TeeChart.Android

TeeChart Programmers Guide

TeeChart.Android Assembly

Requirements

Assembly: TeeChart.Android.dll

Information at Steema

© 2012-2013 Steema Software SL. All rights reserved.


Android.Graphics

Android.Graphics Namespace

Namespace hierarchy

Public Classes

Cursor

Requirements

Namespace: Android.Graphics Namespace

Assembly: TeeChart.Android.dll


Android.Graphics Hierarchy

System.Object

Android.Graphics.Cursor

See Also

AndroidGraphics Namespace


Android.Graphics.Cursor

Android.Graphics.Cursor Class

For a list of all members of this type, see Cursor Members

System.Object
public sealed class Cursor : Object , IDisposable, ISerializable

Requirements

Namespace: Android.Graphics Namespace

Assembly: TeeChart.Android.dll

See Also

Cursor members | Android.Graphics Namespace


Android.Graphics.CursorMembers

Android.Graphics.Cursor all Members

Cursor overview

Constructors

Constructor Overloaded

Public Methods

CopyHandle
Dispose
Draw
DrawStretched
Equals
GetHashCode
Hide
Show
ToString

Public Properties

Clip
Current
Default
Handle
HotSpot
Position
Size
Tag

See Also

Cursor Class | Android.Graphics Namespace


Android.Graphics.Cursor Constructor

Overload List

public Cursor(System.IntPtr)
public Cursor(Android.Media.Stream)
public Cursor(System.String)
public Cursor(System.Type, System.String)

See Also

Cursor Class | Cursor Members | Android.Graphics Namespace


Android.Graphics.Cursor Constructor

public Cursor(Type type,
     String resource)

See Also

Cursor Constructor Overload List | Cursor Class | Cursor Members | Android.Graphics Namespace


Android.Graphics.Cursor Constructor

public Cursor(String fileName)

See Also

Cursor Constructor Overload List | Cursor Class | Cursor Members | Android.Graphics Namespace


Android.Graphics.Cursor Constructor

public Cursor(Stream stream)

See Also

Cursor Constructor Overload List | Cursor Class | Cursor Members | Android.Graphics Namespace


Android.Graphics.Cursor Constructor

public Cursor(IntPtr handle)

See Also

Cursor Constructor Overload List | Cursor Class | Cursor Members | Android.Graphics Namespace


Android.Graphics.CursorMethods

Android.Graphics.Cursor Methods

Public Methods

CopyHandle
Dispose
Draw
DrawStretched
Equals
GetHashCode
Hide
Show
ToString

See Also

Cursor Class | Android.Graphics Namespace


CopyHandle

Android.Graphics.Cursor.CopyHandle Method

public IntPtr CopyHandle()

See Also

Cursor Class | Cursor Members | Android.Graphics Namespace


Dispose

Android.Graphics.Cursor.Dispose Method

public virtual Void Dispose()

See Also

Cursor Class | Cursor Members | Android.Graphics Namespace


Draw

Android.Graphics.Cursor.Draw Method

public Void Draw(Canvas g,
     Rect targetRect)

See Also

Cursor Class | Cursor Members | Android.Graphics Namespace


DrawStretched

Android.Graphics.Cursor.DrawStretched Method

public Void DrawStretched(Canvas g,
     Rect targetRect)

See Also

Cursor Class | Cursor Members | Android.Graphics Namespace


Equals

Android.Graphics.Cursor.Equals Method

public override Boolean Equals(Object obj)

See Also

Cursor Class | Cursor Members | Android.Graphics Namespace


GetHashCode

Android.Graphics.Cursor.GetHashCode Method

public override Int32 GetHashCode()

See Also

Cursor Class | Cursor Members | Android.Graphics Namespace


Hide

Android.Graphics.Cursor.Hide Method

public static Void Hide()

See Also

Cursor Class | Cursor Members | Android.Graphics Namespace


Show

Android.Graphics.Cursor.Show Method

public static Void Show()

See Also

Cursor Class | Cursor Members | Android.Graphics Namespace


ToString

Android.Graphics.Cursor.ToString Method

public override String ToString()

See Also

Cursor Class | Cursor Members | Android.Graphics Namespace


Android.Graphics.CursorProperties

Android.Graphics.Cursor Properties

Public Properties

Clip
Current
Default
Handle
HotSpot
Position
Size
Tag

See Also

Cursor Class | Android.Graphics Namespace


Clip

Android.Graphics.Cursor.Clip Property

public static Rect Clip {get; set;}

See Also

Cursor Class | Cursor Members | Android.Graphics Namespace


Current

Android.Graphics.Cursor.Current Property

public static Cursor Current {get; set;}

See Also

Cursor Class | Cursor Members | Android.Graphics Namespace


Default

Android.Graphics.Cursor.Default Property

public static Cursor Default {get; set;}

See Also

Cursor Class | Cursor Members | Android.Graphics Namespace


Handle

Android.Graphics.Cursor.Handle Property

public IntPtr Handle {get; set;}

See Also

Cursor Class | Cursor Members | Android.Graphics Namespace


HotSpot

Android.Graphics.Cursor.HotSpot Property

public Point HotSpot {get; set;}

See Also

Cursor Class | Cursor Members | Android.Graphics Namespace


Position

Android.Graphics.Cursor.Position Property

public static Point Position {get; set;}

See Also

Cursor Class | Cursor Members | Android.Graphics Namespace


Size

Android.Graphics.Cursor.Size Property

public Size Size {get; set;}

See Also

Cursor Class | Cursor Members | Android.Graphics Namespace


Tag

Android.Graphics.Cursor.Tag Property

public Object Tag {get; set;}

See Also

Cursor Class | Cursor Members | Android.Graphics Namespace


Steema.TeeChart

Steema.TeeChart Namespace

Namespace hierarchy

Public Classes

ScrollModEventArgs | Event arguments class used by AllowScroll chart event.
AxisLabelValueEventArgs | Internal Axis LabelValue EventArgs. See
GetAxisDrawLabelEventArgs |
AxisLabels | Axis Label characteristics
AxisLabelsItems | Custom labels list
AxisLabelItem |
AxisTitle | Axis Title characteristics
Axis | Access to all Axis characteristics
AxisLinePen | Determines the pen used to draw the axis lines
GridPen | Determines the kind of pen used to draw the Grid lines at every Axis Label position.
TicksPen | Determines the kind of Pen used to draw Axis marks along the Axis line.
CustomAxes | Used to access the Custom series List.
DepthAxis | Z plane Axis characteristics
Axes | Access to list of all TChart Axes. Includes Custom and Depth Axes
Chart | Chart contents. See TChart and Web.WebChart for use.
ChartToolTip | Tooltips
TeeChartException | Underlying TeeChart exception class
TeeEvent | Internal use. Underlying Chart event class
TeeMouseEvent | Internal use. Mouse events
Texts | Text message and dialogue constants
SymbolDrawEventArgs |
LegendItems | Specialized List class to hold Legend items of type LegendItem.
LegendItem | The LegendItem class describes characteristics of each item that are placed on the Legend.
LegendSymbol | Legend item symbol characteristics
Legend | Access to all Chart Legend characteristics
LegendTitle |
Page | Chart paging characteristics
Panel | Chart background panel characteristics
TChart |
AllowScrollEventArgs | Event arguments class used by AllowScroll chart event.
SerializeEventArgs | Axis Label EventArgs. See GetAxisLabelEventHandler
GetAxisLabelEventArgs | Axis Label EventArgs. See GetAxisLabelEventHandler
GetNextAxisLabelEventArgs | 'Get Next' Axis Label EventArgs. See GetNextAxisLabelEventHandler
GetAxesChartRectEventArgs |
GetLegendRectEventArgs | Legend Rectangle EventArgs. See GetLegendRectEventHandler
GetLegendTextEventArgs | Legend Text EventArgs. See GetLegendTextEventHandler
GetLegendPosEventArgs | Legend Position EventArgs. See GetLegendPosEventHandler
Title | Underlying Title characteristics
Header | Text displayed above Chart
Footer | Text displayed below Chart
Utils | Chart utility procedures
Wall | Characteristics of Wall Panel that complements an Axis
Walls | Access to Wall and overall Wall display characteristics
LeftWall | Wall Panel at left of Chart
RightWall | Wall Panel at right of Chart
BackWall | Wall Panel at rear of Chart
BottomWall | Wall Panel at bottom of Chart
ZoomScroll | Internal use. Zoom and scroll support
Scroll | Chart mouse scroll characteristics
Zoom | Used at tChart1.Zoom property, determines mouse zoom attributes.

Public Delegates

GetAxisDrawLabelEventHandler |
DrawAxisEventDelegate |
AxisLabelValueDelegate |
AxisCalcPosLabelsEventHandler |
AxisCalcPosValueDelegate |
AxisCalcPosPointDelegate |
PaintChartEventHandler | Chart Paint Event Handler
SymbolDrawEventHandler |
SeriesEventHandler | Common Series event handler
AllowScrollEventHandler | Scroll event handler
GetAxisLabelEventHandler | AxisLabel event handler
GetNextAxisLabelEventHandler | GetNextAxisLabel event handler
GetLegendRectEventHandler | GetLegendRect event handler
GetLegendPosEventHandler | GetLegendPos event handler
GetLegendTextEventHandler | GetLegendText event handler
ScrollModHandler | Scroll event handler
SerializeEventHandler | Serialize Type event handler
GetAxesChartRectEventHandler |
CompareEventHandler | Internal use. Sort event handler
SwapEventHandler | Internal use. Sort event handler

Public Enumerations

AxisLabelAlign | Sets position of Labels on an Axis.
AxisLabelStyle | Defines the possible values of the Style Axis.Labels.Style property
PositionUnits | PositionUnits specifies PositionUnits Axis.Labels.PositionUnits property as percentage or pixels.
ChartClickedPartStyle |
MouseEventKinds | Type of Mouse action
LegendSymbolPosition | Describes the position of the Legend's color rectangles.
LegendSymbolSize | Describes the units in which to define the size of the Legend's color rectangles.
LegendStyles | Describes the possible values of the LegendStyle property.
LegendTextStyles | Describes the possible values of the TextStyle property.
LegendAlignments | Describes the possible values of the Alignment property
PanelMarginUnits | Describes the possible values of the MarginUnits property
DateTimeSteps | Describes a number of different DateTime steps.
ScrollModes | Describes the possible values of the Allow property.
ZoomDirections | Describes the possible values of the Direction property.
ZoomStyles | Describes the possible values of the Style property.

Public Structures

ChartClickedPart
ZoomSnapshot

Public Interfaces

IChart | Common Chart characteristics interface
ITeeEventListener | Interface supports inter-Component communication

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll


Steema.TeeChart Hierarchy

System.Object

Java.Lang.Object

Android.Views.View

Android.Views.ViewGroup

Android.Widget.FrameLayout

Steema.TeeChart.TChart

Steema.TeeChart.Chart.ChartToolTip

Steema.TeeChart.Drawing.TeeBase

Steema.TeeChart.Axes

Steema.TeeChart.Axis

Steema.TeeChart.DepthAxis

Steema.TeeChart.Chart

Steema.TeeChart.Drawing.ChartPen

Steema.TeeChart.Axis.AxisLinePen

Steema.TeeChart.Axis.GridPen

Steema.TeeChart.Axis.TicksPen

Steema.TeeChart.Drawing.Shape

Steema.TeeChart.Drawing.TextShape

Steema.TeeChart.AxisLabelItem

Steema.TeeChart.AxisLabels

Steema.TeeChart.AxisTitle

Steema.TeeChart.Drawing.TextShapePosition

Steema.TeeChart.Legend

Steema.TeeChart.Title

Steema.TeeChart.Footer

Steema.TeeChart.Header

Steema.TeeChart.LegendTitle

Steema.TeeChart.Panel

Steema.TeeChart.Wall

Steema.TeeChart.Walls.BackWall

Steema.TeeChart.Walls.BottomWall

Steema.TeeChart.Walls.LeftWall

Steema.TeeChart.Walls.RightWall

Steema.TeeChart.LegendItem

Steema.TeeChart.LegendSymbol

Steema.TeeChart.Page

Steema.TeeChart.Walls

Steema.TeeChart.ZoomScroll

Steema.TeeChart.Scroll

Steema.TeeChart.Zoom

Steema.TeeChart.TeeEvent

Steema.TeeChart.TeeMouseEvent

Steema.TeeChart.Texts

Steema.TeeChart.Utils

System.Collections.ArrayList

Steema.TeeChart.AxisLabelsItems

System.Collections.CollectionBase

Steema.TeeChart.CustomAxes

System.Collections.Generic.List

Steema.TeeChart.LegendItems

System.EventArgs

Steema.TeeChart.AxisLabelValueEventArgs

Steema.TeeChart.GetAxesChartRectEventArgs

Steema.TeeChart.GetAxisDrawLabelEventArgs

Steema.TeeChart.GetAxisLabelEventArgs

Steema.TeeChart.GetLegendPosEventArgs

Steema.TeeChart.GetLegendRectEventArgs

Steema.TeeChart.GetLegendTextEventArgs

Steema.TeeChart.GetNextAxisLabelEventArgs

Steema.TeeChart.ScrollModEventArgs

Steema.TeeChart.SerializeEventArgs

Steema.TeeChart.SymbolDrawEventArgs

Steema.TeeChart.TChart.AllowScrollEventArgs

System.Exception

Steema.TeeChart.TeeChartException

See Also

SteemaTeeChart Namespace


Steema.TeeChart.Axes

Steema.TeeChart.Axes Class

Access to list of all TChart Axes. Includes Custom and Depth Axes

For a list of all members of this type, see Axes Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class Axes : TeeBase

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Axes members | Steema.TeeChart Namespace


Steema.TeeChart.AxesMembers

Steema.TeeChart.Axes all Members

Axes overview

Constructors

Constructor

Public Fields

NumFixedAxes

Public Methods

CreateNewAxis |
Draw |
IndexOf |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
StringItems |

Public Properties

Bottom | Bottom Axis.
Chart (inherited from TeeBase) | Chart associated with this object
Count | Returns the number of custom axes.
Custom | Custom defined axes collection.
Depth | Depth Axis.
DepthTop | DepthTop Axis.
DrawBehind | Draw axes behind or in front of Series.
Item | Access to indexed Axis
Left | Left Axis.
Right | Right Axis.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top | Top Axis.
Visible | Shows / Hides all Chart axes.

See Also

Axes Class | Steema.TeeChart Namespace


Steema.TeeChart.Axes Constructor

public Axes(Chart c)

See Also

Axes Class | Axes Members | Steema.TeeChart Namespace


Steema.TeeChart.AxesFields

Steema.TeeChart.Axes Fields

Public Fields

NumFixedAxes

See Also

Axes Class | Steema.TeeChart Namespace


NumFixedAxes

Steema.TeeChart.Axes.NumFixedAxes Field

public Int32 NumFixedAxes

See Also

Axes Class | Axes Members | Steema.TeeChart Namespace


Steema.TeeChart.AxesMethods

Steema.TeeChart.Axes Methods

Public Methods

CreateNewAxis |
Draw |
IndexOf |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
StringItems |

See Also

Axes Class | Steema.TeeChart Namespace


CreateNewAxis

Steema.TeeChart.Axes.CreateNewAxis Method

public static Axis CreateNewAxis(Chart chart)

See Also

Axes Class | Axes Members | Steema.TeeChart Namespace


Draw

Steema.TeeChart.Axes.Draw Method

Overload List

public Void Draw()
public Void Draw(Steema.TeeChart.Drawing.Graphics3D)

See Also

Axes Class | Axes Members | Steema.TeeChart Namespace


Draw

Steema.TeeChart.Axes.Draw Method

public Void Draw(Graphics3D g)

See Also

Draw Overload List | Axes Class | Axes Members | Steema.TeeChart Namespace


Draw

Steema.TeeChart.Axes.Draw Method

public Void Draw()

See Also

Draw Overload List | Axes Class | Axes Members | Steema.TeeChart Namespace


IndexOf

Steema.TeeChart.Axes.IndexOf Method

public Int32 IndexOf(Axis a)

See Also

Axes Class | Axes Members | Steema.TeeChart Namespace


StringItems

Steema.TeeChart.Axes.StringItems Method

public String[] StringItems()

See Also

Axes Class | Axes Members | Steema.TeeChart Namespace


Steema.TeeChart.AxesProperties

Steema.TeeChart.Axes Properties

Public Properties

Bottom | Bottom Axis.
Chart (inherited from TeeBase) | Chart associated with this object
Count | Returns the number of custom axes.
Custom | Custom defined axes collection.
Depth | Depth Axis.
DepthTop | DepthTop Axis.
DrawBehind | Draw axes behind or in front of Series.
Item | Access to indexed Axis
Left | Left Axis.
Right | Right Axis.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top | Top Axis.
Visible | Shows / Hides all Chart axes.

See Also

Axes Class | Steema.TeeChart Namespace


Bottom

Steema.TeeChart.Axes.Bottom Property

Bottom Axis.
public Axis Bottom {get;}

See Also

Axes Class | Axes Members | Steema.TeeChart Namespace


Count

Steema.TeeChart.Axes.Count Property

Returns the number of custom axes.
public Int32 Count {get;}

See Also

Axes Class | Axes Members | Steema.TeeChart Namespace


Custom

Steema.TeeChart.Axes.Custom Property

Custom defined axes collection.
public CustomAxes Custom {get;}

See Also

Axes Class | Axes Members | Steema.TeeChart Namespace


Depth

Steema.TeeChart.Axes.Depth Property

Depth Axis.
public DepthAxis Depth {get;}

See Also

Axes Class | Axes Members | Steema.TeeChart Namespace


DepthTop

Steema.TeeChart.Axes.DepthTop Property

DepthTop Axis.
public DepthAxis DepthTop {get;}

See Also

Axes Class | Axes Members | Steema.TeeChart Namespace


DrawBehind

Steema.TeeChart.Axes.DrawBehind Property

Draw axes behind or in front of Series.
public Boolean DrawBehind {get; set;}

See Also

Axes Class | Axes Members | Steema.TeeChart Namespace


Item

Steema.TeeChart.Axes.Item Property

Access to indexed Axis
public Axis Item(Int32 index) {get;}

See Also

Axes Class | Axes Members | Steema.TeeChart Namespace


Left

Steema.TeeChart.Axes.Left Property

Left Axis.
public Axis Left {get;}

See Also

Axes Class | Axes Members | Steema.TeeChart Namespace


Right

Steema.TeeChart.Axes.Right Property

Right Axis.
public Axis Right {get;}

See Also

Axes Class | Axes Members | Steema.TeeChart Namespace


Top

Steema.TeeChart.Axes.Top Property

Top Axis.
public Axis Top {get;}

See Also

Axes Class | Axes Members | Steema.TeeChart Namespace


Visible

Steema.TeeChart.Axes.Visible Property

Shows / Hides all Chart axes.
public Boolean Visible {get; set;}

See Also

Axes Class | Axes Members | Steema.TeeChart Namespace


Steema.TeeChart.Axis

Steema.TeeChart.Axis Class

Access to all Axis characteristics

For a list of all members of this type, see Axis Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class Axis : TeeBase , ICloneable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Axis members | Steema.TeeChart Namespace


Steema.TeeChart.AxisMembers

Steema.TeeChart.Axis all Members

Axis overview

Constructors

Constructor Overloaded

Public Events

GetAxisDrawLabel

Public Fields

AxisClickGap
IAxisSize
IEndPos
IGapSize
IsDepthAxis
IStartPos

Public Methods

AdjustMaxMin | Calculates Maximum and Minimum values based on Max and Min values of the dependent Series.
AdjustMaxMinRect | Called internally to recalculate the max and min values using the Rect parameter positions.
AxisRect |
CalcLabelStyle | Returns the most logical Axis Label style.
CalcMinMax | Returns the minimum and maximum values of the associated Series.
CalcSizeValue | Returns the amount in pixels of a portion of the axis of size "Value" in axis scales.
CalcXYIncrement | Returns the calculated Axis Label increment.
Clicked | Returns if X and Y coordinates are close to the Axis position.
Clone |
DateTimeDefaultFormat | Returns a Time or Date format depending if the astep parameter is lower than one day (time) or greater (date).
DateTimeIncrement | Is a set of constants used to specify a date time increment.
Draw | Displays an Axis at the specified screen positions with the current axis scales.
DrawAxisLabel | Draws Axis Label (string) at specified X,Y co-ordinate at Angle.
DrawTitle | TeeChart internal use. Outputs the title during the chart painting procedure.
FindDateTimeStep | Internal use. Returns Axis Datetime step.
InternalCalcPosPoint | Returns the corresponding value of a Screen position.
InternalCalcRange | Internal use.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsCustom | Returns true if Axis is a Custom Axis
MaxLabelsWidth | Returns the maximum width in pixels of all Axis Labels.
Scroll | Dispaces Axis Minimum and Maximum values.
SetCalcPosValue | Advanced use. Requests the Axis to re-check assigned calculation methods
SetMinMax | Changes the Axis Minimum and Maximum scales.
TitleOrName |

Public Properties

Automatic | Calculates Max and Min of axis scale based on associated Series.
AutomaticMaximum | Controls maximum value automatically based on the maximum value of its associated Series.
AutomaticMinimum | Controls minimum value automatically based on the minimum value of its associated Series.
AxisPen | Determines the kind of pen used to draw the Axes.
CalcIncrement | Returns the calculated Axis Label increment.
Chart (inherited from TeeBase) | Chart associated with this object
EndPosition | Axis End position as percentage of Chart.
Grid | Determines the pen used to draw the Chart Grid.
GridCentered |
Horizontal | Sets a custom axis to be drawn horizontally.
Increment | Is the minimum step between axis labels. Can use DateTimeSteps for date-time axis.
IncrementOffset | The offset applied to the Increment property. If Increment is 10 and IncrementOffset is 5, axis labels drawn (5, 15, 25 etc.).
Inverted | Swaps the Axis Minimum and Maximum scales.
IsDateTime | An axis is "DateTime" if at least one Active Series with datetime values is associated to it
Labels | Accesses the Label characteristics of Axis Labels.
LabelsOnAxis |
Logarithmic | Scales the Axis Logarithmically when True.
LogarithmicBase | Sets the base for the Logarithmic scale when Axis Logarithmic = True.
Maximum | Sets Axis Maximum value.
MaximumOffset | The amount of pixels that will be left as a margin at axis maximum position.
MaximumRound | Rounds Axis Maximum to nearest Integer value.
MaxXValue | Maximum X value for the specified Axis.
MaxYValue | Maximum Y value for the specified Axis.
MinAxisIncrement | Advanced use. Smallest Axis calculation increment. Default: 1e-12
Minimum | Sets Axis Minimum value.
MinimumOffset | Pixels separation at axis minimum.
MinimumRound | Rounds Axis Minimum to nearest Integer value.
MinorGrid | Sets characteristics of the Grid coincidental to Minor Ticks.
MinorTickCount | Determines the number of Axis minor ticks between major ticks.
MinorTicks | Determines the Pen used to draw the Axis Minor ticks.
MinXValue | Minimum X value for the specified Axis.
MinYValue | Minimum Y value for the specified Axis.
OtherSide | Sets the Axis to Otherside (Left or Right, Top or Bottom)
PartnerAxis | Use this property when UsePartnerAxis is set to True to define an Axis pair whose bounding rectangle will limit the plotted Gridilines for either Axis. It is possible to have a one sided partnership where only one of the two Axes limits its Gridline plot.
PosAxis | Please use Position property.
Position | Sets the screen co-ordinate where axis is drawn.
PositionUnits | Defines Position units (pixels or percentage) for the RelativePosition property.
RelativePosition | Axis position relative to Chart.
StartEndPositionUnits | Defines Position units (pixels or percentage) for the StartPosition and EndPosition properties.
StartPosition | Axis Start position as percentage of Chart.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickOnLabelsOnly | Sets the Axis Ticks and Axis Grid to be drawn at Labels only.
Ticks | Determines the Pen used to draw Axis marks along the Axis line.
TicksInner | Determines the Pen used to draw Axis marks inside the Axis line.
Title | Title attributes
TitleSize |
UsePartnerAxis | When True and PartnerAxis is set to the value of a valid Axis, Axis GridlInes will zone to the bounding rectangle of the two Partner Axes. It is possible to have a one sided partnership where only one of the two Axes limits its Gridline plot.
Visible | Shows or hides all the five Chart Axes at once.
ZoomLimitToAxisBounds | When true, zooms associated to this axis will not exceed the standard axis scale. This can be useful for multi axis charts to avoid a zoom on a neighbouring axis sending the associated contents of this Axis out of bounds.
ZPosition | Determines the Z axis position along chart Depth

See Also

Axis Class | Steema.TeeChart Namespace


Steema.TeeChart.Axis Constructor

Overload List

public Axis()
public Axis(Steema.TeeChart.Chart)
public Axis(System.Boolean, System.Boolean, Steema.TeeChart.Chart)
public Axis(System.ComponentModel.IContainer)

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


Steema.TeeChart.Axis Constructor

public Axis(IContainer container)

See Also

Axis Constructor Overload List | Axis Class | Axis Members | Steema.TeeChart Namespace


Steema.TeeChart.Axis Constructor

public Axis(Boolean horiz,
     Boolean isOtherSide,
     Chart c)

See Also

Axis Constructor Overload List | Axis Class | Axis Members | Steema.TeeChart Namespace


Steema.TeeChart.Axis Constructor

public Axis(Chart c)

See Also

Axis Constructor Overload List | Axis Class | Axis Members | Steema.TeeChart Namespace


Steema.TeeChart.Axis Constructor

public Axis()

See Also

Axis Constructor Overload List | Axis Class | Axis Members | Steema.TeeChart Namespace


Steema.TeeChart.AxisEvents

Steema.TeeChart.Axis Events

Public Events

GetAxisDrawLabel

See Also

Axis Class | Steema.TeeChart Namespace


GetAxisDrawLabel

Steema.TeeChart.Axis.GetAxisDrawLabel Event

public GetAxisDrawLabelEventHandler  GetAxisDrawLabel

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


Steema.TeeChart.AxisFields

Steema.TeeChart.Axis Fields

Public Fields

AxisClickGap
IAxisSize
IEndPos
IGapSize
IsDepthAxis
IStartPos

See Also

Axis Class | Steema.TeeChart Namespace


AxisClickGap

Steema.TeeChart.Axis.AxisClickGap Field

public Int32 AxisClickGap

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


IAxisSize

Steema.TeeChart.Axis.IAxisSize Field

public Int32 IAxisSize

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


IEndPos

Steema.TeeChart.Axis.IEndPos Field

public Int32 IEndPos

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


IGapSize

Steema.TeeChart.Axis.IGapSize Field

public Int32 IGapSize

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


IsDepthAxis

Steema.TeeChart.Axis.IsDepthAxis Field

public Boolean IsDepthAxis

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


IStartPos

Steema.TeeChart.Axis.IStartPos Field

public Int32 IStartPos

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


Steema.TeeChart.AxisMethods

Steema.TeeChart.Axis Methods

Public Methods

AdjustMaxMin | Calculates Maximum and Minimum values based on Max and Min values of the dependent Series.
AdjustMaxMinRect | Called internally to recalculate the max and min values using the Rect parameter positions.
AxisRect |
CalcLabelStyle | Returns the most logical Axis Label style.
CalcMinMax | Returns the minimum and maximum values of the associated Series.
CalcSizeValue | Returns the amount in pixels of a portion of the axis of size "Value" in axis scales.
CalcXYIncrement | Returns the calculated Axis Label increment.
Clicked | Returns if X and Y coordinates are close to the Axis position.
Clone |
DateTimeDefaultFormat | Returns a Time or Date format depending if the astep parameter is lower than one day (time) or greater (date).
DateTimeIncrement | Is a set of constants used to specify a date time increment.
Draw | Displays an Axis at the specified screen positions with the current axis scales.
DrawAxisLabel | Draws Axis Label (string) at specified X,Y co-ordinate at Angle.
DrawTitle | TeeChart internal use. Outputs the title during the chart painting procedure.
FindDateTimeStep | Internal use. Returns Axis Datetime step.
InternalCalcPosPoint | Returns the corresponding value of a Screen position.
InternalCalcRange | Internal use.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsCustom | Returns true if Axis is a Custom Axis
MaxLabelsWidth | Returns the maximum width in pixels of all Axis Labels.
Scroll | Dispaces Axis Minimum and Maximum values.
SetCalcPosValue | Advanced use. Requests the Axis to re-check assigned calculation methods
SetMinMax | Changes the Axis Minimum and Maximum scales.
TitleOrName |

See Also

Axis Class | Steema.TeeChart Namespace


AdjustMaxMin

Steema.TeeChart.Axis.AdjustMaxMin Method

Calculates Maximum and Minimum values based on Max and Min values of the dependent Series.
public Void AdjustMaxMin()

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


AdjustMaxMinRect

Steema.TeeChart.Axis.AdjustMaxMinRect Method

Overload List

Called internally to recalculate the max and min values using the Rect parameter positions.

public Void AdjustMaxMinRect(System.Drawing.Rectangle)

Called internally to recalculate the max and min values using the Rect parameter positions.

public Void AdjustMaxMinRect(System.Int32, System.Int32, System.Int32, System.Int32)

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


AdjustMaxMinRect

Steema.TeeChart.Axis.AdjustMaxMinRect Method

Called internally to recalculate the max and min values using the Rect parameter positions.
public Void AdjustMaxMinRect(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

See Also

AdjustMaxMinRect Overload List | Axis Class | Axis Members | Steema.TeeChart Namespace


AdjustMaxMinRect

Steema.TeeChart.Axis.AdjustMaxMinRect Method

Called internally to recalculate the max and min values using the Rect parameter positions.
public Void AdjustMaxMinRect(Rectangle rect)

See Also

AdjustMaxMinRect Overload List | Axis Class | Axis Members | Steema.TeeChart Namespace


AxisRect

Steema.TeeChart.Axis.AxisRect Method

public Rectangle AxisRect()

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


CalcLabelStyle

Steema.TeeChart.Axis.CalcLabelStyle Method

Returns the most logical Axis Label style.
public AxisLabelStyle CalcLabelStyle()

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


CalcMinMax

Steema.TeeChart.Axis.CalcMinMax Method

Returns the minimum and maximum values of the associated Series.
public Void CalcMinMax(Double& min,
     Double& max)

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


CalcSizeValue

Steema.TeeChart.Axis.CalcSizeValue Method

Returns the amount in pixels of a portion of the axis of size "Value" in axis scales.
public Int32 CalcSizeValue(Double value)

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


CalcXYIncrement

Steema.TeeChart.Axis.CalcXYIncrement Method

Returns the calculated Axis Label increment.
public Double CalcXYIncrement(Int32 maxLabelSize)

Parameters

maxLabelSize
The maximum allowable LabelSize in pixels.

Return Value

Size of increment in Axis units.

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


Clicked

Steema.TeeChart.Axis.Clicked Method

Overload List

Returns if X and Y coordinates are close to the Axis position.

public Boolean Clicked(System.Drawing.Point)

Returns if X and Y coordinates are close to the Axis position.

public Boolean Clicked(System.Int32, System.Int32)

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


Clicked

Steema.TeeChart.Axis.Clicked Method

Returns if X and Y coordinates are close to the Axis position.
public Boolean Clicked(Int32 x,
     Int32 y)

Parameters

x
x Pixel location
y
y Pixel location

Return Value

True if x,y location on or near to Axis

See Also

Clicked Overload List | Axis Class | Axis Members | Steema.TeeChart Namespace


Clicked

Steema.TeeChart.Axis.Clicked Method

Returns if X and Y coordinates are close to the Axis position.
public Boolean Clicked(Point xy)

Parameters

xy
X and Y coordinates

Return Value

X and Y coordinates as integer

See Also

Clicked Overload List | Axis Class | Axis Members | Steema.TeeChart Namespace


Clone

Steema.TeeChart.Axis.Clone Method

public virtual Object Clone()

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


DateTimeDefaultFormat

Steema.TeeChart.Axis.DateTimeDefaultFormat Method

Returns a Time or Date format depending if the astep parameter is lower than one day (time) or greater (date).
public String DateTimeDefaultFormat(Double astep)

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


DateTimeIncrement

Steema.TeeChart.Axis.DateTimeIncrement Method

Is a set of constants used to specify a date time increment.
public Void DateTimeIncrement(Boolean isDateTime,
     Boolean increment,
     Double& value,
     Double anIncrement,
     DateTimeSteps tmpWhichDatetime)

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


Draw

Steema.TeeChart.Axis.Draw Method

Overload List

Displays an Axis at the specified screen positions with the current axis scales.

public Void Draw(System.Boolean)

Displays an Axis at the specified screen positions with the current axis scales.

public Void Draw(System.Int32, System.Int32, System.Int32, System.Boolean, System.Int32, System.Int32)

Displays an Axis at the specified screen positions with the current axis scales.

public Void Draw(System.Int32, System.Int32, System.Int32, System.Boolean)

Displays an Axis at the specified screen positions with the current axis scales.

public Void Draw(System.Int32, System.Int32, System.Int32, System.Boolean, System.Double, System.Double, System.Int32, System.Int32)

Displays an Axis at the specified screen positions with the current axis scales.

public Void Draw(System.Int32, System.Int32, System.Int32, System.Boolean, System.Double, System.Double, System.Double, System.Int32, System.Int32)

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


Draw

Steema.TeeChart.Axis.Draw Method

Displays an Axis at the specified screen positions with the current axis scales.
public Void Draw(Int32 posLabels,
     Int32 posTitle,
     Int32 posAxis,
     Boolean gridVisible,
     Double aMinimum,
     Double aMaximum,
     Double aIncrement,
     Int32 aStartPos,
     Int32 aEndPos)

See Also

Draw Overload List | Axis Class | Axis Members | Steema.TeeChart Namespace


Draw

Steema.TeeChart.Axis.Draw Method

Displays an Axis at the specified screen positions with the current axis scales.
public Void Draw(Int32 posLabels,
     Int32 posTitle,
     Int32 posAxis,
     Boolean gridVisible,
     Double aMinimum,
     Double aMaximum,
     Int32 aStartPosition,
     Int32 aEndPosition)

See Also

Draw Overload List | Axis Class | Axis Members | Steema.TeeChart Namespace


Draw

Steema.TeeChart.Axis.Draw Method

Displays an Axis at the specified screen positions with the current axis scales.
public Void Draw(Int32 posLabels,
     Int32 posTitle,
     Int32 posAxis,
     Boolean gridVisible)

See Also

Draw Overload List | Axis Class | Axis Members | Steema.TeeChart Namespace


Draw

Steema.TeeChart.Axis.Draw Method

Displays an Axis at the specified screen positions with the current axis scales.
public Void Draw(Int32 posLabels,
     Int32 posTitle,
     Int32 posAxis,
     Boolean gridVisible,
     Int32 aStartPos,
     Int32 aEndPos)

See Also

Draw Overload List | Axis Class | Axis Members | Steema.TeeChart Namespace


Draw

Steema.TeeChart.Axis.Draw Method

Displays an Axis at the specified screen positions with the current axis scales.
public Void Draw(Boolean calcPosAxis)

Parameters

calcPosAxis
True if space allowance for Axis Labelling required.

See Also

Draw Overload List | Axis Class | Axis Members | Steema.TeeChart Namespace


DrawAxisLabel

Steema.TeeChart.Axis.DrawAxisLabel Method

Overload List

Draws Axis Label (string) at specified X,Y co-ordinate at Angle.

public Void DrawAxisLabel(System.Int32, System.Int32, System.Int32, System.String, Steema.TeeChart.Drawing.TextShape)
public Void DrawAxisLabel(Steema.TeeChart.Drawing.ChartFont, System.Int32, System.Int32, System.Int32, System.String, Steema.TeeChart.Drawing.TextShape)

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


DrawAxisLabel

Steema.TeeChart.Axis.DrawAxisLabel Method

public Void DrawAxisLabel(ChartFont f,
     Int32 x,
     Int32 y,
     Int32 angle,
     String st,
     TextShape format)

See Also

DrawAxisLabel Overload List | Axis Class | Axis Members | Steema.TeeChart Namespace


DrawAxisLabel

Steema.TeeChart.Axis.DrawAxisLabel Method

Draws Axis Label (string) at specified X,Y co-ordinate at Angle.
public Void DrawAxisLabel(Int32 x,
     Int32 y,
     Int32 angle,
     String st,
     TextShape labelItem)

See Also

DrawAxisLabel Overload List | Axis Class | Axis Members | Steema.TeeChart Namespace


DrawTitle

Steema.TeeChart.Axis.DrawTitle Method

TeeChart internal use. Outputs the title during the chart painting procedure.
public Void DrawTitle(Int32 x,
     Int32 y)

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


FindDateTimeStep

Steema.TeeChart.Axis.FindDateTimeStep Method

Internal use. Returns Axis Datetime step.
public static DateTimeSteps FindDateTimeStep(Double stepValue)

Parameters

stepValue
Desired Increment

Return Value

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


InternalCalcPosPoint

Steema.TeeChart.Axis.InternalCalcPosPoint Method

Returns the corresponding value of a Screen position.
public Double InternalCalcPosPoint(Int32 value)

Parameters

value
Screen value

Return Value

Position on screen in pixels

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


InternalCalcRange

Steema.TeeChart.Axis.InternalCalcRange Method

Internal use.
public Void InternalCalcRange()

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


IsCustom

Steema.TeeChart.Axis.IsCustom Method

Returns true if Axis is a Custom Axis
public Boolean IsCustom()

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


MaxLabelsWidth

Steema.TeeChart.Axis.MaxLabelsWidth Method

Returns the maximum width in pixels of all Axis Labels.
public Int32 MaxLabelsWidth()

Return Value

Maximum width in pixels

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


Scroll

Steema.TeeChart.Axis.Scroll Method

Dispaces Axis Minimum and Maximum values.
public Void Scroll(Double offset,
     Boolean checkLimits)

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


SetCalcPosValue

Steema.TeeChart.Axis.SetCalcPosValue Method

Advanced use. Requests the Axis to re-check assigned calculation methods
public Void SetCalcPosValue()

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


SetMinMax

Steema.TeeChart.Axis.SetMinMax Method

Overload List

Changes the Axis Minimum and Maximum scales.

public Void SetMinMax(System.DateTime, System.DateTime)

Changes the Axis Minimum and Maximum scales.

public Void SetMinMax(System.Double, System.Double)

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


SetMinMax

Steema.TeeChart.Axis.SetMinMax Method

Changes the Axis Minimum and Maximum scales.
public Void SetMinMax(Double min,
     Double max)

Parameters

min
Axis Minimum scale
max
Axis Maximum scale

See Also

SetMinMax Overload List | Axis Class | Axis Members | Steema.TeeChart Namespace


SetMinMax

Steema.TeeChart.Axis.SetMinMax Method

Changes the Axis Minimum and Maximum scales.
public Void SetMinMax(DateTime minDate,
     DateTime maxDate)

Parameters

minDate
Axis Minimum scale
maxDate
Axis Maximum scale

See Also

SetMinMax Overload List | Axis Class | Axis Members | Steema.TeeChart Namespace


TitleOrName

Steema.TeeChart.Axis.TitleOrName Method

public String TitleOrName()

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


Steema.TeeChart.AxisProperties

Steema.TeeChart.Axis Properties

Public Properties

Automatic | Calculates Max and Min of axis scale based on associated Series.
AutomaticMaximum | Controls maximum value automatically based on the maximum value of its associated Series.
AutomaticMinimum | Controls minimum value automatically based on the minimum value of its associated Series.
AxisPen | Determines the kind of pen used to draw the Axes.
CalcIncrement | Returns the calculated Axis Label increment.
Chart (inherited from TeeBase) | Chart associated with this object
EndPosition | Axis End position as percentage of Chart.
Grid | Determines the pen used to draw the Chart Grid.
GridCentered |
Horizontal | Sets a custom axis to be drawn horizontally.
Increment | Is the minimum step between axis labels. Can use DateTimeSteps for date-time axis.
IncrementOffset | The offset applied to the Increment property. If Increment is 10 and IncrementOffset is 5, axis labels drawn (5, 15, 25 etc.).
Inverted | Swaps the Axis Minimum and Maximum scales.
IsDateTime | An axis is "DateTime" if at least one Active Series with datetime values is associated to it
Labels | Accesses the Label characteristics of Axis Labels.
LabelsOnAxis |
Logarithmic | Scales the Axis Logarithmically when True.
LogarithmicBase | Sets the base for the Logarithmic scale when Axis Logarithmic = True.
Maximum | Sets Axis Maximum value.
MaximumOffset | The amount of pixels that will be left as a margin at axis maximum position.
MaximumRound | Rounds Axis Maximum to nearest Integer value.
MaxXValue | Maximum X value for the specified Axis.
MaxYValue | Maximum Y value for the specified Axis.
MinAxisIncrement | Advanced use. Smallest Axis calculation increment. Default: 1e-12
Minimum | Sets Axis Minimum value.
MinimumOffset | Pixels separation at axis minimum.
MinimumRound | Rounds Axis Minimum to nearest Integer value.
MinorGrid | Sets characteristics of the Grid coincidental to Minor Ticks.
MinorTickCount | Determines the number of Axis minor ticks between major ticks.
MinorTicks | Determines the Pen used to draw the Axis Minor ticks.
MinXValue | Minimum X value for the specified Axis.
MinYValue | Minimum Y value for the specified Axis.
OtherSide | Sets the Axis to Otherside (Left or Right, Top or Bottom)
PartnerAxis | Use this property when UsePartnerAxis is set to True to define an Axis pair whose bounding rectangle will limit the plotted Gridilines for either Axis. It is possible to have a one sided partnership where only one of the two Axes limits its Gridline plot.
PosAxis | Please use Position property.
Position | Sets the screen co-ordinate where axis is drawn.
PositionUnits | Defines Position units (pixels or percentage) for the RelativePosition property.
RelativePosition | Axis position relative to Chart.
StartEndPositionUnits | Defines Position units (pixels or percentage) for the StartPosition and EndPosition properties.
StartPosition | Axis Start position as percentage of Chart.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickOnLabelsOnly | Sets the Axis Ticks and Axis Grid to be drawn at Labels only.
Ticks | Determines the Pen used to draw Axis marks along the Axis line.
TicksInner | Determines the Pen used to draw Axis marks inside the Axis line.
Title | Title attributes
TitleSize |
UsePartnerAxis | When True and PartnerAxis is set to the value of a valid Axis, Axis GridlInes will zone to the bounding rectangle of the two Partner Axes. It is possible to have a one sided partnership where only one of the two Axes limits its Gridline plot.
Visible | Shows or hides all the five Chart Axes at once.
ZoomLimitToAxisBounds | When true, zooms associated to this axis will not exceed the standard axis scale. This can be useful for multi axis charts to avoid a zoom on a neighbouring axis sending the associated contents of this Axis out of bounds.
ZPosition | Determines the Z axis position along chart Depth

See Also

Axis Class | Steema.TeeChart Namespace


Automatic

Steema.TeeChart.Axis.Automatic Property

Calculates Max and Min of axis scale based on associated Series.
public Boolean Automatic {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


AutomaticMaximum

Steema.TeeChart.Axis.AutomaticMaximum Property

Controls maximum value automatically based on the maximum value of its associated Series.
public Boolean AutomaticMaximum {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


AutomaticMinimum

Steema.TeeChart.Axis.AutomaticMinimum Property

Controls minimum value automatically based on the minimum value of its associated Series.
public Boolean AutomaticMinimum {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


AxisPen

Steema.TeeChart.Axis.AxisPen Property

Determines the kind of pen used to draw the Axes.
public AxisLinePen AxisPen {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


CalcIncrement

Steema.TeeChart.Axis.CalcIncrement Property

Returns the calculated Axis Label increment.
public Double CalcIncrement {get;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


EndPosition

Steema.TeeChart.Axis.EndPosition Property

Axis End position as percentage of Chart.
public Double EndPosition {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


Grid

Steema.TeeChart.Axis.Grid Property

Determines the pen used to draw the Chart Grid.
public GridPen Grid {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


GridCentered

Steema.TeeChart.Axis.GridCentered Property

public Boolean GridCentered {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


Horizontal

Steema.TeeChart.Axis.Horizontal Property

Sets a custom axis to be drawn horizontally.
public Boolean Horizontal {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


Increment

Steema.TeeChart.Axis.Increment Property

Is the minimum step between axis labels. Can use DateTimeSteps for date-time axis.
public Double Increment {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


IncrementOffset

Steema.TeeChart.Axis.IncrementOffset Property

The offset applied to the Increment property. If Increment is 10 and IncrementOffset is 5, axis labels drawn (5, 15, 25 etc.).
public Double IncrementOffset {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


Inverted

Steema.TeeChart.Axis.Inverted Property

Swaps the Axis Minimum and Maximum scales.
public Boolean Inverted {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


IsDateTime

Steema.TeeChart.Axis.IsDateTime Property

An axis is "DateTime" if at least one Active Series with datetime values is associated to it
public Boolean IsDateTime {get;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


Labels

Steema.TeeChart.Axis.Labels Property

Accesses the Label characteristics of Axis Labels.
public AxisLabels Labels {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


OnAxis

Steema.TeeChart.AxisLabels.OnAxis Property

Controls whether the Labels at Axis Minimum and Maximum positions will be shown or not.
public Boolean OnAxis {get; set;}

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


Logarithmic

Steema.TeeChart.Axis.Logarithmic Property

Scales the Axis Logarithmically when True.
public Boolean Logarithmic {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


LogarithmicBase

Steema.TeeChart.Axis.LogarithmicBase Property

Sets the base for the Logarithmic scale when Axis Logarithmic = True.
public Double LogarithmicBase {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


Maximum

Steema.TeeChart.Axis.Maximum Property

Sets Axis Maximum value.
public Double Maximum {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


MaximumOffset

Steema.TeeChart.Axis.MaximumOffset Property

The amount of pixels that will be left as a margin at axis maximum position.
public Int32 MaximumOffset {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


MaximumRound

Steema.TeeChart.Axis.MaximumRound Property

Rounds Axis Maximum to nearest Integer value.
public Boolean MaximumRound {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


MaxXValue

Steema.TeeChart.Axis.MaxXValue Property

Maximum X value for the specified Axis.
public Double MaxXValue {get;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


MaxYValue

Steema.TeeChart.Axis.MaxYValue Property

Maximum Y value for the specified Axis.
public Double MaxYValue {get;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


MinAxisIncrement

Steema.TeeChart.Axis.MinAxisIncrement Property

Advanced use. Smallest Axis calculation increment. Default: 1e-12
public Double MinAxisIncrement {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


Minimum

Steema.TeeChart.Axis.Minimum Property

Sets Axis Minimum value.
public Double Minimum {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


MinimumOffset

Steema.TeeChart.Axis.MinimumOffset Property

Pixels separation at axis minimum.
public Int32 MinimumOffset {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


MinimumRound

Steema.TeeChart.Axis.MinimumRound Property

Rounds Axis Minimum to nearest Integer value.
public Boolean MinimumRound {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


MinorGrid

Steema.TeeChart.Axis.MinorGrid Property

Sets characteristics of the Grid coincidental to Minor Ticks.
public ChartPen MinorGrid {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


MinorTickCount

Steema.TeeChart.Axis.MinorTickCount Property

Determines the number of Axis minor ticks between major ticks.
public Int32 MinorTickCount {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


MinorTicks

Steema.TeeChart.Axis.MinorTicks Property

Determines the Pen used to draw the Axis Minor ticks.
public TicksPen MinorTicks {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


MinXValue

Steema.TeeChart.Axis.MinXValue Property

Minimum X value for the specified Axis.
public Double MinXValue {get;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


MinYValue

Steema.TeeChart.Axis.MinYValue Property

Minimum Y value for the specified Axis.
public Double MinYValue {get;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


OtherSide

Steema.TeeChart.Axis.OtherSide Property

Sets the Axis to Otherside (Left or Right, Top or Bottom)
public Boolean OtherSide {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


PartnerAxis

Steema.TeeChart.Axis.PartnerAxis Property

Use this property when UsePartnerAxis is set to True to define an Axis pair whose bounding rectangle will limit the plotted Gridilines for either Axis. It is possible to have a one sided partnership where only one of the two Axes limits its Gridline plot.
public Axis PartnerAxis {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


PosAxis

Steema.TeeChart.Axis.PosAxis Property

Please use Position property.
public Int32 PosAxis {get;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


Position

Steema.TeeChart.Axis.Position Property

Sets the screen co-ordinate where axis is drawn.
public Int32 Position {get;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


PositionUnits

Steema.TeeChart.Axis.PositionUnits Property

Defines Position units (pixels or percentage) for the RelativePosition property.
public PositionUnits PositionUnits {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


RelativePosition

Steema.TeeChart.Axis.RelativePosition Property

Axis position relative to Chart.
public Double RelativePosition {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


StartEndPositionUnits

Steema.TeeChart.Axis.StartEndPositionUnits Property

Defines Position units (pixels or percentage) for the StartPosition and EndPosition properties.
public PositionUnits StartEndPositionUnits {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


StartPosition

Steema.TeeChart.Axis.StartPosition Property

Axis Start position as percentage of Chart.
public Double StartPosition {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


TickOnLabelsOnly

Steema.TeeChart.Axis.TickOnLabelsOnly Property

Sets the Axis Ticks and Axis Grid to be drawn at Labels only.
public Boolean TickOnLabelsOnly {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


Ticks

Steema.TeeChart.Axis.Ticks Property

Determines the Pen used to draw Axis marks along the Axis line.
public TicksPen Ticks {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


TicksInner

Steema.TeeChart.Axis.TicksInner Property

Determines the Pen used to draw Axis marks inside the Axis line.
public TicksPen TicksInner {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


Title

Steema.TeeChart.Axis.Title Property

Title attributes
public AxisTitle Title {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


TitleSize

Steema.TeeChart.Axis.TitleSize Property

public Int32 TitleSize {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


UsePartnerAxis

Steema.TeeChart.Axis.UsePartnerAxis Property

When True and PartnerAxis is set to the value of a valid Axis, Axis GridlInes will zone to the bounding rectangle of the two Partner Axes. It is possible to have a one sided partnership where only one of the two Axes limits its Gridline plot.
public Boolean UsePartnerAxis {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


Visible

Steema.TeeChart.Axis.Visible Property

Shows or hides all the five Chart Axes at once.
public Boolean Visible {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


ZoomLimitToAxisBounds

Steema.TeeChart.Axis.ZoomLimitToAxisBounds Property

When true, zooms associated to this axis will not exceed the standard axis scale. This can be useful for multi axis charts to avoid a zoom on a neighbouring axis sending the associated contents of this Axis out of bounds.
public Boolean ZoomLimitToAxisBounds {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


ZPosition

Steema.TeeChart.Axis.ZPosition Property

Determines the Z axis position along chart Depth
public Double ZPosition {get; set;}

See Also

Axis Class | Axis Members | Steema.TeeChart Namespace


Steema.TeeChart.Axis.AxisLinePen

Steema.TeeChart.Axis.AxisLinePen Class

Determines the pen used to draw the axis lines

For a list of all members of this type, see AxisLinePen Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.ChartPen
public sealed class AxisLinePen : ChartPen , ICloneable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

AxisLinePen members | Steema.TeeChart Namespace


Steema.TeeChart.Axis.AxisLinePenMembers

Steema.TeeChart.Axis.AxisLinePen all Members

AxisLinePen overview

Public Methods

Assign (inherited from ChartPen) |
Clone (inherited from ChartPen) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from ChartPen) | Determines the color used by the pen to draw lines on the Drawing.
DashPattern (inherited from ChartPen) |
DashWidth (inherited from ChartPen) |
DrawingPen (inherited from ChartPen) | Accesses the internal Drawing.Pen object.
EndCap (inherited from ChartPen) | Style of line endings.
Style (inherited from ChartPen) | Determines the style in which the pen draw lines on the Drawing.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency (inherited from ChartPen) | Sets Transparency level from 0 to 100%.
UseStyling (inherited from ChartPen) | Set to false to make ChartPen ignore Style, DashCap, DashPattern and EndCap properties. Useful as a performance micro-optimization.
Visible (inherited from ChartPen) | Determines if the pen will draw lines or not.
Width | Sets the width of the AxisLinePen

Constructors

Steema.TeeChart.Axis.AxisLinePen..ctor Overloaded

See Also

AxisLinePen Class | Steema.TeeChart Namespace


Steema.TeeChart.Axis.AxisLinePenMethods

Steema.TeeChart.Axis.AxisLinePen Methods

Public Methods

Assign (inherited from ChartPen) |
Clone (inherited from ChartPen) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

See Also

AxisLinePen Class | Steema.TeeChart Namespace


Steema.TeeChart.Axis.AxisLinePenProperties

Steema.TeeChart.Axis.AxisLinePen Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from ChartPen) | Determines the color used by the pen to draw lines on the Drawing.
DashPattern (inherited from ChartPen) |
DashWidth (inherited from ChartPen) |
DrawingPen (inherited from ChartPen) | Accesses the internal Drawing.Pen object.
EndCap (inherited from ChartPen) | Style of line endings.
Style (inherited from ChartPen) | Determines the style in which the pen draw lines on the Drawing.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency (inherited from ChartPen) | Sets Transparency level from 0 to 100%.
UseStyling (inherited from ChartPen) | Set to false to make ChartPen ignore Style, DashCap, DashPattern and EndCap properties. Useful as a performance micro-optimization.
Visible (inherited from ChartPen) | Determines if the pen will draw lines or not.
Width | Sets the width of the AxisLinePen

See Also

AxisLinePen Class | Steema.TeeChart Namespace


Width

Steema.TeeChart.Axis+AxisLinePen.Width Property

Sets the width of the AxisLinePen
public override Int32 Width {get; set;}

See Also

AxisLinePen Class | AxisLinePen Members | Steema.TeeChart Namespace


Steema.TeeChart.Axis+AxisLinePen Constructor

Overload List

public Axis+AxisLinePen()
public Axis+AxisLinePen(Steema.TeeChart.Chart)

See Also

AxisLinePen Class | AxisLinePen Members | Steema.TeeChart Namespace


Steema.TeeChart.Axis+AxisLinePen Constructor

public Axis+AxisLinePen(Chart c)

See Also

Axis.AxisLinePen Constructor Overload List | AxisLinePen Class | AxisLinePen Members | Steema.TeeChart Namespace


Steema.TeeChart.Axis+AxisLinePen Constructor

public Axis+AxisLinePen()

See Also

Axis.AxisLinePen Constructor Overload List | AxisLinePen Class | AxisLinePen Members | Steema.TeeChart Namespace


Steema.TeeChart.Axis.GridPen

Steema.TeeChart.Axis.GridPen Class

Determines the kind of pen used to draw the Grid lines at every Axis Label position.

For a list of all members of this type, see GridPen Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.ChartPen
public class GridPen : ChartPen , ICloneable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

GridPen members | Steema.TeeChart Namespace


Steema.TeeChart.Axis.GridPenMembers

Steema.TeeChart.Axis.GridPen all Members

GridPen overview

Public Methods

Assign (inherited from ChartPen) |
Clone (inherited from ChartPen) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Centered | Aligns the Grid to the centre.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from ChartPen) | Determines the color used by the pen to draw lines on the Drawing.
DashPattern (inherited from ChartPen) |
DashWidth (inherited from ChartPen) |
DrawEvery |
DrawingPen (inherited from ChartPen) | Accesses the internal Drawing.Pen object.
EndCap (inherited from ChartPen) | Style of line endings.
Style (inherited from ChartPen) | Determines the style in which the pen draw lines on the Drawing.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency (inherited from ChartPen) | Sets Transparency level from 0 to 100%.
UseStyling (inherited from ChartPen) | Set to false to make ChartPen ignore Style, DashCap, DashPattern and EndCap properties. Useful as a performance micro-optimization.
Visible (inherited from ChartPen) | Determines if the pen will draw lines or not.
Width (inherited from ChartPen) | Determines the width of lines the pen draws.
ZPosition |

Constructors

Steema.TeeChart.Axis.GridPen..ctor Overloaded

See Also

GridPen Class | Steema.TeeChart Namespace


Steema.TeeChart.Axis.GridPenMethods

Steema.TeeChart.Axis.GridPen Methods

Public Methods

Assign (inherited from ChartPen) |
Clone (inherited from ChartPen) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

See Also

GridPen Class | Steema.TeeChart Namespace


Steema.TeeChart.Axis.GridPenProperties

Steema.TeeChart.Axis.GridPen Properties

Public Properties

Centered | Aligns the Grid to the centre.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from ChartPen) | Determines the color used by the pen to draw lines on the Drawing.
DashPattern (inherited from ChartPen) |
DashWidth (inherited from ChartPen) |
DrawEvery |
DrawingPen (inherited from ChartPen) | Accesses the internal Drawing.Pen object.
EndCap (inherited from ChartPen) | Style of line endings.
Style (inherited from ChartPen) | Determines the style in which the pen draw lines on the Drawing.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency (inherited from ChartPen) | Sets Transparency level from 0 to 100%.
UseStyling (inherited from ChartPen) | Set to false to make ChartPen ignore Style, DashCap, DashPattern and EndCap properties. Useful as a performance micro-optimization.
Visible (inherited from ChartPen) | Determines if the pen will draw lines or not.
Width (inherited from ChartPen) | Determines the width of lines the pen draws.
ZPosition |

See Also

GridPen Class | Steema.TeeChart Namespace


Centered

Steema.TeeChart.Axis+GridPen.Centered Property

Aligns the Grid to the centre.
public Boolean Centered {get; set;}

See Also

GridPen Class | GridPen Members | Steema.TeeChart Namespace


DrawEvery

Steema.TeeChart.Axis+GridPen.DrawEvery Property

public Int32 DrawEvery {get; set;}

See Also

GridPen Class | GridPen Members | Steema.TeeChart Namespace


ZPosition

Steema.TeeChart.Axis+GridPen.ZPosition Property

public Double ZPosition {get; set;}

See Also

GridPen Class | GridPen Members | Steema.TeeChart Namespace


Steema.TeeChart.Axis+GridPen Constructor

Overload List

public Axis+GridPen()
public Axis+GridPen(Steema.TeeChart.Chart)

See Also

GridPen Class | GridPen Members | Steema.TeeChart Namespace


Steema.TeeChart.Axis+GridPen Constructor

public Axis+GridPen(Chart c)

See Also

Axis.GridPen Constructor Overload List | GridPen Class | GridPen Members | Steema.TeeChart Namespace


Steema.TeeChart.Axis+GridPen Constructor

public Axis+GridPen()

See Also

Axis.GridPen Constructor Overload List | GridPen Class | GridPen Members | Steema.TeeChart Namespace


Steema.TeeChart.Axis.TicksPen

Steema.TeeChart.Axis.TicksPen Class

Determines the kind of Pen used to draw Axis marks along the Axis line.

For a list of all members of this type, see TicksPen Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.ChartPen
public class TicksPen : ChartPen , ICloneable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

TicksPen members | Steema.TeeChart Namespace


Steema.TeeChart.Axis.TicksPenMembers

Steema.TeeChart.Axis.TicksPen all Members

TicksPen overview

Public Methods

Assign (inherited from ChartPen) |
Clone (inherited from ChartPen) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from ChartPen) | Determines the color used by the pen to draw lines on the Drawing.
DashPattern (inherited from ChartPen) |
DashWidth (inherited from ChartPen) |
DrawingPen (inherited from ChartPen) | Accesses the internal Drawing.Pen object.
EndCap (inherited from ChartPen) | Style of line endings.
Length | Length of Axis Ticks in pixels.
Style (inherited from ChartPen) | Determines the style in which the pen draw lines on the Drawing.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency (inherited from ChartPen) | Sets Transparency level from 0 to 100%.
UseStyling (inherited from ChartPen) | Set to false to make ChartPen ignore Style, DashCap, DashPattern and EndCap properties. Useful as a performance micro-optimization.
Visible (inherited from ChartPen) | Determines if the pen will draw lines or not.
Width (inherited from ChartPen) | Determines the width of lines the pen draws.

Constructors

Steema.TeeChart.Axis.TicksPen..ctor Overloaded

See Also

TicksPen Class | Steema.TeeChart Namespace


Steema.TeeChart.Axis.TicksPenMethods

Steema.TeeChart.Axis.TicksPen Methods

Public Methods

Assign (inherited from ChartPen) |
Clone (inherited from ChartPen) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

See Also

TicksPen Class | Steema.TeeChart Namespace


Steema.TeeChart.Axis.TicksPenProperties

Steema.TeeChart.Axis.TicksPen Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from ChartPen) | Determines the color used by the pen to draw lines on the Drawing.
DashPattern (inherited from ChartPen) |
DashWidth (inherited from ChartPen) |
DrawingPen (inherited from ChartPen) | Accesses the internal Drawing.Pen object.
EndCap (inherited from ChartPen) | Style of line endings.
Length | Length of Axis Ticks in pixels.
Style (inherited from ChartPen) | Determines the style in which the pen draw lines on the Drawing.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency (inherited from ChartPen) | Sets Transparency level from 0 to 100%.
UseStyling (inherited from ChartPen) | Set to false to make ChartPen ignore Style, DashCap, DashPattern and EndCap properties. Useful as a performance micro-optimization.
Visible (inherited from ChartPen) | Determines if the pen will draw lines or not.
Width (inherited from ChartPen) | Determines the width of lines the pen draws.

See Also

TicksPen Class | Steema.TeeChart Namespace


Length

Steema.TeeChart.Axis+TicksPen.Length Property

Length of Axis Ticks in pixels.
public Int32 Length {get; set;}

See Also

TicksPen Class | TicksPen Members | Steema.TeeChart Namespace


Steema.TeeChart.Axis+TicksPen Constructor

Overload List

public Axis+TicksPen()
public Axis+TicksPen(Steema.TeeChart.Chart)
public Axis+TicksPen(Steema.TeeChart.Drawing.ChartPen, Steema.TeeChart.Chart)

See Also

TicksPen Class | TicksPen Members | Steema.TeeChart Namespace


Steema.TeeChart.Axis+TicksPen Constructor

public Axis+TicksPen(ChartPen p,
     Chart c)

See Also

Axis.TicksPen Constructor Overload List | TicksPen Class | TicksPen Members | Steema.TeeChart Namespace


Steema.TeeChart.Axis+TicksPen Constructor

public Axis+TicksPen(Chart c)

See Also

Axis.TicksPen Constructor Overload List | TicksPen Class | TicksPen Members | Steema.TeeChart Namespace


Steema.TeeChart.Axis+TicksPen Constructor

public Axis+TicksPen()

See Also

Axis.TicksPen Constructor Overload List | TicksPen Class | TicksPen Members | Steema.TeeChart Namespace


Steema.TeeChart.AxisCalcPosLabelsEventHandler

Steema.TeeChart.AxisCalcPosLabelsEventHandler Delegate

public delegate AxisCalcPosLabelsEventHandler (Axis axis,
     Int32 value)

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart Namespace


Steema.TeeChart.AxisCalcPosPointDelegate

Steema.TeeChart.AxisCalcPosPointDelegate Delegate

public delegate AxisCalcPosPointDelegate (Int32 value)

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart Namespace


Steema.TeeChart.AxisCalcPosValueDelegate

Steema.TeeChart.AxisCalcPosValueDelegate Delegate

public delegate AxisCalcPosValueDelegate (Double value)

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelAlign

Steema.TeeChart.AxisLabelAlign Enum

Sets position of Labels on an Axis.
[Serializable]
public sealed enum AxisLabelAlign : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Default | Default position.
Opposite | Labels aligned opposite the default position.

See Also

Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelItem

Steema.TeeChart.AxisLabelItem Class

For a list of all members of this type, see AxisLabelItem Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
public class AxisLabelItem : TextShape , ICloneable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

AxisLabelItem members | Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelItemMembers

Steema.TeeChart.AxisLabelItem all Members

AxisLabelItem overview

Constructors

Constructor

Public Fields

Size (inherited from TextShape)

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.
Repaint | Refresh Label

Public Properties

AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Value | The Axis Value of the Label
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

AxisLabelItem Class | Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelItem Constructor

public AxisLabelItem(Chart c)

See Also

AxisLabelItem Class | AxisLabelItem Members | Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelItemFields

Steema.TeeChart.AxisLabelItem Fields

Public Fields

Size (inherited from TextShape)

See Also

AxisLabelItem Class | Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelItemMethods

Steema.TeeChart.AxisLabelItem Methods

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.
Repaint | Refresh Label

See Also

AxisLabelItem Class | Steema.TeeChart Namespace


Repaint

Steema.TeeChart.AxisLabelItem.Repaint Method

Refresh Label
public Void Repaint()

See Also

AxisLabelItem Class | AxisLabelItem Members | Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelItemProperties

Steema.TeeChart.AxisLabelItem Properties

Public Properties

AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Value | The Axis Value of the Label
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

AxisLabelItem Class | Steema.TeeChart Namespace


Value

Steema.TeeChart.AxisLabelItem.Value Property

The Axis Value of the Label
public Double Value {get; set;}

See Also

AxisLabelItem Class | AxisLabelItem Members | Steema.TeeChart Namespace


Steema.TeeChart.AxisLabels

Steema.TeeChart.AxisLabels Class

Axis Label characteristics

For a list of all members of this type, see AxisLabels Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
public class AxisLabels : TextShape , ICloneable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

AxisLabels members | Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelsMembers

Steema.TeeChart.AxisLabels all Members

AxisLabels overview

Constructors

Constructor Accesses the Label characteristics of Axis Labels.

Public Fields

Size (inherited from TextShape)

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clicked | Returns the Index of the "clicked" label.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
LabelHeight | Returns the Axis Label height of the Value parameter.
LabelValue | Returns the corresponding text representation of the Value parameter.
LabelWidth | Returns the Axis Label width of the Value parameter.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.
SplitInLines | Sets Separator string to invoke 'new line' in string St

Public Properties

Align | Sets position of Labels on an Axis
Alternate | Sets the axis labels to be drawn in two rows or columns.
Angle | Defines the rotation degree applied to each Axis Label.
AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
CustomSize | Changes spacing occupied by the axis labels between the ticks and the title.
DateTimeFormat | Is a standard DateTime formatting string specifier used to draw the axis labels.
ExactDateTime | Sets the Axis.Increment property to calculate Axis Labels in exact DateTime steps.
Exponent | Enables/disables the display of Axis Labels in exponent format with super-script fonts.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
GridIgnoresLabelSize | When True, the Axis grid will not try to resize to accomodate the Label Font size.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Items | Contains the custom labels
LabelsAsLocalTime | When true, displays DateTime Labels in Local Time rather than UTC.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines (inherited from TextShape) | Access to array of Text lines
MultiLine | Automatically breaks DateTime Labels on occurence of a space " ".
OnAxis | Controls whether the Labels at Axis Minimum and Maximum positions will be shown or not.
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
RoundFirstLabel | Controls if Axis labels will be automatically "rounded" to the nearest magnitude.
Separation | Specifies the percent amount of minimum distance between Axis Labels.
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Style | Sets the style of the labels.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
ValueFormat | Specifies the desired formatting string to be applied to Axis Labels.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

AxisLabels Class | Steema.TeeChart Namespace


Steema.TeeChart.AxisLabels Constructor

Accesses the Label characteristics of Axis Labels.
public AxisLabels(Axis a)

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelsFields

Steema.TeeChart.AxisLabels Fields

Public Fields

Size (inherited from TextShape)

See Also

AxisLabels Class | Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelsMethods

Steema.TeeChart.AxisLabels Methods

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clicked | Returns the Index of the "clicked" label.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
LabelHeight | Returns the Axis Label height of the Value parameter.
LabelValue | Returns the corresponding text representation of the Value parameter.
LabelWidth | Returns the Axis Label width of the Value parameter.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.
SplitInLines | Sets Separator string to invoke 'new line' in string St

See Also

AxisLabels Class | Steema.TeeChart Namespace


Clicked

Steema.TeeChart.AxisLabels.Clicked Method

Returns the Index of the "clicked" label.
public Int32 Clicked(Int32 X,
     Int32 Y)

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


LabelHeight

Steema.TeeChart.AxisLabels.LabelHeight Method

Returns the Axis Label height of the Value parameter.
public Int32 LabelHeight(Double value)

Parameters

value
Axis value

Return Value

Axis Label height in pixels

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


LabelValue

Steema.TeeChart.AxisLabels.LabelValue Method

Returns the corresponding text representation of the Value parameter.
public String LabelValue(Double value)

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


LabelWidth

Steema.TeeChart.AxisLabels.LabelWidth Method

Returns the Axis Label width of the Value parameter.
public Int32 LabelWidth(Double value)

Parameters

value
Axis value

Return Value

Axis Label width in pixels

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


SplitInLines

Steema.TeeChart.AxisLabels.SplitInLines Method

Sets Separator string to invoke 'new line' in string St
public Void SplitInLines(String& s,
     String separator)

Parameters

s
Input string
separator
String to be used for new line

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelsProperties

Steema.TeeChart.AxisLabels Properties

Public Properties

Align | Sets position of Labels on an Axis
Alternate | Sets the axis labels to be drawn in two rows or columns.
Angle | Defines the rotation degree applied to each Axis Label.
AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
CustomSize | Changes spacing occupied by the axis labels between the ticks and the title.
DateTimeFormat | Is a standard DateTime formatting string specifier used to draw the axis labels.
ExactDateTime | Sets the Axis.Increment property to calculate Axis Labels in exact DateTime steps.
Exponent | Enables/disables the display of Axis Labels in exponent format with super-script fonts.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
GridIgnoresLabelSize | When True, the Axis grid will not try to resize to accomodate the Label Font size.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Items | Contains the custom labels
LabelsAsLocalTime | When true, displays DateTime Labels in Local Time rather than UTC.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines (inherited from TextShape) | Access to array of Text lines
MultiLine | Automatically breaks DateTime Labels on occurence of a space " ".
OnAxis | Controls whether the Labels at Axis Minimum and Maximum positions will be shown or not.
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
RoundFirstLabel | Controls if Axis labels will be automatically "rounded" to the nearest magnitude.
Separation | Specifies the percent amount of minimum distance between Axis Labels.
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Style | Sets the style of the labels.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
ValueFormat | Specifies the desired formatting string to be applied to Axis Labels.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

AxisLabels Class | Steema.TeeChart Namespace


Align

Steema.TeeChart.AxisLabels.Align Property

Sets position of Labels on an Axis
public AxisLabelAlign Align {get; set;}

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


Alternate

Steema.TeeChart.AxisLabels.Alternate Property

Sets the axis labels to be drawn in two rows or columns.
public Boolean Alternate {get; set;}

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


Angle

Steema.TeeChart.AxisLabels.Angle Property

Defines the rotation degree applied to each Axis Label.
public Int32 Angle {get; set;}

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


CustomSize

Steema.TeeChart.AxisLabels.CustomSize Property

Changes spacing occupied by the axis labels between the ticks and the title.
public Int32 CustomSize {get; set;}

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


DateTimeFormat

Steema.TeeChart.AxisLabels.DateTimeFormat Property

Is a standard DateTime formatting string specifier used to draw the axis labels.
public String DateTimeFormat {get; set;}

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


ExactDateTime

Steema.TeeChart.AxisLabels.ExactDateTime Property

Sets the Axis.Increment property to calculate Axis Labels in exact DateTime steps.
public Boolean ExactDateTime {get; set;}

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


Exponent

Steema.TeeChart.AxisLabels.Exponent Property

Enables/disables the display of Axis Labels in exponent format with super-script fonts.
public Boolean Exponent {get; set;}

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


GridIgnoresLabelSize

Steema.TeeChart.AxisLabels.GridIgnoresLabelSize Property

When True, the Axis grid will not try to resize to accomodate the Label Font size.
public Boolean GridIgnoresLabelSize {get; set;}

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


Items

Steema.TeeChart.AxisLabels.Items Property

Contains the custom labels
public AxisLabelsItems Items {get;}

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


LabelsAsLocalTime

Steema.TeeChart.AxisLabels.LabelsAsLocalTime Property

When true, displays DateTime Labels in Local Time rather than UTC.
public Boolean LabelsAsLocalTime {get; set;}

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


MultiLine

Steema.TeeChart.AxisLabels.MultiLine Property

Automatically breaks DateTime Labels on occurence of a space " ".
public Boolean MultiLine {get; set;}

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


RoundFirstLabel

Steema.TeeChart.AxisLabels.RoundFirstLabel Property

Controls if Axis labels will be automatically "rounded" to the nearest magnitude.
public Boolean RoundFirstLabel {get; set;}

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


Separation

Steema.TeeChart.AxisLabels.Separation Property

Specifies the percent amount of minimum distance between Axis Labels.
public Int32 Separation {get; set;}

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


Style

Steema.TeeChart.AxisLabels.Style Property

Sets the style of the labels.
public AxisLabelStyle Style {get; set;}

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


ValueFormat

Steema.TeeChart.AxisLabels.ValueFormat Property

Specifies the desired formatting string to be applied to Axis Labels.
public String ValueFormat {get; set;}

See Also

AxisLabels Class | AxisLabels Members | Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelsItems

Steema.TeeChart.AxisLabelsItems Class

Custom labels list

For a list of all members of this type, see AxisLabelsItems Members

System.Object
System.Collections.ArrayList
public class AxisLabelsItems : ArrayList , IList, ICollection
, IEnumerable, ICloneable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

AxisLabelsItems members | Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelsItemsMembers

Steema.TeeChart.AxisLabelsItems all Members

AxisLabelsItems overview

Constructors

Constructor

Public Methods

Add | Add New Label
Clear | Clear Custom Labels list
CopyFrom |

Public Properties

Item Access indexed Label characteristics

See Also

AxisLabelsItems Class | Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelsItems Constructor

public AxisLabelsItems(Axis a)

See Also

AxisLabelsItems Class | AxisLabelsItems Members | Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelsItemsMethods

Steema.TeeChart.AxisLabelsItems Methods

Public Methods

Add | Add New Label
Clear | Clear Custom Labels list
CopyFrom |

See Also

AxisLabelsItems Class | Steema.TeeChart Namespace


Add

Steema.TeeChart.AxisLabelsItems.Add Method

Overload List

Add New Label

public AxisLabelItem Add(System.Double)

Add New Label with Text

public AxisLabelItem Add(System.Double, System.String)

See Also

AxisLabelsItems Class | AxisLabelsItems Members | Steema.TeeChart Namespace


Add

Steema.TeeChart.AxisLabelsItems.Add Method

Add New Label with Text
public AxisLabelItem Add(Double value,
     String text)

Parameters

value
Label text
text
The Axis Data value

Return Value

The new AxisLabelItem

See Also

Add Overload List | AxisLabelsItems Class | AxisLabelsItems Members | Steema.TeeChart Namespace


Add

Steema.TeeChart.AxisLabelsItems.Add Method

Add New Label
public AxisLabelItem Add(Double value)

Parameters

value
The Axis Data value

Return Value

The new AxisLabelItem

See Also

Add Overload List | AxisLabelsItems Class | AxisLabelsItems Members | Steema.TeeChart Namespace


Clear

Steema.TeeChart.AxisLabelsItems.Clear Method

Clear Custom Labels list
public override Void Clear()

See Also

AxisLabelsItems Class | AxisLabelsItems Members | Steema.TeeChart Namespace


CopyFrom

Steema.TeeChart.AxisLabelsItems.CopyFrom Method

public Void CopyFrom(AxisLabelsItems Source)

See Also

AxisLabelsItems Class | AxisLabelsItems Members | Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelsItemsProperties

Steema.TeeChart.AxisLabelsItems Properties

Public Properties

Item Access indexed Label characteristics

See Also

AxisLabelsItems Class | Steema.TeeChart Namespace


Item

Steema.TeeChart.AxisLabelsItems.Item Property

Access indexed Label characteristics
public AxisLabelItem Item(Int32 index) {get;}

See Also

AxisLabelsItems Class | AxisLabelsItems Members | Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelStyle

Steema.TeeChart.AxisLabelStyle Enum

Defines the possible values of the Style Axis.Labels.Style property
[Serializable]
public sealed enum AxisLabelStyle : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Auto | Choose the Style automatically
None | No label. This will trigger the event with empty strings
Value | Axis labeling is based on axis Minimum and Maximum properties
Mark | Each Series point will have a Label using SeriesMarks style
Text | Each Series point will have a Label using Series.XLabels strings
PointValue | Each Series point will have a Label using Series.XValues (notMandatory) strings

See Also

Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelValueDelegate

Steema.TeeChart.AxisLabelValueDelegate Delegate

public delegate AxisLabelValueDelegate (Object sender,
     AxisLabelValueEventArgs e)

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelValueEventArgs

Steema.TeeChart.AxisLabelValueEventArgs Class

Internal Axis LabelValue EventArgs. See

For a list of all members of this type, see AxisLabelValueEventArgs Members

System.Object
System.EventArgs
public class AxisLabelValueEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

AxisLabelValueEventArgs members | Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelValueEventArgsMembers

Steema.TeeChart.AxisLabelValueEventArgs all Members

AxisLabelValueEventArgs overview

Constructors

Constructor

Public Properties

TmpValue

See Also

AxisLabelValueEventArgs Class | Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelValueEventArgs Constructor

public AxisLabelValueEventArgs(Double tmpValue)

See Also

AxisLabelValueEventArgs Class | AxisLabelValueEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.AxisLabelValueEventArgsProperties

Steema.TeeChart.AxisLabelValueEventArgs Properties

Public Properties

TmpValue

See Also

AxisLabelValueEventArgs Class | Steema.TeeChart Namespace


TmpValue

Steema.TeeChart.AxisLabelValueEventArgs.TmpValue Property

public Double TmpValue {get; set;}

See Also

AxisLabelValueEventArgs Class | AxisLabelValueEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.AxisTitle

Steema.TeeChart.AxisTitle Class

Axis Title characteristics

For a list of all members of this type, see AxisTitle Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
public sealed class AxisTitle : TextShape , ICloneable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

AxisTitle members | Steema.TeeChart Namespace


Steema.TeeChart.AxisTitleMembers

Steema.TeeChart.AxisTitle all Members

AxisTitle overview

Constructors

Constructor Overloaded

Public Fields

Size (inherited from TextShape)

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.

Public Properties

Angle | Rotation in degrees applied to each Axis Label.
AutoPosition | Gets or sets whether axis title positioning is automatically calculated.
AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Caption | Defines the string of text used for each Chart Axis.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
CustomSize | Change spacing between the axis/labels and the outer panel edge.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

AxisTitle Class | Steema.TeeChart Namespace


Steema.TeeChart.AxisTitle Constructor

Overload List

public AxisTitle()
public AxisTitle(Steema.TeeChart.Chart)

See Also

AxisTitle Class | AxisTitle Members | Steema.TeeChart Namespace


Steema.TeeChart.AxisTitle Constructor

public AxisTitle(Chart c)

See Also

AxisTitle Constructor Overload List | AxisTitle Class | AxisTitle Members | Steema.TeeChart Namespace


Steema.TeeChart.AxisTitle Constructor

public AxisTitle()

See Also

AxisTitle Constructor Overload List | AxisTitle Class | AxisTitle Members | Steema.TeeChart Namespace


Steema.TeeChart.AxisTitleFields

Steema.TeeChart.AxisTitle Fields

Public Fields

Size (inherited from TextShape)

See Also

AxisTitle Class | Steema.TeeChart Namespace


Steema.TeeChart.AxisTitleMethods

Steema.TeeChart.AxisTitle Methods

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.

See Also

AxisTitle Class | Steema.TeeChart Namespace


Steema.TeeChart.AxisTitleProperties

Steema.TeeChart.AxisTitle Properties

Public Properties

Angle | Rotation in degrees applied to each Axis Label.
AutoPosition | Gets or sets whether axis title positioning is automatically calculated.
AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Caption | Defines the string of text used for each Chart Axis.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
CustomSize | Change spacing between the axis/labels and the outer panel edge.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

AxisTitle Class | Steema.TeeChart Namespace


Angle

Steema.TeeChart.AxisTitle.Angle Property

Rotation in degrees applied to each Axis Label.
public Int32 Angle {get; set;}

See Also

AxisTitle Class | AxisTitle Members | Steema.TeeChart Namespace


AutoPosition

Steema.TeeChart.AxisTitle.AutoPosition Property

Gets or sets whether axis title positioning is automatically calculated.
public Boolean AutoPosition {get; set;}

See Also

AxisTitle Class | AxisTitle Members | Steema.TeeChart Namespace


Caption

Steema.TeeChart.AxisTitle.Caption Property

Defines the string of text used for each Chart Axis.
public String Caption {get; set;}

See Also

AxisTitle Class | AxisTitle Members | Steema.TeeChart Namespace


CustomSize

Steema.TeeChart.AxisTitle.CustomSize Property

Change spacing between the axis/labels and the outer panel edge.
public Int32 CustomSize {get; set;}

See Also

AxisTitle Class | AxisTitle Members | Steema.TeeChart Namespace


Steema.TeeChart.Chart

Steema.TeeChart.Chart Class

Chart contents. See TChart and Web.WebChart for use.

For a list of all members of this type, see Chart Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class Chart : TeeBase , ICloneable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Chart members | Steema.TeeChart Namespace


Steema.TeeChart.ChartMembers

Steema.TeeChart.Chart all Members

Chart overview

Constructors

Constructor Overloaded

Public Fields

AutoRepaint
CancelMouse
ChartRect
ClipWhenMetafiling
ClipWhenPrinting
IInvalidate
iOpenGL
IsEmbedded
iVideoTool
iWorldMaps

Public Methods

ActiveSeriesLegend | Returns the Active series (visible) that corresponds to the ItemIndex position in the Legend
Bitmap | Saves the current chart image to the specified File Name.
CalcClickedPart |
CanClip | Returns the number of active (visible) series.
Clone |
CountActiveSeries | Returns the number of active (visible) series.
DoKeyDown |
DoMouseDown |
DoMouseMove |
DoMouseUp |
DoPanelPaint |
Draw | Paints the Chart on the Drawing Canvas g.
FormattedLegend | Returns the text string corresponding to a Legend position.
FormattedValueLegend | Returns the string to display at Legend for a given series and point index.
FreeSeriesColor | Returns a color from the default color palette not used by any Series.
GetASeries | Returns first active (visible) series.
GetAxisSeries | Returns the first Series that depends on the specified Axis.
GetDefaultColor | Returns a color from global ColorPalette array variable.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsAxisVisible |
IsFreeSeriesColor | Returns whether the AColor parameter is used by any Series or not.
MaxMarkWidth | Returns the longest width in pixels for all the active (visible) series marks.
MaxTextHeight | Returns the height in pixels for the tallest "Label" of Axis, active or not.
MaxTextWidth | Returns the width in pixels for the longest "Label" of all series, active or not.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the highest of all the current Series Y point values.
MinXValue | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
SeriesLegend | When the Legend style is "Series", returns the series that corresponds to the Legend "ItemIndex" position. The "OnlyActive" parameter, when false takes into account all series, visibly active or not.
SeriesTitleLegend | Returns the Series.Title string.
UndoZoom |

Public Properties

Animations | Collection of Animation components contained in this Chart.
Aspect | 3D view parameters.
Axes | Collection of predefined and custom axis objects.
Chart (inherited from TeeBase) | Chart associated with this object
ChartBounds | Read only. Used to get the four sides of the Chart (Left, Top, Right and Bottom)
ColorPalette |
CustomChartRect |
Footer | Defines Text shown at the bottom of the Chart.
Graphics3D | Accesses TeeChart Draw properties and methods.
Header | Defines Text shown at top of the Chart.
Height | Sets the Chart Height in pixels.
Item | Default indexer ( Example: tChart1[0].Color=Color.Blue; is equivalent to tChart1.Series[0].Color=Color.Blue; )
Legend | Legend characteristics.
Listeners | Returns array list of objects that implement the ITeeEventListener interface.
MaxZOrder | Run-time and read only. The MaxZOrder property indicates the Chart depth in number of Series. When Chart.View3D is True, each Series has a Z order. The Series Z order defines the order along the Z axis when Series are displayed. The MaxZOrder property is the maximum Z order of all active Series. Some Series share a same Z order (stacked Bars, stacked Areas, etc).
Page | Accesses multiple page characteristics of the Chart.
Panel | Background visible attributes.
Panning | Sets the scrolling direction or denies scrolling.
Parent | The IChart parent of the Chart.
SerializedTag | Holds a custom tag object.
Series | Collection of Series contained in this Chart.
SubFooter | Defines Text shown directly above Footer.
SubHeader | Defines Text shown directly below Header.
SubTitle |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title |
Tools | Collection of Tool components contained in this Chart.
ToolTip | Displays a text box at the cursor.
Walls | Accesses left, bottom and back wall characteristics of the Chart.
Width | Sets the Chart Width in pixels.
Zoom | Accesses the Zoom characteristics of the Chart.

See Also

Chart Class | Steema.TeeChart Namespace


Steema.TeeChart.Chart Constructor

Overload List

public Chart(System.Object)
public Chart()

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Steema.TeeChart.Chart Constructor

public Chart()

See Also

Chart Constructor Overload List | Chart Class | Chart Members | Steema.TeeChart Namespace


Steema.TeeChart.Chart Constructor

public Chart(Object instance)

See Also

Chart Constructor Overload List | Chart Class | Chart Members | Steema.TeeChart Namespace


Steema.TeeChart.ChartFields

Steema.TeeChart.Chart Fields

Public Fields

AutoRepaint
CancelMouse
ChartRect
ClipWhenMetafiling
ClipWhenPrinting
IInvalidate
iOpenGL
IsEmbedded
iVideoTool
iWorldMaps

See Also

Chart Class | Steema.TeeChart Namespace


AutoRepaint

Steema.TeeChart.Chart.AutoRepaint Field

public Boolean AutoRepaint

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


CancelMouse

Steema.TeeChart.Chart.CancelMouse Field

public Boolean CancelMouse

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


ChartRect

Steema.TeeChart.Chart.ChartRect Field

public Rectangle ChartRect

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


ClipWhenMetafiling

Steema.TeeChart.Chart.ClipWhenMetafiling Field

public Boolean ClipWhenMetafiling

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


ClipWhenPrinting

Steema.TeeChart.Chart.ClipWhenPrinting Field

public Boolean ClipWhenPrinting

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


IInvalidate

Steema.TeeChart.Chart.IInvalidate Field

public Boolean IInvalidate

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


iOpenGL

Steema.TeeChart.Chart.iOpenGL Field

public Boolean iOpenGL

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


IsEmbedded

Steema.TeeChart.Chart.IsEmbedded Field

public Boolean IsEmbedded

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


iVideoTool

Steema.TeeChart.Chart.iVideoTool Field

public Boolean iVideoTool

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


iWorldMaps

Steema.TeeChart.Chart.iWorldMaps Field

public Boolean iWorldMaps

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Steema.TeeChart.ChartMethods

Steema.TeeChart.Chart Methods

Public Methods

ActiveSeriesLegend | Returns the Active series (visible) that corresponds to the ItemIndex position in the Legend
Bitmap | Saves the current chart image to the specified File Name.
CalcClickedPart |
CanClip | Returns the number of active (visible) series.
Clone |
CountActiveSeries | Returns the number of active (visible) series.
DoKeyDown |
DoMouseDown |
DoMouseMove |
DoMouseUp |
DoPanelPaint |
Draw | Paints the Chart on the Drawing Canvas g.
FormattedLegend | Returns the text string corresponding to a Legend position.
FormattedValueLegend | Returns the string to display at Legend for a given series and point index.
FreeSeriesColor | Returns a color from the default color palette not used by any Series.
GetASeries | Returns first active (visible) series.
GetAxisSeries | Returns the first Series that depends on the specified Axis.
GetDefaultColor | Returns a color from global ColorPalette array variable.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsAxisVisible |
IsFreeSeriesColor | Returns whether the AColor parameter is used by any Series or not.
MaxMarkWidth | Returns the longest width in pixels for all the active (visible) series marks.
MaxTextHeight | Returns the height in pixels for the tallest "Label" of Axis, active or not.
MaxTextWidth | Returns the width in pixels for the longest "Label" of all series, active or not.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the highest of all the current Series Y point values.
MinXValue | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
SeriesLegend | When the Legend style is "Series", returns the series that corresponds to the Legend "ItemIndex" position. The "OnlyActive" parameter, when false takes into account all series, visibly active or not.
SeriesTitleLegend | Returns the Series.Title string.
UndoZoom |

See Also

Chart Class | Steema.TeeChart Namespace


ActiveSeriesLegend

Steema.TeeChart.Chart.ActiveSeriesLegend Method

Returns the Active series (visible) that corresponds to the ItemIndex position in the Legend
public Series ActiveSeriesLegend(Int32 itemIndex)

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Bitmap

Steema.TeeChart.Chart.Bitmap Method

Overload List

Saves the current chart image to the specified File Name.

public Bitmap Bitmap(System.Int32, System.Int32, Android.Graphics.PixelFormat)

Saves the current chart image to the specified File Name.

public Bitmap Bitmap(System.Int32, System.Int32)

Saves the current chart image to the specified File Name.

public Bitmap Bitmap()

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Bitmap

Steema.TeeChart.Chart.Bitmap Method

Saves the current chart image to the specified File Name.
public Bitmap Bitmap()

See Also

Bitmap Overload List | Chart Class | Chart Members | Steema.TeeChart Namespace


Bitmap

Steema.TeeChart.Chart.Bitmap Method

Saves the current chart image to the specified File Name.
public Bitmap Bitmap(Int32 width,
     Int32 height)

See Also

Bitmap Overload List | Chart Class | Chart Members | Steema.TeeChart Namespace


Bitmap

Steema.TeeChart.Chart.Bitmap Method

Saves the current chart image to the specified File Name.
public Bitmap Bitmap(Int32 width,
     Int32 height,
     PixelFormat pixelformat)

See Also

Bitmap Overload List | Chart Class | Chart Members | Steema.TeeChart Namespace


CalcClickedPart

Steema.TeeChart.Chart.CalcClickedPart Method

public Void CalcClickedPart(Point Pos,
     ChartClickedPart& Part)

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


CanClip

Steema.TeeChart.Chart.CanClip Method

Returns the number of active (visible) series.
public Boolean CanClip()

Return Value

Number of Active (visible) Series.

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Clone

Steema.TeeChart.Chart.Clone Method

public virtual Object Clone()

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


CountActiveSeries

Steema.TeeChart.Chart.CountActiveSeries Method

Returns the number of active (visible) series.
public Int32 CountActiveSeries()

Return Value

Number of Active (visible) Series.

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


DoKeyDown

Steema.TeeChart.Chart.DoKeyDown Method

public abstract Void DoKeyDown(KeyEvent e)

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


DoMouseDown

Steema.TeeChart.Chart.DoMouseDown Method

public abstract Void DoMouseDown(Boolean IsDoubleClick,
     MotionEvent e)

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


DoMouseMove

Steema.TeeChart.Chart.DoMouseMove Method

public abstract Void DoMouseMove(Int32 x,
     Int32 y,
     Cursor& c)

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


DoMouseUp

Steema.TeeChart.Chart.DoMouseUp Method

public abstract Void DoMouseUp(MotionEvent e)

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


DoPanelPaint

Steema.TeeChart.Chart.DoPanelPaint Method

public Void DoPanelPaint(Canvas g,
     Rectangle r)

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Draw

Steema.TeeChart.Chart.Draw Method

Overload List

Paints the Chart on the Drawing Canvas g.

public Void Draw(Android.Graphics.Canvas)
public Void Draw(Android.Graphics.Canvas, System.Boolean)
public Void Draw(Android.Graphics.Canvas, System.Drawing.Rectangle)
public Void Draw(Android.Graphics.Canvas, System.Drawing.Rectangle, System.Boolean)

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Draw

Steema.TeeChart.Chart.Draw Method

public Void Draw(Canvas g,
     Rectangle r,
     Boolean noTools)

See Also

Draw Overload List | Chart Class | Chart Members | Steema.TeeChart Namespace


Draw

Steema.TeeChart.Chart.Draw Method

public Void Draw(Canvas g,
     Rectangle r)

See Also

Draw Overload List | Chart Class | Chart Members | Steema.TeeChart Namespace


Draw

Steema.TeeChart.Chart.Draw Method

public Void Draw(Canvas g,
     Boolean noTools)

See Also

Draw Overload List | Chart Class | Chart Members | Steema.TeeChart Namespace


Draw

Steema.TeeChart.Chart.Draw Method

Paints the Chart on the Drawing Canvas g.
public Void Draw(Canvas g)

See Also

Draw Overload List | Chart Class | Chart Members | Steema.TeeChart Namespace


FormattedLegend

Steema.TeeChart.Chart.FormattedLegend Method

Returns the text string corresponding to a Legend position.
public String FormattedLegend(Int32 seriesOrValueIndex)

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


FormattedValueLegend

Steema.TeeChart.Chart.FormattedValueLegend Method

Returns the string to display at Legend for a given series and point index.
public String FormattedValueLegend(Series aSeries,
     Int32 valueIndex)

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


FreeSeriesColor

Steema.TeeChart.Chart.FreeSeriesColor Method

Returns a color from the default color palette not used by any Series.
public Color FreeSeriesColor(Boolean checkBackground)

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


GetASeries

Steema.TeeChart.Chart.GetASeries Method

Returns first active (visible) series.
public Series GetASeries()

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


GetAxisSeries

Steema.TeeChart.Chart.GetAxisSeries Method

Returns the first Series that depends on the specified Axis.
public Series GetAxisSeries(Axis axis)

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


GetDefaultColor

Steema.TeeChart.Chart.GetDefaultColor Method

Returns a color from global ColorPalette array variable.
public Color GetDefaultColor(Int32 index)

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


IsAxisVisible

Steema.TeeChart.Chart.IsAxisVisible Method

public Boolean IsAxisVisible(Axis a)

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


IsFreeSeriesColor

Steema.TeeChart.Chart.IsFreeSeriesColor Method

Returns whether the AColor parameter is used by any Series or not.
public Boolean IsFreeSeriesColor(Color color,
     Boolean checkBackground)

Parameters

color
Color
checkBackground
When true, uses current Chart background

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


MaxMarkWidth

Steema.TeeChart.Chart.MaxMarkWidth Method

Returns the longest width in pixels for all the active (visible) series marks.
public Int32 MaxMarkWidth()

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


MaxTextHeight

Steema.TeeChart.Chart.MaxTextHeight Method

Returns the height in pixels for the tallest "Label" of Axis, active or not.
public Int32 MaxTextHeight(Axis a)

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


MaxTextWidth

Steema.TeeChart.Chart.MaxTextWidth Method

Returns the width in pixels for the longest "Label" of all series, active or not.
public Int32 MaxTextWidth()

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


MaxXValue

Steema.TeeChart.Chart.MaxXValue Method

Returns the Maximum Value of the Series X Values List.
public Double MaxXValue(Axis axis)

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


MaxYValue

Steema.TeeChart.Chart.MaxYValue Method

Returns the highest of all the current Series Y point values.
public Double MaxYValue(Axis axis)

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


MinXValue

Steema.TeeChart.Chart.MinXValue Method

Returns the Minimum Value of the Series X Values List.
public Double MinXValue(Axis axis)

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


MinYValue

Steema.TeeChart.Chart.MinYValue Method

Returns the Minimum Value of the Series Y Values List.
public Double MinYValue(Axis axis)

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


SeriesLegend

Steema.TeeChart.Chart.SeriesLegend Method

When the Legend style is "Series", returns the series that corresponds to the Legend "ItemIndex" position. The "OnlyActive" parameter, when false takes into account all series, visibly active or not.
public Series SeriesLegend(Int32 itemIndex,
     Boolean onlyActive)

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


SeriesTitleLegend

Steema.TeeChart.Chart.SeriesTitleLegend Method

Returns the Series.Title string.
public String SeriesTitleLegend(Int32 seriesIndex,
     Boolean onlyActive)

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


UndoZoom

Steema.TeeChart.Chart.UndoZoom Method

public Void UndoZoom()

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Steema.TeeChart.ChartProperties

Steema.TeeChart.Chart Properties

Public Properties

Animations | Collection of Animation components contained in this Chart.
Aspect | 3D view parameters.
Axes | Collection of predefined and custom axis objects.
Chart (inherited from TeeBase) | Chart associated with this object
ChartBounds | Read only. Used to get the four sides of the Chart (Left, Top, Right and Bottom)
ColorPalette |
CustomChartRect |
Footer | Defines Text shown at the bottom of the Chart.
Graphics3D | Accesses TeeChart Draw properties and methods.
Header | Defines Text shown at top of the Chart.
Height | Sets the Chart Height in pixels.
Item | Default indexer ( Example: tChart1[0].Color=Color.Blue; is equivalent to tChart1.Series[0].Color=Color.Blue; )
Legend | Legend characteristics.
Listeners | Returns array list of objects that implement the ITeeEventListener interface.
MaxZOrder | Run-time and read only. The MaxZOrder property indicates the Chart depth in number of Series. When Chart.View3D is True, each Series has a Z order. The Series Z order defines the order along the Z axis when Series are displayed. The MaxZOrder property is the maximum Z order of all active Series. Some Series share a same Z order (stacked Bars, stacked Areas, etc).
Page | Accesses multiple page characteristics of the Chart.
Panel | Background visible attributes.
Panning | Sets the scrolling direction or denies scrolling.
Parent | The IChart parent of the Chart.
SerializedTag | Holds a custom tag object.
Series | Collection of Series contained in this Chart.
SubFooter | Defines Text shown directly above Footer.
SubHeader | Defines Text shown directly below Header.
SubTitle |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title |
Tools | Collection of Tool components contained in this Chart.
ToolTip | Displays a text box at the cursor.
Walls | Accesses left, bottom and back wall characteristics of the Chart.
Width | Sets the Chart Width in pixels.
Zoom | Accesses the Zoom characteristics of the Chart.

See Also

Chart Class | Steema.TeeChart Namespace


Animations

Steema.TeeChart.Chart.Animations Property

Collection of Animation components contained in this Chart.
public AnimationsCollection Animations {get;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Aspect

Steema.TeeChart.Chart.Aspect Property

3D view parameters.
public Aspect Aspect {get; set;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Axes

Steema.TeeChart.Chart.Axes Property

Collection of predefined and custom axis objects.
public Axes Axes {get;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


ChartBounds

Steema.TeeChart.Chart.ChartBounds Property

Read only. Used to get the four sides of the Chart (Left, Top, Right and Bottom)
public Rectangle ChartBounds {get;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


ColorPalette

Steema.TeeChart.Chart.ColorPalette Property

public Color[] ColorPalette {get; set;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


CustomChartRect

Steema.TeeChart.Chart.CustomChartRect Property

public Boolean CustomChartRect {get; set;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Footer

Steema.TeeChart.Chart.Footer Property

Defines Text shown at the bottom of the Chart.
public Footer Footer {get;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Graphics3D

Steema.TeeChart.Chart.Graphics3D Property

Accesses TeeChart Draw properties and methods.
public Graphics3D Graphics3D {get; set;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Header

Steema.TeeChart.Chart.Header Property

Defines Text shown at top of the Chart.
public Header Header {get;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Height

Steema.TeeChart.Chart.Height Property

Sets the Chart Height in pixels.
public Int32 Height {get; set;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Item

Steema.TeeChart.Chart.Item Property

Default indexer ( Example: tChart1[0].Color=Color.Blue; is equivalent to tChart1.Series[0].Color=Color.Blue; )
public Series Item(Int32 index) {get; set;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Legend

Steema.TeeChart.Chart.Legend Property

Legend characteristics.
public Legend Legend {get;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Listeners

Steema.TeeChart.Chart.Listeners Property

Returns array list of objects that implement the ITeeEventListener interface.
public List<ITeeEventListener> Listeners {get; set;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


MaxZOrder

Steema.TeeChart.Chart.MaxZOrder Property

Run-time and read only. The MaxZOrder property indicates the Chart depth in number of Series. When Chart.View3D is True, each Series has a Z order. The Series Z order defines the order along the Z axis when Series are displayed. The MaxZOrder property is the maximum Z order of all active Series. Some Series share a same Z order (stacked Bars, stacked Areas, etc).
public Int32 MaxZOrder {get;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Page

Steema.TeeChart.Chart.Page Property

Accesses multiple page characteristics of the Chart.
public Page Page {get;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Panel

Steema.TeeChart.Chart.Panel Property

Background visible attributes.
public Panel Panel {get; set;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Panning

Steema.TeeChart.Chart.Panning Property

Sets the scrolling direction or denies scrolling.
public Scroll Panning {get;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Parent

Steema.TeeChart.Chart.Parent Property

The IChart parent of the Chart.
public IChart Parent {get; set;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


SerializedTag

Steema.TeeChart.Chart.SerializedTag Property

Holds a custom tag object.
public Object SerializedTag {get; set;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Series

Steema.TeeChart.Chart.Series Property

Collection of Series contained in this Chart.
public SeriesCollection Series {get;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


SubFooter

Steema.TeeChart.Chart.SubFooter Property

Defines Text shown directly above Footer.
public Footer SubFooter {get;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


SubHeader

Steema.TeeChart.Chart.SubHeader Property

Defines Text shown directly below Header.
public Header SubHeader {get;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


SubTitle

Steema.TeeChart.Chart.SubTitle Property

public Header SubTitle {get;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Title

Steema.TeeChart.Chart.Title Property

public Header Title {get;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Tools

Steema.TeeChart.Chart.Tools Property

Collection of Tool components contained in this Chart.
public ToolsCollection Tools {get;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


ToolTip

Steema.TeeChart.Chart.ToolTip Property

Displays a text box at the cursor.
public ChartToolTip ToolTip {get;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Walls

Steema.TeeChart.Chart.Walls Property

Accesses left, bottom and back wall characteristics of the Chart.
public Walls Walls {get;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Width

Steema.TeeChart.Chart.Width Property

Sets the Chart Width in pixels.
public Int32 Width {get; set;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Zoom

Steema.TeeChart.Chart.Zoom Property

Accesses the Zoom characteristics of the Chart.
public Zoom Zoom {get;}

See Also

Chart Class | Chart Members | Steema.TeeChart Namespace


Steema.TeeChart.Chart.ChartToolTip

Steema.TeeChart.Chart.ChartToolTip Class

Tooltips

For a list of all members of this type, see ChartToolTip Members

System.Object
public sealed class ChartToolTip : Object , IDisposable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

ChartToolTip members | Steema.TeeChart Namespace


Steema.TeeChart.Chart.ChartToolTipMembers

Steema.TeeChart.Chart.ChartToolTip all Members

ChartToolTip overview

Public Fields

Text

Public Methods

Dispose |
Hide | Hides a ToolTip.
Show | Makes Visible a ToolTip.

Constructors

Steema.TeeChart.Chart.ChartToolTip..ctor

See Also

ChartToolTip Class | Steema.TeeChart Namespace


Steema.TeeChart.Chart.ChartToolTipFields

Steema.TeeChart.Chart.ChartToolTip Fields

Public Fields

Text

See Also

ChartToolTip Class | Steema.TeeChart Namespace


Text

Steema.TeeChart.Chart+ChartToolTip.Text Field

public String Text

See Also

ChartToolTip Class | ChartToolTip Members | Steema.TeeChart Namespace


Steema.TeeChart.Chart.ChartToolTipMethods

Steema.TeeChart.Chart.ChartToolTip Methods

Public Methods

Dispose |
Hide | Hides a ToolTip.
Show | Makes Visible a ToolTip.

See Also

ChartToolTip Class | Steema.TeeChart Namespace


Dispose

Steema.TeeChart.Chart+ChartToolTip.Dispose Method

public virtual Void Dispose()

See Also

ChartToolTip Class | ChartToolTip Members | Steema.TeeChart Namespace


Hide

Steema.TeeChart.Chart+ChartToolTip.Hide Method

Hides a ToolTip.
public Void Hide()

See Also

ChartToolTip Class | ChartToolTip Members | Steema.TeeChart Namespace


Show

Steema.TeeChart.Chart+ChartToolTip.Show Method

Makes Visible a ToolTip.
public Void Show()

See Also

ChartToolTip Class | ChartToolTip Members | Steema.TeeChart Namespace


Steema.TeeChart.Chart+ChartToolTip Constructor

public Chart+ChartToolTip(Chart c)

See Also

ChartToolTip Class | ChartToolTip Members | Steema.TeeChart Namespace


Steema.TeeChart.ChartClickedPart

Steema.TeeChart.ChartClickedPart ValueType

For a list of all members of this type, see ChartClickedPart Members

System.Object
System.ValueType
public sealed struct ChartClickedPart : ValueType

See Also

ChartClickedPart Members | Steema.TeeChart Namespace


Steema.TeeChart.ChartClickedPartMembers

Steema.TeeChart.ChartClickedPart all Members

ChartClickedPart overview

Public Fields

AAxis
ASeries
Part
PointIndex

See Also

ChartClickedPart Structure | Steema.TeeChart Namespace


Steema.TeeChart.ChartClickedPartFields

Steema.TeeChart.ChartClickedPart Fields

Public Fields

AAxis
ASeries
Part
PointIndex

See Also

ChartClickedPart Structure | Steema.TeeChart Namespace


AAxis

Steema.TeeChart.ChartClickedPart.AAxis Field

public Axis AAxis

See Also

ChartClickedPart Structure | ChartClickedPart Members | Steema.TeeChart Namespace


ASeries

Steema.TeeChart.ChartClickedPart.ASeries Field

public Series ASeries

See Also

ChartClickedPart Structure | ChartClickedPart Members | Steema.TeeChart Namespace


Part

Steema.TeeChart.ChartClickedPart.Part Field

public ChartClickedPartStyle Part

See Also

ChartClickedPart Structure | ChartClickedPart Members | Steema.TeeChart Namespace


PointIndex

Steema.TeeChart.ChartClickedPart.PointIndex Field

public Int32 PointIndex

See Also

ChartClickedPart Structure | ChartClickedPart Members | Steema.TeeChart Namespace


Steema.TeeChart.ChartClickedPartStyle

Steema.TeeChart.ChartClickedPartStyle Enum

[Serializable]
public sealed enum ChartClickedPartStyle : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
None |
Legend |
Axis |
Series |
Header |
Foot |
ChartRect |
SeriesMarks |
SeriesPointer |
SubHeader |
SubFoot |
AxisTitle |

See Also

Steema.TeeChart Namespace


Steema.TeeChart.CustomAxes

Steema.TeeChart.CustomAxes Class

Used to access the Custom series List.

For a list of all members of this type, see CustomAxes Members

System.Object
System.Collections.CollectionBase
public sealed class CustomAxes : CollectionBase , IList, ICollection
, IEnumerable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

CustomAxes members | Steema.TeeChart Namespace


Steema.TeeChart.CustomAxesMembers

Steema.TeeChart.CustomAxes all Members

CustomAxes overview

Constructors

Constructor

Public Methods

Add | Adds a Custom Axis.
Clear | Removes (and optionally disposes) all Series.
IndexOf |
New | Creates and adds a custom axis to the chart.
Remove | Removes the Custom Axis of Index 'CustomAxisIndex'.
RemoveAll | Removes all Custom Axes.

Public Properties

Item

See Also

CustomAxes Class | Steema.TeeChart Namespace


Steema.TeeChart.CustomAxes Constructor

public CustomAxes()

See Also

CustomAxes Class | CustomAxes Members | Steema.TeeChart Namespace


Steema.TeeChart.CustomAxesMethods

Steema.TeeChart.CustomAxes Methods

Public Methods

Add | Adds a Custom Axis.
Clear | Removes (and optionally disposes) all Series.
IndexOf |
New | Creates and adds a custom axis to the chart.
Remove | Removes the Custom Axis of Index 'CustomAxisIndex'.
RemoveAll | Removes all Custom Axes.

See Also

CustomAxes Class | Steema.TeeChart Namespace


Add

Steema.TeeChart.CustomAxes.Add Method

Adds a Custom Axis.
public Axis Add(Axis axis)

See Also

CustomAxes Class | CustomAxes Members | Steema.TeeChart Namespace


Clear

Steema.TeeChart.CustomAxes.Clear Method

Overload List

Removes (and optionally disposes) all Series.

public Void Clear(System.Boolean)

Removes and disposes all Series.

public Void Clear()

See Also

CustomAxes Class | CustomAxes Members | Steema.TeeChart Namespace


Clear

Steema.TeeChart.CustomAxes.Clear Method

Removes and disposes all Series.
public Void Clear()

See Also

Clear Overload List | CustomAxes Class | CustomAxes Members | Steema.TeeChart Namespace


Clear

Steema.TeeChart.CustomAxes.Clear Method

Removes (and optionally disposes) all Series.
public Void Clear(Boolean dispose)

See Also

Clear Overload List | CustomAxes Class | CustomAxes Members | Steema.TeeChart Namespace


IndexOf

Steema.TeeChart.CustomAxes.IndexOf Method

public Int32 IndexOf(Axis a)

See Also

CustomAxes Class | CustomAxes Members | Steema.TeeChart Namespace


New

Steema.TeeChart.CustomAxes.New Method

Creates and adds a custom axis to the chart.
public Axis New()

See Also

CustomAxes Class | CustomAxes Members | Steema.TeeChart Namespace


Remove

Steema.TeeChart.CustomAxes.Remove Method

Removes the Custom Axis of Index 'CustomAxisIndex'.
public Void Remove(Axis a)

See Also

CustomAxes Class | CustomAxes Members | Steema.TeeChart Namespace


RemoveAll

Steema.TeeChart.CustomAxes.RemoveAll Method

Removes all Custom Axes.
public Void RemoveAll()

See Also

CustomAxes Class | CustomAxes Members | Steema.TeeChart Namespace


Steema.TeeChart.CustomAxesProperties

Steema.TeeChart.CustomAxes Properties

Public Properties

Item

See Also

CustomAxes Class | Steema.TeeChart Namespace


Item

Steema.TeeChart.CustomAxes.Item Property

public Axis Item(Int32 index) {get; set;}

See Also

CustomAxes Class | CustomAxes Members | Steema.TeeChart Namespace


Steema.TeeChart.DateTimeSteps

Steema.TeeChart.DateTimeSteps Enum

Describes a number of different DateTime steps.
[Serializable]
public sealed enum DateTimeSteps : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
OneMicrosecond | Defines a OneMicrosecond TimeSpan.
OneMillisecond | Defines a OneMillisecond TimeSpan.
OneSecond | Defines a OneSecond TimeSpan.
FiveSeconds | Defines a FiveSeconds TimeSpan.
TenSeconds | Defines a TenSeconds TimeSpan.
FifteenSeconds | Defines a FifteenSeconds TimeSpan.
ThirtySeconds | Defines a ThirtySeconds TimeSpan.
OneMinute | Defines a OneMinute TimeSpan.
FiveMinutes | Defines a FiveMinutes TimeSpan.
TenMinutes | Defines a TenMinutes TimeSpan.
FifteenMinutes | Defines a FifteenMinutes TimeSpan.
ThirtyMinutes | Defines a ThirtyMinutes TimeSpan.
OneHour | Defines a OneHour TimeSpan.
TwoHours | Defines a TwoHours TimeSpan.
SixHours | Defines a SixHours TimeSpan.
TwelveHours | Defines a TwelveHours TimeSpan.
OneDay | Defines a OneDay TimeSpan.
TwoDays | Defines a TwoDays TimeSpan.
ThreeDays | Defines a ThreeDays TimeSpan.
OneWeek | Defines a OneWeek TimeSpan.
HalfMonth | Defines a HalfMonth TimeSpan.
OneMonth | Defines a OneMonth TimeSpan.
TwoMonths | Defines a TwoMonths TimeSpan.
ThreeMonths | Defines a ThreeMonths TimeSpan.
FourMonths | Defines a FourMonths TimeSpan.
SixMonths | Defines a SixMonths TimeSpan.
OneYear | Defines a OneYear TimeSpan.
None | Defines an automatic TimeSpan.

See Also

Steema.TeeChart Namespace


Steema.TeeChart.DepthAxis

Steema.TeeChart.DepthAxis Class

Z plane Axis characteristics

For a list of all members of this type, see DepthAxis Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Axis
public class DepthAxis : Axis , ICloneable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

DepthAxis members | Steema.TeeChart Namespace


Steema.TeeChart.DepthAxisMembers

Steema.TeeChart.DepthAxis all Members

DepthAxis overview

Constructors

Constructor

Public Events

GetAxisDrawLabel (inherited from Axis)

Public Fields

Steema.TeeChart.Axis.CalcPosPoint
Steema.TeeChart.Axis.CalcPosValue
Steema.TeeChart.Axis.CalcXPosValue
Steema.TeeChart.Axis.CalcYPosValue
IAxisSize (inherited from Axis)
IEndPos (inherited from Axis)
IGapSize (inherited from Axis)
IsDepthAxis (inherited from Axis)
IStartPos (inherited from Axis)

Public Methods

AdjustMaxMin (inherited from Axis) | Calculates Maximum and Minimum values based on Max and Min values of the dependent Series.
AdjustMaxMinRect (inherited from Axis) | Called internally to recalculate the max and min values using the Rect parameter positions.
AxisRect (inherited from Axis) |
CalcLabelStyle (inherited from Axis) | Returns the most logical Axis Label style.
CalcMinMax (inherited from Axis) | Returns the minimum and maximum values of the associated Series.
CalcSizeValue (inherited from Axis) | Returns the amount in pixels of a portion of the axis of size "Value" in axis scales.
CalcXYIncrement (inherited from Axis) | Returns the calculated Axis Label increment.
Clicked (inherited from Axis) | Returns if X and Y coordinates are close to the Axis position.
Clone (inherited from Axis) |
DateTimeDefaultFormat (inherited from Axis) | Returns a Time or Date format depending if the astep parameter is lower than one day (time) or greater (date).
DateTimeIncrement (inherited from Axis) | Is a set of constants used to specify a date time increment.
Draw (inherited from Axis) | Displays an Axis at the specified screen positions with the current axis scales.
DrawAxisLabel (inherited from Axis) | Draws Axis Label (string) at specified X,Y co-ordinate at Angle.
DrawTitle (inherited from Axis) | TeeChart internal use. Outputs the title during the chart painting procedure.
InternalCalcPosPoint (inherited from Axis) | Returns the corresponding value of a Screen position.
InternalCalcRange (inherited from Axis) | Internal use.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsCustom (inherited from Axis) | Returns true if Axis is a Custom Axis
MaxLabelsWidth (inherited from Axis) | Returns the maximum width in pixels of all Axis Labels.
Scroll (inherited from Axis) | Dispaces Axis Minimum and Maximum values.
SetCalcPosValue (inherited from Axis) | Advanced use. Requests the Axis to re-check assigned calculation methods
SetMinMax (inherited from Axis) | Changes the Axis Minimum and Maximum scales.
TitleOrName (inherited from Axis) |

Public Properties

Automatic (inherited from Axis) | Calculates Max and Min of axis scale based on associated Series.
AutomaticMaximum (inherited from Axis) | Controls maximum value automatically based on the maximum value of its associated Series.
AutomaticMinimum (inherited from Axis) | Controls minimum value automatically based on the minimum value of its associated Series.
AxisPen (inherited from Axis) | Determines the kind of pen used to draw the Axes.
CalcIncrement (inherited from Axis) | Returns the calculated Axis Label increment.
Chart (inherited from TeeBase) | Chart associated with this object
EndPosition (inherited from Axis) | Axis End position as percentage of Chart.
Grid (inherited from Axis) | Determines the pen used to draw the Chart Grid.
GridCentered (inherited from Axis) |
Horizontal (inherited from Axis) | Sets a custom axis to be drawn horizontally.
Increment (inherited from Axis) | Is the minimum step between axis labels. Can use DateTimeSteps for date-time axis.
IncrementOffset (inherited from Axis) | The offset applied to the Increment property. If Increment is 10 and IncrementOffset is 5, axis labels drawn (5, 15, 25 etc.).
Inverted (inherited from Axis) | Swaps the Axis Minimum and Maximum scales.
IsDateTime (inherited from Axis) | An axis is "DateTime" if at least one Active Series with datetime values is associated to it
Labels (inherited from Axis) | Accesses the Label characteristics of Axis Labels.
LabelsAsSeriesTitles | Gets or sets whether label Text set as Series title or as point labels.
LabelsOnAxis (inherited from Axis) |
Logarithmic (inherited from Axis) | Scales the Axis Logarithmically when True.
LogarithmicBase (inherited from Axis) | Sets the base for the Logarithmic scale when Axis Logarithmic = True.
Maximum (inherited from Axis) | Sets Axis Maximum value.
MaximumOffset (inherited from Axis) | The amount of pixels that will be left as a margin at axis maximum position.
MaximumRound (inherited from Axis) | Rounds Axis Maximum to nearest Integer value.
MaxXValue (inherited from Axis) | Maximum X value for the specified Axis.
MaxYValue (inherited from Axis) | Maximum Y value for the specified Axis.
MinAxisIncrement (inherited from Axis) | Advanced use. Smallest Axis calculation increment. Default: 1e-12
Minimum (inherited from Axis) | Sets Axis Minimum value.
MinimumOffset (inherited from Axis) | Pixels separation at axis minimum.
MinimumRound (inherited from Axis) | Rounds Axis Minimum to nearest Integer value.
MinorGrid (inherited from Axis) | Sets characteristics of the Grid coincidental to Minor Ticks.
MinorTickCount (inherited from Axis) | Determines the number of Axis minor ticks between major ticks.
MinorTicks (inherited from Axis) | Determines the Pen used to draw the Axis Minor ticks.
MinXValue (inherited from Axis) | Minimum X value for the specified Axis.
MinYValue (inherited from Axis) | Minimum Y value for the specified Axis.
OtherSide (inherited from Axis) | Sets the Axis to Otherside (Left or Right, Top or Bottom)
PartnerAxis (inherited from Axis) | Use this property when UsePartnerAxis is set to True to define an Axis pair whose bounding rectangle will limit the plotted Gridilines for either Axis. It is possible to have a one sided partnership where only one of the two Axes limits its Gridline plot.
PosAxis (inherited from Axis) | Please use Position property.
Position (inherited from Axis) | Sets the screen co-ordinate where axis is drawn.
PositionUnits (inherited from Axis) | Defines Position units (pixels or percentage) for the RelativePosition property.
RelativePosition (inherited from Axis) | Axis position relative to Chart.
StartEndPositionUnits (inherited from Axis) | Defines Position units (pixels or percentage) for the StartPosition and EndPosition properties.
StartPosition (inherited from Axis) | Axis Start position as percentage of Chart.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickOnLabelsOnly (inherited from Axis) | Sets the Axis Ticks and Axis Grid to be drawn at Labels only.
Ticks (inherited from Axis) | Determines the Pen used to draw Axis marks along the Axis line.
TicksInner (inherited from Axis) | Determines the Pen used to draw Axis marks inside the Axis line.
Title (inherited from Axis) | Title attributes
TitleSize (inherited from Axis) |
UsePartnerAxis (inherited from Axis) | When True and PartnerAxis is set to the value of a valid Axis, Axis GridlInes will zone to the bounding rectangle of the two Partner Axes. It is possible to have a one sided partnership where only one of the two Axes limits its Gridline plot.
Visible | Shows or hides the Depth Axis.
ZoomLimitToAxisBounds (inherited from Axis) | When true, zooms associated to this axis will not exceed the standard axis scale. This can be useful for multi axis charts to avoid a zoom on a neighbouring axis sending the associated contents of this Axis out of bounds.
ZPosition (inherited from Axis) | Determines the Z axis position along chart Depth

See Also

DepthAxis Class | Steema.TeeChart Namespace


Steema.TeeChart.DepthAxis Constructor

public DepthAxis(Boolean horiz,
     Boolean isOtherSide,
     Chart c)

See Also

DepthAxis Class | DepthAxis Members | Steema.TeeChart Namespace


Steema.TeeChart.DepthAxisEvents

Steema.TeeChart.DepthAxis Events

Public Events

GetAxisDrawLabel (inherited from Axis)

See Also

DepthAxis Class | Steema.TeeChart Namespace


Steema.TeeChart.DepthAxisFields

Steema.TeeChart.DepthAxis Fields

Public Fields

Steema.TeeChart.Axis.CalcPosPoint
Steema.TeeChart.Axis.CalcPosValue
Steema.TeeChart.Axis.CalcXPosValue
Steema.TeeChart.Axis.CalcYPosValue
IAxisSize (inherited from Axis)
IEndPos (inherited from Axis)
IGapSize (inherited from Axis)
IsDepthAxis (inherited from Axis)
IStartPos (inherited from Axis)

See Also

DepthAxis Class | Steema.TeeChart Namespace


Steema.TeeChart.DepthAxisMethods

Steema.TeeChart.DepthAxis Methods

Public Methods

AdjustMaxMin (inherited from Axis) | Calculates Maximum and Minimum values based on Max and Min values of the dependent Series.
AdjustMaxMinRect (inherited from Axis) | Called internally to recalculate the max and min values using the Rect parameter positions.
AxisRect (inherited from Axis) |
CalcLabelStyle (inherited from Axis) | Returns the most logical Axis Label style.
CalcMinMax (inherited from Axis) | Returns the minimum and maximum values of the associated Series.
CalcSizeValue (inherited from Axis) | Returns the amount in pixels of a portion of the axis of size "Value" in axis scales.
CalcXYIncrement (inherited from Axis) | Returns the calculated Axis Label increment.
Clicked (inherited from Axis) | Returns if X and Y coordinates are close to the Axis position.
Clone (inherited from Axis) |
DateTimeDefaultFormat (inherited from Axis) | Returns a Time or Date format depending if the astep parameter is lower than one day (time) or greater (date).
DateTimeIncrement (inherited from Axis) | Is a set of constants used to specify a date time increment.
Draw (inherited from Axis) | Displays an Axis at the specified screen positions with the current axis scales.
DrawAxisLabel (inherited from Axis) | Draws Axis Label (string) at specified X,Y co-ordinate at Angle.
DrawTitle (inherited from Axis) | TeeChart internal use. Outputs the title during the chart painting procedure.
InternalCalcPosPoint (inherited from Axis) | Returns the corresponding value of a Screen position.
InternalCalcRange (inherited from Axis) | Internal use.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsCustom (inherited from Axis) | Returns true if Axis is a Custom Axis
MaxLabelsWidth (inherited from Axis) | Returns the maximum width in pixels of all Axis Labels.
Scroll (inherited from Axis) | Dispaces Axis Minimum and Maximum values.
SetCalcPosValue (inherited from Axis) | Advanced use. Requests the Axis to re-check assigned calculation methods
SetMinMax (inherited from Axis) | Changes the Axis Minimum and Maximum scales.
TitleOrName (inherited from Axis) |

See Also

DepthAxis Class | Steema.TeeChart Namespace


Steema.TeeChart.DepthAxisProperties

Steema.TeeChart.DepthAxis Properties

Public Properties

Automatic (inherited from Axis) | Calculates Max and Min of axis scale based on associated Series.
AutomaticMaximum (inherited from Axis) | Controls maximum value automatically based on the maximum value of its associated Series.
AutomaticMinimum (inherited from Axis) | Controls minimum value automatically based on the minimum value of its associated Series.
AxisPen (inherited from Axis) | Determines the kind of pen used to draw the Axes.
CalcIncrement (inherited from Axis) | Returns the calculated Axis Label increment.
Chart (inherited from TeeBase) | Chart associated with this object
EndPosition (inherited from Axis) | Axis End position as percentage of Chart.
Grid (inherited from Axis) | Determines the pen used to draw the Chart Grid.
GridCentered (inherited from Axis) |
Horizontal (inherited from Axis) | Sets a custom axis to be drawn horizontally.
Increment (inherited from Axis) | Is the minimum step between axis labels. Can use DateTimeSteps for date-time axis.
IncrementOffset (inherited from Axis) | The offset applied to the Increment property. If Increment is 10 and IncrementOffset is 5, axis labels drawn (5, 15, 25 etc.).
Inverted (inherited from Axis) | Swaps the Axis Minimum and Maximum scales.
IsDateTime (inherited from Axis) | An axis is "DateTime" if at least one Active Series with datetime values is associated to it
Labels (inherited from Axis) | Accesses the Label characteristics of Axis Labels.
LabelsAsSeriesTitles | Gets or sets whether label Text set as Series title or as point labels.
LabelsOnAxis (inherited from Axis) |
Logarithmic (inherited from Axis) | Scales the Axis Logarithmically when True.
LogarithmicBase (inherited from Axis) | Sets the base for the Logarithmic scale when Axis Logarithmic = True.
Maximum (inherited from Axis) | Sets Axis Maximum value.
MaximumOffset (inherited from Axis) | The amount of pixels that will be left as a margin at axis maximum position.
MaximumRound (inherited from Axis) | Rounds Axis Maximum to nearest Integer value.
MaxXValue (inherited from Axis) | Maximum X value for the specified Axis.
MaxYValue (inherited from Axis) | Maximum Y value for the specified Axis.
MinAxisIncrement (inherited from Axis) | Advanced use. Smallest Axis calculation increment. Default: 1e-12
Minimum (inherited from Axis) | Sets Axis Minimum value.
MinimumOffset (inherited from Axis) | Pixels separation at axis minimum.
MinimumRound (inherited from Axis) | Rounds Axis Minimum to nearest Integer value.
MinorGrid (inherited from Axis) | Sets characteristics of the Grid coincidental to Minor Ticks.
MinorTickCount (inherited from Axis) | Determines the number of Axis minor ticks between major ticks.
MinorTicks (inherited from Axis) | Determines the Pen used to draw the Axis Minor ticks.
MinXValue (inherited from Axis) | Minimum X value for the specified Axis.
MinYValue (inherited from Axis) | Minimum Y value for the specified Axis.
OtherSide (inherited from Axis) | Sets the Axis to Otherside (Left or Right, Top or Bottom)
PartnerAxis (inherited from Axis) | Use this property when UsePartnerAxis is set to True to define an Axis pair whose bounding rectangle will limit the plotted Gridilines for either Axis. It is possible to have a one sided partnership where only one of the two Axes limits its Gridline plot.
PosAxis (inherited from Axis) | Please use Position property.
Position (inherited from Axis) | Sets the screen co-ordinate where axis is drawn.
PositionUnits (inherited from Axis) | Defines Position units (pixels or percentage) for the RelativePosition property.
RelativePosition (inherited from Axis) | Axis position relative to Chart.
StartEndPositionUnits (inherited from Axis) | Defines Position units (pixels or percentage) for the StartPosition and EndPosition properties.
StartPosition (inherited from Axis) | Axis Start position as percentage of Chart.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickOnLabelsOnly (inherited from Axis) | Sets the Axis Ticks and Axis Grid to be drawn at Labels only.
Ticks (inherited from Axis) | Determines the Pen used to draw Axis marks along the Axis line.
TicksInner (inherited from Axis) | Determines the Pen used to draw Axis marks inside the Axis line.
Title (inherited from Axis) | Title attributes
TitleSize (inherited from Axis) |
UsePartnerAxis (inherited from Axis) | When True and PartnerAxis is set to the value of a valid Axis, Axis GridlInes will zone to the bounding rectangle of the two Partner Axes. It is possible to have a one sided partnership where only one of the two Axes limits its Gridline plot.
Visible | Shows or hides the Depth Axis.
ZoomLimitToAxisBounds (inherited from Axis) | When true, zooms associated to this axis will not exceed the standard axis scale. This can be useful for multi axis charts to avoid a zoom on a neighbouring axis sending the associated contents of this Axis out of bounds.
ZPosition (inherited from Axis) | Determines the Z axis position along chart Depth

See Also

DepthAxis Class | Steema.TeeChart Namespace


LabelsAsSeriesTitles

Steema.TeeChart.DepthAxis.LabelsAsSeriesTitles Property

Gets or sets whether label Text set as Series title or as point labels.
public Boolean LabelsAsSeriesTitles {get; set;}

See Also

DepthAxis Class | DepthAxis Members | Steema.TeeChart Namespace


Visible

Steema.TeeChart.DepthAxis.Visible Property

Shows or hides the Depth Axis.
public Boolean Visible {get; set;}

See Also

DepthAxis Class | DepthAxis Members | Steema.TeeChart Namespace


Steema.TeeChart.DrawAxisEventDelegate

Steema.TeeChart.DrawAxisEventDelegate Delegate

public delegate DrawAxisEventDelegate ()

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart Namespace


Steema.TeeChart.Footer

Steema.TeeChart.Footer Class

Text displayed below Chart

For a list of all members of this type, see Footer Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
Steema.TeeChart.Drawing.TextShapePosition
Steema.TeeChart.Title
public class Footer : Title , ICloneable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Footer members | Steema.TeeChart Namespace


Steema.TeeChart.FooterMembers

Steema.TeeChart.Footer all Members

Footer overview

Constructors

Constructor Overloaded

Public Fields

Size (inherited from TextShape)

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clicked (inherited from Title) | Returns if mouse cursor is inside TChartTitle bound rectangle.
Clone (inherited from Shape) |
DoDraw (inherited from Title) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.

Public Properties

AdjustFrame (inherited from Title) | Resizes Header and Footer frames to full Chart dimensions when True.
Alignment (inherited from Title) | Sets how TChart Header and Footer text will be aligned within Chart rectangle.
AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
CustomPosition (inherited from TextShapePosition) | Set to true to permit custom positioning of TextShape.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Title) | Gets/Sets Left position of Header or Footer Text.
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Title) | Gets/Sets Top position of Header or Footer Text.
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

Footer Class | Steema.TeeChart Namespace


Steema.TeeChart.Footer Constructor

Overload List

public Footer()
public Footer(Steema.TeeChart.Chart)
public Footer(Steema.TeeChart.Chart, System.Boolean)

See Also

Footer Class | Footer Members | Steema.TeeChart Namespace


Steema.TeeChart.Footer Constructor

public Footer(Chart c,
     Boolean startVisible)

See Also

Footer Constructor Overload List | Footer Class | Footer Members | Steema.TeeChart Namespace


Steema.TeeChart.Footer Constructor

public Footer(Chart c)

See Also

Footer Constructor Overload List | Footer Class | Footer Members | Steema.TeeChart Namespace


Steema.TeeChart.Footer Constructor

public Footer()

See Also

Footer Constructor Overload List | Footer Class | Footer Members | Steema.TeeChart Namespace


Steema.TeeChart.FooterFields

Steema.TeeChart.Footer Fields

Public Fields

Size (inherited from TextShape)

See Also

Footer Class | Steema.TeeChart Namespace


Steema.TeeChart.FooterMethods

Steema.TeeChart.Footer Methods

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clicked (inherited from Title) | Returns if mouse cursor is inside TChartTitle bound rectangle.
Clone (inherited from Shape) |
DoDraw (inherited from Title) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.

See Also

Footer Class | Steema.TeeChart Namespace


Steema.TeeChart.FooterProperties

Steema.TeeChart.Footer Properties

Public Properties

AdjustFrame (inherited from Title) | Resizes Header and Footer frames to full Chart dimensions when True.
Alignment (inherited from Title) | Sets how TChart Header and Footer text will be aligned within Chart rectangle.
AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
CustomPosition (inherited from TextShapePosition) | Set to true to permit custom positioning of TextShape.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Title) | Gets/Sets Left position of Header or Footer Text.
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Title) | Gets/Sets Top position of Header or Footer Text.
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

Footer Class | Steema.TeeChart Namespace


Steema.TeeChart.GetAxesChartRectEventArgs

Steema.TeeChart.GetAxesChartRectEventArgs Class

For a list of all members of this type, see GetAxesChartRectEventArgs Members

System.Object
System.EventArgs
public class GetAxesChartRectEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

GetAxesChartRectEventArgs members | Steema.TeeChart Namespace


Steema.TeeChart.GetAxesChartRectEventArgsMembers

Steema.TeeChart.GetAxesChartRectEventArgs all Members

GetAxesChartRectEventArgs overview

Constructors

Constructor

Public Properties

AxesChartRect

See Also

GetAxesChartRectEventArgs Class | Steema.TeeChart Namespace


Steema.TeeChart.GetAxesChartRectEventArgs Constructor

public GetAxesChartRectEventArgs(Rectangle rect)

See Also

GetAxesChartRectEventArgs Class | GetAxesChartRectEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.GetAxesChartRectEventArgsProperties

Steema.TeeChart.GetAxesChartRectEventArgs Properties

Public Properties

AxesChartRect

See Also

GetAxesChartRectEventArgs Class | Steema.TeeChart Namespace


AxesChartRect

Steema.TeeChart.GetAxesChartRectEventArgs.AxesChartRect Property

public Rectangle AxesChartRect {get; set;}

See Also

GetAxesChartRectEventArgs Class | GetAxesChartRectEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.GetAxesChartRectEventHandler

Steema.TeeChart.GetAxesChartRectEventHandler Delegate

public delegate GetAxesChartRectEventHandler (Object sender,
     GetAxesChartRectEventArgs e)

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart Namespace


Steema.TeeChart.GetAxisDrawLabelEventArgs

Steema.TeeChart.GetAxisDrawLabelEventArgs Class

For a list of all members of this type, see GetAxisDrawLabelEventArgs Members

System.Object
System.EventArgs
public class GetAxisDrawLabelEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

GetAxisDrawLabelEventArgs members | Steema.TeeChart Namespace


Steema.TeeChart.GetAxisDrawLabelEventArgsMembers

Steema.TeeChart.GetAxisDrawLabelEventArgs all Members

GetAxisDrawLabelEventArgs overview

Constructors

Constructor

Public Properties

DrawLabel | Draws the label when set to true.
Text |
X |
Y |
Z |

See Also

GetAxisDrawLabelEventArgs Class | Steema.TeeChart Namespace


Steema.TeeChart.GetAxisDrawLabelEventArgs Constructor

public GetAxisDrawLabelEventArgs(Int32 X,
     Int32 Y,
     Int32 Z,
     String Text,
     Boolean DrawLabel)

See Also

GetAxisDrawLabelEventArgs Class | GetAxisDrawLabelEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.GetAxisDrawLabelEventArgsProperties

Steema.TeeChart.GetAxisDrawLabelEventArgs Properties

Public Properties

DrawLabel | Draws the label when set to true.
Text |
X |
Y |
Z |

See Also

GetAxisDrawLabelEventArgs Class | Steema.TeeChart Namespace


DrawLabel

Steema.TeeChart.GetAxisDrawLabelEventArgs.DrawLabel Property

Draws the label when set to true.
public Boolean DrawLabel {get; set;}

See Also

GetAxisDrawLabelEventArgs Class | GetAxisDrawLabelEventArgs Members | Steema.TeeChart Namespace


Text

Steema.TeeChart.GetAxisDrawLabelEventArgs.Text Property

public String Text {get; set;}

See Also

GetAxisDrawLabelEventArgs Class | GetAxisDrawLabelEventArgs Members | Steema.TeeChart Namespace


X

Steema.TeeChart.GetAxisDrawLabelEventArgs.X Property

public Int32 X {get; set;}

See Also

GetAxisDrawLabelEventArgs Class | GetAxisDrawLabelEventArgs Members | Steema.TeeChart Namespace


Y

Steema.TeeChart.GetAxisDrawLabelEventArgs.Y Property

public Int32 Y {get; set;}

See Also

GetAxisDrawLabelEventArgs Class | GetAxisDrawLabelEventArgs Members | Steema.TeeChart Namespace


Z

Steema.TeeChart.GetAxisDrawLabelEventArgs.Z Property

public Int32 Z {get; set;}

See Also

GetAxisDrawLabelEventArgs Class | GetAxisDrawLabelEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.GetAxisDrawLabelEventHandler

Steema.TeeChart.GetAxisDrawLabelEventHandler Delegate

public delegate GetAxisDrawLabelEventHandler (Object sender,
     GetAxisDrawLabelEventArgs e)

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart Namespace


Steema.TeeChart.GetAxisLabelEventArgs

Steema.TeeChart.GetAxisLabelEventArgs Class

Axis Label EventArgs. See GetAxisLabelEventHandler

For a list of all members of this type, see GetAxisLabelEventArgs Members

System.Object
System.EventArgs
public class GetAxisLabelEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

GetAxisLabelEventArgs members | Steema.TeeChart Namespace


Steema.TeeChart.GetAxisLabelEventArgsMembers

Steema.TeeChart.GetAxisLabelEventArgs all Members

GetAxisLabelEventArgs overview

Constructors

Constructor

Public Properties

LabelText | Modifies the Axis Label text.
Series | Read only. Label Series
ValueIndex | Read only. Index of Label

See Also

GetAxisLabelEventArgs Class | Steema.TeeChart Namespace


Steema.TeeChart.GetAxisLabelEventArgs Constructor

public GetAxisLabelEventArgs(Series s,
     Int32 valueIndex,
     String labelText)

See Also

GetAxisLabelEventArgs Class | GetAxisLabelEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.GetAxisLabelEventArgsProperties

Steema.TeeChart.GetAxisLabelEventArgs Properties

Public Properties

LabelText | Modifies the Axis Label text.
Series | Read only. Label Series
ValueIndex | Read only. Index of Label

See Also

GetAxisLabelEventArgs Class | Steema.TeeChart Namespace


LabelText

Steema.TeeChart.GetAxisLabelEventArgs.LabelText Property

Modifies the Axis Label text.
public String LabelText {get; set;}

See Also

GetAxisLabelEventArgs Class | GetAxisLabelEventArgs Members | Steema.TeeChart Namespace


Series

Steema.TeeChart.GetAxisLabelEventArgs.Series Property

Read only. Label Series
public Series Series {get;}

See Also

GetAxisLabelEventArgs Class | GetAxisLabelEventArgs Members | Steema.TeeChart Namespace


ValueIndex

Steema.TeeChart.GetAxisLabelEventArgs.ValueIndex Property

Read only. Index of Label
public Int32 ValueIndex {get;}

See Also

GetAxisLabelEventArgs Class | GetAxisLabelEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.GetAxisLabelEventHandler

Steema.TeeChart.GetAxisLabelEventHandler Delegate

AxisLabel event handler
public delegate GetAxisLabelEventHandler (Object sender,
     GetAxisLabelEventArgs e)

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart Namespace


Steema.TeeChart.GetLegendPosEventArgs

Steema.TeeChart.GetLegendPosEventArgs Class

Legend Position EventArgs. See GetLegendPosEventHandler

For a list of all members of this type, see GetLegendPosEventArgs Members

System.Object
System.EventArgs
public class GetLegendPosEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

GetLegendPosEventArgs members | Steema.TeeChart Namespace


Steema.TeeChart.GetLegendPosEventArgsMembers

Steema.TeeChart.GetLegendPosEventArgs all Members

GetLegendPosEventArgs overview

Constructors

Constructor

Public Properties

Index
X
XColor
Y

See Also

GetLegendPosEventArgs Class | Steema.TeeChart Namespace


Steema.TeeChart.GetLegendPosEventArgs Constructor

public GetLegendPosEventArgs(Int32 index,
     Int32 x,
     Int32 y,
     Int32 xColor)

See Also

GetLegendPosEventArgs Class | GetLegendPosEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.GetLegendPosEventArgsProperties

Steema.TeeChart.GetLegendPosEventArgs Properties

Public Properties

Index
X
XColor
Y

See Also

GetLegendPosEventArgs Class | Steema.TeeChart Namespace


Index

Steema.TeeChart.GetLegendPosEventArgs.Index Property

public Int32 Index {get;}

See Also

GetLegendPosEventArgs Class | GetLegendPosEventArgs Members | Steema.TeeChart Namespace


X

Steema.TeeChart.GetLegendPosEventArgs.X Property

public Int32 X {get; set;}

See Also

GetLegendPosEventArgs Class | GetLegendPosEventArgs Members | Steema.TeeChart Namespace


XColor

Steema.TeeChart.GetLegendPosEventArgs.XColor Property

public Int32 XColor {get; set;}

See Also

GetLegendPosEventArgs Class | GetLegendPosEventArgs Members | Steema.TeeChart Namespace


Y

Steema.TeeChart.GetLegendPosEventArgs.Y Property

public Int32 Y {get; set;}

See Also

GetLegendPosEventArgs Class | GetLegendPosEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.GetLegendPosEventHandler

Steema.TeeChart.GetLegendPosEventHandler Delegate

GetLegendPos event handler
public delegate GetLegendPosEventHandler (Object sender,
     GetLegendPosEventArgs e)

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart Namespace


Steema.TeeChart.GetLegendRectEventArgs

Steema.TeeChart.GetLegendRectEventArgs Class

Legend Rectangle EventArgs. See GetLegendRectEventHandler

For a list of all members of this type, see GetLegendRectEventArgs Members

System.Object
System.EventArgs
public class GetLegendRectEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

GetLegendRectEventArgs members | Steema.TeeChart Namespace


Steema.TeeChart.GetLegendRectEventArgsMembers

Steema.TeeChart.GetLegendRectEventArgs all Members

GetLegendRectEventArgs overview

Constructors

Constructor

Public Properties

Rectangle

See Also

GetLegendRectEventArgs Class | Steema.TeeChart Namespace


Steema.TeeChart.GetLegendRectEventArgs Constructor

public GetLegendRectEventArgs(Rectangle rect)

See Also

GetLegendRectEventArgs Class | GetLegendRectEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.GetLegendRectEventArgsProperties

Steema.TeeChart.GetLegendRectEventArgs Properties

Public Properties

Rectangle

See Also

GetLegendRectEventArgs Class | Steema.TeeChart Namespace


Rectangle

Steema.TeeChart.GetLegendRectEventArgs.Rectangle Property

public Rectangle Rectangle {get; set;}

See Also

GetLegendRectEventArgs Class | GetLegendRectEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.GetLegendRectEventHandler

Steema.TeeChart.GetLegendRectEventHandler Delegate

GetLegendRect event handler
public delegate GetLegendRectEventHandler (Object sender,
     GetLegendRectEventArgs e)

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart Namespace


Steema.TeeChart.GetLegendTextEventArgs

Steema.TeeChart.GetLegendTextEventArgs Class

Legend Text EventArgs. See GetLegendTextEventHandler

For a list of all members of this type, see GetLegendTextEventArgs Members

System.Object
System.EventArgs
public class GetLegendTextEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

GetLegendTextEventArgs members | Steema.TeeChart Namespace


Steema.TeeChart.GetLegendTextEventArgsMembers

Steema.TeeChart.GetLegendTextEventArgs all Members

GetLegendTextEventArgs overview

Constructors

Constructor

Public Properties

Index |
LegendStyle |
Text | Sets the Text for the Legend values.

See Also

GetLegendTextEventArgs Class | Steema.TeeChart Namespace


Steema.TeeChart.GetLegendTextEventArgs Constructor

public GetLegendTextEventArgs(LegendStyles legendStyle,
     Int32 index,
     String text)

See Also

GetLegendTextEventArgs Class | GetLegendTextEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.GetLegendTextEventArgsProperties

Steema.TeeChart.GetLegendTextEventArgs Properties

Public Properties

Index |
LegendStyle |
Text | Sets the Text for the Legend values.

See Also

GetLegendTextEventArgs Class | Steema.TeeChart Namespace


Index

Steema.TeeChart.GetLegendTextEventArgs.Index Property

public Int32 Index {get;}

See Also

GetLegendTextEventArgs Class | GetLegendTextEventArgs Members | Steema.TeeChart Namespace


LegendStyle

Steema.TeeChart.GetLegendTextEventArgs.LegendStyle Property

public LegendStyles LegendStyle {get;}

See Also

GetLegendTextEventArgs Class | GetLegendTextEventArgs Members | Steema.TeeChart Namespace


Text

Steema.TeeChart.GetLegendTextEventArgs.Text Property

Sets the Text for the Legend values.
public String Text {get; set;}

See Also

GetLegendTextEventArgs Class | GetLegendTextEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.GetLegendTextEventHandler

Steema.TeeChart.GetLegendTextEventHandler Delegate

GetLegendText event handler
public delegate GetLegendTextEventHandler (Object sender,
     GetLegendTextEventArgs e)

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart Namespace


Steema.TeeChart.GetNextAxisLabelEventArgs

Steema.TeeChart.GetNextAxisLabelEventArgs Class

'Get Next' Axis Label EventArgs. See GetNextAxisLabelEventHandler

For a list of all members of this type, see GetNextAxisLabelEventArgs Members

System.Object
System.EventArgs
public class GetNextAxisLabelEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

GetNextAxisLabelEventArgs members | Steema.TeeChart Namespace


Steema.TeeChart.GetNextAxisLabelEventArgsMembers

Steema.TeeChart.GetNextAxisLabelEventArgs all Members

GetNextAxisLabelEventArgs overview

Constructors

Constructor

Public Properties

LabelIndex
LabelValue
Stop

See Also

GetNextAxisLabelEventArgs Class | Steema.TeeChart Namespace


Steema.TeeChart.GetNextAxisLabelEventArgs Constructor

public GetNextAxisLabelEventArgs(Int32 labelIndex,
     Double labelValue,
     Boolean doStop)

See Also

GetNextAxisLabelEventArgs Class | GetNextAxisLabelEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.GetNextAxisLabelEventArgsProperties

Steema.TeeChart.GetNextAxisLabelEventArgs Properties

Public Properties

LabelIndex
LabelValue
Stop

See Also

GetNextAxisLabelEventArgs Class | Steema.TeeChart Namespace


LabelIndex

Steema.TeeChart.GetNextAxisLabelEventArgs.LabelIndex Property

public Int32 LabelIndex {get;}

See Also

GetNextAxisLabelEventArgs Class | GetNextAxisLabelEventArgs Members | Steema.TeeChart Namespace


LabelValue

Steema.TeeChart.GetNextAxisLabelEventArgs.LabelValue Property

public Double LabelValue {get; set;}

See Also

GetNextAxisLabelEventArgs Class | GetNextAxisLabelEventArgs Members | Steema.TeeChart Namespace


Stop

Steema.TeeChart.GetNextAxisLabelEventArgs.Stop Property

public Boolean Stop {get; set;}

See Also

GetNextAxisLabelEventArgs Class | GetNextAxisLabelEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.GetNextAxisLabelEventHandler

Steema.TeeChart.GetNextAxisLabelEventHandler Delegate

GetNextAxisLabel event handler
public delegate GetNextAxisLabelEventHandler (Object sender,
     GetNextAxisLabelEventArgs e)

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart Namespace


Steema.TeeChart.Header

Steema.TeeChart.Header Class

Text displayed above Chart

For a list of all members of this type, see Header Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
Steema.TeeChart.Drawing.TextShapePosition
Steema.TeeChart.Title
public class Header : Title , ICloneable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Header members | Steema.TeeChart Namespace


Steema.TeeChart.HeaderMembers

Steema.TeeChart.Header all Members

Header overview

Constructors

Constructor Overloaded

Public Fields

Size (inherited from TextShape)

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clicked (inherited from Title) | Returns if mouse cursor is inside TChartTitle bound rectangle.
Clone (inherited from Shape) |
DoDraw (inherited from Title) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.

Public Properties

AdjustFrame (inherited from Title) | Resizes Header and Footer frames to full Chart dimensions when True.
Alignment (inherited from Title) | Sets how TChart Header and Footer text will be aligned within Chart rectangle.
AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
CustomPosition (inherited from TextShapePosition) | Set to true to permit custom positioning of TextShape.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Title) | Gets/Sets Left position of Header or Footer Text.
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Title) | Gets/Sets Top position of Header or Footer Text.
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

Header Class | Steema.TeeChart Namespace


Steema.TeeChart.Header Constructor

Overload List

public Header()
public Header(Steema.TeeChart.Chart)
public Header(Steema.TeeChart.Chart, System.Boolean)

See Also

Header Class | Header Members | Steema.TeeChart Namespace


Steema.TeeChart.Header Constructor

public Header(Chart c,
     Boolean startVisible)

See Also

Header Constructor Overload List | Header Class | Header Members | Steema.TeeChart Namespace


Steema.TeeChart.Header Constructor

public Header(Chart c)

See Also

Header Constructor Overload List | Header Class | Header Members | Steema.TeeChart Namespace


Steema.TeeChart.Header Constructor

public Header()

See Also

Header Constructor Overload List | Header Class | Header Members | Steema.TeeChart Namespace


Steema.TeeChart.HeaderFields

Steema.TeeChart.Header Fields

Public Fields

Size (inherited from TextShape)

See Also

Header Class | Steema.TeeChart Namespace


Steema.TeeChart.HeaderMethods

Steema.TeeChart.Header Methods

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clicked (inherited from Title) | Returns if mouse cursor is inside TChartTitle bound rectangle.
Clone (inherited from Shape) |
DoDraw (inherited from Title) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.

See Also

Header Class | Steema.TeeChart Namespace


Steema.TeeChart.HeaderProperties

Steema.TeeChart.Header Properties

Public Properties

AdjustFrame (inherited from Title) | Resizes Header and Footer frames to full Chart dimensions when True.
Alignment (inherited from Title) | Sets how TChart Header and Footer text will be aligned within Chart rectangle.
AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
CustomPosition (inherited from TextShapePosition) | Set to true to permit custom positioning of TextShape.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Title) | Gets/Sets Left position of Header or Footer Text.
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Title) | Gets/Sets Top position of Header or Footer Text.
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

Header Class | Steema.TeeChart Namespace


Steema.TeeChart.IChart

Steema.TeeChart.IChart Interface

Common Chart characteristics interface
public interface IChart

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

IChart members | Steema.TeeChart Namespace


Steema.TeeChart.IChartMembers

Steema.TeeChart.IChart all Members

IChart overview

Public Methods

AssignGetAxisLabel
AssignScrollMod
CheckBackground
CheckClickSeries
CheckGetAxisLabelAssigned
CheckGetNextAxisLabelAssigned
CheckTitle
DoAfterDraw
DoAllowScroll
DoBeforeDraw
DoBeforeDrawAxes
DoBeforeDrawSeries
DoClickAxis
DoClickLegend
DoClickSeries
DoGetAxesChartRect
DoGetAxisLabel
DoGetLegendPos
DoGetLegendRectangle
DoGetLegendSize
DoGetLegendText
DoGetNextAxisLabel
DoInvalidate
DoScroll
DoScrollMod
DoSetControlStyle
DoUndoneZoom
DoZoomed
DrawBackColor
FindParentForm
GetControl
GetCursor
IsWebForm
PointToScreen
RefreshControl
SetChart
SetCursor

See Also

IChart Interface | Steema.TeeChart Namespace


Steema.TeeChart.IChartMethods

Steema.TeeChart.IChart Methods

Public Methods

AssignGetAxisLabel
AssignScrollMod
CheckBackground
CheckClickSeries
CheckGetAxisLabelAssigned
CheckGetNextAxisLabelAssigned
CheckTitle
DoAfterDraw
DoAllowScroll
DoBeforeDraw
DoBeforeDrawAxes
DoBeforeDrawSeries
DoClickAxis
DoClickLegend
DoClickSeries
DoGetAxesChartRect
DoGetAxisLabel
DoGetLegendPos
DoGetLegendRectangle
DoGetLegendSize
DoGetLegendText
DoGetNextAxisLabel
DoInvalidate
DoScroll
DoScrollMod
DoSetControlStyle
DoUndoneZoom
DoZoomed
DrawBackColor
FindParentForm
GetControl
GetCursor
IsWebForm
PointToScreen
RefreshControl
SetChart
SetCursor

See Also

IChart Interface | Steema.TeeChart Namespace


AssignGetAxisLabel

Steema.TeeChart.IChart.AssignGetAxisLabel Method

public abstract Void AssignGetAxisLabel(Boolean addMethod,
     GetAxisLabelEventHandler handler)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


AssignScrollMod

Steema.TeeChart.IChart.AssignScrollMod Method

public abstract Void AssignScrollMod(Boolean addMethod,
     ScrollModHandler handler)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


CheckBackground

Steema.TeeChart.IChart.CheckBackground Method

public abstract Void CheckBackground(Object sender,
     MotionEvent e)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


CheckClickSeries

Steema.TeeChart.IChart.CheckClickSeries Method

public abstract Boolean CheckClickSeries()

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


CheckGetAxisLabelAssigned

Steema.TeeChart.IChart.CheckGetAxisLabelAssigned Method

public abstract Boolean CheckGetAxisLabelAssigned()

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


CheckGetNextAxisLabelAssigned

Steema.TeeChart.IChart.CheckGetNextAxisLabelAssigned Method

public abstract Boolean CheckGetNextAxisLabelAssigned()

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


CheckTitle

Steema.TeeChart.IChart.CheckTitle Method

public abstract Void CheckTitle(Title ATitle,
     MotionEvent e)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DoAfterDraw

Steema.TeeChart.IChart.DoAfterDraw Method

public abstract Void DoAfterDraw()

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DoAllowScroll

Steema.TeeChart.IChart.DoAllowScroll Method

public abstract Boolean DoAllowScroll(Axis a,
     Double Delta,
     Double& Min,
     Double& Max)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DoBeforeDraw

Steema.TeeChart.IChart.DoBeforeDraw Method

public abstract Void DoBeforeDraw()

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DoBeforeDrawAxes

Steema.TeeChart.IChart.DoBeforeDrawAxes Method

public abstract Void DoBeforeDrawAxes()

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DoBeforeDrawSeries

Steema.TeeChart.IChart.DoBeforeDrawSeries Method

public abstract Void DoBeforeDrawSeries()

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DoClickAxis

Steema.TeeChart.IChart.DoClickAxis Method

public abstract Void DoClickAxis(Axis a,
     MotionEvent e)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DoClickLegend

Steema.TeeChart.IChart.DoClickLegend Method

public abstract Void DoClickLegend(Object sender,
     MotionEvent e)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DoClickSeries

Steema.TeeChart.IChart.DoClickSeries Method

public abstract Void DoClickSeries(Object sender,
     Series s,
     Int32 valueIndex,
     MotionEvent e)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DoGetAxesChartRect

Steema.TeeChart.IChart.DoGetAxesChartRect Method

public abstract Void DoGetAxesChartRect(Object sender,
     Rectangle& rect)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DoGetAxisLabel

Steema.TeeChart.IChart.DoGetAxisLabel Method

public abstract Void DoGetAxisLabel(Object sender,
     Series s,
     Int32 valueIndex,
     String& labelText)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DoGetLegendPos

Steema.TeeChart.IChart.DoGetLegendPos Method

public abstract Void DoGetLegendPos(Object sender,
     Int32 index,
     Int32& X,
     Int32& Y,
     Int32& XColor)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DoGetLegendRectangle

Steema.TeeChart.IChart.DoGetLegendRectangle Method

public abstract Void DoGetLegendRectangle(Object sender,
     Rectangle& rect)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DoGetLegendSize

Steema.TeeChart.IChart.DoGetLegendSize Method

public abstract Void DoGetLegendSize(Object sender,
     Int32& Size)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DoGetLegendText

Steema.TeeChart.IChart.DoGetLegendText Method

public abstract Void DoGetLegendText(Object sender,
     LegendStyles LegendStyle,
     Int32 Index,
     String& Text)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DoGetNextAxisLabel

Steema.TeeChart.IChart.DoGetNextAxisLabel Method

public abstract Void DoGetNextAxisLabel(Object sender,
     Int32 labelIndex,
     Double& labelValue,
     Boolean& Stop)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DoInvalidate

Steema.TeeChart.IChart.DoInvalidate Method

public abstract Void DoInvalidate()

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DoScroll

Steema.TeeChart.IChart.DoScroll Method

public abstract Void DoScroll(Object sender,
     EventArgs e)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DoScrollMod

Steema.TeeChart.IChart.DoScrollMod Method

public abstract Boolean DoScrollMod(Axis a,
     Double Delta,
     Double& Min,
     Double& Max)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DoSetControlStyle

Steema.TeeChart.IChart.DoSetControlStyle Method

public abstract Void DoSetControlStyle()

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DoUndoneZoom

Steema.TeeChart.IChart.DoUndoneZoom Method

public abstract Void DoUndoneZoom(Object sender,
     EventArgs e)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DoZoomed

Steema.TeeChart.IChart.DoZoomed Method

public abstract Void DoZoomed(Object sender,
     EventArgs e)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


DrawBackColor

Steema.TeeChart.IChart.DrawBackColor Method

public abstract Void DrawBackColor(Graphics3D g)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


FindParentForm

Steema.TeeChart.IChart.FindParentForm Method

public abstract Object FindParentForm()

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


GetControl

Steema.TeeChart.IChart.GetControl Method

public abstract View GetControl()

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


GetCursor

Steema.TeeChart.IChart.GetCursor Method

public abstract Cursor GetCursor()

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


IsWebForm

Steema.TeeChart.IChart.IsWebForm Method

public abstract Boolean IsWebForm()

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


PointToScreen

Steema.TeeChart.IChart.PointToScreen Method

public abstract Point PointToScreen(Point p)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


RefreshControl

Steema.TeeChart.IChart.RefreshControl Method

public abstract Void RefreshControl()

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


SetChart

Steema.TeeChart.IChart.SetChart Method

public abstract Void SetChart(Chart c)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


SetCursor

Steema.TeeChart.IChart.SetCursor Method

public abstract Void SetCursor(Cursor c)

See Also

IChart Interface | IChart Members | Steema.TeeChart Namespace


Steema.TeeChart.ITeeEventListener

Steema.TeeChart.ITeeEventListener Interface

Interface supports inter-Component communication
public interface ITeeEventListener

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

ITeeEventListener members | Steema.TeeChart Namespace


Steema.TeeChart.ITeeEventListenerMembers

Steema.TeeChart.ITeeEventListener all Members

ITeeEventListener overview

Public Methods

TeeEvent

See Also

ITeeEventListener Interface | Steema.TeeChart Namespace


Steema.TeeChart.ITeeEventListenerMethods

Steema.TeeChart.ITeeEventListener Methods

Public Methods

TeeEvent

See Also

ITeeEventListener Interface | Steema.TeeChart Namespace


TeeEvent

Steema.TeeChart.ITeeEventListener.TeeEvent Method

public abstract Void TeeEvent(TeeEvent e)

See Also

ITeeEventListener Interface | ITeeEventListener Members | Steema.TeeChart Namespace


Steema.TeeChart.Legend

Steema.TeeChart.Legend Class

Access to all Chart Legend characteristics

For a list of all members of this type, see Legend Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
Steema.TeeChart.Drawing.TextShapePosition
public class Legend : TextShapePosition , ICloneable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Legend members | Steema.TeeChart Namespace


Steema.TeeChart.LegendMembers

Steema.TeeChart.Legend all Members

Legend overview

Constructors

Constructor Overloaded

Public Fields

ColumnWidthAuto
ColumnWidths
Size (inherited from TextShape)

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clicked | Returns the index of the clicked Legend Point.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
FormattedLegend | Returns the text string corresponding to a Legend position.
FormattedValue | Returns the corresponding Legend text for the Series ValueIndex point.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint |

Public Properties

Alignment | The Alignment property defines the Legend position.
AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
CheckBoxes | Enables/disables the display of Legend check boxes.
ClipText (inherited from TextShape) |
Color | Changes the background color of the Legend box.
CurrentPage | Legend shows only the current page items when the Chart is divided into pages.
CustomPosition (inherited from TextShapePosition) | Set to true to permit custom positioning of TextShape.
DividingLines | Pen attributes used to draw lines separating Legend items.
DrawBehind | Gets or sets whether the Legend is draw in front of or behind the rest of the Chart's elements.
FirstValue | Defines which is the first Legend item displayed
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
FontSeriesColor | Sets the font color of the legend text to that of the Series color, or not.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
HorizMargin | Speficies the number of screen pixels between Legend and Chart rectangles.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Inverted | When True, draws the Legend items in opposite direction.
Items | List of LegendItem objects.
Left (inherited from Shape) | Shape rectangle left co-ordinate
LegendStyle | Defines which items will be displayed in Chart Legend.
Lines | Access to the Legend's Array of Text lines.
MaxNumRows | Sets the Maximum number of Legend Rows to display for a horizontal (Chart Top or Bottom) Legend.
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
ResizeChart | Resizes Chart rectangle to prevent overlap with Legend.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Series | Determine which series is used as data for the Legend entries.
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Symbol | Sets the width and position of the color rectangle associated with each Legend item.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text | Use the Text property to add text to the Legend.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
TextStyle | Determines how Legend text items will be formatted.
TextSymbolGap | Sets the space in pixels to the left of the Legend Text item. It may be used to increase the space between the text and the symbol.
Title | Sets the Title text and its characteristics at the top of the legend
Top (inherited from Shape) | Shape rectangle top co-ordinate
TopLeftPos | Specifies the Legend's top position in percent of total chart height.
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Vertical | Is read only and returns True only if the legend is left or right aligned.
VertMargin | Determines the vertical margin in pixels between Legend and Chart rectangle.
VertSpacing | Sets vertical spacing between Legend items (pixels).
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

Legend Class | Steema.TeeChart Namespace


Steema.TeeChart.Legend Constructor

Overload List

public Legend()
public Legend(Steema.TeeChart.Chart)

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


Steema.TeeChart.Legend Constructor

public Legend(Chart c)

See Also

Legend Constructor Overload List | Legend Class | Legend Members | Steema.TeeChart Namespace


Steema.TeeChart.Legend Constructor

public Legend()

See Also

Legend Constructor Overload List | Legend Class | Legend Members | Steema.TeeChart Namespace


Steema.TeeChart.LegendFields

Steema.TeeChart.Legend Fields

Public Fields

ColumnWidthAuto
ColumnWidths
Size (inherited from TextShape)

See Also

Legend Class | Steema.TeeChart Namespace


ColumnWidthAuto

Steema.TeeChart.Legend.ColumnWidthAuto Field

public Boolean ColumnWidthAuto

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


ColumnWidths

Steema.TeeChart.Legend.ColumnWidths Field

public Int32[] ColumnWidths

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


Steema.TeeChart.LegendMethods

Steema.TeeChart.Legend Methods

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clicked | Returns the index of the clicked Legend Point.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
FormattedLegend | Returns the text string corresponding to a Legend position.
FormattedValue | Returns the corresponding Legend text for the Series ValueIndex point.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint |

See Also

Legend Class | Steema.TeeChart Namespace


Clicked

Steema.TeeChart.Legend.Clicked Method

Returns the index of the clicked Legend Point.
public Int32 Clicked(Int32 x,
     Int32 y)

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


FormattedLegend

Steema.TeeChart.Legend.FormattedLegend Method

Returns the text string corresponding to a Legend position.
public String FormattedLegend(Int32 seriesOrValueIndex)

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


FormattedValue

Steema.TeeChart.Legend.FormattedValue Method

Returns the corresponding Legend text for the Series ValueIndex point.
public String FormattedValue(Series aSeries,
     Int32 valueIndex)

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


Paint

Steema.TeeChart.Legend.Paint Method

Overload List

public override Void Paint(Steema.TeeChart.Drawing.Graphics3D, System.Drawing.Rectangle)
public Void Paint(Steema.TeeChart.Drawing.Graphics3D, System.Drawing.Rectangle, System.Boolean, System.Boolean)

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


Paint

Steema.TeeChart.Legend.Paint Method

public Void Paint(Graphics3D g,
     Rectangle rect,
     Boolean doDraw,
     Boolean doCalc)

See Also

Paint Overload List | Legend Class | Legend Members | Steema.TeeChart Namespace


Paint

Steema.TeeChart.Legend.Paint Method

public override Void Paint(Graphics3D g,
     Rectangle rect)

See Also

Paint Overload List | Legend Class | Legend Members | Steema.TeeChart Namespace


Steema.TeeChart.LegendProperties

Steema.TeeChart.Legend Properties

Public Properties

Alignment | The Alignment property defines the Legend position.
AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
CheckBoxes | Enables/disables the display of Legend check boxes.
ClipText (inherited from TextShape) |
Color | Changes the background color of the Legend box.
CurrentPage | Legend shows only the current page items when the Chart is divided into pages.
CustomPosition (inherited from TextShapePosition) | Set to true to permit custom positioning of TextShape.
DividingLines | Pen attributes used to draw lines separating Legend items.
DrawBehind | Gets or sets whether the Legend is draw in front of or behind the rest of the Chart's elements.
FirstValue | Defines which is the first Legend item displayed
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
FontSeriesColor | Sets the font color of the legend text to that of the Series color, or not.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
HorizMargin | Speficies the number of screen pixels between Legend and Chart rectangles.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Inverted | When True, draws the Legend items in opposite direction.
Items | List of LegendItem objects.
Left (inherited from Shape) | Shape rectangle left co-ordinate
LegendStyle | Defines which items will be displayed in Chart Legend.
Lines | Access to the Legend's Array of Text lines.
MaxNumRows | Sets the Maximum number of Legend Rows to display for a horizontal (Chart Top or Bottom) Legend.
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
ResizeChart | Resizes Chart rectangle to prevent overlap with Legend.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Series | Determine which series is used as data for the Legend entries.
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Symbol | Sets the width and position of the color rectangle associated with each Legend item.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text | Use the Text property to add text to the Legend.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
TextStyle | Determines how Legend text items will be formatted.
TextSymbolGap | Sets the space in pixels to the left of the Legend Text item. It may be used to increase the space between the text and the symbol.
Title | Sets the Title text and its characteristics at the top of the legend
Top (inherited from Shape) | Shape rectangle top co-ordinate
TopLeftPos | Specifies the Legend's top position in percent of total chart height.
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Vertical | Is read only and returns True only if the legend is left or right aligned.
VertMargin | Determines the vertical margin in pixels between Legend and Chart rectangle.
VertSpacing | Sets vertical spacing between Legend items (pixels).
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

Legend Class | Steema.TeeChart Namespace


Alignment

Steema.TeeChart.Legend.Alignment Property

The Alignment property defines the Legend position.
public LegendAlignments Alignment {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


CheckBoxes

Steema.TeeChart.Legend.CheckBoxes Property

Enables/disables the display of Legend check boxes.
public Boolean CheckBoxes {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


Color

Steema.TeeChart.Legend.Color Property

Changes the background color of the Legend box.
public Color Color {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


CurrentPage

Steema.TeeChart.Legend.CurrentPage Property

Legend shows only the current page items when the Chart is divided into pages.
public Boolean CurrentPage {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


DividingLines

Steema.TeeChart.Legend.DividingLines Property

Pen attributes used to draw lines separating Legend items.
public ChartPen DividingLines {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


DrawBehind

Steema.TeeChart.Legend.DrawBehind Property

Gets or sets whether the Legend is draw in front of or behind the rest of the Chart's elements.
public Boolean DrawBehind {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


FirstValue

Steema.TeeChart.Legend.FirstValue Property

Defines which is the first Legend item displayed
public Int32 FirstValue {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


FontSeriesColor

Steema.TeeChart.Legend.FontSeriesColor Property

Sets the font color of the legend text to that of the Series color, or not.
public Boolean FontSeriesColor {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


HorizMargin

Steema.TeeChart.Legend.HorizMargin Property

Speficies the number of screen pixels between Legend and Chart rectangles.
public Int32 HorizMargin {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


Inverted

Steema.TeeChart.Legend.Inverted Property

When True, draws the Legend items in opposite direction.
public Boolean Inverted {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


Items

Steema.TeeChart.Legend.Items Property

List of LegendItem objects.
public LegendItems Items {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


LegendStyle

Steema.TeeChart.Legend.LegendStyle Property

Defines which items will be displayed in Chart Legend.
public LegendStyles LegendStyle {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


Lines

Steema.TeeChart.Legend.Lines Property

Access to the Legend's Array of Text lines.
public String[] Lines {get;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


MaxNumRows

Steema.TeeChart.Legend.MaxNumRows Property

Sets the Maximum number of Legend Rows to display for a horizontal (Chart Top or Bottom) Legend.
public Int32 MaxNumRows {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


ResizeChart

Steema.TeeChart.Legend.ResizeChart Property

Resizes Chart rectangle to prevent overlap with Legend.
public Boolean ResizeChart {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


Series

Steema.TeeChart.Legend.Series Property

Determine which series is used as data for the Legend entries.
public Series Series {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


Symbol

Steema.TeeChart.Legend.Symbol Property

Sets the width and position of the color rectangle associated with each Legend item.
public LegendSymbol Symbol {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


Text

Steema.TeeChart.Legend.Text Property

Use the Text property to add text to the Legend.
public String Text {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


TextStyle

Steema.TeeChart.Legend.TextStyle Property

Determines how Legend text items will be formatted.
public LegendTextStyles TextStyle {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


TextSymbolGap

Steema.TeeChart.Legend.TextSymbolGap Property

Sets the space in pixels to the left of the Legend Text item. It may be used to increase the space between the text and the symbol.
public Int32 TextSymbolGap {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


Title

Steema.TeeChart.Legend.Title Property

Sets the Title text and its characteristics at the top of the legend
public LegendTitle Title {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


TopLeftPos

Steema.TeeChart.Legend.TopLeftPos Property

Specifies the Legend's top position in percent of total chart height.
public Int32 TopLeftPos {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


Vertical

Steema.TeeChart.Legend.Vertical Property

Is read only and returns True only if the legend is left or right aligned.
public Boolean Vertical {get;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


VertMargin

Steema.TeeChart.Legend.VertMargin Property

Determines the vertical margin in pixels between Legend and Chart rectangle.
public Int32 VertMargin {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


VertSpacing

Steema.TeeChart.Legend.VertSpacing Property

Sets vertical spacing between Legend items (pixels).
public Int32 VertSpacing {get; set;}

See Also

Legend Class | Legend Members | Steema.TeeChart Namespace


Steema.TeeChart.LegendAlignments

Steema.TeeChart.LegendAlignments Enum

Describes the possible values of the Alignment property
[Serializable]
public sealed enum LegendAlignments : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Left | Aligns the legend to the left of the TChart.
Right | Aligns the legend to the right of the TChart.
Top | Aligns the legend to the top of the TChart.
Bottom | Aligns the legend to the bottom of the TChart.

See Also

Steema.TeeChart Namespace


Steema.TeeChart.LegendItem

Steema.TeeChart.LegendItem Class

The LegendItem class describes characteristics of each item that are placed on the Legend.

For a list of all members of this type, see LegendItem Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public sealed class LegendItem : TeeBase

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

LegendItem members | Steema.TeeChart Namespace


Steema.TeeChart.LegendItemMembers

Steema.TeeChart.LegendItem all Members

LegendItem overview

Constructors

Constructor

Public Methods

Invalidate (inherited from TeeBase) Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Align | Gets and sets the Text alignment options
Chart (inherited from TeeBase) | Chart associated with this object
Left | Gets and sets the Left position of the referenced legend item.
SymbolRectangle | Gets or sets a Rectangle for the legend item symbol.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text | Gets or sets a Text for the referenced legend item.
Text2 | Returns the text displayed at Legend item in second column.
Top | Gets and sets the Top position of the referenced legend item.

See Also

LegendItem Class | Steema.TeeChart Namespace


Steema.TeeChart.LegendItem Constructor

public LegendItem(Legend legend)

See Also

LegendItem Class | LegendItem Members | Steema.TeeChart Namespace


Steema.TeeChart.LegendItemMethods

Steema.TeeChart.LegendItem Methods

Public Methods

Invalidate (inherited from TeeBase) Use Invalidate when the entire canvas needs to be repainted.

See Also

LegendItem Class | Steema.TeeChart Namespace


Steema.TeeChart.LegendItemProperties

Steema.TeeChart.LegendItem Properties

Public Properties

Align | Gets and sets the Text alignment options
Chart (inherited from TeeBase) | Chart associated with this object
Left | Gets and sets the Left position of the referenced legend item.
SymbolRectangle | Gets or sets a Rectangle for the legend item symbol.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text | Gets or sets a Text for the referenced legend item.
Text2 | Returns the text displayed at Legend item in second column.
Top | Gets and sets the Top position of the referenced legend item.

See Also

LegendItem Class | Steema.TeeChart Namespace


Align

Steema.TeeChart.LegendItem.Align Property

Gets and sets the Text alignment options
public Align Align {get; set;}

See Also

LegendItem Class | LegendItem Members | Steema.TeeChart Namespace


Left

Steema.TeeChart.LegendItem.Left Property

Gets and sets the Left position of the referenced legend item.
public Int32 Left {get; set;}

See Also

LegendItem Class | LegendItem Members | Steema.TeeChart Namespace


SymbolRectangle

Steema.TeeChart.LegendItem.SymbolRectangle Property

Gets or sets a Rectangle for the legend item symbol.
public Rectangle SymbolRectangle {get; set;}

See Also

LegendItem Class | LegendItem Members | Steema.TeeChart Namespace


Text

Steema.TeeChart.LegendItem.Text Property

Gets or sets a Text for the referenced legend item.
public String Text {get; set;}

See Also

LegendItem Class | LegendItem Members | Steema.TeeChart Namespace


Text2

Steema.TeeChart.LegendItem.Text2 Property

Returns the text displayed at Legend item in second column.
public String Text2 {get; set;}

See Also

LegendItem Class | LegendItem Members | Steema.TeeChart Namespace


Top

Steema.TeeChart.LegendItem.Top Property

Gets and sets the Top position of the referenced legend item.
public Int32 Top {get; set;}

See Also

LegendItem Class | LegendItem Members | Steema.TeeChart Namespace


Steema.TeeChart.LegendItems

Steema.TeeChart.LegendItems Class

Specialized List class to hold Legend items of type LegendItem.

For a list of all members of this type, see LegendItems Members

System.Object
System.Collections.Generic.List<LegendItem>
public sealed class LegendItems : List<LegendItem>
, IList<LegendItem>
, ICollection<LegendItem>
, IEnumerable<LegendItem>
, IEnumerable, IList, ICollection, IReadOnlyList<LegendItem>
, IReadOnlyCollection<LegendItem>

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

LegendItems members | Steema.TeeChart Namespace


Steema.TeeChart.LegendItemsMembers

Steema.TeeChart.LegendItems all Members

LegendItems overview

Constructors

Constructor

Public Properties

AutoPosition | Gets or sets whether legend items positioning is automatically calculated when Custom is set to true.
Custom | When True, legend does not automatically calculate the legend items to be displayed, and it uses the Items property instead.
Item | Access indexed Label characteristics

See Also

LegendItems Class | Steema.TeeChart Namespace


Steema.TeeChart.LegendItems Constructor

public LegendItems(Legend legend)

See Also

LegendItems Class | LegendItems Members | Steema.TeeChart Namespace


Steema.TeeChart.LegendItemsProperties

Steema.TeeChart.LegendItems Properties

Public Properties

AutoPosition | Gets or sets whether legend items positioning is automatically calculated when Custom is set to true.
Custom | When True, legend does not automatically calculate the legend items to be displayed, and it uses the Items property instead.
Item | Access indexed Label characteristics

See Also

LegendItems Class | Steema.TeeChart Namespace


AutoPosition

Steema.TeeChart.LegendItems.AutoPosition Property

Gets or sets whether legend items positioning is automatically calculated when Custom is set to true.
public Boolean AutoPosition {get; set;}

See Also

LegendItems Class | LegendItems Members | Steema.TeeChart Namespace


Custom

Steema.TeeChart.LegendItems.Custom Property

When True, legend does not automatically calculate the legend items to be displayed, and it uses the Items property instead.
public Boolean Custom {get; set;}

See Also

LegendItems Class | LegendItems Members | Steema.TeeChart Namespace


Item

Steema.TeeChart.LegendItems.Item Property

Access indexed Label characteristics
public LegendItem Item(Int32 index) {get; set;}

See Also

LegendItems Class | LegendItems Members | Steema.TeeChart Namespace


Steema.TeeChart.LegendStyles

Steema.TeeChart.LegendStyles Enum

Describes the possible values of the LegendStyle property.
[Serializable]
public sealed enum LegendStyles : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Auto | Legend draws Series Titles if there's more than one Series in the TChart.
Series | Legend draws the Series Titles even if there's only one Series in the chart.
Values | Legend draws the first Active Series' values.
LastValues | Legend draws the Last Value of each Active Series (similar to Series).
Palette | Legend draws a number of the Palette entries defined by MaxNumRows.

See Also

Steema.TeeChart Namespace


Steema.TeeChart.LegendSymbol

Steema.TeeChart.LegendSymbol Class

Legend item symbol characteristics

For a list of all members of this type, see LegendSymbol Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class LegendSymbol : TeeBase

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

LegendSymbol members | Steema.TeeChart Namespace


Steema.TeeChart.LegendSymbolMembers

Steema.TeeChart.LegendSymbol all Members

LegendSymbol overview

Constructors

Constructor

Public Events

OnSymbolDraw

Public Methods

Invalidate (inherited from TeeBase) Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Continous | Adjoins the different legend rectangles when true.
DefaultPen | Uses series pen properties to draw a border around the coloured box legend symbol, when true.
Pen | Pen used to draw a border around the color box legend symbols.
Position | Sets the position of the Legend color rectangles.
Shadow | Sets a shadow around the Legend symbols.
Squared | When true, the legend symbol will be resized to square shaped.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Visible | Shows or hides Legend symbols.
Width | Defines the width of the color rectangles (symbols).
WidthUnits | Defines the Width units for the width of Symbol.

See Also

LegendSymbol Class | Steema.TeeChart Namespace


Steema.TeeChart.LegendSymbol Constructor

public LegendSymbol(Legend legend)

See Also

LegendSymbol Class | LegendSymbol Members | Steema.TeeChart Namespace


Steema.TeeChart.LegendSymbolEvents

Steema.TeeChart.LegendSymbol Events

Public Events

OnSymbolDraw

See Also

LegendSymbol Class | Steema.TeeChart Namespace


OnSymbolDraw

Steema.TeeChart.LegendSymbol.OnSymbolDraw Event

public SymbolDrawEventHandler  OnSymbolDraw

See Also

LegendSymbol Class | LegendSymbol Members | Steema.TeeChart Namespace


Steema.TeeChart.LegendSymbolMethods

Steema.TeeChart.LegendSymbol Methods

Public Methods

Invalidate (inherited from TeeBase) Use Invalidate when the entire canvas needs to be repainted.

See Also

LegendSymbol Class | Steema.TeeChart Namespace


Steema.TeeChart.LegendSymbolProperties

Steema.TeeChart.LegendSymbol Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Continous | Adjoins the different legend rectangles when true.
DefaultPen | Uses series pen properties to draw a border around the coloured box legend symbol, when true.
Pen | Pen used to draw a border around the color box legend symbols.
Position | Sets the position of the Legend color rectangles.
Shadow | Sets a shadow around the Legend symbols.
Squared | When true, the legend symbol will be resized to square shaped.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Visible | Shows or hides Legend symbols.
Width | Defines the width of the color rectangles (symbols).
WidthUnits | Defines the Width units for the width of Symbol.

See Also

LegendSymbol Class | Steema.TeeChart Namespace


Continous

Steema.TeeChart.LegendSymbol.Continous Property

Adjoins the different legend rectangles when true.
public Boolean Continous {get; set;}

See Also

LegendSymbol Class | LegendSymbol Members | Steema.TeeChart Namespace


DefaultPen

Steema.TeeChart.LegendSymbol.DefaultPen Property

Uses series pen properties to draw a border around the coloured box legend symbol, when true.
public Boolean DefaultPen {get; set;}

See Also

LegendSymbol Class | LegendSymbol Members | Steema.TeeChart Namespace


Pen

Steema.TeeChart.LegendSymbol.Pen Property

Pen used to draw a border around the color box legend symbols.
public ChartPen Pen {get;}

See Also

LegendSymbol Class | LegendSymbol Members | Steema.TeeChart Namespace


Position

Steema.TeeChart.LegendSymbol.Position Property

Sets the position of the Legend color rectangles.
public LegendSymbolPosition Position {get; set;}

See Also

LegendSymbol Class | LegendSymbol Members | Steema.TeeChart Namespace


Shadow

Steema.TeeChart.LegendSymbol.Shadow Property

Sets a shadow around the Legend symbols.
public Shadow Shadow {get;}

See Also

LegendSymbol Class | LegendSymbol Members | Steema.TeeChart Namespace


Squared

Steema.TeeChart.LegendSymbol.Squared Property

When true, the legend symbol will be resized to square shaped.
public Boolean Squared {get; set;}

See Also

LegendSymbol Class | LegendSymbol Members | Steema.TeeChart Namespace


Visible

Steema.TeeChart.LegendSymbol.Visible Property

Shows or hides Legend symbols.
public Boolean Visible {get; set;}

See Also

LegendSymbol Class | LegendSymbol Members | Steema.TeeChart Namespace


Width

Steema.TeeChart.LegendSymbol.Width Property

Defines the width of the color rectangles (symbols).
public Int32 Width {get; set;}

See Also

LegendSymbol Class | LegendSymbol Members | Steema.TeeChart Namespace


WidthUnits

Steema.TeeChart.LegendSymbol.WidthUnits Property

Defines the Width units for the width of Symbol.
public LegendSymbolSize WidthUnits {get; set;}

See Also

LegendSymbol Class | LegendSymbol Members | Steema.TeeChart Namespace


Steema.TeeChart.LegendSymbolPosition

Steema.TeeChart.LegendSymbolPosition Enum

Describes the position of the Legend's color rectangles.
[Serializable]
public sealed enum LegendSymbolPosition : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Left | Defines the left positioning of the Legend's color rectangles.
Right | Defines the right positioning of the Legend's color rectangles.

See Also

Steema.TeeChart Namespace


Steema.TeeChart.LegendSymbolSize

Steema.TeeChart.LegendSymbolSize Enum

Describes the units in which to define the size of the Legend's color rectangles.
[Serializable]
public sealed enum LegendSymbolSize : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Percent | Defines the units as a Percentage of the Legend width.
Pixels | Defines the units as Pixels.

See Also

Steema.TeeChart Namespace


Steema.TeeChart.LegendTextStyles

Steema.TeeChart.LegendTextStyles Enum

Describes the possible values of the TextStyle property.
[Serializable]
public sealed enum LegendTextStyles : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Plain | Legend Text is defined as the series point labels.
LeftValue | Legend Text is defined as the series values on the left of the series point labels.
RightValue | Legend Text is defined as the series values on the right of the series point labels.
LeftPercent | Legend Text is defined as the series values as a percentage of the total of series values on the left of the series point labels.
RightPercent | Legend Text is defined as the series values as a percentage of the total of series values on the right of the series point labels.
XValue | Legend Text is defined as the xvalues of the series.
Value | Legend Text is defined as the series value.
Percent | Legend Text is defined as the series values as a percentage of the total of series values
XAndValue | Legend Text is defined as xvalues of the series and the series values.
XAndPercent | Legend Text is defined as xvalues of the series and the series values as a percentage of the total of series values.

See Also

Steema.TeeChart Namespace


Steema.TeeChart.LegendTitle

Steema.TeeChart.LegendTitle Class

For a list of all members of this type, see LegendTitle Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
public sealed class LegendTitle : TextShape , ICloneable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

LegendTitle members | Steema.TeeChart Namespace


Steema.TeeChart.LegendTitleMembers

Steema.TeeChart.LegendTitle all Members

LegendTitle overview

Constructors

Constructor Overloaded

Public Fields

Size (inherited from TextShape)

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.

Public Properties

AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

LegendTitle Class | Steema.TeeChart Namespace


Steema.TeeChart.LegendTitle Constructor

Overload List

public LegendTitle(Steema.TeeChart.Chart)
public LegendTitle(Steema.TeeChart.Chart, System.Boolean)

See Also

LegendTitle Class | LegendTitle Members | Steema.TeeChart Namespace


Steema.TeeChart.LegendTitle Constructor

public LegendTitle(Chart c,
     Boolean startVisible)

See Also

LegendTitle Constructor Overload List | LegendTitle Class | LegendTitle Members | Steema.TeeChart Namespace


Steema.TeeChart.LegendTitle Constructor

public LegendTitle(Chart c)

See Also

LegendTitle Constructor Overload List | LegendTitle Class | LegendTitle Members | Steema.TeeChart Namespace


Steema.TeeChart.LegendTitleFields

Steema.TeeChart.LegendTitle Fields

Public Fields

Size (inherited from TextShape)

See Also

LegendTitle Class | Steema.TeeChart Namespace


Steema.TeeChart.LegendTitleMethods

Steema.TeeChart.LegendTitle Methods

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.

See Also

LegendTitle Class | Steema.TeeChart Namespace


Steema.TeeChart.LegendTitleProperties

Steema.TeeChart.LegendTitle Properties

Public Properties

AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

LegendTitle Class | Steema.TeeChart Namespace


Steema.TeeChart.MouseEventKinds

Steema.TeeChart.MouseEventKinds Enum

Type of Mouse action
[Serializable]
public sealed enum MouseEventKinds : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Down | MouseButton down action
Move | MouseMove
Up | MouseButton Up action
Wheel | MouseWheel action

See Also

Steema.TeeChart Namespace


Steema.TeeChart.Page

Steema.TeeChart.Page Class

Chart paging characteristics

For a list of all members of this type, see Page Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class Page : TeeBase

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Page members | Steema.TeeChart Namespace


Steema.TeeChart.PageMembers

Steema.TeeChart.Page all Members

Page overview

Constructors

Constructor

Public Methods

FirstValueIndex | Returns the first ValueIndex of the current page.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Next | Moves to next page ( Current + 1 )
Previous | Moves to previous page ( Current - 1 )

Public Properties

AutoScale | Set to true to scale the Y Axis for each page.
Chart (inherited from TeeBase) | Chart associated with this object
Count | Gets the number of pages, according to MaxPointsPerPage property.
Current | Gets or sets the current page number.
MaxPointsPerPage | Gets or Sets the number of points displayed per page.
ScaleLastPage | Determines how the last Chart page will be displayed.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Page Class | Steema.TeeChart Namespace


Steema.TeeChart.Page Constructor

public Page(Chart c)

See Also

Page Class | Page Members | Steema.TeeChart Namespace


Steema.TeeChart.PageMethods

Steema.TeeChart.Page Methods

Public Methods

FirstValueIndex | Returns the first ValueIndex of the current page.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Next | Moves to next page ( Current + 1 )
Previous | Moves to previous page ( Current - 1 )

See Also

Page Class | Steema.TeeChart Namespace


FirstValueIndex

Steema.TeeChart.Page.FirstValueIndex Method

Returns the first ValueIndex of the current page.
public Int32 FirstValueIndex()

See Also

Page Class | Page Members | Steema.TeeChart Namespace


Next

Steema.TeeChart.Page.Next Method

Moves to next page ( Current + 1 )
public Void Next()

See Also

Page Class | Page Members | Steema.TeeChart Namespace


Previous

Steema.TeeChart.Page.Previous Method

Moves to previous page ( Current - 1 )
public Void Previous()

See Also

Page Class | Page Members | Steema.TeeChart Namespace


Steema.TeeChart.PageProperties

Steema.TeeChart.Page Properties

Public Properties

AutoScale | Set to true to scale the Y Axis for each page.
Chart (inherited from TeeBase) | Chart associated with this object
Count | Gets the number of pages, according to MaxPointsPerPage property.
Current | Gets or sets the current page number.
MaxPointsPerPage | Gets or Sets the number of points displayed per page.
ScaleLastPage | Determines how the last Chart page will be displayed.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Page Class | Steema.TeeChart Namespace


AutoScale

Steema.TeeChart.Page.AutoScale Property

Set to true to scale the Y Axis for each page.
public Boolean AutoScale {get; set;}

See Also

Page Class | Page Members | Steema.TeeChart Namespace


Count

Steema.TeeChart.Page.Count Property

Gets the number of pages, according to MaxPointsPerPage property.
public Int32 Count {get;}

See Also

Page Class | Page Members | Steema.TeeChart Namespace


Current

Steema.TeeChart.Page.Current Property

Gets or sets the current page number.
public Int32 Current {get; set;}

See Also

Page Class | Page Members | Steema.TeeChart Namespace


MaxPointsPerPage

Steema.TeeChart.Page.MaxPointsPerPage Property

Gets or Sets the number of points displayed per page.
public Int32 MaxPointsPerPage {get; set;}

See Also

Page Class | Page Members | Steema.TeeChart Namespace


ScaleLastPage

Steema.TeeChart.Page.ScaleLastPage Property

Determines how the last Chart page will be displayed.
public Boolean ScaleLastPage {get; set;}

See Also

Page Class | Page Members | Steema.TeeChart Namespace


Steema.TeeChart.PaintChartEventHandler

Steema.TeeChart.PaintChartEventHandler Delegate

Chart Paint Event Handler
public delegate PaintChartEventHandler (Object sender,
     Graphics3D g)

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart Namespace


Steema.TeeChart.Panel

Steema.TeeChart.Panel Class

Chart background panel characteristics

For a list of all members of this type, see Panel Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
public class Panel : Shape , ICloneable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Panel members | Steema.TeeChart Namespace


Steema.TeeChart.PanelMembers

Steema.TeeChart.Panel all Members

Panel overview

Constructors

Constructor Overloaded

Public Methods

Assign (inherited from Shape) | Assign all properties from a shape to another.
BackImageClear |
Clone (inherited from Shape) |
Draw | Paints the Chart in your preferred Canvas and region.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from Shape) |

Public Properties

BackImageInside | System.Obsolete: Please use Walls.Back.Image property.
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderPen |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Shape) | Defines the shape Color.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
MarginBottom | Sets Bottom margin as percentage of Chart Drawing.
MarginLeft | Sets Left margin as percentage of Chart Drawing.
MarginRight | Sets Right margin as percentage of Chart Drawing.
MarginTop | Sets Top margin as percentage of Chart Drawing.
MarginUnits | Sets the units in which the Margins are expressed.
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible | This property shows or hides the Panel.
Width (inherited from Shape) | The Width of the shape.

See Also

Panel Class | Steema.TeeChart Namespace


Steema.TeeChart.Panel Constructor

Overload List

public Panel()
public Panel(Steema.TeeChart.Chart)

See Also

Panel Class | Panel Members | Steema.TeeChart Namespace


Steema.TeeChart.Panel Constructor

public Panel(Chart c)

See Also

Panel Constructor Overload List | Panel Class | Panel Members | Steema.TeeChart Namespace


Steema.TeeChart.Panel Constructor

public Panel()

See Also

Panel Constructor Overload List | Panel Class | Panel Members | Steema.TeeChart Namespace


Steema.TeeChart.PanelMethods

Steema.TeeChart.Panel Methods

Public Methods

Assign (inherited from Shape) | Assign all properties from a shape to another.
BackImageClear |
Clone (inherited from Shape) |
Draw | Paints the Chart in your preferred Canvas and region.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from Shape) |

See Also

Panel Class | Steema.TeeChart Namespace


BackImageClear

Steema.TeeChart.Panel.BackImageClear Method

public Void BackImageClear()

See Also

Panel Class | Panel Members | Steema.TeeChart Namespace


Draw

Steema.TeeChart.Panel.Draw Method

Paints the Chart in your preferred Canvas and region.
public Void Draw(Graphics3D g,
     Rectangle& r)

See Also

Panel Class | Panel Members | Steema.TeeChart Namespace


Steema.TeeChart.PanelProperties

Steema.TeeChart.Panel Properties

Public Properties

BackImageInside | System.Obsolete: Please use Walls.Back.Image property.
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderPen |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Shape) | Defines the shape Color.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
MarginBottom | Sets Bottom margin as percentage of Chart Drawing.
MarginLeft | Sets Left margin as percentage of Chart Drawing.
MarginRight | Sets Right margin as percentage of Chart Drawing.
MarginTop | Sets Top margin as percentage of Chart Drawing.
MarginUnits | Sets the units in which the Margins are expressed.
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible | This property shows or hides the Panel.
Width (inherited from Shape) | The Width of the shape.

See Also

Panel Class | Steema.TeeChart Namespace


BackImageInside

Steema.TeeChart.Panel.BackImageInside Property

System.Obsolete: Please use Walls.Back.Image property.
public Boolean BackImageInside {get; set;}

See Also

Panel Class | Panel Members | Steema.TeeChart Namespace


BorderPen

Steema.TeeChart.Panel.BorderPen Property

public ChartPen BorderPen {get; set;}

See Also

Panel Class | Panel Members | Steema.TeeChart Namespace


MarginBottom

Steema.TeeChart.Panel.MarginBottom Property

Sets Bottom margin as percentage of Chart Drawing.
public Double MarginBottom {get; set;}

See Also

Panel Class | Panel Members | Steema.TeeChart Namespace


MarginLeft

Steema.TeeChart.Panel.MarginLeft Property

Sets Left margin as percentage of Chart Drawing.
public Double MarginLeft {get; set;}

See Also

Panel Class | Panel Members | Steema.TeeChart Namespace


MarginRight

Steema.TeeChart.Panel.MarginRight Property

Sets Right margin as percentage of Chart Drawing.
public Double MarginRight {get; set;}

See Also

Panel Class | Panel Members | Steema.TeeChart Namespace


MarginTop

Steema.TeeChart.Panel.MarginTop Property

Sets Top margin as percentage of Chart Drawing.
public Double MarginTop {get; set;}

See Also

Panel Class | Panel Members | Steema.TeeChart Namespace


MarginUnits

Steema.TeeChart.Panel.MarginUnits Property

Sets the units in which the Margins are expressed.
public PanelMarginUnits MarginUnits {get; set;}

See Also

Panel Class | Panel Members | Steema.TeeChart Namespace


Visible

Steema.TeeChart.Panel.Visible Property

This property shows or hides the Panel.
public Boolean Visible {get; set;}

See Also

Panel Class | Panel Members | Steema.TeeChart Namespace


Steema.TeeChart.PanelMarginUnits

Steema.TeeChart.PanelMarginUnits Enum

Describes the possible values of the MarginUnits property
[Serializable]
public sealed enum PanelMarginUnits : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Percent | Defines units as a percentage of the panel size.
Pixels | Defines units in pixels.

See Also

Steema.TeeChart Namespace


Steema.TeeChart.PositionUnits

Steema.TeeChart.PositionUnits Enum

PositionUnits specifies PositionUnits Axis.Labels.PositionUnits property as percentage or pixels.
[Serializable]
public sealed enum PositionUnits : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Percent | Units as a percentage of horizontal or vertical chart size.
Pixels | Units as pixels.

See Also

Steema.TeeChart Namespace


Steema.TeeChart.Scroll

Steema.TeeChart.Scroll Class

Chart mouse scroll characteristics

For a list of all members of this type, see Scroll Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.ZoomScroll
public class Scroll : ZoomScroll

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Scroll members | Steema.TeeChart Namespace


Steema.TeeChart.ScrollMembers

Steema.TeeChart.Scroll all Members

Scroll overview

Constructors

Constructor

Public Fields

x0 (inherited from ZoomScroll)
x1 (inherited from ZoomScroll)
y0 (inherited from ZoomScroll)
y1 (inherited from ZoomScroll)

Public Methods

Activate (inherited from ZoomScroll) | Internal use. Starts a Zoom or Scroll from the co-ordinates X,Y.
Check (inherited from ZoomScroll) | Swaps the X0 and X1 coordinates when X1 is lower than X0.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Active (inherited from ZoomScroll) | Returns the active state of Chart Zoom and Scroll.
Allow | Enables/Disables selected ScrollModes.
Chart (inherited from TeeBase) | Chart associated with this object
KeyShift (inherited from ZoomScroll) | Sets a keyboard button as an extra condition to initiate the zoom.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Scroll Class | Steema.TeeChart Namespace


Steema.TeeChart.Scroll Constructor

public Scroll(Chart c)

See Also

Scroll Class | Scroll Members | Steema.TeeChart Namespace


Steema.TeeChart.ScrollFields

Steema.TeeChart.Scroll Fields

Public Fields

x0 (inherited from ZoomScroll)
x1 (inherited from ZoomScroll)
y0 (inherited from ZoomScroll)
y1 (inherited from ZoomScroll)

See Also

Scroll Class | Steema.TeeChart Namespace


Steema.TeeChart.ScrollMethods

Steema.TeeChart.Scroll Methods

Public Methods

Activate (inherited from ZoomScroll) | Internal use. Starts a Zoom or Scroll from the co-ordinates X,Y.
Check (inherited from ZoomScroll) | Swaps the X0 and X1 coordinates when X1 is lower than X0.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

See Also

Scroll Class | Steema.TeeChart Namespace


Steema.TeeChart.ScrollProperties

Steema.TeeChart.Scroll Properties

Public Properties

Active (inherited from ZoomScroll) | Returns the active state of Chart Zoom and Scroll.
Allow | Enables/Disables selected ScrollModes.
Chart (inherited from TeeBase) | Chart associated with this object
KeyShift (inherited from ZoomScroll) | Sets a keyboard button as an extra condition to initiate the zoom.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Scroll Class | Steema.TeeChart Namespace


Allow

Steema.TeeChart.Scroll.Allow Property

Enables/Disables selected ScrollModes.
public ScrollModes Allow {get; set;}

See Also

Scroll Class | Scroll Members | Steema.TeeChart Namespace


Steema.TeeChart.ScrollModes

Steema.TeeChart.ScrollModes Enum

Describes the possible values of the Allow property.
[Serializable]
public sealed enum ScrollModes : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
None | Deny scrolling.
Vertical | Allow only Horizontal Scrolling.
Horizontal | Allow only Vertical Scrolling.
Both | Allow complete Horizontal and Vertical Scrolling.

See Also

Steema.TeeChart Namespace


Steema.TeeChart.ScrollModEventArgs

Steema.TeeChart.ScrollModEventArgs Class

Event arguments class used by AllowScroll chart event.

For a list of all members of this type, see ScrollModEventArgs Members

System.Object
System.EventArgs
public class ScrollModEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

ScrollModEventArgs members | Steema.TeeChart Namespace


Steema.TeeChart.ScrollModEventArgsMembers

Steema.TeeChart.ScrollModEventArgs all Members

ScrollModEventArgs overview

Constructors

Constructor

Public Fields

AllowScroll
Max
Min

See Also

ScrollModEventArgs Class | Steema.TeeChart Namespace


Steema.TeeChart.ScrollModEventArgs Constructor

public ScrollModEventArgs(Double min,
     Double max,
     Boolean allowScroll)

See Also

ScrollModEventArgs Class | ScrollModEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.ScrollModEventArgsFields

Steema.TeeChart.ScrollModEventArgs Fields

Public Fields

AllowScroll
Max
Min

See Also

ScrollModEventArgs Class | Steema.TeeChart Namespace


AllowScroll

Steema.TeeChart.ScrollModEventArgs.AllowScroll Field

public Boolean AllowScroll

See Also

ScrollModEventArgs Class | ScrollModEventArgs Members | Steema.TeeChart Namespace


Max

Steema.TeeChart.ScrollModEventArgs.Max Field

public Double Max

See Also

ScrollModEventArgs Class | ScrollModEventArgs Members | Steema.TeeChart Namespace


Min

Steema.TeeChart.ScrollModEventArgs.Min Field

public Double Min

See Also

ScrollModEventArgs Class | ScrollModEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.ScrollModHandler

Steema.TeeChart.ScrollModHandler Delegate

Scroll event handler
public delegate ScrollModHandler (Axis a,
     ScrollModEventArgs e)

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart Namespace


Steema.TeeChart.SerializeEventArgs

Steema.TeeChart.SerializeEventArgs Class

Axis Label EventArgs. See GetAxisLabelEventHandler

For a list of all members of this type, see SerializeEventArgs Members

System.Object
System.EventArgs
public class SerializeEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

SerializeEventArgs members | Steema.TeeChart Namespace


Steema.TeeChart.SerializeEventArgsMembers

Steema.TeeChart.SerializeEventArgs all Members

SerializeEventArgs overview

Constructors

Constructor

Public Properties

Type | Sets Type to add to Serialization.
TypeName | Name of Type to Serialize

See Also

SerializeEventArgs Class | Steema.TeeChart Namespace


Steema.TeeChart.SerializeEventArgs Constructor

public SerializeEventArgs(String tName,
     Type t)

See Also

SerializeEventArgs Class | SerializeEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.SerializeEventArgsProperties

Steema.TeeChart.SerializeEventArgs Properties

Public Properties

Type | Sets Type to add to Serialization.
TypeName | Name of Type to Serialize

See Also

SerializeEventArgs Class | Steema.TeeChart Namespace


Type

Steema.TeeChart.SerializeEventArgs.Type Property

Sets Type to add to Serialization.
public Type Type {get; set;}

See Also

SerializeEventArgs Class | SerializeEventArgs Members | Steema.TeeChart Namespace


TypeName

Steema.TeeChart.SerializeEventArgs.TypeName Property

Name of Type to Serialize
public String TypeName {get;}

See Also

SerializeEventArgs Class | SerializeEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.SerializeEventHandler

Steema.TeeChart.SerializeEventHandler Delegate

Serialize Type event handler
public delegate SerializeEventHandler (Object sender,
     SerializeEventArgs e)

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart Namespace


Steema.TeeChart.SymbolDrawEventArgs

Steema.TeeChart.SymbolDrawEventArgs Class

For a list of all members of this type, see SymbolDrawEventArgs Members

System.Object
System.EventArgs
public class SymbolDrawEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

SymbolDrawEventArgs members | Steema.TeeChart Namespace


Steema.TeeChart.SymbolDrawEventArgsMembers

Steema.TeeChart.SymbolDrawEventArgs all Members

SymbolDrawEventArgs overview

Constructors

Constructor

Public Properties

Rect
Series
ValueIndex

See Also

SymbolDrawEventArgs Class | Steema.TeeChart Namespace


Steema.TeeChart.SymbolDrawEventArgs Constructor

public SymbolDrawEventArgs(Series s,
     Int32 valind,
     Rectangle r)

See Also

SymbolDrawEventArgs Class | SymbolDrawEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.SymbolDrawEventArgsProperties

Steema.TeeChart.SymbolDrawEventArgs Properties

Public Properties

Rect
Series
ValueIndex

See Also

SymbolDrawEventArgs Class | Steema.TeeChart Namespace


Rect

Steema.TeeChart.SymbolDrawEventArgs.Rect Property

public Rectangle Rect {get; set;}

See Also

SymbolDrawEventArgs Class | SymbolDrawEventArgs Members | Steema.TeeChart Namespace


Series

Steema.TeeChart.SymbolDrawEventArgs.Series Property

public Series Series {get; set;}

See Also

SymbolDrawEventArgs Class | SymbolDrawEventArgs Members | Steema.TeeChart Namespace


ValueIndex

Steema.TeeChart.SymbolDrawEventArgs.ValueIndex Property

public Int32 ValueIndex {get; set;}

See Also

SymbolDrawEventArgs Class | SymbolDrawEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.SymbolDrawEventHandler

Steema.TeeChart.SymbolDrawEventHandler Delegate

public delegate SymbolDrawEventHandler (Object sender,
     SymbolDrawEventArgs e)

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart Namespace


Steema.TeeChart.TChart

Steema.TeeChart.TChart Class

For a list of all members of this type, see TChart Members

System.Object
Java.Lang.Object
Android.Views.View
Android.Views.ViewGroup
Android.Widget.FrameLayout
[Serializable]
public class TChart : FrameLayout , IDisposable, IJavaObject, ICallback
, IAccessibilityEventSource, ICallback, IViewManager, IViewParent
, IChart

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

TChart members | Steema.TeeChart Namespace


Steema.TeeChart.TChartMembers

Steema.TeeChart.TChart all Members

TChart overview

Constructors

Constructor Overloaded

Public Events

AfterDraw
AllowScroll
BeforeDraw
BeforeDrawAxes
BeforeDrawSeries
ClickSeries
GetAxesChartRect
GetAxisLabel
GetLegendPos
GetLegendRect
GetLegendText
GetNextAxisLabel
Scroll
ScrollMod
UndoneZoom
Zoomed

Public Fields

NotSupportedSeries

Public Methods

Clear | Reset the Chart to its default values.
DoInvalidate |
Draw | Paints the Chart in your preferred Canvas and region.
ExchangeSeries |
Free | Frees all the resources used by the chart.
OnKeyDown |
OnTouchEvent | This override implements what TChart will do when OnTouchEvent is fired.
RemoveAllSeries |

Public Properties

Animations | Collection of Animation components contained in this Chart.
Aspect | Accesses view characteristics of the Chart.
AutoRepaint | Enables/Disables Repainting of Chart when points are added.
Axes | Collection of predefined and custom axis objects.
Bitmap | Returns a Bitmap image filled with Chart.
Canvas |
Chart | Defines the Chart to display.
Cursor |
Footer | Defines Text shown at the bottom of the Chart.
Frame | Obsolete. Determines properties of frame around chart back wall. Use tChart1.Walls.Back.Pen property instead.
Graphics3D | Use the Graphics3D property to access TeeChart Draw properties and methods.
Header | Defines Text shown at top of the Chart.
Item | Default indexer ( Example: tChart1[0].Color=Color.Blue; is equivalent to tChart1.Series[0].Color=Color.Blue; )
Legend | Legend characteristics
Page | Accesses multiple page characteristics of the Chart.
Panel | Background visible attributes.
Panning | Accesses Panning characteristics.
Series | Collection of Series contained in this Chart.
SeriesCount | Obsolete. Returns number of Series in Chart. Use tChart1.Series.Count property instead.
SubFooter | Defines Text shown directly above Footer.
SubHeader | Defines Text shown directly below Header.
Tools | Collection of Tool components contained in this Chart.
Walls | Accesses left, bottom and back wall characteristics of the Chart.
Zoom | Accesses the Zoom characteristics of the Chart.

See Also

TChart Class | Steema.TeeChart Namespace


Steema.TeeChart.TChart Constructor

Overload List

public TChart(Android.Content.Context, System.Object)
public TChart(Android.Content.Context)

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Steema.TeeChart.TChart Constructor

public TChart(Context context)

See Also

TChart Constructor Overload List | TChart Class | TChart Members | Steema.TeeChart Namespace


Steema.TeeChart.TChart Constructor

public TChart(Context context,
     Object instance)

See Also

TChart Constructor Overload List | TChart Class | TChart Members | Steema.TeeChart Namespace


Steema.TeeChart.TChartEvents

Steema.TeeChart.TChart Events

Public Events

AfterDraw
AllowScroll
BeforeDraw
BeforeDrawAxes
BeforeDrawSeries
ClickSeries
GetAxesChartRect
GetAxisLabel
GetLegendPos
GetLegendRect
GetLegendText
GetNextAxisLabel
Scroll
ScrollMod
UndoneZoom
Zoomed

See Also

TChart Class | Steema.TeeChart Namespace


AfterDraw

Steema.TeeChart.TChart.AfterDraw Event

public PaintChartEventHandler  AfterDraw

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


AllowScroll

Steema.TeeChart.TChart.AllowScroll Event

public AllowScrollEventHandler  AllowScroll

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


BeforeDraw

Steema.TeeChart.TChart.BeforeDraw Event

public PaintChartEventHandler  BeforeDraw

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


BeforeDrawAxes

Steema.TeeChart.TChart.BeforeDrawAxes Event

public PaintChartEventHandler  BeforeDrawAxes

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


BeforeDrawSeries

Steema.TeeChart.TChart.BeforeDrawSeries Event

public PaintChartEventHandler  BeforeDrawSeries

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


ClickSeries

Steema.TeeChart.TChart.ClickSeries Event

public SeriesEventHandler  ClickSeries

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


GetAxesChartRect

Steema.TeeChart.TChart.GetAxesChartRect Event

public GetAxesChartRectEventHandler  GetAxesChartRect

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


GetAxisLabel

Steema.TeeChart.TChart.GetAxisLabel Event

public GetAxisLabelEventHandler  GetAxisLabel

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


GetLegendPos

Steema.TeeChart.TChart.GetLegendPos Event

public GetLegendPosEventHandler  GetLegendPos

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


GetLegendRect

Steema.TeeChart.TChart.GetLegendRect Event

public GetLegendRectEventHandler  GetLegendRect

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


GetLegendText

Steema.TeeChart.TChart.GetLegendText Event

public GetLegendTextEventHandler  GetLegendText

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


GetNextAxisLabel

Steema.TeeChart.TChart.GetNextAxisLabel Event

public GetNextAxisLabelEventHandler  GetNextAxisLabel

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Scroll

Steema.TeeChart.TChart.Scroll Event

public EventHandler  Scroll

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


ScrollMod

Steema.TeeChart.TChart.ScrollMod Event

public ScrollModHandler  ScrollMod

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


UndoneZoom

Steema.TeeChart.TChart.UndoneZoom Event

public EventHandler  UndoneZoom

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Zoomed

Steema.TeeChart.TChart.Zoomed Event

public EventHandler  Zoomed

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Steema.TeeChart.TChartFields

Steema.TeeChart.TChart Fields

Public Fields

NotSupportedSeries

See Also

TChart Class | Steema.TeeChart Namespace


NotSupportedSeries

Steema.TeeChart.TChart.NotSupportedSeries Field

public List<Type> NotSupportedSeries

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Steema.TeeChart.TChartMethods

Steema.TeeChart.TChart Methods

Public Methods

Clear | Reset the Chart to its default values.
DoInvalidate |
Draw | Paints the Chart in your preferred Canvas and region.
ExchangeSeries |
Free | Frees all the resources used by the chart.
OnKeyDown |
OnTouchEvent | This override implements what TChart will do when OnTouchEvent is fired.
RemoveAllSeries |

See Also

TChart Class | Steema.TeeChart Namespace


Clear

Steema.TeeChart.TChart.Clear Method

Reset the Chart to its default values.
public Void Clear()

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


DoInvalidate

Steema.TeeChart.TChart.DoInvalidate Method

public abstract Void DoInvalidate()

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Draw

Steema.TeeChart.TChart.Draw Method

Overload List

Paints the Chart in your preferred Canvas and region.

public override Void Draw(Android.Graphics.Canvas)
public override Void Draw(Android.Graphics.Canvas, System.Drawing.Rectangle)

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Draw

Steema.TeeChart.TChart.Draw Method

public override Void Draw(Canvas g,
     Rectangle rect)

See Also

Draw Overload List | TChart Class | TChart Members | Steema.TeeChart Namespace


Draw

Steema.TeeChart.TChart.Draw Method

Paints the Chart in your preferred Canvas and region.
public override Void Draw(Canvas g)

See Also

Draw Overload List | TChart Class | TChart Members | Steema.TeeChart Namespace


ExchangeSeries

Steema.TeeChart.TChart.ExchangeSeries Method

public Void ExchangeSeries(Int32 series1,
     Int32 series2)

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Free

Steema.TeeChart.TChart.Free Method

Frees all the resources used by the chart.
public Void Free()

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


OnKeyDown

Steema.TeeChart.TChart.OnKeyDown Method

public override Boolean OnKeyDown(Keycode keyCode,
     KeyEvent e)

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


OnTouchEvent

Steema.TeeChart.TChart.OnTouchEvent Method

This override implements what TChart will do when OnTouchEvent is fired.
public override Boolean OnTouchEvent(MotionEvent e)

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


RemoveAllSeries

Steema.TeeChart.TChart.RemoveAllSeries Method

public Void RemoveAllSeries()

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Steema.TeeChart.TChartProperties

Steema.TeeChart.TChart Properties

Public Properties

Animations | Collection of Animation components contained in this Chart.
Aspect | Accesses view characteristics of the Chart.
AutoRepaint | Enables/Disables Repainting of Chart when points are added.
Axes | Collection of predefined and custom axis objects.
Bitmap | Returns a Bitmap image filled with Chart.
Canvas |
Chart | Defines the Chart to display.
Cursor |
Footer | Defines Text shown at the bottom of the Chart.
Frame | Obsolete. Determines properties of frame around chart back wall. Use tChart1.Walls.Back.Pen property instead.
Graphics3D | Use the Graphics3D property to access TeeChart Draw properties and methods.
Header | Defines Text shown at top of the Chart.
Item | Default indexer ( Example: tChart1[0].Color=Color.Blue; is equivalent to tChart1.Series[0].Color=Color.Blue; )
Legend | Legend characteristics
Page | Accesses multiple page characteristics of the Chart.
Panel | Background visible attributes.
Panning | Accesses Panning characteristics.
Series | Collection of Series contained in this Chart.
SeriesCount | Obsolete. Returns number of Series in Chart. Use tChart1.Series.Count property instead.
SubFooter | Defines Text shown directly above Footer.
SubHeader | Defines Text shown directly below Header.
Tools | Collection of Tool components contained in this Chart.
Walls | Accesses left, bottom and back wall characteristics of the Chart.
Zoom | Accesses the Zoom characteristics of the Chart.

See Also

TChart Class | Steema.TeeChart Namespace


Animations

Steema.TeeChart.TChart.Animations Property

Collection of Animation components contained in this Chart.
public AnimationsCollection Animations {get;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Aspect

Steema.TeeChart.TChart.Aspect Property

Accesses view characteristics of the Chart.
public Aspect Aspect {get; set;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


AutoRepaint

Steema.TeeChart.TChart.AutoRepaint Property

Enables/Disables Repainting of Chart when points are added.
public Boolean AutoRepaint {get; set;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Axes

Steema.TeeChart.TChart.Axes Property

Collection of predefined and custom axis objects.
public Axes Axes {get;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Bitmap

Steema.TeeChart.TChart.Bitmap Property

Returns a Bitmap image filled with Chart.
public Bitmap Bitmap {get;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Canvas

Steema.TeeChart.TChart.Canvas Property

public Graphics3D Canvas {get; set;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Chart

Steema.TeeChart.TChart.Chart Property

Defines the Chart to display.
public Chart Chart {get; set;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Cursor

Steema.TeeChart.TChart.Cursor Property

public Cursor Cursor {get; set;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Footer

Steema.TeeChart.TChart.Footer Property

Defines Text shown at the bottom of the Chart.
public Footer Footer {get;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Frame

Steema.TeeChart.TChart.Frame Property

Obsolete. Determines properties of frame around chart back wall. Use tChart1.Walls.Back.Pen property instead.
public ChartPen Frame {get;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Graphics3D

Steema.TeeChart.TChart.Graphics3D Property

Use the Graphics3D property to access TeeChart Draw properties and methods.
public Graphics3D Graphics3D {get; set;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Header

Steema.TeeChart.TChart.Header Property

Defines Text shown at top of the Chart.
public Header Header {get;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Item

Steema.TeeChart.TChart.Item Property

Default indexer ( Example: tChart1[0].Color=Color.Blue; is equivalent to tChart1.Series[0].Color=Color.Blue; )
public Series Item(Int32 index) {get; set;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Legend

Steema.TeeChart.TChart.Legend Property

Legend characteristics
public Legend Legend {get;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Page

Steema.TeeChart.TChart.Page Property

Accesses multiple page characteristics of the Chart.
public Page Page {get;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Panel

Steema.TeeChart.TChart.Panel Property

Background visible attributes.
public Panel Panel {get; set;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Panning

Steema.TeeChart.TChart.Panning Property

Accesses Panning characteristics.
public Scroll Panning {get;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Series

Steema.TeeChart.TChart.Series Property

Collection of Series contained in this Chart.
public SeriesCollection Series {get;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


SeriesCount

Steema.TeeChart.TChart.SeriesCount Property

Obsolete. Returns number of Series in Chart. Use tChart1.Series.Count property instead.
public Int32 SeriesCount {get;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


SubFooter

Steema.TeeChart.TChart.SubFooter Property

Defines Text shown directly above Footer.
public Footer SubFooter {get;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


SubHeader

Steema.TeeChart.TChart.SubHeader Property

Defines Text shown directly below Header.
public Header SubHeader {get;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Tools

Steema.TeeChart.TChart.Tools Property

Collection of Tool components contained in this Chart.
public ToolsCollection Tools {get;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Walls

Steema.TeeChart.TChart.Walls Property

Accesses left, bottom and back wall characteristics of the Chart.
public Walls Walls {get;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Zoom

Steema.TeeChart.TChart.Zoom Property

Accesses the Zoom characteristics of the Chart.
public Zoom Zoom {get;}

See Also

TChart Class | TChart Members | Steema.TeeChart Namespace


Steema.TeeChart.TChart.AllowScrollEventArgs

Steema.TeeChart.TChart.AllowScrollEventArgs Class

Event arguments class used by AllowScroll chart event.

For a list of all members of this type, see AllowScrollEventArgs Members

System.Object
System.EventArgs
public class AllowScrollEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

AllowScrollEventArgs members | Steema.TeeChart Namespace


Steema.TeeChart.TChart.AllowScrollEventArgsMembers

Steema.TeeChart.TChart.AllowScrollEventArgs all Members

AllowScrollEventArgs overview

Constructors

Steema.TeeChart.TChart.AllowScrollEventArgs..ctor

Public Fields

AllowScroll
Max
Min

See Also

AllowScrollEventArgs Class | Steema.TeeChart Namespace


Steema.TeeChart.TChart+AllowScrollEventArgs Constructor

public TChart+AllowScrollEventArgs(Double min,
     Double max,
     Boolean allowScroll)

See Also

AllowScrollEventArgs Class | AllowScrollEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.TChart.AllowScrollEventArgsFields

Steema.TeeChart.TChart.AllowScrollEventArgs Fields

Public Fields

AllowScroll
Max
Min

See Also

AllowScrollEventArgs Class | Steema.TeeChart Namespace


AllowScroll

Steema.TeeChart.TChart+AllowScrollEventArgs.AllowScroll Field

public Boolean AllowScroll

See Also

AllowScrollEventArgs Class | AllowScrollEventArgs Members | Steema.TeeChart Namespace


Max

Steema.TeeChart.TChart+AllowScrollEventArgs.Max Field

public Double Max

See Also

AllowScrollEventArgs Class | AllowScrollEventArgs Members | Steema.TeeChart Namespace


Min

Steema.TeeChart.TChart+AllowScrollEventArgs.Min Field

public Double Min

See Also

AllowScrollEventArgs Class | AllowScrollEventArgs Members | Steema.TeeChart Namespace


Steema.TeeChart.TChart.AllowScrollEventHandler

Steema.TeeChart.TChart.AllowScrollEventHandler Delegate

Scroll event handler
public delegate AllowScrollEventHandler (Axis a,
     AllowScrollEventArgs e)

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart Namespace


Steema.TeeChart.TChart.SeriesEventHandler

Steema.TeeChart.TChart.SeriesEventHandler Delegate

Common Series event handler
public delegate SeriesEventHandler (Object sender,
     Series s,
     Int32 valueIndex,
     MotionEvent e)

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart Namespace


Steema.TeeChart.TeeChartException

Steema.TeeChart.TeeChartException Class

Underlying TeeChart exception class

For a list of all members of this type, see TeeChartException Members

System.Object
System.Exception
public class TeeChartException : Exception , ISerializable, _Exception

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

TeeChartException members | Steema.TeeChart Namespace


Steema.TeeChart.TeeChartExceptionMembers

Steema.TeeChart.TeeChartException all Members

TeeChartException overview

Constructors

Constructor Overloaded

See Also

TeeChartException Class | Steema.TeeChart Namespace


Steema.TeeChart.TeeChartException Constructor

Overload List

public TeeChartException()
public TeeChartException(System.String, System.Exception)
public TeeChartException(System.String)

See Also

TeeChartException Class | TeeChartException Members | Steema.TeeChart Namespace


Steema.TeeChart.TeeChartException Constructor

public TeeChartException(String message)

See Also

TeeChartException Constructor Overload List | TeeChartException Class | TeeChartException Members | Steema.TeeChart Namespace


Steema.TeeChart.TeeChartException Constructor

public TeeChartException(String message,
     Exception e)

See Also

TeeChartException Constructor Overload List | TeeChartException Class | TeeChartException Members | Steema.TeeChart Namespace


Steema.TeeChart.TeeChartException Constructor

public TeeChartException()

See Also

TeeChartException Constructor Overload List | TeeChartException Class | TeeChartException Members | Steema.TeeChart Namespace


Steema.TeeChart.TeeEvent

Steema.TeeChart.TeeEvent Class

Internal use. Underlying Chart event class

For a list of all members of this type, see TeeEvent Members

System.Object
public class TeeEvent : Object

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

TeeEvent members | Steema.TeeChart Namespace


Steema.TeeChart.TeeEventMembers

Steema.TeeChart.TeeEvent all Members

TeeEvent overview

Constructors

Constructor

Public Fields

sender

See Also

TeeEvent Class | Steema.TeeChart Namespace


Steema.TeeChart.TeeEvent Constructor

public TeeEvent()

See Also

TeeEvent Class | TeeEvent Members | Steema.TeeChart Namespace


Steema.TeeChart.TeeEventFields

Steema.TeeChart.TeeEvent Fields

Public Fields

sender

See Also

TeeEvent Class | Steema.TeeChart Namespace


sender

Steema.TeeChart.TeeEvent.sender Field

public Chart sender

See Also

TeeEvent Class | TeeEvent Members | Steema.TeeChart Namespace


Steema.TeeChart.TeeMouseEvent

Steema.TeeChart.TeeMouseEvent Class

Internal use. Mouse events

For a list of all members of this type, see TeeMouseEvent Members

System.Object
Steema.TeeChart.TeeEvent
public class TeeMouseEvent : TeeEvent

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

TeeMouseEvent members | Steema.TeeChart Namespace


Steema.TeeChart.TeeMouseEventMembers

Steema.TeeChart.TeeMouseEvent all Members

TeeMouseEvent overview

Constructors

Constructor

Public Fields

Event
mArgs
ModifierKeys
sender (inherited from TeeEvent)

See Also

TeeMouseEvent Class | Steema.TeeChart Namespace


Steema.TeeChart.TeeMouseEvent Constructor

public TeeMouseEvent()

See Also

TeeMouseEvent Class | TeeMouseEvent Members | Steema.TeeChart Namespace


Steema.TeeChart.TeeMouseEventFields

Steema.TeeChart.TeeMouseEvent Fields

Public Fields

Event
mArgs
ModifierKeys
sender (inherited from TeeEvent)

See Also

TeeMouseEvent Class | Steema.TeeChart Namespace


Event

Steema.TeeChart.TeeMouseEvent.Event Field

public MouseEventKinds Event

See Also

TeeMouseEvent Class | TeeMouseEvent Members | Steema.TeeChart Namespace


mArgs

Steema.TeeChart.TeeMouseEvent.mArgs Field

public MotionEvent mArgs

See Also

TeeMouseEvent Class | TeeMouseEvent Members | Steema.TeeChart Namespace


ModifierKeys

Steema.TeeChart.TeeMouseEvent.ModifierKeys Field

public Keycode ModifierKeys

See Also

TeeMouseEvent Class | TeeMouseEvent Members | Steema.TeeChart Namespace


Steema.TeeChart.Texts

Steema.TeeChart.Texts Class

Text message and dialogue constants

For a list of all members of this type, see Texts Members

System.Object
public class Texts : Object

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Texts members | Steema.TeeChart Namespace


Steema.TeeChart.TextsMembers

Steema.TeeChart.Texts all Members

Texts overview

Public Fields

About
AddNewGroup
ADOConnection
All
AllDataFilter
AllFilesFilter
AllPictureFilter
AllSeries
AnnotationDesc
AnnotationSummary
AnnotationTool
AnswerVectorIndex
ApplyColorPalette
AsBMP
AsEMF
AsFlex
AsGIF
AsHTML5
AsJPEG
AsJScript
AskDataSet
AskDataSource
AskLanguage
AsPCX
AsPDF
AsPNG
AsPS
AsSVG
AsTIFF
AsVML
AsXAML
AVIFile
AxisArrowDesc
AxisArrowSummary
AxisArrowTool
AxisBreaksDesc
AxisBreaksSummary
AxisBreaksTool
AxisDlgValue
AxisIncrementNeg
AxisLabels
AxisLabelSep
AxisLogBase
AxisLogDateTime
AxisLogNotPositive
AxisMaxMin
AxisMinMax
AxisScrollDesc
AxisScrollSummary
AxisScrollTool
AxisTitle
BannerTool
BannerToolDesc
BannerToolSummary
BaseLine
BlackIsBackTheme
BlueSkyTheme
BMPFilter
Border
BottomAxis
Box
BrowseImage
BusinessTheme
CalcPeriod
CalendarSeries
Cancel
CandleBar
CandleNoClose
CandleNoOpen
CanNotCreateTempChart
CanNotEmailChart
CannotFindEditor
CanNotFindTempPath
CannotLoadChartFromURL
CannotLoadSeriesDataFromURL
CantDeleteAncestor
CarriageReturnChar
ChangeGroupName
ChangeSeriesTitle
CharForHeight
ChartImageDesc
ChartImageSummary
ChartWizard
CheckPointerSize
Circle
CircularSeries
ClassicTheme
Clear
ClearImage
ClearMessage
ClipSeries
ClipSeriesDesc
ClipSeriesSummary
ColorBandDesc
ColorBandSummary
ColorBandTool
ColorGridSeriesRangeExceed
ColorLineDesc
ColorLineSummary
ColorLineTool
ColorPalette
ColorRange
Colors
Column
ColumnSeparator
CommanMsg3D
CommanMsgChart
CommanMsgCopy
CommanMsgDepth
CommanMsgDepthing
CommanMsgDepthLabel
CommanMsgEdit
CommanMsgMove
CommanMsgMoveLabel
CommanMsgMoving
CommanMsgNormal
CommanMsgNormalLabel
CommanMsgNormalPieLabel
CommanMsgPanel
CommanMsgPieExploding
CommanMsgPrint
CommanMsgRotate
CommanMsgRotateLabel
CommanMsgRotating
CommanMsgSave
CommanMsgZoom
CommanMsgZooming
CommanMsgZoomLabel
Cone
Confirm
Copyright
Cover
Cross
Cube
Current
CursorTool
CursorToolDesc
CursorToolSummary
CustomAxes
CustomAxesEditor
CustomHotspotDesc
CustomHotspotSummary
CustomHotspotTool
DarkPen
DataSet
DataSource
DataTableTool
DataTableToolDesc
DataTableToolSummary
DateTime
DateTimeFormat
Default
DefaultDemoTee
DefaultEditorHeight
DefaultEditorSize
DefaultFontName
DefaultFontSize
DefaultPercentOf
DefaultPercentOf2
DefaultTheme
DefDateTimeFormat
DefLogValueFormat
DefPercentFormat
DefValueFormat
Delete
DeltaPointSeries
DepthAxis
DepthTopAxis
DesignFolderNotFound
DesiredIncrement
DiagCross
Diamond
DotFrame
Dotted
Down
DownTri
DragMarksDesc
DragMarksSummary
DragMarksTool
DragPoint
DragPointDesc
DragPointSummary
DrawLineDesc
DrawLineSummary
DrawLineTool
Edit
EditChart
Editing
Ellipse
EMFFilter
EmptyTeeFile
EnterDateTime
ExcelFilter
ExcelTheme
Execute
ExpandAnimation
ExpandDesc
ExpandSummary
ExpAverageWeight
ExpFinish
Exploded
ExpNext
ExportChart
ExportPanelNotSet
ExtraLegendDesc
ExtraLegendSummary
ExtraLegendTool
ExtrOut
FaderTool
FaderToolSummary
FibonacciTool
FibonacciToolDesc
FieldNotFound
FieldsSeparator
FileSize
Filled
FillSample
First
FittingError
FlexFilter
Foot
FunctionAdd
FunctionADX
FunctionAverage
FunctionBollinger
FunctionCCI
FunctionCLV
FunctionCompress
FunctionCompressOHLC
FunctionCorrelation
FunctionCount
FunctionCross
FunctionCumulative
FunctionCurveFitting
FunctionCustom
FunctionDivide
FunctionDownSampling
FunctionExpAverage
FunctionExpMovAve
FunctionExpTrend
FunctionHigh
FunctionHistogram
FunctionLogTrend
FunctionLow
FunctionMACD
FunctionMedian
FunctionMode
FunctionMomentum
FunctionMomentumDiv
FunctionMovingAverage
FunctionMultiply
FunctionNone
FunctionOBV
FunctionPerf
FunctionPerimeter
FunctionPeriod
FunctionPVO
FunctionRMS
FunctionRSI
FunctionSAR
FunctionSmooth
FunctionStdDeviation
FunctionStochastic
FunctionSubtract
FunctionTrend
FunctionVariance
FunnelBelow
FunnelExceed
FunnelPercent
FunnelSegment
FunnelSeries
FunnelWithin
Gallery3D
GalleryArea
GalleryArrow
GalleryBar
GalleryBar3D
GalleryBarJoin
GalleryBezier
GalleryBigCandle
GalleryBoxPlot
GalleryBubble
GalleryCandle
GalleryCircled
GalleryCircularGauge
GalleryClock
GalleryColorGrid
GalleryContour
GalleryCursor
GalleryDarvas
GalleryDonut
GalleryEquiVolume
GalleryError
GalleryErrorBar
GalleryErrorPoint
GalleryErrorPoint3D
GalleryExtended
GalleryFastLine
GalleryFinancial
GalleryFunctions
GalleryGantt
GalleryGauge
GalleryGauges
GalleryHighLow
GalleryHistogram
GalleryHorizBar
GalleryHorizBoxPlot
GalleryHorizLine
GalleryIsoSurface
GalleryKagi
GalleryKnobGauge
GalleryLine
GalleryLinearGauge
GalleryLinePoint
GalleryLogoFont
GalleryMap
GalleryNumericGauge
GalleryOrgChart
GalleryPie
GalleryPoint
GalleryPoint3D
GalleryPointFigure
GalleryPolar
GalleryPolarBar
GalleryPyramid
GalleryRadar
GalleryRenko
GallerySamples
GalleryShape
GallerySmith
GalleryStandard
GalleryStats
GallerySurface
GalleryTagCloud
GalleryTower
GalleryTreeMap
GalleryTriSurface
GalleryVector3D
GalleryVerticalLinearGauge
GalleryVolume
GalleryVolumePipe
GalleryWaterFall
GalleryWindRose
GalleryWorldMap
GalleryWorldMaps
GanttSample1
GanttSample10
GanttSample2
GanttSample3
GanttSample4
GanttSample5
GanttSample6
GanttSample7
GanttSample8
GanttSample9
GanttTool
GanttToolDesc
GanttToolSummary
GIFFilter
Gradient
GrayscaleTheme
Grid3D
GridBandDesc
GridBandSummary
GridBandTool
GridTranspose
GridTransposeDesc
GridTransposeSummary
GroupName
Height
HelperScriptAnnotation
Hollow
HorizAreaSeries
HorizHistogramSeries
HorizLine
HotspotSummary
HotspotTool
HTMLFilter
Image
ImageBarSeries
ImagePointSeries
ImageTool
ImageToolSummary
ImportChart
ImportTeeChart
ImportTeeChartFile
IncorrectMaxMinValue
Index
Insert
InvalidEditorClass
InvalidTeeFile
InvPyramid
JPEGFilter
JScriptFilter
JScriptNonSupportMsg
Labels
Last
LEDGauge
LeftAxis
Legend
LegendColorWidth
LegendFirstValue
LegendPaleteToolDesc
LegendPaletteTool
LegendPaletteToolSummary
LegendScrollBarDesc
LegendScrollBarSummary
LightTool
LightToolDesc
LightToolSummary
Line
Lines
LineSeparator
Load
LoadChart
LowBezierPoints
Magnify
MagnifySummary
MappingAfrica
MappingAsia
MappingAustralia
MappingCentralAmerica
MappingEurope
MappingEurope15
MappingEurope27
MappingMiddleEast
MappingNorthAmerica
MappingSouthAmerica
MappingSpain
MappingUSA
MappingUSAHawaiiAlaska
MappingWorld
MapSeries
MarkerTool
Marks
MarksTipDesc
MarksTipSummary
MarksTipTool
Maximum
MaxPointsPerPage
MenuDelete
MenuEdit
MenuNew
MenuRename
MenuViewToolbar
MildOut
Minimum
MissingEditorClass
NativePen
NearestPointDesc
NearestPointSummary
NearestTool
NewName
NewSeriesTitle
Next
No
NoBorder
NoCircle
NoGrid
NoHigh
NoLine
NoLines
NoLow
None
NoPoint
NoPrinterError
Normal
NoSeriesSelected
OnlineSupport
OpenDocumentFilter
OpenTeeChartFile
OpenTextFile
OpenXmlThemeFile
OperaTheme
OpportunityValues
Options
Origin
PageNumber
PageOfPages
Patterns
PCXFilter
PDFFilter
Percent3D
Period
PeriodRange
PieOther
PieSample1
PieSample2
PieSample3
PieSample4
PieSample5
PieSample6
PieSample7
PieSample8
PieTool
PieToolDesc
PieToolSummary
Play
PNGFilter
Point2D
Points
PolarDegreeSymbol
PolarGridSeries
PolyDegreeRange
Positions
Post
Preview
PrintPreview
Prior
Property
PSFilter
Pyramid
QuoteValues
RandomTheme
RecordVideo
Rectangle
RectangleTool
RectangleToolDesc
RefreshData
RefreshInterval
RenamePage
RightAxis
RotateDesc
RotateSummary
RotateTool
SaveChart
SaveChartToFile
Scale
ScrollBarTool
ScrollPagerSummary
ScrollPagerTool
ScrollTool
ScrollToolDesc
ScrollToolSummary
SelectAVIFile
SelectedSeries
SelectFolder
SelectorTool
SelectorToolDesc
SelectorToolSummary
SelectPictureFile
SelfStack
SemiPie
Separator
Series
SeriesAnimationDesc
SeriesAnimationSummary
SeriesAnimTool
SeriesBandTool
SeriesBandToolDesc
SeriesBandToolSummary
SeriesDelete
SeriesHotspotDesc
SeriesInvDataSource
SeriesList
SeriesParentNoSelf
SeriesRegionTool
SeriesRegionToolSummary
SeriesSetDataSource
SeriesStatsTool
SeriesStatsToolDesc
SeriesStatsToolSummary
SeriesTextFieldZero
SeriesTranspose
SeriesTransposeDesc
SeriesTransposeSummary
Shadow
ShapeGallery1
ShapeGallery2
SideAll
Sides
SingleColor
SingleRecord
SmallDotsPen
SmithReactance
SmithResistance
Stack
Stack100
Stairs
Star
Stop
SubChartChartName
SubChartNewChart
SubChartNewName
SubChartRenameChart
SubChartTool
SubChartToolSummary
Summary
SupportURL
SureToApply
SureToDelete
SurfaceNearestTool
SurfaceNearestToolDesc
SurfaceNearestToolSummary
SVGFilter
TabDelimiter
TeeChart
TeeChartExceptionString
TeeChartPocketEval
TeeChartTheme
TeeFiles
TeeFilesExtension
TENFilter
TernaryMarkRadius
TernaryMarkWeight
TernarySeries
Test
Text
TextFile
TextFilter
TextSrcURL
Themes
ThemeSelector
TIFFFilter
Title
TopAxis
Transparency
Triangle
TriSurfaceAllColinear
TriSurfaceLess
TriSurfaceSimilar
TxtFilesExtension
Up
Value
ValuesAngle
ValuesArrowEndX
ValuesArrowEndY
ValuesBar
ValuesBubbleRadius
ValuesClose
ValuesDate
ValuesFormat
ValuesGanttEnd
ValuesGanttNextTask
ValuesGanttStart
ValuesHigh
ValuesLow
ValuesOffset
ValuesOpen
ValuesPie
ValuesStdError
ValuesVectorEndZ
ValuesVolume
ValuesWeighting
ValuesX
ValuesY
ValuesZ
VertLine
VideoPlayerTool
VideoPlayerToolSummary
VideoTool
VideoToolSummary
View3D
VMLFilter
WarningHIColor
WEBTheme
WireFrame
WizardSureToClose
WizardTab
WMFFilter
WrongTeeFileFormat
XAMLFilter
XMLFile
XMLFilter
XPTheme
Yes
ZoomTool
ZoomToolDesc
ZoomToolSummary

See Also

Texts Class | Steema.TeeChart Namespace


Steema.TeeChart.TextsFields

Steema.TeeChart.Texts Fields

Public Fields

About
AddNewGroup
ADOConnection
All
AllDataFilter
AllFilesFilter
AllPictureFilter
AllSeries
AnnotationDesc
AnnotationSummary
AnnotationTool
AnswerVectorIndex
ApplyColorPalette
AsBMP
AsEMF
AsFlex
AsGIF
AsHTML5
AsJPEG
AsJScript
AskDataSet
AskDataSource
AskLanguage
AsPCX
AsPDF
AsPNG
AsPS
AsSVG
AsTIFF
AsVML
AsXAML
AVIFile
AxisArrowDesc
AxisArrowSummary
AxisArrowTool
AxisBreaksDesc
AxisBreaksSummary
AxisBreaksTool
AxisDlgValue
AxisIncrementNeg
AxisLabels
AxisLabelSep
AxisLogBase
AxisLogDateTime
AxisLogNotPositive
AxisMaxMin
AxisMinMax
AxisScrollDesc
AxisScrollSummary
AxisScrollTool
AxisTitle
BannerTool
BannerToolDesc
BannerToolSummary
BaseLine
BlackIsBackTheme
BlueSkyTheme
BMPFilter
Border
BottomAxis
Box
BrowseImage
BusinessTheme
CalcPeriod
CalendarSeries
Cancel
CandleBar
CandleNoClose
CandleNoOpen
CanNotCreateTempChart
CanNotEmailChart
CannotFindEditor
CanNotFindTempPath
CannotLoadChartFromURL
CannotLoadSeriesDataFromURL
CantDeleteAncestor
CarriageReturnChar
ChangeGroupName
ChangeSeriesTitle
CharForHeight
ChartImageDesc
ChartImageSummary
ChartWizard
CheckPointerSize
Circle
CircularSeries
ClassicTheme
Clear
ClearImage
ClearMessage
ClipSeries
ClipSeriesDesc
ClipSeriesSummary
ColorBandDesc
ColorBandSummary
ColorBandTool
ColorGridSeriesRangeExceed
ColorLineDesc
ColorLineSummary
ColorLineTool
ColorPalette
ColorRange
Colors
Column
ColumnSeparator
CommanMsg3D
CommanMsgChart
CommanMsgCopy
CommanMsgDepth
CommanMsgDepthing
CommanMsgDepthLabel
CommanMsgEdit
CommanMsgMove
CommanMsgMoveLabel
CommanMsgMoving
CommanMsgNormal
CommanMsgNormalLabel
CommanMsgNormalPieLabel
CommanMsgPanel
CommanMsgPieExploding
CommanMsgPrint
CommanMsgRotate
CommanMsgRotateLabel
CommanMsgRotating
CommanMsgSave
CommanMsgZoom
CommanMsgZooming
CommanMsgZoomLabel
Cone
Confirm
Copyright
Cover
Cross
Cube
Current
CursorTool
CursorToolDesc
CursorToolSummary
CustomAxes
CustomAxesEditor
CustomHotspotDesc
CustomHotspotSummary
CustomHotspotTool
DarkPen
DataSet
DataSource
DataTableTool
DataTableToolDesc
DataTableToolSummary
DateTime
DateTimeFormat
Default
DefaultDemoTee
DefaultEditorHeight
DefaultEditorSize
DefaultFontName
DefaultFontSize
DefaultPercentOf
DefaultPercentOf2
DefaultTheme
DefDateTimeFormat
DefLogValueFormat
DefPercentFormat
DefValueFormat
Delete
DeltaPointSeries
DepthAxis
DepthTopAxis
DesignFolderNotFound
DesiredIncrement
DiagCross
Diamond
DotFrame
Dotted
Down
DownTri
DragMarksDesc
DragMarksSummary
DragMarksTool
DragPoint
DragPointDesc
DragPointSummary
DrawLineDesc
DrawLineSummary
DrawLineTool
Edit
EditChart
Editing
Ellipse
EMFFilter
EmptyTeeFile
EnterDateTime
ExcelFilter
ExcelTheme
Execute
ExpandAnimation
ExpandDesc
ExpandSummary
ExpAverageWeight
ExpFinish
Exploded
ExpNext
ExportChart
ExportPanelNotSet
ExtraLegendDesc
ExtraLegendSummary
ExtraLegendTool
ExtrOut
FaderTool
FaderToolSummary
FibonacciTool
FibonacciToolDesc
FieldNotFound
FieldsSeparator
FileSize
Filled
FillSample
First
FittingError
FlexFilter
Foot
FunctionAdd
FunctionADX
FunctionAverage
FunctionBollinger
FunctionCCI
FunctionCLV
FunctionCompress
FunctionCompressOHLC
FunctionCorrelation
FunctionCount
FunctionCross
FunctionCumulative
FunctionCurveFitting
FunctionCustom
FunctionDivide
FunctionDownSampling
FunctionExpAverage
FunctionExpMovAve
FunctionExpTrend
FunctionHigh
FunctionHistogram
FunctionLogTrend
FunctionLow
FunctionMACD
FunctionMedian
FunctionMode
FunctionMomentum
FunctionMomentumDiv
FunctionMovingAverage
FunctionMultiply
FunctionNone
FunctionOBV
FunctionPerf
FunctionPerimeter
FunctionPeriod
FunctionPVO
FunctionRMS
FunctionRSI
FunctionSAR
FunctionSmooth
FunctionStdDeviation
FunctionStochastic
FunctionSubtract
FunctionTrend
FunctionVariance
FunnelBelow
FunnelExceed
FunnelPercent
FunnelSegment
FunnelSeries
FunnelWithin
Gallery3D
GalleryArea
GalleryArrow
GalleryBar
GalleryBar3D
GalleryBarJoin
GalleryBezier
GalleryBigCandle
GalleryBoxPlot
GalleryBubble
GalleryCandle
GalleryCircled
GalleryCircularGauge
GalleryClock
GalleryColorGrid
GalleryContour
GalleryCursor
GalleryDarvas
GalleryDonut
GalleryEquiVolume
GalleryError
GalleryErrorBar
GalleryErrorPoint
GalleryErrorPoint3D
GalleryExtended
GalleryFastLine
GalleryFinancial
GalleryFunctions
GalleryGantt
GalleryGauge
GalleryGauges
GalleryHighLow
GalleryHistogram
GalleryHorizBar
GalleryHorizBoxPlot
GalleryHorizLine
GalleryIsoSurface
GalleryKagi
GalleryKnobGauge
GalleryLine
GalleryLinearGauge
GalleryLinePoint
GalleryLogoFont
GalleryMap
GalleryNumericGauge
GalleryOrgChart
GalleryPie
GalleryPoint
GalleryPoint3D
GalleryPointFigure
GalleryPolar
GalleryPolarBar
GalleryPyramid
GalleryRadar
GalleryRenko
GallerySamples
GalleryShape
GallerySmith
GalleryStandard
GalleryStats
GallerySurface
GalleryTagCloud
GalleryTower
GalleryTreeMap
GalleryTriSurface
GalleryVector3D
GalleryVerticalLinearGauge
GalleryVolume
GalleryVolumePipe
GalleryWaterFall
GalleryWindRose
GalleryWorldMap
GalleryWorldMaps
GanttSample1
GanttSample10
GanttSample2
GanttSample3
GanttSample4
GanttSample5
GanttSample6
GanttSample7
GanttSample8
GanttSample9
GanttTool
GanttToolDesc
GanttToolSummary
GIFFilter
Gradient
GrayscaleTheme
Grid3D
GridBandDesc
GridBandSummary
GridBandTool
GridTranspose
GridTransposeDesc
GridTransposeSummary
GroupName
Height
HelperScriptAnnotation
Hollow
HorizAreaSeries
HorizHistogramSeries
HorizLine
HotspotSummary
HotspotTool
HTMLFilter
Image
ImageBarSeries
ImagePointSeries
ImageTool
ImageToolSummary
ImportChart
ImportTeeChart
ImportTeeChartFile
IncorrectMaxMinValue
Index
Insert
InvalidEditorClass
InvalidTeeFile
InvPyramid
JPEGFilter
JScriptFilter
JScriptNonSupportMsg
Labels
Last
LEDGauge
LeftAxis
Legend
LegendColorWidth
LegendFirstValue
LegendPaleteToolDesc
LegendPaletteTool
LegendPaletteToolSummary
LegendScrollBarDesc
LegendScrollBarSummary
LightTool
LightToolDesc
LightToolSummary
Line
Lines
LineSeparator
Load
LoadChart
LowBezierPoints
Magnify
MagnifySummary
MappingAfrica
MappingAsia
MappingAustralia
MappingCentralAmerica
MappingEurope
MappingEurope15
MappingEurope27
MappingMiddleEast
MappingNorthAmerica
MappingSouthAmerica
MappingSpain
MappingUSA
MappingUSAHawaiiAlaska
MappingWorld
MapSeries
MarkerTool
Marks
MarksTipDesc
MarksTipSummary
MarksTipTool
Maximum
MaxPointsPerPage
MenuDelete
MenuEdit
MenuNew
MenuRename
MenuViewToolbar
MildOut
Minimum
MissingEditorClass
NativePen
NearestPointDesc
NearestPointSummary
NearestTool
NewName
NewSeriesTitle
Next
No
NoBorder
NoCircle
NoGrid
NoHigh
NoLine
NoLines
NoLow
None
NoPoint
NoPrinterError
Normal
NoSeriesSelected
OnlineSupport
OpenDocumentFilter
OpenTeeChartFile
OpenTextFile
OpenXmlThemeFile
OperaTheme
OpportunityValues
Options
Origin
PageNumber
PageOfPages
Patterns
PCXFilter
PDFFilter
Percent3D
Period
PeriodRange
PieOther
PieSample1
PieSample2
PieSample3
PieSample4
PieSample5
PieSample6
PieSample7
PieSample8
PieTool
PieToolDesc
PieToolSummary
Play
PNGFilter
Point2D
Points
PolarDegreeSymbol
PolarGridSeries
PolyDegreeRange
Positions
Post
Preview
PrintPreview
Prior
Property
PSFilter
Pyramid
QuoteValues
RandomTheme
RecordVideo
Rectangle
RectangleTool
RectangleToolDesc
RefreshData
RefreshInterval
RenamePage
RightAxis
RotateDesc
RotateSummary
RotateTool
SaveChart
SaveChartToFile
Scale
ScrollBarTool
ScrollPagerSummary
ScrollPagerTool
ScrollTool
ScrollToolDesc
ScrollToolSummary
SelectAVIFile
SelectedSeries
SelectFolder
SelectorTool
SelectorToolDesc
SelectorToolSummary
SelectPictureFile
SelfStack
SemiPie
Separator
Series
SeriesAnimationDesc
SeriesAnimationSummary
SeriesAnimTool
SeriesBandTool
SeriesBandToolDesc
SeriesBandToolSummary
SeriesDelete
SeriesHotspotDesc
SeriesInvDataSource
SeriesList
SeriesParentNoSelf
SeriesRegionTool
SeriesRegionToolSummary
SeriesSetDataSource
SeriesStatsTool
SeriesStatsToolDesc
SeriesStatsToolSummary
SeriesTextFieldZero
SeriesTranspose
SeriesTransposeDesc
SeriesTransposeSummary
Shadow
ShapeGallery1
ShapeGallery2
SideAll
Sides
SingleColor
SingleRecord
SmallDotsPen
SmithReactance
SmithResistance
Stack
Stack100
Stairs
Star
Stop
SubChartChartName
SubChartNewChart
SubChartNewName
SubChartRenameChart
SubChartTool
SubChartToolSummary
Summary
SupportURL
SureToApply
SureToDelete
SurfaceNearestTool
SurfaceNearestToolDesc
SurfaceNearestToolSummary
SVGFilter
TabDelimiter
TeeChart
TeeChartExceptionString
TeeChartPocketEval
TeeChartTheme
TeeFiles
TeeFilesExtension
TENFilter
TernaryMarkRadius
TernaryMarkWeight
TernarySeries
Test
Text
TextFile
TextFilter
TextSrcURL
Themes
ThemeSelector
TIFFFilter
Title
TopAxis
Transparency
Triangle
TriSurfaceAllColinear
TriSurfaceLess
TriSurfaceSimilar
TxtFilesExtension
Up
Value
ValuesAngle
ValuesArrowEndX
ValuesArrowEndY
ValuesBar
ValuesBubbleRadius
ValuesClose
ValuesDate
ValuesFormat
ValuesGanttEnd
ValuesGanttNextTask
ValuesGanttStart
ValuesHigh
ValuesLow
ValuesOffset
ValuesOpen
ValuesPie
ValuesStdError
ValuesVectorEndZ
ValuesVolume
ValuesWeighting
ValuesX
ValuesY
ValuesZ
VertLine
VideoPlayerTool
VideoPlayerToolSummary
VideoTool
VideoToolSummary
View3D
VMLFilter
WarningHIColor
WEBTheme
WireFrame
WizardSureToClose
WizardTab
WMFFilter
WrongTeeFileFormat
XAMLFilter
XMLFile
XMLFilter
XPTheme
Yes
ZoomTool
ZoomToolDesc
ZoomToolSummary

See Also

Texts Class | Steema.TeeChart Namespace


About

Steema.TeeChart.Texts.About Field

public String About

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AddNewGroup

Steema.TeeChart.Texts.AddNewGroup Field

public String AddNewGroup

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ADOConnection

Steema.TeeChart.Texts.ADOConnection Field

public String ADOConnection

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


All

Steema.TeeChart.Texts.All Field

public String All

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AllDataFilter

Steema.TeeChart.Texts.AllDataFilter Field

public String AllDataFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AllFilesFilter

Steema.TeeChart.Texts.AllFilesFilter Field

public String AllFilesFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AllPictureFilter

Steema.TeeChart.Texts.AllPictureFilter Field

public String AllPictureFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AllSeries

Steema.TeeChart.Texts.AllSeries Field

public String AllSeries

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AnnotationDesc

Steema.TeeChart.Texts.AnnotationDesc Field

public const String AnnotationDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AnnotationSummary

Steema.TeeChart.Texts.AnnotationSummary Field

public String AnnotationSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AnnotationTool

Steema.TeeChart.Texts.AnnotationTool Field

public String AnnotationTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AnswerVectorIndex

Steema.TeeChart.Texts.AnswerVectorIndex Field

public String AnswerVectorIndex

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ApplyColorPalette

Steema.TeeChart.Texts.ApplyColorPalette Field

public String ApplyColorPalette

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AsBMP

Steema.TeeChart.Texts.AsBMP Field

public String AsBMP

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AsEMF

Steema.TeeChart.Texts.AsEMF Field

public String AsEMF

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AsFlex

Steema.TeeChart.Texts.AsFlex Field

public String AsFlex

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AsGIF

Steema.TeeChart.Texts.AsGIF Field

public String AsGIF

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AsHTML5

Steema.TeeChart.Texts.AsHTML5 Field

public String AsHTML5

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AsJPEG

Steema.TeeChart.Texts.AsJPEG Field

public String AsJPEG

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AsJScript

Steema.TeeChart.Texts.AsJScript Field

public String AsJScript

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AskDataSet

Steema.TeeChart.Texts.AskDataSet Field

public String AskDataSet

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AskDataSource

Steema.TeeChart.Texts.AskDataSource Field

public String AskDataSource

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AskLanguage

Steema.TeeChart.Texts.AskLanguage Field

public String AskLanguage

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AsPCX

Steema.TeeChart.Texts.AsPCX Field

public String AsPCX

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AsPDF

Steema.TeeChart.Texts.AsPDF Field

public String AsPDF

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AsPNG

Steema.TeeChart.Texts.AsPNG Field

public String AsPNG

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AsPS

Steema.TeeChart.Texts.AsPS Field

public String AsPS

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AsSVG

Steema.TeeChart.Texts.AsSVG Field

public String AsSVG

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AsTIFF

Steema.TeeChart.Texts.AsTIFF Field

public String AsTIFF

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AsVML

Steema.TeeChart.Texts.AsVML Field

public String AsVML

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AsXAML

Steema.TeeChart.Texts.AsXAML Field

public String AsXAML

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AVIFile

Steema.TeeChart.Texts.AVIFile Field

public String AVIFile

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AxisArrowDesc

Steema.TeeChart.Texts.AxisArrowDesc Field

public const String AxisArrowDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AxisArrowSummary

Steema.TeeChart.Texts.AxisArrowSummary Field

public String AxisArrowSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AxisArrowTool

Steema.TeeChart.Texts.AxisArrowTool Field

public String AxisArrowTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AxisBreaksDesc

Steema.TeeChart.Texts.AxisBreaksDesc Field

public const String AxisBreaksDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AxisBreaksSummary

Steema.TeeChart.Texts.AxisBreaksSummary Field

public String AxisBreaksSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AxisBreaksTool

Steema.TeeChart.Texts.AxisBreaksTool Field

public String AxisBreaksTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AxisDlgValue

Steema.TeeChart.Texts.AxisDlgValue Field

public String AxisDlgValue

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AxisIncrementNeg

Steema.TeeChart.Texts.AxisIncrementNeg Field

public String AxisIncrementNeg

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AxisLabels

Steema.TeeChart.Texts.AxisLabels Field

public String AxisLabels

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AxisLabelSep

Steema.TeeChart.Texts.AxisLabelSep Field

public String AxisLabelSep

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AxisLogBase

Steema.TeeChart.Texts.AxisLogBase Field

public String AxisLogBase

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AxisLogDateTime

Steema.TeeChart.Texts.AxisLogDateTime Field

public String AxisLogDateTime

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AxisLogNotPositive

Steema.TeeChart.Texts.AxisLogNotPositive Field

public String AxisLogNotPositive

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AxisMaxMin

Steema.TeeChart.Texts.AxisMaxMin Field

public String AxisMaxMin

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AxisMinMax

Steema.TeeChart.Texts.AxisMinMax Field

public String AxisMinMax

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AxisScrollDesc

Steema.TeeChart.Texts.AxisScrollDesc Field

public const String AxisScrollDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AxisScrollSummary

Steema.TeeChart.Texts.AxisScrollSummary Field

public String AxisScrollSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AxisScrollTool

Steema.TeeChart.Texts.AxisScrollTool Field

public String AxisScrollTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


AxisTitle

Steema.TeeChart.Texts.AxisTitle Field

public String AxisTitle

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


BannerTool

Steema.TeeChart.Texts.BannerTool Field

public String BannerTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


BannerToolDesc

Steema.TeeChart.Texts.BannerToolDesc Field

public const String BannerToolDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


BannerToolSummary

Steema.TeeChart.Texts.BannerToolSummary Field

public String BannerToolSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


BaseLine

Steema.TeeChart.Texts.BaseLine Field

public String BaseLine

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


BlackIsBackTheme

Steema.TeeChart.Texts.BlackIsBackTheme Field

public String BlackIsBackTheme

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


BlueSkyTheme

Steema.TeeChart.Texts.BlueSkyTheme Field

public String BlueSkyTheme

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


BMPFilter

Steema.TeeChart.Texts.BMPFilter Field

public String BMPFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Border

Steema.TeeChart.Texts.Border Field

public String Border

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


BottomAxis

Steema.TeeChart.Texts.BottomAxis Field

public String BottomAxis

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Box

Steema.TeeChart.Texts.Box Field

public String Box

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


BrowseImage

Steema.TeeChart.Texts.BrowseImage Field

public String BrowseImage

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


BusinessTheme

Steema.TeeChart.Texts.BusinessTheme Field

public String BusinessTheme

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CalcPeriod

Steema.TeeChart.Texts.CalcPeriod Field

public String CalcPeriod

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CalendarSeries

Steema.TeeChart.Texts.CalendarSeries Field

public String CalendarSeries

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Cancel

Steema.TeeChart.Texts.Cancel Field

public String Cancel

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CandleBar

Steema.TeeChart.Texts.CandleBar Field

public String CandleBar

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CandleNoClose

Steema.TeeChart.Texts.CandleNoClose Field

public String CandleNoClose

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CandleNoOpen

Steema.TeeChart.Texts.CandleNoOpen Field

public String CandleNoOpen

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CanNotCreateTempChart

Steema.TeeChart.Texts.CanNotCreateTempChart Field

public String CanNotCreateTempChart

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CanNotEmailChart

Steema.TeeChart.Texts.CanNotEmailChart Field

public String CanNotEmailChart

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CannotFindEditor

Steema.TeeChart.Texts.CannotFindEditor Field

public String CannotFindEditor

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CanNotFindTempPath

Steema.TeeChart.Texts.CanNotFindTempPath Field

public String CanNotFindTempPath

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CannotLoadChartFromURL

Steema.TeeChart.Texts.CannotLoadChartFromURL Field

public String CannotLoadChartFromURL

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CannotLoadSeriesDataFromURL

Steema.TeeChart.Texts.CannotLoadSeriesDataFromURL Field

public String CannotLoadSeriesDataFromURL

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CantDeleteAncestor

Steema.TeeChart.Texts.CantDeleteAncestor Field

public String CantDeleteAncestor

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CarriageReturnChar

Steema.TeeChart.Texts.CarriageReturnChar Field

public const Char CarriageReturnChar

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ChangeGroupName

Steema.TeeChart.Texts.ChangeGroupName Field

public String ChangeGroupName

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ChangeSeriesTitle

Steema.TeeChart.Texts.ChangeSeriesTitle Field

public String ChangeSeriesTitle

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CharForHeight

Steema.TeeChart.Texts.CharForHeight Field

public const String CharForHeight

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ChartImageDesc

Steema.TeeChart.Texts.ChartImageDesc Field

public const String ChartImageDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ChartImageSummary

Steema.TeeChart.Texts.ChartImageSummary Field

public String ChartImageSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ChartWizard

Steema.TeeChart.Texts.ChartWizard Field

public String ChartWizard

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CheckPointerSize

Steema.TeeChart.Texts.CheckPointerSize Field

public String CheckPointerSize

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Circle

Steema.TeeChart.Texts.Circle Field

public String Circle

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CircularSeries

Steema.TeeChart.Texts.CircularSeries Field

public String CircularSeries

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ClassicTheme

Steema.TeeChart.Texts.ClassicTheme Field

public String ClassicTheme

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Clear

Steema.TeeChart.Texts.Clear Field

public String Clear

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ClearImage

Steema.TeeChart.Texts.ClearImage Field

public String ClearImage

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ClearMessage

Steema.TeeChart.Texts.ClearMessage Field

public String ClearMessage

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ClipSeries

Steema.TeeChart.Texts.ClipSeries Field

public String ClipSeries

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ClipSeriesDesc

Steema.TeeChart.Texts.ClipSeriesDesc Field

public const String ClipSeriesDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ClipSeriesSummary

Steema.TeeChart.Texts.ClipSeriesSummary Field

public String ClipSeriesSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ColorBandDesc

Steema.TeeChart.Texts.ColorBandDesc Field

public const String ColorBandDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ColorBandSummary

Steema.TeeChart.Texts.ColorBandSummary Field

public String ColorBandSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ColorBandTool

Steema.TeeChart.Texts.ColorBandTool Field

public String ColorBandTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ColorGridSeriesRangeExceed

Steema.TeeChart.Texts.ColorGridSeriesRangeExceed Field

public String ColorGridSeriesRangeExceed

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ColorLineDesc

Steema.TeeChart.Texts.ColorLineDesc Field

public const String ColorLineDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ColorLineSummary

Steema.TeeChart.Texts.ColorLineSummary Field

public String ColorLineSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ColorLineTool

Steema.TeeChart.Texts.ColorLineTool Field

public String ColorLineTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ColorPalette

Steema.TeeChart.Texts.ColorPalette Field

public String ColorPalette

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ColorRange

Steema.TeeChart.Texts.ColorRange Field

public String ColorRange

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Colors

Steema.TeeChart.Texts.Colors Field

public String Colors

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Column

Steema.TeeChart.Texts.Column Field

public String Column

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ColumnSeparator

Steema.TeeChart.Texts.ColumnSeparator Field

public const Char ColumnSeparator

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsg3D

Steema.TeeChart.Texts.CommanMsg3D Field

public String CommanMsg3D

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgChart

Steema.TeeChart.Texts.CommanMsgChart Field

public String CommanMsgChart

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgCopy

Steema.TeeChart.Texts.CommanMsgCopy Field

public String CommanMsgCopy

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgDepth

Steema.TeeChart.Texts.CommanMsgDepth Field

public String CommanMsgDepth

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgDepthing

Steema.TeeChart.Texts.CommanMsgDepthing Field

public String CommanMsgDepthing

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgDepthLabel

Steema.TeeChart.Texts.CommanMsgDepthLabel Field

public String CommanMsgDepthLabel

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgEdit

Steema.TeeChart.Texts.CommanMsgEdit Field

public String CommanMsgEdit

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgMove

Steema.TeeChart.Texts.CommanMsgMove Field

public String CommanMsgMove

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgMoveLabel

Steema.TeeChart.Texts.CommanMsgMoveLabel Field

public String CommanMsgMoveLabel

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgMoving

Steema.TeeChart.Texts.CommanMsgMoving Field

public String CommanMsgMoving

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgNormal

Steema.TeeChart.Texts.CommanMsgNormal Field

public String CommanMsgNormal

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgNormalLabel

Steema.TeeChart.Texts.CommanMsgNormalLabel Field

public String CommanMsgNormalLabel

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgNormalPieLabel

Steema.TeeChart.Texts.CommanMsgNormalPieLabel Field

public String CommanMsgNormalPieLabel

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgPanel

Steema.TeeChart.Texts.CommanMsgPanel Field

public String CommanMsgPanel

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgPieExploding

Steema.TeeChart.Texts.CommanMsgPieExploding Field

public String CommanMsgPieExploding

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgPrint

Steema.TeeChart.Texts.CommanMsgPrint Field

public String CommanMsgPrint

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgRotate

Steema.TeeChart.Texts.CommanMsgRotate Field

public String CommanMsgRotate

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgRotateLabel

Steema.TeeChart.Texts.CommanMsgRotateLabel Field

public String CommanMsgRotateLabel

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgRotating

Steema.TeeChart.Texts.CommanMsgRotating Field

public String CommanMsgRotating

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgSave

Steema.TeeChart.Texts.CommanMsgSave Field

public String CommanMsgSave

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgZoom

Steema.TeeChart.Texts.CommanMsgZoom Field

public String CommanMsgZoom

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgZooming

Steema.TeeChart.Texts.CommanMsgZooming Field

public String CommanMsgZooming

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CommanMsgZoomLabel

Steema.TeeChart.Texts.CommanMsgZoomLabel Field

public String CommanMsgZoomLabel

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Cone

Steema.TeeChart.Texts.Cone Field

public String Cone

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Confirm

Steema.TeeChart.Texts.Confirm Field

public String Confirm

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Copyright

Steema.TeeChart.Texts.Copyright Field

public const String Copyright

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Cover

Steema.TeeChart.Texts.Cover Field

public String Cover

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Cross

Steema.TeeChart.Texts.Cross Field

public String Cross

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Cube

Steema.TeeChart.Texts.Cube Field

public String Cube

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Current

Steema.TeeChart.Texts.Current Field

public String Current

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CursorTool

Steema.TeeChart.Texts.CursorTool Field

public String CursorTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CursorToolDesc

Steema.TeeChart.Texts.CursorToolDesc Field

public const String CursorToolDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CursorToolSummary

Steema.TeeChart.Texts.CursorToolSummary Field

public String CursorToolSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CustomAxes

Steema.TeeChart.Texts.CustomAxes Field

public String CustomAxes

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CustomAxesEditor

Steema.TeeChart.Texts.CustomAxesEditor Field

public String CustomAxesEditor

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CustomHotspotDesc

Steema.TeeChart.Texts.CustomHotspotDesc Field

public const String CustomHotspotDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CustomHotspotSummary

Steema.TeeChart.Texts.CustomHotspotSummary Field

public String CustomHotspotSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


CustomHotspotTool

Steema.TeeChart.Texts.CustomHotspotTool Field

public String CustomHotspotTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DarkPen

Steema.TeeChart.Texts.DarkPen Field

public String DarkPen

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DataSet

Steema.TeeChart.Texts.DataSet Field

public String DataSet

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DataSource

Steema.TeeChart.Texts.DataSource Field

public String DataSource

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DataTableTool

Steema.TeeChart.Texts.DataTableTool Field

public String DataTableTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DataTableToolDesc

Steema.TeeChart.Texts.DataTableToolDesc Field

public const String DataTableToolDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DataTableToolSummary

Steema.TeeChart.Texts.DataTableToolSummary Field

public String DataTableToolSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DateTime

Steema.TeeChart.Texts.DateTime Field

public String DateTime

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DateTimeFormat

Steema.TeeChart.Texts.DateTimeFormat Field

public String DateTimeFormat

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Default

Steema.TeeChart.Texts.Default Field

public String Default

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DefaultDemoTee

Steema.TeeChart.Texts.DefaultDemoTee Field

public String DefaultDemoTee

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DefaultEditorHeight

Steema.TeeChart.Texts.DefaultEditorHeight Field

public String DefaultEditorHeight

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DefaultEditorSize

Steema.TeeChart.Texts.DefaultEditorSize Field

public String DefaultEditorSize

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DefaultFontName

Steema.TeeChart.Texts.DefaultFontName Field

public String DefaultFontName

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DefaultFontSize

Steema.TeeChart.Texts.DefaultFontSize Field

public String DefaultFontSize

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DefaultPercentOf

Steema.TeeChart.Texts.DefaultPercentOf Field

public String DefaultPercentOf

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DefaultPercentOf2

Steema.TeeChart.Texts.DefaultPercentOf2 Field

public String DefaultPercentOf2

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DefaultTheme

Steema.TeeChart.Texts.DefaultTheme Field

public String DefaultTheme

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DefDateTimeFormat

Steema.TeeChart.Texts.DefDateTimeFormat Field

public const String DefDateTimeFormat

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DefLogValueFormat

Steema.TeeChart.Texts.DefLogValueFormat Field

public const String DefLogValueFormat

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DefPercentFormat

Steema.TeeChart.Texts.DefPercentFormat Field

public const String DefPercentFormat

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DefValueFormat

Steema.TeeChart.Texts.DefValueFormat Field

public const String DefValueFormat

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Delete

Steema.TeeChart.Texts.Delete Field

public String Delete

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DeltaPointSeries

Steema.TeeChart.Texts.DeltaPointSeries Field

public String DeltaPointSeries

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DepthAxis

Steema.TeeChart.Texts.DepthAxis Field

public String DepthAxis

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DepthTopAxis

Steema.TeeChart.Texts.DepthTopAxis Field

public String DepthTopAxis

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DesignFolderNotFound

Steema.TeeChart.Texts.DesignFolderNotFound Field

public String DesignFolderNotFound

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DesiredIncrement

Steema.TeeChart.Texts.DesiredIncrement Field

public String DesiredIncrement

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DiagCross

Steema.TeeChart.Texts.DiagCross Field

public String DiagCross

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Diamond

Steema.TeeChart.Texts.Diamond Field

public String Diamond

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DotFrame

Steema.TeeChart.Texts.DotFrame Field

public String DotFrame

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Dotted

Steema.TeeChart.Texts.Dotted Field

public String Dotted

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Down

Steema.TeeChart.Texts.Down Field

public String Down

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DownTri

Steema.TeeChart.Texts.DownTri Field

public String DownTri

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DragMarksDesc

Steema.TeeChart.Texts.DragMarksDesc Field

public const String DragMarksDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DragMarksSummary

Steema.TeeChart.Texts.DragMarksSummary Field

public String DragMarksSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DragMarksTool

Steema.TeeChart.Texts.DragMarksTool Field

public String DragMarksTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DragPoint

Steema.TeeChart.Texts.DragPoint Field

public String DragPoint

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DragPointDesc

Steema.TeeChart.Texts.DragPointDesc Field

public const String DragPointDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DragPointSummary

Steema.TeeChart.Texts.DragPointSummary Field

public String DragPointSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DrawLineDesc

Steema.TeeChart.Texts.DrawLineDesc Field

public const String DrawLineDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DrawLineSummary

Steema.TeeChart.Texts.DrawLineSummary Field

public String DrawLineSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


DrawLineTool

Steema.TeeChart.Texts.DrawLineTool Field

public String DrawLineTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Edit

Steema.TeeChart.Texts.Edit Field

public String Edit

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


EditChart

Steema.TeeChart.Texts.EditChart Field

public String EditChart

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Editing

Steema.TeeChart.Texts.Editing Field

public String Editing

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Ellipse

Steema.TeeChart.Texts.Ellipse Field

public String Ellipse

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


EMFFilter

Steema.TeeChart.Texts.EMFFilter Field

public String EMFFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


EmptyTeeFile

Steema.TeeChart.Texts.EmptyTeeFile Field

public String EmptyTeeFile

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


EnterDateTime

Steema.TeeChart.Texts.EnterDateTime Field

public String EnterDateTime

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ExcelFilter

Steema.TeeChart.Texts.ExcelFilter Field

public String ExcelFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ExcelTheme

Steema.TeeChart.Texts.ExcelTheme Field

public String ExcelTheme

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Execute

Steema.TeeChart.Texts.Execute Field

public String Execute

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ExpandAnimation

Steema.TeeChart.Texts.ExpandAnimation Field

public String ExpandAnimation

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ExpandDesc

Steema.TeeChart.Texts.ExpandDesc Field

public const String ExpandDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ExpandSummary

Steema.TeeChart.Texts.ExpandSummary Field

public String ExpandSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ExpAverageWeight

Steema.TeeChart.Texts.ExpAverageWeight Field

public String ExpAverageWeight

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ExpFinish

Steema.TeeChart.Texts.ExpFinish Field

public String ExpFinish

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Exploded

Steema.TeeChart.Texts.Exploded Field

public String Exploded

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ExpNext

Steema.TeeChart.Texts.ExpNext Field

public String ExpNext

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ExportChart

Steema.TeeChart.Texts.ExportChart Field

public String ExportChart

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ExportPanelNotSet

Steema.TeeChart.Texts.ExportPanelNotSet Field

public String ExportPanelNotSet

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ExtraLegendDesc

Steema.TeeChart.Texts.ExtraLegendDesc Field

public const String ExtraLegendDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ExtraLegendSummary

Steema.TeeChart.Texts.ExtraLegendSummary Field

public String ExtraLegendSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ExtraLegendTool

Steema.TeeChart.Texts.ExtraLegendTool Field

public String ExtraLegendTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ExtrOut

Steema.TeeChart.Texts.ExtrOut Field

public String ExtrOut

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FaderTool

Steema.TeeChart.Texts.FaderTool Field

public String FaderTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FaderToolSummary

Steema.TeeChart.Texts.FaderToolSummary Field

public String FaderToolSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FibonacciTool

Steema.TeeChart.Texts.FibonacciTool Field

public String FibonacciTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FibonacciToolDesc

Steema.TeeChart.Texts.FibonacciToolDesc Field

public String FibonacciToolDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FieldNotFound

Steema.TeeChart.Texts.FieldNotFound Field

public String FieldNotFound

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FieldsSeparator

Steema.TeeChart.Texts.FieldsSeparator Field

public const Char FieldsSeparator

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FileSize

Steema.TeeChart.Texts.FileSize Field

public String FileSize

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Filled

Steema.TeeChart.Texts.Filled Field

public String Filled

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FillSample

Steema.TeeChart.Texts.FillSample Field

public String FillSample

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


First

Steema.TeeChart.Texts.First Field

public String First

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FittingError

Steema.TeeChart.Texts.FittingError Field

public String FittingError

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FlexFilter

Steema.TeeChart.Texts.FlexFilter Field

public String FlexFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Foot

Steema.TeeChart.Texts.Foot Field

public String Foot

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionAdd

Steema.TeeChart.Texts.FunctionAdd Field

public String FunctionAdd

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionADX

Steema.TeeChart.Texts.FunctionADX Field

public String FunctionADX

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionAverage

Steema.TeeChart.Texts.FunctionAverage Field

public String FunctionAverage

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionBollinger

Steema.TeeChart.Texts.FunctionBollinger Field

public String FunctionBollinger

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionCCI

Steema.TeeChart.Texts.FunctionCCI Field

public String FunctionCCI

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionCLV

Steema.TeeChart.Texts.FunctionCLV Field

public String FunctionCLV

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionCompress

Steema.TeeChart.Texts.FunctionCompress Field

public String FunctionCompress

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionCompressOHLC

Steema.TeeChart.Texts.FunctionCompressOHLC Field

public String FunctionCompressOHLC

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionCorrelation

Steema.TeeChart.Texts.FunctionCorrelation Field

public String FunctionCorrelation

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionCount

Steema.TeeChart.Texts.FunctionCount Field

public String FunctionCount

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionCross

Steema.TeeChart.Texts.FunctionCross Field

public String FunctionCross

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionCumulative

Steema.TeeChart.Texts.FunctionCumulative Field

public String FunctionCumulative

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionCurveFitting

Steema.TeeChart.Texts.FunctionCurveFitting Field

public String FunctionCurveFitting

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionCustom

Steema.TeeChart.Texts.FunctionCustom Field

public String FunctionCustom

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionDivide

Steema.TeeChart.Texts.FunctionDivide Field

public String FunctionDivide

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionDownSampling

Steema.TeeChart.Texts.FunctionDownSampling Field

public String FunctionDownSampling

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionExpAverage

Steema.TeeChart.Texts.FunctionExpAverage Field

public String FunctionExpAverage

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionExpMovAve

Steema.TeeChart.Texts.FunctionExpMovAve Field

public String FunctionExpMovAve

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionExpTrend

Steema.TeeChart.Texts.FunctionExpTrend Field

public String FunctionExpTrend

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionHigh

Steema.TeeChart.Texts.FunctionHigh Field

public String FunctionHigh

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionHistogram

Steema.TeeChart.Texts.FunctionHistogram Field

public String FunctionHistogram

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionLogTrend

Steema.TeeChart.Texts.FunctionLogTrend Field

public String FunctionLogTrend

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionLow

Steema.TeeChart.Texts.FunctionLow Field

public String FunctionLow

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionMACD

Steema.TeeChart.Texts.FunctionMACD Field

public String FunctionMACD

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionMedian

Steema.TeeChart.Texts.FunctionMedian Field

public String FunctionMedian

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionMode

Steema.TeeChart.Texts.FunctionMode Field

public String FunctionMode

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionMomentum

Steema.TeeChart.Texts.FunctionMomentum Field

public String FunctionMomentum

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionMomentumDiv

Steema.TeeChart.Texts.FunctionMomentumDiv Field

public String FunctionMomentumDiv

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionMovingAverage

Steema.TeeChart.Texts.FunctionMovingAverage Field

public String FunctionMovingAverage

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionMultiply

Steema.TeeChart.Texts.FunctionMultiply Field

public String FunctionMultiply

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionNone

Steema.TeeChart.Texts.FunctionNone Field

public String FunctionNone

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionOBV

Steema.TeeChart.Texts.FunctionOBV Field

public String FunctionOBV

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionPerf

Steema.TeeChart.Texts.FunctionPerf Field

public String FunctionPerf

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionPerimeter

Steema.TeeChart.Texts.FunctionPerimeter Field

public String FunctionPerimeter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionPeriod

Steema.TeeChart.Texts.FunctionPeriod Field

public String FunctionPeriod

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionPVO

Steema.TeeChart.Texts.FunctionPVO Field

public String FunctionPVO

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionRMS

Steema.TeeChart.Texts.FunctionRMS Field

public String FunctionRMS

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionRSI

Steema.TeeChart.Texts.FunctionRSI Field

public String FunctionRSI

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionSAR

Steema.TeeChart.Texts.FunctionSAR Field

public String FunctionSAR

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionSmooth

Steema.TeeChart.Texts.FunctionSmooth Field

public String FunctionSmooth

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionStdDeviation

Steema.TeeChart.Texts.FunctionStdDeviation Field

public String FunctionStdDeviation

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionStochastic

Steema.TeeChart.Texts.FunctionStochastic Field

public String FunctionStochastic

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionSubtract

Steema.TeeChart.Texts.FunctionSubtract Field

public String FunctionSubtract

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionTrend

Steema.TeeChart.Texts.FunctionTrend Field

public String FunctionTrend

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunctionVariance

Steema.TeeChart.Texts.FunctionVariance Field

public String FunctionVariance

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunnelBelow

Steema.TeeChart.Texts.FunnelBelow Field

public String FunnelBelow

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunnelExceed

Steema.TeeChart.Texts.FunnelExceed Field

public String FunnelExceed

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunnelPercent

Steema.TeeChart.Texts.FunnelPercent Field

public String FunnelPercent

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunnelSegment

Steema.TeeChart.Texts.FunnelSegment Field

public String FunnelSegment

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunnelSeries

Steema.TeeChart.Texts.FunnelSeries Field

public String FunnelSeries

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


FunnelWithin

Steema.TeeChart.Texts.FunnelWithin Field

public String FunnelWithin

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Gallery3D

Steema.TeeChart.Texts.Gallery3D Field

public String Gallery3D

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryArea

Steema.TeeChart.Texts.GalleryArea Field

public String GalleryArea

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryArrow

Steema.TeeChart.Texts.GalleryArrow Field

public String GalleryArrow

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryBar

Steema.TeeChart.Texts.GalleryBar Field

public String GalleryBar

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryBar3D

Steema.TeeChart.Texts.GalleryBar3D Field

public String GalleryBar3D

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryBarJoin

Steema.TeeChart.Texts.GalleryBarJoin Field

public String GalleryBarJoin

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryBezier

Steema.TeeChart.Texts.GalleryBezier Field

public String GalleryBezier

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryBigCandle

Steema.TeeChart.Texts.GalleryBigCandle Field

public String GalleryBigCandle

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryBoxPlot

Steema.TeeChart.Texts.GalleryBoxPlot Field

public String GalleryBoxPlot

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryBubble

Steema.TeeChart.Texts.GalleryBubble Field

public String GalleryBubble

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryCandle

Steema.TeeChart.Texts.GalleryCandle Field

public String GalleryCandle

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryCircled

Steema.TeeChart.Texts.GalleryCircled Field

public String GalleryCircled

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryCircularGauge

Steema.TeeChart.Texts.GalleryCircularGauge Field

public String GalleryCircularGauge

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryClock

Steema.TeeChart.Texts.GalleryClock Field

public String GalleryClock

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryColorGrid

Steema.TeeChart.Texts.GalleryColorGrid Field

public String GalleryColorGrid

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryContour

Steema.TeeChart.Texts.GalleryContour Field

public String GalleryContour

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryCursor

Steema.TeeChart.Texts.GalleryCursor Field

public String GalleryCursor

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryDarvas

Steema.TeeChart.Texts.GalleryDarvas Field

public String GalleryDarvas

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryDonut

Steema.TeeChart.Texts.GalleryDonut Field

public String GalleryDonut

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryEquiVolume

Steema.TeeChart.Texts.GalleryEquiVolume Field

public String GalleryEquiVolume

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryError

Steema.TeeChart.Texts.GalleryError Field

public String GalleryError

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryErrorBar

Steema.TeeChart.Texts.GalleryErrorBar Field

public String GalleryErrorBar

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryErrorPoint

Steema.TeeChart.Texts.GalleryErrorPoint Field

public String GalleryErrorPoint

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryErrorPoint3D

Steema.TeeChart.Texts.GalleryErrorPoint3D Field

public String GalleryErrorPoint3D

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryExtended

Steema.TeeChart.Texts.GalleryExtended Field

public String GalleryExtended

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryFastLine

Steema.TeeChart.Texts.GalleryFastLine Field

public String GalleryFastLine

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryFinancial

Steema.TeeChart.Texts.GalleryFinancial Field

public String GalleryFinancial

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryFunctions

Steema.TeeChart.Texts.GalleryFunctions Field

public String GalleryFunctions

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryGantt

Steema.TeeChart.Texts.GalleryGantt Field

public String GalleryGantt

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryGauge

Steema.TeeChart.Texts.GalleryGauge Field

public String GalleryGauge

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryGauges

Steema.TeeChart.Texts.GalleryGauges Field

public String GalleryGauges

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryHighLow

Steema.TeeChart.Texts.GalleryHighLow Field

public String GalleryHighLow

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryHistogram

Steema.TeeChart.Texts.GalleryHistogram Field

public String GalleryHistogram

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryHorizBar

Steema.TeeChart.Texts.GalleryHorizBar Field

public String GalleryHorizBar

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryHorizBoxPlot

Steema.TeeChart.Texts.GalleryHorizBoxPlot Field

public String GalleryHorizBoxPlot

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryHorizLine

Steema.TeeChart.Texts.GalleryHorizLine Field

public String GalleryHorizLine

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryIsoSurface

Steema.TeeChart.Texts.GalleryIsoSurface Field

public String GalleryIsoSurface

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryKagi

Steema.TeeChart.Texts.GalleryKagi Field

public String GalleryKagi

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryKnobGauge

Steema.TeeChart.Texts.GalleryKnobGauge Field

public String GalleryKnobGauge

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryLine

Steema.TeeChart.Texts.GalleryLine Field

public String GalleryLine

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryLinearGauge

Steema.TeeChart.Texts.GalleryLinearGauge Field

public String GalleryLinearGauge

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryLinePoint

Steema.TeeChart.Texts.GalleryLinePoint Field

public String GalleryLinePoint

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryLogoFont

Steema.TeeChart.Texts.GalleryLogoFont Field

public String GalleryLogoFont

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryMap

Steema.TeeChart.Texts.GalleryMap Field

public String GalleryMap

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryNumericGauge

Steema.TeeChart.Texts.GalleryNumericGauge Field

public String GalleryNumericGauge

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryOrgChart

Steema.TeeChart.Texts.GalleryOrgChart Field

public String GalleryOrgChart

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryPie

Steema.TeeChart.Texts.GalleryPie Field

public String GalleryPie

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryPoint

Steema.TeeChart.Texts.GalleryPoint Field

public String GalleryPoint

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryPoint3D

Steema.TeeChart.Texts.GalleryPoint3D Field

public String GalleryPoint3D

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryPointFigure

Steema.TeeChart.Texts.GalleryPointFigure Field

public String GalleryPointFigure

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryPolar

Steema.TeeChart.Texts.GalleryPolar Field

public String GalleryPolar

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryPolarBar

Steema.TeeChart.Texts.GalleryPolarBar Field

public String GalleryPolarBar

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryPyramid

Steema.TeeChart.Texts.GalleryPyramid Field

public String GalleryPyramid

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryRadar

Steema.TeeChart.Texts.GalleryRadar Field

public String GalleryRadar

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryRenko

Steema.TeeChart.Texts.GalleryRenko Field

public String GalleryRenko

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GallerySamples

Steema.TeeChart.Texts.GallerySamples Field

public String GallerySamples

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryShape

Steema.TeeChart.Texts.GalleryShape Field

public String GalleryShape

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GallerySmith

Steema.TeeChart.Texts.GallerySmith Field

public String GallerySmith

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryStandard

Steema.TeeChart.Texts.GalleryStandard Field

public String GalleryStandard

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryStats

Steema.TeeChart.Texts.GalleryStats Field

public String GalleryStats

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GallerySurface

Steema.TeeChart.Texts.GallerySurface Field

public String GallerySurface

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryTagCloud

Steema.TeeChart.Texts.GalleryTagCloud Field

public String GalleryTagCloud

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryTower

Steema.TeeChart.Texts.GalleryTower Field

public String GalleryTower

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryTreeMap

Steema.TeeChart.Texts.GalleryTreeMap Field

public String GalleryTreeMap

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryTriSurface

Steema.TeeChart.Texts.GalleryTriSurface Field

public String GalleryTriSurface

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryVector3D

Steema.TeeChart.Texts.GalleryVector3D Field

public String GalleryVector3D

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryVerticalLinearGauge

Steema.TeeChart.Texts.GalleryVerticalLinearGauge Field

public String GalleryVerticalLinearGauge

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryVolume

Steema.TeeChart.Texts.GalleryVolume Field

public String GalleryVolume

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryVolumePipe

Steema.TeeChart.Texts.GalleryVolumePipe Field

public String GalleryVolumePipe

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryWaterFall

Steema.TeeChart.Texts.GalleryWaterFall Field

public String GalleryWaterFall

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryWindRose

Steema.TeeChart.Texts.GalleryWindRose Field

public String GalleryWindRose

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryWorldMap

Steema.TeeChart.Texts.GalleryWorldMap Field

public String GalleryWorldMap

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GalleryWorldMaps

Steema.TeeChart.Texts.GalleryWorldMaps Field

public String GalleryWorldMaps

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GanttSample1

Steema.TeeChart.Texts.GanttSample1 Field

public String GanttSample1

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GanttSample10

Steema.TeeChart.Texts.GanttSample10 Field

public String GanttSample10

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GanttSample2

Steema.TeeChart.Texts.GanttSample2 Field

public String GanttSample2

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GanttSample3

Steema.TeeChart.Texts.GanttSample3 Field

public String GanttSample3

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GanttSample4

Steema.TeeChart.Texts.GanttSample4 Field

public String GanttSample4

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GanttSample5

Steema.TeeChart.Texts.GanttSample5 Field

public String GanttSample5

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GanttSample6

Steema.TeeChart.Texts.GanttSample6 Field

public String GanttSample6

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GanttSample7

Steema.TeeChart.Texts.GanttSample7 Field

public String GanttSample7

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GanttSample8

Steema.TeeChart.Texts.GanttSample8 Field

public String GanttSample8

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GanttSample9

Steema.TeeChart.Texts.GanttSample9 Field

public String GanttSample9

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GanttTool

Steema.TeeChart.Texts.GanttTool Field

public String GanttTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GanttToolDesc

Steema.TeeChart.Texts.GanttToolDesc Field

public const String GanttToolDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GanttToolSummary

Steema.TeeChart.Texts.GanttToolSummary Field

public String GanttToolSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GIFFilter

Steema.TeeChart.Texts.GIFFilter Field

public String GIFFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Gradient

Steema.TeeChart.Texts.Gradient Field

public String Gradient

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GrayscaleTheme

Steema.TeeChart.Texts.GrayscaleTheme Field

public String GrayscaleTheme

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Grid3D

Steema.TeeChart.Texts.Grid3D Field

public String Grid3D

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GridBandDesc

Steema.TeeChart.Texts.GridBandDesc Field

public const String GridBandDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GridBandSummary

Steema.TeeChart.Texts.GridBandSummary Field

public String GridBandSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GridBandTool

Steema.TeeChart.Texts.GridBandTool Field

public String GridBandTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GridTranspose

Steema.TeeChart.Texts.GridTranspose Field

public String GridTranspose

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GridTransposeDesc

Steema.TeeChart.Texts.GridTransposeDesc Field

public const String GridTransposeDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GridTransposeSummary

Steema.TeeChart.Texts.GridTransposeSummary Field

public String GridTransposeSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


GroupName

Steema.TeeChart.Texts.GroupName Field

public String GroupName

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Height

Steema.TeeChart.Texts.Height Field

public String Height

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


HelperScriptAnnotation

Steema.TeeChart.Texts.HelperScriptAnnotation Field

public String HelperScriptAnnotation

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Hollow

Steema.TeeChart.Texts.Hollow Field

public String Hollow

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


HorizAreaSeries

Steema.TeeChart.Texts.HorizAreaSeries Field

public String HorizAreaSeries

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


HorizHistogramSeries

Steema.TeeChart.Texts.HorizHistogramSeries Field

public String HorizHistogramSeries

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


HorizLine

Steema.TeeChart.Texts.HorizLine Field

public String HorizLine

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


HotspotSummary

Steema.TeeChart.Texts.HotspotSummary Field

public String HotspotSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


HotspotTool

Steema.TeeChart.Texts.HotspotTool Field

public String HotspotTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


HTMLFilter

Steema.TeeChart.Texts.HTMLFilter Field

public String HTMLFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Image

Steema.TeeChart.Texts.Image Field

public String Image

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ImageBarSeries

Steema.TeeChart.Texts.ImageBarSeries Field

public String ImageBarSeries

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ImagePointSeries

Steema.TeeChart.Texts.ImagePointSeries Field

public String ImagePointSeries

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ImageTool

Steema.TeeChart.Texts.ImageTool Field

public String ImageTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ImageToolSummary

Steema.TeeChart.Texts.ImageToolSummary Field

public String ImageToolSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ImportChart

Steema.TeeChart.Texts.ImportChart Field

public String ImportChart

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ImportTeeChart

Steema.TeeChart.Texts.ImportTeeChart Field

public String ImportTeeChart

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ImportTeeChartFile

Steema.TeeChart.Texts.ImportTeeChartFile Field

public String ImportTeeChartFile

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


IncorrectMaxMinValue

Steema.TeeChart.Texts.IncorrectMaxMinValue Field

public String IncorrectMaxMinValue

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Index

Steema.TeeChart.Texts.Index Field

public String Index

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Insert

Steema.TeeChart.Texts.Insert Field

public String Insert

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


InvalidEditorClass

Steema.TeeChart.Texts.InvalidEditorClass Field

public String InvalidEditorClass

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


InvalidTeeFile

Steema.TeeChart.Texts.InvalidTeeFile Field

public String InvalidTeeFile

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


InvPyramid

Steema.TeeChart.Texts.InvPyramid Field

public String InvPyramid

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


JPEGFilter

Steema.TeeChart.Texts.JPEGFilter Field

public String JPEGFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


JScriptFilter

Steema.TeeChart.Texts.JScriptFilter Field

public String JScriptFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


JScriptNonSupportMsg

Steema.TeeChart.Texts.JScriptNonSupportMsg Field

public String JScriptNonSupportMsg

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Labels

Steema.TeeChart.Texts.Labels Field

public String Labels

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Last

Steema.TeeChart.Texts.Last Field

public String Last

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


LEDGauge

Steema.TeeChart.Texts.LEDGauge Field

public String LEDGauge

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


LeftAxis

Steema.TeeChart.Texts.LeftAxis Field

public String LeftAxis

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Legend

Steema.TeeChart.Texts.Legend Field

public String Legend

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


LegendColorWidth

Steema.TeeChart.Texts.LegendColorWidth Field

public String LegendColorWidth

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


LegendFirstValue

Steema.TeeChart.Texts.LegendFirstValue Field

public String LegendFirstValue

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


LegendPaleteToolDesc

Steema.TeeChart.Texts.LegendPaleteToolDesc Field

public const String LegendPaleteToolDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


LegendPaletteTool

Steema.TeeChart.Texts.LegendPaletteTool Field

public String LegendPaletteTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


LegendPaletteToolSummary

Steema.TeeChart.Texts.LegendPaletteToolSummary Field

public String LegendPaletteToolSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


LegendScrollBarDesc

Steema.TeeChart.Texts.LegendScrollBarDesc Field

public const String LegendScrollBarDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


LegendScrollBarSummary

Steema.TeeChart.Texts.LegendScrollBarSummary Field

public String LegendScrollBarSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


LightTool

Steema.TeeChart.Texts.LightTool Field

public String LightTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


LightToolDesc

Steema.TeeChart.Texts.LightToolDesc Field

public const String LightToolDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


LightToolSummary

Steema.TeeChart.Texts.LightToolSummary Field

public String LightToolSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Line

Steema.TeeChart.Texts.Line Field

public String Line

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Lines

Steema.TeeChart.Texts.Lines Field

public String Lines

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


LineSeparator

Steema.TeeChart.Texts.LineSeparator Field

public const Char LineSeparator

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Load

Steema.TeeChart.Texts.Load Field

public String Load

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


LoadChart

Steema.TeeChart.Texts.LoadChart Field

public String LoadChart

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


LowBezierPoints

Steema.TeeChart.Texts.LowBezierPoints Field

public String LowBezierPoints

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Magnify

Steema.TeeChart.Texts.Magnify Field

public String Magnify

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MagnifySummary

Steema.TeeChart.Texts.MagnifySummary Field

public String MagnifySummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MappingAfrica

Steema.TeeChart.Texts.MappingAfrica Field

public String MappingAfrica

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MappingAsia

Steema.TeeChart.Texts.MappingAsia Field

public String MappingAsia

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MappingAustralia

Steema.TeeChart.Texts.MappingAustralia Field

public String MappingAustralia

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MappingCentralAmerica

Steema.TeeChart.Texts.MappingCentralAmerica Field

public String MappingCentralAmerica

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MappingEurope

Steema.TeeChart.Texts.MappingEurope Field

public String MappingEurope

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MappingEurope15

Steema.TeeChart.Texts.MappingEurope15 Field

public String MappingEurope15

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MappingEurope27

Steema.TeeChart.Texts.MappingEurope27 Field

public String MappingEurope27

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MappingMiddleEast

Steema.TeeChart.Texts.MappingMiddleEast Field

public String MappingMiddleEast

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MappingNorthAmerica

Steema.TeeChart.Texts.MappingNorthAmerica Field

public String MappingNorthAmerica

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MappingSouthAmerica

Steema.TeeChart.Texts.MappingSouthAmerica Field

public String MappingSouthAmerica

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MappingSpain

Steema.TeeChart.Texts.MappingSpain Field

public String MappingSpain

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MappingUSA

Steema.TeeChart.Texts.MappingUSA Field

public String MappingUSA

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MappingUSAHawaiiAlaska

Steema.TeeChart.Texts.MappingUSAHawaiiAlaska Field

public String MappingUSAHawaiiAlaska

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MappingWorld

Steema.TeeChart.Texts.MappingWorld Field

public String MappingWorld

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MapSeries

Steema.TeeChart.Texts.MapSeries Field

public String MapSeries

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MarkerTool

Steema.TeeChart.Texts.MarkerTool Field

public String MarkerTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Marks

Steema.TeeChart.Texts.Marks Field

public String Marks

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MarksTipDesc

Steema.TeeChart.Texts.MarksTipDesc Field

public const String MarksTipDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MarksTipSummary

Steema.TeeChart.Texts.MarksTipSummary Field

public String MarksTipSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MarksTipTool

Steema.TeeChart.Texts.MarksTipTool Field

public String MarksTipTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Maximum

Steema.TeeChart.Texts.Maximum Field

public String Maximum

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MaxPointsPerPage

Steema.TeeChart.Texts.MaxPointsPerPage Field

public String MaxPointsPerPage

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MenuDelete

Steema.TeeChart.Texts.MenuDelete Field

public String MenuDelete

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MenuEdit

Steema.TeeChart.Texts.MenuEdit Field

public String MenuEdit

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MenuNew

Steema.TeeChart.Texts.MenuNew Field

public String MenuNew

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MenuRename

Steema.TeeChart.Texts.MenuRename Field

public String MenuRename

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MenuViewToolbar

Steema.TeeChart.Texts.MenuViewToolbar Field

public String MenuViewToolbar

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MildOut

Steema.TeeChart.Texts.MildOut Field

public String MildOut

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Minimum

Steema.TeeChart.Texts.Minimum Field

public String Minimum

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


MissingEditorClass

Steema.TeeChart.Texts.MissingEditorClass Field

public String MissingEditorClass

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


NativePen

Steema.TeeChart.Texts.NativePen Field

public String NativePen

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


NearestPointDesc

Steema.TeeChart.Texts.NearestPointDesc Field

public const String NearestPointDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


NearestPointSummary

Steema.TeeChart.Texts.NearestPointSummary Field

public String NearestPointSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


NearestTool

Steema.TeeChart.Texts.NearestTool Field

public String NearestTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


NewName

Steema.TeeChart.Texts.NewName Field

public String NewName

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


NewSeriesTitle

Steema.TeeChart.Texts.NewSeriesTitle Field

public String NewSeriesTitle

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Next

Steema.TeeChart.Texts.Next Field

public String Next

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


No

Steema.TeeChart.Texts.No Field

public String No

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


NoBorder

Steema.TeeChart.Texts.NoBorder Field

public String NoBorder

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


NoCircle

Steema.TeeChart.Texts.NoCircle Field

public String NoCircle

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


NoGrid

Steema.TeeChart.Texts.NoGrid Field

public String NoGrid

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


NoHigh

Steema.TeeChart.Texts.NoHigh Field

public String NoHigh

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


NoLine

Steema.TeeChart.Texts.NoLine Field

public String NoLine

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


NoLines

Steema.TeeChart.Texts.NoLines Field

public String NoLines

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


NoLow

Steema.TeeChart.Texts.NoLow Field

public String NoLow

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


None

Steema.TeeChart.Texts.None Field

public String None

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


NoPoint

Steema.TeeChart.Texts.NoPoint Field

public String NoPoint

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


NoPrinterError

Steema.TeeChart.Texts.NoPrinterError Field

public String NoPrinterError

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Normal

Steema.TeeChart.Texts.Normal Field

public String Normal

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


NoSeriesSelected

Steema.TeeChart.Texts.NoSeriesSelected Field

public String NoSeriesSelected

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


OnlineSupport

Steema.TeeChart.Texts.OnlineSupport Field

public String OnlineSupport

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


OpenDocumentFilter

Steema.TeeChart.Texts.OpenDocumentFilter Field

public String OpenDocumentFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


OpenTeeChartFile

Steema.TeeChart.Texts.OpenTeeChartFile Field

public String OpenTeeChartFile

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


OpenTextFile

Steema.TeeChart.Texts.OpenTextFile Field

public String OpenTextFile

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


OpenXmlThemeFile

Steema.TeeChart.Texts.OpenXmlThemeFile Field

public String OpenXmlThemeFile

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


OperaTheme

Steema.TeeChart.Texts.OperaTheme Field

public String OperaTheme

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


OpportunityValues

Steema.TeeChart.Texts.OpportunityValues Field

public String OpportunityValues

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Options

Steema.TeeChart.Texts.Options Field

public String Options

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Origin

Steema.TeeChart.Texts.Origin Field

public String Origin

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PageNumber

Steema.TeeChart.Texts.PageNumber Field

public String PageNumber

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PageOfPages

Steema.TeeChart.Texts.PageOfPages Field

public String PageOfPages

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Patterns

Steema.TeeChart.Texts.Patterns Field

public String Patterns

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PCXFilter

Steema.TeeChart.Texts.PCXFilter Field

public String PCXFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PDFFilter

Steema.TeeChart.Texts.PDFFilter Field

public String PDFFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Percent3D

Steema.TeeChart.Texts.Percent3D Field

public String Percent3D

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Period

Steema.TeeChart.Texts.Period Field

public String Period

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PeriodRange

Steema.TeeChart.Texts.PeriodRange Field

public String PeriodRange

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PieOther

Steema.TeeChart.Texts.PieOther Field

public String PieOther

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PieSample1

Steema.TeeChart.Texts.PieSample1 Field

public String PieSample1

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PieSample2

Steema.TeeChart.Texts.PieSample2 Field

public String PieSample2

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PieSample3

Steema.TeeChart.Texts.PieSample3 Field

public String PieSample3

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PieSample4

Steema.TeeChart.Texts.PieSample4 Field

public String PieSample4

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PieSample5

Steema.TeeChart.Texts.PieSample5 Field

public String PieSample5

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PieSample6

Steema.TeeChart.Texts.PieSample6 Field

public String PieSample6

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PieSample7

Steema.TeeChart.Texts.PieSample7 Field

public String PieSample7

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PieSample8

Steema.TeeChart.Texts.PieSample8 Field

public String PieSample8

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PieTool

Steema.TeeChart.Texts.PieTool Field

public String PieTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PieToolDesc

Steema.TeeChart.Texts.PieToolDesc Field

public const String PieToolDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PieToolSummary

Steema.TeeChart.Texts.PieToolSummary Field

public String PieToolSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Play

Steema.TeeChart.Texts.Play Field

public String Play

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PNGFilter

Steema.TeeChart.Texts.PNGFilter Field

public String PNGFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Point2D

Steema.TeeChart.Texts.Point2D Field

public String Point2D

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Points

Steema.TeeChart.Texts.Points Field

public String Points

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PolarDegreeSymbol

Steema.TeeChart.Texts.PolarDegreeSymbol Field

public const String PolarDegreeSymbol

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PolarGridSeries

Steema.TeeChart.Texts.PolarGridSeries Field

public String PolarGridSeries

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PolyDegreeRange

Steema.TeeChart.Texts.PolyDegreeRange Field

public String PolyDegreeRange

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Positions

Steema.TeeChart.Texts.Positions Field

public String Positions

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Post

Steema.TeeChart.Texts.Post Field

public String Post

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Preview

Steema.TeeChart.Texts.Preview Field

public String Preview

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PrintPreview

Steema.TeeChart.Texts.PrintPreview Field

public String PrintPreview

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Prior

Steema.TeeChart.Texts.Prior Field

public String Prior

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Property

Steema.TeeChart.Texts.Property Field

public String Property

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


PSFilter

Steema.TeeChart.Texts.PSFilter Field

public String PSFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Pyramid

Steema.TeeChart.Texts.Pyramid Field

public String Pyramid

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


QuoteValues

Steema.TeeChart.Texts.QuoteValues Field

public String QuoteValues

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


RandomTheme

Steema.TeeChart.Texts.RandomTheme Field

public String RandomTheme

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


RecordVideo

Steema.TeeChart.Texts.RecordVideo Field

public String RecordVideo

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Rectangle

Steema.TeeChart.Texts.Rectangle Field

public String Rectangle

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


RectangleTool

Steema.TeeChart.Texts.RectangleTool Field

public String RectangleTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


RectangleToolDesc

Steema.TeeChart.Texts.RectangleToolDesc Field

public const String RectangleToolDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


RefreshData

Steema.TeeChart.Texts.RefreshData Field

public String RefreshData

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


RefreshInterval

Steema.TeeChart.Texts.RefreshInterval Field

public String RefreshInterval

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


RenamePage

Steema.TeeChart.Texts.RenamePage Field

public String RenamePage

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


RightAxis

Steema.TeeChart.Texts.RightAxis Field

public String RightAxis

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


RotateDesc

Steema.TeeChart.Texts.RotateDesc Field

public const String RotateDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


RotateSummary

Steema.TeeChart.Texts.RotateSummary Field

public String RotateSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


RotateTool

Steema.TeeChart.Texts.RotateTool Field

public String RotateTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SaveChart

Steema.TeeChart.Texts.SaveChart Field

public String SaveChart

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SaveChartToFile

Steema.TeeChart.Texts.SaveChartToFile Field

public String SaveChartToFile

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Scale

Steema.TeeChart.Texts.Scale Field

public String Scale

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ScrollBarTool

Steema.TeeChart.Texts.ScrollBarTool Field

public String ScrollBarTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ScrollPagerSummary

Steema.TeeChart.Texts.ScrollPagerSummary Field

public String ScrollPagerSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ScrollPagerTool

Steema.TeeChart.Texts.ScrollPagerTool Field

public String ScrollPagerTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ScrollTool

Steema.TeeChart.Texts.ScrollTool Field

public String ScrollTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ScrollToolDesc

Steema.TeeChart.Texts.ScrollToolDesc Field

public const String ScrollToolDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ScrollToolSummary

Steema.TeeChart.Texts.ScrollToolSummary Field

public String ScrollToolSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SelectAVIFile

Steema.TeeChart.Texts.SelectAVIFile Field

public String SelectAVIFile

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SelectedSeries

Steema.TeeChart.Texts.SelectedSeries Field

public String SelectedSeries

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SelectFolder

Steema.TeeChart.Texts.SelectFolder Field

public String SelectFolder

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SelectorTool

Steema.TeeChart.Texts.SelectorTool Field

public String SelectorTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SelectorToolDesc

Steema.TeeChart.Texts.SelectorToolDesc Field

public const String SelectorToolDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SelectorToolSummary

Steema.TeeChart.Texts.SelectorToolSummary Field

public String SelectorToolSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SelectPictureFile

Steema.TeeChart.Texts.SelectPictureFile Field

public String SelectPictureFile

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SelfStack

Steema.TeeChart.Texts.SelfStack Field

public String SelfStack

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SemiPie

Steema.TeeChart.Texts.SemiPie Field

public String SemiPie

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Separator

Steema.TeeChart.Texts.Separator Field

public String Separator

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Series

Steema.TeeChart.Texts.Series Field

public String Series

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SeriesAnimationDesc

Steema.TeeChart.Texts.SeriesAnimationDesc Field

public const String SeriesAnimationDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SeriesAnimationSummary

Steema.TeeChart.Texts.SeriesAnimationSummary Field

public String SeriesAnimationSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SeriesAnimTool

Steema.TeeChart.Texts.SeriesAnimTool Field

public String SeriesAnimTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SeriesBandTool

Steema.TeeChart.Texts.SeriesBandTool Field

public String SeriesBandTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SeriesBandToolDesc

Steema.TeeChart.Texts.SeriesBandToolDesc Field

public const String SeriesBandToolDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SeriesBandToolSummary

Steema.TeeChart.Texts.SeriesBandToolSummary Field

public String SeriesBandToolSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SeriesDelete

Steema.TeeChart.Texts.SeriesDelete Field

public String SeriesDelete

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SeriesHotspotDesc

Steema.TeeChart.Texts.SeriesHotspotDesc Field

public const String SeriesHotspotDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SeriesInvDataSource

Steema.TeeChart.Texts.SeriesInvDataSource Field

public String SeriesInvDataSource

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SeriesList

Steema.TeeChart.Texts.SeriesList Field

public String SeriesList

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SeriesParentNoSelf

Steema.TeeChart.Texts.SeriesParentNoSelf Field

public String SeriesParentNoSelf

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SeriesRegionTool

Steema.TeeChart.Texts.SeriesRegionTool Field

public String SeriesRegionTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SeriesRegionToolSummary

Steema.TeeChart.Texts.SeriesRegionToolSummary Field

public String SeriesRegionToolSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SeriesSetDataSource

Steema.TeeChart.Texts.SeriesSetDataSource Field

public String SeriesSetDataSource

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SeriesStatsTool

Steema.TeeChart.Texts.SeriesStatsTool Field

public String SeriesStatsTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SeriesStatsToolDesc

Steema.TeeChart.Texts.SeriesStatsToolDesc Field

public const String SeriesStatsToolDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SeriesStatsToolSummary

Steema.TeeChart.Texts.SeriesStatsToolSummary Field

public String SeriesStatsToolSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SeriesTextFieldZero

Steema.TeeChart.Texts.SeriesTextFieldZero Field

public String SeriesTextFieldZero

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SeriesTranspose

Steema.TeeChart.Texts.SeriesTranspose Field

public String SeriesTranspose

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SeriesTransposeDesc

Steema.TeeChart.Texts.SeriesTransposeDesc Field

public const String SeriesTransposeDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SeriesTransposeSummary

Steema.TeeChart.Texts.SeriesTransposeSummary Field

public String SeriesTransposeSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Shadow

Steema.TeeChart.Texts.Shadow Field

public String Shadow

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ShapeGallery1

Steema.TeeChart.Texts.ShapeGallery1 Field

public String ShapeGallery1

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ShapeGallery2

Steema.TeeChart.Texts.ShapeGallery2 Field

public String ShapeGallery2

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SideAll

Steema.TeeChart.Texts.SideAll Field

public String SideAll

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Sides

Steema.TeeChart.Texts.Sides Field

public String Sides

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SingleColor

Steema.TeeChart.Texts.SingleColor Field

public String SingleColor

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SingleRecord

Steema.TeeChart.Texts.SingleRecord Field

public String SingleRecord

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SmallDotsPen

Steema.TeeChart.Texts.SmallDotsPen Field

public String SmallDotsPen

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SmithReactance

Steema.TeeChart.Texts.SmithReactance Field

public String SmithReactance

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SmithResistance

Steema.TeeChart.Texts.SmithResistance Field

public String SmithResistance

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Stack

Steema.TeeChart.Texts.Stack Field

public String Stack

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Stack100

Steema.TeeChart.Texts.Stack100 Field

public String Stack100

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Stairs

Steema.TeeChart.Texts.Stairs Field

public String Stairs

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Star

Steema.TeeChart.Texts.Star Field

public String Star

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Stop

Steema.TeeChart.Texts.Stop Field

public String Stop

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SubChartChartName

Steema.TeeChart.Texts.SubChartChartName Field

public String SubChartChartName

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SubChartNewChart

Steema.TeeChart.Texts.SubChartNewChart Field

public String SubChartNewChart

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SubChartNewName

Steema.TeeChart.Texts.SubChartNewName Field

public String SubChartNewName

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SubChartRenameChart

Steema.TeeChart.Texts.SubChartRenameChart Field

public String SubChartRenameChart

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SubChartTool

Steema.TeeChart.Texts.SubChartTool Field

public String SubChartTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SubChartToolSummary

Steema.TeeChart.Texts.SubChartToolSummary Field

public String SubChartToolSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Summary

Steema.TeeChart.Texts.Summary Field

public String Summary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SupportURL

Steema.TeeChart.Texts.SupportURL Field

public String SupportURL

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SureToApply

Steema.TeeChart.Texts.SureToApply Field

public String SureToApply

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SureToDelete

Steema.TeeChart.Texts.SureToDelete Field

public String SureToDelete

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SurfaceNearestTool

Steema.TeeChart.Texts.SurfaceNearestTool Field

public String SurfaceNearestTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SurfaceNearestToolDesc

Steema.TeeChart.Texts.SurfaceNearestToolDesc Field

public const String SurfaceNearestToolDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SurfaceNearestToolSummary

Steema.TeeChart.Texts.SurfaceNearestToolSummary Field

public String SurfaceNearestToolSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


SVGFilter

Steema.TeeChart.Texts.SVGFilter Field

public String SVGFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


TabDelimiter

Steema.TeeChart.Texts.TabDelimiter Field

public const String TabDelimiter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


TeeChart

Steema.TeeChart.Texts.TeeChart Field

public const String TeeChart

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


TeeChartExceptionString

Steema.TeeChart.Texts.TeeChartExceptionString Field

public String TeeChartExceptionString

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


TeeChartPocketEval

Steema.TeeChart.Texts.TeeChartPocketEval Field

public const String TeeChartPocketEval

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


TeeChartTheme

Steema.TeeChart.Texts.TeeChartTheme Field

public String TeeChartTheme

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


TeeFiles

Steema.TeeChart.Texts.TeeFiles Field

public String TeeFiles

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


TeeFilesExtension

Steema.TeeChart.Texts.TeeFilesExtension Field

public String TeeFilesExtension

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


TENFilter

Steema.TeeChart.Texts.TENFilter Field

public String TENFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


TernaryMarkRadius

Steema.TeeChart.Texts.TernaryMarkRadius Field

public String TernaryMarkRadius

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


TernaryMarkWeight

Steema.TeeChart.Texts.TernaryMarkWeight Field

public String TernaryMarkWeight

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


TernarySeries

Steema.TeeChart.Texts.TernarySeries Field

public String TernarySeries

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Test

Steema.TeeChart.Texts.Test Field

public String Test

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Text

Steema.TeeChart.Texts.Text Field

public String Text

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


TextFile

Steema.TeeChart.Texts.TextFile Field

public String TextFile

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


TextFilter

Steema.TeeChart.Texts.TextFilter Field

public String TextFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


TextSrcURL

Steema.TeeChart.Texts.TextSrcURL Field

public String TextSrcURL

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Themes

Steema.TeeChart.Texts.Themes Field

public String Themes

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ThemeSelector

Steema.TeeChart.Texts.ThemeSelector Field

public String ThemeSelector

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


TIFFFilter

Steema.TeeChart.Texts.TIFFFilter Field

public String TIFFFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Title

Steema.TeeChart.Texts.Title Field

public String Title

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


TopAxis

Steema.TeeChart.Texts.TopAxis Field

public String TopAxis

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Transparency

Steema.TeeChart.Texts.Transparency Field

public String Transparency

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Triangle

Steema.TeeChart.Texts.Triangle Field

public String Triangle

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


TriSurfaceAllColinear

Steema.TeeChart.Texts.TriSurfaceAllColinear Field

public String TriSurfaceAllColinear

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


TriSurfaceLess

Steema.TeeChart.Texts.TriSurfaceLess Field

public String TriSurfaceLess

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


TriSurfaceSimilar

Steema.TeeChart.Texts.TriSurfaceSimilar Field

public String TriSurfaceSimilar

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


TxtFilesExtension

Steema.TeeChart.Texts.TxtFilesExtension Field

public String TxtFilesExtension

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Up

Steema.TeeChart.Texts.Up Field

public String Up

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Value

Steema.TeeChart.Texts.Value Field

public String Value

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesAngle

Steema.TeeChart.Texts.ValuesAngle Field

public String ValuesAngle

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesArrowEndX

Steema.TeeChart.Texts.ValuesArrowEndX Field

public String ValuesArrowEndX

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesArrowEndY

Steema.TeeChart.Texts.ValuesArrowEndY Field

public String ValuesArrowEndY

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesBar

Steema.TeeChart.Texts.ValuesBar Field

public String ValuesBar

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesBubbleRadius

Steema.TeeChart.Texts.ValuesBubbleRadius Field

public String ValuesBubbleRadius

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesClose

Steema.TeeChart.Texts.ValuesClose Field

public String ValuesClose

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesDate

Steema.TeeChart.Texts.ValuesDate Field

public String ValuesDate

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesFormat

Steema.TeeChart.Texts.ValuesFormat Field

public String ValuesFormat

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesGanttEnd

Steema.TeeChart.Texts.ValuesGanttEnd Field

public String ValuesGanttEnd

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesGanttNextTask

Steema.TeeChart.Texts.ValuesGanttNextTask Field

public String ValuesGanttNextTask

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesGanttStart

Steema.TeeChart.Texts.ValuesGanttStart Field

public String ValuesGanttStart

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesHigh

Steema.TeeChart.Texts.ValuesHigh Field

public String ValuesHigh

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesLow

Steema.TeeChart.Texts.ValuesLow Field

public String ValuesLow

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesOffset

Steema.TeeChart.Texts.ValuesOffset Field

public String ValuesOffset

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesOpen

Steema.TeeChart.Texts.ValuesOpen Field

public String ValuesOpen

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesPie

Steema.TeeChart.Texts.ValuesPie Field

public String ValuesPie

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesStdError

Steema.TeeChart.Texts.ValuesStdError Field

public String ValuesStdError

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesVectorEndZ

Steema.TeeChart.Texts.ValuesVectorEndZ Field

public String ValuesVectorEndZ

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesVolume

Steema.TeeChart.Texts.ValuesVolume Field

public String ValuesVolume

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesWeighting

Steema.TeeChart.Texts.ValuesWeighting Field

public String ValuesWeighting

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesX

Steema.TeeChart.Texts.ValuesX Field

public const String ValuesX

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesY

Steema.TeeChart.Texts.ValuesY Field

public const String ValuesY

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ValuesZ

Steema.TeeChart.Texts.ValuesZ Field

public const String ValuesZ

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


VertLine

Steema.TeeChart.Texts.VertLine Field

public String VertLine

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


VideoPlayerTool

Steema.TeeChart.Texts.VideoPlayerTool Field

public String VideoPlayerTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


VideoPlayerToolSummary

Steema.TeeChart.Texts.VideoPlayerToolSummary Field

public String VideoPlayerToolSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


VideoTool

Steema.TeeChart.Texts.VideoTool Field

public String VideoTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


VideoToolSummary

Steema.TeeChart.Texts.VideoToolSummary Field

public String VideoToolSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


View3D

Steema.TeeChart.Texts.View3D Field

public String View3D

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


VMLFilter

Steema.TeeChart.Texts.VMLFilter Field

public String VMLFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


WarningHIColor

Steema.TeeChart.Texts.WarningHIColor Field

public String WarningHIColor

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


WEBTheme

Steema.TeeChart.Texts.WEBTheme Field

public String WEBTheme

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


WireFrame

Steema.TeeChart.Texts.WireFrame Field

public String WireFrame

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


WizardSureToClose

Steema.TeeChart.Texts.WizardSureToClose Field

public String WizardSureToClose

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


WizardTab

Steema.TeeChart.Texts.WizardTab Field

public String WizardTab

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


WMFFilter

Steema.TeeChart.Texts.WMFFilter Field

public String WMFFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


WrongTeeFileFormat

Steema.TeeChart.Texts.WrongTeeFileFormat Field

public String WrongTeeFileFormat

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


XAMLFilter

Steema.TeeChart.Texts.XAMLFilter Field

public String XAMLFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


XMLFile

Steema.TeeChart.Texts.XMLFile Field

public String XMLFile

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


XMLFilter

Steema.TeeChart.Texts.XMLFilter Field

public String XMLFilter

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


XPTheme

Steema.TeeChart.Texts.XPTheme Field

public String XPTheme

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Yes

Steema.TeeChart.Texts.Yes Field

public String Yes

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ZoomTool

Steema.TeeChart.Texts.ZoomTool Field

public String ZoomTool

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ZoomToolDesc

Steema.TeeChart.Texts.ZoomToolDesc Field

public const String ZoomToolDesc

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


ZoomToolSummary

Steema.TeeChart.Texts.ZoomToolSummary Field

public String ZoomToolSummary

See Also

Texts Class | Texts Members | Steema.TeeChart Namespace


Steema.TeeChart.Title

Steema.TeeChart.Title Class

Underlying Title characteristics

For a list of all members of this type, see Title Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
Steema.TeeChart.Drawing.TextShapePosition
public class Title : TextShapePosition , ICloneable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Title members | Steema.TeeChart Namespace


Steema.TeeChart.TitleMembers

Steema.TeeChart.Title all Members

Title overview

Constructors

Constructor Overloaded

Public Fields

Size (inherited from TextShape)

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clicked | Returns if mouse cursor is inside TChartTitle bound rectangle.
Clone (inherited from Shape) |
DoDraw |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.

Public Properties

AdjustFrame | Resizes Header and Footer frames to full Chart dimensions when True.
Alignment | Sets how TChart Header and Footer text will be aligned within Chart rectangle.
AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
CustomPosition (inherited from TextShapePosition) | Set to true to permit custom positioning of TextShape.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left | Gets/Sets Left position of Header or Footer Text.
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top | Gets/Sets Top position of Header or Footer Text.
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

Title Class | Steema.TeeChart Namespace


Steema.TeeChart.Title Constructor

Overload List

public Title()
public Title(Steema.TeeChart.Chart)

See Also

Title Class | Title Members | Steema.TeeChart Namespace


Steema.TeeChart.Title Constructor

public Title(Chart c)

See Also

Title Constructor Overload List | Title Class | Title Members | Steema.TeeChart Namespace


Steema.TeeChart.Title Constructor

public Title()

See Also

Title Constructor Overload List | Title Class | Title Members | Steema.TeeChart Namespace


Steema.TeeChart.TitleFields

Steema.TeeChart.Title Fields

Public Fields

Size (inherited from TextShape)

See Also

Title Class | Steema.TeeChart Namespace


Steema.TeeChart.TitleMethods

Steema.TeeChart.Title Methods

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clicked | Returns if mouse cursor is inside TChartTitle bound rectangle.
Clone (inherited from Shape) |
DoDraw |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.

See Also

Title Class | Steema.TeeChart Namespace


Clicked

Steema.TeeChart.Title.Clicked Method

Overload List

Returns if mouse cursor is inside TChartTitle bound rectangle.

public abstract Boolean Clicked(System.Drawing.Point)

Returns if mouse cursor is inside TChartTitle bound rectangle.

public abstract Boolean Clicked(System.Int32, System.Int32)

See Also

Title Class | Title Members | Steema.TeeChart Namespace


Clicked

Steema.TeeChart.Title.Clicked Method

Returns if mouse cursor is inside TChartTitle bound rectangle.
public abstract Boolean Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | Title Class | Title Members | Steema.TeeChart Namespace


Clicked

Steema.TeeChart.Title.Clicked Method

Returns if mouse cursor is inside TChartTitle bound rectangle.
public abstract Boolean Clicked(Point p)

See Also

Clicked Overload List | Title Class | Title Members | Steema.TeeChart Namespace


DoDraw

Steema.TeeChart.Title.DoDraw Method

Overload List

public Void DoDraw(Steema.TeeChart.Drawing.Graphics3D, System.Drawing.Rectangle&, System.Boolean, System.String)
public Void DoDraw(Steema.TeeChart.Drawing.Graphics3D, System.Drawing.Rectangle&, System.Boolean, System.Boolean, System.String)

See Also

Title Class | Title Members | Steema.TeeChart Namespace


DoDraw

Steema.TeeChart.Title.DoDraw Method

public Void DoDraw(Graphics3D g,
     Rectangle& rect,
     Boolean CustomOnly,
     Boolean OnlyShadow,
     String Entity)

See Also

DoDraw Overload List | Title Class | Title Members | Steema.TeeChart Namespace


DoDraw

Steema.TeeChart.Title.DoDraw Method

public Void DoDraw(Graphics3D g,
     Rectangle& rect,
     Boolean CustomOnly,
     String Entity)

See Also

DoDraw Overload List | Title Class | Title Members | Steema.TeeChart Namespace


Steema.TeeChart.TitleProperties

Steema.TeeChart.Title Properties

Public Properties

AdjustFrame | Resizes Header and Footer frames to full Chart dimensions when True.
Alignment | Sets how TChart Header and Footer text will be aligned within Chart rectangle.
AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
CustomPosition (inherited from TextShapePosition) | Set to true to permit custom positioning of TextShape.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left | Gets/Sets Left position of Header or Footer Text.
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top | Gets/Sets Top position of Header or Footer Text.
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

Title Class | Steema.TeeChart Namespace


AdjustFrame

Steema.TeeChart.Title.AdjustFrame Property

Resizes Header and Footer frames to full Chart dimensions when True.
public Boolean AdjustFrame {get; set;}

See Also

Title Class | Title Members | Steema.TeeChart Namespace


Alignment

Steema.TeeChart.Title.Alignment Property

Sets how TChart Header and Footer text will be aligned within Chart rectangle.
public Align Alignment {get; set;}

See Also

Title Class | Title Members | Steema.TeeChart Namespace


Left

Steema.TeeChart.Title.Left Property

Gets/Sets Left position of Header or Footer Text.
public Int32 Left {get; set;}

See Also

Title Class | Title Members | Steema.TeeChart Namespace


Top

Steema.TeeChart.Title.Top Property

Gets/Sets Top position of Header or Footer Text.
public Int32 Top {get; set;}

See Also

Title Class | Title Members | Steema.TeeChart Namespace


Steema.TeeChart.Utils

Steema.TeeChart.Utils Class

Chart utility procedures

For a list of all members of this type, see Utils Members

System.Object
public sealed abstract class Utils : Object

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Utils members | Steema.TeeChart Namespace


Steema.TeeChart.UtilsMembers

Steema.TeeChart.Utils all Members

Utils overview

Public Fields

AnimationTypesOf |
DateTimeStep | Array of double values to define DateTimeSteps.GetDateTimeStep
DefaultNodeHeight |
FunctionGalleryPage |
FunctionTypesOf |
PiStep |
RandSeed |
SeriesGalleryCount |
SeriesGalleryPage |
SeriesTypesOf |
TeeChartKeyName |
TeeChartRoot |
ToolTypesOf |

Public Methods

AnimationTypeIndex | Returns the index in AnimationTypesOf list of a given tool instance.
ArcSin |
AutoLanguage |
CalcColorBlend |
CheckBitmapFitsInMemory | Checks if Android's VM has enough memory for a Bitmap with the given specification.
CheckForOverflowException |
ColorArrayToHexArray |
ColorIsEmpty |
ColorToHex |
ContainsRect |
CopyToDoubleNullable |
Crop | Crops a rectangle from the given Bitmap.
DarkenColor |
DateTime |
DateTimeDefaultFormat |
DateTimeToStr |
DecimalNullableToDoubleNullable |
DecimalToDoubleNullable |
Deg2Rad | Returns a radian value from a degree value.
DesignTime |
DoubleToDoubleNullable |
ErrorMessage | Shows a message box dialog showing a TeeChart Exception.
FloatNullableToDoubleNullable |
FloatToDoubleNullable |
FormatFloat |
FreeMemory | Calculates the memory available in Android's VM.
FromArgb |
FromLTRB |
GalleryByType |
GalleryStyle |
GetBitmapSize | Calculates the memory bytes used by the given Bitmap.
GetDateTimeStep | Evaluates and returns a DateTimeSteps value as an Axis double scale that may be used to set the Increment.
HexArrayToColorArray |
HexToColor |
InflateRect |
Int | Int returns the integer part of X; that is, X rounded toward zero.
Int16NullableToDoubleNullable |
Int16ToDoubleNullable |
Int32NullableToDoubleNullable |
Int32ToDoubleNullable |
IntersectRect |
IntersectWithRect |
IsNullOrEmpty |
IsRectEmpty |
Language |
MulDiv |
Odd |
OffsetPoint |
OffsetRect |
PointAtDistance |
Rad2Deg | Returns a degree value from a radian value.
Random |
RationaliseValues | Converts values to their respective percentages
RectangleFtoRectF | Converts a System.Drawing.RectangleF to Android.Graphics.RectF
RectangletoRect | Converts a System.Drawing.Rectangle to Android.Graphics.Rect
RegisterFunction |
RegisterSeries |
RegisterTool |
Registry_GetValue |
Registry_SetValue |
RememberEditor |
RememberEditorSize |
Round |
SeriesNameOrIndex |
SeriesTypesIndex |
SetLength |
SetTextViewFont |
ShareFolder |
SignificantDifference |
SinCos |
SmallerThanIdentity | Checks if a Matrix is smaller than the identity Matrix.
Sort |
Sqr |
StringToDouble |
StringToInt |
SwapDouble |
SwapFloat |
SwapInteger |
TeeDistance |
ThemeFolder |
TimeToStr |
ToAndroidColor | Converts a System.Drawing.Color to Android.Graphics.Color
ToolTypeIndex | Returns the index in ToolTypesOf list of a given tool instance.
ToPoint |
ToRectangle |
TruncateDouble |
UnRegisterSeries |
UnRegisterTool |
VirtualShare |
WriteLine |
YesNo | Shows a message box dialog asking confirmation.
YesNoDelete | Shows a dialog asking confirmation with Yes and No options.

Public Properties

AnimationTypesCount |
CalcFramesPerSecond | Gets or sets whether the FramesPerSecond is calculated or not (>= .NET 2.0).
EmptyColor |
EmptyPoint |
EmptyRectangle |
FramesPerSecond | Gets the number of Frames per second drawn by the chart (>= .NET 2.0).
FunctionTypesCount |
IsMediumTrust |
NewLine |
OAMaxValue |
OAMinValue |
SeriesTypesCount |
ToolTypesCount |

See Also

Utils Class | Steema.TeeChart Namespace


Steema.TeeChart.UtilsFields

Steema.TeeChart.Utils Fields

Public Fields

AnimationTypesOf |
DateTimeStep | Array of double values to define DateTimeSteps.GetDateTimeStep
DefaultNodeHeight |
FunctionGalleryPage |
FunctionTypesOf |
PiStep |
RandSeed |
SeriesGalleryCount |
SeriesGalleryPage |
SeriesTypesOf |
TeeChartKeyName |
TeeChartRoot |
ToolTypesOf |

See Also

Utils Class | Steema.TeeChart Namespace


AnimationTypesOf

Steema.TeeChart.Utils.AnimationTypesOf Field

public List<Type> AnimationTypesOf

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


DateTimeStep

Steema.TeeChart.Utils.DateTimeStep Field

Array of double values to define DateTimeSteps.GetDateTimeStep
public Double[] DateTimeStep

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


DefaultNodeHeight

Steema.TeeChart.Utils.DefaultNodeHeight Field

public Int32 DefaultNodeHeight

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


FunctionGalleryPage

Steema.TeeChart.Utils.FunctionGalleryPage Field

public ArrayList FunctionGalleryPage

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


FunctionTypesOf

Steema.TeeChart.Utils.FunctionTypesOf Field

public ArrayList FunctionTypesOf

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


PiStep

Steema.TeeChart.Utils.PiStep Field

public Double PiStep

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


RandSeed

Steema.TeeChart.Utils.RandSeed Field

public Int32 RandSeed

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


SeriesGalleryCount

Steema.TeeChart.Utils.SeriesGalleryCount Field

public List<Int32> SeriesGalleryCount

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


SeriesGalleryPage

Steema.TeeChart.Utils.SeriesGalleryPage Field

public List<Int32> SeriesGalleryPage

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


SeriesTypesOf

Steema.TeeChart.Utils.SeriesTypesOf Field

public List<Type> SeriesTypesOf

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


TeeChartKeyName

Steema.TeeChart.Utils.TeeChartKeyName Field

public String TeeChartKeyName

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


TeeChartRoot

Steema.TeeChart.Utils.TeeChartRoot Field

public String TeeChartRoot

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


ToolTypesOf

Steema.TeeChart.Utils.ToolTypesOf Field

public List<Type> ToolTypesOf

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


Steema.TeeChart.UtilsMethods

Steema.TeeChart.Utils Methods

Public Methods

AnimationTypeIndex | Returns the index in AnimationTypesOf list of a given tool instance.
ArcSin |
AutoLanguage |
CalcColorBlend |
CheckBitmapFitsInMemory | Checks if Android's VM has enough memory for a Bitmap with the given specification.
CheckForOverflowException |
ColorArrayToHexArray |
ColorIsEmpty |
ColorToHex |
ContainsRect |
CopyToDoubleNullable |
Crop | Crops a rectangle from the given Bitmap.
DarkenColor |
DateTime |
DateTimeDefaultFormat |
DateTimeToStr |
DecimalNullableToDoubleNullable |
DecimalToDoubleNullable |
Deg2Rad | Returns a radian value from a degree value.
DesignTime |
DoubleToDoubleNullable |
ErrorMessage | Shows a message box dialog showing a TeeChart Exception.
FloatNullableToDoubleNullable |
FloatToDoubleNullable |
FormatFloat |
FreeMemory | Calculates the memory available in Android's VM.
FromArgb |
FromLTRB |
GalleryByType |
GalleryStyle |
GetBitmapSize | Calculates the memory bytes used by the given Bitmap.
GetDateTimeStep | Evaluates and returns a DateTimeSteps value as an Axis double scale that may be used to set the Increment.
HexArrayToColorArray |
HexToColor |
InflateRect |
Int | Int returns the integer part of X; that is, X rounded toward zero.
Int16NullableToDoubleNullable |
Int16ToDoubleNullable |
Int32NullableToDoubleNullable |
Int32ToDoubleNullable |
IntersectRect |
IntersectWithRect |
IsNullOrEmpty |
IsRectEmpty |
Language |
MulDiv |
Odd |
OffsetPoint |
OffsetRect |
PointAtDistance |
Rad2Deg | Returns a degree value from a radian value.
Random |
RationaliseValues | Converts values to their respective percentages
RectangleFtoRectF | Converts a System.Drawing.RectangleF to Android.Graphics.RectF
RectangletoRect | Converts a System.Drawing.Rectangle to Android.Graphics.Rect
RegisterFunction |
RegisterSeries |
RegisterTool |
Registry_GetValue |
Registry_SetValue |
RememberEditor |
RememberEditorSize |
Round |
SeriesNameOrIndex |
SeriesTypesIndex |
SetLength |
SetTextViewFont |
ShareFolder |
SignificantDifference |
SinCos |
SmallerThanIdentity | Checks if a Matrix is smaller than the identity Matrix.
Sort |
Sqr |
StringToDouble |
StringToInt |
SwapDouble |
SwapFloat |
SwapInteger |
TeeDistance |
ThemeFolder |
TimeToStr |
ToAndroidColor | Converts a System.Drawing.Color to Android.Graphics.Color
ToolTypeIndex | Returns the index in ToolTypesOf list of a given tool instance.
ToPoint |
ToRectangle |
TruncateDouble |
UnRegisterSeries |
UnRegisterTool |
VirtualShare |
WriteLine |
YesNo | Shows a message box dialog asking confirmation.
YesNoDelete | Shows a dialog asking confirmation with Yes and No options.

See Also

Utils Class | Steema.TeeChart Namespace


AnimationTypeIndex

Steema.TeeChart.Utils.AnimationTypeIndex Method

Overload List

Returns the index in AnimationTypesOf list of a given tool instance.

public static Int32 AnimationTypeIndex(Steema.TeeChart.Animations.Animation)

Returns the index in AnimationTypesOf list of a given tool instance.

public static Int32 AnimationTypeIndex(System.Type)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


AnimationTypeIndex

Steema.TeeChart.Utils.AnimationTypeIndex Method

Returns the index in AnimationTypesOf list of a given tool instance.
public static Int32 AnimationTypeIndex(Type animation)

Parameters

tool
Animation to search its type in list

See Also

AnimationTypeIndex Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


AnimationTypeIndex

Steema.TeeChart.Utils.AnimationTypeIndex Method

Returns the index in AnimationTypesOf list of a given tool instance.
public static Int32 AnimationTypeIndex(Animation animation)

Parameters

tool
Animation to search its type in list

See Also

AnimationTypeIndex Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


ArcSin

Steema.TeeChart.Utils.ArcSin Method

public static Double ArcSin(Double X)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


AutoLanguage

Steema.TeeChart.Utils.AutoLanguage Method

public static Boolean AutoLanguage()

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


CalcColorBlend

Steema.TeeChart.Utils.CalcColorBlend Method

public static Color CalcColorBlend(Color start,
     Color end,
     Int32 percentage)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


CheckBitmapFitsInMemory

Steema.TeeChart.Utils.CheckBitmapFitsInMemory Method

Checks if Android's VM has enough memory for a Bitmap with the given specification.
public static Boolean CheckBitmapFitsInMemory(Int64 bmpwidth,
     Int64 bmpheight,
     Config config)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


CheckForOverflowException

Steema.TeeChart.Utils.CheckForOverflowException Method

public static Boolean CheckForOverflowException(Int32[] Nums)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


ColorArrayToHexArray

Steema.TeeChart.Utils.ColorArrayToHexArray Method

public static String[] ColorArrayToHexArray(Color[] Colors)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


ColorIsEmpty

Steema.TeeChart.Utils.ColorIsEmpty Method

public static Boolean ColorIsEmpty(Color color)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


ColorToHex

Steema.TeeChart.Utils.ColorToHex Method

Overload List

public static String ColorToHex(System.Drawing.Color)
public static String ColorToHex(System.Drawing.Color, System.Boolean)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


ColorToHex

Steema.TeeChart.Utils.ColorToHex Method

public static String ColorToHex(Color color,
     Boolean ARGB)

See Also

ColorToHex Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


ColorToHex

Steema.TeeChart.Utils.ColorToHex Method

public static String ColorToHex(Color color)

See Also

ColorToHex Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


ContainsRect

Steema.TeeChart.Utils.ContainsRect Method

public static Boolean ContainsRect(Rectangle rect1,
     Rectangle rect2)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


CopyToDoubleNullable

Steema.TeeChart.Utils.CopyToDoubleNullable Method

public static Array CopyToDoubleNullable(Array array)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


Crop

Steema.TeeChart.Utils.Crop Method

Crops a rectangle from the given Bitmap.
public static Bitmap Crop(Bitmap image,
     Rectangle r)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


DarkenColor

Steema.TeeChart.Utils.DarkenColor Method

public static Color DarkenColor(Color AColor,
     Int32 Percentage)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


DateTime

Steema.TeeChart.Utils.DateTime Method

Overload List

public static Double DateTime(System.DateTime)
public static DateTime DateTime(System.Nullable`1[System.Double], System.Double)
public static DateTime DateTime(System.Double)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


DateTime

Steema.TeeChart.Utils.DateTime Method

public static DateTime DateTime(Double value)

See Also

DateTime Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


DateTime

Steema.TeeChart.Utils.DateTime Method

public static DateTime DateTime(Nullable<Double> value,
     Double defaultNull)

See Also

DateTime Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


DateTime

Steema.TeeChart.Utils.DateTime Method

public static Double DateTime(DateTime value)

See Also

DateTime Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


DateTimeDefaultFormat

Steema.TeeChart.Utils.DateTimeDefaultFormat Method

public static String DateTimeDefaultFormat(Double tmpValue)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


DateTimeToStr

Steema.TeeChart.Utils.DateTimeToStr Method

Overload List

public static String DateTimeToStr(System.Double)
public static String DateTimeToStr(System.DateTime)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


DateTimeToStr

Steema.TeeChart.Utils.DateTimeToStr Method

public static String DateTimeToStr(DateTime datetime)

See Also

DateTimeToStr Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


DateTimeToStr

Steema.TeeChart.Utils.DateTimeToStr Method

public static String DateTimeToStr(Double datetime)

See Also

DateTimeToStr Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


DecimalNullableToDoubleNullable

Steema.TeeChart.Utils.DecimalNullableToDoubleNullable Method

public static Nullable<Double> DecimalNullableToDoubleNullable(Nullable<Decimal> d)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


DecimalToDoubleNullable

Steema.TeeChart.Utils.DecimalToDoubleNullable Method

public static Nullable<Double> DecimalToDoubleNullable(Decimal d)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


Deg2Rad

Steema.TeeChart.Utils.Deg2Rad Method

Returns a radian value from a degree value.
public static Double Deg2Rad(Double degree)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


DesignTime

Steema.TeeChart.Utils.DesignTime Method

public static String DesignTime()

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


DoubleToDoubleNullable

Steema.TeeChart.Utils.DoubleToDoubleNullable Method

public static Nullable<Double> DoubleToDoubleNullable(Double d)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


ErrorMessage

Steema.TeeChart.Utils.ErrorMessage Method

Shows a message box dialog showing a TeeChart Exception.
public static Boolean ErrorMessage(String s)

Parameters

s
Additional custom text to display at dialog.

Return Value

True if user selects "Ok"

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


FloatNullableToDoubleNullable

Steema.TeeChart.Utils.FloatNullableToDoubleNullable Method

public static Nullable<Double> FloatNullableToDoubleNullable(Nullable<Single> d)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


FloatToDoubleNullable

Steema.TeeChart.Utils.FloatToDoubleNullable Method

public static Nullable<Double> FloatToDoubleNullable(Single d)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


FormatFloat

Steema.TeeChart.Utils.FormatFloat Method

public static String FormatFloat(String format,
     Double value)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


FreeMemory

Steema.TeeChart.Utils.FreeMemory Method

Calculates the memory available in Android's VM.
public static Int64 FreeMemory()

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


FromArgb

Steema.TeeChart.Utils.FromArgb Method

Overload List

public static Color FromArgb(System.Int32, System.Drawing.Color)
public static Color FromArgb(System.Int32, System.Int32, System.Int32)
public static Color FromArgb(System.Int32, System.Int32, System.Int32, System.Int32)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


FromArgb

Steema.TeeChart.Utils.FromArgb Method

public static Color FromArgb(Int32 a,
     Int32 r,
     Int32 g,
     Int32 b)

See Also

FromArgb Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


FromArgb

Steema.TeeChart.Utils.FromArgb Method

public static Color FromArgb(Int32 r,
     Int32 g,
     Int32 b)

See Also

FromArgb Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


FromArgb

Steema.TeeChart.Utils.FromArgb Method

public static Color FromArgb(Int32 alpha,
     Color baseColor)

See Also

FromArgb Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


FromLTRB

Steema.TeeChart.Utils.FromLTRB Method

Overload List

public static Rectangle FromLTRB(System.Int32, System.Int32, System.Int32, System.Int32)
public static Rectangle FromLTRB(System.Int32, System.Int32, System.Int32, System.Int32, System.Boolean)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


FromLTRB

Steema.TeeChart.Utils.FromLTRB Method

public static Rectangle FromLTRB(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom,
     Boolean orientate)

See Also

FromLTRB Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


FromLTRB

Steema.TeeChart.Utils.FromLTRB Method

public static Rectangle FromLTRB(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

See Also

FromLTRB Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


GalleryByType

Steema.TeeChart.Utils.GalleryByType Method

public static Boolean GalleryByType()

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


GalleryStyle

Steema.TeeChart.Utils.GalleryStyle Method

public static Int32 GalleryStyle()

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


GetBitmapSize

Steema.TeeChart.Utils.GetBitmapSize Method

Overload List

Calculates the memory bytes used by the given Bitmap.

public static Int64 GetBitmapSize(Android.Graphics.Bitmap)

Calculates the memory bytes used by a Bitmap with the given specification.

public static Int64 GetBitmapSize(System.Int64, System.Int64, Android.Graphics.Bitmap+Config)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


GetBitmapSize

Steema.TeeChart.Utils.GetBitmapSize Method

Calculates the memory bytes used by a Bitmap with the given specification.
public static Int64 GetBitmapSize(Int64 bmpwidth,
     Int64 bmpheight,
     Config config)

See Also

GetBitmapSize Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


GetBitmapSize

Steema.TeeChart.Utils.GetBitmapSize Method

Calculates the memory bytes used by the given Bitmap.
public static Int64 GetBitmapSize(Bitmap bmp)

See Also

GetBitmapSize Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


GetDateTimeStep

Steema.TeeChart.Utils.GetDateTimeStep Method

Evaluates and returns a DateTimeSteps value as an Axis double scale that may be used to set the Increment.
public static Double GetDateTimeStep(DateTimeSteps value)

Parameters

value
Steema.TeeChart.DateTimeSteps

Return Value

Axis value

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


HexArrayToColorArray

Steema.TeeChart.Utils.HexArrayToColorArray Method

public static Color[] HexArrayToColorArray(String[] Colors)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


HexToColor

Steema.TeeChart.Utils.HexToColor Method

public static Color HexToColor(String color)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


InflateRect

Steema.TeeChart.Utils.InflateRect Method

public static Void InflateRect(Rectangle& rect,
     Int32 width,
     Int32 height)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


Int

Steema.TeeChart.Utils.Int Method

Int returns the integer part of X; that is, X rounded toward zero.
public static Double Int(Double d)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


Int16NullableToDoubleNullable

Steema.TeeChart.Utils.Int16NullableToDoubleNullable Method

public static Nullable<Double> Int16NullableToDoubleNullable(Nullable<Int16> d)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


Int16ToDoubleNullable

Steema.TeeChart.Utils.Int16ToDoubleNullable Method

public static Nullable<Double> Int16ToDoubleNullable(Int16 d)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


Int32NullableToDoubleNullable

Steema.TeeChart.Utils.Int32NullableToDoubleNullable Method

public static Nullable<Double> Int32NullableToDoubleNullable(Nullable<Int32> d)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


Int32ToDoubleNullable

Steema.TeeChart.Utils.Int32ToDoubleNullable Method

public static Nullable<Double> Int32ToDoubleNullable(Int32 d)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


IntersectRect

Steema.TeeChart.Utils.IntersectRect Method

public static Rectangle IntersectRect(Rectangle rect1,
     Rectangle rect2)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


IntersectWithRect

Steema.TeeChart.Utils.IntersectWithRect Method

public static Boolean IntersectWithRect(Rectangle rect1,
     Rectangle rect2)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


IsNullOrEmpty

Steema.TeeChart.Utils.IsNullOrEmpty Method

public static Boolean IsNullOrEmpty(String s)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


IsRectEmpty

Steema.TeeChart.Utils.IsRectEmpty Method

Overload List

public static Boolean IsRectEmpty(System.Drawing.RectangleF)
public static Boolean IsRectEmpty(System.Drawing.Rectangle)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


IsRectEmpty

Steema.TeeChart.Utils.IsRectEmpty Method

public static Boolean IsRectEmpty(Rectangle rect)

See Also

IsRectEmpty Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


IsRectEmpty

Steema.TeeChart.Utils.IsRectEmpty Method

public static Boolean IsRectEmpty(RectangleF rect)

See Also

IsRectEmpty Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


Language

Steema.TeeChart.Utils.Language Method

public static Int32 Language()

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


MulDiv

Steema.TeeChart.Utils.MulDiv Method

public static Int32 MulDiv(Int32 Number,
     Int32 Numerator,
     Int32 Denominator)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


Odd

Steema.TeeChart.Utils.Odd Method

public static Boolean Odd(Int32 value)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


OffsetPoint

Steema.TeeChart.Utils.OffsetPoint Method

public static PointDouble OffsetPoint(PointDouble value,
     Double x,
     Double y)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


OffsetRect

Steema.TeeChart.Utils.OffsetRect Method

public static Void OffsetRect(Rectangle& rect,
     Int32 offsetX,
     Int32 offsetY)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


PointAtDistance

Steema.TeeChart.Utils.PointAtDistance Method

public static Point PointAtDistance(Point AFrom,
     Point ATo,
     Int32 ADist)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


Rad2Deg

Steema.TeeChart.Utils.Rad2Deg Method

Returns a degree value from a radian value.
public static Double Rad2Deg(Double radian)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


Random

Steema.TeeChart.Utils.Random Method

public static Int32 Random(Int32 ARange)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


RationaliseValues

Steema.TeeChart.Utils.RationaliseValues Method

Converts values to their respective percentages
public static Void RationaliseValues(Double& x,
     Double& y,
     Double& z)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


RectangleFtoRectF

Steema.TeeChart.Utils.RectangleFtoRectF Method

Converts a System.Drawing.RectangleF to Android.Graphics.RectF
public static RectF RectangleFtoRectF(RectangleF r)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


RectangletoRect

Steema.TeeChart.Utils.RectangletoRect Method

Converts a System.Drawing.Rectangle to Android.Graphics.Rect
public static Rect RectangletoRect(Rectangle r)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


RegisterFunction

Steema.TeeChart.Utils.RegisterFunction Method

public static Void RegisterFunction(Type functionType,
     Int32 galleryPage)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


RegisterSeries

Steema.TeeChart.Utils.RegisterSeries Method

public static Void RegisterSeries(Type seriesType,
     Type editorType,
     Int32 galleryPage,
     Int32 galleryCount)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


RegisterTool

Steema.TeeChart.Utils.RegisterTool Method

public static Void RegisterTool(Type toolType,
     Type editorType)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


Registry_GetValue

Steema.TeeChart.Utils.Registry_GetValue Method

public static Object Registry_GetValue(String keyName,
     String valueName,
     Object defaultValue)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


Registry_SetValue

Steema.TeeChart.Utils.Registry_SetValue Method

public static Void Registry_SetValue(String keyName,
     String valueName,
     Object value)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


RememberEditor

Steema.TeeChart.Utils.RememberEditor Method

public static Boolean RememberEditor()

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


RememberEditorSize

Steema.TeeChart.Utils.RememberEditorSize Method

public static Boolean RememberEditorSize()

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


Round

Steema.TeeChart.Utils.Round Method

Overload List

public static Int32 Round(System.Single)
public static Int32 Round(System.Double)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


Round

Steema.TeeChart.Utils.Round Method

public static Int32 Round(Double value)

See Also

Round Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


Round

Steema.TeeChart.Utils.Round Method

public static Int32 Round(Single value)

See Also

Round Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


SeriesNameOrIndex

Steema.TeeChart.Utils.SeriesNameOrIndex Method

public static String SeriesNameOrIndex(Series ASeries)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


SeriesTypesIndex

Steema.TeeChart.Utils.SeriesTypesIndex Method

Overload List

public static Int32 SeriesTypesIndex(Steema.TeeChart.Styles.Series)
public static Int32 SeriesTypesIndex(System.Type)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


SeriesTypesIndex

Steema.TeeChart.Utils.SeriesTypesIndex Method

public static Int32 SeriesTypesIndex(Type seriesType)

See Also

SeriesTypesIndex Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


SeriesTypesIndex

Steema.TeeChart.Utils.SeriesTypesIndex Method

public static Int32 SeriesTypesIndex(Series s)

See Also

SeriesTypesIndex Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


SetLength

Steema.TeeChart.Utils.SetLength Method

Overload List

public static Array SetLength(System.Array, System.Int32, System.Type)
public static Array SetLength(System.Array, System.Int32, System.Int32, System.Type)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


SetLength

Steema.TeeChart.Utils.SetLength Method

public static Array SetLength(Array S,
     Int32 NewLength1,
     Int32 NewLength2,
     Type ElementType)

See Also

SetLength Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


SetLength

Steema.TeeChart.Utils.SetLength Method

public static Array SetLength(Array S,
     Int32 NewLength,
     Type ElementType)

See Also

SetLength Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


SetTextViewFont

Steema.TeeChart.Utils.SetTextViewFont Method

public static Void SetTextViewFont(TextView t,
     TextPaint font)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


ShareFolder

Steema.TeeChart.Utils.ShareFolder Method

public static String ShareFolder()

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


SignificantDifference

Steema.TeeChart.Utils.SignificantDifference Method

public static Boolean SignificantDifference(Double d1,
     Double d2)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


SinCos

Steema.TeeChart.Utils.SinCos Method

public static Void SinCos(Double angle,
     Double& resultSin,
     Double& resultCos)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


SmallerThanIdentity

Steema.TeeChart.Utils.SmallerThanIdentity Method

Checks if a Matrix is smaller than the identity Matrix.
public static Boolean SmallerThanIdentity(Matrix m)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


Sort

Steema.TeeChart.Utils.Sort Method

public static Void Sort(Int32 startIndex,
     Int32 endIndex,
     CompareEventHandler compareFunction,
     SwapEventHandler swap)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


Sqr

Steema.TeeChart.Utils.Sqr Method

public static Double Sqr(Double value)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


StringToDouble

Steema.TeeChart.Utils.StringToDouble Method

public static Double StringToDouble(String text,
     Double value)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


StringToInt

Steema.TeeChart.Utils.StringToInt Method

public static Int32 StringToInt(String text,
     Int32 value)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


SwapDouble

Steema.TeeChart.Utils.SwapDouble Method

public static Void SwapDouble(Double& a,
     Double& b)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


SwapFloat

Steema.TeeChart.Utils.SwapFloat Method

public static Void SwapFloat(Single& a,
     Single& b)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


SwapInteger

Steema.TeeChart.Utils.SwapInteger Method

public static Void SwapInteger(Int32& a,
     Int32& b)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


TeeDistance

Steema.TeeChart.Utils.TeeDistance Method

public static Double TeeDistance(Double x,
     Double y)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


ThemeFolder

Steema.TeeChart.Utils.ThemeFolder Method

public static String ThemeFolder()

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


TimeToStr

Steema.TeeChart.Utils.TimeToStr Method

Overload List

public static String TimeToStr(System.Double)
public static String TimeToStr(System.DateTime)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


TimeToStr

Steema.TeeChart.Utils.TimeToStr Method

public static String TimeToStr(DateTime datetime)

See Also

TimeToStr Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


TimeToStr

Steema.TeeChart.Utils.TimeToStr Method

public static String TimeToStr(Double datetime)

See Also

TimeToStr Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


ToAndroidColor

Steema.TeeChart.Utils.ToAndroidColor Method

Converts a System.Drawing.Color to Android.Graphics.Color
public static Color ToAndroidColor(Color r)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


ToolTypeIndex

Steema.TeeChart.Utils.ToolTypeIndex Method

Overload List

Returns the index in ToolTypesOf list of a given tool instance.

public static Int32 ToolTypeIndex(Steema.TeeChart.Tools.Tool)

Returns the index in ToolTypesOf list of a given tool instance.

public static Int32 ToolTypeIndex(System.Type)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


ToolTypeIndex

Steema.TeeChart.Utils.ToolTypeIndex Method

Returns the index in ToolTypesOf list of a given tool instance.
public static Int32 ToolTypeIndex(Type tool)

Parameters

tool
Tool to search its type in list

See Also

ToolTypeIndex Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


ToolTypeIndex

Steema.TeeChart.Utils.ToolTypeIndex Method

Returns the index in ToolTypesOf list of a given tool instance.
public static Int32 ToolTypeIndex(Tool tool)

Parameters

tool
Tool to search its type in list

See Also

ToolTypeIndex Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


ToPoint

Steema.TeeChart.Utils.ToPoint Method

public static Point ToPoint(PointF point)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


ToRectangle

Steema.TeeChart.Utils.ToRectangle Method

public static Rectangle ToRectangle(RectangleF rect)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


TruncateDouble

Steema.TeeChart.Utils.TruncateDouble Method

public static Double TruncateDouble(Double d)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


UnRegisterSeries

Steema.TeeChart.Utils.UnRegisterSeries Method

public static Void UnRegisterSeries(Type seriesType)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


UnRegisterTool

Steema.TeeChart.Utils.UnRegisterTool Method

public static Void UnRegisterTool(Type toolType)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


VirtualShare

Steema.TeeChart.Utils.VirtualShare Method

public static String VirtualShare()

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


WriteLine

Steema.TeeChart.Utils.WriteLine Method

Overload List

public static String WriteLine(System.String, System.Object, System.Int32)
public static String WriteLine(System.String, System.Object)

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


WriteLine

Steema.TeeChart.Utils.WriteLine Method

public static String WriteLine(String title,
     Object value)

See Also

WriteLine Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


WriteLine

Steema.TeeChart.Utils.WriteLine Method

public static String WriteLine(String title,
     Object value,
     Int32 increaseFrameIndex)

See Also

WriteLine Overload List | Utils Class | Utils Members | Steema.TeeChart Namespace


YesNo

Steema.TeeChart.Utils.YesNo Method

Shows a message box dialog asking confirmation.
public static Boolean YesNo(String s)

Parameters

s
Additional custom text to display at dialog.

Return Value

True if user selects "Yes"

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


YesNoDelete

Steema.TeeChart.Utils.YesNoDelete Method

Shows a dialog asking confirmation with Yes and No options.
public static Boolean YesNoDelete(String s)

Parameters

s
Additional custom text to show at dialog

Return Value

Returns True if user selects "Yes".

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


Steema.TeeChart.UtilsProperties

Steema.TeeChart.Utils Properties

Public Properties

AnimationTypesCount |
CalcFramesPerSecond | Gets or sets whether the FramesPerSecond is calculated or not (>= .NET 2.0).
EmptyColor |
EmptyPoint |
EmptyRectangle |
FramesPerSecond | Gets the number of Frames per second drawn by the chart (>= .NET 2.0).
FunctionTypesCount |
IsMediumTrust |
NewLine |
OAMaxValue |
OAMinValue |
SeriesTypesCount |
ToolTypesCount |

See Also

Utils Class | Steema.TeeChart Namespace


AnimationTypesCount

Steema.TeeChart.Utils.AnimationTypesCount Property

public static Int32 AnimationTypesCount {get;}

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


CalcFramesPerSecond

Steema.TeeChart.Utils.CalcFramesPerSecond Property

Gets or sets whether the FramesPerSecond is calculated or not (>= .NET 2.0).
public static Boolean CalcFramesPerSecond {get; set;}

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


EmptyColor

Steema.TeeChart.Utils.EmptyColor Property

public static Color EmptyColor {get;}

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


EmptyPoint

Steema.TeeChart.Utils.EmptyPoint Property

public static Point EmptyPoint {get;}

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


EmptyRectangle

Steema.TeeChart.Utils.EmptyRectangle Property

public static Rectangle EmptyRectangle {get;}

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


FramesPerSecond

Steema.TeeChart.Utils.FramesPerSecond Property

Gets the number of Frames per second drawn by the chart (>= .NET 2.0).
public static Single FramesPerSecond {get;}

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


FunctionTypesCount

Steema.TeeChart.Utils.FunctionTypesCount Property

public static Int32 FunctionTypesCount {get;}

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


IsMediumTrust

Steema.TeeChart.Utils.IsMediumTrust Property

public static Boolean IsMediumTrust {get;}

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


NewLine

Steema.TeeChart.Utils.NewLine Property

public static String NewLine {get;}

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


OAMaxValue

Steema.TeeChart.Utils.OAMaxValue Property

public static Double OAMaxValue {get;}

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


OAMinValue

Steema.TeeChart.Utils.OAMinValue Property

public static Double OAMinValue {get;}

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


SeriesTypesCount

Steema.TeeChart.Utils.SeriesTypesCount Property

public static Int32 SeriesTypesCount {get;}

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


ToolTypesCount

Steema.TeeChart.Utils.ToolTypesCount Property

public static Int32 ToolTypesCount {get;}

See Also

Utils Class | Utils Members | Steema.TeeChart Namespace


Steema.TeeChart.Utils.CompareEventHandler

Steema.TeeChart.Utils.CompareEventHandler Delegate

Internal use. Sort event handler
public delegate CompareEventHandler (Int32 a,
     Int32 b)

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart Namespace


Steema.TeeChart.Utils.SwapEventHandler

Steema.TeeChart.Utils.SwapEventHandler Delegate

Internal use. Sort event handler
public delegate SwapEventHandler (Int32 a,
     Int32 b)

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart Namespace


Steema.TeeChart.Wall

Steema.TeeChart.Wall Class

Characteristics of Wall Panel that complements an Axis

For a list of all members of this type, see Wall Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
public class Wall : Shape , ICloneable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Wall members | Steema.TeeChart Namespace


Steema.TeeChart.WallMembers

Steema.TeeChart.Wall all Members

Wall overview

Constructors

Constructor

Public Methods

Assign (inherited from Shape) | Assign all properties from a shape to another.
Clone (inherited from Shape) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from Shape) |

Public Properties

ApplyDark | Applies a darker shade to 3D Chart Walls when true.
AutoHide |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Shape) | Defines the shape Color.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
Size | Sets the Chart Wall thickness.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

Wall Class | Steema.TeeChart Namespace


Steema.TeeChart.Wall Constructor

public Wall(Chart c,
     Walls w)

See Also

Wall Class | Wall Members | Steema.TeeChart Namespace


Steema.TeeChart.WallMethods

Steema.TeeChart.Wall Methods

Public Methods

Assign (inherited from Shape) | Assign all properties from a shape to another.
Clone (inherited from Shape) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from Shape) |

See Also

Wall Class | Steema.TeeChart Namespace


Steema.TeeChart.WallProperties

Steema.TeeChart.Wall Properties

Public Properties

ApplyDark | Applies a darker shade to 3D Chart Walls when true.
AutoHide |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Shape) | Defines the shape Color.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
Size | Sets the Chart Wall thickness.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

Wall Class | Steema.TeeChart Namespace


ApplyDark

Steema.TeeChart.Wall.ApplyDark Property

Applies a darker shade to 3D Chart Walls when true.
public Boolean ApplyDark {get; set;}

See Also

Wall Class | Wall Members | Steema.TeeChart Namespace


AutoHide

Steema.TeeChart.Wall.AutoHide Property

public Boolean AutoHide {get; set;}

See Also

Wall Class | Wall Members | Steema.TeeChart Namespace


Size

Steema.TeeChart.Wall.Size Property

Sets the Chart Wall thickness.
public Int32 Size {get; set;}

See Also

Wall Class | Wall Members | Steema.TeeChart Namespace


Steema.TeeChart.Walls

Steema.TeeChart.Walls Class

Access to Wall and overall Wall display characteristics

For a list of all members of this type, see Walls Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class Walls : TeeBase

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Walls members | Steema.TeeChart Namespace


Steema.TeeChart.WallsMembers

Steema.TeeChart.Walls all Members

Walls overview

Constructors

Constructor

Public Methods

CalcWallSize | Calculates the Wall thickness of the specified Axis.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint | Use this method to paint walls at rectangle r.

Public Properties

Back | Defines the pen and brush used to fill the back chart side.
Bottom | Defines the pen and brush used to fill the bottom chart side.
Chart (inherited from TeeBase) | Chart associated with this object
Left | Defines the pen and brush used to fill the left chart side.
Right | Defines the pen and brush used to fill the right chart side.
Size |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
View3D | Shows all Chart walls in 3D.
Visible | Shows / Hides all Chart walls.

See Also

Walls Class | Steema.TeeChart Namespace


Steema.TeeChart.Walls Constructor

public Walls(Chart c)

See Also

Walls Class | Walls Members | Steema.TeeChart Namespace


Steema.TeeChart.WallsMethods

Steema.TeeChart.Walls Methods

Public Methods

CalcWallSize | Calculates the Wall thickness of the specified Axis.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint | Use this method to paint walls at rectangle r.

See Also

Walls Class | Steema.TeeChart Namespace


CalcWallSize

Steema.TeeChart.Walls.CalcWallSize Method

Calculates the Wall thickness of the specified Axis.
public Int32 CalcWallSize(Axis a)

See Also

Walls Class | Walls Members | Steema.TeeChart Namespace


Paint

Steema.TeeChart.Walls.Paint Method

Use this method to paint walls at rectangle r.
public Void Paint(Graphics3D g,
     Rectangle r)

See Also

Walls Class | Walls Members | Steema.TeeChart Namespace


Steema.TeeChart.WallsProperties

Steema.TeeChart.Walls Properties

Public Properties

Back | Defines the pen and brush used to fill the back chart side.
Bottom | Defines the pen and brush used to fill the bottom chart side.
Chart (inherited from TeeBase) | Chart associated with this object
Left | Defines the pen and brush used to fill the left chart side.
Right | Defines the pen and brush used to fill the right chart side.
Size |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
View3D | Shows all Chart walls in 3D.
Visible | Shows / Hides all Chart walls.

See Also

Walls Class | Steema.TeeChart Namespace


Back

Steema.TeeChart.Walls.Back Property

Defines the pen and brush used to fill the back chart side.
public BackWall Back {get;}

See Also

Walls Class | Walls Members | Steema.TeeChart Namespace


Bottom

Steema.TeeChart.Walls.Bottom Property

Defines the pen and brush used to fill the bottom chart side.
public BottomWall Bottom {get;}

See Also

Walls Class | Walls Members | Steema.TeeChart Namespace


Left

Steema.TeeChart.Walls.Left Property

Defines the pen and brush used to fill the left chart side.
public LeftWall Left {get;}

See Also

Walls Class | Walls Members | Steema.TeeChart Namespace


Right

Steema.TeeChart.Walls.Right Property

Defines the pen and brush used to fill the right chart side.
public RightWall Right {get;}

See Also

Walls Class | Walls Members | Steema.TeeChart Namespace


Size

Steema.TeeChart.Walls.Size Property

public Int32 Size {set;}

See Also

Walls Class | Walls Members | Steema.TeeChart Namespace


View3D

Steema.TeeChart.Walls.View3D Property

Shows all Chart walls in 3D.
public Boolean View3D {get; set;}

See Also

Walls Class | Walls Members | Steema.TeeChart Namespace


Visible

Steema.TeeChart.Walls.Visible Property

Shows / Hides all Chart walls.
public Boolean Visible {get; set;}

See Also

Walls Class | Walls Members | Steema.TeeChart Namespace


Steema.TeeChart.Walls.BackWall

Steema.TeeChart.Walls.BackWall Class

Wall Panel at rear of Chart

For a list of all members of this type, see BackWall Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Wall
public class BackWall : Wall , ICloneable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

BackWall members | Steema.TeeChart Namespace


Steema.TeeChart.Walls.BackWallMembers

Steema.TeeChart.Walls.BackWall all Members

BackWall overview

Constructors

Steema.TeeChart.Walls.BackWall..ctor

Public Methods

Assign (inherited from Shape) | Assign all properties from a shape to another.
Clone (inherited from Shape) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint | Use this method to paint a back wall at rectangle r.

Public Properties

ApplyDark (inherited from Wall) | Applies a darker shade to 3D Chart Walls when true.
AutoHide (inherited from Wall) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Shape) | Defines the shape Color.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
Size (inherited from Wall) | Sets the Chart Wall thickness.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

BackWall Class | Steema.TeeChart Namespace


Steema.TeeChart.Walls+BackWall Constructor

public Walls+BackWall(Chart c,
     Walls w)

See Also

BackWall Class | BackWall Members | Steema.TeeChart Namespace


Steema.TeeChart.Walls.BackWallMethods

Steema.TeeChart.Walls.BackWall Methods

Public Methods

Assign (inherited from Shape) | Assign all properties from a shape to another.
Clone (inherited from Shape) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint | Use this method to paint a back wall at rectangle r.

See Also

BackWall Class | Steema.TeeChart Namespace


Paint

Steema.TeeChart.Walls+BackWall.Paint Method

Use this method to paint a back wall at rectangle r.
public override Void Paint(Graphics3D g,
     Rectangle rect)

See Also

BackWall Class | BackWall Members | Steema.TeeChart Namespace


Steema.TeeChart.Walls.BackWallProperties

Steema.TeeChart.Walls.BackWall Properties

Public Properties

ApplyDark (inherited from Wall) | Applies a darker shade to 3D Chart Walls when true.
AutoHide (inherited from Wall) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Shape) | Defines the shape Color.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
Size (inherited from Wall) | Sets the Chart Wall thickness.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

BackWall Class | Steema.TeeChart Namespace


Steema.TeeChart.Walls.BottomWall

Steema.TeeChart.Walls.BottomWall Class

Wall Panel at bottom of Chart

For a list of all members of this type, see BottomWall Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Wall
public class BottomWall : Wall , ICloneable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

BottomWall members | Steema.TeeChart Namespace


Steema.TeeChart.Walls.BottomWallMembers

Steema.TeeChart.Walls.BottomWall all Members

BottomWall overview

Constructors

Steema.TeeChart.Walls.BottomWall..ctor

Public Methods

Assign (inherited from Shape) | Assign all properties from a shape to another.
Clone (inherited from Shape) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint | Use this method to paint a bottom wall at rectangle r.

Public Properties

ApplyDark (inherited from Wall) | Applies a darker shade to 3D Chart Walls when true.
AutoHide (inherited from Wall) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Shape) | Defines the shape Color.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
Size (inherited from Wall) | Sets the Chart Wall thickness.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

BottomWall Class | Steema.TeeChart Namespace


Steema.TeeChart.Walls+BottomWall Constructor

public Walls+BottomWall(Chart c,
     Walls w)

See Also

BottomWall Class | BottomWall Members | Steema.TeeChart Namespace


Steema.TeeChart.Walls.BottomWallMethods

Steema.TeeChart.Walls.BottomWall Methods

Public Methods

Assign (inherited from Shape) | Assign all properties from a shape to another.
Clone (inherited from Shape) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint | Use this method to paint a bottom wall at rectangle r.

See Also

BottomWall Class | Steema.TeeChart Namespace


Paint

Steema.TeeChart.Walls+BottomWall.Paint Method

Use this method to paint a bottom wall at rectangle r.
public override Void Paint(Graphics3D g,
     Rectangle rect)

See Also

BottomWall Class | BottomWall Members | Steema.TeeChart Namespace


Steema.TeeChart.Walls.BottomWallProperties

Steema.TeeChart.Walls.BottomWall Properties

Public Properties

ApplyDark (inherited from Wall) | Applies a darker shade to 3D Chart Walls when true.
AutoHide (inherited from Wall) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Shape) | Defines the shape Color.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
Size (inherited from Wall) | Sets the Chart Wall thickness.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

BottomWall Class | Steema.TeeChart Namespace


Steema.TeeChart.Walls.LeftWall

Steema.TeeChart.Walls.LeftWall Class

Wall Panel at left of Chart

For a list of all members of this type, see LeftWall Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Wall
public class LeftWall : Wall , ICloneable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

LeftWall members | Steema.TeeChart Namespace


Steema.TeeChart.Walls.LeftWallMembers

Steema.TeeChart.Walls.LeftWall all Members

LeftWall overview

Constructors

Steema.TeeChart.Walls.LeftWall..ctor

Public Methods

Assign (inherited from Shape) | Assign all properties from a shape to another.
Clone (inherited from Shape) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint | Use this method to paint a left wall at rectangle r.

Public Properties

ApplyDark (inherited from Wall) | Applies a darker shade to 3D Chart Walls when true.
AutoHide (inherited from Wall) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
Color | Specifies the color used to fill the LeftWall background.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
Size (inherited from Wall) | Sets the Chart Wall thickness.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

LeftWall Class | Steema.TeeChart Namespace


Steema.TeeChart.Walls+LeftWall Constructor

public Walls+LeftWall(Chart c,
     Walls w)

See Also

LeftWall Class | LeftWall Members | Steema.TeeChart Namespace


Steema.TeeChart.Walls.LeftWallMethods

Steema.TeeChart.Walls.LeftWall Methods

Public Methods

Assign (inherited from Shape) | Assign all properties from a shape to another.
Clone (inherited from Shape) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint | Use this method to paint a left wall at rectangle r.

See Also

LeftWall Class | Steema.TeeChart Namespace


Paint

Steema.TeeChart.Walls+LeftWall.Paint Method

Use this method to paint a left wall at rectangle r.
public override Void Paint(Graphics3D g,
     Rectangle rect)

See Also

LeftWall Class | LeftWall Members | Steema.TeeChart Namespace


Steema.TeeChart.Walls.LeftWallProperties

Steema.TeeChart.Walls.LeftWall Properties

Public Properties

ApplyDark (inherited from Wall) | Applies a darker shade to 3D Chart Walls when true.
AutoHide (inherited from Wall) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
Color | Specifies the color used to fill the LeftWall background.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
Size (inherited from Wall) | Sets the Chart Wall thickness.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

LeftWall Class | Steema.TeeChart Namespace


Color

Steema.TeeChart.Walls+LeftWall.Color Property

Specifies the color used to fill the LeftWall background.
public Color Color {get; set;}

See Also

LeftWall Class | LeftWall Members | Steema.TeeChart Namespace


Steema.TeeChart.Walls.RightWall

Steema.TeeChart.Walls.RightWall Class

Wall Panel at right of Chart

For a list of all members of this type, see RightWall Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Wall
public class RightWall : Wall , ICloneable

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

RightWall members | Steema.TeeChart Namespace


Steema.TeeChart.Walls.RightWallMembers

Steema.TeeChart.Walls.RightWall all Members

RightWall overview

Constructors

Steema.TeeChart.Walls.RightWall..ctor

Public Methods

Assign (inherited from Shape) | Assign all properties from a shape to another.
Clone (inherited from Shape) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint | Use this method to paint a right wall at rectangle r.

Public Properties

ApplyDark (inherited from Wall) | Applies a darker shade to 3D Chart Walls when true.
AutoHide (inherited from Wall) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Shape) | Defines the shape Color.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
Size (inherited from Wall) | Sets the Chart Wall thickness.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible | Shows/Hides Right Wall.
Width (inherited from Shape) | The Width of the shape.

See Also

RightWall Class | Steema.TeeChart Namespace


Steema.TeeChart.Walls+RightWall Constructor

public Walls+RightWall(Chart c,
     Walls w)

See Also

RightWall Class | RightWall Members | Steema.TeeChart Namespace


Steema.TeeChart.Walls.RightWallMethods

Steema.TeeChart.Walls.RightWall Methods

Public Methods

Assign (inherited from Shape) | Assign all properties from a shape to another.
Clone (inherited from Shape) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint | Use this method to paint a right wall at rectangle r.

See Also

RightWall Class | Steema.TeeChart Namespace


Paint

Steema.TeeChart.Walls+RightWall.Paint Method

Use this method to paint a right wall at rectangle r.
public override Void Paint(Graphics3D g,
     Rectangle rect)

See Also

RightWall Class | RightWall Members | Steema.TeeChart Namespace


Steema.TeeChart.Walls.RightWallProperties

Steema.TeeChart.Walls.RightWall Properties

Public Properties

ApplyDark (inherited from Wall) | Applies a darker shade to 3D Chart Walls when true.
AutoHide (inherited from Wall) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Shape) | Defines the shape Color.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
Size (inherited from Wall) | Sets the Chart Wall thickness.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible | Shows/Hides Right Wall.
Width (inherited from Shape) | The Width of the shape.

See Also

RightWall Class | Steema.TeeChart Namespace


Visible

Steema.TeeChart.Walls+RightWall.Visible Property

Shows/Hides Right Wall.
public Boolean Visible {get; set;}

See Also

RightWall Class | RightWall Members | Steema.TeeChart Namespace


Steema.TeeChart.Zoom

Steema.TeeChart.Zoom Class

Used at tChart1.Zoom property, determines mouse zoom attributes.

For a list of all members of this type, see Zoom Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.ZoomScroll
public class Zoom : ZoomScroll

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

Zoom members | Steema.TeeChart Namespace


Steema.TeeChart.ZoomMembers

Steema.TeeChart.Zoom all Members

Zoom overview

Constructors

Constructor Creates a new Zoom instance.

Public Fields

AnimatedFactor | Controls the animated zoom "speed" (inertia)
x0 (inherited from ZoomScroll) |
x1 (inherited from ZoomScroll) |
y0 (inherited from ZoomScroll) |
y1 (inherited from ZoomScroll) |

Public Methods

Activate (inherited from ZoomScroll) | Internal use. Starts a Zoom or Scroll from the co-ordinates X,Y.
Check (inherited from ZoomScroll) | Swaps the X0 and X1 coordinates when X1 is lower than X0.
Draw | Displays rectangle while dragging Chart for zoom operation.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Undo | Rescales the Chart Axis to their Maximum and Minimum values.
ZoomPercent | Applies the specified PercentZoom Zoom In/Out to the current Axis scales.
ZoomRect | Zooms the Chart rectangle. Units pixels

Public Properties

Active (inherited from ZoomScroll) | Returns the active state of Chart Zoom and Scroll.
Allow | Allows runtime Zoom by dragging the mouse when True.
Animated | Animates Zoom in sequenced steps when True.
AnimatedSteps | Determines number of steps of the animated zooming sequence.
Brush | Brush used to fill mousedragged zoom area.
Chart (inherited from TeeBase) | Chart associated with this object
Direction | Sets the direction of the zoom on a selected area.
History |
HistorySteps | Collection that stores Axes zoom history to be used when Zoom History is true.
KeyShift (inherited from ZoomScroll) | Sets a keyboard button as an extra condition to initiate the zoom.
MinPixels | Sets min. number of pixels to actuate zoom action.
Pen | Pen used to draw surrounding rectangle of zoom area.
Style |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
UseNativePen | TeeChart uses Windows' native pen for speed when drawing the zoom rectangle. If you start to set Zoom Pen properties but wish to override their use and return to the native (non-coloured) Windows pen please be sure to set this property to true.
Zoomed | Determines if Chart axis scales fit all Chart points or not.

See Also

Zoom Class | Steema.TeeChart Namespace


Steema.TeeChart.Zoom Constructor

Creates a new Zoom instance.
public Zoom(Chart c)

See Also

Zoom Class | Zoom Members | Steema.TeeChart Namespace


Steema.TeeChart.ZoomFields

Steema.TeeChart.Zoom Fields

Public Fields

AnimatedFactor | Controls the animated zoom "speed" (inertia)
x0 (inherited from ZoomScroll) |
x1 (inherited from ZoomScroll) |
y0 (inherited from ZoomScroll) |
y1 (inherited from ZoomScroll) |

See Also

Zoom Class | Steema.TeeChart Namespace


AnimatedFactor

Steema.TeeChart.Zoom.AnimatedFactor Field

Controls the animated zoom "speed" (inertia)
public Double AnimatedFactor

See Also

Zoom Class | Zoom Members | Steema.TeeChart Namespace


Steema.TeeChart.ZoomMethods

Steema.TeeChart.Zoom Methods

Public Methods

Activate (inherited from ZoomScroll) | Internal use. Starts a Zoom or Scroll from the co-ordinates X,Y.
Check (inherited from ZoomScroll) | Swaps the X0 and X1 coordinates when X1 is lower than X0.
Draw | Displays rectangle while dragging Chart for zoom operation.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Undo | Rescales the Chart Axis to their Maximum and Minimum values.
ZoomPercent | Applies the specified PercentZoom Zoom In/Out to the current Axis scales.
ZoomRect | Zooms the Chart rectangle. Units pixels

See Also

Zoom Class | Steema.TeeChart Namespace


Draw

Steema.TeeChart.Zoom.Draw Method

Displays rectangle while dragging Chart for zoom operation.
public Void Draw()

See Also

Zoom Class | Zoom Members | Steema.TeeChart Namespace


Undo

Steema.TeeChart.Zoom.Undo Method

Rescales the Chart Axis to their Maximum and Minimum values.
public Void Undo()

See Also

Zoom Class | Zoom Members | Steema.TeeChart Namespace


ZoomPercent

Steema.TeeChart.Zoom.ZoomPercent Method

Applies the specified PercentZoom Zoom In/Out to the current Axis scales.
public Void ZoomPercent(Double percentZoom)

See Also

Zoom Class | Zoom Members | Steema.TeeChart Namespace


ZoomRect

Steema.TeeChart.Zoom.ZoomRect Method

Zooms the Chart rectangle. Units pixels
public Void ZoomRect(Rectangle r)

See Also

Zoom Class | Zoom Members | Steema.TeeChart Namespace


Steema.TeeChart.ZoomProperties

Steema.TeeChart.Zoom Properties

Public Properties

Active (inherited from ZoomScroll) | Returns the active state of Chart Zoom and Scroll.
Allow | Allows runtime Zoom by dragging the mouse when True.
Animated | Animates Zoom in sequenced steps when True.
AnimatedSteps | Determines number of steps of the animated zooming sequence.
Brush | Brush used to fill mousedragged zoom area.
Chart (inherited from TeeBase) | Chart associated with this object
Direction | Sets the direction of the zoom on a selected area.
History |
HistorySteps | Collection that stores Axes zoom history to be used when Zoom History is true.
KeyShift (inherited from ZoomScroll) | Sets a keyboard button as an extra condition to initiate the zoom.
MinPixels | Sets min. number of pixels to actuate zoom action.
Pen | Pen used to draw surrounding rectangle of zoom area.
Style |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
UseNativePen | TeeChart uses Windows' native pen for speed when drawing the zoom rectangle. If you start to set Zoom Pen properties but wish to override their use and return to the native (non-coloured) Windows pen please be sure to set this property to true.
Zoomed | Determines if Chart axis scales fit all Chart points or not.

See Also

Zoom Class | Steema.TeeChart Namespace


Allow

Steema.TeeChart.Zoom.Allow Property

Allows runtime Zoom by dragging the mouse when True.
public Boolean Allow {get; set;}

See Also

Zoom Class | Zoom Members | Steema.TeeChart Namespace


Animated

Steema.TeeChart.Zoom.Animated Property

Animates Zoom in sequenced steps when True.
public Boolean Animated {get; set;}

See Also

Zoom Class | Zoom Members | Steema.TeeChart Namespace


AnimatedSteps

Steema.TeeChart.Zoom.AnimatedSteps Property

Determines number of steps of the animated zooming sequence.
public Int32 AnimatedSteps {get; set;}

See Also

Zoom Class | Zoom Members | Steema.TeeChart Namespace


Brush

Steema.TeeChart.Zoom.Brush Property

Brush used to fill mousedragged zoom area.
public ChartBrush Brush {get;}

See Also

Zoom Class | Zoom Members | Steema.TeeChart Namespace


Direction

Steema.TeeChart.Zoom.Direction Property

Sets the direction of the zoom on a selected area.
public ZoomDirections Direction {get; set;}

See Also

Zoom Class | Zoom Members | Steema.TeeChart Namespace


History

Steema.TeeChart.Zoom.History Property

public Boolean History {get; set;}

See Also

Zoom Class | Zoom Members | Steema.TeeChart Namespace


HistorySteps

Steema.TeeChart.Zoom.HistorySteps Property

Collection that stores Axes zoom history to be used when Zoom History is true.
public List<ZoomSnapshot> HistorySteps {get; set;}

See Also

Zoom Class | Zoom Members | Steema.TeeChart Namespace


MinPixels

Steema.TeeChart.Zoom.MinPixels Property

Sets min. number of pixels to actuate zoom action.
public Int32 MinPixels {get; set;}

See Also

Zoom Class | Zoom Members | Steema.TeeChart Namespace


Pen

Steema.TeeChart.Zoom.Pen Property

Pen used to draw surrounding rectangle of zoom area.
public ChartPen Pen {get;}

See Also

Zoom Class | Zoom Members | Steema.TeeChart Namespace


Style

Steema.TeeChart.Zoom.Style Property

public ZoomStyles Style {get; set;}

See Also

Zoom Class | Zoom Members | Steema.TeeChart Namespace


UseNativePen

Steema.TeeChart.Zoom.UseNativePen Property

TeeChart uses Windows' native pen for speed when drawing the zoom rectangle. If you start to set Zoom Pen properties but wish to override their use and return to the native (non-coloured) Windows pen please be sure to set this property to true.
public Boolean UseNativePen {get; set;}

See Also

Zoom Class | Zoom Members | Steema.TeeChart Namespace


Zoomed

Steema.TeeChart.Zoom.Zoomed Property

Determines if Chart axis scales fit all Chart points or not.
public Boolean Zoomed {get; set;}

See Also

Zoom Class | Zoom Members | Steema.TeeChart Namespace


Steema.TeeChart.ZoomDirections

Steema.TeeChart.ZoomDirections Enum

Describes the possible values of the Direction property.
[Serializable]
public sealed enum ZoomDirections : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Horizontal | Allow only Horizontal Zooming.
Vertical | Allow only Vertical Zooming.
Both | Allow both Horizontal and Vertical Zooming.

See Also

Steema.TeeChart Namespace


Steema.TeeChart.ZoomScroll

Steema.TeeChart.ZoomScroll Class

Internal use. Zoom and scroll support

For a list of all members of this type, see ZoomScroll Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class ZoomScroll : TeeBase

Requirements

Namespace: Steema.TeeChart Namespace

Assembly: TeeChart.Android.dll

See Also

ZoomScroll members | Steema.TeeChart Namespace


Steema.TeeChart.ZoomScrollMembers

Steema.TeeChart.ZoomScroll all Members

ZoomScroll overview

Constructors

Constructor

Public Fields

x0
x1
y0
y1

Public Methods

Activate | Internal use. Starts a Zoom or Scroll from the co-ordinates X,Y.
Check | Swaps the X0 and X1 coordinates when X1 is lower than X0.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Active | Returns the active state of Chart Zoom and Scroll.
Chart (inherited from TeeBase) | Chart associated with this object
KeyShift | Sets a keyboard button as an extra condition to initiate the zoom.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

ZoomScroll Class | Steema.TeeChart Namespace


Steema.TeeChart.ZoomScroll Constructor

public ZoomScroll(Chart c)

See Also

ZoomScroll Class | ZoomScroll Members | Steema.TeeChart Namespace


Steema.TeeChart.ZoomScrollFields

Steema.TeeChart.ZoomScroll Fields

Public Fields

x0
x1
y0
y1

See Also

ZoomScroll Class | Steema.TeeChart Namespace


x0

Steema.TeeChart.ZoomScroll.x0 Field

public Int32 x0

See Also

ZoomScroll Class | ZoomScroll Members | Steema.TeeChart Namespace


x1

Steema.TeeChart.ZoomScroll.x1 Field

public Int32 x1

See Also

ZoomScroll Class | ZoomScroll Members | Steema.TeeChart Namespace


y0

Steema.TeeChart.ZoomScroll.y0 Field

public Int32 y0

See Also

ZoomScroll Class | ZoomScroll Members | Steema.TeeChart Namespace


y1

Steema.TeeChart.ZoomScroll.y1 Field

public Int32 y1

See Also

ZoomScroll Class | ZoomScroll Members | Steema.TeeChart Namespace


Steema.TeeChart.ZoomScrollMethods

Steema.TeeChart.ZoomScroll Methods

Public Methods

Activate | Internal use. Starts a Zoom or Scroll from the co-ordinates X,Y.
Check | Swaps the X0 and X1 coordinates when X1 is lower than X0.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

See Also

ZoomScroll Class | Steema.TeeChart Namespace


Activate

Steema.TeeChart.ZoomScroll.Activate Method

Internal use. Starts a Zoom or Scroll from the co-ordinates X,Y.
public Void Activate(Int32 x,
     Int32 y)

See Also

ZoomScroll Class | ZoomScroll Members | Steema.TeeChart Namespace


Check

Steema.TeeChart.ZoomScroll.Check Method

Swaps the X0 and X1 coordinates when X1 is lower than X0.
public Void Check()

See Also

ZoomScroll Class | ZoomScroll Members | Steema.TeeChart Namespace


Steema.TeeChart.ZoomScrollProperties

Steema.TeeChart.ZoomScroll Properties

Public Properties

Active | Returns the active state of Chart Zoom and Scroll.
Chart (inherited from TeeBase) | Chart associated with this object
KeyShift | Sets a keyboard button as an extra condition to initiate the zoom.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

ZoomScroll Class | Steema.TeeChart Namespace


Active

Steema.TeeChart.ZoomScroll.Active Property

Returns the active state of Chart Zoom and Scroll.
public Boolean Active {get; set;}

See Also

ZoomScroll Class | ZoomScroll Members | Steema.TeeChart Namespace


KeyShift

Steema.TeeChart.ZoomScroll.KeyShift Property

Sets a keyboard button as an extra condition to initiate the zoom.
public Keycode KeyShift {get; set;}

See Also

ZoomScroll Class | ZoomScroll Members | Steema.TeeChart Namespace


Steema.TeeChart.ZoomSnapshot

Steema.TeeChart.ZoomSnapshot ValueType

For a list of all members of this type, see ZoomSnapshot Members

System.Object
System.ValueType
public sealed struct ZoomSnapshot : ValueType

See Also

ZoomSnapshot Members | Steema.TeeChart Namespace


Steema.TeeChart.ZoomSnapshotMembers

Steema.TeeChart.ZoomSnapshot all Members

ZoomSnapshot overview

Public Fields

AxesMinMax
CustomCount
CustomMinMax

See Also

ZoomSnapshot Structure | Steema.TeeChart Namespace


Steema.TeeChart.ZoomSnapshotFields

Steema.TeeChart.ZoomSnapshot Fields

Public Fields

AxesMinMax
CustomCount
CustomMinMax

See Also

ZoomSnapshot Structure | Steema.TeeChart Namespace


AxesMinMax

Steema.TeeChart.ZoomSnapshot.AxesMinMax Field

public Double[] AxesMinMax

See Also

ZoomSnapshot Structure | ZoomSnapshot Members | Steema.TeeChart Namespace


CustomCount

Steema.TeeChart.ZoomSnapshot.CustomCount Field

public Int32 CustomCount

See Also

ZoomSnapshot Structure | ZoomSnapshot Members | Steema.TeeChart Namespace


CustomMinMax

Steema.TeeChart.ZoomSnapshot.CustomMinMax Field

public Double[][] CustomMinMax

See Also

ZoomSnapshot Structure | ZoomSnapshot Members | Steema.TeeChart Namespace


Steema.TeeChart.ZoomStyles

Steema.TeeChart.ZoomStyles Enum

Describes the possible values of the Style property.
[Serializable]
public sealed enum ZoomStyles : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
InChart | Classic TeeChart zoom reduced to axes area.
FullChart | Zooms the chart as an image.
Classic | Traditional TeeChart for desktop zooming and scrolling.
None | Doesn't perform any zoom or scrolling

See Also

Steema.TeeChart Namespace


Steema.TeeChart.Animations

Steema.TeeChart.Animations Namespace

Namespace hierarchy

Public Enumerations

AnimationTrigger

Public Classes

Animation | Base Animation class.
AnimationsCollection | Collection of Animation components.
BeforeDrawAxesEventArgs | Internal use. Animation support EventArgs
BeforeDrawSeriesEventArgs | Internal use. Animation support EventArgs
AfterDrawSeriesEventsArgs | Internal use. Animation support EventArgs
BeforeDrawEventArgs | Internal use. Animation support EventArgs
AfterDrawEventArgs | Internal use. Animation support EventArgs

Requirements

Namespace: Steema.TeeChart.Animations Namespace

Assembly: TeeChart.Android.dll


Steema.TeeChart.Animations Hierarchy

System.Object

Steema.TeeChart.Drawing.TeeBase

Steema.TeeChart.Animations.Animation

System.Collections.CollectionBase

Steema.TeeChart.Animations.AnimationsCollection

System.EventArgs

Steema.TeeChart.Animations.AfterDrawEventArgs

Steema.TeeChart.Animations.AfterDrawSeriesEventsArgs

Steema.TeeChart.Animations.BeforeDrawAxesEventArgs

Steema.TeeChart.Animations.BeforeDrawEventArgs

Steema.TeeChart.Animations.BeforeDrawSeriesEventArgs

See Also

SteemaTeeChartAnimations Namespace


Steema.TeeChart.Animations.AfterDrawEventArgs

Steema.TeeChart.Animations.AfterDrawEventArgs Class

Internal use. Animation support EventArgs

For a list of all members of this type, see AfterDrawEventArgs Members

System.Object
System.EventArgs
public class AfterDrawEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Animations Namespace

Assembly: TeeChart.Android.dll

See Also

AfterDrawEventArgs members | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.AfterDrawEventArgsMembers

Steema.TeeChart.Animations.AfterDrawEventArgs all Members

AfterDrawEventArgs overview

Constructors

Constructor

See Also

AfterDrawEventArgs Class | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.AfterDrawEventArgs Constructor

public AfterDrawEventArgs()

See Also

AfterDrawEventArgs Class | AfterDrawEventArgs Members | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.AfterDrawSeriesEventsArgs

Steema.TeeChart.Animations.AfterDrawSeriesEventsArgs Class

Internal use. Animation support EventArgs

For a list of all members of this type, see AfterDrawSeriesEventsArgs Members

System.Object
System.EventArgs
public class AfterDrawSeriesEventsArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Animations Namespace

Assembly: TeeChart.Android.dll

See Also

AfterDrawSeriesEventsArgs members | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.AfterDrawSeriesEventsArgsMembers

Steema.TeeChart.Animations.AfterDrawSeriesEventsArgs all Members

AfterDrawSeriesEventsArgs overview

Constructors

Constructor

See Also

AfterDrawSeriesEventsArgs Class | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.AfterDrawSeriesEventsArgs Constructor

public AfterDrawSeriesEventsArgs()

See Also

AfterDrawSeriesEventsArgs Class | AfterDrawSeriesEventsArgs Members | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.Animation

Steema.TeeChart.Animations.Animation Class

Base Animation class.

For a list of all members of this type, see Animation Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class Animation : TeeBase , ICloneable

Requirements

Namespace: Steema.TeeChart.Animations Namespace

Assembly: TeeChart.Android.dll

See Also

Animation members | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.AnimationMembers

Steema.TeeChart.Animations.Animation all Members

Animation overview

Public Fields

ClickTolerance
Part

Public Methods

Clone |
CreateNewAnimation | Creates a new Animation object and sets the Name and Chart properties.
GetBitmapEditor | Returns the associated bitmap icon for a given Animation class. This icon is used at Animations gallery ListBox and Animations Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
NewFromType | Creates a new animation from the System.Type of an existing animations object.
ToString |

Public Properties

Active | Enables/Disables the indexed Animation.
Chart (inherited from TeeBase) | Chart associated with this object
Description |
Speed | Gets and sets the speed of the animation effect, in milliseconds.
Summary |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Target | Gets and sets the target to which the animation is applied.
Trigger | Gets and sets the type of trigger which starts the animation.

See Also

Animation Class | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.AnimationFields

Steema.TeeChart.Animations.Animation Fields

Public Fields

ClickTolerance
Part

See Also

Animation Class | Steema.TeeChart.Animations Namespace


ClickTolerance

Steema.TeeChart.Animations.Animation.ClickTolerance Field

public const Int32 ClickTolerance

See Also

Animation Class | Animation Members | Steema.TeeChart.Animations Namespace


Part

Steema.TeeChart.Animations.Animation.Part Field

public ChartClickedPart Part

See Also

Animation Class | Animation Members | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.AnimationMethods

Steema.TeeChart.Animations.Animation Methods

Public Methods

Clone |
CreateNewAnimation | Creates a new Animation object and sets the Name and Chart properties.
GetBitmapEditor | Returns the associated bitmap icon for a given Animation class. This icon is used at Animations gallery ListBox and Animations Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
NewFromType | Creates a new animation from the System.Type of an existing animations object.
ToString |

See Also

Animation Class | Steema.TeeChart.Animations Namespace


Clone

Steema.TeeChart.Animations.Animation.Clone Method

public virtual Object Clone()

See Also

Animation Class | Animation Members | Steema.TeeChart.Animations Namespace


CreateNewAnimation

Steema.TeeChart.Animations.Animation.CreateNewAnimation Method

Creates a new Animation object and sets the Name and Chart properties.
public static Animation CreateNewAnimation(Chart chart,
     Type type)

See Also

Animation Class | Animation Members | Steema.TeeChart.Animations Namespace


GetBitmapEditor

Steema.TeeChart.Animations.Animation.GetBitmapEditor Method

Returns the associated bitmap icon for a given Animation class. This icon is used at Animations gallery ListBox and Animations Editor dialog.
public Bitmap GetBitmapEditor()

See Also

Animation Class | Animation Members | Steema.TeeChart.Animations Namespace


NewFromType

Steema.TeeChart.Animations.Animation.NewFromType Method

Creates a new animation from the System.Type of an existing animations object.
public static Animation NewFromType(Type type)

See Also

Animation Class | Animation Members | Steema.TeeChart.Animations Namespace


ToString

Steema.TeeChart.Animations.Animation.ToString Method

public override String ToString()

See Also

Animation Class | Animation Members | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.AnimationProperties

Steema.TeeChart.Animations.Animation Properties

Public Properties

Active | Enables/Disables the indexed Animation.
Chart (inherited from TeeBase) | Chart associated with this object
Description |
Speed | Gets and sets the speed of the animation effect, in milliseconds.
Summary |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Target | Gets and sets the target to which the animation is applied.
Trigger | Gets and sets the type of trigger which starts the animation.

See Also

Animation Class | Steema.TeeChart.Animations Namespace


Active

Steema.TeeChart.Animations.Animation.Active Property

Enables/Disables the indexed Animation.
public Boolean Active {get; set;}

See Also

Animation Class | Animation Members | Steema.TeeChart.Animations Namespace


Description

Steema.TeeChart.Animations.Animation.Description Property

public abstract String Description {get;}

See Also

Animation Class | Animation Members | Steema.TeeChart.Animations Namespace


Speed

Steema.TeeChart.Animations.Animation.Speed Property

Gets and sets the speed of the animation effect, in milliseconds.
public Int32 Speed {get; set;}

See Also

Animation Class | Animation Members | Steema.TeeChart.Animations Namespace


Summary

Steema.TeeChart.Animations.Animation.Summary Property

public abstract String Summary {get;}

See Also

Animation Class | Animation Members | Steema.TeeChart.Animations Namespace


Target

Steema.TeeChart.Animations.Animation.Target Property

Gets and sets the target to which the animation is applied.
public ChartClickedPartStyle Target {get; set;}

See Also

Animation Class | Animation Members | Steema.TeeChart.Animations Namespace


Trigger

Steema.TeeChart.Animations.Animation.Trigger Property

Gets and sets the type of trigger which starts the animation.
public AnimationTrigger Trigger {get; set;}

See Also

Animation Class | Animation Members | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.AnimationsCollection

Steema.TeeChart.Animations.AnimationsCollection Class

Collection of Animation components.

For a list of all members of this type, see AnimationsCollection Members

System.Object
System.Collections.CollectionBase
public class AnimationsCollection : CollectionBase , IList, ICollection
, IEnumerable

Requirements

Namespace: Steema.TeeChart.Animations Namespace

Assembly: TeeChart.Android.dll

See Also

AnimationsCollection members | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.AnimationsCollectionMembers

Steema.TeeChart.Animations.AnimationsCollection all Members

AnimationsCollection overview

Constructors

Constructor

Public Fields

chart

Public Methods

Add | Adds a new animation to your TChart.
Clear | Removes (and optionally disposes) all Animations.
IndexOf | Returns the corresponding point index which has the specified Value.
Remove | Removes a animation from the TChart.

Public Properties

Item

See Also

AnimationsCollection Class | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.AnimationsCollection Constructor

public AnimationsCollection(Chart c)

See Also

AnimationsCollection Class | AnimationsCollection Members | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.AnimationsCollectionFields

Steema.TeeChart.Animations.AnimationsCollection Fields

Public Fields

chart

See Also

AnimationsCollection Class | Steema.TeeChart.Animations Namespace


chart

Steema.TeeChart.Animations.AnimationsCollection.chart Field

public Chart chart

See Also

AnimationsCollection Class | AnimationsCollection Members | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.AnimationsCollectionMethods

Steema.TeeChart.Animations.AnimationsCollection Methods

Public Methods

Add | Adds a new animation to your TChart.
Clear | Removes (and optionally disposes) all Animations.
IndexOf | Returns the corresponding point index which has the specified Value.
Remove | Removes a animation from the TChart.

See Also

AnimationsCollection Class | Steema.TeeChart.Animations Namespace


Add

Steema.TeeChart.Animations.AnimationsCollection.Add Method

Overload List

Adds a new animation to your TChart.

public Int32 Add(Steema.TeeChart.Animations.Animation)
public Int32 Add(System.Type)

See Also

AnimationsCollection Class | AnimationsCollection Members | Steema.TeeChart.Animations Namespace


Add

Steema.TeeChart.Animations.AnimationsCollection.Add Method

public Int32 Add(Type animation)

See Also

Add Overload List | AnimationsCollection Class | AnimationsCollection Members | Steema.TeeChart.Animations Namespace


Add

Steema.TeeChart.Animations.AnimationsCollection.Add Method

Adds a new animation to your TChart.
public Int32 Add(Animation animation)

See Also

Add Overload List | AnimationsCollection Class | AnimationsCollection Members | Steema.TeeChart.Animations Namespace


Clear

Steema.TeeChart.Animations.AnimationsCollection.Clear Method

Overload List

Removes (and optionally disposes) all Animations.

public Void Clear(System.Boolean)

Removes and disposes all Animations.

public Void Clear()

See Also

AnimationsCollection Class | AnimationsCollection Members | Steema.TeeChart.Animations Namespace


Clear

Steema.TeeChart.Animations.AnimationsCollection.Clear Method

Removes and disposes all Animations.
public Void Clear()

See Also

Clear Overload List | AnimationsCollection Class | AnimationsCollection Members | Steema.TeeChart.Animations Namespace


Clear

Steema.TeeChart.Animations.AnimationsCollection.Clear Method

Removes (and optionally disposes) all Animations.
public Void Clear(Boolean dispose)

See Also

Clear Overload List | AnimationsCollection Class | AnimationsCollection Members | Steema.TeeChart.Animations Namespace


IndexOf

Steema.TeeChart.Animations.AnimationsCollection.IndexOf Method

Returns the corresponding point index which has the specified Value.
public Int32 IndexOf(Animation s)

See Also

AnimationsCollection Class | AnimationsCollection Members | Steema.TeeChart.Animations Namespace


Remove

Steema.TeeChart.Animations.AnimationsCollection.Remove Method

Removes a animation from the TChart.
public Void Remove(Animation s)

See Also

AnimationsCollection Class | AnimationsCollection Members | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.AnimationsCollectionProperties

Steema.TeeChart.Animations.AnimationsCollection Properties

Public Properties

Item

See Also

AnimationsCollection Class | Steema.TeeChart.Animations Namespace


Item

Steema.TeeChart.Animations.AnimationsCollection.Item Property

public Animation Item(Int32 index) {get; set;}

See Also

AnimationsCollection Class | AnimationsCollection Members | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.AnimationTrigger

Steema.TeeChart.Animations.AnimationTrigger Enum

[Serializable]
public sealed enum AnimationTrigger : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
MouseClick |
MouseOver |

See Also

Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.BeforeDrawAxesEventArgs

Steema.TeeChart.Animations.BeforeDrawAxesEventArgs Class

Internal use. Animation support EventArgs

For a list of all members of this type, see BeforeDrawAxesEventArgs Members

System.Object
System.EventArgs
public class BeforeDrawAxesEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Animations Namespace

Assembly: TeeChart.Android.dll

See Also

BeforeDrawAxesEventArgs members | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.BeforeDrawAxesEventArgsMembers

Steema.TeeChart.Animations.BeforeDrawAxesEventArgs all Members

BeforeDrawAxesEventArgs overview

Constructors

Constructor

See Also

BeforeDrawAxesEventArgs Class | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.BeforeDrawAxesEventArgs Constructor

public BeforeDrawAxesEventArgs()

See Also

BeforeDrawAxesEventArgs Class | BeforeDrawAxesEventArgs Members | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.BeforeDrawEventArgs

Steema.TeeChart.Animations.BeforeDrawEventArgs Class

Internal use. Animation support EventArgs

For a list of all members of this type, see BeforeDrawEventArgs Members

System.Object
System.EventArgs
public class BeforeDrawEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Animations Namespace

Assembly: TeeChart.Android.dll

See Also

BeforeDrawEventArgs members | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.BeforeDrawEventArgsMembers

Steema.TeeChart.Animations.BeforeDrawEventArgs all Members

BeforeDrawEventArgs overview

Constructors

Constructor

See Also

BeforeDrawEventArgs Class | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.BeforeDrawEventArgs Constructor

public BeforeDrawEventArgs()

See Also

BeforeDrawEventArgs Class | BeforeDrawEventArgs Members | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.BeforeDrawSeriesEventArgs

Steema.TeeChart.Animations.BeforeDrawSeriesEventArgs Class

Internal use. Animation support EventArgs

For a list of all members of this type, see BeforeDrawSeriesEventArgs Members

System.Object
System.EventArgs
public class BeforeDrawSeriesEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Animations Namespace

Assembly: TeeChart.Android.dll

See Also

BeforeDrawSeriesEventArgs members | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.BeforeDrawSeriesEventArgsMembers

Steema.TeeChart.Animations.BeforeDrawSeriesEventArgs all Members

BeforeDrawSeriesEventArgs overview

Constructors

Constructor

See Also

BeforeDrawSeriesEventArgs Class | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Animations.BeforeDrawSeriesEventArgs Constructor

public BeforeDrawSeriesEventArgs()

See Also

BeforeDrawSeriesEventArgs Class | BeforeDrawSeriesEventArgs Members | Steema.TeeChart.Animations Namespace


Steema.TeeChart.Data

Steema.TeeChart.Data Namespace

Namespace hierarchy

Public Classes

SeriesSource | Abstract class to define Series.DataSource components.
DataSeriesSource | Abstract class to define Database Series.DataSource components.
SummarySource | Fills a Series with specified summary fields from dataset. This component must be assigned to Series.DataSource property.
TextField | Source Textfield charactistics
TextFieldCollection | TextField Collection
TextSource |
CrossTabSource |

Public Enumerations

DataGroup | Timespan grouping elements
ChartAggregate | Aggregate grouping elements
GroupFormula | Determines if crosstab will acumulate dataset field values or will simply count records.

Requirements

Namespace: Steema.TeeChart.Data Namespace

Assembly: TeeChart.Android.dll


Steema.TeeChart.Data Hierarchy

System.Object

Steema.TeeChart.Data.TextField

System.Collections.CollectionBase

Steema.TeeChart.Data.TextFieldCollection

System.MarshalByRefObject

System.ComponentModel.Component

Steema.TeeChart.Data.SeriesSource

Steema.TeeChart.Data.CrossTabSource

Steema.TeeChart.Data.DataSeriesSource

Steema.TeeChart.Data.SummarySource

Steema.TeeChart.Data.TextSource

See Also

SteemaTeeChartData Namespace


Steema.TeeChart.Data.ChartAggregate

Steema.TeeChart.Data.ChartAggregate Enum

Aggregate grouping elements
[Serializable]
public sealed enum ChartAggregate : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
None |
Sum |
Count |
High |
Low |
Average |

See Also

Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.CrossTabSource

Steema.TeeChart.Data.CrossTabSource Class

For a list of all members of this type, see CrossTabSource Members

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Data.SeriesSource
public class CrossTabSource : SeriesSource , IComponent, IDisposable

Requirements

Namespace: Steema.TeeChart.Data Namespace

Assembly: TeeChart.Android.dll

See Also

CrossTabSource members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.CrossTabSourceMembers

Steema.TeeChart.Data.CrossTabSource all Members

CrossTabSource overview

Constructors

Constructor Overloaded Use this constructor if you intend to setup the DataSource contents later.

Public Methods

RefreshData Refreshes the Series from the CrossTabSource Datasource. You do not need to call this method directly, please use CheckDataSource

Public Properties

CaseSensitive | When records in the database contain labels or group texts that are only different in case, setting this property to True will consider texts as different, thus creating new series or groups in the final chart.
DataSource | Stores the Datasource associated with this CrossTabSource.
Formula | Determines how will the crosstab use database values to add points to series.
GroupField | The field in the dataset to be used as grouping field. Different values in this field will be used to create additional series.
LabelField | The field in the dataset to be used to add labels (text) to series points.
Series | The Series that has this component as DataSource.
ValueField | The field in the dataset where values will be obtained to perform accumulation in the final crosstab chart.

See Also

CrossTabSource Class | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.CrossTabSource Constructor

Overload List

Use this constructor if you intend to setup the DataSource contents later.

public CrossTabSource()

Use this constructor if you already have the datasource available.

public CrossTabSource(System.Object)

See Also

CrossTabSource Class | CrossTabSource Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.CrossTabSource Constructor

Use this constructor if you already have the datasource available.
public CrossTabSource(Object source)

See Also

CrossTabSource Constructor Overload List | CrossTabSource Class | CrossTabSource Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.CrossTabSource Constructor

Use this constructor if you intend to setup the DataSource contents later.
public CrossTabSource()

See Also

CrossTabSource Constructor Overload List | CrossTabSource Class | CrossTabSource Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.CrossTabSourceMethods

Steema.TeeChart.Data.CrossTabSource Methods

Public Methods

RefreshData Refreshes the Series from the CrossTabSource Datasource. You do not need to call this method directly, please use CheckDataSource

See Also

CrossTabSource Class | Steema.TeeChart.Data Namespace


RefreshData

Steema.TeeChart.Data.CrossTabSource.RefreshData Method

Refreshes the Series from the CrossTabSource Datasource. You do not need to call this method directly, please use CheckDataSource
public override Void RefreshData()

See Also

CrossTabSource Class | CrossTabSource Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.CrossTabSourceProperties

Steema.TeeChart.Data.CrossTabSource Properties

Public Properties

CaseSensitive | When records in the database contain labels or group texts that are only different in case, setting this property to True will consider texts as different, thus creating new series or groups in the final chart.
DataSource | Stores the Datasource associated with this CrossTabSource.
Formula | Determines how will the crosstab use database values to add points to series.
GroupField | The field in the dataset to be used as grouping field. Different values in this field will be used to create additional series.
LabelField | The field in the dataset to be used to add labels (text) to series points.
Series | The Series that has this component as DataSource.
ValueField | The field in the dataset where values will be obtained to perform accumulation in the final crosstab chart.

See Also

CrossTabSource Class | Steema.TeeChart.Data Namespace


CaseSensitive

Steema.TeeChart.Data.CrossTabSource.CaseSensitive Property

When records in the database contain labels or group texts that are only different in case, setting this property to True will consider texts as different, thus creating new series or groups in the final chart.
public Boolean CaseSensitive {get; set;}

See Also

CrossTabSource Class | CrossTabSource Members | Steema.TeeChart.Data Namespace


DataSource

Steema.TeeChart.Data.CrossTabSource.DataSource Property

Stores the Datasource associated with this CrossTabSource.
public Object DataSource {get; set;}

See Also

CrossTabSource Class | CrossTabSource Members | Steema.TeeChart.Data Namespace


Formula

Steema.TeeChart.Data.CrossTabSource.Formula Property

Determines how will the crosstab use database values to add points to series.
public GroupFormula Formula {get; set;}

See Also

CrossTabSource Class | CrossTabSource Members | Steema.TeeChart.Data Namespace


GroupField

Steema.TeeChart.Data.CrossTabSource.GroupField Property

The field in the dataset to be used as grouping field. Different values in this field will be used to create additional series.
public String GroupField {get; set;}

See Also

CrossTabSource Class | CrossTabSource Members | Steema.TeeChart.Data Namespace


LabelField

Steema.TeeChart.Data.CrossTabSource.LabelField Property

The field in the dataset to be used to add labels (text) to series points.
public String LabelField {get; set;}

See Also

CrossTabSource Class | CrossTabSource Members | Steema.TeeChart.Data Namespace


Series

Steema.TeeChart.Data.CrossTabSource.Series Property

The Series that has this component as DataSource.
public Series Series {get; set;}

See Also

CrossTabSource Class | CrossTabSource Members | Steema.TeeChart.Data Namespace


ValueField

Steema.TeeChart.Data.CrossTabSource.ValueField Property

The field in the dataset where values will be obtained to perform accumulation in the final crosstab chart.
public String ValueField {get; set;}

See Also

CrossTabSource Class | CrossTabSource Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.DataGroup

Steema.TeeChart.Data.DataGroup Enum

Timespan grouping elements
[Serializable]
public sealed enum DataGroup : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
Hour |
Day |
Week |
WeekDay |
Month |
Quarter |
Year |
None |

See Also

Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.DataSeriesSource

Steema.TeeChart.Data.DataSeriesSource Class

Abstract class to define Database Series.DataSource components.

For a list of all members of this type, see DataSeriesSource Members

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Data.SeriesSource
public abstract class DataSeriesSource : SeriesSource , IComponent
, IDisposable

Requirements

Namespace: Steema.TeeChart.Data Namespace

Assembly: TeeChart.Android.dll

See Also

DataSeriesSource members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.DataSeriesSourceMembers

Steema.TeeChart.Data.DataSeriesSource all Members

DataSeriesSource overview

Public Methods

IsValidSource | Returns True when object is a valid source.
RefreshData (inherited from SeriesSource) | Fills Series with data from source.

Public Properties

Series (inherited from SeriesSource) The Series that has this component as DataSource.

See Also

DataSeriesSource Class | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.DataSeriesSourceMethods

Steema.TeeChart.Data.DataSeriesSource Methods

Public Methods

IsValidSource | Returns True when object is a valid source.
RefreshData (inherited from SeriesSource) | Fills Series with data from source.

See Also

DataSeriesSource Class | Steema.TeeChart.Data Namespace


IsValidSource

Steema.TeeChart.Data.DataSeriesSource.IsValidSource Method

Returns True when object is a valid source.
public static Boolean IsValidSource(Object c)

See Also

DataSeriesSource Class | DataSeriesSource Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.DataSeriesSourceProperties

Steema.TeeChart.Data.DataSeriesSource Properties

Public Properties

Series (inherited from SeriesSource) The Series that has this component as DataSource.

See Also

DataSeriesSource Class | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.GroupFormula

Steema.TeeChart.Data.GroupFormula Enum

Determines if crosstab will acumulate dataset field values or will simply count records.
[Serializable]
public sealed enum GroupFormula : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Count |
Sum |
Min |
Max |
Product |

See Also

Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.SeriesSource

Steema.TeeChart.Data.SeriesSource Class

Abstract class to define Series.DataSource components.

For a list of all members of this type, see SeriesSource Members

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
public abstract class SeriesSource : Component , IComponent, IDisposable

Requirements

Namespace: Steema.TeeChart.Data Namespace

Assembly: TeeChart.Android.dll

See Also

SeriesSource members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.SeriesSourceMembers

Steema.TeeChart.Data.SeriesSource all Members

SeriesSource overview

Public Methods

RefreshData Fills Series with data from source.

Public Properties

Series The Series that has this component as DataSource.

See Also

SeriesSource Class | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.SeriesSourceMethods

Steema.TeeChart.Data.SeriesSource Methods

Public Methods

RefreshData Fills Series with data from source.

See Also

SeriesSource Class | Steema.TeeChart.Data Namespace


RefreshData

Steema.TeeChart.Data.SeriesSource.RefreshData Method

Fills Series with data from source.
public abstract Void RefreshData()

See Also

SeriesSource Class | SeriesSource Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.SeriesSourceProperties

Steema.TeeChart.Data.SeriesSource Properties

Public Properties

Series The Series that has this component as DataSource.

See Also

SeriesSource Class | Steema.TeeChart.Data Namespace


Series

Steema.TeeChart.Data.SeriesSource.Series Property

The Series that has this component as DataSource.
public Series Series {get; set;}

See Also

SeriesSource Class | SeriesSource Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.SummarySource

Steema.TeeChart.Data.SummarySource Class

Fills a Series with specified summary fields from dataset. This component must be assigned to Series.DataSource property.

For a list of all members of this type, see SummarySource Members

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Data.SeriesSource
Steema.TeeChart.Data.DataSeriesSource
public class SummarySource : DataSeriesSource , IComponent, IDisposable

Requirements

Namespace: Steema.TeeChart.Data Namespace

Assembly: TeeChart.Android.dll

See Also

SummarySource members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.SummarySourceMembers

Steema.TeeChart.Data.SummarySource all Members

SummarySource overview

Constructors

Constructor Overloaded Use this constructor if you intend to setup the SummarySource contents later.

Public Methods

RefreshData Refreshes the Series from the SingleRecordSource Datasource. You do not need to call this method directly, please use CheckDataSource

Public Properties

DataSource | Stores the Datasource associated with this SingleRecordSource
Series (inherited from SeriesSource) | The Series that has this component as DataSource.

See Also

SummarySource Class | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.SummarySource Constructor

Overload List

Use this constructor if you intend to setup the SummarySource contents later.

public SummarySource()

Use this constructor if you already have the datasource available.

public SummarySource(System.Object)

See Also

SummarySource Class | SummarySource Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.SummarySource Constructor

Use this constructor if you already have the datasource available.
public SummarySource(Object source)

See Also

SummarySource Constructor Overload List | SummarySource Class | SummarySource Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.SummarySource Constructor

Use this constructor if you intend to setup the SummarySource contents later.
public SummarySource()

See Also

SummarySource Constructor Overload List | SummarySource Class | SummarySource Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.SummarySourceMethods

Steema.TeeChart.Data.SummarySource Methods

Public Methods

RefreshData Refreshes the Series from the SingleRecordSource Datasource. You do not need to call this method directly, please use CheckDataSource

See Also

SummarySource Class | Steema.TeeChart.Data Namespace


RefreshData

Steema.TeeChart.Data.SummarySource.RefreshData Method

Refreshes the Series from the SingleRecordSource Datasource. You do not need to call this method directly, please use CheckDataSource
public override Void RefreshData()

See Also

SummarySource Class | SummarySource Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.SummarySourceProperties

Steema.TeeChart.Data.SummarySource Properties

Public Properties

DataSource | Stores the Datasource associated with this SingleRecordSource
Series (inherited from SeriesSource) | The Series that has this component as DataSource.

See Also

SummarySource Class | Steema.TeeChart.Data Namespace


DataSource

Steema.TeeChart.Data.SummarySource.DataSource Property

Stores the Datasource associated with this SingleRecordSource
public Object DataSource {get; set;}

See Also

SummarySource Class | SummarySource Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.TextField

Steema.TeeChart.Data.TextField Class

Source Textfield charactistics

For a list of all members of this type, see TextField Members

System.Object
public sealed class TextField : Object

Requirements

Namespace: Steema.TeeChart.Data Namespace

Assembly: TeeChart.Android.dll

See Also

TextField members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.TextFieldMembers

Steema.TeeChart.Data.TextField all Members

TextField overview

Constructors

Constructor Overloaded

Public Properties

Index | Stores the index of the added textsource field.
Name | Stores the name of the added textsource field.

See Also

TextField Class | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.TextField Constructor

Overload List

public TextField()
public TextField(System.Int32, System.String)

See Also

TextField Class | TextField Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.TextField Constructor

public TextField(Int32 index,
     String name)

See Also

TextField Constructor Overload List | TextField Class | TextField Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.TextField Constructor

public TextField()

See Also

TextField Constructor Overload List | TextField Class | TextField Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.TextFieldProperties

Steema.TeeChart.Data.TextField Properties

Public Properties

Index | Stores the index of the added textsource field.
Name | Stores the name of the added textsource field.

See Also

TextField Class | Steema.TeeChart.Data Namespace


Index

Steema.TeeChart.Data.TextField.Index Property

Stores the index of the added textsource field.
public Int32 Index {get; set;}

See Also

TextField Class | TextField Members | Steema.TeeChart.Data Namespace


Name

Steema.TeeChart.Data.TextField.Name Property

Stores the name of the added textsource field.
public String Name {get; set;}

See Also

TextField Class | TextField Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.TextFieldCollection

Steema.TeeChart.Data.TextFieldCollection Class

TextField Collection

For a list of all members of this type, see TextFieldCollection Members

System.Object
System.Collections.CollectionBase
public class TextFieldCollection : CollectionBase , IList, ICollection
, IEnumerable

Requirements

Namespace: Steema.TeeChart.Data Namespace

Assembly: TeeChart.Android.dll

See Also

TextFieldCollection members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.TextFieldCollectionMembers

Steema.TeeChart.Data.TextFieldCollection all Members

TextFieldCollection overview

Public Methods

Add | Adds a textsource field into the TextFieldCollection.
AddRange |
Insert | Inserts a textsource field into the TextFieldCollection at the specific index.
Remove | Removes a textsource field from the TextFieldCollection.

Public Properties

Item

See Also

TextFieldCollection Class | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.TextFieldCollectionMethods

Steema.TeeChart.Data.TextFieldCollection Methods

Public Methods

Add | Adds a textsource field into the TextFieldCollection.
AddRange |
Insert | Inserts a textsource field into the TextFieldCollection at the specific index.
Remove | Removes a textsource field from the TextFieldCollection.

See Also

TextFieldCollection Class | Steema.TeeChart.Data Namespace


Add

Steema.TeeChart.Data.TextFieldCollection.Add Method

Overload List

Adds a textsource field into the TextFieldCollection.

public Int32 Add(Steema.TeeChart.Data.TextField)

Adds a textsource field into the TextFieldCollection.

public Int32 Add(System.Int32, System.String)

See Also

TextFieldCollection Class | TextFieldCollection Members | Steema.TeeChart.Data Namespace


Add

Steema.TeeChart.Data.TextFieldCollection.Add Method

Adds a textsource field into the TextFieldCollection.
public Int32 Add(Int32 index,
     String name)

See Also

Add Overload List | TextFieldCollection Class | TextFieldCollection Members | Steema.TeeChart.Data Namespace


Add

Steema.TeeChart.Data.TextFieldCollection.Add Method

Adds a textsource field into the TextFieldCollection.
public Int32 Add(TextField field)

See Also

Add Overload List | TextFieldCollection Class | TextFieldCollection Members | Steema.TeeChart.Data Namespace


AddRange

Steema.TeeChart.Data.TextFieldCollection.AddRange Method

public Void AddRange(TextField[] fields)

See Also

TextFieldCollection Class | TextFieldCollection Members | Steema.TeeChart.Data Namespace


Insert

Steema.TeeChart.Data.TextFieldCollection.Insert Method

Inserts a textsource field into the TextFieldCollection at the specific index.
public Void Insert(Int32 index,
     TextField field)

See Also

TextFieldCollection Class | TextFieldCollection Members | Steema.TeeChart.Data Namespace


Remove

Steema.TeeChart.Data.TextFieldCollection.Remove Method

Removes a textsource field from the TextFieldCollection.
public Void Remove(TextField field)

See Also

TextFieldCollection Class | TextFieldCollection Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.TextFieldCollectionProperties

Steema.TeeChart.Data.TextFieldCollection Properties

Public Properties

Item

See Also

TextFieldCollection Class | Steema.TeeChart.Data Namespace


Item

Steema.TeeChart.Data.TextFieldCollection.Item Property

public TextField Item(Int32 index) {get;}

See Also

TextFieldCollection Class | TextFieldCollection Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.TextSource

Steema.TeeChart.Data.TextSource Class

For a list of all members of this type, see TextSource Members

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Data.SeriesSource
public class TextSource : SeriesSource , IComponent, IDisposable

Requirements

Namespace: Steema.TeeChart.Data Namespace

Assembly: TeeChart.Android.dll

See Also

TextSource members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.TextSourceMembers

Steema.TeeChart.Data.TextSource all Members

TextSource overview

Constructors

Constructor Overloaded

Public Methods

Add |
IsURL | Returns true when FileName property starts with "http://"
LoadFromFile |
LoadFromStream |
LoadFromStrings |
LoadFromURL |
RefreshData |

Public Properties

DecimalSeparator | Specifies the decimal separator used to read numbers within a TextSource.
Fields |
FileName |
HeaderLines |
Separator |
Series (inherited from SeriesSource) | The Series that has this component as DataSource.

See Also

TextSource Class | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.TextSource Constructor

Overload List

public TextSource()
public TextSource(System.String)

See Also

TextSource Class | TextSource Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.TextSource Constructor

public TextSource(String fileName)

See Also

TextSource Constructor Overload List | TextSource Class | TextSource Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.TextSource Constructor

public TextSource()

See Also

TextSource Constructor Overload List | TextSource Class | TextSource Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.TextSourceMethods

Steema.TeeChart.Data.TextSource Methods

Public Methods

Add |
IsURL | Returns true when FileName property starts with "http://"
LoadFromFile |
LoadFromStream |
LoadFromStrings |
LoadFromURL |
RefreshData |

See Also

TextSource Class | Steema.TeeChart.Data Namespace


Add

Steema.TeeChart.Data.TextSource.Add Method

public Void Add(StreamReader r)

See Also

TextSource Class | TextSource Members | Steema.TeeChart.Data Namespace


IsURL

Steema.TeeChart.Data.TextSource.IsURL Method

Returns true when FileName property starts with "http://"
public Boolean IsURL()

See Also

TextSource Class | TextSource Members | Steema.TeeChart.Data Namespace


LoadFromFile

Steema.TeeChart.Data.TextSource.LoadFromFile Method

public Void LoadFromFile(String AFileName)

See Also

TextSource Class | TextSource Members | Steema.TeeChart.Data Namespace


LoadFromStream

Steema.TeeChart.Data.TextSource.LoadFromStream Method

public Void LoadFromStream(Stream Stream)

See Also

TextSource Class | TextSource Members | Steema.TeeChart.Data Namespace


LoadFromStrings

Steema.TeeChart.Data.TextSource.LoadFromStrings Method

public Void LoadFromStrings(String[] Strings)

See Also

TextSource Class | TextSource Members | Steema.TeeChart.Data Namespace


LoadFromURL

Steema.TeeChart.Data.TextSource.LoadFromURL Method

public Void LoadFromURL(String AURL)

See Also

TextSource Class | TextSource Members | Steema.TeeChart.Data Namespace


RefreshData

Steema.TeeChart.Data.TextSource.RefreshData Method

public override Void RefreshData()

See Also

TextSource Class | TextSource Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Data.TextSourceProperties

Steema.TeeChart.Data.TextSource Properties

Public Properties

DecimalSeparator | Specifies the decimal separator used to read numbers within a TextSource.
Fields |
FileName |
HeaderLines |
Separator |
Series (inherited from SeriesSource) | The Series that has this component as DataSource.

See Also

TextSource Class | Steema.TeeChart.Data Namespace


DecimalSeparator

Steema.TeeChart.Data.TextSource.DecimalSeparator Property

Specifies the decimal separator used to read numbers within a TextSource.
public Char DecimalSeparator {get; set;}

See Also

TextSource Class | TextSource Members | Steema.TeeChart.Data Namespace


Fields

Steema.TeeChart.Data.TextSource.Fields Property

public TextFieldCollection Fields {get;}

See Also

TextSource Class | TextSource Members | Steema.TeeChart.Data Namespace


FileName

Steema.TeeChart.Data.TextSource.FileName Property

public String FileName {get; set;}

See Also

TextSource Class | TextSource Members | Steema.TeeChart.Data Namespace


HeaderLines

Steema.TeeChart.Data.TextSource.HeaderLines Property

public Int32 HeaderLines {get; set;}

See Also

TextSource Class | TextSource Members | Steema.TeeChart.Data Namespace


Separator

Steema.TeeChart.Data.TextSource.Separator Property

public Char Separator {get; set;}

See Also

TextSource Class | TextSource Members | Steema.TeeChart.Data Namespace


Steema.TeeChart.Drawing

Steema.TeeChart.Drawing Namespace

Namespace hierarchy

Public Classes

TeeBase | Non-visible class for Chart element common characteristics
Shape | Base class for Chart Shape elements
TextShape | Base class for Chart shape elements with text
ChartPen | Common Chart Pen
Aspect | Chart view characteristics
Shadow | Properties to draw a shadow.
PointXYZ | XYZ Point holder
Graphics3D |
Pie3D |
ChartBrush | Common Chart Brush
GradientStyle |
Gradient | Properties to configure a gradient filling.
ChartFont | Common Chart Font
Bevel | Properties to display bevels (frames) around rectangles.
ImageBevel | Properties to display bevels (frames) around rectangles.
ShapeSize | Size holder
TextShapePosition | Shape Custom Position
View3DEvent | Notify class for Aspect related activity
Graphics3DAndroid |

Public Interfaces

IDirect2D
IOpenGL
IGLLightsource
IGLPosition

Public Delegates

TTeeView3DScrolled
TTeeCanvasCalcPoints
TTeeCanvasTriPoints

Public Structures

PointDouble | XY Point holder
Point3DDouble | XYZ Point Holder
Point3D | XYZ Point Holder
Triangle3D | Triangular 3D element holder
TTriangleIndexes |
Triangle2D | Triangular 2D element holder

Public Enumerations

ThreeDPlane | orientation
SurfaceStyle |
CanvasType |
TeeFontStyle |
TCanvasBackMode |
TTeeTransparency |
BufferStyle | The type of double buffered applied during Chart drawing.
PathGradientMode |
TCanvas3DPlane |
GradientDirection |
DashStyle |
EdgeStyles | Defines the styles of the edges between two adjacent surfaces.
BevelStyles | Defines the styles of the bevels (frames) around rectangles.
ImageMode | Display characteristics for an Image
TextFormat |
TextShapeStyle | Defines the style of text-containing shapes.

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll


Steema.TeeChart.Drawing Hierarchy

System.Object

Steema.TeeChart.Drawing.Graphics3D.Pie3D

Steema.TeeChart.Drawing.PointXYZ

Steema.TeeChart.Drawing.ShapeSize

Steema.TeeChart.Drawing.TeeBase

Steema.TeeChart.Drawing.Aspect

Steema.TeeChart.Drawing.Bevel

Steema.TeeChart.Drawing.ChartBrush

Steema.TeeChart.Drawing.ChartFont

Steema.TeeChart.Drawing.ChartPen

Steema.TeeChart.Drawing.Gradient

Steema.TeeChart.Drawing.GradientStyle

Steema.TeeChart.Drawing.Graphics3D

Steema.TeeChart.Drawing.Graphics3DAndroid

Steema.TeeChart.Drawing.ImageBevel

Steema.TeeChart.Drawing.Shadow

Steema.TeeChart.Drawing.Shape

Steema.TeeChart.Drawing.TextShape

Steema.TeeChart.Drawing.TextShapePosition

Steema.TeeChart.TeeEvent

Steema.TeeChart.Drawing.View3DEvent

See Also

SteemaTeeChartDrawing Namespace


Steema.TeeChart.Drawing.Aspect

Steema.TeeChart.Drawing.Aspect Class

Chart view characteristics

For a list of all members of this type, see Aspect Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public sealed class Aspect : TeeBase

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

Aspect members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.AspectMembers

Steema.TeeChart.Drawing.Aspect all Members

Aspect overview

Constructors

Constructor Overloaded

Public Fields

Height3D
Width3D

Public Methods

Assign | Copies all properties from a Series component to another.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

Public Properties

ApplyZOrder | When True, multiple Series are displayed at a different 3D "Z" (depth) position.
Chart (inherited from TeeBase) | Chart associated with this object
Chart3DPercent | Percent from 0 to 100 of Z Depth.
ClipPoints | When True, restricts Series points to display outside the Chart axes rectangle.
ColorPaletteIndex | Stores the Index of the ColorPalette used in the Chart.
Elevation | Gets or sets the angle in degrees of 3D elevation.
ElevationFloat | Gets or sets the angle, as float, in degrees of 3D elevation.
HorizOffset | Amount (postive or negative) in pixels of horizontal displacement.
HorizOffsetFloat | Amount (postive or negative) in pixels of horizontal displacement.
OrthoAngle | Angle in degrees, from 0 to 90, when displaying in Orthogonal mode.
Orthogonal | When True, displays in semi-3D mode.
Perspective | Percent of 3D perspective
Rotation | Gets or sets the angle in degrees of 3D rotation.
RotationFloat | Gets or sets the angle, as Float, in degrees of 3D rotation.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
ThemeIndex |
Tilt | Gets or sets the angle in degrees of 3D tilt.
VertOffset | Amount (postive or negative) in pixels of vertical displacement.
VertOffsetFloat | Amount (postive or negative) in pixels of vertical displacement.
View3D | Gets or sets 3D display mode.
ZOffset |
Zoom | Percent of zoom in 3D mode.
ZoomFloat | Percent of zoom in 3D mode.
ZoomText | When True, all texts are resized according to Zoom property.

See Also

Aspect Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Aspect Constructor

Overload List

public Aspect()
public Aspect(Steema.TeeChart.Chart)

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Aspect Constructor

public Aspect(Chart c)

See Also

Aspect Constructor Overload List | Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Aspect Constructor

public Aspect()

See Also

Aspect Constructor Overload List | Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.AspectFields

Steema.TeeChart.Drawing.Aspect Fields

Public Fields

Height3D
Width3D

See Also

Aspect Class | Steema.TeeChart.Drawing Namespace


Height3D

Steema.TeeChart.Drawing.Aspect.Height3D Field

public Int32 Height3D

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


Width3D

Steema.TeeChart.Drawing.Aspect.Width3D Field

public Int32 Width3D

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.AspectMethods

Steema.TeeChart.Drawing.Aspect Methods

Public Methods

Assign | Copies all properties from a Series component to another.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

See Also

Aspect Class | Steema.TeeChart.Drawing Namespace


Assign

Steema.TeeChart.Drawing.Aspect.Assign Method

Copies all properties from a Series component to another.
public Void Assign(Aspect a)

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.AspectProperties

Steema.TeeChart.Drawing.Aspect Properties

Public Properties

ApplyZOrder | When True, multiple Series are displayed at a different 3D "Z" (depth) position.
Chart (inherited from TeeBase) | Chart associated with this object
Chart3DPercent | Percent from 0 to 100 of Z Depth.
ClipPoints | When True, restricts Series points to display outside the Chart axes rectangle.
ColorPaletteIndex | Stores the Index of the ColorPalette used in the Chart.
Elevation | Gets or sets the angle in degrees of 3D elevation.
ElevationFloat | Gets or sets the angle, as float, in degrees of 3D elevation.
HorizOffset | Amount (postive or negative) in pixels of horizontal displacement.
HorizOffsetFloat | Amount (postive or negative) in pixels of horizontal displacement.
OrthoAngle | Angle in degrees, from 0 to 90, when displaying in Orthogonal mode.
Orthogonal | When True, displays in semi-3D mode.
Perspective | Percent of 3D perspective
Rotation | Gets or sets the angle in degrees of 3D rotation.
RotationFloat | Gets or sets the angle, as Float, in degrees of 3D rotation.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
ThemeIndex |
Tilt | Gets or sets the angle in degrees of 3D tilt.
VertOffset | Amount (postive or negative) in pixels of vertical displacement.
VertOffsetFloat | Amount (postive or negative) in pixels of vertical displacement.
View3D | Gets or sets 3D display mode.
ZOffset |
Zoom | Percent of zoom in 3D mode.
ZoomFloat | Percent of zoom in 3D mode.
ZoomText | When True, all texts are resized according to Zoom property.

See Also

Aspect Class | Steema.TeeChart.Drawing Namespace


ApplyZOrder

Steema.TeeChart.Drawing.Aspect.ApplyZOrder Property

When True, multiple Series are displayed at a different 3D "Z" (depth) position.
public Boolean ApplyZOrder {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


Chart3DPercent

Steema.TeeChart.Drawing.Aspect.Chart3DPercent Property

Percent from 0 to 100 of Z Depth.
public Int32 Chart3DPercent {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


ClipPoints

Steema.TeeChart.Drawing.Aspect.ClipPoints Property

When True, restricts Series points to display outside the Chart axes rectangle.
public Boolean ClipPoints {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


ColorPaletteIndex

Steema.TeeChart.Drawing.Aspect.ColorPaletteIndex Property

Stores the Index of the ColorPalette used in the Chart.
public Int32 ColorPaletteIndex {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


Elevation

Steema.TeeChart.Drawing.Aspect.Elevation Property

Gets or sets the angle in degrees of 3D elevation.
public Int32 Elevation {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


ElevationFloat

Steema.TeeChart.Drawing.Aspect.ElevationFloat Property

Gets or sets the angle, as float, in degrees of 3D elevation.
public Double ElevationFloat {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


HorizOffset

Steema.TeeChart.Drawing.Aspect.HorizOffset Property

Amount (postive or negative) in pixels of horizontal displacement.
public Int32 HorizOffset {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


HorizOffsetFloat

Steema.TeeChart.Drawing.Aspect.HorizOffsetFloat Property

Amount (postive or negative) in pixels of horizontal displacement.
public Double HorizOffsetFloat {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


OrthoAngle

Steema.TeeChart.Drawing.Aspect.OrthoAngle Property

Angle in degrees, from 0 to 90, when displaying in Orthogonal mode.
public Int32 OrthoAngle {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace | Orthogonal


Orthogonal

Steema.TeeChart.Drawing.Aspect.Orthogonal Property

When True, displays in semi-3D mode.
public Boolean Orthogonal {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


Perspective

Steema.TeeChart.Drawing.Aspect.Perspective Property

Percent of 3D perspective
public Int32 Perspective {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


Rotation

Steema.TeeChart.Drawing.Aspect.Rotation Property

Gets or sets the angle in degrees of 3D rotation.
public Int32 Rotation {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


RotationFloat

Steema.TeeChart.Drawing.Aspect.RotationFloat Property

Gets or sets the angle, as Float, in degrees of 3D rotation.
public Double RotationFloat {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


ThemeIndex

Steema.TeeChart.Drawing.Aspect.ThemeIndex Property

public Int32 ThemeIndex {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


Tilt

Steema.TeeChart.Drawing.Aspect.Tilt Property

Gets or sets the angle in degrees of 3D tilt.
public Int32 Tilt {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


VertOffset

Steema.TeeChart.Drawing.Aspect.VertOffset Property

Amount (postive or negative) in pixels of vertical displacement.
public Int32 VertOffset {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


VertOffsetFloat

Steema.TeeChart.Drawing.Aspect.VertOffsetFloat Property

Amount (postive or negative) in pixels of vertical displacement.
public Double VertOffsetFloat {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


View3D

Steema.TeeChart.Drawing.Aspect.View3D Property

Gets or sets 3D display mode.
public Boolean View3D {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace | Orthogonal


ZOffset

Steema.TeeChart.Drawing.Aspect.ZOffset Property

public Double ZOffset {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


Zoom

Steema.TeeChart.Drawing.Aspect.Zoom Property

Percent of zoom in 3D mode.
public Int32 Zoom {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace | View3D


ZoomFloat

Steema.TeeChart.Drawing.Aspect.ZoomFloat Property

Percent of zoom in 3D mode.
public Double ZoomFloat {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace | View3D


ZoomText

Steema.TeeChart.Drawing.Aspect.ZoomText Property

When True, all texts are resized according to Zoom property.
public Boolean ZoomText {get; set;}

See Also

Aspect Class | Aspect Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Aspect.TTeeView3DScrolled

Steema.TeeChart.Drawing.Aspect.TTeeView3DScrolled Delegate

public delegate TTeeView3DScrolled (Boolean IsHoriz)

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Bevel

Steema.TeeChart.Drawing.Bevel Class

Properties to display bevels (frames) around rectangles.

For a list of all members of this type, see Bevel Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public sealed class Bevel : TeeBase , ICloneable

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

Bevel members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.BevelMembers

Steema.TeeChart.Drawing.Bevel all Members

Bevel overview

Constructors

Constructor

Public Methods

Assign | Assign all properties from a bevel to another.
Clone |
Draw | Draws bevels around rectangle parameter.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
ColorOne | Color of left and top sides of bevels.
ColorTwo | Color of right and bottom sides of bevels.
Inner | Style for inner bevel.
Outer | Style for outer bevel.
StringColorOne |
StringColorTwo |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Width | Size in pixels for bevels.

See Also

Bevel Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Bevel Constructor

public Bevel(Chart c)

See Also

Bevel Class | Bevel Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.BevelMethods

Steema.TeeChart.Drawing.Bevel Methods

Public Methods

Assign | Assign all properties from a bevel to another.
Clone |
Draw | Draws bevels around rectangle parameter.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

See Also

Bevel Class | Steema.TeeChart.Drawing Namespace


Assign

Steema.TeeChart.Drawing.Bevel.Assign Method

Assign all properties from a bevel to another.
public Void Assign(Bevel b)

See Also

Bevel Class | Bevel Members | Steema.TeeChart.Drawing Namespace


Clone

Steema.TeeChart.Drawing.Bevel.Clone Method

public virtual Object Clone()

See Also

Bevel Class | Bevel Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Bevel.Draw Method

Draws bevels around rectangle parameter.
public Void Draw(Graphics3D g,
     Rectangle rect)

See Also

Bevel Class | Bevel Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.BevelProperties

Steema.TeeChart.Drawing.Bevel Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
ColorOne | Color of left and top sides of bevels.
ColorTwo | Color of right and bottom sides of bevels.
Inner | Style for inner bevel.
Outer | Style for outer bevel.
StringColorOne |
StringColorTwo |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Width | Size in pixels for bevels.

See Also

Bevel Class | Steema.TeeChart.Drawing Namespace


ColorOne

Steema.TeeChart.Drawing.Bevel.ColorOne Property

Color of left and top sides of bevels.
public Color ColorOne {get; set;}

See Also

Bevel Class | Bevel Members | Steema.TeeChart.Drawing Namespace


ColorTwo

Steema.TeeChart.Drawing.Bevel.ColorTwo Property

Color of right and bottom sides of bevels.
public Color ColorTwo {get; set;}

See Also

Bevel Class | Bevel Members | Steema.TeeChart.Drawing Namespace


Inner

Steema.TeeChart.Drawing.Bevel.Inner Property

Style for inner bevel.
public BevelStyles Inner {get; set;}

See Also

Bevel Class | Bevel Members | Steema.TeeChart.Drawing Namespace


Outer

Steema.TeeChart.Drawing.Bevel.Outer Property

Style for outer bevel.
public BevelStyles Outer {get; set;}

See Also

Bevel Class | Bevel Members | Steema.TeeChart.Drawing Namespace


StringColorOne

Steema.TeeChart.Drawing.Bevel.StringColorOne Property

public String StringColorOne {get; set;}

See Also

Bevel Class | Bevel Members | Steema.TeeChart.Drawing Namespace


StringColorTwo

Steema.TeeChart.Drawing.Bevel.StringColorTwo Property

public String StringColorTwo {get; set;}

See Also

Bevel Class | Bevel Members | Steema.TeeChart.Drawing Namespace


Width

Steema.TeeChart.Drawing.Bevel.Width Property

Size in pixels for bevels.
public Int32 Width {get; set;}

See Also

Bevel Class | Bevel Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.BevelStyles

Steema.TeeChart.Drawing.BevelStyles Enum

Defines the styles of the bevels (frames) around rectangles.
[Serializable]
public sealed enum BevelStyles : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
None | No bevel.
Lowered | Lowered bevel.
Raised | Raised bevel.

See Also

Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.BufferStyle

Steema.TeeChart.Drawing.BufferStyle Enum

The type of double buffered applied during Chart drawing.
[Serializable]
public sealed enum BufferStyle : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
None | No double-buffering.
DoubleBuffer | Double buffering built into the System.Windows.Forms.ControlStyles enum.
OptimizedBuffer | Manually implemented, fully optimal double-buffering.

See Also

Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.CanvasType

Steema.TeeChart.Drawing.CanvasType Enum

[Serializable]
public sealed enum CanvasType : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
GDIplus |
HotSpot |
PDF |
EPS |
SVG |
VML |
XAML |
Flex |
Direct2D |
HTML5 |

See Also

Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartBrush

Steema.TeeChart.Drawing.ChartBrush Class

Common Chart Brush

For a list of all members of this type, see ChartBrush Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public sealed class ChartBrush : TeeBase , ICloneable

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

ChartBrush members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartBrushMembers

Steema.TeeChart.Drawing.ChartBrush all Members

ChartBrush overview

Constructors

Constructor Overloaded

Public Methods

ClearImage | Clears the IBrush element from all associated bitmap images.
Clone |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
LoadImage | Loads a bitmap into a ChartBrush element from the specified path.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Color | Determines the color used to fill a zone.
DrawingBrush | Accesses the internal Drawing.Brush
ForegroundColor | Color to fill inner portions of Brush, when Solid is false.
Gradient | Fill Gradient.
GradientVisible |
Image | Image to use for fill.
ImageMode | Drawing Brush Image Style.
ImageTransparent | Sets the Brush image to Transparent.
Solid | Fills using Color only. Does not use Foreground color.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency | Sets Transparency level from 0 to 100%.
Visible | Empty of Brush when False.
WrapMode | Drawing Brush Image Style.

See Also

ChartBrush Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartBrush Constructor

Overload List

public ChartBrush()
public ChartBrush(Steema.TeeChart.Chart, System.Boolean)
public ChartBrush(Steema.TeeChart.Chart)
public ChartBrush(Steema.TeeChart.Chart, System.Drawing.Color)
public ChartBrush(Steema.TeeChart.Chart, System.Drawing.Color, System.Boolean)

See Also

ChartBrush Class | ChartBrush Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartBrush Constructor

public ChartBrush(Chart c,
     Color aColor,
     Boolean startVisible)

See Also

ChartBrush Constructor Overload List | ChartBrush Class | ChartBrush Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartBrush Constructor

public ChartBrush(Chart c,
     Color aColor)

See Also

ChartBrush Constructor Overload List | ChartBrush Class | ChartBrush Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartBrush Constructor

public ChartBrush(Chart c)

See Also

ChartBrush Constructor Overload List | ChartBrush Class | ChartBrush Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartBrush Constructor

public ChartBrush(Chart c,
     Boolean startVisible)

See Also

ChartBrush Constructor Overload List | ChartBrush Class | ChartBrush Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartBrush Constructor

public ChartBrush()

See Also

ChartBrush Constructor Overload List | ChartBrush Class | ChartBrush Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartBrushMethods

Steema.TeeChart.Drawing.ChartBrush Methods

Public Methods

ClearImage | Clears the IBrush element from all associated bitmap images.
Clone |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
LoadImage | Loads a bitmap into a ChartBrush element from the specified path.

See Also

ChartBrush Class | Steema.TeeChart.Drawing Namespace


ClearImage

Steema.TeeChart.Drawing.ChartBrush.ClearImage Method

Clears the IBrush element from all associated bitmap images.
public Void ClearImage()

See Also

ChartBrush Class | ChartBrush Members | Steema.TeeChart.Drawing Namespace


Clone

Steema.TeeChart.Drawing.ChartBrush.Clone Method

public virtual Object Clone()

See Also

ChartBrush Class | ChartBrush Members | Steema.TeeChart.Drawing Namespace


LoadImage

Steema.TeeChart.Drawing.ChartBrush.LoadImage Method

Loads a bitmap into a ChartBrush element from the specified path.
public Void LoadImage(String fileName)

See Also

ChartBrush Class | ChartBrush Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartBrushProperties

Steema.TeeChart.Drawing.ChartBrush Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Color | Determines the color used to fill a zone.
DrawingBrush | Accesses the internal Drawing.Brush
ForegroundColor | Color to fill inner portions of Brush, when Solid is false.
Gradient | Fill Gradient.
GradientVisible |
Image | Image to use for fill.
ImageMode | Drawing Brush Image Style.
ImageTransparent | Sets the Brush image to Transparent.
Solid | Fills using Color only. Does not use Foreground color.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency | Sets Transparency level from 0 to 100%.
Visible | Empty of Brush when False.
WrapMode | Drawing Brush Image Style.

See Also

ChartBrush Class | Steema.TeeChart.Drawing Namespace


Color

Steema.TeeChart.Drawing.ChartBrush.Color Property

Determines the color used to fill a zone.
public Color Color {get; set;}

See Also

ChartBrush Class | ChartBrush Members | Steema.TeeChart.Drawing Namespace


DrawingBrush

Steema.TeeChart.Drawing.ChartBrush.DrawingBrush Property

Accesses the internal Drawing.Brush
public Paint DrawingBrush {get;}

See Also

ChartBrush Class | ChartBrush Members | Steema.TeeChart.Drawing Namespace


ForegroundColor

Steema.TeeChart.Drawing.ChartBrush.ForegroundColor Property

Color to fill inner portions of Brush, when Solid is false.
public Color ForegroundColor {get; set;}

See Also

ChartBrush Class | ChartBrush Members | Steema.TeeChart.Drawing Namespace


Gradient

Steema.TeeChart.Drawing.ChartBrush.Gradient Property

Fill Gradient.
public Gradient Gradient {get; set;}

See Also

ChartBrush Class | ChartBrush Members | Steema.TeeChart.Drawing Namespace


GradientVisible

Steema.TeeChart.Drawing.ChartBrush.GradientVisible Property

public Boolean GradientVisible {get;}

See Also

ChartBrush Class | ChartBrush Members | Steema.TeeChart.Drawing Namespace


Image

Steema.TeeChart.Drawing.ChartBrush.Image Property

Image to use for fill.
public Bitmap Image {get; set;}

See Also

ChartBrush Class | ChartBrush Members | Steema.TeeChart.Drawing Namespace


ImageMode

Steema.TeeChart.Drawing.ChartBrush.ImageMode Property

Drawing Brush Image Style.
public ImageMode ImageMode {get; set;}

See Also

ChartBrush Class | ChartBrush Members | Steema.TeeChart.Drawing Namespace


ImageTransparent

Steema.TeeChart.Drawing.ChartBrush.ImageTransparent Property

Sets the Brush image to Transparent.
public Boolean ImageTransparent {get; set;}

See Also

ChartBrush Class | ChartBrush Members | Steema.TeeChart.Drawing Namespace


Solid

Steema.TeeChart.Drawing.ChartBrush.Solid Property

Fills using Color only. Does not use Foreground color.
public Boolean Solid {get; set;}

See Also

ChartBrush Class | ChartBrush Members | Steema.TeeChart.Drawing Namespace


Transparency

Steema.TeeChart.Drawing.ChartBrush.Transparency Property

Sets Transparency level from 0 to 100%.
public Int32 Transparency {get; set;}

See Also

ChartBrush Class | ChartBrush Members | Steema.TeeChart.Drawing Namespace


Visible

Steema.TeeChart.Drawing.ChartBrush.Visible Property

Empty of Brush when False.
public Boolean Visible {get; set;}

See Also

ChartBrush Class | ChartBrush Members | Steema.TeeChart.Drawing Namespace


WrapMode

Steema.TeeChart.Drawing.ChartBrush.WrapMode Property

Drawing Brush Image Style.
public TileMode WrapMode {get; set;}

See Also

ChartBrush Class | ChartBrush Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartFont

Steema.TeeChart.Drawing.ChartFont Class

Common Chart Font

For a list of all members of this type, see ChartFont Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public sealed class ChartFont : TeeBase , ICloneable

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

ChartFont members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartFontMembers

Steema.TeeChart.Drawing.ChartFont all Members

ChartFont overview

Constructors

Constructor Overloaded

Public Methods

Clone |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ShouldDrawShadow |

Public Properties

Bold | Sets Font bold for text.
Brush | Sets the Brush characteristics of the font.
Chart (inherited from TeeBase) | Chart associated with this object
Color | Defines a Font colour for text.
DrawingFont |
Gradient | Applies a gradient fill to the font.
Italic | Sets Font italic (true or false) for text.
Name | Defines a Font type for text.
Shadow | Accesses the shadow properties of the font.
Size | Sets Font sizing (in points) for text.
SizeFloat | Sets Font sizing as em-size float for text to enable use of Font.Unit
Strikeout | Sets Font Strikeout on/off.
Style |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Underline | Sets Font underline on/off.
UsePrivateFont | Sets or returns whether to include TeeChart's private fonts in the ChartFont class.

See Also

ChartFont Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartFont Constructor

Overload List

public ChartFont()
public ChartFont(Steema.TeeChart.Chart)
public ChartFont(Steema.TeeChart.Chart, Android.Text.TextPaint)

See Also

ChartFont Class | ChartFont Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartFont Constructor

public ChartFont(Chart c,
     TextPaint font)

See Also

ChartFont Constructor Overload List | ChartFont Class | ChartFont Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartFont Constructor

public ChartFont(Chart c)

See Also

ChartFont Constructor Overload List | ChartFont Class | ChartFont Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartFont Constructor

public ChartFont()

See Also

ChartFont Constructor Overload List | ChartFont Class | ChartFont Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartFontMethods

Steema.TeeChart.Drawing.ChartFont Methods

Public Methods

Clone |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ShouldDrawShadow |

See Also

ChartFont Class | Steema.TeeChart.Drawing Namespace


Clone

Steema.TeeChart.Drawing.ChartFont.Clone Method

public virtual Object Clone()

See Also

ChartFont Class | ChartFont Members | Steema.TeeChart.Drawing Namespace


ShouldDrawShadow

Steema.TeeChart.Drawing.ChartFont.ShouldDrawShadow Method

public Boolean ShouldDrawShadow()

See Also

ChartFont Class | ChartFont Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartFontProperties

Steema.TeeChart.Drawing.ChartFont Properties

Public Properties

Bold | Sets Font bold for text.
Brush | Sets the Brush characteristics of the font.
Chart (inherited from TeeBase) | Chart associated with this object
Color | Defines a Font colour for text.
DrawingFont |
Gradient | Applies a gradient fill to the font.
Italic | Sets Font italic (true or false) for text.
Name | Defines a Font type for text.
Shadow | Accesses the shadow properties of the font.
Size | Sets Font sizing (in points) for text.
SizeFloat | Sets Font sizing as em-size float for text to enable use of Font.Unit
Strikeout | Sets Font Strikeout on/off.
Style |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Underline | Sets Font underline on/off.
UsePrivateFont | Sets or returns whether to include TeeChart's private fonts in the ChartFont class.

See Also

ChartFont Class | Steema.TeeChart.Drawing Namespace


Bold

Steema.TeeChart.Drawing.ChartFont.Bold Property

Sets Font bold for text.
public Boolean Bold {get; set;}

See Also

ChartFont Class | ChartFont Members | Steema.TeeChart.Drawing Namespace


Brush

Steema.TeeChart.Drawing.ChartFont.Brush Property

Sets the Brush characteristics of the font.
public ChartBrush Brush {get;}

See Also

ChartFont Class | ChartFont Members | Steema.TeeChart.Drawing Namespace


Color

Steema.TeeChart.Drawing.ChartFont.Color Property

Defines a Font colour for text.
public Color Color {get; set;}

See Also

ChartFont Class | ChartFont Members | Steema.TeeChart.Drawing Namespace


DrawingFont

Steema.TeeChart.Drawing.ChartFont.DrawingFont Property

public TextPaint DrawingFont {get; set;}

See Also

ChartFont Class | ChartFont Members | Steema.TeeChart.Drawing Namespace


Gradient

Steema.TeeChart.Drawing.ChartFont.Gradient Property

Applies a gradient fill to the font.
public Gradient Gradient {get; set;}

See Also

ChartFont Class | ChartFont Members | Steema.TeeChart.Drawing Namespace


Italic

Steema.TeeChart.Drawing.ChartFont.Italic Property

Sets Font italic (true or false) for text.
public Boolean Italic {get; set;}

See Also

ChartFont Class | ChartFont Members | Steema.TeeChart.Drawing Namespace


Name

Steema.TeeChart.Drawing.ChartFont.Name Property

Defines a Font type for text.
public String Name {get; set;}

See Also

ChartFont Class | ChartFont Members | Steema.TeeChart.Drawing Namespace


Shadow

Steema.TeeChart.Drawing.ChartFont.Shadow Property

Accesses the shadow properties of the font.
public Shadow Shadow {get;}

See Also

ChartFont Class | ChartFont Members | Steema.TeeChart.Drawing Namespace


Size

Steema.TeeChart.Drawing.ChartFont.Size Property

Sets Font sizing (in points) for text.
public Int32 Size {get; set;}

See Also

ChartFont Class | ChartFont Members | Steema.TeeChart.Drawing Namespace


SizeFloat

Steema.TeeChart.Drawing.ChartFont.SizeFloat Property

Sets Font sizing as em-size float for text to enable use of Font.Unit
public Single SizeFloat {get; set;}

See Also

ChartFont Class | ChartFont Members | Steema.TeeChart.Drawing Namespace


Strikeout

Steema.TeeChart.Drawing.ChartFont.Strikeout Property

Sets Font Strikeout on/off.
public Boolean Strikeout {get; set;}

See Also

ChartFont Class | ChartFont Members | Steema.TeeChart.Drawing Namespace


Style

Steema.TeeChart.Drawing.ChartFont.Style Property

public TypefaceStyle Style {get;}

See Also

ChartFont Class | ChartFont Members | Steema.TeeChart.Drawing Namespace


Underline

Steema.TeeChart.Drawing.ChartFont.Underline Property

Sets Font underline on/off.
public Boolean Underline {get; set;}

See Also

ChartFont Class | ChartFont Members | Steema.TeeChart.Drawing Namespace


UsePrivateFont

Steema.TeeChart.Drawing.ChartFont.UsePrivateFont Property

Sets or returns whether to include TeeChart's private fonts in the ChartFont class.
public Boolean UsePrivateFont {get; set;}

See Also

ChartFont Class | ChartFont Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartPen

Steema.TeeChart.Drawing.ChartPen Class

Common Chart Pen

For a list of all members of this type, see ChartPen Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class ChartPen : TeeBase , ICloneable

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

ChartPen members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartPenMembers

Steema.TeeChart.Drawing.ChartPen all Members

ChartPen overview

Constructors

Constructor Overloaded

Public Methods

Assign |
Clone |
CreateNewChartPen | Creates a new ChartPen object and sets the Chart property.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
NewFromType | Creates a new ChartPen from the System.Type of an existing ChartPen object.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Color | Determines the color used by the pen to draw lines on the Drawing.
DashPattern |
DashWidth |
DrawingPen | Accesses the internal Drawing.Pen object.
EndCap | Style of line endings.
Style | Determines the style in which the pen draw lines on the Drawing.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency | Sets Transparency level from 0 to 100%.
UseStyling | Set to false to make ChartPen ignore Style, DashCap, DashPattern and EndCap properties. Useful as a performance micro-optimization.
Visible | Determines if the pen will draw lines or not.
Width | Determines the width of lines the pen draws.

See Also

ChartPen Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartPen Constructor

Overload List

public ChartPen()
public ChartPen(Steema.TeeChart.Chart, System.Drawing.Color, System.Boolean)
public ChartPen(Steema.TeeChart.Chart)
public ChartPen(System.Drawing.Color)
public ChartPen(Steema.TeeChart.Chart, System.Drawing.Color)
public ChartPen(Steema.TeeChart.Chart, System.Boolean)
public ChartPen(Steema.TeeChart.Chart, System.Drawing.Color, System.Boolean, Android.Graphics.Paint+Cap)

See Also

ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartPen Constructor

public ChartPen(Chart c,
     Color startColor,
     Boolean startVisible,
     Cap cap)

See Also

ChartPen Constructor Overload List | ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartPen Constructor

public ChartPen(Chart c,
     Boolean startVisible)

See Also

ChartPen Constructor Overload List | ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartPen Constructor

public ChartPen(Chart c,
     Color startColor)

See Also

ChartPen Constructor Overload List | ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartPen Constructor

public ChartPen(Color c)

See Also

ChartPen Constructor Overload List | ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartPen Constructor

public ChartPen(Chart c)

See Also

ChartPen Constructor Overload List | ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartPen Constructor

public ChartPen(Chart c,
     Color startColor,
     Boolean startVisible)

See Also

ChartPen Constructor Overload List | ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartPen Constructor

public ChartPen()

See Also

ChartPen Constructor Overload List | ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartPenMethods

Steema.TeeChart.Drawing.ChartPen Methods

Public Methods

Assign |
Clone |
CreateNewChartPen | Creates a new ChartPen object and sets the Chart property.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
NewFromType | Creates a new ChartPen from the System.Type of an existing ChartPen object.

See Also

ChartPen Class | Steema.TeeChart.Drawing Namespace


Assign

Steema.TeeChart.Drawing.ChartPen.Assign Method

Overload List

public Void Assign(Steema.TeeChart.Drawing.ChartPen)
public Void Assign(Steema.TeeChart.Drawing.ChartPen, System.Drawing.Color)

See Also

ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


Assign

Steema.TeeChart.Drawing.ChartPen.Assign Method

public Void Assign(ChartPen p,
     Color AColor)

See Also

Assign Overload List | ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


Assign

Steema.TeeChart.Drawing.ChartPen.Assign Method

public Void Assign(ChartPen p)

See Also

Assign Overload List | ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


Clone

Steema.TeeChart.Drawing.ChartPen.Clone Method

public virtual Object Clone()

See Also

ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


CreateNewChartPen

Steema.TeeChart.Drawing.ChartPen.CreateNewChartPen Method

Creates a new ChartPen object and sets the Chart property.
public static ChartPen CreateNewChartPen(Chart chart,
     Type type)

See Also

ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


NewFromType

Steema.TeeChart.Drawing.ChartPen.NewFromType Method

Creates a new ChartPen from the System.Type of an existing ChartPen object.
public static ChartPen NewFromType(Type type,
     Chart c)

See Also

ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ChartPenProperties

Steema.TeeChart.Drawing.ChartPen Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Color | Determines the color used by the pen to draw lines on the Drawing.
DashPattern |
DashWidth |
DrawingPen | Accesses the internal Drawing.Pen object.
EndCap | Style of line endings.
Style | Determines the style in which the pen draw lines on the Drawing.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency | Sets Transparency level from 0 to 100%.
UseStyling | Set to false to make ChartPen ignore Style, DashCap, DashPattern and EndCap properties. Useful as a performance micro-optimization.
Visible | Determines if the pen will draw lines or not.
Width | Determines the width of lines the pen draws.

See Also

ChartPen Class | Steema.TeeChart.Drawing Namespace


Color

Steema.TeeChart.Drawing.ChartPen.Color Property

Determines the color used by the pen to draw lines on the Drawing.
public Color Color {get; set;}

See Also

ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


DashPattern

Steema.TeeChart.Drawing.ChartPen.DashPattern Property

public Single[] DashPattern {get; set;}

See Also

ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


DashWidth

Steema.TeeChart.Drawing.ChartPen.DashWidth Property

public Int32 DashWidth {get; set;}

See Also

ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


DrawingPen

Steema.TeeChart.Drawing.ChartPen.DrawingPen Property

Accesses the internal Drawing.Pen object.
public Paint DrawingPen {get;}

See Also

ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


EndCap

Steema.TeeChart.Drawing.ChartPen.EndCap Property

Style of line endings.
public Cap EndCap {get; set;}

See Also

ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


Style

Steema.TeeChart.Drawing.ChartPen.Style Property

Determines the style in which the pen draw lines on the Drawing.
public abstract DashStyle Style {get; set;}

See Also

ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


Transparency

Steema.TeeChart.Drawing.ChartPen.Transparency Property

Sets Transparency level from 0 to 100%.
public Int32 Transparency {get; set;}

See Also

ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


UseStyling

Steema.TeeChart.Drawing.ChartPen.UseStyling Property

Set to false to make ChartPen ignore Style, DashCap, DashPattern and EndCap properties. Useful as a performance micro-optimization.
public Boolean UseStyling {get; set;}

See Also

ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


Visible

Steema.TeeChart.Drawing.ChartPen.Visible Property

Determines if the pen will draw lines or not.
public Boolean Visible {get; set;}

See Also

ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


Width

Steema.TeeChart.Drawing.ChartPen.Width Property

Determines the width of lines the pen draws.
public abstract Int32 Width {get; set;}

See Also

ChartPen Class | ChartPen Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.DashStyle

Steema.TeeChart.Drawing.DashStyle Enum

[Serializable]
public sealed enum DashStyle : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
Solid |
Dash |
Dot |
DashDot |
DashDotDot |
Custom |

See Also

Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.EdgeStyles

Steema.TeeChart.Drawing.EdgeStyles Enum

Defines the styles of the edges between two adjacent surfaces.
[Serializable]
public sealed enum EdgeStyles : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
Flat | Flat Edges
Curved | Curved Edges
None | No special edge treament.

See Also

Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Gradient

Steema.TeeChart.Drawing.Gradient Class

Properties to configure a gradient filling.

For a list of all members of this type, see Gradient Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class Gradient : TeeBase , ICloneable

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

Gradient members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.GradientMembers

Steema.TeeChart.Drawing.Gradient all Members

Gradient overview

Constructors

Constructor Overloaded

Public Methods

Assign |
Clone |
Draw | Fills the Canvas area using the Gradient color and direction properties.
DrawingBrush | Brush to fill rectangular area rect
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Angle | Enables fine-tuning of displayed Colors.
Chart (inherited from TeeBase) | Chart associated with this object
Direction | Specifies the direction the gradient fill will be applied.
EndColor | One of the three Colors used to create the gradient fill.
EndPoint | Gets or sets the ending two-dimensional coordinates of a linear gradient. Use when UseStandardGradient is false.
MiddleColor | One of the three Colors used to create the gradient fill.
RadialCenter | Gets or sets the center of the outermost circle of a radial gradient.
RadialOrigin | Gets or sets the location of the two-dimensional focal point that defines the beginning of a radial gradient.
RadiusX | Gets or sets the horizontal radius of the outermost circle of a radial gradient.
RadiusY | Gets or sets the vertical radius of the outermost circle of a radial gradient.
StartColor | One of the three Colors used to create the gradient fill.
StartPoint | Gets or sets the starting two-dimensional coordinates of a linear gradient. Use when UseStandardGradient is false.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency | Amount of transparency in percentage.
UseMiddle | Determines whether MiddleColor is used when creating the gradient fill, or not.
UseStandardGradient | Gets or sets whether TeeChart standard gradient settings (StartPoint, EndPoint, GradientStops) are used or whether user-entered values are used.
Visible | Determines whether the gradient fill appears on screen.
WrapMode | Used to repeat fillings.

See Also

Gradient Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Gradient Constructor

Overload List

public Gradient()
public Gradient(Steema.TeeChart.Chart)

See Also

Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Gradient Constructor

public Gradient(Chart c)

See Also

Gradient Constructor Overload List | Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Gradient Constructor

public Gradient()

See Also

Gradient Constructor Overload List | Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.GradientMethods

Steema.TeeChart.Drawing.Gradient Methods

Public Methods

Assign |
Clone |
Draw | Fills the Canvas area using the Gradient color and direction properties.
DrawingBrush | Brush to fill rectangular area rect
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

See Also

Gradient Class | Steema.TeeChart.Drawing Namespace


Assign

Steema.TeeChart.Drawing.Gradient.Assign Method

public Void Assign(Gradient value)

See Also

Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


Clone

Steema.TeeChart.Drawing.Gradient.Clone Method

public virtual Object Clone()

See Also

Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Gradient.Draw Method

Overload List

Fills the Canvas area using the Gradient color and direction properties.

public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Int32, System.Int32, System.Int32, System.Int32)

Fills the Canvas area using the Gradient color and direction properties.

public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Drawing.Point[])

Fills the Canvas area using the Gradient color and direction properties.

public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Drawing.Rectangle)

See Also

Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Gradient.Draw Method

Fills the Canvas area using the Gradient color and direction properties.
public Void Draw(Graphics3D g,
     Rectangle rect)

See Also

Draw Overload List | Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Gradient.Draw Method

Fills the Canvas area using the Gradient color and direction properties.
public Void Draw(Graphics3D g,
     Point[] p)

See Also

Draw Overload List | Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Gradient.Draw Method

Fills the Canvas area using the Gradient color and direction properties.
public Void Draw(Graphics3D g,
     Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

See Also

Draw Overload List | Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


DrawingBrush

Steema.TeeChart.Drawing.Gradient.DrawingBrush Method

Overload List

Brush to fill rectangular area rect

public Paint DrawingBrush()

Uses the x,y point co-ordinate define the Brush for a 'size' square

public Paint DrawingBrush(System.Drawing.Size)

Brush to fill rectangular area rect

public Paint DrawingBrush(System.Drawing.Rectangle)

See Also

Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


DrawingBrush

Steema.TeeChart.Drawing.Gradient.DrawingBrush Method

Brush to fill rectangular area rect
public Paint DrawingBrush(Rectangle rect)

See Also

DrawingBrush Overload List | Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


DrawingBrush

Steema.TeeChart.Drawing.Gradient.DrawingBrush Method

Uses the x,y point co-ordinate define the Brush for a 'size' square
public Paint DrawingBrush(Size size)

See Also

DrawingBrush Overload List | Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


DrawingBrush

Steema.TeeChart.Drawing.Gradient.DrawingBrush Method

Brush to fill rectangular area rect
public Paint DrawingBrush()

See Also

DrawingBrush Overload List | Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.GradientProperties

Steema.TeeChart.Drawing.Gradient Properties

Public Properties

Angle | Enables fine-tuning of displayed Colors.
Chart (inherited from TeeBase) | Chart associated with this object
Direction | Specifies the direction the gradient fill will be applied.
EndColor | One of the three Colors used to create the gradient fill.
EndPoint | Gets or sets the ending two-dimensional coordinates of a linear gradient. Use when UseStandardGradient is false.
MiddleColor | One of the three Colors used to create the gradient fill.
RadialCenter | Gets or sets the center of the outermost circle of a radial gradient.
RadialOrigin | Gets or sets the location of the two-dimensional focal point that defines the beginning of a radial gradient.
RadiusX | Gets or sets the horizontal radius of the outermost circle of a radial gradient.
RadiusY | Gets or sets the vertical radius of the outermost circle of a radial gradient.
StartColor | One of the three Colors used to create the gradient fill.
StartPoint | Gets or sets the starting two-dimensional coordinates of a linear gradient. Use when UseStandardGradient is false.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency | Amount of transparency in percentage.
UseMiddle | Determines whether MiddleColor is used when creating the gradient fill, or not.
UseStandardGradient | Gets or sets whether TeeChart standard gradient settings (StartPoint, EndPoint, GradientStops) are used or whether user-entered values are used.
Visible | Determines whether the gradient fill appears on screen.
WrapMode | Used to repeat fillings.

See Also

Gradient Class | Steema.TeeChart.Drawing Namespace


Angle

Steema.TeeChart.Drawing.Gradient.Angle Property

Enables fine-tuning of displayed Colors.
public Double Angle {get; set;}

See Also

Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


Direction

Steema.TeeChart.Drawing.Gradient.Direction Property

Specifies the direction the gradient fill will be applied.
public GradientDirection Direction {get; set;}

See Also

Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


EndColor

Steema.TeeChart.Drawing.Gradient.EndColor Property

One of the three Colors used to create the gradient fill.
public Color EndColor {get; set;}

See Also

Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


EndPoint

Steema.TeeChart.Drawing.Gradient.EndPoint Property

Gets or sets the ending two-dimensional coordinates of a linear gradient. Use when UseStandardGradient is false.
public Point EndPoint {get; set;}

See Also

Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


MiddleColor

Steema.TeeChart.Drawing.Gradient.MiddleColor Property

One of the three Colors used to create the gradient fill.
public Color MiddleColor {get; set;}

See Also

Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


RadialCenter

Steema.TeeChart.Drawing.Gradient.RadialCenter Property

Gets or sets the center of the outermost circle of a radial gradient.
public Point RadialCenter {get; set;}

See Also

Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


RadialOrigin

Steema.TeeChart.Drawing.Gradient.RadialOrigin Property

Gets or sets the location of the two-dimensional focal point that defines the beginning of a radial gradient.
public Point RadialOrigin {get; set;}

See Also

Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


RadiusX

Steema.TeeChart.Drawing.Gradient.RadiusX Property

Gets or sets the horizontal radius of the outermost circle of a radial gradient.
public Double RadiusX {get; set;}

See Also

Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


RadiusY

Steema.TeeChart.Drawing.Gradient.RadiusY Property

Gets or sets the vertical radius of the outermost circle of a radial gradient.
public Double RadiusY {get; set;}

See Also

Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


StartColor

Steema.TeeChart.Drawing.Gradient.StartColor Property

One of the three Colors used to create the gradient fill.
public Color StartColor {get; set;}

See Also

Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


StartPoint

Steema.TeeChart.Drawing.Gradient.StartPoint Property

Gets or sets the starting two-dimensional coordinates of a linear gradient. Use when UseStandardGradient is false.
public Point StartPoint {get; set;}

See Also

Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


Transparency

Steema.TeeChart.Drawing.Gradient.Transparency Property

Amount of transparency in percentage.
public Int32 Transparency {get; set;}

See Also

Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


UseMiddle

Steema.TeeChart.Drawing.Gradient.UseMiddle Property

Determines whether MiddleColor is used when creating the gradient fill, or not.
public Boolean UseMiddle {get; set;}

See Also

Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


UseStandardGradient

Steema.TeeChart.Drawing.Gradient.UseStandardGradient Property

Gets or sets whether TeeChart standard gradient settings (StartPoint, EndPoint, GradientStops) are used or whether user-entered values are used.
public Boolean UseStandardGradient {get; set;}

See Also

Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


Visible

Steema.TeeChart.Drawing.Gradient.Visible Property

Determines whether the gradient fill appears on screen.
public Boolean Visible {get; set;}

See Also

Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


WrapMode

Steema.TeeChart.Drawing.Gradient.WrapMode Property

Used to repeat fillings.
public TileMode WrapMode {get; set;}

See Also

Gradient Class | Gradient Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.GradientDirection

Steema.TeeChart.Drawing.GradientDirection Enum

[Serializable]
public sealed enum GradientDirection : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
TopBottom |
BottomTop |
LeftRight |
RightLeft |
FromTopLeft |
FromBottomLeft |
Radial |
DiagonalUp |
DiagonalDown |

See Also

Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.GradientStyle

Steema.TeeChart.Drawing.GradientStyle Class

For a list of all members of this type, see GradientStyle Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class GradientStyle : TeeBase , ICloneable

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

GradientStyle members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.GradientStyleMembers

Steema.TeeChart.Drawing.GradientStyle all Members

GradientStyle overview

Constructors

Constructor Overloaded

Public Methods

Clone |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

Public Properties

CenterXOffset | The X pixel offset from the center of the non-linear gradient.
CenterYOffset | The Y pixel offset from the center of the non-linear gradient.
Chart (inherited from TeeBase) | Chart associated with this object
Direction | Specifies the direction the non-linear gradient fill will be applied.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Visible | When true, applies the specified non-linear gradient style.

See Also

GradientStyle Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.GradientStyle Constructor

Overload List

public GradientStyle()
public GradientStyle(Steema.TeeChart.Chart)

See Also

GradientStyle Class | GradientStyle Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.GradientStyle Constructor

public GradientStyle(Chart c)

See Also

GradientStyle Constructor Overload List | GradientStyle Class | GradientStyle Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.GradientStyle Constructor

public GradientStyle()

See Also

GradientStyle Constructor Overload List | GradientStyle Class | GradientStyle Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.GradientStyleMethods

Steema.TeeChart.Drawing.GradientStyle Methods

Public Methods

Clone |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

See Also

GradientStyle Class | Steema.TeeChart.Drawing Namespace


Clone

Steema.TeeChart.Drawing.GradientStyle.Clone Method

public virtual Object Clone()

See Also

GradientStyle Class | GradientStyle Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.GradientStyleProperties

Steema.TeeChart.Drawing.GradientStyle Properties

Public Properties

CenterXOffset | The X pixel offset from the center of the non-linear gradient.
CenterYOffset | The Y pixel offset from the center of the non-linear gradient.
Chart (inherited from TeeBase) | Chart associated with this object
Direction | Specifies the direction the non-linear gradient fill will be applied.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Visible | When true, applies the specified non-linear gradient style.

See Also

GradientStyle Class | Steema.TeeChart.Drawing Namespace


CenterXOffset

Steema.TeeChart.Drawing.GradientStyle.CenterXOffset Property

The X pixel offset from the center of the non-linear gradient.
public Int32 CenterXOffset {get; set;}

See Also

GradientStyle Class | GradientStyle Members | Steema.TeeChart.Drawing Namespace


CenterYOffset

Steema.TeeChart.Drawing.GradientStyle.CenterYOffset Property

The Y pixel offset from the center of the non-linear gradient.
public Int32 CenterYOffset {get; set;}

See Also

GradientStyle Class | GradientStyle Members | Steema.TeeChart.Drawing Namespace


Direction

Steema.TeeChart.Drawing.GradientStyle.Direction Property

Specifies the direction the non-linear gradient fill will be applied.
public PathGradientMode Direction {get; set;}

See Also

GradientStyle Class | GradientStyle Members | Steema.TeeChart.Drawing Namespace


Visible

Steema.TeeChart.Drawing.GradientStyle.Visible Property

When true, applies the specified non-linear gradient style.
public Boolean Visible {get; set;}

See Also

GradientStyle Class | GradientStyle Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Graphics3D

Steema.TeeChart.Drawing.Graphics3D Class

For a list of all members of this type, see Graphics3D Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public abstract class Graphics3D : TeeBase

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

Graphics3D members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Graphics3DMembers

Steema.TeeChart.Drawing.Graphics3D all Members

Graphics3D overview

Constructors

Constructor

Public Fields

FourPoints
IPointDoubles
Monochrome
NumCylinderSides
PiStep

Public Methods

ApplyBright | Converts the Color parameter to a brighter color.
ApplyDark | Converts the Color parameter to a darker color.
Arc |
Arrow |
Calc3DPoint |
Calc3DPos | Calculates and returns the XY position in pixels of the point p, XYZ 3D coordinate.
CalcRect3D | Calculates and returns the position in pixels of the Rectangle 3D coordinates.
Calculate2DPosition | Calculates and returns the XY position in pixels of the coordinate.
Calculate3DPosition | Calculates and returns the XY position in pixels of the XYZ 3D coordinate.
Changed |
ClearClipRegions |
ClipCube | Creates a cubic Windows GDI clipping region.
ClipEllipse |
ClipPolygon |
ClipRectangle | Creates a Windows GDI clipping region and selects it into TChart.Canvas device context handle.
Cone | Paints a cone. Use ONLY with OPENGL.
ConvexHull | Calculates the boundary points of the convex hull of a set of 2D xy points. Original
CrossingLines | Returns true if two lines cross.
Cube | Draws a Cube.
Cylinder | Draws cylinder toggle Boolean for vertical or horizontal cylinder.
DisableRotation |
Draw | Paints the image in rectangle r.
DrawBeziers | Draws Bézier splines for the Point array p at displacement z
DrawPath | Draws a GraphicsPath.
Elevate |
Ellipse | Ellipse bounding rectangle (Left, Top, Right, Bottom) with Z offset at angle.
EnableRotation |
EndBlending | Supports OpenGL Transparency
EraseBackground |
FillRectangle |
FillRegion |
FontTextHeight | Determines the Font Height to be used for outputted text when using the Drawing.
FourPointsFromRect | Returns a TFourPoints structure (array of four TPoint records)
Frame3D |
FrontPlaneBegin |
FrontPlaneEnd |
GetArrowPoints |
GetChartPolygon | Returns a z-shifted Region from a Rectangle.
GetClipRoundRectangle | Returns a PointDouble array which contains a Rounded Rectangle.
HorizCone | Paints a cone. Use ONLY with OPENGL.
HorizontalLine | Draws a Horizontal at z depth position.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Line |
LineTo |
LineWithZ |
MeasureString | Returns the SizeF of a string of a specified font.
MoveTo | Sets the value of PenPos to x and y co-ordinates before calling LineTo.
OrientRectangle | Makes sure the R rectangle Left is smaller than Right and Top is smaller than Bottom. Returns corrected rectangle.
PaintBevel |
PaintImageBevel | Draws a custom border around a specified Rectangle.
Pie | Draws a Pie slice.
Pixel |
Plane | Draws a polygon (Point p1, Point p2, Point p3, Point p4) at Z depth offset.
PlaneFour3D | Draws a polygon of four points.
PointAtDistance | Returns point "To" minus "distance" pixels from "From" point.
PointFromCircle | Returns the PointDouble which is on the circle bounded by rectBounds at the angle degrees.
PointFromEllipse | Returns the PointDouble which is on the ellipse bounded by rectBounds at the angle degrees.
PointFromSpiral |
PointInEllipse | Returns true if point P is inside the ellipse bounded by Left, Top, Right, Bottom.
PointInHorizTriangle | Returns true if point P is inside the horizontal triangle.
PointInLine |
PointInLineTolerance | Determines if point T is "near" line segment between Point1 and Point2.
PointInPolygon |
PointInRect |
PointInTriangle | Returns true if point P is inside the vert triangle of p0, p1, p2.
Polygon | Draws a polygon with z position offset.
PolygonBounds | Returns the minimum left / top and the maximum right / bottom for all the points in "p" polygon
PolygonFourDouble |
PolygonPointBounds | Returns a parallelogram of upper-left, upper-right, and lower-left corners.
PolygonRect | Returns bounding rectangle for point array p
Polyline |
PopMatrix |
PrepareDrawImage | Prepares the Chart Canvas for drawing.
Projection | Internal use. Calculates the projection co-ordinates for rectangle Bounds
PushMatrix |
Pyramid | Draws a vertical or horizontal Pyramid with optional dark shaded sides.
PyramidTrunc | Draws a pyramid with a truncated apex of variable thickness.
Rectangle | Draws a rectangle between the defined co-ordinates.
RectangleF |
RectangleWithZ |
RectangleY | Horizontal Rectangle from Left to Right, from Z0 to Z1 position, at Top Y.
RectangleZ | Horizontal Rectangle from Left to Right, from Z0 to Z1 position, at Top Y.
RectCenter |
RectFromPolygon | Returns the bounding rectangle for a given array of XY points.
RectFromRectZ | Returns the smallest bounding rectangle containing the four corners of the "R" rectangle after calculating their 3D position.
Rotate |
RotateLabel | Draws a rotated text string at the specified x,y and z coordinates with the RotDegree rotation angle.
RotateRectangle |
RoundRectangle |
SetClipRegion |
SetTextAlign |
ShowImage |
SmoothShadow |
Sphere | Draws a sphere.
StartBlending | Supports OpenGL Transparency
Surface3D |
TeeCull |
TextHeight | Returns the vertical text size in pixels of ChartFont f.
TextOut | Displays 2D non-rotated label at the specified x and y screen coordinates.
TextWidth | Returns the horizontal text size in pixels of ChartFont f.
Translate |
Transparency | Returns percentage based on Color "A" value.
TransparentColor | Returns Color parameter after changing its "A" value.
Triangle | Draws a triangle (point p0, pointp1, pointp2) at Z position.
TriSurface |
UnClip |
UnClipRectangle | Removes any clipping region applied to Chart Drawing.
ValidState | Returns true if the Chart Canvas can be drawn to.
VerticalLine |
ZLine | Draws a Line from (X,Y,Z0) to (X,Y,Z1).

Public Properties

BackColor | Sets / returns the color used to fill spaces when displaying text or filling with brushes of different style than bsSolid.
Brush | Determines Brush used to fill the Canvas draw rectangle background.
BufferStyle | Draws items to an internal canvas to prevent flickering on screen.
CanvasType | Gets the type of canvas used to draw the chart.
Chart (inherited from TeeBase) | Chart associated with this object
ChartXCenter | Returns the centre Horizontal co-ordinate of the Chart.
ChartYCenter | Returns the middle Vertical coordinate of the Chart.
Font | Determines Font for outputted text when using the Drawing.
FontHeight | Defines the Height of the Font in pixels.
GDIplusCanvas |
Gradient | Gets and sets the Brush.Gradient properties of the Canvas.
Pen | Indicates the kind of pen used to draw Canvas lines.
RotationCenter | Sets the Pixel location (using X,Y,Z) of the centre of rotation for use with the Aspect.Rotation property.
RotationCenterFloat | Sets the Pixel location (using X,Y,Z) of the centre of rotation for use with the Aspect.Rotation property.
ScreenHeight | Returns the height, in pixels, of the Chart Panel .
ScreenWidth | Returns the width, in pixels, of the Chart Panel.
Supports3DText | Returns if Canvas supports 3D Text or not.
SupportsFullRotation | Returns if Canvas can do rotation and elevation of more than 90 degree.
SupportsID | Gets and sets whether each TeeChart element drawn is assigned a unique ID.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TextAlign | Sets the alignment used when displaying text using TextOut or TextOut3D.
UseBuffer | Draws items to an internal canvas to prevent flickering on screen.
XCenter | Obtain the X coordinate of the pixel location of the center of the 3D Canvas.
YCenter | Obtain the Y coordinate of the pixel location of the center of the 3D Canvas.

See Also

Graphics3D Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Graphics3D Constructor

public Graphics3D(Chart c)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Graphics3DFields

Steema.TeeChart.Drawing.Graphics3D Fields

Public Fields

FourPoints
IPointDoubles
Monochrome
NumCylinderSides
PiStep

See Also

Graphics3D Class | Steema.TeeChart.Drawing Namespace


FourPoints

Steema.TeeChart.Drawing.Graphics3D.FourPoints Field

public Point[] FourPoints

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


IPointDoubles

Steema.TeeChart.Drawing.Graphics3D.IPointDoubles Field

public PointDouble[] IPointDoubles

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Monochrome

Steema.TeeChart.Drawing.Graphics3D.Monochrome Field

public Boolean Monochrome

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


NumCylinderSides

Steema.TeeChart.Drawing.Graphics3D.NumCylinderSides Field

public Int32 NumCylinderSides

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PiStep

Steema.TeeChart.Drawing.Graphics3D.PiStep Field

public const Double PiStep

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Graphics3DMethods

Steema.TeeChart.Drawing.Graphics3D Methods

Public Methods

ApplyBright | Converts the Color parameter to a brighter color.
ApplyDark | Converts the Color parameter to a darker color.
Arc |
Arrow |
Calc3DPoint |
Calc3DPos | Calculates and returns the XY position in pixels of the point p, XYZ 3D coordinate.
CalcRect3D | Calculates and returns the position in pixels of the Rectangle 3D coordinates.
Calculate2DPosition | Calculates and returns the XY position in pixels of the coordinate.
Calculate3DPosition | Calculates and returns the XY position in pixels of the XYZ 3D coordinate.
Changed |
ClearClipRegions |
ClipCube | Creates a cubic Windows GDI clipping region.
ClipEllipse |
ClipPolygon |
ClipRectangle | Creates a Windows GDI clipping region and selects it into TChart.Canvas device context handle.
Cone | Paints a cone. Use ONLY with OPENGL.
ConvexHull | Calculates the boundary points of the convex hull of a set of 2D xy points. Original
CrossingLines | Returns true if two lines cross.
Cube | Draws a Cube.
Cylinder | Draws cylinder toggle Boolean for vertical or horizontal cylinder.
DisableRotation |
Draw | Paints the image in rectangle r.
DrawBeziers | Draws Bézier splines for the Point array p at displacement z
DrawPath | Draws a GraphicsPath.
Elevate |
Ellipse | Ellipse bounding rectangle (Left, Top, Right, Bottom) with Z offset at angle.
EnableRotation |
EndBlending | Supports OpenGL Transparency
EraseBackground |
FillRectangle |
FillRegion |
FontTextHeight | Determines the Font Height to be used for outputted text when using the Drawing.
FourPointsFromRect | Returns a TFourPoints structure (array of four TPoint records)
Frame3D |
FrontPlaneBegin |
FrontPlaneEnd |
GetArrowPoints |
GetChartPolygon | Returns a z-shifted Region from a Rectangle.
GetClipRoundRectangle | Returns a PointDouble array which contains a Rounded Rectangle.
HorizCone | Paints a cone. Use ONLY with OPENGL.
HorizontalLine | Draws a Horizontal at z depth position.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Line |
LineTo |
LineWithZ |
MeasureString | Returns the SizeF of a string of a specified font.
MoveTo | Sets the value of PenPos to x and y co-ordinates before calling LineTo.
OrientRectangle | Makes sure the R rectangle Left is smaller than Right and Top is smaller than Bottom. Returns corrected rectangle.
PaintBevel |
PaintImageBevel | Draws a custom border around a specified Rectangle.
Pie | Draws a Pie slice.
Pixel |
Plane | Draws a polygon (Point p1, Point p2, Point p3, Point p4) at Z depth offset.
PlaneFour3D | Draws a polygon of four points.
PointAtDistance | Returns point "To" minus "distance" pixels from "From" point.
PointFromCircle | Returns the PointDouble which is on the circle bounded by rectBounds at the angle degrees.
PointFromEllipse | Returns the PointDouble which is on the ellipse bounded by rectBounds at the angle degrees.
PointFromSpiral |
PointInEllipse | Returns true if point P is inside the ellipse bounded by Left, Top, Right, Bottom.
PointInHorizTriangle | Returns true if point P is inside the horizontal triangle.
PointInLine |
PointInLineTolerance | Determines if point T is "near" line segment between Point1 and Point2.
PointInPolygon |
PointInRect |
PointInTriangle | Returns true if point P is inside the vert triangle of p0, p1, p2.
Polygon | Draws a polygon with z position offset.
PolygonBounds | Returns the minimum left / top and the maximum right / bottom for all the points in "p" polygon
PolygonFourDouble |
PolygonPointBounds | Returns a parallelogram of upper-left, upper-right, and lower-left corners.
PolygonRect | Returns bounding rectangle for point array p
Polyline |
PopMatrix |
PrepareDrawImage | Prepares the Chart Canvas for drawing.
Projection | Internal use. Calculates the projection co-ordinates for rectangle Bounds
PushMatrix |
Pyramid | Draws a vertical or horizontal Pyramid with optional dark shaded sides.
PyramidTrunc | Draws a pyramid with a truncated apex of variable thickness.
Rectangle | Draws a rectangle between the defined co-ordinates.
RectangleF |
RectangleWithZ |
RectangleY | Horizontal Rectangle from Left to Right, from Z0 to Z1 position, at Top Y.
RectangleZ | Horizontal Rectangle from Left to Right, from Z0 to Z1 position, at Top Y.
RectCenter |
RectFromPolygon | Returns the bounding rectangle for a given array of XY points.
RectFromRectZ | Returns the smallest bounding rectangle containing the four corners of the "R" rectangle after calculating their 3D position.
Rotate |
RotateLabel | Draws a rotated text string at the specified x,y and z coordinates with the RotDegree rotation angle.
RotateRectangle |
RoundRectangle |
SetClipRegion |
SetTextAlign |
ShowImage |
SmoothShadow |
Sphere | Draws a sphere.
StartBlending | Supports OpenGL Transparency
Surface3D |
TeeCull |
TextHeight | Returns the vertical text size in pixels of ChartFont f.
TextOut | Displays 2D non-rotated label at the specified x and y screen coordinates.
TextWidth | Returns the horizontal text size in pixels of ChartFont f.
Translate |
Transparency | Returns percentage based on Color "A" value.
TransparentColor | Returns Color parameter after changing its "A" value.
Triangle | Draws a triangle (point p0, pointp1, pointp2) at Z position.
TriSurface |
UnClip |
UnClipRectangle | Removes any clipping region applied to Chart Drawing.
ValidState | Returns true if the Chart Canvas can be drawn to.
VerticalLine |
ZLine | Draws a Line from (X,Y,Z0) to (X,Y,Z1).

See Also

Graphics3D Class | Steema.TeeChart.Drawing Namespace


ApplyBright

Steema.TeeChart.Drawing.Graphics3D.ApplyBright Method

Converts the Color parameter to a brighter color.
public static Void ApplyBright(Color& c,
     Byte howMuch)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


ApplyDark

Steema.TeeChart.Drawing.Graphics3D.ApplyDark Method

Converts the Color parameter to a darker color.
public static Void ApplyDark(Color& c,
     Byte howMuch)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Arc

Steema.TeeChart.Drawing.Graphics3D.Arc Method

Overload List

public abstract Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Single, System.Single)
public Void Arc(System.Drawing.Rectangle, System.Single, System.Single)

Draws an arc in the rectangle defined by the 4 co-ordinates.

public abstract Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Arc

Steema.TeeChart.Drawing.Graphics3D.Arc Method

Draws an arc in the rectangle defined by the 4 co-ordinates.
public abstract Void Arc(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 x3,
     Int32 y3,
     Int32 x4,
     Int32 y4)

See Also

Arc Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Arc

Steema.TeeChart.Drawing.Graphics3D.Arc Method

public Void Arc(Rectangle rect,
     Single startAngle,
     Single sweepAngle)

See Also

Arc Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Arc

Steema.TeeChart.Drawing.Graphics3D.Arc Method

public abstract Void Arc(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Single startAngle,
     Single sweepAngle)

See Also

Arc Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Arrow

Steema.TeeChart.Drawing.Graphics3D.Arrow Method

Overload List

public abstract Void Arrow(System.Boolean, System.Drawing.Point, System.Drawing.Point, System.Int32, System.Int32, System.Int32, System.Double)

Draws a line with an arrow head of ArrowWidth and ArrowHeight dimensions in pixels.

public abstract Void Arrow(System.Boolean, System.Drawing.Point, System.Drawing.Point, System.Int32, System.Int32, System.Int32)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Arrow

Steema.TeeChart.Drawing.Graphics3D.Arrow Method

Draws a line with an arrow head of ArrowWidth and ArrowHeight dimensions in pixels.
public abstract Void Arrow(Boolean Filled,
     Point FromPoint,
     Point ToPoint,
     Int32 ArrowWidth,
     Int32 ArrowHeight,
     Int32 Z)

See Also

Arrow Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Arrow

Steema.TeeChart.Drawing.Graphics3D.Arrow Method

public abstract Void Arrow(Boolean Filled,
     Point FromPoint,
     Point ToPoint,
     Int32 ArrowWidth,
     Int32 ArrowHeight,
     Int32 Z,
     Double ArrowPercent)

See Also

Arrow Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Calc3DPoint

Steema.TeeChart.Drawing.Graphics3D.Calc3DPoint Method

Overload List

public Point Calc3DPoint(Steema.TeeChart.Drawing.Point3D)
public Point Calc3DPoint(System.Int32, System.Int32, System.Int32)
public PointDouble Calc3DPoint(Steema.TeeChart.Drawing.PointDouble, System.Double)
public Point Calc3DPoint(System.Drawing.Point, System.Int32)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Calc3DPoint

Steema.TeeChart.Drawing.Graphics3D.Calc3DPoint Method

public Point Calc3DPoint(Point p,
     Int32 z)

See Also

Calc3DPoint Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Calc3DPoint

Steema.TeeChart.Drawing.Graphics3D.Calc3DPoint Method

public PointDouble Calc3DPoint(PointDouble p,
     Double z)

See Also

Calc3DPoint Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Calc3DPoint

Steema.TeeChart.Drawing.Graphics3D.Calc3DPoint Method

public Point Calc3DPoint(Int32 x,
     Int32 y,
     Int32 z)

See Also

Calc3DPoint Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Calc3DPoint

Steema.TeeChart.Drawing.Graphics3D.Calc3DPoint Method

public Point Calc3DPoint(Point3D p)

See Also

Calc3DPoint Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Calc3DPos

Steema.TeeChart.Drawing.Graphics3D.Calc3DPos Method

Overload List

Calculates and returns the XY position in pixels of the point p, XYZ 3D coordinate.

public abstract Void Calc3DPos(System.Drawing.Point&, System.Int32, System.Int32, System.Int32)
public abstract Void Calc3DPos(Steema.TeeChart.Drawing.PointDouble&, System.Double, System.Double, System.Double)

Calculates and returns the XY position in pixels of the point p Z 3D coordinate.

public Void Calc3DPos(System.Drawing.Point&, System.Drawing.Point, System.Int32)
public Void Calc3DPos(Steema.TeeChart.Drawing.PointDouble&, Steema.TeeChart.Drawing.PointDouble, System.Double)

Calculates and returns the XY position in pixels of the XYZ 3D coordinate.

public Void Calc3DPos(System.Int32&, System.Int32&, System.Int32)
public Void Calc3DPos(System.Single&, System.Single&, System.Int32)
public Void Calc3DPos(System.Double&, System.Double&, System.Double)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Calc3DPos

Steema.TeeChart.Drawing.Graphics3D.Calc3DPos Method

public Void Calc3DPos(Double& x,
     Double& y,
     Double z)

See Also

Calc3DPos Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Calc3DPos

Steema.TeeChart.Drawing.Graphics3D.Calc3DPos Method

public Void Calc3DPos(Single& x,
     Single& y,
     Int32 z)

See Also

Calc3DPos Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Calc3DPos

Steema.TeeChart.Drawing.Graphics3D.Calc3DPos Method

Calculates and returns the XY position in pixels of the XYZ 3D coordinate.
public Void Calc3DPos(Int32& x,
     Int32& y,
     Int32 z)

See Also

Calc3DPos Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Calc3DPos

Steema.TeeChart.Drawing.Graphics3D.Calc3DPos Method

public Void Calc3DPos(PointDouble& p,
     PointDouble source,
     Double z)

See Also

Calc3DPos Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Calc3DPos

Steema.TeeChart.Drawing.Graphics3D.Calc3DPos Method

Calculates and returns the XY position in pixels of the point p Z 3D coordinate.
public Void Calc3DPos(Point& p,
     Point source,
     Int32 z)

See Also

Calc3DPos Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Calc3DPos

Steema.TeeChart.Drawing.Graphics3D.Calc3DPos Method

public abstract Void Calc3DPos(PointDouble& p,
     Double x,
     Double y,
     Double z)

See Also

Calc3DPos Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Calc3DPos

Steema.TeeChart.Drawing.Graphics3D.Calc3DPos Method

Calculates and returns the XY position in pixels of the point p, XYZ 3D coordinate.
public abstract Void Calc3DPos(Point& p,
     Int32 x,
     Int32 y,
     Int32 z)

See Also

Calc3DPos Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


CalcRect3D

Steema.TeeChart.Drawing.Graphics3D.CalcRect3D Method

Overload List

Calculates and returns the position in pixels of the Rectangle 3D coordinates.

public RectangleF CalcRect3D(System.Drawing.RectangleF, System.Int32)

Calculates and returns the position in pixels of the Rectangle 3D coordinates.

public Rectangle CalcRect3D(System.Drawing.Rectangle, System.Int32)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


CalcRect3D

Steema.TeeChart.Drawing.Graphics3D.CalcRect3D Method

Calculates and returns the position in pixels of the Rectangle 3D coordinates.
public Rectangle CalcRect3D(Rectangle r,
     Int32 z)

See Also

CalcRect3D Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


CalcRect3D

Steema.TeeChart.Drawing.Graphics3D.CalcRect3D Method

Calculates and returns the position in pixels of the Rectangle 3D coordinates.
public RectangleF CalcRect3D(RectangleF r,
     Int32 z)

See Also

CalcRect3D Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Calculate2DPosition

Steema.TeeChart.Drawing.Graphics3D.Calculate2DPosition Method

Calculates and returns the XY position in pixels of the coordinate.
public abstract Void Calculate2DPosition(Int32& x,
     Int32& y,
     Int32 z)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Calculate3DPosition

Steema.TeeChart.Drawing.Graphics3D.Calculate3DPosition Method

Overload List

Calculates and returns the XY position in pixels of the XYZ 3D coordinate.

public Point Calculate3DPosition(System.Drawing.Point, System.Int32)

Calculates and returns the XY position in pixels of the XYZ 3D coordinate.

public Point Calculate3DPosition(Steema.TeeChart.Drawing.Point3D)

Calculates and returns the XY position in pixels of the XYZ 3D coordinate.

public abstract Point Calculate3DPosition(System.Int32, System.Int32, System.Int32)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Calculate3DPosition

Steema.TeeChart.Drawing.Graphics3D.Calculate3DPosition Method

Calculates and returns the XY position in pixels of the XYZ 3D coordinate.
public abstract Point Calculate3DPosition(Int32 x,
     Int32 y,
     Int32 z)

See Also

Calculate3DPosition Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Calculate3DPosition

Steema.TeeChart.Drawing.Graphics3D.Calculate3DPosition Method

Calculates and returns the XY position in pixels of the XYZ 3D coordinate.
public Point Calculate3DPosition(Point3D P)

See Also

Calculate3DPosition Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Calculate3DPosition

Steema.TeeChart.Drawing.Graphics3D.Calculate3DPosition Method

Calculates and returns the XY position in pixels of the XYZ 3D coordinate.
public Point Calculate3DPosition(Point P,
     Int32 z)

See Also

Calculate3DPosition Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Changed

Steema.TeeChart.Drawing.Graphics3D.Changed Method

public abstract Void Changed(Object o)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


ClearClipRegions

Steema.TeeChart.Drawing.Graphics3D.ClearClipRegions Method

public abstract Void ClearClipRegions()

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


ClipCube

Steema.TeeChart.Drawing.Graphics3D.ClipCube Method

Creates a cubic Windows GDI clipping region.
public abstract Void ClipCube(Rectangle rect,
     Int32 minZ,
     Int32 maxZ)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


ClipEllipse

Steema.TeeChart.Drawing.Graphics3D.ClipEllipse Method

public abstract Void ClipEllipse(Rectangle r)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


ClipPolygon

Steema.TeeChart.Drawing.Graphics3D.ClipPolygon Method

public abstract Void ClipPolygon(Point[] p)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


ClipRectangle

Steema.TeeChart.Drawing.Graphics3D.ClipRectangle Method

Overload List

Creates a Windows GDI clipping region and selects it into TChart.Canvas device context handle.

public Void ClipRectangle(System.Int32, System.Int32, System.Int32, System.Int32)
public abstract Void ClipRectangle(System.Drawing.Rectangle)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


ClipRectangle

Steema.TeeChart.Drawing.Graphics3D.ClipRectangle Method

public abstract Void ClipRectangle(Rectangle r)

See Also

ClipRectangle Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


ClipRectangle

Steema.TeeChart.Drawing.Graphics3D.ClipRectangle Method

Creates a Windows GDI clipping region and selects it into TChart.Canvas device context handle.
public Void ClipRectangle(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

See Also

ClipRectangle Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Cone

Steema.TeeChart.Drawing.Graphics3D.Cone Method

Overload List

Paints a cone. Use ONLY with OPENGL.

public Void Cone(System.Boolean, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Boolean)

Paints a cone. Use ONLY with OPENGL.

public Void Cone(System.Boolean, System.Drawing.Rectangle, System.Int32, System.Int32, System.Boolean)

Paints a cone with Cone Percent . Use ONLY with OPENGL.

public abstract Void Cone(System.Boolean, System.Drawing.Rectangle, System.Int32, System.Int32, System.Boolean, System.Int32)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Cone

Steema.TeeChart.Drawing.Graphics3D.Cone Method

Paints a cone with Cone Percent . Use ONLY with OPENGL.
public abstract Void Cone(Boolean vertical,
     Rectangle r,
     Int32 z0,
     Int32 z1,
     Boolean darkSides,
     Int32 conePercent)

See Also

Cone Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Cone

Steema.TeeChart.Drawing.Graphics3D.Cone Method

Paints a cone. Use ONLY with OPENGL.
public Void Cone(Boolean vertical,
     Rectangle r,
     Int32 z0,
     Int32 z1,
     Boolean darkSides)

See Also

Cone Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Cone

Steema.TeeChart.Drawing.Graphics3D.Cone Method

Paints a cone. Use ONLY with OPENGL.
public Void Cone(Boolean vertical,
     Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom,
     Int32 z0,
     Int32 z1,
     Boolean darkSides)

See Also

Cone Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


ConvexHull

Steema.TeeChart.Drawing.Graphics3D.ConvexHull Method

Calculates the boundary points of the convex hull of a set of 2D xy points. Original
public Boolean ConvexHull(Point[]& p,
     Int32& size)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


CrossingLines

Steema.TeeChart.Drawing.Graphics3D.CrossingLines Method

Returns true if two lines cross.
public static Boolean CrossingLines(Double x1,
     Double y1,
     Double x2,
     Double y2,
     Double x3,
     Double y3,
     Double x4,
     Double y4,
     Double& x,
     Double& y)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Cube

Steema.TeeChart.Drawing.Graphics3D.Cube Method

Overload List

Draws a Cube.

public Void Cube(System.Drawing.Rectangle, System.Int32, System.Int32)

Draws a Cube with Dark Sides.

public Void Cube(System.Drawing.Rectangle, System.Int32, System.Int32, System.Boolean)

Draws a Cube with Dark Sides.

public abstract Void Cube(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Boolean)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Cube

Steema.TeeChart.Drawing.Graphics3D.Cube Method

Draws a Cube with Dark Sides.
public abstract Void Cube(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom,
     Int32 z0,
     Int32 z1,
     Boolean darkSides)

See Also

Cube Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Cube

Steema.TeeChart.Drawing.Graphics3D.Cube Method

Draws a Cube with Dark Sides.
public Void Cube(Rectangle r,
     Int32 z0,
     Int32 z1,
     Boolean darkSides)

See Also

Cube Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Cube

Steema.TeeChart.Drawing.Graphics3D.Cube Method

Draws a Cube.
public Void Cube(Rectangle r,
     Int32 z0,
     Int32 z1)

See Also

Cube Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Cylinder

Steema.TeeChart.Drawing.Graphics3D.Cylinder Method

Draws cylinder toggle Boolean for vertical or horizontal cylinder.
public abstract Void Cylinder(Boolean vertical,
     Rectangle r,
     Int32 z0,
     Int32 z1,
     Boolean darkSides)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


DisableRotation

Steema.TeeChart.Drawing.Graphics3D.DisableRotation Method

public abstract Void DisableRotation()

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Graphics3D.Draw Method

Overload List

Paints the image in rectangle r.

public abstract Void Draw(System.Drawing.Rectangle, Android.Graphics.Bitmap, Steema.TeeChart.Drawing.ImageMode, System.Boolean)
public abstract Void Draw(System.Int32, System.Int32, Android.Graphics.Bitmap)
public abstract Void Draw(System.Drawing.Rectangle, Android.Graphics.Bitmap, System.Boolean)
public abstract Void Draw(System.Drawing.Rectangle, System.Drawing.Rectangle, Android.Graphics.Bitmap, System.Boolean)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Graphics3D.Draw Method

public abstract Void Draw(Rectangle destRect,
     Rectangle srcRect,
     Bitmap image,
     Boolean transparent)

See Also

Draw Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Graphics3D.Draw Method

public abstract Void Draw(Rectangle r,
     Bitmap image,
     Boolean transparent)

See Also

Draw Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Graphics3D.Draw Method

public abstract Void Draw(Int32 x,
     Int32 y,
     Bitmap image)

See Also

Draw Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Graphics3D.Draw Method

Paints the image in rectangle r.
public abstract Void Draw(Rectangle r,
     Bitmap image,
     ImageMode mode,
     Boolean transparent)

See Also

Draw Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


DrawBeziers

Steema.TeeChart.Drawing.Graphics3D.DrawBeziers Method

Overload List

Draws Bézier splines for the Point array p at displacement z

public abstract Void DrawBeziers(System.Int32, System.Drawing.Point[])

Draws Bézier splines for the Point array p

public abstract Void DrawBeziers(System.Drawing.Point[])

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


DrawBeziers

Steema.TeeChart.Drawing.Graphics3D.DrawBeziers Method

Draws Bézier splines for the Point array p
public abstract Void DrawBeziers(Point[] p)

See Also

DrawBeziers Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


DrawBeziers

Steema.TeeChart.Drawing.Graphics3D.DrawBeziers Method

Draws Bézier splines for the Point array p at displacement z
public abstract Void DrawBeziers(Int32 z,
     Point[] p)

See Also

DrawBeziers Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


DrawPath

Steema.TeeChart.Drawing.Graphics3D.DrawPath Method

Draws a GraphicsPath.
public abstract Void DrawPath(Paint pen,
     Path path)

Parameters

pen
Pen that determines the color, width, and style of the path.
path
GraphicsPath to draw.

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Elevate

Steema.TeeChart.Drawing.Graphics3D.Elevate Method

public abstract Void Elevate(Int32 angle)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Ellipse

Steema.TeeChart.Drawing.Graphics3D.Ellipse Method

Overload List

Ellipse bounding rectangle (Left, Top, Right, Bottom) with Z offset at angle.

public Void Ellipse(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Double)

Ellipse bounding Rectangle r.

public Void Ellipse(System.Drawing.Rectangle)

Ellipse bounding Rectangle at z depth.

public Void Ellipse(System.Drawing.Rectangle, System.Int32)

Ellipse bounding Rect (X1,Y1,X2,Y2) at Z position.

public abstract Void Ellipse(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

Ellipse bounding rectangle r with Z offset at angle.

public Void Ellipse(System.Drawing.Rectangle, System.Int32, System.Double)
public abstract Void Ellipse(System.Int32, System.Int32, System.Int32, System.Int32)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Ellipse

Steema.TeeChart.Drawing.Graphics3D.Ellipse Method

public abstract Void Ellipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

See Also

Ellipse Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Ellipse

Steema.TeeChart.Drawing.Graphics3D.Ellipse Method

Ellipse bounding rectangle r with Z offset at angle.
public Void Ellipse(Rectangle r,
     Int32 z,
     Double angle)

See Also

Ellipse Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Ellipse

Steema.TeeChart.Drawing.Graphics3D.Ellipse Method

Ellipse bounding Rect (X1,Y1,X2,Y2) at Z position.
public abstract Void Ellipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 z)

See Also

Ellipse Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Ellipse

Steema.TeeChart.Drawing.Graphics3D.Ellipse Method

Ellipse bounding Rectangle at z depth.
public Void Ellipse(Rectangle r,
     Int32 z)

See Also

Ellipse Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Ellipse

Steema.TeeChart.Drawing.Graphics3D.Ellipse Method

Ellipse bounding Rectangle r.
public Void Ellipse(Rectangle r)

See Also

Ellipse Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Ellipse

Steema.TeeChart.Drawing.Graphics3D.Ellipse Method

Ellipse bounding rectangle (Left, Top, Right, Bottom) with Z offset at angle.
public Void Ellipse(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom,
     Int32 z,
     Double angle)

See Also

Ellipse Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


EnableRotation

Steema.TeeChart.Drawing.Graphics3D.EnableRotation Method

public abstract Void EnableRotation()

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


EndBlending

Steema.TeeChart.Drawing.Graphics3D.EndBlending Method

Supports OpenGL Transparency
public abstract Void EndBlending()

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


EraseBackground

Steema.TeeChart.Drawing.Graphics3D.EraseBackground Method

public abstract Void EraseBackground(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


FillRectangle

Steema.TeeChart.Drawing.Graphics3D.FillRectangle Method

public abstract Void FillRectangle(Paint brush,
     Int32 x,
     Int32 y,
     Int32 width,
     Int32 height)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


FillRegion

Steema.TeeChart.Drawing.Graphics3D.FillRegion Method

public abstract Void FillRegion(Paint brush,
     Region region)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


FontTextHeight

Steema.TeeChart.Drawing.Graphics3D.FontTextHeight Method

Determines the Font Height to be used for outputted text when using the Drawing.
public Int32 FontTextHeight(ChartFont f)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


FourPointsFromRect

Steema.TeeChart.Drawing.Graphics3D.FourPointsFromRect Method

Returns a TFourPoints structure (array of four TPoint records)
public Point[] FourPointsFromRect(Rectangle r,
     Int32 z)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Frame3D

Steema.TeeChart.Drawing.Graphics3D.Frame3D Method

public Void Frame3D(Rectangle Rect,
     Color TopColor,
     Color BottomColor,
     Int32 Width)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


FrontPlaneBegin

Steema.TeeChart.Drawing.Graphics3D.FrontPlaneBegin Method

public abstract Void FrontPlaneBegin()

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


FrontPlaneEnd

Steema.TeeChart.Drawing.Graphics3D.FrontPlaneEnd Method

public abstract Void FrontPlaneEnd()

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


GetArrowPoints

Steema.TeeChart.Drawing.Graphics3D.GetArrowPoints Method

public Point[] GetArrowPoints(Point FromPoint,
     Point ToPoint,
     Int32 ArrowWidth,
     Int32 ArrowHeight,
     Int32 Z,
     Double ArrowPercent)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


GetChartPolygon

Steema.TeeChart.Drawing.Graphics3D.GetChartPolygon Method

Returns a z-shifted Region from a Rectangle.
public abstract Region GetChartPolygon(Rectangle rect,
     Int32 minZ,
     Int32 maxZ)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


GetClipRoundRectangle

Steema.TeeChart.Drawing.Graphics3D.GetClipRoundRectangle Method

Overload List

Returns a PointDouble array which contains a Rounded Rectangle.

public PointDouble[] GetClipRoundRectangle(System.Drawing.Rectangle, System.Int32, System.Int32, System.Int32)

Returns a PointDouble array which contains a Rounded Rectangle.

public PointDouble[] GetClipRoundRectangle(System.Byte[]&, System.Drawing.Rectangle, System.Int32, System.Int32, System.Int32)

Returns a PointDouble array which contains a Rounded Rectangle.

public PointDouble[] GetClipRoundRectangle(System.Drawing.Rectangle, System.Int32, System.Int32)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


GetClipRoundRectangle

Steema.TeeChart.Drawing.Graphics3D.GetClipRoundRectangle Method

Returns a PointDouble array which contains a Rounded Rectangle.
public PointDouble[] GetClipRoundRectangle(Rectangle rect,
     Int32 borderRound,
     Int32 width)

See Also

GetClipRoundRectangle Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


GetClipRoundRectangle

Steema.TeeChart.Drawing.Graphics3D.GetClipRoundRectangle Method

Returns a PointDouble array which contains a Rounded Rectangle.
public PointDouble[] GetClipRoundRectangle(Byte[]& pathPointType,
     Rectangle rect,
     Int32 roundWidth,
     Int32 roundHeight,
     Int32 width)

See Also

GetClipRoundRectangle Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


GetClipRoundRectangle

Steema.TeeChart.Drawing.Graphics3D.GetClipRoundRectangle Method

Returns a PointDouble array which contains a Rounded Rectangle.
public PointDouble[] GetClipRoundRectangle(Rectangle rect,
     Int32 roundWidth,
     Int32 roundHeight,
     Int32 width)

See Also

GetClipRoundRectangle Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


HorizCone

Steema.TeeChart.Drawing.Graphics3D.HorizCone Method

Paints a cone. Use ONLY with OPENGL.
public Void HorizCone(Rectangle r,
     Int32 z0,
     Int32 z1,
     Boolean darkSides,
     Int32 conePercent)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


HorizontalLine

Steema.TeeChart.Drawing.Graphics3D.HorizontalLine Method

Overload List

Draws a Horizontal at z depth position.

public abstract Void HorizontalLine(System.Int32, System.Int32, System.Int32, System.Int32)
public abstract Void HorizontalLine(System.Int32, System.Int32, System.Int32)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


HorizontalLine

Steema.TeeChart.Drawing.Graphics3D.HorizontalLine Method

public abstract Void HorizontalLine(Int32 left,
     Int32 right,
     Int32 y)

See Also

HorizontalLine Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


HorizontalLine

Steema.TeeChart.Drawing.Graphics3D.HorizontalLine Method

Draws a Horizontal at z depth position.
public abstract Void HorizontalLine(Int32 left,
     Int32 right,
     Int32 y,
     Int32 z)

See Also

HorizontalLine Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Line

Steema.TeeChart.Drawing.Graphics3D.Line Method

Overload List

public abstract Void Line(System.Double, System.Double, System.Double, System.Double)
public abstract Void Line(System.Int32, System.Int32, System.Int32, System.Int32)

Draws a Line between point p0 and point p1 with Z offset.

public Void Line(System.Drawing.Point, System.Drawing.Point, System.Int32)

Draws a Line between PointDouble p0 and PointDouble p1.

public Void Line(Steema.TeeChart.Drawing.PointDouble, Steema.TeeChart.Drawing.PointDouble)

Draws a Line between point p0 and point p1.

public Void Line(System.Drawing.Point, System.Drawing.Point)

Draws a Line between co-ordinates with different start/end z depth offset.

public abstract Void Line(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

Draws a Line between co-ordinates with z depth offset.

public abstract Void Line(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Line

Steema.TeeChart.Drawing.Graphics3D.Line Method

Draws a Line between co-ordinates with z depth offset.
public abstract Void Line(Int32 x0,
     Int32 y0,
     Int32 x1,
     Int32 y1,
     Int32 z)

See Also

Line Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Line

Steema.TeeChart.Drawing.Graphics3D.Line Method

Draws a Line between co-ordinates with different start/end z depth offset.
public abstract Void Line(Int32 x0,
     Int32 y0,
     Int32 z0,
     Int32 x1,
     Int32 y1,
     Int32 z1)

See Also

Line Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Line

Steema.TeeChart.Drawing.Graphics3D.Line Method

Draws a Line between point p0 and point p1.
public Void Line(Point p0,
     Point p1)

Parameters

p0
Origin xy
p1
Destination xy

See Also

Line Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Line

Steema.TeeChart.Drawing.Graphics3D.Line Method

Draws a Line between PointDouble p0 and PointDouble p1.
public Void Line(PointDouble p0,
     PointDouble p1)

Parameters

p0
Origin xy
p1
Destination xy

See Also

Line Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Line

Steema.TeeChart.Drawing.Graphics3D.Line Method

Draws a Line between point p0 and point p1 with Z offset.
public Void Line(Point p0,
     Point p1,
     Int32 z)

Parameters

p0
Origin xy
p1
Destination xy
z
Depth offset

See Also

Line Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Line

Steema.TeeChart.Drawing.Graphics3D.Line Method

public abstract Void Line(Int32 x0,
     Int32 y0,
     Int32 x1,
     Int32 y1)

See Also

Line Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Line

Steema.TeeChart.Drawing.Graphics3D.Line Method

public abstract Void Line(Double x0,
     Double y0,
     Double x1,
     Double y1)

See Also

Line Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


LineTo

Steema.TeeChart.Drawing.Graphics3D.LineTo Method

Overload List

public abstract Void LineTo(System.Int32, System.Int32)

Draws a line to Point with z depth offset.

public Void LineTo(System.Drawing.Point, System.Int32)

Draws line from present position to end co-ordinates with z depth offset.

public abstract Void LineTo(System.Int32, System.Int32, System.Int32)

Draws a Line to 3D Point.

public abstract Void LineTo(Steema.TeeChart.Drawing.Point3D)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


LineTo

Steema.TeeChart.Drawing.Graphics3D.LineTo Method

Draws a Line to 3D Point.
public abstract Void LineTo(Point3D p)

See Also

LineTo Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


LineTo

Steema.TeeChart.Drawing.Graphics3D.LineTo Method

Draws line from present position to end co-ordinates with z depth offset.
public abstract Void LineTo(Int32 x,
     Int32 y,
     Int32 z)

See Also

LineTo Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


LineTo

Steema.TeeChart.Drawing.Graphics3D.LineTo Method

Draws a line to Point with z depth offset.
public Void LineTo(Point p,
     Int32 z)

See Also

LineTo Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


LineTo

Steema.TeeChart.Drawing.Graphics3D.LineTo Method

public abstract Void LineTo(Int32 x,
     Int32 y)

See Also

LineTo Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


LineWithZ

Steema.TeeChart.Drawing.Graphics3D.LineWithZ Method

public Void LineWithZ(Int32 x,
     Int32 y,
     Int32 x1,
     Int32 y1,
     Int32 z)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


MeasureString

Steema.TeeChart.Drawing.Graphics3D.MeasureString Method

Returns the SizeF of a string of a specified font.
public abstract SizeF MeasureString(ChartFont f,
     String text)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


MoveTo

Steema.TeeChart.Drawing.Graphics3D.MoveTo Method

Overload List

Sets the value of PenPos to x and y co-ordinates before calling LineTo.

public abstract Void MoveTo(System.Int32, System.Int32)

Sets the value of PenPos to Point p before calling LineTo.

public Void MoveTo(System.Drawing.Point)

Sets the value of PenPos to x, y and z co-ordinates before calling LineTo.

public abstract Void MoveTo(System.Int32, System.Int32, System.Int32)

Sets the value of PenPos to Point p with z depth offset before calling LineTo.

public abstract Void MoveTo(System.Drawing.Point, System.Int32)

Sets the value of PenPos to 3D Point p before calling LineTo.

public abstract Void MoveTo(Steema.TeeChart.Drawing.Point3D)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


MoveTo

Steema.TeeChart.Drawing.Graphics3D.MoveTo Method

Sets the value of PenPos to 3D Point p before calling LineTo.
public abstract Void MoveTo(Point3D p)

See Also

MoveTo Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


MoveTo

Steema.TeeChart.Drawing.Graphics3D.MoveTo Method

Sets the value of PenPos to Point p with z depth offset before calling LineTo.
public abstract Void MoveTo(Point p,
     Int32 z)

See Also

MoveTo Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


MoveTo

Steema.TeeChart.Drawing.Graphics3D.MoveTo Method

Sets the value of PenPos to x, y and z co-ordinates before calling LineTo.
public abstract Void MoveTo(Int32 x,
     Int32 y,
     Int32 z)

See Also

MoveTo Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


MoveTo

Steema.TeeChart.Drawing.Graphics3D.MoveTo Method

Sets the value of PenPos to Point p before calling LineTo.
public Void MoveTo(Point p)

See Also

MoveTo Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


MoveTo

Steema.TeeChart.Drawing.Graphics3D.MoveTo Method

Sets the value of PenPos to x and y co-ordinates before calling LineTo.
public abstract Void MoveTo(Int32 x,
     Int32 y)

See Also

MoveTo Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


OrientRectangle

Steema.TeeChart.Drawing.Graphics3D.OrientRectangle Method

Makes sure the R rectangle Left is smaller than Right and Top is smaller than Bottom. Returns corrected rectangle.
public Void OrientRectangle(Rectangle& rect)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PaintBevel

Steema.TeeChart.Drawing.Graphics3D.PaintBevel Method

public Void PaintBevel(BevelStyles bevel,
     Rectangle rect,
     Int32 width,
     Color one,
     Color two)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PaintImageBevel

Steema.TeeChart.Drawing.Graphics3D.PaintImageBevel Method

Draws a custom border around a specified Rectangle.
public Void PaintImageBevel(Rectangle rect,
     Int32 width,
     Paint pen,
     Paint brush,
     Int32 borderRound)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Pie

Steema.TeeChart.Drawing.Graphics3D.Pie Method

Overload List

Draws a Pie slice.

public Void Pie(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

Draws a Pie slice using StartAngle and End Angle.

public abstract Void Pie(System.Int32, System.Int32, System.Int32, System.Int32, System.Double, System.Double)
public abstract Void Pie(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Double, System.Double, System.Boolean, System.Boolean, System.Int32, System.Int32, Steema.TeeChart.Drawing.EdgeStyles)

Draws a 3D Pie slice using start Angle and end Angle and donut percent.

public abstract Void Pie(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Double, System.Double, System.Boolean, System.Boolean, System.Int32, System.Int32, Steema.TeeChart.Drawing.EdgeStyles)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Pie

Steema.TeeChart.Drawing.Graphics3D.Pie Method

Draws a 3D Pie slice using start Angle and end Angle and donut percent.
public abstract Void Pie(Int32 xCenter,
     Int32 yCenter,
     Int32 xRadius,
     Int32 yRadius,
     Int32 z0,
     Int32 z1,
     Double startAngle,
     Double endAngle,
     Boolean darkSides,
     Boolean drawSides,
     Int32 donutPercent,
     Int32 bevelPercent,
     EdgeStyles edgeStyle)

See Also

Pie Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Pie

Steema.TeeChart.Drawing.Graphics3D.Pie Method

public abstract Void Pie(Int32 xCenter,
     Int32 yCenter,
     Int32 xOffset,
     Int32 yOffset,
     Int32 xRadius,
     Int32 yRadius,
     Int32 z0,
     Int32 z1,
     Double startAngle,
     Double endAngle,
     Boolean darkSides,
     Boolean drawSides,
     Int32 donutPercent,
     Int32 bevelPercent,
     EdgeStyles edgeStyle)

See Also

Pie Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Pie

Steema.TeeChart.Drawing.Graphics3D.Pie Method

Draws a Pie slice using StartAngle and End Angle.
public abstract Void Pie(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Double startAngle,
     Double endAngle)

See Also

Pie Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Pie

Steema.TeeChart.Drawing.Graphics3D.Pie Method

Draws a Pie slice.
public Void Pie(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 x3,
     Int32 y3,
     Int32 x4,
     Int32 y4)

See Also

Pie Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Pixel

Steema.TeeChart.Drawing.Graphics3D.Pixel Method

public abstract Void Pixel(Int32 x,
     Int32 y,
     Int32 z,
     Color color)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Plane

Steema.TeeChart.Drawing.Graphics3D.Plane Method

Overload List

Draws a polygon (Point p1, Point p2, Point p3, Point p4) at Z depth offset.

public abstract Void Plane(System.Drawing.Point, System.Drawing.Point, System.Drawing.Point, System.Drawing.Point, System.Int32)

Draws a polygon (Point p1, Point p2) at Z depth offset.

public abstract Void Plane(System.Drawing.Point, System.Drawing.Point, System.Int32, System.Int32)

Draws a polygon using points array p with different start/end z depth offset.

public Void Plane(System.Int32, System.Int32, System.Drawing.Point[])

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Plane

Steema.TeeChart.Drawing.Graphics3D.Plane Method

Draws a polygon using points array p with different start/end z depth offset.
public Void Plane(Int32 z0,
     Int32 z1,
     Point[] p)

See Also

Plane Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Plane

Steema.TeeChart.Drawing.Graphics3D.Plane Method

Draws a polygon (Point p1, Point p2) at Z depth offset.
public abstract Void Plane(Point p1,
     Point p2,
     Int32 z0,
     Int32 z1)

See Also

Plane Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Plane

Steema.TeeChart.Drawing.Graphics3D.Plane Method

Draws a polygon (Point p1, Point p2, Point p3, Point p4) at Z depth offset.
public abstract Void Plane(Point p1,
     Point p2,
     Point p3,
     Point p4,
     Int32 z)

See Also

Plane Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PlaneFour3D

Steema.TeeChart.Drawing.Graphics3D.PlaneFour3D Method

Draws a polygon of four points.
public abstract Void PlaneFour3D(Int32 z0,
     Int32 z1,
     Point[] p)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointAtDistance

Steema.TeeChart.Drawing.Graphics3D.PointAtDistance Method

Returns point "To" minus "distance" pixels from "From" point.
public static Point PointAtDistance(Point From,
     Point To,
     Int32 distance)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointFromCircle

Steema.TeeChart.Drawing.Graphics3D.PointFromCircle Method

Overload List

Returns the PointDouble which is on the circle bounded by rectBounds at the angle degrees.

public PointDouble PointFromCircle(System.Drawing.Rectangle, System.Double)

Returns the PointDouble which is on the circle bounded by rectBounds at the angle degrees.

public PointDouble PointFromCircle(System.Drawing.Rectangle, System.Double, System.Int32)

Returns the PointDouble which is on the circle bounded by rectBounds at the angle degrees. Optionally translates the point in TeeChart's 3D space when the Z Position is greater than zero.

public PointDouble PointFromCircle(System.Drawing.Rectangle, System.Double, System.Int32, System.Boolean)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointFromCircle

Steema.TeeChart.Drawing.Graphics3D.PointFromCircle Method

Returns the PointDouble which is on the circle bounded by rectBounds at the angle degrees. Optionally translates the point in TeeChart's 3D space when the Z Position is greater than zero.
public PointDouble PointFromCircle(Rectangle rectBounds,
     Double degrees,
     Int32 zPos,
     Boolean clockWise)

See Also

PointFromCircle Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointFromCircle

Steema.TeeChart.Drawing.Graphics3D.PointFromCircle Method

Returns the PointDouble which is on the circle bounded by rectBounds at the angle degrees.
public PointDouble PointFromCircle(Rectangle rectBounds,
     Double degrees,
     Int32 zPos)

See Also

PointFromCircle Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointFromCircle

Steema.TeeChart.Drawing.Graphics3D.PointFromCircle Method

Returns the PointDouble which is on the circle bounded by rectBounds at the angle degrees.
public PointDouble PointFromCircle(Rectangle rectBounds,
     Double degrees)

See Also

PointFromCircle Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointFromEllipse

Steema.TeeChart.Drawing.Graphics3D.PointFromEllipse Method

Overload List

Returns the PointDouble which is on the ellipse bounded by rectBounds at the angle degrees.

public PointDouble PointFromEllipse(System.Drawing.Rectangle, System.Double)

Returns the PointDouble which is on the ellipse bounded by rectBounds at the angle degrees. Optionally translates the point in TeeChart's 3D space when the Z Position is greater than zero.

public PointDouble PointFromEllipse(System.Drawing.Rectangle, System.Double, System.Int32)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointFromEllipse

Steema.TeeChart.Drawing.Graphics3D.PointFromEllipse Method

Returns the PointDouble which is on the ellipse bounded by rectBounds at the angle degrees. Optionally translates the point in TeeChart's 3D space when the Z Position is greater than zero.
public PointDouble PointFromEllipse(Rectangle rectBounds,
     Double degrees,
     Int32 zPos)

See Also

PointFromEllipse Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointFromEllipse

Steema.TeeChart.Drawing.Graphics3D.PointFromEllipse Method

Returns the PointDouble which is on the ellipse bounded by rectBounds at the angle degrees.
public PointDouble PointFromEllipse(Rectangle rectBounds,
     Double degrees)

See Also

PointFromEllipse Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointFromSpiral

Steema.TeeChart.Drawing.Graphics3D.PointFromSpiral Method

public PointDouble PointFromSpiral(Rectangle rectBounds,
     Double degrees,
     Double twist)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointInEllipse

Steema.TeeChart.Drawing.Graphics3D.PointInEllipse Method

Overload List

Returns true if point P is inside the ellipse bounded by Left, Top, Right, Bottom.

public static Boolean PointInEllipse(System.Drawing.Point, System.Int32, System.Int32, System.Int32, System.Int32)

Returns true if point P is inside the ellipse bounded by Rect.

public static Boolean PointInEllipse(System.Drawing.Point, System.Drawing.Rectangle)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointInEllipse

Steema.TeeChart.Drawing.Graphics3D.PointInEllipse Method

Returns true if point P is inside the ellipse bounded by Rect.
public static Boolean PointInEllipse(Point p,
     Rectangle rect)

See Also

PointInEllipse Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointInEllipse

Steema.TeeChart.Drawing.Graphics3D.PointInEllipse Method

Returns true if point P is inside the ellipse bounded by Left, Top, Right, Bottom.
public static Boolean PointInEllipse(Point p,
     Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

See Also

PointInEllipse Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointInHorizTriangle

Steema.TeeChart.Drawing.Graphics3D.PointInHorizTriangle Method

Returns true if point P is inside the horizontal triangle.
public static Boolean PointInHorizTriangle(Point p,
     Int32 y0,
     Int32 y1,
     Int32 x0,
     Int32 x1)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointInLine

Steema.TeeChart.Drawing.Graphics3D.PointInLine Method

public static Boolean PointInLine(Point p,
     Point fromPoint,
     Point toPoint)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointInLineTolerance

Steema.TeeChart.Drawing.Graphics3D.PointInLineTolerance Method

Determines if point T is "near" line segment between Point1 and Point2.
public static Boolean PointInLineTolerance(Point p,
     Int32 px,
     Int32 py,
     Int32 qx,
     Int32 qy,
     Int32 tolerance)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointInPolygon

Steema.TeeChart.Drawing.Graphics3D.PointInPolygon Method

Overload List

public static Boolean PointInPolygon(System.Drawing.Point, Steema.TeeChart.Drawing.Triangle2D)

Returns true if point P is inside Poly polygon.

public static Boolean PointInPolygon(System.Drawing.Point, System.Drawing.Point[])

Returns true if point P is inside Poly polygon.

public static Boolean PointInPolygon(System.Drawing.Point, Steema.TeeChart.Drawing.PointDouble[])

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointInPolygon

Steema.TeeChart.Drawing.Graphics3D.PointInPolygon Method

Returns true if point P is inside Poly polygon.
public static Boolean PointInPolygon(Point p,
     PointDouble[] poly)

See Also

PointInPolygon Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointInPolygon

Steema.TeeChart.Drawing.Graphics3D.PointInPolygon Method

Returns true if point P is inside Poly polygon.
public static Boolean PointInPolygon(Point p,
     Point[] poly)

See Also

PointInPolygon Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointInPolygon

Steema.TeeChart.Drawing.Graphics3D.PointInPolygon Method

public static Boolean PointInPolygon(Point p,
     Triangle2D triangle)

See Also

PointInPolygon Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointInRect

Steema.TeeChart.Drawing.Graphics3D.PointInRect Method

public static Boolean PointInRect(Rectangle rect,
     Int32 x,
     Int32 y)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointInTriangle

Steema.TeeChart.Drawing.Graphics3D.PointInTriangle Method

Overload List

Returns true if point P is inside the vert triangle of p0, p1, p2.

public static Boolean PointInTriangle(System.Drawing.Point, System.Drawing.Point, System.Drawing.Point, System.Drawing.Point)

Returns true if point P is inside the vert triangle of x0y0, midxY1, x1y0.

public static Boolean PointInTriangle(System.Drawing.Point, System.Int32, System.Int32, System.Int32, System.Int32)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointInTriangle

Steema.TeeChart.Drawing.Graphics3D.PointInTriangle Method

Returns true if point P is inside the vert triangle of x0y0, midxY1, x1y0.
public static Boolean PointInTriangle(Point p,
     Int32 x0,
     Int32 x1,
     Int32 y0,
     Int32 y1)

See Also

PointInTriangle Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PointInTriangle

Steema.TeeChart.Drawing.Graphics3D.PointInTriangle Method

Returns true if point P is inside the vert triangle of p0, p1, p2.
public static Boolean PointInTriangle(Point p,
     Point p0,
     Point p1,
     Point p2)

See Also

PointInTriangle Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Polygon

Steema.TeeChart.Drawing.Graphics3D.Polygon Method

Overload List

Draws a polygon with z position offset.

public abstract Void Polygon(System.Int32, System.Drawing.Point[])
public abstract Void Polygon(System.Double, Steema.TeeChart.Drawing.PointDouble[])
public abstract Void Polygon(Steema.TeeChart.Drawing.PointDouble[])
public abstract Void Polygon(Steema.TeeChart.Drawing.Point3D[])
public abstract Void Polygon(System.Drawing.Point[])

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Polygon

Steema.TeeChart.Drawing.Graphics3D.Polygon Method

public abstract Void Polygon(Point[] p)

See Also

Polygon Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Polygon

Steema.TeeChart.Drawing.Graphics3D.Polygon Method

public abstract Void Polygon(Point3D[] p)

See Also

Polygon Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Polygon

Steema.TeeChart.Drawing.Graphics3D.Polygon Method

public abstract Void Polygon(PointDouble[] p)

See Also

Polygon Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Polygon

Steema.TeeChart.Drawing.Graphics3D.Polygon Method

public abstract Void Polygon(Double z,
     PointDouble[] p)

See Also

Polygon Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Polygon

Steema.TeeChart.Drawing.Graphics3D.Polygon Method

Draws a polygon with z position offset.
public abstract Void Polygon(Int32 z,
     Point[] p)

See Also

Polygon Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PolygonBounds

Steema.TeeChart.Drawing.Graphics3D.PolygonBounds Method

Returns the minimum left / top and the maximum right / bottom for all the points in "p" polygon
public Rectangle PolygonBounds(Point[] p)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PolygonFourDouble

Steema.TeeChart.Drawing.Graphics3D.PolygonFourDouble Method

public abstract Void PolygonFourDouble()

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PolygonPointBounds

Steema.TeeChart.Drawing.Graphics3D.PolygonPointBounds Method

Returns a parallelogram of upper-left, upper-right, and lower-left corners.
public Point[] PolygonPointBounds(Point[] p)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PolygonRect

Steema.TeeChart.Drawing.Graphics3D.PolygonRect Method

Overload List

Returns bounding rectangle for point array p

public RectangleF PolygonRect(System.Drawing.PointF[])

Returns bounding rectangle for point array p

public Rectangle PolygonRect(System.Drawing.Point[])

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PolygonRect

Steema.TeeChart.Drawing.Graphics3D.PolygonRect Method

Returns bounding rectangle for point array p
public Rectangle PolygonRect(Point[] p)

See Also

PolygonRect Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PolygonRect

Steema.TeeChart.Drawing.Graphics3D.PolygonRect Method

Returns bounding rectangle for point array p
public RectangleF PolygonRect(PointF[] p)

See Also

PolygonRect Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Polyline

Steema.TeeChart.Drawing.Graphics3D.Polyline Method

Overload List

public abstract Void Polyline(System.Drawing.Point[])
public abstract Void Polyline(System.Int32, System.Drawing.Point[])

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Polyline

Steema.TeeChart.Drawing.Graphics3D.Polyline Method

public abstract Void Polyline(Int32 z,
     Point[] p)

See Also

Polyline Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Polyline

Steema.TeeChart.Drawing.Graphics3D.Polyline Method

public abstract Void Polyline(Point[] p)

See Also

Polyline Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PopMatrix

Steema.TeeChart.Drawing.Graphics3D.PopMatrix Method

public abstract Void PopMatrix()

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PrepareDrawImage

Steema.TeeChart.Drawing.Graphics3D.PrepareDrawImage Method

Prepares the Chart Canvas for drawing.
public abstract Void PrepareDrawImage()

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Projection

Steema.TeeChart.Drawing.Graphics3D.Projection Method

Internal use. Calculates the projection co-ordinates for rectangle Bounds
public abstract Void Projection(Int32 MaxDepth,
     Rectangle ABounds,
     Rectangle Rect)

Parameters

maxDepth
Max shape depth
r
Projected shape rectangle

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PushMatrix

Steema.TeeChart.Drawing.Graphics3D.PushMatrix Method

public abstract Void PushMatrix()

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Pyramid

Steema.TeeChart.Drawing.Graphics3D.Pyramid Method

Overload List

Draws a vertical or horizontal Pyramid with optional dark shaded sides.

public Void Pyramid(System.Boolean, System.Drawing.Rectangle, System.Int32, System.Int32, System.Boolean)

Draws a vertical or horizontal Pyramid with optional dark shaded sides.

public abstract Void Pyramid(System.Boolean, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Boolean)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Pyramid

Steema.TeeChart.Drawing.Graphics3D.Pyramid Method

Draws a vertical or horizontal Pyramid with optional dark shaded sides.
public abstract Void Pyramid(Boolean vertical,
     Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom,
     Int32 z0,
     Int32 z1,
     Boolean darkSides)

See Also

Pyramid Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Pyramid

Steema.TeeChart.Drawing.Graphics3D.Pyramid Method

Draws a vertical or horizontal Pyramid with optional dark shaded sides.
public Void Pyramid(Boolean vertical,
     Rectangle r,
     Int32 z0,
     Int32 z1,
     Boolean darkSides)

See Also

Pyramid Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


PyramidTrunc

Steema.TeeChart.Drawing.Graphics3D.PyramidTrunc Method

Draws a pyramid with a truncated apex of variable thickness.
public abstract Void PyramidTrunc(Rectangle r,
     Int32 startZ,
     Int32 endZ,
     Int32 truncX,
     Int32 truncZ)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Rectangle

Steema.TeeChart.Drawing.Graphics3D.Rectangle Method

Overload List

Draws a rectangle between the defined co-ordinates.

public Void Rectangle(System.Int32, System.Int32, System.Int32, System.Int32)
public abstract Void Rectangle(System.Drawing.Rectangle)

Draws a rectangle between the defined co-ordinates with z depth.

public Void Rectangle(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

Draws a Rectangle (Rectangle r) at z depth.

public abstract Void Rectangle(System.Drawing.Rectangle, System.Int32)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Rectangle

Steema.TeeChart.Drawing.Graphics3D.Rectangle Method

Draws a Rectangle (Rectangle r) at z depth.
public abstract Void Rectangle(Rectangle r,
     Int32 z)

See Also

Rectangle Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Rectangle

Steema.TeeChart.Drawing.Graphics3D.Rectangle Method

Draws a rectangle between the defined co-ordinates with z depth.
public Void Rectangle(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom,
     Int32 z)

See Also

Rectangle Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Rectangle

Steema.TeeChart.Drawing.Graphics3D.Rectangle Method

public abstract Void Rectangle(Rectangle r)

See Also

Rectangle Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Rectangle

Steema.TeeChart.Drawing.Graphics3D.Rectangle Method

Draws a rectangle between the defined co-ordinates.
public Void Rectangle(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

See Also

Rectangle Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


RectangleF

Steema.TeeChart.Drawing.Graphics3D.RectangleF Method

public Void RectangleF(RectangleF r)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


RectangleWithZ

Steema.TeeChart.Drawing.Graphics3D.RectangleWithZ Method

public Void RectangleWithZ(Rectangle r,
     Int32 z)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


RectangleY

Steema.TeeChart.Drawing.Graphics3D.RectangleY Method

Horizontal Rectangle from Left to Right, from Z0 to Z1 position, at Top Y.
public abstract Void RectangleY(Int32 left,
     Int32 top,
     Int32 right,
     Int32 z0,
     Int32 z1)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


RectangleZ

Steema.TeeChart.Drawing.Graphics3D.RectangleZ Method

Horizontal Rectangle from Left to Right, from Z0 to Z1 position, at Top Y.
public abstract Void RectangleZ(Int32 left,
     Int32 top,
     Int32 bottom,
     Int32 z0,
     Int32 z1)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


RectCenter

Steema.TeeChart.Drawing.Graphics3D.RectCenter Method

Overload List

public static Void RectCenter(System.Drawing.Rectangle, System.Int32&, System.Int32&)
public static Void RectCenter(System.Drawing.RectangleF, System.Single&, System.Single&)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


RectCenter

Steema.TeeChart.Drawing.Graphics3D.RectCenter Method

public static Void RectCenter(RectangleF r,
     Single& x,
     Single& y)

See Also

RectCenter Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


RectCenter

Steema.TeeChart.Drawing.Graphics3D.RectCenter Method

public static Void RectCenter(Rectangle r,
     Int32& x,
     Int32& y)

See Also

RectCenter Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


RectFromPolygon

Steema.TeeChart.Drawing.Graphics3D.RectFromPolygon Method

Overload List

Returns the bounding rectangle for a given array of XY points.

public Rectangle RectFromPolygon(System.Int32, System.Drawing.Point[])

Returns the bounding rectangle for a given array of XY points.

public Rectangle RectFromPolygon(System.Int32, Steema.TeeChart.Drawing.PointDouble[])

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


RectFromPolygon

Steema.TeeChart.Drawing.Graphics3D.RectFromPolygon Method

Returns the bounding rectangle for a given array of XY points.
public Rectangle RectFromPolygon(Int32 num,
     PointDouble[] p)

See Also

RectFromPolygon Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


RectFromPolygon

Steema.TeeChart.Drawing.Graphics3D.RectFromPolygon Method

Returns the bounding rectangle for a given array of XY points.
public Rectangle RectFromPolygon(Int32 num,
     Point[] p)

See Also

RectFromPolygon Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


RectFromRectZ

Steema.TeeChart.Drawing.Graphics3D.RectFromRectZ Method

Returns the smallest bounding rectangle containing the four corners of the "R" rectangle after calculating their 3D position.
public Rectangle RectFromRectZ(Rectangle r,
     Int32 z)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Rotate

Steema.TeeChart.Drawing.Graphics3D.Rotate Method

public abstract Void Rotate(Int32 angle)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


RotateLabel

Steema.TeeChart.Drawing.Graphics3D.RotateLabel Method

Overload List

Draws a rotated text string at the specified x,y and z coordinates with the RotDegree rotation angle.

public abstract Void RotateLabel(System.Int32, System.Int32, System.Int32, System.String, System.Double)
public abstract Void RotateLabel(System.Int32, System.Int32, System.String, System.Double)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


RotateLabel

Steema.TeeChart.Drawing.Graphics3D.RotateLabel Method

public abstract Void RotateLabel(Int32 x,
     Int32 y,
     String text,
     Double rotDegree)

See Also

RotateLabel Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


RotateLabel

Steema.TeeChart.Drawing.Graphics3D.RotateLabel Method

Draws a rotated text string at the specified x,y and z coordinates with the RotDegree rotation angle.
public abstract Void RotateLabel(Int32 x,
     Int32 y,
     Int32 z,
     String text,
     Double rotDegree)

See Also

RotateLabel Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


RotateRectangle

Steema.TeeChart.Drawing.Graphics3D.RotateRectangle Method

public static Point[] RotateRectangle(Rectangle r,
     Int32 angle)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


RoundRectangle

Steema.TeeChart.Drawing.Graphics3D.RoundRectangle Method

Overload List

public Void RoundRectangle(System.Drawing.Rectangle, System.Int32)
public abstract Void RoundRectangle(System.Drawing.Rectangle, System.Int32, System.Int32)

Draws a rectangle with rounded corners.

public Void RoundRectangle(System.Drawing.Rectangle)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


RoundRectangle

Steema.TeeChart.Drawing.Graphics3D.RoundRectangle Method

Draws a rectangle with rounded corners.
public Void RoundRectangle(Rectangle r)

See Also

RoundRectangle Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


RoundRectangle

Steema.TeeChart.Drawing.Graphics3D.RoundRectangle Method

public abstract Void RoundRectangle(Rectangle r,
     Int32 roundWidth,
     Int32 roundHeight)

See Also

RoundRectangle Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


RoundRectangle

Steema.TeeChart.Drawing.Graphics3D.RoundRectangle Method

public Void RoundRectangle(Rectangle r,
     Int32 round)

See Also

RoundRectangle Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


SetClipRegion

Steema.TeeChart.Drawing.Graphics3D.SetClipRegion Method

Overload List

public abstract Void SetClipRegion(Android.Graphics.Region)
public abstract Void SetClipRegion(Android.Graphics.Region, System.Boolean)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


SetClipRegion

Steema.TeeChart.Drawing.Graphics3D.SetClipRegion Method

public abstract Void SetClipRegion(Region region,
     Boolean intersect)

See Also

SetClipRegion Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


SetClipRegion

Steema.TeeChart.Drawing.Graphics3D.SetClipRegion Method

public abstract Void SetClipRegion(Region region)

See Also

SetClipRegion Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


SetTextAlign

Steema.TeeChart.Drawing.Graphics3D.SetTextAlign Method

public abstract Void SetTextAlign(Align a)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


ShowImage

Steema.TeeChart.Drawing.Graphics3D.ShowImage Method

public abstract Void ShowImage(Canvas g)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


SmoothShadow

Steema.TeeChart.Drawing.Graphics3D.SmoothShadow Method

public abstract Void SmoothShadow(Shadow shadow,
     Rectangle rect,
     Boolean ellipse,
     Int32 roundsize,
     Point[] p,
     Int32 donutpercent,
     Int32 z)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Sphere

Steema.TeeChart.Drawing.Graphics3D.Sphere Method

Draws a sphere.
public abstract Void Sphere(Int32 x,
     Int32 y,
     Int32 z,
     Double radius)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


StartBlending

Steema.TeeChart.Drawing.Graphics3D.StartBlending Method

Supports OpenGL Transparency
public abstract Void StartBlending(Double transparency)

Parameters

transparency
%

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Surface3D

Steema.TeeChart.Drawing.Graphics3D.Surface3D Method

public abstract Void Surface3D(SurfaceStyle style,
     Boolean sameBrush,
     Int32 numXValues,
     Int32 numZValues,
     TTeeCanvasCalcPoints calcPoints)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


TeeCull

Steema.TeeChart.Drawing.Graphics3D.TeeCull Method

Overload List

public abstract Boolean TeeCull(System.Drawing.Point, System.Drawing.Point, System.Drawing.Point)
public abstract Boolean TeeCull(System.Drawing.Point[])

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


TeeCull

Steema.TeeChart.Drawing.Graphics3D.TeeCull Method

public abstract Boolean TeeCull(Point[] P)

See Also

TeeCull Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


TeeCull

Steema.TeeChart.Drawing.Graphics3D.TeeCull Method

public abstract Boolean TeeCull(Point p0,
     Point p1,
     Point p2)

See Also

TeeCull Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


TextHeight

Steema.TeeChart.Drawing.Graphics3D.TextHeight Method

Overload List

Returns the vertical text size in pixels of ChartFont f.

public abstract Single TextHeight(Steema.TeeChart.Drawing.ChartFont, System.String)

Returns the vertical size in pixels of the text string.

public abstract Single TextHeight(System.String)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


TextHeight

Steema.TeeChart.Drawing.Graphics3D.TextHeight Method

Returns the vertical size in pixels of the text string.
public abstract Single TextHeight(String text)

Return Value

Height in pixels of the text string.

See Also

TextHeight Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


TextHeight

Steema.TeeChart.Drawing.Graphics3D.TextHeight Method

Returns the vertical text size in pixels of ChartFont f.
public abstract Single TextHeight(ChartFont f,
     String text)

Return Value

Height in pixels of ChartFont f.

See Also

TextHeight Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


TextOut

Steema.TeeChart.Drawing.Graphics3D.TextOut Method

Overload List

Displays 2D non-rotated label at the specified x and y screen coordinates.

public abstract Void TextOut(System.Int32, System.Int32, System.String)

Displays 2D non-rotated label (in ChartFont f) at the specified x and y screen coordinates.

public Void TextOut(Steema.TeeChart.Drawing.ChartFont, System.Int32, System.Int32, System.String)

Displays 2D non-rotated label at the specified x,y and z screen coordinates.

public abstract Void TextOut(System.Int32, System.Int32, System.Int32, System.String)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


TextOut

Steema.TeeChart.Drawing.Graphics3D.TextOut Method

Displays 2D non-rotated label at the specified x,y and z screen coordinates.
public abstract Void TextOut(Int32 x,
     Int32 y,
     Int32 z,
     String text)

See Also

TextOut Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


TextOut

Steema.TeeChart.Drawing.Graphics3D.TextOut Method

Displays 2D non-rotated label (in ChartFont f) at the specified x and y screen coordinates.
public Void TextOut(ChartFont f,
     Int32 x,
     Int32 y,
     String text)

See Also

TextOut Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


TextOut

Steema.TeeChart.Drawing.Graphics3D.TextOut Method

Displays 2D non-rotated label at the specified x and y screen coordinates.
public abstract Void TextOut(Int32 x,
     Int32 y,
     String text)

See Also

TextOut Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


TextWidth

Steema.TeeChart.Drawing.Graphics3D.TextWidth Method

Overload List

Returns the horizontal text size in pixels of ChartFont f.

public abstract Single TextWidth(Steema.TeeChart.Drawing.ChartFont, System.String)

Returns the horizontal size in pixels of the text string.

public abstract Single TextWidth(System.String)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


TextWidth

Steema.TeeChart.Drawing.Graphics3D.TextWidth Method

Returns the horizontal size in pixels of the text string.
public abstract Single TextWidth(String text)

See Also

TextWidth Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


TextWidth

Steema.TeeChart.Drawing.Graphics3D.TextWidth Method

Returns the horizontal text size in pixels of ChartFont f.
public abstract Single TextWidth(ChartFont f,
     String text)

See Also

TextWidth Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Translate

Steema.TeeChart.Drawing.Graphics3D.Translate Method

public abstract Void Translate(Int32 x,
     Int32 y,
     Int32 z)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Transparency

Steema.TeeChart.Drawing.Graphics3D.Transparency Method

Returns percentage based on Color "A" value.
public static Int32 Transparency(Color color)

Return Value

Percentage from 0 to 100%

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


TransparentColor

Steema.TeeChart.Drawing.Graphics3D.TransparentColor Method

Returns Color parameter after changing its "A" value.
public static Color TransparentColor(Int32 transparency,
     Color color)

Parameters

transparency
From 0 to 100
color
A Color

Return Value

Color with transparency percentage applied.

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Triangle

Steema.TeeChart.Drawing.Graphics3D.Triangle Method

Overload List

Draws a triangle (point p0, pointp1, pointp2) at Z position.

public abstract Void Triangle(System.Drawing.Point, System.Drawing.Point, System.Drawing.Point, System.Int32)

Draws a triangle (Triangle3D p).

public abstract Void Triangle(Steema.TeeChart.Drawing.Triangle3D)
public abstract Void Triangle(Steema.TeeChart.Drawing.Triangle3D, System.Drawing.Color[])

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Triangle

Steema.TeeChart.Drawing.Graphics3D.Triangle Method

public abstract Void Triangle(Triangle3D p,
     Color[] Colors)

See Also

Triangle Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Triangle

Steema.TeeChart.Drawing.Graphics3D.Triangle Method

Draws a triangle (Triangle3D p).
public abstract Void Triangle(Triangle3D p)

See Also

Triangle Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Triangle

Steema.TeeChart.Drawing.Graphics3D.Triangle Method

Draws a triangle (point p0, pointp1, pointp2) at Z position.
public abstract Void Triangle(Point p0,
     Point p1,
     Point p2,
     Int32 z)

See Also

Triangle Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


TriSurface

Steema.TeeChart.Drawing.Graphics3D.TriSurface Method

public abstract Void TriSurface(Int32 NumTriangles,
     TTeeTransparency Transparency,
     TTeeCanvasTriPoints CalcPoints)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


UnClip

Steema.TeeChart.Drawing.Graphics3D.UnClip Method

public abstract Void UnClip()

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


UnClipRectangle

Steema.TeeChart.Drawing.Graphics3D.UnClipRectangle Method

Removes any clipping region applied to Chart Drawing.
public Void UnClipRectangle()

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


ValidState

Steema.TeeChart.Drawing.Graphics3D.ValidState Method

Returns true if the Chart Canvas can be drawn to.
public abstract Boolean ValidState()

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


VerticalLine

Steema.TeeChart.Drawing.Graphics3D.VerticalLine Method

Overload List

public abstract Void VerticalLine(System.Int32, System.Int32, System.Int32)

Draws a Vertical Line from (X,Top) to (X,Bottom) at z depth position.

public abstract Void VerticalLine(System.Int32, System.Int32, System.Int32, System.Int32)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


VerticalLine

Steema.TeeChart.Drawing.Graphics3D.VerticalLine Method

Draws a Vertical Line from (X,Top) to (X,Bottom) at z depth position.
public abstract Void VerticalLine(Int32 x,
     Int32 top,
     Int32 bottom,
     Int32 z)

See Also

VerticalLine Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


VerticalLine

Steema.TeeChart.Drawing.Graphics3D.VerticalLine Method

public abstract Void VerticalLine(Int32 x,
     Int32 top,
     Int32 bottom)

See Also

VerticalLine Overload List | Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


ZLine

Steema.TeeChart.Drawing.Graphics3D.ZLine Method

Draws a Line from (X,Y,Z0) to (X,Y,Z1).
public abstract Void ZLine(Int32 x,
     Int32 y,
     Int32 z0,
     Int32 z1)

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Graphics3DProperties

Steema.TeeChart.Drawing.Graphics3D Properties

Public Properties

BackColor | Sets / returns the color used to fill spaces when displaying text or filling with brushes of different style than bsSolid.
Brush | Determines Brush used to fill the Canvas draw rectangle background.
BufferStyle | Draws items to an internal canvas to prevent flickering on screen.
CanvasType | Gets the type of canvas used to draw the chart.
Chart (inherited from TeeBase) | Chart associated with this object
ChartXCenter | Returns the centre Horizontal co-ordinate of the Chart.
ChartYCenter | Returns the middle Vertical coordinate of the Chart.
Font | Determines Font for outputted text when using the Drawing.
FontHeight | Defines the Height of the Font in pixels.
GDIplusCanvas |
Gradient | Gets and sets the Brush.Gradient properties of the Canvas.
Pen | Indicates the kind of pen used to draw Canvas lines.
RotationCenter | Sets the Pixel location (using X,Y,Z) of the centre of rotation for use with the Aspect.Rotation property.
RotationCenterFloat | Sets the Pixel location (using X,Y,Z) of the centre of rotation for use with the Aspect.Rotation property.
ScreenHeight | Returns the height, in pixels, of the Chart Panel .
ScreenWidth | Returns the width, in pixels, of the Chart Panel.
Supports3DText | Returns if Canvas supports 3D Text or not.
SupportsFullRotation | Returns if Canvas can do rotation and elevation of more than 90 degree.
SupportsID | Gets and sets whether each TeeChart element drawn is assigned a unique ID.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TextAlign | Sets the alignment used when displaying text using TextOut or TextOut3D.
UseBuffer | Draws items to an internal canvas to prevent flickering on screen.
XCenter | Obtain the X coordinate of the pixel location of the center of the 3D Canvas.
YCenter | Obtain the Y coordinate of the pixel location of the center of the 3D Canvas.

See Also

Graphics3D Class | Steema.TeeChart.Drawing Namespace


BackColor

Steema.TeeChart.Drawing.Graphics3D.BackColor Property

Sets / returns the color used to fill spaces when displaying text or filling with brushes of different style than bsSolid.
public Color BackColor {get; set;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Brush

Steema.TeeChart.Drawing.Graphics3D.Brush Property

Determines Brush used to fill the Canvas draw rectangle background.
public ChartBrush Brush {get; set;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


BufferStyle

Steema.TeeChart.Drawing.Graphics3D.BufferStyle Property

Draws items to an internal canvas to prevent flickering on screen.
public abstract BufferStyle BufferStyle {get; set;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


CanvasType

Steema.TeeChart.Drawing.Graphics3D.CanvasType Property

Gets the type of canvas used to draw the chart.
public CanvasType CanvasType {get;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


ChartXCenter

Steema.TeeChart.Drawing.Graphics3D.ChartXCenter Property

Returns the centre Horizontal co-ordinate of the Chart.
public Int32 ChartXCenter {get;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


ChartYCenter

Steema.TeeChart.Drawing.Graphics3D.ChartYCenter Property

Returns the middle Vertical coordinate of the Chart.
public Int32 ChartYCenter {get;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Font

Steema.TeeChart.Drawing.Graphics3D.Font Property

Determines Font for outputted text when using the Drawing.
public ChartFont Font {get; set;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


FontHeight

Steema.TeeChart.Drawing.Graphics3D.FontHeight Property

Defines the Height of the Font in pixels.
public Int32 FontHeight {get;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


GDIplusCanvas

Steema.TeeChart.Drawing.Graphics3D.GDIplusCanvas Property

public Canvas GDIplusCanvas {get;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Gradient

Steema.TeeChart.Drawing.Graphics3D.Gradient Property

Gets and sets the Brush.Gradient properties of the Canvas.
public Gradient Gradient {get; set;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Pen

Steema.TeeChart.Drawing.Graphics3D.Pen Property

Indicates the kind of pen used to draw Canvas lines.
public ChartPen Pen {get; set;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


RotationCenter

Steema.TeeChart.Drawing.Graphics3D.RotationCenter Property

Sets the Pixel location (using X,Y,Z) of the centre of rotation for use with the Aspect.Rotation property.
public PointXYZ RotationCenter {get; set;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


RotationCenterFloat

Steema.TeeChart.Drawing.Graphics3D.RotationCenterFloat Property

Sets the Pixel location (using X,Y,Z) of the centre of rotation for use with the Aspect.Rotation property.
public Point3DDouble RotationCenterFloat {get; set;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


ScreenHeight

Steema.TeeChart.Drawing.Graphics3D.ScreenHeight Property

Returns the height, in pixels, of the Chart Panel .
public Int32 ScreenHeight {get;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


ScreenWidth

Steema.TeeChart.Drawing.Graphics3D.ScreenWidth Property

Returns the width, in pixels, of the Chart Panel.
public Int32 ScreenWidth {get;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Supports3DText

Steema.TeeChart.Drawing.Graphics3D.Supports3DText Property

Returns if Canvas supports 3D Text or not.
public Boolean Supports3DText {get; set;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


SupportsFullRotation

Steema.TeeChart.Drawing.Graphics3D.SupportsFullRotation Property

Returns if Canvas can do rotation and elevation of more than 90 degree.
public abstract Boolean SupportsFullRotation {get;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


SupportsID

Steema.TeeChart.Drawing.Graphics3D.SupportsID Property

Gets and sets whether each TeeChart element drawn is assigned a unique ID.
public Boolean SupportsID {get; set;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


TextAlign

Steema.TeeChart.Drawing.Graphics3D.TextAlign Property

Sets the alignment used when displaying text using TextOut or TextOut3D.
public Align TextAlign {get; set;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


UseBuffer

Steema.TeeChart.Drawing.Graphics3D.UseBuffer Property

Draws items to an internal canvas to prevent flickering on screen.
public abstract Boolean UseBuffer {get; set;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


XCenter

Steema.TeeChart.Drawing.Graphics3D.XCenter Property

Obtain the X coordinate of the pixel location of the center of the 3D Canvas.
public Int32 XCenter {get; set;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


YCenter

Steema.TeeChart.Drawing.Graphics3D.YCenter Property

Obtain the Y coordinate of the pixel location of the center of the 3D Canvas.
public Int32 YCenter {get; set;}

See Also

Graphics3D Class | Graphics3D Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Graphics3D.Pie3D

Steema.TeeChart.Drawing.Graphics3D.Pie3D Class

For a list of all members of this type, see Pie3D Members

System.Object
public class Pie3D : Object

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

Pie3D members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Graphics3D.Pie3DMembers

Steema.TeeChart.Drawing.Graphics3D.Pie3D all Members

Pie3D overview

Public Fields

OldColor

Public Methods

Pie
PointD

Constructors

Steema.TeeChart.Drawing.Graphics3D.Pie3D..ctor

See Also

Pie3D Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Graphics3D.Pie3DFields

Steema.TeeChart.Drawing.Graphics3D.Pie3D Fields

Public Fields

OldColor

See Also

Pie3D Class | Steema.TeeChart.Drawing Namespace


OldColor

Steema.TeeChart.Drawing.Graphics3D+Pie3D.OldColor Field

public Color OldColor

See Also

Pie3D Class | Pie3D Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Graphics3D.Pie3DMethods

Steema.TeeChart.Drawing.Graphics3D.Pie3D Methods

Public Methods

Pie
PointD

See Also

Pie3D Class | Steema.TeeChart.Drawing Namespace


Pie

Steema.TeeChart.Drawing.Graphics3D+Pie3D.Pie Method

public Void Pie(Int32 xCenter,
     Int32 yCenter,
     Int32 xRadius,
     Int32 yRadius,
     Int32 z0,
     Int32 z1,
     Double startAngle,
     Double endAngle,
     Boolean darkSides,
     Boolean drawSides,
     Int32 donutPercent,
     Int32 bevelPercent,
     EdgeStyles edgeStyle)

See Also

Pie3D Class | Pie3D Members | Steema.TeeChart.Drawing Namespace


PointD

Steema.TeeChart.Drawing.Graphics3D+Pie3D.PointD Method

public PointDouble PointD(Rectangle rect,
     Double angle,
     Int32 z)

See Also

Pie3D Class | Pie3D Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Graphics3D+Pie3D Constructor

public Graphics3D+Pie3D(Graphics3D graphics)

See Also

Pie3D Class | Pie3D Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Graphics3DAndroid

Steema.TeeChart.Drawing.Graphics3DAndroid Class

For a list of all members of this type, see Graphics3DAndroid Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Graphics3D
public class Graphics3DAndroid : Graphics3D

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

Graphics3DAndroid members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Graphics3DAndroidMembers

Steema.TeeChart.Drawing.Graphics3DAndroid all Members

Graphics3DAndroid overview

Constructors

Constructor

Public Fields

FourPoints (inherited from Graphics3D)
IPointDoubles (inherited from Graphics3D)
Monochrome (inherited from Graphics3D)

Public Methods

Arc |
Arrow (inherited from Graphics3D) |
Calc3DPoint (inherited from Graphics3D) |
Calc3DPos (inherited from Graphics3D) | Calculates and returns the XY position in pixels of the point p, XYZ 3D coordinate.
CalcRect3D (inherited from Graphics3D) | Calculates and returns the position in pixels of the Rectangle 3D coordinates.
Calculate2DPosition (inherited from Graphics3D) | Calculates and returns the XY position in pixels of the coordinate.
Calculate3DPosition (inherited from Graphics3D) | Calculates and returns the XY position in pixels of the XYZ 3D coordinate.
Changed (inherited from Graphics3D) |
ClearClipRegions | Removes all clipping regions applied to Chart Drawing including Client Clip Regions.
ClipCube (inherited from Graphics3D) | Creates a cubic Windows GDI clipping region.
ClipEllipse | Creates an elliptical clipping region.
ClipPolygon | Creates an polygonal clipping region.
ClipRectangle | Creates a rectangular clipping region.
Cone (inherited from Graphics3D) | Paints a cone. Use ONLY with OPENGL.
ConvexHull (inherited from Graphics3D) | Calculates the boundary points of the convex hull of a set of 2D xy points. Original
Cube (inherited from Graphics3D) | Draws a Cube.
Cylinder (inherited from Graphics3D) | Draws cylinder toggle Boolean for vertical or horizontal cylinder.
DisableRotation (inherited from Graphics3D) |
Draw | Paints the image at x,y coordinates.
DrawBeziers | Draws Bézier splines for the Point array p
DrawPath | Draws a GraphicsPath.
Elevate (inherited from Graphics3D) |
Ellipse | Ellipse bounding Rectangle defined by x1, y1, x2 and y2.
EnableRotation (inherited from Graphics3D) |
EndBlending (inherited from Graphics3D) | Supports OpenGL Transparency
EraseBackground |
FillRectangle (inherited from Graphics3D) |
FillRegion |
FontTextHeight (inherited from Graphics3D) | Determines the Font Height to be used for outputted text when using the Drawing.
FourPointsFromRect (inherited from Graphics3D) | Returns a TFourPoints structure (array of four TPoint records)
Frame3D (inherited from Graphics3D) |
FrontPlaneBegin (inherited from Graphics3D) |
FrontPlaneEnd (inherited from Graphics3D) |
GetArrowPoints (inherited from Graphics3D) |
GetChartPolygon (inherited from Graphics3D) | Returns a z-shifted Region from a Rectangle.
GetClipRoundRectangle (inherited from Graphics3D) | Returns a PointDouble array which contains a Rounded Rectangle.
HorizCone (inherited from Graphics3D) | Paints a cone. Use ONLY with OPENGL.
HorizontalLine | Draws a Horizontal Line.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Line | Draws a Line between co-ordinates.
LineTo | Draws a line from the present PenPos to the new co-ordinates.
LineWithZ (inherited from Graphics3D) |
MeasureString | Returns the SizeF of a string of a specified font.
MoveTo | Sets the value of PenPos to x and y co-ordinates before calling LineTo.
OrientRectangle (inherited from Graphics3D) | Makes sure the R rectangle Left is smaller than Right and Top is smaller than Bottom. Returns corrected rectangle.
PaintBevel (inherited from Graphics3D) |
PaintImageBevel (inherited from Graphics3D) | Draws a custom border around a specified Rectangle.
PathFromPointFs |
PathFromPoints |
Pie (inherited from Graphics3D) | Draws a Pie slice.
Pixel | Sets the 3D pixel to OLE_Color, using Pen.Width.
Plane (inherited from Graphics3D) | Draws a polygon (Point p1, Point p2, Point p3, Point p4) at Z depth offset.
PlaneFour3D (inherited from Graphics3D) | Draws a polygon of four points.
PointFromCircle (inherited from Graphics3D) | Returns the PointDouble which is on the circle bounded by rectBounds at the angle degrees.
PointFromEllipse (inherited from Graphics3D) | Returns the PointDouble which is on the ellipse bounded by rectBounds at the angle degrees.
PointFromSpiral (inherited from Graphics3D) |
Polygon | Draws a polygon.
PolygonBounds (inherited from Graphics3D) | Returns the minimum left / top and the maximum right / bottom for all the points in "p" polygon
PolygonFourDouble (inherited from Graphics3D) |
PolygonPointBounds (inherited from Graphics3D) | Returns a parallelogram of upper-left, upper-right, and lower-left corners.
PolygonRect (inherited from Graphics3D) | Returns bounding rectangle for point array p
Polyline | Draws a series of line segments to join point array p at z displacement
PopMatrix (inherited from Graphics3D) |
PrepareDrawImage |
Projection (inherited from Graphics3D) | Internal use. Calculates the projection co-ordinates for rectangle Bounds
PushMatrix (inherited from Graphics3D) |
Pyramid (inherited from Graphics3D) | Draws a vertical or horizontal Pyramid with optional dark shaded sides.
PyramidTrunc (inherited from Graphics3D) | Draws a pyramid with a truncated apex of variable thickness.
Rectangle | Draws a Rectangle (Rectangle r).
RectangleF (inherited from Graphics3D) |
RectangleWithZ (inherited from Graphics3D) |
RectangleY (inherited from Graphics3D) | Horizontal Rectangle from Left to Right, from Z0 to Z1 position, at Top Y.
RectangleZ (inherited from Graphics3D) | Horizontal Rectangle from Left to Right, from Z0 to Z1 position, at Top Y.
RectFromPolygon (inherited from Graphics3D) | Returns the bounding rectangle for a given array of XY points.
RectFromRectZ (inherited from Graphics3D) | Returns the smallest bounding rectangle containing the four corners of the "R" rectangle after calculating their 3D position.
Rotate (inherited from Graphics3D) |
RotateLabel | Draws a rotated text string at the specified xy coordinates with the RotDegree rotation angle.
RoundRectangle (inherited from Graphics3D) |
SetClipRegion |
SetTextAlign (inherited from Graphics3D) |
ShowImage (inherited from Graphics3D) |
SmoothShadow (inherited from Graphics3D) |
Sphere (inherited from Graphics3D) | Draws a sphere.
StartBlending (inherited from Graphics3D) | Supports OpenGL Transparency
Surface3D (inherited from Graphics3D) |
TeeCull (inherited from Graphics3D) |
TextHeight (inherited from Graphics3D) | Returns the vertical text size in pixels of ChartFont f.
TextOut (inherited from Graphics3D) | Displays 2D non-rotated label at the specified x and y screen coordinates.
TextWidth (inherited from Graphics3D) | Returns the horizontal text size in pixels of ChartFont f.
Translate (inherited from Graphics3D) |
Triangle (inherited from Graphics3D) | Draws a triangle (point p0, pointp1, pointp2) at Z position.
TriSurface (inherited from Graphics3D) |
UnClip | Removes any clipping region applied to Chart Drawing.
UnClipRectangle (inherited from Graphics3D) | Removes any clipping region applied to Chart Drawing.
ValidState (inherited from Graphics3D) | Returns true if the Chart Canvas can be drawn to.
VerticalLine | Draws a Vertical Line from (X,Top) to (X,Bottom).
ZLine (inherited from Graphics3D) | Draws a Line from (X,Y,Z0) to (X,Y,Z1).

Public Properties

BackColor (inherited from Graphics3D) | Sets / returns the color used to fill spaces when displaying text or filling with brushes of different style than bsSolid.
Brush (inherited from Graphics3D) | Determines Brush used to fill the Canvas draw rectangle background.
BufferStyle (inherited from Graphics3D) | Draws items to an internal canvas to prevent flickering on screen.
CanvasType (inherited from Graphics3D) | Gets the type of canvas used to draw the chart.
Chart (inherited from TeeBase) | Chart associated with this object
ChartXCenter (inherited from Graphics3D) | Returns the centre Horizontal co-ordinate of the Chart.
ChartYCenter (inherited from Graphics3D) | Returns the middle Vertical coordinate of the Chart.
Font (inherited from Graphics3D) | Determines Font for outputted text when using the Drawing.
FontHeight (inherited from Graphics3D) | Defines the Height of the Font in pixels.
GDIplusCanvas (inherited from Graphics3D) |
Gradient (inherited from Graphics3D) | Gets and sets the Brush.Gradient properties of the Canvas.
Pen (inherited from Graphics3D) | Indicates the kind of pen used to draw Canvas lines.
RotationCenter (inherited from Graphics3D) | Sets the Pixel location (using X,Y,Z) of the centre of rotation for use with the Aspect.Rotation property.
RotationCenterFloat (inherited from Graphics3D) | Sets the Pixel location (using X,Y,Z) of the centre of rotation for use with the Aspect.Rotation property.
ScreenHeight (inherited from Graphics3D) | Returns the height, in pixels, of the Chart Panel .
ScreenWidth (inherited from Graphics3D) | Returns the width, in pixels, of the Chart Panel.
Supports3DText (inherited from Graphics3D) | Returns if Canvas supports 3D Text or not.
SupportsFullRotation (inherited from Graphics3D) | Returns if Canvas can do rotation and elevation of more than 90 degree.
SupportsID (inherited from Graphics3D) | Gets and sets whether each TeeChart element drawn is assigned a unique ID.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TextAlign (inherited from Graphics3D) | Sets the alignment used when displaying text using TextOut or TextOut3D.
UseBuffer (inherited from Graphics3D) | Draws items to an internal canvas to prevent flickering on screen.
XCenter (inherited from Graphics3D) | Obtain the X coordinate of the pixel location of the center of the 3D Canvas.
YCenter (inherited from Graphics3D) | Obtain the Y coordinate of the pixel location of the center of the 3D Canvas.

See Also

Graphics3DAndroid Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Graphics3DAndroid Constructor

public Graphics3DAndroid(Chart c)

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Graphics3DAndroidFields

Steema.TeeChart.Drawing.Graphics3DAndroid Fields

Public Fields

FourPoints (inherited from Graphics3D)
IPointDoubles (inherited from Graphics3D)
Monochrome (inherited from Graphics3D)

See Also

Graphics3DAndroid Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Graphics3DAndroidMethods

Steema.TeeChart.Drawing.Graphics3DAndroid Methods

Public Methods

Arc |
Arrow (inherited from Graphics3D) |
Calc3DPoint (inherited from Graphics3D) |
Calc3DPos (inherited from Graphics3D) | Calculates and returns the XY position in pixels of the point p, XYZ 3D coordinate.
CalcRect3D (inherited from Graphics3D) | Calculates and returns the position in pixels of the Rectangle 3D coordinates.
Calculate2DPosition (inherited from Graphics3D) | Calculates and returns the XY position in pixels of the coordinate.
Calculate3DPosition (inherited from Graphics3D) | Calculates and returns the XY position in pixels of the XYZ 3D coordinate.
Changed (inherited from Graphics3D) |
ClearClipRegions | Removes all clipping regions applied to Chart Drawing including Client Clip Regions.
ClipCube (inherited from Graphics3D) | Creates a cubic Windows GDI clipping region.
ClipEllipse | Creates an elliptical clipping region.
ClipPolygon | Creates an polygonal clipping region.
ClipRectangle | Creates a rectangular clipping region.
Cone (inherited from Graphics3D) | Paints a cone. Use ONLY with OPENGL.
ConvexHull (inherited from Graphics3D) | Calculates the boundary points of the convex hull of a set of 2D xy points. Original
Cube (inherited from Graphics3D) | Draws a Cube.
Cylinder (inherited from Graphics3D) | Draws cylinder toggle Boolean for vertical or horizontal cylinder.
DisableRotation (inherited from Graphics3D) |
Draw | Paints the image at x,y coordinates.
DrawBeziers | Draws Bézier splines for the Point array p
DrawPath | Draws a GraphicsPath.
Elevate (inherited from Graphics3D) |
Ellipse | Ellipse bounding Rectangle defined by x1, y1, x2 and y2.
EnableRotation (inherited from Graphics3D) |
EndBlending (inherited from Graphics3D) | Supports OpenGL Transparency
EraseBackground |
FillRectangle (inherited from Graphics3D) |
FillRegion |
FontTextHeight (inherited from Graphics3D) | Determines the Font Height to be used for outputted text when using the Drawing.
FourPointsFromRect (inherited from Graphics3D) | Returns a TFourPoints structure (array of four TPoint records)
Frame3D (inherited from Graphics3D) |
FrontPlaneBegin (inherited from Graphics3D) |
FrontPlaneEnd (inherited from Graphics3D) |
GetArrowPoints (inherited from Graphics3D) |
GetChartPolygon (inherited from Graphics3D) | Returns a z-shifted Region from a Rectangle.
GetClipRoundRectangle (inherited from Graphics3D) | Returns a PointDouble array which contains a Rounded Rectangle.
HorizCone (inherited from Graphics3D) | Paints a cone. Use ONLY with OPENGL.
HorizontalLine | Draws a Horizontal Line.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Line | Draws a Line between co-ordinates.
LineTo | Draws a line from the present PenPos to the new co-ordinates.
LineWithZ (inherited from Graphics3D) |
MeasureString | Returns the SizeF of a string of a specified font.
MoveTo | Sets the value of PenPos to x and y co-ordinates before calling LineTo.
OrientRectangle (inherited from Graphics3D) | Makes sure the R rectangle Left is smaller than Right and Top is smaller than Bottom. Returns corrected rectangle.
PaintBevel (inherited from Graphics3D) |
PaintImageBevel (inherited from Graphics3D) | Draws a custom border around a specified Rectangle.
PathFromPointFs |
PathFromPoints |
Pie (inherited from Graphics3D) | Draws a Pie slice.
Pixel | Sets the 3D pixel to OLE_Color, using Pen.Width.
Plane (inherited from Graphics3D) | Draws a polygon (Point p1, Point p2, Point p3, Point p4) at Z depth offset.
PlaneFour3D (inherited from Graphics3D) | Draws a polygon of four points.
PointFromCircle (inherited from Graphics3D) | Returns the PointDouble which is on the circle bounded by rectBounds at the angle degrees.
PointFromEllipse (inherited from Graphics3D) | Returns the PointDouble which is on the ellipse bounded by rectBounds at the angle degrees.
PointFromSpiral (inherited from Graphics3D) |
Polygon | Draws a polygon.
PolygonBounds (inherited from Graphics3D) | Returns the minimum left / top and the maximum right / bottom for all the points in "p" polygon
PolygonFourDouble (inherited from Graphics3D) |
PolygonPointBounds (inherited from Graphics3D) | Returns a parallelogram of upper-left, upper-right, and lower-left corners.
PolygonRect (inherited from Graphics3D) | Returns bounding rectangle for point array p
Polyline | Draws a series of line segments to join point array p at z displacement
PopMatrix (inherited from Graphics3D) |
PrepareDrawImage |
Projection (inherited from Graphics3D) | Internal use. Calculates the projection co-ordinates for rectangle Bounds
PushMatrix (inherited from Graphics3D) |
Pyramid (inherited from Graphics3D) | Draws a vertical or horizontal Pyramid with optional dark shaded sides.
PyramidTrunc (inherited from Graphics3D) | Draws a pyramid with a truncated apex of variable thickness.
Rectangle | Draws a Rectangle (Rectangle r).
RectangleF (inherited from Graphics3D) |
RectangleWithZ (inherited from Graphics3D) |
RectangleY (inherited from Graphics3D) | Horizontal Rectangle from Left to Right, from Z0 to Z1 position, at Top Y.
RectangleZ (inherited from Graphics3D) | Horizontal Rectangle from Left to Right, from Z0 to Z1 position, at Top Y.
RectFromPolygon (inherited from Graphics3D) | Returns the bounding rectangle for a given array of XY points.
RectFromRectZ (inherited from Graphics3D) | Returns the smallest bounding rectangle containing the four corners of the "R" rectangle after calculating their 3D position.
Rotate (inherited from Graphics3D) |
RotateLabel | Draws a rotated text string at the specified xy coordinates with the RotDegree rotation angle.
RoundRectangle (inherited from Graphics3D) |
SetClipRegion |
SetTextAlign (inherited from Graphics3D) |
ShowImage (inherited from Graphics3D) |
SmoothShadow (inherited from Graphics3D) |
Sphere (inherited from Graphics3D) | Draws a sphere.
StartBlending (inherited from Graphics3D) | Supports OpenGL Transparency
Surface3D (inherited from Graphics3D) |
TeeCull (inherited from Graphics3D) |
TextHeight (inherited from Graphics3D) | Returns the vertical text size in pixels of ChartFont f.
TextOut (inherited from Graphics3D) | Displays 2D non-rotated label at the specified x and y screen coordinates.
TextWidth (inherited from Graphics3D) | Returns the horizontal text size in pixels of ChartFont f.
Translate (inherited from Graphics3D) |
Triangle (inherited from Graphics3D) | Draws a triangle (point p0, pointp1, pointp2) at Z position.
TriSurface (inherited from Graphics3D) |
UnClip | Removes any clipping region applied to Chart Drawing.
UnClipRectangle (inherited from Graphics3D) | Removes any clipping region applied to Chart Drawing.
ValidState (inherited from Graphics3D) | Returns true if the Chart Canvas can be drawn to.
VerticalLine | Draws a Vertical Line from (X,Top) to (X,Bottom).
ZLine (inherited from Graphics3D) | Draws a Line from (X,Y,Z0) to (X,Y,Z1).

See Also

Graphics3DAndroid Class | Steema.TeeChart.Drawing Namespace


Arc

Steema.TeeChart.Drawing.Graphics3DAndroid.Arc Method

Overload List

public override Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Single, System.Single)

Draws an arc in the rectangle defined by the 4 co-ordinates.

public override Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Arc

Steema.TeeChart.Drawing.Graphics3DAndroid.Arc Method

Draws an arc in the rectangle defined by the 4 co-ordinates.
public override Void Arc(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 x3,
     Int32 y3,
     Int32 x4,
     Int32 y4)

See Also

Arc Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Arc

Steema.TeeChart.Drawing.Graphics3DAndroid.Arc Method

public override Void Arc(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Single startAngle,
     Single sweepAngle)

See Also

Arc Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


ClearClipRegions

Steema.TeeChart.Drawing.Graphics3DAndroid.ClearClipRegions Method

Removes all clipping regions applied to Chart Drawing including Client Clip Regions.
public override Void ClearClipRegions()

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


ClipEllipse

Steema.TeeChart.Drawing.Graphics3DAndroid.ClipEllipse Method

Creates an elliptical clipping region.
public override Void ClipEllipse(Rectangle r)

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


ClipPolygon

Steema.TeeChart.Drawing.Graphics3DAndroid.ClipPolygon Method

Creates an polygonal clipping region.
public override Void ClipPolygon(Point[] p)

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


ClipRectangle

Steema.TeeChart.Drawing.Graphics3DAndroid.ClipRectangle Method

Overload List

Creates a rectangular clipping region.

public override Void ClipRectangle(System.Drawing.Rectangle)

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


ClipRectangle

Steema.TeeChart.Drawing.Graphics3DAndroid.ClipRectangle Method

Creates a rectangular clipping region.
public override Void ClipRectangle(Rectangle r)

See Also

ClipRectangle Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Graphics3DAndroid.Draw Method

Overload List

Paints the image at x,y coordinates.

public override Void Draw(System.Int32, System.Int32, Android.Graphics.Bitmap)
public Void Draw(System.Drawing.Point[], Android.Graphics.Bitmap, Steema.TeeChart.Drawing.ImageMode, System.Boolean)

Paints the image in rectangle r.

public override Void Draw(System.Drawing.Rectangle, System.Drawing.Rectangle, Android.Graphics.Bitmap, System.Boolean)

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Graphics3DAndroid.Draw Method

Paints the image in rectangle r.
public override Void Draw(Rectangle destRect,
     Rectangle srcRect,
     Bitmap image,
     Boolean transparent)

See Also

Draw Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Graphics3DAndroid.Draw Method

public Void Draw(Point[] points,
     Bitmap image,
     ImageMode mode,
     Boolean transparent)

See Also

Draw Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Graphics3DAndroid.Draw Method

Paints the image at x,y coordinates.
public override Void Draw(Int32 x,
     Int32 y,
     Bitmap image)

See Also

Draw Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


DrawBeziers

Steema.TeeChart.Drawing.Graphics3DAndroid.DrawBeziers Method

Overload List

Draws Bézier splines for the Point array p

public override Void DrawBeziers(System.Drawing.Point[])

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


DrawBeziers

Steema.TeeChart.Drawing.Graphics3DAndroid.DrawBeziers Method

Draws Bézier splines for the Point array p
public override Void DrawBeziers(Point[] p)

See Also

DrawBeziers Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


DrawPath

Steema.TeeChart.Drawing.Graphics3DAndroid.DrawPath Method

Draws a GraphicsPath.
public override Void DrawPath(Paint pen,
     Path path)

Parameters

pen
Pen that determines the color, width, and style of the path.
path
GraphicsPath to draw.

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Ellipse

Steema.TeeChart.Drawing.Graphics3DAndroid.Ellipse Method

Overload List

Ellipse bounding Rectangle defined by x1, y1, x2 and y2.

public override Void Ellipse(System.Int32, System.Int32, System.Int32, System.Int32)

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Ellipse

Steema.TeeChart.Drawing.Graphics3DAndroid.Ellipse Method

Ellipse bounding Rectangle defined by x1, y1, x2 and y2.
public override Void Ellipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

See Also

Ellipse Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


EraseBackground

Steema.TeeChart.Drawing.Graphics3DAndroid.EraseBackground Method

public override Void EraseBackground(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


FillRegion

Steema.TeeChart.Drawing.Graphics3DAndroid.FillRegion Method

public override Void FillRegion(Paint brush,
     Region region)

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


HorizontalLine

Steema.TeeChart.Drawing.Graphics3DAndroid.HorizontalLine Method

Overload List

Draws a Horizontal Line.

public override Void HorizontalLine(System.Int32, System.Int32, System.Int32)

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


HorizontalLine

Steema.TeeChart.Drawing.Graphics3DAndroid.HorizontalLine Method

Draws a Horizontal Line.
public override Void HorizontalLine(Int32 left,
     Int32 right,
     Int32 y)

See Also

HorizontalLine Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Line

Steema.TeeChart.Drawing.Graphics3DAndroid.Line Method

Overload List

Draws a Line between co-ordinates.

public override Void Line(System.Double, System.Double, System.Double, System.Double)

Draws a Line between points.

public Void Line(System.Drawing.PointF, System.Drawing.PointF)

Draws a Line between co-ordinates.

public override Void Line(System.Int32, System.Int32, System.Int32, System.Int32)

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Line

Steema.TeeChart.Drawing.Graphics3DAndroid.Line Method

Draws a Line between co-ordinates.
public override Void Line(Int32 x0,
     Int32 y0,
     Int32 x1,
     Int32 y1)

See Also

Line Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Line

Steema.TeeChart.Drawing.Graphics3DAndroid.Line Method

Draws a Line between points.
public Void Line(PointF p0,
     PointF p1)

See Also

Line Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Line

Steema.TeeChart.Drawing.Graphics3DAndroid.Line Method

Draws a Line between co-ordinates.
public override Void Line(Double x0,
     Double y0,
     Double x1,
     Double y1)

See Also

Line Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


LineTo

Steema.TeeChart.Drawing.Graphics3DAndroid.LineTo Method

Overload List

Draws a line from the present PenPos to the new co-ordinates.

public override Void LineTo(System.Int32, System.Int32)

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


LineTo

Steema.TeeChart.Drawing.Graphics3DAndroid.LineTo Method

Draws a line from the present PenPos to the new co-ordinates.
public override Void LineTo(Int32 x,
     Int32 y)

See Also

LineTo Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


MeasureString

Steema.TeeChart.Drawing.Graphics3DAndroid.MeasureString Method

Returns the SizeF of a string of a specified font.
public override SizeF MeasureString(ChartFont f,
     String text)

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


MoveTo

Steema.TeeChart.Drawing.Graphics3DAndroid.MoveTo Method

Overload List

Sets the value of PenPos to x and y co-ordinates before calling LineTo.

public override Void MoveTo(System.Int32, System.Int32)

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


MoveTo

Steema.TeeChart.Drawing.Graphics3DAndroid.MoveTo Method

Sets the value of PenPos to x and y co-ordinates before calling LineTo.
public override Void MoveTo(Int32 x,
     Int32 y)

See Also

MoveTo Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


PathFromPointFs

Steema.TeeChart.Drawing.Graphics3DAndroid.PathFromPointFs Method

public static Path PathFromPointFs(PointF[] p)

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


PathFromPoints

Steema.TeeChart.Drawing.Graphics3DAndroid.PathFromPoints Method

public static Path PathFromPoints(Point[] p)

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Pixel

Steema.TeeChart.Drawing.Graphics3DAndroid.Pixel Method

Sets the 3D pixel to OLE_Color, using Pen.Width.
public override Void Pixel(Int32 x,
     Int32 y,
     Int32 z,
     Color color)

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Polygon

Steema.TeeChart.Drawing.Graphics3DAndroid.Polygon Method

Overload List

Draws a polygon.

public override Void Polygon(Steema.TeeChart.Drawing.PointDouble[])

Draws a polygon.

public override Void Polygon(System.Drawing.Point[])

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Polygon

Steema.TeeChart.Drawing.Graphics3DAndroid.Polygon Method

Draws a polygon.
public override Void Polygon(Point[] p)

See Also

Polygon Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Polygon

Steema.TeeChart.Drawing.Graphics3DAndroid.Polygon Method

Draws a polygon.
public override Void Polygon(PointDouble[] p)

See Also

Polygon Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Polyline

Steema.TeeChart.Drawing.Graphics3DAndroid.Polyline Method

Overload List

Draws a series of line segments to join point array p at z displacement

public override Void Polyline(System.Drawing.Point[])

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Polyline

Steema.TeeChart.Drawing.Graphics3DAndroid.Polyline Method

Draws a series of line segments to join point array p at z displacement
public override Void Polyline(Point[] p)

See Also

Polyline Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


PrepareDrawImage

Steema.TeeChart.Drawing.Graphics3DAndroid.PrepareDrawImage Method

public override Void PrepareDrawImage()

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Rectangle

Steema.TeeChart.Drawing.Graphics3DAndroid.Rectangle Method

Overload List

Draws a Rectangle (Rectangle r).

public override Void Rectangle(System.Drawing.Rectangle)

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Rectangle

Steema.TeeChart.Drawing.Graphics3DAndroid.Rectangle Method

Draws a Rectangle (Rectangle r).
public override Void Rectangle(Rectangle r)

See Also

Rectangle Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


RotateLabel

Steema.TeeChart.Drawing.Graphics3DAndroid.RotateLabel Method

Overload List

Draws a rotated text string at the specified xy coordinates with the RotDegree rotation angle.

public override Void RotateLabel(System.Int32, System.Int32, System.String, System.Double)

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


RotateLabel

Steema.TeeChart.Drawing.Graphics3DAndroid.RotateLabel Method

Draws a rotated text string at the specified xy coordinates with the RotDegree rotation angle.
public override Void RotateLabel(Int32 x,
     Int32 y,
     String text,
     Double rotDegree)

See Also

RotateLabel Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


SetClipRegion

Steema.TeeChart.Drawing.Graphics3DAndroid.SetClipRegion Method

Overload List

public override Void SetClipRegion(Android.Graphics.Region)
public override Void SetClipRegion(Android.Graphics.Region, System.Boolean)

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


SetClipRegion

Steema.TeeChart.Drawing.Graphics3DAndroid.SetClipRegion Method

public override Void SetClipRegion(Region region,
     Boolean intersect)

See Also

SetClipRegion Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


SetClipRegion

Steema.TeeChart.Drawing.Graphics3DAndroid.SetClipRegion Method

public override Void SetClipRegion(Region region)

See Also

SetClipRegion Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


UnClip

Steema.TeeChart.Drawing.Graphics3DAndroid.UnClip Method

Removes any clipping region applied to Chart Drawing.
public override Void UnClip()

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


VerticalLine

Steema.TeeChart.Drawing.Graphics3DAndroid.VerticalLine Method

Overload List

Draws a Vertical Line from (X,Top) to (X,Bottom).

public override Void VerticalLine(System.Int32, System.Int32, System.Int32)

See Also

Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


VerticalLine

Steema.TeeChart.Drawing.Graphics3DAndroid.VerticalLine Method

Draws a Vertical Line from (X,Top) to (X,Bottom).
public override Void VerticalLine(Int32 x,
     Int32 top,
     Int32 bottom)

See Also

VerticalLine Overload List | Graphics3DAndroid Class | Graphics3DAndroid Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Graphics3DAndroidProperties

Steema.TeeChart.Drawing.Graphics3DAndroid Properties

Public Properties

BackColor (inherited from Graphics3D) | Sets / returns the color used to fill spaces when displaying text or filling with brushes of different style than bsSolid.
Brush (inherited from Graphics3D) | Determines Brush used to fill the Canvas draw rectangle background.
BufferStyle (inherited from Graphics3D) | Draws items to an internal canvas to prevent flickering on screen.
CanvasType (inherited from Graphics3D) | Gets the type of canvas used to draw the chart.
Chart (inherited from TeeBase) | Chart associated with this object
ChartXCenter (inherited from Graphics3D) | Returns the centre Horizontal co-ordinate of the Chart.
ChartYCenter (inherited from Graphics3D) | Returns the middle Vertical coordinate of the Chart.
Font (inherited from Graphics3D) | Determines Font for outputted text when using the Drawing.
FontHeight (inherited from Graphics3D) | Defines the Height of the Font in pixels.
GDIplusCanvas (inherited from Graphics3D) |
Gradient (inherited from Graphics3D) | Gets and sets the Brush.Gradient properties of the Canvas.
Pen (inherited from Graphics3D) | Indicates the kind of pen used to draw Canvas lines.
RotationCenter (inherited from Graphics3D) | Sets the Pixel location (using X,Y,Z) of the centre of rotation for use with the Aspect.Rotation property.
RotationCenterFloat (inherited from Graphics3D) | Sets the Pixel location (using X,Y,Z) of the centre of rotation for use with the Aspect.Rotation property.
ScreenHeight (inherited from Graphics3D) | Returns the height, in pixels, of the Chart Panel .
ScreenWidth (inherited from Graphics3D) | Returns the width, in pixels, of the Chart Panel.
Supports3DText (inherited from Graphics3D) | Returns if Canvas supports 3D Text or not.
SupportsFullRotation (inherited from Graphics3D) | Returns if Canvas can do rotation and elevation of more than 90 degree.
SupportsID (inherited from Graphics3D) | Gets and sets whether each TeeChart element drawn is assigned a unique ID.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TextAlign (inherited from Graphics3D) | Sets the alignment used when displaying text using TextOut or TextOut3D.
UseBuffer (inherited from Graphics3D) | Draws items to an internal canvas to prevent flickering on screen.
XCenter (inherited from Graphics3D) | Obtain the X coordinate of the pixel location of the center of the 3D Canvas.
YCenter (inherited from Graphics3D) | Obtain the Y coordinate of the pixel location of the center of the 3D Canvas.

See Also

Graphics3DAndroid Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.IDirect2D

Steema.TeeChart.Drawing.IDirect2D Interface

public interface IDirect2D

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

IDirect2D members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.IDirect2DMembers

Steema.TeeChart.Drawing.IDirect2D all Members

IDirect2D overview

Public Methods

Resize

See Also

IDirect2D Interface | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.IDirect2DMethods

Steema.TeeChart.Drawing.IDirect2D Methods

Public Methods

Resize

See Also

IDirect2D Interface | Steema.TeeChart.Drawing Namespace


Resize

Steema.TeeChart.Drawing.IDirect2D.Resize Method

public abstract Void Resize()

See Also

IDirect2D Interface | IDirect2D Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.IGLLightsource

Steema.TeeChart.Drawing.IGLLightsource Interface

public interface IGLLightsource

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

IGLLightsource members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.IGLLightsourceMembers

Steema.TeeChart.Drawing.IGLLightsource all Members

IGLLightsource overview

Public Methods

GLColor

Public Properties

Color
FixedPosition
Position
Visible

See Also

IGLLightsource Interface | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.IGLLightsourceMethods

Steema.TeeChart.Drawing.IGLLightsource Methods

Public Methods

GLColor

See Also

IGLLightsource Interface | Steema.TeeChart.Drawing Namespace


GLColor

Steema.TeeChart.Drawing.IGLLightsource.GLColor Method

public abstract Single[] GLColor()

See Also

IGLLightsource Interface | IGLLightsource Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.IGLLightsourceProperties

Steema.TeeChart.Drawing.IGLLightsource Properties

Public Properties

Color
FixedPosition
Position
Visible

See Also

IGLLightsource Interface | Steema.TeeChart.Drawing Namespace


Color

Steema.TeeChart.Drawing.IGLLightsource.Color Property

public abstract Color Color {get; set;}

See Also

IGLLightsource Interface | IGLLightsource Members | Steema.TeeChart.Drawing Namespace


FixedPosition

Steema.TeeChart.Drawing.IGLLightsource.FixedPosition Property

public abstract Boolean FixedPosition {get; set;}

See Also

IGLLightsource Interface | IGLLightsource Members | Steema.TeeChart.Drawing Namespace


Position

Steema.TeeChart.Drawing.IGLLightsource.Position Property

public abstract IGLPosition Position {get; set;}

See Also

IGLLightsource Interface | IGLLightsource Members | Steema.TeeChart.Drawing Namespace


Visible

Steema.TeeChart.Drawing.IGLLightsource.Visible Property

public abstract Boolean Visible {get; set;}

See Also

IGLLightsource Interface | IGLLightsource Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.IGLPosition

Steema.TeeChart.Drawing.IGLPosition Interface

public interface IGLPosition

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

IGLPosition members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.IGLPositionMembers

Steema.TeeChart.Drawing.IGLPosition all Members

IGLPosition overview

Public Properties

X
Y
Z

See Also

IGLPosition Interface | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.IGLPositionProperties

Steema.TeeChart.Drawing.IGLPosition Properties

Public Properties

X
Y
Z

See Also

IGLPosition Interface | Steema.TeeChart.Drawing Namespace


X

Steema.TeeChart.Drawing.IGLPosition.X Property

public abstract Double X {get; set;}

See Also

IGLPosition Interface | IGLPosition Members | Steema.TeeChart.Drawing Namespace


Y

Steema.TeeChart.Drawing.IGLPosition.Y Property

public abstract Double Y {get; set;}

See Also

IGLPosition Interface | IGLPosition Members | Steema.TeeChart.Drawing Namespace


Z

Steema.TeeChart.Drawing.IGLPosition.Z Property

public abstract Double Z {get; set;}

See Also

IGLPosition Interface | IGLPosition Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ImageBevel

Steema.TeeChart.Drawing.ImageBevel Class

Properties to display bevels (frames) around rectangles.

For a list of all members of this type, see ImageBevel Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public sealed class ImageBevel : TeeBase , ICloneable

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

ImageBevel members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ImageBevelMembers

Steema.TeeChart.Drawing.ImageBevel all Members

ImageBevel overview

Constructors

Constructor

Public Methods

Assign | Assign all properties from a bevel to another.
Clone |
Draw | Draws bevels around rectangle parameter.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Brush | Sets ImageBevel Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
Pen | Sets ImageBevel Pen characteristics.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Visible | Sets the visibility of the Image Bevel.
Width | Draws an Image Bevel of the specified width.

See Also

ImageBevel Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ImageBevel Constructor

public ImageBevel(Chart c)

See Also

ImageBevel Class | ImageBevel Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ImageBevelMethods

Steema.TeeChart.Drawing.ImageBevel Methods

Public Methods

Assign | Assign all properties from a bevel to another.
Clone |
Draw | Draws bevels around rectangle parameter.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

See Also

ImageBevel Class | Steema.TeeChart.Drawing Namespace


Assign

Steema.TeeChart.Drawing.ImageBevel.Assign Method

Assign all properties from a bevel to another.
public Void Assign(ImageBevel b)

See Also

ImageBevel Class | ImageBevel Members | Steema.TeeChart.Drawing Namespace


Clone

Steema.TeeChart.Drawing.ImageBevel.Clone Method

public virtual Object Clone()

See Also

ImageBevel Class | ImageBevel Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.ImageBevel.Draw Method

Draws bevels around rectangle parameter.
public Void Draw(Graphics3D g,
     Rectangle rect,
     Int32 borderRound)

See Also

ImageBevel Class | ImageBevel Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ImageBevelProperties

Steema.TeeChart.Drawing.ImageBevel Properties

Public Properties

Brush | Sets ImageBevel Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
Pen | Sets ImageBevel Pen characteristics.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Visible | Sets the visibility of the Image Bevel.
Width | Draws an Image Bevel of the specified width.

See Also

ImageBevel Class | Steema.TeeChart.Drawing Namespace


Brush

Steema.TeeChart.Drawing.ImageBevel.Brush Property

Sets ImageBevel Brush characteristics.
public ChartBrush Brush {get; set;}

See Also

ImageBevel Class | ImageBevel Members | Steema.TeeChart.Drawing Namespace


Pen

Steema.TeeChart.Drawing.ImageBevel.Pen Property

Sets ImageBevel Pen characteristics.
public ChartPen Pen {get; set;}

See Also

ImageBevel Class | ImageBevel Members | Steema.TeeChart.Drawing Namespace


Visible

Steema.TeeChart.Drawing.ImageBevel.Visible Property

Sets the visibility of the Image Bevel.
public Boolean Visible {get; set;}

See Also

ImageBevel Class | ImageBevel Members | Steema.TeeChart.Drawing Namespace


Width

Steema.TeeChart.Drawing.ImageBevel.Width Property

Draws an Image Bevel of the specified width.
public Int32 Width {get; set;}

See Also

ImageBevel Class | ImageBevel Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ImageMode

Steema.TeeChart.Drawing.ImageMode Enum

Display characteristics for an Image
[Serializable]
public sealed enum ImageMode : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
Normal | Display unmodfied
Stretch | Stretch to bounding area dimensions
Tile | Repeat Tile small image over larger bounding area
Center | Place unmodified image at Center of bounding area

See Also

Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.IOpenGL

Steema.TeeChart.Drawing.IOpenGL Interface

public interface IOpenGL

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

IOpenGL members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.IOpenGLMembers

Steema.TeeChart.Drawing.IOpenGL all Members

IOpenGL overview

Public Methods

SetChart

Public Properties

Active
AmbientLight
DrawStyle
FontExtrusion
FontOutlines
Light0
Light1
Light2
ShadeQuality
Shininess

See Also

IOpenGL Interface | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.IOpenGLMethods

Steema.TeeChart.Drawing.IOpenGL Methods

Public Methods

SetChart

See Also

IOpenGL Interface | Steema.TeeChart.Drawing Namespace


SetChart

Steema.TeeChart.Drawing.IOpenGL.SetChart Method

public abstract Void SetChart(Chart c)

See Also

IOpenGL Interface | IOpenGL Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.IOpenGLProperties

Steema.TeeChart.Drawing.IOpenGL Properties

Public Properties

Active
AmbientLight
DrawStyle
FontExtrusion
FontOutlines
Light0
Light1
Light2
ShadeQuality
Shininess

See Also

IOpenGL Interface | Steema.TeeChart.Drawing Namespace


Active

Steema.TeeChart.Drawing.IOpenGL.Active Property

public abstract Boolean Active {get; set;}

See Also

IOpenGL Interface | IOpenGL Members | Steema.TeeChart.Drawing Namespace


AmbientLight

Steema.TeeChart.Drawing.IOpenGL.AmbientLight Property

public abstract Int32 AmbientLight {get; set;}

See Also

IOpenGL Interface | IOpenGL Members | Steema.TeeChart.Drawing Namespace


DrawStyle

Steema.TeeChart.Drawing.IOpenGL.DrawStyle Property

public abstract SurfaceStyle DrawStyle {get; set;}

See Also

IOpenGL Interface | IOpenGL Members | Steema.TeeChart.Drawing Namespace


FontExtrusion

Steema.TeeChart.Drawing.IOpenGL.FontExtrusion Property

public abstract Int32 FontExtrusion {get; set;}

See Also

IOpenGL Interface | IOpenGL Members | Steema.TeeChart.Drawing Namespace


FontOutlines

Steema.TeeChart.Drawing.IOpenGL.FontOutlines Property

public abstract Boolean FontOutlines {get; set;}

See Also

IOpenGL Interface | IOpenGL Members | Steema.TeeChart.Drawing Namespace


Light0

Steema.TeeChart.Drawing.IOpenGL.Light0 Property

public abstract IGLLightsource Light0 {get;}

See Also

IOpenGL Interface | IOpenGL Members | Steema.TeeChart.Drawing Namespace


Light1

Steema.TeeChart.Drawing.IOpenGL.Light1 Property

public abstract IGLLightsource Light1 {get;}

See Also

IOpenGL Interface | IOpenGL Members | Steema.TeeChart.Drawing Namespace


Light2

Steema.TeeChart.Drawing.IOpenGL.Light2 Property

public abstract IGLLightsource Light2 {get;}

See Also

IOpenGL Interface | IOpenGL Members | Steema.TeeChart.Drawing Namespace


ShadeQuality

Steema.TeeChart.Drawing.IOpenGL.ShadeQuality Property

public abstract Boolean ShadeQuality {get; set;}

See Also

IOpenGL Interface | IOpenGL Members | Steema.TeeChart.Drawing Namespace


Shininess

Steema.TeeChart.Drawing.IOpenGL.Shininess Property

public abstract Double Shininess {get; set;}

See Also

IOpenGL Interface | IOpenGL Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.PathGradientMode

Steema.TeeChart.Drawing.PathGradientMode Enum

[Serializable]
public sealed enum PathGradientMode : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
FromCenter |
Radial |

See Also

Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Point3D

Steema.TeeChart.Drawing.Point3D ValueType

XYZ Point Holder

For a list of all members of this type, see Point3D Members

System.Object
System.ValueType
public sealed struct Point3D : ValueType

See Also

Point3D Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Point3DMembers

Steema.TeeChart.Drawing.Point3D all Members

Point3D overview

Constructors

Constructor Overloaded

Public Fields

Empty
X
Y
Z

See Also

Point3D Structure | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Point3D Constructor

Overload List

public Point3D(System.Int32, System.Int32, System.Int32)
public Point3D(System.Drawing.Point, System.Int32)

See Also

Point3D Structure | Point3D Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Point3D Constructor

public Point3D(Point point,
     Int32 z)

See Also

Point3D Constructor Overload List | Point3D Structure | Point3D Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Point3D Constructor

public Point3D(Int32 x,
     Int32 y,
     Int32 z)

See Also

Point3D Constructor Overload List | Point3D Structure | Point3D Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Point3DFields

Steema.TeeChart.Drawing.Point3D Fields

Public Fields

Empty
X
Y
Z

See Also

Point3D Structure | Steema.TeeChart.Drawing Namespace


Empty

Steema.TeeChart.Drawing.Point3D.Empty Field

public Point3D Empty

See Also

Point3D Structure | Point3D Members | Steema.TeeChart.Drawing Namespace


X

Steema.TeeChart.Drawing.Point3D.X Field

public Int32 X

See Also

Point3D Structure | Point3D Members | Steema.TeeChart.Drawing Namespace


Y

Steema.TeeChart.Drawing.Point3D.Y Field

public Int32 Y

See Also

Point3D Structure | Point3D Members | Steema.TeeChart.Drawing Namespace


Z

Steema.TeeChart.Drawing.Point3D.Z Field

public Int32 Z

See Also

Point3D Structure | Point3D Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Point3DDouble

Steema.TeeChart.Drawing.Point3DDouble ValueType

XYZ Point Holder

For a list of all members of this type, see Point3DDouble Members

System.Object
System.ValueType
public sealed struct Point3DDouble : ValueType

See Also

Point3DDouble Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Point3DDoubleMembers

Steema.TeeChart.Drawing.Point3DDouble all Members

Point3DDouble overview

Public Fields

X
Y
Z

See Also

Point3DDouble Structure | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Point3DDoubleFields

Steema.TeeChart.Drawing.Point3DDouble Fields

Public Fields

X
Y
Z

See Also

Point3DDouble Structure | Steema.TeeChart.Drawing Namespace


X

Steema.TeeChart.Drawing.Point3DDouble.X Field

public Double X

See Also

Point3DDouble Structure | Point3DDouble Members | Steema.TeeChart.Drawing Namespace


Y

Steema.TeeChart.Drawing.Point3DDouble.Y Field

public Double Y

See Also

Point3DDouble Structure | Point3DDouble Members | Steema.TeeChart.Drawing Namespace


Z

Steema.TeeChart.Drawing.Point3DDouble.Z Field

public Double Z

See Also

Point3DDouble Structure | Point3DDouble Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.PointDouble

Steema.TeeChart.Drawing.PointDouble ValueType

XY Point holder

For a list of all members of this type, see PointDouble Members

System.Object
System.ValueType
public sealed struct PointDouble : ValueType

See Also

PointDouble Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.PointDoubleMembers

Steema.TeeChart.Drawing.PointDouble all Members

PointDouble overview

Constructors

Constructor

Public Fields

Empty

Public Methods

FromPoint
Offset
Round
RoundF

Public Properties

IsEmpty
X
Y

See Also

PointDouble Structure | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.PointDouble Constructor

public PointDouble(Double x,
     Double y)

See Also

PointDouble Structure | PointDouble Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.PointDoubleFields

Steema.TeeChart.Drawing.PointDouble Fields

Public Fields

Empty

See Also

PointDouble Structure | Steema.TeeChart.Drawing Namespace


Empty

Steema.TeeChart.Drawing.PointDouble.Empty Field

public readonly PointDouble Empty

See Also

PointDouble Structure | PointDouble Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.PointDoubleMethods

Steema.TeeChart.Drawing.PointDouble Methods

Public Methods

FromPoint
Offset
Round
RoundF

See Also

PointDouble Structure | Steema.TeeChart.Drawing Namespace


FromPoint

Steema.TeeChart.Drawing.PointDouble.FromPoint Method

Overload List

public static PointDouble[] FromPoint(System.Drawing.PointF[])
public static PointDouble FromPoint(System.Drawing.PointF)
public static PointDouble[] FromPoint(System.Drawing.Point[])
public static PointDouble FromPoint(System.Drawing.Point)

See Also

PointDouble Structure | PointDouble Members | Steema.TeeChart.Drawing Namespace


FromPoint

Steema.TeeChart.Drawing.PointDouble.FromPoint Method

public static PointDouble FromPoint(Point point)

See Also

FromPoint Overload List | PointDouble Structure | PointDouble Members | Steema.TeeChart.Drawing Namespace


FromPoint

Steema.TeeChart.Drawing.PointDouble.FromPoint Method

public static PointDouble[] FromPoint(Point[] point)

See Also

FromPoint Overload List | PointDouble Structure | PointDouble Members | Steema.TeeChart.Drawing Namespace


FromPoint

Steema.TeeChart.Drawing.PointDouble.FromPoint Method

public static PointDouble FromPoint(PointF point)

See Also

FromPoint Overload List | PointDouble Structure | PointDouble Members | Steema.TeeChart.Drawing Namespace


FromPoint

Steema.TeeChart.Drawing.PointDouble.FromPoint Method

public static PointDouble[] FromPoint(PointF[] point)

See Also

FromPoint Overload List | PointDouble Structure | PointDouble Members | Steema.TeeChart.Drawing Namespace


Offset

Steema.TeeChart.Drawing.PointDouble.Offset Method

public static PointDouble Offset(PointDouble value,
     Double x,
     Double y)

See Also

PointDouble Structure | PointDouble Members | Steema.TeeChart.Drawing Namespace


Round

Steema.TeeChart.Drawing.PointDouble.Round Method

Overload List

public static Point Round(Steema.TeeChart.Drawing.PointDouble)
public static Point[] Round(Steema.TeeChart.Drawing.PointDouble[])

See Also

PointDouble Structure | PointDouble Members | Steema.TeeChart.Drawing Namespace


Round

Steema.TeeChart.Drawing.PointDouble.Round Method

public static Point[] Round(PointDouble[] value)

See Also

Round Overload List | PointDouble Structure | PointDouble Members | Steema.TeeChart.Drawing Namespace


Round

Steema.TeeChart.Drawing.PointDouble.Round Method

public static Point Round(PointDouble value)

See Also

Round Overload List | PointDouble Structure | PointDouble Members | Steema.TeeChart.Drawing Namespace


RoundF

Steema.TeeChart.Drawing.PointDouble.RoundF Method

Overload List

public static PointF RoundF(Steema.TeeChart.Drawing.PointDouble)
public static PointF[] RoundF(Steema.TeeChart.Drawing.PointDouble[])

See Also

PointDouble Structure | PointDouble Members | Steema.TeeChart.Drawing Namespace


RoundF

Steema.TeeChart.Drawing.PointDouble.RoundF Method

public static PointF[] RoundF(PointDouble[] value)

See Also

RoundF Overload List | PointDouble Structure | PointDouble Members | Steema.TeeChart.Drawing Namespace


RoundF

Steema.TeeChart.Drawing.PointDouble.RoundF Method

public static PointF RoundF(PointDouble value)

See Also

RoundF Overload List | PointDouble Structure | PointDouble Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.PointDoubleProperties

Steema.TeeChart.Drawing.PointDouble Properties

Public Properties

IsEmpty
X
Y

See Also

PointDouble Structure | Steema.TeeChart.Drawing Namespace


IsEmpty

Steema.TeeChart.Drawing.PointDouble.IsEmpty Property

public Boolean IsEmpty {get;}

See Also

PointDouble Structure | PointDouble Members | Steema.TeeChart.Drawing Namespace


X

Steema.TeeChart.Drawing.PointDouble.X Property

public Double X {get; set;}

See Also

PointDouble Structure | PointDouble Members | Steema.TeeChart.Drawing Namespace


Y

Steema.TeeChart.Drawing.PointDouble.Y Property

public Double Y {get; set;}

See Also

PointDouble Structure | PointDouble Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.PointXYZ

Steema.TeeChart.Drawing.PointXYZ Class

XYZ Point holder

For a list of all members of this type, see PointXYZ Members

System.Object
public class PointXYZ : Object

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

PointXYZ members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.PointXYZMembers

Steema.TeeChart.Drawing.PointXYZ all Members

PointXYZ overview

Constructors

Constructor Overloaded

Public Properties

X | This property gets or sets the X location in pixels.
Y | This property gets or sets the Y location in pixels.
Z | This property gets or sets the Z location in pixels.

See Also

PointXYZ Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.PointXYZ Constructor

Overload List

public PointXYZ()
public PointXYZ(System.Int32, System.Int32, System.Int32)

See Also

PointXYZ Class | PointXYZ Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.PointXYZ Constructor

public PointXYZ(Int32 x,
     Int32 y,
     Int32 z)

See Also

PointXYZ Constructor Overload List | PointXYZ Class | PointXYZ Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.PointXYZ Constructor

public PointXYZ()

See Also

PointXYZ Constructor Overload List | PointXYZ Class | PointXYZ Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.PointXYZProperties

Steema.TeeChart.Drawing.PointXYZ Properties

Public Properties

X | This property gets or sets the X location in pixels.
Y | This property gets or sets the Y location in pixels.
Z | This property gets or sets the Z location in pixels.

See Also

PointXYZ Class | Steema.TeeChart.Drawing Namespace


X

Steema.TeeChart.Drawing.PointXYZ.X Property

This property gets or sets the X location in pixels.
public Int32 X {get; set;}

See Also

PointXYZ Class | PointXYZ Members | Steema.TeeChart.Drawing Namespace


Y

Steema.TeeChart.Drawing.PointXYZ.Y Property

This property gets or sets the Y location in pixels.
public Int32 Y {get; set;}

See Also

PointXYZ Class | PointXYZ Members | Steema.TeeChart.Drawing Namespace


Z

Steema.TeeChart.Drawing.PointXYZ.Z Property

This property gets or sets the Z location in pixels.
public Int32 Z {get; set;}

See Also

PointXYZ Class | PointXYZ Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Shadow

Steema.TeeChart.Drawing.Shadow Class

Properties to draw a shadow.

For a list of all members of this type, see Shadow Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class Shadow : TeeBase , ICloneable

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

Shadow members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ShadowMembers

Steema.TeeChart.Drawing.Shadow all Members

Shadow overview

Constructors

Constructor Overloaded Chart Shadow Constructor

Public Methods

Assign | Assign characteristics of Shadow 'value'
Clone |
Draw | Draws a shadow around the Rect rectangle parameter.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

Public Properties

BlurSize |
Brush | Defines the Brush characteristics to fill the shadow.
Chart (inherited from TeeBase) | Chart associated with this object
Clip |
Color | Gets or sets Color used to fill.
Height | Sets the vertical displacement of the shadow in pixels.
HorizSize |
Size | Size in pixels of shadow.
Smooth | Gets and sets if the shadow will be displayed as a rectangle with smooth edges.
SmoothBlur | Gets and sets if the shadow will be displayed as a rectangle with smooth edges.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency | Sets Transparency level from 0 to 100% of shadow.
VertSize |
Visible | Determines whether the shadow will appear on screen.
Width | Sets the horizontal shadow size in pixels.

See Also

Shadow Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Shadow Constructor

Overload List

Chart Shadow Constructor

public Shadow(Steema.TeeChart.Chart)

Chart Shadow Constructor, defines Shadow size

public Shadow(Steema.TeeChart.Chart, System.Int32)

See Also

Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Shadow Constructor

Chart Shadow Constructor, defines Shadow size
public Shadow(Chart c,
     Int32 size)

See Also

Shadow Constructor Overload List | Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Shadow Constructor

Chart Shadow Constructor
public Shadow(Chart c)

See Also

Shadow Constructor Overload List | Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ShadowMethods

Steema.TeeChart.Drawing.Shadow Methods

Public Methods

Assign | Assign characteristics of Shadow 'value'
Clone |
Draw | Draws a shadow around the Rect rectangle parameter.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

See Also

Shadow Class | Steema.TeeChart.Drawing Namespace


Assign

Steema.TeeChart.Drawing.Shadow.Assign Method

Assign characteristics of Shadow 'value'
public Void Assign(Shadow value)

See Also

Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Clone

Steema.TeeChart.Drawing.Shadow.Clone Method

public virtual Object Clone()

See Also

Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Shadow.Draw Method

Overload List

Draws a shadow around the Rect rectangle parameter.

public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Drawing.Rectangle)

Draws a shadow around the ellipse described by the top left and botton right parameters.

public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Int32, System.Int32, System.Int32, System.Int32)

Draws a shadow around the ellipse described by the top left and botton right parameters.

public abstract Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

Draws a shadow around the polygon described by the array of points parameter.

public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Int32, System.Int32, System.Drawing.Point[])

Draws a shadow around the polygon described by the array of points parameter.

public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Int32, System.Int32, Steema.TeeChart.Drawing.PointDouble[])

Draws a shadow around the Rect rectangle parameter.

public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Drawing.Rectangle, System.Int32, System.Int32, System.Int32)

Draws a shadow around the Rect rectangle parameter.

public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Drawing.Rectangle, System.Int32, System.Int32)

See Also

Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Shadow.Draw Method

Draws a shadow around the Rect rectangle parameter.
public Void Draw(Graphics3D g,
     Rectangle rect,
     Int32 angle,
     Int32 aZ)

See Also

Draw Overload List | Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Shadow.Draw Method

Draws a shadow around the Rect rectangle parameter.
public Void Draw(Graphics3D g,
     Rectangle rect,
     Int32 roundSize,
     Int32 angle,
     Int32 aZ)

See Also

Draw Overload List | Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Shadow.Draw Method

Draws a shadow around the polygon described by the array of points parameter.
public Void Draw(Graphics3D g,
     Int32 aWidth,
     Int32 aHeight,
     PointDouble[] points)

See Also

Draw Overload List | Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Shadow.Draw Method

Draws a shadow around the polygon described by the array of points parameter.
public Void Draw(Graphics3D g,
     Int32 aWidth,
     Int32 aHeight,
     Point[] points)

See Also

Draw Overload List | Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Shadow.Draw Method

Draws a shadow around the ellipse described by the top left and botton right parameters.
public abstract Void Draw(Graphics3D g,
     Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 z)

See Also

Draw Overload List | Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Shadow.Draw Method

Draws a shadow around the ellipse described by the top left and botton right parameters.
public Void Draw(Graphics3D g,
     Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

See Also

Draw Overload List | Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Draw

Steema.TeeChart.Drawing.Shadow.Draw Method

Draws a shadow around the Rect rectangle parameter.
public Void Draw(Graphics3D g,
     Rectangle rect)

See Also

Draw Overload List | Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ShadowProperties

Steema.TeeChart.Drawing.Shadow Properties

Public Properties

BlurSize |
Brush | Defines the Brush characteristics to fill the shadow.
Chart (inherited from TeeBase) | Chart associated with this object
Clip |
Color | Gets or sets Color used to fill.
Height | Sets the vertical displacement of the shadow in pixels.
HorizSize |
Size | Size in pixels of shadow.
Smooth | Gets and sets if the shadow will be displayed as a rectangle with smooth edges.
SmoothBlur | Gets and sets if the shadow will be displayed as a rectangle with smooth edges.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency | Sets Transparency level from 0 to 100% of shadow.
VertSize |
Visible | Determines whether the shadow will appear on screen.
Width | Sets the horizontal shadow size in pixels.

See Also

Shadow Class | Steema.TeeChart.Drawing Namespace


BlurSize

Steema.TeeChart.Drawing.Shadow.BlurSize Property

public Int32 BlurSize {get; set;}

See Also

Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Brush

Steema.TeeChart.Drawing.Shadow.Brush Property

Defines the Brush characteristics to fill the shadow.
public ChartBrush Brush {get;}

See Also

Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Clip

Steema.TeeChart.Drawing.Shadow.Clip Property

public Boolean Clip {get; set;}

See Also

Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Color

Steema.TeeChart.Drawing.Shadow.Color Property

Gets or sets Color used to fill.
public Color Color {get; set;}

See Also

Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Height

Steema.TeeChart.Drawing.Shadow.Height Property

Sets the vertical displacement of the shadow in pixels.
public Int32 Height {get; set;}

See Also

Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


HorizSize

Steema.TeeChart.Drawing.Shadow.HorizSize Property

public Int32 HorizSize {get; set;}

See Also

Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Size

Steema.TeeChart.Drawing.Shadow.Size Property

Size in pixels of shadow.
public Size Size {get; set;}

See Also

Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Smooth

Steema.TeeChart.Drawing.Shadow.Smooth Property

Gets and sets if the shadow will be displayed as a rectangle with smooth edges.
public Boolean Smooth {get; set;}

See Also

Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


SmoothBlur

Steema.TeeChart.Drawing.Shadow.SmoothBlur Property

Gets and sets if the shadow will be displayed as a rectangle with smooth edges.
public Int32 SmoothBlur {get; set;}

See Also

Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Transparency

Steema.TeeChart.Drawing.Shadow.Transparency Property

Sets Transparency level from 0 to 100% of shadow.
public Int32 Transparency {get; set;}

See Also

Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


VertSize

Steema.TeeChart.Drawing.Shadow.VertSize Property

public Int32 VertSize {get; set;}

See Also

Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Visible

Steema.TeeChart.Drawing.Shadow.Visible Property

Determines whether the shadow will appear on screen.
public Boolean Visible {get; set;}

See Also

Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Width

Steema.TeeChart.Drawing.Shadow.Width Property

Sets the horizontal shadow size in pixels.
public Int32 Width {get; set;}

See Also

Shadow Class | Shadow Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Shape

Steema.TeeChart.Drawing.Shape Class

Base class for Chart Shape elements

For a list of all members of this type, see Shape Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class Shape : TeeBase , ICloneable

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

Shape members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ShapeMembers

Steema.TeeChart.Drawing.Shape all Members

Shape overview

Constructors

Constructor Overloaded

Public Methods

Assign | Assign all properties from a shape to another.
Clone |
CreateNewShape | Creates a new Shape object and sets the Chart property.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
NewFromType | Creates a new series from the System.Type of an existing series object.
Paint |

Public Properties

Bevel | Sets the bevel characteristics of the Shape.
BevelInner |
BevelOuter |
BevelWidth |
BorderRound | Rounds the Borders of the Chart Shapes.
Bottom | Shape rectangle bottom co-ordinate
Brush | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
Color | Defines the shape Color.
Gradient | Calls the Gradient characteristics for the shape.
Height | The Height of the shape.
Image | Rendered Image for Shape background
ImageBevel | Sets the bevel characteristics of the Shape.
ImageMode | ImageMode for rendered Shape background Image
ImageTransparent | Sets the shape image to transparent.
Left | Shape rectangle left co-ordinate
Pen | Specifies the pen used to draw the shape.
Right | Shape rectangle right co-ordinate
Shadow | Defines the shape's Shadow characteristics.
ShapeBounds | Defines the boundaries of the Shape.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top | Shape rectangle top co-ordinate
Transparency | Sets Transparency level from 0 to 100% of shape.
Transparent | Enables/disables transparency of shape.
Visible | Shows or hides the Shape.
Width | The Width of the shape.

See Also

Shape Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Shape Constructor

Overload List

public Shape()
public Shape(Steema.TeeChart.Chart)

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Shape Constructor

public Shape(Chart c)

See Also

Shape Constructor Overload List | Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Shape Constructor

public Shape()

See Also

Shape Constructor Overload List | Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ShapeMethods

Steema.TeeChart.Drawing.Shape Methods

Public Methods

Assign | Assign all properties from a shape to another.
Clone |
CreateNewShape | Creates a new Shape object and sets the Chart property.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
NewFromType | Creates a new series from the System.Type of an existing series object.
Paint |

See Also

Shape Class | Steema.TeeChart.Drawing Namespace


Assign

Steema.TeeChart.Drawing.Shape.Assign Method

Assign all properties from a shape to another.
public Void Assign(Shape s)

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Clone

Steema.TeeChart.Drawing.Shape.Clone Method

public virtual Object Clone()

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


CreateNewShape

Steema.TeeChart.Drawing.Shape.CreateNewShape Method

Creates a new Shape object and sets the Chart property.
public static Shape CreateNewShape(Chart chart,
     Type type)

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


NewFromType

Steema.TeeChart.Drawing.Shape.NewFromType Method

Creates a new series from the System.Type of an existing series object.
public static Shape NewFromType(Type type)

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Paint

Steema.TeeChart.Drawing.Shape.Paint Method

public abstract Void Paint(Graphics3D g,
     Rectangle rect)

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ShapeProperties

Steema.TeeChart.Drawing.Shape Properties

Public Properties

Bevel | Sets the bevel characteristics of the Shape.
BevelInner |
BevelOuter |
BevelWidth |
BorderRound | Rounds the Borders of the Chart Shapes.
Bottom | Shape rectangle bottom co-ordinate
Brush | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
Color | Defines the shape Color.
Gradient | Calls the Gradient characteristics for the shape.
Height | The Height of the shape.
Image | Rendered Image for Shape background
ImageBevel | Sets the bevel characteristics of the Shape.
ImageMode | ImageMode for rendered Shape background Image
ImageTransparent | Sets the shape image to transparent.
Left | Shape rectangle left co-ordinate
Pen | Specifies the pen used to draw the shape.
Right | Shape rectangle right co-ordinate
Shadow | Defines the shape's Shadow characteristics.
ShapeBounds | Defines the boundaries of the Shape.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top | Shape rectangle top co-ordinate
Transparency | Sets Transparency level from 0 to 100% of shape.
Transparent | Enables/disables transparency of shape.
Visible | Shows or hides the Shape.
Width | The Width of the shape.

See Also

Shape Class | Steema.TeeChart.Drawing Namespace


Bevel

Steema.TeeChart.Drawing.Shape.Bevel Property

Sets the bevel characteristics of the Shape.
public Bevel Bevel {get;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


BevelInner

Steema.TeeChart.Drawing.Shape.BevelInner Property

public BevelStyles BevelInner {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


BevelOuter

Steema.TeeChart.Drawing.Shape.BevelOuter Property

public BevelStyles BevelOuter {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


BevelWidth

Steema.TeeChart.Drawing.Shape.BevelWidth Property

public Int32 BevelWidth {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


BorderRound

Steema.TeeChart.Drawing.Shape.BorderRound Property

Rounds the Borders of the Chart Shapes.
public Int32 BorderRound {get; set;}

Example

This sample shows how to use the BorderRound property:

private void numericUpDown1_ValueChanged(object sender, System.EventArgs e) {
    tChart1.Panel.BorderRound = (int)numericUpDown1.Value;
}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Bottom

Steema.TeeChart.Drawing.Shape.Bottom Property

Shape rectangle bottom co-ordinate
public Int32 Bottom {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Brush

Steema.TeeChart.Drawing.Shape.Brush Property

Defines the kind of brush used to fill shape background.
public ChartBrush Brush {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Color

Steema.TeeChart.Drawing.Shape.Color Property

Defines the shape Color.
public Color Color {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Gradient

Steema.TeeChart.Drawing.Shape.Gradient Property

Calls the Gradient characteristics for the shape.
public Gradient Gradient {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Height

Steema.TeeChart.Drawing.Shape.Height Property

The Height of the shape.
public Int32 Height {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Image

Steema.TeeChart.Drawing.Shape.Image Property

Rendered Image for Shape background
public Bitmap Image {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


ImageBevel

Steema.TeeChart.Drawing.Shape.ImageBevel Property

Sets the bevel characteristics of the Shape.
public ImageBevel ImageBevel {get;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


ImageMode

Steema.TeeChart.Drawing.Shape.ImageMode Property

ImageMode for rendered Shape background Image
public ImageMode ImageMode {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


ImageTransparent

Steema.TeeChart.Drawing.Shape.ImageTransparent Property

Sets the shape image to transparent.
public Boolean ImageTransparent {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Left

Steema.TeeChart.Drawing.Shape.Left Property

Shape rectangle left co-ordinate
public Int32 Left {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Pen

Steema.TeeChart.Drawing.Shape.Pen Property

Specifies the pen used to draw the shape.
public ChartPen Pen {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Right

Steema.TeeChart.Drawing.Shape.Right Property

Shape rectangle right co-ordinate
public Int32 Right {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Shadow

Steema.TeeChart.Drawing.Shape.Shadow Property

Defines the shape's Shadow characteristics.
public Shadow Shadow {get;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


ShapeBounds

Steema.TeeChart.Drawing.Shape.ShapeBounds Property

Defines the boundaries of the Shape.
public Rectangle ShapeBounds {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Top

Steema.TeeChart.Drawing.Shape.Top Property

Shape rectangle top co-ordinate
public Int32 Top {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Transparency

Steema.TeeChart.Drawing.Shape.Transparency Property

Sets Transparency level from 0 to 100% of shape.
public Int32 Transparency {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Transparent

Steema.TeeChart.Drawing.Shape.Transparent Property

Enables/disables transparency of shape.
public Boolean Transparent {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Visible

Steema.TeeChart.Drawing.Shape.Visible Property

Shows or hides the Shape.
public Boolean Visible {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Width

Steema.TeeChart.Drawing.Shape.Width Property

The Width of the shape.
public Int32 Width {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ShapeSize

Steema.TeeChart.Drawing.ShapeSize Class

Size holder

For a list of all members of this type, see ShapeSize Members

System.Object
public class ShapeSize : Object

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

ShapeSize members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ShapeSizeMembers

Steema.TeeChart.Drawing.ShapeSize all Members

ShapeSize overview

Constructors

Constructor

Public Fields

Height
Width

See Also

ShapeSize Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ShapeSize Constructor

public ShapeSize()

See Also

ShapeSize Class | ShapeSize Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ShapeSizeFields

Steema.TeeChart.Drawing.ShapeSize Fields

Public Fields

Height
Width

See Also

ShapeSize Class | Steema.TeeChart.Drawing Namespace


Height

Steema.TeeChart.Drawing.ShapeSize.Height Field

public Int32 Height

See Also

ShapeSize Class | ShapeSize Members | Steema.TeeChart.Drawing Namespace


Width

Steema.TeeChart.Drawing.ShapeSize.Width Field

public Int32 Width

See Also

ShapeSize Class | ShapeSize Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.SurfaceStyle

Steema.TeeChart.Drawing.SurfaceStyle Enum

[Serializable]
public sealed enum SurfaceStyle : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Solid |
Wire |
Dot |

See Also

Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TCanvas3DPlane

Steema.TeeChart.Drawing.TCanvas3DPlane Enum

[Serializable]
public sealed enum TCanvas3DPlane : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
cpX |
cpY |
cpZ |

See Also

Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TCanvasBackMode

Steema.TeeChart.Drawing.TCanvasBackMode Enum

[Serializable]
public sealed enum TCanvasBackMode : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
None |
Opaque |
Transparent |

See Also

Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TeeBase

Steema.TeeChart.Drawing.TeeBase Class

Non-visible class for Chart element common characteristics

For a list of all members of this type, see TeeBase Members

System.Object
public class TeeBase : Object

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

TeeBase members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TeeBaseMembers

Steema.TeeChart.Drawing.TeeBase all Members

TeeBase overview

Constructors

Constructor Overloaded

Public Methods

Invalidate Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Chart | Chart associated with this object
Tag | Gets or sets an object that provides additional data about the TChart object.

See Also

TeeBase Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TeeBase Constructor

Overload List

public TeeBase(Steema.TeeChart.Chart)
public TeeBase()

See Also

TeeBase Class | TeeBase Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TeeBase Constructor

public TeeBase()

See Also

TeeBase Constructor Overload List | TeeBase Class | TeeBase Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TeeBase Constructor

public TeeBase(Chart c)

See Also

TeeBase Constructor Overload List | TeeBase Class | TeeBase Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TeeBaseMethods

Steema.TeeChart.Drawing.TeeBase Methods

Public Methods

Invalidate Use Invalidate when the entire canvas needs to be repainted.

See Also

TeeBase Class | Steema.TeeChart.Drawing Namespace


Invalidate

Steema.TeeChart.Drawing.TeeBase.Invalidate Method

Use Invalidate when the entire canvas needs to be repainted.
public abstract Void Invalidate()

See Also

TeeBase Class | TeeBase Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TeeBaseProperties

Steema.TeeChart.Drawing.TeeBase Properties

Public Properties

Chart | Chart associated with this object
Tag | Gets or sets an object that provides additional data about the TChart object.

See Also

TeeBase Class | Steema.TeeChart.Drawing Namespace


Chart

Steema.TeeChart.Drawing.TeeBase.Chart Property

Chart associated with this object
public Chart Chart {get; set;}

See Also

TeeBase Class | TeeBase Members | Steema.TeeChart.Drawing Namespace


Tag

Steema.TeeChart.Drawing.TeeBase.Tag Property

Gets or sets an object that provides additional data about the TChart object.
public Object Tag {get; set;}

See Also

TeeBase Class | TeeBase Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TeeFontStyle

Steema.TeeChart.Drawing.TeeFontStyle Enum

[Serializable]
public sealed enum TeeFontStyle : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Bitmap |
Normal |
Outline |

See Also

Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TextFormat

Steema.TeeChart.Drawing.TextFormat Enum

[Serializable]
public sealed enum TextFormat : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
Normal |
Html |

See Also

Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TextShape

Steema.TeeChart.Drawing.TextShape Class

Base class for Chart shape elements with text

For a list of all members of this type, see TextShape Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
public class TextShape : Shape , ICloneable

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

TextShape members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TextShapeMembers

Steema.TeeChart.Drawing.TextShape all Members

TextShape overview

Constructors

Constructor Overloaded

Public Fields

Size

Public Methods

Assign | Assign all properties from a TextShape to another.
Clone (inherited from Shape) |
DrawRectRotated | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint | Paints the TextShape object on the Chart Canvas.

Public Properties

AutoSize |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText |
Color (inherited from Shape) | Defines the shape Color.
Font | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text | The Text property is used to display customized strings inside Shapes.
TextAlign |
TextFormat | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

TextShape Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TextShape Constructor

Overload List

public TextShape()
public TextShape(Steema.TeeChart.Chart)

See Also

TextShape Class | TextShape Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TextShape Constructor

public TextShape(Chart c)

See Also

TextShape Constructor Overload List | TextShape Class | TextShape Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TextShape Constructor

public TextShape()

See Also

TextShape Constructor Overload List | TextShape Class | TextShape Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TextShapeFields

Steema.TeeChart.Drawing.TextShape Fields

Public Fields

Size

See Also

TextShape Class | Steema.TeeChart.Drawing Namespace


Size

Steema.TeeChart.Drawing.TextShape.Size Field

public ShapeSize Size

See Also

TextShape Class | TextShape Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TextShapeMethods

Steema.TeeChart.Drawing.TextShape Methods

Public Methods

Assign | Assign all properties from a TextShape to another.
Clone (inherited from Shape) |
DrawRectRotated | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint | Paints the TextShape object on the Chart Canvas.

See Also

TextShape Class | Steema.TeeChart.Drawing Namespace


Assign

Steema.TeeChart.Drawing.TextShape.Assign Method

Overload List

Assign all properties from a TextShape to another.

public Void Assign(Steema.TeeChart.Drawing.TextShape)

See Also

TextShape Class | TextShape Members | Steema.TeeChart.Drawing Namespace


Assign

Steema.TeeChart.Drawing.TextShape.Assign Method

Assign all properties from a TextShape to another.
public Void Assign(TextShape s)

See Also

Assign Overload List | TextShape Class | TextShape Members | Steema.TeeChart.Drawing Namespace


DrawRectRotated

Steema.TeeChart.Drawing.TextShape.DrawRectRotated Method

Draws the Shape rectangle rotated by Angle degrees.
public Void DrawRectRotated(Graphics3D g,
     Rectangle rect,
     Int32 angle,
     Int32 aZ)

See Also

TextShape Class | TextShape Members | Steema.TeeChart.Drawing Namespace


Paint

Steema.TeeChart.Drawing.TextShape.Paint Method

Overload List

Paints the TextShape object on the Chart Canvas.

public Void Paint()

Paints the TextShape object on the Chart Canvas.

public Void Paint(Steema.TeeChart.Drawing.Graphics3D)

Paints the TextShape object on the Chart Canvas.

public override Void Paint(Steema.TeeChart.Drawing.Graphics3D, System.Drawing.Rectangle)

See Also

TextShape Class | TextShape Members | Steema.TeeChart.Drawing Namespace


Paint

Steema.TeeChart.Drawing.TextShape.Paint Method

Paints the TextShape object on the Chart Canvas.
public override Void Paint(Graphics3D g,
     Rectangle rect)

See Also

Paint Overload List | TextShape Class | TextShape Members | Steema.TeeChart.Drawing Namespace


Paint

Steema.TeeChart.Drawing.TextShape.Paint Method

Paints the TextShape object on the Chart Canvas.
public Void Paint(Graphics3D g)

See Also

Paint Overload List | TextShape Class | TextShape Members | Steema.TeeChart.Drawing Namespace


Paint

Steema.TeeChart.Drawing.TextShape.Paint Method

Paints the TextShape object on the Chart Canvas.
public Void Paint()

See Also

Paint Overload List | TextShape Class | TextShape Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TextShapeProperties

Steema.TeeChart.Drawing.TextShape Properties

Public Properties

AutoSize |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText |
Color (inherited from Shape) | Defines the shape Color.
Font | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text | The Text property is used to display customized strings inside Shapes.
TextAlign |
TextFormat | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

TextShape Class | Steema.TeeChart.Drawing Namespace


AutoSize

Steema.TeeChart.Drawing.TextShape.AutoSize Property

public Boolean AutoSize {get; set;}

See Also

TextShape Class | TextShape Members | Steema.TeeChart.Drawing Namespace


ClipText

Steema.TeeChart.Drawing.TextShape.ClipText Property

public Boolean ClipText {get; set;}

See Also

TextShape Class | TextShape Members | Steema.TeeChart.Drawing Namespace


Font

Steema.TeeChart.Drawing.TextShape.Font Property

Determines the font attributes used to output ShapeSeries.Text strings.
public ChartFont Font {get; set;}

See Also

TextShape Class | TextShape Members | Steema.TeeChart.Drawing Namespace


Lines

Steema.TeeChart.Drawing.TextShape.Lines Property

Access to array of Text lines
public String[] Lines {get; set;}

See Also

TextShape Class | TextShape Members | Steema.TeeChart.Drawing Namespace


ShadowSize

Steema.TeeChart.Drawing.TextShape.ShadowSize Property

public Int32 ShadowSize {get; set;}

See Also

TextShape Class | TextShape Members | Steema.TeeChart.Drawing Namespace


ShapeStyle

Steema.TeeChart.Drawing.TextShape.ShapeStyle Property

Shape may be rectagular or rounded rectangular.
public TextShapeStyle ShapeStyle {get; set;}

See Also

TextShape Class | TextShape Members | Steema.TeeChart.Drawing Namespace


Text

Steema.TeeChart.Drawing.TextShape.Text Property

The Text property is used to display customized strings inside Shapes.
public String Text {get; set;}

See Also

TextShape Class | TextShape Members | Steema.TeeChart.Drawing Namespace


TextAlign

Steema.TeeChart.Drawing.TextShape.TextAlign Property

public Align TextAlign {get; set;}

See Also

TextShape Class | TextShape Members | Steema.TeeChart.Drawing Namespace


TextFormat

Steema.TeeChart.Drawing.TextShape.TextFormat Property

Determines if Text is drawn as Normal or HTML styles.
public TextFormat TextFormat {get; set;}

See Also

TextShape Class | TextShape Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TextShapePosition

Steema.TeeChart.Drawing.TextShapePosition Class

Shape Custom Position

For a list of all members of this type, see TextShapePosition Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
public class TextShapePosition : TextShape , ICloneable

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

TextShapePosition members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TextShapePositionMembers

Steema.TeeChart.Drawing.TextShapePosition all Members

TextShapePosition overview

Constructors

Constructor Overloaded

Public Fields

Size (inherited from TextShape)

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.

Public Properties

AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
CustomPosition | Set to true to permit custom positioning of TextShape.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

TextShapePosition Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TextShapePosition Constructor

Overload List

public TextShapePosition()
public TextShapePosition(Steema.TeeChart.Chart)

See Also

TextShapePosition Class | TextShapePosition Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TextShapePosition Constructor

public TextShapePosition(Chart c)

See Also

TextShapePosition Constructor Overload List | TextShapePosition Class | TextShapePosition Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TextShapePosition Constructor

public TextShapePosition()

See Also

TextShapePosition Constructor Overload List | TextShapePosition Class | TextShapePosition Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TextShapePositionFields

Steema.TeeChart.Drawing.TextShapePosition Fields

Public Fields

Size (inherited from TextShape)

See Also

TextShapePosition Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TextShapePositionMethods

Steema.TeeChart.Drawing.TextShapePosition Methods

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.

See Also

TextShapePosition Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TextShapePositionProperties

Steema.TeeChart.Drawing.TextShapePosition Properties

Public Properties

AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
CustomPosition | Set to true to permit custom positioning of TextShape.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

TextShapePosition Class | Steema.TeeChart.Drawing Namespace


CustomPosition

Steema.TeeChart.Drawing.TextShapePosition.CustomPosition Property

Set to true to permit custom positioning of TextShape.
public Boolean CustomPosition {get; set;}

See Also

TextShapePosition Class | TextShapePosition Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TextShapeStyle

Steema.TeeChart.Drawing.TextShapeStyle Enum

Defines the style of text-containing shapes.
[Serializable]
public sealed enum TextShapeStyle : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Rectangle | Defines a Rectangular shape.
RoundRectangle | Defines a Rounded Rectangular shape.

See Also

Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.ThreeDPlane

Steema.TeeChart.Drawing.ThreeDPlane Enum

orientation
[Serializable]
public sealed enum ThreeDPlane : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
cpX |
cpY |
cpZ |

See Also

Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Triangle2D

Steema.TeeChart.Drawing.Triangle2D ValueType

Triangular 2D element holder

For a list of all members of this type, see Triangle2D Members

System.Object
System.ValueType
public sealed struct Triangle2D : ValueType

See Also

Triangle2D Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Triangle2DMembers

Steema.TeeChart.Drawing.Triangle2D all Members

Triangle2D overview

Public Fields

p0
p1
p2

See Also

Triangle2D Structure | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Triangle2DFields

Steema.TeeChart.Drawing.Triangle2D Fields

Public Fields

p0
p1
p2

See Also

Triangle2D Structure | Steema.TeeChart.Drawing Namespace


p0

Steema.TeeChart.Drawing.Triangle2D.p0 Field

public Point p0

See Also

Triangle2D Structure | Triangle2D Members | Steema.TeeChart.Drawing Namespace


p1

Steema.TeeChart.Drawing.Triangle2D.p1 Field

public Point p1

See Also

Triangle2D Structure | Triangle2D Members | Steema.TeeChart.Drawing Namespace


p2

Steema.TeeChart.Drawing.Triangle2D.p2 Field

public Point p2

See Also

Triangle2D Structure | Triangle2D Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Triangle3D

Steema.TeeChart.Drawing.Triangle3D ValueType

Triangular 3D element holder

For a list of all members of this type, see Triangle3D Members

System.Object
System.ValueType
public sealed struct Triangle3D : ValueType

See Also

Triangle3D Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Triangle3DMembers

Steema.TeeChart.Drawing.Triangle3D all Members

Triangle3D overview

Public Fields

p0
p1
p2

See Also

Triangle3D Structure | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.Triangle3DFields

Steema.TeeChart.Drawing.Triangle3D Fields

Public Fields

p0
p1
p2

See Also

Triangle3D Structure | Steema.TeeChart.Drawing Namespace


p0

Steema.TeeChart.Drawing.Triangle3D.p0 Field

public Point3D p0

See Also

Triangle3D Structure | Triangle3D Members | Steema.TeeChart.Drawing Namespace


p1

Steema.TeeChart.Drawing.Triangle3D.p1 Field

public Point3D p1

See Also

Triangle3D Structure | Triangle3D Members | Steema.TeeChart.Drawing Namespace


p2

Steema.TeeChart.Drawing.Triangle3D.p2 Field

public Point3D p2

See Also

Triangle3D Structure | Triangle3D Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TTeeCanvasCalcPoints

Steema.TeeChart.Drawing.TTeeCanvasCalcPoints Delegate

public delegate TTeeCanvasCalcPoints (Int32 x,
     Int32 z,
     Point3D& P0,
     Point3D& P1,
     Color& Color0,
     Color& Color1)

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TTeeCanvasTriPoints

Steema.TeeChart.Drawing.TTeeCanvasTriPoints Delegate

public delegate TTeeCanvasTriPoints (Int32 Index,
     Point3D[]& Points,
     Color[]& Colors,
     Triangle3D& Indexes,
     TTriangleIndexes& TriangleIndexes)

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TTeeTransparency

Steema.TeeChart.Drawing.TTeeTransparency Enum

[Serializable]
public sealed enum TTeeTransparency : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
MaxValue |
MinValue |

See Also

Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TTriangleIndexes

Steema.TeeChart.Drawing.TTriangleIndexes ValueType

For a list of all members of this type, see TTriangleIndexes Members

System.Object
System.ValueType
public sealed struct TTriangleIndexes : ValueType

See Also

TTriangleIndexes Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TTriangleIndexesMembers

Steema.TeeChart.Drawing.TTriangleIndexes all Members

TTriangleIndexes overview

Public Fields

Point0
Point1
Point2

See Also

TTriangleIndexes Structure | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.TTriangleIndexesFields

Steema.TeeChart.Drawing.TTriangleIndexes Fields

Public Fields

Point0
Point1
Point2

See Also

TTriangleIndexes Structure | Steema.TeeChart.Drawing Namespace


Point0

Steema.TeeChart.Drawing.TTriangleIndexes.Point0 Field

public Int32 Point0

See Also

TTriangleIndexes Structure | TTriangleIndexes Members | Steema.TeeChart.Drawing Namespace


Point1

Steema.TeeChart.Drawing.TTriangleIndexes.Point1 Field

public Int32 Point1

See Also

TTriangleIndexes Structure | TTriangleIndexes Members | Steema.TeeChart.Drawing Namespace


Point2

Steema.TeeChart.Drawing.TTriangleIndexes.Point2 Field

public Int32 Point2

See Also

TTriangleIndexes Structure | TTriangleIndexes Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.View3DEvent

Steema.TeeChart.Drawing.View3DEvent Class

Notify class for Aspect related activity

For a list of all members of this type, see View3DEvent Members

System.Object
Steema.TeeChart.TeeEvent
public class View3DEvent : TeeEvent

Requirements

Namespace: Steema.TeeChart.Drawing Namespace

Assembly: TeeChart.Android.dll

See Also

View3DEvent members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.View3DEventMembers

Steema.TeeChart.Drawing.View3DEvent all Members

View3DEvent overview

Constructors

Constructor

Public Fields

sender (inherited from TeeEvent)

See Also

View3DEvent Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.View3DEvent Constructor

public View3DEvent()

See Also

View3DEvent Class | View3DEvent Members | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Drawing.View3DEventFields

Steema.TeeChart.Drawing.View3DEvent Fields

Public Fields

sender (inherited from TeeEvent)

See Also

View3DEvent Class | Steema.TeeChart.Drawing Namespace


Steema.TeeChart.Functions

Steema.TeeChart.Functions Namespace

Namespace hierarchy

Public Classes

Function | Basic functions (Add, Subtract, High, Low, Average and Count).
ADXFunction | The ADXFunction is normally used in financial trending applications to determine whether a market is trending, or moving sideways. A high ADX reading indicates a trending market. A rising ADX indicates a trending market (either up or down). If the ADX reaches 40 or greater, look for a signal that indicates the trend is over. An ADX of 20 or less indicates a sideways market.
Moving | Internal use. Base class for moving calculation functions
MovingAverage | Moving Average Function
Add | Add Function.
ManySeries | Internal use. Base class for multiple Series function calculations
Subtract | Subtract Function.
Multiply | Multiply Function.
Divide | Divide Function.
High | High Function. Returns highest value.
Low | Low Function. Returns lowest value.
Average | Average (mean) Function.
Count | Count Function.
Cumulative | Cumulative Function. The TCumulative function sums the Series values starting from the first point. Example: Given these values: 1 2 3 The TCumulative function returns: 1 3 6 ( 1=1, 1+2=3 and 1+2+3=6 )
Momentum | Momentum Function.
MomentumDivision | Momentum Division Function.
ExpAverage | Exponential Average Function.
ExpMovAverage | Exponential Moving Average Function
Bollinger | Summary description for Bollinger.
CCIFunction | CCI Function.
CLVFunction | CLV Function.
CompressOHLC | CompressOHLC Function.
CompressGetDateEventArgs | EventArgs for CompressGetDateHandler
CrossPoints | CrossPoints Function.
BaseTrend | Internal use. Base class for different trend functions.
ExpTrendFunction | The Exponential Trend function is similar to Trend, except that the calculation fits values using their exponential (e) weights.
TrendFunction | Trendline function
CorrelationFunction | Correlation function
PolyFitting | Base class for fitting function(s)
Custom | Custom y=f(x) function
CalculateEventArgs | EventArgs for CalculateEventHandler
CustomSorted | Intermediate abstract class used by MedianFunction and ModeFunction to calculate values using the source series values sorted in ascending order.
DownSampling | Reduces the number of points in series by using several different methods.
HistogramFunction | Constructs a histogram or cumulative histogram from data.
MACDFunction | The MACD function (Moving Average Convergence Divergence), used in financial charts.
MedianFunction | Calculates the median value of the source series values. The median value is different than the average in that median returns the value that is "at the middle" of the source series values ordered in ascending order. If more than one value shares the middle position, this function returns the average of those values.
ModeFunction | The mode function returns the source series value that is most more times.
OBVFunction | OBV Function.
Performance | Performance Function.
PerimeterFunction | Perimeter function.
Regression |
Poly |
PVOFunction | PVO Function.
RootMeanSquare | Root Mean Square Function.
RSIFunction | RSIFunction is a Line Series derived component that calculates a percent value based on Financial data. RSIFunction must be connected to a OHLC Series or any derived Series component (e.g. Candle). Like a MovingAverage Function, RSI will calculate a new point Y value by using previous Period points. The used formula is: Add all Close prices greater than Open prices and divide by ocurrences (Ups). Add all Close prices lower than Open prices and divide by ocurrences (Downs). RSI = 100.0 - ( 100.0 / ( 1.0 + Math.Abs( Ups / Downs ) ) ) To see a visual representation of TeeChart Extended Functions, go to the TeeChart User Guide.
SARFunction | Parabolic Stop And Reversal financial indicator.
Smoothing | Smoothing Function.
Spline | Spline smoothing.
StdDeviation | Standard Deviation Function.
Stochastic | Stochastic Function.
VarianceFunction | Variance function.

Public Enumerations

PeriodStyles | Descibes function period as a number of points or as a range of points.
PeriodAligns | Descibes how a function is aligned with respect to the source series.
CompressionPeriod | Describes the possible values of the Compress property.
TrendStyles | Defines different trend styles.
DownSamplingMethod | Defines type of downsampling method.
RSIStyle | Used in see cref="RSIFunction.Style"/> property.

Public Delegates

CompressGetDateHandler |
CalculateEventHandler | Internal use. Function calculation event handler

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll


Steema.TeeChart.Functions Hierarchy

System.Object

Steema.TeeChart.Drawing.TeeBase

Steema.TeeChart.Functions.Function

Steema.TeeChart.Functions.Add

Steema.TeeChart.Functions.ADXFunction

Steema.TeeChart.Functions.Average

Steema.TeeChart.Functions.BaseTrend

Steema.TeeChart.Functions.CorrelationFunction

Steema.TeeChart.Functions.ExpTrendFunction

Steema.TeeChart.Functions.TrendFunction

Steema.TeeChart.Functions.Bollinger

Steema.TeeChart.Functions.CCIFunction

Steema.TeeChart.Functions.CLVFunction

Steema.TeeChart.Functions.CompressOHLC

Steema.TeeChart.Functions.Count

Steema.TeeChart.Functions.CrossPoints

Steema.TeeChart.Functions.Cumulative

Steema.TeeChart.Functions.Custom

Steema.TeeChart.Functions.CustomSorted

Steema.TeeChart.Functions.MedianFunction

Steema.TeeChart.Functions.ModeFunction

Steema.TeeChart.Functions.DownSampling

Steema.TeeChart.Functions.ExpMovAverage

Steema.TeeChart.Functions.High

Steema.TeeChart.Functions.HistogramFunction

Steema.TeeChart.Functions.Low

Steema.TeeChart.Functions.ManySeries

Steema.TeeChart.Functions.Divide

Steema.TeeChart.Functions.Multiply

Steema.TeeChart.Functions.Subtract

Steema.TeeChart.Functions.Moving

Steema.TeeChart.Functions.ExpAverage

Steema.TeeChart.Functions.MACDFunction

Steema.TeeChart.Functions.Momentum

Steema.TeeChart.Functions.MomentumDivision

Steema.TeeChart.Functions.MovingAverage

Steema.TeeChart.Functions.Performance

Steema.TeeChart.Functions.RSIFunction

Steema.TeeChart.Functions.Stochastic

Steema.TeeChart.Functions.OBVFunction

Steema.TeeChart.Functions.PerimeterFunction

Steema.TeeChart.Functions.PolyFitting

Steema.TeeChart.Functions.PVOFunction

Steema.TeeChart.Functions.RootMeanSquare

Steema.TeeChart.Functions.SARFunction

Steema.TeeChart.Functions.Smoothing

Steema.TeeChart.Functions.StdDeviation

Steema.TeeChart.Functions.VarianceFunction

Steema.TeeChart.Functions.Poly

Steema.TeeChart.Functions.Regression

Steema.TeeChart.Functions.Spline

System.EventArgs

Steema.TeeChart.Functions.CalculateEventArgs

Steema.TeeChart.Functions.CompressGetDateEventArgs

See Also

SteemaTeeChartFunctions Namespace


Steema.TeeChart.Functions.Add

Steema.TeeChart.Functions.Add Class

Add Function.

For a list of all members of this type, see Add Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class Add : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

Add members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.AddMembers

Steema.TeeChart.Functions.Add all Members

Add overview

Constructors

Constructor

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Add Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Add Constructor

public Add()

See Also

Add Class | Add Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.AddMethods

Steema.TeeChart.Functions.Add Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

Add Class | Steema.TeeChart.Functions Namespace


Calculate

Steema.TeeChart.Functions.Add.Calculate Method

Performs function operation on SourceSeries series.
public override Double Calculate(Series sourceSeries,
     Int32 firstIndex,
     Int32 lastIndex)

See Also

Add Class | Add Members | Steema.TeeChart.Functions Namespace


CalculateMany

Steema.TeeChart.Functions.Add.CalculateMany Method

Performs function operation on list of series (SourceSeriesList).
public override Double CalculateMany(ArrayList sourceSeriesList,
     Int32 valueIndex)

See Also

Add Class | Add Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.Add.Description Method

public override String Description()

See Also

Add Class | Add Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.AddProperties

Steema.TeeChart.Functions.Add Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Add Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ADXFunction

Steema.TeeChart.Functions.ADXFunction Class

The ADXFunction is normally used in financial trending applications to determine whether a market is trending, or moving sideways. A high ADX reading indicates a trending market. A rising ADX indicates a trending market (either up or down). If the ADX reaches 40 or greater, look for a signal that indicates the trend is over. An ADX of 20 or less indicates a sideways market.

For a list of all members of this type, see ADXFunction Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class ADXFunction : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

ADXFunction members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ADXFunctionMembers

Steema.TeeChart.Functions.ADXFunction all Members

ADXFunction overview

Constructors

Constructor Overloaded

Public Methods

AddPoints | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
DMDown | Access characteristics of the DMDown line (a FastLineSeries). DMDown is a sub-series (of type FastLine) of ADX function.
DMUp | Access characteristics of the DMUp line (a FastLineSeries). DMUp is a sub-series (of type FastLine) of ADX function.
DownLinePen | The pen used to draw the lower ADX line. Corresponds to DMDown.Pen property.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
UpLinePen The pen used to draw the upper ADX line. Corresponds to DMUp.Pen property.
aDXFunction1.UpLinePen.Color = Color.Blue ;

See Also

ADXFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ADXFunction Constructor

Overload List

public ADXFunction()
public ADXFunction(Steema.TeeChart.Chart)
public ADXFunction(Steema.TeeChart.Styles.FastLine, Steema.TeeChart.Styles.FastLine)

See Also

ADXFunction Class | ADXFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ADXFunction Constructor

public ADXFunction(FastLine dmDown,
     FastLine dmUp)

See Also

ADXFunction Constructor Overload List | ADXFunction Class | ADXFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ADXFunction Constructor

public ADXFunction(Chart c)

See Also

ADXFunction Constructor Overload List | ADXFunction Class | ADXFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ADXFunction Constructor

public ADXFunction()

See Also

ADXFunction Constructor Overload List | ADXFunction Class | ADXFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ADXFunctionMethods

Steema.TeeChart.Functions.ADXFunction Methods

Public Methods

AddPoints | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

ADXFunction Class | Steema.TeeChart.Functions Namespace


AddPoints

Steema.TeeChart.Functions.ADXFunction.AddPoints Method

Gets all points from Source series, performs a function operation and stores results in ParentSeries.
public override Void AddPoints(Array source)

See Also

ADXFunction Class | ADXFunction Members | Steema.TeeChart.Functions Namespace


Clear

Steema.TeeChart.Functions.ADXFunction.Clear Method

public override Void Clear()

See Also

ADXFunction Class | ADXFunction Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.ADXFunction.Description Method

public override String Description()

See Also

ADXFunction Class | ADXFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ADXFunctionProperties

Steema.TeeChart.Functions.ADXFunction Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
DMDown | Access characteristics of the DMDown line (a FastLineSeries). DMDown is a sub-series (of type FastLine) of ADX function.
DMUp | Access characteristics of the DMUp line (a FastLineSeries). DMUp is a sub-series (of type FastLine) of ADX function.
DownLinePen | The pen used to draw the lower ADX line. Corresponds to DMDown.Pen property.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
UpLinePen The pen used to draw the upper ADX line. Corresponds to DMUp.Pen property.
aDXFunction1.UpLinePen.Color = Color.Blue ;

See Also

ADXFunction Class | Steema.TeeChart.Functions Namespace


DMDown

Steema.TeeChart.Functions.ADXFunction.DMDown Property

Access characteristics of the DMDown line (a FastLineSeries). DMDown is a sub-series (of type FastLine) of ADX function.
public FastLine DMDown {get; set;}

See Also

ADXFunction Class | ADXFunction Members | Steema.TeeChart.Functions Namespace


DMUp

Steema.TeeChart.Functions.ADXFunction.DMUp Property

Access characteristics of the DMUp line (a FastLineSeries). DMUp is a sub-series (of type FastLine) of ADX function.
public FastLine DMUp {get; set;}

See Also

ADXFunction Class | ADXFunction Members | Steema.TeeChart.Functions Namespace


DownLinePen

Steema.TeeChart.Functions.ADXFunction.DownLinePen Property

The pen used to draw the lower ADX line. Corresponds to DMDown.Pen property.
public ChartPen DownLinePen {get; set;}

See Also

ADXFunction Class | ADXFunction Members | Steema.TeeChart.Functions Namespace


UpLinePen

Steema.TeeChart.Functions.ADXFunction.UpLinePen Property

The pen used to draw the upper ADX line. Corresponds to DMUp.Pen property.
aDXFunction1.UpLinePen.Color = Color.Blue ;

public ChartPen UpLinePen {get; set;}

See Also

ADXFunction Class | ADXFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Average

Steema.TeeChart.Functions.Average Class

Average (mean) Function.

For a list of all members of this type, see Average Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class Average : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

Average members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.AverageMembers

Steema.TeeChart.Functions.Average all Members

Average overview

Constructors

Constructor Overloaded

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
IncludeNulls | Calculates the average using only the non-null points of a series, or not.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Average Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Average Constructor

Overload List

public Average()
public Average(System.Boolean)

See Also

Average Class | Average Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Average Constructor

public Average(Boolean UseNulls)

See Also

Average Constructor Overload List | Average Class | Average Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Average Constructor

public Average()

See Also

Average Constructor Overload List | Average Class | Average Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.AverageMethods

Steema.TeeChart.Functions.Average Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

Average Class | Steema.TeeChart.Functions Namespace


Calculate

Steema.TeeChart.Functions.Average.Calculate Method

Performs function operation on SourceSeries series.
public override Double Calculate(Series sourceSeries,
     Int32 firstIndex,
     Int32 lastIndex)

See Also

Average Class | Average Members | Steema.TeeChart.Functions Namespace


CalculateMany

Steema.TeeChart.Functions.Average.CalculateMany Method

Performs function operation on list of series (SourceSeriesList).
public override Double CalculateMany(ArrayList sourceSeriesList,
     Int32 valueIndex)

See Also

Average Class | Average Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.Average.Description Method

public override String Description()

See Also

Average Class | Average Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.AverageProperties

Steema.TeeChart.Functions.Average Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
IncludeNulls | Calculates the average using only the non-null points of a series, or not.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Average Class | Steema.TeeChart.Functions Namespace


IncludeNulls

Steema.TeeChart.Functions.Average.IncludeNulls Property

Calculates the average using only the non-null points of a series, or not.
public Boolean IncludeNulls {get; set;}

See Also

Average Class | Average Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.BaseTrend

Steema.TeeChart.Functions.BaseTrend Class

Internal use. Base class for different trend functions.

For a list of all members of this type, see BaseTrend Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class BaseTrend : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

BaseTrend members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.BaseTrendMembers

Steema.TeeChart.Functions.BaseTrend all Members

BaseTrend overview

Constructors

Constructor Overloaded

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate |
CalculateMany |
CalculateTrend | Calculates trendline paramaters m and b, where y=m*x+b
Clear (inherited from Function) |
Description (inherited from Function) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
RSquared |
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TrendStyle | Defines different methods for calculating trendline
UseDecimals | Gets and sets whether System.Decimal is used instead of System.Double for the internal algorithms. When true, algorithms are more accurate but accept a smaller range of numbers.

See Also

BaseTrend Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.BaseTrend Constructor

Overload List

public BaseTrend()
public BaseTrend(Steema.TeeChart.Chart)

See Also

BaseTrend Class | BaseTrend Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.BaseTrend Constructor

public BaseTrend(Chart c)

See Also

BaseTrend Constructor Overload List | BaseTrend Class | BaseTrend Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.BaseTrend Constructor

public BaseTrend()

See Also

BaseTrend Constructor Overload List | BaseTrend Class | BaseTrend Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.BaseTrendMethods

Steema.TeeChart.Functions.BaseTrend Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate |
CalculateMany |
CalculateTrend | Calculates trendline paramaters m and b, where y=m*x+b
Clear (inherited from Function) |
Description (inherited from Function) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

BaseTrend Class | Steema.TeeChart.Functions Namespace


Calculate

Steema.TeeChart.Functions.BaseTrend.Calculate Method

public override Double Calculate(Series s,
     Int32 firstIndex,
     Int32 lastIndex)

See Also

BaseTrend Class | BaseTrend Members | Steema.TeeChart.Functions Namespace


CalculateMany

Steema.TeeChart.Functions.BaseTrend.CalculateMany Method

public override Double CalculateMany(ArrayList sourceSeriesList,
     Int32 valueIndex)

See Also

BaseTrend Class | BaseTrend Members | Steema.TeeChart.Functions Namespace


CalculateTrend

Steema.TeeChart.Functions.BaseTrend.CalculateTrend Method

Overload List

Calculates trendline paramaters m and b, where y=m*x+b

public Boolean CalculateTrend(Steema.TeeChart.Styles.Series, System.Int32, System.Int32, System.Double&, System.Double&)

Calculates trendline paramaters m and b, where y=m*x+b

public Boolean CalculateTrend(Steema.TeeChart.Styles.Series, System.Int32, System.Int32, System.Decimal&, System.Decimal&)

See Also

BaseTrend Class | BaseTrend Members | Steema.TeeChart.Functions Namespace


CalculateTrend

Steema.TeeChart.Functions.BaseTrend.CalculateTrend Method

Calculates trendline paramaters m and b, where y=m*x+b
public Boolean CalculateTrend(Series s,
     Int32 firstIndex,
     Int32 lastIndex,
     Decimal& m,
     Decimal& b)

Parameters

s
firstIndex
lastIndex
m
Calculated line parameter
b
Calculated line parameter

Return Value

See Also

CalculateTrend Overload List | BaseTrend Class | BaseTrend Members | Steema.TeeChart.Functions Namespace


CalculateTrend

Steema.TeeChart.Functions.BaseTrend.CalculateTrend Method

Calculates trendline paramaters m and b, where y=m*x+b
public Boolean CalculateTrend(Series s,
     Int32 firstIndex,
     Int32 lastIndex,
     Double& m,
     Double& b)

Parameters

s
firstIndex
lastIndex
m
Calculated line parameter
b
Calculated line parameter

Return Value

See Also

CalculateTrend Overload List | BaseTrend Class | BaseTrend Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.BaseTrendProperties

Steema.TeeChart.Functions.BaseTrend Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
RSquared |
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TrendStyle | Defines different methods for calculating trendline
UseDecimals | Gets and sets whether System.Decimal is used instead of System.Double for the internal algorithms. When true, algorithms are more accurate but accept a smaller range of numbers.

See Also

BaseTrend Class | Steema.TeeChart.Functions Namespace


RSquared

Steema.TeeChart.Functions.BaseTrend.RSquared Property

public Double RSquared {get;}

See Also

BaseTrend Class | BaseTrend Members | Steema.TeeChart.Functions Namespace


TrendStyle

Steema.TeeChart.Functions.BaseTrend.TrendStyle Property

Defines different methods for calculating trendline
public TrendStyles TrendStyle {get; set;}

See Also

BaseTrend Class | BaseTrend Members | Steema.TeeChart.Functions Namespace


UseDecimals

Steema.TeeChart.Functions.BaseTrend.UseDecimals Property

Gets and sets whether System.Decimal is used instead of System.Double for the internal algorithms. When true, algorithms are more accurate but accept a smaller range of numbers.
public Boolean UseDecimals {get; set;}

See Also

BaseTrend Class | BaseTrend Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Bollinger

Steema.TeeChart.Functions.Bollinger Class

Summary description for Bollinger.

For a list of all members of this type, see Bollinger Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class Bollinger : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

Bollinger members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.BollingerMembers

Steema.TeeChart.Functions.Bollinger all Members

Bollinger overview

Constructors

Constructor Overloaded

Public Methods

AddPoints |
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Deviation | Deviation defines the standard deviation (StdDev) multiplier, used to calculate low and high Bollinger band value.
Exponential | When Exponential is true, then exponential moving average function will be used to calculate mean value. Otherwise standard moving average function will be used to calculate mean value.
LowBand | LowBand Series stores the low band (Mean - Deviation*StdDev) values. High band values (Mean + Deviation*StdDev) values are stored in the ParentSeries.
LowBandPen | The pen use to display the lower band line. Corresponds to LowBand.Pen property.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
UpperBandPen | The pen used to display the upper band line.

See Also

Bollinger Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Bollinger Constructor

Overload List

public Bollinger()
public Bollinger(Steema.TeeChart.Chart)
public Bollinger(Steema.TeeChart.Styles.FastLine)

See Also

Bollinger Class | Bollinger Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Bollinger Constructor

public Bollinger(FastLine lowBand)

See Also

Bollinger Constructor Overload List | Bollinger Class | Bollinger Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Bollinger Constructor

public Bollinger(Chart c)

See Also

Bollinger Constructor Overload List | Bollinger Class | Bollinger Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Bollinger Constructor

public Bollinger()

See Also

Bollinger Constructor Overload List | Bollinger Class | Bollinger Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.BollingerMethods

Steema.TeeChart.Functions.Bollinger Methods

Public Methods

AddPoints |
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

Bollinger Class | Steema.TeeChart.Functions Namespace


AddPoints

Steema.TeeChart.Functions.Bollinger.AddPoints Method

public override Void AddPoints(Array source)

See Also

Bollinger Class | Bollinger Members | Steema.TeeChart.Functions Namespace


Clear

Steema.TeeChart.Functions.Bollinger.Clear Method

public override Void Clear()

See Also

Bollinger Class | Bollinger Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.Bollinger.Description Method

public override String Description()

See Also

Bollinger Class | Bollinger Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.BollingerProperties

Steema.TeeChart.Functions.Bollinger Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Deviation | Deviation defines the standard deviation (StdDev) multiplier, used to calculate low and high Bollinger band value.
Exponential | When Exponential is true, then exponential moving average function will be used to calculate mean value. Otherwise standard moving average function will be used to calculate mean value.
LowBand | LowBand Series stores the low band (Mean - Deviation*StdDev) values. High band values (Mean + Deviation*StdDev) values are stored in the ParentSeries.
LowBandPen | The pen use to display the lower band line. Corresponds to LowBand.Pen property.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
UpperBandPen | The pen used to display the upper band line.

See Also

Bollinger Class | Steema.TeeChart.Functions Namespace


Deviation

Steema.TeeChart.Functions.Bollinger.Deviation Property

Deviation defines the standard deviation (StdDev) multiplier, used to calculate low and high Bollinger band value.
public Double Deviation {get; set;}

See Also

Bollinger Class | Bollinger Members | Steema.TeeChart.Functions Namespace


Exponential

Steema.TeeChart.Functions.Bollinger.Exponential Property

When Exponential is true, then exponential moving average function will be used to calculate mean value. Otherwise standard moving average function will be used to calculate mean value.
public Boolean Exponential {get; set;}

See Also

Bollinger Class | Bollinger Members | Steema.TeeChart.Functions Namespace


LowBand

Steema.TeeChart.Functions.Bollinger.LowBand Property

LowBand Series stores the low band (Mean - Deviation*StdDev) values. High band values (Mean + Deviation*StdDev) values are stored in the ParentSeries.
public FastLine LowBand {get; set;}

See Also

Bollinger Class | Bollinger Members | Steema.TeeChart.Functions Namespace


LowBandPen

Steema.TeeChart.Functions.Bollinger.LowBandPen Property

The pen use to display the lower band line. Corresponds to LowBand.Pen property.
public ChartPen LowBandPen {get; set;}

See Also

Bollinger Class | Bollinger Members | Steema.TeeChart.Functions Namespace


UpperBandPen

Steema.TeeChart.Functions.Bollinger.UpperBandPen Property

The pen used to display the upper band line.
public ChartPen UpperBandPen {get; set;}

See Also

Bollinger Class | Bollinger Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CalculateEventArgs

Steema.TeeChart.Functions.CalculateEventArgs Class

EventArgs for CalculateEventHandler

For a list of all members of this type, see CalculateEventArgs Members

System.Object
System.EventArgs
public class CalculateEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

CalculateEventArgs members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CalculateEventArgsMembers

Steema.TeeChart.Functions.CalculateEventArgs all Members

CalculateEventArgs overview

Constructors

Constructor

Public Fields

Y

Public Properties

X Returns the current X parameter.

See Also

CalculateEventArgs Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CalculateEventArgs Constructor

public CalculateEventArgs(Double x,
     Double y)

See Also

CalculateEventArgs Class | CalculateEventArgs Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CalculateEventArgsFields

Steema.TeeChart.Functions.CalculateEventArgs Fields

Public Fields

Y

See Also

CalculateEventArgs Class | Steema.TeeChart.Functions Namespace


Y

Steema.TeeChart.Functions.CalculateEventArgs.Y Field

public Double Y

See Also

CalculateEventArgs Class | CalculateEventArgs Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CalculateEventArgsProperties

Steema.TeeChart.Functions.CalculateEventArgs Properties

Public Properties

X Returns the current X parameter.

See Also

CalculateEventArgs Class | Steema.TeeChart.Functions Namespace


X

Steema.TeeChart.Functions.CalculateEventArgs.X Property

Returns the current X parameter.
public Double X {get;}

See Also

CalculateEventArgs Class | CalculateEventArgs Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CalculateEventHandler

Steema.TeeChart.Functions.CalculateEventHandler Delegate

Internal use. Function calculation event handler
public delegate CalculateEventHandler (Object sender,
     CalculateEventArgs e)

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CCIFunction

Steema.TeeChart.Functions.CCIFunction Class

CCI Function.

For a list of all members of this type, see CCIFunction Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class CCIFunction : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

CCIFunction members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CCIFunctionMembers

Steema.TeeChart.Functions.CCIFunction all Members

CCIFunction overview

Constructors

Constructor Overloaded

Public Methods

AddPoints | Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Constant | Value by which to multiply mean deviation.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

CCIFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CCIFunction Constructor

Overload List

public CCIFunction()
public CCIFunction(Steema.TeeChart.Chart)

See Also

CCIFunction Class | CCIFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CCIFunction Constructor

public CCIFunction(Chart c)

See Also

CCIFunction Constructor Overload List | CCIFunction Class | CCIFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CCIFunction Constructor

public CCIFunction()

See Also

CCIFunction Constructor Overload List | CCIFunction Class | CCIFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CCIFunctionMethods

Steema.TeeChart.Functions.CCIFunction Methods

Public Methods

AddPoints | Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

CCIFunction Class | Steema.TeeChart.Functions Namespace


AddPoints

Steema.TeeChart.Functions.CCIFunction.AddPoints Method

Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
public override Void AddPoints(Array source)

See Also

CCIFunction Class | CCIFunction Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.CCIFunction.Description Method

public override String Description()

See Also

CCIFunction Class | CCIFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CCIFunctionProperties

Steema.TeeChart.Functions.CCIFunction Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Constant | Value by which to multiply mean deviation.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

CCIFunction Class | Steema.TeeChart.Functions Namespace


Constant

Steema.TeeChart.Functions.CCIFunction.Constant Property

Value by which to multiply mean deviation.
public Double Constant {get; set;}

See Also

CCIFunction Class | CCIFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CLVFunction

Steema.TeeChart.Functions.CLVFunction Class

CLV Function.

For a list of all members of this type, see CLVFunction Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class CLVFunction : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

CLVFunction members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CLVFunctionMembers

Steema.TeeChart.Functions.CLVFunction all Members

CLVFunction overview

Constructors

Constructor Overloaded

Public Methods

AddPoints | Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Accumulate | Accumulates the CLV Function results.
Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Volume | Gets/sets the Volume series by which CLV results are multiplied.

See Also

CLVFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CLVFunction Constructor

Overload List

public CLVFunction()
public CLVFunction(Steema.TeeChart.Chart)

See Also

CLVFunction Class | CLVFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CLVFunction Constructor

public CLVFunction(Chart c)

See Also

CLVFunction Constructor Overload List | CLVFunction Class | CLVFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CLVFunction Constructor

public CLVFunction()

See Also

CLVFunction Constructor Overload List | CLVFunction Class | CLVFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CLVFunctionMethods

Steema.TeeChart.Functions.CLVFunction Methods

Public Methods

AddPoints | Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

CLVFunction Class | Steema.TeeChart.Functions Namespace


AddPoints

Steema.TeeChart.Functions.CLVFunction.AddPoints Method

Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
public override Void AddPoints(Array source)

See Also

CLVFunction Class | CLVFunction Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.CLVFunction.Description Method

public override String Description()

See Also

CLVFunction Class | CLVFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CLVFunctionProperties

Steema.TeeChart.Functions.CLVFunction Properties

Public Properties

Accumulate | Accumulates the CLV Function results.
Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Volume | Gets/sets the Volume series by which CLV results are multiplied.

See Also

CLVFunction Class | Steema.TeeChart.Functions Namespace


Accumulate

Steema.TeeChart.Functions.CLVFunction.Accumulate Property

Accumulates the CLV Function results.
public Boolean Accumulate {get; set;}

See Also

CLVFunction Class | CLVFunction Members | Steema.TeeChart.Functions Namespace


Volume

Steema.TeeChart.Functions.CLVFunction.Volume Property

Gets/sets the Volume series by which CLV results are multiplied.
public Series Volume {get; set;}

See Also

CLVFunction Class | CLVFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CompressGetDateEventArgs

Steema.TeeChart.Functions.CompressGetDateEventArgs Class

EventArgs for CompressGetDateHandler

For a list of all members of this type, see CompressGetDateEventArgs Members

System.Object
System.EventArgs
public class CompressGetDateEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

CompressGetDateEventArgs members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CompressGetDateEventArgsMembers

Steema.TeeChart.Functions.CompressGetDateEventArgs all Members

CompressGetDateEventArgs overview

Constructors

Constructor

Public Properties

Date | The CompressOHLC Function ValueIndex Date.
Source | The CompressOHLC Function Source series.
ValueIndex | The CompressOHLC Function ValueIndex.

See Also

CompressGetDateEventArgs Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CompressGetDateEventArgs Constructor

public CompressGetDateEventArgs(Series source,
     Int32 valueIndex,
     DateTime date)

See Also

CompressGetDateEventArgs Class | CompressGetDateEventArgs Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CompressGetDateEventArgsProperties

Steema.TeeChart.Functions.CompressGetDateEventArgs Properties

Public Properties

Date | The CompressOHLC Function ValueIndex Date.
Source | The CompressOHLC Function Source series.
ValueIndex | The CompressOHLC Function ValueIndex.

See Also

CompressGetDateEventArgs Class | Steema.TeeChart.Functions Namespace


Date

Steema.TeeChart.Functions.CompressGetDateEventArgs.Date Property

The CompressOHLC Function ValueIndex Date.
public DateTime Date {get;}

See Also

CompressGetDateEventArgs Class | CompressGetDateEventArgs Members | Steema.TeeChart.Functions Namespace


Source

Steema.TeeChart.Functions.CompressGetDateEventArgs.Source Property

The CompressOHLC Function Source series.
public Series Source {get;}

See Also

CompressGetDateEventArgs Class | CompressGetDateEventArgs Members | Steema.TeeChart.Functions Namespace


ValueIndex

Steema.TeeChart.Functions.CompressGetDateEventArgs.ValueIndex Property

The CompressOHLC Function ValueIndex.
public Int32 ValueIndex {get;}

See Also

CompressGetDateEventArgs Class | CompressGetDateEventArgs Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CompressGetDateHandler

Steema.TeeChart.Functions.CompressGetDateHandler Delegate

public delegate CompressGetDateHandler (Object sender,
     CompressGetDateEventArgs e)

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CompressionPeriod

Steema.TeeChart.Functions.CompressionPeriod Enum

Describes the possible values of the Compress property.
[Serializable]
public sealed enum CompressionPeriod : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
ocDay | Day.
ocWeek | Week.
ocMonth | Month.
ocBiMonth | BiMonthly.
ocQuarter | Quarter.
ocYear | Year.

See Also

Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CompressOHLC

Steema.TeeChart.Functions.CompressOHLC Class

CompressOHLC Function.

For a list of all members of this type, see CompressOHLC Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class CompressOHLC : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

CompressOHLC members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CompressOHLCMembers

Steema.TeeChart.Functions.CompressOHLC all Members

CompressOHLC overview

Constructors

Constructor Overloaded

Public Events

OnGetDate

Public Methods

AddPoints | Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Compress | Gets or sets the Compression Period as defined by the CompressionPeriod enumeration.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

CompressOHLC Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CompressOHLC Constructor

Overload List

public CompressOHLC()
public CompressOHLC(Steema.TeeChart.Chart)

See Also

CompressOHLC Class | CompressOHLC Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CompressOHLC Constructor

public CompressOHLC(Chart c)

See Also

CompressOHLC Constructor Overload List | CompressOHLC Class | CompressOHLC Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CompressOHLC Constructor

public CompressOHLC()

See Also

CompressOHLC Constructor Overload List | CompressOHLC Class | CompressOHLC Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CompressOHLCEvents

Steema.TeeChart.Functions.CompressOHLC Events

Public Events

OnGetDate

See Also

CompressOHLC Class | Steema.TeeChart.Functions Namespace


OnGetDate

Steema.TeeChart.Functions.CompressOHLC.OnGetDate Event

public CompressGetDateHandler  OnGetDate

See Also

CompressOHLC Class | CompressOHLC Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CompressOHLCMethods

Steema.TeeChart.Functions.CompressOHLC Methods

Public Methods

AddPoints | Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

CompressOHLC Class | Steema.TeeChart.Functions Namespace


AddPoints

Steema.TeeChart.Functions.CompressOHLC.AddPoints Method

Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
public override Void AddPoints(Array source)

See Also

CompressOHLC Class | CompressOHLC Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.CompressOHLC.Description Method

public override String Description()

See Also

CompressOHLC Class | CompressOHLC Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CompressOHLCProperties

Steema.TeeChart.Functions.CompressOHLC Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Compress | Gets or sets the Compression Period as defined by the CompressionPeriod enumeration.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

CompressOHLC Class | Steema.TeeChart.Functions Namespace


Compress

Steema.TeeChart.Functions.CompressOHLC.Compress Property

Gets or sets the Compression Period as defined by the CompressionPeriod enumeration.
public CompressionPeriod Compress {get; set;}

See Also

CompressOHLC Class | CompressOHLC Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CorrelationFunction

Steema.TeeChart.Functions.CorrelationFunction Class

Correlation function

For a list of all members of this type, see CorrelationFunction Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.BaseTrend
public class CorrelationFunction : BaseTrend

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

CorrelationFunction members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CorrelationFunctionMembers

Steema.TeeChart.Functions.CorrelationFunction all Members

CorrelationFunction overview

Constructors

Constructor

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate |
CalculateMany (inherited from BaseTrend) |
CalculateTrend (inherited from BaseTrend) | Calculates trendline paramaters m and b, where y=m*x+b
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
RSquared (inherited from BaseTrend) |
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TrendStyle (inherited from BaseTrend) | Defines different methods for calculating trendline
UseDecimals (inherited from BaseTrend) | Gets and sets whether System.Decimal is used instead of System.Double for the internal algorithms. When true, algorithms are more accurate but accept a smaller range of numbers.

See Also

CorrelationFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CorrelationFunction Constructor

public CorrelationFunction()

See Also

CorrelationFunction Class | CorrelationFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CorrelationFunctionMethods

Steema.TeeChart.Functions.CorrelationFunction Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate |
CalculateMany (inherited from BaseTrend) |
CalculateTrend (inherited from BaseTrend) | Calculates trendline paramaters m and b, where y=m*x+b
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

CorrelationFunction Class | Steema.TeeChart.Functions Namespace


Calculate

Steema.TeeChart.Functions.CorrelationFunction.Calculate Method

public override Double Calculate(Series s,
     Int32 firstIndex,
     Int32 lastIndex)

See Also

CorrelationFunction Class | CorrelationFunction Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.CorrelationFunction.Description Method

public override String Description()

See Also

CorrelationFunction Class | CorrelationFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CorrelationFunctionProperties

Steema.TeeChart.Functions.CorrelationFunction Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
RSquared (inherited from BaseTrend) |
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TrendStyle (inherited from BaseTrend) | Defines different methods for calculating trendline
UseDecimals (inherited from BaseTrend) | Gets and sets whether System.Decimal is used instead of System.Double for the internal algorithms. When true, algorithms are more accurate but accept a smaller range of numbers.

See Also

CorrelationFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Count

Steema.TeeChart.Functions.Count Class

Count Function.

For a list of all members of this type, see Count Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class Count : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

Count members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CountMembers

Steema.TeeChart.Functions.Count all Members

Count overview

Constructors

Constructor

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Count Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Count Constructor

public Count()

See Also

Count Class | Count Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CountMethods

Steema.TeeChart.Functions.Count Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

Count Class | Steema.TeeChart.Functions Namespace


Calculate

Steema.TeeChart.Functions.Count.Calculate Method

Performs function operation on SourceSeries series.
public override Double Calculate(Series sourceSeries,
     Int32 firstIndex,
     Int32 lastIndex)

See Also

Count Class | Count Members | Steema.TeeChart.Functions Namespace


CalculateMany

Steema.TeeChart.Functions.Count.CalculateMany Method

Performs function operation on list of series (SourceSeriesList).
public override Double CalculateMany(ArrayList sourceSeriesList,
     Int32 valueIndex)

See Also

Count Class | Count Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.Count.Description Method

public override String Description()

See Also

Count Class | Count Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CountProperties

Steema.TeeChart.Functions.Count Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Count Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CrossPoints

Steema.TeeChart.Functions.CrossPoints Class

CrossPoints Function.

For a list of all members of this type, see CrossPoints Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class CrossPoints : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

CrossPoints members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CrossPointsMembers

Steema.TeeChart.Functions.CrossPoints all Members

CrossPoints overview

Constructors

Constructor Overloaded

Public Methods

AddPoints |
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

CrossPoints Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CrossPoints Constructor

Overload List

public CrossPoints()
public CrossPoints(Steema.TeeChart.Chart)

See Also

CrossPoints Class | CrossPoints Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CrossPoints Constructor

public CrossPoints(Chart c)

See Also

CrossPoints Constructor Overload List | CrossPoints Class | CrossPoints Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CrossPoints Constructor

public CrossPoints()

See Also

CrossPoints Constructor Overload List | CrossPoints Class | CrossPoints Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CrossPointsMethods

Steema.TeeChart.Functions.CrossPoints Methods

Public Methods

AddPoints |
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

CrossPoints Class | Steema.TeeChart.Functions Namespace


AddPoints

Steema.TeeChart.Functions.CrossPoints.AddPoints Method

public override Void AddPoints(Array source)

See Also

CrossPoints Class | CrossPoints Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.CrossPoints.Description Method

public override String Description()

See Also

CrossPoints Class | CrossPoints Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CrossPointsProperties

Steema.TeeChart.Functions.CrossPoints Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

CrossPoints Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Cumulative

Steema.TeeChart.Functions.Cumulative Class

Cumulative Function. The TCumulative function sums the Series values starting from the first point. Example: Given these values: 1 2 3 The TCumulative function returns: 1 3 6 ( 1=1, 1+2=3 and 1+2+3=6 )

For a list of all members of this type, see Cumulative Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class Cumulative : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

Cumulative members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CumulativeMembers

Steema.TeeChart.Functions.Cumulative all Members

Cumulative overview

Constructors

Constructor Overloaded

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Cumulative Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Cumulative Constructor

Overload List

public Cumulative()
public Cumulative(Steema.TeeChart.Chart)

See Also

Cumulative Class | Cumulative Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Cumulative Constructor

public Cumulative(Chart c)

See Also

Cumulative Constructor Overload List | Cumulative Class | Cumulative Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Cumulative Constructor

public Cumulative()

See Also

Cumulative Constructor Overload List | Cumulative Class | Cumulative Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CumulativeMethods

Steema.TeeChart.Functions.Cumulative Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

Cumulative Class | Steema.TeeChart.Functions Namespace


Calculate

Steema.TeeChart.Functions.Cumulative.Calculate Method

Performs function operation on SourceSeries series.
public override Double Calculate(Series sourceSeries,
     Int32 firstIndex,
     Int32 lastIndex)

See Also

Cumulative Class | Cumulative Members | Steema.TeeChart.Functions Namespace


CalculateMany

Steema.TeeChart.Functions.Cumulative.CalculateMany Method

Performs function operation on list of series (SourceSeriesList).
public override Double CalculateMany(ArrayList sourceSeriesList,
     Int32 valueIndex)

See Also

Cumulative Class | Cumulative Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.Cumulative.Description Method

public override String Description()

See Also

Cumulative Class | Cumulative Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CumulativeProperties

Steema.TeeChart.Functions.Cumulative Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Cumulative Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Custom

Steema.TeeChart.Functions.Custom Class

Custom y=f(x) function

For a list of all members of this type, see Custom Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class Custom : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

Custom members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CustomMembers

Steema.TeeChart.Functions.Custom all Members

Custom overview

Constructors

Constructor Overloaded

Public Events

CalculateEvent

Public Fields

X

Public Methods

AddPoints | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
NumPoints | Gets or sets the number of points.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
StartX | The initial value for the "X" parameter.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Custom Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Custom Constructor

Overload List

public Custom()
public Custom(Steema.TeeChart.Chart)

See Also

Custom Class | Custom Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Custom Constructor

public Custom(Chart c)

See Also

Custom Constructor Overload List | Custom Class | Custom Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Custom Constructor

public Custom()

See Also

Custom Constructor Overload List | Custom Class | Custom Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CustomEvents

Steema.TeeChart.Functions.Custom Events

Public Events

CalculateEvent

See Also

Custom Class | Steema.TeeChart.Functions Namespace


CalculateEvent

Steema.TeeChart.Functions.Custom.CalculateEvent Event

public CalculateEventHandler  CalculateEvent

See Also

Custom Class | Custom Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CustomFields

Steema.TeeChart.Functions.Custom Fields

Public Fields

X

See Also

Custom Class | Steema.TeeChart.Functions Namespace


X

Steema.TeeChart.Functions.Custom.X Field

public Double X

See Also

Custom Class | Custom Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CustomMethods

Steema.TeeChart.Functions.Custom Methods

Public Methods

AddPoints | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

Custom Class | Steema.TeeChart.Functions Namespace


AddPoints

Steema.TeeChart.Functions.Custom.AddPoints Method

Gets all points from Source series, performs a function operation and stores results in ParentSeries.
public override Void AddPoints(Array source)

See Also

Custom Class | Custom Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.Custom.Description Method

public override String Description()

See Also

Custom Class | Custom Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CustomProperties

Steema.TeeChart.Functions.Custom Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
NumPoints | Gets or sets the number of points.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
StartX | The initial value for the "X" parameter.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Custom Class | Steema.TeeChart.Functions Namespace


NumPoints

Steema.TeeChart.Functions.Custom.NumPoints Property

Gets or sets the number of points.
public Int32 NumPoints {get; set;}

See Also

Custom Class | Custom Members | Steema.TeeChart.Functions Namespace


StartX

Steema.TeeChart.Functions.Custom.StartX Property

The initial value for the "X" parameter.
public Double StartX {get; set;}

See Also

Custom Class | Custom Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CustomSorted

Steema.TeeChart.Functions.CustomSorted Class

Intermediate abstract class used by MedianFunction and ModeFunction to calculate values using the source series values sorted in ascending order.

For a list of all members of this type, see CustomSorted Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class CustomSorted : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

CustomSorted members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CustomSortedMembers

Steema.TeeChart.Functions.CustomSorted all Members

CustomSorted overview

Constructors

Constructor Overloaded

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate |
CalculateMany |
Clear (inherited from Function) |
Description (inherited from Function) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
IncludeNulls | When True, null values in the source series will be included in the calculation. Default is True.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

CustomSorted Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CustomSorted Constructor

Overload List

public CustomSorted()
public CustomSorted(Steema.TeeChart.Chart)

See Also

CustomSorted Class | CustomSorted Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CustomSorted Constructor

public CustomSorted(Chart c)

See Also

CustomSorted Constructor Overload List | CustomSorted Class | CustomSorted Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CustomSorted Constructor

public CustomSorted()

See Also

CustomSorted Constructor Overload List | CustomSorted Class | CustomSorted Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CustomSortedMethods

Steema.TeeChart.Functions.CustomSorted Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate |
CalculateMany |
Clear (inherited from Function) |
Description (inherited from Function) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

CustomSorted Class | Steema.TeeChart.Functions Namespace


Calculate

Steema.TeeChart.Functions.CustomSorted.Calculate Method

public override Double Calculate(Series source,
     Int32 first,
     Int32 last)

See Also

CustomSorted Class | CustomSorted Members | Steema.TeeChart.Functions Namespace


CalculateMany

Steema.TeeChart.Functions.CustomSorted.CalculateMany Method

public override Double CalculateMany(ArrayList sourceSeries,
     Int32 valueIndex)

See Also

CustomSorted Class | CustomSorted Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.CustomSortedProperties

Steema.TeeChart.Functions.CustomSorted Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
IncludeNulls | When True, null values in the source series will be included in the calculation. Default is True.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

CustomSorted Class | Steema.TeeChart.Functions Namespace


IncludeNulls

Steema.TeeChart.Functions.CustomSorted.IncludeNulls Property

When True, null values in the source series will be included in the calculation. Default is True.
public Boolean IncludeNulls {get; set;}

See Also

CustomSorted Class | CustomSorted Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Divide

Steema.TeeChart.Functions.Divide Class

Divide Function.

For a list of all members of this type, see Divide Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.ManySeries
public class Divide : ManySeries

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

Divide members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.DivideMembers

Steema.TeeChart.Functions.Divide all Members

Divide overview

Constructors

Constructor

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from ManySeries) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Divide Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Divide Constructor

public Divide()

See Also

Divide Class | Divide Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.DivideMethods

Steema.TeeChart.Functions.Divide Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from ManySeries) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

Divide Class | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.Divide.Description Method

public override String Description()

See Also

Divide Class | Divide Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.DivideProperties

Steema.TeeChart.Functions.Divide Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Divide Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.DownSampling

Steema.TeeChart.Functions.DownSampling Class

Reduces the number of points in series by using several different methods.

For a list of all members of this type, see DownSampling Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class DownSampling : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

DownSampling members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.DownSamplingMembers

Steema.TeeChart.Functions.DownSampling all Members

DownSampling overview

Constructors

Constructor Overloaded

Public Methods

AddPoints | Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.
Reduce | Reduce the number of points in double arrays

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
DisplayedPointCount |
Method |
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
ReducedSize | Returns reduced size
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Tolerance | Gets or sets the tolerance for downsampling method. All points within Tolerance will be replaced with one or two points.

See Also

DownSampling Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.DownSampling Constructor

Overload List

public DownSampling()
public DownSampling(Steema.TeeChart.Chart)

See Also

DownSampling Class | DownSampling Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.DownSampling Constructor

public DownSampling(Chart c)

See Also

DownSampling Constructor Overload List | DownSampling Class | DownSampling Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.DownSampling Constructor

public DownSampling()

See Also

DownSampling Constructor Overload List | DownSampling Class | DownSampling Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.DownSamplingMethods

Steema.TeeChart.Functions.DownSampling Methods

Public Methods

AddPoints | Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.
Reduce | Reduce the number of points in double arrays

See Also

DownSampling Class | Steema.TeeChart.Functions Namespace


AddPoints

Steema.TeeChart.Functions.DownSampling.AddPoints Method

Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
public override Void AddPoints(Array source)

See Also

DownSampling Class | DownSampling Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.DownSampling.Description Method

public override String Description()

See Also

DownSampling Class | DownSampling Members | Steema.TeeChart.Functions Namespace


Reduce

Steema.TeeChart.Functions.DownSampling.Reduce Method

Reduce the number of points in double arrays
public Int32 Reduce(DownSamplingMethod algorithm,
     Double tol,
     Int32 lbound,
     Int32 ubound,
     Series s,
     Double[]& rx,
     Double[]& ry,
     ColorList& colors,
     Color color)

Parameters

algorithm
Reduction algorithm
tol
Desicred tolerance
lbound
Lower bound for x,y arrays
ubound
Upper bound for x,y arrays
x
x array
y
y array
rx
x array with reduced values
ry
y array with reduced values

Return Value

reduced array size

See Also

DownSampling Class | DownSampling Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.DownSamplingProperties

Steema.TeeChart.Functions.DownSampling Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
DisplayedPointCount |
Method |
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
ReducedSize | Returns reduced size
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Tolerance | Gets or sets the tolerance for downsampling method. All points within Tolerance will be replaced with one or two points.

See Also

DownSampling Class | Steema.TeeChart.Functions Namespace


DisplayedPointCount

Steema.TeeChart.Functions.DownSampling.DisplayedPointCount Property

public Int32 DisplayedPointCount {get; set;}

See Also

DownSampling Class | DownSampling Members | Steema.TeeChart.Functions Namespace


Method

Steema.TeeChart.Functions.DownSampling.Method Property

public DownSamplingMethod Method {get; set;}

See Also

DownSampling Class | DownSampling Members | Steema.TeeChart.Functions Namespace


ReducedSize

Steema.TeeChart.Functions.DownSampling.ReducedSize Property

Returns reduced size
public Int32 ReducedSize {get;}

See Also

DownSampling Class | DownSampling Members | Steema.TeeChart.Functions Namespace


Tolerance

Steema.TeeChart.Functions.DownSampling.Tolerance Property

Gets or sets the tolerance for downsampling method. All points within Tolerance will be replaced with one or two points.
public Double Tolerance {get; set;}

See Also

DownSampling Class | DownSampling Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.DownSamplingMethod

Steema.TeeChart.Functions.DownSamplingMethod Enum

Defines type of downsampling method.
[Serializable]
public sealed enum DownSamplingMethod : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Max | Replace group of points with group maximum value.
Min | Replace group of points with group minimum value.
MinMax | Replace group of points with two points : group minimum and maximum value.
MinMaxFirstLast | Replace group of points with two points : group minimum and maximum value. Draw From Last value of one group to the First value of the next.
MinMaxFirstLastNull | Replace group of points with two points : group minimum and maximum value. Draw From Last value of one group to the First value of the next. Only include the first null of the group in the calculation but without plotting it.
Average | Replace group of points with group average value.

See Also

Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ExpAverage

Steema.TeeChart.Functions.ExpAverage Class

Exponential Average Function.

For a list of all members of this type, see ExpAverage Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.Moving
public class ExpAverage : Moving

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

ExpAverage members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ExpAverageMembers

Steema.TeeChart.Functions.ExpAverage all Members

ExpAverage overview

Constructors

Constructor

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Weight | Performs an Exponential average based on its DataSource values.

See Also

ExpAverage Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ExpAverage Constructor

public ExpAverage()

See Also

ExpAverage Class | ExpAverage Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ExpAverageMethods

Steema.TeeChart.Functions.ExpAverage Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

ExpAverage Class | Steema.TeeChart.Functions Namespace


Calculate

Steema.TeeChart.Functions.ExpAverage.Calculate Method

Performs function operation on SourceSeries series.
public override Double Calculate(Series s,
     Int32 firstIndex,
     Int32 lastIndex)

See Also

ExpAverage Class | ExpAverage Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.ExpAverage.Description Method

public override String Description()

See Also

ExpAverage Class | ExpAverage Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ExpAverageProperties

Steema.TeeChart.Functions.ExpAverage Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Weight | Performs an Exponential average based on its DataSource values.

See Also

ExpAverage Class | Steema.TeeChart.Functions Namespace


Weight

Steema.TeeChart.Functions.ExpAverage.Weight Property

Performs an Exponential average based on its DataSource values.
public Double Weight {get; set;}

See Also

ExpAverage Class | ExpAverage Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ExpMovAverage

Steema.TeeChart.Functions.ExpMovAverage Class

Exponential Moving Average Function

For a list of all members of this type, see ExpMovAverage Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class ExpMovAverage : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

ExpMovAverage members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ExpMovAverageMembers

Steema.TeeChart.Functions.ExpMovAverage all Members

ExpMovAverage overview

Constructors

Constructor Overloaded

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

ExpMovAverage Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ExpMovAverage Constructor

Overload List

public ExpMovAverage()
public ExpMovAverage(Steema.TeeChart.Chart)

See Also

ExpMovAverage Class | ExpMovAverage Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ExpMovAverage Constructor

public ExpMovAverage(Chart c)

See Also

ExpMovAverage Constructor Overload List | ExpMovAverage Class | ExpMovAverage Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ExpMovAverage Constructor

public ExpMovAverage()

See Also

ExpMovAverage Constructor Overload List | ExpMovAverage Class | ExpMovAverage Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ExpMovAverageMethods

Steema.TeeChart.Functions.ExpMovAverage Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

ExpMovAverage Class | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.ExpMovAverage.Description Method

public override String Description()

See Also

ExpMovAverage Class | ExpMovAverage Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ExpMovAverageProperties

Steema.TeeChart.Functions.ExpMovAverage Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

ExpMovAverage Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ExpTrendFunction

Steema.TeeChart.Functions.ExpTrendFunction Class

The Exponential Trend function is similar to Trend, except that the calculation fits values using their exponential (e) weights.

For a list of all members of this type, see ExpTrendFunction Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.BaseTrend
public class ExpTrendFunction : BaseTrend

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

ExpTrendFunction members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ExpTrendFunctionMembers

Steema.TeeChart.Functions.ExpTrendFunction all Members

ExpTrendFunction overview

Constructors

Constructor Overloaded

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from BaseTrend) |
CalculateMany (inherited from BaseTrend) |
CalculateTrend (inherited from BaseTrend) | Calculates trendline paramaters m and b, where y=m*x+b
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
RSquared (inherited from BaseTrend) |
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TrendStyle (inherited from BaseTrend) | Defines different methods for calculating trendline
UseDecimals (inherited from BaseTrend) | Gets and sets whether System.Decimal is used instead of System.Double for the internal algorithms. When true, algorithms are more accurate but accept a smaller range of numbers.

See Also

ExpTrendFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ExpTrendFunction Constructor

Overload List

public ExpTrendFunction()
public ExpTrendFunction(Steema.TeeChart.Chart)

See Also

ExpTrendFunction Class | ExpTrendFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ExpTrendFunction Constructor

public ExpTrendFunction(Chart c)

See Also

ExpTrendFunction Constructor Overload List | ExpTrendFunction Class | ExpTrendFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ExpTrendFunction Constructor

public ExpTrendFunction()

See Also

ExpTrendFunction Constructor Overload List | ExpTrendFunction Class | ExpTrendFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ExpTrendFunctionMethods

Steema.TeeChart.Functions.ExpTrendFunction Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from BaseTrend) |
CalculateMany (inherited from BaseTrend) |
CalculateTrend (inherited from BaseTrend) | Calculates trendline paramaters m and b, where y=m*x+b
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

ExpTrendFunction Class | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.ExpTrendFunction.Description Method

public override String Description()

See Also

ExpTrendFunction Class | ExpTrendFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ExpTrendFunctionProperties

Steema.TeeChart.Functions.ExpTrendFunction Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
RSquared (inherited from BaseTrend) |
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TrendStyle (inherited from BaseTrend) | Defines different methods for calculating trendline
UseDecimals (inherited from BaseTrend) | Gets and sets whether System.Decimal is used instead of System.Double for the internal algorithms. When true, algorithms are more accurate but accept a smaller range of numbers.

See Also

ExpTrendFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Function

Steema.TeeChart.Functions.Function Class

Basic functions (Add, Subtract, High, Low, Average and Count).

For a list of all members of this type, see Function Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class Function : TeeBase

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

Function members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.FunctionMembers

Steema.TeeChart.Functions.Function all Members

Function overview

Constructors

Constructor Overloaded

Public Methods

AddPoints | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany | Performs function operation on list of series (SourceSeriesList).
Clear |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period | Controls how many points or X range will trigger a new point calculation.
PeriodAlign | Controls where to place function calculations inside the full period space.
PeriodStyle | Controls how the Period property is interpreted.
Series | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Function Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Function Constructor

Overload List

public Function()
public Function(Steema.TeeChart.Chart)

See Also

Function Class | Function Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Function Constructor

public Function(Chart c)

See Also

Function Constructor Overload List | Function Class | Function Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Function Constructor

public Function()

See Also

Function Constructor Overload List | Function Class | Function Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.FunctionMethods

Steema.TeeChart.Functions.Function Methods

Public Methods

AddPoints | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany | Performs function operation on list of series (SourceSeriesList).
Clear |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate | Performs a CheckDataSource method on ParentSeries.

See Also

Function Class | Steema.TeeChart.Functions Namespace


AddPoints

Steema.TeeChart.Functions.Function.AddPoints Method

Gets all points from Source series, performs a function operation and stores results in ParentSeries.
public abstract Void AddPoints(Array source)

See Also

Function Class | Function Members | Steema.TeeChart.Functions Namespace


Calculate

Steema.TeeChart.Functions.Function.Calculate Method

Performs function operation on SourceSeries series.
public abstract Double Calculate(Series source,
     Int32 first,
     Int32 last)

See Also

Function Class | Function Members | Steema.TeeChart.Functions Namespace


CalculateMany

Steema.TeeChart.Functions.Function.CalculateMany Method

Performs function operation on list of series (SourceSeriesList).
public abstract Double CalculateMany(ArrayList sourceSeries,
     Int32 valueIndex)

See Also

Function Class | Function Members | Steema.TeeChart.Functions Namespace


Clear

Steema.TeeChart.Functions.Function.Clear Method

public abstract Void Clear()

See Also

Function Class | Function Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.Function.Description Method

public abstract String Description()

See Also

Function Class | Function Members | Steema.TeeChart.Functions Namespace


Recalculate

Steema.TeeChart.Functions.Function.Recalculate Method

Performs a CheckDataSource method on ParentSeries.
public Void Recalculate()

See Also

Function Class | Function Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.FunctionProperties

Steema.TeeChart.Functions.Function Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period | Controls how many points or X range will trigger a new point calculation.
PeriodAlign | Controls where to place function calculations inside the full period space.
PeriodStyle | Controls how the Period property is interpreted.
Series | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Function Class | Steema.TeeChart.Functions Namespace


Period

Steema.TeeChart.Functions.Function.Period Property

Controls how many points or X range will trigger a new point calculation.
public Double Period {get; set;}

See Also

Function Class | Function Members | Steema.TeeChart.Functions Namespace


PeriodAlign

Steema.TeeChart.Functions.Function.PeriodAlign Property

Controls where to place function calculations inside the full period space.
public PeriodAligns PeriodAlign {get; set;}

See Also

Function Class | Function Members | Steema.TeeChart.Functions Namespace


PeriodStyle

Steema.TeeChart.Functions.Function.PeriodStyle Property

Controls how the Period property is interpreted.
public PeriodStyles PeriodStyle {get; set;}

See Also

Function Class | Function Members | Steema.TeeChart.Functions Namespace


Series

Steema.TeeChart.Functions.Function.Series Property

Returns the TChartSeries parent of TTeeFunction.
public Series Series {get; set;}

See Also

Function Class | Function Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.High

Steema.TeeChart.Functions.High Class

High Function. Returns highest value.

For a list of all members of this type, see High Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class High : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

High members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.HighMembers

Steema.TeeChart.Functions.High all Members

High overview

Constructors

Constructor

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

High Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.High Constructor

public High()

See Also

High Class | High Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.HighMethods

Steema.TeeChart.Functions.High Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

High Class | Steema.TeeChart.Functions Namespace


Calculate

Steema.TeeChart.Functions.High.Calculate Method

Performs function operation on SourceSeries series.
public override Double Calculate(Series sourceSeries,
     Int32 firstIndex,
     Int32 lastIndex)

See Also

High Class | High Members | Steema.TeeChart.Functions Namespace


CalculateMany

Steema.TeeChart.Functions.High.CalculateMany Method

Performs function operation on list of series (SourceSeriesList).
public override Double CalculateMany(ArrayList sourceSeriesList,
     Int32 valueIndex)

See Also

High Class | High Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.High.Description Method

public override String Description()

See Also

High Class | High Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.HighProperties

Steema.TeeChart.Functions.High Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

High Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.HistogramFunction

Steema.TeeChart.Functions.HistogramFunction Class

Constructs a histogram or cumulative histogram from data.

For a list of all members of this type, see HistogramFunction Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class HistogramFunction : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

HistogramFunction members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.HistogramFunctionMembers

Steema.TeeChart.Functions.HistogramFunction all Members

HistogramFunction overview

Constructors

Constructor Overloaded

Public Methods

AddPoints | Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Histogram | Constructs histogram from data double array.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Cumulative | If true, cumulative histogram is calculated.
IncludeNulls | Calculates the histogram using only the non-null points of a series, or not.
NumBins | Number of bins (centerpoints) in histogram.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

HistogramFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.HistogramFunction Constructor

Overload List

public HistogramFunction()
public HistogramFunction(Steema.TeeChart.Chart)

See Also

HistogramFunction Class | HistogramFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.HistogramFunction Constructor

public HistogramFunction(Chart c)

See Also

HistogramFunction Constructor Overload List | HistogramFunction Class | HistogramFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.HistogramFunction Constructor

public HistogramFunction()

See Also

HistogramFunction Constructor Overload List | HistogramFunction Class | HistogramFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.HistogramFunctionMethods

Steema.TeeChart.Functions.HistogramFunction Methods

Public Methods

AddPoints | Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Histogram | Constructs histogram from data double array.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

HistogramFunction Class | Steema.TeeChart.Functions Namespace


AddPoints

Steema.TeeChart.Functions.HistogramFunction.AddPoints Method

Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
public override Void AddPoints(Array source)

See Also

HistogramFunction Class | HistogramFunction Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.HistogramFunction.Description Method

public override String Description()

See Also

HistogramFunction Class | HistogramFunction Members | Steema.TeeChart.Functions Namespace


Histogram

Steema.TeeChart.Functions.HistogramFunction.Histogram Method

Constructs histogram from data double array.
public static Void Histogram(Double[] data,
     Int32 lb,
     Int32 ub,
     Double[]& bins,
     Double[]& counts,
     Int32 nbins,
     Double min,
     Double max)

Parameters

data
Defines data for histogram.
lb
Data lower bound.
ub
Data upper bound.
bins
Returns bins centerpoints.
counts
Returns each bin count.
nbins
Number of bins used in histogram. Value must match the bins and counts size.
min
Minimum value used for histogram. Usually it's data minimum value.
max
Maximum value used for histogram. Usually it's data maximum value.

See Also

HistogramFunction Class | HistogramFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.HistogramFunctionProperties

Steema.TeeChart.Functions.HistogramFunction Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Cumulative | If true, cumulative histogram is calculated.
IncludeNulls | Calculates the histogram using only the non-null points of a series, or not.
NumBins | Number of bins (centerpoints) in histogram.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

HistogramFunction Class | Steema.TeeChart.Functions Namespace


Cumulative

Steema.TeeChart.Functions.HistogramFunction.Cumulative Property

If true, cumulative histogram is calculated.
public Boolean Cumulative {get; set;}

See Also

HistogramFunction Class | HistogramFunction Members | Steema.TeeChart.Functions Namespace


IncludeNulls

Steema.TeeChart.Functions.HistogramFunction.IncludeNulls Property

Calculates the histogram using only the non-null points of a series, or not.
public Boolean IncludeNulls {get; set;}

See Also

HistogramFunction Class | HistogramFunction Members | Steema.TeeChart.Functions Namespace


NumBins

Steema.TeeChart.Functions.HistogramFunction.NumBins Property

Number of bins (centerpoints) in histogram.
public Int32 NumBins {get; set;}

See Also

HistogramFunction Class | HistogramFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Low

Steema.TeeChart.Functions.Low Class

Low Function. Returns lowest value.

For a list of all members of this type, see Low Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class Low : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

Low members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.LowMembers

Steema.TeeChart.Functions.Low all Members

Low overview

Constructors

Constructor

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Low Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Low Constructor

public Low()

See Also

Low Class | Low Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.LowMethods

Steema.TeeChart.Functions.Low Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

Low Class | Steema.TeeChart.Functions Namespace


Calculate

Steema.TeeChart.Functions.Low.Calculate Method

Performs function operation on SourceSeries series.
public override Double Calculate(Series sourceSeries,
     Int32 firstIndex,
     Int32 lastIndex)

See Also

Low Class | Low Members | Steema.TeeChart.Functions Namespace


CalculateMany

Steema.TeeChart.Functions.Low.CalculateMany Method

Performs function operation on list of series (SourceSeriesList).
public override Double CalculateMany(ArrayList sourceSeriesList,
     Int32 valueIndex)

See Also

Low Class | Low Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.Low.Description Method

public override String Description()

See Also

Low Class | Low Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.LowProperties

Steema.TeeChart.Functions.Low Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Low Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MACDFunction

Steema.TeeChart.Functions.MACDFunction Class

The MACD function (Moving Average Convergence Divergence), used in financial charts.

For a list of all members of this type, see MACDFunction Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.Moving
public class MACDFunction : Moving

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

MACDFunction members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MACDFunctionMembers

Steema.TeeChart.Functions.MACDFunction all Members

MACDFunction overview

Constructors

Constructor Overloaded

Public Methods

AddPoints |
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Histogram | Returns a sub-series (of type Volume) internally calculated by MACD function.
HistogramPen | The Pen used to draw the histogram line of a MACD function.
MACDExp | Returns a second sub-series (of type FastLine) internally calculated by MACD function.
MACDExpPen | The pen properties used to draw the Exponential MACD line.
MACDPen | The pen properties used to draw the MACD line.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
Period2 | The Period property controls how many points or X range(sse note below) will trigger a new point calculation.
Period3 | Determines the number of samples used to calculate a MACD function.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

MACDFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MACDFunction Constructor

Overload List

public MACDFunction()
public MACDFunction(Steema.TeeChart.Chart)
public MACDFunction(Steema.TeeChart.Styles.FastLine, Steema.TeeChart.Styles.Volume)

See Also

MACDFunction Class | MACDFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MACDFunction Constructor

public MACDFunction(FastLine macdExp,
     Volume histogram)

See Also

MACDFunction Constructor Overload List | MACDFunction Class | MACDFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MACDFunction Constructor

public MACDFunction(Chart c)

See Also

MACDFunction Constructor Overload List | MACDFunction Class | MACDFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MACDFunction Constructor

public MACDFunction()

See Also

MACDFunction Constructor Overload List | MACDFunction Class | MACDFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MACDFunctionMethods

Steema.TeeChart.Functions.MACDFunction Methods

Public Methods

AddPoints |
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

MACDFunction Class | Steema.TeeChart.Functions Namespace


AddPoints

Steema.TeeChart.Functions.MACDFunction.AddPoints Method

public override Void AddPoints(Array source)

See Also

MACDFunction Class | MACDFunction Members | Steema.TeeChart.Functions Namespace


Clear

Steema.TeeChart.Functions.MACDFunction.Clear Method

public override Void Clear()

See Also

MACDFunction Class | MACDFunction Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.MACDFunction.Description Method

public override String Description()

See Also

MACDFunction Class | MACDFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MACDFunctionProperties

Steema.TeeChart.Functions.MACDFunction Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Histogram | Returns a sub-series (of type Volume) internally calculated by MACD function.
HistogramPen | The Pen used to draw the histogram line of a MACD function.
MACDExp | Returns a second sub-series (of type FastLine) internally calculated by MACD function.
MACDExpPen | The pen properties used to draw the Exponential MACD line.
MACDPen | The pen properties used to draw the MACD line.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
Period2 | The Period property controls how many points or X range(sse note below) will trigger a new point calculation.
Period3 | Determines the number of samples used to calculate a MACD function.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

MACDFunction Class | Steema.TeeChart.Functions Namespace


Histogram

Steema.TeeChart.Functions.MACDFunction.Histogram Property

Returns a sub-series (of type Volume) internally calculated by MACD function.
public Volume Histogram {get; set;}

See Also

MACDFunction Class | MACDFunction Members | Steema.TeeChart.Functions Namespace


HistogramPen

Steema.TeeChart.Functions.MACDFunction.HistogramPen Property

The Pen used to draw the histogram line of a MACD function.
public ChartPen HistogramPen {get; set;}

See Also

MACDFunction Class | MACDFunction Members | Steema.TeeChart.Functions Namespace


MACDExp

Steema.TeeChart.Functions.MACDFunction.MACDExp Property

Returns a second sub-series (of type FastLine) internally calculated by MACD function.
public FastLine MACDExp {get; set;}

See Also

MACDFunction Class | MACDFunction Members | Steema.TeeChart.Functions Namespace


MACDExpPen

Steema.TeeChart.Functions.MACDFunction.MACDExpPen Property

The pen properties used to draw the Exponential MACD line.
public ChartPen MACDExpPen {get; set;}

See Also

MACDFunction Class | MACDFunction Members | Steema.TeeChart.Functions Namespace


MACDPen

Steema.TeeChart.Functions.MACDFunction.MACDPen Property

The pen properties used to draw the MACD line.
public ChartPen MACDPen {get; set;}

See Also

MACDFunction Class | MACDFunction Members | Steema.TeeChart.Functions Namespace


Period2

Steema.TeeChart.Functions.MACDFunction.Period2 Property

The Period property controls how many points or X range(sse note below) will trigger a new point calculation.
public Double Period2 {get; set;}

See Also

MACDFunction Class | MACDFunction Members | Steema.TeeChart.Functions Namespace


Period3

Steema.TeeChart.Functions.MACDFunction.Period3 Property

Determines the number of samples used to calculate a MACD function.
public Double Period3 {get; set;}

See Also

MACDFunction Class | MACDFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ManySeries

Steema.TeeChart.Functions.ManySeries Class

Internal use. Base class for multiple Series function calculations

For a list of all members of this type, see ManySeries Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class ManySeries : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

ManySeries members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ManySeriesMembers

Steema.TeeChart.Functions.ManySeries all Members

ManySeries overview

Constructors

Constructor

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description (inherited from Function) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

ManySeries Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ManySeries Constructor

public ManySeries()

See Also

ManySeries Class | ManySeries Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ManySeriesMethods

Steema.TeeChart.Functions.ManySeries Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description (inherited from Function) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

ManySeries Class | Steema.TeeChart.Functions Namespace


CalculateMany

Steema.TeeChart.Functions.ManySeries.CalculateMany Method

Performs function operation on list of series (SourceSeriesList).
public override Double CalculateMany(ArrayList sourceSeries,
     Int32 valueIndex)

See Also

ManySeries Class | ManySeries Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ManySeriesProperties

Steema.TeeChart.Functions.ManySeries Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

ManySeries Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MedianFunction

Steema.TeeChart.Functions.MedianFunction Class

Calculates the median value of the source series values. The median value is different than the average in that median returns the value that is "at the middle" of the source series values ordered in ascending order. If more than one value shares the middle position, this function returns the average of those values.

For a list of all members of this type, see MedianFunction Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.CustomSorted
public class MedianFunction : CustomSorted

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

MedianFunction members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MedianFunctionMembers

Steema.TeeChart.Functions.MedianFunction all Members

MedianFunction overview

Constructors

Constructor Overloaded

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from CustomSorted) |
CalculateMany (inherited from CustomSorted) |
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
IncludeNulls (inherited from CustomSorted) | When True, null values in the source series will be included in the calculation. Default is True.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

MedianFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MedianFunction Constructor

Overload List

public MedianFunction()
public MedianFunction(Steema.TeeChart.Chart)

See Also

MedianFunction Class | MedianFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MedianFunction Constructor

public MedianFunction(Chart c)

See Also

MedianFunction Constructor Overload List | MedianFunction Class | MedianFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MedianFunction Constructor

public MedianFunction()

See Also

MedianFunction Constructor Overload List | MedianFunction Class | MedianFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MedianFunctionMethods

Steema.TeeChart.Functions.MedianFunction Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from CustomSorted) |
CalculateMany (inherited from CustomSorted) |
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

MedianFunction Class | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.MedianFunction.Description Method

public override String Description()

See Also

MedianFunction Class | MedianFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MedianFunctionProperties

Steema.TeeChart.Functions.MedianFunction Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
IncludeNulls (inherited from CustomSorted) | When True, null values in the source series will be included in the calculation. Default is True.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

MedianFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ModeFunction

Steema.TeeChart.Functions.ModeFunction Class

The mode function returns the source series value that is most more times.

For a list of all members of this type, see ModeFunction Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.CustomSorted
public class ModeFunction : CustomSorted

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

ModeFunction members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ModeFunctionMembers

Steema.TeeChart.Functions.ModeFunction all Members

ModeFunction overview

Constructors

Constructor Overloaded

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from CustomSorted) |
CalculateMany (inherited from CustomSorted) |
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
IncludeNulls (inherited from CustomSorted) | When True, null values in the source series will be included in the calculation. Default is True.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

ModeFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ModeFunction Constructor

Overload List

public ModeFunction()
public ModeFunction(Steema.TeeChart.Chart)

See Also

ModeFunction Class | ModeFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ModeFunction Constructor

public ModeFunction(Chart c)

See Also

ModeFunction Constructor Overload List | ModeFunction Class | ModeFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ModeFunction Constructor

public ModeFunction()

See Also

ModeFunction Constructor Overload List | ModeFunction Class | ModeFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ModeFunctionMethods

Steema.TeeChart.Functions.ModeFunction Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from CustomSorted) |
CalculateMany (inherited from CustomSorted) |
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

ModeFunction Class | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.ModeFunction.Description Method

public override String Description()

See Also

ModeFunction Class | ModeFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.ModeFunctionProperties

Steema.TeeChart.Functions.ModeFunction Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
IncludeNulls (inherited from CustomSorted) | When True, null values in the source series will be included in the calculation. Default is True.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

ModeFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Momentum

Steema.TeeChart.Functions.Momentum Class

Momentum Function.

For a list of all members of this type, see Momentum Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.Moving
public class Momentum : Moving

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

Momentum members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MomentumMembers

Steema.TeeChart.Functions.Momentum all Members

Momentum overview

Constructors

Constructor

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Momentum Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Momentum Constructor

public Momentum()

See Also

Momentum Class | Momentum Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MomentumMethods

Steema.TeeChart.Functions.Momentum Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

Momentum Class | Steema.TeeChart.Functions Namespace


Calculate

Steema.TeeChart.Functions.Momentum.Calculate Method

Performs function operation on SourceSeries series.
public override Double Calculate(Series s,
     Int32 firstIndex,
     Int32 lastIndex)

See Also

Momentum Class | Momentum Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.Momentum.Description Method

public override String Description()

See Also

Momentum Class | Momentum Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MomentumProperties

Steema.TeeChart.Functions.Momentum Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Momentum Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MomentumDivision

Steema.TeeChart.Functions.MomentumDivision Class

Momentum Division Function.

For a list of all members of this type, see MomentumDivision Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.Moving
public class MomentumDivision : Moving

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

MomentumDivision members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MomentumDivisionMembers

Steema.TeeChart.Functions.MomentumDivision all Members

MomentumDivision overview

Constructors

Constructor

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

MomentumDivision Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MomentumDivision Constructor

public MomentumDivision()

See Also

MomentumDivision Class | MomentumDivision Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MomentumDivisionMethods

Steema.TeeChart.Functions.MomentumDivision Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

MomentumDivision Class | Steema.TeeChart.Functions Namespace


Calculate

Steema.TeeChart.Functions.MomentumDivision.Calculate Method

Performs function operation on SourceSeries series.
public override Double Calculate(Series s,
     Int32 firstIndex,
     Int32 lastIndex)

See Also

MomentumDivision Class | MomentumDivision Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.MomentumDivision.Description Method

public override String Description()

See Also

MomentumDivision Class | MomentumDivision Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MomentumDivisionProperties

Steema.TeeChart.Functions.MomentumDivision Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

MomentumDivision Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Moving

Steema.TeeChart.Functions.Moving Class

Internal use. Base class for moving calculation functions

For a list of all members of this type, see Moving Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class Moving : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

Moving members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MovingMembers

Steema.TeeChart.Functions.Moving all Members

Moving overview

Constructors

Constructor Overloaded

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description (inherited from Function) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Moving Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Moving Constructor

Overload List

public Moving()
public Moving(Steema.TeeChart.Chart)

See Also

Moving Class | Moving Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Moving Constructor

public Moving(Chart c)

See Also

Moving Constructor Overload List | Moving Class | Moving Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Moving Constructor

public Moving()

See Also

Moving Constructor Overload List | Moving Class | Moving Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MovingMethods

Steema.TeeChart.Functions.Moving Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description (inherited from Function) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

Moving Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MovingProperties

Steema.TeeChart.Functions.Moving Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Moving Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MovingAverage

Steema.TeeChart.Functions.MovingAverage Class

Moving Average Function

For a list of all members of this type, see MovingAverage Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.Moving
public class MovingAverage : Moving

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

MovingAverage members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MovingAverageMembers

Steema.TeeChart.Functions.MovingAverage all Members

MovingAverage overview

Constructors

Constructor Overloaded

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Weighted | Set Weighted to true to calculate Mov. Avg. using the corresponding X point values.
WeightedIndex | Set WeightedIndex to true to calculate Mov. Avg. using the source points index as the "weight".

See Also

MovingAverage Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MovingAverage Constructor

Overload List

public MovingAverage()
public MovingAverage(Steema.TeeChart.Chart)

See Also

MovingAverage Class | MovingAverage Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MovingAverage Constructor

public MovingAverage(Chart c)

See Also

MovingAverage Constructor Overload List | MovingAverage Class | MovingAverage Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MovingAverage Constructor

public MovingAverage()

See Also

MovingAverage Constructor Overload List | MovingAverage Class | MovingAverage Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MovingAverageMethods

Steema.TeeChart.Functions.MovingAverage Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

MovingAverage Class | Steema.TeeChart.Functions Namespace


Calculate

Steema.TeeChart.Functions.MovingAverage.Calculate Method

Performs function operation on SourceSeries series.
public override Double Calculate(Series sourceSeries,
     Int32 firstIndex,
     Int32 lastIndex)

See Also

MovingAverage Class | MovingAverage Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.MovingAverage.Description Method

public override String Description()

See Also

MovingAverage Class | MovingAverage Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MovingAverageProperties

Steema.TeeChart.Functions.MovingAverage Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Weighted | Set Weighted to true to calculate Mov. Avg. using the corresponding X point values.
WeightedIndex | Set WeightedIndex to true to calculate Mov. Avg. using the source points index as the "weight".

See Also

MovingAverage Class | Steema.TeeChart.Functions Namespace


Weighted

Steema.TeeChart.Functions.MovingAverage.Weighted Property

Set Weighted to true to calculate Mov. Avg. using the corresponding X point values.
public Boolean Weighted {get; set;}

See Also

MovingAverage Class | MovingAverage Members | Steema.TeeChart.Functions Namespace


WeightedIndex

Steema.TeeChart.Functions.MovingAverage.WeightedIndex Property

Set WeightedIndex to true to calculate Mov. Avg. using the source points index as the "weight".
public Boolean WeightedIndex {get; set;}

See Also

MovingAverage Class | MovingAverage Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Multiply

Steema.TeeChart.Functions.Multiply Class

Multiply Function.

For a list of all members of this type, see Multiply Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.ManySeries
public class Multiply : ManySeries

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

Multiply members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MultiplyMembers

Steema.TeeChart.Functions.Multiply all Members

Multiply overview

Constructors

Constructor

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from ManySeries) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Multiply Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Multiply Constructor

public Multiply()

See Also

Multiply Class | Multiply Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MultiplyMethods

Steema.TeeChart.Functions.Multiply Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from ManySeries) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

Multiply Class | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.Multiply.Description Method

public override String Description()

See Also

Multiply Class | Multiply Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.MultiplyProperties

Steema.TeeChart.Functions.Multiply Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Multiply Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.OBVFunction

Steema.TeeChart.Functions.OBVFunction Class

OBV Function.

For a list of all members of this type, see OBVFunction Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class OBVFunction : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

OBVFunction members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.OBVFunctionMembers

Steema.TeeChart.Functions.OBVFunction all Members

OBVFunction overview

Constructors

Constructor Overloaded

Public Methods

AddPoints | Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Volume | Gets/sets the Volume series by which OBV results are multiplied.

See Also

OBVFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.OBVFunction Constructor

Overload List

public OBVFunction()
public OBVFunction(Steema.TeeChart.Chart)

See Also

OBVFunction Class | OBVFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.OBVFunction Constructor

public OBVFunction(Chart c)

See Also

OBVFunction Constructor Overload List | OBVFunction Class | OBVFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.OBVFunction Constructor

public OBVFunction()

See Also

OBVFunction Constructor Overload List | OBVFunction Class | OBVFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.OBVFunctionMethods

Steema.TeeChart.Functions.OBVFunction Methods

Public Methods

AddPoints | Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

OBVFunction Class | Steema.TeeChart.Functions Namespace


AddPoints

Steema.TeeChart.Functions.OBVFunction.AddPoints Method

Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
public override Void AddPoints(Array source)

See Also

OBVFunction Class | OBVFunction Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.OBVFunction.Description Method

public override String Description()

See Also

OBVFunction Class | OBVFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.OBVFunctionProperties

Steema.TeeChart.Functions.OBVFunction Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Volume | Gets/sets the Volume series by which OBV results are multiplied.

See Also

OBVFunction Class | Steema.TeeChart.Functions Namespace


Volume

Steema.TeeChart.Functions.OBVFunction.Volume Property

Gets/sets the Volume series by which OBV results are multiplied.
public Series Volume {get; set;}

See Also

OBVFunction Class | OBVFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Performance

Steema.TeeChart.Functions.Performance Class

Performance Function.

For a list of all members of this type, see Performance Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.Moving
public class Performance : Moving

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

Performance members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PerformanceMembers

Steema.TeeChart.Functions.Performance all Members

Performance overview

Constructors

Constructor Overloaded

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate |
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Performance Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Performance Constructor

Overload List

public Performance()
public Performance(Steema.TeeChart.Chart)

See Also

Performance Class | Performance Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Performance Constructor

public Performance(Chart c)

See Also

Performance Constructor Overload List | Performance Class | Performance Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Performance Constructor

public Performance()

See Also

Performance Constructor Overload List | Performance Class | Performance Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PerformanceMethods

Steema.TeeChart.Functions.Performance Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate |
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

Performance Class | Steema.TeeChart.Functions Namespace


Calculate

Steema.TeeChart.Functions.Performance.Calculate Method

public override Double Calculate(Series s,
     Int32 firstIndex,
     Int32 lastIndex)

See Also

Performance Class | Performance Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.Performance.Description Method

public override String Description()

See Also

Performance Class | Performance Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PerformanceProperties

Steema.TeeChart.Functions.Performance Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Performance Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PerimeterFunction

Steema.TeeChart.Functions.PerimeterFunction Class

Perimeter function.

For a list of all members of this type, see PerimeterFunction Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class PerimeterFunction : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

PerimeterFunction members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PerimeterFunctionMembers

Steema.TeeChart.Functions.PerimeterFunction all Members

PerimeterFunction overview

Constructors

Constructor Overloaded

Public Methods

AddPoints |
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

PerimeterFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PerimeterFunction Constructor

Overload List

public PerimeterFunction()
public PerimeterFunction(Steema.TeeChart.Chart)

See Also

PerimeterFunction Class | PerimeterFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PerimeterFunction Constructor

public PerimeterFunction(Chart c)

See Also

PerimeterFunction Constructor Overload List | PerimeterFunction Class | PerimeterFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PerimeterFunction Constructor

public PerimeterFunction()

See Also

PerimeterFunction Constructor Overload List | PerimeterFunction Class | PerimeterFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PerimeterFunctionMethods

Steema.TeeChart.Functions.PerimeterFunction Methods

Public Methods

AddPoints |
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

PerimeterFunction Class | Steema.TeeChart.Functions Namespace


AddPoints

Steema.TeeChart.Functions.PerimeterFunction.AddPoints Method

public override Void AddPoints(Array source)

See Also

PerimeterFunction Class | PerimeterFunction Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.PerimeterFunction.Description Method

public override String Description()

See Also

PerimeterFunction Class | PerimeterFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PerimeterFunctionProperties

Steema.TeeChart.Functions.PerimeterFunction Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

PerimeterFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PeriodAligns

Steema.TeeChart.Functions.PeriodAligns Enum

Descibes how a function is aligned with respect to the source series.
[Serializable]
public sealed enum PeriodAligns : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
First | Aligns the function with the first point of the function period.
Center | Aligns the function with the centre point of the function period.
Last | Aligns the function with the last point of the function period.

See Also

Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PeriodStyles

Steema.TeeChart.Functions.PeriodStyles Enum

Descibes function period as a number of points or as a range of points.
[Serializable]
public sealed enum PeriodStyles : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
NumPoints | Defines function period as a number of points.
Range | Defines function period as a range of points.

See Also

Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Poly

Steema.TeeChart.Functions.Poly Class

For a list of all members of this type, see Poly Members

System.Object
public class Poly : Object

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

Poly members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PolyMembers

Steema.TeeChart.Functions.Poly all Members

Poly overview

Constructors

Constructor

Public Fields

maxDegree
PolyCoeff

Public Methods

PolyEval | Evaluate function by using polyDegree polynomial with polyCoeff at value x.
PolyFit | Calculate the polynomial fit

Public Properties

PolyDegree

See Also

Poly Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Poly Constructor

public Poly()

See Also

Poly Class | Poly Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PolyFields

Steema.TeeChart.Functions.Poly Fields

Public Fields

maxDegree
PolyCoeff

See Also

Poly Class | Steema.TeeChart.Functions Namespace


maxDegree

Steema.TeeChart.Functions.Poly.maxDegree Field

public Int32 maxDegree

See Also

Poly Class | Poly Members | Steema.TeeChart.Functions Namespace


PolyCoeff

Steema.TeeChart.Functions.Poly.PolyCoeff Field

public Double[] PolyCoeff

See Also

Poly Class | Poly Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PolyMethods

Steema.TeeChart.Functions.Poly Methods

Public Methods

PolyEval | Evaluate function by using polyDegree polynomial with polyCoeff at value x.
PolyFit | Calculate the polynomial fit

See Also

Poly Class | Steema.TeeChart.Functions Namespace


PolyEval

Steema.TeeChart.Functions.Poly.PolyEval Method

Evaluate function by using polyDegree polynomial with polyCoeff at value x.
public Double PolyEval(Double x)

See Also

Poly Class | Poly Members | Steema.TeeChart.Functions Namespace


PolyFit

Steema.TeeChart.Functions.Poly.PolyFit Method

Calculate the polynomial fit
public Void PolyFit(Int32 numPoints,
     Double[] x,
     Double[] y)

Parameters

numPoints
Number of points to fit
x
x values
y
y values

See Also

Poly Class | Poly Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PolyProperties

Steema.TeeChart.Functions.Poly Properties

Public Properties

PolyDegree

See Also

Poly Class | Steema.TeeChart.Functions Namespace


PolyDegree

Steema.TeeChart.Functions.Poly.PolyDegree Property

public Int32 PolyDegree {get; set;}

See Also

Poly Class | Poly Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PolyFitting

Steema.TeeChart.Functions.PolyFitting Class

Base class for fitting function(s)

For a list of all members of this type, see PolyFitting Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class PolyFitting : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

PolyFitting members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PolyFittingMembers

Steema.TeeChart.Functions.PolyFitting all Members

PolyFitting overview

Constructors

Constructor Overloaded

Public Methods

AddPoints |
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Coefficient | Returns calculated fitted coefficient
Description |
GetCurveYValue | Evaluate function using calculated coefficients
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Factor |
FirstCalcPoint |
FirstPoint |
LastCalcPoint |
LastPoint |
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
PolyDegree |
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

PolyFitting Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PolyFitting Constructor

Overload List

public PolyFitting()
public PolyFitting(Steema.TeeChart.Chart)

See Also

PolyFitting Class | PolyFitting Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PolyFitting Constructor

public PolyFitting(Chart c)

See Also

PolyFitting Constructor Overload List | PolyFitting Class | PolyFitting Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PolyFitting Constructor

public PolyFitting()

See Also

PolyFitting Constructor Overload List | PolyFitting Class | PolyFitting Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PolyFittingMethods

Steema.TeeChart.Functions.PolyFitting Methods

Public Methods

AddPoints |
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Coefficient | Returns calculated fitted coefficient
Description |
GetCurveYValue | Evaluate function using calculated coefficients
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

PolyFitting Class | Steema.TeeChart.Functions Namespace


AddPoints

Steema.TeeChart.Functions.PolyFitting.AddPoints Method

public override Void AddPoints(Array source)

See Also

PolyFitting Class | PolyFitting Members | Steema.TeeChart.Functions Namespace


Coefficient

Steema.TeeChart.Functions.PolyFitting.Coefficient Method

Returns calculated fitted coefficient
public Double Coefficient(Int32 index)

See Also

PolyFitting Class | PolyFitting Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.PolyFitting.Description Method

public override String Description()

See Also

PolyFitting Class | PolyFitting Members | Steema.TeeChart.Functions Namespace


GetCurveYValue

Steema.TeeChart.Functions.PolyFitting.GetCurveYValue Method

Evaluate function using calculated coefficients
public Double GetCurveYValue(Series s,
     Double x)

Parameters

s
Series which contains value
x
Value to be evaluated at

Return Value

y(x) using calculated polynomial coefficients

See Also

PolyFitting Class | PolyFitting Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PolyFittingProperties

Steema.TeeChart.Functions.PolyFitting Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Factor |
FirstCalcPoint |
FirstPoint |
LastCalcPoint |
LastPoint |
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
PolyDegree |
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

PolyFitting Class | Steema.TeeChart.Functions Namespace


Factor

Steema.TeeChart.Functions.PolyFitting.Factor Property

public Int32 Factor {get; set;}

See Also

PolyFitting Class | PolyFitting Members | Steema.TeeChart.Functions Namespace


FirstCalcPoint

Steema.TeeChart.Functions.PolyFitting.FirstCalcPoint Property

public Int32 FirstCalcPoint {get; set;}

See Also

PolyFitting Class | PolyFitting Members | Steema.TeeChart.Functions Namespace


FirstPoint

Steema.TeeChart.Functions.PolyFitting.FirstPoint Property

public Int32 FirstPoint {get; set;}

See Also

PolyFitting Class | PolyFitting Members | Steema.TeeChart.Functions Namespace


LastCalcPoint

Steema.TeeChart.Functions.PolyFitting.LastCalcPoint Property

public Int32 LastCalcPoint {get; set;}

See Also

PolyFitting Class | PolyFitting Members | Steema.TeeChart.Functions Namespace


LastPoint

Steema.TeeChart.Functions.PolyFitting.LastPoint Property

public Int32 LastPoint {get; set;}

See Also

PolyFitting Class | PolyFitting Members | Steema.TeeChart.Functions Namespace


PolyDegree

Steema.TeeChart.Functions.PolyFitting.PolyDegree Property

public Int32 PolyDegree {get; set;}

See Also

PolyFitting Class | PolyFitting Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PVOFunction

Steema.TeeChart.Functions.PVOFunction Class

PVO Function.

For a list of all members of this type, see PVOFunction Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class PVOFunction : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

PVOFunction members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PVOFunctionMembers

Steema.TeeChart.Functions.PVOFunction all Members

PVOFunction overview

Constructors

Constructor Overloaded

Public Methods

AddPoints | Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Percentage | Controls if the difference of two moving averages will be percentual or not.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
Period2 | Defines the period of the second exponential moving average.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

PVOFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PVOFunction Constructor

Overload List

public PVOFunction()
public PVOFunction(Steema.TeeChart.Chart)

See Also

PVOFunction Class | PVOFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PVOFunction Constructor

public PVOFunction(Chart c)

See Also

PVOFunction Constructor Overload List | PVOFunction Class | PVOFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PVOFunction Constructor

public PVOFunction()

See Also

PVOFunction Constructor Overload List | PVOFunction Class | PVOFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PVOFunctionMethods

Steema.TeeChart.Functions.PVOFunction Methods

Public Methods

AddPoints | Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

PVOFunction Class | Steema.TeeChart.Functions Namespace


AddPoints

Steema.TeeChart.Functions.PVOFunction.AddPoints Method

Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
public override Void AddPoints(Array source)

See Also

PVOFunction Class | PVOFunction Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.PVOFunction.Description Method

public override String Description()

See Also

PVOFunction Class | PVOFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.PVOFunctionProperties

Steema.TeeChart.Functions.PVOFunction Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Percentage | Controls if the difference of two moving averages will be percentual or not.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
Period2 | Defines the period of the second exponential moving average.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

PVOFunction Class | Steema.TeeChart.Functions Namespace


Percentage

Steema.TeeChart.Functions.PVOFunction.Percentage Property

Controls if the difference of two moving averages will be percentual or not.
public Boolean Percentage {get; set;}

See Also

PVOFunction Class | PVOFunction Members | Steema.TeeChart.Functions Namespace


Period2

Steema.TeeChart.Functions.PVOFunction.Period2 Property

Defines the period of the second exponential moving average.
public Int32 Period2 {get; set;}

See Also

PVOFunction Class | PVOFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Regression

Steema.TeeChart.Functions.Regression Class

For a list of all members of this type, see Regression Members

System.Object
public class Regression : Object

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

Regression members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.RegressionMembers

Steema.TeeChart.Functions.Regression all Members

Regression overview

Constructors

Constructor

Public Methods

LinearRegression Ordinary least-square linear regression with or without weights

See Also

Regression Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Regression Constructor

public Regression()

See Also

Regression Class | Regression Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.RegressionMethods

Steema.TeeChart.Functions.Regression Methods

Public Methods

LinearRegression Ordinary least-square linear regression with or without weights

See Also

Regression Class | Steema.TeeChart.Functions Namespace


LinearRegression

Steema.TeeChart.Functions.Regression.LinearRegression Method

Ordinary least-square linear regression with or without weights
public static Void LinearRegression(Int32 numpoints,
     Double[] x,
     Double[] y,
     Double[] weights,
     Double[]& coeffs)

Parameters

numpoints
The number of points in x array.
x
Array of x values. The size of x and y must be the same.
y
Array of y values. The size of x and x must be the same.
weights
Point weights. If null, no weights are used in linear regression.
coeffs
Returns linear regression coefficients.

See Also

Regression Class | Regression Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.RootMeanSquare

Steema.TeeChart.Functions.RootMeanSquare Class

Root Mean Square Function.

For a list of all members of this type, see RootMeanSquare Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class RootMeanSquare : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

RootMeanSquare members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.RootMeanSquareMembers

Steema.TeeChart.Functions.RootMeanSquare all Members

RootMeanSquare overview

Constructors

Constructor Overloaded

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Complete | Defines the RMS formula.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

RootMeanSquare Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.RootMeanSquare Constructor

Overload List

public RootMeanSquare()
public RootMeanSquare(Steema.TeeChart.Chart)

See Also

RootMeanSquare Class | RootMeanSquare Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.RootMeanSquare Constructor

public RootMeanSquare(Chart c)

See Also

RootMeanSquare Constructor Overload List | RootMeanSquare Class | RootMeanSquare Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.RootMeanSquare Constructor

public RootMeanSquare()

See Also

RootMeanSquare Constructor Overload List | RootMeanSquare Class | RootMeanSquare Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.RootMeanSquareMethods

Steema.TeeChart.Functions.RootMeanSquare Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

RootMeanSquare Class | Steema.TeeChart.Functions Namespace


Calculate

Steema.TeeChart.Functions.RootMeanSquare.Calculate Method

Performs function operation on SourceSeries series.
public override Double Calculate(Series s,
     Int32 firstIndex,
     Int32 lastIndex)

See Also

RootMeanSquare Class | RootMeanSquare Members | Steema.TeeChart.Functions Namespace


CalculateMany

Steema.TeeChart.Functions.RootMeanSquare.CalculateMany Method

Performs function operation on list of series (SourceSeriesList).
public override Double CalculateMany(ArrayList sourceSeries,
     Int32 valueIndex)

See Also

RootMeanSquare Class | RootMeanSquare Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.RootMeanSquare.Description Method

public override String Description()

See Also

RootMeanSquare Class | RootMeanSquare Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.RootMeanSquareProperties

Steema.TeeChart.Functions.RootMeanSquare Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Complete | Defines the RMS formula.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

RootMeanSquare Class | Steema.TeeChart.Functions Namespace


Complete

Steema.TeeChart.Functions.RootMeanSquare.Complete Property

Defines the RMS formula.
public Boolean Complete {get; set;}

See Also

RootMeanSquare Class | RootMeanSquare Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.RSIFunction

Steema.TeeChart.Functions.RSIFunction Class

RSIFunction is a Line Series derived component that calculates a percent value based on Financial data. RSIFunction must be connected to a OHLC Series or any derived Series component (e.g. Candle). Like a MovingAverage Function, RSI will calculate a new point Y value by using previous Period points. The used formula is: Add all Close prices greater than Open prices and divide by ocurrences (Ups). Add all Close prices lower than Open prices and divide by ocurrences (Downs). RSI = 100.0 - ( 100.0 / ( 1.0 + Math.Abs( Ups / Downs ) ) ) To see a visual representation of TeeChart Extended Functions, go to the TeeChart User Guide.

For a list of all members of this type, see RSIFunction Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.Moving
public class RSIFunction : Moving

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

RSIFunction members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.RSIFunctionMembers

Steema.TeeChart.Functions.RSIFunction all Members

RSIFunction overview

Constructors

Constructor Overloaded

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate |
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Style | Sets the RSI function to use either Open or Close values.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

RSIFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.RSIFunction Constructor

Overload List

public RSIFunction()
public RSIFunction(Steema.TeeChart.Chart)

See Also

RSIFunction Class | RSIFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.RSIFunction Constructor

public RSIFunction(Chart c)

See Also

RSIFunction Constructor Overload List | RSIFunction Class | RSIFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.RSIFunction Constructor

public RSIFunction()

See Also

RSIFunction Constructor Overload List | RSIFunction Class | RSIFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.RSIFunctionMethods

Steema.TeeChart.Functions.RSIFunction Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate |
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

RSIFunction Class | Steema.TeeChart.Functions Namespace


Calculate

Steema.TeeChart.Functions.RSIFunction.Calculate Method

public override Double Calculate(Series source,
     Int32 first,
     Int32 last)

See Also

RSIFunction Class | RSIFunction Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.RSIFunction.Description Method

public override String Description()

See Also

RSIFunction Class | RSIFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.RSIFunctionProperties

Steema.TeeChart.Functions.RSIFunction Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Style | Sets the RSI function to use either Open or Close values.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

RSIFunction Class | Steema.TeeChart.Functions Namespace


Style

Steema.TeeChart.Functions.RSIFunction.Style Property

Sets the RSI function to use either Open or Close values.
public RSIStyle Style {get; set;}

See Also

RSIFunction Class | RSIFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.RSIStyle

Steema.TeeChart.Functions.RSIStyle Enum

Used in see cref="RSIFunction.Style"/> property.
[Serializable]
public sealed enum RSIStyle : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
OpenClose | Uses Close values comparative to their respective Open Values.
Close | Uses Close values comparative to prior Close values.

See Also

Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.SARFunction

Steema.TeeChart.Functions.SARFunction Class

Parabolic Stop And Reversal financial indicator.

For a list of all members of this type, see SARFunction Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class SARFunction : Function

Remarks

The Parabolic SAR, developed by Welles Wilder, is used to set trailing price stops. SAR refers to "Stop-And-Reversal". It is designed to create exit points for both long and short positions in such a way that it allows for reactions or fluctuations at the beginning of the position, but accelerates upward (for long positions) or downward (for short positions) as the movement tops out.

Parabolic SAR is plotted around the price chart similar to a moving average. The basics behind the formula for computing the SAR values can be found above.

The Parabolic SAR provides excellent exit points. You should close long positions when the price falls below the SAR and close short positions when the price rises above the SAR.

If you are long (i.e., the price is above the SAR), the SAR will move up every day, regardless of the direction the price is moving. The amount the SAR moves up depends on the amount that prices move. Wilder suggests using this indicator in a trending (or directional) market. If the security is trending up, then one might only take long positions. If the security is trending down, one might only take short positions.

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

SARFunction members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.SARFunctionMembers

Steema.TeeChart.Functions.SARFunction all Members

SARFunction overview

Constructors

Constructor Overloaded

Public Methods

AddPoints |
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

AccelerationFactor | Defines Wilder acceleration factor.
Chart (inherited from TeeBase) | Chart associated with this object
MaxStep | Defines maximum step in SAR calculation.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

SARFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.SARFunction Constructor

Overload List

public SARFunction()
public SARFunction(Steema.TeeChart.Chart)

See Also

SARFunction Class | SARFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.SARFunction Constructor

public SARFunction(Chart c)

See Also

SARFunction Constructor Overload List | SARFunction Class | SARFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.SARFunction Constructor

public SARFunction()

See Also

SARFunction Constructor Overload List | SARFunction Class | SARFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.SARFunctionMethods

Steema.TeeChart.Functions.SARFunction Methods

Public Methods

AddPoints |
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

SARFunction Class | Steema.TeeChart.Functions Namespace


AddPoints

Steema.TeeChart.Functions.SARFunction.AddPoints Method

public override Void AddPoints(Array source)

See Also

SARFunction Class | SARFunction Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.SARFunction.Description Method

public override String Description()

See Also

SARFunction Class | SARFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.SARFunctionProperties

Steema.TeeChart.Functions.SARFunction Properties

Public Properties

AccelerationFactor | Defines Wilder acceleration factor.
Chart (inherited from TeeBase) | Chart associated with this object
MaxStep | Defines maximum step in SAR calculation.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

SARFunction Class | Steema.TeeChart.Functions Namespace


AccelerationFactor

Steema.TeeChart.Functions.SARFunction.AccelerationFactor Property

Defines Wilder acceleration factor.
public Double AccelerationFactor {get; set;}

See Also

SARFunction Class | SARFunction Members | Steema.TeeChart.Functions Namespace


MaxStep

Steema.TeeChart.Functions.SARFunction.MaxStep Property

Defines maximum step in SAR calculation.
public Double MaxStep {get; set;}

See Also

SARFunction Class | SARFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Smoothing

Steema.TeeChart.Functions.Smoothing Class

Smoothing Function.

For a list of all members of this type, see Smoothing Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class Smoothing : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

Smoothing members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.SmoothingMembers

Steema.TeeChart.Functions.Smoothing all Members

Smoothing overview

Constructors

Constructor Overloaded

Public Methods

AddPoints | Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Factor | Gets or sets number of times the resulting smooth points are in quantity compared to source points.
Interpolate | When true, resulting smooth curves will pass exactly over source points.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Smoothing Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Smoothing Constructor

Overload List

public Smoothing()
public Smoothing(Steema.TeeChart.Chart)

See Also

Smoothing Class | Smoothing Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Smoothing Constructor

public Smoothing(Chart c)

See Also

Smoothing Constructor Overload List | Smoothing Class | Smoothing Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Smoothing Constructor

public Smoothing()

See Also

Smoothing Constructor Overload List | Smoothing Class | Smoothing Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.SmoothingMethods

Steema.TeeChart.Functions.Smoothing Methods

Public Methods

AddPoints | Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

Smoothing Class | Steema.TeeChart.Functions Namespace


AddPoints

Steema.TeeChart.Functions.Smoothing.AddPoints Method

Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
public override Void AddPoints(Array source)

See Also

Smoothing Class | Smoothing Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.Smoothing.Description Method

public override String Description()

See Also

Smoothing Class | Smoothing Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.SmoothingProperties

Steema.TeeChart.Functions.Smoothing Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Factor | Gets or sets number of times the resulting smooth points are in quantity compared to source points.
Interpolate | When true, resulting smooth curves will pass exactly over source points.
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Smoothing Class | Steema.TeeChart.Functions Namespace


Factor

Steema.TeeChart.Functions.Smoothing.Factor Property

Gets or sets number of times the resulting smooth points are in quantity compared to source points.
public Int32 Factor {get; set;}

See Also

Smoothing Class | Smoothing Members | Steema.TeeChart.Functions Namespace


Interpolate

Steema.TeeChart.Functions.Smoothing.Interpolate Property

When true, resulting smooth curves will pass exactly over source points.
public Boolean Interpolate {get; set;}

See Also

Smoothing Class | Smoothing Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Spline

Steema.TeeChart.Functions.Spline Class

Spline smoothing.

For a list of all members of this type, see Spline Members

System.Object
public class Spline : Object

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

Spline members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.SplineMembers

Steema.TeeChart.Functions.Spline all Members

Spline overview

Constructors

Constructor

Public Methods

AddPoint | Adds a new source point with specified X and Y values.
Clear | Removes all source points.
Rebuild | Calculates new smoothed points from internal list of points.
SetKnuckle |
Value | Returns an interpolated point.

Public Properties

Build | Indicates the spline has already calculated smooth points.
Fragments | Gets or sets the number of resulting smooth points.
Interpolated | When true, the spline calculates interpolated points that will pass exactly over source points.
Item |
NumberOfVertices | Returns the number of total source points.

See Also

Spline Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Spline Constructor

public Spline()

See Also

Spline Class | Spline Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.SplineMethods

Steema.TeeChart.Functions.Spline Methods

Public Methods

AddPoint | Adds a new source point with specified X and Y values.
Clear | Removes all source points.
Rebuild | Calculates new smoothed points from internal list of points.
SetKnuckle |
Value | Returns an interpolated point.

See Also

Spline Class | Steema.TeeChart.Functions Namespace


AddPoint

Steema.TeeChart.Functions.Spline.AddPoint Method

Adds a new source point with specified X and Y values.
public Void AddPoint(Double X,
     Double Y)

See Also

Spline Class | Spline Members | Steema.TeeChart.Functions Namespace


Clear

Steema.TeeChart.Functions.Spline.Clear Method

Removes all source points.
public Void Clear()

See Also

Spline Class | Spline Members | Steema.TeeChart.Functions Namespace


Rebuild

Steema.TeeChart.Functions.Spline.Rebuild Method

Calculates new smoothed points from internal list of points.
public Void Rebuild()

See Also

Spline Class | Spline Members | Steema.TeeChart.Functions Namespace


SetKnuckle

Steema.TeeChart.Functions.Spline.SetKnuckle Method

public Void SetKnuckle(Int32 index,
     Boolean value)

See Also

Spline Class | Spline Members | Steema.TeeChart.Functions Namespace


Value

Steema.TeeChart.Functions.Spline.Value Method

Returns an interpolated point.
public PointDouble Value(Double Parameter)

See Also

Spline Class | Spline Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.SplineProperties

Steema.TeeChart.Functions.Spline Properties

Public Properties

Build | Indicates the spline has already calculated smooth points.
Fragments | Gets or sets the number of resulting smooth points.
Interpolated | When true, the spline calculates interpolated points that will pass exactly over source points.
Item |
NumberOfVertices | Returns the number of total source points.

See Also

Spline Class | Steema.TeeChart.Functions Namespace


Build

Steema.TeeChart.Functions.Spline.Build Property

Indicates the spline has already calculated smooth points.
public Boolean Build {get; set;}

See Also

Spline Class | Spline Members | Steema.TeeChart.Functions Namespace


Fragments

Steema.TeeChart.Functions.Spline.Fragments Property

Gets or sets the number of resulting smooth points.
public Int32 Fragments {get; set;}

See Also

Spline Class | Spline Members | Steema.TeeChart.Functions Namespace


Interpolated

Steema.TeeChart.Functions.Spline.Interpolated Property

When true, the spline calculates interpolated points that will pass exactly over source points.
public Boolean Interpolated {get; set;}

See Also

Spline Class | Spline Members | Steema.TeeChart.Functions Namespace


Item

Steema.TeeChart.Functions.Spline.Item Property

public PointDouble Item(Int32 index) {get; set;}

See Also

Spline Class | Spline Members | Steema.TeeChart.Functions Namespace


NumberOfVertices

Steema.TeeChart.Functions.Spline.NumberOfVertices Property

Returns the number of total source points.
public Int32 NumberOfVertices {get;}

See Also

Spline Class | Spline Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.StdDeviation

Steema.TeeChart.Functions.StdDeviation Class

Standard Deviation Function.

For a list of all members of this type, see StdDeviation Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class StdDeviation : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

StdDeviation members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.StdDeviationMembers

Steema.TeeChart.Functions.StdDeviation all Members

StdDeviation overview

Constructors

Constructor Overloaded

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Complete |
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

StdDeviation Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.StdDeviation Constructor

Overload List

public StdDeviation()
public StdDeviation(Steema.TeeChart.Chart)

See Also

StdDeviation Class | StdDeviation Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.StdDeviation Constructor

public StdDeviation(Chart c)

See Also

StdDeviation Constructor Overload List | StdDeviation Class | StdDeviation Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.StdDeviation Constructor

public StdDeviation()

See Also

StdDeviation Constructor Overload List | StdDeviation Class | StdDeviation Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.StdDeviationMethods

Steema.TeeChart.Functions.StdDeviation Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

StdDeviation Class | Steema.TeeChart.Functions Namespace


Calculate

Steema.TeeChart.Functions.StdDeviation.Calculate Method

Performs function operation on SourceSeries series.
public override Double Calculate(Series s,
     Int32 firstIndex,
     Int32 lastIndex)

See Also

StdDeviation Class | StdDeviation Members | Steema.TeeChart.Functions Namespace


CalculateMany

Steema.TeeChart.Functions.StdDeviation.CalculateMany Method

Performs function operation on list of series (SourceSeriesList).
public override Double CalculateMany(ArrayList sourceSeries,
     Int32 valueIndex)

See Also

StdDeviation Class | StdDeviation Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.StdDeviation.Description Method

public override String Description()

See Also

StdDeviation Class | StdDeviation Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.StdDeviationProperties

Steema.TeeChart.Functions.StdDeviation Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Complete |
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

StdDeviation Class | Steema.TeeChart.Functions Namespace


Complete

Steema.TeeChart.Functions.StdDeviation.Complete Property

public Boolean Complete {get; set;}

See Also

StdDeviation Class | StdDeviation Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Stochastic

Steema.TeeChart.Functions.Stochastic Class

Stochastic Function.

For a list of all members of this type, see Stochastic Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.Moving
public class Stochastic : Moving

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

Stochastic members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.StochasticMembers

Steema.TeeChart.Functions.Stochastic all Members

Stochastic overview

Constructors

Constructor Overloaded

Public Methods

AddPoints | Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Stochastic Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Stochastic Constructor

Overload List

public Stochastic()
public Stochastic(Steema.TeeChart.Chart)

See Also

Stochastic Class | Stochastic Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Stochastic Constructor

public Stochastic(Chart c)

See Also

Stochastic Constructor Overload List | Stochastic Class | Stochastic Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Stochastic Constructor

public Stochastic()

See Also

Stochastic Constructor Overload List | Stochastic Class | Stochastic Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.StochasticMethods

Steema.TeeChart.Functions.Stochastic Methods

Public Methods

AddPoints | Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
Calculate | Performs function operation on SourceSeries series.
CalculateMany (inherited from Function) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

Stochastic Class | Steema.TeeChart.Functions Namespace


AddPoints

Steema.TeeChart.Functions.Stochastic.AddPoints Method

Gets all points from Source series, performs a function operation on points and stores results in ParentSeries.
public override Void AddPoints(Array source)

See Also

Stochastic Class | Stochastic Members | Steema.TeeChart.Functions Namespace


Calculate

Steema.TeeChart.Functions.Stochastic.Calculate Method

Performs function operation on SourceSeries series.
public override Double Calculate(Series s,
     Int32 firstIndex,
     Int32 lastIndex)

See Also

Stochastic Class | Stochastic Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.Stochastic.Description Method

public override String Description()

See Also

Stochastic Class | Stochastic Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.StochasticProperties

Steema.TeeChart.Functions.Stochastic Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Stochastic Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Subtract

Steema.TeeChart.Functions.Subtract Class

Subtract Function.

For a list of all members of this type, see Subtract Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.ManySeries
public class Subtract : ManySeries

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

Subtract members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.SubtractMembers

Steema.TeeChart.Functions.Subtract all Members

Subtract overview

Constructors

Constructor

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from ManySeries) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Subtract Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.Subtract Constructor

public Subtract()

See Also

Subtract Class | Subtract Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.SubtractMethods

Steema.TeeChart.Functions.Subtract Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from Function) | Performs function operation on SourceSeries series.
CalculateMany (inherited from ManySeries) | Performs function operation on list of series (SourceSeriesList).
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

Subtract Class | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.Subtract.Description Method

public override String Description()

See Also

Subtract Class | Subtract Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.SubtractProperties

Steema.TeeChart.Functions.Subtract Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Subtract Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.TrendFunction

Steema.TeeChart.Functions.TrendFunction Class

Trendline function

For a list of all members of this type, see TrendFunction Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.BaseTrend
public class TrendFunction : BaseTrend

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

TrendFunction members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.TrendFunctionMembers

Steema.TeeChart.Functions.TrendFunction all Members

TrendFunction overview

Constructors

Constructor

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from BaseTrend) |
CalculateMany (inherited from BaseTrend) |
CalculateTrend (inherited from BaseTrend) | Calculates trendline paramaters m and b, where y=m*x+b
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
RSquared (inherited from BaseTrend) |
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TrendStyle (inherited from BaseTrend) | Defines different methods for calculating trendline
UseDecimals (inherited from BaseTrend) | Gets and sets whether System.Decimal is used instead of System.Double for the internal algorithms. When true, algorithms are more accurate but accept a smaller range of numbers.

See Also

TrendFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.TrendFunction Constructor

public TrendFunction()

See Also

TrendFunction Class | TrendFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.TrendFunctionMethods

Steema.TeeChart.Functions.TrendFunction Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate (inherited from BaseTrend) |
CalculateMany (inherited from BaseTrend) |
CalculateTrend (inherited from BaseTrend) | Calculates trendline paramaters m and b, where y=m*x+b
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

TrendFunction Class | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.TrendFunction.Description Method

public override String Description()

See Also

TrendFunction Class | TrendFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.TrendFunctionProperties

Steema.TeeChart.Functions.TrendFunction Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
RSquared (inherited from BaseTrend) |
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TrendStyle (inherited from BaseTrend) | Defines different methods for calculating trendline
UseDecimals (inherited from BaseTrend) | Gets and sets whether System.Decimal is used instead of System.Double for the internal algorithms. When true, algorithms are more accurate but accept a smaller range of numbers.

See Also

TrendFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.TrendStyles

Steema.TeeChart.Functions.TrendStyles Enum

Defines different trend styles.
[Serializable]
public sealed enum TrendStyles : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
Normal | Normal linear fit.
Logarithmic | Logarithmic fit.
Exponential | Exponential fit

See Also

Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.VarianceFunction

Steema.TeeChart.Functions.VarianceFunction Class

Variance function.

For a list of all members of this type, see VarianceFunction Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class VarianceFunction : Function

Requirements

Namespace: Steema.TeeChart.Functions Namespace

Assembly: TeeChart.Android.dll

See Also

VarianceFunction members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.VarianceFunctionMembers

Steema.TeeChart.Functions.VarianceFunction all Members

VarianceFunction overview

Constructors

Constructor

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on s series.
CalculateMany | Performs function operation on all sourceSeries series.
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

VarianceFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.VarianceFunction Constructor

public VarianceFunction()

See Also

VarianceFunction Class | VarianceFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.VarianceFunctionMethods

Steema.TeeChart.Functions.VarianceFunction Methods

Public Methods

AddPoints (inherited from Function) | Gets all points from Source series, performs a function operation and stores results in ParentSeries.
Calculate | Performs function operation on s series.
CalculateMany | Performs function operation on all sourceSeries series.
Clear (inherited from Function) |
Description |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Recalculate (inherited from Function) | Performs a CheckDataSource method on ParentSeries.

See Also

VarianceFunction Class | Steema.TeeChart.Functions Namespace


Calculate

Steema.TeeChart.Functions.VarianceFunction.Calculate Method

Performs function operation on s series.
public override Double Calculate(Series s,
     Int32 firstIndex,
     Int32 lastIndex)

See Also

VarianceFunction Class | VarianceFunction Members | Steema.TeeChart.Functions Namespace


CalculateMany

Steema.TeeChart.Functions.VarianceFunction.CalculateMany Method

Performs function operation on all sourceSeries series.
public override Double CalculateMany(ArrayList sourceSeries,
     Int32 valueIndex)

See Also

VarianceFunction Class | VarianceFunction Members | Steema.TeeChart.Functions Namespace


Description

Steema.TeeChart.Functions.VarianceFunction.Description Method

public override String Description()

See Also

VarianceFunction Class | VarianceFunction Members | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Functions.VarianceFunctionProperties

Steema.TeeChart.Functions.VarianceFunction Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Period (inherited from Function) | Controls how many points or X range will trigger a new point calculation.
PeriodAlign (inherited from Function) | Controls where to place function calculations inside the full period space.
PeriodStyle (inherited from Function) | Controls how the Period property is interpreted.
Series (inherited from Function) | Returns the TChartSeries parent of TTeeFunction.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

VarianceFunction Class | Steema.TeeChart.Functions Namespace


Steema.TeeChart.Languages

Steema.TeeChart.Languages Namespace

Namespace hierarchy

Public Interfaces

ITranslator

Public Classes

English English Constants.

Requirements

Namespace: Steema.TeeChart.Languages Namespace

Assembly: TeeChart.Android.dll


Steema.TeeChart.Languages Hierarchy

System.Object

Steema.TeeChart.Texts

Steema.TeeChart.Languages.English

See Also

SteemaTeeChartLanguages Namespace


Steema.TeeChart.Languages.English

Steema.TeeChart.Languages.English Class

English Constants.

For a list of all members of this type, see English Members

System.Object
Steema.TeeChart.Texts
public sealed class English : Texts

Requirements

Namespace: Steema.TeeChart.Languages Namespace

Assembly: TeeChart.Android.dll

See Also

English members | Steema.TeeChart.Languages Namespace


Steema.TeeChart.Languages.EnglishMembers

Steema.TeeChart.Languages.English all Members

English overview

Public Fields

TextsOk

Public Methods

Activate
SetTexts

See Also

English Class | Steema.TeeChart.Languages Namespace


Steema.TeeChart.Languages.EnglishFields

Steema.TeeChart.Languages.English Fields

Public Fields

TextsOk

See Also

English Class | Steema.TeeChart.Languages Namespace


TextsOk

Steema.TeeChart.Languages.English.TextsOk Field

public Boolean TextsOk

See Also

English Class | English Members | Steema.TeeChart.Languages Namespace


Steema.TeeChart.Languages.EnglishMethods

Steema.TeeChart.Languages.English Methods

Public Methods

Activate
SetTexts

See Also

English Class | Steema.TeeChart.Languages Namespace


Activate

Steema.TeeChart.Languages.English.Activate Method

public static Void Activate()

See Also

English Class | English Members | Steema.TeeChart.Languages Namespace


SetTexts

Steema.TeeChart.Languages.English.SetTexts Method

public static Void SetTexts()

See Also

English Class | English Members | Steema.TeeChart.Languages Namespace


Steema.TeeChart.Languages.ITranslator

Steema.TeeChart.Languages.ITranslator Interface

public interface ITranslator

Requirements

Namespace: Steema.TeeChart.Languages Namespace

Assembly: TeeChart.Android.dll

See Also

ITranslator members | Steema.TeeChart.Languages Namespace


Steema.TeeChart.Languages.ITranslatorMembers

Steema.TeeChart.Languages.ITranslator all Members

ITranslator overview

Public Methods

AskLanguage
GetLanguage
HasUpperCase
InitLanguage
LanguageToString
Translate

See Also

ITranslator Interface | Steema.TeeChart.Languages Namespace


Steema.TeeChart.Languages.ITranslatorMethods

Steema.TeeChart.Languages.ITranslator Methods

Public Methods

AskLanguage
GetLanguage
HasUpperCase
InitLanguage
LanguageToString
Translate

See Also

ITranslator Interface | Steema.TeeChart.Languages Namespace


AskLanguage

Steema.TeeChart.Languages.ITranslator.AskLanguage Method

public abstract Boolean AskLanguage(Int32& language)

See Also

ITranslator Interface | ITranslator Members | Steema.TeeChart.Languages Namespace


GetLanguage

Steema.TeeChart.Languages.ITranslator.GetLanguage Method

public abstract String GetLanguage()

See Also

ITranslator Interface | ITranslator Members | Steema.TeeChart.Languages Namespace


HasUpperCase

Steema.TeeChart.Languages.ITranslator.HasUpperCase Method

public abstract Boolean HasUpperCase()

See Also

ITranslator Interface | ITranslator Members | Steema.TeeChart.Languages Namespace


InitLanguage

Steema.TeeChart.Languages.ITranslator.InitLanguage Method

public abstract Void InitLanguage(Int32 language)

See Also

ITranslator Interface | ITranslator Members | Steema.TeeChart.Languages Namespace


LanguageToString

Steema.TeeChart.Languages.ITranslator.LanguageToString Method

public abstract String LanguageToString(Int32 language)

See Also

ITranslator Interface | ITranslator Members | Steema.TeeChart.Languages Namespace


Translate

Steema.TeeChart.Languages.ITranslator.Translate Method

Overload List

public abstract Void Translate(Android.Views.View)
public abstract Void Translate(Android.Views.View, System.Collections.ArrayList)

See Also

ITranslator Interface | ITranslator Members | Steema.TeeChart.Languages Namespace


Translate

Steema.TeeChart.Languages.ITranslator.Translate Method

public abstract Void Translate(View c,
     ArrayList excludechildren)

See Also

Translate Overload List | ITranslator Interface | ITranslator Members | Steema.TeeChart.Languages Namespace


Translate

Steema.TeeChart.Languages.ITranslator.Translate Method

public abstract Void Translate(View c)

See Also

Translate Overload List | ITranslator Interface | ITranslator Members | Steema.TeeChart.Languages Namespace


Steema.TeeChart.Styles

Steema.TeeChart.Styles Namespace

Namespace hierarchy

Public Enumerations

ValueListOrder | Describes the possible values of the Order property.
HorizontalAxis | Describes the possible values of the HorizAxis property.
VerticalAxis | Describes the possible values of the VertAxis property.
TreatNullsStyle | Defines how to treat null points.
SeriesEventStyle | For internal use.
SeriesGroupActive | Describes the possible values of the Active property.
MarksStyles | Describes the possible values of the Style property.
ArrowHeadStyles |
ArrowHeadDirection |
MultiAreas | Describes the possible values of the MultiArea property.
CandleStyles | Describes the possible values of the Style property.
ClockStyles | Describes the possible values of the Style property.
Sides | Reserved for future use.
ContourConstruction | Contour level construction algorithm.
PointerStyles | Describes the pointer style of a series pointer.
CustomStack | Describes the possible values of the Stacked property.
PaletteStyles | Describes the possible values of the PaletteStyle property.
MultiBars | Describes the possible values of the MultiBar property.
BarStyles | Describes the possible values of the BarStyle property.
MarksLocation | Describes the possible values of the MarksLocation property.
BoxTypes | Box type for calculation
PricingMethods | Price method used for calculation
BoxFillType | Box fill style for each data point
ErrorStyles | Describes the possible values of the ErrorStyle property.
ErrorWidthUnits | Describes the possible values of the ErrorWidthUnits property.
DrawAllPointsStyle |
HandStyle | Describes the possible values of the HandStyle property.
DigitalFont |
OrgLineStyle | Defines the type of connecting lines between organizational chart items.
PieOtherStyles | Describes the possible values of the Style property of the PieOtherSlice class.
MultiPies | Describes the possible values of the MultiPie property of the Pie class.
ShapeXYStyles | Describes the possible values of the XYStyle property.
ShapeStyles | Describes the possible values of the Style property.
ShapeTextVertAlign | Describes the possible values of the VertAlignment property.
ShapeTextHorizAlign | Describes the possible values of the HorizAlignment property.
TagCloudOrder |
TernaryAxisScale |
TernaryStyle |
TernaryMarkStyle |
TernaryFormat |
TernaryLegendStyle |
TowerStyles | Describes the possible values of the TowerStyle property.
TreeMapColorStyle |
TreeMapTiling |

Public Classes

SeriesPoint | Class provides access to Point characteristics
SeriesXYPoint | Class provides access to XY Point characteristics
ValueList | Array to hold Series data point values.
StringList | The StringList class is manipulated via the Series Labels property.
ColorList | The ColorList class is manipulated via the Series Colors property.
BeforeDrawPointEventArgs | The Event Data for the BeforeDrawPoint event.
GetSeriesMarkEventArgs | The Event Data for the GetSeriesMark event.
SeriesEvent | Listens to all the Series class events.
SeriesGroup | Access to series group characteristics
SeriesGroups | Access to series groups characteristics
Series | The base class for all TeeChart Series styles.
SeriesCollection | The SeriesCollection class, a collection of Series objects, is manipulated via the Chart Series property.
SeriesPointer | Some Series have a Pointer property which returns a SeriesPointer class. Pointers are shape figures drawn on each Y point coordinates.
Callout | Mark Callout pointer characteristics
MarksCallout |
MarksItem |
MarksItems |
SeriesMarks | Series Marks characteristics
Symbols | Series Mark Symbols
Position | Series Mark Position
MarkPositions | Series Marks' Positions
BaseLine | Abstract Series class inherited by a number of TeeChart series styles.
CustomPoint | Base Series class inherited by a number of TeeChart series styles.
Custom | Base Series class inherited by a number of TeeChart series styles.
Area | Area Series
Points | Point Series.
Arrow | Arrow Series.
CustomBar | Custom Bar Series.
GetBarStyleEventArgs | The Event Data for the GetBarStyle event.
Bar | The Bar Series component outputs all points as vertical bars.
Bar3D | Bar3D Series.
BarJoin | BarJoin series.
Bezier | Bezier series.
Bubble | Bubble Series.
Calendar | Calendar series.
CalendarChangeEventArgs | The Event Data for the Change event.
CalendarCell | Contains the characteristics of each Calendar Cell.
CalendarCellUpper | Format information for the upper row cells of the Calendar Series.
SeriesOHLCPoint | Class provides access to XYZ Point characteristics
OHLC | OHLC is an base Series class that maintains lists for Open, Close, High and Low values.
Candle | Candle Series.
Circular | Circled Series.
CircularGauge | CircularGauge Series.
TFrame | The TFrame object draws a frame of three bands at the outer edge of an ellipse or circle defined by a rectangle.
CFrame |
CustomPolar | CustomPolar Series.
Custom2DPolar | Custom2DPolar is the ancestor of the WindRose Series and the Clock Series.
Clock | Clock Series.
Custom3D | Custom3D Series.
Custom3DPalette | Custom3DPalette Series Style.
GetColorEventArgs | The Event Data for the GetValueColor event.
Custom3DGrid | Custom3DGridSeries
GetYValueEventArgs | The Event Data for the GetYValue event.
ColorGrid | The ColorGrid series displays a grid of color cells.
LevelSegment |
ContourLevel | Contains characteristic information for a Contour series' "level".
ContourSeriesMarks |
Contour | The Contour series calculates and displays "isolines" from a custom array of XYZ points.
GetLevelEventArgs | The Event Data for the GetLevel event.
DrawLevelEventArgs | The Event Data for the DrawLevel event.
ContourDraw | Composite of the Contour series class.
GetPointerStyleEventArgs | The Event Data for the GetPointerStyle event.
SeriesXYZPoint | Class provides access to XYZ Point characteristics
CustomBox | CustomBox Series.
Box | The Box Series plots a vertical box series.
HorizBox | The Box Series plots an horizontal box series.
GaugeSeriesPointer | Derived from SeriesPointer, GaugeSeriesPointer implements pointer styles specific to the CircularGauge series.
CustomGauge |
ColorLineCollection | Collection of GaugeSeriesPointers.
ColorLineStartValues | Collection of integer values defining the StartValues of the ColorLines in the ColorLineCollection.
ColorLineEndValues | Collection of integer values defining the EndValues of the ColorLines in the ColorLineCollection.
CustomTimeOHLC |
Darvas | Darvas Series.
Pie | Pie Series.
PieMarks | Customized pie series marks with additional properties.
PieOtherSlice | Pie series uses this class in its OtherSlice property.
PieShadow | Pie series uses this class in its Shadow property.
SliceValueList |
ExplodedSliceList | List to hold percents of exploding effect, one per each Pie slice.
Donut | Donut series.
EquiVolume | EquiVolume Series.
CustomError | CustomErrorSeries Series.
Error | ErrorSeries Series.
ErrorBar | ErrorBar Series.
ErrorsFormat |
ErrorsFormat3D |
ChartErrorsBase |
ChartErrors |
ChartErrors3D |
CustomErrorPoint |
ErrorPoint | ErrorPoint Series.
Points3D | Point3D Series. Each point has XYZ coordinates.
CustomErrorPoint3D |
ErrorPoint3D | ErrorPoint3D Series.
FastLine | The FastLine Series is an extremely simple Series component that draws its points as fast as possible.
Funnel | Funnel Series.
Gantt | Gantt Series.
Gauges | Gauges Series.
HighLow | HighLow series.
Histogram | Histogram Series.
HorizArea | HorizArea series.
HorizBar | Horizontal Bar Series.
HorizHistogram | HorizHistogram series.
Line | Line Series.
HorizLine | Horizontal Line Series.
ImageBar | ImageBar Series.
CustomImagePoint |
ImagePoint |
Surface | Surface 3D Series.
IsoSurface | Iso-Surface 3D Series.
SurfaceSides |
KagiDrawValueEventArgs | Variables describe point characteristics when plotted.
Kagi | The Kagi financial chart.
KnobGauge | KnobGauge Series.
LinearGauge | Linear Gauge Series.
VerticalLinearGauge | VerticalLinear Gauge Series.
LinePoint | LinePoint series.
PolygonList | ValueLists is a collection of ValueList objects.
PolyObj |
PolygonSaveTree |
Polygon |
PolygonSeries | Polygon Series is a descendant of Series. Use Polygon Series to define the shape of the Polygons to be drawn by the Map Series. A Polygon Series contains the co-ordinates of the Points which define the boundary of a Polygon. PolygonSeries stores the point Valuelists and individual characteristics of each Map Series 'sub' Series (each Polygon is a Chart Series). Map Series hides the need treat each Polygon as a Series by treating the Polygons as an internal collection of Series.
Map | Map series.
NumericGauge | Numeric Gauge Series.
Spacing |
OrgShape | Base shape class for oragnizational chart item.
OrgItem |
OrgItems |
OrgItemList | OrgItem list
OrgSeries | Organizational Chart.
OrgDraw | All item drawing is done in this class
PointFigureDrawValueEventArgs |
PointFigure | PointFigure Series.
Polar | Polar Series.
PolarBar | Polar Bar Series.
GridColorPalette | Defines palette properties.
PolarGrid | Polar Grid Series.
Pyramid | Pyramid Series.
Radar | Radar Series.
RenkoDrawValueEventArgs | Variables describe brick characteristics when plotted.
Renko | The Renko chart financial indicator.
RenkoBar |
Shape | Shape Series.
Smith | Smith Series.
TagCloudDrawTagEventArgs |
TagCloud |
Ternary | Ternary Series.
Tower | Tower Series. The Tower Series is designed to use a 0 or 1 based integer grid index. X and Z values should be sequential values of 1.
TreeMapItem |
TreeMap | TreeMap Series
TriSurface | TriSurface Series.
Vector3D | Vector3D Series.
Volume | Volume Series.
VolumePipe | VolumePipe Series.
Waterfall | The Waterfall series draws vertical "slices", one for each Z row of the equivalent surface.
WindRose | WindRose Series.

Public Interfaces

IWorldMaps
ISeriesPointer
IVideoCreator
IVideoPlayer

Public Delegates

GetSeriesMarkEventHandler | The Delegate for the GetSeriesMark event.
BeforeDrawPointEventHandler | The Delegate for the BeforeDrawPoint event.
ClickPointerEventHandler | The Delegate for the ClickPointer event.
GetPointerStyleEventHandler | The Delegate for the GetPointerStyle event.
GetBarStyleEventHandler | The Delegate for the GetBarStyle event.
CalendarChangeEventHandler | The Delegate for the Change event.
GetPointerStyleEventHandler | The Delegate for the GetPointerStyle event.
GetColorEventHandler | The Delegate for the GetValueColor event.
GetYValueEventHandler | The Delegate for the GetYValue event.
GetLevelEventHandler | The Delegate for the GetLevel event.
DrawLevelEventHandler | The Delegate for the DrawLevel event.
GetPointerStyleEventHandler | The Delegate for the GetPointerStyle event.
GaugesChangeHandler | Gauges Series OnChange Event Handler
GetImageEvent |
KagiDrawValueEventHandler | Used with event triggered when Kagi points are plotted.
PointFigureDrawValueEventHandler |
RenkoDrawValueEventHandler | Used with event triggered when Renko bricks are plotted.
TagCloudDrawTagEventHandler |
ClickPointerEventHandler | The Delegate for the ClickPointer event.
GetPointerStyleEventHandler | The Delegate for the GetPointerStyle event.

Public Structures

SeriesRandom | Used internally to add random values to a series.
LevelPoint |
GridPalette | Used in Custom3DPalette series to store the palette values.
GaugePointerStyles |
PieAngle | Internal structure used by Pie series to store each pie slice angle.
BoxLabel |
PFPoint |
BoxLabel |
CellsOrientation |

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll


Steema.TeeChart.Styles Hierarchy

System.Object

Steema.TeeChart.Drawing.TeeBase

Steema.TeeChart.Drawing.Shadow

Steema.TeeChart.Styles.Pie.PieShadow

Steema.TeeChart.Drawing.Shape

Steema.TeeChart.Drawing.TextShape

Steema.TeeChart.Drawing.TextShapePosition

Steema.TeeChart.Styles.OrgShape

Steema.TeeChart.Styles.Calendar.CalendarCell

Steema.TeeChart.Styles.Calendar.CalendarCellUpper

Steema.TeeChart.Styles.MarksItem

Steema.TeeChart.Styles.SeriesMarks

Steema.TeeChart.Styles.SeriesMarks.Symbols

Steema.TeeChart.Styles.ChartErrorsBase

Steema.TeeChart.Styles.ChartErrors

Steema.TeeChart.Styles.ChartErrors3D

Steema.TeeChart.Styles.Contour.ContourDraw

Steema.TeeChart.Styles.ContourSeriesMarks

Steema.TeeChart.Styles.GridColorPalette

Steema.TeeChart.Styles.OrgSeries.OrgDraw

Steema.TeeChart.Styles.Pie.PieMarks

Steema.TeeChart.Styles.Pie.PieOtherSlice

Steema.TeeChart.Styles.Polygon

Steema.TeeChart.Styles.Series

Steema.TeeChart.Styles.BaseLine

Steema.TeeChart.Styles.CustomPoint

Steema.TeeChart.Styles.Custom

Steema.TeeChart.Styles.Area

Steema.TeeChart.Styles.HorizArea

Steema.TeeChart.Styles.Bezier

Steema.TeeChart.Styles.Line

Steema.TeeChart.Styles.HorizLine

Steema.TeeChart.Styles.OHLC

Steema.TeeChart.Styles.Candle

Steema.TeeChart.Styles.Darvas

Steema.TeeChart.Styles.EquiVolume

Steema.TeeChart.Styles.CustomTimeOHLC

Steema.TeeChart.Styles.Kagi

Steema.TeeChart.Styles.PointFigure

Steema.TeeChart.Styles.Renko

Steema.TeeChart.Styles.Volume

Steema.TeeChart.Styles.Points

Steema.TeeChart.Styles.Arrow

Steema.TeeChart.Styles.Bubble

Steema.TeeChart.Styles.CustomBox

Steema.TeeChart.Styles.Box

Steema.TeeChart.Styles.HorizBox

Steema.TeeChart.Styles.CustomErrorPoint

Steema.TeeChart.Styles.ErrorPoint

Steema.TeeChart.Styles.CustomImagePoint

Steema.TeeChart.Styles.ImagePoint

Steema.TeeChart.Styles.Gantt

Steema.TeeChart.Styles.LinePoint

Steema.TeeChart.Styles.FastLine

Steema.TeeChart.Styles.Histogram

Steema.TeeChart.Styles.HorizHistogram

Steema.TeeChart.Styles.Calendar

Steema.TeeChart.Styles.Circular

Steema.TeeChart.Styles.CircularGauge

Steema.TeeChart.Styles.KnobGauge

Steema.TeeChart.Styles.CustomPolar

Steema.TeeChart.Styles.Custom2DPolar

Steema.TeeChart.Styles.Clock

Steema.TeeChart.Styles.WindRose

Steema.TeeChart.Styles.Polar

Steema.TeeChart.Styles.PolarBar

Steema.TeeChart.Styles.PolarGrid

Steema.TeeChart.Styles.Radar

Steema.TeeChart.Styles.Gauges

Steema.TeeChart.Styles.Pie

Steema.TeeChart.Styles.Donut

Steema.TeeChart.Styles.Smith

Steema.TeeChart.Styles.Custom3D

Steema.TeeChart.Styles.Custom3DPalette

Steema.TeeChart.Styles.Custom3DGrid

Steema.TeeChart.Styles.ColorGrid

Steema.TeeChart.Styles.Contour

Steema.TeeChart.Styles.Surface

Steema.TeeChart.Styles.IsoSurface

Steema.TeeChart.Styles.Waterfall

Steema.TeeChart.Styles.Tower

Steema.TeeChart.Styles.Map

Steema.TeeChart.Styles.TagCloud

Steema.TeeChart.Styles.Ternary

Steema.TeeChart.Styles.TriSurface

Steema.TeeChart.Styles.Vector3D

Steema.TeeChart.Styles.Points3D

Steema.TeeChart.Styles.CustomErrorPoint3D

Steema.TeeChart.Styles.ErrorPoint3D

Steema.TeeChart.Styles.CustomBar

Steema.TeeChart.Styles.Bar

Steema.TeeChart.Styles.Bar3D

Steema.TeeChart.Styles.BarJoin

Steema.TeeChart.Styles.CustomError

Steema.TeeChart.Styles.Error

Steema.TeeChart.Styles.ErrorBar

Steema.TeeChart.Styles.ImageBar

Steema.TeeChart.Styles.RenkoBar

Steema.TeeChart.Styles.HorizBar

Steema.TeeChart.Styles.CustomGauge

Steema.TeeChart.Styles.LinearGauge

Steema.TeeChart.Styles.VerticalLinearGauge

Steema.TeeChart.Styles.NumericGauge

Steema.TeeChart.Styles.Funnel

Steema.TeeChart.Styles.HighLow

Steema.TeeChart.Styles.OrgSeries

Steema.TeeChart.Styles.TreeMap

Steema.TeeChart.Styles.PolygonSeries

Steema.TeeChart.Styles.Pyramid

Steema.TeeChart.Styles.Shape

Steema.TeeChart.Styles.VolumePipe

Steema.TeeChart.Styles.SeriesGroup

Steema.TeeChart.Styles.SeriesPointer

Steema.TeeChart.Styles.Callout

Steema.TeeChart.Styles.MarksCallout

Steema.TeeChart.Styles.GaugeSeriesPointer

Steema.TeeChart.Styles.Spacing

Steema.TeeChart.Styles.TFrame

Steema.TeeChart.Styles.CFrame

Steema.TeeChart.Styles.ValueList

Steema.TeeChart.Styles.ContourLevel

Steema.TeeChart.Styles.ErrorsFormat

Steema.TeeChart.Styles.ErrorsFormat3D

Steema.TeeChart.Styles.LevelSegment

Steema.TeeChart.Styles.OrgItem

Steema.TeeChart.Styles.TreeMapItem

Steema.TeeChart.Styles.PolyObj

Steema.TeeChart.Styles.SeriesMarks.Position

Steema.TeeChart.Styles.SeriesPoint

Steema.TeeChart.Styles.SeriesOHLCPoint

Steema.TeeChart.Styles.SeriesXYPoint

Steema.TeeChart.Styles.SeriesXYZPoint

Steema.TeeChart.Styles.SurfaceSides

Steema.TeeChart.TeeEvent

Steema.TeeChart.Styles.SeriesEvent

System.Collections.ArrayList

Steema.TeeChart.Styles.ColorLineCollection

Steema.TeeChart.Styles.ColorLineEndValues

Steema.TeeChart.Styles.ColorLineStartValues

Steema.TeeChart.Styles.ColorList

Steema.TeeChart.Styles.OrgItemList

Steema.TeeChart.Styles.Pie.ExplodedSliceList

Steema.TeeChart.Styles.Pie.SliceValueList

Steema.TeeChart.Styles.SeriesMarks.MarkPositions

Steema.TeeChart.Styles.StringList

System.Collections.CollectionBase

Steema.TeeChart.Styles.MarksItems

Steema.TeeChart.Styles.OrgItems

Steema.TeeChart.Styles.PolygonList

Steema.TeeChart.Styles.PolygonSaveTree

Steema.TeeChart.Styles.SeriesCollection

Steema.TeeChart.Styles.SeriesGroups

System.EventArgs

Steema.TeeChart.Styles.BeforeDrawPointEventArgs

Steema.TeeChart.Styles.Calendar.CalendarChangeEventArgs

Steema.TeeChart.Styles.Contour.DrawLevelEventArgs

Steema.TeeChart.Styles.Contour.GetLevelEventArgs

Steema.TeeChart.Styles.Custom3DGrid.GetYValueEventArgs

Steema.TeeChart.Styles.Custom3DPalette.GetColorEventArgs

Steema.TeeChart.Styles.CustomBar.GetBarStyleEventArgs

Steema.TeeChart.Styles.GetPointerStyleEventArgs

Steema.TeeChart.Styles.GetSeriesMarkEventArgs

Steema.TeeChart.Styles.KagiDrawValueEventArgs

Steema.TeeChart.Styles.PointFigureDrawValueEventArgs

Steema.TeeChart.Styles.RenkoDrawValueEventArgs

Steema.TeeChart.Styles.TagCloudDrawTagEventArgs

See Also

SteemaTeeChartStyles Namespace


Steema.TeeChart.Styles.Area

Steema.TeeChart.Styles.Area Class

Area Series

For a list of all members of this type, see Area Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
public class Area : Custom , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Area members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.AreaMembers

Steema.TeeChart.Styles.Area all Members

Area overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Custom) | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Custom) |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Custom) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue |
MaxYValue | Returns the highest of all the current Series Y point values.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue |
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AreaBrush | Determines Brush to fill the background Area region.
AreaLines | Determines Pen to draw AreaLines.
AreaLinesPen |
Brush (inherited from Custom) | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient | Determines Gradient to fill the background Area region.
GradientRelative | Gets and sets a value which when true calculates the Gradient relative to each point. When false, the Gradient is calculated with respect to the entire Gradient area.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
MultiArea | Determines how Multi-AreaSeries are displayed.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
Origin | Sets axis value as a common bottom for all AreaSeries points.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StackGroup |
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TopGradient | Determines to fill the top 3D Area region.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UseOrigin | Aligns bottom of AreaSeries to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Area Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Area Constructor

Overload List

public Area(Steema.TeeChart.Chart)
public Area()

See Also

Area Class | Area Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Area Constructor

public Area()

See Also

Area Constructor Overload List | Area Class | Area Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Area Constructor

public Area(Chart c)

See Also

Area Constructor Overload List | Area Class | Area Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.AreaEvents

Steema.TeeChart.Styles.Area Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Area Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.AreaFields

Steema.TeeChart.Styles.Area Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Area Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.AreaMethods

Steema.TeeChart.Styles.Area Methods

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Custom) | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Custom) |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Custom) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue |
MaxYValue | Returns the highest of all the current Series Y point values.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue |
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Area Class | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.Area.MaxXValue Method

public override Double MaxXValue()

See Also

Area Class | Area Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.Area.MaxYValue Method

Returns the highest of all the current Series Y point values.
public override Double MaxYValue()

See Also

Area Class | Area Members | Steema.TeeChart.Styles Namespace


MinXValue

Steema.TeeChart.Styles.Area.MinXValue Method

public override Double MinXValue()

See Also

Area Class | Area Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.Area.MinYValue Method

Returns the Minimum Value of the Series Y Values List.
public override Double MinYValue()

See Also

Area Class | Area Members | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.Area.SetSubGallery Method

public override Void SetSubGallery(Int32 index)

See Also

Area Class | Area Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.AreaProperties

Steema.TeeChart.Styles.Area Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AreaBrush | Determines Brush to fill the background Area region.
AreaLines | Determines Pen to draw AreaLines.
AreaLinesPen |
Brush (inherited from Custom) | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient | Determines Gradient to fill the background Area region.
GradientRelative | Gets and sets a value which when true calculates the Gradient relative to each point. When false, the Gradient is calculated with respect to the entire Gradient area.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
MultiArea | Determines how Multi-AreaSeries are displayed.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
Origin | Sets axis value as a common bottom for all AreaSeries points.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StackGroup |
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TopGradient | Determines to fill the top 3D Area region.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UseOrigin | Aligns bottom of AreaSeries to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Area Class | Steema.TeeChart.Styles Namespace


AreaBrush

Steema.TeeChart.Styles.Area.AreaBrush Property

Determines Brush to fill the background Area region.
public ChartBrush AreaBrush {get;}

See Also

Area Class | Area Members | Steema.TeeChart.Styles Namespace


AreaLines

Steema.TeeChart.Styles.Area.AreaLines Property

Determines Pen to draw AreaLines.
public ChartPen AreaLines {get;}

See Also

Area Class | Area Members | Steema.TeeChart.Styles Namespace


AreaLinesPen

Steema.TeeChart.Styles.Area.AreaLinesPen Property

public ChartPen AreaLinesPen {get;}

See Also

Area Class | Area Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Area.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

Area Class | Area Members | Steema.TeeChart.Styles Namespace


Gradient

Steema.TeeChart.Styles.Area.Gradient Property

Determines Gradient to fill the background Area region.
public Gradient Gradient {get;}

See Also

Area Class | Area Members | Steema.TeeChart.Styles Namespace


GradientRelative

Steema.TeeChart.Styles.Area.GradientRelative Property

Gets and sets a value which when true calculates the Gradient relative to each point. When false, the Gradient is calculated with respect to the entire Gradient area.
public Boolean GradientRelative {get; set;}

See Also

Area Class | Area Members | Steema.TeeChart.Styles Namespace


MultiArea

Steema.TeeChart.Styles.Area.MultiArea Property

Determines how Multi-AreaSeries are displayed.
public MultiAreas MultiArea {get; set;}

See Also

Area Class | Area Members | Steema.TeeChart.Styles Namespace


Origin

Steema.TeeChart.Styles.Area.Origin Property

Sets axis value as a common bottom for all AreaSeries points.
public Double Origin {get; set;}

See Also

Area Class | Area Members | Steema.TeeChart.Styles Namespace


StackGroup

Steema.TeeChart.Styles.Area.StackGroup Property

public Int32 StackGroup {get; set;}

See Also

Area Class | Area Members | Steema.TeeChart.Styles Namespace


TopGradient

Steema.TeeChart.Styles.Area.TopGradient Property

Determines to fill the top 3D Area region.
public Gradient TopGradient {get;}

See Also

Area Class | Area Members | Steema.TeeChart.Styles Namespace


UseOrigin

Steema.TeeChart.Styles.Area.UseOrigin Property

Aligns bottom of AreaSeries to the Origin property value.
public Boolean UseOrigin {get; set;}

See Also

Area Class | Area Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Arrow

Steema.TeeChart.Styles.Arrow Class

Arrow Series.

For a list of all members of this type, see Arrow Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Points
public class Arrow : Points , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Arrow members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ArrowMembers

Steema.TeeChart.Styles.Arrow all Members

Arrow overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add | Adds an Arrow with start and end coordinates.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
ArrowHeight | Determines the vertical arrow head size in pixels.
ArrowWidth | Determines the horizontal arrow head size in pixels.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
EndXValues | Sets X1 values for Arrows.
EndYValues | Sets Y1 values for Arrows.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartXValues | Sets X0 values for Arrows.
StartYValues | Sets Y0 values for Arrows.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Arrow Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Arrow Constructor

Overload List

public Arrow()
public Arrow(Steema.TeeChart.Chart)

See Also

Arrow Class | Arrow Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Arrow Constructor

public Arrow(Chart c)

See Also

Arrow Constructor Overload List | Arrow Class | Arrow Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Arrow Constructor

public Arrow()

See Also

Arrow Constructor Overload List | Arrow Class | Arrow Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ArrowEvents

Steema.TeeChart.Styles.Arrow Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Arrow Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ArrowFields

Steema.TeeChart.Styles.Arrow Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Arrow Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ArrowMethods

Steema.TeeChart.Styles.Arrow Methods

Public Methods

Add | Adds an Arrow with start and end coordinates.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Arrow Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Arrow.Add Method

Overload List

Adds an Arrow with start and end coordinates.

public Int32 Add(System.Double, System.Double, System.Double, System.Double)

Adds an Arrow with start and end coordinates and label.

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.String)

Adds an Arrow with start and end coordinates and color.

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Drawing.Color)

Adds an Arrow with start and end coordinates, label and color.

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.String, System.Drawing.Color)

See Also

Arrow Class | Arrow Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Arrow.Add Method

Adds an Arrow with start and end coordinates, label and color.
public Int32 Add(Double x0,
     Double y0,
     Double x1,
     Double y1,
     String text,
     Color color)

See Also

Add Overload List | Arrow Class | Arrow Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Arrow.Add Method

Adds an Arrow with start and end coordinates and color.
public Int32 Add(Double x0,
     Double y0,
     Double x1,
     Double y1,
     Color color)

See Also

Add Overload List | Arrow Class | Arrow Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Arrow.Add Method

Adds an Arrow with start and end coordinates and label.
public Int32 Add(Double x0,
     Double y0,
     Double x1,
     Double y1,
     String text)

See Also

Add Overload List | Arrow Class | Arrow Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Arrow.Add Method

Adds an Arrow with start and end coordinates.
public Int32 Add(Double x0,
     Double y0,
     Double x1,
     Double y1)

See Also

Add Overload List | Arrow Class | Arrow Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.Arrow.DrawValue Method

Called internally. Draws the "ValueIndex" point of the Series.
public override Void DrawValue(Int32 valueIndex)

See Also

Arrow Class | Arrow Members | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.Arrow.MaxXValue Method

Returns the Maximum Value of the Series X Values List.
public override Double MaxXValue()

See Also

Arrow Class | Arrow Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.Arrow.MaxYValue Method

Returns the Maximum Value of the Series Y Values List.
public override Double MaxYValue()

See Also

Arrow Class | Arrow Members | Steema.TeeChart.Styles Namespace


MinXValue

Steema.TeeChart.Styles.Arrow.MinXValue Method

Returns the Minimum Value of the Series X Values List.
public override Double MinXValue()

See Also

Arrow Class | Arrow Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.Arrow.MinYValue Method

Returns the Minimum Value of the Series Y Values List.
public override Double MinYValue()

See Also

Arrow Class | Arrow Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ArrowProperties

Steema.TeeChart.Styles.Arrow Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
ArrowHeight | Determines the vertical arrow head size in pixels.
ArrowWidth | Determines the horizontal arrow head size in pixels.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
EndXValues | Sets X1 values for Arrows.
EndYValues | Sets Y1 values for Arrows.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartXValues | Sets X0 values for Arrows.
StartYValues | Sets Y0 values for Arrows.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Arrow Class | Steema.TeeChart.Styles Namespace


ArrowHeight

Steema.TeeChart.Styles.Arrow.ArrowHeight Property

Determines the vertical arrow head size in pixels.
public Int32 ArrowHeight {get; set;}

See Also

Arrow Class | Arrow Members | Steema.TeeChart.Styles Namespace


ArrowWidth

Steema.TeeChart.Styles.Arrow.ArrowWidth Property

Determines the horizontal arrow head size in pixels.
public Int32 ArrowWidth {get; set;}

See Also

Arrow Class | Arrow Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Arrow.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

Arrow Class | Arrow Members | Steema.TeeChart.Styles Namespace


EndXValues

Steema.TeeChart.Styles.Arrow.EndXValues Property

Sets X1 values for Arrows.
public ValueList EndXValues {get; set;}

See Also

Arrow Class | Arrow Members | Steema.TeeChart.Styles Namespace


EndYValues

Steema.TeeChart.Styles.Arrow.EndYValues Property

Sets Y1 values for Arrows.
public ValueList EndYValues {get; set;}

See Also

Arrow Class | Arrow Members | Steema.TeeChart.Styles Namespace


StartXValues

Steema.TeeChart.Styles.Arrow.StartXValues Property

Sets X0 values for Arrows.
public ValueList StartXValues {get; set;}

See Also

Arrow Class | Arrow Members | Steema.TeeChart.Styles Namespace


StartYValues

Steema.TeeChart.Styles.Arrow.StartYValues Property

Sets Y0 values for Arrows.
public ValueList StartYValues {get; set;}

See Also

Arrow Class | Arrow Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ArrowHeadDirection

Steema.TeeChart.Styles.ArrowHeadDirection Enum

[Serializable]
public sealed enum ArrowHeadDirection : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
FromPoint |
ToPoint |

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ArrowHeadStyles

Steema.TeeChart.Styles.ArrowHeadStyles Enum

[Serializable]
public sealed enum ArrowHeadStyles : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
None |
Line |
Solid |

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Bar

Steema.TeeChart.Styles.Bar Class

The Bar Series component outputs all points as vertical bars.

For a list of all members of this type, see Bar Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomBar
public class Bar : CustomBar , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Bar members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BarMembers

Steema.TeeChart.Styles.Bar all Members

Bar overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetBarStyle (inherited from CustomBar) | Occurs when series bars are painted.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomBar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BarMargin (inherited from CustomBar) | Returns side margin amount in pixels.
BarRectangle (inherited from CustomBar) | For internal use.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos | Returns the Screen X pixel coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos | Returns the Screen Y pixel coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomBar) | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawBar | Internal use.
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from CustomBar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetOriginPos | Returns the corresponding screen pixels coordinate of the leftmost horizontal bar edge.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointOrigin (inherited from CustomBar) | For internal use.
PrepareForGallery (inherited from CustomBar) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from CustomBar) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoMarkPosition (inherited from CustomBar) | Repositions Marks on BarSeries to prevent overlapping.
BarBounds (inherited from CustomBar) | Coordinates of current Bar point being displayed.
BarStyle (inherited from CustomBar) | Defines the Bar shape used to draw Bars.
BarWidthPercent | Determines the percent of total Bar width used.
BevelSize (inherited from CustomBar) | Amount in pixels of the bar bevel. Used only when BarStyle property is Bevel (only in 2D and 3D orthogonal display modes)
Brush (inherited from CustomBar) | Defines the Brush used to fill Bars.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent (inherited from CustomBar) |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBarWidth (inherited from CustomBar) |
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from CustomBar) | Darkens sides of bars to enhance 3D effect.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthPercent (inherited from CustomBar) | Defines the percentage, from 0 to 100, that the bars will need in the "Z" depth space direction.
Description | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from CustomBar) | Defines the color Gradient used to fill the Bars.
GradientRelative (inherited from CustomBar) | When Gradient is Visible, calculates Colors based on highest bar.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksLocation (inherited from CustomBar) | Sets the alignment of the Mark into the Bars.
MarksOnBar (inherited from CustomBar) | Sets a postition of the Marks into the Bars.
MiddleZ (inherited from Series) | For internal use.
MultiBar (inherited from CustomBar) | Determines how multiple BarSeries will be displayed in the same Chart.
NumGallerySeries (inherited from Series) | For internal use.
OffsetPercent (inherited from CustomBar) | Sets the Bar displacement as percent of Bar size.
Origin (inherited from CustomBar) | Sets the common bottom value used for all Bar points.
Pen (inherited from CustomBar) | Pen used to draw the Bar rectangles.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow (inherited from CustomBar) | Defines the Shadow used to draw behind the Bars.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideMargins (inherited from CustomBar) | Sets a margin between Chart rectangle and Bars.
StackGroup (inherited from CustomBar) | Allows stacking independent Series within the same Chart.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickLines (inherited from CustomBar) | Pen used to draw "tick" lines across each bar.
Title (inherited from Series) | Series description to show in Legend and editors.
UseOrigin (inherited from CustomBar) | Allows Bars to be bottom aligned to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin (inherited from CustomBar) | System.Obsolete: Please use Origin property.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Bar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Bar Constructor

Overload List

public Bar()
public Bar(Steema.TeeChart.Chart)

See Also

Bar Class | Bar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Bar Constructor

public Bar(Chart c)

See Also

Bar Constructor Overload List | Bar Class | Bar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Bar Constructor

public Bar()

See Also

Bar Constructor Overload List | Bar Class | Bar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BarEvents

Steema.TeeChart.Styles.Bar Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetBarStyle (inherited from CustomBar) | Occurs when series bars are painted.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Bar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BarFields

Steema.TeeChart.Styles.Bar Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Bar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BarMethods

Steema.TeeChart.Styles.Bar Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomBar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BarMargin (inherited from CustomBar) | Returns side margin amount in pixels.
BarRectangle (inherited from CustomBar) | For internal use.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos | Returns the Screen X pixel coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos | Returns the Screen Y pixel coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomBar) | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawBar | Internal use.
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from CustomBar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetOriginPos | Returns the corresponding screen pixels coordinate of the leftmost horizontal bar edge.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointOrigin (inherited from CustomBar) | For internal use.
PrepareForGallery (inherited from CustomBar) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from CustomBar) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Bar Class | Steema.TeeChart.Styles Namespace


CalcXPos

Steema.TeeChart.Styles.Bar.CalcXPos Method

Returns the Screen X pixel coordinate of the ValueIndex Series value.
public override Int32 CalcXPos(Int32 valueIndex)

See Also

Bar Class | Bar Members | Steema.TeeChart.Styles Namespace


CalcYPos

Steema.TeeChart.Styles.Bar.CalcYPos Method

Returns the Screen Y pixel coordinate of the ValueIndex Series value.
public override Int32 CalcYPos(Int32 valueIndex)

See Also

Bar Class | Bar Members | Steema.TeeChart.Styles Namespace


DrawBar

Steema.TeeChart.Styles.Bar.DrawBar Method

Internal use.
public override Void DrawBar(Int32 barIndex,
     Int32 startPos,
     Int32 endPos)

See Also

Bar Class | Bar Members | Steema.TeeChart.Styles Namespace


GetOriginPos

Steema.TeeChart.Styles.Bar.GetOriginPos Method

Returns the corresponding screen pixels coordinate of the leftmost horizontal bar edge.
public Int32 GetOriginPos(Int32 valueIndex)

See Also

Bar Class | Bar Members | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.Bar.MaxXValue Method

Returns the Maximum Value of the Series X Values List.
public override Double MaxXValue()

See Also

Bar Class | Bar Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.Bar.MaxYValue Method

Returns the Maximum Value of the Series Y Values List.
public override Double MaxYValue()

See Also

Bar Class | Bar Members | Steema.TeeChart.Styles Namespace


MinXValue

Steema.TeeChart.Styles.Bar.MinXValue Method

Returns the Minimum Value of the Series X Values List.
public override Double MinXValue()

See Also

Bar Class | Bar Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.Bar.MinYValue Method

Returns the Minimum Value of the Series Y Values List.
public override Double MinYValue()

See Also

Bar Class | Bar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BarProperties

Steema.TeeChart.Styles.Bar Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoMarkPosition (inherited from CustomBar) | Repositions Marks on BarSeries to prevent overlapping.
BarBounds (inherited from CustomBar) | Coordinates of current Bar point being displayed.
BarStyle (inherited from CustomBar) | Defines the Bar shape used to draw Bars.
BarWidthPercent | Determines the percent of total Bar width used.
BevelSize (inherited from CustomBar) | Amount in pixels of the bar bevel. Used only when BarStyle property is Bevel (only in 2D and 3D orthogonal display modes)
Brush (inherited from CustomBar) | Defines the Brush used to fill Bars.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent (inherited from CustomBar) |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBarWidth (inherited from CustomBar) |
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from CustomBar) | Darkens sides of bars to enhance 3D effect.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthPercent (inherited from CustomBar) | Defines the percentage, from 0 to 100, that the bars will need in the "Z" depth space direction.
Description | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from CustomBar) | Defines the color Gradient used to fill the Bars.
GradientRelative (inherited from CustomBar) | When Gradient is Visible, calculates Colors based on highest bar.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksLocation (inherited from CustomBar) | Sets the alignment of the Mark into the Bars.
MarksOnBar (inherited from CustomBar) | Sets a postition of the Marks into the Bars.
MiddleZ (inherited from Series) | For internal use.
MultiBar (inherited from CustomBar) | Determines how multiple BarSeries will be displayed in the same Chart.
NumGallerySeries (inherited from Series) | For internal use.
OffsetPercent (inherited from CustomBar) | Sets the Bar displacement as percent of Bar size.
Origin (inherited from CustomBar) | Sets the common bottom value used for all Bar points.
Pen (inherited from CustomBar) | Pen used to draw the Bar rectangles.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow (inherited from CustomBar) | Defines the Shadow used to draw behind the Bars.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideMargins (inherited from CustomBar) | Sets a margin between Chart rectangle and Bars.
StackGroup (inherited from CustomBar) | Allows stacking independent Series within the same Chart.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickLines (inherited from CustomBar) | Pen used to draw "tick" lines across each bar.
Title (inherited from Series) | Series description to show in Legend and editors.
UseOrigin (inherited from CustomBar) | Allows Bars to be bottom aligned to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin (inherited from CustomBar) | System.Obsolete: Please use Origin property.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Bar Class | Steema.TeeChart.Styles Namespace


BarWidthPercent

Steema.TeeChart.Styles.Bar.BarWidthPercent Property

Determines the percent of total Bar width used.
public Int32 BarWidthPercent {get; set;}

See Also

Bar Class | Bar Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Bar.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

Bar Class | Bar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Bar3D

Steema.TeeChart.Styles.Bar3D Class

Bar3D Series.

For a list of all members of this type, see Bar3D Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomBar
Steema.TeeChart.Styles.Bar
public class Bar3D : Bar , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Bar3D members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Bar3DMembers

Steema.TeeChart.Styles.Bar3D all Members

Bar3D overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetBarStyle (inherited from CustomBar) | Occurs when series bars are painted.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add | Adds a bar with an X and Y value, Y start point and color.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomBar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BarMargin (inherited from CustomBar) | Returns side margin amount in pixels.
BarRectangle (inherited from CustomBar) | For internal use.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Bar) | Returns the Screen X pixel coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Bar) | Returns the Screen Y pixel coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomBar) | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawBar (inherited from Bar) | Internal use.
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from CustomBar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetOriginPos (inherited from Bar) | Returns the corresponding screen pixels coordinate of the leftmost horizontal bar edge.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Bar) | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Bar) | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointOrigin | Returns the corresponding screen pixels coordinate of the leftmost horizontal bar edge.
PrepareForGallery (inherited from CustomBar) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from CustomBar) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoMarkPosition (inherited from CustomBar) | Repositions Marks on BarSeries to prevent overlapping.
BarBounds (inherited from CustomBar) | Coordinates of current Bar point being displayed.
BarStyle (inherited from CustomBar) | Defines the Bar shape used to draw Bars.
BarWidthPercent (inherited from Bar) | Determines the percent of total Bar width used.
BevelSize (inherited from CustomBar) | Amount in pixels of the bar bevel. Used only when BarStyle property is Bevel (only in 2D and 3D orthogonal display modes)
Brush (inherited from CustomBar) | Defines the Brush used to fill Bars.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent (inherited from CustomBar) |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBarWidth (inherited from CustomBar) |
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from CustomBar) | Darkens sides of bars to enhance 3D effect.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthPercent (inherited from CustomBar) | Defines the percentage, from 0 to 100, that the bars will need in the "Z" depth space direction.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from CustomBar) | Defines the color Gradient used to fill the Bars.
GradientRelative (inherited from CustomBar) | When Gradient is Visible, calculates Colors based on highest bar.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksLocation (inherited from CustomBar) | Sets the alignment of the Mark into the Bars.
MarksOnBar (inherited from CustomBar) | Sets a postition of the Marks into the Bars.
MiddleZ (inherited from Series) | For internal use.
MultiBar (inherited from CustomBar) | Determines how multiple BarSeries will be displayed in the same Chart.
NumGallerySeries (inherited from Series) | For internal use.
OffsetPercent (inherited from CustomBar) | Sets the Bar displacement as percent of Bar size.
OffsetValues |
Origin (inherited from CustomBar) | Sets the common bottom value used for all Bar points.
Pen (inherited from CustomBar) | Pen used to draw the Bar rectangles.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow (inherited from CustomBar) | Defines the Shadow used to draw behind the Bars.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideMargins (inherited from CustomBar) | Sets a margin between Chart rectangle and Bars.
StackGroup (inherited from CustomBar) | Allows stacking independent Series within the same Chart.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickLines (inherited from CustomBar) | Pen used to draw "tick" lines across each bar.
Title (inherited from Series) | Series description to show in Legend and editors.
UseOrigin (inherited from CustomBar) | Allows Bars to be bottom aligned to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin (inherited from CustomBar) | System.Obsolete: Please use Origin property.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Bar3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Bar3D Constructor

Overload List

public Bar3D()
public Bar3D(Steema.TeeChart.Chart)

See Also

Bar3D Class | Bar3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Bar3D Constructor

public Bar3D(Chart c)

See Also

Bar3D Constructor Overload List | Bar3D Class | Bar3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Bar3D Constructor

public Bar3D()

See Also

Bar3D Constructor Overload List | Bar3D Class | Bar3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Bar3DEvents

Steema.TeeChart.Styles.Bar3D Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetBarStyle (inherited from CustomBar) | Occurs when series bars are painted.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Bar3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Bar3DFields

Steema.TeeChart.Styles.Bar3D Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Bar3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Bar3DMethods

Steema.TeeChart.Styles.Bar3D Methods

Public Methods

Add | Adds a bar with an X and Y value, Y start point and color.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomBar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BarMargin (inherited from CustomBar) | Returns side margin amount in pixels.
BarRectangle (inherited from CustomBar) | For internal use.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Bar) | Returns the Screen X pixel coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Bar) | Returns the Screen Y pixel coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomBar) | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawBar (inherited from Bar) | Internal use.
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from CustomBar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetOriginPos (inherited from Bar) | Returns the corresponding screen pixels coordinate of the leftmost horizontal bar edge.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Bar) | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Bar) | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointOrigin | Returns the corresponding screen pixels coordinate of the leftmost horizontal bar edge.
PrepareForGallery (inherited from CustomBar) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from CustomBar) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Bar3D Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Bar3D.Add Method

Overload List

Adds a bar with an X and Y value, Y start point and color.

public Int32 Add(System.Double, System.Double, System.Double, System.Drawing.Color)

Adds a bar with an X and Y value and Y start point.

public Int32 Add(System.Double, System.Double, System.Double)

Adds a bar with an X and Y value with offset and label.

public Int32 Add(System.Double, System.Double, System.Double, System.String)

Adds a bar with an X and Y value, Y start point, label and color.

public Int32 Add(System.Double, System.Double, System.Double, System.String, System.Drawing.Color)

See Also

Bar3D Class | Bar3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Bar3D.Add Method

Adds a bar with an X and Y value, Y start point, label and color.
public Int32 Add(Double x,
     Double y,
     Double offset,
     String text,
     Color color)

See Also

Add Overload List | Bar3D Class | Bar3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Bar3D.Add Method

Adds a bar with an X and Y value with offset and label.
public Int32 Add(Double x,
     Double y,
     Double offset,
     String text)

See Also

Add Overload List | Bar3D Class | Bar3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Bar3D.Add Method

Adds a bar with an X and Y value and Y start point.
public Int32 Add(Double x,
     Double y,
     Double offset)

See Also

Add Overload List | Bar3D Class | Bar3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Bar3D.Add Method

Adds a bar with an X and Y value, Y start point and color.
public Int32 Add(Double x,
     Double y,
     Double offset,
     Color color)

See Also

Add Overload List | Bar3D Class | Bar3D Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.Bar3D.MaxYValue Method

Returns the Maximum Value of the Series Y Values List.
public override Double MaxYValue()

See Also

Bar3D Class | Bar3D Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.Bar3D.MinYValue Method

Returns the Minimum Value of the Series Y Values List.
public override Double MinYValue()

See Also

Bar3D Class | Bar3D Members | Steema.TeeChart.Styles Namespace


PointOrigin

Steema.TeeChart.Styles.Bar3D.PointOrigin Method

Returns the corresponding screen pixels coordinate of the leftmost horizontal bar edge.
public override Double PointOrigin(Int32 valueIndex,
     Boolean sumAll)

See Also

Bar3D Class | Bar3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Bar3DProperties

Steema.TeeChart.Styles.Bar3D Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoMarkPosition (inherited from CustomBar) | Repositions Marks on BarSeries to prevent overlapping.
BarBounds (inherited from CustomBar) | Coordinates of current Bar point being displayed.
BarStyle (inherited from CustomBar) | Defines the Bar shape used to draw Bars.
BarWidthPercent (inherited from Bar) | Determines the percent of total Bar width used.
BevelSize (inherited from CustomBar) | Amount in pixels of the bar bevel. Used only when BarStyle property is Bevel (only in 2D and 3D orthogonal display modes)
Brush (inherited from CustomBar) | Defines the Brush used to fill Bars.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent (inherited from CustomBar) |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBarWidth (inherited from CustomBar) |
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from CustomBar) | Darkens sides of bars to enhance 3D effect.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthPercent (inherited from CustomBar) | Defines the percentage, from 0 to 100, that the bars will need in the "Z" depth space direction.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from CustomBar) | Defines the color Gradient used to fill the Bars.
GradientRelative (inherited from CustomBar) | When Gradient is Visible, calculates Colors based on highest bar.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksLocation (inherited from CustomBar) | Sets the alignment of the Mark into the Bars.
MarksOnBar (inherited from CustomBar) | Sets a postition of the Marks into the Bars.
MiddleZ (inherited from Series) | For internal use.
MultiBar (inherited from CustomBar) | Determines how multiple BarSeries will be displayed in the same Chart.
NumGallerySeries (inherited from Series) | For internal use.
OffsetPercent (inherited from CustomBar) | Sets the Bar displacement as percent of Bar size.
OffsetValues |
Origin (inherited from CustomBar) | Sets the common bottom value used for all Bar points.
Pen (inherited from CustomBar) | Pen used to draw the Bar rectangles.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow (inherited from CustomBar) | Defines the Shadow used to draw behind the Bars.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideMargins (inherited from CustomBar) | Sets a margin between Chart rectangle and Bars.
StackGroup (inherited from CustomBar) | Allows stacking independent Series within the same Chart.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickLines (inherited from CustomBar) | Pen used to draw "tick" lines across each bar.
Title (inherited from Series) | Series description to show in Legend and editors.
UseOrigin (inherited from CustomBar) | Allows Bars to be bottom aligned to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin (inherited from CustomBar) | System.Obsolete: Please use Origin property.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Bar3D Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Bar3D.Description Property

public override String Description {get;}

See Also

Bar3D Class | Bar3D Members | Steema.TeeChart.Styles Namespace


OffsetValues

Steema.TeeChart.Styles.Bar3D.OffsetValues Property

public ValueList OffsetValues {get; set;}

See Also

Bar3D Class | Bar3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BarJoin

Steema.TeeChart.Styles.BarJoin Class

BarJoin series.

For a list of all members of this type, see BarJoin Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomBar
Steema.TeeChart.Styles.Bar
public class BarJoin : Bar , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

BarJoin members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BarJoinMembers

Steema.TeeChart.Styles.BarJoin all Members

BarJoin overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetBarStyle (inherited from CustomBar) | Occurs when series bars are painted.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomBar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BarMargin (inherited from CustomBar) | Returns side margin amount in pixels.
BarRectangle (inherited from CustomBar) | For internal use.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Bar) | Returns the Screen X pixel coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Bar) | Returns the Screen Y pixel coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomBar) | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawBar | Internal use.
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from CustomBar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetOriginPos (inherited from Bar) | Returns the corresponding screen pixels coordinate of the leftmost horizontal bar edge.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Bar) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Bar) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Bar) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Bar) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointOrigin (inherited from CustomBar) | For internal use.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from CustomBar) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoMarkPosition (inherited from CustomBar) | Repositions Marks on BarSeries to prevent overlapping.
BarBounds (inherited from CustomBar) | Coordinates of current Bar point being displayed.
BarStyle (inherited from CustomBar) | Defines the Bar shape used to draw Bars.
BarWidthPercent (inherited from Bar) | Determines the percent of total Bar width used.
BevelSize (inherited from CustomBar) | Amount in pixels of the bar bevel. Used only when BarStyle property is Bevel (only in 2D and 3D orthogonal display modes)
Brush (inherited from CustomBar) | Defines the Brush used to fill Bars.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent (inherited from CustomBar) |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBarWidth (inherited from CustomBar) |
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from CustomBar) | Darkens sides of bars to enhance 3D effect.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthPercent (inherited from CustomBar) | Defines the percentage, from 0 to 100, that the bars will need in the "Z" depth space direction.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from CustomBar) | Defines the color Gradient used to fill the Bars.
GradientRelative (inherited from CustomBar) | When Gradient is Visible, calculates Colors based on highest bar.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
JoinPen | Determines the pen to draw the lines between each bar point.
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksLocation (inherited from CustomBar) | Sets the alignment of the Mark into the Bars.
MarksOnBar (inherited from CustomBar) | Sets a postition of the Marks into the Bars.
MiddleZ (inherited from Series) | For internal use.
MultiBar (inherited from CustomBar) | Determines how multiple BarSeries will be displayed in the same Chart.
NumGallerySeries (inherited from Series) | For internal use.
OffsetPercent (inherited from CustomBar) | Sets the Bar displacement as percent of Bar size.
Origin (inherited from CustomBar) | Sets the common bottom value used for all Bar points.
Pen (inherited from CustomBar) | Pen used to draw the Bar rectangles.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow (inherited from CustomBar) | Defines the Shadow used to draw behind the Bars.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideMargins (inherited from CustomBar) | Sets a margin between Chart rectangle and Bars.
StackGroup (inherited from CustomBar) | Allows stacking independent Series within the same Chart.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickLines (inherited from CustomBar) | Pen used to draw "tick" lines across each bar.
Title (inherited from Series) | Series description to show in Legend and editors.
UseOrigin (inherited from CustomBar) | Allows Bars to be bottom aligned to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin (inherited from CustomBar) | System.Obsolete: Please use Origin property.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

BarJoin Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BarJoin Constructor

Overload List

public BarJoin()
public BarJoin(Steema.TeeChart.Chart)

See Also

BarJoin Class | BarJoin Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BarJoin Constructor

public BarJoin(Chart c)

See Also

BarJoin Constructor Overload List | BarJoin Class | BarJoin Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BarJoin Constructor

public BarJoin()

See Also

BarJoin Constructor Overload List | BarJoin Class | BarJoin Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BarJoinEvents

Steema.TeeChart.Styles.BarJoin Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetBarStyle (inherited from CustomBar) | Occurs when series bars are painted.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

BarJoin Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BarJoinFields

Steema.TeeChart.Styles.BarJoin Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

BarJoin Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BarJoinMethods

Steema.TeeChart.Styles.BarJoin Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomBar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BarMargin (inherited from CustomBar) | Returns side margin amount in pixels.
BarRectangle (inherited from CustomBar) | For internal use.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Bar) | Returns the Screen X pixel coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Bar) | Returns the Screen Y pixel coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomBar) | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawBar | Internal use.
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from CustomBar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetOriginPos (inherited from Bar) | Returns the corresponding screen pixels coordinate of the leftmost horizontal bar edge.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Bar) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Bar) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Bar) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Bar) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointOrigin (inherited from CustomBar) | For internal use.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from CustomBar) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

BarJoin Class | Steema.TeeChart.Styles Namespace


DrawBar

Steema.TeeChart.Styles.BarJoin.DrawBar Method

Internal use.
public override Void DrawBar(Int32 BarIndex,
     Int32 StartPos,
     Int32 EndPos)

See Also

BarJoin Class | BarJoin Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.BarJoin.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

BarJoin Class | BarJoin Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BarJoinProperties

Steema.TeeChart.Styles.BarJoin Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoMarkPosition (inherited from CustomBar) | Repositions Marks on BarSeries to prevent overlapping.
BarBounds (inherited from CustomBar) | Coordinates of current Bar point being displayed.
BarStyle (inherited from CustomBar) | Defines the Bar shape used to draw Bars.
BarWidthPercent (inherited from Bar) | Determines the percent of total Bar width used.
BevelSize (inherited from CustomBar) | Amount in pixels of the bar bevel. Used only when BarStyle property is Bevel (only in 2D and 3D orthogonal display modes)
Brush (inherited from CustomBar) | Defines the Brush used to fill Bars.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent (inherited from CustomBar) |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBarWidth (inherited from CustomBar) |
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from CustomBar) | Darkens sides of bars to enhance 3D effect.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthPercent (inherited from CustomBar) | Defines the percentage, from 0 to 100, that the bars will need in the "Z" depth space direction.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from CustomBar) | Defines the color Gradient used to fill the Bars.
GradientRelative (inherited from CustomBar) | When Gradient is Visible, calculates Colors based on highest bar.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
JoinPen | Determines the pen to draw the lines between each bar point.
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksLocation (inherited from CustomBar) | Sets the alignment of the Mark into the Bars.
MarksOnBar (inherited from CustomBar) | Sets a postition of the Marks into the Bars.
MiddleZ (inherited from Series) | For internal use.
MultiBar (inherited from CustomBar) | Determines how multiple BarSeries will be displayed in the same Chart.
NumGallerySeries (inherited from Series) | For internal use.
OffsetPercent (inherited from CustomBar) | Sets the Bar displacement as percent of Bar size.
Origin (inherited from CustomBar) | Sets the common bottom value used for all Bar points.
Pen (inherited from CustomBar) | Pen used to draw the Bar rectangles.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow (inherited from CustomBar) | Defines the Shadow used to draw behind the Bars.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideMargins (inherited from CustomBar) | Sets a margin between Chart rectangle and Bars.
StackGroup (inherited from CustomBar) | Allows stacking independent Series within the same Chart.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickLines (inherited from CustomBar) | Pen used to draw "tick" lines across each bar.
Title (inherited from Series) | Series description to show in Legend and editors.
UseOrigin (inherited from CustomBar) | Allows Bars to be bottom aligned to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin (inherited from CustomBar) | System.Obsolete: Please use Origin property.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

BarJoin Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.BarJoin.Description Property

public override String Description {get;}

See Also

BarJoin Class | BarJoin Members | Steema.TeeChart.Styles Namespace


JoinPen

Steema.TeeChart.Styles.BarJoin.JoinPen Property

Determines the pen to draw the lines between each bar point.
public ChartPen JoinPen {get;}

See Also

BarJoin Class | BarJoin Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BarStyles

Steema.TeeChart.Styles.BarStyles Enum

Describes the possible values of the BarStyle property.
[Serializable]
public sealed enum BarStyles : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
Rectangle | Defines a rectangle shape for each bar series point.
Pyramid | Defines a pyramid shape for each bar series point.
InvPyramid | Defines an inverted pyramid shape for each bar series point.
Cylinder | Defines a cylinder shape for each bar series point.
Ellipse | Defines an ellipse shape for each bar series point.
Arrow | Defines an arrow shape for each bar series point.
RectGradient | Defines a rectangle shape with a gradient for each bar series point.
Cone | Defines a cone shape for each bar series point.
InvArrow | Defines an inverted arrow shape for each bar series point.
InvCone | Defines an inverted cone shape for each bar series point.
Bevel | Defines an bevelled shape for each bar series point.
SlantCube | Defines an bevelled cubic shape for each bar series point.
Diamond | Defines a diamond shape for each bar series point.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BaseLine

Steema.TeeChart.Styles.BaseLine Class

Abstract Series class inherited by a number of TeeChart series styles.

For a list of all members of this type, see BaseLine Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public abstract class BaseLine : Series , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

BaseLine members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BaseLineMembers

Steema.TeeChart.Styles.BaseLine all Members

BaseLine overview

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Series) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen | Determines pen to draw the line connecting all points.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull |
TreatNulls |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

BaseLine Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BaseLineEvents

Steema.TeeChart.Styles.BaseLine Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

BaseLine Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BaseLineFields

Steema.TeeChart.Styles.BaseLine Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

BaseLine Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BaseLineMethods

Steema.TeeChart.Styles.BaseLine Methods

Public Methods

Add |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Series) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

BaseLine Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.BaseLine.Add Method

Overload List

public override Void Add(System.Array, System.Array, System.Boolean)
public override Int32 Add(System.Double, System.Double)

See Also

BaseLine Class | BaseLine Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.BaseLine.Add Method

public override Int32 Add(Double x,
     Double y)

See Also

Add Overload List | BaseLine Class | BaseLine Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.BaseLine.Add Method

public override Void Add(Array xValues,
     Array yValues,
     Boolean append)

See Also

Add Overload List | BaseLine Class | BaseLine Members | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.BaseLine.AssignFormat Method

Overload List

public override Void AssignFormat(Steema.TeeChart.Styles.Series, Steema.TeeChart.Styles.Series)

See Also

BaseLine Class | BaseLine Members | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.BaseLine.AssignFormat Method

public override Void AssignFormat(Series source,
     Series target)

See Also

AssignFormat Overload List | BaseLine Class | BaseLine Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BaseLineProperties

Steema.TeeChart.Styles.BaseLine Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen | Determines pen to draw the line connecting all points.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull |
TreatNulls |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

BaseLine Class | Steema.TeeChart.Styles Namespace


LinePen

Steema.TeeChart.Styles.BaseLine.LinePen Property

Determines pen to draw the line connecting all points.
public ChartPen LinePen {get; set;}

See Also

BaseLine Class | BaseLine Members | Steema.TeeChart.Styles Namespace


TreatNaNAsNull

Steema.TeeChart.Styles.BaseLine.TreatNaNAsNull Property

public Boolean TreatNaNAsNull {get; set;}

See Also

BaseLine Class | BaseLine Members | Steema.TeeChart.Styles Namespace


TreatNulls

Steema.TeeChart.Styles.BaseLine.TreatNulls Property

public TreatNullsStyle TreatNulls {get; set;}

See Also

BaseLine Class | BaseLine Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BeforeDrawPointEventArgs

Steema.TeeChart.Styles.BeforeDrawPointEventArgs Class

The Event Data for the BeforeDrawPoint event.

For a list of all members of this type, see BeforeDrawPointEventArgs Members

System.Object
System.EventArgs
public class BeforeDrawPointEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

BeforeDrawPointEventArgs members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BeforeDrawPointEventArgsMembers

Steema.TeeChart.Styles.BeforeDrawPointEventArgs all Members

BeforeDrawPointEventArgs overview

Constructors

Constructor

Public Properties

ValueIndex The Index of the value in the series ValueList.

See Also

BeforeDrawPointEventArgs Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BeforeDrawPointEventArgs Constructor

public BeforeDrawPointEventArgs(Int32 valueIndex)

See Also

BeforeDrawPointEventArgs Class | BeforeDrawPointEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BeforeDrawPointEventArgsProperties

Steema.TeeChart.Styles.BeforeDrawPointEventArgs Properties

Public Properties

ValueIndex The Index of the value in the series ValueList.

See Also

BeforeDrawPointEventArgs Class | Steema.TeeChart.Styles Namespace


ValueIndex

Steema.TeeChart.Styles.BeforeDrawPointEventArgs.ValueIndex Property

The Index of the value in the series ValueList.
public Int32 ValueIndex {get;}

See Also

BeforeDrawPointEventArgs Class | BeforeDrawPointEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Bezier

Steema.TeeChart.Styles.Bezier Class

Bezier series.

For a list of all members of this type, see Bezier Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
public class Bezier : Custom , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Bezier members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BezierMembers

Steema.TeeChart.Styles.Bezier all Members

Bezier overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Custom) | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Custom) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery | Internal use.
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush (inherited from Custom) | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Bezier Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Bezier Constructor

Overload List

public Bezier()
public Bezier(Steema.TeeChart.Chart)

See Also

Bezier Class | Bezier Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Bezier Constructor

public Bezier(Chart c)

See Also

Bezier Constructor Overload List | Bezier Class | Bezier Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Bezier Constructor

public Bezier()

See Also

Bezier Constructor Overload List | Bezier Class | Bezier Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BezierEvents

Steema.TeeChart.Styles.Bezier Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Bezier Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BezierFields

Steema.TeeChart.Styles.Bezier Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Bezier Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BezierMethods

Steema.TeeChart.Styles.Bezier Methods

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Custom) | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Custom) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery | Internal use.
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Bezier Class | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.Bezier.Draw Method

public override Void Draw()

See Also

Bezier Class | Bezier Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.Bezier.PrepareForGallery Method

Internal use.
public override Void PrepareForGallery(Boolean IsEnabled)

See Also

Bezier Class | Bezier Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BezierProperties

Steema.TeeChart.Styles.Bezier Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush (inherited from Custom) | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Bezier Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Bezier.Description Property

public override String Description {get;}

See Also

Bezier Class | Bezier Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Box

Steema.TeeChart.Styles.Box Class

The Box Series plots a vertical box series.

For a list of all members of this type, see Box Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Points
Steema.TeeChart.Styles.CustomBox
public class Box : CustomBox , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Box members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BoxMembers

Steema.TeeChart.Styles.Box all Members

Box overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from CustomBox) | Add x-displacement position and values for Box valueset.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos |
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer (inherited from CustomBox) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from CustomBox) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBox) | Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue |
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue | Returns the Minimum Value of the Series X Values List.
MinYValue |
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from CustomBox) |
ReconstructFromData (inherited from CustomBox) | Reconstructs the box plot from series data
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AdjacentPoint1 (inherited from CustomBox) | Read from AdjacentPoint1 to get SampleValues lower adjacent point limit. Write to AdjacentPoint1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
AdjacentPoint3 (inherited from CustomBox) | Read from AdjacentPoint3 to get SampleValues upper adjacent point limit. Write to AdjacentPoint3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
Box (inherited from CustomBox) | Controls the appearance of CustomBoxSeries box.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
ExtrOut (inherited from CustomBox) | Controls the appearance of the extreme range of outer points.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InnerFence1 (inherited from CustomBox) | Read from InnerFence1 to get SampleValues lower inner fence. Write to InnerFence1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
InnerFence3 (inherited from CustomBox) | Read from InnerFence3 to get SampleValues upper inner fence. Write to InnerFence3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
Median (inherited from CustomBox) | Read from Median to get SampleValues median value. Write to Median to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
MedianPen (inherited from CustomBox) | Defines the Pen to draw the median line.
MiddleZ (inherited from Series) | For internal use.
MildOut (inherited from CustomBox) | Controls the appearance of the mid range of outer points.
NumGallerySeries (inherited from Series) | For internal use.
OuterFence1 (inherited from CustomBox) | Read from OuterFence1 to get SampleValues lower outer fence. Write to OuterFence1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
OuterFence3 (inherited from CustomBox) | Read from OuterFence3 to get SampleValues upper outer fence. Write to OuterFence3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
Position (inherited from CustomBox) | Specifies the position of box series.
Quartile1 (inherited from CustomBox) | Read from Quartile1 to get SampleValues first quartile. Write to Quartile1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
Quartile3 (inherited from CustomBox) | Read from Quartile3 to get SampleValues third quartile. Write to Quartile3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
SampleValues (inherited from CustomBox) | Use SampleValues property to get access to the values of Series.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UseCustomValues (inherited from CustomBox) | Set the UseCustomValues property to true if you want to override internal algorithm to construct a box plot.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
WhiskerLength (inherited from CustomBox) | Defines the whisker length as a function of the inter-quartike range (IQR).
WhiskerPen (inherited from CustomBox) | Defines the Pen to draw the whisker lines.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Box Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Box Constructor

Overload List

public Box()
public Box(Steema.TeeChart.Chart)

See Also

Box Class | Box Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Box Constructor

public Box(Chart c)

See Also

Box Constructor Overload List | Box Class | Box Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Box Constructor

public Box()

See Also

Box Constructor Overload List | Box Class | Box Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BoxEvents

Steema.TeeChart.Styles.Box Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Box Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BoxFields

Steema.TeeChart.Styles.Box Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Box Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BoxMethods

Steema.TeeChart.Styles.Box Methods

Public Methods

Add (inherited from CustomBox) | Add x-displacement position and values for Box valueset.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos |
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer (inherited from CustomBox) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from CustomBox) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBox) | Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue |
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue | Returns the Minimum Value of the Series X Values List.
MinYValue |
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from CustomBox) |
ReconstructFromData (inherited from CustomBox) | Reconstructs the box plot from series data
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Box Class | Steema.TeeChart.Styles Namespace


CalcXPos

Steema.TeeChart.Styles.Box.CalcXPos Method

public override Int32 CalcXPos(Int32 valueIndex)

See Also

Box Class | Box Members | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.Box.MaxXValue Method

Returns the Maximum Value of the Series X Values List.
public override Double MaxXValue()

See Also

Box Class | Box Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.Box.MaxYValue Method

public override Double MaxYValue()

See Also

Box Class | Box Members | Steema.TeeChart.Styles Namespace


MinXValue

Steema.TeeChart.Styles.Box.MinXValue Method

Returns the Minimum Value of the Series X Values List.
public override Double MinXValue()

See Also

Box Class | Box Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.Box.MinYValue Method

public override Double MinYValue()

See Also

Box Class | Box Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BoxProperties

Steema.TeeChart.Styles.Box Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AdjacentPoint1 (inherited from CustomBox) | Read from AdjacentPoint1 to get SampleValues lower adjacent point limit. Write to AdjacentPoint1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
AdjacentPoint3 (inherited from CustomBox) | Read from AdjacentPoint3 to get SampleValues upper adjacent point limit. Write to AdjacentPoint3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
Box (inherited from CustomBox) | Controls the appearance of CustomBoxSeries box.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
ExtrOut (inherited from CustomBox) | Controls the appearance of the extreme range of outer points.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InnerFence1 (inherited from CustomBox) | Read from InnerFence1 to get SampleValues lower inner fence. Write to InnerFence1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
InnerFence3 (inherited from CustomBox) | Read from InnerFence3 to get SampleValues upper inner fence. Write to InnerFence3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
Median (inherited from CustomBox) | Read from Median to get SampleValues median value. Write to Median to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
MedianPen (inherited from CustomBox) | Defines the Pen to draw the median line.
MiddleZ (inherited from Series) | For internal use.
MildOut (inherited from CustomBox) | Controls the appearance of the mid range of outer points.
NumGallerySeries (inherited from Series) | For internal use.
OuterFence1 (inherited from CustomBox) | Read from OuterFence1 to get SampleValues lower outer fence. Write to OuterFence1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
OuterFence3 (inherited from CustomBox) | Read from OuterFence3 to get SampleValues upper outer fence. Write to OuterFence3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
Position (inherited from CustomBox) | Specifies the position of box series.
Quartile1 (inherited from CustomBox) | Read from Quartile1 to get SampleValues first quartile. Write to Quartile1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
Quartile3 (inherited from CustomBox) | Read from Quartile3 to get SampleValues third quartile. Write to Quartile3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
SampleValues (inherited from CustomBox) | Use SampleValues property to get access to the values of Series.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UseCustomValues (inherited from CustomBox) | Set the UseCustomValues property to true if you want to override internal algorithm to construct a box plot.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
WhiskerLength (inherited from CustomBox) | Defines the whisker length as a function of the inter-quartike range (IQR).
WhiskerPen (inherited from CustomBox) | Defines the Pen to draw the whisker lines.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Box Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Box.Description Property

public override String Description {get;}

See Also

Box Class | Box Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Bubble

Steema.TeeChart.Styles.Bubble Class

Bubble Series.

For a list of all members of this type, see Bubble Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Points
public class Bubble : Points , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Bubble members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BubbleMembers

Steema.TeeChart.Styles.Bubble all Members

Bubble overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add | Adds a new Bubble point to the Series Points List and color.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf | Is used to validate the DataSource property both at design and run-time.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue | Returns the maximum Z value.
MinXValue | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue | Returns the minimum Z value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach | Controls which color will be drawn on the bubbles.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
RadiusValues | A TList object that stores each Bubble point Radius value.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Squared | Determines how the Bubble size is calculated.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UseVerticalAxis | Gets and sets whether the Radius values are calculated relative to the Vertical Axis or the Horizontal Axis. This property only has a visible effect when Squared is set to true.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Bubble Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Bubble Constructor

Overload List

public Bubble()
public Bubble(Steema.TeeChart.Chart)

See Also

Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Bubble Constructor

public Bubble(Chart c)

See Also

Bubble Constructor Overload List | Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Bubble Constructor

public Bubble()

See Also

Bubble Constructor Overload List | Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BubbleEvents

Steema.TeeChart.Styles.Bubble Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Bubble Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BubbleFields

Steema.TeeChart.Styles.Bubble Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Bubble Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BubbleMethods

Steema.TeeChart.Styles.Bubble Methods

Public Methods

Add | Adds a new Bubble point to the Series Points List and color.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf | Is used to validate the DataSource property both at design and run-time.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue | Returns the maximum Z value.
MinXValue | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue | Returns the minimum Z value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Bubble Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Bubble.Add Method

Overload List

Adds a new Bubble point to the Series Points List and color.

public Int32 Add(System.Double, System.Double, System.Double, System.Drawing.Color)

Adds a new Bubble point to the Series Points List.

public Int32 Add(System.Double, System.Double, System.Double)

Adds a new Bubble point to the Series Points List and label.

public Int32 Add(System.Double, System.Double, System.Double, System.String)

Adds a new Bubble point to the Series Points List, label and color.

public Int32 Add(System.Double, System.Double, System.Double, System.String, System.Drawing.Color)

See Also

Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Bubble.Add Method

Adds a new Bubble point to the Series Points List, label and color.
public Int32 Add(Double x,
     Double y,
     Double radius,
     String text,
     Color color)

See Also

Add Overload List | Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Bubble.Add Method

Adds a new Bubble point to the Series Points List and label.
public Int32 Add(Double x,
     Double y,
     Double radius,
     String text)

See Also

Add Overload List | Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Bubble.Add Method

Adds a new Bubble point to the Series Points List.
public Int32 Add(Double x,
     Double y,
     Double radius)

See Also

Add Overload List | Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Bubble.Add Method

Adds a new Bubble point to the Series Points List and color.
public Int32 Add(Double x,
     Double y,
     Double radius,
     Color color)

See Also

Add Overload List | Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


ClickedPointer

Steema.TeeChart.Styles.Bubble.ClickedPointer Method

Overload List

public override Boolean ClickedPointer(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

See Also

Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


ClickedPointer

Steema.TeeChart.Styles.Bubble.ClickedPointer Method

public override Boolean ClickedPointer(Int32 valueIndex,
     Int32 tmpX,
     Int32 tmpY,
     Int32 x,
     Int32 y)

See Also

ClickedPointer Overload List | Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.Bubble.DrawValue Method

Called internally. Draws the "ValueIndex" point of the Series.
public override Void DrawValue(Int32 valueIndex)

See Also

Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


IsValidSourceOf

Steema.TeeChart.Styles.Bubble.IsValidSourceOf Method

Is used to validate the DataSource property both at design and run-time.
public override Boolean IsValidSourceOf(Series value)

See Also

Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.Bubble.MaxXValue Method

Returns the Maximum Value of the Series X Values List.
public override Double MaxXValue()

See Also

Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.Bubble.MaxYValue Method

Returns the Maximum Value of the Series Y Values List.
public override Double MaxYValue()

See Also

Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


MaxZValue

Steema.TeeChart.Styles.Bubble.MaxZValue Method

Returns the maximum Z value.
public override Double MaxZValue()

See Also

Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


MinXValue

Steema.TeeChart.Styles.Bubble.MinXValue Method

Returns the Minimum Value of the Series X Values List.
public override Double MinXValue()

See Also

Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.Bubble.MinYValue Method

Returns the Minimum Value of the Series Y Values List.
public override Double MinYValue()

See Also

Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


MinZValue

Steema.TeeChart.Styles.Bubble.MinZValue Method

Returns the minimum Z value.
public override Double MinZValue()

See Also

Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.BubbleProperties

Steema.TeeChart.Styles.Bubble Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach | Controls which color will be drawn on the bubbles.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
RadiusValues | A TList object that stores each Bubble point Radius value.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Squared | Determines how the Bubble size is calculated.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UseVerticalAxis | Gets and sets whether the Radius values are calculated relative to the Vertical Axis or the Horizontal Axis. This property only has a visible effect when Squared is set to true.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Bubble Class | Steema.TeeChart.Styles Namespace


ColorEach

Steema.TeeChart.Styles.Bubble.ColorEach Property

Controls which color will be drawn on the bubbles.
public Boolean ColorEach {get; set;}

See Also

Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Bubble.Description Property

public override String Description {get;}

See Also

Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


RadiusValues

Steema.TeeChart.Styles.Bubble.RadiusValues Property

A TList object that stores each Bubble point Radius value.
public ValueList RadiusValues {get; set;}

See Also

Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


Squared

Steema.TeeChart.Styles.Bubble.Squared Property

Determines how the Bubble size is calculated.
public Boolean Squared {get; set;}

See Also

Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


UseVerticalAxis

Steema.TeeChart.Styles.Bubble.UseVerticalAxis Property

Gets and sets whether the Radius values are calculated relative to the Vertical Axis or the Horizontal Axis. This property only has a visible effect when Squared is set to true.
public Boolean UseVerticalAxis {get; set;}

See Also

Bubble Class | Bubble Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar

Steema.TeeChart.Styles.Calendar Class

Calendar series.

For a list of all members of this type, see Calendar Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class Calendar : Series , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Calendar members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CalendarMembers

Steema.TeeChart.Styles.Calendar all Members

Calendar overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
Change |
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
DayOneColumn |
DayOneRow |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
MonthClick | Handles the click events of the NextMonth and PreviosMonth buttons.
NextMonth | Moves the Calender series onto the month after the present one.
PrepareForGallery |
PreviousMonth | Moves the Calender series onto the month before the present one.
RectCell | Returns the bounderies of a 2D-Rectangle defining the outline of the specified Calender series cell.
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetCell | Can use Mouseclick to set the selected DateCell.
SetNextPrevious | Can use Mouseclick to set the Next or Previous buttons.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Columns | Returns the number of Columns present in the Calender Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
Date | Defines a day and causes Calender Series to display the associated month.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
Days | Defines Calender Cell appearance characteristics for calender days.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets description text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
Month |
Months | Defines Calender Cell appearance for the month name.
NextMonthButton | Gets the month after the present one.
NumGallerySeries (inherited from Series) | For internal use.
Pen | Element Pen Characteristics.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
PreviousMonthButton | Gets the month before the present one.
Rows | Returns the number of Rows present in the Calender Series.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Sunday | Defines Calender Cell appearance for all Sundays.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Today | Defines Calender Cell appearance for the highlighted day.
Trailing | Defines Calender Cell appearance for the trailing days.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
WeekDays | Defines Calender Cell appearance for weekday titles.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Calendar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar Constructor

Overload List

public Calendar()
public Calendar(Steema.TeeChart.Chart)

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar Constructor

public Calendar(Chart c)

See Also

Calendar Constructor Overload List | Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar Constructor

public Calendar()

See Also

Calendar Constructor Overload List | Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CalendarEvents

Steema.TeeChart.Styles.Calendar Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
Change |
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Calendar Class | Steema.TeeChart.Styles Namespace


Change

Steema.TeeChart.Styles.Calendar.Change Event

public CalendarChangeEventHandler  Change

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CalendarFields

Steema.TeeChart.Styles.Calendar Fields

Public Fields

bBrush (inherited from Series) |
DayOneColumn |
DayOneRow |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Calendar Class | Steema.TeeChart.Styles Namespace


DayOneColumn

Steema.TeeChart.Styles.Calendar.DayOneColumn Field

public Int32 DayOneColumn

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


DayOneRow

Steema.TeeChart.Styles.Calendar.DayOneRow Field

public Int32 DayOneRow

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CalendarMethods

Steema.TeeChart.Styles.Calendar Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
MonthClick | Handles the click events of the NextMonth and PreviosMonth buttons.
NextMonth | Moves the Calender series onto the month after the present one.
PrepareForGallery |
PreviousMonth | Moves the Calender series onto the month before the present one.
RectCell | Returns the bounderies of a 2D-Rectangle defining the outline of the specified Calender series cell.
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetCell | Can use Mouseclick to set the selected DateCell.
SetNextPrevious | Can use Mouseclick to set the Next or Previous buttons.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Calendar Class | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Calendar.Clicked Method

Overload List

Returns the ValueIndex of the "clicked" point in the Series.

public override Int32 Clicked(System.Int32, System.Int32)

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Calendar.Clicked Method

Returns the ValueIndex of the "clicked" point in the Series.
public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.Calendar.Draw Method

public override Void Draw()

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


MonthClick

Steema.TeeChart.Styles.Calendar.MonthClick Method

Handles the click events of the NextMonth and PreviosMonth buttons.
public Void MonthClick(Object sender,
     EventArgs e)

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


NextMonth

Steema.TeeChart.Styles.Calendar.NextMonth Method

Moves the Calender series onto the month after the present one.
public Void NextMonth()

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.Calendar.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


PreviousMonth

Steema.TeeChart.Styles.Calendar.PreviousMonth Method

Moves the Calender series onto the month before the present one.
public Void PreviousMonth()

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


RectCell

Steema.TeeChart.Styles.Calendar.RectCell Method

Returns the bounderies of a 2D-Rectangle defining the outline of the specified Calender series cell.
public Rectangle RectCell(Int32 Column,
     Int32 Row)

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


SetCell

Steema.TeeChart.Styles.Calendar.SetCell Method

Can use Mouseclick to set the selected DateCell.
public Boolean SetCell(Int32 x,
     Int32 y)

Parameters

x
pixel X location
y
pixel Y location

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


SetNextPrevious

Steema.TeeChart.Styles.Calendar.SetNextPrevious Method

Can use Mouseclick to set the Next or Previous buttons.
public Boolean SetNextPrevious(Int32 x,
     Int32 y)

Parameters

x
pixel X location
y
pixel Y location

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CalendarProperties

Steema.TeeChart.Styles.Calendar Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Columns | Returns the number of Columns present in the Calender Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
Date | Defines a day and causes Calender Series to display the associated month.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
Days | Defines Calender Cell appearance characteristics for calender days.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets description text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
Month |
Months | Defines Calender Cell appearance for the month name.
NextMonthButton | Gets the month after the present one.
NumGallerySeries (inherited from Series) | For internal use.
Pen | Element Pen Characteristics.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
PreviousMonthButton | Gets the month before the present one.
Rows | Returns the number of Rows present in the Calender Series.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Sunday | Defines Calender Cell appearance for all Sundays.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Today | Defines Calender Cell appearance for the highlighted day.
Trailing | Defines Calender Cell appearance for the trailing days.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
WeekDays | Defines Calender Cell appearance for weekday titles.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Calendar Class | Steema.TeeChart.Styles Namespace


Columns

Steema.TeeChart.Styles.Calendar.Columns Property

Returns the number of Columns present in the Calender Series.
public Int32 Columns {get;}

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


Date

Steema.TeeChart.Styles.Calendar.Date Property

Defines a day and causes Calender Series to display the associated month.
public DateTime Date {get; set;}

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


Days

Steema.TeeChart.Styles.Calendar.Days Property

Defines Calender Cell appearance characteristics for calender days.
public CalendarCell Days {get;}

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Calendar.Description Property

Gets description text.
public override String Description {get;}

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


Month

Steema.TeeChart.Styles.Calendar.Month Property

public Int32 Month {get;}

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


Months

Steema.TeeChart.Styles.Calendar.Months Property

Defines Calender Cell appearance for the month name.
public CalendarCellUpper Months {get;}

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


NextMonthButton

Steema.TeeChart.Styles.Calendar.NextMonthButton Property

Gets the month after the present one.
public TextShape NextMonthButton {get;}

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


Pen

Steema.TeeChart.Styles.Calendar.Pen Property

Element Pen Characteristics.
public ChartPen Pen {get;}

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


PreviousMonthButton

Steema.TeeChart.Styles.Calendar.PreviousMonthButton Property

Gets the month before the present one.
public TextShape PreviousMonthButton {get;}

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


Rows

Steema.TeeChart.Styles.Calendar.Rows Property

Returns the number of Rows present in the Calender Series.
public Int32 Rows {get;}

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


Sunday

Steema.TeeChart.Styles.Calendar.Sunday Property

Defines Calender Cell appearance for all Sundays.
public CalendarCell Sunday {get;}

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


Today

Steema.TeeChart.Styles.Calendar.Today Property

Defines Calender Cell appearance for the highlighted day.
public CalendarCell Today {get;}

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


Trailing

Steema.TeeChart.Styles.Calendar.Trailing Property

Defines Calender Cell appearance for the trailing days.
public CalendarCell Trailing {get;}

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


WeekDays

Steema.TeeChart.Styles.Calendar.WeekDays Property

Defines Calender Cell appearance for weekday titles.
public CalendarCellUpper WeekDays {get;}

See Also

Calendar Class | Calendar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar.CalendarCell

Steema.TeeChart.Styles.Calendar.CalendarCell Class

Contains the characteristics of each Calendar Cell.

For a list of all members of this type, see CalendarCell Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
public class CalendarCell : TextShape , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

CalendarCell members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar.CalendarCellMembers

Steema.TeeChart.Styles.Calendar.CalendarCell all Members

CalendarCell overview

Public Fields

Series
Size (inherited from TextShape)

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.

Public Properties

AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

Constructors

Steema.TeeChart.Styles.Calendar.CalendarCell..ctor Overloaded

See Also

CalendarCell Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar.CalendarCellFields

Steema.TeeChart.Styles.Calendar.CalendarCell Fields

Public Fields

Series
Size (inherited from TextShape)

See Also

CalendarCell Class | Steema.TeeChart.Styles Namespace


Series

Steema.TeeChart.Styles.Calendar+CalendarCell.Series Field

public Calendar Series

See Also

CalendarCell Class | CalendarCell Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar.CalendarCellMethods

Steema.TeeChart.Styles.Calendar.CalendarCell Methods

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.

See Also

CalendarCell Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar.CalendarCellProperties

Steema.TeeChart.Styles.Calendar.CalendarCell Properties

Public Properties

AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

CalendarCell Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar+CalendarCell Constructor

Overload List

public Calendar+CalendarCell()
public Calendar+CalendarCell(Steema.TeeChart.Styles.Calendar)

See Also

CalendarCell Class | CalendarCell Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar+CalendarCell Constructor

public Calendar+CalendarCell(Calendar s)

See Also

Calendar.CalendarCell Constructor Overload List | CalendarCell Class | CalendarCell Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar+CalendarCell Constructor

public Calendar+CalendarCell()

See Also

Calendar.CalendarCell Constructor Overload List | CalendarCell Class | CalendarCell Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar.CalendarCellUpper

Steema.TeeChart.Styles.Calendar.CalendarCellUpper Class

Format information for the upper row cells of the Calendar Series.

For a list of all members of this type, see CalendarCellUpper Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
Steema.TeeChart.Styles.Calendar+CalendarCell
public sealed class CalendarCellUpper : CalendarCell , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

CalendarCellUpper members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar.CalendarCellUpperMembers

Steema.TeeChart.Styles.Calendar.CalendarCellUpper all Members

CalendarCellUpper overview

Public Fields

Series (inherited from Calendar+CalendarCell)
Size (inherited from TextShape)

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.

Public Properties

AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Format | Defines the DateValue format for the months and weekdays.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
UpperCase | Enables/disables the display of months and weekdays in upper case.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

Constructors

Steema.TeeChart.Styles.Calendar.CalendarCellUpper..ctor Overloaded

See Also

CalendarCellUpper Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar.CalendarCellUpperFields

Steema.TeeChart.Styles.Calendar.CalendarCellUpper Fields

Public Fields

Series (inherited from Calendar+CalendarCell)
Size (inherited from TextShape)

See Also

CalendarCellUpper Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar.CalendarCellUpperMethods

Steema.TeeChart.Styles.Calendar.CalendarCellUpper Methods

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.

See Also

CalendarCellUpper Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar.CalendarCellUpperProperties

Steema.TeeChart.Styles.Calendar.CalendarCellUpper Properties

Public Properties

AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Format | Defines the DateValue format for the months and weekdays.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
UpperCase | Enables/disables the display of months and weekdays in upper case.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

CalendarCellUpper Class | Steema.TeeChart.Styles Namespace


Format

Steema.TeeChart.Styles.Calendar+CalendarCellUpper.Format Property

Defines the DateValue format for the months and weekdays.
public String Format {get; set;}

See Also

CalendarCellUpper Class | CalendarCellUpper Members | Steema.TeeChart.Styles Namespace


UpperCase

Steema.TeeChart.Styles.Calendar+CalendarCellUpper.UpperCase Property

Enables/disables the display of months and weekdays in upper case.
public Boolean UpperCase {get; set;}

See Also

CalendarCellUpper Class | CalendarCellUpper Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar+CalendarCellUpper Constructor

Overload List

public Calendar+CalendarCellUpper()
public Calendar+CalendarCellUpper(Steema.TeeChart.Styles.Calendar)

See Also

CalendarCellUpper Class | CalendarCellUpper Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar+CalendarCellUpper Constructor

public Calendar+CalendarCellUpper(Calendar s)

See Also

Calendar.CalendarCellUpper Constructor Overload List | CalendarCellUpper Class | CalendarCellUpper Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar+CalendarCellUpper Constructor

public Calendar+CalendarCellUpper()

See Also

Calendar.CalendarCellUpper Constructor Overload List | CalendarCellUpper Class | CalendarCellUpper Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar.CalendarChangeEventArgs

Steema.TeeChart.Styles.Calendar.CalendarChangeEventArgs Class

The Event Data for the Change event.

For a list of all members of this type, see CalendarChangeEventArgs Members

System.Object
System.EventArgs
public class CalendarChangeEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

CalendarChangeEventArgs members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar.CalendarChangeEventArgsMembers

Steema.TeeChart.Styles.Calendar.CalendarChangeEventArgs all Members

CalendarChangeEventArgs overview

Public Properties

Date The selected date.

Constructors

Steema.TeeChart.Styles.Calendar.CalendarChangeEventArgs..ctor

See Also

CalendarChangeEventArgs Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar.CalendarChangeEventArgsProperties

Steema.TeeChart.Styles.Calendar.CalendarChangeEventArgs Properties

Public Properties

Date The selected date.

See Also

CalendarChangeEventArgs Class | Steema.TeeChart.Styles Namespace


Date

Steema.TeeChart.Styles.Calendar+CalendarChangeEventArgs.Date Property

The selected date.
public DateTime Date {get; set;}

See Also

CalendarChangeEventArgs Class | CalendarChangeEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar+CalendarChangeEventArgs Constructor

public Calendar+CalendarChangeEventArgs(DateTime dateTime)

See Also

CalendarChangeEventArgs Class | CalendarChangeEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Calendar.CalendarChangeEventHandler

Steema.TeeChart.Styles.Calendar.CalendarChangeEventHandler Delegate

The Delegate for the Change event.
public delegate CalendarChangeEventHandler (Calendar sender,
     CalendarChangeEventArgs e)

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Callout

Steema.TeeChart.Styles.Callout Class

Mark Callout pointer characteristics

For a list of all members of this type, see Callout Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.SeriesPointer
public class Callout : SeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Callout members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CalloutMembers

Steema.TeeChart.Styles.Callout all Members

Callout overview

Constructors

Constructor Overloaded

Public Methods

Clone (inherited from SeriesPointer) |
Draw (inherited from SeriesPointer) | Internal use. Draw Pointer
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Arrow |
ArrowHead |
ArrowHeadDirection |
ArrowHeadSize |
Brush (inherited from SeriesPointer) | Brush used to fill Series Pointers.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from SeriesPointer) | Sets the pointer color.
Dark3D (inherited from SeriesPointer) | Fills pointer sides in 3D mode with darker color.
Distance |
Draw3D (inherited from SeriesPointer) | Draws pointer in 3D mode.
EndZ (inherited from SeriesPointer) |
Gradient (inherited from SeriesPointer) | Configures Gradient filling attributes.
HorizSize (inherited from SeriesPointer) | Horizontal size of pointer in pixels.
InflateMargins (inherited from SeriesPointer) | Expands axes to fit pointers.
MiddleZ (inherited from SeriesPointer) |
Pen (inherited from SeriesPointer) | Pen used to draw a frame around Series Pointers.
Series (inherited from SeriesPointer) |
StartZ (inherited from SeriesPointer) |
Style (inherited from SeriesPointer) | Sets the Pointer style.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency (inherited from SeriesPointer) | Sets Percent of semiglass effect.
VertSize (inherited from SeriesPointer) | Sets Horizontal size of pointer in pixels.
Visible (inherited from SeriesPointer) | Shows or hides the pointer.

See Also

Callout Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Callout Constructor

Overload List

public Callout()
public Callout(Steema.TeeChart.Styles.Series)

See Also

Callout Class | Callout Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Callout Constructor

public Callout(Series s)

See Also

Callout Constructor Overload List | Callout Class | Callout Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Callout Constructor

public Callout()

See Also

Callout Constructor Overload List | Callout Class | Callout Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CalloutMethods

Steema.TeeChart.Styles.Callout Methods

Public Methods

Clone (inherited from SeriesPointer) |
Draw (inherited from SeriesPointer) | Internal use. Draw Pointer
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

See Also

Callout Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CalloutProperties

Steema.TeeChart.Styles.Callout Properties

Public Properties

Arrow |
ArrowHead |
ArrowHeadDirection |
ArrowHeadSize |
Brush (inherited from SeriesPointer) | Brush used to fill Series Pointers.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from SeriesPointer) | Sets the pointer color.
Dark3D (inherited from SeriesPointer) | Fills pointer sides in 3D mode with darker color.
Distance |
Draw3D (inherited from SeriesPointer) | Draws pointer in 3D mode.
EndZ (inherited from SeriesPointer) |
Gradient (inherited from SeriesPointer) | Configures Gradient filling attributes.
HorizSize (inherited from SeriesPointer) | Horizontal size of pointer in pixels.
InflateMargins (inherited from SeriesPointer) | Expands axes to fit pointers.
MiddleZ (inherited from SeriesPointer) |
Pen (inherited from SeriesPointer) | Pen used to draw a frame around Series Pointers.
Series (inherited from SeriesPointer) |
StartZ (inherited from SeriesPointer) |
Style (inherited from SeriesPointer) | Sets the Pointer style.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency (inherited from SeriesPointer) | Sets Percent of semiglass effect.
VertSize (inherited from SeriesPointer) | Sets Horizontal size of pointer in pixels.
Visible (inherited from SeriesPointer) | Shows or hides the pointer.

See Also

Callout Class | Steema.TeeChart.Styles Namespace


Arrow

Steema.TeeChart.Styles.Callout.Arrow Property

public ChartPen Arrow {get; set;}

See Also

Callout Class | Callout Members | Steema.TeeChart.Styles Namespace


ArrowHead

Steema.TeeChart.Styles.Callout.ArrowHead Property

public ArrowHeadStyles ArrowHead {get; set;}

See Also

Callout Class | Callout Members | Steema.TeeChart.Styles Namespace


ArrowHeadDirection

Steema.TeeChart.Styles.Callout.ArrowHeadDirection Property

public ArrowHeadDirection ArrowHeadDirection {get; set;}

See Also

Callout Class | Callout Members | Steema.TeeChart.Styles Namespace


ArrowHeadSize

Steema.TeeChart.Styles.Callout.ArrowHeadSize Property

public Int32 ArrowHeadSize {get; set;}

See Also

Callout Class | Callout Members | Steema.TeeChart.Styles Namespace


Distance

Steema.TeeChart.Styles.Callout.Distance Property

public Int32 Distance {get; set;}

See Also

Callout Class | Callout Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Candle

Steema.TeeChart.Styles.Candle Class

Candle Series.

For a list of all members of this type, see Candle Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
Steema.TeeChart.Styles.OHLC
public class Candle : OHLC , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Candle members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CandleMembers

Steema.TeeChart.Styles.Candle all Members

Candle overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from OHLC) | Adds new point with specified integer index and double open, high, low and close.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
ClickedCandle | Returns true if point p is inside the bounds of the ValueIndex candle
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Custom) |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from OHLC) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue |
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue |
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush (inherited from Custom) | Sets Brush characteristics.
CandleWidth | Sets the horizontal Candle Size in pixels.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
CloseValues (inherited from OHLC) | Gets and sets all Stock market Close values.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DateValues (inherited from OHLC) | Gets and sets all Stock market Date values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
DownCloseColor | Candle color fill when Close value is greater than Open value.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HighLowPen | Pen used to draw "high" and "low" lines
HighValues (inherited from OHLC) | Gets and sets all Stock market High values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from OHLC) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
LowValues (inherited from OHLC) | Gets and sets all Stock market Low values.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OpenValues (inherited from OHLC) | Gets and sets all Stock market Open values.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
Pen |
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowClose | Determines whether Close prices will be displayed.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
ShowOpen | Determines whether Open prices will be displayed.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Style | Determines how the Candle points will be drawn.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UpCloseColor | Candle color fill when Open value is greater than Close value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Candle Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Candle Constructor

Overload List

public Candle(Steema.TeeChart.Chart)
public Candle()

See Also

Candle Class | Candle Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Candle Constructor

public Candle()

See Also

Candle Constructor Overload List | Candle Class | Candle Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Candle Constructor

public Candle(Chart c)

See Also

Candle Constructor Overload List | Candle Class | Candle Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CandleEvents

Steema.TeeChart.Styles.Candle Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Candle Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CandleFields

Steema.TeeChart.Styles.Candle Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Candle Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CandleMethods

Steema.TeeChart.Styles.Candle Methods

Public Methods

Add (inherited from OHLC) | Adds new point with specified integer index and double open, high, low and close.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
ClickedCandle | Returns true if point p is inside the bounds of the ValueIndex candle
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Custom) |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from OHLC) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue |
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue |
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Candle Class | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Candle.Clicked Method

Overload List

Returns the ValueIndex of the "clicked" point in the Series.

public override Int32 Clicked(System.Int32, System.Int32)

See Also

Candle Class | Candle Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Candle.Clicked Method

Returns the ValueIndex of the "clicked" point in the Series.
public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | Candle Class | Candle Members | Steema.TeeChart.Styles Namespace


ClickedCandle

Steema.TeeChart.Styles.Candle.ClickedCandle Method

Returns true if point p is inside the bounds of the ValueIndex candle
public Boolean ClickedCandle(Int32 valueIndex,
     Point p)

See Also

Candle Class | Candle Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.Candle.DrawValue Method

Called internally. Draws the "ValueIndex" point of the Series.
public override Void DrawValue(Int32 valueIndex)

See Also

Candle Class | Candle Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.Candle.MaxYValue Method

public override Double MaxYValue()

See Also

Candle Class | Candle Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.Candle.MinYValue Method

public override Double MinYValue()

See Also

Candle Class | Candle Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.Candle.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

Candle Class | Candle Members | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.Candle.SetSubGallery Method

public override Void SetSubGallery(Int32 index)

See Also

Candle Class | Candle Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CandleProperties

Steema.TeeChart.Styles.Candle Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush (inherited from Custom) | Sets Brush characteristics.
CandleWidth | Sets the horizontal Candle Size in pixels.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
CloseValues (inherited from OHLC) | Gets and sets all Stock market Close values.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DateValues (inherited from OHLC) | Gets and sets all Stock market Date values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
DownCloseColor | Candle color fill when Close value is greater than Open value.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HighLowPen | Pen used to draw "high" and "low" lines
HighValues (inherited from OHLC) | Gets and sets all Stock market High values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from OHLC) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
LowValues (inherited from OHLC) | Gets and sets all Stock market Low values.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OpenValues (inherited from OHLC) | Gets and sets all Stock market Open values.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
Pen |
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowClose | Determines whether Close prices will be displayed.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
ShowOpen | Determines whether Open prices will be displayed.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Style | Determines how the Candle points will be drawn.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UpCloseColor | Candle color fill when Open value is greater than Close value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Candle Class | Steema.TeeChart.Styles Namespace


CandleWidth

Steema.TeeChart.Styles.Candle.CandleWidth Property

Sets the horizontal Candle Size in pixels.
public Int32 CandleWidth {get; set;}

See Also

Candle Class | Candle Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Candle.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

Candle Class | Candle Members | Steema.TeeChart.Styles Namespace


DownCloseColor

Steema.TeeChart.Styles.Candle.DownCloseColor Property

Candle color fill when Close value is greater than Open value.
public Color DownCloseColor {get; set;}

See Also

Candle Class | Candle Members | Steema.TeeChart.Styles Namespace


HighLowPen

Steema.TeeChart.Styles.Candle.HighLowPen Property

Pen used to draw "high" and "low" lines
public ChartPen HighLowPen {get;}

See Also

Candle Class | Candle Members | Steema.TeeChart.Styles Namespace


Pen

Steema.TeeChart.Styles.Candle.Pen Property

public ChartPen Pen {get;}

See Also

Candle Class | Candle Members | Steema.TeeChart.Styles Namespace


ShowClose

Steema.TeeChart.Styles.Candle.ShowClose Property

Determines whether Close prices will be displayed.
public Boolean ShowClose {get; set;}

See Also

Candle Class | Candle Members | Steema.TeeChart.Styles Namespace


ShowOpen

Steema.TeeChart.Styles.Candle.ShowOpen Property

Determines whether Open prices will be displayed.
public Boolean ShowOpen {get; set;}

See Also

Candle Class | Candle Members | Steema.TeeChart.Styles Namespace


Style

Steema.TeeChart.Styles.Candle.Style Property

Determines how the Candle points will be drawn.
public CandleStyles Style {get; set;}

See Also

Candle Class | Candle Members | Steema.TeeChart.Styles Namespace


UpCloseColor

Steema.TeeChart.Styles.Candle.UpCloseColor Property

Candle color fill when Open value is greater than Close value.
public Color UpCloseColor {get; set;}

See Also

Candle Class | Candle Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CandleStyles

Steema.TeeChart.Styles.CandleStyles Enum

Describes the possible values of the Style property.
[Serializable]
public sealed enum CandleStyles : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
CandleStick | Candle points represented by vertical rectangles with Open and Close vertical tick marks.
CandleBar | Candle points represented by vertical lines with Open and Close horizontal tick marks.
OpenClose | Candle points represented by vertical rectangles without Open and Close vertical tick marks.
Line | Candle points represented by a line.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CellsOrientation

Steema.TeeChart.Styles.CellsOrientation ValueType

For a list of all members of this type, see CellsOrientation Members

System.Object
System.ValueType
public sealed struct CellsOrientation : ValueType

See Also

CellsOrientation Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CellsOrientationMembers

Steema.TeeChart.Styles.CellsOrientation all Members

CellsOrientation overview

Public Fields

EndX
EndZ
IncX
IncZ
InitX
InitZ

See Also

CellsOrientation Structure | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CellsOrientationFields

Steema.TeeChart.Styles.CellsOrientation Fields

Public Fields

EndX
EndZ
IncX
IncZ
InitX
InitZ

See Also

CellsOrientation Structure | Steema.TeeChart.Styles Namespace


EndX

Steema.TeeChart.Styles.CellsOrientation.EndX Field

public Int32 EndX

See Also

CellsOrientation Structure | CellsOrientation Members | Steema.TeeChart.Styles Namespace


EndZ

Steema.TeeChart.Styles.CellsOrientation.EndZ Field

public Int32 EndZ

See Also

CellsOrientation Structure | CellsOrientation Members | Steema.TeeChart.Styles Namespace


IncX

Steema.TeeChart.Styles.CellsOrientation.IncX Field

public Int32 IncX

See Also

CellsOrientation Structure | CellsOrientation Members | Steema.TeeChart.Styles Namespace


IncZ

Steema.TeeChart.Styles.CellsOrientation.IncZ Field

public Int32 IncZ

See Also

CellsOrientation Structure | CellsOrientation Members | Steema.TeeChart.Styles Namespace


InitX

Steema.TeeChart.Styles.CellsOrientation.InitX Field

public Int32 InitX

See Also

CellsOrientation Structure | CellsOrientation Members | Steema.TeeChart.Styles Namespace


InitZ

Steema.TeeChart.Styles.CellsOrientation.InitZ Field

public Int32 InitZ

See Also

CellsOrientation Structure | CellsOrientation Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CFrame

Steema.TeeChart.Styles.CFrame Class

For a list of all members of this type, see CFrame Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.TFrame
public class CFrame : TFrame

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

CFrame members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CFrameMembers

Steema.TeeChart.Styles.CFrame all Members

CFrame overview

Constructors

Constructor Overloaded

Public Methods

CalcWidth (inherited from TFrame) | Calculates the actual width of the TFrame object in pixels as using the Width property and the rectangle Rect.
Draw |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Circled (inherited from TFrame) | Toggles the drawing of a circular or rectangular frame.
FrameElementPercents | An array defining the width of each frame member, inner, middle, outer, with that order in the array. The total should sum 100 (%).
GaugeColorPalette (inherited from TFrame) | Gets and sets the CircularGauge's color palette.
InnerBand (inherited from TFrame) | Gets and sets the InnerBand's ChartBrush characteristics.
MiddleBand (inherited from TFrame) | Gets and sets the MiddleBand's ChartBrush characteristics.
OuterBand (inherited from TFrame) | Gets and sets the OuterBand's ChartBrush characteristics.
RotationAngle | Gets and sets the angle of Frame rotation.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TotalAngle | Gets and sets the total display angle of the Frame.
Visible (inherited from TFrame) | Gets and sets the visibility of the TFrame object.
Width (inherited from TFrame) | Gets and sets the width of the TFrame object as a percentage of its bounding rectangle.

See Also

CFrame Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CFrame Constructor

Overload List

public CFrame(Steema.TeeChart.Chart, System.Drawing.Color[])
public CFrame(Steema.TeeChart.Chart, System.Drawing.Color[], System.Boolean)
public CFrame()

See Also

CFrame Class | CFrame Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CFrame Constructor

public CFrame()

See Also

CFrame Constructor Overload List | CFrame Class | CFrame Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CFrame Constructor

public CFrame(Chart c,
     Color[] gColorPalette,
     Boolean circle)

See Also

CFrame Constructor Overload List | CFrame Class | CFrame Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CFrame Constructor

public CFrame(Chart c,
     Color[] gColorPalette)

See Also

CFrame Constructor Overload List | CFrame Class | CFrame Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CFrameMethods

Steema.TeeChart.Styles.CFrame Methods

Public Methods

CalcWidth (inherited from TFrame) | Calculates the actual width of the TFrame object in pixels as using the Width property and the rectangle Rect.
Draw |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

See Also

CFrame Class | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.CFrame.Draw Method

Overload List

public override Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Drawing.Rectangle)

See Also

CFrame Class | CFrame Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.CFrame.Draw Method

public override Void Draw(Graphics3D graphics,
     Rectangle Rect)

See Also

Draw Overload List | CFrame Class | CFrame Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CFrameProperties

Steema.TeeChart.Styles.CFrame Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Circled (inherited from TFrame) | Toggles the drawing of a circular or rectangular frame.
FrameElementPercents | An array defining the width of each frame member, inner, middle, outer, with that order in the array. The total should sum 100 (%).
GaugeColorPalette (inherited from TFrame) | Gets and sets the CircularGauge's color palette.
InnerBand (inherited from TFrame) | Gets and sets the InnerBand's ChartBrush characteristics.
MiddleBand (inherited from TFrame) | Gets and sets the MiddleBand's ChartBrush characteristics.
OuterBand (inherited from TFrame) | Gets and sets the OuterBand's ChartBrush characteristics.
RotationAngle | Gets and sets the angle of Frame rotation.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TotalAngle | Gets and sets the total display angle of the Frame.
Visible (inherited from TFrame) | Gets and sets the visibility of the TFrame object.
Width (inherited from TFrame) | Gets and sets the width of the TFrame object as a percentage of its bounding rectangle.

See Also

CFrame Class | Steema.TeeChart.Styles Namespace


FrameElementPercents

Steema.TeeChart.Styles.CFrame.FrameElementPercents Property

An array defining the width of each frame member, inner, middle, outer, with that order in the array. The total should sum 100 (%).
public Double[] FrameElementPercents {get; set;}

See Also

CFrame Class | CFrame Members | Steema.TeeChart.Styles Namespace


RotationAngle

Steema.TeeChart.Styles.CFrame.RotationAngle Property

Gets and sets the angle of Frame rotation.
public Int32 RotationAngle {get; set;}

See Also

CFrame Class | CFrame Members | Steema.TeeChart.Styles Namespace


TotalAngle

Steema.TeeChart.Styles.CFrame.TotalAngle Property

Gets and sets the total display angle of the Frame.
public Int32 TotalAngle {get; set;}

See Also

CFrame Class | CFrame Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ChartErrors

Steema.TeeChart.Styles.ChartErrors Class

For a list of all members of this type, see ChartErrors Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.ChartErrorsBase
public class ChartErrors : ChartErrorsBase

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

ChartErrors members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ChartErrorsMembers

Steema.TeeChart.Styles.ChartErrors all Members

ChartErrors overview

Constructors

Constructor

Public Fields

ISeries (inherited from ChartErrorsBase)

Public Methods

DrawError (inherited from ChartErrorsBase) |
DrawZError (inherited from ChartErrorsBase) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
PreparePen (inherited from ChartErrorsBase) |

Public Properties

Bottom (inherited from ChartErrorsBase) | Gets and sets the corresponding Bottom Error value for each Point.
Chart (inherited from TeeBase) | Chart associated with this object
ErrorSizeUnits (inherited from ChartErrorsBase) | Sets ErrorSize in pixels or percentage of Pointer size.
Format | Gets and sets the corresponding Format.
Left (inherited from ChartErrorsBase) | Gets and sets the corresponding Left Error value for each Point.
Right (inherited from ChartErrorsBase) | Gets and sets the corresponding Right Error value for each Point.
SeriesColor (inherited from ChartErrorsBase) | Gets and sets a value which when true uses the error Color relative to each point. When false, the error Color is taken from the corresponding ChartPen.
Size (inherited from ChartErrorsBase) | Determines the size of the Error "T".
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top (inherited from ChartErrorsBase) | Gets and sets the corresponding Top Error value for each Point.

See Also

ChartErrors Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ChartErrors Constructor

public ChartErrors(Series AOwner)

See Also

ChartErrors Class | ChartErrors Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ChartErrorsFields

Steema.TeeChart.Styles.ChartErrors Fields

Public Fields

ISeries (inherited from ChartErrorsBase)

See Also

ChartErrors Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ChartErrorsMethods

Steema.TeeChart.Styles.ChartErrors Methods

Public Methods

DrawError (inherited from ChartErrorsBase) |
DrawZError (inherited from ChartErrorsBase) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
PreparePen (inherited from ChartErrorsBase) |

See Also

ChartErrors Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ChartErrorsProperties

Steema.TeeChart.Styles.ChartErrors Properties

Public Properties

Bottom (inherited from ChartErrorsBase) | Gets and sets the corresponding Bottom Error value for each Point.
Chart (inherited from TeeBase) | Chart associated with this object
ErrorSizeUnits (inherited from ChartErrorsBase) | Sets ErrorSize in pixels or percentage of Pointer size.
Format | Gets and sets the corresponding Format.
Left (inherited from ChartErrorsBase) | Gets and sets the corresponding Left Error value for each Point.
Right (inherited from ChartErrorsBase) | Gets and sets the corresponding Right Error value for each Point.
SeriesColor (inherited from ChartErrorsBase) | Gets and sets a value which when true uses the error Color relative to each point. When false, the error Color is taken from the corresponding ChartPen.
Size (inherited from ChartErrorsBase) | Determines the size of the Error "T".
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top (inherited from ChartErrorsBase) | Gets and sets the corresponding Top Error value for each Point.

See Also

ChartErrors Class | Steema.TeeChart.Styles Namespace


Format

Steema.TeeChart.Styles.ChartErrors.Format Property

Gets and sets the corresponding Format.
public ErrorsFormat Format {get;}

See Also

ChartErrors Class | ChartErrors Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ChartErrors3D

Steema.TeeChart.Styles.ChartErrors3D Class

For a list of all members of this type, see ChartErrors3D Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.ChartErrorsBase
public class ChartErrors3D : ChartErrorsBase

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

ChartErrors3D members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ChartErrors3DMembers

Steema.TeeChart.Styles.ChartErrors3D all Members

ChartErrors3D overview

Constructors

Constructor

Public Fields

ISeries (inherited from ChartErrorsBase)

Public Methods

DrawError (inherited from ChartErrorsBase) |
DrawZError (inherited from ChartErrorsBase) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
PreparePen (inherited from ChartErrorsBase) |

Public Properties

Back | Gets and sets the corresponding Back Error value for each Point.
Bottom (inherited from ChartErrorsBase) | Gets and sets the corresponding Bottom Error value for each Point.
Chart (inherited from TeeBase) | Chart associated with this object
ErrorSizeUnits (inherited from ChartErrorsBase) | Sets ErrorSize in pixels or percentage of Pointer size.
Format | Gets and sets the corresponding Format.
Front | Gets and sets the corresponding Front Error value for each Point.
Left (inherited from ChartErrorsBase) | Gets and sets the corresponding Left Error value for each Point.
Right (inherited from ChartErrorsBase) | Gets and sets the corresponding Right Error value for each Point.
SeriesColor (inherited from ChartErrorsBase) | Gets and sets a value which when true uses the error Color relative to each point. When false, the error Color is taken from the corresponding ChartPen.
Size (inherited from ChartErrorsBase) | Determines the size of the Error "T".
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top (inherited from ChartErrorsBase) | Gets and sets the corresponding Top Error value for each Point.

See Also

ChartErrors3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ChartErrors3D Constructor

public ChartErrors3D(Series AOwner)

See Also

ChartErrors3D Class | ChartErrors3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ChartErrors3DFields

Steema.TeeChart.Styles.ChartErrors3D Fields

Public Fields

ISeries (inherited from ChartErrorsBase)

See Also

ChartErrors3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ChartErrors3DMethods

Steema.TeeChart.Styles.ChartErrors3D Methods

Public Methods

DrawError (inherited from ChartErrorsBase) |
DrawZError (inherited from ChartErrorsBase) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
PreparePen (inherited from ChartErrorsBase) |

See Also

ChartErrors3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ChartErrors3DProperties

Steema.TeeChart.Styles.ChartErrors3D Properties

Public Properties

Back | Gets and sets the corresponding Back Error value for each Point.
Bottom (inherited from ChartErrorsBase) | Gets and sets the corresponding Bottom Error value for each Point.
Chart (inherited from TeeBase) | Chart associated with this object
ErrorSizeUnits (inherited from ChartErrorsBase) | Sets ErrorSize in pixels or percentage of Pointer size.
Format | Gets and sets the corresponding Format.
Front | Gets and sets the corresponding Front Error value for each Point.
Left (inherited from ChartErrorsBase) | Gets and sets the corresponding Left Error value for each Point.
Right (inherited from ChartErrorsBase) | Gets and sets the corresponding Right Error value for each Point.
SeriesColor (inherited from ChartErrorsBase) | Gets and sets a value which when true uses the error Color relative to each point. When false, the error Color is taken from the corresponding ChartPen.
Size (inherited from ChartErrorsBase) | Determines the size of the Error "T".
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top (inherited from ChartErrorsBase) | Gets and sets the corresponding Top Error value for each Point.

See Also

ChartErrors3D Class | Steema.TeeChart.Styles Namespace


Back

Steema.TeeChart.Styles.ChartErrors3D.Back Property

Gets and sets the corresponding Back Error value for each Point.
public ValueList Back {get;}

See Also

ChartErrors3D Class | ChartErrors3D Members | Steema.TeeChart.Styles Namespace


Format

Steema.TeeChart.Styles.ChartErrors3D.Format Property

Gets and sets the corresponding Format.
public ErrorsFormat3D Format {get;}

See Also

ChartErrors3D Class | ChartErrors3D Members | Steema.TeeChart.Styles Namespace


Front

Steema.TeeChart.Styles.ChartErrors3D.Front Property

Gets and sets the corresponding Front Error value for each Point.
public ValueList Front {get;}

See Also

ChartErrors3D Class | ChartErrors3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ChartErrorsBase

Steema.TeeChart.Styles.ChartErrorsBase Class

For a list of all members of this type, see ChartErrorsBase Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public abstract class ChartErrorsBase : TeeBase

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

ChartErrorsBase members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ChartErrorsBaseMembers

Steema.TeeChart.Styles.ChartErrorsBase all Members

ChartErrorsBase overview

Constructors

Constructor

Public Fields

ISeries

Public Methods

DrawError |
DrawZError |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
PreparePen |

Public Properties

Bottom | Gets and sets the corresponding Bottom Error value for each Point.
Chart (inherited from TeeBase) | Chart associated with this object
ErrorSizeUnits | Sets ErrorSize in pixels or percentage of Pointer size.
Left | Gets and sets the corresponding Left Error value for each Point.
Right | Gets and sets the corresponding Right Error value for each Point.
SeriesColor | Gets and sets a value which when true uses the error Color relative to each point. When false, the error Color is taken from the corresponding ChartPen.
Size | Determines the size of the Error "T".
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top | Gets and sets the corresponding Top Error value for each Point.

See Also

ChartErrorsBase Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ChartErrorsBase Constructor

public ChartErrorsBase(Series AOwner)

See Also

ChartErrorsBase Class | ChartErrorsBase Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ChartErrorsBaseFields

Steema.TeeChart.Styles.ChartErrorsBase Fields

Public Fields

ISeries

See Also

ChartErrorsBase Class | Steema.TeeChart.Styles Namespace


ISeries

Steema.TeeChart.Styles.ChartErrorsBase.ISeries Field

public Series ISeries

See Also

ChartErrorsBase Class | ChartErrorsBase Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ChartErrorsBaseMethods

Steema.TeeChart.Styles.ChartErrorsBase Methods

Public Methods

DrawError |
DrawZError |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
PreparePen |

See Also

ChartErrorsBase Class | Steema.TeeChart.Styles Namespace


DrawError

Steema.TeeChart.Styles.ChartErrorsBase.DrawError Method

public Void DrawError(Int32 X,
     Int32 Y,
     Int32 ALength,
     Int32 HalfSize,
     Int32 AZ,
     Boolean IsHoriz)

See Also

ChartErrorsBase Class | ChartErrorsBase Members | Steema.TeeChart.Styles Namespace


DrawZError

Steema.TeeChart.Styles.ChartErrorsBase.DrawZError Method

public Void DrawZError(Int32 X,
     Int32 Y,
     Int32 Z,
     Int32 ALength,
     Int32 HalfSize)

See Also

ChartErrorsBase Class | ChartErrorsBase Members | Steema.TeeChart.Styles Namespace


PreparePen

Steema.TeeChart.Styles.ChartErrorsBase.PreparePen Method

public Void PreparePen(Int32 ValueIndex,
     ChartPen ErrorPen)

See Also

ChartErrorsBase Class | ChartErrorsBase Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ChartErrorsBaseProperties

Steema.TeeChart.Styles.ChartErrorsBase Properties

Public Properties

Bottom | Gets and sets the corresponding Bottom Error value for each Point.
Chart (inherited from TeeBase) | Chart associated with this object
ErrorSizeUnits | Sets ErrorSize in pixels or percentage of Pointer size.
Left | Gets and sets the corresponding Left Error value for each Point.
Right | Gets and sets the corresponding Right Error value for each Point.
SeriesColor | Gets and sets a value which when true uses the error Color relative to each point. When false, the error Color is taken from the corresponding ChartPen.
Size | Determines the size of the Error "T".
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top | Gets and sets the corresponding Top Error value for each Point.

See Also

ChartErrorsBase Class | Steema.TeeChart.Styles Namespace


Bottom

Steema.TeeChart.Styles.ChartErrorsBase.Bottom Property

Gets and sets the corresponding Bottom Error value for each Point.
public ValueList Bottom {get;}

See Also

ChartErrorsBase Class | ChartErrorsBase Members | Steema.TeeChart.Styles Namespace


ErrorSizeUnits

Steema.TeeChart.Styles.ChartErrorsBase.ErrorSizeUnits Property

Sets ErrorSize in pixels or percentage of Pointer size.
public ErrorWidthUnits ErrorSizeUnits {get; set;}

See Also

ChartErrorsBase Class | ChartErrorsBase Members | Steema.TeeChart.Styles Namespace


Left

Steema.TeeChart.Styles.ChartErrorsBase.Left Property

Gets and sets the corresponding Left Error value for each Point.
public ValueList Left {get;}

See Also

ChartErrorsBase Class | ChartErrorsBase Members | Steema.TeeChart.Styles Namespace


Right

Steema.TeeChart.Styles.ChartErrorsBase.Right Property

Gets and sets the corresponding Right Error value for each Point.
public ValueList Right {get;}

See Also

ChartErrorsBase Class | ChartErrorsBase Members | Steema.TeeChart.Styles Namespace


SeriesColor

Steema.TeeChart.Styles.ChartErrorsBase.SeriesColor Property

Gets and sets a value which when true uses the error Color relative to each point. When false, the error Color is taken from the corresponding ChartPen.
public Boolean SeriesColor {get; set;}

See Also

ChartErrorsBase Class | ChartErrorsBase Members | Steema.TeeChart.Styles Namespace


Size

Steema.TeeChart.Styles.ChartErrorsBase.Size Property

Determines the size of the Error "T".
public Int32 Size {get; set;}

See Also

ChartErrorsBase Class | ChartErrorsBase Members | Steema.TeeChart.Styles Namespace


Top

Steema.TeeChart.Styles.ChartErrorsBase.Top Property

Gets and sets the corresponding Top Error value for each Point.
public ValueList Top {get;}

See Also

ChartErrorsBase Class | ChartErrorsBase Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Circular

Steema.TeeChart.Styles.Circular Class

Circled Series.

For a list of all members of this type, see Circular Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class Circular : Series , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Circular members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CircularMembers

Steema.TeeChart.Styles.Circular all Members

Circular overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
PiDegree | Represents the constant pi / 180.
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointToAngle | Returns the angle from the XY point parameter to the circle center.
PointToRadius | Returns the radius from XY point to the circle center.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor | Determines the color to fill the ellipse.
Circled | Sets CirleSeries as elliptical or circular.
CircleGradient | Determines the Gradient which fills the ellipse.
CircleHeight | Returns the height of the bounding Circle.
CircleRect | Returns the rectangle that bounds the circle.
CircleWidth | Returns the width of the bounding Circle.
CircleXCenter | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter | Returns the exact vertical position of the ellipse's center in pixels.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius | Sets ellipse's horizontal radius in pixels.
CustomYRadius | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RotationAngle | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
UniqueCustomRadius | Sets all the CirleSeries in a chart to use the same radius or independent.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Circular Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Circular Constructor

Overload List

public Circular()
public Circular(Steema.TeeChart.Chart)

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Circular Constructor

public Circular(Chart c)

See Also

Circular Constructor Overload List | Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Circular Constructor

public Circular()

See Also

Circular Constructor Overload List | Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CircularEvents

Steema.TeeChart.Styles.Circular Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Circular Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CircularFields

Steema.TeeChart.Styles.Circular Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
PiDegree | Represents the constant pi / 180.
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Circular Class | Steema.TeeChart.Styles Namespace


PiDegree

Steema.TeeChart.Styles.Circular.PiDegree Field

Represents the constant pi / 180.
public const Double PiDegree

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CircularMethods

Steema.TeeChart.Styles.Circular Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointToAngle | Returns the angle from the XY point parameter to the circle center.
PointToRadius | Returns the radius from XY point to the circle center.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Circular Class | Steema.TeeChart.Styles Namespace


AngleToPos

Steema.TeeChart.Styles.Circular.AngleToPos Method

Returns the exact Screen position for a given pair of Angle and Radius values.
public abstract Void AngleToPos(Double angle,
     Double aXRadius,
     Double aYRadius,
     Int32& x,
     Int32& y)

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.Circular.AssignFormat Method

Overload List

public override Void AssignFormat(Steema.TeeChart.Styles.Series, Steema.TeeChart.Styles.Series)

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.Circular.AssignFormat Method

public override Void AssignFormat(Series source,
     Series target)

See Also

AssignFormat Overload List | Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Circular.Clicked Method

Overload List

public override Int32 Clicked(System.Int32, System.Int32)

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Circular.Clicked Method

public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


PointToAngle

Steema.TeeChart.Styles.Circular.PointToAngle Method

Returns the angle from the XY point parameter to the circle center.
public Double PointToAngle(Int32 x,
     Int32 y)

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


PointToRadius

Steema.TeeChart.Styles.Circular.PointToRadius Method

Returns the radius from XY point to the circle center.
public Double PointToRadius(Int32 x,
     Int32 y)

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


Rotate

Steema.TeeChart.Styles.Circular.Rotate Method

Returns the angle by which the Chart is rotated.
public Void Rotate(Int32 angle)

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CircularProperties

Steema.TeeChart.Styles.Circular Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor | Determines the color to fill the ellipse.
Circled | Sets CirleSeries as elliptical or circular.
CircleGradient | Determines the Gradient which fills the ellipse.
CircleHeight | Returns the height of the bounding Circle.
CircleRect | Returns the rectangle that bounds the circle.
CircleWidth | Returns the width of the bounding Circle.
CircleXCenter | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter | Returns the exact vertical position of the ellipse's center in pixels.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius | Sets ellipse's horizontal radius in pixels.
CustomYRadius | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RotationAngle | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
UniqueCustomRadius | Sets all the CirleSeries in a chart to use the same radius or independent.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Circular Class | Steema.TeeChart.Styles Namespace


CircleBackColor

Steema.TeeChart.Styles.Circular.CircleBackColor Property

Determines the color to fill the ellipse.
public Color CircleBackColor {get; set;}

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


Circled

Steema.TeeChart.Styles.Circular.Circled Property

Sets CirleSeries as elliptical or circular.
public Boolean Circled {get; set;}

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


CircleGradient

Steema.TeeChart.Styles.Circular.CircleGradient Property

Determines the Gradient which fills the ellipse.
public Gradient CircleGradient {get; set;}

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


CircleHeight

Steema.TeeChart.Styles.Circular.CircleHeight Property

Returns the height of the bounding Circle.
public Int32 CircleHeight {get;}

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


CircleRect

Steema.TeeChart.Styles.Circular.CircleRect Property

Returns the rectangle that bounds the circle.
public Rectangle CircleRect {get;}

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


CircleWidth

Steema.TeeChart.Styles.Circular.CircleWidth Property

Returns the width of the bounding Circle.
public Int32 CircleWidth {get;}

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


CircleXCenter

Steema.TeeChart.Styles.Circular.CircleXCenter Property

Returns the exact horizontal position of ellipse's center in pixels.
public Int32 CircleXCenter {get;}

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


CircleYCenter

Steema.TeeChart.Styles.Circular.CircleYCenter Property

Returns the exact vertical position of the ellipse's center in pixels.
public Int32 CircleYCenter {get;}

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


CustomXRadius

Steema.TeeChart.Styles.Circular.CustomXRadius Property

Sets ellipse's horizontal radius in pixels.
public Int32 CustomXRadius {get; set;}

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


CustomYRadius

Steema.TeeChart.Styles.Circular.CustomYRadius Property

Sets ellipse's vertical radius in pixels.
public Int32 CustomYRadius {get; set;}

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


RotationAngle

Steema.TeeChart.Styles.Circular.RotationAngle Property

Sets angle of Chart rotation.
public Int32 RotationAngle {get; set;}

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


UniqueCustomRadius

Steema.TeeChart.Styles.Circular.UniqueCustomRadius Property

Sets all the CirleSeries in a chart to use the same radius or independent.
public Boolean UniqueCustomRadius {get; set;}

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


XRadius

Steema.TeeChart.Styles.Circular.XRadius Property

Returns the exact horizontal size of the ellipse's radius in pixels.
public Int32 XRadius {get;}

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


YRadius

Steema.TeeChart.Styles.Circular.YRadius Property

Returns the exact vertical size of the ellipse's radius in pixels.
public Int32 YRadius {get;}

See Also

Circular Class | Circular Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CircularGauge

Steema.TeeChart.Styles.CircularGauge Class

CircularGauge Series.

For a list of all members of this type, see CircularGauge Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
public class CircularGauge : Circular , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

CircularGauge members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CircularGaugeMembers

Steema.TeeChart.Styles.CircularGauge all Members

CircularGauge overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawHand |
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.
ValueChanged | Called when the Gauge Value property is changed.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Circular) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Circular) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoPositionLinearGauge | Gets and sets the automatic positioning of the embedded LinearGauge.
AutoPositionNumericGauge | Gets and sets the automatic positioning of the embedded NumericGauge.
AutoValueLinearGauge | Gets and sets the whether or not the embedded LinearGauge displays the same value as the CircularGauge.
AutoValueNumericGauge | Gets and sets the whether or not the embedded NumericGauge displays the same value as the CircularGauge.
Axis | Gets the CircularGauges's Axis characteristics.
Center | Returns a sub-object with properties that control the appearance of a shape at the middle of gauge.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorLineEndValues | Gets or sets a collection of EndValues which initially contains the RedLineEndValue and the GreenLineEndValue.
ColorLines | Gets or sets a collection of ColorLines which initially contains the RedLine and the GreenLine.
ColorLineStartValues | Gets or sets a collection of StartValues which initially contains the RedLineStartValue and the GreenLineStartValue.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBounds | Gets or sets a custom bounding rectangle for the gauge.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
DisplayRotationAngle | Gets and sets the angle of Frame rotation.
DisplayTotalAngle | Gets and sets the total display angle of the Frame.
EndPoint | Returns a sub-object with properties that control the appearance of a shape at the end of the gauge arrow.
EndZ (inherited from Series) | For internal use.
FaceBrush | ChartBrush characteristics of the CircularGauge's face.
FillToSemiCircle | Gets or sets whether or not a semi-circular GaugeSeries is filled.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Frame | The Frame is the object which surrounds the CircularGauge and which consists of three configurable Bands: Inner, Middle and Outer.
Function (inherited from Series) | Function object to calculate values.
GaugeColorPalette | Gets and sets the CircularGauge's color palette.
GreenLine | The 'greenline' object is the curved shape with a gradient which is used to signal a low or minimum value.
GreenLineEndValue | Gets and sets the value at which the 'redline' marker ends.
GreenLineStartValue | Gets and sets the value at which the 'redline' marker starts.
Hand | Gets and sets the Hand (or needle) object characteristics.
HandDistance | Gets and sets the distance between the center of the hand and its head as a percentage of the total distance.
HandOffset | Gets and sets the distance between the center of the hand and its tail as a percentage of the total distance.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsInside | Defines where to display gauge axis labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinearGauge | Gets and sets properties of an embedded LinearGauge. Set Visible to true to visualize.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
Maximum | Gets or sets the maximum value for the gauge.
MiddleZ (inherited from Series) | For internal use.
Minimum | Gets or sets the minimum value for the gauge.
MinorTickDistance | The distance between the minor ticks and the CircularGauge curved axis.
MinorTicks | Gets and sets the characteristics of the Axis' minor tick marks.
NumericGauge | Gets and sets properties of an embedded NumericGauge. Set Visible to true to visualize.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedLine | The 'redline' object is the curved shape with a gradient which is used to signal a high or maximum value.
RedLineEndValue | Gets and sets the value at which the 'redline' marker ends.
RedLineStartValue | Gets and sets the value at which the 'redline' marker starts.
RotateLabels | When true, labels are rotated so to appear parallel to the curved CircularGauge axis.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Ticks | Gets and sets the characteristics of the Axis' major tick marks.
Title (inherited from Series) | Series description to show in Legend and editors.
TotalAngle | Controls the size in degrees for the gauge axis.
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
Value | Gets or sets the position of gauge arrow line.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

CircularGauge Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CircularGauge Constructor

Overload List

public CircularGauge()
public CircularGauge(Steema.TeeChart.Chart)

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CircularGauge Constructor

public CircularGauge(Chart c)

See Also

CircularGauge Constructor Overload List | CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CircularGauge Constructor

public CircularGauge()

See Also

CircularGauge Constructor Overload List | CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CircularGaugeEvents

Steema.TeeChart.Styles.CircularGauge Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawHand |
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.
ValueChanged | Called when the Gauge Value property is changed.

See Also

CircularGauge Class | Steema.TeeChart.Styles Namespace


BeforeDrawHand

Steema.TeeChart.Styles.CircularGauge.BeforeDrawHand Event

public PaintChartEventHandler  BeforeDrawHand

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


ValueChanged

Steema.TeeChart.Styles.CircularGauge.ValueChanged Event

Called when the Gauge Value property is changed.
public GaugesChangeHandler  ValueChanged

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CircularGaugeFields

Steema.TeeChart.Styles.CircularGauge Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

CircularGauge Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CircularGaugeMethods

Steema.TeeChart.Styles.CircularGauge Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Circular) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Circular) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

CircularGauge Class | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.CircularGauge.Draw Method

public override Void Draw()

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.CircularGauge.PrepareForGallery Method

public override Void PrepareForGallery(Boolean isEnabled)

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CircularGaugeProperties

Steema.TeeChart.Styles.CircularGauge Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoPositionLinearGauge | Gets and sets the automatic positioning of the embedded LinearGauge.
AutoPositionNumericGauge | Gets and sets the automatic positioning of the embedded NumericGauge.
AutoValueLinearGauge | Gets and sets the whether or not the embedded LinearGauge displays the same value as the CircularGauge.
AutoValueNumericGauge | Gets and sets the whether or not the embedded NumericGauge displays the same value as the CircularGauge.
Axis | Gets the CircularGauges's Axis characteristics.
Center | Returns a sub-object with properties that control the appearance of a shape at the middle of gauge.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorLineEndValues | Gets or sets a collection of EndValues which initially contains the RedLineEndValue and the GreenLineEndValue.
ColorLines | Gets or sets a collection of ColorLines which initially contains the RedLine and the GreenLine.
ColorLineStartValues | Gets or sets a collection of StartValues which initially contains the RedLineStartValue and the GreenLineStartValue.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBounds | Gets or sets a custom bounding rectangle for the gauge.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
DisplayRotationAngle | Gets and sets the angle of Frame rotation.
DisplayTotalAngle | Gets and sets the total display angle of the Frame.
EndPoint | Returns a sub-object with properties that control the appearance of a shape at the end of the gauge arrow.
EndZ (inherited from Series) | For internal use.
FaceBrush | ChartBrush characteristics of the CircularGauge's face.
FillToSemiCircle | Gets or sets whether or not a semi-circular GaugeSeries is filled.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Frame | The Frame is the object which surrounds the CircularGauge and which consists of three configurable Bands: Inner, Middle and Outer.
Function (inherited from Series) | Function object to calculate values.
GaugeColorPalette | Gets and sets the CircularGauge's color palette.
GreenLine | The 'greenline' object is the curved shape with a gradient which is used to signal a low or minimum value.
GreenLineEndValue | Gets and sets the value at which the 'redline' marker ends.
GreenLineStartValue | Gets and sets the value at which the 'redline' marker starts.
Hand | Gets and sets the Hand (or needle) object characteristics.
HandDistance | Gets and sets the distance between the center of the hand and its head as a percentage of the total distance.
HandOffset | Gets and sets the distance between the center of the hand and its tail as a percentage of the total distance.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsInside | Defines where to display gauge axis labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinearGauge | Gets and sets properties of an embedded LinearGauge. Set Visible to true to visualize.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
Maximum | Gets or sets the maximum value for the gauge.
MiddleZ (inherited from Series) | For internal use.
Minimum | Gets or sets the minimum value for the gauge.
MinorTickDistance | The distance between the minor ticks and the CircularGauge curved axis.
MinorTicks | Gets and sets the characteristics of the Axis' minor tick marks.
NumericGauge | Gets and sets properties of an embedded NumericGauge. Set Visible to true to visualize.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedLine | The 'redline' object is the curved shape with a gradient which is used to signal a high or maximum value.
RedLineEndValue | Gets and sets the value at which the 'redline' marker ends.
RedLineStartValue | Gets and sets the value at which the 'redline' marker starts.
RotateLabels | When true, labels are rotated so to appear parallel to the curved CircularGauge axis.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Ticks | Gets and sets the characteristics of the Axis' major tick marks.
Title (inherited from Series) | Series description to show in Legend and editors.
TotalAngle | Controls the size in degrees for the gauge axis.
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
Value | Gets or sets the position of gauge arrow line.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

CircularGauge Class | Steema.TeeChart.Styles Namespace


AutoPositionLinearGauge

Steema.TeeChart.Styles.CircularGauge.AutoPositionLinearGauge Property

Gets and sets the automatic positioning of the embedded LinearGauge.
public Boolean AutoPositionLinearGauge {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


AutoPositionNumericGauge

Steema.TeeChart.Styles.CircularGauge.AutoPositionNumericGauge Property

Gets and sets the automatic positioning of the embedded NumericGauge.
public Boolean AutoPositionNumericGauge {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


AutoValueLinearGauge

Steema.TeeChart.Styles.CircularGauge.AutoValueLinearGauge Property

Gets and sets the whether or not the embedded LinearGauge displays the same value as the CircularGauge.
public Boolean AutoValueLinearGauge {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


AutoValueNumericGauge

Steema.TeeChart.Styles.CircularGauge.AutoValueNumericGauge Property

Gets and sets the whether or not the embedded NumericGauge displays the same value as the CircularGauge.
public Boolean AutoValueNumericGauge {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


Axis

Steema.TeeChart.Styles.CircularGauge.Axis Property

Gets the CircularGauges's Axis characteristics.
public Axis Axis {get;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


Center

Steema.TeeChart.Styles.CircularGauge.Center Property

Returns a sub-object with properties that control the appearance of a shape at the middle of gauge.
public GaugeSeriesPointer Center {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


ColorLineEndValues

Steema.TeeChart.Styles.CircularGauge.ColorLineEndValues Property

Gets or sets a collection of EndValues which initially contains the RedLineEndValue and the GreenLineEndValue.
public ColorLineEndValues ColorLineEndValues {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


ColorLines

Steema.TeeChart.Styles.CircularGauge.ColorLines Property

Gets or sets a collection of ColorLines which initially contains the RedLine and the GreenLine.
public ColorLineCollection ColorLines {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


ColorLineStartValues

Steema.TeeChart.Styles.CircularGauge.ColorLineStartValues Property

Gets or sets a collection of StartValues which initially contains the RedLineStartValue and the GreenLineStartValue.
public ColorLineStartValues ColorLineStartValues {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


CustomBounds

Steema.TeeChart.Styles.CircularGauge.CustomBounds Property

Gets or sets a custom bounding rectangle for the gauge.
public Rectangle CustomBounds {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.CircularGauge.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


DisplayRotationAngle

Steema.TeeChart.Styles.CircularGauge.DisplayRotationAngle Property

Gets and sets the angle of Frame rotation.
public Int32 DisplayRotationAngle {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


DisplayTotalAngle

Steema.TeeChart.Styles.CircularGauge.DisplayTotalAngle Property

Gets and sets the total display angle of the Frame.
public Int32 DisplayTotalAngle {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


EndPoint

Steema.TeeChart.Styles.CircularGauge.EndPoint Property

Returns a sub-object with properties that control the appearance of a shape at the end of the gauge arrow.
public SeriesPointer EndPoint {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


FaceBrush

Steema.TeeChart.Styles.CircularGauge.FaceBrush Property

ChartBrush characteristics of the CircularGauge's face.
public ChartBrush FaceBrush {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


FillToSemiCircle

Steema.TeeChart.Styles.CircularGauge.FillToSemiCircle Property

Gets or sets whether or not a semi-circular GaugeSeries is filled.
public Boolean FillToSemiCircle {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


Frame

Steema.TeeChart.Styles.CircularGauge.Frame Property

The Frame is the object which surrounds the CircularGauge and which consists of three configurable Bands: Inner, Middle and Outer.
public CFrame Frame {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


GaugeColorPalette

Steema.TeeChart.Styles.CircularGauge.GaugeColorPalette Property

Gets and sets the CircularGauge's color palette.
public Color[] GaugeColorPalette {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


GreenLine

Steema.TeeChart.Styles.CircularGauge.GreenLine Property

The 'greenline' object is the curved shape with a gradient which is used to signal a low or minimum value.
public GaugeSeriesPointer GreenLine {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


GreenLineEndValue

Steema.TeeChart.Styles.CircularGauge.GreenLineEndValue Property

Gets and sets the value at which the 'redline' marker ends.
public Double GreenLineEndValue {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


GreenLineStartValue

Steema.TeeChart.Styles.CircularGauge.GreenLineStartValue Property

Gets and sets the value at which the 'redline' marker starts.
public Double GreenLineStartValue {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


Hand

Steema.TeeChart.Styles.CircularGauge.Hand Property

Gets and sets the Hand (or needle) object characteristics.
public GaugeSeriesPointer Hand {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


HandDistance

Steema.TeeChart.Styles.CircularGauge.HandDistance Property

Gets and sets the distance between the center of the hand and its head as a percentage of the total distance.
public Int32 HandDistance {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


HandOffset

Steema.TeeChart.Styles.CircularGauge.HandOffset Property

Gets and sets the distance between the center of the hand and its tail as a percentage of the total distance.
public Int32 HandOffset {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


LabelsInside

Steema.TeeChart.Styles.CircularGauge.LabelsInside Property

Defines where to display gauge axis labels.
public Boolean LabelsInside {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


LinearGauge

Steema.TeeChart.Styles.CircularGauge.LinearGauge Property

Gets and sets properties of an embedded LinearGauge. Set Visible to true to visualize.
public LinearGauge LinearGauge {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


Maximum

Steema.TeeChart.Styles.CircularGauge.Maximum Property

Gets or sets the maximum value for the gauge.
public Double Maximum {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


Minimum

Steema.TeeChart.Styles.CircularGauge.Minimum Property

Gets or sets the minimum value for the gauge.
public Double Minimum {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


MinorTickDistance

Steema.TeeChart.Styles.CircularGauge.MinorTickDistance Property

The distance between the minor ticks and the CircularGauge curved axis.
public Int32 MinorTickDistance {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


MinorTicks

Steema.TeeChart.Styles.CircularGauge.MinorTicks Property

Gets and sets the characteristics of the Axis' minor tick marks.
public GaugeSeriesPointer MinorTicks {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


NumericGauge

Steema.TeeChart.Styles.CircularGauge.NumericGauge Property

Gets and sets properties of an embedded NumericGauge. Set Visible to true to visualize.
public NumericGauge NumericGauge {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


RedLine

Steema.TeeChart.Styles.CircularGauge.RedLine Property

The 'redline' object is the curved shape with a gradient which is used to signal a high or maximum value.
public GaugeSeriesPointer RedLine {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


RedLineEndValue

Steema.TeeChart.Styles.CircularGauge.RedLineEndValue Property

Gets and sets the value at which the 'redline' marker ends.
public Double RedLineEndValue {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


RedLineStartValue

Steema.TeeChart.Styles.CircularGauge.RedLineStartValue Property

Gets and sets the value at which the 'redline' marker starts.
public Double RedLineStartValue {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


RotateLabels

Steema.TeeChart.Styles.CircularGauge.RotateLabels Property

When true, labels are rotated so to appear parallel to the curved CircularGauge axis.
public Boolean RotateLabels {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


Ticks

Steema.TeeChart.Styles.CircularGauge.Ticks Property

Gets and sets the characteristics of the Axis' major tick marks.
public GaugeSeriesPointer Ticks {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


TotalAngle

Steema.TeeChart.Styles.CircularGauge.TotalAngle Property

Controls the size in degrees for the gauge axis.
public Double TotalAngle {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


Value

Steema.TeeChart.Styles.CircularGauge.Value Property

Gets or sets the position of gauge arrow line.
public Double Value {get; set;}

See Also

CircularGauge Class | CircularGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Clock

Steema.TeeChart.Styles.Clock Class

Clock Series.

For a list of all members of this type, see Clock Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
Steema.TeeChart.Styles.CustomPolar
Steema.TeeChart.Styles.Custom2DPolar
public class Clock : Custom2DPolar , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Clock members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ClockMembers

Steema.TeeChart.Styles.Clock all Members

Clock overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle (inherited from CustomPolar) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from CustomPolar) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPolar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPolar) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPolar) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPolar) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawRing (inherited from CustomPolar) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomPolar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
DrawZone (inherited from CustomPolar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom2DPolar) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
OnGetPointerStyle (inherited from CustomPolar) |
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery (inherited from Custom2DPolar) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AngleIncrement (inherited from CustomPolar) | Sets angle in degrees used to draw the dividing grid lines in anti-clockwise direction.
AngleValues (inherited from CustomPolar) | Gets list of angle values for each polar point.
Brush (inherited from CustomPolar) | Sets Polar Back Brush.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleLabels (inherited from CustomPolar) | Sets CicleLabel properties.
CircleLabelsFont (inherited from CustomPolar) |
CircleLabelsInside (inherited from CustomPolar) | Enables/disables the display of the axis labels inside the circle area.
CircleLabelsRotated (inherited from CustomPolar) | When true rotates the labels of a circular TeeChart series at an angle in line with the Radar/Polar circle at each Label point.
CirclePen (inherited from CustomPolar) | Determines the pen used to draw the outmost circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
ClockWiseLabels (inherited from CustomPolar) | Displays of the circle labels in a clockwise direction.
CloseCircle (inherited from CustomPolar) | Draws a Line between the last and first PolarSeries point coordinates.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Font (inherited from CustomPolar) | Sets the label font.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsMargin (inherited from CustomPolar) | Defines the distance between the CustomPolar circle and the labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen (inherited from CustomPolar) | Determines Pen used to draw the Line connecting PolarSeries points.
PenHours | Sets the Pen for the Clock's hour hand.
PenMinutes | Sets the Pen for the Clock's minute hand.
PenSeconds | Sets the Pen for the Clock's second hand.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPolar) | Pointer contains several properties to control the formatting attributes of Points like Pen, Brush, Draw3D, Visible, etc.
RadiusIncrement (inherited from CustomPolar) | Determines the increment used to draw the ring grid lines.
RadiusValues (inherited from CustomPolar) | Gets list of radius values for each polar point.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Style | Sets the style of the clock figures, Roman or Decimal.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Timer |
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from CustomPolar) | Sets Transparency level from 0 to 100%.
TreatNaNAsNull (inherited from CustomPolar) |
TreatNulls (inherited from CustomPolar) |
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Clock Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Clock Constructor

Overload List

public Clock()
public Clock(Steema.TeeChart.Chart)

See Also

Clock Class | Clock Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Clock Constructor

public Clock(Chart c)

See Also

Clock Constructor Overload List | Clock Class | Clock Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Clock Constructor

public Clock()

See Also

Clock Constructor Overload List | Clock Class | Clock Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ClockEvents

Steema.TeeChart.Styles.Clock Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle (inherited from CustomPolar) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Clock Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ClockFields

Steema.TeeChart.Styles.Clock Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Clock Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ClockMethods

Steema.TeeChart.Styles.Clock Methods

Public Methods

Add (inherited from CustomPolar) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPolar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPolar) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPolar) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPolar) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawRing (inherited from CustomPolar) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomPolar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
DrawZone (inherited from CustomPolar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom2DPolar) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
OnGetPointerStyle (inherited from CustomPolar) |
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery (inherited from Custom2DPolar) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Clock Class | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.Clock.Draw Method

public override Void Draw()

See Also

Clock Class | Clock Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ClockProperties

Steema.TeeChart.Styles.Clock Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AngleIncrement (inherited from CustomPolar) | Sets angle in degrees used to draw the dividing grid lines in anti-clockwise direction.
AngleValues (inherited from CustomPolar) | Gets list of angle values for each polar point.
Brush (inherited from CustomPolar) | Sets Polar Back Brush.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleLabels (inherited from CustomPolar) | Sets CicleLabel properties.
CircleLabelsFont (inherited from CustomPolar) |
CircleLabelsInside (inherited from CustomPolar) | Enables/disables the display of the axis labels inside the circle area.
CircleLabelsRotated (inherited from CustomPolar) | When true rotates the labels of a circular TeeChart series at an angle in line with the Radar/Polar circle at each Label point.
CirclePen (inherited from CustomPolar) | Determines the pen used to draw the outmost circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
ClockWiseLabels (inherited from CustomPolar) | Displays of the circle labels in a clockwise direction.
CloseCircle (inherited from CustomPolar) | Draws a Line between the last and first PolarSeries point coordinates.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Font (inherited from CustomPolar) | Sets the label font.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsMargin (inherited from CustomPolar) | Defines the distance between the CustomPolar circle and the labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen (inherited from CustomPolar) | Determines Pen used to draw the Line connecting PolarSeries points.
PenHours | Sets the Pen for the Clock's hour hand.
PenMinutes | Sets the Pen for the Clock's minute hand.
PenSeconds | Sets the Pen for the Clock's second hand.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPolar) | Pointer contains several properties to control the formatting attributes of Points like Pen, Brush, Draw3D, Visible, etc.
RadiusIncrement (inherited from CustomPolar) | Determines the increment used to draw the ring grid lines.
RadiusValues (inherited from CustomPolar) | Gets list of radius values for each polar point.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Style | Sets the style of the clock figures, Roman or Decimal.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Timer |
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from CustomPolar) | Sets Transparency level from 0 to 100%.
TreatNaNAsNull (inherited from CustomPolar) |
TreatNulls (inherited from CustomPolar) |
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Clock Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Clock.Description Property

public override String Description {get;}

See Also

Clock Class | Clock Members | Steema.TeeChart.Styles Namespace


PenHours

Steema.TeeChart.Styles.Clock.PenHours Property

Sets the Pen for the Clock's hour hand.
public ChartPen PenHours {get;}

See Also

Clock Class | Clock Members | Steema.TeeChart.Styles Namespace


PenMinutes

Steema.TeeChart.Styles.Clock.PenMinutes Property

Sets the Pen for the Clock's minute hand.
public ChartPen PenMinutes {get;}

See Also

Clock Class | Clock Members | Steema.TeeChart.Styles Namespace


PenSeconds

Steema.TeeChart.Styles.Clock.PenSeconds Property

Sets the Pen for the Clock's second hand.
public ChartPen PenSeconds {get;}

See Also

Clock Class | Clock Members | Steema.TeeChart.Styles Namespace


Style

Steema.TeeChart.Styles.Clock.Style Property

Sets the style of the clock figures, Roman or Decimal.
public ClockStyles Style {get; set;}

See Also

Clock Class | Clock Members | Steema.TeeChart.Styles Namespace


Timer

Steema.TeeChart.Styles.Clock.Timer Property

public Timer Timer {get;}

See Also

Clock Class | Clock Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ClockStyles

Steema.TeeChart.Styles.ClockStyles Enum

Describes the possible values of the Style property.
[Serializable]
public sealed enum ClockStyles : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
Decimal | Defines clock figures as Decimal numerals.
Roman | Defines clock figures as Roman numerals.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorGrid

Steema.TeeChart.Styles.ColorGrid Class

The ColorGrid series displays a grid of color cells.

For a list of all members of this type, see ColorGrid Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
Steema.TeeChart.Styles.Custom3DGrid
public class ColorGrid : Custom3DGrid , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

ColorGrid members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorGridMembers

Steema.TeeChart.Styles.ColorGrid all Members

ColorGrid overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
GetYValue (inherited from Custom3DGrid) | Occurs when the Surface Series needs to recreate the grid of values.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
ReuseGridIndex (inherited from Custom3DGrid) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Custom3D) | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos |
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos |
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CellBounds |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Custom3DGrid) | Deletes all Series values.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
CreateValues (inherited from Custom3DGrid) | Makes a Surface grid of NumX by NumZ dimensions.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillGridIndex (inherited from Custom3DGrid) |
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Custom3DPalette) | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue |
MinXValue |
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue |
PrepareForGallery (inherited from Custom3DPalette) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Bitmap | Use this property to display a bitmap within a ColorGrid.
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
CenteredPoints |
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IrregularGrid (inherited from Custom3DGrid) | Determine if X and Z values are equi-distant or not.
Item (inherited from Custom3DGrid) | A two dimension array property for the easy access to series cell values.
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
NumXValues (inherited from Custom3DGrid) | Determines the Surface's horizontal size in number of points.
NumZValues (inherited from Custom3DGrid) | Determines the Surface's depth size in number of points.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XStep |
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZStep |
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

ColorGrid Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorGrid Constructor

Overload List

public ColorGrid(Steema.TeeChart.Chart)
public ColorGrid()

See Also

ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorGrid Constructor

public ColorGrid()

See Also

ColorGrid Constructor Overload List | ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorGrid Constructor

public ColorGrid(Chart c)

See Also

ColorGrid Constructor Overload List | ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorGridEvents

Steema.TeeChart.Styles.ColorGrid Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
GetYValue (inherited from Custom3DGrid) | Occurs when the Surface Series needs to recreate the grid of values.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

ColorGrid Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorGridFields

Steema.TeeChart.Styles.ColorGrid Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
ReuseGridIndex (inherited from Custom3DGrid) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

ColorGrid Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorGridMethods

Steema.TeeChart.Styles.ColorGrid Methods

Public Methods

Add (inherited from Custom3D) | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos |
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos |
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CellBounds |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Custom3DGrid) | Deletes all Series values.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
CreateValues (inherited from Custom3DGrid) | Makes a Surface grid of NumX by NumZ dimensions.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillGridIndex (inherited from Custom3DGrid) |
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Custom3DPalette) | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue |
MinXValue |
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue |
PrepareForGallery (inherited from Custom3DPalette) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

ColorGrid Class | Steema.TeeChart.Styles Namespace


CalcXPos

Steema.TeeChart.Styles.ColorGrid.CalcXPos Method

public override Int32 CalcXPos(Int32 index)

See Also

ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


CalcYPos

Steema.TeeChart.Styles.ColorGrid.CalcYPos Method

public override Int32 CalcYPos(Int32 index)

See Also

ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


CellBounds

Steema.TeeChart.Styles.ColorGrid.CellBounds Method

public Rectangle CellBounds(Int32 ValueIndex)

See Also

ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.ColorGrid.Clicked Method

Overload List

public override Int32 Clicked(System.Int32, System.Int32)

See Also

ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.ColorGrid.Clicked Method

public override Int32 Clicked(Int32 X,
     Int32 Y)

See Also

Clicked Overload List | ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.ColorGrid.Draw Method

public override Void Draw()

See Also

ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


GalleryChanged3D

Steema.TeeChart.Styles.ColorGrid.GalleryChanged3D Method

public override Void GalleryChanged3D(Boolean Is3D)

See Also

ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.ColorGrid.MaxXValue Method

Returns the Maximum Value of the Series X Values List.
public override Double MaxXValue()

See Also

ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.ColorGrid.MaxYValue Method

Returns the Maximum Value of the Series Y Values List.
public override Double MaxYValue()

See Also

ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


MaxZValue

Steema.TeeChart.Styles.ColorGrid.MaxZValue Method

public override Double MaxZValue()

See Also

ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


MinXValue

Steema.TeeChart.Styles.ColorGrid.MinXValue Method

public override Double MinXValue()

See Also

ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.ColorGrid.MinYValue Method

Returns the Minimum Value of the Series Y Values List.
public override Double MinYValue()

See Also

ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


MinZValue

Steema.TeeChart.Styles.ColorGrid.MinZValue Method

public override Double MinZValue()

See Also

ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.ColorGrid.SetSubGallery Method

public override Void SetSubGallery(Int32 index)

See Also

ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorGridProperties

Steema.TeeChart.Styles.ColorGrid Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Bitmap | Use this property to display a bitmap within a ColorGrid.
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
CenteredPoints |
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IrregularGrid (inherited from Custom3DGrid) | Determine if X and Z values are equi-distant or not.
Item (inherited from Custom3DGrid) | A two dimension array property for the easy access to series cell values.
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
NumXValues (inherited from Custom3DGrid) | Determines the Surface's horizontal size in number of points.
NumZValues (inherited from Custom3DGrid) | Determines the Surface's depth size in number of points.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XStep |
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZStep |
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

ColorGrid Class | Steema.TeeChart.Styles Namespace


Bitmap

Steema.TeeChart.Styles.ColorGrid.Bitmap Property

Use this property to display a bitmap within a ColorGrid.
public Bitmap Bitmap {get; set;}

Example

This sample shows how to use the ColorGrid.Bitmap property:

private void SetFlower() {
    MemoryStream ms = new MemoryStream();
    Image flower = pictureBox1.Image;
    flower.Save(ms, System.Drawing.Imaging.ImageFormat.Jpeg);
    Bitmap bm = new Bitmap(ms);
    colorGrid1.Bitmap = bm;
}

See Also

ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


CenteredPoints

Steema.TeeChart.Styles.ColorGrid.CenteredPoints Property

public Boolean CenteredPoints {get; set;}

See Also

ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.ColorGrid.Description Property

public override String Description {get;}

See Also

ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


XStep

Steema.TeeChart.Styles.ColorGrid.XStep Property

public Int32 XStep {get; set;}

See Also

ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


ZStep

Steema.TeeChart.Styles.ColorGrid.ZStep Property

public Int32 ZStep {get; set;}

See Also

ColorGrid Class | ColorGrid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorLineCollection

Steema.TeeChart.Styles.ColorLineCollection Class

Collection of GaugeSeriesPointers.

For a list of all members of this type, see ColorLineCollection Members

System.Object
System.Collections.ArrayList
public class ColorLineCollection : ArrayList , IList, ICollection
, IEnumerable, ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

ColorLineCollection members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorLineCollectionMembers

Steema.TeeChart.Styles.ColorLineCollection all Members

ColorLineCollection overview

Constructors

Constructor

Public Properties

Item

See Also

ColorLineCollection Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorLineCollection Constructor

public ColorLineCollection(Int32 capacity)

See Also

ColorLineCollection Class | ColorLineCollection Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorLineCollectionProperties

Steema.TeeChart.Styles.ColorLineCollection Properties

Public Properties

Item

See Also

ColorLineCollection Class | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.ColorLineCollection.Item Property

public GaugeSeriesPointer Item(Int32 index) {get; set;}

See Also

ColorLineCollection Class | ColorLineCollection Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorLineEndValues

Steema.TeeChart.Styles.ColorLineEndValues Class

Collection of integer values defining the EndValues of the ColorLines in the ColorLineCollection.

For a list of all members of this type, see ColorLineEndValues Members

System.Object
System.Collections.ArrayList
public class ColorLineEndValues : ArrayList , IList, ICollection
, IEnumerable, ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

ColorLineEndValues members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorLineEndValuesMembers

Steema.TeeChart.Styles.ColorLineEndValues all Members

ColorLineEndValues overview

Constructors

Constructor

Public Properties

Item

See Also

ColorLineEndValues Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorLineEndValues Constructor

public ColorLineEndValues(Int32 capacity)

See Also

ColorLineEndValues Class | ColorLineEndValues Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorLineEndValuesProperties

Steema.TeeChart.Styles.ColorLineEndValues Properties

Public Properties

Item

See Also

ColorLineEndValues Class | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.ColorLineEndValues.Item Property

public Double Item(Int32 index) {get; set;}

See Also

ColorLineEndValues Class | ColorLineEndValues Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorLineStartValues

Steema.TeeChart.Styles.ColorLineStartValues Class

Collection of integer values defining the StartValues of the ColorLines in the ColorLineCollection.

For a list of all members of this type, see ColorLineStartValues Members

System.Object
System.Collections.ArrayList
public class ColorLineStartValues : ArrayList , IList, ICollection
, IEnumerable, ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

ColorLineStartValues members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorLineStartValuesMembers

Steema.TeeChart.Styles.ColorLineStartValues all Members

ColorLineStartValues overview

Constructors

Constructor

Public Properties

Item

See Also

ColorLineStartValues Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorLineStartValues Constructor

public ColorLineStartValues(Int32 capacity)

See Also

ColorLineStartValues Class | ColorLineStartValues Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorLineStartValuesProperties

Steema.TeeChart.Styles.ColorLineStartValues Properties

Public Properties

Item

See Also

ColorLineStartValues Class | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.ColorLineStartValues.Item Property

public Double Item(Int32 index) {get; set;}

See Also

ColorLineStartValues Class | ColorLineStartValues Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorList

Steema.TeeChart.Styles.ColorList Class

The ColorList class is manipulated via the Series Colors property.

For a list of all members of this type, see ColorList Members

System.Object
System.Collections.ArrayList
public sealed class ColorList : ArrayList , IList, ICollection
, IEnumerable, ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

ColorList members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorListMembers

Steema.TeeChart.Styles.ColorList all Members

ColorList overview

Constructors

Constructor Overloaded

Public Fields

Name

Public Properties

Item

See Also

ColorList Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorList Constructor

Overload List

public ColorList()
public ColorList(System.Int32)
public ColorList(System.Int32, System.String)
public ColorList(System.Drawing.Color[])
public ColorList(System.Drawing.Color[], System.String)

See Also

ColorList Class | ColorList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorList Constructor

public ColorList(Color[] colors,
     String name)

See Also

ColorList Constructor Overload List | ColorList Class | ColorList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorList Constructor

public ColorList(Color[] colors)

See Also

ColorList Constructor Overload List | ColorList Class | ColorList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorList Constructor

public ColorList(Int32 capacity,
     String name)

See Also

ColorList Constructor Overload List | ColorList Class | ColorList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorList Constructor

public ColorList(Int32 capacity)

See Also

ColorList Constructor Overload List | ColorList Class | ColorList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorList Constructor

public ColorList()

See Also

ColorList Constructor Overload List | ColorList Class | ColorList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorListFields

Steema.TeeChart.Styles.ColorList Fields

Public Fields

Name

See Also

ColorList Class | Steema.TeeChart.Styles Namespace


Name

Steema.TeeChart.Styles.ColorList.Name Field

public String Name

See Also

ColorList Class | ColorList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ColorListProperties

Steema.TeeChart.Styles.ColorList Properties

Public Properties

Item

See Also

ColorList Class | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.ColorList.Item Property

public Color Item(Int32 index) {get; set;}

See Also

ColorList Class | ColorList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Contour

Steema.TeeChart.Styles.Contour Class

The Contour series calculates and displays "isolines" from a custom array of XYZ points.

For a list of all members of this type, see Contour Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
Steema.TeeChart.Styles.Custom3DGrid
public class Contour : Custom3DGrid , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Contour members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ContourMembers

Steema.TeeChart.Styles.Contour all Members

Contour overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
DrawLevel |
GetLevel |
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
GetYValue (inherited from Custom3DGrid) | Occurs when the Surface Series needs to recreate the grid of values.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
LinesColor | Default contour levels line pen color.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
ReuseGridIndex (inherited from Custom3DGrid) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Custom3D) | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Custom3DGrid) | Deletes all Series values.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked | Clicked point index.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
CreateAutoLevels |
CreateValues (inherited from Custom3DGrid) | Makes a Surface grid of NumX by NumZ dimensions.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillGridIndex (inherited from Custom3DGrid) |
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom3DPalette) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString |
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Custom3D) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery (inherited from Custom3DPalette) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutomaticLevels | Sets ContourSeries Automatic Levels.
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ContourMarks | Special characteristic for contour marks.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
DrawingAlgorithm | Contour series level construction and drawing algorithm.
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FillLevels | If true, fill contour levels.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Frame | Defines Series bounding frame characteristic.
Function (inherited from Series) | Function object to calculate values.
GetZAxis | Returns the associated z axis. If in 3D, then the result is Depth axis, otherwise the result is series default vertical axis.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IrregularGrid (inherited from Custom3DGrid) | Determine if X and Z values are equi-distant or not.
Item (inherited from Custom3DGrid) | A two dimension array property for the easy access to series cell values.
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Levels | Accesses ContourLevel characteristics by selecting Level index.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
NumLevels | Sets the number of 'isobar-like' levels for the ContourSeries.
NumXValues (inherited from Custom3DGrid) | Determines the Surface's horizontal size in number of points.
NumZValues (inherited from Custom3DGrid) | Determines the Surface's depth size in number of points.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer | Contour series Pointer characteristics.
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YPosition | Sets the Y-Axis height of the Contour Series.
YPositionLevel | Enables/disables YPosition to be set.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

Contour Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Contour Constructor

Overload List

public Contour(Steema.TeeChart.Chart)
public Contour()

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Contour Constructor

public Contour()

See Also

Contour Constructor Overload List | Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Contour Constructor

public Contour(Chart c)

See Also

Contour Constructor Overload List | Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ContourEvents

Steema.TeeChart.Styles.Contour Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
DrawLevel |
GetLevel |
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
GetYValue (inherited from Custom3DGrid) | Occurs when the Surface Series needs to recreate the grid of values.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Contour Class | Steema.TeeChart.Styles Namespace


DrawLevel

Steema.TeeChart.Styles.Contour.DrawLevel Event

public DrawLevelEventHandler  DrawLevel

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


GetLevel

Steema.TeeChart.Styles.Contour.GetLevel Event

public GetLevelEventHandler  GetLevel

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ContourFields

Steema.TeeChart.Styles.Contour Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
LinesColor | Default contour levels line pen color.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
ReuseGridIndex (inherited from Custom3DGrid) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Contour Class | Steema.TeeChart.Styles Namespace


LinesColor

Steema.TeeChart.Styles.Contour.LinesColor Field

Default contour levels line pen color.
public Color LinesColor

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ContourMethods

Steema.TeeChart.Styles.Contour Methods

Public Methods

Add (inherited from Custom3D) | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Custom3DGrid) | Deletes all Series values.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked | Clicked point index.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
CreateAutoLevels |
CreateValues (inherited from Custom3DGrid) | Makes a Surface grid of NumX by NumZ dimensions.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillGridIndex (inherited from Custom3DGrid) |
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom3DPalette) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString |
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Custom3D) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery (inherited from Custom3DPalette) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Contour Class | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Contour.Clicked Method

Overload List

Clicked point index.

public override Int32 Clicked(System.Int32, System.Int32)

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Contour.Clicked Method

Clicked point index.
public override Int32 Clicked(Int32 x,
     Int32 y)

Parameters

x
Screen x position.
y
Screen y position.

Return Value

Clicked point index.

See Also

Clicked Overload List | Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


CreateAutoLevels

Steema.TeeChart.Styles.Contour.CreateAutoLevels Method

public Void CreateAutoLevels()

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.Contour.Draw Method

public override Void Draw()

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


LegendString

Steema.TeeChart.Styles.Contour.LegendString Method

public override String LegendString(Int32 legendIndex,
     LegendTextStyles legendTextStyle)

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.Contour.MaxYValue Method

Returns the Maximum Value of the Series Y Values List.
public override Double MaxYValue()

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.Contour.MinYValue Method

Returns the Minimum Value of the Series Y Values List.
public override Double MinYValue()

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.Contour.SetSubGallery Method

public override Void SetSubGallery(Int32 index)

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ContourProperties

Steema.TeeChart.Styles.Contour Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutomaticLevels | Sets ContourSeries Automatic Levels.
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ContourMarks | Special characteristic for contour marks.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
DrawingAlgorithm | Contour series level construction and drawing algorithm.
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FillLevels | If true, fill contour levels.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Frame | Defines Series bounding frame characteristic.
Function (inherited from Series) | Function object to calculate values.
GetZAxis | Returns the associated z axis. If in 3D, then the result is Depth axis, otherwise the result is series default vertical axis.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IrregularGrid (inherited from Custom3DGrid) | Determine if X and Z values are equi-distant or not.
Item (inherited from Custom3DGrid) | A two dimension array property for the easy access to series cell values.
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Levels | Accesses ContourLevel characteristics by selecting Level index.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
NumLevels | Sets the number of 'isobar-like' levels for the ContourSeries.
NumXValues (inherited from Custom3DGrid) | Determines the Surface's horizontal size in number of points.
NumZValues (inherited from Custom3DGrid) | Determines the Surface's depth size in number of points.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer | Contour series Pointer characteristics.
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YPosition | Sets the Y-Axis height of the Contour Series.
YPositionLevel | Enables/disables YPosition to be set.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

Contour Class | Steema.TeeChart.Styles Namespace


AutomaticLevels

Steema.TeeChart.Styles.Contour.AutomaticLevels Property

Sets ContourSeries Automatic Levels.
public Boolean AutomaticLevels {get; set;}

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


ContourMarks

Steema.TeeChart.Styles.Contour.ContourMarks Property

Special characteristic for contour marks.
public ContourSeriesMarks ContourMarks {get; set;}

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Contour.Description Property

public override String Description {get;}

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


DrawingAlgorithm

Steema.TeeChart.Styles.Contour.DrawingAlgorithm Property

Contour series level construction and drawing algorithm.
public ContourConstruction DrawingAlgorithm {get; set;}

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


FillLevels

Steema.TeeChart.Styles.Contour.FillLevels Property

If true, fill contour levels.
public Boolean FillLevels {get; set;}

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


Frame

Steema.TeeChart.Styles.Contour.Frame Property

Defines Series bounding frame characteristic.
public ChartPen Frame {get; set;}

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


GetZAxis

Steema.TeeChart.Styles.Contour.GetZAxis Property

Returns the associated z axis. If in 3D, then the result is Depth axis, otherwise the result is series default vertical axis.
public Axis GetZAxis {get;}

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


Levels

Steema.TeeChart.Styles.Contour.Levels Property

Accesses ContourLevel characteristics by selecting Level index.
public List<ContourLevel> Levels {get; set;}

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


NumLevels

Steema.TeeChart.Styles.Contour.NumLevels Property

Sets the number of 'isobar-like' levels for the ContourSeries.
public Int32 NumLevels {get; set;}

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


Pointer

Steema.TeeChart.Styles.Contour.Pointer Property

Contour series Pointer characteristics.
public virtual SeriesPointer Pointer {get; set;}

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


YPosition

Steema.TeeChart.Styles.Contour.YPosition Property

Sets the Y-Axis height of the Contour Series.
public Double YPosition {get; set;}

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


YPositionLevel

Steema.TeeChart.Styles.Contour.YPositionLevel Property

Enables/disables YPosition to be set.
public Boolean YPositionLevel {get; set;}

See Also

Contour Class | Contour Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Contour.ContourDraw

Steema.TeeChart.Styles.Contour.ContourDraw Class

Composite of the Contour series class.

For a list of all members of this type, see ContourDraw Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class ContourDraw : TeeBase

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

ContourDraw members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Contour.ContourDrawMembers

Steema.TeeChart.Styles.Contour.ContourDraw all Members

ContourDraw overview

Public Methods

Invalidate (inherited from TeeBase) Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

Constructors

Steema.TeeChart.Styles.Contour.ContourDraw..ctor

See Also

ContourDraw Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Contour.ContourDrawMethods

Steema.TeeChart.Styles.Contour.ContourDraw Methods

Public Methods

Invalidate (inherited from TeeBase) Use Invalidate when the entire canvas needs to be repainted.

See Also

ContourDraw Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Contour.ContourDrawProperties

Steema.TeeChart.Styles.Contour.ContourDraw Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

ContourDraw Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Contour+ContourDraw Constructor

public Contour+ContourDraw(Contour cSeries)

See Also

ContourDraw Class | ContourDraw Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Contour.DrawLevelEventArgs

Steema.TeeChart.Styles.Contour.DrawLevelEventArgs Class

The Event Data for the DrawLevel event.

For a list of all members of this type, see DrawLevelEventArgs Members

System.Object
System.EventArgs
public class DrawLevelEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

DrawLevelEventArgs members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Contour.DrawLevelEventArgsMembers

Steema.TeeChart.Styles.Contour.DrawLevelEventArgs all Members

DrawLevelEventArgs overview

Public Properties

LevelIndex Accesses the ContourLevel characteristics selecting Level by index.

Constructors

Steema.TeeChart.Styles.Contour.DrawLevelEventArgs..ctor

See Also

DrawLevelEventArgs Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Contour.DrawLevelEventArgsProperties

Steema.TeeChart.Styles.Contour.DrawLevelEventArgs Properties

Public Properties

LevelIndex Accesses the ContourLevel characteristics selecting Level by index.

See Also

DrawLevelEventArgs Class | Steema.TeeChart.Styles Namespace


LevelIndex

Steema.TeeChart.Styles.Contour+DrawLevelEventArgs.LevelIndex Property

Accesses the ContourLevel characteristics selecting Level by index.
public Int32 LevelIndex {get;}

See Also

DrawLevelEventArgs Class | DrawLevelEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Contour+DrawLevelEventArgs Constructor

public Contour+DrawLevelEventArgs(Int32 LevelIndex)

See Also

DrawLevelEventArgs Class | DrawLevelEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Contour.DrawLevelEventHandler

Steema.TeeChart.Styles.Contour.DrawLevelEventHandler Delegate

The Delegate for the DrawLevel event.
public delegate DrawLevelEventHandler (Contour sender,
     DrawLevelEventArgs e)

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Contour.GetLevelEventArgs

Steema.TeeChart.Styles.Contour.GetLevelEventArgs Class

The Event Data for the GetLevel event.

For a list of all members of this type, see GetLevelEventArgs Members

System.Object
System.EventArgs
public class GetLevelEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

GetLevelEventArgs members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Contour.GetLevelEventArgsMembers

Steema.TeeChart.Styles.Contour.GetLevelEventArgs all Members

GetLevelEventArgs overview

Public Properties

Color | Sets the Colour of the ContourSeries Level.
LevelIndex | Accesses the ContourLevel characteristics selecting Level by index.
Value | Gets or Sets the values in the Value array.

Constructors

Steema.TeeChart.Styles.Contour.GetLevelEventArgs..ctor

See Also

GetLevelEventArgs Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Contour.GetLevelEventArgsProperties

Steema.TeeChart.Styles.Contour.GetLevelEventArgs Properties

Public Properties

Color | Sets the Colour of the ContourSeries Level.
LevelIndex | Accesses the ContourLevel characteristics selecting Level by index.
Value | Gets or Sets the values in the Value array.

See Also

GetLevelEventArgs Class | Steema.TeeChart.Styles Namespace


Color

Steema.TeeChart.Styles.Contour+GetLevelEventArgs.Color Property

Sets the Colour of the ContourSeries Level.
public Color Color {get; set;}

See Also

GetLevelEventArgs Class | GetLevelEventArgs Members | Steema.TeeChart.Styles Namespace


LevelIndex

Steema.TeeChart.Styles.Contour+GetLevelEventArgs.LevelIndex Property

Accesses the ContourLevel characteristics selecting Level by index.
public Int32 LevelIndex {get;}

See Also

GetLevelEventArgs Class | GetLevelEventArgs Members | Steema.TeeChart.Styles Namespace


Value

Steema.TeeChart.Styles.Contour+GetLevelEventArgs.Value Property

Gets or Sets the values in the Value array.
public Double Value {get; set;}

See Also

GetLevelEventArgs Class | GetLevelEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Contour+GetLevelEventArgs Constructor

public Contour+GetLevelEventArgs(Int32 LevelIndex,
     Double Value,
     Color Color)

See Also

GetLevelEventArgs Class | GetLevelEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Contour.GetLevelEventHandler

Steema.TeeChart.Styles.Contour.GetLevelEventHandler Delegate

The Delegate for the GetLevel event.
public delegate GetLevelEventHandler (Contour sender,
     GetLevelEventArgs e)

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ContourConstruction

Steema.TeeChart.Styles.ContourConstruction Enum

Contour level construction algorithm.
[Serializable]
public sealed enum ContourConstruction : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Fast | Level is not segmented (fast)
Segments | Each level is segmented (slow).

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ContourLevel

Steema.TeeChart.Styles.ContourLevel Class

Contains characteristic information for a Contour series' "level".

For a list of all members of this type, see ContourLevel Members

System.Object
public class ContourLevel : Object

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

ContourLevel members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ContourLevelMembers

Steema.TeeChart.Styles.ContourLevel all Members

ContourLevel overview

Constructors

Constructor

Public Methods

Clicked
ClickedSegment
DefaultPen
GetSegmentPoints
ShouldSerializePen

Public Properties

Color | Colour of ContourSeries Level.
Pen | Pen characteristics of the ContourLevel
Segments |
StringColor |
UpToValue | Sets range value for ContourLevel.

See Also

ContourLevel Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ContourLevel Constructor

public ContourLevel(Contour cs,
     Int32 levelindex)

See Also

ContourLevel Class | ContourLevel Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ContourLevelMethods

Steema.TeeChart.Styles.ContourLevel Methods

Public Methods

Clicked
ClickedSegment
DefaultPen
GetSegmentPoints
ShouldSerializePen

See Also

ContourLevel Class | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.ContourLevel.Clicked Method

public Boolean Clicked(Int32 x,
     Int32 y,
     Int32& segmentindex,
     Int32& pointindex)

See Also

ContourLevel Class | ContourLevel Members | Steema.TeeChart.Styles Namespace


ClickedSegment

Steema.TeeChart.Styles.ContourLevel.ClickedSegment Method

public Boolean ClickedSegment(Int32 x,
     Int32 y,
     Int32 segmentindex,
     Int32& pointindex)

See Also

ContourLevel Class | ContourLevel Members | Steema.TeeChart.Styles Namespace


DefaultPen

Steema.TeeChart.Styles.ContourLevel.DefaultPen Method

public Boolean DefaultPen()

See Also

ContourLevel Class | ContourLevel Members | Steema.TeeChart.Styles Namespace


GetSegmentPoints

Steema.TeeChart.Styles.ContourLevel.GetSegmentPoints Method

public Point[] GetSegmentPoints(Int32 segmentindex)

See Also

ContourLevel Class | ContourLevel Members | Steema.TeeChart.Styles Namespace


ShouldSerializePen

Steema.TeeChart.Styles.ContourLevel.ShouldSerializePen Method

public Boolean ShouldSerializePen()

See Also

ContourLevel Class | ContourLevel Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ContourLevelProperties

Steema.TeeChart.Styles.ContourLevel Properties

Public Properties

Color | Colour of ContourSeries Level.
Pen | Pen characteristics of the ContourLevel
Segments |
StringColor |
UpToValue | Sets range value for ContourLevel.

See Also

ContourLevel Class | Steema.TeeChart.Styles Namespace


Color

Steema.TeeChart.Styles.ContourLevel.Color Property

Colour of ContourSeries Level.
public Color Color {get; set;}

See Also

ContourLevel Class | ContourLevel Members | Steema.TeeChart.Styles Namespace


Pen

Steema.TeeChart.Styles.ContourLevel.Pen Property

Pen characteristics of the ContourLevel
public ChartPen Pen {get; set;}

See Also

ContourLevel Class | ContourLevel Members | Steema.TeeChart.Styles Namespace


Segments

Steema.TeeChart.Styles.ContourLevel.Segments Property

public List<LevelSegment> Segments {get;}

See Also

ContourLevel Class | ContourLevel Members | Steema.TeeChart.Styles Namespace


StringColor

Steema.TeeChart.Styles.ContourLevel.StringColor Property

public String StringColor {get; set;}

See Also

ContourLevel Class | ContourLevel Members | Steema.TeeChart.Styles Namespace


UpToValue

Steema.TeeChart.Styles.ContourLevel.UpToValue Property

Sets range value for ContourLevel.
public Double UpToValue {get; set;}

See Also

ContourLevel Class | ContourLevel Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ContourSeriesMarks

Steema.TeeChart.Styles.ContourSeriesMarks Class

For a list of all members of this type, see ContourSeriesMarks Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class ContourSeriesMarks : TeeBase

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

ContourSeriesMarks members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ContourSeriesMarksMembers

Steema.TeeChart.Styles.ContourSeriesMarks all Members

ContourSeriesMarks overview

Constructors

Constructor

Public Methods

Invalidate (inherited from TeeBase) Use Invalidate when the entire canvas needs to be repainted.

Public Properties

AntiOverlap |
AtSegments |
Chart (inherited from TeeBase) | Chart associated with this object
ColorLevel |
Density |
Margin |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Visible |

See Also

ContourSeriesMarks Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ContourSeriesMarks Constructor

public ContourSeriesMarks(Contour cs)

See Also

ContourSeriesMarks Class | ContourSeriesMarks Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ContourSeriesMarksMethods

Steema.TeeChart.Styles.ContourSeriesMarks Methods

Public Methods

Invalidate (inherited from TeeBase) Use Invalidate when the entire canvas needs to be repainted.

See Also

ContourSeriesMarks Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ContourSeriesMarksProperties

Steema.TeeChart.Styles.ContourSeriesMarks Properties

Public Properties

AntiOverlap |
AtSegments |
Chart (inherited from TeeBase) | Chart associated with this object
ColorLevel |
Density |
Margin |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Visible |

See Also

ContourSeriesMarks Class | Steema.TeeChart.Styles Namespace


AntiOverlap

Steema.TeeChart.Styles.ContourSeriesMarks.AntiOverlap Property

public Boolean AntiOverlap {get; set;}

See Also

ContourSeriesMarks Class | ContourSeriesMarks Members | Steema.TeeChart.Styles Namespace


AtSegments

Steema.TeeChart.Styles.ContourSeriesMarks.AtSegments Property

public Boolean AtSegments {get; set;}

See Also

ContourSeriesMarks Class | ContourSeriesMarks Members | Steema.TeeChart.Styles Namespace


ColorLevel

Steema.TeeChart.Styles.ContourSeriesMarks.ColorLevel Property

public Boolean ColorLevel {get; set;}

See Also

ContourSeriesMarks Class | ContourSeriesMarks Members | Steema.TeeChart.Styles Namespace


Density

Steema.TeeChart.Styles.ContourSeriesMarks.Density Property

public Int32 Density {get; set;}

See Also

ContourSeriesMarks Class | ContourSeriesMarks Members | Steema.TeeChart.Styles Namespace


Margin

Steema.TeeChart.Styles.ContourSeriesMarks.Margin Property

public Int32 Margin {get; set;}

See Also

ContourSeriesMarks Class | ContourSeriesMarks Members | Steema.TeeChart.Styles Namespace


Visible

Steema.TeeChart.Styles.ContourSeriesMarks.Visible Property

public Boolean Visible {get; set;}

See Also

ContourSeriesMarks Class | ContourSeriesMarks Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom

Steema.TeeChart.Styles.Custom Class

Base Series class inherited by a number of TeeChart series styles.

For a list of all members of this type, see Custom Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
public class Custom : CustomPoint , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Custom members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomMembers

Steema.TeeChart.Styles.Custom all Members

Custom overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine | Allows mouse clicks over the line drawn between points.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InvertedStairs | Changes the direction of the step, when true.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity | Sets Opacity level from 0 to 100%
OutLine | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Custom Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom Constructor

Overload List

public Custom()
public Custom(Steema.TeeChart.Chart)

See Also

Custom Class | Custom Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom Constructor

public Custom(Chart c)

See Also

Custom Constructor Overload List | Custom Class | Custom Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom Constructor

public Custom()

See Also

Custom Constructor Overload List | Custom Class | Custom Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomEvents

Steema.TeeChart.Styles.Custom Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Custom Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomFields

Steema.TeeChart.Styles.Custom Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Custom Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomMethods

Steema.TeeChart.Styles.Custom Methods

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Custom Class | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.Custom.AssignFormat Method

Overload List

public override Void AssignFormat(Steema.TeeChart.Styles.Series, Steema.TeeChart.Styles.Series)

See Also

Custom Class | Custom Members | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.Custom.AssignFormat Method

public override Void AssignFormat(Series source,
     Series target)

See Also

AssignFormat Overload List | Custom Class | Custom Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Custom.Clicked Method

Overload List

Calculates if any point is at XY position.

public override Int32 Clicked(System.Int32, System.Int32)

See Also

Custom Class | Custom Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Custom.Clicked Method

Calculates if any point is at XY position.
public override Int32 Clicked(Int32 x,
     Int32 y)

Return Value

Point index

See Also

Clicked Overload List | Custom Class | Custom Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.Custom.Draw Method

public override Void Draw()

See Also

Custom Class | Custom Members | Steema.TeeChart.Styles Namespace


DrawHiddenValue

Steema.TeeChart.Styles.Custom.DrawHiddenValue Method

public override Void DrawHiddenValue(Int32 valueIndex,
     Double& startValue,
     Double& endValue,
     Int32 gapSize,
     Axis axis)

See Also

Custom Class | Custom Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.Custom.DrawValue Method

Called internally. Draws the "ValueIndex" point of the Series.
public override Void DrawValue(Int32 valueIndex)

See Also

Custom Class | Custom Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomProperties

Steema.TeeChart.Styles.Custom Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine | Allows mouse clicks over the line drawn between points.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InvertedStairs | Changes the direction of the step, when true.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity | Sets Opacity level from 0 to 100%
OutLine | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Custom Class | Steema.TeeChart.Styles Namespace


Brush

Steema.TeeChart.Styles.Custom.Brush Property

Sets Brush characteristics.
public ChartBrush Brush {get;}

See Also

Custom Class | Custom Members | Steema.TeeChart.Styles Namespace


ClickableLine

Steema.TeeChart.Styles.Custom.ClickableLine Property

Allows mouse clicks over the line drawn between points.
public Boolean ClickableLine {get; set;}

See Also

Custom Class | Custom Members | Steema.TeeChart.Styles Namespace


ColorEachLine

Steema.TeeChart.Styles.Custom.ColorEachLine Property

Enables/Disables the coloring of each connecting line of a series.
public Boolean ColorEachLine {get; set;}

See Also

Custom Class | Custom Members | Steema.TeeChart.Styles Namespace


Dark3D

Steema.TeeChart.Styles.Custom.Dark3D Property

Darkens parts of 3D Line Series to add depth.
public Boolean Dark3D {get; set;}

See Also

Custom Class | Custom Members | Steema.TeeChart.Styles Namespace


InvertedStairs

Steema.TeeChart.Styles.Custom.InvertedStairs Property

Changes the direction of the step, when true.
public Boolean InvertedStairs {get; set;}

See Also

Custom Class | Custom Members | Steema.TeeChart.Styles Namespace


LineHeight

Steema.TeeChart.Styles.Custom.LineHeight Property

Defines the vertical thickness of the line in pixels.
public Int32 LineHeight {get; set;}

See Also

Custom Class | Custom Members | Steema.TeeChart.Styles Namespace


Opacity

Steema.TeeChart.Styles.Custom.Opacity Property

Sets Opacity level from 0 to 100%
public Int32 Opacity {get; set;}

See Also

Custom Class | Custom Members | Steema.TeeChart.Styles Namespace


OutLine

Steema.TeeChart.Styles.Custom.OutLine Property

Pen for Series Line's outer pen.
public ChartPen OutLine {get; set;}

See Also

Custom Class | Custom Members | Steema.TeeChart.Styles Namespace


Smoothed

Steema.TeeChart.Styles.Custom.Smoothed Property

Gets or sets whether the Line Series' line is smoothed.
public Boolean Smoothed {get; set;}

See Also

Custom Class | Custom Members | Steema.TeeChart.Styles Namespace


Stairs

Steema.TeeChart.Styles.Custom.Stairs Property

Steps line joining adjacent points.
public Boolean Stairs {get; set;}

See Also

Custom Class | Custom Members | Steema.TeeChart.Styles Namespace


Transparency

Steema.TeeChart.Styles.Custom.Transparency Property

Sets Transparency level from 0 to 100%
public Int32 Transparency {get; set;}

See Also

Custom Class | Custom Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom2DPolar

Steema.TeeChart.Styles.Custom2DPolar Class

Custom2DPolar is the ancestor of the WindRose Series and the Clock Series.

For a list of all members of this type, see Custom2DPolar Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
Steema.TeeChart.Styles.CustomPolar
public class Custom2DPolar : CustomPolar , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Custom2DPolar members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom2DPolarMembers

Steema.TeeChart.Styles.Custom2DPolar all Members

Custom2DPolar overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle (inherited from CustomPolar) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from CustomPolar) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPolar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPolar) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPolar) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPolar) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from CustomPolar) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawRing (inherited from CustomPolar) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomPolar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
DrawZone (inherited from CustomPolar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
OnGetPointerStyle (inherited from CustomPolar) |
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AngleIncrement (inherited from CustomPolar) | Sets angle in degrees used to draw the dividing grid lines in anti-clockwise direction.
AngleValues (inherited from CustomPolar) | Gets list of angle values for each polar point.
Brush (inherited from CustomPolar) | Sets Polar Back Brush.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleLabels (inherited from CustomPolar) | Sets CicleLabel properties.
CircleLabelsFont (inherited from CustomPolar) |
CircleLabelsInside (inherited from CustomPolar) | Enables/disables the display of the axis labels inside the circle area.
CircleLabelsRotated (inherited from CustomPolar) | When true rotates the labels of a circular TeeChart series at an angle in line with the Radar/Polar circle at each Label point.
CirclePen (inherited from CustomPolar) | Determines the pen used to draw the outmost circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
ClockWiseLabels (inherited from CustomPolar) | Displays of the circle labels in a clockwise direction.
CloseCircle (inherited from CustomPolar) | Draws a Line between the last and first PolarSeries point coordinates.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Font (inherited from CustomPolar) | Sets the label font.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsMargin (inherited from CustomPolar) | Defines the distance between the CustomPolar circle and the labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen (inherited from CustomPolar) | Determines Pen used to draw the Line connecting PolarSeries points.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPolar) | Pointer contains several properties to control the formatting attributes of Points like Pen, Brush, Draw3D, Visible, etc.
RadiusIncrement (inherited from CustomPolar) | Determines the increment used to draw the ring grid lines.
RadiusValues (inherited from CustomPolar) | Gets list of radius values for each polar point.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from CustomPolar) | Sets Transparency level from 0 to 100%.
TreatNaNAsNull (inherited from CustomPolar) |
TreatNulls (inherited from CustomPolar) |
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Custom2DPolar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom2DPolar Constructor

Overload List

public Custom2DPolar()
public Custom2DPolar(Steema.TeeChart.Chart)

See Also

Custom2DPolar Class | Custom2DPolar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom2DPolar Constructor

public Custom2DPolar(Chart c)

See Also

Custom2DPolar Constructor Overload List | Custom2DPolar Class | Custom2DPolar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom2DPolar Constructor

public Custom2DPolar()

See Also

Custom2DPolar Constructor Overload List | Custom2DPolar Class | Custom2DPolar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom2DPolarEvents

Steema.TeeChart.Styles.Custom2DPolar Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle (inherited from CustomPolar) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Custom2DPolar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom2DPolarFields

Steema.TeeChart.Styles.Custom2DPolar Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Custom2DPolar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom2DPolarMethods

Steema.TeeChart.Styles.Custom2DPolar Methods

Public Methods

Add (inherited from CustomPolar) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPolar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPolar) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPolar) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPolar) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from CustomPolar) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawRing (inherited from CustomPolar) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomPolar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
DrawZone (inherited from CustomPolar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
OnGetPointerStyle (inherited from CustomPolar) |
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Custom2DPolar Class | Steema.TeeChart.Styles Namespace


GalleryChanged3D

Steema.TeeChart.Styles.Custom2DPolar.GalleryChanged3D Method

public override Void GalleryChanged3D(Boolean Is3D)

See Also

Custom2DPolar Class | Custom2DPolar Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.Custom2DPolar.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

Custom2DPolar Class | Custom2DPolar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom2DPolarProperties

Steema.TeeChart.Styles.Custom2DPolar Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AngleIncrement (inherited from CustomPolar) | Sets angle in degrees used to draw the dividing grid lines in anti-clockwise direction.
AngleValues (inherited from CustomPolar) | Gets list of angle values for each polar point.
Brush (inherited from CustomPolar) | Sets Polar Back Brush.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleLabels (inherited from CustomPolar) | Sets CicleLabel properties.
CircleLabelsFont (inherited from CustomPolar) |
CircleLabelsInside (inherited from CustomPolar) | Enables/disables the display of the axis labels inside the circle area.
CircleLabelsRotated (inherited from CustomPolar) | When true rotates the labels of a circular TeeChart series at an angle in line with the Radar/Polar circle at each Label point.
CirclePen (inherited from CustomPolar) | Determines the pen used to draw the outmost circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
ClockWiseLabels (inherited from CustomPolar) | Displays of the circle labels in a clockwise direction.
CloseCircle (inherited from CustomPolar) | Draws a Line between the last and first PolarSeries point coordinates.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Font (inherited from CustomPolar) | Sets the label font.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsMargin (inherited from CustomPolar) | Defines the distance between the CustomPolar circle and the labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen (inherited from CustomPolar) | Determines Pen used to draw the Line connecting PolarSeries points.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPolar) | Pointer contains several properties to control the formatting attributes of Points like Pen, Brush, Draw3D, Visible, etc.
RadiusIncrement (inherited from CustomPolar) | Determines the increment used to draw the ring grid lines.
RadiusValues (inherited from CustomPolar) | Gets list of radius values for each polar point.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from CustomPolar) | Sets Transparency level from 0 to 100%.
TreatNaNAsNull (inherited from CustomPolar) |
TreatNulls (inherited from CustomPolar) |
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Custom2DPolar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3D

Steema.TeeChart.Styles.Custom3D Class

Custom3D Series.

For a list of all members of this type, see Custom3D Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public abstract class Custom3D : Series , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Custom3D members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DMembers

Steema.TeeChart.Styles.Custom3D all Members

Custom3D overview

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Series) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item | XYZ Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues | Values defining Z grid point positions.

See Also

Custom3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DEvents

Steema.TeeChart.Styles.Custom3D Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Custom3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DFields

Steema.TeeChart.Styles.Custom3D Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Custom3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DMethods

Steema.TeeChart.Styles.Custom3D Methods

Public Methods

Add | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Series) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Custom3D Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Custom3D.Add Method

Overload List

Adds the X, Y and Z arrays.

public Void Add(System.Array, System.Array, System.Array, System.Array)

Adds the X, Y and Z arrays.

public Void Add(System.Array, System.Array, System.Array)
public Int32 Add(System.Nullable`1[System.Double], System.Nullable`1[System.Double], System.Nullable`1[System.Double])
public Int32 Add(System.Nullable`1[System.Double], System.Nullable`1[System.Double], System.Nullable`1[System.Double], System.String)
public Int32 Add(System.Nullable`1[System.Double], System.Nullable`1[System.Double], System.Nullable`1[System.Double], System.Drawing.Color)
public Int32 Add(System.DateTime, System.Nullable`1[System.Double], System.Nullable`1[System.Double], System.String, System.Drawing.Color)
public Int32 Add(System.Nullable`1[System.Double], System.Nullable`1[System.Double], System.Nullable`1[System.Double], System.String, System.Drawing.Color)

Adds a new point to a 3D Series.

public Int32 Add(System.Double, System.Double, System.Double)

Adds a new point to a 3D Series and color.

public Int32 Add(System.Double, System.Double, System.Double, System.Drawing.Color)

Adds a new point to a 3D Series and label.

public Int32 Add(System.Double, System.Double, System.Double, System.String)

Adds a new point to a 3D Series, label and color.

public Int32 Add(System.Double, System.Double, System.Double, System.String, System.Drawing.Color)

Adds a new Datetime point to a 3D Series, label and color.

public Int32 Add(System.DateTime, System.Double, System.Double, System.String, System.Drawing.Color)

See Also

Custom3D Class | Custom3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Custom3D.Add Method

Adds a new Datetime point to a 3D Series, label and color.
public Int32 Add(DateTime aDate,
     Double y,
     Double z,
     String text,
     Color color)

Parameters

aDate
Datetime value
y
Y value
z
Z value
text
Point text
color
Point Color

Return Value

index of added point

See Also

Add Overload List | Custom3D Class | Custom3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Custom3D.Add Method

Adds a new point to a 3D Series, label and color.
public Int32 Add(Double x,
     Double y,
     Double z,
     String text,
     Color color)

See Also

Add Overload List | Custom3D Class | Custom3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Custom3D.Add Method

Adds a new point to a 3D Series and label.
public Int32 Add(Double x,
     Double y,
     Double z,
     String text)

See Also

Add Overload List | Custom3D Class | Custom3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Custom3D.Add Method

Adds a new point to a 3D Series and color.
public Int32 Add(Double x,
     Double y,
     Double z,
     Color color)

See Also

Add Overload List | Custom3D Class | Custom3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Custom3D.Add Method

Adds a new point to a 3D Series.
public Int32 Add(Double x,
     Double y,
     Double z)

See Also

Add Overload List | Custom3D Class | Custom3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Custom3D.Add Method

public Int32 Add(Nullable<Double> x,
     Nullable<Double> y,
     Nullable<Double> z,
     String text,
     Color color)

See Also

Add Overload List | Custom3D Class | Custom3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Custom3D.Add Method

public Int32 Add(DateTime aDate,
     Nullable<Double> y,
     Nullable<Double> z,
     String text,
     Color color)

See Also

Add Overload List | Custom3D Class | Custom3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Custom3D.Add Method

public Int32 Add(Nullable<Double> x,
     Nullable<Double> y,
     Nullable<Double> z,
     Color color)

See Also

Add Overload List | Custom3D Class | Custom3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Custom3D.Add Method

public Int32 Add(Nullable<Double> x,
     Nullable<Double> y,
     Nullable<Double> z,
     String text)

See Also

Add Overload List | Custom3D Class | Custom3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Custom3D.Add Method

public Int32 Add(Nullable<Double> x,
     Nullable<Double> y,
     Nullable<Double> z)

See Also

Add Overload List | Custom3D Class | Custom3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Custom3D.Add Method

Adds the X, Y and Z arrays.
public Void Add(Array xValues,
     Array yValues,
     Array zValues)

See Also

Add Overload List | Custom3D Class | Custom3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Custom3D.Add Method

Adds the X, Y and Z arrays.
public Void Add(Array xValues,
     Array yValues,
     Array zValues,
     Array colorValues)

See Also

Add Overload List | Custom3D Class | Custom3D Members | Steema.TeeChart.Styles Namespace


CalcZPos

Steema.TeeChart.Styles.Custom3D.CalcZPos Method

public Int32 CalcZPos(Int32 valueIndex)

See Also

Custom3D Class | Custom3D Members | Steema.TeeChart.Styles Namespace


IsValidSourceOf

Steema.TeeChart.Styles.Custom3D.IsValidSourceOf Method

Checks if given series object instance is a Custom3D instance.
public override Boolean IsValidSourceOf(Series value)

See Also

Custom3D Class | Custom3D Members | Steema.TeeChart.Styles Namespace


MaxZValue

Steema.TeeChart.Styles.Custom3D.MaxZValue Method

Returns Maximum Z Value.
public override Double MaxZValue()

See Also

Custom3D Class | Custom3D Members | Steema.TeeChart.Styles Namespace


MinZValue

Steema.TeeChart.Styles.Custom3D.MinZValue Method

Returns Minimum Z Value.
public override Double MinZValue()

See Also

Custom3D Class | Custom3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DProperties

Steema.TeeChart.Styles.Custom3D Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item | XYZ Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues | Values defining Z grid point positions.

See Also

Custom3D Class | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.Custom3D.Item Property

XYZ Point characteristics
public SeriesXYZPoint Item(Int32 index) {get;}

See Also

Custom3D Class | Custom3D Members | Steema.TeeChart.Styles Namespace


TimesZOrder

Steema.TeeChart.Styles.Custom3D.TimesZOrder Property

For internal use.
public Int32 TimesZOrder {get; set;}

See Also

Custom3D Class | Custom3D Members | Steema.TeeChart.Styles Namespace


ZValues

Steema.TeeChart.Styles.Custom3D.ZValues Property

Values defining Z grid point positions.
public ValueList ZValues {get;}

See Also

Custom3D Class | Custom3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DGrid

Steema.TeeChart.Styles.Custom3DGrid Class

Custom3DGridSeries

For a list of all members of this type, see Custom3DGrid Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
public class Custom3DGrid : Custom3DPalette , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Custom3DGrid members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DGridMembers

Steema.TeeChart.Styles.Custom3DGrid all Members

Custom3DGrid overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
GetYValue | Occurs when the Surface Series needs to recreate the grid of values.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
ReuseGridIndex |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Custom3D) | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear | Deletes all Series values.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked (inherited from Series) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
CreateValues | Makes a Surface grid of NumX by NumZ dimensions.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillGridIndex |
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom3DPalette) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Custom3DPalette) | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Custom3D) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery (inherited from Custom3DPalette) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Custom3DPalette) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IrregularGrid | Determine if X and Z values are equi-distant or not.
Item | A two dimension array property for the easy access to series cell values.
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
NumXValues | Determines the Surface's horizontal size in number of points.
NumZValues | Determines the Surface's depth size in number of points.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

Custom3DGrid Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DGrid Constructor

Overload List

public Custom3DGrid()
public Custom3DGrid(Steema.TeeChart.Chart)

See Also

Custom3DGrid Class | Custom3DGrid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DGrid Constructor

public Custom3DGrid(Chart c)

See Also

Custom3DGrid Constructor Overload List | Custom3DGrid Class | Custom3DGrid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DGrid Constructor

public Custom3DGrid()

See Also

Custom3DGrid Constructor Overload List | Custom3DGrid Class | Custom3DGrid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DGridEvents

Steema.TeeChart.Styles.Custom3DGrid Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
GetYValue | Occurs when the Surface Series needs to recreate the grid of values.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Custom3DGrid Class | Steema.TeeChart.Styles Namespace


GetYValue

Steema.TeeChart.Styles.Custom3DGrid.GetYValue Event

Occurs when the Surface Series needs to recreate the grid of values.
public GetYValueEventHandler  GetYValue

See Also

Custom3DGrid Class | Custom3DGrid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DGridFields

Steema.TeeChart.Styles.Custom3DGrid Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
ReuseGridIndex |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Custom3DGrid Class | Steema.TeeChart.Styles Namespace


ReuseGridIndex

Steema.TeeChart.Styles.Custom3DGrid.ReuseGridIndex Field

public Boolean ReuseGridIndex

See Also

Custom3DGrid Class | Custom3DGrid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DGridMethods

Steema.TeeChart.Styles.Custom3DGrid Methods

Public Methods

Add (inherited from Custom3D) | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear | Deletes all Series values.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked (inherited from Series) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
CreateValues | Makes a Surface grid of NumX by NumZ dimensions.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillGridIndex |
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom3DPalette) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Custom3DPalette) | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Custom3D) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery (inherited from Custom3DPalette) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Custom3DPalette) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Custom3DGrid Class | Steema.TeeChart.Styles Namespace


Clear

Steema.TeeChart.Styles.Custom3DGrid.Clear Method

Deletes all Series values.
public override Void Clear()

See Also

Custom3DGrid Class | Custom3DGrid Members | Steema.TeeChart.Styles Namespace


CreateValues

Steema.TeeChart.Styles.Custom3DGrid.CreateValues Method

Makes a Surface grid of NumX by NumZ dimensions.
public Void CreateValues(Int32 numX,
     Int32 numZ)

See Also

Custom3DGrid Class | Custom3DGrid Members | Steema.TeeChart.Styles Namespace


FillGridIndex

Steema.TeeChart.Styles.Custom3DGrid.FillGridIndex Method

Overload List

public Void FillGridIndex(System.Int32)
public Void FillGridIndex()

See Also

Custom3DGrid Class | Custom3DGrid Members | Steema.TeeChart.Styles Namespace


FillGridIndex

Steema.TeeChart.Styles.Custom3DGrid.FillGridIndex Method

public Void FillGridIndex()

See Also

FillGridIndex Overload List | Custom3DGrid Class | Custom3DGrid Members | Steema.TeeChart.Styles Namespace


FillGridIndex

Steema.TeeChart.Styles.Custom3DGrid.FillGridIndex Method

public Void FillGridIndex(Int32 StartIndex)

See Also

FillGridIndex Overload List | Custom3DGrid Class | Custom3DGrid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DGridProperties

Steema.TeeChart.Styles.Custom3DGrid Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IrregularGrid | Determine if X and Z values are equi-distant or not.
Item | A two dimension array property for the easy access to series cell values.
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
NumXValues | Determines the Surface's horizontal size in number of points.
NumZValues | Determines the Surface's depth size in number of points.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

Custom3DGrid Class | Steema.TeeChart.Styles Namespace


IrregularGrid

Steema.TeeChart.Styles.Custom3DGrid.IrregularGrid Property

Determine if X and Z values are equi-distant or not.
public Boolean IrregularGrid {get; set;}

See Also

Custom3DGrid Class | Custom3DGrid Members | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.Custom3DGrid.Item Property

A two dimension array property for the easy access to series cell values.
public Int32 Item(Int32 x,
     Int32 z) {get; set;}

See Also

Custom3DGrid Class | Custom3DGrid Members | Steema.TeeChart.Styles Namespace


NumXValues

Steema.TeeChart.Styles.Custom3DGrid.NumXValues Property

Determines the Surface's horizontal size in number of points.
public Int32 NumXValues {get; set;}

See Also

Custom3DGrid Class | Custom3DGrid Members | Steema.TeeChart.Styles Namespace


NumZValues

Steema.TeeChart.Styles.Custom3DGrid.NumZValues Property

Determines the Surface's depth size in number of points.
public Int32 NumZValues {get; set;}

See Also

Custom3DGrid Class | Custom3DGrid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DGrid.GetYValueEventArgs

Steema.TeeChart.Styles.Custom3DGrid.GetYValueEventArgs Class

The Event Data for the GetYValue event.

For a list of all members of this type, see GetYValueEventArgs Members

System.Object
System.EventArgs
public class GetYValueEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

GetYValueEventArgs members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DGrid.GetYValueEventArgsMembers

Steema.TeeChart.Styles.Custom3DGrid.GetYValueEventArgs all Members

GetYValueEventArgs overview

Public Properties

Value | The series point YValue.
X | The series point XValue.
Z | The series point ZValue.

Constructors

Steema.TeeChart.Styles.Custom3DGrid.GetYValueEventArgs..ctor

See Also

GetYValueEventArgs Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DGrid.GetYValueEventArgsProperties

Steema.TeeChart.Styles.Custom3DGrid.GetYValueEventArgs Properties

Public Properties

Value | The series point YValue.
X | The series point XValue.
Z | The series point ZValue.

See Also

GetYValueEventArgs Class | Steema.TeeChart.Styles Namespace


Value

Steema.TeeChart.Styles.Custom3DGrid+GetYValueEventArgs.Value Property

The series point YValue.
public Double Value {get; set;}

See Also

GetYValueEventArgs Class | GetYValueEventArgs Members | Steema.TeeChart.Styles Namespace


X

Steema.TeeChart.Styles.Custom3DGrid+GetYValueEventArgs.X Property

The series point XValue.
public Int32 X {get;}

See Also

GetYValueEventArgs Class | GetYValueEventArgs Members | Steema.TeeChart.Styles Namespace


Z

Steema.TeeChart.Styles.Custom3DGrid+GetYValueEventArgs.Z Property

The series point ZValue.
public Int32 Z {get;}

See Also

GetYValueEventArgs Class | GetYValueEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DGrid+GetYValueEventArgs Constructor

public Custom3DGrid+GetYValueEventArgs(Int32 X,
     Int32 Z,
     Double Value)

See Also

GetYValueEventArgs Class | GetYValueEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DGrid.GetYValueEventHandler

Steema.TeeChart.Styles.Custom3DGrid.GetYValueEventHandler Delegate

The Delegate for the GetYValue event.
public delegate GetYValueEventHandler (Series sender,
     GetYValueEventArgs e)

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DPalette

Steema.TeeChart.Styles.Custom3DPalette Class

Custom3DPalette Series Style.

For a list of all members of this type, see Custom3DPalette Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
public class Custom3DPalette : Custom3D , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Custom3DPalette members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DPaletteMembers

Steema.TeeChart.Styles.Custom3DPalette all Members

Custom3DPalette overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Custom3D) | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
ClearPalette | Deletes all Palette information.
Clicked (inherited from Series) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Custom3D) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
BlueFactor | Defines the alpha value for the Blue of the ARGB component.
Brush | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndColor | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
GreenFactor | Defines the alpha value for the Green of the ARGB component.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Custom3D) | XYZ Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Palette | Access the Color Palette list
PaletteMin | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange | Defines the range of colour in the default color Palette.
PaletteStep | The interval amount between palette Colors.
PaletteSteps | Sets the number of entries in the default color Palette.
PaletteStyle | Selects Pale or Strong colour palette.
Pen | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedFactor | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartColor | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange | Sets gradient color palette to fill Surface polygons.
UsePalette | Sets multi-color palette to fill Surface polygons.
UsePaletteMin | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

Custom3DPalette Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DPalette Constructor

Overload List

public Custom3DPalette(Steema.TeeChart.Chart)
public Custom3DPalette()

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DPalette Constructor

public Custom3DPalette()

See Also

Custom3DPalette Constructor Overload List | Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DPalette Constructor

public Custom3DPalette(Chart c)

See Also

Custom3DPalette Constructor Overload List | Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DPaletteEvents

Steema.TeeChart.Styles.Custom3DPalette Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Custom3DPalette Class | Steema.TeeChart.Styles Namespace


GetValueColor

Steema.TeeChart.Styles.Custom3DPalette.GetValueColor Event

Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
public GetColorEventHandler  GetValueColor

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DPaletteFields

Steema.TeeChart.Styles.Custom3DPalette Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Custom3DPalette Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DPaletteMethods

Steema.TeeChart.Styles.Custom3DPalette Methods

Public Methods

Add (inherited from Custom3D) | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
ClearPalette | Deletes all Palette information.
Clicked (inherited from Series) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Custom3D) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Custom3DPalette Class | Steema.TeeChart.Styles Namespace


AddPalette

Steema.TeeChart.Styles.Custom3DPalette.AddPalette Method

Add Color to Palette list
public Int32 AddPalette(Double aValue,
     Color aColor)

Parameters

aValue
Data Value
aColor
Color

Return Value

New Palette Color Index

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


ClearPalette

Steema.TeeChart.Styles.Custom3DPalette.ClearPalette Method

Deletes all Palette information.
public Void ClearPalette()

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


GalleryChanged3D

Steema.TeeChart.Styles.Custom3DPalette.GalleryChanged3D Method

public override Void GalleryChanged3D(Boolean Is3D)

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


LegendString

Steema.TeeChart.Styles.Custom3DPalette.LegendString Method

Returns LegendString for LegendIndexth item.
public override String LegendString(Int32 legendIndex,
     LegendTextStyles legendTextStyle)

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.Custom3DPalette.PrepareForGallery Method

public override Void PrepareForGallery(Boolean isEnabled)

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.Custom3DPalette.SetSubGallery Method

public override Void SetSubGallery(Int32 index)

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


ValueColor

Steema.TeeChart.Styles.Custom3DPalette.ValueColor Method

Returns the colour of the index point.
public override Color ValueColor(Int32 valueIndex)

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DPaletteProperties

Steema.TeeChart.Styles.Custom3DPalette Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
BlueFactor | Defines the alpha value for the Blue of the ARGB component.
Brush | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndColor | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
GreenFactor | Defines the alpha value for the Green of the ARGB component.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Custom3D) | XYZ Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Palette | Access the Color Palette list
PaletteMin | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange | Defines the range of colour in the default color Palette.
PaletteStep | The interval amount between palette Colors.
PaletteSteps | Sets the number of entries in the default color Palette.
PaletteStyle | Selects Pale or Strong colour palette.
Pen | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedFactor | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartColor | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange | Sets gradient color palette to fill Surface polygons.
UsePalette | Sets multi-color palette to fill Surface polygons.
UsePaletteMin | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

Custom3DPalette Class | Steema.TeeChart.Styles Namespace


BlueFactor

Steema.TeeChart.Styles.Custom3DPalette.BlueFactor Property

Defines the alpha value for the Blue of the ARGB component.
public Double BlueFactor {get; set;}

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


Brush

Steema.TeeChart.Styles.Custom3DPalette.Brush Property

Defines the Brush to fill the Surface polygons.
public ChartBrush Brush {get; set;}

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


EndColor

Steema.TeeChart.Styles.Custom3DPalette.EndColor Property

Determines the last Range palette color.
public Color EndColor {get; set;}

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


GreenFactor

Steema.TeeChart.Styles.Custom3DPalette.GreenFactor Property

Defines the alpha value for the Green of the ARGB component.
public Double GreenFactor {get; set;}

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


LegendEvery

Steema.TeeChart.Styles.Custom3DPalette.LegendEvery Property

public Int32 LegendEvery {get; set;}

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


MidColor

Steema.TeeChart.Styles.Custom3DPalette.MidColor Property

Determines the middle Range palette color.
public Color MidColor {get; set;}

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


Palette

Steema.TeeChart.Styles.Custom3DPalette.Palette Property

Access the Color Palette list
public List<GridPalette> Palette {get;}

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


PaletteMin

Steema.TeeChart.Styles.Custom3DPalette.PaletteMin Property

The starting value used to calculate the color palette when UsePaletteMin is true.
public Double PaletteMin {get; set;}

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


PaletteRange

Steema.TeeChart.Styles.Custom3DPalette.PaletteRange Property

Defines the range of colour in the default color Palette.
public Double PaletteRange {get; set;}

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


PaletteStep

Steema.TeeChart.Styles.Custom3DPalette.PaletteStep Property

The interval amount between palette Colors.
public Double PaletteStep {get; set;}

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


PaletteSteps

Steema.TeeChart.Styles.Custom3DPalette.PaletteSteps Property

Sets the number of entries in the default color Palette.
public Int32 PaletteSteps {get; set;}

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


PaletteStyle

Steema.TeeChart.Styles.Custom3DPalette.PaletteStyle Property

Selects Pale or Strong colour palette.
public PaletteStyles PaletteStyle {get; set;}

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


Pen

Steema.TeeChart.Styles.Custom3DPalette.Pen Property

Defines the Pen to draw the Surface polygons.
public ChartPen Pen {get; set;}

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


RedFactor

Steema.TeeChart.Styles.Custom3DPalette.RedFactor Property

Defines the alpha value for the Red of the ARGB component.
public Double RedFactor {get; set;}

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


StartColor

Steema.TeeChart.Styles.Custom3DPalette.StartColor Property

Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
public Color StartColor {get; set;}

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


UseColorRange

Steema.TeeChart.Styles.Custom3DPalette.UseColorRange Property

Sets gradient color palette to fill Surface polygons.
public Boolean UseColorRange {get; set;}

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


UsePalette

Steema.TeeChart.Styles.Custom3DPalette.UsePalette Property

Sets multi-color palette to fill Surface polygons.
public Boolean UsePalette {get; set;}

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


UsePaletteMin

Steema.TeeChart.Styles.Custom3DPalette.UsePaletteMin Property

Set to True to force the color palette to start at UsePaletteMin property value.
public Boolean UsePaletteMin {get; set;}

See Also

Custom3DPalette Class | Custom3DPalette Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DPalette.GetColorEventArgs

Steema.TeeChart.Styles.Custom3DPalette.GetColorEventArgs Class

The Event Data for the GetValueColor event.

For a list of all members of this type, see GetColorEventArgs Members

System.Object
System.EventArgs
public class GetColorEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

GetColorEventArgs members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DPalette.GetColorEventArgsMembers

Steema.TeeChart.Styles.Custom3DPalette.GetColorEventArgs all Members

GetColorEventArgs overview

Public Properties

Color | The color of the series point.
ValueIndex | The Index of the value in the series ValueList.

Constructors

Steema.TeeChart.Styles.Custom3DPalette.GetColorEventArgs..ctor

See Also

GetColorEventArgs Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DPalette.GetColorEventArgsProperties

Steema.TeeChart.Styles.Custom3DPalette.GetColorEventArgs Properties

Public Properties

Color | The color of the series point.
ValueIndex | The Index of the value in the series ValueList.

See Also

GetColorEventArgs Class | Steema.TeeChart.Styles Namespace


Color

Steema.TeeChart.Styles.Custom3DPalette+GetColorEventArgs.Color Property

The color of the series point.
public Color Color {get; set;}

See Also

GetColorEventArgs Class | GetColorEventArgs Members | Steema.TeeChart.Styles Namespace


ValueIndex

Steema.TeeChart.Styles.Custom3DPalette+GetColorEventArgs.ValueIndex Property

The Index of the value in the series ValueList.
public Int32 ValueIndex {get;}

See Also

GetColorEventArgs Class | GetColorEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DPalette+GetColorEventArgs Constructor

public Custom3DPalette+GetColorEventArgs(Int32 valueIndex,
     Color color)

See Also

GetColorEventArgs Class | GetColorEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Custom3DPalette.GetColorEventHandler

Steema.TeeChart.Styles.Custom3DPalette.GetColorEventHandler Delegate

The Delegate for the GetValueColor event.
public delegate GetColorEventHandler (Series sender,
     GetColorEventArgs e)

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBar

Steema.TeeChart.Styles.CustomBar Class

Custom Bar Series.

For a list of all members of this type, see CustomBar Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class CustomBar : Series , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

CustomBar members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBarMembers

Steema.TeeChart.Styles.CustomBar all Members

CustomBar overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetBarStyle | Occurs when series bars are painted.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BarMargin | Returns side margin amount in pixels.
BarRectangle | For internal use.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawBar |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointOrigin | For internal use.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoMarkPosition | Repositions Marks on BarSeries to prevent overlapping.
BarBounds | Coordinates of current Bar point being displayed.
BarStyle | Defines the Bar shape used to draw Bars.
BevelSize | Amount in pixels of the bar bevel. Used only when BarStyle property is Bevel (only in 2D and 3D orthogonal display modes)
Brush | Defines the Brush used to fill Bars.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBarWidth |
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D | Darkens sides of bars to enhance 3D effect.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthPercent | Defines the percentage, from 0 to 100, that the bars will need in the "Z" depth space direction.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient | Defines the color Gradient used to fill the Bars.
GradientRelative | When Gradient is Visible, calculates Colors based on highest bar.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksLocation | Sets the alignment of the Mark into the Bars.
MarksOnBar | Sets a postition of the Marks into the Bars.
MiddleZ (inherited from Series) | For internal use.
MultiBar | Determines how multiple BarSeries will be displayed in the same Chart.
NumGallerySeries (inherited from Series) | For internal use.
OffsetPercent | Sets the Bar displacement as percent of Bar size.
Origin | Sets the common bottom value used for all Bar points.
Pen | Pen used to draw the Bar rectangles.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow | Defines the Shadow used to draw behind the Bars.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideMargins | Sets a margin between Chart rectangle and Bars.
StackGroup | Allows stacking independent Series within the same Chart.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickLines | Pen used to draw "tick" lines across each bar.
Title (inherited from Series) | Series description to show in Legend and editors.
UseOrigin | Allows Bars to be bottom aligned to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin | System.Obsolete: Please use Origin property.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

CustomBar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBar Constructor

Overload List

public CustomBar(Steema.TeeChart.Chart)
public CustomBar()

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBar Constructor

public CustomBar()

See Also

CustomBar Constructor Overload List | CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBar Constructor

public CustomBar(Chart c)

See Also

CustomBar Constructor Overload List | CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBarEvents

Steema.TeeChart.Styles.CustomBar Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetBarStyle | Occurs when series bars are painted.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

CustomBar Class | Steema.TeeChart.Styles Namespace


GetBarStyle

Steema.TeeChart.Styles.CustomBar.GetBarStyle Event

Occurs when series bars are painted.
public GetBarStyleEventHandler  GetBarStyle

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBarFields

Steema.TeeChart.Styles.CustomBar Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

CustomBar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBarMethods

Steema.TeeChart.Styles.CustomBar Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BarMargin | Returns side margin amount in pixels.
BarRectangle | For internal use.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawBar |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointOrigin | For internal use.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

CustomBar Class | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.CustomBar.AssignFormat Method

Overload List

public override Void AssignFormat(Steema.TeeChart.Styles.Series, Steema.TeeChart.Styles.Series)

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.CustomBar.AssignFormat Method

public override Void AssignFormat(Series source,
     Series target)

See Also

AssignFormat Overload List | CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


BarMargin

Steema.TeeChart.Styles.CustomBar.BarMargin Method

Returns side margin amount in pixels.
public Int32 BarMargin()

Return Value

Side margin amount in pixels.

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


BarRectangle

Steema.TeeChart.Styles.CustomBar.BarRectangle Method

Overload List

For internal use.

public Void BarRectangle(System.Drawing.Color, System.Drawing.Rectangle)

For internal use.

public Void BarRectangle(System.Drawing.Color, System.Int32, System.Int32, System.Int32, System.Int32)

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


BarRectangle

Steema.TeeChart.Styles.CustomBar.BarRectangle Method

For internal use.
public Void BarRectangle(Color barColor,
     Int32 aLeft,
     Int32 aTop,
     Int32 aRight,
     Int32 aBottom)

See Also

BarRectangle Overload List | CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


BarRectangle

Steema.TeeChart.Styles.CustomBar.BarRectangle Method

For internal use.
public Void BarRectangle(Color barColor,
     Rectangle r)

See Also

BarRectangle Overload List | CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.CustomBar.Clicked Method

Overload List

Returns the ValueIndex of the "clicked" point in the Series.

public override Int32 Clicked(System.Int32, System.Int32)

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.CustomBar.Clicked Method

Returns the ValueIndex of the "clicked" point in the Series.
public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


DrawBar

Steema.TeeChart.Styles.CustomBar.DrawBar Method

public abstract Void DrawBar(Int32 barIndex,
     Int32 startPos,
     Int32 endPos)

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.CustomBar.DrawValue Method

Called internally. Draws the "ValueIndex" point of the Series.
public override Void DrawValue(Int32 valueIndex)

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


DrawValuesForward

Steema.TeeChart.Styles.CustomBar.DrawValuesForward Method

public override Boolean DrawValuesForward()

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


PointOrigin

Steema.TeeChart.Styles.CustomBar.PointOrigin Method

For internal use.
public abstract Double PointOrigin(Int32 valueIndex,
     Boolean sumAll)

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.CustomBar.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.CustomBar.SetSubGallery Method

public override Void SetSubGallery(Int32 index)

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBarProperties

Steema.TeeChart.Styles.CustomBar Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoMarkPosition | Repositions Marks on BarSeries to prevent overlapping.
BarBounds | Coordinates of current Bar point being displayed.
BarStyle | Defines the Bar shape used to draw Bars.
BevelSize | Amount in pixels of the bar bevel. Used only when BarStyle property is Bevel (only in 2D and 3D orthogonal display modes)
Brush | Defines the Brush used to fill Bars.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBarWidth |
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D | Darkens sides of bars to enhance 3D effect.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthPercent | Defines the percentage, from 0 to 100, that the bars will need in the "Z" depth space direction.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient | Defines the color Gradient used to fill the Bars.
GradientRelative | When Gradient is Visible, calculates Colors based on highest bar.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksLocation | Sets the alignment of the Mark into the Bars.
MarksOnBar | Sets a postition of the Marks into the Bars.
MiddleZ (inherited from Series) | For internal use.
MultiBar | Determines how multiple BarSeries will be displayed in the same Chart.
NumGallerySeries (inherited from Series) | For internal use.
OffsetPercent | Sets the Bar displacement as percent of Bar size.
Origin | Sets the common bottom value used for all Bar points.
Pen | Pen used to draw the Bar rectangles.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow | Defines the Shadow used to draw behind the Bars.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideMargins | Sets a margin between Chart rectangle and Bars.
StackGroup | Allows stacking independent Series within the same Chart.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickLines | Pen used to draw "tick" lines across each bar.
Title (inherited from Series) | Series description to show in Legend and editors.
UseOrigin | Allows Bars to be bottom aligned to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin | System.Obsolete: Please use Origin property.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

CustomBar Class | Steema.TeeChart.Styles Namespace


AutoMarkPosition

Steema.TeeChart.Styles.CustomBar.AutoMarkPosition Property

Repositions Marks on BarSeries to prevent overlapping.
public Boolean AutoMarkPosition {get; set;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


BarBounds

Steema.TeeChart.Styles.CustomBar.BarBounds Property

Coordinates of current Bar point being displayed.
public Rectangle BarBounds {get;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


BarStyle

Steema.TeeChart.Styles.CustomBar.BarStyle Property

Defines the Bar shape used to draw Bars.
public BarStyles BarStyle {get; set;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


BevelSize

Steema.TeeChart.Styles.CustomBar.BevelSize Property

Amount in pixels of the bar bevel. Used only when BarStyle property is Bevel (only in 2D and 3D orthogonal display modes)
public Int32 BevelSize {get; set;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


Brush

Steema.TeeChart.Styles.CustomBar.Brush Property

Defines the Brush used to fill Bars.
public ChartBrush Brush {get;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


ConePercent

Steema.TeeChart.Styles.CustomBar.ConePercent Property

public Int32 ConePercent {get; set;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


CustomBarWidth

Steema.TeeChart.Styles.CustomBar.CustomBarWidth Property

public Int32 CustomBarWidth {get; set;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


Dark3D

Steema.TeeChart.Styles.CustomBar.Dark3D Property

Darkens sides of bars to enhance 3D effect.
public Boolean Dark3D {get; set;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


DepthPercent

Steema.TeeChart.Styles.CustomBar.DepthPercent Property

Defines the percentage, from 0 to 100, that the bars will need in the "Z" depth space direction.
public Int32 DepthPercent {get; set;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


Gradient

Steema.TeeChart.Styles.CustomBar.Gradient Property

Defines the color Gradient used to fill the Bars.
public Gradient Gradient {get; set;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


GradientRelative

Steema.TeeChart.Styles.CustomBar.GradientRelative Property

When Gradient is Visible, calculates Colors based on highest bar.
public Boolean GradientRelative {get; set;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


MarksLocation

Steema.TeeChart.Styles.CustomBar.MarksLocation Property

Sets the alignment of the Mark into the Bars.
public MarksLocation MarksLocation {get; set;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


MarksOnBar

Steema.TeeChart.Styles.CustomBar.MarksOnBar Property

Sets a postition of the Marks into the Bars.
public Boolean MarksOnBar {get; set;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


MultiBar

Steema.TeeChart.Styles.CustomBar.MultiBar Property

Determines how multiple BarSeries will be displayed in the same Chart.
public MultiBars MultiBar {get; set;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


OffsetPercent

Steema.TeeChart.Styles.CustomBar.OffsetPercent Property

Sets the Bar displacement as percent of Bar size.
public Int32 OffsetPercent {get; set;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


Origin

Steema.TeeChart.Styles.CustomBar.Origin Property

Sets the common bottom value used for all Bar points.
public Double Origin {get; set;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


Pen

Steema.TeeChart.Styles.CustomBar.Pen Property

Pen used to draw the Bar rectangles.
public ChartPen Pen {get;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


Shadow

Steema.TeeChart.Styles.CustomBar.Shadow Property

Defines the Shadow used to draw behind the Bars.
public Shadow Shadow {get; set;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


SideMargins

Steema.TeeChart.Styles.CustomBar.SideMargins Property

Sets a margin between Chart rectangle and Bars.
public Boolean SideMargins {get; set;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


StackGroup

Steema.TeeChart.Styles.CustomBar.StackGroup Property

Allows stacking independent Series within the same Chart.
public Int32 StackGroup {get; set;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


TickLines

Steema.TeeChart.Styles.CustomBar.TickLines Property

Pen used to draw "tick" lines across each bar.
public ChartPen TickLines {get;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


UseOrigin

Steema.TeeChart.Styles.CustomBar.UseOrigin Property

Allows Bars to be bottom aligned to the Origin property value.
public Boolean UseOrigin {get; set;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


YOrigin

Steema.TeeChart.Styles.CustomBar.YOrigin Property

System.Obsolete: Please use Origin property.
public Double YOrigin {get; set;}

See Also

CustomBar Class | CustomBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBar.GetBarStyleEventArgs

Steema.TeeChart.Styles.CustomBar.GetBarStyleEventArgs Class

The Event Data for the GetBarStyle event.

For a list of all members of this type, see GetBarStyleEventArgs Members

System.Object
System.EventArgs
public class GetBarStyleEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

GetBarStyleEventArgs members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBar.GetBarStyleEventArgsMembers

Steema.TeeChart.Styles.CustomBar.GetBarStyleEventArgs all Members

GetBarStyleEventArgs overview

Public Properties

Style | The Bar series BarStyle.
ValueIndex | The Index of the value in the series ValueList.

Constructors

Steema.TeeChart.Styles.CustomBar.GetBarStyleEventArgs..ctor

See Also

GetBarStyleEventArgs Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBar.GetBarStyleEventArgsProperties

Steema.TeeChart.Styles.CustomBar.GetBarStyleEventArgs Properties

Public Properties

Style | The Bar series BarStyle.
ValueIndex | The Index of the value in the series ValueList.

See Also

GetBarStyleEventArgs Class | Steema.TeeChart.Styles Namespace


Style

Steema.TeeChart.Styles.CustomBar+GetBarStyleEventArgs.Style Property

The Bar series BarStyle.
public BarStyles Style {get; set;}

See Also

GetBarStyleEventArgs Class | GetBarStyleEventArgs Members | Steema.TeeChart.Styles Namespace


ValueIndex

Steema.TeeChart.Styles.CustomBar+GetBarStyleEventArgs.ValueIndex Property

The Index of the value in the series ValueList.
public Int32 ValueIndex {get;}

See Also

GetBarStyleEventArgs Class | GetBarStyleEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBar+GetBarStyleEventArgs Constructor

public CustomBar+GetBarStyleEventArgs(Int32 valueIndex,
     BarStyles style)

See Also

GetBarStyleEventArgs Class | GetBarStyleEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBar.GetBarStyleEventHandler

Steema.TeeChart.Styles.CustomBar.GetBarStyleEventHandler Delegate

The Delegate for the GetBarStyle event.
public delegate GetBarStyleEventHandler (CustomBar sender,
     GetBarStyleEventArgs e)

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBox

Steema.TeeChart.Styles.CustomBox Class

CustomBox Series.

For a list of all members of this type, see CustomBox Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Points
public class CustomBox : Points , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

CustomBox members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBoxMembers

Steema.TeeChart.Styles.CustomBox all Members

CustomBox overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add | Add x-displacement position and values for Box valueset.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
ReconstructFromData | Reconstructs the box plot from series data
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AdjacentPoint1 | Read from AdjacentPoint1 to get SampleValues lower adjacent point limit. Write to AdjacentPoint1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
AdjacentPoint3 | Read from AdjacentPoint3 to get SampleValues upper adjacent point limit. Write to AdjacentPoint3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
Box | Controls the appearance of CustomBoxSeries box.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Points) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
ExtrOut | Controls the appearance of the extreme range of outer points.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InnerFence1 | Read from InnerFence1 to get SampleValues lower inner fence. Write to InnerFence1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
InnerFence3 | Read from InnerFence3 to get SampleValues upper inner fence. Write to InnerFence3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
Median | Read from Median to get SampleValues median value. Write to Median to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
MedianPen | Defines the Pen to draw the median line.
MiddleZ (inherited from Series) | For internal use.
MildOut | Controls the appearance of the mid range of outer points.
NumGallerySeries (inherited from Series) | For internal use.
OuterFence1 | Read from OuterFence1 to get SampleValues lower outer fence. Write to OuterFence1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
OuterFence3 | Read from OuterFence3 to get SampleValues upper outer fence. Write to OuterFence3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
Position | Specifies the position of box series.
Quartile1 | Read from Quartile1 to get SampleValues first quartile. Write to Quartile1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
Quartile3 | Read from Quartile3 to get SampleValues third quartile. Write to Quartile3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
SampleValues | Use SampleValues property to get access to the values of Series.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UseCustomValues | Set the UseCustomValues property to true if you want to override internal algorithm to construct a box plot.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
WhiskerLength | Defines the whisker length as a function of the inter-quartike range (IQR).
WhiskerPen | Defines the Pen to draw the whisker lines.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

CustomBox Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBox Constructor

Overload List

public CustomBox()
public CustomBox(Steema.TeeChart.Chart)

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBox Constructor

public CustomBox(Chart c)

See Also

CustomBox Constructor Overload List | CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBox Constructor

public CustomBox()

See Also

CustomBox Constructor Overload List | CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBoxEvents

Steema.TeeChart.Styles.CustomBox Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

CustomBox Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBoxFields

Steema.TeeChart.Styles.CustomBox Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

CustomBox Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBoxMethods

Steema.TeeChart.Styles.CustomBox Methods

Public Methods

Add | Add x-displacement position and values for Box valueset.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
ReconstructFromData | Reconstructs the box plot from series data
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

CustomBox Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomBox.Add Method

Overload List

Add x-displacement position and values for Box valueset.

public Void Add(System.Double, System.Double[])

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomBox.Add Method

Add x-displacement position and values for Box valueset.
public Void Add(Double aPosition,
     Double[] values)

See Also

Add Overload List | CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


ClickedPointer

Steema.TeeChart.Styles.CustomBox.ClickedPointer Method

Overload List

public override Boolean ClickedPointer(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


ClickedPointer

Steema.TeeChart.Styles.CustomBox.ClickedPointer Method

public override Boolean ClickedPointer(Int32 valueIndex,
     Int32 tmpX,
     Int32 tmpY,
     Int32 x,
     Int32 y)

See Also

ClickedPointer Overload List | CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.CustomBox.Draw Method

public override Void Draw()

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.CustomBox.DrawValue Method

Draws the "ValueIndex" point of the Series.
public override Void DrawValue(Int32 index)

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.CustomBox.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


ReconstructFromData

Steema.TeeChart.Styles.CustomBox.ReconstructFromData Method

Reconstructs the box plot from series data
public Void ReconstructFromData()

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomBoxProperties

Steema.TeeChart.Styles.CustomBox Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AdjacentPoint1 | Read from AdjacentPoint1 to get SampleValues lower adjacent point limit. Write to AdjacentPoint1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
AdjacentPoint3 | Read from AdjacentPoint3 to get SampleValues upper adjacent point limit. Write to AdjacentPoint3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
Box | Controls the appearance of CustomBoxSeries box.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Points) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
ExtrOut | Controls the appearance of the extreme range of outer points.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InnerFence1 | Read from InnerFence1 to get SampleValues lower inner fence. Write to InnerFence1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
InnerFence3 | Read from InnerFence3 to get SampleValues upper inner fence. Write to InnerFence3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
Median | Read from Median to get SampleValues median value. Write to Median to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
MedianPen | Defines the Pen to draw the median line.
MiddleZ (inherited from Series) | For internal use.
MildOut | Controls the appearance of the mid range of outer points.
NumGallerySeries (inherited from Series) | For internal use.
OuterFence1 | Read from OuterFence1 to get SampleValues lower outer fence. Write to OuterFence1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
OuterFence3 | Read from OuterFence3 to get SampleValues upper outer fence. Write to OuterFence3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
Position | Specifies the position of box series.
Quartile1 | Read from Quartile1 to get SampleValues first quartile. Write to Quartile1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
Quartile3 | Read from Quartile3 to get SampleValues third quartile. Write to Quartile3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
SampleValues | Use SampleValues property to get access to the values of Series.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UseCustomValues | Set the UseCustomValues property to true if you want to override internal algorithm to construct a box plot.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
WhiskerLength | Defines the whisker length as a function of the inter-quartike range (IQR).
WhiskerPen | Defines the Pen to draw the whisker lines.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

CustomBox Class | Steema.TeeChart.Styles Namespace


AdjacentPoint1

Steema.TeeChart.Styles.CustomBox.AdjacentPoint1 Property

Read from AdjacentPoint1 to get SampleValues lower adjacent point limit. Write to AdjacentPoint1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
public Double AdjacentPoint1 {get; set;}

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


AdjacentPoint3

Steema.TeeChart.Styles.CustomBox.AdjacentPoint3 Property

Read from AdjacentPoint3 to get SampleValues upper adjacent point limit. Write to AdjacentPoint3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
public Double AdjacentPoint3 {get; set;}

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


Box

Steema.TeeChart.Styles.CustomBox.Box Property

Controls the appearance of CustomBoxSeries box.
public SeriesPointer Box {get;}

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


ExtrOut

Steema.TeeChart.Styles.CustomBox.ExtrOut Property

Controls the appearance of the extreme range of outer points.
public SeriesPointer ExtrOut {get;}

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


InnerFence1

Steema.TeeChart.Styles.CustomBox.InnerFence1 Property

Read from InnerFence1 to get SampleValues lower inner fence. Write to InnerFence1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
public Double InnerFence1 {get; set;}

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


InnerFence3

Steema.TeeChart.Styles.CustomBox.InnerFence3 Property

Read from InnerFence3 to get SampleValues upper inner fence. Write to InnerFence3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
public Double InnerFence3 {get; set;}

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


Median

Steema.TeeChart.Styles.CustomBox.Median Property

Read from Median to get SampleValues median value. Write to Median to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
public Double Median {get; set;}

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


MedianPen

Steema.TeeChart.Styles.CustomBox.MedianPen Property

Defines the Pen to draw the median line.
public ChartPen MedianPen {get;}

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


MildOut

Steema.TeeChart.Styles.CustomBox.MildOut Property

Controls the appearance of the mid range of outer points.
public SeriesPointer MildOut {get;}

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


OuterFence1

Steema.TeeChart.Styles.CustomBox.OuterFence1 Property

Read from OuterFence1 to get SampleValues lower outer fence. Write to OuterFence1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
public Double OuterFence1 {get; set;}

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


OuterFence3

Steema.TeeChart.Styles.CustomBox.OuterFence3 Property

Read from OuterFence3 to get SampleValues upper outer fence. Write to OuterFence3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
public Double OuterFence3 {get; set;}

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


Position

Steema.TeeChart.Styles.CustomBox.Position Property

Specifies the position of box series.
public Double Position {get; set;}

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


Quartile1

Steema.TeeChart.Styles.CustomBox.Quartile1 Property

Read from Quartile1 to get SampleValues first quartile. Write to Quartile1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
public Double Quartile1 {get; set;}

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


Quartile3

Steema.TeeChart.Styles.CustomBox.Quartile3 Property

Read from Quartile3 to get SampleValues third quartile. Write to Quartile3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
public Double Quartile3 {get; set;}

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


SampleValues

Steema.TeeChart.Styles.CustomBox.SampleValues Property

Use SampleValues property to get access to the values of Series.
public ValueList SampleValues {get;}

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


UseCustomValues

Steema.TeeChart.Styles.CustomBox.UseCustomValues Property

Set the UseCustomValues property to true if you want to override internal algorithm to construct a box plot.
public Boolean UseCustomValues {get; set;}

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


WhiskerLength

Steema.TeeChart.Styles.CustomBox.WhiskerLength Property

Defines the whisker length as a function of the inter-quartike range (IQR).
public Double WhiskerLength {get; set;}

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


WhiskerPen

Steema.TeeChart.Styles.CustomBox.WhiskerPen Property

Defines the Pen to draw the whisker lines.
public ChartPen WhiskerPen {get;}

See Also

CustomBox Class | CustomBox Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomError

Steema.TeeChart.Styles.CustomError Class

CustomErrorSeries Series.

For a list of all members of this type, see CustomError Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomBar
Steema.TeeChart.Styles.Bar
public class CustomError : Bar , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

CustomError members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomErrorMembers

Steema.TeeChart.Styles.CustomError all Members

CustomError overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetBarStyle (inherited from CustomBar) | Occurs when series bars are painted.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add | Adds a new Error Bar point in selected color and with label.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddValue | Adds a new Error Bar point to the Series.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomBar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BarMargin (inherited from CustomBar) | Returns side margin amount in pixels.
BarRectangle (inherited from CustomBar) | For internal use.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Bar) | Returns the Screen X pixel coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Bar) | Returns the Screen Y pixel coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawBar | Displays an ErrorBar point ( BarIndex point ) using the Start and End pixel coordinates.
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from CustomBar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetOriginPos (inherited from Bar) | Returns the corresponding screen pixels coordinate of the leftmost horizontal bar edge.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Bar) | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Bar) | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointOrigin (inherited from CustomBar) | For internal use.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from CustomBar) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoMarkPosition (inherited from CustomBar) | Repositions Marks on BarSeries to prevent overlapping.
BarBounds (inherited from CustomBar) | Coordinates of current Bar point being displayed.
BarStyle (inherited from CustomBar) | Defines the Bar shape used to draw Bars.
BarWidthPercent (inherited from Bar) | Determines the percent of total Bar width used.
BevelSize (inherited from CustomBar) | Amount in pixels of the bar bevel. Used only when BarStyle property is Bevel (only in 2D and 3D orthogonal display modes)
Brush (inherited from CustomBar) | Defines the Brush used to fill Bars.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent (inherited from CustomBar) |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBarWidth (inherited from CustomBar) |
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from CustomBar) | Darkens sides of bars to enhance 3D effect.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthPercent (inherited from CustomBar) | Defines the percentage, from 0 to 100, that the bars will need in the "Z" depth space direction.
Description (inherited from Bar) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
ErrorPen | Defines Pen to draw Error "T" on top of Error Bars.
ErrorStyle | Defines the Error Series Style according to EErrorSeriesStyle.
ErrorValues | Gets and sets the corresponding Error value for each Bar.
ErrorWidth | Determines the horizontal size of the Error "T".
ErrorWidthUnits | Sets ErrorWidth in pixels or percentage of Bar width.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from CustomBar) | Defines the color Gradient used to fill the Bars.
GradientRelative (inherited from CustomBar) | When Gradient is Visible, calculates Colors based on highest bar.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksLocation (inherited from CustomBar) | Sets the alignment of the Mark into the Bars.
MarksOnBar (inherited from CustomBar) | Sets a postition of the Marks into the Bars.
MiddleZ (inherited from Series) | For internal use.
MultiBar (inherited from CustomBar) | Determines how multiple BarSeries will be displayed in the same Chart.
NumGallerySeries (inherited from Series) | For internal use.
OffsetPercent (inherited from CustomBar) | Sets the Bar displacement as percent of Bar size.
Origin (inherited from CustomBar) | Sets the common bottom value used for all Bar points.
Pen (inherited from CustomBar) | Pen used to draw the Bar rectangles.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow (inherited from CustomBar) | Defines the Shadow used to draw behind the Bars.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideMargins (inherited from CustomBar) | Sets a margin between Chart rectangle and Bars.
StackGroup (inherited from CustomBar) | Allows stacking independent Series within the same Chart.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickLines (inherited from CustomBar) | Pen used to draw "tick" lines across each bar.
Title (inherited from Series) | Series description to show in Legend and editors.
UseOrigin (inherited from CustomBar) | Allows Bars to be bottom aligned to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin (inherited from CustomBar) | System.Obsolete: Please use Origin property.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

CustomError Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomError Constructor

Overload List

public CustomError()
public CustomError(Steema.TeeChart.Chart)

See Also

CustomError Class | CustomError Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomError Constructor

public CustomError(Chart c)

See Also

CustomError Constructor Overload List | CustomError Class | CustomError Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomError Constructor

public CustomError()

See Also

CustomError Constructor Overload List | CustomError Class | CustomError Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomErrorEvents

Steema.TeeChart.Styles.CustomError Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetBarStyle (inherited from CustomBar) | Occurs when series bars are painted.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

CustomError Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomErrorFields

Steema.TeeChart.Styles.CustomError Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

CustomError Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomErrorMethods

Steema.TeeChart.Styles.CustomError Methods

Public Methods

Add | Adds a new Error Bar point in selected color and with label.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddValue | Adds a new Error Bar point to the Series.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomBar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BarMargin (inherited from CustomBar) | Returns side margin amount in pixels.
BarRectangle (inherited from CustomBar) | For internal use.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Bar) | Returns the Screen X pixel coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Bar) | Returns the Screen Y pixel coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawBar | Displays an ErrorBar point ( BarIndex point ) using the Start and End pixel coordinates.
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from CustomBar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetOriginPos (inherited from Bar) | Returns the corresponding screen pixels coordinate of the leftmost horizontal bar edge.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Bar) | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Bar) | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointOrigin (inherited from CustomBar) | For internal use.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from CustomBar) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

CustomError Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomError.Add Method

Overload List

Adds a new Error Bar point in selected color and with label.

public Int32 Add(System.Double, System.Double, System.Double, System.String, System.Drawing.Color)

Adds a new Error Bar point to the Series with label.

public Int32 Add(System.Double, System.Double, System.Double, System.String)

Adds a new Error Bar point to the Series.

public Int32 Add(System.Double, System.Double, System.Double)

Adds a new Error Bar point to the Series in selected color.

public Int32 Add(System.Double, System.Double, System.Double, System.Drawing.Color)

See Also

CustomError Class | CustomError Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomError.Add Method

Adds a new Error Bar point to the Series in selected color.
public Int32 Add(Double x,
     Double y,
     Double errorValue,
     Color color)

See Also

Add Overload List | CustomError Class | CustomError Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomError.Add Method

Adds a new Error Bar point to the Series.
public Int32 Add(Double x,
     Double y,
     Double errorValue)

See Also

Add Overload List | CustomError Class | CustomError Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomError.Add Method

Adds a new Error Bar point to the Series with label.
public Int32 Add(Double x,
     Double y,
     Double errorValue,
     String text)

See Also

Add Overload List | CustomError Class | CustomError Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomError.Add Method

Adds a new Error Bar point in selected color and with label.
public Int32 Add(Double x,
     Double y,
     Double errorValue,
     String text,
     Color color)

See Also

Add Overload List | CustomError Class | CustomError Members | Steema.TeeChart.Styles Namespace


AddValue

Steema.TeeChart.Styles.CustomError.AddValue Method

Adds a new Error Bar point to the Series.
public Int32 AddValue(Double y,
     Double errorValue)

Return Value

ValueList index of added point

See Also

CustomError Class | CustomError Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.CustomError.Clicked Method

Overload List

Returns the ValueIndex of the "clicked" point in the Series.

public override Int32 Clicked(System.Int32, System.Int32)

See Also

CustomError Class | CustomError Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.CustomError.Clicked Method

Returns the ValueIndex of the "clicked" point in the Series.
public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | CustomError Class | CustomError Members | Steema.TeeChart.Styles Namespace


DrawBar

Steema.TeeChart.Styles.CustomError.DrawBar Method

Displays an ErrorBar point ( BarIndex point ) using the Start and End pixel coordinates.
public override Void DrawBar(Int32 BarIndex,
     Int32 StartPos,
     Int32 EndPos)

See Also

CustomError Class | CustomError Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.CustomError.MaxYValue Method

Returns the Maximum Value of the Series Y Values List.
public override Double MaxYValue()

See Also

CustomError Class | CustomError Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.CustomError.MinYValue Method

Returns the Minimum Value of the Series Y Values List.
public override Double MinYValue()

See Also

CustomError Class | CustomError Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.CustomError.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

CustomError Class | CustomError Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomErrorProperties

Steema.TeeChart.Styles.CustomError Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoMarkPosition (inherited from CustomBar) | Repositions Marks on BarSeries to prevent overlapping.
BarBounds (inherited from CustomBar) | Coordinates of current Bar point being displayed.
BarStyle (inherited from CustomBar) | Defines the Bar shape used to draw Bars.
BarWidthPercent (inherited from Bar) | Determines the percent of total Bar width used.
BevelSize (inherited from CustomBar) | Amount in pixels of the bar bevel. Used only when BarStyle property is Bevel (only in 2D and 3D orthogonal display modes)
Brush (inherited from CustomBar) | Defines the Brush used to fill Bars.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent (inherited from CustomBar) |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBarWidth (inherited from CustomBar) |
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from CustomBar) | Darkens sides of bars to enhance 3D effect.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthPercent (inherited from CustomBar) | Defines the percentage, from 0 to 100, that the bars will need in the "Z" depth space direction.
Description (inherited from Bar) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
ErrorPen | Defines Pen to draw Error "T" on top of Error Bars.
ErrorStyle | Defines the Error Series Style according to EErrorSeriesStyle.
ErrorValues | Gets and sets the corresponding Error value for each Bar.
ErrorWidth | Determines the horizontal size of the Error "T".
ErrorWidthUnits | Sets ErrorWidth in pixels or percentage of Bar width.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from CustomBar) | Defines the color Gradient used to fill the Bars.
GradientRelative (inherited from CustomBar) | When Gradient is Visible, calculates Colors based on highest bar.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksLocation (inherited from CustomBar) | Sets the alignment of the Mark into the Bars.
MarksOnBar (inherited from CustomBar) | Sets a postition of the Marks into the Bars.
MiddleZ (inherited from Series) | For internal use.
MultiBar (inherited from CustomBar) | Determines how multiple BarSeries will be displayed in the same Chart.
NumGallerySeries (inherited from Series) | For internal use.
OffsetPercent (inherited from CustomBar) | Sets the Bar displacement as percent of Bar size.
Origin (inherited from CustomBar) | Sets the common bottom value used for all Bar points.
Pen (inherited from CustomBar) | Pen used to draw the Bar rectangles.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow (inherited from CustomBar) | Defines the Shadow used to draw behind the Bars.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideMargins (inherited from CustomBar) | Sets a margin between Chart rectangle and Bars.
StackGroup (inherited from CustomBar) | Allows stacking independent Series within the same Chart.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickLines (inherited from CustomBar) | Pen used to draw "tick" lines across each bar.
Title (inherited from Series) | Series description to show in Legend and editors.
UseOrigin (inherited from CustomBar) | Allows Bars to be bottom aligned to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin (inherited from CustomBar) | System.Obsolete: Please use Origin property.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

CustomError Class | Steema.TeeChart.Styles Namespace


ErrorPen

Steema.TeeChart.Styles.CustomError.ErrorPen Property

Defines Pen to draw Error "T" on top of Error Bars.
public ChartPen ErrorPen {get; set;}

See Also

CustomError Class | CustomError Members | Steema.TeeChart.Styles Namespace


ErrorStyle

Steema.TeeChart.Styles.CustomError.ErrorStyle Property

Defines the Error Series Style according to EErrorSeriesStyle.
public ErrorStyles ErrorStyle {get; set;}

See Also

CustomError Class | CustomError Members | Steema.TeeChart.Styles Namespace


ErrorValues

Steema.TeeChart.Styles.CustomError.ErrorValues Property

Gets and sets the corresponding Error value for each Bar.
public ValueList ErrorValues {get;}

See Also

CustomError Class | CustomError Members | Steema.TeeChart.Styles Namespace


ErrorWidth

Steema.TeeChart.Styles.CustomError.ErrorWidth Property

Determines the horizontal size of the Error "T".
public Int32 ErrorWidth {get; set;}

See Also

CustomError Class | CustomError Members | Steema.TeeChart.Styles Namespace


ErrorWidthUnits

Steema.TeeChart.Styles.CustomError.ErrorWidthUnits Property

Sets ErrorWidth in pixels or percentage of Bar width.
public ErrorWidthUnits ErrorWidthUnits {get; set;}

See Also

CustomError Class | CustomError Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomErrorPoint

Steema.TeeChart.Styles.CustomErrorPoint Class

For a list of all members of this type, see CustomErrorPoint Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Points
public abstract class CustomErrorPoint : Points , ICloneable
, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

CustomErrorPoint members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomErrorPointMembers

Steema.TeeChart.Styles.CustomErrorPoint all Members

CustomErrorPoint overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add | Adds a new Point with the four errors in selected color and with label.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue |
MaxYValue |
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue |
MinYValue |
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
Errors | Gets and sets the corresponding ChartErrors Errors
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

CustomErrorPoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomErrorPoint Constructor

Overload List

public CustomErrorPoint(Steema.TeeChart.Chart)
public CustomErrorPoint()

See Also

CustomErrorPoint Class | CustomErrorPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomErrorPoint Constructor

public CustomErrorPoint()

See Also

CustomErrorPoint Constructor Overload List | CustomErrorPoint Class | CustomErrorPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomErrorPoint Constructor

public CustomErrorPoint(Chart c)

See Also

CustomErrorPoint Constructor Overload List | CustomErrorPoint Class | CustomErrorPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomErrorPointEvents

Steema.TeeChart.Styles.CustomErrorPoint Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

CustomErrorPoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomErrorPointFields

Steema.TeeChart.Styles.CustomErrorPoint Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

CustomErrorPoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomErrorPointMethods

Steema.TeeChart.Styles.CustomErrorPoint Methods

Public Methods

Add | Adds a new Point with the four errors in selected color and with label.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue |
MaxYValue |
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue |
MinYValue |
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

CustomErrorPoint Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomErrorPoint.Add Method

Overload List

Adds a new Point with the four errors in selected color and with label.

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.String, System.Drawing.Color)

Adds a new Point to the Series with the four errors and label.

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.String)

Adds a new Point to the Series with the four errors.

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Double, System.Double)

Adds a new Point to the Series with the four errors in selected color.

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.Drawing.Color)

Adds a new Point to the Series with the four errors.

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Double)

See Also

CustomErrorPoint Class | CustomErrorPoint Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomErrorPoint.Add Method

Adds a new Point to the Series with the four errors.
public Int32 Add(Double y,
     Double LErr,
     Double RErr,
     Double TErr,
     Double BErr)

Return Value

ValueList index of added point

See Also

Add Overload List | CustomErrorPoint Class | CustomErrorPoint Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomErrorPoint.Add Method

Adds a new Point to the Series with the four errors in selected color.
public Int32 Add(Double x,
     Double y,
     Double LErr,
     Double RErr,
     Double TErr,
     Double BErr,
     Color color)

See Also

Add Overload List | CustomErrorPoint Class | CustomErrorPoint Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomErrorPoint.Add Method

Adds a new Point to the Series with the four errors.
public Int32 Add(Double x,
     Double y,
     Double LErr,
     Double RErr,
     Double TErr,
     Double BErr)

See Also

Add Overload List | CustomErrorPoint Class | CustomErrorPoint Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomErrorPoint.Add Method

Adds a new Point to the Series with the four errors and label.
public Int32 Add(Double x,
     Double y,
     Double LErr,
     Double RErr,
     Double TErr,
     Double BErr,
     String text)

See Also

Add Overload List | CustomErrorPoint Class | CustomErrorPoint Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomErrorPoint.Add Method

Adds a new Point with the four errors in selected color and with label.
public Int32 Add(Double XVal,
     Double YVal,
     Double LErr,
     Double RErr,
     Double TErr,
     Double BErr,
     String text,
     Color color)

See Also

Add Overload List | CustomErrorPoint Class | CustomErrorPoint Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.CustomErrorPoint.Clicked Method

Overload List

Returns the ValueIndex of the "clicked" point in the Series.

public override Int32 Clicked(System.Int32, System.Int32)

See Also

CustomErrorPoint Class | CustomErrorPoint Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.CustomErrorPoint.Clicked Method

Returns the ValueIndex of the "clicked" point in the Series.
public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | CustomErrorPoint Class | CustomErrorPoint Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.CustomErrorPoint.DrawValue Method

public override Void DrawValue(Int32 valueIndex)

See Also

CustomErrorPoint Class | CustomErrorPoint Members | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.CustomErrorPoint.MaxXValue Method

public override Double MaxXValue()

See Also

CustomErrorPoint Class | CustomErrorPoint Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.CustomErrorPoint.MaxYValue Method

public override Double MaxYValue()

See Also

CustomErrorPoint Class | CustomErrorPoint Members | Steema.TeeChart.Styles Namespace


MinXValue

Steema.TeeChart.Styles.CustomErrorPoint.MinXValue Method

public override Double MinXValue()

See Also

CustomErrorPoint Class | CustomErrorPoint Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.CustomErrorPoint.MinYValue Method

public override Double MinYValue()

See Also

CustomErrorPoint Class | CustomErrorPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomErrorPointProperties

Steema.TeeChart.Styles.CustomErrorPoint Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
Errors | Gets and sets the corresponding ChartErrors Errors
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

CustomErrorPoint Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.CustomErrorPoint.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

CustomErrorPoint Class | CustomErrorPoint Members | Steema.TeeChart.Styles Namespace


Errors

Steema.TeeChart.Styles.CustomErrorPoint.Errors Property

Gets and sets the corresponding ChartErrors Errors
public ChartErrors Errors {get;}

See Also

CustomErrorPoint Class | CustomErrorPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomErrorPoint3D

Steema.TeeChart.Styles.CustomErrorPoint3D Class

For a list of all members of this type, see CustomErrorPoint3D Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Points3D
public abstract class CustomErrorPoint3D : Points3D , ICloneable
, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

CustomErrorPoint3D members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomErrorPoint3DMembers

Steema.TeeChart.Styles.CustomErrorPoint3D all Members

CustomErrorPoint3D overview

Constructors

Constructor

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle (inherited from Points3D) |
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add | Adds a new Point3D with the six errors in selected color and with label.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Points3D) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue |
MaxYValue |
MaxZValue |
MinXValue |
MinYValue |
MinZValue |
PrepareForGallery (inherited from Points3D) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points3D) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
BaseLine (inherited from Points3D) | Sets the Pen for the Point3D connecting Lines.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthSize (inherited from Points3D) | Sets the Depth of each 3DPoint to the value of DepthSize.
Description | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
Errors | Gets and sets the corresponding ChartErrors Errors
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Custom3D) | XYZ Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points3D) | Sets the Pen for the Point3D connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from Points3D) | Each point in a PointSeries is drawn using the Pointer properties.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from Points3D) |
TreatNulls (inherited from Points3D) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

CustomErrorPoint3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomErrorPoint3D Constructor

public CustomErrorPoint3D(Chart c)

See Also

CustomErrorPoint3D Class | CustomErrorPoint3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomErrorPoint3DEvents

Steema.TeeChart.Styles.CustomErrorPoint3D Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle (inherited from Points3D) |
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

CustomErrorPoint3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomErrorPoint3DFields

Steema.TeeChart.Styles.CustomErrorPoint3D Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

CustomErrorPoint3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomErrorPoint3DMethods

Steema.TeeChart.Styles.CustomErrorPoint3D Methods

Public Methods

Add | Adds a new Point3D with the six errors in selected color and with label.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Points3D) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue |
MaxYValue |
MaxZValue |
MinXValue |
MinYValue |
MinZValue |
PrepareForGallery (inherited from Points3D) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points3D) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

CustomErrorPoint3D Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomErrorPoint3D.Add Method

Overload List

Adds a new Point3D with the six errors in selected color and with label.

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.String, System.Drawing.Color)

Adds a new Point3D to the Series with the six errors and label.

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.String)

Adds a new Point3D to the Series with the six errors.

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.Double)

Adds a new Point3D to the Series with the six errors in selected color.

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.Drawing.Color)

Adds a new Point3D to the Series with the six errors.

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.Double)

See Also

CustomErrorPoint3D Class | CustomErrorPoint3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomErrorPoint3D.Add Method

Adds a new Point3D to the Series with the six errors.
public Int32 Add(Double y,
     Double z,
     Double LeftErr,
     Double RightErr,
     Double TopErr,
     Double BottomErr,
     Double FrontErr,
     Double BackErr)

Return Value

ValueList index of added point

See Also

Add Overload List | CustomErrorPoint3D Class | CustomErrorPoint3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomErrorPoint3D.Add Method

Adds a new Point3D to the Series with the six errors in selected color.
public Int32 Add(Double x,
     Double y,
     Double z,
     Double LeftErr,
     Double RightErr,
     Double TopErr,
     Double BottomErr,
     Double FrontErr,
     Double BackErr,
     Color color)

See Also

Add Overload List | CustomErrorPoint3D Class | CustomErrorPoint3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomErrorPoint3D.Add Method

Adds a new Point3D to the Series with the six errors.
public Int32 Add(Double x,
     Double y,
     Double z,
     Double LeftErr,
     Double RightErr,
     Double TopErr,
     Double BottomErr,
     Double FrontErr,
     Double BackErr)

See Also

Add Overload List | CustomErrorPoint3D Class | CustomErrorPoint3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomErrorPoint3D.Add Method

Adds a new Point3D to the Series with the six errors and label.
public Int32 Add(Double x,
     Double y,
     Double z,
     Double LeftErr,
     Double RightErr,
     Double TopErr,
     Double BottomErr,
     Double FrontErr,
     Double BackErr,
     String text)

See Also

Add Overload List | CustomErrorPoint3D Class | CustomErrorPoint3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomErrorPoint3D.Add Method

Adds a new Point3D with the six errors in selected color and with label.
public Int32 Add(Double XVal,
     Double YVal,
     Double ZVal,
     Double LeftErr,
     Double RightErr,
     Double TopErr,
     Double BottomErr,
     Double FrontErr,
     Double BackErr,
     String text,
     Color color)

See Also

Add Overload List | CustomErrorPoint3D Class | CustomErrorPoint3D Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.CustomErrorPoint3D.Clicked Method

Overload List

Returns the ValueIndex of the "clicked" point in the Series.

public override Int32 Clicked(System.Int32, System.Int32)

See Also

CustomErrorPoint3D Class | CustomErrorPoint3D Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.CustomErrorPoint3D.Clicked Method

Returns the ValueIndex of the "clicked" point in the Series.
public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | CustomErrorPoint3D Class | CustomErrorPoint3D Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.CustomErrorPoint3D.DrawValue Method

public override Void DrawValue(Int32 valueIndex)

See Also

CustomErrorPoint3D Class | CustomErrorPoint3D Members | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.CustomErrorPoint3D.MaxXValue Method

public override Double MaxXValue()

See Also

CustomErrorPoint3D Class | CustomErrorPoint3D Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.CustomErrorPoint3D.MaxYValue Method

public override Double MaxYValue()

See Also

CustomErrorPoint3D Class | CustomErrorPoint3D Members | Steema.TeeChart.Styles Namespace


MaxZValue

Steema.TeeChart.Styles.CustomErrorPoint3D.MaxZValue Method

public override Double MaxZValue()

See Also

CustomErrorPoint3D Class | CustomErrorPoint3D Members | Steema.TeeChart.Styles Namespace


MinXValue

Steema.TeeChart.Styles.CustomErrorPoint3D.MinXValue Method

public override Double MinXValue()

See Also

CustomErrorPoint3D Class | CustomErrorPoint3D Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.CustomErrorPoint3D.MinYValue Method

public override Double MinYValue()

See Also

CustomErrorPoint3D Class | CustomErrorPoint3D Members | Steema.TeeChart.Styles Namespace


MinZValue

Steema.TeeChart.Styles.CustomErrorPoint3D.MinZValue Method

public override Double MinZValue()

See Also

CustomErrorPoint3D Class | CustomErrorPoint3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomErrorPoint3DProperties

Steema.TeeChart.Styles.CustomErrorPoint3D Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
BaseLine (inherited from Points3D) | Sets the Pen for the Point3D connecting Lines.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthSize (inherited from Points3D) | Sets the Depth of each 3DPoint to the value of DepthSize.
Description | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
Errors | Gets and sets the corresponding ChartErrors Errors
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Custom3D) | XYZ Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points3D) | Sets the Pen for the Point3D connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from Points3D) | Each point in a PointSeries is drawn using the Pointer properties.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from Points3D) |
TreatNulls (inherited from Points3D) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

CustomErrorPoint3D Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.CustomErrorPoint3D.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

CustomErrorPoint3D Class | CustomErrorPoint3D Members | Steema.TeeChart.Styles Namespace


Errors

Steema.TeeChart.Styles.CustomErrorPoint3D.Errors Property

Gets and sets the corresponding ChartErrors Errors
public ChartErrors3D Errors {get;}

See Also

CustomErrorPoint3D Class | CustomErrorPoint3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomGauge

Steema.TeeChart.Styles.CustomGauge Class

For a list of all members of this type, see CustomGauge Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class CustomGauge : Series , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

CustomGauge members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomGaugeMembers

Steema.TeeChart.Styles.CustomGauge all Members

CustomGauge overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.
ValueChanged | Called when the Gauge Value property is changed.

Public Fields

bBrush (inherited from Series) |
BlackPalette |
BluesPalette |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetGaugePaletteColor | Returns the Color with index Index within the color array GaugeColorPalette.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Axis | Gets the LinearGauges's Axis characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorLineEndValues | Gets or sets a collection of EndValues which initially contains the RedLineEndValue and the GreenLineEndValue.
ColorLines | Gets or sets a collection of ColorLines which initially contains the RedLine and the GreenLine.
ColorLineStartValues | Gets or sets a collection of StartValues which initially contains the RedLineStartValue and the GreenLineStartValue.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBounds | Gets or sets a custom bounding rectangle for the gauge.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FaceBrush | ChartBrush characteristics of the CustomGauge's face.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Frame | The Frame is the object which surrounds the LinearGauge and which consists of three configurable Bands: Inner, Middle and Outer.
Function (inherited from Series) | Function object to calculate values.
GaugeColorPalette | Gets and sets the CircularGauge's color palette.
GreenLine | The 'greenline' object is the curved shape with a gradient which is used to signal a low or minimum value.
GreenLineEndValue | Gets and sets the value at which the 'redline' marker ends.
GreenLineStartValue | Gets and sets the value at which the 'redline' marker starts.
Hand | Gets and sets the Hand (or needle) object characteristics.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Horizontal | Gets and sets whether the LinearGauge should be displayed horizontally or vertically.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
Maximum | Gets or sets the maximum value for the gauge.
MiddleZ (inherited from Series) | For internal use.
Minimum | Gets or sets the minimum value for the gauge.
MinorTickDistance | The minor tick offset.
MinorTicks | Gets and sets the characteristics of the Axis' minor tick marks.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedLine | The 'redline' object is the curved shape with a gradient which is used to signal a high or maximum value.
RedLineEndValue | Gets and sets the value at which the 'redline' marker ends.
RedLineStartValue | Gets and sets the value at which the 'redline' marker starts.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Ticks | Gets and sets the characteristics of the Axis' major tick marks.
Title (inherited from Series) | Series description to show in Legend and editors.
Value | Gets or sets the position of gauge arrow line.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

CustomGauge Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomGauge Constructor

Overload List

public CustomGauge()
public CustomGauge(Steema.TeeChart.Chart)

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomGauge Constructor

public CustomGauge(Chart c)

See Also

CustomGauge Constructor Overload List | CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomGauge Constructor

public CustomGauge()

See Also

CustomGauge Constructor Overload List | CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomGaugeEvents

Steema.TeeChart.Styles.CustomGauge Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.
ValueChanged | Called when the Gauge Value property is changed.

See Also

CustomGauge Class | Steema.TeeChart.Styles Namespace


ValueChanged

Steema.TeeChart.Styles.CustomGauge.ValueChanged Event

Called when the Gauge Value property is changed.
public GaugesChangeHandler  ValueChanged

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomGaugeFields

Steema.TeeChart.Styles.CustomGauge Fields

Public Fields

bBrush (inherited from Series) |
BlackPalette |
BluesPalette |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

CustomGauge Class | Steema.TeeChart.Styles Namespace


BlackPalette

Steema.TeeChart.Styles.CustomGauge.BlackPalette Field

public Color[] BlackPalette

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


BluesPalette

Steema.TeeChart.Styles.CustomGauge.BluesPalette Field

public Color[] BluesPalette

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomGaugeMethods

Steema.TeeChart.Styles.CustomGauge Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetGaugePaletteColor | Returns the Color with index Index within the color array GaugeColorPalette.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

CustomGauge Class | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.CustomGauge.Clicked Method

Overload List

public override Int32 Clicked(System.Int32, System.Int32)

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.CustomGauge.Clicked Method

public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.CustomGauge.Draw Method

Overload List

public override Void Draw()
public Void Draw(Steema.TeeChart.Drawing.Graphics3D)

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.CustomGauge.Draw Method

public Void Draw(Graphics3D graphics)

See Also

Draw Overload List | CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.CustomGauge.Draw Method

public override Void Draw()

See Also

Draw Overload List | CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


GetGaugePaletteColor

Steema.TeeChart.Styles.CustomGauge.GetGaugePaletteColor Method

Returns the Color with index Index within the color array GaugeColorPalette.
public static Color GetGaugePaletteColor(Int32 Index,
     Color[] GaugeColorPalette)

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomGaugeProperties

Steema.TeeChart.Styles.CustomGauge Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Axis | Gets the LinearGauges's Axis characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorLineEndValues | Gets or sets a collection of EndValues which initially contains the RedLineEndValue and the GreenLineEndValue.
ColorLines | Gets or sets a collection of ColorLines which initially contains the RedLine and the GreenLine.
ColorLineStartValues | Gets or sets a collection of StartValues which initially contains the RedLineStartValue and the GreenLineStartValue.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBounds | Gets or sets a custom bounding rectangle for the gauge.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FaceBrush | ChartBrush characteristics of the CustomGauge's face.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Frame | The Frame is the object which surrounds the LinearGauge and which consists of three configurable Bands: Inner, Middle and Outer.
Function (inherited from Series) | Function object to calculate values.
GaugeColorPalette | Gets and sets the CircularGauge's color palette.
GreenLine | The 'greenline' object is the curved shape with a gradient which is used to signal a low or minimum value.
GreenLineEndValue | Gets and sets the value at which the 'redline' marker ends.
GreenLineStartValue | Gets and sets the value at which the 'redline' marker starts.
Hand | Gets and sets the Hand (or needle) object characteristics.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Horizontal | Gets and sets whether the LinearGauge should be displayed horizontally or vertically.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
Maximum | Gets or sets the maximum value for the gauge.
MiddleZ (inherited from Series) | For internal use.
Minimum | Gets or sets the minimum value for the gauge.
MinorTickDistance | The minor tick offset.
MinorTicks | Gets and sets the characteristics of the Axis' minor tick marks.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedLine | The 'redline' object is the curved shape with a gradient which is used to signal a high or maximum value.
RedLineEndValue | Gets and sets the value at which the 'redline' marker ends.
RedLineStartValue | Gets and sets the value at which the 'redline' marker starts.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Ticks | Gets and sets the characteristics of the Axis' major tick marks.
Title (inherited from Series) | Series description to show in Legend and editors.
Value | Gets or sets the position of gauge arrow line.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

CustomGauge Class | Steema.TeeChart.Styles Namespace


Axis

Steema.TeeChart.Styles.CustomGauge.Axis Property

Gets the LinearGauges's Axis characteristics.
public Axis Axis {get;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


ColorLineEndValues

Steema.TeeChart.Styles.CustomGauge.ColorLineEndValues Property

Gets or sets a collection of EndValues which initially contains the RedLineEndValue and the GreenLineEndValue.
public ColorLineEndValues ColorLineEndValues {get; set;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


ColorLines

Steema.TeeChart.Styles.CustomGauge.ColorLines Property

Gets or sets a collection of ColorLines which initially contains the RedLine and the GreenLine.
public ColorLineCollection ColorLines {get; set;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


ColorLineStartValues

Steema.TeeChart.Styles.CustomGauge.ColorLineStartValues Property

Gets or sets a collection of StartValues which initially contains the RedLineStartValue and the GreenLineStartValue.
public ColorLineStartValues ColorLineStartValues {get; set;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


CustomBounds

Steema.TeeChart.Styles.CustomGauge.CustomBounds Property

Gets or sets a custom bounding rectangle for the gauge.
public Rectangle CustomBounds {get; set;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


FaceBrush

Steema.TeeChart.Styles.CustomGauge.FaceBrush Property

ChartBrush characteristics of the CustomGauge's face.
public ChartBrush FaceBrush {get; set;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


Frame

Steema.TeeChart.Styles.CustomGauge.Frame Property

The Frame is the object which surrounds the LinearGauge and which consists of three configurable Bands: Inner, Middle and Outer.
public TFrame Frame {get; set;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


GaugeColorPalette

Steema.TeeChart.Styles.CustomGauge.GaugeColorPalette Property

Gets and sets the CircularGauge's color palette.
public Color[] GaugeColorPalette {get; set;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


GreenLine

Steema.TeeChart.Styles.CustomGauge.GreenLine Property

The 'greenline' object is the curved shape with a gradient which is used to signal a low or minimum value.
public GaugeSeriesPointer GreenLine {get; set;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


GreenLineEndValue

Steema.TeeChart.Styles.CustomGauge.GreenLineEndValue Property

Gets and sets the value at which the 'redline' marker ends.
public Double GreenLineEndValue {get; set;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


GreenLineStartValue

Steema.TeeChart.Styles.CustomGauge.GreenLineStartValue Property

Gets and sets the value at which the 'redline' marker starts.
public Double GreenLineStartValue {get; set;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


Hand

Steema.TeeChart.Styles.CustomGauge.Hand Property

Gets and sets the Hand (or needle) object characteristics.
public GaugeSeriesPointer Hand {get; set;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


Horizontal

Steema.TeeChart.Styles.CustomGauge.Horizontal Property

Gets and sets whether the LinearGauge should be displayed horizontally or vertically.
public Boolean Horizontal {get; set;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


Maximum

Steema.TeeChart.Styles.CustomGauge.Maximum Property

Gets or sets the maximum value for the gauge.
public Double Maximum {get; set;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


Minimum

Steema.TeeChart.Styles.CustomGauge.Minimum Property

Gets or sets the minimum value for the gauge.
public Double Minimum {get; set;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


MinorTickDistance

Steema.TeeChart.Styles.CustomGauge.MinorTickDistance Property

The minor tick offset.
public Int32 MinorTickDistance {get; set;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


MinorTicks

Steema.TeeChart.Styles.CustomGauge.MinorTicks Property

Gets and sets the characteristics of the Axis' minor tick marks.
public GaugeSeriesPointer MinorTicks {get; set;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


RedLine

Steema.TeeChart.Styles.CustomGauge.RedLine Property

The 'redline' object is the curved shape with a gradient which is used to signal a high or maximum value.
public GaugeSeriesPointer RedLine {get; set;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


RedLineEndValue

Steema.TeeChart.Styles.CustomGauge.RedLineEndValue Property

Gets and sets the value at which the 'redline' marker ends.
public Double RedLineEndValue {get; set;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


RedLineStartValue

Steema.TeeChart.Styles.CustomGauge.RedLineStartValue Property

Gets and sets the value at which the 'redline' marker starts.
public Double RedLineStartValue {get; set;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


Ticks

Steema.TeeChart.Styles.CustomGauge.Ticks Property

Gets and sets the characteristics of the Axis' major tick marks.
public GaugeSeriesPointer Ticks {get; set;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


Value

Steema.TeeChart.Styles.CustomGauge.Value Property

Gets or sets the position of gauge arrow line.
public Double Value {get; set;}

See Also

CustomGauge Class | CustomGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomImagePoint

Steema.TeeChart.Styles.CustomImagePoint Class

For a list of all members of this type, see CustomImagePoint Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Points
public class CustomImagePoint : Points , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

CustomImagePoint members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomImagePointMembers

Steema.TeeChart.Styles.CustomImagePoint all Members

CustomImagePoint overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetImage |
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Points) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
PointImage |
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparent |
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

CustomImagePoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomImagePoint Constructor

Overload List

public CustomImagePoint()
public CustomImagePoint(Steema.TeeChart.Chart)

See Also

CustomImagePoint Class | CustomImagePoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomImagePoint Constructor

public CustomImagePoint(Chart c)

See Also

CustomImagePoint Constructor Overload List | CustomImagePoint Class | CustomImagePoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomImagePoint Constructor

public CustomImagePoint()

See Also

CustomImagePoint Constructor Overload List | CustomImagePoint Class | CustomImagePoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomImagePointEvents

Steema.TeeChart.Styles.CustomImagePoint Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetImage |
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

CustomImagePoint Class | Steema.TeeChart.Styles Namespace


GetImage

Steema.TeeChart.Styles.CustomImagePoint.GetImage Event

public GetImageEvent  GetImage

See Also

CustomImagePoint Class | CustomImagePoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomImagePointFields

Steema.TeeChart.Styles.CustomImagePoint Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

CustomImagePoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomImagePointMethods

Steema.TeeChart.Styles.CustomImagePoint Methods

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

CustomImagePoint Class | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.CustomImagePoint.DrawValue Method

public override Void DrawValue(Int32 valueIndex)

See Also

CustomImagePoint Class | CustomImagePoint Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.CustomImagePoint.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

CustomImagePoint Class | CustomImagePoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomImagePointProperties

Steema.TeeChart.Styles.CustomImagePoint Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Points) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
PointImage |
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparent |
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

CustomImagePoint Class | Steema.TeeChart.Styles Namespace


PointImage

Steema.TeeChart.Styles.CustomImagePoint.PointImage Property

public Bitmap PointImage {get; set;}

See Also

CustomImagePoint Class | CustomImagePoint Members | Steema.TeeChart.Styles Namespace


Transparent

Steema.TeeChart.Styles.CustomImagePoint.Transparent Property

public Boolean Transparent {get; set;}

See Also

CustomImagePoint Class | CustomImagePoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomPoint

Steema.TeeChart.Styles.CustomPoint Class

Base Series class inherited by a number of TeeChart series styles.

For a list of all members of this type, see CustomPoint Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
public class CustomPoint : BaseLine , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

CustomPoint members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomPointMembers

Steema.TeeChart.Styles.CustomPoint all Members

CustomPoint overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer | Occurs when a series pointer is clicked.
GetPointerStyle | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

CustomPoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomPoint Constructor

Overload List

public CustomPoint()
public CustomPoint(Steema.TeeChart.Chart)

See Also

CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomPoint Constructor

public CustomPoint(Chart c)

See Also

CustomPoint Constructor Overload List | CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomPoint Constructor

public CustomPoint()

See Also

CustomPoint Constructor Overload List | CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomPointEvents

Steema.TeeChart.Styles.CustomPoint Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer | Occurs when a series pointer is clicked.
GetPointerStyle | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

CustomPoint Class | Steema.TeeChart.Styles Namespace


ClickPointer

Steema.TeeChart.Styles.CustomPoint.ClickPointer Event

Occurs when a series pointer is clicked.
public ClickPointerEventHandler  ClickPointer

See Also

CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


GetPointerStyle

Steema.TeeChart.Styles.CustomPoint.GetPointerStyle Event

Occurs on the drawing of the series pointers.
public GetPointerStyleEventHandler  GetPointerStyle

See Also

CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomPointFields

Steema.TeeChart.Styles.CustomPoint Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

CustomPoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomPointMethods

Steema.TeeChart.Styles.CustomPoint Methods

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

CustomPoint Class | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.CustomPoint.AssignFormat Method

Overload List

public override Void AssignFormat(Steema.TeeChart.Styles.Series, Steema.TeeChart.Styles.Series)

See Also

CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.CustomPoint.AssignFormat Method

public override Void AssignFormat(Series source,
     Series target)

See Also

AssignFormat Overload List | CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


CalcXPos

Steema.TeeChart.Styles.CustomPoint.CalcXPos Method

Returns horizontal screen position for a given point.
public override Int32 CalcXPos(Int32 valueIndex)

See Also

CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


CalcYPos

Steema.TeeChart.Styles.CustomPoint.CalcYPos Method

Returns vertical screen position for a given point.
public override Int32 CalcYPos(Int32 valueIndex)

See Also

CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.CustomPoint.Clicked Method

Overload List

Returns the ValueIndex of the "clicked" point in the Series.

public override Int32 Clicked(System.Int32, System.Int32)

See Also

CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.CustomPoint.Clicked Method

Returns the ValueIndex of the "clicked" point in the Series.
public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


ClickedPointer

Steema.TeeChart.Styles.CustomPoint.ClickedPointer Method

Overload List

For internal use.

public Int32 ClickedPointer(System.Drawing.Point)

For internal use.

public abstract Int32 ClickedPointer(System.Int32, System.Int32)

For internal use.

public abstract Boolean ClickedPointer(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

See Also

CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


ClickedPointer

Steema.TeeChart.Styles.CustomPoint.ClickedPointer Method

For internal use.
public abstract Boolean ClickedPointer(Int32 valueIndex,
     Int32 tmpX,
     Int32 tmpY,
     Int32 x,
     Int32 y)

See Also

ClickedPointer Overload List | CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


ClickedPointer

Steema.TeeChart.Styles.CustomPoint.ClickedPointer Method

For internal use.
public abstract Int32 ClickedPointer(Int32 x,
     Int32 y)

See Also

ClickedPointer Overload List | CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


ClickedPointer

Steema.TeeChart.Styles.CustomPoint.ClickedPointer Method

For internal use.
public Int32 ClickedPointer(Point P)

See Also

ClickedPointer Overload List | CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


DrawPointer

Steema.TeeChart.Styles.CustomPoint.DrawPointer Method

Draws series pointer to the Canvas.
public Void DrawPointer(Int32 aX,
     Int32 aY,
     Color aColor,
     Int32 valueIndex)

See Also

CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.CustomPoint.DrawValue Method

Called internally. Draws the "ValueIndex" point of the Series.
public override Void DrawValue(Int32 valueIndex)

See Also

CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.CustomPoint.MaxXValue Method

Returns the Maximum Value of the Series X Values List.
public override Double MaxXValue()

See Also

CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.CustomPoint.MaxYValue Method

Returns the Maximum Value of the Series Y Values List.
public override Double MaxYValue()

See Also

CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


MinXValue

Steema.TeeChart.Styles.CustomPoint.MinXValue Method

Returns the Minimum Value of the Series X Values List.
public override Double MinXValue()

See Also

CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.CustomPoint.MinYValue Method

Returns the Minimum Value of the Series Y Values List.
public override Double MinYValue()

See Also

CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomPointProperties

Steema.TeeChart.Styles.CustomPoint Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

CustomPoint Class | Steema.TeeChart.Styles Namespace


Pointer

Steema.TeeChart.Styles.CustomPoint.Pointer Property

Defines all necessary properties of the Series Pointer.
public virtual SeriesPointer Pointer {get; set;}

See Also

CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


Stacked

Steema.TeeChart.Styles.CustomPoint.Stacked Property

Defines how multiple series will be displayed.
public CustomStack Stacked {get; set;}

See Also

CustomPoint Class | CustomPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomPoint.ClickPointerEventHandler

Steema.TeeChart.Styles.CustomPoint.ClickPointerEventHandler Delegate

The Delegate for the ClickPointer event.
public delegate ClickPointerEventHandler (CustomPoint series,
     Int32 valueIndex,
     Int32 x,
     Int32 y)

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomPoint.GetPointerStyleEventHandler

Steema.TeeChart.Styles.CustomPoint.GetPointerStyleEventHandler Delegate

The Delegate for the GetPointerStyle event.
public delegate GetPointerStyleEventHandler (CustomPoint series,
     GetPointerStyleEventArgs e)

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomPolar

Steema.TeeChart.Styles.CustomPolar Class

CustomPolar Series.

For a list of all members of this type, see CustomPolar Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
public class CustomPolar : Circular , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

CustomPolar members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomPolarMembers

Steema.TeeChart.Styles.CustomPolar all Members

CustomPolar overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawRing |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
DrawZone |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
OnGetPointerStyle |
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AngleIncrement | Sets angle in degrees used to draw the dividing grid lines in anti-clockwise direction.
AngleValues | Gets list of angle values for each polar point.
Brush | Sets Polar Back Brush.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleLabels | Sets CicleLabel properties.
CircleLabelsFont |
CircleLabelsInside | Enables/disables the display of the axis labels inside the circle area.
CircleLabelsRotated | When true rotates the labels of a circular TeeChart series at an angle in line with the Radar/Polar circle at each Label point.
CirclePen | Determines the pen used to draw the outmost circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
ClockWiseLabels | Displays of the circle labels in a clockwise direction.
CloseCircle | Draws a Line between the last and first PolarSeries point coordinates.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Font | Sets the label font.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsMargin | Defines the distance between the CustomPolar circle and the labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen | Determines Pen used to draw the Line connecting PolarSeries points.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer | Pointer contains several properties to control the formatting attributes of Points like Pen, Brush, Draw3D, Visible, etc.
RadiusIncrement | Determines the increment used to draw the ring grid lines.
RadiusValues | Gets list of radius values for each polar point.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency | Sets Transparency level from 0 to 100%.
TreatNaNAsNull |
TreatNulls |
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

CustomPolar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomPolar Constructor

Overload List

public CustomPolar()
public CustomPolar(Steema.TeeChart.Chart)

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomPolar Constructor

public CustomPolar(Chart c)

See Also

CustomPolar Constructor Overload List | CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomPolar Constructor

public CustomPolar()

See Also

CustomPolar Constructor Overload List | CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomPolarEvents

Steema.TeeChart.Styles.CustomPolar Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

CustomPolar Class | Steema.TeeChart.Styles Namespace


GetPointerStyle

Steema.TeeChart.Styles.CustomPolar.GetPointerStyle Event

Occurs on the drawing of the series pointers.
public GetPointerStyleEventHandler  GetPointerStyle

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomPolarFields

Steema.TeeChart.Styles.CustomPolar Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

CustomPolar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomPolarMethods

Steema.TeeChart.Styles.CustomPolar Methods

Public Methods

Add |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawRing |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
DrawZone |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
OnGetPointerStyle |
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

CustomPolar Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomPolar.Add Method

Overload List

public override Void Add(System.Array, System.Array, System.Boolean)
public override Int32 Add(System.Double, System.Double)

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomPolar.Add Method

public override Int32 Add(Double x,
     Double y)

See Also

Add Overload List | CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.CustomPolar.Add Method

public override Void Add(Array xValues,
     Array yValues,
     Boolean append)

See Also

Add Overload List | CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.CustomPolar.AssignFormat Method

Overload List

public override Void AssignFormat(Steema.TeeChart.Styles.Series, Steema.TeeChart.Styles.Series)

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.CustomPolar.AssignFormat Method

public override Void AssignFormat(Series source,
     Series target)

See Also

AssignFormat Overload List | CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


CalcXPos

Steema.TeeChart.Styles.CustomPolar.CalcXPos Method

Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
public override Int32 CalcXPos(Int32 valueIndex)

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


CalcYPos

Steema.TeeChart.Styles.CustomPolar.CalcYPos Method

Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
public override Int32 CalcYPos(Int32 valueIndex)

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.CustomPolar.Clicked Method

Overload List

public override Int32 Clicked(System.Int32, System.Int32)

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.CustomPolar.Clicked Method

public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.CustomPolar.Draw Method

public override Void Draw()

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


DrawRing

Steema.TeeChart.Styles.CustomPolar.DrawRing Method

public Void DrawRing(Double value,
     Int32 z)

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.CustomPolar.DrawValue Method

Called internally. Draws the "ValueIndex" point of the Series.
public override Void DrawValue(Int32 valueIndex)

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


DrawZone

Steema.TeeChart.Styles.CustomPolar.DrawZone Method

public Void DrawZone(Double Min,
     Double Max,
     Int32 z)

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


OnGetPointerStyle

Steema.TeeChart.Styles.CustomPolar.OnGetPointerStyle Method

Overload List

public abstract Void OnGetPointerStyle(System.Int32, Steema.TeeChart.Styles.PointerStyles&)
public abstract Void OnGetPointerStyle(System.Int32, Steema.TeeChart.Styles.PointerStyles&, System.Drawing.Color&)

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


OnGetPointerStyle

Steema.TeeChart.Styles.CustomPolar.OnGetPointerStyle Method

public abstract Void OnGetPointerStyle(Int32 valueIndex,
     PointerStyles& style,
     Color& aColor)

See Also

OnGetPointerStyle Overload List | CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


OnGetPointerStyle

Steema.TeeChart.Styles.CustomPolar.OnGetPointerStyle Method

public abstract Void OnGetPointerStyle(Int32 valueIndex,
     PointerStyles& style)

See Also

OnGetPointerStyle Overload List | CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.CustomPolar.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomPolarProperties

Steema.TeeChart.Styles.CustomPolar Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AngleIncrement | Sets angle in degrees used to draw the dividing grid lines in anti-clockwise direction.
AngleValues | Gets list of angle values for each polar point.
Brush | Sets Polar Back Brush.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleLabels | Sets CicleLabel properties.
CircleLabelsFont |
CircleLabelsInside | Enables/disables the display of the axis labels inside the circle area.
CircleLabelsRotated | When true rotates the labels of a circular TeeChart series at an angle in line with the Radar/Polar circle at each Label point.
CirclePen | Determines the pen used to draw the outmost circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
ClockWiseLabels | Displays of the circle labels in a clockwise direction.
CloseCircle | Draws a Line between the last and first PolarSeries point coordinates.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Font | Sets the label font.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsMargin | Defines the distance between the CustomPolar circle and the labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen | Determines Pen used to draw the Line connecting PolarSeries points.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer | Pointer contains several properties to control the formatting attributes of Points like Pen, Brush, Draw3D, Visible, etc.
RadiusIncrement | Determines the increment used to draw the ring grid lines.
RadiusValues | Gets list of radius values for each polar point.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency | Sets Transparency level from 0 to 100%.
TreatNaNAsNull |
TreatNulls |
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

CustomPolar Class | Steema.TeeChart.Styles Namespace


AngleIncrement

Steema.TeeChart.Styles.CustomPolar.AngleIncrement Property

Sets angle in degrees used to draw the dividing grid lines in anti-clockwise direction.
public Double AngleIncrement {get; set;}

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


AngleValues

Steema.TeeChart.Styles.CustomPolar.AngleValues Property

Gets list of angle values for each polar point.
public ValueList AngleValues {get;}

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


Brush

Steema.TeeChart.Styles.CustomPolar.Brush Property

Sets Polar Back Brush.
public ChartBrush Brush {get;}

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


CircleLabels

Steema.TeeChart.Styles.CustomPolar.CircleLabels Property

Sets CicleLabel properties.
public Boolean CircleLabels {get; set;}

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


CircleLabelsFont

Steema.TeeChart.Styles.CustomPolar.CircleLabelsFont Property

public ChartFont CircleLabelsFont {get; set;}

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


CircleLabelsInside

Steema.TeeChart.Styles.CustomPolar.CircleLabelsInside Property

Enables/disables the display of the axis labels inside the circle area.
public Boolean CircleLabelsInside {get; set;}

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


CircleLabelsRotated

Steema.TeeChart.Styles.CustomPolar.CircleLabelsRotated Property

When true rotates the labels of a circular TeeChart series at an angle in line with the Radar/Polar circle at each Label point.
public Boolean CircleLabelsRotated {get; set;}

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


CirclePen

Steema.TeeChart.Styles.CustomPolar.CirclePen Property

Determines the pen used to draw the outmost circle.
public ChartPen CirclePen {get; set;}

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


ClockWiseLabels

Steema.TeeChart.Styles.CustomPolar.ClockWiseLabels Property

Displays of the circle labels in a clockwise direction.
public Boolean ClockWiseLabels {get; set;}

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


CloseCircle

Steema.TeeChart.Styles.CustomPolar.CloseCircle Property

Draws a Line between the last and first PolarSeries point coordinates.
public Boolean CloseCircle {get; set;}

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


Font

Steema.TeeChart.Styles.CustomPolar.Font Property

Sets the label font.
public ChartFont Font {get; set;}

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


LabelsMargin

Steema.TeeChart.Styles.CustomPolar.LabelsMargin Property

Defines the distance between the CustomPolar circle and the labels.
public Int32 LabelsMargin {get; set;}

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


Pen

Steema.TeeChart.Styles.CustomPolar.Pen Property

Determines Pen used to draw the Line connecting PolarSeries points.
public ChartPen Pen {get; set;}

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


Pointer

Steema.TeeChart.Styles.CustomPolar.Pointer Property

Pointer contains several properties to control the formatting attributes of Points like Pen, Brush, Draw3D, Visible, etc.
public virtual SeriesPointer Pointer {get; set;}

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


RadiusIncrement

Steema.TeeChart.Styles.CustomPolar.RadiusIncrement Property

Determines the increment used to draw the ring grid lines.
public Double RadiusIncrement {get; set;}

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


RadiusValues

Steema.TeeChart.Styles.CustomPolar.RadiusValues Property

Gets list of radius values for each polar point.
public ValueList RadiusValues {get;}

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


Transparency

Steema.TeeChart.Styles.CustomPolar.Transparency Property

Sets Transparency level from 0 to 100%.
public Int32 Transparency {get; set;}

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


TreatNaNAsNull

Steema.TeeChart.Styles.CustomPolar.TreatNaNAsNull Property

public Boolean TreatNaNAsNull {get; set;}

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


TreatNulls

Steema.TeeChart.Styles.CustomPolar.TreatNulls Property

public TreatNullsStyle TreatNulls {get; set;}

See Also

CustomPolar Class | CustomPolar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomPolar.GetPointerStyleEventHandler

Steema.TeeChart.Styles.CustomPolar.GetPointerStyleEventHandler Delegate

The Delegate for the GetPointerStyle event.
public delegate GetPointerStyleEventHandler (CustomPolar series,
     GetPointerStyleEventArgs e)

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomStack

Steema.TeeChart.Styles.CustomStack Enum

Describes the possible values of the Stacked property.
[Serializable]
public sealed enum CustomStack : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
None | Series will be drawn one behind the other.
Overlap | Series will be drawn one over the other.
Stack | Draws each series on top of the previous one.
Stack100 | Adjusts each individual series to a common 0..100 axis scale.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomTimeOHLC

Steema.TeeChart.Styles.CustomTimeOHLC Class

For a list of all members of this type, see CustomTimeOHLC Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
Steema.TeeChart.Styles.OHLC
public class CustomTimeOHLC : OHLC , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

CustomTimeOHLC members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomTimeOHLCMembers

Steema.TeeChart.Styles.CustomTimeOHLC all Members

CustomTimeOHLC overview

Constructors

Constructor

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from OHLC) | Adds new point with specified integer index and double open, high, low and close.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Custom) | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Custom) |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Custom) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from OHLC) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from OHLC) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from OHLC) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
BoxSize |
BoxType | Use BoxType to change box sensitivity according to the data range.
Brush (inherited from Custom) | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
CloseValues (inherited from OHLC) | Gets and sets all Stock market Close values.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DateValues (inherited from OHLC) | Gets and sets all Stock market Date values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HighValues (inherited from OHLC) | Gets and sets all Stock market High values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IncrementAsBox | When true, Chart will try to size grid to box size.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from OHLC) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
LowValues (inherited from OHLC) | Gets and sets all Stock market Low values.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OpenValues (inherited from OHLC) | Gets and sets all Stock market Open values.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Period |
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

CustomTimeOHLC Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomTimeOHLC Constructor

public CustomTimeOHLC(Chart c)

See Also

CustomTimeOHLC Class | CustomTimeOHLC Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomTimeOHLCEvents

Steema.TeeChart.Styles.CustomTimeOHLC Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

CustomTimeOHLC Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomTimeOHLCFields

Steema.TeeChart.Styles.CustomTimeOHLC Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

CustomTimeOHLC Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomTimeOHLCMethods

Steema.TeeChart.Styles.CustomTimeOHLC Methods

Public Methods

Add (inherited from OHLC) | Adds new point with specified integer index and double open, high, low and close.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Custom) | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Custom) |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Custom) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from OHLC) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from OHLC) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from OHLC) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

CustomTimeOHLC Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomTimeOHLCProperties

Steema.TeeChart.Styles.CustomTimeOHLC Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
BoxSize |
BoxType | Use BoxType to change box sensitivity according to the data range.
Brush (inherited from Custom) | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
CloseValues (inherited from OHLC) | Gets and sets all Stock market Close values.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DateValues (inherited from OHLC) | Gets and sets all Stock market Date values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HighValues (inherited from OHLC) | Gets and sets all Stock market High values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IncrementAsBox | When true, Chart will try to size grid to box size.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from OHLC) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
LowValues (inherited from OHLC) | Gets and sets all Stock market Low values.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OpenValues (inherited from OHLC) | Gets and sets all Stock market Open values.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Period |
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

CustomTimeOHLC Class | Steema.TeeChart.Styles Namespace


BoxSize

Steema.TeeChart.Styles.CustomTimeOHLC.BoxSize Property

public Double BoxSize {get; set;}

See Also

CustomTimeOHLC Class | CustomTimeOHLC Members | Steema.TeeChart.Styles Namespace


BoxType

Steema.TeeChart.Styles.CustomTimeOHLC.BoxType Property

Use BoxType to change box sensitivity according to the data range.
public BoxTypes BoxType {get; set;}

See Also

CustomTimeOHLC Class | CustomTimeOHLC Members | Steema.TeeChart.Styles Namespace


IncrementAsBox

Steema.TeeChart.Styles.CustomTimeOHLC.IncrementAsBox Property

When true, Chart will try to size grid to box size.
public Boolean IncrementAsBox {get; set;}

See Also

CustomTimeOHLC Class | CustomTimeOHLC Members | Steema.TeeChart.Styles Namespace


Period

Steema.TeeChart.Styles.CustomTimeOHLC.Period Property

public Int32 Period {get; set;}

See Also

CustomTimeOHLC Class | CustomTimeOHLC Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomTimeOHLC.BoxTypes

Steema.TeeChart.Styles.CustomTimeOHLC.BoxTypes Enum

Box type for calculation
[Serializable]
public sealed enum BoxTypes : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
Standard | Use same Box value across all data range
ATR | Use period's Average True range to set Box value for entire chart

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.CustomTimeOHLC.PricingMethods

Steema.TeeChart.Styles.CustomTimeOHLC.PricingMethods Enum

Price method used for calculation
[Serializable]
public sealed enum PricingMethods : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
HighLow | Uses high in a rising market, low price when downward
Close | Uses Close price for both up and downward movements

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Darvas

Steema.TeeChart.Styles.Darvas Class

Darvas Series.

For a list of all members of this type, see Darvas Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
Steema.TeeChart.Styles.OHLC
Steema.TeeChart.Styles.Candle
public class Darvas : Candle , ICloneable, ISeriesPointer

Remarks

The Darvas Boxes were taken from the pages of Nicolas Darvas’ book, How I Made $2,000,000 in the Stock Market. The boxes are used to normalize a trend. A "buy" signal would be indicated when the price of the stock exceeds the top of the box. A "sell" signal would be indicated when the price of the stock falls below the bottom of the box. For more info on Darvas Boxes check the following link: http://www.gerryco.com/tech/darvas.html .

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Darvas members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.DarvasMembers

Steema.TeeChart.Styles.Darvas all Members

Darvas overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
Boxes |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
NumBoxes |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from OHLC) | Adds new point with specified integer index and double open, high, low and close.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked |
ClickedCandle (inherited from Candle) | Returns true if point p is inside the bounds of the ValueIndex candle
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Candle) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from OHLC) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Candle) |
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Candle) |
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Candle) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Candle) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
BoxBrush | Brush used to draw Darvas boxes.
BoxPen | Pen used to draw outline of Darvas boxes.
Brush (inherited from Custom) | Sets Brush characteristics.
CandleWidth (inherited from Candle) | Sets the horizontal Candle Size in pixels.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
CloseValues (inherited from OHLC) | Gets and sets all Stock market Close values.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DateValues (inherited from OHLC) | Gets and sets all Stock market Date values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
DownCloseColor (inherited from Candle) | Candle color fill when Close value is greater than Open value.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HighLowPen (inherited from Candle) | Pen used to draw "high" and "low" lines
HighValues (inherited from OHLC) | Gets and sets all Stock market High values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from OHLC) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
LowValues (inherited from OHLC) | Gets and sets all Stock market Low values.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OpenValues (inherited from OHLC) | Gets and sets all Stock market Open values.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
Pen (inherited from Candle) |
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowClose (inherited from Candle) | Determines whether Close prices will be displayed.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
ShowOpen (inherited from Candle) | Determines whether Open prices will be displayed.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Style (inherited from Candle) | Determines how the Candle points will be drawn.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UpCloseColor (inherited from Candle) | Candle color fill when Open value is greater than Close value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Darvas Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Darvas Constructor

Overload List

public Darvas(Steema.TeeChart.Chart)
public Darvas()

See Also

Darvas Class | Darvas Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Darvas Constructor

public Darvas()

See Also

Darvas Constructor Overload List | Darvas Class | Darvas Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Darvas Constructor

public Darvas(Chart c)

See Also

Darvas Constructor Overload List | Darvas Class | Darvas Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.DarvasEvents

Steema.TeeChart.Styles.Darvas Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Darvas Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.DarvasFields

Steema.TeeChart.Styles.Darvas Fields

Public Fields

bBrush (inherited from Series) |
Boxes |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
NumBoxes |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Darvas Class | Steema.TeeChart.Styles Namespace


Boxes

Steema.TeeChart.Styles.Darvas.Boxes Field

public Rectangle[] Boxes

See Also

Darvas Class | Darvas Members | Steema.TeeChart.Styles Namespace


NumBoxes

Steema.TeeChart.Styles.Darvas.NumBoxes Field

public Int32 NumBoxes

See Also

Darvas Class | Darvas Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.DarvasMethods

Steema.TeeChart.Styles.Darvas Methods

Public Methods

Add (inherited from OHLC) | Adds new point with specified integer index and double open, high, low and close.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked |
ClickedCandle (inherited from Candle) | Returns true if point p is inside the bounds of the ValueIndex candle
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Candle) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from OHLC) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Candle) |
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Candle) |
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Candle) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Candle) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Darvas Class | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Darvas.Clicked Method

Overload List

public override Int32 Clicked(System.Int32, System.Int32)

See Also

Darvas Class | Darvas Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Darvas.Clicked Method

public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | Darvas Class | Darvas Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.Darvas.Draw Method

public override Void Draw()

See Also

Darvas Class | Darvas Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.DarvasProperties

Steema.TeeChart.Styles.Darvas Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
BoxBrush | Brush used to draw Darvas boxes.
BoxPen | Pen used to draw outline of Darvas boxes.
Brush (inherited from Custom) | Sets Brush characteristics.
CandleWidth (inherited from Candle) | Sets the horizontal Candle Size in pixels.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
CloseValues (inherited from OHLC) | Gets and sets all Stock market Close values.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DateValues (inherited from OHLC) | Gets and sets all Stock market Date values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
DownCloseColor (inherited from Candle) | Candle color fill when Close value is greater than Open value.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HighLowPen (inherited from Candle) | Pen used to draw "high" and "low" lines
HighValues (inherited from OHLC) | Gets and sets all Stock market High values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from OHLC) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
LowValues (inherited from OHLC) | Gets and sets all Stock market Low values.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OpenValues (inherited from OHLC) | Gets and sets all Stock market Open values.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
Pen (inherited from Candle) |
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowClose (inherited from Candle) | Determines whether Close prices will be displayed.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
ShowOpen (inherited from Candle) | Determines whether Open prices will be displayed.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Style (inherited from Candle) | Determines how the Candle points will be drawn.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UpCloseColor (inherited from Candle) | Candle color fill when Open value is greater than Close value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Darvas Class | Steema.TeeChart.Styles Namespace


BoxBrush

Steema.TeeChart.Styles.Darvas.BoxBrush Property

Brush used to draw Darvas boxes.
public ChartBrush BoxBrush {get;}

See Also

Darvas Class | Darvas Members | Steema.TeeChart.Styles Namespace


BoxPen

Steema.TeeChart.Styles.Darvas.BoxPen Property

Pen used to draw outline of Darvas boxes.
public ChartPen BoxPen {get;}

See Also

Darvas Class | Darvas Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Darvas.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

Darvas Class | Darvas Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.DigitalFont

Steema.TeeChart.Styles.DigitalFont Enum

[Serializable]
public sealed enum DigitalFont : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
Bar |
Dot |

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Donut

Steema.TeeChart.Styles.Donut Class

Donut series.

For a list of all members of this type, see Donut Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
Steema.TeeChart.Styles.Pie
public class Donut : Pie , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Donut members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.DonutMembers

Steema.TeeChart.Styles.Donut all Members

Donut overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

Angles (inherited from Pie) |
bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Pie) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
BelongsToOtherSlice (inherited from Pie) | Returns true if indexed Slice belongs to the Otherslice
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Pie) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Pie) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Pie) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Pie) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Pie) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery (inherited from Pie) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Pie) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AngleSize (inherited from Pie) | Total angle in degrees (0 to 360) for all slices.
AutoMarkPosition (inherited from Pie) | If true, marks will be displayed trying to not overlap one to each other.
BevelPercent (inherited from Pie) | Gets and sets the bevel as a percentage of the pie's depth.
Brush (inherited from Pie) | Brush fill for PieSeries.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Pie) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
Dark3D (inherited from Pie) | Darkens side of 3D pie section to add depth.
DarkPen (inherited from Pie) |
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
DonutPercent |
EdgeStyle (inherited from Pie) | Gets and sets the EdgeStyle of the bevel.
EndZ (inherited from Series) | For internal use.
ExplodeBiggest (inherited from Pie) | Displaces the biggest slice from centre by value set.
ExplodedSlice (inherited from Pie) | Accesses the properties for exploding any Pie slice.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksPie (inherited from Pie) |
MiddleZ (inherited from Series) | For internal use.
MultiPie (inherited from Pie) | Sets automatic Pie positioning when multiple Pie series exist.
NumGallerySeries (inherited from Series) | For internal use.
OtherSlice (inherited from Pie) | Accesses the OtherSlice properties.
Pen (inherited from Pie) | Line pen for Pie.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
PieValues (inherited from Pie) | Stores the Pie slice values.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow (inherited from Pie) | Defines the offset shadow of the PieSeries.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SliceHeight (inherited from Pie) | Use SliceHeight array property to specify a different height for each pie slice.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Pie) | Sets Transparency level from 0 to 100%.
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
UsePatterns (inherited from Pie) | Fills Pie Sectors with different Brush pattern styles.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Donut Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Donut Constructor

Overload List

public Donut()
public Donut(Steema.TeeChart.Chart)

See Also

Donut Class | Donut Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Donut Constructor

public Donut(Chart c)

See Also

Donut Constructor Overload List | Donut Class | Donut Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Donut Constructor

public Donut()

See Also

Donut Constructor Overload List | Donut Class | Donut Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.DonutEvents

Steema.TeeChart.Styles.Donut Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Donut Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.DonutFields

Steema.TeeChart.Styles.Donut Fields

Public Fields

Angles (inherited from Pie) |
bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Donut Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.DonutMethods

Steema.TeeChart.Styles.Donut Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Pie) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
BelongsToOtherSlice (inherited from Pie) | Returns true if indexed Slice belongs to the Otherslice
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Pie) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Pie) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Pie) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Pie) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Pie) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery (inherited from Pie) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Pie) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Donut Class | Steema.TeeChart.Styles Namespace


GalleryChanged3D

Steema.TeeChart.Styles.Donut.GalleryChanged3D Method

public override Void GalleryChanged3D(Boolean Is3D)

See Also

Donut Class | Donut Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.DonutProperties

Steema.TeeChart.Styles.Donut Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AngleSize (inherited from Pie) | Total angle in degrees (0 to 360) for all slices.
AutoMarkPosition (inherited from Pie) | If true, marks will be displayed trying to not overlap one to each other.
BevelPercent (inherited from Pie) | Gets and sets the bevel as a percentage of the pie's depth.
Brush (inherited from Pie) | Brush fill for PieSeries.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Pie) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
Dark3D (inherited from Pie) | Darkens side of 3D pie section to add depth.
DarkPen (inherited from Pie) |
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
DonutPercent |
EdgeStyle (inherited from Pie) | Gets and sets the EdgeStyle of the bevel.
EndZ (inherited from Series) | For internal use.
ExplodeBiggest (inherited from Pie) | Displaces the biggest slice from centre by value set.
ExplodedSlice (inherited from Pie) | Accesses the properties for exploding any Pie slice.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksPie (inherited from Pie) |
MiddleZ (inherited from Series) | For internal use.
MultiPie (inherited from Pie) | Sets automatic Pie positioning when multiple Pie series exist.
NumGallerySeries (inherited from Series) | For internal use.
OtherSlice (inherited from Pie) | Accesses the OtherSlice properties.
Pen (inherited from Pie) | Line pen for Pie.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
PieValues (inherited from Pie) | Stores the Pie slice values.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow (inherited from Pie) | Defines the offset shadow of the PieSeries.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SliceHeight (inherited from Pie) | Use SliceHeight array property to specify a different height for each pie slice.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Pie) | Sets Transparency level from 0 to 100%.
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
UsePatterns (inherited from Pie) | Fills Pie Sectors with different Brush pattern styles.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Donut Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Donut.Description Property

public override String Description {get;}

See Also

Donut Class | Donut Members | Steema.TeeChart.Styles Namespace


DonutPercent

Steema.TeeChart.Styles.Donut.DonutPercent Property

public Int32 DonutPercent {get; set;}

See Also

Donut Class | Donut Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.DrawAllPointsStyle

Steema.TeeChart.Styles.DrawAllPointsStyle Enum

[Serializable]
public sealed enum DrawAllPointsStyle : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
First | When the series has several points that share the same X pixel position, but with different Y position, it will only display the first point.
MinMax | Plots both the minimum and maximum Y that map to each X pixel.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.EquiVolume

Steema.TeeChart.Styles.EquiVolume Class

EquiVolume Series.

For a list of all members of this type, see EquiVolume Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
Steema.TeeChart.Styles.OHLC
Steema.TeeChart.Styles.Candle
public class EquiVolume : Candle , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

EquiVolume members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.EquiVolumeMembers

Steema.TeeChart.Styles.EquiVolume all Members

EquiVolume overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
calcPassed |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add | Adds new point with specified dateTime date and double volume, open, high, low and close values.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AdjustCalcPosPoint |
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcUnitSize |
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Candle) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedCandle (inherited from Candle) | Returns true if point p is inside the bounds of the ValueIndex candle
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from OHLC) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Candle) |
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Candle) |
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Candle) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Candle) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
BoxFillStyle | Style used to plot EquiVolume Bars
Brush (inherited from Custom) | Sets Brush characteristics.
CandleWidth (inherited from Candle) | Sets the horizontal Candle Size in pixels.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
CloseValues (inherited from OHLC) | Gets and sets all Stock market Close values.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DateValues (inherited from OHLC) | Gets and sets all Stock market Date values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
DownCloseColor (inherited from Candle) | Candle color fill when Close value is greater than Open value.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HighLowPen (inherited from Candle) | Pen used to draw "high" and "low" lines
HighValues (inherited from OHLC) | Gets and sets all Stock market High values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from OHLC) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
LowValues (inherited from OHLC) | Gets and sets all Stock market Low values.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OpenValues (inherited from OHLC) | Gets and sets all Stock market Open values.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
Pen (inherited from Candle) |
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
PointGap | Gap in pixels between each EquiVolume Bar
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowClose (inherited from Candle) | Determines whether Close prices will be displayed.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
ShowOpen (inherited from Candle) | Determines whether Open prices will be displayed.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Style (inherited from Candle) | Determines how the Candle points will be drawn.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UpCloseColor (inherited from Candle) | Candle color fill when Open value is greater than Close value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
VolumePointer | When Visible this pointer marks points where volume exceeds the previous point. Default behaviour is an up triangle where the Close value is higher than the previous point and a down triangle when Close is lower.
VolumeValues | Gets and sets all event Volume values.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

EquiVolume Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.EquiVolume Constructor

Overload List

public EquiVolume()
public EquiVolume(Steema.TeeChart.Chart)

See Also

EquiVolume Class | EquiVolume Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.EquiVolume Constructor

public EquiVolume(Chart c)

See Also

EquiVolume Constructor Overload List | EquiVolume Class | EquiVolume Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.EquiVolume Constructor

public EquiVolume()

See Also

EquiVolume Constructor Overload List | EquiVolume Class | EquiVolume Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.EquiVolumeEvents

Steema.TeeChart.Styles.EquiVolume Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

EquiVolume Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.EquiVolumeFields

Steema.TeeChart.Styles.EquiVolume Fields

Public Fields

bBrush (inherited from Series) |
calcPassed |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

EquiVolume Class | Steema.TeeChart.Styles Namespace


calcPassed

Steema.TeeChart.Styles.EquiVolume.calcPassed Field

public Boolean calcPassed

See Also

EquiVolume Class | EquiVolume Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.EquiVolumeMethods

Steema.TeeChart.Styles.EquiVolume Methods

Public Methods

Add | Adds new point with specified dateTime date and double volume, open, high, low and close values.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AdjustCalcPosPoint |
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcUnitSize |
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Candle) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedCandle (inherited from Candle) | Returns true if point p is inside the bounds of the ValueIndex candle
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from OHLC) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Candle) |
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Candle) |
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Candle) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Candle) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

EquiVolume Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.EquiVolume.Add Method

Overload List

Adds new point with specified dateTime date and double volume, open, high, low and close values.

public Int32 Add(System.DateTime, System.Double, System.Double, System.Double, System.Double, System.Double)

Adds new point with specified double volume, open, high, low and close values.

public override Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Double)

Adds new point with specified integer index and double volume, open, high, low and close values.

public Int32 Add(System.Int32, System.Double, System.Double, System.Double, System.Double, System.Double)

See Also

EquiVolume Class | EquiVolume Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.EquiVolume.Add Method

Adds new point with specified integer index and double volume, open, high, low and close values.
public Int32 Add(Int32 index,
     Double volume,
     Double open,
     Double high,
     Double low,
     Double close)

Return Value

ValueList index of added point

See Also

Add Overload List | EquiVolume Class | EquiVolume Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.EquiVolume.Add Method

Adds new point with specified double volume, open, high, low and close values.
public override Int32 Add(Double volume,
     Double open,
     Double high,
     Double low,
     Double close)

Return Value

ValueList index of added point

See Also

Add Overload List | EquiVolume Class | EquiVolume Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.EquiVolume.Add Method

Adds new point with specified dateTime date and double volume, open, high, low and close values.
public Int32 Add(DateTime aDate,
     Double volume,
     Double open,
     Double high,
     Double low,
     Double close)

Return Value

ValueList index of added point

See Also

Add Overload List | EquiVolume Class | EquiVolume Members | Steema.TeeChart.Styles Namespace


AdjustCalcPosPoint

Steema.TeeChart.Styles.EquiVolume.AdjustCalcPosPoint Method

public Double AdjustCalcPosPoint(Int32 pixelVal)

See Also

EquiVolume Class | EquiVolume Members | Steema.TeeChart.Styles Namespace


CalcUnitSize

Steema.TeeChart.Styles.EquiVolume.CalcUnitSize Method

Overload List

public Void CalcUnitSize()
public Void CalcUnitSize(System.Double, System.Double)

See Also

EquiVolume Class | EquiVolume Members | Steema.TeeChart.Styles Namespace


CalcUnitSize

Steema.TeeChart.Styles.EquiVolume.CalcUnitSize Method

public Void CalcUnitSize(Double min,
     Double max)

See Also

CalcUnitSize Overload List | EquiVolume Class | EquiVolume Members | Steema.TeeChart.Styles Namespace


CalcUnitSize

Steema.TeeChart.Styles.EquiVolume.CalcUnitSize Method

public Void CalcUnitSize()

See Also

CalcUnitSize Overload List | EquiVolume Class | EquiVolume Members | Steema.TeeChart.Styles Namespace


CalcYPos

Steema.TeeChart.Styles.EquiVolume.CalcYPos Method

Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
public override Int32 CalcYPos(Int32 index)

See Also

EquiVolume Class | EquiVolume Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.EquiVolume.Draw Method

public override Void Draw()

See Also

EquiVolume Class | EquiVolume Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.EquiVolume.DrawValue Method

public override Void DrawValue(Int32 valueIndex)

See Also

EquiVolume Class | EquiVolume Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.EquiVolumeProperties

Steema.TeeChart.Styles.EquiVolume Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
BoxFillStyle | Style used to plot EquiVolume Bars
Brush (inherited from Custom) | Sets Brush characteristics.
CandleWidth (inherited from Candle) | Sets the horizontal Candle Size in pixels.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
CloseValues (inherited from OHLC) | Gets and sets all Stock market Close values.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DateValues (inherited from OHLC) | Gets and sets all Stock market Date values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
DownCloseColor (inherited from Candle) | Candle color fill when Close value is greater than Open value.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HighLowPen (inherited from Candle) | Pen used to draw "high" and "low" lines
HighValues (inherited from OHLC) | Gets and sets all Stock market High values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from OHLC) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
LowValues (inherited from OHLC) | Gets and sets all Stock market Low values.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OpenValues (inherited from OHLC) | Gets and sets all Stock market Open values.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
Pen (inherited from Candle) |
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
PointGap | Gap in pixels between each EquiVolume Bar
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowClose (inherited from Candle) | Determines whether Close prices will be displayed.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
ShowOpen (inherited from Candle) | Determines whether Open prices will be displayed.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Style (inherited from Candle) | Determines how the Candle points will be drawn.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UpCloseColor (inherited from Candle) | Candle color fill when Open value is greater than Close value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
VolumePointer | When Visible this pointer marks points where volume exceeds the previous point. Default behaviour is an up triangle where the Close value is higher than the previous point and a down triangle when Close is lower.
VolumeValues | Gets and sets all event Volume values.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

EquiVolume Class | Steema.TeeChart.Styles Namespace


BoxFillStyle

Steema.TeeChart.Styles.EquiVolume.BoxFillStyle Property

Style used to plot EquiVolume Bars
public BoxFillType BoxFillStyle {get; set;}

See Also

EquiVolume Class | EquiVolume Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.EquiVolume.Description Property

public override String Description {get;}

See Also

EquiVolume Class | EquiVolume Members | Steema.TeeChart.Styles Namespace


PointGap

Steema.TeeChart.Styles.EquiVolume.PointGap Property

Gap in pixels between each EquiVolume Bar
public Int32 PointGap {get; set;}

See Also

EquiVolume Class | EquiVolume Members | Steema.TeeChart.Styles Namespace


VolumePointer

Steema.TeeChart.Styles.EquiVolume.VolumePointer Property

When Visible this pointer marks points where volume exceeds the previous point. Default behaviour is an up triangle where the Close value is higher than the previous point and a down triangle when Close is lower.
public SeriesPointer VolumePointer {get; set;}

See Also

EquiVolume Class | EquiVolume Members | Steema.TeeChart.Styles Namespace


VolumeValues

Steema.TeeChart.Styles.EquiVolume.VolumeValues Property

Gets and sets all event Volume values.
public ValueList VolumeValues {get; set;}

See Also

EquiVolume Class | EquiVolume Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.EquiVolume.BoxFillType

Steema.TeeChart.Styles.EquiVolume.BoxFillType Enum

Box fill style for each data point
[Serializable]
public sealed enum BoxFillType : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
FillToClose | Fills Box with Up or Down Colour to Close value
Outline | Use Up and Down Colour to plot Box outline only

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Error

Steema.TeeChart.Styles.Error Class

ErrorSeries Series.

For a list of all members of this type, see Error Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomBar
Steema.TeeChart.Styles.Bar
Steema.TeeChart.Styles.CustomError
public class Error : CustomError , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Error members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorMembers

Steema.TeeChart.Styles.Error all Members

Error overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetBarStyle (inherited from CustomBar) | Occurs when series bars are painted.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from CustomError) | Adds a new Error Bar point in selected color and with label.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddValue (inherited from CustomError) | Adds a new Error Bar point to the Series.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomBar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BarMargin (inherited from CustomBar) | Returns side margin amount in pixels.
BarRectangle (inherited from CustomBar) | For internal use.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Bar) | Returns the Screen X pixel coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Bar) | Returns the Screen Y pixel coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomError) | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawBar (inherited from CustomError) | Displays an ErrorBar point ( BarIndex point ) using the Start and End pixel coordinates.
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from CustomBar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetOriginPos (inherited from Bar) | Returns the corresponding screen pixels coordinate of the leftmost horizontal bar edge.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Bar) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomError) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Bar) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomError) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointOrigin (inherited from CustomBar) | For internal use.
PrepareForGallery (inherited from CustomError) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from CustomBar) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoMarkPosition (inherited from CustomBar) | Repositions Marks on BarSeries to prevent overlapping.
BarBounds (inherited from CustomBar) | Coordinates of current Bar point being displayed.
BarStyle (inherited from CustomBar) | Defines the Bar shape used to draw Bars.
BarWidthPercent (inherited from Bar) | Determines the percent of total Bar width used.
BevelSize (inherited from CustomBar) | Amount in pixels of the bar bevel. Used only when BarStyle property is Bevel (only in 2D and 3D orthogonal display modes)
Brush (inherited from CustomBar) | Defines the Brush used to fill Bars.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent (inherited from CustomBar) |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBarWidth (inherited from CustomBar) |
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from CustomBar) | Darkens sides of bars to enhance 3D effect.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthPercent (inherited from CustomBar) | Defines the percentage, from 0 to 100, that the bars will need in the "Z" depth space direction.
Description |
EndZ (inherited from Series) | For internal use.
ErrorPen (inherited from CustomError) | Defines Pen to draw Error "T" on top of Error Bars.
ErrorStyle (inherited from CustomError) | Defines the Error Series Style according to EErrorSeriesStyle.
ErrorValues (inherited from CustomError) | Gets and sets the corresponding Error value for each Bar.
ErrorWidth (inherited from CustomError) | Determines the horizontal size of the Error "T".
ErrorWidthUnits (inherited from CustomError) | Sets ErrorWidth in pixels or percentage of Bar width.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from CustomBar) | Defines the color Gradient used to fill the Bars.
GradientRelative (inherited from CustomBar) | When Gradient is Visible, calculates Colors based on highest bar.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksLocation (inherited from CustomBar) | Sets the alignment of the Mark into the Bars.
MarksOnBar (inherited from CustomBar) | Sets a postition of the Marks into the Bars.
MiddleZ (inherited from Series) | For internal use.
MultiBar (inherited from CustomBar) | Determines how multiple BarSeries will be displayed in the same Chart.
NumGallerySeries (inherited from Series) | For internal use.
OffsetPercent (inherited from CustomBar) | Sets the Bar displacement as percent of Bar size.
Origin (inherited from CustomBar) | Sets the common bottom value used for all Bar points.
Pen (inherited from CustomBar) | Pen used to draw the Bar rectangles.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow (inherited from CustomBar) | Defines the Shadow used to draw behind the Bars.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideMargins (inherited from CustomBar) | Sets a margin between Chart rectangle and Bars.
StackGroup (inherited from CustomBar) | Allows stacking independent Series within the same Chart.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickLines (inherited from CustomBar) | Pen used to draw "tick" lines across each bar.
Title (inherited from Series) | Series description to show in Legend and editors.
UseOrigin (inherited from CustomBar) | Allows Bars to be bottom aligned to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin (inherited from CustomBar) | System.Obsolete: Please use Origin property.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Error Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Error Constructor

Overload List

public Error()
public Error(Steema.TeeChart.Chart)

See Also

Error Class | Error Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Error Constructor

public Error(Chart c)

See Also

Error Constructor Overload List | Error Class | Error Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Error Constructor

public Error()

See Also

Error Constructor Overload List | Error Class | Error Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorEvents

Steema.TeeChart.Styles.Error Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetBarStyle (inherited from CustomBar) | Occurs when series bars are painted.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Error Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorFields

Steema.TeeChart.Styles.Error Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Error Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorMethods

Steema.TeeChart.Styles.Error Methods

Public Methods

Add (inherited from CustomError) | Adds a new Error Bar point in selected color and with label.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddValue (inherited from CustomError) | Adds a new Error Bar point to the Series.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomBar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BarMargin (inherited from CustomBar) | Returns side margin amount in pixels.
BarRectangle (inherited from CustomBar) | For internal use.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Bar) | Returns the Screen X pixel coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Bar) | Returns the Screen Y pixel coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomError) | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawBar (inherited from CustomError) | Displays an ErrorBar point ( BarIndex point ) using the Start and End pixel coordinates.
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from CustomBar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetOriginPos (inherited from Bar) | Returns the corresponding screen pixels coordinate of the leftmost horizontal bar edge.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Bar) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomError) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Bar) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomError) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointOrigin (inherited from CustomBar) | For internal use.
PrepareForGallery (inherited from CustomError) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from CustomBar) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Error Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorProperties

Steema.TeeChart.Styles.Error Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoMarkPosition (inherited from CustomBar) | Repositions Marks on BarSeries to prevent overlapping.
BarBounds (inherited from CustomBar) | Coordinates of current Bar point being displayed.
BarStyle (inherited from CustomBar) | Defines the Bar shape used to draw Bars.
BarWidthPercent (inherited from Bar) | Determines the percent of total Bar width used.
BevelSize (inherited from CustomBar) | Amount in pixels of the bar bevel. Used only when BarStyle property is Bevel (only in 2D and 3D orthogonal display modes)
Brush (inherited from CustomBar) | Defines the Brush used to fill Bars.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent (inherited from CustomBar) |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBarWidth (inherited from CustomBar) |
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from CustomBar) | Darkens sides of bars to enhance 3D effect.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthPercent (inherited from CustomBar) | Defines the percentage, from 0 to 100, that the bars will need in the "Z" depth space direction.
Description |
EndZ (inherited from Series) | For internal use.
ErrorPen (inherited from CustomError) | Defines Pen to draw Error "T" on top of Error Bars.
ErrorStyle (inherited from CustomError) | Defines the Error Series Style according to EErrorSeriesStyle.
ErrorValues (inherited from CustomError) | Gets and sets the corresponding Error value for each Bar.
ErrorWidth (inherited from CustomError) | Determines the horizontal size of the Error "T".
ErrorWidthUnits (inherited from CustomError) | Sets ErrorWidth in pixels or percentage of Bar width.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from CustomBar) | Defines the color Gradient used to fill the Bars.
GradientRelative (inherited from CustomBar) | When Gradient is Visible, calculates Colors based on highest bar.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksLocation (inherited from CustomBar) | Sets the alignment of the Mark into the Bars.
MarksOnBar (inherited from CustomBar) | Sets a postition of the Marks into the Bars.
MiddleZ (inherited from Series) | For internal use.
MultiBar (inherited from CustomBar) | Determines how multiple BarSeries will be displayed in the same Chart.
NumGallerySeries (inherited from Series) | For internal use.
OffsetPercent (inherited from CustomBar) | Sets the Bar displacement as percent of Bar size.
Origin (inherited from CustomBar) | Sets the common bottom value used for all Bar points.
Pen (inherited from CustomBar) | Pen used to draw the Bar rectangles.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow (inherited from CustomBar) | Defines the Shadow used to draw behind the Bars.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideMargins (inherited from CustomBar) | Sets a margin between Chart rectangle and Bars.
StackGroup (inherited from CustomBar) | Allows stacking independent Series within the same Chart.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickLines (inherited from CustomBar) | Pen used to draw "tick" lines across each bar.
Title (inherited from Series) | Series description to show in Legend and editors.
UseOrigin (inherited from CustomBar) | Allows Bars to be bottom aligned to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin (inherited from CustomBar) | System.Obsolete: Please use Origin property.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Error Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Error.Description Property

public override String Description {get;}

See Also

Error Class | Error Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorBar

Steema.TeeChart.Styles.ErrorBar Class

ErrorBar Series.

For a list of all members of this type, see ErrorBar Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomBar
Steema.TeeChart.Styles.Bar
Steema.TeeChart.Styles.CustomError
public class ErrorBar : CustomError , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

ErrorBar members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorBarMembers

Steema.TeeChart.Styles.ErrorBar all Members

ErrorBar overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetBarStyle (inherited from CustomBar) | Occurs when series bars are painted.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from CustomError) | Adds a new Error Bar point in selected color and with label.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddValue (inherited from CustomError) | Adds a new Error Bar point to the Series.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomBar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BarMargin (inherited from CustomBar) | Returns side margin amount in pixels.
BarRectangle (inherited from CustomBar) | For internal use.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Bar) | Returns the Screen X pixel coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Bar) | Returns the Screen Y pixel coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomError) | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawBar (inherited from CustomError) | Displays an ErrorBar point ( BarIndex point ) using the Start and End pixel coordinates.
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from CustomBar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetOriginPos (inherited from Bar) | Returns the corresponding screen pixels coordinate of the leftmost horizontal bar edge.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Bar) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomError) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Bar) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomError) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointOrigin (inherited from CustomBar) | For internal use.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from CustomBar) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoMarkPosition (inherited from CustomBar) | Repositions Marks on BarSeries to prevent overlapping.
BarBounds (inherited from CustomBar) | Coordinates of current Bar point being displayed.
BarStyle (inherited from CustomBar) | Defines the Bar shape used to draw Bars.
BarWidthPercent (inherited from Bar) | Determines the percent of total Bar width used.
BevelSize (inherited from CustomBar) | Amount in pixels of the bar bevel. Used only when BarStyle property is Bevel (only in 2D and 3D orthogonal display modes)
Brush (inherited from CustomBar) | Defines the Brush used to fill Bars.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent (inherited from CustomBar) |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBarWidth (inherited from CustomBar) |
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from CustomBar) | Darkens sides of bars to enhance 3D effect.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthPercent (inherited from CustomBar) | Defines the percentage, from 0 to 100, that the bars will need in the "Z" depth space direction.
Description | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
ErrorPen (inherited from CustomError) | Defines Pen to draw Error "T" on top of Error Bars.
ErrorStyle (inherited from CustomError) | Defines the Error Series Style according to EErrorSeriesStyle.
ErrorValues (inherited from CustomError) | Gets and sets the corresponding Error value for each Bar.
ErrorWidth (inherited from CustomError) | Determines the horizontal size of the Error "T".
ErrorWidthUnits (inherited from CustomError) | Sets ErrorWidth in pixels or percentage of Bar width.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from CustomBar) | Defines the color Gradient used to fill the Bars.
GradientRelative (inherited from CustomBar) | When Gradient is Visible, calculates Colors based on highest bar.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksLocation (inherited from CustomBar) | Sets the alignment of the Mark into the Bars.
MarksOnBar (inherited from CustomBar) | Sets a postition of the Marks into the Bars.
MiddleZ (inherited from Series) | For internal use.
MultiBar (inherited from CustomBar) | Determines how multiple BarSeries will be displayed in the same Chart.
NumGallerySeries (inherited from Series) | For internal use.
OffsetPercent (inherited from CustomBar) | Sets the Bar displacement as percent of Bar size.
Origin (inherited from CustomBar) | Sets the common bottom value used for all Bar points.
Pen (inherited from CustomBar) | Pen used to draw the Bar rectangles.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow (inherited from CustomBar) | Defines the Shadow used to draw behind the Bars.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideMargins (inherited from CustomBar) | Sets a margin between Chart rectangle and Bars.
StackGroup (inherited from CustomBar) | Allows stacking independent Series within the same Chart.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickLines (inherited from CustomBar) | Pen used to draw "tick" lines across each bar.
Title (inherited from Series) | Series description to show in Legend and editors.
UseOrigin (inherited from CustomBar) | Allows Bars to be bottom aligned to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin (inherited from CustomBar) | System.Obsolete: Please use Origin property.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

ErrorBar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorBar Constructor

Overload List

public ErrorBar()
public ErrorBar(Steema.TeeChart.Chart)

See Also

ErrorBar Class | ErrorBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorBar Constructor

public ErrorBar(Chart c)

See Also

ErrorBar Constructor Overload List | ErrorBar Class | ErrorBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorBar Constructor

public ErrorBar()

See Also

ErrorBar Constructor Overload List | ErrorBar Class | ErrorBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorBarEvents

Steema.TeeChart.Styles.ErrorBar Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetBarStyle (inherited from CustomBar) | Occurs when series bars are painted.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

ErrorBar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorBarFields

Steema.TeeChart.Styles.ErrorBar Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

ErrorBar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorBarMethods

Steema.TeeChart.Styles.ErrorBar Methods

Public Methods

Add (inherited from CustomError) | Adds a new Error Bar point in selected color and with label.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddValue (inherited from CustomError) | Adds a new Error Bar point to the Series.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomBar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BarMargin (inherited from CustomBar) | Returns side margin amount in pixels.
BarRectangle (inherited from CustomBar) | For internal use.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Bar) | Returns the Screen X pixel coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Bar) | Returns the Screen Y pixel coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomError) | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawBar (inherited from CustomError) | Displays an ErrorBar point ( BarIndex point ) using the Start and End pixel coordinates.
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from CustomBar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetOriginPos (inherited from Bar) | Returns the corresponding screen pixels coordinate of the leftmost horizontal bar edge.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Bar) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomError) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Bar) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomError) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointOrigin (inherited from CustomBar) | For internal use.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from CustomBar) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

ErrorBar Class | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.ErrorBar.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

ErrorBar Class | ErrorBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorBarProperties

Steema.TeeChart.Styles.ErrorBar Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoMarkPosition (inherited from CustomBar) | Repositions Marks on BarSeries to prevent overlapping.
BarBounds (inherited from CustomBar) | Coordinates of current Bar point being displayed.
BarStyle (inherited from CustomBar) | Defines the Bar shape used to draw Bars.
BarWidthPercent (inherited from Bar) | Determines the percent of total Bar width used.
BevelSize (inherited from CustomBar) | Amount in pixels of the bar bevel. Used only when BarStyle property is Bevel (only in 2D and 3D orthogonal display modes)
Brush (inherited from CustomBar) | Defines the Brush used to fill Bars.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent (inherited from CustomBar) |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBarWidth (inherited from CustomBar) |
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from CustomBar) | Darkens sides of bars to enhance 3D effect.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthPercent (inherited from CustomBar) | Defines the percentage, from 0 to 100, that the bars will need in the "Z" depth space direction.
Description | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
ErrorPen (inherited from CustomError) | Defines Pen to draw Error "T" on top of Error Bars.
ErrorStyle (inherited from CustomError) | Defines the Error Series Style according to EErrorSeriesStyle.
ErrorValues (inherited from CustomError) | Gets and sets the corresponding Error value for each Bar.
ErrorWidth (inherited from CustomError) | Determines the horizontal size of the Error "T".
ErrorWidthUnits (inherited from CustomError) | Sets ErrorWidth in pixels or percentage of Bar width.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from CustomBar) | Defines the color Gradient used to fill the Bars.
GradientRelative (inherited from CustomBar) | When Gradient is Visible, calculates Colors based on highest bar.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksLocation (inherited from CustomBar) | Sets the alignment of the Mark into the Bars.
MarksOnBar (inherited from CustomBar) | Sets a postition of the Marks into the Bars.
MiddleZ (inherited from Series) | For internal use.
MultiBar (inherited from CustomBar) | Determines how multiple BarSeries will be displayed in the same Chart.
NumGallerySeries (inherited from Series) | For internal use.
OffsetPercent (inherited from CustomBar) | Sets the Bar displacement as percent of Bar size.
Origin (inherited from CustomBar) | Sets the common bottom value used for all Bar points.
Pen (inherited from CustomBar) | Pen used to draw the Bar rectangles.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow (inherited from CustomBar) | Defines the Shadow used to draw behind the Bars.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideMargins (inherited from CustomBar) | Sets a margin between Chart rectangle and Bars.
StackGroup (inherited from CustomBar) | Allows stacking independent Series within the same Chart.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickLines (inherited from CustomBar) | Pen used to draw "tick" lines across each bar.
Title (inherited from Series) | Series description to show in Legend and editors.
UseOrigin (inherited from CustomBar) | Allows Bars to be bottom aligned to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin (inherited from CustomBar) | System.Obsolete: Please use Origin property.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

ErrorBar Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.ErrorBar.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

ErrorBar Class | ErrorBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorPoint

Steema.TeeChart.Styles.ErrorPoint Class

ErrorPoint Series.

For a list of all members of this type, see ErrorPoint Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Points
Steema.TeeChart.Styles.CustomErrorPoint
public class ErrorPoint : CustomErrorPoint , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

ErrorPoint members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorPointMembers

Steema.TeeChart.Styles.ErrorPoint all Members

ErrorPoint overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from CustomErrorPoint) | Adds a new Point with the four errors in selected color and with label.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomErrorPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomErrorPoint) |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomErrorPoint) |
MaxYValue (inherited from CustomErrorPoint) |
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomErrorPoint) |
MinYValue (inherited from CustomErrorPoint) |
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from CustomErrorPoint) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
Errors (inherited from CustomErrorPoint) | Gets and sets the corresponding ChartErrors Errors
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

ErrorPoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorPoint Constructor

Overload List

public ErrorPoint()
public ErrorPoint(Steema.TeeChart.Chart)

See Also

ErrorPoint Class | ErrorPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorPoint Constructor

public ErrorPoint(Chart c)

See Also

ErrorPoint Constructor Overload List | ErrorPoint Class | ErrorPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorPoint Constructor

public ErrorPoint()

See Also

ErrorPoint Constructor Overload List | ErrorPoint Class | ErrorPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorPointEvents

Steema.TeeChart.Styles.ErrorPoint Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

ErrorPoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorPointFields

Steema.TeeChart.Styles.ErrorPoint Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

ErrorPoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorPointMethods

Steema.TeeChart.Styles.ErrorPoint Methods

Public Methods

Add (inherited from CustomErrorPoint) | Adds a new Point with the four errors in selected color and with label.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomErrorPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomErrorPoint) |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomErrorPoint) |
MaxYValue (inherited from CustomErrorPoint) |
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomErrorPoint) |
MinYValue (inherited from CustomErrorPoint) |
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

ErrorPoint Class | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.ErrorPoint.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

ErrorPoint Class | ErrorPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorPointProperties

Steema.TeeChart.Styles.ErrorPoint Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from CustomErrorPoint) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
Errors (inherited from CustomErrorPoint) | Gets and sets the corresponding ChartErrors Errors
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

ErrorPoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorPoint3D

Steema.TeeChart.Styles.ErrorPoint3D Class

ErrorPoint3D Series.

For a list of all members of this type, see ErrorPoint3D Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Points3D
Steema.TeeChart.Styles.CustomErrorPoint3D
public class ErrorPoint3D : CustomErrorPoint3D , ICloneable
, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

ErrorPoint3D members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorPoint3DMembers

Steema.TeeChart.Styles.ErrorPoint3D all Members

ErrorPoint3D overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle (inherited from Points3D) |
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from CustomErrorPoint3D) | Adds a new Point3D with the six errors in selected color and with label.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomErrorPoint3D) | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Points3D) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomErrorPoint3D) |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomErrorPoint3D) |
MaxYValue (inherited from CustomErrorPoint3D) |
MaxZValue (inherited from CustomErrorPoint3D) |
MinXValue (inherited from CustomErrorPoint3D) |
MinYValue (inherited from CustomErrorPoint3D) |
MinZValue (inherited from CustomErrorPoint3D) |
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points3D) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
BaseLine (inherited from Points3D) | Sets the Pen for the Point3D connecting Lines.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthSize (inherited from Points3D) | Sets the Depth of each 3DPoint to the value of DepthSize.
Description (inherited from CustomErrorPoint3D) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
Errors (inherited from CustomErrorPoint3D) | Gets and sets the corresponding ChartErrors Errors
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Custom3D) | XYZ Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points3D) | Sets the Pen for the Point3D connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from Points3D) | Each point in a PointSeries is drawn using the Pointer properties.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from Points3D) |
TreatNulls (inherited from Points3D) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

ErrorPoint3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorPoint3D Constructor

Overload List

public ErrorPoint3D()
public ErrorPoint3D(Steema.TeeChart.Chart)

See Also

ErrorPoint3D Class | ErrorPoint3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorPoint3D Constructor

public ErrorPoint3D(Chart c)

See Also

ErrorPoint3D Constructor Overload List | ErrorPoint3D Class | ErrorPoint3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorPoint3D Constructor

public ErrorPoint3D()

See Also

ErrorPoint3D Constructor Overload List | ErrorPoint3D Class | ErrorPoint3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorPoint3DEvents

Steema.TeeChart.Styles.ErrorPoint3D Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle (inherited from Points3D) |
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

ErrorPoint3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorPoint3DFields

Steema.TeeChart.Styles.ErrorPoint3D Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

ErrorPoint3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorPoint3DMethods

Steema.TeeChart.Styles.ErrorPoint3D Methods

Public Methods

Add (inherited from CustomErrorPoint3D) | Adds a new Point3D with the six errors in selected color and with label.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomErrorPoint3D) | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Points3D) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomErrorPoint3D) |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomErrorPoint3D) |
MaxYValue (inherited from CustomErrorPoint3D) |
MaxZValue (inherited from CustomErrorPoint3D) |
MinXValue (inherited from CustomErrorPoint3D) |
MinYValue (inherited from CustomErrorPoint3D) |
MinZValue (inherited from CustomErrorPoint3D) |
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points3D) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

ErrorPoint3D Class | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.ErrorPoint3D.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

ErrorPoint3D Class | ErrorPoint3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorPoint3DProperties

Steema.TeeChart.Styles.ErrorPoint3D Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
BaseLine (inherited from Points3D) | Sets the Pen for the Point3D connecting Lines.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthSize (inherited from Points3D) | Sets the Depth of each 3DPoint to the value of DepthSize.
Description (inherited from CustomErrorPoint3D) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
Errors (inherited from CustomErrorPoint3D) | Gets and sets the corresponding ChartErrors Errors
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Custom3D) | XYZ Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points3D) | Sets the Pen for the Point3D connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from Points3D) | Each point in a PointSeries is drawn using the Pointer properties.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from Points3D) |
TreatNulls (inherited from Points3D) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

ErrorPoint3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorsFormat

Steema.TeeChart.Styles.ErrorsFormat Class

For a list of all members of this type, see ErrorsFormat Members

System.Object
public class ErrorsFormat : Object

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

ErrorsFormat members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorsFormatMembers

Steema.TeeChart.Styles.ErrorsFormat all Members

ErrorsFormat overview

Constructors

Constructor

Public Fields

IntChart

Public Properties

Bottom | Defines Pen to draw Error "T" on bottom of Error Points.
Left | Defines Pen to draw Error "T" on left of Error Points.
Right | Defines Pen to draw Error "T" on right of Error Points.
Top | Defines Pen to draw Error "T" on top of Error Points.

See Also

ErrorsFormat Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorsFormat Constructor

public ErrorsFormat(Chart c)

See Also

ErrorsFormat Class | ErrorsFormat Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorsFormatFields

Steema.TeeChart.Styles.ErrorsFormat Fields

Public Fields

IntChart

See Also

ErrorsFormat Class | Steema.TeeChart.Styles Namespace


IntChart

Steema.TeeChart.Styles.ErrorsFormat.IntChart Field

public Chart IntChart

See Also

ErrorsFormat Class | ErrorsFormat Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorsFormatProperties

Steema.TeeChart.Styles.ErrorsFormat Properties

Public Properties

Bottom | Defines Pen to draw Error "T" on bottom of Error Points.
Left | Defines Pen to draw Error "T" on left of Error Points.
Right | Defines Pen to draw Error "T" on right of Error Points.
Top | Defines Pen to draw Error "T" on top of Error Points.

See Also

ErrorsFormat Class | Steema.TeeChart.Styles Namespace


Bottom

Steema.TeeChart.Styles.ErrorsFormat.Bottom Property

Defines Pen to draw Error "T" on bottom of Error Points.
public ChartPen Bottom {get; set;}

See Also

ErrorsFormat Class | ErrorsFormat Members | Steema.TeeChart.Styles Namespace


Left

Steema.TeeChart.Styles.ErrorsFormat.Left Property

Defines Pen to draw Error "T" on left of Error Points.
public ChartPen Left {get; set;}

See Also

ErrorsFormat Class | ErrorsFormat Members | Steema.TeeChart.Styles Namespace


Right

Steema.TeeChart.Styles.ErrorsFormat.Right Property

Defines Pen to draw Error "T" on right of Error Points.
public ChartPen Right {get; set;}

See Also

ErrorsFormat Class | ErrorsFormat Members | Steema.TeeChart.Styles Namespace


Top

Steema.TeeChart.Styles.ErrorsFormat.Top Property

Defines Pen to draw Error "T" on top of Error Points.
public ChartPen Top {get; set;}

See Also

ErrorsFormat Class | ErrorsFormat Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorsFormat3D

Steema.TeeChart.Styles.ErrorsFormat3D Class

For a list of all members of this type, see ErrorsFormat3D Members

System.Object
Steema.TeeChart.Styles.ErrorsFormat
public class ErrorsFormat3D : ErrorsFormat

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

ErrorsFormat3D members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorsFormat3DMembers

Steema.TeeChart.Styles.ErrorsFormat3D all Members

ErrorsFormat3D overview

Constructors

Constructor

Public Fields

IntChart (inherited from ErrorsFormat)

Public Properties

Back | Defines Pen to draw Error "T" on back of Error 3D Points.
Bottom (inherited from ErrorsFormat) | Defines Pen to draw Error "T" on bottom of Error Points.
Front | Defines Pen to draw Error "T" on front of Error 3D Points.
Left (inherited from ErrorsFormat) | Defines Pen to draw Error "T" on left of Error Points.
Right (inherited from ErrorsFormat) | Defines Pen to draw Error "T" on right of Error Points.
Top (inherited from ErrorsFormat) | Defines Pen to draw Error "T" on top of Error Points.

See Also

ErrorsFormat3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorsFormat3D Constructor

public ErrorsFormat3D(Chart c)

See Also

ErrorsFormat3D Class | ErrorsFormat3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorsFormat3DFields

Steema.TeeChart.Styles.ErrorsFormat3D Fields

Public Fields

IntChart (inherited from ErrorsFormat)

See Also

ErrorsFormat3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorsFormat3DProperties

Steema.TeeChart.Styles.ErrorsFormat3D Properties

Public Properties

Back | Defines Pen to draw Error "T" on back of Error 3D Points.
Bottom (inherited from ErrorsFormat) | Defines Pen to draw Error "T" on bottom of Error Points.
Front | Defines Pen to draw Error "T" on front of Error 3D Points.
Left (inherited from ErrorsFormat) | Defines Pen to draw Error "T" on left of Error Points.
Right (inherited from ErrorsFormat) | Defines Pen to draw Error "T" on right of Error Points.
Top (inherited from ErrorsFormat) | Defines Pen to draw Error "T" on top of Error Points.

See Also

ErrorsFormat3D Class | Steema.TeeChart.Styles Namespace


Back

Steema.TeeChart.Styles.ErrorsFormat3D.Back Property

Defines Pen to draw Error "T" on back of Error 3D Points.
public ChartPen Back {get; set;}

See Also

ErrorsFormat3D Class | ErrorsFormat3D Members | Steema.TeeChart.Styles Namespace


Front

Steema.TeeChart.Styles.ErrorsFormat3D.Front Property

Defines Pen to draw Error "T" on front of Error 3D Points.
public ChartPen Front {get; set;}

See Also

ErrorsFormat3D Class | ErrorsFormat3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorStyles

Steema.TeeChart.Styles.ErrorStyles Enum

Describes the possible values of the ErrorStyle property.
[Serializable]
public sealed enum ErrorStyles : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
Left | Crossbar of 'T' error displacement indicator displayed on the left.
Right | Crossbar of 'T' error displacement indicator displayed on the right.
LeftRight | Crossbar of 'T' error displacement indicator displayed on the left and right.
Top | Crossbar of 'T' error displacement indicator displayed on the top.
Bottom | Crossbar of 'T' error displacement indicator displayed on the bottom.
TopBottom | Crossbar of 'T' error displacement indicator displayed on the top and bottom.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ErrorWidthUnits

Steema.TeeChart.Styles.ErrorWidthUnits Enum

Describes the possible values of the ErrorWidthUnits property.
[Serializable]
public sealed enum ErrorWidthUnits : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Percent | Defines the error width units as a percentage of the chart size.
Pixels | Defines the error width units in pixels.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.FastLine

Steema.TeeChart.Styles.FastLine Class

The FastLine Series is an extremely simple Series component that draws its points as fast as possible.

For a list of all members of this type, see FastLine Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
public class FastLine : BaseLine , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

FastLine members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.FastLineMembers

Steema.TeeChart.Styles.FastLine all Members

FastLine overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from BaseLine) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue |
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue |
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoRepaint |
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
DrawAllPoints |
DrawAllPointsStyle |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IgnoreNulls |
InvertedStairs |
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stairs |
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency |
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

FastLine Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.FastLine Constructor

Overload List

public FastLine(Steema.TeeChart.Chart)
public FastLine()

See Also

FastLine Class | FastLine Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.FastLine Constructor

public FastLine()

See Also

FastLine Constructor Overload List | FastLine Class | FastLine Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.FastLine Constructor

public FastLine(Chart c)

See Also

FastLine Constructor Overload List | FastLine Class | FastLine Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.FastLineEvents

Steema.TeeChart.Styles.FastLine Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

FastLine Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.FastLineFields

Steema.TeeChart.Styles.FastLine Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

FastLine Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.FastLineMethods

Steema.TeeChart.Styles.FastLine Methods

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from BaseLine) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue |
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue |
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

FastLine Class | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.FastLine.Clicked Method

Overload List

Returns the ValueIndex of the "clicked" point in the Series.

public override Int32 Clicked(System.Int32, System.Int32)

See Also

FastLine Class | FastLine Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.FastLine.Clicked Method

Returns the ValueIndex of the "clicked" point in the Series.
public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | FastLine Class | FastLine Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.FastLine.Draw Method

public override Void Draw()

See Also

FastLine Class | FastLine Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.FastLine.DrawValue Method

Called internally. Draws the "ValueIndex" point of the Series.
public override Void DrawValue(Int32 index)

See Also

FastLine Class | FastLine Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.FastLine.MaxYValue Method

public override Double MaxYValue()

See Also

FastLine Class | FastLine Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.FastLine.MinYValue Method

public override Double MinYValue()

See Also

FastLine Class | FastLine Members | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.FastLine.SetSubGallery Method

public override Void SetSubGallery(Int32 index)

See Also

FastLine Class | FastLine Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.FastLineProperties

Steema.TeeChart.Styles.FastLine Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoRepaint |
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
DrawAllPoints |
DrawAllPointsStyle |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IgnoreNulls |
InvertedStairs |
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stairs |
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency |
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

FastLine Class | Steema.TeeChart.Styles Namespace


AutoRepaint

Steema.TeeChart.Styles.FastLine.AutoRepaint Property

public Boolean AutoRepaint {get; set;}

See Also

FastLine Class | FastLine Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.FastLine.Description Property

public override String Description {get;}

See Also

FastLine Class | FastLine Members | Steema.TeeChart.Styles Namespace


DrawAllPoints

Steema.TeeChart.Styles.FastLine.DrawAllPoints Property

public Boolean DrawAllPoints {get; set;}

See Also

FastLine Class | FastLine Members | Steema.TeeChart.Styles Namespace


DrawAllPointsStyle

Steema.TeeChart.Styles.FastLine.DrawAllPointsStyle Property

public DrawAllPointsStyle DrawAllPointsStyle {get; set;}

See Also

FastLine Class | FastLine Members | Steema.TeeChart.Styles Namespace


IgnoreNulls

Steema.TeeChart.Styles.FastLine.IgnoreNulls Property

public Boolean IgnoreNulls {get; set;}

See Also

FastLine Class | FastLine Members | Steema.TeeChart.Styles Namespace


InvertedStairs

Steema.TeeChart.Styles.FastLine.InvertedStairs Property

public Boolean InvertedStairs {get; set;}

See Also

FastLine Class | FastLine Members | Steema.TeeChart.Styles Namespace


Stairs

Steema.TeeChart.Styles.FastLine.Stairs Property

public Boolean Stairs {get; set;}

See Also

FastLine Class | FastLine Members | Steema.TeeChart.Styles Namespace


Transparency

Steema.TeeChart.Styles.FastLine.Transparency Property

public Int32 Transparency {get; set;}

See Also

FastLine Class | FastLine Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Funnel

Steema.TeeChart.Styles.Funnel Class

Funnel Series.

For a list of all members of this type, see Funnel Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class Funnel : Series , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Funnel members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.FunnelMembers

Steema.TeeChart.Styles.Funnel all Members

Funnel overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add | Adds new Funnel segment to the Series.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Series) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
Recalc | Uses all Quote and Opportunity values to reconstruct the Funnel chart.
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

AboveColor | Funnel segment color if Opportunity value is greater than Quote value.
Active (inherited from Series) | Shows or hides this series.
AutoUpdate | Reconstructs FunnelSeries with every added point.
BelowColor | Funnel segment color if Opportunity value is more than the DifferenceLimit % below the Quote value.
Brush | Defines Brush to fill Funnel Series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
DifferenceLimit | Sets the difference (expressed in Quote %) used to define the Funnel segment color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinesPen | Defines Pen to draw FunnelSeries bounding polygon.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
OpportunityValues |
Pen | Define Pen to draw the Funnel Chart.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
QuotesSorted | Sorts added segments by QuoteValues in descending order.
QuoteValues | Accesses the quote values of the FunnelSeries.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
WithinColor | Funnel segment color if Opportunity value is within DifferenceLimit % below the Quote value.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Funnel Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Funnel Constructor

Overload List

public Funnel(Steema.TeeChart.Chart)
public Funnel()

See Also

Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Funnel Constructor

public Funnel()

See Also

Funnel Constructor Overload List | Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Funnel Constructor

public Funnel(Chart c)

See Also

Funnel Constructor Overload List | Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.FunnelEvents

Steema.TeeChart.Styles.Funnel Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Funnel Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.FunnelFields

Steema.TeeChart.Styles.Funnel Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Funnel Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.FunnelMethods

Steema.TeeChart.Styles.Funnel Methods

Public Methods

Add | Adds new Funnel segment to the Series.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Series) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
Recalc | Uses all Quote and Opportunity values to reconstruct the Funnel chart.
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Funnel Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Funnel.Add Method

Overload List

Adds new Funnel segment to the Series.

public Int32 Add(System.Double, System.Double, System.String, System.Drawing.Color)

See Also

Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Funnel.Add Method

Adds new Funnel segment to the Series.
public Int32 Add(Double aQuote,
     Double aOpportunity,
     String aLabel,
     Color aColor)

See Also

Add Overload List | Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.Funnel.Draw Method

public override Void Draw()

See Also

Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.Funnel.DrawValue Method

Called internally. Draws the "ValueIndex" point of the Series.
public override Void DrawValue(Int32 valueIndex)

See Also

Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


LegendString

Steema.TeeChart.Styles.Funnel.LegendString Method

Returns LegendString for LegendIndexth item.
public override String LegendString(Int32 legendIndex,
     LegendTextStyles legendTextStyle)

See Also

Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.Funnel.MaxXValue Method

Returns the Maximum Value of the Series X Values List.
public override Double MaxXValue()

See Also

Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


MinXValue

Steema.TeeChart.Styles.Funnel.MinXValue Method

Returns the Minimum Value of the Series X Values List.
public override Double MinXValue()

See Also

Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.Funnel.MinYValue Method

Returns the Minimum Value of the Series Y Values List.
public override Double MinYValue()

See Also

Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


Recalc

Steema.TeeChart.Styles.Funnel.Recalc Method

Uses all Quote and Opportunity values to reconstruct the Funnel chart.
public Void Recalc()

See Also

Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.FunnelProperties

Steema.TeeChart.Styles.Funnel Properties

Public Properties

AboveColor | Funnel segment color if Opportunity value is greater than Quote value.
Active (inherited from Series) | Shows or hides this series.
AutoUpdate | Reconstructs FunnelSeries with every added point.
BelowColor | Funnel segment color if Opportunity value is more than the DifferenceLimit % below the Quote value.
Brush | Defines Brush to fill Funnel Series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
DifferenceLimit | Sets the difference (expressed in Quote %) used to define the Funnel segment color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinesPen | Defines Pen to draw FunnelSeries bounding polygon.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
OpportunityValues |
Pen | Define Pen to draw the Funnel Chart.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
QuotesSorted | Sorts added segments by QuoteValues in descending order.
QuoteValues | Accesses the quote values of the FunnelSeries.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
WithinColor | Funnel segment color if Opportunity value is within DifferenceLimit % below the Quote value.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Funnel Class | Steema.TeeChart.Styles Namespace


AboveColor

Steema.TeeChart.Styles.Funnel.AboveColor Property

Funnel segment color if Opportunity value is greater than Quote value.
public Color AboveColor {get; set;}

See Also

Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


AutoUpdate

Steema.TeeChart.Styles.Funnel.AutoUpdate Property

Reconstructs FunnelSeries with every added point.
public Boolean AutoUpdate {get; set;}

See Also

Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


BelowColor

Steema.TeeChart.Styles.Funnel.BelowColor Property

Funnel segment color if Opportunity value is more than the DifferenceLimit % below the Quote value.
public Color BelowColor {get; set;}

See Also

Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


Brush

Steema.TeeChart.Styles.Funnel.Brush Property

Defines Brush to fill Funnel Series.
public ChartBrush Brush {get;}

See Also

Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Funnel.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


DifferenceLimit

Steema.TeeChart.Styles.Funnel.DifferenceLimit Property

Sets the difference (expressed in Quote %) used to define the Funnel segment color.
public Double DifferenceLimit {get; set;}

See Also

Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


LinesPen

Steema.TeeChart.Styles.Funnel.LinesPen Property

Defines Pen to draw FunnelSeries bounding polygon.
public ChartPen LinesPen {get;}

See Also

Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


OpportunityValues

Steema.TeeChart.Styles.Funnel.OpportunityValues Property

public ValueList OpportunityValues {get;}

See Also

Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


Pen

Steema.TeeChart.Styles.Funnel.Pen Property

Define Pen to draw the Funnel Chart.
public ChartPen Pen {get;}

See Also

Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


QuotesSorted

Steema.TeeChart.Styles.Funnel.QuotesSorted Property

Sorts added segments by QuoteValues in descending order.
public Boolean QuotesSorted {get; set;}

See Also

Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


QuoteValues

Steema.TeeChart.Styles.Funnel.QuoteValues Property

Accesses the quote values of the FunnelSeries.
public ValueList QuoteValues {get;}

See Also

Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


WithinColor

Steema.TeeChart.Styles.Funnel.WithinColor Property

Funnel segment color if Opportunity value is within DifferenceLimit % below the Quote value.
public Color WithinColor {get; set;}

See Also

Funnel Class | Funnel Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Gantt

Steema.TeeChart.Styles.Gantt Class

Gantt Series.

For a list of all members of this type, see Gantt Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Points
public class Gantt : Points , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Gantt members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GanttMembers

Steema.TeeChart.Styles.Gantt all Members

Gantt overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add |
AddMultipleNextTasks | Add any number of end task indexes to a particular start task index.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf | true is Series source is Gantt
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConnectingPen |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndValues |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
MultipleNextTasks | MultiDimensional array to store Multiple NextTasks, with the indices being start and end task index and the value -1.
NextTasks |
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartValues |
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Gantt Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Gantt Constructor

Overload List

public Gantt()
public Gantt(Steema.TeeChart.Chart)

See Also

Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Gantt Constructor

public Gantt(Chart c)

See Also

Gantt Constructor Overload List | Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Gantt Constructor

public Gantt()

See Also

Gantt Constructor Overload List | Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GanttEvents

Steema.TeeChart.Styles.Gantt Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Gantt Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GanttFields

Steema.TeeChart.Styles.Gantt Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Gantt Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GanttMethods

Steema.TeeChart.Styles.Gantt Methods

Public Methods

Add |
AddMultipleNextTasks | Add any number of end task indexes to a particular start task index.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf | true is Series source is Gantt
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Gantt Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Gantt.Add Method

Overload List

public Int32 Add(System.DateTime, System.DateTime, System.Double, System.String)
public Int32 Add(System.DateTime, System.DateTime, System.Double, System.String, System.Drawing.Color)
public Int32 Add(System.DateTime, System.DateTime, System.Double, System.Drawing.Color)

Adds a new Gantt bar with start and end coordinates and color.

public Int32 Add(System.Double, System.Double, System.Double, System.Drawing.Color)

Adds a new Gantt bar with start and end coordinates to the Series.

public Int32 Add(System.Double, System.Double, System.Double)

Adds a new Gantt bar with start and end coordinates and label.

public Int32 Add(System.Double, System.Double, System.Double, System.String)

Adds a new Gantt bar with start and end coordinates, label and color.

public Int32 Add(System.Double, System.Double, System.Double, System.String, System.Drawing.Color)

See Also

Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Gantt.Add Method

Adds a new Gantt bar with start and end coordinates, label and color.
public Int32 Add(Double start,
     Double endDate,
     Double y,
     String text,
     Color color)

See Also

Add Overload List | Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Gantt.Add Method

Adds a new Gantt bar with start and end coordinates and label.
public Int32 Add(Double start,
     Double endDate,
     Double y,
     String text)

See Also

Add Overload List | Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Gantt.Add Method

Adds a new Gantt bar with start and end coordinates to the Series.
public Int32 Add(Double start,
     Double endDate,
     Double y)

See Also

Add Overload List | Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Gantt.Add Method

Adds a new Gantt bar with start and end coordinates and color.
public Int32 Add(Double start,
     Double endDate,
     Double Y,
     Color color)

See Also

Add Overload List | Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Gantt.Add Method

public Int32 Add(DateTime start,
     DateTime endDate,
     Double y,
     Color color)

See Also

Add Overload List | Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Gantt.Add Method

public Int32 Add(DateTime start,
     DateTime endDate,
     Double y,
     String text,
     Color color)

See Also

Add Overload List | Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Gantt.Add Method

public Int32 Add(DateTime start,
     DateTime endDate,
     Double y,
     String text)

See Also

Add Overload List | Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


AddMultipleNextTasks

Steema.TeeChart.Styles.Gantt.AddMultipleNextTasks Method

Add any number of end task indexes to a particular start task index.
public Void AddMultipleNextTasks(Int32 startTaskIndex,
     Int32 endTaskIndex)

See Also

Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


ClickedPointer

Steema.TeeChart.Styles.Gantt.ClickedPointer Method

Overload List

For internal use.

public override Boolean ClickedPointer(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

See Also

Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


ClickedPointer

Steema.TeeChart.Styles.Gantt.ClickedPointer Method

For internal use.
public override Boolean ClickedPointer(Int32 valueIndex,
     Int32 tmpX,
     Int32 tmpY,
     Int32 x,
     Int32 y)

See Also

ClickedPointer Overload List | Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.Gantt.Draw Method

public override Void Draw()

See Also

Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.Gantt.DrawValue Method

Called internally. Draws the "ValueIndex" point of the Series.
public override Void DrawValue(Int32 valueIndex)

See Also

Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


IsValidSourceOf

Steema.TeeChart.Styles.Gantt.IsValidSourceOf Method

true is Series source is Gantt
public override Boolean IsValidSourceOf(Series value)

See Also

Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.Gantt.MaxXValue Method

Returns the Maximum Value of the Series X Values List.
public override Double MaxXValue()

See Also

Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.Gantt.PrepareForGallery Method

public override Void PrepareForGallery(Boolean isEnabled)

See Also

Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GanttProperties

Steema.TeeChart.Styles.Gantt Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConnectingPen |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndValues |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
MultipleNextTasks | MultiDimensional array to store Multiple NextTasks, with the indices being start and end task index and the value -1.
NextTasks |
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartValues |
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Gantt Class | Steema.TeeChart.Styles Namespace


ConnectingPen

Steema.TeeChart.Styles.Gantt.ConnectingPen Property

public ChartPen ConnectingPen {get; set;}

See Also

Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Gantt.Description Property

public override String Description {get;}

See Also

Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


EndValues

Steema.TeeChart.Styles.Gantt.EndValues Property

public ValueList EndValues {get;}

See Also

Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


MultipleNextTasks

Steema.TeeChart.Styles.Gantt.MultipleNextTasks Property

MultiDimensional array to store Multiple NextTasks, with the indices being start and end task index and the value -1.
public Double[,] MultipleNextTasks {get; set;}

See Also

Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


NextTasks

Steema.TeeChart.Styles.Gantt.NextTasks Property

public ValueList NextTasks {get;}

See Also

Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


StartValues

Steema.TeeChart.Styles.Gantt.StartValues Property

public ValueList StartValues {get;}

See Also

Gantt Class | Gantt Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GaugePointerStyles

Steema.TeeChart.Styles.GaugePointerStyles ValueType

For a list of all members of this type, see GaugePointerStyles Members

System.Object
System.ValueType
public sealed struct GaugePointerStyles : ValueType

See Also

GaugePointerStyles Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GaugePointerStylesMembers

Steema.TeeChart.Styles.GaugePointerStyles all Members

GaugePointerStyles overview

Constructors

Constructor

Public Fields

Center
ColorLine
Hand
MinorTick
Tick
Value

Public Methods

Equals
GetHashCode
op_Equality
op_Implicit
op_Inequality

See Also

GaugePointerStyles Structure | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GaugePointerStyles Constructor

public GaugePointerStyles(Int32 value)

See Also

GaugePointerStyles Structure | GaugePointerStyles Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GaugePointerStylesFields

Steema.TeeChart.Styles.GaugePointerStyles Fields

Public Fields

Center
ColorLine
Hand
MinorTick
Tick
Value

See Also

GaugePointerStyles Structure | Steema.TeeChart.Styles Namespace


Center

Steema.TeeChart.Styles.GaugePointerStyles.Center Field

public GaugePointerStyles Center

See Also

GaugePointerStyles Structure | GaugePointerStyles Members | Steema.TeeChart.Styles Namespace


ColorLine

Steema.TeeChart.Styles.GaugePointerStyles.ColorLine Field

public GaugePointerStyles ColorLine

See Also

GaugePointerStyles Structure | GaugePointerStyles Members | Steema.TeeChart.Styles Namespace


Hand

Steema.TeeChart.Styles.GaugePointerStyles.Hand Field

public GaugePointerStyles Hand

See Also

GaugePointerStyles Structure | GaugePointerStyles Members | Steema.TeeChart.Styles Namespace


MinorTick

Steema.TeeChart.Styles.GaugePointerStyles.MinorTick Field

public GaugePointerStyles MinorTick

See Also

GaugePointerStyles Structure | GaugePointerStyles Members | Steema.TeeChart.Styles Namespace


Tick

Steema.TeeChart.Styles.GaugePointerStyles.Tick Field

public GaugePointerStyles Tick

See Also

GaugePointerStyles Structure | GaugePointerStyles Members | Steema.TeeChart.Styles Namespace


Value

Steema.TeeChart.Styles.GaugePointerStyles.Value Field

public Int32 Value

See Also

GaugePointerStyles Structure | GaugePointerStyles Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GaugePointerStylesMethods

Steema.TeeChart.Styles.GaugePointerStyles Methods

Public Methods

Equals
GetHashCode
op_Equality
op_Implicit
op_Inequality

See Also

GaugePointerStyles Structure | Steema.TeeChart.Styles Namespace


Equals

Steema.TeeChart.Styles.GaugePointerStyles.Equals Method

Overload List

public override Boolean Equals(System.Object)
public Boolean Equals(Steema.TeeChart.Styles.GaugePointerStyles)

See Also

GaugePointerStyles Structure | GaugePointerStyles Members | Steema.TeeChart.Styles Namespace


Equals

Steema.TeeChart.Styles.GaugePointerStyles.Equals Method

public Boolean Equals(GaugePointerStyles p)

See Also

Equals Overload List | GaugePointerStyles Structure | GaugePointerStyles Members | Steema.TeeChart.Styles Namespace


Equals

Steema.TeeChart.Styles.GaugePointerStyles.Equals Method

public override Boolean Equals(Object obj)

See Also

Equals Overload List | GaugePointerStyles Structure | GaugePointerStyles Members | Steema.TeeChart.Styles Namespace


GetHashCode

Steema.TeeChart.Styles.GaugePointerStyles.GetHashCode Method

public override Int32 GetHashCode()

See Also

GaugePointerStyles Structure | GaugePointerStyles Members | Steema.TeeChart.Styles Namespace


op_Equality

Steema.TeeChart.Styles.GaugePointerStyles.op_Equality Method

public static Boolean op_Equality(GaugePointerStyles a,
     GaugePointerStyles b)

See Also

GaugePointerStyles Structure | GaugePointerStyles Members | Steema.TeeChart.Styles Namespace


op_Implicit

Steema.TeeChart.Styles.GaugePointerStyles.op_Implicit Method

Overload List

public static GaugePointerStyles op_Implicit(Steema.TeeChart.Styles.PointerStyles)
public static GaugePointerStyles op_Implicit(System.Int32)
public static Int32 op_Implicit(Steema.TeeChart.Styles.GaugePointerStyles)
public static PointerStyles op_Implicit(Steema.TeeChart.Styles.GaugePointerStyles)

See Also

GaugePointerStyles Structure | GaugePointerStyles Members | Steema.TeeChart.Styles Namespace


op_Implicit

Steema.TeeChart.Styles.GaugePointerStyles.op_Implicit Method

public static PointerStyles op_Implicit(GaugePointerStyles PointerStyle)

See Also

op_Implicit Overload List | GaugePointerStyles Structure | GaugePointerStyles Members | Steema.TeeChart.Styles Namespace


op_Implicit

Steema.TeeChart.Styles.GaugePointerStyles.op_Implicit Method

public static Int32 op_Implicit(GaugePointerStyles PointerStyle)

See Also

op_Implicit Overload List | GaugePointerStyles Structure | GaugePointerStyles Members | Steema.TeeChart.Styles Namespace


op_Implicit

Steema.TeeChart.Styles.GaugePointerStyles.op_Implicit Method

public static GaugePointerStyles op_Implicit(Int32 PointerStyle)

See Also

op_Implicit Overload List | GaugePointerStyles Structure | GaugePointerStyles Members | Steema.TeeChart.Styles Namespace


op_Implicit

Steema.TeeChart.Styles.GaugePointerStyles.op_Implicit Method

public static GaugePointerStyles op_Implicit(PointerStyles PointerStyle)

See Also

op_Implicit Overload List | GaugePointerStyles Structure | GaugePointerStyles Members | Steema.TeeChart.Styles Namespace


op_Inequality

Steema.TeeChart.Styles.GaugePointerStyles.op_Inequality Method

public static Boolean op_Inequality(GaugePointerStyles a,
     GaugePointerStyles b)

See Also

GaugePointerStyles Structure | GaugePointerStyles Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Gauges

Steema.TeeChart.Styles.Gauges Class

Gauges Series.

For a list of all members of this type, see Gauges Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
public class Gauges : Circular , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Gauges members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GaugesMembers

Steema.TeeChart.Styles.Gauges all Members

Gauges overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.
OnChange | Called when the Gauge Value property is changed.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Circular) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Circular) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Center | Returns a sub-object with properties that control the appearance of a shape at the middle of gauge.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
EndPoint | Returns a sub-object with properties that control the appearance of a shape at the end of the gauge arrow.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HandDistance | The amount in pixels that define a gap between the gauge axis and the end of the gauge arrow line.
HandStyle | Style of Gauge hand.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsInside | Defines where to display gauge axis labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
Maximum | Gets or sets the maximum value for the gauge.
MiddleZ (inherited from Series) | For internal use.
Minimum | Gets or sets the minimum value for the gauge.
MinorTickDistance | Set to a value bigger than zero to display the axis minor ticks (ticks inside normal ticks) displaced from the axis line the specified number of pixels.
NumGallerySeries (inherited from Series) | For internal use.
Pen | Line pen for Gauge.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TotalAngle | Controls the size in degrees for the gauge axis.
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
Value | Gets or sets the position of gauge arrow line.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Gauges Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Gauges Constructor

Overload List

public Gauges()
public Gauges(Steema.TeeChart.Chart)

See Also

Gauges Class | Gauges Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Gauges Constructor

public Gauges(Chart c)

See Also

Gauges Constructor Overload List | Gauges Class | Gauges Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Gauges Constructor

public Gauges()

See Also

Gauges Constructor Overload List | Gauges Class | Gauges Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GaugesEvents

Steema.TeeChart.Styles.Gauges Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.
OnChange | Called when the Gauge Value property is changed.

See Also

Gauges Class | Steema.TeeChart.Styles Namespace


OnChange

Steema.TeeChart.Styles.Gauges.OnChange Event

Called when the Gauge Value property is changed.
public GaugesChangeHandler  OnChange

See Also

Gauges Class | Gauges Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GaugesFields

Steema.TeeChart.Styles.Gauges Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Gauges Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GaugesMethods

Steema.TeeChart.Styles.Gauges Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Circular) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Circular) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Gauges Class | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.Gauges.Draw Method

public override Void Draw()

See Also

Gauges Class | Gauges Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.Gauges.PrepareForGallery Method

public override Void PrepareForGallery(Boolean isEnabled)

See Also

Gauges Class | Gauges Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GaugesProperties

Steema.TeeChart.Styles.Gauges Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Center | Returns a sub-object with properties that control the appearance of a shape at the middle of gauge.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
EndPoint | Returns a sub-object with properties that control the appearance of a shape at the end of the gauge arrow.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HandDistance | The amount in pixels that define a gap between the gauge axis and the end of the gauge arrow line.
HandStyle | Style of Gauge hand.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsInside | Defines where to display gauge axis labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
Maximum | Gets or sets the maximum value for the gauge.
MiddleZ (inherited from Series) | For internal use.
Minimum | Gets or sets the minimum value for the gauge.
MinorTickDistance | Set to a value bigger than zero to display the axis minor ticks (ticks inside normal ticks) displaced from the axis line the specified number of pixels.
NumGallerySeries (inherited from Series) | For internal use.
Pen | Line pen for Gauge.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TotalAngle | Controls the size in degrees for the gauge axis.
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
Value | Gets or sets the position of gauge arrow line.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Gauges Class | Steema.TeeChart.Styles Namespace


Center

Steema.TeeChart.Styles.Gauges.Center Property

Returns a sub-object with properties that control the appearance of a shape at the middle of gauge.
public SeriesPointer Center {get;}

See Also

Gauges Class | Gauges Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Gauges.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

Gauges Class | Gauges Members | Steema.TeeChart.Styles Namespace


EndPoint

Steema.TeeChart.Styles.Gauges.EndPoint Property

Returns a sub-object with properties that control the appearance of a shape at the end of the gauge arrow.
public SeriesPointer EndPoint {get;}

See Also

Gauges Class | Gauges Members | Steema.TeeChart.Styles Namespace


HandDistance

Steema.TeeChart.Styles.Gauges.HandDistance Property

The amount in pixels that define a gap between the gauge axis and the end of the gauge arrow line.
public Int32 HandDistance {get; set;}

See Also

Gauges Class | Gauges Members | Steema.TeeChart.Styles Namespace


HandStyle

Steema.TeeChart.Styles.Gauges.HandStyle Property

Style of Gauge hand.
public HandStyle HandStyle {get; set;}

See Also

Gauges Class | Gauges Members | Steema.TeeChart.Styles Namespace


LabelsInside

Steema.TeeChart.Styles.Gauges.LabelsInside Property

Defines where to display gauge axis labels.
public Boolean LabelsInside {get; set;}

See Also

Gauges Class | Gauges Members | Steema.TeeChart.Styles Namespace


Maximum

Steema.TeeChart.Styles.Gauges.Maximum Property

Gets or sets the maximum value for the gauge.
public Double Maximum {get; set;}

See Also

Gauges Class | Gauges Members | Steema.TeeChart.Styles Namespace


Minimum

Steema.TeeChart.Styles.Gauges.Minimum Property

Gets or sets the minimum value for the gauge.
public Double Minimum {get; set;}

See Also

Gauges Class | Gauges Members | Steema.TeeChart.Styles Namespace


MinorTickDistance

Steema.TeeChart.Styles.Gauges.MinorTickDistance Property

Set to a value bigger than zero to display the axis minor ticks (ticks inside normal ticks) displaced from the axis line the specified number of pixels.
public Int32 MinorTickDistance {get; set;}

See Also

Gauges Class | Gauges Members | Steema.TeeChart.Styles Namespace


Pen

Steema.TeeChart.Styles.Gauges.Pen Property

Line pen for Gauge.
public ChartPen Pen {get;}

See Also

Gauges Class | Gauges Members | Steema.TeeChart.Styles Namespace


TotalAngle

Steema.TeeChart.Styles.Gauges.TotalAngle Property

Controls the size in degrees for the gauge axis.
public Double TotalAngle {get; set;}

See Also

Gauges Class | Gauges Members | Steema.TeeChart.Styles Namespace


Value

Steema.TeeChart.Styles.Gauges.Value Property

Gets or sets the position of gauge arrow line.
public Double Value {get; set;}

See Also

Gauges Class | Gauges Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GaugesChangeHandler

Steema.TeeChart.Styles.GaugesChangeHandler Delegate

Gauges Series OnChange Event Handler
public delegate GaugesChangeHandler (Object sender,
     EventArgs e)

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GaugeSeriesPointer

Steema.TeeChart.Styles.GaugeSeriesPointer Class

Derived from SeriesPointer, GaugeSeriesPointer implements pointer styles specific to the CircularGauge series.

For a list of all members of this type, see GaugeSeriesPointer Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.SeriesPointer
public class GaugeSeriesPointer : SeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

GaugeSeriesPointer members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GaugeSeriesPointerMembers

Steema.TeeChart.Styles.GaugeSeriesPointer all Members

GaugeSeriesPointer overview

Constructors

Constructor

Public Methods

Clone |
Draw |
DrawColorLine |
DrawShadow |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Brush (inherited from SeriesPointer) | Brush used to fill Series Pointers.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from SeriesPointer) | Sets the pointer color.
Dark3D (inherited from SeriesPointer) | Fills pointer sides in 3D mode with darker color.
Draw3D (inherited from SeriesPointer) | Draws pointer in 3D mode.
EndZ (inherited from SeriesPointer) |
Gradient (inherited from SeriesPointer) | Configures Gradient filling attributes.
HorizSize (inherited from SeriesPointer) | Horizontal size of pointer in pixels.
InflateMargins (inherited from SeriesPointer) | Expands axes to fit pointers.
MiddleZ (inherited from SeriesPointer) |
Pen (inherited from SeriesPointer) | Pen used to draw a frame around Series Pointers.
Series (inherited from SeriesPointer) |
Shadow |
StartZ (inherited from SeriesPointer) |
Style |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency (inherited from SeriesPointer) | Sets Percent of semiglass effect.
VertSize (inherited from SeriesPointer) | Sets Horizontal size of pointer in pixels.
Visible (inherited from SeriesPointer) | Shows or hides the pointer.

See Also

GaugeSeriesPointer Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GaugeSeriesPointer Constructor

public GaugeSeriesPointer(Chart c,
     Series s)

See Also

GaugeSeriesPointer Class | GaugeSeriesPointer Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GaugeSeriesPointerMethods

Steema.TeeChart.Styles.GaugeSeriesPointer Methods

Public Methods

Clone |
Draw |
DrawColorLine |
DrawShadow |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

See Also

GaugeSeriesPointer Class | Steema.TeeChart.Styles Namespace


Clone

Steema.TeeChart.Styles.GaugeSeriesPointer.Clone Method

Overload List

public Object Clone()

See Also

GaugeSeriesPointer Class | GaugeSeriesPointer Members | Steema.TeeChart.Styles Namespace


Clone

Steema.TeeChart.Styles.GaugeSeriesPointer.Clone Method

public Object Clone()

See Also

Clone Overload List | GaugeSeriesPointer Class | GaugeSeriesPointer Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.GaugeSeriesPointer.Draw Method

Overload List

public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Drawing.Point, System.Drawing.Point, System.Drawing.Point, System.Drawing.Point, System.Drawing.Point, System.Drawing.Point)
public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Boolean, System.Int32, System.Int32, System.Int32, System.Int32, System.Drawing.Color, Steema.TeeChart.Styles.GaugePointerStyles)

See Also

GaugeSeriesPointer Class | GaugeSeriesPointer Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.GaugeSeriesPointer.Draw Method

public Void Draw(Graphics3D g,
     Boolean is3D,
     Int32 px,
     Int32 py,
     Int32 tmpHoriz,
     Int32 tmpVert,
     Color colorValue,
     GaugePointerStyles aStyle)

See Also

Draw Overload List | GaugeSeriesPointer Class | GaugeSeriesPointer Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.GaugeSeriesPointer.Draw Method

public Void Draw(Graphics3D g,
     Point Inner,
     Point InnerPlus,
     Point InnerMinus,
     Point Outer,
     Point OuterPlus,
     Point OuterMinus)

See Also

Draw Overload List | GaugeSeriesPointer Class | GaugeSeriesPointer Members | Steema.TeeChart.Styles Namespace


DrawColorLine

Steema.TeeChart.Styles.GaugeSeriesPointer.DrawColorLine Method

Overload List

public Void DrawColorLine(Steema.TeeChart.Drawing.Graphics3D, System.Int32, System.Int32, System.Drawing.Rectangle, System.Boolean)
public Void DrawColorLine(Steema.TeeChart.Drawing.Graphics3D, System.Int32, System.Int32, System.Drawing.Rectangle)

See Also

GaugeSeriesPointer Class | GaugeSeriesPointer Members | Steema.TeeChart.Styles Namespace


DrawColorLine

Steema.TeeChart.Styles.GaugeSeriesPointer.DrawColorLine Method

public Void DrawColorLine(Graphics3D g,
     Int32 StartAngle,
     Int32 EndAngle,
     Rectangle Container)

See Also

DrawColorLine Overload List | GaugeSeriesPointer Class | GaugeSeriesPointer Members | Steema.TeeChart.Styles Namespace


DrawColorLine

Steema.TeeChart.Styles.GaugeSeriesPointer.DrawColorLine Method

public Void DrawColorLine(Graphics3D g,
     Int32 StartAngle,
     Int32 EndAngle,
     Rectangle Container,
     Boolean Spiralled)

See Also

DrawColorLine Overload List | GaugeSeriesPointer Class | GaugeSeriesPointer Members | Steema.TeeChart.Styles Namespace


DrawShadow

Steema.TeeChart.Styles.GaugeSeriesPointer.DrawShadow Method

public Void DrawShadow(Graphics3D g,
     Single angle,
     Int32 px,
     Int32 py,
     Int32 tmpHoriz,
     Int32 tmpVert,
     GaugePointerStyles aStyle)

See Also

GaugeSeriesPointer Class | GaugeSeriesPointer Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GaugeSeriesPointerProperties

Steema.TeeChart.Styles.GaugeSeriesPointer Properties

Public Properties

Brush (inherited from SeriesPointer) | Brush used to fill Series Pointers.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from SeriesPointer) | Sets the pointer color.
Dark3D (inherited from SeriesPointer) | Fills pointer sides in 3D mode with darker color.
Draw3D (inherited from SeriesPointer) | Draws pointer in 3D mode.
EndZ (inherited from SeriesPointer) |
Gradient (inherited from SeriesPointer) | Configures Gradient filling attributes.
HorizSize (inherited from SeriesPointer) | Horizontal size of pointer in pixels.
InflateMargins (inherited from SeriesPointer) | Expands axes to fit pointers.
MiddleZ (inherited from SeriesPointer) |
Pen (inherited from SeriesPointer) | Pen used to draw a frame around Series Pointers.
Series (inherited from SeriesPointer) |
Shadow |
StartZ (inherited from SeriesPointer) |
Style |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency (inherited from SeriesPointer) | Sets Percent of semiglass effect.
VertSize (inherited from SeriesPointer) | Sets Horizontal size of pointer in pixels.
Visible (inherited from SeriesPointer) | Shows or hides the pointer.

See Also

GaugeSeriesPointer Class | Steema.TeeChart.Styles Namespace


Shadow

Steema.TeeChart.Styles.GaugeSeriesPointer.Shadow Property

public Shadow Shadow {get; set;}

See Also

GaugeSeriesPointer Class | GaugeSeriesPointer Members | Steema.TeeChart.Styles Namespace


Style

Steema.TeeChart.Styles.GaugeSeriesPointer.Style Property

public GaugePointerStyles Style {get; set;}

See Also

GaugeSeriesPointer Class | GaugeSeriesPointer Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GetImageEvent

Steema.TeeChart.Styles.GetImageEvent Delegate

public delegate GetImageEvent (CustomImagePoint sender,
     Int32 valueIndex,
     Bitmap image)

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GetPointerStyleEventArgs

Steema.TeeChart.Styles.GetPointerStyleEventArgs Class

The Event Data for the GetPointerStyle event.

For a list of all members of this type, see GetPointerStyleEventArgs Members

System.Object
System.EventArgs
public class GetPointerStyleEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

GetPointerStyleEventArgs members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GetPointerStyleEventArgsMembers

Steema.TeeChart.Styles.GetPointerStyleEventArgs all Members

GetPointerStyleEventArgs overview

Constructors

Constructor

Public Properties

Color | The series pointerColor.
Style | The series pointer Style.
ValueIndex | The Index of the value in the series ValueList.

See Also

GetPointerStyleEventArgs Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GetPointerStyleEventArgs Constructor

public GetPointerStyleEventArgs(Int32 valueIndex,
     PointerStyles style)

See Also

GetPointerStyleEventArgs Class | GetPointerStyleEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GetPointerStyleEventArgsProperties

Steema.TeeChart.Styles.GetPointerStyleEventArgs Properties

Public Properties

Color | The series pointerColor.
Style | The series pointer Style.
ValueIndex | The Index of the value in the series ValueList.

See Also

GetPointerStyleEventArgs Class | Steema.TeeChart.Styles Namespace


Color

Steema.TeeChart.Styles.GetPointerStyleEventArgs.Color Property

The series pointerColor.
public Color Color {get; set;}

See Also

GetPointerStyleEventArgs Class | GetPointerStyleEventArgs Members | Steema.TeeChart.Styles Namespace


Style

Steema.TeeChart.Styles.GetPointerStyleEventArgs.Style Property

The series pointer Style.
public PointerStyles Style {get; set;}

See Also

GetPointerStyleEventArgs Class | GetPointerStyleEventArgs Members | Steema.TeeChart.Styles Namespace


ValueIndex

Steema.TeeChart.Styles.GetPointerStyleEventArgs.ValueIndex Property

The Index of the value in the series ValueList.
public Int32 ValueIndex {get;}

See Also

GetPointerStyleEventArgs Class | GetPointerStyleEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GetSeriesMarkEventArgs

Steema.TeeChart.Styles.GetSeriesMarkEventArgs Class

The Event Data for the GetSeriesMark event.

For a list of all members of this type, see GetSeriesMarkEventArgs Members

System.Object
System.EventArgs
public class GetSeriesMarkEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

GetSeriesMarkEventArgs members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GetSeriesMarkEventArgsMembers

Steema.TeeChart.Styles.GetSeriesMarkEventArgs all Members

GetSeriesMarkEventArgs overview

Constructors

Constructor

Public Properties

MarkText | Gets or sets the text of the series Mark.
ValueIndex | The Index of the value in the series ValueList.

See Also

GetSeriesMarkEventArgs Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GetSeriesMarkEventArgs Constructor

public GetSeriesMarkEventArgs(Int32 valueIndex,
     String markText)

See Also

GetSeriesMarkEventArgs Class | GetSeriesMarkEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GetSeriesMarkEventArgsProperties

Steema.TeeChart.Styles.GetSeriesMarkEventArgs Properties

Public Properties

MarkText | Gets or sets the text of the series Mark.
ValueIndex | The Index of the value in the series ValueList.

See Also

GetSeriesMarkEventArgs Class | Steema.TeeChart.Styles Namespace


MarkText

Steema.TeeChart.Styles.GetSeriesMarkEventArgs.MarkText Property

Gets or sets the text of the series Mark.
public String MarkText {get; set;}

See Also

GetSeriesMarkEventArgs Class | GetSeriesMarkEventArgs Members | Steema.TeeChart.Styles Namespace


ValueIndex

Steema.TeeChart.Styles.GetSeriesMarkEventArgs.ValueIndex Property

The Index of the value in the series ValueList.
public Int32 ValueIndex {get;}

See Also

GetSeriesMarkEventArgs Class | GetSeriesMarkEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GridColorPalette

Steema.TeeChart.Styles.GridColorPalette Class

Defines palette properties.

For a list of all members of this type, see GridColorPalette Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class GridColorPalette : TeeBase

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

GridColorPalette members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GridColorPaletteMembers

Steema.TeeChart.Styles.GridColorPalette all Members

GridColorPalette overview

Constructors

Constructor

Public Methods

InitColors |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
EndColor |
MidColor |
Palette | Access the Color Palette list
PaletteMin |
PaletteStep |
PaletteSteps |
PaletteStyle |
Series |
StartColor |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
UseColorRange |
UsePalette |
UsePaletteMin |

See Also

GridColorPalette Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GridColorPalette Constructor

public GridColorPalette(Series Owner)

See Also

GridColorPalette Class | GridColorPalette Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GridColorPaletteMethods

Steema.TeeChart.Styles.GridColorPalette Methods

Public Methods

InitColors |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

See Also

GridColorPalette Class | Steema.TeeChart.Styles Namespace


InitColors

Steema.TeeChart.Styles.GridColorPalette.InitColors Method

public Void InitColors(Color Color,
     Double MinValue,
     Double MaxValue)

See Also

GridColorPalette Class | GridColorPalette Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GridColorPaletteProperties

Steema.TeeChart.Styles.GridColorPalette Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
EndColor |
MidColor |
Palette | Access the Color Palette list
PaletteMin |
PaletteStep |
PaletteSteps |
PaletteStyle |
Series |
StartColor |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
UseColorRange |
UsePalette |
UsePaletteMin |

See Also

GridColorPalette Class | Steema.TeeChart.Styles Namespace


EndColor

Steema.TeeChart.Styles.GridColorPalette.EndColor Property

public Color EndColor {get; set;}

See Also

GridColorPalette Class | GridColorPalette Members | Steema.TeeChart.Styles Namespace


MidColor

Steema.TeeChart.Styles.GridColorPalette.MidColor Property

public Color MidColor {get; set;}

See Also

GridColorPalette Class | GridColorPalette Members | Steema.TeeChart.Styles Namespace


Palette

Steema.TeeChart.Styles.GridColorPalette.Palette Property

Access the Color Palette list
public List<GridPalette> Palette {get;}

See Also

GridColorPalette Class | GridColorPalette Members | Steema.TeeChart.Styles Namespace


PaletteMin

Steema.TeeChart.Styles.GridColorPalette.PaletteMin Property

public Double PaletteMin {get; set;}

See Also

GridColorPalette Class | GridColorPalette Members | Steema.TeeChart.Styles Namespace


PaletteStep

Steema.TeeChart.Styles.GridColorPalette.PaletteStep Property

public Double PaletteStep {get; set;}

See Also

GridColorPalette Class | GridColorPalette Members | Steema.TeeChart.Styles Namespace


PaletteSteps

Steema.TeeChart.Styles.GridColorPalette.PaletteSteps Property

public Int32 PaletteSteps {get; set;}

See Also

GridColorPalette Class | GridColorPalette Members | Steema.TeeChart.Styles Namespace


PaletteStyle

Steema.TeeChart.Styles.GridColorPalette.PaletteStyle Property

public PaletteStyles PaletteStyle {get; set;}

See Also

GridColorPalette Class | GridColorPalette Members | Steema.TeeChart.Styles Namespace


Series

Steema.TeeChart.Styles.GridColorPalette.Series Property

public Custom3DPalette Series {get;}

See Also

GridColorPalette Class | GridColorPalette Members | Steema.TeeChart.Styles Namespace


StartColor

Steema.TeeChart.Styles.GridColorPalette.StartColor Property

public Color StartColor {get; set;}

See Also

GridColorPalette Class | GridColorPalette Members | Steema.TeeChart.Styles Namespace


UseColorRange

Steema.TeeChart.Styles.GridColorPalette.UseColorRange Property

public Boolean UseColorRange {get; set;}

See Also

GridColorPalette Class | GridColorPalette Members | Steema.TeeChart.Styles Namespace


UsePalette

Steema.TeeChart.Styles.GridColorPalette.UsePalette Property

public Boolean UsePalette {get; set;}

See Also

GridColorPalette Class | GridColorPalette Members | Steema.TeeChart.Styles Namespace


UsePaletteMin

Steema.TeeChart.Styles.GridColorPalette.UsePaletteMin Property

public Boolean UsePaletteMin {get; set;}

See Also

GridColorPalette Class | GridColorPalette Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GridPalette

Steema.TeeChart.Styles.GridPalette ValueType

Used in Custom3DPalette series to store the palette values.

For a list of all members of this type, see GridPalette Members

System.Object
System.ValueType
public sealed struct GridPalette : ValueType

See Also

GridPalette Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GridPaletteMembers

Steema.TeeChart.Styles.GridPalette all Members

GridPalette overview

Constructors

Constructor

Public Fields

Color
UpToValue

See Also

GridPalette Structure | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GridPalette Constructor

public GridPalette(Double aValue,
     Color aColor)

See Also

GridPalette Structure | GridPalette Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.GridPaletteFields

Steema.TeeChart.Styles.GridPalette Fields

Public Fields

Color
UpToValue

See Also

GridPalette Structure | Steema.TeeChart.Styles Namespace


Color

Steema.TeeChart.Styles.GridPalette.Color Field

public Color Color

See Also

GridPalette Structure | GridPalette Members | Steema.TeeChart.Styles Namespace


UpToValue

Steema.TeeChart.Styles.GridPalette.UpToValue Field

public Double UpToValue

See Also

GridPalette Structure | GridPalette Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HandStyle

Steema.TeeChart.Styles.HandStyle Enum

Describes the possible values of the HandStyle property.
[Serializable]
public sealed enum HandStyle : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
Line | Gauge hand drawn as a Line.
Triangle | Gauge hand drawn as a triangular pointer.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HighLow

Steema.TeeChart.Styles.HighLow Class

HighLow series.

For a list of all members of this type, see HighLow Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class HighLow : Series , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

HighLow members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HighLowMembers

Steema.TeeChart.Styles.HighLow all Members

HighLow overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add | Adds a new High and Low value to a HighLow series.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Calculates if any point is at XY position.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf | true if Series source is HighLow
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HighBrush |
HighPen |
HighValues |
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LowBrush |
LowPen |
LowValues |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen |
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

HighLow Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HighLow Constructor

Overload List

public HighLow()
public HighLow(Steema.TeeChart.Chart)

See Also

HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HighLow Constructor

public HighLow(Chart c)

See Also

HighLow Constructor Overload List | HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HighLow Constructor

public HighLow()

See Also

HighLow Constructor Overload List | HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HighLowEvents

Steema.TeeChart.Styles.HighLow Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

HighLow Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HighLowFields

Steema.TeeChart.Styles.HighLow Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

HighLow Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HighLowMethods

Steema.TeeChart.Styles.HighLow Methods

Public Methods

Add | Adds a new High and Low value to a HighLow series.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Calculates if any point is at XY position.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf | true if Series source is HighLow
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

HighLow Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.HighLow.Add Method

Overload List

Adds a new High and Low value to a HighLow series.

public Int32 Add(System.Double, System.Double, System.Double)

Adds a new High and Low value to a HighLow series and color.

public Int32 Add(System.Double, System.Double, System.Double, System.Drawing.Color)

Adds a new High and Low value to a HighLow series and label.

public Int32 Add(System.Double, System.Double, System.Double, System.String)

Adds a new High and Low value to a HighLow series with label and color.

public Int32 Add(System.Double, System.Double, System.Double, System.String, System.Drawing.Color)

See Also

HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.HighLow.Add Method

Adds a new High and Low value to a HighLow series with label and color.
public Int32 Add(Double x,
     Double h,
     Double l,
     String text,
     Color color)

See Also

Add Overload List | HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.HighLow.Add Method

Adds a new High and Low value to a HighLow series and label.
public Int32 Add(Double x,
     Double h,
     Double l,
     String text)

See Also

Add Overload List | HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.HighLow.Add Method

Adds a new High and Low value to a HighLow series and color.
public Int32 Add(Double x,
     Double h,
     Double l,
     Color color)

See Also

Add Overload List | HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.HighLow.Add Method

Adds a new High and Low value to a HighLow series.
public Int32 Add(Double x,
     Double h,
     Double l)

See Also

Add Overload List | HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.HighLow.Clicked Method

Overload List

Calculates if any point is at XY position.

public override Int32 Clicked(System.Int32, System.Int32)

See Also

HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.HighLow.Clicked Method

Calculates if any point is at XY position.
public override Int32 Clicked(Int32 x,
     Int32 y)

Return Value

Point index

See Also

Clicked Overload List | HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.HighLow.DrawValue Method

Called internally. Draws the "ValueIndex" point of the Series.
public override Void DrawValue(Int32 valueIndex)

See Also

HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


IsValidSourceOf

Steema.TeeChart.Styles.HighLow.IsValidSourceOf Method

true if Series source is HighLow
public override Boolean IsValidSourceOf(Series value)

See Also

HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.HighLow.MaxYValue Method

Returns the Maximum Value of the Series Y Values List.
public override Double MaxYValue()

See Also

HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.HighLow.MinYValue Method

Returns the Minimum Value of the Series Y Values List.
public override Double MinYValue()

See Also

HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.HighLow.SetSubGallery Method

public override Void SetSubGallery(Int32 index)

See Also

HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HighLowProperties

Steema.TeeChart.Styles.HighLow Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HighBrush |
HighPen |
HighValues |
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LowBrush |
LowPen |
LowValues |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen |
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

HighLow Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.HighLow.Description Property

public override String Description {get;}

See Also

HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


HighBrush

Steema.TeeChart.Styles.HighLow.HighBrush Property

public ChartBrush HighBrush {get;}

See Also

HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


HighPen

Steema.TeeChart.Styles.HighLow.HighPen Property

public ChartPen HighPen {get;}

See Also

HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


HighValues

Steema.TeeChart.Styles.HighLow.HighValues Property

public ValueList HighValues {get;}

See Also

HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


LowBrush

Steema.TeeChart.Styles.HighLow.LowBrush Property

public ChartBrush LowBrush {get;}

See Also

HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


LowPen

Steema.TeeChart.Styles.HighLow.LowPen Property

public ChartPen LowPen {get;}

See Also

HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


LowValues

Steema.TeeChart.Styles.HighLow.LowValues Property

public ValueList LowValues {get;}

See Also

HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


Pen

Steema.TeeChart.Styles.HighLow.Pen Property

public ChartPen Pen {get;}

See Also

HighLow Class | HighLow Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Histogram

Steema.TeeChart.Styles.Histogram Class

Histogram Series.

For a list of all members of this type, see Histogram Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
public class Histogram : BaseLine , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Histogram members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HistogramMembers

Steema.TeeChart.Styles.Histogram all Members

Histogram overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from BaseLine) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush |
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
LinesPen |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency |
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UseYOrigin |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin |
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Histogram Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Histogram Constructor

Overload List

public Histogram()
public Histogram(Steema.TeeChart.Chart)

See Also

Histogram Class | Histogram Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Histogram Constructor

public Histogram(Chart c)

See Also

Histogram Constructor Overload List | Histogram Class | Histogram Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Histogram Constructor

public Histogram()

See Also

Histogram Constructor Overload List | Histogram Class | Histogram Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HistogramEvents

Steema.TeeChart.Styles.Histogram Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Histogram Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HistogramFields

Steema.TeeChart.Styles.Histogram Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Histogram Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HistogramMethods

Steema.TeeChart.Styles.Histogram Methods

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from BaseLine) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Histogram Class | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Histogram.Clicked Method

Overload List

public override Int32 Clicked(System.Int32, System.Int32)

See Also

Histogram Class | Histogram Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Histogram.Clicked Method

public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | Histogram Class | Histogram Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.Histogram.DrawValue Method

public override Void DrawValue(Int32 valueIndex)

See Also

Histogram Class | Histogram Members | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.Histogram.SetSubGallery Method

public override Void SetSubGallery(Int32 index)

See Also

Histogram Class | Histogram Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HistogramProperties

Steema.TeeChart.Styles.Histogram Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush |
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
LinesPen |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency |
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UseYOrigin |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin |
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Histogram Class | Steema.TeeChart.Styles Namespace


Brush

Steema.TeeChart.Styles.Histogram.Brush Property

public ChartBrush Brush {get;}

See Also

Histogram Class | Histogram Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Histogram.Description Property

public override String Description {get;}

See Also

Histogram Class | Histogram Members | Steema.TeeChart.Styles Namespace


LinesPen

Steema.TeeChart.Styles.Histogram.LinesPen Property

public ChartPen LinesPen {get;}

See Also

Histogram Class | Histogram Members | Steema.TeeChart.Styles Namespace


Transparency

Steema.TeeChart.Styles.Histogram.Transparency Property

public Int32 Transparency {get; set;}

See Also

Histogram Class | Histogram Members | Steema.TeeChart.Styles Namespace


UseYOrigin

Steema.TeeChart.Styles.Histogram.UseYOrigin Property

public Boolean UseYOrigin {get; set;}

See Also

Histogram Class | Histogram Members | Steema.TeeChart.Styles Namespace


YOrigin

Steema.TeeChart.Styles.Histogram.YOrigin Property

public Int32 YOrigin {get; set;}

See Also

Histogram Class | Histogram Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizArea

Steema.TeeChart.Styles.HorizArea Class

HorizArea series.

For a list of all members of this type, see HorizArea Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
Steema.TeeChart.Styles.Area
public class HorizArea : Area , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

HorizArea members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizAreaMembers

Steema.TeeChart.Styles.HorizArea all Members

HorizArea overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Custom) | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Custom) |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Custom) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Area) |
MaxYValue (inherited from Area) | Returns the highest of all the current Series Y point values.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Area) |
MinYValue (inherited from Area) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Area) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AreaBrush (inherited from Area) | Determines Brush to fill the background Area region.
AreaLines (inherited from Area) | Determines Pen to draw AreaLines.
AreaLinesPen (inherited from Area) |
Brush (inherited from Custom) | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from Area) | Determines Gradient to fill the background Area region.
GradientRelative (inherited from Area) | Gets and sets a value which when true calculates the Gradient relative to each point. When false, the Gradient is calculated with respect to the entire Gradient area.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
MultiArea (inherited from Area) | Determines how Multi-AreaSeries are displayed.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
Origin (inherited from Area) | Sets axis value as a common bottom for all AreaSeries points.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StackGroup (inherited from Area) |
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TopGradient (inherited from Area) | Determines to fill the top 3D Area region.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UseOrigin (inherited from Area) | Aligns bottom of AreaSeries to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

HorizArea Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizArea Constructor

Overload List

public HorizArea(Steema.TeeChart.Chart)
public HorizArea()

See Also

HorizArea Class | HorizArea Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizArea Constructor

public HorizArea()

See Also

HorizArea Constructor Overload List | HorizArea Class | HorizArea Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizArea Constructor

public HorizArea(Chart c)

See Also

HorizArea Constructor Overload List | HorizArea Class | HorizArea Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizAreaEvents

Steema.TeeChart.Styles.HorizArea Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

HorizArea Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizAreaFields

Steema.TeeChart.Styles.HorizArea Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

HorizArea Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizAreaMethods

Steema.TeeChart.Styles.HorizArea Methods

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Custom) | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Custom) |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Custom) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Area) |
MaxYValue (inherited from Area) | Returns the highest of all the current Series Y point values.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Area) |
MinYValue (inherited from Area) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Area) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

HorizArea Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizAreaProperties

Steema.TeeChart.Styles.HorizArea Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AreaBrush (inherited from Area) | Determines Brush to fill the background Area region.
AreaLines (inherited from Area) | Determines Pen to draw AreaLines.
AreaLinesPen (inherited from Area) |
Brush (inherited from Custom) | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from Area) | Determines Gradient to fill the background Area region.
GradientRelative (inherited from Area) | Gets and sets a value which when true calculates the Gradient relative to each point. When false, the Gradient is calculated with respect to the entire Gradient area.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
MultiArea (inherited from Area) | Determines how Multi-AreaSeries are displayed.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
Origin (inherited from Area) | Sets axis value as a common bottom for all AreaSeries points.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StackGroup (inherited from Area) |
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TopGradient (inherited from Area) | Determines to fill the top 3D Area region.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UseOrigin (inherited from Area) | Aligns bottom of AreaSeries to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

HorizArea Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.HorizArea.Description Property

public override String Description {get;}

See Also

HorizArea Class | HorizArea Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizBar

Steema.TeeChart.Styles.HorizBar Class

Horizontal Bar Series.

For a list of all members of this type, see HorizBar Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomBar
public class HorizBar : CustomBar , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

HorizBar members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizBarMembers

Steema.TeeChart.Styles.HorizBar all Members

HorizBar overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetBarStyle (inherited from CustomBar) | Occurs when series bars are painted.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomBar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BarMargin (inherited from CustomBar) | Returns side margin amount in pixels.
BarRectangle (inherited from CustomBar) | For internal use.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos | The vertical Bar position is the "real" Y pos plus the Barwidth by our BarSeries order.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomBar) | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawBar |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from CustomBar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue | Returns the Minimum Value of the Series X Values List.
MinYValue |
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointOrigin (inherited from CustomBar) | For internal use.
PrepareForGallery (inherited from CustomBar) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from CustomBar) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoMarkPosition (inherited from CustomBar) | Repositions Marks on BarSeries to prevent overlapping.
BarBounds (inherited from CustomBar) | Coordinates of current Bar point being displayed.
BarHeightPercent | Defines the percent of bar Height, from 0 to 100.
BarStyle (inherited from CustomBar) | Defines the Bar shape used to draw Bars.
BevelSize (inherited from CustomBar) | Amount in pixels of the bar bevel. Used only when BarStyle property is Bevel (only in 2D and 3D orthogonal display modes)
Brush (inherited from CustomBar) | Defines the Brush used to fill Bars.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent (inherited from CustomBar) |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBarWidth (inherited from CustomBar) |
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from CustomBar) | Darkens sides of bars to enhance 3D effect.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthPercent (inherited from CustomBar) | Defines the percentage, from 0 to 100, that the bars will need in the "Z" depth space direction.
Description | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from CustomBar) | Defines the color Gradient used to fill the Bars.
GradientRelative (inherited from CustomBar) | When Gradient is Visible, calculates Colors based on highest bar.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksLocation (inherited from CustomBar) | Sets the alignment of the Mark into the Bars.
MarksOnBar (inherited from CustomBar) | Sets a postition of the Marks into the Bars.
MiddleZ (inherited from Series) | For internal use.
MultiBar (inherited from CustomBar) | Determines how multiple BarSeries will be displayed in the same Chart.
NumGallerySeries (inherited from Series) | For internal use.
OffsetPercent (inherited from CustomBar) | Sets the Bar displacement as percent of Bar size.
Origin (inherited from CustomBar) | Sets the common bottom value used for all Bar points.
Pen (inherited from CustomBar) | Pen used to draw the Bar rectangles.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow (inherited from CustomBar) | Defines the Shadow used to draw behind the Bars.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideMargins (inherited from CustomBar) | Sets a margin between Chart rectangle and Bars.
StackGroup (inherited from CustomBar) | Allows stacking independent Series within the same Chart.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickLines (inherited from CustomBar) | Pen used to draw "tick" lines across each bar.
Title (inherited from Series) | Series description to show in Legend and editors.
UseOrigin (inherited from CustomBar) | Allows Bars to be bottom aligned to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin (inherited from CustomBar) | System.Obsolete: Please use Origin property.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

HorizBar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizBar Constructor

Overload List

public HorizBar()
public HorizBar(Steema.TeeChart.Chart)

See Also

HorizBar Class | HorizBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizBar Constructor

public HorizBar(Chart c)

See Also

HorizBar Constructor Overload List | HorizBar Class | HorizBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizBar Constructor

public HorizBar()

See Also

HorizBar Constructor Overload List | HorizBar Class | HorizBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizBarEvents

Steema.TeeChart.Styles.HorizBar Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetBarStyle (inherited from CustomBar) | Occurs when series bars are painted.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

HorizBar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizBarFields

Steema.TeeChart.Styles.HorizBar Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

HorizBar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizBarMethods

Steema.TeeChart.Styles.HorizBar Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomBar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BarMargin (inherited from CustomBar) | Returns side margin amount in pixels.
BarRectangle (inherited from CustomBar) | For internal use.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos | The vertical Bar position is the "real" Y pos plus the Barwidth by our BarSeries order.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomBar) | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawBar |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from CustomBar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue | Returns the Minimum Value of the Series X Values List.
MinYValue |
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointOrigin (inherited from CustomBar) | For internal use.
PrepareForGallery (inherited from CustomBar) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from CustomBar) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

HorizBar Class | Steema.TeeChart.Styles Namespace


CalcXPos

Steema.TeeChart.Styles.HorizBar.CalcXPos Method

Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
public override Int32 CalcXPos(Int32 valueIndex)

See Also

HorizBar Class | HorizBar Members | Steema.TeeChart.Styles Namespace


CalcYPos

Steema.TeeChart.Styles.HorizBar.CalcYPos Method

The vertical Bar position is the "real" Y pos plus the Barwidth by our BarSeries order.
public override Int32 CalcYPos(Int32 valueIndex)

See Also

HorizBar Class | HorizBar Members | Steema.TeeChart.Styles Namespace


DrawBar

Steema.TeeChart.Styles.HorizBar.DrawBar Method

public override Void DrawBar(Int32 barIndex,
     Int32 startPos,
     Int32 endPos)

See Also

HorizBar Class | HorizBar Members | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.HorizBar.MaxXValue Method

Returns the Maximum Value of the Series X Values List.
public override Double MaxXValue()

See Also

HorizBar Class | HorizBar Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.HorizBar.MaxYValue Method

Returns the Maximum Value of the Series Y Values List.
public override Double MaxYValue()

See Also

HorizBar Class | HorizBar Members | Steema.TeeChart.Styles Namespace


MinXValue

Steema.TeeChart.Styles.HorizBar.MinXValue Method

Returns the Minimum Value of the Series X Values List.
public override Double MinXValue()

See Also

HorizBar Class | HorizBar Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.HorizBar.MinYValue Method

public override Double MinYValue()

See Also

HorizBar Class | HorizBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizBarProperties

Steema.TeeChart.Styles.HorizBar Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoMarkPosition (inherited from CustomBar) | Repositions Marks on BarSeries to prevent overlapping.
BarBounds (inherited from CustomBar) | Coordinates of current Bar point being displayed.
BarHeightPercent | Defines the percent of bar Height, from 0 to 100.
BarStyle (inherited from CustomBar) | Defines the Bar shape used to draw Bars.
BevelSize (inherited from CustomBar) | Amount in pixels of the bar bevel. Used only when BarStyle property is Bevel (only in 2D and 3D orthogonal display modes)
Brush (inherited from CustomBar) | Defines the Brush used to fill Bars.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent (inherited from CustomBar) |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBarWidth (inherited from CustomBar) |
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from CustomBar) | Darkens sides of bars to enhance 3D effect.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthPercent (inherited from CustomBar) | Defines the percentage, from 0 to 100, that the bars will need in the "Z" depth space direction.
Description | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from CustomBar) | Defines the color Gradient used to fill the Bars.
GradientRelative (inherited from CustomBar) | When Gradient is Visible, calculates Colors based on highest bar.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksLocation (inherited from CustomBar) | Sets the alignment of the Mark into the Bars.
MarksOnBar (inherited from CustomBar) | Sets a postition of the Marks into the Bars.
MiddleZ (inherited from Series) | For internal use.
MultiBar (inherited from CustomBar) | Determines how multiple BarSeries will be displayed in the same Chart.
NumGallerySeries (inherited from Series) | For internal use.
OffsetPercent (inherited from CustomBar) | Sets the Bar displacement as percent of Bar size.
Origin (inherited from CustomBar) | Sets the common bottom value used for all Bar points.
Pen (inherited from CustomBar) | Pen used to draw the Bar rectangles.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow (inherited from CustomBar) | Defines the Shadow used to draw behind the Bars.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideMargins (inherited from CustomBar) | Sets a margin between Chart rectangle and Bars.
StackGroup (inherited from CustomBar) | Allows stacking independent Series within the same Chart.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickLines (inherited from CustomBar) | Pen used to draw "tick" lines across each bar.
Title (inherited from Series) | Series description to show in Legend and editors.
UseOrigin (inherited from CustomBar) | Allows Bars to be bottom aligned to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin (inherited from CustomBar) | System.Obsolete: Please use Origin property.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

HorizBar Class | Steema.TeeChart.Styles Namespace


BarHeightPercent

Steema.TeeChart.Styles.HorizBar.BarHeightPercent Property

Defines the percent of bar Height, from 0 to 100.
public Int32 BarHeightPercent {get; set;}

See Also

HorizBar Class | HorizBar Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.HorizBar.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

HorizBar Class | HorizBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizBox

Steema.TeeChart.Styles.HorizBox Class

The Box Series plots an horizontal box series.

For a list of all members of this type, see HorizBox Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Points
Steema.TeeChart.Styles.CustomBox
public class HorizBox : CustomBox , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

HorizBox members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizBoxMembers

Steema.TeeChart.Styles.HorizBox all Members

HorizBox overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from CustomBox) | Add x-displacement position and values for Box valueset.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos |
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer (inherited from CustomBox) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from CustomBox) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBox) | Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue |
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue |
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from CustomBox) |
ReconstructFromData (inherited from CustomBox) | Reconstructs the box plot from series data
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AdjacentPoint1 (inherited from CustomBox) | Read from AdjacentPoint1 to get SampleValues lower adjacent point limit. Write to AdjacentPoint1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
AdjacentPoint3 (inherited from CustomBox) | Read from AdjacentPoint3 to get SampleValues upper adjacent point limit. Write to AdjacentPoint3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
Box (inherited from CustomBox) | Controls the appearance of CustomBoxSeries box.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
ExtrOut (inherited from CustomBox) | Controls the appearance of the extreme range of outer points.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InnerFence1 (inherited from CustomBox) | Read from InnerFence1 to get SampleValues lower inner fence. Write to InnerFence1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
InnerFence3 (inherited from CustomBox) | Read from InnerFence3 to get SampleValues upper inner fence. Write to InnerFence3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
Median (inherited from CustomBox) | Read from Median to get SampleValues median value. Write to Median to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
MedianPen (inherited from CustomBox) | Defines the Pen to draw the median line.
MiddleZ (inherited from Series) | For internal use.
MildOut (inherited from CustomBox) | Controls the appearance of the mid range of outer points.
NumGallerySeries (inherited from Series) | For internal use.
OuterFence1 (inherited from CustomBox) | Read from OuterFence1 to get SampleValues lower outer fence. Write to OuterFence1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
OuterFence3 (inherited from CustomBox) | Read from OuterFence3 to get SampleValues upper outer fence. Write to OuterFence3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
Position (inherited from CustomBox) | Specifies the position of box series.
Quartile1 (inherited from CustomBox) | Read from Quartile1 to get SampleValues first quartile. Write to Quartile1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
Quartile3 (inherited from CustomBox) | Read from Quartile3 to get SampleValues third quartile. Write to Quartile3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
SampleValues (inherited from CustomBox) | Use SampleValues property to get access to the values of Series.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UseCustomValues (inherited from CustomBox) | Set the UseCustomValues property to true if you want to override internal algorithm to construct a box plot.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
WhiskerLength (inherited from CustomBox) | Defines the whisker length as a function of the inter-quartike range (IQR).
WhiskerPen (inherited from CustomBox) | Defines the Pen to draw the whisker lines.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

HorizBox Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizBox Constructor

Overload List

public HorizBox()
public HorizBox(Steema.TeeChart.Chart)

See Also

HorizBox Class | HorizBox Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizBox Constructor

public HorizBox(Chart c)

See Also

HorizBox Constructor Overload List | HorizBox Class | HorizBox Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizBox Constructor

public HorizBox()

See Also

HorizBox Constructor Overload List | HorizBox Class | HorizBox Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizBoxEvents

Steema.TeeChart.Styles.HorizBox Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

HorizBox Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizBoxFields

Steema.TeeChart.Styles.HorizBox Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

HorizBox Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizBoxMethods

Steema.TeeChart.Styles.HorizBox Methods

Public Methods

Add (inherited from CustomBox) | Add x-displacement position and values for Box valueset.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos |
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer (inherited from CustomBox) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from CustomBox) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBox) | Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue |
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue |
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from CustomBox) |
ReconstructFromData (inherited from CustomBox) | Reconstructs the box plot from series data
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

HorizBox Class | Steema.TeeChart.Styles Namespace


CalcYPos

Steema.TeeChart.Styles.HorizBox.CalcYPos Method

public override Int32 CalcYPos(Int32 valueIndex)

See Also

HorizBox Class | HorizBox Members | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.HorizBox.MaxXValue Method

public override Double MaxXValue()

See Also

HorizBox Class | HorizBox Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.HorizBox.MaxYValue Method

Returns the Maximum Value of the Series Y Values List.
public override Double MaxYValue()

See Also

HorizBox Class | HorizBox Members | Steema.TeeChart.Styles Namespace


MinXValue

Steema.TeeChart.Styles.HorizBox.MinXValue Method

public override Double MinXValue()

See Also

HorizBox Class | HorizBox Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.HorizBox.MinYValue Method

Returns the Minimum Value of the Series Y Values List.
public override Double MinYValue()

See Also

HorizBox Class | HorizBox Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizBoxProperties

Steema.TeeChart.Styles.HorizBox Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AdjacentPoint1 (inherited from CustomBox) | Read from AdjacentPoint1 to get SampleValues lower adjacent point limit. Write to AdjacentPoint1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
AdjacentPoint3 (inherited from CustomBox) | Read from AdjacentPoint3 to get SampleValues upper adjacent point limit. Write to AdjacentPoint3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
Box (inherited from CustomBox) | Controls the appearance of CustomBoxSeries box.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
ExtrOut (inherited from CustomBox) | Controls the appearance of the extreme range of outer points.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InnerFence1 (inherited from CustomBox) | Read from InnerFence1 to get SampleValues lower inner fence. Write to InnerFence1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
InnerFence3 (inherited from CustomBox) | Read from InnerFence3 to get SampleValues upper inner fence. Write to InnerFence3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
Median (inherited from CustomBox) | Read from Median to get SampleValues median value. Write to Median to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
MedianPen (inherited from CustomBox) | Defines the Pen to draw the median line.
MiddleZ (inherited from Series) | For internal use.
MildOut (inherited from CustomBox) | Controls the appearance of the mid range of outer points.
NumGallerySeries (inherited from Series) | For internal use.
OuterFence1 (inherited from CustomBox) | Read from OuterFence1 to get SampleValues lower outer fence. Write to OuterFence1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
OuterFence3 (inherited from CustomBox) | Read from OuterFence3 to get SampleValues upper outer fence. Write to OuterFence3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
Position (inherited from CustomBox) | Specifies the position of box series.
Quartile1 (inherited from CustomBox) | Read from Quartile1 to get SampleValues first quartile. Write to Quartile1 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
Quartile3 (inherited from CustomBox) | Read from Quartile3 to get SampleValues third quartile. Write to Quartile3 to override CustomBox Series default calculating algorithm and use supplied value to construct box plot.
SampleValues (inherited from CustomBox) | Use SampleValues property to get access to the values of Series.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UseCustomValues (inherited from CustomBox) | Set the UseCustomValues property to true if you want to override internal algorithm to construct a box plot.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
WhiskerLength (inherited from CustomBox) | Defines the whisker length as a function of the inter-quartike range (IQR).
WhiskerPen (inherited from CustomBox) | Defines the Pen to draw the whisker lines.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

HorizBox Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.HorizBox.Description Property

public override String Description {get;}

See Also

HorizBox Class | HorizBox Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizHistogram

Steema.TeeChart.Styles.HorizHistogram Class

HorizHistogram series.

For a list of all members of this type, see HorizHistogram Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.Histogram
public class HorizHistogram : Histogram , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

HorizHistogram members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizHistogramMembers

Steema.TeeChart.Styles.HorizHistogram all Members

HorizHistogram overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from BaseLine) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Histogram) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Histogram) |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Histogram) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush (inherited from Histogram) |
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
LinesPen (inherited from Histogram) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Histogram) |
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UseYOrigin (inherited from Histogram) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin (inherited from Histogram) |
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

HorizHistogram Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizHistogram Constructor

Overload List

public HorizHistogram(Steema.TeeChart.Chart)
public HorizHistogram()

See Also

HorizHistogram Class | HorizHistogram Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizHistogram Constructor

public HorizHistogram()

See Also

HorizHistogram Constructor Overload List | HorizHistogram Class | HorizHistogram Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizHistogram Constructor

public HorizHistogram(Chart c)

See Also

HorizHistogram Constructor Overload List | HorizHistogram Class | HorizHistogram Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizHistogramEvents

Steema.TeeChart.Styles.HorizHistogram Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

HorizHistogram Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizHistogramFields

Steema.TeeChart.Styles.HorizHistogram Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

HorizHistogram Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizHistogramMethods

Steema.TeeChart.Styles.HorizHistogram Methods

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from BaseLine) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Histogram) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Histogram) |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Histogram) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

HorizHistogram Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizHistogramProperties

Steema.TeeChart.Styles.HorizHistogram Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush (inherited from Histogram) |
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
LinesPen (inherited from Histogram) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Histogram) |
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UseYOrigin (inherited from Histogram) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin (inherited from Histogram) |
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

HorizHistogram Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.HorizHistogram.Description Property

public override String Description {get;}

See Also

HorizHistogram Class | HorizHistogram Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizLine

Steema.TeeChart.Styles.HorizLine Class

Horizontal Line Series.

For a list of all members of this type, see HorizLine Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
Steema.TeeChart.Styles.Line
public class HorizLine : Line , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

HorizLine members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizLineMembers

Steema.TeeChart.Styles.HorizLine all Members

HorizLine overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Custom) | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Custom) |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Custom) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Line) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush (inherited from Custom) | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from Line) | Determines the Line Gradient.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

HorizLine Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizLine Constructor

Overload List

public HorizLine(Steema.TeeChart.Chart)
public HorizLine()

See Also

HorizLine Class | HorizLine Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizLine Constructor

public HorizLine()

See Also

HorizLine Constructor Overload List | HorizLine Class | HorizLine Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizLine Constructor

public HorizLine(Chart c)

See Also

HorizLine Constructor Overload List | HorizLine Class | HorizLine Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizLineEvents

Steema.TeeChart.Styles.HorizLine Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

HorizLine Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizLineFields

Steema.TeeChart.Styles.HorizLine Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

HorizLine Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizLineMethods

Steema.TeeChart.Styles.HorizLine Methods

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Custom) | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Custom) |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Custom) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Line) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

HorizLine Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizLineProperties

Steema.TeeChart.Styles.HorizLine Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush (inherited from Custom) | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from Line) | Determines the Line Gradient.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

HorizLine Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.HorizLine.Description Property

public override String Description {get;}

See Also

HorizLine Class | HorizLine Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.HorizontalAxis

Steema.TeeChart.Styles.HorizontalAxis Enum

Describes the possible values of the HorizAxis property.
[Serializable]
public sealed enum HorizontalAxis : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Top | Associates the series with the top axis.
Bottom | Associates the series with the bottom axis.
Both | Associates the series with both the top and bottom axes.
Custom | Associates the series with a custom axis.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ImageBar

Steema.TeeChart.Styles.ImageBar Class

ImageBar Series.

For a list of all members of this type, see ImageBar Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomBar
Steema.TeeChart.Styles.Bar
public class ImageBar : Bar , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

ImageBar members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ImageBarMembers

Steema.TeeChart.Styles.ImageBar all Members

ImageBar overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetBarStyle (inherited from CustomBar) | Occurs when series bars are painted.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomBar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BarMargin (inherited from CustomBar) | Returns side margin amount in pixels.
BarRectangle (inherited from CustomBar) | For internal use.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Bar) | Returns the Screen X pixel coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Bar) | Returns the Screen Y pixel coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomBar) | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawBar | Internal use. Draws Bar
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from CustomBar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetOriginPos (inherited from Bar) | Returns the corresponding screen pixels coordinate of the leftmost horizontal bar edge.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Bar) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Bar) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Bar) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Bar) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointOrigin (inherited from CustomBar) | For internal use.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from CustomBar) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoMarkPosition (inherited from CustomBar) | Repositions Marks on BarSeries to prevent overlapping.
BarBounds (inherited from CustomBar) | Coordinates of current Bar point being displayed.
BarStyle (inherited from CustomBar) | Defines the Bar shape used to draw Bars.
BarWidthPercent (inherited from Bar) | Determines the percent of total Bar width used.
BevelSize (inherited from CustomBar) | Amount in pixels of the bar bevel. Used only when BarStyle property is Bevel (only in 2D and 3D orthogonal display modes)
Brush (inherited from CustomBar) | Defines the Brush used to fill Bars.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent (inherited from CustomBar) |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBarWidth (inherited from CustomBar) |
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from CustomBar) | Darkens sides of bars to enhance 3D effect.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthPercent (inherited from CustomBar) | Defines the percentage, from 0 to 100, that the bars will need in the "Z" depth space direction.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from CustomBar) | Defines the color Gradient used to fill the Bars.
GradientRelative (inherited from CustomBar) | When Gradient is Visible, calculates Colors based on highest bar.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Image |
ImageTiled |
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksLocation (inherited from CustomBar) | Sets the alignment of the Mark into the Bars.
MarksOnBar (inherited from CustomBar) | Sets a postition of the Marks into the Bars.
MiddleZ (inherited from Series) | For internal use.
MultiBar (inherited from CustomBar) | Determines how multiple BarSeries will be displayed in the same Chart.
NumGallerySeries (inherited from Series) | For internal use.
OffsetPercent (inherited from CustomBar) | Sets the Bar displacement as percent of Bar size.
Origin (inherited from CustomBar) | Sets the common bottom value used for all Bar points.
Pen (inherited from CustomBar) | Pen used to draw the Bar rectangles.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow (inherited from CustomBar) | Defines the Shadow used to draw behind the Bars.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideMargins (inherited from CustomBar) | Sets a margin between Chart rectangle and Bars.
StackGroup (inherited from CustomBar) | Allows stacking independent Series within the same Chart.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickLines (inherited from CustomBar) | Pen used to draw "tick" lines across each bar.
Title (inherited from Series) | Series description to show in Legend and editors.
UseOrigin (inherited from CustomBar) | Allows Bars to be bottom aligned to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin (inherited from CustomBar) | System.Obsolete: Please use Origin property.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

ImageBar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ImageBar Constructor

Overload List

public ImageBar()
public ImageBar(Steema.TeeChart.Chart)

See Also

ImageBar Class | ImageBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ImageBar Constructor

public ImageBar(Chart c)

See Also

ImageBar Constructor Overload List | ImageBar Class | ImageBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ImageBar Constructor

public ImageBar()

See Also

ImageBar Constructor Overload List | ImageBar Class | ImageBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ImageBarEvents

Steema.TeeChart.Styles.ImageBar Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetBarStyle (inherited from CustomBar) | Occurs when series bars are painted.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

ImageBar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ImageBarFields

Steema.TeeChart.Styles.ImageBar Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

ImageBar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ImageBarMethods

Steema.TeeChart.Styles.ImageBar Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomBar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BarMargin (inherited from CustomBar) | Returns side margin amount in pixels.
BarRectangle (inherited from CustomBar) | For internal use.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Bar) | Returns the Screen X pixel coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Bar) | Returns the Screen Y pixel coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomBar) | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawBar | Internal use. Draws Bar
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from CustomBar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetOriginPos (inherited from Bar) | Returns the corresponding screen pixels coordinate of the leftmost horizontal bar edge.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Bar) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Bar) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Bar) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Bar) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointOrigin (inherited from CustomBar) | For internal use.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from CustomBar) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

ImageBar Class | Steema.TeeChart.Styles Namespace


DrawBar

Steema.TeeChart.Styles.ImageBar.DrawBar Method

Internal use. Draws Bar
public override Void DrawBar(Int32 BarIndex,
     Int32 StartPos,
     Int32 EndPos)

See Also

ImageBar Class | ImageBar Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.ImageBar.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

ImageBar Class | ImageBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ImageBarProperties

Steema.TeeChart.Styles.ImageBar Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoMarkPosition (inherited from CustomBar) | Repositions Marks on BarSeries to prevent overlapping.
BarBounds (inherited from CustomBar) | Coordinates of current Bar point being displayed.
BarStyle (inherited from CustomBar) | Defines the Bar shape used to draw Bars.
BarWidthPercent (inherited from Bar) | Determines the percent of total Bar width used.
BevelSize (inherited from CustomBar) | Amount in pixels of the bar bevel. Used only when BarStyle property is Bevel (only in 2D and 3D orthogonal display modes)
Brush (inherited from CustomBar) | Defines the Brush used to fill Bars.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent (inherited from CustomBar) |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBarWidth (inherited from CustomBar) |
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from CustomBar) | Darkens sides of bars to enhance 3D effect.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthPercent (inherited from CustomBar) | Defines the percentage, from 0 to 100, that the bars will need in the "Z" depth space direction.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from CustomBar) | Defines the color Gradient used to fill the Bars.
GradientRelative (inherited from CustomBar) | When Gradient is Visible, calculates Colors based on highest bar.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Image |
ImageTiled |
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksLocation (inherited from CustomBar) | Sets the alignment of the Mark into the Bars.
MarksOnBar (inherited from CustomBar) | Sets a postition of the Marks into the Bars.
MiddleZ (inherited from Series) | For internal use.
MultiBar (inherited from CustomBar) | Determines how multiple BarSeries will be displayed in the same Chart.
NumGallerySeries (inherited from Series) | For internal use.
OffsetPercent (inherited from CustomBar) | Sets the Bar displacement as percent of Bar size.
Origin (inherited from CustomBar) | Sets the common bottom value used for all Bar points.
Pen (inherited from CustomBar) | Pen used to draw the Bar rectangles.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow (inherited from CustomBar) | Defines the Shadow used to draw behind the Bars.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideMargins (inherited from CustomBar) | Sets a margin between Chart rectangle and Bars.
StackGroup (inherited from CustomBar) | Allows stacking independent Series within the same Chart.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickLines (inherited from CustomBar) | Pen used to draw "tick" lines across each bar.
Title (inherited from Series) | Series description to show in Legend and editors.
UseOrigin (inherited from CustomBar) | Allows Bars to be bottom aligned to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin (inherited from CustomBar) | System.Obsolete: Please use Origin property.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

ImageBar Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.ImageBar.Description Property

public override String Description {get;}

See Also

ImageBar Class | ImageBar Members | Steema.TeeChart.Styles Namespace


Image

Steema.TeeChart.Styles.ImageBar.Image Property

public Bitmap Image {get; set;}

See Also

ImageBar Class | ImageBar Members | Steema.TeeChart.Styles Namespace


ImageTiled

Steema.TeeChart.Styles.ImageBar.ImageTiled Property

public Boolean ImageTiled {get; set;}

See Also

ImageBar Class | ImageBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ImagePoint

Steema.TeeChart.Styles.ImagePoint Class

For a list of all members of this type, see ImagePoint Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Points
Steema.TeeChart.Styles.CustomImagePoint
public class ImagePoint : CustomImagePoint , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

ImagePoint members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ImagePointMembers

Steema.TeeChart.Styles.ImagePoint all Members

ImagePoint overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetImage (inherited from CustomImagePoint) |
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomImagePoint) |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from CustomImagePoint) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
PointImage (inherited from CustomImagePoint) |
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparent (inherited from CustomImagePoint) |
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

ImagePoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ImagePoint Constructor

Overload List

public ImagePoint()
public ImagePoint(Steema.TeeChart.Chart)

See Also

ImagePoint Class | ImagePoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ImagePoint Constructor

public ImagePoint(Chart c)

See Also

ImagePoint Constructor Overload List | ImagePoint Class | ImagePoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ImagePoint Constructor

public ImagePoint()

See Also

ImagePoint Constructor Overload List | ImagePoint Class | ImagePoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ImagePointEvents

Steema.TeeChart.Styles.ImagePoint Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetImage (inherited from CustomImagePoint) |
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

ImagePoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ImagePointFields

Steema.TeeChart.Styles.ImagePoint Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

ImagePoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ImagePointMethods

Steema.TeeChart.Styles.ImagePoint Methods

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomImagePoint) |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from CustomImagePoint) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

ImagePoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ImagePointProperties

Steema.TeeChart.Styles.ImagePoint Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
PointImage (inherited from CustomImagePoint) |
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparent (inherited from CustomImagePoint) |
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

ImagePoint Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.ImagePoint.Description Property

public override String Description {get;}

See Also

ImagePoint Class | ImagePoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ISeriesPointer

Steema.TeeChart.Styles.ISeriesPointer Interface

public interface ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

ISeriesPointer members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ISeriesPointerMembers

Steema.TeeChart.Styles.ISeriesPointer all Members

ISeriesPointer overview

Public Properties

Pointer

See Also

ISeriesPointer Interface | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ISeriesPointerProperties

Steema.TeeChart.Styles.ISeriesPointer Properties

Public Properties

Pointer

See Also

ISeriesPointer Interface | Steema.TeeChart.Styles Namespace


Pointer

Steema.TeeChart.Styles.ISeriesPointer.Pointer Property

public abstract SeriesPointer Pointer {get; set;}

See Also

ISeriesPointer Interface | ISeriesPointer Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.IsoSurface

Steema.TeeChart.Styles.IsoSurface Class

Iso-Surface 3D Series.

For a list of all members of this type, see IsoSurface Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
Steema.TeeChart.Styles.Custom3DGrid
Steema.TeeChart.Styles.Surface
public class IsoSurface : Surface , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

IsoSurface members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.IsoSurfaceMembers

Steema.TeeChart.Styles.IsoSurface all Members

IsoSurface overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
GetYValue (inherited from Custom3DGrid) | Occurs when the Surface Series needs to recreate the grid of values.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
ReuseGridIndex (inherited from Custom3DGrid) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Custom3D) | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CellsOrientation (inherited from Surface) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Custom3DGrid) | Deletes all Series values.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked (inherited from Surface) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
CreateValues (inherited from Custom3DGrid) | Makes a Surface grid of NumX by NumZ dimensions.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FastCalcPoints (inherited from Surface) |
FillGridIndex (inherited from Custom3DGrid) |
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom3DPalette) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Custom3DPalette) | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Custom3D) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
BandPen |
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
DotFrame (inherited from Surface) | Sets SurfaceSeries as a grid of dots (pixels).
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HideCells (inherited from Surface) |
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IrregularGrid (inherited from Custom3DGrid) | Determine if X and Z values are equi-distant or not.
Item (inherited from Custom3DGrid) | A two dimension array property for the easy access to series cell values.
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
NumXValues (inherited from Custom3DGrid) | Determines the Surface's horizontal size in number of points.
NumZValues (inherited from Custom3DGrid) | Determines the Surface's depth size in number of points.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideBrush (inherited from Surface) | Determines the Brush to fill the sides of a Surface Series.
SideLines (inherited from Surface) |
Sides |
SmoothPalette (inherited from Surface) | Determine the cell Colors of a Surface Series.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
UseYPosition |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
WaterFall (inherited from Surface) | Enables/disables the display as a waterfall.
WaterLines (inherited from Surface) | Sets Pen to draw valuelines.
WireFrame (inherited from Surface) | Shows Surface polygons as grid or wire frame when true.
XValues (inherited from Series) | Values defining horizontal point positions.
YPosition |
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

IsoSurface Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.IsoSurface Constructor

Overload List

public IsoSurface()
public IsoSurface(Steema.TeeChart.Chart)

See Also

IsoSurface Class | IsoSurface Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.IsoSurface Constructor

public IsoSurface(Chart c)

See Also

IsoSurface Constructor Overload List | IsoSurface Class | IsoSurface Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.IsoSurface Constructor

public IsoSurface()

See Also

IsoSurface Constructor Overload List | IsoSurface Class | IsoSurface Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.IsoSurfaceEvents

Steema.TeeChart.Styles.IsoSurface Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
GetYValue (inherited from Custom3DGrid) | Occurs when the Surface Series needs to recreate the grid of values.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

IsoSurface Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.IsoSurfaceFields

Steema.TeeChart.Styles.IsoSurface Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
ReuseGridIndex (inherited from Custom3DGrid) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

IsoSurface Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.IsoSurfaceMethods

Steema.TeeChart.Styles.IsoSurface Methods

Public Methods

Add (inherited from Custom3D) | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CellsOrientation (inherited from Surface) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Custom3DGrid) | Deletes all Series values.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked (inherited from Surface) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
CreateValues (inherited from Custom3DGrid) | Makes a Surface grid of NumX by NumZ dimensions.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FastCalcPoints (inherited from Surface) |
FillGridIndex (inherited from Custom3DGrid) |
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom3DPalette) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Custom3DPalette) | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Custom3D) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

IsoSurface Class | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.IsoSurface.Draw Method

public override Void Draw()

See Also

IsoSurface Class | IsoSurface Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.IsoSurface.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

IsoSurface Class | IsoSurface Members | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.IsoSurface.SetSubGallery Method

public override Void SetSubGallery(Int32 index)

See Also

IsoSurface Class | IsoSurface Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.IsoSurfaceProperties

Steema.TeeChart.Styles.IsoSurface Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
BandPen |
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
DotFrame (inherited from Surface) | Sets SurfaceSeries as a grid of dots (pixels).
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HideCells (inherited from Surface) |
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IrregularGrid (inherited from Custom3DGrid) | Determine if X and Z values are equi-distant or not.
Item (inherited from Custom3DGrid) | A two dimension array property for the easy access to series cell values.
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
NumXValues (inherited from Custom3DGrid) | Determines the Surface's horizontal size in number of points.
NumZValues (inherited from Custom3DGrid) | Determines the Surface's depth size in number of points.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideBrush (inherited from Surface) | Determines the Brush to fill the sides of a Surface Series.
SideLines (inherited from Surface) |
Sides |
SmoothPalette (inherited from Surface) | Determine the cell Colors of a Surface Series.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
UseYPosition |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
WaterFall (inherited from Surface) | Enables/disables the display as a waterfall.
WaterLines (inherited from Surface) | Sets Pen to draw valuelines.
WireFrame (inherited from Surface) | Shows Surface polygons as grid or wire frame when true.
XValues (inherited from Series) | Values defining horizontal point positions.
YPosition |
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

IsoSurface Class | Steema.TeeChart.Styles Namespace


BandPen

Steema.TeeChart.Styles.IsoSurface.BandPen Property

public ChartPen BandPen {get; set;}

See Also

IsoSurface Class | IsoSurface Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.IsoSurface.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

IsoSurface Class | IsoSurface Members | Steema.TeeChart.Styles Namespace


Sides

Steema.TeeChart.Styles.IsoSurface.Sides Property

public SurfaceSides Sides {get; set;}

See Also

IsoSurface Class | IsoSurface Members | Steema.TeeChart.Styles Namespace


UseYPosition

Steema.TeeChart.Styles.IsoSurface.UseYPosition Property

public Boolean UseYPosition {get; set;}

See Also

IsoSurface Class | IsoSurface Members | Steema.TeeChart.Styles Namespace


YPosition

Steema.TeeChart.Styles.IsoSurface.YPosition Property

public Double YPosition {get; set;}

See Also

IsoSurface Class | IsoSurface Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.IVideoCreator

Steema.TeeChart.Styles.IVideoCreator Interface

public interface IVideoCreator

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

IVideoCreator members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.IVideoCreatorMembers

Steema.TeeChart.Styles.IVideoCreator all Members

IVideoCreator overview

Public Methods

GetChart
StartRecording
StopRecording

Public Properties

Tag

See Also

IVideoCreator Interface | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.IVideoCreatorMethods

Steema.TeeChart.Styles.IVideoCreator Methods

Public Methods

GetChart
StartRecording
StopRecording

See Also

IVideoCreator Interface | Steema.TeeChart.Styles Namespace


GetChart

Steema.TeeChart.Styles.IVideoCreator.GetChart Method

public abstract Chart GetChart()

See Also

IVideoCreator Interface | IVideoCreator Members | Steema.TeeChart.Styles Namespace


StartRecording

Steema.TeeChart.Styles.IVideoCreator.StartRecording Method

public abstract Void StartRecording(String FileName)

See Also

IVideoCreator Interface | IVideoCreator Members | Steema.TeeChart.Styles Namespace


StopRecording

Steema.TeeChart.Styles.IVideoCreator.StopRecording Method

public abstract Void StopRecording()

See Also

IVideoCreator Interface | IVideoCreator Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.IVideoCreatorProperties

Steema.TeeChart.Styles.IVideoCreator Properties

Public Properties

Tag

See Also

IVideoCreator Interface | Steema.TeeChart.Styles Namespace


Tag

Steema.TeeChart.Styles.IVideoCreator.Tag Property

public abstract Object Tag {get; set;}

See Also

IVideoCreator Interface | IVideoCreator Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.IVideoPlayer

Steema.TeeChart.Styles.IVideoPlayer Interface

public interface IVideoPlayer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

IVideoPlayer members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.IVideoPlayerMembers

Steema.TeeChart.Styles.IVideoPlayer all Members

IVideoPlayer overview

Public Methods

Play

Public Properties

Brush
FileName
Loop

See Also

IVideoPlayer Interface | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.IVideoPlayerMethods

Steema.TeeChart.Styles.IVideoPlayer Methods

Public Methods

Play

See Also

IVideoPlayer Interface | Steema.TeeChart.Styles Namespace


Play

Steema.TeeChart.Styles.IVideoPlayer.Play Method

public abstract Void Play()

See Also

IVideoPlayer Interface | IVideoPlayer Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.IVideoPlayerProperties

Steema.TeeChart.Styles.IVideoPlayer Properties

Public Properties

Brush
FileName
Loop

See Also

IVideoPlayer Interface | Steema.TeeChart.Styles Namespace


Brush

Steema.TeeChart.Styles.IVideoPlayer.Brush Property

public abstract ChartBrush Brush {get; set;}

See Also

IVideoPlayer Interface | IVideoPlayer Members | Steema.TeeChart.Styles Namespace


FileName

Steema.TeeChart.Styles.IVideoPlayer.FileName Property

public abstract String FileName {get; set;}

See Also

IVideoPlayer Interface | IVideoPlayer Members | Steema.TeeChart.Styles Namespace


Loop

Steema.TeeChart.Styles.IVideoPlayer.Loop Property

public abstract Boolean Loop {get; set;}

See Also

IVideoPlayer Interface | IVideoPlayer Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.IWorldMaps

Steema.TeeChart.Styles.IWorldMaps Interface

public interface IWorldMaps

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

IWorldMaps members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.IWorldMapsMembers

Steema.TeeChart.Styles.IWorldMaps all Members

IWorldMaps overview

Public Methods

GetWorldMapTypeNames
ParseWorldMapTypeName

Public Properties

InGallery

See Also

IWorldMaps Interface | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.IWorldMapsMethods

Steema.TeeChart.Styles.IWorldMaps Methods

Public Methods

GetWorldMapTypeNames
ParseWorldMapTypeName

See Also

IWorldMaps Interface | Steema.TeeChart.Styles Namespace


GetWorldMapTypeNames

Steema.TeeChart.Styles.IWorldMaps.GetWorldMapTypeNames Method

public abstract String[] GetWorldMapTypeNames()

See Also

IWorldMaps Interface | IWorldMaps Members | Steema.TeeChart.Styles Namespace


ParseWorldMapTypeName

Steema.TeeChart.Styles.IWorldMaps.ParseWorldMapTypeName Method

public abstract Object ParseWorldMapTypeName(String name)

See Also

IWorldMaps Interface | IWorldMaps Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.IWorldMapsProperties

Steema.TeeChart.Styles.IWorldMaps Properties

Public Properties

InGallery

See Also

IWorldMaps Interface | Steema.TeeChart.Styles Namespace


InGallery

Steema.TeeChart.Styles.IWorldMaps.InGallery Property

public abstract Boolean InGallery {get; set;}

See Also

IWorldMaps Interface | IWorldMaps Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Kagi

Steema.TeeChart.Styles.Kagi Class

The Kagi financial chart.

For a list of all members of this type, see Kagi Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
Steema.TeeChart.Styles.OHLC
Steema.TeeChart.Styles.CustomTimeOHLC
public class Kagi : CustomTimeOHLC , ICloneable, ISeriesPointer

Remarks

Kagi charts, at first glance, look like swing charts. Like swing charts, they have no time axis and are made up of a series of vertical lines, however in the case of kagi charts, the vertical lines are based solely on the action of closing prices, not a bar's high and low prices. Another difference is that the thickness of a kagi chart line changes when closing prices penetrate the previous column top or bottom.

Construction of Kagi Chart:

Choose a reversal amount - absolute or relative value. Note the first closing price in your data. This is called the BasePrice. If the closing price of Day 2 is greater than the closing price of Day 1 (the base price), use UpSwing stype to draw vertical line upwards from the closing price of Day 1 to the closing price of Day 2. If the closing price of Day 2 is less than the closing price of Day 1, use DownPen style to draw vertical line downwards from the closing price of Day 1 to the closing price of Day 2. If the closing price of Day 2 is equal to the closing price of Day 1, do nothing. Instead, wait until the end of Day 3, and compare this price with the base price. If the closing price continues to rise (or fall), we keep moving the kagi chart up (or down) to the close of each day, regardless of how much or how little it moves. If the closing price moves in the opposite direction by less than a predetermined number of cents, the reversal amount, we ignore the small move and do nothing to our chart. If the kagi line has been moving upwards, and the closing price has fallen by more than the reversal amount, we draw a short horizontal line, called the 'inflection line', then a new line downwards, to the lower close of that day. If the kagi line has been moving downwards, and the closing price has risen by more than the reversal amount, we draw an inflection line, then a new line upwards, to the higher close of that day.

Vertical drawing pen style is defined by the following rules: If a DownSwing line is extended beyond the previous swing high, pen style is change to UpSwing penbeyond that point. An UpSwing pen changes to DownSwing pen when the UpSwing line moves below the previous swing low.

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Kagi members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.KagiMembers

Steema.TeeChart.Styles.Kagi all Members

Kagi overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValue | Event triggers on Kagi point plot. Can be used to monitor reversals.
AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from OHLC) | Adds new point with specified integer index and double open, high, low and close.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Custom) | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Custom) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from OHLC) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString |
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue |
MaxYValue |
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue |
MinYValue |
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

AbsoluteReversal | If false, reversal amount is treated as percentage, otherwise as absolute value.
Active (inherited from Series) | Shows or hides this series.
BasePrice | The base price i.e. first closing value.
BoxSize (inherited from CustomTimeOHLC) |
BoxType (inherited from CustomTimeOHLC) | Use BoxType to change box sensitivity according to the data range.
Brush (inherited from Custom) | Sets Brush characteristics.
BuySymbol | Defines buy symbol.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
CloseValues (inherited from OHLC) | Gets and sets all Stock market Close values.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DateValues (inherited from OHLC) | Gets and sets all Stock market Date values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
DownSwing | Controls the appearance of downswing lines.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HighValues (inherited from OHLC) | Gets and sets all Stock market High values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IncrementAsBox (inherited from CustomTimeOHLC) | When true, Chart will try to size grid to box size.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from OHLC) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
LowValues (inherited from OHLC) | Gets and sets all Stock market Low values.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OpenValues (inherited from OHLC) | Gets and sets all Stock market Open values.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Period (inherited from CustomTimeOHLC) |
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
ReversalAmount | Reversal ammount (percentage or absolute value)
SellSymbol | Defines sell symbol.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UpSwing | Controls the appearance of upswing lines.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Kagi Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Kagi Constructor

Overload List

public Kagi()
public Kagi(Steema.TeeChart.Chart)

See Also

Kagi Class | Kagi Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Kagi Constructor

public Kagi(Chart c)

See Also

Kagi Constructor Overload List | Kagi Class | Kagi Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Kagi Constructor

public Kagi()

See Also

Kagi Constructor Overload List | Kagi Class | Kagi Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.KagiEvents

Steema.TeeChart.Styles.Kagi Events

Public Events

AfterDrawValue | Event triggers on Kagi point plot. Can be used to monitor reversals.
AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Kagi Class | Steema.TeeChart.Styles Namespace


AfterDrawValue

Steema.TeeChart.Styles.Kagi.AfterDrawValue Event

Event triggers on Kagi point plot. Can be used to monitor reversals.
public KagiDrawValueEventHandler  AfterDrawValue

See Also

Kagi Class | Kagi Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.KagiFields

Steema.TeeChart.Styles.Kagi Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Kagi Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.KagiMethods

Steema.TeeChart.Styles.Kagi Methods

Public Methods

Add (inherited from OHLC) | Adds new point with specified integer index and double open, high, low and close.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Custom) | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Custom) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from OHLC) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString |
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue |
MaxYValue |
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue |
MinYValue |
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Kagi Class | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.Kagi.Draw Method

public override Void Draw()

See Also

Kagi Class | Kagi Members | Steema.TeeChart.Styles Namespace


LegendString

Steema.TeeChart.Styles.Kagi.LegendString Method

public override String LegendString(Int32 legendIndex,
     LegendTextStyles legendTextStyle)

See Also

Kagi Class | Kagi Members | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.Kagi.MaxXValue Method

public override Double MaxXValue()

See Also

Kagi Class | Kagi Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.Kagi.MaxYValue Method

public override Double MaxYValue()

See Also

Kagi Class | Kagi Members | Steema.TeeChart.Styles Namespace


MinXValue

Steema.TeeChart.Styles.Kagi.MinXValue Method

public override Double MinXValue()

See Also

Kagi Class | Kagi Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.Kagi.MinYValue Method

public override Double MinYValue()

See Also

Kagi Class | Kagi Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.Kagi.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

Kagi Class | Kagi Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.KagiProperties

Steema.TeeChart.Styles.Kagi Properties

Public Properties

AbsoluteReversal | If false, reversal amount is treated as percentage, otherwise as absolute value.
Active (inherited from Series) | Shows or hides this series.
BasePrice | The base price i.e. first closing value.
BoxSize (inherited from CustomTimeOHLC) |
BoxType (inherited from CustomTimeOHLC) | Use BoxType to change box sensitivity according to the data range.
Brush (inherited from Custom) | Sets Brush characteristics.
BuySymbol | Defines buy symbol.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
CloseValues (inherited from OHLC) | Gets and sets all Stock market Close values.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DateValues (inherited from OHLC) | Gets and sets all Stock market Date values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
DownSwing | Controls the appearance of downswing lines.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HighValues (inherited from OHLC) | Gets and sets all Stock market High values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IncrementAsBox (inherited from CustomTimeOHLC) | When true, Chart will try to size grid to box size.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from OHLC) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
LowValues (inherited from OHLC) | Gets and sets all Stock market Low values.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OpenValues (inherited from OHLC) | Gets and sets all Stock market Open values.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Period (inherited from CustomTimeOHLC) |
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
ReversalAmount | Reversal ammount (percentage or absolute value)
SellSymbol | Defines sell symbol.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UpSwing | Controls the appearance of upswing lines.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Kagi Class | Steema.TeeChart.Styles Namespace


AbsoluteReversal

Steema.TeeChart.Styles.Kagi.AbsoluteReversal Property

If false, reversal amount is treated as percentage, otherwise as absolute value.
public Boolean AbsoluteReversal {get; set;}

See Also

Kagi Class | Kagi Members | Steema.TeeChart.Styles Namespace


BasePrice

Steema.TeeChart.Styles.Kagi.BasePrice Property

The base price i.e. first closing value.
public Double BasePrice {get;}

See Also

Kagi Class | Kagi Members | Steema.TeeChart.Styles Namespace


BuySymbol

Steema.TeeChart.Styles.Kagi.BuySymbol Property

Defines buy symbol.
public SeriesPointer BuySymbol {get;}

See Also

Kagi Class | Kagi Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Kagi.Description Property

public override String Description {get;}

See Also

Kagi Class | Kagi Members | Steema.TeeChart.Styles Namespace


DownSwing

Steema.TeeChart.Styles.Kagi.DownSwing Property

Controls the appearance of downswing lines.
public ChartPen DownSwing {get;}

See Also

Kagi Class | Kagi Members | Steema.TeeChart.Styles Namespace


ReversalAmount

Steema.TeeChart.Styles.Kagi.ReversalAmount Property

Reversal ammount (percentage or absolute value)
public Double ReversalAmount {get; set;}

See Also

Kagi Class | Kagi Members | Steema.TeeChart.Styles Namespace


SellSymbol

Steema.TeeChart.Styles.Kagi.SellSymbol Property

Defines sell symbol.
public SeriesPointer SellSymbol {get;}

See Also

Kagi Class | Kagi Members | Steema.TeeChart.Styles Namespace


UpSwing

Steema.TeeChart.Styles.Kagi.UpSwing Property

Controls the appearance of upswing lines.
public ChartPen UpSwing {get;}

See Also

Kagi Class | Kagi Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Kagi.BoxLabel

Steema.TeeChart.Styles.Kagi.BoxLabel ValueType

For a list of all members of this type, see BoxLabel Members

System.Object
System.ValueType
public sealed struct BoxLabel : ValueType

See Also

BoxLabel Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Kagi.BoxLabelMembers

Steema.TeeChart.Styles.Kagi.BoxLabel all Members

BoxLabel overview

Constructors

Steema.TeeChart.Styles.Kagi.BoxLabel..ctor

Public Fields

BoxDate
BoxValue
Index

See Also

BoxLabel Structure | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Kagi+BoxLabel Constructor

public Kagi+BoxLabel(Int32 idx,
     Double date,
     Double value)

See Also

BoxLabel Structure | BoxLabel Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Kagi.BoxLabelFields

Steema.TeeChart.Styles.Kagi.BoxLabel Fields

Public Fields

BoxDate
BoxValue
Index

See Also

BoxLabel Structure | Steema.TeeChart.Styles Namespace


BoxDate

Steema.TeeChart.Styles.Kagi+BoxLabel.BoxDate Field

public Double BoxDate

See Also

BoxLabel Structure | BoxLabel Members | Steema.TeeChart.Styles Namespace


BoxValue

Steema.TeeChart.Styles.Kagi+BoxLabel.BoxValue Field

public Double BoxValue

See Also

BoxLabel Structure | BoxLabel Members | Steema.TeeChart.Styles Namespace


Index

Steema.TeeChart.Styles.Kagi+BoxLabel.Index Field

public Int32 Index

See Also

BoxLabel Structure | BoxLabel Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.KagiDrawValueEventArgs

Steema.TeeChart.Styles.KagiDrawValueEventArgs Class

Variables describe point characteristics when plotted.

For a list of all members of this type, see KagiDrawValueEventArgs Members

System.Object
System.EventArgs
public class KagiDrawValueEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

KagiDrawValueEventArgs members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.KagiDrawValueEventArgsMembers

Steema.TeeChart.Styles.KagiDrawValueEventArgs all Members

KagiDrawValueEventArgs overview

Constructors

Constructor

Public Properties

Close
ColIndex
IsUp
Reversal

See Also

KagiDrawValueEventArgs Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.KagiDrawValueEventArgs Constructor

public KagiDrawValueEventArgs(Int32 index,
     Double closeValue,
     Boolean isUp,
     Boolean reversal)

See Also

KagiDrawValueEventArgs Class | KagiDrawValueEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.KagiDrawValueEventArgsProperties

Steema.TeeChart.Styles.KagiDrawValueEventArgs Properties

Public Properties

Close
ColIndex
IsUp
Reversal

See Also

KagiDrawValueEventArgs Class | Steema.TeeChart.Styles Namespace


Close

Steema.TeeChart.Styles.KagiDrawValueEventArgs.Close Property

public Double Close {get; set;}

See Also

KagiDrawValueEventArgs Class | KagiDrawValueEventArgs Members | Steema.TeeChart.Styles Namespace


ColIndex

Steema.TeeChart.Styles.KagiDrawValueEventArgs.ColIndex Property

public Int32 ColIndex {get; set;}

See Also

KagiDrawValueEventArgs Class | KagiDrawValueEventArgs Members | Steema.TeeChart.Styles Namespace


IsUp

Steema.TeeChart.Styles.KagiDrawValueEventArgs.IsUp Property

public Boolean IsUp {get; set;}

See Also

KagiDrawValueEventArgs Class | KagiDrawValueEventArgs Members | Steema.TeeChart.Styles Namespace


Reversal

Steema.TeeChart.Styles.KagiDrawValueEventArgs.Reversal Property

public Boolean Reversal {get; set;}

See Also

KagiDrawValueEventArgs Class | KagiDrawValueEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.KagiDrawValueEventHandler

Steema.TeeChart.Styles.KagiDrawValueEventHandler Delegate

Used with event triggered when Kagi points are plotted.
public delegate KagiDrawValueEventHandler (Object sender,
     KagiDrawValueEventArgs e)

Parameters

sender
e

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.KnobGauge

Steema.TeeChart.Styles.KnobGauge Class

KnobGauge Series.

For a list of all members of this type, see KnobGauge Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
Steema.TeeChart.Styles.CircularGauge
public class KnobGauge : CircularGauge , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

KnobGauge members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.KnobGaugeMembers

Steema.TeeChart.Styles.KnobGauge all Members

KnobGauge overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawHand (inherited from CircularGauge) |
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.
ValueChanged (inherited from CircularGauge) | Called when the Gauge Value property is changed.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Circular) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Circular) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from CircularGauge) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery (inherited from CircularGauge) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
ActiveCenter | When true, Knobgauge centre responds to mousedragging to modify value.
AutoPositionLinearGauge (inherited from CircularGauge) | Gets and sets the automatic positioning of the embedded LinearGauge.
AutoPositionNumericGauge (inherited from CircularGauge) | Gets and sets the automatic positioning of the embedded NumericGauge.
AutoValueLinearGauge (inherited from CircularGauge) | Gets and sets the whether or not the embedded LinearGauge displays the same value as the CircularGauge.
AutoValueNumericGauge (inherited from CircularGauge) | Gets and sets the whether or not the embedded NumericGauge displays the same value as the CircularGauge.
Axis (inherited from CircularGauge) | Gets the CircularGauges's Axis characteristics.
AxisInside | Gets and sets whether not the entire Gauge Axis is displayed outside of the bounding circular area.
Center (inherited from CircularGauge) | Returns a sub-object with properties that control the appearance of a shape at the middle of gauge.
CenterPoint | Returns the Knobgauge centrepoint. Read-only.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorLineEndValues (inherited from CircularGauge) | Gets or sets a collection of EndValues which initially contains the RedLineEndValue and the GreenLineEndValue.
ColorLines (inherited from CircularGauge) | Gets or sets a collection of ColorLines which initially contains the RedLine and the GreenLine.
ColorLineStartValues (inherited from CircularGauge) | Gets or sets a collection of StartValues which initially contains the RedLineStartValue and the GreenLineStartValue.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBounds (inherited from CircularGauge) | Gets or sets a custom bounding rectangle for the gauge.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
DisplayRotationAngle (inherited from CircularGauge) | Gets and sets the angle of Frame rotation.
DisplayTotalAngle (inherited from CircularGauge) | Gets and sets the total display angle of the Frame.
EndPoint (inherited from CircularGauge) | Returns a sub-object with properties that control the appearance of a shape at the end of the gauge arrow.
EndZ (inherited from Series) | For internal use.
FaceBrush (inherited from CircularGauge) | ChartBrush characteristics of the CircularGauge's face.
FillToSemiCircle (inherited from CircularGauge) | Gets or sets whether or not a semi-circular GaugeSeries is filled.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Frame (inherited from CircularGauge) | The Frame is the object which surrounds the CircularGauge and which consists of three configurable Bands: Inner, Middle and Outer.
Function (inherited from Series) | Function object to calculate values.
GaugeColorPalette (inherited from CircularGauge) | Gets and sets the CircularGauge's color palette.
GreenLine (inherited from CircularGauge) | The 'greenline' object is the curved shape with a gradient which is used to signal a low or minimum value.
GreenLineEndValue (inherited from CircularGauge) | Gets and sets the value at which the 'redline' marker ends.
GreenLineStartValue (inherited from CircularGauge) | Gets and sets the value at which the 'redline' marker starts.
Hand (inherited from CircularGauge) | Gets and sets the Hand (or needle) object characteristics.
HandDistance (inherited from CircularGauge) | Gets and sets the distance between the center of the hand and its head as a percentage of the total distance.
HandOffset (inherited from CircularGauge) | Gets and sets the distance between the center of the hand and its tail as a percentage of the total distance.
HighLightBrush | Gets and sets the brush which draws the highlight on the knob.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsInside (inherited from CircularGauge) | Defines where to display gauge axis labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinearGauge (inherited from CircularGauge) | Gets and sets properties of an embedded LinearGauge. Set Visible to true to visualize.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
Maximum (inherited from CircularGauge) | Gets or sets the maximum value for the gauge.
MiddleZ (inherited from Series) | For internal use.
Minimum (inherited from CircularGauge) | Gets or sets the minimum value for the gauge.
MinorTickDistance (inherited from CircularGauge) | The distance between the minor ticks and the CircularGauge curved axis.
MinorTicks (inherited from CircularGauge) | Gets and sets the characteristics of the Axis' minor tick marks.
NumericGauge (inherited from CircularGauge) | Gets and sets properties of an embedded NumericGauge. Set Visible to true to visualize.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedLine (inherited from CircularGauge) | The 'redline' object is the curved shape with a gradient which is used to signal a high or maximum value.
RedLineEndValue (inherited from CircularGauge) | Gets and sets the value at which the 'redline' marker ends.
RedLineStartValue (inherited from CircularGauge) | Gets and sets the value at which the 'redline' marker starts.
RotateLabels (inherited from CircularGauge) | When true, labels are rotated so to appear parallel to the curved CircularGauge axis.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Ticks (inherited from CircularGauge) | Gets and sets the characteristics of the Axis' major tick marks.
Title (inherited from Series) | Series description to show in Legend and editors.
TotalAngle (inherited from CircularGauge) | Controls the size in degrees for the gauge axis.
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
Value (inherited from CircularGauge) | Gets or sets the position of gauge arrow line.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

KnobGauge Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.KnobGauge Constructor

Overload List

public KnobGauge()
public KnobGauge(Steema.TeeChart.Chart)

See Also

KnobGauge Class | KnobGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.KnobGauge Constructor

public KnobGauge(Chart c)

See Also

KnobGauge Constructor Overload List | KnobGauge Class | KnobGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.KnobGauge Constructor

public KnobGauge()

See Also

KnobGauge Constructor Overload List | KnobGauge Class | KnobGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.KnobGaugeEvents

Steema.TeeChart.Styles.KnobGauge Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawHand (inherited from CircularGauge) |
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.
ValueChanged (inherited from CircularGauge) | Called when the Gauge Value property is changed.

See Also

KnobGauge Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.KnobGaugeFields

Steema.TeeChart.Styles.KnobGauge Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

KnobGauge Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.KnobGaugeMethods

Steema.TeeChart.Styles.KnobGauge Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Circular) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Circular) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from CircularGauge) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery (inherited from CircularGauge) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

KnobGauge Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.KnobGaugeProperties

Steema.TeeChart.Styles.KnobGauge Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
ActiveCenter | When true, Knobgauge centre responds to mousedragging to modify value.
AutoPositionLinearGauge (inherited from CircularGauge) | Gets and sets the automatic positioning of the embedded LinearGauge.
AutoPositionNumericGauge (inherited from CircularGauge) | Gets and sets the automatic positioning of the embedded NumericGauge.
AutoValueLinearGauge (inherited from CircularGauge) | Gets and sets the whether or not the embedded LinearGauge displays the same value as the CircularGauge.
AutoValueNumericGauge (inherited from CircularGauge) | Gets and sets the whether or not the embedded NumericGauge displays the same value as the CircularGauge.
Axis (inherited from CircularGauge) | Gets the CircularGauges's Axis characteristics.
AxisInside | Gets and sets whether not the entire Gauge Axis is displayed outside of the bounding circular area.
Center (inherited from CircularGauge) | Returns a sub-object with properties that control the appearance of a shape at the middle of gauge.
CenterPoint | Returns the Knobgauge centrepoint. Read-only.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorLineEndValues (inherited from CircularGauge) | Gets or sets a collection of EndValues which initially contains the RedLineEndValue and the GreenLineEndValue.
ColorLines (inherited from CircularGauge) | Gets or sets a collection of ColorLines which initially contains the RedLine and the GreenLine.
ColorLineStartValues (inherited from CircularGauge) | Gets or sets a collection of StartValues which initially contains the RedLineStartValue and the GreenLineStartValue.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBounds (inherited from CircularGauge) | Gets or sets a custom bounding rectangle for the gauge.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
DisplayRotationAngle (inherited from CircularGauge) | Gets and sets the angle of Frame rotation.
DisplayTotalAngle (inherited from CircularGauge) | Gets and sets the total display angle of the Frame.
EndPoint (inherited from CircularGauge) | Returns a sub-object with properties that control the appearance of a shape at the end of the gauge arrow.
EndZ (inherited from Series) | For internal use.
FaceBrush (inherited from CircularGauge) | ChartBrush characteristics of the CircularGauge's face.
FillToSemiCircle (inherited from CircularGauge) | Gets or sets whether or not a semi-circular GaugeSeries is filled.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Frame (inherited from CircularGauge) | The Frame is the object which surrounds the CircularGauge and which consists of three configurable Bands: Inner, Middle and Outer.
Function (inherited from Series) | Function object to calculate values.
GaugeColorPalette (inherited from CircularGauge) | Gets and sets the CircularGauge's color palette.
GreenLine (inherited from CircularGauge) | The 'greenline' object is the curved shape with a gradient which is used to signal a low or minimum value.
GreenLineEndValue (inherited from CircularGauge) | Gets and sets the value at which the 'redline' marker ends.
GreenLineStartValue (inherited from CircularGauge) | Gets and sets the value at which the 'redline' marker starts.
Hand (inherited from CircularGauge) | Gets and sets the Hand (or needle) object characteristics.
HandDistance (inherited from CircularGauge) | Gets and sets the distance between the center of the hand and its head as a percentage of the total distance.
HandOffset (inherited from CircularGauge) | Gets and sets the distance between the center of the hand and its tail as a percentage of the total distance.
HighLightBrush | Gets and sets the brush which draws the highlight on the knob.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsInside (inherited from CircularGauge) | Defines where to display gauge axis labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinearGauge (inherited from CircularGauge) | Gets and sets properties of an embedded LinearGauge. Set Visible to true to visualize.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
Maximum (inherited from CircularGauge) | Gets or sets the maximum value for the gauge.
MiddleZ (inherited from Series) | For internal use.
Minimum (inherited from CircularGauge) | Gets or sets the minimum value for the gauge.
MinorTickDistance (inherited from CircularGauge) | The distance between the minor ticks and the CircularGauge curved axis.
MinorTicks (inherited from CircularGauge) | Gets and sets the characteristics of the Axis' minor tick marks.
NumericGauge (inherited from CircularGauge) | Gets and sets properties of an embedded NumericGauge. Set Visible to true to visualize.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedLine (inherited from CircularGauge) | The 'redline' object is the curved shape with a gradient which is used to signal a high or maximum value.
RedLineEndValue (inherited from CircularGauge) | Gets and sets the value at which the 'redline' marker ends.
RedLineStartValue (inherited from CircularGauge) | Gets and sets the value at which the 'redline' marker starts.
RotateLabels (inherited from CircularGauge) | When true, labels are rotated so to appear parallel to the curved CircularGauge axis.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Ticks (inherited from CircularGauge) | Gets and sets the characteristics of the Axis' major tick marks.
Title (inherited from Series) | Series description to show in Legend and editors.
TotalAngle (inherited from CircularGauge) | Controls the size in degrees for the gauge axis.
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
Value (inherited from CircularGauge) | Gets or sets the position of gauge arrow line.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

KnobGauge Class | Steema.TeeChart.Styles Namespace


ActiveCenter

Steema.TeeChart.Styles.KnobGauge.ActiveCenter Property

When true, Knobgauge centre responds to mousedragging to modify value.
public Boolean ActiveCenter {get; set;}

See Also

KnobGauge Class | KnobGauge Members | Steema.TeeChart.Styles Namespace


AxisInside

Steema.TeeChart.Styles.KnobGauge.AxisInside Property

Gets and sets whether not the entire Gauge Axis is displayed outside of the bounding circular area.
public Boolean AxisInside {get; set;}

See Also

KnobGauge Class | KnobGauge Members | Steema.TeeChart.Styles Namespace


CenterPoint

Steema.TeeChart.Styles.KnobGauge.CenterPoint Property

Returns the Knobgauge centrepoint. Read-only.
public Point CenterPoint {get;}

See Also

KnobGauge Class | KnobGauge Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.KnobGauge.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

KnobGauge Class | KnobGauge Members | Steema.TeeChart.Styles Namespace


HighLightBrush

Steema.TeeChart.Styles.KnobGauge.HighLightBrush Property

Gets and sets the brush which draws the highlight on the knob.
public ChartBrush HighLightBrush {get; set;}

See Also

KnobGauge Class | KnobGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LevelPoint

Steema.TeeChart.Styles.LevelPoint ValueType

For a list of all members of this type, see LevelPoint Members

System.Object
System.ValueType
public sealed struct LevelPoint : ValueType

See Also

LevelPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LevelPointMembers

Steema.TeeChart.Styles.LevelPoint all Members

LevelPoint overview

Public Fields

X
Y

See Also

LevelPoint Structure | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LevelPointFields

Steema.TeeChart.Styles.LevelPoint Fields

Public Fields

X
Y

See Also

LevelPoint Structure | Steema.TeeChart.Styles Namespace


X

Steema.TeeChart.Styles.LevelPoint.X Field

public Double X

See Also

LevelPoint Structure | LevelPoint Members | Steema.TeeChart.Styles Namespace


Y

Steema.TeeChart.Styles.LevelPoint.Y Field

public Double Y

See Also

LevelPoint Structure | LevelPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LevelSegment

Steema.TeeChart.Styles.LevelSegment Class

For a list of all members of this type, see LevelSegment Members

System.Object
public class LevelSegment : Object

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

LevelSegment members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LevelSegmentMembers

Steema.TeeChart.Styles.LevelSegment all Members

LevelSegment overview

Constructors

Constructor

Public Fields

Count
Points

See Also

LevelSegment Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LevelSegment Constructor

public LevelSegment()

See Also

LevelSegment Class | LevelSegment Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LevelSegmentFields

Steema.TeeChart.Styles.LevelSegment Fields

Public Fields

Count
Points

See Also

LevelSegment Class | Steema.TeeChart.Styles Namespace


Count

Steema.TeeChart.Styles.LevelSegment.Count Field

public Int32 Count

See Also

LevelSegment Class | LevelSegment Members | Steema.TeeChart.Styles Namespace


Points

Steema.TeeChart.Styles.LevelSegment.Points Field

public LevelPoint[] Points

See Also

LevelSegment Class | LevelSegment Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Line

Steema.TeeChart.Styles.Line Class

Line Series.

For a list of all members of this type, see Line Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
public class Line : Custom , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Line members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LineMembers

Steema.TeeChart.Styles.Line all Members

Line overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Custom) | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Custom) |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Custom) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush (inherited from Custom) | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient | Determines the Line Gradient.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Line Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Line Constructor

Overload List

public Line(Steema.TeeChart.Chart)
public Line()

See Also

Line Class | Line Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Line Constructor

public Line()

See Also

Line Constructor Overload List | Line Class | Line Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Line Constructor

public Line(Chart c)

See Also

Line Constructor Overload List | Line Class | Line Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LineEvents

Steema.TeeChart.Styles.Line Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Line Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LineFields

Steema.TeeChart.Styles.Line Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Line Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LineMethods

Steema.TeeChart.Styles.Line Methods

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Custom) | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Custom) |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Custom) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Line Class | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.Line.SetSubGallery Method

public override Void SetSubGallery(Int32 Index)

See Also

Line Class | Line Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LineProperties

Steema.TeeChart.Styles.Line Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush (inherited from Custom) | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient | Determines the Line Gradient.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Line Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Line.Description Property

public override String Description {get;}

See Also

Line Class | Line Members | Steema.TeeChart.Styles Namespace


Gradient

Steema.TeeChart.Styles.Line.Gradient Property

Determines the Line Gradient.
public Gradient Gradient {get;}

See Also

Line Class | Line Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LinearGauge

Steema.TeeChart.Styles.LinearGauge Class

Linear Gauge Series.

For a list of all members of this type, see LinearGauge Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomGauge
public class LinearGauge : CustomGauge , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

LinearGauge members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LinearGaugeMembers

Steema.TeeChart.Styles.LinearGauge all Members

LinearGauge overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.
ValueChanged (inherited from CustomGauge) | Called when the Gauge Value property is changed.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomGauge) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Axis (inherited from CustomGauge) | Gets the LinearGauges's Axis characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorLineEndValues (inherited from CustomGauge) | Gets or sets a collection of EndValues which initially contains the RedLineEndValue and the GreenLineEndValue.
ColorLines (inherited from CustomGauge) | Gets or sets a collection of ColorLines which initially contains the RedLine and the GreenLine.
ColorLineStartValues (inherited from CustomGauge) | Gets or sets a collection of StartValues which initially contains the RedLineStartValue and the GreenLineStartValue.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBounds (inherited from CustomGauge) | Gets or sets a custom bounding rectangle for the gauge.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FaceBrush (inherited from CustomGauge) | ChartBrush characteristics of the CustomGauge's face.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Frame (inherited from CustomGauge) | The Frame is the object which surrounds the LinearGauge and which consists of three configurable Bands: Inner, Middle and Outer.
Function (inherited from Series) | Function object to calculate values.
GaugeColorPalette (inherited from CustomGauge) | Gets and sets the CircularGauge's color palette.
GreenLine (inherited from CustomGauge) | The 'greenline' object is the curved shape with a gradient which is used to signal a low or minimum value.
GreenLineEndValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker ends.
GreenLineStartValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker starts.
Hand (inherited from CustomGauge) | Gets and sets the Hand (or needle) object characteristics.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Horizontal (inherited from CustomGauge) | Gets and sets whether the LinearGauge should be displayed horizontally or vertically.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
Maximum (inherited from CustomGauge) | Gets or sets the maximum value for the gauge.
MaxValueIndicator | A visible marker for the maximum value reached by the LinearGauge.
MiddleZ (inherited from Series) | For internal use.
Minimum (inherited from CustomGauge) | Gets or sets the minimum value for the gauge.
MinorTickDistance (inherited from CustomGauge) | The minor tick offset.
MinorTicks (inherited from CustomGauge) | Gets and sets the characteristics of the Axis' minor tick marks.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedLine (inherited from CustomGauge) | The 'redline' object is the curved shape with a gradient which is used to signal a high or maximum value.
RedLineEndValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker ends.
RedLineStartValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker starts.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Ticks (inherited from CustomGauge) | Gets and sets the characteristics of the Axis' major tick marks.
Title (inherited from Series) | Series description to show in Legend and editors.
UseValueColorPalette | Set true to use the ValueColorPalette and so define a custom gradient scheme for the LinearGauge hand.
Value (inherited from CustomGauge) | Gets or sets the position of gauge arrow line.
ValueAreaBrush | Brush characteristics of the area behind the value, or hand, pointer.
ValueColorPalette | An array of Colors defining a custom gradient color scheme.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

LinearGauge Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LinearGauge Constructor

Overload List

public LinearGauge()
public LinearGauge(Steema.TeeChart.Chart)

See Also

LinearGauge Class | LinearGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LinearGauge Constructor

public LinearGauge(Chart c)

See Also

LinearGauge Constructor Overload List | LinearGauge Class | LinearGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LinearGauge Constructor

public LinearGauge()

See Also

LinearGauge Constructor Overload List | LinearGauge Class | LinearGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LinearGaugeEvents

Steema.TeeChart.Styles.LinearGauge Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.
ValueChanged (inherited from CustomGauge) | Called when the Gauge Value property is changed.

See Also

LinearGauge Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LinearGaugeFields

Steema.TeeChart.Styles.LinearGauge Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

LinearGauge Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LinearGaugeMethods

Steema.TeeChart.Styles.LinearGauge Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomGauge) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

LinearGauge Class | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.LinearGauge.Draw Method

Overload List

public override Void Draw()

See Also

LinearGauge Class | LinearGauge Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.LinearGauge.Draw Method

public override Void Draw()

See Also

Draw Overload List | LinearGauge Class | LinearGauge Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.LinearGauge.PrepareForGallery Method

public override Void PrepareForGallery(Boolean isEnabled)

See Also

LinearGauge Class | LinearGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LinearGaugeProperties

Steema.TeeChart.Styles.LinearGauge Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Axis (inherited from CustomGauge) | Gets the LinearGauges's Axis characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorLineEndValues (inherited from CustomGauge) | Gets or sets a collection of EndValues which initially contains the RedLineEndValue and the GreenLineEndValue.
ColorLines (inherited from CustomGauge) | Gets or sets a collection of ColorLines which initially contains the RedLine and the GreenLine.
ColorLineStartValues (inherited from CustomGauge) | Gets or sets a collection of StartValues which initially contains the RedLineStartValue and the GreenLineStartValue.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBounds (inherited from CustomGauge) | Gets or sets a custom bounding rectangle for the gauge.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FaceBrush (inherited from CustomGauge) | ChartBrush characteristics of the CustomGauge's face.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Frame (inherited from CustomGauge) | The Frame is the object which surrounds the LinearGauge and which consists of three configurable Bands: Inner, Middle and Outer.
Function (inherited from Series) | Function object to calculate values.
GaugeColorPalette (inherited from CustomGauge) | Gets and sets the CircularGauge's color palette.
GreenLine (inherited from CustomGauge) | The 'greenline' object is the curved shape with a gradient which is used to signal a low or minimum value.
GreenLineEndValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker ends.
GreenLineStartValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker starts.
Hand (inherited from CustomGauge) | Gets and sets the Hand (or needle) object characteristics.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Horizontal (inherited from CustomGauge) | Gets and sets whether the LinearGauge should be displayed horizontally or vertically.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
Maximum (inherited from CustomGauge) | Gets or sets the maximum value for the gauge.
MaxValueIndicator | A visible marker for the maximum value reached by the LinearGauge.
MiddleZ (inherited from Series) | For internal use.
Minimum (inherited from CustomGauge) | Gets or sets the minimum value for the gauge.
MinorTickDistance (inherited from CustomGauge) | The minor tick offset.
MinorTicks (inherited from CustomGauge) | Gets and sets the characteristics of the Axis' minor tick marks.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedLine (inherited from CustomGauge) | The 'redline' object is the curved shape with a gradient which is used to signal a high or maximum value.
RedLineEndValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker ends.
RedLineStartValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker starts.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Ticks (inherited from CustomGauge) | Gets and sets the characteristics of the Axis' major tick marks.
Title (inherited from Series) | Series description to show in Legend and editors.
UseValueColorPalette | Set true to use the ValueColorPalette and so define a custom gradient scheme for the LinearGauge hand.
Value (inherited from CustomGauge) | Gets or sets the position of gauge arrow line.
ValueAreaBrush | Brush characteristics of the area behind the value, or hand, pointer.
ValueColorPalette | An array of Colors defining a custom gradient color scheme.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

LinearGauge Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.LinearGauge.Description Property

public override String Description {get;}

See Also

LinearGauge Class | LinearGauge Members | Steema.TeeChart.Styles Namespace


MaxValueIndicator

Steema.TeeChart.Styles.LinearGauge.MaxValueIndicator Property

A visible marker for the maximum value reached by the LinearGauge.
public GaugeSeriesPointer MaxValueIndicator {get; set;}

See Also

LinearGauge Class | LinearGauge Members | Steema.TeeChart.Styles Namespace


UseValueColorPalette

Steema.TeeChart.Styles.LinearGauge.UseValueColorPalette Property

Set true to use the ValueColorPalette and so define a custom gradient scheme for the LinearGauge hand.
public Boolean UseValueColorPalette {get; set;}

See Also

LinearGauge Class | LinearGauge Members | Steema.TeeChart.Styles Namespace


ValueAreaBrush

Steema.TeeChart.Styles.LinearGauge.ValueAreaBrush Property

Brush characteristics of the area behind the value, or hand, pointer.
public ChartBrush ValueAreaBrush {get; set;}

See Also

LinearGauge Class | LinearGauge Members | Steema.TeeChart.Styles Namespace


ValueColorPalette

Steema.TeeChart.Styles.LinearGauge.ValueColorPalette Property

An array of Colors defining a custom gradient color scheme.
public Color[] ValueColorPalette {get; set;}

See Also

LinearGauge Class | LinearGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LinePoint

Steema.TeeChart.Styles.LinePoint Class

LinePoint series.

For a list of all members of this type, see LinePoint Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Points
public class LinePoint : Points , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

LinePoint members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LinePointMembers

Steema.TeeChart.Styles.LinePoint all Members

LinePoint overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

LinePoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LinePoint Constructor

Overload List

public LinePoint()
public LinePoint(Steema.TeeChart.Chart)

See Also

LinePoint Class | LinePoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LinePoint Constructor

public LinePoint(Chart c)

See Also

LinePoint Constructor Overload List | LinePoint Class | LinePoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LinePoint Constructor

public LinePoint()

See Also

LinePoint Constructor Overload List | LinePoint Class | LinePoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LinePointEvents

Steema.TeeChart.Styles.LinePoint Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

LinePoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LinePointFields

Steema.TeeChart.Styles.LinePoint Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

LinePoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LinePointMethods

Steema.TeeChart.Styles.LinePoint Methods

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Points) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

LinePoint Class | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.LinePoint.DrawValue Method

Called internally. Draws the "ValueIndex" point of the Series.
public override Void DrawValue(Int32 valueIndex)

See Also

LinePoint Class | LinePoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.LinePointProperties

Steema.TeeChart.Styles.LinePoint Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen (inherited from Points) | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

LinePoint Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.LinePoint.Description Property

public override String Description {get;}

See Also

LinePoint Class | LinePoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Map

Steema.TeeChart.Styles.Map Class

Map series.

For a list of all members of this type, see Map Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
public class Map : Custom3DPalette , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Map members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MapMembers

Steema.TeeChart.Styles.Map all Members

Map overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add | Adds a new shape to the Map Series and returns the index of the Polygon in the Shapes collection.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
AddPolyShape |
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear |
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked | Returns the ValueIndex of the "clicked" point in the Map Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete |
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Custom3DPalette) | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue |
MaxYValue |
MaxZValue (inherited from Custom3D) | Returns Maximum Z Value.
MinXValue |
MinYValue |
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item | Default array property in Map series to make easier to obtain a Map polygon object:
LabelMember |
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shapes | Returns a list of Polygon objects. Each polygon object in the list refers to a "shape" in the Map series.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency | Sets global Map series transparency.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues |
YValues |
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

Map Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Map Constructor

Overload List

public Map()
public Map(Steema.TeeChart.Chart)

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Map Constructor

public Map(Chart c)

See Also

Map Constructor Overload List | Map Class | Map Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Map Constructor

public Map()

See Also

Map Constructor Overload List | Map Class | Map Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MapEvents

Steema.TeeChart.Styles.Map Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Map Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MapFields

Steema.TeeChart.Styles.Map Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Map Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MapMethods

Steema.TeeChart.Styles.Map Methods

Public Methods

Add | Adds a new shape to the Map Series and returns the index of the Polygon in the Shapes collection.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
AddPolyShape |
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear |
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked | Returns the ValueIndex of the "clicked" point in the Map Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete |
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Custom3DPalette) | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue |
MaxYValue |
MaxZValue (inherited from Custom3D) | Returns Maximum Z Value.
MinXValue |
MinYValue |
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Map Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Map.Add Method

Overload List

Adds a new shape to the Map Series and returns the index of the Polygon in the Shapes collection.

public Int32 Add(System.Double[], System.Double[], System.Double, System.String)

Adds a new shape to the Map Series and returns the index of the Polygon in the Shapes collection.

public Int32 Add(System.Int32[], System.Int32[], System.Int32, System.String)

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Map.Add Method

Adds a new shape to the Map Series and returns the index of the Polygon in the Shapes collection.
public Int32 Add(Int32[] X,
     Int32[] Y,
     Int32 Z,
     String Text)

See Also

Add Overload List | Map Class | Map Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Map.Add Method

Adds a new shape to the Map Series and returns the index of the Polygon in the Shapes collection.
public Int32 Add(Double[] X,
     Double[] Y,
     Double Z,
     String Text)

See Also

Add Overload List | Map Class | Map Members | Steema.TeeChart.Styles Namespace


AddPolyShape

Steema.TeeChart.Styles.Map.AddPolyShape Method

public Void AddPolyShape(Point[] points,
     String label,
     Double zval)

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


Clear

Steema.TeeChart.Styles.Map.Clear Method

public override Void Clear()

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Map.Clicked Method

Overload List

Returns the ValueIndex of the "clicked" point in the Map Series.

public override Int32 Clicked(System.Int32, System.Int32)

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Map.Clicked Method

Returns the ValueIndex of the "clicked" point in the Map Series.
public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | Map Class | Map Members | Steema.TeeChart.Styles Namespace


Delete

Steema.TeeChart.Styles.Map.Delete Method

Overload List

public override Void Delete(System.Int32)
public override Void Delete(System.Int32, System.Int32, System.Boolean)

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


Delete

Steema.TeeChart.Styles.Map.Delete Method

public override Void Delete(Int32 index,
     Int32 count,
     Boolean removeGap)

See Also

Delete Overload List | Map Class | Map Members | Steema.TeeChart.Styles Namespace


Delete

Steema.TeeChart.Styles.Map.Delete Method

public override Void Delete(Int32 index)

See Also

Delete Overload List | Map Class | Map Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.Map.Draw Method

public override Void Draw()

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.Map.DrawValue Method

public override Void DrawValue(Int32 index)

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


GalleryChanged3D

Steema.TeeChart.Styles.Map.GalleryChanged3D Method

public override Void GalleryChanged3D(Boolean Is3D)

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.Map.MaxXValue Method

public override Double MaxXValue()

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.Map.MaxYValue Method

public override Double MaxYValue()

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


MinXValue

Steema.TeeChart.Styles.Map.MinXValue Method

public override Double MinXValue()

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.Map.MinYValue Method

public override Double MinYValue()

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.Map.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.Map.SetSubGallery Method

public override Void SetSubGallery(Int32 index)

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MapProperties

Steema.TeeChart.Styles.Map Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item | Default array property in Map series to make easier to obtain a Map polygon object:
LabelMember |
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shapes | Returns a list of Polygon objects. Each polygon object in the list refers to a "shape" in the Map series.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency | Sets global Map series transparency.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues |
YValues |
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

Map Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Map.Description Property

public override String Description {get;}

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.Map.Item Property

Default array property in Map series to make easier to obtain a Map polygon object:
public Polygon Item(Int32 index) {get;}

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


LabelMember

Steema.TeeChart.Styles.Map.LabelMember Property

public String LabelMember {get; set;}

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


Shapes

Steema.TeeChart.Styles.Map.Shapes Property

Returns a list of Polygon objects. Each polygon object in the list refers to a "shape" in the Map series.
public PolygonList Shapes {get; set;}

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


Transparency

Steema.TeeChart.Styles.Map.Transparency Property

Sets global Map series transparency.
public Int32 Transparency {get; set;}

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


XValues

Steema.TeeChart.Styles.Map.XValues Property

public ValueList XValues {get;}

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


YValues

Steema.TeeChart.Styles.Map.YValues Property

public ValueList YValues {get;}

See Also

Map Class | Map Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MarksCallout

Steema.TeeChart.Styles.MarksCallout Class

For a list of all members of this type, see MarksCallout Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.SeriesPointer
Steema.TeeChart.Styles.Callout
public class MarksCallout : Callout

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

MarksCallout members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MarksCalloutMembers

Steema.TeeChart.Styles.MarksCallout all Members

MarksCallout overview

Constructors

Constructor

Public Methods

Clone (inherited from SeriesPointer) |
Draw (inherited from SeriesPointer) | Internal use. Draw Pointer
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Arrow (inherited from Callout) |
ArrowHead (inherited from Callout) |
ArrowHeadDirection (inherited from Callout) |
ArrowHeadSize (inherited from Callout) |
Brush (inherited from SeriesPointer) | Brush used to fill Series Pointers.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from SeriesPointer) | Sets the pointer color.
Dark3D (inherited from SeriesPointer) | Fills pointer sides in 3D mode with darker color.
Distance (inherited from Callout) |
Draw3D (inherited from SeriesPointer) | Draws pointer in 3D mode.
EndZ (inherited from SeriesPointer) |
Gradient (inherited from SeriesPointer) | Configures Gradient filling attributes.
HorizSize (inherited from SeriesPointer) | Horizontal size of pointer in pixels.
InflateMargins (inherited from SeriesPointer) | Expands axes to fit pointers.
Length | Length between datapoint and Mark
MiddleZ (inherited from SeriesPointer) |
Pen (inherited from SeriesPointer) | Pen used to draw a frame around Series Pointers.
Series (inherited from SeriesPointer) |
StartZ (inherited from SeriesPointer) |
Style (inherited from SeriesPointer) | Sets the Pointer style.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency (inherited from SeriesPointer) | Sets Percent of semiglass effect.
VertSize (inherited from SeriesPointer) | Sets Horizontal size of pointer in pixels.
Visible (inherited from SeriesPointer) | Shows or hides the pointer.

See Also

MarksCallout Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MarksCallout Constructor

public MarksCallout(Series s)

See Also

MarksCallout Class | MarksCallout Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MarksCalloutMethods

Steema.TeeChart.Styles.MarksCallout Methods

Public Methods

Clone (inherited from SeriesPointer) |
Draw (inherited from SeriesPointer) | Internal use. Draw Pointer
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

See Also

MarksCallout Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MarksCalloutProperties

Steema.TeeChart.Styles.MarksCallout Properties

Public Properties

Arrow (inherited from Callout) |
ArrowHead (inherited from Callout) |
ArrowHeadDirection (inherited from Callout) |
ArrowHeadSize (inherited from Callout) |
Brush (inherited from SeriesPointer) | Brush used to fill Series Pointers.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from SeriesPointer) | Sets the pointer color.
Dark3D (inherited from SeriesPointer) | Fills pointer sides in 3D mode with darker color.
Distance (inherited from Callout) |
Draw3D (inherited from SeriesPointer) | Draws pointer in 3D mode.
EndZ (inherited from SeriesPointer) |
Gradient (inherited from SeriesPointer) | Configures Gradient filling attributes.
HorizSize (inherited from SeriesPointer) | Horizontal size of pointer in pixels.
InflateMargins (inherited from SeriesPointer) | Expands axes to fit pointers.
Length | Length between datapoint and Mark
MiddleZ (inherited from SeriesPointer) |
Pen (inherited from SeriesPointer) | Pen used to draw a frame around Series Pointers.
Series (inherited from SeriesPointer) |
StartZ (inherited from SeriesPointer) |
Style (inherited from SeriesPointer) | Sets the Pointer style.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency (inherited from SeriesPointer) | Sets Percent of semiglass effect.
VertSize (inherited from SeriesPointer) | Sets Horizontal size of pointer in pixels.
Visible (inherited from SeriesPointer) | Shows or hides the pointer.

See Also

MarksCallout Class | Steema.TeeChart.Styles Namespace


Length

Steema.TeeChart.Styles.MarksCallout.Length Property

Length between datapoint and Mark
public Int32 Length {get; set;}

See Also

MarksCallout Class | MarksCallout Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MarksItem

Steema.TeeChart.Styles.MarksItem Class

For a list of all members of this type, see MarksItem Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
public class MarksItem : TextShape , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

MarksItem members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MarksItemMembers

Steema.TeeChart.Styles.MarksItem all Members

MarksItem overview

Constructors

Constructor Overloaded

Public Fields

ChartMarkColor
Size (inherited from TextShape)

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.

Public Properties

AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

MarksItem Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MarksItem Constructor

Overload List

public MarksItem()
public MarksItem(Steema.TeeChart.Chart)

See Also

MarksItem Class | MarksItem Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MarksItem Constructor

public MarksItem(Chart c)

See Also

MarksItem Constructor Overload List | MarksItem Class | MarksItem Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MarksItem Constructor

public MarksItem()

See Also

MarksItem Constructor Overload List | MarksItem Class | MarksItem Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MarksItemFields

Steema.TeeChart.Styles.MarksItem Fields

Public Fields

ChartMarkColor
Size (inherited from TextShape)

See Also

MarksItem Class | Steema.TeeChart.Styles Namespace


ChartMarkColor

Steema.TeeChart.Styles.MarksItem.ChartMarkColor Field

public Color ChartMarkColor

See Also

MarksItem Class | MarksItem Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MarksItemMethods

Steema.TeeChart.Styles.MarksItem Methods

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.

See Also

MarksItem Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MarksItemProperties

Steema.TeeChart.Styles.MarksItem Properties

Public Properties

AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

MarksItem Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MarksItems

Steema.TeeChart.Styles.MarksItems Class

For a list of all members of this type, see MarksItems Members

System.Object
System.Collections.CollectionBase
public class MarksItems : CollectionBase , IList, ICollection
, IEnumerable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

MarksItems members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MarksItemsMembers

Steema.TeeChart.Styles.MarksItems all Members

MarksItems overview

Constructors

Constructor

Public Methods

Clear

Public Properties

Item

See Also

MarksItems Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MarksItems Constructor

public MarksItems(SeriesMarks s)

See Also

MarksItems Class | MarksItems Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MarksItemsMethods

Steema.TeeChart.Styles.MarksItems Methods

Public Methods

Clear

See Also

MarksItems Class | Steema.TeeChart.Styles Namespace


Clear

Steema.TeeChart.Styles.MarksItems.Clear Method

public Void Clear()

See Also

MarksItems Class | MarksItems Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MarksItemsProperties

Steema.TeeChart.Styles.MarksItems Properties

Public Properties

Item

See Also

MarksItems Class | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.MarksItems.Item Property

public MarksItem Item(Int32 index) {get; set;}

See Also

MarksItems Class | MarksItems Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MarksLocation

Steema.TeeChart.Styles.MarksLocation Enum

Describes the possible values of the MarksLocation property.
[Serializable]
public sealed enum MarksLocation : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Start | Set the alignment at start position of the Marks into the Bar.
Center | Set the alignment at center position of the Marks into the Bar.
End | Set the alignment at end position of the Marks into the Bar.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MarksStyles

Steema.TeeChart.Styles.MarksStyles Enum

Describes the possible values of the Style property.
[Serializable]
public sealed enum MarksStyles : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
Value | Shows the point value.
Percent | Shows the percent the point value represents.
Label | Shows the associated Point Label.
LabelPercent | Shows the point Label and the percent value the point represents.
LabelValue | Shows the point Label and the point value.
Legend | Shows whatever is shown at Chart Legend.
PercentTotal | Shows the percent the point represents together with the "of" word and the sum of all points absolute values.
LabelPercentTotal | Shows the point Label toghether with the resulting "PercentTotal" style.
XValue | Shows the point XValue.
XY | Shows the point XValue and YValue.
SeriesTitle | Show the point Series Title.
PointIndex | Show the point Index.
PercentRelative | Show the point percent relative to first point value.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MultiAreas

Steema.TeeChart.Styles.MultiAreas Enum

Describes the possible values of the MultiArea property.
[Serializable]
public sealed enum MultiAreas : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
None | Areas will be drawn one behind the other.
Stacked | Draws each Area on top of previous one.
Stacked100 | Adjusts each individual point to a common 0..100 axis scale.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MultiBars

Steema.TeeChart.Styles.MultiBars Enum

Describes the possible values of the MultiBar property.
[Serializable]
public sealed enum MultiBars : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
None | Bar series are placed one behind the other.
Side | Bar series points are placed one beside the other.
Stacked | Bar series are placed one on top of the other.
Stacked100 | Bar series are placed one on top of the other against a common axis scale 0..100.
SideAll | Bar series, that is, all series points, are drawn one beside the other.
SelfStack | The points of each bar series are drawn one on top of the other.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.MultiPies

Steema.TeeChart.Styles.MultiPies Enum

Describes the possible values of the MultiPie property of the Pie class.
[Serializable]
public sealed enum MultiPies : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
Automatic | Multiple Pie series are displayed using an automatically calculated chart space portion. (default)
Disabled | Multiple Pie series are displayed using custom manual ChartRect positions, or overlapped.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.NumericGauge

Steema.TeeChart.Styles.NumericGauge Class

Numeric Gauge Series.

For a list of all members of this type, see NumericGauge Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomGauge
public class NumericGauge : CustomGauge , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

NumericGauge members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.NumericGaugeMembers

Steema.TeeChart.Styles.NumericGauge all Members

NumericGauge overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.
ValueChanged (inherited from CustomGauge) | Called when the Gauge Value property is changed.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
LCDPalette |
LEDPalette |
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomGauge) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from CustomGauge) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Axis (inherited from CustomGauge) | Gets the LinearGauges's Axis characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorLineEndValues (inherited from CustomGauge) | Gets or sets a collection of EndValues which initially contains the RedLineEndValue and the GreenLineEndValue.
ColorLines (inherited from CustomGauge) | Gets or sets a collection of ColorLines which initially contains the RedLine and the GreenLine.
ColorLineStartValues (inherited from CustomGauge) | Gets or sets a collection of StartValues which initially contains the RedLineStartValue and the GreenLineStartValue.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBounds (inherited from CustomGauge) | Gets or sets a custom bounding rectangle for the gauge.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
DigitalFontType | The style of digital font.
EndZ (inherited from Series) | For internal use.
FaceBrush (inherited from CustomGauge) | ChartBrush characteristics of the CustomGauge's face.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Frame (inherited from CustomGauge) | The Frame is the object which surrounds the LinearGauge and which consists of three configurable Bands: Inner, Middle and Outer.
Function (inherited from Series) | Function object to calculate values.
GaugeColorPalette (inherited from CustomGauge) | Gets and sets the CircularGauge's color palette.
GreenLine (inherited from CustomGauge) | The 'greenline' object is the curved shape with a gradient which is used to signal a low or minimum value.
GreenLineEndValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker ends.
GreenLineStartValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker starts.
Hand (inherited from CustomGauge) | Gets and sets the Hand (or needle) object characteristics.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Horizontal (inherited from CustomGauge) | Gets and sets whether the LinearGauge should be displayed horizontally or vertically.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Markers | The collection of Numeric gauge markers for displaying text or numbers.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
Maximum (inherited from CustomGauge) | Gets or sets the maximum value for the gauge.
MiddleZ (inherited from Series) | For internal use.
Minimum (inherited from CustomGauge) | Gets or sets the minimum value for the gauge.
MinorTickDistance (inherited from CustomGauge) | The minor tick offset.
MinorTicks (inherited from CustomGauge) | Gets and sets the characteristics of the Axis' minor tick marks.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedLine (inherited from CustomGauge) | The 'redline' object is the curved shape with a gradient which is used to signal a high or maximum value.
RedLineEndValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker ends.
RedLineStartValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker starts.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TextMarker | Gets and sets the Marker object which defines the "Text", e.g. FREQ, of the NumericGauge. This allows access to Font, Brush and Pen characteristics of the shape.
Ticks (inherited from CustomGauge) | Gets and sets the characteristics of the Axis' major tick marks.
Title (inherited from Series) | Series description to show in Legend and editors.
UnitsMarker | Gets and sets the Marker object which defines the "Units", e.g. MHz, of the NumericGauge. This allows access to Font, Brush and Pen characteristics of the shape.
Value (inherited from CustomGauge) | Gets or sets the position of gauge arrow line.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValueMarker | Gets and sets the Marker object which defines the "Value" of the NumericGauge. This allows access to Font, Brush and Pen characteristics of the shape.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

NumericGauge Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.NumericGauge Constructor

Overload List

public NumericGauge()
public NumericGauge(Steema.TeeChart.Chart)

See Also

NumericGauge Class | NumericGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.NumericGauge Constructor

public NumericGauge(Chart c)

See Also

NumericGauge Constructor Overload List | NumericGauge Class | NumericGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.NumericGauge Constructor

public NumericGauge()

See Also

NumericGauge Constructor Overload List | NumericGauge Class | NumericGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.NumericGaugeEvents

Steema.TeeChart.Styles.NumericGauge Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.
ValueChanged (inherited from CustomGauge) | Called when the Gauge Value property is changed.

See Also

NumericGauge Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.NumericGaugeFields

Steema.TeeChart.Styles.NumericGauge Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
LCDPalette |
LEDPalette |
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

NumericGauge Class | Steema.TeeChart.Styles Namespace


LCDPalette

Steema.TeeChart.Styles.NumericGauge.LCDPalette Field

public Color[] LCDPalette

See Also

NumericGauge Class | NumericGauge Members | Steema.TeeChart.Styles Namespace


LEDPalette

Steema.TeeChart.Styles.NumericGauge.LEDPalette Field

public Color[] LEDPalette

See Also

NumericGauge Class | NumericGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.NumericGaugeMethods

Steema.TeeChart.Styles.NumericGauge Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomGauge) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from CustomGauge) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

NumericGauge Class | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.NumericGauge.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

NumericGauge Class | NumericGauge Members | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.NumericGauge.SetSubGallery Method

public override Void SetSubGallery(Int32 index)

See Also

NumericGauge Class | NumericGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.NumericGaugeProperties

Steema.TeeChart.Styles.NumericGauge Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Axis (inherited from CustomGauge) | Gets the LinearGauges's Axis characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorLineEndValues (inherited from CustomGauge) | Gets or sets a collection of EndValues which initially contains the RedLineEndValue and the GreenLineEndValue.
ColorLines (inherited from CustomGauge) | Gets or sets a collection of ColorLines which initially contains the RedLine and the GreenLine.
ColorLineStartValues (inherited from CustomGauge) | Gets or sets a collection of StartValues which initially contains the RedLineStartValue and the GreenLineStartValue.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBounds (inherited from CustomGauge) | Gets or sets a custom bounding rectangle for the gauge.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
DigitalFontType | The style of digital font.
EndZ (inherited from Series) | For internal use.
FaceBrush (inherited from CustomGauge) | ChartBrush characteristics of the CustomGauge's face.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Frame (inherited from CustomGauge) | The Frame is the object which surrounds the LinearGauge and which consists of three configurable Bands: Inner, Middle and Outer.
Function (inherited from Series) | Function object to calculate values.
GaugeColorPalette (inherited from CustomGauge) | Gets and sets the CircularGauge's color palette.
GreenLine (inherited from CustomGauge) | The 'greenline' object is the curved shape with a gradient which is used to signal a low or minimum value.
GreenLineEndValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker ends.
GreenLineStartValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker starts.
Hand (inherited from CustomGauge) | Gets and sets the Hand (or needle) object characteristics.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Horizontal (inherited from CustomGauge) | Gets and sets whether the LinearGauge should be displayed horizontally or vertically.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Markers | The collection of Numeric gauge markers for displaying text or numbers.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
Maximum (inherited from CustomGauge) | Gets or sets the maximum value for the gauge.
MiddleZ (inherited from Series) | For internal use.
Minimum (inherited from CustomGauge) | Gets or sets the minimum value for the gauge.
MinorTickDistance (inherited from CustomGauge) | The minor tick offset.
MinorTicks (inherited from CustomGauge) | Gets and sets the characteristics of the Axis' minor tick marks.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedLine (inherited from CustomGauge) | The 'redline' object is the curved shape with a gradient which is used to signal a high or maximum value.
RedLineEndValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker ends.
RedLineStartValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker starts.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TextMarker | Gets and sets the Marker object which defines the "Text", e.g. FREQ, of the NumericGauge. This allows access to Font, Brush and Pen characteristics of the shape.
Ticks (inherited from CustomGauge) | Gets and sets the characteristics of the Axis' major tick marks.
Title (inherited from Series) | Series description to show in Legend and editors.
UnitsMarker | Gets and sets the Marker object which defines the "Units", e.g. MHz, of the NumericGauge. This allows access to Font, Brush and Pen characteristics of the shape.
Value (inherited from CustomGauge) | Gets or sets the position of gauge arrow line.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValueMarker | Gets and sets the Marker object which defines the "Value" of the NumericGauge. This allows access to Font, Brush and Pen characteristics of the shape.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

NumericGauge Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.NumericGauge.Description Property

public override String Description {get;}

See Also

NumericGauge Class | NumericGauge Members | Steema.TeeChart.Styles Namespace


DigitalFontType

Steema.TeeChart.Styles.NumericGauge.DigitalFontType Property

The style of digital font.
public DigitalFont DigitalFontType {get; set;}

See Also

NumericGauge Class | NumericGauge Members | Steema.TeeChart.Styles Namespace


Markers

Steema.TeeChart.Styles.NumericGauge.Markers Property

The collection of Numeric gauge markers for displaying text or numbers.
public MarkersCollection Markers {get; set;}

See Also

NumericGauge Class | NumericGauge Members | Steema.TeeChart.Styles Namespace


TextMarker

Steema.TeeChart.Styles.NumericGauge.TextMarker Property

Gets and sets the Marker object which defines the "Text", e.g. FREQ, of the NumericGauge. This allows access to Font, Brush and Pen characteristics of the shape.
public Marker TextMarker {get; set;}

See Also

NumericGauge Class | NumericGauge Members | Steema.TeeChart.Styles Namespace


UnitsMarker

Steema.TeeChart.Styles.NumericGauge.UnitsMarker Property

Gets and sets the Marker object which defines the "Units", e.g. MHz, of the NumericGauge. This allows access to Font, Brush and Pen characteristics of the shape.
public Marker UnitsMarker {get; set;}

See Also

NumericGauge Class | NumericGauge Members | Steema.TeeChart.Styles Namespace


ValueMarker

Steema.TeeChart.Styles.NumericGauge.ValueMarker Property

Gets and sets the Marker object which defines the "Value" of the NumericGauge. This allows access to Font, Brush and Pen characteristics of the shape.
public Marker ValueMarker {get; set;}

See Also

NumericGauge Class | NumericGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OHLC

Steema.TeeChart.Styles.OHLC Class

OHLC is an base Series class that maintains lists for Open, Close, High and Low values.

For a list of all members of this type, see OHLC Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
public class OHLC : Custom , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

OHLC members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OHLCMembers

Steema.TeeChart.Styles.OHLC all Members

OHLC overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add | Adds new point with specified integer index and double open, high, low and close.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Custom) | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Custom) |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Custom) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush (inherited from Custom) | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
CloseValues | Gets and sets all Stock market Close values.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DateValues | Gets and sets all Stock market Date values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HighValues | Gets and sets all Stock market High values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
LowValues | Gets and sets all Stock market Low values.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OpenValues | Gets and sets all Stock market Open values.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

OHLC Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OHLC Constructor

Overload List

public OHLC(Steema.TeeChart.Chart)
public OHLC()

See Also

OHLC Class | OHLC Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OHLC Constructor

public OHLC()

See Also

OHLC Constructor Overload List | OHLC Class | OHLC Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OHLC Constructor

public OHLC(Chart c)

See Also

OHLC Constructor Overload List | OHLC Class | OHLC Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OHLCEvents

Steema.TeeChart.Styles.OHLC Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

OHLC Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OHLCFields

Steema.TeeChart.Styles.OHLC Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

OHLC Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OHLCMethods

Steema.TeeChart.Styles.OHLC Methods

Public Methods

Add | Adds new point with specified integer index and double open, high, low and close.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Custom) | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Custom) |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Custom) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

OHLC Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.OHLC.Add Method

Overload List

Adds new point with specified integer index and double open, high, low and close.

public Int32 Add(System.Int32, System.Double, System.Double, System.Double, System.Double)

Adds new point with specified double index and double open, high, low and close.

public override Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Double)

Adds new point with specified double open, high, low and close.

public Int32 Add(System.Double, System.Double, System.Double, System.Double)

Adds new point with specified DateTime x and double open, high, low and close.

public Int32 Add(System.DateTime, System.Double, System.Double, System.Double, System.Double)

See Also

OHLC Class | OHLC Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.OHLC.Add Method

Adds new point with specified DateTime x and double open, high, low and close.
public Int32 Add(DateTime aDate,
     Double open,
     Double high,
     Double low,
     Double close)

Return Value

ValueList index of added point

See Also

Add Overload List | OHLC Class | OHLC Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.OHLC.Add Method

Adds new point with specified double open, high, low and close.
public Int32 Add(Double open,
     Double high,
     Double low,
     Double close)

Return Value

ValueList index of added point

See Also

Add Overload List | OHLC Class | OHLC Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.OHLC.Add Method

Adds new point with specified double index and double open, high, low and close.
public override Int32 Add(Double index,
     Double open,
     Double high,
     Double low,
     Double close)

Return Value

ValueList index of added point

See Also

Add Overload List | OHLC Class | OHLC Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.OHLC.Add Method

Adds new point with specified integer index and double open, high, low and close.
public Int32 Add(Int32 index,
     Double open,
     Double high,
     Double low,
     Double close)

Return Value

ValueList index of added point

See Also

Add Overload List | OHLC Class | OHLC Members | Steema.TeeChart.Styles Namespace


IsValidSourceOf

Steema.TeeChart.Styles.OHLC.IsValidSourceOf Method

Validates Series datasource.
public override Boolean IsValidSourceOf(Series value)

Parameters

value
The series to validate.

Return Value

True if value can be a Series data source.

See Also

OHLC Class | OHLC Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.OHLC.MaxYValue Method

Returns the Maximum Value of the Series Y Values List.
public override Double MaxYValue()

See Also

OHLC Class | OHLC Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.OHLC.MinYValue Method

Returns the Minimum Value of the Series Y Values List.
public override Double MinYValue()

See Also

OHLC Class | OHLC Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OHLCProperties

Steema.TeeChart.Styles.OHLC Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush (inherited from Custom) | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
CloseValues | Gets and sets all Stock market Close values.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DateValues | Gets and sets all Stock market Date values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HighValues | Gets and sets all Stock market High values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
LowValues | Gets and sets all Stock market Low values.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OpenValues | Gets and sets all Stock market Open values.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

OHLC Class | Steema.TeeChart.Styles Namespace


CloseValues

Steema.TeeChart.Styles.OHLC.CloseValues Property

Gets and sets all Stock market Close values.
public ValueList CloseValues {get; set;}

See Also

OHLC Class | OHLC Members | Steema.TeeChart.Styles Namespace


DateValues

Steema.TeeChart.Styles.OHLC.DateValues Property

Gets and sets all Stock market Date values.
public ValueList DateValues {get; set;}

See Also

OHLC Class | OHLC Members | Steema.TeeChart.Styles Namespace


HighValues

Steema.TeeChart.Styles.OHLC.HighValues Property

Gets and sets all Stock market High values.
public ValueList HighValues {get; set;}

See Also

OHLC Class | OHLC Members | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.OHLC.Item Property

Point characteristics
public SeriesOHLCPoint Item(Int32 index) {get;}

See Also

OHLC Class | OHLC Members | Steema.TeeChart.Styles Namespace


LowValues

Steema.TeeChart.Styles.OHLC.LowValues Property

Gets and sets all Stock market Low values.
public ValueList LowValues {get; set;}

See Also

OHLC Class | OHLC Members | Steema.TeeChart.Styles Namespace


OpenValues

Steema.TeeChart.Styles.OHLC.OpenValues Property

Gets and sets all Stock market Open values.
public ValueList OpenValues {get; set;}

See Also

OHLC Class | OHLC Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgItem

Steema.TeeChart.Styles.OrgItem Class

For a list of all members of this type, see OrgItem Members

System.Object
public class OrgItem : Object

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

OrgItem members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgItemMembers

Steema.TeeChart.Styles.OrgItem all Members

OrgItem overview

Constructors

Constructor

Public Methods

AddBrother
AddChild
Level
Parent

Public Properties

Format
Index
Series
Superior
Text

See Also

OrgItem Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgItem Constructor

public OrgItem(OrgItems Collection)

See Also

OrgItem Class | OrgItem Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgItemMethods

Steema.TeeChart.Styles.OrgItem Methods

Public Methods

AddBrother
AddChild
Level
Parent

See Also

OrgItem Class | Steema.TeeChart.Styles Namespace


AddBrother

Steema.TeeChart.Styles.OrgItem.AddBrother Method

public OrgItem AddBrother(String Text)

See Also

OrgItem Class | OrgItem Members | Steema.TeeChart.Styles Namespace


AddChild

Steema.TeeChart.Styles.OrgItem.AddChild Method

public OrgItem AddChild(String Text)

See Also

OrgItem Class | OrgItem Members | Steema.TeeChart.Styles Namespace


Level

Steema.TeeChart.Styles.OrgItem.Level Method

public Int32 Level()

See Also

OrgItem Class | OrgItem Members | Steema.TeeChart.Styles Namespace


Parent

Steema.TeeChart.Styles.OrgItem.Parent Method

public OrgItem Parent()

See Also

OrgItem Class | OrgItem Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgItemProperties

Steema.TeeChart.Styles.OrgItem Properties

Public Properties

Format
Index
Series
Superior
Text

See Also

OrgItem Class | Steema.TeeChart.Styles Namespace


Format

Steema.TeeChart.Styles.OrgItem.Format Property

public OrgShape Format {get; set;}

See Also

OrgItem Class | OrgItem Members | Steema.TeeChart.Styles Namespace


Index

Steema.TeeChart.Styles.OrgItem.Index Property

public Int32 Index {get; set;}

See Also

OrgItem Class | OrgItem Members | Steema.TeeChart.Styles Namespace


Series

Steema.TeeChart.Styles.OrgItem.Series Property

public OrgSeries Series {get;}

See Also

OrgItem Class | OrgItem Members | Steema.TeeChart.Styles Namespace


Superior

Steema.TeeChart.Styles.OrgItem.Superior Property

public Int32 Superior {get; set;}

See Also

OrgItem Class | OrgItem Members | Steema.TeeChart.Styles Namespace


Text

Steema.TeeChart.Styles.OrgItem.Text Property

public String Text {get; set;}

See Also

OrgItem Class | OrgItem Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgItemList

Steema.TeeChart.Styles.OrgItemList Class

OrgItem list

For a list of all members of this type, see OrgItemList Members

System.Object
System.Collections.ArrayList
public class OrgItemList : ArrayList , IList, ICollection, IEnumerable
, ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

OrgItemList members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgItemListMembers

Steema.TeeChart.Styles.OrgItemList all Members

OrgItemList overview

Constructors

Constructor

Public Properties

Item

See Also

OrgItemList Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgItemList Constructor

public OrgItemList()

See Also

OrgItemList Class | OrgItemList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgItemListProperties

Steema.TeeChart.Styles.OrgItemList Properties

Public Properties

Item

See Also

OrgItemList Class | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.OrgItemList.Item Property

public Int32 Item(Int32 index) {get;}

See Also

OrgItemList Class | OrgItemList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgItems

Steema.TeeChart.Styles.OrgItems Class

For a list of all members of this type, see OrgItems Members

System.Object
System.Collections.CollectionBase
public class OrgItems : CollectionBase , IList, ICollection, IEnumerable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

OrgItems members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgItemsMembers

Steema.TeeChart.Styles.OrgItems all Members

OrgItems overview

Constructors

Constructor

Public Methods

Add
AddRange
Assign
IndexOf
LevelOf

Public Properties

Item

See Also

OrgItems Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgItems Constructor

public OrgItems(OrgSeries Series)

See Also

OrgItems Class | OrgItems Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgItemsMethods

Steema.TeeChart.Styles.OrgItems Methods

Public Methods

Add
AddRange
Assign
IndexOf
LevelOf

See Also

OrgItems Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.OrgItems.Add Method

Overload List

public Int32 Add(Steema.TeeChart.Styles.OrgItem)
public OrgItem Add()

See Also

OrgItems Class | OrgItems Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.OrgItems.Add Method

public OrgItem Add()

See Also

Add Overload List | OrgItems Class | OrgItems Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.OrgItems.Add Method

public Int32 Add(OrgItem i)

See Also

Add Overload List | OrgItems Class | OrgItems Members | Steema.TeeChart.Styles Namespace


AddRange

Steema.TeeChart.Styles.OrgItems.AddRange Method

public Void AddRange(ICollection c)

See Also

OrgItems Class | OrgItems Members | Steema.TeeChart.Styles Namespace


Assign

Steema.TeeChart.Styles.OrgItems.Assign Method

public Void Assign(OrgItems value)

See Also

OrgItems Class | OrgItems Members | Steema.TeeChart.Styles Namespace


IndexOf

Steema.TeeChart.Styles.OrgItems.IndexOf Method

public Int32 IndexOf(OrgItem l)

See Also

OrgItems Class | OrgItems Members | Steema.TeeChart.Styles Namespace


LevelOf

Steema.TeeChart.Styles.OrgItems.LevelOf Method

public Int32 LevelOf(OrgItem i)

See Also

OrgItems Class | OrgItems Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgItemsProperties

Steema.TeeChart.Styles.OrgItems Properties

Public Properties

Item

See Also

OrgItems Class | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.OrgItems.Item Property

public OrgItem Item(Int32 index) {get; set;}

See Also

OrgItems Class | OrgItems Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgLineStyle

Steema.TeeChart.Styles.OrgLineStyle Enum

Defines the type of connecting lines between organizational chart items.
[Serializable]
public sealed enum OrgLineStyle : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
lsSquared | Draw connection as vertical and horizontal line.
lsDiagonal | Draw connection as diagonal line.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgSeries

Steema.TeeChart.Styles.OrgSeries Class

Organizational Chart.

For a list of all members of this type, see OrgSeries Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class OrgSeries : Series , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

OrgSeries members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgSeriesMembers

Steema.TeeChart.Styles.OrgSeries all Members

OrgSeries overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos |
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos |
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete |
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstChild |
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf |
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Bounds | Bounding rectangle.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Format | Default format for organizational chart items.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item | Organizational chart item.
Items | Organizational chart items.
ItemSpacing | Vertical and horizontal spacing between organizational chart items.
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineStyle | How the connecting lines are drawn.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen |
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

OrgSeries Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgSeries Constructor

Overload List

public OrgSeries()
public OrgSeries(Steema.TeeChart.Chart)

See Also

OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgSeries Constructor

public OrgSeries(Chart c)

See Also

OrgSeries Constructor Overload List | OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgSeries Constructor

public OrgSeries()

See Also

OrgSeries Constructor Overload List | OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgSeriesEvents

Steema.TeeChart.Styles.OrgSeries Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

OrgSeries Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgSeriesFields

Steema.TeeChart.Styles.OrgSeries Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

OrgSeries Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgSeriesMethods

Steema.TeeChart.Styles.OrgSeries Methods

Public Methods

Add |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos |
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos |
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete |
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstChild |
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf |
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

OrgSeries Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.OrgSeries.Add Method

Overload List

public override Int32 Add(System.String, System.Double)
public override Int32 Add(System.Double, System.Double, System.String)
public override Int32 Add(System.String)

See Also

OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.OrgSeries.Add Method

public override Int32 Add(String aText)

See Also

Add Overload List | OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.OrgSeries.Add Method

public override Int32 Add(Double x,
     Double y,
     String text)

See Also

Add Overload List | OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.OrgSeries.Add Method

public override Int32 Add(String aText,
     Double aSuperior)

See Also

Add Overload List | OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.OrgSeries.AssignFormat Method

Overload List

public override Void AssignFormat(Steema.TeeChart.Styles.Series, Steema.TeeChart.Styles.Series)

See Also

OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.OrgSeries.AssignFormat Method

public override Void AssignFormat(Series source,
     Series target)

See Also

AssignFormat Overload List | OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


CalcXPos

Steema.TeeChart.Styles.OrgSeries.CalcXPos Method

public override Int32 CalcXPos(Int32 index)

See Also

OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


CalcYPos

Steema.TeeChart.Styles.OrgSeries.CalcYPos Method

public override Int32 CalcYPos(Int32 index)

See Also

OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.OrgSeries.Clicked Method

Overload List

public override Int32 Clicked(System.Int32, System.Int32)

See Also

OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.OrgSeries.Clicked Method

public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


Delete

Steema.TeeChart.Styles.OrgSeries.Delete Method

Overload List

public override Void Delete(System.Int32)

See Also

OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


Delete

Steema.TeeChart.Styles.OrgSeries.Delete Method

public override Void Delete(Int32 index)

See Also

Delete Overload List | OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.OrgSeries.Draw Method

public override Void Draw()

See Also

OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


FirstChild

Steema.TeeChart.Styles.OrgSeries.FirstChild Method

public Int32 FirstChild(Int32 valueindex)

See Also

OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


IsValidSourceOf

Steema.TeeChart.Styles.OrgSeries.IsValidSourceOf Method

public override Boolean IsValidSourceOf(Series value)

See Also

OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgSeriesProperties

Steema.TeeChart.Styles.OrgSeries Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Bounds | Bounding rectangle.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Format | Default format for organizational chart items.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item | Organizational chart item.
Items | Organizational chart items.
ItemSpacing | Vertical and horizontal spacing between organizational chart items.
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineStyle | How the connecting lines are drawn.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen |
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

OrgSeries Class | Steema.TeeChart.Styles Namespace


Bounds

Steema.TeeChart.Styles.OrgSeries.Bounds Property

Bounding rectangle.
public Rectangle Bounds {get;}

Remarks

Minimum rectangle enclosing all items.

See Also

OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.OrgSeries.Description Property

public override String Description {get;}

See Also

OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


Format

Steema.TeeChart.Styles.OrgSeries.Format Property

Default format for organizational chart items.
public OrgShape Format {get; set;}

See Also

OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.OrgSeries.Item Property

Organizational chart item.
public OrgItem Item(Int32 index) {get; set;}

Parameters

index
Index of item in Items collection.

Return Value

Organizational chart item.

See Also

OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


Items

Steema.TeeChart.Styles.OrgSeries.Items Property

Organizational chart items.
public OrgItems Items {get; set;}

See Also

OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


ItemSpacing

Steema.TeeChart.Styles.OrgSeries.ItemSpacing Property

Vertical and horizontal spacing between organizational chart items.
public Spacing ItemSpacing {get; set;}

See Also

OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


LineStyle

Steema.TeeChart.Styles.OrgSeries.LineStyle Property

How the connecting lines are drawn.
public OrgLineStyle LineStyle {get; set;}

See Also

OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


Pen

Steema.TeeChart.Styles.OrgSeries.Pen Property

public ChartPen Pen {get;}

See Also

OrgSeries Class | OrgSeries Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgSeries.OrgDraw

Steema.TeeChart.Styles.OrgSeries.OrgDraw Class

All item drawing is done in this class

For a list of all members of this type, see OrgDraw Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class OrgDraw : TeeBase

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

OrgDraw members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgSeries.OrgDrawMembers

Steema.TeeChart.Styles.OrgSeries.OrgDraw all Members

OrgDraw overview

Constructors

Steema.TeeChart.Styles.OrgSeries.OrgDraw..ctor

Public Methods

AutoSizeNodes |
Draw |
GetChilds |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Bounds |
Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

OrgDraw Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgSeries+OrgDraw Constructor

public OrgSeries+OrgDraw(OrgSeries s)

See Also

OrgDraw Class | OrgDraw Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgSeries.OrgDrawMethods

Steema.TeeChart.Styles.OrgSeries.OrgDraw Methods

Public Methods

AutoSizeNodes |
Draw |
GetChilds |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

See Also

OrgDraw Class | Steema.TeeChart.Styles Namespace


AutoSizeNodes

Steema.TeeChart.Styles.OrgSeries+OrgDraw.AutoSizeNodes Method

public Void AutoSizeNodes()

See Also

OrgDraw Class | OrgDraw Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.OrgSeries+OrgDraw.Draw Method

public Void Draw()

See Also

OrgDraw Class | OrgDraw Members | Steema.TeeChart.Styles Namespace


GetChilds

Steema.TeeChart.Styles.OrgSeries+OrgDraw.GetChilds Method

public Void GetChilds(OrgItemList l,
     Int32 superior,
     Boolean visibleOnly)

See Also

OrgDraw Class | OrgDraw Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgSeries.OrgDrawProperties

Steema.TeeChart.Styles.OrgSeries.OrgDraw Properties

Public Properties

Bounds |
Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

OrgDraw Class | Steema.TeeChart.Styles Namespace


Bounds

Steema.TeeChart.Styles.OrgSeries+OrgDraw.Bounds Property

public Rectangle Bounds {get;}

See Also

OrgDraw Class | OrgDraw Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgShape

Steema.TeeChart.Styles.OrgShape Class

Base shape class for oragnizational chart item.

For a list of all members of this type, see OrgShape Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
Steema.TeeChart.Drawing.TextShapePosition
public class OrgShape : TextShapePosition , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

OrgShape members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgShapeMembers

Steema.TeeChart.Styles.OrgShape all Members

OrgShape overview

Constructors

Constructor Overloaded

Public Fields

Size (inherited from TextShape)

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.

Public Properties

AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
CustomPosition (inherited from TextShapePosition) | Set to true to permit custom positioning of TextShape.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

OrgShape Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgShape Constructor

Overload List

public OrgShape()
public OrgShape(Steema.TeeChart.Chart)

See Also

OrgShape Class | OrgShape Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgShape Constructor

public OrgShape(Chart c)

See Also

OrgShape Constructor Overload List | OrgShape Class | OrgShape Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgShape Constructor

public OrgShape()

See Also

OrgShape Constructor Overload List | OrgShape Class | OrgShape Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgShapeFields

Steema.TeeChart.Styles.OrgShape Fields

Public Fields

Size (inherited from TextShape)

See Also

OrgShape Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgShapeMethods

Steema.TeeChart.Styles.OrgShape Methods

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.

See Also

OrgShape Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.OrgShapeProperties

Steema.TeeChart.Styles.OrgShape Properties

Public Properties

AutoSize (inherited from TextShape) |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
CustomPosition (inherited from TextShapePosition) | Set to true to permit custom positioning of TextShape.
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines (inherited from TextShape) | Access to array of Text lines
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

OrgShape Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PaletteStyles

Steema.TeeChart.Styles.PaletteStyles Enum

Describes the possible values of the PaletteStyle property.
[Serializable]
public sealed enum PaletteStyles : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Pale | Defines a pale palette.
Strong | Defines a strong palette.
GrayScale | Defines a grayscale palette.
InvertedGray | Defines an inverted grayscale palette.
Rainbow | Defines a rainbow palette.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie

Steema.TeeChart.Styles.Pie Class

Pie Series.

For a list of all members of this type, see Pie Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
public class Pie : Circular , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Pie members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PieMembers

Steema.TeeChart.Styles.Pie all Members

Pie overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

Angles |
bBrush (inherited from Series) |
BelongsToOther |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
BelongsToOtherSlice | Returns true if indexed Slice belongs to the Otherslice
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AngleSize | Total angle in degrees (0 to 360) for all slices.
AutoMarkPosition | If true, marks will be displayed trying to not overlap one to each other.
BevelPercent | Gets and sets the bevel as a percentage of the pie's depth.
Brush | Brush fill for PieSeries.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
Color (inherited from Series) | Default color for all points.
ColorEach | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
Dark3D | Darkens side of 3D pie section to add depth.
DarkPen |
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EdgeStyle | Gets and sets the EdgeStyle of the bevel.
EndZ (inherited from Series) | For internal use.
ExplodeBiggest | Displaces the biggest slice from centre by value set.
ExplodedSlice | Accesses the properties for exploding any Pie slice.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksPie |
MiddleZ (inherited from Series) | For internal use.
MultiPie | Sets automatic Pie positioning when multiple Pie series exist.
NumGallerySeries (inherited from Series) | For internal use.
OtherSlice | Accesses the OtherSlice properties.
Pen | Line pen for Pie.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
PieValues | Stores the Pie slice values.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow | Defines the offset shadow of the PieSeries.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SliceHeight | Use SliceHeight array property to specify a different height for each pie slice.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency | Sets Transparency level from 0 to 100%.
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
UsePatterns | Fills Pie Sectors with different Brush pattern styles.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Pie Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie Constructor

Overload List

public Pie()
public Pie(Steema.TeeChart.Chart)

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie Constructor

public Pie(Chart c)

See Also

Pie Constructor Overload List | Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie Constructor

public Pie()

See Also

Pie Constructor Overload List | Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PieEvents

Steema.TeeChart.Styles.Pie Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Pie Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PieFields

Steema.TeeChart.Styles.Pie Fields

Public Fields

Angles |
bBrush (inherited from Series) |
BelongsToOther |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Pie Class | Steema.TeeChart.Styles Namespace


Angles

Steema.TeeChart.Styles.Pie.Angles Field

public PieAngle[] Angles

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


BelongsToOther

Steema.TeeChart.Styles.Pie.BelongsToOther Field

public const Int32 BelongsToOther

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PieMethods

Steema.TeeChart.Styles.Pie Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
BelongsToOtherSlice | Returns true if indexed Slice belongs to the Otherslice
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Pie Class | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.Pie.AssignFormat Method

Overload List

public override Void AssignFormat(Steema.TeeChart.Styles.Series, Steema.TeeChart.Styles.Series)

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.Pie.AssignFormat Method

public override Void AssignFormat(Series source,
     Series target)

See Also

AssignFormat Overload List | Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


BelongsToOtherSlice

Steema.TeeChart.Styles.Pie.BelongsToOtherSlice Method

Returns true if indexed Slice belongs to the Otherslice
public Boolean BelongsToOtherSlice(Int32 valueIndex)

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


CalcXPos

Steema.TeeChart.Styles.Pie.CalcXPos Method

Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
public override Int32 CalcXPos(Int32 valueIndex)

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Pie.Clicked Method

Overload List

public override Int32 Clicked(System.Int32, System.Int32)

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Pie.Clicked Method

public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.Pie.Draw Method

public override Void Draw()

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


DrawMarksSeries

Steema.TeeChart.Styles.Pie.DrawMarksSeries Method

public override Void DrawMarksSeries(Series s,
     Boolean& ActiveRegion)

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.Pie.DrawValue Method

Called internally. Draws the "ValueIndex" point of the Series.
public override Void DrawValue(Int32 valueIndex)

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


GalleryChanged3D

Steema.TeeChart.Styles.Pie.GalleryChanged3D Method

public override Void GalleryChanged3D(Boolean is3D)

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.Pie.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.Pie.SetSubGallery Method

public override Void SetSubGallery(Int32 index)

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PieProperties

Steema.TeeChart.Styles.Pie Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AngleSize | Total angle in degrees (0 to 360) for all slices.
AutoMarkPosition | If true, marks will be displayed trying to not overlap one to each other.
BevelPercent | Gets and sets the bevel as a percentage of the pie's depth.
Brush | Brush fill for PieSeries.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
Color (inherited from Series) | Default color for all points.
ColorEach | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
Dark3D | Darkens side of 3D pie section to add depth.
DarkPen |
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EdgeStyle | Gets and sets the EdgeStyle of the bevel.
EndZ (inherited from Series) | For internal use.
ExplodeBiggest | Displaces the biggest slice from centre by value set.
ExplodedSlice | Accesses the properties for exploding any Pie slice.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksPie |
MiddleZ (inherited from Series) | For internal use.
MultiPie | Sets automatic Pie positioning when multiple Pie series exist.
NumGallerySeries (inherited from Series) | For internal use.
OtherSlice | Accesses the OtherSlice properties.
Pen | Line pen for Pie.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
PieValues | Stores the Pie slice values.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow | Defines the offset shadow of the PieSeries.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SliceHeight | Use SliceHeight array property to specify a different height for each pie slice.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency | Sets Transparency level from 0 to 100%.
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
UsePatterns | Fills Pie Sectors with different Brush pattern styles.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Pie Class | Steema.TeeChart.Styles Namespace


AngleSize

Steema.TeeChart.Styles.Pie.AngleSize Property

Total angle in degrees (0 to 360) for all slices.
public Int32 AngleSize {get; set;}

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


AutoMarkPosition

Steema.TeeChart.Styles.Pie.AutoMarkPosition Property

If true, marks will be displayed trying to not overlap one to each other.
public Boolean AutoMarkPosition {get; set;}

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


BevelPercent

Steema.TeeChart.Styles.Pie.BevelPercent Property

Gets and sets the bevel as a percentage of the pie's depth.
public Int32 BevelPercent {get; set;}

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


Brush

Steema.TeeChart.Styles.Pie.Brush Property

Brush fill for PieSeries.
public ChartBrush Brush {get;}

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


ColorEach

Steema.TeeChart.Styles.Pie.ColorEach Property

Draws points with different preset Colors.
public Boolean ColorEach {get; set;}

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


Dark3D

Steema.TeeChart.Styles.Pie.Dark3D Property

Darkens side of 3D pie section to add depth.
public Boolean Dark3D {get; set;}

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


DarkPen

Steema.TeeChart.Styles.Pie.DarkPen Property

public Boolean DarkPen {get; set;}

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Pie.Description Property

public override String Description {get;}

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


EdgeStyle

Steema.TeeChart.Styles.Pie.EdgeStyle Property

Gets and sets the EdgeStyle of the bevel.
public EdgeStyles EdgeStyle {get; set;}

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


ExplodeBiggest

Steema.TeeChart.Styles.Pie.ExplodeBiggest Property

Displaces the biggest slice from centre by value set.
public Int32 ExplodeBiggest {get; set;}

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


ExplodedSlice

Steema.TeeChart.Styles.Pie.ExplodedSlice Property

Accesses the properties for exploding any Pie slice.
public ExplodedSliceList ExplodedSlice {get; set;}

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


MarksPie

Steema.TeeChart.Styles.Pie.MarksPie Property

public PieMarks MarksPie {get; set;}

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


MultiPie

Steema.TeeChart.Styles.Pie.MultiPie Property

Sets automatic Pie positioning when multiple Pie series exist.
public MultiPies MultiPie {get; set;}

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


OtherSlice

Steema.TeeChart.Styles.Pie.OtherSlice Property

Accesses the OtherSlice properties.
public PieOtherSlice OtherSlice {get; set;}

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


Pen

Steema.TeeChart.Styles.Pie.Pen Property

Line pen for Pie.
public ChartPen Pen {get;}

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


PieValues

Steema.TeeChart.Styles.Pie.PieValues Property

Stores the Pie slice values.
public ValueList PieValues {get;}

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


Shadow

Steema.TeeChart.Styles.Pie.Shadow Property

Defines the offset shadow of the PieSeries.
public PieShadow Shadow {get;}

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


SliceHeight

Steema.TeeChart.Styles.Pie.SliceHeight Property

Use SliceHeight array property to specify a different height for each pie slice.
public SliceValueList SliceHeight {get;}

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


Transparency

Steema.TeeChart.Styles.Pie.Transparency Property

Sets Transparency level from 0 to 100%.
public Int32 Transparency {get; set;}

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


UsePatterns

Steema.TeeChart.Styles.Pie.UsePatterns Property

Fills Pie Sectors with different Brush pattern styles.
public Boolean UsePatterns {get; set;}

See Also

Pie Class | Pie Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.ExplodedSliceList

Steema.TeeChart.Styles.Pie.ExplodedSliceList Class

List to hold percents of exploding effect, one per each Pie slice.

For a list of all members of this type, see ExplodedSliceList Members

System.Object
System.Collections.ArrayList
public class ExplodedSliceList : ArrayList , IList, ICollection
, IEnumerable, ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

ExplodedSliceList members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.ExplodedSliceListMembers

Steema.TeeChart.Styles.Pie.ExplodedSliceList all Members

ExplodedSliceList overview

Constructors

Steema.TeeChart.Styles.Pie.ExplodedSliceList..ctor

Public Properties

Item

See Also

ExplodedSliceList Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie+ExplodedSliceList Constructor

public Pie+ExplodedSliceList(Int32 capacity)

See Also

ExplodedSliceList Class | ExplodedSliceList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.ExplodedSliceListProperties

Steema.TeeChart.Styles.Pie.ExplodedSliceList Properties

Public Properties

Item

See Also

ExplodedSliceList Class | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.Pie+ExplodedSliceList.Item Property

public Int32 Item(Int32 index) {get; set;}

See Also

ExplodedSliceList Class | ExplodedSliceList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.PieAngle

Steema.TeeChart.Styles.Pie.PieAngle ValueType

Internal structure used by Pie series to store each pie slice angle.

For a list of all members of this type, see PieAngle Members

System.Object
System.ValueType
public sealed struct PieAngle : ValueType

See Also

PieAngle Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.PieAngleMembers

Steema.TeeChart.Styles.Pie.PieAngle all Members

PieAngle overview

Public Fields

EndAngle
MidAngle
StartAngle

Public Methods

Contains Returns true if angle is within the pie slice.

See Also

PieAngle Structure | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.PieAngleFields

Steema.TeeChart.Styles.Pie.PieAngle Fields

Public Fields

EndAngle
MidAngle
StartAngle

See Also

PieAngle Structure | Steema.TeeChart.Styles Namespace


EndAngle

Steema.TeeChart.Styles.Pie+PieAngle.EndAngle Field

public Double EndAngle

See Also

PieAngle Structure | PieAngle Members | Steema.TeeChart.Styles Namespace


MidAngle

Steema.TeeChart.Styles.Pie+PieAngle.MidAngle Field

public Double MidAngle

See Also

PieAngle Structure | PieAngle Members | Steema.TeeChart.Styles Namespace


StartAngle

Steema.TeeChart.Styles.Pie+PieAngle.StartAngle Field

public Double StartAngle

See Also

PieAngle Structure | PieAngle Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.PieAngleMethods

Steema.TeeChart.Styles.Pie.PieAngle Methods

Public Methods

Contains Returns true if angle is within the pie slice.

See Also

PieAngle Structure | Steema.TeeChart.Styles Namespace


Contains

Steema.TeeChart.Styles.Pie+PieAngle.Contains Method

Returns true if angle is within the pie slice.
public Boolean Contains(Double angle)

See Also

PieAngle Structure | PieAngle Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.PieMarks

Steema.TeeChart.Styles.Pie.PieMarks Class

Customized pie series marks with additional properties.

For a list of all members of this type, see PieMarks Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class PieMarks : TeeBase

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

PieMarks members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.PieMarksMembers

Steema.TeeChart.Styles.Pie.PieMarks all Members

PieMarks overview

Public Methods

Invalidate (inherited from TeeBase) Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
LegSize |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
VertCenter |

Constructors

Steema.TeeChart.Styles.Pie.PieMarks..ctor

See Also

PieMarks Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.PieMarksMethods

Steema.TeeChart.Styles.Pie.PieMarks Methods

Public Methods

Invalidate (inherited from TeeBase) Use Invalidate when the entire canvas needs to be repainted.

See Also

PieMarks Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.PieMarksProperties

Steema.TeeChart.Styles.Pie.PieMarks Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
LegSize |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
VertCenter |

See Also

PieMarks Class | Steema.TeeChart.Styles Namespace


LegSize

Steema.TeeChart.Styles.Pie+PieMarks.LegSize Property

public Int32 LegSize {get; set;}

See Also

PieMarks Class | PieMarks Members | Steema.TeeChart.Styles Namespace


VertCenter

Steema.TeeChart.Styles.Pie+PieMarks.VertCenter Property

public Boolean VertCenter {get; set;}

See Also

PieMarks Class | PieMarks Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie+PieMarks Constructor

public Pie+PieMarks(Chart c,
     Series s)

See Also

PieMarks Class | PieMarks Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.PieOtherSlice

Steema.TeeChart.Styles.Pie.PieOtherSlice Class

Pie series uses this class in its OtherSlice property.

For a list of all members of this type, see PieOtherSlice Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class PieOtherSlice : TeeBase

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

PieOtherSlice members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.PieOtherSliceMembers

Steema.TeeChart.Styles.Pie.PieOtherSlice all Members

PieOtherSlice overview

Public Methods

Invalidate (inherited from TeeBase) Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Color | Sets the Color of the OtherSlice.
Legend | Sets the properties of the PieOtherSlice Legend.
Style | Sets either value or percentage to group the 'other' Pie slice.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text | Title for otherSlice.
Value | Value (value or percentage) for Otherslice grouping.

Constructors

Steema.TeeChart.Styles.Pie.PieOtherSlice..ctor

See Also

PieOtherSlice Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.PieOtherSliceMethods

Steema.TeeChart.Styles.Pie.PieOtherSlice Methods

Public Methods

Invalidate (inherited from TeeBase) Use Invalidate when the entire canvas needs to be repainted.

See Also

PieOtherSlice Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.PieOtherSliceProperties

Steema.TeeChart.Styles.Pie.PieOtherSlice Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Color | Sets the Color of the OtherSlice.
Legend | Sets the properties of the PieOtherSlice Legend.
Style | Sets either value or percentage to group the 'other' Pie slice.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text | Title for otherSlice.
Value | Value (value or percentage) for Otherslice grouping.

See Also

PieOtherSlice Class | Steema.TeeChart.Styles Namespace


Color

Steema.TeeChart.Styles.Pie+PieOtherSlice.Color Property

Sets the Color of the OtherSlice.
public Color Color {get; set;}

See Also

PieOtherSlice Class | PieOtherSlice Members | Steema.TeeChart.Styles Namespace


Legend

Steema.TeeChart.Styles.Pie+PieOtherSlice.Legend Property

Sets the properties of the PieOtherSlice Legend.
public Legend Legend {get; set;}

Example

This sample shows how to use the PieOtherSlice Legend property:

// prepare "Other" to group values below 10
pie1.OtherSlice.Style=Steema.TeeChart.Styles.PieOtherStyles.BelowValue;
pie1.OtherSlice.Value=10;
pie1.OtherSlice.Text = "Other";
pie1.OtherSlice.Legend.Visible = true;
pie1.OtherSlice.Legend.CustomPosition = true;
pie1.OtherSlice.Legend.Left = 350;
pie1.OtherSlice.Legend.Top = 150;

See Also

PieOtherSlice Class | PieOtherSlice Members | Steema.TeeChart.Styles Namespace


Style

Steema.TeeChart.Styles.Pie+PieOtherSlice.Style Property

Sets either value or percentage to group the 'other' Pie slice.
public PieOtherStyles Style {get; set;}

See Also

PieOtherSlice Class | PieOtherSlice Members | Steema.TeeChart.Styles Namespace


Text

Steema.TeeChart.Styles.Pie+PieOtherSlice.Text Property

Title for otherSlice.
public String Text {get; set;}

See Also

PieOtherSlice Class | PieOtherSlice Members | Steema.TeeChart.Styles Namespace


Value

Steema.TeeChart.Styles.Pie+PieOtherSlice.Value Property

Value (value or percentage) for Otherslice grouping.
public Double Value {get; set;}

See Also

PieOtherSlice Class | PieOtherSlice Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie+PieOtherSlice Constructor

public Pie+PieOtherSlice(Chart c,
     Series s)

See Also

PieOtherSlice Class | PieOtherSlice Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.PieShadow

Steema.TeeChart.Styles.Pie.PieShadow Class

Pie series uses this class in its Shadow property.

For a list of all members of this type, see PieShadow Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shadow
public class PieShadow : Shadow , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

PieShadow members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.PieShadowMembers

Steema.TeeChart.Styles.Pie.PieShadow all Members

PieShadow overview

Public Methods

Assign (inherited from Shadow) | Assign characteristics of Shadow 'value'
Clone (inherited from Shadow) |
Draw |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

Public Properties

BlurSize (inherited from Shadow) |
Brush (inherited from Shadow) | Defines the Brush characteristics to fill the shadow.
Chart (inherited from TeeBase) | Chart associated with this object
Clip (inherited from Shadow) |
Color (inherited from Shadow) | Gets or sets Color used to fill.
Height (inherited from Shadow) | Sets the vertical displacement of the shadow in pixels.
HorizSize (inherited from Shadow) |
Size (inherited from Shadow) | Size in pixels of shadow.
Smooth (inherited from Shadow) | Gets and sets if the shadow will be displayed as a rectangle with smooth edges.
SmoothBlur (inherited from Shadow) | Gets and sets if the shadow will be displayed as a rectangle with smooth edges.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency (inherited from Shadow) | Sets Transparency level from 0 to 100% of shadow.
VertSize (inherited from Shadow) |
Visible (inherited from Shadow) | Determines whether the shadow will appear on screen.
Width (inherited from Shadow) | Sets the horizontal shadow size in pixels.

Constructors

Steema.TeeChart.Styles.Pie.PieShadow..ctor

See Also

PieShadow Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.PieShadowMethods

Steema.TeeChart.Styles.Pie.PieShadow Methods

Public Methods

Assign (inherited from Shadow) | Assign characteristics of Shadow 'value'
Clone (inherited from Shadow) |
Draw |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

See Also

PieShadow Class | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.Pie+PieShadow.Draw Method

public override Void Draw(Graphics3D g,
     Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 z)

See Also

PieShadow Class | PieShadow Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.PieShadowProperties

Steema.TeeChart.Styles.Pie.PieShadow Properties

Public Properties

BlurSize (inherited from Shadow) |
Brush (inherited from Shadow) | Defines the Brush characteristics to fill the shadow.
Chart (inherited from TeeBase) | Chart associated with this object
Clip (inherited from Shadow) |
Color (inherited from Shadow) | Gets or sets Color used to fill.
Height (inherited from Shadow) | Sets the vertical displacement of the shadow in pixels.
HorizSize (inherited from Shadow) |
Size (inherited from Shadow) | Size in pixels of shadow.
Smooth (inherited from Shadow) | Gets and sets if the shadow will be displayed as a rectangle with smooth edges.
SmoothBlur (inherited from Shadow) | Gets and sets if the shadow will be displayed as a rectangle with smooth edges.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency (inherited from Shadow) | Sets Transparency level from 0 to 100% of shadow.
VertSize (inherited from Shadow) |
Visible (inherited from Shadow) | Determines whether the shadow will appear on screen.
Width (inherited from Shadow) | Sets the horizontal shadow size in pixels.

See Also

PieShadow Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie+PieShadow Constructor

public Pie+PieShadow(Chart c,
     Pie pie)

See Also

PieShadow Class | PieShadow Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.SliceValueList

Steema.TeeChart.Styles.Pie.SliceValueList Class

For a list of all members of this type, see SliceValueList Members

System.Object
System.Collections.ArrayList
public class SliceValueList : ArrayList , IList, ICollection, IEnumerable
, ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

SliceValueList members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.SliceValueListMembers

Steema.TeeChart.Styles.Pie.SliceValueList all Members

SliceValueList overview

Public Properties

Item

Constructors

Steema.TeeChart.Styles.Pie.SliceValueList..ctor

See Also

SliceValueList Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie.SliceValueListProperties

Steema.TeeChart.Styles.Pie.SliceValueList Properties

Public Properties

Item

See Also

SliceValueList Class | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.Pie+SliceValueList.Item Property

public Int32 Item(Int32 index) {get; set;}

See Also

SliceValueList Class | SliceValueList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pie+SliceValueList Constructor

public Pie+SliceValueList(Pie series)

See Also

SliceValueList Class | SliceValueList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PieOtherStyles

Steema.TeeChart.Styles.PieOtherStyles Enum

Describes the possible values of the Style property of the PieOtherSlice class.
[Serializable]
public sealed enum PieOtherStyles : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
None | No "Other" slice is generated. (default)
BelowPercent | Slices with values below a percentage are grouped.
BelowValue | Slices with values below a value are grouped.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointerStyles

Steema.TeeChart.Styles.PointerStyles Enum

Describes the pointer style of a series pointer.
[Serializable]
public sealed enum PointerStyles : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Rectangle | Defines the pointer as a rectangle.
Circle | Defines the pointer as a circle.
Triangle | Defines the pointer as a triangle.
DownTriangle | Defines the pointer as a down pointing triangle.
Cross | Defines the pointer as a cross.
DiagCross | Defines the pointer as a diagonal cross.
Star | Defines the pointer as a star.
Diamond | Defines the pointer as a diamond.
SmallDot | Defines the pointer as a small dot.
Nothing | Defines the pointer as no shape.
LeftTriangle | Defines the pointer as a left triangle.
RightTriangle | Defines the pointer as a right triangle.
Sphere | Defines the pointer as a graded sphere.
PolishedSphere | Defines the pointer as a polished sphere.
Hexagon | Defines the pointer as hexagon.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointFigure

Steema.TeeChart.Styles.PointFigure Class

PointFigure Series.

For a list of all members of this type, see PointFigure Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
Steema.TeeChart.Styles.OHLC
Steema.TeeChart.Styles.CustomTimeOHLC
public class PointFigure : CustomTimeOHLC , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

PointFigure members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointFigureMembers

Steema.TeeChart.Styles.PointFigure all Members

PointFigure overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValue |
AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
pMethod |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).
variableBoxValues |

Public Methods

Add (inherited from OHLC) | Adds new point with specified integer index and double open, high, low and close.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
addPFPoint |
addYearLabel |
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked |
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Custom) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from OHLC) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString |
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue |
MaxYValue (inherited from OHLC) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue |
MinYValue (inherited from OHLC) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
BoxSize (inherited from CustomTimeOHLC) |
BoxType (inherited from CustomTimeOHLC) | Use BoxType to change box sensitivity according to the data range.
Brush (inherited from Custom) | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
CloseValues (inherited from OHLC) | Gets and sets all Stock market Close values.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DateValues (inherited from OHLC) | Gets and sets all Stock market Date values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
DownSymbol |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HighValues (inherited from OHLC) | Gets and sets all Stock market High values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IncrementAsBox (inherited from CustomTimeOHLC) | When true, Chart will try to size grid to box size.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from OHLC) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
LowValues (inherited from OHLC) | Gets and sets all Stock market Low values.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
MonthFont | Font used to write the Month-Change labels is visible.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OpenValues (inherited from OHLC) | Gets and sets all Stock market Open values.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Period (inherited from CustomTimeOHLC) |
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
PointList |
PricingMethod | Pricing method used when calculating box movement.
ReversalAmount |
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
ShowMonths | When true, shows Month changes in data columns.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
StoreBoxStats | When true, TeeChart will store box stats (location, column, value and UP/Down). When activating this property please note that some effect on performance will take place.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UpSymbol |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

PointFigure Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointFigure Constructor

Overload List

public PointFigure()
public PointFigure(Steema.TeeChart.Chart)

See Also

PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointFigure Constructor

public PointFigure(Chart c)

See Also

PointFigure Constructor Overload List | PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointFigure Constructor

public PointFigure()

See Also

PointFigure Constructor Overload List | PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointFigureEvents

Steema.TeeChart.Styles.PointFigure Events

Public Events

AfterDrawValue |
AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

PointFigure Class | Steema.TeeChart.Styles Namespace


AfterDrawValue

Steema.TeeChart.Styles.PointFigure.AfterDrawValue Event

public PointFigureDrawValueEventHandler  AfterDrawValue

See Also

PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointFigureFields

Steema.TeeChart.Styles.PointFigure Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
pMethod |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).
variableBoxValues |

See Also

PointFigure Class | Steema.TeeChart.Styles Namespace


pMethod

Steema.TeeChart.Styles.PointFigure.pMethod Field

public PricingMethods pMethod

See Also

PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


variableBoxValues

Steema.TeeChart.Styles.PointFigure.variableBoxValues Field

public Double[] variableBoxValues

See Also

PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointFigureMethods

Steema.TeeChart.Styles.PointFigure Methods

Public Methods

Add (inherited from OHLC) | Adds new point with specified integer index and double open, high, low and close.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
addPFPoint |
addYearLabel |
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked |
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Custom) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from OHLC) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString |
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue |
MaxYValue (inherited from OHLC) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue |
MinYValue (inherited from OHLC) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

PointFigure Class | Steema.TeeChart.Styles Namespace


addPFPoint

Steema.TeeChart.Styles.PointFigure.addPFPoint Method

public Void addPFPoint(Int32 column,
     Int32 x,
     Int32 y,
     Double value,
     Boolean isUp)

See Also

PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


addYearLabel

Steema.TeeChart.Styles.PointFigure.addYearLabel Method

public Void addYearLabel(Int32 idx,
     Int32 year)

See Also

PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.PointFigure.Clicked Method

Overload List

public override Int32 Clicked(System.Int32, System.Int32)

See Also

PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.PointFigure.Clicked Method

public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.PointFigure.Draw Method

public override Void Draw()

See Also

PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


LegendString

Steema.TeeChart.Styles.PointFigure.LegendString Method

public override String LegendString(Int32 legendIndex,
     LegendTextStyles legendTextStyle)

See Also

PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.PointFigure.MaxXValue Method

public override Double MaxXValue()

See Also

PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


MinXValue

Steema.TeeChart.Styles.PointFigure.MinXValue Method

public override Double MinXValue()

See Also

PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.PointFigure.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointFigureProperties

Steema.TeeChart.Styles.PointFigure Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
BoxSize (inherited from CustomTimeOHLC) |
BoxType (inherited from CustomTimeOHLC) | Use BoxType to change box sensitivity according to the data range.
Brush (inherited from Custom) | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
CloseValues (inherited from OHLC) | Gets and sets all Stock market Close values.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DateValues (inherited from OHLC) | Gets and sets all Stock market Date values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
DownSymbol |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HighValues (inherited from OHLC) | Gets and sets all Stock market High values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IncrementAsBox (inherited from CustomTimeOHLC) | When true, Chart will try to size grid to box size.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from OHLC) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
LowValues (inherited from OHLC) | Gets and sets all Stock market Low values.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
MonthFont | Font used to write the Month-Change labels is visible.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OpenValues (inherited from OHLC) | Gets and sets all Stock market Open values.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Period (inherited from CustomTimeOHLC) |
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
PointList |
PricingMethod | Pricing method used when calculating box movement.
ReversalAmount |
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
ShowMonths | When true, shows Month changes in data columns.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
StoreBoxStats | When true, TeeChart will store box stats (location, column, value and UP/Down). When activating this property please note that some effect on performance will take place.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UpSymbol |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

PointFigure Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.PointFigure.Description Property

public override String Description {get;}

See Also

PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


DownSymbol

Steema.TeeChart.Styles.PointFigure.DownSymbol Property

public SeriesPointer DownSymbol {get;}

See Also

PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


MonthFont

Steema.TeeChart.Styles.PointFigure.MonthFont Property

Font used to write the Month-Change labels is visible.
public ChartFont MonthFont {get; set;}

See Also

PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace | ShowMonths


PointList

Steema.TeeChart.Styles.PointFigure.PointList Property

public PFPoint[] PointList {get; set;}

See Also

PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


PricingMethod

Steema.TeeChart.Styles.PointFigure.PricingMethod Property

Pricing method used when calculating box movement.
public PricingMethods PricingMethod {get; set;}

See Also

PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


ReversalAmount

Steema.TeeChart.Styles.PointFigure.ReversalAmount Property

public Double ReversalAmount {get; set;}

See Also

PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


ShowMonths

Steema.TeeChart.Styles.PointFigure.ShowMonths Property

When true, shows Month changes in data columns.
public Boolean ShowMonths {get; set;}

See Also

PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


StoreBoxStats

Steema.TeeChart.Styles.PointFigure.StoreBoxStats Property

When true, TeeChart will store box stats (location, column, value and UP/Down). When activating this property please note that some effect on performance will take place.
public Boolean StoreBoxStats {get; set;}

See Also

PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


UpSymbol

Steema.TeeChart.Styles.PointFigure.UpSymbol Property

public SeriesPointer UpSymbol {get;}

See Also

PointFigure Class | PointFigure Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointFigure.PFPoint

Steema.TeeChart.Styles.PointFigure.PFPoint ValueType

For a list of all members of this type, see PFPoint Members

System.Object
System.ValueType
public sealed struct PFPoint : ValueType

See Also

PFPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointFigure.PFPointMembers

Steema.TeeChart.Styles.PointFigure.PFPoint all Members

PFPoint overview

Constructors

Steema.TeeChart.Styles.PointFigure.PFPoint..ctor

Public Fields

Column
IsUp
Value
X
Y

See Also

PFPoint Structure | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointFigure+PFPoint Constructor

public PointFigure+PFPoint(Int32 column,
     Int32 x,
     Int32 y,
     Double value,
     Boolean isUp)

See Also

PFPoint Structure | PFPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointFigure.PFPointFields

Steema.TeeChart.Styles.PointFigure.PFPoint Fields

Public Fields

Column
IsUp
Value
X
Y

See Also

PFPoint Structure | Steema.TeeChart.Styles Namespace


Column

Steema.TeeChart.Styles.PointFigure+PFPoint.Column Field

public Int32 Column

See Also

PFPoint Structure | PFPoint Members | Steema.TeeChart.Styles Namespace


IsUp

Steema.TeeChart.Styles.PointFigure+PFPoint.IsUp Field

public Boolean IsUp

See Also

PFPoint Structure | PFPoint Members | Steema.TeeChart.Styles Namespace


Value

Steema.TeeChart.Styles.PointFigure+PFPoint.Value Field

public Double Value

See Also

PFPoint Structure | PFPoint Members | Steema.TeeChart.Styles Namespace


X

Steema.TeeChart.Styles.PointFigure+PFPoint.X Field

public Int32 X

See Also

PFPoint Structure | PFPoint Members | Steema.TeeChart.Styles Namespace


Y

Steema.TeeChart.Styles.PointFigure+PFPoint.Y Field

public Int32 Y

See Also

PFPoint Structure | PFPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointFigureDrawValueEventArgs

Steema.TeeChart.Styles.PointFigureDrawValueEventArgs Class

For a list of all members of this type, see PointFigureDrawValueEventArgs Members

System.Object
System.EventArgs
public class PointFigureDrawValueEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

PointFigureDrawValueEventArgs members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointFigureDrawValueEventArgsMembers

Steema.TeeChart.Styles.PointFigureDrawValueEventArgs all Members

PointFigureDrawValueEventArgs overview

Constructors

Constructor

Public Properties

ColIndex |
IsUp |
PointValue | Draws the label when set to true.
X |
Y |
Z |

See Also

PointFigureDrawValueEventArgs Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointFigureDrawValueEventArgs Constructor

public PointFigureDrawValueEventArgs(Int32 X,
     Int32 Y,
     Int32 Z,
     Int32 colIndex,
     Double pointValue,
     Boolean isUp)

See Also

PointFigureDrawValueEventArgs Class | PointFigureDrawValueEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointFigureDrawValueEventArgsProperties

Steema.TeeChart.Styles.PointFigureDrawValueEventArgs Properties

Public Properties

ColIndex |
IsUp |
PointValue | Draws the label when set to true.
X |
Y |
Z |

See Also

PointFigureDrawValueEventArgs Class | Steema.TeeChart.Styles Namespace


ColIndex

Steema.TeeChart.Styles.PointFigureDrawValueEventArgs.ColIndex Property

public Int32 ColIndex {get; set;}

See Also

PointFigureDrawValueEventArgs Class | PointFigureDrawValueEventArgs Members | Steema.TeeChart.Styles Namespace


IsUp

Steema.TeeChart.Styles.PointFigureDrawValueEventArgs.IsUp Property

public Boolean IsUp {get; set;}

See Also

PointFigureDrawValueEventArgs Class | PointFigureDrawValueEventArgs Members | Steema.TeeChart.Styles Namespace


PointValue

Steema.TeeChart.Styles.PointFigureDrawValueEventArgs.PointValue Property

Draws the label when set to true.
public Double PointValue {get; set;}

See Also

PointFigureDrawValueEventArgs Class | PointFigureDrawValueEventArgs Members | Steema.TeeChart.Styles Namespace


X

Steema.TeeChart.Styles.PointFigureDrawValueEventArgs.X Property

public Int32 X {get; set;}

See Also

PointFigureDrawValueEventArgs Class | PointFigureDrawValueEventArgs Members | Steema.TeeChart.Styles Namespace


Y

Steema.TeeChart.Styles.PointFigureDrawValueEventArgs.Y Property

public Int32 Y {get; set;}

See Also

PointFigureDrawValueEventArgs Class | PointFigureDrawValueEventArgs Members | Steema.TeeChart.Styles Namespace


Z

Steema.TeeChart.Styles.PointFigureDrawValueEventArgs.Z Property

public Int32 Z {get; set;}

See Also

PointFigureDrawValueEventArgs Class | PointFigureDrawValueEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointFigureDrawValueEventHandler

Steema.TeeChart.Styles.PointFigureDrawValueEventHandler Delegate

public delegate PointFigureDrawValueEventHandler (Object sender,
     PointFigureDrawValueEventArgs e)

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Points

Steema.TeeChart.Styles.Points Class

Point Series.

For a list of all members of this type, see Points Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
public class Points : CustomPoint , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Points members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointsMembers

Steema.TeeChart.Styles.Points all Members

Points overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomPoint) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Points Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Points Constructor

Overload List

public Points(Steema.TeeChart.Chart)
public Points()

See Also

Points Class | Points Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Points Constructor

public Points()

See Also

Points Constructor Overload List | Points Class | Points Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Points Constructor

public Points(Chart c)

See Also

Points Constructor Overload List | Points Class | Points Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointsEvents

Steema.TeeChart.Styles.Points Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Points Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointsFields

Steema.TeeChart.Styles.Points Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Points Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointsMethods

Steema.TeeChart.Styles.Points Methods

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPoint) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPoint) | Returns the ValueIndex of the "clicked" point in the Series.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomPoint) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Points Class | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.Points.SetSubGallery Method

public override Void SetSubGallery(Int32 index)

See Also

Points Class | Points Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PointsProperties

Steema.TeeChart.Styles.Points Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen | Sets the Pen for the Point connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Points Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Points.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

Points Class | Points Members | Steema.TeeChart.Styles Namespace


LinePen

Steema.TeeChart.Styles.Points.LinePen Property

Sets the Pen for the Point connecting Lines.
public ChartPen LinePen {get; set;}

See Also

Points Class | Points Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Points3D

Steema.TeeChart.Styles.Points3D Class

Point3D Series. Each point has XYZ coordinates.

For a list of all members of this type, see Points3D Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
public class Points3D : Custom3D , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Points3D members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Points3DMembers

Steema.TeeChart.Styles.Points3D all Members

Points3D overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle |
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue | Returns MaxZValue.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
BaseLine | Sets the Pen for the Point3D connecting Lines.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthSize | Sets the Depth of each 3DPoint to the value of DepthSize.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Custom3D) | XYZ Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen | Sets the Pen for the Point3D connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer | Each point in a PointSeries is drawn using the Pointer properties.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull |
TreatNulls |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

Points3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Points3D Constructor

Overload List

public Points3D(Steema.TeeChart.Chart)
public Points3D()

See Also

Points3D Class | Points3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Points3D Constructor

public Points3D()

See Also

Points3D Constructor Overload List | Points3D Class | Points3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Points3D Constructor

public Points3D(Chart c)

See Also

Points3D Constructor Overload List | Points3D Class | Points3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Points3DEvents

Steema.TeeChart.Styles.Points3D Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle |
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Points3D Class | Steema.TeeChart.Styles Namespace


GetPointerStyle

Steema.TeeChart.Styles.Points3D.GetPointerStyle Event

public GetPointerStyleEventHandler  GetPointerStyle

See Also

Points3D Class | Points3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Points3DFields

Steema.TeeChart.Styles.Points3D Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Points3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Points3DMethods

Steema.TeeChart.Styles.Points3D Methods

Public Methods

Add |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue | Returns MaxZValue.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Points3D Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Points3D.Add Method

Overload List

public override Void Add(System.Array, System.Array, System.Boolean)
public override Int32 Add(System.Double, System.Double)

See Also

Points3D Class | Points3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Points3D.Add Method

public override Int32 Add(Double x,
     Double y)

See Also

Add Overload List | Points3D Class | Points3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Points3D.Add Method

public override Void Add(Array xValues,
     Array yValues,
     Boolean append)

See Also

Add Overload List | Points3D Class | Points3D Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Points3D.Clicked Method

Overload List

Returns the ValueIndex of the "clicked" point in the Series.

public override Int32 Clicked(System.Int32, System.Int32)

See Also

Points3D Class | Points3D Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Points3D.Clicked Method

Returns the ValueIndex of the "clicked" point in the Series.
public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | Points3D Class | Points3D Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.Points3D.Draw Method

public override Void Draw()

See Also

Points3D Class | Points3D Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.Points3D.DrawValue Method

Called internally. Draws the "ValueIndex" point of the Series.
public override Void DrawValue(Int32 valueIndex)

See Also

Points3D Class | Points3D Members | Steema.TeeChart.Styles Namespace


MaxZValue

Steema.TeeChart.Styles.Points3D.MaxZValue Method

Returns MaxZValue.
public override Double MaxZValue()

See Also

Points3D Class | Points3D Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.Points3D.PrepareForGallery Method

public override Void PrepareForGallery(Boolean isEnabled)

See Also

Points3D Class | Points3D Members | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.Points3D.SetSubGallery Method

public override Void SetSubGallery(Int32 index)

See Also

Points3D Class | Points3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Points3DProperties

Steema.TeeChart.Styles.Points3D Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
BaseLine | Sets the Pen for the Point3D connecting Lines.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthSize | Sets the Depth of each 3DPoint to the value of DepthSize.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Custom3D) | XYZ Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LinePen | Sets the Pen for the Point3D connecting Lines.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer | Each point in a PointSeries is drawn using the Pointer properties.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
TreatNaNAsNull |
TreatNulls |
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

Points3D Class | Steema.TeeChart.Styles Namespace


BaseLine

Steema.TeeChart.Styles.Points3D.BaseLine Property

Sets the Pen for the Point3D connecting Lines.
public ChartPen BaseLine {get;}

See Also

Points3D Class | Points3D Members | Steema.TeeChart.Styles Namespace


DepthSize

Steema.TeeChart.Styles.Points3D.DepthSize Property

Sets the Depth of each 3DPoint to the value of DepthSize.
public Double DepthSize {get; set;}

See Also

Points3D Class | Points3D Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Points3D.Description Property

public override String Description {get;}

See Also

Points3D Class | Points3D Members | Steema.TeeChart.Styles Namespace


LinePen

Steema.TeeChart.Styles.Points3D.LinePen Property

Sets the Pen for the Point3D connecting Lines.
public ChartPen LinePen {get;}

See Also

Points3D Class | Points3D Members | Steema.TeeChart.Styles Namespace


Pointer

Steema.TeeChart.Styles.Points3D.Pointer Property

Each point in a PointSeries is drawn using the Pointer properties.
public virtual SeriesPointer Pointer {get; set;}

See Also

Points3D Class | Points3D Members | Steema.TeeChart.Styles Namespace


TreatNaNAsNull

Steema.TeeChart.Styles.Points3D.TreatNaNAsNull Property

public Boolean TreatNaNAsNull {get; set;}

See Also

Points3D Class | Points3D Members | Steema.TeeChart.Styles Namespace


TreatNulls

Steema.TeeChart.Styles.Points3D.TreatNulls Property

public TreatNullsStyle TreatNulls {get; set;}

See Also

Points3D Class | Points3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Points3D.GetPointerStyleEventHandler

Steema.TeeChart.Styles.Points3D.GetPointerStyleEventHandler Delegate

The Delegate for the GetPointerStyle event.
public delegate GetPointerStyleEventHandler (Points3D series,
     GetPointerStyleEventArgs e)

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Polar

Steema.TeeChart.Styles.Polar Class

Polar Series.

For a list of all members of this type, see Polar Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
Steema.TeeChart.Styles.CustomPolar
public class Polar : CustomPolar , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Polar members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarMembers

Steema.TeeChart.Styles.Polar all Members

Polar overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle (inherited from CustomPolar) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from CustomPolar) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPolar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPolar) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPolar) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPolar) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from CustomPolar) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawRing (inherited from CustomPolar) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomPolar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
DrawZone (inherited from CustomPolar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
OnGetPointerStyle (inherited from CustomPolar) |
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery (inherited from CustomPolar) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AngleIncrement (inherited from CustomPolar) | Sets angle in degrees used to draw the dividing grid lines in anti-clockwise direction.
AngleValues (inherited from CustomPolar) | Gets list of angle values for each polar point.
Brush (inherited from CustomPolar) | Sets Polar Back Brush.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleLabels (inherited from CustomPolar) | Sets CicleLabel properties.
CircleLabelsFont (inherited from CustomPolar) |
CircleLabelsInside (inherited from CustomPolar) | Enables/disables the display of the axis labels inside the circle area.
CircleLabelsRotated (inherited from CustomPolar) | When true rotates the labels of a circular TeeChart series at an angle in line with the Radar/Polar circle at each Label point.
CirclePen (inherited from CustomPolar) | Determines the pen used to draw the outmost circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
ClockWiseLabels (inherited from CustomPolar) | Displays of the circle labels in a clockwise direction.
CloseCircle (inherited from CustomPolar) | Draws a Line between the last and first PolarSeries point coordinates.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Font (inherited from CustomPolar) | Sets the label font.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsMargin (inherited from CustomPolar) | Defines the distance between the CustomPolar circle and the labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen (inherited from CustomPolar) | Determines Pen used to draw the Line connecting PolarSeries points.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPolar) | Pointer contains several properties to control the formatting attributes of Points like Pen, Brush, Draw3D, Visible, etc.
RadiusIncrement (inherited from CustomPolar) | Determines the increment used to draw the ring grid lines.
RadiusValues (inherited from CustomPolar) | Gets list of radius values for each polar point.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from CustomPolar) | Sets Transparency level from 0 to 100%.
TreatNaNAsNull (inherited from CustomPolar) |
TreatNulls (inherited from CustomPolar) |
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Polar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Polar Constructor

Overload List

public Polar()
public Polar(Steema.TeeChart.Chart)

See Also

Polar Class | Polar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Polar Constructor

public Polar(Chart c)

See Also

Polar Constructor Overload List | Polar Class | Polar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Polar Constructor

public Polar()

See Also

Polar Constructor Overload List | Polar Class | Polar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarEvents

Steema.TeeChart.Styles.Polar Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle (inherited from CustomPolar) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Polar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarFields

Steema.TeeChart.Styles.Polar Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Polar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarMethods

Steema.TeeChart.Styles.Polar Methods

Public Methods

Add (inherited from CustomPolar) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPolar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPolar) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPolar) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPolar) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from CustomPolar) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawRing (inherited from CustomPolar) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomPolar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
DrawZone (inherited from CustomPolar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
OnGetPointerStyle (inherited from CustomPolar) |
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery (inherited from CustomPolar) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Polar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarProperties

Steema.TeeChart.Styles.Polar Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AngleIncrement (inherited from CustomPolar) | Sets angle in degrees used to draw the dividing grid lines in anti-clockwise direction.
AngleValues (inherited from CustomPolar) | Gets list of angle values for each polar point.
Brush (inherited from CustomPolar) | Sets Polar Back Brush.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleLabels (inherited from CustomPolar) | Sets CicleLabel properties.
CircleLabelsFont (inherited from CustomPolar) |
CircleLabelsInside (inherited from CustomPolar) | Enables/disables the display of the axis labels inside the circle area.
CircleLabelsRotated (inherited from CustomPolar) | When true rotates the labels of a circular TeeChart series at an angle in line with the Radar/Polar circle at each Label point.
CirclePen (inherited from CustomPolar) | Determines the pen used to draw the outmost circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
ClockWiseLabels (inherited from CustomPolar) | Displays of the circle labels in a clockwise direction.
CloseCircle (inherited from CustomPolar) | Draws a Line between the last and first PolarSeries point coordinates.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Font (inherited from CustomPolar) | Sets the label font.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsMargin (inherited from CustomPolar) | Defines the distance between the CustomPolar circle and the labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen (inherited from CustomPolar) | Determines Pen used to draw the Line connecting PolarSeries points.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPolar) | Pointer contains several properties to control the formatting attributes of Points like Pen, Brush, Draw3D, Visible, etc.
RadiusIncrement (inherited from CustomPolar) | Determines the increment used to draw the ring grid lines.
RadiusValues (inherited from CustomPolar) | Gets list of radius values for each polar point.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from CustomPolar) | Sets Transparency level from 0 to 100%.
TreatNaNAsNull (inherited from CustomPolar) |
TreatNulls (inherited from CustomPolar) |
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Polar Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Polar.Description Property

public override String Description {get;}

See Also

Polar Class | Polar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarBar

Steema.TeeChart.Styles.PolarBar Class

Polar Bar Series.

For a list of all members of this type, see PolarBar Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
Steema.TeeChart.Styles.CustomPolar
Steema.TeeChart.Styles.Polar
public class PolarBar : Polar , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

PolarBar members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarBarMembers

Steema.TeeChart.Styles.PolarBar all Members

PolarBar overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle (inherited from CustomPolar) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from CustomPolar) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPolar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPolar) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPolar) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPolar) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from CustomPolar) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawRing (inherited from CustomPolar) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomPolar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
DrawZone (inherited from CustomPolar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
OnGetPointerStyle (inherited from CustomPolar) |
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery (inherited from CustomPolar) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AngleIncrement (inherited from CustomPolar) | Sets angle in degrees used to draw the dividing grid lines in anti-clockwise direction.
AngleValues (inherited from CustomPolar) | Gets list of angle values for each polar point.
Brush (inherited from CustomPolar) | Sets Polar Back Brush.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleLabels (inherited from CustomPolar) | Sets CicleLabel properties.
CircleLabelsFont (inherited from CustomPolar) |
CircleLabelsInside (inherited from CustomPolar) | Enables/disables the display of the axis labels inside the circle area.
CircleLabelsRotated (inherited from CustomPolar) | When true rotates the labels of a circular TeeChart series at an angle in line with the Radar/Polar circle at each Label point.
CirclePen (inherited from CustomPolar) | Determines the pen used to draw the outmost circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
ClockWiseLabels (inherited from CustomPolar) | Displays of the circle labels in a clockwise direction.
CloseCircle (inherited from CustomPolar) | Draws a Line between the last and first PolarSeries point coordinates.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Font (inherited from CustomPolar) | Sets the label font.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsMargin (inherited from CustomPolar) | Defines the distance between the CustomPolar circle and the labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen (inherited from CustomPolar) | Determines Pen used to draw the Line connecting PolarSeries points.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPolar) | Pointer contains several properties to control the formatting attributes of Points like Pen, Brush, Draw3D, Visible, etc.
RadiusIncrement (inherited from CustomPolar) | Determines the increment used to draw the ring grid lines.
RadiusValues (inherited from CustomPolar) | Gets list of radius values for each polar point.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from CustomPolar) | Sets Transparency level from 0 to 100%.
TreatNaNAsNull (inherited from CustomPolar) |
TreatNulls (inherited from CustomPolar) |
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

PolarBar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarBar Constructor

Overload List

public PolarBar()
public PolarBar(Steema.TeeChart.Chart)

See Also

PolarBar Class | PolarBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarBar Constructor

public PolarBar(Chart c)

See Also

PolarBar Constructor Overload List | PolarBar Class | PolarBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarBar Constructor

public PolarBar()

See Also

PolarBar Constructor Overload List | PolarBar Class | PolarBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarBarEvents

Steema.TeeChart.Styles.PolarBar Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle (inherited from CustomPolar) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

PolarBar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarBarFields

Steema.TeeChart.Styles.PolarBar Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

PolarBar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarBarMethods

Steema.TeeChart.Styles.PolarBar Methods

Public Methods

Add (inherited from CustomPolar) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPolar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPolar) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPolar) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPolar) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from CustomPolar) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawRing (inherited from CustomPolar) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomPolar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
DrawZone (inherited from CustomPolar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
OnGetPointerStyle (inherited from CustomPolar) |
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery (inherited from CustomPolar) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

PolarBar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarBarProperties

Steema.TeeChart.Styles.PolarBar Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AngleIncrement (inherited from CustomPolar) | Sets angle in degrees used to draw the dividing grid lines in anti-clockwise direction.
AngleValues (inherited from CustomPolar) | Gets list of angle values for each polar point.
Brush (inherited from CustomPolar) | Sets Polar Back Brush.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleLabels (inherited from CustomPolar) | Sets CicleLabel properties.
CircleLabelsFont (inherited from CustomPolar) |
CircleLabelsInside (inherited from CustomPolar) | Enables/disables the display of the axis labels inside the circle area.
CircleLabelsRotated (inherited from CustomPolar) | When true rotates the labels of a circular TeeChart series at an angle in line with the Radar/Polar circle at each Label point.
CirclePen (inherited from CustomPolar) | Determines the pen used to draw the outmost circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
ClockWiseLabels (inherited from CustomPolar) | Displays of the circle labels in a clockwise direction.
CloseCircle (inherited from CustomPolar) | Draws a Line between the last and first PolarSeries point coordinates.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Font (inherited from CustomPolar) | Sets the label font.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsMargin (inherited from CustomPolar) | Defines the distance between the CustomPolar circle and the labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen (inherited from CustomPolar) | Determines Pen used to draw the Line connecting PolarSeries points.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPolar) | Pointer contains several properties to control the formatting attributes of Points like Pen, Brush, Draw3D, Visible, etc.
RadiusIncrement (inherited from CustomPolar) | Determines the increment used to draw the ring grid lines.
RadiusValues (inherited from CustomPolar) | Gets list of radius values for each polar point.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from CustomPolar) | Sets Transparency level from 0 to 100%.
TreatNaNAsNull (inherited from CustomPolar) |
TreatNulls (inherited from CustomPolar) |
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

PolarBar Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.PolarBar.Description Property

public override String Description {get;}

See Also

PolarBar Class | PolarBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarGrid

Steema.TeeChart.Styles.PolarGrid Class

Polar Grid Series.

For a list of all members of this type, see PolarGrid Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
Steema.TeeChart.Styles.CustomPolar
public class PolarGrid : CustomPolar , ICloneable, ISeriesPointer

Remarks

Displays an array of values as a circular grid of cells.

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

PolarGrid members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarGridMembers

Steema.TeeChart.Styles.PolarGrid all Members

PolarGrid overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle (inherited from CustomPolar) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from CustomPolar) |
AddCell | Add new cell to polar grid series.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos |
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos |
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from CustomPolar) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawRing (inherited from CustomPolar) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
DrawZone (inherited from CustomPolar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf |
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString |
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
OnGetPointerStyle (inherited from CustomPolar) |
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AngleIncrement (inherited from CustomPolar) | Sets angle in degrees used to draw the dividing grid lines in anti-clockwise direction.
AngleValues (inherited from CustomPolar) | Gets list of angle values for each polar point.
Brush (inherited from CustomPolar) | Sets Polar Back Brush.
CellValues | Polar Grid cell values.
Centered | If true, cells are centered around angles.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleLabels (inherited from CustomPolar) | Sets CicleLabel properties.
CircleLabelsFont (inherited from CustomPolar) |
CircleLabelsInside (inherited from CustomPolar) | Enables/disables the display of the axis labels inside the circle area.
CircleLabelsRotated (inherited from CustomPolar) | When true rotates the labels of a circular TeeChart series at an angle in line with the Radar/Polar circle at each Label point.
CirclePen (inherited from CustomPolar) | Determines the pen used to draw the outmost circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
ClockWiseLabels (inherited from CustomPolar) | Displays of the circle labels in a clockwise direction.
CloseCircle (inherited from CustomPolar) | Draws a Line between the last and first PolarSeries point coordinates.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Font (inherited from CustomPolar) | Sets the label font.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsMargin (inherited from CustomPolar) | Defines the distance between the CustomPolar circle and the labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
NumSectors | Defines the number of sectors in polar grid.
NumTracks | Defines number of tracks in polar grid.
Palette | Access polar grid color palette properties.
Pen (inherited from CustomPolar) | Determines Pen used to draw the Line connecting PolarSeries points.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPolar) | Pointer contains several properties to control the formatting attributes of Points like Pen, Brush, Draw3D, Visible, etc.
RadiusIncrement (inherited from CustomPolar) | Determines the increment used to draw the ring grid lines.
RadiusValues (inherited from CustomPolar) | Gets list of radius values for each polar point.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from CustomPolar) | Sets Transparency level from 0 to 100%.
TreatNaNAsNull (inherited from CustomPolar) |
TreatNulls (inherited from CustomPolar) |
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

PolarGrid Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarGrid Constructor

Overload List

public PolarGrid()
public PolarGrid(Steema.TeeChart.Chart)

See Also

PolarGrid Class | PolarGrid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarGrid Constructor

public PolarGrid(Chart c)

See Also

PolarGrid Constructor Overload List | PolarGrid Class | PolarGrid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarGrid Constructor

public PolarGrid()

See Also

PolarGrid Constructor Overload List | PolarGrid Class | PolarGrid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarGridEvents

Steema.TeeChart.Styles.PolarGrid Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle (inherited from CustomPolar) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

PolarGrid Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarGridFields

Steema.TeeChart.Styles.PolarGrid Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

PolarGrid Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarGridMethods

Steema.TeeChart.Styles.PolarGrid Methods

Public Methods

Add (inherited from CustomPolar) |
AddCell | Add new cell to polar grid series.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos |
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos |
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from CustomPolar) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawRing (inherited from CustomPolar) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
DrawZone (inherited from CustomPolar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf |
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString |
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
OnGetPointerStyle (inherited from CustomPolar) |
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

PolarGrid Class | Steema.TeeChart.Styles Namespace


AddCell

Steema.TeeChart.Styles.PolarGrid.AddCell Method

Add new cell to polar grid series.
public Int32 AddCell(Int32 sector,
     Int32 track,
     Double value)

Parameters

sector
Cell sector.
track
Cell track.
value
Value for Cell[sector,track].

Return Value

Added cell index.

See Also

PolarGrid Class | PolarGrid Members | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.PolarGrid.AssignFormat Method

Overload List

public override Void AssignFormat(Steema.TeeChart.Styles.Series, Steema.TeeChart.Styles.Series)

See Also

PolarGrid Class | PolarGrid Members | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.PolarGrid.AssignFormat Method

public override Void AssignFormat(Series source,
     Series target)

See Also

AssignFormat Overload List | PolarGrid Class | PolarGrid Members | Steema.TeeChart.Styles Namespace


CalcXPos

Steema.TeeChart.Styles.PolarGrid.CalcXPos Method

public override Int32 CalcXPos(Int32 valueIndex)

See Also

PolarGrid Class | PolarGrid Members | Steema.TeeChart.Styles Namespace


CalcYPos

Steema.TeeChart.Styles.PolarGrid.CalcYPos Method

public override Int32 CalcYPos(Int32 valueIndex)

See Also

PolarGrid Class | PolarGrid Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.PolarGrid.Clicked Method

Overload List

public override Int32 Clicked(System.Int32, System.Int32)

See Also

PolarGrid Class | PolarGrid Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.PolarGrid.Clicked Method

public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | PolarGrid Class | PolarGrid Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.PolarGrid.DrawValue Method

public override Void DrawValue(Int32 valueIndex)

See Also

PolarGrid Class | PolarGrid Members | Steema.TeeChart.Styles Namespace


IsValidSourceOf

Steema.TeeChart.Styles.PolarGrid.IsValidSourceOf Method

public override Boolean IsValidSourceOf(Series value)

See Also

PolarGrid Class | PolarGrid Members | Steema.TeeChart.Styles Namespace


LegendString

Steema.TeeChart.Styles.PolarGrid.LegendString Method

public override String LegendString(Int32 legendIndex,
     LegendTextStyles legendTextStyle)

See Also

PolarGrid Class | PolarGrid Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.PolarGrid.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

PolarGrid Class | PolarGrid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolarGridProperties

Steema.TeeChart.Styles.PolarGrid Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AngleIncrement (inherited from CustomPolar) | Sets angle in degrees used to draw the dividing grid lines in anti-clockwise direction.
AngleValues (inherited from CustomPolar) | Gets list of angle values for each polar point.
Brush (inherited from CustomPolar) | Sets Polar Back Brush.
CellValues | Polar Grid cell values.
Centered | If true, cells are centered around angles.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleLabels (inherited from CustomPolar) | Sets CicleLabel properties.
CircleLabelsFont (inherited from CustomPolar) |
CircleLabelsInside (inherited from CustomPolar) | Enables/disables the display of the axis labels inside the circle area.
CircleLabelsRotated (inherited from CustomPolar) | When true rotates the labels of a circular TeeChart series at an angle in line with the Radar/Polar circle at each Label point.
CirclePen (inherited from CustomPolar) | Determines the pen used to draw the outmost circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
ClockWiseLabels (inherited from CustomPolar) | Displays of the circle labels in a clockwise direction.
CloseCircle (inherited from CustomPolar) | Draws a Line between the last and first PolarSeries point coordinates.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Font (inherited from CustomPolar) | Sets the label font.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsMargin (inherited from CustomPolar) | Defines the distance between the CustomPolar circle and the labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
NumSectors | Defines the number of sectors in polar grid.
NumTracks | Defines number of tracks in polar grid.
Palette | Access polar grid color palette properties.
Pen (inherited from CustomPolar) | Determines Pen used to draw the Line connecting PolarSeries points.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPolar) | Pointer contains several properties to control the formatting attributes of Points like Pen, Brush, Draw3D, Visible, etc.
RadiusIncrement (inherited from CustomPolar) | Determines the increment used to draw the ring grid lines.
RadiusValues (inherited from CustomPolar) | Gets list of radius values for each polar point.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from CustomPolar) | Sets Transparency level from 0 to 100%.
TreatNaNAsNull (inherited from CustomPolar) |
TreatNulls (inherited from CustomPolar) |
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

PolarGrid Class | Steema.TeeChart.Styles Namespace


CellValues

Steema.TeeChart.Styles.PolarGrid.CellValues Property

Polar Grid cell values.
public ValueList CellValues {get; set;}

See Also

PolarGrid Class | PolarGrid Members | Steema.TeeChart.Styles Namespace


Centered

Steema.TeeChart.Styles.PolarGrid.Centered Property

If true, cells are centered around angles.
public Boolean Centered {get; set;}

See Also

PolarGrid Class | PolarGrid Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.PolarGrid.Description Property

public override String Description {get;}

See Also

PolarGrid Class | PolarGrid Members | Steema.TeeChart.Styles Namespace


NumSectors

Steema.TeeChart.Styles.PolarGrid.NumSectors Property

Defines the number of sectors in polar grid.
public Int32 NumSectors {get; set;}

See Also

PolarGrid Class | PolarGrid Members | Steema.TeeChart.Styles Namespace


NumTracks

Steema.TeeChart.Styles.PolarGrid.NumTracks Property

Defines number of tracks in polar grid.
public Int32 NumTracks {get; set;}

See Also

PolarGrid Class | PolarGrid Members | Steema.TeeChart.Styles Namespace


Palette

Steema.TeeChart.Styles.PolarGrid.Palette Property

Access polar grid color palette properties.
public GridColorPalette Palette {get; set;}

See Also

PolarGrid Class | PolarGrid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Polygon

Steema.TeeChart.Styles.Polygon Class

For a list of all members of this type, see Polygon Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class Polygon : TeeBase

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Polygon members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonMembers

Steema.TeeChart.Styles.Polygon all Members

Polygon overview

Constructors

Constructor Overloaded

Public Methods

Add | Use Add method to add a boundary coordinate to the polygon. The polygon will be drawn in sequential order of the coordinates. (ie. from point 1 (X0,Y0) to point 2 (X1,Y1) to point 3 (X2,Y2), ....)
Bounds | Returns the rectangle in pixels that corresponds to the maximum space used by the polygon.
CalcPoints |
Draw |
GetPoints | The GetPoints function returns the coordinates of all Points of the Polygon.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Visible | Returns True if the polygon fits inside the available Chart ChartRect rectangle.

Public Properties

Brush | The Brush property determines the kind of brush used to fill the polygon interior.
Chart (inherited from TeeBase) | Chart associated with this object
Closed | When Closed is True, the polygon is displayed and filled using the polygon Pen and Brush properties. When Closed is False, a poly-line is displayed using the Pen property.
Color | Set Color property to specify the color to be used to fill the polygon. Or to be used to draw the Brush pattern.
Gradient | The Gradient property determines the kind of polygon's interior gradient effect.
Index |
ParentBrush | To have a polygon to use the same Brush as its parentseries (Map Series), set ParentBrush to True. If ParentBrush is False, the polygon uses its own Brush property.
ParentPen | To have a polygon to use the same Pen as its Parentseries, set ParentPen to True. If ParentPen is False, the polygon uses its own Pen property.
ParentSeries |
Pen | Set Pen property to specify the Pen to be used to draw the border of the polygon.
Points | Use the Points property to have access to the co-ordinates PointList which determine the boundary of the polygon.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text | Use Text to specify the text string that labels the polygon
Transparency | Amount of opacity used to fill the polygon interior. 100 means fully transparent, 0 means fully opaque.
Z | Use Z property to specify the position on the Z-axis of the 3D Map Series. In Chart terms this will set a Z plane position, a lower value of Z will be drawn in front of a higher Z value. Map Series is intended to be viewed in 2D and the Z value is provided to be used as a value for a Polygon (ie. for demographic maps). If colour Palette is used then the Z value will set the Polygon colour.

See Also

Polygon Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Polygon Constructor

Overload List

public Polygon(Steema.TeeChart.Chart)
public Polygon(Steema.TeeChart.Styles.PolygonList, Steema.TeeChart.Chart)

See Also

Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Polygon Constructor

public Polygon(PolygonList Collection,
     Chart AChart)

See Also

Polygon Constructor Overload List | Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Polygon Constructor

public Polygon(Chart AChart)

See Also

Polygon Constructor Overload List | Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonMethods

Steema.TeeChart.Styles.Polygon Methods

Public Methods

Add | Use Add method to add a boundary coordinate to the polygon. The polygon will be drawn in sequential order of the coordinates. (ie. from point 1 (X0,Y0) to point 2 (X1,Y1) to point 3 (X2,Y2), ....)
Bounds | Returns the rectangle in pixels that corresponds to the maximum space used by the polygon.
CalcPoints |
Draw |
GetPoints | The GetPoints function returns the coordinates of all Points of the Polygon.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Visible | Returns True if the polygon fits inside the available Chart ChartRect rectangle.

See Also

Polygon Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Polygon.Add Method

Overload List

Use Add method to add a boundary coordinate to the polygon. The polygon will be drawn in sequential order of the coordinates. (ie. from point 1 (X0,Y0) to point 2 (X1,Y1) to point 3 (X2,Y2), ....)

public Int32 Add(System.Drawing.Point)

Use Add method to add a boundary coordinate to the polygon. The polygon will be drawn in sequential order of the coordinates. (ie. from point 1 (X0,Y0) to point 2 (X1,Y1) to point 3 (X2,Y2), ....)

public Int32 Add(System.Double, System.Double)

See Also

Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Polygon.Add Method

Use Add method to add a boundary coordinate to the polygon. The polygon will be drawn in sequential order of the coordinates. (ie. from point 1 (X0,Y0) to point 2 (X1,Y1) to point 3 (X2,Y2), ....)
public Int32 Add(Double X,
     Double Y)

See Also

Add Overload List | Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Polygon.Add Method

Use Add method to add a boundary coordinate to the polygon. The polygon will be drawn in sequential order of the coordinates. (ie. from point 1 (X0,Y0) to point 2 (X1,Y1) to point 3 (X2,Y2), ....)
public Int32 Add(Point Point)

See Also

Add Overload List | Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


Bounds

Steema.TeeChart.Styles.Polygon.Bounds Method

Returns the rectangle in pixels that corresponds to the maximum space used by the polygon.
public Rectangle Bounds()

See Also

Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


CalcPoints

Steema.TeeChart.Styles.Polygon.CalcPoints Method

public Void CalcPoints(Int32 xoffset,
     Int32 yoffset)

See Also

Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.Polygon.Draw Method

public Void Draw(Graphics3D g,
     Int32 ValueIndex)

See Also

Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


GetPoints

Steema.TeeChart.Styles.Polygon.GetPoints Method

The GetPoints function returns the coordinates of all Points of the Polygon.
public Point[] GetPoints()

See Also

Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


Visible

Steema.TeeChart.Styles.Polygon.Visible Method

Returns True if the polygon fits inside the available Chart ChartRect rectangle.
public Boolean Visible()

See Also

Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonProperties

Steema.TeeChart.Styles.Polygon Properties

Public Properties

Brush | The Brush property determines the kind of brush used to fill the polygon interior.
Chart (inherited from TeeBase) | Chart associated with this object
Closed | When Closed is True, the polygon is displayed and filled using the polygon Pen and Brush properties. When Closed is False, a poly-line is displayed using the Pen property.
Color | Set Color property to specify the color to be used to fill the polygon. Or to be used to draw the Brush pattern.
Gradient | The Gradient property determines the kind of polygon's interior gradient effect.
Index |
ParentBrush | To have a polygon to use the same Brush as its parentseries (Map Series), set ParentBrush to True. If ParentBrush is False, the polygon uses its own Brush property.
ParentPen | To have a polygon to use the same Pen as its Parentseries, set ParentPen to True. If ParentPen is False, the polygon uses its own Pen property.
ParentSeries |
Pen | Set Pen property to specify the Pen to be used to draw the border of the polygon.
Points | Use the Points property to have access to the co-ordinates PointList which determine the boundary of the polygon.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text | Use Text to specify the text string that labels the polygon
Transparency | Amount of opacity used to fill the polygon interior. 100 means fully transparent, 0 means fully opaque.
Z | Use Z property to specify the position on the Z-axis of the 3D Map Series. In Chart terms this will set a Z plane position, a lower value of Z will be drawn in front of a higher Z value. Map Series is intended to be viewed in 2D and the Z value is provided to be used as a value for a Polygon (ie. for demographic maps). If colour Palette is used then the Z value will set the Polygon colour.

See Also

Polygon Class | Steema.TeeChart.Styles Namespace


Brush

Steema.TeeChart.Styles.Polygon.Brush Property

The Brush property determines the kind of brush used to fill the polygon interior.
public ChartBrush Brush {get;}

See Also

Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


Closed

Steema.TeeChart.Styles.Polygon.Closed Property

When Closed is True, the polygon is displayed and filled using the polygon Pen and Brush properties. When Closed is False, a poly-line is displayed using the Pen property.
public Boolean Closed {get; set;}

See Also

Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


Color

Steema.TeeChart.Styles.Polygon.Color Property

Set Color property to specify the color to be used to fill the polygon. Or to be used to draw the Brush pattern.
public Color Color {get; set;}

See Also

Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


Gradient

Steema.TeeChart.Styles.Polygon.Gradient Property

The Gradient property determines the kind of polygon's interior gradient effect.
public Gradient Gradient {get;}

See Also

Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


Index

Steema.TeeChart.Styles.Polygon.Index Property

public Int32 Index {get; set;}

See Also

Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


ParentBrush

Steema.TeeChart.Styles.Polygon.ParentBrush Property

To have a polygon to use the same Brush as its parentseries (Map Series), set ParentBrush to True. If ParentBrush is False, the polygon uses its own Brush property.
public Boolean ParentBrush {get; set;}

See Also

Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


ParentPen

Steema.TeeChart.Styles.Polygon.ParentPen Property

To have a polygon to use the same Pen as its Parentseries, set ParentPen to True. If ParentPen is False, the polygon uses its own Pen property.
public Boolean ParentPen {get; set;}

See Also

Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


ParentSeries

Steema.TeeChart.Styles.Polygon.ParentSeries Property

public Map ParentSeries {get; set;}

See Also

Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


Pen

Steema.TeeChart.Styles.Polygon.Pen Property

Set Pen property to specify the Pen to be used to draw the border of the polygon.
public ChartPen Pen {get; set;}

See Also

Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


Points

Steema.TeeChart.Styles.Polygon.Points Property

Use the Points property to have access to the co-ordinates PointList which determine the boundary of the polygon.
public PolygonSeries Points {get; set;}

See Also

Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


Text

Steema.TeeChart.Styles.Polygon.Text Property

Use Text to specify the text string that labels the polygon
public String Text {get; set;}

See Also

Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


Transparency

Steema.TeeChart.Styles.Polygon.Transparency Property

Amount of opacity used to fill the polygon interior. 100 means fully transparent, 0 means fully opaque.
public Int32 Transparency {get; set;}

See Also

Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


Z

Steema.TeeChart.Styles.Polygon.Z Property

Use Z property to specify the position on the Z-axis of the 3D Map Series. In Chart terms this will set a Z plane position, a lower value of Z will be drawn in front of a higher Z value. Map Series is intended to be viewed in 2D and the Z value is provided to be used as a value for a Polygon (ie. for demographic maps). If colour Palette is used then the Z value will set the Polygon colour.
public Double Z {get; set;}

See Also

Polygon Class | Polygon Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonList

Steema.TeeChart.Styles.PolygonList Class

ValueLists is a collection of ValueList objects.

For a list of all members of this type, see PolygonList Members

System.Object
System.Collections.CollectionBase
public class PolygonList : CollectionBase , IList, ICollection
, IEnumerable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

PolygonList members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonListMembers

Steema.TeeChart.Styles.PolygonList all Members

PolygonList overview

Constructors

Constructor

Public Methods

Add
AddRange
Assign
IndexOf
RemoveRange

Public Properties

Item |
Item |
Owner | The Owner property returns the Map Series that owns the PolygonList.

See Also

PolygonList Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonList Constructor

public PolygonList(Map MapSeries)

See Also

PolygonList Class | PolygonList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonListMethods

Steema.TeeChart.Styles.PolygonList Methods

Public Methods

Add
AddRange
Assign
IndexOf
RemoveRange

See Also

PolygonList Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.PolygonList.Add Method

public Int32 Add(Polygon value)

See Also

PolygonList Class | PolygonList Members | Steema.TeeChart.Styles Namespace


AddRange

Steema.TeeChart.Styles.PolygonList.AddRange Method

public Void AddRange(ICollection c)

See Also

PolygonList Class | PolygonList Members | Steema.TeeChart.Styles Namespace


Assign

Steema.TeeChart.Styles.PolygonList.Assign Method

public Void Assign(PolygonList Value)

See Also

PolygonList Class | PolygonList Members | Steema.TeeChart.Styles Namespace


IndexOf

Steema.TeeChart.Styles.PolygonList.IndexOf Method

public Int32 IndexOf(Series s)

See Also

PolygonList Class | PolygonList Members | Steema.TeeChart.Styles Namespace


RemoveRange

Steema.TeeChart.Styles.PolygonList.RemoveRange Method

public Void RemoveRange(Int32 index,
     Int32 count)

See Also

PolygonList Class | PolygonList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonListProperties

Steema.TeeChart.Styles.PolygonList Properties

Public Properties

Item |
Item |
Owner | The Owner property returns the Map Series that owns the PolygonList.

See Also

PolygonList Class | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.PolygonList.Item Property

public Polygon Item(Int32 index) {get; set;}

See Also

PolygonList Class | PolygonList Members | Steema.TeeChart.Styles Namespace


Owner

Steema.TeeChart.Styles.PolygonList.Owner Property

The Owner property returns the Map Series that owns the PolygonList.
public Map Owner {get; set;}

See Also

PolygonList Class | PolygonList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonSaveTree

Steema.TeeChart.Styles.PolygonSaveTree Class

For a list of all members of this type, see PolygonSaveTree Members

System.Object
System.Collections.CollectionBase
[Serializable]
public class PolygonSaveTree : CollectionBase , IList, ICollection
, IEnumerable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

PolygonSaveTree members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonSaveTreeMembers

Steema.TeeChart.Styles.PolygonSaveTree all Members

PolygonSaveTree overview

Constructors

Constructor

Public Methods

Add

Public Properties

Item

See Also

PolygonSaveTree Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonSaveTree Constructor

public PolygonSaveTree()

See Also

PolygonSaveTree Class | PolygonSaveTree Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonSaveTreeMethods

Steema.TeeChart.Styles.PolygonSaveTree Methods

Public Methods

Add

See Also

PolygonSaveTree Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.PolygonSaveTree.Add Method

public Void Add(PolyObj item)

See Also

PolygonSaveTree Class | PolygonSaveTree Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonSaveTreeProperties

Steema.TeeChart.Styles.PolygonSaveTree Properties

Public Properties

Item

See Also

PolygonSaveTree Class | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.PolygonSaveTree.Item Property

public PolyObj Item(Int32 Index) {get; set;}

See Also

PolygonSaveTree Class | PolygonSaveTree Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonSeries

Steema.TeeChart.Styles.PolygonSeries Class

Polygon Series is a descendant of Series. Use Polygon Series to define the shape of the Polygons to be drawn by the Map Series. A Polygon Series contains the co-ordinates of the Points which define the boundary of a Polygon. PolygonSeries stores the point Valuelists and individual characteristics of each Map Series 'sub' Series (each Polygon is a Chart Series). Map Series hides the need treat each Polygon as a Series by treating the Polygons as an internal collection of Series.

For a list of all members of this type, see PolygonSeries Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class PolygonSeries : Series , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

PolygonSeries members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonSeriesMembers

Steema.TeeChart.Styles.PolygonSeries all Members

PolygonSeries overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Series) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
Polygon |
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString |
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen |
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

PolygonSeries Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonSeries Constructor

Overload List

public PolygonSeries(Steema.TeeChart.Chart)
public PolygonSeries()

See Also

PolygonSeries Class | PolygonSeries Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonSeries Constructor

public PolygonSeries()

See Also

PolygonSeries Constructor Overload List | PolygonSeries Class | PolygonSeries Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonSeries Constructor

public PolygonSeries(Chart c)

See Also

PolygonSeries Constructor Overload List | PolygonSeries Class | PolygonSeries Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonSeriesEvents

Steema.TeeChart.Styles.PolygonSeries Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

PolygonSeries Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonSeriesFields

Steema.TeeChart.Styles.PolygonSeries Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

PolygonSeries Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonSeriesMethods

Steema.TeeChart.Styles.PolygonSeries Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Series) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
Polygon |
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString |
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

PolygonSeries Class | Steema.TeeChart.Styles Namespace


Polygon

Steema.TeeChart.Styles.PolygonSeries.Polygon Method

public Polygon Polygon()

See Also

PolygonSeries Class | PolygonSeries Members | Steema.TeeChart.Styles Namespace


ToString

Steema.TeeChart.Styles.PolygonSeries.ToString Method

public override String ToString()

See Also

PolygonSeries Class | PolygonSeries Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolygonSeriesProperties

Steema.TeeChart.Styles.PolygonSeries Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description (inherited from Series) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen |
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

PolygonSeries Class | Steema.TeeChart.Styles Namespace


Pen

Steema.TeeChart.Styles.PolygonSeries.Pen Property

public ChartPen Pen {get; set;}

See Also

PolygonSeries Class | PolygonSeries Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolyObj

Steema.TeeChart.Styles.PolyObj Class

For a list of all members of this type, see PolyObj Members

System.Object
[Serializable]
public class PolyObj : Object

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

PolyObj members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolyObjMembers

Steema.TeeChart.Styles.PolyObj all Members

PolyObj overview

Constructors

Constructor

Public Fields

IPoints
Text
ZValue

See Also

PolyObj Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolyObj Constructor

public PolyObj(Point[] points,
     String label,
     Double zval)

See Also

PolyObj Class | PolyObj Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PolyObjFields

Steema.TeeChart.Styles.PolyObj Fields

Public Fields

IPoints
Text
ZValue

See Also

PolyObj Class | Steema.TeeChart.Styles Namespace


IPoints

Steema.TeeChart.Styles.PolyObj.IPoints Field

public Point[] IPoints

See Also

PolyObj Class | PolyObj Members | Steema.TeeChart.Styles Namespace


Text

Steema.TeeChart.Styles.PolyObj.Text Field

public String Text

See Also

PolyObj Class | PolyObj Members | Steema.TeeChart.Styles Namespace


ZValue

Steema.TeeChart.Styles.PolyObj.ZValue Field

public Double ZValue

See Also

PolyObj Class | PolyObj Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pyramid

Steema.TeeChart.Styles.Pyramid Class

Pyramid Series.

For a list of all members of this type, see Pyramid Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class Pyramid : Series , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Pyramid members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PyramidMembers

Steema.TeeChart.Styles.Pyramid all Members

Pyramid overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Series) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward | Returns whether the Series needs to draw points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush | Sets Brush characteristics for the Pyramid Series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen | Element Pen characteristics.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SizePercent | Sets size of Pyramid base relative to Chart Axis bounding width.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Pyramid Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pyramid Constructor

Overload List

public Pyramid(Steema.TeeChart.Chart)
public Pyramid()

See Also

Pyramid Class | Pyramid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pyramid Constructor

public Pyramid()

See Also

Pyramid Constructor Overload List | Pyramid Class | Pyramid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Pyramid Constructor

public Pyramid(Chart c)

See Also

Pyramid Constructor Overload List | Pyramid Class | Pyramid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PyramidEvents

Steema.TeeChart.Styles.Pyramid Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Pyramid Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PyramidFields

Steema.TeeChart.Styles.Pyramid Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Pyramid Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PyramidMethods

Steema.TeeChart.Styles.Pyramid Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Series) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward | Returns whether the Series needs to draw points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Pyramid Class | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.Pyramid.DrawValue Method

Called internally. Draws the "ValueIndex" point of the Series.
public override Void DrawValue(Int32 valueIndex)

See Also

Pyramid Class | Pyramid Members | Steema.TeeChart.Styles Namespace


DrawValuesForward

Steema.TeeChart.Styles.Pyramid.DrawValuesForward Method

Returns whether the Series needs to draw points in ascending/descending order.
public override Boolean DrawValuesForward()

See Also

Pyramid Class | Pyramid Members | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.Pyramid.MaxXValue Method

Returns the Maximum Value of the Series X Values List.
public override Double MaxXValue()

See Also

Pyramid Class | Pyramid Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.Pyramid.MaxYValue Method

Returns the Maximum Value of the Series Y Values List.
public override Double MaxYValue()

See Also

Pyramid Class | Pyramid Members | Steema.TeeChart.Styles Namespace


MinXValue

Steema.TeeChart.Styles.Pyramid.MinXValue Method

Returns the Minimum Value of the Series X Values List.
public override Double MinXValue()

See Also

Pyramid Class | Pyramid Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.Pyramid.MinYValue Method

Returns the Minimum Value of the Series Y Values List.
public override Double MinYValue()

See Also

Pyramid Class | Pyramid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.PyramidProperties

Steema.TeeChart.Styles.Pyramid Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush | Sets Brush characteristics for the Pyramid Series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen | Element Pen characteristics.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SizePercent | Sets size of Pyramid base relative to Chart Axis bounding width.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Pyramid Class | Steema.TeeChart.Styles Namespace


Brush

Steema.TeeChart.Styles.Pyramid.Brush Property

Sets Brush characteristics for the Pyramid Series.
public ChartBrush Brush {get;}

See Also

Pyramid Class | Pyramid Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Pyramid.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

Pyramid Class | Pyramid Members | Steema.TeeChart.Styles Namespace


Pen

Steema.TeeChart.Styles.Pyramid.Pen Property

Element Pen characteristics.
public ChartPen Pen {get;}

See Also

Pyramid Class | Pyramid Members | Steema.TeeChart.Styles Namespace


SizePercent

Steema.TeeChart.Styles.Pyramid.SizePercent Property

Sets size of Pyramid base relative to Chart Axis bounding width.
public Int32 SizePercent {get; set;}

See Also

Pyramid Class | Pyramid Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Radar

Steema.TeeChart.Styles.Radar Class

Radar Series.

For a list of all members of this type, see Radar Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
Steema.TeeChart.Styles.CustomPolar
public class Radar : CustomPolar , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Radar members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RadarMembers

Steema.TeeChart.Styles.Radar all Members

Radar overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle (inherited from CustomPolar) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from CustomPolar) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPolar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPolar) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPolar) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPolar) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from CustomPolar) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawRing (inherited from CustomPolar) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomPolar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
DrawZone (inherited from CustomPolar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
OnGetPointerStyle (inherited from CustomPolar) |
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AngleIncrement (inherited from CustomPolar) | Sets angle in degrees used to draw the dividing grid lines in anti-clockwise direction.
AngleValues (inherited from CustomPolar) | Gets list of angle values for each polar point.
Brush (inherited from CustomPolar) | Sets Polar Back Brush.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleLabels (inherited from CustomPolar) | Sets CicleLabel properties.
CircleLabelsFont (inherited from CustomPolar) |
CircleLabelsInside (inherited from CustomPolar) | Enables/disables the display of the axis labels inside the circle area.
CircleLabelsRotated (inherited from CustomPolar) | When true rotates the labels of a circular TeeChart series at an angle in line with the Radar/Polar circle at each Label point.
CirclePen (inherited from CustomPolar) | Determines the pen used to draw the outmost circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
ClockWiseLabels (inherited from CustomPolar) | Displays of the circle labels in a clockwise direction.
CloseCircle (inherited from CustomPolar) | Draws a Line between the last and first PolarSeries point coordinates.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Font (inherited from CustomPolar) | Sets the label font.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsMargin (inherited from CustomPolar) | Defines the distance between the CustomPolar circle and the labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen (inherited from CustomPolar) | Determines Pen used to draw the Line connecting PolarSeries points.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPolar) | Pointer contains several properties to control the formatting attributes of Points like Pen, Brush, Draw3D, Visible, etc.
RadiusIncrement (inherited from CustomPolar) | Determines the increment used to draw the ring grid lines.
RadiusValues (inherited from CustomPolar) | Gets list of radius values for each polar point.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from CustomPolar) | Sets Transparency level from 0 to 100%.
TreatNaNAsNull (inherited from CustomPolar) |
TreatNulls (inherited from CustomPolar) |
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Radar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Radar Constructor

Overload List

public Radar()
public Radar(Steema.TeeChart.Chart)

See Also

Radar Class | Radar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Radar Constructor

public Radar(Chart c)

See Also

Radar Constructor Overload List | Radar Class | Radar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Radar Constructor

public Radar()

See Also

Radar Constructor Overload List | Radar Class | Radar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RadarEvents

Steema.TeeChart.Styles.Radar Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle (inherited from CustomPolar) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Radar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RadarFields

Steema.TeeChart.Styles.Radar Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Radar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RadarMethods

Steema.TeeChart.Styles.Radar Methods

Public Methods

Add (inherited from CustomPolar) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomPolar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPolar) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPolar) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPolar) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from CustomPolar) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawRing (inherited from CustomPolar) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomPolar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
DrawZone (inherited from CustomPolar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
OnGetPointerStyle (inherited from CustomPolar) |
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Radar Class | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.Radar.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

Radar Class | Radar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RadarProperties

Steema.TeeChart.Styles.Radar Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AngleIncrement (inherited from CustomPolar) | Sets angle in degrees used to draw the dividing grid lines in anti-clockwise direction.
AngleValues (inherited from CustomPolar) | Gets list of angle values for each polar point.
Brush (inherited from CustomPolar) | Sets Polar Back Brush.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleLabels (inherited from CustomPolar) | Sets CicleLabel properties.
CircleLabelsFont (inherited from CustomPolar) |
CircleLabelsInside (inherited from CustomPolar) | Enables/disables the display of the axis labels inside the circle area.
CircleLabelsRotated (inherited from CustomPolar) | When true rotates the labels of a circular TeeChart series at an angle in line with the Radar/Polar circle at each Label point.
CirclePen (inherited from CustomPolar) | Determines the pen used to draw the outmost circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
ClockWiseLabels (inherited from CustomPolar) | Displays of the circle labels in a clockwise direction.
CloseCircle (inherited from CustomPolar) | Draws a Line between the last and first PolarSeries point coordinates.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Font (inherited from CustomPolar) | Sets the label font.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsMargin (inherited from CustomPolar) | Defines the distance between the CustomPolar circle and the labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen (inherited from CustomPolar) | Determines Pen used to draw the Line connecting PolarSeries points.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPolar) | Pointer contains several properties to control the formatting attributes of Points like Pen, Brush, Draw3D, Visible, etc.
RadiusIncrement (inherited from CustomPolar) | Determines the increment used to draw the ring grid lines.
RadiusValues (inherited from CustomPolar) | Gets list of radius values for each polar point.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from CustomPolar) | Sets Transparency level from 0 to 100%.
TreatNaNAsNull (inherited from CustomPolar) |
TreatNulls (inherited from CustomPolar) |
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Radar Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Radar.Description Property

public override String Description {get;}

See Also

Radar Class | Radar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Renko

Steema.TeeChart.Styles.Renko Class

The Renko chart financial indicator.

For a list of all members of this type, see Renko Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
Steema.TeeChart.Styles.OHLC
Steema.TeeChart.Styles.CustomTimeOHLC
public class Renko : CustomTimeOHLC , ICloneable, ISeriesPointer

Remarks

The Renko chart is a trend following technique. It got its name from a Japanese word "renga" meaning bricks. In Renko chart line brick is drawn in the direction of the prior move only if prices move by a minimum amount which is equivalent to the box size that are always equal in size.

Renko charts are always based on the closing prices. Renko bricks are drawn after comparing, that day’s close with the previous brick (high or low). A "box size" which determines the minimum price change to show is specified.

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Renko members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RenkoMembers

Steema.TeeChart.Styles.Renko all Members

Renko overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValue | Event triggers on Renko Brick plot. Can be used to monitor reversals.
AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add | Adds new point with specified dateTime date and double volume, open, high, low and close values.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Custom) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from OHLC) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString |
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue |
MaxYValue |
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue |
MinYValue |
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
BoxLabels |
BoxSize (inherited from CustomTimeOHLC) |
BoxType (inherited from CustomTimeOHLC) | Use BoxType to change box sensitivity according to the data range.
Brush (inherited from Custom) | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
CloseValues (inherited from OHLC) | Gets and sets all Stock market Close values.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DateValues (inherited from OHLC) | Gets and sets all Stock market Date values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
DownSwingColor | Color for downward trend bricks.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HighValues (inherited from OHLC) | Gets and sets all Stock market High values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IncrementAsBox (inherited from CustomTimeOHLC) | When true, Chart will try to size grid to box size.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from OHLC) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
LowValues (inherited from OHLC) | Gets and sets all Stock market Low values.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OpenValues (inherited from OHLC) | Gets and sets all Stock market Open values.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Period (inherited from CustomTimeOHLC) |
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UpSwingColor | Color for upward trend bricks.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VData | Access characteristics of the Volume data. VData is a sub-series (of type Volume) of the Renko Series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
VolumeValues | Gets and sets all event Volume values.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Renko Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Renko Constructor

Overload List

public Renko()
public Renko(Steema.TeeChart.Chart)

See Also

Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Renko Constructor

public Renko(Chart c)

See Also

Renko Constructor Overload List | Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Renko Constructor

public Renko()

See Also

Renko Constructor Overload List | Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RenkoEvents

Steema.TeeChart.Styles.Renko Events

Public Events

AfterDrawValue | Event triggers on Renko Brick plot. Can be used to monitor reversals.
AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Renko Class | Steema.TeeChart.Styles Namespace


AfterDrawValue

Steema.TeeChart.Styles.Renko.AfterDrawValue Event

Event triggers on Renko Brick plot. Can be used to monitor reversals.
public RenkoDrawValueEventHandler  AfterDrawValue

See Also

Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RenkoFields

Steema.TeeChart.Styles.Renko Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Renko Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RenkoMethods

Steema.TeeChart.Styles.Renko Methods

Public Methods

Add | Adds new point with specified dateTime date and double volume, open, high, low and close values.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Custom) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from OHLC) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString |
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue |
MaxYValue |
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue |
MinYValue |
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Renko Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Renko.Add Method

Overload List

Adds new point with specified dateTime date and double volume, open, high, low and close values.

public Int32 Add(System.DateTime, System.Double, System.Double, System.Double, System.Double, System.Double)

See Also

Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Renko.Add Method

Adds new point with specified dateTime date and double volume, open, high, low and close values.
public Int32 Add(DateTime aDate,
     Double volume,
     Double open,
     Double high,
     Double low,
     Double close)

Return Value

ValueList index of added point

See Also

Add Overload List | Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Renko.Clicked Method

Overload List

Calculates if any point is at XY position.

public override Int32 Clicked(System.Int32, System.Int32)

See Also

Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Renko.Clicked Method

Calculates if any point is at XY position.
public override Int32 Clicked(Int32 x,
     Int32 y)

Return Value

Point index

See Also

Clicked Overload List | Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.Renko.Draw Method

public override Void Draw()

See Also

Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


GetMarkValue

Steema.TeeChart.Styles.Renko.GetMarkValue Method

Returns corresponding Point value suitable for displaying at Series Marks.
public override Double GetMarkValue(Int32 valueIndex)

See Also

Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


LegendString

Steema.TeeChart.Styles.Renko.LegendString Method

public override String LegendString(Int32 legendIndex,
     LegendTextStyles legendTextStyle)

See Also

Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.Renko.MaxXValue Method

public override Double MaxXValue()

See Also

Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.Renko.MaxYValue Method

public override Double MaxYValue()

See Also

Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


MinXValue

Steema.TeeChart.Styles.Renko.MinXValue Method

public override Double MinXValue()

See Also

Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.Renko.MinYValue Method

public override Double MinYValue()

See Also

Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.Renko.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RenkoProperties

Steema.TeeChart.Styles.Renko Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
BoxLabels |
BoxSize (inherited from CustomTimeOHLC) |
BoxType (inherited from CustomTimeOHLC) | Use BoxType to change box sensitivity according to the data range.
Brush (inherited from Custom) | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
CloseValues (inherited from OHLC) | Gets and sets all Stock market Close values.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DateValues (inherited from OHLC) | Gets and sets all Stock market Date values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
DownSwingColor | Color for downward trend bricks.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HighValues (inherited from OHLC) | Gets and sets all Stock market High values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IncrementAsBox (inherited from CustomTimeOHLC) | When true, Chart will try to size grid to box size.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from OHLC) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
LowValues (inherited from OHLC) | Gets and sets all Stock market Low values.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
OpenValues (inherited from OHLC) | Gets and sets all Stock market Open values.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Period (inherited from CustomTimeOHLC) |
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UpSwingColor | Color for upward trend bricks.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VData | Access characteristics of the Volume data. VData is a sub-series (of type Volume) of the Renko Series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
VolumeValues | Gets and sets all event Volume values.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Renko Class | Steema.TeeChart.Styles Namespace


BoxLabels

Steema.TeeChart.Styles.Renko.BoxLabels Property

public BoxLabel[] BoxLabels {get;}

See Also

Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Renko.Description Property

public override String Description {get;}

See Also

Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


DownSwingColor

Steema.TeeChart.Styles.Renko.DownSwingColor Property

Color for downward trend bricks.
public Color DownSwingColor {get; set;}

See Also

Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


UpSwingColor

Steema.TeeChart.Styles.Renko.UpSwingColor Property

Color for upward trend bricks.
public Color UpSwingColor {get; set;}

See Also

Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


VData

Steema.TeeChart.Styles.Renko.VData Property

Access characteristics of the Volume data. VData is a sub-series (of type Volume) of the Renko Series.
public Bar VData {get; set;}

See Also

Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


VolumeValues

Steema.TeeChart.Styles.Renko.VolumeValues Property

Gets and sets all event Volume values.
public ValueList VolumeValues {get; set;}

See Also

Renko Class | Renko Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Renko.BoxLabel

Steema.TeeChart.Styles.Renko.BoxLabel ValueType

For a list of all members of this type, see BoxLabel Members

System.Object
System.ValueType
public sealed struct BoxLabel : ValueType

See Also

BoxLabel Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Renko.BoxLabelMembers

Steema.TeeChart.Styles.Renko.BoxLabel all Members

BoxLabel overview

Constructors

Steema.TeeChart.Styles.Renko.BoxLabel..ctor

Public Fields

BoxDate
BoxValue
Index

See Also

BoxLabel Structure | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Renko+BoxLabel Constructor

public Renko+BoxLabel(Int32 idx,
     Double date,
     Double value)

See Also

BoxLabel Structure | BoxLabel Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Renko.BoxLabelFields

Steema.TeeChart.Styles.Renko.BoxLabel Fields

Public Fields

BoxDate
BoxValue
Index

See Also

BoxLabel Structure | Steema.TeeChart.Styles Namespace


BoxDate

Steema.TeeChart.Styles.Renko+BoxLabel.BoxDate Field

public Double BoxDate

See Also

BoxLabel Structure | BoxLabel Members | Steema.TeeChart.Styles Namespace


BoxValue

Steema.TeeChart.Styles.Renko+BoxLabel.BoxValue Field

public Double BoxValue

See Also

BoxLabel Structure | BoxLabel Members | Steema.TeeChart.Styles Namespace


Index

Steema.TeeChart.Styles.Renko+BoxLabel.Index Field

public Int32 Index

See Also

BoxLabel Structure | BoxLabel Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RenkoBar

Steema.TeeChart.Styles.RenkoBar Class

For a list of all members of this type, see RenkoBar Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomBar
Steema.TeeChart.Styles.Bar
public class RenkoBar : Bar , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

RenkoBar members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RenkoBarMembers

Steema.TeeChart.Styles.RenkoBar all Members

RenkoBar overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetBarStyle (inherited from CustomBar) | Occurs when series bars are painted.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomBar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BarMargin (inherited from CustomBar) | Returns side margin amount in pixels.
BarRectangle (inherited from CustomBar) | For internal use.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Bar) | Returns the Screen X pixel coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Bar) | Returns the Screen Y pixel coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomBar) | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawBar (inherited from Bar) | Internal use.
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from CustomBar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetOriginPos (inherited from Bar) | Returns the corresponding screen pixels coordinate of the leftmost horizontal bar edge.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue |
MaxYValue (inherited from Bar) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Bar) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Bar) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointOrigin (inherited from CustomBar) | For internal use.
PrepareForGallery (inherited from CustomBar) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from CustomBar) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoMarkPosition (inherited from CustomBar) | Repositions Marks on BarSeries to prevent overlapping.
BarBounds (inherited from CustomBar) | Coordinates of current Bar point being displayed.
BarStyle (inherited from CustomBar) | Defines the Bar shape used to draw Bars.
BarWidthPercent (inherited from Bar) | Determines the percent of total Bar width used.
BevelSize (inherited from CustomBar) | Amount in pixels of the bar bevel. Used only when BarStyle property is Bevel (only in 2D and 3D orthogonal display modes)
Brush (inherited from CustomBar) | Defines the Brush used to fill Bars.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent (inherited from CustomBar) |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBarWidth (inherited from CustomBar) |
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from CustomBar) | Darkens sides of bars to enhance 3D effect.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthPercent (inherited from CustomBar) | Defines the percentage, from 0 to 100, that the bars will need in the "Z" depth space direction.
Description (inherited from Bar) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from CustomBar) | Defines the color Gradient used to fill the Bars.
GradientRelative (inherited from CustomBar) | When Gradient is Visible, calculates Colors based on highest bar.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksLocation (inherited from CustomBar) | Sets the alignment of the Mark into the Bars.
MarksOnBar (inherited from CustomBar) | Sets a postition of the Marks into the Bars.
MiddleZ (inherited from Series) | For internal use.
MultiBar (inherited from CustomBar) | Determines how multiple BarSeries will be displayed in the same Chart.
NumGallerySeries (inherited from Series) | For internal use.
OffsetPercent (inherited from CustomBar) | Sets the Bar displacement as percent of Bar size.
Origin (inherited from CustomBar) | Sets the common bottom value used for all Bar points.
Pen (inherited from CustomBar) | Pen used to draw the Bar rectangles.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow (inherited from CustomBar) | Defines the Shadow used to draw behind the Bars.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideMargins (inherited from CustomBar) | Sets a margin between Chart rectangle and Bars.
StackGroup (inherited from CustomBar) | Allows stacking independent Series within the same Chart.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickLines (inherited from CustomBar) | Pen used to draw "tick" lines across each bar.
Title (inherited from Series) | Series description to show in Legend and editors.
UseOrigin (inherited from CustomBar) | Allows Bars to be bottom aligned to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin (inherited from CustomBar) | System.Obsolete: Please use Origin property.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

RenkoBar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RenkoBar Constructor

Overload List

public RenkoBar()
public RenkoBar(Steema.TeeChart.Chart)
public RenkoBar(Steema.TeeChart.Styles.Renko)

See Also

RenkoBar Class | RenkoBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RenkoBar Constructor

public RenkoBar(Renko parentRenko)

See Also

RenkoBar Constructor Overload List | RenkoBar Class | RenkoBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RenkoBar Constructor

public RenkoBar(Chart c)

See Also

RenkoBar Constructor Overload List | RenkoBar Class | RenkoBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RenkoBar Constructor

public RenkoBar()

See Also

RenkoBar Constructor Overload List | RenkoBar Class | RenkoBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RenkoBarEvents

Steema.TeeChart.Styles.RenkoBar Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetBarStyle (inherited from CustomBar) | Occurs when series bars are painted.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

RenkoBar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RenkoBarFields

Steema.TeeChart.Styles.RenkoBar Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

RenkoBar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RenkoBarMethods

Steema.TeeChart.Styles.RenkoBar Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from CustomBar) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BarMargin (inherited from CustomBar) | Returns side margin amount in pixels.
BarRectangle (inherited from CustomBar) | For internal use.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Bar) | Returns the Screen X pixel coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Bar) | Returns the Screen Y pixel coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomBar) | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawBar (inherited from Bar) | Internal use.
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomBar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from CustomBar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetOriginPos (inherited from Bar) | Returns the corresponding screen pixels coordinate of the leftmost horizontal bar edge.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue |
MaxYValue (inherited from Bar) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Bar) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Bar) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointOrigin (inherited from CustomBar) | For internal use.
PrepareForGallery (inherited from CustomBar) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from CustomBar) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

RenkoBar Class | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.RenkoBar.MaxXValue Method

public override Double MaxXValue()

See Also

RenkoBar Class | RenkoBar Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RenkoBarProperties

Steema.TeeChart.Styles.RenkoBar Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AutoMarkPosition (inherited from CustomBar) | Repositions Marks on BarSeries to prevent overlapping.
BarBounds (inherited from CustomBar) | Coordinates of current Bar point being displayed.
BarStyle (inherited from CustomBar) | Defines the Bar shape used to draw Bars.
BarWidthPercent (inherited from Bar) | Determines the percent of total Bar width used.
BevelSize (inherited from CustomBar) | Amount in pixels of the bar bevel. Used only when BarStyle property is Bevel (only in 2D and 3D orthogonal display modes)
Brush (inherited from CustomBar) | Defines the Brush used to fill Bars.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent (inherited from CustomBar) |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBarWidth (inherited from CustomBar) |
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from CustomBar) | Darkens sides of bars to enhance 3D effect.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
DepthPercent (inherited from CustomBar) | Defines the percentage, from 0 to 100, that the bars will need in the "Z" depth space direction.
Description (inherited from Bar) | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient (inherited from CustomBar) | Defines the color Gradient used to fill the Bars.
GradientRelative (inherited from CustomBar) | When Gradient is Visible, calculates Colors based on highest bar.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarksLocation (inherited from CustomBar) | Sets the alignment of the Mark into the Bars.
MarksOnBar (inherited from CustomBar) | Sets a postition of the Marks into the Bars.
MiddleZ (inherited from Series) | For internal use.
MultiBar (inherited from CustomBar) | Determines how multiple BarSeries will be displayed in the same Chart.
NumGallerySeries (inherited from Series) | For internal use.
OffsetPercent (inherited from CustomBar) | Sets the Bar displacement as percent of Bar size.
Origin (inherited from CustomBar) | Sets the common bottom value used for all Bar points.
Pen (inherited from CustomBar) | Pen used to draw the Bar rectangles.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
Shadow (inherited from CustomBar) | Defines the Shadow used to draw behind the Bars.
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideMargins (inherited from CustomBar) | Sets a margin between Chart rectangle and Bars.
StackGroup (inherited from CustomBar) | Allows stacking independent Series within the same Chart.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TickLines (inherited from CustomBar) | Pen used to draw "tick" lines across each bar.
Title (inherited from Series) | Series description to show in Legend and editors.
UseOrigin (inherited from CustomBar) | Allows Bars to be bottom aligned to the Origin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YOrigin (inherited from CustomBar) | System.Obsolete: Please use Origin property.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

RenkoBar Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RenkoDrawValueEventArgs

Steema.TeeChart.Styles.RenkoDrawValueEventArgs Class

Variables describe brick characteristics when plotted.

For a list of all members of this type, see RenkoDrawValueEventArgs Members

System.Object
System.EventArgs
public class RenkoDrawValueEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

RenkoDrawValueEventArgs members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RenkoDrawValueEventArgsMembers

Steema.TeeChart.Styles.RenkoDrawValueEventArgs all Members

RenkoDrawValueEventArgs overview

Constructors

Constructor

Public Properties

ColIndex
High
IsUp
Low
Reversal

See Also

RenkoDrawValueEventArgs Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RenkoDrawValueEventArgs Constructor

public RenkoDrawValueEventArgs(Int32 index,
     Double high,
     Double low,
     Boolean isUp,
     Boolean reversal)

See Also

RenkoDrawValueEventArgs Class | RenkoDrawValueEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RenkoDrawValueEventArgsProperties

Steema.TeeChart.Styles.RenkoDrawValueEventArgs Properties

Public Properties

ColIndex
High
IsUp
Low
Reversal

See Also

RenkoDrawValueEventArgs Class | Steema.TeeChart.Styles Namespace


ColIndex

Steema.TeeChart.Styles.RenkoDrawValueEventArgs.ColIndex Property

public Int32 ColIndex {get; set;}

See Also

RenkoDrawValueEventArgs Class | RenkoDrawValueEventArgs Members | Steema.TeeChart.Styles Namespace


High

Steema.TeeChart.Styles.RenkoDrawValueEventArgs.High Property

public Double High {get; set;}

See Also

RenkoDrawValueEventArgs Class | RenkoDrawValueEventArgs Members | Steema.TeeChart.Styles Namespace


IsUp

Steema.TeeChart.Styles.RenkoDrawValueEventArgs.IsUp Property

public Boolean IsUp {get; set;}

See Also

RenkoDrawValueEventArgs Class | RenkoDrawValueEventArgs Members | Steema.TeeChart.Styles Namespace


Low

Steema.TeeChart.Styles.RenkoDrawValueEventArgs.Low Property

public Double Low {get; set;}

See Also

RenkoDrawValueEventArgs Class | RenkoDrawValueEventArgs Members | Steema.TeeChart.Styles Namespace


Reversal

Steema.TeeChart.Styles.RenkoDrawValueEventArgs.Reversal Property

public Boolean Reversal {get; set;}

See Also

RenkoDrawValueEventArgs Class | RenkoDrawValueEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.RenkoDrawValueEventHandler

Steema.TeeChart.Styles.RenkoDrawValueEventHandler Delegate

Used with event triggered when Renko bricks are plotted.
public delegate RenkoDrawValueEventHandler (Object sender,
     RenkoDrawValueEventArgs e)

Parameters

sender
e

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Series

Steema.TeeChart.Styles.Series Class

The base class for all TeeChart Series styles.

For a list of all members of this type, see Series Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class Series : TeeBase , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Series members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMembers

Steema.TeeChart.Styles.Series all Members

Series overview

Constructors

Constructor Required for Windows.Forms Class Composition Designer support

Public Events

AfterDrawValues | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter | Occurs when the mouse pointer enters the control.
MouseLeave | Occurs when the mouse pointer leaves the control.

Public Fields

AutoDepth | Constant field for internal use.
AutoZOrder | Constant field for internal use.
bBrush |
GetHorizAxis | Returns the horizontal axis associated with the series.
GetVertAxis | Returns the vertical axis associated with the series.
HasZValues | Returns true if the series has ZValues.
mandatory |
manualData |
notMandatory |
UseAxis | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add | Adds a new null (transparent) point.
AddNull | System.Obsolete: Please use Add() method without parameters.
AddNullXY | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign | Copies all properties from one Series component to another.
AssignDispose |
AssignFormat |
AssignValues | Adds all Values from Source series.
BeginUpdate | Recalculates the function just one time, when finished adding points.
CalcPosValue | Returns "Value" parameter coordinate position in pixels.
CalcXPos | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue | Returns the size in pixels corresponding to value parameter in vertical axis scales.
ChangeType | Replaces ASeries object with a new Series object of another class.
CheckDataSource | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder | Reorders points according to Order property of X,Y,etc value lists.
Clear | Removes all points, texts and Colors from the Series.
Clicked |
Clone | Returns a new Series, copy of this original.
ColorRange | This method will change the Color of a specified range of points.
CreateNewSeries | Creates a new Series object and sets the Name, Chart, Sub-Style and Function properties.
Delete | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue |
DrawMarksSeries |
DrawSeries | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward | Returns whether Series draws its points in ascending/descending order.
EndUpdate | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D |
GetBitmapEditor | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue | Returns corresponding Point value suitable for displaying at Series Marks.
HasColors |
HasLabels |
HasNoMandatoryValues |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf | Validates Series datasource.
LastDisplayedIndex | Returns the index of the series point that is displayed first when the series is drawn.
LegendString | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue | Returns Maximum Z Value.
MinXValue | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue | Returns Minimum Z Value.
NewFromType | Creates a new series from the System.Type of an existing series object.
PrepareForGallery |
RefreshSeries | Recalculates all dependent Series points again.
Repaint | Forces the Chart to Repaint.
ScreenPointToValuePoint | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull | Sets the specified series point to a null (transparent) point.
SetSubGallery | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName | System.Obsolete: Please use ToString() method.
ToString | Overridden ToString() method.
ValueColor | Returns the colour of the index point.
ValueMarkText | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource |
XScreenToValue | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color | Default color for all points.
ColorEach | Draws points with different preset Colors.
ColorEachPoint | System.Obsolete: Please use ColorEach property.
ColorMember | Gets or sets the Datasource Color Field
Colors | Access to the stored Color Array, if created, for the Series.
Count | Returns the number of points in the Series.
Cursor | Cursor displayed when mouse is over a series point.
CustomHorizAxis | Specified the custom horizontal axis for the series.
CustomVertAxis | Specified the custom vertical axis for the series.
DataSource | Object to load data from.
DateTimeFormat | Determines the DateTimeFormat to display point values.
DefaultNullValue | Sets or returns the value to be used as a null value within the series.
Depth | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
EndZ | For internal use.
FirstVisibleIndex | Returns the index of the Series' first visible point.
Function | Function object to calculate values.
HorizAxis | Horizontal axis to associate to this Series.
Item | Point characteristics
LabelMember | Gets or sets the Datasource Label Field
Labels | Accesses a list of series point labels.
LastVisibleIndex | Returns the index of the Series' last visible point.
Marks | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ | For internal use.
NumGallerySeries | For internal use.
PercentFormat | Sets the Format to display point values as percentage.
SeriesColor | System.Obsolete: Use the Series Color property.
SeriesData |
ShowInLegend | Displays this Series Title in Legend.
StartZ | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title | Series description to show in Legend and editors.
ValueFormat | Determines the Format to display point values.
ValuesLists | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis | Determines Vertical axis associated to this Series.
Visible | Shows or hides this series.
XValues | Values defining horizontal point positions.
YValues | Values defining vertical point positions.
ZOrder | Determines where on the depth axis the Series is drawn.

See Also

Series Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Series Constructor

Required for Windows.Forms Class Composition Designer support
public Series(IContainer container)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesEvents

Steema.TeeChart.Styles.Series Events

Public Events

AfterDrawValues | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter | Occurs when the mouse pointer enters the control.
MouseLeave | Occurs when the mouse pointer leaves the control.

See Also

Series Class | Steema.TeeChart.Styles Namespace


AfterDrawValues

Steema.TeeChart.Styles.Series.AfterDrawValues Event

Called just after drawing all series points, and before drawing other series that are in front.
public PaintChartEventHandler  AfterDrawValues

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


BeforeDrawPoint

Steema.TeeChart.Styles.Series.BeforeDrawPoint Event

Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
public BeforeDrawPointEventHandler  BeforeDrawPoint

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


BeforeDrawValues

Steema.TeeChart.Styles.Series.BeforeDrawValues Event

Called just before drawing all series points, and after drawing other series that are behind.
public PaintChartEventHandler  BeforeDrawValues

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


GetSeriesMark

Steema.TeeChart.Styles.Series.GetSeriesMark Event

Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
public GetSeriesMarkEventHandler  GetSeriesMark

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


MouseEnter

Steema.TeeChart.Styles.Series.MouseEnter Event

Occurs when the mouse pointer enters the control.
public EventHandler  MouseEnter

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


MouseLeave

Steema.TeeChart.Styles.Series.MouseLeave Event

Occurs when the mouse pointer leaves the control.
public EventHandler  MouseLeave

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesFields

Steema.TeeChart.Styles.Series Fields

Public Fields

AutoDepth | Constant field for internal use.
AutoZOrder | Constant field for internal use.
bBrush |
GetHorizAxis | Returns the horizontal axis associated with the series.
GetVertAxis | Returns the vertical axis associated with the series.
HasZValues | Returns true if the series has ZValues.
mandatory |
manualData |
notMandatory |
UseAxis | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Series Class | Steema.TeeChart.Styles Namespace


AutoDepth

Steema.TeeChart.Styles.Series.AutoDepth Field

Constant field for internal use.
public const Int32 AutoDepth

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


AutoZOrder

Steema.TeeChart.Styles.Series.AutoZOrder Field

Constant field for internal use.
public const Int32 AutoZOrder

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


bBrush

Steema.TeeChart.Styles.Series.bBrush Field

public ChartBrush bBrush

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


GetHorizAxis

Steema.TeeChart.Styles.Series.GetHorizAxis Field

Returns the horizontal axis associated with the series.
public Axis GetHorizAxis

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


GetVertAxis

Steema.TeeChart.Styles.Series.GetVertAxis Field

Returns the vertical axis associated with the series.
public Axis GetVertAxis

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


HasZValues

Steema.TeeChart.Styles.Series.HasZValues Field

Returns true if the series has ZValues.
public Boolean HasZValues

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


mandatory

Steema.TeeChart.Styles.Series.mandatory Field

public ValueList mandatory

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


manualData

Steema.TeeChart.Styles.Series.manualData Field

public Boolean manualData

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


notMandatory

Steema.TeeChart.Styles.Series.notMandatory Field

public ValueList notMandatory

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


UseAxis

Steema.TeeChart.Styles.Series.UseAxis Field

Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).
public Boolean UseAxis

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMethods

Steema.TeeChart.Styles.Series Methods

Public Methods

Add | Adds a new null (transparent) point.
AddNull | System.Obsolete: Please use Add() method without parameters.
AddNullXY | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign | Copies all properties from one Series component to another.
AssignDispose |
AssignFormat |
AssignValues | Adds all Values from Source series.
BeginUpdate | Recalculates the function just one time, when finished adding points.
CalcPosValue | Returns "Value" parameter coordinate position in pixels.
CalcXPos | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue | Returns the size in pixels corresponding to value parameter in vertical axis scales.
ChangeType | Replaces ASeries object with a new Series object of another class.
CheckDataSource | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder | Reorders points according to Order property of X,Y,etc value lists.
Clear | Removes all points, texts and Colors from the Series.
Clicked |
Clone | Returns a new Series, copy of this original.
ColorRange | This method will change the Color of a specified range of points.
CreateNewSeries | Creates a new Series object and sets the Name, Chart, Sub-Style and Function properties.
Delete | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue |
DrawMarksSeries |
DrawSeries | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward | Returns whether Series draws its points in ascending/descending order.
EndUpdate | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D |
GetBitmapEditor | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue | Returns corresponding Point value suitable for displaying at Series Marks.
HasColors |
HasLabels |
HasNoMandatoryValues |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf | Validates Series datasource.
LastDisplayedIndex | Returns the index of the series point that is displayed first when the series is drawn.
LegendString | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the Maximum Value of the Series X Values List.
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue | Returns Maximum Z Value.
MinXValue | Returns the Minimum Value of the Series X Values List.
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue | Returns Minimum Z Value.
NewFromType | Creates a new series from the System.Type of an existing series object.
PrepareForGallery |
RefreshSeries | Recalculates all dependent Series points again.
Repaint | Forces the Chart to Repaint.
ScreenPointToValuePoint | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull | Sets the specified series point to a null (transparent) point.
SetSubGallery | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName | System.Obsolete: Please use ToString() method.
ToString | Overridden ToString() method.
ValueColor | Returns the colour of the index point.
ValueMarkText | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource |
XScreenToValue | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Series Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Overload List

Adds a new null (transparent) point.

public Int32 Add()
public Int32 Add(System.Nullable`1[System.Int32])

Adds a new point with specified value.

public Int32 Add(System.Int32)
public Int32 Add(System.Nullable`1[System.Double])

Adds a new point with specified value.

public Int32 Add(System.Double)
public Int32 Add(System.Nullable`1[System.Int64])

Adds a new point with specified value.

public Int32 Add(System.Int64)

Adds a new point with specified value.

public Int32 Add(System.UInt64)

Adds the array of unsigned long values.

public Void Add(System.UInt64[])
public Void Add(System.Nullable`1[System.Int64][])

Adds the array of long values.

public Void Add(System.Int64[])
public Int32 Add(System.Nullable`1[System.Single])

Adds a new point with specified value.

public Int32 Add(System.Single)
public Int32 Add(System.Nullable`1[System.Double], System.String)

Adds a new point with specified value and text.

public Int32 Add(System.Double, System.String)
public Int32 Add(System.Nullable`1[System.Double], System.Nullable`1[System.Double])

Adds a new point with specified x and y values.

public abstract Int32 Add(System.Double, System.Double)

Adds the pair of floating point x- and y-pixel coordinates

public Int32 Add(System.Drawing.PointF)
public Int32 Add(System.Nullable`1[System.Double], System.Nullable`1[System.Double], System.String)

Adds a new point with specified x,y values and text.

public abstract Int32 Add(System.Double, System.Double, System.String)
public Int32 Add(System.Nullable`1[System.Double], System.Nullable`1[System.Double], System.String, System.Drawing.Color)

Adds a new point with specified x,y values, text and color.

public Int32 Add(System.Double, System.Double, System.String, System.Drawing.Color)
public Int32 Add(System.DateTime, System.Nullable`1[System.Double], System.String, System.Drawing.Color)

Adds a new Datetime point to a Series, label and color.

public Int32 Add(System.DateTime, System.Double, System.String, System.Drawing.Color)
public Int32 Add(System.Nullable`1[System.Double], System.Nullable`1[System.Double], System.Drawing.Color)

Adds a new point with specified x and y values and color.

public Int32 Add(System.Double, System.Double, System.Drawing.Color)
public Int32 Add(System.Nullable`1[System.Double], System.String, System.Drawing.Color)

Adds a new point with specified value, text and color.

public Int32 Add(System.Double, System.String, System.Drawing.Color)
public Int32 Add(System.Nullable`1[System.Double], System.Drawing.Color)

Adds a new point with specified value and color.

public Int32 Add(System.Double, System.Drawing.Color)

Adds a new null point with specified text.

public abstract Int32 Add(System.String)

Adds all points in source Series.

public Void Add(Steema.TeeChart.Styles.Series)

Adds generic type T.

public Void Add(T)

Adds the X and Y arrays, optionally appending the values to any existing ones.

public abstract Void Add(System.Array, System.Array, System.Boolean)

Adds the X and Y arrays.

public Void Add(System.Array, System.Array)
public Void Add(System.Nullable`1[System.Double][])

Adds the array of double values.

public Void Add(System.Double[])
public Void Add(System.Nullable`1[System.Single][])

Adds the array of float values.

public Void Add(System.Single[])
public Void Add(System.Nullable`1[System.Int32][])

Adds the array of integer values.

public Void Add(System.Int32[])

Adds a new point with specified value.

public Int32 Add(System.UInt32)

Adds the array of unsigned long values.

public Void Add(System.UInt32[])

Adds the collection of objects that implement the IList interface.

public Void Add(System.Collections.IList)
public Int32 Add(System.DateTime, System.Nullable`1[System.Double])

Adds new point with specified DateTime x and Double y values.

public Int32 Add(System.DateTime, System.Double)

Adds new point with specified DateTime x and DateTime y values.

public Int32 Add(System.DateTime, System.DateTime)
public Int32 Add(System.DateTime, System.Nullable`1[System.Double], System.Drawing.Color)

Adds new point with specified DateTime x, Double y values and Color.

public Int32 Add(System.DateTime, System.Double, System.Drawing.Color)
public Int32 Add(System.DateTime, System.Nullable`1[System.Double], System.String)

Adds new point with specified DateTime x, Double y values and Text.

public Int32 Add(System.DateTime, System.Double, System.String)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds new point with specified DateTime x, Double y values and Text.
public Int32 Add(DateTime x,
     Double y,
     String text)

Return Value

ValueList index of added point

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

public Int32 Add(DateTime x,
     Nullable<Double> y,
     String text)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds new point with specified DateTime x, Double y values and Color.
public Int32 Add(DateTime x,
     Double y,
     Color c)

Return Value

ValueList index of added point

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

public Int32 Add(DateTime x,
     Nullable<Double> y,
     Color c)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds new point with specified DateTime x and DateTime y values.
public Int32 Add(DateTime x,
     DateTime y)

Return Value

ValueList index of added point

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds new point with specified DateTime x and Double y values.
public Int32 Add(DateTime x,
     Double y)

Return Value

ValueList index of added point

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

public Int32 Add(DateTime x,
     Nullable<Double> y)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds the collection of objects that implement the IList interface.
public Void Add(IList list)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds the array of unsigned long values.
public Void Add(UInt32[] values)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds a new point with specified value.
public Int32 Add(UInt32 value)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds the array of integer values.
public Void Add(Int32[] values)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

public Void Add(Nullable`1[] values)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds the array of float values.
public Void Add(Single[] values)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds the array of double values.
public Void Add(Double[] values)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds the X and Y arrays.
public Void Add(Array xValues,
     Array yValues)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds the X and Y arrays, optionally appending the values to any existing ones.
public abstract Void Add(Array xValues,
     Array yValues,
     Boolean append)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds generic type T.
public Void Add<T>(T TType)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds all points in source Series.
public Void Add(Series source)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds a new null point with specified text.
public abstract Int32 Add(String text)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds a new point with specified value and color.
public Int32 Add(Double value,
     Color color)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

public Int32 Add(Nullable<Double> value,
     Color color)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds a new point with specified value, text and color.
public Int32 Add(Double value,
     String text,
     Color color)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

public Int32 Add(Nullable<Double> value,
     String text,
     Color color)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds a new point with specified x and y values and color.
public Int32 Add(Double x,
     Double y,
     Color color)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

public Int32 Add(Nullable<Double> x,
     Nullable<Double> y,
     Color color)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds a new Datetime point to a Series, label and color.
public Int32 Add(DateTime aDate,
     Double y,
     String text,
     Color color)

Parameters

aDate
Datetime value
y
Y value
text
Point text
color
Point color

Return Value

index of added point

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

public Int32 Add(DateTime aDate,
     Nullable<Double> y,
     String text,
     Color color)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds a new point with specified x,y values, text and color.
public Int32 Add(Double x,
     Double y,
     String text,
     Color color)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

public Int32 Add(Nullable<Double> x,
     Nullable<Double> y,
     String text,
     Color color)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds a new point with specified x,y values and text.
public abstract Int32 Add(Double x,
     Double y,
     String text)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

public Int32 Add(Nullable<Double> x,
     Nullable<Double> y,
     String text)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds the pair of floating point x- and y-pixel coordinates
public Int32 Add(PointF p)

Return Value

ValueList index of added point

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds a new point with specified x and y values.
public abstract Int32 Add(Double x,
     Double y)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

public Int32 Add(Nullable<Double> x,
     Nullable<Double> y)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds a new point with specified value and text.
public Int32 Add(Double value,
     String text)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

public Int32 Add(Nullable<Double> value,
     String text)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds a new point with specified value.
public Int32 Add(Single value)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

public Int32 Add(Nullable<Single> value)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds the array of long values.
public Void Add(Int64[] values)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds the array of unsigned long values.
public Void Add(UInt64[] values)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds a new point with specified value.
public Int32 Add(UInt64 value)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds a new point with specified value.
public Int32 Add(Int64 value)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

public Int32 Add(Nullable<Int64> value)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds a new point with specified value.
public Int32 Add(Double value)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

public Int32 Add(Nullable<Double> value)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds a new point with specified value.
public Int32 Add(Int32 value)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

public Int32 Add(Nullable<Int32> value)

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Series.Add Method

Adds a new null (transparent) point.
public Int32 Add()

See Also

Add Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


AddNull

Steema.TeeChart.Styles.Series.AddNull Method

System.Obsolete: Please use Add() method without parameters.
public Int32 AddNull()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


AddNullXY

Steema.TeeChart.Styles.Series.AddNullXY Method

System.Obsolete: Please use Add(x,y,Color.Transparent) method.
public Int32 AddNullXY(Double x,
     Double y)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Assign

Steema.TeeChart.Styles.Series.Assign Method

Overload List

Copies all properties from one Series component to another.

public Void Assign(Steema.TeeChart.Styles.Series)

Copies all properties from one Series component to another.

public Void Assign(Steema.TeeChart.Styles.Series, Steema.TeeChart.Styles.Series)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Assign

Steema.TeeChart.Styles.Series.Assign Method

Copies all properties from one Series component to another.
public Void Assign(Series source,
     Series target)

See Also

Assign Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Assign

Steema.TeeChart.Styles.Series.Assign Method

Copies all properties from one Series component to another.
public Void Assign(Series source)

See Also

Assign Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


AssignDispose

Steema.TeeChart.Styles.Series.AssignDispose Method

public static Void AssignDispose(Series& s,
     Series newSeries)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.Series.AssignFormat Method

Overload List

public Void AssignFormat(Steema.TeeChart.Styles.Series)
public abstract Void AssignFormat(Steema.TeeChart.Styles.Series, Steema.TeeChart.Styles.Series)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.Series.AssignFormat Method

public abstract Void AssignFormat(Series source,
     Series target)

See Also

AssignFormat Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.Series.AssignFormat Method

public Void AssignFormat(Series source)

See Also

AssignFormat Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


AssignValues

Steema.TeeChart.Styles.Series.AssignValues Method

Overload List

Adds all Values from Source series.

public Void AssignValues(Steema.TeeChart.Styles.Series)

Adds all Values from Source series.

public Void AssignValues(Steema.TeeChart.Styles.Series, Steema.TeeChart.Styles.Series)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


AssignValues

Steema.TeeChart.Styles.Series.AssignValues Method

Adds all Values from Source series.
public Void AssignValues(Series source,
     Series target)

See Also

AssignValues Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


AssignValues

Steema.TeeChart.Styles.Series.AssignValues Method

Adds all Values from Source series.
public Void AssignValues(Series source)

See Also

AssignValues Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


BeginUpdate

Steema.TeeChart.Styles.Series.BeginUpdate Method

Recalculates the function just one time, when finished adding points.
public Void BeginUpdate()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


CalcPosValue

Steema.TeeChart.Styles.Series.CalcPosValue Method

Returns "Value" parameter coordinate position in pixels.
public Int32 CalcPosValue(Double value)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


CalcXPos

Steema.TeeChart.Styles.Series.CalcXPos Method

Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
public abstract Int32 CalcXPos(Int32 index)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


CalcXPosValue

Steema.TeeChart.Styles.Series.CalcXPosValue Method

Returns the pixel Screen Horizontal coordinate of the specified Value.
public abstract Int32 CalcXPosValue(Double value)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


CalcXSizeValue

Steema.TeeChart.Styles.Series.CalcXSizeValue Method

Returns the size in pixels corresponding to value parameter in horizontal axis scales.
public Int32 CalcXSizeValue(Double value)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


CalcYPos

Steema.TeeChart.Styles.Series.CalcYPos Method

Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
public abstract Int32 CalcYPos(Int32 index)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


CalcYPosValue

Steema.TeeChart.Styles.Series.CalcYPosValue Method

Returns the pixel Screen Vertical coordinate of the specified Value.
public abstract Int32 CalcYPosValue(Double value)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


CalcYSizeValue

Steema.TeeChart.Styles.Series.CalcYSizeValue Method

Returns the size in pixels corresponding to value parameter in vertical axis scales.
public Int32 CalcYSizeValue(Double value)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


ChangeType

Steema.TeeChart.Styles.Series.ChangeType Method

Replaces ASeries object with a new Series object of another class.
public static Void ChangeType(Series& s,
     Type newType)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


CheckDataSource

Steema.TeeChart.Styles.Series.CheckDataSource Method

Refreshes all Series point values, either from database Tables, Queries or Series points.
public Void CheckDataSource()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


CheckOrder

Steema.TeeChart.Styles.Series.CheckOrder Method

Reorders points according to Order property of X,Y,etc value lists.
public Void CheckOrder()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Clear

Steema.TeeChart.Styles.Series.Clear Method

Removes all points, texts and Colors from the Series.
public abstract Void Clear()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Series.Clicked Method

Overload List

public Int32 Clicked(System.Drawing.Point)

Returns the ValueIndex of the "clicked" point in the Series.

public abstract Int32 Clicked(System.Int32, System.Int32)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Series.Clicked Method

Returns the ValueIndex of the "clicked" point in the Series.
public abstract Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Series.Clicked Method

public Int32 Clicked(Point p)

See Also

Clicked Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Clone

Steema.TeeChart.Styles.Series.Clone Method

Returns a new Series, copy of this original.
public virtual Object Clone()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


ColorRange

Steema.TeeChart.Styles.Series.ColorRange Method

This method will change the Color of a specified range of points.
public Void ColorRange(ValueList AValueList,
     Double FromValue,
     Double ToValue,
     Color AColor)

Parameters

AValueList
Valuelist from which the range is defined
FromValue
Beginning of the specified AValueList range
ToValue
End of the specified AValueList range
AColor
New Color for range of points

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


CreateNewSeries

Steema.TeeChart.Styles.Series.CreateNewSeries Method

Overload List

Creates a new Series object and sets the Name, Chart, Sub-Style and Function properties.

public static Series CreateNewSeries(Steema.TeeChart.Chart, System.Type, System.Type, System.Int32)

Creates a new Series object and sets the Name, Chart, Sub-Style and Function properties.

public static Series CreateNewSeries(Steema.TeeChart.Chart, System.Type, System.Type, System.Int32, System.Object[])

Creates a new Series object and sets the Name, Chart and Function properties.

public static Series CreateNewSeries(Steema.TeeChart.Chart, System.Type, System.Type)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


CreateNewSeries

Steema.TeeChart.Styles.Series.CreateNewSeries Method

Creates a new Series object and sets the Name, Chart and Function properties.
public static Series CreateNewSeries(Chart chart,
     Type type,
     Type aFunction)

See Also

CreateNewSeries Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


CreateNewSeries

Steema.TeeChart.Styles.Series.CreateNewSeries Method

Creates a new Series object and sets the Name, Chart, Sub-Style and Function properties.
public static Series CreateNewSeries(Chart chart,
     Type type,
     Type aFunction,
     Int32 subIndex,
     Object[] initArgs)

See Also

CreateNewSeries Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


CreateNewSeries

Steema.TeeChart.Styles.Series.CreateNewSeries Method

Creates a new Series object and sets the Name, Chart, Sub-Style and Function properties.
public static Series CreateNewSeries(Chart chart,
     Type type,
     Type aFunction,
     Int32 subIndex)

See Also

CreateNewSeries Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Delete

Steema.TeeChart.Styles.Series.Delete Method

Overload List

Removes the index th point. X values remain unchanged.

public abstract Void Delete(System.Int32)

Removes count number of points starting at index. When RemoveGap parameter is true, it calls ValueList FillSequence.

public abstract Void Delete(System.Int32, System.Int32, System.Boolean)
public abstract Void Delete(System.Int32, System.Int32)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Delete

Steema.TeeChart.Styles.Series.Delete Method

public abstract Void Delete(Int32 index,
     Int32 count)

See Also

Delete Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Delete

Steema.TeeChart.Styles.Series.Delete Method

Removes count number of points starting at index. When RemoveGap parameter is true, it calls ValueList FillSequence.
public abstract Void Delete(Int32 index,
     Int32 count,
     Boolean removeGap)

See Also

Delete Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Delete

Steema.TeeChart.Styles.Series.Delete Method

Removes the index th point. X values remain unchanged.
public abstract Void Delete(Int32 index)

See Also

Delete Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.Series.Draw Method

public abstract Void Draw()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


DrawHiddenValue

Steema.TeeChart.Styles.Series.DrawHiddenValue Method

public abstract Void DrawHiddenValue(Int32 valueIndex,
     Double& startValue,
     Double& endValue,
     Int32 gapSize,
     Axis axis)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


DrawMarksSeries

Steema.TeeChart.Styles.Series.DrawMarksSeries Method

public abstract Void DrawMarksSeries(Series s,
     Boolean& ActiveRegion)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


DrawSeries

Steema.TeeChart.Styles.Series.DrawSeries Method

Draws the series to the Chart Canvas.
public Void DrawSeries()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.Series.DrawValue Method

Called internally. Draws the "ValueIndex" point of the Series.
public abstract Void DrawValue(Int32 index)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


DrawValuesForward

Steema.TeeChart.Styles.Series.DrawValuesForward Method

Returns whether Series draws its points in ascending/descending order.
public abstract Boolean DrawValuesForward()

Return Value

True if values in this series are displayed forward, from 0 to Count-1.

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


EndUpdate

Steema.TeeChart.Styles.Series.EndUpdate Method

Used with .BeginUpdate to recalculate the function just once when finished adding points.
public Void EndUpdate()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


FillSampleValues

Steema.TeeChart.Styles.Series.FillSampleValues Method

Overload List

Adds random values to help visualize the Series. Each series class determines how many random points to add.

public Void FillSampleValues()

Adds the specified NumValues random points.

public abstract Void FillSampleValues(System.Int32)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


FillSampleValues

Steema.TeeChart.Styles.Series.FillSampleValues Method

Adds the specified NumValues random points.
public abstract Void FillSampleValues(Int32 numValues)

Parameters

numValues
The number of sample values to add.

See Also

FillSampleValues Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


FillSampleValues

Steema.TeeChart.Styles.Series.FillSampleValues Method

Adds random values to help visualize the Series. Each series class determines how many random points to add.
public Void FillSampleValues()

See Also

FillSampleValues Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


FirstDisplayedIndex

Steema.TeeChart.Styles.Series.FirstDisplayedIndex Method

Returns the index of the series point that is displayed first when the series is drawn.
public Int32 FirstDisplayedIndex()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


GalleryChanged3D

Steema.TeeChart.Styles.Series.GalleryChanged3D Method

public abstract Void GalleryChanged3D(Boolean Is3D)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


GetBitmapEditor

Steema.TeeChart.Styles.Series.GetBitmapEditor Method

Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
public Bitmap GetBitmapEditor()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


GetMarkValue

Steema.TeeChart.Styles.Series.GetMarkValue Method

Returns corresponding Point value suitable for displaying at Series Marks.
public abstract Double GetMarkValue(Int32 valueIndex)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


HasColors

Steema.TeeChart.Styles.Series.HasColors Method

public static Boolean HasColors(Series aSeries)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


HasLabels

Steema.TeeChart.Styles.Series.HasLabels Method

public static Boolean HasLabels(Series aSeries)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


HasNoMandatoryValues

Steema.TeeChart.Styles.Series.HasNoMandatoryValues Method

public static Boolean HasNoMandatoryValues(Series aSeries)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


IsNull

Steema.TeeChart.Styles.Series.IsNull Method

Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
public Boolean IsNull(Int32 index)

Parameters

index
The point index.

Return Value

True if the point color is Color.Transparent.

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


IsValidSourceOf

Steema.TeeChart.Styles.Series.IsValidSourceOf Method

Validates Series datasource.
public abstract Boolean IsValidSourceOf(Series value)

Parameters

value
The series to validate.

Return Value

True if value can be a Series data source.

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


LastDisplayedIndex

Steema.TeeChart.Styles.Series.LastDisplayedIndex Method

Returns the index of the series point that is displayed first when the series is drawn.
public Int32 LastDisplayedIndex()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


LegendString

Steema.TeeChart.Styles.Series.LegendString Method

Returns the formatted string corresponding to the LegendIndex point.
public abstract String LegendString(Int32 legendIndex,
     LegendTextStyles legendTextStyle)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


MaxMarkWidth

Steema.TeeChart.Styles.Series.MaxMarkWidth Method

Returns the length in pixels of the longest Mark text.
public Int32 MaxMarkWidth()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.Series.MaxXValue Method

Returns the Maximum Value of the Series X Values List.
public abstract Double MaxXValue()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.Series.MaxYValue Method

Returns the Maximum Value of the Series Y Values List.
public abstract Double MaxYValue()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


MaxZValue

Steema.TeeChart.Styles.Series.MaxZValue Method

Returns Maximum Z Value.
public abstract Double MaxZValue()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


MinXValue

Steema.TeeChart.Styles.Series.MinXValue Method

Returns the Minimum Value of the Series X Values List.
public abstract Double MinXValue()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.Series.MinYValue Method

Returns the Minimum Value of the Series Y Values List.
public abstract Double MinYValue()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


MinZValue

Steema.TeeChart.Styles.Series.MinZValue Method

Returns Minimum Z Value.
public abstract Double MinZValue()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


NewFromType

Steema.TeeChart.Styles.Series.NewFromType Method

Overload List

Creates a new series from the System.Type of an existing series object.

public static Series NewFromType(System.Type)

Creates a new series from the System.Type of an existing series object.

public static Series NewFromType(System.Type, System.Object[])

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


NewFromType

Steema.TeeChart.Styles.Series.NewFromType Method

Creates a new series from the System.Type of an existing series object.
public static Series NewFromType(Type type,
     Object[] initArgs)

See Also

NewFromType Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


NewFromType

Steema.TeeChart.Styles.Series.NewFromType Method

Creates a new series from the System.Type of an existing series object.
public static Series NewFromType(Type type)

See Also

NewFromType Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.Series.PrepareForGallery Method

public abstract Void PrepareForGallery(Boolean IsEnabled)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


RefreshSeries

Steema.TeeChart.Styles.Series.RefreshSeries Method

Recalculates all dependent Series points again.
public Void RefreshSeries()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Repaint

Steema.TeeChart.Styles.Series.Repaint Method

Forces the Chart to Repaint.
public Void Repaint()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


ScreenPointToValuePoint

Steema.TeeChart.Styles.Series.ScreenPointToValuePoint Method

Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
public abstract PointDouble ScreenPointToValuePoint(Int32 x,
     Int32 y)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


SetNull

Steema.TeeChart.Styles.Series.SetNull Method

Overload List

Sets the specified series point to a null (transparent) point.

public Void SetNull(System.Int32)

Toogles between null (transparent) and regular point.

public Void SetNull(System.Int32, System.Boolean)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


SetNull

Steema.TeeChart.Styles.Series.SetNull Method

Toogles between null (transparent) and regular point.
public Void SetNull(Int32 valueIndex,
     Boolean isnull)

Parameters

valueIndex
Point index
isNull
If true, transform to null point, otherwise transform to normal point.

See Also

SetNull Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


SetNull

Steema.TeeChart.Styles.Series.SetNull Method

Sets the specified series point to a null (transparent) point.
public Void SetNull(Int32 valueIndex)

See Also

SetNull Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.Series.SetSubGallery Method

Creates and prepares the index'th Series style to show at sub-gallery dialog.
public abstract Void SetSubGallery(Int32 index)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


SortByLabels

Steema.TeeChart.Styles.Series.SortByLabels Method

Overload List

Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).

public Void SortByLabels(Steema.TeeChart.Styles.ValueListOrder)
public Void SortByLabels()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


SortByLabels

Steema.TeeChart.Styles.Series.SortByLabels Method

public Void SortByLabels()

See Also

SortByLabels Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


SortByLabels

Steema.TeeChart.Styles.Series.SortByLabels Method

Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
public Void SortByLabels(ValueListOrder order)

See Also

SortByLabels Overload List | Series Class | Series Members | Steema.TeeChart.Styles Namespace


TitleOrName

Steema.TeeChart.Styles.Series.TitleOrName Method

System.Obsolete: Please use ToString() method.
public String TitleOrName()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


ToString

Steema.TeeChart.Styles.Series.ToString Method

Overridden ToString() method.
public override String ToString()

Return Value

Returns the Series Title property.

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


ValueColor

Steema.TeeChart.Styles.Series.ValueColor Method

Returns the colour of the index point.
public abstract Color ValueColor(Int32 valueIndex)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


ValueMarkText

Steema.TeeChart.Styles.Series.ValueMarkText Method

Returns the string representation of a Index point used to draw the Mark.
public String ValueMarkText(Int32 index)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


ValuePointToScreenPoint

Steema.TeeChart.Styles.Series.ValuePointToScreenPoint Method

Returns the corresponding Screen Point values of a Value position between Axis limits.
public abstract Point ValuePointToScreenPoint(Double x,
     Double y)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


WriteToDataSource

Steema.TeeChart.Styles.Series.WriteToDataSource Method

public Void WriteToDataSource()

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


XScreenToValue

Steema.TeeChart.Styles.Series.XScreenToValue Method

Returns the corresponding X value of a Screen position between Axis limits.
public abstract Double XScreenToValue(Int32 screenPos)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


YScreenToValue

Steema.TeeChart.Styles.Series.YScreenToValue Method

Returns the corresponding Y value of a Screen position between Axis limits.
public abstract Double YScreenToValue(Int32 screenPos)

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesProperties

Steema.TeeChart.Styles.Series Properties

Public Properties

Active | Shows or hides this series.
Chart (inherited from TeeBase) | Chart associated with this object
Color | Default color for all points.
ColorEach | Draws points with different preset Colors.
ColorEachPoint | System.Obsolete: Please use ColorEach property.
ColorMember | Gets or sets the Datasource Color Field
Colors | Access to the stored Color Array, if created, for the Series.
Count | Returns the number of points in the Series.
Cursor | Cursor displayed when mouse is over a series point.
CustomHorizAxis | Specified the custom horizontal axis for the series.
CustomVertAxis | Specified the custom vertical axis for the series.
DataSource | Object to load data from.
DateTimeFormat | Determines the DateTimeFormat to display point values.
DefaultNullValue | Sets or returns the value to be used as a null value within the series.
Depth | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
EndZ | For internal use.
FirstVisibleIndex | Returns the index of the Series' first visible point.
Function | Function object to calculate values.
HorizAxis | Horizontal axis to associate to this Series.
Item | Point characteristics
LabelMember | Gets or sets the Datasource Label Field
Labels | Accesses a list of series point labels.
LastVisibleIndex | Returns the index of the Series' last visible point.
Marks | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ | For internal use.
NumGallerySeries | For internal use.
PercentFormat | Sets the Format to display point values as percentage.
SeriesColor | System.Obsolete: Use the Series Color property.
SeriesData |
ShowInLegend | Displays this Series Title in Legend.
StartZ | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title | Series description to show in Legend and editors.
ValueFormat | Determines the Format to display point values.
ValuesLists | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis | Determines Vertical axis associated to this Series.
Visible | Shows or hides this series.
XValues | Values defining horizontal point positions.
YValues | Values defining vertical point positions.
ZOrder | Determines where on the depth axis the Series is drawn.

See Also

Series Class | Steema.TeeChart.Styles Namespace


Active

Steema.TeeChart.Styles.Series.Active Property

Shows or hides this series.
public Boolean Active {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Color

Steema.TeeChart.Styles.Series.Color Property

Default color for all points.
public Color Color {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


ColorEach

Steema.TeeChart.Styles.Series.ColorEach Property

Draws points with different preset Colors.
public Boolean ColorEach {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


ColorEachPoint

Steema.TeeChart.Styles.Series.ColorEachPoint Property

System.Obsolete: Please use ColorEach property.
public Boolean ColorEachPoint {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


ColorMember

Steema.TeeChart.Styles.Series.ColorMember Property

Gets or sets the Datasource Color Field
public String ColorMember {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Colors

Steema.TeeChart.Styles.Series.Colors Property

Access to the stored Color Array, if created, for the Series.
public ColorList Colors {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Count

Steema.TeeChart.Styles.Series.Count Property

Returns the number of points in the Series.
public Int32 Count {get;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Cursor

Steema.TeeChart.Styles.Series.Cursor Property

Cursor displayed when mouse is over a series point.
public Cursor Cursor {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


CustomHorizAxis

Steema.TeeChart.Styles.Series.CustomHorizAxis Property

Specified the custom horizontal axis for the series.
public Axis CustomHorizAxis {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


CustomVertAxis

Steema.TeeChart.Styles.Series.CustomVertAxis Property

Specified the custom vertical axis for the series.
public Axis CustomVertAxis {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


DataSource

Steema.TeeChart.Styles.Series.DataSource Property

Object to load data from.
public Object DataSource {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


DateTimeFormat

Steema.TeeChart.Styles.Series.DateTimeFormat Property

Determines the DateTimeFormat to display point values.
public String DateTimeFormat {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


DefaultNullValue

Steema.TeeChart.Styles.Series.DefaultNullValue Property

Sets or returns the value to be used as a null value within the series.
public Double DefaultNullValue {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Depth

Steema.TeeChart.Styles.Series.Depth Property

Sets the Depth of the series points or interconnecting lines.
public Int32 Depth {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Series.Description Property

Gets descriptive text.
public abstract String Description {get;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


EndZ

Steema.TeeChart.Styles.Series.EndZ Property

For internal use.
public Int32 EndZ {get;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


FirstVisibleIndex

Steema.TeeChart.Styles.Series.FirstVisibleIndex Property

Returns the index of the Series' first visible point.
public Int32 FirstVisibleIndex {get;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Function

Steema.TeeChart.Styles.Series.Function Property

Function object to calculate values.
public Function Function {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


HorizAxis

Steema.TeeChart.Styles.Series.HorizAxis Property

Horizontal axis to associate to this Series.
public HorizontalAxis HorizAxis {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.Series.Item Property

Point characteristics
public SeriesXYPoint Item(Int32 index) {get;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


LabelMember

Steema.TeeChart.Styles.Series.LabelMember Property

Gets or sets the Datasource Label Field
public String LabelMember {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Labels

Steema.TeeChart.Styles.Series.Labels Property

Accesses a list of series point labels.
public StringList Labels {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


LastVisibleIndex

Steema.TeeChart.Styles.Series.LastVisibleIndex Property

Returns the index of the Series' last visible point.
public Int32 LastVisibleIndex {get;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Marks

Steema.TeeChart.Styles.Series.Marks Property

Defines all necessary properties to draw a mark near to each Series point.
public SeriesMarks Marks {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


MiddleZ

Steema.TeeChart.Styles.Series.MiddleZ Property

For internal use.
public Int32 MiddleZ {get;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


NumGallerySeries

Steema.TeeChart.Styles.Series.NumGallerySeries Property

For internal use.
public abstract Int32 NumGallerySeries {get;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


PercentFormat

Steema.TeeChart.Styles.Series.PercentFormat Property

Sets the Format to display point values as percentage.
public String PercentFormat {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


SeriesColor

Steema.TeeChart.Styles.Series.SeriesColor Property

System.Obsolete: Use the Series Color property.
public Color SeriesColor {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


SeriesData

Steema.TeeChart.Styles.Series.SeriesData Property

public String SeriesData {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


ShowInLegend

Steema.TeeChart.Styles.Series.ShowInLegend Property

Displays this Series Title in Legend.
public Boolean ShowInLegend {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


StartZ

Steema.TeeChart.Styles.Series.StartZ Property

For internal use.
public Int32 StartZ {get;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Title

Steema.TeeChart.Styles.Series.Title Property

Series description to show in Legend and editors.
public String Title {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


ValueFormat

Steema.TeeChart.Styles.Series.ValueFormat Property

Determines the Format to display point values.
public String ValueFormat {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


ValuesLists

Steema.TeeChart.Styles.Series.ValuesLists Property

Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
public List<ValueList> ValuesLists {get;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


VertAxis

Steema.TeeChart.Styles.Series.VertAxis Property

Determines Vertical axis associated to this Series.
public VerticalAxis VertAxis {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Visible

Steema.TeeChart.Styles.Series.Visible Property

Shows or hides this series.
public Boolean Visible {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


XValues

Steema.TeeChart.Styles.Series.XValues Property

Values defining horizontal point positions.
public ValueList XValues {get;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


YValues

Steema.TeeChart.Styles.Series.YValues Property

Values defining vertical point positions.
public ValueList YValues {get;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


ZOrder

Steema.TeeChart.Styles.Series.ZOrder Property

Determines where on the depth axis the Series is drawn.
public Int32 ZOrder {get; set;}

See Also

Series Class | Series Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Series.BeforeDrawPointEventHandler

Steema.TeeChart.Styles.Series.BeforeDrawPointEventHandler Delegate

The Delegate for the BeforeDrawPoint event.
public delegate BeforeDrawPointEventHandler (Series series,
     BeforeDrawPointEventArgs e)

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Series.GetSeriesMarkEventHandler

Steema.TeeChart.Styles.Series.GetSeriesMarkEventHandler Delegate

The Delegate for the GetSeriesMark event.
public delegate GetSeriesMarkEventHandler (Series series,
     GetSeriesMarkEventArgs e)

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Series.SeriesRandom

Steema.TeeChart.Styles.Series.SeriesRandom ValueType

Used internally to add random values to a series.

For a list of all members of this type, see SeriesRandom Members

System.Object
System.ValueType
public sealed struct SeriesRandom : ValueType

See Also

SeriesRandom Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Series.SeriesRandomMembers

Steema.TeeChart.Styles.Series.SeriesRandom all Members

SeriesRandom overview

Public Fields

DifY
MinY
StepX
tmpX
tmpY

Public Methods

Random

See Also

SeriesRandom Structure | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Series.SeriesRandomFields

Steema.TeeChart.Styles.Series.SeriesRandom Fields

Public Fields

DifY
MinY
StepX
tmpX
tmpY

See Also

SeriesRandom Structure | Steema.TeeChart.Styles Namespace


DifY

Steema.TeeChart.Styles.Series+SeriesRandom.DifY Field

public Double DifY

See Also

SeriesRandom Structure | SeriesRandom Members | Steema.TeeChart.Styles Namespace


MinY

Steema.TeeChart.Styles.Series+SeriesRandom.MinY Field

public Double MinY

See Also

SeriesRandom Structure | SeriesRandom Members | Steema.TeeChart.Styles Namespace


StepX

Steema.TeeChart.Styles.Series+SeriesRandom.StepX Field

public Double StepX

See Also

SeriesRandom Structure | SeriesRandom Members | Steema.TeeChart.Styles Namespace


tmpX

Steema.TeeChart.Styles.Series+SeriesRandom.tmpX Field

public Double tmpX

See Also

SeriesRandom Structure | SeriesRandom Members | Steema.TeeChart.Styles Namespace


tmpY

Steema.TeeChart.Styles.Series+SeriesRandom.tmpY Field

public Double tmpY

See Also

SeriesRandom Structure | SeriesRandom Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Series.SeriesRandomMethods

Steema.TeeChart.Styles.Series.SeriesRandom Methods

Public Methods

Random

See Also

SeriesRandom Structure | Steema.TeeChart.Styles Namespace


Random

Steema.TeeChart.Styles.Series+SeriesRandom.Random Method

Overload List

public Double Random()
public Int32 Random(System.Int32)

See Also

SeriesRandom Structure | SeriesRandom Members | Steema.TeeChart.Styles Namespace


Random

Steema.TeeChart.Styles.Series+SeriesRandom.Random Method

public Int32 Random(Int32 Range)

See Also

Random Overload List | SeriesRandom Structure | SeriesRandom Members | Steema.TeeChart.Styles Namespace


Random

Steema.TeeChart.Styles.Series+SeriesRandom.Random Method

public Double Random()

See Also

Random Overload List | SeriesRandom Structure | SeriesRandom Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesCollection

Steema.TeeChart.Styles.SeriesCollection Class

The SeriesCollection class, a collection of Series objects, is manipulated via the Chart Series property.

For a list of all members of this type, see SeriesCollection Members

System.Object
System.Collections.CollectionBase
public sealed class SeriesCollection : CollectionBase , IList
, ICollection, IEnumerable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

SeriesCollection members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesCollectionMembers

Steema.TeeChart.Styles.SeriesCollection all Members

SeriesCollection overview

Constructors

Constructor

Public Methods

ActiveUseAxis |
Add |
AddGroup | Adds a new series group to the groups list.
Clear | Removes (and optionally disposes) all Series.
Exchange | This method changes the Series order, swapping one Series Z position with another.
IndexOf | Returns the corresponding point index which has the specified Value.
MoveTo |
Remove | Deletes the specified Series from the Chart list of series.
RemoveAllSeries | Removes all Series from the Chart but not disposes (destroys) them
WithTitle |

Public Properties

AllActive | Returns true if all series are active and sets the active property of all series
ApplyZOrder | Sets multiple Series on same Chart in different Z spaces when true.
Chart | Defines the Chart component.
Groups | List of series groups.
Item |

See Also

SeriesCollection Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesCollection Constructor

public SeriesCollection(Chart c)

See Also

SeriesCollection Class | SeriesCollection Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesCollectionMethods

Steema.TeeChart.Styles.SeriesCollection Methods

Public Methods

ActiveUseAxis |
Add |
AddGroup | Adds a new series group to the groups list.
Clear | Removes (and optionally disposes) all Series.
Exchange | This method changes the Series order, swapping one Series Z position with another.
IndexOf | Returns the corresponding point index which has the specified Value.
MoveTo |
Remove | Deletes the specified Series from the Chart list of series.
RemoveAllSeries | Removes all Series from the Chart but not disposes (destroys) them
WithTitle |

See Also

SeriesCollection Class | Steema.TeeChart.Styles Namespace


ActiveUseAxis

Steema.TeeChart.Styles.SeriesCollection.ActiveUseAxis Method

public Boolean ActiveUseAxis()

See Also

SeriesCollection Class | SeriesCollection Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.SeriesCollection.Add Method

Overload List

public Series Add(System.Type)

Adds a new Series instance to Chart.

public Series Add(Steema.TeeChart.Styles.Series)

See Also

SeriesCollection Class | SeriesCollection Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.SeriesCollection.Add Method

Adds a new Series instance to Chart.
public Series Add(Series s)

Parameters

s
The Series instance to add.

Return Value

The same Series.

See Also

Add Overload List | SeriesCollection Class | SeriesCollection Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.SeriesCollection.Add Method

public Series Add(Type type)

See Also

Add Overload List | SeriesCollection Class | SeriesCollection Members | Steema.TeeChart.Styles Namespace


AddGroup

Steema.TeeChart.Styles.SeriesCollection.AddGroup Method

Adds a new series group to the groups list.
public SeriesGroup AddGroup(String name)

Parameters

name
New series group name.

See Also

SeriesCollection Class | SeriesCollection Members | Steema.TeeChart.Styles Namespace


Clear

Steema.TeeChart.Styles.SeriesCollection.Clear Method

Overload List

Removes (and optionally disposes) all Series.

public Void Clear(System.Boolean)

Removes and disposes all Series.

public Void Clear()

See Also

SeriesCollection Class | SeriesCollection Members | Steema.TeeChart.Styles Namespace


Clear

Steema.TeeChart.Styles.SeriesCollection.Clear Method

Removes and disposes all Series.
public Void Clear()

See Also

Clear Overload List | SeriesCollection Class | SeriesCollection Members | Steema.TeeChart.Styles Namespace


Clear

Steema.TeeChart.Styles.SeriesCollection.Clear Method

Removes (and optionally disposes) all Series.
public Void Clear(Boolean dispose)

See Also

Clear Overload List | SeriesCollection Class | SeriesCollection Members | Steema.TeeChart.Styles Namespace


Exchange

Steema.TeeChart.Styles.SeriesCollection.Exchange Method

This method changes the Series order, swapping one Series Z position with another.
public Void Exchange(Int32 series1,
     Int32 series2)

See Also

SeriesCollection Class | SeriesCollection Members | Steema.TeeChart.Styles Namespace


IndexOf

Steema.TeeChart.Styles.SeriesCollection.IndexOf Method

Returns the corresponding point index which has the specified Value.
public Int32 IndexOf(Series s)

See Also

SeriesCollection Class | SeriesCollection Members | Steema.TeeChart.Styles Namespace


MoveTo

Steema.TeeChart.Styles.SeriesCollection.MoveTo Method

public Void MoveTo(Series s,
     Int32 index)

See Also

SeriesCollection Class | SeriesCollection Members | Steema.TeeChart.Styles Namespace


Remove

Steema.TeeChart.Styles.SeriesCollection.Remove Method

Deletes the specified Series from the Chart list of series.
public Void Remove(Series s)

See Also

SeriesCollection Class | SeriesCollection Members | Steema.TeeChart.Styles Namespace


RemoveAllSeries

Steema.TeeChart.Styles.SeriesCollection.RemoveAllSeries Method

Removes all Series from the Chart but not disposes (destroys) them
public Void RemoveAllSeries()

See Also

SeriesCollection Class | SeriesCollection Members | Steema.TeeChart.Styles Namespace


WithTitle

Steema.TeeChart.Styles.SeriesCollection.WithTitle Method

public Series WithTitle(String title)

See Also

SeriesCollection Class | SeriesCollection Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesCollectionProperties

Steema.TeeChart.Styles.SeriesCollection Properties

Public Properties

AllActive | Returns true if all series are active and sets the active property of all series
ApplyZOrder | Sets multiple Series on same Chart in different Z spaces when true.
Chart | Defines the Chart component.
Groups | List of series groups.
Item |

See Also

SeriesCollection Class | Steema.TeeChart.Styles Namespace


AllActive

Steema.TeeChart.Styles.SeriesCollection.AllActive Property

Returns true if all series are active and sets the active property of all series
public Boolean AllActive {get; set;}

See Also

SeriesCollection Class | SeriesCollection Members | Steema.TeeChart.Styles Namespace


ApplyZOrder

Steema.TeeChart.Styles.SeriesCollection.ApplyZOrder Property

Sets multiple Series on same Chart in different Z spaces when true.
public Boolean ApplyZOrder {get; set;}

See Also

SeriesCollection Class | SeriesCollection Members | Steema.TeeChart.Styles Namespace


Chart

Steema.TeeChart.Styles.SeriesCollection.Chart Property

Defines the Chart component.
public Chart Chart {get;}

See Also

SeriesCollection Class | SeriesCollection Members | Steema.TeeChart.Styles Namespace


Groups

Steema.TeeChart.Styles.SeriesCollection.Groups Property

List of series groups.
public SeriesGroups Groups {get;}

See Also

SeriesCollection Class | SeriesCollection Members | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.SeriesCollection.Item Property

public Series Item(Int32 index) {get; set;}

See Also

SeriesCollection Class | SeriesCollection Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesEvent

Steema.TeeChart.Styles.SeriesEvent Class

Listens to all the Series class events.

For a list of all members of this type, see SeriesEvent Members

System.Object
Steema.TeeChart.TeeEvent
public class SeriesEvent : TeeEvent

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

SeriesEvent members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesEventMembers

Steema.TeeChart.Styles.SeriesEvent all Members

SeriesEvent overview

Constructors

Constructor

Public Fields

Event
sender (inherited from TeeEvent)
Series

See Also

SeriesEvent Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesEvent Constructor

public SeriesEvent()

See Also

SeriesEvent Class | SeriesEvent Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesEventFields

Steema.TeeChart.Styles.SeriesEvent Fields

Public Fields

Event
sender (inherited from TeeEvent)
Series

See Also

SeriesEvent Class | Steema.TeeChart.Styles Namespace


Event

Steema.TeeChart.Styles.SeriesEvent.Event Field

public SeriesEventStyle Event

See Also

SeriesEvent Class | SeriesEvent Members | Steema.TeeChart.Styles Namespace


Series

Steema.TeeChart.Styles.SeriesEvent.Series Field

public Series Series

See Also

SeriesEvent Class | SeriesEvent Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesEventStyle

Steema.TeeChart.Styles.SeriesEventStyle Enum

For internal use.
[Serializable]
public sealed enum SeriesEventStyle : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Add |
Remove |
RemoveAll |
ChangeTitle |
ChangeColor |
Swap |
ChangeActive |
DataChanged |

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesGroup

Steema.TeeChart.Styles.SeriesGroup Class

Access to series group characteristics

For a list of all members of this type, see SeriesGroup Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public sealed class SeriesGroup : TeeBase

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

SeriesGroup members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesGroupMembers

Steema.TeeChart.Styles.SeriesGroup all Members

SeriesGroup overview

Constructors

Constructor Overloaded

Public Methods

Hide | For all series in the group, sets their Active property to False.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Show | For all series in the group, sets their Active property to True.
ToString |

Public Properties

Active | Returns Yes, No or Some if all, none or some series in the group are active and sets the active property of all series in the group.
Chart (inherited from TeeBase) | Chart associated with this object
Name | The name of the group.
Series | The list of series that belong to this group.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

SeriesGroup Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesGroup Constructor

Overload List

public SeriesGroup()
public SeriesGroup(Steema.TeeChart.Chart)

See Also

SeriesGroup Class | SeriesGroup Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesGroup Constructor

public SeriesGroup(Chart c)

See Also

SeriesGroup Constructor Overload List | SeriesGroup Class | SeriesGroup Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesGroup Constructor

public SeriesGroup()

See Also

SeriesGroup Constructor Overload List | SeriesGroup Class | SeriesGroup Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesGroupMethods

Steema.TeeChart.Styles.SeriesGroup Methods

Public Methods

Hide | For all series in the group, sets their Active property to False.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Show | For all series in the group, sets their Active property to True.
ToString |

See Also

SeriesGroup Class | Steema.TeeChart.Styles Namespace


Hide

Steema.TeeChart.Styles.SeriesGroup.Hide Method

For all series in the group, sets their Active property to False.
public Void Hide()

See Also

SeriesGroup Class | SeriesGroup Members | Steema.TeeChart.Styles Namespace


Show

Steema.TeeChart.Styles.SeriesGroup.Show Method

For all series in the group, sets their Active property to True.
public Void Show()

See Also

SeriesGroup Class | SeriesGroup Members | Steema.TeeChart.Styles Namespace


ToString

Steema.TeeChart.Styles.SeriesGroup.ToString Method

public override String ToString()

See Also

SeriesGroup Class | SeriesGroup Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesGroupProperties

Steema.TeeChart.Styles.SeriesGroup Properties

Public Properties

Active | Returns Yes, No or Some if all, none or some series in the group are active and sets the active property of all series in the group.
Chart (inherited from TeeBase) | Chart associated with this object
Name | The name of the group.
Series | The list of series that belong to this group.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

SeriesGroup Class | Steema.TeeChart.Styles Namespace


Active

Steema.TeeChart.Styles.SeriesGroup.Active Property

Returns Yes, No or Some if all, none or some series in the group are active and sets the active property of all series in the group.
public SeriesGroupActive Active {get; set;}

See Also

SeriesGroup Class | SeriesGroup Members | Steema.TeeChart.Styles Namespace


Name

Steema.TeeChart.Styles.SeriesGroup.Name Property

The name of the group.
public String Name {get; set;}

See Also

SeriesGroup Class | SeriesGroup Members | Steema.TeeChart.Styles Namespace


Series

Steema.TeeChart.Styles.SeriesGroup.Series Property

The list of series that belong to this group.
public SeriesCollection Series {get; set;}

See Also

SeriesGroup Class | SeriesGroup Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesGroupActive

Steema.TeeChart.Styles.SeriesGroupActive Enum

Describes the possible values of the Active property.
[Serializable]
public sealed enum SeriesGroupActive : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Yes | All series in the group are active.
No | No series in the group are active.
Some | Some of the series in the group are active.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesGroups

Steema.TeeChart.Styles.SeriesGroups Class

Access to series groups characteristics

For a list of all members of this type, see SeriesGroups Members

System.Object
System.Collections.CollectionBase
public sealed class SeriesGroups : CollectionBase , IList, ICollection
, IEnumerable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

SeriesGroups members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesGroupsMembers

Steema.TeeChart.Styles.SeriesGroups all Members

SeriesGroups overview

Constructors

Constructor

Public Methods

Add | Adds a new series group to the list.
Contains | Returns first group index than contains Series, or -1 if any.
FindByName |

Public Properties

Item Gets or Sets the SeriesGroup at the index position inside the list.

See Also

SeriesGroups Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesGroups Constructor

public SeriesGroups(Chart c)

See Also

SeriesGroups Class | SeriesGroups Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesGroupsMethods

Steema.TeeChart.Styles.SeriesGroups Methods

Public Methods

Add | Adds a new series group to the list.
Contains | Returns first group index than contains Series, or -1 if any.
FindByName |

See Also

SeriesGroups Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.SeriesGroups.Add Method

Adds a new series group to the list.
public SeriesGroup Add(String name)

Parameters

name
New series group name.

See Also

SeriesGroups Class | SeriesGroups Members | Steema.TeeChart.Styles Namespace


Contains

Steema.TeeChart.Styles.SeriesGroups.Contains Method

Returns first group index than contains Series, or -1 if any.
public Int32 Contains(Series s)

See Also

SeriesGroups Class | SeriesGroups Members | Steema.TeeChart.Styles Namespace


FindByName

Steema.TeeChart.Styles.SeriesGroups.FindByName Method

public SeriesGroup FindByName(String Name,
     Boolean CaseSensitive)

See Also

SeriesGroups Class | SeriesGroups Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesGroupsProperties

Steema.TeeChart.Styles.SeriesGroups Properties

Public Properties

Item Gets or Sets the SeriesGroup at the index position inside the list.

See Also

SeriesGroups Class | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.SeriesGroups.Item Property

Gets or Sets the SeriesGroup at the index position inside the list.
public SeriesGroup Item(Int32 index) {get; set;}

See Also

SeriesGroups Class | SeriesGroups Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarks

Steema.TeeChart.Styles.SeriesMarks Class

Series Marks characteristics

For a list of all members of this type, see SeriesMarks Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
public class SeriesMarks : TextShape , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

SeriesMarks members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarksMembers

Steema.TeeChart.Styles.SeriesMarks all Members

SeriesMarks overview

Constructors

Constructor Overloaded

Public Fields

CheckMarkArrowColor | When True, Marks arrow pen color is changed if the point has the same color.
Size (inherited from TextShape) |

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clear | Removes all mark positions and mark items.
Clicked | Determines which Mark contains the p point parameters.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.
PercentString | Returns the string showing a "percent" value for a given point. For example: "25%" The optional "AddTotal" parameter, when true, returns: "25% of 1234".
ResetPositions | Turns all Marks positions Custom to false. Tells chart to repaint using automatically positioned marks.
TextWidth | Returns the length in pixels for the ValueIndex th mark text string. It checks if the Mark has multiple lines of text.

Public Properties

Angle | Sets angle from 0 to 360º to rotate Marks.
Arrow | The Pen used to draw a line connecting Marks to Series points.
ArrowLength | The length in pixels for the line connecting the Mark to Series point.
AutoSize (inherited from TextShape) |
BackColor |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Callout | Marks Callout characteristics
Chart (inherited from TeeBase) | Chart associated with this object
Clip | Restricts Marks to Chart axes space, when true.
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
DrawEvery | The number of Marks to skip. ( Default is 1, all Marks are displayed ).
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
FontSeriesColor | Font Color in Mark texts are given from its point Color.
Frame |
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
InflateMargins | Expands axes to fit Series Marks.
Items |
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines |
MultiLine | Characters in Mark texts are split into multiple lines, when true.
OnTop | Gets or sets a value which determines if Series Marks are always drawn on top of all other Series in the Chart.
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Positions |
Right (inherited from Shape) | Shape rectangle right co-ordinate
Series |
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
SoftClip | Gets and sets whether Marks are selectively restricted to the axes space.
Style | Defines how Series Marks are constructed.
Symbol |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.
ZPosition | Sets Position in pixels on the Z axis.

See Also

SeriesMarks Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarks Constructor

Overload List

public SeriesMarks()
public SeriesMarks(Steema.TeeChart.Chart)
public SeriesMarks(Steema.TeeChart.Styles.Series)

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarks Constructor

public SeriesMarks(Series s)

See Also

SeriesMarks Constructor Overload List | SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarks Constructor

public SeriesMarks(Chart c)

See Also

SeriesMarks Constructor Overload List | SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarks Constructor

public SeriesMarks()

See Also

SeriesMarks Constructor Overload List | SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarksFields

Steema.TeeChart.Styles.SeriesMarks Fields

Public Fields

CheckMarkArrowColor | When True, Marks arrow pen color is changed if the point has the same color.
Size (inherited from TextShape) |

See Also

SeriesMarks Class | Steema.TeeChart.Styles Namespace


CheckMarkArrowColor

Steema.TeeChart.Styles.SeriesMarks.CheckMarkArrowColor Field

When True, Marks arrow pen color is changed if the point has the same color.
public Boolean CheckMarkArrowColor

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarksMethods

Steema.TeeChart.Styles.SeriesMarks Methods

Public Methods

Assign (inherited from TextShape) | Assign all properties from a TextShape to another.
Clear | Removes all mark positions and mark items.
Clicked | Determines which Mark contains the p point parameters.
Clone (inherited from Shape) |
DrawRectRotated (inherited from TextShape) | Draws the Shape rectangle rotated by Angle degrees.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from TextShape) | Paints the TextShape object on the Chart Canvas.
PercentString | Returns the string showing a "percent" value for a given point. For example: "25%" The optional "AddTotal" parameter, when true, returns: "25% of 1234".
ResetPositions | Turns all Marks positions Custom to false. Tells chart to repaint using automatically positioned marks.
TextWidth | Returns the length in pixels for the ValueIndex th mark text string. It checks if the Mark has multiple lines of text.

See Also

SeriesMarks Class | Steema.TeeChart.Styles Namespace


Clear

Steema.TeeChart.Styles.SeriesMarks.Clear Method

Removes all mark positions and mark items.
public Void Clear()

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.SeriesMarks.Clicked Method

Overload List

Determines which Mark contains the p point parameters.

public abstract Int32 Clicked(System.Drawing.Point)

Determines which Mark contains the XY pixel point parameters.

public abstract Int32 Clicked(System.Int32, System.Int32)

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.SeriesMarks.Clicked Method

Determines which Mark contains the XY pixel point parameters.
public abstract Int32 Clicked(Int32 x,
     Int32 y)

Return Value

The Mark index containing the XY point.

See Also

Clicked Overload List | SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.SeriesMarks.Clicked Method

Determines which Mark contains the p point parameters.
public abstract Int32 Clicked(Point p)

See Also

Clicked Overload List | SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


PercentString

Steema.TeeChart.Styles.SeriesMarks.PercentString Method

Returns the string showing a "percent" value for a given point. For example: "25%" The optional "AddTotal" parameter, when true, returns: "25% of 1234".
public String PercentString(Int32 valueIndex,
     Boolean addTotal)

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


ResetPositions

Steema.TeeChart.Styles.SeriesMarks.ResetPositions Method

Turns all Marks positions Custom to false. Tells chart to repaint using automatically positioned marks.
public Void ResetPositions()

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


TextWidth

Steema.TeeChart.Styles.SeriesMarks.TextWidth Method

Returns the length in pixels for the ValueIndex th mark text string. It checks if the Mark has multiple lines of text.
public Int32 TextWidth(Int32 valueIndex)

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarksProperties

Steema.TeeChart.Styles.SeriesMarks Properties

Public Properties

Angle | Sets angle from 0 to 360º to rotate Marks.
Arrow | The Pen used to draw a line connecting Marks to Series points.
ArrowLength | The length in pixels for the line connecting the Mark to Series point.
AutoSize (inherited from TextShape) |
BackColor |
Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Callout | Marks Callout characteristics
Chart (inherited from TeeBase) | Chart associated with this object
Clip | Restricts Marks to Chart axes space, when true.
ClipText (inherited from TextShape) |
Color (inherited from Shape) | Defines the shape Color.
DrawEvery | The number of Marks to skip. ( Default is 1, all Marks are displayed ).
Font (inherited from TextShape) | Determines the font attributes used to output ShapeSeries.Text strings.
FontSeriesColor | Font Color in Mark texts are given from its point Color.
Frame |
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
InflateMargins | Expands axes to fit Series Marks.
Items |
Left (inherited from Shape) | Shape rectangle left co-ordinate
Lines |
MultiLine | Characters in Mark texts are split into multiple lines, when true.
OnTop | Gets or sets a value which determines if Series Marks are always drawn on top of all other Series in the Chart.
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Positions |
Right (inherited from Shape) | Shape rectangle right co-ordinate
Series |
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShadowSize (inherited from TextShape) |
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
ShapeStyle (inherited from TextShape) | Shape may be rectagular or rounded rectangular.
SoftClip | Gets and sets whether Marks are selectively restricted to the axes space.
Style | Defines how Series Marks are constructed.
Symbol |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from TextShape) | The Text property is used to display customized strings inside Shapes.
TextAlign (inherited from TextShape) |
TextFormat (inherited from TextShape) | Determines if Text is drawn as Normal or HTML styles.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.
ZPosition | Sets Position in pixels on the Z axis.

See Also

SeriesMarks Class | Steema.TeeChart.Styles Namespace


Angle

Steema.TeeChart.Styles.SeriesMarks.Angle Property

Sets angle from 0 to 360º to rotate Marks.
public Double Angle {get; set;}

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


Arrow

Steema.TeeChart.Styles.SeriesMarks.Arrow Property

The Pen used to draw a line connecting Marks to Series points.
public ChartPen Arrow {get;}

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


ArrowLength

Steema.TeeChart.Styles.SeriesMarks.ArrowLength Property

The length in pixels for the line connecting the Mark to Series point.
public Int32 ArrowLength {get; set;}

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


BackColor

Steema.TeeChart.Styles.SeriesMarks.BackColor Property

public Color BackColor {get; set;}

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


Callout

Steema.TeeChart.Styles.SeriesMarks.Callout Property

Marks Callout characteristics
public MarksCallout Callout {get;}

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


Clip

Steema.TeeChart.Styles.SeriesMarks.Clip Property

Restricts Marks to Chart axes space, when true.
public Boolean Clip {get; set;}

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


DrawEvery

Steema.TeeChart.Styles.SeriesMarks.DrawEvery Property

The number of Marks to skip. ( Default is 1, all Marks are displayed ).
public Int32 DrawEvery {get; set;}

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


FontSeriesColor

Steema.TeeChart.Styles.SeriesMarks.FontSeriesColor Property

Font Color in Mark texts are given from its point Color.
public Boolean FontSeriesColor {get; set;}

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


Frame

Steema.TeeChart.Styles.SeriesMarks.Frame Property

public ChartPen Frame {get;}

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


InflateMargins

Steema.TeeChart.Styles.SeriesMarks.InflateMargins Property

Expands axes to fit Series Marks.
public Boolean InflateMargins {get; set;}

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


Items

Steema.TeeChart.Styles.SeriesMarks.Items Property

public MarksItems Items {get;}

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


Lines

Steema.TeeChart.Styles.SeriesMarks.Lines Property

public String[] Lines {get; set;}

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


MultiLine

Steema.TeeChart.Styles.SeriesMarks.MultiLine Property

Characters in Mark texts are split into multiple lines, when true.
public Boolean MultiLine {get; set;}

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


OnTop

Steema.TeeChart.Styles.SeriesMarks.OnTop Property

Gets or sets a value which determines if Series Marks are always drawn on top of all other Series in the Chart.
public Boolean OnTop {get; set;}

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


Positions

Steema.TeeChart.Styles.SeriesMarks.Positions Property

public MarkPositions Positions {get;}

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


Series

Steema.TeeChart.Styles.SeriesMarks.Series Property

public Series Series {get; set;}

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


SoftClip

Steema.TeeChart.Styles.SeriesMarks.SoftClip Property

Gets and sets whether Marks are selectively restricted to the axes space.
public Boolean SoftClip {get; set;}

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


Style

Steema.TeeChart.Styles.SeriesMarks.Style Property

Defines how Series Marks are constructed.
public MarksStyles Style {get; set;}

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


Symbol

Steema.TeeChart.Styles.SeriesMarks.Symbol Property

public Symbols Symbol {get;}

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


ZPosition

Steema.TeeChart.Styles.SeriesMarks.ZPosition Property

Sets Position in pixels on the Z axis.
public Int32 ZPosition {get; set;}

See Also

SeriesMarks Class | SeriesMarks Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarks.MarkPositions

Steema.TeeChart.Styles.SeriesMarks.MarkPositions Class

Series Marks' Positions

For a list of all members of this type, see MarkPositions Members

System.Object
System.Collections.ArrayList
public class MarkPositions : ArrayList , IList, ICollection, IEnumerable
, ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

MarkPositions members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarks.MarkPositionsMembers

Steema.TeeChart.Styles.SeriesMarks.MarkPositions all Members

MarkPositions overview

Constructors

Steema.TeeChart.Styles.SeriesMarks.MarkPositions..ctor

Public Methods

ExistCustom | Checks for Custom Marks
MoveTo |

Public Properties

Item

See Also

MarkPositions Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarks+MarkPositions Constructor

public SeriesMarks+MarkPositions()

See Also

MarkPositions Class | MarkPositions Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarks.MarkPositionsMethods

Steema.TeeChart.Styles.SeriesMarks.MarkPositions Methods

Public Methods

ExistCustom | Checks for Custom Marks
MoveTo |

See Also

MarkPositions Class | Steema.TeeChart.Styles Namespace


ExistCustom

Steema.TeeChart.Styles.SeriesMarks+MarkPositions.ExistCustom Method

Checks for Custom Marks
public Boolean ExistCustom()

Return Value

true if Custom exists

See Also

MarkPositions Class | MarkPositions Members | Steema.TeeChart.Styles Namespace


MoveTo

Steema.TeeChart.Styles.SeriesMarks+MarkPositions.MoveTo Method

public Void MoveTo(Position& position,
     Int32 xpos,
     Int32 ypos)

See Also

MarkPositions Class | MarkPositions Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarks.MarkPositionsProperties

Steema.TeeChart.Styles.SeriesMarks.MarkPositions Properties

Public Properties

Item

See Also

MarkPositions Class | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.SeriesMarks+MarkPositions.Item Property

public Position Item(Int32 index) {get; set;}

See Also

MarkPositions Class | MarkPositions Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarks.Position

Steema.TeeChart.Styles.SeriesMarks.Position Class

Series Mark Position

For a list of all members of this type, see Position Members

System.Object
public class Position : Object

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Position members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarks.PositionMembers

Steema.TeeChart.Styles.SeriesMarks.Position all Members

Position overview

Constructors

Steema.TeeChart.Styles.SeriesMarks.Position..ctor

Public Fields

ArrowFix
ArrowFrom
ArrowTo
Custom
HasMid
Height
LeftTop
MidPoint
Width

Public Methods

Assign

Public Properties

Bounds Returns the bounding rectangle of the indexed Mark.

See Also

Position Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarks+Position Constructor

public SeriesMarks+Position()

See Also

Position Class | Position Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarks.PositionFields

Steema.TeeChart.Styles.SeriesMarks.Position Fields

Public Fields

ArrowFix
ArrowFrom
ArrowTo
Custom
HasMid
Height
LeftTop
MidPoint
Width

See Also

Position Class | Steema.TeeChart.Styles Namespace


ArrowFix

Steema.TeeChart.Styles.SeriesMarks+Position.ArrowFix Field

public Boolean ArrowFix

See Also

Position Class | Position Members | Steema.TeeChart.Styles Namespace


ArrowFrom

Steema.TeeChart.Styles.SeriesMarks+Position.ArrowFrom Field

public Point ArrowFrom

See Also

Position Class | Position Members | Steema.TeeChart.Styles Namespace


ArrowTo

Steema.TeeChart.Styles.SeriesMarks+Position.ArrowTo Field

public Point ArrowTo

See Also

Position Class | Position Members | Steema.TeeChart.Styles Namespace


Custom

Steema.TeeChart.Styles.SeriesMarks+Position.Custom Field

public Boolean Custom

See Also

Position Class | Position Members | Steema.TeeChart.Styles Namespace


HasMid

Steema.TeeChart.Styles.SeriesMarks+Position.HasMid Field

public Boolean HasMid

See Also

Position Class | Position Members | Steema.TeeChart.Styles Namespace


Height

Steema.TeeChart.Styles.SeriesMarks+Position.Height Field

public Int32 Height

See Also

Position Class | Position Members | Steema.TeeChart.Styles Namespace


LeftTop

Steema.TeeChart.Styles.SeriesMarks+Position.LeftTop Field

public Point LeftTop

See Also

Position Class | Position Members | Steema.TeeChart.Styles Namespace


MidPoint

Steema.TeeChart.Styles.SeriesMarks+Position.MidPoint Field

public Point MidPoint

See Also

Position Class | Position Members | Steema.TeeChart.Styles Namespace


Width

Steema.TeeChart.Styles.SeriesMarks+Position.Width Field

public Int32 Width

See Also

Position Class | Position Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarks.PositionMethods

Steema.TeeChart.Styles.SeriesMarks.Position Methods

Public Methods

Assign

See Also

Position Class | Steema.TeeChart.Styles Namespace


Assign

Steema.TeeChart.Styles.SeriesMarks+Position.Assign Method

public Void Assign(Position source)

See Also

Position Class | Position Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarks.PositionProperties

Steema.TeeChart.Styles.SeriesMarks.Position Properties

Public Properties

Bounds Returns the bounding rectangle of the indexed Mark.

See Also

Position Class | Steema.TeeChart.Styles Namespace


Bounds

Steema.TeeChart.Styles.SeriesMarks+Position.Bounds Property

Returns the bounding rectangle of the indexed Mark.
public Rectangle Bounds {get;}

See Also

Position Class | Position Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarks.Symbols

Steema.TeeChart.Styles.SeriesMarks.Symbols Class

Series Mark Symbols

For a list of all members of this type, see Symbols Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
public class Symbols : Shape , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Symbols members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarks.SymbolsMembers

Steema.TeeChart.Styles.SeriesMarks.Symbols all Members

Symbols overview

Public Methods

Assign (inherited from Shape) | Assign all properties from a shape to another.
Clone (inherited from Shape) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from Shape) |

Public Properties

Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Shape) | Defines the shape Color.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

Constructors

Steema.TeeChart.Styles.SeriesMarks.Symbols..ctor

See Also

Symbols Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarks.SymbolsMethods

Steema.TeeChart.Styles.SeriesMarks.Symbols Methods

Public Methods

Assign (inherited from Shape) | Assign all properties from a shape to another.
Clone (inherited from Shape) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from Shape) |

See Also

Symbols Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarks.SymbolsProperties

Steema.TeeChart.Styles.SeriesMarks.Symbols Properties

Public Properties

Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Shape) | Defines the shape Color.
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

Symbols Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesMarks+Symbols Constructor

public SeriesMarks+Symbols(Chart c)

See Also

Symbols Class | Symbols Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesOHLCPoint

Steema.TeeChart.Styles.SeriesOHLCPoint Class

Class provides access to XYZ Point characteristics

For a list of all members of this type, see SeriesOHLCPoint Members

System.Object
Steema.TeeChart.Styles.SeriesPoint
public class SeriesOHLCPoint : SeriesPoint

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

SeriesOHLCPoint members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesOHLCPointMembers

Steema.TeeChart.Styles.SeriesOHLCPoint all Members

SeriesOHLCPoint overview

Constructors

Constructor Overloaded

Public Properties

Close | Indexed Point Close value
Color (inherited from SeriesPoint) | Indexed Point Color
Date | Indexed Point Date value
High | Indexed Point High value
Label (inherited from SeriesPoint) | Indexed Point Label
Low | Indexed Point Low value
Open | Indexed Point Open value

See Also

SeriesOHLCPoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesOHLCPoint Constructor

Overload List

public SeriesOHLCPoint()
public SeriesOHLCPoint(Steema.TeeChart.Styles.OHLC, System.Int32)

See Also

SeriesOHLCPoint Class | SeriesOHLCPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesOHLCPoint Constructor

public SeriesOHLCPoint(OHLC s,
     Int32 i)

See Also

SeriesOHLCPoint Constructor Overload List | SeriesOHLCPoint Class | SeriesOHLCPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesOHLCPoint Constructor

public SeriesOHLCPoint()

See Also

SeriesOHLCPoint Constructor Overload List | SeriesOHLCPoint Class | SeriesOHLCPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesOHLCPointProperties

Steema.TeeChart.Styles.SeriesOHLCPoint Properties

Public Properties

Close | Indexed Point Close value
Color (inherited from SeriesPoint) | Indexed Point Color
Date | Indexed Point Date value
High | Indexed Point High value
Label (inherited from SeriesPoint) | Indexed Point Label
Low | Indexed Point Low value
Open | Indexed Point Open value

See Also

SeriesOHLCPoint Class | Steema.TeeChart.Styles Namespace


Close

Steema.TeeChart.Styles.SeriesOHLCPoint.Close Property

Indexed Point Close value
public Double Close {get; set;}

See Also

SeriesOHLCPoint Class | SeriesOHLCPoint Members | Steema.TeeChart.Styles Namespace


Date

Steema.TeeChart.Styles.SeriesOHLCPoint.Date Property

Indexed Point Date value
public Double Date {get; set;}

See Also

SeriesOHLCPoint Class | SeriesOHLCPoint Members | Steema.TeeChart.Styles Namespace


High

Steema.TeeChart.Styles.SeriesOHLCPoint.High Property

Indexed Point High value
public Double High {get; set;}

See Also

SeriesOHLCPoint Class | SeriesOHLCPoint Members | Steema.TeeChart.Styles Namespace


Low

Steema.TeeChart.Styles.SeriesOHLCPoint.Low Property

Indexed Point Low value
public Double Low {get; set;}

See Also

SeriesOHLCPoint Class | SeriesOHLCPoint Members | Steema.TeeChart.Styles Namespace


Open

Steema.TeeChart.Styles.SeriesOHLCPoint.Open Property

Indexed Point Open value
public Double Open {get; set;}

See Also

SeriesOHLCPoint Class | SeriesOHLCPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesPoint

Steema.TeeChart.Styles.SeriesPoint Class

Class provides access to Point characteristics

For a list of all members of this type, see SeriesPoint Members

System.Object
public class SeriesPoint : Object

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

SeriesPoint members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesPointMembers

Steema.TeeChart.Styles.SeriesPoint all Members

SeriesPoint overview

Constructors

Constructor Overloaded

Public Properties

Color | Indexed Point Color
Label | Indexed Point Label

See Also

SeriesPoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesPoint Constructor

Overload List

public SeriesPoint()
public SeriesPoint(Steema.TeeChart.Styles.Series, System.Int32)

See Also

SeriesPoint Class | SeriesPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesPoint Constructor

public SeriesPoint(Series s,
     Int32 i)

See Also

SeriesPoint Constructor Overload List | SeriesPoint Class | SeriesPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesPoint Constructor

public SeriesPoint()

See Also

SeriesPoint Constructor Overload List | SeriesPoint Class | SeriesPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesPointProperties

Steema.TeeChart.Styles.SeriesPoint Properties

Public Properties

Color | Indexed Point Color
Label | Indexed Point Label

See Also

SeriesPoint Class | Steema.TeeChart.Styles Namespace


Color

Steema.TeeChart.Styles.SeriesPoint.Color Property

Indexed Point Color
public Color Color {get; set;}

See Also

SeriesPoint Class | SeriesPoint Members | Steema.TeeChart.Styles Namespace


Label

Steema.TeeChart.Styles.SeriesPoint.Label Property

Indexed Point Label
public String Label {get; set;}

See Also

SeriesPoint Class | SeriesPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesPointer

Steema.TeeChart.Styles.SeriesPointer Class

Some Series have a Pointer property which returns a SeriesPointer class. Pointers are shape figures drawn on each Y point coordinates.

For a list of all members of this type, see SeriesPointer Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class SeriesPointer : TeeBase

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

SeriesPointer members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesPointerMembers

Steema.TeeChart.Styles.SeriesPointer all Members

SeriesPointer overview

Constructors

Constructor

Public Methods

Clone |
Draw | Internal use. Draw Pointer
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Brush | Brush used to fill Series Pointers.
Chart (inherited from TeeBase) | Chart associated with this object
Color | Sets the pointer color.
Dark3D | Fills pointer sides in 3D mode with darker color.
Draw3D | Draws pointer in 3D mode.
EndZ |
Gradient | Configures Gradient filling attributes.
HorizSize | Horizontal size of pointer in pixels.
InflateMargins | Expands axes to fit pointers.
MiddleZ |
Pen | Pen used to draw a frame around Series Pointers.
Series |
StartZ |
Style | Sets the Pointer style.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency | Sets Percent of semiglass effect.
VertSize | Sets Horizontal size of pointer in pixels.
Visible | Shows or hides the pointer.

See Also

SeriesPointer Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesPointer Constructor

public SeriesPointer(Chart c,
     Series s)

See Also

SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesPointerMethods

Steema.TeeChart.Styles.SeriesPointer Methods

Public Methods

Clone |
Draw | Internal use. Draw Pointer
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

See Also

SeriesPointer Class | Steema.TeeChart.Styles Namespace


Clone

Steema.TeeChart.Styles.SeriesPointer.Clone Method

public Object Clone()

See Also

SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.SeriesPointer.Draw Method

Overload List

Internal use. Draw Pointer

public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Boolean, System.Int32, System.Int32, System.Int32, System.Int32, System.Drawing.Color, Steema.TeeChart.Styles.PointerStyles)
public Void Draw(System.Int32, System.Int32, System.Drawing.Color)
public Void Draw(System.Int32, System.Int32, System.Drawing.Color, Steema.TeeChart.Styles.PointerStyles)

See Also

SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.SeriesPointer.Draw Method

public Void Draw(Int32 px,
     Int32 py,
     Color colorValue,
     PointerStyles aStyle)

See Also

Draw Overload List | SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.SeriesPointer.Draw Method

public Void Draw(Int32 px,
     Int32 py,
     Color colorValue)

See Also

Draw Overload List | SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.SeriesPointer.Draw Method

Internal use. Draw Pointer
public Void Draw(Graphics3D g,
     Boolean is3D,
     Int32 px,
     Int32 py,
     Int32 tmpHoriz,
     Int32 tmpVert,
     Color colorValue,
     PointerStyles aStyle)

See Also

Draw Overload List | SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesPointerProperties

Steema.TeeChart.Styles.SeriesPointer Properties

Public Properties

Brush | Brush used to fill Series Pointers.
Chart (inherited from TeeBase) | Chart associated with this object
Color | Sets the pointer color.
Dark3D | Fills pointer sides in 3D mode with darker color.
Draw3D | Draws pointer in 3D mode.
EndZ |
Gradient | Configures Gradient filling attributes.
HorizSize | Horizontal size of pointer in pixels.
InflateMargins | Expands axes to fit pointers.
MiddleZ |
Pen | Pen used to draw a frame around Series Pointers.
Series |
StartZ |
Style | Sets the Pointer style.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency | Sets Percent of semiglass effect.
VertSize | Sets Horizontal size of pointer in pixels.
Visible | Shows or hides the pointer.

See Also

SeriesPointer Class | Steema.TeeChart.Styles Namespace


Brush

Steema.TeeChart.Styles.SeriesPointer.Brush Property

Brush used to fill Series Pointers.
public ChartBrush Brush {get; set;}

See Also

SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


Color

Steema.TeeChart.Styles.SeriesPointer.Color Property

Sets the pointer color.
public Color Color {get; set;}

See Also

SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


Dark3D

Steema.TeeChart.Styles.SeriesPointer.Dark3D Property

Fills pointer sides in 3D mode with darker color.
public Boolean Dark3D {get; set;}

See Also

SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


Draw3D

Steema.TeeChart.Styles.SeriesPointer.Draw3D Property

Draws pointer in 3D mode.
public Boolean Draw3D {get; set;}

See Also

SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


EndZ

Steema.TeeChart.Styles.SeriesPointer.EndZ Property

public Int32 EndZ {get;}

See Also

SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


Gradient

Steema.TeeChart.Styles.SeriesPointer.Gradient Property

Configures Gradient filling attributes.
public Gradient Gradient {get;}

See Also

SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


HorizSize

Steema.TeeChart.Styles.SeriesPointer.HorizSize Property

Horizontal size of pointer in pixels.
public Int32 HorizSize {get; set;}

See Also

SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


InflateMargins

Steema.TeeChart.Styles.SeriesPointer.InflateMargins Property

Expands axes to fit pointers.
public Boolean InflateMargins {get; set;}

See Also

SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


MiddleZ

Steema.TeeChart.Styles.SeriesPointer.MiddleZ Property

public Int32 MiddleZ {get;}

See Also

SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


Pen

Steema.TeeChart.Styles.SeriesPointer.Pen Property

Pen used to draw a frame around Series Pointers.
public ChartPen Pen {get; set;}

See Also

SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


Series

Steema.TeeChart.Styles.SeriesPointer.Series Property

public Series Series {get; set;}

See Also

SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


StartZ

Steema.TeeChart.Styles.SeriesPointer.StartZ Property

public Int32 StartZ {get;}

See Also

SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


Style

Steema.TeeChart.Styles.SeriesPointer.Style Property

Sets the Pointer style.
public PointerStyles Style {get; set;}

See Also

SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


Transparency

Steema.TeeChart.Styles.SeriesPointer.Transparency Property

Sets Percent of semiglass effect.
public Int32 Transparency {get; set;}

See Also

SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


VertSize

Steema.TeeChart.Styles.SeriesPointer.VertSize Property

Sets Horizontal size of pointer in pixels.
public Int32 VertSize {get; set;}

See Also

SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


Visible

Steema.TeeChart.Styles.SeriesPointer.Visible Property

Shows or hides the pointer.
public Boolean Visible {get; set;}

See Also

SeriesPointer Class | SeriesPointer Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesXYPoint

Steema.TeeChart.Styles.SeriesXYPoint Class

Class provides access to XY Point characteristics

For a list of all members of this type, see SeriesXYPoint Members

System.Object
Steema.TeeChart.Styles.SeriesPoint
public class SeriesXYPoint : SeriesPoint

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

SeriesXYPoint members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesXYPointMembers

Steema.TeeChart.Styles.SeriesXYPoint all Members

SeriesXYPoint overview

Constructors

Constructor Overloaded

Public Properties

Color (inherited from SeriesPoint) | Indexed Point Color
Label (inherited from SeriesPoint) | Indexed Point Label
X | Indexed Point X value
Y | Indexed Point Y value

See Also

SeriesXYPoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesXYPoint Constructor

Overload List

public SeriesXYPoint()
public SeriesXYPoint(Steema.TeeChart.Styles.Series, System.Int32)

See Also

SeriesXYPoint Class | SeriesXYPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesXYPoint Constructor

public SeriesXYPoint(Series s,
     Int32 i)

See Also

SeriesXYPoint Constructor Overload List | SeriesXYPoint Class | SeriesXYPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesXYPoint Constructor

public SeriesXYPoint()

See Also

SeriesXYPoint Constructor Overload List | SeriesXYPoint Class | SeriesXYPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesXYPointProperties

Steema.TeeChart.Styles.SeriesXYPoint Properties

Public Properties

Color (inherited from SeriesPoint) | Indexed Point Color
Label (inherited from SeriesPoint) | Indexed Point Label
X | Indexed Point X value
Y | Indexed Point Y value

See Also

SeriesXYPoint Class | Steema.TeeChart.Styles Namespace


X

Steema.TeeChart.Styles.SeriesXYPoint.X Property

Indexed Point X value
public Double X {get; set;}

Remarks

Use this property to access each ValueList of the Data Point

Example

line1.Points[3].X=50;
//Sets the 2nd X value of the Line Series to 50

See Also

SeriesXYPoint Class | SeriesXYPoint Members | Steema.TeeChart.Styles Namespace


Y

Steema.TeeChart.Styles.SeriesXYPoint.Y Property

Indexed Point Y value
public Double Y {get; set;}

See Also

SeriesXYPoint Class | SeriesXYPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesXYZPoint

Steema.TeeChart.Styles.SeriesXYZPoint Class

Class provides access to XYZ Point characteristics

For a list of all members of this type, see SeriesXYZPoint Members

System.Object
Steema.TeeChart.Styles.SeriesPoint
Steema.TeeChart.Styles.SeriesXYPoint
public class SeriesXYZPoint : SeriesXYPoint

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

SeriesXYZPoint members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesXYZPointMembers

Steema.TeeChart.Styles.SeriesXYZPoint all Members

SeriesXYZPoint overview

Constructors

Constructor Overloaded

Public Properties

Color (inherited from SeriesPoint) | Indexed Point Color
Label (inherited from SeriesPoint) | Indexed Point Label
X (inherited from SeriesXYPoint) | Indexed Point X value
Y (inherited from SeriesXYPoint) | Indexed Point Y value
Z | Indexed Point Z value

See Also

SeriesXYZPoint Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesXYZPoint Constructor

Overload List

public SeriesXYZPoint()
public SeriesXYZPoint(Steema.TeeChart.Styles.Custom3D, System.Int32)

See Also

SeriesXYZPoint Class | SeriesXYZPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesXYZPoint Constructor

public SeriesXYZPoint(Custom3D s,
     Int32 i)

See Also

SeriesXYZPoint Constructor Overload List | SeriesXYZPoint Class | SeriesXYZPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesXYZPoint Constructor

public SeriesXYZPoint()

See Also

SeriesXYZPoint Constructor Overload List | SeriesXYZPoint Class | SeriesXYZPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SeriesXYZPointProperties

Steema.TeeChart.Styles.SeriesXYZPoint Properties

Public Properties

Color (inherited from SeriesPoint) | Indexed Point Color
Label (inherited from SeriesPoint) | Indexed Point Label
X (inherited from SeriesXYPoint) | Indexed Point X value
Y (inherited from SeriesXYPoint) | Indexed Point Y value
Z | Indexed Point Z value

See Also

SeriesXYZPoint Class | Steema.TeeChart.Styles Namespace


Z

Steema.TeeChart.Styles.SeriesXYZPoint.Z Property

Indexed Point Z value
public Double Z {get; set;}

See Also

SeriesXYZPoint Class | SeriesXYZPoint Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Shape

Steema.TeeChart.Styles.Shape Class

Shape Series.

For a list of all members of this type, see Shape Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class Shape : Series , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Shape members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ShapeMembers

Steema.TeeChart.Styles.Shape all Members

Shape overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf | Returns false if the Value parameter is the same as Self.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
ArcEndAngle | Gets or sets the EndAngle of the Arc.
ArcStartAngle | Gets or sets the StartAngle of the Arc.
Brush | Defines the brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Font | Determines the font attributes used to output ShapeSeries.
Format |
Function (inherited from Series) | Function object to calculate values.
Gradient | Gets Gradient fill characteristics for the ShapeSeries Shape.
HorizAlignment | Horizontally aligns the text.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
ParallelogramOffset | Gets or sets the Offset applied to the Parallelogram shape.
Pen | Defines pen to draw Series Shape.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Style | Defines how a TChartShape component appears on a Chart.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text | Displays customized strings inside Shapes.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparent | Allows Shape Brush attributes to fill the interior of the Shape.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAlignment | Sets the vertical alignment of Text within a TChartShape Series shape.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
X0 | Coordinate used to define the englobing ShapeSeries rectangle.
X1 | Coordinate used to define the englobing ShapeSeries rectangle.
XValues (inherited from Series) | Values defining horizontal point positions.
XYStyle |
Y0 | Coordinate used to define the englobing ShapeSeries rectangle.
Y1 | Coordinate used to define the englobing ShapeSeries rectangle.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Shape Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Shape Constructor

Overload List

public Shape()
public Shape(Steema.TeeChart.Chart)

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Shape Constructor

public Shape(Chart c)

See Also

Shape Constructor Overload List | Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Shape Constructor

public Shape()

See Also

Shape Constructor Overload List | Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ShapeEvents

Steema.TeeChart.Styles.Shape Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Shape Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ShapeFields

Steema.TeeChart.Styles.Shape Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Shape Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ShapeMethods

Steema.TeeChart.Styles.Shape Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf | Returns false if the Value parameter is the same as Self.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Shape Class | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Shape.Clicked Method

Overload List

Returns the ValueIndex of the "clicked" point in the Series.

public override Int32 Clicked(System.Int32, System.Int32)

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Shape.Clicked Method

Returns the ValueIndex of the "clicked" point in the Series.
public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.Shape.DrawValue Method

Called internally. Draws the "ValueIndex" point of the Series.
public override Void DrawValue(Int32 valueIndex)

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


IsValidSourceOf

Steema.TeeChart.Styles.Shape.IsValidSourceOf Method

Returns false if the Value parameter is the same as Self.
public override Boolean IsValidSourceOf(Series s)

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.Shape.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.Shape.SetSubGallery Method

public override Void SetSubGallery(Int32 index)

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ShapeProperties

Steema.TeeChart.Styles.Shape Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
ArcEndAngle | Gets or sets the EndAngle of the Arc.
ArcStartAngle | Gets or sets the StartAngle of the Arc.
Brush | Defines the brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Font | Determines the font attributes used to output ShapeSeries.
Format |
Function (inherited from Series) | Function object to calculate values.
Gradient | Gets Gradient fill characteristics for the ShapeSeries Shape.
HorizAlignment | Horizontally aligns the text.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
ParallelogramOffset | Gets or sets the Offset applied to the Parallelogram shape.
Pen | Defines pen to draw Series Shape.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Style | Defines how a TChartShape component appears on a Chart.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text | Displays customized strings inside Shapes.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparent | Allows Shape Brush attributes to fill the interior of the Shape.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAlignment | Sets the vertical alignment of Text within a TChartShape Series shape.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
X0 | Coordinate used to define the englobing ShapeSeries rectangle.
X1 | Coordinate used to define the englobing ShapeSeries rectangle.
XValues (inherited from Series) | Values defining horizontal point positions.
XYStyle |
Y0 | Coordinate used to define the englobing ShapeSeries rectangle.
Y1 | Coordinate used to define the englobing ShapeSeries rectangle.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Shape Class | Steema.TeeChart.Styles Namespace


ArcEndAngle

Steema.TeeChart.Styles.Shape.ArcEndAngle Property

Gets or sets the EndAngle of the Arc.
public Int32 ArcEndAngle {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


ArcStartAngle

Steema.TeeChart.Styles.Shape.ArcStartAngle Property

Gets or sets the StartAngle of the Arc.
public Int32 ArcStartAngle {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


Brush

Steema.TeeChart.Styles.Shape.Brush Property

Defines the brush used to fill shape background.
public ChartBrush Brush {get;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Shape.Description Property

public override String Description {get;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


Font

Steema.TeeChart.Styles.Shape.Font Property

Determines the font attributes used to output ShapeSeries.
public ChartFont Font {get;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


Format

Steema.TeeChart.Styles.Shape.Format Property

public TextShape Format {get;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


Gradient

Steema.TeeChart.Styles.Shape.Gradient Property

Gets Gradient fill characteristics for the ShapeSeries Shape.
public Gradient Gradient {get;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


HorizAlignment

Steema.TeeChart.Styles.Shape.HorizAlignment Property

Horizontally aligns the text.
public ShapeTextHorizAlign HorizAlignment {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


ParallelogramOffset

Steema.TeeChart.Styles.Shape.ParallelogramOffset Property

Gets or sets the Offset applied to the Parallelogram shape.
public Double ParallelogramOffset {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


Pen

Steema.TeeChart.Styles.Shape.Pen Property

Defines pen to draw Series Shape.
public ChartPen Pen {get;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


Style

Steema.TeeChart.Styles.Shape.Style Property

Defines how a TChartShape component appears on a Chart.
public ShapeStyles Style {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


Text

Steema.TeeChart.Styles.Shape.Text Property

Displays customized strings inside Shapes.
public String[] Text {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


Transparent

Steema.TeeChart.Styles.Shape.Transparent Property

Allows Shape Brush attributes to fill the interior of the Shape.
public Boolean Transparent {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


VertAlignment

Steema.TeeChart.Styles.Shape.VertAlignment Property

Sets the vertical alignment of Text within a TChartShape Series shape.
public ShapeTextVertAlign VertAlignment {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


X0

Steema.TeeChart.Styles.Shape.X0 Property

Coordinate used to define the englobing ShapeSeries rectangle.
public Double X0 {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


X1

Steema.TeeChart.Styles.Shape.X1 Property

Coordinate used to define the englobing ShapeSeries rectangle.
public Double X1 {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


XYStyle

Steema.TeeChart.Styles.Shape.XYStyle Property

public ShapeXYStyles XYStyle {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


Y0

Steema.TeeChart.Styles.Shape.Y0 Property

Coordinate used to define the englobing ShapeSeries rectangle.
public Double Y0 {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


Y1

Steema.TeeChart.Styles.Shape.Y1 Property

Coordinate used to define the englobing ShapeSeries rectangle.
public Double Y1 {get; set;}

See Also

Shape Class | Shape Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ShapeStyles

Steema.TeeChart.Styles.ShapeStyles Enum

Describes the possible values of the Style property.
[Serializable]
public sealed enum ShapeStyles : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
Rectangle | The shape is a rectangle.
Circle | The shape is a circle.
VertLine | The shape is a vertical line.
HorizLine | The shape is a horizontal line.
Triangle | The shape is a triangle.
InvertTriangle | The shape is an inverted triangle.
Line | The shape is a line.
Diamond | The shape is a diamond.
Cube | The shape is a cube.
Cross | The shape is a cross.
DiagCross | The shape is a diagonal cross.
Star | The shape is a star.
Pyramid | The shape is a pyramid.
InvertPyramid | The shape is an inverted pyramid.
Arc | The shape is an arc.
Parallelogram | The shape is an arc.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ShapeTextHorizAlign

Steema.TeeChart.Styles.ShapeTextHorizAlign Enum

Describes the possible values of the HorizAlignment property.
[Serializable]
public sealed enum ShapeTextHorizAlign : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Left | Text is horizontally aligned to the left of the shape.
Center | Text is horizontally aligned to the centre of the shape.
Right | Text is horizontally aligned to the right of the shape.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ShapeTextVertAlign

Steema.TeeChart.Styles.ShapeTextVertAlign Enum

Describes the possible values of the VertAlignment property.
[Serializable]
public sealed enum ShapeTextVertAlign : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Top | Text is vertically aligned to the top of the shape.
Center | Text is vertically aligned to the centre of the shape.
Bottom | Text is vertically aligned to the bottom of the shape.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ShapeXYStyles

Steema.TeeChart.Styles.ShapeXYStyles Enum

Describes the possible values of the XYStyle property.
[Serializable]
public sealed enum ShapeXYStyles : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Pixels | Position relative to Chart Panel. 0,0 is Panel Left, Top.
Axis | Position in Axis units.
AxisOrigin | Use Left,Top (X0,Y0) to set the Axis origin in Axis units. Right, Bottom sets width and height in Pixels.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Sides

Steema.TeeChart.Styles.Sides Enum

Reserved for future use.
[Serializable]
public sealed enum Sides : Enum , IComparable, IFormattable, IConvertible

Public Members

Member Description

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Smith

Steema.TeeChart.Styles.Smith Class

Smith Series.

For a list of all members of this type, see Smith Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
public class Smith : Circular , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Smith members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SmithMembers

Steema.TeeChart.Styles.Smith all Members

Smith overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Circular) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint |
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint |
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush | Defines Brush to fill Chart.
CCirclePen | Defines Pen to draw CCircles of the Smith Series.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CirclePen | Defines Pen to draw external Circle of the Smith Series.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
CLabels | Shows/hides the constant reactance labels.
CLabelsFont | xCircle labels font.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
ImagSymbol |
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen | Defines pen to draw SmithSeries Chart.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer | Defines pen to draw SmithSeries Chart.
RCirclePen | Defines Pen to draw RCircles of the Smith Series.
RLabels | Shows/hides the constant resistance labels.
RLabelsFont | rCircle labels font.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Smith Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Smith Constructor

Overload List

public Smith()
public Smith(Steema.TeeChart.Chart)

See Also

Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Smith Constructor

public Smith(Chart c)

See Also

Smith Constructor Overload List | Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Smith Constructor

public Smith()

See Also

Smith Constructor Overload List | Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SmithEvents

Steema.TeeChart.Styles.Smith Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Smith Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SmithFields

Steema.TeeChart.Styles.Smith Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Smith Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SmithMethods

Steema.TeeChart.Styles.Smith Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Circular) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked | Returns the ValueIndex of the "clicked" point in the Series.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint |
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint |
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Smith Class | Steema.TeeChart.Styles Namespace


CalcXPos

Steema.TeeChart.Styles.Smith.CalcXPos Method

Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
public override Int32 CalcXPos(Int32 valueIndex)

See Also

Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


CalcYPos

Steema.TeeChart.Styles.Smith.CalcYPos Method

Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
public override Int32 CalcYPos(Int32 valueIndex)

See Also

Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Smith.Clicked Method

Overload List

Returns the ValueIndex of the "clicked" point in the Series.

public override Int32 Clicked(System.Int32, System.Int32)

See Also

Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Smith.Clicked Method

Returns the ValueIndex of the "clicked" point in the Series.
public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.Smith.Draw Method

public override Void Draw()

See Also

Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.Smith.DrawValue Method

Called internally. Draws the "ValueIndex" point of the Series.
public override Void DrawValue(Int32 valueIndex)

See Also

Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.Smith.PrepareForGallery Method

public override Void PrepareForGallery(Boolean isEnabled)

See Also

Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


ScreenPointToValuePoint

Steema.TeeChart.Styles.Smith.ScreenPointToValuePoint Method

public override PointDouble ScreenPointToValuePoint(Int32 x,
     Int32 y)

See Also

Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


ValuePointToScreenPoint

Steema.TeeChart.Styles.Smith.ValuePointToScreenPoint Method

public override Point ValuePointToScreenPoint(Double resist,
     Double react)

See Also

Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SmithProperties

Steema.TeeChart.Styles.Smith Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush | Defines Brush to fill Chart.
CCirclePen | Defines Pen to draw CCircles of the Smith Series.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CirclePen | Defines Pen to draw external Circle of the Smith Series.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
CLabels | Shows/hides the constant reactance labels.
CLabelsFont | xCircle labels font.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
ImagSymbol |
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Pen | Defines pen to draw SmithSeries Chart.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer | Defines pen to draw SmithSeries Chart.
RCirclePen | Defines Pen to draw RCircles of the Smith Series.
RLabels | Shows/hides the constant resistance labels.
RLabelsFont | rCircle labels font.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Smith Class | Steema.TeeChart.Styles Namespace


Brush

Steema.TeeChart.Styles.Smith.Brush Property

Defines Brush to fill Chart.
public ChartBrush Brush {get;}

See Also

Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


CCirclePen

Steema.TeeChart.Styles.Smith.CCirclePen Property

Defines Pen to draw CCircles of the Smith Series.
public GridPen CCirclePen {get;}

See Also

Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


CirclePen

Steema.TeeChart.Styles.Smith.CirclePen Property

Defines Pen to draw external Circle of the Smith Series.
public ChartPen CirclePen {get;}

See Also

Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


CLabels

Steema.TeeChart.Styles.Smith.CLabels Property

Shows/hides the constant reactance labels.
public Boolean CLabels {get; set;}

See Also

Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


CLabelsFont

Steema.TeeChart.Styles.Smith.CLabelsFont Property

xCircle labels font.
public ChartFont CLabelsFont {get;}

See Also

Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Smith.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


ImagSymbol

Steema.TeeChart.Styles.Smith.ImagSymbol Property

public String ImagSymbol {get; set;}

See Also

Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


Pen

Steema.TeeChart.Styles.Smith.Pen Property

Defines pen to draw SmithSeries Chart.
public ChartPen Pen {get;}

See Also

Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


Pointer

Steema.TeeChart.Styles.Smith.Pointer Property

Defines pen to draw SmithSeries Chart.
public virtual SeriesPointer Pointer {get; set;}

See Also

Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


RCirclePen

Steema.TeeChart.Styles.Smith.RCirclePen Property

Defines Pen to draw RCircles of the Smith Series.
public GridPen RCirclePen {get;}

See Also

Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


RLabels

Steema.TeeChart.Styles.Smith.RLabels Property

Shows/hides the constant resistance labels.
public Boolean RLabels {get; set;}

See Also

Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


RLabelsFont

Steema.TeeChart.Styles.Smith.RLabelsFont Property

rCircle labels font.
public ChartFont RLabelsFont {get;}

See Also

Smith Class | Smith Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Spacing

Steema.TeeChart.Styles.Spacing Class

For a list of all members of this type, see Spacing Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class Spacing : TeeBase

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Spacing members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SpacingMembers

Steema.TeeChart.Styles.Spacing all Members

Spacing overview

Constructors

Constructor Overloaded

Public Methods

Invalidate (inherited from TeeBase) Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Horizontal |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Vertical |

See Also

Spacing Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Spacing Constructor

Overload List

public Spacing()
public Spacing(Steema.TeeChart.Styles.Series)

See Also

Spacing Class | Spacing Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Spacing Constructor

public Spacing(Series s)

See Also

Spacing Constructor Overload List | Spacing Class | Spacing Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Spacing Constructor

public Spacing()

See Also

Spacing Constructor Overload List | Spacing Class | Spacing Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SpacingMethods

Steema.TeeChart.Styles.Spacing Methods

Public Methods

Invalidate (inherited from TeeBase) Use Invalidate when the entire canvas needs to be repainted.

See Also

Spacing Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SpacingProperties

Steema.TeeChart.Styles.Spacing Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Horizontal |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Vertical |

See Also

Spacing Class | Steema.TeeChart.Styles Namespace


Horizontal

Steema.TeeChart.Styles.Spacing.Horizontal Property

public Int32 Horizontal {get; set;}

See Also

Spacing Class | Spacing Members | Steema.TeeChart.Styles Namespace


Vertical

Steema.TeeChart.Styles.Spacing.Vertical Property

public Int32 Vertical {get; set;}

See Also

Spacing Class | Spacing Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.StringList

Steema.TeeChart.Styles.StringList Class

The StringList class is manipulated via the Series Labels property.

For a list of all members of this type, see StringList Members

System.Object
System.Collections.ArrayList
public class StringList : ArrayList , IList, ICollection, IEnumerable
, ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

StringList members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.StringListMembers

Steema.TeeChart.Styles.StringList all Members

StringList overview

Constructors

Constructor Overloaded

Public Fields

Name

Public Methods

IndexOf

Public Properties

Item

See Also

StringList Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.StringList Constructor

Overload List

public StringList()
public StringList(System.Int32)
public StringList(System.Int32, System.String)

See Also

StringList Class | StringList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.StringList Constructor

public StringList(Int32 capacity,
     String name)

See Also

StringList Constructor Overload List | StringList Class | StringList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.StringList Constructor

public StringList(Int32 capacity)

See Also

StringList Constructor Overload List | StringList Class | StringList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.StringList Constructor

public StringList()

See Also

StringList Constructor Overload List | StringList Class | StringList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.StringListFields

Steema.TeeChart.Styles.StringList Fields

Public Fields

Name

See Also

StringList Class | Steema.TeeChart.Styles Namespace


Name

Steema.TeeChart.Styles.StringList.Name Field

public String Name

See Also

StringList Class | StringList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.StringListMethods

Steema.TeeChart.Styles.StringList Methods

Public Methods

IndexOf

See Also

StringList Class | Steema.TeeChart.Styles Namespace


IndexOf

Steema.TeeChart.Styles.StringList.IndexOf Method

public Int32 IndexOf(String value,
     Boolean caseSensitive)

See Also

StringList Class | StringList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.StringListProperties

Steema.TeeChart.Styles.StringList Properties

Public Properties

Item

See Also

StringList Class | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.StringList.Item Property

public String Item(Int32 index) {get; set;}

See Also

StringList Class | StringList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Surface

Steema.TeeChart.Styles.Surface Class

Surface 3D Series.

For a list of all members of this type, see Surface Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
Steema.TeeChart.Styles.Custom3DGrid
public class Surface : Custom3DGrid , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Surface members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SurfaceMembers

Steema.TeeChart.Styles.Surface all Members

Surface overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
GetYValue (inherited from Custom3DGrid) | Occurs when the Surface Series needs to recreate the grid of values.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
ReuseGridIndex (inherited from Custom3DGrid) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Custom3D) | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CellsOrientation |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Custom3DGrid) | Deletes all Series values.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
CreateValues (inherited from Custom3DGrid) | Makes a Surface grid of NumX by NumZ dimensions.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FastCalcPoints |
FillGridIndex (inherited from Custom3DGrid) |
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom3DPalette) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Custom3DPalette) | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Custom3D) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
DotFrame | Sets SurfaceSeries as a grid of dots (pixels).
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HideCells |
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IrregularGrid (inherited from Custom3DGrid) | Determine if X and Z values are equi-distant or not.
Item (inherited from Custom3DGrid) | A two dimension array property for the easy access to series cell values.
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
NumXValues (inherited from Custom3DGrid) | Determines the Surface's horizontal size in number of points.
NumZValues (inherited from Custom3DGrid) | Determines the Surface's depth size in number of points.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideBrush | Determines the Brush to fill the sides of a Surface Series.
SideLines |
SmoothPalette | Determine the cell Colors of a Surface Series.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
WaterFall | Enables/disables the display as a waterfall.
WaterLines | Sets Pen to draw valuelines.
WireFrame | Shows Surface polygons as grid or wire frame when true.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

Surface Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Surface Constructor

Overload List

public Surface(Steema.TeeChart.Chart)
public Surface()

See Also

Surface Class | Surface Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Surface Constructor

public Surface()

See Also

Surface Constructor Overload List | Surface Class | Surface Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Surface Constructor

public Surface(Chart c)

See Also

Surface Constructor Overload List | Surface Class | Surface Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SurfaceEvents

Steema.TeeChart.Styles.Surface Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
GetYValue (inherited from Custom3DGrid) | Occurs when the Surface Series needs to recreate the grid of values.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Surface Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SurfaceFields

Steema.TeeChart.Styles.Surface Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
ReuseGridIndex (inherited from Custom3DGrid) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Surface Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SurfaceMethods

Steema.TeeChart.Styles.Surface Methods

Public Methods

Add (inherited from Custom3D) | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CellsOrientation |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Custom3DGrid) | Deletes all Series values.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
CreateValues (inherited from Custom3DGrid) | Makes a Surface grid of NumX by NumZ dimensions.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FastCalcPoints |
FillGridIndex (inherited from Custom3DGrid) |
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom3DPalette) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Custom3DPalette) | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Custom3D) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Surface Class | Steema.TeeChart.Styles Namespace


CellsOrientation

Steema.TeeChart.Styles.Surface.CellsOrientation Method

public CellsOrientation CellsOrientation()

See Also

Surface Class | Surface Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Surface.Clicked Method

Overload List

public override Int32 Clicked(System.Int32, System.Int32)

See Also

Surface Class | Surface Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Surface.Clicked Method

public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | Surface Class | Surface Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.Surface.Draw Method

public override Void Draw()

See Also

Surface Class | Surface Members | Steema.TeeChart.Styles Namespace


FastCalcPoints

Steema.TeeChart.Styles.Surface.FastCalcPoints Method

public Boolean FastCalcPoints(Int32 x,
     Int32 z,
     Point3D& p0,
     Point3D& p1,
     Color& color0,
     Color& color1)

See Also

Surface Class | Surface Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.Surface.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

Surface Class | Surface Members | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.Surface.SetSubGallery Method

public override Void SetSubGallery(Int32 index)

See Also

Surface Class | Surface Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SurfaceProperties

Steema.TeeChart.Styles.Surface Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
DotFrame | Sets SurfaceSeries as a grid of dots (pixels).
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HideCells |
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IrregularGrid (inherited from Custom3DGrid) | Determine if X and Z values are equi-distant or not.
Item (inherited from Custom3DGrid) | A two dimension array property for the easy access to series cell values.
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
NumXValues (inherited from Custom3DGrid) | Determines the Surface's horizontal size in number of points.
NumZValues (inherited from Custom3DGrid) | Determines the Surface's depth size in number of points.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideBrush | Determines the Brush to fill the sides of a Surface Series.
SideLines |
SmoothPalette | Determine the cell Colors of a Surface Series.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
WaterFall | Enables/disables the display as a waterfall.
WaterLines | Sets Pen to draw valuelines.
WireFrame | Shows Surface polygons as grid or wire frame when true.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

Surface Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Surface.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

Surface Class | Surface Members | Steema.TeeChart.Styles Namespace


DotFrame

Steema.TeeChart.Styles.Surface.DotFrame Property

Sets SurfaceSeries as a grid of dots (pixels).
public Boolean DotFrame {get; set;}

See Also

Surface Class | Surface Members | Steema.TeeChart.Styles Namespace


HideCells

Steema.TeeChart.Styles.Surface.HideCells Property

public Boolean HideCells {get; set;}

See Also

Surface Class | Surface Members | Steema.TeeChart.Styles Namespace


SideBrush

Steema.TeeChart.Styles.Surface.SideBrush Property

Determines the Brush to fill the sides of a Surface Series.
public ChartBrush SideBrush {get; set;}

See Also

Surface Class | Surface Members | Steema.TeeChart.Styles Namespace


SideLines

Steema.TeeChart.Styles.Surface.SideLines Property

public ChartPen SideLines {get; set;}

See Also

Surface Class | Surface Members | Steema.TeeChart.Styles Namespace


SmoothPalette

Steema.TeeChart.Styles.Surface.SmoothPalette Property

Determine the cell Colors of a Surface Series.
public Boolean SmoothPalette {get; set;}

See Also

Surface Class | Surface Members | Steema.TeeChart.Styles Namespace


WaterFall

Steema.TeeChart.Styles.Surface.WaterFall Property

Enables/disables the display as a waterfall.
public Boolean WaterFall {get; set;}

See Also

Surface Class | Surface Members | Steema.TeeChart.Styles Namespace


WaterLines

Steema.TeeChart.Styles.Surface.WaterLines Property

Sets Pen to draw valuelines.
public ChartPen WaterLines {get;}

See Also

Surface Class | Surface Members | Steema.TeeChart.Styles Namespace


WireFrame

Steema.TeeChart.Styles.Surface.WireFrame Property

Shows Surface polygons as grid or wire frame when true.
public Boolean WireFrame {get; set;}

See Also

Surface Class | Surface Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SurfaceSides

Steema.TeeChart.Styles.SurfaceSides Class

For a list of all members of this type, see SurfaceSides Members

System.Object
public class SurfaceSides : Object

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

SurfaceSides members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SurfaceSidesMembers

Steema.TeeChart.Styles.SurfaceSides all Members

SurfaceSides overview

Constructors

Constructor

Public Properties

Brush
Levels
Pen

See Also

SurfaceSides Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SurfaceSides Constructor

public SurfaceSides(Surface Series)

See Also

SurfaceSides Class | SurfaceSides Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.SurfaceSidesProperties

Steema.TeeChart.Styles.SurfaceSides Properties

Public Properties

Brush
Levels
Pen

See Also

SurfaceSides Class | Steema.TeeChart.Styles Namespace


Brush

Steema.TeeChart.Styles.SurfaceSides.Brush Property

public ChartBrush Brush {get; set;}

See Also

SurfaceSides Class | SurfaceSides Members | Steema.TeeChart.Styles Namespace


Levels

Steema.TeeChart.Styles.SurfaceSides.Levels Property

public Boolean Levels {get; set;}

See Also

SurfaceSides Class | SurfaceSides Members | Steema.TeeChart.Styles Namespace


Pen

Steema.TeeChart.Styles.SurfaceSides.Pen Property

public ChartPen Pen {get; set;}

See Also

SurfaceSides Class | SurfaceSides Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TagCloud

Steema.TeeChart.Styles.TagCloud Class

For a list of all members of this type, see TagCloud Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
public class TagCloud : Custom3DPalette , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

TagCloud members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TagCloudMembers

Steema.TeeChart.Styles.TagCloud all Members

TagCloud overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
DrawTag | The DrawTag event.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
Positions |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Custom3D) | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
AddTag | Adds a tag with given text and value (frequency).
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos |
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos |
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetTagFontSize | Returns the font size of the tag of the specified valueindex.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Custom3DPalette) | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Custom3D) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Custom3DPalette) |
Sort |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
Filter | Gets and sets the string which filters the tags drawn.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Font | Gets and sets the font characteristics of the tags.
Function (inherited from Series) | Function object to calculate values.
Gradient | Gets and sets the gradient.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Custom3D) | XYZ Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TagSeparation | Gets and sets the percentage separation between tags.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

TagCloud Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TagCloud Constructor

Overload List

public TagCloud(Steema.TeeChart.Chart)
public TagCloud()

See Also

TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TagCloud Constructor

public TagCloud()

See Also

TagCloud Constructor Overload List | TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TagCloud Constructor

public TagCloud(Chart c)

See Also

TagCloud Constructor Overload List | TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TagCloudEvents

Steema.TeeChart.Styles.TagCloud Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
DrawTag | The DrawTag event.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

TagCloud Class | Steema.TeeChart.Styles Namespace


DrawTag

Steema.TeeChart.Styles.TagCloud.DrawTag Event

The DrawTag event.
public TagCloudDrawTagEventHandler  DrawTag

See Also

TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TagCloudFields

Steema.TeeChart.Styles.TagCloud Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
Positions |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

TagCloud Class | Steema.TeeChart.Styles Namespace


Positions

Steema.TeeChart.Styles.TagCloud.Positions Field

public Rectangle[] Positions

See Also

TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TagCloudMethods

Steema.TeeChart.Styles.TagCloud Methods

Public Methods

Add (inherited from Custom3D) | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
AddTag | Adds a tag with given text and value (frequency).
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos |
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos |
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetTagFontSize | Returns the font size of the tag of the specified valueindex.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Custom3DPalette) | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Custom3D) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Custom3DPalette) |
Sort |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

TagCloud Class | Steema.TeeChart.Styles Namespace


AddTag

Steema.TeeChart.Styles.TagCloud.AddTag Method

Adds a tag with given text and value (frequency).
public Int32 AddTag(String Text,
     Double Value)

See Also

TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


CalcXPos

Steema.TeeChart.Styles.TagCloud.CalcXPos Method

public override Int32 CalcXPos(Int32 index)

See Also

TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


CalcYPos

Steema.TeeChart.Styles.TagCloud.CalcYPos Method

public override Int32 CalcYPos(Int32 index)

See Also

TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.TagCloud.Clicked Method

Overload List

public override Int32 Clicked(System.Int32, System.Int32)

See Also

TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.TagCloud.Clicked Method

public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.TagCloud.Draw Method

public override Void Draw()

See Also

TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


GalleryChanged3D

Steema.TeeChart.Styles.TagCloud.GalleryChanged3D Method

public override Void GalleryChanged3D(Boolean Is3D)

See Also

TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


GetTagFontSize

Steema.TeeChart.Styles.TagCloud.GetTagFontSize Method

Returns the font size of the tag of the specified valueindex.
public Int32 GetTagFontSize(Int32 ValueIndex)

See Also

TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.TagCloud.PrepareForGallery Method

public override Void PrepareForGallery(Boolean isEnabled)

See Also

TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


Sort

Steema.TeeChart.Styles.TagCloud.Sort Method

Overload List

public Void Sort(Steema.TeeChart.Styles.TagCloudOrder)
public Void Sort(Steema.TeeChart.Styles.TagCloudOrder, Steema.TeeChart.Styles.ValueListOrder)

See Also

TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


Sort

Steema.TeeChart.Styles.TagCloud.Sort Method

public Void Sort(TagCloudOrder SortBy,
     ValueListOrder Order)

See Also

Sort Overload List | TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


Sort

Steema.TeeChart.Styles.TagCloud.Sort Method

public Void Sort(TagCloudOrder SortBy)

See Also

Sort Overload List | TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TagCloudProperties

Steema.TeeChart.Styles.TagCloud Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
Filter | Gets and sets the string which filters the tags drawn.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Font | Gets and sets the font characteristics of the tags.
Function (inherited from Series) | Function object to calculate values.
Gradient | Gets and sets the gradient.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Custom3D) | XYZ Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TagSeparation | Gets and sets the percentage separation between tags.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

TagCloud Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.TagCloud.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


Filter

Steema.TeeChart.Styles.TagCloud.Filter Property

Gets and sets the string which filters the tags drawn.
public String Filter {get; set;}

See Also

TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


Font

Steema.TeeChart.Styles.TagCloud.Font Property

Gets and sets the font characteristics of the tags.
public ChartFont Font {get; set;}

See Also

TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


Gradient

Steema.TeeChart.Styles.TagCloud.Gradient Property

Gets and sets the gradient.
public Gradient Gradient {get; set;}

See Also

TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


TagSeparation

Steema.TeeChart.Styles.TagCloud.TagSeparation Property

Gets and sets the percentage separation between tags.
public Int32 TagSeparation {get; set;}

See Also

TagCloud Class | TagCloud Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TagCloudDrawTagEventArgs

Steema.TeeChart.Styles.TagCloudDrawTagEventArgs Class

For a list of all members of this type, see TagCloudDrawTagEventArgs Members

System.Object
System.EventArgs
public class TagCloudDrawTagEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

TagCloudDrawTagEventArgs members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TagCloudDrawTagEventArgsMembers

Steema.TeeChart.Styles.TagCloudDrawTagEventArgs all Members

TagCloudDrawTagEventArgs overview

Constructors

Constructor

Public Properties

ValueIndex

See Also

TagCloudDrawTagEventArgs Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TagCloudDrawTagEventArgs Constructor

public TagCloudDrawTagEventArgs(Int32 index)

See Also

TagCloudDrawTagEventArgs Class | TagCloudDrawTagEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TagCloudDrawTagEventArgsProperties

Steema.TeeChart.Styles.TagCloudDrawTagEventArgs Properties

Public Properties

ValueIndex

See Also

TagCloudDrawTagEventArgs Class | Steema.TeeChart.Styles Namespace


ValueIndex

Steema.TeeChart.Styles.TagCloudDrawTagEventArgs.ValueIndex Property

public Int32 ValueIndex {get; set;}

See Also

TagCloudDrawTagEventArgs Class | TagCloudDrawTagEventArgs Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TagCloudDrawTagEventHandler

Steema.TeeChart.Styles.TagCloudDrawTagEventHandler Delegate

public delegate TagCloudDrawTagEventHandler (Object sender,
     TagCloudDrawTagEventArgs e)

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TagCloudOrder

Steema.TeeChart.Styles.TagCloudOrder Enum

[Serializable]
public sealed enum TagCloudOrder : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Text |
Value |
None |

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Ternary

Steema.TeeChart.Styles.Ternary Class

Ternary Series.

For a list of all members of this type, see Ternary Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
public class Ternary : Custom3DPalette , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Ternary members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TernaryMembers

Steema.TeeChart.Styles.Ternary all Members

Ternary overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer | Occurs when a series pointer is clicked.
GetPointerStyle | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPointFromValues |
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked |
ClickedPointer |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom3DPalette) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetVertexTitles |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString |
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Custom3D) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Custom3DPalette) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AxisScale |
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient |
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Custom3D) | XYZ Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
LinesPen |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarkStyle |
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer |
RadiusValues |
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
RotateLabels |
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TernaryLegendStyle |
TernaryStyle |
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
VertexA |
VertexB |
VertexC |
VertexTitles |
Visible (inherited from Series) | Shows or hides this series.
WeightValues |
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

Ternary Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Ternary Constructor

Overload List

public Ternary(Steema.TeeChart.Chart)
public Ternary()

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Ternary Constructor

public Ternary()

See Also

Ternary Constructor Overload List | Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Ternary Constructor

public Ternary(Chart c)

See Also

Ternary Constructor Overload List | Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TernaryEvents

Steema.TeeChart.Styles.Ternary Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer | Occurs when a series pointer is clicked.
GetPointerStyle | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Ternary Class | Steema.TeeChart.Styles Namespace


ClickPointer

Steema.TeeChart.Styles.Ternary.ClickPointer Event

Occurs when a series pointer is clicked.
public ClickPointerEventHandler  ClickPointer

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


GetPointerStyle

Steema.TeeChart.Styles.Ternary.GetPointerStyle Event

Occurs on the drawing of the series pointers.
public GetPointerStyleEventHandler  GetPointerStyle

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TernaryFields

Steema.TeeChart.Styles.Ternary Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Ternary Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TernaryMethods

Steema.TeeChart.Styles.Ternary Methods

Public Methods

Add |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPointFromValues |
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked |
ClickedPointer |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom3DPalette) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetVertexTitles |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString |
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Custom3D) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Custom3DPalette) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Ternary Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Ternary.Add Method

Overload List

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Drawing.Color)
public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.String, System.Drawing.Color)
public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Double, System.Drawing.Color)
public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Double, System.String, System.Drawing.Color)

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Ternary.Add Method

public Int32 Add(Double AX,
     Double AY,
     Double AZ,
     Double ARadius,
     Double AWeight,
     String aLabel,
     Color AColor)

See Also

Add Overload List | Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Ternary.Add Method

public Int32 Add(Double AX,
     Double AY,
     Double AZ,
     Double ARadius,
     Double AWeight,
     Color AColor)

See Also

Add Overload List | Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Ternary.Add Method

public Int32 Add(Double AX,
     Double AY,
     Double AZ,
     Double ARadius,
     String aLabel,
     Color AColor)

See Also

Add Overload List | Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Ternary.Add Method

public Int32 Add(Double AX,
     Double AY,
     Double AZ,
     Double ARadius,
     Color AColor)

See Also

Add Overload List | Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


CalcPointFromValues

Steema.TeeChart.Styles.Ternary.CalcPointFromValues Method

public Point CalcPointFromValues(Double a,
     Double b,
     Double c)

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Ternary.Clicked Method

Overload List

public override Int32 Clicked(System.Int32, System.Int32)

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Ternary.Clicked Method

public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


ClickedPointer

Steema.TeeChart.Styles.Ternary.ClickedPointer Method

public Boolean ClickedPointer(Int32 ValueIndex,
     Int32 tmpX,
     Int32 tmpY,
     Int32 x,
     Int32 y)

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.Ternary.Draw Method

public override Void Draw()

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.Ternary.DrawValue Method

public override Void DrawValue(Int32 index)

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


GetVertexTitles

Steema.TeeChart.Styles.Ternary.GetVertexTitles Method

public List`1[] GetVertexTitles()

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


LegendString

Steema.TeeChart.Styles.Ternary.LegendString Method

public override String LegendString(Int32 legendIndex,
     LegendTextStyles legendTextStyle)

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.Ternary.PrepareForGallery Method

public override Void PrepareForGallery(Boolean isEnabled)

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TernaryProperties

Steema.TeeChart.Styles.Ternary Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AxisScale |
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
Gradient |
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Custom3D) | XYZ Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
LinesPen |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MarkStyle |
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer |
RadiusValues |
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
RotateLabels |
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TernaryLegendStyle |
TernaryStyle |
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
VertexA |
VertexB |
VertexC |
VertexTitles |
Visible (inherited from Series) | Shows or hides this series.
WeightValues |
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

Ternary Class | Steema.TeeChart.Styles Namespace


AxisScale

Steema.TeeChart.Styles.Ternary.AxisScale Property

public TernaryAxisScale AxisScale {get; set;}

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Ternary.Description Property

public override String Description {get;}

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


Gradient

Steema.TeeChart.Styles.Ternary.Gradient Property

public Gradient Gradient {get; set;}

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


LinesPen

Steema.TeeChart.Styles.Ternary.LinesPen Property

public ChartPen LinesPen {get; set;}

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


MarkStyle

Steema.TeeChart.Styles.Ternary.MarkStyle Property

public TernaryMarkStyle MarkStyle {get; set;}

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


Pointer

Steema.TeeChart.Styles.Ternary.Pointer Property

public virtual SeriesPointer Pointer {get; set;}

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


RadiusValues

Steema.TeeChart.Styles.Ternary.RadiusValues Property

public ValueList RadiusValues {get; set;}

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


RotateLabels

Steema.TeeChart.Styles.Ternary.RotateLabels Property

public Boolean RotateLabels {get; set;}

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


TernaryLegendStyle

Steema.TeeChart.Styles.Ternary.TernaryLegendStyle Property

public TernaryLegendStyle TernaryLegendStyle {get; set;}

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


TernaryStyle

Steema.TeeChart.Styles.Ternary.TernaryStyle Property

public TernaryStyle TernaryStyle {get; set;}

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


VertexA

Steema.TeeChart.Styles.Ternary.VertexA Property

public Point VertexA {get;}

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


VertexB

Steema.TeeChart.Styles.Ternary.VertexB Property

public Point VertexB {get;}

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


VertexC

Steema.TeeChart.Styles.Ternary.VertexC Property

public Point VertexC {get;}

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


VertexTitles

Steema.TeeChart.Styles.Ternary.VertexTitles Property

public List`1[] VertexTitles {get;}

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


WeightValues

Steema.TeeChart.Styles.Ternary.WeightValues Property

public ValueList WeightValues {get; set;}

See Also

Ternary Class | Ternary Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Ternary.ClickPointerEventHandler

Steema.TeeChart.Styles.Ternary.ClickPointerEventHandler Delegate

The Delegate for the ClickPointer event.
public delegate ClickPointerEventHandler (Ternary series,
     Int32 valueIndex,
     Int32 x,
     Int32 y)

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Ternary.GetPointerStyleEventHandler

Steema.TeeChart.Styles.Ternary.GetPointerStyleEventHandler Delegate

The Delegate for the GetPointerStyle event.
public delegate GetPointerStyleEventHandler (Ternary series,
     GetPointerStyleEventArgs e)

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TernaryAxisScale

Steema.TeeChart.Styles.TernaryAxisScale Enum

[Serializable]
public sealed enum TernaryAxisScale : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Percent |
Unit |

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TernaryFormat

Steema.TeeChart.Styles.TernaryFormat Enum

[Serializable]
public sealed enum TernaryFormat : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Piper |
Ternary |

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TernaryLegendStyle

Steema.TeeChart.Styles.TernaryLegendStyle Enum

[Serializable]
public sealed enum TernaryLegendStyle : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Bubble |
BubbleWeight |
Values |
ValuesBubble |
ValuesBubbleWeight |
Weight |

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TernaryMarkStyle

Steema.TeeChart.Styles.TernaryMarkStyle Enum

[Serializable]
public sealed enum TernaryMarkStyle : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Short |
Long |
LongLabelled |

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TernaryStyle

Steema.TeeChart.Styles.TernaryStyle Enum

[Serializable]
public sealed enum TernaryStyle : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Bubble |
Point |

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TFrame

Steema.TeeChart.Styles.TFrame Class

The TFrame object draws a frame of three bands at the outer edge of an ellipse or circle defined by a rectangle.

For a list of all members of this type, see TFrame Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class TFrame : TeeBase

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

TFrame members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TFrameMembers

Steema.TeeChart.Styles.TFrame all Members

TFrame overview

Constructors

Constructor Overloaded

Public Methods

CalcWidth | Calculates the actual width of the TFrame object in pixels as using the Width property and the rectangle Rect.
Draw |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Circled | Toggles the drawing of a circular or rectangular frame.
GaugeColorPalette | Gets and sets the CircularGauge's color palette.
InnerBand | Gets and sets the InnerBand's ChartBrush characteristics.
MiddleBand | Gets and sets the MiddleBand's ChartBrush characteristics.
OuterBand | Gets and sets the OuterBand's ChartBrush characteristics.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Visible | Gets and sets the visibility of the TFrame object.
Width | Gets and sets the width of the TFrame object as a percentage of its bounding rectangle.

See Also

TFrame Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TFrame Constructor

Overload List

public TFrame(Steema.TeeChart.Chart, System.Drawing.Color[])
public TFrame(Steema.TeeChart.Chart, System.Drawing.Color[], System.Boolean)
public TFrame()

See Also

TFrame Class | TFrame Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TFrame Constructor

public TFrame()

See Also

TFrame Constructor Overload List | TFrame Class | TFrame Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TFrame Constructor

public TFrame(Chart c,
     Color[] gColorPalette,
     Boolean circle)

See Also

TFrame Constructor Overload List | TFrame Class | TFrame Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TFrame Constructor

public TFrame(Chart c,
     Color[] gColorPalette)

See Also

TFrame Constructor Overload List | TFrame Class | TFrame Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TFrameMethods

Steema.TeeChart.Styles.TFrame Methods

Public Methods

CalcWidth | Calculates the actual width of the TFrame object in pixels as using the Width property and the rectangle Rect.
Draw |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

See Also

TFrame Class | Steema.TeeChart.Styles Namespace


CalcWidth

Steema.TeeChart.Styles.TFrame.CalcWidth Method

Calculates the actual width of the TFrame object in pixels as using the Width property and the rectangle Rect.
public Int32 CalcWidth(Rectangle Rect)

See Also

TFrame Class | TFrame Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.TFrame.Draw Method

Overload List

public abstract Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Drawing.Rectangle)

Draw's the TFrame object within the bounds defined by Rect.

public Void Draw(System.Drawing.Rectangle)

See Also

TFrame Class | TFrame Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.TFrame.Draw Method

Draw's the TFrame object within the bounds defined by Rect.
public Void Draw(Rectangle Rect)

See Also

Draw Overload List | TFrame Class | TFrame Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.TFrame.Draw Method

public abstract Void Draw(Graphics3D graphics,
     Rectangle Rect)

See Also

Draw Overload List | TFrame Class | TFrame Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TFrameProperties

Steema.TeeChart.Styles.TFrame Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Circled | Toggles the drawing of a circular or rectangular frame.
GaugeColorPalette | Gets and sets the CircularGauge's color palette.
InnerBand | Gets and sets the InnerBand's ChartBrush characteristics.
MiddleBand | Gets and sets the MiddleBand's ChartBrush characteristics.
OuterBand | Gets and sets the OuterBand's ChartBrush characteristics.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Visible | Gets and sets the visibility of the TFrame object.
Width | Gets and sets the width of the TFrame object as a percentage of its bounding rectangle.

See Also

TFrame Class | Steema.TeeChart.Styles Namespace


Circled

Steema.TeeChart.Styles.TFrame.Circled Property

Toggles the drawing of a circular or rectangular frame.
public Boolean Circled {get; set;}

See Also

TFrame Class | TFrame Members | Steema.TeeChart.Styles Namespace


GaugeColorPalette

Steema.TeeChart.Styles.TFrame.GaugeColorPalette Property

Gets and sets the CircularGauge's color palette.
public Color[] GaugeColorPalette {get; set;}

See Also

TFrame Class | TFrame Members | Steema.TeeChart.Styles Namespace


InnerBand

Steema.TeeChart.Styles.TFrame.InnerBand Property

Gets and sets the InnerBand's ChartBrush characteristics.
public ChartBrush InnerBand {get; set;}

See Also

TFrame Class | TFrame Members | Steema.TeeChart.Styles Namespace


MiddleBand

Steema.TeeChart.Styles.TFrame.MiddleBand Property

Gets and sets the MiddleBand's ChartBrush characteristics.
public ChartBrush MiddleBand {get; set;}

See Also

TFrame Class | TFrame Members | Steema.TeeChart.Styles Namespace


OuterBand

Steema.TeeChart.Styles.TFrame.OuterBand Property

Gets and sets the OuterBand's ChartBrush characteristics.
public ChartBrush OuterBand {get; set;}

See Also

TFrame Class | TFrame Members | Steema.TeeChart.Styles Namespace


Visible

Steema.TeeChart.Styles.TFrame.Visible Property

Gets and sets the visibility of the TFrame object.
public Boolean Visible {get; set;}

See Also

TFrame Class | TFrame Members | Steema.TeeChart.Styles Namespace


Width

Steema.TeeChart.Styles.TFrame.Width Property

Gets and sets the width of the TFrame object as a percentage of its bounding rectangle.
public Int32 Width {get; set;}

See Also

TFrame Class | TFrame Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Tower

Steema.TeeChart.Styles.Tower Class

Tower Series. The Tower Series is designed to use a 0 or 1 based integer grid index. X and Z values should be sequential values of 1.

For a list of all members of this type, see Tower Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
Steema.TeeChart.Styles.Custom3DGrid
public class Tower : Custom3DGrid , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Tower members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TowerMembers

Steema.TeeChart.Styles.Tower all Members

Tower overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
GetYValue (inherited from Custom3DGrid) | Occurs when the Surface Series needs to recreate the grid of values.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
ReuseGridIndex (inherited from Custom3DGrid) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Custom3D) | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos |
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Custom3DGrid) | Deletes all Series values.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
CreateValues (inherited from Custom3DGrid) | Makes a Surface grid of NumX by NumZ dimensions.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillGridIndex (inherited from Custom3DGrid) |
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom3DPalette) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetOriginPos |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Custom3DPalette) | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue |
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue |
MinXValue |
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue |
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D |
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IrregularGrid (inherited from Custom3DGrid) | Determine if X and Z values are equi-distant or not.
Item (inherited from Custom3DGrid) | A two dimension array property for the easy access to series cell values.
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
NumXValues (inherited from Custom3DGrid) | Determines the Surface's horizontal size in number of points.
NumZValues (inherited from Custom3DGrid) | Determines the Surface's depth size in number of points.
Origin |
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentDepth |
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
PercentWidth |
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked | Gets and sets whether the Tower series should be stacked.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
TowerStyle |
Transparency |
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UseOrigin |
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

Tower Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Tower Constructor

Overload List

public Tower()
public Tower(Steema.TeeChart.Chart)

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Tower Constructor

public Tower(Chart c)

See Also

Tower Constructor Overload List | Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Tower Constructor

public Tower()

See Also

Tower Constructor Overload List | Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TowerEvents

Steema.TeeChart.Styles.Tower Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
GetYValue (inherited from Custom3DGrid) | Occurs when the Surface Series needs to recreate the grid of values.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Tower Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TowerFields

Steema.TeeChart.Styles.Tower Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
ReuseGridIndex (inherited from Custom3DGrid) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Tower Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TowerMethods

Steema.TeeChart.Styles.Tower Methods

Public Methods

Add (inherited from Custom3D) | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos |
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Custom3DGrid) | Deletes all Series values.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
CreateValues (inherited from Custom3DGrid) | Makes a Surface grid of NumX by NumZ dimensions.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillGridIndex (inherited from Custom3DGrid) |
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom3DPalette) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
GetOriginPos |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Custom3DPalette) | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue |
MaxYValue | Returns the Maximum Value of the Series Y Values List.
MaxZValue |
MinXValue |
MinYValue | Returns the Minimum Value of the Series Y Values List.
MinZValue |
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Tower Class | Steema.TeeChart.Styles Namespace


CalcYPos

Steema.TeeChart.Styles.Tower.CalcYPos Method

public override Int32 CalcYPos(Int32 valueIndex)

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Tower.Clicked Method

Overload List

public override Int32 Clicked(System.Int32, System.Int32)

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.Tower.Clicked Method

public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.Tower.Draw Method

public override Void Draw()

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


GetOriginPos

Steema.TeeChart.Styles.Tower.GetOriginPos Method

public Int32 GetOriginPos(Int32 valueIndex)

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.Tower.MaxXValue Method

public override Double MaxXValue()

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.Tower.MaxYValue Method

Returns the Maximum Value of the Series Y Values List.
public override Double MaxYValue()

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


MaxZValue

Steema.TeeChart.Styles.Tower.MaxZValue Method

public override Double MaxZValue()

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


MinXValue

Steema.TeeChart.Styles.Tower.MinXValue Method

public override Double MinXValue()

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.Tower.MinYValue Method

Returns the Minimum Value of the Series Y Values List.
public override Double MinYValue()

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


MinZValue

Steema.TeeChart.Styles.Tower.MinZValue Method

public override Double MinZValue()

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.Tower.PrepareForGallery Method

public override Void PrepareForGallery(Boolean isEnabled)

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.Tower.SetSubGallery Method

public override Void SetSubGallery(Int32 index)

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TowerProperties

Steema.TeeChart.Styles.Tower Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D |
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IrregularGrid (inherited from Custom3DGrid) | Determine if X and Z values are equi-distant or not.
Item (inherited from Custom3DGrid) | A two dimension array property for the easy access to series cell values.
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
NumXValues (inherited from Custom3DGrid) | Determines the Surface's horizontal size in number of points.
NumZValues (inherited from Custom3DGrid) | Determines the Surface's depth size in number of points.
Origin |
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentDepth |
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
PercentWidth |
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Stacked | Gets and sets whether the Tower series should be stacked.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
TowerStyle |
Transparency |
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UseOrigin |
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

Tower Class | Steema.TeeChart.Styles Namespace


Dark3D

Steema.TeeChart.Styles.Tower.Dark3D Property

public Boolean Dark3D {get; set;}

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Tower.Description Property

public override String Description {get;}

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


Origin

Steema.TeeChart.Styles.Tower.Origin Property

public Double Origin {get; set;}

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


PercentDepth

Steema.TeeChart.Styles.Tower.PercentDepth Property

public Int32 PercentDepth {get; set;}

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


PercentWidth

Steema.TeeChart.Styles.Tower.PercentWidth Property

public Int32 PercentWidth {get; set;}

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


Stacked

Steema.TeeChart.Styles.Tower.Stacked Property

Gets and sets whether the Tower series should be stacked.
public Boolean Stacked {get; set;}

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


TowerStyle

Steema.TeeChart.Styles.Tower.TowerStyle Property

public TowerStyles TowerStyle {get; set;}

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


Transparency

Steema.TeeChart.Styles.Tower.Transparency Property

public Int32 Transparency {get; set;}

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


UseOrigin

Steema.TeeChart.Styles.Tower.UseOrigin Property

public Boolean UseOrigin {get; set;}

See Also

Tower Class | Tower Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TowerStyles

Steema.TeeChart.Styles.TowerStyles Enum

Describes the possible values of the TowerStyle property.
[Serializable]
public sealed enum TowerStyles : Enum , IComparable, IFormattable, IConvertible

Public Members

Member | Description
Cube | Defines Tower series points as cubes.
Rectangle | Defines Tower series points as rectangles.
Cover | Defines Tower series points as covers.
Cylinder | Defines Tower series points as cylinders.
Arrow | Defines Tower series points as arrows.
Cone | Defines Tower series points as cones.
Pyramid | Defines Tower series points as pyramids.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TreatNullsStyle

Steema.TeeChart.Styles.TreatNullsStyle Enum

Defines how to treat null points.
[Serializable]
public sealed enum TreatNullsStyle : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
DoNotPaint | Null points are not painted, but they are still used in other calculations.
Skip | Null points are skipped in drawing and calculations. The Null points themselves are not painted, but the regular points are connected with a line (in case of Line Series). That results in no gaps.
Ignore | Null points are completely ignored.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TreeMap

Steema.TeeChart.Styles.TreeMap Class

TreeMap Series

For a list of all members of this type, see TreeMap Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.OrgSeries
public class TreeMap : OrgSeries , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

TreeMap members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TreeMapMembers

Steema.TeeChart.Styles.TreeMap all Members

TreeMap overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from OrgSeries) |
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from OrgSeries) |
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from OrgSeries) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from OrgSeries) |
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstChild (inherited from OrgSeries) |
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate |
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from OrgSeries) |
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxLevels |
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor |
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Bounds (inherited from OrgSeries) | Bounding rectangle.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ColorStyle |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Format (inherited from OrgSeries) | Default format for organizational chart items.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from OrgSeries) | Organizational chart item.
Items (inherited from OrgSeries) | Organizational chart items.
ItemSpacing (inherited from OrgSeries) | Vertical and horizontal spacing between organizational chart items.
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineStyle (inherited from OrgSeries) | How the connecting lines are drawn.
MapStyle |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Palette |
PaletteSteps |
Pen (inherited from OrgSeries) |
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

TreeMap Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TreeMap Constructor

Overload List

public TreeMap()
public TreeMap(Steema.TeeChart.Chart)

See Also

TreeMap Class | TreeMap Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TreeMap Constructor

public TreeMap(Chart c)

See Also

TreeMap Constructor Overload List | TreeMap Class | TreeMap Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TreeMap Constructor

public TreeMap()

See Also

TreeMap Constructor Overload List | TreeMap Class | TreeMap Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TreeMapEvents

Steema.TeeChart.Styles.TreeMap Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

TreeMap Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TreeMapFields

Steema.TeeChart.Styles.TreeMap Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

TreeMap Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TreeMapMethods

Steema.TeeChart.Styles.TreeMap Methods

Public Methods

Add |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from OrgSeries) |
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from OrgSeries) |
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from OrgSeries) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from OrgSeries) |
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstChild (inherited from OrgSeries) |
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate |
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from OrgSeries) |
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxLevels |
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor |
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

TreeMap Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.TreeMap.Add Method

Overload List

public override Int32 Add(System.String, System.Double)
public Int32 Add(System.String, System.Int32, System.Double)

See Also

TreeMap Class | TreeMap Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.TreeMap.Add Method

public Int32 Add(String aText,
     Int32 aSuperior,
     Double aValue)

See Also

Add Overload List | TreeMap Class | TreeMap Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.TreeMap.Add Method

public override Int32 Add(String aText,
     Double aValue)

See Also

Add Overload List | TreeMap Class | TreeMap Members | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.TreeMap.AssignFormat Method

Overload List

public override Void AssignFormat(Steema.TeeChart.Styles.Series, Steema.TeeChart.Styles.Series)

See Also

TreeMap Class | TreeMap Members | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.TreeMap.AssignFormat Method

public override Void AssignFormat(Series source,
     Series target)

See Also

AssignFormat Overload List | TreeMap Class | TreeMap Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.TreeMap.Draw Method

public override Void Draw()

See Also

TreeMap Class | TreeMap Members | Steema.TeeChart.Styles Namespace


Invalidate

Steema.TeeChart.Styles.TreeMap.Invalidate Method

public override Void Invalidate()

See Also

TreeMap Class | TreeMap Members | Steema.TeeChart.Styles Namespace


MaxLevels

Steema.TeeChart.Styles.TreeMap.MaxLevels Method

public Int32 MaxLevels()

See Also

TreeMap Class | TreeMap Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.TreeMap.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

TreeMap Class | TreeMap Members | Steema.TeeChart.Styles Namespace


ValueColor

Steema.TeeChart.Styles.TreeMap.ValueColor Method

public override Color ValueColor(Int32 valueIndex)

See Also

TreeMap Class | TreeMap Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TreeMapProperties

Steema.TeeChart.Styles.TreeMap Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Bounds (inherited from OrgSeries) | Bounding rectangle.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ColorStyle |
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Format (inherited from OrgSeries) | Default format for organizational chart items.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from OrgSeries) | Organizational chart item.
Items (inherited from OrgSeries) | Organizational chart items.
ItemSpacing (inherited from OrgSeries) | Vertical and horizontal spacing between organizational chart items.
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineStyle (inherited from OrgSeries) | How the connecting lines are drawn.
MapStyle |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Palette |
PaletteSteps |
Pen (inherited from OrgSeries) |
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

TreeMap Class | Steema.TeeChart.Styles Namespace


ColorStyle

Steema.TeeChart.Styles.TreeMap.ColorStyle Property

public TreeMapColorStyle ColorStyle {get; set;}

See Also

TreeMap Class | TreeMap Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.TreeMap.Description Property

public override String Description {get;}

See Also

TreeMap Class | TreeMap Members | Steema.TeeChart.Styles Namespace


MapStyle

Steema.TeeChart.Styles.TreeMap.MapStyle Property

public TreeMapTiling MapStyle {get; set;}

See Also

TreeMap Class | TreeMap Members | Steema.TeeChart.Styles Namespace


Palette

Steema.TeeChart.Styles.TreeMap.Palette Property

public GridColorPalette Palette {get; set;}

See Also

TreeMap Class | TreeMap Members | Steema.TeeChart.Styles Namespace


PaletteSteps

Steema.TeeChart.Styles.TreeMap.PaletteSteps Property

public Int32 PaletteSteps {get; set;}

See Also

TreeMap Class | TreeMap Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TreeMapColorStyle

Steema.TeeChart.Styles.TreeMapColorStyle Enum

[Serializable]
public sealed enum TreeMapColorStyle : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
ByLevel |
ByValue |

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TreeMapItem

Steema.TeeChart.Styles.TreeMapItem Class

For a list of all members of this type, see TreeMapItem Members

System.Object
Steema.TeeChart.Styles.OrgItem
public class TreeMapItem : OrgItem

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

TreeMapItem members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TreeMapItemMembers

Steema.TeeChart.Styles.TreeMapItem all Members

TreeMapItem overview

Constructors

Constructor

Public Methods

AddBrother (inherited from OrgItem)
AddChild (inherited from OrgItem)
Level (inherited from OrgItem)
Parent (inherited from OrgItem)

Public Properties

Format (inherited from OrgItem)
Index (inherited from OrgItem)
Series (inherited from OrgItem)
Superior (inherited from OrgItem)
Text (inherited from OrgItem)
Value

See Also

TreeMapItem Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TreeMapItem Constructor

public TreeMapItem(OrgItems Collection)

See Also

TreeMapItem Class | TreeMapItem Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TreeMapItemMethods

Steema.TeeChart.Styles.TreeMapItem Methods

Public Methods

AddBrother (inherited from OrgItem)
AddChild (inherited from OrgItem)
Level (inherited from OrgItem)
Parent (inherited from OrgItem)

See Also

TreeMapItem Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TreeMapItemProperties

Steema.TeeChart.Styles.TreeMapItem Properties

Public Properties

Format (inherited from OrgItem)
Index (inherited from OrgItem)
Series (inherited from OrgItem)
Superior (inherited from OrgItem)
Text (inherited from OrgItem)
Value

See Also

TreeMapItem Class | Steema.TeeChart.Styles Namespace


Value

Steema.TeeChart.Styles.TreeMapItem.Value Property

public Double Value {get; set;}

See Also

TreeMapItem Class | TreeMapItem Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TreeMapTiling

Steema.TeeChart.Styles.TreeMapTiling Enum

[Serializable]
public sealed enum TreeMapTiling : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Slice |
Strip |

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TriSurface

Steema.TeeChart.Styles.TriSurface Class

TriSurface Series.

For a list of all members of this type, see TriSurface Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
public class TriSurface : Custom3DPalette , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

TriSurface members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TriSurfaceMembers

Steema.TeeChart.Styles.TriSurface all Members

TriSurface overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
CacheTriangles |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
NumTriangles |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Custom3D) | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear | Deletes all TriSurfaceSeries values.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom3DPalette) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Custom3DPalette) | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Custom3D) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery (inherited from Custom3DPalette) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Custom3DPalette) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HideTriangles | Hides constructed tiangles
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Custom3D) | XYZ Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Outline | Accesses the TChartHiddenPen object representing the color and style of TriSurface border.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

TriSurface Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TriSurface Constructor

Overload List

public TriSurface(Steema.TeeChart.Chart)
public TriSurface()

See Also

TriSurface Class | TriSurface Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TriSurface Constructor

public TriSurface()

See Also

TriSurface Constructor Overload List | TriSurface Class | TriSurface Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TriSurface Constructor

public TriSurface(Chart c)

See Also

TriSurface Constructor Overload List | TriSurface Class | TriSurface Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TriSurfaceEvents

Steema.TeeChart.Styles.TriSurface Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

TriSurface Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TriSurfaceFields

Steema.TeeChart.Styles.TriSurface Fields

Public Fields

bBrush (inherited from Series) |
CacheTriangles |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
NumTriangles |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

TriSurface Class | Steema.TeeChart.Styles Namespace


CacheTriangles

Steema.TeeChart.Styles.TriSurface.CacheTriangles Field

public Boolean CacheTriangles

See Also

TriSurface Class | TriSurface Members | Steema.TeeChart.Styles Namespace


NumTriangles

Steema.TeeChart.Styles.TriSurface.NumTriangles Field

public Int32 NumTriangles

See Also

TriSurface Class | TriSurface Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TriSurfaceMethods

Steema.TeeChart.Styles.TriSurface Methods

Public Methods

Add (inherited from Custom3D) | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear | Deletes all TriSurfaceSeries values.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom3DPalette) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Custom3DPalette) | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Custom3D) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery (inherited from Custom3DPalette) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Custom3DPalette) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

TriSurface Class | Steema.TeeChart.Styles Namespace


Clear

Steema.TeeChart.Styles.TriSurface.Clear Method

Deletes all TriSurfaceSeries values.
public override Void Clear()

See Also

TriSurface Class | TriSurface Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.TriSurface.Clicked Method

Overload List

public override Int32 Clicked(System.Int32, System.Int32)

See Also

TriSurface Class | TriSurface Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.TriSurface.Clicked Method

public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | TriSurface Class | TriSurface Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.TriSurface.Draw Method

public override Void Draw()

See Also

TriSurface Class | TriSurface Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.TriSurfaceProperties

Steema.TeeChart.Styles.TriSurface Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HideTriangles | Hides constructed tiangles
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Custom3D) | XYZ Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Outline | Accesses the TChartHiddenPen object representing the color and style of TriSurface border.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

TriSurface Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.TriSurface.Description Property

public override String Description {get;}

See Also

TriSurface Class | TriSurface Members | Steema.TeeChart.Styles Namespace


HideTriangles

Steema.TeeChart.Styles.TriSurface.HideTriangles Property

Hides constructed tiangles
public Boolean HideTriangles {get; set;}

See Also

TriSurface Class | TriSurface Members | Steema.TeeChart.Styles Namespace


Outline

Steema.TeeChart.Styles.TriSurface.Outline Property

Accesses the TChartHiddenPen object representing the color and style of TriSurface border.
public ChartPen Outline {get;}

See Also

TriSurface Class | TriSurface Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ValueList

Steema.TeeChart.Styles.ValueList Class

Array to hold Series data point values.

For a list of all members of this type, see ValueList Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public sealed class ValueList : TeeBase

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

ValueList members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ValueListMembers

Steema.TeeChart.Styles.ValueList all Members

ValueList overview

Constructors

Constructor Overloaded

Public Fields

Capacity
Count
DefaultCapacity
Name
TempValue
Value

Public Methods

AsDateTime |
Clear |
FillSequence | Renumbers all values in a IValueList class starting at zero.
IndexOf | Returns the corresponding point index which has the specified Value.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Locate |
RemoveAt |
RemoveRange |
Sort | Re-orders Series points, interchanging their position in the Series Values lists.

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
DataMember | Field to use as source for this value list.
DateTime | Allows values to be expressed either as numbers or as Date+Time values.
First | Returns the First point value.
Item |
Last | Returns the Last point value.
Maximum | Returns the highest of all values in the list.
MaxValue |
Minimum | Returns the lowest of all values in the list.
MinValue |
Order | Determines if points are automatically sorted or left at original position.
Range |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Total | Returns the sum of all IValueList values.
TotalABS | Returns the sum of all absolute values in the list.

See Also

ValueList Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ValueList Constructor

Overload List

public ValueList()
public ValueList(Steema.TeeChart.Styles.Series, System.String)
public ValueList(Steema.TeeChart.Styles.Series, System.String, System.Int32)

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ValueList Constructor

public ValueList(Series s,
     String name,
     Int32 initialCapacity)

See Also

ValueList Constructor Overload List | ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ValueList Constructor

public ValueList(Series s,
     String name)

See Also

ValueList Constructor Overload List | ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ValueList Constructor

public ValueList()

See Also

ValueList Constructor Overload List | ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ValueListFields

Steema.TeeChart.Styles.ValueList Fields

Public Fields

Capacity
Count
DefaultCapacity
Name
TempValue
Value

See Also

ValueList Class | Steema.TeeChart.Styles Namespace


Capacity

Steema.TeeChart.Styles.ValueList.Capacity Field

public Int32 Capacity

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Count

Steema.TeeChart.Styles.ValueList.Count Field

public Int32 Count

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


DefaultCapacity

Steema.TeeChart.Styles.ValueList.DefaultCapacity Field

public Int32 DefaultCapacity

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Name

Steema.TeeChart.Styles.ValueList.Name Field

public String Name

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


TempValue

Steema.TeeChart.Styles.ValueList.TempValue Field

public Double TempValue

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Value

Steema.TeeChart.Styles.ValueList.Value Field

public Double[] Value

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ValueListMethods

Steema.TeeChart.Styles.ValueList Methods

Public Methods

AsDateTime |
Clear |
FillSequence | Renumbers all values in a IValueList class starting at zero.
IndexOf | Returns the corresponding point index which has the specified Value.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Locate |
RemoveAt |
RemoveRange |
Sort | Re-orders Series points, interchanging their position in the Series Values lists.

See Also

ValueList Class | Steema.TeeChart.Styles Namespace


AsDateTime

Steema.TeeChart.Styles.ValueList.AsDateTime Method

public DateTime AsDateTime(Int32 index)

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Clear

Steema.TeeChart.Styles.ValueList.Clear Method

Overload List

public Void Clear()
public Void Clear(System.Int32)

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Clear

Steema.TeeChart.Styles.ValueList.Clear Method

public Void Clear(Int32 startCapacity)

See Also

Clear Overload List | ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Clear

Steema.TeeChart.Styles.ValueList.Clear Method

public Void Clear()

See Also

Clear Overload List | ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


FillSequence

Steema.TeeChart.Styles.ValueList.FillSequence Method

Renumbers all values in a IValueList class starting at zero.
public Void FillSequence()

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


IndexOf

Steema.TeeChart.Styles.ValueList.IndexOf Method

Returns the corresponding point index which has the specified Value.
public Int32 IndexOf(Double value)

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Locate

Steema.TeeChart.Styles.ValueList.Locate Method

public Int32 Locate(Double value)

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


RemoveAt

Steema.TeeChart.Styles.ValueList.RemoveAt Method

public Void RemoveAt(Int32 index)

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


RemoveRange

Steema.TeeChart.Styles.ValueList.RemoveRange Method

public Void RemoveRange(Int32 index,
     Int32 count)

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Sort

Steema.TeeChart.Styles.ValueList.Sort Method

Re-orders Series points, interchanging their position in the Series Values lists.
public Void Sort()

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ValueListProperties

Steema.TeeChart.Styles.ValueList Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
DataMember | Field to use as source for this value list.
DateTime | Allows values to be expressed either as numbers or as Date+Time values.
First | Returns the First point value.
Item |
Last | Returns the Last point value.
Maximum | Returns the highest of all values in the list.
MaxValue |
Minimum | Returns the lowest of all values in the list.
MinValue |
Order | Determines if points are automatically sorted or left at original position.
Range |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Total | Returns the sum of all IValueList values.
TotalABS | Returns the sum of all absolute values in the list.

See Also

ValueList Class | Steema.TeeChart.Styles Namespace


DataMember

Steema.TeeChart.Styles.ValueList.DataMember Property

Field to use as source for this value list.
public String DataMember {get; set;}

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


DateTime

Steema.TeeChart.Styles.ValueList.DateTime Property

Allows values to be expressed either as numbers or as Date+Time values.
public Boolean DateTime {get; set;}

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


First

Steema.TeeChart.Styles.ValueList.First Property

Returns the First point value.
public Double First {get;}

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Item

Steema.TeeChart.Styles.ValueList.Item Property

public Double Item(Int32 index) {get; set;}

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Last

Steema.TeeChart.Styles.ValueList.Last Property

Returns the Last point value.
public Double Last {get;}

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Maximum

Steema.TeeChart.Styles.ValueList.Maximum Property

Returns the highest of all values in the list.
public Double Maximum {get;}

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


MaxValue

Steema.TeeChart.Styles.ValueList.MaxValue Property

public Double MaxValue {get;}

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Minimum

Steema.TeeChart.Styles.ValueList.Minimum Property

Returns the lowest of all values in the list.
public Double Minimum {get;}

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


MinValue

Steema.TeeChart.Styles.ValueList.MinValue Property

public Double MinValue {get;}

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Order

Steema.TeeChart.Styles.ValueList.Order Property

Determines if points are automatically sorted or left at original position.
public ValueListOrder Order {get; set;}

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Range

Steema.TeeChart.Styles.ValueList.Range Property

public Double Range {get;}

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Total

Steema.TeeChart.Styles.ValueList.Total Property

Returns the sum of all IValueList values.
public Double Total {get;}

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


TotalABS

Steema.TeeChart.Styles.ValueList.TotalABS Property

Returns the sum of all absolute values in the list.
public Double TotalABS {get;}

See Also

ValueList Class | ValueList Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.ValueListOrder

Steema.TeeChart.Styles.ValueListOrder Enum

Describes the possible values of the Order property.
[Serializable]
public sealed enum ValueListOrder : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
None | Values are ordered in the order in which they were added to the ValueList.
Ascending | Values are ordered in ascending numerical order.
Descending | Values are ordered in descending numerical order.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Vector3D

Steema.TeeChart.Styles.Vector3D Class

Vector3D Series.

For a list of all members of this type, see Vector3D Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
public class Vector3D : Custom3DPalette , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Vector3D members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Vector3DMembers

Steema.TeeChart.Styles.Vector3D all Members

Vector3D overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add | Adds a new 3D vector line to series from (x0, y0, z0) to (x1, y1, z1) as axis values.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked (inherited from Series) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom3DPalette) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf |
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Custom3DPalette) | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the biggest value in the Series XValues array.
MaxYValue | Returns the biggest value in the Series YValues array.
MaxZValue | Returns the biggest value in the Series ZValues array.
MinXValue | Returns the smallest value in the Series XValues array.
MinYValue | Returns the smallest value in the Series YValues array.
MinZValue | Returns the smallest value in the Series ZValues array.
PrepareForGallery (inherited from Custom3DPalette) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Custom3DPalette) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
ArrowHeight | The arrow height in pixels.
ArrowWidth | The arrow width in pixels.
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
EndArrow | When Visible, this pen is used to display arrows at the end coordinate of vector lines.
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndXValues | List of values representing the end X coordinates of vector lines.
EndYValues | List of values representing the end Y coordinates of vector lines.
EndZ (inherited from Series) | For internal use.
EndZValues | List of values representing the end Z coordinates of vector lines.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Custom3D) | XYZ Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartArrow | When Visible, this pen is used to display arrows at the start coordinate of vector lines.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

Vector3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Vector3D Constructor

Overload List

public Vector3D(Steema.TeeChart.Chart)
public Vector3D()

See Also

Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Vector3D Constructor

public Vector3D()

See Also

Vector3D Constructor Overload List | Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Vector3D Constructor

public Vector3D(Chart c)

See Also

Vector3D Constructor Overload List | Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Vector3DEvents

Steema.TeeChart.Styles.Vector3D Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Vector3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Vector3DFields

Steema.TeeChart.Styles.Vector3D Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Vector3D Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Vector3DMethods

Steema.TeeChart.Styles.Vector3D Methods

Public Methods

Add | Adds a new 3D vector line to series from (x0, y0, z0) to (x1, y1, z1) as axis values.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked (inherited from Series) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Series) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom3DPalette) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf |
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Custom3DPalette) | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue | Returns the biggest value in the Series XValues array.
MaxYValue | Returns the biggest value in the Series YValues array.
MaxZValue | Returns the biggest value in the Series ZValues array.
MinXValue | Returns the smallest value in the Series XValues array.
MinYValue | Returns the smallest value in the Series YValues array.
MinZValue | Returns the smallest value in the Series ZValues array.
PrepareForGallery (inherited from Custom3DPalette) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Custom3DPalette) |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Vector3D Class | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Vector3D.Add Method

Overload List

Adds a new 3D vector line to series from (x0, y0, z0) to (x1, y1, z1) as axis values.

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Double, System.Double)

Adds a new 3D vector line to series from (x0, y0, z0) to (x1, y1, z1) as axis values with a specified text and color.

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.String, System.Drawing.Color)

See Also

Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Vector3D.Add Method

Adds a new 3D vector line to series from (x0, y0, z0) to (x1, y1, z1) as axis values with a specified text and color.
public Int32 Add(Double x0,
     Double y0,
     Double z0,
     Double x1,
     Double y1,
     Double z1,
     String text,
     Color color)

See Also

Add Overload List | Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


Add

Steema.TeeChart.Styles.Vector3D.Add Method

Adds a new 3D vector line to series from (x0, y0, z0) to (x1, y1, z1) as axis values.
public Int32 Add(Double x0,
     Double y0,
     Double z0,
     Double x1,
     Double y1,
     Double z1)

See Also

Add Overload List | Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.Vector3D.DrawValue Method

public override Void DrawValue(Int32 valueIndex)

See Also

Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


IsValidSourceOf

Steema.TeeChart.Styles.Vector3D.IsValidSourceOf Method

public override Boolean IsValidSourceOf(Series value)

See Also

Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


MaxXValue

Steema.TeeChart.Styles.Vector3D.MaxXValue Method

Returns the biggest value in the Series XValues array.
public override Double MaxXValue()

See Also

Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


MaxYValue

Steema.TeeChart.Styles.Vector3D.MaxYValue Method

Returns the biggest value in the Series YValues array.
public override Double MaxYValue()

See Also

Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


MaxZValue

Steema.TeeChart.Styles.Vector3D.MaxZValue Method

Returns the biggest value in the Series ZValues array.
public override Double MaxZValue()

See Also

Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


MinXValue

Steema.TeeChart.Styles.Vector3D.MinXValue Method

Returns the smallest value in the Series XValues array.
public override Double MinXValue()

See Also

Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


MinYValue

Steema.TeeChart.Styles.Vector3D.MinYValue Method

Returns the smallest value in the Series YValues array.
public override Double MinYValue()

See Also

Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


MinZValue

Steema.TeeChart.Styles.Vector3D.MinZValue Method

Returns the smallest value in the Series ZValues array.
public override Double MinZValue()

See Also

Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Vector3DProperties

Steema.TeeChart.Styles.Vector3D Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
ArrowHeight | The arrow height in pixels.
ArrowWidth | The arrow width in pixels.
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description | Gets descriptive text.
EndArrow | When Visible, this pen is used to display arrows at the end coordinate of vector lines.
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndXValues | List of values representing the end X coordinates of vector lines.
EndYValues | List of values representing the end Y coordinates of vector lines.
EndZ (inherited from Series) | For internal use.
EndZValues | List of values representing the end Z coordinates of vector lines.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Custom3D) | XYZ Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartArrow | When Visible, this pen is used to display arrows at the start coordinate of vector lines.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

Vector3D Class | Steema.TeeChart.Styles Namespace


ArrowHeight

Steema.TeeChart.Styles.Vector3D.ArrowHeight Property

The arrow height in pixels.
public Int32 ArrowHeight {get; set;}

See Also

Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


ArrowWidth

Steema.TeeChart.Styles.Vector3D.ArrowWidth Property

The arrow width in pixels.
public Int32 ArrowWidth {get; set;}

See Also

Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Vector3D.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


EndArrow

Steema.TeeChart.Styles.Vector3D.EndArrow Property

When Visible, this pen is used to display arrows at the end coordinate of vector lines.
public ChartPen EndArrow {get;}

See Also

Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


EndXValues

Steema.TeeChart.Styles.Vector3D.EndXValues Property

List of values representing the end X coordinates of vector lines.
public ValueList EndXValues {get;}

See Also

Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


EndYValues

Steema.TeeChart.Styles.Vector3D.EndYValues Property

List of values representing the end Y coordinates of vector lines.
public ValueList EndYValues {get;}

See Also

Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


EndZValues

Steema.TeeChart.Styles.Vector3D.EndZValues Property

List of values representing the end Z coordinates of vector lines.
public ValueList EndZValues {get;}

See Also

Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


StartArrow

Steema.TeeChart.Styles.Vector3D.StartArrow Property

When Visible, this pen is used to display arrows at the start coordinate of vector lines.
public ChartPen StartArrow {get;}

See Also

Vector3D Class | Vector3D Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VerticalAxis

Steema.TeeChart.Styles.VerticalAxis Enum

Describes the possible values of the VertAxis property.
[Serializable]
public sealed enum VerticalAxis : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Left | Associates the series with the left axis.
Right | Associates the series with the right axis.
Both | Associates the series with both the left and right axis.
Custom | Associates the series with a custom axis.

See Also

Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VerticalLinearGauge

Steema.TeeChart.Styles.VerticalLinearGauge Class

VerticalLinear Gauge Series.

For a list of all members of this type, see VerticalLinearGauge Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomGauge
Steema.TeeChart.Styles.LinearGauge
public class VerticalLinearGauge : LinearGauge , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

VerticalLinearGauge members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VerticalLinearGaugeMembers

Steema.TeeChart.Styles.VerticalLinearGauge all Members

VerticalLinearGauge overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.
ValueChanged (inherited from CustomGauge) | Called when the Gauge Value property is changed.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomGauge) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from LinearGauge) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from LinearGauge) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Axis (inherited from CustomGauge) | Gets the LinearGauges's Axis characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorLineEndValues (inherited from CustomGauge) | Gets or sets a collection of EndValues which initially contains the RedLineEndValue and the GreenLineEndValue.
ColorLines (inherited from CustomGauge) | Gets or sets a collection of ColorLines which initially contains the RedLine and the GreenLine.
ColorLineStartValues (inherited from CustomGauge) | Gets or sets a collection of StartValues which initially contains the RedLineStartValue and the GreenLineStartValue.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBounds (inherited from CustomGauge) | Gets or sets a custom bounding rectangle for the gauge.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FaceBrush (inherited from CustomGauge) | ChartBrush characteristics of the CustomGauge's face.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Frame (inherited from CustomGauge) | The Frame is the object which surrounds the LinearGauge and which consists of three configurable Bands: Inner, Middle and Outer.
Function (inherited from Series) | Function object to calculate values.
GaugeColorPalette (inherited from CustomGauge) | Gets and sets the CircularGauge's color palette.
GreenLine (inherited from CustomGauge) | The 'greenline' object is the curved shape with a gradient which is used to signal a low or minimum value.
GreenLineEndValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker ends.
GreenLineStartValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker starts.
Hand (inherited from CustomGauge) | Gets and sets the Hand (or needle) object characteristics.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Horizontal (inherited from CustomGauge) | Gets and sets whether the LinearGauge should be displayed horizontally or vertically.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
Maximum (inherited from CustomGauge) | Gets or sets the maximum value for the gauge.
MaxValueIndicator (inherited from LinearGauge) | A visible marker for the maximum value reached by the LinearGauge.
MiddleZ (inherited from Series) | For internal use.
Minimum (inherited from CustomGauge) | Gets or sets the minimum value for the gauge.
MinorTickDistance (inherited from CustomGauge) | The minor tick offset.
MinorTicks (inherited from CustomGauge) | Gets and sets the characteristics of the Axis' minor tick marks.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedLine (inherited from CustomGauge) | The 'redline' object is the curved shape with a gradient which is used to signal a high or maximum value.
RedLineEndValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker ends.
RedLineStartValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker starts.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Ticks (inherited from CustomGauge) | Gets and sets the characteristics of the Axis' major tick marks.
Title (inherited from Series) | Series description to show in Legend and editors.
UseValueColorPalette (inherited from LinearGauge) | Set true to use the ValueColorPalette and so define a custom gradient scheme for the LinearGauge hand.
Value (inherited from CustomGauge) | Gets or sets the position of gauge arrow line.
ValueAreaBrush (inherited from LinearGauge) | Brush characteristics of the area behind the value, or hand, pointer.
ValueColorPalette (inherited from LinearGauge) | An array of Colors defining a custom gradient color scheme.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

VerticalLinearGauge Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VerticalLinearGauge Constructor

Overload List

public VerticalLinearGauge()
public VerticalLinearGauge(Steema.TeeChart.Chart)

See Also

VerticalLinearGauge Class | VerticalLinearGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VerticalLinearGauge Constructor

public VerticalLinearGauge(Chart c)

See Also

VerticalLinearGauge Constructor Overload List | VerticalLinearGauge Class | VerticalLinearGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VerticalLinearGauge Constructor

public VerticalLinearGauge()

See Also

VerticalLinearGauge Constructor Overload List | VerticalLinearGauge Class | VerticalLinearGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VerticalLinearGaugeEvents

Steema.TeeChart.Styles.VerticalLinearGauge Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.
ValueChanged (inherited from CustomGauge) | Called when the Gauge Value property is changed.

See Also

VerticalLinearGauge Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VerticalLinearGaugeFields

Steema.TeeChart.Styles.VerticalLinearGauge Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

VerticalLinearGauge Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VerticalLinearGaugeMethods

Steema.TeeChart.Styles.VerticalLinearGauge Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomGauge) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from LinearGauge) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from LinearGauge) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

VerticalLinearGauge Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VerticalLinearGaugeProperties

Steema.TeeChart.Styles.VerticalLinearGauge Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Axis (inherited from CustomGauge) | Gets the LinearGauges's Axis characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorLineEndValues (inherited from CustomGauge) | Gets or sets a collection of EndValues which initially contains the RedLineEndValue and the GreenLineEndValue.
ColorLines (inherited from CustomGauge) | Gets or sets a collection of ColorLines which initially contains the RedLine and the GreenLine.
ColorLineStartValues (inherited from CustomGauge) | Gets or sets a collection of StartValues which initially contains the RedLineStartValue and the GreenLineStartValue.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomBounds (inherited from CustomGauge) | Gets or sets a custom bounding rectangle for the gauge.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FaceBrush (inherited from CustomGauge) | ChartBrush characteristics of the CustomGauge's face.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Frame (inherited from CustomGauge) | The Frame is the object which surrounds the LinearGauge and which consists of three configurable Bands: Inner, Middle and Outer.
Function (inherited from Series) | Function object to calculate values.
GaugeColorPalette (inherited from CustomGauge) | Gets and sets the CircularGauge's color palette.
GreenLine (inherited from CustomGauge) | The 'greenline' object is the curved shape with a gradient which is used to signal a low or minimum value.
GreenLineEndValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker ends.
GreenLineStartValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker starts.
Hand (inherited from CustomGauge) | Gets and sets the Hand (or needle) object characteristics.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Horizontal (inherited from CustomGauge) | Gets and sets whether the LinearGauge should be displayed horizontally or vertically.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
Maximum (inherited from CustomGauge) | Gets or sets the maximum value for the gauge.
MaxValueIndicator (inherited from LinearGauge) | A visible marker for the maximum value reached by the LinearGauge.
MiddleZ (inherited from Series) | For internal use.
Minimum (inherited from CustomGauge) | Gets or sets the minimum value for the gauge.
MinorTickDistance (inherited from CustomGauge) | The minor tick offset.
MinorTicks (inherited from CustomGauge) | Gets and sets the characteristics of the Axis' minor tick marks.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedLine (inherited from CustomGauge) | The 'redline' object is the curved shape with a gradient which is used to signal a high or maximum value.
RedLineEndValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker ends.
RedLineStartValue (inherited from CustomGauge) | Gets and sets the value at which the 'redline' marker starts.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Ticks (inherited from CustomGauge) | Gets and sets the characteristics of the Axis' major tick marks.
Title (inherited from Series) | Series description to show in Legend and editors.
UseValueColorPalette (inherited from LinearGauge) | Set true to use the ValueColorPalette and so define a custom gradient scheme for the LinearGauge hand.
Value (inherited from CustomGauge) | Gets or sets the position of gauge arrow line.
ValueAreaBrush (inherited from LinearGauge) | Brush characteristics of the area behind the value, or hand, pointer.
ValueColorPalette (inherited from LinearGauge) | An array of Colors defining a custom gradient color scheme.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

VerticalLinearGauge Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.VerticalLinearGauge.Description Property

public override String Description {get;}

See Also

VerticalLinearGauge Class | VerticalLinearGauge Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Volume

Steema.TeeChart.Styles.Volume Class

Volume Series.

For a list of all members of this type, see Volume Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
public class Volume : Custom , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Volume members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VolumeMembers

Steema.TeeChart.Styles.Volume all Members

Volume overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Custom) | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Custom) |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush (inherited from Custom) | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InflateMargins | Expands axes to fit volume lines.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
Origin | Defines the YValue used as the origin for the specified Volume Series.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UseOrigin | Enables/Disables the Y value that defines the bottom position for Volume points.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Volume Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Volume Constructor

Overload List

public Volume(Steema.TeeChart.Chart)
public Volume()

See Also

Volume Class | Volume Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Volume Constructor

public Volume()

See Also

Volume Constructor Overload List | Volume Class | Volume Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Volume Constructor

public Volume(Chart c)

See Also

Volume Constructor Overload List | Volume Class | Volume Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VolumeEvents

Steema.TeeChart.Styles.Volume Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
ClickPointer (inherited from CustomPoint) | Occurs when a series pointer is clicked.
GetPointerStyle (inherited from CustomPoint) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Volume Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VolumeFields

Steema.TeeChart.Styles.Volume Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Volume Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VolumeMethods

Steema.TeeChart.Styles.Volume Methods

Public Methods

Add (inherited from BaseLine) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Custom) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPoint) | Returns horizontal screen position for a given point.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPoint) | Returns vertical screen position for a given point.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from Custom) | Calculates if any point is at XY position.
ClickedPointer (inherited from CustomPoint) | For internal use.
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Custom) |
DrawHiddenValue (inherited from Custom) |
DrawMarksSeries (inherited from Series) |
DrawPointer (inherited from CustomPoint) | Draws series pointer to the Canvas.
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from CustomPoint) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from CustomPoint) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from CustomPoint) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from CustomPoint) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Volume Class | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.Volume.DrawValue Method

Called internally. Draws the "ValueIndex" point of the Series.
public override Void DrawValue(Int32 valueIndex)

See Also

Volume Class | Volume Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.Volume.PrepareForGallery Method

public override Void PrepareForGallery(Boolean isEnabled)

See Also

Volume Class | Volume Members | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.Volume.SetSubGallery Method

public override Void SetSubGallery(Int32 index)

See Also

Volume Class | Volume Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VolumeProperties

Steema.TeeChart.Styles.Volume Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush (inherited from Custom) | Sets Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
ClickableLine (inherited from Custom) | Allows mouse clicks over the line drawn between points.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachLine (inherited from Custom) | Enables/Disables the coloring of each connecting line of a series.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
Dark3D (inherited from Custom) | Darkens parts of 3D Line Series to add depth.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
InflateMargins | Expands axes to fit volume lines.
InvertedStairs (inherited from Custom) | Changes the direction of the step, when true.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineHeight (inherited from Custom) | Defines the vertical thickness of the line in pixels.
LinePen (inherited from BaseLine) | Determines pen to draw the line connecting all points.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
Opacity (inherited from Custom) | Sets Opacity level from 0 to 100%
Origin | Defines the YValue used as the origin for the specified Volume Series.
OutLine (inherited from Custom) | Pen for Series Line's outer pen.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPoint) | Defines all necessary properties of the Series Pointer.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
Smoothed (inherited from Custom) | Gets or sets whether the Line Series' line is smoothed.
Stacked (inherited from CustomPoint) | Defines how multiple series will be displayed.
Stairs (inherited from Custom) | Steps line joining adjacent points.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from Custom) | Sets Transparency level from 0 to 100%
TreatNaNAsNull (inherited from BaseLine) |
TreatNulls (inherited from BaseLine) |
UseOrigin | Enables/Disables the Y value that defines the bottom position for Volume points.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

Volume Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Volume.Description Property

public override String Description {get;}

See Also

Volume Class | Volume Members | Steema.TeeChart.Styles Namespace


InflateMargins

Steema.TeeChart.Styles.Volume.InflateMargins Property

Expands axes to fit volume lines.
public Boolean InflateMargins {get; set;}

See Also

Volume Class | Volume Members | Steema.TeeChart.Styles Namespace


Origin

Steema.TeeChart.Styles.Volume.Origin Property

Defines the YValue used as the origin for the specified Volume Series.
public Double Origin {get; set;}

See Also

Volume Class | Volume Members | Steema.TeeChart.Styles Namespace


UseOrigin

Steema.TeeChart.Styles.Volume.UseOrigin Property

Enables/Disables the Y value that defines the bottom position for Volume points.
public Boolean UseOrigin {get; set;}

See Also

Volume Class | Volume Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VolumePipe

Steema.TeeChart.Styles.VolumePipe Class

VolumePipe Series.

For a list of all members of this type, see VolumePipe Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class VolumePipe : Series , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

VolumePipe members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VolumePipeMembers

Steema.TeeChart.Styles.VolumePipe all Members

VolumePipe overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
BoundingPoints |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
IPolyList |
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush | Sets Brush characteristics for the VolumePipe Series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent | Sets the Cone percentage.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineAsPointColor | Sets LinePen color to each Point Color.
LinesPen | Sets LinePen characteristics for the VolumePipe Series.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Separation | Sets the separation between Cone segments.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

VolumePipe Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VolumePipe Constructor

Overload List

public VolumePipe()
public VolumePipe(Steema.TeeChart.Chart)

See Also

VolumePipe Class | VolumePipe Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VolumePipe Constructor

public VolumePipe(Chart c)

See Also

VolumePipe Constructor Overload List | VolumePipe Class | VolumePipe Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VolumePipe Constructor

public VolumePipe()

See Also

VolumePipe Constructor Overload List | VolumePipe Class | VolumePipe Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VolumePipeEvents

Steema.TeeChart.Styles.VolumePipe Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

VolumePipe Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VolumePipeFields

Steema.TeeChart.Styles.VolumePipe Fields

Public Fields

bBrush (inherited from Series) |
BoundingPoints |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
IPolyList |
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

VolumePipe Class | Steema.TeeChart.Styles Namespace


BoundingPoints

Steema.TeeChart.Styles.VolumePipe.BoundingPoints Field

public Point[] BoundingPoints

See Also

VolumePipe Class | VolumePipe Members | Steema.TeeChart.Styles Namespace


IPolyList

Steema.TeeChart.Styles.VolumePipe.IPolyList Field

public ArrayList IPolyList

See Also

VolumePipe Class | VolumePipe Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VolumePipeMethods

Steema.TeeChart.Styles.VolumePipe Methods

Public Methods

Add (inherited from Series) | Adds a new null (transparent) point.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue |
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Series) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
PrepareForGallery (inherited from Series) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

VolumePipe Class | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.VolumePipe.Clicked Method

Overload List

public override Int32 Clicked(System.Int32, System.Int32)

See Also

VolumePipe Class | VolumePipe Members | Steema.TeeChart.Styles Namespace


Clicked

Steema.TeeChart.Styles.VolumePipe.Clicked Method

public override Int32 Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | VolumePipe Class | VolumePipe Members | Steema.TeeChart.Styles Namespace


Draw

Steema.TeeChart.Styles.VolumePipe.Draw Method

public override Void Draw()

See Also

VolumePipe Class | VolumePipe Members | Steema.TeeChart.Styles Namespace


DrawValue

Steema.TeeChart.Styles.VolumePipe.DrawValue Method

public override Void DrawValue(Int32 index)

See Also

VolumePipe Class | VolumePipe Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.VolumePipeProperties

Steema.TeeChart.Styles.VolumePipe Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
Brush | Sets Brush characteristics for the VolumePipe Series.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
ConePercent | Sets the Cone percentage.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LineAsPointColor | Sets LinePen color to each Point Color.
LinesPen | Sets LinePen characteristics for the VolumePipe Series.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Separation | Sets the separation between Cone segments.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

VolumePipe Class | Steema.TeeChart.Styles Namespace


Brush

Steema.TeeChart.Styles.VolumePipe.Brush Property

Sets Brush characteristics for the VolumePipe Series.
public ChartBrush Brush {get;}

See Also

VolumePipe Class | VolumePipe Members | Steema.TeeChart.Styles Namespace


ConePercent

Steema.TeeChart.Styles.VolumePipe.ConePercent Property

Sets the Cone percentage.
public Int32 ConePercent {get; set;}

See Also

VolumePipe Class | VolumePipe Members | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.VolumePipe.Description Property

public override String Description {get;}

See Also

VolumePipe Class | VolumePipe Members | Steema.TeeChart.Styles Namespace


LineAsPointColor

Steema.TeeChart.Styles.VolumePipe.LineAsPointColor Property

Sets LinePen color to each Point Color.
public Boolean LineAsPointColor {get; set;}

See Also

VolumePipe Class | VolumePipe Members | Steema.TeeChart.Styles Namespace


LinesPen

Steema.TeeChart.Styles.VolumePipe.LinesPen Property

Sets LinePen characteristics for the VolumePipe Series.
public ChartPen LinesPen {get; set;}

See Also

VolumePipe Class | VolumePipe Members | Steema.TeeChart.Styles Namespace


Separation

Steema.TeeChart.Styles.VolumePipe.Separation Property

Sets the separation between Cone segments.
public Int32 Separation {get; set;}

See Also

VolumePipe Class | VolumePipe Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Waterfall

Steema.TeeChart.Styles.Waterfall Class

The Waterfall series draws vertical "slices", one for each Z row of the equivalent surface.

For a list of all members of this type, see Waterfall Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
Steema.TeeChart.Styles.Custom3DGrid
Steema.TeeChart.Styles.Surface
public class Waterfall : Surface , ICloneable

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

Waterfall members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.WaterfallMembers

Steema.TeeChart.Styles.Waterfall all Members

Waterfall overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
GetYValue (inherited from Custom3DGrid) | Occurs when the Surface Series needs to recreate the grid of values.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
ReuseGridIndex (inherited from Custom3DGrid) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from Custom3D) | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CellsOrientation (inherited from Surface) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Custom3DGrid) | Deletes all Series values.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked (inherited from Surface) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
CreateValues (inherited from Custom3DGrid) | Makes a Surface grid of NumX by NumZ dimensions.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Surface) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FastCalcPoints (inherited from Surface) |
FillGridIndex (inherited from Custom3DGrid) |
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom3DPalette) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Custom3DPalette) | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Custom3D) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery (inherited from Surface) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
DotFrame (inherited from Surface) | Sets SurfaceSeries as a grid of dots (pixels).
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HideCells (inherited from Surface) |
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IrregularGrid (inherited from Custom3DGrid) | Determine if X and Z values are equi-distant or not.
Item (inherited from Custom3DGrid) | A two dimension array property for the easy access to series cell values.
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
NumXValues (inherited from Custom3DGrid) | Determines the Surface's horizontal size in number of points.
NumZValues (inherited from Custom3DGrid) | Determines the Surface's depth size in number of points.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideBrush (inherited from Surface) | Determines the Brush to fill the sides of a Surface Series.
SideLines (inherited from Surface) |
SmoothPalette (inherited from Surface) | Determine the cell Colors of a Surface Series.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
WaterFall (inherited from Surface) | Enables/disables the display as a waterfall.
WaterLines (inherited from Surface) | Sets Pen to draw valuelines.
WireFrame (inherited from Surface) | Shows Surface polygons as grid or wire frame when true.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

Waterfall Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Waterfall Constructor

Overload List

public Waterfall(Steema.TeeChart.Chart)
public Waterfall()

See Also

Waterfall Class | Waterfall Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Waterfall Constructor

public Waterfall()

See Also

Waterfall Constructor Overload List | Waterfall Class | Waterfall Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.Waterfall Constructor

public Waterfall(Chart c)

See Also

Waterfall Constructor Overload List | Waterfall Class | Waterfall Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.WaterfallEvents

Steema.TeeChart.Styles.Waterfall Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
GetValueColor (inherited from Custom3DPalette) | Occurs each time a Surface's polygon is displayed. Using this event, specific Colors can be assigned to individual Surface polygons.
GetYValue (inherited from Custom3DGrid) | Occurs when the Surface Series needs to recreate the grid of values.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

Waterfall Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.WaterfallFields

Steema.TeeChart.Styles.Waterfall Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
ReuseGridIndex (inherited from Custom3DGrid) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

Waterfall Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.WaterfallMethods

Steema.TeeChart.Styles.Waterfall Methods

Public Methods

Add (inherited from Custom3D) | Adds the X, Y and Z arrays.
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AddPalette (inherited from Custom3DPalette) | Add Color to Palette list
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat (inherited from Series) |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from Series) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CalcZPos (inherited from Custom3D) |
CellsOrientation (inherited from Surface) |
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Custom3DGrid) | Deletes all Series values.
ClearPalette (inherited from Custom3DPalette) | Deletes all Palette information.
Clicked (inherited from Surface) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
CreateValues (inherited from Custom3DGrid) | Makes a Surface grid of NumX by NumZ dimensions.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from Surface) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from Series) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FastCalcPoints (inherited from Surface) |
FillGridIndex (inherited from Custom3DGrid) |
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom3DPalette) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Custom3D) | Checks if given series object instance is a Custom3D instance.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Custom3DPalette) | Returns LegendString for LegendIndexth item.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Custom3D) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Custom3D) | Returns Minimum Z Value.
PrepareForGallery (inherited from Surface) |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery |
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Custom3DPalette) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

Waterfall Class | Steema.TeeChart.Styles Namespace


SetSubGallery

Steema.TeeChart.Styles.Waterfall.SetSubGallery Method

public override Void SetSubGallery(Int32 index)

See Also

Waterfall Class | Waterfall Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.WaterfallProperties

Steema.TeeChart.Styles.Waterfall Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
BlueFactor (inherited from Custom3DPalette) | Defines the alpha value for the Blue of the ARGB component.
Brush (inherited from Custom3DPalette) | Defines the Brush to fill the Surface polygons.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
DotFrame (inherited from Surface) | Sets SurfaceSeries as a grid of dots (pixels).
EndColor (inherited from Custom3DPalette) | Determines the last Range palette color.
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Function (inherited from Series) | Function object to calculate values.
GreenFactor (inherited from Custom3DPalette) | Defines the alpha value for the Green of the ARGB component.
HideCells (inherited from Surface) |
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
IrregularGrid (inherited from Custom3DGrid) | Determine if X and Z values are equi-distant or not.
Item (inherited from Custom3DGrid) | A two dimension array property for the easy access to series cell values.
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
LegendEvery (inherited from Custom3DPalette) |
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MidColor (inherited from Custom3DPalette) | Determines the middle Range palette color.
MiddleZ (inherited from Series) | For internal use.
NumGallerySeries (inherited from Series) | For internal use.
NumXValues (inherited from Custom3DGrid) | Determines the Surface's horizontal size in number of points.
NumZValues (inherited from Custom3DGrid) | Determines the Surface's depth size in number of points.
Palette (inherited from Custom3DPalette) | Access the Color Palette list
PaletteMin (inherited from Custom3DPalette) | The starting value used to calculate the color palette when UsePaletteMin is true.
PaletteRange (inherited from Custom3DPalette) | Defines the range of colour in the default color Palette.
PaletteStep (inherited from Custom3DPalette) | The interval amount between palette Colors.
PaletteSteps (inherited from Custom3DPalette) | Sets the number of entries in the default color Palette.
PaletteStyle (inherited from Custom3DPalette) | Selects Pale or Strong colour palette.
Pen (inherited from Custom3DPalette) | Defines the Pen to draw the Surface polygons.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
RedFactor (inherited from Custom3DPalette) | Defines the alpha value for the Red of the ARGB component.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
SideBrush (inherited from Surface) | Determines the Brush to fill the sides of a Surface Series.
SideLines (inherited from Surface) |
SmoothPalette (inherited from Surface) | Determine the cell Colors of a Surface Series.
StartColor (inherited from Custom3DPalette) | Sets 1 of 3 Colors used to create the palette to fill the Surface polygons.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TimesZOrder (inherited from Custom3D) | For internal use.
Title (inherited from Series) | Series description to show in Legend and editors.
UseColorRange (inherited from Custom3DPalette) | Sets gradient color palette to fill Surface polygons.
UsePalette (inherited from Custom3DPalette) | Sets multi-color palette to fill Surface polygons.
UsePaletteMin (inherited from Custom3DPalette) | Set to True to force the color palette to start at UsePaletteMin property value.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
WaterFall (inherited from Surface) | Enables/disables the display as a waterfall.
WaterLines (inherited from Surface) | Sets Pen to draw valuelines.
WireFrame (inherited from Surface) | Shows Surface polygons as grid or wire frame when true.
XValues (inherited from Series) | Values defining horizontal point positions.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.
ZValues (inherited from Custom3D) | Values defining Z grid point positions.

See Also

Waterfall Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.Waterfall.Description Property

public override String Description {get;}

See Also

Waterfall Class | Waterfall Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.WindRose

Steema.TeeChart.Styles.WindRose Class

WindRose Series.

For a list of all members of this type, see WindRose Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
Steema.TeeChart.Styles.CustomPolar
Steema.TeeChart.Styles.Custom2DPolar
public class WindRose : Custom2DPolar , ICloneable, ISeriesPointer

Requirements

Namespace: Steema.TeeChart.Styles Namespace

Assembly: TeeChart.Android.dll

See Also

WindRose members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.WindRoseMembers

Steema.TeeChart.Styles.WindRose all Members

WindRose overview

Constructors

Constructor Overloaded

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle (inherited from CustomPolar) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

Public Methods

Add (inherited from CustomPolar) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPolar) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPolar) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPolar) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from CustomPolar) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawRing (inherited from CustomPolar) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomPolar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
DrawZone (inherited from CustomPolar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom2DPolar) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
OnGetPointerStyle (inherited from CustomPolar) |
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

Public Properties

Active (inherited from Series) | Shows or hides this series.
AngleIncrement (inherited from CustomPolar) | Sets angle in degrees used to draw the dividing grid lines in anti-clockwise direction.
AngleValues (inherited from CustomPolar) | Gets list of angle values for each polar point.
Brush (inherited from CustomPolar) | Sets Polar Back Brush.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleLabels (inherited from CustomPolar) | Sets CicleLabel properties.
CircleLabelsFont (inherited from CustomPolar) |
CircleLabelsInside (inherited from CustomPolar) | Enables/disables the display of the axis labels inside the circle area.
CircleLabelsRotated (inherited from CustomPolar) | When true rotates the labels of a circular TeeChart series at an angle in line with the Radar/Polar circle at each Label point.
CirclePen (inherited from CustomPolar) | Determines the pen used to draw the outmost circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
ClockWiseLabels (inherited from CustomPolar) | Displays of the circle labels in a clockwise direction.
CloseCircle (inherited from CustomPolar) | Draws a Line between the last and first PolarSeries point coordinates.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Font (inherited from CustomPolar) | Sets the label font.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsMargin (inherited from CustomPolar) | Defines the distance between the CustomPolar circle and the labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
MirrorAngles |
MirrorLabels |
NumGallerySeries (inherited from Series) | For internal use.
Pen (inherited from CustomPolar) | Determines Pen used to draw the Line connecting PolarSeries points.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPolar) | Pointer contains several properties to control the formatting attributes of Points like Pen, Brush, Draw3D, Visible, etc.
RadiusIncrement (inherited from CustomPolar) | Determines the increment used to draw the ring grid lines.
RadiusValues (inherited from CustomPolar) | Gets list of radius values for each polar point.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from CustomPolar) | Sets Transparency level from 0 to 100%.
TreatNaNAsNull (inherited from CustomPolar) |
TreatNulls (inherited from CustomPolar) |
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

WindRose Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.WindRose Constructor

Overload List

public WindRose()
public WindRose(Steema.TeeChart.Chart)

See Also

WindRose Class | WindRose Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.WindRose Constructor

public WindRose(Chart c)

See Also

WindRose Constructor Overload List | WindRose Class | WindRose Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.WindRose Constructor

public WindRose()

See Also

WindRose Constructor Overload List | WindRose Class | WindRose Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.WindRoseEvents

Steema.TeeChart.Styles.WindRose Events

Public Events

AfterDrawValues (inherited from Series) | Called just after drawing all series points, and before drawing other series that are in front.
BeforeDrawPoint (inherited from Series) | Triggered Before a Series Point is plotted. Use to modify paint characteristics of indexed point.
BeforeDrawValues (inherited from Series) | Called just before drawing all series points, and after drawing other series that are behind.
GetPointerStyle (inherited from CustomPolar) | Occurs on the drawing of the series pointers.
GetSeriesMark (inherited from Series) | Triggered on placing Mark for each Series Point. Use this method to modify the Mark Text content.
MouseEnter (inherited from Series) | Occurs when the mouse pointer enters the control.
MouseLeave (inherited from Series) | Occurs when the mouse pointer leaves the control.

See Also

WindRose Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.WindRoseFields

Steema.TeeChart.Styles.WindRose Fields

Public Fields

bBrush (inherited from Series) |
GetHorizAxis (inherited from Series) | Returns the horizontal axis associated with the series.
GetVertAxis (inherited from Series) | Returns the vertical axis associated with the series.
HasZValues (inherited from Series) | Returns true if the series has ZValues.
mandatory (inherited from Series) |
manualData (inherited from Series) |
notMandatory (inherited from Series) |
UseAxis (inherited from Series) | Returns True when the Series needs axes to display points. For example, Pie Series returns False (it does not need axes).

See Also

WindRose Class | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.WindRoseMethods

Steema.TeeChart.Styles.WindRose Methods

Public Methods

Add (inherited from CustomPolar) |
AddNull (inherited from Series) | System.Obsolete: Please use Add() method without parameters.
AddNullXY (inherited from Series) | System.Obsolete: Please use Add(x,y,Color.Transparent) method.
AngleToPos (inherited from Circular) | Returns the exact Screen position for a given pair of Angle and Radius values.
Assign (inherited from Series) | Copies all properties from one Series component to another.
AssignFormat |
AssignValues (inherited from Series) | Adds all Values from Source series.
BeginUpdate (inherited from Series) | Recalculates the function just one time, when finished adding points.
CalcPosValue (inherited from Series) | Returns "Value" parameter coordinate position in pixels.
CalcXPos (inherited from CustomPolar) | Returns the pixel Screen Horizontal coordinate of the ValueIndex Series value.
CalcXPosValue (inherited from Series) | Returns the pixel Screen Horizontal coordinate of the specified Value.
CalcXSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in horizontal axis scales.
CalcYPos (inherited from CustomPolar) | Returns the pixel Screen Vertical coordinate of the ValueIndex Series value.
CalcYPosValue (inherited from Series) | Returns the pixel Screen Vertical coordinate of the specified Value.
CalcYSizeValue (inherited from Series) | Returns the size in pixels corresponding to value parameter in vertical axis scales.
CheckDataSource (inherited from Series) | Refreshes all Series point values, either from database Tables, Queries or Series points.
CheckOrder (inherited from Series) | Reorders points according to Order property of X,Y,etc value lists.
Clear (inherited from Series) | Removes all points, texts and Colors from the Series.
Clicked (inherited from CustomPolar) |
Clone (inherited from Series) | Returns a new Series, copy of this original.
ColorRange (inherited from Series) | This method will change the Color of a specified range of points.
Delete (inherited from Series) | Removes the index th point. X values remain unchanged.
Draw (inherited from CustomPolar) |
DrawHiddenValue (inherited from Series) |
DrawMarksSeries (inherited from Series) |
DrawRing (inherited from CustomPolar) |
DrawSeries (inherited from Series) | Draws the series to the Chart Canvas.
DrawValue (inherited from CustomPolar) | Called internally. Draws the "ValueIndex" point of the Series.
DrawValuesForward (inherited from Series) | Returns whether Series draws its points in ascending/descending order.
DrawZone (inherited from CustomPolar) |
EndUpdate (inherited from Series) | Used with .BeginUpdate to recalculate the function just once when finished adding points.
FillSampleValues (inherited from Series) | Adds random values to help visualize the Series. Each series class determines how many random points to add.
FirstDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
GalleryChanged3D (inherited from Custom2DPolar) |
GetBitmapEditor (inherited from Series) | Returns the associated bitmap icon for a given Series class. This icon is used at ChartListBox and Series Editor dialog.
GetMarkValue (inherited from Series) | Returns corresponding Point value suitable for displaying at Series Marks.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
IsNull (inherited from Series) | Returns true if the index th point in the Series is "null" or "empty". A point is considered "null" when the color of that point is "Transparent".
IsValidSourceOf (inherited from Series) | Validates Series datasource.
LastDisplayedIndex (inherited from Series) | Returns the index of the series point that is displayed first when the series is drawn.
LegendString (inherited from Series) | Returns the formatted string corresponding to the LegendIndex point.
MaxMarkWidth (inherited from Series) | Returns the length in pixels of the longest Mark text.
MaxXValue (inherited from Series) | Returns the Maximum Value of the Series X Values List.
MaxYValue (inherited from Series) | Returns the Maximum Value of the Series Y Values List.
MaxZValue (inherited from Series) | Returns Maximum Z Value.
MinXValue (inherited from Series) | Returns the Minimum Value of the Series X Values List.
MinYValue (inherited from Series) | Returns the Minimum Value of the Series Y Values List.
MinZValue (inherited from Series) | Returns Minimum Z Value.
OnGetPointerStyle (inherited from CustomPolar) |
PointToAngle (inherited from Circular) | Returns the angle from the XY point parameter to the circle center.
PointToRadius (inherited from Circular) | Returns the radius from XY point to the circle center.
PrepareForGallery |
RefreshSeries (inherited from Series) | Recalculates all dependent Series points again.
Repaint (inherited from Series) | Forces the Chart to Repaint.
Rotate (inherited from Circular) | Returns the angle by which the Chart is rotated.
ScreenPointToValuePoint (inherited from Series) | Returns the corresponding Value PointDouble values of a Screen position between Axis limits.
SetNull (inherited from Series) | Sets the specified series point to a null (transparent) point.
SetSubGallery (inherited from Series) | Creates and prepares the index'th Series style to show at sub-gallery dialog.
SortByLabels (inherited from Series) | Sorts all points in the series using the Labels (texts) list. Note: non-mandatory values (X) are modified (they are not preserved).
TitleOrName (inherited from Series) | System.Obsolete: Please use ToString() method.
ToString (inherited from Series) | Overridden ToString() method.
ValueColor (inherited from Series) | Returns the colour of the index point.
ValueMarkText (inherited from Series) | Returns the string representation of a Index point used to draw the Mark.
ValuePointToScreenPoint (inherited from Series) | Returns the corresponding Screen Point values of a Value position between Axis limits.
WriteToDataSource (inherited from Series) |
XScreenToValue (inherited from Series) | Returns the corresponding X value of a Screen position between Axis limits.
YScreenToValue (inherited from Series) | Returns the corresponding Y value of a Screen position between Axis limits.

See Also

WindRose Class | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.WindRose.AssignFormat Method

Overload List

public override Void AssignFormat(Steema.TeeChart.Styles.Series, Steema.TeeChart.Styles.Series)

See Also

WindRose Class | WindRose Members | Steema.TeeChart.Styles Namespace


AssignFormat

Steema.TeeChart.Styles.WindRose.AssignFormat Method

public override Void AssignFormat(Series source,
     Series target)

See Also

AssignFormat Overload List | WindRose Class | WindRose Members | Steema.TeeChart.Styles Namespace


PrepareForGallery

Steema.TeeChart.Styles.WindRose.PrepareForGallery Method

public override Void PrepareForGallery(Boolean IsEnabled)

See Also

WindRose Class | WindRose Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Styles.WindRoseProperties

Steema.TeeChart.Styles.WindRose Properties

Public Properties

Active (inherited from Series) | Shows or hides this series.
AngleIncrement (inherited from CustomPolar) | Sets angle in degrees used to draw the dividing grid lines in anti-clockwise direction.
AngleValues (inherited from CustomPolar) | Gets list of angle values for each polar point.
Brush (inherited from CustomPolar) | Sets Polar Back Brush.
Chart (inherited from TeeBase) | Chart associated with this object
CircleBackColor (inherited from Circular) | Determines the color to fill the ellipse.
Circled (inherited from Circular) | Sets CirleSeries as elliptical or circular.
CircleGradient (inherited from Circular) | Determines the Gradient which fills the ellipse.
CircleHeight (inherited from Circular) | Returns the height of the bounding Circle.
CircleLabels (inherited from CustomPolar) | Sets CicleLabel properties.
CircleLabelsFont (inherited from CustomPolar) |
CircleLabelsInside (inherited from CustomPolar) | Enables/disables the display of the axis labels inside the circle area.
CircleLabelsRotated (inherited from CustomPolar) | When true rotates the labels of a circular TeeChart series at an angle in line with the Radar/Polar circle at each Label point.
CirclePen (inherited from CustomPolar) | Determines the pen used to draw the outmost circle.
CircleRect (inherited from Circular) | Returns the rectangle that bounds the circle.
CircleWidth (inherited from Circular) | Returns the width of the bounding Circle.
CircleXCenter (inherited from Circular) | Returns the exact horizontal position of ellipse's center in pixels.
CircleYCenter (inherited from Circular) | Returns the exact vertical position of the ellipse's center in pixels.
ClockWiseLabels (inherited from CustomPolar) | Displays of the circle labels in a clockwise direction.
CloseCircle (inherited from CustomPolar) | Draws a Line between the last and first PolarSeries point coordinates.
Color (inherited from Series) | Default color for all points.
ColorEach (inherited from Series) | Draws points with different preset Colors.
ColorEachPoint (inherited from Series) | System.Obsolete: Please use ColorEach property.
ColorMember (inherited from Series) | Gets or sets the Datasource Color Field
Colors (inherited from Series) | Access to the stored Color Array, if created, for the Series.
Count (inherited from Series) | Returns the number of points in the Series.
Cursor (inherited from Series) | Cursor displayed when mouse is over a series point.
CustomHorizAxis (inherited from Series) | Specified the custom horizontal axis for the series.
CustomVertAxis (inherited from Series) | Specified the custom vertical axis for the series.
CustomXRadius (inherited from Circular) | Sets ellipse's horizontal radius in pixels.
CustomYRadius (inherited from Circular) | Sets ellipse's vertical radius in pixels.
DataSource (inherited from Series) | Object to load data from.
DateTimeFormat (inherited from Series) | Determines the DateTimeFormat to display point values.
DefaultNullValue (inherited from Series) | Sets or returns the value to be used as a null value within the series.
Depth (inherited from Series) | Sets the Depth of the series points or interconnecting lines.
Description |
EndZ (inherited from Series) | For internal use.
FirstVisibleIndex (inherited from Series) | Returns the index of the Series' first visible point.
Font (inherited from CustomPolar) | Sets the label font.
Function (inherited from Series) | Function object to calculate values.
HorizAxis (inherited from Series) | Horizontal axis to associate to this Series.
Item (inherited from Series) | Point characteristics
LabelMember (inherited from Series) | Gets or sets the Datasource Label Field
Labels (inherited from Series) | Accesses a list of series point labels.
LabelsMargin (inherited from CustomPolar) | Defines the distance between the CustomPolar circle and the labels.
LastVisibleIndex (inherited from Series) | Returns the index of the Series' last visible point.
Marks (inherited from Series) | Defines all necessary properties to draw a mark near to each Series point.
MiddleZ (inherited from Series) | For internal use.
MirrorAngles |
MirrorLabels |
NumGallerySeries (inherited from Series) | For internal use.
Pen (inherited from CustomPolar) | Determines Pen used to draw the Line connecting PolarSeries points.
PercentFormat (inherited from Series) | Sets the Format to display point values as percentage.
Pointer (inherited from CustomPolar) | Pointer contains several properties to control the formatting attributes of Points like Pen, Brush, Draw3D, Visible, etc.
RadiusIncrement (inherited from CustomPolar) | Determines the increment used to draw the ring grid lines.
RadiusValues (inherited from CustomPolar) | Gets list of radius values for each polar point.
RotationAngle (inherited from Circular) | Sets angle of Chart rotation.
SeriesColor (inherited from Series) | System.Obsolete: Use the Series Color property.
SeriesData (inherited from Series) |
ShowInLegend (inherited from Series) | Displays this Series Title in Legend.
StartZ (inherited from Series) | For internal use.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Title (inherited from Series) | Series description to show in Legend and editors.
Transparency (inherited from CustomPolar) | Sets Transparency level from 0 to 100%.
TreatNaNAsNull (inherited from CustomPolar) |
TreatNulls (inherited from CustomPolar) |
UniqueCustomRadius (inherited from Circular) | Sets all the CirleSeries in a chart to use the same radius or independent.
ValueFormat (inherited from Series) | Determines the Format to display point values.
ValuesLists (inherited from Series) | Returns the Steema.TeeChart.Styles.ValuesLists object of the series.
VertAxis (inherited from Series) | Determines Vertical axis associated to this Series.
Visible (inherited from Series) | Shows or hides this series.
XRadius (inherited from Circular) | Returns the exact horizontal size of the ellipse's radius in pixels.
XValues (inherited from Series) | Values defining horizontal point positions.
YRadius (inherited from Circular) | Returns the exact vertical size of the ellipse's radius in pixels.
YValues (inherited from Series) | Values defining vertical point positions.
ZOrder (inherited from Series) | Determines where on the depth axis the Series is drawn.

See Also

WindRose Class | Steema.TeeChart.Styles Namespace


Description

Steema.TeeChart.Styles.WindRose.Description Property

public override String Description {get;}

See Also

WindRose Class | WindRose Members | Steema.TeeChart.Styles Namespace


MirrorAngles

Steema.TeeChart.Styles.WindRose.MirrorAngles Property

public Boolean MirrorAngles {get; set;}

See Also

WindRose Class | WindRose Members | Steema.TeeChart.Styles Namespace


MirrorLabels

Steema.TeeChart.Styles.WindRose.MirrorLabels Property

public Boolean MirrorLabels {get; set;}

See Also

WindRose Class | WindRose Members | Steema.TeeChart.Styles Namespace


Steema.TeeChart.Themes

Steema.TeeChart.Themes Namespace

Namespace hierarchy

Public Classes

ColorPalettes |
Theme | Summary description for Theme.
CustomTheme | Summary description for CustomTheme.
TeeChartTheme | Summary description for DefaultTheme.
OperaTheme |
BlackIsBackTheme | BlackIsBackTheme.
BlueSkyTheme | BlueSkyTheme.
BusinessTheme | Summary description for BusinessTheme.
ClassicTheme | Summary description for ExcelTheme.
ExcelTheme | Summary description for ExcelTheme.
GrayscaleTheme | Summary description for GrayscaleTheme.
RandomTheme |
ThemeProperties |
WebTheme | Summary description for WebTheme.
XPTheme | Summary description for XPTheme.

Requirements

Namespace: Steema.TeeChart.Themes Namespace

Assembly: TeeChart.Android.dll


Steema.TeeChart.Themes Hierarchy

System.Object

Steema.TeeChart.Drawing.TeeBase

Steema.TeeChart.Themes.Theme

Steema.TeeChart.Themes.CustomTheme

Steema.TeeChart.Themes.TeeChartTheme

Steema.TeeChart.Themes.BlueSkyTheme

Steema.TeeChart.Themes.BusinessTheme

Steema.TeeChart.Themes.XPTheme

Steema.TeeChart.Themes.ClassicTheme

Steema.TeeChart.Themes.ExcelTheme

Steema.TeeChart.Themes.GrayscaleTheme

Steema.TeeChart.Themes.OperaTheme

Steema.TeeChart.Themes.BlackIsBackTheme

Steema.TeeChart.Themes.RandomTheme

Steema.TeeChart.Themes.WebTheme

Steema.TeeChart.Themes.ThemeProperties

System.Collections.ArrayList

Steema.TeeChart.Themes.ColorPalettes

See Also

SteemaTeeChartThemes Namespace


Steema.TeeChart.Themes.BlackIsBackTheme

Steema.TeeChart.Themes.BlackIsBackTheme Class

BlackIsBackTheme.

For a list of all members of this type, see BlackIsBackTheme Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
Steema.TeeChart.Themes.TeeChartTheme
Steema.TeeChart.Themes.OperaTheme
public class BlackIsBackTheme : OperaTheme

Requirements

Namespace: Steema.TeeChart.Themes Namespace

Assembly: TeeChart.Android.dll

See Also

BlackIsBackTheme members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.BlackIsBackThemeMembers

Steema.TeeChart.Themes.BlackIsBackTheme all Members

BlackIsBackTheme overview

Constructors

Constructor Overloaded

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

BlackIsBackTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.BlackIsBackTheme Constructor

Overload List

public BlackIsBackTheme()
public BlackIsBackTheme(Steema.TeeChart.Chart)

See Also

BlackIsBackTheme Class | BlackIsBackTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.BlackIsBackTheme Constructor

public BlackIsBackTheme(Chart c)

See Also

BlackIsBackTheme Constructor Overload List | BlackIsBackTheme Class | BlackIsBackTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.BlackIsBackTheme Constructor

public BlackIsBackTheme()

See Also

BlackIsBackTheme Constructor Overload List | BlackIsBackTheme Class | BlackIsBackTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.BlackIsBackThemeMethods

Steema.TeeChart.Themes.BlackIsBackTheme Methods

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

See Also

BlackIsBackTheme Class | Steema.TeeChart.Themes Namespace


ToString

Steema.TeeChart.Themes.BlackIsBackTheme.ToString Method

public override String ToString()

See Also

BlackIsBackTheme Class | BlackIsBackTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.BlackIsBackThemeProperties

Steema.TeeChart.Themes.BlackIsBackTheme Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

BlackIsBackTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.BlueSkyTheme

Steema.TeeChart.Themes.BlueSkyTheme Class

BlueSkyTheme.

For a list of all members of this type, see BlueSkyTheme Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
Steema.TeeChart.Themes.TeeChartTheme
public class BlueSkyTheme : TeeChartTheme

Requirements

Namespace: Steema.TeeChart.Themes Namespace

Assembly: TeeChart.Android.dll

See Also

BlueSkyTheme members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.BlueSkyThemeMembers

Steema.TeeChart.Themes.BlueSkyTheme all Members

BlueSkyTheme overview

Constructors

Constructor Overloaded

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

BlueSkyTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.BlueSkyTheme Constructor

Overload List

public BlueSkyTheme()
public BlueSkyTheme(Steema.TeeChart.Chart)

See Also

BlueSkyTheme Class | BlueSkyTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.BlueSkyTheme Constructor

public BlueSkyTheme(Chart c)

See Also

BlueSkyTheme Constructor Overload List | BlueSkyTheme Class | BlueSkyTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.BlueSkyTheme Constructor

public BlueSkyTheme()

See Also

BlueSkyTheme Constructor Overload List | BlueSkyTheme Class | BlueSkyTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.BlueSkyThemeMethods

Steema.TeeChart.Themes.BlueSkyTheme Methods

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

See Also

BlueSkyTheme Class | Steema.TeeChart.Themes Namespace


ToString

Steema.TeeChart.Themes.BlueSkyTheme.ToString Method

public override String ToString()

See Also

BlueSkyTheme Class | BlueSkyTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.BlueSkyThemeProperties

Steema.TeeChart.Themes.BlueSkyTheme Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

BlueSkyTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.BusinessTheme

Steema.TeeChart.Themes.BusinessTheme Class

Summary description for BusinessTheme.

For a list of all members of this type, see BusinessTheme Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
Steema.TeeChart.Themes.TeeChartTheme
public class BusinessTheme : TeeChartTheme

Requirements

Namespace: Steema.TeeChart.Themes Namespace

Assembly: TeeChart.Android.dll

See Also

BusinessTheme members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.BusinessThemeMembers

Steema.TeeChart.Themes.BusinessTheme all Members

BusinessTheme overview

Constructors

Constructor Overloaded

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

BusinessTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.BusinessTheme Constructor

Overload List

public BusinessTheme()
public BusinessTheme(Steema.TeeChart.Chart)

See Also

BusinessTheme Class | BusinessTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.BusinessTheme Constructor

public BusinessTheme(Chart c)

See Also

BusinessTheme Constructor Overload List | BusinessTheme Class | BusinessTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.BusinessTheme Constructor

public BusinessTheme()

See Also

BusinessTheme Constructor Overload List | BusinessTheme Class | BusinessTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.BusinessThemeMethods

Steema.TeeChart.Themes.BusinessTheme Methods

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

See Also

BusinessTheme Class | Steema.TeeChart.Themes Namespace


ToString

Steema.TeeChart.Themes.BusinessTheme.ToString Method

public override String ToString()

See Also

BusinessTheme Class | BusinessTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.BusinessThemeProperties

Steema.TeeChart.Themes.BusinessTheme Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

BusinessTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ClassicTheme

Steema.TeeChart.Themes.ClassicTheme Class

Summary description for ExcelTheme.

For a list of all members of this type, see ClassicTheme Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
Steema.TeeChart.Themes.TeeChartTheme
public class ClassicTheme : TeeChartTheme

Requirements

Namespace: Steema.TeeChart.Themes Namespace

Assembly: TeeChart.Android.dll

See Also

ClassicTheme members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ClassicThemeMembers

Steema.TeeChart.Themes.ClassicTheme all Members

ClassicTheme overview

Constructors

Constructor Overloaded

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

ClassicTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ClassicTheme Constructor

Overload List

public ClassicTheme()
public ClassicTheme(Steema.TeeChart.Chart)

See Also

ClassicTheme Class | ClassicTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ClassicTheme Constructor

public ClassicTheme(Chart c)

See Also

ClassicTheme Constructor Overload List | ClassicTheme Class | ClassicTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ClassicTheme Constructor

public ClassicTheme()

See Also

ClassicTheme Constructor Overload List | ClassicTheme Class | ClassicTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ClassicThemeMethods

Steema.TeeChart.Themes.ClassicTheme Methods

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

See Also

ClassicTheme Class | Steema.TeeChart.Themes Namespace


ToString

Steema.TeeChart.Themes.ClassicTheme.ToString Method

public override String ToString()

See Also

ClassicTheme Class | ClassicTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ClassicThemeProperties

Steema.TeeChart.Themes.ClassicTheme Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

ClassicTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ColorPalettes

Steema.TeeChart.Themes.ColorPalettes Class

For a list of all members of this type, see ColorPalettes Members

System.Object
System.Collections.ArrayList
public sealed class ColorPalettes : ArrayList , IList, ICollection
, IEnumerable, ICloneable

Requirements

Namespace: Steema.TeeChart.Themes Namespace

Assembly: TeeChart.Android.dll

See Also

ColorPalettes members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ColorPalettesMembers

Steema.TeeChart.Themes.ColorPalettes all Members

ColorPalettes overview

Constructors

Constructor

Public Methods

ApplyPalette
ColorPaletteChanged
GetPalette
IsInPalette

Public Properties

Item

See Also

ColorPalettes Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ColorPalettes Constructor

public ColorPalettes()

See Also

ColorPalettes Class | ColorPalettes Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ColorPalettesMethods

Steema.TeeChart.Themes.ColorPalettes Methods

Public Methods

ApplyPalette
ColorPaletteChanged
GetPalette
IsInPalette

See Also

ColorPalettes Class | Steema.TeeChart.Themes Namespace


ApplyPalette

Steema.TeeChart.Themes.ColorPalettes.ApplyPalette Method

Overload List

public static Void ApplyPalette(Steema.TeeChart.Chart, System.Int32)
public static Void ApplyPalette(Steema.TeeChart.Chart, System.Drawing.Color[])

See Also

ColorPalettes Class | ColorPalettes Members | Steema.TeeChart.Themes Namespace


ApplyPalette

Steema.TeeChart.Themes.ColorPalettes.ApplyPalette Method

public static Void ApplyPalette(Chart custom,
     Color[] Palette)

See Also

ApplyPalette Overload List | ColorPalettes Class | ColorPalettes Members | Steema.TeeChart.Themes Namespace


ApplyPalette

Steema.TeeChart.Themes.ColorPalettes.ApplyPalette Method

public static Void ApplyPalette(Chart custom,
     Int32 Index)

See Also

ApplyPalette Overload List | ColorPalettes Class | ColorPalettes Members | Steema.TeeChart.Themes Namespace


ColorPaletteChanged

Steema.TeeChart.Themes.ColorPalettes.ColorPaletteChanged Method

public static Void ColorPaletteChanged(Chart custom,
     Color[] Palette)

See Also

ColorPalettes Class | ColorPalettes Members | Steema.TeeChart.Themes Namespace


GetPalette

Steema.TeeChart.Themes.ColorPalettes.GetPalette Method

public static Color[] GetPalette(Int32 Index)

See Also

ColorPalettes Class | ColorPalettes Members | Steema.TeeChart.Themes Namespace


IsInPalette

Steema.TeeChart.Themes.ColorPalettes.IsInPalette Method

public static Boolean IsInPalette(Color color,
     Color[] Palette)

See Also

ColorPalettes Class | ColorPalettes Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ColorPalettesProperties

Steema.TeeChart.Themes.ColorPalettes Properties

Public Properties

Item

See Also

ColorPalettes Class | Steema.TeeChart.Themes Namespace


Item

Steema.TeeChart.Themes.ColorPalettes.Item Property

public String Item(Int32 index) {get;}

See Also

ColorPalettes Class | ColorPalettes Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.CustomTheme

Steema.TeeChart.Themes.CustomTheme Class

Summary description for CustomTheme.

For a list of all members of this type, see CustomTheme Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
public class CustomTheme : Theme

Requirements

Namespace: Steema.TeeChart.Themes Namespace

Assembly: TeeChart.Android.dll

See Also

CustomTheme members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.CustomThemeMembers

Steema.TeeChart.Themes.CustomTheme all Members

CustomTheme overview

Constructors

Constructor

Public Methods

Apply |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

CustomTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.CustomTheme Constructor

public CustomTheme(Chart c)

See Also

CustomTheme Class | CustomTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.CustomThemeMethods

Steema.TeeChart.Themes.CustomTheme Methods

Public Methods

Apply |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

See Also

CustomTheme Class | Steema.TeeChart.Themes Namespace


Apply

Steema.TeeChart.Themes.CustomTheme.Apply Method

Overload List

public override Void Apply(Steema.TeeChart.Chart)

See Also

CustomTheme Class | CustomTheme Members | Steema.TeeChart.Themes Namespace


Apply

Steema.TeeChart.Themes.CustomTheme.Apply Method

public override Void Apply(Chart AChart)

See Also

Apply Overload List | CustomTheme Class | CustomTheme Members | Steema.TeeChart.Themes Namespace


ToString

Steema.TeeChart.Themes.CustomTheme.ToString Method

public override String ToString()

See Also

CustomTheme Class | CustomTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.CustomThemeProperties

Steema.TeeChart.Themes.CustomTheme Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

CustomTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ExcelTheme

Steema.TeeChart.Themes.ExcelTheme Class

Summary description for ExcelTheme.

For a list of all members of this type, see ExcelTheme Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
Steema.TeeChart.Themes.TeeChartTheme
public class ExcelTheme : TeeChartTheme

Requirements

Namespace: Steema.TeeChart.Themes Namespace

Assembly: TeeChart.Android.dll

See Also

ExcelTheme members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ExcelThemeMembers

Steema.TeeChart.Themes.ExcelTheme all Members

ExcelTheme overview

Constructors

Constructor Overloaded

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

ExcelTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ExcelTheme Constructor

Overload List

public ExcelTheme()
public ExcelTheme(Steema.TeeChart.Chart)

See Also

ExcelTheme Class | ExcelTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ExcelTheme Constructor

public ExcelTheme(Chart c)

See Also

ExcelTheme Constructor Overload List | ExcelTheme Class | ExcelTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ExcelTheme Constructor

public ExcelTheme()

See Also

ExcelTheme Constructor Overload List | ExcelTheme Class | ExcelTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ExcelThemeMethods

Steema.TeeChart.Themes.ExcelTheme Methods

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

See Also

ExcelTheme Class | Steema.TeeChart.Themes Namespace


ToString

Steema.TeeChart.Themes.ExcelTheme.ToString Method

public override String ToString()

See Also

ExcelTheme Class | ExcelTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ExcelThemeProperties

Steema.TeeChart.Themes.ExcelTheme Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

ExcelTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.GrayscaleTheme

Steema.TeeChart.Themes.GrayscaleTheme Class

Summary description for GrayscaleTheme.

For a list of all members of this type, see GrayscaleTheme Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
Steema.TeeChart.Themes.TeeChartTheme
public class GrayscaleTheme : TeeChartTheme

Requirements

Namespace: Steema.TeeChart.Themes Namespace

Assembly: TeeChart.Android.dll

See Also

GrayscaleTheme members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.GrayscaleThemeMembers

Steema.TeeChart.Themes.GrayscaleTheme all Members

GrayscaleTheme overview

Constructors

Constructor Overloaded

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

GrayscaleTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.GrayscaleTheme Constructor

Overload List

public GrayscaleTheme()
public GrayscaleTheme(Steema.TeeChart.Chart)

See Also

GrayscaleTheme Class | GrayscaleTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.GrayscaleTheme Constructor

public GrayscaleTheme(Chart c)

See Also

GrayscaleTheme Constructor Overload List | GrayscaleTheme Class | GrayscaleTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.GrayscaleTheme Constructor

public GrayscaleTheme()

See Also

GrayscaleTheme Constructor Overload List | GrayscaleTheme Class | GrayscaleTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.GrayscaleThemeMethods

Steema.TeeChart.Themes.GrayscaleTheme Methods

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

See Also

GrayscaleTheme Class | Steema.TeeChart.Themes Namespace


ToString

Steema.TeeChart.Themes.GrayscaleTheme.ToString Method

public override String ToString()

See Also

GrayscaleTheme Class | GrayscaleTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.GrayscaleThemeProperties

Steema.TeeChart.Themes.GrayscaleTheme Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

GrayscaleTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.OperaTheme

Steema.TeeChart.Themes.OperaTheme Class

For a list of all members of this type, see OperaTheme Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
Steema.TeeChart.Themes.TeeChartTheme
public class OperaTheme : TeeChartTheme

Requirements

Namespace: Steema.TeeChart.Themes Namespace

Assembly: TeeChart.Android.dll

See Also

OperaTheme members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.OperaThemeMembers

Steema.TeeChart.Themes.OperaTheme all Members

OperaTheme overview

Constructors

Constructor Overloaded

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

OperaTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.OperaTheme Constructor

Overload List

public OperaTheme()
public OperaTheme(Steema.TeeChart.Chart)

See Also

OperaTheme Class | OperaTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.OperaTheme Constructor

public OperaTheme(Chart c)

See Also

OperaTheme Constructor Overload List | OperaTheme Class | OperaTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.OperaTheme Constructor

public OperaTheme()

See Also

OperaTheme Constructor Overload List | OperaTheme Class | OperaTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.OperaThemeMethods

Steema.TeeChart.Themes.OperaTheme Methods

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

See Also

OperaTheme Class | Steema.TeeChart.Themes Namespace


ToString

Steema.TeeChart.Themes.OperaTheme.ToString Method

public override String ToString()

See Also

OperaTheme Class | OperaTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.OperaThemeProperties

Steema.TeeChart.Themes.OperaTheme Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

OperaTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.RandomTheme

Steema.TeeChart.Themes.RandomTheme Class

For a list of all members of this type, see RandomTheme Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
Steema.TeeChart.Themes.TeeChartTheme
public class RandomTheme : TeeChartTheme

Requirements

Namespace: Steema.TeeChart.Themes Namespace

Assembly: TeeChart.Android.dll

See Also

RandomTheme members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.RandomThemeMembers

Steema.TeeChart.Themes.RandomTheme all Members

RandomTheme overview

Constructors

Constructor Overloaded

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
RandomColor |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

RandomTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.RandomTheme Constructor

Overload List

public RandomTheme()
public RandomTheme(Steema.TeeChart.Chart)

See Also

RandomTheme Class | RandomTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.RandomTheme Constructor

public RandomTheme(Chart c)

See Also

RandomTheme Constructor Overload List | RandomTheme Class | RandomTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.RandomTheme Constructor

public RandomTheme()

See Also

RandomTheme Constructor Overload List | RandomTheme Class | RandomTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.RandomThemeMethods

Steema.TeeChart.Themes.RandomTheme Methods

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

See Also

RandomTheme Class | Steema.TeeChart.Themes Namespace


ToString

Steema.TeeChart.Themes.RandomTheme.ToString Method

public override String ToString()

See Also

RandomTheme Class | RandomTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.RandomThemeProperties

Steema.TeeChart.Themes.RandomTheme Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
RandomColor |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

RandomTheme Class | Steema.TeeChart.Themes Namespace


RandomColor

Steema.TeeChart.Themes.RandomTheme.RandomColor Property

public static Color RandomColor {get;}

See Also

RandomTheme Class | RandomTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.TeeChartTheme

Steema.TeeChart.Themes.TeeChartTheme Class

Summary description for DefaultTheme.

For a list of all members of this type, see TeeChartTheme Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
public class TeeChartTheme : CustomTheme

Requirements

Namespace: Steema.TeeChart.Themes Namespace

Assembly: TeeChart.Android.dll

See Also

TeeChartTheme members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.TeeChartThemeMembers

Steema.TeeChart.Themes.TeeChartTheme all Members

TeeChartTheme overview

Constructors

Constructor Overloaded

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

TeeChartTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.TeeChartTheme Constructor

Overload List

public TeeChartTheme()
public TeeChartTheme(Steema.TeeChart.Chart)

See Also

TeeChartTheme Class | TeeChartTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.TeeChartTheme Constructor

public TeeChartTheme(Chart c)

See Also

TeeChartTheme Constructor Overload List | TeeChartTheme Class | TeeChartTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.TeeChartTheme Constructor

public TeeChartTheme()

See Also

TeeChartTheme Constructor Overload List | TeeChartTheme Class | TeeChartTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.TeeChartThemeMethods

Steema.TeeChart.Themes.TeeChartTheme Methods

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

See Also

TeeChartTheme Class | Steema.TeeChart.Themes Namespace


ToString

Steema.TeeChart.Themes.TeeChartTheme.ToString Method

public override String ToString()

See Also

TeeChartTheme Class | TeeChartTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.TeeChartThemeProperties

Steema.TeeChart.Themes.TeeChartTheme Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

TeeChartTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.Theme

Steema.TeeChart.Themes.Theme Class

Summary description for Theme.

For a list of all members of this type, see Theme Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public abstract class Theme : TeeBase

Requirements

Namespace: Steema.TeeChart.Themes Namespace

Assembly: TeeChart.Android.dll

See Also

Theme members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ThemeMembers

Steema.TeeChart.Themes.Theme all Members

Theme overview

Constructors

Constructor

Public Fields

ClassicPalette
CoolPalette
ExcelPalette
GrayscalePalette
MacOSPalette
ModernPalette
OnBlackPalette
OperaPalette
PastelsPalette
RainbowPalette
SolidPalette
TeeChartPalette
VictorianPalette
WarmPalette
WebPalette
WindowsVistaPalette
WindowsXPPalette

Public Methods

Apply |
ApplyChartTheme |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
RegisterChartThemes |
ToString |

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
ChartThemes |
ColorPalettes |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Theme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.Theme Constructor

public Theme(Chart c)

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ThemeFields

Steema.TeeChart.Themes.Theme Fields

Public Fields

ClassicPalette
CoolPalette
ExcelPalette
GrayscalePalette
MacOSPalette
ModernPalette
OnBlackPalette
OperaPalette
PastelsPalette
RainbowPalette
SolidPalette
TeeChartPalette
VictorianPalette
WarmPalette
WebPalette
WindowsVistaPalette
WindowsXPPalette

See Also

Theme Class | Steema.TeeChart.Themes Namespace


ClassicPalette

Steema.TeeChart.Themes.Theme.ClassicPalette Field

public Color[] ClassicPalette

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


CoolPalette

Steema.TeeChart.Themes.Theme.CoolPalette Field

public Color[] CoolPalette

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


ExcelPalette

Steema.TeeChart.Themes.Theme.ExcelPalette Field

public Color[] ExcelPalette

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


GrayscalePalette

Steema.TeeChart.Themes.Theme.GrayscalePalette Field

public Color[] GrayscalePalette

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


MacOSPalette

Steema.TeeChart.Themes.Theme.MacOSPalette Field

public Color[] MacOSPalette

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


ModernPalette

Steema.TeeChart.Themes.Theme.ModernPalette Field

public Color[] ModernPalette

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


OnBlackPalette

Steema.TeeChart.Themes.Theme.OnBlackPalette Field

public Color[] OnBlackPalette

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


OperaPalette

Steema.TeeChart.Themes.Theme.OperaPalette Field

public Color[] OperaPalette

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


PastelsPalette

Steema.TeeChart.Themes.Theme.PastelsPalette Field

public Color[] PastelsPalette

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


RainbowPalette

Steema.TeeChart.Themes.Theme.RainbowPalette Field

public Color[] RainbowPalette

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


SolidPalette

Steema.TeeChart.Themes.Theme.SolidPalette Field

public Color[] SolidPalette

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


TeeChartPalette

Steema.TeeChart.Themes.Theme.TeeChartPalette Field

public Color[] TeeChartPalette

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


VictorianPalette

Steema.TeeChart.Themes.Theme.VictorianPalette Field

public Color[] VictorianPalette

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


WarmPalette

Steema.TeeChart.Themes.Theme.WarmPalette Field

public Color[] WarmPalette

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


WebPalette

Steema.TeeChart.Themes.Theme.WebPalette Field

public Color[] WebPalette

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


WindowsVistaPalette

Steema.TeeChart.Themes.Theme.WindowsVistaPalette Field

public Color[] WindowsVistaPalette

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


WindowsXPPalette

Steema.TeeChart.Themes.Theme.WindowsXPPalette Field

public Color[] WindowsXPPalette

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ThemeMethods

Steema.TeeChart.Themes.Theme Methods

Public Methods

Apply |
ApplyChartTheme |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
RegisterChartThemes |
ToString |

See Also

Theme Class | Steema.TeeChart.Themes Namespace


Apply

Steema.TeeChart.Themes.Theme.Apply Method

Overload List

public Void Apply()
public abstract Void Apply(Steema.TeeChart.Chart)

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


Apply

Steema.TeeChart.Themes.Theme.Apply Method

public abstract Void Apply(Chart AChart)

See Also

Apply Overload List | Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


Apply

Steema.TeeChart.Themes.Theme.Apply Method

public Void Apply()

See Also

Apply Overload List | Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


ApplyChartTheme

Steema.TeeChart.Themes.Theme.ApplyChartTheme Method

Overload List

public static Void ApplyChartTheme(Steema.TeeChart.Themes.Theme, Steema.TeeChart.Chart)
public static Void ApplyChartTheme(Steema.TeeChart.Themes.Theme, Steema.TeeChart.Chart, System.Int32)
public static Void ApplyChartTheme(System.IO.Stream, Steema.TeeChart.Chart, System.Int32)

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


ApplyChartTheme

Steema.TeeChart.Themes.Theme.ApplyChartTheme Method

public static Void ApplyChartTheme(Stream ThemeStream,
     Chart CustomChart,
     Int32 PaletteIndex)

See Also

ApplyChartTheme Overload List | Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


ApplyChartTheme

Steema.TeeChart.Themes.Theme.ApplyChartTheme Method

public static Void ApplyChartTheme(Theme ThemeClass,
     Chart CustomChart,
     Int32 PaletteIndex)

See Also

ApplyChartTheme Overload List | Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


ApplyChartTheme

Steema.TeeChart.Themes.Theme.ApplyChartTheme Method

public static Void ApplyChartTheme(Theme ThemeClass,
     Chart CustomChart)

See Also

ApplyChartTheme Overload List | Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


RegisterChartThemes

Steema.TeeChart.Themes.Theme.RegisterChartThemes Method

public static Void RegisterChartThemes()

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


ToString

Steema.TeeChart.Themes.Theme.ToString Method

public override String ToString()

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ThemeProperties

Steema.TeeChart.Themes.ThemeProperties Class

For a list of all members of this type, see ThemeProperties Members

System.Object
public class ThemeProperties : Object , IThemeProperties

Requirements

Namespace: Steema.TeeChart.Themes Namespace

Assembly: TeeChart.Android.dll

See Also

ThemeProperties members | Steema.TeeChart.Themes Namespace


ChartThemes

Steema.TeeChart.Themes.Theme.ChartThemes Property

public static List<Type> ChartThemes {get;}

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


ColorPalettes

Steema.TeeChart.Themes.Theme.ColorPalettes Property

public static ColorPalettes ColorPalettes {get;}

See Also

Theme Class | Theme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ThemePropertiesMembers

Steema.TeeChart.Themes.ThemeProperties all Members

ThemeProperties overview

Constructors

Constructor

Public Methods

Read
Write

Public Properties

AspectSmoothingMode
AspectTextRenderingHint
AxesBottomGridCentered
AxesBottomGridVisible
AxesTopGridVisible
AxisAxisPenColor
AxisAxisPenWidth
AxisGridCentered
AxisGridColor
AxisGridStyle
AxisGridVisible
AxisGridWidth
AxisLabelsFontBold
AxisLabelsFontColor
AxisLabelsFontItalic
AxisLabelsFontName
AxisLabelsFontSize
AxisMinorGridColor
AxisMinorGridVisible
AxisMinorTickCount
AxisMinorTicksLength
AxisMinorTicksVisible
AxisTicksColor
AxisTicksInnerColor
AxisTicksInnerLength
AxisTicksInnerVisible
AxisTicksLength
AxisTitleFontBold
AxisTitleFontColor
AxisTitleFontItalic
AxisTitleFontName
AxisTitleFontSize
Base64
HeaderColor
HeaderFontBold
HeaderFontColor
HeaderFontItalic
HeaderFontName
HeaderFontSize
HeaderGradientDirection
HeaderGradientEndColor
HeaderGradientMiddleColor
HeaderGradientSigma
HeaderGradientSigmaFocus
HeaderGradientSigmaScale
HeaderGradientStartColor
HeaderGradientVisible
HeaderPenColor
HeaderPenVisible
HeaderPenWidth
HeaderShadowSize
HeaderShadowTransparency
HeaderTransparency
Instance
LegendDividingLinesColor
LegendDividingLinesVisible
LegendFontColor
LegendFontName
LegendFontSize
LegendGradientDirection
LegendGradientEndColor
LegendGradientMiddleColor
LegendGradientSigma
LegendGradientSigmaFocus
LegendGradientSigmaScale
LegendGradientStartColor
LegendGradientVisible
LegendPenColor
LegendPenStyle
LegendPenVisible
LegendPenWidth
LegendShadowColor
LegendShadowHeight
LegendShadowTransparency
LegendShadowWidth
LegendSymbolDefaultPen
LegendSymbolPenVisible
LegendSymbolSquared
LegendTransparent
Palette
PanelBevelInner
PanelBevelOuter
PanelBevelWidth
PanelBorderRound
PanelColor
PanelGradientDirection
PanelGradientEndColor
PanelGradientMiddleColor
PanelGradientSigma
PanelGradientSigmaFocus
PanelGradientSigmaScale
PanelGradientStartColor
PanelGradientVisible
PanelPenColor
PanelPenStyle
PanelPenVisible
PanelPenWidth
PanelShadowColor
PanelShadowSize
PanelShadowVisible
SeriesMarksArrowColor
SeriesMarksFontColor
SeriesMarksFontName
SeriesMarksFontSize
SeriesMarksGradientDirection
SeriesMarksGradientEndColor
SeriesMarksGradientMiddleColor
SeriesMarksGradientSigma
SeriesMarksGradientSigmaFocus
SeriesMarksGradientSigmaScale
SeriesMarksGradientStartColor
SeriesMarksGradientVisible
SeriesMarksTransparent
WallApplyDark
WallGradientDirection
WallGradientEndColor
WallGradientMiddleColor
WallGradientSigma
WallGradientSigmaFocus
WallGradientSigmaScale
WallGradientStartColor
WallGradientVisible
WallPenColor
WallPenStyle
WallPenVisible
WallPenWidth
WallsBackColor
WallsBackGradientDirection
WallsBackGradientEndColor
WallsBackGradientMiddleColor
WallsBackGradientSigma
WallsBackGradientSigmaFocus
WallsBackGradientSigmaScale
WallsBackGradientStartColor
WallsBackGradientVisible
WallsBackTransparent
WallsBottomColor
WallSize
WallsLeftColor
WallsRightColor

See Also

ThemeProperties Class | Steema.TeeChart.Themes.Theme Namespace


Steema.TeeChart.Themes.ThemeProperties Constructor

public ThemeProperties()

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ThemePropertiesMethods

Steema.TeeChart.Themes.ThemeProperties Methods

Public Methods

Read
Write

See Also

ThemeProperties Class | Steema.TeeChart.Themes Namespace


Read

Steema.TeeChart.Themes.ThemeProperties.Read Method

Overload List

public Void Read(System.String)
public Void Read(System.IO.Stream)

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


Read

Steema.TeeChart.Themes.ThemeProperties.Read Method

public Void Read(Stream stream)

See Also

Read Overload List | ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


Read

Steema.TeeChart.Themes.ThemeProperties.Read Method

public Void Read(String fileName)

See Also

Read Overload List | ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


Write

Steema.TeeChart.Themes.ThemeProperties.Write Method

Overload List

public Void Write(System.String)
public Void Write(System.IO.Stream)

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


Write

Steema.TeeChart.Themes.ThemeProperties.Write Method

public Void Write(Stream stream)

See Also

Write Overload List | ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


Write

Steema.TeeChart.Themes.ThemeProperties.Write Method

public Void Write(String fileName)

See Also

Write Overload List | ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.ThemePropertiesProperties

Steema.TeeChart.Themes.ThemeProperties Properties

Public Properties

AspectSmoothingMode
AspectTextRenderingHint
AxesBottomGridCentered
AxesBottomGridVisible
AxesTopGridVisible
AxisAxisPenColor
AxisAxisPenWidth
AxisGridCentered
AxisGridColor
AxisGridStyle
AxisGridVisible
AxisGridWidth
AxisLabelsFontBold
AxisLabelsFontColor
AxisLabelsFontItalic
AxisLabelsFontName
AxisLabelsFontSize
AxisMinorGridColor
AxisMinorGridVisible
AxisMinorTickCount
AxisMinorTicksLength
AxisMinorTicksVisible
AxisTicksColor
AxisTicksInnerColor
AxisTicksInnerLength
AxisTicksInnerVisible
AxisTicksLength
AxisTitleFontBold
AxisTitleFontColor
AxisTitleFontItalic
AxisTitleFontName
AxisTitleFontSize
Base64
HeaderColor
HeaderFontBold
HeaderFontColor
HeaderFontItalic
HeaderFontName
HeaderFontSize
HeaderGradientDirection
HeaderGradientEndColor
HeaderGradientMiddleColor
HeaderGradientSigma
HeaderGradientSigmaFocus
HeaderGradientSigmaScale
HeaderGradientStartColor
HeaderGradientVisible
HeaderPenColor
HeaderPenVisible
HeaderPenWidth
HeaderShadowSize
HeaderShadowTransparency
HeaderTransparency
Instance
LegendDividingLinesColor
LegendDividingLinesVisible
LegendFontColor
LegendFontName
LegendFontSize
LegendGradientDirection
LegendGradientEndColor
LegendGradientMiddleColor
LegendGradientSigma
LegendGradientSigmaFocus
LegendGradientSigmaScale
LegendGradientStartColor
LegendGradientVisible
LegendPenColor
LegendPenStyle
LegendPenVisible
LegendPenWidth
LegendShadowColor
LegendShadowHeight
LegendShadowTransparency
LegendShadowWidth
LegendSymbolDefaultPen
LegendSymbolPenVisible
LegendSymbolSquared
LegendTransparent
Palette
PanelBevelInner
PanelBevelOuter
PanelBevelWidth
PanelBorderRound
PanelColor
PanelGradientDirection
PanelGradientEndColor
PanelGradientMiddleColor
PanelGradientSigma
PanelGradientSigmaFocus
PanelGradientSigmaScale
PanelGradientStartColor
PanelGradientVisible
PanelPenColor
PanelPenStyle
PanelPenVisible
PanelPenWidth
PanelShadowColor
PanelShadowSize
PanelShadowVisible
SeriesMarksArrowColor
SeriesMarksFontColor
SeriesMarksFontName
SeriesMarksFontSize
SeriesMarksGradientDirection
SeriesMarksGradientEndColor
SeriesMarksGradientMiddleColor
SeriesMarksGradientSigma
SeriesMarksGradientSigmaFocus
SeriesMarksGradientSigmaScale
SeriesMarksGradientStartColor
SeriesMarksGradientVisible
SeriesMarksTransparent
WallApplyDark
WallGradientDirection
WallGradientEndColor
WallGradientMiddleColor
WallGradientSigma
WallGradientSigmaFocus
WallGradientSigmaScale
WallGradientStartColor
WallGradientVisible
WallPenColor
WallPenStyle
WallPenVisible
WallPenWidth
WallsBackColor
WallsBackGradientDirection
WallsBackGradientEndColor
WallsBackGradientMiddleColor
WallsBackGradientSigma
WallsBackGradientSigmaFocus
WallsBackGradientSigmaScale
WallsBackGradientStartColor
WallsBackGradientVisible
WallsBackTransparent
WallsBottomColor
WallSize
WallsLeftColor
WallsRightColor

See Also

ThemeProperties Class | Steema.TeeChart.Themes Namespace


AspectSmoothingMode

Steema.TeeChart.Themes.ThemeProperties.AspectSmoothingMode Property

public virtual String AspectSmoothingMode {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AspectTextRenderingHint

Steema.TeeChart.Themes.ThemeProperties.AspectTextRenderingHint Property

public virtual String AspectTextRenderingHint {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxesBottomGridCentered

Steema.TeeChart.Themes.ThemeProperties.AxesBottomGridCentered Property

public virtual Boolean AxesBottomGridCentered {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxesBottomGridVisible

Steema.TeeChart.Themes.ThemeProperties.AxesBottomGridVisible Property

public virtual Boolean AxesBottomGridVisible {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxesTopGridVisible

Steema.TeeChart.Themes.ThemeProperties.AxesTopGridVisible Property

public virtual Boolean AxesTopGridVisible {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisAxisPenColor

Steema.TeeChart.Themes.ThemeProperties.AxisAxisPenColor Property

public virtual String AxisAxisPenColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisAxisPenWidth

Steema.TeeChart.Themes.ThemeProperties.AxisAxisPenWidth Property

public virtual Int32 AxisAxisPenWidth {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisGridCentered

Steema.TeeChart.Themes.ThemeProperties.AxisGridCentered Property

public virtual Boolean AxisGridCentered {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisGridColor

Steema.TeeChart.Themes.ThemeProperties.AxisGridColor Property

public virtual String AxisGridColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisGridStyle

Steema.TeeChart.Themes.ThemeProperties.AxisGridStyle Property

public virtual String AxisGridStyle {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisGridVisible

Steema.TeeChart.Themes.ThemeProperties.AxisGridVisible Property

public virtual Boolean AxisGridVisible {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisGridWidth

Steema.TeeChart.Themes.ThemeProperties.AxisGridWidth Property

public virtual Int32 AxisGridWidth {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisLabelsFontBold

Steema.TeeChart.Themes.ThemeProperties.AxisLabelsFontBold Property

public virtual Boolean AxisLabelsFontBold {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisLabelsFontColor

Steema.TeeChart.Themes.ThemeProperties.AxisLabelsFontColor Property

public virtual String AxisLabelsFontColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisLabelsFontItalic

Steema.TeeChart.Themes.ThemeProperties.AxisLabelsFontItalic Property

public virtual Boolean AxisLabelsFontItalic {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisLabelsFontName

Steema.TeeChart.Themes.ThemeProperties.AxisLabelsFontName Property

public virtual String AxisLabelsFontName {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisLabelsFontSize

Steema.TeeChart.Themes.ThemeProperties.AxisLabelsFontSize Property

public virtual Int32 AxisLabelsFontSize {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisMinorGridColor

Steema.TeeChart.Themes.ThemeProperties.AxisMinorGridColor Property

public virtual String AxisMinorGridColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisMinorGridVisible

Steema.TeeChart.Themes.ThemeProperties.AxisMinorGridVisible Property

public virtual Boolean AxisMinorGridVisible {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisMinorTickCount

Steema.TeeChart.Themes.ThemeProperties.AxisMinorTickCount Property

public virtual Int32 AxisMinorTickCount {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisMinorTicksLength

Steema.TeeChart.Themes.ThemeProperties.AxisMinorTicksLength Property

public virtual Int32 AxisMinorTicksLength {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisMinorTicksVisible

Steema.TeeChart.Themes.ThemeProperties.AxisMinorTicksVisible Property

public virtual Boolean AxisMinorTicksVisible {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisTicksColor

Steema.TeeChart.Themes.ThemeProperties.AxisTicksColor Property

public virtual String AxisTicksColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisTicksInnerColor

Steema.TeeChart.Themes.ThemeProperties.AxisTicksInnerColor Property

public virtual String AxisTicksInnerColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisTicksInnerLength

Steema.TeeChart.Themes.ThemeProperties.AxisTicksInnerLength Property

public virtual Int32 AxisTicksInnerLength {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisTicksInnerVisible

Steema.TeeChart.Themes.ThemeProperties.AxisTicksInnerVisible Property

public virtual Boolean AxisTicksInnerVisible {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisTicksLength

Steema.TeeChart.Themes.ThemeProperties.AxisTicksLength Property

public virtual Int32 AxisTicksLength {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisTitleFontBold

Steema.TeeChart.Themes.ThemeProperties.AxisTitleFontBold Property

public virtual Boolean AxisTitleFontBold {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisTitleFontColor

Steema.TeeChart.Themes.ThemeProperties.AxisTitleFontColor Property

public virtual String AxisTitleFontColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisTitleFontItalic

Steema.TeeChart.Themes.ThemeProperties.AxisTitleFontItalic Property

public virtual Boolean AxisTitleFontItalic {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisTitleFontName

Steema.TeeChart.Themes.ThemeProperties.AxisTitleFontName Property

public virtual String AxisTitleFontName {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


AxisTitleFontSize

Steema.TeeChart.Themes.ThemeProperties.AxisTitleFontSize Property

public virtual Int32 AxisTitleFontSize {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


Base64

Steema.TeeChart.Themes.ThemeProperties.Base64 Property

public virtual String Base64 {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


HeaderColor

Steema.TeeChart.Themes.ThemeProperties.HeaderColor Property

public virtual String HeaderColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


HeaderFontBold

Steema.TeeChart.Themes.ThemeProperties.HeaderFontBold Property

public virtual Boolean HeaderFontBold {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


HeaderFontColor

Steema.TeeChart.Themes.ThemeProperties.HeaderFontColor Property

public virtual String HeaderFontColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


HeaderFontItalic

Steema.TeeChart.Themes.ThemeProperties.HeaderFontItalic Property

public virtual Boolean HeaderFontItalic {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


HeaderFontName

Steema.TeeChart.Themes.ThemeProperties.HeaderFontName Property

public virtual String HeaderFontName {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


HeaderFontSize

Steema.TeeChart.Themes.ThemeProperties.HeaderFontSize Property

public virtual Int32 HeaderFontSize {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


HeaderGradientDirection

Steema.TeeChart.Themes.ThemeProperties.HeaderGradientDirection Property

public virtual String HeaderGradientDirection {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


HeaderGradientEndColor

Steema.TeeChart.Themes.ThemeProperties.HeaderGradientEndColor Property

public virtual String HeaderGradientEndColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


HeaderGradientMiddleColor

Steema.TeeChart.Themes.ThemeProperties.HeaderGradientMiddleColor Property

public virtual String HeaderGradientMiddleColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


HeaderGradientSigma

Steema.TeeChart.Themes.ThemeProperties.HeaderGradientSigma Property

public virtual Boolean HeaderGradientSigma {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


HeaderGradientSigmaFocus

Steema.TeeChart.Themes.ThemeProperties.HeaderGradientSigmaFocus Property

public virtual Single HeaderGradientSigmaFocus {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


HeaderGradientSigmaScale

Steema.TeeChart.Themes.ThemeProperties.HeaderGradientSigmaScale Property

public virtual Single HeaderGradientSigmaScale {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


HeaderGradientStartColor

Steema.TeeChart.Themes.ThemeProperties.HeaderGradientStartColor Property

public virtual String HeaderGradientStartColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


HeaderGradientVisible

Steema.TeeChart.Themes.ThemeProperties.HeaderGradientVisible Property

public virtual Boolean HeaderGradientVisible {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


HeaderPenColor

Steema.TeeChart.Themes.ThemeProperties.HeaderPenColor Property

public virtual String HeaderPenColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


HeaderPenVisible

Steema.TeeChart.Themes.ThemeProperties.HeaderPenVisible Property

public virtual Boolean HeaderPenVisible {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


HeaderPenWidth

Steema.TeeChart.Themes.ThemeProperties.HeaderPenWidth Property

public virtual Int32 HeaderPenWidth {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


HeaderShadowSize

Steema.TeeChart.Themes.ThemeProperties.HeaderShadowSize Property

public virtual Int32 HeaderShadowSize {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


HeaderShadowTransparency

Steema.TeeChart.Themes.ThemeProperties.HeaderShadowTransparency Property

public virtual Int32 HeaderShadowTransparency {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


HeaderTransparency

Steema.TeeChart.Themes.ThemeProperties.HeaderTransparency Property

public virtual Int32 HeaderTransparency {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


Instance

Steema.TeeChart.Themes.ThemeProperties.Instance Property

public static ThemeProperties Instance {get;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendDividingLinesColor

Steema.TeeChart.Themes.ThemeProperties.LegendDividingLinesColor Property

public virtual String LegendDividingLinesColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendDividingLinesVisible

Steema.TeeChart.Themes.ThemeProperties.LegendDividingLinesVisible Property

public virtual Boolean LegendDividingLinesVisible {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendFontColor

Steema.TeeChart.Themes.ThemeProperties.LegendFontColor Property

public virtual String LegendFontColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendFontName

Steema.TeeChart.Themes.ThemeProperties.LegendFontName Property

public virtual String LegendFontName {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendFontSize

Steema.TeeChart.Themes.ThemeProperties.LegendFontSize Property

public virtual Int32 LegendFontSize {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendGradientDirection

Steema.TeeChart.Themes.ThemeProperties.LegendGradientDirection Property

public virtual String LegendGradientDirection {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendGradientEndColor

Steema.TeeChart.Themes.ThemeProperties.LegendGradientEndColor Property

public virtual String LegendGradientEndColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendGradientMiddleColor

Steema.TeeChart.Themes.ThemeProperties.LegendGradientMiddleColor Property

public virtual String LegendGradientMiddleColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendGradientSigma

Steema.TeeChart.Themes.ThemeProperties.LegendGradientSigma Property

public virtual Boolean LegendGradientSigma {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendGradientSigmaFocus

Steema.TeeChart.Themes.ThemeProperties.LegendGradientSigmaFocus Property

public virtual Single LegendGradientSigmaFocus {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendGradientSigmaScale

Steema.TeeChart.Themes.ThemeProperties.LegendGradientSigmaScale Property

public virtual Single LegendGradientSigmaScale {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendGradientStartColor

Steema.TeeChart.Themes.ThemeProperties.LegendGradientStartColor Property

public virtual String LegendGradientStartColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendGradientVisible

Steema.TeeChart.Themes.ThemeProperties.LegendGradientVisible Property

public virtual Boolean LegendGradientVisible {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendPenColor

Steema.TeeChart.Themes.ThemeProperties.LegendPenColor Property

public virtual String LegendPenColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendPenStyle

Steema.TeeChart.Themes.ThemeProperties.LegendPenStyle Property

public virtual String LegendPenStyle {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendPenVisible

Steema.TeeChart.Themes.ThemeProperties.LegendPenVisible Property

public virtual Boolean LegendPenVisible {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendPenWidth

Steema.TeeChart.Themes.ThemeProperties.LegendPenWidth Property

public virtual Int32 LegendPenWidth {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendShadowColor

Steema.TeeChart.Themes.ThemeProperties.LegendShadowColor Property

public virtual String LegendShadowColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendShadowHeight

Steema.TeeChart.Themes.ThemeProperties.LegendShadowHeight Property

public virtual Int32 LegendShadowHeight {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendShadowTransparency

Steema.TeeChart.Themes.ThemeProperties.LegendShadowTransparency Property

public virtual Int32 LegendShadowTransparency {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendShadowWidth

Steema.TeeChart.Themes.ThemeProperties.LegendShadowWidth Property

public virtual Int32 LegendShadowWidth {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendSymbolDefaultPen

Steema.TeeChart.Themes.ThemeProperties.LegendSymbolDefaultPen Property

public virtual Boolean LegendSymbolDefaultPen {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendSymbolPenVisible

Steema.TeeChart.Themes.ThemeProperties.LegendSymbolPenVisible Property

public virtual Boolean LegendSymbolPenVisible {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendSymbolSquared

Steema.TeeChart.Themes.ThemeProperties.LegendSymbolSquared Property

public virtual Boolean LegendSymbolSquared {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


LegendTransparent

Steema.TeeChart.Themes.ThemeProperties.LegendTransparent Property

public virtual Boolean LegendTransparent {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


Palette

Steema.TeeChart.Themes.ThemeProperties.Palette Property

public virtual String[] Palette {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


PanelBevelInner

Steema.TeeChart.Themes.ThemeProperties.PanelBevelInner Property

public virtual String PanelBevelInner {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


PanelBevelOuter

Steema.TeeChart.Themes.ThemeProperties.PanelBevelOuter Property

public virtual String PanelBevelOuter {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


PanelBevelWidth

Steema.TeeChart.Themes.ThemeProperties.PanelBevelWidth Property

public virtual Int32 PanelBevelWidth {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


PanelBorderRound

Steema.TeeChart.Themes.ThemeProperties.PanelBorderRound Property

public virtual Int32 PanelBorderRound {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


PanelColor

Steema.TeeChart.Themes.ThemeProperties.PanelColor Property

public virtual String PanelColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


PanelGradientDirection

Steema.TeeChart.Themes.ThemeProperties.PanelGradientDirection Property

public virtual String PanelGradientDirection {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


PanelGradientEndColor

Steema.TeeChart.Themes.ThemeProperties.PanelGradientEndColor Property

public virtual String PanelGradientEndColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


PanelGradientMiddleColor

Steema.TeeChart.Themes.ThemeProperties.PanelGradientMiddleColor Property

public virtual String PanelGradientMiddleColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


PanelGradientSigma

Steema.TeeChart.Themes.ThemeProperties.PanelGradientSigma Property

public virtual Boolean PanelGradientSigma {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


PanelGradientSigmaFocus

Steema.TeeChart.Themes.ThemeProperties.PanelGradientSigmaFocus Property

public virtual Single PanelGradientSigmaFocus {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


PanelGradientSigmaScale

Steema.TeeChart.Themes.ThemeProperties.PanelGradientSigmaScale Property

public virtual Single PanelGradientSigmaScale {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


PanelGradientStartColor

Steema.TeeChart.Themes.ThemeProperties.PanelGradientStartColor Property

public virtual String PanelGradientStartColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


PanelGradientVisible

Steema.TeeChart.Themes.ThemeProperties.PanelGradientVisible Property

public virtual Boolean PanelGradientVisible {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


PanelPenColor

Steema.TeeChart.Themes.ThemeProperties.PanelPenColor Property

public virtual String PanelPenColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


PanelPenStyle

Steema.TeeChart.Themes.ThemeProperties.PanelPenStyle Property

public virtual String PanelPenStyle {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


PanelPenVisible

Steema.TeeChart.Themes.ThemeProperties.PanelPenVisible Property

public virtual Boolean PanelPenVisible {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


PanelPenWidth

Steema.TeeChart.Themes.ThemeProperties.PanelPenWidth Property

public virtual Int32 PanelPenWidth {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


PanelShadowColor

Steema.TeeChart.Themes.ThemeProperties.PanelShadowColor Property

public virtual String PanelShadowColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


PanelShadowSize

Steema.TeeChart.Themes.ThemeProperties.PanelShadowSize Property

public virtual Int32 PanelShadowSize {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


PanelShadowVisible

Steema.TeeChart.Themes.ThemeProperties.PanelShadowVisible Property

public virtual Boolean PanelShadowVisible {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


SeriesMarksArrowColor

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksArrowColor Property

public virtual String SeriesMarksArrowColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


SeriesMarksFontColor

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksFontColor Property

public virtual String SeriesMarksFontColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


SeriesMarksFontName

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksFontName Property

public virtual String SeriesMarksFontName {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


SeriesMarksFontSize

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksFontSize Property

public virtual Int32 SeriesMarksFontSize {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


SeriesMarksGradientDirection

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksGradientDirection Property

public virtual String SeriesMarksGradientDirection {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


SeriesMarksGradientEndColor

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksGradientEndColor Property

public virtual String SeriesMarksGradientEndColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


SeriesMarksGradientMiddleColor

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksGradientMiddleColor Property

public virtual String SeriesMarksGradientMiddleColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


SeriesMarksGradientSigma

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksGradientSigma Property

public virtual Boolean SeriesMarksGradientSigma {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


SeriesMarksGradientSigmaFocus

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksGradientSigmaFocus Property

public virtual Single SeriesMarksGradientSigmaFocus {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


SeriesMarksGradientSigmaScale

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksGradientSigmaScale Property

public virtual Single SeriesMarksGradientSigmaScale {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


SeriesMarksGradientStartColor

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksGradientStartColor Property

public virtual String SeriesMarksGradientStartColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


SeriesMarksGradientVisible

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksGradientVisible Property

public virtual Boolean SeriesMarksGradientVisible {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


SeriesMarksTransparent

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksTransparent Property

public virtual Boolean SeriesMarksTransparent {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallApplyDark

Steema.TeeChart.Themes.ThemeProperties.WallApplyDark Property

public virtual Boolean WallApplyDark {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallGradientDirection

Steema.TeeChart.Themes.ThemeProperties.WallGradientDirection Property

public virtual String WallGradientDirection {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallGradientEndColor

Steema.TeeChart.Themes.ThemeProperties.WallGradientEndColor Property

public virtual String WallGradientEndColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallGradientMiddleColor

Steema.TeeChart.Themes.ThemeProperties.WallGradientMiddleColor Property

public virtual String WallGradientMiddleColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallGradientSigma

Steema.TeeChart.Themes.ThemeProperties.WallGradientSigma Property

public virtual Boolean WallGradientSigma {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallGradientSigmaFocus

Steema.TeeChart.Themes.ThemeProperties.WallGradientSigmaFocus Property

public virtual Single WallGradientSigmaFocus {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallGradientSigmaScale

Steema.TeeChart.Themes.ThemeProperties.WallGradientSigmaScale Property

public virtual Single WallGradientSigmaScale {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallGradientStartColor

Steema.TeeChart.Themes.ThemeProperties.WallGradientStartColor Property

public virtual String WallGradientStartColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallGradientVisible

Steema.TeeChart.Themes.ThemeProperties.WallGradientVisible Property

public virtual Boolean WallGradientVisible {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallPenColor

Steema.TeeChart.Themes.ThemeProperties.WallPenColor Property

public virtual String WallPenColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallPenStyle

Steema.TeeChart.Themes.ThemeProperties.WallPenStyle Property

public virtual String WallPenStyle {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallPenVisible

Steema.TeeChart.Themes.ThemeProperties.WallPenVisible Property

public virtual Boolean WallPenVisible {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallPenWidth

Steema.TeeChart.Themes.ThemeProperties.WallPenWidth Property

public virtual Int32 WallPenWidth {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallsBackColor

Steema.TeeChart.Themes.ThemeProperties.WallsBackColor Property

public virtual String WallsBackColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallsBackGradientDirection

Steema.TeeChart.Themes.ThemeProperties.WallsBackGradientDirection Property

public virtual String WallsBackGradientDirection {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallsBackGradientEndColor

Steema.TeeChart.Themes.ThemeProperties.WallsBackGradientEndColor Property

public virtual String WallsBackGradientEndColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallsBackGradientMiddleColor

Steema.TeeChart.Themes.ThemeProperties.WallsBackGradientMiddleColor Property

public virtual String WallsBackGradientMiddleColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallsBackGradientSigma

Steema.TeeChart.Themes.ThemeProperties.WallsBackGradientSigma Property

public virtual Boolean WallsBackGradientSigma {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallsBackGradientSigmaFocus

Steema.TeeChart.Themes.ThemeProperties.WallsBackGradientSigmaFocus Property

public virtual Single WallsBackGradientSigmaFocus {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallsBackGradientSigmaScale

Steema.TeeChart.Themes.ThemeProperties.WallsBackGradientSigmaScale Property

public virtual Single WallsBackGradientSigmaScale {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallsBackGradientStartColor

Steema.TeeChart.Themes.ThemeProperties.WallsBackGradientStartColor Property

public virtual String WallsBackGradientStartColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallsBackGradientVisible

Steema.TeeChart.Themes.ThemeProperties.WallsBackGradientVisible Property

public virtual Boolean WallsBackGradientVisible {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallsBackTransparent

Steema.TeeChart.Themes.ThemeProperties.WallsBackTransparent Property

public virtual Boolean WallsBackTransparent {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallsBottomColor

Steema.TeeChart.Themes.ThemeProperties.WallsBottomColor Property

public virtual String WallsBottomColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallSize

Steema.TeeChart.Themes.ThemeProperties.WallSize Property

public virtual Int32 WallSize {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallsLeftColor

Steema.TeeChart.Themes.ThemeProperties.WallsLeftColor Property

public virtual String WallsLeftColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


WallsRightColor

Steema.TeeChart.Themes.ThemeProperties.WallsRightColor Property

public virtual String WallsRightColor {get; set;}

See Also

ThemeProperties Class | ThemeProperties Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.WebTheme

Steema.TeeChart.Themes.WebTheme Class

Summary description for WebTheme.

For a list of all members of this type, see WebTheme Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
Steema.TeeChart.Themes.TeeChartTheme
public class WebTheme : TeeChartTheme

Requirements

Namespace: Steema.TeeChart.Themes Namespace

Assembly: TeeChart.Android.dll

See Also

WebTheme members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.WebThemeMembers

Steema.TeeChart.Themes.WebTheme all Members

WebTheme overview

Constructors

Constructor Overloaded

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

WebTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.WebTheme Constructor

Overload List

public WebTheme()
public WebTheme(Steema.TeeChart.Chart)

See Also

WebTheme Class | WebTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.WebTheme Constructor

public WebTheme(Chart c)

See Also

WebTheme Constructor Overload List | WebTheme Class | WebTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.WebTheme Constructor

public WebTheme()

See Also

WebTheme Constructor Overload List | WebTheme Class | WebTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.WebThemeMethods

Steema.TeeChart.Themes.WebTheme Methods

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

See Also

WebTheme Class | Steema.TeeChart.Themes Namespace


ToString

Steema.TeeChart.Themes.WebTheme.ToString Method

public override String ToString()

See Also

WebTheme Class | WebTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.WebThemeProperties

Steema.TeeChart.Themes.WebTheme Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

WebTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.XPTheme

Steema.TeeChart.Themes.XPTheme Class

Summary description for XPTheme.

For a list of all members of this type, see XPTheme Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
Steema.TeeChart.Themes.TeeChartTheme
Steema.TeeChart.Themes.BusinessTheme
public class XPTheme : BusinessTheme

Requirements

Namespace: Steema.TeeChart.Themes Namespace

Assembly: TeeChart.Android.dll

See Also

XPTheme members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.XPThemeMembers

Steema.TeeChart.Themes.XPTheme all Members

XPTheme overview

Constructors

Constructor Overloaded

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

XPTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.XPTheme Constructor

Overload List

public XPTheme()
public XPTheme(Steema.TeeChart.Chart)

See Also

XPTheme Class | XPTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.XPTheme Constructor

public XPTheme(Chart c)

See Also

XPTheme Constructor Overload List | XPTheme Class | XPTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.XPTheme Constructor

public XPTheme()

See Also

XPTheme Constructor Overload List | XPTheme Class | XPTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.XPThemeMethods

Steema.TeeChart.Themes.XPTheme Methods

Public Methods

Apply (inherited from CustomTheme) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString |

See Also

XPTheme Class | Steema.TeeChart.Themes Namespace


ToString

Steema.TeeChart.Themes.XPTheme.ToString Method

public override String ToString()

See Also

XPTheme Class | XPTheme Members | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Themes.XPThemeProperties

Steema.TeeChart.Themes.XPTheme Properties

Public Properties

Chart (inherited from TeeBase) | Chart associated with this object
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

XPTheme Class | Steema.TeeChart.Themes Namespace


Steema.TeeChart.Tools

Steema.TeeChart.Tools Namespace

Namespace hierarchy

Public Classes

ToolsCollection | Collection of Tool components.
MarkersCollection | Collection of Marker Tool components.
Tool | Base Tool class.
Annotation | Annotation tool.
Marker | Marker tool.
ToolSeries | Base abstract class for Tool components with a Series property.
ToolAxis | Base abstract class for Tool components with an Axis property.
BeforeDrawAxesEventArgs | Internal use. Tool support EventArgs
BeforeDrawSeriesEventArgs | Internal use. Tool support EventArgs
AfterDrawSeriesEventsArgs | Internal use. Tool support EventArgs
BeforeDrawEventArgs | Internal use. Tool support EventArgs
AfterDrawEventArgs | Internal use. Tool support EventArgs
AnnotationCallout
AxisBreak | Axis Breaks tool.
AxisBreaks | Collection of AxisBreak
AxisBreaksTool | Axis Breaks tool.
ColorBand | Color band tool, use it to display a coloured rectangle (band) at the specified axis and position.
ColorLine | Color Line tool. To draw custom lines at a axis value.
DataTableFilterSeriesEventArgs | Event args to enable filtering of series in the DataTable.
DataTableEventArgs | Event args to enable modification of text in the DataTable.
TableLegend | Legend shape.
DataTableTool
ExtraLegend | ExtraLegend tool.
FibonacciTool | Fibonacci fans and arcs financial tool. Tool supports Fibonacci arcs and fans. Fibonacci arcs are charting technique consisting of three curved lines that are drawn for the purpose of anticipating key support and resistance levels, and areas of ranging. Fibonacci arcs are created by first drawing an invisible trendline between two points (usually the high and low in a given period), and then by drawing three curves that intersect this trendline at the key Fibonacci levels of 38.2%, 50% and 61.8%. Fibonacci fans are charting technique consisting of three diagonal lines that use Fibonacci ratios to help identify key levels of support and resistance. Fibonacci fans are created by first drawing a trendline through two points (usually the high and low in a given period), and then by dividing the vertical distance between the two points by the key Fibonacci ratios of 38.2%, 50% and 61.8%. The result of these divisions each represent a point within the vertical distance. The three 'fan' lines are then created by drawing a line from the leftmost point to each of the three representing a Fibonacci ratio.
FibonacciItem | Individual Fibonacci level properties.
FibonacciLevels | Collection of all arcs.
GridBand | Grid Band tool, use it to display a coloured rectangles (bands) at the grid lines of the specified axis and position.
GridTranspose | Transpose Grid 3D.
LegendPalette
PageNumber | PageNumber annotation tool.
SeriesBandTool | Series-Band tool. Use it to display a band between two (line) series. created 2003-12-14 by mkaul@leuze.de
SeriesRegionTool | Series region Tool. It colors bounded area under the (series) curve.
SeriesStats | Calculates basic series statistics.
SeriesTranspose | Transpose multiple series (swap rows and columns).
SubChartTool | Annotation tool.
InnerChart
SubChart
ChartCollection | Collection of Chart components.

Public Enumerations

AnnotationPositions | Describes the possible values of the Position property.
AxisBreakStyle | Describes the possible values of the AxisBreaks.Style property.
FibonacciStyle | Defines style for Levels
LegendPaletteAxis |

Public Delegates

ColorLineToolOnDragEventHandler | ColorLine tool drag event handler
DataTableFilterSeriesEventHandler | DataTable tool's FilterSeries event handler. Suitable for filtering series.
DataTableEventHandler | DataTable tool event handler. Suitable for modifying item texts.

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll


Steema.TeeChart.Tools Hierarchy

System.Object

Java.Lang.Object

Android.Views.View

Android.Views.ViewGroup

Android.Widget.FrameLayout

Steema.TeeChart.TChart

Steema.TeeChart.Tools.InnerChart

Steema.TeeChart.Drawing.TeeBase

Steema.TeeChart.Drawing.Shape

Steema.TeeChart.Tools.TableLegend

Steema.TeeChart.Styles.SeriesPointer

Steema.TeeChart.Styles.Callout

Steema.TeeChart.Tools.AnnotationCallout

Steema.TeeChart.Tools.Tool

Steema.TeeChart.Tools.Annotation

Steema.TeeChart.Tools.Marker

Steema.TeeChart.Tools.PageNumber

Steema.TeeChart.Tools.DataTableTool

Steema.TeeChart.Tools.GridTranspose

Steema.TeeChart.Tools.SeriesTranspose

Steema.TeeChart.Tools.SubChartTool

Steema.TeeChart.Tools.ToolAxis

Steema.TeeChart.Tools.AxisBreaksTool

Steema.TeeChart.Tools.ColorBand

Steema.TeeChart.Tools.ColorLine

Steema.TeeChart.Tools.GridBand

Steema.TeeChart.Tools.ToolSeries

Steema.TeeChart.Tools.ExtraLegend

Steema.TeeChart.Tools.FibonacciTool

Steema.TeeChart.Tools.LegendPalette

Steema.TeeChart.Tools.SeriesBandTool

Steema.TeeChart.Tools.SeriesRegionTool

Steema.TeeChart.Tools.SeriesStats

Steema.TeeChart.Tools.AxisBreak

Steema.TeeChart.Tools.FibonacciTool.FibonacciItem

Steema.TeeChart.Tools.SubChart

System.Collections.CollectionBase

Steema.TeeChart.Tools.AxisBreaks

Steema.TeeChart.Tools.ChartCollection

Steema.TeeChart.Tools.FibonacciTool.FibonacciLevels

Steema.TeeChart.Tools.ToolsCollection

Steema.TeeChart.Tools.MarkersCollection

System.EventArgs

Steema.TeeChart.Tools.AfterDrawEventArgs

Steema.TeeChart.Tools.AfterDrawSeriesEventsArgs

Steema.TeeChart.Tools.BeforeDrawAxesEventArgs

Steema.TeeChart.Tools.BeforeDrawEventArgs

Steema.TeeChart.Tools.BeforeDrawSeriesEventArgs

Steema.TeeChart.Tools.DataTableEventArgs

Steema.TeeChart.Tools.DataTableFilterSeriesEventArgs

See Also

SteemaTeeChartTools Namespace


Steema.TeeChart.Tools.AfterDrawEventArgs

Steema.TeeChart.Tools.AfterDrawEventArgs Class

Internal use. Tool support EventArgs

For a list of all members of this type, see AfterDrawEventArgs Members

System.Object
System.EventArgs
public class AfterDrawEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

AfterDrawEventArgs members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AfterDrawEventArgsMembers

Steema.TeeChart.Tools.AfterDrawEventArgs all Members

AfterDrawEventArgs overview

Constructors

Constructor

See Also

AfterDrawEventArgs Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AfterDrawEventArgs Constructor

public AfterDrawEventArgs()

See Also

AfterDrawEventArgs Class | AfterDrawEventArgs Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AfterDrawSeriesEventsArgs

Steema.TeeChart.Tools.AfterDrawSeriesEventsArgs Class

Internal use. Tool support EventArgs

For a list of all members of this type, see AfterDrawSeriesEventsArgs Members

System.Object
System.EventArgs
public class AfterDrawSeriesEventsArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

AfterDrawSeriesEventsArgs members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AfterDrawSeriesEventsArgsMembers

Steema.TeeChart.Tools.AfterDrawSeriesEventsArgs all Members

AfterDrawSeriesEventsArgs overview

Constructors

Constructor

See Also

AfterDrawSeriesEventsArgs Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AfterDrawSeriesEventsArgs Constructor

public AfterDrawSeriesEventsArgs()

See Also

AfterDrawSeriesEventsArgs Class | AfterDrawSeriesEventsArgs Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.Annotation

Steema.TeeChart.Tools.Annotation Class

Annotation tool.

For a list of all members of this type, see Annotation Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
public class Annotation : Tool , ICloneable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

Annotation members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AnnotationMembers

Steema.TeeChart.Tools.Annotation all Members

Annotation overview

Constructors

Constructor Overloaded

Public Methods

Clone (inherited from Tool) |
EditorKey | The method passed to the KeyDown event by default.
EndEdit | Stops the Annotation from further editing.
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
StartEdit | Puts the Annotation into edit mode.
ToString (inherited from Tool) |

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
AllowEdit | Allows the Text of the Tool to be edited.
AutoSize | Set to true to permit custom sizing of TextShape.
Bounds | The rectangular bounds of the annotation tool.
Callout |
Chart (inherited from TeeBase) | Chart associated with this object
ClipText |
Cursor |
Description | Gets descriptive text.
Height | Sets a custom width.
Left | Sets horizontal displacement in pixels of text box from Chart's left edge.
Position | Defines a default position for the Annotation Tool text box and text.
PositionUnits | Defines Annotation Position units (pixels or percentage).
Shape | Sets characteristics of the Annotation Tool text and text box Shape.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text | Defines the text for the Annotation Tool.
TextAlign |
Top | Sets vertical displacement in pixels of text box from Chart's top edge.
Width | Sets a custom width.

See Also

Annotation Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.Annotation Constructor

Overload List

public Annotation()
public Annotation(Steema.TeeChart.Chart)

See Also

Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.Annotation Constructor

public Annotation(Chart c)

See Also

Annotation Constructor Overload List | Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.Annotation Constructor

public Annotation()

See Also

Annotation Constructor Overload List | Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AnnotationMethods

Steema.TeeChart.Tools.Annotation Methods

Public Methods

Clone (inherited from Tool) |
EditorKey | The method passed to the KeyDown event by default.
EndEdit | Stops the Annotation from further editing.
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
StartEdit | Puts the Annotation into edit mode.
ToString (inherited from Tool) |

See Also

Annotation Class | Steema.TeeChart.Tools Namespace


EditorKey

Steema.TeeChart.Tools.Annotation.EditorKey Method

The method passed to the KeyDown event by default.
public Void EditorKey(Object sender,
     KeyEvent e)

See Also

Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


EndEdit

Steema.TeeChart.Tools.Annotation.EndEdit Method

Stops the Annotation from further editing.
public Void EndEdit()

See Also

Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


StartEdit

Steema.TeeChart.Tools.Annotation.StartEdit Method

Puts the Annotation into edit mode.
public Void StartEdit()

See Also

Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AnnotationProperties

Steema.TeeChart.Tools.Annotation Properties

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
AllowEdit | Allows the Text of the Tool to be edited.
AutoSize | Set to true to permit custom sizing of TextShape.
Bounds | The rectangular bounds of the annotation tool.
Callout |
Chart (inherited from TeeBase) | Chart associated with this object
ClipText |
Cursor |
Description | Gets descriptive text.
Height | Sets a custom width.
Left | Sets horizontal displacement in pixels of text box from Chart's left edge.
Position | Defines a default position for the Annotation Tool text box and text.
PositionUnits | Defines Annotation Position units (pixels or percentage).
Shape | Sets characteristics of the Annotation Tool text and text box Shape.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text | Defines the text for the Annotation Tool.
TextAlign |
Top | Sets vertical displacement in pixels of text box from Chart's top edge.
Width | Sets a custom width.

See Also

Annotation Class | Steema.TeeChart.Tools Namespace


AllowEdit

Steema.TeeChart.Tools.Annotation.AllowEdit Property

Allows the Text of the Tool to be edited.
public Boolean AllowEdit {get; set;}

See Also

Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


AutoSize

Steema.TeeChart.Tools.Annotation.AutoSize Property

Set to true to permit custom sizing of TextShape.
public Boolean AutoSize {get; set;}

See Also

Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


Bounds

Steema.TeeChart.Tools.Annotation.Bounds Property

The rectangular bounds of the annotation tool.
public Rectangle Bounds {get; set;}

See Also

Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


Callout

Steema.TeeChart.Tools.Annotation.Callout Property

public AnnotationCallout Callout {get;}

See Also

Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


ClipText

Steema.TeeChart.Tools.Annotation.ClipText Property

public Boolean ClipText {get; set;}

See Also

Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


Cursor

Steema.TeeChart.Tools.Annotation.Cursor Property

public Cursor Cursor {get; set;}

See Also

Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


Description

Steema.TeeChart.Tools.Annotation.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


Height

Steema.TeeChart.Tools.Annotation.Height Property

Sets a custom width.
public Int32 Height {get; set;}

See Also

Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


Left

Steema.TeeChart.Tools.Annotation.Left Property

Sets horizontal displacement in pixels of text box from Chart's left edge.
public Int32 Left {get; set;}

See Also

Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


Position

Steema.TeeChart.Tools.Annotation.Position Property

Defines a default position for the Annotation Tool text box and text.
public AnnotationPositions Position {get; set;}

See Also

Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


PositionUnits

Steema.TeeChart.Tools.Annotation.PositionUnits Property

Defines Annotation Position units (pixels or percentage).
public PositionUnits PositionUnits {get; set;}

See Also

Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


Shape

Steema.TeeChart.Tools.Annotation.Shape Property

Sets characteristics of the Annotation Tool text and text box Shape.
public TextShapePosition Shape {get;}

See Also

Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


Summary

Steema.TeeChart.Tools.Annotation.Summary Property

Gets detailed descriptive text.
public override String Summary {get;}

See Also

Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


Text

Steema.TeeChart.Tools.Annotation.Text Property

Defines the text for the Annotation Tool.
public String Text {get; set;}

See Also

Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


TextAlign

Steema.TeeChart.Tools.Annotation.TextAlign Property

public Align TextAlign {get; set;}

See Also

Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


Top

Steema.TeeChart.Tools.Annotation.Top Property

Sets vertical displacement in pixels of text box from Chart's top edge.
public Int32 Top {get; set;}

See Also

Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


Width

Steema.TeeChart.Tools.Annotation.Width Property

Sets a custom width.
public Int32 Width {get; set;}

See Also

Annotation Class | Annotation Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AnnotationCallout

Steema.TeeChart.Tools.AnnotationCallout Class

For a list of all members of this type, see AnnotationCallout Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.SeriesPointer
Steema.TeeChart.Styles.Callout
public class AnnotationCallout : Callout

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

AnnotationCallout members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AnnotationCalloutMembers

Steema.TeeChart.Tools.AnnotationCallout all Members

AnnotationCallout overview

Constructors

Constructor

Public Methods

Clone (inherited from SeriesPointer) |
Draw (inherited from SeriesPointer) | Internal use. Draw Pointer
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

Public Properties

Arrow (inherited from Callout) |
ArrowHead (inherited from Callout) |
ArrowHeadDirection (inherited from Callout) |
ArrowHeadSize (inherited from Callout) |
Brush (inherited from SeriesPointer) | Brush used to fill Series Pointers.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from SeriesPointer) | Sets the pointer color.
Dark3D (inherited from SeriesPointer) | Fills pointer sides in 3D mode with darker color.
Distance (inherited from Callout) |
Draw3D (inherited from SeriesPointer) | Draws pointer in 3D mode.
EndZ (inherited from SeriesPointer) |
Gradient (inherited from SeriesPointer) | Configures Gradient filling attributes.
HorizSize (inherited from SeriesPointer) | Horizontal size of pointer in pixels.
InflateMargins (inherited from SeriesPointer) | Expands axes to fit pointers.
MiddleZ (inherited from SeriesPointer) |
Pen (inherited from SeriesPointer) | Pen used to draw a frame around Series Pointers.
Series (inherited from SeriesPointer) |
StartZ (inherited from SeriesPointer) |
Style (inherited from SeriesPointer) | Sets the Pointer style.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency (inherited from SeriesPointer) | Sets Percent of semiglass effect.
VertSize (inherited from SeriesPointer) | Sets Horizontal size of pointer in pixels.
Visible (inherited from SeriesPointer) | Shows or hides the pointer.
XPosition |
YPosition |
ZPosition |

See Also

AnnotationCallout Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AnnotationCallout Constructor

public AnnotationCallout(Series s)

See Also

AnnotationCallout Class | AnnotationCallout Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AnnotationCalloutMethods

Steema.TeeChart.Tools.AnnotationCallout Methods

Public Methods

Clone (inherited from SeriesPointer) |
Draw (inherited from SeriesPointer) | Internal use. Draw Pointer
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.

See Also

AnnotationCallout Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AnnotationCalloutProperties

Steema.TeeChart.Tools.AnnotationCallout Properties

Public Properties

Arrow (inherited from Callout) |
ArrowHead (inherited from Callout) |
ArrowHeadDirection (inherited from Callout) |
ArrowHeadSize (inherited from Callout) |
Brush (inherited from SeriesPointer) | Brush used to fill Series Pointers.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from SeriesPointer) | Sets the pointer color.
Dark3D (inherited from SeriesPointer) | Fills pointer sides in 3D mode with darker color.
Distance (inherited from Callout) |
Draw3D (inherited from SeriesPointer) | Draws pointer in 3D mode.
EndZ (inherited from SeriesPointer) |
Gradient (inherited from SeriesPointer) | Configures Gradient filling attributes.
HorizSize (inherited from SeriesPointer) | Horizontal size of pointer in pixels.
InflateMargins (inherited from SeriesPointer) | Expands axes to fit pointers.
MiddleZ (inherited from SeriesPointer) |
Pen (inherited from SeriesPointer) | Pen used to draw a frame around Series Pointers.
Series (inherited from SeriesPointer) |
StartZ (inherited from SeriesPointer) |
Style (inherited from SeriesPointer) | Sets the Pointer style.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency (inherited from SeriesPointer) | Sets Percent of semiglass effect.
VertSize (inherited from SeriesPointer) | Sets Horizontal size of pointer in pixels.
Visible (inherited from SeriesPointer) | Shows or hides the pointer.
XPosition |
YPosition |
ZPosition |

See Also

AnnotationCallout Class | Steema.TeeChart.Tools Namespace


XPosition

Steema.TeeChart.Tools.AnnotationCallout.XPosition Property

public Int32 XPosition {get; set;}

See Also

AnnotationCallout Class | AnnotationCallout Members | Steema.TeeChart.Tools Namespace


YPosition

Steema.TeeChart.Tools.AnnotationCallout.YPosition Property

public Int32 YPosition {get; set;}

See Also

AnnotationCallout Class | AnnotationCallout Members | Steema.TeeChart.Tools Namespace


ZPosition

Steema.TeeChart.Tools.AnnotationCallout.ZPosition Property

public Int32 ZPosition {get; set;}

See Also

AnnotationCallout Class | AnnotationCallout Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AnnotationPositions

Steema.TeeChart.Tools.AnnotationPositions Enum

Describes the possible values of the Position property.
[Serializable]
public sealed enum AnnotationPositions : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
LeftTop | Draws the Annotation Tool in the top left of the Chart Panel.
LeftBottom | Draws the Annotation Tool in the bottom left of the Chart Panel.
RightTop | Draws the Annotation Tool in the top right of the Chart Panel.
RightBottom | Draws the Annotation Tool in the bottom right of the Chart Panel.

See Also

Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AxisBreak

Steema.TeeChart.Tools.AxisBreak Class

Axis Breaks tool.

For a list of all members of this type, see AxisBreak Members

System.Object
public class AxisBreak : Object

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

AxisBreak members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AxisBreakMembers

Steema.TeeChart.Tools.AxisBreak all Members

AxisBreak overview

Constructors

Constructor Overloaded

Public Properties

Enabled | Enables or disables the axis break.
EndValue | Sets the End value of the Axis break.
StartValue | Sets the Start value of the Axis break.
Style | Sets the style of the break.

See Also

AxisBreak Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AxisBreak Constructor

Overload List

public AxisBreak()
public AxisBreak(Steema.TeeChart.Tools.AxisBreaksTool)

See Also

AxisBreak Class | AxisBreak Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AxisBreak Constructor

public AxisBreak(AxisBreaksTool owner)

See Also

AxisBreak Constructor Overload List | AxisBreak Class | AxisBreak Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AxisBreak Constructor

public AxisBreak()

See Also

AxisBreak Constructor Overload List | AxisBreak Class | AxisBreak Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AxisBreakProperties

Steema.TeeChart.Tools.AxisBreak Properties

Public Properties

Enabled | Enables or disables the axis break.
EndValue | Sets the End value of the Axis break.
StartValue | Sets the Start value of the Axis break.
Style | Sets the style of the break.

See Also

AxisBreak Class | Steema.TeeChart.Tools Namespace


Enabled

Steema.TeeChart.Tools.AxisBreak.Enabled Property

Enables or disables the axis break.
public Boolean Enabled {get; set;}

See Also

AxisBreak Class | AxisBreak Members | Steema.TeeChart.Tools Namespace


EndValue

Steema.TeeChart.Tools.AxisBreak.EndValue Property

Sets the End value of the Axis break.
public Double EndValue {get; set;}

See Also

AxisBreak Class | AxisBreak Members | Steema.TeeChart.Tools Namespace


StartValue

Steema.TeeChart.Tools.AxisBreak.StartValue Property

Sets the Start value of the Axis break.
public Double StartValue {get; set;}

See Also

AxisBreak Class | AxisBreak Members | Steema.TeeChart.Tools Namespace


Style

Steema.TeeChart.Tools.AxisBreak.Style Property

Sets the style of the break.
public AxisBreakStyle Style {get; set;}

See Also

AxisBreak Class | AxisBreak Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AxisBreaks

Steema.TeeChart.Tools.AxisBreaks Class

Collection of AxisBreak

For a list of all members of this type, see AxisBreaks Members

System.Object
System.Collections.CollectionBase
public class AxisBreaks : CollectionBase , IList, ICollection
, IEnumerable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

AxisBreaks members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AxisBreaksMembers

Steema.TeeChart.Tools.AxisBreaks all Members

AxisBreaks overview

Constructors

Constructor

Public Methods

Add
Clear
IndexOf
Remove

Public Properties

Item

See Also

AxisBreaks Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AxisBreaks Constructor

public AxisBreaks()

See Also

AxisBreaks Class | AxisBreaks Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AxisBreaksMethods

Steema.TeeChart.Tools.AxisBreaks Methods

Public Methods

Add
Clear
IndexOf
Remove

See Also

AxisBreaks Class | Steema.TeeChart.Tools Namespace


Add

Steema.TeeChart.Tools.AxisBreaks.Add Method

public Int32 Add(AxisBreak l)

See Also

AxisBreaks Class | AxisBreaks Members | Steema.TeeChart.Tools Namespace


Clear

Steema.TeeChart.Tools.AxisBreaks.Clear Method

public Void Clear()

See Also

AxisBreaks Class | AxisBreaks Members | Steema.TeeChart.Tools Namespace


IndexOf

Steema.TeeChart.Tools.AxisBreaks.IndexOf Method

public Int32 IndexOf(AxisBreak l)

See Also

AxisBreaks Class | AxisBreaks Members | Steema.TeeChart.Tools Namespace


Remove

Steema.TeeChart.Tools.AxisBreaks.Remove Method

public Void Remove(AxisBreak s)

See Also

AxisBreaks Class | AxisBreaks Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AxisBreaksProperties

Steema.TeeChart.Tools.AxisBreaks Properties

Public Properties

Item

See Also

AxisBreaks Class | Steema.TeeChart.Tools Namespace


Item

Steema.TeeChart.Tools.AxisBreaks.Item Property

public AxisBreak Item(Int32 index) {get;}

See Also

AxisBreaks Class | AxisBreaks Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AxisBreaksTool

Steema.TeeChart.Tools.AxisBreaksTool Class

Axis Breaks tool.

For a list of all members of this type, see AxisBreaksTool Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolAxis
public class AxisBreaksTool : ToolAxis , ICloneable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

AxisBreaksTool members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AxisBreaksToolMembers

Steema.TeeChart.Tools.AxisBreaksTool all Members

AxisBreaksTool overview

Constructors

Constructor Overloaded

Public Methods

AdjustCalcPosPoint |
AxisBreakDoAllowScroll |
BreakSizeUpTo |
Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Axis (inherited from ToolAxis) | Sets the axis to which a Tool will belong.
Breaks | List of breaks.
Brush | Element Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
Description | Gets descriptive text.
GapSize |
Pen | Specifies the pen used to draw the gap outline.
ScaleAdjustment | Default 0.0000001. This variable avoids jump/flicker when scrolling across Break boundaries by moving scroll to 'just' outside of Break zone when traversing Axis Min or Max. Adjust if your Axis scale requires different sensitivity.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

AxisBreaksTool Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AxisBreaksTool Constructor

Overload List

public AxisBreaksTool()
public AxisBreaksTool(Steema.TeeChart.Chart)

See Also

AxisBreaksTool Class | AxisBreaksTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AxisBreaksTool Constructor

public AxisBreaksTool(Chart c)

See Also

AxisBreaksTool Constructor Overload List | AxisBreaksTool Class | AxisBreaksTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AxisBreaksTool Constructor

public AxisBreaksTool()

See Also

AxisBreaksTool Constructor Overload List | AxisBreaksTool Class | AxisBreaksTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AxisBreaksToolMethods

Steema.TeeChart.Tools.AxisBreaksTool Methods

Public Methods

AdjustCalcPosPoint |
AxisBreakDoAllowScroll |
BreakSizeUpTo |
Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

See Also

AxisBreaksTool Class | Steema.TeeChart.Tools Namespace


AdjustCalcPosPoint

Steema.TeeChart.Tools.AxisBreaksTool.AdjustCalcPosPoint Method

public Double AdjustCalcPosPoint(Int32 pixelVal)

See Also

AxisBreaksTool Class | AxisBreaksTool Members | Steema.TeeChart.Tools Namespace


AxisBreakDoAllowScroll

Steema.TeeChart.Tools.AxisBreaksTool.AxisBreakDoAllowScroll Method

public Void AxisBreakDoAllowScroll(Axis a,
     ScrollModEventArgs e)

See Also

AxisBreaksTool Class | AxisBreaksTool Members | Steema.TeeChart.Tools Namespace


BreakSizeUpTo

Steema.TeeChart.Tools.AxisBreaksTool.BreakSizeUpTo Method

public Int32 BreakSizeUpTo(Double Value)

See Also

AxisBreaksTool Class | AxisBreaksTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AxisBreaksToolProperties

Steema.TeeChart.Tools.AxisBreaksTool Properties

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Axis (inherited from ToolAxis) | Sets the axis to which a Tool will belong.
Breaks | List of breaks.
Brush | Element Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
Description | Gets descriptive text.
GapSize |
Pen | Specifies the pen used to draw the gap outline.
ScaleAdjustment | Default 0.0000001. This variable avoids jump/flicker when scrolling across Break boundaries by moving scroll to 'just' outside of Break zone when traversing Axis Min or Max. Adjust if your Axis scale requires different sensitivity.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

AxisBreaksTool Class | Steema.TeeChart.Tools Namespace


Breaks

Steema.TeeChart.Tools.AxisBreaksTool.Breaks Property

List of breaks.
public AxisBreaks Breaks {get; set;}

See Also

AxisBreaksTool Class | AxisBreaksTool Members | Steema.TeeChart.Tools Namespace


Brush

Steema.TeeChart.Tools.AxisBreaksTool.Brush Property

Element Brush characteristics.
public ChartBrush Brush {get; set;}

See Also

AxisBreaksTool Class | AxisBreaksTool Members | Steema.TeeChart.Tools Namespace


Description

Steema.TeeChart.Tools.AxisBreaksTool.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

AxisBreaksTool Class | AxisBreaksTool Members | Steema.TeeChart.Tools Namespace


GapSize

Steema.TeeChart.Tools.AxisBreaksTool.GapSize Property

public Int32 GapSize {get; set;}

See Also

AxisBreaksTool Class | AxisBreaksTool Members | Steema.TeeChart.Tools Namespace


Pen

Steema.TeeChart.Tools.AxisBreaksTool.Pen Property

Specifies the pen used to draw the gap outline.
public ChartPen Pen {get; set;}

See Also

AxisBreaksTool Class | AxisBreaksTool Members | Steema.TeeChart.Tools Namespace


ScaleAdjustment

Steema.TeeChart.Tools.AxisBreaksTool.ScaleAdjustment Property

Default 0.0000001. This variable avoids jump/flicker when scrolling across Break boundaries by moving scroll to 'just' outside of Break zone when traversing Axis Min or Max. Adjust if your Axis scale requires different sensitivity.
public Double ScaleAdjustment {get; set;}

See Also

AxisBreaksTool Class | AxisBreaksTool Members | Steema.TeeChart.Tools Namespace


Summary

Steema.TeeChart.Tools.AxisBreaksTool.Summary Property

Gets detailed descriptive text.
public override String Summary {get;}

See Also

AxisBreaksTool Class | AxisBreaksTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.AxisBreakStyle

Steema.TeeChart.Tools.AxisBreakStyle Enum

Describes the possible values of the AxisBreaks.Style property.
[Serializable]
public sealed enum AxisBreakStyle : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
SmallZigZag | Draws the break as small Zig Zag.
ZigZag | Draws the break as Zig Zag.
Line | Draws the break as Line.
None | Draws the break as Transparent.

See Also

Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.BeforeDrawAxesEventArgs

Steema.TeeChart.Tools.BeforeDrawAxesEventArgs Class

Internal use. Tool support EventArgs

For a list of all members of this type, see BeforeDrawAxesEventArgs Members

System.Object
System.EventArgs
public class BeforeDrawAxesEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

BeforeDrawAxesEventArgs members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.BeforeDrawAxesEventArgsMembers

Steema.TeeChart.Tools.BeforeDrawAxesEventArgs all Members

BeforeDrawAxesEventArgs overview

Constructors

Constructor

See Also

BeforeDrawAxesEventArgs Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.BeforeDrawAxesEventArgs Constructor

public BeforeDrawAxesEventArgs()

See Also

BeforeDrawAxesEventArgs Class | BeforeDrawAxesEventArgs Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.BeforeDrawEventArgs

Steema.TeeChart.Tools.BeforeDrawEventArgs Class

Internal use. Tool support EventArgs

For a list of all members of this type, see BeforeDrawEventArgs Members

System.Object
System.EventArgs
public class BeforeDrawEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

BeforeDrawEventArgs members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.BeforeDrawEventArgsMembers

Steema.TeeChart.Tools.BeforeDrawEventArgs all Members

BeforeDrawEventArgs overview

Constructors

Constructor

See Also

BeforeDrawEventArgs Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.BeforeDrawEventArgs Constructor

public BeforeDrawEventArgs()

See Also

BeforeDrawEventArgs Class | BeforeDrawEventArgs Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.BeforeDrawSeriesEventArgs

Steema.TeeChart.Tools.BeforeDrawSeriesEventArgs Class

Internal use. Tool support EventArgs

For a list of all members of this type, see BeforeDrawSeriesEventArgs Members

System.Object
System.EventArgs
public class BeforeDrawSeriesEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

BeforeDrawSeriesEventArgs members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.BeforeDrawSeriesEventArgsMembers

Steema.TeeChart.Tools.BeforeDrawSeriesEventArgs all Members

BeforeDrawSeriesEventArgs overview

Constructors

Constructor

See Also

BeforeDrawSeriesEventArgs Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.BeforeDrawSeriesEventArgs Constructor

public BeforeDrawSeriesEventArgs()

See Also

BeforeDrawSeriesEventArgs Class | BeforeDrawSeriesEventArgs Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ChartCollection

Steema.TeeChart.Tools.ChartCollection Class

Collection of Chart components.

For a list of all members of this type, see ChartCollection Members

System.Object
System.Collections.CollectionBase
public sealed class ChartCollection : CollectionBase , IList, ICollection
, IEnumerable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

ChartCollection members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ChartCollectionMembers

Steema.TeeChart.Tools.ChartCollection all Members

ChartCollection overview

Constructors

Constructor

Public Methods

Add
AddChart
Insert
Remove

Public Properties

Item
Owner

See Also

ChartCollection Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ChartCollection Constructor

public ChartCollection(Tool tool)

See Also

ChartCollection Class | ChartCollection Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ChartCollectionMethods

Steema.TeeChart.Tools.ChartCollection Methods

Public Methods

Add
AddChart
Insert
Remove

See Also

ChartCollection Class | Steema.TeeChart.Tools Namespace


Add

Steema.TeeChart.Tools.ChartCollection.Add Method

public SubChart Add(SubChart c)

See Also

ChartCollection Class | ChartCollection Members | Steema.TeeChart.Tools Namespace


AddChart

Steema.TeeChart.Tools.ChartCollection.AddChart Method

public TChart AddChart(String name)

See Also

ChartCollection Class | ChartCollection Members | Steema.TeeChart.Tools Namespace


Insert

Steema.TeeChart.Tools.ChartCollection.Insert Method

public Void Insert(Int32 index,
     SubChart item)

See Also

ChartCollection Class | ChartCollection Members | Steema.TeeChart.Tools Namespace


Remove

Steema.TeeChart.Tools.ChartCollection.Remove Method

public Void Remove(SubChart item)

See Also

ChartCollection Class | ChartCollection Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ChartCollectionProperties

Steema.TeeChart.Tools.ChartCollection Properties

Public Properties

Item
Owner

See Also

ChartCollection Class | Steema.TeeChart.Tools Namespace


Item

Steema.TeeChart.Tools.ChartCollection.Item Property

public SubChart Item(Int32 index) {get; set;}

See Also

ChartCollection Class | ChartCollection Members | Steema.TeeChart.Tools Namespace


Owner

Steema.TeeChart.Tools.ChartCollection.Owner Property

public Tool Owner {get; set;}

See Also

ChartCollection Class | ChartCollection Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ColorBand

Steema.TeeChart.Tools.ColorBand Class

Color band tool, use it to display a coloured rectangle (band) at the specified axis and position.

For a list of all members of this type, see ColorBand Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolAxis
public class ColorBand : ToolAxis , ICloneable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

ColorBand members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ColorBandMembers

Steema.TeeChart.Tools.ColorBand all Members

ColorBand overview

Constructors

Constructor Overloaded

Public Methods

Clicked |
Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Axis (inherited from ToolAxis) | Sets the axis to which a Tool will belong.
Brush | Element Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
Color | Sets Band Color.
Description | Gets descriptive text.
DrawBehind | Draws the Colorband behind the series values when true.
End | Sets End Axis value of colorband.
EndLine | Contains formatting properties for the automatic line used to drag the end value of the ColorBand tool at runtime.
EndLinePen | Pen used to draw the ending line of the color band tool.
Gradient | Sets Band colour gradient.
Pen (inherited from ToolAxis) | Element Pen characteristics.
ResizeEnd | Gets or sets if the ColorBand tool allows mouse dragging of the edge corresponding to the end value.
ResizeStart | Gets or sets if the ColorBand tool allows mouse dragging of the edge corresponding to the start value.
Start | Sets Start Axis value of colorband.
StartLine | Contains formatting properties for the automatic line used to drag the start value of the ColorBand tool at runtime.
StartLinePen | Pen used to draw the starting line of the color band tool.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency | Sets the Transparency of ColorBand as percentage.

See Also

ColorBand Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ColorBand Constructor

Overload List

public ColorBand()
public ColorBand(Steema.TeeChart.Chart)

See Also

ColorBand Class | ColorBand Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ColorBand Constructor

public ColorBand(Chart c)

See Also

ColorBand Constructor Overload List | ColorBand Class | ColorBand Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ColorBand Constructor

public ColorBand()

See Also

ColorBand Constructor Overload List | ColorBand Class | ColorBand Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ColorBandMethods

Steema.TeeChart.Tools.ColorBand Methods

Public Methods

Clicked |
Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

See Also

ColorBand Class | Steema.TeeChart.Tools Namespace


Clicked

Steema.TeeChart.Tools.ColorBand.Clicked Method

public Boolean Clicked(Int32 X,
     Int32 Y)

See Also

ColorBand Class | ColorBand Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ColorBandProperties

Steema.TeeChart.Tools.ColorBand Properties

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Axis (inherited from ToolAxis) | Sets the axis to which a Tool will belong.
Brush | Element Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
Color | Sets Band Color.
Description | Gets descriptive text.
DrawBehind | Draws the Colorband behind the series values when true.
End | Sets End Axis value of colorband.
EndLine | Contains formatting properties for the automatic line used to drag the end value of the ColorBand tool at runtime.
EndLinePen | Pen used to draw the ending line of the color band tool.
Gradient | Sets Band colour gradient.
Pen (inherited from ToolAxis) | Element Pen characteristics.
ResizeEnd | Gets or sets if the ColorBand tool allows mouse dragging of the edge corresponding to the end value.
ResizeStart | Gets or sets if the ColorBand tool allows mouse dragging of the edge corresponding to the start value.
Start | Sets Start Axis value of colorband.
StartLine | Contains formatting properties for the automatic line used to drag the start value of the ColorBand tool at runtime.
StartLinePen | Pen used to draw the starting line of the color band tool.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency | Sets the Transparency of ColorBand as percentage.

See Also

ColorBand Class | Steema.TeeChart.Tools Namespace


Brush

Steema.TeeChart.Tools.ColorBand.Brush Property

Element Brush characteristics.
public ChartBrush Brush {get; set;}

See Also

ColorBand Class | ColorBand Members | Steema.TeeChart.Tools Namespace


Color

Steema.TeeChart.Tools.ColorBand.Color Property

Sets Band Color.
public Color Color {get; set;}

See Also

ColorBand Class | ColorBand Members | Steema.TeeChart.Tools Namespace


Description

Steema.TeeChart.Tools.ColorBand.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

ColorBand Class | ColorBand Members | Steema.TeeChart.Tools Namespace


DrawBehind

Steema.TeeChart.Tools.ColorBand.DrawBehind Property

Draws the Colorband behind the series values when true.
public Boolean DrawBehind {get; set;}

See Also

ColorBand Class | ColorBand Members | Steema.TeeChart.Tools Namespace


End

Steema.TeeChart.Tools.ColorBand.End Property

Sets End Axis value of colorband.
public Double End {get; set;}

See Also

ColorBand Class | ColorBand Members | Steema.TeeChart.Tools Namespace


EndLine

Steema.TeeChart.Tools.ColorBand.EndLine Property

Contains formatting properties for the automatic line used to drag the end value of the ColorBand tool at runtime.
public ColorLine EndLine {get; set;}

See Also

ColorBand Class | ColorBand Members | Steema.TeeChart.Tools Namespace


EndLinePen

Steema.TeeChart.Tools.ColorBand.EndLinePen Property

Pen used to draw the ending line of the color band tool.
public ChartPen EndLinePen {get;}

See Also

ColorBand Class | ColorBand Members | Steema.TeeChart.Tools Namespace


Gradient

Steema.TeeChart.Tools.ColorBand.Gradient Property

Sets Band colour gradient.
public Gradient Gradient {get;}

See Also

ColorBand Class | ColorBand Members | Steema.TeeChart.Tools Namespace


ResizeEnd

Steema.TeeChart.Tools.ColorBand.ResizeEnd Property

Gets or sets if the ColorBand tool allows mouse dragging of the edge corresponding to the end value.
public Boolean ResizeEnd {get; set;}

See Also

ColorBand Class | ColorBand Members | Steema.TeeChart.Tools Namespace


ResizeStart

Steema.TeeChart.Tools.ColorBand.ResizeStart Property

Gets or sets if the ColorBand tool allows mouse dragging of the edge corresponding to the start value.
public Boolean ResizeStart {get; set;}

See Also

ColorBand Class | ColorBand Members | Steema.TeeChart.Tools Namespace


Start

Steema.TeeChart.Tools.ColorBand.Start Property

Sets Start Axis value of colorband.
public Double Start {get; set;}

See Also

ColorBand Class | ColorBand Members | Steema.TeeChart.Tools Namespace


StartLine

Steema.TeeChart.Tools.ColorBand.StartLine Property

Contains formatting properties for the automatic line used to drag the start value of the ColorBand tool at runtime.
public ColorLine StartLine {get; set;}

See Also

ColorBand Class | ColorBand Members | Steema.TeeChart.Tools Namespace


StartLinePen

Steema.TeeChart.Tools.ColorBand.StartLinePen Property

Pen used to draw the starting line of the color band tool.
public ChartPen StartLinePen {get;}

See Also

ColorBand Class | ColorBand Members | Steema.TeeChart.Tools Namespace


Summary

Steema.TeeChart.Tools.ColorBand.Summary Property

Gets detailed descriptive text.
public override String Summary {get;}

See Also

ColorBand Class | ColorBand Members | Steema.TeeChart.Tools Namespace


Transparency

Steema.TeeChart.Tools.ColorBand.Transparency Property

Sets the Transparency of ColorBand as percentage.
public Int32 Transparency {get; set;}

See Also

ColorBand Class | ColorBand Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ColorLine

Steema.TeeChart.Tools.ColorLine Class

Color Line tool. To draw custom lines at a axis value.

For a list of all members of this type, see ColorLine Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolAxis
public class ColorLine : ToolAxis , ICloneable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

ColorLine members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ColorLineMembers

Steema.TeeChart.Tools.ColorLine all Members

ColorLine overview

Constructors

Constructor Overloaded

Public Events

DragLine
EndDragLine

Public Methods

Clicked |
Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
AllowDrag | Allows mousedrag of Line when true .
Axis (inherited from ToolAxis) | Sets the axis to which a Tool will belong.
Chart (inherited from TeeBase) | Chart associated with this object
ColorLineClickTolerance | Gets and sets pixel proximity tolerance for Clicks.
Description | Gets descriptive text.
DragRepaint | Repaints the Chart while moving the ColorLine when True.
Draw3D | Draws ColorLine in 3D when True.
DrawBehind | Draws the ColorLine behind the series values.
NoLimitDrag | Allows drag of ColorLine outside of the Chart rectangle.
OriginalCursor | Gets or sets the Cursor to which the ColorLine defaults when the mouse is not over it.
Pen (inherited from ToolAxis) | Element Pen characteristics.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Value | Determines Axis position where the ColorLine has to be drawn.

See Also

ColorLine Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ColorLine Constructor

Overload List

public ColorLine()
public ColorLine(Steema.TeeChart.Chart)

See Also

ColorLine Class | ColorLine Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ColorLine Constructor

public ColorLine(Chart c)

See Also

ColorLine Constructor Overload List | ColorLine Class | ColorLine Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ColorLine Constructor

public ColorLine()

See Also

ColorLine Constructor Overload List | ColorLine Class | ColorLine Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ColorLineEvents

Steema.TeeChart.Tools.ColorLine Events

Public Events

DragLine
EndDragLine

See Also

ColorLine Class | Steema.TeeChart.Tools Namespace


DragLine

Steema.TeeChart.Tools.ColorLine.DragLine Event

public EventHandler  DragLine

See Also

ColorLine Class | ColorLine Members | Steema.TeeChart.Tools Namespace


EndDragLine

Steema.TeeChart.Tools.ColorLine.EndDragLine Event

public ColorLineToolOnDragEventHandler  EndDragLine

See Also

ColorLine Class | ColorLine Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ColorLineMethods

Steema.TeeChart.Tools.ColorLine Methods

Public Methods

Clicked |
Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

See Also

ColorLine Class | Steema.TeeChart.Tools Namespace


Clicked

Steema.TeeChart.Tools.ColorLine.Clicked Method

Overload List

public Boolean Clicked(System.Drawing.Point)
public Boolean Clicked(System.Int32, System.Int32)

See Also

ColorLine Class | ColorLine Members | Steema.TeeChart.Tools Namespace


Clicked

Steema.TeeChart.Tools.ColorLine.Clicked Method

public Boolean Clicked(Int32 x,
     Int32 y)

See Also

Clicked Overload List | ColorLine Class | ColorLine Members | Steema.TeeChart.Tools Namespace


Clicked

Steema.TeeChart.Tools.ColorLine.Clicked Method

public Boolean Clicked(Point point)

See Also

Clicked Overload List | ColorLine Class | ColorLine Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ColorLineProperties

Steema.TeeChart.Tools.ColorLine Properties

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
AllowDrag | Allows mousedrag of Line when true .
Axis (inherited from ToolAxis) | Sets the axis to which a Tool will belong.
Chart (inherited from TeeBase) | Chart associated with this object
ColorLineClickTolerance | Gets and sets pixel proximity tolerance for Clicks.
Description | Gets descriptive text.
DragRepaint | Repaints the Chart while moving the ColorLine when True.
Draw3D | Draws ColorLine in 3D when True.
DrawBehind | Draws the ColorLine behind the series values.
NoLimitDrag | Allows drag of ColorLine outside of the Chart rectangle.
OriginalCursor | Gets or sets the Cursor to which the ColorLine defaults when the mouse is not over it.
Pen (inherited from ToolAxis) | Element Pen characteristics.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Value | Determines Axis position where the ColorLine has to be drawn.

See Also

ColorLine Class | Steema.TeeChart.Tools Namespace


AllowDrag

Steema.TeeChart.Tools.ColorLine.AllowDrag Property

Allows mousedrag of Line when true .
public Boolean AllowDrag {get; set;}

See Also

ColorLine Class | ColorLine Members | Steema.TeeChart.Tools Namespace


ColorLineClickTolerance

Steema.TeeChart.Tools.ColorLine.ColorLineClickTolerance Property

Gets and sets pixel proximity tolerance for Clicks.
public Int32 ColorLineClickTolerance {get; set;}

See Also

ColorLine Class | ColorLine Members | Steema.TeeChart.Tools Namespace


Description

Steema.TeeChart.Tools.ColorLine.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

ColorLine Class | ColorLine Members | Steema.TeeChart.Tools Namespace


DragRepaint

Steema.TeeChart.Tools.ColorLine.DragRepaint Property

Repaints the Chart while moving the ColorLine when True.
public Boolean DragRepaint {get; set;}

See Also

ColorLine Class | ColorLine Members | Steema.TeeChart.Tools Namespace


Draw3D

Steema.TeeChart.Tools.ColorLine.Draw3D Property

Draws ColorLine in 3D when True.
public Boolean Draw3D {get; set;}

See Also

ColorLine Class | ColorLine Members | Steema.TeeChart.Tools Namespace


DrawBehind

Steema.TeeChart.Tools.ColorLine.DrawBehind Property

Draws the ColorLine behind the series values.
public Boolean DrawBehind {get; set;}

See Also

ColorLine Class | ColorLine Members | Steema.TeeChart.Tools Namespace


NoLimitDrag

Steema.TeeChart.Tools.ColorLine.NoLimitDrag Property

Allows drag of ColorLine outside of the Chart rectangle.
public Boolean NoLimitDrag {get; set;}

See Also

ColorLine Class | ColorLine Members | Steema.TeeChart.Tools Namespace


OriginalCursor

Steema.TeeChart.Tools.ColorLine.OriginalCursor Property

Gets or sets the Cursor to which the ColorLine defaults when the mouse is not over it.
public Cursor OriginalCursor {get; set;}

See Also

ColorLine Class | ColorLine Members | Steema.TeeChart.Tools Namespace


Summary

Steema.TeeChart.Tools.ColorLine.Summary Property

Gets detailed descriptive text.
public override String Summary {get;}

See Also

ColorLine Class | ColorLine Members | Steema.TeeChart.Tools Namespace


Value

Steema.TeeChart.Tools.ColorLine.Value Property

Determines Axis position where the ColorLine has to be drawn.
public Double Value {get; set;}

See Also

ColorLine Class | ColorLine Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ColorLineToolOnDragEventHandler

Steema.TeeChart.Tools.ColorLineToolOnDragEventHandler Delegate

ColorLine tool drag event handler
public delegate ColorLineToolOnDragEventHandler (Object sender)

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.DataTableEventArgs

Steema.TeeChart.Tools.DataTableEventArgs Class

Event args to enable modification of text in the DataTable.

For a list of all members of this type, see DataTableEventArgs Members

System.Object
System.EventArgs
public class DataTableEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

DataTableEventArgs members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.DataTableEventArgsMembers

Steema.TeeChart.Tools.DataTableEventArgs all Members

DataTableEventArgs overview

Constructors

Constructor

Public Properties

Series
Text
ValueIndex

See Also

DataTableEventArgs Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.DataTableEventArgs Constructor

public DataTableEventArgs(String text,
     Series series,
     Int32 valueIndex)

See Also

DataTableEventArgs Class | DataTableEventArgs Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.DataTableEventArgsProperties

Steema.TeeChart.Tools.DataTableEventArgs Properties

Public Properties

Series
Text
ValueIndex

See Also

DataTableEventArgs Class | Steema.TeeChart.Tools Namespace


Series

Steema.TeeChart.Tools.DataTableEventArgs.Series Property

public Series Series {get;}

See Also

DataTableEventArgs Class | DataTableEventArgs Members | Steema.TeeChart.Tools Namespace


Text

Steema.TeeChart.Tools.DataTableEventArgs.Text Property

public String Text {get; set;}

See Also

DataTableEventArgs Class | DataTableEventArgs Members | Steema.TeeChart.Tools Namespace


ValueIndex

Steema.TeeChart.Tools.DataTableEventArgs.ValueIndex Property

public Int32 ValueIndex {get;}

See Also

DataTableEventArgs Class | DataTableEventArgs Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.DataTableEventHandler

Steema.TeeChart.Tools.DataTableEventHandler Delegate

DataTable tool event handler. Suitable for modifying item texts.
public delegate DataTableEventHandler (DataTableTool sender,
     DataTableEventArgs e)

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.DataTableFilterSeriesEventArgs

Steema.TeeChart.Tools.DataTableFilterSeriesEventArgs Class

Event args to enable filtering of series in the DataTable.

For a list of all members of this type, see DataTableFilterSeriesEventArgs Members

System.Object
System.EventArgs
public class DataTableFilterSeriesEventArgs : EventArgs

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

DataTableFilterSeriesEventArgs members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.DataTableFilterSeriesEventArgsMembers

Steema.TeeChart.Tools.DataTableFilterSeriesEventArgs all Members

DataTableFilterSeriesEventArgs overview

Constructors

Constructor

Public Properties

Accept
Series

See Also

DataTableFilterSeriesEventArgs Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.DataTableFilterSeriesEventArgs Constructor

public DataTableFilterSeriesEventArgs(Series series,
     Boolean accept)

See Also

DataTableFilterSeriesEventArgs Class | DataTableFilterSeriesEventArgs Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.DataTableFilterSeriesEventArgsProperties

Steema.TeeChart.Tools.DataTableFilterSeriesEventArgs Properties

Public Properties

Accept
Series

See Also

DataTableFilterSeriesEventArgs Class | Steema.TeeChart.Tools Namespace


Accept

Steema.TeeChart.Tools.DataTableFilterSeriesEventArgs.Accept Property

public Boolean Accept {get; set;}

See Also

DataTableFilterSeriesEventArgs Class | DataTableFilterSeriesEventArgs Members | Steema.TeeChart.Tools Namespace


Series

Steema.TeeChart.Tools.DataTableFilterSeriesEventArgs.Series Property

public Series Series {get;}

See Also

DataTableFilterSeriesEventArgs Class | DataTableFilterSeriesEventArgs Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.DataTableFilterSeriesEventHandler

Steema.TeeChart.Tools.DataTableFilterSeriesEventHandler Delegate

DataTable tool's FilterSeries event handler. Suitable for filtering series.
public delegate DataTableFilterSeriesEventHandler (DataTableTool sender,
     DataTableFilterSeriesEventArgs e)

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.DataTableTool

Steema.TeeChart.Tools.DataTableTool Class

For a list of all members of this type, see DataTableTool Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
public class DataTableTool : Tool , ICloneable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

DataTableTool members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.DataTableToolMembers

Steema.TeeChart.Tools.DataTableTool all Members

DataTableTool overview

Constructors

Constructor Overloaded

Public Events

FilterSeries
GetText

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
AutoOffset |
AutoPosition | Automatically position DataTable.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText | Clip legend text.
ColumnPen |
Description | Gets descriptive text.
Font | Legend text font.
Inverted | Invert legend items.
Left | Legend left coordinate. If zero, left coordinate is calculated automatically.
RowPen |
Summary | Gets detailed descriptive text.
TableLegend |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top | Legend top coordinate. If zero, top coordinate is calculated automatically.

See Also

DataTableTool Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.DataTableTool Constructor

Overload List

public DataTableTool()
public DataTableTool(Steema.TeeChart.Chart)

See Also

DataTableTool Class | DataTableTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.DataTableTool Constructor

public DataTableTool(Chart c)

See Also

DataTableTool Constructor Overload List | DataTableTool Class | DataTableTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.DataTableTool Constructor

public DataTableTool()

See Also

DataTableTool Constructor Overload List | DataTableTool Class | DataTableTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.DataTableToolEvents

Steema.TeeChart.Tools.DataTableTool Events

Public Events

FilterSeries
GetText

See Also

DataTableTool Class | Steema.TeeChart.Tools Namespace


FilterSeries

Steema.TeeChart.Tools.DataTableTool.FilterSeries Event

public DataTableFilterSeriesEventHandler  FilterSeries

See Also

DataTableTool Class | DataTableTool Members | Steema.TeeChart.Tools Namespace


GetText

Steema.TeeChart.Tools.DataTableTool.GetText Event

public DataTableEventHandler  GetText

See Also

DataTableTool Class | DataTableTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.DataTableToolMethods

Steema.TeeChart.Tools.DataTableTool Methods

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

See Also

DataTableTool Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.DataTableToolProperties

Steema.TeeChart.Tools.DataTableTool Properties

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
AutoOffset |
AutoPosition | Automatically position DataTable.
Chart (inherited from TeeBase) | Chart associated with this object
ClipText | Clip legend text.
ColumnPen |
Description | Gets descriptive text.
Font | Legend text font.
Inverted | Invert legend items.
Left | Legend left coordinate. If zero, left coordinate is calculated automatically.
RowPen |
Summary | Gets detailed descriptive text.
TableLegend |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top | Legend top coordinate. If zero, top coordinate is calculated automatically.

See Also

DataTableTool Class | Steema.TeeChart.Tools Namespace


AutoOffset

Steema.TeeChart.Tools.DataTableTool.AutoOffset Property

public Boolean AutoOffset {get; set;}

See Also

DataTableTool Class | DataTableTool Members | Steema.TeeChart.Tools Namespace


AutoPosition

Steema.TeeChart.Tools.DataTableTool.AutoPosition Property

Automatically position DataTable.
public Boolean AutoPosition {get; set;}

See Also

DataTableTool Class | DataTableTool Members | Steema.TeeChart.Tools Namespace


ClipText

Steema.TeeChart.Tools.DataTableTool.ClipText Property

Clip legend text.
public Boolean ClipText {get; set;}

See Also

DataTableTool Class | DataTableTool Members | Steema.TeeChart.Tools Namespace


ColumnPen

Steema.TeeChart.Tools.DataTableTool.ColumnPen Property

public ChartPen ColumnPen {get; set;}

See Also

DataTableTool Class | DataTableTool Members | Steema.TeeChart.Tools Namespace


Description

Steema.TeeChart.Tools.DataTableTool.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

DataTableTool Class | DataTableTool Members | Steema.TeeChart.Tools Namespace


Font

Steema.TeeChart.Tools.DataTableTool.Font Property

Legend text font.
public ChartFont Font {get;}

See Also

DataTableTool Class | DataTableTool Members | Steema.TeeChart.Tools Namespace


Inverted

Steema.TeeChart.Tools.DataTableTool.Inverted Property

Invert legend items.
public Boolean Inverted {get; set;}

See Also

DataTableTool Class | DataTableTool Members | Steema.TeeChart.Tools Namespace


Left

Steema.TeeChart.Tools.DataTableTool.Left Property

Legend left coordinate. If zero, left coordinate is calculated automatically.
public Int32 Left {get; set;}

See Also

DataTableTool Class | DataTableTool Members | Steema.TeeChart.Tools Namespace


RowPen

Steema.TeeChart.Tools.DataTableTool.RowPen Property

public ChartPen RowPen {get; set;}

See Also

DataTableTool Class | DataTableTool Members | Steema.TeeChart.Tools Namespace


Summary

Steema.TeeChart.Tools.DataTableTool.Summary Property

Gets detailed descriptive text.
public override String Summary {get;}

See Also

DataTableTool Class | DataTableTool Members | Steema.TeeChart.Tools Namespace


TableLegend

Steema.TeeChart.Tools.DataTableTool.TableLegend Property

public TableLegend TableLegend {get; set;}

See Also

DataTableTool Class | DataTableTool Members | Steema.TeeChart.Tools Namespace


Top

Steema.TeeChart.Tools.DataTableTool.Top Property

Legend top coordinate. If zero, top coordinate is calculated automatically.
public Int32 Top {get; set;}

See Also

DataTableTool Class | DataTableTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ExtraLegend

Steema.TeeChart.Tools.ExtraLegend Class

ExtraLegend tool.

For a list of all members of this type, see ExtraLegend Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class ExtraLegend : ToolSeries , ICloneable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

ExtraLegend members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ExtraLegendMembers

Steema.TeeChart.Tools.ExtraLegend all Members

ExtraLegend overview

Constructors

Constructor Overloaded

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Chart (inherited from TeeBase) | Chart associated with this object
Description | Gets descriptive text.
GetHorizAxis (inherited from ToolSeries) | Returns the associated Top or Bottom Chart Horizontal Axis.
GetVertAxis (inherited from ToolSeries) | Returns the associated Left or Right Chart Vertical Axis.
Legend | Gets or sets the Legend characteristics.
Series (inherited from ToolSeries) | Sets Series with which Tools are associated.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

ExtraLegend Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ExtraLegend Constructor

Overload List

public ExtraLegend()
public ExtraLegend(Steema.TeeChart.Chart)

See Also

ExtraLegend Class | ExtraLegend Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ExtraLegend Constructor

public ExtraLegend(Chart c)

See Also

ExtraLegend Constructor Overload List | ExtraLegend Class | ExtraLegend Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ExtraLegend Constructor

public ExtraLegend()

See Also

ExtraLegend Constructor Overload List | ExtraLegend Class | ExtraLegend Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ExtraLegendMethods

Steema.TeeChart.Tools.ExtraLegend Methods

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

See Also

ExtraLegend Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ExtraLegendProperties

Steema.TeeChart.Tools.ExtraLegend Properties

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Chart (inherited from TeeBase) | Chart associated with this object
Description | Gets descriptive text.
GetHorizAxis (inherited from ToolSeries) | Returns the associated Top or Bottom Chart Horizontal Axis.
GetVertAxis (inherited from ToolSeries) | Returns the associated Left or Right Chart Vertical Axis.
Legend | Gets or sets the Legend characteristics.
Series (inherited from ToolSeries) | Sets Series with which Tools are associated.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

ExtraLegend Class | Steema.TeeChart.Tools Namespace


Description

Steema.TeeChart.Tools.ExtraLegend.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

ExtraLegend Class | ExtraLegend Members | Steema.TeeChart.Tools Namespace


Legend

Steema.TeeChart.Tools.ExtraLegend.Legend Property

Gets or sets the Legend characteristics.
public Legend Legend {get; set;}

See Also

ExtraLegend Class | ExtraLegend Members | Steema.TeeChart.Tools Namespace


Summary

Steema.TeeChart.Tools.ExtraLegend.Summary Property

Gets detailed descriptive text.
public override String Summary {get;}

See Also

ExtraLegend Class | ExtraLegend Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.FibonacciStyle

Steema.TeeChart.Tools.FibonacciStyle Enum

Defines style for Levels
[Serializable]
public sealed enum FibonacciStyle : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
Arc | Fibonacci arcs.
Fan | Fibonacci fan lines.
Retracements | Fibonacci fan lines.

See Also

Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.FibonacciTool

Steema.TeeChart.Tools.FibonacciTool Class

Fibonacci fans and arcs financial tool. Tool supports Fibonacci arcs and fans. Fibonacci arcs are charting technique consisting of three curved lines that are drawn for the purpose of anticipating key support and resistance levels, and areas of ranging. Fibonacci arcs are created by first drawing an invisible trendline between two points (usually the high and low in a given period), and then by drawing three curves that intersect this trendline at the key Fibonacci levels of 38.2%, 50% and 61.8%. Fibonacci fans are charting technique consisting of three diagonal lines that use Fibonacci ratios to help identify key levels of support and resistance. Fibonacci fans are created by first drawing a trendline through two points (usually the high and low in a given period), and then by dividing the vertical distance between the two points by the key Fibonacci ratios of 38.2%, 50% and 61.8%. The result of these divisions each represent a point within the vertical distance. The three 'fan' lines are then created by drawing a line from the leftmost point to each of the three representing a Fibonacci ratio.

For a list of all members of this type, see FibonacciTool Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class FibonacciTool : ToolSeries , ICloneable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

FibonacciTool members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.FibonacciToolMembers

Steema.TeeChart.Tools.FibonacciTool all Members

FibonacciTool overview

Constructors

Constructor Overloaded

Public Methods

AxisPoint | Convert from axis double XY to screen pixels XY.
Clone (inherited from Tool) |
CreateDefaultLevels | Create default Fibonacci levels at 38.2%, 50% and 61.8%
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Chart (inherited from TeeBase) | Chart associated with this object
Description |
DrawStyle | Defines Fibonacci tool drawing style. Tool supports Fibonacci arcs and Fibonacci fans (lines).
EndX | Defines trendline end point x coordinate.
EndY | Defines trendline end point y coordinate.
GetHorizAxis (inherited from ToolSeries) | Returns the associated Top or Bottom Chart Horizontal Axis.
GetVertAxis (inherited from ToolSeries) | Returns the associated Left or Right Chart Vertical Axis.
LabelsAngle | Labels angle.
LabelsFont | Controls level font properties.
Levels | Returns the list of Fibonacci levels.
Series (inherited from ToolSeries) | Sets Series with which Tools are associated.
ShowLabels | If true, show individual Fibonacci level labels.
StartX | Defines trendline start point x coordinate.
StartY | Defines trendline start point y coordinate.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TrendPen | Defines trend pen characteristics.

See Also

FibonacciTool Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.FibonacciTool Constructor

Overload List

public FibonacciTool()
public FibonacciTool(Steema.TeeChart.Chart)

See Also

FibonacciTool Class | FibonacciTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.FibonacciTool Constructor

public FibonacciTool(Chart c)

See Also

FibonacciTool Constructor Overload List | FibonacciTool Class | FibonacciTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.FibonacciTool Constructor

public FibonacciTool()

See Also

FibonacciTool Constructor Overload List | FibonacciTool Class | FibonacciTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.FibonacciToolMethods

Steema.TeeChart.Tools.FibonacciTool Methods

Public Methods

AxisPoint | Convert from axis double XY to screen pixels XY.
Clone (inherited from Tool) |
CreateDefaultLevels | Create default Fibonacci levels at 38.2%, 50% and 61.8%
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

See Also

FibonacciTool Class | Steema.TeeChart.Tools Namespace


AxisPoint

Steema.TeeChart.Tools.FibonacciTool.AxisPoint Method

Convert from axis double XY to screen pixels XY.
public Point AxisPoint(Double x,
     Double y)

Parameters

p
Axis point coordinate.

Return Value

Screen point coordinate.

See Also

FibonacciTool Class | FibonacciTool Members | Steema.TeeChart.Tools Namespace


CreateDefaultLevels

Steema.TeeChart.Tools.FibonacciTool.CreateDefaultLevels Method

Create default Fibonacci levels at 38.2%, 50% and 61.8%
public Void CreateDefaultLevels()

See Also

FibonacciTool Class | FibonacciTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.FibonacciToolProperties

Steema.TeeChart.Tools.FibonacciTool Properties

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Chart (inherited from TeeBase) | Chart associated with this object
Description |
DrawStyle | Defines Fibonacci tool drawing style. Tool supports Fibonacci arcs and Fibonacci fans (lines).
EndX | Defines trendline end point x coordinate.
EndY | Defines trendline end point y coordinate.
GetHorizAxis (inherited from ToolSeries) | Returns the associated Top or Bottom Chart Horizontal Axis.
GetVertAxis (inherited from ToolSeries) | Returns the associated Left or Right Chart Vertical Axis.
LabelsAngle | Labels angle.
LabelsFont | Controls level font properties.
Levels | Returns the list of Fibonacci levels.
Series (inherited from ToolSeries) | Sets Series with which Tools are associated.
ShowLabels | If true, show individual Fibonacci level labels.
StartX | Defines trendline start point x coordinate.
StartY | Defines trendline start point y coordinate.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
TrendPen | Defines trend pen characteristics.

See Also

FibonacciTool Class | Steema.TeeChart.Tools Namespace


Description

Steema.TeeChart.Tools.FibonacciTool.Description Property

public override String Description {get;}

See Also

FibonacciTool Class | FibonacciTool Members | Steema.TeeChart.Tools Namespace


DrawStyle

Steema.TeeChart.Tools.FibonacciTool.DrawStyle Property

Defines Fibonacci tool drawing style. Tool supports Fibonacci arcs and Fibonacci fans (lines).
public FibonacciStyle DrawStyle {get; set;}

See Also

FibonacciTool Class | FibonacciTool Members | Steema.TeeChart.Tools Namespace


EndX

Steema.TeeChart.Tools.FibonacciTool.EndX Property

Defines trendline end point x coordinate.
public Double EndX {get; set;}

See Also

FibonacciTool Class | FibonacciTool Members | Steema.TeeChart.Tools Namespace


EndY

Steema.TeeChart.Tools.FibonacciTool.EndY Property

Defines trendline end point y coordinate.
public Double EndY {get; set;}

See Also

FibonacciTool Class | FibonacciTool Members | Steema.TeeChart.Tools Namespace


LabelsAngle

Steema.TeeChart.Tools.FibonacciTool.LabelsAngle Property

Labels angle.
public Int32 LabelsAngle {get; set;}

See Also

FibonacciTool Class | FibonacciTool Members | Steema.TeeChart.Tools Namespace


LabelsFont

Steema.TeeChart.Tools.FibonacciTool.LabelsFont Property

Controls level font properties.
public ChartFont LabelsFont {get;}

See Also

FibonacciTool Class | FibonacciTool Members | Steema.TeeChart.Tools Namespace


Levels

Steema.TeeChart.Tools.FibonacciTool.Levels Property

Returns the list of Fibonacci levels.
public FibonacciLevels Levels {get;}

See Also

FibonacciTool Class | FibonacciTool Members | Steema.TeeChart.Tools Namespace


ShowLabels

Steema.TeeChart.Tools.FibonacciTool.ShowLabels Property

If true, show individual Fibonacci level labels.
public Boolean ShowLabels {get; set;}

See Also

FibonacciTool Class | FibonacciTool Members | Steema.TeeChart.Tools Namespace


StartX

Steema.TeeChart.Tools.FibonacciTool.StartX Property

Defines trendline start point x coordinate.
public Double StartX {get; set;}

See Also

FibonacciTool Class | FibonacciTool Members | Steema.TeeChart.Tools Namespace


StartY

Steema.TeeChart.Tools.FibonacciTool.StartY Property

Defines trendline start point y coordinate.
public Double StartY {get; set;}

See Also

FibonacciTool Class | FibonacciTool Members | Steema.TeeChart.Tools Namespace


Summary

Steema.TeeChart.Tools.FibonacciTool.Summary Property

Gets detailed descriptive text.
public override String Summary {get;}

See Also

FibonacciTool Class | FibonacciTool Members | Steema.TeeChart.Tools Namespace


TrendPen

Steema.TeeChart.Tools.FibonacciTool.TrendPen Property

Defines trend pen characteristics.
public ChartPen TrendPen {get;}

See Also

FibonacciTool Class | FibonacciTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.FibonacciTool.FibonacciItem

Steema.TeeChart.Tools.FibonacciTool.FibonacciItem Class

Individual Fibonacci level properties.

For a list of all members of this type, see FibonacciItem Members

System.Object
public class FibonacciItem : Object

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

FibonacciItem members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.FibonacciTool.FibonacciItemMembers

Steema.TeeChart.Tools.FibonacciTool.FibonacciItem all Members

FibonacciItem overview

Constructors

Steema.TeeChart.Tools.FibonacciTool.FibonacciItem..ctor

Public Properties

Pen | Defines individual Fibonacci level pen characteristics.
Value | Defines Fibonaccio arc value in range (0,100).

See Also

FibonacciItem Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.FibonacciTool+FibonacciItem Constructor

public FibonacciTool+FibonacciItem(FibonacciTool owner,
     Double value)

See Also

FibonacciItem Class | FibonacciItem Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.FibonacciTool.FibonacciItemProperties

Steema.TeeChart.Tools.FibonacciTool.FibonacciItem Properties

Public Properties

Pen | Defines individual Fibonacci level pen characteristics.
Value | Defines Fibonaccio arc value in range (0,100).

See Also

FibonacciItem Class | Steema.TeeChart.Tools Namespace


Pen

Steema.TeeChart.Tools.FibonacciTool+FibonacciItem.Pen Property

Defines individual Fibonacci level pen characteristics.
public ChartPen Pen {get;}

See Also

FibonacciItem Class | FibonacciItem Members | Steema.TeeChart.Tools Namespace


Value

Steema.TeeChart.Tools.FibonacciTool+FibonacciItem.Value Property

Defines Fibonaccio arc value in range (0,100).
public Double Value {get; set;}

See Also

FibonacciItem Class | FibonacciItem Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.FibonacciTool.FibonacciLevels

Steema.TeeChart.Tools.FibonacciTool.FibonacciLevels Class

Collection of all arcs.

For a list of all members of this type, see FibonacciLevels Members

System.Object
System.Collections.CollectionBase
public class FibonacciLevels : CollectionBase , IList, ICollection
, IEnumerable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

FibonacciLevels members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.FibonacciTool.FibonacciLevelsMembers

Steema.TeeChart.Tools.FibonacciTool.FibonacciLevels all Members

FibonacciLevels overview

Constructors

Steema.TeeChart.Tools.FibonacciTool.FibonacciLevels..ctor

Public Methods

Add
Clear
IndexOf
Remove

Public Properties

Item

See Also

FibonacciLevels Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.FibonacciTool+FibonacciLevels Constructor

public FibonacciTool+FibonacciLevels()

See Also

FibonacciLevels Class | FibonacciLevels Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.FibonacciTool.FibonacciLevelsMethods

Steema.TeeChart.Tools.FibonacciTool.FibonacciLevels Methods

Public Methods

Add
Clear
IndexOf
Remove

See Also

FibonacciLevels Class | Steema.TeeChart.Tools Namespace


Add

Steema.TeeChart.Tools.FibonacciTool+FibonacciLevels.Add Method

public Int32 Add(FibonacciItem l)

See Also

FibonacciLevels Class | FibonacciLevels Members | Steema.TeeChart.Tools Namespace


Clear

Steema.TeeChart.Tools.FibonacciTool+FibonacciLevels.Clear Method

public Void Clear()

See Also

FibonacciLevels Class | FibonacciLevels Members | Steema.TeeChart.Tools Namespace


IndexOf

Steema.TeeChart.Tools.FibonacciTool+FibonacciLevels.IndexOf Method

public Int32 IndexOf(FibonacciItem l)

See Also

FibonacciLevels Class | FibonacciLevels Members | Steema.TeeChart.Tools Namespace


Remove

Steema.TeeChart.Tools.FibonacciTool+FibonacciLevels.Remove Method

public Void Remove(FibonacciItem s)

See Also

FibonacciLevels Class | FibonacciLevels Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.FibonacciTool.FibonacciLevelsProperties

Steema.TeeChart.Tools.FibonacciTool.FibonacciLevels Properties

Public Properties

Item

See Also

FibonacciLevels Class | Steema.TeeChart.Tools Namespace


Item

Steema.TeeChart.Tools.FibonacciTool+FibonacciLevels.Item Property

public FibonacciItem Item(Int32 index) {get;}

See Also

FibonacciLevels Class | FibonacciLevels Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.GridBand

Steema.TeeChart.Tools.GridBand Class

Grid Band tool, use it to display a coloured rectangles (bands) at the grid lines of the specified axis and position.

For a list of all members of this type, see GridBand Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolAxis
public class GridBand : ToolAxis , ICloneable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

GridBand members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.GridBandMembers

Steema.TeeChart.Tools.GridBand all Members

GridBand overview

Constructors

Constructor Overloaded

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Axis (inherited from ToolAxis) | Sets the axis to which a Tool will belong.
Band1 | The Brush characteristics of the first GridBand tool Band.
Band2 | The Brush characteristics of the second GridBand tool Band.
Chart (inherited from TeeBase) | Chart associated with this object
Description | Gets descriptive text.
Pen (inherited from ToolAxis) | Element Pen characteristics.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

GridBand Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.GridBand Constructor

Overload List

public GridBand()
public GridBand(Steema.TeeChart.Chart)

See Also

GridBand Class | GridBand Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.GridBand Constructor

public GridBand(Chart c)

See Also

GridBand Constructor Overload List | GridBand Class | GridBand Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.GridBand Constructor

public GridBand()

See Also

GridBand Constructor Overload List | GridBand Class | GridBand Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.GridBandMethods

Steema.TeeChart.Tools.GridBand Methods

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

See Also

GridBand Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.GridBandProperties

Steema.TeeChart.Tools.GridBand Properties

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Axis (inherited from ToolAxis) | Sets the axis to which a Tool will belong.
Band1 | The Brush characteristics of the first GridBand tool Band.
Band2 | The Brush characteristics of the second GridBand tool Band.
Chart (inherited from TeeBase) | Chart associated with this object
Description | Gets descriptive text.
Pen (inherited from ToolAxis) | Element Pen characteristics.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

GridBand Class | Steema.TeeChart.Tools Namespace


Band1

Steema.TeeChart.Tools.GridBand.Band1 Property

The Brush characteristics of the first GridBand tool Band.
public ChartBrush Band1 {get; set;}

See Also

GridBand Class | GridBand Members | Steema.TeeChart.Tools Namespace


Band2

Steema.TeeChart.Tools.GridBand.Band2 Property

The Brush characteristics of the second GridBand tool Band.
public ChartBrush Band2 {get; set;}

See Also

GridBand Class | GridBand Members | Steema.TeeChart.Tools Namespace


Description

Steema.TeeChart.Tools.GridBand.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

GridBand Class | GridBand Members | Steema.TeeChart.Tools Namespace


Summary

Steema.TeeChart.Tools.GridBand.Summary Property

Gets detailed descriptive text.
public override String Summary {get;}

See Also

GridBand Class | GridBand Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.GridTranspose

Steema.TeeChart.Tools.GridTranspose Class

Transpose Grid 3D.

For a list of all members of this type, see GridTranspose Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
public class GridTranspose : Tool , ICloneable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

GridTranspose members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.GridTransposeMembers

Steema.TeeChart.Tools.GridTranspose all Members

GridTranspose overview

Constructors

Constructor Overloaded

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |
Transpose |

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Chart (inherited from TeeBase) | Chart associated with this object
Description | Gets descriptive text.
Series |
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

GridTranspose Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.GridTranspose Constructor

Overload List

public GridTranspose()
public GridTranspose(Steema.TeeChart.Chart)

See Also

GridTranspose Class | GridTranspose Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.GridTranspose Constructor

public GridTranspose(Chart c)

See Also

GridTranspose Constructor Overload List | GridTranspose Class | GridTranspose Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.GridTranspose Constructor

public GridTranspose()

See Also

GridTranspose Constructor Overload List | GridTranspose Class | GridTranspose Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.GridTransposeMethods

Steema.TeeChart.Tools.GridTranspose Methods

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |
Transpose |

See Also

GridTranspose Class | Steema.TeeChart.Tools Namespace


Transpose

Steema.TeeChart.Tools.GridTranspose.Transpose Method

public Void Transpose()

See Also

GridTranspose Class | GridTranspose Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.GridTransposeProperties

Steema.TeeChart.Tools.GridTranspose Properties

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Chart (inherited from TeeBase) | Chart associated with this object
Description | Gets descriptive text.
Series |
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

GridTranspose Class | Steema.TeeChart.Tools Namespace


Description

Steema.TeeChart.Tools.GridTranspose.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

GridTranspose Class | GridTranspose Members | Steema.TeeChart.Tools Namespace


Series

Steema.TeeChart.Tools.GridTranspose.Series Property

public Custom3DGrid Series {get; set;}

See Also

GridTranspose Class | GridTranspose Members | Steema.TeeChart.Tools Namespace


Summary

Steema.TeeChart.Tools.GridTranspose.Summary Property

Gets detailed descriptive text.
public override String Summary {get;}

See Also

GridTranspose Class | GridTranspose Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.InnerChart

Steema.TeeChart.Tools.InnerChart Class

For a list of all members of this type, see InnerChart Members

System.Object
Java.Lang.Object
Android.Views.View
Android.Views.ViewGroup
Android.Widget.FrameLayout
Steema.TeeChart.TChart
public class InnerChart : TChart , IDisposable, IJavaObject, ICallback
, IAccessibilityEventSource, ICallback, IViewManager, IViewParent
, IChart

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

InnerChart members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.InnerChartMembers

Steema.TeeChart.Tools.InnerChart all Members

InnerChart overview

Constructors

Constructor Overloaded

Public Events

AfterDraw (inherited from TChart)
AllowScroll (inherited from TChart)
BeforeDraw (inherited from TChart)
BeforeDrawAxes (inherited from TChart)
BeforeDrawSeries (inherited from TChart)
ClickSeries (inherited from TChart)
GetAxesChartRect (inherited from TChart)
GetAxisLabel (inherited from TChart)
GetLegendPos (inherited from TChart)
GetLegendRect (inherited from TChart)
GetLegendText (inherited from TChart)
GetNextAxisLabel (inherited from TChart)
Scroll (inherited from TChart)
ScrollMod (inherited from TChart)
UndoneZoom (inherited from TChart)
Zoomed (inherited from TChart)

Public Methods

Clear (inherited from TChart) | Reset the Chart to its default values.
DoInvalidate |
Draw (inherited from TChart) | Paints the Chart in your preferred Canvas and region.
ExchangeSeries (inherited from TChart) |
Free (inherited from TChart) | Frees all the resources used by the chart.
OnKeyDown (inherited from TChart) |
OnTouchEvent (inherited from TChart) | This override implements what TChart will do when OnTouchEvent is fired.
RemoveAllSeries (inherited from TChart) |

Public Properties

Animations (inherited from TChart) | Collection of Animation components contained in this Chart.
Aspect (inherited from TChart) | Accesses view characteristics of the Chart.
AutoRepaint (inherited from TChart) | Enables/Disables Repainting of Chart when points are added.
Axes (inherited from TChart) | Collection of predefined and custom axis objects.
Bitmap (inherited from TChart) | Returns a Bitmap image filled with Chart.
Canvas (inherited from TChart) |
Chart (inherited from TChart) | Defines the Chart to display.
Cursor (inherited from TChart) |
Footer (inherited from TChart) | Defines Text shown at the bottom of the Chart.
Frame (inherited from TChart) | Obsolete. Determines properties of frame around chart back wall. Use tChart1.Walls.Back.Pen property instead.
Graphics3D (inherited from TChart) | Use the Graphics3D property to access TeeChart Draw properties and methods.
Header (inherited from TChart) | Defines Text shown at top of the Chart.
IParent |
Item (inherited from TChart) | Default indexer ( Example: tChart1[0].Color=Color.Blue; is equivalent to tChart1.Series[0].Color=Color.Blue; )
Legend (inherited from TChart) | Legend characteristics
Page (inherited from TChart) | Accesses multiple page characteristics of the Chart.
Panel (inherited from TChart) | Background visible attributes.
Panning (inherited from TChart) | Accesses Panning characteristics.
Series (inherited from TChart) | Collection of Series contained in this Chart.
SeriesCount (inherited from TChart) | Obsolete. Returns number of Series in Chart. Use tChart1.Series.Count property instead.
SubFooter (inherited from TChart) | Defines Text shown directly above Footer.
SubHeader (inherited from TChart) | Defines Text shown directly below Header.
Tools (inherited from TChart) | Collection of Tool components contained in this Chart.
Walls (inherited from TChart) | Accesses left, bottom and back wall characteristics of the Chart.
Zoom (inherited from TChart) | Accesses the Zoom characteristics of the Chart.

See Also

InnerChart Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.InnerChart Constructor

Overload List

public InnerChart(Steema.TeeChart.Tools.SubChart, Android.Content.Context)
public InnerChart(Android.Content.Context)

See Also

InnerChart Class | InnerChart Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.InnerChart Constructor

public InnerChart(Context context)

See Also

InnerChart Constructor Overload List | InnerChart Class | InnerChart Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.InnerChart Constructor

public InnerChart(SubChart parent,
     Context context)

See Also

InnerChart Constructor Overload List | InnerChart Class | InnerChart Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.InnerChartEvents

Steema.TeeChart.Tools.InnerChart Events

Public Events

AfterDraw (inherited from TChart)
AllowScroll (inherited from TChart)
BeforeDraw (inherited from TChart)
BeforeDrawAxes (inherited from TChart)
BeforeDrawSeries (inherited from TChart)
ClickSeries (inherited from TChart)
GetAxesChartRect (inherited from TChart)
GetAxisLabel (inherited from TChart)
GetLegendPos (inherited from TChart)
GetLegendRect (inherited from TChart)
GetLegendText (inherited from TChart)
GetNextAxisLabel (inherited from TChart)
Scroll (inherited from TChart)
ScrollMod (inherited from TChart)
UndoneZoom (inherited from TChart)
Zoomed (inherited from TChart)

See Also

InnerChart Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.InnerChartMethods

Steema.TeeChart.Tools.InnerChart Methods

Public Methods

Clear (inherited from TChart) | Reset the Chart to its default values.
DoInvalidate |
Draw (inherited from TChart) | Paints the Chart in your preferred Canvas and region.
ExchangeSeries (inherited from TChart) |
Free (inherited from TChart) | Frees all the resources used by the chart.
OnKeyDown (inherited from TChart) |
OnTouchEvent (inherited from TChart) | This override implements what TChart will do when OnTouchEvent is fired.
RemoveAllSeries (inherited from TChart) |

See Also

InnerChart Class | Steema.TeeChart.Tools Namespace


DoInvalidate

Steema.TeeChart.Tools.InnerChart.DoInvalidate Method

public override Void DoInvalidate()

See Also

InnerChart Class | InnerChart Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.InnerChartProperties

Steema.TeeChart.Tools.InnerChart Properties

Public Properties

Animations (inherited from TChart) | Collection of Animation components contained in this Chart.
Aspect (inherited from TChart) | Accesses view characteristics of the Chart.
AutoRepaint (inherited from TChart) | Enables/Disables Repainting of Chart when points are added.
Axes (inherited from TChart) | Collection of predefined and custom axis objects.
Bitmap (inherited from TChart) | Returns a Bitmap image filled with Chart.
Canvas (inherited from TChart) |
Chart (inherited from TChart) | Defines the Chart to display.
Cursor (inherited from TChart) |
Footer (inherited from TChart) | Defines Text shown at the bottom of the Chart.
Frame (inherited from TChart) | Obsolete. Determines properties of frame around chart back wall. Use tChart1.Walls.Back.Pen property instead.
Graphics3D (inherited from TChart) | Use the Graphics3D property to access TeeChart Draw properties and methods.
Header (inherited from TChart) | Defines Text shown at top of the Chart.
IParent |
Item (inherited from TChart) | Default indexer ( Example: tChart1[0].Color=Color.Blue; is equivalent to tChart1.Series[0].Color=Color.Blue; )
Legend (inherited from TChart) | Legend characteristics
Page (inherited from TChart) | Accesses multiple page characteristics of the Chart.
Panel (inherited from TChart) | Background visible attributes.
Panning (inherited from TChart) | Accesses Panning characteristics.
Series (inherited from TChart) | Collection of Series contained in this Chart.
SeriesCount (inherited from TChart) | Obsolete. Returns number of Series in Chart. Use tChart1.Series.Count property instead.
SubFooter (inherited from TChart) | Defines Text shown directly above Footer.
SubHeader (inherited from TChart) | Defines Text shown directly below Header.
Tools (inherited from TChart) | Collection of Tool components contained in this Chart.
Walls (inherited from TChart) | Accesses left, bottom and back wall characteristics of the Chart.
Zoom (inherited from TChart) | Accesses the Zoom characteristics of the Chart.

See Also

InnerChart Class | Steema.TeeChart.Tools Namespace


IParent

Steema.TeeChart.Tools.InnerChart.IParent Property

public SubChart IParent {get; set;}

See Also

InnerChart Class | InnerChart Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.LegendPalette

Steema.TeeChart.Tools.LegendPalette Class

For a list of all members of this type, see LegendPalette Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class LegendPalette : ToolSeries , ICloneable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

LegendPalette members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.LegendPaletteMembers

Steema.TeeChart.Tools.LegendPalette all Members

LegendPalette overview

Constructors

Constructor Overloaded

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Axes | Gets the Axes collection of Axis of the LegendPalette Tool.
Axis |
Border |
Chart (inherited from TeeBase) | Chart associated with this object
Description | Gets descriptive text.
GetHorizAxis (inherited from ToolSeries) | Returns the associated Top or Bottom Chart Horizontal Axis.
GetVertAxis (inherited from ToolSeries) | Returns the associated Left or Right Chart Vertical Axis.
Gradient |
Height |
Inverted |
Left |
Pen |
PositionUnits |
Series (inherited from ToolSeries) | Sets Series with which Tools are associated.
Smooth |
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top |
Transparent |
Vertical |
Width |

See Also

LegendPalette Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.LegendPalette Constructor

Overload List

public LegendPalette()
public LegendPalette(Steema.TeeChart.Chart)

See Also

LegendPalette Class | LegendPalette Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.LegendPalette Constructor

public LegendPalette(Chart c)

See Also

LegendPalette Constructor Overload List | LegendPalette Class | LegendPalette Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.LegendPalette Constructor

public LegendPalette()

See Also

LegendPalette Constructor Overload List | LegendPalette Class | LegendPalette Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.LegendPaletteMethods

Steema.TeeChart.Tools.LegendPalette Methods

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

See Also

LegendPalette Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.LegendPaletteProperties

Steema.TeeChart.Tools.LegendPalette Properties

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Axes | Gets the Axes collection of Axis of the LegendPalette Tool.
Axis |
Border |
Chart (inherited from TeeBase) | Chart associated with this object
Description | Gets descriptive text.
GetHorizAxis (inherited from ToolSeries) | Returns the associated Top or Bottom Chart Horizontal Axis.
GetVertAxis (inherited from ToolSeries) | Returns the associated Left or Right Chart Vertical Axis.
Gradient |
Height |
Inverted |
Left |
Pen |
PositionUnits |
Series (inherited from ToolSeries) | Sets Series with which Tools are associated.
Smooth |
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top |
Transparent |
Vertical |
Width |

See Also

LegendPalette Class | Steema.TeeChart.Tools Namespace


Axes

Steema.TeeChart.Tools.LegendPalette.Axes Property

Gets the Axes collection of Axis of the LegendPalette Tool.
public Axes Axes {get;}

See Also

LegendPalette Class | LegendPalette Members | Steema.TeeChart.Tools Namespace


Axis

Steema.TeeChart.Tools.LegendPalette.Axis Property

public LegendPaletteAxis Axis {get; set;}

See Also

LegendPalette Class | LegendPalette Members | Steema.TeeChart.Tools Namespace


Border

Steema.TeeChart.Tools.LegendPalette.Border Property

public ChartPen Border {get; set;}

See Also

LegendPalette Class | LegendPalette Members | Steema.TeeChart.Tools Namespace


Description

Steema.TeeChart.Tools.LegendPalette.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

LegendPalette Class | LegendPalette Members | Steema.TeeChart.Tools Namespace


Gradient

Steema.TeeChart.Tools.LegendPalette.Gradient Property

public Gradient Gradient {get; set;}

See Also

LegendPalette Class | LegendPalette Members | Steema.TeeChart.Tools Namespace


Height

Steema.TeeChart.Tools.LegendPalette.Height Property

public Int32 Height {get; set;}

See Also

LegendPalette Class | LegendPalette Members | Steema.TeeChart.Tools Namespace


Inverted

Steema.TeeChart.Tools.LegendPalette.Inverted Property

public Boolean Inverted {get; set;}

See Also

LegendPalette Class | LegendPalette Members | Steema.TeeChart.Tools Namespace


Left

Steema.TeeChart.Tools.LegendPalette.Left Property

public Int32 Left {get; set;}

See Also

LegendPalette Class | LegendPalette Members | Steema.TeeChart.Tools Namespace


Pen

Steema.TeeChart.Tools.LegendPalette.Pen Property

public ChartPen Pen {get; set;}

See Also

LegendPalette Class | LegendPalette Members | Steema.TeeChart.Tools Namespace


PositionUnits

Steema.TeeChart.Tools.LegendPalette.PositionUnits Property

public PositionUnits PositionUnits {get; set;}

See Also

LegendPalette Class | LegendPalette Members | Steema.TeeChart.Tools Namespace


Smooth

Steema.TeeChart.Tools.LegendPalette.Smooth Property

public Boolean Smooth {get; set;}

See Also

LegendPalette Class | LegendPalette Members | Steema.TeeChart.Tools Namespace


Summary

Steema.TeeChart.Tools.LegendPalette.Summary Property

Gets detailed descriptive text.
public override String Summary {get;}

See Also

LegendPalette Class | LegendPalette Members | Steema.TeeChart.Tools Namespace


Top

Steema.TeeChart.Tools.LegendPalette.Top Property

public Int32 Top {get; set;}

See Also

LegendPalette Class | LegendPalette Members | Steema.TeeChart.Tools Namespace


Transparent

Steema.TeeChart.Tools.LegendPalette.Transparent Property

public Boolean Transparent {get; set;}

See Also

LegendPalette Class | LegendPalette Members | Steema.TeeChart.Tools Namespace


Vertical

Steema.TeeChart.Tools.LegendPalette.Vertical Property

public Boolean Vertical {get; set;}

See Also

LegendPalette Class | LegendPalette Members | Steema.TeeChart.Tools Namespace


Width

Steema.TeeChart.Tools.LegendPalette.Width Property

public Int32 Width {get; set;}

See Also

LegendPalette Class | LegendPalette Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.LegendPaletteAxis

Steema.TeeChart.Tools.LegendPaletteAxis Enum

[Serializable]
public sealed enum LegendPaletteAxis : Enum , IComparable, IFormattable
, IConvertible

Public Members

Member | Description
laDefault | Use default axis.
laOther | Use other axis.
laBoth | Use both axes.

See Also

Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.Marker

Steema.TeeChart.Tools.Marker Class

Marker tool.

For a list of all members of this type, see Marker Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.Annotation
public class Marker : Annotation , ICloneable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

Marker members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.MarkerMembers

Steema.TeeChart.Tools.Marker all Members

Marker overview

Constructors

Constructor Overloaded

Public Fields

IRectangle

Public Methods

Clone (inherited from Tool) |
EditorKey (inherited from Annotation) | The method passed to the KeyDown event by default.
EndEdit (inherited from Annotation) | Stops the Annotation from further editing.
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
StartEdit (inherited from Annotation) | Puts the Annotation into edit mode.
TextWidth |
ToString (inherited from Tool) |

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
AllowEdit (inherited from Annotation) | Allows the Text of the Tool to be edited.
AutoSize (inherited from Annotation) | Set to true to permit custom sizing of TextShape.
Bounds (inherited from Annotation) | The rectangular bounds of the annotation tool.
Callout (inherited from Annotation) |
Centered |
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from Annotation) |
Cursor (inherited from Annotation) |
Description | Gets descriptive text.
Height (inherited from Annotation) | Sets a custom width.
Left (inherited from Annotation) | Sets horizontal displacement in pixels of text box from Chart's left edge.
Position (inherited from Annotation) | Defines a default position for the Annotation Tool text box and text.
PositionUnits (inherited from Annotation) | Defines Annotation Position units (pixels or percentage).
Shape (inherited from Annotation) | Sets characteristics of the Annotation Tool text and text box Shape.
Summary (inherited from Annotation) | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from Annotation) | Defines the text for the Annotation Tool.
TextAlign (inherited from Annotation) |
Top (inherited from Annotation) | Sets vertical displacement in pixels of text box from Chart's top edge.
UsePalette |
Width (inherited from Annotation) | Sets a custom width.

See Also

Marker Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.Marker Constructor

Overload List

public Marker(System.String, System.Int32, Steema.TeeChart.Tools.AnnotationPositions, Android.Graphics.Paint+Align, System.Drawing.Color, System.Drawing.Color)
public Marker()
public Marker(Steema.TeeChart.Chart)
public Marker(Steema.TeeChart.Chart, System.String, System.Int32, Steema.TeeChart.Tools.AnnotationPositions, Android.Graphics.Paint+Align, System.Drawing.Color, System.Drawing.Color)

See Also

Marker Class | Marker Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.Marker Constructor

public Marker(Chart c,
     String text,
     Int32 fontsize,
     AnnotationPositions pos,
     Align align,
     Color color1,
     Color color2)

See Also

Marker Constructor Overload List | Marker Class | Marker Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.Marker Constructor

public Marker(Chart c)

See Also

Marker Constructor Overload List | Marker Class | Marker Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.Marker Constructor

public Marker()

See Also

Marker Constructor Overload List | Marker Class | Marker Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.Marker Constructor

public Marker(String text,
     Int32 fontsize,
     AnnotationPositions pos,
     Align align,
     Color color1,
     Color color2)

See Also

Marker Constructor Overload List | Marker Class | Marker Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.MarkerFields

Steema.TeeChart.Tools.Marker Fields

Public Fields

IRectangle

See Also

Marker Class | Steema.TeeChart.Tools Namespace


IRectangle

Steema.TeeChart.Tools.Marker.IRectangle Field

public Rectangle IRectangle

See Also

Marker Class | Marker Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.MarkerMethods

Steema.TeeChart.Tools.Marker Methods

Public Methods

Clone (inherited from Tool) |
EditorKey (inherited from Annotation) | The method passed to the KeyDown event by default.
EndEdit (inherited from Annotation) | Stops the Annotation from further editing.
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
StartEdit (inherited from Annotation) | Puts the Annotation into edit mode.
TextWidth |
ToString (inherited from Tool) |

See Also

Marker Class | Steema.TeeChart.Tools Namespace


TextWidth

Steema.TeeChart.Tools.Marker.TextWidth Method

public Int32 TextWidth()

See Also

Marker Class | Marker Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.MarkerProperties

Steema.TeeChart.Tools.Marker Properties

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
AllowEdit (inherited from Annotation) | Allows the Text of the Tool to be edited.
AutoSize (inherited from Annotation) | Set to true to permit custom sizing of TextShape.
Bounds (inherited from Annotation) | The rectangular bounds of the annotation tool.
Callout (inherited from Annotation) |
Centered |
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from Annotation) |
Cursor (inherited from Annotation) |
Description | Gets descriptive text.
Height (inherited from Annotation) | Sets a custom width.
Left (inherited from Annotation) | Sets horizontal displacement in pixels of text box from Chart's left edge.
Position (inherited from Annotation) | Defines a default position for the Annotation Tool text box and text.
PositionUnits (inherited from Annotation) | Defines Annotation Position units (pixels or percentage).
Shape (inherited from Annotation) | Sets characteristics of the Annotation Tool text and text box Shape.
Summary (inherited from Annotation) | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from Annotation) | Defines the text for the Annotation Tool.
TextAlign (inherited from Annotation) |
Top (inherited from Annotation) | Sets vertical displacement in pixels of text box from Chart's top edge.
UsePalette |
Width (inherited from Annotation) | Sets a custom width.

See Also

Marker Class | Steema.TeeChart.Tools Namespace


Centered

Steema.TeeChart.Tools.Marker.Centered Property

public Boolean Centered {get; set;}

See Also

Marker Class | Marker Members | Steema.TeeChart.Tools Namespace


Description

Steema.TeeChart.Tools.Marker.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

Marker Class | Marker Members | Steema.TeeChart.Tools Namespace


UsePalette

Steema.TeeChart.Tools.Marker.UsePalette Property

public Boolean UsePalette {get; set;}

See Also

Marker Class | Marker Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.MarkersCollection

Steema.TeeChart.Tools.MarkersCollection Class

Collection of Marker Tool components.

For a list of all members of this type, see MarkersCollection Members

System.Object
System.Collections.CollectionBase
Steema.TeeChart.Tools.ToolsCollection
public class MarkersCollection : ToolsCollection , IList, ICollection
, IEnumerable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

MarkersCollection members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.MarkersCollectionMembers

Steema.TeeChart.Tools.MarkersCollection all Members

MarkersCollection overview

Constructors

Constructor

Public Fields

chart (inherited from ToolsCollection)

Public Methods

Add |
Clear |
IndexOf (inherited from ToolsCollection) | Returns the corresponding point index which has the specified Value.
Remove (inherited from ToolsCollection) | Removes a tool from the TChart.
SetParentChart |

Public Properties

Item

See Also

MarkersCollection Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.MarkersCollection Constructor

public MarkersCollection(Chart c)

See Also

MarkersCollection Class | MarkersCollection Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.MarkersCollectionFields

Steema.TeeChart.Tools.MarkersCollection Fields

Public Fields

chart (inherited from ToolsCollection)

See Also

MarkersCollection Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.MarkersCollectionMethods

Steema.TeeChart.Tools.MarkersCollection Methods

Public Methods

Add |
Clear |
IndexOf (inherited from ToolsCollection) | Returns the corresponding point index which has the specified Value.
Remove (inherited from ToolsCollection) | Removes a tool from the TChart.
SetParentChart |

See Also

MarkersCollection Class | Steema.TeeChart.Tools Namespace


Add

Steema.TeeChart.Tools.MarkersCollection.Add Method

Overload List

public Marker Add(System.String)

See Also

MarkersCollection Class | MarkersCollection Members | Steema.TeeChart.Tools Namespace


Add

Steema.TeeChart.Tools.MarkersCollection.Add Method

public Marker Add(String aText)

See Also

Add Overload List | MarkersCollection Class | MarkersCollection Members | Steema.TeeChart.Tools Namespace


Clear

Steema.TeeChart.Tools.MarkersCollection.Clear Method

Overload List

public override Void Clear(System.Boolean)

See Also

MarkersCollection Class | MarkersCollection Members | Steema.TeeChart.Tools Namespace


Clear

Steema.TeeChart.Tools.MarkersCollection.Clear Method

public override Void Clear(Boolean dispose)

See Also

Clear Overload List | MarkersCollection Class | MarkersCollection Members | Steema.TeeChart.Tools Namespace


SetParentChart

Steema.TeeChart.Tools.MarkersCollection.SetParentChart Method

public Void SetParentChart(Chart chart)

See Also

MarkersCollection Class | MarkersCollection Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.MarkersCollectionProperties

Steema.TeeChart.Tools.MarkersCollection Properties

Public Properties

Item

See Also

MarkersCollection Class | Steema.TeeChart.Tools Namespace


Item

Steema.TeeChart.Tools.MarkersCollection.Item Property

public Marker Item(Int32 index) {get; set;}

See Also

MarkersCollection Class | MarkersCollection Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.PageNumber

Steema.TeeChart.Tools.PageNumber Class

PageNumber annotation tool.

For a list of all members of this type, see PageNumber Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.Annotation
public class PageNumber : Annotation , ICloneable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

PageNumber members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.PageNumberMembers

Steema.TeeChart.Tools.PageNumber all Members

PageNumber overview

Constructors

Constructor Overloaded

Public Methods

Clone (inherited from Tool) |
EditorKey (inherited from Annotation) | The method passed to the KeyDown event by default.
EndEdit (inherited from Annotation) | Stops the Annotation from further editing.
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
StartEdit (inherited from Annotation) | Puts the Annotation into edit mode.
ToString (inherited from Tool) |

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
AllowEdit (inherited from Annotation) | Allows the Text of the Tool to be edited.
AutoSize (inherited from Annotation) | Set to true to permit custom sizing of TextShape.
Bounds (inherited from Annotation) | The rectangular bounds of the annotation tool.
Callout (inherited from Annotation) |
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from Annotation) |
Cursor (inherited from Annotation) |
Description | Gets descriptive text.
Format | Defines the format of the PageNumTool text string.
Height (inherited from Annotation) | Sets a custom width.
Left (inherited from Annotation) | Sets horizontal displacement in pixels of text box from Chart's left edge.
Position (inherited from Annotation) | Defines a default position for the Annotation Tool text box and text.
PositionUnits (inherited from Annotation) | Defines Annotation Position units (pixels or percentage).
Shape (inherited from Annotation) | Sets characteristics of the Annotation Tool text and text box Shape.
Summary (inherited from Annotation) | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from Annotation) | Defines the text for the Annotation Tool.
TextAlign (inherited from Annotation) |
Top (inherited from Annotation) | Sets vertical displacement in pixels of text box from Chart's top edge.
Width (inherited from Annotation) | Sets a custom width.

See Also

PageNumber Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.PageNumber Constructor

Overload List

public PageNumber()
public PageNumber(Steema.TeeChart.Chart)

See Also

PageNumber Class | PageNumber Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.PageNumber Constructor

public PageNumber(Chart c)

See Also

PageNumber Constructor Overload List | PageNumber Class | PageNumber Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.PageNumber Constructor

public PageNumber()

See Also

PageNumber Constructor Overload List | PageNumber Class | PageNumber Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.PageNumberMethods

Steema.TeeChart.Tools.PageNumber Methods

Public Methods

Clone (inherited from Tool) |
EditorKey (inherited from Annotation) | The method passed to the KeyDown event by default.
EndEdit (inherited from Annotation) | Stops the Annotation from further editing.
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
StartEdit (inherited from Annotation) | Puts the Annotation into edit mode.
ToString (inherited from Tool) |

See Also

PageNumber Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.PageNumberProperties

Steema.TeeChart.Tools.PageNumber Properties

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
AllowEdit (inherited from Annotation) | Allows the Text of the Tool to be edited.
AutoSize (inherited from Annotation) | Set to true to permit custom sizing of TextShape.
Bounds (inherited from Annotation) | The rectangular bounds of the annotation tool.
Callout (inherited from Annotation) |
Chart (inherited from TeeBase) | Chart associated with this object
ClipText (inherited from Annotation) |
Cursor (inherited from Annotation) |
Description | Gets descriptive text.
Format | Defines the format of the PageNumTool text string.
Height (inherited from Annotation) | Sets a custom width.
Left (inherited from Annotation) | Sets horizontal displacement in pixels of text box from Chart's left edge.
Position (inherited from Annotation) | Defines a default position for the Annotation Tool text box and text.
PositionUnits (inherited from Annotation) | Defines Annotation Position units (pixels or percentage).
Shape (inherited from Annotation) | Sets characteristics of the Annotation Tool text and text box Shape.
Summary (inherited from Annotation) | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Text (inherited from Annotation) | Defines the text for the Annotation Tool.
TextAlign (inherited from Annotation) |
Top (inherited from Annotation) | Sets vertical displacement in pixels of text box from Chart's top edge.
Width (inherited from Annotation) | Sets a custom width.

See Also

PageNumber Class | Steema.TeeChart.Tools Namespace


Description

Steema.TeeChart.Tools.PageNumber.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

PageNumber Class | PageNumber Members | Steema.TeeChart.Tools Namespace


Format

Steema.TeeChart.Tools.PageNumber.Format Property

Defines the format of the PageNumTool text string.
public String Format {get; set;}

See Also

PageNumber Class | PageNumber Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesBandTool

Steema.TeeChart.Tools.SeriesBandTool Class

Series-Band tool. Use it to display a band between two (line) series. created 2003-12-14 by mkaul@leuze.de

For a list of all members of this type, see SeriesBandTool Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class SeriesBandTool : ToolSeries , ICloneable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

SeriesBandTool members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesBandToolMembers

Steema.TeeChart.Tools.SeriesBandTool all Members

SeriesBandTool overview

Constructors

Constructor Overloaded

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
BoundValue | Gets and sets a constant value to be used as one of the limits of band filled areas. Note: BoundValue property is only used when the Series2 property is not set (ie: is null).
Brush | Element Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
Description | Gets descriptive text.
DrawBehindSeries | Gets and sets a flag which causes filling to occur before or after the series are displayed.
GetHorizAxis (inherited from ToolSeries) | Returns the associated Top or Bottom Chart Horizontal Axis.
GetVertAxis (inherited from ToolSeries) | Returns the associated Left or Right Chart Vertical Axis.
Gradient | The gradient colors used to fill the area between the two series.
Pen | Element Pen characteristics.
Series (inherited from ToolSeries) | Sets Series with which Tools are associated.
Series2 | Gets and sets the second series associated to this tool. SeriesBand tool needs two series to fill the area in between them.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency | The amount of semi-glass effect (opacity) to apply when filling the area between the two series.

See Also

SeriesBandTool Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesBandTool Constructor

Overload List

public SeriesBandTool()
public SeriesBandTool(Steema.TeeChart.Chart)

See Also

SeriesBandTool Class | SeriesBandTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesBandTool Constructor

public SeriesBandTool(Chart c)

See Also

SeriesBandTool Constructor Overload List | SeriesBandTool Class | SeriesBandTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesBandTool Constructor

public SeriesBandTool()

See Also

SeriesBandTool Constructor Overload List | SeriesBandTool Class | SeriesBandTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesBandToolMethods

Steema.TeeChart.Tools.SeriesBandTool Methods

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

See Also

SeriesBandTool Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesBandToolProperties

Steema.TeeChart.Tools.SeriesBandTool Properties

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
BoundValue | Gets and sets a constant value to be used as one of the limits of band filled areas. Note: BoundValue property is only used when the Series2 property is not set (ie: is null).
Brush | Element Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
Description | Gets descriptive text.
DrawBehindSeries | Gets and sets a flag which causes filling to occur before or after the series are displayed.
GetHorizAxis (inherited from ToolSeries) | Returns the associated Top or Bottom Chart Horizontal Axis.
GetVertAxis (inherited from ToolSeries) | Returns the associated Left or Right Chart Vertical Axis.
Gradient | The gradient colors used to fill the area between the two series.
Pen | Element Pen characteristics.
Series (inherited from ToolSeries) | Sets Series with which Tools are associated.
Series2 | Gets and sets the second series associated to this tool. SeriesBand tool needs two series to fill the area in between them.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency | The amount of semi-glass effect (opacity) to apply when filling the area between the two series.

See Also

SeriesBandTool Class | Steema.TeeChart.Tools Namespace


BoundValue

Steema.TeeChart.Tools.SeriesBandTool.BoundValue Property

Gets and sets a constant value to be used as one of the limits of band filled areas. Note: BoundValue property is only used when the Series2 property is not set (ie: is null).
public Double BoundValue {get; set;}

See Also

SeriesBandTool Class | SeriesBandTool Members | Steema.TeeChart.Tools Namespace


Brush

Steema.TeeChart.Tools.SeriesBandTool.Brush Property

Element Brush characteristics.
public ChartBrush Brush {get; set;}

See Also

SeriesBandTool Class | SeriesBandTool Members | Steema.TeeChart.Tools Namespace


Description

Steema.TeeChart.Tools.SeriesBandTool.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

SeriesBandTool Class | SeriesBandTool Members | Steema.TeeChart.Tools Namespace


DrawBehindSeries

Steema.TeeChart.Tools.SeriesBandTool.DrawBehindSeries Property

Gets and sets a flag which causes filling to occur before or after the series are displayed.
public Boolean DrawBehindSeries {get; set;}

See Also

SeriesBandTool Class | SeriesBandTool Members | Steema.TeeChart.Tools Namespace


Gradient

Steema.TeeChart.Tools.SeriesBandTool.Gradient Property

The gradient colors used to fill the area between the two series.
public Gradient Gradient {get; set;}

See Also

SeriesBandTool Class | SeriesBandTool Members | Steema.TeeChart.Tools Namespace


Pen

Steema.TeeChart.Tools.SeriesBandTool.Pen Property

Element Pen characteristics.
public ChartPen Pen {get; set;}

See Also

SeriesBandTool Class | SeriesBandTool Members | Steema.TeeChart.Tools Namespace


Series2

Steema.TeeChart.Tools.SeriesBandTool.Series2 Property

Gets and sets the second series associated to this tool. SeriesBand tool needs two series to fill the area in between them.
public Series Series2 {get; set;}

See Also

SeriesBandTool Class | SeriesBandTool Members | Steema.TeeChart.Tools Namespace


Summary

Steema.TeeChart.Tools.SeriesBandTool.Summary Property

Gets detailed descriptive text.
public override String Summary {get;}

See Also

SeriesBandTool Class | SeriesBandTool Members | Steema.TeeChart.Tools Namespace


Transparency

Steema.TeeChart.Tools.SeriesBandTool.Transparency Property

The amount of semi-glass effect (opacity) to apply when filling the area between the two series.
public Int32 Transparency {get; set;}

See Also

SeriesBandTool Class | SeriesBandTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesRegionTool

Steema.TeeChart.Tools.SeriesRegionTool Class

Series region Tool. It colors bounded area under the (series) curve.

For a list of all members of this type, see SeriesRegionTool Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class SeriesRegionTool : ToolSeries , ICloneable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

SeriesRegionTool members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesRegionToolMembers

Steema.TeeChart.Tools.SeriesRegionTool all Members

SeriesRegionTool overview

Constructors

Constructor Overloaded

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
AutoBound | If true, region left and right bounds are equal to series minimum and maximum x value.
Brush | Element Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
Color | Sets region Color.
Description | Gets descriptive text.
DrawBehindSeries | If true, draw region behind series. If false, draw region over series.
GetHorizAxis (inherited from ToolSeries) | Returns the associated Top or Bottom Chart Horizontal Axis.
GetVertAxis (inherited from ToolSeries) | Returns the associated Left or Right Chart Vertical Axis.
Gradient | Sets region colour gradient.
LowerBound | Defines region left (series not mandatory values) lower bound.
Origin | Region bottom or upper limit. Used only if is true.
Pen | Element Pen characteristics.
Series (inherited from ToolSeries) | Sets Series with which Tools are associated.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency | Sets the Transparency of region as percentage.
UpperBound | Defines region right (series not mandatory values) upper bound.
UseOrigin | If true, region bottom or upper limit is defined by .

See Also

SeriesRegionTool Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesRegionTool Constructor

Overload List

public SeriesRegionTool()
public SeriesRegionTool(Steema.TeeChart.Chart)

See Also

SeriesRegionTool Class | SeriesRegionTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesRegionTool Constructor

public SeriesRegionTool(Chart c)

See Also

SeriesRegionTool Constructor Overload List | SeriesRegionTool Class | SeriesRegionTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesRegionTool Constructor

public SeriesRegionTool()

See Also

SeriesRegionTool Constructor Overload List | SeriesRegionTool Class | SeriesRegionTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesRegionToolMethods

Steema.TeeChart.Tools.SeriesRegionTool Methods

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

See Also

SeriesRegionTool Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesRegionToolProperties

Steema.TeeChart.Tools.SeriesRegionTool Properties

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
AutoBound | If true, region left and right bounds are equal to series minimum and maximum x value.
Brush | Element Brush characteristics.
Chart (inherited from TeeBase) | Chart associated with this object
Color | Sets region Color.
Description | Gets descriptive text.
DrawBehindSeries | If true, draw region behind series. If false, draw region over series.
GetHorizAxis (inherited from ToolSeries) | Returns the associated Top or Bottom Chart Horizontal Axis.
GetVertAxis (inherited from ToolSeries) | Returns the associated Left or Right Chart Vertical Axis.
Gradient | Sets region colour gradient.
LowerBound | Defines region left (series not mandatory values) lower bound.
Origin | Region bottom or upper limit. Used only if is true.
Pen | Element Pen characteristics.
Series (inherited from ToolSeries) | Sets Series with which Tools are associated.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Transparency | Sets the Transparency of region as percentage.
UpperBound | Defines region right (series not mandatory values) upper bound.
UseOrigin | If true, region bottom or upper limit is defined by .

See Also

SeriesRegionTool Class | Steema.TeeChart.Tools Namespace


AutoBound

Steema.TeeChart.Tools.SeriesRegionTool.AutoBound Property

If true, region left and right bounds are equal to series minimum and maximum x value.
public Boolean AutoBound {get; set;}

See Also

SeriesRegionTool Class | SeriesRegionTool Members | Steema.TeeChart.Tools Namespace


Brush

Steema.TeeChart.Tools.SeriesRegionTool.Brush Property

Element Brush characteristics.
public ChartBrush Brush {get; set;}

See Also

SeriesRegionTool Class | SeriesRegionTool Members | Steema.TeeChart.Tools Namespace


Color

Steema.TeeChart.Tools.SeriesRegionTool.Color Property

Sets region Color.
public Color Color {get; set;}

See Also

SeriesRegionTool Class | SeriesRegionTool Members | Steema.TeeChart.Tools Namespace


Description

Steema.TeeChart.Tools.SeriesRegionTool.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

SeriesRegionTool Class | SeriesRegionTool Members | Steema.TeeChart.Tools Namespace


DrawBehindSeries

Steema.TeeChart.Tools.SeriesRegionTool.DrawBehindSeries Property

If true, draw region behind series. If false, draw region over series.
public Boolean DrawBehindSeries {get; set;}

See Also

SeriesRegionTool Class | SeriesRegionTool Members | Steema.TeeChart.Tools Namespace


Gradient

Steema.TeeChart.Tools.SeriesRegionTool.Gradient Property

Sets region colour gradient.
public Gradient Gradient {get;}

See Also

SeriesRegionTool Class | SeriesRegionTool Members | Steema.TeeChart.Tools Namespace


LowerBound

Steema.TeeChart.Tools.SeriesRegionTool.LowerBound Property

Defines region left (series not mandatory values) lower bound.
public Double LowerBound {get; set;}

See Also

SeriesRegionTool Class | SeriesRegionTool Members | Steema.TeeChart.Tools Namespace


Origin

Steema.TeeChart.Tools.SeriesRegionTool.Origin Property

Region bottom or upper limit. Used only if is true.
public Double Origin {get; set;}

See Also

SeriesRegionTool Class | SeriesRegionTool Members | Steema.TeeChart.Tools Namespace | UseOrigin


Pen

Steema.TeeChart.Tools.SeriesRegionTool.Pen Property

Element Pen characteristics.
public ChartPen Pen {get; set;}

See Also

SeriesRegionTool Class | SeriesRegionTool Members | Steema.TeeChart.Tools Namespace


Summary

Steema.TeeChart.Tools.SeriesRegionTool.Summary Property

Gets detailed descriptive text.
public override String Summary {get;}

See Also

SeriesRegionTool Class | SeriesRegionTool Members | Steema.TeeChart.Tools Namespace


Transparency

Steema.TeeChart.Tools.SeriesRegionTool.Transparency Property

Sets the Transparency of region as percentage.
public Int32 Transparency {get; set;}

See Also

SeriesRegionTool Class | SeriesRegionTool Members | Steema.TeeChart.Tools Namespace


UpperBound

Steema.TeeChart.Tools.SeriesRegionTool.UpperBound Property

Defines region right (series not mandatory values) upper bound.
public Double UpperBound {get; set;}

See Also

SeriesRegionTool Class | SeriesRegionTool Members | Steema.TeeChart.Tools Namespace


UseOrigin

Steema.TeeChart.Tools.SeriesRegionTool.UseOrigin Property

If true, region bottom or upper limit is defined by .
public Boolean UseOrigin {get; set;}

See Also

SeriesRegionTool Class | SeriesRegionTool Members | Steema.TeeChart.Tools Namespace | Origin


Steema.TeeChart.Tools.SeriesStats

Steema.TeeChart.Tools.SeriesStats Class

Calculates basic series statistics.

For a list of all members of this type, see SeriesStats Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class SeriesStats : ToolSeries , ICloneable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

SeriesStats members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesStatsMembers

Steema.TeeChart.Tools.SeriesStats all Members

SeriesStats overview

Constructors

Constructor Overloaded

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Chart (inherited from TeeBase) | Chart associated with this object
Description |
GetHorizAxis (inherited from ToolSeries) | Returns the associated Top or Bottom Chart Horizontal Axis.
GetVertAxis (inherited from ToolSeries) | Returns the associated Left or Right Chart Vertical Axis.
Series (inherited from ToolSeries) | Sets Series with which Tools are associated.
Statistics | Statistics report in text form.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

SeriesStats Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesStats Constructor

Overload List

public SeriesStats()
public SeriesStats(Steema.TeeChart.Chart)

See Also

SeriesStats Class | SeriesStats Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesStats Constructor

public SeriesStats(Chart c)

See Also

SeriesStats Constructor Overload List | SeriesStats Class | SeriesStats Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesStats Constructor

public SeriesStats()

See Also

SeriesStats Constructor Overload List | SeriesStats Class | SeriesStats Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesStatsMethods

Steema.TeeChart.Tools.SeriesStats Methods

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

See Also

SeriesStats Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesStatsProperties

Steema.TeeChart.Tools.SeriesStats Properties

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Chart (inherited from TeeBase) | Chart associated with this object
Description |
GetHorizAxis (inherited from ToolSeries) | Returns the associated Top or Bottom Chart Horizontal Axis.
GetVertAxis (inherited from ToolSeries) | Returns the associated Left or Right Chart Vertical Axis.
Series (inherited from ToolSeries) | Sets Series with which Tools are associated.
Statistics | Statistics report in text form.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

SeriesStats Class | Steema.TeeChart.Tools Namespace


Description

Steema.TeeChart.Tools.SeriesStats.Description Property

public override String Description {get;}

See Also

SeriesStats Class | SeriesStats Members | Steema.TeeChart.Tools Namespace


Statistics

Steema.TeeChart.Tools.SeriesStats.Statistics Property

Statistics report in text form.
public String Statistics {get;}

See Also

SeriesStats Class | SeriesStats Members | Steema.TeeChart.Tools Namespace


Summary

Steema.TeeChart.Tools.SeriesStats.Summary Property

Gets detailed descriptive text.
public override String Summary {get;}

See Also

SeriesStats Class | SeriesStats Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesTranspose

Steema.TeeChart.Tools.SeriesTranspose Class

Transpose multiple series (swap rows and columns).

For a list of all members of this type, see SeriesTranspose Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
public class SeriesTranspose : Tool , ICloneable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

SeriesTranspose members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesTransposeMembers

Steema.TeeChart.Tools.SeriesTranspose all Members

SeriesTranspose overview

Constructors

Constructor Overloaded

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |
Transpose |

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Chart (inherited from TeeBase) | Chart associated with this object
Description | Gets descriptive text.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

SeriesTranspose Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesTranspose Constructor

Overload List

public SeriesTranspose()
public SeriesTranspose(Steema.TeeChart.Chart)

See Also

SeriesTranspose Class | SeriesTranspose Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesTranspose Constructor

public SeriesTranspose(Chart c)

See Also

SeriesTranspose Constructor Overload List | SeriesTranspose Class | SeriesTranspose Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesTranspose Constructor

public SeriesTranspose()

See Also

SeriesTranspose Constructor Overload List | SeriesTranspose Class | SeriesTranspose Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesTransposeMethods

Steema.TeeChart.Tools.SeriesTranspose Methods

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |
Transpose |

See Also

SeriesTranspose Class | Steema.TeeChart.Tools Namespace


Transpose

Steema.TeeChart.Tools.SeriesTranspose.Transpose Method

public Void Transpose()

See Also

SeriesTranspose Class | SeriesTranspose Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SeriesTransposeProperties

Steema.TeeChart.Tools.SeriesTranspose Properties

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Chart (inherited from TeeBase) | Chart associated with this object
Description | Gets descriptive text.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

SeriesTranspose Class | Steema.TeeChart.Tools Namespace


Description

Steema.TeeChart.Tools.SeriesTranspose.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

SeriesTranspose Class | SeriesTranspose Members | Steema.TeeChart.Tools Namespace


Summary

Steema.TeeChart.Tools.SeriesTranspose.Summary Property

Gets detailed descriptive text.
public override String Summary {get;}

See Also

SeriesTranspose Class | SeriesTranspose Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SubChart

Steema.TeeChart.Tools.SubChart Class

For a list of all members of this type, see SubChart Members

System.Object
public class SubChart : Object

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

SubChart members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SubChartMembers

Steema.TeeChart.Tools.SubChart all Members

SubChart overview

Constructors

Constructor Overloaded

Public Methods

Bounds
Clicked

Public Properties

Chart |
Data |
Height | Sets the Chart Height in pixels.
ITool |
Left | Sets the Chart Left position in pixels.
Top | Sets the Chart Top position in pixels.
Width | Sets the Chart Width in pixels.

See Also

SubChart Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SubChart Constructor

Overload List

public SubChart()
public SubChart(Steema.TeeChart.Chart)
public SubChart(Steema.TeeChart.Tools.ChartCollection)

See Also

SubChart Class | SubChart Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SubChart Constructor

public SubChart(ChartCollection collection)

See Also

SubChart Constructor Overload List | SubChart Class | SubChart Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SubChart Constructor

public SubChart(Chart c)

See Also

SubChart Constructor Overload List | SubChart Class | SubChart Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SubChart Constructor

public SubChart()

See Also

SubChart Constructor Overload List | SubChart Class | SubChart Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SubChartMethods

Steema.TeeChart.Tools.SubChart Methods

Public Methods

Bounds
Clicked

See Also

SubChart Class | Steema.TeeChart.Tools Namespace


Bounds

Steema.TeeChart.Tools.SubChart.Bounds Method

public Rectangle Bounds()

See Also

SubChart Class | SubChart Members | Steema.TeeChart.Tools Namespace


Clicked

Steema.TeeChart.Tools.SubChart.Clicked Method

public Boolean Clicked(Int32 X,
     Int32 Y)

See Also

SubChart Class | SubChart Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SubChartProperties

Steema.TeeChart.Tools.SubChart Properties

Public Properties

Chart |
Data |
Height | Sets the Chart Height in pixels.
ITool |
Left | Sets the Chart Left position in pixels.
Top | Sets the Chart Top position in pixels.
Width | Sets the Chart Width in pixels.

See Also

SubChart Class | Steema.TeeChart.Tools Namespace


Chart

Steema.TeeChart.Tools.SubChart.Chart Property

public TChart Chart {get; set;}

See Also

SubChart Class | SubChart Members | Steema.TeeChart.Tools Namespace


Data

Steema.TeeChart.Tools.SubChart.Data Property

public String Data {get; set;}

See Also

SubChart Class | SubChart Members | Steema.TeeChart.Tools Namespace


Height

Steema.TeeChart.Tools.SubChart.Height Property

Sets the Chart Height in pixels.
public Int32 Height {get; set;}

See Also

SubChart Class | SubChart Members | Steema.TeeChart.Tools Namespace


ITool

Steema.TeeChart.Tools.SubChart.ITool Property

public Tool ITool {get; set;}

See Also

SubChart Class | SubChart Members | Steema.TeeChart.Tools Namespace


Left

Steema.TeeChart.Tools.SubChart.Left Property

Sets the Chart Left position in pixels.
public Int32 Left {get; set;}

See Also

SubChart Class | SubChart Members | Steema.TeeChart.Tools Namespace


Top

Steema.TeeChart.Tools.SubChart.Top Property

Sets the Chart Top position in pixels.
public Int32 Top {get; set;}

See Also

SubChart Class | SubChart Members | Steema.TeeChart.Tools Namespace


Width

Steema.TeeChart.Tools.SubChart.Width Property

Sets the Chart Width in pixels.
public Int32 Width {get; set;}

See Also

SubChart Class | SubChart Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SubChartTool

Steema.TeeChart.Tools.SubChartTool Class

Annotation tool.

For a list of all members of this type, see SubChartTool Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
public class SubChartTool : Tool , ICloneable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

SubChartTool members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SubChartToolMembers

Steema.TeeChart.Tools.SubChartTool all Members

SubChartTool overview

Constructors

Constructor Overloaded

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Chart (inherited from TeeBase) | Chart associated with this object
Charts | The collection of charts within the subchart tool.
Description | Gets descriptive text.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

SubChartTool Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SubChartTool Constructor

Overload List

public SubChartTool()
public SubChartTool(Steema.TeeChart.Chart)

See Also

SubChartTool Class | SubChartTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SubChartTool Constructor

public SubChartTool(Chart c)

See Also

SubChartTool Constructor Overload List | SubChartTool Class | SubChartTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SubChartTool Constructor

public SubChartTool()

See Also

SubChartTool Constructor Overload List | SubChartTool Class | SubChartTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SubChartToolMethods

Steema.TeeChart.Tools.SubChartTool Methods

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

See Also

SubChartTool Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.SubChartToolProperties

Steema.TeeChart.Tools.SubChartTool Properties

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Chart (inherited from TeeBase) | Chart associated with this object
Charts | The collection of charts within the subchart tool.
Description | Gets descriptive text.
Summary | Gets detailed descriptive text.
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

SubChartTool Class | Steema.TeeChart.Tools Namespace


Charts

Steema.TeeChart.Tools.SubChartTool.Charts Property

The collection of charts within the subchart tool.
public ChartCollection Charts {get;}

See Also

SubChartTool Class | SubChartTool Members | Steema.TeeChart.Tools Namespace


Description

Steema.TeeChart.Tools.SubChartTool.Description Property

Gets descriptive text.
public override String Description {get;}

See Also

SubChartTool Class | SubChartTool Members | Steema.TeeChart.Tools Namespace


Summary

Steema.TeeChart.Tools.SubChartTool.Summary Property

Gets detailed descriptive text.
public override String Summary {get;}

See Also

SubChartTool Class | SubChartTool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.TableLegend

Steema.TeeChart.Tools.TableLegend Class

Legend shape.

For a list of all members of this type, see TableLegend Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
public class TableLegend : Shape , ICloneable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

TableLegend members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.TableLegendMembers

Steema.TeeChart.Tools.TableLegend all Members

TableLegend overview

Constructors

Constructor Overloaded

Public Methods

Assign (inherited from Shape) | Assign all properties from a shape to another.
Clone (inherited from Shape) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from Shape) |

Public Properties

Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Shape) | Defines the shape Color.
Font |
FontSeriesColor |
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
OtherSide |
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
Symbol |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

TableLegend Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.TableLegend Constructor

Overload List

public TableLegend()
public TableLegend(Steema.TeeChart.Chart)

See Also

TableLegend Class | TableLegend Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.TableLegend Constructor

public TableLegend(Chart c)

See Also

TableLegend Constructor Overload List | TableLegend Class | TableLegend Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.TableLegend Constructor

public TableLegend()

See Also

TableLegend Constructor Overload List | TableLegend Class | TableLegend Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.TableLegendMethods

Steema.TeeChart.Tools.TableLegend Methods

Public Methods

Assign (inherited from Shape) | Assign all properties from a shape to another.
Clone (inherited from Shape) |
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
Paint (inherited from Shape) |

See Also

TableLegend Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.TableLegendProperties

Steema.TeeChart.Tools.TableLegend Properties

Public Properties

Bevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
BevelInner (inherited from Shape) |
BevelOuter (inherited from Shape) |
BevelWidth (inherited from Shape) |
BorderRound (inherited from Shape) | Rounds the Borders of the Chart Shapes.
Bottom (inherited from Shape) | Shape rectangle bottom co-ordinate
Brush (inherited from Shape) | Defines the kind of brush used to fill shape background.
Chart (inherited from TeeBase) | Chart associated with this object
Color (inherited from Shape) | Defines the shape Color.
Font |
FontSeriesColor |
Gradient (inherited from Shape) | Calls the Gradient characteristics for the shape.
Height (inherited from Shape) | The Height of the shape.
Image (inherited from Shape) | Rendered Image for Shape background
ImageBevel (inherited from Shape) | Sets the bevel characteristics of the Shape.
ImageMode (inherited from Shape) | ImageMode for rendered Shape background Image
ImageTransparent (inherited from Shape) | Sets the shape image to transparent.
Left (inherited from Shape) | Shape rectangle left co-ordinate
OtherSide |
Pen (inherited from Shape) | Specifies the pen used to draw the shape.
Right (inherited from Shape) | Shape rectangle right co-ordinate
Shadow (inherited from Shape) | Defines the shape's Shadow characteristics.
ShapeBounds (inherited from Shape) | Defines the boundaries of the Shape.
Symbol |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.
Top (inherited from Shape) | Shape rectangle top co-ordinate
Transparency (inherited from Shape) | Sets Transparency level from 0 to 100% of shape.
Transparent (inherited from Shape) | Enables/disables transparency of shape.
Visible (inherited from Shape) | Shows or hides the Shape.
Width (inherited from Shape) | The Width of the shape.

See Also

TableLegend Class | Steema.TeeChart.Tools Namespace


Font

Steema.TeeChart.Tools.TableLegend.Font Property

public ChartFont Font {get; set;}

See Also

TableLegend Class | TableLegend Members | Steema.TeeChart.Tools Namespace


FontSeriesColor

Steema.TeeChart.Tools.TableLegend.FontSeriesColor Property

public Boolean FontSeriesColor {get; set;}

See Also

TableLegend Class | TableLegend Members | Steema.TeeChart.Tools Namespace


OtherSide

Steema.TeeChart.Tools.TableLegend.OtherSide Property

public Boolean OtherSide {get; set;}

See Also

TableLegend Class | TableLegend Members | Steema.TeeChart.Tools Namespace


Symbol

Steema.TeeChart.Tools.TableLegend.Symbol Property

public LegendSymbol Symbol {get; set;}

See Also

TableLegend Class | TableLegend Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.Tool

Steema.TeeChart.Tools.Tool Class

Base Tool class.

For a list of all members of this type, see Tool Members

System.Object
Steema.TeeChart.Drawing.TeeBase
public class Tool : TeeBase , ICloneable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

Tool members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolMembers

Steema.TeeChart.Tools.Tool all Members

Tool overview

Public Fields

ClickTolerance

Public Methods

Clone |
CreateNewTool | Creates a new Tool object and sets the Name and Chart properties.
GetBitmapEditor | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
NewFromType | Creates a new tool from the System.Type of an existing tools object.
ToString |

Public Properties

Active | Enables/Disables the indexed Tool.
Chart (inherited from TeeBase) | Chart associated with this object
Description |
Summary |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Tool Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolFields

Steema.TeeChart.Tools.Tool Fields

Public Fields

ClickTolerance

See Also

Tool Class | Steema.TeeChart.Tools Namespace


ClickTolerance

Steema.TeeChart.Tools.Tool.ClickTolerance Field

public const Int32 ClickTolerance

See Also

Tool Class | Tool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolMethods

Steema.TeeChart.Tools.Tool Methods

Public Methods

Clone |
CreateNewTool | Creates a new Tool object and sets the Name and Chart properties.
GetBitmapEditor | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
NewFromType | Creates a new tool from the System.Type of an existing tools object.
ToString |

See Also

Tool Class | Steema.TeeChart.Tools Namespace


Clone

Steema.TeeChart.Tools.Tool.Clone Method

public virtual Object Clone()

See Also

Tool Class | Tool Members | Steema.TeeChart.Tools Namespace


CreateNewTool

Steema.TeeChart.Tools.Tool.CreateNewTool Method

Creates a new Tool object and sets the Name and Chart properties.
public static Tool CreateNewTool(Chart chart,
     Type type)

See Also

Tool Class | Tool Members | Steema.TeeChart.Tools Namespace


GetBitmapEditor

Steema.TeeChart.Tools.Tool.GetBitmapEditor Method

Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
public Bitmap GetBitmapEditor()

See Also

Tool Class | Tool Members | Steema.TeeChart.Tools Namespace


NewFromType

Steema.TeeChart.Tools.Tool.NewFromType Method

Creates a new tool from the System.Type of an existing tools object.
public static Tool NewFromType(Type type)

See Also

Tool Class | Tool Members | Steema.TeeChart.Tools Namespace


ToString

Steema.TeeChart.Tools.Tool.ToString Method

public override String ToString()

See Also

Tool Class | Tool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolProperties

Steema.TeeChart.Tools.Tool Properties

Public Properties

Active | Enables/Disables the indexed Tool.
Chart (inherited from TeeBase) | Chart associated with this object
Description |
Summary |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

Tool Class | Steema.TeeChart.Tools Namespace


Active

Steema.TeeChart.Tools.Tool.Active Property

Enables/Disables the indexed Tool.
public Boolean Active {get; set;}

See Also

Tool Class | Tool Members | Steema.TeeChart.Tools Namespace


Description

Steema.TeeChart.Tools.Tool.Description Property

public abstract String Description {get;}

See Also

Tool Class | Tool Members | Steema.TeeChart.Tools Namespace


Summary

Steema.TeeChart.Tools.Tool.Summary Property

public abstract String Summary {get;}

See Also

Tool Class | Tool Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolAxis

Steema.TeeChart.Tools.ToolAxis Class

Base abstract class for Tool components with an Axis property.

For a list of all members of this type, see ToolAxis Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
public class ToolAxis : Tool , ICloneable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

ToolAxis members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolAxisMembers

Steema.TeeChart.Tools.ToolAxis all Members

ToolAxis overview

Constructors

Constructor Overloaded

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Axis | Sets the axis to which a Tool will belong.
Chart (inherited from TeeBase) | Chart associated with this object
Description (inherited from Tool) |
Pen | Element Pen characteristics.
Summary (inherited from Tool) |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

ToolAxis Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolAxis Constructor

Overload List

public ToolAxis()
public ToolAxis(Steema.TeeChart.Chart)
public ToolAxis(Steema.TeeChart.Axis)

See Also

ToolAxis Class | ToolAxis Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolAxis Constructor

public ToolAxis(Axis a)

See Also

ToolAxis Constructor Overload List | ToolAxis Class | ToolAxis Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolAxis Constructor

public ToolAxis(Chart c)

See Also

ToolAxis Constructor Overload List | ToolAxis Class | ToolAxis Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolAxis Constructor

public ToolAxis()

See Also

ToolAxis Constructor Overload List | ToolAxis Class | ToolAxis Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolAxisMethods

Steema.TeeChart.Tools.ToolAxis Methods

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

See Also

ToolAxis Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolAxisProperties

Steema.TeeChart.Tools.ToolAxis Properties

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Axis | Sets the axis to which a Tool will belong.
Chart (inherited from TeeBase) | Chart associated with this object
Description (inherited from Tool) |
Pen | Element Pen characteristics.
Summary (inherited from Tool) |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

ToolAxis Class | Steema.TeeChart.Tools Namespace


Axis

Steema.TeeChart.Tools.ToolAxis.Axis Property

Sets the axis to which a Tool will belong.
public Axis Axis {get; set;}

See Also

ToolAxis Class | ToolAxis Members | Steema.TeeChart.Tools Namespace


Pen

Steema.TeeChart.Tools.ToolAxis.Pen Property

Element Pen characteristics.
public ChartPen Pen {get; set;}

See Also

ToolAxis Class | ToolAxis Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolsCollection

Steema.TeeChart.Tools.ToolsCollection Class

Collection of Tool components.

For a list of all members of this type, see ToolsCollection Members

System.Object
System.Collections.CollectionBase
public class ToolsCollection : CollectionBase , IList, ICollection
, IEnumerable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

ToolsCollection members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolsCollectionMembers

Steema.TeeChart.Tools.ToolsCollection all Members

ToolsCollection overview

Constructors

Constructor

Public Fields

chart

Public Methods

Add | Adds a new tool to your TChart.
Clear | Removes (and optionally disposes) all Series.
IndexOf | Returns the corresponding point index which has the specified Value.
Remove | Removes a tool from the TChart.

Public Properties

Item

See Also

ToolsCollection Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolsCollection Constructor

public ToolsCollection(Chart c)

See Also

ToolsCollection Class | ToolsCollection Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolsCollectionFields

Steema.TeeChart.Tools.ToolsCollection Fields

Public Fields

chart

See Also

ToolsCollection Class | Steema.TeeChart.Tools Namespace


chart

Steema.TeeChart.Tools.ToolsCollection.chart Field

public Chart chart

See Also

ToolsCollection Class | ToolsCollection Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolsCollectionMethods

Steema.TeeChart.Tools.ToolsCollection Methods

Public Methods

Add | Adds a new tool to your TChart.
Clear | Removes (and optionally disposes) all Series.
IndexOf | Returns the corresponding point index which has the specified Value.
Remove | Removes a tool from the TChart.

See Also

ToolsCollection Class | Steema.TeeChart.Tools Namespace


Add

Steema.TeeChart.Tools.ToolsCollection.Add Method

Overload List

Adds a new tool to your TChart.

public Int32 Add(Steema.TeeChart.Tools.Tool)
public Int32 Add(System.Type)

See Also

ToolsCollection Class | ToolsCollection Members | Steema.TeeChart.Tools Namespace


Add

Steema.TeeChart.Tools.ToolsCollection.Add Method

public Int32 Add(Type tool)

See Also

Add Overload List | ToolsCollection Class | ToolsCollection Members | Steema.TeeChart.Tools Namespace


Add

Steema.TeeChart.Tools.ToolsCollection.Add Method

Adds a new tool to your TChart.
public Int32 Add(Tool tool)

See Also

Add Overload List | ToolsCollection Class | ToolsCollection Members | Steema.TeeChart.Tools Namespace


Clear

Steema.TeeChart.Tools.ToolsCollection.Clear Method

Overload List

Removes (and optionally disposes) all Series.

public override Void Clear(System.Boolean)

Removes and disposes all Series.

public Void Clear()

See Also

ToolsCollection Class | ToolsCollection Members | Steema.TeeChart.Tools Namespace


Clear

Steema.TeeChart.Tools.ToolsCollection.Clear Method

Removes and disposes all Series.
public Void Clear()

See Also

Clear Overload List | ToolsCollection Class | ToolsCollection Members | Steema.TeeChart.Tools Namespace


Clear

Steema.TeeChart.Tools.ToolsCollection.Clear Method

Removes (and optionally disposes) all Series.
public override Void Clear(Boolean dispose)

See Also

Clear Overload List | ToolsCollection Class | ToolsCollection Members | Steema.TeeChart.Tools Namespace


IndexOf

Steema.TeeChart.Tools.ToolsCollection.IndexOf Method

Returns the corresponding point index which has the specified Value.
public Int32 IndexOf(Tool s)

See Also

ToolsCollection Class | ToolsCollection Members | Steema.TeeChart.Tools Namespace


Remove

Steema.TeeChart.Tools.ToolsCollection.Remove Method

Removes a tool from the TChart.
public Void Remove(Tool s)

See Also

ToolsCollection Class | ToolsCollection Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolsCollectionProperties

Steema.TeeChart.Tools.ToolsCollection Properties

Public Properties

Item

See Also

ToolsCollection Class | Steema.TeeChart.Tools Namespace


Item

Steema.TeeChart.Tools.ToolsCollection.Item Property

public Tool Item(Int32 index) {get; set;}

See Also

ToolsCollection Class | ToolsCollection Members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolSeries

Steema.TeeChart.Tools.ToolSeries Class

Base abstract class for Tool components with a Series property.

For a list of all members of this type, see ToolSeries Members

System.Object
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
public class ToolSeries : Tool , ICloneable

Requirements

Namespace: Steema.TeeChart.Tools Namespace

Assembly: TeeChart.Android.dll

See Also

ToolSeries members | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolSeriesMembers

Steema.TeeChart.Tools.ToolSeries all Members

ToolSeries overview

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Chart (inherited from TeeBase) | Chart associated with this object
Description (inherited from Tool) |
GetHorizAxis | Returns the associated Top or Bottom Chart Horizontal Axis.
GetVertAxis | Returns the associated Left or Right Chart Vertical Axis.
Series | Sets Series with which Tools are associated.
Summary (inherited from Tool) |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

ToolSeries Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolSeriesMethods

Steema.TeeChart.Tools.ToolSeries Methods

Public Methods

Clone (inherited from Tool) |
GetBitmapEditor (inherited from Tool) | Returns the associated bitmap icon for a given Tool class. This icon is used at Tools gallery ListBox and Tools Editor dialog.
Invalidate (inherited from TeeBase) | Use Invalidate when the entire canvas needs to be repainted.
ToString (inherited from Tool) |

See Also

ToolSeries Class | Steema.TeeChart.Tools Namespace


Steema.TeeChart.Tools.ToolSeriesProperties

Steema.TeeChart.Tools.ToolSeries Properties

Public Properties

Active (inherited from Tool) | Enables/Disables the indexed Tool.
Chart (inherited from TeeBase) | Chart associated with this object
Description (inherited from Tool) |
GetHorizAxis | Returns the associated Top or Bottom Chart Horizontal Axis.
GetVertAxis | Returns the associated Left or Right Chart Vertical Axis.
Series | Sets Series with which Tools are associated.
Summary (inherited from Tool) |
Tag (inherited from TeeBase) | Gets or sets an object that provides additional data about the TChart object.

See Also

ToolSeries Class | Steema.TeeChart.Tools Namespace


GetHorizAxis

Steema.TeeChart.Tools.ToolSeries.GetHorizAxis Property

Returns the associated Top or Bottom Chart Horizontal Axis.
public Axis GetHorizAxis {get;}

See Also

ToolSeries Class | ToolSeries Members | Steema.TeeChart.Tools Namespace


GetVertAxis

Steema.TeeChart.Tools.ToolSeries.GetVertAxis Property

Returns the associated Left or Right Chart Vertical Axis.
public Axis GetVertAxis {get;}

See Also

ToolSeries Class | ToolSeries Members | Steema.TeeChart.Tools Namespace


Series

Steema.TeeChart.Tools.ToolSeries.Series Property

Sets Series with which Tools are associated.
public Series Series {get; set;}

See Also

ToolSeries Class | ToolSeries Members | Steema.TeeChart.Tools Namespace