TeeBI_API

Summary

Component library for data-mining, visualization, machine-learning and Big-Data

Namespaces
Name | Description
BI.Algorithm | Represents namespace BI.Algorithm.
BI.Algorithm.Bayes | Represents namespace BI.Algorithm.Bayes.
BI.Algorithm.CART | Represents namespace BI.Algorithm.CART.
BI.Algorithm.Classify | Represents namespace BI.Algorithm.Classify.
BI.Algorithm.Clustering | Represents namespace BI.Algorithm.Clustering.
BI.Algorithm.Clustering.Engine | Represents namespace BI.Algorithm.Clustering.Engine.
BI.Algorithm.Clustering.Scikit | Represents namespace BI.Algorithm.Clustering.Scikit.
BI.Algorithm.DecisionTree | Represents namespace BI.Algorithm.DecisionTree.
BI.Algorithm.DimReduction | Represents namespace BI.Algorithm.DimReduction.
BI.Algorithm.Ensemble | Represents namespace BI.Algorithm.Ensemble.
BI.Algorithm.Model | Represents namespace BI.Algorithm.Model.
BI.Algorithm.Register | Represents namespace BI.Algorithm.Register.
BI.Algorithm.Regression | Represents namespace BI.Algorithm.Regression.
BI.Arrays | Represents namespace BI.Arrays.
BI.Arrays.Parallel | Represents namespace BI.Arrays.Parallel.
BI.Arrays.Strings | Represents namespace BI.Arrays.Strings.
BI.ClientDataset | Represents namespace BI.ClientDataset.
BI.CollectionItem | Represents namespace BI.CollectionItem.
BI.Compare | Represents namespace BI.Compare.
BI.Compression | Represents namespace BI.Compression.
BI.Compression.Snappy | Represents namespace BI.Compression.Snappy.
BI.Compression.SynZip | Represents namespace BI.Compression.SynZip.
BI.Convert | Represents namespace BI.Convert.
BI.Crypt.LockBox | Represents namespace BI.Crypt.LockBox.
BI.CSV | Represents namespace BI.CSV.
BI.Dashboard | Represents namespace BI.Dashboard.
BI.Dashboard.HTML | Represents namespace BI.Dashboard.HTML.
BI.Dashboard.HTML.Chart | Represents namespace BI.Dashboard.HTML.Chart.
BI.Dashboard.Layouts | Represents namespace BI.Dashboard.Layouts.
BI.Dashboard.Loader | Represents namespace BI.Dashboard.Loader.
BI.DataItem | Represents namespace BI.DataItem.
BI.Dataset | Represents namespace BI.Dataset.
BI.DataSource | Represents namespace BI.DataSource.
BI.DB | Represents namespace BI.DB.
BI.DB.BDE | Represents namespace BI.DB.BDE.
BI.DB.Dataset | Represents namespace BI.DB.Dataset.
BI.DB.Fire | Represents namespace BI.DB.Fire.
BI.DB.Fire.AllDrivers | Represents namespace BI.DB.Fire.AllDrivers.
BI.DB.microOLAP | Represents namespace BI.DB.microOLAP.
BI.DB.SqlExpr | Represents namespace BI.DB.SqlExpr.
BI.DB.UniDAC | Represents namespace BI.DB.UniDAC.
BI.DB.ZeosLib | Represents namespace BI.DB.ZeosLib.
BI.Delphi.Generator | Represents namespace BI.Delphi.Generator.
BI.Email.Indy | Represents namespace BI.Email.Indy.
BI.Excel | Represents namespace BI.Excel.
BI.Excel.TMSFlexCel | Represents namespace BI.Excel.TMSFlexCel.
BI.Expression | Represents namespace BI.Expression.
BI.Expression.DateTime | Represents namespace BI.Expression.DateTime.
BI.Expression.Filter | Represents namespace BI.Expression.Filter.
BI.Expressions | Represents namespace BI.Expressions.
BI.FPC | Represents namespace BI.FPC.
BI.Geographic | Represents namespace BI.Geographic.
BI.Grid.Plugin | Represents namespace BI.Grid.Plugin.
BI.Gridify | Represents namespace BI.Gridify.
BI.GuessLinks | Represents namespace BI.GuessLinks.
BI.Html | Represents namespace BI.Html.
BI.Info | Represents namespace BI.Info.
BI.JSON | Represents namespace BI.JSON.
BI.JSON.FPC | Represents namespace BI.JSON.FPC.
BI.JSON.mORMot | Represents namespace BI.JSON.mORMot.
BI.JSON.Standard | Represents namespace BI.JSON.Standard.
BI.JSON.SuperObject | Represents namespace BI.JSON.SuperObject.
BI.Languages.English | Represents namespace BI.Languages.English.
BI.Languages.Spanish | Represents namespace BI.Languages.Spanish.
BI.MapReduce | Represents namespace BI.MapReduce.
BI.Merge | Represents namespace BI.Merge.
BI.Persist | Represents namespace BI.Persist.
BI.Plugins.Python | Represents namespace BI.Plugins.Python.
BI.Plugins.Python.Engine | Represents namespace BI.Plugins.Python.Engine.
BI.Plugins.R | Represents namespace BI.Plugins.R.
BI.Plugins.R.Command | Represents namespace BI.Plugins.R.Command.
BI.Plugins.R.opaR | Represents namespace BI.Plugins.R.opaR.
BI.Query | Represents namespace BI.Query.
BI.Rank | Represents namespace BI.Rank.
BI.RTTI | Represents namespace BI.RTTI.
BI.Schedule | Represents namespace BI.Schedule.
BI.Search | Represents namespace BI.Search.
BI.SingleRecord | Represents namespace BI.SingleRecord.
BI.SQL | Represents namespace BI.SQL.
BI.SqlDB | Represents namespace BI.SqlDB.
BI.Store.Component | Represents namespace BI.Store.Component.
BI.Streams | Represents namespace BI.Streams.
BI.Streams.Reader | Represents namespace BI.Streams.Reader.
BI.Summary | Represents namespace BI.Summary.
BI.Summary.Persist | Represents namespace BI.Summary.Persist.
BI.Summary.Totals | Represents namespace BI.Summary.Totals.
BI.Tools | Represents namespace BI.Tools.
BI.Tree | Represents namespace BI.Tree.
BI.UI | Represents namespace BI.UI.
BI.UI.Colors | Represents namespace BI.UI.Colors.
BI.Verify | Represents namespace BI.Verify.
BI.Web | Represents namespace BI.Web.
BI.Web.FPC | Represents namespace BI.Web.FPC.
BI.Web.Html | Represents namespace BI.Web.Html.
BI.Web.Indy | Represents namespace BI.Web.Indy.
BI.Web.Net | Represents namespace BI.Web.Net.
BI.Workflow | Represents namespace BI.Workflow.
BI.XMLData | Represents namespace BI.XMLData.
BI.XMLData.FPC | Represents namespace BI.XMLData.FPC.
BI.XMLData.MSXML | Represents namespace BI.XMLData.MSXML.
BI.XMLData.Omni | Represents namespace BI.XMLData.Omni.
BI.XMLData.OXml | Represents namespace BI.XMLData.OXml.
FMXBI.Chart | Represents namespace FMXBI.Chart.
FMXBI.Chart.Financial | Represents namespace FMXBI.Chart.Financial.
FMXBI.Chart.Geo | Represents namespace FMXBI.Chart.Geo.
FMXBI.Chart.Plugin | Represents namespace FMXBI.Chart.Plugin.
FMXBI.Chart.Source | Represents namespace FMXBI.Chart.Source.
FMXBI.Chart.ThreeD | Represents namespace FMXBI.Chart.ThreeD.
FMXBI.ChartFunctions | Represents namespace FMXBI.ChartFunctions.
FMXBI.Component | Represents namespace FMXBI.Component.
FMXBI.Dashboard | Represents namespace FMXBI.Dashboard.
FMXBI.Dashboard.Chart | Represents namespace FMXBI.Dashboard.Chart.
FMXBI.DataControl | Represents namespace FMXBI.DataControl.
FMXBI.DataManager | Represents namespace FMXBI.DataManager.
FMXBI.DataViewer | Represents namespace FMXBI.DataViewer.
FMXBI.Editor.Chart.Source | Represents namespace FMXBI.Editor.Chart.Source.
FMXBI.Editor.Column | Represents namespace FMXBI.Editor.Column.
FMXBI.Editor.ControlTree | Represents namespace FMXBI.Editor.ControlTree.
FMXBI.Editor.Data | Represents namespace FMXBI.Editor.Data.
FMXBI.Editor.Grid | Represents namespace FMXBI.Editor.Grid.
FMXBI.Editor.Items | Represents namespace FMXBI.Editor.Items.
FMXBI.Editor.Stores | Represents namespace FMXBI.Editor.Stores.
FMXBI.Editor.Visualizer | Represents namespace FMXBI.Editor.Visualizer.
FMXBI.Editor.Visualizer.Chart | Represents namespace FMXBI.Editor.Visualizer.Chart.
FMXBI.Grid | Represents namespace FMXBI.Grid.
FMXBI.Grid.Grid | Represents namespace FMXBI.Grid.Grid.
FMXBI.Grid.TeeGrid | Represents namespace FMXBI.Grid.TeeGrid.
FMXBI.Grid.TMS | Represents namespace FMXBI.Grid.TMS.
FMXBI.Grid.Woll | Represents namespace FMXBI.Grid.Woll.
FMXBI.GridForm | Represents namespace FMXBI.GridForm.
FMXBI.PDF | Represents namespace FMXBI.PDF.
FMXBI.R.Console | Represents namespace FMXBI.R.Console.
FMXBI.Status | Represents namespace FMXBI.Status.
FMXBI.Tree | Represents namespace FMXBI.Tree.
FMXBI.Tree.TeeTree | Represents namespace FMXBI.Tree.TeeTree.
FMXBI.Tree.TreeView | Represents namespace FMXBI.Tree.TreeView.
FMXBI.Visualizer | Represents namespace FMXBI.Visualizer.
FMXBI.Visualizer.Chart | Represents namespace FMXBI.Visualizer.Chart.
teebi | Represents namespace teebi.
TeeBIAbout | Represents namespace TeeBIAbout.
TeeBIDebugFrame | Represents namespace TeeBIDebugFrame.
TeeBIDebugVisualizer | Represents namespace TeeBIDebugVisualizer.
TeeBIFMXAbout | Represents namespace TeeBIFMXAbout.
TeeBIFMXRegister | Represents namespace TeeBIFMXRegister.
TeeBIRegister | Represents namespace TeeBIRegister.
TeeBIRegisterAbout | Represents namespace TeeBIRegisterAbout.
TeeBIRegisterCreator | Represents namespace TeeBIRegisterCreator.
TeeBIRegisterMenu | Represents namespace TeeBIRegisterMenu.
Unit_Icon_Generator | Represents namespace Unit_Icon_Generator.
VCLBI.Chart | Represents namespace VCLBI.Chart.
VCLBI.Chart.Financial | Represents namespace VCLBI.Chart.Financial.
VCLBI.Chart.Geo | Represents namespace VCLBI.Chart.Geo.
VCLBI.Chart.Plugin | Represents namespace VCLBI.Chart.Plugin.
VCLBI.Chart.Source | Represents namespace VCLBI.Chart.Source.
VCLBI.Chart.ThreeD | Represents namespace VCLBI.Chart.ThreeD.
VCLBI.ChartFunctions | Represents namespace VCLBI.ChartFunctions.
VCLBI.Component | Represents namespace VCLBI.Component.
VCLBI.Dashboard | Represents namespace VCLBI.Dashboard.
VCLBI.Dashboard.Chart | Represents namespace VCLBI.Dashboard.Chart.
VCLBI.DataControl | Represents namespace VCLBI.DataControl.
VCLBI.DataEditor | Represents namespace VCLBI.DataEditor.
VCLBI.DataManager | Represents namespace VCLBI.DataManager.
VCLBI.DataSelect | Represents namespace VCLBI.DataSelect.
VCLBI.DataTree | Represents namespace VCLBI.DataTree.
VCLBI.DataViewer | Represents namespace VCLBI.DataViewer.
VCLBI.Designer.Template.Layouts | Represents namespace VCLBI.Designer.Template.Layouts.
VCLBI.Editor.BIGrid | Represents namespace VCLBI.Editor.BIGrid.
VCLBI.Editor.Chart | Represents namespace VCLBI.Editor.Chart.
VCLBI.Editor.Chart.Source | Represents namespace VCLBI.Editor.Chart.Source.
VCLBI.Editor.ChartFunctions | Represents namespace VCLBI.Editor.ChartFunctions.
VCLBI.Editor.Completion | Represents namespace VCLBI.Editor.Completion.
VCLBI.Editor.ControlTree | Represents namespace VCLBI.Editor.ControlTree.
VCLBI.Editor.Data | Represents namespace VCLBI.Editor.Data.
VCLBI.Editor.Data.Links | Represents namespace VCLBI.Editor.Data.Links.
VCLBI.Editor.DataComponent | Represents namespace VCLBI.Editor.DataComponent.
VCLBI.Editor.DataRank | Represents namespace VCLBI.Editor.DataRank.
VCLBI.Editor.DataSelect | Represents namespace VCLBI.Editor.DataSelect.
VCLBI.Editor.DataSet | Represents namespace VCLBI.Editor.DataSet.
VCLBI.Editor.DateTimeRange | Represents namespace VCLBI.Editor.DateTimeRange.
VCLBI.Editor.DynamicFilter | Represents namespace VCLBI.Editor.DynamicFilter.
VCLBI.Editor.ExportData | Represents namespace VCLBI.Editor.ExportData.
VCLBI.Editor.Expression | Represents namespace VCLBI.Editor.Expression.
VCLBI.Editor.Filter.DateTime | Represents namespace VCLBI.Editor.Filter.DateTime.
VCLBI.Editor.Filter.Item | Represents namespace VCLBI.Editor.Filter.Item.
VCLBI.Editor.Formats | Represents namespace VCLBI.Editor.Formats.
VCLBI.Editor.Grid | Represents namespace VCLBI.Editor.Grid.
VCLBI.Editor.Gridify | Represents namespace VCLBI.Editor.Gridify.
VCLBI.Editor.Hops | Represents namespace VCLBI.Editor.Hops.
VCLBI.Editor.Items | Represents namespace VCLBI.Editor.Items.
VCLBI.Editor.ListItems | Represents namespace VCLBI.Editor.ListItems.
VCLBI.Editor.Needs | Represents namespace VCLBI.Editor.Needs.
VCLBI.Editor.NumericFromTo | Represents namespace VCLBI.Editor.NumericFromTo.
VCLBI.Editor.Query | Represents namespace VCLBI.Editor.Query.
VCLBI.Editor.Search | Represents namespace VCLBI.Editor.Search.
VCLBI.Editor.SelectText | Represents namespace VCLBI.Editor.SelectText.
VCLBI.Editor.Sort | Represents namespace VCLBI.Editor.Sort.
VCLBI.Editor.Split | Represents namespace VCLBI.Editor.Split.
VCLBI.Editor.Stores | Represents namespace VCLBI.Editor.Stores.
VCLBI.Editor.Summary | Represents namespace VCLBI.Editor.Summary.
VCLBI.Editor.Template | Represents namespace VCLBI.Editor.Template.
VCLBI.Editor.Template.Data | Represents namespace VCLBI.Editor.Template.Data.
VCLBI.Editor.Template.Layouts | Represents namespace VCLBI.Editor.Template.Layouts.
VCLBI.Editor.Template.Panels | Represents namespace VCLBI.Editor.Template.Panels.
VCLBI.Editor.Visualizer | Represents namespace VCLBI.Editor.Visualizer.
VCLBI.Editor.Visualizer.Chart | Represents namespace VCLBI.Editor.Visualizer.Chart.
VCLBI.Editor.Workflow | Represents namespace VCLBI.Editor.Workflow.
VCLBI.Editor.WorkflowItem | Represents namespace VCLBI.Editor.WorkflowItem.
VCLBI.Export.RichView | Represents namespace VCLBI.Export.RichView.
VCLBI.Grid | Represents namespace VCLBI.Grid.
VCLBI.Grid.DBGrid | Represents namespace VCLBI.Grid.DBGrid.
VCLBI.Grid.JVCL | Represents namespace VCLBI.Grid.JVCL.
VCLBI.Grid.SMDBGrid | Represents namespace VCLBI.Grid.SMDBGrid.
VCLBI.Grid.TeeGrid | Represents namespace VCLBI.Grid.TeeGrid.
VCLBI.GridChart | Represents namespace VCLBI.GridChart.
VCLBI.GridForm | Represents namespace VCLBI.GridForm.
VCLBI.LinkDiagram | Represents namespace VCLBI.LinkDiagram.
VCLBI.Menus | Represents namespace VCLBI.Menus.
VCLBI.NewColumn | Represents namespace VCLBI.NewColumn.
VCLBI.PDF | Represents namespace VCLBI.PDF.
VCLBI.R.Console | Represents namespace VCLBI.R.Console.
VCLBI.Tree | Represents namespace VCLBI.Tree.
VCLBI.Tree.TeeTree | Represents namespace VCLBI.Tree.TeeTree.
VCLBI.Tree.TreeView | Represents namespace VCLBI.Tree.TreeView.
VCLBI.Tree.VirtualTreeView | Represents namespace VCLBI.Tree.VirtualTreeView.
VCLBI.Visualizer | Represents namespace VCLBI.Visualizer.
VCLBI.Visualizer.Chart | Represents namespace VCLBI.Visualizer.Chart.
Top
TeeBI Documentation


BI.Algorithm Namespace

Summary

Represents namespace BI.Algorithm.

Classes
Name | Description
TAlgorithmNeedsHelper | Represents type TAlgorithmNeedsHelper.
TBaseAlgorithm | Represents type TBaseAlgorithm.
TCloneProvider | Represents type TCloneProvider.
TDataAccess | Represents type TDataAccess.
TDataKindsHelper | Represents type TDataKindsHelper.
TDataProviderNeeds | Represents type TDataProviderNeeds.
TSingleSourceProvider | Represents type TSingleSourceProvider.
Top
Records
Name | Description
TAlgorithmNeed | Represents type TAlgorithmNeed.
Top
Enumerations
Name | Description
TQuantityStyle | Represents type TQuantityStyle.
Top
Types
Name | Description
TAlgorithmNeeds | Represents an array of the TAlgorithmNeed type.
TBaseAlgorithmClass | Represents type TBaseAlgorithmClass.
TDataKinds | Represents type TDataKinds.
TDataOrigins | Represents an array of the TStringArray type.
Top


BI.Algorithm Classes

Classes
Name | Description
TAlgorithmNeedsHelper | Represents type TAlgorithmNeedsHelper.
TBaseAlgorithm | Represents type TBaseAlgorithm.
TCloneProvider | Represents type TCloneProvider.
TDataAccess | Represents type TDataAccess.
TDataKindsHelper | Represents type TDataKindsHelper.
TDataProviderNeeds | Represents type TDataProviderNeeds.
TSingleSourceProvider | Represents type TSingleSourceProvider.
Top


TAlgorithmNeedsHelper Class Helper

Summary

Represents type TAlgorithmNeedsHelper.

Namespace: BI.Algorithm
Syntax
Delphi
type
 TAlgorithmNeedsHelper=record helper for TAlgorithmNeeds
 end;
Methods
Name | Description
Add(TAlgorithmNeed) | Represents method Add(TAlgorithmNeed).
AnyNeedNot(TDataItem) | Represents method AnyNeedNot(TDataItem).
Clear | Represents method Clear.
Count | Represents method Count.
Verify(Boolean) | Represents method Verify(Boolean).
Top
See Also

Reference

  • BI.Algorithm


TAlgorithmNeedsHelper Methods

Methods
Name | Description
Add(TAlgorithmNeed) | Represents method Add(TAlgorithmNeed).
AnyNeedNot(TDataItem) | Represents method AnyNeedNot(TDataItem).
Clear | Represents method Clear.
Count | Represents method Count.
Verify(Boolean) | Represents method Verify(Boolean).
Top


TAlgorithmNeedsHelper.Add(TAlgorithmNeed) Method

Summary

Represents method Add(TAlgorithmNeed).

Namespace: BI.Algorithm
Syntax
Delphi
public
 procedure Add(const ANeed:TAlgorithmNeed);

Parameters

ANeed
Type: TAlgorithmNeed

See Also

Reference

  • TAlgorithmNeedsHelper
  • BI.Algorithm


TAlgorithmNeedsHelper.AnyNeedNot(TDataItem) Method

Summary

Represents method AnyNeedNot(TDataItem).

Namespace: BI.Algorithm
Syntax
Delphi
public
 function AnyNeedNot(const AData:TDataItem):Boolean;

Parameters

AData
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • TAlgorithmNeedsHelper
  • BI.Algorithm


TAlgorithmNeedsHelper.Clear Method

Summary

Represents method Clear.

Namespace: BI.Algorithm
Syntax
Delphi
public
 procedure Clear; inline;
See Also

Reference

  • TAlgorithmNeedsHelper
  • BI.Algorithm


TAlgorithmNeedsHelper.Count Method

Summary

Represents method Count.

Namespace: BI.Algorithm
Syntax
Delphi
public
 function Count:Integer; inline;

Return Value

Type: Integer

See Also

Reference

  • TAlgorithmNeedsHelper
  • BI.Algorithm


TAlgorithmNeedsHelper.Verify(Boolean) Method

Summary

Represents method Verify(Boolean).

Namespace: BI.Algorithm
Syntax
Delphi
public
 function Verify(const Silent:Boolean=False):Boolean;

Parameters

Silent
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • TAlgorithmNeedsHelper
  • BI.Algorithm


TBaseAlgorithm Class

Summary

Represents type TBaseAlgorithm.

Namespace: BI.Algorithm
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TBaseAlgorithm
BI.Algorithm.Model.TModel
BI.Algorithm.Regression.TRegression
BI.Plugins.R.TRBaseAlgorithm
Syntax
Delphi
type
 TBaseAlgorithm=class(TDataProviderNeeds)
 end;

The TBaseAlgorithm type exposes the following members.

Methods
Show:
Name | Description
AddOutput(TDataItem) | Represents method AddOutput(TDataItem).
Calculate | Represents method Calculate.
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Top
See Also

Reference

  • BI.Algorithm


TBaseAlgorithm Methods

Methods
Name | Description
AddOutput(TDataItem) | Represents method AddOutput(TDataItem).
Calculate | Represents method Calculate.
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Top


TBaseAlgorithm.AddOutput(TDataItem) Method

Summary

Represents method AddOutput(TDataItem).

Namespace: BI.Algorithm
Syntax
Delphi
protected
 procedure AddOutput(const AData:TDataItem); virtual;

Parameters

AData
Type: TDataItem

See Also

Reference

  • TBaseAlgorithm
  • BI.Algorithm


TBaseAlgorithm.Calculate Method

Summary

Represents method Calculate.

Namespace: BI.Algorithm
Syntax
Delphi
public
 procedure Calculate; virtual; abstract;
See Also

Reference

  • TBaseAlgorithm
  • BI.Algorithm


TBaseAlgorithm.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Algorithm
Syntax
Delphi
protected
 procedure Load(const AData: TDataItem; const Children: Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TBaseAlgorithm
  • BI.Algorithm


TCloneProvider Class

Summary

Represents type TCloneProvider.

Namespace: BI.Algorithm
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TSingleSourceProvider
BI.Algorithm.TCloneProvider
BI.Workflow.TConvertItem
BI.Workflow.TDataRankItem
BI.Workflow.TDataShuffle
BI.Workflow.TItemAction
BI.Workflow.TItemsAction
BI.Workflow.TMergeItem
BI.Workflow.TNormalizeItem
BI.Workflow.TReorderItem
BI.Workflow.TSortActionItem
Syntax
Delphi
type
 TCloneProvider=class(TSingleSourceProvider)
 end;

The TCloneProvider type exposes the following members.

Methods
Show:
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Top
See Also

Reference

  • BI.Algorithm


TCloneProvider Methods

Methods
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Top


TCloneProvider.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Algorithm
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TCloneProvider
  • BI.Algorithm


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.Algorithm
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Algorithm.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.Algorithm


TDataKindsHelper Class Helper

Summary

Represents type TDataKindsHelper.

Namespace: BI.Algorithm
Syntax
Delphi
type
 TDataKindsHelper=record helper for TDataKinds
 end;
Constants
Name | Description
Numeric | Represents constant Numeric.
Top
See Also

Reference

  • BI.Algorithm


TDataKindsHelper Constants

Constants
Name | Description
Numeric | Represents constant Numeric.
Top


TDataKindsHelper.Numeric Constant

Summary

Represents constant Numeric.

Namespace: BI.Algorithm
Syntax
Delphi
public
 Numeric:TDataKinds=[dkInt32,dkInt64,dkSingle,dkDouble,dkExtended,dkDateTime];

Value

Type: TDataKinds

See Also

Reference

  • TDataKindsHelper
  • BI.Algorithm


TDataProviderNeeds Class

Summary

Represents type TDataProviderNeeds.

Namespace: BI.Algorithm
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TBaseAlgorithm
BI.Algorithm.TSingleSourceProvider
BI.Workflow.TCompareItem
BI.Workflow.TDataProviderNeedsAccess
FMXBI.ChartFunctions.TDataFunction
VCLBI.ChartFunctions.TDataFunction
Syntax
Delphi
type
 TDataProviderNeeds=class(TDataProvider)
 end;

The TDataProviderNeeds type exposes the following members.

Methods
Show:
Name | Description
TryFixOrigins | Represents method TryFixOrigins.
Top
Fields
Show:
Name | Description
IOrigins | Represents field IOrigins.
IParent | Represents field IParent.
Needs | Represents field Needs.
Top
See Also

Reference

  • BI.Algorithm


TDataProviderNeeds Methods

Methods
Name | Description
TryFixOrigins | Represents method TryFixOrigins.
Top


TDataProviderNeeds.TryFixOrigins Method

Summary

Represents method TryFixOrigins.

Namespace: BI.Algorithm
Syntax
Delphi
protected
 procedure TryFixOrigins;
See Also

Reference

  • TDataProviderNeeds
  • BI.Algorithm


TDataProviderNeeds Fields

Fields
Name | Description
IOrigins | Represents field IOrigins.
IParent | Represents field IParent.
Needs | Represents field Needs.
Top


TDataProviderNeeds.IOrigins Field

Summary

Represents field IOrigins.

Namespace: BI.Algorithm
Syntax
Delphi
protected
 IOrigins : TDataOrigins;

Field Value

Type: TDataOrigins

See Also

Reference

  • TDataProviderNeeds
  • BI.Algorithm


TDataProviderNeeds.IParent Field

Summary

Represents field IParent.

Namespace: BI.Algorithm
Syntax
Delphi
protected
 IParent : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TDataProviderNeeds
  • BI.Algorithm


TDataProviderNeeds.Needs Field

Summary

Represents field Needs.

Namespace: BI.Algorithm
Syntax
Delphi
public
 Needs : TAlgorithmNeeds;

Field Value

Type: TAlgorithmNeeds

See Also

Reference

  • TDataProviderNeeds
  • BI.Algorithm


TSingleSourceProvider Class

Summary

Represents type TSingleSourceProvider.

Namespace: BI.Algorithm
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TSingleSourceProvider
BI.Algorithm.TCloneProvider
BI.SingleRecord.TSingleRecord
BI.Workflow.TDataGridifyItem
BI.Workflow.TDataTranspose
BI.Workflow.TFilterAction
BI.Workflow.TGroupByItem
BI.Workflow.TSplitItem
Syntax
Delphi
type
 TSingleSourceProvider=class(TDataProviderNeeds)
 end;

The TSingleSourceProvider type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TSingleSourceProvider class.
Destroy | Represents the destructor of the TSingleSourceProvider class. (Overrides TDataProvider.Destroy.)
Top
Properties
Show:
Name | Description
Source | Represents property Source.
Top
Methods
Show:
Name | Description
ClearSource | Represents method ClearSource.
Notify(TBIEvent) | Represents method Notify(TBIEvent).
Top
See Also

Reference

  • BI.Algorithm


TSingleSourceProvider Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TSingleSourceProvider class.
Destroy | Represents the destructor of the TSingleSourceProvider class. (Overrides TDataProvider.Destroy.)
Top


TSingleSourceProvider.Create(TComponent) Constructor

Summary

Initializes a new instance of the TSingleSourceProvider class.

Namespace: BI.Algorithm
Syntax
Delphi
public
 Constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TSingleSourceProvider
  • BI.Algorithm


TSingleSourceProvider.Destroy Destructor

Summary

Represents the destructor of the TSingleSourceProvider class.

Namespace: BI.Algorithm
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TDataProvider.Destroy
See Also

Reference

  • TSingleSourceProvider
  • BI.Algorithm


TSingleSourceProvider Properties

Properties
Name | Description
Source | Represents property Source.
Top


TSingleSourceProvider.Source Property

Summary

Represents property Source.

Namespace: BI.Algorithm
Syntax
Delphi
public
 property Source:TDataItem read GetSource write SetSource;

Property Value

Type: TDataItem

See Also

Reference

  • TSingleSourceProvider
  • BI.Algorithm


TSingleSourceProvider Methods

Methods
Name | Description
ClearSource | Represents method ClearSource.
Notify(TBIEvent) | Represents method Notify(TBIEvent).
Top


TSingleSourceProvider.ClearSource Method

Summary

Represents method ClearSource.

Namespace: BI.Algorithm
Syntax
Delphi
protected
 procedure ClearSource; virtual;
See Also

Reference

  • TSingleSourceProvider
  • BI.Algorithm


TSingleSourceProvider.Notify(TBIEvent) Method

Summary

Represents method Notify(TBIEvent).

Namespace: BI.Algorithm
Syntax
Delphi
protected
 procedure Notify(const AEvent:TBIEvent);

Parameters

AEvent
Type: TBIEvent

See Also

Reference

  • TSingleSourceProvider
  • BI.Algorithm


BI.Algorithm Records

Records
Name | Description
TAlgorithmNeed | Represents type TAlgorithmNeed.
Top


TAlgorithmNeed Record

Summary

Represents type TAlgorithmNeed.

Namespace: BI.Algorithm
Syntax
Delphi
type
 TAlgorithmNeed=record
 end;

The TAlgorithmNeed type exposes the following members.

Constructors
Show:
Name | Description
Create(String,TQuantityStyle,Integer,TDataKinds) | Initializes a new instance of the TAlgorithmNeed class.
Top
Methods
Show:
Name | Description
CheckData | Represents method CheckData.
First | Represents method First.
Verify(Boolean) | Represents method Verify(Boolean).
Top
Fields
Show:
Name | Description
Data | Represents field Data.
Kinds | Represents field Kinds.
Name | Represents field Name.
Quantity | Represents field Quantity.
Style | Represents field Style.
Top
See Also

Reference

  • BI.Algorithm


TAlgorithmNeed Constructors

Constructors
Name | Description
Create(String,TQuantityStyle,Integer,TDataKinds) | Initializes a new instance of the TAlgorithmNeed class.
Top


TAlgorithmNeed.Create(String,TQuantityStyle,Integer,TDataKinds) Constructor

Summary

Initializes a new instance of the TAlgorithmNeed class.

Namespace: BI.Algorithm
Syntax
Delphi
public
 Constructor Create(const AName:String;
 const AStyle:TQuantityStyle;
 const AQuantity:Integer;
 const AKinds:TDataKinds=[]);

Parameters

AName
Type: String

AStyle
Type: TQuantityStyle

AQuantity
Type: Integer

AKinds
Type: TDataKinds

See Also

Reference

  • TAlgorithmNeed
  • BI.Algorithm


TAlgorithmNeed Methods

Methods
Name | Description
CheckData | Represents method CheckData.
First | Represents method First.
Verify(Boolean) | Represents method Verify(Boolean).
Top


TAlgorithmNeed.CheckData Method

Summary

Represents method CheckData.

Namespace: BI.Algorithm
Syntax
Delphi
public
 procedure CheckData;
See Also

Reference

  • TAlgorithmNeed
  • BI.Algorithm


TAlgorithmNeed.First Method

Summary

Represents method First.

Namespace: BI.Algorithm
Syntax
Delphi
public
 function First:TDataItem;

Return Value

Type: TDataItem

See Also

Reference

  • TAlgorithmNeed
  • BI.Algorithm


TAlgorithmNeed.Verify(Boolean) Method

Summary

Represents method Verify(Boolean).

Namespace: BI.Algorithm
Syntax
Delphi
public
 function Verify(const Silent:Boolean=False):Boolean;

Parameters

Silent
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • TAlgorithmNeed
  • BI.Algorithm


TAlgorithmNeed Fields

Fields
Name | Description
Data | Represents field Data.
Kinds | Represents field Kinds.
Name | Represents field Name.
Quantity | Represents field Quantity.
Style | Represents field Style.
Top


TAlgorithmNeed.Data Field

Summary

Represents field Data.

Namespace: BI.Algorithm
Syntax
Delphi
public
 Data : TDataArray;

Field Value

Type: TDataArray

See Also

Reference

  • TAlgorithmNeed
  • BI.Algorithm


TAlgorithmNeed.Kinds Field

Summary

Represents field Kinds.

Namespace: BI.Algorithm
Syntax
Delphi
public
 Kinds : TDataKinds;

Field Value

Type: TDataKinds

See Also

Reference

  • TAlgorithmNeed
  • BI.Algorithm


TAlgorithmNeed.Name Field

Summary

Represents field Name.

Namespace: BI.Algorithm
Syntax
Delphi
public
 Name : String;

Field Value

Type: String

See Also

Reference

  • TAlgorithmNeed
  • BI.Algorithm


TAlgorithmNeed.Quantity Field

Summary

Represents field Quantity.

Namespace: BI.Algorithm
Syntax
Delphi
public
 Quantity : Integer;

Field Value

Type: Integer

See Also

Reference

  • TAlgorithmNeed
  • BI.Algorithm


TAlgorithmNeed.Style Field

Summary

Represents field Style.

Namespace: BI.Algorithm
Syntax
Delphi
public
 Style : TQuantityStyle;

Field Value

Type: TQuantityStyle

See Also

Reference

  • TAlgorithmNeed
  • BI.Algorithm


BI.Algorithm Enumerations

Enumerations
Name | Description
TQuantityStyle | Represents type TQuantityStyle.
Top


TQuantityStyle Enumeration

Summary

Represents type TQuantityStyle.

Namespace: BI.Algorithm
Syntax
Delphi
type
 TQuantityStyle=(Exact, Minimum, Maximum);

The TQuantityStyle type exposes the following members.

Members
Show:
Name | Description
Exact | Represents constant Exact.
Maximum | Represents constant Maximum.
Minimum | Represents constant Minimum.
Top
See Also

Reference

  • BI.Algorithm


BI.Algorithm Types

Types
Name | Description
TAlgorithmNeeds | Represents an array of the TAlgorithmNeed type.
TBaseAlgorithmClass | Represents type TBaseAlgorithmClass.
TDataKinds | Represents type TDataKinds.
TDataOrigins | Represents an array of the TStringArray type.
Top


TAlgorithmNeeds Type

Summary

Represents an array of the TAlgorithmNeed type.

Namespace: BI.Algorithm
Syntax
Delphi
type
 TAlgorithmNeeds=Array of TAlgorithmNeed;
See Also

Reference

  • BI.Algorithm


TBaseAlgorithmClass Type

Summary

Represents type TBaseAlgorithmClass.

Namespace: BI.Algorithm
Syntax
Delphi
type
 TBaseAlgorithmClass=class of TBaseAlgorithm;
See Also

Reference

  • BI.Algorithm


TDataKinds Type

Summary

Represents type TDataKinds.

Namespace: BI.Algorithm
Syntax
Delphi
type
 TDataKinds=set of TDataKind;
See Also

Reference

  • BI.Algorithm


TDataOrigins Type

Summary

Represents an array of the TStringArray type.

Namespace: BI.Algorithm
Syntax
Delphi
type
 TDataOrigins=Array of TStringArray;
See Also

Reference

  • BI.Algorithm


BI.Algorithm.Bayes Namespace

Summary

Represents namespace BI.Algorithm.Bayes.

Classes
Name | Description
TBINaiveBayes | Represents type TBINaiveBayes.
Top


BI.Algorithm.Bayes Classes

Classes
Name | Description
TBINaiveBayes | Represents type TBINaiveBayes.
Top


TBINaiveBayes Class

Summary

Represents type TBINaiveBayes.

Namespace: BI.Algorithm.Bayes
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TBaseAlgorithm
BI.Algorithm.Model.TModel
BI.Algorithm.Model.TSupervisedModel
BI.Plugins.R.TRSupervisedModel
BI.Algorithm.Bayes.TBINaiveBayes
Syntax
Delphi
type
 TBINaiveBayes=class(TRSupervisedModel)
 end;

The TBINaiveBayes type exposes the following members.

Methods
Show:
Name | Description
BuildScript | Represents method BuildScript. (Overrides TRSupervisedModel.BuildScript.)
Top
See Also

Reference

  • BI.Algorithm.Bayes


TBINaiveBayes Methods

Methods
Name | Description
BuildScript | Represents method BuildScript. (Overrides TRSupervisedModel.BuildScript.)
Top


TBINaiveBayes.BuildScript Method

Summary

Represents method BuildScript.

Namespace: BI.Algorithm.Bayes
Syntax
Delphi
protected
 procedure BuildScript; override;

Overrides

TRSupervisedModel.BuildScript
See Also

Reference

  • TBINaiveBayes
  • BI.Algorithm.Bayes


BI.Algorithm.CART Namespace

Summary

Represents namespace BI.Algorithm.CART.

Classes
Name | Description
TBICART | Represents type TBICART.
Top


BI.Algorithm.CART Classes

Classes
Name | Description
TBICART | Represents type TBICART.
Top


TBICART Class

Summary

Represents type TBICART.

Namespace: BI.Algorithm.CART
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TBaseAlgorithm
BI.Algorithm.Model.TModel
BI.Algorithm.Model.TSupervisedModel
BI.Plugins.R.TRSupervisedModel
BI.Algorithm.CART.TBICART
Syntax
Delphi
type
 TBICART=class(TRSupervisedModel)
 end;

The TBICART type exposes the following members.

Methods
Show:
Name | Description
BuildScript | Represents method BuildScript. (Overrides TRSupervisedModel.BuildScript.)
Top
See Also

Reference

  • BI.Algorithm.CART


TBICART Methods

Methods
Name | Description
BuildScript | Represents method BuildScript. (Overrides TRSupervisedModel.BuildScript.)
Top


TBICART.BuildScript Method

Summary

Represents method BuildScript.

Namespace: BI.Algorithm.CART
Syntax
Delphi
protected
 procedure BuildScript; override;

Overrides

TRSupervisedModel.BuildScript
See Also

Reference

  • TBICART
  • BI.Algorithm.CART


BI.Algorithm.Classify Namespace

Summary

Represents namespace BI.Algorithm.Classify.

Classes
Name | Description
TBICrossTable | Represents type TBICrossTable.
TBINearestNeighbour | Represents type TBINearestNeighbour.
Top


BI.Algorithm.Classify Classes

Classes
Name | Description
TBICrossTable | Represents type TBICrossTable.
TBINearestNeighbour | Represents type TBINearestNeighbour.
Top


TBICrossTable Class

Summary

Represents type TBICrossTable.

Namespace: BI.Algorithm.Classify
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TBaseAlgorithm
BI.Plugins.R.TRBaseAlgorithm
BI.Algorithm.Classify.TBICrossTable
Syntax
Delphi
type
 TBICrossTable=class(TRBaseAlgorithm)
 end;

The TBICrossTable type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBICrossTable class.
Top
Properties
Show:
Name | Description
ChiSquare | Represents property ChiSquare.
Predicted | Represents property Predicted.
Real | Represents property Real.
Top
Methods
Show:
Name | Description
AddOutput(TDataItem) | Represents method AddOutput(TDataItem). (Overrides TBaseAlgorithm.AddOutput(TDataItem).)
BuildScript | Represents method BuildScript. (Overrides TRBaseAlgorithm.BuildScript.)
Top
See Also

Reference

  • BI.Algorithm.Classify


TBICrossTable Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBICrossTable class.
Top


TBICrossTable.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBICrossTable class.

Namespace: BI.Algorithm.Classify
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBICrossTable
  • BI.Algorithm.Classify


TBICrossTable Properties

Properties
Name | Description
ChiSquare | Represents property ChiSquare.
Predicted | Represents property Predicted.
Real | Represents property Real.
Top


TBICrossTable.ChiSquare Property

Summary

Represents property ChiSquare.

Namespace: BI.Algorithm.Classify
Syntax
Delphi
published
 property ChiSquare:Boolean read FChiSquare write SetChiSquare;

Property Value

Type: Boolean

See Also

Reference

  • TBICrossTable
  • BI.Algorithm.Classify


TBICrossTable.Predicted Property

Summary

Represents property Predicted.

Namespace: BI.Algorithm.Classify
Syntax
Delphi
public
 property Predicted:TDataItem read GetPredicted write SetPredicted;

Property Value

Type: TDataItem

See Also

Reference

  • TBICrossTable
  • BI.Algorithm.Classify


TBICrossTable.Real Property

Summary

Represents property Real.

Namespace: BI.Algorithm.Classify
Syntax
Delphi
public
 property Real:TDataItem read GetReal write SetReal;

Property Value

Type: TDataItem

See Also

Reference

  • TBICrossTable
  • BI.Algorithm.Classify


TBICrossTable Methods

Methods
Name | Description
AddOutput(TDataItem) | Represents method AddOutput(TDataItem). (Overrides TBaseAlgorithm.AddOutput(TDataItem).)
BuildScript | Represents method BuildScript. (Overrides TRBaseAlgorithm.BuildScript.)
Top


TBICrossTable.AddOutput(TDataItem) Method

Summary

Represents method AddOutput(TDataItem).

Namespace: BI.Algorithm.Classify
Syntax
Delphi
protected
 procedure AddOutput(const AData:TDataItem); override;

Parameters

AData
Type: TDataItem

Overrides

TBaseAlgorithm.AddOutput(TDataItem)
See Also

Reference

  • TBICrossTable
  • BI.Algorithm.Classify


TBICrossTable.BuildScript Method

Summary

Represents method BuildScript.

Namespace: BI.Algorithm.Classify
Syntax
Delphi
protected
 procedure BuildScript; override;

Overrides

TRBaseAlgorithm.BuildScript
See Also

Reference

  • TBICrossTable
  • BI.Algorithm.Classify


TBINearestNeighbour Class

Summary

Represents type TBINearestNeighbour.

Namespace: BI.Algorithm.Classify
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TBaseAlgorithm
BI.Algorithm.Model.TModel
BI.Algorithm.Model.TSupervisedModel
BI.Plugins.R.TRSupervisedModel
BI.Algorithm.Classify.TBINearestNeighbour
Syntax
Delphi
type
 TBINearestNeighbour=class(TRSupervisedModel)
 end;

The TBINearestNeighbour type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBINearestNeighbour class. (Overrides TSupervisedModel.Create(TComponent).)
Top
Properties
Show:
Name | Description
K | Represents property K.
Top
Methods
Show:
Name | Description
BuildScript | Represents method BuildScript. (Overrides TRSupervisedModel.BuildScript.)
Top
See Also

Reference

  • BI.Algorithm.Classify


TBINearestNeighbour Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBINearestNeighbour class. (Overrides TSupervisedModel.Create(TComponent).)
Top


TBINearestNeighbour.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBINearestNeighbour class.

Namespace: BI.Algorithm.Classify
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TSupervisedModel.Create(TComponent)
See Also

Reference

  • TBINearestNeighbour
  • BI.Algorithm.Classify


TBINearestNeighbour Properties

Properties
Name | Description
K | Represents property K.
Top


TBINearestNeighbour.K Property

Summary

Represents property K.

Namespace: BI.Algorithm.Classify
Syntax
Delphi
published
 property K:Integer read FK write SetK default 1;

Property Value

Type: Integer

See Also

Reference

  • TBINearestNeighbour
  • BI.Algorithm.Classify


TBINearestNeighbour Methods

Methods
Name | Description
BuildScript | Represents method BuildScript. (Overrides TRSupervisedModel.BuildScript.)
Top


TBINearestNeighbour.BuildScript Method

Summary

Represents method BuildScript.

Namespace: BI.Algorithm.Classify
Syntax
Delphi
protected
 procedure BuildScript; override;

Overrides

TRSupervisedModel.BuildScript
See Also

Reference

  • TBINearestNeighbour
  • BI.Algorithm.Classify


BI.Algorithm.Clustering Namespace

Summary

Represents namespace BI.Algorithm.Clustering.

Classes
Name | Description
TBIClustering | Represents type TBIClustering.
TBIProvider | Represents type TBIProvider.
Top
Enumerations
Name | Description
TClusteringMethod | Represents type TClusteringMethod.
TDistanceMethod | Represents type TDistanceMethod.
Top
Delegates
Name | Description
TCalcDistanceFunc | Represents type TCalcDistanceFunc.
Top
Routines
Name | Description
DistChebyshev(TClusterData,TClusterData) | Represents method DistChebyshev(TClusterData,TClusterData).
DistEuclidean(TClusterData,TClusterData) | Represents method DistEuclidean(TClusterData,TClusterData).
DistManhattan(TClusterData,TClusterData) | Represents method DistManhattan(TClusterData,TClusterData).
DistSorensen(TClusterData,TClusterData) | Represents method DistSorensen(TClusterData,TClusterData).
DistSqrEuclidean(TClusterData,TClusterData) | Represents method DistSqrEuclidean(TClusterData,TClusterData).
TeeHypot(Integer,Integer) | Overloaded. Represents method TeeHypot(Integer,Integer).
TeeHypot(TClusterValue,TClusterValue) | Overloaded. Represents method TeeHypot(TClusterValue,TClusterValue).
Top


BI.Algorithm.Clustering Classes

Classes
Name | Description
TBIClustering | Represents type TBIClustering.
TBIProvider | Represents type TBIProvider.
Top


TBIClustering Class

Summary

Represents type TBIClustering.

Namespace: BI.Algorithm.Clustering
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TBaseAlgorithm
BI.Algorithm.Model.TModel
BI.Algorithm.Model.TSupervisedModel
BI.Algorithm.Clustering.TBIClustering
Syntax
Delphi
type
 TBIClustering=class(TSupervisedModel)
 end;

The TBIClustering type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIClustering class. (Overrides TSupervisedModel.Create(TComponent).)
Destroy | Represents the destructor of the TBIClustering class. (Overrides TSupervisedModel.Destroy.)
Top
Methods
Show:
Name | Description
Calculate | Represents method Calculate. (Overrides TSupervisedModel.Calculate.)
Evaluation | Represents method Evaluation.
Summary | Represents method Summary.
Top
Fields
Show:
Name | Description
Options | Represents field Options.
Output | Represents field Output.
Top
See Also

Reference

  • BI.Algorithm.Clustering


TBIClustering Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBIClustering class. (Overrides TSupervisedModel.Create(TComponent).)
Destroy | Represents the destructor of the TBIClustering class. (Overrides TSupervisedModel.Destroy.)
Top


TBIClustering.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIClustering class.

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TSupervisedModel.Create(TComponent)
See Also

Reference

  • TBIClustering
  • BI.Algorithm.Clustering


TBIClustering.Destroy Destructor

Summary

Represents the destructor of the TBIClustering class.

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TSupervisedModel.Destroy
See Also

Reference

  • TBIClustering
  • BI.Algorithm.Clustering


TBIClustering Methods

Methods
Name | Description
Calculate | Represents method Calculate. (Overrides TSupervisedModel.Calculate.)
Evaluation | Represents method Evaluation.
Summary | Represents method Summary.
Top


TBIClustering.Calculate Method

Summary

Represents method Calculate.

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
public
 procedure Calculate; override;

Overrides

TSupervisedModel.Calculate
See Also

Reference

  • TBIClustering
  • BI.Algorithm.Clustering


TBIClustering.Evaluation Method

Summary

Represents method Evaluation.

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
public
 function Evaluation:Double;

Return Value

Type: Double

See Also

Reference

  • TBIClustering
  • BI.Algorithm.Clustering


TBIClustering.Summary Method

Summary

Represents method Summary.

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
public
 function Summary:TDataItem;

Return Value

Type: TDataItem

See Also

Reference

  • TBIClustering
  • BI.Algorithm.Clustering


TBIClustering Fields

Fields
Name | Description
Options | Represents field Options.
Output | Represents field Output.
Top


TBIClustering.Options Field

Summary

Represents field Options.

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
public
 Options : TBIProvider;

Field Value

Type: TBIProvider

See Also

Reference

  • TBIClustering
  • BI.Algorithm.Clustering


TBIClustering.Output Field

Summary

Represents field Output.

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
public
 Output : TCluster;

Field Value

Type: TCluster

See Also

Reference

  • TBIClustering
  • BI.Algorithm.Clustering


TBIProvider Class

Summary

Represents type TBIProvider.

Namespace: BI.Algorithm.Clustering
Inheritance Hierarchy
TObject
BI.Algorithm.Clustering.Engine.TClusterProvider
BI.Algorithm.Clustering.TBIProvider
Syntax
Delphi
type
 TBIProvider=class(TClusterProvider)
 end;

The TBIProvider type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TBIProvider class.
Top
Properties
Show:
Name | Description
Distance | Represents property Distance.
Linkage | Represents property Linkage.
Method | Represents property Method.
MinkowskiLambda | Represents property MinkowskiLambda.
NumClusters | Represents property NumClusters.
Top
Methods
Show:
Name | Description
CalcDistanceData(Integer,Integer) | Overloaded. Represents method CalcDistanceData(Integer,Integer). (Overrides TClusterProvider.CalcDistanceData(Integer,Integer).)
CalcDistanceData(Integer,TCluster) | Overloaded. Represents method CalcDistanceData(Integer,TCluster). (Overrides TClusterProvider.CalcDistanceData(Integer,TCluster).)
CalcDistanceData(TCluster,TCluster) | Overloaded. Represents method CalcDistanceData(TCluster,TCluster). (Overrides TClusterProvider.CalcDistanceData(TCluster,TCluster).)
CalcDistanceData(TClusterData,TClusterData) | Overloaded. Represents method CalcDistanceData(TClusterData,TClusterData).
CloneData(TClusterData) | Represents method CloneData(TClusterData). (Overrides TClusterProvider.CloneData(TClusterData).)
GetData(Integer) | Represents method GetData(Integer). (Overrides TClusterProvider.GetData(Integer).)
RecalcValues(TCluster) | Represents method RecalcValues(TCluster). (Overrides TClusterProvider.RecalcValues(TCluster).)
SourceCount | Represents method SourceCount. (Overrides TClusterProvider.SourceCount.)
Top
See Also

Reference

  • BI.Algorithm.Clustering


TBIProvider Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TBIProvider class.
Top


TBIProvider.Destroy Destructor

Summary

Represents the destructor of the TBIProvider class.

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIProvider
  • BI.Algorithm.Clustering


TBIProvider Properties

Properties
Name | Description
Distance | Represents property Distance.
Linkage | Represents property Linkage.
Method | Represents property Method.
MinkowskiLambda | Represents property MinkowskiLambda.
NumClusters | Represents property NumClusters.
Top


TBIProvider.Distance Property

Summary

Represents property Distance.

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
public
 property Distance:TDistanceMethod read FDistance write SetDistance default Euclidean;

Property Value

Type: TDistanceMethod

See Also

Reference

  • TBIProvider
  • BI.Algorithm.Clustering


TBIProvider.Linkage Property

Summary

Represents property Linkage.

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
public
 property Linkage:TLinkageMethod read FLinkage write SetLinkage default lmNone;

Property Value

Type: TLinkageMethod

See Also

Reference

  • TBIProvider
  • BI.Algorithm.Clustering


TBIProvider.Method Property

Summary

Represents property Method.

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
public
 property Method: TClusteringMethod read FMethod write SetMethod default KMeans;

Property Value

Type: TClusteringMethod

See Also

Reference

  • TBIProvider
  • BI.Algorithm.Clustering


TBIProvider.MinkowskiLambda Property

Summary

Represents property MinkowskiLambda.

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
public
 property MinkowskiLambda:Single read FLambda write SetLambda;

Property Value

Type: Single

See Also

Reference

  • TBIProvider
  • BI.Algorithm.Clustering


TBIProvider.NumClusters Property

Summary

Represents property NumClusters.

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
public
 property NumClusters:Integer read FNumClusters write FNumClusters;

Property Value

Type: Integer

See Also

Reference

  • TBIProvider
  • BI.Algorithm.Clustering


TBIProvider Methods

Methods
Name | Description
CalcDistanceData(Integer,Integer) | Overloaded. Represents method CalcDistanceData(Integer,Integer). (Overrides TClusterProvider.CalcDistanceData(Integer,Integer).)
CalcDistanceData(Integer,TCluster) | Overloaded. Represents method CalcDistanceData(Integer,TCluster). (Overrides TClusterProvider.CalcDistanceData(Integer,TCluster).)
CalcDistanceData(TCluster,TCluster) | Overloaded. Represents method CalcDistanceData(TCluster,TCluster). (Overrides TClusterProvider.CalcDistanceData(TCluster,TCluster).)
CalcDistanceData(TClusterData,TClusterData) | Overloaded. Represents method CalcDistanceData(TClusterData,TClusterData).
CloneData(TClusterData) | Represents method CloneData(TClusterData). (Overrides TClusterProvider.CloneData(TClusterData).)
GetData(Integer) | Represents method GetData(Integer). (Overrides TClusterProvider.GetData(Integer).)
RecalcValues(TCluster) | Represents method RecalcValues(TCluster). (Overrides TClusterProvider.RecalcValues(TCluster).)
SourceCount | Represents method SourceCount. (Overrides TClusterProvider.SourceCount.)
Top


TBIProvider.CalcDistanceData(Integer,Integer) Method

Summary

Represents method CalcDistanceData(Integer,Integer).

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
protected
 function CalcDistanceData(const A,B:Integer):TClusterValue; overload; override;

Parameters

A
Type: Integer

B
Type: Integer

Return Value

Type: TClusterValue

Overrides

TClusterProvider.CalcDistanceData(Integer,Integer)
See Also

Reference

  • TBIProvider
  • BI.Algorithm.Clustering


TBIProvider.CalcDistanceData(Integer,TCluster) Method

Summary

Represents method CalcDistanceData(Integer,TCluster).

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
protected
 function CalcDistanceData(const A:Integer; const B:TCluster):TClusterValue; overload; override;

Parameters

A
Type: Integer

B
Type: TCluster

Return Value

Type: TClusterValue

Overrides

TClusterProvider.CalcDistanceData(Integer,TCluster)
See Also

Reference

  • TBIProvider
  • BI.Algorithm.Clustering


TBIProvider.CalcDistanceData(TCluster,TCluster) Method

Summary

Represents method CalcDistanceData(TCluster,TCluster).

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
protected
 function CalcDistanceData(const A,B:TCluster):TClusterValue; overload; override;

Parameters

A
Type: TCluster

B
Type: TCluster

Return Value

Type: TClusterValue

Overrides

TClusterProvider.CalcDistanceData(TCluster,TCluster)
See Also

Reference

  • TBIProvider
  • BI.Algorithm.Clustering


TBIProvider.CalcDistanceData(TClusterData,TClusterData) Method

Summary

Represents method CalcDistanceData(TClusterData,TClusterData).

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
protected
 function CalcDistanceData(const A,B:TClusterData):TClusterValue; overload;

Parameters

A
Type: TClusterData

B
Type: TClusterData

Return Value

Type: TClusterValue

See Also

Reference

  • TBIProvider
  • BI.Algorithm.Clustering


TBIProvider.CloneData(TClusterData) Method

Summary

Represents method CloneData(TClusterData).

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
protected
 function CloneData(const AData:TClusterData):TClusterData; override;

Parameters

AData
Type: TClusterData

Return Value

Type: TClusterData

Overrides

TClusterProvider.CloneData(TClusterData)
See Also

Reference

  • TBIProvider
  • BI.Algorithm.Clustering


TBIProvider.GetData(Integer) Method

Summary

Represents method GetData(Integer).

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
protected
 function GetData(const Index:Integer):TClusterData; override;

Parameters

Index
Type: Integer

Return Value

Type: TClusterData

Overrides

TClusterProvider.GetData(Integer)
See Also

Reference

  • TBIProvider
  • BI.Algorithm.Clustering


TBIProvider.RecalcValues(TCluster) Method

Summary

Represents method RecalcValues(TCluster).

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
protected
 procedure RecalcValues(const ACluster:TCluster); override;

Parameters

ACluster
Type: TCluster

Overrides

TClusterProvider.RecalcValues(TCluster)
See Also

Reference

  • TBIProvider
  • BI.Algorithm.Clustering


TBIProvider.SourceCount Method

Summary

Represents method SourceCount.

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
protected
 function SourceCount:Integer; override;

Return Value

Type: Integer

Overrides

TClusterProvider.SourceCount
See Also

Reference

  • TBIProvider
  • BI.Algorithm.Clustering


BI.Algorithm.Clustering Enumerations

Enumerations
Name | Description
TClusteringMethod | Represents type TClusteringMethod.
TDistanceMethod | Represents type TDistanceMethod.
Top


TClusteringMethod Enumeration

Summary

Represents type TClusteringMethod.

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
type
 TClusteringMethod=(KMeans, Hierarchical, QT);

The TClusteringMethod type exposes the following members.

Members
Show:
Name | Description
Hierarchical | Represents constant Hierarchical.
KMeans | Represents constant KMeans.
QT | Represents constant QT.
Top
See Also

Reference

  • BI.Algorithm.Clustering


TDistanceMethod Enumeration

Summary

Represents type TDistanceMethod.

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
type
 TDistanceMethod=(Euclidean, SquaredEuclidean, Manhattan, Minkowski, Sorensen, Chebyshev);

The TDistanceMethod type exposes the following members.

Members
Show:
Name | Description
Chebyshev | Represents constant Chebyshev.
Euclidean | Represents constant Euclidean.
Manhattan | Represents constant Manhattan.
Minkowski | Represents constant Minkowski.
Sorensen | Represents constant Sorensen.
SquaredEuclidean | Represents constant SquaredEuclidean.
Top
See Also

Reference

  • BI.Algorithm.Clustering


BI.Algorithm.Clustering Delegates

Delegates
Name | Description
TCalcDistanceFunc | Represents type TCalcDistanceFunc.
Top


TCalcDistanceFunc Delegate

Summary

Represents type TCalcDistanceFunc.

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
type
 TCalcDistanceFunc=function(const A,B:TClusterData):TClusterValue;
See Also

Reference

  • BI.Algorithm.Clustering


BI.Algorithm.Clustering Routines

Routines
Name | Description
DistChebyshev(TClusterData,TClusterData) | Represents method DistChebyshev(TClusterData,TClusterData).
DistEuclidean(TClusterData,TClusterData) | Represents method DistEuclidean(TClusterData,TClusterData).
DistManhattan(TClusterData,TClusterData) | Represents method DistManhattan(TClusterData,TClusterData).
DistSorensen(TClusterData,TClusterData) | Represents method DistSorensen(TClusterData,TClusterData).
DistSqrEuclidean(TClusterData,TClusterData) | Represents method DistSqrEuclidean(TClusterData,TClusterData).
TeeHypot(Integer,Integer) | Overloaded. Represents method TeeHypot(Integer,Integer).
TeeHypot(TClusterValue,TClusterValue) | Overloaded. Represents method TeeHypot(TClusterValue,TClusterValue).
Top


DistChebyshev(TClusterData,TClusterData) Method

Summary

Represents method DistChebyshev(TClusterData,TClusterData).

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
function DistChebyshev(const A,B:TClusterData):TClusterValue;

Parameters

A
Type: TClusterData

B
Type: TClusterData

Return Value

Type: TClusterValue

See Also

Reference

  • BI.Algorithm.Clustering


DistEuclidean(TClusterData,TClusterData) Method

Summary

Represents method DistEuclidean(TClusterData,TClusterData).

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
function DistEuclidean(const A,B:TClusterData):TClusterValue;

Parameters

A
Type: TClusterData

B
Type: TClusterData

Return Value

Type: TClusterValue

See Also

Reference

  • BI.Algorithm.Clustering


DistManhattan(TClusterData,TClusterData) Method

Summary

Represents method DistManhattan(TClusterData,TClusterData).

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
function DistManhattan(const A,B:TClusterData):TClusterValue;

Parameters

A
Type: TClusterData

B
Type: TClusterData

Return Value

Type: TClusterValue

See Also

Reference

  • BI.Algorithm.Clustering


DistSorensen(TClusterData,TClusterData) Method

Summary

Represents method DistSorensen(TClusterData,TClusterData).

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
function DistSorensen(const A,B:TClusterData):TClusterValue;

Parameters

A
Type: TClusterData

B
Type: TClusterData

Return Value

Type: TClusterValue

See Also

Reference

  • BI.Algorithm.Clustering


DistSqrEuclidean(TClusterData,TClusterData) Method

Summary

Represents method DistSqrEuclidean(TClusterData,TClusterData).

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
function DistSqrEuclidean(const A,B:TClusterData):TClusterValue;

Parameters

A
Type: TClusterData

B
Type: TClusterData

Return Value

Type: TClusterValue

See Also

Reference

  • BI.Algorithm.Clustering


TeeHypot(Integer,Integer) Method

Summary

Represents method TeeHypot(Integer,Integer).

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
function TeeHypot(const X,Y:Integer):TClusterValue; overload;

Parameters

X
Type: Integer

Y
Type: Integer

Return Value

Type: TClusterValue

See Also

Reference

  • BI.Algorithm.Clustering


TeeHypot(TClusterValue,TClusterValue) Method

Summary

Represents method TeeHypot(TClusterValue,TClusterValue).

Namespace: BI.Algorithm.Clustering
Syntax
Delphi
function TeeHypot(const X,Y:TClusterValue):TClusterValue; overload;

Parameters

X
Type: System.Void

Y
Type: System.Void

Return Value

Type: TClusterValue

See Also

Reference

  • BI.Algorithm.Clustering


BI.Algorithm.Clustering.Engine Namespace

Summary

Represents namespace BI.Algorithm.Clustering.Engine.

Classes
Name | Description
TBaseClustering | Represents type TBaseClustering.
TCluster | Represents type TCluster.
TClusterProvider | Represents type TClusterProvider.
TFastList | Represents type TFastList.
TFloatList | Represents type TFloatList.
THierarchicalClustering | Represents type THierarchicalClustering.
TKMeansClustering | Represents type TKMeansClustering.
TMatrix | Represents type TMatrix.
TMatrixList | Represents type TMatrixList.
TQTClustering | Represents type TQTClustering.
Top
Records
Name | Description
TClusterEvaluation | Represents type TClusterEvaluation.
TDistance | Represents type TDistance.
TMatrixItem | Represents type TMatrixItem.
Top
Enumerations
Name | Description
TLinkageMethod | Represents type TLinkageMethod.
Top
Types
Name | Description
PMatrixItem | Represents a pointer type to TMatrixItem.
PPointerList | Represents a pointer type to TPointerList.
TClusterData | Represents an array of the TClusterValue type.
TClusterValue | Represents an alias of the Single type.
TDistances | Represents an array of the TDistance type.
TPointerList | Represents an array of the Pointer type.
Top


BI.Algorithm.Clustering.Engine Classes

Classes
Name | Description
TBaseClustering | Represents type TBaseClustering.
TCluster | Represents type TCluster.
TClusterProvider | Represents type TClusterProvider.
TFastList | Represents type TFastList.
TFloatList | Represents type TFloatList.
THierarchicalClustering | Represents type THierarchicalClustering.
TKMeansClustering | Represents type TKMeansClustering.
TMatrix | Represents type TMatrix.
TMatrixList | Represents type TMatrixList.
TQTClustering | Represents type TQTClustering.
Top


TBaseClustering Class

Summary

Represents type TBaseClustering.

Namespace: BI.Algorithm.Clustering.Engine
Inheritance Hierarchy
TPersistent
BI.Algorithm.Clustering.Engine.TBaseClustering
BI.Algorithm.Clustering.Engine.THierarchicalClustering
BI.Algorithm.Clustering.Engine.TKMeansClustering
BI.Algorithm.Clustering.Engine.TQTClustering
Syntax
Delphi
type
 TBaseClustering=class(TPersistent)
 end;

The TBaseClustering type exposes the following members.

Constructors
Show:
Name | Description
Create(TClusterProvider) | Initializes a new instance of the TBaseClustering class.
Destroy | Represents the destructor of the TBaseClustering class.
Top
Properties
Show:
Name | Description
Linkage | Represents property Linkage.
Provider | Represents property Provider.
Top
Methods
Show:
Name | Description
CalcDistance(TCluster,TCluster) | Represents method CalcDistance(TCluster,TCluster).
Evaluation(TCluster) | Represents method Evaluation(TCluster).
Execute | Represents method Execute.
IsUndefined(TCluster) | Represents method IsUndefined(TCluster).
Scatter(TCluster) | Overloaded. Represents method Scatter(TCluster).
Scatter(TCluster,TCluster) | Overloaded. Represents method Scatter(TCluster,TCluster).
Top
Fields
Show:
Name | Description
Clusters | Represents field Clusters.
Top
See Also

Reference

  • BI.Algorithm.Clustering.Engine


TBaseClustering Constructors

Constructors
Name | Description
Create(TClusterProvider) | Initializes a new instance of the TBaseClustering class.
Destroy | Represents the destructor of the TBaseClustering class.
Top


TBaseClustering.Create(TClusterProvider) Constructor

Summary

Initializes a new instance of the TBaseClustering class.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 Constructor Create(const AProvider:TClusterProvider); virtual;

Parameters

AProvider
Type: TClusterProvider

See Also

Reference

  • TBaseClustering
  • BI.Algorithm.Clustering.Engine


TBaseClustering.Destroy Destructor

Summary

Represents the destructor of the TBaseClustering class.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBaseClustering
  • BI.Algorithm.Clustering.Engine


TBaseClustering Properties

Properties
Name | Description
Linkage | Represents property Linkage.
Provider | Represents property Provider.
Top


TBaseClustering.Linkage Property

Summary

Represents property Linkage.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
published
 property Linkage:TLinkageMethod read FLinkage write FLinkage default lmNone;

Property Value

Type: TLinkageMethod

See Also

Reference

  • TBaseClustering
  • BI.Algorithm.Clustering.Engine


TBaseClustering.Provider Property

Summary

Represents property Provider.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
published
 property Provider:TClusterProvider read FProvider;

Property Value

Type: TClusterProvider

See Also

Reference

  • TBaseClustering
  • BI.Algorithm.Clustering.Engine


TBaseClustering Methods

Methods
Name | Description
CalcDistance(TCluster,TCluster) | Represents method CalcDistance(TCluster,TCluster).
Evaluation(TCluster) | Represents method Evaluation(TCluster).
Execute | Represents method Execute.
IsUndefined(TCluster) | Represents method IsUndefined(TCluster).
Scatter(TCluster) | Overloaded. Represents method Scatter(TCluster).
Scatter(TCluster,TCluster) | Overloaded. Represents method Scatter(TCluster,TCluster).
Top


TBaseClustering.CalcDistance(TCluster,TCluster) Method

Summary

Represents method CalcDistance(TCluster,TCluster).

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
protected
 function CalcDistance(const A,B:TCluster):Single;

Parameters

A
Type: TCluster

B
Type: TCluster

Return Value

Type: Single

See Also

Reference

  • TBaseClustering
  • BI.Algorithm.Clustering.Engine


TBaseClustering.Evaluation(TCluster) Method

Summary

Represents method Evaluation(TCluster).

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 function Evaluation(const ACluster:TCluster):TClusterEvaluation;

Parameters

ACluster
Type: TCluster

Return Value

Type: TClusterEvaluation

See Also

Reference

  • TBaseClustering
  • BI.Algorithm.Clustering.Engine


TBaseClustering.Execute Method

Summary

Represents method Execute.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 function Execute:TCluster; virtual;

Return Value

Type: TCluster

See Also

Reference

  • TBaseClustering
  • BI.Algorithm.Clustering.Engine


TBaseClustering.IsUndefined(TCluster) Method

Summary

Represents method IsUndefined(TCluster).

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 class function IsUndefined(const ACluster:TCluster):Boolean;

Parameters

ACluster
Type: TCluster

Return Value

Type: Boolean

See Also

Reference

  • TBaseClustering
  • BI.Algorithm.Clustering.Engine


TBaseClustering.Scatter(TCluster) Method

Summary

Represents method Scatter(TCluster).

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 function Scatter(const ACluster:TCluster):Double; overload;

Parameters

ACluster
Type: TCluster

Return Value

Type: Double

See Also

Reference

  • TBaseClustering
  • BI.Algorithm.Clustering.Engine


TBaseClustering.Scatter(TCluster,TCluster) Method

Summary

Represents method Scatter(TCluster,TCluster).

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 function Scatter(const A,B:TCluster):Double; overload;

Parameters

A
Type: TCluster

B
Type: TCluster

Return Value

Type: Double

See Also

Reference

  • TBaseClustering
  • BI.Algorithm.Clustering.Engine


TBaseClustering Fields

Fields
Name | Description
Clusters | Represents field Clusters.
Top


TBaseClustering.Clusters Field

Summary

Represents field Clusters.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 Clusters : TCluster;

Field Value

Type: TCluster

See Also

Reference

  • TBaseClustering
  • BI.Algorithm.Clustering.Engine


TCluster Class

Summary

Represents type TCluster.

Namespace: BI.Algorithm.Clustering.Engine
Inheritance Hierarchy
TObject
BI.Algorithm.Clustering.Engine.TFastList
BI.Algorithm.Clustering.Engine.TCluster
Syntax
Delphi
type
 TCluster=class(TFastList)
 end;

The TCluster type exposes the following members.

Properties
Show:
Name | Description
Item[Integer] | Represents property Item[Integer].
Top
Methods
Show:
Name | Description
AddItem(Integer,TClusterData) | Represents method AddItem(Integer,TClusterData).
Clear | Represents method Clear. (Overrides TFastList.Clear.)
Top
Fields
Show:
Name | Description
Data | Represents field Data.
Index | Represents field Index.
Top
See Also

Reference

  • BI.Algorithm.Clustering.Engine


TCluster Properties

Properties
Name | Description
Item[Integer] | Represents property Item[Integer].
Top


TCluster.Item[Integer] Property

Summary

Represents property Item[Integer].

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 property Item[Index:Integer]:TCluster read Get; default;

Parameters

Index
Type: Integer

Property Value

Type: TCluster

See Also

Reference

  • TCluster
  • BI.Algorithm.Clustering.Engine


TCluster Methods

Methods
Name | Description
AddItem(Integer,TClusterData) | Represents method AddItem(Integer,TClusterData).
Clear | Represents method Clear. (Overrides TFastList.Clear.)
Top


TCluster.AddItem(Integer,TClusterData) Method

Summary

Represents method AddItem(Integer,TClusterData).

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 function AddItem(const AIndex:Integer; const AData:TClusterData):TCluster;

Parameters

AIndex
Type: Integer

AData
Type: TClusterData

Return Value

Type: TCluster

See Also

Reference

  • TCluster
  • BI.Algorithm.Clustering.Engine


TCluster.Clear Method

Summary

Represents method Clear.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 procedure Clear; override;

Overrides

TFastList.Clear
See Also

Reference

  • TCluster
  • BI.Algorithm.Clustering.Engine


TCluster Fields

Fields
Name | Description
Data | Represents field Data.
Index | Represents field Index.
Top


TCluster.Data Field

Summary

Represents field Data.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 Data : TClusterData;

Field Value

Type: TClusterData

See Also

Reference

  • TCluster
  • BI.Algorithm.Clustering.Engine


TCluster.Index Field

Summary

Represents field Index.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 Index : Integer;

Field Value

Type: Integer

See Also

Reference

  • TCluster
  • BI.Algorithm.Clustering.Engine


TClusterProvider Class

Summary

Represents type TClusterProvider.

Namespace: BI.Algorithm.Clustering.Engine
Inheritance Hierarchy
TObject
BI.Algorithm.Clustering.Engine.TClusterProvider
BI.Algorithm.Clustering.TBIProvider
Syntax
Delphi
type
 TClusterProvider=class abstract
 end;

The TClusterProvider type exposes the following members.

Methods
Show:
Name | Description
BeginClustering | Represents method BeginClustering.
CalcDistanceData(Integer,Integer) | Overloaded. Represents method CalcDistanceData(Integer,Integer).
CalcDistanceData(Integer,TCluster) | Overloaded. Represents method CalcDistanceData(Integer,TCluster).
CalcDistanceData(TCluster,TCluster) | Overloaded. Represents method CalcDistanceData(TCluster,TCluster).
CloneData(TClusterData) | Represents method CloneData(TClusterData).
EndClustering | Represents method EndClustering.
GetData(Integer) | Represents method GetData(Integer).
RecalcValues(TCluster) | Represents method RecalcValues(TCluster).
SourceCount | Represents method SourceCount.
Top
See Also

Reference

  • BI.Algorithm.Clustering.Engine


TClusterProvider Methods

Methods
Name | Description
BeginClustering | Represents method BeginClustering.
CalcDistanceData(Integer,Integer) | Overloaded. Represents method CalcDistanceData(Integer,Integer).
CalcDistanceData(Integer,TCluster) | Overloaded. Represents method CalcDistanceData(Integer,TCluster).
CalcDistanceData(TCluster,TCluster) | Overloaded. Represents method CalcDistanceData(TCluster,TCluster).
CloneData(TClusterData) | Represents method CloneData(TClusterData).
EndClustering | Represents method EndClustering.
GetData(Integer) | Represents method GetData(Integer).
RecalcValues(TCluster) | Represents method RecalcValues(TCluster).
SourceCount | Represents method SourceCount.
Top


TClusterProvider.BeginClustering Method

Summary

Represents method BeginClustering.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
protected
 procedure BeginClustering; virtual;
See Also

Reference

  • TClusterProvider
  • BI.Algorithm.Clustering.Engine


TClusterProvider.CalcDistanceData(Integer,Integer) Method

Summary

Represents method CalcDistanceData(Integer,Integer).

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
protected
 function CalcDistanceData(const A,B:Integer):Single; overload; virtual; abstract;

Parameters

A
Type: Integer

B
Type: Integer

Return Value

Type: Single

See Also

Reference

  • TClusterProvider
  • BI.Algorithm.Clustering.Engine


TClusterProvider.CalcDistanceData(Integer,TCluster) Method

Summary

Represents method CalcDistanceData(Integer,TCluster).

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
protected
 function CalcDistanceData(const A:Integer; const B:TCluster):Single; overload; virtual; abstract;

Parameters

A
Type: Integer

B
Type: TCluster

Return Value

Type: Single

See Also

Reference

  • TClusterProvider
  • BI.Algorithm.Clustering.Engine


TClusterProvider.CalcDistanceData(TCluster,TCluster) Method

Summary

Represents method CalcDistanceData(TCluster,TCluster).

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
protected
 function CalcDistanceData(const A,B:TCluster):Single; overload; virtual; abstract;

Parameters

A
Type: TCluster

B
Type: TCluster

Return Value

Type: Single

See Also

Reference

  • TClusterProvider
  • BI.Algorithm.Clustering.Engine


TClusterProvider.CloneData(TClusterData) Method

Summary

Represents method CloneData(TClusterData).

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
protected
 function CloneData(const AData:TClusterData):TClusterData; virtual; abstract;

Parameters

AData
Type: TClusterData

Return Value

Type: TClusterData

See Also

Reference

  • TClusterProvider
  • BI.Algorithm.Clustering.Engine


TClusterProvider.EndClustering Method

Summary

Represents method EndClustering.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
protected
 procedure EndClustering; virtual;
See Also

Reference

  • TClusterProvider
  • BI.Algorithm.Clustering.Engine


TClusterProvider.GetData(Integer) Method

Summary

Represents method GetData(Integer).

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
protected
 function GetData(const Index:Integer):TClusterData; virtual; abstract;

Parameters

Index
Type: Integer

Return Value

Type: TClusterData

See Also

Reference

  • TClusterProvider
  • BI.Algorithm.Clustering.Engine


TClusterProvider.RecalcValues(TCluster) Method

Summary

Represents method RecalcValues(TCluster).

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
protected
 procedure RecalcValues(const ACluster:TCluster); virtual; abstract;

Parameters

ACluster
Type: TCluster

See Also

Reference

  • TClusterProvider
  • BI.Algorithm.Clustering.Engine


TClusterProvider.SourceCount Method

Summary

Represents method SourceCount.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
protected
 function SourceCount:Integer; virtual; abstract;

Return Value

Type: Integer

See Also

Reference

  • TClusterProvider
  • BI.Algorithm.Clustering.Engine


TFastList Class

Summary

Represents type TFastList.

Namespace: BI.Algorithm.Clustering.Engine
Inheritance Hierarchy
TObject
BI.Algorithm.Clustering.Engine.TFastList
BI.Algorithm.Clustering.Engine.TCluster
BI.Algorithm.Clustering.Engine.TMatrixList
Syntax
Delphi
type
 TFastList=class
 end;

The TFastList type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TFastList class.
Top
Properties
Show:
Name | Description
Count | Represents property Count.
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Add(Pointer) | Represents method Add(Pointer).
Clear | Represents method Clear.
Delete(Integer) | Represents method Delete(Integer).
Top
See Also

Reference

  • BI.Algorithm.Clustering.Engine


TFastList Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TFastList class.
Top


TFastList.Destroy Destructor

Summary

Represents the destructor of the TFastList class.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TFastList
  • BI.Algorithm.Clustering.Engine


TFastList Properties

Properties
Name | Description
Count | Represents property Count.
Items[Integer] | Represents property Items[Integer].
Top


TFastList.Count Property

Summary

Represents property Count.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 property Count:Integer read FCount;

Property Value

Type: Integer

See Also

Reference

  • TFastList
  • BI.Algorithm.Clustering.Engine


TFastList.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 property Items[Index:Integer]:Pointer read Get; default;

Parameters

Index
Type: Integer

Property Value

Type: Pointer

See Also

Reference

  • TFastList
  • BI.Algorithm.Clustering.Engine


TFastList Methods

Methods
Name | Description
Add(Pointer) | Represents method Add(Pointer).
Clear | Represents method Clear.
Delete(Integer) | Represents method Delete(Integer).
Top


TFastList.Add(Pointer) Method

Summary

Represents method Add(Pointer).

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 procedure Add(const Item:Pointer);

Parameters

Item
Type: Pointer

See Also

Reference

  • TFastList
  • BI.Algorithm.Clustering.Engine


TFastList.Clear Method

Summary

Represents method Clear.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 procedure Clear; virtual;
See Also

Reference

  • TFastList
  • BI.Algorithm.Clustering.Engine


TFastList.Delete(Integer) Method

Summary

Represents method Delete(Integer).

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 procedure Delete(const Index:Integer);

Parameters

Index
Type: Integer

See Also

Reference

  • TFastList
  • BI.Algorithm.Clustering.Engine


TFloatList Class

Summary

Represents type TFloatList.

Namespace: BI.Algorithm.Clustering.Engine
Inheritance Hierarchy
TObject
BI.Algorithm.Clustering.Engine.TFloatList
BI.Algorithm.Clustering.Engine.TMatrix
Syntax
Delphi
type
 TFloatList=class
 end;

The TFloatList type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TFloatList class.
Top
Properties
Show:
Name | Description
Count | Represents property Count.
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Add(Single) | Represents method Add(Single).
Clear | Represents method Clear.
Delete(Integer) | Represents method Delete(Integer).
Top
See Also

Reference

  • BI.Algorithm.Clustering.Engine


TFloatList Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TFloatList class.
Top


TFloatList.Destroy Destructor

Summary

Represents the destructor of the TFloatList class.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TFloatList
  • BI.Algorithm.Clustering.Engine


TFloatList Properties

Properties
Name | Description
Count | Represents property Count.
Items[Integer] | Represents property Items[Integer].
Top


TFloatList.Count Property

Summary

Represents property Count.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 property Count:Integer read FCount;

Property Value

Type: Integer

See Also

Reference

  • TFloatList
  • BI.Algorithm.Clustering.Engine


TFloatList.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 property Items[Index:Integer]:Single read Get; default;

Parameters

Index
Type: Integer

Property Value

Type: Single

See Also

Reference

  • TFloatList
  • BI.Algorithm.Clustering.Engine


TFloatList Methods

Methods
Name | Description
Add(Single) | Represents method Add(Single).
Clear | Represents method Clear.
Delete(Integer) | Represents method Delete(Integer).
Top


TFloatList.Add(Single) Method

Summary

Represents method Add(Single).

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 procedure Add(const Item:Single);

Parameters

Item
Type: Single

See Also

Reference

  • TFloatList
  • BI.Algorithm.Clustering.Engine


TFloatList.Clear Method

Summary

Represents method Clear.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 procedure Clear; virtual;
See Also

Reference

  • TFloatList
  • BI.Algorithm.Clustering.Engine


TFloatList.Delete(Integer) Method

Summary

Represents method Delete(Integer).

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 procedure Delete(const Index:Integer);

Parameters

Index
Type: Integer

See Also

Reference

  • TFloatList
  • BI.Algorithm.Clustering.Engine


THierarchicalClustering Class

Summary

Represents type THierarchicalClustering.

Namespace: BI.Algorithm.Clustering.Engine
Inheritance Hierarchy
TPersistent
BI.Algorithm.Clustering.Engine.TBaseClustering
BI.Algorithm.Clustering.Engine.THierarchicalClustering
Syntax
Delphi
type
 THierarchicalClustering=class(TBaseClustering)
 end;

The THierarchicalClustering type exposes the following members.

Constructors
Show:
Name | Description
Create(TClusterProvider) | Initializes a new instance of the THierarchicalClustering class. (Overrides TBaseClustering.Create(TClusterProvider).)
Top
Properties
Show:
Name | Description
NumClusters | Represents property NumClusters.
Top
Methods
Show:
Name | Description
Execute | Represents method Execute. (Overrides TBaseClustering.Execute.)
Top
See Also

Reference

  • BI.Algorithm.Clustering.Engine


THierarchicalClustering Constructors

Constructors
Name | Description
Create(TClusterProvider) | Initializes a new instance of the THierarchicalClustering class. (Overrides TBaseClustering.Create(TClusterProvider).)
Top


THierarchicalClustering.Create(TClusterProvider) Constructor

Summary

Initializes a new instance of the THierarchicalClustering class.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 Constructor Create(const AProvider:TClusterProvider); override;

Parameters

AProvider
Type: TClusterProvider

Overrides

TBaseClustering.Create(TClusterProvider)
See Also

Reference

  • THierarchicalClustering
  • BI.Algorithm.Clustering.Engine


THierarchicalClustering Properties

Properties
Name | Description
NumClusters | Represents property NumClusters.
Top


THierarchicalClustering.NumClusters Property

Summary

Represents property NumClusters.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
published
 property NumClusters:Integer read FCount write FCount default 5;

Property Value

Type: Integer

See Also

Reference

  • THierarchicalClustering
  • BI.Algorithm.Clustering.Engine


THierarchicalClustering Methods

Methods
Name | Description
Execute | Represents method Execute. (Overrides TBaseClustering.Execute.)
Top


THierarchicalClustering.Execute Method

Summary

Represents method Execute.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 function Execute:TCluster; override;

Return Value

Type: TCluster

Overrides

TBaseClustering.Execute
See Also

Reference

  • THierarchicalClustering
  • BI.Algorithm.Clustering.Engine


TKMeansClustering Class

Summary

Represents type TKMeansClustering.

Namespace: BI.Algorithm.Clustering.Engine
Inheritance Hierarchy
TPersistent
BI.Algorithm.Clustering.Engine.TBaseClustering
BI.Algorithm.Clustering.Engine.TKMeansClustering
Syntax
Delphi
type
 TKMeansClustering=class(TBaseClustering)
 end;

The TKMeansClustering type exposes the following members.

Constructors
Show:
Name | Description
Create(TClusterProvider) | Initializes a new instance of the TKMeansClustering class. (Overrides TBaseClustering.Create(TClusterProvider).)
Top
Properties
Show:
Name | Description
MaxIterations | Represents property MaxIterations.
NumClusters | Represents property NumClusters.
Top
Methods
Show:
Name | Description
Execute | Represents method Execute. (Overrides TBaseClustering.Execute.)
Top
See Also

Reference

  • BI.Algorithm.Clustering.Engine


TKMeansClustering Constructors

Constructors
Name | Description
Create(TClusterProvider) | Initializes a new instance of the TKMeansClustering class. (Overrides TBaseClustering.Create(TClusterProvider).)
Top


TKMeansClustering.Create(TClusterProvider) Constructor

Summary

Initializes a new instance of the TKMeansClustering class.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 Constructor Create(const AProvider:TClusterProvider); override;

Parameters

AProvider
Type: TClusterProvider

Overrides

TBaseClustering.Create(TClusterProvider)
See Also

Reference

  • TKMeansClustering
  • BI.Algorithm.Clustering.Engine


TKMeansClustering Properties

Properties
Name | Description
MaxIterations | Represents property MaxIterations.
NumClusters | Represents property NumClusters.
Top


TKMeansClustering.MaxIterations Property

Summary

Represents property MaxIterations.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
published
 property MaxIterations:Integer read FMaxIter write FMaxIter default 1000;

Property Value

Type: Integer

See Also

Reference

  • TKMeansClustering
  • BI.Algorithm.Clustering.Engine


TKMeansClustering.NumClusters Property

Summary

Represents property NumClusters.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
published
 property NumClusters:Integer read FKCount write FKCount default 5;

Property Value

Type: Integer

See Also

Reference

  • TKMeansClustering
  • BI.Algorithm.Clustering.Engine


TKMeansClustering Methods

Methods
Name | Description
Execute | Represents method Execute. (Overrides TBaseClustering.Execute.)
Top


TKMeansClustering.Execute Method

Summary

Represents method Execute.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 function Execute:TCluster; override;

Return Value

Type: TCluster

Overrides

TBaseClustering.Execute
See Also

Reference

  • TKMeansClustering
  • BI.Algorithm.Clustering.Engine


TMatrix Class

Summary

Represents type TMatrix.

Namespace: BI.Algorithm.Clustering.Engine
Inheritance Hierarchy
TObject
BI.Algorithm.Clustering.Engine.TFloatList
BI.Algorithm.Clustering.Engine.TMatrix
Syntax
Delphi
type
 TMatrix=class(TFloatList)
 end;

The TMatrix type exposes the following members.

Methods
Show:
Name | Description
Clear | Represents method Clear. (Overrides TFloatList.Clear.)
Top
See Also

Reference

  • BI.Algorithm.Clustering.Engine


TMatrix Methods

Methods
Name | Description
Clear | Represents method Clear. (Overrides TFloatList.Clear.)
Top


TMatrix.Clear Method

Summary

Represents method Clear.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 procedure Clear; override;

Overrides

TFloatList.Clear
See Also

Reference

  • TMatrix
  • BI.Algorithm.Clustering.Engine


TMatrixList Class

Summary

Represents type TMatrixList.

Namespace: BI.Algorithm.Clustering.Engine
Inheritance Hierarchy
TObject
BI.Algorithm.Clustering.Engine.TFastList
BI.Algorithm.Clustering.Engine.TMatrixList
Syntax
Delphi
type
 TMatrixList=class(TFastList)
 end;

The TMatrixList type exposes the following members.

Methods
Show:
Name | Description
Clear | Represents method Clear. (Overrides TFastList.Clear.)
Top
See Also

Reference

  • BI.Algorithm.Clustering.Engine


TMatrixList Methods

Methods
Name | Description
Clear | Represents method Clear. (Overrides TFastList.Clear.)
Top


TMatrixList.Clear Method

Summary

Represents method Clear.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 procedure Clear; override;

Overrides

TFastList.Clear
See Also

Reference

  • TMatrixList
  • BI.Algorithm.Clustering.Engine


TQTClustering Class

Summary

Represents type TQTClustering.

Namespace: BI.Algorithm.Clustering.Engine
Inheritance Hierarchy
TPersistent
BI.Algorithm.Clustering.Engine.TBaseClustering
BI.Algorithm.Clustering.Engine.TQTClustering
Syntax
Delphi
type
 TQTClustering=class(TBaseClustering)
 end;

The TQTClustering type exposes the following members.

Constructors
Show:
Name | Description
Create(TClusterProvider) | Initializes a new instance of the TQTClustering class. (Overrides TBaseClustering.Create(TClusterProvider).)
Top
Properties
Show:
Name | Description
MaxDiameter | Represents property MaxDiameter.
MinCount | Represents property MinCount.
Top
Methods
Show:
Name | Description
Execute | Represents method Execute. (Overrides TBaseClustering.Execute.)
Top
See Also

Reference

  • BI.Algorithm.Clustering.Engine


TQTClustering Constructors

Constructors
Name | Description
Create(TClusterProvider) | Initializes a new instance of the TQTClustering class. (Overrides TBaseClustering.Create(TClusterProvider).)
Top


TQTClustering.Create(TClusterProvider) Constructor

Summary

Initializes a new instance of the TQTClustering class.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 Constructor Create(const AProvider:TClusterProvider); override;

Parameters

AProvider
Type: TClusterProvider

Overrides

TBaseClustering.Create(TClusterProvider)
See Also

Reference

  • TQTClustering
  • BI.Algorithm.Clustering.Engine


TQTClustering Properties

Properties
Name | Description
MaxDiameter | Represents property MaxDiameter.
MinCount | Represents property MinCount.
Top


TQTClustering.MaxDiameter Property

Summary

Represents property MaxDiameter.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
published
 property MaxDiameter:Double read FMaxDiameter write FMaxDiameter;

Property Value

Type: Double

See Also

Reference

  • TQTClustering
  • BI.Algorithm.Clustering.Engine


TQTClustering.MinCount Property

Summary

Represents property MinCount.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
published
 property MinCount:Integer read FMinCount write FMinCount default 1;

Property Value

Type: Integer

See Also

Reference

  • TQTClustering
  • BI.Algorithm.Clustering.Engine


TQTClustering Methods

Methods
Name | Description
Execute | Represents method Execute. (Overrides TBaseClustering.Execute.)
Top


TQTClustering.Execute Method

Summary

Represents method Execute.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 function Execute:TCluster; override;

Return Value

Type: TCluster

Overrides

TBaseClustering.Execute
See Also

Reference

  • TQTClustering
  • BI.Algorithm.Clustering.Engine


BI.Algorithm.Clustering.Engine Records

Records
Name | Description
TClusterEvaluation | Represents type TClusterEvaluation.
TDistance | Represents type TDistance.
TMatrixItem | Represents type TMatrixItem.
Top


TClusterEvaluation Record

Summary

Represents type TClusterEvaluation.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
type
 TClusterEvaluation=record
 end;

The TClusterEvaluation type exposes the following members.

Fields
Show:
Name | Description
DaviesBouldin | Represents field DaviesBouldin.
Dunn | Represents field Dunn.
Top
See Also

Reference

  • BI.Algorithm.Clustering.Engine


TClusterEvaluation Fields

Fields
Name | Description
DaviesBouldin | Represents field DaviesBouldin.
Dunn | Represents field Dunn.
Top


TClusterEvaluation.DaviesBouldin Field

Summary

Represents field DaviesBouldin.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 DaviesBouldin,
 Dunn : Double;

Field Value

Type: Double

See Also

Reference

  • TClusterEvaluation
  • BI.Algorithm.Clustering.Engine


TClusterEvaluation.Dunn Field

Summary

Represents field Dunn.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 DaviesBouldin,
 Dunn : Double;

Field Value

Type: Double

See Also

Reference

  • TClusterEvaluation
  • BI.Algorithm.Clustering.Engine


TDistance Record

Summary

Represents type TDistance.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
type
 TDistance=record
 end;

The TDistance type exposes the following members.

Fields
Show:
Name | Description
Index | Represents field Index.
Value | Represents field Value.
Top
See Also

Reference

  • BI.Algorithm.Clustering.Engine


TDistance Fields

Fields
Name | Description
Index | Represents field Index.
Value | Represents field Value.
Top


TDistance.Index Field

Summary

Represents field Index.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 Index : Integer;

Field Value

Type: Integer

See Also

Reference

  • TDistance
  • BI.Algorithm.Clustering.Engine


TDistance.Value Field

Summary

Represents field Value.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 Value : Single;

Field Value

Type: Single

See Also

Reference

  • TDistance
  • BI.Algorithm.Clustering.Engine


TMatrixItem Record

Summary

Represents type TMatrixItem.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
type
 TMatrixItem=record
 end;

The TMatrixItem type exposes the following members.

Fields
Show:
Name | Description
Next | Represents field Next.
Value | Represents field Value.
Top
See Also

Reference

  • BI.Algorithm.Clustering.Engine


TMatrixItem Fields

Fields
Name | Description
Next | Represents field Next.
Value | Represents field Value.
Top


TMatrixItem.Next Field

Summary

Represents field Next.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 Next : PMatrixItem;

Field Value

Type: PMatrixItem

See Also

Reference

  • TMatrixItem
  • BI.Algorithm.Clustering.Engine


TMatrixItem.Value Field

Summary

Represents field Value.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
public
 Value : Single;

Field Value

Type: Single

See Also

Reference

  • TMatrixItem
  • BI.Algorithm.Clustering.Engine


BI.Algorithm.Clustering.Engine Enumerations

Enumerations
Name | Description
TLinkageMethod | Represents type TLinkageMethod.
Top


TLinkageMethod Enumeration

Summary

Represents type TLinkageMethod.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
type
 TLinkageMethod=(lmNone, lmSingle, lmComplete, lmAverage, lmWard);

The TLinkageMethod type exposes the following members.

Members
Show:
Name | Description
lmAverage | Represents constant lmAverage.
lmComplete | Represents constant lmComplete.
lmNone | Represents constant lmNone.
lmSingle | Represents constant lmSingle.
lmWard | Represents constant lmWard.
Top
See Also

Reference

  • BI.Algorithm.Clustering.Engine


BI.Algorithm.Clustering.Engine Types

Types
Name | Description
PMatrixItem | Represents a pointer type to TMatrixItem.
PPointerList | Represents a pointer type to TPointerList.
TClusterData | Represents an array of the TClusterValue type.
TClusterValue | Represents an alias of the Single type.
TDistances | Represents an array of the TDistance type.
TPointerList | Represents an array of the Pointer type.
Top


PMatrixItem Type

Summary

Represents a pointer type to TMatrixItem.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
type
 PMatrixItem=^TMatrixItem;
See Also

Reference

  • BI.Algorithm.Clustering.Engine


PPointerList Type

Summary

Represents a pointer type to TPointerList.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
type
 PPointerList=^TPointerList;
See Also

Reference

  • BI.Algorithm.Clustering.Engine


TClusterData Type

Summary

Represents an array of the TClusterValue type.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
type
 TClusterData=Array of TClusterValue;
See Also

Reference

  • BI.Algorithm.Clustering.Engine


TClusterValue Type

Summary

Represents an alias of the Single type.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
type
 TClusterValue=Single;
See Also

Reference

  • BI.Algorithm.Clustering.Engine


TDistances Type

Summary

Represents an array of the TDistance type.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
type
 TDistances=Array of TDistance;
See Also

Reference

  • BI.Algorithm.Clustering.Engine


TPointerList Type

Summary

Represents an array of the Pointer type.

Namespace: BI.Algorithm.Clustering.Engine
Syntax
Delphi
type
 TPointerList = Array[0..(Maxint div 16) - 1] of Pointer;
See Also

Reference

  • BI.Algorithm.Clustering.Engine


BI.Algorithm.Clustering.Scikit Namespace

Summary

Represents namespace BI.Algorithm.Clustering.Scikit.

Classes
Name | Description
TBIScikitClustering | Represents type TBIScikitClustering.
Top


BI.Algorithm.Clustering.Scikit Classes

Classes
Name | Description
TBIScikitClustering | Represents type TBIScikitClustering.
Top


TBIScikitClustering Class

Summary

Represents type TBIScikitClustering.

Namespace: BI.Algorithm.Clustering.Scikit
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TBaseAlgorithm
BI.Algorithm.Model.TModel
BI.Algorithm.Model.TSupervisedModel
BI.Plugins.Python.TScikitSupervisedModel
BI.Algorithm.Clustering.Scikit.TBIScikitClustering
Syntax
Delphi
type
 TBIScikitClustering=class(TScikitSupervisedModel)
 end;

The TBIScikitClustering type exposes the following members.

Methods
Show:
Name | Description
BuildScript | Represents method BuildScript. (Overrides TScikitSupervisedModel.BuildScript.)
Calculate | Represents method Calculate. (Overrides TSupervisedModel.Calculate.)
Top
See Also

Reference

  • BI.Algorithm.Clustering.Scikit


TBIScikitClustering Methods

Methods
Name | Description
BuildScript | Represents method BuildScript. (Overrides TScikitSupervisedModel.BuildScript.)
Calculate | Represents method Calculate. (Overrides TSupervisedModel.Calculate.)
Top


TBIScikitClustering.BuildScript Method

Summary

Represents method BuildScript.

Namespace: BI.Algorithm.Clustering.Scikit
Syntax
Delphi
protected
 function BuildScript:TStrings; override;

Return Value

Type: TStrings

Overrides

TScikitSupervisedModel.BuildScript
See Also

Reference

  • TBIScikitClustering
  • BI.Algorithm.Clustering.Scikit


TBIScikitClustering.Calculate Method

Summary

Represents method Calculate.

Namespace: BI.Algorithm.Clustering.Scikit
Syntax
Delphi
public
 procedure Calculate; override;

Overrides

TSupervisedModel.Calculate
See Also

Reference

  • TBIScikitClustering
  • BI.Algorithm.Clustering.Scikit


BI.Algorithm.DecisionTree Namespace

Summary

Represents namespace BI.Algorithm.DecisionTree.

Classes
Name | Description
TDataAccess | Represents type TDataAccess.
TDecisionTree | Represents type TDecisionTree.
Top
Records
Name | Description
TColumnData | Represents type TColumnData.
TGain | Represents type TGain.
TNodeData | Represents type TNodeData.
Top
Types
Name | Description
TDecisionNode | Represents an alias of the TNode<TNodeData> type.
Top
Routines
Name | Description
MatchBooleans(TBooleanArray,TBooleanArray) | Represents method MatchBooleans(TBooleanArray,TBooleanArray).
MatchNotBooleans(TBooleanArray,TBooleanArray) | Represents method MatchNotBooleans(TBooleanArray,TBooleanArray).
Top


BI.Algorithm.DecisionTree Classes

Classes
Name | Description
TDataAccess | Represents type TDataAccess.
TDecisionTree | Represents type TDecisionTree.
Top


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.Algorithm.DecisionTree
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Algorithm.DecisionTree.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.Algorithm.DecisionTree


TDecisionTree Class

Summary

Represents type TDecisionTree.

Namespace: BI.Algorithm.DecisionTree
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TBaseAlgorithm
BI.Algorithm.Model.TModel
BI.Algorithm.Model.TSupervisedModel
BI.Algorithm.DecisionTree.TDecisionTree
Syntax
Delphi
type
 TDecisionTree=class(TSupervisedModel)
 end;

The TDecisionTree type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TDecisionTree class. (Overrides TSupervisedModel.Create(TComponent).)
Destroy | Represents the destructor of the TDecisionTree class. (Overrides TSupervisedModel.Destroy.)
Top
Methods
Show:
Name | Description
Calculate | Represents method Calculate. (Overrides TSupervisedModel.Calculate.)
Top
Fields
Show:
Name | Description
ColumnData | Represents field ColumnData.
MaxData | Represents field MaxData.
Root | Represents field Root.
Top
See Also

Reference

  • BI.Algorithm.DecisionTree


TDecisionTree Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TDecisionTree class. (Overrides TSupervisedModel.Create(TComponent).)
Destroy | Represents the destructor of the TDecisionTree class. (Overrides TSupervisedModel.Destroy.)
Top


TDecisionTree.Create(TComponent) Constructor

Summary

Initializes a new instance of the TDecisionTree class.

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TSupervisedModel.Create(TComponent)
See Also

Reference

  • TDecisionTree
  • BI.Algorithm.DecisionTree


TDecisionTree.Destroy Destructor

Summary

Represents the destructor of the TDecisionTree class.

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TSupervisedModel.Destroy
See Also

Reference

  • TDecisionTree
  • BI.Algorithm.DecisionTree


TDecisionTree Methods

Methods
Name | Description
Calculate | Represents method Calculate. (Overrides TSupervisedModel.Calculate.)
Top


TDecisionTree.Calculate Method

Summary

Represents method Calculate.

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
public
 procedure Calculate; override;

Overrides

TSupervisedModel.Calculate
See Also

Reference

  • TDecisionTree
  • BI.Algorithm.DecisionTree


TDecisionTree Fields

Fields
Name | Description
ColumnData | Represents field ColumnData.
MaxData | Represents field MaxData.
Root | Represents field Root.
Top


TDecisionTree.ColumnData Field

Summary

Represents field ColumnData.

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
public
 ColumnData : Array of TColumnData;

Field Value

Type: Array of TColumnData

See Also

Reference

  • TDecisionTree
  • BI.Algorithm.DecisionTree


TDecisionTree.MaxData Field

Summary

Represents field MaxData.

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
public
 MaxData : TInteger;

Field Value

Type: TInteger

See Also

Reference

  • TDecisionTree
  • BI.Algorithm.DecisionTree


TDecisionTree.Root Field

Summary

Represents field Root.

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
public
 Root : TDecisionNode;

Field Value

Type: TDecisionNode

See Also

Reference

  • TDecisionTree
  • BI.Algorithm.DecisionTree


BI.Algorithm.DecisionTree Records

Records
Name | Description
TColumnData | Represents type TColumnData.
TGain | Represents type TGain.
TNodeData | Represents type TNodeData.
Top


TColumnData Record

Summary

Represents type TColumnData.

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
type
 TColumnData=record
 end;

The TColumnData type exposes the following members.

Fields
Show:
Name | Description
Continous | Represents field Continous.
Flag | Represents field Flag.
Top
See Also

Reference

  • BI.Algorithm.DecisionTree


TColumnData Fields

Fields
Name | Description
Continous | Represents field Continous.
Flag | Represents field Flag.
Top


TColumnData.Continous Field

Summary

Represents field Continous.

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
public
 Continous : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TColumnData
  • BI.Algorithm.DecisionTree


TColumnData.Flag Field

Summary

Represents field Flag.

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
public
 Flag : TBooleanArray;

Field Value

Type: TBooleanArray

See Also

Reference

  • TColumnData
  • BI.Algorithm.DecisionTree


TGain Record

Summary

Represents type TGain.

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
type
 TGain=record
 end;

The TGain type exposes the following members.

Methods
Show:
Name | Description
Calculate(TDataItem) | Represents method Calculate(TDataItem).
Entropy(TInteger) | Represents method Entropy(TInteger).
Top
Fields
Show:
Name | Description
Count | Represents field Count.
FEntropy | Represents field FEntropy.
Indices | Represents field Indices.
Tree | Represents field Tree.
Top
See Also

Reference

  • BI.Algorithm.DecisionTree


TGain Methods

Methods
Name | Description
Calculate(TDataItem) | Represents method Calculate(TDataItem).
Entropy(TInteger) | Represents method Entropy(TInteger).
Top


TGain.Calculate(TDataItem) Method

Summary

Represents method Calculate(TDataItem).

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
public
 function Calculate(const AData:TDataItem):TFloat;

Parameters

AData
Type: TDataItem

Return Value

Type: TFloat

See Also

Reference

  • TGain
  • BI.Algorithm.DecisionTree


TGain.Entropy(TInteger) Method

Summary

Represents method Entropy(TInteger).

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
public
 function Entropy(const Count:TInteger):TFloat;

Parameters

Count
Type: System.Void

Return Value

Type: TFloat

See Also

Reference

  • TGain
  • BI.Algorithm.DecisionTree


TGain Fields

Fields
Name | Description
Count | Represents field Count.
FEntropy | Represents field FEntropy.
Indices | Represents field Indices.
Tree | Represents field Tree.
Top


TGain.Count Field

Summary

Represents field Count.

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
public
 Count : TInteger;

Field Value

Type: TInteger

See Also

Reference

  • TGain
  • BI.Algorithm.DecisionTree


TGain.FEntropy Field

Summary

Represents field FEntropy.

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
public
 FEntropy : TFloat;

Field Value

Type: TFloat

See Also

Reference

  • TGain
  • BI.Algorithm.DecisionTree


TGain.Indices Field

Summary

Represents field Indices.

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
public
 Indices : TBooleanArray;

Field Value

Type: TBooleanArray

See Also

Reference

  • TGain
  • BI.Algorithm.DecisionTree


TGain.Tree Field

Summary

Represents field Tree.

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
public
 Tree : TDecisionTree;

Field Value

Type: TDecisionTree

See Also

Reference

  • TGain
  • BI.Algorithm.DecisionTree


TNodeData Record

Summary

Represents type TNodeData.

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
type
 TNodeData=record
 end;

The TNodeData type exposes the following members.

Methods
Show:
Name | Description
ToString | Represents method ToString.
Top
Fields
Show:
Name | Description
Attribute | Represents field Attribute.
Index | Represents field Index.
Top
See Also

Reference

  • BI.Algorithm.DecisionTree


TNodeData Methods

Methods
Name | Description
ToString | Represents method ToString.
Top


TNodeData.ToString Method

Summary

Represents method ToString.

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
public
 function ToString:String;

Return Value

Type: String

See Also

Reference

  • TNodeData
  • BI.Algorithm.DecisionTree


TNodeData Fields

Fields
Name | Description
Attribute | Represents field Attribute.
Index | Represents field Index.
Top


TNodeData.Attribute Field

Summary

Represents field Attribute.

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
public
 Attribute : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TNodeData
  • BI.Algorithm.DecisionTree


TNodeData.Index Field

Summary

Represents field Index.

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
public
 Index : TInteger;

Field Value

Type: TInteger

See Also

Reference

  • TNodeData
  • BI.Algorithm.DecisionTree


BI.Algorithm.DecisionTree Types

Types
Name | Description
TDecisionNode | Represents an alias of the TNode<TNodeData> type.
Top


TDecisionNode Type

Summary

Represents an alias of the TNode<TNodeData> type.

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
type
 TDecisionNode=TNode<TNodeData>;
See Also

Reference

  • BI.Algorithm.DecisionTree


BI.Algorithm.DecisionTree Routines

Routines
Name | Description
MatchBooleans(TBooleanArray,TBooleanArray) | Represents method MatchBooleans(TBooleanArray,TBooleanArray).
MatchNotBooleans(TBooleanArray,TBooleanArray) | Represents method MatchNotBooleans(TBooleanArray,TBooleanArray).
Top


MatchBooleans(TBooleanArray,TBooleanArray) Method

Summary

Represents method MatchBooleans(TBooleanArray,TBooleanArray).

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
procedure MatchBooleans(var Indices,Flags:TBooleanArray);

Parameters

Indices
Type: TBooleanArray

Flags
Type: TBooleanArray

See Also

Reference

  • BI.Algorithm.DecisionTree


MatchNotBooleans(TBooleanArray,TBooleanArray) Method

Summary

Represents method MatchNotBooleans(TBooleanArray,TBooleanArray).

Namespace: BI.Algorithm.DecisionTree
Syntax
Delphi
procedure MatchNotBooleans(var Indices,Flags:TBooleanArray);

Parameters

Indices
Type: TBooleanArray

Flags
Type: TBooleanArray

See Also

Reference

  • BI.Algorithm.DecisionTree


BI.Algorithm.DimReduction Namespace

Summary

Represents namespace BI.Algorithm.DimReduction.

Classes
Name | Description
TBIPCA | Represents type TBIPCA.
Top


BI.Algorithm.DimReduction Classes

Classes
Name | Description
TBIPCA | Represents type TBIPCA.
Top


TBIPCA Class

Summary

Represents type TBIPCA.

Namespace: BI.Algorithm.DimReduction
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TBaseAlgorithm
BI.Algorithm.Model.TModel
BI.Algorithm.Model.TSupervisedModel
BI.Plugins.R.TRSupervisedModel
BI.Algorithm.DimReduction.TBIPCA
Syntax
Delphi
type
 TBIPCA=class(TRSupervisedModel)
 end;

The TBIPCA type exposes the following members.

Methods
Show:
Name | Description
BuildScript | Represents method BuildScript. (Overrides TRSupervisedModel.BuildScript.)
Top
See Also

Reference

  • BI.Algorithm.DimReduction


TBIPCA Methods

Methods
Name | Description
BuildScript | Represents method BuildScript. (Overrides TRSupervisedModel.BuildScript.)
Top


TBIPCA.BuildScript Method

Summary

Represents method BuildScript.

Namespace: BI.Algorithm.DimReduction
Syntax
Delphi
protected
 procedure BuildScript; override;

Overrides

TRSupervisedModel.BuildScript
See Also

Reference

  • TBIPCA
  • BI.Algorithm.DimReduction


BI.Algorithm.Ensemble Namespace

Summary

Represents namespace BI.Algorithm.Ensemble.

Classes
Name | Description
TBIRandomForest | Represents type TBIRandomForest.
Top


BI.Algorithm.Ensemble Classes

Classes
Name | Description
TBIRandomForest | Represents type TBIRandomForest.
Top


TBIRandomForest Class

Summary

Represents type TBIRandomForest.

Namespace: BI.Algorithm.Ensemble
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TBaseAlgorithm
BI.Algorithm.Model.TModel
BI.Algorithm.Model.TSupervisedModel
BI.Plugins.R.TRSupervisedModel
BI.Algorithm.Ensemble.TBIRandomForest
Syntax
Delphi
type
 TBIRandomForest=class(TRSupervisedModel)
 end;

The TBIRandomForest type exposes the following members.

Methods
Show:
Name | Description
BuildScript | Represents method BuildScript. (Overrides TRSupervisedModel.BuildScript.)
Top
See Also

Reference

  • BI.Algorithm.Ensemble


TBIRandomForest Methods

Methods
Name | Description
BuildScript | Represents method BuildScript. (Overrides TRSupervisedModel.BuildScript.)
Top


TBIRandomForest.BuildScript Method

Summary

Represents method BuildScript.

Namespace: BI.Algorithm.Ensemble
Syntax
Delphi
protected
 procedure BuildScript; override;

Overrides

TRSupervisedModel.BuildScript
See Also

Reference

  • TBIRandomForest
  • BI.Algorithm.Ensemble


BI.Algorithm.Model Namespace

Summary

Represents namespace BI.Algorithm.Model.

Classes
Name | Description
TBIPlugin | Represents type TBIPlugin.
TDataProviderAccess | Represents type TDataProviderAccess.
TModel | Represents type TModel.
TModelsHelper | Represents type TModelsHelper.
TModelSplit | Represents type TModelSplit.
TPredictedData | Represents type TPredictedData.
TSupervisedModel | Represents type TSupervisedModel.
Top
Types
Name | Description
TModelClass | Represents type TModelClass.
TModels | Represents an array of the TModelClass type.
TSupervisedModelClass | Represents type TSupervisedModelClass.
Top


BI.Algorithm.Model Classes

Classes
Name | Description
TBIPlugin | Represents type TBIPlugin.
TDataProviderAccess | Represents type TDataProviderAccess.
TModel | Represents type TModel.
TModelsHelper | Represents type TModelsHelper.
TModelSplit | Represents type TModelSplit.
TPredictedData | Represents type TPredictedData.
TSupervisedModel | Represents type TSupervisedModel.
Top


TBIPlugin Class

Summary

Represents type TBIPlugin.

Namespace: BI.Algorithm.Model
Inheritance Hierarchy
TObject
BI.Algorithm.Model.TBIPlugin
BI.Plugins.Python.TBIPython
BI.Plugins.R.TBIREngine
Syntax
Delphi
type
 TBIPlugin=class
 end;

The TBIPlugin type exposes the following members.

Methods
Show:
Name | Description
ConvertToNumeric(TDataItem,TDataItem) | Represents method ConvertToNumeric(TDataItem,TDataItem).
DataToVector(TNativeIntArray,TDataItem,Boolean,String) | Represents method DataToVector(TNativeIntArray,TDataItem,Boolean,String).
Top
See Also

Reference

  • BI.Algorithm.Model


TBIPlugin Methods

Methods
Name | Description
ConvertToNumeric(TDataItem,TDataItem) | Represents method ConvertToNumeric(TDataItem,TDataItem).
DataToVector(TNativeIntArray,TDataItem,Boolean,String) | Represents method DataToVector(TNativeIntArray,TDataItem,Boolean,String).
Top


TBIPlugin.ConvertToNumeric(TDataItem,TDataItem) Method

Summary

Represents method ConvertToNumeric(TDataItem,TDataItem).

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 class function ConvertToNumeric(const AData:TDataItem; out ANew:TDataItem):Boolean; static;

Parameters

AData
Type: TDataItem

ANew
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • TBIPlugin
  • BI.Algorithm.Model


TBIPlugin.DataToVector(TNativeIntArray,TDataItem,Boolean,String) Method

Summary

Represents method DataToVector(TNativeIntArray,TDataItem,Boolean,String).

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 class function DataToVector(const Indices:TNativeIntArray; const AData:TDataItem;
 const UseMissing:Boolean=True;
 const MissingValue:String=''):String; static;

Parameters

Indices
Type: System.Void

AData
Type: TDataItem

UseMissing
Type: Boolean

MissingValue
Type: String

Return Value

Type: String

See Also

Reference

  • TBIPlugin
  • BI.Algorithm.Model


TDataProviderAccess Class

Summary

Represents type TDataProviderAccess.

Namespace: BI.Algorithm.Model
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.Model.TDataProviderAccess
Syntax
Delphi
type
 TDataProviderAccess=class(TDataProvider);
See Also

Reference

  • BI.Algorithm.Model


TModel Class

Summary

Represents type TModel.

Namespace: BI.Algorithm.Model
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TBaseAlgorithm
BI.Algorithm.Model.TModel
BI.Algorithm.Model.TSupervisedModel
Syntax
Delphi
type
 TModel=class(TBaseAlgorithm)
 end;

The TModel type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TModel class.
Top
Methods
Show:
Name | Description
Description | Represents method Description.
Top
Fields
Show:
Name | Description
Models | Represents field Models.
Top
See Also

Reference

  • BI.Algorithm.Model


TModel Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TModel class.
Top


TModel.Create(TComponent) Constructor

Summary

Initializes a new instance of the TModel class.

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TModel
  • BI.Algorithm.Model


TModel Methods

Methods
Name | Description
Description | Represents method Description.
Top


TModel.Description Method

Summary

Represents method Description.

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 class function Description:String;

Return Value

Type: String

See Also

Reference

  • TModel
  • BI.Algorithm.Model


TModel Fields

Fields
Name | Description
Models | Represents field Models.
Top


TModel.Models Field

Summary

Represents field Models.

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 class var
 Models : TModels;

Field Value

Type: TModels

See Also

Reference

  • TModel
  • BI.Algorithm.Model


TModelsHelper Class Helper

Summary

Represents type TModelsHelper.

Namespace: BI.Algorithm.Model
Syntax
Delphi
type
 TModelsHelper=record helper for TModels
 end;
Methods
Name | Description
Count | Represents method Count.
Exists(TModelClass) | Represents method Exists(TModelClass).
IndexOf(TModelClass) | Represents method IndexOf(TModelClass).
Register(TModelClass) | Overloaded. Represents method Register(TModelClass).
Register(TModelClass[]) | Overloaded. Represents method Register(TModelClass[]).
UnRegister(TModelClass) | Overloaded. Represents method UnRegister(TModelClass).
UnRegister(TModelClass[]) | Overloaded. Represents method UnRegister(TModelClass[]).
Top
See Also

Reference

  • BI.Algorithm.Model


TModelsHelper Methods

Methods
Name | Description
Count | Represents method Count.
Exists(TModelClass) | Represents method Exists(TModelClass).
IndexOf(TModelClass) | Represents method IndexOf(TModelClass).
Register(TModelClass) | Overloaded. Represents method Register(TModelClass).
Register(TModelClass[]) | Overloaded. Represents method Register(TModelClass[]).
UnRegister(TModelClass) | Overloaded. Represents method UnRegister(TModelClass).
UnRegister(TModelClass[]) | Overloaded. Represents method UnRegister(TModelClass[]).
Top


TModelsHelper.Count Method

Summary

Represents method Count.

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 function Count:Integer; inline;

Return Value

Type: Integer

See Also

Reference

  • TModelsHelper
  • BI.Algorithm.Model


TModelsHelper.Exists(TModelClass) Method

Summary

Represents method Exists(TModelClass).

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 function Exists(const AModel:TModelClass):Boolean; inline;

Parameters

AModel
Type: TModelClass

Return Value

Type: Boolean

See Also

Reference

  • TModelsHelper
  • BI.Algorithm.Model


TModelsHelper.IndexOf(TModelClass) Method

Summary

Represents method IndexOf(TModelClass).

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 function IndexOf(const AModel:TModelClass):Integer;

Parameters

AModel
Type: TModelClass

Return Value

Type: Integer

See Also

Reference

  • TModelsHelper
  • BI.Algorithm.Model


TModelsHelper.Register(TModelClass) Method

Summary

Represents method Register(TModelClass).

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 procedure Register(const AModel:TModelClass); overload;

Parameters

AModel
Type: TModelClass

See Also

Reference

  • TModelsHelper
  • BI.Algorithm.Model


TModelsHelper.Register(TModelClass[]) Method

Summary

Represents method Register(TModelClass[]).

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 procedure Register(const AModels:Array of TModelClass); overload;

Parameters

AModels
Type: Array of TModelClass

See Also

Reference

  • TModelsHelper
  • BI.Algorithm.Model


TModelsHelper.UnRegister(TModelClass) Method

Summary

Represents method UnRegister(TModelClass).

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 procedure UnRegister(const AModel:TModelClass); overload;

Parameters

AModel
Type: TModelClass

See Also

Reference

  • TModelsHelper
  • BI.Algorithm.Model


TModelsHelper.UnRegister(TModelClass[]) Method

Summary

Represents method UnRegister(TModelClass[]).

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 procedure UnRegister(const AModels:Array of TModelClass); overload;

Parameters

AModels
Type: Array of TModelClass

See Also

Reference

  • TModelsHelper
  • BI.Algorithm.Model


TModelSplit Class

Summary

Represents type TModelSplit.

Namespace: BI.Algorithm.Model
Inheritance Hierarchy
TPersistent
BI.Algorithm.Model.TModelSplit
Syntax
Delphi
type
 TModelSplit=class(TPersistent)
 end;

The TModelSplit type exposes the following members.

Constructors
Show:
Name | Description
Create(TDataProvider) | Initializes a new instance of the TModelSplit class.
Top
Properties
Show:
Name | Description
By | Represents property By.
Count | Represents property Count.
Mode | Represents property Mode.
Percent | Represents property Percent.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
Fields
Show:
Name | Description
Split | Represents field Split.
Top
See Also

Reference

  • BI.Algorithm.Model


TModelSplit Constructors

Constructors
Name | Description
Create(TDataProvider) | Initializes a new instance of the TModelSplit class.
Top


TModelSplit.Create(TDataProvider) Constructor

Summary

Initializes a new instance of the TModelSplit class.

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 Constructor Create(const AProvider:TDataProvider);

Parameters

AProvider
Type: TDataProvider

See Also

Reference

  • TModelSplit
  • BI.Algorithm.Model


TModelSplit Properties

Properties
Name | Description
By | Represents property By.
Count | Represents property Count.
Mode | Represents property Mode.
Percent | Represents property Percent.
Top


TModelSplit.By Property

Summary

Represents property By.

Namespace: BI.Algorithm.Model
Syntax
Delphi
published
 property By:TSplitBy read GetBy write SetBy default TSplitBy.Percent;

Property Value

Type: TSplitBy

See Also

Reference

  • TModelSplit
  • BI.Algorithm.Model


TModelSplit.Count Property

Summary

Represents property Count.

Namespace: BI.Algorithm.Model
Syntax
Delphi
published
 property Count: Integer read GetCount write SetCount default 0;

Property Value

Type: Integer

See Also

Reference

  • TModelSplit
  • BI.Algorithm.Model


TModelSplit.Mode Property

Summary

Represents property Mode.

Namespace: BI.Algorithm.Model
Syntax
Delphi
published
 property Mode:TSplitMode read GetMode write SetMode default TSplitMode.Random;

Property Value

Type: TSplitMode

See Also

Reference

  • TModelSplit
  • BI.Algorithm.Model


TModelSplit.Percent Property

Summary

Represents property Percent.

Namespace: BI.Algorithm.Model
Syntax
Delphi
published
 property Percent:Single read GetPercent write SetPercent stored IsPercentStored;

Property Value

Type: Single

See Also

Reference

  • TModelSplit
  • BI.Algorithm.Model


TModelSplit Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TModelSplit.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TModelSplit
  • BI.Algorithm.Model


TModelSplit Fields

Fields
Name | Description
Split | Represents field Split.
Top


TModelSplit.Split Field

Summary

Represents field Split.

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 Split : TSplitOptions;

Field Value

Type: TSplitOptions

See Also

Reference

  • TModelSplit
  • BI.Algorithm.Model


TPredictedData Class

Summary

Represents type TPredictedData.

Namespace: BI.Algorithm.Model
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Algorithm.Model.TPredictedData
Syntax
Delphi
type
 TPredictedData=class(TDataItem)
 end;

The TPredictedData type exposes the following members.

Constructors
Show:
Name | Description
Create(TDataItem,TNativeIntArray) | Initializes a new instance of the TPredictedData class.
Destroy | Represents the destructor of the TPredictedData class. (Overrides TDataItem.Destroy.)
Top
Properties
Show:
Name | Description
Confusion | Represents property Confusion.
Correct | Represents property Correct.
Predicted | Represents property Predicted.
Real | Represents property Real.
Top
Methods
Show:
Name | Description
IsEqual(TInteger) | Represents method IsEqual(TInteger).
Top
Fields
Show:
Name | Description
ConfusionClass | Represents field ConfusionClass.
Top
See Also

Reference

  • BI.Algorithm.Model


TPredictedData Constructors

Constructors
Name | Description
Create(TDataItem,TNativeIntArray) | Initializes a new instance of the TPredictedData class.
Destroy | Represents the destructor of the TPredictedData class. (Overrides TDataItem.Destroy.)
Top


TPredictedData.Create(TDataItem,TNativeIntArray) Constructor

Summary

Initializes a new instance of the TPredictedData class.

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 Constructor Create(const ATarget:TDataItem; const Indices:TNativeIntArray);

Parameters

ATarget
Type: TDataItem

Indices
Type: System.Void

See Also

Reference

  • TPredictedData
  • BI.Algorithm.Model


TPredictedData.Destroy Destructor

Summary

Represents the destructor of the TPredictedData class.

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TDataItem.Destroy
See Also

Reference

  • TPredictedData
  • BI.Algorithm.Model


TPredictedData Properties

Properties
Name | Description
Confusion | Represents property Confusion.
Correct | Represents property Correct.
Predicted | Represents property Predicted.
Real | Represents property Real.
Top


TPredictedData.Confusion Property

Summary

Represents property Confusion.

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 property Confusion:TDataItem read GetConfusion;

Property Value

Type: TDataItem

See Also

Reference

  • TPredictedData
  • BI.Algorithm.Model


TPredictedData.Correct Property

Summary

Represents property Correct.

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 property Correct:TInteger read GetCorrect;

Property Value

Type: TInteger

See Also

Reference

  • TPredictedData
  • BI.Algorithm.Model


TPredictedData.Predicted Property

Summary

Represents property Predicted.

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 property Predicted:TDataItem read FPredicted;

Property Value

Type: TDataItem

See Also

Reference

  • TPredictedData
  • BI.Algorithm.Model


TPredictedData.Real Property

Summary

Represents property Real.

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 property Real:TDataItem read FReal;

Property Value

Type: TDataItem

See Also

Reference

  • TPredictedData
  • BI.Algorithm.Model


TPredictedData Methods

Methods
Name | Description
IsEqual(TInteger) | Represents method IsEqual(TInteger).
Top


TPredictedData.IsEqual(TInteger) Method

Summary

Represents method IsEqual(TInteger).

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 function IsEqual(const AIndex: TInteger):Boolean;

Parameters

AIndex
Type: System.Void

Return Value

Type: Boolean

See Also

Reference

  • TPredictedData
  • BI.Algorithm.Model


TPredictedData Fields

Fields
Name | Description
ConfusionClass | Represents field ConfusionClass.
Top


TPredictedData.ConfusionClass Field

Summary

Represents field ConfusionClass.

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 class var
 ConfusionClass : TBaseAlgorithmClass;

Field Value

Type: TBaseAlgorithmClass

See Also

Reference

  • TPredictedData
  • BI.Algorithm.Model


TSupervisedModel Class

Summary

Represents type TSupervisedModel.

Namespace: BI.Algorithm.Model
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TBaseAlgorithm
BI.Algorithm.Model.TModel
BI.Algorithm.Model.TSupervisedModel
BI.Algorithm.Clustering.TBIClustering
BI.Algorithm.DecisionTree.TDecisionTree
BI.Plugins.Python.TScikitSupervisedModel
BI.Plugins.R.TRSupervisedModel
Syntax
Delphi
type
 TSupervisedModel=class(TModel)
 end;

The TSupervisedModel type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TSupervisedModel class. (Overrides TModel.Create(TComponent).)
Destroy | Represents the destructor of the TSupervisedModel class. (Overrides TDataProvider.Destroy.)
Top
Properties
Show:
Name | Description
Attributes | Represents property Attributes.
Normalize | Represents property Normalize.
Predicted | Represents property Predicted.
Split | Represents property Split.
Target | Represents property Target.
Top
Methods
Show:
Name | Description
AddOutput(TDataItem) | Represents method AddOutput(TDataItem). (Overrides TBaseAlgorithm.AddOutput(TDataItem).)
Calculate | Represents method Calculate. (Overrides TBaseAlgorithm.Calculate.)
Top
Fields
Show:
Name | Description
FPredicted | Represents field FPredicted.
Indices | Represents field Indices.
Top
See Also

Reference

  • BI.Algorithm.Model


TSupervisedModel Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TSupervisedModel class. (Overrides TModel.Create(TComponent).)
Destroy | Represents the destructor of the TSupervisedModel class. (Overrides TDataProvider.Destroy.)
Top


TSupervisedModel.Create(TComponent) Constructor

Summary

Initializes a new instance of the TSupervisedModel class.

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TModel.Create(TComponent)
See Also

Reference

  • TSupervisedModel
  • BI.Algorithm.Model


TSupervisedModel.Destroy Destructor

Summary

Represents the destructor of the TSupervisedModel class.

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TDataProvider.Destroy
See Also

Reference

  • TSupervisedModel
  • BI.Algorithm.Model


TSupervisedModel Properties

Properties
Name | Description
Attributes | Represents property Attributes.
Normalize | Represents property Normalize.
Predicted | Represents property Predicted.
Split | Represents property Split.
Target | Represents property Target.
Top


TSupervisedModel.Attributes Property

Summary

Represents property Attributes.

Namespace: BI.Algorithm.Model
Syntax
Delphi
published
 property Attributes:TDataArray read GetAttributes write SetAttributes;

Property Value

Type: TDataArray

See Also

Reference

  • TSupervisedModel
  • BI.Algorithm.Model


TSupervisedModel.Normalize Property

Summary

Represents property Normalize.

Namespace: BI.Algorithm.Model
Syntax
Delphi
published
 property Normalize:Boolean read FNormalize write SetNormalize default False;

Property Value

Type: Boolean

See Also

Reference

  • TSupervisedModel
  • BI.Algorithm.Model


TSupervisedModel.Predicted Property

Summary

Represents property Predicted.

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 property Predicted:TPredictedData read GetPredicted;

Property Value

Type: TPredictedData

See Also

Reference

  • TSupervisedModel
  • BI.Algorithm.Model


TSupervisedModel.Split Property

Summary

Represents property Split.

Namespace: BI.Algorithm.Model
Syntax
Delphi
published
 property Split:TModelSplit read FSplit write SetSplit;

Property Value

Type: TModelSplit

See Also

Reference

  • TSupervisedModel
  • BI.Algorithm.Model


TSupervisedModel.Target Property

Summary

Represents property Target.

Namespace: BI.Algorithm.Model
Syntax
Delphi
published
 property Target:TDataItem read GetTarget write SetTarget;

Property Value

Type: TDataItem

See Also

Reference

  • TSupervisedModel
  • BI.Algorithm.Model


TSupervisedModel Methods

Methods
Name | Description
AddOutput(TDataItem) | Represents method AddOutput(TDataItem). (Overrides TBaseAlgorithm.AddOutput(TDataItem).)
Calculate | Represents method Calculate. (Overrides TBaseAlgorithm.Calculate.)
Top


TSupervisedModel.AddOutput(TDataItem) Method

Summary

Represents method AddOutput(TDataItem).

Namespace: BI.Algorithm.Model
Syntax
Delphi
protected
 procedure AddOutput(const AData:TDataItem); override;

Parameters

AData
Type: TDataItem

Overrides

TBaseAlgorithm.AddOutput(TDataItem)
See Also

Reference

  • TSupervisedModel
  • BI.Algorithm.Model


TSupervisedModel.Calculate Method

Summary

Represents method Calculate.

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 procedure Calculate; override;

Overrides

TBaseAlgorithm.Calculate
See Also

Reference

  • TSupervisedModel
  • BI.Algorithm.Model


TSupervisedModel Fields

Fields
Name | Description
FPredicted | Represents field FPredicted.
Indices | Represents field Indices.
Top


TSupervisedModel.FPredicted Field

Summary

Represents field FPredicted.

Namespace: BI.Algorithm.Model
Syntax
Delphi
protected
 FPredicted : TPredictedData;

Field Value

Type: TPredictedData

See Also

Reference

  • TSupervisedModel
  • BI.Algorithm.Model


TSupervisedModel.Indices Field

Summary

Represents field Indices.

Namespace: BI.Algorithm.Model
Syntax
Delphi
public
 Indices : TDataSplit;

Field Value

Type: TDataSplit

See Also

Reference

  • TSupervisedModel
  • BI.Algorithm.Model


BI.Algorithm.Model Types

Types
Name | Description
TModelClass | Represents type TModelClass.
TModels | Represents an array of the TModelClass type.
TSupervisedModelClass | Represents type TSupervisedModelClass.
Top


TModelClass Type

Summary

Represents type TModelClass.

Namespace: BI.Algorithm.Model
Syntax
Delphi
type
 TModelClass=class of TModel;
See Also

Reference

  • BI.Algorithm.Model


TModels Type

Summary

Represents an array of the TModelClass type.

Namespace: BI.Algorithm.Model
Syntax
Delphi
type
 TModels=Array of TModelClass;
See Also

Reference

  • BI.Algorithm.Model


TSupervisedModelClass Type

Summary

Represents type TSupervisedModelClass.

Namespace: BI.Algorithm.Model
Syntax
Delphi
type
 TSupervisedModelClass=class of TSupervisedModel;
See Also

Reference

  • BI.Algorithm.Model


BI.Algorithm.Register Namespace

Summary

Represents namespace BI.Algorithm.Register.

Records
Name | Description
TAllModels | Represents type TAllModels.
Top
Constants
Name | Description
ModelClasses | Represents constant ModelClasses.
ModelCount | Represents constant ModelCount.
Top


BI.Algorithm.Register Records

Records
Name | Description
TAllModels | Represents type TAllModels.
Top


TAllModels Record

Summary

Represents type TAllModels.

Namespace: BI.Algorithm.Register
Syntax
Delphi
type
 TAllModels=record
 end;

The TAllModels type exposes the following members.

Methods
Show:
Name | Description
AllModels(TStrings) | Represents method AllModels(TStrings).
Top
See Also

Reference

  • BI.Algorithm.Register


TAllModels Methods

Methods
Name | Description
AllModels(TStrings) | Represents method AllModels(TStrings).
Top


TAllModels.AllModels(TStrings) Method

Summary

Represents method AllModels(TStrings).

Namespace: BI.Algorithm.Register
Syntax
Delphi
public
 class procedure AllModels(const ADest: TStrings); static;

Parameters

ADest
Type: TStrings

See Also

Reference

  • TAllModels
  • BI.Algorithm.Register


BI.Algorithm.Register Constants

Constants
Name | Description
ModelClasses | Represents constant ModelClasses.
ModelCount | Represents constant ModelCount.
Top


ModelClasses Constant

Summary

Represents constant ModelClasses.

Namespace: BI.Algorithm.Register
Syntax
Delphi
 ModelClasses : Array[0..ModelCount-1] of TModelClass=(
 TBINaiveBayes,
 TBICART,
 TBINearestNeighbour,
 TBIClustering,
 TDecisionTree,
 TBIPCA,
 TBIRandomForest,
 TBIScikitClustering,
 TBISupportVector);

Value

Type: Array[0..ModelCount-1] of TModelClass

See Also

Reference

  • BI.Algorithm.Register


ModelCount Constant

Summary

Represents constant ModelCount.

Namespace: BI.Algorithm.Register
Syntax
Delphi
 ModelCount=9;

Value

Type: ShortInt

See Also

Reference

  • BI.Algorithm.Register


BI.Algorithm.Regression Namespace

Summary

Represents namespace BI.Algorithm.Regression.

Classes
Name | Description
TBISupportVector | Represents type TBISupportVector.
TLinearRegression | Represents type TLinearRegression.
TRegression | Represents type TRegression.
TRegressionMatrix | Represents type TRegressionMatrix.
Top


BI.Algorithm.Regression Classes

Classes
Name | Description
TBISupportVector | Represents type TBISupportVector.
TLinearRegression | Represents type TLinearRegression.
TRegression | Represents type TRegression.
TRegressionMatrix | Represents type TRegressionMatrix.
Top


TBISupportVector Class

Summary

Represents type TBISupportVector.

Namespace: BI.Algorithm.Regression
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TBaseAlgorithm
BI.Algorithm.Model.TModel
BI.Algorithm.Model.TSupervisedModel
BI.Plugins.R.TRSupervisedModel
BI.Algorithm.Regression.TBISupportVector
Syntax
Delphi
type
 TBISupportVector=class(TRSupervisedModel)
 end;

The TBISupportVector type exposes the following members.

Methods
Show:
Name | Description
BuildScript | Represents method BuildScript. (Overrides TRSupervisedModel.BuildScript.)
Calculate | Represents method Calculate. (Overrides TRSupervisedModel.Calculate.)
Top
See Also

Reference

  • BI.Algorithm.Regression


TBISupportVector Methods

Methods
Name | Description
BuildScript | Represents method BuildScript. (Overrides TRSupervisedModel.BuildScript.)
Calculate | Represents method Calculate. (Overrides TRSupervisedModel.Calculate.)
Top


TBISupportVector.BuildScript Method

Summary

Represents method BuildScript.

Namespace: BI.Algorithm.Regression
Syntax
Delphi
protected
 procedure BuildScript; override;

Overrides

TRSupervisedModel.BuildScript
See Also

Reference

  • TBISupportVector
  • BI.Algorithm.Regression


TBISupportVector.Calculate Method

Summary

Represents method Calculate.

Namespace: BI.Algorithm.Regression
Syntax
Delphi
public
 procedure Calculate; override;

Overrides

TRSupervisedModel.Calculate
See Also

Reference

  • TBISupportVector
  • BI.Algorithm.Regression


TLinearRegression Class

Summary

Represents type TLinearRegression.

Namespace: BI.Algorithm.Regression
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TBaseAlgorithm
BI.Algorithm.Regression.TRegression
BI.Algorithm.Regression.TLinearRegression
Syntax
Delphi
type
 TLinearRegression=class(TRegression)
 end;

The TLinearRegression type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TLinearRegression class.
Top
Properties
Show:
Name | Description
X | Represents property X.
Y | Represents property Y.
Top
Methods
Show:
Name | Description
Calculate | Represents method Calculate. (Overrides TBaseAlgorithm.Calculate.)
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TBaseAlgorithm.Load(TDataItem,Boolean).)
MeanSquaredError(TDataItem,TDataItem) | Represents method MeanSquaredError(TDataItem,TDataItem).
Top
Fields
Show:
Name | Description
B | Represents field B.
Coefficient | Represents field Coefficient.
Count | Represents field Count.
M | Represents field M.
SumX | Represents field SumX.
SumX2 | Represents field SumX2.
SumXY | Represents field SumXY.
SumY | Represents field SumY.
SumY2 | Represents field SumY2.
Top
See Also

Reference

  • BI.Algorithm.Regression


TLinearRegression Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TLinearRegression class.
Top


TLinearRegression.Create(TComponent) Constructor

Summary

Initializes a new instance of the TLinearRegression class.

Namespace: BI.Algorithm.Regression
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TLinearRegression
  • BI.Algorithm.Regression


TLinearRegression Properties

Properties
Name | Description
X | Represents property X.
Y | Represents property Y.
Top


TLinearRegression.X Property

Summary

Represents property X.

Namespace: BI.Algorithm.Regression
Syntax
Delphi
public
 property X:TDataItem read GetX write SetX;

Property Value

Type: TDataItem

See Also

Reference

  • TLinearRegression
  • BI.Algorithm.Regression


TLinearRegression.Y Property

Summary

Represents property Y.

Namespace: BI.Algorithm.Regression
Syntax
Delphi
public
 property Y:TDataItem read GetY write SetY;

Property Value

Type: TDataItem

See Also

Reference

  • TLinearRegression
  • BI.Algorithm.Regression


TLinearRegression Methods

Methods
Name | Description
Calculate | Represents method Calculate. (Overrides TBaseAlgorithm.Calculate.)
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TBaseAlgorithm.Load(TDataItem,Boolean).)
MeanSquaredError(TDataItem,TDataItem) | Represents method MeanSquaredError(TDataItem,TDataItem).
Top


TLinearRegression.Calculate Method

Summary

Represents method Calculate.

Namespace: BI.Algorithm.Regression
Syntax
Delphi
public
 procedure Calculate; override;

Overrides

TBaseAlgorithm.Calculate
See Also

Reference

  • TLinearRegression
  • BI.Algorithm.Regression


TLinearRegression.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Algorithm.Regression
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TBaseAlgorithm.Load(TDataItem,Boolean)
See Also

Reference

  • TLinearRegression
  • BI.Algorithm.Regression


TLinearRegression.MeanSquaredError(TDataItem,TDataItem) Method

Summary

Represents method MeanSquaredError(TDataItem,TDataItem).

Namespace: BI.Algorithm.Regression
Syntax
Delphi
public
 function MeanSquaredError(const X,Y:TDataItem):TFloat;

Parameters

X
Type: TDataItem

Y
Type: TDataItem

Return Value

Type: TFloat

See Also

Reference

  • TLinearRegression
  • BI.Algorithm.Regression


TLinearRegression Fields

Fields
Name | Description
B | Represents field B.
Coefficient | Represents field Coefficient.
Count | Represents field Count.
M | Represents field M.
SumX | Represents field SumX.
SumX2 | Represents field SumX2.
SumXY | Represents field SumXY.
SumY | Represents field SumY.
SumY2 | Represents field SumY2.
Top


TLinearRegression.B Field

Summary

Represents field B.

Namespace: BI.Algorithm.Regression
Syntax
Delphi
public
 Coefficient,
 M,B : TFloat;

Field Value

Type: TFloat

See Also

Reference

  • TLinearRegression
  • BI.Algorithm.Regression


TLinearRegression.Coefficient Field

Summary

Represents field Coefficient.

Namespace: BI.Algorithm.Regression
Syntax
Delphi
public
 Coefficient,
 M,B : TFloat;

Field Value

Type: TFloat

See Also

Reference

  • TLinearRegression
  • BI.Algorithm.Regression


TLinearRegression.Count Field

Summary

Represents field Count.

Namespace: BI.Algorithm.Regression
Syntax
Delphi
public
 Count : TInteger;

Field Value

Type: TInteger

See Also

Reference

  • TLinearRegression
  • BI.Algorithm.Regression


TLinearRegression.M Field

Summary

Represents field M.

Namespace: BI.Algorithm.Regression
Syntax
Delphi
public
 Coefficient,
 M,B : TFloat;

Field Value

Type: TFloat

See Also

Reference

  • TLinearRegression
  • BI.Algorithm.Regression


TLinearRegression.SumX Field

Summary

Represents field SumX.

Namespace: BI.Algorithm.Regression
Syntax
Delphi
public
 SumX,
 SumX2,
 SumY,
 SumY2,
 SumXY : TFloat;

Field Value

Type: TFloat

See Also

Reference

  • TLinearRegression
  • BI.Algorithm.Regression


TLinearRegression.SumX2 Field

Summary

Represents field SumX2.

Namespace: BI.Algorithm.Regression
Syntax
Delphi
public
 SumX,
 SumX2,
 SumY,
 SumY2,
 SumXY : TFloat;

Field Value

Type: TFloat

See Also

Reference

  • TLinearRegression
  • BI.Algorithm.Regression


TLinearRegression.SumXY Field

Summary

Represents field SumXY.

Namespace: BI.Algorithm.Regression
Syntax
Delphi
public
 SumX,
 SumX2,
 SumY,
 SumY2,
 SumXY : TFloat;

Field Value

Type: TFloat

See Also

Reference

  • TLinearRegression
  • BI.Algorithm.Regression


TLinearRegression.SumY Field

Summary

Represents field SumY.

Namespace: BI.Algorithm.Regression
Syntax
Delphi
public
 SumX,
 SumX2,
 SumY,
 SumY2,
 SumXY : TFloat;

Field Value

Type: TFloat

See Also

Reference

  • TLinearRegression
  • BI.Algorithm.Regression


TLinearRegression.SumY2 Field

Summary

Represents field SumY2.

Namespace: BI.Algorithm.Regression
Syntax
Delphi
public
 SumX,
 SumX2,
 SumY,
 SumY2,
 SumXY : TFloat;

Field Value

Type: TFloat

See Also

Reference

  • TLinearRegression
  • BI.Algorithm.Regression


TRegression Class

Summary

Represents type TRegression.

Namespace: BI.Algorithm.Regression
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TBaseAlgorithm
BI.Algorithm.Regression.TRegression
BI.Algorithm.Regression.TLinearRegression
Syntax
Delphi
type
 TRegression=class(TBaseAlgorithm)
 end;
See Also

Reference

  • BI.Algorithm.Regression


TRegressionMatrix Class

Summary

Represents type TRegressionMatrix.

Namespace: BI.Algorithm.Regression
Inheritance Hierarchy
TObject
BI.Algorithm.Regression.TRegressionMatrix
Syntax
Delphi
type
 TRegressionMatrix=class
 end;

The TRegressionMatrix type exposes the following members.

Methods
Show:
Name | Description
Calculate(TDataItem) | Represents method Calculate(TDataItem).
Top
See Also

Reference

  • BI.Algorithm.Regression


TRegressionMatrix Methods

Methods
Name | Description
Calculate(TDataItem) | Represents method Calculate(TDataItem).
Top


TRegressionMatrix.Calculate(TDataItem) Method

Summary

Represents method Calculate(TDataItem).

Namespace: BI.Algorithm.Regression
Syntax
Delphi
public
 class function Calculate(const Data:TDataItem):TSquareGrid;

Parameters

Data
Type: TDataItem

Return Value

Type: TSquareGrid

See Also

Reference

  • TRegressionMatrix
  • BI.Algorithm.Regression


BI.Arrays Namespace

Summary

Represents namespace BI.Arrays.

Classes
Name | Description
EBIException | Represents type EBIException.
TBooleanMap | Represents type TBooleanMap.
TDataMap | Represents type TDataMap.
TDataOrderHelper | Represents type TDataOrderHelper.
TDataStats | Represents type TDataStats.
TDataStats<T> | Represents type TDataStats<T>.
TDateTimeMap | Represents type TDateTimeMap.
TDoubleMap | Represents type TDoubleMap.
TExtendedMap | Represents type TExtendedMap.
TInt32Map | Represents type TInt32Map.
TInt64Map | Represents type TInt64Map.
TSingleMap | Represents type TSingleMap.
TSquareGrid | Represents type TSquareGrid.
TTextMap | Represents type TTextMap.
Top
Enumerations
Name | Description
TDataOrder | Represents type TDataOrder.
Top
Types
Name | Description
TBooleanArray | Represents an array of the Boolean type.
TDataMapClass | Represents type TDataMapClass.
TDataStatsClass | Represents type TDataStatsClass.
TDateTimeArray | Represents an array of the TDateTime type.
TDoubleArray | Represents an array of the Double type.
TExtendedArray | Represents an array of the Extended type.
TFloat | Represents an alias of the Double type.
TFloatGrid | Represents an array of the TDoubleArray type.
TInt32Array | Represents an array of the Integer type.
TInt64Array | Represents an array of the Int64 type.
TInteger | Represents an alias of the NativeInt type.
TLoopInteger | Represents an alias of the TInteger type.
TNativeIntArray | Represents an alias of the TInt32Array type.
TNativeInteger | Represents an alias of the Integer type.
TSingleArray | Represents an array of the Single type.
TTextArray | Represents an array of the type.
Top


BI.Arrays Classes

Classes
Name | Description
EBIException | Represents type EBIException.
TBooleanMap | Represents type TBooleanMap.
TDataMap | Represents type TDataMap.
TDataOrderHelper | Represents type TDataOrderHelper.
TDataStats | Represents type TDataStats.
TDataStats<T> | Represents type TDataStats<T>.
TDateTimeMap | Represents type TDateTimeMap.
TDoubleMap | Represents type TDoubleMap.
TExtendedMap | Represents type TExtendedMap.
TInt32Map | Represents type TInt32Map.
TInt64Map | Represents type TInt64Map.
TSingleMap | Represents type TSingleMap.
TSquareGrid | Represents type TSquareGrid.
TTextMap | Represents type TTextMap.
Top


EBIException Class

Summary

Represents type EBIException.

Namespace: BI.Arrays
Inheritance Hierarchy
Exception
BI.Arrays.EBIException
BI.CSV.EBICSV
BI.Excel.EExcelException
BI.JSON.EBIJSON
BI.SQL.ESQLParser
BI.XMLData.EBIXML
Syntax
Delphi
type
 EBIException=class(Exception);
See Also

Reference

  • BI.Arrays


TBooleanMap Class

Summary

Represents type TBooleanMap.

Namespace: BI.Arrays
Inheritance Hierarchy
TObject
BI.Arrays.TDataMap
BI.Arrays.TBooleanMap
Syntax
Delphi
type
 TBooleanMap=class(TDataMap)
 end;

The TBooleanMap type exposes the following members.

Methods
Show:
Name | Description
AsString(TInteger) | Represents method AsString(TInteger). (Overrides TDataMap.AsString(TInteger).)
Top
See Also

Reference

  • BI.Arrays


TBooleanMap Methods

Methods
Name | Description
AsString(TInteger) | Represents method AsString(TInteger). (Overrides TDataMap.AsString(TInteger).)
Top


TBooleanMap.AsString(TInteger) Method

Summary

Represents method AsString(TInteger).

Namespace: BI.Arrays
Syntax
Delphi
public
 function AsString(const Index:TInteger):String; override;

Parameters

Index
Type: System.Void

Return Value

Type: String

Overrides

TDataMap.AsString(TInteger)
See Also

Reference

  • TBooleanMap
  • BI.Arrays


TDataMap Class

Summary

Represents type TDataMap.

Namespace: BI.Arrays
Inheritance Hierarchy
TObject
BI.Arrays.TDataMap
BI.Arrays.TBooleanMap
BI.Arrays.TDateTimeMap
BI.Arrays.TDoubleMap
BI.Arrays.TExtendedMap
BI.Arrays.TInt32Map
BI.Arrays.TInt64Map
BI.Arrays.TSingleMap
BI.Arrays.TTextMap
BI.Persist.TDataMapAccess
Syntax
Delphi
type
 TDataMap=class
 end;

The TDataMap type exposes the following members.

Properties
Show:
Name | Description
Sorted | Represents property Sorted.
Top
Methods
Show:
Name | Description
AsString(TInteger) | Represents method AsString(TInteger).
Clear | Represents method Clear.
Count | Represents method Count.
Top
Fields
Show:
Name | Description
CachedCount | Represents field CachedCount.
FSorted | Represents field FSorted.
Map | Represents field Map.
Top
See Also

Reference

  • BI.Arrays


TDataMap Properties

Properties
Name | Description
Sorted | Represents property Sorted.
Top


TDataMap.Sorted Property

Summary

Represents property Sorted.

Namespace: BI.Arrays
Syntax
Delphi
public
 property Sorted:TDataOrder read FSorted;

Property Value

Type: TDataOrder

See Also

Reference

  • TDataMap
  • BI.Arrays


TDataMap Methods

Methods
Name | Description
AsString(TInteger) | Represents method AsString(TInteger).
Clear | Represents method Clear.
Count | Represents method Count.
Top


TDataMap.AsString(TInteger) Method

Summary

Represents method AsString(TInteger).

Namespace: BI.Arrays
Syntax
Delphi
public
 function AsString(const Index:TInteger):String; virtual; abstract;

Parameters

Index
Type: System.Void

Return Value

Type: String

See Also

Reference

  • TDataMap
  • BI.Arrays


TDataMap.Clear Method

Summary

Represents method Clear.

Namespace: BI.Arrays
Syntax
Delphi
public
 procedure Clear; virtual;
See Also

Reference

  • TDataMap
  • BI.Arrays


TDataMap.Count Method

Summary

Represents method Count.

Namespace: BI.Arrays
Syntax
Delphi
public
 function Count:TInteger; inline;

Return Value

Type: TInteger

See Also

Reference

  • TDataMap
  • BI.Arrays


TDataMap Fields

Fields
Name | Description
CachedCount | Represents field CachedCount.
FSorted | Represents field FSorted.
Map | Represents field Map.
Top


TDataMap.CachedCount Field

Summary

Represents field CachedCount.

Namespace: BI.Arrays
Syntax
Delphi
protected
 CachedCount : TInteger;

Field Value

Type: TInteger

See Also

Reference

  • TDataMap
  • BI.Arrays


TDataMap.FSorted Field

Summary

Represents field FSorted.

Namespace: BI.Arrays
Syntax
Delphi
protected
 FSorted : TDataOrder;

Field Value

Type: TDataOrder

See Also

Reference

  • TDataMap
  • BI.Arrays


TDataMap.Map Field

Summary

Represents field Map.

Namespace: BI.Arrays
Syntax
Delphi
public
 Map : TInt64Array;

Field Value

Type: TInt64Array

See Also

Reference

  • TDataMap
  • BI.Arrays


TDataOrderHelper Class Helper

Summary

Represents type TDataOrderHelper.

Namespace: BI.Arrays
Syntax
Delphi
type
 TDataOrderHelper=record helper for TDataOrder
 end;
Methods
Name | Description
ToString | Represents method ToString.
Top
See Also

Reference

  • BI.Arrays


TDataOrderHelper Methods

Methods
Name | Description
ToString | Represents method ToString.
Top


TDataOrderHelper.ToString Method

Summary

Represents method ToString.

Namespace: BI.Arrays
Syntax
Delphi
public
 function ToString:String;

Return Value

Type: String

See Also

Reference

  • TDataOrderHelper
  • BI.Arrays


TDataStats Class

Summary

Represents type TDataStats.

Namespace: BI.Arrays
Inheritance Hierarchy
TObject
BI.Arrays.TDataStats
Syntax
Delphi
type
 TDataStats=class
 end;

The TDataStats type exposes the following members.

Fields
Show:
Name | Description
Mean | Represents field Mean.
Peakedness | Represents field Peakedness.
Range | Represents field Range.
Skewness | Represents field Skewness.
StdDeviation | Represents field StdDeviation.
Sum | Represents field Sum.
Variance | Represents field Variance.
Top
See Also

Reference

  • BI.Arrays


TDataStats Fields

Fields
Name | Description
Mean | Represents field Mean.
Peakedness | Represents field Peakedness.
Range | Represents field Range.
Skewness | Represents field Skewness.
StdDeviation | Represents field StdDeviation.
Sum | Represents field Sum.
Variance | Represents field Variance.
Top


TDataStats.Mean Field

Summary

Represents field Mean.

Namespace: BI.Arrays
Syntax
Delphi
public
 Mean : TFloat;

Field Value

Type: TFloat

See Also

Reference

  • TDataStats
  • BI.Arrays


TDataStats.Peakedness Field

Summary

Represents field Peakedness.

Namespace: BI.Arrays
Syntax
Delphi
public
 Peakedness : TFloat;

Field Value

Type: TFloat

See Also

Reference

  • TDataStats
  • BI.Arrays


TDataStats.Range Field

Summary

Represents field Range.

Namespace: BI.Arrays
Syntax
Delphi
public
 Range : TFloat;

Field Value

Type: TFloat

See Also

Reference

  • TDataStats
  • BI.Arrays


TDataStats.Skewness Field

Summary

Represents field Skewness.

Namespace: BI.Arrays
Syntax
Delphi
public
 Skewness : TFloat;

Field Value

Type: TFloat

See Also

Reference

  • TDataStats
  • BI.Arrays


TDataStats.StdDeviation Field

Summary

Represents field StdDeviation.

Namespace: BI.Arrays
Syntax
Delphi
public
 StdDeviation : TFloat;

Field Value

Type: TFloat

See Also

Reference

  • TDataStats
  • BI.Arrays


TDataStats.Sum Field

Summary

Represents field Sum.

Namespace: BI.Arrays
Syntax
Delphi
public
 Sum : TFloat;

Field Value

Type: TFloat

See Also

Reference

  • TDataStats
  • BI.Arrays


TDataStats.Variance Field

Summary

Represents field Variance.

Namespace: BI.Arrays
Syntax
Delphi
public
 Variance : TFloat;

Field Value

Type: TFloat

See Also

Reference

  • TDataStats
  • BI.Arrays


TDataStats<T> Class

Summary

Represents type TDataStats<T>.

Namespace: BI.Arrays
Inheritance Hierarchy
TObject
BI.Arrays.TDataStats<T>
Syntax
Delphi
type
 TDataStats<T

Type Parameters

T
See Also

Reference

  • BI.Arrays


TDateTimeMap Class

Summary

Represents type TDateTimeMap.

Namespace: BI.Arrays
Inheritance Hierarchy
TObject
BI.Arrays.TDataMap
BI.Arrays.TDateTimeMap
Syntax
Delphi
type
 TDateTimeMap=class(TDataMap)
 end;

The TDateTimeMap type exposes the following members.

Properties
Show:
Name | Description
Item[TInteger] | Represents property Item[TInteger].
Top
Methods
Show:
Name | Description
AddMap(TDateTime) | Represents method AddMap(TDateTime).
AsString(TInteger) | Represents method AsString(TInteger). (Overrides TDataMap.AsString(TInteger).)
Clear | Represents method Clear. (Overrides TDataMap.Clear.)
Find(TDateTime,Boolean) | Overloaded. Represents method Find(TDateTime,Boolean).
Find(TDateTime,TNativeInteger) | Overloaded. Represents method Find(TDateTime,TNativeInteger).
Top
Fields
Show:
Name | Description
Items | Represents field Items.
Top
See Also

Reference

  • BI.Arrays


TDateTimeMap Properties

Properties
Name | Description
Item[TInteger] | Represents property Item[TInteger].
Top


TDateTimeMap.Item[TInteger] Property

Summary

Represents property Item[TInteger].

Namespace: BI.Arrays
Syntax
Delphi
public
 property Item[const Index:TInteger]:TDateTime read GetItem; default;

Parameters

Index
Type: System.Void

Property Value

Type: TDateTime

See Also

Reference

  • TDateTimeMap
  • BI.Arrays


TDateTimeMap Methods

Methods
Name | Description
AddMap(TDateTime) | Represents method AddMap(TDateTime).
AsString(TInteger) | Represents method AsString(TInteger). (Overrides TDataMap.AsString(TInteger).)
Clear | Represents method Clear. (Overrides TDataMap.Clear.)
Find(TDateTime,Boolean) | Overloaded. Represents method Find(TDateTime,Boolean).
Find(TDateTime,TNativeInteger) | Overloaded. Represents method Find(TDateTime,TNativeInteger).
Top


TDateTimeMap.AddMap(TDateTime) Method

Summary

Represents method AddMap(TDateTime).

Namespace: BI.Arrays
Syntax
Delphi
public
 procedure AddMap(const Value:TDateTime);

Parameters

Value
Type: TDateTime

See Also

Reference

  • TDateTimeMap
  • BI.Arrays


TDateTimeMap.AsString(TInteger) Method

Summary

Represents method AsString(TInteger).

Namespace: BI.Arrays
Syntax
Delphi
public
 function AsString(const Index:TInteger):String; override;

Parameters

Index
Type: System.Void

Return Value

Type: String

Overrides

TDataMap.AsString(TInteger)
See Also

Reference

  • TDateTimeMap
  • BI.Arrays


TDateTimeMap.Clear Method

Summary

Represents method Clear.

Namespace: BI.Arrays
Syntax
Delphi
public
 procedure Clear; override;

Overrides

TDataMap.Clear
See Also

Reference

  • TDateTimeMap
  • BI.Arrays


TDateTimeMap.Find(TDateTime,Boolean) Method

Summary

Represents method Find(TDateTime,Boolean).

Namespace: BI.Arrays
Syntax
Delphi
public
 function Find(const Value:TDateTime; out Exists:Boolean):TNativeInteger; overload; inline;

Parameters

Value
Type: TDateTime

Exists
Type: Boolean

Return Value

Type: TNativeInteger

See Also

Reference

  • TDateTimeMap
  • BI.Arrays


TDateTimeMap.Find(TDateTime,TNativeInteger) Method

Summary

Represents method Find(TDateTime,TNativeInteger).

Namespace: BI.Arrays
Syntax
Delphi
public
 function Find(const Value:TDateTime; out Index: TNativeInteger):Boolean; overload; inline;

Parameters

Value
Type: TDateTime

Index
Type: System.Void

Return Value

Type: Boolean

See Also

Reference

  • TDateTimeMap
  • BI.Arrays


TDateTimeMap Fields

Fields
Name | Description
Items | Represents field Items.
Top


TDateTimeMap.Items Field

Summary

Represents field Items.

Namespace: BI.Arrays
Syntax
Delphi
public
 Items : TDateTimeArray;

Field Value

Type: TDateTimeArray

See Also

Reference

  • TDateTimeMap
  • BI.Arrays


TDoubleMap Class

Summary

Represents type TDoubleMap.

Namespace: BI.Arrays
Inheritance Hierarchy
TObject
BI.Arrays.TDataMap
BI.Arrays.TDoubleMap
Syntax
Delphi
type
 TDoubleMap=class(TDataMap)
 end;

The TDoubleMap type exposes the following members.

Properties
Show:
Name | Description
Item[TInteger] | Represents property Item[TInteger].
Top
Methods
Show:
Name | Description
AddMap(Double) | Represents method AddMap(Double).
AsString(TInteger) | Represents method AsString(TInteger). (Overrides TDataMap.AsString(TInteger).)
Clear | Represents method Clear. (Overrides TDataMap.Clear.)
Find(Double,Boolean) | Overloaded. Represents method Find(Double,Boolean).
Find(Double,TNativeInteger) | Overloaded. Represents method Find(Double,TNativeInteger).
Top
Fields
Show:
Name | Description
Items | Represents field Items.
Top
See Also

Reference

  • BI.Arrays


TDoubleMap Properties

Properties
Name | Description
Item[TInteger] | Represents property Item[TInteger].
Top


TDoubleMap.Item[TInteger] Property

Summary

Represents property Item[TInteger].

Namespace: BI.Arrays
Syntax
Delphi
public
 property Item[const Index:TInteger]:Double read GetItem; default;

Parameters

Index
Type: System.Void

Property Value

Type: Double

See Also

Reference

  • TDoubleMap
  • BI.Arrays


TDoubleMap Methods

Methods
Name | Description
AddMap(Double) | Represents method AddMap(Double).
AsString(TInteger) | Represents method AsString(TInteger). (Overrides TDataMap.AsString(TInteger).)
Clear | Represents method Clear. (Overrides TDataMap.Clear.)
Find(Double,Boolean) | Overloaded. Represents method Find(Double,Boolean).
Find(Double,TNativeInteger) | Overloaded. Represents method Find(Double,TNativeInteger).
Top


TDoubleMap.AddMap(Double) Method

Summary

Represents method AddMap(Double).

Namespace: BI.Arrays
Syntax
Delphi
public
 procedure AddMap(const Value:Double);

Parameters

Value
Type: Double

See Also

Reference

  • TDoubleMap
  • BI.Arrays


TDoubleMap.AsString(TInteger) Method

Summary

Represents method AsString(TInteger).

Namespace: BI.Arrays
Syntax
Delphi
public
 function AsString(const Index:TInteger):String; override;

Parameters

Index
Type: System.Void

Return Value

Type: String

Overrides

TDataMap.AsString(TInteger)
See Also

Reference

  • TDoubleMap
  • BI.Arrays


TDoubleMap.Clear Method

Summary

Represents method Clear.

Namespace: BI.Arrays
Syntax
Delphi
public
 procedure Clear; override;

Overrides

TDataMap.Clear
See Also

Reference

  • TDoubleMap
  • BI.Arrays


TDoubleMap.Find(Double,Boolean) Method

Summary

Represents method Find(Double,Boolean).

Namespace: BI.Arrays
Syntax
Delphi
public
 function Find(const Value:Double; out Exists:Boolean):TNativeInteger; overload; inline;

Parameters

Value
Type: Double

Exists
Type: Boolean

Return Value

Type: TNativeInteger

See Also

Reference

  • TDoubleMap
  • BI.Arrays


TDoubleMap.Find(Double,TNativeInteger) Method

Summary

Represents method Find(Double,TNativeInteger).

Namespace: BI.Arrays
Syntax
Delphi
public
 function Find(const Value:Double; out Index:TNativeInteger):Boolean; overload; inline;

Parameters

Value
Type: Double

Index
Type: System.Void

Return Value

Type: Boolean

See Also

Reference

  • TDoubleMap
  • BI.Arrays


TDoubleMap Fields

Fields
Name | Description
Items | Represents field Items.
Top


TDoubleMap.Items Field

Summary

Represents field Items.

Namespace: BI.Arrays
Syntax
Delphi
public
 Items : TDoubleArray;

Field Value

Type: TDoubleArray

See Also

Reference

  • TDoubleMap
  • BI.Arrays


TExtendedMap Class

Summary

Represents type TExtendedMap.

Namespace: BI.Arrays
Inheritance Hierarchy
TObject
BI.Arrays.TDataMap
BI.Arrays.TExtendedMap
Syntax
Delphi
type
 TExtendedMap=class(TDataMap)
 end;

The TExtendedMap type exposes the following members.

Properties
Show:
Name | Description
Item[TInteger] | Represents property Item[TInteger].
Top
Methods
Show:
Name | Description
AddMap(Extended) | Represents method AddMap(Extended).
AsString(TInteger) | Represents method AsString(TInteger). (Overrides TDataMap.AsString(TInteger).)
Clear | Represents method Clear. (Overrides TDataMap.Clear.)
Find(Extended,Boolean) | Overloaded. Represents method Find(Extended,Boolean).
Find(Extended,TNativeInteger) | Overloaded. Represents method Find(Extended,TNativeInteger).
Top
Fields
Show:
Name | Description
Items | Represents field Items.
Top
See Also

Reference

  • BI.Arrays


TExtendedMap Properties

Properties
Name | Description
Item[TInteger] | Represents property Item[TInteger].
Top


TExtendedMap.Item[TInteger] Property

Summary

Represents property Item[TInteger].

Namespace: BI.Arrays
Syntax
Delphi
public
 property Item[const Index:TInteger]:Extended read GetItem; default;

Parameters

Index
Type: System.Void

Property Value

Type: Extended

See Also

Reference

  • TExtendedMap
  • BI.Arrays


TExtendedMap Methods

Methods
Name | Description
AddMap(Extended) | Represents method AddMap(Extended).
AsString(TInteger) | Represents method AsString(TInteger). (Overrides TDataMap.AsString(TInteger).)
Clear | Represents method Clear. (Overrides TDataMap.Clear.)
Find(Extended,Boolean) | Overloaded. Represents method Find(Extended,Boolean).
Find(Extended,TNativeInteger) | Overloaded. Represents method Find(Extended,TNativeInteger).
Top


TExtendedMap.AddMap(Extended) Method

Summary

Represents method AddMap(Extended).

Namespace: BI.Arrays
Syntax
Delphi
public
 procedure AddMap(const Value:Extended);

Parameters

Value
Type: Extended

See Also

Reference

  • TExtendedMap
  • BI.Arrays


TExtendedMap.AsString(TInteger) Method

Summary

Represents method AsString(TInteger).

Namespace: BI.Arrays
Syntax
Delphi
public
 function AsString(const Index:TInteger):String; override;

Parameters

Index
Type: System.Void

Return Value

Type: String

Overrides

TDataMap.AsString(TInteger)
See Also

Reference

  • TExtendedMap
  • BI.Arrays


TExtendedMap.Clear Method

Summary

Represents method Clear.

Namespace: BI.Arrays
Syntax
Delphi
public
 procedure Clear; override;

Overrides

TDataMap.Clear
See Also

Reference

  • TExtendedMap
  • BI.Arrays


TExtendedMap.Find(Extended,Boolean) Method

Summary

Represents method Find(Extended,Boolean).

Namespace: BI.Arrays
Syntax
Delphi
public
 function Find(const Value:Extended; out Exists:Boolean):TNativeInteger; overload; inline;

Parameters

Value
Type: Extended

Exists
Type: Boolean

Return Value

Type: TNativeInteger

See Also

Reference

  • TExtendedMap
  • BI.Arrays


TExtendedMap.Find(Extended,TNativeInteger) Method

Summary

Represents method Find(Extended,TNativeInteger).

Namespace: BI.Arrays
Syntax
Delphi
public
 function Find(const Value:Extended; out Index:TNativeInteger):Boolean; overload; inline;

Parameters

Value
Type: Extended

Index
Type: System.Void

Return Value

Type: Boolean

See Also

Reference

  • TExtendedMap
  • BI.Arrays


TExtendedMap Fields

Fields
Name | Description
Items | Represents field Items.
Top


TExtendedMap.Items Field

Summary

Represents field Items.

Namespace: BI.Arrays
Syntax
Delphi
public
 Items : TExtendedArray;

Field Value

Type: TExtendedArray

See Also

Reference

  • TExtendedMap
  • BI.Arrays


TInt32Map Class

Summary

Represents type TInt32Map.

Namespace: BI.Arrays
Inheritance Hierarchy
TObject
BI.Arrays.TDataMap
BI.Arrays.TInt32Map
BI.Expressions.TInvertedIndex
Syntax
Delphi
type
 TInt32Map=class(TDataMap)
 end;

The TInt32Map type exposes the following members.

Properties
Show:
Name | Description
Item[TInteger] | Represents property Item[TInteger].
Top
Methods
Show:
Name | Description
AddMap(Integer) | Represents method AddMap(Integer).
AsString(TInteger) | Represents method AsString(TInteger). (Overrides TDataMap.AsString(TInteger).)
Clear | Represents method Clear. (Overrides TDataMap.Clear.)
Find(Integer,Boolean) | Overloaded. Represents method Find(Integer,Boolean).
Find(Integer,TNativeInteger) | Overloaded. Represents method Find(Integer,TNativeInteger).
Top
Fields
Show:
Name | Description
Items | Represents field Items.
Top
See Also

Reference

  • BI.Arrays


TInt32Map Properties

Properties
Name | Description
Item[TInteger] | Represents property Item[TInteger].
Top


TInt32Map.Item[TInteger] Property

Summary

Represents property Item[TInteger].

Namespace: BI.Arrays
Syntax
Delphi
public
 property Item[const Index:TInteger]:Integer read GetItem; default;

Parameters

Index
Type: System.Void

Property Value

Type: Integer

See Also

Reference

  • TInt32Map
  • BI.Arrays


TInt32Map Methods

Methods
Name | Description
AddMap(Integer) | Represents method AddMap(Integer).
AsString(TInteger) | Represents method AsString(TInteger). (Overrides TDataMap.AsString(TInteger).)
Clear | Represents method Clear. (Overrides TDataMap.Clear.)
Find(Integer,Boolean) | Overloaded. Represents method Find(Integer,Boolean).
Find(Integer,TNativeInteger) | Overloaded. Represents method Find(Integer,TNativeInteger).
Top


TInt32Map.AddMap(Integer) Method

Summary

Represents method AddMap(Integer).

Namespace: BI.Arrays
Syntax
Delphi
public
 procedure AddMap(const Value:Integer);

Parameters

Value
Type: Integer

See Also

Reference

  • TInt32Map
  • BI.Arrays


TInt32Map.AsString(TInteger) Method

Summary

Represents method AsString(TInteger).

Namespace: BI.Arrays
Syntax
Delphi
public
 function AsString(const Index:TInteger):String; override;

Parameters

Index
Type: System.Void

Return Value

Type: String

Overrides

TDataMap.AsString(TInteger)
See Also

Reference

  • TInt32Map
  • BI.Arrays


TInt32Map.Clear Method

Summary

Represents method Clear.

Namespace: BI.Arrays
Syntax
Delphi
public
 procedure Clear; override;

Overrides

TDataMap.Clear
See Also

Reference

  • TInt32Map
  • BI.Arrays


TInt32Map.Find(Integer,Boolean) Method

Summary

Represents method Find(Integer,Boolean).

Namespace: BI.Arrays
Syntax
Delphi
public
 function Find(const Value:Integer; out Exists:Boolean):TNativeInteger; overload; inline;

Parameters

Value
Type: Integer

Exists
Type: Boolean

Return Value

Type: TNativeInteger

See Also

Reference

  • TInt32Map
  • BI.Arrays


TInt32Map.Find(Integer,TNativeInteger) Method

Summary

Represents method Find(Integer,TNativeInteger).

Namespace: BI.Arrays
Syntax
Delphi
public
 function Find(const Value:Integer; out AIndex:TNativeInteger):Boolean; overload; inline;

Parameters

Value
Type: Integer

AIndex
Type: System.Void

Return Value

Type: Boolean

See Also

Reference

  • TInt32Map
  • BI.Arrays


TInt32Map Fields

Fields
Name | Description
Items | Represents field Items.
Top


TInt32Map.Items Field

Summary

Represents field Items.

Namespace: BI.Arrays
Syntax
Delphi
public
 Items : TInt32Array;

Field Value

Type: TInt32Array

See Also

Reference

  • TInt32Map
  • BI.Arrays


TInt64Map Class

Summary

Represents type TInt64Map.

Namespace: BI.Arrays
Inheritance Hierarchy
TObject
BI.Arrays.TDataMap
BI.Arrays.TInt64Map
Syntax
Delphi
type
 TInt64Map=class(TDataMap)
 end;

The TInt64Map type exposes the following members.

Properties
Show:
Name | Description
Item[TInteger] | Represents property Item[TInteger].
Top
Methods
Show:
Name | Description
AddMap(Int64) | Represents method AddMap(Int64).
AsString(TInteger) | Represents method AsString(TInteger). (Overrides TDataMap.AsString(TInteger).)
Clear | Represents method Clear. (Overrides TDataMap.Clear.)
Find(Int64,Boolean) | Overloaded. Represents method Find(Int64,Boolean).
Find(Int64,TNativeInteger) | Overloaded. Represents method Find(Int64,TNativeInteger).
Top
Fields
Show:
Name | Description
Items | Represents field Items.
Top
See Also

Reference

  • BI.Arrays


TInt64Map Properties

Properties
Name | Description
Item[TInteger] | Represents property Item[TInteger].
Top


TInt64Map.Item[TInteger] Property

Summary

Represents property Item[TInteger].

Namespace: BI.Arrays
Syntax
Delphi
public
 property Item[const Index:TInteger]:Int64 read GetItem; default;

Parameters

Index
Type: System.Void

Property Value

Type: Int64

See Also

Reference

  • TInt64Map
  • BI.Arrays


TInt64Map Methods

Methods
Name | Description
AddMap(Int64) | Represents method AddMap(Int64).
AsString(TInteger) | Represents method AsString(TInteger). (Overrides TDataMap.AsString(TInteger).)
Clear | Represents method Clear. (Overrides TDataMap.Clear.)
Find(Int64,Boolean) | Overloaded. Represents method Find(Int64,Boolean).
Find(Int64,TNativeInteger) | Overloaded. Represents method Find(Int64,TNativeInteger).
Top


TInt64Map.AddMap(Int64) Method

Summary

Represents method AddMap(Int64).

Namespace: BI.Arrays
Syntax
Delphi
public
 procedure AddMap(const Value:Int64);

Parameters

Value
Type: Int64

See Also

Reference

  • TInt64Map
  • BI.Arrays


TInt64Map.AsString(TInteger) Method

Summary

Represents method AsString(TInteger).

Namespace: BI.Arrays
Syntax
Delphi
public
 function AsString(const Index:TInteger):String; override;

Parameters

Index
Type: System.Void

Return Value

Type: String

Overrides

TDataMap.AsString(TInteger)
See Also

Reference

  • TInt64Map
  • BI.Arrays


TInt64Map.Clear Method

Summary

Represents method Clear.

Namespace: BI.Arrays
Syntax
Delphi
public
 procedure Clear; override;

Overrides

TDataMap.Clear
See Also

Reference

  • TInt64Map
  • BI.Arrays


TInt64Map.Find(Int64,Boolean) Method

Summary

Represents method Find(Int64,Boolean).

Namespace: BI.Arrays
Syntax
Delphi
public
 function Find(const Value:Int64; out Exists:Boolean):TNativeInteger; overload; inline;

Parameters

Value
Type: Int64

Exists
Type: Boolean

Return Value

Type: TNativeInteger

See Also

Reference

  • TInt64Map
  • BI.Arrays


TInt64Map.Find(Int64,TNativeInteger) Method

Summary

Represents method Find(Int64,TNativeInteger).

Namespace: BI.Arrays
Syntax
Delphi
public
 function Find(const Value:Int64; out Index: TNativeInteger):Boolean; overload; inline;

Parameters

Value
Type: Int64

Index
Type: System.Void

Return Value

Type: Boolean

See Also

Reference

  • TInt64Map
  • BI.Arrays


TInt64Map Fields

Fields
Name | Description
Items | Represents field Items.
Top


TInt64Map.Items Field

Summary

Represents field Items.

Namespace: BI.Arrays
Syntax
Delphi
public
 Items : TInt64Array;

Field Value

Type: TInt64Array

See Also

Reference

  • TInt64Map
  • BI.Arrays


TSingleMap Class

Summary

Represents type TSingleMap.

Namespace: BI.Arrays
Inheritance Hierarchy
TObject
BI.Arrays.TDataMap
BI.Arrays.TSingleMap
Syntax
Delphi
type
 TSingleMap=class(TDataMap)
 end;

The TSingleMap type exposes the following members.

Properties
Show:
Name | Description
Item[TInteger] | Represents property Item[TInteger].
Top
Methods
Show:
Name | Description
AddMap(Single) | Represents method AddMap(Single).
AsString(TInteger) | Represents method AsString(TInteger). (Overrides TDataMap.AsString(TInteger).)
Clear | Represents method Clear. (Overrides TDataMap.Clear.)
Find(Single,Boolean) | Overloaded. Represents method Find(Single,Boolean).
Find(Single,TNativeInteger) | Overloaded. Represents method Find(Single,TNativeInteger).
Top
Fields
Show:
Name | Description
Items | Represents field Items.
Top
See Also

Reference

  • BI.Arrays


TSingleMap Properties

Properties
Name | Description
Item[TInteger] | Represents property Item[TInteger].
Top


TSingleMap.Item[TInteger] Property

Summary

Represents property Item[TInteger].

Namespace: BI.Arrays
Syntax
Delphi
public
 property Item[const Index:TInteger]:Single read GetItem; default;

Parameters

Index
Type: System.Void

Property Value

Type: Single

See Also

Reference

  • TSingleMap
  • BI.Arrays


TSingleMap Methods

Methods
Name | Description
AddMap(Single) | Represents method AddMap(Single).
AsString(TInteger) | Represents method AsString(TInteger). (Overrides TDataMap.AsString(TInteger).)
Clear | Represents method Clear. (Overrides TDataMap.Clear.)
Find(Single,Boolean) | Overloaded. Represents method Find(Single,Boolean).
Find(Single,TNativeInteger) | Overloaded. Represents method Find(Single,TNativeInteger).
Top


TSingleMap.AddMap(Single) Method

Summary

Represents method AddMap(Single).

Namespace: BI.Arrays
Syntax
Delphi
public
 procedure AddMap(const Value:Single);

Parameters

Value
Type: Single

See Also

Reference

  • TSingleMap
  • BI.Arrays


TSingleMap.AsString(TInteger) Method

Summary

Represents method AsString(TInteger).

Namespace: BI.Arrays
Syntax
Delphi
public
 function AsString(const Index:TInteger):String; override;

Parameters

Index
Type: System.Void

Return Value

Type: String

Overrides

TDataMap.AsString(TInteger)
See Also

Reference

  • TSingleMap
  • BI.Arrays


TSingleMap.Clear Method

Summary

Represents method Clear.

Namespace: BI.Arrays
Syntax
Delphi
public
 procedure Clear; override;

Overrides

TDataMap.Clear
See Also

Reference

  • TSingleMap
  • BI.Arrays


TSingleMap.Find(Single,Boolean) Method

Summary

Represents method Find(Single,Boolean).

Namespace: BI.Arrays
Syntax
Delphi
public
 function Find(const Value:Single; out Exists:Boolean):TNativeInteger; overload; inline;

Parameters

Value
Type: Single

Exists
Type: Boolean

Return Value

Type: TNativeInteger

See Also

Reference

  • TSingleMap
  • BI.Arrays


TSingleMap.Find(Single,TNativeInteger) Method

Summary

Represents method Find(Single,TNativeInteger).

Namespace: BI.Arrays
Syntax
Delphi
public
 function Find(const Value:Single; out Index:TNativeInteger):Boolean; overload; inline;

Parameters

Value
Type: Single

Index
Type: System.Void

Return Value

Type: Boolean

See Also

Reference

  • TSingleMap
  • BI.Arrays


TSingleMap Fields

Fields
Name | Description
Items | Represents field Items.
Top


TSingleMap.Items Field

Summary

Represents field Items.

Namespace: BI.Arrays
Syntax
Delphi
public
 Items : TSingleArray;

Field Value

Type: TSingleArray

See Also

Reference

  • TSingleMap
  • BI.Arrays


TSquareGrid Class

Summary

Represents type TSquareGrid.

Namespace: BI.Arrays
Syntax
Delphi
type
 TSquareGrid=type TFloatGrid;
See Also

Reference

  • BI.Arrays


TTextMap Class

Summary

Represents type TTextMap.

Namespace: BI.Arrays
Inheritance Hierarchy
TObject
BI.Arrays.TDataMap
BI.Arrays.TTextMap
Syntax
Delphi
type
 TTextMap=class(TDataMap)
 end;

The TTextMap type exposes the following members.

Properties
Show:
Name | Description
IgnoreCase | Represents property IgnoreCase.
Item[TInteger] | Represents property Item[TInteger].
Top
Methods
Show:
Name | Description
AddMap(String) | Represents method AddMap(String).
AsString(TInteger) | Represents method AsString(TInteger). (Overrides TDataMap.AsString(TInteger).)
Clear | Represents method Clear. (Overrides TDataMap.Clear.)
Find(String,Boolean) | Overloaded. Represents method Find(String,Boolean).
Find(String,TNativeInteger) | Overloaded. Represents method Find(String,TNativeInteger).
Top
Fields
Show:
Name | Description
Items | Represents field Items.
Top
See Also

Reference

  • BI.Arrays


TTextMap Properties

Properties
Name | Description
IgnoreCase | Represents property IgnoreCase.
Item[TInteger] | Represents property Item[TInteger].
Top


TTextMap.IgnoreCase Property

Summary

Represents property IgnoreCase.

Namespace: BI.Arrays
Syntax
Delphi
public
 property IgnoreCase:Boolean read FIgnoreCase;

Property Value

Type: Boolean

See Also

Reference

  • TTextMap
  • BI.Arrays


TTextMap.Item[TInteger] Property

Summary

Represents property Item[TInteger].

Namespace: BI.Arrays
Syntax
Delphi
public
 property Item[const Index:TInteger]:String read GetItem; default;

Parameters

Index
Type: System.Void

Property Value

Type: String

See Also

Reference

  • TTextMap
  • BI.Arrays


TTextMap Methods

Methods
Name | Description
AddMap(String) | Represents method AddMap(String).
AsString(TInteger) | Represents method AsString(TInteger). (Overrides TDataMap.AsString(TInteger).)
Clear | Represents method Clear. (Overrides TDataMap.Clear.)
Find(String,Boolean) | Overloaded. Represents method Find(String,Boolean).
Find(String,TNativeInteger) | Overloaded. Represents method Find(String,TNativeInteger).
Top


TTextMap.AddMap(String) Method

Summary

Represents method AddMap(String).

Namespace: BI.Arrays
Syntax
Delphi
public
 procedure AddMap(const Value:String);

Parameters

Value
Type: String

See Also

Reference

  • TTextMap
  • BI.Arrays


TTextMap.AsString(TInteger) Method

Summary

Represents method AsString(TInteger).

Namespace: BI.Arrays
Syntax
Delphi
public
 function AsString(const Index:TInteger):String; override;

Parameters

Index
Type: System.Void

Return Value

Type: String

Overrides

TDataMap.AsString(TInteger)
See Also

Reference

  • TTextMap
  • BI.Arrays


TTextMap.Clear Method

Summary

Represents method Clear.

Namespace: BI.Arrays
Syntax
Delphi
public
 procedure Clear; override;

Overrides

TDataMap.Clear
See Also

Reference

  • TTextMap
  • BI.Arrays


TTextMap.Find(String,Boolean) Method

Summary

Represents method Find(String,Boolean).

Namespace: BI.Arrays
Syntax
Delphi
public
 function Find(const Value:String; out Exists:Boolean):TNativeInteger; overload; inline;

Parameters

Value
Type: String

Exists
Type: Boolean

Return Value

Type: TNativeInteger

See Also

Reference

  • TTextMap
  • BI.Arrays


TTextMap.Find(String,TNativeInteger) Method

Summary

Represents method Find(String,TNativeInteger).

Namespace: BI.Arrays
Syntax
Delphi
public
 function Find(const Value:String; out Index: TNativeInteger):Boolean; overload; inline;

Parameters

Value
Type: String

Index
Type: System.Void

Return Value

Type: Boolean

See Also

Reference

  • TTextMap
  • BI.Arrays


TTextMap Fields

Fields
Name | Description
Items | Represents field Items.
Top


TTextMap.Items Field

Summary

Represents field Items.

Namespace: BI.Arrays
Syntax
Delphi
public
 Items : TTextArray;

Field Value

Type: TTextArray

See Also

Reference

  • TTextMap
  • BI.Arrays


BI.Arrays Enumerations

Enumerations
Name | Description
TDataOrder | Represents type TDataOrder.
Top


TDataOrder Enumeration

Summary

Represents type TDataOrder.

Namespace: BI.Arrays
Syntax
Delphi
type
 TDataOrder=(None, Ascending, Descending);

The TDataOrder type exposes the following members.

Members
Show:
Name | Description
Ascending | Represents constant Ascending.
Descending | Represents constant Descending.
None | Represents constant None.
Top
See Also

Reference

  • BI.Arrays


BI.Arrays Types

Types
Name | Description
TBooleanArray | Represents an array of the Boolean type.
TDataMapClass | Represents type TDataMapClass.
TDataStatsClass | Represents type TDataStatsClass.
TDateTimeArray | Represents an array of the TDateTime type.
TDoubleArray | Represents an array of the Double type.
TExtendedArray | Represents an array of the Extended type.
TFloat | Represents an alias of the Double type.
TFloatGrid | Represents an array of the TDoubleArray type.
TInt32Array | Represents an array of the Integer type.
TInt64Array | Represents an array of the Int64 type.
TInteger | Represents an alias of the NativeInt type.
TLoopInteger | Represents an alias of the TInteger type.
TNativeIntArray | Represents an alias of the TInt32Array type.
TNativeInteger | Represents an alias of the Integer type.
TSingleArray | Represents an array of the Single type.
TTextArray | Represents an array of the type.
Top


TBooleanArray Type

Summary

Represents an array of the Boolean type.

Namespace: BI.Arrays
Syntax
Delphi
type
 TBooleanArray=Array of Boolean;
See Also

Reference

  • BI.Arrays


TDataMapClass Type

Summary

Represents type TDataMapClass.

Namespace: BI.Arrays
Syntax
Delphi
type
 TDataMapClass=class of TDataMap;
See Also

Reference

  • BI.Arrays


TDataStatsClass Type

Summary

Represents type TDataStatsClass.

Namespace: BI.Arrays
Syntax
Delphi
type
 TDataStatsClass=class of TDataStats;
See Also

Reference

  • BI.Arrays


TDateTimeArray Type

Summary

Represents an array of the TDateTime type.

Namespace: BI.Arrays
Syntax
Delphi
type
 TDateTimeArray=Array of TDateTime;
See Also

Reference

  • BI.Arrays


TDoubleArray Type

Summary

Represents an array of the Double type.

Namespace: BI.Arrays
Syntax
Delphi
type
 TDoubleArray=Array of Double;
See Also

Reference

  • BI.Arrays


TExtendedArray Type

Summary

Represents an array of the Extended type.

Namespace: BI.Arrays
Syntax
Delphi
type
 TExtendedArray=Array of Extended;
See Also

Reference

  • BI.Arrays


TFloat Type

Summary

Represents an alias of the Double type.

Namespace: BI.Arrays
Syntax
Delphi
type
 TFloat=Double;
See Also

Reference

  • BI.Arrays


TFloatGrid Type

Summary

Represents an array of the TDoubleArray type.

Namespace: BI.Arrays
Syntax
Delphi
type
 TFloatGrid=Array of TDoubleArray;
See Also

Reference

  • BI.Arrays


TInt32Array Type

Summary

Represents an array of the Integer type.

Namespace: BI.Arrays
Syntax
Delphi
type
 TInt32Array=Array of Integer;
See Also

Reference

  • BI.Arrays


TInt64Array Type

Summary

Represents an array of the Int64 type.

Namespace: BI.Arrays
Syntax
Delphi
type
 TInt64Array=Array of Int64;
See Also

Reference

  • BI.Arrays


TInteger Type

Summary

Represents an alias of the NativeInt type.

Namespace: BI.Arrays
Syntax
Delphi
type
 TInteger=NativeInt;
See Also

Reference

  • BI.Arrays


TLoopInteger Type

Summary

Represents an alias of the TInteger type.

Namespace: BI.Arrays
Syntax
Delphi
type
 TLoopInteger=TInteger;
See Also

Reference

  • BI.Arrays


TNativeIntArray Type

Summary

Represents an alias of the TInt32Array type.

Namespace: BI.Arrays
Syntax
Delphi
type
 TNativeIntArray=TInt32Array;
See Also

Reference

  • BI.Arrays


TNativeInteger Type

Summary

Represents an alias of the Integer type.

Namespace: BI.Arrays
Syntax
Delphi
type
 TNativeInteger=Integer;
See Also

Reference

  • BI.Arrays


TSingleArray Type

Summary

Represents an array of the Single type.

Namespace: BI.Arrays
Syntax
Delphi
type
 TSingleArray=Array of Single;
See Also

Reference

  • BI.Arrays


TTextArray Type

Summary

Represents an array of the type.

Namespace: BI.Arrays
Syntax
Delphi
type
 TTextArray=Array of String;
See Also

Reference

  • BI.Arrays


BI.Arrays.Parallel Namespace

Summary

Represents namespace BI.Arrays.Parallel.

Records
Name | Description
TParallelArray | Represents type TParallelArray.
TSortedAscendingArray | Represents type TSortedAscendingArray.
TSortedDescendingArray | Represents type TSortedDescendingArray.
Top


BI.Arrays.Parallel Records

Records
Name | Description
TParallelArray | Represents type TParallelArray.
TSortedAscendingArray | Represents type TSortedAscendingArray.
TSortedDescendingArray | Represents type TSortedDescendingArray.
Top


TParallelArray Record

Summary

Represents type TParallelArray.

Namespace: BI.Arrays.Parallel
Syntax
Delphi
type
 TParallelArray=record
 end;

The TParallelArray type exposes the following members.

Methods
Show:
Name | Description
Sort(TDoubleArray,Boolean,Integer) | Overloaded. Represents method Sort(TDoubleArray,Boolean,Integer).
Sort(TInt32Array,Boolean,Integer) | Overloaded. Represents method Sort(TInt32Array,Boolean,Integer).
Sort(TInt64Array,Boolean,Integer) | Overloaded. Represents method Sort(TInt64Array,Boolean,Integer).
Sort(TSingleArray,Boolean,Integer) | Overloaded. Represents method Sort(TSingleArray,Boolean,Integer).
Top
See Also

Reference

  • BI.Arrays.Parallel


TParallelArray Methods

Methods
Name | Description
Sort(TDoubleArray,Boolean,Integer) | Overloaded. Represents method Sort(TDoubleArray,Boolean,Integer).
Sort(TInt32Array,Boolean,Integer) | Overloaded. Represents method Sort(TInt32Array,Boolean,Integer).
Sort(TInt64Array,Boolean,Integer) | Overloaded. Represents method Sort(TInt64Array,Boolean,Integer).
Sort(TSingleArray,Boolean,Integer) | Overloaded. Represents method Sort(TSingleArray,Boolean,Integer).
Top


TParallelArray.Sort(TDoubleArray,Boolean,Integer) Method

Summary

Represents method Sort(TDoubleArray,Boolean,Integer).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Sort(const Value:TDoubleArray;
 const Ascending:Boolean=True;
 const Threads:Integer=0):TDoubleArray; overload; static;

Parameters

Value
Type: TDoubleArray

Ascending
Type: Boolean

Threads
Type: Integer

Return Value

Type: TDoubleArray

See Also

Reference

  • TParallelArray
  • BI.Arrays.Parallel


TParallelArray.Sort(TInt32Array,Boolean,Integer) Method

Summary

Represents method Sort(TInt32Array,Boolean,Integer).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Sort(const Value:TInt32Array;
 const Ascending:Boolean=True;
 const Threads:Integer=0):TInt32Array; overload; static;

Parameters

Value
Type: TInt32Array

Ascending
Type: Boolean

Threads
Type: Integer

Return Value

Type: TInt32Array

See Also

Reference

  • TParallelArray
  • BI.Arrays.Parallel


TParallelArray.Sort(TInt64Array,Boolean,Integer) Method

Summary

Represents method Sort(TInt64Array,Boolean,Integer).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Sort(const Value:TInt64Array;
 const Ascending:Boolean=True;
 const Threads:Integer=0):TInt64Array; overload; static;

Parameters

Value
Type: TInt64Array

Ascending
Type: Boolean

Threads
Type: Integer

Return Value

Type: TInt64Array

See Also

Reference

  • TParallelArray
  • BI.Arrays.Parallel


TParallelArray.Sort(TSingleArray,Boolean,Integer) Method

Summary

Represents method Sort(TSingleArray,Boolean,Integer).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Sort(const Value:TSingleArray;
 const Ascending:Boolean=True;
 const Threads:Integer=0):TSingleArray; overload; static;

Parameters

Value
Type: TSingleArray

Ascending
Type: Boolean

Threads
Type: Integer

Return Value

Type: TSingleArray

See Also

Reference

  • TParallelArray
  • BI.Arrays.Parallel


TSortedAscendingArray Record

Summary

Represents type TSortedAscendingArray.

Namespace: BI.Arrays.Parallel
Syntax
Delphi
type
 TSortedAscendingArray=record
 end;

The TSortedAscendingArray type exposes the following members.

Methods
Show:
Name | Description
Merge(TDoubleArray,TDoubleArray) | Overloaded. Represents method Merge(TDoubleArray,TDoubleArray).
Merge(TDoubleArray,TDoubleArray,TInteger,TInteger,TInteger,TInteger) | Overloaded. Represents method Merge(TDoubleArray,TDoubleArray,TInteger,TInteger,TInteger,TInteger).
Merge(TDoubleArray[]) | Overloaded. Represents method Merge(TDoubleArray[]).
Merge(TInt32Array,TInt32Array) | Overloaded. Represents method Merge(TInt32Array,TInt32Array).
Merge(TInt32Array,TInt32Array,TInteger,TInteger,TInteger,TInteger) | Overloaded. Represents method Merge(TInt32Array,TInt32Array,TInteger,TInteger,TInteger,TInteger).
Merge(TInt32Array[]) | Overloaded. Represents method Merge(TInt32Array[]).
Merge(TInt64Array,TInt64Array) | Overloaded. Represents method Merge(TInt64Array,TInt64Array).
Merge(TInt64Array,TInt64Array,TInteger,TInteger,TInteger,TInteger) | Overloaded. Represents method Merge(TInt64Array,TInt64Array,TInteger,TInteger,TInteger,TInteger).
Merge(TInt64Array[]) | Overloaded. Represents method Merge(TInt64Array[]).
Merge(TSingleArray,TSingleArray) | Overloaded. Represents method Merge(TSingleArray,TSingleArray).
Merge(TSingleArray,TSingleArray,TInteger,TInteger,TInteger,TInteger) | Overloaded. Represents method Merge(TSingleArray,TSingleArray,TInteger,TInteger,TInteger,TInteger).
Merge(TSingleArray[]) | Overloaded. Represents method Merge(TSingleArray[]).
Top
See Also

Reference

  • BI.Arrays.Parallel


TSortedAscendingArray Methods

Methods
Name | Description
Merge(TDoubleArray,TDoubleArray) | Overloaded. Represents method Merge(TDoubleArray,TDoubleArray).
Merge(TDoubleArray,TDoubleArray,TInteger,TInteger,TInteger,TInteger) | Overloaded. Represents method Merge(TDoubleArray,TDoubleArray,TInteger,TInteger,TInteger,TInteger).
Merge(TDoubleArray[]) | Overloaded. Represents method Merge(TDoubleArray[]).
Merge(TInt32Array,TInt32Array) | Overloaded. Represents method Merge(TInt32Array,TInt32Array).
Merge(TInt32Array,TInt32Array,TInteger,TInteger,TInteger,TInteger) | Overloaded. Represents method Merge(TInt32Array,TInt32Array,TInteger,TInteger,TInteger,TInteger).
Merge(TInt32Array[]) | Overloaded. Represents method Merge(TInt32Array[]).
Merge(TInt64Array,TInt64Array) | Overloaded. Represents method Merge(TInt64Array,TInt64Array).
Merge(TInt64Array,TInt64Array,TInteger,TInteger,TInteger,TInteger) | Overloaded. Represents method Merge(TInt64Array,TInt64Array,TInteger,TInteger,TInteger,TInteger).
Merge(TInt64Array[]) | Overloaded. Represents method Merge(TInt64Array[]).
Merge(TSingleArray,TSingleArray) | Overloaded. Represents method Merge(TSingleArray,TSingleArray).
Merge(TSingleArray,TSingleArray,TInteger,TInteger,TInteger,TInteger) | Overloaded. Represents method Merge(TSingleArray,TSingleArray,TInteger,TInteger,TInteger,TInteger).
Merge(TSingleArray[]) | Overloaded. Represents method Merge(TSingleArray[]).
Top


TSortedAscendingArray.Merge(TDoubleArray,TDoubleArray) Method

Summary

Represents method Merge(TDoubleArray,TDoubleArray).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const A,B:TDoubleArray):TDoubleArray; overload; inline; static;

Parameters

A
Type: TDoubleArray

B
Type: TDoubleArray

Return Value

Type: TDoubleArray

See Also

Reference

  • TSortedAscendingArray
  • BI.Arrays.Parallel


TSortedAscendingArray.Merge(TDoubleArray,TDoubleArray,TInteger,TInteger,TInteger,TInteger) Method

Summary

Represents method Merge(TDoubleArray,TDoubleArray,TInteger,TInteger,TInteger,TInteger).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const A,B:TDoubleArray; AFrom,ATo,BFrom,BTo:TInteger):TDoubleArray; overload; static;

Parameters

A
Type: TDoubleArray

B
Type: TDoubleArray

AFrom
Type: System.Void

ATo
Type: System.Void

BFrom
Type: System.Void

BTo
Type: System.Void

Return Value

Type: TDoubleArray

See Also

Reference

  • TSortedAscendingArray
  • BI.Arrays.Parallel


TSortedAscendingArray.Merge(TDoubleArray[]) Method

Summary

Represents method Merge(TDoubleArray[]).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const Value:Array of TDoubleArray):TDoubleArray; overload; static;

Parameters

Value
Type: Array of TDoubleArray

Return Value

Type: TDoubleArray

See Also

Reference

  • TSortedAscendingArray
  • BI.Arrays.Parallel


TSortedAscendingArray.Merge(TInt32Array,TInt32Array) Method

Summary

Represents method Merge(TInt32Array,TInt32Array).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const A,B:TInt32Array):TInt32Array; overload; inline; static;

Parameters

A
Type: TInt32Array

B
Type: TInt32Array

Return Value

Type: TInt32Array

See Also

Reference

  • TSortedAscendingArray
  • BI.Arrays.Parallel


TSortedAscendingArray.Merge(TInt32Array,TInt32Array,TInteger,TInteger,TInteger,TInteger) Method

Summary

Represents method Merge(TInt32Array,TInt32Array,TInteger,TInteger,TInteger,TInteger).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const A,B:TInt32Array; AFrom,ATo,BFrom,BTo:TInteger):TInt32Array; overload; static;

Parameters

A
Type: TInt32Array

B
Type: TInt32Array

AFrom
Type: System.Void

ATo
Type: System.Void

BFrom
Type: System.Void

BTo
Type: System.Void

Return Value

Type: TInt32Array

See Also

Reference

  • TSortedAscendingArray
  • BI.Arrays.Parallel


TSortedAscendingArray.Merge(TInt32Array[]) Method

Summary

Represents method Merge(TInt32Array[]).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const Value:Array of TInt32Array):TInt32Array; overload; static;

Parameters

Value
Type: Array of TInt32Array

Return Value

Type: TInt32Array

See Also

Reference

  • TSortedAscendingArray
  • BI.Arrays.Parallel


TSortedAscendingArray.Merge(TInt64Array,TInt64Array) Method

Summary

Represents method Merge(TInt64Array,TInt64Array).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const A,B:TInt64Array):TInt64Array; overload; inline; static;

Parameters

A
Type: TInt64Array

B
Type: TInt64Array

Return Value

Type: TInt64Array

See Also

Reference

  • TSortedAscendingArray
  • BI.Arrays.Parallel


TSortedAscendingArray.Merge(TInt64Array,TInt64Array,TInteger,TInteger,TInteger,TInteger) Method

Summary

Represents method Merge(TInt64Array,TInt64Array,TInteger,TInteger,TInteger,TInteger).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const A,B:TInt64Array; AFrom,ATo,BFrom,BTo:TInteger):TInt64Array; overload; static;

Parameters

A
Type: TInt64Array

B
Type: TInt64Array

AFrom
Type: System.Void

ATo
Type: System.Void

BFrom
Type: System.Void

BTo
Type: System.Void

Return Value

Type: TInt64Array

See Also

Reference

  • TSortedAscendingArray
  • BI.Arrays.Parallel


TSortedAscendingArray.Merge(TInt64Array[]) Method

Summary

Represents method Merge(TInt64Array[]).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const Value:Array of TInt64Array):TInt64Array; overload; static;

Parameters

Value
Type: Array of TInt64Array

Return Value

Type: TInt64Array

See Also

Reference

  • TSortedAscendingArray
  • BI.Arrays.Parallel


TSortedAscendingArray.Merge(TSingleArray,TSingleArray) Method

Summary

Represents method Merge(TSingleArray,TSingleArray).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const A,B:TSingleArray):TSingleArray; overload; inline; static;

Parameters

A
Type: TSingleArray

B
Type: TSingleArray

Return Value

Type: TSingleArray

See Also

Reference

  • TSortedAscendingArray
  • BI.Arrays.Parallel


TSortedAscendingArray.Merge(TSingleArray,TSingleArray,TInteger,TInteger,TInteger,TInteger) Method

Summary

Represents method Merge(TSingleArray,TSingleArray,TInteger,TInteger,TInteger,TInteger).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const A,B:TSingleArray; AFrom,ATo,BFrom,BTo:TInteger):TSingleArray; overload; static;

Parameters

A
Type: TSingleArray

B
Type: TSingleArray

AFrom
Type: System.Void

ATo
Type: System.Void

BFrom
Type: System.Void

BTo
Type: System.Void

Return Value

Type: TSingleArray

See Also

Reference

  • TSortedAscendingArray
  • BI.Arrays.Parallel


TSortedAscendingArray.Merge(TSingleArray[]) Method

Summary

Represents method Merge(TSingleArray[]).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const Value:Array of TSingleArray):TSingleArray; overload; static;

Parameters

Value
Type: Array of TSingleArray

Return Value

Type: TSingleArray

See Also

Reference

  • TSortedAscendingArray
  • BI.Arrays.Parallel


TSortedDescendingArray Record

Summary

Represents type TSortedDescendingArray.

Namespace: BI.Arrays.Parallel
Syntax
Delphi
type
 TSortedDescendingArray=record
 end;

The TSortedDescendingArray type exposes the following members.

Methods
Show:
Name | Description
Merge(TDoubleArray,TDoubleArray) | Overloaded. Represents method Merge(TDoubleArray,TDoubleArray).
Merge(TDoubleArray,TDoubleArray,TInteger,TInteger,TInteger,TInteger) | Overloaded. Represents method Merge(TDoubleArray,TDoubleArray,TInteger,TInteger,TInteger,TInteger).
Merge(TDoubleArray[]) | Overloaded. Represents method Merge(TDoubleArray[]).
Merge(TInt32Array,TInt32Array) | Overloaded. Represents method Merge(TInt32Array,TInt32Array).
Merge(TInt32Array,TInt32Array,TInteger,TInteger,TInteger,TInteger) | Overloaded. Represents method Merge(TInt32Array,TInt32Array,TInteger,TInteger,TInteger,TInteger).
Merge(TInt32Array[]) | Overloaded. Represents method Merge(TInt32Array[]).
Merge(TInt64Array,TInt64Array) | Overloaded. Represents method Merge(TInt64Array,TInt64Array).
Merge(TInt64Array,TInt64Array,TInteger,TInteger,TInteger,TInteger) | Overloaded. Represents method Merge(TInt64Array,TInt64Array,TInteger,TInteger,TInteger,TInteger).
Merge(TInt64Array[]) | Overloaded. Represents method Merge(TInt64Array[]).
Merge(TSingleArray,TSingleArray) | Overloaded. Represents method Merge(TSingleArray,TSingleArray).
Merge(TSingleArray,TSingleArray,TInteger,TInteger,TInteger,TInteger) | Overloaded. Represents method Merge(TSingleArray,TSingleArray,TInteger,TInteger,TInteger,TInteger).
Merge(TSingleArray[]) | Overloaded. Represents method Merge(TSingleArray[]).
Top
See Also

Reference

  • BI.Arrays.Parallel


TSortedDescendingArray Methods

Methods
Name | Description
Merge(TDoubleArray,TDoubleArray) | Overloaded. Represents method Merge(TDoubleArray,TDoubleArray).
Merge(TDoubleArray,TDoubleArray,TInteger,TInteger,TInteger,TInteger) | Overloaded. Represents method Merge(TDoubleArray,TDoubleArray,TInteger,TInteger,TInteger,TInteger).
Merge(TDoubleArray[]) | Overloaded. Represents method Merge(TDoubleArray[]).
Merge(TInt32Array,TInt32Array) | Overloaded. Represents method Merge(TInt32Array,TInt32Array).
Merge(TInt32Array,TInt32Array,TInteger,TInteger,TInteger,TInteger) | Overloaded. Represents method Merge(TInt32Array,TInt32Array,TInteger,TInteger,TInteger,TInteger).
Merge(TInt32Array[]) | Overloaded. Represents method Merge(TInt32Array[]).
Merge(TInt64Array,TInt64Array) | Overloaded. Represents method Merge(TInt64Array,TInt64Array).
Merge(TInt64Array,TInt64Array,TInteger,TInteger,TInteger,TInteger) | Overloaded. Represents method Merge(TInt64Array,TInt64Array,TInteger,TInteger,TInteger,TInteger).
Merge(TInt64Array[]) | Overloaded. Represents method Merge(TInt64Array[]).
Merge(TSingleArray,TSingleArray) | Overloaded. Represents method Merge(TSingleArray,TSingleArray).
Merge(TSingleArray,TSingleArray,TInteger,TInteger,TInteger,TInteger) | Overloaded. Represents method Merge(TSingleArray,TSingleArray,TInteger,TInteger,TInteger,TInteger).
Merge(TSingleArray[]) | Overloaded. Represents method Merge(TSingleArray[]).
Top


TSortedDescendingArray.Merge(TDoubleArray,TDoubleArray) Method

Summary

Represents method Merge(TDoubleArray,TDoubleArray).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const A,B:TDoubleArray):TDoubleArray; overload; inline; static;

Parameters

A
Type: TDoubleArray

B
Type: TDoubleArray

Return Value

Type: TDoubleArray

See Also

Reference

  • TSortedDescendingArray
  • BI.Arrays.Parallel


TSortedDescendingArray.Merge(TDoubleArray,TDoubleArray,TInteger,TInteger,TInteger,TInteger) Method

Summary

Represents method Merge(TDoubleArray,TDoubleArray,TInteger,TInteger,TInteger,TInteger).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const A,B:TDoubleArray; AFrom,ATo,BFrom,BTo:TInteger):TDoubleArray; overload; static;

Parameters

A
Type: TDoubleArray

B
Type: TDoubleArray

AFrom
Type: System.Void

ATo
Type: System.Void

BFrom
Type: System.Void

BTo
Type: System.Void

Return Value

Type: TDoubleArray

See Also

Reference

  • TSortedDescendingArray
  • BI.Arrays.Parallel


TSortedDescendingArray.Merge(TDoubleArray[]) Method

Summary

Represents method Merge(TDoubleArray[]).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const Value:Array of TDoubleArray):TDoubleArray; overload; static;

Parameters

Value
Type: Array of TDoubleArray

Return Value

Type: TDoubleArray

See Also

Reference

  • TSortedDescendingArray
  • BI.Arrays.Parallel


TSortedDescendingArray.Merge(TInt32Array,TInt32Array) Method

Summary

Represents method Merge(TInt32Array,TInt32Array).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const A,B:TInt32Array):TInt32Array; overload; inline; static;

Parameters

A
Type: TInt32Array

B
Type: TInt32Array

Return Value

Type: TInt32Array

See Also

Reference

  • TSortedDescendingArray
  • BI.Arrays.Parallel


TSortedDescendingArray.Merge(TInt32Array,TInt32Array,TInteger,TInteger,TInteger,TInteger) Method

Summary

Represents method Merge(TInt32Array,TInt32Array,TInteger,TInteger,TInteger,TInteger).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const A,B:TInt32Array; AFrom,ATo,BFrom,BTo:TInteger):TInt32Array; overload; static;

Parameters

A
Type: TInt32Array

B
Type: TInt32Array

AFrom
Type: System.Void

ATo
Type: System.Void

BFrom
Type: System.Void

BTo
Type: System.Void

Return Value

Type: TInt32Array

See Also

Reference

  • TSortedDescendingArray
  • BI.Arrays.Parallel


TSortedDescendingArray.Merge(TInt32Array[]) Method

Summary

Represents method Merge(TInt32Array[]).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const Value:Array of TInt32Array):TInt32Array; overload; static;

Parameters

Value
Type: Array of TInt32Array

Return Value

Type: TInt32Array

See Also

Reference

  • TSortedDescendingArray
  • BI.Arrays.Parallel


TSortedDescendingArray.Merge(TInt64Array,TInt64Array) Method

Summary

Represents method Merge(TInt64Array,TInt64Array).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const A,B:TInt64Array):TInt64Array; overload; inline; static;

Parameters

A
Type: TInt64Array

B
Type: TInt64Array

Return Value

Type: TInt64Array

See Also

Reference

  • TSortedDescendingArray
  • BI.Arrays.Parallel


TSortedDescendingArray.Merge(TInt64Array,TInt64Array,TInteger,TInteger,TInteger,TInteger) Method

Summary

Represents method Merge(TInt64Array,TInt64Array,TInteger,TInteger,TInteger,TInteger).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const A,B:TInt64Array; AFrom,ATo,BFrom,BTo:TInteger):TInt64Array; overload; static;

Parameters

A
Type: TInt64Array

B
Type: TInt64Array

AFrom
Type: System.Void

ATo
Type: System.Void

BFrom
Type: System.Void

BTo
Type: System.Void

Return Value

Type: TInt64Array

See Also

Reference

  • TSortedDescendingArray
  • BI.Arrays.Parallel


TSortedDescendingArray.Merge(TInt64Array[]) Method

Summary

Represents method Merge(TInt64Array[]).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const Value:Array of TInt64Array):TInt64Array; overload; static;

Parameters

Value
Type: Array of TInt64Array

Return Value

Type: TInt64Array

See Also

Reference

  • TSortedDescendingArray
  • BI.Arrays.Parallel


TSortedDescendingArray.Merge(TSingleArray,TSingleArray) Method

Summary

Represents method Merge(TSingleArray,TSingleArray).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const A,B:TSingleArray):TSingleArray; overload; inline; static;

Parameters

A
Type: TSingleArray

B
Type: TSingleArray

Return Value

Type: TSingleArray

See Also

Reference

  • TSortedDescendingArray
  • BI.Arrays.Parallel


TSortedDescendingArray.Merge(TSingleArray,TSingleArray,TInteger,TInteger,TInteger,TInteger) Method

Summary

Represents method Merge(TSingleArray,TSingleArray,TInteger,TInteger,TInteger,TInteger).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const A,B:TSingleArray; AFrom,ATo,BFrom,BTo:TInteger):TSingleArray; overload; static;

Parameters

A
Type: TSingleArray

B
Type: TSingleArray

AFrom
Type: System.Void

ATo
Type: System.Void

BFrom
Type: System.Void

BTo
Type: System.Void

Return Value

Type: TSingleArray

See Also

Reference

  • TSortedDescendingArray
  • BI.Arrays.Parallel


TSortedDescendingArray.Merge(TSingleArray[]) Method

Summary

Represents method Merge(TSingleArray[]).

Namespace: BI.Arrays.Parallel
Syntax
Delphi
public
 class function Merge(const Value:Array of TSingleArray):TSingleArray; overload; static;

Parameters

Value
Type: Array of TSingleArray

Return Value

Type: TSingleArray

See Also

Reference

  • TSortedDescendingArray
  • BI.Arrays.Parallel


BI.Arrays.Strings Namespace

Summary

Represents namespace BI.Arrays.Strings.

Classes
Name | Description
TStringArrayHelper | Represents type TStringArrayHelper.
Top
Types
Name | Description
TArrayOfStrings | Represents an alias of the TStringArray type.
TStringArray | Represents an array of the type.
Top


BI.Arrays.Strings Classes

Classes
Name | Description
TStringArrayHelper | Represents type TStringArrayHelper.
Top


TStringArrayHelper Class Helper

Summary

Represents type TStringArrayHelper.

Namespace: BI.Arrays.Strings
Syntax
Delphi
type
 TStringArrayHelper=record helper for TStringArray
 end;
Methods
Name | Description
Add(String) | Represents method Add(String).
Count | Represents method Count.
Split(String,Char) | Overloaded. Represents method Split(String,Char).
Split(String,Char,Char) | Overloaded. Represents method Split(String,Char,Char).
Split(String,String) | Overloaded. Represents method Split(String,String).
Top
See Also

Reference

  • BI.Arrays.Strings


TStringArrayHelper Methods

Methods
Name | Description
Add(String) | Represents method Add(String).
Count | Represents method Count.
Split(String,Char) | Overloaded. Represents method Split(String,Char).
Split(String,Char,Char) | Overloaded. Represents method Split(String,Char,Char).
Split(String,String) | Overloaded. Represents method Split(String,String).
Top


TStringArrayHelper.Add(String) Method

Summary

Represents method Add(String).

Namespace: BI.Arrays.Strings
Syntax
Delphi
public
 procedure Add(const S:String);

Parameters

S
Type: String

See Also

Reference

  • TStringArrayHelper
  • BI.Arrays.Strings


TStringArrayHelper.Count Method

Summary

Represents method Count.

Namespace: BI.Arrays.Strings
Syntax
Delphi
public
 function Count:Integer; inline;

Return Value

Type: Integer

See Also

Reference

  • TStringArrayHelper
  • BI.Arrays.Strings


TStringArrayHelper.Split(String,Char) Method

Summary

Represents method Split(String,Char).

Namespace: BI.Arrays.Strings
Syntax
Delphi
public
 class function Split(const S:String; const Delimiter:Char):TStringArray; overload; static;

Parameters

S
Type: String

Delimiter
Type: Char

Return Value

Type: TStringArray

See Also

Reference

  • TStringArrayHelper
  • BI.Arrays.Strings


TStringArrayHelper.Split(String,Char,Char) Method

Summary

Represents method Split(String,Char,Char).

Namespace: BI.Arrays.Strings
Syntax
Delphi
public
 class function Split(const S:String; const Delimiter,Quote:Char):TStringArray; overload; static;

Parameters

S
Type: String

Delimiter
Type: Char

Quote
Type: Char

Return Value

Type: TStringArray

See Also

Reference

  • TStringArrayHelper
  • BI.Arrays.Strings


TStringArrayHelper.Split(String,String) Method

Summary

Represents method Split(String,String).

Namespace: BI.Arrays.Strings
Syntax
Delphi
public
 class function Split(const S,Delimiter:String):TStringArray; overload; static;

Parameters

S
Type: String

Delimiter
Type: String

Return Value

Type: TStringArray

See Also

Reference

  • TStringArrayHelper
  • BI.Arrays.Strings


BI.Arrays.Strings Types

Types
Name | Description
TArrayOfStrings | Represents an alias of the TStringArray type.
TStringArray | Represents an array of the type.
Top


TArrayOfStrings Type

Summary

Represents an alias of the TStringArray type.

Namespace: BI.Arrays.Strings
Syntax
Delphi
type
 TArrayOfStrings=TStringArray;
See Also

Reference

  • BI.Arrays.Strings


TStringArray Type

Summary

Represents an array of the type.

Namespace: BI.Arrays.Strings
Syntax
Delphi
type
 TStringArray=Array of String;
See Also

Reference

  • BI.Arrays.Strings


BI.ClientDataset Namespace

Summary

Represents namespace BI.ClientDataset.

Classes
Name | Description
TBIClientDataset | Represents type TBIClientDataset.
TClientDatasetExport | Represents type TClientDatasetExport.
Top


BI.ClientDataset Classes

Classes
Name | Description
TBIClientDataset | Represents type TBIClientDataset.
TClientDatasetExport | Represents type TClientDatasetExport.
Top


TBIClientDataset Class

Summary

Represents type TBIClientDataset.

Namespace: BI.ClientDataset
Inheritance Hierarchy
TObject
BI.DataSource.TBISource
BI.DataSource.TBIItemsSource
BI.DataSource.TBIFileSource
BI.DB.Dataset.TBIDataSetSource
BI.ClientDataset.TBIClientDataset
Syntax
Delphi
type
 TBIClientDataset=class(TBIDatasetSource)
 end;

The TBIClientDataset type exposes the following members.

Methods
Show:
Name | Description
DoImportFile(String) | Represents method DoImportFile(String). (Overrides TBIFileSource.DoImportFile(String).)
FileFilter | Represents method FileFilter. (Overrides TBIFileSource.FileFilter.)
FillData(TClientDataSet,TDataArray) | Overloaded. Represents method FillData(TClientDataSet,TDataArray).
FillData(TClientDataSet,TDataItem) | Overloaded. Represents method FillData(TClientDataSet,TDataItem).
FillData(TClientDataSet,TDataItem,TExpression) | Overloaded. Represents method FillData(TClientDataSet,TDataItem,TExpression).
Import(String,Boolean) | Overloaded. Represents method Import(String,Boolean).
Supports(String) | Represents method Supports(String). (Overrides TBIFileSource.Supports(String).)
Top
See Also

Reference

  • BI.ClientDataset


TBIClientDataset Methods

Methods
Name | Description
DoImportFile(String) | Represents method DoImportFile(String). (Overrides TBIFileSource.DoImportFile(String).)
FileFilter | Represents method FileFilter. (Overrides TBIFileSource.FileFilter.)
FillData(TClientDataSet,TDataArray) | Overloaded. Represents method FillData(TClientDataSet,TDataArray).
FillData(TClientDataSet,TDataItem) | Overloaded. Represents method FillData(TClientDataSet,TDataItem).
FillData(TClientDataSet,TDataItem,TExpression) | Overloaded. Represents method FillData(TClientDataSet,TDataItem,TExpression).
Import(String,Boolean) | Overloaded. Represents method Import(String,Boolean).
Supports(String) | Represents method Supports(String). (Overrides TBIFileSource.Supports(String).)
Top


TBIClientDataset.DoImportFile(String) Method

Summary

Represents method DoImportFile(String).

Namespace: BI.ClientDataset
Syntax
Delphi
protected
 function DoImportFile(const FileName:String):TDataArray; override;

Parameters

FileName
Type: String

Return Value

Type: TDataArray

Overrides

TBIFileSource.DoImportFile(String)
See Also

Reference

  • TBIClientDataset
  • BI.ClientDataset


TBIClientDataset.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.ClientDataset
Syntax
Delphi
public
 class function FileFilter:TFileFilters; override;

Return Value

Type: TFileFilters

Overrides

TBIFileSource.FileFilter
See Also

Reference

  • TBIClientDataset
  • BI.ClientDataset


TBIClientDataset.FillData(TClientDataSet,TDataArray) Method

Summary

Represents method FillData(TClientDataSet,TDataArray).

Namespace: BI.ClientDataset
Syntax
Delphi
public
 class procedure FillData(const DataSet: TClientDataSet; const AData: TDataArray); overload; static;

Parameters

DataSet
Type: TClientDataSet

AData
Type: TDataArray

See Also

Reference

  • TBIClientDataset
  • BI.ClientDataset


TBIClientDataset.FillData(TClientDataSet,TDataItem) Method

Summary

Represents method FillData(TClientDataSet,TDataItem).

Namespace: BI.ClientDataset
Syntax
Delphi
public
 class procedure FillData(const DataSet:TClientDataSet; const AData:TDataItem); overload; static;

Parameters

DataSet
Type: TClientDataSet

AData
Type: TDataItem

See Also

Reference

  • TBIClientDataset
  • BI.ClientDataset


TBIClientDataset.FillData(TClientDataSet,TDataItem,TExpression) Method

Summary

Represents method FillData(TClientDataSet,TDataItem,TExpression).

Namespace: BI.ClientDataset
Syntax
Delphi
public
 class procedure FillData(const DataSet:TClientDataSet; const AData:TDataItem; const Filter:TExpression=nil); overload; static;

Parameters

DataSet
Type: TClientDataSet

AData
Type: TDataItem

Filter
Type: TExpression

See Also

Reference

  • TBIClientDataset
  • BI.ClientDataset


TBIClientDataset.Import(String,Boolean) Method

Summary

Represents method Import(String,Boolean).

Namespace: BI.ClientDataset
Syntax
Delphi
public
 function Import(const Folder:String; Recursive:Boolean):TDataArray; overload;

Parameters

Folder
Type: String

Recursive
Type: Boolean

Return Value

Type: TDataArray

See Also

Reference

  • TBIClientDataset
  • BI.ClientDataset


TBIClientDataset.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.ClientDataset
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIFileSource.Supports(String)
See Also

Reference

  • TBIClientDataset
  • BI.ClientDataset


TClientDatasetExport Class

Summary

Represents type TClientDatasetExport.

Namespace: BI.ClientDataset
Inheritance Hierarchy
TObject
BI.DataSource.TBIExport
BI.ClientDataset.TClientDatasetExport
Syntax
Delphi
type
 TClientDatasetExport=class(TBIExport)
 end;

The TClientDatasetExport type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TClientDatasetExport class. (Overrides TBIExport.Create.)
Top
Methods
Show:
Name | Description
FileFilter | Represents method FileFilter. (Overrides TBIExport.FileFilter.)
SaveToFile(String) | Represents method SaveToFile(String). (Overrides TBIExport.SaveToFile(String).)
Supports(String) | Represents method Supports(String). (Overrides TBIExport.Supports(String).)
Top
Fields
Show:
Name | Description
Format | Represents field Format.
Top
See Also

Reference

  • BI.ClientDataset


TClientDatasetExport Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TClientDatasetExport class. (Overrides TBIExport.Create.)
Top


TClientDatasetExport.Create Constructor

Summary

Initializes a new instance of the TClientDatasetExport class.

Namespace: BI.ClientDataset
Syntax
Delphi
public
 Constructor Create; override;

Overrides

TBIExport.Create
See Also

Reference

  • TClientDatasetExport
  • BI.ClientDataset


TClientDatasetExport Methods

Methods
Name | Description
FileFilter | Represents method FileFilter. (Overrides TBIExport.FileFilter.)
SaveToFile(String) | Represents method SaveToFile(String). (Overrides TBIExport.SaveToFile(String).)
Supports(String) | Represents method Supports(String). (Overrides TBIExport.Supports(String).)
Top


TClientDatasetExport.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.ClientDataset
Syntax
Delphi
public
 class function FileFilter: TFileFilters; override;

Return Value

Type: TFileFilters

Overrides

TBIExport.FileFilter
See Also

Reference

  • TClientDatasetExport
  • BI.ClientDataset


TClientDatasetExport.SaveToFile(String) Method

Summary

Represents method SaveToFile(String).

Namespace: BI.ClientDataset
Syntax
Delphi
public
 procedure SaveToFile(const AFileName:String); override;

Parameters

AFileName
Type: String

Overrides

TBIExport.SaveToFile(String)
See Also

Reference

  • TClientDatasetExport
  • BI.ClientDataset


TClientDatasetExport.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.ClientDataset
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIExport.Supports(String)
See Also

Reference

  • TClientDatasetExport
  • BI.ClientDataset


TClientDatasetExport Fields

Fields
Name | Description
Format | Represents field Format.
Top


TClientDatasetExport.Format Field

Summary

Represents field Format.

Namespace: BI.ClientDataset
Syntax
Delphi
public
 Format : TDataPacketFormat;

Field Value

Type: TDataPacketFormat

See Also

Reference

  • TClientDatasetExport
  • BI.ClientDataset


BI.CollectionItem Namespace

Summary

Represents namespace BI.CollectionItem.

Classes
Name | Description
TDataAccess | Represents type TDataAccess.
TDataCollectionItem | Represents type TDataCollectionItem.
TDataProviderAccess | Represents type TDataProviderAccess.
Top


BI.CollectionItem Classes

Classes
Name | Description
TDataAccess | Represents type TDataAccess.
TDataCollectionItem | Represents type TDataCollectionItem.
TDataProviderAccess | Represents type TDataProviderAccess.
Top


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.CollectionItem
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.CollectionItem.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.CollectionItem


TDataCollectionItem Class

Summary

Represents type TDataCollectionItem.

Namespace: BI.CollectionItem
Inheritance Hierarchy
TCollectionItem
BI.CollectionItem.TDataCollectionItem
BI.Dashboard.TVisualData
BI.Expression.Filter.TFilterItem
BI.Query.TQueryItem
BI.Workflow.TWorkflowItem
FMXBI.Chart.Source.TDataCollectionItemAccess
VCLBI.Chart.Source.TDataCollectionItemAccess
Syntax
Delphi
type
 TDataCollectionItem=class(TCollectionItem)
 end;

The TDataCollectionItem type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TDataCollectionItem class.
Top
Properties
Show:
Name | Description
Data | Represents property Data.
Name | Represents property Name.
OnChange | Represents property OnChange.
Provider | Represents property Provider.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
BeginUpdate | Represents method BeginUpdate.
Changed | Represents method Changed.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
EndUpdate | Represents method EndUpdate.
GetDisplayName | Represents method GetDisplayName.
Loaded | Represents method Loaded.
Owner | Represents method Owner.
ValidateData(TDataItem) | Represents method ValidateData(TDataItem).
Top
Fields
Show:
Name | Description
FData | Represents field FData.
FProvider | Represents field FProvider.
IOrigin | Represents field IOrigin.
IUpdating | Represents field IUpdating.
Top
See Also

Reference

  • BI.CollectionItem


TDataCollectionItem Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TDataCollectionItem class.
Top


TDataCollectionItem.Destroy Destructor

Summary

Represents the destructor of the TDataCollectionItem class.

Namespace: BI.CollectionItem
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TDataCollectionItem
  • BI.CollectionItem


TDataCollectionItem Properties

Properties
Name | Description
Data | Represents property Data.
Name | Represents property Name.
OnChange | Represents property OnChange.
Provider | Represents property Provider.
Top


TDataCollectionItem.Data Property

Summary

Represents property Data.

Namespace: BI.CollectionItem
Syntax
Delphi
published
 property Data:TDataItem read GetData write SetData;

Property Value

Type: TDataItem

See Also

Reference

  • TDataCollectionItem
  • BI.CollectionItem


TDataCollectionItem.Name Property

Summary

Represents property Name.

Namespace: BI.CollectionItem
Syntax
Delphi
published
 property Name:String read FName write FName;

Property Value

Type: String

See Also

Reference

  • TDataCollectionItem
  • BI.CollectionItem


TDataCollectionItem.OnChange Property

Summary

Represents property OnChange.

Namespace: BI.CollectionItem
Syntax
Delphi
published
 property OnChange:TNotifyEvent read FOnChange write FOnChange;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TDataCollectionItem
  • BI.CollectionItem


TDataCollectionItem.Provider Property

Summary

Represents property Provider.

Namespace: BI.CollectionItem
Syntax
Delphi
published
 property Provider:TComponent read FProvider write SetProvider;

Property Value

Type: TComponent

See Also

Reference

  • TDataCollectionItem
  • BI.CollectionItem


TDataCollectionItem Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
BeginUpdate | Represents method BeginUpdate.
Changed | Represents method Changed.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
EndUpdate | Represents method EndUpdate.
GetDisplayName | Represents method GetDisplayName.
Loaded | Represents method Loaded.
Owner | Represents method Owner.
ValidateData(TDataItem) | Represents method ValidateData(TDataItem).
Top


TDataCollectionItem.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.CollectionItem
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TDataCollectionItem
  • BI.CollectionItem


TDataCollectionItem.BeginUpdate Method

Summary

Represents method BeginUpdate.

Namespace: BI.CollectionItem
Syntax
Delphi
protected
 procedure BeginUpdate; inline;
See Also

Reference

  • TDataCollectionItem
  • BI.CollectionItem


TDataCollectionItem.Changed Method

Summary

Represents method Changed.

Namespace: BI.CollectionItem
Syntax
Delphi
protected
 procedure Changed; virtual;
See Also

Reference

  • TDataCollectionItem
  • BI.CollectionItem


TDataCollectionItem.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: BI.CollectionItem
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TDataCollectionItem
  • BI.CollectionItem


TDataCollectionItem.EndUpdate Method

Summary

Represents method EndUpdate.

Namespace: BI.CollectionItem
Syntax
Delphi
protected
 procedure EndUpdate;
See Also

Reference

  • TDataCollectionItem
  • BI.CollectionItem


TDataCollectionItem.GetDisplayName Method

Summary

Represents method GetDisplayName.

Namespace: BI.CollectionItem
Syntax
Delphi
protected
 function GetDisplayName:String; override;

Return Value

Type: String

See Also

Reference

  • TDataCollectionItem
  • BI.CollectionItem


TDataCollectionItem.Loaded Method

Summary

Represents method Loaded.

Namespace: BI.CollectionItem
Syntax
Delphi
protected
 procedure Loaded; virtual;
See Also

Reference

  • TDataCollectionItem
  • BI.CollectionItem


TDataCollectionItem.Owner Method

Summary

Represents method Owner.

Namespace: BI.CollectionItem
Syntax
Delphi
protected
 function Owner:TComponent; virtual;

Return Value

Type: TComponent

See Also

Reference

  • TDataCollectionItem
  • BI.CollectionItem


TDataCollectionItem.ValidateData(TDataItem) Method

Summary

Represents method ValidateData(TDataItem).

Namespace: BI.CollectionItem
Syntax
Delphi
protected
 procedure ValidateData(const AData:TDataItem); virtual;

Parameters

AData
Type: TDataItem

See Also

Reference

  • TDataCollectionItem
  • BI.CollectionItem


TDataCollectionItem Fields

Fields
Name | Description
FData | Represents field FData.
FProvider | Represents field FProvider.
IOrigin | Represents field IOrigin.
IUpdating | Represents field IUpdating.
Top


TDataCollectionItem.FData Field

Summary

Represents field FData.

Namespace: BI.CollectionItem
Syntax
Delphi
protected
 FData : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TDataCollectionItem
  • BI.CollectionItem


TDataCollectionItem.FProvider Field

Summary

Represents field FProvider.

Namespace: BI.CollectionItem
Syntax
Delphi
protected
 FProvider : TComponent;

Field Value

Type: TComponent

See Also

Reference

  • TDataCollectionItem
  • BI.CollectionItem


TDataCollectionItem.IOrigin Field

Summary

Represents field IOrigin.

Namespace: BI.CollectionItem
Syntax
Delphi
protected
 IOrigin : String;

Field Value

Type: String

See Also

Reference

  • TDataCollectionItem
  • BI.CollectionItem


TDataCollectionItem.IUpdating Field

Summary

Represents field IUpdating.

Namespace: BI.CollectionItem
Syntax
Delphi
protected
 IUpdating : Integer;

Field Value

Type: Integer

See Also

Reference

  • TDataCollectionItem
  • BI.CollectionItem


TDataProviderAccess Class

Summary

Represents type TDataProviderAccess.

Namespace: BI.CollectionItem
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.CollectionItem.TDataProviderAccess
Syntax
Delphi
type
 TDataProviderAccess=class(TDataProvider);
See Also

Reference

  • BI.CollectionItem


BI.Compare Namespace

Summary

Represents namespace BI.Compare.

Classes
Name | Description
TBaseDifferences | Represents type TBaseDifferences.
TDataDifferences | Represents type TDataDifferences.
TDataItemAccess | Represents type TDataItemAccess.
TDifference | Represents type TDifference.
TItemDifference | Represents type TItemDifference.
TItemDifferences | Represents type TItemDifferences.
Top
Records
Name | Description
TDataCompare | Represents type TDataCompare.
TRenamedData | Represents type TRenamedData.
TRenamedItem | Represents type TRenamedItem.
Top


BI.Compare Classes

Classes
Name | Description
TBaseDifferences | Represents type TBaseDifferences.
TDataDifferences | Represents type TDataDifferences.
TDataItemAccess | Represents type TDataItemAccess.
TDifference | Represents type TDifference.
TItemDifference | Represents type TItemDifference.
TItemDifferences | Represents type TItemDifferences.
Top


TBaseDifferences Class

Summary

Represents type TBaseDifferences.

Namespace: BI.Compare
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Compare.TBaseDifferences
BI.Compare.TItemDifference
BI.Compare.TItemDifferences
Syntax
Delphi
type
 TBaseDifferences=class(TDataItem)
 end;

The TBaseDifferences type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TBaseDifferences class.
Top
Fields
Show:
Name | Description
Added | Represents field Added.
Modified | Represents field Modified.
Removed | Represents field Removed.
Top
See Also

Reference

  • BI.Compare


TBaseDifferences Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TBaseDifferences class.
Top


TBaseDifferences.Create Constructor

Summary

Initializes a new instance of the TBaseDifferences class.

Namespace: BI.Compare
Syntax
Delphi
public
 Constructor Create;
See Also

Reference

  • TBaseDifferences
  • BI.Compare


TBaseDifferences Fields

Fields
Name | Description
Added | Represents field Added.
Modified | Represents field Modified.
Removed | Represents field Removed.
Top


TBaseDifferences.Added Field

Summary

Represents field Added.

Namespace: BI.Compare
Syntax
Delphi
public
 Added,
 Removed,
 Modified : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TBaseDifferences
  • BI.Compare


TBaseDifferences.Modified Field

Summary

Represents field Modified.

Namespace: BI.Compare
Syntax
Delphi
public
 Added,
 Removed,
 Modified : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TBaseDifferences
  • BI.Compare


TBaseDifferences.Removed Field

Summary

Represents field Removed.

Namespace: BI.Compare
Syntax
Delphi
public
 Added,
 Removed,
 Modified : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TBaseDifferences
  • BI.Compare


TDataDifferences Class

Summary

Represents type TDataDifferences.

Namespace: BI.Compare
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Compare.TDataDifferences
Syntax
Delphi
type
 TDataDifferences=class(TDataItem)
 end;

The TDataDifferences type exposes the following members.

Fields
Show:
Name | Description
Added | Represents field Added.
Modified | Represents field Modified.
Removed | Represents field Removed.
Renamed | Represents field Renamed.
Top
See Also

Reference

  • BI.Compare


TDataDifferences Fields

Fields
Name | Description
Added | Represents field Added.
Modified | Represents field Modified.
Removed | Represents field Removed.
Renamed | Represents field Renamed.
Top


TDataDifferences.Added Field

Summary

Represents field Added.

Namespace: BI.Compare
Syntax
Delphi
public
 Added : TDataArray;

Field Value

Type: TDataArray

See Also

Reference

  • TDataDifferences
  • BI.Compare


TDataDifferences.Modified Field

Summary

Represents field Modified.

Namespace: BI.Compare
Syntax
Delphi
public
 Modified : Array of TDifference;

Field Value

Type: Array of TDifference

See Also

Reference

  • TDataDifferences
  • BI.Compare


TDataDifferences.Removed Field

Summary

Represents field Removed.

Namespace: BI.Compare
Syntax
Delphi
public
 Removed : TDataArray;

Field Value

Type: TDataArray

See Also

Reference

  • TDataDifferences
  • BI.Compare


TDataDifferences.Renamed Field

Summary

Represents field Renamed.

Namespace: BI.Compare
Syntax
Delphi
public
 Renamed : Array of TRenamedData;

Field Value

Type: Array of TRenamedData

See Also

Reference

  • TDataDifferences
  • BI.Compare


TDataItemAccess Class

Summary

Represents type TDataItemAccess.

Namespace: BI.Compare
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Compare.TDataItemAccess
Syntax
Delphi
type
 TDataItemAccess=class(TDataItem);
See Also

Reference

  • BI.Compare


TDifference Class

Summary

Represents type TDifference.

Namespace: BI.Compare
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Compare.TDifference
Syntax
Delphi
type
 TDifference=class(TDataItem)
 end;

The TDifference type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TDifference class.
Top
Fields
Show:
Name | Description
Items | Represents field Items.
Rows | Represents field Rows.
Top
See Also

Reference

  • BI.Compare


TDifference Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TDifference class.
Top


TDifference.Create Constructor

Summary

Initializes a new instance of the TDifference class.

Namespace: BI.Compare
Syntax
Delphi
public
 Constructor Create;
See Also

Reference

  • TDifference
  • BI.Compare


TDifference Fields

Fields
Name | Description
Items | Represents field Items.
Rows | Represents field Rows.
Top


TDifference.Items Field

Summary

Represents field Items.

Namespace: BI.Compare
Syntax
Delphi
public
 Items : TItemDifferences;

Field Value

Type: TItemDifferences

See Also

Reference

  • TDifference
  • BI.Compare


TDifference.Rows Field

Summary

Represents field Rows.

Namespace: BI.Compare
Syntax
Delphi
public
 Rows : TBaseDifferences;

Field Value

Type: TBaseDifferences

See Also

Reference

  • TDifference
  • BI.Compare


TItemDifference Class

Summary

Represents type TItemDifference.

Namespace: BI.Compare
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Compare.TBaseDifferences
BI.Compare.TItemDifference
Syntax
Delphi
type
 TItemDifference=class(TBaseDifferences)
 end;

The TItemDifference type exposes the following members.

Fields
Show:
Name | Description
Item | Represents field Item.
SameKind | Represents field SameKind.
SameTable | Represents field SameTable.
Top
See Also

Reference

  • BI.Compare


TItemDifference Fields

Fields
Name | Description
Item | Represents field Item.
SameKind | Represents field SameKind.
SameTable | Represents field SameTable.
Top


TItemDifference.Item Field

Summary

Represents field Item.

Namespace: BI.Compare
Syntax
Delphi
public
 Item : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TItemDifference
  • BI.Compare


TItemDifference.SameKind Field

Summary

Represents field SameKind.

Namespace: BI.Compare
Syntax
Delphi
public
 SameKind : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TItemDifference
  • BI.Compare


TItemDifference.SameTable Field

Summary

Represents field SameTable.

Namespace: BI.Compare
Syntax
Delphi
public
 SameTable : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TItemDifference
  • BI.Compare


TItemDifferences Class

Summary

Represents type TItemDifferences.

Namespace: BI.Compare
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Compare.TBaseDifferences
BI.Compare.TItemDifferences
Syntax
Delphi
type
 TItemDifferences=class(TBaseDifferences)
 end;

The TItemDifferences type exposes the following members.

Fields
Show:
Name | Description
Renamed | Represents field Renamed.
Top
See Also

Reference

  • BI.Compare


TItemDifferences Fields

Fields
Name | Description
Renamed | Represents field Renamed.
Top


TItemDifferences.Renamed Field

Summary

Represents field Renamed.

Namespace: BI.Compare
Syntax
Delphi
public
 Renamed : Array of TRenamedItem;

Field Value

Type: Array of TRenamedItem

See Also

Reference

  • TItemDifferences
  • BI.Compare


BI.Compare Records

Records
Name | Description
TDataCompare | Represents type TDataCompare.
TRenamedData | Represents type TRenamedData.
TRenamedItem | Represents type TRenamedItem.
Top


TDataCompare Record

Summary

Represents type TDataCompare.

Namespace: BI.Compare
Syntax
Delphi
type
 TDataCompare=record
 end;

The TDataCompare type exposes the following members.

Methods
Show:
Name | Description
Compare(TDataArray,TInteger,TDataArray,TInteger) | Overloaded. Represents method Compare(TDataArray,TInteger,TDataArray,TInteger).
Compare(TDataItem,TDataItem,TDataItem) | Overloaded. Represents method Compare(TDataItem,TDataItem,TDataItem).
Compare(TDataItem,TDataItem,TInteger) | Overloaded. Represents method Compare(TDataItem,TDataItem,TInteger).
Compare(TDataItem,TInteger,TDataItem,TInteger) | Overloaded. Represents method Compare(TDataItem,TInteger,TDataItem,TInteger).
Same(TDataItem,TDataItem) | Overloaded. Represents method Same(TDataItem,TDataItem).
Same(TDataItem,TDataItem,TDifference) | Overloaded. Represents method Same(TDataItem,TDataItem,TDifference).
Top
See Also

Reference

  • BI.Compare


TDataCompare Methods

Methods
Name | Description
Compare(TDataArray,TInteger,TDataArray,TInteger) | Overloaded. Represents method Compare(TDataArray,TInteger,TDataArray,TInteger).
Compare(TDataItem,TDataItem,TDataItem) | Overloaded. Represents method Compare(TDataItem,TDataItem,TDataItem).
Compare(TDataItem,TDataItem,TInteger) | Overloaded. Represents method Compare(TDataItem,TDataItem,TInteger).
Compare(TDataItem,TInteger,TDataItem,TInteger) | Overloaded. Represents method Compare(TDataItem,TInteger,TDataItem,TInteger).
Same(TDataItem,TDataItem) | Overloaded. Represents method Same(TDataItem,TDataItem).
Same(TDataItem,TDataItem,TDifference) | Overloaded. Represents method Same(TDataItem,TDataItem,TDifference).
Top


TDataCompare.Compare(TDataArray,TInteger,TDataArray,TInteger) Method

Summary

Represents method Compare(TDataArray,TInteger,TDataArray,TInteger).

Namespace: BI.Compare
Syntax
Delphi
public
 class function Compare(const A:TDataArray; const ARow:TInteger;
 const B:TDataArray; const BRow:TInteger): Boolean; overload; static;

Parameters

A
Type: TDataArray

ARow
Type: System.Void

B
Type: TDataArray

BRow
Type: System.Void

Return Value

Type: Boolean

See Also

Reference

  • TDataCompare
  • BI.Compare


TDataCompare.Compare(TDataItem,TDataItem,TDataItem) Method

Summary

Represents method Compare(TDataItem,TDataItem,TDataItem).

Namespace: BI.Compare
Syntax
Delphi
public
 class procedure Compare(const Before,After:TDataItem; const Dest:TDataItem); overload; static;

Parameters

Before
Type: TDataItem

After
Type: TDataItem

Dest
Type: TDataItem

See Also

Reference

  • TDataCompare
  • BI.Compare


TDataCompare.Compare(TDataItem,TDataItem,TInteger) Method

Summary

Represents method Compare(TDataItem,TDataItem,TInteger).

Namespace: BI.Compare
Syntax
Delphi
public
 class function Compare(const Before, After: TDataItem; const ARow:TInteger): Boolean; overload; static;

Parameters

Before
Type: TDataItem

After
Type: TDataItem

ARow
Type: System.Void

Return Value

Type: Boolean

See Also

Reference

  • TDataCompare
  • BI.Compare


TDataCompare.Compare(TDataItem,TInteger,TDataItem,TInteger) Method

Summary

Represents method Compare(TDataItem,TInteger,TDataItem,TInteger).

Namespace: BI.Compare
Syntax
Delphi
public
 class function Compare(const A:TDataItem; const ARow:TInteger;
 const B:TDataItem; const BRow:TInteger): Boolean; overload; static;

Parameters

A
Type: TDataItem

ARow
Type: System.Void

B
Type: TDataItem

BRow
Type: System.Void

Return Value

Type: Boolean

See Also

Reference

  • TDataCompare
  • BI.Compare


TDataCompare.Same(TDataItem,TDataItem) Method

Summary

Represents method Same(TDataItem,TDataItem).

Namespace: BI.Compare
Syntax
Delphi
public
 class function Same(const Before,After:TDataItem):Boolean; overload; static;

Parameters

Before
Type: TDataItem

After
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • TDataCompare
  • BI.Compare


TDataCompare.Same(TDataItem,TDataItem,TDifference) Method

Summary

Represents method Same(TDataItem,TDataItem,TDifference).

Namespace: BI.Compare
Syntax
Delphi
public
 class function Same(const Before,After:TDataItem; var Diff:TDifference):Boolean; overload; static;

Parameters

Before
Type: TDataItem

After
Type: TDataItem

Diff
Type: TDifference

Return Value

Type: Boolean

See Also

Reference

  • TDataCompare
  • BI.Compare


TRenamedData Record

Summary

Represents type TRenamedData.

Namespace: BI.Compare
Syntax
Delphi
type
 TRenamedData=record
 end;

The TRenamedData type exposes the following members.

Fields
Show:
Name | Description
After | Represents field After.
Before | Represents field Before.
Top
See Also

Reference

  • BI.Compare


TRenamedData Fields

Fields
Name | Description
After | Represents field After.
Before | Represents field Before.
Top


TRenamedData.After Field

Summary

Represents field After.

Namespace: BI.Compare
Syntax
Delphi
public
 Before,
 After : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TRenamedData
  • BI.Compare


TRenamedData.Before Field

Summary

Represents field Before.

Namespace: BI.Compare
Syntax
Delphi
public
 Before,
 After : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TRenamedData
  • BI.Compare


TRenamedItem Record

Summary

Represents type TRenamedItem.

Namespace: BI.Compare
Syntax
Delphi
type
 TRenamedItem=record
 end;

The TRenamedItem type exposes the following members.

Fields
Show:
Name | Description
After | Represents field After.
Before | Represents field Before.
Top
See Also

Reference

  • BI.Compare


TRenamedItem Fields

Fields
Name | Description
After | Represents field After.
Before | Represents field Before.
Top


TRenamedItem.After Field

Summary

Represents field After.

Namespace: BI.Compare
Syntax
Delphi
public
 Before,
 After : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TRenamedItem
  • BI.Compare


TRenamedItem.Before Field

Summary

Represents field Before.

Namespace: BI.Compare
Syntax
Delphi
public
 Before,
 After : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TRenamedItem
  • BI.Compare


BI.Compression Namespace

Summary

Represents namespace BI.Compression.

Classes
Name | Description
TCompressionPlugin | Represents type TCompressionPlugin.
TSystemCompression | Represents type TSystemCompression.
Top
Records
Name | Description
TCompression | Represents type TCompression.
Top
Delegates
Name | Description
TCompressionError | Represents type TCompressionError.
Top
Types
Name | Description
TCompressionPluginClass | Represents type TCompressionPluginClass.
Top


BI.Compression Classes

Classes
Name | Description
TCompressionPlugin | Represents type TCompressionPlugin.
TSystemCompression | Represents type TSystemCompression.
Top


TCompressionPlugin Class

Summary

Represents type TCompressionPlugin.

Namespace: BI.Compression
Inheritance Hierarchy
TObject
BI.Compression.TCompressionPlugin
BI.Compression.Snappy.TSnappyCompression
BI.Compression.SynZip.TSynLZCompression
BI.Compression.SynZip.TSynZipCompression
BI.Compression.TSystemCompression
Syntax
Delphi
type
 TCompressionPlugin=class abstract
 end;

The TCompressionPlugin type exposes the following members.

Methods
Show:
Name | Description
Compress(TStream,String) | Represents method Compress(TStream,String).
DeCompress(String,String,TCompressionError) | Overloaded. Represents method DeCompress(String,String,TCompressionError).
DeCompress(TStream,String) | Overloaded. Represents method DeCompress(TStream,String).
Top
See Also

Reference

  • BI.Compression


TCompressionPlugin Methods

Methods
Name | Description
Compress(TStream,String) | Represents method Compress(TStream,String).
DeCompress(String,String,TCompressionError) | Overloaded. Represents method DeCompress(String,String,TCompressionError).
DeCompress(TStream,String) | Overloaded. Represents method DeCompress(TStream,String).
Top


TCompressionPlugin.Compress(TStream,String) Method

Summary

Represents method Compress(TStream,String).

Namespace: BI.Compression
Syntax
Delphi
public
 function Compress(const AStream:TStream; const AName:String):TMemoryStream; virtual; abstract;

Parameters

AStream
Type: TStream

AName
Type: String

Return Value

Type: TMemoryStream

See Also

Reference

  • TCompressionPlugin
  • BI.Compression


TCompressionPlugin.DeCompress(String,String,TCompressionError) Method

Summary

Represents method DeCompress(String,String,TCompressionError).

Namespace: BI.Compression
Syntax
Delphi
public
 function DeCompress(const AFileName:String;
 const APassword:String='';
 const AError:TCompressionError=nil):TStringArray; overload; virtual; abstract;

Parameters

AFileName
Type: String

APassword
Type: String

AError
Type: TCompressionError

Return Value

Type: TStringArray

See Also

Reference

  • TCompressionPlugin
  • BI.Compression


TCompressionPlugin.DeCompress(TStream,String) Method

Summary

Represents method DeCompress(TStream,String).

Namespace: BI.Compression
Syntax
Delphi
public
 function DeCompress(const AStream:TStream; const AName:String):TMemoryStream; overload; virtual; abstract;

Parameters

AStream
Type: TStream

AName
Type: String

Return Value

Type: TMemoryStream

See Also

Reference

  • TCompressionPlugin
  • BI.Compression


TSystemCompression Class

Summary

Represents type TSystemCompression.

Namespace: BI.Compression
Inheritance Hierarchy
TObject
BI.Compression.TCompressionPlugin
BI.Compression.TSystemCompression
Syntax
Delphi
type
 TSystemCompression=class(TCompressionPlugin)
 end;

The TSystemCompression type exposes the following members.

Methods
Show:
Name | Description
Compress(TStream,String) | Represents method Compress(TStream,String). (Overrides TCompressionPlugin.Compress(TStream,String).)
DeCompress(String,String,TCompressionError) | Represents method DeCompress(String,String,TCompressionError). (Overrides TCompressionPlugin.DeCompress(String,String,TCompressionError).)
DeCompress(TStream,String) | Represents method DeCompress(TStream,String). (Overrides TCompressionPlugin.DeCompress(TStream,String).)
Top
See Also

Reference

  • BI.Compression


TSystemCompression Methods

Methods
Name | Description
Compress(TStream,String) | Represents method Compress(TStream,String). (Overrides TCompressionPlugin.Compress(TStream,String).)
DeCompress(String,String,TCompressionError) | Represents method DeCompress(String,String,TCompressionError). (Overrides TCompressionPlugin.DeCompress(String,String,TCompressionError).)
DeCompress(TStream,String) | Represents method DeCompress(TStream,String). (Overrides TCompressionPlugin.DeCompress(TStream,String).)
Top


TSystemCompression.Compress(TStream,String) Method

Summary

Represents method Compress(TStream,String).

Namespace: BI.Compression
Syntax
Delphi
public
 function Compress(const AStream:TStream; const AName:String):TMemoryStream; override;

Parameters

AStream
Type: TStream

AName
Type: String

Return Value

Type: TMemoryStream

Overrides

TCompressionPlugin.Compress(TStream,String)
See Also

Reference

  • TSystemCompression
  • BI.Compression


TSystemCompression.DeCompress(TStream,String) Method

Summary

Represents method DeCompress(TStream,String).

Namespace: BI.Compression
Syntax
Delphi
public
 function DeCompress(const AStream:TStream; const AName:String):TMemoryStream; override;

Parameters

AStream
Type: TStream

AName
Type: String

Return Value

Type: TMemoryStream

Overrides

TCompressionPlugin.DeCompress(TStream,String)
See Also

Reference

  • TSystemCompression
  • BI.Compression


BI.Compression Records

Records
Name | Description
TCompression | Represents type TCompression.
Top


TCompression Record

Summary

Represents type TCompression.

Namespace: BI.Compression
Syntax
Delphi
type
 TCompression=record
 end;

The TCompression type exposes the following members.

Properties
Show:
Name | Description
Plugin | Represents property Plugin.
Top
Methods
Show:
Name | Description
Compress(TStream,String) | Represents method Compress(TStream,String).
DeCompress(String,String,TCompressionError) | Overloaded. Represents method DeCompress(String,String,TCompressionError).
DeCompress(TStream,String) | Overloaded. Represents method DeCompress(TStream,String).
Top
See Also

Reference

  • BI.Compression


TCompression Properties

Properties
Name | Description
Plugin | Represents property Plugin.
Top


TCompression.Plugin Property

Summary

Represents property Plugin.

Namespace: BI.Compression
Syntax
Delphi
public
 class property Plugin : TCompressionPluginClass read GetPlugin write SetPlugin;

Property Value

Type: TCompressionPluginClass

See Also

Reference

  • TCompression
  • BI.Compression


TCompression Methods

Methods
Name | Description
Compress(TStream,String) | Represents method Compress(TStream,String).
DeCompress(String,String,TCompressionError) | Overloaded. Represents method DeCompress(String,String,TCompressionError).
DeCompress(TStream,String) | Overloaded. Represents method DeCompress(TStream,String).
Top


TCompression.Compress(TStream,String) Method

Summary

Represents method Compress(TStream,String).

Namespace: BI.Compression
Syntax
Delphi
public
 class function Compress(const AStream:TStream; const AName:String):TMemoryStream; static; inline;

Parameters

AStream
Type: TStream

AName
Type: String

Return Value

Type: TMemoryStream

See Also

Reference

  • TCompression
  • BI.Compression


TCompression.DeCompress(String,String,TCompressionError) Method

Summary

Represents method DeCompress(String,String,TCompressionError).

Namespace: BI.Compression
Syntax
Delphi
public
 class function DeCompress(const AFileName:String;
 const APassword:String='';
 const AError:TCompressionError=nil):TStringArray; overload; static; inline;

Parameters

AFileName
Type: String

APassword
Type: String

AError
Type: TCompressionError

Return Value

Type: TStringArray

See Also

Reference

  • TCompression
  • BI.Compression


TCompression.DeCompress(TStream,String) Method

Summary

Represents method DeCompress(TStream,String).

Namespace: BI.Compression
Syntax
Delphi
public
 class function DeCompress(const AStream:TStream; const AName:String):TMemoryStream; overload; static; inline;

Parameters

AStream
Type: TStream

AName
Type: String

Return Value

Type: TMemoryStream

See Also

Reference

  • TCompression
  • BI.Compression


BI.Compression Delegates

Delegates
Name | Description
TCompressionError | Represents type TCompressionError.
Top


TCompressionError Delegate

Summary

Represents type TCompressionError.

Namespace: BI.Compression
Syntax
Delphi
type
 TCompressionError=function(const Text:String):Boolean of object;
See Also

Reference

  • BI.Compression


BI.Compression Types

Types
Name | Description
TCompressionPluginClass | Represents type TCompressionPluginClass.
Top


TCompressionPluginClass Type

Summary

Represents type TCompressionPluginClass.

Namespace: BI.Compression
Syntax
Delphi
type
 TCompressionPluginClass=class of TCompressionPlugin;
See Also

Reference

  • BI.Compression


BI.Compression.Snappy Namespace

Summary

Represents namespace BI.Compression.Snappy.

Classes
Name | Description
TSnappyCompression | Represents type TSnappyCompression.
Top


BI.Compression.Snappy Classes

Classes
Name | Description
TSnappyCompression | Represents type TSnappyCompression.
Top


TSnappyCompression Class

Summary

Represents type TSnappyCompression.

Namespace: BI.Compression.Snappy
Inheritance Hierarchy
TObject
BI.Compression.TCompressionPlugin
BI.Compression.Snappy.TSnappyCompression
Syntax
Delphi
type
 TSnappyCompression=class(TCompressionPlugin)
 end;

The TSnappyCompression type exposes the following members.

Methods
Show:
Name | Description
Compress(TStream,String) | Represents method Compress(TStream,String). (Overrides TCompressionPlugin.Compress(TStream,String).)
DeCompress(String,String,TCompressionError) | Represents method DeCompress(String,String,TCompressionError). (Overrides TCompressionPlugin.DeCompress(String,String,TCompressionError).)
DeCompress(TStream,String) | Represents method DeCompress(TStream,String). (Overrides TCompressionPlugin.DeCompress(TStream,String).)
Top
See Also

Reference

  • BI.Compression.Snappy


TSnappyCompression Methods

Methods
Name | Description
Compress(TStream,String) | Represents method Compress(TStream,String). (Overrides TCompressionPlugin.Compress(TStream,String).)
DeCompress(String,String,TCompressionError) | Represents method DeCompress(String,String,TCompressionError). (Overrides TCompressionPlugin.DeCompress(String,String,TCompressionError).)
DeCompress(TStream,String) | Represents method DeCompress(TStream,String). (Overrides TCompressionPlugin.DeCompress(TStream,String).)
Top


TSnappyCompression.Compress(TStream,String) Method

Summary

Represents method Compress(TStream,String).

Namespace: BI.Compression.Snappy
Syntax
Delphi
public
 function Compress(const AStream:TStream; const AName:String):TMemoryStream; override;

Parameters

AStream
Type: TStream

AName
Type: String

Return Value

Type: TMemoryStream

Overrides

TCompressionPlugin.Compress(TStream,String)
See Also

Reference

  • TSnappyCompression
  • BI.Compression.Snappy


TSnappyCompression.DeCompress(TStream,String) Method

Summary

Represents method DeCompress(TStream,String).

Namespace: BI.Compression.Snappy
Syntax
Delphi
public
 function DeCompress(const AStream:TStream; const AName:String):TMemoryStream; override;

Parameters

AStream
Type: TStream

AName
Type: String

Return Value

Type: TMemoryStream

Overrides

TCompressionPlugin.DeCompress(TStream,String)
See Also

Reference

  • TSnappyCompression
  • BI.Compression.Snappy


BI.Compression.SynZip Namespace

Summary

Represents namespace BI.Compression.SynZip.

Classes
Name | Description
TSynLZCompression | Represents type TSynLZCompression.
TSynZipCompression | Represents type TSynZipCompression.
Top


BI.Compression.SynZip Classes

Classes
Name | Description
TSynLZCompression | Represents type TSynLZCompression.
TSynZipCompression | Represents type TSynZipCompression.
Top


TSynLZCompression Class

Summary

Represents type TSynLZCompression.

Namespace: BI.Compression.SynZip
Inheritance Hierarchy
TObject
BI.Compression.TCompressionPlugin
BI.Compression.SynZip.TSynLZCompression
Syntax
Delphi
type
 TSynLZCompression=class(TCompressionPlugin)
 end;

The TSynLZCompression type exposes the following members.

Methods
Show:
Name | Description
Compress(TStream,String) | Represents method Compress(TStream,String). (Overrides TCompressionPlugin.Compress(TStream,String).)
DeCompress(String,String,TCompressionError) | Represents method DeCompress(String,String,TCompressionError). (Overrides TCompressionPlugin.DeCompress(String,String,TCompressionError).)
DeCompress(TStream,String) | Represents method DeCompress(TStream,String). (Overrides TCompressionPlugin.DeCompress(TStream,String).)
Top
See Also

Reference

  • BI.Compression.SynZip


TSynLZCompression Methods

Methods
Name | Description
Compress(TStream,String) | Represents method Compress(TStream,String). (Overrides TCompressionPlugin.Compress(TStream,String).)
DeCompress(String,String,TCompressionError) | Represents method DeCompress(String,String,TCompressionError). (Overrides TCompressionPlugin.DeCompress(String,String,TCompressionError).)
DeCompress(TStream,String) | Represents method DeCompress(TStream,String). (Overrides TCompressionPlugin.DeCompress(TStream,String).)
Top


TSynLZCompression.Compress(TStream,String) Method

Summary

Represents method Compress(TStream,String).

Namespace: BI.Compression.SynZip
Syntax
Delphi
public
 function Compress(const AStream:TStream; const AName:String=''):TMemoryStream; override;

Parameters

AStream
Type: TStream

AName
Type: String

Return Value

Type: TMemoryStream

Overrides

TCompressionPlugin.Compress(TStream,String)
See Also

Reference

  • TSynLZCompression
  • BI.Compression.SynZip


TSynLZCompression.DeCompress(TStream,String) Method

Summary

Represents method DeCompress(TStream,String).

Namespace: BI.Compression.SynZip
Syntax
Delphi
public
 function DeCompress(const AStream:TStream; const AName:String=''):TMemoryStream; override;

Parameters

AStream
Type: TStream

AName
Type: String

Return Value

Type: TMemoryStream

Overrides

TCompressionPlugin.DeCompress(TStream,String)
See Also

Reference

  • TSynLZCompression
  • BI.Compression.SynZip


TSynZipCompression Class

Summary

Represents type TSynZipCompression.

Namespace: BI.Compression.SynZip
Inheritance Hierarchy
TObject
BI.Compression.TCompressionPlugin
BI.Compression.SynZip.TSynZipCompression
Syntax
Delphi
type
 TSynZipCompression=class(TCompressionPlugin)
 end;

The TSynZipCompression type exposes the following members.

Methods
Show:
Name | Description
Compress(TStream,String) | Represents method Compress(TStream,String). (Overrides TCompressionPlugin.Compress(TStream,String).)
DeCompress(String,String,TCompressionError) | Represents method DeCompress(String,String,TCompressionError). (Overrides TCompressionPlugin.DeCompress(String,String,TCompressionError).)
DeCompress(TStream,String) | Represents method DeCompress(TStream,String). (Overrides TCompressionPlugin.DeCompress(TStream,String).)
Top
See Also

Reference

  • BI.Compression.SynZip


TSynZipCompression Methods

Methods
Name | Description
Compress(TStream,String) | Represents method Compress(TStream,String). (Overrides TCompressionPlugin.Compress(TStream,String).)
DeCompress(String,String,TCompressionError) | Represents method DeCompress(String,String,TCompressionError). (Overrides TCompressionPlugin.DeCompress(String,String,TCompressionError).)
DeCompress(TStream,String) | Represents method DeCompress(TStream,String). (Overrides TCompressionPlugin.DeCompress(TStream,String).)
Top


TSynZipCompression.Compress(TStream,String) Method

Summary

Represents method Compress(TStream,String).

Namespace: BI.Compression.SynZip
Syntax
Delphi
public
 function Compress(const AStream:TStream; const AName:String=''):TMemoryStream; override;

Parameters

AStream
Type: TStream

AName
Type: String

Return Value

Type: TMemoryStream

Overrides

TCompressionPlugin.Compress(TStream,String)
See Also

Reference

  • TSynZipCompression
  • BI.Compression.SynZip


TSynZipCompression.DeCompress(TStream,String) Method

Summary

Represents method DeCompress(TStream,String).

Namespace: BI.Compression.SynZip
Syntax
Delphi
public
 function DeCompress(const AStream:TStream; const AName:String=''):TMemoryStream; override;

Parameters

AStream
Type: TStream

AName
Type: String

Return Value

Type: TMemoryStream

Overrides

TCompressionPlugin.DeCompress(TStream,String)
See Also

Reference

  • TSynZipCompression
  • BI.Compression.SynZip


BI.Convert Namespace

Summary

Represents namespace BI.Convert.

Classes
Name | Description
TDataItemAccess | Represents type TDataItemAccess.
TDataItemsAccess | Represents type TDataItemsAccess.
Top
Records
Name | Description
TDataKindConvert | Represents type TDataKindConvert.
Top


BI.Convert Classes

Classes
Name | Description
TDataItemAccess | Represents type TDataItemAccess.
TDataItemsAccess | Represents type TDataItemsAccess.
Top


TDataItemAccess Class

Summary

Represents type TDataItemAccess.

Namespace: BI.Convert
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Convert.TDataItemAccess
Syntax
Delphi
type
 TDataItemAccess=class(TDataItem);
See Also

Reference

  • BI.Convert


TDataItemsAccess Class

Summary

Represents type TDataItemsAccess.

Namespace: BI.Convert
Inheritance Hierarchy
TObject
BI.DataItem.TDataItems
BI.Convert.TDataItemsAccess
Syntax
Delphi
type
 TDataItemsAccess=class(TDataItems);
See Also

Reference

  • BI.Convert


BI.Convert Records

Records
Name | Description
TDataKindConvert | Represents type TDataKindConvert.
Top


TDataKindConvert Record

Summary

Represents type TDataKindConvert.

Namespace: BI.Convert
Syntax
Delphi
type
 TDataKindConvert=record
 end;

The TDataKindConvert type exposes the following members.

Methods
Show:
Name | Description
CanConvert(TDataItem,TDataKind) | Represents method CanConvert(TDataItem,TDataKind).
Convert(TDataItem,TDataKind) | Represents method Convert(TDataItem,TDataKind).
Top
See Also

Reference

  • BI.Convert


TDataKindConvert Methods

Methods
Name | Description
CanConvert(TDataItem,TDataKind) | Represents method CanConvert(TDataItem,TDataKind).
Convert(TDataItem,TDataKind) | Represents method Convert(TDataItem,TDataKind).
Top


TDataKindConvert.CanConvert(TDataItem,TDataKind) Method

Summary

Represents method CanConvert(TDataItem,TDataKind).

Namespace: BI.Convert
Syntax
Delphi
public
 class function CanConvert(const AData:TDataItem; const AKind:TDataKind):Boolean; static;

Parameters

AData
Type: TDataItem

AKind
Type: TDataKind

Return Value

Type: Boolean

See Also

Reference

  • TDataKindConvert
  • BI.Convert


TDataKindConvert.Convert(TDataItem,TDataKind) Method

Summary

Represents method Convert(TDataItem,TDataKind).

Namespace: BI.Convert
Syntax
Delphi
public
 class function Convert(const AData:TDataItem; const AKind:TDataKind):Boolean; static;

Parameters

AData
Type: TDataItem

AKind
Type: TDataKind

Return Value

Type: Boolean

See Also

Reference

  • TDataKindConvert
  • BI.Convert


BI.Crypt.LockBox Namespace

Summary

Represents namespace BI.Crypt.LockBox.

Classes
Name | Description
TBILockBox | Represents type TBILockBox.
Top
Enumerations
Name | Description
TBICipher | Represents type TBICipher.
Top


BI.Crypt.LockBox Classes

Classes
Name | Description
TBILockBox | Represents type TBILockBox.
Top


TBILockBox Class

Summary

Represents type TBILockBox.

Namespace: BI.Crypt.LockBox
Inheritance Hierarchy
TObject
BI.UI.TCrypto
BI.Crypt.LockBox.TBILockBox
Syntax
Delphi
type
 TBILockBox=class(TCrypto)
 end;

The TBILockBox type exposes the following members.

Properties
Show:
Name | Description
Cipher | Represents property Cipher.
Top
Methods
Show:
Name | Description
Decrypt(String) | Represents method Decrypt(String). (Overrides TCrypto.Decrypt(String).)
Decrypt(TStream) | Represents method Decrypt(TStream). (Overrides TCrypto.Decrypt(TStream).)
Encrypt(String) | Represents method Encrypt(String). (Overrides TCrypto.Encrypt(String).)
Encrypt(TStream) | Represents method Encrypt(TStream). (Overrides TCrypto.Encrypt(TStream).)
SetKey(String) | Represents method SetKey(String).
Top
Fields
Show:
Name | Description
FCipher | Represents field FCipher.
Top
See Also

Reference

  • BI.Crypt.LockBox


TBILockBox Properties

Properties
Name | Description
Cipher | Represents property Cipher.
Top


TBILockBox.Cipher Property

Summary

Represents property Cipher.

Namespace: BI.Crypt.LockBox
Syntax
Delphi
public
 class property Cipher:TBICipher read GetCipher write SetCipher
 default TBICipher.Blowfish;

Property Value

Type: TBICipher

See Also

Reference

  • TBILockBox
  • BI.Crypt.LockBox


TBILockBox Methods

Methods
Name | Description
Decrypt(String) | Represents method Decrypt(String). (Overrides TCrypto.Decrypt(String).)
Decrypt(TStream) | Represents method Decrypt(TStream). (Overrides TCrypto.Decrypt(TStream).)
Encrypt(String) | Represents method Encrypt(String). (Overrides TCrypto.Encrypt(String).)
Encrypt(TStream) | Represents method Encrypt(TStream). (Overrides TCrypto.Encrypt(TStream).)
SetKey(String) | Represents method SetKey(String).
Top


TBILockBox.Decrypt(TStream) Method

Summary

Represents method Decrypt(TStream).

Namespace: BI.Crypt.LockBox
Syntax
Delphi
public
 class function Decrypt(const Stream:TStream):TStream; override;

Parameters

Stream
Type: TStream

Return Value

Type: TStream

Overrides

TCrypto.Decrypt(TStream)
See Also

Reference

  • TBILockBox
  • BI.Crypt.LockBox


TBILockBox.Encrypt(TStream) Method

Summary

Represents method Encrypt(TStream).

Namespace: BI.Crypt.LockBox
Syntax
Delphi
public
 class function Encrypt(const Stream:TStream):TStream; override;

Parameters

Stream
Type: TStream

Return Value

Type: TStream

Overrides

TCrypto.Encrypt(TStream)
See Also

Reference

  • TBILockBox
  • BI.Crypt.LockBox


TBILockBox.SetKey(String) Method

Summary

Represents method SetKey(String).

Namespace: BI.Crypt.LockBox
Syntax
Delphi
public
 class procedure SetKey(const AKey:String); static;

Parameters

AKey
Type: String

See Also

Reference

  • TBILockBox
  • BI.Crypt.LockBox


TBILockBox Fields

Fields
Name | Description
FCipher | Represents field FCipher.
Top


TBILockBox.FCipher Field

Summary

Represents field FCipher.

Namespace: BI.Crypt.LockBox
Syntax
Delphi
protected
 class var FCipher : TLbSymmetricCipher;

Field Value

Type: TLbSymmetricCipher

See Also

Reference

  • TBILockBox
  • BI.Crypt.LockBox


BI.Crypt.LockBox Enumerations

Enumerations
Name | Description
TBICipher | Represents type TBICipher.
Top


TBICipher Enumeration

Summary

Represents type TBICipher.

Namespace: BI.Crypt.LockBox
Syntax
Delphi
type
 TBICipher=(Blowfish, DES, DES3, Rijndael);

The TBICipher type exposes the following members.

Members
Show:
Name | Description
Blowfish | Represents constant Blowfish.
DES | Represents constant DES.
DES3 | Represents constant DES3.
Rijndael | Represents constant Rijndael.
Top
See Also

Reference

  • BI.Crypt.LockBox


BI.CSV Namespace

Summary

Represents namespace BI.CSV.

Classes
Name | Description
EBICSV | Represents type EBICSV.
TBICSV | Represents type TBICSV.
TBICSVExport | Represents type TBICSVExport.
TDataAccess | Represents type TDataAccess.
TDataItemsAccess | Represents type TDataItemsAccess.
Top
Records
Name | Description
TCSVHeader | Represents type TCSVHeader.
Top
Enumerations
Name | Description
TTextHeaders | Represents type TTextHeaders.
Top
Routines
Name | Description
AreTitles(TStringArray) | Represents method AreTitles(TStringArray).
IsQuoted(String) | Represents method IsQuoted(String).
IsText(String) | Represents method IsText(String).
Top


BI.CSV Classes

Classes
Name | Description
EBICSV | Represents type EBICSV.
TBICSV | Represents type TBICSV.
TBICSVExport | Represents type TBICSVExport.
TDataAccess | Represents type TDataAccess.
TDataItemsAccess | Represents type TDataItemsAccess.
Top


EBICSV Class

Summary

Represents type EBICSV.

Namespace: BI.CSV
Inheritance Hierarchy
Exception
BI.Arrays.EBIException
BI.CSV.EBICSV
Syntax
Delphi
type
 EBICSV=class(EBIException);
See Also

Reference

  • BI.CSV


TBICSV Class

Summary

Represents type TBICSV.

Namespace: BI.CSV
Inheritance Hierarchy
TObject
BI.DataSource.TBISource
BI.DataSource.TBIItemsSource
BI.DataSource.TBIFileSource
BI.DataSource.TBITextSource
BI.CSV.TBICSV
Syntax
Delphi
type
 TBICSV=class(TBITextSource)
 end;

The TBICSV type exposes the following members.

Constants
Show:
Name | Description
AutomaticDelimiter | Represents constant AutomaticDelimiter.
Top
Constructors
Show:
Name | Description
Create(TDataDefinition,Boolean) | Initializes a new instance of the TBICSV class. (Overrides TBITextSource.Create(TDataDefinition,Boolean).)
Top
Methods
Show:
Name | Description
FileFilter | Represents method FileFilter. (Overrides TBIFileSource.FileFilter.)
Import(String,Boolean) | Overloaded. Represents method Import(String,Boolean).
Import(TStrings) | Represents method Import(TStrings). (Overrides TBIFileSource.Import(TStrings).)
ImportFile(String) | Represents method ImportFile(String). (Overrides TBIFileSource.ImportFile(String).)
ImportText(String) | Represents method ImportText(String).
InternalImportFile(String) | Represents method InternalImportFile(String). (Overrides TBITextSource.InternalImportFile(String).)
Supports(String) | Represents method Supports(String). (Overrides TBIFileSource.Supports(String).)
Top
Fields
Show:
Name | Description
Delimiter | Represents field Delimiter.
Header | Represents field Header.
Quote | Represents field Quote.
Top
See Also

Reference

  • BI.CSV


TBICSV Constants

Constants
Name | Description
AutomaticDelimiter | Represents constant AutomaticDelimiter.
Top


TBICSV.AutomaticDelimiter Constant

Summary

Represents constant AutomaticDelimiter.

Namespace: BI.CSV
Syntax
Delphi
public
 AutomaticDelimiter=#0;

Value

Type: string

See Also

Reference

  • TBICSV
  • BI.CSV


TBICSV Constructors

Constructors
Name | Description
Create(TDataDefinition,Boolean) | Initializes a new instance of the TBICSV class. (Overrides TBITextSource.Create(TDataDefinition,Boolean).)
Top


TBICSV.Create(TDataDefinition,Boolean) Constructor

Summary

Initializes a new instance of the TBICSV class.

Namespace: BI.CSV
Syntax
Delphi
public
 Constructor Create(const Definition:TDataDefinition=nil; const MultiThread:Boolean=False); override;

Parameters

Definition
Type: TDataDefinition

MultiThread
Type: Boolean

Overrides

TBITextSource.Create(TDataDefinition,Boolean)
See Also

Reference

  • TBICSV
  • BI.CSV


TBICSV Methods

Methods
Name | Description
FileFilter | Represents method FileFilter. (Overrides TBIFileSource.FileFilter.)
Import(String,Boolean) | Overloaded. Represents method Import(String,Boolean).
Import(TStrings) | Represents method Import(TStrings). (Overrides TBIFileSource.Import(TStrings).)
ImportFile(String) | Represents method ImportFile(String). (Overrides TBIFileSource.ImportFile(String).)
ImportText(String) | Represents method ImportText(String).
InternalImportFile(String) | Represents method InternalImportFile(String). (Overrides TBITextSource.InternalImportFile(String).)
Supports(String) | Represents method Supports(String). (Overrides TBIFileSource.Supports(String).)
Top


TBICSV.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.CSV
Syntax
Delphi
public
 class function FileFilter:TFileFilters; override;

Return Value

Type: TFileFilters

Overrides

TBIFileSource.FileFilter
See Also

Reference

  • TBICSV
  • BI.CSV


TBICSV.Import(String,Boolean) Method

Summary

Represents method Import(String,Boolean).

Namespace: BI.CSV
Syntax
Delphi
public
 function Import(const Folder:String; Recursive:Boolean=False):TDataArray; overload;

Parameters

Folder
Type: String

Recursive
Type: Boolean

Return Value

Type: TDataArray

See Also

Reference

  • TBICSV
  • BI.CSV


TBICSV.Import(TStrings) Method

Summary

Represents method Import(TStrings).

Namespace: BI.CSV
Syntax
Delphi
public
 function Import(const Strings:TStrings):TDataArray; override;

Parameters

Strings
Type: TStrings

Return Value

Type: TDataArray

Overrides

TBIFileSource.Import(TStrings)
See Also

Reference

  • TBICSV
  • BI.CSV


TBICSV.ImportFile(String) Method

Summary

Represents method ImportFile(String).

Namespace: BI.CSV
Syntax
Delphi
public
 function ImportFile(const AFileName:String):TDataArray; override;

Parameters

AFileName
Type: String

Return Value

Type: TDataArray

Overrides

TBIFileSource.ImportFile(String)
See Also

Reference

  • TBICSV
  • BI.CSV


TBICSV.ImportText(String) Method

Summary

Represents method ImportText(String).

Namespace: BI.CSV
Syntax
Delphi
public
 function ImportText(const AText:String):TDataItem;

Parameters

AText
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TBICSV
  • BI.CSV


TBICSV.InternalImportFile(String) Method

Summary

Represents method InternalImportFile(String).

Namespace: BI.CSV
Syntax
Delphi
protected
 function InternalImportFile(const FileName:String):TDataArray; override;

Parameters

FileName
Type: String

Return Value

Type: TDataArray

Overrides

TBITextSource.InternalImportFile(String)
See Also

Reference

  • TBICSV
  • BI.CSV


TBICSV.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.CSV
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIFileSource.Supports(String)
See Also

Reference

  • TBICSV
  • BI.CSV


TBICSV Fields

Fields
Name | Description
Delimiter | Represents field Delimiter.
Header | Represents field Header.
Quote | Represents field Quote.
Top


TBICSV.Delimiter Field

Summary

Represents field Delimiter.

Namespace: BI.CSV
Syntax
Delphi
public
 Delimiter : Char;

Field Value

Type: Char

See Also

Reference

  • TBICSV
  • BI.CSV


TBICSV.Header Field

Summary

Represents field Header.

Namespace: BI.CSV
Syntax
Delphi
public
 Header : TCSVHeader;

Field Value

Type: TCSVHeader

See Also

Reference

  • TBICSV
  • BI.CSV


TBICSV.Quote Field

Summary

Represents field Quote.

Namespace: BI.CSV
Syntax
Delphi
public
 Quote : Char;

Field Value

Type: Char

See Also

Reference

  • TBICSV
  • BI.CSV


TBICSVExport Class

Summary

Represents type TBICSVExport.

Namespace: BI.CSV
Inheritance Hierarchy
TObject
BI.DataSource.TBIExport
BI.DataSource.TBITextExport
BI.CSV.TBICSVExport
Syntax
Delphi
type
 TBICSVExport=class(TBITextExport)
 end;

The TBICSVExport type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TBICSVExport class. (Overrides TBIExport.Create.)
Top
Methods
Show:
Name | Description
DoEmit(TStrings) | Represents method DoEmit(TStrings). (Overrides TBIExport.DoEmit(TStrings).)
FileFilter | Represents method FileFilter. (Overrides TBIExport.FileFilter.)
Supports(String) | Represents method Supports(String). (Overrides TBIExport.Supports(String).)
Top
Fields
Show:
Name | Description
Delimiter | Represents field Delimiter.
Header | Represents field Header.
Quote | Represents field Quote.
Top
See Also

Reference

  • BI.CSV


TBICSVExport Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TBICSVExport class. (Overrides TBIExport.Create.)
Top


TBICSVExport.Create Constructor

Summary

Initializes a new instance of the TBICSVExport class.

Namespace: BI.CSV
Syntax
Delphi
public
 Constructor Create; override;

Overrides

TBIExport.Create
See Also

Reference

  • TBICSVExport
  • BI.CSV


TBICSVExport Methods

Methods
Name | Description
DoEmit(TStrings) | Represents method DoEmit(TStrings). (Overrides TBIExport.DoEmit(TStrings).)
FileFilter | Represents method FileFilter. (Overrides TBIExport.FileFilter.)
Supports(String) | Represents method Supports(String). (Overrides TBIExport.Supports(String).)
Top


TBICSVExport.DoEmit(TStrings) Method

Summary

Represents method DoEmit(TStrings).

Namespace: BI.CSV
Syntax
Delphi
protected
 procedure DoEmit(const AItems: TStrings); override;

Parameters

AItems
Type: TStrings

Overrides

TBIExport.DoEmit(TStrings)
See Also

Reference

  • TBICSVExport
  • BI.CSV


TBICSVExport.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.CSV
Syntax
Delphi
public
 class function FileFilter:TFileFilters; override;

Return Value

Type: TFileFilters

Overrides

TBIExport.FileFilter
See Also

Reference

  • TBICSVExport
  • BI.CSV


TBICSVExport.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.CSV
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIExport.Supports(String)
See Also

Reference

  • TBICSVExport
  • BI.CSV


TBICSVExport Fields

Fields
Name | Description
Delimiter | Represents field Delimiter.
Header | Represents field Header.
Quote | Represents field Quote.
Top


TBICSVExport.Delimiter Field

Summary

Represents field Delimiter.

Namespace: BI.CSV
Syntax
Delphi
public
 Delimiter : Char;

Field Value

Type: Char

See Also

Reference

  • TBICSVExport
  • BI.CSV


TBICSVExport.Header Field

Summary

Represents field Header.

Namespace: BI.CSV
Syntax
Delphi
public
 Header : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBICSVExport
  • BI.CSV


TBICSVExport.Quote Field

Summary

Represents field Quote.

Namespace: BI.CSV
Syntax
Delphi
public
 Quote : Char;

Field Value

Type: Char

See Also

Reference

  • TBICSVExport
  • BI.CSV


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.CSV
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.CSV.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.CSV


TDataItemsAccess Class

Summary

Represents type TDataItemsAccess.

Namespace: BI.CSV
Inheritance Hierarchy
TObject
BI.DataItem.TDataItems
BI.CSV.TDataItemsAccess
Syntax
Delphi
type
 TDataItemsAccess=class(TDataItems);
See Also

Reference

  • BI.CSV


BI.CSV Records

Records
Name | Description
TCSVHeader | Represents type TCSVHeader.
Top


TCSVHeader Record

Summary

Represents type TCSVHeader.

Namespace: BI.CSV
Syntax
Delphi
type
 TCSVHeader=record
 end;

The TCSVHeader type exposes the following members.

Fields
Show:
Name | Description
Count | Represents field Count.
Headers | Represents field Headers.
Top
See Also

Reference

  • BI.CSV


TCSVHeader Fields

Fields
Name | Description
Count | Represents field Count.
Headers | Represents field Headers.
Top


TCSVHeader.Count Field

Summary

Represents field Count.

Namespace: BI.CSV
Syntax
Delphi
public
 Count : Integer;

Field Value

Type: Integer

See Also

Reference

  • TCSVHeader
  • BI.CSV


TCSVHeader.Headers Field

Summary

Represents field Headers.

Namespace: BI.CSV
Syntax
Delphi
public
 Headers : TTextHeaders;

Field Value

Type: TTextHeaders

See Also

Reference

  • TCSVHeader
  • BI.CSV


BI.CSV Enumerations

Enumerations
Name | Description
TTextHeaders | Represents type TTextHeaders.
Top


TTextHeaders Enumeration

Summary

Represents type TTextHeaders.

Namespace: BI.CSV
Syntax
Delphi
type
 TTextHeaders=(Auto,Yes,No);

The TTextHeaders type exposes the following members.

Members
Show:
Name | Description
Auto | Represents constant Auto.
No | Represents constant No.
Yes | Represents constant Yes.
Top
See Also

Reference

  • BI.CSV


BI.CSV Routines

Routines
Name | Description
AreTitles(TStringArray) | Represents method AreTitles(TStringArray).
IsQuoted(String) | Represents method IsQuoted(String).
IsText(String) | Represents method IsText(String).
Top


AreTitles(TStringArray) Method

Summary

Represents method AreTitles(TStringArray).

Namespace: BI.CSV
Syntax
Delphi
function AreTitles(const Fields:TStringArray):Boolean;

Parameters

Fields
Type: TStringArray

Return Value

Type: Boolean

See Also

Reference

  • BI.CSV


IsQuoted(String) Method

Summary

Represents method IsQuoted(String).

Namespace: BI.CSV
Syntax
Delphi
function IsQuoted(const S:String):Boolean;

Parameters

S
Type: String

Return Value

Type: Boolean

See Also

Reference

  • BI.CSV


IsText(String) Method

Summary

Represents method IsText(String).

Namespace: BI.CSV
Syntax
Delphi
function IsText(const S:String):Boolean;

Parameters

S
Type: String

Return Value

Type: Boolean

See Also

Reference

  • BI.CSV


BI.Dashboard Namespace

Summary

Represents namespace BI.Dashboard.

Classes
Name | Description
TBaseItem | Represents type TBaseItem.
TBIFont | Represents type TBIFont.
TBIPanel | Represents type TBIPanel.
TBITemplate | Represents type TBITemplate.
TChangeListener | Represents type TChangeListener.
TComponentAccess | Represents type TComponentAccess.
TCustomBIPanel | Represents type TCustomBIPanel.
TDashboard | Represents type TDashboard.
TDashboardItem | Represents type TDashboardItem.
TDashboardItems | Represents type TDashboardItems.
TDashboards | Represents type TDashboards.
TDataAccess | Represents type TDataAccess.
TListeners | Represents type TListeners.
TPanelKindHelper | Represents type TPanelKindHelper.
TPanels | Represents type TPanels.
TProviderAccess | Represents type TProviderAccess.
TRender | Represents type TRender.
TVariable | Represents type TVariable.
TVariables | Represents type TVariables.
TVisualData | Represents type TVisualData.
TVisualDataItems | Represents type TVisualDataItems.
Top
Enumerations
Name | Description
TPanelKind | Represents type TPanelKind.
TVisualDataKind | Represents type TVisualDataKind.
Top
Delegates
Name | Description
TChangeEvent | Represents type TChangeEvent.
Top
Types
Name | Description
TRenderClass | Represents type TRenderClass.
TVariableArray | Represents an array of the TVariable type.
Top


BI.Dashboard Classes

Classes
Name | Description
TBaseItem | Represents type TBaseItem.
TBIFont | Represents type TBIFont.
TBIPanel | Represents type TBIPanel.
TBITemplate | Represents type TBITemplate.
TChangeListener | Represents type TChangeListener.
TComponentAccess | Represents type TComponentAccess.
TCustomBIPanel | Represents type TCustomBIPanel.
TDashboard | Represents type TDashboard.
TDashboardItem | Represents type TDashboardItem.
TDashboardItems | Represents type TDashboardItems.
TDashboards | Represents type TDashboards.
TDataAccess | Represents type TDataAccess.
TListeners | Represents type TListeners.
TPanelKindHelper | Represents type TPanelKindHelper.
TPanels | Represents type TPanels.
TProviderAccess | Represents type TProviderAccess.
TRender | Represents type TRender.
TVariable | Represents type TVariable.
TVariables | Represents type TVariables.
TVisualData | Represents type TVisualData.
TVisualDataItems | Represents type TVisualDataItems.
Top


TBaseItem Class

Summary

Represents type TBaseItem.

Namespace: BI.Dashboard
Inheritance Hierarchy
TCollectionItem
BI.Dashboard.TBaseItem
BI.Dashboard.HTML.TBaseItemAccess
BI.Dashboard.TCustomBIPanel
FMXBI.Dashboard.TBaseItemAccess
VCLBI.Dashboard.TBaseItemAccess
Syntax
Delphi
type
 TBaseItem=class(TCollectionItem)
 end;

The TBaseItem type exposes the following members.

Properties
Show:
Name | Description
Name | Represents property Name.
Top
Methods
Show:
Name | Description
ReplaceString(String) | Represents method ReplaceString(String).
Template | Represents method Template.
UsesVariable(TChangeListener) | Represents method UsesVariable(TChangeListener).
Variables | Represents method Variables.
Top
See Also

Reference

  • BI.Dashboard


TBaseItem Properties

Properties
Name | Description
Name | Represents property Name.
Top


TBaseItem.Name Property

Summary

Represents property Name.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Name:String read FName write SetName;

Property Value

Type: String

See Also

Reference

  • TBaseItem
  • BI.Dashboard


TBaseItem Methods

Methods
Name | Description
ReplaceString(String) | Represents method ReplaceString(String).
Template | Represents method Template.
UsesVariable(TChangeListener) | Represents method UsesVariable(TChangeListener).
Variables | Represents method Variables.
Top


TBaseItem.ReplaceString(String) Method

Summary

Represents method ReplaceString(String).

Namespace: BI.Dashboard
Syntax
Delphi
protected
 function ReplaceString(const S:String):String;

Parameters

S
Type: String

Return Value

Type: String

See Also

Reference

  • TBaseItem
  • BI.Dashboard


TBaseItem.Template Method

Summary

Represents method Template.

Namespace: BI.Dashboard
Syntax
Delphi
protected
 function Template: TBITemplate;

Return Value

Type: TBITemplate

See Also

Reference

  • TBaseItem
  • BI.Dashboard


TBaseItem.UsesVariable(TChangeListener) Method

Summary

Represents method UsesVariable(TChangeListener).

Namespace: BI.Dashboard
Syntax
Delphi
public
 function UsesVariable(const Sender:TChangeListener):Boolean; virtual;

Parameters

Sender
Type: TChangeListener

Return Value

Type: Boolean

See Also

Reference

  • TBaseItem
  • BI.Dashboard


TBaseItem.Variables Method

Summary

Represents method Variables.

Namespace: BI.Dashboard
Syntax
Delphi
protected
 function Variables:TVariables;

Return Value

Type: TVariables

See Also

Reference

  • TBaseItem
  • BI.Dashboard


TBIFont Class

Summary

Represents type TBIFont.

Namespace: BI.Dashboard
Inheritance Hierarchy
TPersistent
BI.Dashboard.TBIFont
Syntax
Delphi
type
 TBIFont=class(TPersistent)
 end;

The TBIFont type exposes the following members.

Properties
Show:
Name | Description
Bold | Represents property Bold.
Color | Represents property Color.
Family | Represents property Family.
Italic | Represents property Italic.
Size | Represents property Size.
Top
See Also

Reference

  • BI.Dashboard


TBIFont Properties

Properties
Name | Description
Bold | Represents property Bold.
Color | Represents property Color.
Family | Represents property Family.
Italic | Represents property Italic.
Size | Represents property Size.
Top


TBIFont.Bold Property

Summary

Represents property Bold.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Bold:Boolean read FBold write FBold default False;

Property Value

Type: Boolean

See Also

Reference

  • TBIFont
  • BI.Dashboard


TBIFont.Color Property

Summary

Represents property Color.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Color:TAlphaColor read FColor write SetColor default TAlphaColors.Null;

Property Value

Type: TAlphaColor

See Also

Reference

  • TBIFont
  • BI.Dashboard


TBIFont.Family Property

Summary

Represents property Family.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Family:String read FFamily write FFamily;

Property Value

Type: String

See Also

Reference

  • TBIFont
  • BI.Dashboard


TBIFont.Italic Property

Summary

Represents property Italic.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Italic:Boolean read FItalic write FItalic default False;

Property Value

Type: Boolean

See Also

Reference

  • TBIFont
  • BI.Dashboard


TBIFont.Size Property

Summary

Represents property Size.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Size:Single read FSize write FSize;

Property Value

Type: Single

See Also

Reference

  • TBIFont
  • BI.Dashboard


TBIPanel Class

Summary

Represents type TBIPanel.

Namespace: BI.Dashboard
Inheritance Hierarchy
TCollectionItem
BI.Dashboard.TBaseItem
BI.Dashboard.TCustomBIPanel
BI.Dashboard.TBIPanel
BI.Dashboard.HTML.TBIPanelAccess
FMXBI.Dashboard.TBIPanelAccess
VCLBI.Dashboard.TBIPanelAccess
Syntax
Delphi
type
 TBIPanel=class(TCustomBIPanel)
 end;

The TBIPanel type exposes the following members.

Properties
Show:
Name | Description
Back | Represents property Back.
Data | Represents property Data.
Font | Represents property Font.
Height | Represents property Height.
Kind | Represents property Kind.
Source | Represents property Source.
Target | Represents property Target.
URL | Represents property URL.
Width | Represents property Width.
Top
See Also

Reference

  • BI.Dashboard


TBIPanel Properties

Properties
Name | Description
Back | Represents property Back.
Data | Represents property Data.
Font | Represents property Font.
Height | Represents property Height.
Kind | Represents property Kind.
Source | Represents property Source.
Target | Represents property Target.
URL | Represents property URL.
Width | Represents property Width.
Top


TBIPanel.Back Property

Summary

Represents property Back.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Back;

Property Value

Type: Void

See Also

Reference

  • TBIPanel
  • BI.Dashboard


TBIPanel.Data Property

Summary

Represents property Data.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Data;

Property Value

Type: Void

See Also

Reference

  • TBIPanel
  • BI.Dashboard


TBIPanel.Font Property

Summary

Represents property Font.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Font;

Property Value

Type: Void

See Also

Reference

  • TBIPanel
  • BI.Dashboard


TBIPanel.Height Property

Summary

Represents property Height.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Height;

Property Value

Type: Void

See Also

Reference

  • TBIPanel
  • BI.Dashboard


TBIPanel.Kind Property

Summary

Represents property Kind.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Kind;

Property Value

Type: Void

See Also

Reference

  • TBIPanel
  • BI.Dashboard


TBIPanel.Source Property

Summary

Represents property Source.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Source;

Property Value

Type: Void

See Also

Reference

  • TBIPanel
  • BI.Dashboard


TBIPanel.Target Property

Summary

Represents property Target.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Target;

Property Value

Type: Void

See Also

Reference

  • TBIPanel
  • BI.Dashboard


TBIPanel.URL Property

Summary

Represents property URL.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property URL;

Property Value

Type: Void

See Also

Reference

  • TBIPanel
  • BI.Dashboard


TBIPanel.Width Property

Summary

Represents property Width.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Width;

Property Value

Type: Void

See Also

Reference

  • TBIPanel
  • BI.Dashboard


TBITemplate Class

Summary

Represents type TBITemplate.

Namespace: BI.Dashboard
Inheritance Hierarchy
TComponent
BI.Dashboard.TBITemplate
BI.Dashboard.HTML.TBITemplateAccess
BI.Dashboard.Loader.TBITemplateAccess
BI.Dashboard.Loader.TTemplateAccess
FMXBI.Dashboard.TBITemplateAccess
VCLBI.Dashboard.TBITemplateAccess
VCLBI.Editor.Template.TBITemplateAccess
VCLBI.Editor.Template.TTemplateAccess
Syntax
Delphi
type
 TBITemplate=class(TComponent)
 end;

The TBITemplate type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBITemplate class.
Destroy | Represents the destructor of the TBITemplate class.
Top
Properties
Show:
Name | Description
Dashboards | Represents property Dashboards.
Data | Represents property Data.
Layouts | Represents property Layouts.
List | Represents property List.
MainData | Represents property MainData.
Panels | Represents property Panels.
Top
Methods
Show:
Name | Description
Clear | Represents method Clear.
FindData(String,String) | Represents method FindData(String,String).
FindLayout(String) | Represents method FindLayout(String).
Generate(TRender,TDashboard,String,String) | Represents method Generate(TRender,TDashboard,String,String).
GetItem(String) | Represents method GetItem(String).
GetMasterDetail(TDataItem,TInteger) | Represents method GetMasterDetail(TDataItem,TInteger).
Loaded | Represents method Loaded.
NewOwner | Represents method NewOwner.
NewQuery(TVisualData,String) | Represents method NewQuery(TVisualData,String).
PanelData(TBIPanel) | Represents method PanelData(TBIPanel).
Top
Fields
Show:
Name | Description
Root | Represents field Root.
Top
See Also

Reference

  • BI.Dashboard


TBITemplate Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBITemplate class.
Destroy | Represents the destructor of the TBITemplate class.
Top


TBITemplate.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBITemplate class.

Namespace: BI.Dashboard
Syntax
Delphi
public
 Constructor Create(Owner:TComponent); override;

Parameters

Owner
Type: TComponent

See Also

Reference

  • TBITemplate
  • BI.Dashboard


TBITemplate.Destroy Destructor

Summary

Represents the destructor of the TBITemplate class.

Namespace: BI.Dashboard
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBITemplate
  • BI.Dashboard


TBITemplate Properties

Properties
Name | Description
Dashboards | Represents property Dashboards.
Data | Represents property Data.
Layouts | Represents property Layouts.
List | Represents property List.
MainData | Represents property MainData.
Panels | Represents property Panels.
Top


TBITemplate.Dashboards Property

Summary

Represents property Dashboards.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Dashboards:TDashboards read FDashboards write SetDashboards;

Property Value

Type: TDashboards

See Also

Reference

  • TBITemplate
  • BI.Dashboard


TBITemplate.Data Property

Summary

Represents property Data.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Data:TVisualDataItems read FData write SetData;

Property Value

Type: TVisualDataItems

See Also

Reference

  • TBITemplate
  • BI.Dashboard


TBITemplate.Layouts Property

Summary

Represents property Layouts.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Layouts:TLayouts read FLayouts write SetLayouts;

Property Value

Type: TLayouts

See Also

Reference

  • TBITemplate
  • BI.Dashboard


TBITemplate.List Property

Summary

Represents property List.

Namespace: BI.Dashboard
Syntax
Delphi
protected
 property List:TDataItem read IList write IList;

Property Value

Type: TDataItem

See Also

Reference

  • TBITemplate
  • BI.Dashboard


TBITemplate.MainData Property

Summary

Represents property MainData.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property MainData:TDataItem read IMainData write IMainData;

Property Value

Type: TDataItem

See Also

Reference

  • TBITemplate
  • BI.Dashboard


TBITemplate.Panels Property

Summary

Represents property Panels.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Panels:TPanels read FPanels write SetPanels;

Property Value

Type: TPanels

See Also

Reference

  • TBITemplate
  • BI.Dashboard


TBITemplate Methods

Methods
Name | Description
Clear | Represents method Clear.
FindData(String,String) | Represents method FindData(String,String).
FindLayout(String) | Represents method FindLayout(String).
Generate(TRender,TDashboard,String,String) | Represents method Generate(TRender,TDashboard,String,String).
GetItem(String) | Represents method GetItem(String).
GetMasterDetail(TDataItem,TInteger) | Represents method GetMasterDetail(TDataItem,TInteger).
Loaded | Represents method Loaded.
NewOwner | Represents method NewOwner.
NewQuery(TVisualData,String) | Represents method NewQuery(TVisualData,String).
PanelData(TBIPanel) | Represents method PanelData(TBIPanel).
Top


TBITemplate.Clear Method

Summary

Represents method Clear.

Namespace: BI.Dashboard
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TBITemplate
  • BI.Dashboard


TBITemplate.FindData(String,String) Method

Summary

Represents method FindData(String,String).

Namespace: BI.Dashboard
Syntax
Delphi
protected
 function FindData(const AStore,AName:String):TDataItem;

Parameters

AStore
Type: String

AName
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TBITemplate
  • BI.Dashboard


TBITemplate.FindLayout(String) Method

Summary

Represents method FindLayout(String).

Namespace: BI.Dashboard
Syntax
Delphi
public
 function FindLayout(const ALayout:String):TLayoutItem;

Parameters

ALayout
Type: String

Return Value

Type: TLayoutItem

See Also

Reference

  • TBITemplate
  • BI.Dashboard


TBITemplate.Generate(TRender,TDashboard,String,String) Method

Summary

Represents method Generate(TRender,TDashboard,String,String).

Namespace: BI.Dashboard
Syntax
Delphi
public
 procedure Generate(const ARender:TRender; const ADashboard:TDashboard;
 const ALayout:String='';
 const AParams:String='');

Parameters

ARender
Type: TRender

ADashboard
Type: TDashboard

ALayout
Type: String

AParams
Type: String

See Also

Reference

  • TBITemplate
  • BI.Dashboard


TBITemplate.GetItem(String) Method

Summary

Represents method GetItem(String).

Namespace: BI.Dashboard
Syntax
Delphi
protected
 function GetItem(const AName:String):TDataItem;

Parameters

AName
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TBITemplate
  • BI.Dashboard


TBITemplate.GetMasterDetail(TDataItem,TInteger) Method

Summary

Represents method GetMasterDetail(TDataItem,TInteger).

Namespace: BI.Dashboard
Syntax
Delphi
public
 class function GetMasterDetail(const AData:TDataItem; const AIndex:TInteger):TCursorIndex;

Parameters

AData
Type: TDataItem

AIndex
Type: System.Void

Return Value

Type: TCursorIndex

See Also

Reference

  • TBITemplate
  • BI.Dashboard


TBITemplate.Loaded Method

Summary

Represents method Loaded.

Namespace: BI.Dashboard
Syntax
Delphi
protected
 procedure Loaded; override;
See Also

Reference

  • TBITemplate
  • BI.Dashboard


TBITemplate.NewOwner Method

Summary

Represents method NewOwner.

Namespace: BI.Dashboard
Syntax
Delphi
protected
 function NewOwner:TComponent;

Return Value

Type: TComponent

See Also

Reference

  • TBITemplate
  • BI.Dashboard


TBITemplate.NewQuery(TVisualData,String) Method

Summary

Represents method NewQuery(TVisualData,String).

Namespace: BI.Dashboard
Syntax
Delphi
public
 function NewQuery(const ADest:TVisualData; const SQL:String):TBIQuery;

Parameters

ADest
Type: TVisualData

SQL
Type: String

Return Value

Type: TBIQuery

See Also

Reference

  • TBITemplate
  • BI.Dashboard


TBITemplate.PanelData(TBIPanel) Method

Summary

Represents method PanelData(TBIPanel).

Namespace: BI.Dashboard
Syntax
Delphi
protected
 function PanelData(const APanel:TBIPanel):TDataItem;

Parameters

APanel
Type: TBIPanel

Return Value

Type: TDataItem

See Also

Reference

  • TBITemplate
  • BI.Dashboard


TBITemplate Fields

Fields
Name | Description
Root | Represents field Root.
Top


TBITemplate.Root Field

Summary

Represents field Root.

Namespace: BI.Dashboard
Syntax
Delphi
public
 class
 var Root : String;

Field Value

Type: String

See Also

Reference

  • TBITemplate
  • BI.Dashboard


TChangeListener Class

Summary

Represents type TChangeListener.

Namespace: BI.Dashboard
Inheritance Hierarchy
TObject
BI.Dashboard.TChangeListener
Syntax
Delphi
type
 TChangeListener=class
 end;

The TChangeListener type exposes the following members.

Properties
Show:
Name | Description
Name | Represents property Name.
Source | Represents property Source.
Top
Methods
Show:
Name | Description
Changed(TExpression) | Represents method Changed(TExpression).
Top
See Also

Reference

  • BI.Dashboard


TChangeListener Properties

Properties
Name | Description
Name | Represents property Name.
Source | Represents property Source.
Top


TChangeListener.Name Property

Summary

Represents property Name.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Name:String read FName;

Property Value

Type: String

See Also

Reference

  • TChangeListener
  • BI.Dashboard


TChangeListener.Source Property

Summary

Represents property Source.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Source:TObject read FSource;

Property Value

Type: TObject

See Also

Reference

  • TChangeListener
  • BI.Dashboard


TChangeListener Methods

Methods
Name | Description
Changed(TExpression) | Represents method Changed(TExpression).
Top


TChangeListener.Changed(TExpression) Method

Summary

Represents method Changed(TExpression).

Namespace: BI.Dashboard
Syntax
Delphi
public
 procedure Changed(const AValue:TExpression);

Parameters

AValue
Type: TExpression

See Also

Reference

  • TChangeListener
  • BI.Dashboard


TComponentAccess Class

Summary

Represents type TComponentAccess.

Namespace: BI.Dashboard
Inheritance Hierarchy
TComponent
BI.Dashboard.TComponentAccess
Syntax
Delphi
type
 TComponentAccess=class(TComponent);
See Also

Reference

  • BI.Dashboard


TCustomBIPanel Class

Summary

Represents type TCustomBIPanel.

Namespace: BI.Dashboard
Inheritance Hierarchy
TCollectionItem
BI.Dashboard.TBaseItem
BI.Dashboard.TCustomBIPanel
BI.Dashboard.TBIPanel
BI.Dashboard.TDashboard
BI.Dashboard.TDashboardItem
Syntax
Delphi
type
 TCustomBIPanel=class(TBaseItem)
 end;

The TCustomBIPanel type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TCustomBIPanel class.
Destroy | Represents the destructor of the TCustomBIPanel class.
Top
Properties
Show:
Name | Description
Back | Represents property Back.
Data | Represents property Data.
Display | Represents property Display.
Font | Represents property Font.
Height | Represents property Height.
Key | Represents property Key.
Kind | Represents property Kind.
Source | Represents property Source.
Target | Represents property Target.
Title | Represents property Title.
URL | Represents property URL.
VisualData | Represents property VisualData.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
UsesVariable(TChangeListener) | Represents method UsesVariable(TChangeListener). (Overrides TBaseItem.UsesVariable(TChangeListener).)
Top
See Also

Reference

  • BI.Dashboard


TCustomBIPanel Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TCustomBIPanel class.
Destroy | Represents the destructor of the TCustomBIPanel class.
Top


TCustomBIPanel.Create(TCollection) Constructor

Summary

Initializes a new instance of the TCustomBIPanel class.

Namespace: BI.Dashboard
Syntax
Delphi
public
 Constructor Create(Collection:TCollection); override;

Parameters

Collection
Type: TCollection

See Also

Reference

  • TCustomBIPanel
  • BI.Dashboard


TCustomBIPanel.Destroy Destructor

Summary

Represents the destructor of the TCustomBIPanel class.

Namespace: BI.Dashboard
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TCustomBIPanel
  • BI.Dashboard


TCustomBIPanel Properties

Properties
Name | Description
Back | Represents property Back.
Data | Represents property Data.
Display | Represents property Display.
Font | Represents property Font.
Height | Represents property Height.
Key | Represents property Key.
Kind | Represents property Kind.
Source | Represents property Source.
Target | Represents property Target.
Title | Represents property Title.
URL | Represents property URL.
VisualData | Represents property VisualData.
Width | Represents property Width.
Top


TCustomBIPanel.Back Property

Summary

Represents property Back.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Back:TAlphaColor read FBack write SetBack default TAlphaColors.Null;

Property Value

Type: TAlphaColor

See Also

Reference

  • TCustomBIPanel
  • BI.Dashboard


TCustomBIPanel.Data Property

Summary

Represents property Data.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Data:String read GetData write SetData;

Property Value

Type: String

See Also

Reference

  • TCustomBIPanel
  • BI.Dashboard


TCustomBIPanel.Display Property

Summary

Represents property Display.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Display:String read FDisplay write FDisplay;

Property Value

Type: String

See Also

Reference

  • TCustomBIPanel
  • BI.Dashboard


TCustomBIPanel.Font Property

Summary

Represents property Font.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Font:TBIFont read FFont write SetFont;

Property Value

Type: TBIFont

See Also

Reference

  • TCustomBIPanel
  • BI.Dashboard


TCustomBIPanel.Height Property

Summary

Represents property Height.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Height:TBICoordinate read FHeight write SetHeight;

Property Value

Type: TBICoordinate

See Also

Reference

  • TCustomBIPanel
  • BI.Dashboard


TCustomBIPanel.Key Property

Summary

Represents property Key.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Key:String read FKey write FKey;

Property Value

Type: String

See Also

Reference

  • TCustomBIPanel
  • BI.Dashboard


TCustomBIPanel.Kind Property

Summary

Represents property Kind.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Kind:TPanelKind read FKind write SetKind default TPanelKind.Automatic;

Property Value

Type: TPanelKind

See Also

Reference

  • TCustomBIPanel
  • BI.Dashboard


TCustomBIPanel.Source Property

Summary

Represents property Source.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Source:String read FSource write FSource;

Property Value

Type: String

See Also

Reference

  • TCustomBIPanel
  • BI.Dashboard


TCustomBIPanel.Target Property

Summary

Represents property Target.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Target:String read FTarget write SetTarget;

Property Value

Type: String

See Also

Reference

  • TCustomBIPanel
  • BI.Dashboard


TCustomBIPanel.Title Property

Summary

Represents property Title.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Title:String read FTitle write FTitle;

Property Value

Type: String

See Also

Reference

  • TCustomBIPanel
  • BI.Dashboard


TCustomBIPanel.URL Property

Summary

Represents property URL.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property URL:String read FURL write FURL;

Property Value

Type: String

See Also

Reference

  • TCustomBIPanel
  • BI.Dashboard


TCustomBIPanel.VisualData Property

Summary

Represents property VisualData.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property VisualData:TVisualData read IData write SetVisualData;

Property Value

Type: TVisualData

See Also

Reference

  • TCustomBIPanel
  • BI.Dashboard


TCustomBIPanel.Width Property

Summary

Represents property Width.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Width:TBICoordinate read FWidth write SetWidth;

Property Value

Type: TBICoordinate

See Also

Reference

  • TCustomBIPanel
  • BI.Dashboard


TCustomBIPanel Methods

Methods
Name | Description
UsesVariable(TChangeListener) | Represents method UsesVariable(TChangeListener). (Overrides TBaseItem.UsesVariable(TChangeListener).)
Top


TCustomBIPanel.UsesVariable(TChangeListener) Method

Summary

Represents method UsesVariable(TChangeListener).

Namespace: BI.Dashboard
Syntax
Delphi
public
 function UsesVariable(const Sender:TChangeListener):Boolean; override;

Parameters

Sender
Type: TChangeListener

Return Value

Type: Boolean

Overrides

TBaseItem.UsesVariable(TChangeListener)
See Also

Reference

  • TCustomBIPanel
  • BI.Dashboard


TDashboard Class

Summary

Represents type TDashboard.

Namespace: BI.Dashboard
Inheritance Hierarchy
TCollectionItem
BI.Dashboard.TBaseItem
BI.Dashboard.TCustomBIPanel
BI.Dashboard.TDashboard
Syntax
Delphi
type
 TDashboard=class(TCustomBIPanel)
 end;

The TDashboard type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TDashboard class. (Overrides TCustomBIPanel.Create(TCollection).)
Destroy | Represents the destructor of the TDashboard class. (Overrides TCustomBIPanel.Destroy.)
Top
Properties
Show:
Name | Description
Back | Represents property Back.
Height | Represents property Height.
Items | Represents property Items.
Item[Integer] | Represents property Item[Integer].
Layout | Represents property Layout.
LayoutItem | Represents property LayoutItem.
Padding | Represents property Padding.
Splitters | Represents property Splitters.
Titles | Represents property Titles.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
Find(TBIPanel) | Represents method Find(TBIPanel).
IndexOfPanel(String) | Represents method IndexOfPanel(String).
Top
Fields
Show:
Name | Description
FLayoutItem | Represents field FLayoutItem.
Top
See Also

Reference

  • BI.Dashboard


TDashboard Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TDashboard class. (Overrides TCustomBIPanel.Create(TCollection).)
Destroy | Represents the destructor of the TDashboard class. (Overrides TCustomBIPanel.Destroy.)
Top


TDashboard.Create(TCollection) Constructor

Summary

Initializes a new instance of the TDashboard class.

Namespace: BI.Dashboard
Syntax
Delphi
public
 Constructor Create(ACollection:TCollection); override;

Parameters

ACollection
Type: TCollection

Overrides

TCustomBIPanel.Create(TCollection)
See Also

Reference

  • TDashboard
  • BI.Dashboard


TDashboard.Destroy Destructor

Summary

Represents the destructor of the TDashboard class.

Namespace: BI.Dashboard
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TCustomBIPanel.Destroy
See Also

Reference

  • TDashboard
  • BI.Dashboard


TDashboard Properties

Properties
Name | Description
Back | Represents property Back.
Height | Represents property Height.
Items | Represents property Items.
Item[Integer] | Represents property Item[Integer].
Layout | Represents property Layout.
LayoutItem | Represents property LayoutItem.
Padding | Represents property Padding.
Splitters | Represents property Splitters.
Titles | Represents property Titles.
Width | Represents property Width.
Top


TDashboard.Back Property

Summary

Represents property Back.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Back;

Property Value

Type: Void

See Also

Reference

  • TDashboard
  • BI.Dashboard


TDashboard.Height Property

Summary

Represents property Height.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Height;

Property Value

Type: Void

See Also

Reference

  • TDashboard
  • BI.Dashboard


TDashboard.Items Property

Summary

Represents property Items.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Items:TDashboardItems read FItems write SetItems;

Property Value

Type: TDashboardItems

See Also

Reference

  • TDashboard
  • BI.Dashboard


TDashboard.Item[Integer] Property

Summary

Represents property Item[Integer].

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Item[const AIndex:Integer]:TDashboardItem read Get write Put; default;

Parameters

AIndex
Type: Integer

Property Value

Type: TDashboardItem

See Also

Reference

  • TDashboard
  • BI.Dashboard


TDashboard.Layout Property

Summary

Represents property Layout.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Layout:String read FLayout write SetLayout;

Property Value

Type: String

See Also

Reference

  • TDashboard
  • BI.Dashboard


TDashboard.LayoutItem Property

Summary

Represents property LayoutItem.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property LayoutItem:TLayoutItem read FLayoutItem;

Property Value

Type: TLayoutItem

See Also

Reference

  • TDashboard
  • BI.Dashboard


TDashboard.Padding Property

Summary

Represents property Padding.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Padding:Single read FPadding write FPadding;

Property Value

Type: Single

See Also

Reference

  • TDashboard
  • BI.Dashboard


TDashboard.Splitters Property

Summary

Represents property Splitters.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Splitters:Boolean read FSplitters write FSplitters default True;

Property Value

Type: Boolean

See Also

Reference

  • TDashboard
  • BI.Dashboard


TDashboard.Titles Property

Summary

Represents property Titles.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Titles:Boolean read FTitles write FTitles default True;

Property Value

Type: Boolean

See Also

Reference

  • TDashboard
  • BI.Dashboard


TDashboard.Width Property

Summary

Represents property Width.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Width;

Property Value

Type: Void

See Also

Reference

  • TDashboard
  • BI.Dashboard


TDashboard Methods

Methods
Name | Description
Find(TBIPanel) | Represents method Find(TBIPanel).
IndexOfPanel(String) | Represents method IndexOfPanel(String).
Top


TDashboard.Find(TBIPanel) Method

Summary

Represents method Find(TBIPanel).

Namespace: BI.Dashboard
Syntax
Delphi
public
 function Find(const APanel:TBIPanel):TDashboardItem;

Parameters

APanel
Type: TBIPanel

Return Value

Type: TDashboardItem

See Also

Reference

  • TDashboard
  • BI.Dashboard


TDashboard.IndexOfPanel(String) Method

Summary

Represents method IndexOfPanel(String).

Namespace: BI.Dashboard
Syntax
Delphi
public
 function IndexOfPanel(const AName:String):Integer;

Parameters

AName
Type: String

Return Value

Type: Integer

See Also

Reference

  • TDashboard
  • BI.Dashboard


TDashboard Fields

Fields
Name | Description
FLayoutItem | Represents field FLayoutItem.
Top


TDashboard.FLayoutItem Field

Summary

Represents field FLayoutItem.

Namespace: BI.Dashboard
Syntax
Delphi
protected
 FLayoutItem : TLayoutItem;

Field Value

Type: TLayoutItem

See Also

Reference

  • TDashboard
  • BI.Dashboard


TDashboardItem Class

Summary

Represents type TDashboardItem.

Namespace: BI.Dashboard
Inheritance Hierarchy
TCollectionItem
BI.Dashboard.TBaseItem
BI.Dashboard.TCustomBIPanel
BI.Dashboard.TDashboardItem
BI.Dashboard.HTML.Chart.TDashboardItemAccess
BI.Dashboard.HTML.TDashboardItemAccess
FMXBI.Dashboard.Chart.TDashboardItemAccess
FMXBI.Dashboard.TDashboardItemAccess
VCLBI.Dashboard.Chart.TDashboardItemAccess
VCLBI.Dashboard.TDashboardItemAccess
Syntax
Delphi
type
 TDashboardItem=class(TCustomBIPanel)
 end;

The TDashboardItem type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TDashboardItem class. (Overrides TCustomBIPanel.Create(TCollection).)
Top
Properties
Show:
Name | Description
Colorize | Represents property Colorize.
CSSClass | Represents property CSSClass.
Dashboard | Represents property Dashboard.
Detail | Represents property Detail.
Height | Represents property Height.
Horizontal | Represents property Horizontal.
Kind | Represents property Kind.
Master | Represents property Master.
Max | Represents property Max.
Min | Represents property Min.
Navigator | Represents property Navigator.
Padding | Represents property Padding.
Panel | Represents property Panel.
PanelItem | Represents property PanelItem.
Position | Represents property Position.
RealPosition | Represents property RealPosition.
Selected | Represents property Selected.
Target | Represents property Target.
Text | Represents property Text.
Title | Represents property Title.
URL | Represents property URL.
Visible | Represents property Visible.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
CalcDisplay | Represents method CalcDisplay.
CalcKind | Represents method CalcKind.
CountOfData | Represents method CountOfData.
GetSelected(Integer) | Represents method GetSelected(Integer).
GetSelectedDisplay(Integer) | Represents method GetSelectedDisplay(Integer).
SelectedIndex | Represents method SelectedIndex.
UsesVariable(TChangeListener) | Represents method UsesVariable(TChangeListener). (Overrides TCustomBIPanel.UsesVariable(TChangeListener).)
Top
Fields
Show:
Name | Description
Format | Represents field Format.
Minify | Represents field Minify.
Top
See Also

Reference

  • BI.Dashboard


TDashboardItem Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TDashboardItem class. (Overrides TCustomBIPanel.Create(TCollection).)
Top


TDashboardItem.Create(TCollection) Constructor

Summary

Initializes a new instance of the TDashboardItem class.

Namespace: BI.Dashboard
Syntax
Delphi
public
 Constructor Create(Collection:TCollection); override;

Parameters

Collection
Type: TCollection

Overrides

TCustomBIPanel.Create(TCollection)
See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem Properties

Properties
Name | Description
Colorize | Represents property Colorize.
CSSClass | Represents property CSSClass.
Dashboard | Represents property Dashboard.
Detail | Represents property Detail.
Height | Represents property Height.
Horizontal | Represents property Horizontal.
Kind | Represents property Kind.
Master | Represents property Master.
Max | Represents property Max.
Min | Represents property Min.
Navigator | Represents property Navigator.
Padding | Represents property Padding.
Panel | Represents property Panel.
PanelItem | Represents property PanelItem.
Position | Represents property Position.
RealPosition | Represents property RealPosition.
Selected | Represents property Selected.
Target | Represents property Target.
Text | Represents property Text.
Title | Represents property Title.
URL | Represents property URL.
Visible | Represents property Visible.
Width | Represents property Width.
Top


TDashboardItem.Colorize Property

Summary

Represents property Colorize.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Colorize:Boolean read FColorize write FColorize default False;

Property Value

Type: Boolean

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.CSSClass Property

Summary

Represents property CSSClass.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property CSSClass:String read FCSSClass write FCSSClass;

Property Value

Type: String

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.Dashboard Property

Summary

Represents property Dashboard.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Dashboard:TDashboard read GetDashboard;

Property Value

Type: TDashboard

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.Detail Property

Summary

Represents property Detail.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Detail:TDataItem read FDetail;

Property Value

Type: TDataItem

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.Height Property

Summary

Represents property Height.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Height;

Property Value

Type: Void

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.Horizontal Property

Summary

Represents property Horizontal.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Horizontal:Boolean read FHorizontal write FHorizontal default False;

Property Value

Type: Boolean

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.Kind Property

Summary

Represents property Kind.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Kind;

Property Value

Type: Void

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.Master Property

Summary

Represents property Master.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Master:TDataItem read FMaster;

Property Value

Type: TDataItem

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.Max Property

Summary

Represents property Max.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Max:Single read FMax write FMax;

Property Value

Type: Single

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.Min Property

Summary

Represents property Min.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Min:Single read FMin write FMin;

Property Value

Type: Single

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.Navigator Property

Summary

Represents property Navigator.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Navigator:Boolean read FNavigator write FNavigator default False;

Property Value

Type: Boolean

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.Padding Property

Summary

Represents property Padding.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Padding:Single read FPadding write FPadding;

Property Value

Type: Single

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.Panel Property

Summary

Represents property Panel.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Panel:String read GetPanel write SetPanel;

Property Value

Type: String

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.PanelItem Property

Summary

Represents property PanelItem.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property PanelItem:TCustomBIPanel read FPanel write FPanel;

Property Value

Type: TCustomBIPanel

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.Position Property

Summary

Represents property Position.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Position:String read FPosition write FPosition;

Property Value

Type: String

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.RealPosition Property

Summary

Represents property RealPosition.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property RealPosition:String read IPosition;

Property Value

Type: String

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.Selected Property

Summary

Represents property Selected.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Selected:String read FSelected write FSelected;

Property Value

Type: String

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.Target Property

Summary

Represents property Target.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Target;

Property Value

Type: Void

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.Text Property

Summary

Represents property Text.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Text:String read GetText write FText;

Property Value

Type: String

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.Title Property

Summary

Represents property Title.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Title;

Property Value

Type: Void

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.URL Property

Summary

Represents property URL.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property URL;

Property Value

Type: Void

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.Visible Property

Summary

Represents property Visible.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Visible:Boolean read FVisible write SetVisible default True;

Property Value

Type: Boolean

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.Width Property

Summary

Represents property Width.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Width;

Property Value

Type: Void

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem Methods

Methods
Name | Description
CalcDisplay | Represents method CalcDisplay.
CalcKind | Represents method CalcKind.
CountOfData | Represents method CountOfData.
GetSelected(Integer) | Represents method GetSelected(Integer).
GetSelectedDisplay(Integer) | Represents method GetSelectedDisplay(Integer).
SelectedIndex | Represents method SelectedIndex.
UsesVariable(TChangeListener) | Represents method UsesVariable(TChangeListener). (Overrides TCustomBIPanel.UsesVariable(TChangeListener).)
Top


TDashboardItem.CalcDisplay Method

Summary

Represents method CalcDisplay.

Namespace: BI.Dashboard
Syntax
Delphi
public
 function CalcDisplay:String;

Return Value

Type: String

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.CalcKind Method

Summary

Represents method CalcKind.

Namespace: BI.Dashboard
Syntax
Delphi
public
 function CalcKind:TPanelKind;

Return Value

Type: TPanelKind

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.CountOfData Method

Summary

Represents method CountOfData.

Namespace: BI.Dashboard
Syntax
Delphi
public
 function CountOfData:TInteger;

Return Value

Type: TInteger

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.GetSelected(Integer) Method

Summary

Represents method GetSelected(Integer).

Namespace: BI.Dashboard
Syntax
Delphi
public
 function GetSelected(const AIndex:Integer):String;

Parameters

AIndex
Type: Integer

Return Value

Type: String

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.GetSelectedDisplay(Integer) Method

Summary

Represents method GetSelectedDisplay(Integer).

Namespace: BI.Dashboard
Syntax
Delphi
public
 function GetSelectedDisplay(const AIndex:Integer): String;

Parameters

AIndex
Type: Integer

Return Value

Type: String

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.SelectedIndex Method

Summary

Represents method SelectedIndex.

Namespace: BI.Dashboard
Syntax
Delphi
public
 function SelectedIndex:Integer;

Return Value

Type: Integer

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.UsesVariable(TChangeListener) Method

Summary

Represents method UsesVariable(TChangeListener).

Namespace: BI.Dashboard
Syntax
Delphi
public
 function UsesVariable(const Sender:TChangeListener):Boolean; override;

Parameters

Sender
Type: TChangeListener

Return Value

Type: Boolean

Overrides

TCustomBIPanel.UsesVariable(TChangeListener)
See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem Fields

Fields
Name | Description
Format | Represents field Format.
Minify | Represents field Minify.
Top


TDashboardItem.Format Field

Summary

Represents field Format.

Namespace: BI.Dashboard
Syntax
Delphi
protected
 Format : String;

Field Value

Type: String

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItem.Minify Field

Summary

Represents field Minify.

Namespace: BI.Dashboard
Syntax
Delphi
protected
 Minify : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TDashboardItem
  • BI.Dashboard


TDashboardItems Class

Summary

Represents type TDashboardItems.

Namespace: BI.Dashboard
Inheritance Hierarchy
TOwnedCollection
BI.Dashboard.TDashboardItems
Syntax
Delphi
type
 TDashboardItems=class(TOwnedCollection)
 end;

The TDashboardItems type exposes the following members.

Properties
Show:
Name | Description
Item[Integer] | Represents property Item[Integer].
Top
Methods
Show:
Name | Description
Add(TBIPanel) | Overloaded. Represents method Add(TBIPanel).
IndexOf(String) | Represents method IndexOf(String).
Top
See Also

Reference

  • BI.Dashboard


TDashboardItems Properties

Properties
Name | Description
Item[Integer] | Represents property Item[Integer].
Top


TDashboardItems.Item[Integer] Property

Summary

Represents property Item[Integer].

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Item[const Index:Integer]:TDashboardItem read Get write Put; default;

Parameters

Index
Type: Integer

Property Value

Type: TDashboardItem

See Also

Reference

  • TDashboardItems
  • BI.Dashboard


TDashboardItems Methods

Methods
Name | Description
Add(TBIPanel) | Overloaded. Represents method Add(TBIPanel).
IndexOf(String) | Represents method IndexOf(String).
Top


TDashboardItems.Add(TBIPanel) Method

Summary

Represents method Add(TBIPanel).

Namespace: BI.Dashboard
Syntax
Delphi
public
 function Add(const APanel:TBIPanel):TDashboardItem; overload;

Parameters

APanel
Type: TBIPanel

Return Value

Type: TDashboardItem

See Also

Reference

  • TDashboardItems
  • BI.Dashboard


TDashboardItems.IndexOf(String) Method

Summary

Represents method IndexOf(String).

Namespace: BI.Dashboard
Syntax
Delphi
public
 function IndexOf(const AName:String):Integer;

Parameters

AName
Type: String

Return Value

Type: Integer

See Also

Reference

  • TDashboardItems
  • BI.Dashboard


TDashboards Class

Summary

Represents type TDashboards.

Namespace: BI.Dashboard
Inheritance Hierarchy
TOwnedCollection
BI.Dashboard.TDashboards
Syntax
Delphi
type
 TDashboards=class(TOwnedCollection)
 end;

The TDashboards type exposes the following members.

Properties
Show:
Name | Description
Item[Integer] | Represents property Item[Integer].
Top
Methods
Show:
Name | Description
Add | Represents method Add.
Find(String) | Represents method Find(String).
IndexOf(String) | Represents method IndexOf(String).
Top
See Also

Reference

  • BI.Dashboard


TDashboards Properties

Properties
Name | Description
Item[Integer] | Represents property Item[Integer].
Top


TDashboards.Item[Integer] Property

Summary

Represents property Item[Integer].

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Item[const Index:Integer]:TDashboard read Get write Put; default;

Parameters

Index
Type: Integer

Property Value

Type: TDashboard

See Also

Reference

  • TDashboards
  • BI.Dashboard


TDashboards Methods

Methods
Name | Description
Add | Represents method Add.
Find(String) | Represents method Find(String).
IndexOf(String) | Represents method IndexOf(String).
Top


TDashboards.Add Method

Summary

Represents method Add.

Namespace: BI.Dashboard
Syntax
Delphi
public
 function Add:TDashboard;

Return Value

Type: TDashboard

See Also

Reference

  • TDashboards
  • BI.Dashboard


TDashboards.Find(String) Method

Summary

Represents method Find(String).

Namespace: BI.Dashboard
Syntax
Delphi
public
 function Find(const AName:String):TDashboard;

Parameters

AName
Type: String

Return Value

Type: TDashboard

See Also

Reference

  • TDashboards
  • BI.Dashboard


TDashboards.IndexOf(String) Method

Summary

Represents method IndexOf(String).

Namespace: BI.Dashboard
Syntax
Delphi
public
 function IndexOf(const AName:String):Integer;

Parameters

AName
Type: String

Return Value

Type: Integer

See Also

Reference

  • TDashboards
  • BI.Dashboard


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.Dashboard
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Dashboard.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.Dashboard


TListeners Class

Summary

Represents type TListeners.

Namespace: BI.Dashboard
Inheritance Hierarchy
TList
BI.Dashboard.TListeners
Syntax
Delphi
type
 TListeners=class(TList<TChangeListener>)
 end;

The TListeners type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TListeners class.
Top
Methods
Show:
Name | Description
Changed(String,TExpression) | Represents method Changed(String,TExpression).
Top
See Also

Reference

  • BI.Dashboard


TListeners Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TListeners class.
Top


TListeners.Destroy Destructor

Summary

Represents the destructor of the TListeners class.

Namespace: BI.Dashboard
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TListeners
  • BI.Dashboard


TListeners Methods

Methods
Name | Description
Changed(String,TExpression) | Represents method Changed(String,TExpression).
Top


TListeners.Changed(String,TExpression) Method

Summary

Represents method Changed(String,TExpression).

Namespace: BI.Dashboard
Syntax
Delphi
public
 procedure Changed(const AName:String; const AValue:TExpression);

Parameters

AName
Type: String

AValue
Type: TExpression

See Also

Reference

  • TListeners
  • BI.Dashboard


TPanelKindHelper Class Helper

Summary

Represents type TPanelKindHelper.

Namespace: BI.Dashboard
Syntax
Delphi
type
 TPanelKindHelper=record helper for TPanelKind
 end;
Methods
Name | Description
From(String) | Represents method From(String).
ToString | Represents method ToString.
Top
See Also

Reference

  • BI.Dashboard


TPanelKindHelper Methods

Methods
Name | Description
From(String) | Represents method From(String).
ToString | Represents method ToString.
Top


TPanelKindHelper.From(String) Method

Summary

Represents method From(String).

Namespace: BI.Dashboard
Syntax
Delphi
public
 class function From(const S:String):TPanelKind; static;

Parameters

S
Type: String

Return Value

Type: TPanelKind

See Also

Reference

  • TPanelKindHelper
  • BI.Dashboard


TPanelKindHelper.ToString Method

Summary

Represents method ToString.

Namespace: BI.Dashboard
Syntax
Delphi
public
 function ToString:String;

Return Value

Type: String

See Also

Reference

  • TPanelKindHelper
  • BI.Dashboard


TPanels Class

Summary

Represents type TPanels.

Namespace: BI.Dashboard
Inheritance Hierarchy
TOwnedCollection
BI.Dashboard.TPanels
Syntax
Delphi
type
 TPanels=class(TOwnedCollection)
 end;

The TPanels type exposes the following members.

Properties
Show:
Name | Description
Item[Integer] | Represents property Item[Integer].
Top
Methods
Show:
Name | Description
Add(TVisualData) | Represents method Add(TVisualData).
Find(String) | Represents method Find(String).
IndexOf(String) | Represents method IndexOf(String).
Top
See Also

Reference

  • BI.Dashboard


TPanels Properties

Properties
Name | Description
Item[Integer] | Represents property Item[Integer].
Top


TPanels.Item[Integer] Property

Summary

Represents property Item[Integer].

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Item[const Index:Integer]:TBIPanel read Get write Put; default;

Parameters

Index
Type: Integer

Property Value

Type: TBIPanel

See Also

Reference

  • TPanels
  • BI.Dashboard


TPanels Methods

Methods
Name | Description
Add(TVisualData) | Represents method Add(TVisualData).
Find(String) | Represents method Find(String).
IndexOf(String) | Represents method IndexOf(String).
Top


TPanels.Add(TVisualData) Method

Summary

Represents method Add(TVisualData).

Namespace: BI.Dashboard
Syntax
Delphi
public
 function Add(const AData:TVisualData):TBIPanel;

Parameters

AData
Type: TVisualData

Return Value

Type: TBIPanel

See Also

Reference

  • TPanels
  • BI.Dashboard


TPanels.Find(String) Method

Summary

Represents method Find(String).

Namespace: BI.Dashboard
Syntax
Delphi
public
 function Find(const AName:String):TBIPanel;

Parameters

AName
Type: String

Return Value

Type: TBIPanel

See Also

Reference

  • TPanels
  • BI.Dashboard


TPanels.IndexOf(String) Method

Summary

Represents method IndexOf(String).

Namespace: BI.Dashboard
Syntax
Delphi
public
 function IndexOf(const AName:String):Integer;

Parameters

AName
Type: String

Return Value

Type: Integer

See Also

Reference

  • TPanels
  • BI.Dashboard


TProviderAccess Class

Summary

Represents type TProviderAccess.

Namespace: BI.Dashboard
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Dashboard.TProviderAccess
Syntax
Delphi
type
 TProviderAccess=class(TDataProvider);
See Also

Reference

  • BI.Dashboard


TRender Class

Summary

Represents type TRender.

Namespace: BI.Dashboard
Inheritance Hierarchy
TObject
BI.Dashboard.TRender
BI.Dashboard.HTML.THTMLRender
BI.Dashboard.HTML.TRenderAccess
FMXBI.Dashboard.TRenderAccess
FMXBI.Dashboard.TScreenRender
VCLBI.Dashboard.TRenderAccess
VCLBI.Dashboard.TScreenRender
Syntax
Delphi
type
 TRender=class
 end;

The TRender type exposes the following members.

Methods
Show:
Name | Description
AddItems(TStrings,TDataItem,String) | Represents method AddItems(TStrings,TDataItem,String).
AddItemSeparator(Integer,TPanelKind) | Represents method AddItemSeparator(Integer,TPanelKind).
AddListener(String,TObject) | Represents method AddListener(String,TObject).
ChangeSelected(TDashboardItem,Integer) | Represents method ChangeSelected(TDashboardItem,Integer).
Clear | Represents method Clear.
DataAsString(TDataItem) | Represents method DataAsString(TDataItem).
Emit(TDashboard,Integer,String) | Overloaded. Represents method Emit(TDashboard,Integer,String).
FindRootLayout(String) | Represents method FindRootLayout(String).
Finish | Represents method Finish.
GetColorizers(TDashboardItem) | Represents method GetColorizers(TDashboardItem).
GetDisplayData(TDataItem,String) | Represents method GetDisplayData(TDataItem,String).
Init(TDashboard,String,TStrings) | Represents method Init(TDashboard,String,TStrings).
TopRender | Represents method TopRender.
Top
Fields
Show:
Name | Description
FVariables | Represents field FVariables.
FVisual | Represents field FVisual.
ILayout | Represents field ILayout.
ILayoutName | Represents field ILayoutName.
IParent | Represents field IParent.
Top
See Also

Reference

  • BI.Dashboard


TRender Methods

Methods
Name | Description
AddItems(TStrings,TDataItem,String) | Represents method AddItems(TStrings,TDataItem,String).
AddItemSeparator(Integer,TPanelKind) | Represents method AddItemSeparator(Integer,TPanelKind).
AddListener(String,TObject) | Represents method AddListener(String,TObject).
ChangeSelected(TDashboardItem,Integer) | Represents method ChangeSelected(TDashboardItem,Integer).
Clear | Represents method Clear.
DataAsString(TDataItem) | Represents method DataAsString(TDataItem).
Emit(TDashboard,Integer,String) | Overloaded. Represents method Emit(TDashboard,Integer,String).
FindRootLayout(String) | Represents method FindRootLayout(String).
Finish | Represents method Finish.
GetColorizers(TDashboardItem) | Represents method GetColorizers(TDashboardItem).
GetDisplayData(TDataItem,String) | Represents method GetDisplayData(TDataItem,String).
Init(TDashboard,String,TStrings) | Represents method Init(TDashboard,String,TStrings).
TopRender | Represents method TopRender.
Top


TRender.AddItems(TStrings,TDataItem,String) Method

Summary

Represents method AddItems(TStrings,TDataItem,String).

Namespace: BI.Dashboard
Syntax
Delphi
protected
 class procedure AddItems(const AItems: TStrings; const AData:TDataItem;
 const ADisplay:String=''); static;

Parameters

AItems
Type: TStrings

AData
Type: TDataItem

ADisplay
Type: String

See Also

Reference

  • TRender
  • BI.Dashboard


TRender.AddItemSeparator(Integer,TPanelKind) Method

Summary

Represents method AddItemSeparator(Integer,TPanelKind).

Namespace: BI.Dashboard
Syntax
Delphi
protected
 procedure AddItemSeparator(const AIndex:Integer=-1; const AKind:TPanelKind=TPanelKind.Automatic); virtual;

Parameters

AIndex
Type: Integer

AKind
Type: TPanelKind

See Also

Reference

  • TRender
  • BI.Dashboard


TRender.AddListener(String,TObject) Method

Summary

Represents method AddListener(String,TObject).

Namespace: BI.Dashboard
Syntax
Delphi
protected
 procedure AddListener(const AName:String; const ASource:TObject); virtual; abstract;

Parameters

AName
Type: String

ASource
Type: TObject

See Also

Reference

  • TRender
  • BI.Dashboard


TRender.ChangeSelected(TDashboardItem,Integer) Method

Summary

Represents method ChangeSelected(TDashboardItem,Integer).

Namespace: BI.Dashboard
Syntax
Delphi
protected
 procedure ChangeSelected(const AItem:TDashboardItem; const AIndex:Integer);

Parameters

AItem
Type: TDashboardItem

AIndex
Type: Integer

See Also

Reference

  • TRender
  • BI.Dashboard


TRender.Clear Method

Summary

Represents method Clear.

Namespace: BI.Dashboard
Syntax
Delphi
public
 procedure Clear; virtual; abstract;
See Also

Reference

  • TRender
  • BI.Dashboard


TRender.DataAsString(TDataItem) Method

Summary

Represents method DataAsString(TDataItem).

Namespace: BI.Dashboard
Syntax
Delphi
protected
 class function DataAsString(const AData:TDataItem):String; static;

Parameters

AData
Type: TDataItem

Return Value

Type: String

See Also

Reference

  • TRender
  • BI.Dashboard


TRender.Emit(TDashboard,Integer,String) Method

Summary

Represents method Emit(TDashboard,Integer,String).

Namespace: BI.Dashboard
Syntax
Delphi
public
 procedure Emit(const ADashboard:TDashboard; const AItem:Integer; const APosition:String); overload; virtual;

Parameters

ADashboard
Type: TDashboard

AItem
Type: Integer

APosition
Type: String

See Also

Reference

  • TRender
  • BI.Dashboard


TRender.FindRootLayout(String) Method

Summary

Represents method FindRootLayout(String).

Namespace: BI.Dashboard
Syntax
Delphi
protected
 function FindRootLayout(const AName:String):TLayoutItem;

Parameters

AName
Type: String

Return Value

Type: TLayoutItem

See Also

Reference

  • TRender
  • BI.Dashboard


TRender.Finish Method

Summary

Represents method Finish.

Namespace: BI.Dashboard
Syntax
Delphi
public
 procedure Finish; virtual;
See Also

Reference

  • TRender
  • BI.Dashboard


TRender.GetColorizers(TDashboardItem) Method

Summary

Represents method GetColorizers(TDashboardItem).

Namespace: BI.Dashboard
Syntax
Delphi
protected
 function GetColorizers(const AItem:TDashboardItem):TDataColorizers;

Parameters

AItem
Type: TDashboardItem

Return Value

Type: TDataColorizers

See Also

Reference

  • TRender
  • BI.Dashboard


TRender.GetDisplayData(TDataItem,String) Method

Summary

Represents method GetDisplayData(TDataItem,String).

Namespace: BI.Dashboard
Syntax
Delphi
public
 class function GetDisplayData(const AData:TDataItem; const AName:String=''):TDataItem; static;

Parameters

AData
Type: TDataItem

AName
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TRender
  • BI.Dashboard


TRender.Init(TDashboard,String,TStrings) Method

Summary

Represents method Init(TDashboard,String,TStrings).

Namespace: BI.Dashboard
Syntax
Delphi
public
 procedure Init(const ADashboard:TDashboard; const ALayout:String='';
 const AParams:TStrings=nil); virtual;

Parameters

ADashboard
Type: TDashboard

ALayout
Type: String

AParams
Type: TStrings

See Also

Reference

  • TRender
  • BI.Dashboard


TRender.TopRender Method

Summary

Represents method TopRender.

Namespace: BI.Dashboard
Syntax
Delphi
protected
 function TopRender:TRender;

Return Value

Type: TRender

See Also

Reference

  • TRender
  • BI.Dashboard


TRender Fields

Fields
Name | Description
FVariables | Represents field FVariables.
FVisual | Represents field FVisual.
ILayout | Represents field ILayout.
ILayoutName | Represents field ILayoutName.
IParent | Represents field IParent.
Top


TRender.FVariables Field

Summary

Represents field FVariables.

Namespace: BI.Dashboard
Syntax
Delphi
protected
 FVariables : TVariables;

Field Value

Type: TVariables

See Also

Reference

  • TRender
  • BI.Dashboard


TRender.FVisual Field

Summary

Represents field FVisual.

Namespace: BI.Dashboard
Syntax
Delphi
protected
 FVisual : TBITemplate;

Field Value

Type: TBITemplate

See Also

Reference

  • TRender
  • BI.Dashboard


TRender.ILayout Field

Summary

Represents field ILayout.

Namespace: BI.Dashboard
Syntax
Delphi
protected
 ILayout : TLayoutItem;

Field Value

Type: TLayoutItem

See Also

Reference

  • TRender
  • BI.Dashboard


TRender.ILayoutName Field

Summary

Represents field ILayoutName.

Namespace: BI.Dashboard
Syntax
Delphi
protected
 ILayoutName : String;

Field Value

Type: String

See Also

Reference

  • TRender
  • BI.Dashboard


TRender.IParent Field

Summary

Represents field IParent.

Namespace: BI.Dashboard
Syntax
Delphi
protected
 IParent : TRender;

Field Value

Type: TRender

See Also

Reference

  • TRender
  • BI.Dashboard


TVariable Class

Summary

Represents type TVariable.

Namespace: BI.Dashboard
Inheritance Hierarchy
TObject
BI.Dashboard.TVariable
Syntax
Delphi
type
 TVariable=class
 end;

The TVariable type exposes the following members.

Properties
Show:
Name | Description
Value | Represents property Value.
Top
Fields
Show:
Name | Description
Listeners | Represents field Listeners.
Name | Represents field Name.
Top
See Also

Reference

  • BI.Dashboard


TVariable Properties

Properties
Name | Description
Value | Represents property Value.
Top


TVariable.Value Property

Summary

Represents property Value.

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Value:TExpression read FValue write SetValue;

Property Value

Type: TExpression

See Also

Reference

  • TVariable
  • BI.Dashboard


TVariable Fields

Fields
Name | Description
Listeners | Represents field Listeners.
Name | Represents field Name.
Top


TVariable.Listeners Field

Summary

Represents field Listeners.

Namespace: BI.Dashboard
Syntax
Delphi
public
 Listeners : TListeners;

Field Value

Type: TListeners

See Also

Reference

  • TVariable
  • BI.Dashboard


TVariable.Name Field

Summary

Represents field Name.

Namespace: BI.Dashboard
Syntax
Delphi
public
 Name : String;

Field Value

Type: String

See Also

Reference

  • TVariable
  • BI.Dashboard


TVariables Class

Summary

Represents type TVariables.

Namespace: BI.Dashboard
Inheritance Hierarchy
TObjectList
BI.Dashboard.TVariables
Syntax
Delphi
type
 TVariables=class(TObjectList<TVariable>)
 end;

The TVariables type exposes the following members.

Methods
Show:
Name | Description
Add(String,TExpression) | Represents method Add(String,TExpression).
AddListener(String,TObject,TChangeEvent) | Represents method AddListener(String,TObject,TChangeEvent).
Change(String,Boolean) | Overloaded. Represents method Change(String,Boolean).
Change(String,TExpression) | Overloaded. Represents method Change(String,TExpression).
IndexOf(String) | Represents method IndexOf(String).
Notify(TVariable,TCollectionNotification) | Represents method Notify(TVariable,TCollectionNotification).
TryAdd(String) | Represents method TryAdd(String).
Top
Fields
Show:
Name | Description
IMain | Represents field IMain.
Top
See Also

Reference

  • BI.Dashboard


TVariables Methods

Methods
Name | Description
Add(String,TExpression) | Represents method Add(String,TExpression).
AddListener(String,TObject,TChangeEvent) | Represents method AddListener(String,TObject,TChangeEvent).
Change(String,Boolean) | Overloaded. Represents method Change(String,Boolean).
Change(String,TExpression) | Overloaded. Represents method Change(String,TExpression).
IndexOf(String) | Represents method IndexOf(String).
Notify(TVariable,TCollectionNotification) | Represents method Notify(TVariable,TCollectionNotification).
TryAdd(String) | Represents method TryAdd(String).
Top


TVariables.Add(String,TExpression) Method

Summary

Represents method Add(String,TExpression).

Namespace: BI.Dashboard
Syntax
Delphi
public
 procedure Add(const AName:String; const AValue:TExpression);

Parameters

AName
Type: String

AValue
Type: TExpression

See Also

Reference

  • TVariables
  • BI.Dashboard


TVariables.AddListener(String,TObject,TChangeEvent) Method

Summary

Represents method AddListener(String,TObject,TChangeEvent).

Namespace: BI.Dashboard
Syntax
Delphi
public
 procedure AddListener(const AName:String; const ASource:TObject; const AOnChange:TChangeEvent);

Parameters

AName
Type: String

ASource
Type: TObject

AOnChange
Type: TChangeEvent

See Also

Reference

  • TVariables
  • BI.Dashboard


TVariables.Change(String,Boolean) Method

Summary

Represents method Change(String,Boolean).

Namespace: BI.Dashboard
Syntax
Delphi
public
 procedure Change(const AName:String; const AValue:Boolean); overload;

Parameters

AName
Type: String

AValue
Type: Boolean

See Also

Reference

  • TVariables
  • BI.Dashboard


TVariables.Change(String,TExpression) Method

Summary

Represents method Change(String,TExpression).

Namespace: BI.Dashboard
Syntax
Delphi
public
 procedure Change(const AName:String; const AValue:TExpression); overload;

Parameters

AName
Type: String

AValue
Type: TExpression

See Also

Reference

  • TVariables
  • BI.Dashboard


TVariables.IndexOf(String) Method

Summary

Represents method IndexOf(String).

Namespace: BI.Dashboard
Syntax
Delphi
public
 function IndexOf(const AName:String):Integer;

Parameters

AName
Type: String

Return Value

Type: Integer

See Also

Reference

  • TVariables
  • BI.Dashboard


TVariables.Notify(TVariable,TCollectionNotification) Method

Summary

Represents method Notify(TVariable,TCollectionNotification).

Namespace: BI.Dashboard
Syntax
Delphi
protected
 procedure Notify(const Item: TVariable; Action: TCollectionNotification); override;

Parameters

Item
Type: TVariable

Action
Type: TCollectionNotification

See Also

Reference

  • TVariables
  • BI.Dashboard


TVariables.TryAdd(String) Method

Summary

Represents method TryAdd(String).

Namespace: BI.Dashboard
Syntax
Delphi
public
 procedure TryAdd(const AName:String);

Parameters

AName
Type: String

See Also

Reference

  • TVariables
  • BI.Dashboard


TVariables Fields

Fields
Name | Description
IMain | Represents field IMain.
Top


TVariables.IMain Field

Summary

Represents field IMain.

Namespace: BI.Dashboard
Syntax
Delphi
protected
 IMain : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TVariables
  • BI.Dashboard


TVisualData Class

Summary

Represents type TVisualData.

Namespace: BI.Dashboard
Inheritance Hierarchy
TCollectionItem
BI.CollectionItem.TDataCollectionItem
BI.Dashboard.TVisualData
BI.Dashboard.Loader.TVisualDataAccess
Syntax
Delphi
type
 TVisualData=class(TDataCollectionItem)
 end;

The TVisualData type exposes the following members.

Properties
Show:
Name | Description
Expression | Represents property Expression.
Name | Represents property Name.
Top
See Also

Reference

  • BI.Dashboard


TVisualData Properties

Properties
Name | Description
Expression | Represents property Expression.
Name | Represents property Name.
Top


TVisualData.Expression Property

Summary

Represents property Expression.

Namespace: BI.Dashboard
Syntax
Delphi
protected
 property Expression:TExpression read FExpression write FExpression;

Property Value

Type: TExpression

See Also

Reference

  • TVisualData
  • BI.Dashboard


TVisualData.Name Property

Summary

Represents property Name.

Namespace: BI.Dashboard
Syntax
Delphi
published
 property Name:String read FName write SetName;

Property Value

Type: String

See Also

Reference

  • TVisualData
  • BI.Dashboard


TVisualDataItems Class

Summary

Represents type TVisualDataItems.

Namespace: BI.Dashboard
Inheritance Hierarchy
TOwnedCollection
BI.Dashboard.TVisualDataItems
Syntax
Delphi
type
 TVisualDataItems=class(TOwnedCollection)
 end;

The TVisualDataItems type exposes the following members.

Properties
Show:
Name | Description
Item[Integer] | Represents property Item[Integer].
Top
Methods
Show:
Name | Description
Add(TDataItem) | Represents method Add(TDataItem).
Change(String,TExpression) | Represents method Change(String,TExpression).
Find(String) | Represents method Find(String).
IndexOf(String) | Overloaded. Represents method IndexOf(String).
ValueOf(String) | Represents method ValueOf(String).
Top
See Also

Reference

  • BI.Dashboard


TVisualDataItems Properties

Properties
Name | Description
Item[Integer] | Represents property Item[Integer].
Top


TVisualDataItems.Item[Integer] Property

Summary

Represents property Item[Integer].

Namespace: BI.Dashboard
Syntax
Delphi
public
 property Item[const Index:Integer]:TVisualData read Get write Put; default;

Parameters

Index
Type: Integer

Property Value

Type: TVisualData

See Also

Reference

  • TVisualDataItems
  • BI.Dashboard


TVisualDataItems Methods

Methods
Name | Description
Add(TDataItem) | Represents method Add(TDataItem).
Change(String,TExpression) | Represents method Change(String,TExpression).
Find(String) | Represents method Find(String).
IndexOf(String) | Overloaded. Represents method IndexOf(String).
ValueOf(String) | Represents method ValueOf(String).
Top


TVisualDataItems.Add(TDataItem) Method

Summary

Represents method Add(TDataItem).

Namespace: BI.Dashboard
Syntax
Delphi
public
 function Add(const AData:TDataItem):TVisualData;

Parameters

AData
Type: TDataItem

Return Value

Type: TVisualData

See Also

Reference

  • TVisualDataItems
  • BI.Dashboard


TVisualDataItems.Change(String,TExpression) Method

Summary

Represents method Change(String,TExpression).

Namespace: BI.Dashboard
Syntax
Delphi
public
 procedure Change(const AName:String; const AValue:TExpression);

Parameters

AName
Type: String

AValue
Type: TExpression

See Also

Reference

  • TVisualDataItems
  • BI.Dashboard


TVisualDataItems.Find(String) Method

Summary

Represents method Find(String).

Namespace: BI.Dashboard
Syntax
Delphi
public
 function Find(const AName:String):TVisualData;

Parameters

AName
Type: String

Return Value

Type: TVisualData

See Also

Reference

  • TVisualDataItems
  • BI.Dashboard


TVisualDataItems.IndexOf(String) Method

Summary

Represents method IndexOf(String).

Namespace: BI.Dashboard
Syntax
Delphi
public
 function IndexOf(const AName:String):Integer; overload;

Parameters

AName
Type: String

Return Value

Type: Integer

See Also

Reference

  • TVisualDataItems
  • BI.Dashboard


TVisualDataItems.ValueOf(String) Method

Summary

Represents method ValueOf(String).

Namespace: BI.Dashboard
Syntax
Delphi
public
 function ValueOf(const AName:String):TExpression;

Parameters

AName
Type: String

Return Value

Type: TExpression

See Also

Reference

  • TVisualDataItems
  • BI.Dashboard


BI.Dashboard Enumerations

Enumerations
Name | Description
TPanelKind | Represents type TPanelKind.
TVisualDataKind | Represents type TVisualDataKind.
Top


TPanelKind Enumeration

Summary

Represents type TPanelKind.

Namespace: BI.Dashboard
Syntax
Delphi
type
 TPanelKind=(Automatic,Grid,List,Text,CheckList,Combo,Buttons,Image,Slider,
 Check,Navigator,Tree,Radio,Chart);

The TPanelKind type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Buttons | Represents constant Buttons.
Chart | Represents constant Chart.
Check | Represents constant Check.
CheckList | Represents constant CheckList.
Combo | Represents constant Combo.
Grid | Represents constant Grid.
Image | Represents constant Image.
List | Represents constant List.
Navigator | Represents constant Navigator.
Radio | Represents constant Radio.
Slider | Represents constant Slider.
Text | Represents constant Text.
Tree | Represents constant Tree.
Top
See Also

Reference

  • BI.Dashboard


TVisualDataKind Enumeration

Summary

Represents type TVisualDataKind.

Namespace: BI.Dashboard
Syntax
Delphi
type
 TVisualDataKind=(Data,Query,SingleRecord,Variable,FileURL,Custom);

The TVisualDataKind type exposes the following members.

Members
Show:
Name | Description
Custom | Represents constant Custom.
Data | Represents constant Data.
FileURL | Represents constant FileURL.
Query | Represents constant Query.
SingleRecord | Represents constant SingleRecord.
Variable | Represents constant Variable.
Top
See Also

Reference

  • BI.Dashboard


BI.Dashboard Delegates

Delegates
Name | Description
TChangeEvent | Represents type TChangeEvent.
Top


TChangeEvent Delegate

Summary

Represents type TChangeEvent.

Namespace: BI.Dashboard
Syntax
Delphi
type
 TChangeEvent=procedure(const Sender:TChangeListener; const AValue:TExpression) of object;
See Also

Reference

  • BI.Dashboard


BI.Dashboard Types

Types
Name | Description
TRenderClass | Represents type TRenderClass.
TVariableArray | Represents an array of the TVariable type.
Top


TRenderClass Type

Summary

Represents type TRenderClass.

Namespace: BI.Dashboard
Syntax
Delphi
type
 TRenderClass=class of TRender;
See Also

Reference

  • BI.Dashboard


TVariableArray Type

Summary

Represents an array of the TVariable type.

Namespace: BI.Dashboard
Syntax
Delphi
type
 TVariableArray=Array of TVariable;
See Also

Reference

  • BI.Dashboard


BI.Dashboard.HTML Namespace

Summary

Represents namespace BI.Dashboard.HTML.

Classes
Name | Description
TBaseItemAccess | Represents type TBaseItemAccess.
TBIPanelAccess | Represents type TBIPanelAccess.
TBITemplateAccess | Represents type TBITemplateAccess.
TDashboardItemAccess | Represents type TDashboardItemAccess.
TDivs | Represents type TDivs.
THTMLRender | Represents type THTMLRender.
TRenderAccess | Represents type TRenderAccess.
Top
Records
Name | Description
TDiv | Represents type TDiv.
Top
Delegates
Name | Description
THTMLChartProc | Represents type THTMLChartProc.
Top
Routines
Name | Description
FontStyle(TBIFont) | Represents method FontStyle(TBIFont).
FontStyles(Boolean,TBIFont) | Represents method FontStyles(Boolean,TBIFont).
GetItemText(TDashboardItem) | Represents method GetItemText(TDashboardItem).
HTMLButtons(TDashboardItem,TDataItem,Boolean,String,String) | Represents method HTMLButtons(TDashboardItem,TDataItem,Boolean,String,String).
HTMLCheckBox(TDashboardItem) | Represents method HTMLCheckBox(TDashboardItem).
HTMLImage(TDashboardItem) | Represents method HTMLImage(TDashboardItem).
HTMLList(TDashboardItem,TDataItem,Boolean,String,String) | Represents method HTMLList(TDashboardItem,TDataItem,Boolean,String,String).
HTMLRadio(TDashboardItem,TDataItem,String,String,String) | Represents method HTMLRadio(TDashboardItem,TDataItem,String,String,String).
HTMLSlider(TDashboardItem,Integer,Integer,String) | Represents method HTMLSlider(TDashboardItem,Integer,Integer,String).
HTMLText(TDashboardItem) | Overloaded. Represents method HTMLText(TDashboardItem).
HTMLText(TDashboardItem,String) | Overloaded. Represents method HTMLText(TDashboardItem,String).
RandomLightColor | Represents method RandomLightColor.
Top


BI.Dashboard.HTML Classes

Classes
Name | Description
TBaseItemAccess | Represents type TBaseItemAccess.
TBIPanelAccess | Represents type TBIPanelAccess.
TBITemplateAccess | Represents type TBITemplateAccess.
TDashboardItemAccess | Represents type TDashboardItemAccess.
TDivs | Represents type TDivs.
THTMLRender | Represents type THTMLRender.
TRenderAccess | Represents type TRenderAccess.
Top


TBaseItemAccess Class

Summary

Represents type TBaseItemAccess.

Namespace: BI.Dashboard.HTML
Inheritance Hierarchy
TCollectionItem
BI.Dashboard.TBaseItem
BI.Dashboard.HTML.TBaseItemAccess
Syntax
Delphi
type
 TBaseItemAccess=class(TBaseItem);
See Also

Reference

  • BI.Dashboard.HTML


TBIPanelAccess Class

Summary

Represents type TBIPanelAccess.

Namespace: BI.Dashboard.HTML
Inheritance Hierarchy
TCollectionItem
BI.Dashboard.TBaseItem
BI.Dashboard.TCustomBIPanel
BI.Dashboard.TBIPanel
BI.Dashboard.HTML.TBIPanelAccess
Syntax
Delphi
type
 TBIPanelAccess=class(TBIPanel);
See Also

Reference

  • BI.Dashboard.HTML


TBITemplateAccess Class

Summary

Represents type TBITemplateAccess.

Namespace: BI.Dashboard.HTML
Inheritance Hierarchy
TComponent
BI.Dashboard.TBITemplate
BI.Dashboard.HTML.TBITemplateAccess
Syntax
Delphi
type
 TBITemplateAccess=class(TBITemplate);
See Also

Reference

  • BI.Dashboard.HTML


TDashboardItemAccess Class

Summary

Represents type TDashboardItemAccess.

Namespace: BI.Dashboard.HTML
Inheritance Hierarchy
TCollectionItem
BI.Dashboard.TBaseItem
BI.Dashboard.TCustomBIPanel
BI.Dashboard.TDashboardItem
BI.Dashboard.HTML.TDashboardItemAccess
Syntax
Delphi
type
 TDashboardItemAccess=class(TDashboardItem);
See Also

Reference

  • BI.Dashboard.HTML


TDivs Class

Summary

Represents type TDivs.

Namespace: BI.Dashboard.HTML
Inheritance Hierarchy
TList
BI.Dashboard.HTML.TDivs
Syntax
Delphi
type
 TDivs=class(TList<TDiv>)
 end;

The TDivs type exposes the following members.

Methods
Show:
Name | Description
IndexOfPosition(String) | Represents method IndexOfPosition(String).
Top
See Also

Reference

  • BI.Dashboard.HTML


TDivs Methods

Methods
Name | Description
IndexOfPosition(String) | Represents method IndexOfPosition(String).
Top


TDivs.IndexOfPosition(String) Method

Summary

Represents method IndexOfPosition(String).

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 function IndexOfPosition(const APosition:String):Integer;

Parameters

APosition
Type: String

Return Value

Type: Integer

See Also

Reference

  • TDivs
  • BI.Dashboard.HTML


THTMLRender Class

Summary

Represents type THTMLRender.

Namespace: BI.Dashboard.HTML
Inheritance Hierarchy
TObject
BI.Dashboard.TRender
BI.Dashboard.HTML.THTMLRender
BI.Dashboard.HTML.Chart.THTMLRenderAccess
Syntax
Delphi
type
 THTMLRender=class(TRender)
 end;

The THTMLRender type exposes the following members.

Constants
Show:
Name | Description
CSSBegin | Represents constant CSSBegin.
CSSEnd | Represents constant CSSEnd.
ScriptBegin | Represents constant ScriptBegin.
ScriptEnd | Represents constant ScriptEnd.
Top
Constructors
Show:
Name | Description
Create | Initializes a new instance of the THTMLRender class.
Destroy | Represents the destructor of the THTMLRender class.
Top
Properties
Show:
Name | Description
HTML | Represents property HTML.
MinifyScripts | Represents property MinifyScripts.
Title | Represents property Title.
Top
Methods
Show:
Name | Description
AddItemSeparator(Integer,TPanelKind) | Represents method AddItemSeparator(Integer,TPanelKind). (Overrides TRender.AddItemSeparator(Integer,TPanelKind).)
AddListener(String,TObject) | Represents method AddListener(String,TObject). (Overrides TRender.AddListener(String,TObject).)
ClassOf(TDashboardItem) | Represents method ClassOf(TDashboardItem).
Clear | Represents method Clear. (Overrides TRender.Clear.)
Emit(TDashboard,Integer,String) | Represents method Emit(TDashboard,Integer,String). (Overrides TRender.Emit(TDashboard,Integer,String).)
Finish | Represents method Finish. (Overrides TRender.Finish.)
FreeChartName | Represents method FreeChartName.
Init(TDashboard,String,TStrings) | Represents method Init(TDashboard,String,TStrings). (Overrides TRender.Init(TDashboard,String,TStrings).)
Top
Fields
Show:
Name | Description
Charts | Represents field Charts.
CSS | Represents field CSS.
HTMLChart | Represents field HTMLChart.
IAnyGauge | Represents field IAnyGauge.
IAnyMap | Represents field IAnyMap.
SteemaSources | Represents field SteemaSources.
Top
See Also

Reference

  • BI.Dashboard.HTML


THTMLRender Constants

Constants
Name | Description
CSSBegin | Represents constant CSSBegin.
CSSEnd | Represents constant CSSEnd.
ScriptBegin | Represents constant ScriptBegin.
ScriptEnd | Represents constant ScriptEnd.
Top


THTMLRender.CSSBegin Constant

Summary

Represents constant CSSBegin.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
protected
 CSSBegin='<style type="text/css">';

Value

Type: string

See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender.CSSEnd Constant

Summary

Represents constant CSSEnd.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
protected
 CSSEnd='</style>';

Value

Type: string

See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender.ScriptBegin Constant

Summary

Represents constant ScriptBegin.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
protected
 ScriptBegin='<script type="text/javascript">';

Value

Type: string

See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender.ScriptEnd Constant

Summary

Represents constant ScriptEnd.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
protected
 ScriptEnd='</script>';

Value

Type: string

See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender Constructors

Constructors
Name | Description
Create | Initializes a new instance of the THTMLRender class.
Destroy | Represents the destructor of the THTMLRender class.
Top


THTMLRender.Create Constructor

Summary

Initializes a new instance of the THTMLRender class.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 Constructor Create;
See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender.Destroy Destructor

Summary

Represents the destructor of the THTMLRender class.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender Properties

Properties
Name | Description
HTML | Represents property HTML.
MinifyScripts | Represents property MinifyScripts.
Title | Represents property Title.
Top


THTMLRender.HTML Property

Summary

Represents property HTML.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 property HTML:TStringList read FHTML;

Property Value

Type: TStringList

See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender.MinifyScripts Property

Summary

Represents property MinifyScripts.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 property MinifyScripts:Boolean read FMinify write FMinify default True;

Property Value

Type: Boolean

See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender.Title Property

Summary

Represents property Title.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 property Title:String read FTitle write FTitle;

Property Value

Type: String

See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender Methods

Methods
Name | Description
AddItemSeparator(Integer,TPanelKind) | Represents method AddItemSeparator(Integer,TPanelKind). (Overrides TRender.AddItemSeparator(Integer,TPanelKind).)
AddListener(String,TObject) | Represents method AddListener(String,TObject). (Overrides TRender.AddListener(String,TObject).)
ClassOf(TDashboardItem) | Represents method ClassOf(TDashboardItem).
Clear | Represents method Clear. (Overrides TRender.Clear.)
Emit(TDashboard,Integer,String) | Represents method Emit(TDashboard,Integer,String). (Overrides TRender.Emit(TDashboard,Integer,String).)
Finish | Represents method Finish. (Overrides TRender.Finish.)
FreeChartName | Represents method FreeChartName.
Init(TDashboard,String,TStrings) | Represents method Init(TDashboard,String,TStrings). (Overrides TRender.Init(TDashboard,String,TStrings).)
Top


THTMLRender.AddItemSeparator(Integer,TPanelKind) Method

Summary

Represents method AddItemSeparator(Integer,TPanelKind).

Namespace: BI.Dashboard.HTML
Syntax
Delphi
protected
 procedure AddItemSeparator(const AIndex:Integer=-1; const AKind:TPanelKind=TPanelKind.Automatic); override;

Parameters

AIndex
Type: Integer

AKind
Type: TPanelKind

Overrides

TRender.AddItemSeparator(Integer,TPanelKind)
See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender.AddListener(String,TObject) Method

Summary

Represents method AddListener(String,TObject).

Namespace: BI.Dashboard.HTML
Syntax
Delphi
protected
 procedure AddListener(const AName:String; const ASource:TObject); override;

Parameters

AName
Type: String

ASource
Type: TObject

Overrides

TRender.AddListener(String,TObject)
See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender.ClassOf(TDashboardItem) Method

Summary

Represents method ClassOf(TDashboardItem).

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 class function ClassOf(const AItem:TDashboardItem):String; static;

Parameters

AItem
Type: TDashboardItem

Return Value

Type: String

See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender.Clear Method

Summary

Represents method Clear.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 procedure Clear; override;

Overrides

TRender.Clear
See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender.Emit(TDashboard,Integer,String) Method

Summary

Represents method Emit(TDashboard,Integer,String).

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 procedure Emit(const ADashboard:TDashboard; const AItem:Integer; const APosition:String); override;

Parameters

ADashboard
Type: TDashboard

AItem
Type: Integer

APosition
Type: String

Overrides

TRender.Emit(TDashboard,Integer,String)
See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender.Finish Method

Summary

Represents method Finish.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 procedure Finish; override;

Overrides

TRender.Finish
See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender.FreeChartName Method

Summary

Represents method FreeChartName.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
protected
 function FreeChartName:String;

Return Value

Type: String

See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender.Init(TDashboard,String,TStrings) Method

Summary

Represents method Init(TDashboard,String,TStrings).

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 procedure Init(const ADashboard:TDashboard; const ALayout:String=''; const AParams:TStrings=nil); override;

Parameters

ADashboard
Type: TDashboard

ALayout
Type: String

AParams
Type: TStrings

Overrides

TRender.Init(TDashboard,String,TStrings)
See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender Fields

Fields
Name | Description
Charts | Represents field Charts.
CSS | Represents field CSS.
HTMLChart | Represents field HTMLChart.
IAnyGauge | Represents field IAnyGauge.
IAnyMap | Represents field IAnyMap.
SteemaSources | Represents field SteemaSources.
Top


THTMLRender.Charts Field

Summary

Represents field Charts.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 Charts : TStringList;

Field Value

Type: TStringList

See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender.CSS Field

Summary

Represents field CSS.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 CSS: String;

Field Value

Type: String

See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender.HTMLChart Field

Summary

Represents field HTMLChart.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 class var
 HTMLChart : THTMLChartProc;

Field Value

Type: THTMLChartProc

See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender.IAnyGauge Field

Summary

Represents field IAnyGauge.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 IAnyGauge : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender.IAnyMap Field

Summary

Represents field IAnyMap.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 IAnyMap : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


THTMLRender.SteemaSources Field

Summary

Represents field SteemaSources.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 SteemaSources:String;

Field Value

Type: String

See Also

Reference

  • THTMLRender
  • BI.Dashboard.HTML


TRenderAccess Class

Summary

Represents type TRenderAccess.

Namespace: BI.Dashboard.HTML
Inheritance Hierarchy
TObject
BI.Dashboard.TRender
BI.Dashboard.HTML.TRenderAccess
Syntax
Delphi
type
 TRenderAccess=class(TRender);
See Also

Reference

  • BI.Dashboard.HTML


BI.Dashboard.HTML Records

Records
Name | Description
TDiv | Represents type TDiv.
Top


TDiv Record

Summary

Represents type TDiv.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
type
 TDiv=record
 end;

The TDiv type exposes the following members.

Fields
Show:
Name | Description
HTML | Represents field HTML.
ID | Represents field ID.
Item | Represents field Item.
Position | Represents field Position.
Style | Represents field Style.
Top
See Also

Reference

  • BI.Dashboard.HTML


TDiv Fields

Fields
Name | Description
HTML | Represents field HTML.
ID | Represents field ID.
Item | Represents field Item.
Position | Represents field Position.
Style | Represents field Style.
Top


TDiv.HTML Field

Summary

Represents field HTML.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 HTML : String;

Field Value

Type: String

See Also

Reference

  • TDiv
  • BI.Dashboard.HTML


TDiv.ID Field

Summary

Represents field ID.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 ID : Integer;

Field Value

Type: Integer

See Also

Reference

  • TDiv
  • BI.Dashboard.HTML


TDiv.Item Field

Summary

Represents field Item.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 Item : TDashboardItem;

Field Value

Type: TDashboardItem

See Also

Reference

  • TDiv
  • BI.Dashboard.HTML


TDiv.Position Field

Summary

Represents field Position.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 Position : String;

Field Value

Type: String

See Also

Reference

  • TDiv
  • BI.Dashboard.HTML


TDiv.Style Field

Summary

Represents field Style.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
public
 Style : String;

Field Value

Type: String

See Also

Reference

  • TDiv
  • BI.Dashboard.HTML


BI.Dashboard.HTML Delegates

Delegates
Name | Description
THTMLChartProc | Represents type THTMLChartProc.
Top


THTMLChartProc Delegate

Summary

Represents type THTMLChartProc.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
type
 THTMLChartProc=function(const ARender:THTMLRender; const AItem:TDashboardItem; const AFormat:String):String;
See Also

Reference

  • BI.Dashboard.HTML


BI.Dashboard.HTML Routines

Routines
Name | Description
FontStyle(TBIFont) | Represents method FontStyle(TBIFont).
FontStyles(Boolean,TBIFont) | Represents method FontStyles(Boolean,TBIFont).
GetItemText(TDashboardItem) | Represents method GetItemText(TDashboardItem).
HTMLButtons(TDashboardItem,TDataItem,Boolean,String,String) | Represents method HTMLButtons(TDashboardItem,TDataItem,Boolean,String,String).
HTMLCheckBox(TDashboardItem) | Represents method HTMLCheckBox(TDashboardItem).
HTMLImage(TDashboardItem) | Represents method HTMLImage(TDashboardItem).
HTMLList(TDashboardItem,TDataItem,Boolean,String,String) | Represents method HTMLList(TDashboardItem,TDataItem,Boolean,String,String).
HTMLRadio(TDashboardItem,TDataItem,String,String,String) | Represents method HTMLRadio(TDashboardItem,TDataItem,String,String,String).
HTMLSlider(TDashboardItem,Integer,Integer,String) | Represents method HTMLSlider(TDashboardItem,Integer,Integer,String).
HTMLText(TDashboardItem) | Overloaded. Represents method HTMLText(TDashboardItem).
HTMLText(TDashboardItem,String) | Overloaded. Represents method HTMLText(TDashboardItem,String).
RandomLightColor | Represents method RandomLightColor.
Top


FontStyle(TBIFont) Method

Summary

Represents method FontStyle(TBIFont).

Namespace: BI.Dashboard.HTML
Syntax
Delphi
function FontStyle(const AFont:TBIFont):String;

Parameters

AFont
Type: TBIFont

Return Value

Type: String

See Also

Reference

  • BI.Dashboard.HTML


FontStyles(Boolean,TBIFont) Method

Summary

Represents method FontStyles(Boolean,TBIFont).

Namespace: BI.Dashboard.HTML
Syntax
Delphi
function FontStyles(const IsBegin:Boolean; const AFont:TBIFont):String;

Parameters

IsBegin
Type: Boolean

AFont
Type: TBIFont

Return Value

Type: String

See Also

Reference

  • BI.Dashboard.HTML


GetItemText(TDashboardItem) Method

Summary

Represents method GetItemText(TDashboardItem).

Namespace: BI.Dashboard.HTML
Syntax
Delphi
function GetItemText(const AItem:TDashboardItem):String;

Parameters

AItem
Type: TDashboardItem

Return Value

Type: String

See Also

Reference

  • BI.Dashboard.HTML


HTMLButtons(TDashboardItem,TDataItem,Boolean,String,String) Method

Summary

Represents method HTMLButtons(TDashboardItem,TDataItem,Boolean,String,String).

Namespace: BI.Dashboard.HTML
Syntax
Delphi
function HTMLButtons(const AItem:TDashboardItem; const AData:TDataItem; const AsList:Boolean;
 const AVariable,ChangeFunction:String):String;

Parameters

AItem
Type: TDashboardItem

AData
Type: TDataItem

AsList
Type: Boolean

AVariable
Type: String

ChangeFunction
Type: String

Return Value

Type: String

See Also

Reference

  • BI.Dashboard.HTML


HTMLCheckBox(TDashboardItem) Method

Summary

Represents method HTMLCheckBox(TDashboardItem).

Namespace: BI.Dashboard.HTML
Syntax
Delphi
function HTMLCheckBox(const AItem:TDashboardItem):String;

Parameters

AItem
Type: TDashboardItem

Return Value

Type: String

See Also

Reference

  • BI.Dashboard.HTML


HTMLImage(TDashboardItem) Method

Summary

Represents method HTMLImage(TDashboardItem).

Namespace: BI.Dashboard.HTML
Syntax
Delphi
function HTMLImage(const AItem:TDashboardItem):String;

Parameters

AItem
Type: TDashboardItem

Return Value

Type: String

See Also

Reference

  • BI.Dashboard.HTML


HTMLList(TDashboardItem,TDataItem,Boolean,String,String) Method

Summary

Represents method HTMLList(TDashboardItem,TDataItem,Boolean,String,String).

Namespace: BI.Dashboard.HTML
Syntax
Delphi
function HTMLList(const AItem:TDashboardItem; const AData:TDataItem; const AsList:Boolean;
 const AVariable,ChangeFunction:String):String;

Parameters

AItem
Type: TDashboardItem

AData
Type: TDataItem

AsList
Type: Boolean

AVariable
Type: String

ChangeFunction
Type: String

Return Value

Type: String

See Also

Reference

  • BI.Dashboard.HTML


HTMLRadio(TDashboardItem,TDataItem,String,String,String) Method

Summary

Represents method HTMLRadio(TDashboardItem,TDataItem,String,String,String).

Namespace: BI.Dashboard.HTML
Syntax
Delphi
function HTMLRadio(const AItem:TDashboardItem; const AData:TDataItem;
 const AVariable,ChangeFunction,AGroup:String):String;

Parameters

AItem
Type: TDashboardItem

AData
Type: TDataItem

AVariable
Type: String

ChangeFunction
Type: String

AGroup
Type: String

Return Value

Type: String

See Also

Reference

  • BI.Dashboard.HTML


HTMLSlider(TDashboardItem,Integer,Integer,String) Method

Summary

Represents method HTMLSlider(TDashboardItem,Integer,Integer,String).

Namespace: BI.Dashboard.HTML
Syntax
Delphi
function HTMLSlider(const AItem:TDashboardItem; const ACount,ASelected:Integer; const ATarget:String):String;

Parameters

AItem
Type: TDashboardItem

ACount
Type: Integer

ASelected
Type: Integer

ATarget
Type: String

Return Value

Type: String

See Also

Reference

  • BI.Dashboard.HTML


HTMLText(TDashboardItem) Method

Summary

Represents method HTMLText(TDashboardItem).

Namespace: BI.Dashboard.HTML
Syntax
Delphi
function HTMLText(const AItem:TDashboardItem):String; overload;

Parameters

AItem
Type: TDashboardItem

Return Value

Type: String

See Also

Reference

  • BI.Dashboard.HTML


HTMLText(TDashboardItem,String) Method

Summary

Represents method HTMLText(TDashboardItem,String).

Namespace: BI.Dashboard.HTML
Syntax
Delphi
function HTMLText(const AItem:TDashboardItem; const AText:String):String; overload;

Parameters

AItem
Type: TDashboardItem

AText
Type: String

Return Value

Type: String

See Also

Reference

  • BI.Dashboard.HTML


RandomLightColor Method

Summary

Represents method RandomLightColor.

Namespace: BI.Dashboard.HTML
Syntax
Delphi
function RandomLightColor:TColor;

Return Value

Type: TColor

See Also

Reference

  • BI.Dashboard.HTML


BI.Dashboard.HTML.Chart Namespace

Summary

Represents namespace BI.Dashboard.HTML.Chart.

Classes
Name | Description
TDashboardItemAccess | Represents type TDashboardItemAccess.
THTMLChartRender | Represents type THTMLChartRender.
THTMLRenderAccess | Represents type THTMLRenderAccess.
TJavascriptAccess | Represents type TJavascriptAccess.
Top
Variables
Name | Description
ChartRender | Represents variable ChartRender.
Top
Routines
Name | Description
HTMLChart(THTMLRender,TDashboardItem,String) | Represents method HTMLChart(THTMLRender,TDashboardItem,String).
Top


BI.Dashboard.HTML.Chart Classes

Classes
Name | Description
TDashboardItemAccess | Represents type TDashboardItemAccess.
THTMLChartRender | Represents type THTMLChartRender.
THTMLRenderAccess | Represents type THTMLRenderAccess.
TJavascriptAccess | Represents type TJavascriptAccess.
Top


TDashboardItemAccess Class

Summary

Represents type TDashboardItemAccess.

Namespace: BI.Dashboard.HTML.Chart
Inheritance Hierarchy
TCollectionItem
BI.Dashboard.TBaseItem
BI.Dashboard.TCustomBIPanel
BI.Dashboard.TDashboardItem
BI.Dashboard.HTML.Chart.TDashboardItemAccess
Syntax
Delphi
type
 TDashboardItemAccess=class(TDashboardItem);
See Also

Reference

  • BI.Dashboard.HTML.Chart


THTMLChartRender Class

Summary

Represents type THTMLChartRender.

Namespace: BI.Dashboard.HTML.Chart
Inheritance Hierarchy
TObject
BI.Dashboard.HTML.Chart.THTMLChartRender
Syntax
Delphi
type
 THTMLChartRender=class
 end;
See Also

Reference

  • BI.Dashboard.HTML.Chart


THTMLRenderAccess Class

Summary

Represents type THTMLRenderAccess.

Namespace: BI.Dashboard.HTML.Chart
Inheritance Hierarchy
TObject
BI.Dashboard.TRender
BI.Dashboard.HTML.THTMLRender
BI.Dashboard.HTML.Chart.THTMLRenderAccess
Syntax
Delphi
type
 THTMLRenderAccess=class(THTMLRender);
See Also

Reference

  • BI.Dashboard.HTML.Chart


TJavascriptAccess Class

Summary

Represents type TJavascriptAccess.

Namespace: BI.Dashboard.HTML.Chart
Inheritance Hierarchy
TJavascriptExportFormat
BI.Dashboard.HTML.Chart.TJavascriptAccess
Syntax
Delphi
type
 TJavascriptAccess=class(TJavascriptExportFormat);
See Also

Reference

  • BI.Dashboard.HTML.Chart


BI.Dashboard.HTML.Chart Variables

Variables
Name | Description
ChartRender | Represents variable ChartRender.
Top


ChartRender Variable

Summary

Represents variable ChartRender.

Namespace: BI.Dashboard.HTML.Chart
Syntax
Delphi
ChartRender : THTMLChartRender=nil;

Value

Type: THTMLChartRender

See Also

Reference

  • BI.Dashboard.HTML.Chart


BI.Dashboard.HTML.Chart Routines

Routines
Name | Description
HTMLChart(THTMLRender,TDashboardItem,String) | Represents method HTMLChart(THTMLRender,TDashboardItem,String).
Top


HTMLChart(THTMLRender,TDashboardItem,String) Method

Summary

Represents method HTMLChart(THTMLRender,TDashboardItem,String).

Namespace: BI.Dashboard.HTML.Chart
Syntax
Delphi
function HTMLChart(const ARender:THTMLRender; const AItem:TDashboardItem; const AFormat:String):String;

Parameters

ARender
Type: THTMLRender

AItem
Type: TDashboardItem

AFormat
Type: String

Return Value

Type: String

See Also

Reference

  • BI.Dashboard.HTML.Chart


BI.Dashboard.Layouts Namespace

Summary

Represents namespace BI.Dashboard.Layouts.

Classes
Name | Description
TBICoordinate | Represents type TBICoordinate.
TLayoutItem | Represents type TLayoutItem.
TLayouts | Represents type TLayouts.
Top
Enumerations
Name | Description
TLayoutStyle | Represents type TLayoutStyle.
TUnits | Represents type TUnits.
Top
Constants
Name | Description
PredefinedLayouts | Represents constant PredefinedLayouts.
Top
Routines
Name | Description
CreatePredefinedLayouts | Represents method CreatePredefinedLayouts.
Top


BI.Dashboard.Layouts Classes

Classes
Name | Description
TBICoordinate | Represents type TBICoordinate.
TLayoutItem | Represents type TLayoutItem.
TLayouts | Represents type TLayouts.
Top


TBICoordinate Class

Summary

Represents type TBICoordinate.

Namespace: BI.Dashboard.Layouts
Inheritance Hierarchy
TPersistent
BI.Dashboard.Layouts.TBICoordinate
Syntax
Delphi
type
 TBICoordinate=class(TPersistent)
 end;

The TBICoordinate type exposes the following members.

Properties
Show:
Name | Description
Units | Represents property Units.
Value | Represents property Value.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
FromString(String) | Represents method FromString(String).
Top
See Also

Reference

  • BI.Dashboard.Layouts


TBICoordinate Properties

Properties
Name | Description
Units | Represents property Units.
Value | Represents property Value.
Top


TBICoordinate.Units Property

Summary

Represents property Units.

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
published
 property Units:TUnits read FUnits write SetUnits default TUnits.Pixels;

Property Value

Type: TUnits

See Also

Reference

  • TBICoordinate
  • BI.Dashboard.Layouts


TBICoordinate.Value Property

Summary

Represents property Value.

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
published
 property Value:Single read FValue write SetValue;

Property Value

Type: Single

See Also

Reference

  • TBICoordinate
  • BI.Dashboard.Layouts


TBICoordinate Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
FromString(String) | Represents method FromString(String).
Top


TBICoordinate.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TBICoordinate
  • BI.Dashboard.Layouts


TBICoordinate.FromString(String) Method

Summary

Represents method FromString(String).

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
public
 procedure FromString(const S:String);

Parameters

S
Type: String

See Also

Reference

  • TBICoordinate
  • BI.Dashboard.Layouts


TLayoutItem Class

Summary

Represents type TLayoutItem.

Namespace: BI.Dashboard.Layouts
Inheritance Hierarchy
TCollectionItem
BI.Dashboard.Layouts.TLayoutItem
Syntax
Delphi
type
 TLayoutItem=class(TCollectionItem)
 end;

The TLayoutItem type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TLayoutItem class.
Destroy | Represents the destructor of the TLayoutItem class.
Top
Properties
Show:
Name | Description
Align | Represents property Align.
Height | Represents property Height.
Items | Represents property Items.
Item[Integer] | Represents property Item[Integer].
Name | Represents property Name.
Nested | Represents property Nested.
Style | Represents property Style.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
Find(String) | Represents method Find(String).
IsHorizontal | Represents method IsHorizontal.
IsPanels | Represents method IsPanels.
Top
See Also

Reference

  • BI.Dashboard.Layouts


TLayoutItem Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TLayoutItem class.
Destroy | Represents the destructor of the TLayoutItem class.
Top


TLayoutItem.Create(TCollection) Constructor

Summary

Initializes a new instance of the TLayoutItem class.

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
public
 Constructor Create(ACollection:TCollection); override;

Parameters

ACollection
Type: TCollection

See Also

Reference

  • TLayoutItem
  • BI.Dashboard.Layouts


TLayoutItem.Destroy Destructor

Summary

Represents the destructor of the TLayoutItem class.

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TLayoutItem
  • BI.Dashboard.Layouts


TLayoutItem Properties

Properties
Name | Description
Align | Represents property Align.
Height | Represents property Height.
Items | Represents property Items.
Item[Integer] | Represents property Item[Integer].
Name | Represents property Name.
Nested | Represents property Nested.
Style | Represents property Style.
Width | Represents property Width.
Top


TLayoutItem.Align Property

Summary

Represents property Align.

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
published
 property Align:String read FAlign write FAlign;

Property Value

Type: String

See Also

Reference

  • TLayoutItem
  • BI.Dashboard.Layouts


TLayoutItem.Height Property

Summary

Represents property Height.

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
published
 property Height:TBICoordinate read FHeight write FHeight;

Property Value

Type: TBICoordinate

See Also

Reference

  • TLayoutItem
  • BI.Dashboard.Layouts


TLayoutItem.Items Property

Summary

Represents property Items.

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
published
 property Items:TLayouts read FItems write SetItems;

Property Value

Type: TLayouts

See Also

Reference

  • TLayoutItem
  • BI.Dashboard.Layouts


TLayoutItem.Item[Integer] Property

Summary

Represents property Item[Integer].

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
public
 property Item[const AIndex:Integer]:TLayoutItem read Get write Put; default;

Parameters

AIndex
Type: Integer

Property Value

Type: TLayoutItem

See Also

Reference

  • TLayoutItem
  • BI.Dashboard.Layouts


TLayoutItem.Name Property

Summary

Represents property Name.

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
published
 property Name:String read FName write SetName;

Property Value

Type: String

See Also

Reference

  • TLayoutItem
  • BI.Dashboard.Layouts


TLayoutItem.Nested Property

Summary

Represents property Nested.

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
published
 property Nested:String read FNested write FNested;

Property Value

Type: String

See Also

Reference

  • TLayoutItem
  • BI.Dashboard.Layouts


TLayoutItem.Style Property

Summary

Represents property Style.

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
published
 property Style:TLayoutStyle read FStyle write FStyle default TLayoutStyle.Automatic;

Property Value

Type: TLayoutStyle

See Also

Reference

  • TLayoutItem
  • BI.Dashboard.Layouts


TLayoutItem.Width Property

Summary

Represents property Width.

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
published
 property Width:TBICoordinate read FWidth write FWidth;

Property Value

Type: TBICoordinate

See Also

Reference

  • TLayoutItem
  • BI.Dashboard.Layouts


TLayoutItem Methods

Methods
Name | Description
Find(String) | Represents method Find(String).
IsHorizontal | Represents method IsHorizontal.
IsPanels | Represents method IsPanels.
Top


TLayoutItem.Find(String) Method

Summary

Represents method Find(String).

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
public
 function Find(const AName:String):TLayoutItem;

Parameters

AName
Type: String

Return Value

Type: TLayoutItem

See Also

Reference

  • TLayoutItem
  • BI.Dashboard.Layouts


TLayoutItem.IsHorizontal Method

Summary

Represents method IsHorizontal.

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
public
 function IsHorizontal:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TLayoutItem
  • BI.Dashboard.Layouts


TLayoutItem.IsPanels Method

Summary

Represents method IsPanels.

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
public
 function IsPanels:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TLayoutItem
  • BI.Dashboard.Layouts


TLayouts Class

Summary

Represents type TLayouts.

Namespace: BI.Dashboard.Layouts
Inheritance Hierarchy
TOwnedCollection
BI.Dashboard.Layouts.TLayouts
Syntax
Delphi
type
 TLayouts=class(TOwnedCollection)
 end;

The TLayouts type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TLayouts class.
Top
Properties
Show:
Name | Description
Item[Integer] | Represents property Item[Integer].
Top
Methods
Show:
Name | Description
AddTo(TStrings) | Represents method AddTo(TStrings).
Best(Integer) | Represents method Best(Integer).
Find(String) | Represents method Find(String).
IndexOf(TLayoutItem) | Represents method IndexOf(TLayoutItem).
Predefined | Represents method Predefined.
Top
See Also

Reference

  • BI.Dashboard.Layouts


TLayouts Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TLayouts class.
Top


TLayouts.Destroy Destructor

Summary

Represents the destructor of the TLayouts class.

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TLayouts
  • BI.Dashboard.Layouts


TLayouts Properties

Properties
Name | Description
Item[Integer] | Represents property Item[Integer].
Top


TLayouts.Item[Integer] Property

Summary

Represents property Item[Integer].

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
public
 property Item[const AIndex:Integer]:TLayoutItem read Get write Put; default;

Parameters

AIndex
Type: Integer

Property Value

Type: TLayoutItem

See Also

Reference

  • TLayouts
  • BI.Dashboard.Layouts


TLayouts Methods

Methods
Name | Description
AddTo(TStrings) | Represents method AddTo(TStrings).
Best(Integer) | Represents method Best(Integer).
Find(String) | Represents method Find(String).
IndexOf(TLayoutItem) | Represents method IndexOf(TLayoutItem).
Predefined | Represents method Predefined.
Top


TLayouts.AddTo(TStrings) Method

Summary

Represents method AddTo(TStrings).

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
public
 procedure AddTo(const AItems: TStrings);

Parameters

AItems
Type: TStrings

See Also

Reference

  • TLayouts
  • BI.Dashboard.Layouts


TLayouts.Best(Integer) Method

Summary

Represents method Best(Integer).

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
public
 function Best(const ACount:Integer):String;

Parameters

ACount
Type: Integer

Return Value

Type: String

See Also

Reference

  • TLayouts
  • BI.Dashboard.Layouts


TLayouts.Find(String) Method

Summary

Represents method Find(String).

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
public
 function Find(const AName:String):TLayoutItem;

Parameters

AName
Type: String

Return Value

Type: TLayoutItem

See Also

Reference

  • TLayouts
  • BI.Dashboard.Layouts


TLayouts.IndexOf(TLayoutItem) Method

Summary

Represents method IndexOf(TLayoutItem).

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
public
 function IndexOf(const AItem:TLayoutItem):Integer;

Parameters

AItem
Type: TLayoutItem

Return Value

Type: Integer

See Also

Reference

  • TLayouts
  • BI.Dashboard.Layouts


TLayouts.Predefined Method

Summary

Represents method Predefined.

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
public
 class function Predefined:TLayouts; static;

Return Value

Type: TLayouts

See Also

Reference

  • TLayouts
  • BI.Dashboard.Layouts


BI.Dashboard.Layouts Enumerations

Enumerations
Name | Description
TLayoutStyle | Represents type TLayoutStyle.
TUnits | Represents type TUnits.
Top


TLayoutStyle Enumeration

Summary

Represents type TLayoutStyle.

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
type
 TLayoutStyle=(Automatic,Panels,Tabs,List,Combo);

The TLayoutStyle type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Combo | Represents constant Combo.
List | Represents constant List.
Panels | Represents constant Panels.
Tabs | Represents constant Tabs.
Top
See Also

Reference

  • BI.Dashboard.Layouts


TUnits Enumeration

Summary

Represents type TUnits.

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
type
 TUnits=(Pixels,Percent);

The TUnits type exposes the following members.

Members
Show:
Name | Description
Percent | Represents constant Percent.
Pixels | Represents constant Pixels.
Top
See Also

Reference

  • BI.Dashboard.Layouts


BI.Dashboard.Layouts Constants

Constants
Name | Description
PredefinedLayouts | Represents constant PredefinedLayouts.
Top


PredefinedLayouts Constant

Summary

Represents constant PredefinedLayouts.

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
 PredefinedLayouts=
'{'+
'  "layouts": ['+
'    { "name": "Empty", "items": [] },'+
'    { "name": "Single", "items": [ { "name": "0" } ] },'+
'    { "name": "2 Rows", "grid": { "rows": 2 } },'+
'    { "name": "2 Columns", "grid": { "columns": 2 } },'+
'    { "name": "3 Rows", "grid": { "rows": 3 } },'+
'    { "name": "3 Columns", "grid": { "columns": 3 } },'+
'    {'+
'      "name": "Top (Left Right)",'+
'      "items": ['+
'        { "name": "0", "align": "top", "height": "50%" },'+
'        { "name": "left right", "nested": "2 Columns" }'+
'      ]'+
'    },'+
'    {'+
'      "name": "(Left Right) Bottom",'+
'      "items": ['+
'        { "name": "left right", "nested": "2 Columns" },'+
'        { "name": "2", "align": "bottom", "height": "50%" }'+
'      ]'+
'    },'+
'    {'+
'      "name": "Left (Top Bottom)",'+
'      "items": ['+
'        { "name": "0", "align": "left", "width": "50%" },'+
'        { "name": "top bottom", "nested": "2 Rows" }'+
'      ]'+
'    },'+
'    {'+
'      "name": "(Top Bottom) Right",'+
'      "items": ['+
'        { "name": "top bottom", "nested": "2 Rows" },'+
'        { "name": "2", "align": "right", "width": "50%" }'+
'      ]'+
'    },'+
'    { "name": "2x2", "grid": { "rows": 2, "columns": 2 } },'+
'    { "name": "3x3", "grid": { "rows": 3, "columns": 3 } },'+
'    { "name": "tabs", "style": "tabs" },'+
'    { "name": "list", "style": "list" },'+
'    { "name": "combo", "style": "combo" }'+
'  ]'+
'}';

Value

Type: string

See Also

Reference

  • BI.Dashboard.Layouts


BI.Dashboard.Layouts Routines

Routines
Name | Description
CreatePredefinedLayouts | Represents method CreatePredefinedLayouts.
Top


CreatePredefinedLayouts Method

Summary

Represents method CreatePredefinedLayouts.

Namespace: BI.Dashboard.Layouts
Syntax
Delphi
function CreatePredefinedLayouts:TLayouts;

Return Value

Type: TLayouts

See Also

Reference

  • BI.Dashboard.Layouts


BI.Dashboard.Loader Namespace

Summary

Represents namespace BI.Dashboard.Loader.

Classes
Name | Description
TBITemplateAccess | Represents type TBITemplateAccess.
TTemplateAccess | Represents type TTemplateAccess.
TVisualDataAccess | Represents type TVisualDataAccess.
Top
Records
Name | Description
TTemplateLoader | Represents type TTemplateLoader.
Top
Routines
Name | Description
GuessNames(TDataItem,String) | Represents method GuessNames(TDataItem,String).
Top


BI.Dashboard.Loader Classes

Classes
Name | Description
TBITemplateAccess | Represents type TBITemplateAccess.
TTemplateAccess | Represents type TTemplateAccess.
TVisualDataAccess | Represents type TVisualDataAccess.
Top


TBITemplateAccess Class

Summary

Represents type TBITemplateAccess.

Namespace: BI.Dashboard.Loader
Inheritance Hierarchy
TComponent
BI.Dashboard.TBITemplate
BI.Dashboard.Loader.TBITemplateAccess
Syntax
Delphi
type
 TBITemplateAccess=class(TBITemplate);
See Also

Reference

  • BI.Dashboard.Loader


TTemplateAccess Class

Summary

Represents type TTemplateAccess.

Namespace: BI.Dashboard.Loader
Inheritance Hierarchy
TComponent
BI.Dashboard.TBITemplate
BI.Dashboard.Loader.TTemplateAccess
Syntax
Delphi
type
 TTemplateAccess=class(TBITemplate);
See Also

Reference

  • BI.Dashboard.Loader


TVisualDataAccess Class

Summary

Represents type TVisualDataAccess.

Namespace: BI.Dashboard.Loader
Inheritance Hierarchy
TCollectionItem
BI.CollectionItem.TDataCollectionItem
BI.Dashboard.TVisualData
BI.Dashboard.Loader.TVisualDataAccess
Syntax
Delphi
type
 TVisualDataAccess=class(TVisualData);
See Also

Reference

  • BI.Dashboard.Loader


BI.Dashboard.Loader Records

Records
Name | Description
TTemplateLoader | Represents type TTemplateLoader.
Top


TTemplateLoader Record

Summary

Represents type TTemplateLoader.

Namespace: BI.Dashboard.Loader
Syntax
Delphi
type
 TTemplateLoader=record
 end;

The TTemplateLoader type exposes the following members.

Methods
Show:
Name | Description
FromJSON(String,TBITemplate) | Represents method FromJSON(String,TBITemplate).
FromJSONFile(String) | Overloaded. Represents method FromJSONFile(String).
FromJSONFile(String,TBITemplate) | Overloaded. Represents method FromJSONFile(String,TBITemplate).
ImportJSON(String) | Represents method ImportJSON(String).
ImportLayouts(TBITemplate,TDataItem,TLayouts) | Represents method ImportLayouts(TBITemplate,TDataItem,TLayouts).
Top
See Also

Reference

  • BI.Dashboard.Loader


TTemplateLoader Methods

Methods
Name | Description
FromJSON(String,TBITemplate) | Represents method FromJSON(String,TBITemplate).
FromJSONFile(String) | Overloaded. Represents method FromJSONFile(String).
FromJSONFile(String,TBITemplate) | Overloaded. Represents method FromJSONFile(String,TBITemplate).
ImportJSON(String) | Represents method ImportJSON(String).
ImportLayouts(TBITemplate,TDataItem,TLayouts) | Represents method ImportLayouts(TBITemplate,TDataItem,TLayouts).
Top


TTemplateLoader.FromJSON(String,TBITemplate) Method

Summary

Represents method FromJSON(String,TBITemplate).

Namespace: BI.Dashboard.Loader
Syntax
Delphi
public
 class procedure FromJSON(const AJSON:String; const ATemplate:TBITemplate); static;

Parameters

AJSON
Type: String

ATemplate
Type: TBITemplate

See Also

Reference

  • TTemplateLoader
  • BI.Dashboard.Loader


TTemplateLoader.FromJSONFile(String) Method

Summary

Represents method FromJSONFile(String).

Namespace: BI.Dashboard.Loader
Syntax
Delphi
public
 class function FromJSONFile(const AFile:String):TBITemplate; overload; static;

Parameters

AFile
Type: String

Return Value

Type: TBITemplate

See Also

Reference

  • TTemplateLoader
  • BI.Dashboard.Loader


TTemplateLoader.FromJSONFile(String,TBITemplate) Method

Summary

Represents method FromJSONFile(String,TBITemplate).

Namespace: BI.Dashboard.Loader
Syntax
Delphi
public
 class procedure FromJSONFile(const AFile:String; const ATemplate:TBITemplate); overload; static;

Parameters

AFile
Type: String

ATemplate
Type: TBITemplate

See Also

Reference

  • TTemplateLoader
  • BI.Dashboard.Loader


TTemplateLoader.ImportJSON(String) Method

Summary

Represents method ImportJSON(String).

Namespace: BI.Dashboard.Loader
Syntax
Delphi
public
 class function ImportJSON(const AText:String):TDataItem; static;

Parameters

AText
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TTemplateLoader
  • BI.Dashboard.Loader


TTemplateLoader.ImportLayouts(TBITemplate,TDataItem,TLayouts) Method

Summary

Represents method ImportLayouts(TBITemplate,TDataItem,TLayouts).

Namespace: BI.Dashboard.Loader
Syntax
Delphi
public
 class procedure ImportLayouts(const ATemplate:TBITemplate;
 const AData: TDataItem;
 const ALayouts:TLayouts); static;

Parameters

ATemplate
Type: TBITemplate

AData
Type: TDataItem

ALayouts
Type: TLayouts

See Also

Reference

  • TTemplateLoader
  • BI.Dashboard.Loader


BI.Dashboard.Loader Routines

Routines
Name | Description
GuessNames(TDataItem,String) | Represents method GuessNames(TDataItem,String).
Top


GuessNames(TDataItem,String) Method

Summary

Represents method GuessNames(TDataItem,String).

Namespace: BI.Dashboard.Loader
Syntax
Delphi
procedure GuessNames(const AData:TDataItem; const AItem:String);

Parameters

AData
Type: TDataItem

AItem
Type: String

See Also

Reference

  • BI.Dashboard.Loader


BI.DataItem Namespace

Summary

Represents namespace BI.DataItem.

Classes
Name | Description
TDataArrayHelper | Represents type TDataArrayHelper.
TDataItem | Represents type TDataItem.
TDataItems | Represents type TDataItems.
TDataKindHelper | Represents type TDataKindHelper.
TDataProvider | Represents type TDataProvider.
TDetailData | Represents type TDetailData.
THashIndex | Represents type THashIndex.
TImportHistory | Represents type TImportHistory.
Top
Records
Name | Description
TBIConsumers | Represents type TBIConsumers.
TDataTimes | Represents type TDataTimes.
TIndexHelper | Represents type TIndexHelper.
TMemory | Represents type TMemory.
TMissingData | Represents type TMissingData.
TSortItem | Represents type TSortItem.
Top
Enumerations
Name | Description
TBIEvent | Represents type TBIEvent.
TDataKind | Represents type TDataKind.
TNumericData | Represents type TNumericData.
Top
Delegates
Name | Description
TBIConsumer | Represents type TBIConsumer.
Top
Types
Name | Description
TDataArray | Represents an array of the TDataItem type.
Top


BI.DataItem Classes

Classes
Name | Description
TDataArrayHelper | Represents type TDataArrayHelper.
TDataItem | Represents type TDataItem.
TDataItems | Represents type TDataItems.
TDataKindHelper | Represents type TDataKindHelper.
TDataProvider | Represents type TDataProvider.
TDetailData | Represents type TDetailData.
THashIndex | Represents type THashIndex.
TImportHistory | Represents type TImportHistory.
Top


TDataArrayHelper Class Helper

Summary

Represents type TDataArrayHelper.

Namespace: BI.DataItem
Syntax
Delphi
type
 TDataArrayHelper=record helper for TDataArray
 end;
Methods
Name | Description
Add(TDataArray) | Overloaded. Represents method Add(TDataArray).
Add(TDataItem) | Overloaded. Represents method Add(TDataItem).
Clear | Represents method Clear.
Copy | Represents method Copy.
Count | Represents method Count.
Delete(Integer) | Represents method Delete(Integer).
Equal(TDataArray) | Represents method Equal(TDataArray).
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer).
Exists(TDataItem) | Represents method Exists(TDataItem).
Find(String) | Represents method Find(String).
FreeAll | Represents method FreeAll.
IndexOf(String) | Overloaded. Represents method IndexOf(String).
IndexOf(TDataItem) | Overloaded. Represents method IndexOf(TDataItem).
Insert(TDataItem,Integer) | Represents method Insert(TDataItem,Integer).
Remove(TDataItem) | Represents method Remove(TDataItem).
Subtract(TDataArray) | Overloaded. Represents method Subtract(TDataArray).
Subtract(TDataItem) | Overloaded. Represents method Subtract(TDataItem).
Top
See Also

Reference

  • BI.DataItem


TDataArrayHelper Methods

Methods
Name | Description
Add(TDataArray) | Overloaded. Represents method Add(TDataArray).
Add(TDataItem) | Overloaded. Represents method Add(TDataItem).
Clear | Represents method Clear.
Copy | Represents method Copy.
Count | Represents method Count.
Delete(Integer) | Represents method Delete(Integer).
Equal(TDataArray) | Represents method Equal(TDataArray).
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer).
Exists(TDataItem) | Represents method Exists(TDataItem).
Find(String) | Represents method Find(String).
FreeAll | Represents method FreeAll.
IndexOf(String) | Overloaded. Represents method IndexOf(String).
IndexOf(TDataItem) | Overloaded. Represents method IndexOf(TDataItem).
Insert(TDataItem,Integer) | Represents method Insert(TDataItem,Integer).
Remove(TDataItem) | Represents method Remove(TDataItem).
Subtract(TDataArray) | Overloaded. Represents method Subtract(TDataArray).
Subtract(TDataItem) | Overloaded. Represents method Subtract(TDataItem).
Top


TDataArrayHelper.Add(TDataArray) Method

Summary

Represents method Add(TDataArray).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Add(const AData:TDataArray); overload;

Parameters

AData
Type: TDataArray

See Also

Reference

  • TDataArrayHelper
  • BI.DataItem


TDataArrayHelper.Add(TDataItem) Method

Summary

Represents method Add(TDataItem).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Add(const AData:TDataItem); overload;

Parameters

AData
Type: TDataItem

See Also

Reference

  • TDataArrayHelper
  • BI.DataItem


TDataArrayHelper.Clear Method

Summary

Represents method Clear.

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Clear; inline;
See Also

Reference

  • TDataArrayHelper
  • BI.DataItem


TDataArrayHelper.Copy Method

Summary

Represents method Copy.

Namespace: BI.DataItem
Syntax
Delphi
public
 function Copy:TDataArray;

Return Value

Type: TDataArray

See Also

Reference

  • TDataArrayHelper
  • BI.DataItem


TDataArrayHelper.Count Method

Summary

Represents method Count.

Namespace: BI.DataItem
Syntax
Delphi
public
 function Count:Integer; inline;

Return Value

Type: Integer

See Also

Reference

  • TDataArrayHelper
  • BI.DataItem


TDataArrayHelper.Delete(Integer) Method

Summary

Represents method Delete(Integer).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Delete(const Index:Integer);

Parameters

Index
Type: Integer

See Also

Reference

  • TDataArrayHelper
  • BI.DataItem


TDataArrayHelper.Equal(TDataArray) Method

Summary

Represents method Equal(TDataArray).

Namespace: BI.DataItem
Syntax
Delphi
public
 function Equal(const Value:TDataArray):Boolean;

Parameters

Value
Type: TDataArray

Return Value

Type: Boolean

See Also

Reference

  • TDataArrayHelper
  • BI.DataItem


TDataArrayHelper.Exchange(Integer,Integer) Method

Summary

Represents method Exchange(Integer,Integer).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Exchange(const A,B:Integer);

Parameters

A
Type: Integer

B
Type: Integer

See Also

Reference

  • TDataArrayHelper
  • BI.DataItem


TDataArrayHelper.Exists(TDataItem) Method

Summary

Represents method Exists(TDataItem).

Namespace: BI.DataItem
Syntax
Delphi
public
 function Exists(const AData:TDataItem):Boolean; inline;

Parameters

AData
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • TDataArrayHelper
  • BI.DataItem


TDataArrayHelper.Find(String) Method

Summary

Represents method Find(String).

Namespace: BI.DataItem
Syntax
Delphi
public
 function Find(const AName:String):TDataItem;

Parameters

AName
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TDataArrayHelper
  • BI.DataItem


TDataArrayHelper.FreeAll Method

Summary

Represents method FreeAll.

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure FreeAll;
See Also

Reference

  • TDataArrayHelper
  • BI.DataItem


TDataArrayHelper.IndexOf(String) Method

Summary

Represents method IndexOf(String).

Namespace: BI.DataItem
Syntax
Delphi
public
 function IndexOf(const AName:String):Integer; overload;

Parameters

AName
Type: String

Return Value

Type: Integer

See Also

Reference

  • TDataArrayHelper
  • BI.DataItem


TDataArrayHelper.IndexOf(TDataItem) Method

Summary

Represents method IndexOf(TDataItem).

Namespace: BI.DataItem
Syntax
Delphi
public
 function IndexOf(const AData:TDataItem):Integer; overload;

Parameters

AData
Type: TDataItem

Return Value

Type: Integer

See Also

Reference

  • TDataArrayHelper
  • BI.DataItem


TDataArrayHelper.Insert(TDataItem,Integer) Method

Summary

Represents method Insert(TDataItem,Integer).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Insert(const AData:TDataItem; const AIndex:Integer);

Parameters

AData
Type: TDataItem

AIndex
Type: Integer

See Also

Reference

  • TDataArrayHelper
  • BI.DataItem


TDataArrayHelper.Remove(TDataItem) Method

Summary

Represents method Remove(TDataItem).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Remove(const AData:TDataItem);

Parameters

AData
Type: TDataItem

See Also

Reference

  • TDataArrayHelper
  • BI.DataItem


TDataArrayHelper.Subtract(TDataArray) Method

Summary

Represents method Subtract(TDataArray).

Namespace: BI.DataItem
Syntax
Delphi
public
 function Subtract(const AItems:TDataArray):TDataArray; overload;

Parameters

AItems
Type: TDataArray

Return Value

Type: TDataArray

See Also

Reference

  • TDataArrayHelper
  • BI.DataItem


TDataArrayHelper.Subtract(TDataItem) Method

Summary

Represents method Subtract(TDataItem).

Namespace: BI.DataItem
Syntax
Delphi
public
 function Subtract(const AItem:TDataItem):TDataArray; overload;

Parameters

AItem
Type: TDataItem

Return Value

Type: TDataArray

See Also

Reference

  • TDataArrayHelper
  • BI.DataItem


TDataItem Class

Summary

Represents type TDataItem.

Namespace: BI.DataItem
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Algorithm.DecisionTree.TDataAccess
BI.Algorithm.Model.TPredictedData
BI.Algorithm.TDataAccess
BI.CollectionItem.TDataAccess
BI.Compare.TBaseDifferences
BI.Compare.TDataDifferences
BI.Compare.TDataItemAccess
BI.Compare.TDifference
BI.Convert.TDataItemAccess
BI.CSV.TDataAccess
BI.Dashboard.TDataAccess
BI.DataItem.TDetailData
BI.Dataset.TDataAccess
BI.DataSource.TDataAccess
BI.DataSource.TDataItemAccess
BI.DB.Dataset.TDataAccess
BI.DB.Fire.TDataAccess
BI.DB.microOLAP.TDataAccess
BI.DB.TDataAccess
BI.DB.ZeosLib.TDataAccess
BI.Expressions.TDataAccess
BI.Expressions.TExpressionColumn
BI.Geographic.TDataItemAccess
BI.GuessLinks.TDataItemAccess
BI.Html.TDataAccess
BI.Html.TDataItemAccess
BI.Info.TDataAccess
BI.Info.TDataInfo
BI.JSON.TDataAccess
BI.Merge.TDataItemAccess
BI.Persist.TDataAccess
BI.Persist.TDataItemAccess
BI.Plugins.Python.TDataAccess
BI.Plugins.R.opaR.TDataAccess
BI.Query.TDataAccess
BI.SingleRecord.TDataItemAccess
BI.Store.Component.TDataAccess
BI.Summary.TDataAccess
BI.Summary.TDataItemAccess
BI.Summary.Totals.TDataItemAccess
BI.Tools.TDataAccess
BI.Verify.TDataAccess
BI.Web.TBIWebHistory
BI.Web.TDataItemAccess
BI.Workflow.TDataAccess
BI.XMLData.TDataAccess
FMXBI.Chart.Financial.TDataItemAccess
FMXBI.Chart.Geo.TDataAccess
FMXBI.Chart.Plugin.TDataAccess
FMXBI.Chart.TDataItemAccess
FMXBI.ChartFunctions.TDataAccess
FMXBI.DataControl.TDataAccess
FMXBI.Editor.Column.TDataItemAccess
FMXBI.Grid.Grid.TDataAccess
VCLBI.Chart.Financial.TDataItemAccess
VCLBI.Chart.Geo.TDataAccess
VCLBI.Chart.Plugin.TDataAccess
VCLBI.Chart.TDataItemAccess
VCLBI.ChartFunctions.TDataAccess
VCLBI.DataControl.TDataAccess
VCLBI.DataManager.TDataAcess
VCLBI.DataSelect.TDataAccess
VCLBI.DataViewer.TDataAccess
VCLBI.Editor.DataComponent.TDataItemAccess
VCLBI.Editor.DynamicFilter.TDataAccess
VCLBI.Grid.DBGrid.TDataAccess
VCLBI.Grid.TDataItemAccess
VCLBI.LinkDiagram.TDataAccess
VCLBI.NewColumn.TDataAccess
Syntax
Delphi
type
 TDataItem=class
 end;

The TDataItem type exposes the following members.

Constructors
Show:
Name | Description
Create(Boolean) | Overloaded. Initializes a new instance of the TDataItem class.
Create(TDataArray) | Overloaded. Initializes a new instance of the TDataItem class.
Create(TDataKind) | Overloaded. Initializes a new instance of the TDataItem class.
Create(TDataKind,String) | Overloaded. Initializes a new instance of the TDataItem class.
Create(TDataProvider) | Overloaded. Initializes a new instance of the TDataItem class.
Destroy | Represents the destructor of the TDataItem class.
Top
Properties
Show:
Name | Description
Count | Represents property Count.
DataMap | Represents property DataMap.
History | Represents property History.
Items | Represents property Items.
Item[Integer] | Represents property Item[Integer].
Item[String] | Represents property Item[String].
Kind | Represents property Kind.
Master | Represents property Master.
Name | Represents property Name.
Parent | Represents property Parent.
Provider | Represents property Provider.
Stats | Represents property Stats.
Unique | Represents property Unique.
Top
Methods
Show:
Name | Description
CheckEmptyName | Represents method CheckEmptyName.
Clear | Represents method Clear.
ClearData(Boolean) | Represents method ClearData(Boolean).
ClearDelay | Represents method ClearDelay.
CloneData(TDataItem,TInteger,TInteger) | Represents method CloneData(TDataItem,TInteger,TInteger).
Compare(TInteger,TInteger,Boolean) | Represents method Compare(TInteger,TInteger,Boolean).
CopyFrom(TInteger,TDataItem,TInteger) | Overloaded. Represents method CopyFrom(TInteger,TDataItem,TInteger).
CopyFrom(TInteger,TDataMap,TInteger) | Overloaded. Represents method CopyFrom(TInteger,TDataMap,TInteger).
CreateIndexMulti(TDataArray) | Represents method CreateIndexMulti(TDataArray).
CreateMap(TDataKind) | Represents method CreateMap(TDataKind).
CreateMasterIndex | Represents method CreateMasterIndex.
CreateStats | Represents method CreateStats.
DataToString(TInteger) | Overloaded. Represents method DataToString(TInteger).
Delete(TInteger,TInteger) | Represents method Delete(TInteger,TInteger).
EqualsMap(TInteger,TInteger) | Represents method EqualsMap(TInteger,TInteger).
ExistsBefore(TInteger) | Represents method ExistsBefore(TInteger).
FindInMap(TInteger,TNativeInteger) | Represents method FindInMap(TInteger,TNativeInteger).
Finish | Represents method Finish.
FullName | Represents method FullName.
GetProvider | Represents method GetProvider.
HasItems | Represents method HasItems.
HasMaster | Represents method HasMaster.
Insert(TInteger,Boolean) | Represents method Insert(TInteger,Boolean).
IsChildOf(TDataItem) | Represents method IsChildOf(TDataItem).
Load | Overloaded. Represents method Load.
Load(Boolean) | Overloaded. Represents method Load(Boolean).
LoadFromFile(String) | Represents method LoadFromFile(String).
MaxTextLength | Represents method MaxTextLength.
ReCalculate(Boolean) | Represents method ReCalculate(Boolean).
Resize(TInteger) | Represents method Resize(TInteger).
SameData(TInteger,TInteger) | Represents method SameData(TInteger,TInteger).
SaveToFile(String) | Represents method SaveToFile(String).
SetInternalDate(TDateTimePart) | Represents method SetInternalDate(TDateTimePart).
SortBy(TDataItem,Boolean,Boolean) | Overloaded. Represents method SortBy(TDataItem,Boolean,Boolean).
SortBy(TSortItem) | Overloaded. Represents method SortBy(TSortItem).
SwapRows(TInteger,TInteger) | Represents method SwapRows(TInteger,TInteger).
TotalColumns | Represents method TotalColumns.
TotalRows | Represents method TotalRows.
UnLoadData(Boolean) | Represents method UnLoadData(Boolean).
Top
Fields
Show:
Name | Description
AsTable | Represents field AsTable.
BooleanData | Represents field BooleanData.
DateTimeData | Represents field DateTimeData.
DelayPos | Represents field DelayPos.
DoubleData | Represents field DoubleData.
ExtendedData | Represents field ExtendedData.
FConsumers | Represents field FConsumers.
FCount | Represents field FCount.
FDataMap | Represents field FDataMap.
FKind | Represents field FKind.
FParent | Represents field FParent.
FStats | Represents field FStats.
FUnique | Represents field FUnique.
IDate | Represents field IDate.
IHasDate | Represents field IHasDate.
IMaster | Represents field IMaster.
IMaxTextLength | Represents field IMaxTextLength.
Int32Data | Represents field Int32Data.
Int64Data | Represents field Int64Data.
KeepProvider | Represents field KeepProvider.
LastAccess | Represents field LastAccess.
Missing | Represents field Missing.
NumericValues | Represents field NumericValues.
ParentGroup | Represents field ParentGroup.
Primary | Represents field Primary.
SavedDelayPos | Represents field SavedDelayPos.
SingleData | Represents field SingleData.
TagObject | Represents field TagObject.
TextData | Represents field TextData.
UsedMemory | Represents field UsedMemory.
Top
See Also

Reference

  • BI.DataItem


TDataItem Constructors

Constructors
Name | Description
Create(Boolean) | Overloaded. Initializes a new instance of the TDataItem class.
Create(TDataArray) | Overloaded. Initializes a new instance of the TDataItem class.
Create(TDataKind) | Overloaded. Initializes a new instance of the TDataItem class.
Create(TDataKind,String) | Overloaded. Initializes a new instance of the TDataItem class.
Create(TDataProvider) | Overloaded. Initializes a new instance of the TDataItem class.
Destroy | Represents the destructor of the TDataItem class.
Top


TDataItem.Create(Boolean) Constructor

Summary

Initializes a new instance of the TDataItem class.

Namespace: BI.DataItem
Syntax
Delphi
public
 Constructor Create(const Table:Boolean=False); overload; virtual;

Parameters

Table
Type: Boolean

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Create(TDataArray) Constructor

Summary

Initializes a new instance of the TDataItem class.

Namespace: BI.DataItem
Syntax
Delphi
public
 Constructor Create(const AData:TDataArray); overload;

Parameters

AData
Type: TDataArray

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Create(TDataKind) Constructor

Summary

Initializes a new instance of the TDataItem class.

Namespace: BI.DataItem
Syntax
Delphi
public
 Constructor Create(const AKind: TDataKind); overload;

Parameters

AKind
Type: TDataKind

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Create(TDataKind,String) Constructor

Summary

Initializes a new instance of the TDataItem class.

Namespace: BI.DataItem
Syntax
Delphi
public
 Constructor Create(const AKind: TDataKind; const AName:String); overload;

Parameters

AKind
Type: TDataKind

AName
Type: String

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Create(TDataProvider) Constructor

Summary

Initializes a new instance of the TDataItem class.

Namespace: BI.DataItem
Syntax
Delphi
public
 Constructor Create(const AProvider:TDataProvider); overload;

Parameters

AProvider
Type: TDataProvider

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Destroy Destructor

Summary

Represents the destructor of the TDataItem class.

Namespace: BI.DataItem
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem Properties

Properties
Name | Description
Count | Represents property Count.
DataMap | Represents property DataMap.
History | Represents property History.
Items | Represents property Items.
Item[Integer] | Represents property Item[Integer].
Item[String] | Represents property Item[String].
Kind | Represents property Kind.
Master | Represents property Master.
Name | Represents property Name.
Parent | Represents property Parent.
Provider | Represents property Provider.
Stats | Represents property Stats.
Unique | Represents property Unique.
Top


TDataItem.Count Property

Summary

Represents property Count.

Namespace: BI.DataItem
Syntax
Delphi
public
 property Count:TInteger read FCount;

Property Value

Type: TInteger

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.DataMap Property

Summary

Represents property DataMap.

Namespace: BI.DataItem
Syntax
Delphi
public
 property DataMap:TDataMap read FDataMap;

Property Value

Type: TDataMap

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.History Property

Summary

Represents property History.

Namespace: BI.DataItem
Syntax
Delphi
public
 property History:TImportHistory read GetHistory;

Property Value

Type: TImportHistory

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Items Property

Summary

Represents property Items.

Namespace: BI.DataItem
Syntax
Delphi
public
 property Items:TDataItems read GetItems;

Property Value

Type: TDataItems

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Item[Integer] Property

Summary

Represents property Item[Integer].

Namespace: BI.DataItem
Syntax
Delphi
public
 property Item[const Index:Integer]:TDataItem read GetItemByIndex; default;

Parameters

Index
Type: Integer

Property Value

Type: TDataItem

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Item[String] Property

Summary

Represents property Item[String].

Namespace: BI.DataItem
Syntax
Delphi
public
 [HPPGEN('__property TDataItem* Item2[const System::UnicodeString Name] = {read=GetItem/*, default*/};'+
 sLineBreak+
 'TDataItem* operator[](const System::UnicodeString Name) { return this->Item2[Name]; }'
 )]
 property Item[const Name:String]:TDataItem read GetItem; default;

Parameters

Name
Type: String

Property Value

Type: TDataItem

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Kind Property

Summary

Represents property Kind.

Namespace: BI.DataItem
Syntax
Delphi
public
 property Kind:TDataKind read FKind;

Property Value

Type: TDataKind

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Master Property

Summary

Represents property Master.

Namespace: BI.DataItem
Syntax
Delphi
public
 property Master:TDataItem read GetMaster write SetMaster;

Property Value

Type: TDataItem

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Name Property

Summary

Represents property Name.

Namespace: BI.DataItem
Syntax
Delphi
public
 property Name:String read FName write SetName;

Property Value

Type: String

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Parent Property

Summary

Represents property Parent.

Namespace: BI.DataItem
Syntax
Delphi
public
 property Parent:TDataItem read FParent;

Property Value

Type: TDataItem

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Provider Property

Summary

Represents property Provider.

Namespace: BI.DataItem
Syntax
Delphi
public
 property Provider:TDataProvider read FProvider write SetProvider;

Property Value

Type: TDataProvider

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Stats Property

Summary

Represents property Stats.

Namespace: BI.DataItem
Syntax
Delphi
public
 property Stats:TDataStats read GetStats;

Property Value

Type: TDataStats

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Unique Property

Summary

Represents property Unique.

Namespace: BI.DataItem
Syntax
Delphi
public
 property Unique:Boolean read FUnique;

Property Value

Type: Boolean

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem Methods

Methods
Name | Description
CheckEmptyName | Represents method CheckEmptyName.
Clear | Represents method Clear.
ClearData(Boolean) | Represents method ClearData(Boolean).
ClearDelay | Represents method ClearDelay.
CloneData(TDataItem,TInteger,TInteger) | Represents method CloneData(TDataItem,TInteger,TInteger).
Compare(TInteger,TInteger,Boolean) | Represents method Compare(TInteger,TInteger,Boolean).
CopyFrom(TInteger,TDataItem,TInteger) | Overloaded. Represents method CopyFrom(TInteger,TDataItem,TInteger).
CopyFrom(TInteger,TDataMap,TInteger) | Overloaded. Represents method CopyFrom(TInteger,TDataMap,TInteger).
CreateIndexMulti(TDataArray) | Represents method CreateIndexMulti(TDataArray).
CreateMap(TDataKind) | Represents method CreateMap(TDataKind).
CreateMasterIndex | Represents method CreateMasterIndex.
CreateStats | Represents method CreateStats.
DataToString(TInteger) | Overloaded. Represents method DataToString(TInteger).
Delete(TInteger,TInteger) | Represents method Delete(TInteger,TInteger).
EqualsMap(TInteger,TInteger) | Represents method EqualsMap(TInteger,TInteger).
ExistsBefore(TInteger) | Represents method ExistsBefore(TInteger).
FindInMap(TInteger,TNativeInteger) | Represents method FindInMap(TInteger,TNativeInteger).
Finish | Represents method Finish.
FullName | Represents method FullName.
GetProvider | Represents method GetProvider.
HasItems | Represents method HasItems.
HasMaster | Represents method HasMaster.
Insert(TInteger,Boolean) | Represents method Insert(TInteger,Boolean).
IsChildOf(TDataItem) | Represents method IsChildOf(TDataItem).
Load | Overloaded. Represents method Load.
Load(Boolean) | Overloaded. Represents method Load(Boolean).
LoadFromFile(String) | Represents method LoadFromFile(String).
MaxTextLength | Represents method MaxTextLength.
ReCalculate(Boolean) | Represents method ReCalculate(Boolean).
Resize(TInteger) | Represents method Resize(TInteger).
SameData(TInteger,TInteger) | Represents method SameData(TInteger,TInteger).
SaveToFile(String) | Represents method SaveToFile(String).
SetInternalDate(TDateTimePart) | Represents method SetInternalDate(TDateTimePart).
SortBy(TDataItem,Boolean,Boolean) | Overloaded. Represents method SortBy(TDataItem,Boolean,Boolean).
SortBy(TSortItem) | Overloaded. Represents method SortBy(TSortItem).
SwapRows(TInteger,TInteger) | Represents method SwapRows(TInteger,TInteger).
TotalColumns | Represents method TotalColumns.
TotalRows | Represents method TotalRows.
UnLoadData(Boolean) | Represents method UnLoadData(Boolean).
Top


TDataItem.CheckEmptyName Method

Summary

Represents method CheckEmptyName.

Namespace: BI.DataItem
Syntax
Delphi
protected
 procedure CheckEmptyName;
See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Clear Method

Summary

Represents method Clear.

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.ClearData(Boolean) Method

Summary

Represents method ClearData(Boolean).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure ClearData(const Recursive:Boolean=False);

Parameters

Recursive
Type: Boolean

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.ClearDelay Method

Summary

Represents method ClearDelay.

Namespace: BI.DataItem
Syntax
Delphi
protected
 procedure ClearDelay;
See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.CloneData(TDataItem,TInteger,TInteger) Method

Summary

Represents method CloneData(TDataItem,TInteger,TInteger).

Namespace: BI.DataItem
Syntax
Delphi
protected
 procedure CloneData(const ASource:TDataItem; const AStart,ACount:TInteger);

Parameters

ASource
Type: TDataItem

AStart
Type: System.Void

ACount
Type: System.Void

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Compare(TInteger,TInteger,Boolean) Method

Summary

Represents method Compare(TInteger,TInteger,Boolean).

Namespace: BI.DataItem
Syntax
Delphi
public
 function Compare(const A,B:TInteger; const IgnoreTextCase:Boolean=False):Integer;

Parameters

A
Type: System.Void

B
Type: System.Void

IgnoreTextCase
Type: Boolean

Return Value

Type: Integer

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.CopyFrom(TInteger,TDataItem,TInteger) Method

Summary

Represents method CopyFrom(TInteger,TDataItem,TInteger).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure CopyFrom(const DestIndex:TInteger;
 const Source:TDataItem;
 const SourceIndex:TInteger); overload;

Parameters

DestIndex
Type: System.Void

Source
Type: TDataItem

SourceIndex
Type: System.Void

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.CopyFrom(TInteger,TDataMap,TInteger) Method

Summary

Represents method CopyFrom(TInteger,TDataMap,TInteger).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure CopyFrom(const DestIndex:TInteger;
 const Source:TDataMap;
 const SourceIndex:TInteger); overload;

Parameters

DestIndex
Type: System.Void

Source
Type: TDataMap

SourceIndex
Type: System.Void

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.CreateIndexMulti(TDataArray) Method

Summary

Represents method CreateIndexMulti(TDataArray).

Namespace: BI.DataItem
Syntax
Delphi
public
 class function CreateIndexMulti(const Items:TDataArray):TNativeIntArray; static;

Parameters

Items
Type: TDataArray

Return Value

Type: TNativeIntArray

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.CreateMap(TDataKind) Method

Summary

Represents method CreateMap(TDataKind).

Namespace: BI.DataItem
Syntax
Delphi
protected
 class function CreateMap(const AKind:TDataKind):TDataMap;

Parameters

AKind
Type: TDataKind

Return Value

Type: TDataMap

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.CreateMasterIndex Method

Summary

Represents method CreateMasterIndex.

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure CreateMasterIndex;
See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.CreateStats Method

Summary

Represents method CreateStats.

Namespace: BI.DataItem
Syntax
Delphi
protected
 function CreateStats:TDataStats;

Return Value

Type: TDataStats

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.DataToString(TInteger) Method

Summary

Represents method DataToString(TInteger).

Namespace: BI.DataItem
Syntax
Delphi
public
 function DataToString(const Index:TInteger):String; overload;

Parameters

Index
Type: System.Void

Return Value

Type: String

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Delete(TInteger,TInteger) Method

Summary

Represents method Delete(TInteger,TInteger).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Delete(const Row:TInteger; const ACount:TInteger=1);

Parameters

Row
Type: System.Void

ACount
Type: System.Void

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.EqualsMap(TInteger,TInteger) Method

Summary

Represents method EqualsMap(TInteger,TInteger).

Namespace: BI.DataItem
Syntax
Delphi
public
 function EqualsMap(const A,B:TInteger):Boolean;

Parameters

A
Type: System.Void

B
Type: System.Void

Return Value

Type: Boolean

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.ExistsBefore(TInteger) Method

Summary

Represents method ExistsBefore(TInteger).

Namespace: BI.DataItem
Syntax
Delphi
protected
 function ExistsBefore(const AIndex:TInteger):Boolean;

Parameters

AIndex
Type: System.Void

Return Value

Type: Boolean

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.FindInMap(TInteger,TNativeInteger) Method

Summary

Represents method FindInMap(TInteger,TNativeInteger).

Namespace: BI.DataItem
Syntax
Delphi
public
 function FindInMap(const Index:TInteger; out ABin:TNativeInteger):Boolean;

Parameters

Index
Type: System.Void

ABin
Type: System.Void

Return Value

Type: Boolean

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Finish Method

Summary

Represents method Finish.

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Finish;
See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.FullName Method

Summary

Represents method FullName.

Namespace: BI.DataItem
Syntax
Delphi
public
 function FullName:String;

Return Value

Type: String

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.GetProvider Method

Summary

Represents method GetProvider.

Namespace: BI.DataItem
Syntax
Delphi
protected
 function GetProvider:TDataProvider;

Return Value

Type: TDataProvider

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.HasItems Method

Summary

Represents method HasItems.

Namespace: BI.DataItem
Syntax
Delphi
protected
 function HasItems:Boolean; inline;

Return Value

Type: Boolean

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.HasMaster Method

Summary

Represents method HasMaster.

Namespace: BI.DataItem
Syntax
Delphi
protected
 function HasMaster:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Insert(TInteger,Boolean) Method

Summary

Represents method Insert(TInteger,Boolean).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Insert(const AtIndex:TInteger; const AMissing:Boolean=True);

Parameters

AtIndex
Type: System.Void

AMissing
Type: Boolean

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.IsChildOf(TDataItem) Method

Summary

Represents method IsChildOf(TDataItem).

Namespace: BI.DataItem
Syntax
Delphi
public
 function IsChildOf(const AParent:TDataItem):Boolean;

Parameters

AParent
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Load Method

Summary

Represents method Load.

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Load; overload; inline;
See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Load(Boolean) Method

Summary

Represents method Load(Boolean).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Load(const Children:Boolean); overload; virtual;

Parameters

Children
Type: Boolean

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.LoadFromFile(String) Method

Summary

Represents method LoadFromFile(String).

Namespace: BI.DataItem
Syntax
Delphi
public
 class function LoadFromFile(const AFileName:String):TDataItem; inline;

Parameters

AFileName
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.MaxTextLength Method

Summary

Represents method MaxTextLength.

Namespace: BI.DataItem
Syntax
Delphi
protected
 function MaxTextLength:Integer;

Return Value

Type: Integer

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.ReCalculate(Boolean) Method

Summary

Represents method ReCalculate(Boolean).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure ReCalculate(const Parallel:Boolean=False); virtual;

Parameters

Parallel
Type: Boolean

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Resize(TInteger) Method

Summary

Represents method Resize(TInteger).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Resize(const Size:TInteger);

Parameters

Size
Type: System.Void

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.SameData(TInteger,TInteger) Method

Summary

Represents method SameData(TInteger,TInteger).

Namespace: BI.DataItem
Syntax
Delphi
public
 function SameData(const A,B:TInteger):Boolean;

Parameters

A
Type: System.Void

B
Type: System.Void

Return Value

Type: Boolean

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.SaveToFile(String) Method

Summary

Represents method SaveToFile(String).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure SaveToFile(const AFileName:String); inline;

Parameters

AFileName
Type: String

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.SetInternalDate(TDateTimePart) Method

Summary

Represents method SetInternalDate(TDateTimePart).

Namespace: BI.DataItem
Syntax
Delphi
protected
 procedure SetInternalDate(const ADate:TDateTimePart);

Parameters

ADate
Type: TDateTimePart

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.SortBy(TDataItem,Boolean,Boolean) Method

Summary

Represents method SortBy(TDataItem,Boolean,Boolean).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure SortBy(const AData: TDataItem;
 const Ascending: Boolean=True;
 const IgnoreTextCase:Boolean=False); overload;

Parameters

AData
Type: TDataItem

Ascending
Type: Boolean

IgnoreTextCase
Type: Boolean

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.SortBy(TSortItem) Method

Summary

Represents method SortBy(TSortItem).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure SortBy(const ASort: TSortItem); overload;

Parameters

ASort
Type: TSortItem

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.SwapRows(TInteger,TInteger) Method

Summary

Represents method SwapRows(TInteger,TInteger).

Namespace: BI.DataItem
Syntax
Delphi
protected
 procedure SwapRows(const A,B:TInteger);

Parameters

A
Type: System.Void

B
Type: System.Void

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.TotalColumns Method

Summary

Represents method TotalColumns.

Namespace: BI.DataItem
Syntax
Delphi
public
 function TotalColumns: TInteger;

Return Value

Type: TInteger

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.TotalRows Method

Summary

Represents method TotalRows.

Namespace: BI.DataItem
Syntax
Delphi
public
 function TotalRows: TInteger;

Return Value

Type: TInteger

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.UnLoadData(Boolean) Method

Summary

Represents method UnLoadData(Boolean).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure UnLoadData(const InvalidItems:Boolean=False); virtual;

Parameters

InvalidItems
Type: Boolean

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem Fields

Fields
Name | Description
AsTable | Represents field AsTable.
BooleanData | Represents field BooleanData.
DateTimeData | Represents field DateTimeData.
DelayPos | Represents field DelayPos.
DoubleData | Represents field DoubleData.
ExtendedData | Represents field ExtendedData.
FConsumers | Represents field FConsumers.
FCount | Represents field FCount.
FDataMap | Represents field FDataMap.
FKind | Represents field FKind.
FParent | Represents field FParent.
FStats | Represents field FStats.
FUnique | Represents field FUnique.
IDate | Represents field IDate.
IHasDate | Represents field IHasDate.
IMaster | Represents field IMaster.
IMaxTextLength | Represents field IMaxTextLength.
Int32Data | Represents field Int32Data.
Int64Data | Represents field Int64Data.
KeepProvider | Represents field KeepProvider.
LastAccess | Represents field LastAccess.
Missing | Represents field Missing.
NumericValues | Represents field NumericValues.
ParentGroup | Represents field ParentGroup.
Primary | Represents field Primary.
SavedDelayPos | Represents field SavedDelayPos.
SingleData | Represents field SingleData.
TagObject | Represents field TagObject.
TextData | Represents field TextData.
UsedMemory | Represents field UsedMemory.
Top


TDataItem.AsTable Field

Summary

Represents field AsTable.

Namespace: BI.DataItem
Syntax
Delphi
public
 AsTable : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.BooleanData Field

Summary

Represents field BooleanData.

Namespace: BI.DataItem
Syntax
Delphi
public
 BooleanData : TBooleanArray;

Field Value

Type: TBooleanArray

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.DateTimeData Field

Summary

Represents field DateTimeData.

Namespace: BI.DataItem
Syntax
Delphi
public
 DateTimeData : TDateTimeArray;

Field Value

Type: TDateTimeArray

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.DelayPos Field

Summary

Represents field DelayPos.

Namespace: BI.DataItem
Syntax
Delphi
protected
 SavedDelayPos,
 DelayPos : Int64;

Field Value

Type: Int64

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.DoubleData Field

Summary

Represents field DoubleData.

Namespace: BI.DataItem
Syntax
Delphi
public
 DoubleData : TDoubleArray;

Field Value

Type: TDoubleArray

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.ExtendedData Field

Summary

Represents field ExtendedData.

Namespace: BI.DataItem
Syntax
Delphi
public
 ExtendedData : TExtendedArray;

Field Value

Type: TExtendedArray

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.FConsumers Field

Summary

Represents field FConsumers.

Namespace: BI.DataItem
Syntax
Delphi
protected
 FConsumers : TBIConsumers;

Field Value

Type: TBIConsumers

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.FCount Field

Summary

Represents field FCount.

Namespace: BI.DataItem
Syntax
Delphi
protected
 FCount : TInteger;

Field Value

Type: TInteger

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.FDataMap Field

Summary

Represents field FDataMap.

Namespace: BI.DataItem
Syntax
Delphi
protected
 FDataMap : TDataMap;

Field Value

Type: TDataMap

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.FKind Field

Summary

Represents field FKind.

Namespace: BI.DataItem
Syntax
Delphi
protected
 FKind : TDataKind;

Field Value

Type: TDataKind

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.FParent Field

Summary

Represents field FParent.

Namespace: BI.DataItem
Syntax
Delphi
protected
 FParent : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.FStats Field

Summary

Represents field FStats.

Namespace: BI.DataItem
Syntax
Delphi
protected
 FStats : TDataStats;

Field Value

Type: TDataStats

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.FUnique Field

Summary

Represents field FUnique.

Namespace: BI.DataItem
Syntax
Delphi
protected
 FUnique : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.IDate Field

Summary

Represents field IDate.

Namespace: BI.DataItem
Syntax
Delphi
protected
 IDate : TDateTimePart;

Field Value

Type: TDateTimePart

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.IHasDate Field

Summary

Represents field IHasDate.

Namespace: BI.DataItem
Syntax
Delphi
protected
 IHasDate : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.IMaster Field

Summary

Represents field IMaster.

Namespace: BI.DataItem
Syntax
Delphi
protected
 IMaster : TMasterDetail;

Field Value

Type: TMasterDetail

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.IMaxTextLength Field

Summary

Represents field IMaxTextLength.

Namespace: BI.DataItem
Syntax
Delphi
protected
 IMaxTextLength : Integer;

Field Value

Type: Integer

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Int32Data Field

Summary

Represents field Int32Data.

Namespace: BI.DataItem
Syntax
Delphi
public
 Int32Data : TInt32Array;

Field Value

Type: TInt32Array

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Int64Data Field

Summary

Represents field Int64Data.

Namespace: BI.DataItem
Syntax
Delphi
public
 Int64Data : TInt64Array;

Field Value

Type: TInt64Array

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.KeepProvider Field

Summary

Represents field KeepProvider.

Namespace: BI.DataItem
Syntax
Delphi
protected
 KeepProvider : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.LastAccess Field

Summary

Represents field LastAccess.

Namespace: BI.DataItem
Syntax
Delphi
public
 LastAccess : TDateTime;

Field Value

Type: TDateTime

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Missing Field

Summary

Represents field Missing.

Namespace: BI.DataItem
Syntax
Delphi
public
 Missing : TMissingData;

Field Value

Type: TMissingData

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.NumericValues Field

Summary

Represents field NumericValues.

Namespace: BI.DataItem
Syntax
Delphi
public
 NumericValues : TNumericData;

Field Value

Type: TNumericData

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.ParentGroup Field

Summary

Represents field ParentGroup.

Namespace: BI.DataItem
Syntax
Delphi
public
 ParentGroup : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.Primary Field

Summary

Represents field Primary.

Namespace: BI.DataItem
Syntax
Delphi
public
 Primary : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.SavedDelayPos Field

Summary

Represents field SavedDelayPos.

Namespace: BI.DataItem
Syntax
Delphi
protected
 SavedDelayPos,
 DelayPos : Int64;

Field Value

Type: Int64

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.SingleData Field

Summary

Represents field SingleData.

Namespace: BI.DataItem
Syntax
Delphi
public
 SingleData : TSingleArray;

Field Value

Type: TSingleArray

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.TagObject Field

Summary

Represents field TagObject.

Namespace: BI.DataItem
Syntax
Delphi
protected
 TagObject : TObject;

Field Value

Type: TObject

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.TextData Field

Summary

Represents field TextData.

Namespace: BI.DataItem
Syntax
Delphi
public
 TextData : TTextArray;

Field Value

Type: TTextArray

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItem.UsedMemory Field

Summary

Represents field UsedMemory.

Namespace: BI.DataItem
Syntax
Delphi
public
 UsedMemory : Cardinal;

Field Value

Type: Cardinal

See Also

Reference

  • TDataItem
  • BI.DataItem


TDataItems Class

Summary

Represents type TDataItems.

Namespace: BI.DataItem
Inheritance Hierarchy
TObject
BI.DataItem.TDataItems
BI.Convert.TDataItemsAccess
BI.CSV.TDataItemsAccess
BI.DataSource.TDataItemsAccess
BI.Persist.TDataItemsAccess
Syntax
Delphi
type
 TDataItems=class
 end;

The TDataItems type exposes the following members.

Constructors
Show:
Name | Description
Create(TDataItem) | Initializes a new instance of the TDataItems class.
Destroy | Represents the destructor of the TDataItems class.
Top
Properties
Show:
Name | Description
AsArray | Represents property AsArray.
Item[Integer] | Represents property Item[Integer].
Last | Represents property Last.
Names[String] | Represents property Names[String].
Parent | Represents property Parent.
Top
Methods
Show:
Name | Description
Add(String,TDataKind,TObject) | Overloaded. Represents method Add(String,TDataKind,TObject).
Add(TDataItem) | Overloaded. Represents method Add(TDataItem).
AddDirect(TDataItem) | Represents method AddDirect(TDataItem).
Clear | Represents method Clear.
Count | Represents method Count.
Delete(TDataItem) | Represents method Delete(TDataItem).
DestroyAll | Represents method DestroyAll.
DoChanged | Represents method DoChanged.
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer).
Exists(String) | Represents method Exists(String).
Find(String) | Represents method Find(String).
GetEmptyName | Represents method GetEmptyName.
IndexOf(String) | Represents method IndexOf(String).
Insert(TDataItem,Integer) | Represents method Insert(TDataItem,Integer).
New(String,TDataKind,TObject) | Represents method New(String,TDataKind,TObject).
Resize(TInteger) | Represents method Resize(TInteger).
Reverse | Represents method Reverse.
Select(Integer,Integer) | Overloaded. Represents method Select(Integer,Integer).
Select(Integer[]) | Overloaded. Represents method Select(Integer[]).
SortByName(Boolean,Boolean) | Represents method SortByName(Boolean,Boolean).
UniqueName(String) | Represents method UniqueName(String).
Top
Fields
Show:
Name | Description
Valid | Represents field Valid.
Top
See Also

Reference

  • BI.DataItem


TDataItems Constructors

Constructors
Name | Description
Create(TDataItem) | Initializes a new instance of the TDataItems class.
Destroy | Represents the destructor of the TDataItems class.
Top


TDataItems.Create(TDataItem) Constructor

Summary

Initializes a new instance of the TDataItems class.

Namespace: BI.DataItem
Syntax
Delphi
public
 Constructor Create(const AParent:TDataItem);

Parameters

AParent
Type: TDataItem

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.Destroy Destructor

Summary

Represents the destructor of the TDataItems class.

Namespace: BI.DataItem
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems Properties

Properties
Name | Description
AsArray | Represents property AsArray.
Item[Integer] | Represents property Item[Integer].
Last | Represents property Last.
Names[String] | Represents property Names[String].
Parent | Represents property Parent.
Top


TDataItems.AsArray Property

Summary

Represents property AsArray.

Namespace: BI.DataItem
Syntax
Delphi
public
 property AsArray:TDataArray read FItems;

Property Value

Type: TDataArray

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.Item[Integer] Property

Summary

Represents property Item[Integer].

Namespace: BI.DataItem
Syntax
Delphi
public
 property Item[const Index:Integer]:TDataItem read GetItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TDataItem

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.Last Property

Summary

Represents property Last.

Namespace: BI.DataItem
Syntax
Delphi
public
 property Last:TDataItem read GetLast;

Property Value

Type: TDataItem

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.Names[String] Property

Summary

Represents property Names[String].

Namespace: BI.DataItem
Syntax
Delphi
public
 property Names[const Index:String]:TDataItem read GetNames;

Parameters

Index
Type: String

Property Value

Type: TDataItem

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.Parent Property

Summary

Represents property Parent.

Namespace: BI.DataItem
Syntax
Delphi
public
 property Parent:TDataItem read FParent;

Property Value

Type: TDataItem

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems Methods

Methods
Name | Description
Add(String,TDataKind,TObject) | Overloaded. Represents method Add(String,TDataKind,TObject).
Add(TDataItem) | Overloaded. Represents method Add(TDataItem).
AddDirect(TDataItem) | Represents method AddDirect(TDataItem).
Clear | Represents method Clear.
Count | Represents method Count.
Delete(TDataItem) | Represents method Delete(TDataItem).
DestroyAll | Represents method DestroyAll.
DoChanged | Represents method DoChanged.
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer).
Exists(String) | Represents method Exists(String).
Find(String) | Represents method Find(String).
GetEmptyName | Represents method GetEmptyName.
IndexOf(String) | Represents method IndexOf(String).
Insert(TDataItem,Integer) | Represents method Insert(TDataItem,Integer).
New(String,TDataKind,TObject) | Represents method New(String,TDataKind,TObject).
Resize(TInteger) | Represents method Resize(TInteger).
Reverse | Represents method Reverse.
Select(Integer,Integer) | Overloaded. Represents method Select(Integer,Integer).
Select(Integer[]) | Overloaded. Represents method Select(Integer[]).
SortByName(Boolean,Boolean) | Represents method SortByName(Boolean,Boolean).
UniqueName(String) | Represents method UniqueName(String).
Top


TDataItems.Add(String,TDataKind,TObject) Method

Summary

Represents method Add(String,TDataKind,TObject).

Namespace: BI.DataItem
Syntax
Delphi
public
 function Add(const AName: String; const AKind: TDataKind; const Tag:TObject=nil): TDataItem; overload;

Parameters

AName
Type: String

AKind
Type: TDataKind

Tag
Type: TObject

Return Value

Type: TDataItem

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.Add(TDataItem) Method

Summary

Represents method Add(TDataItem).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Add(const AData:TDataItem); overload;

Parameters

AData
Type: TDataItem

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.AddDirect(TDataItem) Method

Summary

Represents method AddDirect(TDataItem).

Namespace: BI.DataItem
Syntax
Delphi
protected
 procedure AddDirect(const AData:TDataItem);

Parameters

AData
Type: TDataItem

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.Clear Method

Summary

Represents method Clear.

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.Count Method

Summary

Represents method Count.

Namespace: BI.DataItem
Syntax
Delphi
public
 function Count:Integer; inline;

Return Value

Type: Integer

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.Delete(TDataItem) Method

Summary

Represents method Delete(TDataItem).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Delete(const AData:TDataItem);

Parameters

AData
Type: TDataItem

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.DestroyAll Method

Summary

Represents method DestroyAll.

Namespace: BI.DataItem
Syntax
Delphi
protected
 procedure DestroyAll;
See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.DoChanged Method

Summary

Represents method DoChanged.

Namespace: BI.DataItem
Syntax
Delphi
protected
 procedure DoChanged;
See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.Exchange(Integer,Integer) Method

Summary

Represents method Exchange(Integer,Integer).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Exchange(const A,B:Integer);

Parameters

A
Type: Integer

B
Type: Integer

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.Exists(String) Method

Summary

Represents method Exists(String).

Namespace: BI.DataItem
Syntax
Delphi
public
 function Exists(const AName:String):Boolean; inline;

Parameters

AName
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.Find(String) Method

Summary

Represents method Find(String).

Namespace: BI.DataItem
Syntax
Delphi
public
 function Find(const AName: String): TDataItem; inline;

Parameters

AName
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.GetEmptyName Method

Summary

Represents method GetEmptyName.

Namespace: BI.DataItem
Syntax
Delphi
protected
 function GetEmptyName:String;

Return Value

Type: String

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.IndexOf(String) Method

Summary

Represents method IndexOf(String).

Namespace: BI.DataItem
Syntax
Delphi
public
 function IndexOf(const AName:String):Integer;

Parameters

AName
Type: String

Return Value

Type: Integer

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.Insert(TDataItem,Integer) Method

Summary

Represents method Insert(TDataItem,Integer).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Insert(const AData:TDataItem; const AIndex:Integer);

Parameters

AData
Type: TDataItem

AIndex
Type: Integer

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.New(String,TDataKind,TObject) Method

Summary

Represents method New(String,TDataKind,TObject).

Namespace: BI.DataItem
Syntax
Delphi
public
 function New(const AName:String; const AKind:TDataKind; const Tag:TObject=nil):TDataItem;

Parameters

AName
Type: String

AKind
Type: TDataKind

Tag
Type: TObject

Return Value

Type: TDataItem

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.Resize(TInteger) Method

Summary

Represents method Resize(TInteger).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Resize(const Size:TInteger);

Parameters

Size
Type: System.Void

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.Reverse Method

Summary

Represents method Reverse.

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Reverse;
See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.Select(Integer,Integer) Method

Summary

Represents method Select(Integer,Integer).

Namespace: BI.DataItem
Syntax
Delphi
public
 function Select(const Start,Finish:Integer):TDataArray; overload;

Parameters

Start
Type: Integer

Finish
Type: Integer

Return Value

Type: TDataArray

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.Select(Integer[]) Method

Summary

Represents method Select(Integer[]).

Namespace: BI.DataItem
Syntax
Delphi
public
 function Select(const Indices:Array of Integer):TDataArray; overload;

Parameters

Indices
Type: Array of Integer

Return Value

Type: TDataArray

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.SortByName(Boolean,Boolean) Method

Summary

Represents method SortByName(Boolean,Boolean).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure SortByName(const Ascending:Boolean=True; const IgnoreCase:Boolean=True);

Parameters

Ascending
Type: Boolean

IgnoreCase
Type: Boolean

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems.UniqueName(String) Method

Summary

Represents method UniqueName(String).

Namespace: BI.DataItem
Syntax
Delphi
public
 function UniqueName(const APrefix:String):String;

Parameters

APrefix
Type: String

Return Value

Type: String

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataItems Fields

Fields
Name | Description
Valid | Represents field Valid.
Top


TDataItems.Valid Field

Summary

Represents field Valid.

Namespace: BI.DataItem
Syntax
Delphi
protected
 Valid : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TDataItems
  • BI.DataItem


TDataKindHelper Class Helper

Summary

Represents type TDataKindHelper.

Namespace: BI.DataItem
Syntax
Delphi
type
 TDataKindHelper=record helper for TDataKind
 end;
Methods
Name | Description
FromString(String,TDataKind) | Represents method FromString(String,TDataKind).
IsNumeric | Represents method IsNumeric.
ToString | Represents method ToString.
Top
See Also

Reference

  • BI.DataItem


TDataKindHelper Methods

Methods
Name | Description
FromString(String,TDataKind) | Represents method FromString(String,TDataKind).
IsNumeric | Represents method IsNumeric.
ToString | Represents method ToString.
Top


TDataKindHelper.FromString(String,TDataKind) Method

Summary

Represents method FromString(String,TDataKind).

Namespace: BI.DataItem
Syntax
Delphi
public
 class function FromString(const AText:String; out AKind:TDataKind):Boolean; static;

Parameters

AText
Type: String

AKind
Type: TDataKind

Return Value

Type: Boolean

See Also

Reference

  • TDataKindHelper
  • BI.DataItem


TDataKindHelper.IsNumeric Method

Summary

Represents method IsNumeric.

Namespace: BI.DataItem
Syntax
Delphi
public
 function IsNumeric:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TDataKindHelper
  • BI.DataItem


TDataKindHelper.ToString Method

Summary

Represents method ToString.

Namespace: BI.DataItem
Syntax
Delphi
public
 function ToString:String;

Return Value

Type: String

See Also

Reference

  • TDataKindHelper
  • BI.DataItem


TDataProvider Class

Summary

Represents type TDataProvider.

Namespace: BI.DataItem
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.Model.TDataProviderAccess
BI.Algorithm.TDataProviderNeeds
BI.CollectionItem.TDataProviderAccess
BI.Dashboard.TProviderAccess
BI.DataSource.TDataCursor
BI.Persist.TBaseDataImporter
BI.Persist.TDataDelayProvider
BI.Persist.TDataImporter
BI.Query.TDataProviderAccess
BI.Summary.Totals.TSummaryTotals
BI.Summary.TSummary
FMXBI.DataControl.TDataProviderAccess
VCLBI.DataControl.TDataProviderAccess
VCLBI.Editor.Needs.TDataProviderAccess
VCLBI.Editor.Query.TDataProviderAccess
VCLBI.Editor.WorkflowItem.TDataProviderAccess
VCLBI.Grid.TDataProviderAccess
Syntax
Delphi
type
 TDataProvider=class(TComponent)
 end;

The TDataProvider type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TDataProvider class.
Top
Properties
Show:
Name | Description
Title | Represents property Title.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
BeginUpdate | Represents method BeginUpdate.
Changed | Represents method Changed.
Changing | Represents method Changing.
EndUpdate | Represents method EndUpdate.
GetItems(TDataItem) | Represents method GetItems(TDataItem).
GetStream(TDataArray) | Overloaded. Represents method GetStream(TDataArray).
GetStream(TDataItem,TDataItem) | Overloaded. Represents method GetStream(TDataItem,TDataItem).
Load(TDataItem,Boolean) | Overloaded. Represents method Load(TDataItem,Boolean).
NewData | Represents method NewData.
Top
Fields
Show:
Name | Description
FConsumers | Represents field FConsumers.
Top
See Also

Reference

  • BI.DataItem


TDataProvider Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TDataProvider class.
Top


TDataProvider.Destroy Destructor

Summary

Represents the destructor of the TDataProvider class.

Namespace: BI.DataItem
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TDataProvider
  • BI.DataItem


TDataProvider Properties

Properties
Name | Description
Title | Represents property Title.
Top


TDataProvider.Title Property

Summary

Represents property Title.

Namespace: BI.DataItem
Syntax
Delphi
published
 property Title:String read FTitle write FTitle;

Property Value

Type: String

See Also

Reference

  • TDataProvider
  • BI.DataItem


TDataProvider Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
BeginUpdate | Represents method BeginUpdate.
Changed | Represents method Changed.
Changing | Represents method Changing.
EndUpdate | Represents method EndUpdate.
GetItems(TDataItem) | Represents method GetItems(TDataItem).
GetStream(TDataArray) | Overloaded. Represents method GetStream(TDataArray).
GetStream(TDataItem,TDataItem) | Overloaded. Represents method GetStream(TDataItem,TDataItem).
Load(TDataItem,Boolean) | Overloaded. Represents method Load(TDataItem,Boolean).
NewData | Represents method NewData.
Top


TDataProvider.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TDataProvider
  • BI.DataItem


TDataProvider.BeginUpdate Method

Summary

Represents method BeginUpdate.

Namespace: BI.DataItem
Syntax
Delphi
protected
 procedure BeginUpdate; inline;
See Also

Reference

  • TDataProvider
  • BI.DataItem


TDataProvider.Changed Method

Summary

Represents method Changed.

Namespace: BI.DataItem
Syntax
Delphi
protected
 procedure Changed; virtual;
See Also

Reference

  • TDataProvider
  • BI.DataItem


TDataProvider.Changing Method

Summary

Represents method Changing.

Namespace: BI.DataItem
Syntax
Delphi
protected
 function Changing:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TDataProvider
  • BI.DataItem


TDataProvider.EndUpdate Method

Summary

Represents method EndUpdate.

Namespace: BI.DataItem
Syntax
Delphi
protected
 procedure EndUpdate;
See Also

Reference

  • TDataProvider
  • BI.DataItem


TDataProvider.GetItems(TDataItem) Method

Summary

Represents method GetItems(TDataItem).

Namespace: BI.DataItem
Syntax
Delphi
protected
 procedure GetItems(const AData:TDataItem); virtual;

Parameters

AData
Type: TDataItem

See Also

Reference

  • TDataProvider
  • BI.DataItem


TDataProvider.GetStream(TDataArray) Method

Summary

Represents method GetStream(TDataArray).

Namespace: BI.DataItem
Syntax
Delphi
protected
 function GetStream(const AItems:TDataArray):TStream; overload; virtual;

Parameters

AItems
Type: TDataArray

Return Value

Type: TStream

See Also

Reference

  • TDataProvider
  • BI.DataItem


TDataProvider.GetStream(TDataItem,TDataItem) Method

Summary

Represents method GetStream(TDataItem,TDataItem).

Namespace: BI.DataItem
Syntax
Delphi
protected
 function GetStream(const AData,ANext:TDataItem):TStream; overload; virtual;

Parameters

AData
Type: TDataItem

ANext
Type: TDataItem

Return Value

Type: TStream

See Also

Reference

  • TDataProvider
  • BI.DataItem


TDataProvider.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.DataItem
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); overload; virtual; abstract;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

See Also

Reference

  • TDataProvider
  • BI.DataItem


TDataProvider.NewData Method

Summary

Represents method NewData.

Namespace: BI.DataItem
Syntax
Delphi
public
 function NewData:TDataItem;

Return Value

Type: TDataItem

See Also

Reference

  • TDataProvider
  • BI.DataItem


TDataProvider Fields

Fields
Name | Description
FConsumers | Represents field FConsumers.
Top


TDataProvider.FConsumers Field

Summary

Represents field FConsumers.

Namespace: BI.DataItem
Syntax
Delphi
protected
 FConsumers : TBIConsumers;

Field Value

Type: TBIConsumers

See Also

Reference

  • TDataProvider
  • BI.DataItem


TDetailData Class

Summary

Represents type TDetailData.

Namespace: BI.DataItem
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.DataItem.TDetailData
Syntax
Delphi
type
 TDetailData=class(TDataItem)
 end;

The TDetailData type exposes the following members.

Constructors
Show:
Name | Description
Create(TDataItem,String) | Initializes a new instance of the TDetailData class.
Top
Fields
Show:
Name | Description
Detail | Represents field Detail.
Top
See Also

Reference

  • BI.DataItem


TDetailData Constructors

Constructors
Name | Description
Create(TDataItem,String) | Initializes a new instance of the TDetailData class.
Top


TDetailData.Create(TDataItem,String) Constructor

Summary

Initializes a new instance of the TDetailData class.

Namespace: BI.DataItem
Syntax
Delphi
public
 Constructor Create(const ADetail:TDataItem; const AName:String);

Parameters

ADetail
Type: TDataItem

AName
Type: String

See Also

Reference

  • TDetailData
  • BI.DataItem


TDetailData Fields

Fields
Name | Description
Detail | Represents field Detail.
Top


TDetailData.Detail Field

Summary

Represents field Detail.

Namespace: BI.DataItem
Syntax
Delphi
public
 Detail : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TDetailData
  • BI.DataItem


THashIndex Class

Summary

Represents type THashIndex.

Namespace: BI.DataItem
Inheritance Hierarchy
TObject
BI.DataItem.THashIndex
Syntax
Delphi
type
 THashIndex=class
 end;

The THashIndex type exposes the following members.

Constructors
Show:
Name | Description
Create(TInteger) | Initializes a new instance of the THashIndex class.
Top
Methods
Show:
Name | Description
Sort | Represents method Sort.
Top
See Also

Reference

  • BI.DataItem


THashIndex Constructors

Constructors
Name | Description
Create(TInteger) | Initializes a new instance of the THashIndex class.
Top


THashIndex.Create(TInteger) Constructor

Summary

Initializes a new instance of the THashIndex class.

Namespace: BI.DataItem
Syntax
Delphi
public
 Constructor Create(const ACount:TInteger);

Parameters

ACount
Type: System.Void

See Also

Reference

  • THashIndex
  • BI.DataItem


THashIndex Methods

Methods
Name | Description
Sort | Represents method Sort.
Top


THashIndex.Sort Method

Summary

Represents method Sort.

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Sort;
See Also

Reference

  • THashIndex
  • BI.DataItem


TImportHistory Class

Summary

Represents type TImportHistory.

Namespace: BI.DataItem
Inheritance Hierarchy
TObject
BI.DataItem.TImportHistory
Syntax
Delphi
type
 TImportHistory=class
 end;

The TImportHistory type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TImportHistory class.
Top
Fields
Show:
Name | Description
DateTime | Represents field DateTime.
Memory | Represents field Memory.
Times | Represents field Times.
Top
See Also

Reference

  • BI.DataItem


TImportHistory Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TImportHistory class.
Top


TImportHistory.Create Constructor

Summary

Initializes a new instance of the TImportHistory class.

Namespace: BI.DataItem
Syntax
Delphi
public
 Constructor Create;
See Also

Reference

  • TImportHistory
  • BI.DataItem


TImportHistory Fields

Fields
Name | Description
DateTime | Represents field DateTime.
Memory | Represents field Memory.
Times | Represents field Times.
Top


TImportHistory.DateTime Field

Summary

Represents field DateTime.

Namespace: BI.DataItem
Syntax
Delphi
public
 DateTime : TDateTime;

Field Value

Type: TDateTime

See Also

Reference

  • TImportHistory
  • BI.DataItem


TImportHistory.Memory Field

Summary

Represents field Memory.

Namespace: BI.DataItem
Syntax
Delphi
public
 Memory : TInteger;

Field Value

Type: TInteger

See Also

Reference

  • TImportHistory
  • BI.DataItem


TImportHistory.Times Field

Summary

Represents field Times.

Namespace: BI.DataItem
Syntax
Delphi
public
 Times : TDataTimes;

Field Value

Type: TDataTimes

See Also

Reference

  • TImportHistory
  • BI.DataItem


BI.DataItem Records

Records
Name | Description
TBIConsumers | Represents type TBIConsumers.
TDataTimes | Represents type TDataTimes.
TIndexHelper | Represents type TIndexHelper.
TMemory | Represents type TMemory.
TMissingData | Represents type TMissingData.
TSortItem | Represents type TSortItem.
Top


TBIConsumers Record

Summary

Represents type TBIConsumers.

Namespace: BI.DataItem
Syntax
Delphi
type
 TBIConsumers=record
 end;

The TBIConsumers type exposes the following members.

Methods
Show:
Name | Description
Add(TBIConsumer) | Represents method Add(TBIConsumer).
Broadcast(TBIEvent) | Represents method Broadcast(TBIEvent).
IndexOf(TBIConsumer) | Represents method IndexOf(TBIConsumer).
Remove(TBIConsumer) | Represents method Remove(TBIConsumer).
Top
Fields
Show:
Name | Description
Changing | Represents field Changing.
Top
See Also

Reference

  • BI.DataItem


TBIConsumers Methods

Methods
Name | Description
Add(TBIConsumer) | Represents method Add(TBIConsumer).
Broadcast(TBIEvent) | Represents method Broadcast(TBIEvent).
IndexOf(TBIConsumer) | Represents method IndexOf(TBIConsumer).
Remove(TBIConsumer) | Represents method Remove(TBIConsumer).
Top


TBIConsumers.Add(TBIConsumer) Method

Summary

Represents method Add(TBIConsumer).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Add(const AConsumer:TBIConsumer);

Parameters

AConsumer
Type: TBIConsumer

See Also

Reference

  • TBIConsumers
  • BI.DataItem


TBIConsumers.Broadcast(TBIEvent) Method

Summary

Represents method Broadcast(TBIEvent).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Broadcast(const AEvent:TBIEvent);

Parameters

AEvent
Type: TBIEvent

See Also

Reference

  • TBIConsumers
  • BI.DataItem


TBIConsumers.IndexOf(TBIConsumer) Method

Summary

Represents method IndexOf(TBIConsumer).

Namespace: BI.DataItem
Syntax
Delphi
public
 function IndexOf(const AConsumer:TBIConsumer):Integer;

Parameters

AConsumer
Type: TBIConsumer

Return Value

Type: Integer

See Also

Reference

  • TBIConsumers
  • BI.DataItem


TBIConsumers.Remove(TBIConsumer) Method

Summary

Represents method Remove(TBIConsumer).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Remove(const AConsumer:TBIConsumer);

Parameters

AConsumer
Type: TBIConsumer

See Also

Reference

  • TBIConsumers
  • BI.DataItem


TBIConsumers Fields

Fields
Name | Description
Changing | Represents field Changing.
Top


TBIConsumers.Changing Field

Summary

Represents field Changing.

Namespace: BI.DataItem
Syntax
Delphi
public
 Changing : Integer;

Field Value

Type: Integer

See Also

Reference

  • TBIConsumers
  • BI.DataItem


TDataTimes Record

Summary

Represents type TDataTimes.

Namespace: BI.DataItem
Syntax
Delphi
type
 TDataTimes=record
 end;

The TDataTimes type exposes the following members.

Fields
Show:
Name | Description
Calculating | Represents field Calculating.
LoadingData | Represents field LoadingData.
LoadingInfo | Represents field LoadingInfo.
Opening | Represents field Opening.
Total | Represents field Total.
Top
See Also

Reference

  • BI.DataItem


TDataTimes Fields

Fields
Name | Description
Calculating | Represents field Calculating.
LoadingData | Represents field LoadingData.
LoadingInfo | Represents field LoadingInfo.
Opening | Represents field Opening.
Total | Represents field Total.
Top


TDataTimes.Calculating Field

Summary

Represents field Calculating.

Namespace: BI.DataItem
Syntax
Delphi
public
 Calculating : Cardinal;

Field Value

Type: Cardinal

See Also

Reference

  • TDataTimes
  • BI.DataItem


TDataTimes.LoadingData Field

Summary

Represents field LoadingData.

Namespace: BI.DataItem
Syntax
Delphi
public
 LoadingData : Cardinal;

Field Value

Type: Cardinal

See Also

Reference

  • TDataTimes
  • BI.DataItem


TDataTimes.LoadingInfo Field

Summary

Represents field LoadingInfo.

Namespace: BI.DataItem
Syntax
Delphi
public
 LoadingInfo : Cardinal;

Field Value

Type: Cardinal

See Also

Reference

  • TDataTimes
  • BI.DataItem


TDataTimes.Opening Field

Summary

Represents field Opening.

Namespace: BI.DataItem
Syntax
Delphi
public
 Opening : Cardinal;

Field Value

Type: Cardinal

See Also

Reference

  • TDataTimes
  • BI.DataItem


TDataTimes.Total Field

Summary

Represents field Total.

Namespace: BI.DataItem
Syntax
Delphi
public
 Total : Cardinal;

Field Value

Type: Cardinal

See Also

Reference

  • TDataTimes
  • BI.DataItem


TIndexHelper Record

Summary

Represents type TIndexHelper.

Namespace: BI.DataItem
Syntax
Delphi
type
 TIndexHelper=record
 end;

The TIndexHelper type exposes the following members.

Methods
Show:
Name | Description
From(TDataArray) | Represents method From(TDataArray).
Top
See Also

Reference

  • BI.DataItem


TIndexHelper Methods

Methods
Name | Description
From(TDataArray) | Represents method From(TDataArray).
Top


TIndexHelper.From(TDataArray) Method

Summary

Represents method From(TDataArray).

Namespace: BI.DataItem
Syntax
Delphi
public
 function From(const AItems:TDataArray):TNativeIntArray;

Parameters

AItems
Type: TDataArray

Return Value

Type: TNativeIntArray

See Also

Reference

  • TIndexHelper
  • BI.DataItem


TMemory Record

Summary

Represents type TMemory.

Namespace: BI.DataItem
Syntax
Delphi
type
 TMemory=record
 end;

The TMemory type exposes the following members.

Methods
Show:
Name | Description
Allocated | Represents method Allocated.
Available | Represents method Available.
Init | Represents method Init.
TotalPhysical | Represents method TotalPhysical.
Top
Fields
Show:
Name | Description
MinLimit | Represents field MinLimit.
Top
See Also

Reference

  • BI.DataItem


TMemory Methods

Methods
Name | Description
Allocated | Represents method Allocated.
Available | Represents method Available.
Init | Represents method Init.
TotalPhysical | Represents method TotalPhysical.
Top


TMemory.Allocated Method

Summary

Represents method Allocated.

Namespace: BI.DataItem
Syntax
Delphi
public
 class function Allocated:Int64; static;

Return Value

Type: Int64

See Also

Reference

  • TMemory
  • BI.DataItem


TMemory.Available Method

Summary

Represents method Available.

Namespace: BI.DataItem
Syntax
Delphi
public
 class function Available:UInt64; static;

Return Value

Type: UInt64

See Also

Reference

  • TMemory
  • BI.DataItem


TMemory.Init Method

Summary

Represents method Init.

Namespace: BI.DataItem
Syntax
Delphi
public
 class procedure Init; static;
See Also

Reference

  • TMemory
  • BI.DataItem


TMemory.TotalPhysical Method

Summary

Represents method TotalPhysical.

Namespace: BI.DataItem
Syntax
Delphi
public
 class function TotalPhysical:UInt64; static;

Return Value

Type: UInt64

See Also

Reference

  • TMemory
  • BI.DataItem


TMemory Fields

Fields
Name | Description
MinLimit | Represents field MinLimit.
Top


TMemory.MinLimit Field

Summary

Represents field MinLimit.

Namespace: BI.DataItem
Syntax
Delphi
public
 class var MinLimit:UInt64;

Field Value

Type: UInt64

See Also

Reference

  • TMemory
  • BI.DataItem


TMissingData Record

Summary

Represents type TMissingData.

Namespace: BI.DataItem
Syntax
Delphi
type
 TMissingData=record
 end;

The TMissingData type exposes the following members.

Properties
Show:
Name | Description
Item[TInteger] | Represents property Item[TInteger].
Top
Methods
Show:
Name | Description
All | Represents method All.
Init(TInteger) | Represents method Init(TInteger).
MissingCount | Represents method MissingCount.
Swap(TInteger,TInteger) | Represents method Swap(TInteger,TInteger).
Top
Fields
Show:
Name | Description
Count | Represents field Count.
Items | Represents field Items.
Top
See Also

Reference

  • BI.DataItem


TMissingData Properties

Properties
Name | Description
Item[TInteger] | Represents property Item[TInteger].
Top


TMissingData.Item[TInteger] Property

Summary

Represents property Item[TInteger].

Namespace: BI.DataItem
Syntax
Delphi
public
 property Item[const Index:TInteger]:Boolean read GetItem write SetItem; default;

Parameters

Index
Type: System.Void

Property Value

Type: Boolean

See Also

Reference

  • TMissingData
  • BI.DataItem


TMissingData Methods

Methods
Name | Description
All | Represents method All.
Init(TInteger) | Represents method Init(TInteger).
MissingCount | Represents method MissingCount.
Swap(TInteger,TInteger) | Represents method Swap(TInteger,TInteger).
Top


TMissingData.All Method

Summary

Represents method All.

Namespace: BI.DataItem
Syntax
Delphi
public
 function All:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TMissingData
  • BI.DataItem


TMissingData.Init(TInteger) Method

Summary

Represents method Init(TInteger).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Init(const ACount:TInteger);

Parameters

ACount
Type: System.Void

See Also

Reference

  • TMissingData
  • BI.DataItem


TMissingData.MissingCount Method

Summary

Represents method MissingCount.

Namespace: BI.DataItem
Syntax
Delphi
public
 function MissingCount:TInteger;

Return Value

Type: TInteger

See Also

Reference

  • TMissingData
  • BI.DataItem


TMissingData.Swap(TInteger,TInteger) Method

Summary

Represents method Swap(TInteger,TInteger).

Namespace: BI.DataItem
Syntax
Delphi
public
 procedure Swap(const A,B:TInteger);

Parameters

A
Type: System.Void

B
Type: System.Void

See Also

Reference

  • TMissingData
  • BI.DataItem


TMissingData Fields

Fields
Name | Description
Count | Represents field Count.
Items | Represents field Items.
Top


TMissingData.Count Field

Summary

Represents field Count.

Namespace: BI.DataItem
Syntax
Delphi
public
 Count : TInteger;

Field Value

Type: TInteger

See Also

Reference

  • TMissingData
  • BI.DataItem


TMissingData.Items Field

Summary

Represents field Items.

Namespace: BI.DataItem
Syntax
Delphi
public
 Items : TBooleanArray;

Field Value

Type: TBooleanArray

See Also

Reference

  • TMissingData
  • BI.DataItem


TSortItem Record

Summary

Represents type TSortItem.

Namespace: BI.DataItem
Syntax
Delphi
type
 TSortItem=record
 end;

The TSortItem type exposes the following members.

Fields
Show:
Name | Description
Active | Represents field Active.
Data | Represents field Data.
Descending | Represents field Descending.
IgnoreTextCase | Represents field IgnoreTextCase.
Top
See Also

Reference

  • BI.DataItem


TSortItem Fields

Fields
Name | Description
Active | Represents field Active.
Data | Represents field Data.
Descending | Represents field Descending.
IgnoreTextCase | Represents field IgnoreTextCase.
Top


TSortItem.Active Field

Summary

Represents field Active.

Namespace: BI.DataItem
Syntax
Delphi
public
 Active : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TSortItem
  • BI.DataItem


TSortItem.Data Field

Summary

Represents field Data.

Namespace: BI.DataItem
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TSortItem
  • BI.DataItem


TSortItem.Descending Field

Summary

Represents field Descending.

Namespace: BI.DataItem
Syntax
Delphi
public
 Descending: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TSortItem
  • BI.DataItem


TSortItem.IgnoreTextCase Field

Summary

Represents field IgnoreTextCase.

Namespace: BI.DataItem
Syntax
Delphi
public
 IgnoreTextCase: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TSortItem
  • BI.DataItem


BI.DataItem Enumerations

Enumerations
Name | Description
TBIEvent | Represents type TBIEvent.
TDataKind | Represents type TDataKind.
TNumericData | Represents type TNumericData.
Top


TBIEvent Enumeration

Summary

Represents type TBIEvent.

Namespace: BI.DataItem
Syntax
Delphi
type
 TBIEvent=(Changed,Destroyed,ChangedValues);

The TBIEvent type exposes the following members.

Members
Show:
Name | Description
Changed | Represents constant Changed.
ChangedValues | Represents constant ChangedValues.
Destroyed | Represents constant Destroyed.
Top
See Also

Reference

  • BI.DataItem


TDataKind Enumeration

Summary

Represents type TDataKind.

Namespace: BI.DataItem
Syntax
Delphi
type
 TDataKind=(dkInt32,
 dkInt64,
 dkSingle,
 dkDouble,
 dkExtended,
 dkText,
 dkDateTime,
 dkBoolean,
 dkUnknown);

The TDataKind type exposes the following members.

Members
Show:
Name | Description
dkBoolean | Represents constant dkBoolean.
dkDateTime | Represents constant dkDateTime.
dkDouble | Represents constant dkDouble.
dkExtended | Represents constant dkExtended.
dkInt32 | Represents constant dkInt32.
dkInt64 | Represents constant dkInt64.
dkSingle | Represents constant dkSingle.
dkText | Represents constant dkText.
dkUnknown | Represents constant dkUnknown.
Top
See Also

Reference

  • BI.DataItem


TNumericData Enumeration

Summary

Represents type TNumericData.

Namespace: BI.DataItem
Syntax
Delphi
type
 TNumericData=(Normal, Percentages);

The TNumericData type exposes the following members.

Members
Show:
Name | Description
Normal | Represents constant Normal.
Percentages | Represents constant Percentages.
Top
See Also

Reference

  • BI.DataItem


BI.DataItem Delegates

Delegates
Name | Description
TBIConsumer | Represents type TBIConsumer.
Top


TBIConsumer Delegate

Summary

Represents type TBIConsumer.

Namespace: BI.DataItem
Syntax
Delphi
type
 TBIConsumer=procedure(const AEvent:TBIEvent) of object;
See Also

Reference

  • BI.DataItem


BI.DataItem Types

Types
Name | Description
TDataArray | Represents an array of the TDataItem type.
Top


TDataArray Type

Summary

Represents an array of the TDataItem type.

Namespace: BI.DataItem
Syntax
Delphi
type
 TDataArray=Array of TDataItem;
See Also

Reference

  • BI.DataItem


BI.Dataset Namespace

Summary

Represents namespace BI.Dataset.

Classes
Name | Description
TBICustomDataSet | Represents type TBICustomDataSet.
TBIDataset | Represents type TBIDataset.
TBIDataset.TBIMasterDataLink | Represents type TBIMasterDataLink.
TDataAccess | Represents type TDataAccess.
TDataCursorAccess | Represents type TDataCursorAccess.
Top
Records
Name | Description
TItem | Represents type TItem.
TRecInfo | Represents type TRecInfo.
Top
Types
Name | Description
PItems | Represents a pointer type to TItems.
PRecInfo | Represents a pointer type to TRecInfo.
TBIDataset.TBIMasterDataLinkClass | Represents type TBIMasterDataLinkClass.
TItemData | Represents an array of the Byte type.
TItems | Represents an array of the TItem type.
TTeeAddRecordBuffer | Represents an alias of the TTeeRecordBuffer type.
TTeeBookmark | Represents an alias of the TBookmark type.
TTeeRecordBuffer | Represents an alias of the TRecordBuffer type.
TTeeRecordBufferP | Represents an alias of the TRecordBuffer type.
TTeeValueBuffer | Represents an alias of the TValueBuffer type.
Top
Constants
Name | Description
MaxDataSize | Represents constant MaxDataSize.
Top
Routines
Name | Description
BufferToString(PByte) | Represents method BufferToString(PByte).
CopyBuffer(TField,PByte,PByte) | Represents method CopyBuffer(TField,PByte,PByte).
StringToBuffer(PByte,String) | Represents method StringToBuffer(PByte,String).
Top


BI.Dataset Classes

Classes
Name | Description
TBICustomDataSet | Represents type TBICustomDataSet.
TBIDataset | Represents type TBIDataset.
TBIDataset.TBIMasterDataLink | Represents type TBIMasterDataLink.
TDataAccess | Represents type TDataAccess.
TDataCursorAccess | Represents type TDataCursorAccess.
Top


TBICustomDataSet Class

Summary

Represents type TBICustomDataSet.

Namespace: BI.Dataset
Inheritance Hierarchy
TDataSet
BI.Dataset.TBICustomDataSet
BI.Dataset.TBIDataset
Syntax
Delphi
type
 TBICustomDataSet=class abstract(TDataSet)
 end;

The TBICustomDataSet type exposes the following members.

Properties
Show:
Name | Description
Active | Represents property Active.
AfterCancel | Represents property AfterCancel.
AfterClose | Represents property AfterClose.
AfterDelete | Represents property AfterDelete.
AfterEdit | Represents property AfterEdit.
AfterInsert | Represents property AfterInsert.
AfterOpen | Represents property AfterOpen.
AfterPost | Represents property AfterPost.
AfterRefresh | Represents property AfterRefresh.
AfterScroll | Represents property AfterScroll.
AutoCalcFields | Represents property AutoCalcFields.
BeforeCancel | Represents property BeforeCancel.
BeforeClose | Represents property BeforeClose.
BeforeDelete | Represents property BeforeDelete.
BeforeEdit | Represents property BeforeEdit.
BeforeInsert | Represents property BeforeInsert.
BeforeOpen | Represents property BeforeOpen.
BeforePost | Represents property BeforePost.
BeforeRefresh | Represents property BeforeRefresh.
BeforeScroll | Represents property BeforeScroll.
OnCalcFields | Represents property OnCalcFields.
OnDeleteError | Represents property OnDeleteError.
OnEditError | Represents property OnEditError.
OnNewRecord | Represents property OnNewRecord.
OnPostError | Represents property OnPostError.
ReadOnly | Represents property ReadOnly.
Top
Methods
Show:
Name | Description
AllocRecordBuffer | Represents method AllocRecordBuffer.
BookMarkToIndex(TInteger) | Represents method BookMarkToIndex(TInteger).
DoFillBuffer(TTeeRecordBuffer) | Represents method DoFillBuffer(TTeeRecordBuffer).
FreeRecordBuffer(TTeeRecordBuffer) | Represents method FreeRecordBuffer(TTeeRecordBuffer).
GetBookmarkData(TTeeRecordBuffer,TTeeBookmark) | Represents method GetBookmarkData(TTeeRecordBuffer,TTeeBookmark).
GetBookmarkFlag(TTeeRecordBuffer) | Represents method GetBookmarkFlag(TTeeRecordBuffer).
GetIndexPosition | Represents method GetIndexPosition.
GetRecNo | Represents method GetRecNo.
GetRecord(TTeeRecordBuffer,TGetMode,Boolean) | Represents method GetRecord(TTeeRecordBuffer,TGetMode,Boolean).
InternalAddRecord(TTeeAddRecordBuffer,Boolean) | Represents method InternalAddRecord(TTeeAddRecordBuffer,Boolean).
InternalClose | Represents method InternalClose.
InternalDelete | Represents method InternalDelete.
InternalFirst | Represents method InternalFirst.
InternalGotoBookmark(TTeeBookmark) | Represents method InternalGotoBookmark(TTeeBookmark).
InternalHandleException | Represents method InternalHandleException.
InternalInitRecord(TTeeRecordBuffer) | Represents method InternalInitRecord(TTeeRecordBuffer).
InternalLast | Represents method InternalLast.
InternalOpen | Represents method InternalOpen.
InternalPost | Represents method InternalPost.
InternalRefresh | Represents method InternalRefresh.
InternalSetToRecord(TTeeRecordBuffer) | Represents method InternalSetToRecord(TTeeRecordBuffer).
IsCursorOpen | Represents method IsCursorOpen.
RecInfoOfs | Represents method RecInfoOfs.
SetBookmarkData(TTeeRecordBuffer,TTeeBookmark) | Represents method SetBookmarkData(TTeeRecordBuffer,TTeeBookmark).
SetBookmarkFlag(TTeeRecordBuffer,TBookmarkFlag) | Represents method SetBookmarkFlag(TTeeRecordBuffer,TBookmarkFlag).
SetFieldData(TField,TTeeValueBuffer) | Represents method SetFieldData(TField,TTeeValueBuffer).
SetRecNo(Integer) | Represents method SetRecNo(Integer).
ValidActiveBuffer | Represents method ValidActiveBuffer.
Top
See Also

Reference

  • BI.Dataset


TBICustomDataSet Properties

Properties
Name | Description
Active | Represents property Active.
AfterCancel | Represents property AfterCancel.
AfterClose | Represents property AfterClose.
AfterDelete | Represents property AfterDelete.
AfterEdit | Represents property AfterEdit.
AfterInsert | Represents property AfterInsert.
AfterOpen | Represents property AfterOpen.
AfterPost | Represents property AfterPost.
AfterRefresh | Represents property AfterRefresh.
AfterScroll | Represents property AfterScroll.
AutoCalcFields | Represents property AutoCalcFields.
BeforeCancel | Represents property BeforeCancel.
BeforeClose | Represents property BeforeClose.
BeforeDelete | Represents property BeforeDelete.
BeforeEdit | Represents property BeforeEdit.
BeforeInsert | Represents property BeforeInsert.
BeforeOpen | Represents property BeforeOpen.
BeforePost | Represents property BeforePost.
BeforeRefresh | Represents property BeforeRefresh.
BeforeScroll | Represents property BeforeScroll.
OnCalcFields | Represents property OnCalcFields.
OnDeleteError | Represents property OnDeleteError.
OnEditError | Represents property OnEditError.
OnNewRecord | Represents property OnNewRecord.
OnPostError | Represents property OnPostError.
ReadOnly | Represents property ReadOnly.
Top


TBICustomDataSet.Active Property

Summary

Represents property Active.

Namespace: BI.Dataset
Syntax
Delphi
published
 property Active;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.AfterCancel Property

Summary

Represents property AfterCancel.

Namespace: BI.Dataset
Syntax
Delphi
published
 property AfterCancel;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.AfterClose Property

Summary

Represents property AfterClose.

Namespace: BI.Dataset
Syntax
Delphi
published
 property AfterClose;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.AfterDelete Property

Summary

Represents property AfterDelete.

Namespace: BI.Dataset
Syntax
Delphi
published
 property AfterDelete;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.AfterEdit Property

Summary

Represents property AfterEdit.

Namespace: BI.Dataset
Syntax
Delphi
published
 property AfterEdit;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.AfterInsert Property

Summary

Represents property AfterInsert.

Namespace: BI.Dataset
Syntax
Delphi
published
 property AfterInsert;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.AfterOpen Property

Summary

Represents property AfterOpen.

Namespace: BI.Dataset
Syntax
Delphi
published
 property AfterOpen;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.AfterPost Property

Summary

Represents property AfterPost.

Namespace: BI.Dataset
Syntax
Delphi
published
 property AfterPost;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.AfterRefresh Property

Summary

Represents property AfterRefresh.

Namespace: BI.Dataset
Syntax
Delphi
published
 property AfterRefresh;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.AfterScroll Property

Summary

Represents property AfterScroll.

Namespace: BI.Dataset
Syntax
Delphi
published
 property AfterScroll;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.AutoCalcFields Property

Summary

Represents property AutoCalcFields.

Namespace: BI.Dataset
Syntax
Delphi
published
 property AutoCalcFields;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.BeforeCancel Property

Summary

Represents property BeforeCancel.

Namespace: BI.Dataset
Syntax
Delphi
published
 property BeforeCancel;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.BeforeClose Property

Summary

Represents property BeforeClose.

Namespace: BI.Dataset
Syntax
Delphi
published
 property BeforeClose;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.BeforeDelete Property

Summary

Represents property BeforeDelete.

Namespace: BI.Dataset
Syntax
Delphi
published
 property BeforeDelete;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.BeforeEdit Property

Summary

Represents property BeforeEdit.

Namespace: BI.Dataset
Syntax
Delphi
published
 property BeforeEdit;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.BeforeInsert Property

Summary

Represents property BeforeInsert.

Namespace: BI.Dataset
Syntax
Delphi
published
 property BeforeInsert;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.BeforeOpen Property

Summary

Represents property BeforeOpen.

Namespace: BI.Dataset
Syntax
Delphi
published
 property BeforeOpen;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.BeforePost Property

Summary

Represents property BeforePost.

Namespace: BI.Dataset
Syntax
Delphi
published
 property BeforePost;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.BeforeRefresh Property

Summary

Represents property BeforeRefresh.

Namespace: BI.Dataset
Syntax
Delphi
published
 property BeforeRefresh;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.BeforeScroll Property

Summary

Represents property BeforeScroll.

Namespace: BI.Dataset
Syntax
Delphi
published
 property BeforeScroll;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.OnCalcFields Property

Summary

Represents property OnCalcFields.

Namespace: BI.Dataset
Syntax
Delphi
published
 property OnCalcFields;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.OnDeleteError Property

Summary

Represents property OnDeleteError.

Namespace: BI.Dataset
Syntax
Delphi
published
 property OnDeleteError;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.OnEditError Property

Summary

Represents property OnEditError.

Namespace: BI.Dataset
Syntax
Delphi
published
 property OnEditError;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.OnNewRecord Property

Summary

Represents property OnNewRecord.

Namespace: BI.Dataset
Syntax
Delphi
published
 property OnNewRecord;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.OnPostError Property

Summary

Represents property OnPostError.

Namespace: BI.Dataset
Syntax
Delphi
published
 property OnPostError;

Property Value

Type: Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.ReadOnly Property

Summary

Represents property ReadOnly.

Namespace: BI.Dataset
Syntax
Delphi
protected
 property ReadOnly:Boolean read FReadOnly write FReadOnly;

Property Value

Type: Boolean

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet Methods

Methods
Name | Description
AllocRecordBuffer | Represents method AllocRecordBuffer.
BookMarkToIndex(TInteger) | Represents method BookMarkToIndex(TInteger).
DoFillBuffer(TTeeRecordBuffer) | Represents method DoFillBuffer(TTeeRecordBuffer).
FreeRecordBuffer(TTeeRecordBuffer) | Represents method FreeRecordBuffer(TTeeRecordBuffer).
GetBookmarkData(TTeeRecordBuffer,TTeeBookmark) | Represents method GetBookmarkData(TTeeRecordBuffer,TTeeBookmark).
GetBookmarkFlag(TTeeRecordBuffer) | Represents method GetBookmarkFlag(TTeeRecordBuffer).
GetIndexPosition | Represents method GetIndexPosition.
GetRecNo | Represents method GetRecNo.
GetRecord(TTeeRecordBuffer,TGetMode,Boolean) | Represents method GetRecord(TTeeRecordBuffer,TGetMode,Boolean).
InternalAddRecord(TTeeAddRecordBuffer,Boolean) | Represents method InternalAddRecord(TTeeAddRecordBuffer,Boolean).
InternalClose | Represents method InternalClose.
InternalDelete | Represents method InternalDelete.
InternalFirst | Represents method InternalFirst.
InternalGotoBookmark(TTeeBookmark) | Represents method InternalGotoBookmark(TTeeBookmark).
InternalHandleException | Represents method InternalHandleException.
InternalInitRecord(TTeeRecordBuffer) | Represents method InternalInitRecord(TTeeRecordBuffer).
InternalLast | Represents method InternalLast.
InternalOpen | Represents method InternalOpen.
InternalPost | Represents method InternalPost.
InternalRefresh | Represents method InternalRefresh.
InternalSetToRecord(TTeeRecordBuffer) | Represents method InternalSetToRecord(TTeeRecordBuffer).
IsCursorOpen | Represents method IsCursorOpen.
RecInfoOfs | Represents method RecInfoOfs.
SetBookmarkData(TTeeRecordBuffer,TTeeBookmark) | Represents method SetBookmarkData(TTeeRecordBuffer,TTeeBookmark).
SetBookmarkFlag(TTeeRecordBuffer,TBookmarkFlag) | Represents method SetBookmarkFlag(TTeeRecordBuffer,TBookmarkFlag).
SetFieldData(TField,TTeeValueBuffer) | Represents method SetFieldData(TField,TTeeValueBuffer).
SetRecNo(Integer) | Represents method SetRecNo(Integer).
ValidActiveBuffer | Represents method ValidActiveBuffer.
Top


TBICustomDataSet.AllocRecordBuffer Method

Summary

Represents method AllocRecordBuffer.

Namespace: BI.Dataset
Syntax
Delphi
protected
 function AllocRecordBuffer: TTeeRecordBuffer; override;

Return Value

Type: TTeeRecordBuffer

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.BookMarkToIndex(TInteger) Method

Summary

Represents method BookMarkToIndex(TInteger).

Namespace: BI.Dataset
Syntax
Delphi
protected
 function BookMarkToIndex(const ABookMark:TInteger):TInteger; virtual; abstract;

Parameters

ABookMark
Type: System.Void

Return Value

Type: TInteger

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.DoFillBuffer(TTeeRecordBuffer) Method

Summary

Represents method DoFillBuffer(TTeeRecordBuffer).

Namespace: BI.Dataset
Syntax
Delphi
protected
 Procedure DoFillBuffer(const Buffer: TTeeRecordBuffer); virtual; abstract;

Parameters

Buffer
Type: System.Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.FreeRecordBuffer(TTeeRecordBuffer) Method

Summary

Represents method FreeRecordBuffer(TTeeRecordBuffer).

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure FreeRecordBuffer(var Buffer: TTeeRecordBuffer); override;

Parameters

Buffer
Type: System.Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.GetBookmarkData(TTeeRecordBuffer,TTeeBookmark) Method

Summary

Represents method GetBookmarkData(TTeeRecordBuffer,TTeeBookmark).

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure GetBookmarkData(Buffer: TTeeRecordBuffer; Data: TTeeBookmark); override;

Parameters

Buffer
Type: System.Void

Data
Type: System.Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.GetBookmarkFlag(TTeeRecordBuffer) Method

Summary

Represents method GetBookmarkFlag(TTeeRecordBuffer).

Namespace: BI.Dataset
Syntax
Delphi
protected
 function GetBookmarkFlag(Buffer: TTeeRecordBuffer): TBookmarkFlag; override;

Parameters

Buffer
Type: System.Void

Return Value

Type: TBookmarkFlag

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.GetIndexPosition Method

Summary

Represents method GetIndexPosition.

Namespace: BI.Dataset
Syntax
Delphi
protected
 function GetIndexPosition:TInteger; virtual; abstract;

Return Value

Type: TInteger

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.GetRecNo Method

Summary

Represents method GetRecNo.

Namespace: BI.Dataset
Syntax
Delphi
protected
 function GetRecNo: Integer; override;

Return Value

Type: Integer

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.GetRecord(TTeeRecordBuffer,TGetMode,Boolean) Method

Summary

Represents method GetRecord(TTeeRecordBuffer,TGetMode,Boolean).

Namespace: BI.Dataset
Syntax
Delphi
protected
 function GetRecord(Buffer: TTeeRecordBuffer; GetMode: TGetMode; DoCheck: Boolean): TGetResult; override;

Parameters

Buffer
Type: System.Void

GetMode
Type: TGetMode

DoCheck
Type: Boolean

Return Value

Type: TGetResult

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.InternalAddRecord(TTeeAddRecordBuffer,Boolean) Method

Summary

Represents method InternalAddRecord(TTeeAddRecordBuffer,Boolean).

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure InternalAddRecord(Buffer: TTeeAddRecordBuffer; Append: Boolean); override;

Parameters

Buffer
Type: System.Void

Append
Type: Boolean

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.InternalClose Method

Summary

Represents method InternalClose.

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure InternalClose; override;
See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.InternalDelete Method

Summary

Represents method InternalDelete.

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure InternalDelete; override;
See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.InternalFirst Method

Summary

Represents method InternalFirst.

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure InternalFirst; override;
See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.InternalGotoBookmark(TTeeBookmark) Method

Summary

Represents method InternalGotoBookmark(TTeeBookmark).

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure InternalGotoBookmark(Bookmark:TTeeBookmark); override;

Parameters

Bookmark
Type: System.Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.InternalHandleException Method

Summary

Represents method InternalHandleException.

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure InternalHandleException; override;
See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.InternalInitRecord(TTeeRecordBuffer) Method

Summary

Represents method InternalInitRecord(TTeeRecordBuffer).

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure InternalInitRecord(Buffer: TTeeRecordBuffer); override;

Parameters

Buffer
Type: System.Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.InternalLast Method

Summary

Represents method InternalLast.

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure InternalLast; override;
See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.InternalOpen Method

Summary

Represents method InternalOpen.

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure InternalOpen; override;
See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.InternalPost Method

Summary

Represents method InternalPost.

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure InternalPost; override;
See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.InternalRefresh Method

Summary

Represents method InternalRefresh.

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure InternalRefresh; override;
See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.InternalSetToRecord(TTeeRecordBuffer) Method

Summary

Represents method InternalSetToRecord(TTeeRecordBuffer).

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure InternalSetToRecord(Buffer: TTeeRecordBuffer); override;

Parameters

Buffer
Type: System.Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.IsCursorOpen Method

Summary

Represents method IsCursorOpen.

Namespace: BI.Dataset
Syntax
Delphi
protected
 function IsCursorOpen: Boolean; override;

Return Value

Type: Boolean

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.RecInfoOfs Method

Summary

Represents method RecInfoOfs.

Namespace: BI.Dataset
Syntax
Delphi
protected
 Function RecInfoOfs:Integer; virtual; abstract;

Return Value

Type: Integer

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.SetBookmarkData(TTeeRecordBuffer,TTeeBookmark) Method

Summary

Represents method SetBookmarkData(TTeeRecordBuffer,TTeeBookmark).

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure SetBookmarkData(Buffer: TTeeRecordBuffer; Data: TTeeBookmark); override;

Parameters

Buffer
Type: System.Void

Data
Type: System.Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.SetBookmarkFlag(TTeeRecordBuffer,TBookmarkFlag) Method

Summary

Represents method SetBookmarkFlag(TTeeRecordBuffer,TBookmarkFlag).

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure SetBookmarkFlag(Buffer: TTeeRecordBuffer; Value: TBookmarkFlag); override;

Parameters

Buffer
Type: System.Void

Value
Type: TBookmarkFlag

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.SetFieldData(TField,TTeeValueBuffer) Method

Summary

Represents method SetFieldData(TField,TTeeValueBuffer).

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure SetFieldData(Field: TField; Buffer: TTeeValueBuffer); override;

Parameters

Field
Type: TField

Buffer
Type: System.Void

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.SetRecNo(Integer) Method

Summary

Represents method SetRecNo(Integer).

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure SetRecNo(Value: Integer); override;

Parameters

Value
Type: Integer

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBICustomDataSet.ValidActiveBuffer Method

Summary

Represents method ValidActiveBuffer.

Namespace: BI.Dataset
Syntax
Delphi
protected
 function ValidActiveBuffer:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TBICustomDataSet
  • BI.Dataset


TBIDataset Class

Summary

Represents type TBIDataset.

Namespace: BI.Dataset
Inheritance Hierarchy
TDataSet
BI.Dataset.TBICustomDataSet
BI.Dataset.TBIDataset
VCLBI.Grid.DBGrid.TBIDatasetAccess
VCLBI.Grid.TBIDatasetAccess
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64 or pidOSX32
 or pidiOSSimulator or pidiOSDevice
 or pidiOSDevice64
 )]
 TBIDataset = class(TBICustomDataSet)
 end;

The TBIDataset type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIDataset class.
Destroy | Represents the destructor of the TBIDataset class.
Top
Properties
Show:
Name | Description
Active | Represents property Active.
AfterCancel | Represents property AfterCancel.
AfterClose | Represents property AfterClose.
AfterDelete | Represents property AfterDelete.
AfterEdit | Represents property AfterEdit.
AfterInsert | Represents property AfterInsert.
AfterOpen | Represents property AfterOpen.
AfterPost | Represents property AfterPost.
AfterRefresh | Represents property AfterRefresh.
AfterScroll | Represents property AfterScroll.
BeforeCancel | Represents property BeforeCancel.
BeforeClose | Represents property BeforeClose.
BeforeDelete | Represents property BeforeDelete.
BeforeEdit | Represents property BeforeEdit.
BeforeInsert | Represents property BeforeInsert.
BeforeOpen | Represents property BeforeOpen.
BeforePost | Represents property BeforePost.
BeforeRefresh | Represents property BeforeRefresh.
BeforeScroll | Represents property BeforeScroll.
Cursor | Represents property Cursor.
Data | Represents property Data.
Filter | Represents property Filter.
Link | Represents property Link.
Master | Represents property Master.
ObjectView | Represents property ObjectView.
OnCalcFields | Represents property OnCalcFields.
OnDeleteError | Represents property OnDeleteError.
OnEditError | Represents property OnEditError.
OnFilterRecord | Represents property OnFilterRecord.
OnNewRecord | Represents property OnNewRecord.
OnPostError | Represents property OnPostError.
Provider | Represents property Provider.
ReadOnly | Represents property ReadOnly.
RowNumbers | Represents property RowNumbers.
Top
Methods
Show:
Name | Description
BookMarkToIndex(TInteger) | Represents method BookMarkToIndex(TInteger). (Overrides TBICustomDataSet.BookMarkToIndex(TInteger).)
Clear | Represents method Clear.
DataOf(TField) | Represents method DataOf(TField).
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
DoAfterOpen | Represents method DoAfterOpen.
DoFillBuffer(TTeeRecordBuffer) | Represents method DoFillBuffer(TTeeRecordBuffer). (Overrides TBICustomDataSet.DoFillBuffer(TTeeRecordBuffer).)
GetFieldData(TField,TTeeValueBuffer) | Represents method GetFieldData(TField,TTeeValueBuffer).
GetIndexPosition | Represents method GetIndexPosition. (Overrides TBICustomDataSet.GetIndexPosition.)
GetRecordCount | Represents method GetRecordCount.
GetRecordSize | Represents method GetRecordSize.
GetRowItem | Represents method GetRowItem.
InternalAddRecord(TTeeAddRecordBuffer,Boolean) | Represents method InternalAddRecord(TTeeAddRecordBuffer,Boolean). (Overrides TBICustomDataSet.InternalAddRecord(TTeeAddRecordBuffer,Boolean).)
InternalClose | Represents method InternalClose. (Overrides TBICustomDataSet.InternalClose.)
InternalDelete | Represents method InternalDelete. (Overrides TBICustomDataSet.InternalDelete.)
InternalInitFieldDefs | Represents method InternalInitFieldDefs.
InternalOpen | Represents method InternalOpen. (Overrides TBICustomDataSet.InternalOpen.)
InternalPost | Represents method InternalPost. (Overrides TBICustomDataSet.InternalPost.)
InvertSortBy(TField) | Represents method InvertSortBy(TField).
IsCursorOpen | Represents method IsCursorOpen. (Overrides TBICustomDataSet.IsCursorOpen.)
Loaded | Represents method Loaded.
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
PrepareIndex(TCursorIndex,Boolean) | Represents method PrepareIndex(TCursorIndex,Boolean).
RecInfoOfs | Represents method RecInfoOfs. (Overrides TBICustomDataSet.RecInfoOfs.)
SetDataSetField(TDataSetField) | Represents method SetDataSetField(TDataSetField).
SetFieldData(TField,TTeeValueBuffer) | Represents method SetFieldData(TField,TTeeValueBuffer). (Overrides TBICustomDataSet.SetFieldData(TField,TTeeValueBuffer).)
SetFieldOnGetText(TField,Boolean) | Represents method SetFieldOnGetText(TField,Boolean).
SetFieldProps(TField,TFieldDef) | Represents method SetFieldProps(TField,TFieldDef).
SetItems(TDataArray) | Represents method SetItems(TDataArray).
Top
Fields
Show:
Name | Description
FloatFormat | Represents field FloatFormat.
Index | Represents field Index.
MasterDataLinkClass | Represents field MasterDataLinkClass.
PercentFormat | Represents field PercentFormat.
Top
See Also

Reference

  • BI.Dataset


TBIDataset Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBIDataset class.
Destroy | Represents the destructor of the TBIDataset class.
Top


TBIDataset.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIDataset class.

Namespace: BI.Dataset
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.Destroy Destructor

Summary

Represents the destructor of the TBIDataset class.

Namespace: BI.Dataset
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset Properties

Properties
Name | Description
Active | Represents property Active.
AfterCancel | Represents property AfterCancel.
AfterClose | Represents property AfterClose.
AfterDelete | Represents property AfterDelete.
AfterEdit | Represents property AfterEdit.
AfterInsert | Represents property AfterInsert.
AfterOpen | Represents property AfterOpen.
AfterPost | Represents property AfterPost.
AfterRefresh | Represents property AfterRefresh.
AfterScroll | Represents property AfterScroll.
BeforeCancel | Represents property BeforeCancel.
BeforeClose | Represents property BeforeClose.
BeforeDelete | Represents property BeforeDelete.
BeforeEdit | Represents property BeforeEdit.
BeforeInsert | Represents property BeforeInsert.
BeforeOpen | Represents property BeforeOpen.
BeforePost | Represents property BeforePost.
BeforeRefresh | Represents property BeforeRefresh.
BeforeScroll | Represents property BeforeScroll.
Cursor | Represents property Cursor.
Data | Represents property Data.
Filter | Represents property Filter.
Link | Represents property Link.
Master | Represents property Master.
ObjectView | Represents property ObjectView.
OnCalcFields | Represents property OnCalcFields.
OnDeleteError | Represents property OnDeleteError.
OnEditError | Represents property OnEditError.
OnFilterRecord | Represents property OnFilterRecord.
OnNewRecord | Represents property OnNewRecord.
OnPostError | Represents property OnPostError.
Provider | Represents property Provider.
ReadOnly | Represents property ReadOnly.
RowNumbers | Represents property RowNumbers.
Top


TBIDataset.Active Property

Summary

Represents property Active.

Namespace: BI.Dataset
Syntax
Delphi
published
 property Active;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.AfterCancel Property

Summary

Represents property AfterCancel.

Namespace: BI.Dataset
Syntax
Delphi
published
 property AfterCancel;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.AfterClose Property

Summary

Represents property AfterClose.

Namespace: BI.Dataset
Syntax
Delphi
published
 property AfterClose;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.AfterDelete Property

Summary

Represents property AfterDelete.

Namespace: BI.Dataset
Syntax
Delphi
published
 property AfterDelete;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.AfterEdit Property

Summary

Represents property AfterEdit.

Namespace: BI.Dataset
Syntax
Delphi
published
 property AfterEdit;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.AfterInsert Property

Summary

Represents property AfterInsert.

Namespace: BI.Dataset
Syntax
Delphi
published
 property AfterInsert;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.AfterOpen Property

Summary

Represents property AfterOpen.

Namespace: BI.Dataset
Syntax
Delphi
published
 property AfterOpen;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.AfterPost Property

Summary

Represents property AfterPost.

Namespace: BI.Dataset
Syntax
Delphi
published
 property AfterPost;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.AfterRefresh Property

Summary

Represents property AfterRefresh.

Namespace: BI.Dataset
Syntax
Delphi
published
 property AfterRefresh;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.AfterScroll Property

Summary

Represents property AfterScroll.

Namespace: BI.Dataset
Syntax
Delphi
published
 property AfterScroll;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.BeforeCancel Property

Summary

Represents property BeforeCancel.

Namespace: BI.Dataset
Syntax
Delphi
published
 property BeforeCancel;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.BeforeClose Property

Summary

Represents property BeforeClose.

Namespace: BI.Dataset
Syntax
Delphi
published
 property BeforeClose;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.BeforeDelete Property

Summary

Represents property BeforeDelete.

Namespace: BI.Dataset
Syntax
Delphi
published
 property BeforeDelete;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.BeforeEdit Property

Summary

Represents property BeforeEdit.

Namespace: BI.Dataset
Syntax
Delphi
published
 property BeforeEdit;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.BeforeInsert Property

Summary

Represents property BeforeInsert.

Namespace: BI.Dataset
Syntax
Delphi
published
 property BeforeInsert;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.BeforeOpen Property

Summary

Represents property BeforeOpen.

Namespace: BI.Dataset
Syntax
Delphi
published
 property BeforeOpen;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.BeforePost Property

Summary

Represents property BeforePost.

Namespace: BI.Dataset
Syntax
Delphi
published
 property BeforePost;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.BeforeRefresh Property

Summary

Represents property BeforeRefresh.

Namespace: BI.Dataset
Syntax
Delphi
published
 property BeforeRefresh;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.BeforeScroll Property

Summary

Represents property BeforeScroll.

Namespace: BI.Dataset
Syntax
Delphi
published
 property BeforeScroll;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.Cursor Property

Summary

Represents property Cursor.

Namespace: BI.Dataset
Syntax
Delphi
public
 property Cursor:TDataCursor read ICursor;

Property Value

Type: TDataCursor

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.Data Property

Summary

Represents property Data.

Namespace: BI.Dataset
Syntax
Delphi
published
 property Data:TDataItem read GetData write SetData;

Property Value

Type: TDataItem

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.Filter Property

Summary

Represents property Filter.

Namespace: BI.Dataset
Syntax
Delphi
published
 property Filter:TBIFilter read FFilter write SetFilter;

Property Value

Type: TBIFilter

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.Link Property

Summary

Represents property Link.

Namespace: BI.Dataset
Syntax
Delphi
protected
 property Link:TMasterDataLink read ILink;

Property Value

Type: TMasterDataLink

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.Master Property

Summary

Represents property Master.

Namespace: BI.Dataset
Syntax
Delphi
published
 property Master:TBIDataSet read FMaster write SetMaster;

Property Value

Type: TBIDataSet

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.ObjectView Property

Summary

Represents property ObjectView.

Namespace: BI.Dataset
Syntax
Delphi
published
 property ObjectView default True;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.OnCalcFields Property

Summary

Represents property OnCalcFields.

Namespace: BI.Dataset
Syntax
Delphi
published
 property OnCalcFields;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.OnDeleteError Property

Summary

Represents property OnDeleteError.

Namespace: BI.Dataset
Syntax
Delphi
published
 property OnDeleteError;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.OnEditError Property

Summary

Represents property OnEditError.

Namespace: BI.Dataset
Syntax
Delphi
published
 property OnEditError;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.OnFilterRecord Property

Summary

Represents property OnFilterRecord.

Namespace: BI.Dataset
Syntax
Delphi
published
 property OnFilterRecord;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.OnNewRecord Property

Summary

Represents property OnNewRecord.

Namespace: BI.Dataset
Syntax
Delphi
published
 property OnNewRecord;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.OnPostError Property

Summary

Represents property OnPostError.

Namespace: BI.Dataset
Syntax
Delphi
published
 property OnPostError;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.Provider Property

Summary

Represents property Provider.

Namespace: BI.Dataset
Syntax
Delphi
published
 property Provider:TComponent read GetProvider write SetProvider;

Property Value

Type: TComponent

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.ReadOnly Property

Summary

Represents property ReadOnly.

Namespace: BI.Dataset
Syntax
Delphi
published
 property ReadOnly default True;

Property Value

Type: Void

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.RowNumbers Property

Summary

Represents property RowNumbers.

Namespace: BI.Dataset
Syntax
Delphi
published
 property RowNumbers:Boolean read FRowNumbers write SetRowNumbers;

Property Value

Type: Boolean

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset Methods

Methods
Name | Description
BookMarkToIndex(TInteger) | Represents method BookMarkToIndex(TInteger). (Overrides TBICustomDataSet.BookMarkToIndex(TInteger).)
Clear | Represents method Clear.
DataOf(TField) | Represents method DataOf(TField).
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
DoAfterOpen | Represents method DoAfterOpen.
DoFillBuffer(TTeeRecordBuffer) | Represents method DoFillBuffer(TTeeRecordBuffer). (Overrides TBICustomDataSet.DoFillBuffer(TTeeRecordBuffer).)
GetFieldData(TField,TTeeValueBuffer) | Represents method GetFieldData(TField,TTeeValueBuffer).
GetIndexPosition | Represents method GetIndexPosition. (Overrides TBICustomDataSet.GetIndexPosition.)
GetRecordCount | Represents method GetRecordCount.
GetRecordSize | Represents method GetRecordSize.
GetRowItem | Represents method GetRowItem.
InternalAddRecord(TTeeAddRecordBuffer,Boolean) | Represents method InternalAddRecord(TTeeAddRecordBuffer,Boolean). (Overrides TBICustomDataSet.InternalAddRecord(TTeeAddRecordBuffer,Boolean).)
InternalClose | Represents method InternalClose. (Overrides TBICustomDataSet.InternalClose.)
InternalDelete | Represents method InternalDelete. (Overrides TBICustomDataSet.InternalDelete.)
InternalInitFieldDefs | Represents method InternalInitFieldDefs.
InternalOpen | Represents method InternalOpen. (Overrides TBICustomDataSet.InternalOpen.)
InternalPost | Represents method InternalPost. (Overrides TBICustomDataSet.InternalPost.)
InvertSortBy(TField) | Represents method InvertSortBy(TField).
IsCursorOpen | Represents method IsCursorOpen. (Overrides TBICustomDataSet.IsCursorOpen.)
Loaded | Represents method Loaded.
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
PrepareIndex(TCursorIndex,Boolean) | Represents method PrepareIndex(TCursorIndex,Boolean).
RecInfoOfs | Represents method RecInfoOfs. (Overrides TBICustomDataSet.RecInfoOfs.)
SetDataSetField(TDataSetField) | Represents method SetDataSetField(TDataSetField).
SetFieldData(TField,TTeeValueBuffer) | Represents method SetFieldData(TField,TTeeValueBuffer). (Overrides TBICustomDataSet.SetFieldData(TField,TTeeValueBuffer).)
SetFieldOnGetText(TField,Boolean) | Represents method SetFieldOnGetText(TField,Boolean).
SetFieldProps(TField,TFieldDef) | Represents method SetFieldProps(TField,TFieldDef).
SetItems(TDataArray) | Represents method SetItems(TDataArray).
Top


TBIDataset.BookMarkToIndex(TInteger) Method

Summary

Represents method BookMarkToIndex(TInteger).

Namespace: BI.Dataset
Syntax
Delphi
protected
 function BookMarkToIndex(const ABookMark:TInteger):TInteger; override;

Parameters

ABookMark
Type: System.Void

Return Value

Type: TInteger

Overrides

TBICustomDataSet.BookMarkToIndex(TInteger)
See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.Clear Method

Summary

Represents method Clear.

Namespace: BI.Dataset
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.DataOf(TField) Method

Summary

Represents method DataOf(TField).

Namespace: BI.Dataset
Syntax
Delphi
public
 function DataOf(const AField:TField):TDataItem;

Parameters

AField
Type: TField

Return Value

Type: TDataItem

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.DoAfterOpen Method

Summary

Represents method DoAfterOpen.

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure DoAfterOpen; override;
See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.DoFillBuffer(TTeeRecordBuffer) Method

Summary

Represents method DoFillBuffer(TTeeRecordBuffer).

Namespace: BI.Dataset
Syntax
Delphi
protected
 Procedure DoFillBuffer(const Buffer: TTeeRecordBuffer); override;

Parameters

Buffer
Type: System.Void

Overrides

TBICustomDataSet.DoFillBuffer(TTeeRecordBuffer)
See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.GetFieldData(TField,TTeeValueBuffer) Method

Summary

Represents method GetFieldData(TField,TTeeValueBuffer).

Namespace: BI.Dataset
Syntax
Delphi
public
 function GetFieldData(Field: TField; var Buffer: TTeeValueBuffer): Boolean; override;

Parameters

Field
Type: TField

Buffer
Type: System.Void

Return Value

Type: Boolean

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.GetIndexPosition Method

Summary

Represents method GetIndexPosition.

Namespace: BI.Dataset
Syntax
Delphi
protected
 function GetIndexPosition:TInteger; override;

Return Value

Type: TInteger

Overrides

TBICustomDataSet.GetIndexPosition
See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.GetRecordCount Method

Summary

Represents method GetRecordCount.

Namespace: BI.Dataset
Syntax
Delphi
protected
 function GetRecordCount: Integer; override;

Return Value

Type: Integer

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.GetRecordSize Method

Summary

Represents method GetRecordSize.

Namespace: BI.Dataset
Syntax
Delphi
protected
 function GetRecordSize: Word; override;

Return Value

Type: Word

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.GetRowItem Method

Summary

Represents method GetRowItem.

Namespace: BI.Dataset
Syntax
Delphi
protected
 function GetRowItem: TDataItem;

Return Value

Type: TDataItem

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.InternalAddRecord(TTeeAddRecordBuffer,Boolean) Method

Summary

Represents method InternalAddRecord(TTeeAddRecordBuffer,Boolean).

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure InternalAddRecord(Buffer: TTeeAddRecordBuffer; Append: Boolean); override;

Parameters

Buffer
Type: System.Void

Append
Type: Boolean

Overrides

TBICustomDataSet.InternalAddRecord(TTeeAddRecordBuffer,Boolean)
See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.InternalClose Method

Summary

Represents method InternalClose.

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure InternalClose; override;

Overrides

TBICustomDataSet.InternalClose
See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.InternalDelete Method

Summary

Represents method InternalDelete.

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure InternalDelete; override;

Overrides

TBICustomDataSet.InternalDelete
See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.InternalInitFieldDefs Method

Summary

Represents method InternalInitFieldDefs.

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure InternalInitFieldDefs; override;
See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.InternalOpen Method

Summary

Represents method InternalOpen.

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure InternalOpen; override;

Overrides

TBICustomDataSet.InternalOpen
See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.InternalPost Method

Summary

Represents method InternalPost.

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure InternalPost; override;

Overrides

TBICustomDataSet.InternalPost
See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.InvertSortBy(TField) Method

Summary

Represents method InvertSortBy(TField).

Namespace: BI.Dataset
Syntax
Delphi
public
 procedure InvertSortBy(const AField:TField);

Parameters

AField
Type: TField

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.IsCursorOpen Method

Summary

Represents method IsCursorOpen.

Namespace: BI.Dataset
Syntax
Delphi
protected
 function IsCursorOpen: Boolean; override;

Return Value

Type: Boolean

Overrides

TBICustomDataSet.IsCursorOpen
See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.Loaded Method

Summary

Represents method Loaded.

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure Loaded; override;
See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure Notification( AComponent: TComponent; Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.PrepareIndex(TCursorIndex,Boolean) Method

Summary

Represents method PrepareIndex(TCursorIndex,Boolean).

Namespace: BI.Dataset
Syntax
Delphi
public
 procedure PrepareIndex(const AIndex:TCursorIndex; const AllRows:Boolean=True);

Parameters

AIndex
Type: System.Void

AllRows
Type: Boolean

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.RecInfoOfs Method

Summary

Represents method RecInfoOfs.

Namespace: BI.Dataset
Syntax
Delphi
protected
 Function RecInfoOfs: Integer; override;

Return Value

Type: Integer

Overrides

TBICustomDataSet.RecInfoOfs
See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.SetDataSetField(TDataSetField) Method

Summary

Represents method SetDataSetField(TDataSetField).

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure SetDataSetField(const Value: TDataSetField); override;

Parameters

Value
Type: TDataSetField

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.SetFieldData(TField,TTeeValueBuffer) Method

Summary

Represents method SetFieldData(TField,TTeeValueBuffer).

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure SetFieldData(Field: TField; Buffer: TTeeValueBuffer); override;

Parameters

Field
Type: TField

Buffer
Type: System.Void

Overrides

TBICustomDataSet.SetFieldData(TField,TTeeValueBuffer)
See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.SetFieldOnGetText(TField,Boolean) Method

Summary

Represents method SetFieldOnGetText(TField,Boolean).

Namespace: BI.Dataset
Syntax
Delphi
public
 procedure SetFieldOnGetText(const AField:TField; const Hide:Boolean);

Parameters

AField
Type: TField

Hide
Type: Boolean

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.SetFieldProps(TField,TFieldDef) Method

Summary

Represents method SetFieldProps(TField,TFieldDef).

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure SetFieldProps(Field: TField; FieldDef: TFieldDef); override;

Parameters

Field
Type: TField

FieldDef
Type: TFieldDef

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.SetItems(TDataArray) Method

Summary

Represents method SetItems(TDataArray).

Namespace: BI.Dataset
Syntax
Delphi
public
 procedure SetItems(const AData:TDataArray);

Parameters

AData
Type: TDataArray

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset Fields

Fields
Name | Description
FloatFormat | Represents field FloatFormat.
Index | Represents field Index.
MasterDataLinkClass | Represents field MasterDataLinkClass.
PercentFormat | Represents field PercentFormat.
Top


TBIDataset.FloatFormat Field

Summary

Represents field FloatFormat.

Namespace: BI.Dataset
Syntax
Delphi
public
 FloatFormat : String;

Field Value

Type: String

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.Index Field

Summary

Represents field Index.

Namespace: BI.Dataset
Syntax
Delphi
protected
 Index : TCursorIndex;

Field Value

Type: TCursorIndex

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.MasterDataLinkClass Field

Summary

Represents field MasterDataLinkClass.

Namespace: BI.Dataset
Syntax
Delphi
public
 MasterDataLinkClass : TBIMasterDataLinkClass;

Field Value

Type: TBIMasterDataLinkClass

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.PercentFormat Field

Summary

Represents field PercentFormat.

Namespace: BI.Dataset
Syntax
Delphi
public
 PercentFormat : String;

Field Value

Type: String

See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.TBIMasterDataLink Class

Summary

Represents type TBIMasterDataLink.

Namespace: BI.Dataset
Inheritance Hierarchy
TMasterDataLink
BI.Dataset.TBIDataset.TBIMasterDataLink
Syntax
Delphi
public
type
 TBIMasterDataLink=class(TMasterDataLink)
 end;

The TBIDataset.TBIMasterDataLink type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TBIDataset.TBIMasterDataLink class.
Top
Methods
Show:
Name | Description
ActiveChanged | Represents method ActiveChanged.
RecordChanged(TField) | Represents method RecordChanged(TField).
Top
See Also

Reference

  • TBIDataset
  • BI.Dataset


TBIDataset.TBIMasterDataLink Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TBIDataset.TBIMasterDataLink class.
Top


TBIDataset.TBIMasterDataLink.Destroy Destructor

Summary

Represents the destructor of the TBIDataset.TBIMasterDataLink class.

Namespace: BI.Dataset
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIDataset.TBIMasterDataLink
  • TBIDataset
  • BI.Dataset


TBIDataset.TBIMasterDataLink Methods

Methods
Name | Description
ActiveChanged | Represents method ActiveChanged.
RecordChanged(TField) | Represents method RecordChanged(TField).
Top


TBIDataset.TBIMasterDataLink.ActiveChanged Method

Summary

Represents method ActiveChanged.

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure ActiveChanged; override;
See Also

Reference

  • TBIDataset.TBIMasterDataLink
  • TBIDataset
  • BI.Dataset


TBIDataset.TBIMasterDataLink.RecordChanged(TField) Method

Summary

Represents method RecordChanged(TField).

Namespace: BI.Dataset
Syntax
Delphi
protected
 procedure RecordChanged(Field: TField); override;

Parameters

Field
Type: TField

See Also

Reference

  • TBIDataset.TBIMasterDataLink
  • TBIDataset
  • BI.Dataset


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.Dataset
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Dataset.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.Dataset


TDataCursorAccess Class

Summary

Represents type TDataCursorAccess.

Namespace: BI.Dataset
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.DataSource.TDataCursor
BI.Dataset.TDataCursorAccess
Syntax
Delphi
type
 TDataCursorAccess=class(TDataCursor);
See Also

Reference

  • BI.Dataset


BI.Dataset Records

Records
Name | Description
TItem | Represents type TItem.
TRecInfo | Represents type TRecInfo.
Top


TItem Record

Summary

Represents type TItem.

Namespace: BI.Dataset
Syntax
Delphi
type
 TItem=packed record
 end;

The TItem type exposes the following members.

Fields
Show:
Name | Description
Data | Represents field Data.
Missing | Represents field Missing.
Top
See Also

Reference

  • BI.Dataset


TItem Fields

Fields
Name | Description
Data | Represents field Data.
Missing | Represents field Missing.
Top


TItem.Data Field

Summary

Represents field Data.

Namespace: BI.Dataset
Syntax
Delphi
public
 Data : TItemData;

Field Value

Type: TItemData

See Also

Reference

  • TItem
  • BI.Dataset


TItem.Missing Field

Summary

Represents field Missing.

Namespace: BI.Dataset
Syntax
Delphi
public
 Missing : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TItem
  • BI.Dataset


TRecInfo Record

Summary

Represents type TRecInfo.

Namespace: BI.Dataset
Syntax
Delphi
type
 TRecInfo = packed record
 end;

The TRecInfo type exposes the following members.

Fields
Show:
Name | Description
Bookmark | Represents field Bookmark.
BookmarkFlag | Represents field BookmarkFlag.
Top
See Also

Reference

  • BI.Dataset


TRecInfo Fields

Fields
Name | Description
Bookmark | Represents field Bookmark.
BookmarkFlag | Represents field BookmarkFlag.
Top


TRecInfo.Bookmark Field

Summary

Represents field Bookmark.

Namespace: BI.Dataset
Syntax
Delphi
public
 Bookmark : Integer;

Field Value

Type: Integer

See Also

Reference

  • TRecInfo
  • BI.Dataset


TRecInfo.BookmarkFlag Field

Summary

Represents field BookmarkFlag.

Namespace: BI.Dataset
Syntax
Delphi
public
 BookmarkFlag : TBookmarkFlag;

Field Value

Type: TBookmarkFlag

See Also

Reference

  • TRecInfo
  • BI.Dataset


BI.Dataset Types

Types
Name | Description
PItems | Represents a pointer type to TItems.
PRecInfo | Represents a pointer type to TRecInfo.
TBIDataset.TBIMasterDataLinkClass | Represents type TBIMasterDataLinkClass.
TItemData | Represents an array of the Byte type.
TItems | Represents an array of the TItem type.
TTeeAddRecordBuffer | Represents an alias of the TTeeRecordBuffer type.
TTeeBookmark | Represents an alias of the TBookmark type.
TTeeRecordBuffer | Represents an alias of the TRecordBuffer type.
TTeeRecordBufferP | Represents an alias of the TRecordBuffer type.
TTeeValueBuffer | Represents an alias of the TValueBuffer type.
Top


PItems Type

Summary

Represents a pointer type to TItems.

Namespace: BI.Dataset
Syntax
Delphi
type
 PItems=^TItems;
See Also

Reference

  • BI.Dataset


PRecInfo Type

Summary

Represents a pointer type to TRecInfo.

Namespace: BI.Dataset
Syntax
Delphi
type
 PRecInfo = ^TRecInfo;
See Also

Reference

  • BI.Dataset


TBIDataset.TBIMasterDataLinkClass Type

Summary

Represents type TBIMasterDataLinkClass.

Namespace: BI.Dataset
Syntax
Delphi
public
type
 TBIMasterDataLinkClass=class of TBIMasterDataLink;
See Also

Reference

  • TBIDataset
  • BI.Dataset


TItemData Type

Summary

Represents an array of the Byte type.

Namespace: BI.Dataset
Syntax
Delphi
type
 TItemData=packed Array[0..MaxDataSize-1] of Byte;
See Also

Reference

  • BI.Dataset


TItems Type

Summary

Represents an array of the TItem type.

Namespace: BI.Dataset
Syntax
Delphi
type
 TItems=packed Array[0..10000] of TItem;
See Also

Reference

  • BI.Dataset


TTeeAddRecordBuffer Type

Summary

Represents an alias of the TTeeRecordBuffer type.

Namespace: BI.Dataset
Syntax
Delphi
type
 TTeeAddRecordBuffer=TTeeRecordBuffer;
See Also

Reference

  • BI.Dataset


TTeeBookmark Type

Summary

Represents an alias of the TBookmark type.

Namespace: BI.Dataset
Syntax
Delphi
type
 TTeeBookmark=TBookmark;
See Also

Reference

  • BI.Dataset


TTeeRecordBuffer Type

Summary

Represents an alias of the TRecordBuffer type.

Namespace: BI.Dataset
Syntax
Delphi
type
 TTeeRecordBuffer=TRecordBuffer;
See Also

Reference

  • BI.Dataset


TTeeRecordBufferP Type

Summary

Represents an alias of the TRecordBuffer type.

Namespace: BI.Dataset
Syntax
Delphi
type
 TTeeRecordBufferP=TRecordBuffer;
See Also

Reference

  • BI.Dataset


TTeeValueBuffer Type

Summary

Represents an alias of the TValueBuffer type.

Namespace: BI.Dataset
Syntax
Delphi
type
 TTeeValueBuffer=TValueBuffer;
See Also

Reference

  • BI.Dataset


BI.Dataset Constants

Constants
Name | Description
MaxDataSize | Represents constant MaxDataSize.
Top


MaxDataSize Constant

Summary

Represents constant MaxDataSize.

Namespace: BI.Dataset
Syntax
Delphi
 MaxDataSize=512;

Value

Type: SmallInt

See Also

Reference

  • BI.Dataset


BI.Dataset Routines

Routines
Name | Description
BufferToString(PByte) | Represents method BufferToString(PByte).
CopyBuffer(TField,PByte,PByte) | Represents method CopyBuffer(TField,PByte,PByte).
StringToBuffer(PByte,String) | Represents method StringToBuffer(PByte,String).
Top


BufferToString(PByte) Method

Summary

Represents method BufferToString(PByte).

Namespace: BI.Dataset
Syntax
Delphi
function BufferToString(const P:PByte):String; inline;

Parameters

P
Type: PByte

Return Value

Type: String

See Also

Reference

  • BI.Dataset


CopyBuffer(TField,PByte,PByte) Method

Summary

Represents method CopyBuffer(TField,PByte,PByte).

Namespace: BI.Dataset
Syntax
Delphi
procedure CopyBuffer(const AField:TField; const ASource,ADest:PByte);

Parameters

AField
Type: TField

ASource
Type: PByte

ADest
Type: PByte

See Also

Reference

  • BI.Dataset


StringToBuffer(PByte,String) Method

Summary

Represents method StringToBuffer(PByte,String).

Namespace: BI.Dataset
Syntax
Delphi
procedure StringToBuffer(const P:PByte; const S:String);

Parameters

P
Type: PByte

S
Type: String

See Also

Reference

  • BI.Dataset


BI.DataSource Namespace

Summary

Represents namespace BI.DataSource.

Classes
Name | Description
TBIExport | Represents type TBIExport.
TBIExportersHelper | Represents type TBIExportersHelper.
TBIFileImporter | Represents type TBIFileImporter.
TBIFileImportersHelper | Represents type TBIFileImportersHelper.
TBIFileSource | Represents type TBIFileSource.
TBIHierarchicalSource | Represents type TBIHierarchicalSource.
TBIItemsSource | Represents type TBIItemsSource.
TBINativeExport | Represents type TBINativeExport.
TBINativeImporter | Represents type TBINativeImporter.
TBISource | Represents type TBISource.
TBITextExport | Represents type TBITextExport.
TBITextSource | Represents type TBITextSource.
TDataAccess | Represents type TDataAccess.
TDataCursor | Represents type TDataCursor.
TDataCursorItemsHelper | Represents type TDataCursorItemsHelper.
TDataItemAccess | Represents type TDataItemAccess.
TDataItemsAccess | Represents type TDataItemsAccess.
TDataSelect | Represents type TDataSelect.
TExpressionColumnAccess | Represents type TExpressionColumnAccess.
TFileFiltersHelper | Represents type TFileFiltersHelper.
Top
Records
Name | Description
TDataClone | Represents type TDataClone.
TDataCursorItem | Represents type TDataCursorItem.
TFileFilter | Represents type TFileFilter.
Top
Enumerations
Name | Description
TFileShareMode | Represents type TFileShareMode.
Top
Delegates
Name | Description
TCursorLoopObject | Represents type TCursorLoopObject.
TExportGetText | Represents type TExportGetText.
Top
Types
Name | Description
TBIExportClass | Represents type TBIExportClass.
TBIExporters | Represents an array of the TBIExportClass type.
TBIFileImporters | Represents an array of the TBIFileSourceClass type.
TBIFileSourceClass | Represents type TBIFileSourceClass.
TCursorIndex | Represents an alias of the TNativeIntArray type.
TCursorLoop | Represents type TCursorLoop.
TDataCursorItems | Represents an array of the TDataCursorItem type.
TFileFilters | Represents an array of the TFileFilter type.
Top
Routines
Name | Description
CheckZBS | Represents method CheckZBS.
CloneItem(TDataItem,TDataArray) | Represents method CloneItem(TDataItem,TDataArray).
GetFilesFrom(String,String,String,Boolean) | Represents method GetFilesFrom(String,String,String,Boolean).
Top


BI.DataSource Classes

Classes
Name | Description
TBIExport | Represents type TBIExport.
TBIExportersHelper | Represents type TBIExportersHelper.
TBIFileImporter | Represents type TBIFileImporter.
TBIFileImportersHelper | Represents type TBIFileImportersHelper.
TBIFileSource | Represents type TBIFileSource.
TBIHierarchicalSource | Represents type TBIHierarchicalSource.
TBIItemsSource | Represents type TBIItemsSource.
TBINativeExport | Represents type TBINativeExport.
TBINativeImporter | Represents type TBINativeImporter.
TBISource | Represents type TBISource.
TBITextExport | Represents type TBITextExport.
TBITextSource | Represents type TBITextSource.
TDataAccess | Represents type TDataAccess.
TDataCursor | Represents type TDataCursor.
TDataCursorItemsHelper | Represents type TDataCursorItemsHelper.
TDataItemAccess | Represents type TDataItemAccess.
TDataItemsAccess | Represents type TDataItemsAccess.
TDataSelect | Represents type TDataSelect.
TExpressionColumnAccess | Represents type TExpressionColumnAccess.
TFileFiltersHelper | Represents type TFileFiltersHelper.
Top


TBIExport Class

Summary

Represents type TBIExport.

Namespace: BI.DataSource
Inheritance Hierarchy
TObject
BI.DataSource.TBIExport
BI.ClientDataset.TClientDatasetExport
BI.DataSource.TBINativeExport
BI.DataSource.TBITextExport
BI.Excel.TBIExcelExport
Syntax
Delphi
type
 TBIExport=class
 end;

The TBIExport type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TBIExport class.
Destroy | Represents the destructor of the TBIExport class.
Top
Properties
Show:
Name | Description
Data | Represents property Data.
SchemaOnly | Represents property SchemaOnly.
Top
Methods
Show:
Name | Description
AsString | Overloaded. Represents method AsString.
AsString(TDataItem) | Overloaded. Represents method AsString(TDataItem).
DoEmit(TStrings) | Represents method DoEmit(TStrings).
EmitTo(TStrings) | Represents method EmitTo(TStrings).
FileFilter | Represents method FileFilter.
SaveToFile(String) | Overloaded. Represents method SaveToFile(String).
SaveToFile(TDataItem,String) | Overloaded. Represents method SaveToFile(TDataItem,String).
SaveToStream(TStream) | Represents method SaveToStream(TStream).
Supports(String) | Represents method Supports(String).
ToStrings | Overloaded. Represents method ToStrings.
ToStrings(TDataItem) | Overloaded. Represents method ToStrings(TDataItem).
Top
Events
Show:
Name | Description
OnGetText | Represents property OnGetText.
Top
Fields
Show:
Name | Description
BinaryOnly | Represents field BinaryOnly.
Cursor | Represents field Cursor.
FOnGetText | Represents field FOnGetText.
Items | Represents field Items.
Totals | Represents field Totals.
Top
See Also

Reference

  • BI.DataSource


TBIExport Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TBIExport class.
Destroy | Represents the destructor of the TBIExport class.
Top


TBIExport.Create Constructor

Summary

Initializes a new instance of the TBIExport class.

Namespace: BI.DataSource
Syntax
Delphi
public
 Constructor Create; virtual;
See Also

Reference

  • TBIExport
  • BI.DataSource


TBIExport.Destroy Destructor

Summary

Represents the destructor of the TBIExport class.

Namespace: BI.DataSource
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIExport
  • BI.DataSource


TBIExport Properties

Properties
Name | Description
Data | Represents property Data.
SchemaOnly | Represents property SchemaOnly.
Top


TBIExport.Data Property

Summary

Represents property Data.

Namespace: BI.DataSource
Syntax
Delphi
public
 property Data:TDataItem read GetData write SetData;

Property Value

Type: TDataItem

See Also

Reference

  • TBIExport
  • BI.DataSource


TBIExport.SchemaOnly Property

Summary

Represents property SchemaOnly.

Namespace: BI.DataSource
Syntax
Delphi
public
 property SchemaOnly:Boolean read FSchemaOnly write FSchemaOnly default False;

Property Value

Type: Boolean

See Also

Reference

  • TBIExport
  • BI.DataSource


TBIExport Methods

Methods
Name | Description
AsString | Overloaded. Represents method AsString.
AsString(TDataItem) | Overloaded. Represents method AsString(TDataItem).
DoEmit(TStrings) | Represents method DoEmit(TStrings).
EmitTo(TStrings) | Represents method EmitTo(TStrings).
FileFilter | Represents method FileFilter.
SaveToFile(String) | Overloaded. Represents method SaveToFile(String).
SaveToFile(TDataItem,String) | Overloaded. Represents method SaveToFile(TDataItem,String).
SaveToStream(TStream) | Represents method SaveToStream(TStream).
Supports(String) | Represents method Supports(String).
ToStrings | Overloaded. Represents method ToStrings.
ToStrings(TDataItem) | Overloaded. Represents method ToStrings(TDataItem).
Top


TBIExport.AsString Method

Summary

Represents method AsString.

Namespace: BI.DataSource
Syntax
Delphi
public
 function AsString:String; overload;

Return Value

Type: String

See Also

Reference

  • TBIExport
  • BI.DataSource


TBIExport.AsString(TDataItem) Method

Summary

Represents method AsString(TDataItem).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function AsString(const AData:TDataItem):String; overload;

Parameters

AData
Type: TDataItem

Return Value

Type: String

See Also

Reference

  • TBIExport
  • BI.DataSource


TBIExport.DoEmit(TStrings) Method

Summary

Represents method DoEmit(TStrings).

Namespace: BI.DataSource
Syntax
Delphi
protected
 procedure DoEmit(const AItems: TStrings); virtual;

Parameters

AItems
Type: TStrings

See Also

Reference

  • TBIExport
  • BI.DataSource


TBIExport.EmitTo(TStrings) Method

Summary

Represents method EmitTo(TStrings).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure EmitTo(const AItems: TStrings);

Parameters

AItems
Type: TStrings

See Also

Reference

  • TBIExport
  • BI.DataSource


TBIExport.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.DataSource
Syntax
Delphi
public
 class function FileFilter:TFileFilters; virtual;

Return Value

Type: TFileFilters

See Also

Reference

  • TBIExport
  • BI.DataSource


TBIExport.SaveToFile(String) Method

Summary

Represents method SaveToFile(String).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure SaveToFile(const AFileName:String); overload; virtual;

Parameters

AFileName
Type: String

See Also

Reference

  • TBIExport
  • BI.DataSource


TBIExport.SaveToFile(TDataItem,String) Method

Summary

Represents method SaveToFile(TDataItem,String).

Namespace: BI.DataSource
Syntax
Delphi
public
 class procedure SaveToFile(const AData:TDataItem; const AFileName:String); overload;

Parameters

AData
Type: TDataItem

AFileName
Type: String

See Also

Reference

  • TBIExport
  • BI.DataSource


TBIExport.SaveToStream(TStream) Method

Summary

Represents method SaveToStream(TStream).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure SaveToStream(const AStream:TStream);

Parameters

AStream
Type: TStream

See Also

Reference

  • TBIExport
  • BI.DataSource


TBIExport.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; virtual; abstract;

Parameters

Extension
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TBIExport
  • BI.DataSource


TBIExport.ToStrings Method

Summary

Represents method ToStrings.

Namespace: BI.DataSource
Syntax
Delphi
public
 function ToStrings:TStrings; overload;

Return Value

Type: TStrings

See Also

Reference

  • TBIExport
  • BI.DataSource


TBIExport.ToStrings(TDataItem) Method

Summary

Represents method ToStrings(TDataItem).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function ToStrings(const AData:TDataItem):TStrings; overload;

Parameters

AData
Type: TDataItem

Return Value

Type: TStrings

See Also

Reference

  • TBIExport
  • BI.DataSource


TBIExport Events

Events
Name | Description
OnGetText | Represents property OnGetText.
Top


TBIExport.OnGetText Event

Summary

Represents property OnGetText.

Namespace: BI.DataSource
Syntax
Delphi
public
 property OnGetText:TExportGetText read FOnGetText write FOnGetText;

Value

Type: TExportGetText

See Also

Reference

  • TBIExport
  • BI.DataSource


TBIExport Fields

Fields
Name | Description
BinaryOnly | Represents field BinaryOnly.
Cursor | Represents field Cursor.
FOnGetText | Represents field FOnGetText.
Items | Represents field Items.
Totals | Represents field Totals.
Top


TBIExport.BinaryOnly Field

Summary

Represents field BinaryOnly.

Namespace: BI.DataSource
Syntax
Delphi
public
 BinaryOnly : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBIExport
  • BI.DataSource


TBIExport.Cursor Field

Summary

Represents field Cursor.

Namespace: BI.DataSource
Syntax
Delphi
public
 Cursor : TDataCursor;

Field Value

Type: TDataCursor

See Also

Reference

  • TBIExport
  • BI.DataSource


TBIExport.FOnGetText Field

Summary

Represents field FOnGetText.

Namespace: BI.DataSource
Syntax
Delphi
protected
 FOnGetText : TExportGetText;

Field Value

Type: TExportGetText

See Also

Reference

  • TBIExport
  • BI.DataSource


TBIExport.Items Field

Summary

Represents field Items.

Namespace: BI.DataSource
Syntax
Delphi
protected
 Items : TDataArray;

Field Value

Type: TDataArray

See Also

Reference

  • TBIExport
  • BI.DataSource


TBIExport.Totals Field

Summary

Represents field Totals.

Namespace: BI.DataSource
Syntax
Delphi
public
 Totals : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TBIExport
  • BI.DataSource


TBIExportersHelper Class Helper

Summary

Represents type TBIExportersHelper.

Namespace: BI.DataSource
Syntax
Delphi
type
 TBIExportersHelper=record helper for TBIExporters
 end;
Methods
Name | Description
Find(TBIExportClass) | Represents method Find(TBIExportClass).
GuessExtension(String) | Represents method GuessExtension(String).
RegisterClass(TBIExportClass) | Represents method RegisterClass(TBIExportClass).
UnRegisterClass(TBIExportClass) | Represents method UnRegisterClass(TBIExportClass).
Top
Fields
Name | Description
Items | Represents field Items.
Top
See Also

Reference

  • BI.DataSource


TBIExportersHelper Methods

Methods
Name | Description
Find(TBIExportClass) | Represents method Find(TBIExportClass).
GuessExtension(String) | Represents method GuessExtension(String).
RegisterClass(TBIExportClass) | Represents method RegisterClass(TBIExportClass).
UnRegisterClass(TBIExportClass) | Represents method UnRegisterClass(TBIExportClass).
Top


TBIExportersHelper.Find(TBIExportClass) Method

Summary

Represents method Find(TBIExportClass).

Namespace: BI.DataSource
Syntax
Delphi
protected
 class function Find(const AClass:TBIExportClass):Integer; static;

Parameters

AClass
Type: TBIExportClass

Return Value

Type: Integer

See Also

Reference

  • TBIExportersHelper
  • BI.DataSource


TBIExportersHelper.GuessExtension(String) Method

Summary

Represents method GuessExtension(String).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function GuessExtension(const Extension:String):TBIExportClass; static;

Parameters

Extension
Type: String

Return Value

Type: TBIExportClass

See Also

Reference

  • TBIExportersHelper
  • BI.DataSource


TBIExportersHelper.RegisterClass(TBIExportClass) Method

Summary

Represents method RegisterClass(TBIExportClass).

Namespace: BI.DataSource
Syntax
Delphi
public
 class procedure RegisterClass(const AClass:TBIExportClass); static;

Parameters

AClass
Type: TBIExportClass

See Also

Reference

  • TBIExportersHelper
  • BI.DataSource


TBIExportersHelper.UnRegisterClass(TBIExportClass) Method

Summary

Represents method UnRegisterClass(TBIExportClass).

Namespace: BI.DataSource
Syntax
Delphi
public
 class procedure UnRegisterClass(const AClass:TBIExportClass); static;

Parameters

AClass
Type: TBIExportClass

See Also

Reference

  • TBIExportersHelper
  • BI.DataSource


TBIExportersHelper Fields

Fields
Name | Description
Items | Represents field Items.
Top


TBIExportersHelper.Items Field

Summary

Represents field Items.

Namespace: BI.DataSource
Syntax
Delphi
public
 class var
 Items : TBIExporters;

Field Value

Type: TBIExporters

See Also

Reference

  • TBIExportersHelper
  • BI.DataSource


TBIFileImporter Class

Summary

Represents type TBIFileImporter.

Namespace: BI.DataSource
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Persist.TDataImporter
BI.DataSource.TBIFileImporter
Syntax
Delphi
type
 TBIFileImporter=class(TDataImporter)
 end;

The TBIFileImporter type exposes the following members.

Constructors
Show:
Name | Description
CreateDefinition(String,TDataDefinition) | Initializes a new instance of the TBIFileImporter class. (Overrides TDataImporter.CreateDefinition(String,TDataDefinition).)
Top
Methods
Show:
Name | Description
AllData | Represents method AllData. (Overrides TDataImporter.AllData.)
GetDefinition(String) | Represents method GetDefinition(String). (Overrides TDataImporter.GetDefinition(String).)
Import | Represents method Import. (Overrides TDataImporter.Import.)
IsRemote | Represents method IsRemote. (Overrides TDataImporter.IsRemote.)
Load(String) | Represents method Load(String). (Overrides TDataImporter.Load(String).)
Supports(TDataDefinitionKind,TDataDefinition) | Represents method Supports(TDataDefinitionKind,TDataDefinition). (Overrides TDataImporter.Supports(TDataDefinitionKind,TDataDefinition).)
Top
See Also

Reference

  • BI.DataSource


TBIFileImporter Constructors

Constructors
Name | Description
CreateDefinition(String,TDataDefinition) | Initializes a new instance of the TBIFileImporter class. (Overrides TDataImporter.CreateDefinition(String,TDataDefinition).)
Top


TBIFileImporter.CreateDefinition(String,TDataDefinition) Constructor

Summary

Initializes a new instance of the TBIFileImporter class.

Namespace: BI.DataSource
Syntax
Delphi
public
 Constructor CreateDefinition(const AStore:String; const ADefinition:TDataDefinition); override;

Parameters

AStore
Type: String

ADefinition
Type: TDataDefinition

Overrides

TDataImporter.CreateDefinition(String,TDataDefinition)
See Also

Reference

  • TBIFileImporter
  • BI.DataSource


TBIFileImporter Methods

Methods
Name | Description
AllData | Represents method AllData. (Overrides TDataImporter.AllData.)
GetDefinition(String) | Represents method GetDefinition(String). (Overrides TDataImporter.GetDefinition(String).)
Import | Represents method Import. (Overrides TDataImporter.Import.)
IsRemote | Represents method IsRemote. (Overrides TDataImporter.IsRemote.)
Load(String) | Represents method Load(String). (Overrides TDataImporter.Load(String).)
Supports(TDataDefinitionKind,TDataDefinition) | Represents method Supports(TDataDefinitionKind,TDataDefinition). (Overrides TDataImporter.Supports(TDataDefinitionKind,TDataDefinition).)
Top


TBIFileImporter.AllData Method

Summary

Represents method AllData.

Namespace: BI.DataSource
Syntax
Delphi
public
 function AllData:TStringArray; override;

Return Value

Type: TStringArray

Overrides

TDataImporter.AllData
See Also

Reference

  • TBIFileImporter
  • BI.DataSource


TBIFileImporter.GetDefinition(String) Method

Summary

Represents method GetDefinition(String).

Namespace: BI.DataSource
Syntax
Delphi
public
 function GetDefinition(const AName:String):TDataDefinition; override;

Parameters

AName
Type: String

Return Value

Type: TDataDefinition

Overrides

TDataImporter.GetDefinition(String)
See Also

Reference

  • TBIFileImporter
  • BI.DataSource


TBIFileImporter.Import Method

Summary

Represents method Import.

Namespace: BI.DataSource
Syntax
Delphi
public
 function Import:TDataArray; override;

Return Value

Type: TDataArray

Overrides

TDataImporter.Import
See Also

Reference

  • TBIFileImporter
  • BI.DataSource


TBIFileImporter.IsRemote Method

Summary

Represents method IsRemote.

Namespace: BI.DataSource
Syntax
Delphi
public
 class function IsRemote:Boolean; override;

Return Value

Type: Boolean

Overrides

TDataImporter.IsRemote
See Also

Reference

  • TBIFileImporter
  • BI.DataSource


TBIFileImporter.Load(String) Method

Summary

Represents method Load(String).

Namespace: BI.DataSource
Syntax
Delphi
public
 function Load(const AName:String):TDataItem; override;

Parameters

AName
Type: String

Return Value

Type: TDataItem

Overrides

TDataImporter.Load(String)
See Also

Reference

  • TBIFileImporter
  • BI.DataSource


TBIFileImporter.Supports(TDataDefinitionKind,TDataDefinition) Method

Summary

Represents method Supports(TDataDefinitionKind,TDataDefinition).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function Supports(const Kind:TDataDefinitionKind;
 const ADefinition:TDataDefinition=nil):Boolean; override;

Parameters

Kind
Type: TDataDefinitionKind

ADefinition
Type: TDataDefinition

Return Value

Type: Boolean

Overrides

TDataImporter.Supports(TDataDefinitionKind,TDataDefinition)
See Also

Reference

  • TBIFileImporter
  • BI.DataSource


TBIFileImportersHelper Class Helper

Summary

Represents type TBIFileImportersHelper.

Namespace: BI.DataSource
Syntax
Delphi
type
 TBIFileImportersHelper=record helper for TBIFileImporters
 end;
Methods
Name | Description
Find(TBIFileSourceClass) | Represents method Find(TBIFileSourceClass).
GuessExtension(String) | Represents method GuessExtension(String).
RegisterClass(TBIFileSourceClass) | Represents method RegisterClass(TBIFileSourceClass).
UnRegisterClass(TBIFileSourceClass) | Represents method UnRegisterClass(TBIFileSourceClass).
Top
Fields
Name | Description
Items | Represents field Items.
Top
See Also

Reference

  • BI.DataSource


TBIFileImportersHelper Methods

Methods
Name | Description
Find(TBIFileSourceClass) | Represents method Find(TBIFileSourceClass).
GuessExtension(String) | Represents method GuessExtension(String).
RegisterClass(TBIFileSourceClass) | Represents method RegisterClass(TBIFileSourceClass).
UnRegisterClass(TBIFileSourceClass) | Represents method UnRegisterClass(TBIFileSourceClass).
Top


TBIFileImportersHelper.Find(TBIFileSourceClass) Method

Summary

Represents method Find(TBIFileSourceClass).

Namespace: BI.DataSource
Syntax
Delphi
protected
 class function Find(const AClass:TBIFileSourceClass):Integer; static;

Parameters

AClass
Type: TBIFileSourceClass

Return Value

Type: Integer

See Also

Reference

  • TBIFileImportersHelper
  • BI.DataSource


TBIFileImportersHelper.GuessExtension(String) Method

Summary

Represents method GuessExtension(String).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function GuessExtension(const Extension:String):TBIFileSourceClass; static;

Parameters

Extension
Type: String

Return Value

Type: TBIFileSourceClass

See Also

Reference

  • TBIFileImportersHelper
  • BI.DataSource


TBIFileImportersHelper.RegisterClass(TBIFileSourceClass) Method

Summary

Represents method RegisterClass(TBIFileSourceClass).

Namespace: BI.DataSource
Syntax
Delphi
public
 class procedure RegisterClass(const AClass:TBIFileSourceClass); static;

Parameters

AClass
Type: TBIFileSourceClass

See Also

Reference

  • TBIFileImportersHelper
  • BI.DataSource


TBIFileImportersHelper.UnRegisterClass(TBIFileSourceClass) Method

Summary

Represents method UnRegisterClass(TBIFileSourceClass).

Namespace: BI.DataSource
Syntax
Delphi
public
 class procedure UnRegisterClass(const AClass:TBIFileSourceClass); static;

Parameters

AClass
Type: TBIFileSourceClass

See Also

Reference

  • TBIFileImportersHelper
  • BI.DataSource


TBIFileImportersHelper Fields

Fields
Name | Description
Items | Represents field Items.
Top


TBIFileImportersHelper.Items Field

Summary

Represents field Items.

Namespace: BI.DataSource
Syntax
Delphi
public
 class var
 Items : TBIFileImporters;

Field Value

Type: TBIFileImporters

See Also

Reference

  • TBIFileImportersHelper
  • BI.DataSource


TBIFileSource Class

Summary

Represents type TBIFileSource.

Namespace: BI.DataSource
Inheritance Hierarchy
TObject
BI.DataSource.TBISource
BI.DataSource.TBIItemsSource
BI.DataSource.TBIFileSource
BI.DataSource.TBINativeImporter
BI.DataSource.TBITextSource
BI.DB.Dataset.TBIDataSetSource
BI.Web.TBIURLSource
Syntax
Delphi
type
 TBIFileSource=class(TBIItemsSource)
 end;

The TBIFileSource type exposes the following members.

Methods
Show:
Name | Description
AppendData(TDataArray,TDataArray) | Represents method AppendData(TDataArray,TDataArray).
DataArrayFrom(TDataItem) | Represents method DataArrayFrom(TDataItem).
DataFromFiles(TStringDynArray,Boolean) | Represents method DataFromFiles(TStringDynArray,Boolean).
DoImportFile(String) | Represents method DoImportFile(String).
DoImportStream(String,TStream) | Represents method DoImportStream(String,TStream).
FileFilter | Represents method FileFilter.
FindImporterClass(String) | Represents method FindImporterClass(String).
FromFile(String) | Overloaded. Represents method FromFile(String).
FromStrings(TStrings) | Represents method FromStrings(TStrings).
FromText(String) | Represents method FromText(String).
GetFileSize(String) | Represents method GetFileSize(String).
GuessFromContent(TStrings) | Represents method GuessFromContent(TStrings).
Import(String,String,String,Boolean) | Overloaded. Represents method Import(String,String,String,Boolean).
Import(TStrings) | Overloaded. Represents method Import(TStrings).
ImportFile(String) | Overloaded. Represents method ImportFile(String).
ImportOneFile(String) | Represents method ImportOneFile(String).
ImportStream(String,TStream) | Represents method ImportStream(String,TStream).
ImportZip(String) | Represents method ImportZip(String).
IncludedFiles(String,TDataDefinition) | Represents method IncludedFiles(String,TDataDefinition).
Supports(String) | Represents method Supports(String).
TaskImport(TObject) | Represents method TaskImport(TObject).
Top
Fields
Show:
Name | Description
IFiles | Represents field IFiles.
IResult | Represents field IResult.
Top
See Also

Reference

  • BI.DataSource


TBIFileSource Methods

Methods
Name | Description
AppendData(TDataArray,TDataArray) | Represents method AppendData(TDataArray,TDataArray).
DataArrayFrom(TDataItem) | Represents method DataArrayFrom(TDataItem).
DataFromFiles(TStringDynArray,Boolean) | Represents method DataFromFiles(TStringDynArray,Boolean).
DoImportFile(String) | Represents method DoImportFile(String).
DoImportStream(String,TStream) | Represents method DoImportStream(String,TStream).
FileFilter | Represents method FileFilter.
FindImporterClass(String) | Represents method FindImporterClass(String).
FromFile(String) | Overloaded. Represents method FromFile(String).
FromStrings(TStrings) | Represents method FromStrings(TStrings).
FromText(String) | Represents method FromText(String).
GetFileSize(String) | Represents method GetFileSize(String).
GuessFromContent(TStrings) | Represents method GuessFromContent(TStrings).
Import(String,String,String,Boolean) | Overloaded. Represents method Import(String,String,String,Boolean).
Import(TStrings) | Overloaded. Represents method Import(TStrings).
ImportFile(String) | Overloaded. Represents method ImportFile(String).
ImportOneFile(String) | Represents method ImportOneFile(String).
ImportStream(String,TStream) | Represents method ImportStream(String,TStream).
ImportZip(String) | Represents method ImportZip(String).
IncludedFiles(String,TDataDefinition) | Represents method IncludedFiles(String,TDataDefinition).
Supports(String) | Represents method Supports(String).
TaskImport(TObject) | Represents method TaskImport(TObject).
Top


TBIFileSource.AppendData(TDataArray,TDataArray) Method

Summary

Represents method AppendData(TDataArray,TDataArray).

Namespace: BI.DataSource
Syntax
Delphi
protected
 class procedure AppendData(var AResult:TDataArray; const AItems:TDataArray); static;

Parameters

AResult
Type: TDataArray

AItems
Type: TDataArray

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource.DataArrayFrom(TDataItem) Method

Summary

Represents method DataArrayFrom(TDataItem).

Namespace: BI.DataSource
Syntax
Delphi
protected
 class function DataArrayFrom(const AData:TDataItem):TDataArray; static;

Parameters

AData
Type: TDataItem

Return Value

Type: TDataArray

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource.DataFromFiles(TStringDynArray,Boolean) Method

Summary

Represents method DataFromFiles(TStringDynArray,Boolean).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function DataFromFiles(const AFiles:TStringDynArray; const Local:Boolean): TDataItem; static;

Parameters

AFiles
Type: TStringDynArray

Local
Type: Boolean

Return Value

Type: TDataItem

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource.DoImportFile(String) Method

Summary

Represents method DoImportFile(String).

Namespace: BI.DataSource
Syntax
Delphi
protected
 function DoImportFile(const FileName:String):TDataArray; virtual;

Parameters

FileName
Type: String

Return Value

Type: TDataArray

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource.DoImportStream(String,TStream) Method

Summary

Represents method DoImportStream(String,TStream).

Namespace: BI.DataSource
Syntax
Delphi
protected
 function DoImportStream(const AExtension:String; const AStream:TStream):TDataArray; virtual;

Parameters

AExtension
Type: String

AStream
Type: TStream

Return Value

Type: TDataArray

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.DataSource
Syntax
Delphi
public
 class function FileFilter:TFileFilters; virtual;

Return Value

Type: TFileFilters

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource.FindImporterClass(String) Method

Summary

Represents method FindImporterClass(String).

Namespace: BI.DataSource
Syntax
Delphi
protected
 function FindImporterClass(const AFileName:String):TBIFileSourceClass;

Parameters

AFileName
Type: String

Return Value

Type: TBIFileSourceClass

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource.FromFile(String) Method

Summary

Represents method FromFile(String).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function FromFile(const AFileName:String):TDataItem; overload;

Parameters

AFileName
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource.FromStrings(TStrings) Method

Summary

Represents method FromStrings(TStrings).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function FromStrings(const AStrings:TStrings):TDataItem;

Parameters

AStrings
Type: TStrings

Return Value

Type: TDataItem

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource.FromText(String) Method

Summary

Represents method FromText(String).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function FromText(const AText:String):TDataItem;

Parameters

AText
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource.GetFileSize(String) Method

Summary

Represents method GetFileSize(String).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function GetFileSize(const FileName:String):Int64; static;

Parameters

FileName
Type: String

Return Value

Type: Int64

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource.GuessFromContent(TStrings) Method

Summary

Represents method GuessFromContent(TStrings).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function GuessFromContent(const S:TStrings):TBIFileSourceClass; static;

Parameters

S
Type: TStrings

Return Value

Type: TBIFileSourceClass

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource.Import(String,String,String,Boolean) Method

Summary

Represents method Import(String,String,String,Boolean).

Namespace: BI.DataSource
Syntax
Delphi
public
 function Import(const Folder,IncludePattern,ExcludePattern:String; Recursive:Boolean):TDataArray; overload;

Parameters

Folder
Type: String

IncludePattern
Type: String

ExcludePattern
Type: String

Recursive
Type: Boolean

Return Value

Type: TDataArray

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource.Import(TStrings) Method

Summary

Represents method Import(TStrings).

Namespace: BI.DataSource
Syntax
Delphi
public
 function Import(const Strings:TStrings):TDataArray; overload; virtual;

Parameters

Strings
Type: TStrings

Return Value

Type: TDataArray

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource.ImportFile(String) Method

Summary

Represents method ImportFile(String).

Namespace: BI.DataSource
Syntax
Delphi
public
 function ImportFile(const FileName:String):TDataArray; overload; virtual;

Parameters

FileName
Type: String

Return Value

Type: TDataArray

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource.ImportOneFile(String) Method

Summary

Represents method ImportOneFile(String).

Namespace: BI.DataSource
Syntax
Delphi
protected
 function ImportOneFile(const AFile:String):TDataArray;

Parameters

AFile
Type: String

Return Value

Type: TDataArray

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource.ImportStream(String,TStream) Method

Summary

Represents method ImportStream(String,TStream).

Namespace: BI.DataSource
Syntax
Delphi
public
 function ImportStream(const AFileName: String; const AStream:TStream): TDataArray;

Parameters

AFileName
Type: String

AStream
Type: TStream

Return Value

Type: TDataArray

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource.ImportZip(String) Method

Summary

Represents method ImportZip(String).

Namespace: BI.DataSource
Syntax
Delphi
protected
 function ImportZip(const FileName:String):TDataArray;

Parameters

FileName
Type: String

Return Value

Type: TDataArray

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource.IncludedFiles(String,TDataDefinition) Method

Summary

Represents method IncludedFiles(String,TDataDefinition).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function IncludedFiles(const AStore:String; const ADef:TDataDefinition):TStringDynArray; static;

Parameters

AStore
Type: String

ADef
Type: TDataDefinition

Return Value

Type: TStringDynArray

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; virtual;

Parameters

Extension
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource.TaskImport(TObject) Method

Summary

Represents method TaskImport(TObject).

Namespace: BI.DataSource
Syntax
Delphi
protected
 procedure TaskImport(Sender:TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource Fields

Fields
Name | Description
IFiles | Represents field IFiles.
IResult | Represents field IResult.
Top


TBIFileSource.IFiles Field

Summary

Represents field IFiles.

Namespace: BI.DataSource
Syntax
Delphi
protected
 IFiles : TStringDynArray;

Field Value

Type: TStringDynArray

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIFileSource.IResult Field

Summary

Represents field IResult.

Namespace: BI.DataSource
Syntax
Delphi
protected
 IResult : Array of TDataArray;

Field Value

Type: Array of TDataArray

See Also

Reference

  • TBIFileSource
  • BI.DataSource


TBIHierarchicalSource Class

Summary

Represents type TBIHierarchicalSource.

Namespace: BI.DataSource
Inheritance Hierarchy
TObject
BI.DataSource.TBISource
BI.DataSource.TBIItemsSource
BI.DataSource.TBIFileSource
BI.DataSource.TBITextSource
BI.DataSource.TBIHierarchicalSource
BI.JSON.TBIJSON
BI.XMLData.TBIXML
Syntax
Delphi
type
 TBIHierarchicalSource=class(TBITextSource)
 end;

The TBIHierarchicalSource type exposes the following members.

Constructors
Show:
Name | Description
Create(TDataDefinition,Boolean) | Initializes a new instance of the TBIHierarchicalSource class. (Overrides TBITextSource.Create(TDataDefinition,Boolean).)
Top
Fields
Show:
Name | Description
Hierarchical | Represents field Hierarchical.
Top
See Also

Reference

  • BI.DataSource


TBIHierarchicalSource Constructors

Constructors
Name | Description
Create(TDataDefinition,Boolean) | Initializes a new instance of the TBIHierarchicalSource class. (Overrides TBITextSource.Create(TDataDefinition,Boolean).)
Top


TBIHierarchicalSource.Create(TDataDefinition,Boolean) Constructor

Summary

Initializes a new instance of the TBIHierarchicalSource class.

Namespace: BI.DataSource
Syntax
Delphi
public
 Constructor Create(const Definition:TDataDefinition=nil;
 const MultiThread:Boolean=False); override;

Parameters

Definition
Type: TDataDefinition

MultiThread
Type: Boolean

Overrides

TBITextSource.Create(TDataDefinition,Boolean)
See Also

Reference

  • TBIHierarchicalSource
  • BI.DataSource


TBIHierarchicalSource Fields

Fields
Name | Description
Hierarchical | Represents field Hierarchical.
Top


TBIHierarchicalSource.Hierarchical Field

Summary

Represents field Hierarchical.

Namespace: BI.DataSource
Syntax
Delphi
public
 Hierarchical : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBIHierarchicalSource
  • BI.DataSource


TBIItemsSource Class

Summary

Represents type TBIItemsSource.

Namespace: BI.DataSource
Inheritance Hierarchy
TObject
BI.DataSource.TBISource
BI.DataSource.TBIItemsSource
BI.DataSource.TBIFileSource
BI.DB.ZeosLib.TBIZeosLib
Syntax
Delphi
type
 TBIItemsSource=class(TBISource)
 end;

The TBIItemsSource type exposes the following members.

Properties
Show:
Name | Description
ExcludePattern | Represents property ExcludePattern.
IncludePattern | Represents property IncludePattern.
Top
See Also

Reference

  • BI.DataSource


TBIItemsSource Properties

Properties
Name | Description
ExcludePattern | Represents property ExcludePattern.
IncludePattern | Represents property IncludePattern.
Top


TBIItemsSource.ExcludePattern Property

Summary

Represents property ExcludePattern.

Namespace: BI.DataSource
Syntax
Delphi
public
 property ExcludePattern:String read GetExclude write SetExclude;

Property Value

Type: String

See Also

Reference

  • TBIItemsSource
  • BI.DataSource


TBIItemsSource.IncludePattern Property

Summary

Represents property IncludePattern.

Namespace: BI.DataSource
Syntax
Delphi
public
 property IncludePattern:String read GetInclude write SetInclude;

Property Value

Type: String

See Also

Reference

  • TBIItemsSource
  • BI.DataSource


TBINativeExport Class

Summary

Represents type TBINativeExport.

Namespace: BI.DataSource
Inheritance Hierarchy
TObject
BI.DataSource.TBIExport
BI.DataSource.TBINativeExport
Syntax
Delphi
type
 TBINativeExport=class(TBIExport)
 end;

The TBINativeExport type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TBINativeExport class. (Overrides TBIExport.Create.)
Top
Methods
Show:
Name | Description
FileFilter | Represents method FileFilter. (Overrides TBIExport.FileFilter.)
SaveToFile(String) | Represents method SaveToFile(String). (Overrides TBIExport.SaveToFile(String).)
Supports(String) | Represents method Supports(String). (Overrides TBIExport.Supports(String).)
Top
See Also

Reference

  • BI.DataSource


TBINativeExport Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TBINativeExport class. (Overrides TBIExport.Create.)
Top


TBINativeExport.Create Constructor

Summary

Initializes a new instance of the TBINativeExport class.

Namespace: BI.DataSource
Syntax
Delphi
public
 Constructor Create; override;

Overrides

TBIExport.Create
See Also

Reference

  • TBINativeExport
  • BI.DataSource


TBINativeExport Methods

Methods
Name | Description
FileFilter | Represents method FileFilter. (Overrides TBIExport.FileFilter.)
SaveToFile(String) | Represents method SaveToFile(String). (Overrides TBIExport.SaveToFile(String).)
Supports(String) | Represents method Supports(String). (Overrides TBIExport.Supports(String).)
Top


TBINativeExport.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.DataSource
Syntax
Delphi
public
 class function FileFilter: TFileFilters; override;

Return Value

Type: TFileFilters

Overrides

TBIExport.FileFilter
See Also

Reference

  • TBINativeExport
  • BI.DataSource


TBINativeExport.SaveToFile(String) Method

Summary

Represents method SaveToFile(String).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure SaveToFile(const AFileName:String); override;

Parameters

AFileName
Type: String

Overrides

TBIExport.SaveToFile(String)
See Also

Reference

  • TBINativeExport
  • BI.DataSource


TBINativeExport.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIExport.Supports(String)
See Also

Reference

  • TBINativeExport
  • BI.DataSource


TBINativeImporter Class

Summary

Represents type TBINativeImporter.

Namespace: BI.DataSource
Inheritance Hierarchy
TObject
BI.DataSource.TBISource
BI.DataSource.TBIItemsSource
BI.DataSource.TBIFileSource
BI.DataSource.TBINativeImporter
Syntax
Delphi
type
 TBINativeImporter=class(TBIFileSource)
 end;

The TBINativeImporter type exposes the following members.

Methods
Show:
Name | Description
Supports(String) | Represents method Supports(String). (Overrides TBIFileSource.Supports(String).)
Top
See Also

Reference

  • BI.DataSource


TBINativeImporter Methods

Methods
Name | Description
Supports(String) | Represents method Supports(String). (Overrides TBIFileSource.Supports(String).)
Top


TBINativeImporter.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIFileSource.Supports(String)
See Also

Reference

  • TBINativeImporter
  • BI.DataSource


TBISource Class

Summary

Represents type TBISource.

Namespace: BI.DataSource
Inheritance Hierarchy
TObject
BI.DataSource.TBISource
BI.DataSource.TBIItemsSource
BI.DB.Fire.TBISourceAccess
BI.DB.microOLAP.TBISourceAccess
BI.DB.ZeosLib.TBISourceAccess
Syntax
Delphi
type
 TBISource=class
 end;

The TBISource type exposes the following members.

Constructors
Show:
Name | Description
Create(TDataDefinition,Boolean) | Initializes a new instance of the TBISource class.
Top
Properties
Show:
Name | Description
IgnoreMissing | Represents property IgnoreMissing.
Top
Methods
Show:
Name | Description
CallOnError(String) | Represents method CallOnError(String).
DoProgress(Single,Boolean) | Represents method DoProgress(Single,Boolean).
FromData(TDataArray) | Represents method FromData(TDataArray).
NameOfFile(String) | Represents method NameOfFile(String).
Top
Events
Show:
Name | Description
OnError | Represents property OnError.
OnProgress | Represents property OnProgress.
Top
Fields
Show:
Name | Description
IDefinition | Represents field IDefinition.
Parallel | Represents field Parallel.
Top
See Also

Reference

  • BI.DataSource


TBISource Constructors

Constructors
Name | Description
Create(TDataDefinition,Boolean) | Initializes a new instance of the TBISource class.
Top


TBISource.Create(TDataDefinition,Boolean) Constructor

Summary

Initializes a new instance of the TBISource class.

Namespace: BI.DataSource
Syntax
Delphi
public
 Constructor Create(const Definition:TDataDefinition=nil;
 const MultiThread:Boolean=False); virtual;

Parameters

Definition
Type: TDataDefinition

MultiThread
Type: Boolean

See Also

Reference

  • TBISource
  • BI.DataSource


TBISource Properties

Properties
Name | Description
IgnoreMissing | Represents property IgnoreMissing.
Top


TBISource.IgnoreMissing Property

Summary

Represents property IgnoreMissing.

Namespace: BI.DataSource
Syntax
Delphi
public
 property IgnoreMissing:Boolean read FIgnoreMissing write FIgnoreMissing default False;

Property Value

Type: Boolean

See Also

Reference

  • TBISource
  • BI.DataSource


TBISource Methods

Methods
Name | Description
CallOnError(String) | Represents method CallOnError(String).
DoProgress(Single,Boolean) | Represents method DoProgress(Single,Boolean).
FromData(TDataArray) | Represents method FromData(TDataArray).
NameOfFile(String) | Represents method NameOfFile(String).
Top


TBISource.CallOnError(String) Method

Summary

Represents method CallOnError(String).

Namespace: BI.DataSource
Syntax
Delphi
protected
 function CallOnError(const Text:String):Boolean;

Parameters

Text
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TBISource
  • BI.DataSource


TBISource.DoProgress(Single,Boolean) Method

Summary

Represents method DoProgress(Single,Boolean).

Namespace: BI.DataSource
Syntax
Delphi
protected
 procedure DoProgress(const Percent:Single; var Cancel:Boolean);

Parameters

Percent
Type: Single

Cancel
Type: Boolean

See Also

Reference

  • TBISource
  • BI.DataSource


TBISource.FromData(TDataArray) Method

Summary

Represents method FromData(TDataArray).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function FromData(const AData:TDataArray):TDataItem; static;

Parameters

AData
Type: TDataArray

Return Value

Type: TDataItem

See Also

Reference

  • TBISource
  • BI.DataSource


TBISource.NameOfFile(String) Method

Summary

Represents method NameOfFile(String).

Namespace: BI.DataSource
Syntax
Delphi
protected
 function NameOfFile(const FileName:String):String;

Parameters

FileName
Type: String

Return Value

Type: String

See Also

Reference

  • TBISource
  • BI.DataSource


TBISource Events

Events
Name | Description
OnError | Represents property OnError.
OnProgress | Represents property OnProgress.
Top


TBISource.OnError Event

Summary

Represents property OnError.

Namespace: BI.DataSource
Syntax
Delphi
public
 property OnError:TBIError read FOnError write FOnError;

Value

Type: TBIError

See Also

Reference

  • TBISource
  • BI.DataSource


TBISource.OnProgress Event

Summary

Represents property OnProgress.

Namespace: BI.DataSource
Syntax
Delphi
public
 property OnProgress:TBIProgress read FOnProgress write FOnProgress;

Value

Type: TBIProgress

See Also

Reference

  • TBISource
  • BI.DataSource


TBISource Fields

Fields
Name | Description
IDefinition | Represents field IDefinition.
Parallel | Represents field Parallel.
Top


TBISource.IDefinition Field

Summary

Represents field IDefinition.

Namespace: BI.DataSource
Syntax
Delphi
protected
 IDefinition : TDataDefinition;

Field Value

Type: TDataDefinition

See Also

Reference

  • TBISource
  • BI.DataSource


TBISource.Parallel Field

Summary

Represents field Parallel.

Namespace: BI.DataSource
Syntax
Delphi
public
 Parallel : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBISource
  • BI.DataSource


TBITextExport Class

Summary

Represents type TBITextExport.

Namespace: BI.DataSource
Inheritance Hierarchy
TObject
BI.DataSource.TBIExport
BI.DataSource.TBITextExport
BI.CSV.TBICSVExport
BI.Html.TBIHTMLExport
BI.JSON.TBIJSONExport
BI.XMLData.TBIXMLExport
FMXBI.PDF.TBIPDFExport
VCLBI.PDF.TBIPDFExport
Syntax
Delphi
type
 TBITextExport=class(TBIExport)
 end;

The TBITextExport type exposes the following members.

Methods
Show:
Name | Description
DataToString(TDataItem,TInteger) | Represents method DataToString(TDataItem,TInteger).
Top
Fields
Show:
Name | Description
FloatFormat | Represents field FloatFormat.
Top
See Also

Reference

  • BI.DataSource


TBITextExport Methods

Methods
Name | Description
DataToString(TDataItem,TInteger) | Represents method DataToString(TDataItem,TInteger).
Top


TBITextExport.DataToString(TDataItem,TInteger) Method

Summary

Represents method DataToString(TDataItem,TInteger).

Namespace: BI.DataSource
Syntax
Delphi
public
 function DataToString(const AData:TDataItem; const AIndex:TInteger):String;

Parameters

AData
Type: TDataItem

AIndex
Type: System.Void

Return Value

Type: String

See Also

Reference

  • TBITextExport
  • BI.DataSource


TBITextExport Fields

Fields
Name | Description
FloatFormat | Represents field FloatFormat.
Top


TBITextExport.FloatFormat Field

Summary

Represents field FloatFormat.

Namespace: BI.DataSource
Syntax
Delphi
public
 FloatFormat : String;

Field Value

Type: String

See Also

Reference

  • TBITextExport
  • BI.DataSource


TBITextSource Class

Summary

Represents type TBITextSource.

Namespace: BI.DataSource
Inheritance Hierarchy
TObject
BI.DataSource.TBISource
BI.DataSource.TBIItemsSource
BI.DataSource.TBIFileSource
BI.DataSource.TBITextSource
BI.CSV.TBICSV
BI.DataSource.TBIHierarchicalSource
BI.Excel.TBIExcel
BI.Html.TBIHTML
Syntax
Delphi
type
 TBITextSource=class(TBIFileSource)
 end;

The TBITextSource type exposes the following members.

Constructors
Show:
Name | Description
Create(TDataDefinition,Boolean) | Initializes a new instance of the TBITextSource class. (Overrides TBISource.Create(TDataDefinition,Boolean).)
Top
Properties
Show:
Name | Description
Text | Represents property Text.
Top
Methods
Show:
Name | Description
ChangeBoolToInt(TDataItem,TInteger) | Represents method ChangeBoolToInt(TDataItem,TInteger).
ChangeToBoolean(TDataItem,Boolean) | Represents method ChangeToBoolean(TDataItem,Boolean).
ChangeToText(TDataItem,TInteger,TInteger) | Represents method ChangeToText(TDataItem,TInteger,TInteger).
DoImportFile(String) | Represents method DoImportFile(String). (Overrides TBIFileSource.DoImportFile(String).)
DoImportStream(String,TStream) | Represents method DoImportStream(String,TStream). (Overrides TBIFileSource.DoImportStream(String,TStream).)
GuessKind(String) | Represents method GuessKind(String).
InternalImportFile(String) | Represents method InternalImportFile(String).
LoadFromFile(String) | Overloaded. Represents method LoadFromFile(String).
LoadFromFile(String,TFileShareMode) | Overloaded. Represents method LoadFromFile(String,TFileShareMode).
SetColumn(TDataItem,TInteger,String) | Represents method SetColumn(TDataItem,TInteger,String).
StringsFrom(String) | Represents method StringsFrom(String).
TryDecimal(String,Single) | Represents method TryDecimal(String,Single).
Top
Fields
Show:
Name | Description
DecimalDetected | Represents field DecimalDetected.
FirstStringChar | Represents field FirstStringChar.
FText | Represents field FText.
ISettings | Represents field ISettings.
MissingValue | Represents field MissingValue.
QuotedBooleans | Represents field QuotedBooleans.
ZBS | Represents field ZBS.
ZeroOneAsBoolean | Represents field ZeroOneAsBoolean.
Top
See Also

Reference

  • BI.DataSource


TBITextSource Constructors

Constructors
Name | Description
Create(TDataDefinition,Boolean) | Initializes a new instance of the TBITextSource class. (Overrides TBISource.Create(TDataDefinition,Boolean).)
Top


TBITextSource.Create(TDataDefinition,Boolean) Constructor

Summary

Initializes a new instance of the TBITextSource class.

Namespace: BI.DataSource
Syntax
Delphi
public
 Constructor Create(const Definition:TDataDefinition=nil;
 const MultiThread:Boolean=False); override;

Parameters

Definition
Type: TDataDefinition

MultiThread
Type: Boolean

Overrides

TBISource.Create(TDataDefinition,Boolean)
See Also

Reference

  • TBITextSource
  • BI.DataSource


TBITextSource Properties

Properties
Name | Description
Text | Represents property Text.
Top


TBITextSource.Text Property

Summary

Represents property Text.

Namespace: BI.DataSource
Syntax
Delphi
public
 property Text:String read FText;

Property Value

Type: String

See Also

Reference

  • TBITextSource
  • BI.DataSource


TBITextSource Methods

Methods
Name | Description
ChangeBoolToInt(TDataItem,TInteger) | Represents method ChangeBoolToInt(TDataItem,TInteger).
ChangeToBoolean(TDataItem,Boolean) | Represents method ChangeToBoolean(TDataItem,Boolean).
ChangeToText(TDataItem,TInteger,TInteger) | Represents method ChangeToText(TDataItem,TInteger,TInteger).
DoImportFile(String) | Represents method DoImportFile(String). (Overrides TBIFileSource.DoImportFile(String).)
DoImportStream(String,TStream) | Represents method DoImportStream(String,TStream). (Overrides TBIFileSource.DoImportStream(String,TStream).)
GuessKind(String) | Represents method GuessKind(String).
InternalImportFile(String) | Represents method InternalImportFile(String).
LoadFromFile(String) | Overloaded. Represents method LoadFromFile(String).
LoadFromFile(String,TFileShareMode) | Overloaded. Represents method LoadFromFile(String,TFileShareMode).
SetColumn(TDataItem,TInteger,String) | Represents method SetColumn(TDataItem,TInteger,String).
StringsFrom(String) | Represents method StringsFrom(String).
TryDecimal(String,Single) | Represents method TryDecimal(String,Single).
Top


TBITextSource.ChangeBoolToInt(TDataItem,TInteger) Method

Summary

Represents method ChangeBoolToInt(TDataItem,TInteger).

Namespace: BI.DataSource
Syntax
Delphi
protected
 class procedure ChangeBoolToInt(const Col:TDataItem; const ARow:TInteger);

Parameters

Col
Type: TDataItem

ARow
Type: System.Void

See Also

Reference

  • TBITextSource
  • BI.DataSource


TBITextSource.ChangeToBoolean(TDataItem,Boolean) Method

Summary

Represents method ChangeToBoolean(TDataItem,Boolean).

Namespace: BI.DataSource
Syntax
Delphi
protected
 class procedure ChangeToBoolean(const Col:TDataItem; const AValue:Boolean);

Parameters

Col
Type: TDataItem

AValue
Type: Boolean

See Also

Reference

  • TBITextSource
  • BI.DataSource


TBITextSource.ChangeToText(TDataItem,TInteger,TInteger) Method

Summary

Represents method ChangeToText(TDataItem,TInteger,TInteger).

Namespace: BI.DataSource
Syntax
Delphi
protected
 class procedure ChangeToText(const Col:TDataItem; const Index,Total:TInteger); static;

Parameters

Col
Type: TDataItem

Index
Type: System.Void

Total
Type: System.Void

See Also

Reference

  • TBITextSource
  • BI.DataSource


TBITextSource.DoImportFile(String) Method

Summary

Represents method DoImportFile(String).

Namespace: BI.DataSource
Syntax
Delphi
protected
 function DoImportFile(const FileName:String):TDataArray; override;

Parameters

FileName
Type: String

Return Value

Type: TDataArray

Overrides

TBIFileSource.DoImportFile(String)
See Also

Reference

  • TBITextSource
  • BI.DataSource


TBITextSource.DoImportStream(String,TStream) Method

Summary

Represents method DoImportStream(String,TStream).

Namespace: BI.DataSource
Syntax
Delphi
protected
 function DoImportStream(const AExtension:String; const AStream:TStream):TDataArray; override;

Parameters

AExtension
Type: String

AStream
Type: TStream

Return Value

Type: TDataArray

Overrides

TBIFileSource.DoImportStream(String,TStream)
See Also

Reference

  • TBITextSource
  • BI.DataSource


TBITextSource.GuessKind(String) Method

Summary

Represents method GuessKind(String).

Namespace: BI.DataSource
Syntax
Delphi
protected
 function GuessKind(const Value:String):TDataKind;

Parameters

Value
Type: String

Return Value

Type: TDataKind

See Also

Reference

  • TBITextSource
  • BI.DataSource


TBITextSource.InternalImportFile(String) Method

Summary

Represents method InternalImportFile(String).

Namespace: BI.DataSource
Syntax
Delphi
protected
 function InternalImportFile(const FileName:String):TDataArray; virtual;

Parameters

FileName
Type: String

Return Value

Type: TDataArray

See Also

Reference

  • TBITextSource
  • BI.DataSource


TBITextSource.LoadFromFile(String) Method

Summary

Represents method LoadFromFile(String).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function LoadFromFile(const FileName:String):String; overload;

Parameters

FileName
Type: String

Return Value

Type: String

See Also

Reference

  • TBITextSource
  • BI.DataSource


TBITextSource.LoadFromFile(String,TFileShareMode) Method

Summary

Represents method LoadFromFile(String,TFileShareMode).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function LoadFromFile(const FileName:String; const ShareMode:TFileShareMode):String; overload;

Parameters

FileName
Type: String

ShareMode
Type: TFileShareMode

Return Value

Type: String

See Also

Reference

  • TBITextSource
  • BI.DataSource


TBITextSource.SetColumn(TDataItem,TInteger,String) Method

Summary

Represents method SetColumn(TDataItem,TInteger,String).

Namespace: BI.DataSource
Syntax
Delphi
protected
 procedure SetColumn(const Col:TDataItem; const ARow:TInteger; const Value:String);

Parameters

Col
Type: TDataItem

ARow
Type: System.Void

Value
Type: String

See Also

Reference

  • TBITextSource
  • BI.DataSource


TBITextSource.StringsFrom(String) Method

Summary

Represents method StringsFrom(String).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function StringsFrom(const FileName:String):TStrings;

Parameters

FileName
Type: String

Return Value

Type: TStrings

See Also

Reference

  • TBITextSource
  • BI.DataSource


TBITextSource.TryDecimal(String,Single) Method

Summary

Represents method TryDecimal(String,Single).

Namespace: BI.DataSource
Syntax
Delphi
protected
 function TryDecimal(const AText:String; out AValue:Single):Boolean;

Parameters

AText
Type: String

AValue
Type: Single

Return Value

Type: Boolean

See Also

Reference

  • TBITextSource
  • BI.DataSource


TBITextSource Fields

Fields
Name | Description
DecimalDetected | Represents field DecimalDetected.
FirstStringChar | Represents field FirstStringChar.
FText | Represents field FText.
ISettings | Represents field ISettings.
MissingValue | Represents field MissingValue.
QuotedBooleans | Represents field QuotedBooleans.
ZBS | Represents field ZBS.
ZeroOneAsBoolean | Represents field ZeroOneAsBoolean.
Top


TBITextSource.DecimalDetected Field

Summary

Represents field DecimalDetected.

Namespace: BI.DataSource
Syntax
Delphi
protected
 QuotedBooleans,
 DecimalDetected : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBITextSource
  • BI.DataSource


TBITextSource.FirstStringChar Field

Summary

Represents field FirstStringChar.

Namespace: BI.DataSource
Syntax
Delphi
protected
 class var FirstStringChar : Integer;

Field Value

Type: Integer

See Also

Reference

  • TBITextSource
  • BI.DataSource


TBITextSource.FText Field

Summary

Represents field FText.

Namespace: BI.DataSource
Syntax
Delphi
protected
 FText : String;

Field Value

Type: String

See Also

Reference

  • TBITextSource
  • BI.DataSource


TBITextSource.ISettings Field

Summary

Represents field ISettings.

Namespace: BI.DataSource
Syntax
Delphi
protected
 ISettings : TFormatSettings;

Field Value

Type: TFormatSettings

See Also

Reference

  • TBITextSource
  • BI.DataSource


TBITextSource.MissingValue Field

Summary

Represents field MissingValue.

Namespace: BI.DataSource
Syntax
Delphi
public
 MissingValue : String;

Field Value

Type: String

See Also

Reference

  • TBITextSource
  • BI.DataSource


TBITextSource.QuotedBooleans Field

Summary

Represents field QuotedBooleans.

Namespace: BI.DataSource
Syntax
Delphi
protected
 QuotedBooleans,
 DecimalDetected : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBITextSource
  • BI.DataSource


TBITextSource.ZBS Field

Summary

Represents field ZBS.

Namespace: BI.DataSource
Syntax
Delphi
protected
 class var ZBS : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBITextSource
  • BI.DataSource


TBITextSource.ZeroOneAsBoolean Field

Summary

Represents field ZeroOneAsBoolean.

Namespace: BI.DataSource
Syntax
Delphi
public
 ZeroOneAsBoolean : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBITextSource
  • BI.DataSource


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.DataSource
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.DataSource.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.DataSource


TDataCursor Class

Summary

Represents type TDataCursor.

Namespace: BI.DataSource
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.DataSource.TDataCursor
BI.Dataset.TDataCursorAccess
BI.DataSource.TDataSelect
BI.Query.TDataCursorAccess
Syntax
Delphi
type
 TDataCursor=class(TDataProvider)
 end;

The TDataCursor type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TDataCursor class.
Destroy | Represents the destructor of the TDataCursor class. (Overrides TDataProvider.Destroy.)
Top
Properties
Show:
Name | Description
Current | Represents property Current.
Filter | Represents property Filter.
Max | Represents property Max.
Start | Represents property Start.
UseFilter | Represents property UseFilter.
Top
Methods
Show:
Name | Description
Add(TDataArray) | Overloaded. Represents method Add(TDataArray).
Add(TDataItem) | Overloaded. Represents method Add(TDataItem).
Add(TDataItem,String) | Overloaded. Represents method Add(TDataItem,String).
Add(TExpression) | Overloaded. Represents method Add(TExpression).
ApplyFilter | Represents method ApplyFilter.
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TDataProvider.Assign(TPersistent).)
Clear | Represents method Clear.
Count | Represents method Count.
CreateFilter(TDataArray,TDataArray,TInteger,TExpressions) | Represents method CreateFilter(TDataArray,TDataArray,TInteger,TExpressions).
DataItems | Represents method DataItems.
Delete(TInteger) | Represents method Delete(TInteger).
DetailIndex(TDataArray,TDataArray,TInteger) | Overloaded. Represents method DetailIndex(TDataArray,TDataArray,TInteger).
DetailIndex(TDataItem,TDataArray,TDataArray,TInteger) | Overloaded. Represents method DetailIndex(TDataItem,TDataArray,TDataArray,TInteger).
GuessItems(String) | Represents method GuessItems(String).
IndexOf(TDataItem) | Represents method IndexOf(TDataItem).
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
LoadData | Represents method LoadData.
Loop(TCursorLoop) | Overloaded. Represents method Loop(TCursorLoop).
Loop(TCursorLoopObject) | Overloaded. Represents method Loop(TCursorLoopObject).
MasterDetailIndex(TDataItem,TDataArray,TInteger) | Represents method MasterDetailIndex(TDataItem,TDataArray,TInteger).
PackIndex(TCursorIndex) | Represents method PackIndex(TCursorIndex).
Position(TInteger) | Represents method Position(TInteger).
PrepareIndex(TCursorIndex,Boolean) | Represents method PrepareIndex(TCursorIndex,Boolean).
SetDirectFilter(TExpression) | Represents method SetDirectFilter(TExpression).
SetItems(TDataArray) | Represents method SetItems(TDataArray).
SetMasterExpression(TDataItem,TExpression,TInteger) | Represents method SetMasterExpression(TDataItem,TExpression,TInteger).
ToData | Represents method ToData.
Top
Fields
Show:
Name | Description
Data | Represents field Data.
Index | Represents field Index.
Items | Represents field Items.
Parent | Represents field Parent.
SortBy | Represents field SortBy.
ValidIndex | Represents field ValidIndex.
Top
See Also

Reference

  • BI.DataSource


TDataCursor Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TDataCursor class.
Destroy | Represents the destructor of the TDataCursor class. (Overrides TDataProvider.Destroy.)
Top


TDataCursor.Create(TComponent) Constructor

Summary

Initializes a new instance of the TDataCursor class.

Namespace: BI.DataSource
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.Destroy Destructor

Summary

Represents the destructor of the TDataCursor class.

Namespace: BI.DataSource
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TDataProvider.Destroy
See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor Properties

Properties
Name | Description
Current | Represents property Current.
Filter | Represents property Filter.
Max | Represents property Max.
Start | Represents property Start.
UseFilter | Represents property UseFilter.
Top


TDataCursor.Current Property

Summary

Represents property Current.

Namespace: BI.DataSource
Syntax
Delphi
protected
 property Current:TInteger read FCurrent;

Property Value

Type: TInteger

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.Filter Property

Summary

Represents property Filter.

Namespace: BI.DataSource
Syntax
Delphi
published
 property Filter:TExpression read FFilter write SetFilter;

Property Value

Type: TExpression

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.Max Property

Summary

Represents property Max.

Namespace: BI.DataSource
Syntax
Delphi
published
 property Max:TInteger read FMax write FMax;

Property Value

Type: TInteger

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.Start Property

Summary

Represents property Start.

Namespace: BI.DataSource
Syntax
Delphi
published
 property Start:TInteger read FStart write FStart;

Property Value

Type: TInteger

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.UseFilter Property

Summary

Represents property UseFilter.

Namespace: BI.DataSource
Syntax
Delphi
published
 property UseFilter:Boolean read FUseFilter write FUseFilter;

Property Value

Type: Boolean

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor Methods

Methods
Name | Description
Add(TDataArray) | Overloaded. Represents method Add(TDataArray).
Add(TDataItem) | Overloaded. Represents method Add(TDataItem).
Add(TDataItem,String) | Overloaded. Represents method Add(TDataItem,String).
Add(TExpression) | Overloaded. Represents method Add(TExpression).
ApplyFilter | Represents method ApplyFilter.
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TDataProvider.Assign(TPersistent).)
Clear | Represents method Clear.
Count | Represents method Count.
CreateFilter(TDataArray,TDataArray,TInteger,TExpressions) | Represents method CreateFilter(TDataArray,TDataArray,TInteger,TExpressions).
DataItems | Represents method DataItems.
Delete(TInteger) | Represents method Delete(TInteger).
DetailIndex(TDataArray,TDataArray,TInteger) | Overloaded. Represents method DetailIndex(TDataArray,TDataArray,TInteger).
DetailIndex(TDataItem,TDataArray,TDataArray,TInteger) | Overloaded. Represents method DetailIndex(TDataItem,TDataArray,TDataArray,TInteger).
GuessItems(String) | Represents method GuessItems(String).
IndexOf(TDataItem) | Represents method IndexOf(TDataItem).
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
LoadData | Represents method LoadData.
Loop(TCursorLoop) | Overloaded. Represents method Loop(TCursorLoop).
Loop(TCursorLoopObject) | Overloaded. Represents method Loop(TCursorLoopObject).
MasterDetailIndex(TDataItem,TDataArray,TInteger) | Represents method MasterDetailIndex(TDataItem,TDataArray,TInteger).
PackIndex(TCursorIndex) | Represents method PackIndex(TCursorIndex).
Position(TInteger) | Represents method Position(TInteger).
PrepareIndex(TCursorIndex,Boolean) | Represents method PrepareIndex(TCursorIndex,Boolean).
SetDirectFilter(TExpression) | Represents method SetDirectFilter(TExpression).
SetItems(TDataArray) | Represents method SetItems(TDataArray).
SetMasterExpression(TDataItem,TExpression,TInteger) | Represents method SetMasterExpression(TDataItem,TExpression,TInteger).
ToData | Represents method ToData.
Top


TDataCursor.Add(TDataArray) Method

Summary

Represents method Add(TDataArray).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure Add(const AData:TDataArray); overload;

Parameters

AData
Type: TDataArray

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.Add(TDataItem) Method

Summary

Represents method Add(TDataItem).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure Add(const AData:TDataItem); overload;

Parameters

AData
Type: TDataItem

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.Add(TDataItem,String) Method

Summary

Represents method Add(TDataItem,String).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure Add(const AData:TDataItem; const AExpression:String); overload;

Parameters

AData
Type: TDataItem

AExpression
Type: String

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.Add(TExpression) Method

Summary

Represents method Add(TExpression).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure Add(const AExpression:TExpression); overload;

Parameters

AExpression
Type: TExpression

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.ApplyFilter Method

Summary

Represents method ApplyFilter.

Namespace: BI.DataSource
Syntax
Delphi
protected
 procedure ApplyFilter;
See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TDataProvider.Assign(TPersistent)
See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.Clear Method

Summary

Represents method Clear.

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.Count Method

Summary

Represents method Count.

Namespace: BI.DataSource
Syntax
Delphi
public
 function Count:TInteger;

Return Value

Type: TInteger

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.CreateFilter(TDataArray,TDataArray,TInteger,TExpressions) Method

Summary

Represents method CreateFilter(TDataArray,TDataArray,TInteger,TExpressions).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function CreateFilter(const AMasters,ADetails:TDataArray;
 const AIndex:TInteger;
 out Expressions:TExpressions):TExpression; static;

Parameters

AMasters
Type: TDataArray

ADetails
Type: TDataArray

AIndex
Type: System.Void

Expressions
Type: TExpressions

Return Value

Type: TExpression

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.DataItems Method

Summary

Represents method DataItems.

Namespace: BI.DataSource
Syntax
Delphi
public
 function DataItems:TDataArray;

Return Value

Type: TDataArray

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.Delete(TInteger) Method

Summary

Represents method Delete(TInteger).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure Delete(const APosition:TInteger);

Parameters

APosition
Type: System.Void

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.DetailIndex(TDataArray,TDataArray,TInteger) Method

Summary

Represents method DetailIndex(TDataArray,TDataArray,TInteger).

Namespace: BI.DataSource
Syntax
Delphi
public
 function DetailIndex(const AMasters,ADetails:TDataArray; const AIndex:TInteger):TExpressions; overload;

Parameters

AMasters
Type: TDataArray

ADetails
Type: TDataArray

AIndex
Type: System.Void

Return Value

Type: TExpressions

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.DetailIndex(TDataItem,TDataArray,TDataArray,TInteger) Method

Summary

Represents method DetailIndex(TDataItem,TDataArray,TDataArray,TInteger).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function DetailIndex(const AData:TDataItem;
 const AMasters,ADetails:TDataArray;
 const AIndex:TInteger):TCursorIndex; overload; static;

Parameters

AData
Type: TDataItem

AMasters
Type: TDataArray

ADetails
Type: TDataArray

AIndex
Type: System.Void

Return Value

Type: TCursorIndex

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.GuessItems(String) Method

Summary

Represents method GuessItems(String).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure GuessItems(const S:String);

Parameters

S
Type: String

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.IndexOf(TDataItem) Method

Summary

Represents method IndexOf(TDataItem).

Namespace: BI.DataSource
Syntax
Delphi
public
 function IndexOf(const AData:TDataItem):Integer;

Parameters

AData
Type: TDataItem

Return Value

Type: Integer

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.DataSource
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.LoadData Method

Summary

Represents method LoadData.

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure LoadData;
See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.Loop(TCursorLoop) Method

Summary

Represents method Loop(TCursorLoop).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure Loop(const AProc:TCursorLoop); overload;

Parameters

AProc
Type: TCursorLoop

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.Loop(TCursorLoopObject) Method

Summary

Represents method Loop(TCursorLoopObject).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure Loop(const AProc:TCursorLoopObject); overload;

Parameters

AProc
Type: TCursorLoopObject

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.MasterDetailIndex(TDataItem,TDataArray,TInteger) Method

Summary

Represents method MasterDetailIndex(TDataItem,TDataArray,TInteger).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function MasterDetailIndex(const AData:TDataItem;
 const AMasters:TDataArray;
 const AIndex:TInteger):TCursorIndex;

Parameters

AData
Type: TDataItem

AMasters
Type: TDataArray

AIndex
Type: System.Void

Return Value

Type: TCursorIndex

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.PackIndex(TCursorIndex) Method

Summary

Represents method PackIndex(TCursorIndex).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function PackIndex(const AIndex:TCursorIndex):TCursorIndex; static;

Parameters

AIndex
Type: System.Void

Return Value

Type: TCursorIndex

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.Position(TInteger) Method

Summary

Represents method Position(TInteger).

Namespace: BI.DataSource
Syntax
Delphi
public
 function Position(const APosition:TInteger):TInteger;

Parameters

APosition
Type: System.Void

Return Value

Type: TInteger

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.PrepareIndex(TCursorIndex,Boolean) Method

Summary

Represents method PrepareIndex(TCursorIndex,Boolean).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure PrepareIndex(const AIndex:TCursorIndex=nil; const AllRows:Boolean=True);

Parameters

AIndex
Type: System.Void

AllRows
Type: Boolean

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.SetDirectFilter(TExpression) Method

Summary

Represents method SetDirectFilter(TExpression).

Namespace: BI.DataSource
Syntax
Delphi
protected
 procedure SetDirectFilter(const Value: TExpression);

Parameters

Value
Type: TExpression

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.SetItems(TDataArray) Method

Summary

Represents method SetItems(TDataArray).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure SetItems(const AItems:TDataArray);

Parameters

AItems
Type: TDataArray

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.SetMasterExpression(TDataItem,TExpression,TInteger) Method

Summary

Represents method SetMasterExpression(TDataItem,TExpression,TInteger).

Namespace: BI.DataSource
Syntax
Delphi
public
 class procedure SetMasterExpression(const Master:TDataItem;
 const MasterCol:TExpression;
 const AIndex:TInteger); static;

Parameters

Master
Type: TDataItem

MasterCol
Type: TExpression

AIndex
Type: System.Void

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.ToData Method

Summary

Represents method ToData.

Namespace: BI.DataSource
Syntax
Delphi
public
 function ToData:TDataItem;

Return Value

Type: TDataItem

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor Fields

Fields
Name | Description
Data | Represents field Data.
Index | Represents field Index.
Items | Represents field Items.
Parent | Represents field Parent.
SortBy | Represents field SortBy.
ValidIndex | Represents field ValidIndex.
Top


TDataCursor.Data Field

Summary

Represents field Data.

Namespace: BI.DataSource
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.Index Field

Summary

Represents field Index.

Namespace: BI.DataSource
Syntax
Delphi
public
 Index : TCursorIndex;

Field Value

Type: TCursorIndex

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.Items Field

Summary

Represents field Items.

Namespace: BI.DataSource
Syntax
Delphi
public
 Items : TDataCursorItems;

Field Value

Type: TDataCursorItems

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.Parent Field

Summary

Represents field Parent.

Namespace: BI.DataSource
Syntax
Delphi
protected
 Parent : TObject;

Field Value

Type: TObject

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.SortBy Field

Summary

Represents field SortBy.

Namespace: BI.DataSource
Syntax
Delphi
public
 SortBy : TSortItems;

Field Value

Type: TSortItems

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursor.ValidIndex Field

Summary

Represents field ValidIndex.

Namespace: BI.DataSource
Syntax
Delphi
protected
 ValidIndex : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TDataCursor
  • BI.DataSource


TDataCursorItemsHelper Class Helper

Summary

Represents type TDataCursorItemsHelper.

Namespace: BI.DataSource
Syntax
Delphi
type
 TDataCursorItemsHelper=record helper for TDataCursorItems
 end;
Methods
Name | Description
Add(TDataItem) | Represents method Add(TDataItem).
Clear | Represents method Clear.
Count | Represents method Count.
Delete(Integer) | Represents method Delete(Integer).
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer).
Find(TDataItem) | Represents method Find(TDataItem).
Top
See Also

Reference

  • BI.DataSource


TDataCursorItemsHelper Methods

Methods
Name | Description
Add(TDataItem) | Represents method Add(TDataItem).
Clear | Represents method Clear.
Count | Represents method Count.
Delete(Integer) | Represents method Delete(Integer).
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer).
Find(TDataItem) | Represents method Find(TDataItem).
Top


TDataCursorItemsHelper.Add(TDataItem) Method

Summary

Represents method Add(TDataItem).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure Add(const AData:TDataItem);

Parameters

AData
Type: TDataItem

See Also

Reference

  • TDataCursorItemsHelper
  • BI.DataSource


TDataCursorItemsHelper.Clear Method

Summary

Represents method Clear.

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TDataCursorItemsHelper
  • BI.DataSource


TDataCursorItemsHelper.Count Method

Summary

Represents method Count.

Namespace: BI.DataSource
Syntax
Delphi
public
 function Count:Integer;

Return Value

Type: Integer

See Also

Reference

  • TDataCursorItemsHelper
  • BI.DataSource


TDataCursorItemsHelper.Delete(Integer) Method

Summary

Represents method Delete(Integer).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure Delete(const AIndex:Integer);

Parameters

AIndex
Type: Integer

See Also

Reference

  • TDataCursorItemsHelper
  • BI.DataSource


TDataCursorItemsHelper.Exchange(Integer,Integer) Method

Summary

Represents method Exchange(Integer,Integer).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure Exchange(const A,B:Integer);

Parameters

A
Type: Integer

B
Type: Integer

See Also

Reference

  • TDataCursorItemsHelper
  • BI.DataSource


TDataCursorItemsHelper.Find(TDataItem) Method

Summary

Represents method Find(TDataItem).

Namespace: BI.DataSource
Syntax
Delphi
public
 function Find(const AData:TDataItem):Integer;

Parameters

AData
Type: TDataItem

Return Value

Type: Integer

See Also

Reference

  • TDataCursorItemsHelper
  • BI.DataSource


TDataItemAccess Class

Summary

Represents type TDataItemAccess.

Namespace: BI.DataSource
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.DataSource.TDataItemAccess
Syntax
Delphi
type
 TDataItemAccess=class(TDataItem);
See Also

Reference

  • BI.DataSource


TDataItemsAccess Class

Summary

Represents type TDataItemsAccess.

Namespace: BI.DataSource
Inheritance Hierarchy
TObject
BI.DataItem.TDataItems
BI.DataSource.TDataItemsAccess
Syntax
Delphi
type
 TDataItemsAccess=class(TDataItems);
See Also

Reference

  • BI.DataSource


TDataSelect Class

Summary

Represents type TDataSelect.

Namespace: BI.DataSource
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.DataSource.TDataCursor
BI.DataSource.TDataSelect
BI.Query.TDataSelectAccess
Syntax
Delphi
type
 TDataSelect=class(TDataCursor)
 end;

The TDataSelect type exposes the following members.

Properties
Show:
Name | Description
Distinct | Represents property Distinct.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TDataCursor.Assign(TPersistent).)
Calculate | Overloaded. Represents method Calculate.
Calculate(TDataItem) | Overloaded. Represents method Calculate(TDataItem).
GetItems(TDataItem) | Represents method GetItems(TDataItem). (Overrides TDataProvider.GetItems(TDataItem).)
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataCursor.Load(TDataItem,Boolean).)
MainData | Represents method MainData.
SetupHops(TDataHops,TDataArray) | Represents method SetupHops(TDataHops,TDataArray).
ToString | Represents method ToString.
Top
See Also

Reference

  • BI.DataSource


TDataSelect Properties

Properties
Name | Description
Distinct | Represents property Distinct.
Top


TDataSelect.Distinct Property

Summary

Represents property Distinct.

Namespace: BI.DataSource
Syntax
Delphi
public
 property Distinct:Boolean read FDistinct write FDistinct default False;

Property Value

Type: Boolean

See Also

Reference

  • TDataSelect
  • BI.DataSource


TDataSelect Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TDataCursor.Assign(TPersistent).)
Calculate | Overloaded. Represents method Calculate.
Calculate(TDataItem) | Overloaded. Represents method Calculate(TDataItem).
GetItems(TDataItem) | Represents method GetItems(TDataItem). (Overrides TDataProvider.GetItems(TDataItem).)
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataCursor.Load(TDataItem,Boolean).)
MainData | Represents method MainData.
SetupHops(TDataHops,TDataArray) | Represents method SetupHops(TDataHops,TDataArray).
ToString | Represents method ToString.
Top


TDataSelect.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TDataCursor.Assign(TPersistent)
See Also

Reference

  • TDataSelect
  • BI.DataSource


TDataSelect.Calculate Method

Summary

Represents method Calculate.

Namespace: BI.DataSource
Syntax
Delphi
public
 function Calculate:TDataItem; overload;

Return Value

Type: TDataItem

See Also

Reference

  • TDataSelect
  • BI.DataSource


TDataSelect.Calculate(TDataItem) Method

Summary

Represents method Calculate(TDataItem).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure Calculate(const AData:TDataItem); overload;

Parameters

AData
Type: TDataItem

See Also

Reference

  • TDataSelect
  • BI.DataSource


TDataSelect.GetItems(TDataItem) Method

Summary

Represents method GetItems(TDataItem).

Namespace: BI.DataSource
Syntax
Delphi
protected
 procedure GetItems(const AData:TDataItem); override;

Parameters

AData
Type: TDataItem

Overrides

TDataProvider.GetItems(TDataItem)
See Also

Reference

  • TDataSelect
  • BI.DataSource


TDataSelect.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.DataSource
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataCursor.Load(TDataItem,Boolean)
See Also

Reference

  • TDataSelect
  • BI.DataSource


TDataSelect.MainData Method

Summary

Represents method MainData.

Namespace: BI.DataSource
Syntax
Delphi
public
 function MainData:TDataItem;

Return Value

Type: TDataItem

See Also

Reference

  • TDataSelect
  • BI.DataSource


TDataSelect.SetupHops(TDataHops,TDataArray) Method

Summary

Represents method SetupHops(TDataHops,TDataArray).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function SetupHops(const Hops:TDataHops; const AItems:TDataArray):TInt32Array;

Parameters

Hops
Type: TDataHops

AItems
Type: TDataArray

Return Value

Type: TInt32Array

See Also

Reference

  • TDataSelect
  • BI.DataSource


TDataSelect.ToString Method

Summary

Represents method ToString.

Namespace: BI.DataSource
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TDataSelect
  • BI.DataSource


TExpressionColumnAccess Class

Summary

Represents type TExpressionColumnAccess.

Namespace: BI.DataSource
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Expressions.TExpressionColumn
BI.DataSource.TExpressionColumnAccess
Syntax
Delphi
type
 TExpressionColumnAccess=class(TExpressionColumn);
See Also

Reference

  • BI.DataSource


TFileFiltersHelper Class Helper

Summary

Represents type TFileFiltersHelper.

Namespace: BI.DataSource
Syntax
Delphi
type
 TFileFiltersHelper=record helper for TFileFilters
 end;
Methods
Name | Description
Add(String,String) | Represents method Add(String,String).
ToDialogFilter(String,String) | Represents method ToDialogFilter(String,String).
Top
See Also

Reference

  • BI.DataSource


TFileFiltersHelper Methods

Methods
Name | Description
Add(String,String) | Represents method Add(String,String).
ToDialogFilter(String,String) | Represents method ToDialogFilter(String,String).
Top


TFileFiltersHelper.Add(String,String) Method

Summary

Represents method Add(String,String).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure Add(const ADescription,AExtensions:String);

Parameters

ADescription
Type: String

AExtensions
Type: String

See Also

Reference

  • TFileFiltersHelper
  • BI.DataSource


TFileFiltersHelper.ToDialogFilter(String,String) Method

Summary

Represents method ToDialogFilter(String,String).

Namespace: BI.DataSource
Syntax
Delphi
public
 procedure ToDialogFilter(var AFilter:String; var All:String);

Parameters

AFilter
Type: String

All
Type: String

See Also

Reference

  • TFileFiltersHelper
  • BI.DataSource


BI.DataSource Records

Records
Name | Description
TDataClone | Represents type TDataClone.
TDataCursorItem | Represents type TDataCursorItem.
TFileFilter | Represents type TFileFilter.
Top


TDataClone Record

Summary

Represents type TDataClone.

Namespace: BI.DataSource
Syntax
Delphi
type
 TDataClone=record
 end;

The TDataClone type exposes the following members.

Methods
Show:
Name | Description
Clone(TDataItem) | Overloaded. Represents method Clone(TDataItem).
Clone(TDataItem,TDataItem,TDataArray) | Overloaded. Represents method Clone(TDataItem,TDataItem,TDataArray).
Clone(TDataItem,TNativeIntArray) | Overloaded. Represents method Clone(TDataItem,TNativeIntArray).
CloneStructure(TDataItem,TDataArray) | Overloaded. Represents method CloneStructure(TDataItem,TDataArray).
CloneStructure(TDataItem,TDataItem,TDataArray) | Overloaded. Represents method CloneStructure(TDataItem,TDataItem,TDataArray).
CopyData(TDataArray,TDataArray,TInteger,TInteger) | Overloaded. Represents method CopyData(TDataArray,TDataArray,TInteger,TInteger).
CopyData(TDataItem,TDataItem,TInteger,TInteger,TDataArray) | Overloaded. Represents method CopyData(TDataItem,TDataItem,TInteger,TInteger,TDataArray).
Top
See Also

Reference

  • BI.DataSource


TDataClone Methods

Methods
Name | Description
Clone(TDataItem) | Overloaded. Represents method Clone(TDataItem).
Clone(TDataItem,TDataItem,TDataArray) | Overloaded. Represents method Clone(TDataItem,TDataItem,TDataArray).
Clone(TDataItem,TNativeIntArray) | Overloaded. Represents method Clone(TDataItem,TNativeIntArray).
CloneStructure(TDataItem,TDataArray) | Overloaded. Represents method CloneStructure(TDataItem,TDataArray).
CloneStructure(TDataItem,TDataItem,TDataArray) | Overloaded. Represents method CloneStructure(TDataItem,TDataItem,TDataArray).
CopyData(TDataArray,TDataArray,TInteger,TInteger) | Overloaded. Represents method CopyData(TDataArray,TDataArray,TInteger,TInteger).
CopyData(TDataItem,TDataItem,TInteger,TInteger,TDataArray) | Overloaded. Represents method CopyData(TDataItem,TDataItem,TInteger,TInteger,TDataArray).
Top


TDataClone.Clone(TDataItem) Method

Summary

Represents method Clone(TDataItem).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function Clone(const AData:TDataItem):TDataItem; overload; static;

Parameters

AData
Type: TDataItem

Return Value

Type: TDataItem

See Also

Reference

  • TDataClone
  • BI.DataSource


TDataClone.Clone(TDataItem,TDataItem,TDataArray) Method

Summary

Represents method Clone(TDataItem,TDataItem,TDataArray).

Namespace: BI.DataSource
Syntax
Delphi
public
 class procedure Clone(const ASource,ADest:TDataItem; const AItems:TDataArray=nil); overload; static;

Parameters

ASource
Type: TDataItem

ADest
Type: TDataItem

AItems
Type: TDataArray

See Also

Reference

  • TDataClone
  • BI.DataSource


TDataClone.Clone(TDataItem,TNativeIntArray) Method

Summary

Represents method Clone(TDataItem,TNativeIntArray).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function Clone(const AData:TDataItem; const AIndex:TNativeIntArray):TDataItem; overload; static;

Parameters

AData
Type: TDataItem

AIndex
Type: System.Void

Return Value

Type: TDataItem

See Also

Reference

  • TDataClone
  • BI.DataSource


TDataClone.CloneStructure(TDataItem,TDataArray) Method

Summary

Represents method CloneStructure(TDataItem,TDataArray).

Namespace: BI.DataSource
Syntax
Delphi
public
 class function CloneStructure(const AData:TDataItem;
 const AItems:TDataArray=nil):TDataItem; overload; static;

Parameters

AData
Type: TDataItem

AItems
Type: TDataArray

Return Value

Type: TDataItem

See Also

Reference

  • TDataClone
  • BI.DataSource


TDataClone.CloneStructure(TDataItem,TDataItem,TDataArray) Method

Summary

Represents method CloneStructure(TDataItem,TDataItem,TDataArray).

Namespace: BI.DataSource
Syntax
Delphi
public
 class procedure CloneStructure(const ADest,AData:TDataItem;
 const AItems:TDataArray=nil); overload; static;

Parameters

ADest
Type: TDataItem

AData
Type: TDataItem

AItems
Type: TDataArray

See Also

Reference

  • TDataClone
  • BI.DataSource


TDataClone.CopyData(TDataArray,TDataArray,TInteger,TInteger) Method

Summary

Represents method CopyData(TDataArray,TDataArray,TInteger,TInteger).

Namespace: BI.DataSource
Syntax
Delphi
public
 class procedure CopyData(const ASource,ADest:TDataArray;
 const AIndex,ADestPos:TInteger); overload; static;

Parameters

ASource
Type: TDataArray

ADest
Type: TDataArray

AIndex
Type: System.Void

ADestPos
Type: System.Void

See Also

Reference

  • TDataClone
  • BI.DataSource


TDataClone.CopyData(TDataItem,TDataItem,TInteger,TInteger,TDataArray) Method

Summary

Represents method CopyData(TDataItem,TDataItem,TInteger,TInteger,TDataArray).

Namespace: BI.DataSource
Syntax
Delphi
public
 class procedure CopyData(const ASource,ADest:TDataItem;
 const AIndex,ADestPos:TInteger;
 const AItems:TDataArray=nil); overload; static;

Parameters

ASource
Type: TDataItem

ADest
Type: TDataItem

AIndex
Type: System.Void

ADestPos
Type: System.Void

AItems
Type: TDataArray

See Also

Reference

  • TDataClone
  • BI.DataSource


TDataCursorItem Record

Summary

Represents type TDataCursorItem.

Namespace: BI.DataSource
Syntax
Delphi
type
 TDataCursorItem=record
 end;

The TDataCursorItem type exposes the following members.

Fields
Show:
Name | Description
Active | Represents field Active.
Data | Represents field Data.
Name | Represents field Name.
OwnsData | Represents field OwnsData.
Top
See Also

Reference

  • BI.DataSource


TDataCursorItem Fields

Fields
Name | Description
Active | Represents field Active.
Data | Represents field Data.
Name | Represents field Name.
OwnsData | Represents field OwnsData.
Top


TDataCursorItem.Active Field

Summary

Represents field Active.

Namespace: BI.DataSource
Syntax
Delphi
public
 Active : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TDataCursorItem
  • BI.DataSource


TDataCursorItem.Data Field

Summary

Represents field Data.

Namespace: BI.DataSource
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TDataCursorItem
  • BI.DataSource


TDataCursorItem.Name Field

Summary

Represents field Name.

Namespace: BI.DataSource
Syntax
Delphi
public
 Name : String;

Field Value

Type: String

See Also

Reference

  • TDataCursorItem
  • BI.DataSource


TDataCursorItem.OwnsData Field

Summary

Represents field OwnsData.

Namespace: BI.DataSource
Syntax
Delphi
public
 OwnsData : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TDataCursorItem
  • BI.DataSource


TFileFilter Record

Summary

Represents type TFileFilter.

Namespace: BI.DataSource
Syntax
Delphi
type
 TFileFilter=record
 end;

The TFileFilter type exposes the following members.

Methods
Show:
Name | Description
FirstExtension | Represents method FirstExtension.
Top
Fields
Show:
Name | Description
Description | Represents field Description.
Extensions | Represents field Extensions.
Top
See Also

Reference

  • BI.DataSource


TFileFilter Methods

Methods
Name | Description
FirstExtension | Represents method FirstExtension.
Top


TFileFilter.FirstExtension Method

Summary

Represents method FirstExtension.

Namespace: BI.DataSource
Syntax
Delphi
public
 function FirstExtension:String;

Return Value

Type: String

See Also

Reference

  • TFileFilter
  • BI.DataSource


TFileFilter Fields

Fields
Name | Description
Description | Represents field Description.
Extensions | Represents field Extensions.
Top


TFileFilter.Description Field

Summary

Represents field Description.

Namespace: BI.DataSource
Syntax
Delphi
public
 Description,
 Extensions : String;

Field Value

Type: String

See Also

Reference

  • TFileFilter
  • BI.DataSource


TFileFilter.Extensions Field

Summary

Represents field Extensions.

Namespace: BI.DataSource
Syntax
Delphi
public
 Description,
 Extensions : String;

Field Value

Type: String

See Also

Reference

  • TFileFilter
  • BI.DataSource


BI.DataSource Enumerations

Enumerations
Name | Description
TFileShareMode | Represents type TFileShareMode.
Top


TFileShareMode Enumeration

Summary

Represents type TFileShareMode.

Namespace: BI.DataSource
Syntax
Delphi
type
 TFileShareMode=(Exclusive, DenyWrite, DenyRead, DenyNone);

The TFileShareMode type exposes the following members.

Members
Show:
Name | Description
DenyNone | Represents constant DenyNone.
DenyRead | Represents constant DenyRead.
DenyWrite | Represents constant DenyWrite.
Exclusive | Represents constant Exclusive.
Top
See Also

Reference

  • BI.DataSource


BI.DataSource Delegates

Delegates
Name | Description
TCursorLoopObject | Represents type TCursorLoopObject.
TExportGetText | Represents type TExportGetText.
Top


TCursorLoopObject Delegate

Summary

Represents type TCursorLoopObject.

Namespace: BI.DataSource
Syntax
Delphi
type
 TCursorLoopObject=procedure(const AIndex:TInteger) of object;
See Also

Reference

  • BI.DataSource


TExportGetText Delegate

Summary

Represents type TExportGetText.

Namespace: BI.DataSource
Syntax
Delphi
type
 TExportGetText=procedure(const Sender:TBIExport; const Data:TDataItem; const AIndex:TInteger; var Text:String) of object;
See Also

Reference

  • BI.DataSource


BI.DataSource Types

Types
Name | Description
TBIExportClass | Represents type TBIExportClass.
TBIExporters | Represents an array of the TBIExportClass type.
TBIFileImporters | Represents an array of the TBIFileSourceClass type.
TBIFileSourceClass | Represents type TBIFileSourceClass.
TCursorIndex | Represents an alias of the TNativeIntArray type.
TCursorLoop | Represents type TCursorLoop.
TDataCursorItems | Represents an array of the TDataCursorItem type.
TFileFilters | Represents an array of the TFileFilter type.
Top


TBIExportClass Type

Summary

Represents type TBIExportClass.

Namespace: BI.DataSource
Syntax
Delphi
type
 TBIExportClass=class of TBIExport;
See Also

Reference

  • BI.DataSource


TBIExporters Type

Summary

Represents an array of the TBIExportClass type.

Namespace: BI.DataSource
Syntax
Delphi
type
 TBIExporters=Array of TBIExportClass;
See Also

Reference

  • BI.DataSource


TBIFileImporters Type

Summary

Represents an array of the TBIFileSourceClass type.

Namespace: BI.DataSource
Syntax
Delphi
type
 TBIFileImporters=Array of TBIFileSourceClass;
See Also

Reference

  • BI.DataSource


TBIFileSourceClass Type

Summary

Represents type TBIFileSourceClass.

Namespace: BI.DataSource
Syntax
Delphi
type
 TBIFileSourceClass=class of TBIFileSource;
See Also

Reference

  • BI.DataSource


TCursorIndex Type

Summary

Represents an alias of the TNativeIntArray type.

Namespace: BI.DataSource
Syntax
Delphi
type
 TCursorIndex=TNativeIntArray;
See Also

Reference

  • BI.DataSource


TCursorLoop Type

Summary

Represents type TCursorLoop.

Namespace: BI.DataSource
Syntax
Delphi
type
 TCursorLoop=reference to procedure(const AIndex:TInteger);
See Also

Reference

  • BI.DataSource


TDataCursorItems Type

Summary

Represents an array of the TDataCursorItem type.

Namespace: BI.DataSource
Syntax
Delphi
type
 TDataCursorItems=Array of TDataCursorItem;
See Also

Reference

  • BI.DataSource


TFileFilters Type

Summary

Represents an array of the TFileFilter type.

Namespace: BI.DataSource
Syntax
Delphi
type
 TFileFilters=Array of TFileFilter;
See Also

Reference

  • BI.DataSource


BI.DataSource Routines

Routines
Name | Description
CheckZBS | Represents method CheckZBS.
CloneItem(TDataItem,TDataArray) | Represents method CloneItem(TDataItem,TDataArray).
GetFilesFrom(String,String,String,Boolean) | Represents method GetFilesFrom(String,String,String,Boolean).
Top


CheckZBS Method

Summary

Represents method CheckZBS.

Namespace: BI.DataSource
Syntax
Delphi
procedure CheckZBS;
See Also

Reference

  • BI.DataSource


CloneItem(TDataItem,TDataArray) Method

Summary

Represents method CloneItem(TDataItem,TDataArray).

Namespace: BI.DataSource
Syntax
Delphi
function CloneItem(const ASource:TDataItem; const AItems:TDataArray):TDataItem;

Parameters

ASource
Type: TDataItem

AItems
Type: TDataArray

Return Value

Type: TDataItem

See Also

Reference

  • BI.DataSource


GetFilesFrom(String,String,String,Boolean) Method

Summary

Represents method GetFilesFrom(String,String,String,Boolean).

Namespace: BI.DataSource
Syntax
Delphi
function GetFilesFrom(const Folder,IncludePattern,ExcludePattern:String; Recursive:Boolean):TStringDynArray;

Parameters

Folder
Type: String

IncludePattern
Type: String

ExcludePattern
Type: String

Recursive
Type: Boolean

Return Value

Type: TStringDynArray

See Also

Reference

  • BI.DataSource


BI.DB Namespace

Summary

Represents namespace BI.DB.

Classes
Name | Description
TBIDB | Represents type TBIDB.
TBIDBEngine | Represents type TBIDBEngine.
TBIDBExport | Represents type TBIDBExport.
TBIDBImporter | Represents type TBIDBImporter.
TBIDBTester | Represents type TBIDBTester.
TDataAccess | Represents type TDataAccess.
Top
Types
Name | Description
TBIDBTesterClass | Represents type TBIDBTesterClass.
Top
Routines
Name | Description
CleanPrefix(TDataArray) | Represents method CleanPrefix(TDataArray).
Top


BI.DB Classes

Classes
Name | Description
TBIDB | Represents type TBIDB.
TBIDBEngine | Represents type TBIDBEngine.
TBIDBExport | Represents type TBIDBExport.
TBIDBImporter | Represents type TBIDBImporter.
TBIDBTester | Represents type TBIDBTester.
TDataAccess | Represents type TDataAccess.
Top


TBIDB Class

Summary

Represents type TBIDB.

Namespace: BI.DB
Inheritance Hierarchy
TObject
BI.DataSource.TBISource
BI.DataSource.TBIItemsSource
BI.DataSource.TBIFileSource
BI.DB.Dataset.TBIDataSetSource
BI.DB.TBIDB
Syntax
Delphi
type
 TBIDB=class(TBIDatasetSource)
 end;

The TBIDB type exposes the following members.

Constructors
Show:
Name | Description
CreateEngine(TBIDBEngine) | Initializes a new instance of the TBIDB class.
Top
Properties
Show:
Name | Description
Engine | Represents property Engine.
Top
Methods
Show:
Name | Description
DoImportFile(String) | Represents method DoImportFile(String). (Overrides TBIFileSource.DoImportFile(String).)
FileFilter | Represents method FileFilter. (Overrides TBIFileSource.FileFilter.)
Import(TCustomConnection) | Overloaded. Represents method Import(TCustomConnection).
Import(TCustomConnection,Boolean) | Overloaded. Represents method Import(TCustomConnection,Boolean).
IncludedItems(TDataDefinition) | Represents method IncludedItems(TDataDefinition).
Supports(String) | Represents method Supports(String). (Overrides TBIFileSource.Supports(String).)
Top
See Also

Reference

  • BI.DB


TBIDB Constructors

Constructors
Name | Description
CreateEngine(TBIDBEngine) | Initializes a new instance of the TBIDB class.
Top


TBIDB.CreateEngine(TBIDBEngine) Constructor

Summary

Initializes a new instance of the TBIDB class.

Namespace: BI.DB
Syntax
Delphi
public
 Constructor CreateEngine(const AEngine:TBIDBEngine);

Parameters

AEngine
Type: TBIDBEngine

See Also

Reference

  • TBIDB
  • BI.DB


TBIDB Properties

Properties
Name | Description
Engine | Represents property Engine.
Top


TBIDB.Engine Property

Summary

Represents property Engine.

Namespace: BI.DB
Syntax
Delphi
public
 class property Engine:TBIDBEngine read GetEngine write SetEngine;

Property Value

Type: TBIDBEngine

See Also

Reference

  • TBIDB
  • BI.DB


TBIDB Methods

Methods
Name | Description
DoImportFile(String) | Represents method DoImportFile(String). (Overrides TBIFileSource.DoImportFile(String).)
FileFilter | Represents method FileFilter. (Overrides TBIFileSource.FileFilter.)
Import(TCustomConnection) | Overloaded. Represents method Import(TCustomConnection).
Import(TCustomConnection,Boolean) | Overloaded. Represents method Import(TCustomConnection,Boolean).
IncludedItems(TDataDefinition) | Represents method IncludedItems(TDataDefinition).
Supports(String) | Represents method Supports(String). (Overrides TBIFileSource.Supports(String).)
Top


TBIDB.DoImportFile(String) Method

Summary

Represents method DoImportFile(String).

Namespace: BI.DB
Syntax
Delphi
protected
 function DoImportFile(const FileName:String):TDataArray; override;

Parameters

FileName
Type: String

Return Value

Type: TDataArray

Overrides

TBIFileSource.DoImportFile(String)
See Also

Reference

  • TBIDB
  • BI.DB


TBIDB.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.DB
Syntax
Delphi
public
 class function FileFilter: TFileFilters; override;

Return Value

Type: TFileFilters

Overrides

TBIFileSource.FileFilter
See Also

Reference

  • TBIDB
  • BI.DB


TBIDB.Import(TCustomConnection) Method

Summary

Represents method Import(TCustomConnection).

Namespace: BI.DB
Syntax
Delphi
public
 function Import(const Connection:TCustomConnection):TDataArray; overload;

Parameters

Connection
Type: TCustomConnection

Return Value

Type: TDataArray

See Also

Reference

  • TBIDB
  • BI.DB


TBIDB.Import(TCustomConnection,Boolean) Method

Summary

Represents method Import(TCustomConnection,Boolean).

Namespace: BI.DB
Syntax
Delphi
public
 class function Import(const Connection:TCustomConnection; const MultiThread:Boolean):TDataArray; overload;

Parameters

Connection
Type: TCustomConnection

MultiThread
Type: Boolean

Return Value

Type: TDataArray

See Also

Reference

  • TBIDB
  • BI.DB


TBIDB.IncludedItems(TDataDefinition) Method

Summary

Represents method IncludedItems(TDataDefinition).

Namespace: BI.DB
Syntax
Delphi
public
 class function IncludedItems(const ADef:TDataDefinition): TDataItem;

Parameters

ADef
Type: TDataDefinition

Return Value

Type: TDataItem

See Also

Reference

  • TBIDB
  • BI.DB


TBIDB.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.DB
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIFileSource.Supports(String)
See Also

Reference

  • TBIDB
  • BI.DB


TBIDBEngine Class

Summary

Represents type TBIDBEngine.

Namespace: BI.DB
Inheritance Hierarchy
TObject
BI.DB.TBIDBEngine
BI.DB.BDE.TDBBDEEngine
BI.DB.Fire.TDBFireDACEngine
BI.DB.microOLAP.TDBmicroOLAPEngine
BI.DB.SqlExpr.TDBSqlExprEngine
BI.DB.UniDAC.TDBUniDACEngine
BI.SqlDB.TDBSqlDBEngine
Syntax
Delphi
type
 TBIDBEngine=class abstract
 end;

The TBIDBEngine type exposes the following members.

Methods
Show:
Name | Description
AddFields(TFieldDefs,TDataArray) | Represents method AddFields(TFieldDefs,TDataArray).
CloneConnection(TCustomConnection) | Represents method CloneConnection(TCustomConnection).
CreateConnection(TDataDefinition) | Represents method CreateConnection(TDataDefinition).
CreateDataSet(TComponent,TDataItem) | Represents method CreateDataSet(TComponent,TDataItem).
CreateQuery(TCustomConnection,String) | Represents method CreateQuery(TCustomConnection,String).
DriverNames | Represents method DriverNames.
DriverToName(String) | Represents method DriverToName(String).
FileFilter | Represents method FileFilter.
GetConnectionName(TCustomConnection) | Represents method GetConnectionName(TCustomConnection).
GetDriver(Integer) | Represents method GetDriver(Integer).
GetItemNames(TCustomConnection,Boolean,Boolean) | Represents method GetItemNames(TCustomConnection,Boolean,Boolean).
GetKeyFieldNames(TCustomConnection,String) | Represents method GetKeyFieldNames(TCustomConnection,String).
GetTable(TCustomConnection,String) | Represents method GetTable(TCustomConnection,String).
GuessForeignKeys(String,TDataSet,TDataItem,TBISource) | Represents method GuessForeignKeys(String,TDataSet,TDataItem,TBISource).
ImportFile(TBIDB,String) | Represents method ImportFile(TBIDB,String).
StartParallel | Represents method StartParallel.
Supports(String) | Represents method Supports(String).
SupportsParallel | Represents method SupportsParallel.
Tester | Represents method Tester.
Top
See Also

Reference

  • BI.DB


TBIDBEngine Methods

Methods
Name | Description
AddFields(TFieldDefs,TDataArray) | Represents method AddFields(TFieldDefs,TDataArray).
CloneConnection(TCustomConnection) | Represents method CloneConnection(TCustomConnection).
CreateConnection(TDataDefinition) | Represents method CreateConnection(TDataDefinition).
CreateDataSet(TComponent,TDataItem) | Represents method CreateDataSet(TComponent,TDataItem).
CreateQuery(TCustomConnection,String) | Represents method CreateQuery(TCustomConnection,String).
DriverNames | Represents method DriverNames.
DriverToName(String) | Represents method DriverToName(String).
FileFilter | Represents method FileFilter.
GetConnectionName(TCustomConnection) | Represents method GetConnectionName(TCustomConnection).
GetDriver(Integer) | Represents method GetDriver(Integer).
GetItemNames(TCustomConnection,Boolean,Boolean) | Represents method GetItemNames(TCustomConnection,Boolean,Boolean).
GetKeyFieldNames(TCustomConnection,String) | Represents method GetKeyFieldNames(TCustomConnection,String).
GetTable(TCustomConnection,String) | Represents method GetTable(TCustomConnection,String).
GuessForeignKeys(String,TDataSet,TDataItem,TBISource) | Represents method GuessForeignKeys(String,TDataSet,TDataItem,TBISource).
ImportFile(TBIDB,String) | Represents method ImportFile(TBIDB,String).
StartParallel | Represents method StartParallel.
Supports(String) | Represents method Supports(String).
SupportsParallel | Represents method SupportsParallel.
Tester | Represents method Tester.
Top


TBIDBEngine.AddFields(TFieldDefs,TDataArray) Method

Summary

Represents method AddFields(TFieldDefs,TDataArray).

Namespace: BI.DB
Syntax
Delphi
public
 class procedure AddFields(const Fields:TFieldDefs; const AItems:TDataArray);

Parameters

Fields
Type: TFieldDefs

AItems
Type: TDataArray

See Also

Reference

  • TBIDBEngine
  • BI.DB


TBIDBEngine.CloneConnection(TCustomConnection) Method

Summary

Represents method CloneConnection(TCustomConnection).

Namespace: BI.DB
Syntax
Delphi
public
 class function CloneConnection(const AConn:TCustomConnection): TCustomConnection; virtual; abstract;

Parameters

AConn
Type: TCustomConnection

Return Value

Type: TCustomConnection

See Also

Reference

  • TBIDBEngine
  • BI.DB


TBIDBEngine.CreateConnection(TDataDefinition) Method

Summary

Represents method CreateConnection(TDataDefinition).

Namespace: BI.DB
Syntax
Delphi
public
 class function CreateConnection(const Definition:TDataDefinition):TCustomConnection; virtual; abstract;

Parameters

Definition
Type: TDataDefinition

Return Value

Type: TCustomConnection

See Also

Reference

  • TBIDBEngine
  • BI.DB


TBIDBEngine.CreateDataSet(TComponent,TDataItem) Method

Summary

Represents method CreateDataSet(TComponent,TDataItem).

Namespace: BI.DB
Syntax
Delphi
public
 class function CreateDataSet(const AOwner:TComponent; const AData:TDataItem):TDataSet; virtual; abstract;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

Return Value

Type: TDataSet

See Also

Reference

  • TBIDBEngine
  • BI.DB


TBIDBEngine.CreateQuery(TCustomConnection,String) Method

Summary

Represents method CreateQuery(TCustomConnection,String).

Namespace: BI.DB
Syntax
Delphi
public
 class function CreateQuery(const AConnection:TCustomConnection; const SQL:String):TDataSet; virtual; abstract;

Parameters

AConnection
Type: TCustomConnection

SQL
Type: String

Return Value

Type: TDataSet

See Also

Reference

  • TBIDBEngine
  • BI.DB


TBIDBEngine.DriverNames Method

Summary

Represents method DriverNames.

Namespace: BI.DB
Syntax
Delphi
public
 class function DriverNames:TStringDynArray; virtual; abstract;

Return Value

Type: TStringDynArray

See Also

Reference

  • TBIDBEngine
  • BI.DB


TBIDBEngine.DriverToName(String) Method

Summary

Represents method DriverToName(String).

Namespace: BI.DB
Syntax
Delphi
public
 class function DriverToName(const ADriver:String):String; virtual; abstract;

Parameters

ADriver
Type: String

Return Value

Type: String

See Also

Reference

  • TBIDBEngine
  • BI.DB


TBIDBEngine.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.DB
Syntax
Delphi
public
 class function FileFilter:TFileFilters; virtual; abstract;

Return Value

Type: TFileFilters

See Also

Reference

  • TBIDBEngine
  • BI.DB


TBIDBEngine.GetConnectionName(TCustomConnection) Method

Summary

Represents method GetConnectionName(TCustomConnection).

Namespace: BI.DB
Syntax
Delphi
public
 class function GetConnectionName(const AConnection:TCustomConnection):String; virtual; abstract;

Parameters

AConnection
Type: TCustomConnection

Return Value

Type: String

See Also

Reference

  • TBIDBEngine
  • BI.DB


TBIDBEngine.GetDriver(Integer) Method

Summary

Represents method GetDriver(Integer).

Namespace: BI.DB
Syntax
Delphi
public
 class function GetDriver(const AIndex:Integer):String; virtual; abstract;

Parameters

AIndex
Type: Integer

Return Value

Type: String

See Also

Reference

  • TBIDBEngine
  • BI.DB


TBIDBEngine.GetItemNames(TCustomConnection,Boolean,Boolean) Method

Summary

Represents method GetItemNames(TCustomConnection,Boolean,Boolean).

Namespace: BI.DB
Syntax
Delphi
public
 class function GetItemNames(const AConnection:TCustomConnection;
 const IncludeSystem,IncludeViews:Boolean):TStrings; virtual; abstract;

Parameters

AConnection
Type: TCustomConnection

IncludeSystem
Type: Boolean

IncludeViews
Type: Boolean

Return Value

Type: TStrings

See Also

Reference

  • TBIDBEngine
  • BI.DB


TBIDBEngine.GetKeyFieldNames(TCustomConnection,String) Method

Summary

Represents method GetKeyFieldNames(TCustomConnection,String).

Namespace: BI.DB
Syntax
Delphi
public
 class function GetKeyFieldNames(const AConnection:TCustomConnection; const ATable:String):TStrings; virtual; abstract;

Parameters

AConnection
Type: TCustomConnection

ATable
Type: String

Return Value

Type: TStrings

See Also

Reference

  • TBIDBEngine
  • BI.DB


TBIDBEngine.GetTable(TCustomConnection,String) Method

Summary

Represents method GetTable(TCustomConnection,String).

Namespace: BI.DB
Syntax
Delphi
public
 class function GetTable(const AConnection:TCustomConnection; const AName:String):TDataSet; virtual; abstract;

Parameters

AConnection
Type: TCustomConnection

AName
Type: String

Return Value

Type: TDataSet

See Also

Reference

  • TBIDBEngine
  • BI.DB


TBIDBEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource) Method

Summary

Represents method GuessForeignKeys(String,TDataSet,TDataItem,TBISource).

Namespace: BI.DB
Syntax
Delphi
public
 class procedure GuessForeignKeys(const AName:String; const Table:TDataSet;
 const AData:TDataItem; const Source:TBISource); virtual; abstract;

Parameters

AName
Type: String

Table
Type: TDataSet

AData
Type: TDataItem

Source
Type: TBISource

See Also

Reference

  • TBIDBEngine
  • BI.DB


TBIDBEngine.ImportFile(TBIDB,String) Method

Summary

Represents method ImportFile(TBIDB,String).

Namespace: BI.DB
Syntax
Delphi
public
 class function ImportFile(const Source:TBIDB; const AFileName:String):TDataArray; virtual; abstract;

Parameters

Source
Type: TBIDB

AFileName
Type: String

Return Value

Type: TDataArray

See Also

Reference

  • TBIDBEngine
  • BI.DB


TBIDBEngine.StartParallel Method

Summary

Represents method StartParallel.

Namespace: BI.DB
Syntax
Delphi
public
 class procedure StartParallel; virtual;
See Also

Reference

  • TBIDBEngine
  • BI.DB


TBIDBEngine.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.DB
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; virtual; abstract;

Parameters

Extension
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TBIDBEngine
  • BI.DB


TBIDBEngine.SupportsParallel Method

Summary

Represents method SupportsParallel.

Namespace: BI.DB
Syntax
Delphi
public
 class function SupportsParallel:Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TBIDBEngine
  • BI.DB


TBIDBEngine.Tester Method

Summary

Represents method Tester.

Namespace: BI.DB
Syntax
Delphi
public
 class function Tester:TBIDBTesterClass; virtual; abstract;

Return Value

Type: TBIDBTesterClass

See Also

Reference

  • TBIDBEngine
  • BI.DB


TBIDBExport Class

Summary

Represents type TBIDBExport.

Namespace: BI.DB
Inheritance Hierarchy
TObject
BI.DB.TBIDBExport
Syntax
Delphi
type
 TBIDBExport=class
 end;

The TBIDBExport type exposes the following members.

Methods
Show:
Name | Description
Add(TDataSet,TDataItem) | Represents method Add(TDataSet,TDataItem).
From(TComponent,TDataItem) | Represents method From(TComponent,TDataItem).
Top
See Also

Reference

  • BI.DB


TBIDBExport Methods

Methods
Name | Description
Add(TDataSet,TDataItem) | Represents method Add(TDataSet,TDataItem).
From(TComponent,TDataItem) | Represents method From(TComponent,TDataItem).
Top


TBIDBExport.Add(TDataSet,TDataItem) Method

Summary

Represents method Add(TDataSet,TDataItem).

Namespace: BI.DB
Syntax
Delphi
public
 class procedure Add(const ADataSet:TDataSet; const AData:TDataItem); static;

Parameters

ADataSet
Type: TDataSet

AData
Type: TDataItem

See Also

Reference

  • TBIDBExport
  • BI.DB


TBIDBExport.From(TComponent,TDataItem) Method

Summary

Represents method From(TComponent,TDataItem).

Namespace: BI.DB
Syntax
Delphi
public
 class function From(const AOwner:TComponent; const AData:TDataItem):TDataSet; static;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

Return Value

Type: TDataSet

See Also

Reference

  • TBIDBExport
  • BI.DB


TBIDBImporter Class

Summary

Represents type TBIDBImporter.

Namespace: BI.DB
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Persist.TDataImporter
BI.DB.TBIDBImporter
Syntax
Delphi
type
 TBIDBImporter=class(TDataImporter)
 end;

The TBIDBImporter type exposes the following members.

Methods
Show:
Name | Description
Import | Represents method Import. (Overrides TDataImporter.Import.)
Supports(TDataDefinitionKind,TDataDefinition) | Represents method Supports(TDataDefinitionKind,TDataDefinition). (Overrides TDataImporter.Supports(TDataDefinitionKind,TDataDefinition).)
Top
See Also

Reference

  • BI.DB


TBIDBImporter Methods

Methods
Name | Description
Import | Represents method Import. (Overrides TDataImporter.Import.)
Supports(TDataDefinitionKind,TDataDefinition) | Represents method Supports(TDataDefinitionKind,TDataDefinition). (Overrides TDataImporter.Supports(TDataDefinitionKind,TDataDefinition).)
Top


TBIDBImporter.Import Method

Summary

Represents method Import.

Namespace: BI.DB
Syntax
Delphi
public
 function Import:TDataArray; override;

Return Value

Type: TDataArray

Overrides

TDataImporter.Import
See Also

Reference

  • TBIDBImporter
  • BI.DB


TBIDBImporter.Supports(TDataDefinitionKind,TDataDefinition) Method

Summary

Represents method Supports(TDataDefinitionKind,TDataDefinition).

Namespace: BI.DB
Syntax
Delphi
public
 class function Supports(const Kind:TDataDefinitionKind;
 const ADefinition:TDataDefinition=nil):Boolean; override;

Parameters

Kind
Type: TDataDefinitionKind

ADefinition
Type: TDataDefinition

Return Value

Type: Boolean

Overrides

TDataImporter.Supports(TDataDefinitionKind,TDataDefinition)
See Also

Reference

  • TBIDBImporter
  • BI.DB


TBIDBTester Class

Summary

Represents type TBIDBTester.

Namespace: BI.DB
Inheritance Hierarchy
TObject
BI.DB.TBIDBTester
BI.DB.BDE.TBIBDETester
BI.DB.Fire.AllDrivers.TBIDBFireDACTester
BI.DB.SqlExpr.TDBSqlExprTester
Syntax
Delphi
type
 TBIDBTester=class abstract
 end;

The TBIDBTester type exposes the following members.

Methods
Show:
Name | Description
Test(String,String,String,String,String,String,Boolean) | Represents method Test(String,String,String,String,String,String,Boolean).
Top
See Also

Reference

  • BI.DB


TBIDBTester Methods

Methods
Name | Description
Test(String,String,String,String,String,String,Boolean) | Represents method Test(String,String,String,String,String,String,Boolean).
Top


TBIDBTester.Test(String,String,String,String,String,String,Boolean) Method

Summary

Represents method Test(String,String,String,String,String,String,Boolean).

Namespace: BI.DB
Syntax
Delphi
public
 class procedure Test(const Driver,Database,Server,Port,User,Password:String;
 const Prompt:Boolean); virtual; abstract;

Parameters

Driver
Type: String

Database
Type: String

Server
Type: String

Port
Type: String

User
Type: String

Password
Type: String

Prompt
Type: Boolean

See Also

Reference

  • TBIDBTester
  • BI.DB


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.DB
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.DB.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.DB


BI.DB Types

Types
Name | Description
TBIDBTesterClass | Represents type TBIDBTesterClass.
Top


TBIDBTesterClass Type

Summary

Represents type TBIDBTesterClass.

Namespace: BI.DB
Syntax
Delphi
type
 TBIDBTesterClass=class of TBIDBTester;
See Also

Reference

  • BI.DB


BI.DB Routines

Routines
Name | Description
CleanPrefix(TDataArray) | Represents method CleanPrefix(TDataArray).
Top


CleanPrefix(TDataArray) Method

Summary

Represents method CleanPrefix(TDataArray).

Namespace: BI.DB
Syntax
Delphi
procedure CleanPrefix(var Items:TDataArray);

Parameters

Items
Type: TDataArray

See Also

Reference

  • BI.DB


BI.DB.BDE Namespace

Summary

Represents namespace BI.DB.BDE.

Classes
Name | Description
TBIBDETester | Represents type TBIBDETester.
TDBBDEEngine | Represents type TDBBDEEngine.
Top
Constants
Name | Description
BDE_Name | Represents constant BDE_Name.
Top
Routines
Name | Description
CreateDatabase(String) | Represents method CreateDatabase(String).
Top


BI.DB.BDE Classes

Classes
Name | Description
TBIBDETester | Represents type TBIBDETester.
TDBBDEEngine | Represents type TDBBDEEngine.
Top


TBIBDETester Class

Summary

Represents type TBIBDETester.

Namespace: BI.DB.BDE
Inheritance Hierarchy
TObject
BI.DB.TBIDBTester
BI.DB.BDE.TBIBDETester
Syntax
Delphi
type
 TBIBDETester=class(TBIDBTester)
 end;

The TBIBDETester type exposes the following members.

Methods
Show:
Name | Description
Test(String,String,String,String,String,String,Boolean) | Represents method Test(String,String,String,String,String,String,Boolean). (Overrides TBIDBTester.Test(String,String,String,String,String,String,Boolean).)
Top
See Also

Reference

  • BI.DB.BDE


TBIBDETester Methods

Methods
Name | Description
Test(String,String,String,String,String,String,Boolean) | Represents method Test(String,String,String,String,String,String,Boolean). (Overrides TBIDBTester.Test(String,String,String,String,String,String,Boolean).)
Top


TBIBDETester.Test(String,String,String,String,String,String,Boolean) Method

Summary

Represents method Test(String,String,String,String,String,String,Boolean).

Namespace: BI.DB.BDE
Syntax
Delphi
public
 class procedure Test(const Driver,Database,Server,Port,User,Password:String;
 const Prompt:Boolean); override;

Parameters

Driver
Type: String

Database
Type: String

Server
Type: String

Port
Type: String

User
Type: String

Password
Type: String

Prompt
Type: Boolean

Overrides

TBIDBTester.Test(String,String,String,String,String,String,Boolean)
See Also

Reference

  • TBIBDETester
  • BI.DB.BDE


TDBBDEEngine Class

Summary

Represents type TDBBDEEngine.

Namespace: BI.DB.BDE
Inheritance Hierarchy
TObject
BI.DB.TBIDBEngine
BI.DB.BDE.TDBBDEEngine
Syntax
Delphi
type
 TDBBDEEngine=class(TBIDBEngine)
 end;

The TDBBDEEngine type exposes the following members.

Methods
Show:
Name | Description
CloneConnection(TCustomConnection) | Represents method CloneConnection(TCustomConnection). (Overrides TBIDBEngine.CloneConnection(TCustomConnection).)
CreateConnection(TDataDefinition) | Represents method CreateConnection(TDataDefinition). (Overrides TBIDBEngine.CreateConnection(TDataDefinition).)
CreateDataSet(TComponent,TDataItem) | Represents method CreateDataSet(TComponent,TDataItem). (Overrides TBIDBEngine.CreateDataSet(TComponent,TDataItem).)
CreateQuery(TCustomConnection,String) | Represents method CreateQuery(TCustomConnection,String). (Overrides TBIDBEngine.CreateQuery(TCustomConnection,String).)
DriverNames | Represents method DriverNames. (Overrides TBIDBEngine.DriverNames.)
DriverToName(String) | Represents method DriverToName(String). (Overrides TBIDBEngine.DriverToName(String).)
FileFilter | Represents method FileFilter. (Overrides TBIDBEngine.FileFilter.)
GetConnectionName(TCustomConnection) | Represents method GetConnectionName(TCustomConnection). (Overrides TBIDBEngine.GetConnectionName(TCustomConnection).)
GetDriver(Integer) | Represents method GetDriver(Integer). (Overrides TBIDBEngine.GetDriver(Integer).)
GetItemNames(TCustomConnection,Boolean,Boolean) | Represents method GetItemNames(TCustomConnection,Boolean,Boolean). (Overrides TBIDBEngine.GetItemNames(TCustomConnection,Boolean,Boolean).)
GetKeyFieldNames(TCustomConnection,String) | Represents method GetKeyFieldNames(TCustomConnection,String). (Overrides TBIDBEngine.GetKeyFieldNames(TCustomConnection,String).)
GetSchemas(TCustomConnection) | Represents method GetSchemas(TCustomConnection).
GetTable(TCustomConnection,String) | Represents method GetTable(TCustomConnection,String). (Overrides TBIDBEngine.GetTable(TCustomConnection,String).)
GuessForeignKeys(String,TDataSet,TDataItem,TBISource) | Represents method GuessForeignKeys(String,TDataSet,TDataItem,TBISource). (Overrides TBIDBEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource).)
ImportFile(TBIDB,String) | Represents method ImportFile(TBIDB,String). (Overrides TBIDBEngine.ImportFile(TBIDB,String).)
Supports(String) | Represents method Supports(String). (Overrides TBIDBEngine.Supports(String).)
SupportsParallel | Represents method SupportsParallel. (Overrides TBIDBEngine.SupportsParallel.)
Tester | Represents method Tester. (Overrides TBIDBEngine.Tester.)
Top
See Also

Reference

  • BI.DB.BDE


TDBBDEEngine Methods

Methods
Name | Description
CloneConnection(TCustomConnection) | Represents method CloneConnection(TCustomConnection). (Overrides TBIDBEngine.CloneConnection(TCustomConnection).)
CreateConnection(TDataDefinition) | Represents method CreateConnection(TDataDefinition). (Overrides TBIDBEngine.CreateConnection(TDataDefinition).)
CreateDataSet(TComponent,TDataItem) | Represents method CreateDataSet(TComponent,TDataItem). (Overrides TBIDBEngine.CreateDataSet(TComponent,TDataItem).)
CreateQuery(TCustomConnection,String) | Represents method CreateQuery(TCustomConnection,String). (Overrides TBIDBEngine.CreateQuery(TCustomConnection,String).)
DriverNames | Represents method DriverNames. (Overrides TBIDBEngine.DriverNames.)
DriverToName(String) | Represents method DriverToName(String). (Overrides TBIDBEngine.DriverToName(String).)
FileFilter | Represents method FileFilter. (Overrides TBIDBEngine.FileFilter.)
GetConnectionName(TCustomConnection) | Represents method GetConnectionName(TCustomConnection). (Overrides TBIDBEngine.GetConnectionName(TCustomConnection).)
GetDriver(Integer) | Represents method GetDriver(Integer). (Overrides TBIDBEngine.GetDriver(Integer).)
GetItemNames(TCustomConnection,Boolean,Boolean) | Represents method GetItemNames(TCustomConnection,Boolean,Boolean). (Overrides TBIDBEngine.GetItemNames(TCustomConnection,Boolean,Boolean).)
GetKeyFieldNames(TCustomConnection,String) | Represents method GetKeyFieldNames(TCustomConnection,String). (Overrides TBIDBEngine.GetKeyFieldNames(TCustomConnection,String).)
GetSchemas(TCustomConnection) | Represents method GetSchemas(TCustomConnection).
GetTable(TCustomConnection,String) | Represents method GetTable(TCustomConnection,String). (Overrides TBIDBEngine.GetTable(TCustomConnection,String).)
GuessForeignKeys(String,TDataSet,TDataItem,TBISource) | Represents method GuessForeignKeys(String,TDataSet,TDataItem,TBISource). (Overrides TBIDBEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource).)
ImportFile(TBIDB,String) | Represents method ImportFile(TBIDB,String). (Overrides TBIDBEngine.ImportFile(TBIDB,String).)
Supports(String) | Represents method Supports(String). (Overrides TBIDBEngine.Supports(String).)
SupportsParallel | Represents method SupportsParallel. (Overrides TBIDBEngine.SupportsParallel.)
Tester | Represents method Tester. (Overrides TBIDBEngine.Tester.)
Top


TDBBDEEngine.CloneConnection(TCustomConnection) Method

Summary

Represents method CloneConnection(TCustomConnection).

Namespace: BI.DB.BDE
Syntax
Delphi
public
 class function CloneConnection(const AConn:TCustomConnection): TCustomConnection; override;

Parameters

AConn
Type: TCustomConnection

Return Value

Type: TCustomConnection

Overrides

TBIDBEngine.CloneConnection(TCustomConnection)
See Also

Reference

  • TDBBDEEngine
  • BI.DB.BDE


TDBBDEEngine.CreateConnection(TDataDefinition) Method

Summary

Represents method CreateConnection(TDataDefinition).

Namespace: BI.DB.BDE
Syntax
Delphi
public
 class function CreateConnection(const Definition:TDataDefinition):TCustomConnection; override;

Parameters

Definition
Type: TDataDefinition

Return Value

Type: TCustomConnection

Overrides

TBIDBEngine.CreateConnection(TDataDefinition)
See Also

Reference

  • TDBBDEEngine
  • BI.DB.BDE


TDBBDEEngine.CreateDataSet(TComponent,TDataItem) Method

Summary

Represents method CreateDataSet(TComponent,TDataItem).

Namespace: BI.DB.BDE
Syntax
Delphi
public
 class function CreateDataSet(const AOwner:TComponent; const AData:TDataItem):TDataSet; override;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

Return Value

Type: TDataSet

Overrides

TBIDBEngine.CreateDataSet(TComponent,TDataItem)
See Also

Reference

  • TDBBDEEngine
  • BI.DB.BDE


TDBBDEEngine.CreateQuery(TCustomConnection,String) Method

Summary

Represents method CreateQuery(TCustomConnection,String).

Namespace: BI.DB.BDE
Syntax
Delphi
public
 class function CreateQuery(const AConnection:TCustomConnection; const SQL:String):TDataSet; override;

Parameters

AConnection
Type: TCustomConnection

SQL
Type: String

Return Value

Type: TDataSet

Overrides

TBIDBEngine.CreateQuery(TCustomConnection,String)
See Also

Reference

  • TDBBDEEngine
  • BI.DB.BDE


TDBBDEEngine.DriverNames Method

Summary

Represents method DriverNames.

Namespace: BI.DB.BDE
Syntax
Delphi
public
 class function DriverNames:TStringDynArray; override;

Return Value

Type: TStringDynArray

Overrides

TBIDBEngine.DriverNames
See Also

Reference

  • TDBBDEEngine
  • BI.DB.BDE


TDBBDEEngine.DriverToName(String) Method

Summary

Represents method DriverToName(String).

Namespace: BI.DB.BDE
Syntax
Delphi
public
 class function DriverToName(const ADriver:String):String; override;

Parameters

ADriver
Type: String

Return Value

Type: String

Overrides

TBIDBEngine.DriverToName(String)
See Also

Reference

  • TDBBDEEngine
  • BI.DB.BDE


TDBBDEEngine.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.DB.BDE
Syntax
Delphi
public
 class function FileFilter: TFileFilters; override;

Return Value

Type: TFileFilters

Overrides

TBIDBEngine.FileFilter
See Also

Reference

  • TDBBDEEngine
  • BI.DB.BDE


TDBBDEEngine.GetConnectionName(TCustomConnection) Method

Summary

Represents method GetConnectionName(TCustomConnection).

Namespace: BI.DB.BDE
Syntax
Delphi
public
 class function GetConnectionName(const AConnection:TCustomConnection):String; override;

Parameters

AConnection
Type: TCustomConnection

Return Value

Type: String

Overrides

TBIDBEngine.GetConnectionName(TCustomConnection)
See Also

Reference

  • TDBBDEEngine
  • BI.DB.BDE


TDBBDEEngine.GetDriver(Integer) Method

Summary

Represents method GetDriver(Integer).

Namespace: BI.DB.BDE
Syntax
Delphi
public
 class function GetDriver(const AIndex:Integer):String; override;

Parameters

AIndex
Type: Integer

Return Value

Type: String

Overrides

TBIDBEngine.GetDriver(Integer)
See Also

Reference

  • TDBBDEEngine
  • BI.DB.BDE


TDBBDEEngine.GetItemNames(TCustomConnection,Boolean,Boolean) Method

Summary

Represents method GetItemNames(TCustomConnection,Boolean,Boolean).

Namespace: BI.DB.BDE
Syntax
Delphi
public
 class function GetItemNames(const AConnection:TCustomConnection;
 const IncludeSystem,IncludeViews:Boolean):TStrings; override;

Parameters

AConnection
Type: TCustomConnection

IncludeSystem
Type: Boolean

IncludeViews
Type: Boolean

Return Value

Type: TStrings

Overrides

TBIDBEngine.GetItemNames(TCustomConnection,Boolean,Boolean)
See Also

Reference

  • TDBBDEEngine
  • BI.DB.BDE


TDBBDEEngine.GetKeyFieldNames(TCustomConnection,String) Method

Summary

Represents method GetKeyFieldNames(TCustomConnection,String).

Namespace: BI.DB.BDE
Syntax
Delphi
public
 class function GetKeyFieldNames(const AConnection:TCustomConnection; const ATable:String):TStrings; override;

Parameters

AConnection
Type: TCustomConnection

ATable
Type: String

Return Value

Type: TStrings

Overrides

TBIDBEngine.GetKeyFieldNames(TCustomConnection,String)
See Also

Reference

  • TDBBDEEngine
  • BI.DB.BDE


TDBBDEEngine.GetSchemas(TCustomConnection) Method

Summary

Represents method GetSchemas(TCustomConnection).

Namespace: BI.DB.BDE
Syntax
Delphi
public
 class function GetSchemas(const AConnection:TCustomConnection):TStrings;

Parameters

AConnection
Type: TCustomConnection

Return Value

Type: TStrings

See Also

Reference

  • TDBBDEEngine
  • BI.DB.BDE


TDBBDEEngine.GetTable(TCustomConnection,String) Method

Summary

Represents method GetTable(TCustomConnection,String).

Namespace: BI.DB.BDE
Syntax
Delphi
public
 class function GetTable(const AConnection:TCustomConnection; const AName:String):TDataSet; override;

Parameters

AConnection
Type: TCustomConnection

AName
Type: String

Return Value

Type: TDataSet

Overrides

TBIDBEngine.GetTable(TCustomConnection,String)
See Also

Reference

  • TDBBDEEngine
  • BI.DB.BDE


TDBBDEEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource) Method

Summary

Represents method GuessForeignKeys(String,TDataSet,TDataItem,TBISource).

Namespace: BI.DB.BDE
Syntax
Delphi
public
 class procedure GuessForeignKeys(const AName:String; const Table:TDataSet; const AData:TDataItem; const Source:TBISource); override;

Parameters

AName
Type: String

Table
Type: TDataSet

AData
Type: TDataItem

Source
Type: TBISource

Overrides

TBIDBEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource)
See Also

Reference

  • TDBBDEEngine
  • BI.DB.BDE


TDBBDEEngine.ImportFile(TBIDB,String) Method

Summary

Represents method ImportFile(TBIDB,String).

Namespace: BI.DB.BDE
Syntax
Delphi
public
 class function ImportFile(const Source:TBIDB; const AFileName:String):TDataArray; override;

Parameters

Source
Type: TBIDB

AFileName
Type: String

Return Value

Type: TDataArray

Overrides

TBIDBEngine.ImportFile(TBIDB,String)
See Also

Reference

  • TDBBDEEngine
  • BI.DB.BDE


TDBBDEEngine.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.DB.BDE
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIDBEngine.Supports(String)
See Also

Reference

  • TDBBDEEngine
  • BI.DB.BDE


TDBBDEEngine.SupportsParallel Method

Summary

Represents method SupportsParallel.

Namespace: BI.DB.BDE
Syntax
Delphi
public
 class function SupportsParallel:Boolean; override;

Return Value

Type: Boolean

Overrides

TBIDBEngine.SupportsParallel
See Also

Reference

  • TDBBDEEngine
  • BI.DB.BDE


TDBBDEEngine.Tester Method

Summary

Represents method Tester.

Namespace: BI.DB.BDE
Syntax
Delphi
public
 class function Tester:TBIDBTesterClass; override;

Return Value

Type: TBIDBTesterClass

Overrides

TBIDBEngine.Tester
See Also

Reference

  • TDBBDEEngine
  • BI.DB.BDE


BI.DB.BDE Constants

Constants
Name | Description
BDE_Name | Represents constant BDE_Name.
Top


BDE_Name Constant

Summary

Represents constant BDE_Name.

Namespace: BI.DB.BDE
Syntax
Delphi
 BDE_Name='Borland Database Engine';

Value

Type: string

See Also

Reference

  • BI.DB.BDE


BI.DB.BDE Routines

Routines
Name | Description
CreateDatabase(String) | Represents method CreateDatabase(String).
Top


CreateDatabase(String) Method

Summary

Represents method CreateDatabase(String).

Namespace: BI.DB.BDE
Syntax
Delphi
function CreateDatabase(const AName:String):TDatabase;

Parameters

AName
Type: String

Return Value

Type: TDatabase

See Also

Reference

  • BI.DB.BDE


BI.DB.Dataset Namespace

Summary

Represents namespace BI.DB.Dataset.

Classes
Name | Description
TBIDataSetSource | Represents type TBIDataSetSource.
TDataAccess | Represents type TDataAccess.
Top
Routines
Name | Description
FieldNameOfData(TFieldDefs,TDataItem) | Represents method FieldNameOfData(TFieldDefs,TDataItem).
UniqueFieldName(TFieldDefs,String) | Represents method UniqueFieldName(TFieldDefs,String).
Top


BI.DB.Dataset Classes

Classes
Name | Description
TBIDataSetSource | Represents type TBIDataSetSource.
TDataAccess | Represents type TDataAccess.
Top


TBIDataSetSource Class

Summary

Represents type TBIDataSetSource.

Namespace: BI.DB.Dataset
Inheritance Hierarchy
TObject
BI.DataSource.TBISource
BI.DataSource.TBIItemsSource
BI.DataSource.TBIFileSource
BI.DB.Dataset.TBIDataSetSource
BI.ClientDataset.TBIClientDataset
BI.DB.TBIDB
Syntax
Delphi
type
 TBIDataSetSource=class(TBIFileSource)
 end;

The TBIDataSetSource type exposes the following members.

Methods
Show:
Name | Description
Add(TFieldDefs,TDataArray) | Overloaded. Represents method Add(TFieldDefs,TDataArray).
Add(TFieldDefs,TDataItem) | Overloaded. Represents method Add(TFieldDefs,TDataItem).
FieldKind(TFieldType) | Represents method FieldKind(TFieldType).
FieldOf(TDataItem,TDataSet) | Represents method FieldOf(TDataItem,TDataSet).
From(TCustomConnection,String) | Overloaded. Represents method From(TCustomConnection,String).
From(TDataSet,String) | Overloaded. Represents method From(TDataSet,String).
From(TField,String) | Overloaded. Represents method From(TField,String).
From(TField[],String) | Overloaded. Represents method From(TField[],String).
Import(TCustomConnection) | Overloaded. Represents method Import(TCustomConnection).
Import(TDataSet,String) | Overloaded. Represents method Import(TDataSet,String).
Import(TField,String) | Overloaded. Represents method Import(TField,String).
Top
See Also

Reference

  • BI.DB.Dataset


TBIDataSetSource Methods

Methods
Name | Description
Add(TFieldDefs,TDataArray) | Overloaded. Represents method Add(TFieldDefs,TDataArray).
Add(TFieldDefs,TDataItem) | Overloaded. Represents method Add(TFieldDefs,TDataItem).
FieldKind(TFieldType) | Represents method FieldKind(TFieldType).
FieldOf(TDataItem,TDataSet) | Represents method FieldOf(TDataItem,TDataSet).
From(TCustomConnection,String) | Overloaded. Represents method From(TCustomConnection,String).
From(TDataSet,String) | Overloaded. Represents method From(TDataSet,String).
From(TField,String) | Overloaded. Represents method From(TField,String).
From(TField[],String) | Overloaded. Represents method From(TField[],String).
Import(TCustomConnection) | Overloaded. Represents method Import(TCustomConnection).
Import(TDataSet,String) | Overloaded. Represents method Import(TDataSet,String).
Import(TField,String) | Overloaded. Represents method Import(TField,String).
Top


TBIDataSetSource.Add(TFieldDefs,TDataArray) Method

Summary

Represents method Add(TFieldDefs,TDataArray).

Namespace: BI.DB.Dataset
Syntax
Delphi
public
 class procedure Add(const AFields:TFieldDefs; const AItems:TDataArray); overload; static;

Parameters

AFields
Type: TFieldDefs

AItems
Type: TDataArray

See Also

Reference

  • TBIDataSetSource
  • BI.DB.Dataset


TBIDataSetSource.Add(TFieldDefs,TDataItem) Method

Summary

Represents method Add(TFieldDefs,TDataItem).

Namespace: BI.DB.Dataset
Syntax
Delphi
public
 class procedure Add(const AFields:TFieldDefs; const AData:TDataItem); overload; static;

Parameters

AFields
Type: TFieldDefs

AData
Type: TDataItem

See Also

Reference

  • TBIDataSetSource
  • BI.DB.Dataset


TBIDataSetSource.FieldKind(TFieldType) Method

Summary

Represents method FieldKind(TFieldType).

Namespace: BI.DB.Dataset
Syntax
Delphi
public
 class function FieldKind(const AFieldType:TFieldType):TDataKind; static;

Parameters

AFieldType
Type: TFieldType

Return Value

Type: TDataKind

See Also

Reference

  • TBIDataSetSource
  • BI.DB.Dataset


TBIDataSetSource.FieldOf(TDataItem,TDataSet) Method

Summary

Represents method FieldOf(TDataItem,TDataSet).

Namespace: BI.DB.Dataset
Syntax
Delphi
public
 class function FieldOf(const AData:TDataItem; const ADataSet:TDataSet):TField; static;

Parameters

AData
Type: TDataItem

ADataSet
Type: TDataSet

Return Value

Type: TField

See Also

Reference

  • TBIDataSetSource
  • BI.DB.Dataset


TBIDataSetSource.From(TCustomConnection,String) Method

Summary

Represents method From(TCustomConnection,String).

Namespace: BI.DB.Dataset
Syntax
Delphi
public
 class function From(const AConnection:TCustomConnection; const AName:String=''):TDataItem; overload; static;

Parameters

AConnection
Type: TCustomConnection

AName
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TBIDataSetSource
  • BI.DB.Dataset


TBIDataSetSource.From(TDataSet,String) Method

Summary

Represents method From(TDataSet,String).

Namespace: BI.DB.Dataset
Syntax
Delphi
public
 class function From(const ADataSet:TDataSet; const AName:String=''):TDataItem; overload; static;

Parameters

ADataSet
Type: TDataSet

AName
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TBIDataSetSource
  • BI.DB.Dataset


TBIDataSetSource.From(TField,String) Method

Summary

Represents method From(TField,String).

Namespace: BI.DB.Dataset
Syntax
Delphi
public
 class function From(const AField:TField; const AName:String=''):TDataItem; overload; static;

Parameters

AField
Type: TField

AName
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TBIDataSetSource
  • BI.DB.Dataset


TBIDataSetSource.From(TField[],String) Method

Summary

Represents method From(TField[],String).

Namespace: BI.DB.Dataset
Syntax
Delphi
public
 class function From(const AFields:Array of TField; const AName:String=''):TDataItem; overload; static;

Parameters

AFields
Type: Array of TField

AName
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TBIDataSetSource
  • BI.DB.Dataset


TBIDataSetSource.Import(TCustomConnection) Method

Summary

Represents method Import(TCustomConnection).

Namespace: BI.DB.Dataset
Syntax
Delphi
public
 function Import(const AConnection:TCustomConnection):TDataArray; overload;

Parameters

AConnection
Type: TCustomConnection

Return Value

Type: TDataArray

See Also

Reference

  • TBIDataSetSource
  • BI.DB.Dataset


TBIDataSetSource.Import(TDataSet,String) Method

Summary

Represents method Import(TDataSet,String).

Namespace: BI.DB.Dataset
Syntax
Delphi
public
 function Import(const ADataSet:TDataSet; const AName:String=''):TDataItem; overload;

Parameters

ADataSet
Type: TDataSet

AName
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TBIDataSetSource
  • BI.DB.Dataset


TBIDataSetSource.Import(TField,String) Method

Summary

Represents method Import(TField,String).

Namespace: BI.DB.Dataset
Syntax
Delphi
public
 function Import(const AField:TField; const AName:String=''):TDataItem; overload;

Parameters

AField
Type: TField

AName
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TBIDataSetSource
  • BI.DB.Dataset


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.DB.Dataset
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.DB.Dataset.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.DB.Dataset


BI.DB.Dataset Routines

Routines
Name | Description
FieldNameOfData(TFieldDefs,TDataItem) | Represents method FieldNameOfData(TFieldDefs,TDataItem).
UniqueFieldName(TFieldDefs,String) | Represents method UniqueFieldName(TFieldDefs,String).
Top


FieldNameOfData(TFieldDefs,TDataItem) Method

Summary

Represents method FieldNameOfData(TFieldDefs,TDataItem).

Namespace: BI.DB.Dataset
Syntax
Delphi
function FieldNameOfData(const AFields:TFieldDefs; const AData:TDataItem):String;

Parameters

AFields
Type: TFieldDefs

AData
Type: TDataItem

Return Value

Type: String

See Also

Reference

  • BI.DB.Dataset


UniqueFieldName(TFieldDefs,String) Method

Summary

Represents method UniqueFieldName(TFieldDefs,String).

Namespace: BI.DB.Dataset
Syntax
Delphi
function UniqueFieldName(const AFields:TFieldDefs; const AFieldName:String):String;

Parameters

AFields
Type: TFieldDefs

AFieldName
Type: String

Return Value

Type: String

See Also

Reference

  • BI.DB.Dataset


BI.DB.Fire Namespace

Summary

Represents namespace BI.DB.Fire.

Classes
Name | Description
TBISourceAccess | Represents type TBISourceAccess.
TDataAccess | Represents type TDataAccess.
TDBFireDACEngine | Represents type TDBFireDACEngine.
Top
Constants
Name | Description
DBDriverNames | Represents constant DBDriverNames.
DBDrivers | Represents constant DBDrivers.
MSacc | Represents constant MSacc.
Top
Routines
Name | Description
CanGetMetaData(TCustomConnection) | Represents method CanGetMetaData(TCustomConnection).
Top


BI.DB.Fire Classes

Classes
Name | Description
TBISourceAccess | Represents type TBISourceAccess.
TDataAccess | Represents type TDataAccess.
TDBFireDACEngine | Represents type TDBFireDACEngine.
Top


TBISourceAccess Class

Summary

Represents type TBISourceAccess.

Namespace: BI.DB.Fire
Inheritance Hierarchy
TObject
BI.DataSource.TBISource
BI.DB.Fire.TBISourceAccess
Syntax
Delphi
type
 TBISourceAccess=class(TBISource);
See Also

Reference

  • BI.DB.Fire


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.DB.Fire
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.DB.Fire.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.DB.Fire


TDBFireDACEngine Class

Summary

Represents type TDBFireDACEngine.

Namespace: BI.DB.Fire
Inheritance Hierarchy
TObject
BI.DB.TBIDBEngine
BI.DB.Fire.TDBFireDACEngine
Syntax
Delphi
type
 TDBFireDACEngine=class(TBIDBEngine)
 end;

The TDBFireDACEngine type exposes the following members.

Methods
Show:
Name | Description
CloneConnection(TCustomConnection) | Represents method CloneConnection(TCustomConnection). (Overrides TBIDBEngine.CloneConnection(TCustomConnection).)
CreateConnection(TDataDefinition) | Represents method CreateConnection(TDataDefinition). (Overrides TBIDBEngine.CreateConnection(TDataDefinition).)
CreateDataSet(TComponent,TDataItem) | Represents method CreateDataSet(TComponent,TDataItem). (Overrides TBIDBEngine.CreateDataSet(TComponent,TDataItem).)
CreateQuery(TCustomConnection,String) | Represents method CreateQuery(TCustomConnection,String). (Overrides TBIDBEngine.CreateQuery(TCustomConnection,String).)
DriverNames | Represents method DriverNames. (Overrides TBIDBEngine.DriverNames.)
DriverToName(String) | Represents method DriverToName(String). (Overrides TBIDBEngine.DriverToName(String).)
FileFilter | Represents method FileFilter. (Overrides TBIDBEngine.FileFilter.)
GetConnectionName(TCustomConnection) | Represents method GetConnectionName(TCustomConnection). (Overrides TBIDBEngine.GetConnectionName(TCustomConnection).)
GetDriver(Integer) | Represents method GetDriver(Integer). (Overrides TBIDBEngine.GetDriver(Integer).)
GetItemNames(TCustomConnection,Boolean,Boolean) | Represents method GetItemNames(TCustomConnection,Boolean,Boolean). (Overrides TBIDBEngine.GetItemNames(TCustomConnection,Boolean,Boolean).)
GetKeyFieldNames(TCustomConnection,String) | Represents method GetKeyFieldNames(TCustomConnection,String). (Overrides TBIDBEngine.GetKeyFieldNames(TCustomConnection,String).)
GetSchemas(TCustomConnection) | Represents method GetSchemas(TCustomConnection).
GetTable(TCustomConnection,String) | Represents method GetTable(TCustomConnection,String). (Overrides TBIDBEngine.GetTable(TCustomConnection,String).)
GuessForeignKeys(String,TDataSet,TDataItem,TBISource) | Represents method GuessForeignKeys(String,TDataSet,TDataItem,TBISource). (Overrides TBIDBEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource).)
ImportFile(TBIDB,String) | Represents method ImportFile(TBIDB,String). (Overrides TBIDBEngine.ImportFile(TBIDB,String).)
StartParallel | Represents method StartParallel. (Overrides TBIDBEngine.StartParallel.)
Supports(String) | Represents method Supports(String). (Overrides TBIDBEngine.Supports(String).)
Tester | Represents method Tester. (Overrides TBIDBEngine.Tester.)
Top
See Also

Reference

  • BI.DB.Fire


TDBFireDACEngine Methods

Methods
Name | Description
CloneConnection(TCustomConnection) | Represents method CloneConnection(TCustomConnection). (Overrides TBIDBEngine.CloneConnection(TCustomConnection).)
CreateConnection(TDataDefinition) | Represents method CreateConnection(TDataDefinition). (Overrides TBIDBEngine.CreateConnection(TDataDefinition).)
CreateDataSet(TComponent,TDataItem) | Represents method CreateDataSet(TComponent,TDataItem). (Overrides TBIDBEngine.CreateDataSet(TComponent,TDataItem).)
CreateQuery(TCustomConnection,String) | Represents method CreateQuery(TCustomConnection,String). (Overrides TBIDBEngine.CreateQuery(TCustomConnection,String).)
DriverNames | Represents method DriverNames. (Overrides TBIDBEngine.DriverNames.)
DriverToName(String) | Represents method DriverToName(String). (Overrides TBIDBEngine.DriverToName(String).)
FileFilter | Represents method FileFilter. (Overrides TBIDBEngine.FileFilter.)
GetConnectionName(TCustomConnection) | Represents method GetConnectionName(TCustomConnection). (Overrides TBIDBEngine.GetConnectionName(TCustomConnection).)
GetDriver(Integer) | Represents method GetDriver(Integer). (Overrides TBIDBEngine.GetDriver(Integer).)
GetItemNames(TCustomConnection,Boolean,Boolean) | Represents method GetItemNames(TCustomConnection,Boolean,Boolean). (Overrides TBIDBEngine.GetItemNames(TCustomConnection,Boolean,Boolean).)
GetKeyFieldNames(TCustomConnection,String) | Represents method GetKeyFieldNames(TCustomConnection,String). (Overrides TBIDBEngine.GetKeyFieldNames(TCustomConnection,String).)
GetSchemas(TCustomConnection) | Represents method GetSchemas(TCustomConnection).
GetTable(TCustomConnection,String) | Represents method GetTable(TCustomConnection,String). (Overrides TBIDBEngine.GetTable(TCustomConnection,String).)
GuessForeignKeys(String,TDataSet,TDataItem,TBISource) | Represents method GuessForeignKeys(String,TDataSet,TDataItem,TBISource). (Overrides TBIDBEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource).)
ImportFile(TBIDB,String) | Represents method ImportFile(TBIDB,String). (Overrides TBIDBEngine.ImportFile(TBIDB,String).)
StartParallel | Represents method StartParallel. (Overrides TBIDBEngine.StartParallel.)
Supports(String) | Represents method Supports(String). (Overrides TBIDBEngine.Supports(String).)
Tester | Represents method Tester. (Overrides TBIDBEngine.Tester.)
Top


TDBFireDACEngine.CloneConnection(TCustomConnection) Method

Summary

Represents method CloneConnection(TCustomConnection).

Namespace: BI.DB.Fire
Syntax
Delphi
public
 class function CloneConnection(const AConn:TCustomConnection): TCustomConnection; override;

Parameters

AConn
Type: TCustomConnection

Return Value

Type: TCustomConnection

Overrides

TBIDBEngine.CloneConnection(TCustomConnection)
See Also

Reference

  • TDBFireDACEngine
  • BI.DB.Fire


TDBFireDACEngine.CreateConnection(TDataDefinition) Method

Summary

Represents method CreateConnection(TDataDefinition).

Namespace: BI.DB.Fire
Syntax
Delphi
public
 class function CreateConnection(const Definition:TDataDefinition):TCustomConnection; override;

Parameters

Definition
Type: TDataDefinition

Return Value

Type: TCustomConnection

Overrides

TBIDBEngine.CreateConnection(TDataDefinition)
See Also

Reference

  • TDBFireDACEngine
  • BI.DB.Fire


TDBFireDACEngine.CreateDataSet(TComponent,TDataItem) Method

Summary

Represents method CreateDataSet(TComponent,TDataItem).

Namespace: BI.DB.Fire
Syntax
Delphi
public
 class function CreateDataSet(const AOwner:TComponent; const AData:TDataItem):TDataSet; override;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

Return Value

Type: TDataSet

Overrides

TBIDBEngine.CreateDataSet(TComponent,TDataItem)
See Also

Reference

  • TDBFireDACEngine
  • BI.DB.Fire


TDBFireDACEngine.CreateQuery(TCustomConnection,String) Method

Summary

Represents method CreateQuery(TCustomConnection,String).

Namespace: BI.DB.Fire
Syntax
Delphi
public
 class function CreateQuery(const AConnection:TCustomConnection; const SQL:String):TDataSet; override;

Parameters

AConnection
Type: TCustomConnection

SQL
Type: String

Return Value

Type: TDataSet

Overrides

TBIDBEngine.CreateQuery(TCustomConnection,String)
See Also

Reference

  • TDBFireDACEngine
  • BI.DB.Fire


TDBFireDACEngine.DriverNames Method

Summary

Represents method DriverNames.

Namespace: BI.DB.Fire
Syntax
Delphi
public
 class function DriverNames:TStringDynArray; override;

Return Value

Type: TStringDynArray

Overrides

TBIDBEngine.DriverNames
See Also

Reference

  • TDBFireDACEngine
  • BI.DB.Fire


TDBFireDACEngine.DriverToName(String) Method

Summary

Represents method DriverToName(String).

Namespace: BI.DB.Fire
Syntax
Delphi
public
 class function DriverToName(const ADriver:String):String; override;

Parameters

ADriver
Type: String

Return Value

Type: String

Overrides

TBIDBEngine.DriverToName(String)
See Also

Reference

  • TDBFireDACEngine
  • BI.DB.Fire


TDBFireDACEngine.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.DB.Fire
Syntax
Delphi
public
 class function FileFilter: TFileFilters; override;

Return Value

Type: TFileFilters

Overrides

TBIDBEngine.FileFilter
See Also

Reference

  • TDBFireDACEngine
  • BI.DB.Fire


TDBFireDACEngine.GetConnectionName(TCustomConnection) Method

Summary

Represents method GetConnectionName(TCustomConnection).

Namespace: BI.DB.Fire
Syntax
Delphi
public
 class function GetConnectionName(const AConnection:TCustomConnection):String; override;

Parameters

AConnection
Type: TCustomConnection

Return Value

Type: String

Overrides

TBIDBEngine.GetConnectionName(TCustomConnection)
See Also

Reference

  • TDBFireDACEngine
  • BI.DB.Fire


TDBFireDACEngine.GetDriver(Integer) Method

Summary

Represents method GetDriver(Integer).

Namespace: BI.DB.Fire
Syntax
Delphi
public
 class function GetDriver(const AIndex:Integer):String; override;

Parameters

AIndex
Type: Integer

Return Value

Type: String

Overrides

TBIDBEngine.GetDriver(Integer)
See Also

Reference

  • TDBFireDACEngine
  • BI.DB.Fire


TDBFireDACEngine.GetItemNames(TCustomConnection,Boolean,Boolean) Method

Summary

Represents method GetItemNames(TCustomConnection,Boolean,Boolean).

Namespace: BI.DB.Fire
Syntax
Delphi
public
 class function GetItemNames(const AConnection:TCustomConnection;
 const IncludeSystem,IncludeViews:Boolean):TStrings; override;

Parameters

AConnection
Type: TCustomConnection

IncludeSystem
Type: Boolean

IncludeViews
Type: Boolean

Return Value

Type: TStrings

Overrides

TBIDBEngine.GetItemNames(TCustomConnection,Boolean,Boolean)
See Also

Reference

  • TDBFireDACEngine
  • BI.DB.Fire


TDBFireDACEngine.GetKeyFieldNames(TCustomConnection,String) Method

Summary

Represents method GetKeyFieldNames(TCustomConnection,String).

Namespace: BI.DB.Fire
Syntax
Delphi
public
 class function GetKeyFieldNames(const AConnection:TCustomConnection; const ATable:String):TStrings; override;

Parameters

AConnection
Type: TCustomConnection

ATable
Type: String

Return Value

Type: TStrings

Overrides

TBIDBEngine.GetKeyFieldNames(TCustomConnection,String)
See Also

Reference

  • TDBFireDACEngine
  • BI.DB.Fire


TDBFireDACEngine.GetSchemas(TCustomConnection) Method

Summary

Represents method GetSchemas(TCustomConnection).

Namespace: BI.DB.Fire
Syntax
Delphi
public
 class function GetSchemas(const AConnection:TCustomConnection):TStrings;

Parameters

AConnection
Type: TCustomConnection

Return Value

Type: TStrings

See Also

Reference

  • TDBFireDACEngine
  • BI.DB.Fire


TDBFireDACEngine.GetTable(TCustomConnection,String) Method

Summary

Represents method GetTable(TCustomConnection,String).

Namespace: BI.DB.Fire
Syntax
Delphi
public
 class function GetTable(const AConnection:TCustomConnection; const AName:String):TDataSet; override;

Parameters

AConnection
Type: TCustomConnection

AName
Type: String

Return Value

Type: TDataSet

Overrides

TBIDBEngine.GetTable(TCustomConnection,String)
See Also

Reference

  • TDBFireDACEngine
  • BI.DB.Fire


TDBFireDACEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource) Method

Summary

Represents method GuessForeignKeys(String,TDataSet,TDataItem,TBISource).

Namespace: BI.DB.Fire
Syntax
Delphi
public
 class procedure GuessForeignKeys(const AName:String; const Table:TDataSet; const AData:TDataItem; const Source:TBISource); override;

Parameters

AName
Type: String

Table
Type: TDataSet

AData
Type: TDataItem

Source
Type: TBISource

Overrides

TBIDBEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource)
See Also

Reference

  • TDBFireDACEngine
  • BI.DB.Fire


TDBFireDACEngine.ImportFile(TBIDB,String) Method

Summary

Represents method ImportFile(TBIDB,String).

Namespace: BI.DB.Fire
Syntax
Delphi
public
 class function ImportFile(const Source:TBIDB; const AFileName:String):TDataArray; override;

Parameters

Source
Type: TBIDB

AFileName
Type: String

Return Value

Type: TDataArray

Overrides

TBIDBEngine.ImportFile(TBIDB,String)
See Also

Reference

  • TDBFireDACEngine
  • BI.DB.Fire


TDBFireDACEngine.StartParallel Method

Summary

Represents method StartParallel.

Namespace: BI.DB.Fire
Syntax
Delphi
public
 class procedure StartParallel; override;

Overrides

TBIDBEngine.StartParallel
See Also

Reference

  • TDBFireDACEngine
  • BI.DB.Fire


TDBFireDACEngine.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.DB.Fire
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIDBEngine.Supports(String)
See Also

Reference

  • TDBFireDACEngine
  • BI.DB.Fire


TDBFireDACEngine.Tester Method

Summary

Represents method Tester.

Namespace: BI.DB.Fire
Syntax
Delphi
public
 class function Tester:TBIDBTesterClass; override;

Return Value

Type: TBIDBTesterClass

Overrides

TBIDBEngine.Tester
See Also

Reference

  • TDBFireDACEngine
  • BI.DB.Fire


BI.DB.Fire Constants

Constants
Name | Description
DBDriverNames | Represents constant DBDriverNames.
DBDrivers | Represents constant DBDrivers.
MSacc | Represents constant MSacc.
Top


DBDriverNames Constant

Summary

Represents constant DBDriverNames.

Namespace: BI.DB.Fire
Syntax
Delphi
 DBDriverNames:Array of String=['SQLite','MySQL','Oracle','Microsoft SQL Server',
 'ODBC','Microsoft Access','Embarcadero Interbase','MariaDB','dBase'
 ,'MongoDB'];

Value

Type: Array of String

See Also

Reference

  • BI.DB.Fire


DBDrivers Constant

Summary

Represents constant DBDrivers.

Namespace: BI.DB.Fire
Syntax
Delphi
 DBDrivers:Array of String=['SQLite','MySQL','Ora','MSSQL','ODBC',MSAcc,'IB','MySQL','ADS'
 ,'Mongo'];

Value

Type: Array of String

See Also

Reference

  • BI.DB.Fire


MSacc Constant

Summary

Represents constant MSacc.

Namespace: BI.DB.Fire
Syntax
Delphi
 MSacc='MSAcc';

Value

Type: string

See Also

Reference

  • BI.DB.Fire


BI.DB.Fire Routines

Routines
Name | Description
CanGetMetaData(TCustomConnection) | Represents method CanGetMetaData(TCustomConnection).
Top


CanGetMetaData(TCustomConnection) Method

Summary

Represents method CanGetMetaData(TCustomConnection).

Namespace: BI.DB.Fire
Syntax
Delphi
function CanGetMetaData(const Connection:TCustomConnection):Boolean;

Parameters

Connection
Type: TCustomConnection

Return Value

Type: Boolean

See Also

Reference

  • BI.DB.Fire


BI.DB.Fire.AllDrivers Namespace

Summary

Represents namespace BI.DB.Fire.AllDrivers.

Classes
Name | Description
TBIDBFireDACTester | Represents type TBIDBFireDACTester.
Top
Records
Name | Description
TBILocalSQL | Represents type TBILocalSQL.
Top


BI.DB.Fire.AllDrivers Classes

Classes
Name | Description
TBIDBFireDACTester | Represents type TBIDBFireDACTester.
Top


TBIDBFireDACTester Class

Summary

Represents type TBIDBFireDACTester.

Namespace: BI.DB.Fire.AllDrivers
Inheritance Hierarchy
TObject
BI.DB.TBIDBTester
BI.DB.Fire.AllDrivers.TBIDBFireDACTester
Syntax
Delphi
type
 TBIDBFireDACTester=class(TBIDBTester)
 end;

The TBIDBFireDACTester type exposes the following members.

Methods
Show:
Name | Description
Test(String,String,String,String,String,String,Boolean) | Represents method Test(String,String,String,String,String,String,Boolean). (Overrides TBIDBTester.Test(String,String,String,String,String,String,Boolean).)
Top
See Also

Reference

  • BI.DB.Fire.AllDrivers


TBIDBFireDACTester Methods

Methods
Name | Description
Test(String,String,String,String,String,String,Boolean) | Represents method Test(String,String,String,String,String,String,Boolean). (Overrides TBIDBTester.Test(String,String,String,String,String,String,Boolean).)
Top


TBIDBFireDACTester.Test(String,String,String,String,String,String,Boolean) Method

Summary

Represents method Test(String,String,String,String,String,String,Boolean).

Namespace: BI.DB.Fire.AllDrivers
Syntax
Delphi
public
 class procedure Test(const Driver,Database,Server,Port,User,Password:String;
 const Prompt:Boolean); override;

Parameters

Driver
Type: String

Database
Type: String

Server
Type: String

Port
Type: String

User
Type: String

Password
Type: String

Prompt
Type: Boolean

Overrides

TBIDBTester.Test(String,String,String,String,String,String,Boolean)
See Also

Reference

  • TBIDBFireDACTester
  • BI.DB.Fire.AllDrivers


BI.DB.Fire.AllDrivers Records

Records
Name | Description
TBILocalSQL | Represents type TBILocalSQL.
Top


TBILocalSQL Record

Summary

Represents type TBILocalSQL.

Namespace: BI.DB.Fire.AllDrivers
Syntax
Delphi
type
 TBILocalSQL=record
 end;

The TBILocalSQL type exposes the following members.

Methods
Show:
Name | Description
Add(TComponent,TDataItem,TFDLocalSQL) | Represents method Add(TComponent,TDataItem,TFDLocalSQL).
From(TComponent,TDataItem) | Overloaded. Represents method From(TComponent,TDataItem).
From(TFDLocalSQL) | Overloaded. Represents method From(TFDLocalSQL).
Top
See Also

Reference

  • BI.DB.Fire.AllDrivers


TBILocalSQL Methods

Methods
Name | Description
Add(TComponent,TDataItem,TFDLocalSQL) | Represents method Add(TComponent,TDataItem,TFDLocalSQL).
From(TComponent,TDataItem) | Overloaded. Represents method From(TComponent,TDataItem).
From(TFDLocalSQL) | Overloaded. Represents method From(TFDLocalSQL).
Top


TBILocalSQL.Add(TComponent,TDataItem,TFDLocalSQL) Method

Summary

Represents method Add(TComponent,TDataItem,TFDLocalSQL).

Namespace: BI.DB.Fire.AllDrivers
Syntax
Delphi
public
 class procedure Add(const AOwner:TComponent; const AData:TDataItem; const ALocal:TFDLocalSQL); static;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

ALocal
Type: TFDLocalSQL

See Also

Reference

  • TBILocalSQL
  • BI.DB.Fire.AllDrivers


TBILocalSQL.From(TComponent,TDataItem) Method

Summary

Represents method From(TComponent,TDataItem).

Namespace: BI.DB.Fire.AllDrivers
Syntax
Delphi
public
 class function From(const AOwner:TComponent; const AData:TDataItem):TFDLocalSQL; overload; static;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

Return Value

Type: TFDLocalSQL

See Also

Reference

  • TBILocalSQL
  • BI.DB.Fire.AllDrivers


TBILocalSQL.From(TFDLocalSQL) Method

Summary

Represents method From(TFDLocalSQL).

Namespace: BI.DB.Fire.AllDrivers
Syntax
Delphi
public
 class function From(const ALocal:TFDLocalSQL):TDataItem; overload; static;

Parameters

ALocal
Type: TFDLocalSQL

Return Value

Type: TDataItem

See Also

Reference

  • TBILocalSQL
  • BI.DB.Fire.AllDrivers


BI.DB.microOLAP Namespace

Summary

Represents namespace BI.DB.microOLAP.

Classes
Name | Description
TBISourceAccess | Represents type TBISourceAccess.
TDataAccess | Represents type TDataAccess.
TDBmicroOLAPEngine | Represents type TDBmicroOLAPEngine.
Top
Routines
Name | Description
CanGetMetaData(TCustomConnection) | Represents method CanGetMetaData(TCustomConnection).
Top


BI.DB.microOLAP Classes

Classes
Name | Description
TBISourceAccess | Represents type TBISourceAccess.
TDataAccess | Represents type TDataAccess.
TDBmicroOLAPEngine | Represents type TDBmicroOLAPEngine.
Top


TBISourceAccess Class

Summary

Represents type TBISourceAccess.

Namespace: BI.DB.microOLAP
Inheritance Hierarchy
TObject
BI.DataSource.TBISource
BI.DB.microOLAP.TBISourceAccess
Syntax
Delphi
type
 TBISourceAccess=class(TBISource);
See Also

Reference

  • BI.DB.microOLAP


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.DB.microOLAP
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.DB.microOLAP.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.DB.microOLAP


TDBmicroOLAPEngine Class

Summary

Represents type TDBmicroOLAPEngine.

Namespace: BI.DB.microOLAP
Inheritance Hierarchy
TObject
BI.DB.TBIDBEngine
BI.DB.microOLAP.TDBmicroOLAPEngine
Syntax
Delphi
type
 TDBmicroOLAPEngine=class(TBIDBEngine)
 end;

The TDBmicroOLAPEngine type exposes the following members.

Methods
Show:
Name | Description
CloneConnection(TCustomConnection) | Represents method CloneConnection(TCustomConnection). (Overrides TBIDBEngine.CloneConnection(TCustomConnection).)
CreateConnection(TDataDefinition) | Represents method CreateConnection(TDataDefinition). (Overrides TBIDBEngine.CreateConnection(TDataDefinition).)
CreateDataSet(TComponent,TDataItem) | Represents method CreateDataSet(TComponent,TDataItem). (Overrides TBIDBEngine.CreateDataSet(TComponent,TDataItem).)
CreateQuery(TCustomConnection,String) | Represents method CreateQuery(TCustomConnection,String). (Overrides TBIDBEngine.CreateQuery(TCustomConnection,String).)
DriverNames | Represents method DriverNames. (Overrides TBIDBEngine.DriverNames.)
DriverToName(String) | Represents method DriverToName(String). (Overrides TBIDBEngine.DriverToName(String).)
GetConnectionName(TCustomConnection) | Represents method GetConnectionName(TCustomConnection). (Overrides TBIDBEngine.GetConnectionName(TCustomConnection).)
GetDriver(Integer) | Represents method GetDriver(Integer). (Overrides TBIDBEngine.GetDriver(Integer).)
GetKeyFieldNames(TCustomConnection,String) | Represents method GetKeyFieldNames(TCustomConnection,String). (Overrides TBIDBEngine.GetKeyFieldNames(TCustomConnection,String).)
GetSchemas(TCustomConnection) | Represents method GetSchemas(TCustomConnection).
GetTable(TCustomConnection,String) | Represents method GetTable(TCustomConnection,String). (Overrides TBIDBEngine.GetTable(TCustomConnection,String).)
GetTableNames(TCustomConnection) | Represents method GetTableNames(TCustomConnection).
GuessForeignKeys(String,TDataSet,TDataItem,TBISource) | Represents method GuessForeignKeys(String,TDataSet,TDataItem,TBISource). (Overrides TBIDBEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource).)
ImportFile(TBIDB,String) | Represents method ImportFile(TBIDB,String). (Overrides TBIDBEngine.ImportFile(TBIDB,String).)
Supports(String) | Represents method Supports(String). (Overrides TBIDBEngine.Supports(String).)
Tester | Represents method Tester. (Overrides TBIDBEngine.Tester.)
Top
See Also

Reference

  • BI.DB.microOLAP


TDBmicroOLAPEngine Methods

Methods
Name | Description
CloneConnection(TCustomConnection) | Represents method CloneConnection(TCustomConnection). (Overrides TBIDBEngine.CloneConnection(TCustomConnection).)
CreateConnection(TDataDefinition) | Represents method CreateConnection(TDataDefinition). (Overrides TBIDBEngine.CreateConnection(TDataDefinition).)
CreateDataSet(TComponent,TDataItem) | Represents method CreateDataSet(TComponent,TDataItem). (Overrides TBIDBEngine.CreateDataSet(TComponent,TDataItem).)
CreateQuery(TCustomConnection,String) | Represents method CreateQuery(TCustomConnection,String). (Overrides TBIDBEngine.CreateQuery(TCustomConnection,String).)
DriverNames | Represents method DriverNames. (Overrides TBIDBEngine.DriverNames.)
DriverToName(String) | Represents method DriverToName(String). (Overrides TBIDBEngine.DriverToName(String).)
GetConnectionName(TCustomConnection) | Represents method GetConnectionName(TCustomConnection). (Overrides TBIDBEngine.GetConnectionName(TCustomConnection).)
GetDriver(Integer) | Represents method GetDriver(Integer). (Overrides TBIDBEngine.GetDriver(Integer).)
GetKeyFieldNames(TCustomConnection,String) | Represents method GetKeyFieldNames(TCustomConnection,String). (Overrides TBIDBEngine.GetKeyFieldNames(TCustomConnection,String).)
GetSchemas(TCustomConnection) | Represents method GetSchemas(TCustomConnection).
GetTable(TCustomConnection,String) | Represents method GetTable(TCustomConnection,String). (Overrides TBIDBEngine.GetTable(TCustomConnection,String).)
GetTableNames(TCustomConnection) | Represents method GetTableNames(TCustomConnection).
GuessForeignKeys(String,TDataSet,TDataItem,TBISource) | Represents method GuessForeignKeys(String,TDataSet,TDataItem,TBISource). (Overrides TBIDBEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource).)
ImportFile(TBIDB,String) | Represents method ImportFile(TBIDB,String). (Overrides TBIDBEngine.ImportFile(TBIDB,String).)
Supports(String) | Represents method Supports(String). (Overrides TBIDBEngine.Supports(String).)
Tester | Represents method Tester. (Overrides TBIDBEngine.Tester.)
Top


TDBmicroOLAPEngine.CloneConnection(TCustomConnection) Method

Summary

Represents method CloneConnection(TCustomConnection).

Namespace: BI.DB.microOLAP
Syntax
Delphi
public
 class function CloneConnection(const AConn:TCustomConnection): TCustomConnection; override;

Parameters

AConn
Type: TCustomConnection

Return Value

Type: TCustomConnection

Overrides

TBIDBEngine.CloneConnection(TCustomConnection)
See Also

Reference

  • TDBmicroOLAPEngine
  • BI.DB.microOLAP


TDBmicroOLAPEngine.CreateConnection(TDataDefinition) Method

Summary

Represents method CreateConnection(TDataDefinition).

Namespace: BI.DB.microOLAP
Syntax
Delphi
public
 class function CreateConnection(const Definition:TDataDefinition):TCustomConnection; override;

Parameters

Definition
Type: TDataDefinition

Return Value

Type: TCustomConnection

Overrides

TBIDBEngine.CreateConnection(TDataDefinition)
See Also

Reference

  • TDBmicroOLAPEngine
  • BI.DB.microOLAP


TDBmicroOLAPEngine.CreateDataSet(TComponent,TDataItem) Method

Summary

Represents method CreateDataSet(TComponent,TDataItem).

Namespace: BI.DB.microOLAP
Syntax
Delphi
public
 class function CreateDataSet(const AOwner:TComponent; const AData:TDataItem):TDataSet; override;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

Return Value

Type: TDataSet

Overrides

TBIDBEngine.CreateDataSet(TComponent,TDataItem)
See Also

Reference

  • TDBmicroOLAPEngine
  • BI.DB.microOLAP


TDBmicroOLAPEngine.CreateQuery(TCustomConnection,String) Method

Summary

Represents method CreateQuery(TCustomConnection,String).

Namespace: BI.DB.microOLAP
Syntax
Delphi
public
 class function CreateQuery(const AConnection:TCustomConnection; const SQL:String):TDataSet; override;

Parameters

AConnection
Type: TCustomConnection

SQL
Type: String

Return Value

Type: TDataSet

Overrides

TBIDBEngine.CreateQuery(TCustomConnection,String)
See Also

Reference

  • TDBmicroOLAPEngine
  • BI.DB.microOLAP


TDBmicroOLAPEngine.DriverNames Method

Summary

Represents method DriverNames.

Namespace: BI.DB.microOLAP
Syntax
Delphi
public
 class function DriverNames:TStringDynArray; override;

Return Value

Type: TStringDynArray

Overrides

TBIDBEngine.DriverNames
See Also

Reference

  • TDBmicroOLAPEngine
  • BI.DB.microOLAP


TDBmicroOLAPEngine.DriverToName(String) Method

Summary

Represents method DriverToName(String).

Namespace: BI.DB.microOLAP
Syntax
Delphi
public
 class function DriverToName(const ADriver:String):String; override;

Parameters

ADriver
Type: String

Return Value

Type: String

Overrides

TBIDBEngine.DriverToName(String)
See Also

Reference

  • TDBmicroOLAPEngine
  • BI.DB.microOLAP


TDBmicroOLAPEngine.GetConnectionName(TCustomConnection) Method

Summary

Represents method GetConnectionName(TCustomConnection).

Namespace: BI.DB.microOLAP
Syntax
Delphi
public
 class function GetConnectionName(const AConnection:TCustomConnection):String; override;

Parameters

AConnection
Type: TCustomConnection

Return Value

Type: String

Overrides

TBIDBEngine.GetConnectionName(TCustomConnection)
See Also

Reference

  • TDBmicroOLAPEngine
  • BI.DB.microOLAP


TDBmicroOLAPEngine.GetDriver(Integer) Method

Summary

Represents method GetDriver(Integer).

Namespace: BI.DB.microOLAP
Syntax
Delphi
public
 class function GetDriver(const AIndex:Integer):String; override;

Parameters

AIndex
Type: Integer

Return Value

Type: String

Overrides

TBIDBEngine.GetDriver(Integer)
See Also

Reference

  • TDBmicroOLAPEngine
  • BI.DB.microOLAP


TDBmicroOLAPEngine.GetKeyFieldNames(TCustomConnection,String) Method

Summary

Represents method GetKeyFieldNames(TCustomConnection,String).

Namespace: BI.DB.microOLAP
Syntax
Delphi
public
 class function GetKeyFieldNames(const AConnection:TCustomConnection; const ATable:String):TStrings; override;

Parameters

AConnection
Type: TCustomConnection

ATable
Type: String

Return Value

Type: TStrings

Overrides

TBIDBEngine.GetKeyFieldNames(TCustomConnection,String)
See Also

Reference

  • TDBmicroOLAPEngine
  • BI.DB.microOLAP


TDBmicroOLAPEngine.GetSchemas(TCustomConnection) Method

Summary

Represents method GetSchemas(TCustomConnection).

Namespace: BI.DB.microOLAP
Syntax
Delphi
public
 class function GetSchemas(const AConnection:TCustomConnection):TStrings;

Parameters

AConnection
Type: TCustomConnection

Return Value

Type: TStrings

See Also

Reference

  • TDBmicroOLAPEngine
  • BI.DB.microOLAP


TDBmicroOLAPEngine.GetTable(TCustomConnection,String) Method

Summary

Represents method GetTable(TCustomConnection,String).

Namespace: BI.DB.microOLAP
Syntax
Delphi
public
 class function GetTable(const AConnection:TCustomConnection; const AName:String):TDataSet; override;

Parameters

AConnection
Type: TCustomConnection

AName
Type: String

Return Value

Type: TDataSet

Overrides

TBIDBEngine.GetTable(TCustomConnection,String)
See Also

Reference

  • TDBmicroOLAPEngine
  • BI.DB.microOLAP


TDBmicroOLAPEngine.GetTableNames(TCustomConnection) Method

Summary

Represents method GetTableNames(TCustomConnection).

Namespace: BI.DB.microOLAP
Syntax
Delphi
public
 class function GetTableNames(const AConnection:TCustomConnection):TStrings; override;

Parameters

AConnection
Type: TCustomConnection

Return Value

Type: TStrings

See Also

Reference

  • TDBmicroOLAPEngine
  • BI.DB.microOLAP


TDBmicroOLAPEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource) Method

Summary

Represents method GuessForeignKeys(String,TDataSet,TDataItem,TBISource).

Namespace: BI.DB.microOLAP
Syntax
Delphi
public
 class procedure GuessForeignKeys(const AName:String; const Table:TDataSet; const AData:TDataItem; const Source:TBISource); override;

Parameters

AName
Type: String

Table
Type: TDataSet

AData
Type: TDataItem

Source
Type: TBISource

Overrides

TBIDBEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource)
See Also

Reference

  • TDBmicroOLAPEngine
  • BI.DB.microOLAP


TDBmicroOLAPEngine.ImportFile(TBIDB,String) Method

Summary

Represents method ImportFile(TBIDB,String).

Namespace: BI.DB.microOLAP
Syntax
Delphi
public
 class function ImportFile(const Source:TBIDB; const AFileName:String):TDataArray; override;

Parameters

Source
Type: TBIDB

AFileName
Type: String

Return Value

Type: TDataArray

Overrides

TBIDBEngine.ImportFile(TBIDB,String)
See Also

Reference

  • TDBmicroOLAPEngine
  • BI.DB.microOLAP


TDBmicroOLAPEngine.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.DB.microOLAP
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIDBEngine.Supports(String)
See Also

Reference

  • TDBmicroOLAPEngine
  • BI.DB.microOLAP


TDBmicroOLAPEngine.Tester Method

Summary

Represents method Tester.

Namespace: BI.DB.microOLAP
Syntax
Delphi
public
 class function Tester:TBIDBTesterClass; override;

Return Value

Type: TBIDBTesterClass

Overrides

TBIDBEngine.Tester
See Also

Reference

  • TDBmicroOLAPEngine
  • BI.DB.microOLAP


BI.DB.microOLAP Routines

Routines
Name | Description
CanGetMetaData(TCustomConnection) | Represents method CanGetMetaData(TCustomConnection).
Top


CanGetMetaData(TCustomConnection) Method

Summary

Represents method CanGetMetaData(TCustomConnection).

Namespace: BI.DB.microOLAP
Syntax
Delphi
function CanGetMetaData(const Connection:TCustomConnection):Boolean;

Parameters

Connection
Type: TCustomConnection

Return Value

Type: Boolean

See Also

Reference

  • BI.DB.microOLAP


BI.DB.SqlExpr Namespace

Summary

Represents namespace BI.DB.SqlExpr.

Classes
Name | Description
TDBSqlExprEngine | Represents type TDBSqlExprEngine.
TDBSqlExprTester | Represents type TDBSqlExprTester.
Top


BI.DB.SqlExpr Classes

Classes
Name | Description
TDBSqlExprEngine | Represents type TDBSqlExprEngine.
TDBSqlExprTester | Represents type TDBSqlExprTester.
Top


TDBSqlExprEngine Class

Summary

Represents type TDBSqlExprEngine.

Namespace: BI.DB.SqlExpr
Inheritance Hierarchy
TObject
BI.DB.TBIDBEngine
BI.DB.SqlExpr.TDBSqlExprEngine
Syntax
Delphi
type
 TDBSqlExprEngine=class(TBIDBEngine)
 end;

The TDBSqlExprEngine type exposes the following members.

Constants
Show:
Name | Description
DBDriverNames | Represents constant DBDriverNames.
DBDrivers | Represents constant DBDrivers.
Top
Methods
Show:
Name | Description
CloneConnection(TCustomConnection) | Represents method CloneConnection(TCustomConnection). (Overrides TBIDBEngine.CloneConnection(TCustomConnection).)
CreateConnection(TDataDefinition) | Represents method CreateConnection(TDataDefinition). (Overrides TBIDBEngine.CreateConnection(TDataDefinition).)
CreateDataSet(TComponent,TDataItem) | Represents method CreateDataSet(TComponent,TDataItem). (Overrides TBIDBEngine.CreateDataSet(TComponent,TDataItem).)
CreateQuery(TCustomConnection,String) | Represents method CreateQuery(TCustomConnection,String). (Overrides TBIDBEngine.CreateQuery(TCustomConnection,String).)
DriverNames | Represents method DriverNames. (Overrides TBIDBEngine.DriverNames.)
DriverToName(String) | Represents method DriverToName(String). (Overrides TBIDBEngine.DriverToName(String).)
FileFilter | Represents method FileFilter. (Overrides TBIDBEngine.FileFilter.)
GetConnectionName(TCustomConnection) | Represents method GetConnectionName(TCustomConnection). (Overrides TBIDBEngine.GetConnectionName(TCustomConnection).)
GetDriver(Integer) | Represents method GetDriver(Integer). (Overrides TBIDBEngine.GetDriver(Integer).)
GetItemNames(TCustomConnection,Boolean,Boolean) | Represents method GetItemNames(TCustomConnection,Boolean,Boolean). (Overrides TBIDBEngine.GetItemNames(TCustomConnection,Boolean,Boolean).)
GetKeyFieldNames(TCustomConnection,String) | Represents method GetKeyFieldNames(TCustomConnection,String). (Overrides TBIDBEngine.GetKeyFieldNames(TCustomConnection,String).)
GetSchemas(TCustomConnection) | Represents method GetSchemas(TCustomConnection).
GetTable(TCustomConnection,String) | Represents method GetTable(TCustomConnection,String). (Overrides TBIDBEngine.GetTable(TCustomConnection,String).)
GuessForeignKeys(String,TDataSet,TDataItem,TBISource) | Represents method GuessForeignKeys(String,TDataSet,TDataItem,TBISource). (Overrides TBIDBEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource).)
ImportFile(TBIDB,String) | Represents method ImportFile(TBIDB,String). (Overrides TBIDBEngine.ImportFile(TBIDB,String).)
Supports(String) | Represents method Supports(String). (Overrides TBIDBEngine.Supports(String).)
Tester | Represents method Tester. (Overrides TBIDBEngine.Tester.)
Top
See Also

Reference

  • BI.DB.SqlExpr


TDBSqlExprEngine Constants

Constants
Name | Description
DBDriverNames | Represents constant DBDriverNames.
DBDrivers | Represents constant DBDrivers.
Top


TDBSqlExprEngine.DBDriverNames Constant

Summary

Represents constant DBDriverNames.

Namespace: BI.DB.SqlExpr
Syntax
Delphi
public
 DBDriverNames:Array[0..8] of String=('SQLite','MySQL','Oracle','Microsoft SQL Server',
 'ODBC','Microsoft Access','Embarcadero Interbase','Firebird','MariaDB');

Value

Type: Array[0..8] of String

See Also

Reference

  • TDBSqlExprEngine
  • BI.DB.SqlExpr


TDBSqlExprEngine.DBDrivers Constant

Summary

Represents constant DBDrivers.

Namespace: BI.DB.SqlExpr
Syntax
Delphi
public
 DBDrivers:Array[0..8] of String=('SQLite','MySQL','Ora','MSSQL','ODBC','ODBC','IB','FB','MySQL');

Value

Type: Array[0..8] of String

See Also

Reference

  • TDBSqlExprEngine
  • BI.DB.SqlExpr


TDBSqlExprEngine Methods

Methods
Name | Description
CloneConnection(TCustomConnection) | Represents method CloneConnection(TCustomConnection). (Overrides TBIDBEngine.CloneConnection(TCustomConnection).)
CreateConnection(TDataDefinition) | Represents method CreateConnection(TDataDefinition). (Overrides TBIDBEngine.CreateConnection(TDataDefinition).)
CreateDataSet(TComponent,TDataItem) | Represents method CreateDataSet(TComponent,TDataItem). (Overrides TBIDBEngine.CreateDataSet(TComponent,TDataItem).)
CreateQuery(TCustomConnection,String) | Represents method CreateQuery(TCustomConnection,String). (Overrides TBIDBEngine.CreateQuery(TCustomConnection,String).)
DriverNames | Represents method DriverNames. (Overrides TBIDBEngine.DriverNames.)
DriverToName(String) | Represents method DriverToName(String). (Overrides TBIDBEngine.DriverToName(String).)
FileFilter | Represents method FileFilter. (Overrides TBIDBEngine.FileFilter.)
GetConnectionName(TCustomConnection) | Represents method GetConnectionName(TCustomConnection). (Overrides TBIDBEngine.GetConnectionName(TCustomConnection).)
GetDriver(Integer) | Represents method GetDriver(Integer). (Overrides TBIDBEngine.GetDriver(Integer).)
GetItemNames(TCustomConnection,Boolean,Boolean) | Represents method GetItemNames(TCustomConnection,Boolean,Boolean). (Overrides TBIDBEngine.GetItemNames(TCustomConnection,Boolean,Boolean).)
GetKeyFieldNames(TCustomConnection,String) | Represents method GetKeyFieldNames(TCustomConnection,String). (Overrides TBIDBEngine.GetKeyFieldNames(TCustomConnection,String).)
GetSchemas(TCustomConnection) | Represents method GetSchemas(TCustomConnection).
GetTable(TCustomConnection,String) | Represents method GetTable(TCustomConnection,String). (Overrides TBIDBEngine.GetTable(TCustomConnection,String).)
GuessForeignKeys(String,TDataSet,TDataItem,TBISource) | Represents method GuessForeignKeys(String,TDataSet,TDataItem,TBISource). (Overrides TBIDBEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource).)
ImportFile(TBIDB,String) | Represents method ImportFile(TBIDB,String). (Overrides TBIDBEngine.ImportFile(TBIDB,String).)
Supports(String) | Represents method Supports(String). (Overrides TBIDBEngine.Supports(String).)
Tester | Represents method Tester. (Overrides TBIDBEngine.Tester.)
Top


TDBSqlExprEngine.CloneConnection(TCustomConnection) Method

Summary

Represents method CloneConnection(TCustomConnection).

Namespace: BI.DB.SqlExpr
Syntax
Delphi
public
 class function CloneConnection(const AConn:TCustomConnection): TCustomConnection; override;

Parameters

AConn
Type: TCustomConnection

Return Value

Type: TCustomConnection

Overrides

TBIDBEngine.CloneConnection(TCustomConnection)
See Also

Reference

  • TDBSqlExprEngine
  • BI.DB.SqlExpr


TDBSqlExprEngine.CreateConnection(TDataDefinition) Method

Summary

Represents method CreateConnection(TDataDefinition).

Namespace: BI.DB.SqlExpr
Syntax
Delphi
public
 class function CreateConnection(const Definition:TDataDefinition):TCustomConnection; override;

Parameters

Definition
Type: TDataDefinition

Return Value

Type: TCustomConnection

Overrides

TBIDBEngine.CreateConnection(TDataDefinition)
See Also

Reference

  • TDBSqlExprEngine
  • BI.DB.SqlExpr


TDBSqlExprEngine.CreateDataSet(TComponent,TDataItem) Method

Summary

Represents method CreateDataSet(TComponent,TDataItem).

Namespace: BI.DB.SqlExpr
Syntax
Delphi
public
 class function CreateDataSet(const AOwner:TComponent; const AData:TDataItem):TDataSet; override;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

Return Value

Type: TDataSet

Overrides

TBIDBEngine.CreateDataSet(TComponent,TDataItem)
See Also

Reference

  • TDBSqlExprEngine
  • BI.DB.SqlExpr


TDBSqlExprEngine.CreateQuery(TCustomConnection,String) Method

Summary

Represents method CreateQuery(TCustomConnection,String).

Namespace: BI.DB.SqlExpr
Syntax
Delphi
public
 class function CreateQuery(const AConnection:TCustomConnection; const SQL:String):TDataSet; override;

Parameters

AConnection
Type: TCustomConnection

SQL
Type: String

Return Value

Type: TDataSet

Overrides

TBIDBEngine.CreateQuery(TCustomConnection,String)
See Also

Reference

  • TDBSqlExprEngine
  • BI.DB.SqlExpr


TDBSqlExprEngine.DriverNames Method

Summary

Represents method DriverNames.

Namespace: BI.DB.SqlExpr
Syntax
Delphi
public
 class function DriverNames:TStringDynArray; override;

Return Value

Type: TStringDynArray

Overrides

TBIDBEngine.DriverNames
See Also

Reference

  • TDBSqlExprEngine
  • BI.DB.SqlExpr


TDBSqlExprEngine.DriverToName(String) Method

Summary

Represents method DriverToName(String).

Namespace: BI.DB.SqlExpr
Syntax
Delphi
public
 class function DriverToName(const ADriver:String):String; override;

Parameters

ADriver
Type: String

Return Value

Type: String

Overrides

TBIDBEngine.DriverToName(String)
See Also

Reference

  • TDBSqlExprEngine
  • BI.DB.SqlExpr


TDBSqlExprEngine.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.DB.SqlExpr
Syntax
Delphi
public
 class function FileFilter: TFileFilters; override;

Return Value

Type: TFileFilters

Overrides

TBIDBEngine.FileFilter
See Also

Reference

  • TDBSqlExprEngine
  • BI.DB.SqlExpr


TDBSqlExprEngine.GetConnectionName(TCustomConnection) Method

Summary

Represents method GetConnectionName(TCustomConnection).

Namespace: BI.DB.SqlExpr
Syntax
Delphi
public
 class function GetConnectionName(const AConnection:TCustomConnection):String; override;

Parameters

AConnection
Type: TCustomConnection

Return Value

Type: String

Overrides

TBIDBEngine.GetConnectionName(TCustomConnection)
See Also

Reference

  • TDBSqlExprEngine
  • BI.DB.SqlExpr


TDBSqlExprEngine.GetDriver(Integer) Method

Summary

Represents method GetDriver(Integer).

Namespace: BI.DB.SqlExpr
Syntax
Delphi
public
 class function GetDriver(const AIndex:Integer):String; override;

Parameters

AIndex
Type: Integer

Return Value

Type: String

Overrides

TBIDBEngine.GetDriver(Integer)
See Also

Reference

  • TDBSqlExprEngine
  • BI.DB.SqlExpr


TDBSqlExprEngine.GetItemNames(TCustomConnection,Boolean,Boolean) Method

Summary

Represents method GetItemNames(TCustomConnection,Boolean,Boolean).

Namespace: BI.DB.SqlExpr
Syntax
Delphi
public
 class function GetItemNames(const AConnection:TCustomConnection;
 const IncludeSystem,IncludeViews:Boolean):TStrings; override;

Parameters

AConnection
Type: TCustomConnection

IncludeSystem
Type: Boolean

IncludeViews
Type: Boolean

Return Value

Type: TStrings

Overrides

TBIDBEngine.GetItemNames(TCustomConnection,Boolean,Boolean)
See Also

Reference

  • TDBSqlExprEngine
  • BI.DB.SqlExpr


TDBSqlExprEngine.GetKeyFieldNames(TCustomConnection,String) Method

Summary

Represents method GetKeyFieldNames(TCustomConnection,String).

Namespace: BI.DB.SqlExpr
Syntax
Delphi
public
 class function GetKeyFieldNames(const AConnection:TCustomConnection; const ATable:String):TStrings; override;

Parameters

AConnection
Type: TCustomConnection

ATable
Type: String

Return Value

Type: TStrings

Overrides

TBIDBEngine.GetKeyFieldNames(TCustomConnection,String)
See Also

Reference

  • TDBSqlExprEngine
  • BI.DB.SqlExpr


TDBSqlExprEngine.GetSchemas(TCustomConnection) Method

Summary

Represents method GetSchemas(TCustomConnection).

Namespace: BI.DB.SqlExpr
Syntax
Delphi
public
 class function GetSchemas(const AConnection:TCustomConnection):TStrings;

Parameters

AConnection
Type: TCustomConnection

Return Value

Type: TStrings

See Also

Reference

  • TDBSqlExprEngine
  • BI.DB.SqlExpr


TDBSqlExprEngine.GetTable(TCustomConnection,String) Method

Summary

Represents method GetTable(TCustomConnection,String).

Namespace: BI.DB.SqlExpr
Syntax
Delphi
public
 class function GetTable(const AConnection:TCustomConnection; const AName:String):TDataSet; override;

Parameters

AConnection
Type: TCustomConnection

AName
Type: String

Return Value

Type: TDataSet

Overrides

TBIDBEngine.GetTable(TCustomConnection,String)
See Also

Reference

  • TDBSqlExprEngine
  • BI.DB.SqlExpr


TDBSqlExprEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource) Method

Summary

Represents method GuessForeignKeys(String,TDataSet,TDataItem,TBISource).

Namespace: BI.DB.SqlExpr
Syntax
Delphi
public
 class procedure GuessForeignKeys(const AName:String; const Table:TDataSet; const AData:TDataItem; const Source:TBISource); override;

Parameters

AName
Type: String

Table
Type: TDataSet

AData
Type: TDataItem

Source
Type: TBISource

Overrides

TBIDBEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource)
See Also

Reference

  • TDBSqlExprEngine
  • BI.DB.SqlExpr


TDBSqlExprEngine.ImportFile(TBIDB,String) Method

Summary

Represents method ImportFile(TBIDB,String).

Namespace: BI.DB.SqlExpr
Syntax
Delphi
public
 class function ImportFile(const Source:TBIDB; const AFileName:String):TDataArray; override;

Parameters

Source
Type: TBIDB

AFileName
Type: String

Return Value

Type: TDataArray

Overrides

TBIDBEngine.ImportFile(TBIDB,String)
See Also

Reference

  • TDBSqlExprEngine
  • BI.DB.SqlExpr


TDBSqlExprEngine.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.DB.SqlExpr
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIDBEngine.Supports(String)
See Also

Reference

  • TDBSqlExprEngine
  • BI.DB.SqlExpr


TDBSqlExprEngine.Tester Method

Summary

Represents method Tester.

Namespace: BI.DB.SqlExpr
Syntax
Delphi
public
 class function Tester:TBIDBTesterClass; override;

Return Value

Type: TBIDBTesterClass

Overrides

TBIDBEngine.Tester
See Also

Reference

  • TDBSqlExprEngine
  • BI.DB.SqlExpr


TDBSqlExprTester Class

Summary

Represents type TDBSqlExprTester.

Namespace: BI.DB.SqlExpr
Inheritance Hierarchy
TObject
BI.DB.TBIDBTester
BI.DB.SqlExpr.TDBSqlExprTester
Syntax
Delphi
type
 TDBSqlExprTester=class(TBIDBTester)
 end;

The TDBSqlExprTester type exposes the following members.

Methods
Show:
Name | Description
Test(String,String,String,String,String,String,Boolean) | Represents method Test(String,String,String,String,String,String,Boolean). (Overrides TBIDBTester.Test(String,String,String,String,String,String,Boolean).)
Top
See Also

Reference

  • BI.DB.SqlExpr


TDBSqlExprTester Methods

Methods
Name | Description
Test(String,String,String,String,String,String,Boolean) | Represents method Test(String,String,String,String,String,String,Boolean). (Overrides TBIDBTester.Test(String,String,String,String,String,String,Boolean).)
Top


TDBSqlExprTester.Test(String,String,String,String,String,String,Boolean) Method

Summary

Represents method Test(String,String,String,String,String,String,Boolean).

Namespace: BI.DB.SqlExpr
Syntax
Delphi
public
 class procedure Test(const Driver,Database,Server,Port,User,Password:String;
 const Prompt:Boolean); override;

Parameters

Driver
Type: String

Database
Type: String

Server
Type: String

Port
Type: String

User
Type: String

Password
Type: String

Prompt
Type: Boolean

Overrides

TBIDBTester.Test(String,String,String,String,String,String,Boolean)
See Also

Reference

  • TDBSqlExprTester
  • BI.DB.SqlExpr


BI.DB.UniDAC Namespace

Summary

Represents namespace BI.DB.UniDAC.

Classes
Name | Description
TDBUniDACEngine | Represents type TDBUniDACEngine.
Top


BI.DB.UniDAC Classes

Classes
Name | Description
TDBUniDACEngine | Represents type TDBUniDACEngine.
Top


TDBUniDACEngine Class

Summary

Represents type TDBUniDACEngine.

Namespace: BI.DB.UniDAC
Inheritance Hierarchy
TObject
BI.DB.TBIDBEngine
BI.DB.UniDAC.TDBUniDACEngine
Syntax
Delphi
type
 TDBUniDACEngine=class(TBIDBEngine)
 end;

The TDBUniDACEngine type exposes the following members.

Methods
Show:
Name | Description
CloneConnection(TCustomConnection) | Represents method CloneConnection(TCustomConnection). (Overrides TBIDBEngine.CloneConnection(TCustomConnection).)
CreateConnection(TDataDefinition) | Represents method CreateConnection(TDataDefinition). (Overrides TBIDBEngine.CreateConnection(TDataDefinition).)
CreateDataSet(TComponent,TDataItem) | Represents method CreateDataSet(TComponent,TDataItem). (Overrides TBIDBEngine.CreateDataSet(TComponent,TDataItem).)
CreateQuery(TCustomConnection,String) | Represents method CreateQuery(TCustomConnection,String). (Overrides TBIDBEngine.CreateQuery(TCustomConnection,String).)
DriverNames | Represents method DriverNames. (Overrides TBIDBEngine.DriverNames.)
DriverToName(String) | Represents method DriverToName(String). (Overrides TBIDBEngine.DriverToName(String).)
GetConnectionName(TCustomConnection) | Represents method GetConnectionName(TCustomConnection). (Overrides TBIDBEngine.GetConnectionName(TCustomConnection).)
GetDriver(Integer) | Represents method GetDriver(Integer). (Overrides TBIDBEngine.GetDriver(Integer).)
GetKeyFieldNames(TCustomConnection,String) | Represents method GetKeyFieldNames(TCustomConnection,String). (Overrides TBIDBEngine.GetKeyFieldNames(TCustomConnection,String).)
GetSchemas(TCustomConnection) | Represents method GetSchemas(TCustomConnection).
GetTable(TCustomConnection,String) | Represents method GetTable(TCustomConnection,String). (Overrides TBIDBEngine.GetTable(TCustomConnection,String).)
GetTableNames(TCustomConnection) | Represents method GetTableNames(TCustomConnection).
GuessForeignKeys(String,TDataSet,TDataItem,TBISource) | Represents method GuessForeignKeys(String,TDataSet,TDataItem,TBISource). (Overrides TBIDBEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource).)
ImportFile(TBIDB,String) | Represents method ImportFile(TBIDB,String). (Overrides TBIDBEngine.ImportFile(TBIDB,String).)
Tester | Represents method Tester. (Overrides TBIDBEngine.Tester.)
Top
See Also

Reference

  • BI.DB.UniDAC


TDBUniDACEngine Methods

Methods
Name | Description
CloneConnection(TCustomConnection) | Represents method CloneConnection(TCustomConnection). (Overrides TBIDBEngine.CloneConnection(TCustomConnection).)
CreateConnection(TDataDefinition) | Represents method CreateConnection(TDataDefinition). (Overrides TBIDBEngine.CreateConnection(TDataDefinition).)
CreateDataSet(TComponent,TDataItem) | Represents method CreateDataSet(TComponent,TDataItem). (Overrides TBIDBEngine.CreateDataSet(TComponent,TDataItem).)
CreateQuery(TCustomConnection,String) | Represents method CreateQuery(TCustomConnection,String). (Overrides TBIDBEngine.CreateQuery(TCustomConnection,String).)
DriverNames | Represents method DriverNames. (Overrides TBIDBEngine.DriverNames.)
DriverToName(String) | Represents method DriverToName(String). (Overrides TBIDBEngine.DriverToName(String).)
GetConnectionName(TCustomConnection) | Represents method GetConnectionName(TCustomConnection). (Overrides TBIDBEngine.GetConnectionName(TCustomConnection).)
GetDriver(Integer) | Represents method GetDriver(Integer). (Overrides TBIDBEngine.GetDriver(Integer).)
GetKeyFieldNames(TCustomConnection,String) | Represents method GetKeyFieldNames(TCustomConnection,String). (Overrides TBIDBEngine.GetKeyFieldNames(TCustomConnection,String).)
GetSchemas(TCustomConnection) | Represents method GetSchemas(TCustomConnection).
GetTable(TCustomConnection,String) | Represents method GetTable(TCustomConnection,String). (Overrides TBIDBEngine.GetTable(TCustomConnection,String).)
GetTableNames(TCustomConnection) | Represents method GetTableNames(TCustomConnection).
GuessForeignKeys(String,TDataSet,TDataItem,TBISource) | Represents method GuessForeignKeys(String,TDataSet,TDataItem,TBISource). (Overrides TBIDBEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource).)
ImportFile(TBIDB,String) | Represents method ImportFile(TBIDB,String). (Overrides TBIDBEngine.ImportFile(TBIDB,String).)
Tester | Represents method Tester. (Overrides TBIDBEngine.Tester.)
Top


TDBUniDACEngine.CloneConnection(TCustomConnection) Method

Summary

Represents method CloneConnection(TCustomConnection).

Namespace: BI.DB.UniDAC
Syntax
Delphi
public
 class function CloneConnection(const AConn:TCustomConnection): TCustomConnection; override;

Parameters

AConn
Type: TCustomConnection

Return Value

Type: TCustomConnection

Overrides

TBIDBEngine.CloneConnection(TCustomConnection)
See Also

Reference

  • TDBUniDACEngine
  • BI.DB.UniDAC


TDBUniDACEngine.CreateConnection(TDataDefinition) Method

Summary

Represents method CreateConnection(TDataDefinition).

Namespace: BI.DB.UniDAC
Syntax
Delphi
public
 class function CreateConnection(const Definition:TDataDefinition):TCustomConnection; override;

Parameters

Definition
Type: TDataDefinition

Return Value

Type: TCustomConnection

Overrides

TBIDBEngine.CreateConnection(TDataDefinition)
See Also

Reference

  • TDBUniDACEngine
  • BI.DB.UniDAC


TDBUniDACEngine.CreateDataSet(TComponent,TDataItem) Method

Summary

Represents method CreateDataSet(TComponent,TDataItem).

Namespace: BI.DB.UniDAC
Syntax
Delphi
public
 class function CreateDataSet(const AOwner:TComponent; const AData:TDataItem):TDataSet; override;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

Return Value

Type: TDataSet

Overrides

TBIDBEngine.CreateDataSet(TComponent,TDataItem)
See Also

Reference

  • TDBUniDACEngine
  • BI.DB.UniDAC


TDBUniDACEngine.CreateQuery(TCustomConnection,String) Method

Summary

Represents method CreateQuery(TCustomConnection,String).

Namespace: BI.DB.UniDAC
Syntax
Delphi
public
 class function CreateQuery(const AConnection:TCustomConnection; const SQL:String):TDataSet; override;

Parameters

AConnection
Type: TCustomConnection

SQL
Type: String

Return Value

Type: TDataSet

Overrides

TBIDBEngine.CreateQuery(TCustomConnection,String)
See Also

Reference

  • TDBUniDACEngine
  • BI.DB.UniDAC


TDBUniDACEngine.DriverNames Method

Summary

Represents method DriverNames.

Namespace: BI.DB.UniDAC
Syntax
Delphi
public
 class function DriverNames:TStringDynArray; override;

Return Value

Type: TStringDynArray

Overrides

TBIDBEngine.DriverNames
See Also

Reference

  • TDBUniDACEngine
  • BI.DB.UniDAC


TDBUniDACEngine.DriverToName(String) Method

Summary

Represents method DriverToName(String).

Namespace: BI.DB.UniDAC
Syntax
Delphi
public
 class function DriverToName(const ADriver:String):String; override;

Parameters

ADriver
Type: String

Return Value

Type: String

Overrides

TBIDBEngine.DriverToName(String)
See Also

Reference

  • TDBUniDACEngine
  • BI.DB.UniDAC


TDBUniDACEngine.GetConnectionName(TCustomConnection) Method

Summary

Represents method GetConnectionName(TCustomConnection).

Namespace: BI.DB.UniDAC
Syntax
Delphi
public
 class function GetConnectionName(const AConnection:TCustomConnection):String; override;

Parameters

AConnection
Type: TCustomConnection

Return Value

Type: String

Overrides

TBIDBEngine.GetConnectionName(TCustomConnection)
See Also

Reference

  • TDBUniDACEngine
  • BI.DB.UniDAC


TDBUniDACEngine.GetDriver(Integer) Method

Summary

Represents method GetDriver(Integer).

Namespace: BI.DB.UniDAC
Syntax
Delphi
public
 class function GetDriver(const AIndex:Integer):String; override;

Parameters

AIndex
Type: Integer

Return Value

Type: String

Overrides

TBIDBEngine.GetDriver(Integer)
See Also

Reference

  • TDBUniDACEngine
  • BI.DB.UniDAC


TDBUniDACEngine.GetKeyFieldNames(TCustomConnection,String) Method

Summary

Represents method GetKeyFieldNames(TCustomConnection,String).

Namespace: BI.DB.UniDAC
Syntax
Delphi
public
 class function GetKeyFieldNames(const AConnection:TCustomConnection; const ATable:String):TStrings; override;

Parameters

AConnection
Type: TCustomConnection

ATable
Type: String

Return Value

Type: TStrings

Overrides

TBIDBEngine.GetKeyFieldNames(TCustomConnection,String)
See Also

Reference

  • TDBUniDACEngine
  • BI.DB.UniDAC


TDBUniDACEngine.GetSchemas(TCustomConnection) Method

Summary

Represents method GetSchemas(TCustomConnection).

Namespace: BI.DB.UniDAC
Syntax
Delphi
public
 class function GetSchemas(const AConnection:TCustomConnection):TStrings;

Parameters

AConnection
Type: TCustomConnection

Return Value

Type: TStrings

See Also

Reference

  • TDBUniDACEngine
  • BI.DB.UniDAC


TDBUniDACEngine.GetTable(TCustomConnection,String) Method

Summary

Represents method GetTable(TCustomConnection,String).

Namespace: BI.DB.UniDAC
Syntax
Delphi
public
 class function GetTable(const AConnection:TCustomConnection; const AName:String):TDataSet; override;

Parameters

AConnection
Type: TCustomConnection

AName
Type: String

Return Value

Type: TDataSet

Overrides

TBIDBEngine.GetTable(TCustomConnection,String)
See Also

Reference

  • TDBUniDACEngine
  • BI.DB.UniDAC


TDBUniDACEngine.GetTableNames(TCustomConnection) Method

Summary

Represents method GetTableNames(TCustomConnection).

Namespace: BI.DB.UniDAC
Syntax
Delphi
public
 class function GetTableNames(const AConnection:TCustomConnection):TStrings; override;

Parameters

AConnection
Type: TCustomConnection

Return Value

Type: TStrings

See Also

Reference

  • TDBUniDACEngine
  • BI.DB.UniDAC


TDBUniDACEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource) Method

Summary

Represents method GuessForeignKeys(String,TDataSet,TDataItem,TBISource).

Namespace: BI.DB.UniDAC
Syntax
Delphi
public
 class procedure GuessForeignKeys(const AName:String; const Table:TDataSet; const AData:TDataItem; const Source:TBISource); override;

Parameters

AName
Type: String

Table
Type: TDataSet

AData
Type: TDataItem

Source
Type: TBISource

Overrides

TBIDBEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource)
See Also

Reference

  • TDBUniDACEngine
  • BI.DB.UniDAC


TDBUniDACEngine.ImportFile(TBIDB,String) Method

Summary

Represents method ImportFile(TBIDB,String).

Namespace: BI.DB.UniDAC
Syntax
Delphi
public
 class function ImportFile(const Source:TBIDB; const AFileName:String):TDataArray; override;

Parameters

Source
Type: TBIDB

AFileName
Type: String

Return Value

Type: TDataArray

Overrides

TBIDBEngine.ImportFile(TBIDB,String)
See Also

Reference

  • TDBUniDACEngine
  • BI.DB.UniDAC


TDBUniDACEngine.Tester Method

Summary

Represents method Tester.

Namespace: BI.DB.UniDAC
Syntax
Delphi
public
 class function Tester:TBIDBTesterClass; override;

Return Value

Type: TBIDBTesterClass

Overrides

TBIDBEngine.Tester
See Also

Reference

  • TDBUniDACEngine
  • BI.DB.UniDAC


BI.DB.ZeosLib Namespace

Summary

Represents namespace BI.DB.ZeosLib.

Classes
Name | Description
TBISourceAccess | Represents type TBISourceAccess.
TBIZeosLib | Represents type TBIZeosLib.
TDataAccess | Represents type TDataAccess.
Top
Types
Name | Description
TDbcConnection | Represents an alias of the ZDbcConnection type.
TZAbstractConnectionClass | Represents type TZAbstractConnectionClass.
Top
Constants
Name | Description
DBDriverNames | Represents constant DBDriverNames.
Top


BI.DB.ZeosLib Classes

Classes
Name | Description
TBISourceAccess | Represents type TBISourceAccess.
TBIZeosLib | Represents type TBIZeosLib.
TDataAccess | Represents type TDataAccess.
Top


TBISourceAccess Class

Summary

Represents type TBISourceAccess.

Namespace: BI.DB.ZeosLib
Inheritance Hierarchy
TObject
BI.DataSource.TBISource
BI.DB.ZeosLib.TBISourceAccess
Syntax
Delphi
type
 TBISourceAccess=class(TBISource);
See Also

Reference

  • BI.DB.ZeosLib


TBIZeosLib Class

Summary

Represents type TBIZeosLib.

Namespace: BI.DB.ZeosLib
Inheritance Hierarchy
TObject
BI.DataSource.TBISource
BI.DataSource.TBIItemsSource
BI.DB.ZeosLib.TBIZeosLib
Syntax
Delphi
type
 TBIZeosLib=class(TBIItemsSource)
 end;

The TBIZeosLib type exposes the following members.

Methods
Show:
Name | Description
DriverNames | Represents method DriverNames.
FileFilter | Represents method FileFilter.
Import(IZResultSet) | Overloaded. Represents method Import(IZResultSet).
Import(String,String,Boolean) | Overloaded. Represents method Import(String,String,Boolean).
Import(TDbcConnection,Boolean) | Overloaded. Represents method Import(TDbcConnection,Boolean).
Supports(String) | Represents method Supports(String).
Top
See Also

Reference

  • BI.DB.ZeosLib


TBIZeosLib Methods

Methods
Name | Description
DriverNames | Represents method DriverNames.
FileFilter | Represents method FileFilter.
Import(IZResultSet) | Overloaded. Represents method Import(IZResultSet).
Import(String,String,Boolean) | Overloaded. Represents method Import(String,String,Boolean).
Import(TDbcConnection,Boolean) | Overloaded. Represents method Import(TDbcConnection,Boolean).
Supports(String) | Represents method Supports(String).
Top


TBIZeosLib.DriverNames Method

Summary

Represents method DriverNames.

Namespace: BI.DB.ZeosLib
Syntax
Delphi
public
 class function DriverNames: TStringDynArray; static;

Return Value

Type: TStringDynArray

See Also

Reference

  • TBIZeosLib
  • BI.DB.ZeosLib


TBIZeosLib.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.DB.ZeosLib
Syntax
Delphi
public
 class function FileFilter: TFileFilters; static;

Return Value

Type: TFileFilters

See Also

Reference

  • TBIZeosLib
  • BI.DB.ZeosLib


TBIZeosLib.Import(IZResultSet) Method

Summary

Represents method Import(IZResultSet).

Namespace: BI.DB.ZeosLib
Syntax
Delphi
public
 class function Import(const AResultSet:IZResultSet):TDataItem; overload; static;

Parameters

AResultSet
Type: IZResultSet

Return Value

Type: TDataItem

See Also

Reference

  • TBIZeosLib
  • BI.DB.ZeosLib


TBIZeosLib.Import(String,String,Boolean) Method

Summary

Represents method Import(String,String,Boolean).

Namespace: BI.DB.ZeosLib
Syntax
Delphi
public
 class function Import(const AFileName,AProtocol:String;
 const IncludeViews:Boolean=False):TDataItem; overload; static;

Parameters

AFileName
Type: String

AProtocol
Type: String

IncludeViews
Type: Boolean

Return Value

Type: TDataItem

See Also

Reference

  • TBIZeosLib
  • BI.DB.ZeosLib


TBIZeosLib.Import(TDbcConnection,Boolean) Method

Summary

Represents method Import(TDbcConnection,Boolean).

Namespace: BI.DB.ZeosLib
Syntax
Delphi
public
 class function Import(const AConnection:TDbcConnection;
 const IncludeViews:Boolean=False):TDataItem; overload; static;

Parameters

AConnection
Type: System.Void

IncludeViews
Type: Boolean

Return Value

Type: TDataItem

See Also

Reference

  • TBIZeosLib
  • BI.DB.ZeosLib


TBIZeosLib.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.DB.ZeosLib
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; static;

Parameters

Extension
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TBIZeosLib
  • BI.DB.ZeosLib


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.DB.ZeosLib
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.DB.ZeosLib.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.DB.ZeosLib


BI.DB.ZeosLib Types

Types
Name | Description
TDbcConnection | Represents an alias of the ZDbcConnection type.
TZAbstractConnectionClass | Represents type TZAbstractConnectionClass.
Top


TDbcConnection Type

Summary

Represents an alias of the ZDbcConnection type.

Namespace: BI.DB.ZeosLib
Syntax
Delphi
type
 TDbcConnection=ZDbcConnection.TZAbstractConnection;
See Also

Reference

  • BI.DB.ZeosLib


TZAbstractConnectionClass Type

Summary

Represents type TZAbstractConnectionClass.

Namespace: BI.DB.ZeosLib
Syntax
Delphi
type
 TZAbstractConnectionClass=class of TDbcConnection;
See Also

Reference

  • BI.DB.ZeosLib


BI.DB.ZeosLib Constants

Constants
Name | Description
DBDriverNames | Represents constant DBDriverNames.
Top


DBDriverNames Constant

Summary

Represents constant DBDriverNames.

Namespace: BI.DB.ZeosLib
Syntax
Delphi
 DBDriverNames:Array of String=['MySQL','Interbase','Postgres','MSSQL','Sybase',
 'Oracle','SQLite','ASA','ADO'];

Value

Type: Array of String

See Also

Reference

  • BI.DB.ZeosLib


BI.Delphi.Generator Namespace

Summary

Represents namespace BI.Delphi.Generator.

Classes
Name | Description
TBIDelphiGenerator | Represents type TBIDelphiGenerator.
Top
Routines
Name | Description
CharIn(Char,TSysCharSet) | Represents method CharIn(Char,TSysCharSet).
FixReservedWord(String) | Represents method FixReservedWord(String).
Top


BI.Delphi.Generator Classes

Classes
Name | Description
TBIDelphiGenerator | Represents type TBIDelphiGenerator.
Top


TBIDelphiGenerator Class

Summary

Represents type TBIDelphiGenerator.

Namespace: BI.Delphi.Generator
Inheritance Hierarchy
TObject
BI.Delphi.Generator.TBIDelphiGenerator
Syntax
Delphi
type
 TBIDelphiGenerator=class
 end;

The TBIDelphiGenerator type exposes the following members.

Methods
Show:
Name | Description
DelphiName(TDataItem,Integer) | Represents method DelphiName(TDataItem,Integer).
FromData(TDataItem) | Represents method FromData(TDataItem).
Top
See Also

Reference

  • BI.Delphi.Generator


TBIDelphiGenerator Methods

Methods
Name | Description
DelphiName(TDataItem,Integer) | Represents method DelphiName(TDataItem,Integer).
FromData(TDataItem) | Represents method FromData(TDataItem).
Top


TBIDelphiGenerator.DelphiName(TDataItem,Integer) Method

Summary

Represents method DelphiName(TDataItem,Integer).

Namespace: BI.Delphi.Generator
Syntax
Delphi
public
 class function DelphiName(const AData:TDataItem; const ACount:Integer=0):String;

Parameters

AData
Type: TDataItem

ACount
Type: Integer

Return Value

Type: String

See Also

Reference

  • TBIDelphiGenerator
  • BI.Delphi.Generator


TBIDelphiGenerator.FromData(TDataItem) Method

Summary

Represents method FromData(TDataItem).

Namespace: BI.Delphi.Generator
Syntax
Delphi
public
 class function FromData(const AData:TDataItem):TStrings; static;

Parameters

AData
Type: TDataItem

Return Value

Type: TStrings

See Also

Reference

  • TBIDelphiGenerator
  • BI.Delphi.Generator


BI.Delphi.Generator Routines

Routines
Name | Description
CharIn(Char,TSysCharSet) | Represents method CharIn(Char,TSysCharSet).
FixReservedWord(String) | Represents method FixReservedWord(String).
Top


CharIn(Char,TSysCharSet) Method

Summary

Represents method CharIn(Char,TSysCharSet).

Namespace: BI.Delphi.Generator
Syntax
Delphi
function CharIn(const C:Char; const AChars:TSysCharSet):Boolean;

Parameters

C
Type: Char

AChars
Type: TSysCharSet

Return Value

Type: Boolean

See Also

Reference

  • BI.Delphi.Generator


FixReservedWord(String) Method

Summary

Represents method FixReservedWord(String).

Namespace: BI.Delphi.Generator
Syntax
Delphi
function FixReservedWord(const S:String):String;

Parameters

S
Type: String

Return Value

Type: String

See Also

Reference

  • BI.Delphi.Generator


BI.Email.Indy Namespace

Summary

Represents namespace BI.Email.Indy.

Classes
Name | Description
TBIEmailIndy | Represents type TBIEmailIndy.
Top


BI.Email.Indy Classes

Classes
Name | Description
TBIEmailIndy | Represents type TBIEmailIndy.
Top


TBIEmailIndy Class

Summary

Represents type TBIEmailIndy.

Namespace: BI.Email.Indy
Inheritance Hierarchy
TObject
BI.Email.Indy.TBIEmailIndy
Syntax
Delphi
type
 TBIEmailIndy=class
 end;

The TBIEmailIndy type exposes the following members.

Methods
Show:
Name | Description
Send(String,String,String,String,String) | Represents method Send(String,String,String,String,String).
ValidAddress(String) | Represents method ValidAddress(String).
Top
Fields
Show:
Name | Description
EmailFrom | Represents field EmailFrom.
Host | Represents field Host.
Password | Represents field Password.
Username | Represents field Username.
Top
See Also

Reference

  • BI.Email.Indy


TBIEmailIndy Methods

Methods
Name | Description
Send(String,String,String,String,String) | Represents method Send(String,String,String,String,String).
ValidAddress(String) | Represents method ValidAddress(String).
Top


TBIEmailIndy.Send(String,String,String,String,String) Method

Summary

Represents method Send(String,String,String,String,String).

Namespace: BI.Email.Indy
Syntax
Delphi
public
 procedure Send(const AUser,AEmail,ASubject,ATextContent,AHtmlContent:String);

Parameters

AUser
Type: String

AEmail
Type: String

ASubject
Type: String

ATextContent
Type: String

AHtmlContent
Type: String

See Also

Reference

  • TBIEmailIndy
  • BI.Email.Indy


TBIEmailIndy.ValidAddress(String) Method

Summary

Represents method ValidAddress(String).

Namespace: BI.Email.Indy
Syntax
Delphi
public
 class function ValidAddress(const Email:String):Boolean; static;

Parameters

Email
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TBIEmailIndy
  • BI.Email.Indy


TBIEmailIndy Fields

Fields
Name | Description
EmailFrom | Represents field EmailFrom.
Host | Represents field Host.
Password | Represents field Password.
Username | Represents field Username.
Top


TBIEmailIndy.EmailFrom Field

Summary

Represents field EmailFrom.

Namespace: BI.Email.Indy
Syntax
Delphi
public
 Host,
 EmailFrom,
 Username,
 Password : String;

Field Value

Type: String

See Also

Reference

  • TBIEmailIndy
  • BI.Email.Indy


TBIEmailIndy.Host Field

Summary

Represents field Host.

Namespace: BI.Email.Indy
Syntax
Delphi
public
 Host,
 EmailFrom,
 Username,
 Password : String;

Field Value

Type: String

See Also

Reference

  • TBIEmailIndy
  • BI.Email.Indy


TBIEmailIndy.Password Field

Summary

Represents field Password.

Namespace: BI.Email.Indy
Syntax
Delphi
public
 Host,
 EmailFrom,
 Username,
 Password : String;

Field Value

Type: String

See Also

Reference

  • TBIEmailIndy
  • BI.Email.Indy


TBIEmailIndy.Username Field

Summary

Represents field Username.

Namespace: BI.Email.Indy
Syntax
Delphi
public
 Host,
 EmailFrom,
 Username,
 Password : String;

Field Value

Type: String

See Also

Reference

  • TBIEmailIndy
  • BI.Email.Indy


BI.Excel Namespace

Summary

Represents namespace BI.Excel.

Classes
Name | Description
EExcelException | Represents type EExcelException.
TBIExcel | Represents type TBIExcel.
TBIExcelEngine | Represents type TBIExcelEngine.
TBIExcelExport | Represents type TBIExcelExport.
Top
Types
Name | Description
TBIExcelEngineClass | Represents type TBIExcelEngineClass.
Top
Constants
Name | Description
ExcelApp | Represents constant ExcelApp.
ExcelNotInstalled | Represents constant ExcelNotInstalled.
Top
Routines
Name | Description
IsExcel_Installed | Represents method IsExcel_Installed.
OpenExcel(String,Variant) | Represents method OpenExcel(String,Variant).
Top


BI.Excel Classes

Classes
Name | Description
EExcelException | Represents type EExcelException.
TBIExcel | Represents type TBIExcel.
TBIExcelEngine | Represents type TBIExcelEngine.
TBIExcelExport | Represents type TBIExcelExport.
Top


EExcelException Class

Summary

Represents type EExcelException.

Namespace: BI.Excel
Inheritance Hierarchy
Exception
BI.Arrays.EBIException
BI.Excel.EExcelException
Syntax
Delphi
type
 EExcelException=class(EBIException);
See Also

Reference

  • BI.Excel


TBIExcel Class

Summary

Represents type TBIExcel.

Namespace: BI.Excel
Inheritance Hierarchy
TObject
BI.DataSource.TBISource
BI.DataSource.TBIItemsSource
BI.DataSource.TBIFileSource
BI.DataSource.TBITextSource
BI.Excel.TBIExcel
Syntax
Delphi
type
 TBIExcel=class(TBITextSource)
 end;

The TBIExcel type exposes the following members.

Constructors
Show:
Name | Description
Create(TDataDefinition,Boolean) | Initializes a new instance of the TBIExcel class. (Overrides TBITextSource.Create(TDataDefinition,Boolean).)
Top
Properties
Show:
Name | Description
HeaderCount | Represents property HeaderCount.
Top
Methods
Show:
Name | Description
DoImportFile(String) | Represents method DoImportFile(String). (Overrides TBITextSource.DoImportFile(String).)
FileFilter | Represents method FileFilter. (Overrides TBIFileSource.FileFilter.)
Import(String,Boolean) | Overloaded. Represents method Import(String,Boolean).
Supports(String) | Represents method Supports(String). (Overrides TBIFileSource.Supports(String).)
Top
Fields
Show:
Name | Description
Range | Represents field Range.
WorkSheet | Represents field WorkSheet.
Top
See Also

Reference

  • BI.Excel


TBIExcel Constructors

Constructors
Name | Description
Create(TDataDefinition,Boolean) | Initializes a new instance of the TBIExcel class. (Overrides TBITextSource.Create(TDataDefinition,Boolean).)
Top


TBIExcel.Create(TDataDefinition,Boolean) Constructor

Summary

Initializes a new instance of the TBIExcel class.

Namespace: BI.Excel
Syntax
Delphi
public
 Constructor Create(const Definition:TDataDefinition=nil; const MultiThread:Boolean=False); override;

Parameters

Definition
Type: TDataDefinition

MultiThread
Type: Boolean

Overrides

TBITextSource.Create(TDataDefinition,Boolean)
See Also

Reference

  • TBIExcel
  • BI.Excel


TBIExcel Properties

Properties
Name | Description
HeaderCount | Represents property HeaderCount.
Top


TBIExcel.HeaderCount Property

Summary

Represents property HeaderCount.

Namespace: BI.Excel
Syntax
Delphi
public
 property HeaderCount:Integer read FHeaderCount write FHeaderCount default 1;

Property Value

Type: Integer

See Also

Reference

  • TBIExcel
  • BI.Excel


TBIExcel Methods

Methods
Name | Description
DoImportFile(String) | Represents method DoImportFile(String). (Overrides TBITextSource.DoImportFile(String).)
FileFilter | Represents method FileFilter. (Overrides TBIFileSource.FileFilter.)
Import(String,Boolean) | Overloaded. Represents method Import(String,Boolean).
Supports(String) | Represents method Supports(String). (Overrides TBIFileSource.Supports(String).)
Top


TBIExcel.DoImportFile(String) Method

Summary

Represents method DoImportFile(String).

Namespace: BI.Excel
Syntax
Delphi
protected
 function DoImportFile(const FileName:String):TDataArray; override;

Parameters

FileName
Type: String

Return Value

Type: TDataArray

Overrides

TBITextSource.DoImportFile(String)
See Also

Reference

  • TBIExcel
  • BI.Excel


TBIExcel.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.Excel
Syntax
Delphi
public
 class function FileFilter: TFileFilters; override;

Return Value

Type: TFileFilters

Overrides

TBIFileSource.FileFilter
See Also

Reference

  • TBIExcel
  • BI.Excel


TBIExcel.Import(String,Boolean) Method

Summary

Represents method Import(String,Boolean).

Namespace: BI.Excel
Syntax
Delphi
public
 function Import(const Folder:String; Recursive:Boolean=False):TDataArray; overload;

Parameters

Folder
Type: String

Recursive
Type: Boolean

Return Value

Type: TDataArray

See Also

Reference

  • TBIExcel
  • BI.Excel


TBIExcel.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.Excel
Syntax
Delphi
public
 class function Supports(const Extension: String): Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIFileSource.Supports(String)
See Also

Reference

  • TBIExcel
  • BI.Excel


TBIExcel Fields

Fields
Name | Description
Range | Represents field Range.
WorkSheet | Represents field WorkSheet.
Top


TBIExcel.Range Field

Summary

Represents field Range.

Namespace: BI.Excel
Syntax
Delphi
public
 Range : String;

Field Value

Type: String

See Also

Reference

  • TBIExcel
  • BI.Excel


TBIExcel.WorkSheet Field

Summary

Represents field WorkSheet.

Namespace: BI.Excel
Syntax
Delphi
public
 WorkSheet : String;

Field Value

Type: String

See Also

Reference

  • TBIExcel
  • BI.Excel


TBIExcelEngine Class

Summary

Represents type TBIExcelEngine.

Namespace: BI.Excel
Inheritance Hierarchy
TObject
BI.Excel.TBIExcelEngine
BI.Excel.TMSFlexCel.TBITMSFlexCel
Syntax
Delphi
type
 TBIExcelEngine=class
 end;

The TBIExcelEngine type exposes the following members.

Methods
Show:
Name | Description
SaveToFile(TDataItem,String) | Represents method SaveToFile(TDataItem,String).
Top
See Also

Reference

  • BI.Excel


TBIExcelEngine Methods

Methods
Name | Description
SaveToFile(TDataItem,String) | Represents method SaveToFile(TDataItem,String).
Top


TBIExcelEngine.SaveToFile(TDataItem,String) Method

Summary

Represents method SaveToFile(TDataItem,String).

Namespace: BI.Excel
Syntax
Delphi
public
 class procedure SaveToFile(const AData:TDataItem; const AFileName:String); virtual;

Parameters

AData
Type: TDataItem

AFileName
Type: String

See Also

Reference

  • TBIExcelEngine
  • BI.Excel


TBIExcelExport Class

Summary

Represents type TBIExcelExport.

Namespace: BI.Excel
Inheritance Hierarchy
TObject
BI.DataSource.TBIExport
BI.Excel.TBIExcelExport
Syntax
Delphi
type
 TBIExcelExport=class(TBIExport)
 end;

The TBIExcelExport type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TBIExcelExport class. (Overrides TBIExport.Create.)
Top
Methods
Show:
Name | Description
FileFilter | Represents method FileFilter. (Overrides TBIExport.FileFilter.)
SaveToFile(String) | Represents method SaveToFile(String). (Overrides TBIExport.SaveToFile(String).)
Supports(String) | Represents method Supports(String). (Overrides TBIExport.Supports(String).)
Top
Fields
Show:
Name | Description
Engine | Represents field Engine.
Top
See Also

Reference

  • BI.Excel


TBIExcelExport Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TBIExcelExport class. (Overrides TBIExport.Create.)
Top


TBIExcelExport.Create Constructor

Summary

Initializes a new instance of the TBIExcelExport class.

Namespace: BI.Excel
Syntax
Delphi
public
 Constructor Create; override;

Overrides

TBIExport.Create
See Also

Reference

  • TBIExcelExport
  • BI.Excel


TBIExcelExport Methods

Methods
Name | Description
FileFilter | Represents method FileFilter. (Overrides TBIExport.FileFilter.)
SaveToFile(String) | Represents method SaveToFile(String). (Overrides TBIExport.SaveToFile(String).)
Supports(String) | Represents method Supports(String). (Overrides TBIExport.Supports(String).)
Top


TBIExcelExport.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.Excel
Syntax
Delphi
public
 class function FileFilter: TFileFilters; override;

Return Value

Type: TFileFilters

Overrides

TBIExport.FileFilter
See Also

Reference

  • TBIExcelExport
  • BI.Excel


TBIExcelExport.SaveToFile(String) Method

Summary

Represents method SaveToFile(String).

Namespace: BI.Excel
Syntax
Delphi
public
 procedure SaveToFile(const AFileName:String); override;

Parameters

AFileName
Type: String

Overrides

TBIExport.SaveToFile(String)
See Also

Reference

  • TBIExcelExport
  • BI.Excel


TBIExcelExport.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.Excel
Syntax
Delphi
public
 class function Supports(const Extension: String): Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIExport.Supports(String)
See Also

Reference

  • TBIExcelExport
  • BI.Excel


TBIExcelExport Fields

Fields
Name | Description
Engine | Represents field Engine.
Top


TBIExcelExport.Engine Field

Summary

Represents field Engine.

Namespace: BI.Excel
Syntax
Delphi
public
 class
 var Engine : TBIExcelEngineClass;

Field Value

Type: TBIExcelEngineClass

See Also

Reference

  • TBIExcelExport
  • BI.Excel


BI.Excel Types

Types
Name | Description
TBIExcelEngineClass | Represents type TBIExcelEngineClass.
Top


TBIExcelEngineClass Type

Summary

Represents type TBIExcelEngineClass.

Namespace: BI.Excel
Syntax
Delphi
type
 TBIExcelEngineClass=class of TBIExcelEngine;
See Also

Reference

  • BI.Excel


BI.Excel Constants

Constants
Name | Description
ExcelApp | Represents constant ExcelApp.
ExcelNotInstalled | Represents constant ExcelNotInstalled.
Top


ExcelApp Constant

Summary

Represents constant ExcelApp.

Namespace: BI.Excel
Syntax
Delphi
 ExcelApp='Excel.Application';

Value

Type: string

See Also

Reference

  • BI.Excel


ExcelNotInstalled Constant

Summary

Represents constant ExcelNotInstalled.

Namespace: BI.Excel
Syntax
Delphi
 ExcelNotInstalled='Cannot start Microsoft Excel. Is it correctly installed?';

Value

Type: string

See Also

Reference

  • BI.Excel


BI.Excel Routines

Routines
Name | Description
IsExcel_Installed | Represents method IsExcel_Installed.
OpenExcel(String,Variant) | Represents method OpenExcel(String,Variant).
Top


IsExcel_Installed Method

Summary

Represents method IsExcel_Installed.

Namespace: BI.Excel
Syntax
Delphi
function IsExcel_Installed:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • BI.Excel


OpenExcel(String,Variant) Method

Summary

Represents method OpenExcel(String,Variant).

Namespace: BI.Excel
Syntax
Delphi
function OpenExcel(const AFileName:String; out Excel:Variant):Boolean;

Parameters

AFileName
Type: String

Excel
Type: Variant

Return Value

Type: Boolean

See Also

Reference

  • BI.Excel


BI.Excel.TMSFlexCel Namespace

Summary

Represents namespace BI.Excel.TMSFlexCel.

Classes
Name | Description
TBITMSFlexCel | Represents type TBITMSFlexCel.
Top


BI.Excel.TMSFlexCel Classes

Classes
Name | Description
TBITMSFlexCel | Represents type TBITMSFlexCel.
Top


TBITMSFlexCel Class

Summary

Represents type TBITMSFlexCel.

Namespace: BI.Excel.TMSFlexCel
Inheritance Hierarchy
TObject
BI.Excel.TBIExcelEngine
BI.Excel.TMSFlexCel.TBITMSFlexCel
Syntax
Delphi
type
 TBITMSFlexCel=class(TBIExcelEngine)
 end;

The TBITMSFlexCel type exposes the following members.

Methods
Show:
Name | Description
SaveToFile(TDataItem,String) | Represents method SaveToFile(TDataItem,String). (Overrides TBIExcelEngine.SaveToFile(TDataItem,String).)
Top
See Also

Reference

  • BI.Excel.TMSFlexCel


TBITMSFlexCel Methods

Methods
Name | Description
SaveToFile(TDataItem,String) | Represents method SaveToFile(TDataItem,String). (Overrides TBIExcelEngine.SaveToFile(TDataItem,String).)
Top


TBITMSFlexCel.SaveToFile(TDataItem,String) Method

Summary

Represents method SaveToFile(TDataItem,String).

Namespace: BI.Excel.TMSFlexCel
Syntax
Delphi
public
 class procedure SaveToFile(const AData:TDataItem; const AFileName:String); override;

Parameters

AData
Type: TDataItem

AFileName
Type: String

Overrides

TBIExcelEngine.SaveToFile(TDataItem,String)
See Also

Reference

  • TBITMSFlexCel
  • BI.Excel.TMSFlexCel


BI.Expression Namespace

Summary

Represents namespace BI.Expression.

Classes
Name | Description
EExpressionParse | Represents type EExpressionParse.
TArithmeticExpression | Represents type TArithmeticExpression.
TArithmeticOperandHelper | Represents type TArithmeticOperandHelper.
TArrayExpression | Represents type TArrayExpression.
TBooleanExpression | Represents type TBooleanExpression.
TDateExpression | Represents type TDateExpression.
TDateTimeExpression | Represents type TDateTimeExpression.
TDateTimePartExpression | Represents type TDateTimePartExpression.
TDateTimePartHelper | Represents type TDateTimePartHelper.
TExpression | Represents type TExpression.
TExpressionsHelper | Represents type TExpressionsHelper.
TFloatExpression | Represents type TFloatExpression.
TIfExpression | Represents type TIfExpression.
TIntegerExpression | Represents type TIntegerExpression.
TLogicalExpression | Represents type TLogicalExpression.
TLogicalOperandHelper | Represents type TLogicalOperandHelper.
TMathExpression | Represents type TMathExpression.
TMathOperandHelper | Represents type TMathOperandHelper.
TOperandExpression | Represents type TOperandExpression.
TParameterExpression | Represents type TParameterExpression.
TParameterExpressionsHelper | Represents type TParameterExpressionsHelper.
TTextExpression | Represents type TTextExpression.
TTextLogicalExpression | Represents type TTextLogicalExpression.
TTextLogicalOperandHelper | Represents type TTextLogicalOperandHelper.
TTextOperandExpression | Represents type TTextOperandExpression.
TTextOperandHelper | Represents type TTextOperandHelper.
TTextUnaryOperandHelper | Represents type TTextUnaryOperandHelper.
TTimeExpression | Represents type TTimeExpression.
TUnaryDateTimeExpression | Represents type TUnaryDateTimeExpression.
TUnaryExpression | Represents type TUnaryExpression.
TUnaryNotExpression | Represents type TUnaryNotExpression.
TUnaryTextExpression | Represents type TUnaryTextExpression.
Top
Records
Name | Description
TParser | Represents type TParser.
Top
Enumerations
Name | Description
TArithmeticOperand | Represents type TArithmeticOperand.
TDateTimePart | Represents type TDateTimePart.
TDateTimeSpan | Represents type TDateTimeSpan.
TLogicalOperand | Represents type TLogicalOperand.
TMathOperand | Represents type TMathOperand.
TTextLogicalOperand | Represents type TTextLogicalOperand.
TTextOperand | Represents type TTextOperand.
TTextUnaryOperand | Represents type TTextUnaryOperand.
Top
Delegates
Name | Description
TExpressionProc | Represents type TExpressionProc.
Top
Types
Name | Description
TData | Represents an alias of the Variant type.
TErrorProc | Represents type TErrorProc.
TExpressionClass | Represents type TExpressionClass.
TExpressions | Represents an array of the TExpression type.
TParameterExpressionClass | Represents type TParameterExpressionClass.
TParameterExpressions | Represents an array of the TParameterExpressionClass type.
TResolveProc | Represents type TResolveProc.
Top
Constants
Name | Description
CRLF | Represents constant CRLF.
DateParts | Represents constant DateParts.
Top
Routines
Name | Description
CannotBeFloat(String) | Represents method CannotBeFloat(String).
DoInsert(TArrayExpression) | Represents method DoInsert(TArrayExpression).
DoPos(TArrayExpression) | Represents method DoPos(TArrayExpression).
DoRemove(TArrayExpression) | Represents method DoRemove(TArrayExpression).
DoReplace(TArrayExpression) | Represents method DoReplace(TArrayExpression).
DoSplit(TArrayExpression) | Represents method DoSplit(TArrayExpression).
DoSubString(TArrayExpression) | Represents method DoSubString(TArrayExpression).
FromArray(TExpressions,Boolean) | Represents method FromArray(TExpressions,Boolean).
GuessIntrinsic(String) | Represents method GuessIntrinsic(String).
IsAndOr(String) | Represents method IsAndOr(String).
NilFunction(String,Boolean) | Represents method NilFunction(String,Boolean).
StringCount(String,String) | Overloaded. Represents method StringCount(String,String).
StringCount(TArrayExpression) | Overloaded. Represents method StringCount(TArrayExpression).
Top


BI.Expression Classes

Classes
Name | Description
EExpressionParse | Represents type EExpressionParse.
TArithmeticExpression | Represents type TArithmeticExpression.
TArithmeticOperandHelper | Represents type TArithmeticOperandHelper.
TArrayExpression | Represents type TArrayExpression.
TBooleanExpression | Represents type TBooleanExpression.
TDateExpression | Represents type TDateExpression.
TDateTimeExpression | Represents type TDateTimeExpression.
TDateTimePartExpression | Represents type TDateTimePartExpression.
TDateTimePartHelper | Represents type TDateTimePartHelper.
TExpression | Represents type TExpression.
TExpressionsHelper | Represents type TExpressionsHelper.
TFloatExpression | Represents type TFloatExpression.
TIfExpression | Represents type TIfExpression.
TIntegerExpression | Represents type TIntegerExpression.
TLogicalExpression | Represents type TLogicalExpression.
TLogicalOperandHelper | Represents type TLogicalOperandHelper.
TMathExpression | Represents type TMathExpression.
TMathOperandHelper | Represents type TMathOperandHelper.
TOperandExpression | Represents type TOperandExpression.
TParameterExpression | Represents type TParameterExpression.
TParameterExpressionsHelper | Represents type TParameterExpressionsHelper.
TTextExpression | Represents type TTextExpression.
TTextLogicalExpression | Represents type TTextLogicalExpression.
TTextLogicalOperandHelper | Represents type TTextLogicalOperandHelper.
TTextOperandExpression | Represents type TTextOperandExpression.
TTextOperandHelper | Represents type TTextOperandHelper.
TTextUnaryOperandHelper | Represents type TTextUnaryOperandHelper.
TTimeExpression | Represents type TTimeExpression.
TUnaryDateTimeExpression | Represents type TUnaryDateTimeExpression.
TUnaryExpression | Represents type TUnaryExpression.
TUnaryNotExpression | Represents type TUnaryNotExpression.
TUnaryTextExpression | Represents type TUnaryTextExpression.
Top


EExpressionParse Class

Summary

Represents type EExpressionParse.

Namespace: BI.Expression
Inheritance Hierarchy
Exception
BI.Expression.EExpressionParse
Syntax
Delphi
type
 EExpressionParse=class(Exception)
 end;

The EExpressionParse type exposes the following members.

Constructors
Show:
Name | Description
Create(Integer,String) | Initializes a new instance of the EExpressionParse class.
Top
Fields
Show:
Name | Description
Position | Represents field Position.
Top
See Also

Reference

  • BI.Expression


EExpressionParse Constructors

Constructors
Name | Description
Create(Integer,String) | Initializes a new instance of the EExpressionParse class.
Top


EExpressionParse.Create(Integer,String) Constructor

Summary

Initializes a new instance of the EExpressionParse class.

Namespace: BI.Expression
Syntax
Delphi
public
 Constructor Create(APos:Integer; const AMessage:String);

Parameters

APos
Type: Integer

AMessage
Type: String

See Also

Reference

  • EExpressionParse
  • BI.Expression


EExpressionParse Fields

Fields
Name | Description
Position | Represents field Position.
Top


EExpressionParse.Position Field

Summary

Represents field Position.

Namespace: BI.Expression
Syntax
Delphi
public
 Position : Integer;

Field Value

Type: Integer

See Also

Reference

  • EExpressionParse
  • BI.Expression


TArithmeticExpression Class

Summary

Represents type TArithmeticExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TOperandExpression
BI.Expression.TArithmeticExpression
Syntax
Delphi
type
 TArithmeticExpression=class(TOperandExpression)
 end;

The TArithmeticExpression type exposes the following members.

Constructors
Show:
Name | Description
Create(TExpression,TArithmeticOperand,TExpression) | Initializes a new instance of the TArithmeticExpression class.
Top
Methods
Show:
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TOperandExpression.Assign(TExpression).)
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top
Fields
Show:
Name | Description
Operand | Represents field Operand.
Top
See Also

Reference

  • BI.Expression


TArithmeticExpression Constructors

Constructors
Name | Description
Create(TExpression,TArithmeticOperand,TExpression) | Initializes a new instance of the TArithmeticExpression class.
Top


TArithmeticExpression.Create(TExpression,TArithmeticOperand,TExpression) Constructor

Summary

Initializes a new instance of the TArithmeticExpression class.

Namespace: BI.Expression
Syntax
Delphi
public
 Constructor Create(const ALeft:TExpression; const AOperand:TArithmeticOperand; const ARight:TExpression);

Parameters

ALeft
Type: TExpression

AOperand
Type: TArithmeticOperand

ARight
Type: TExpression

See Also

Reference

  • TArithmeticExpression
  • BI.Expression


TArithmeticExpression Methods

Methods
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TOperandExpression.Assign(TExpression).)
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top


TArithmeticExpression.Assign(TExpression) Method

Summary

Represents method Assign(TExpression).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Assign(const Source:TExpression); override;

Parameters

Source
Type: TExpression

Overrides

TOperandExpression.Assign(TExpression)
See Also

Reference

  • TArithmeticExpression
  • BI.Expression


TArithmeticExpression.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TArithmeticExpression
  • BI.Expression


TArithmeticExpression.Value Method

Summary

Represents method Value.

Namespace: BI.Expression
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TArithmeticExpression
  • BI.Expression


TArithmeticExpression Fields

Fields
Name | Description
Operand | Represents field Operand.
Top


TArithmeticExpression.Operand Field

Summary

Represents field Operand.

Namespace: BI.Expression
Syntax
Delphi
public
 Operand : TArithmeticOperand;

Field Value

Type: TArithmeticOperand

See Also

Reference

  • TArithmeticExpression
  • BI.Expression


TArithmeticOperandHelper Class Helper

Summary

Represents type TArithmeticOperandHelper.

Namespace: BI.Expression
Syntax
Delphi
type
 TArithmeticOperandHelper=record helper for TArithmeticOperand
 end;
Methods
Name | Description
FromString(String,TArithmeticOperand) | Represents method FromString(String,TArithmeticOperand).
ToString | Represents method ToString.
Top
See Also

Reference

  • BI.Expression


TArithmeticOperandHelper Methods

Methods
Name | Description
FromString(String,TArithmeticOperand) | Represents method FromString(String,TArithmeticOperand).
ToString | Represents method ToString.
Top


TArithmeticOperandHelper.FromString(String,TArithmeticOperand) Method

Summary

Represents method FromString(String,TArithmeticOperand).

Namespace: BI.Expression
Syntax
Delphi
public
 class function FromString(const S:String; out Operand:TArithmeticOperand):Boolean; static;

Parameters

S
Type: String

Operand
Type: TArithmeticOperand

Return Value

Type: Boolean

See Also

Reference

  • TArithmeticOperandHelper
  • BI.Expression


TArithmeticOperandHelper.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String;

Return Value

Type: String

See Also

Reference

  • TArithmeticOperandHelper
  • BI.Expression


TArrayExpression Class

Summary

Represents type TArrayExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TArrayExpression
Syntax
Delphi
type
 TArrayExpression=class(TExpression)
 end;

The TArrayExpression type exposes the following members.

Constructors
Show:
Name | Description
Create(TData[]) | Overloaded. Initializes a new instance of the TArrayExpression class.
Create(TExpression[]) | Overloaded. Initializes a new instance of the TArrayExpression class.
Destroy | Represents the destructor of the TArrayExpression class.
Top
Properties
Show:
Name | Description
Item[Integer] | Represents property Item[Integer].
Top
Methods
Show:
Name | Description
Add(TExpression) | Represents method Add(TExpression).
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
Clear | Represents method Clear.
Count | Represents method Count.
ToString | Represents method ToString.
Traverse(TExpressionProc) | Represents method Traverse(TExpressionProc). (Overrides TExpression.Traverse(TExpressionProc).)
Value | Represents method Value. (Overrides TExpression.Value.)
Top
Fields
Show:
Name | Description
IsParams | Represents field IsParams.
Items | Represents field Items.
Top
See Also

Reference

  • BI.Expression


TArrayExpression Constructors

Constructors
Name | Description
Create(TData[]) | Overloaded. Initializes a new instance of the TArrayExpression class.
Create(TExpression[]) | Overloaded. Initializes a new instance of the TArrayExpression class.
Destroy | Represents the destructor of the TArrayExpression class.
Top


TArrayExpression.Create(TData[]) Constructor

Summary

Initializes a new instance of the TArrayExpression class.

Namespace: BI.Expression
Syntax
Delphi
public
 Constructor Create(const AValues:Array of TData); overload;

Parameters

AValues
Type: Array of TData

See Also

Reference

  • TArrayExpression
  • BI.Expression


TArrayExpression.Create(TExpression[]) Constructor

Summary

Initializes a new instance of the TArrayExpression class.

Namespace: BI.Expression
Syntax
Delphi
public
 Constructor Create(const AValues:Array of TExpression); overload;

Parameters

AValues
Type: Array of TExpression

See Also

Reference

  • TArrayExpression
  • BI.Expression


TArrayExpression.Destroy Destructor

Summary

Represents the destructor of the TArrayExpression class.

Namespace: BI.Expression
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TArrayExpression
  • BI.Expression


TArrayExpression Properties

Properties
Name | Description
Item[Integer] | Represents property Item[Integer].
Top


TArrayExpression.Item[Integer] Property

Summary

Represents property Item[Integer].

Namespace: BI.Expression
Syntax
Delphi
public
 property Item[const Index:Integer]:TExpression read Get write Put; default;

Parameters

Index
Type: Integer

Property Value

Type: TExpression

See Also

Reference

  • TArrayExpression
  • BI.Expression


TArrayExpression Methods

Methods
Name | Description
Add(TExpression) | Represents method Add(TExpression).
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
Clear | Represents method Clear.
Count | Represents method Count.
ToString | Represents method ToString.
Traverse(TExpressionProc) | Represents method Traverse(TExpressionProc). (Overrides TExpression.Traverse(TExpressionProc).)
Value | Represents method Value. (Overrides TExpression.Value.)
Top


TArrayExpression.Add(TExpression) Method

Summary

Represents method Add(TExpression).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Add(const AValue:TExpression);

Parameters

AValue
Type: TExpression

See Also

Reference

  • TArrayExpression
  • BI.Expression


TArrayExpression.Assign(TExpression) Method

Summary

Represents method Assign(TExpression).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Assign(const Source:TExpression); override;

Parameters

Source
Type: TExpression

Overrides

TExpression.Assign(TExpression)
See Also

Reference

  • TArrayExpression
  • BI.Expression


TArrayExpression.Clear Method

Summary

Represents method Clear.

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TArrayExpression
  • BI.Expression


TArrayExpression.Count Method

Summary

Represents method Count.

Namespace: BI.Expression
Syntax
Delphi
public
 function Count:Integer; inline;

Return Value

Type: Integer

See Also

Reference

  • TArrayExpression
  • BI.Expression


TArrayExpression.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TArrayExpression
  • BI.Expression


TArrayExpression.Traverse(TExpressionProc) Method

Summary

Represents method Traverse(TExpressionProc).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Traverse(const AProc:TExpressionProc); override;

Parameters

AProc
Type: TExpressionProc

Overrides

TExpression.Traverse(TExpressionProc)
See Also

Reference

  • TArrayExpression
  • BI.Expression


TArrayExpression.Value Method

Summary

Represents method Value.

Namespace: BI.Expression
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TArrayExpression
  • BI.Expression


TArrayExpression Fields

Fields
Name | Description
IsParams | Represents field IsParams.
Items | Represents field Items.
Top


TArrayExpression.IsParams Field

Summary

Represents field IsParams.

Namespace: BI.Expression
Syntax
Delphi
public
 IsParams : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TArrayExpression
  • BI.Expression


TArrayExpression.Items Field

Summary

Represents field Items.

Namespace: BI.Expression
Syntax
Delphi
public
 Items : TExpressions;

Field Value

Type: TExpressions

See Also

Reference

  • TArrayExpression
  • BI.Expression


TBooleanExpression Class

Summary

Represents type TBooleanExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TBooleanExpression
Syntax
Delphi
type
 TBooleanExpression=class(TExpression)
 end;

The TBooleanExpression type exposes the following members.

Constructors
Show:
Name | Description
Create(Boolean) | Initializes a new instance of the TBooleanExpression class.
Top
Methods
Show:
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top
Fields
Show:
Name | Description
Logical | Represents field Logical.
Top
See Also

Reference

  • BI.Expression


TBooleanExpression Constructors

Constructors
Name | Description
Create(Boolean) | Initializes a new instance of the TBooleanExpression class.
Top


TBooleanExpression.Create(Boolean) Constructor

Summary

Initializes a new instance of the TBooleanExpression class.

Namespace: BI.Expression
Syntax
Delphi
public
 Constructor Create(const AValue:Boolean);

Parameters

AValue
Type: Boolean

See Also

Reference

  • TBooleanExpression
  • BI.Expression


TBooleanExpression Methods

Methods
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top


TBooleanExpression.Assign(TExpression) Method

Summary

Represents method Assign(TExpression).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Assign(const Source:TExpression); override;

Parameters

Source
Type: TExpression

Overrides

TExpression.Assign(TExpression)
See Also

Reference

  • TBooleanExpression
  • BI.Expression


TBooleanExpression.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TBooleanExpression
  • BI.Expression


TBooleanExpression.Value Method

Summary

Represents method Value.

Namespace: BI.Expression
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TBooleanExpression
  • BI.Expression


TBooleanExpression Fields

Fields
Name | Description
Logical | Represents field Logical.
Top


TBooleanExpression.Logical Field

Summary

Represents field Logical.

Namespace: BI.Expression
Syntax
Delphi
public
 Logical : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBooleanExpression
  • BI.Expression


TDateExpression Class

Summary

Represents type TDateExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TUnaryExpression
BI.Expression.TParameterExpression
BI.Expression.TUnaryDateTimeExpression
BI.Expression.TDateExpression
Syntax
Delphi
type
 TDateExpression=class(TUnaryDateTimeExpression)
 end;

The TDateExpression type exposes the following members.

Methods
Show:
Name | Description
FromData(TData) | Represents method FromData(TData).
FromString(String) | Represents method FromString(String). (Overrides TParameterExpression.FromString(String).)
Today | Represents method Today.
Tomorrow | Represents method Tomorrow.
ToString | Represents method ToString. (Overrides TParameterExpression.ToString.)
Value | Represents method Value. (Overrides TExpression.Value.)
Yesterday | Represents method Yesterday.
Top
See Also

Reference

  • BI.Expression


TDateExpression Methods

Methods
Name | Description
FromData(TData) | Represents method FromData(TData).
FromString(String) | Represents method FromString(String). (Overrides TParameterExpression.FromString(String).)
Today | Represents method Today.
Tomorrow | Represents method Tomorrow.
ToString | Represents method ToString. (Overrides TParameterExpression.ToString.)
Value | Represents method Value. (Overrides TExpression.Value.)
Yesterday | Represents method Yesterday.
Top


TDateExpression.FromData(TData) Method

Summary

Represents method FromData(TData).

Namespace: BI.Expression
Syntax
Delphi
public
 class function FromData(const Value:TData):TDateTime; static;

Parameters

Value
Type: System.Void

Return Value

Type: TDateTime

See Also

Reference

  • TDateExpression
  • BI.Expression


TDateExpression.FromString(String) Method

Summary

Represents method FromString(String).

Namespace: BI.Expression
Syntax
Delphi
public
 class function FromString(const S:String):TParameterExpression; override;

Parameters

S
Type: String

Return Value

Type: TParameterExpression

Overrides

TParameterExpression.FromString(String)
See Also

Reference

  • TDateExpression
  • BI.Expression


TDateExpression.Today Method

Summary

Represents method Today.

Namespace: BI.Expression
Syntax
Delphi
public
 class function Today:TDateExpression; static;

Return Value

Type: TDateExpression

See Also

Reference

  • TDateExpression
  • BI.Expression


TDateExpression.Tomorrow Method

Summary

Represents method Tomorrow.

Namespace: BI.Expression
Syntax
Delphi
public
 class function Tomorrow:TDateExpression; static;

Return Value

Type: TDateExpression

See Also

Reference

  • TDateExpression
  • BI.Expression


TDateExpression.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

Overrides

TParameterExpression.ToString
See Also

Reference

  • TDateExpression
  • BI.Expression


TDateExpression.Value Method

Summary

Represents method Value.

Namespace: BI.Expression
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TDateExpression
  • BI.Expression


TDateExpression.Yesterday Method

Summary

Represents method Yesterday.

Namespace: BI.Expression
Syntax
Delphi
public
 class function Yesterday:TDateExpression; static;

Return Value

Type: TDateExpression

See Also

Reference

  • TDateExpression
  • BI.Expression


TDateTimeExpression Class

Summary

Represents type TDateTimeExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TDateTimeExpression
Syntax
Delphi
type
 TDateTimeExpression=class(TExpression)
 end;

The TDateTimeExpression type exposes the following members.

Constructors
Show:
Name | Description
Create(TDateTime) | Initializes a new instance of the TDateTimeExpression class.
Top
Methods
Show:
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
Date | Represents method Date.
DateSpan(TDateTime) | Represents method DateSpan(TDateTime).
FromData(TData) | Represents method FromData(TData).
Now | Represents method Now.
Time | Represents method Time.
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top
Fields
Show:
Name | Description
DateTime | Represents field DateTime.
Top
See Also

Reference

  • BI.Expression


TDateTimeExpression Constructors

Constructors
Name | Description
Create(TDateTime) | Initializes a new instance of the TDateTimeExpression class.
Top


TDateTimeExpression.Create(TDateTime) Constructor

Summary

Initializes a new instance of the TDateTimeExpression class.

Namespace: BI.Expression
Syntax
Delphi
public
 Constructor Create(const AValue:TDateTime);

Parameters

AValue
Type: TDateTime

See Also

Reference

  • TDateTimeExpression
  • BI.Expression


TDateTimeExpression Methods

Methods
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
Date | Represents method Date.
DateSpan(TDateTime) | Represents method DateSpan(TDateTime).
FromData(TData) | Represents method FromData(TData).
Now | Represents method Now.
Time | Represents method Time.
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top


TDateTimeExpression.Assign(TExpression) Method

Summary

Represents method Assign(TExpression).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Assign(const Source:TExpression); override;

Parameters

Source
Type: TExpression

Overrides

TExpression.Assign(TExpression)
See Also

Reference

  • TDateTimeExpression
  • BI.Expression


TDateTimeExpression.Date Method

Summary

Represents method Date.

Namespace: BI.Expression
Syntax
Delphi
public
 class function Date:TDateTimeExpression; static;

Return Value

Type: TDateTimeExpression

See Also

Reference

  • TDateTimeExpression
  • BI.Expression


TDateTimeExpression.DateSpan(TDateTime) Method

Summary

Represents method DateSpan(TDateTime).

Namespace: BI.Expression
Syntax
Delphi
public
 class function DateSpan(const ADelta:TDateTime):TDateTimeExpression; static;

Parameters

ADelta
Type: TDateTime

Return Value

Type: TDateTimeExpression

See Also

Reference

  • TDateTimeExpression
  • BI.Expression


TDateTimeExpression.FromData(TData) Method

Summary

Represents method FromData(TData).

Namespace: BI.Expression
Syntax
Delphi
public
 class function FromData(const Value:TData):TDateTime; static;

Parameters

Value
Type: System.Void

Return Value

Type: TDateTime

See Also

Reference

  • TDateTimeExpression
  • BI.Expression


TDateTimeExpression.Now Method

Summary

Represents method Now.

Namespace: BI.Expression
Syntax
Delphi
public
 class function Now:TDateTimeExpression; static;

Return Value

Type: TDateTimeExpression

See Also

Reference

  • TDateTimeExpression
  • BI.Expression


TDateTimeExpression.Time Method

Summary

Represents method Time.

Namespace: BI.Expression
Syntax
Delphi
public
 class function Time:TDateTimeExpression; static;

Return Value

Type: TDateTimeExpression

See Also

Reference

  • TDateTimeExpression
  • BI.Expression


TDateTimeExpression.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TDateTimeExpression
  • BI.Expression


TDateTimeExpression.Value Method

Summary

Represents method Value.

Namespace: BI.Expression
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TDateTimeExpression
  • BI.Expression


TDateTimeExpression Fields

Fields
Name | Description
DateTime | Represents field DateTime.
Top


TDateTimeExpression.DateTime Field

Summary

Represents field DateTime.

Namespace: BI.Expression
Syntax
Delphi
public
 DateTime : TDateTime;

Field Value

Type: TDateTime

See Also

Reference

  • TDateTimeExpression
  • BI.Expression


TDateTimePartExpression Class

Summary

Represents type TDateTimePartExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TUnaryExpression
BI.Expression.TParameterExpression
BI.Expression.TDateTimePartExpression
Syntax
Delphi
type
 TDateTimePartExpression=class(TParameterExpression)
 end;

The TDateTimePartExpression type exposes the following members.

Methods
Show:
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TUnaryExpression.Assign(TExpression).)
FromString(String) | Represents method FromString(String). (Overrides TParameterExpression.FromString(String).)
ResultClass | Represents method ResultClass. (Overrides TParameterExpression.ResultClass.)
ToString | Represents method ToString. (Overrides TParameterExpression.ToString.)
Value | Represents method Value. (Overrides TExpression.Value.)
Top
Fields
Show:
Name | Description
Part | Represents field Part.
Top
See Also

Reference

  • BI.Expression


TDateTimePartExpression Methods

Methods
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TUnaryExpression.Assign(TExpression).)
FromString(String) | Represents method FromString(String). (Overrides TParameterExpression.FromString(String).)
ResultClass | Represents method ResultClass. (Overrides TParameterExpression.ResultClass.)
ToString | Represents method ToString. (Overrides TParameterExpression.ToString.)
Value | Represents method Value. (Overrides TExpression.Value.)
Top


TDateTimePartExpression.Assign(TExpression) Method

Summary

Represents method Assign(TExpression).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Assign(const Source:TExpression); override;

Parameters

Source
Type: TExpression

Overrides

TUnaryExpression.Assign(TExpression)
See Also

Reference

  • TDateTimePartExpression
  • BI.Expression


TDateTimePartExpression.FromString(String) Method

Summary

Represents method FromString(String).

Namespace: BI.Expression
Syntax
Delphi
public
 class function FromString(const S:String):TParameterExpression; override;

Parameters

S
Type: String

Return Value

Type: TParameterExpression

Overrides

TParameterExpression.FromString(String)
See Also

Reference

  • TDateTimePartExpression
  • BI.Expression


TDateTimePartExpression.ResultClass Method

Summary

Represents method ResultClass.

Namespace: BI.Expression
Syntax
Delphi
protected
 function ResultClass:TExpressionClass; override;

Return Value

Type: TExpressionClass

Overrides

TParameterExpression.ResultClass
See Also

Reference

  • TDateTimePartExpression
  • BI.Expression


TDateTimePartExpression.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

Overrides

TParameterExpression.ToString
See Also

Reference

  • TDateTimePartExpression
  • BI.Expression


TDateTimePartExpression.Value Method

Summary

Represents method Value.

Namespace: BI.Expression
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TDateTimePartExpression
  • BI.Expression


TDateTimePartExpression Fields

Fields
Name | Description
Part | Represents field Part.
Top


TDateTimePartExpression.Part Field

Summary

Represents field Part.

Namespace: BI.Expression
Syntax
Delphi
public
 Part : TDateTimePart;

Field Value

Type: TDateTimePart

See Also

Reference

  • TDateTimePartExpression
  • BI.Expression


TDateTimePartHelper Class Helper

Summary

Represents type TDateTimePartHelper.

Namespace: BI.Expression
Syntax
Delphi
type
 TDateTimePartHelper=record helper for TDateTimePart
 end;
Methods
Name | Description
AllToText | Represents method AllToText.
AsString(Integer) | Represents method AsString(Integer).
FromString(String,TDateTimePart) | Represents method FromString(String,TDateTimePart).
High | Represents method High.
Low | Represents method Low.
Max | Represents method Max.
ToCode(Integer) | Represents method ToCode(Integer).
ToString | Overloaded. Represents method ToString.
ToString(Integer) | Overloaded. Represents method ToString(Integer).
Top
Fields
Name | Description
QuarterFormat | Represents field QuarterFormat.
Top
See Also

Reference

  • BI.Expression


TDateTimePartHelper Methods

Methods
Name | Description
AllToText | Represents method AllToText.
AsString(Integer) | Represents method AsString(Integer).
FromString(String,TDateTimePart) | Represents method FromString(String,TDateTimePart).
High | Represents method High.
Low | Represents method Low.
Max | Represents method Max.
ToCode(Integer) | Represents method ToCode(Integer).
ToString | Overloaded. Represents method ToString.
ToString(Integer) | Overloaded. Represents method ToString(Integer).
Top


TDateTimePartHelper.AllToText Method

Summary

Represents method AllToText.

Namespace: BI.Expression
Syntax
Delphi
public
 class function AllToText:String; static;

Return Value

Type: String

See Also

Reference

  • TDateTimePartHelper
  • BI.Expression


TDateTimePartHelper.AsString(Integer) Method

Summary

Represents method AsString(Integer).

Namespace: BI.Expression
Syntax
Delphi
public
 function AsString(const Index:Integer):String;

Parameters

Index
Type: Integer

Return Value

Type: String

See Also

Reference

  • TDateTimePartHelper
  • BI.Expression


TDateTimePartHelper.FromString(String,TDateTimePart) Method

Summary

Represents method FromString(String,TDateTimePart).

Namespace: BI.Expression
Syntax
Delphi
public
 class function FromString(const S:String; out APart:TDateTimePart):Boolean; static;

Parameters

S
Type: String

APart
Type: TDateTimePart

Return Value

Type: Boolean

See Also

Reference

  • TDateTimePartHelper
  • BI.Expression


TDateTimePartHelper.High Method

Summary

Represents method High.

Namespace: BI.Expression
Syntax
Delphi
public
 function High:Integer;

Return Value

Type: Integer

See Also

Reference

  • TDateTimePartHelper
  • BI.Expression


TDateTimePartHelper.Low Method

Summary

Represents method Low.

Namespace: BI.Expression
Syntax
Delphi
public
 function Low: Integer;

Return Value

Type: Integer

See Also

Reference

  • TDateTimePartHelper
  • BI.Expression


TDateTimePartHelper.Max Method

Summary

Represents method Max.

Namespace: BI.Expression
Syntax
Delphi
public
 class function Max:Integer; static;

Return Value

Type: Integer

See Also

Reference

  • TDateTimePartHelper
  • BI.Expression


TDateTimePartHelper.ToCode(Integer) Method

Summary

Represents method ToCode(Integer).

Namespace: BI.Expression
Syntax
Delphi
public
 class function ToCode(const Index:Integer):String; static;

Parameters

Index
Type: Integer

Return Value

Type: String

See Also

Reference

  • TDateTimePartHelper
  • BI.Expression


TDateTimePartHelper.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String; overload;

Return Value

Type: String

See Also

Reference

  • TDateTimePartHelper
  • BI.Expression


TDateTimePartHelper.ToString(Integer) Method

Summary

Represents method ToString(Integer).

Namespace: BI.Expression
Syntax
Delphi
public
 class function ToString(const Index:Integer):String; overload; inline; static;

Parameters

Index
Type: Integer

Return Value

Type: String

See Also

Reference

  • TDateTimePartHelper
  • BI.Expression


TDateTimePartHelper Fields

Fields
Name | Description
QuarterFormat | Represents field QuarterFormat.
Top


TDateTimePartHelper.QuarterFormat Field

Summary

Represents field QuarterFormat.

Namespace: BI.Expression
Syntax
Delphi
public
 class
 var QuarterFormat:String;

Field Value

Type: String

See Also

Reference

  • TDateTimePartHelper
  • BI.Expression


TExpression Class

Summary

Represents type TExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TArrayExpression
BI.Expression.TBooleanExpression
BI.Expression.TDateTimeExpression
BI.Expression.TFloatExpression
BI.Expression.TIfExpression
BI.Expression.TIntegerExpression
BI.Expression.TOperandExpression
BI.Expression.TTextExpression
BI.Expression.TUnaryExpression
BI.Expressions.TDataItemExpression
BI.Summary.TSummaryExpression
Syntax
Delphi
type
 TExpression=class abstract
 end;

The TExpression type exposes the following members.

Methods
Show:
Name | Description
Assign(TExpression) | Represents method Assign(TExpression).
AsString | Represents method AsString.
Clone(TExpression) | Overloaded. Represents method Clone(TExpression).
Evaluate(String) | Represents method Evaluate(String).
FromString(String) | Overloaded. Represents method FromString(String).
FromString(String,TResolveProc) | Overloaded. Represents method FromString(String,TResolveProc).
FromString(String,TResolveProc,TErrorProc) | Overloaded. Represents method FromString(String,TResolveProc,TErrorProc).
Traverse(TExpressionProc) | Represents method Traverse(TExpressionProc).
Value | Represents method Value.
Top
Fields
Show:
Name | Description
Null | Represents field Null.
Top
See Also

Reference

  • BI.Expression


TExpression Methods

Methods
Name | Description
Assign(TExpression) | Represents method Assign(TExpression).
AsString | Represents method AsString.
Clone(TExpression) | Overloaded. Represents method Clone(TExpression).
Evaluate(String) | Represents method Evaluate(String).
FromString(String) | Overloaded. Represents method FromString(String).
FromString(String,TResolveProc) | Overloaded. Represents method FromString(String,TResolveProc).
FromString(String,TResolveProc,TErrorProc) | Overloaded. Represents method FromString(String,TResolveProc,TErrorProc).
Traverse(TExpressionProc) | Represents method Traverse(TExpressionProc).
Value | Represents method Value.
Top


TExpression.Assign(TExpression) Method

Summary

Represents method Assign(TExpression).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Assign(const Source:TExpression); virtual; abstract;

Parameters

Source
Type: TExpression

See Also

Reference

  • TExpression
  • BI.Expression


TExpression.AsString Method

Summary

Represents method AsString.

Namespace: BI.Expression
Syntax
Delphi
public
 function AsString:String; virtual;

Return Value

Type: String

See Also

Reference

  • TExpression
  • BI.Expression


TExpression.Clone(TExpression) Method

Summary

Represents method Clone(TExpression).

Namespace: BI.Expression
Syntax
Delphi
public
 class function Clone(const AExpression:TExpression):TExpression; overload; static;

Parameters

AExpression
Type: TExpression

Return Value

Type: TExpression

See Also

Reference

  • TExpression
  • BI.Expression


TExpression.Evaluate(String) Method

Summary

Represents method Evaluate(String).

Namespace: BI.Expression
Syntax
Delphi
public
 class function Evaluate(const S:String):TData; static;

Parameters

S
Type: String

Return Value

Type: TData

See Also

Reference

  • TExpression
  • BI.Expression


TExpression.FromString(String) Method

Summary

Represents method FromString(String).

Namespace: BI.Expression
Syntax
Delphi
public
 class function FromString(const S:String):TExpression; overload; static;

Parameters

S
Type: String

Return Value

Type: TExpression

See Also

Reference

  • TExpression
  • BI.Expression


TExpression.FromString(String,TResolveProc) Method

Summary

Represents method FromString(String,TResolveProc).

Namespace: BI.Expression
Syntax
Delphi
public
 class function FromString(const S:String;
 const Resolve:TResolveProc):TExpression; overload; static;

Parameters

S
Type: String

Resolve
Type: TResolveProc

Return Value

Type: TExpression

See Also

Reference

  • TExpression
  • BI.Expression


TExpression.FromString(String,TResolveProc,TErrorProc) Method

Summary

Represents method FromString(String,TResolveProc,TErrorProc).

Namespace: BI.Expression
Syntax
Delphi
public
 class function FromString(const S:String;
 const Resolve:TResolveProc;
 const Error:TErrorProc):TExpression; overload; static;

Parameters

S
Type: String

Resolve
Type: TResolveProc

Error
Type: TErrorProc

Return Value

Type: TExpression

See Also

Reference

  • TExpression
  • BI.Expression


TExpression.Traverse(TExpressionProc) Method

Summary

Represents method Traverse(TExpressionProc).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Traverse(const AProc:TExpressionProc); virtual;

Parameters

AProc
Type: TExpressionProc

See Also

Reference

  • TExpression
  • BI.Expression


TExpression.Value Method

Summary

Represents method Value.

Namespace: BI.Expression
Syntax
Delphi
public
 function Value:TData; virtual; abstract;

Return Value

Type: TData

See Also

Reference

  • TExpression
  • BI.Expression


TExpression Fields

Fields
Name | Description
Null | Represents field Null.
Top


TExpression.Null Field

Summary

Represents field Null.

Namespace: BI.Expression
Syntax
Delphi
public
 class var
 Null:TData;

Field Value

Type: TData

See Also

Reference

  • TExpression
  • BI.Expression


TExpressionsHelper Class Helper

Summary

Represents type TExpressionsHelper.

Namespace: BI.Expression
Syntax
Delphi
type
 TExpressionsHelper=record helper for TExpressions
 end;
Methods
Name | Description
Add(TExpression) | Overloaded. Represents method Add(TExpression).
Add(TExpression[]) | Overloaded. Represents method Add(TExpression[]).
Count | Represents method Count.
Top
See Also

Reference

  • BI.Expression


TExpressionsHelper Methods

Methods
Name | Description
Add(TExpression) | Overloaded. Represents method Add(TExpression).
Add(TExpression[]) | Overloaded. Represents method Add(TExpression[]).
Count | Represents method Count.
Top


TExpressionsHelper.Add(TExpression) Method

Summary

Represents method Add(TExpression).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Add(const AExpression:TExpression); overload;

Parameters

AExpression
Type: TExpression

See Also

Reference

  • TExpressionsHelper
  • BI.Expression


TExpressionsHelper.Add(TExpression[]) Method

Summary

Represents method Add(TExpression[]).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Add(const AExpressions:Array of TExpression); overload;

Parameters

AExpressions
Type: Array of TExpression

See Also

Reference

  • TExpressionsHelper
  • BI.Expression


TExpressionsHelper.Count Method

Summary

Represents method Count.

Namespace: BI.Expression
Syntax
Delphi
public
 function Count:Integer; inline;

Return Value

Type: Integer

See Also

Reference

  • TExpressionsHelper
  • BI.Expression


TFloatExpression Class

Summary

Represents type TFloatExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TFloatExpression
Syntax
Delphi
type
 TFloatExpression=class(TExpression)
 end;

The TFloatExpression type exposes the following members.

Constructors
Show:
Name | Description
Create(Extended) | Initializes a new instance of the TFloatExpression class.
Top
Methods
Show:
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
E | Represents method E.
Pi | Represents method Pi.
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top
Fields
Show:
Name | Description
Number | Represents field Number.
Top
See Also

Reference

  • BI.Expression


TFloatExpression Constructors

Constructors
Name | Description
Create(Extended) | Initializes a new instance of the TFloatExpression class.
Top


TFloatExpression.Create(Extended) Constructor

Summary

Initializes a new instance of the TFloatExpression class.

Namespace: BI.Expression
Syntax
Delphi
public
 Constructor Create(const AValue:Extended);

Parameters

AValue
Type: Extended

See Also

Reference

  • TFloatExpression
  • BI.Expression


TFloatExpression Methods

Methods
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
E | Represents method E.
Pi | Represents method Pi.
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top


TFloatExpression.Assign(TExpression) Method

Summary

Represents method Assign(TExpression).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Assign(const Source:TExpression); override;

Parameters

Source
Type: TExpression

Overrides

TExpression.Assign(TExpression)
See Also

Reference

  • TFloatExpression
  • BI.Expression


TFloatExpression.E Method

Summary

Represents method E.

Namespace: BI.Expression
Syntax
Delphi
public
 class function E:TFloatExpression; static;

Return Value

Type: TFloatExpression

See Also

Reference

  • TFloatExpression
  • BI.Expression


TFloatExpression.Pi Method

Summary

Represents method Pi.

Namespace: BI.Expression
Syntax
Delphi
public
 class function Pi:TFloatExpression; static;

Return Value

Type: TFloatExpression

See Also

Reference

  • TFloatExpression
  • BI.Expression


TFloatExpression.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TFloatExpression
  • BI.Expression


TFloatExpression.Value Method

Summary

Represents method Value.

Namespace: BI.Expression
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TFloatExpression
  • BI.Expression


TFloatExpression Fields

Fields
Name | Description
Number | Represents field Number.
Top


TFloatExpression.Number Field

Summary

Represents field Number.

Namespace: BI.Expression
Syntax
Delphi
public
 Number : Extended;

Field Value

Type: Extended

See Also

Reference

  • TFloatExpression
  • BI.Expression


TIfExpression Class

Summary

Represents type TIfExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TIfExpression
Syntax
Delphi
type
 TIfExpression=class(TExpression)
 end;

The TIfExpression type exposes the following members.

Constructors
Show:
Name | Description
Create(TLogicalExpression,TExpression,TExpression) | Initializes a new instance of the TIfExpression class.
Destroy | Represents the destructor of the TIfExpression class.
Top
Methods
Show:
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top
Fields
Show:
Name | Description
Condition | Represents field Condition.
ElseExpression | Represents field ElseExpression.
ThenExpression | Represents field ThenExpression.
Top
See Also

Reference

  • BI.Expression


TIfExpression Constructors

Constructors
Name | Description
Create(TLogicalExpression,TExpression,TExpression) | Initializes a new instance of the TIfExpression class.
Destroy | Represents the destructor of the TIfExpression class.
Top


TIfExpression.Create(TLogicalExpression,TExpression,TExpression) Constructor

Summary

Initializes a new instance of the TIfExpression class.

Namespace: BI.Expression
Syntax
Delphi
public
 Constructor Create(const ACondition:TLogicalExpression; const AThen,AElse:TExpression);

Parameters

ACondition
Type: TLogicalExpression

AThen
Type: TExpression

AElse
Type: TExpression

See Also

Reference

  • TIfExpression
  • BI.Expression


TIfExpression.Destroy Destructor

Summary

Represents the destructor of the TIfExpression class.

Namespace: BI.Expression
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TIfExpression
  • BI.Expression


TIfExpression Methods

Methods
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top


TIfExpression.Assign(TExpression) Method

Summary

Represents method Assign(TExpression).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Assign(const Source:TExpression); override;

Parameters

Source
Type: TExpression

Overrides

TExpression.Assign(TExpression)
See Also

Reference

  • TIfExpression
  • BI.Expression


TIfExpression.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TIfExpression
  • BI.Expression


TIfExpression.Value Method

Summary

Represents method Value.

Namespace: BI.Expression
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TIfExpression
  • BI.Expression


TIfExpression Fields

Fields
Name | Description
Condition | Represents field Condition.
ElseExpression | Represents field ElseExpression.
ThenExpression | Represents field ThenExpression.
Top


TIfExpression.Condition Field

Summary

Represents field Condition.

Namespace: BI.Expression
Syntax
Delphi
public
 Condition : TLogicalExpression;

Field Value

Type: TLogicalExpression

See Also

Reference

  • TIfExpression
  • BI.Expression


TIfExpression.ElseExpression Field

Summary

Represents field ElseExpression.

Namespace: BI.Expression
Syntax
Delphi
public
 ThenExpression,
 ElseExpression : TExpression;

Field Value

Type: TExpression

See Also

Reference

  • TIfExpression
  • BI.Expression


TIfExpression.ThenExpression Field

Summary

Represents field ThenExpression.

Namespace: BI.Expression
Syntax
Delphi
public
 ThenExpression,
 ElseExpression : TExpression;

Field Value

Type: TExpression

See Also

Reference

  • TIfExpression
  • BI.Expression


TIntegerExpression Class

Summary

Represents type TIntegerExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TIntegerExpression
Syntax
Delphi
type
 TIntegerExpression=class(TExpression)
 end;

The TIntegerExpression type exposes the following members.

Constructors
Show:
Name | Description
Create(Int64) | Initializes a new instance of the TIntegerExpression class.
Top
Methods
Show:
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top
Fields
Show:
Name | Description
Number | Represents field Number.
Top
See Also

Reference

  • BI.Expression


TIntegerExpression Constructors

Constructors
Name | Description
Create(Int64) | Initializes a new instance of the TIntegerExpression class.
Top


TIntegerExpression.Create(Int64) Constructor

Summary

Initializes a new instance of the TIntegerExpression class.

Namespace: BI.Expression
Syntax
Delphi
public
 Constructor Create(const AValue:Int64);

Parameters

AValue
Type: Int64

See Also

Reference

  • TIntegerExpression
  • BI.Expression


TIntegerExpression Methods

Methods
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top


TIntegerExpression.Assign(TExpression) Method

Summary

Represents method Assign(TExpression).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Assign(const Source:TExpression); override;

Parameters

Source
Type: TExpression

Overrides

TExpression.Assign(TExpression)
See Also

Reference

  • TIntegerExpression
  • BI.Expression


TIntegerExpression.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TIntegerExpression
  • BI.Expression


TIntegerExpression.Value Method

Summary

Represents method Value.

Namespace: BI.Expression
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TIntegerExpression
  • BI.Expression


TIntegerExpression Fields

Fields
Name | Description
Number | Represents field Number.
Top


TIntegerExpression.Number Field

Summary

Represents field Number.

Namespace: BI.Expression
Syntax
Delphi
public
 Number : Int64;

Field Value

Type: Int64

See Also

Reference

  • TIntegerExpression
  • BI.Expression


TLogicalExpression Class

Summary

Represents type TLogicalExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TOperandExpression
BI.Expression.TLogicalExpression
Syntax
Delphi
type
 TLogicalExpression=class(TOperandExpression)
 end;

The TLogicalExpression type exposes the following members.

Constructors
Show:
Name | Description
Create | Overloaded. Initializes a new instance of the TLogicalExpression class.
Create(TExpression,TLogicalOperand,TExpression) | Overloaded. Initializes a new instance of the TLogicalExpression class.
Top
Methods
Show:
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TOperandExpression.Assign(TExpression).)
Join(TLogicalExpression,TLogicalExpression,TLogicalOperand) | Represents method Join(TLogicalExpression,TLogicalExpression,TLogicalOperand).
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top
Fields
Show:
Name | Description
Operand | Represents field Operand.
Top
See Also

Reference

  • BI.Expression


TLogicalExpression Constructors

Constructors
Name | Description
Create | Overloaded. Initializes a new instance of the TLogicalExpression class.
Create(TExpression,TLogicalOperand,TExpression) | Overloaded. Initializes a new instance of the TLogicalExpression class.
Top


TLogicalExpression.Create Constructor

Summary

Initializes a new instance of the TLogicalExpression class.

Namespace: BI.Expression
Syntax
Delphi
public
 Constructor Create; overload;
See Also

Reference

  • TLogicalExpression
  • BI.Expression


TLogicalExpression.Create(TExpression,TLogicalOperand,TExpression) Constructor

Summary

Initializes a new instance of the TLogicalExpression class.

Namespace: BI.Expression
Syntax
Delphi
public
 Constructor Create(const ALeft:TExpression;
 const AOperand:TLogicalOperand;
 const ARight:TExpression); overload;

Parameters

ALeft
Type: TExpression

AOperand
Type: TLogicalOperand

ARight
Type: TExpression

See Also

Reference

  • TLogicalExpression
  • BI.Expression


TLogicalExpression Methods

Methods
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TOperandExpression.Assign(TExpression).)
Join(TLogicalExpression,TLogicalExpression,TLogicalOperand) | Represents method Join(TLogicalExpression,TLogicalExpression,TLogicalOperand).
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top


TLogicalExpression.Assign(TExpression) Method

Summary

Represents method Assign(TExpression).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Assign(const Source: TExpression); override;

Parameters

Source
Type: TExpression

Overrides

TOperandExpression.Assign(TExpression)
See Also

Reference

  • TLogicalExpression
  • BI.Expression


TLogicalExpression.Join(TLogicalExpression,TLogicalExpression,TLogicalOperand) Method

Summary

Represents method Join(TLogicalExpression,TLogicalExpression,TLogicalOperand).

Namespace: BI.Expression
Syntax
Delphi
public
 class function Join(const AOld,ANew:TLogicalExpression;
 const AOperand:TLogicalOperand=TLogicalOperand.&And):TLogicalExpression; static;

Parameters

AOld
Type: TLogicalExpression

ANew
Type: TLogicalExpression

AOperand
Type: TLogicalOperand

Return Value

Type: TLogicalExpression

See Also

Reference

  • TLogicalExpression
  • BI.Expression


TLogicalExpression.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TLogicalExpression
  • BI.Expression


TLogicalExpression.Value Method

Summary

Represents method Value.

Namespace: BI.Expression
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TLogicalExpression
  • BI.Expression


TLogicalExpression Fields

Fields
Name | Description
Operand | Represents field Operand.
Top


TLogicalExpression.Operand Field

Summary

Represents field Operand.

Namespace: BI.Expression
Syntax
Delphi
public
 Operand : TLogicalOperand;

Field Value

Type: TLogicalOperand

See Also

Reference

  • TLogicalExpression
  • BI.Expression


TLogicalOperandHelper Class Helper

Summary

Represents type TLogicalOperandHelper.

Namespace: BI.Expression
Syntax
Delphi
type
 TLogicalOperandHelper=record helper for TLogicalOperand
 end;
Methods
Name | Description
FromString(String,TLogicalOperand) | Represents method FromString(String,TLogicalOperand).
ToString | Represents method ToString.
Top
See Also

Reference

  • BI.Expression


TLogicalOperandHelper Methods

Methods
Name | Description
FromString(String,TLogicalOperand) | Represents method FromString(String,TLogicalOperand).
ToString | Represents method ToString.
Top


TLogicalOperandHelper.FromString(String,TLogicalOperand) Method

Summary

Represents method FromString(String,TLogicalOperand).

Namespace: BI.Expression
Syntax
Delphi
public
 class function FromString(const S:String; out Operand:TLogicalOperand):Boolean; static;

Parameters

S
Type: String

Operand
Type: TLogicalOperand

Return Value

Type: Boolean

See Also

Reference

  • TLogicalOperandHelper
  • BI.Expression


TLogicalOperandHelper.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String;

Return Value

Type: String

See Also

Reference

  • TLogicalOperandHelper
  • BI.Expression


TMathExpression Class

Summary

Represents type TMathExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TUnaryExpression
BI.Expression.TParameterExpression
BI.Expression.TMathExpression
Syntax
Delphi
type
 TMathExpression=class(TParameterExpression)
 end;

The TMathExpression type exposes the following members.

Methods
Show:
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TUnaryExpression.Assign(TExpression).)
FromString(String) | Represents method FromString(String). (Overrides TParameterExpression.FromString(String).)
ResultClass | Represents method ResultClass. (Overrides TParameterExpression.ResultClass.)
SetExpression(TExpression) | Represents method SetExpression(TExpression). (Overrides TParameterExpression.SetExpression(TExpression).)
ToString | Represents method ToString. (Overrides TParameterExpression.ToString.)
Value | Represents method Value. (Overrides TExpression.Value.)
Top
Fields
Show:
Name | Description
Operand | Represents field Operand.
Top
See Also

Reference

  • BI.Expression


TMathExpression Methods

Methods
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TUnaryExpression.Assign(TExpression).)
FromString(String) | Represents method FromString(String). (Overrides TParameterExpression.FromString(String).)
ResultClass | Represents method ResultClass. (Overrides TParameterExpression.ResultClass.)
SetExpression(TExpression) | Represents method SetExpression(TExpression). (Overrides TParameterExpression.SetExpression(TExpression).)
ToString | Represents method ToString. (Overrides TParameterExpression.ToString.)
Value | Represents method Value. (Overrides TExpression.Value.)
Top


TMathExpression.Assign(TExpression) Method

Summary

Represents method Assign(TExpression).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Assign(const Source:TExpression); override;

Parameters

Source
Type: TExpression

Overrides

TUnaryExpression.Assign(TExpression)
See Also

Reference

  • TMathExpression
  • BI.Expression


TMathExpression.FromString(String) Method

Summary

Represents method FromString(String).

Namespace: BI.Expression
Syntax
Delphi
public
 class function FromString(const S:String):TParameterExpression; override;

Parameters

S
Type: String

Return Value

Type: TParameterExpression

Overrides

TParameterExpression.FromString(String)
See Also

Reference

  • TMathExpression
  • BI.Expression


TMathExpression.ResultClass Method

Summary

Represents method ResultClass.

Namespace: BI.Expression
Syntax
Delphi
protected
 function ResultClass:TExpressionClass; override;

Return Value

Type: TExpressionClass

Overrides

TParameterExpression.ResultClass
See Also

Reference

  • TMathExpression
  • BI.Expression


TMathExpression.SetExpression(TExpression) Method

Summary

Represents method SetExpression(TExpression).

Namespace: BI.Expression
Syntax
Delphi
protected
 procedure SetExpression(const Value:TExpression); override;

Parameters

Value
Type: TExpression

Overrides

TParameterExpression.SetExpression(TExpression)
See Also

Reference

  • TMathExpression
  • BI.Expression


TMathExpression.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

Overrides

TParameterExpression.ToString
See Also

Reference

  • TMathExpression
  • BI.Expression


TMathExpression.Value Method

Summary

Represents method Value.

Namespace: BI.Expression
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TMathExpression
  • BI.Expression


TMathExpression Fields

Fields
Name | Description
Operand | Represents field Operand.
Top


TMathExpression.Operand Field

Summary

Represents field Operand.

Namespace: BI.Expression
Syntax
Delphi
public
 Operand : TMathOperand;

Field Value

Type: TMathOperand

See Also

Reference

  • TMathExpression
  • BI.Expression


TMathOperandHelper Class Helper

Summary

Represents type TMathOperandHelper.

Namespace: BI.Expression
Syntax
Delphi
type
 TMathOperandHelper=record helper for TMathOperand
 end;
Methods
Name | Description
FromString(String,TMathOperand) | Represents method FromString(String,TMathOperand).
ToString | Represents method ToString.
Top
See Also

Reference

  • BI.Expression


TMathOperandHelper Methods

Methods
Name | Description
FromString(String,TMathOperand) | Represents method FromString(String,TMathOperand).
ToString | Represents method ToString.
Top


TMathOperandHelper.FromString(String,TMathOperand) Method

Summary

Represents method FromString(String,TMathOperand).

Namespace: BI.Expression
Syntax
Delphi
public
 class function FromString(const S:String; out Operand:TMathOperand):Boolean; static;

Parameters

S
Type: String

Operand
Type: TMathOperand

Return Value

Type: Boolean

See Also

Reference

  • TMathOperandHelper
  • BI.Expression


TMathOperandHelper.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String;

Return Value

Type: String

See Also

Reference

  • TMathOperandHelper
  • BI.Expression


TOperandExpression Class

Summary

Represents type TOperandExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TOperandExpression
BI.Expression.TArithmeticExpression
BI.Expression.TLogicalExpression
BI.Expression.TTextLogicalExpression
Syntax
Delphi
type
 TOperandExpression=class abstract (TExpression)
 end;

The TOperandExpression type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TOperandExpression class.
Top
Methods
Show:
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
Part(TExpression) | Represents method Part(TExpression).
Traverse(TExpressionProc) | Represents method Traverse(TExpressionProc). (Overrides TExpression.Traverse(TExpressionProc).)
Top
Fields
Show:
Name | Description
Left | Represents field Left.
Right | Represents field Right.
Top
See Also

Reference

  • BI.Expression


TOperandExpression Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TOperandExpression class.
Top


TOperandExpression.Destroy Destructor

Summary

Represents the destructor of the TOperandExpression class.

Namespace: BI.Expression
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TOperandExpression
  • BI.Expression


TOperandExpression Methods

Methods
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
Part(TExpression) | Represents method Part(TExpression).
Traverse(TExpressionProc) | Represents method Traverse(TExpressionProc). (Overrides TExpression.Traverse(TExpressionProc).)
Top


TOperandExpression.Assign(TExpression) Method

Summary

Represents method Assign(TExpression).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Assign(const Source:TExpression); override;

Parameters

Source
Type: TExpression

Overrides

TExpression.Assign(TExpression)
See Also

Reference

  • TOperandExpression
  • BI.Expression


TOperandExpression.Part(TExpression) Method

Summary

Represents method Part(TExpression).

Namespace: BI.Expression
Syntax
Delphi
protected
 function Part(const AExpression:TExpression):String;

Parameters

AExpression
Type: TExpression

Return Value

Type: String

See Also

Reference

  • TOperandExpression
  • BI.Expression


TOperandExpression.Traverse(TExpressionProc) Method

Summary

Represents method Traverse(TExpressionProc).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Traverse(const AProc:TExpressionProc); override;

Parameters

AProc
Type: TExpressionProc

Overrides

TExpression.Traverse(TExpressionProc)
See Also

Reference

  • TOperandExpression
  • BI.Expression


TOperandExpression Fields

Fields
Name | Description
Left | Represents field Left.
Right | Represents field Right.
Top


TOperandExpression.Left Field

Summary

Represents field Left.

Namespace: BI.Expression
Syntax
Delphi
public
 Left : TExpression;

Field Value

Type: TExpression

See Also

Reference

  • TOperandExpression
  • BI.Expression


TOperandExpression.Right Field

Summary

Represents field Right.

Namespace: BI.Expression
Syntax
Delphi
public
 Right : TExpression;

Field Value

Type: TExpression

See Also

Reference

  • TOperandExpression
  • BI.Expression


TParameterExpression Class

Summary

Represents type TParameterExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TUnaryExpression
BI.Expression.TParameterExpression
BI.Expression.TDateTimePartExpression
BI.Expression.TMathExpression
BI.Expression.TTextOperandExpression
BI.Expression.TUnaryDateTimeExpression
BI.Expression.TUnaryTextExpression
BI.Expressions.TIsNullData
BI.Expressions.TParameterExpressionAccess
Syntax
Delphi
type
 TParameterExpression=class(TUnaryExpression)
 end;

The TParameterExpression type exposes the following members.

Constructors
Show:
Name | Description
Create(TData[]) | Overloaded. Initializes a new instance of the TParameterExpression class.
Top
Properties
Show:
Name | Description
Parameters | Represents property Parameters.
Top
Methods
Show:
Name | Description
Call(TExpressions) | Represents method Call(TExpressions).
FromString(String) | Represents method FromString(String).
ResultClass | Represents method ResultClass.
SetExpression(TExpression) | Represents method SetExpression(TExpression). (Overrides TUnaryExpression.SetExpression(TExpression).)
ToString | Represents method ToString.
Top
Fields
Show:
Name | Description
FParams | Represents field FParams.
Registered | Represents field Registered.
Top
See Also

Reference

  • BI.Expression


TParameterExpression Constructors

Constructors
Name | Description
Create(TData[]) | Overloaded. Initializes a new instance of the TParameterExpression class.
Top


TParameterExpression.Create(TData[]) Constructor

Summary

Initializes a new instance of the TParameterExpression class.

Namespace: BI.Expression
Syntax
Delphi
public
 Constructor Create(const AParameters:Array of TData); overload;

Parameters

AParameters
Type: Array of TData

See Also

Reference

  • TParameterExpression
  • BI.Expression


TParameterExpression Properties

Properties
Name | Description
Parameters | Represents property Parameters.
Top


TParameterExpression.Parameters Property

Summary

Represents property Parameters.

Namespace: BI.Expression
Syntax
Delphi
public
 property Parameters:TArrayExpression read FParams;

Property Value

Type: TArrayExpression

See Also

Reference

  • TParameterExpression
  • BI.Expression


TParameterExpression Methods

Methods
Name | Description
Call(TExpressions) | Represents method Call(TExpressions).
FromString(String) | Represents method FromString(String).
ResultClass | Represents method ResultClass.
SetExpression(TExpression) | Represents method SetExpression(TExpression). (Overrides TUnaryExpression.SetExpression(TExpression).)
ToString | Represents method ToString.
Top


TParameterExpression.Call(TExpressions) Method

Summary

Represents method Call(TExpressions).

Namespace: BI.Expression
Syntax
Delphi
public
 class function Call(const AParameters:TExpressions):TExpression; static;

Parameters

AParameters
Type: TExpressions

Return Value

Type: TExpression

See Also

Reference

  • TParameterExpression
  • BI.Expression


TParameterExpression.FromString(String) Method

Summary

Represents method FromString(String).

Namespace: BI.Expression
Syntax
Delphi
public
 class function FromString(const S:String):TParameterExpression; virtual;

Parameters

S
Type: String

Return Value

Type: TParameterExpression

See Also

Reference

  • TParameterExpression
  • BI.Expression


TParameterExpression.ResultClass Method

Summary

Represents method ResultClass.

Namespace: BI.Expression
Syntax
Delphi
protected
 function ResultClass:TExpressionClass; virtual; abstract;

Return Value

Type: TExpressionClass

See Also

Reference

  • TParameterExpression
  • BI.Expression


TParameterExpression.SetExpression(TExpression) Method

Summary

Represents method SetExpression(TExpression).

Namespace: BI.Expression
Syntax
Delphi
protected
 procedure SetExpression(const Value:TExpression); override;

Parameters

Value
Type: TExpression

Overrides

TUnaryExpression.SetExpression(TExpression)
See Also

Reference

  • TParameterExpression
  • BI.Expression


TParameterExpression.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TParameterExpression
  • BI.Expression


TParameterExpression Fields

Fields
Name | Description
FParams | Represents field FParams.
Registered | Represents field Registered.
Top


TParameterExpression.FParams Field

Summary

Represents field FParams.

Namespace: BI.Expression
Syntax
Delphi
protected
 FParams : TArrayExpression;

Field Value

Type: TArrayExpression

See Also

Reference

  • TParameterExpression
  • BI.Expression


TParameterExpression.Registered Field

Summary

Represents field Registered.

Namespace: BI.Expression
Syntax
Delphi
public
 class var
 Registered : TParameterExpressions;

Field Value

Type: TParameterExpressions

See Also

Reference

  • TParameterExpression
  • BI.Expression


TParameterExpressionsHelper Class Helper

Summary

Represents type TParameterExpressionsHelper.

Namespace: BI.Expression
Syntax
Delphi
type
 TParameterExpressionsHelper=record helper for TParameterExpressions
 end;
Methods
Name | Description
Add(TParameterExpressionClass) | Represents method Add(TParameterExpressionClass).
IndexOf(TParameterExpressionClass) | Represents method IndexOf(TParameterExpressionClass).
Remove(TParameterExpressionClass) | Represents method Remove(TParameterExpressionClass).
Top
See Also

Reference

  • BI.Expression


TParameterExpressionsHelper Methods

Methods
Name | Description
Add(TParameterExpressionClass) | Represents method Add(TParameterExpressionClass).
IndexOf(TParameterExpressionClass) | Represents method IndexOf(TParameterExpressionClass).
Remove(TParameterExpressionClass) | Represents method Remove(TParameterExpressionClass).
Top


TParameterExpressionsHelper.Add(TParameterExpressionClass) Method

Summary

Represents method Add(TParameterExpressionClass).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Add(const AClass:TParameterExpressionClass);

Parameters

AClass
Type: TParameterExpressionClass

See Also

Reference

  • TParameterExpressionsHelper
  • BI.Expression


TParameterExpressionsHelper.IndexOf(TParameterExpressionClass) Method

Summary

Represents method IndexOf(TParameterExpressionClass).

Namespace: BI.Expression
Syntax
Delphi
public
 function IndexOf(const AClass:TParameterExpressionClass):Integer;

Parameters

AClass
Type: TParameterExpressionClass

Return Value

Type: Integer

See Also

Reference

  • TParameterExpressionsHelper
  • BI.Expression


TParameterExpressionsHelper.Remove(TParameterExpressionClass) Method

Summary

Represents method Remove(TParameterExpressionClass).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Remove(const AClass:TParameterExpressionClass);

Parameters

AClass
Type: TParameterExpressionClass

See Also

Reference

  • TParameterExpressionsHelper
  • BI.Expression


TTextExpression Class

Summary

Represents type TTextExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TTextExpression
Syntax
Delphi
type
 TTextExpression=class(TExpression)
 end;

The TTextExpression type exposes the following members.

Constructors
Show:
Name | Description
Create(String) | Initializes a new instance of the TTextExpression class.
Top
Methods
Show:
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top
Fields
Show:
Name | Description
Text | Represents field Text.
Top
See Also

Reference

  • BI.Expression


TTextExpression Constructors

Constructors
Name | Description
Create(String) | Initializes a new instance of the TTextExpression class.
Top


TTextExpression.Create(String) Constructor

Summary

Initializes a new instance of the TTextExpression class.

Namespace: BI.Expression
Syntax
Delphi
public
 Constructor Create(const AValue:String);

Parameters

AValue
Type: String

See Also

Reference

  • TTextExpression
  • BI.Expression


TTextExpression Methods

Methods
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top


TTextExpression.Assign(TExpression) Method

Summary

Represents method Assign(TExpression).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Assign(const Source:TExpression); override;

Parameters

Source
Type: TExpression

Overrides

TExpression.Assign(TExpression)
See Also

Reference

  • TTextExpression
  • BI.Expression


TTextExpression.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TTextExpression
  • BI.Expression


TTextExpression.Value Method

Summary

Represents method Value.

Namespace: BI.Expression
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TTextExpression
  • BI.Expression


TTextExpression Fields

Fields
Name | Description
Text | Represents field Text.
Top


TTextExpression.Text Field

Summary

Represents field Text.

Namespace: BI.Expression
Syntax
Delphi
public
 Text : String;

Field Value

Type: String

See Also

Reference

  • TTextExpression
  • BI.Expression


TTextLogicalExpression Class

Summary

Represents type TTextLogicalExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TOperandExpression
BI.Expression.TTextLogicalExpression
Syntax
Delphi
type
 TTextLogicalExpression=class(TOperandExpression)
 end;

The TTextLogicalExpression type exposes the following members.

Constructors
Show:
Name | Description
Create(TExpression,TTextLogicalOperand,TExpression) | Initializes a new instance of the TTextLogicalExpression class.
Top
Properties
Show:
Name | Description
CaseSensitive | Represents property CaseSensitive.
Top
Methods
Show:
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TOperandExpression.Assign(TExpression).)
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top
Fields
Show:
Name | Description
Operand | Represents field Operand.
Top
See Also

Reference

  • BI.Expression


TTextLogicalExpression Constructors

Constructors
Name | Description
Create(TExpression,TTextLogicalOperand,TExpression) | Initializes a new instance of the TTextLogicalExpression class.
Top


TTextLogicalExpression.Create(TExpression,TTextLogicalOperand,TExpression) Constructor

Summary

Initializes a new instance of the TTextLogicalExpression class.

Namespace: BI.Expression
Syntax
Delphi
public
 Constructor Create(const ALeft:TExpression; const AOperand:TTextLogicalOperand; const ARight:TExpression);

Parameters

ALeft
Type: TExpression

AOperand
Type: TTextLogicalOperand

ARight
Type: TExpression

See Also

Reference

  • TTextLogicalExpression
  • BI.Expression


TTextLogicalExpression Properties

Properties
Name | Description
CaseSensitive | Represents property CaseSensitive.
Top


TTextLogicalExpression.CaseSensitive Property

Summary

Represents property CaseSensitive.

Namespace: BI.Expression
Syntax
Delphi
public
 property CaseSensitive:Boolean read FCase write FCase default False;

Property Value

Type: Boolean

See Also

Reference

  • TTextLogicalExpression
  • BI.Expression


TTextLogicalExpression Methods

Methods
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TOperandExpression.Assign(TExpression).)
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top


TTextLogicalExpression.Assign(TExpression) Method

Summary

Represents method Assign(TExpression).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Assign(const Source:TExpression); override;

Parameters

Source
Type: TExpression

Overrides

TOperandExpression.Assign(TExpression)
See Also

Reference

  • TTextLogicalExpression
  • BI.Expression


TTextLogicalExpression.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TTextLogicalExpression
  • BI.Expression


TTextLogicalExpression.Value Method

Summary

Represents method Value.

Namespace: BI.Expression
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TTextLogicalExpression
  • BI.Expression


TTextLogicalExpression Fields

Fields
Name | Description
Operand | Represents field Operand.
Top


TTextLogicalExpression.Operand Field

Summary

Represents field Operand.

Namespace: BI.Expression
Syntax
Delphi
public
 Operand : TTextLogicalOperand;

Field Value

Type: TTextLogicalOperand

See Also

Reference

  • TTextLogicalExpression
  • BI.Expression


TTextLogicalOperandHelper Class Helper

Summary

Represents type TTextLogicalOperandHelper.

Namespace: BI.Expression
Syntax
Delphi
type
 TTextLogicalOperandHelper=record helper for TTextLogicalOperand
 end;
Methods
Name | Description
FromString(String,TTextLogicalOperand) | Represents method FromString(String,TTextLogicalOperand).
ToString | Represents method ToString.
Top
See Also

Reference

  • BI.Expression


TTextLogicalOperandHelper Methods

Methods
Name | Description
FromString(String,TTextLogicalOperand) | Represents method FromString(String,TTextLogicalOperand).
ToString | Represents method ToString.
Top


TTextLogicalOperandHelper.FromString(String,TTextLogicalOperand) Method

Summary

Represents method FromString(String,TTextLogicalOperand).

Namespace: BI.Expression
Syntax
Delphi
public
 class function FromString(const S:String; out Operand:TTextLogicalOperand):Boolean; static;

Parameters

S
Type: String

Operand
Type: TTextLogicalOperand

Return Value

Type: Boolean

See Also

Reference

  • TTextLogicalOperandHelper
  • BI.Expression


TTextLogicalOperandHelper.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String;

Return Value

Type: String

See Also

Reference

  • TTextLogicalOperandHelper
  • BI.Expression


TTextOperandExpression Class

Summary

Represents type TTextOperandExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TUnaryExpression
BI.Expression.TParameterExpression
BI.Expression.TTextOperandExpression
Syntax
Delphi
type
 TTextOperandExpression=class(TParameterExpression)
 end;

The TTextOperandExpression type exposes the following members.

Methods
Show:
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TUnaryExpression.Assign(TExpression).)
AsString | Represents method AsString. (Overrides TExpression.AsString.)
FromString(String) | Represents method FromString(String). (Overrides TParameterExpression.FromString(String).)
ResultClass | Represents method ResultClass. (Overrides TParameterExpression.ResultClass.)
ToString | Represents method ToString. (Overrides TParameterExpression.ToString.)
Value | Represents method Value. (Overrides TExpression.Value.)
Top
Fields
Show:
Name | Description
Operand | Represents field Operand.
Top
See Also

Reference

  • BI.Expression


TTextOperandExpression Methods

Methods
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TUnaryExpression.Assign(TExpression).)
AsString | Represents method AsString. (Overrides TExpression.AsString.)
FromString(String) | Represents method FromString(String). (Overrides TParameterExpression.FromString(String).)
ResultClass | Represents method ResultClass. (Overrides TParameterExpression.ResultClass.)
ToString | Represents method ToString. (Overrides TParameterExpression.ToString.)
Value | Represents method Value. (Overrides TExpression.Value.)
Top


TTextOperandExpression.Assign(TExpression) Method

Summary

Represents method Assign(TExpression).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Assign(const Source:TExpression); override;

Parameters

Source
Type: TExpression

Overrides

TUnaryExpression.Assign(TExpression)
See Also

Reference

  • TTextOperandExpression
  • BI.Expression


TTextOperandExpression.AsString Method

Summary

Represents method AsString.

Namespace: BI.Expression
Syntax
Delphi
public
 function AsString:String; override;

Return Value

Type: String

Overrides

TExpression.AsString
See Also

Reference

  • TTextOperandExpression
  • BI.Expression


TTextOperandExpression.FromString(String) Method

Summary

Represents method FromString(String).

Namespace: BI.Expression
Syntax
Delphi
public
 class function FromString(const S:String):TParameterExpression; override;

Parameters

S
Type: String

Return Value

Type: TParameterExpression

Overrides

TParameterExpression.FromString(String)
See Also

Reference

  • TTextOperandExpression
  • BI.Expression


TTextOperandExpression.ResultClass Method

Summary

Represents method ResultClass.

Namespace: BI.Expression
Syntax
Delphi
protected
 function ResultClass:TExpressionClass; override;

Return Value

Type: TExpressionClass

Overrides

TParameterExpression.ResultClass
See Also

Reference

  • TTextOperandExpression
  • BI.Expression


TTextOperandExpression.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

Overrides

TParameterExpression.ToString
See Also

Reference

  • TTextOperandExpression
  • BI.Expression


TTextOperandExpression.Value Method

Summary

Represents method Value.

Namespace: BI.Expression
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TTextOperandExpression
  • BI.Expression


TTextOperandExpression Fields

Fields
Name | Description
Operand | Represents field Operand.
Top


TTextOperandExpression.Operand Field

Summary

Represents field Operand.

Namespace: BI.Expression
Syntax
Delphi
public
 Operand : TTextOperand;

Field Value

Type: TTextOperand

See Also

Reference

  • TTextOperandExpression
  • BI.Expression


TTextOperandHelper Class Helper

Summary

Represents type TTextOperandHelper.

Namespace: BI.Expression
Syntax
Delphi
type
 TTextOperandHelper=record helper for TTextOperand
 end;
Methods
Name | Description
FromString(String,TTextOperand) | Represents method FromString(String,TTextOperand).
ToString | Represents method ToString.
Top
See Also

Reference

  • BI.Expression


TTextOperandHelper Methods

Methods
Name | Description
FromString(String,TTextOperand) | Represents method FromString(String,TTextOperand).
ToString | Represents method ToString.
Top


TTextOperandHelper.FromString(String,TTextOperand) Method

Summary

Represents method FromString(String,TTextOperand).

Namespace: BI.Expression
Syntax
Delphi
public
 class function FromString(const S:String; out Operand:TTextOperand):Boolean; static;

Parameters

S
Type: String

Operand
Type: TTextOperand

Return Value

Type: Boolean

See Also

Reference

  • TTextOperandHelper
  • BI.Expression


TTextOperandHelper.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String;

Return Value

Type: String

See Also

Reference

  • TTextOperandHelper
  • BI.Expression


TTextUnaryOperandHelper Class Helper

Summary

Represents type TTextUnaryOperandHelper.

Namespace: BI.Expression
Syntax
Delphi
type
 TTextUnaryOperandHelper=record helper for TTextUnaryOperand
 end;
Methods
Name | Description
FromString(String,TTextUnaryOperand) | Represents method FromString(String,TTextUnaryOperand).
ToString | Represents method ToString.
Top
See Also

Reference

  • BI.Expression


TTextUnaryOperandHelper Methods

Methods
Name | Description
FromString(String,TTextUnaryOperand) | Represents method FromString(String,TTextUnaryOperand).
ToString | Represents method ToString.
Top


TTextUnaryOperandHelper.FromString(String,TTextUnaryOperand) Method

Summary

Represents method FromString(String,TTextUnaryOperand).

Namespace: BI.Expression
Syntax
Delphi
public
 class function FromString(const S:String; out Operand:TTextUnaryOperand):Boolean; static;

Parameters

S
Type: String

Operand
Type: TTextUnaryOperand

Return Value

Type: Boolean

See Also

Reference

  • TTextUnaryOperandHelper
  • BI.Expression


TTextUnaryOperandHelper.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String;

Return Value

Type: String

See Also

Reference

  • TTextUnaryOperandHelper
  • BI.Expression


TTimeExpression Class

Summary

Represents type TTimeExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TUnaryExpression
BI.Expression.TParameterExpression
BI.Expression.TUnaryDateTimeExpression
BI.Expression.TTimeExpression
Syntax
Delphi
type
 TTimeExpression=class(TUnaryDateTimeExpression)
 end;

The TTimeExpression type exposes the following members.

Methods
Show:
Name | Description
FromData(TData) | Represents method FromData(TData).
FromString(String) | Represents method FromString(String). (Overrides TParameterExpression.FromString(String).)
ToString | Represents method ToString. (Overrides TParameterExpression.ToString.)
Value | Represents method Value. (Overrides TExpression.Value.)
Top
See Also

Reference

  • BI.Expression


TTimeExpression Methods

Methods
Name | Description
FromData(TData) | Represents method FromData(TData).
FromString(String) | Represents method FromString(String). (Overrides TParameterExpression.FromString(String).)
ToString | Represents method ToString. (Overrides TParameterExpression.ToString.)
Value | Represents method Value. (Overrides TExpression.Value.)
Top


TTimeExpression.FromData(TData) Method

Summary

Represents method FromData(TData).

Namespace: BI.Expression
Syntax
Delphi
public
 class function FromData(const Value:TData):TDateTime; static;

Parameters

Value
Type: System.Void

Return Value

Type: TDateTime

See Also

Reference

  • TTimeExpression
  • BI.Expression


TTimeExpression.FromString(String) Method

Summary

Represents method FromString(String).

Namespace: BI.Expression
Syntax
Delphi
public
 class function FromString(const S:String):TParameterExpression; override;

Parameters

S
Type: String

Return Value

Type: TParameterExpression

Overrides

TParameterExpression.FromString(String)
See Also

Reference

  • TTimeExpression
  • BI.Expression


TTimeExpression.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

Overrides

TParameterExpression.ToString
See Also

Reference

  • TTimeExpression
  • BI.Expression


TTimeExpression.Value Method

Summary

Represents method Value.

Namespace: BI.Expression
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TTimeExpression
  • BI.Expression


TUnaryDateTimeExpression Class

Summary

Represents type TUnaryDateTimeExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TUnaryExpression
BI.Expression.TParameterExpression
BI.Expression.TUnaryDateTimeExpression
BI.Expression.TDateExpression
BI.Expression.TTimeExpression
Syntax
Delphi
type
 TUnaryDateTimeExpression=class(TParameterExpression)
 end;

The TUnaryDateTimeExpression type exposes the following members.

Methods
Show:
Name | Description
ResultClass | Represents method ResultClass. (Overrides TParameterExpression.ResultClass.)
Top
See Also

Reference

  • BI.Expression


TUnaryDateTimeExpression Methods

Methods
Name | Description
ResultClass | Represents method ResultClass. (Overrides TParameterExpression.ResultClass.)
Top


TUnaryDateTimeExpression.ResultClass Method

Summary

Represents method ResultClass.

Namespace: BI.Expression
Syntax
Delphi
protected
 function ResultClass:TExpressionClass; override;

Return Value

Type: TExpressionClass

Overrides

TParameterExpression.ResultClass
See Also

Reference

  • TUnaryDateTimeExpression
  • BI.Expression


TUnaryExpression Class

Summary

Represents type TUnaryExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TUnaryExpression
BI.Expression.TParameterExpression
BI.Expression.TUnaryNotExpression
BI.Expressions.TColumnExpression
Syntax
Delphi
type
 TUnaryExpression=class abstract(TExpression)
 end;

The TUnaryExpression type exposes the following members.

Constructors
Show:
Name | Description
Create(TExpression) | Overloaded. Initializes a new instance of the TUnaryExpression class.
Destroy | Represents the destructor of the TUnaryExpression class.
Top
Properties
Show:
Name | Description
Expression | Represents property Expression.
Top
Methods
Show:
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
Traverse(TExpressionProc) | Represents method Traverse(TExpressionProc). (Overrides TExpression.Traverse(TExpressionProc).)
Top
See Also

Reference

  • BI.Expression


TUnaryExpression Constructors

Constructors
Name | Description
Create(TExpression) | Overloaded. Initializes a new instance of the TUnaryExpression class.
Destroy | Represents the destructor of the TUnaryExpression class.
Top


TUnaryExpression.Create(TExpression) Constructor

Summary

Initializes a new instance of the TUnaryExpression class.

Namespace: BI.Expression
Syntax
Delphi
public
 Constructor Create(const AExpression:TExpression); overload;

Parameters

AExpression
Type: TExpression

See Also

Reference

  • TUnaryExpression
  • BI.Expression


TUnaryExpression.Destroy Destructor

Summary

Represents the destructor of the TUnaryExpression class.

Namespace: BI.Expression
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TUnaryExpression
  • BI.Expression


TUnaryExpression Properties

Properties
Name | Description
Expression | Represents property Expression.
Top


TUnaryExpression.Expression Property

Summary

Represents property Expression.

Namespace: BI.Expression
Syntax
Delphi
public
 property Expression : TExpression read FExpression write SetExpression;

Property Value

Type: TExpression

See Also

Reference

  • TUnaryExpression
  • BI.Expression


TUnaryExpression Methods

Methods
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
Traverse(TExpressionProc) | Represents method Traverse(TExpressionProc). (Overrides TExpression.Traverse(TExpressionProc).)
Top


TUnaryExpression.Assign(TExpression) Method

Summary

Represents method Assign(TExpression).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Assign(const Source:TExpression); override;

Parameters

Source
Type: TExpression

Overrides

TExpression.Assign(TExpression)
See Also

Reference

  • TUnaryExpression
  • BI.Expression


TUnaryExpression.Traverse(TExpressionProc) Method

Summary

Represents method Traverse(TExpressionProc).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Traverse(const AProc:TExpressionProc); override;

Parameters

AProc
Type: TExpressionProc

Overrides

TExpression.Traverse(TExpressionProc)
See Also

Reference

  • TUnaryExpression
  • BI.Expression


TUnaryNotExpression Class

Summary

Represents type TUnaryNotExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TUnaryExpression
BI.Expression.TUnaryNotExpression
Syntax
Delphi
type
 TUnaryNotExpression=class(TUnaryExpression)
 end;

The TUnaryNotExpression type exposes the following members.

Methods
Show:
Name | Description
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top
See Also

Reference

  • BI.Expression


TUnaryNotExpression Methods

Methods
Name | Description
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top


TUnaryNotExpression.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TUnaryNotExpression
  • BI.Expression


TUnaryNotExpression.Value Method

Summary

Represents method Value.

Namespace: BI.Expression
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TUnaryNotExpression
  • BI.Expression


TUnaryTextExpression Class

Summary

Represents type TUnaryTextExpression.

Namespace: BI.Expression
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TUnaryExpression
BI.Expression.TParameterExpression
BI.Expression.TUnaryTextExpression
Syntax
Delphi
type
 TUnaryTextExpression=class(TParameterExpression)
 end;

The TUnaryTextExpression type exposes the following members.

Methods
Show:
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TUnaryExpression.Assign(TExpression).)
FromString(String) | Represents method FromString(String). (Overrides TParameterExpression.FromString(String).)
ResultClass | Represents method ResultClass. (Overrides TParameterExpression.ResultClass.)
ToString | Represents method ToString. (Overrides TParameterExpression.ToString.)
Value | Represents method Value. (Overrides TExpression.Value.)
Top
Fields
Show:
Name | Description
Operand | Represents field Operand.
Top
See Also

Reference

  • BI.Expression


TUnaryTextExpression Methods

Methods
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TUnaryExpression.Assign(TExpression).)
FromString(String) | Represents method FromString(String). (Overrides TParameterExpression.FromString(String).)
ResultClass | Represents method ResultClass. (Overrides TParameterExpression.ResultClass.)
ToString | Represents method ToString. (Overrides TParameterExpression.ToString.)
Value | Represents method Value. (Overrides TExpression.Value.)
Top


TUnaryTextExpression.Assign(TExpression) Method

Summary

Represents method Assign(TExpression).

Namespace: BI.Expression
Syntax
Delphi
public
 procedure Assign(const Source:TExpression); override;

Parameters

Source
Type: TExpression

Overrides

TUnaryExpression.Assign(TExpression)
See Also

Reference

  • TUnaryTextExpression
  • BI.Expression


TUnaryTextExpression.FromString(String) Method

Summary

Represents method FromString(String).

Namespace: BI.Expression
Syntax
Delphi
public
 class function FromString(const S:String):TParameterExpression; override;

Parameters

S
Type: String

Return Value

Type: TParameterExpression

Overrides

TParameterExpression.FromString(String)
See Also

Reference

  • TUnaryTextExpression
  • BI.Expression


TUnaryTextExpression.ResultClass Method

Summary

Represents method ResultClass.

Namespace: BI.Expression
Syntax
Delphi
protected
 function ResultClass:TExpressionClass; override;

Return Value

Type: TExpressionClass

Overrides

TParameterExpression.ResultClass
See Also

Reference

  • TUnaryTextExpression
  • BI.Expression


TUnaryTextExpression.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expression
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

Overrides

TParameterExpression.ToString
See Also

Reference

  • TUnaryTextExpression
  • BI.Expression


TUnaryTextExpression.Value Method

Summary

Represents method Value.

Namespace: BI.Expression
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TUnaryTextExpression
  • BI.Expression


TUnaryTextExpression Fields

Fields
Name | Description
Operand | Represents field Operand.
Top


TUnaryTextExpression.Operand Field

Summary

Represents field Operand.

Namespace: BI.Expression
Syntax
Delphi
public
 Operand : TTextUnaryOperand;

Field Value

Type: TTextUnaryOperand

See Also

Reference

  • TUnaryTextExpression
  • BI.Expression


BI.Expression Records

Records
Name | Description
TParser | Represents type TParser.
Top


TParser Record

Summary

Represents type TParser.

Namespace: BI.Expression
Syntax
Delphi
type
 TParser=record
 end;

The TParser type exposes the following members.

Constructors
Show:
Name | Description
Create(String,TResolveProc,TErrorProc) | Initializes a new instance of the TParser class.
Top
Methods
Show:
Name | Description
FromString | Represents method FromString.
Top
See Also

Reference

  • BI.Expression


TParser Constructors

Constructors
Name | Description
Create(String,TResolveProc,TErrorProc) | Initializes a new instance of the TParser class.
Top


TParser.Create(String,TResolveProc,TErrorProc) Constructor

Summary

Initializes a new instance of the TParser class.

Namespace: BI.Expression
Syntax
Delphi
public
 Constructor Create(const S: String;
 const Resolve:TResolveProc;
 const Error:TErrorProc);

Parameters

S
Type: String

Resolve
Type: TResolveProc

Error
Type: TErrorProc

See Also

Reference

  • TParser
  • BI.Expression


TParser Methods

Methods
Name | Description
FromString | Represents method FromString.
Top


TParser.FromString Method

Summary

Represents method FromString.

Namespace: BI.Expression
Syntax
Delphi
public
 function FromString:TExpression;

Return Value

Type: TExpression

See Also

Reference

  • TParser
  • BI.Expression


BI.Expression Enumerations

Enumerations
Name | Description
TArithmeticOperand | Represents type TArithmeticOperand.
TDateTimePart | Represents type TDateTimePart.
TDateTimeSpan | Represents type TDateTimeSpan.
TLogicalOperand | Represents type TLogicalOperand.
TMathOperand | Represents type TMathOperand.
TTextLogicalOperand | Represents type TTextLogicalOperand.
TTextOperand | Represents type TTextOperand.
TTextUnaryOperand | Represents type TTextUnaryOperand.
Top


TArithmeticOperand Enumeration

Summary

Represents type TArithmeticOperand.

Namespace: BI.Expression
Syntax
Delphi
type
 TArithmeticOperand=(Add,Subtract,Multiply,Divide,&Mod,Power);

The TArithmeticOperand type exposes the following members.

Members
Show:
Name | Description
&Mod | Represents constant &Mod.
Add | Represents constant Add.
Divide | Represents constant Divide.
Multiply | Represents constant Multiply.
Power | Represents constant Power.
Subtract | Represents constant Subtract.
Top
See Also

Reference

  • BI.Expression


TDateTimePart Enumeration

Summary

Represents type TDateTimePart.

Namespace: BI.Expression
Syntax
Delphi
type
 TDateTimePart=(None,
 Millisecond,
 HundredsOfSecond,
 TenthsOfSecond,
 Second,
 Minute,
 QuarterHour,
 Hour,
 DayOfMonth,
 DayOfYear,
 WeekOfYear,
 WeekDay,
 ShortWeekDayName,
 LongWeekDayName,
 Month,
 ShortMonthName,
 LongMonthName,
 Quarter,
 Year,
 Decade,
 DecadeOfYear,
 Century,
 Millennium);

The TDateTimePart type exposes the following members.

Members
Show:
Name | Description
Century | Represents constant Century.
DayOfMonth | Represents constant DayOfMonth.
DayOfYear | Represents constant DayOfYear.
Decade | Represents constant Decade.
DecadeOfYear | Represents constant DecadeOfYear.
Hour | Represents constant Hour.
HundredsOfSecond | Represents constant HundredsOfSecond.
LongMonthName | Represents constant LongMonthName.
LongWeekDayName | Represents constant LongWeekDayName.
Millennium | Represents constant Millennium.
Millisecond | Represents constant Millisecond.
Minute | Represents constant Minute.
Month | Represents constant Month.
None | Represents constant None.
Quarter | Represents constant Quarter.
QuarterHour | Represents constant QuarterHour.
Second | Represents constant Second.
ShortMonthName | Represents constant ShortMonthName.
ShortWeekDayName | Represents constant ShortWeekDayName.
TenthsOfSecond | Represents constant TenthsOfSecond.
WeekDay | Represents constant WeekDay.
WeekOfYear | Represents constant WeekOfYear.
Year | Represents constant Year.
Top
See Also

Reference

  • BI.Expression


TDateTimeSpan Enumeration

Summary

Represents type TDateTimeSpan.

Namespace: BI.Expression
Syntax
Delphi
type
 TDateTimeSpan=(None,
 Millisecond,
 HundredsOfSecond,
 TenthsOfSecond,
 Second,
 Minute,
 QuarterHour,
 Hour,
 Day,
 Week,
 Month,
 Quarter,
 Year,
 Decade,
 Century,
 Millennium);

The TDateTimeSpan type exposes the following members.

Members
Show:
Name | Description
Century | Represents constant Century.
Day | Represents constant Day.
Decade | Represents constant Decade.
Hour | Represents constant Hour.
HundredsOfSecond | Represents constant HundredsOfSecond.
Millennium | Represents constant Millennium.
Millisecond | Represents constant Millisecond.
Minute | Represents constant Minute.
Month | Represents constant Month.
None | Represents constant None.
Quarter | Represents constant Quarter.
QuarterHour | Represents constant QuarterHour.
Second | Represents constant Second.
TenthsOfSecond | Represents constant TenthsOfSecond.
Week | Represents constant Week.
Year | Represents constant Year.
Top
See Also

Reference

  • BI.Expression


TLogicalOperand Enumeration

Summary

Represents type TLogicalOperand.

Namespace: BI.Expression
Syntax
Delphi
type
 TLogicalOperand=(Equal,NotEqual,Greater,Lower,GreaterOrEqual,LowerOrEqual,&And,&Or,&In);

The TLogicalOperand type exposes the following members.

Members
Show:
Name | Description
&And | Represents constant &And.
&In | Represents constant &In.
&Or | Represents constant &Or.
Equal | Represents constant Equal.
Greater | Represents constant Greater.
GreaterOrEqual | Represents constant GreaterOrEqual.
Lower | Represents constant Lower.
LowerOrEqual | Represents constant LowerOrEqual.
NotEqual | Represents constant NotEqual.
Top
See Also

Reference

  • BI.Expression


TMathOperand Enumeration

Summary

Represents type TMathOperand.

Namespace: BI.Expression
Syntax
Delphi
type
 TMathOperand=(Abs,Sin,Cos,Tan,Sqr,Sqrt,Log,Ln,Exp,Round,Trunc,Power,Sign);

The TMathOperand type exposes the following members.

Members
Show:
Name | Description
Abs | Represents constant Abs.
Cos | Represents constant Cos.
Exp | Represents constant Exp.
Ln | Represents constant Ln.
Log | Represents constant Log.
Power | Represents constant Power.
Round | Represents constant Round.
Sign | Represents constant Sign.
Sin | Represents constant Sin.
Sqr | Represents constant Sqr.
Sqrt | Represents constant Sqrt.
Tan | Represents constant Tan.
Trunc | Represents constant Trunc.
Top
See Also

Reference

  • BI.Expression


TTextLogicalOperand Enumeration

Summary

Represents type TTextLogicalOperand.

Namespace: BI.Expression
Syntax
Delphi
type
 TTextLogicalOperand=(Starts,Ends,Contains);

The TTextLogicalOperand type exposes the following members.

Members
Show:
Name | Description
Contains | Represents constant Contains.
Ends | Represents constant Ends.
Starts | Represents constant Starts.
Top
See Also

Reference

  • BI.Expression


TTextOperand Enumeration

Summary

Represents type TTextOperand.

Namespace: BI.Expression
Syntax
Delphi
type
 TTextOperand=(IndexOf,Pad,Split,Insert,Remove,Replace,Count,SubString);

The TTextOperand type exposes the following members.

Members
Show:
Name | Description
Count | Represents constant Count.
IndexOf | Represents constant IndexOf.
Insert | Represents constant Insert.
Pad | Represents constant Pad.
Remove | Represents constant Remove.
Replace | Represents constant Replace.
Split | Represents constant Split.
SubString | Represents constant SubString.
Top
See Also

Reference

  • BI.Expression


TTextUnaryOperand Enumeration

Summary

Represents type TTextUnaryOperand.

Namespace: BI.Expression
Syntax
Delphi
type
 TTextUnaryOperand=(Lower,Upper,IsEmpty,Length,Trim);

The TTextUnaryOperand type exposes the following members.

Members
Show:
Name | Description
IsEmpty | Represents constant IsEmpty.
Length | Represents constant Length.
Lower | Represents constant Lower.
Trim | Represents constant Trim.
Upper | Represents constant Upper.
Top
See Also

Reference

  • BI.Expression


BI.Expression Delegates

Delegates
Name | Description
TExpressionProc | Represents type TExpressionProc.
Top


TExpressionProc Delegate

Summary

Represents type TExpressionProc.

Namespace: BI.Expression
Syntax
Delphi
type
 TExpressionProc=procedure(const Item:TExpression) of object;
See Also

Reference

  • BI.Expression


BI.Expression Types

Types
Name | Description
TData | Represents an alias of the Variant type.
TErrorProc | Represents type TErrorProc.
TExpressionClass | Represents type TExpressionClass.
TExpressions | Represents an array of the TExpression type.
TParameterExpressionClass | Represents type TParameterExpressionClass.
TParameterExpressions | Represents an array of the TParameterExpressionClass type.
TResolveProc | Represents type TResolveProc.
Top


TData Type

Summary

Represents an alias of the Variant type.

Namespace: BI.Expression
Syntax
Delphi
type
 TData=Variant;
See Also

Reference

  • BI.Expression


TErrorProc Type

Summary

Represents type TErrorProc.

Namespace: BI.Expression
Syntax
Delphi
type
 TErrorProc=reference to
 function(const APos:Integer; const AMessage:String):Boolean
 ;
See Also

Reference

  • BI.Expression


TExpressionClass Type

Summary

Represents type TExpressionClass.

Namespace: BI.Expression
Syntax
Delphi
type
 TExpressionClass=class of TExpression;
See Also

Reference

  • BI.Expression


TExpressions Type

Summary

Represents an array of the TExpression type.

Namespace: BI.Expression
Syntax
Delphi
type
 TExpressions=Array of TExpression;
See Also

Reference

  • BI.Expression


TParameterExpressionClass Type

Summary

Represents type TParameterExpressionClass.

Namespace: BI.Expression
Syntax
Delphi
type
 TParameterExpressionClass=class of TParameterExpression;
See Also

Reference

  • BI.Expression


TParameterExpressions Type

Summary

Represents an array of the TParameterExpressionClass type.

Namespace: BI.Expression
Syntax
Delphi
type
 TParameterExpressions=Array of TParameterExpressionClass;
See Also

Reference

  • BI.Expression


TResolveProc Type

Summary

Represents type TResolveProc.

Namespace: BI.Expression
Syntax
Delphi
type
 TResolveProc=
 reference to function(const S:String; IsFunction:Boolean):TExpression;
See Also

Reference

  • BI.Expression


BI.Expression Constants

Constants
Name | Description
CRLF | Represents constant CRLF.
DateParts | Represents constant DateParts.
Top


CRLF Constant

Summary

Represents constant CRLF.

Namespace: BI.Expression
Syntax
Delphi
 CRLF=#13#10;

Value

Type: string

See Also

Reference

  • BI.Expression


DateParts Constant

Summary

Represents constant DateParts.

Namespace: BI.Expression
Syntax
Delphi
 DateParts:Array[0..22] of String=(
 '',
 'Millisecond',
 'HundredsOfSecond',
 'TenthsOfSecond',
 'Second',
 'Minute',
 'QuarterOfHour',
 'Hour',
 'Day',
 'DayOfYear',
 'WeekOfYear',
 'WeekDay',
 'ShortWeekDay',
 'LongWeekDay',
 'Month',
 'ShortMonth',
 'LongMonth',
 'Quarter',
 'Year',
 'Decade',
 'DecadeOfYear',
 'Century',
 'Millennium');

Value

Type: Array[0..22] of String

See Also

Reference

  • BI.Expression


BI.Expression Routines

Routines
Name | Description
CannotBeFloat(String) | Represents method CannotBeFloat(String).
DoInsert(TArrayExpression) | Represents method DoInsert(TArrayExpression).
DoPos(TArrayExpression) | Represents method DoPos(TArrayExpression).
DoRemove(TArrayExpression) | Represents method DoRemove(TArrayExpression).
DoReplace(TArrayExpression) | Represents method DoReplace(TArrayExpression).
DoSplit(TArrayExpression) | Represents method DoSplit(TArrayExpression).
DoSubString(TArrayExpression) | Represents method DoSubString(TArrayExpression).
FromArray(TExpressions,Boolean) | Represents method FromArray(TExpressions,Boolean).
GuessIntrinsic(String) | Represents method GuessIntrinsic(String).
IsAndOr(String) | Represents method IsAndOr(String).
NilFunction(String,Boolean) | Represents method NilFunction(String,Boolean).
StringCount(String,String) | Overloaded. Represents method StringCount(String,String).
StringCount(TArrayExpression) | Overloaded. Represents method StringCount(TArrayExpression).
Top


CannotBeFloat(String) Method

Summary

Represents method CannotBeFloat(String).

Namespace: BI.Expression
Syntax
Delphi
function CannotBeFloat(const Token:String):Boolean;

Parameters

Token
Type: String

Return Value

Type: Boolean

See Also

Reference

  • BI.Expression


DoInsert(TArrayExpression) Method

Summary

Represents method DoInsert(TArrayExpression).

Namespace: BI.Expression
Syntax
Delphi
function DoInsert(const A:TArrayExpression):String;

Parameters

A
Type: TArrayExpression

Return Value

Type: String

See Also

Reference

  • BI.Expression


DoPos(TArrayExpression) Method

Summary

Represents method DoPos(TArrayExpression).

Namespace: BI.Expression
Syntax
Delphi
function DoPos(const Params:TArrayExpression):Integer;

Parameters

Params
Type: TArrayExpression

Return Value

Type: Integer

See Also

Reference

  • BI.Expression


DoRemove(TArrayExpression) Method

Summary

Represents method DoRemove(TArrayExpression).

Namespace: BI.Expression
Syntax
Delphi
function DoRemove(const A:TArrayExpression):String;

Parameters

A
Type: TArrayExpression

Return Value

Type: String

See Also

Reference

  • BI.Expression


DoReplace(TArrayExpression) Method

Summary

Represents method DoReplace(TArrayExpression).

Namespace: BI.Expression
Syntax
Delphi
function DoReplace(const A:TArrayExpression):String;

Parameters

A
Type: TArrayExpression

Return Value

Type: String

See Also

Reference

  • BI.Expression


DoSplit(TArrayExpression) Method

Summary

Represents method DoSplit(TArrayExpression).

Namespace: BI.Expression
Syntax
Delphi
function DoSplit(const A:TArrayExpression):TData;

Parameters

A
Type: TArrayExpression

Return Value

Type: TData

See Also

Reference

  • BI.Expression


DoSubString(TArrayExpression) Method

Summary

Represents method DoSubString(TArrayExpression).

Namespace: BI.Expression
Syntax
Delphi
function DoSubString(const A:TArrayExpression):String;

Parameters

A
Type: TArrayExpression

Return Value

Type: String

See Also

Reference

  • BI.Expression


FromArray(TExpressions,Boolean) Method

Summary

Represents method FromArray(TExpressions,Boolean).

Namespace: BI.Expression
Syntax
Delphi
function FromArray(const Value:TExpressions; const IsParams:Boolean):TExpression;

Parameters

Value
Type: TExpressions

IsParams
Type: Boolean

Return Value

Type: TExpression

See Also

Reference

  • BI.Expression


GuessIntrinsic(String) Method

Summary

Represents method GuessIntrinsic(String).

Namespace: BI.Expression
Syntax
Delphi
function GuessIntrinsic(const S:String):TExpression;

Parameters

S
Type: String

Return Value

Type: TExpression

See Also

Reference

  • BI.Expression


IsAndOr(String) Method

Summary

Represents method IsAndOr(String).

Namespace: BI.Expression
Syntax
Delphi
function IsAndOr(const Token:String):Boolean;

Parameters

Token
Type: String

Return Value

Type: Boolean

See Also

Reference

  • BI.Expression


NilFunction(String,Boolean) Method

Summary

Represents method NilFunction(String,Boolean).

Namespace: BI.Expression
Syntax
Delphi
function NilFunction(const S:String; IsFunction:Boolean):TExpression;

Parameters

S
Type: String

IsFunction
Type: Boolean

Return Value

Type: TExpression

See Also

Reference

  • BI.Expression


StringCount(String,String) Method

Summary

Represents method StringCount(String,String).

Namespace: BI.Expression
Syntax
Delphi
function StringCount(Value:String; const Sub:String):Integer; overload;

Parameters

Value
Type: String

Sub
Type: String

Return Value

Type: Integer

See Also

Reference

  • BI.Expression


StringCount(TArrayExpression) Method

Summary

Represents method StringCount(TArrayExpression).

Namespace: BI.Expression
Syntax
Delphi
function StringCount(const A:TArrayExpression):Integer; overload;

Parameters

A
Type: TArrayExpression

Return Value

Type: Integer

See Also

Reference

  • BI.Expression


BI.Expression.DateTime Namespace

Summary

Represents namespace BI.Expression.DateTime.

Records
Name | Description
TBIDateTime | Represents type TBIDateTime.
TLeapLookup | Represents type TLeapLookup.
TLookup | Represents type TLookup.
Top


BI.Expression.DateTime Records

Records
Name | Description
TBIDateTime | Represents type TBIDateTime.
TLeapLookup | Represents type TLeapLookup.
TLookup | Represents type TLookup.
Top


TBIDateTime Record

Summary

Represents type TBIDateTime.

Namespace: BI.Expression.DateTime
Syntax
Delphi
type
 TBIDateTime=record
 end;

The TBIDateTime type exposes the following members.

Methods
Show:
Name | Description
DayOf(TDateTime) | Represents method DayOf(TDateTime).
DayOfTheYear(TDateTime) | Represents method DayOfTheYear(TDateTime).
MonthOf(TDateTime) | Represents method MonthOf(TDateTime).
YearOf(TDateTime) | Represents method YearOf(TDateTime).
Top
See Also

Reference

  • BI.Expression.DateTime


TBIDateTime Methods

Methods
Name | Description
DayOf(TDateTime) | Represents method DayOf(TDateTime).
DayOfTheYear(TDateTime) | Represents method DayOfTheYear(TDateTime).
MonthOf(TDateTime) | Represents method MonthOf(TDateTime).
YearOf(TDateTime) | Represents method YearOf(TDateTime).
Top


TBIDateTime.DayOf(TDateTime) Method

Summary

Represents method DayOf(TDateTime).

Namespace: BI.Expression.DateTime
Syntax
Delphi
public
 class function DayOf(const DateTime: TDateTime): Word; static;

Parameters

DateTime
Type: TDateTime

Return Value

Type: Word

See Also

Reference

  • TBIDateTime
  • BI.Expression.DateTime


TBIDateTime.DayOfTheYear(TDateTime) Method

Summary

Represents method DayOfTheYear(TDateTime).

Namespace: BI.Expression.DateTime
Syntax
Delphi
public
 class function DayOfTheYear(const DateTime: TDateTime):Word; static;

Parameters

DateTime
Type: TDateTime

Return Value

Type: Word

See Also

Reference

  • TBIDateTime
  • BI.Expression.DateTime


TBIDateTime.MonthOf(TDateTime) Method

Summary

Represents method MonthOf(TDateTime).

Namespace: BI.Expression.DateTime
Syntax
Delphi
public
 class function MonthOf(const DateTime: TDateTime): Byte; static;

Parameters

DateTime
Type: TDateTime

Return Value

Type: Byte

See Also

Reference

  • TBIDateTime
  • BI.Expression.DateTime


TBIDateTime.YearOf(TDateTime) Method

Summary

Represents method YearOf(TDateTime).

Namespace: BI.Expression.DateTime
Syntax
Delphi
public
 class function YearOf(const DateTime: TDateTime): Word; static;

Parameters

DateTime
Type: TDateTime

Return Value

Type: Word

See Also

Reference

  • TBIDateTime
  • BI.Expression.DateTime


TLeapLookup Record

Summary

Represents type TLeapLookup.

Namespace: BI.Expression.DateTime
Syntax
Delphi
type
 TLeapLookup=record
 end;

The TLeapLookup type exposes the following members.

Constants
Show:
Name | Description
Day | Represents constant Day.
Month | Represents constant Month.
Top
See Also

Reference

  • BI.Expression.DateTime


TLeapLookup Constants

Constants
Name | Description
Day | Represents constant Day.
Month | Represents constant Month.
Top


TLeapLookup.Day Constant

Summary

Represents constant Day.

Namespace: BI.Expression.DateTime
Syntax
Delphi
public
 Day:Array[0..365] of Byte=
 (
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31
 );

Value

Type: Array[0..365] of Byte

See Also

Reference

  • TLeapLookup
  • BI.Expression.DateTime


TLeapLookup.Month Constant

Summary

Represents constant Month.

Namespace: BI.Expression.DateTime
Syntax
Delphi
public
 Month:Array[0..365] of Byte=
 (
 1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,
 2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,
 3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,
 4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,
 5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,
 6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,
 7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,
 8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,
 9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,
 10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,
 11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,
 12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12
 );

Value

Type: Array[0..365] of Byte

See Also

Reference

  • TLeapLookup
  • BI.Expression.DateTime


TLookup Record

Summary

Represents type TLookup.

Namespace: BI.Expression.DateTime
Syntax
Delphi
type
 TLookup=record
 end;

The TLookup type exposes the following members.

Constants
Show:
Name | Description
Day | Represents constant Day.
Month | Represents constant Month.
Top
See Also

Reference

  • BI.Expression.DateTime


TLookup Constants

Constants
Name | Description
Day | Represents constant Day.
Month | Represents constant Month.
Top


TLookup.Day Constant

Summary

Represents constant Day.

Namespace: BI.Expression.DateTime
Syntax
Delphi
public
 Day:Array[0..364] of Byte=
 (
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,
 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31
 );

Value

Type: Array[0..364] of Byte

See Also

Reference

  • TLookup
  • BI.Expression.DateTime


TLookup.Month Constant

Summary

Represents constant Month.

Namespace: BI.Expression.DateTime
Syntax
Delphi
public
 Month:Array[0..364] of Byte=
 (
 1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,
 2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,2,
 3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,3,
 4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,4,
 5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,5,
 6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,6,
 7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,7,
 8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,8,
 9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,9,
 10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,10,
 11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,11,
 12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12,12
 );

Value

Type: Array[0..364] of Byte

See Also

Reference

  • TLookup
  • BI.Expression.DateTime


BI.Expression.Filter Namespace

Summary

Represents namespace BI.Expression.Filter.

Classes
Name | Description
TBIFilter | Represents type TBIFilter.
TBooleanFilter | Represents type TBooleanFilter.
TDateTimeFilter | Represents type TDateTimeFilter.
TDateTimeSelected | Represents type TDateTimeSelected.
TFilterItem | Represents type TFilterItem.
TFilterItems | Represents type TFilterItems.
TFilterPart | Represents type TFilterPart.
TMonths | Represents type TMonths.
TNumericFilter | Represents type TNumericFilter.
TNumericValue | Represents type TNumericValue.
TTextFilter | Represents type TTextFilter.
TWeekdays | Represents type TWeekdays.
Top
Enumerations
Name | Description
TDateTimeFilterStyle | Represents type TDateTimeFilterStyle.
TTextFilterStyle | Represents type TTextFilterStyle.
Top
Types
Name | Description
TFloat | Represents an alias of the Double type.
Top
Routines
Name | Description
CalcZeroOrAll(Boolean[]) | Represents method CalcZeroOrAll(Boolean[]).
SelectedCount(Boolean[]) | Represents method SelectedCount(Boolean[]).
TryRemove(String,TStrings) | Represents method TryRemove(String,TStrings).
Top


BI.Expression.Filter Classes

Classes
Name | Description
TBIFilter | Represents type TBIFilter.
TBooleanFilter | Represents type TBooleanFilter.
TDateTimeFilter | Represents type TDateTimeFilter.
TDateTimeSelected | Represents type TDateTimeSelected.
TFilterItem | Represents type TFilterItem.
TFilterItems | Represents type TFilterItems.
TFilterPart | Represents type TFilterPart.
TMonths | Represents type TMonths.
TNumericFilter | Represents type TNumericFilter.
TNumericValue | Represents type TNumericValue.
TTextFilter | Represents type TTextFilter.
TWeekdays | Represents type TWeekdays.
Top


TBIFilter Class

Summary

Represents type TBIFilter.

Namespace: BI.Expression.Filter
Inheritance Hierarchy
TPersistent
BI.Expression.Filter.TBIFilter
BI.Query.TBIFilterAccess
VCLBI.Editor.DynamicFilter.TBIFilterAccess
Syntax
Delphi
type
 TBIFilter=class(TPersistent)
 end;

The TBIFilter type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TBIFilter class.
Destroy | Represents the destructor of the TBIFilter class.
Top
Properties
Show:
Name | Description
Enabled | Represents property Enabled.
Items | Represents property Items.
Item[Integer] | Represents property Item[Integer].
Text | Represents property Text.
Top
Methods
Show:
Name | Description
Add(TDataItem) | Overloaded. Represents method Add(TDataItem).
Add(TLogicalExpression) | Overloaded. Represents method Add(TLogicalExpression).
Assign(TPersistent) | Represents method Assign(TPersistent).
Clear | Represents method Clear.
Custom | Represents method Custom.
Delete(Integer) | Represents method Delete(Integer).
Filter | Represents method Filter.
ItemOf(TDataItem) | Represents method ItemOf(TDataItem).
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged.
ICustom | Represents field ICustom.
IUpdating | Represents field IUpdating.
Top
See Also

Reference

  • BI.Expression.Filter


TBIFilter Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TBIFilter class.
Destroy | Represents the destructor of the TBIFilter class.
Top


TBIFilter.Create Constructor

Summary

Initializes a new instance of the TBIFilter class.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 Constructor Create;
See Also

Reference

  • TBIFilter
  • BI.Expression.Filter


TBIFilter.Destroy Destructor

Summary

Represents the destructor of the TBIFilter class.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIFilter
  • BI.Expression.Filter


TBIFilter Properties

Properties
Name | Description
Enabled | Represents property Enabled.
Items | Represents property Items.
Item[Integer] | Represents property Item[Integer].
Text | Represents property Text.
Top


TBIFilter.Enabled Property

Summary

Represents property Enabled.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Enabled:Boolean read FEnabled write SetEnabled default True;

Property Value

Type: Boolean

See Also

Reference

  • TBIFilter
  • BI.Expression.Filter


TBIFilter.Items Property

Summary

Represents property Items.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Items:TFilterItems read FItems write SetItems stored IsItemsStored;

Property Value

Type: TFilterItems

See Also

Reference

  • TBIFilter
  • BI.Expression.Filter


TBIFilter.Item[Integer] Property

Summary

Represents property Item[Integer].

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 property Item[const AIndex:Integer]:TFilterItem read Get write Put; default;

Parameters

AIndex
Type: Integer

Property Value

Type: TFilterItem

See Also

Reference

  • TBIFilter
  • BI.Expression.Filter


TBIFilter.Text Property

Summary

Represents property Text.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Text:String read FText write SetText;

Property Value

Type: String

See Also

Reference

  • TBIFilter
  • BI.Expression.Filter


TBIFilter Methods

Methods
Name | Description
Add(TDataItem) | Overloaded. Represents method Add(TDataItem).
Add(TLogicalExpression) | Overloaded. Represents method Add(TLogicalExpression).
Assign(TPersistent) | Represents method Assign(TPersistent).
Clear | Represents method Clear.
Custom | Represents method Custom.
Delete(Integer) | Represents method Delete(Integer).
Filter | Represents method Filter.
ItemOf(TDataItem) | Represents method ItemOf(TDataItem).
Top


TBIFilter.Add(TDataItem) Method

Summary

Represents method Add(TDataItem).

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 function Add(const AData:TDataItem):TFilterItem; overload; inline;

Parameters

AData
Type: TDataItem

Return Value

Type: TFilterItem

See Also

Reference

  • TBIFilter
  • BI.Expression.Filter


TBIFilter.Add(TLogicalExpression) Method

Summary

Represents method Add(TLogicalExpression).

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 function Add(const AExpression:TLogicalExpression):TFilterItem; overload; inline;

Parameters

AExpression
Type: TLogicalExpression

Return Value

Type: TFilterItem

See Also

Reference

  • TBIFilter
  • BI.Expression.Filter


TBIFilter.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TBIFilter
  • BI.Expression.Filter


TBIFilter.Clear Method

Summary

Represents method Clear.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TBIFilter
  • BI.Expression.Filter


TBIFilter.Custom Method

Summary

Represents method Custom.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 function Custom:TLogicalExpression;

Return Value

Type: TLogicalExpression

See Also

Reference

  • TBIFilter
  • BI.Expression.Filter


TBIFilter.Delete(Integer) Method

Summary

Represents method Delete(Integer).

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure Delete(const AIndex:Integer);

Parameters

AIndex
Type: Integer

See Also

Reference

  • TBIFilter
  • BI.Expression.Filter


TBIFilter.Filter Method

Summary

Represents method Filter.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 function Filter:TExpression;

Return Value

Type: TExpression

See Also

Reference

  • TBIFilter
  • BI.Expression.Filter


TBIFilter.ItemOf(TDataItem) Method

Summary

Represents method ItemOf(TDataItem).

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 function ItemOf(const AData:TDataItem):TFilterItem;

Parameters

AData
Type: TDataItem

Return Value

Type: TFilterItem

See Also

Reference

  • TBIFilter
  • BI.Expression.Filter


TBIFilter Fields

Fields
Name | Description
IChanged | Represents field IChanged.
ICustom | Represents field ICustom.
IUpdating | Represents field IUpdating.
Top


TBIFilter.IChanged Field

Summary

Represents field IChanged.

Namespace: BI.Expression.Filter
Syntax
Delphi
protected
 IChanged : TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TBIFilter
  • BI.Expression.Filter


TBIFilter.ICustom Field

Summary

Represents field ICustom.

Namespace: BI.Expression.Filter
Syntax
Delphi
protected
 ICustom : TExpression;

Field Value

Type: TExpression

See Also

Reference

  • TBIFilter
  • BI.Expression.Filter


TBIFilter.IUpdating Field

Summary

Represents field IUpdating.

Namespace: BI.Expression.Filter
Syntax
Delphi
protected
 IUpdating : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBIFilter
  • BI.Expression.Filter


TBooleanFilter Class

Summary

Represents type TBooleanFilter.

Namespace: BI.Expression.Filter
Inheritance Hierarchy
TPersistent
BI.Expression.Filter.TFilterPart
BI.Expression.Filter.TBooleanFilter
Syntax
Delphi
type
 TBooleanFilter=class(TFilterPart)
 end;

The TBooleanFilter type exposes the following members.

Properties
Show:
Name | Description
IncludeFalse | Represents property IncludeFalse.
IncludeTrue | Represents property IncludeTrue.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Filter | Represents method Filter.
Reset | Represents method Reset.
Top
See Also

Reference

  • BI.Expression.Filter


TBooleanFilter Properties

Properties
Name | Description
IncludeFalse | Represents property IncludeFalse.
IncludeTrue | Represents property IncludeTrue.
Top


TBooleanFilter.IncludeFalse Property

Summary

Represents property IncludeFalse.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property IncludeFalse:Boolean read GetFalse write SetFalse default False;

Property Value

Type: Boolean

See Also

Reference

  • TBooleanFilter
  • BI.Expression.Filter


TBooleanFilter.IncludeTrue Property

Summary

Represents property IncludeTrue.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property IncludeTrue:Boolean read GetTrue write SetTrue default False;

Property Value

Type: Boolean

See Also

Reference

  • TBooleanFilter
  • BI.Expression.Filter


TBooleanFilter Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Filter | Represents method Filter.
Reset | Represents method Reset.
Top


TBooleanFilter.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TBooleanFilter
  • BI.Expression.Filter


TBooleanFilter.Filter Method

Summary

Represents method Filter.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 function Filter:TLogicalExpression;

Return Value

Type: TLogicalExpression

See Also

Reference

  • TBooleanFilter
  • BI.Expression.Filter


TBooleanFilter.Reset Method

Summary

Represents method Reset.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure Reset;
See Also

Reference

  • TBooleanFilter
  • BI.Expression.Filter


TDateTimeFilter Class

Summary

Represents type TDateTimeFilter.

Namespace: BI.Expression.Filter
Inheritance Hierarchy
TPersistent
BI.Expression.Filter.TFilterPart
BI.Expression.Filter.TDateTimeFilter
Syntax
Delphi
type
 TDateTimeFilter=class(TFilterPart)
 end;

The TDateTimeFilter type exposes the following members.

Constructors
Show:
Name | Description
Create(TFilterItem) | Initializes a new instance of the TDateTimeFilter class.
Destroy | Represents the destructor of the TDateTimeFilter class.
Top
Properties
Show:
Name | Description
FromDate | Represents property FromDate.
FromEqual | Represents property FromEqual.
Months | Represents property Months.
Period | Represents property Period.
Quantity | Represents property Quantity.
Selected | Represents property Selected.
Style | Represents property Style.
ToDate | Represents property ToDate.
ToEqual | Represents property ToEqual.
Weekdays | Represents property Weekdays.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Filter | Represents method Filter.
Reset | Represents method Reset.
Top
See Also

Reference

  • BI.Expression.Filter


TDateTimeFilter Constructors

Constructors
Name | Description
Create(TFilterItem) | Initializes a new instance of the TDateTimeFilter class.
Destroy | Represents the destructor of the TDateTimeFilter class.
Top


TDateTimeFilter.Create(TFilterItem) Constructor

Summary

Initializes a new instance of the TDateTimeFilter class.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 Constructor Create(const AItem:TFilterItem);

Parameters

AItem
Type: TFilterItem

See Also

Reference

  • TDateTimeFilter
  • BI.Expression.Filter


TDateTimeFilter.Destroy Destructor

Summary

Represents the destructor of the TDateTimeFilter class.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TDateTimeFilter
  • BI.Expression.Filter


TDateTimeFilter Properties

Properties
Name | Description
FromDate | Represents property FromDate.
FromEqual | Represents property FromEqual.
Months | Represents property Months.
Period | Represents property Period.
Quantity | Represents property Quantity.
Selected | Represents property Selected.
Style | Represents property Style.
ToDate | Represents property ToDate.
ToEqual | Represents property ToEqual.
Weekdays | Represents property Weekdays.
Top


TDateTimeFilter.FromDate Property

Summary

Represents property FromDate.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 property FromDate:TDateTime read GetFrom write SetFrom;

Property Value

Type: TDateTime

See Also

Reference

  • TDateTimeFilter
  • BI.Expression.Filter


TDateTimeFilter.FromEqual Property

Summary

Represents property FromEqual.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 property FromEqual:Boolean read GetFromEqual write SetFromEqual default True;

Property Value

Type: Boolean

See Also

Reference

  • TDateTimeFilter
  • BI.Expression.Filter


TDateTimeFilter.Months Property

Summary

Represents property Months.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Months:TMonths read FMonths write SetMonths;

Property Value

Type: TMonths

See Also

Reference

  • TDateTimeFilter
  • BI.Expression.Filter


TDateTimeFilter.Period Property

Summary

Represents property Period.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Period:TDateTimeSpan read FPeriod write SetPeriod default TDateTimeSpan.None;

Property Value

Type: TDateTimeSpan

See Also

Reference

  • TDateTimeFilter
  • BI.Expression.Filter


TDateTimeFilter.Quantity Property

Summary

Represents property Quantity.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Quantity:Integer read FQuantity write SetQuantity default 1;

Property Value

Type: Integer

See Also

Reference

  • TDateTimeFilter
  • BI.Expression.Filter


TDateTimeFilter.Selected Property

Summary

Represents property Selected.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Selected:TDateTimeSelected read FSelected write SetSelected;

Property Value

Type: TDateTimeSelected

See Also

Reference

  • TDateTimeFilter
  • BI.Expression.Filter


TDateTimeFilter.Style Property

Summary

Represents property Style.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Style:TDateTimeFilterStyle read FStyle write SetStyle default TDateTimeFilterStyle.All;

Property Value

Type: TDateTimeFilterStyle

See Also

Reference

  • TDateTimeFilter
  • BI.Expression.Filter


TDateTimeFilter.ToDate Property

Summary

Represents property ToDate.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 property ToDate:TDateTime read GetTo write SetTo;

Property Value

Type: TDateTime

See Also

Reference

  • TDateTimeFilter
  • BI.Expression.Filter


TDateTimeFilter.ToEqual Property

Summary

Represents property ToEqual.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 property ToEqual:Boolean read GetToEqual write SetToEqual default True;

Property Value

Type: Boolean

See Also

Reference

  • TDateTimeFilter
  • BI.Expression.Filter


TDateTimeFilter.Weekdays Property

Summary

Represents property Weekdays.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Weekdays:TWeekdays read FWeekdays write SetWeedays;

Property Value

Type: TWeekdays

See Also

Reference

  • TDateTimeFilter
  • BI.Expression.Filter


TDateTimeFilter Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Filter | Represents method Filter.
Reset | Represents method Reset.
Top


TDateTimeFilter.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TDateTimeFilter
  • BI.Expression.Filter


TDateTimeFilter.Filter Method

Summary

Represents method Filter.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 function Filter:TLogicalExpression;

Return Value

Type: TLogicalExpression

See Also

Reference

  • TDateTimeFilter
  • BI.Expression.Filter


TDateTimeFilter.Reset Method

Summary

Represents method Reset.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure Reset;
See Also

Reference

  • TDateTimeFilter
  • BI.Expression.Filter


TDateTimeSelected Class

Summary

Represents type TDateTimeSelected.

Namespace: BI.Expression.Filter
Inheritance Hierarchy
TPersistent
BI.Expression.Filter.TFilterPart
BI.Expression.Filter.TDateTimeSelected
Syntax
Delphi
type
 TDateTimeSelected=class(TFilterPart)
 end;

The TDateTimeSelected type exposes the following members.

Properties
Show:
Name | Description
DateTime | Represents property DateTime.
Enabled | Represents property Enabled.
Part | Represents property Part.
Value | Represents property Value.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Filter | Represents method Filter.
Reset | Represents method Reset.
Top
See Also

Reference

  • BI.Expression.Filter


TDateTimeSelected Properties

Properties
Name | Description
DateTime | Represents property DateTime.
Enabled | Represents property Enabled.
Part | Represents property Part.
Value | Represents property Value.
Top


TDateTimeSelected.DateTime Property

Summary

Represents property DateTime.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property DateTime:TDateTime read FDateTime write SetDateTime;

Property Value

Type: TDateTime

See Also

Reference

  • TDateTimeSelected
  • BI.Expression.Filter


TDateTimeSelected.Enabled Property

Summary

Represents property Enabled.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Enabled:Boolean read FEnabled write SetEnabled default False;

Property Value

Type: Boolean

See Also

Reference

  • TDateTimeSelected
  • BI.Expression.Filter


TDateTimeSelected.Part Property

Summary

Represents property Part.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Part:TDateTimePart read FPart write SetPart default TDateTimePart.None;

Property Value

Type: TDateTimePart

See Also

Reference

  • TDateTimeSelected
  • BI.Expression.Filter


TDateTimeSelected.Value Property

Summary

Represents property Value.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Value:Integer read FValue write SetValue default 0;

Property Value

Type: Integer

See Also

Reference

  • TDateTimeSelected
  • BI.Expression.Filter


TDateTimeSelected Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Filter | Represents method Filter.
Reset | Represents method Reset.
Top


TDateTimeSelected.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TDateTimeSelected
  • BI.Expression.Filter


TDateTimeSelected.Filter Method

Summary

Represents method Filter.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 function Filter:TLogicalExpression;

Return Value

Type: TLogicalExpression

See Also

Reference

  • TDateTimeSelected
  • BI.Expression.Filter


TDateTimeSelected.Reset Method

Summary

Represents method Reset.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure Reset;
See Also

Reference

  • TDateTimeSelected
  • BI.Expression.Filter


TFilterItem Class

Summary

Represents type TFilterItem.

Namespace: BI.Expression.Filter
Inheritance Hierarchy
TCollectionItem
BI.CollectionItem.TDataCollectionItem
BI.Expression.Filter.TFilterItem
VCLBI.Editor.Filter.DateTime.TFilterItemAccess
VCLBI.Editor.Filter.Item.TFilterItemAccess
Syntax
Delphi
type
 TFilterItem=class(TDataCollectionItem)
 end;

The TFilterItem type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TFilterItem class.
Destroy | Represents the destructor of the TFilterItem class. (Overrides TDataCollectionItem.Destroy.)
Top
Properties
Show:
Name | Description
BoolFilter | Represents property BoolFilter.
DateTime | Represents property DateTime.
Enabled | Represents property Enabled.
Excluded | Represents property Excluded.
Expression | Represents property Expression.
Filter | Represents property Filter.
Included | Represents property Included.
Inverted | Represents property Inverted.
Kind | Represents property Kind.
Numeric | Represents property Numeric.
Text | Represents property Text.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TDataCollectionItem.Assign(TPersistent).)
Changed | Represents method Changed. (Overrides TDataCollectionItem.Changed.)
DataExpression | Represents method DataExpression.
ExcludeText(String,Boolean) | Represents method ExcludeText(String,Boolean).
IncludeText(String,Boolean) | Represents method IncludeText(String,Boolean).
Reset | Represents method Reset.
Top
See Also

Reference

  • BI.Expression.Filter


TFilterItem Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TFilterItem class.
Destroy | Represents the destructor of the TFilterItem class. (Overrides TDataCollectionItem.Destroy.)
Top


TFilterItem.Create(TCollection) Constructor

Summary

Initializes a new instance of the TFilterItem class.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 Constructor Create(Collection: TCollection); override;

Parameters

Collection
Type: TCollection

See Also

Reference

  • TFilterItem
  • BI.Expression.Filter


TFilterItem.Destroy Destructor

Summary

Represents the destructor of the TFilterItem class.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TDataCollectionItem.Destroy
See Also

Reference

  • TFilterItem
  • BI.Expression.Filter


TFilterItem Properties

Properties
Name | Description
BoolFilter | Represents property BoolFilter.
DateTime | Represents property DateTime.
Enabled | Represents property Enabled.
Excluded | Represents property Excluded.
Expression | Represents property Expression.
Filter | Represents property Filter.
Included | Represents property Included.
Inverted | Represents property Inverted.
Kind | Represents property Kind.
Numeric | Represents property Numeric.
Text | Represents property Text.
Top


TFilterItem.BoolFilter Property

Summary

Represents property BoolFilter.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property BoolFilter:TBooleanFilter read FBool write SetBool;

Property Value

Type: TBooleanFilter

See Also

Reference

  • TFilterItem
  • BI.Expression.Filter


TFilterItem.DateTime Property

Summary

Represents property DateTime.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property DateTime:TDateTimeFilter read FDateTime write SetDateTime;

Property Value

Type: TDateTimeFilter

See Also

Reference

  • TFilterItem
  • BI.Expression.Filter


TFilterItem.Enabled Property

Summary

Represents property Enabled.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Enabled:Boolean read FEnabled write SetEnabled default True;

Property Value

Type: Boolean

See Also

Reference

  • TFilterItem
  • BI.Expression.Filter


TFilterItem.Excluded Property

Summary

Represents property Excluded.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Excluded:TStringList read FExcluded write SetExcluded;

Property Value

Type: TStringList

See Also

Reference

  • TFilterItem
  • BI.Expression.Filter


TFilterItem.Expression Property

Summary

Represents property Expression.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 property Expression:TLogicalExpression read FExpression write FExpression;

Property Value

Type: TLogicalExpression

See Also

Reference

  • TFilterItem
  • BI.Expression.Filter


TFilterItem.Filter Property

Summary

Represents property Filter.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 property Filter:TExpression read GetFilter;

Property Value

Type: TExpression

See Also

Reference

  • TFilterItem
  • BI.Expression.Filter


TFilterItem.Included Property

Summary

Represents property Included.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Included:TStringList read FIncluded write SetIncluded;

Property Value

Type: TStringList

See Also

Reference

  • TFilterItem
  • BI.Expression.Filter


TFilterItem.Inverted Property

Summary

Represents property Inverted.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Inverted:Boolean read FInverted write SetInverted default False;

Property Value

Type: Boolean

See Also

Reference

  • TFilterItem
  • BI.Expression.Filter


TFilterItem.Kind Property

Summary

Represents property Kind.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 property Kind:TDataKind read GetKind;

Property Value

Type: TDataKind

See Also

Reference

  • TFilterItem
  • BI.Expression.Filter


TFilterItem.Numeric Property

Summary

Represents property Numeric.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Numeric:TNumericFilter read FNumeric write SetNumeric;

Property Value

Type: TNumericFilter

See Also

Reference

  • TFilterItem
  • BI.Expression.Filter


TFilterItem.Text Property

Summary

Represents property Text.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Text:TTextFilter read FText write SetText;

Property Value

Type: TTextFilter

See Also

Reference

  • TFilterItem
  • BI.Expression.Filter


TFilterItem Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TDataCollectionItem.Assign(TPersistent).)
Changed | Represents method Changed. (Overrides TDataCollectionItem.Changed.)
DataExpression | Represents method DataExpression.
ExcludeText(String,Boolean) | Represents method ExcludeText(String,Boolean).
IncludeText(String,Boolean) | Represents method IncludeText(String,Boolean).
Reset | Represents method Reset.
Top


TFilterItem.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TDataCollectionItem.Assign(TPersistent)
See Also

Reference

  • TFilterItem
  • BI.Expression.Filter


TFilterItem.Changed Method

Summary

Represents method Changed.

Namespace: BI.Expression.Filter
Syntax
Delphi
protected
 procedure Changed; override;

Overrides

TDataCollectionItem.Changed
See Also

Reference

  • TFilterItem
  • BI.Expression.Filter


TFilterItem.DataExpression Method

Summary

Represents method DataExpression.

Namespace: BI.Expression.Filter
Syntax
Delphi
protected
 function DataExpression:TDataItemExpression;

Return Value

Type: TDataItemExpression

See Also

Reference

  • TFilterItem
  • BI.Expression.Filter


TFilterItem.ExcludeText(String,Boolean) Method

Summary

Represents method ExcludeText(String,Boolean).

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure ExcludeText(const AText:String; const Add:Boolean=True);

Parameters

AText
Type: String

Add
Type: Boolean

See Also

Reference

  • TFilterItem
  • BI.Expression.Filter


TFilterItem.IncludeText(String,Boolean) Method

Summary

Represents method IncludeText(String,Boolean).

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure IncludeText(const AText:String; const Add:Boolean=True);

Parameters

AText
Type: String

Add
Type: Boolean

See Also

Reference

  • TFilterItem
  • BI.Expression.Filter


TFilterItem.Reset Method

Summary

Represents method Reset.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure Reset;
See Also

Reference

  • TFilterItem
  • BI.Expression.Filter


TFilterItems Class

Summary

Represents type TFilterItems.

Namespace: BI.Expression.Filter
Inheritance Hierarchy
TOwnedCollection
BI.Expression.Filter.TFilterItems
Syntax
Delphi
type
 TFilterItems=class(TOwnedCollection)
 end;

The TFilterItems type exposes the following members.

Constructors
Show:
Name | Description
Create(TPersistent) | Initializes a new instance of the TFilterItems class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Add(TDataItem) | Represents method Add(TDataItem).
Filter | Represents method Filter.
Top
See Also

Reference

  • BI.Expression.Filter


TFilterItems Constructors

Constructors
Name | Description
Create(TPersistent) | Initializes a new instance of the TFilterItems class.
Top


TFilterItems.Create(TPersistent) Constructor

Summary

Initializes a new instance of the TFilterItems class.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 Constructor Create(AOwner: TPersistent);

Parameters

AOwner
Type: TPersistent

See Also

Reference

  • TFilterItems
  • BI.Expression.Filter


TFilterItems Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TFilterItems.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 property Items[const Index:Integer]:TFilterItem read Get write Put; default;

Parameters

Index
Type: Integer

Property Value

Type: TFilterItem

See Also

Reference

  • TFilterItems
  • BI.Expression.Filter


TFilterItems Methods

Methods
Name | Description
Add(TDataItem) | Represents method Add(TDataItem).
Filter | Represents method Filter.
Top


TFilterItems.Add(TDataItem) Method

Summary

Represents method Add(TDataItem).

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 function Add(const AData:TDataItem):TFilterItem;

Parameters

AData
Type: TDataItem

Return Value

Type: TFilterItem

See Also

Reference

  • TFilterItems
  • BI.Expression.Filter


TFilterItems.Filter Method

Summary

Represents method Filter.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 function Filter:TExpression;

Return Value

Type: TExpression

See Also

Reference

  • TFilterItems
  • BI.Expression.Filter


TFilterPart Class

Summary

Represents type TFilterPart.

Namespace: BI.Expression.Filter
Inheritance Hierarchy
TPersistent
BI.Expression.Filter.TFilterPart
BI.Expression.Filter.TBooleanFilter
BI.Expression.Filter.TDateTimeFilter
BI.Expression.Filter.TDateTimeSelected
BI.Expression.Filter.TMonths
BI.Expression.Filter.TNumericFilter
BI.Expression.Filter.TNumericValue
BI.Expression.Filter.TTextFilter
BI.Expression.Filter.TWeekdays
Syntax
Delphi
type
 TFilterPart=class(TPersistent)
 end;

The TFilterPart type exposes the following members.

Constructors
Show:
Name | Description
Create(TFilterItem) | Initializes a new instance of the TFilterPart class.
Top
See Also

Reference

  • BI.Expression.Filter


TFilterPart Constructors

Constructors
Name | Description
Create(TFilterItem) | Initializes a new instance of the TFilterPart class.
Top


TFilterPart.Create(TFilterItem) Constructor

Summary

Initializes a new instance of the TFilterPart class.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 Constructor Create(const AItem:TFilterItem);

Parameters

AItem
Type: TFilterItem

See Also

Reference

  • TFilterPart
  • BI.Expression.Filter


TMonths Class

Summary

Represents type TMonths.

Namespace: BI.Expression.Filter
Inheritance Hierarchy
TPersistent
BI.Expression.Filter.TFilterPart
BI.Expression.Filter.TMonths
VCLBI.Editor.Filter.DateTime.TMonthsAccess
Syntax
Delphi
type
 TMonths=class(TFilterPart)
 end;

The TMonths type exposes the following members.

Properties
Show:
Name | Description
April | Represents property April.
August | Represents property August.
December | Represents property December.
February | Represents property February.
January | Represents property January.
July | Represents property July.
June | Represents property June.
March | Represents property March.
May | Represents property May.
Month[Integer] | Represents property Month[Integer].
November | Represents property November.
October | Represents property October.
September | Represents property September.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Filter | Represents method Filter.
Reset | Represents method Reset.
SetMonths(TBooleanArray) | Represents method SetMonths(TBooleanArray).
Top
See Also

Reference

  • BI.Expression.Filter


TMonths Properties

Properties
Name | Description
April | Represents property April.
August | Represents property August.
December | Represents property December.
February | Represents property February.
January | Represents property January.
July | Represents property July.
June | Represents property June.
March | Represents property March.
May | Represents property May.
Month[Integer] | Represents property Month[Integer].
November | Represents property November.
October | Represents property October.
September | Represents property September.
Top


TMonths.April Property

Summary

Represents property April.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property April:Boolean index 3 read Get write Put default False;

Property Value

Type: Boolean

See Also

Reference

  • TMonths
  • BI.Expression.Filter


TMonths.August Property

Summary

Represents property August.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property August:Boolean index 7 read Get write Put default False;

Property Value

Type: Boolean

See Also

Reference

  • TMonths
  • BI.Expression.Filter


TMonths.December Property

Summary

Represents property December.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property December:Boolean index 11 read Get write Put default False;

Property Value

Type: Boolean

See Also

Reference

  • TMonths
  • BI.Expression.Filter


TMonths.February Property

Summary

Represents property February.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property February:Boolean index 1 read Get write Put default False;

Property Value

Type: Boolean

See Also

Reference

  • TMonths
  • BI.Expression.Filter


TMonths.January Property

Summary

Represents property January.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property January:Boolean index 0 read Get write Put default False;

Property Value

Type: Boolean

See Also

Reference

  • TMonths
  • BI.Expression.Filter


TMonths.July Property

Summary

Represents property July.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property July:Boolean index 6 read Get write Put default False;

Property Value

Type: Boolean

See Also

Reference

  • TMonths
  • BI.Expression.Filter


TMonths.June Property

Summary

Represents property June.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property June:Boolean index 5 read Get write Put default False;

Property Value

Type: Boolean

See Also

Reference

  • TMonths
  • BI.Expression.Filter


TMonths.March Property

Summary

Represents property March.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property March:Boolean index 2 read Get write Put default False;

Property Value

Type: Boolean

See Also

Reference

  • TMonths
  • BI.Expression.Filter


TMonths.May Property

Summary

Represents property May.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property May:Boolean index 4 read Get write Put default False;

Property Value

Type: Boolean

See Also

Reference

  • TMonths
  • BI.Expression.Filter


TMonths.Month[Integer] Property

Summary

Represents property Month[Integer].

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 property Month[const Index:Integer]:Boolean read Get write Put; default;

Parameters

Index
Type: Integer

Property Value

Type: Boolean

See Also

Reference

  • TMonths
  • BI.Expression.Filter


TMonths.November Property

Summary

Represents property November.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property November:Boolean index 10 read Get write Put default False;

Property Value

Type: Boolean

See Also

Reference

  • TMonths
  • BI.Expression.Filter


TMonths.October Property

Summary

Represents property October.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property October:Boolean index 9 read Get write Put default False;

Property Value

Type: Boolean

See Also

Reference

  • TMonths
  • BI.Expression.Filter


TMonths.September Property

Summary

Represents property September.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property September:Boolean index 8 read Get write Put default False;

Property Value

Type: Boolean

See Also

Reference

  • TMonths
  • BI.Expression.Filter


TMonths Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Filter | Represents method Filter.
Reset | Represents method Reset.
SetMonths(TBooleanArray) | Represents method SetMonths(TBooleanArray).
Top


TMonths.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TMonths
  • BI.Expression.Filter


TMonths.Filter Method

Summary

Represents method Filter.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 function Filter:TLogicalExpression;

Return Value

Type: TLogicalExpression

See Also

Reference

  • TMonths
  • BI.Expression.Filter


TMonths.Reset Method

Summary

Represents method Reset.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure Reset;
See Also

Reference

  • TMonths
  • BI.Expression.Filter


TMonths.SetMonths(TBooleanArray) Method

Summary

Represents method SetMonths(TBooleanArray).

Namespace: BI.Expression.Filter
Syntax
Delphi
protected
 procedure SetMonths(const Value:TBooleanArray);

Parameters

Value
Type: TBooleanArray

See Also

Reference

  • TMonths
  • BI.Expression.Filter


TNumericFilter Class

Summary

Represents type TNumericFilter.

Namespace: BI.Expression.Filter
Inheritance Hierarchy
TPersistent
BI.Expression.Filter.TFilterPart
BI.Expression.Filter.TNumericFilter
Syntax
Delphi
type
 TNumericFilter=class(TFilterPart)
 end;

The TNumericFilter type exposes the following members.

Constructors
Show:
Name | Description
Create(TFilterItem) | Initializes a new instance of the TNumericFilter class.
Destroy | Represents the destructor of the TNumericFilter class.
Top
Properties
Show:
Name | Description
FromValue | Represents property FromValue.
Selected | Represents property Selected.
ToValue | Represents property ToValue.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Filter | Represents method Filter.
RangeFilter | Represents method RangeFilter.
Reset | Represents method Reset.
Top
See Also

Reference

  • BI.Expression.Filter


TNumericFilter Constructors

Constructors
Name | Description
Create(TFilterItem) | Initializes a new instance of the TNumericFilter class.
Destroy | Represents the destructor of the TNumericFilter class.
Top


TNumericFilter.Create(TFilterItem) Constructor

Summary

Initializes a new instance of the TNumericFilter class.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 Constructor Create(const AItem:TFilterItem);

Parameters

AItem
Type: TFilterItem

See Also

Reference

  • TNumericFilter
  • BI.Expression.Filter


TNumericFilter.Destroy Destructor

Summary

Represents the destructor of the TNumericFilter class.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TNumericFilter
  • BI.Expression.Filter


TNumericFilter Properties

Properties
Name | Description
FromValue | Represents property FromValue.
Selected | Represents property Selected.
ToValue | Represents property ToValue.
Top


TNumericFilter.FromValue Property

Summary

Represents property FromValue.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property FromValue:TNumericValue read FFrom write SetFrom;

Property Value

Type: TNumericValue

See Also

Reference

  • TNumericFilter
  • BI.Expression.Filter


TNumericFilter.Selected Property

Summary

Represents property Selected.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Selected:TNumericValue read FSelected write SetSelected;

Property Value

Type: TNumericValue

See Also

Reference

  • TNumericFilter
  • BI.Expression.Filter


TNumericFilter.ToValue Property

Summary

Represents property ToValue.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property ToValue:TNumericValue read FTo write SetTo;

Property Value

Type: TNumericValue

See Also

Reference

  • TNumericFilter
  • BI.Expression.Filter


TNumericFilter Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Filter | Represents method Filter.
RangeFilter | Represents method RangeFilter.
Reset | Represents method Reset.
Top


TNumericFilter.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TNumericFilter
  • BI.Expression.Filter


TNumericFilter.Filter Method

Summary

Represents method Filter.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 function Filter:TLogicalExpression;

Return Value

Type: TLogicalExpression

See Also

Reference

  • TNumericFilter
  • BI.Expression.Filter


TNumericFilter.RangeFilter Method

Summary

Represents method RangeFilter.

Namespace: BI.Expression.Filter
Syntax
Delphi
protected
 function RangeFilter:TLogicalExpression;

Return Value

Type: TLogicalExpression

See Also

Reference

  • TNumericFilter
  • BI.Expression.Filter


TNumericFilter.Reset Method

Summary

Represents method Reset.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure Reset;
See Also

Reference

  • TNumericFilter
  • BI.Expression.Filter


TNumericValue Class

Summary

Represents type TNumericValue.

Namespace: BI.Expression.Filter
Inheritance Hierarchy
TPersistent
BI.Expression.Filter.TFilterPart
BI.Expression.Filter.TNumericValue
Syntax
Delphi
type
 TNumericValue=class(TFilterPart)
 end;

The TNumericValue type exposes the following members.

Constructors
Show:
Name | Description
Create(TFilterItem,TLogicalOperand) | Initializes a new instance of the TNumericValue class.
Top
Properties
Show:
Name | Description
Enabled | Represents property Enabled.
Equal | Represents property Equal.
Value | Represents property Value.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Filter | Represents method Filter.
Reset | Represents method Reset.
Top
See Also

Reference

  • BI.Expression.Filter


TNumericValue Constructors

Constructors
Name | Description
Create(TFilterItem,TLogicalOperand) | Initializes a new instance of the TNumericValue class.
Top


TNumericValue.Create(TFilterItem,TLogicalOperand) Constructor

Summary

Initializes a new instance of the TNumericValue class.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 Constructor Create(const AItem:TFilterItem; const AOperand:TLogicalOperand);

Parameters

AItem
Type: TFilterItem

AOperand
Type: TLogicalOperand

See Also

Reference

  • TNumericValue
  • BI.Expression.Filter


TNumericValue Properties

Properties
Name | Description
Enabled | Represents property Enabled.
Equal | Represents property Equal.
Value | Represents property Value.
Top


TNumericValue.Enabled Property

Summary

Represents property Enabled.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Enabled:Boolean read FEnabled write SetEnabled default False;

Property Value

Type: Boolean

See Also

Reference

  • TNumericValue
  • BI.Expression.Filter


TNumericValue.Equal Property

Summary

Represents property Equal.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Equal:Boolean read GetEqual write SetEqual default True;

Property Value

Type: Boolean

See Also

Reference

  • TNumericValue
  • BI.Expression.Filter


TNumericValue.Value Property

Summary

Represents property Value.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Value:TFloat read FValue write SetValue;

Property Value

Type: TFloat

See Also

Reference

  • TNumericValue
  • BI.Expression.Filter


TNumericValue Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Filter | Represents method Filter.
Reset | Represents method Reset.
Top


TNumericValue.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TNumericValue
  • BI.Expression.Filter


TNumericValue.Filter Method

Summary

Represents method Filter.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 function Filter:TLogicalExpression;

Return Value

Type: TLogicalExpression

See Also

Reference

  • TNumericValue
  • BI.Expression.Filter


TNumericValue.Reset Method

Summary

Represents method Reset.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure Reset;
See Also

Reference

  • TNumericValue
  • BI.Expression.Filter


TTextFilter Class

Summary

Represents type TTextFilter.

Namespace: BI.Expression.Filter
Inheritance Hierarchy
TPersistent
BI.Expression.Filter.TFilterPart
BI.Expression.Filter.TTextFilter
Syntax
Delphi
type
 TTextFilter=class(TFilterPart)
 end;

The TTextFilter type exposes the following members.

Properties
Show:
Name | Description
CaseSensitive | Represents property CaseSensitive.
Style | Represents property Style.
Text | Represents property Text.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Filter | Represents method Filter.
Reset | Represents method Reset.
Top
See Also

Reference

  • BI.Expression.Filter


TTextFilter Properties

Properties
Name | Description
CaseSensitive | Represents property CaseSensitive.
Style | Represents property Style.
Text | Represents property Text.
Top


TTextFilter.CaseSensitive Property

Summary

Represents property CaseSensitive.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property CaseSensitive:Boolean read FCase write SetCase default False;

Property Value

Type: Boolean

See Also

Reference

  • TTextFilter
  • BI.Expression.Filter


TTextFilter.Style Property

Summary

Represents property Style.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Style:TTextFilterStyle read FStyle write SetStyle default TTextFilterStyle.Contains;

Property Value

Type: TTextFilterStyle

See Also

Reference

  • TTextFilter
  • BI.Expression.Filter


TTextFilter.Text Property

Summary

Represents property Text.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Text:String read FText write SetText;

Property Value

Type: String

See Also

Reference

  • TTextFilter
  • BI.Expression.Filter


TTextFilter Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Filter | Represents method Filter.
Reset | Represents method Reset.
Top


TTextFilter.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TTextFilter
  • BI.Expression.Filter


TTextFilter.Filter Method

Summary

Represents method Filter.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 function Filter:TExpression;

Return Value

Type: TExpression

See Also

Reference

  • TTextFilter
  • BI.Expression.Filter


TTextFilter.Reset Method

Summary

Represents method Reset.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure Reset;
See Also

Reference

  • TTextFilter
  • BI.Expression.Filter


TWeekdays Class

Summary

Represents type TWeekdays.

Namespace: BI.Expression.Filter
Inheritance Hierarchy
TPersistent
BI.Expression.Filter.TFilterPart
BI.Expression.Filter.TWeekdays
VCLBI.Editor.Filter.DateTime.TWeekDaysAccess
Syntax
Delphi
type
 TWeekdays=class(TFilterPart)
 end;

The TWeekdays type exposes the following members.

Properties
Show:
Name | Description
Friday | Represents property Friday.
Monday | Represents property Monday.
Saturday | Represents property Saturday.
Sunday | Represents property Sunday.
Thursday | Represents property Thursday.
Tuesday | Represents property Tuesday.
Wednesday | Represents property Wednesday.
Weekday[Integer] | Represents property Weekday[Integer].
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Filter | Represents method Filter.
Reset | Represents method Reset.
SetWeekDays(TBooleanArray) | Represents method SetWeekDays(TBooleanArray).
Top
See Also

Reference

  • BI.Expression.Filter


TWeekdays Properties

Properties
Name | Description
Friday | Represents property Friday.
Monday | Represents property Monday.
Saturday | Represents property Saturday.
Sunday | Represents property Sunday.
Thursday | Represents property Thursday.
Tuesday | Represents property Tuesday.
Wednesday | Represents property Wednesday.
Weekday[Integer] | Represents property Weekday[Integer].
Top


TWeekdays.Friday Property

Summary

Represents property Friday.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Friday:Boolean index 4 read Get write Put default False;

Property Value

Type: Boolean

See Also

Reference

  • TWeekdays
  • BI.Expression.Filter


TWeekdays.Monday Property

Summary

Represents property Monday.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Monday:Boolean index 0 read Get write Put default False;

Property Value

Type: Boolean

See Also

Reference

  • TWeekdays
  • BI.Expression.Filter


TWeekdays.Saturday Property

Summary

Represents property Saturday.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Saturday:Boolean index 5 read Get write Put default False;

Property Value

Type: Boolean

See Also

Reference

  • TWeekdays
  • BI.Expression.Filter


TWeekdays.Sunday Property

Summary

Represents property Sunday.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Sunday:Boolean index 6 read Get write Put default False;

Property Value

Type: Boolean

See Also

Reference

  • TWeekdays
  • BI.Expression.Filter


TWeekdays.Thursday Property

Summary

Represents property Thursday.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Thursday:Boolean index 3 read Get write Put default False;

Property Value

Type: Boolean

See Also

Reference

  • TWeekdays
  • BI.Expression.Filter


TWeekdays.Tuesday Property

Summary

Represents property Tuesday.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Tuesday:Boolean index 1 read Get write Put default False;

Property Value

Type: Boolean

See Also

Reference

  • TWeekdays
  • BI.Expression.Filter


TWeekdays.Wednesday Property

Summary

Represents property Wednesday.

Namespace: BI.Expression.Filter
Syntax
Delphi
published
 property Wednesday:Boolean index 2 read Get write Put default False;

Property Value

Type: Boolean

See Also

Reference

  • TWeekdays
  • BI.Expression.Filter


TWeekdays.Weekday[Integer] Property

Summary

Represents property Weekday[Integer].

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 property Weekday[const Index:Integer]:Boolean read Get write Put; default;

Parameters

Index
Type: Integer

Property Value

Type: Boolean

See Also

Reference

  • TWeekdays
  • BI.Expression.Filter


TWeekdays Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Filter | Represents method Filter.
Reset | Represents method Reset.
SetWeekDays(TBooleanArray) | Represents method SetWeekDays(TBooleanArray).
Top


TWeekdays.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TWeekdays
  • BI.Expression.Filter


TWeekdays.Filter Method

Summary

Represents method Filter.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 function Filter:TLogicalExpression;

Return Value

Type: TLogicalExpression

See Also

Reference

  • TWeekdays
  • BI.Expression.Filter


TWeekdays.Reset Method

Summary

Represents method Reset.

Namespace: BI.Expression.Filter
Syntax
Delphi
public
 procedure Reset;
See Also

Reference

  • TWeekdays
  • BI.Expression.Filter


TWeekdays.SetWeekDays(TBooleanArray) Method

Summary

Represents method SetWeekDays(TBooleanArray).

Namespace: BI.Expression.Filter
Syntax
Delphi
protected
 procedure SetWeekDays(const Value:TBooleanArray);

Parameters

Value
Type: TBooleanArray

See Also

Reference

  • TWeekdays
  • BI.Expression.Filter


BI.Expression.Filter Enumerations

Enumerations
Name | Description
TDateTimeFilterStyle | Represents type TDateTimeFilterStyle.
TTextFilterStyle | Represents type TTextFilterStyle.
Top


TDateTimeFilterStyle Enumeration

Summary

Represents type TDateTimeFilterStyle.

Namespace: BI.Expression.Filter
Syntax
Delphi
type
 TDateTimeFilterStyle=(All,Custom,Today,Yesterday,Tomorrow,This,Last,Next);

The TDateTimeFilterStyle type exposes the following members.

Members
Show:
Name | Description
All | Represents constant All.
Custom | Represents constant Custom.
Last | Represents constant Last.
Next | Represents constant Next.
This | Represents constant This.
Today | Represents constant Today.
Tomorrow | Represents constant Tomorrow.
Yesterday | Represents constant Yesterday.
Top
See Also

Reference

  • BI.Expression.Filter


TTextFilterStyle Enumeration

Summary

Represents type TTextFilterStyle.

Namespace: BI.Expression.Filter
Syntax
Delphi
type
 TTextFilterStyle=(Contains,IsEqual,Starts,Ends,IsEmpty);

The TTextFilterStyle type exposes the following members.

Members
Show:
Name | Description
Contains | Represents constant Contains.
Ends | Represents constant Ends.
IsEmpty | Represents constant IsEmpty.
IsEqual | Represents constant IsEqual.
Starts | Represents constant Starts.
Top
See Also

Reference

  • BI.Expression.Filter


BI.Expression.Filter Types

Types
Name | Description
TFloat | Represents an alias of the Double type.
Top


TFloat Type

Summary

Represents an alias of the Double type.

Namespace: BI.Expression.Filter
Syntax
Delphi
type
 TFloat=Double;
See Also

Reference

  • BI.Expression.Filter


BI.Expression.Filter Routines

Routines
Name | Description
CalcZeroOrAll(Boolean[]) | Represents method CalcZeroOrAll(Boolean[]).
SelectedCount(Boolean[]) | Represents method SelectedCount(Boolean[]).
TryRemove(String,TStrings) | Represents method TryRemove(String,TStrings).
Top


CalcZeroOrAll(Boolean[]) Method

Summary

Represents method CalcZeroOrAll(Boolean[]).

Namespace: BI.Expression.Filter
Syntax
Delphi
function CalcZeroOrAll(const Value:Array of Boolean):Boolean;

Parameters

Value
Type: Array of Boolean

Return Value

Type: Boolean

See Also

Reference

  • BI.Expression.Filter


SelectedCount(Boolean[]) Method

Summary

Represents method SelectedCount(Boolean[]).

Namespace: BI.Expression.Filter
Syntax
Delphi
function SelectedCount(const Value:Array of Boolean):Integer;

Parameters

Value
Type: Array of Boolean

Return Value

Type: Integer

See Also

Reference

  • BI.Expression.Filter


TryRemove(String,TStrings) Method

Summary

Represents method TryRemove(String,TStrings).

Namespace: BI.Expression.Filter
Syntax
Delphi
procedure TryRemove(const AText:String; const AList:TStrings);

Parameters

AText
Type: String

AList
Type: TStrings

See Also

Reference

  • BI.Expression.Filter


BI.Expressions Namespace

Summary

Represents namespace BI.Expressions.

Classes
Name | Description
TColumnExpression | Represents type TColumnExpression.
TColumnFunction | Represents type TColumnFunction.
TColumnOperandHelper | Represents type TColumnOperandHelper.
TDataAccess | Represents type TDataAccess.
TDataExpression | Represents type TDataExpression.
TDataHops | Represents type TDataHops.
TDataItemExpression | Represents type TDataItemExpression.
TExpressionColumn | Represents type TExpressionColumn.
THops | Represents type THops.
TInvertedIndex | Represents type TInvertedIndex.
TIsNullData | Represents type TIsNullData.
TMovingAverageColumn | Represents type TMovingAverageColumn.
TParameterExpressionAccess | Represents type TParameterExpressionAccess.
TSortItemArrayHelper | Represents type TSortItemArrayHelper.
Top
Records
Name | Description
TDataFilter | Represents type TDataFilter.
TDataFunctions | Represents type TDataFunctions.
TDataItemSort | Represents type TDataItemSort.
TSortItems | Represents type TSortItems.
Top
Enumerations
Name | Description
TColumnOperand | Represents type TColumnOperand.
Top
Types
Name | Description
TColumnExpressionClass | Represents type TColumnExpressionClass.
TDataExpression.TResolver | Represents type TResolver.
TSortItemArray | Represents an array of the TSortItem type.
Top
Routines
Name | Description
AnyOneToOne(TDataItem) | Represents method AnyOneToOne(TDataItem).
GuessMultiItems(TDataItem,TDataItem) | Represents method GuessMultiItems(TDataItem,TDataItem).
IndexOfMaster(TDataItem,TDataArray) | Represents method IndexOfMaster(TDataItem,TDataArray).
LocalToData(TDataItem,String,TBIErrorProc) | Represents method LocalToData(TDataItem,String,TBIErrorProc).
Top


BI.Expressions Classes

Classes
Name | Description
TColumnExpression | Represents type TColumnExpression.
TColumnFunction | Represents type TColumnFunction.
TColumnOperandHelper | Represents type TColumnOperandHelper.
TDataAccess | Represents type TDataAccess.
TDataExpression | Represents type TDataExpression.
TDataHops | Represents type TDataHops.
TDataItemExpression | Represents type TDataItemExpression.
TExpressionColumn | Represents type TExpressionColumn.
THops | Represents type THops.
TInvertedIndex | Represents type TInvertedIndex.
TIsNullData | Represents type TIsNullData.
TMovingAverageColumn | Represents type TMovingAverageColumn.
TParameterExpressionAccess | Represents type TParameterExpressionAccess.
TSortItemArrayHelper | Represents type TSortItemArrayHelper.
Top


TColumnExpression Class

Summary

Represents type TColumnExpression.

Namespace: BI.Expressions
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TUnaryExpression
BI.Expressions.TColumnExpression
BI.Expressions.TColumnFunction
BI.Expressions.TMovingAverageColumn
BI.Summary.TRowFunction
Syntax
Delphi
type
 TColumnExpression=class(TUnaryExpression)
 end;

The TColumnExpression type exposes the following members.

Methods
Show:
Name | Description
Calculate(TDataHops,TDataItem) | Represents method Calculate(TDataHops,TDataItem).
Kind | Represents method Kind.
TryParse(String) | Represents method TryParse(String).
Top
See Also

Reference

  • BI.Expressions


TColumnExpression Methods

Methods
Name | Description
Calculate(TDataHops,TDataItem) | Represents method Calculate(TDataHops,TDataItem).
Kind | Represents method Kind.
TryParse(String) | Represents method TryParse(String).
Top


TColumnExpression.Calculate(TDataHops,TDataItem) Method

Summary

Represents method Calculate(TDataHops,TDataItem).

Namespace: BI.Expressions
Syntax
Delphi
protected
 procedure Calculate(const Hops:TDataHops; const Dest:TDataItem); virtual; abstract;

Parameters

Hops
Type: TDataHops

Dest
Type: TDataItem

See Also

Reference

  • TColumnExpression
  • BI.Expressions


TColumnExpression.Kind Method

Summary

Represents method Kind.

Namespace: BI.Expressions
Syntax
Delphi
protected
 function Kind:TDataKind; virtual; abstract;

Return Value

Type: TDataKind

See Also

Reference

  • TColumnExpression
  • BI.Expressions


TColumnExpression.TryParse(String) Method

Summary

Represents method TryParse(String).

Namespace: BI.Expressions
Syntax
Delphi
protected
 class function TryParse(const S:String):TColumnExpression; virtual; abstract;

Parameters

S
Type: String

Return Value

Type: TColumnExpression

See Also

Reference

  • TColumnExpression
  • BI.Expressions


TColumnFunction Class

Summary

Represents type TColumnFunction.

Namespace: BI.Expressions
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TUnaryExpression
BI.Expressions.TColumnExpression
BI.Expressions.TColumnFunction
Syntax
Delphi
type
 TColumnFunction=class(TColumnExpression)
 end;

The TColumnFunction type exposes the following members.

Methods
Show:
Name | Description
Calculate(TDataHops,TDataItem) | Represents method Calculate(TDataHops,TDataItem). (Overrides TColumnExpression.Calculate(TDataHops,TDataItem).)
Kind | Represents method Kind. (Overrides TColumnExpression.Kind.)
ToString | Represents method ToString.
TryParse(String) | Represents method TryParse(String). (Overrides TColumnExpression.TryParse(String).)
Value | Represents method Value. (Overrides TExpression.Value.)
Top
Fields
Show:
Name | Description
Operand | Represents field Operand.
Top
See Also

Reference

  • BI.Expressions


TColumnFunction Methods

Methods
Name | Description
Calculate(TDataHops,TDataItem) | Represents method Calculate(TDataHops,TDataItem). (Overrides TColumnExpression.Calculate(TDataHops,TDataItem).)
Kind | Represents method Kind. (Overrides TColumnExpression.Kind.)
ToString | Represents method ToString.
TryParse(String) | Represents method TryParse(String). (Overrides TColumnExpression.TryParse(String).)
Value | Represents method Value. (Overrides TExpression.Value.)
Top


TColumnFunction.Calculate(TDataHops,TDataItem) Method

Summary

Represents method Calculate(TDataHops,TDataItem).

Namespace: BI.Expressions
Syntax
Delphi
protected
 procedure Calculate(const Hops:TDataHops; const Dest:TDataItem); override;

Parameters

Hops
Type: TDataHops

Dest
Type: TDataItem

Overrides

TColumnExpression.Calculate(TDataHops,TDataItem)
See Also

Reference

  • TColumnFunction
  • BI.Expressions


TColumnFunction.Kind Method

Summary

Represents method Kind.

Namespace: BI.Expressions
Syntax
Delphi
protected
 function Kind:TDataKind; override;

Return Value

Type: TDataKind

Overrides

TColumnExpression.Kind
See Also

Reference

  • TColumnFunction
  • BI.Expressions


TColumnFunction.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expressions
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TColumnFunction
  • BI.Expressions


TColumnFunction.TryParse(String) Method

Summary

Represents method TryParse(String).

Namespace: BI.Expressions
Syntax
Delphi
protected
 class function TryParse(const S:String):TColumnExpression; override;

Parameters

S
Type: String

Return Value

Type: TColumnExpression

Overrides

TColumnExpression.TryParse(String)
See Also

Reference

  • TColumnFunction
  • BI.Expressions


TColumnFunction.Value Method

Summary

Represents method Value.

Namespace: BI.Expressions
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TColumnFunction
  • BI.Expressions


TColumnFunction Fields

Fields
Name | Description
Operand | Represents field Operand.
Top


TColumnFunction.Operand Field

Summary

Represents field Operand.

Namespace: BI.Expressions
Syntax
Delphi
public
 Operand : TColumnOperand;

Field Value

Type: TColumnOperand

See Also

Reference

  • TColumnFunction
  • BI.Expressions


TColumnOperandHelper Class Helper

Summary

Represents type TColumnOperandHelper.

Namespace: BI.Expressions
Syntax
Delphi
type
 TColumnOperandHelper=record helper for TColumnOperand
 end;
Methods
Name | Description
FromString(String,TColumnOperand) | Represents method FromString(String,TColumnOperand).
ToString | Represents method ToString.
Top
See Also

Reference

  • BI.Expressions


TColumnOperandHelper Methods

Methods
Name | Description
FromString(String,TColumnOperand) | Represents method FromString(String,TColumnOperand).
ToString | Represents method ToString.
Top


TColumnOperandHelper.FromString(String,TColumnOperand) Method

Summary

Represents method FromString(String,TColumnOperand).

Namespace: BI.Expressions
Syntax
Delphi
public
 class function FromString(const S:String; out Operand:TColumnOperand):Boolean; static;

Parameters

S
Type: String

Operand
Type: TColumnOperand

Return Value

Type: Boolean

See Also

Reference

  • TColumnOperandHelper
  • BI.Expressions


TColumnOperandHelper.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expressions
Syntax
Delphi
public
 function ToString:String;

Return Value

Type: String

See Also

Reference

  • TColumnOperandHelper
  • BI.Expressions


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.Expressions
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Expressions.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.Expressions


TDataExpression Class

Summary

Represents type TDataExpression.

Namespace: BI.Expressions
Inheritance Hierarchy
TObject
BI.Expressions.TDataExpression
BI.Summary.TSummaryFilter
Syntax
Delphi
type
 TDataExpression=class
 end;

The TDataExpression type exposes the following members.

Methods
Show:
Name | Description
FromString(TDataItem,String,TErrorProc) | Represents method FromString(TDataItem,String,TErrorProc).
KindOf(TExpression) | Represents method KindOf(TExpression).
Resolve(TDataItem,String,TErrorProc) | Represents method Resolve(TDataItem,String,TErrorProc).
Top
Events
Show:
Name | Description
Resolver | Represents property Resolver.
Top
See Also

Reference

  • BI.Expressions


TDataExpression Methods

Methods
Name | Description
FromString(TDataItem,String,TErrorProc) | Represents method FromString(TDataItem,String,TErrorProc).
KindOf(TExpression) | Represents method KindOf(TExpression).
Resolve(TDataItem,String,TErrorProc) | Represents method Resolve(TDataItem,String,TErrorProc).
Top


TDataExpression.FromString(TDataItem,String,TErrorProc) Method

Summary

Represents method FromString(TDataItem,String,TErrorProc).

Namespace: BI.Expressions
Syntax
Delphi
public
 class function FromString(const AData:TDataItem; const AExpression: String; const Error:TErrorProc=nil): TExpression;

Parameters

AData
Type: TDataItem

AExpression
Type: String

Error
Type: TErrorProc

Return Value

Type: TExpression

See Also

Reference

  • TDataExpression
  • BI.Expressions


TDataExpression.KindOf(TExpression) Method

Summary

Represents method KindOf(TExpression).

Namespace: BI.Expressions
Syntax
Delphi
public
 class function KindOf(const Expression:TExpression):TDataKind; static;

Parameters

Expression
Type: TExpression

Return Value

Type: TDataKind

See Also

Reference

  • TDataExpression
  • BI.Expressions


TDataExpression.Resolve(TDataItem,String,TErrorProc) Method

Summary

Represents method Resolve(TDataItem,String,TErrorProc).

Namespace: BI.Expressions
Syntax
Delphi
protected
 class function Resolve(const AData:TDataItem; const AText:String;
 const Error:TErrorProc):TExpression; virtual;

Parameters

AData
Type: TDataItem

AText
Type: String

Error
Type: TErrorProc

Return Value

Type: TExpression

See Also

Reference

  • TDataExpression
  • BI.Expressions


TDataExpression Events

Events
Name | Description
Resolver | Represents property Resolver.
Top


TDataExpression.Resolver Event

Summary

Represents property Resolver.

Namespace: BI.Expressions
Syntax
Delphi
public
 class property Resolver:TResolver read FResolver write FResolver;

Value

Type: TResolver

See Also

Reference

  • TDataExpression
  • BI.Expressions


TDataHops Class

Summary

Represents type TDataHops.

Namespace: BI.Expressions
Inheritance Hierarchy
TObject
BI.Expressions.TDataHops
Syntax
Delphi
type
 TDataHops=class
 end;

The TDataHops type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TDataHops class.
Top
Methods
Show:
Name | Description
Add(TDataItem) | Overloaded. Represents method Add(TDataItem).
Add(TExpression,Boolean) | Overloaded. Represents method Add(TExpression,Boolean).
Init | Represents method Init.
Invalidate(TInteger) | Represents method Invalidate(TInteger).
Valid | Represents method Valid.
Top
Fields
Show:
Name | Description
Data | Represents field Data.
Hops | Represents field Hops.
Main | Represents field Main.
Top
See Also

Reference

  • BI.Expressions


TDataHops Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TDataHops class.
Top


TDataHops.Destroy Destructor

Summary

Represents the destructor of the TDataHops class.

Namespace: BI.Expressions
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TDataHops
  • BI.Expressions


TDataHops Methods

Methods
Name | Description
Add(TDataItem) | Overloaded. Represents method Add(TDataItem).
Add(TExpression,Boolean) | Overloaded. Represents method Add(TExpression,Boolean).
Init | Represents method Init.
Invalidate(TInteger) | Represents method Invalidate(TInteger).
Valid | Represents method Valid.
Top


TDataHops.Add(TDataItem) Method

Summary

Represents method Add(TDataItem).

Namespace: BI.Expressions
Syntax
Delphi
public
 function Add(const AData:TDataItem):Integer; overload;

Parameters

AData
Type: TDataItem

Return Value

Type: Integer

See Also

Reference

  • TDataHops
  • BI.Expressions


TDataHops.Add(TExpression,Boolean) Method

Summary

Represents method Add(TExpression,Boolean).

Namespace: BI.Expressions
Syntax
Delphi
public
 procedure Add(const AExpression:TExpression; const ChangeMain:Boolean); overload;

Parameters

AExpression
Type: TExpression

ChangeMain
Type: Boolean

See Also

Reference

  • TDataHops
  • BI.Expressions


TDataHops.Init Method

Summary

Represents method Init.

Namespace: BI.Expressions
Syntax
Delphi
public
 procedure Init;
See Also

Reference

  • TDataHops
  • BI.Expressions


TDataHops.Invalidate(TInteger) Method

Summary

Represents method Invalidate(TInteger).

Namespace: BI.Expressions
Syntax
Delphi
public
 procedure Invalidate(const AIndex:TInteger);

Parameters

AIndex
Type: System.Void

See Also

Reference

  • TDataHops
  • BI.Expressions


TDataHops.Valid Method

Summary

Represents method Valid.

Namespace: BI.Expressions
Syntax
Delphi
public
 function Valid:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TDataHops
  • BI.Expressions


TDataHops Fields

Fields
Name | Description
Data | Represents field Data.
Hops | Represents field Hops.
Main | Represents field Main.
Top


TDataHops.Data Field

Summary

Represents field Data.

Namespace: BI.Expressions
Syntax
Delphi
public
 Data : TDataArray;

Field Value

Type: TDataArray

See Also

Reference

  • TDataHops
  • BI.Expressions


TDataHops.Hops Field

Summary

Represents field Hops.

Namespace: BI.Expressions
Syntax
Delphi
public
 Hops : Array of THops;

Field Value

Type: Array of THops

See Also

Reference

  • TDataHops
  • BI.Expressions


TDataHops.Main Field

Summary

Represents field Main.

Namespace: BI.Expressions
Syntax
Delphi
public
 Main : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TDataHops
  • BI.Expressions


TDataItemExpression Class

Summary

Represents type TDataItemExpression.

Namespace: BI.Expressions
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expressions.TDataItemExpression
Syntax
Delphi
type
 TDataItemExpression=class(TExpression)
 end;

The TDataItemExpression type exposes the following members.

Constructors
Show:
Name | Description
Create(TDataItem,Boolean,TDataItem) | Initializes a new instance of the TDataItemExpression class.
Destroy | Represents the destructor of the TDataItemExpression class.
Top
Properties
Show:
Name | Description
Data | Represents property Data.
Hops | Represents property Hops.
Top
Methods
Show:
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
IsLogical | Represents method IsLogical.
Kind | Represents method Kind.
LookupFill(TDataItem,TDataItem) | Represents method LookupFill(TDataItem,TDataItem).
NewLookup(String,TDataItem,TDataItem) | Represents method NewLookup(String,TDataItem,TDataItem).
Notify(TBIEvent) | Represents method Notify(TBIEvent).
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
ValueOf(TDataItem,TInteger) | Represents method ValueOf(TDataItem,TInteger).
Top
See Also

Reference

  • BI.Expressions


TDataItemExpression Constructors

Constructors
Name | Description
Create(TDataItem,Boolean,TDataItem) | Initializes a new instance of the TDataItemExpression class.
Destroy | Represents the destructor of the TDataItemExpression class.
Top


TDataItemExpression.Create(TDataItem,Boolean,TDataItem) Constructor

Summary

Initializes a new instance of the TDataItemExpression class.

Namespace: BI.Expressions
Syntax
Delphi
public
 Constructor Create(const AData:TDataItem; const FreeData:Boolean=False; const AMain:TDataItem=nil);

Parameters

AData
Type: TDataItem

FreeData
Type: Boolean

AMain
Type: TDataItem

See Also

Reference

  • TDataItemExpression
  • BI.Expressions


TDataItemExpression.Destroy Destructor

Summary

Represents the destructor of the TDataItemExpression class.

Namespace: BI.Expressions
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TDataItemExpression
  • BI.Expressions


TDataItemExpression Properties

Properties
Name | Description
Data | Represents property Data.
Hops | Represents property Hops.
Top


TDataItemExpression.Data Property

Summary

Represents property Data.

Namespace: BI.Expressions
Syntax
Delphi
public
 property Data:TDataItem read FData;

Property Value

Type: TDataItem

See Also

Reference

  • TDataItemExpression
  • BI.Expressions


TDataItemExpression.Hops Property

Summary

Represents property Hops.

Namespace: BI.Expressions
Syntax
Delphi
public
 property Hops:THops read FHops;

Property Value

Type: THops

See Also

Reference

  • TDataItemExpression
  • BI.Expressions


TDataItemExpression Methods

Methods
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
IsLogical | Represents method IsLogical.
Kind | Represents method Kind.
LookupFill(TDataItem,TDataItem) | Represents method LookupFill(TDataItem,TDataItem).
NewLookup(String,TDataItem,TDataItem) | Represents method NewLookup(String,TDataItem,TDataItem).
Notify(TBIEvent) | Represents method Notify(TBIEvent).
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
ValueOf(TDataItem,TInteger) | Represents method ValueOf(TDataItem,TInteger).
Top


TDataItemExpression.Assign(TExpression) Method

Summary

Represents method Assign(TExpression).

Namespace: BI.Expressions
Syntax
Delphi
public
 procedure Assign(const Source:TExpression); override;

Parameters

Source
Type: TExpression

Overrides

TExpression.Assign(TExpression)
See Also

Reference

  • TDataItemExpression
  • BI.Expressions


TDataItemExpression.IsLogical Method

Summary

Represents method IsLogical.

Namespace: BI.Expressions
Syntax
Delphi
public
 function IsLogical:Boolean; inline;

Return Value

Type: Boolean

See Also

Reference

  • TDataItemExpression
  • BI.Expressions


TDataItemExpression.Kind Method

Summary

Represents method Kind.

Namespace: BI.Expressions
Syntax
Delphi
public
 function Kind:TDataKind;

Return Value

Type: TDataKind

See Also

Reference

  • TDataItemExpression
  • BI.Expressions


TDataItemExpression.LookupFill(TDataItem,TDataItem) Method

Summary

Represents method LookupFill(TDataItem,TDataItem).

Namespace: BI.Expressions
Syntax
Delphi
public
 class procedure LookupFill(const ASource,ADest:TDataItem); static;

Parameters

ASource
Type: TDataItem

ADest
Type: TDataItem

See Also

Reference

  • TDataItemExpression
  • BI.Expressions


TDataItemExpression.NewLookup(String,TDataItem,TDataItem) Method

Summary

Represents method NewLookup(String,TDataItem,TDataItem).

Namespace: BI.Expressions
Syntax
Delphi
public
 class function NewLookup(const AName:String; const ADetail:TDataItem; const AMaster:TDataItem):TDataItem;

Parameters

AName
Type: String

ADetail
Type: TDataItem

AMaster
Type: TDataItem

Return Value

Type: TDataItem

See Also

Reference

  • TDataItemExpression
  • BI.Expressions


TDataItemExpression.Notify(TBIEvent) Method

Summary

Represents method Notify(TBIEvent).

Namespace: BI.Expressions
Syntax
Delphi
protected
 procedure Notify(const AEvent:TBIEvent);

Parameters

AEvent
Type: TBIEvent

See Also

Reference

  • TDataItemExpression
  • BI.Expressions


TDataItemExpression.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expressions
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TDataItemExpression
  • BI.Expressions


TDataItemExpression.Value Method

Summary

Represents method Value.

Namespace: BI.Expressions
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TDataItemExpression
  • BI.Expressions


TDataItemExpression.ValueOf(TDataItem,TInteger) Method

Summary

Represents method ValueOf(TDataItem,TInteger).

Namespace: BI.Expressions
Syntax
Delphi
protected
 class function ValueOf(const AData:TDataItem; const AIndex:TInteger):TData; static;

Parameters

AData
Type: TDataItem

AIndex
Type: System.Void

Return Value

Type: TData

See Also

Reference

  • TDataItemExpression
  • BI.Expressions


TExpressionColumn Class

Summary

Represents type TExpressionColumn.

Namespace: BI.Expressions
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Expressions.TExpressionColumn
BI.DataSource.TExpressionColumnAccess
BI.Summary.TExpressionColumnAccess
Syntax
Delphi
type
 TExpressionColumn=class(TDataItem)
 end;

The TExpressionColumn type exposes the following members.

Constructors
Show:
Name | Description
Create(TDataItem,String) | Overloaded. Initializes a new instance of the TExpressionColumn class.
Create(TExpression) | Overloaded. Initializes a new instance of the TExpressionColumn class.
Top
Properties
Show:
Name | Description
Expression | Represents property Expression.
Top
Methods
Show:
Name | Description
Fill(TDataItem) | Represents method Fill(TDataItem).
From(TDataItem,String,Boolean,String,TErrorProc) | Overloaded. Represents method From(TDataItem,String,Boolean,String,TErrorProc).
From(TExpression,Boolean,String) | Overloaded. Represents method From(TExpression,Boolean,String).
Load(Boolean) | Represents method Load(Boolean). (Overrides TDataItem.Load(Boolean).)
SetValue(TDataItem,TInteger) | Represents method SetValue(TDataItem,TInteger).
Sort(Boolean) | Represents method Sort(Boolean).
Top
Fields
Show:
Name | Description
Data | Represents field Data.
FExpression | Represents field FExpression.
Top
See Also

Reference

  • BI.Expressions


TExpressionColumn Constructors

Constructors
Name | Description
Create(TDataItem,String) | Overloaded. Initializes a new instance of the TExpressionColumn class.
Create(TExpression) | Overloaded. Initializes a new instance of the TExpressionColumn class.
Top


TExpressionColumn.Create(TDataItem,String) Constructor

Summary

Initializes a new instance of the TExpressionColumn class.

Namespace: BI.Expressions
Syntax
Delphi
public
 Constructor Create(const AData:TDataItem; const AExpression:String); overload;

Parameters

AData
Type: TDataItem

AExpression
Type: String

See Also

Reference

  • TExpressionColumn
  • BI.Expressions


TExpressionColumn.Create(TExpression) Constructor

Summary

Initializes a new instance of the TExpressionColumn class.

Namespace: BI.Expressions
Syntax
Delphi
public
 Constructor Create(const AExpression:TExpression); overload;

Parameters

AExpression
Type: TExpression

See Also

Reference

  • TExpressionColumn
  • BI.Expressions


TExpressionColumn Properties

Properties
Name | Description
Expression | Represents property Expression.
Top


TExpressionColumn.Expression Property

Summary

Represents property Expression.

Namespace: BI.Expressions
Syntax
Delphi
public
 property Expression:TExpression read FExpression write SetExpression;

Property Value

Type: TExpression

See Also

Reference

  • TExpressionColumn
  • BI.Expressions


TExpressionColumn Methods

Methods
Name | Description
Fill(TDataItem) | Represents method Fill(TDataItem).
From(TDataItem,String,Boolean,String,TErrorProc) | Overloaded. Represents method From(TDataItem,String,Boolean,String,TErrorProc).
From(TExpression,Boolean,String) | Overloaded. Represents method From(TExpression,Boolean,String).
Load(Boolean) | Represents method Load(Boolean). (Overrides TDataItem.Load(Boolean).)
SetValue(TDataItem,TInteger) | Represents method SetValue(TDataItem,TInteger).
Sort(Boolean) | Represents method Sort(Boolean).
Top


TExpressionColumn.Fill(TDataItem) Method

Summary

Represents method Fill(TDataItem).

Namespace: BI.Expressions
Syntax
Delphi
public
 procedure Fill(const AParent:TDataItem=nil);

Parameters

AParent
Type: TDataItem

See Also

Reference

  • TExpressionColumn
  • BI.Expressions


TExpressionColumn.From(TDataItem,String,Boolean,String,TErrorProc) Method

Summary

Represents method From(TDataItem,String,Boolean,String,TErrorProc).

Namespace: BI.Expressions
Syntax
Delphi
public
 class function From(const AParent:TDataItem;
 const AExpression: String;
 const Fill:Boolean=True;
 const AName: String='';
 const Error:TErrorProc=nil): TDataItem; overload; static;

Parameters

AParent
Type: TDataItem

AExpression
Type: String

Fill
Type: Boolean

AName
Type: String

Error
Type: TErrorProc

Return Value

Type: TDataItem

See Also

Reference

  • TExpressionColumn
  • BI.Expressions


TExpressionColumn.From(TExpression,Boolean,String) Method

Summary

Represents method From(TExpression,Boolean,String).

Namespace: BI.Expressions
Syntax
Delphi
public
 class function From(const AExpression:TExpression;
 const Fill:Boolean=True;
 const AName:String=''):TDataItem; overload; static;

Parameters

AExpression
Type: TExpression

Fill
Type: Boolean

AName
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TExpressionColumn
  • BI.Expressions


TExpressionColumn.Load(Boolean) Method

Summary

Represents method Load(Boolean).

Namespace: BI.Expressions
Syntax
Delphi
public
 procedure Load(const Children:Boolean=False); override;

Parameters

Children
Type: Boolean

Overrides

TDataItem.Load(Boolean)
See Also

Reference

  • TExpressionColumn
  • BI.Expressions


TExpressionColumn.SetValue(TDataItem,TInteger) Method

Summary

Represents method SetValue(TDataItem,TInteger).

Namespace: BI.Expressions
Syntax
Delphi
protected
 procedure SetValue(const ADest:TDataItem; const AIndex:TInteger);

Parameters

ADest
Type: TDataItem

AIndex
Type: System.Void

See Also

Reference

  • TExpressionColumn
  • BI.Expressions


TExpressionColumn.Sort(Boolean) Method

Summary

Represents method Sort(Boolean).

Namespace: BI.Expressions
Syntax
Delphi
public
 function Sort(const Ascending:Boolean=True):TNativeIntArray;

Parameters

Ascending
Type: Boolean

Return Value

Type: TNativeIntArray

See Also

Reference

  • TExpressionColumn
  • BI.Expressions


TExpressionColumn Fields

Fields
Name | Description
Data | Represents field Data.
FExpression | Represents field FExpression.
Top


TExpressionColumn.Data Field

Summary

Represents field Data.

Namespace: BI.Expressions
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TExpressionColumn
  • BI.Expressions


TExpressionColumn.FExpression Field

Summary

Represents field FExpression.

Namespace: BI.Expressions
Syntax
Delphi
protected
 FExpression : TExpression;

Field Value

Type: TExpression

See Also

Reference

  • TExpressionColumn
  • BI.Expressions


THops Class

Summary

Represents type THops.

Namespace: BI.Expressions
Inheritance Hierarchy
TObject
BI.Expressions.THops
Syntax
Delphi
type
 THops=class
 end;

The THops type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the THops class.
Top
Methods
Show:
Name | Description
Index | Represents method Index.
Init(TDataItem,TDataItem) | Represents method Init(TDataItem,TDataItem).
Top
Fields
Show:
Name | Description
Items | Represents field Items.
Parent | Represents field Parent.
RealSource | Represents field RealSource.
SourceIndex | Represents field SourceIndex.
Valid | Represents field Valid.
Top
See Also

Reference

  • BI.Expressions


THops Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the THops class.
Top


THops.Destroy Destructor

Summary

Represents the destructor of the THops class.

Namespace: BI.Expressions
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • THops
  • BI.Expressions


THops Methods

Methods
Name | Description
Index | Represents method Index.
Init(TDataItem,TDataItem) | Represents method Init(TDataItem,TDataItem).
Top


THops.Index Method

Summary

Represents method Index.

Namespace: BI.Expressions
Syntax
Delphi
public
 function Index:TInteger;

Return Value

Type: TInteger

See Also

Reference

  • THops
  • BI.Expressions


THops.Init(TDataItem,TDataItem) Method

Summary

Represents method Init(TDataItem,TDataItem).

Namespace: BI.Expressions
Syntax
Delphi
public
 procedure Init(const ADetail,AMaster:TDataItem);

Parameters

ADetail
Type: TDataItem

AMaster
Type: TDataItem

See Also

Reference

  • THops
  • BI.Expressions


THops Fields

Fields
Name | Description
Items | Represents field Items.
Parent | Represents field Parent.
RealSource | Represents field RealSource.
SourceIndex | Represents field SourceIndex.
Valid | Represents field Valid.
Top


THops.Items Field

Summary

Represents field Items.

Namespace: BI.Expressions
Syntax
Delphi
public
 Items : THopArray;

Field Value

Type: THopArray

See Also

Reference

  • THops
  • BI.Expressions


THops.Parent Field

Summary

Represents field Parent.

Namespace: BI.Expressions
Syntax
Delphi
public
 Parent : THops;

Field Value

Type: THops

See Also

Reference

  • THops
  • BI.Expressions


THops.RealSource Field

Summary

Represents field RealSource.

Namespace: BI.Expressions
Syntax
Delphi
public
 RealSource : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • THops
  • BI.Expressions


THops.SourceIndex Field

Summary

Represents field SourceIndex.

Namespace: BI.Expressions
Syntax
Delphi
public
 SourceIndex : TInteger;

Field Value

Type: TInteger

See Also

Reference

  • THops
  • BI.Expressions


THops.Valid Field

Summary

Represents field Valid.

Namespace: BI.Expressions
Syntax
Delphi
public
 Valid : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • THops
  • BI.Expressions


TInvertedIndex Class

Summary

Represents type TInvertedIndex.

Namespace: BI.Expressions
Inheritance Hierarchy
TObject
BI.Arrays.TDataMap
BI.Arrays.TInt32Map
BI.Expressions.TInvertedIndex
Syntax
Delphi
type
 TInvertedIndex=class(TInt32Map)
 end;

The TInvertedIndex type exposes the following members.

Constructors
Show:
Name | Description
Create(TNativeIntArray) | Initializes a new instance of the TInvertedIndex class.
Top
See Also

Reference

  • BI.Expressions


TInvertedIndex Constructors

Constructors
Name | Description
Create(TNativeIntArray) | Initializes a new instance of the TInvertedIndex class.
Top


TInvertedIndex.Create(TNativeIntArray) Constructor

Summary

Initializes a new instance of the TInvertedIndex class.

Namespace: BI.Expressions
Syntax
Delphi
public
 Constructor Create(const AIndex:TNativeIntArray);

Parameters

AIndex
Type: System.Void

See Also

Reference

  • TInvertedIndex
  • BI.Expressions


TIsNullData Class

Summary

Represents type TIsNullData.

Namespace: BI.Expressions
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TUnaryExpression
BI.Expression.TParameterExpression
BI.Expressions.TIsNullData
Syntax
Delphi
type
 TIsNullData=class(TParameterExpression)
 end;

The TIsNullData type exposes the following members.

Methods
Show:
Name | Description
FromString(String) | Represents method FromString(String). (Overrides TParameterExpression.FromString(String).)
ResultClass | Represents method ResultClass. (Overrides TParameterExpression.ResultClass.)
SetExpression(TExpression) | Represents method SetExpression(TExpression). (Overrides TParameterExpression.SetExpression(TExpression).)
Value | Represents method Value. (Overrides TExpression.Value.)
Top
See Also

Reference

  • BI.Expressions


TIsNullData Methods

Methods
Name | Description
FromString(String) | Represents method FromString(String). (Overrides TParameterExpression.FromString(String).)
ResultClass | Represents method ResultClass. (Overrides TParameterExpression.ResultClass.)
SetExpression(TExpression) | Represents method SetExpression(TExpression). (Overrides TParameterExpression.SetExpression(TExpression).)
Value | Represents method Value. (Overrides TExpression.Value.)
Top


TIsNullData.FromString(String) Method

Summary

Represents method FromString(String).

Namespace: BI.Expressions
Syntax
Delphi
public
 class function FromString(const S:String):TParameterExpression; override;

Parameters

S
Type: String

Return Value

Type: TParameterExpression

Overrides

TParameterExpression.FromString(String)
See Also

Reference

  • TIsNullData
  • BI.Expressions


TIsNullData.ResultClass Method

Summary

Represents method ResultClass.

Namespace: BI.Expressions
Syntax
Delphi
protected
 function ResultClass:TExpressionClass; override;

Return Value

Type: TExpressionClass

Overrides

TParameterExpression.ResultClass
See Also

Reference

  • TIsNullData
  • BI.Expressions


TIsNullData.SetExpression(TExpression) Method

Summary

Represents method SetExpression(TExpression).

Namespace: BI.Expressions
Syntax
Delphi
protected
 procedure SetExpression(const Value:TExpression); override;

Parameters

Value
Type: TExpression

Overrides

TParameterExpression.SetExpression(TExpression)
See Also

Reference

  • TIsNullData
  • BI.Expressions


TIsNullData.Value Method

Summary

Represents method Value.

Namespace: BI.Expressions
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TIsNullData
  • BI.Expressions


TMovingAverageColumn Class

Summary

Represents type TMovingAverageColumn.

Namespace: BI.Expressions
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TUnaryExpression
BI.Expressions.TColumnExpression
BI.Expressions.TMovingAverageColumn
Syntax
Delphi
type
 TMovingAverageColumn=class(TColumnExpression)
 end;

The TMovingAverageColumn type exposes the following members.

Constructors
Show:
Name | Description
Create(TExpression,Integer) | Initializes a new instance of the TMovingAverageColumn class.
Top
Methods
Show:
Name | Description
Calculate(TDataHops,TDataItem) | Represents method Calculate(TDataHops,TDataItem). (Overrides TColumnExpression.Calculate(TDataHops,TDataItem).)
Kind | Represents method Kind. (Overrides TColumnExpression.Kind.)
ToString | Represents method ToString.
TryParse(String) | Represents method TryParse(String). (Overrides TColumnExpression.TryParse(String).)
Value | Represents method Value. (Overrides TExpression.Value.)
Top
Fields
Show:
Name | Description
Period | Represents field Period.
Top
See Also

Reference

  • BI.Expressions


TMovingAverageColumn Constructors

Constructors
Name | Description
Create(TExpression,Integer) | Initializes a new instance of the TMovingAverageColumn class.
Top


TMovingAverageColumn.Create(TExpression,Integer) Constructor

Summary

Initializes a new instance of the TMovingAverageColumn class.

Namespace: BI.Expressions
Syntax
Delphi
public
 Constructor Create(const AExpression:TExpression; const APeriod:Integer);

Parameters

AExpression
Type: TExpression

APeriod
Type: Integer

See Also

Reference

  • TMovingAverageColumn
  • BI.Expressions


TMovingAverageColumn Methods

Methods
Name | Description
Calculate(TDataHops,TDataItem) | Represents method Calculate(TDataHops,TDataItem). (Overrides TColumnExpression.Calculate(TDataHops,TDataItem).)
Kind | Represents method Kind. (Overrides TColumnExpression.Kind.)
ToString | Represents method ToString.
TryParse(String) | Represents method TryParse(String). (Overrides TColumnExpression.TryParse(String).)
Value | Represents method Value. (Overrides TExpression.Value.)
Top


TMovingAverageColumn.Calculate(TDataHops,TDataItem) Method

Summary

Represents method Calculate(TDataHops,TDataItem).

Namespace: BI.Expressions
Syntax
Delphi
protected
 procedure Calculate(const Hops:TDataHops; const Dest:TDataItem); override;

Parameters

Hops
Type: TDataHops

Dest
Type: TDataItem

Overrides

TColumnExpression.Calculate(TDataHops,TDataItem)
See Also

Reference

  • TMovingAverageColumn
  • BI.Expressions


TMovingAverageColumn.Kind Method

Summary

Represents method Kind.

Namespace: BI.Expressions
Syntax
Delphi
protected
 function Kind:TDataKind; override;

Return Value

Type: TDataKind

Overrides

TColumnExpression.Kind
See Also

Reference

  • TMovingAverageColumn
  • BI.Expressions


TMovingAverageColumn.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expressions
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TMovingAverageColumn
  • BI.Expressions


TMovingAverageColumn.TryParse(String) Method

Summary

Represents method TryParse(String).

Namespace: BI.Expressions
Syntax
Delphi
protected
 class function TryParse(const S:String):TColumnExpression; override;

Parameters

S
Type: String

Return Value

Type: TColumnExpression

Overrides

TColumnExpression.TryParse(String)
See Also

Reference

  • TMovingAverageColumn
  • BI.Expressions


TMovingAverageColumn.Value Method

Summary

Represents method Value.

Namespace: BI.Expressions
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TMovingAverageColumn
  • BI.Expressions


TMovingAverageColumn Fields

Fields
Name | Description
Period | Represents field Period.
Top


TMovingAverageColumn.Period Field

Summary

Represents field Period.

Namespace: BI.Expressions
Syntax
Delphi
public
 Period : Integer;

Field Value

Type: Integer

See Also

Reference

  • TMovingAverageColumn
  • BI.Expressions


TParameterExpressionAccess Class

Summary

Represents type TParameterExpressionAccess.

Namespace: BI.Expressions
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TUnaryExpression
BI.Expression.TParameterExpression
BI.Expressions.TParameterExpressionAccess
Syntax
Delphi
type
 TParameterExpressionAccess=class(TParameterExpression);
See Also

Reference

  • BI.Expressions


TSortItemArrayHelper Class Helper

Summary

Represents type TSortItemArrayHelper.

Namespace: BI.Expressions
Syntax
Delphi
type
 TSortItemArrayHelper=record helper for TSortItemArray
 end;
Methods
Name | Description
NotInOrder(TInteger,TInteger) | Represents method NotInOrder(TInteger,TInteger).
Top
See Also

Reference

  • BI.Expressions


TSortItemArrayHelper Methods

Methods
Name | Description
NotInOrder(TInteger,TInteger) | Represents method NotInOrder(TInteger,TInteger).
Top


TSortItemArrayHelper.NotInOrder(TInteger,TInteger) Method

Summary

Represents method NotInOrder(TInteger,TInteger).

Namespace: BI.Expressions
Syntax
Delphi
public
 function NotInOrder(const A,B:TInteger):Boolean;

Parameters

A
Type: System.Void

B
Type: System.Void

Return Value

Type: Boolean

See Also

Reference

  • TSortItemArrayHelper
  • BI.Expressions


BI.Expressions Records

Records
Name | Description
TDataFilter | Represents type TDataFilter.
TDataFunctions | Represents type TDataFunctions.
TDataItemSort | Represents type TDataItemSort.
TSortItems | Represents type TSortItems.
Top


TDataFilter Record

Summary

Represents type TDataFilter.

Namespace: BI.Expressions
Syntax
Delphi
type
 TDataFilter=record
 end;

The TDataFilter type exposes the following members.

Methods
Show:
Name | Description
FromString(TDataItem,String,TErrorProc) | Represents method FromString(TDataItem,String,TErrorProc).
VerifyLogical(TExpression,String,TErrorProc) | Represents method VerifyLogical(TExpression,String,TErrorProc).
Top
See Also

Reference

  • BI.Expressions


TDataFilter Methods

Methods
Name | Description
FromString(TDataItem,String,TErrorProc) | Represents method FromString(TDataItem,String,TErrorProc).
VerifyLogical(TExpression,String,TErrorProc) | Represents method VerifyLogical(TExpression,String,TErrorProc).
Top


TDataFilter.FromString(TDataItem,String,TErrorProc) Method

Summary

Represents method FromString(TDataItem,String,TErrorProc).

Namespace: BI.Expressions
Syntax
Delphi
public
 class function FromString(const AData:TDataItem; const AExpression: String;
 const Error:TErrorProc=nil): TExpression; static;

Parameters

AData
Type: TDataItem

AExpression
Type: String

Error
Type: TErrorProc

Return Value

Type: TExpression

See Also

Reference

  • TDataFilter
  • BI.Expressions


TDataFilter.VerifyLogical(TExpression,String,TErrorProc) Method

Summary

Represents method VerifyLogical(TExpression,String,TErrorProc).

Namespace: BI.Expressions
Syntax
Delphi
public
 class function VerifyLogical(const AExpression:TExpression;
 const AText: String;
 const Error:TErrorProc): TExpression; static;

Parameters

AExpression
Type: TExpression

AText
Type: String

Error
Type: TErrorProc

Return Value

Type: TExpression

See Also

Reference

  • TDataFilter
  • BI.Expressions


TDataFunctions Record

Summary

Represents type TDataFunctions.

Namespace: BI.Expressions
Syntax
Delphi
type
 TDataFunctions=record
 end;

The TDataFunctions type exposes the following members.

Methods
Show:
Name | Description
Register(TColumnExpressionClass) | Represents method Register(TColumnExpressionClass).
TryParse(String) | Represents method TryParse(String).
UnRegister(TColumnExpressionClass) | Represents method UnRegister(TColumnExpressionClass).
Top
Fields
Show:
Name | Description
Count | Represents field Count.
Items | Represents field Items.
Top
See Also

Reference

  • BI.Expressions


TDataFunctions Methods

Methods
Name | Description
Register(TColumnExpressionClass) | Represents method Register(TColumnExpressionClass).
TryParse(String) | Represents method TryParse(String).
UnRegister(TColumnExpressionClass) | Represents method UnRegister(TColumnExpressionClass).
Top


TDataFunctions.Register(TColumnExpressionClass) Method

Summary

Represents method Register(TColumnExpressionClass).

Namespace: BI.Expressions
Syntax
Delphi
public
 class procedure Register(const AClass:TColumnExpressionClass); static;

Parameters

AClass
Type: TColumnExpressionClass

See Also

Reference

  • TDataFunctions
  • BI.Expressions


TDataFunctions.TryParse(String) Method

Summary

Represents method TryParse(String).

Namespace: BI.Expressions
Syntax
Delphi
public
 class function TryParse(const S:String):TExpression; static;

Parameters

S
Type: String

Return Value

Type: TExpression

See Also

Reference

  • TDataFunctions
  • BI.Expressions


TDataFunctions.UnRegister(TColumnExpressionClass) Method

Summary

Represents method UnRegister(TColumnExpressionClass).

Namespace: BI.Expressions
Syntax
Delphi
public
 class procedure UnRegister(const AClass:TColumnExpressionClass); static;

Parameters

AClass
Type: TColumnExpressionClass

See Also

Reference

  • TDataFunctions
  • BI.Expressions


TDataFunctions Fields

Fields
Name | Description
Count | Represents field Count.
Items | Represents field Items.
Top


TDataFunctions.Count Field

Summary

Represents field Count.

Namespace: BI.Expressions
Syntax
Delphi
public
 class var
 Count : Integer;

Field Value

Type: Integer

See Also

Reference

  • TDataFunctions
  • BI.Expressions


TDataFunctions.Items Field

Summary

Represents field Items.

Namespace: BI.Expressions
Syntax
Delphi
public
 class var
 Items : Array of TColumnExpressionClass;

Field Value

Type: Array of TColumnExpressionClass

See Also

Reference

  • TDataFunctions
  • BI.Expressions


TDataItemSort Record

Summary

Represents type TDataItemSort.

Namespace: BI.Expressions
Syntax
Delphi
type
 TDataItemSort=record
 end;

The TDataItemSort type exposes the following members.

Methods
Show:
Name | Description
By(TDataItem,String,Boolean,Boolean) | Overloaded. Represents method By(TDataItem,String,Boolean,Boolean).
By(TDataItem,TExpression,Boolean,Boolean) | Overloaded. Represents method By(TDataItem,TExpression,Boolean,Boolean).
Top
See Also

Reference

  • BI.Expressions


TDataItemSort Methods

Methods
Name | Description
By(TDataItem,String,Boolean,Boolean) | Overloaded. Represents method By(TDataItem,String,Boolean,Boolean).
By(TDataItem,TExpression,Boolean,Boolean) | Overloaded. Represents method By(TDataItem,TExpression,Boolean,Boolean).
Top


TDataItemSort.By(TDataItem,String,Boolean,Boolean) Method

Summary

Represents method By(TDataItem,String,Boolean,Boolean).

Namespace: BI.Expressions
Syntax
Delphi
public
 class procedure By(const AData: TDataItem;
 const AExpression:String;
 const Ascending: Boolean=True;
 const IgnoreTextCase:Boolean=False); overload; static;

Parameters

AData
Type: TDataItem

AExpression
Type: String

Ascending
Type: Boolean

IgnoreTextCase
Type: Boolean

See Also

Reference

  • TDataItemSort
  • BI.Expressions


TDataItemSort.By(TDataItem,TExpression,Boolean,Boolean) Method

Summary

Represents method By(TDataItem,TExpression,Boolean,Boolean).

Namespace: BI.Expressions
Syntax
Delphi
public
 class procedure By(const AData: TDataItem;
 const AExpression:TExpression;
 const Ascending: Boolean=True;
 const IgnoreTextCase:Boolean=False); overload; static;

Parameters

AData
Type: TDataItem

AExpression
Type: TExpression

Ascending
Type: Boolean

IgnoreTextCase
Type: Boolean

See Also

Reference

  • TDataItemSort
  • BI.Expressions


TSortItems Record

Summary

Represents type TSortItems.

Namespace: BI.Expressions
Syntax
Delphi
type
 TSortItems=record
 end;

The TSortItems type exposes the following members.

Methods
Show:
Name | Description
ActiveCount | Represents method ActiveCount.
Add(TDataItem,Boolean,Boolean) | Overloaded. Represents method Add(TDataItem,Boolean,Boolean).
Clear | Represents method Clear.
Count | Represents method Count.
Delete(Integer) | Represents method Delete(Integer).
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer).
IndexOf(TDataItem) | Represents method IndexOf(TDataItem).
InvertOrder(TDataItem) | Represents method InvertOrder(TDataItem).
Sort(TDataItem) | Overloaded. Represents method Sort(TDataItem).
Sort(TDataItem,TNativeIntArray) | Overloaded. Represents method Sort(TDataItem,TNativeIntArray).
SortData(TDataItem) | Represents method SortData(TDataItem).
ToString | Represents method ToString.
Top
Fields
Show:
Name | Description
Items | Represents field Items.
Top
See Also

Reference

  • BI.Expressions


TSortItems Methods

Methods
Name | Description
ActiveCount | Represents method ActiveCount.
Add(TDataItem,Boolean,Boolean) | Overloaded. Represents method Add(TDataItem,Boolean,Boolean).
Clear | Represents method Clear.
Count | Represents method Count.
Delete(Integer) | Represents method Delete(Integer).
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer).
IndexOf(TDataItem) | Represents method IndexOf(TDataItem).
InvertOrder(TDataItem) | Represents method InvertOrder(TDataItem).
Sort(TDataItem) | Overloaded. Represents method Sort(TDataItem).
Sort(TDataItem,TNativeIntArray) | Overloaded. Represents method Sort(TDataItem,TNativeIntArray).
SortData(TDataItem) | Represents method SortData(TDataItem).
ToString | Represents method ToString.
Top


TSortItems.ActiveCount Method

Summary

Represents method ActiveCount.

Namespace: BI.Expressions
Syntax
Delphi
public
 function ActiveCount:Integer;

Return Value

Type: Integer

See Also

Reference

  • TSortItems
  • BI.Expressions


TSortItems.Add(TDataItem,Boolean,Boolean) Method

Summary

Represents method Add(TDataItem,Boolean,Boolean).

Namespace: BI.Expressions
Syntax
Delphi
public
 procedure Add(const AData:TDataItem; const Ascending:Boolean=True; const IgnoreTextCase:Boolean=False); overload;

Parameters

AData
Type: TDataItem

Ascending
Type: Boolean

IgnoreTextCase
Type: Boolean

See Also

Reference

  • TSortItems
  • BI.Expressions


TSortItems.Clear Method

Summary

Represents method Clear.

Namespace: BI.Expressions
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TSortItems
  • BI.Expressions


TSortItems.Count Method

Summary

Represents method Count.

Namespace: BI.Expressions
Syntax
Delphi
public
 function Count:Integer; inline;

Return Value

Type: Integer

See Also

Reference

  • TSortItems
  • BI.Expressions


TSortItems.Delete(Integer) Method

Summary

Represents method Delete(Integer).

Namespace: BI.Expressions
Syntax
Delphi
public
 procedure Delete(const AIndex:Integer);

Parameters

AIndex
Type: Integer

See Also

Reference

  • TSortItems
  • BI.Expressions


TSortItems.Exchange(Integer,Integer) Method

Summary

Represents method Exchange(Integer,Integer).

Namespace: BI.Expressions
Syntax
Delphi
public
 procedure Exchange(const A,B:Integer);

Parameters

A
Type: Integer

B
Type: Integer

See Also

Reference

  • TSortItems
  • BI.Expressions


TSortItems.IndexOf(TDataItem) Method

Summary

Represents method IndexOf(TDataItem).

Namespace: BI.Expressions
Syntax
Delphi
public
 function IndexOf(const AData:TDataItem):Integer;

Parameters

AData
Type: TDataItem

Return Value

Type: Integer

See Also

Reference

  • TSortItems
  • BI.Expressions


TSortItems.InvertOrder(TDataItem) Method

Summary

Represents method InvertOrder(TDataItem).

Namespace: BI.Expressions
Syntax
Delphi
public
 function InvertOrder(const AData:TDataItem):Boolean;

Parameters

AData
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • TSortItems
  • BI.Expressions


TSortItems.Sort(TDataItem) Method

Summary

Represents method Sort(TDataItem).

Namespace: BI.Expressions
Syntax
Delphi
public
 function Sort(const AData:TDataItem): TNativeIntArray; overload;

Parameters

AData
Type: TDataItem

Return Value

Type: TNativeIntArray

See Also

Reference

  • TSortItems
  • BI.Expressions


TSortItems.Sort(TDataItem,TNativeIntArray) Method

Summary

Represents method Sort(TDataItem,TNativeIntArray).

Namespace: BI.Expressions
Syntax
Delphi
public
 function Sort(const AData:TDataItem; const AIndex:TNativeIntArray): TNativeIntArray; overload;

Parameters

AData
Type: TDataItem

AIndex
Type: System.Void

Return Value

Type: TNativeIntArray

See Also

Reference

  • TSortItems
  • BI.Expressions


TSortItems.SortData(TDataItem) Method

Summary

Represents method SortData(TDataItem).

Namespace: BI.Expressions
Syntax
Delphi
public
 procedure SortData(const AData:TDataItem);

Parameters

AData
Type: TDataItem

See Also

Reference

  • TSortItems
  • BI.Expressions


TSortItems.ToString Method

Summary

Represents method ToString.

Namespace: BI.Expressions
Syntax
Delphi
public
 function ToString: String;

Return Value

Type: String

See Also

Reference

  • TSortItems
  • BI.Expressions


TSortItems Fields

Fields
Name | Description
Items | Represents field Items.
Top


TSortItems.Items Field

Summary

Represents field Items.

Namespace: BI.Expressions
Syntax
Delphi
public
 Items : TSortItemArray;

Field Value

Type: TSortItemArray

See Also

Reference

  • TSortItems
  • BI.Expressions


BI.Expressions Enumerations

Enumerations
Name | Description
TColumnOperand | Represents type TColumnOperand.
Top


TColumnOperand Enumeration

Summary

Represents type TColumnOperand.

Namespace: BI.Expressions
Syntax
Delphi
type
 TColumnOperand=(Percent,PercentChange,Cumulative
 );

The TColumnOperand type exposes the following members.

Members
Show:
Name | Description
Cumulative | Represents constant Cumulative.
Percent | Represents constant Percent.
PercentChange | Represents constant PercentChange.
Top
See Also

Reference

  • BI.Expressions


BI.Expressions Types

Types
Name | Description
TColumnExpressionClass | Represents type TColumnExpressionClass.
TDataExpression.TResolver | Represents type TResolver.
TSortItemArray | Represents an array of the TSortItem type.
Top


TColumnExpressionClass Type

Summary

Represents type TColumnExpressionClass.

Namespace: BI.Expressions
Syntax
Delphi
type
 TColumnExpressionClass=class of TColumnExpression;
See Also

Reference

  • BI.Expressions


TDataExpression.TResolver Type

Summary

Represents type TResolver.

Namespace: BI.Expressions
Syntax
Delphi
public
type
 TResolver=reference to function(const AData:TDataItem;
 const AExpression: String;
 const Error:TErrorProc=nil): TExpression;
See Also

Reference

  • TDataExpression
  • BI.Expressions


TSortItemArray Type

Summary

Represents an array of the TSortItem type.

Namespace: BI.Expressions
Syntax
Delphi
type
 TSortItemArray=Array of TSortItem;
See Also

Reference

  • BI.Expressions


BI.Expressions Routines

Routines
Name | Description
AnyOneToOne(TDataItem) | Represents method AnyOneToOne(TDataItem).
GuessMultiItems(TDataItem,TDataItem) | Represents method GuessMultiItems(TDataItem,TDataItem).
IndexOfMaster(TDataItem,TDataArray) | Represents method IndexOfMaster(TDataItem,TDataArray).
LocalToData(TDataItem,String,TBIErrorProc) | Represents method LocalToData(TDataItem,String,TBIErrorProc).
Top


AnyOneToOne(TDataItem) Method

Summary

Represents method AnyOneToOne(TDataItem).

Namespace: BI.Expressions
Syntax
Delphi
function AnyOneToOne(const AData:TDataItem):TDataItem;

Parameters

AData
Type: TDataItem

Return Value

Type: TDataItem

See Also

Reference

  • BI.Expressions


GuessMultiItems(TDataItem,TDataItem) Method

Summary

Represents method GuessMultiItems(TDataItem,TDataItem).

Namespace: BI.Expressions
Syntax
Delphi
function GuessMultiItems(const Start,Dest:TDataItem):TDataArray;

Parameters

Start
Type: TDataItem

Dest
Type: TDataItem

Return Value

Type: TDataArray

See Also

Reference

  • BI.Expressions


IndexOfMaster(TDataItem,TDataArray) Method

Summary

Represents method IndexOfMaster(TDataItem,TDataArray).

Namespace: BI.Expressions
Syntax
Delphi
function IndexOfMaster(const ACol:TDataItem; const AList:TDataArray):Integer;

Parameters

ACol
Type: TDataItem

AList
Type: TDataArray

Return Value

Type: Integer

See Also

Reference

  • BI.Expressions


LocalToData(TDataItem,String,TBIErrorProc) Method

Summary

Represents method LocalToData(TDataItem,String,TBIErrorProc).

Namespace: BI.Expressions
Syntax
Delphi
function LocalToData(const AData:TDataItem; const S:String; const Error:TBIErrorProc=nil):TDataItem;

Parameters

AData
Type: TDataItem

S
Type: String

Error
Type: TBIErrorProc

Return Value

Type: TDataItem

See Also

Reference

  • BI.Expressions


BI.FPC Namespace

Summary

Represents namespace BI.FPC.

Classes
Name | Description
TProc<T> | Represents type TProc<T>.
Top


BI.FPC Classes

Classes
Name | Description
TProc<T> | Represents type TProc<T>.
Top


TProc<T> Class

Summary

Represents type TProc<T>.

Namespace: BI.FPC
Inheritance Hierarchy
TObject
BI.FPC.TProc<T>
Syntax
Delphi
type
 TProc<T

Type Parameters

T
See Also

Reference

  • BI.FPC


BI.Geographic Namespace

Summary

Represents namespace BI.Geographic.

Classes
Name | Description
TDataItemAccess | Represents type TDataItemAccess.
Top
Records
Name | Description
TCountry | Represents type TCountry.
TEntities | Represents type TEntities.
TEntities.TAustralia | Represents type TAustralia.
TEntities.TBrazil | Represents type TBrazil.
TEntities.TCanada | Represents type TCanada.
TEntities.TChina | Represents type TChina.
TEntities.TFrance | Represents type TFrance.
TEntities.TGermany | Represents type TGermany.
TEntities.TIndia | Represents type TIndia.
TEntities.TIndonesia | Represents type TIndonesia.
TEntities.TItaly | Represents type TItaly.
TEntities.TJapan | Represents type TJapan.
TEntities.TMexico | Represents type TMexico.
TEntities.TNetherlands | Represents type TNetherlands.
TEntities.TPortugal | Represents type TPortugal.
TEntities.TRussia | Represents type TRussia.
TEntities.TSouthAfrica | Represents type TSouthAfrica.
TEntities.TSouthKorea | Represents type TSouthKorea.
TEntities.TSpain | Represents type TSpain.
TEntities.TSwitzerland | Represents type TSwitzerland.
TEntities.TUK | Represents type TUK.
TEntities.TUSA | Represents type TUSA.
TEntity | Represents type TEntity.
TGeo | Represents type TGeo.
TMasterDetail | Represents type TMasterDetail.
Top
Variables
Name | Description
ILinks | Represents variable ILinks.
SynonymNames | Represents variable SynonymNames.
Synonyms | Represents variable Synonyms.
Top
Routines
Name | Description
FindLinkDetail(TDataItem,TMasterDetail) | Represents method FindLinkDetail(TDataItem,TMasterDetail).
PadZeroLeft(Integer,Integer) | Represents method PadZeroLeft(Integer,Integer).
Top


BI.Geographic Classes

Classes
Name | Description
TDataItemAccess | Represents type TDataItemAccess.
Top


TDataItemAccess Class

Summary

Represents type TDataItemAccess.

Namespace: BI.Geographic
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Geographic.TDataItemAccess
Syntax
Delphi
type
 TDataItemAccess=class(TDataItem);
See Also

Reference

  • BI.Geographic


BI.Geographic Records

Records
Name | Description
TCountry | Represents type TCountry.
TEntities | Represents type TEntities.
TEntities.TAustralia | Represents type TAustralia.
TEntities.TBrazil | Represents type TBrazil.
TEntities.TCanada | Represents type TCanada.
TEntities.TChina | Represents type TChina.
TEntities.TFrance | Represents type TFrance.
TEntities.TGermany | Represents type TGermany.
TEntities.TIndia | Represents type TIndia.
TEntities.TIndonesia | Represents type TIndonesia.
TEntities.TItaly | Represents type TItaly.
TEntities.TJapan | Represents type TJapan.
TEntities.TMexico | Represents type TMexico.
TEntities.TNetherlands | Represents type TNetherlands.
TEntities.TPortugal | Represents type TPortugal.
TEntities.TRussia | Represents type TRussia.
TEntities.TSouthAfrica | Represents type TSouthAfrica.
TEntities.TSouthKorea | Represents type TSouthKorea.
TEntities.TSpain | Represents type TSpain.
TEntities.TSwitzerland | Represents type TSwitzerland.
TEntities.TUK | Represents type TUK.
TEntities.TUSA | Represents type TUSA.
TEntity | Represents type TEntity.
TGeo | Represents type TGeo.
TMasterDetail | Represents type TMasterDetail.
Top


TCountry Record

Summary

Represents type TCountry.

Namespace: BI.Geographic
Syntax
Delphi
type
 TCountry=record
 end;

The TCountry type exposes the following members.

Fields
Show:
Name | Description
Capital | Represents field Capital.
Countries | Represents field Countries.
ISOA2 | Represents field ISOA2.
ISOA3 | Represents field ISOA3.
ISONum | Represents field ISONum.
Name | Represents field Name.
Top
See Also

Reference

  • BI.Geographic


TCountry Fields

Fields
Name | Description
Capital | Represents field Capital.
Countries | Represents field Countries.
ISOA2 | Represents field ISOA2.
ISOA3 | Represents field ISOA3.
ISONum | Represents field ISONum.
Name | Represents field Name.
Top


TCountry.Capital Field

Summary

Represents field Capital.

Namespace: BI.Geographic
Syntax
Delphi
public
 Countries,
 ISONum,
 ISOA2,
 ISOA3,
 Capital,
 Name : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TCountry
  • BI.Geographic


TCountry.Countries Field

Summary

Represents field Countries.

Namespace: BI.Geographic
Syntax
Delphi
public
 Countries,
 ISONum,
 ISOA2,
 ISOA3,
 Capital,
 Name : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TCountry
  • BI.Geographic


TCountry.ISOA2 Field

Summary

Represents field ISOA2.

Namespace: BI.Geographic
Syntax
Delphi
public
 Countries,
 ISONum,
 ISOA2,
 ISOA3,
 Capital,
 Name : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TCountry
  • BI.Geographic


TCountry.ISOA3 Field

Summary

Represents field ISOA3.

Namespace: BI.Geographic
Syntax
Delphi
public
 Countries,
 ISONum,
 ISOA2,
 ISOA3,
 Capital,
 Name : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TCountry
  • BI.Geographic


TCountry.ISONum Field

Summary

Represents field ISONum.

Namespace: BI.Geographic
Syntax
Delphi
public
 Countries,
 ISONum,
 ISOA2,
 ISOA3,
 Capital,
 Name : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TCountry
  • BI.Geographic


TCountry.Name Field

Summary

Represents field Name.

Namespace: BI.Geographic
Syntax
Delphi
public
 Countries,
 ISONum,
 ISOA2,
 ISOA3,
 Capital,
 Name : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TCountry
  • BI.Geographic


TEntities Record

Summary

Represents type TEntities.

Namespace: BI.Geographic
Syntax
Delphi
type
 TEntities=record
 end;

The TEntities type exposes the following members.

Fields
Show:
Name | Description
Australia | Represents field Australia.
Brazil | Represents field Brazil.
Canada | Represents field Canada.
China | Represents field China.
Country | Represents field Country.
Data | Represents field Data.
France | Represents field France.
Germany | Represents field Germany.
India | Represents field India.
Indonesia | Represents field Indonesia.
Italy | Represents field Italy.
Japan | Represents field Japan.
Mexico | Represents field Mexico.
Netherlands | Represents field Netherlands.
Portugal | Represents field Portugal.
Russia | Represents field Russia.
SouthAfrica | Represents field SouthAfrica.
SouthKorea | Represents field SouthKorea.
Spain | Represents field Spain.
Switzerland | Represents field Switzerland.
UK | Represents field UK.
USA | Represents field USA.
Top
See Also

Reference

  • BI.Geographic


TEntities Fields

Fields
Name | Description
Australia | Represents field Australia.
Brazil | Represents field Brazil.
Canada | Represents field Canada.
China | Represents field China.
Country | Represents field Country.
Data | Represents field Data.
France | Represents field France.
Germany | Represents field Germany.
India | Represents field India.
Indonesia | Represents field Indonesia.
Italy | Represents field Italy.
Japan | Represents field Japan.
Mexico | Represents field Mexico.
Netherlands | Represents field Netherlands.
Portugal | Represents field Portugal.
Russia | Represents field Russia.
SouthAfrica | Represents field SouthAfrica.
SouthKorea | Represents field SouthKorea.
Spain | Represents field Spain.
Switzerland | Represents field Switzerland.
UK | Represents field UK.
USA | Represents field USA.
Top


TEntities.Australia Field

Summary

Represents field Australia.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data,
 Australia : TAustralia;

Field Value

Type: TAustralia

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.Brazil Field

Summary

Represents field Brazil.

Namespace: BI.Geographic
Syntax
Delphi
public
 Brazil : TBrazil;

Field Value

Type: TBrazil

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.Canada Field

Summary

Represents field Canada.

Namespace: BI.Geographic
Syntax
Delphi
public
 Canada : TCanada;

Field Value

Type: TCanada

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.China Field

Summary

Represents field China.

Namespace: BI.Geographic
Syntax
Delphi
public
 China : TChina;

Field Value

Type: TChina

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.Country Field

Summary

Represents field Country.

Namespace: BI.Geographic
Syntax
Delphi
public
 Country : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data,
 Australia : TAustralia;

Field Value

Type: TAustralia

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.France Field

Summary

Represents field France.

Namespace: BI.Geographic
Syntax
Delphi
public
 France : TFrance;

Field Value

Type: TFrance

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.Germany Field

Summary

Represents field Germany.

Namespace: BI.Geographic
Syntax
Delphi
public
 Germany : TGermany;

Field Value

Type: TGermany

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.India Field

Summary

Represents field India.

Namespace: BI.Geographic
Syntax
Delphi
public
 India : TIndia;

Field Value

Type: TIndia

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.Indonesia Field

Summary

Represents field Indonesia.

Namespace: BI.Geographic
Syntax
Delphi
public
 Indonesia : TIndonesia;

Field Value

Type: TIndonesia

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.Italy Field

Summary

Represents field Italy.

Namespace: BI.Geographic
Syntax
Delphi
public
 Italy : TItaly;

Field Value

Type: TItaly

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.Japan Field

Summary

Represents field Japan.

Namespace: BI.Geographic
Syntax
Delphi
public
 Japan : TJapan;

Field Value

Type: TJapan

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.Mexico Field

Summary

Represents field Mexico.

Namespace: BI.Geographic
Syntax
Delphi
public
 Mexico : TMexico;

Field Value

Type: TMexico

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.Netherlands Field

Summary

Represents field Netherlands.

Namespace: BI.Geographic
Syntax
Delphi
public
 Netherlands : TNetherlands;

Field Value

Type: TNetherlands

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.Portugal Field

Summary

Represents field Portugal.

Namespace: BI.Geographic
Syntax
Delphi
public
 Portugal : TPortugal;

Field Value

Type: TPortugal

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.Russia Field

Summary

Represents field Russia.

Namespace: BI.Geographic
Syntax
Delphi
public
 Russia : TRussia;

Field Value

Type: TRussia

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.SouthAfrica Field

Summary

Represents field SouthAfrica.

Namespace: BI.Geographic
Syntax
Delphi
public
 SouthAfrica : TSouthAfrica;

Field Value

Type: TSouthAfrica

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.SouthKorea Field

Summary

Represents field SouthKorea.

Namespace: BI.Geographic
Syntax
Delphi
public
 SouthKorea : TSouthKorea;

Field Value

Type: TSouthKorea

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.Spain Field

Summary

Represents field Spain.

Namespace: BI.Geographic
Syntax
Delphi
public
 Spain : TSpain;

Field Value

Type: TSpain

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.Switzerland Field

Summary

Represents field Switzerland.

Namespace: BI.Geographic
Syntax
Delphi
public
 Switzerland : TSwitzerland;

Field Value

Type: TSwitzerland

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.UK Field

Summary

Represents field UK.

Namespace: BI.Geographic
Syntax
Delphi
public
 UK : TUK;

Field Value

Type: TUK

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.USA Field

Summary

Represents field USA.

Namespace: BI.Geographic
Syntax
Delphi
public
 USA : TUSA;

Field Value

Type: TUSA

See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.TAustralia Record

Summary

Represents type TAustralia.

Namespace: BI.Geographic
Syntax
Delphi
public
type
 TAustralia=record
 end;

The TEntities.TAustralia type exposes the following members.

Fields
Show:
Name | Description
Counties | Represents field Counties.
Data | Represents field Data.
Lands | Represents field Lands.
Top
See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.TAustralia Fields

Fields
Name | Description
Counties | Represents field Counties.
Data | Represents field Data.
Lands | Represents field Lands.
Top


TEntities.TAustralia.Counties Field

Summary

Represents field Counties.

Namespace: BI.Geographic
Syntax
Delphi
public
 Lands,
 Counties : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TAustralia
  • TEntities
  • BI.Geographic


TEntities.TAustralia.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntities.TAustralia
  • TEntities
  • BI.Geographic


TEntities.TAustralia.Lands Field

Summary

Represents field Lands.

Namespace: BI.Geographic
Syntax
Delphi
public
 Lands,
 Counties : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TAustralia
  • TEntities
  • BI.Geographic


TEntities.TBrazil Record

Summary

Represents type TBrazil.

Namespace: BI.Geographic
Syntax
Delphi
public
type
 TBrazil=record
 end;

The TEntities.TBrazil type exposes the following members.

Fields
Show:
Name | Description
Data | Represents field Data.
Regions | Represents field Regions.
States | Represents field States.
Top
See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.TBrazil Fields

Fields
Name | Description
Data | Represents field Data.
Regions | Represents field Regions.
States | Represents field States.
Top


TEntities.TBrazil.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntities.TBrazil
  • TEntities
  • BI.Geographic


TEntities.TBrazil.Regions Field

Summary

Represents field Regions.

Namespace: BI.Geographic
Syntax
Delphi
public
 Regions,
 States : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TBrazil
  • TEntities
  • BI.Geographic


TEntities.TBrazil.States Field

Summary

Represents field States.

Namespace: BI.Geographic
Syntax
Delphi
public
 Regions,
 States : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TBrazil
  • TEntities
  • BI.Geographic


TEntities.TCanada Record

Summary

Represents type TCanada.

Namespace: BI.Geographic
Syntax
Delphi
public
type
 TCanada=record
 end;

The TEntities.TCanada type exposes the following members.

Fields
Show:
Name | Description
Data | Represents field Data.
Provinces | Represents field Provinces.
Top
See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.TCanada Fields

Fields
Name | Description
Data | Represents field Data.
Provinces | Represents field Provinces.
Top


TEntities.TCanada.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntities.TCanada
  • TEntities
  • BI.Geographic


TEntities.TCanada.Provinces Field

Summary

Represents field Provinces.

Namespace: BI.Geographic
Syntax
Delphi
public
 Provinces : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TCanada
  • TEntities
  • BI.Geographic


TEntities.TChina Record

Summary

Represents type TChina.

Namespace: BI.Geographic
Syntax
Delphi
public
type
 TChina=record
 end;

The TEntities.TChina type exposes the following members.

Fields
Show:
Name | Description
Data | Represents field Data.
Prefectures | Represents field Prefectures.
Provinces | Represents field Provinces.
Top
See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.TChina Fields

Fields
Name | Description
Data | Represents field Data.
Prefectures | Represents field Prefectures.
Provinces | Represents field Provinces.
Top


TEntities.TChina.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntities.TChina
  • TEntities
  • BI.Geographic


TEntities.TChina.Prefectures Field

Summary

Represents field Prefectures.

Namespace: BI.Geographic
Syntax
Delphi
public
 Provinces,
 Prefectures : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TChina
  • TEntities
  • BI.Geographic


TEntities.TChina.Provinces Field

Summary

Represents field Provinces.

Namespace: BI.Geographic
Syntax
Delphi
public
 Provinces,
 Prefectures : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TChina
  • TEntities
  • BI.Geographic


TEntities.TFrance Record

Summary

Represents type TFrance.

Namespace: BI.Geographic
Syntax
Delphi
public
type
 TFrance=record
 end;

The TEntities.TFrance type exposes the following members.

Fields
Show:
Name | Description
Data | Represents field Data.
Departements | Represents field Departements.
Regions | Represents field Regions.
Top
See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.TFrance Fields

Fields
Name | Description
Data | Represents field Data.
Departements | Represents field Departements.
Regions | Represents field Regions.
Top


TEntities.TFrance.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntities.TFrance
  • TEntities
  • BI.Geographic


TEntities.TFrance.Departements Field

Summary

Represents field Departements.

Namespace: BI.Geographic
Syntax
Delphi
public
 Regions,
 Departements: TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TFrance
  • TEntities
  • BI.Geographic


TEntities.TFrance.Regions Field

Summary

Represents field Regions.

Namespace: BI.Geographic
Syntax
Delphi
public
 Regions,
 Departements: TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TFrance
  • TEntities
  • BI.Geographic


TEntities.TGermany Record

Summary

Represents type TGermany.

Namespace: BI.Geographic
Syntax
Delphi
public
type
 TGermany=record
 end;

The TEntities.TGermany type exposes the following members.

Fields
Show:
Name | Description
Data | Represents field Data.
Districts | Represents field Districts.
States | Represents field States.
Top
See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.TGermany Fields

Fields
Name | Description
Data | Represents field Data.
Districts | Represents field Districts.
States | Represents field States.
Top


TEntities.TGermany.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntities.TGermany
  • TEntities
  • BI.Geographic


TEntities.TGermany.Districts Field

Summary

Represents field Districts.

Namespace: BI.Geographic
Syntax
Delphi
public
 States,
 Districts : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TGermany
  • TEntities
  • BI.Geographic


TEntities.TGermany.States Field

Summary

Represents field States.

Namespace: BI.Geographic
Syntax
Delphi
public
 States,
 Districts : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TGermany
  • TEntities
  • BI.Geographic


TEntities.TIndia Record

Summary

Represents type TIndia.

Namespace: BI.Geographic
Syntax
Delphi
public
type
 TIndia=record
 end;

The TEntities.TIndia type exposes the following members.

Fields
Show:
Name | Description
Data | Represents field Data.
States | Represents field States.
Zones | Represents field Zones.
Top
See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.TIndia Fields

Fields
Name | Description
Data | Represents field Data.
States | Represents field States.
Zones | Represents field Zones.
Top


TEntities.TIndia.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntities.TIndia
  • TEntities
  • BI.Geographic


TEntities.TIndia.States Field

Summary

Represents field States.

Namespace: BI.Geographic
Syntax
Delphi
public
 Zones,
 States : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TIndia
  • TEntities
  • BI.Geographic


TEntities.TIndia.Zones Field

Summary

Represents field Zones.

Namespace: BI.Geographic
Syntax
Delphi
public
 Zones,
 States : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TIndia
  • TEntities
  • BI.Geographic


TEntities.TIndonesia Record

Summary

Represents type TIndonesia.

Namespace: BI.Geographic
Syntax
Delphi
public
type
 TIndonesia=record
 end;

The TEntities.TIndonesia type exposes the following members.

Fields
Show:
Name | Description
Data | Represents field Data.
Provinces | Represents field Provinces.
Zones | Represents field Zones.
Top
See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.TIndonesia Fields

Fields
Name | Description
Data | Represents field Data.
Provinces | Represents field Provinces.
Zones | Represents field Zones.
Top


TEntities.TIndonesia.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntities.TIndonesia
  • TEntities
  • BI.Geographic


TEntities.TIndonesia.Provinces Field

Summary

Represents field Provinces.

Namespace: BI.Geographic
Syntax
Delphi
public
 Zones,
 Provinces : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TIndonesia
  • TEntities
  • BI.Geographic


TEntities.TIndonesia.Zones Field

Summary

Represents field Zones.

Namespace: BI.Geographic
Syntax
Delphi
public
 Zones,
 Provinces : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TIndonesia
  • TEntities
  • BI.Geographic


TEntities.TItaly Record

Summary

Represents type TItaly.

Namespace: BI.Geographic
Syntax
Delphi
public
type
 TItaly=record
 end;

The TEntities.TItaly type exposes the following members.

Fields
Show:
Name | Description
Data | Represents field Data.
MacroRegions | Represents field MacroRegions.
Provinces | Represents field Provinces.
Regions | Represents field Regions.
Top
See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.TItaly Fields

Fields
Name | Description
Data | Represents field Data.
MacroRegions | Represents field MacroRegions.
Provinces | Represents field Provinces.
Regions | Represents field Regions.
Top


TEntities.TItaly.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntities.TItaly
  • TEntities
  • BI.Geographic


TEntities.TItaly.MacroRegions Field

Summary

Represents field MacroRegions.

Namespace: BI.Geographic
Syntax
Delphi
public
 MacroRegions,
 Regions,
 Provinces : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TItaly
  • TEntities
  • BI.Geographic


TEntities.TItaly.Provinces Field

Summary

Represents field Provinces.

Namespace: BI.Geographic
Syntax
Delphi
public
 MacroRegions,
 Regions,
 Provinces : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TItaly
  • TEntities
  • BI.Geographic


TEntities.TItaly.Regions Field

Summary

Represents field Regions.

Namespace: BI.Geographic
Syntax
Delphi
public
 MacroRegions,
 Regions,
 Provinces : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TItaly
  • TEntities
  • BI.Geographic


TEntities.TJapan Record

Summary

Represents type TJapan.

Namespace: BI.Geographic
Syntax
Delphi
public
type
 TJapan=record
 end;

The TEntities.TJapan type exposes the following members.

Fields
Show:
Name | Description
Data | Represents field Data.
Prefectures | Represents field Prefectures.
Regions | Represents field Regions.
Top
See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.TJapan Fields

Fields
Name | Description
Data | Represents field Data.
Prefectures | Represents field Prefectures.
Regions | Represents field Regions.
Top


TEntities.TJapan.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntities.TJapan
  • TEntities
  • BI.Geographic


TEntities.TJapan.Prefectures Field

Summary

Represents field Prefectures.

Namespace: BI.Geographic
Syntax
Delphi
public
 Regions,
 Prefectures : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TJapan
  • TEntities
  • BI.Geographic


TEntities.TJapan.Regions Field

Summary

Represents field Regions.

Namespace: BI.Geographic
Syntax
Delphi
public
 Regions,
 Prefectures : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TJapan
  • TEntities
  • BI.Geographic


TEntities.TMexico Record

Summary

Represents type TMexico.

Namespace: BI.Geographic
Syntax
Delphi
public
type
 TMexico=record
 end;

The TEntities.TMexico type exposes the following members.

Fields
Show:
Name | Description
Data | Represents field Data.
States | Represents field States.
Top
See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.TMexico Fields

Fields
Name | Description
Data | Represents field Data.
States | Represents field States.
Top


TEntities.TMexico.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntities.TMexico
  • TEntities
  • BI.Geographic


TEntities.TMexico.States Field

Summary

Represents field States.

Namespace: BI.Geographic
Syntax
Delphi
public
 States : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TMexico
  • TEntities
  • BI.Geographic


TEntities.TNetherlands Record

Summary

Represents type TNetherlands.

Namespace: BI.Geographic
Syntax
Delphi
public
type
 TNetherlands=record
 end;

The TEntities.TNetherlands type exposes the following members.

Fields
Show:
Name | Description
Data | Represents field Data.
Municipalities | Represents field Municipalities.
Provinces | Represents field Provinces.
Top
See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.TNetherlands Fields

Fields
Name | Description
Data | Represents field Data.
Municipalities | Represents field Municipalities.
Provinces | Represents field Provinces.
Top


TEntities.TNetherlands.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntities.TNetherlands
  • TEntities
  • BI.Geographic


TEntities.TNetherlands.Municipalities Field

Summary

Represents field Municipalities.

Namespace: BI.Geographic
Syntax
Delphi
public
 Provinces,
 Municipalities : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TNetherlands
  • TEntities
  • BI.Geographic


TEntities.TNetherlands.Provinces Field

Summary

Represents field Provinces.

Namespace: BI.Geographic
Syntax
Delphi
public
 Provinces,
 Municipalities : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TNetherlands
  • TEntities
  • BI.Geographic


TEntities.TPortugal Record

Summary

Represents type TPortugal.

Namespace: BI.Geographic
Syntax
Delphi
public
type
 TPortugal=record
 end;

The TEntities.TPortugal type exposes the following members.

Fields
Show:
Name | Description
Data | Represents field Data.
Districts | Represents field Districts.
Regions | Represents field Regions.
Top
See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.TPortugal Fields

Fields
Name | Description
Data | Represents field Data.
Districts | Represents field Districts.
Regions | Represents field Regions.
Top


TEntities.TPortugal.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntities.TPortugal
  • TEntities
  • BI.Geographic


TEntities.TPortugal.Districts Field

Summary

Represents field Districts.

Namespace: BI.Geographic
Syntax
Delphi
public
 Regions,
 Districts : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TPortugal
  • TEntities
  • BI.Geographic


TEntities.TPortugal.Regions Field

Summary

Represents field Regions.

Namespace: BI.Geographic
Syntax
Delphi
public
 Regions,
 Districts : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TPortugal
  • TEntities
  • BI.Geographic


TEntities.TRussia Record

Summary

Represents type TRussia.

Namespace: BI.Geographic
Syntax
Delphi
public
type
 TRussia=record
 end;

The TEntities.TRussia type exposes the following members.

Fields
Show:
Name | Description
Data | Represents field Data.
Districts | Represents field Districts.
Subjects | Represents field Subjects.
Top
See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.TRussia Fields

Fields
Name | Description
Data | Represents field Data.
Districts | Represents field Districts.
Subjects | Represents field Subjects.
Top


TEntities.TRussia.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntities.TRussia
  • TEntities
  • BI.Geographic


TEntities.TRussia.Districts Field

Summary

Represents field Districts.

Namespace: BI.Geographic
Syntax
Delphi
public
 Districts,
 Subjects: TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TRussia
  • TEntities
  • BI.Geographic


TEntities.TRussia.Subjects Field

Summary

Represents field Subjects.

Namespace: BI.Geographic
Syntax
Delphi
public
 Districts,
 Subjects: TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TRussia
  • TEntities
  • BI.Geographic


TEntities.TSouthAfrica Record

Summary

Represents type TSouthAfrica.

Namespace: BI.Geographic
Syntax
Delphi
public
type
 TSouthAfrica=record
 end;

The TEntities.TSouthAfrica type exposes the following members.

Fields
Show:
Name | Description
Data | Represents field Data.
Provinces | Represents field Provinces.
Top
See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.TSouthAfrica Fields

Fields
Name | Description
Data | Represents field Data.
Provinces | Represents field Provinces.
Top


TEntities.TSouthAfrica.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntities.TSouthAfrica
  • TEntities
  • BI.Geographic


TEntities.TSouthAfrica.Provinces Field

Summary

Represents field Provinces.

Namespace: BI.Geographic
Syntax
Delphi
public
 Provinces: TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TSouthAfrica
  • TEntities
  • BI.Geographic


TEntities.TSouthKorea Record

Summary

Represents type TSouthKorea.

Namespace: BI.Geographic
Syntax
Delphi
public
type
 TSouthKorea=record
 end;

The TEntities.TSouthKorea type exposes the following members.

Fields
Show:
Name | Description
Data | Represents field Data.
Provinces | Represents field Provinces.
Types | Represents field Types.
Top
See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.TSouthKorea Fields

Fields
Name | Description
Data | Represents field Data.
Provinces | Represents field Provinces.
Types | Represents field Types.
Top


TEntities.TSouthKorea.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntities.TSouthKorea
  • TEntities
  • BI.Geographic


TEntities.TSouthKorea.Provinces Field

Summary

Represents field Provinces.

Namespace: BI.Geographic
Syntax
Delphi
public
 Types,
 Provinces: TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TSouthKorea
  • TEntities
  • BI.Geographic


TEntities.TSouthKorea.Types Field

Summary

Represents field Types.

Namespace: BI.Geographic
Syntax
Delphi
public
 Types,
 Provinces: TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TSouthKorea
  • TEntities
  • BI.Geographic


TEntities.TSpain Record

Summary

Represents type TSpain.

Namespace: BI.Geographic
Syntax
Delphi
public
type
 TSpain=record
 end;

The TEntities.TSpain type exposes the following members.

Fields
Show:
Name | Description
Data | Represents field Data.
Provinces | Represents field Provinces.
Regions | Represents field Regions.
Top
See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.TSpain Fields

Fields
Name | Description
Data | Represents field Data.
Provinces | Represents field Provinces.
Regions | Represents field Regions.
Top


TEntities.TSpain.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntities.TSpain
  • TEntities
  • BI.Geographic


TEntities.TSpain.Provinces Field

Summary

Represents field Provinces.

Namespace: BI.Geographic
Syntax
Delphi
public
 Regions,
 Provinces : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TSpain
  • TEntities
  • BI.Geographic


TEntities.TSpain.Regions Field

Summary

Represents field Regions.

Namespace: BI.Geographic
Syntax
Delphi
public
 Regions,
 Provinces : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TSpain
  • TEntities
  • BI.Geographic


TEntities.TSwitzerland Record

Summary

Represents type TSwitzerland.

Namespace: BI.Geographic
Syntax
Delphi
public
type
 TSwitzerland=record
 end;

The TEntities.TSwitzerland type exposes the following members.

Fields
Show:
Name | Description
Cantons | Represents field Cantons.
Data | Represents field Data.
Top
See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.TSwitzerland Fields

Fields
Name | Description
Cantons | Represents field Cantons.
Data | Represents field Data.
Top


TEntities.TSwitzerland.Cantons Field

Summary

Represents field Cantons.

Namespace: BI.Geographic
Syntax
Delphi
public
 Cantons : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TSwitzerland
  • TEntities
  • BI.Geographic


TEntities.TSwitzerland.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntities.TSwitzerland
  • TEntities
  • BI.Geographic


TEntities.TUK Record

Summary

Represents type TUK.

Namespace: BI.Geographic
Syntax
Delphi
public
type
 TUK=record
 end;

The TEntities.TUK type exposes the following members.

Fields
Show:
Name | Description
Counties | Represents field Counties.
Data | Represents field Data.
NUTS | Represents field NUTS.
Top
See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.TUK Fields

Fields
Name | Description
Counties | Represents field Counties.
Data | Represents field Data.
NUTS | Represents field NUTS.
Top


TEntities.TUK.Counties Field

Summary

Represents field Counties.

Namespace: BI.Geographic
Syntax
Delphi
public
 NUTS,
 Counties: TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TUK
  • TEntities
  • BI.Geographic


TEntities.TUK.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntities.TUK
  • TEntities
  • BI.Geographic


TEntities.TUK.NUTS Field

Summary

Represents field NUTS.

Namespace: BI.Geographic
Syntax
Delphi
public
 NUTS,
 Counties: TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TUK
  • TEntities
  • BI.Geographic


TEntities.TUSA Record

Summary

Represents type TUSA.

Namespace: BI.Geographic
Syntax
Delphi
public
type
 TUSA=record
 end;

The TEntities.TUSA type exposes the following members.

Fields
Show:
Name | Description
Counties | Represents field Counties.
Data | Represents field Data.
States | Represents field States.
Top
See Also

Reference

  • TEntities
  • BI.Geographic


TEntities.TUSA Fields

Fields
Name | Description
Counties | Represents field Counties.
Data | Represents field Data.
States | Represents field States.
Top


TEntities.TUSA.Counties Field

Summary

Represents field Counties.

Namespace: BI.Geographic
Syntax
Delphi
public
 States,
 Counties : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TUSA
  • TEntities
  • BI.Geographic


TEntities.TUSA.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntities.TUSA
  • TEntities
  • BI.Geographic


TEntities.TUSA.States Field

Summary

Represents field States.

Namespace: BI.Geographic
Syntax
Delphi
public
 States,
 Counties : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntities.TUSA
  • TEntities
  • BI.Geographic


TEntity Record

Summary

Represents type TEntity.

Namespace: BI.Geographic
Syntax
Delphi
type
 TEntity=record
 end;

The TEntity type exposes the following members.

Methods
Show:
Name | Description
CodeOfName(String) | Represents method CodeOfName(String).
CodeToString(Int64) | Overloaded. Represents method CodeToString(Int64).
CodeToString(Integer) | Overloaded. Represents method CodeToString(Integer).
CodeToString(String) | Overloaded. Represents method CodeToString(String).
CodeToString(TDataItem,TInteger) | Overloaded. Represents method CodeToString(TDataItem,TInteger).
NameOfCode(Integer) | Represents method NameOfCode(Integer).
SortFindLookup(Integer,TDataItem,TDataItem) | Represents method SortFindLookup(Integer,TDataItem,TDataItem).
Top
Fields
Show:
Name | Description
Data | Represents field Data.
ID | Represents field ID.
Name | Represents field Name.
Pad | Represents field Pad.
Top
See Also

Reference

  • BI.Geographic


TEntity Methods

Methods
Name | Description
CodeOfName(String) | Represents method CodeOfName(String).
CodeToString(Int64) | Overloaded. Represents method CodeToString(Int64).
CodeToString(Integer) | Overloaded. Represents method CodeToString(Integer).
CodeToString(String) | Overloaded. Represents method CodeToString(String).
CodeToString(TDataItem,TInteger) | Overloaded. Represents method CodeToString(TDataItem,TInteger).
NameOfCode(Integer) | Represents method NameOfCode(Integer).
SortFindLookup(Integer,TDataItem,TDataItem) | Represents method SortFindLookup(Integer,TDataItem,TDataItem).
Top


TEntity.CodeOfName(String) Method

Summary

Represents method CodeOfName(String).

Namespace: BI.Geographic
Syntax
Delphi
public
 function CodeOfName(const AName:String):String;

Parameters

AName
Type: String

Return Value

Type: String

See Also

Reference

  • TEntity
  • BI.Geographic


TEntity.CodeToString(Int64) Method

Summary

Represents method CodeToString(Int64).

Namespace: BI.Geographic
Syntax
Delphi
public
 function CodeToString(const ACode:Int64): String; overload;

Parameters

ACode
Type: Int64

Return Value

Type: String

See Also

Reference

  • TEntity
  • BI.Geographic


TEntity.CodeToString(Integer) Method

Summary

Represents method CodeToString(Integer).

Namespace: BI.Geographic
Syntax
Delphi
public
 function CodeToString(const ACode:Integer): String; overload;

Parameters

ACode
Type: Integer

Return Value

Type: String

See Also

Reference

  • TEntity
  • BI.Geographic


TEntity.CodeToString(String) Method

Summary

Represents method CodeToString(String).

Namespace: BI.Geographic
Syntax
Delphi
public
 function CodeToString(const ACode:String): String; overload;

Parameters

ACode
Type: String

Return Value

Type: String

See Also

Reference

  • TEntity
  • BI.Geographic


TEntity.CodeToString(TDataItem,TInteger) Method

Summary

Represents method CodeToString(TDataItem,TInteger).

Namespace: BI.Geographic
Syntax
Delphi
public
 function CodeToString(const AData:TDataItem; const AIndex:TInteger):String; overload;

Parameters

AData
Type: TDataItem

AIndex
Type: System.Void

Return Value

Type: String

See Also

Reference

  • TEntity
  • BI.Geographic


TEntity.NameOfCode(Integer) Method

Summary

Represents method NameOfCode(Integer).

Namespace: BI.Geographic
Syntax
Delphi
public
 function NameOfCode(const ACode:Integer):String;

Parameters

ACode
Type: Integer

Return Value

Type: String

See Also

Reference

  • TEntity
  • BI.Geographic


TEntity.SortFindLookup(Integer,TDataItem,TDataItem) Method

Summary

Represents method SortFindLookup(Integer,TDataItem,TDataItem).

Namespace: BI.Geographic
Syntax
Delphi
public
 function SortFindLookup(const ACode:Integer;
 const ACodeItem,ANameItem:TDataItem):String;

Parameters

ACode
Type: Integer

ACodeItem
Type: TDataItem

ANameItem
Type: TDataItem

Return Value

Type: String

See Also

Reference

  • TEntity
  • BI.Geographic


TEntity Fields

Fields
Name | Description
Data | Represents field Data.
ID | Represents field ID.
Name | Represents field Name.
Pad | Represents field Pad.
Top


TEntity.Data Field

Summary

Represents field Data.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data,
 ID,
 Name : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntity
  • BI.Geographic


TEntity.ID Field

Summary

Represents field ID.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data,
 ID,
 Name : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntity
  • BI.Geographic


TEntity.Name Field

Summary

Represents field Name.

Namespace: BI.Geographic
Syntax
Delphi
public
 Data,
 ID,
 Name : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEntity
  • BI.Geographic


TEntity.Pad Field

Summary

Represents field Pad.

Namespace: BI.Geographic
Syntax
Delphi
public
 Pad: Integer;

Field Value

Type: Integer

See Also

Reference

  • TEntity
  • BI.Geographic


TGeo Record

Summary

Represents type TGeo.

Namespace: BI.Geographic
Syntax
Delphi
type
 TGeo=record
 end;

The TGeo type exposes the following members.

Methods
Show:
Name | Description
AllFoundIn(TDataItem,TEntity,Boolean) | Represents method AllFoundIn(TDataItem,TEntity,Boolean).
Check | Represents method Check.
EntityOf(TDataItem,Int64) | Overloaded. Represents method EntityOf(TDataItem,Int64).
EntityOf(TDataItem,String) | Overloaded. Represents method EntityOf(TDataItem,String).
FindSynonym(String) | Represents method FindSynonym(String).
IsChild(TDataItem) | Represents method IsChild(TDataItem).
IsMultiEntity(TDataItem,TMasterDetail) | Represents method IsMultiEntity(TDataItem,TMasterDetail).
LinkedTo(TDataItem) | Represents method LinkedTo(TDataItem).
TextMapOf(TDataItem) | Represents method TextMapOf(TDataItem).
Top
Fields
Show:
Name | Description
Continents | Represents field Continents.
Country | Represents field Country.
Entities | Represents field Entities.
Top
See Also

Reference

  • BI.Geographic


TGeo Methods

Methods
Name | Description
AllFoundIn(TDataItem,TEntity,Boolean) | Represents method AllFoundIn(TDataItem,TEntity,Boolean).
Check | Represents method Check.
EntityOf(TDataItem,Int64) | Overloaded. Represents method EntityOf(TDataItem,Int64).
EntityOf(TDataItem,String) | Overloaded. Represents method EntityOf(TDataItem,String).
FindSynonym(String) | Represents method FindSynonym(String).
IsChild(TDataItem) | Represents method IsChild(TDataItem).
IsMultiEntity(TDataItem,TMasterDetail) | Represents method IsMultiEntity(TDataItem,TMasterDetail).
LinkedTo(TDataItem) | Represents method LinkedTo(TDataItem).
TextMapOf(TDataItem) | Represents method TextMapOf(TDataItem).
Top


TGeo.AllFoundIn(TDataItem,TEntity,Boolean) Method

Summary

Represents method AllFoundIn(TDataItem,TEntity,Boolean).

Namespace: BI.Geographic
Syntax
Delphi
public
 class function AllFoundIn(const AText:TDataItem; const AEntity:TEntity; const UseSynonyms:Boolean):Boolean; static;

Parameters

AText
Type: TDataItem

AEntity
Type: TEntity

UseSynonyms
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • TGeo
  • BI.Geographic


TGeo.Check Method

Summary

Represents method Check.

Namespace: BI.Geographic
Syntax
Delphi
public
 class procedure Check; static;
See Also

Reference

  • TGeo
  • BI.Geographic


TGeo.EntityOf(TDataItem,Int64) Method

Summary

Represents method EntityOf(TDataItem,Int64).

Namespace: BI.Geographic
Syntax
Delphi
public
 class function EntityOf(const AData:TDataItem; const ACode:Int64):String; overload; static;

Parameters

AData
Type: TDataItem

ACode
Type: Int64

Return Value

Type: String

See Also

Reference

  • TGeo
  • BI.Geographic


TGeo.EntityOf(TDataItem,String) Method

Summary

Represents method EntityOf(TDataItem,String).

Namespace: BI.Geographic
Syntax
Delphi
public
 class function EntityOf(const AData:TDataItem; const ACode:String):String; overload; static;

Parameters

AData
Type: TDataItem

ACode
Type: String

Return Value

Type: String

See Also

Reference

  • TGeo
  • BI.Geographic


TGeo.FindSynonym(String) Method

Summary

Represents method FindSynonym(String).

Namespace: BI.Geographic
Syntax
Delphi
public
 class function FindSynonym(const S:String):String; static;

Parameters

S
Type: String

Return Value

Type: String

See Also

Reference

  • TGeo
  • BI.Geographic


TGeo.IsChild(TDataItem) Method

Summary

Represents method IsChild(TDataItem).

Namespace: BI.Geographic
Syntax
Delphi
public
 class function IsChild(const AData:TDataItem):Boolean; static;

Parameters

AData
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • TGeo
  • BI.Geographic


TGeo.IsMultiEntity(TDataItem,TMasterDetail) Method

Summary

Represents method IsMultiEntity(TDataItem,TMasterDetail).

Namespace: BI.Geographic
Syntax
Delphi
public
 class function IsMultiEntity(const AData:TDataItem; out AMulti:TMasterDetail):Boolean; static;

Parameters

AData
Type: TDataItem

AMulti
Type: TMasterDetail

Return Value

Type: Boolean

See Also

Reference

  • TGeo
  • BI.Geographic


TGeo.LinkedTo(TDataItem) Method

Summary

Represents method LinkedTo(TDataItem).

Namespace: BI.Geographic
Syntax
Delphi
public
 class function LinkedTo(const AData:TDataItem):TDataItem; static;

Parameters

AData
Type: TDataItem

Return Value

Type: TDataItem

See Also

Reference

  • TGeo
  • BI.Geographic


TGeo.TextMapOf(TDataItem) Method

Summary

Represents method TextMapOf(TDataItem).

Namespace: BI.Geographic
Syntax
Delphi
public
 class function TextMapOf(const AData:TDataItem):TTextMap; static;

Parameters

AData
Type: TDataItem

Return Value

Type: TTextMap

See Also

Reference

  • TGeo
  • BI.Geographic


TGeo Fields

Fields
Name | Description
Continents | Represents field Continents.
Country | Represents field Country.
Entities | Represents field Entities.
Top


TGeo.Continents Field

Summary

Represents field Continents.

Namespace: BI.Geographic
Syntax
Delphi
public
 class var
 Continents : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TGeo
  • BI.Geographic


TGeo.Country Field

Summary

Represents field Country.

Namespace: BI.Geographic
Syntax
Delphi
public
 class var
 Country : TCountry;

Field Value

Type: TCountry

See Also

Reference

  • TGeo
  • BI.Geographic


TGeo.Entities Field

Summary

Represents field Entities.

Namespace: BI.Geographic
Syntax
Delphi
public
 class var
 Entities : TEntities;

Field Value

Type: TEntities

See Also

Reference

  • TGeo
  • BI.Geographic


TMasterDetail Record

Summary

Represents type TMasterDetail.

Namespace: BI.Geographic
Syntax
Delphi
type
 TMasterDetail=record
 end;

The TMasterDetail type exposes the following members.

Methods
Show:
Name | Description
Find(TDataItem,Boolean) | Overloaded. Represents method Find(TDataItem,Boolean).
FindDetail(TDataItem,TEntity) | Represents method FindDetail(TDataItem,TEntity).
FindMaster(TDataItem,TMasterDetail) | Represents method FindMaster(TDataItem,TMasterDetail).
Load | Overloaded. Represents method Load.
Top
Fields
Show:
Name | Description
Detail | Represents field Detail.
DetailToMaster | Represents field DetailToMaster.
Master | Represents field Master.
Top
See Also

Reference

  • BI.Geographic


TMasterDetail Methods

Methods
Name | Description
Find(TDataItem,Boolean) | Overloaded. Represents method Find(TDataItem,Boolean).
FindDetail(TDataItem,TEntity) | Represents method FindDetail(TDataItem,TEntity).
FindMaster(TDataItem,TMasterDetail) | Represents method FindMaster(TDataItem,TMasterDetail).
Load | Overloaded. Represents method Load.
Top


TMasterDetail.Find(TDataItem,Boolean) Method

Summary

Represents method Find(TDataItem,Boolean).

Namespace: BI.Geographic
Syntax
Delphi
public
 function Find(const AData:TDataItem; out ByCode:Boolean):Boolean; overload;

Parameters

AData
Type: TDataItem

ByCode
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • TMasterDetail
  • BI.Geographic


TMasterDetail.FindDetail(TDataItem,TEntity) Method

Summary

Represents method FindDetail(TDataItem,TEntity).

Namespace: BI.Geographic
Syntax
Delphi
public
 class function FindDetail(const AData:TDataItem; out AEntity:TEntity):Boolean; static;

Parameters

AData
Type: TDataItem

AEntity
Type: TEntity

Return Value

Type: Boolean

See Also

Reference

  • TMasterDetail
  • BI.Geographic


TMasterDetail.FindMaster(TDataItem,TMasterDetail) Method

Summary

Represents method FindMaster(TDataItem,TMasterDetail).

Namespace: BI.Geographic
Syntax
Delphi
public
 class function FindMaster(const AData:TDataItem; out AMulti:TMasterDetail):Boolean; static;

Parameters

AData
Type: TDataItem

AMulti
Type: TMasterDetail

Return Value

Type: Boolean

See Also

Reference

  • TMasterDetail
  • BI.Geographic


TMasterDetail.Load Method

Summary

Represents method Load.

Namespace: BI.Geographic
Syntax
Delphi
public
 procedure Load; overload;
See Also

Reference

  • TMasterDetail
  • BI.Geographic


TMasterDetail Fields

Fields
Name | Description
Detail | Represents field Detail.
DetailToMaster | Represents field DetailToMaster.
Master | Represents field Master.
Top


TMasterDetail.Detail Field

Summary

Represents field Detail.

Namespace: BI.Geographic
Syntax
Delphi
public
 Master,
 Detail : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TMasterDetail
  • BI.Geographic


TMasterDetail.DetailToMaster Field

Summary

Represents field DetailToMaster.

Namespace: BI.Geographic
Syntax
Delphi
public
 DetailToMaster : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TMasterDetail
  • BI.Geographic


TMasterDetail.Master Field

Summary

Represents field Master.

Namespace: BI.Geographic
Syntax
Delphi
public
 Master,
 Detail : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TMasterDetail
  • BI.Geographic


BI.Geographic Variables

Variables
Name | Description
ILinks | Represents variable ILinks.
SynonymNames | Represents variable SynonymNames.
Synonyms | Represents variable Synonyms.
Top


ILinks Variable

Summary

Represents variable ILinks.

Namespace: BI.Geographic
Syntax
Delphi
ILinks : Array of TMasterDetail;

Value

Type: Array of TMasterDetail

See Also

Reference

  • BI.Geographic


SynonymNames Variable

Summary

Represents variable SynonymNames.

Namespace: BI.Geographic
Syntax
Delphi
Synonyms,
 SynonymNames : TTextArray;

Value

Type: TTextArray

See Also

Reference

  • BI.Geographic


Synonyms Variable

Summary

Represents variable Synonyms.

Namespace: BI.Geographic
Syntax
Delphi
Synonyms,
 SynonymNames : TTextArray;

Value

Type: TTextArray

See Also

Reference

  • BI.Geographic


BI.Geographic Routines

Routines
Name | Description
FindLinkDetail(TDataItem,TMasterDetail) | Represents method FindLinkDetail(TDataItem,TMasterDetail).
PadZeroLeft(Integer,Integer) | Represents method PadZeroLeft(Integer,Integer).
Top


FindLinkDetail(TDataItem,TMasterDetail) Method

Summary

Represents method FindLinkDetail(TDataItem,TMasterDetail).

Namespace: BI.Geographic
Syntax
Delphi
function FindLinkDetail(const AData:TDataItem; out AEntity:TMasterDetail):Boolean;

Parameters

AData
Type: TDataItem

AEntity
Type: TMasterDetail

Return Value

Type: Boolean

See Also

Reference

  • BI.Geographic


PadZeroLeft(Integer,Integer) Method

Summary

Represents method PadZeroLeft(Integer,Integer).

Namespace: BI.Geographic
Syntax
Delphi
function PadZeroLeft(const AValue,ALength:Integer):String;

Parameters

AValue
Type: Integer

ALength
Type: Integer

Return Value

Type: String

See Also

Reference

  • BI.Geographic


BI.Grid.Plugin Namespace

Summary

Represents namespace BI.Grid.Plugin.

Classes
Name | Description
TBIGridPlugin | Represents type TBIGridPlugin.
Top
Types
Name | Description
TBIGridPluginClass | Represents type TBIGridPluginClass.
Top


BI.Grid.Plugin Classes

Classes
Name | Description
TBIGridPlugin | Represents type TBIGridPlugin.
Top


TBIGridPlugin Class

Summary

Represents type TBIGridPlugin.

Namespace: BI.Grid.Plugin
Inheritance Hierarchy
TObject
BI.Grid.Plugin.TBIGridPlugin
FMXBI.Grid.Grid.TBIFMXGridPlugin
FMXBI.Grid.TeeGrid.TBITeeGridPlugin
FMXBI.Grid.TPluginAccess
VCLBI.Grid.DBGrid.TBIDBGridPlugin
VCLBI.Grid.TeeGrid.TBITeeGridPlugin
VCLBI.Grid.TPluginAccess
Syntax
Delphi
type
 TBIGridPlugin=class abstract
 end;

The TBIGridPlugin type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIGridPlugin class.
Top
Properties
Show:
Name | Description
CanSort | Represents property CanSort.
DataSource | Represents property DataSource.
EditorClass | Represents property EditorClass.
ReadOnly | Represents property ReadOnly.
SortEnabled | Represents property SortEnabled.
Totals | Represents property Totals.
Top
Methods
Show:
Name | Description
AutoWidth | Represents method AutoWidth.
BindTo(TDataSet) | Represents method BindTo(TDataSet).
ChangedAlternate(TObject) | Represents method ChangedAlternate(TObject).
Colorize(TDataColorizers) | Represents method Colorize(TDataColorizers).
Duplicates(TDataItem,Boolean) | Represents method Duplicates(TDataItem,Boolean).
GetControl | Represents method GetControl.
GetObject | Represents method GetObject.
SetFilters(Boolean) | Represents method SetFilters(Boolean).
SetOnRowChanged(TNotifyEvent) | Represents method SetOnRowChanged(TNotifyEvent).
SetPopup(TObject) | Represents method SetPopup(TObject).
SetRowNumber(Boolean) | Represents method SetRowNumber(Boolean).
SetSearch(Boolean) | Represents method SetSearch(Boolean).
Top
Fields
Show:
Name | Description
IAlternate | Represents field IAlternate.
Top
See Also

Reference

  • BI.Grid.Plugin


TBIGridPlugin Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBIGridPlugin class.
Top


TBIGridPlugin.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIGridPlugin class.

Namespace: BI.Grid.Plugin
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); virtual; abstract;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBIGridPlugin
  • BI.Grid.Plugin


TBIGridPlugin Properties

Properties
Name | Description
CanSort | Represents property CanSort.
DataSource | Represents property DataSource.
EditorClass | Represents property EditorClass.
ReadOnly | Represents property ReadOnly.
SortEnabled | Represents property SortEnabled.
Totals | Represents property Totals.
Top


TBIGridPlugin.CanSort Property

Summary

Represents property CanSort.

Namespace: BI.Grid.Plugin
Syntax
Delphi
public
 property CanSort:Boolean read GetCanSort;

Property Value

Type: Boolean

See Also

Reference

  • TBIGridPlugin
  • BI.Grid.Plugin


TBIGridPlugin.DataSource Property

Summary

Represents property DataSource.

Namespace: BI.Grid.Plugin
Syntax
Delphi
public
 property DataSource:TDataSource read GetDataSource write SetDataSource;

Property Value

Type: TDataSource

See Also

Reference

  • TBIGridPlugin
  • BI.Grid.Plugin


TBIGridPlugin.EditorClass Property

Summary

Represents property EditorClass.

Namespace: BI.Grid.Plugin
Syntax
Delphi
public
 property EditorClass:String read GetEditorClass;

Property Value

Type: String

See Also

Reference

  • TBIGridPlugin
  • BI.Grid.Plugin


TBIGridPlugin.ReadOnly Property

Summary

Represents property ReadOnly.

Namespace: BI.Grid.Plugin
Syntax
Delphi
public
 property ReadOnly:Boolean read GetReadOnly write SetReadOnly;

Property Value

Type: Boolean

See Also

Reference

  • TBIGridPlugin
  • BI.Grid.Plugin


TBIGridPlugin.SortEnabled Property

Summary

Represents property SortEnabled.

Namespace: BI.Grid.Plugin
Syntax
Delphi
public
 property SortEnabled:Boolean read GetSortEnabled write SetSortEnabled;

Property Value

Type: Boolean

See Also

Reference

  • TBIGridPlugin
  • BI.Grid.Plugin


TBIGridPlugin.Totals Property

Summary

Represents property Totals.

Namespace: BI.Grid.Plugin
Syntax
Delphi
public
 property Totals:Boolean read GetTotals write SetTotals;

Property Value

Type: Boolean

See Also

Reference

  • TBIGridPlugin
  • BI.Grid.Plugin


TBIGridPlugin Methods

Methods
Name | Description
AutoWidth | Represents method AutoWidth.
BindTo(TDataSet) | Represents method BindTo(TDataSet).
ChangedAlternate(TObject) | Represents method ChangedAlternate(TObject).
Colorize(TDataColorizers) | Represents method Colorize(TDataColorizers).
Duplicates(TDataItem,Boolean) | Represents method Duplicates(TDataItem,Boolean).
GetControl | Represents method GetControl.
GetObject | Represents method GetObject.
SetFilters(Boolean) | Represents method SetFilters(Boolean).
SetOnRowChanged(TNotifyEvent) | Represents method SetOnRowChanged(TNotifyEvent).
SetPopup(TObject) | Represents method SetPopup(TObject).
SetRowNumber(Boolean) | Represents method SetRowNumber(Boolean).
SetSearch(Boolean) | Represents method SetSearch(Boolean).
Top


TBIGridPlugin.AutoWidth Method

Summary

Represents method AutoWidth.

Namespace: BI.Grid.Plugin
Syntax
Delphi
protected
 procedure AutoWidth; virtual; abstract;
See Also

Reference

  • TBIGridPlugin
  • BI.Grid.Plugin


TBIGridPlugin.BindTo(TDataSet) Method

Summary

Represents method BindTo(TDataSet).

Namespace: BI.Grid.Plugin
Syntax
Delphi
public
 procedure BindTo(const ADataSet:TDataSet); virtual; abstract;

Parameters

ADataSet
Type: TDataSet

See Also

Reference

  • TBIGridPlugin
  • BI.Grid.Plugin


TBIGridPlugin.ChangedAlternate(TObject) Method

Summary

Represents method ChangedAlternate(TObject).

Namespace: BI.Grid.Plugin
Syntax
Delphi
protected
 procedure ChangedAlternate(Sender:TObject); virtual; abstract;

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIGridPlugin
  • BI.Grid.Plugin


TBIGridPlugin.Colorize(TDataColorizers) Method

Summary

Represents method Colorize(TDataColorizers).

Namespace: BI.Grid.Plugin
Syntax
Delphi
public
 procedure Colorize(const AItems:TDataColorizers); virtual; abstract;

Parameters

AItems
Type: TDataColorizers

See Also

Reference

  • TBIGridPlugin
  • BI.Grid.Plugin


TBIGridPlugin.Duplicates(TDataItem,Boolean) Method

Summary

Represents method Duplicates(TDataItem,Boolean).

Namespace: BI.Grid.Plugin
Syntax
Delphi
public
 procedure Duplicates(const AData:TDataItem; const Hide:Boolean); virtual; abstract;

Parameters

AData
Type: TDataItem

Hide
Type: Boolean

See Also

Reference

  • TBIGridPlugin
  • BI.Grid.Plugin


TBIGridPlugin.GetControl Method

Summary

Represents method GetControl.

Namespace: BI.Grid.Plugin
Syntax
Delphi
public
 function GetControl:TObject; virtual; abstract;

Return Value

Type: TObject

See Also

Reference

  • TBIGridPlugin
  • BI.Grid.Plugin


TBIGridPlugin.GetObject Method

Summary

Represents method GetObject.

Namespace: BI.Grid.Plugin
Syntax
Delphi
public
 function GetObject:TObject; virtual; abstract;

Return Value

Type: TObject

See Also

Reference

  • TBIGridPlugin
  • BI.Grid.Plugin


TBIGridPlugin.SetFilters(Boolean) Method

Summary

Represents method SetFilters(Boolean).

Namespace: BI.Grid.Plugin
Syntax
Delphi
protected
 procedure SetFilters(const Value:Boolean); virtual; abstract;

Parameters

Value
Type: Boolean

See Also

Reference

  • TBIGridPlugin
  • BI.Grid.Plugin


TBIGridPlugin.SetOnRowChanged(TNotifyEvent) Method

Summary

Represents method SetOnRowChanged(TNotifyEvent).

Namespace: BI.Grid.Plugin
Syntax
Delphi
protected
 procedure SetOnRowChanged(const AEvent:TNotifyEvent); virtual; abstract;

Parameters

AEvent
Type: TNotifyEvent

See Also

Reference

  • TBIGridPlugin
  • BI.Grid.Plugin


TBIGridPlugin.SetPopup(TObject) Method

Summary

Represents method SetPopup(TObject).

Namespace: BI.Grid.Plugin
Syntax
Delphi
protected
 procedure SetPopup(const Value:TObject); virtual; abstract;

Parameters

Value
Type: TObject

See Also

Reference

  • TBIGridPlugin
  • BI.Grid.Plugin


TBIGridPlugin.SetRowNumber(Boolean) Method

Summary

Represents method SetRowNumber(Boolean).

Namespace: BI.Grid.Plugin
Syntax
Delphi
protected
 procedure SetRowNumber(const Value:Boolean); virtual; abstract;

Parameters

Value
Type: Boolean

See Also

Reference

  • TBIGridPlugin
  • BI.Grid.Plugin


TBIGridPlugin.SetSearch(Boolean) Method

Summary

Represents method SetSearch(Boolean).

Namespace: BI.Grid.Plugin
Syntax
Delphi
protected
 procedure SetSearch(const Value:Boolean); virtual; abstract;

Parameters

Value
Type: Boolean

See Also

Reference

  • TBIGridPlugin
  • BI.Grid.Plugin


TBIGridPlugin Fields

Fields
Name | Description
IAlternate | Represents field IAlternate.
Top


TBIGridPlugin.IAlternate Field

Summary

Represents field IAlternate.

Namespace: BI.Grid.Plugin
Syntax
Delphi
protected
 IAlternate : TAlternateColor;

Field Value

Type: TAlternateColor

See Also

Reference

  • TBIGridPlugin
  • BI.Grid.Plugin


BI.Grid.Plugin Types

Types
Name | Description
TBIGridPluginClass | Represents type TBIGridPluginClass.
Top


TBIGridPluginClass Type

Summary

Represents type TBIGridPluginClass.

Namespace: BI.Grid.Plugin
Syntax
Delphi
type
 TBIGridPluginClass=class of TBIGridPlugin;
See Also

Reference

  • BI.Grid.Plugin


BI.Gridify Namespace

Summary

Represents namespace BI.Gridify.

Records
Name | Description
TGridify | Represents type TGridify.
Top


BI.Gridify Records

Records
Name | Description
TGridify | Represents type TGridify.
Top


TGridify Record

Summary

Represents type TGridify.

Namespace: BI.Gridify
Syntax
Delphi
type
 TGridify=record
 end;

The TGridify type exposes the following members.

Methods
Show:
Name | Description
Calculate(TDataItem,TDataItem,TDataArray,TDataArray) | Represents method Calculate(TDataItem,TDataItem,TDataArray,TDataArray).
From(TDataItem,String,String,String) | Overloaded. Represents method From(TDataItem,String,String,String).
From(TDataItem,TDataArray,TDataArray) | Overloaded. Represents method From(TDataItem,TDataArray,TDataArray).
FromItems(TDataItem,String,TStringArray,TStringArray) | Represents method FromItems(TDataItem,String,TStringArray,TStringArray).
Top
See Also

Reference

  • BI.Gridify


TGridify Methods

Methods
Name | Description
Calculate(TDataItem,TDataItem,TDataArray,TDataArray) | Represents method Calculate(TDataItem,TDataItem,TDataArray,TDataArray).
From(TDataItem,String,String,String) | Overloaded. Represents method From(TDataItem,String,String,String).
From(TDataItem,TDataArray,TDataArray) | Overloaded. Represents method From(TDataItem,TDataArray,TDataArray).
FromItems(TDataItem,String,TStringArray,TStringArray) | Represents method FromItems(TDataItem,String,TStringArray,TStringArray).
Top


TGridify.Calculate(TDataItem,TDataItem,TDataArray,TDataArray) Method

Summary

Represents method Calculate(TDataItem,TDataItem,TDataArray,TDataArray).

Namespace: BI.Gridify
Syntax
Delphi
public
 class procedure Calculate(const ADest:TDataItem;
 const AValue:TDataItem;
 const ARows,ACols:TDataArray); static;

Parameters

ADest
Type: TDataItem

AValue
Type: TDataItem

ARows
Type: TDataArray

ACols
Type: TDataArray

See Also

Reference

  • TGridify
  • BI.Gridify


TGridify.From(TDataItem,String,String,String) Method

Summary

Represents method From(TDataItem,String,String,String).

Namespace: BI.Gridify
Syntax
Delphi
public
 class function From(const AData:TDataItem;
 const AValue,ARow,ACol:String):TDataItem; overload; static;

Parameters

AData
Type: TDataItem

AValue
Type: String

ARow
Type: String

ACol
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TGridify
  • BI.Gridify


TGridify.From(TDataItem,TDataArray,TDataArray) Method

Summary

Represents method From(TDataItem,TDataArray,TDataArray).

Namespace: BI.Gridify
Syntax
Delphi
public
 class function From(const AValue:TDataItem;
 const ARows,ACols:TDataArray):TDataItem; overload; static;

Parameters

AValue
Type: TDataItem

ARows
Type: TDataArray

ACols
Type: TDataArray

Return Value

Type: TDataItem

See Also

Reference

  • TGridify
  • BI.Gridify


TGridify.FromItems(TDataItem,String,TStringArray,TStringArray) Method

Summary

Represents method FromItems(TDataItem,String,TStringArray,TStringArray).

Namespace: BI.Gridify
Syntax
Delphi
public
 class function FromItems(const AData:TDataItem;
 const AValue:String;
 const ARows,ACols:TStringArray):TDataItem; static;

Parameters

AData
Type: TDataItem

AValue
Type: String

ARows
Type: TStringArray

ACols
Type: TStringArray

Return Value

Type: TDataItem

See Also

Reference

  • TGridify
  • BI.Gridify


BI.GuessLinks Namespace

Summary

Represents namespace BI.GuessLinks.

Classes
Name | Description
TDataItemAccess | Represents type TDataItemAccess.
TGuessLinks | Represents type TGuessLinks.
Top


BI.GuessLinks Classes

Classes
Name | Description
TDataItemAccess | Represents type TDataItemAccess.
TGuessLinks | Represents type TGuessLinks.
Top


TDataItemAccess Class

Summary

Represents type TDataItemAccess.

Namespace: BI.GuessLinks
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.GuessLinks.TDataItemAccess
Syntax
Delphi
type
 TDataItemAccess=class(TDataItem);
See Also

Reference

  • BI.GuessLinks


TGuessLinks Class

Summary

Represents type TGuessLinks.

Namespace: BI.GuessLinks
Inheritance Hierarchy
TObject
BI.GuessLinks.TGuessLinks
Syntax
Delphi
type
 TGuessLinks=class
 end;

The TGuessLinks type exposes the following members.

Methods
Show:
Name | Description
Guess(TDataItem) | Represents method Guess(TDataItem).
Top
See Also

Reference

  • BI.GuessLinks


TGuessLinks Methods

Methods
Name | Description
Guess(TDataItem) | Represents method Guess(TDataItem).
Top


TGuessLinks.Guess(TDataItem) Method

Summary

Represents method Guess(TDataItem).

Namespace: BI.GuessLinks
Syntax
Delphi
public
 class function Guess(const Data:TDataItem):TDataItem;

Parameters

Data
Type: TDataItem

Return Value

Type: TDataItem

See Also

Reference

  • TGuessLinks
  • BI.GuessLinks


BI.Html Namespace

Summary

Represents namespace BI.Html.

Classes
Name | Description
TBIHTML | Represents type TBIHTML.
TBIHTMLExport | Represents type TBIHTMLExport.
TBIHtmlHelper | Represents type TBIHtmlHelper.
TBIXMLAccess | Represents type TBIXMLAccess.
TDataAccess | Represents type TDataAccess.
TDataItemAccess | Represents type TDataItemAccess.
Top
Records
Name | Description
TRowSpan | Represents type TRowSpan.
Top
Routines
Name | Description
HTMLTrim(String) | Represents method HTMLTrim(String).
Top


BI.Html Classes

Classes
Name | Description
TBIHTML | Represents type TBIHTML.
TBIHTMLExport | Represents type TBIHTMLExport.
TBIHtmlHelper | Represents type TBIHtmlHelper.
TBIXMLAccess | Represents type TBIXMLAccess.
TDataAccess | Represents type TDataAccess.
TDataItemAccess | Represents type TDataItemAccess.
Top


TBIHTML Class

Summary

Represents type TBIHTML.

Namespace: BI.Html
Inheritance Hierarchy
TObject
BI.DataSource.TBISource
BI.DataSource.TBIItemsSource
BI.DataSource.TBIFileSource
BI.DataSource.TBITextSource
BI.Html.TBIHTML
Syntax
Delphi
type
 TBIHTML=class(TBITextSource)
 end;

The TBIHTML type exposes the following members.

Methods
Show:
Name | Description
FileFilter | Represents method FileFilter. (Overrides TBIFileSource.FileFilter.)
Import(TStrings) | Represents method Import(TStrings). (Overrides TBIFileSource.Import(TStrings).)
Supports(String) | Represents method Supports(String). (Overrides TBIFileSource.Supports(String).)
Top
See Also

Reference

  • BI.Html


TBIHTML Methods

Methods
Name | Description
FileFilter | Represents method FileFilter. (Overrides TBIFileSource.FileFilter.)
Import(TStrings) | Represents method Import(TStrings). (Overrides TBIFileSource.Import(TStrings).)
Supports(String) | Represents method Supports(String). (Overrides TBIFileSource.Supports(String).)
Top


TBIHTML.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.Html
Syntax
Delphi
public
 class function FileFilter: TFileFilters; override;

Return Value

Type: TFileFilters

Overrides

TBIFileSource.FileFilter
See Also

Reference

  • TBIHTML
  • BI.Html


TBIHTML.Import(TStrings) Method

Summary

Represents method Import(TStrings).

Namespace: BI.Html
Syntax
Delphi
public
 function Import(const Strings:TStrings):TDataArray; override;

Parameters

Strings
Type: TStrings

Return Value

Type: TDataArray

Overrides

TBIFileSource.Import(TStrings)
See Also

Reference

  • TBIHTML
  • BI.Html


TBIHTML.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.Html
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIFileSource.Supports(String)
See Also

Reference

  • TBIHTML
  • BI.Html


TBIHTMLExport Class

Summary

Represents type TBIHTMLExport.

Namespace: BI.Html
Inheritance Hierarchy
TObject
BI.DataSource.TBIExport
BI.DataSource.TBITextExport
BI.Html.TBIHTMLExport
Syntax
Delphi
type
 TBIHTMLExport=class(TBITextExport)
 end;

The TBIHTMLExport type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TBIHTMLExport class. (Overrides TBIExport.Create.)
Top
Methods
Show:
Name | Description
DoEmit(TStrings) | Represents method DoEmit(TStrings). (Overrides TBIExport.DoEmit(TStrings).)
FileFilter | Represents method FileFilter. (Overrides TBIExport.FileFilter.)
Supports(String) | Represents method Supports(String). (Overrides TBIExport.Supports(String).)
Top
Fields
Show:
Name | Description
Borders | Represents field Borders.
Colorizers | Represents field Colorizers.
SortIcons | Represents field SortIcons.
Top
See Also

Reference

  • BI.Html


TBIHTMLExport Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TBIHTMLExport class. (Overrides TBIExport.Create.)
Top


TBIHTMLExport.Create Constructor

Summary

Initializes a new instance of the TBIHTMLExport class.

Namespace: BI.Html
Syntax
Delphi
public
 Constructor Create; override;

Overrides

TBIExport.Create
See Also

Reference

  • TBIHTMLExport
  • BI.Html


TBIHTMLExport Methods

Methods
Name | Description
DoEmit(TStrings) | Represents method DoEmit(TStrings). (Overrides TBIExport.DoEmit(TStrings).)
FileFilter | Represents method FileFilter. (Overrides TBIExport.FileFilter.)
Supports(String) | Represents method Supports(String). (Overrides TBIExport.Supports(String).)
Top


TBIHTMLExport.DoEmit(TStrings) Method

Summary

Represents method DoEmit(TStrings).

Namespace: BI.Html
Syntax
Delphi
protected
 procedure DoEmit(const AItems: TStrings); override;

Parameters

AItems
Type: TStrings

Overrides

TBIExport.DoEmit(TStrings)
See Also

Reference

  • TBIHTMLExport
  • BI.Html


TBIHTMLExport.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.Html
Syntax
Delphi
public
 class function FileFilter: TFileFilters; override;

Return Value

Type: TFileFilters

Overrides

TBIExport.FileFilter
See Also

Reference

  • TBIHTMLExport
  • BI.Html


TBIHTMLExport.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.Html
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIExport.Supports(String)
See Also

Reference

  • TBIHTMLExport
  • BI.Html


TBIHTMLExport Fields

Fields
Name | Description
Borders | Represents field Borders.
Colorizers | Represents field Colorizers.
SortIcons | Represents field SortIcons.
Top


TBIHTMLExport.Borders Field

Summary

Represents field Borders.

Namespace: BI.Html
Syntax
Delphi
public
 Borders : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBIHTMLExport
  • BI.Html


TBIHTMLExport.Colorizers Field

Summary

Represents field Colorizers.

Namespace: BI.Html
Syntax
Delphi
public
 Colorizers : TDataColorizers;

Field Value

Type: TDataColorizers

See Also

Reference

  • TBIHTMLExport
  • BI.Html


TBIHTMLExport.SortIcons Field

Summary

Represents field SortIcons.

Namespace: BI.Html
Syntax
Delphi
public
 SortIcons : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBIHTMLExport
  • BI.Html


TBIHtmlHelper Class

Summary

Represents type TBIHtmlHelper.

Namespace: BI.Html
Inheritance Hierarchy
TObject
BI.Html.TBIHtmlHelper
Syntax
Delphi
type
 TBIHtmlHelper=class
 end;

The TBIHtmlHelper type exposes the following members.

Constants
Show:
Name | Description
Return | Represents constant Return.
Top
Methods
Show:
Name | Description
Color(TColor) | Represents method Color(TColor).
Combo(String,TStringArray,TStringArray) | Represents method Combo(String,TStringArray,TStringArray).
Escape(String) | Represents method Escape(String).
FinishForm(String) | Represents method FinishForm(String).
Hidden(String,Integer) | Overloaded. Represents method Hidden(String,Integer).
Hidden(String,String) | Overloaded. Represents method Hidden(String,String).
InitForm | Represents method InitForm.
Link(String,String) | Represents method Link(String,String).
Navigator(TDataCursor,String,String,String) | Represents method Navigator(TDataCursor,String,String,String).
ToTable(TDataSet) | Represents method ToTable(TDataSet).
Top
Fields
Show:
Name | Description
TableClass | Represents field TableClass.
Top
See Also

Reference

  • BI.Html


TBIHtmlHelper Constants

Constants
Name | Description
Return | Represents constant Return.
Top


TBIHtmlHelper.Return Constant

Summary

Represents constant Return.

Namespace: BI.Html
Syntax
Delphi
public
 Return='</br>';

Value

Type: string

See Also

Reference

  • TBIHtmlHelper
  • BI.Html


TBIHtmlHelper Methods

Methods
Name | Description
Color(TColor) | Represents method Color(TColor).
Combo(String,TStringArray,TStringArray) | Represents method Combo(String,TStringArray,TStringArray).
Escape(String) | Represents method Escape(String).
FinishForm(String) | Represents method FinishForm(String).
Hidden(String,Integer) | Overloaded. Represents method Hidden(String,Integer).
Hidden(String,String) | Overloaded. Represents method Hidden(String,String).
InitForm | Represents method InitForm.
Link(String,String) | Represents method Link(String,String).
Navigator(TDataCursor,String,String,String) | Represents method Navigator(TDataCursor,String,String,String).
ToTable(TDataSet) | Represents method ToTable(TDataSet).
Top


TBIHtmlHelper.Color(TColor) Method

Summary

Represents method Color(TColor).

Namespace: BI.Html
Syntax
Delphi
public
 class function Color(const AColor:TColor):String; static;

Parameters

AColor
Type: TColor

Return Value

Type: String

See Also

Reference

  • TBIHtmlHelper
  • BI.Html


TBIHtmlHelper.Combo(String,TStringArray,TStringArray) Method

Summary

Represents method Combo(String,TStringArray,TStringArray).

Namespace: BI.Html
Syntax
Delphi
public
 class function Combo(const AName:String; const Texts,Values:TStringArray): String; static;

Parameters

AName
Type: String

Texts
Type: TStringArray

Values
Type: TStringArray

Return Value

Type: String

See Also

Reference

  • TBIHtmlHelper
  • BI.Html


TBIHtmlHelper.Escape(String) Method

Summary

Represents method Escape(String).

Namespace: BI.Html
Syntax
Delphi
public
 class function Escape(const S:String):String; static;

Parameters

S
Type: String

Return Value

Type: String

See Also

Reference

  • TBIHtmlHelper
  • BI.Html


TBIHtmlHelper.FinishForm(String) Method

Summary

Represents method FinishForm(String).

Namespace: BI.Html
Syntax
Delphi
public
 class function FinishForm(const AName:String):String; static;

Parameters

AName
Type: String

Return Value

Type: String

See Also

Reference

  • TBIHtmlHelper
  • BI.Html


TBIHtmlHelper.Hidden(String,Integer) Method

Summary

Represents method Hidden(String,Integer).

Namespace: BI.Html
Syntax
Delphi
public
 class function Hidden(const AName:String; const AValue:Integer):String; overload; static;

Parameters

AName
Type: String

AValue
Type: Integer

Return Value

Type: String

See Also

Reference

  • TBIHtmlHelper
  • BI.Html


TBIHtmlHelper.Hidden(String,String) Method

Summary

Represents method Hidden(String,String).

Namespace: BI.Html
Syntax
Delphi
public
 class function Hidden(const AName,AValue:String):String; overload; static;

Parameters

AName
Type: String

AValue
Type: String

Return Value

Type: String

See Also

Reference

  • TBIHtmlHelper
  • BI.Html


TBIHtmlHelper.InitForm Method

Summary

Represents method InitForm.

Namespace: BI.Html
Syntax
Delphi
public
 class function InitForm:String; static;

Return Value

Type: String

See Also

Reference

  • TBIHtmlHelper
  • BI.Html


TBIHtmlHelper.Link(String,String) Method

Summary

Represents method Link(String,String).

Namespace: BI.Html
Syntax
Delphi
public
 class function Link(const Text,URL:String):String; static;

Parameters

Text
Type: String

URL
Type: String

Return Value

Type: String

See Also

Reference

  • TBIHtmlHelper
  • BI.Html


TBIHtmlHelper.Navigator(TDataCursor,String,String,String) Method

Summary

Represents method Navigator(TDataCursor,String,String,String).

Namespace: BI.Html
Syntax
Delphi
public
 class function Navigator(const ACursor:TDataCursor; const URL,Button,ButtonDisabled:String):String; static;

Parameters

ACursor
Type: TDataCursor

URL
Type: String

Button
Type: String

ButtonDisabled
Type: String

Return Value

Type: String

See Also

Reference

  • TBIHtmlHelper
  • BI.Html


TBIHtmlHelper.ToTable(TDataSet) Method

Summary

Represents method ToTable(TDataSet).

Namespace: BI.Html
Syntax
Delphi
public
 class function ToTable(const ADataSet:TDataSet):String; static;

Parameters

ADataSet
Type: TDataSet

Return Value

Type: String

See Also

Reference

  • TBIHtmlHelper
  • BI.Html


TBIHtmlHelper Fields

Fields
Name | Description
TableClass | Represents field TableClass.
Top


TBIHtmlHelper.TableClass Field

Summary

Represents field TableClass.

Namespace: BI.Html
Syntax
Delphi
public
 class var
 TableClass:String;

Field Value

Type: String

See Also

Reference

  • TBIHtmlHelper
  • BI.Html


TBIXMLAccess Class

Summary

Represents type TBIXMLAccess.

Namespace: BI.Html
Inheritance Hierarchy
TObject
BI.DataSource.TBISource
BI.DataSource.TBIItemsSource
BI.DataSource.TBIFileSource
BI.DataSource.TBITextSource
BI.DataSource.TBIHierarchicalSource
BI.XMLData.TBIXML
BI.Html.TBIXMLAccess
Syntax
Delphi
type
 TBIXMLAccess=class(TBIXML);
See Also

Reference

  • BI.Html


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.Html
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Html.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.Html


TDataItemAccess Class

Summary

Represents type TDataItemAccess.

Namespace: BI.Html
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Html.TDataItemAccess
Syntax
Delphi
type
 TDataItemAccess=class(TDataItem);
See Also

Reference

  • BI.Html


BI.Html Records

Records
Name | Description
TRowSpan | Represents type TRowSpan.
Top


TRowSpan Record

Summary

Represents type TRowSpan.

Namespace: BI.Html
Syntax
Delphi
type
 TRowSpan=record
 end;

The TRowSpan type exposes the following members.

Fields
Show:
Name | Description
Count | Represents field Count.
Data | Represents field Data.
Top
See Also

Reference

  • BI.Html


TRowSpan Fields

Fields
Name | Description
Count | Represents field Count.
Data | Represents field Data.
Top


TRowSpan.Count Field

Summary

Represents field Count.

Namespace: BI.Html
Syntax
Delphi
public
 Count : Integer;

Field Value

Type: Integer

See Also

Reference

  • TRowSpan
  • BI.Html


TRowSpan.Data Field

Summary

Represents field Data.

Namespace: BI.Html
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TRowSpan
  • BI.Html


BI.Html Routines

Routines
Name | Description
HTMLTrim(String) | Represents method HTMLTrim(String).
Top


HTMLTrim(String) Method

Summary

Represents method HTMLTrim(String).

Namespace: BI.Html
Syntax
Delphi
function HTMLTrim(const S:String):String;

Parameters

S
Type: String

Return Value

Type: String

See Also

Reference

  • BI.Html


BI.Info Namespace

Summary

Represents namespace BI.Info.

Classes
Name | Description
TDataAccess | Represents type TDataAccess.
TDataInfo | Represents type TDataInfo.
Top
Records
Name | Description
TDataItemsInfo | Represents type TDataItemsInfo.
Top


BI.Info Classes

Classes
Name | Description
TDataAccess | Represents type TDataAccess.
TDataInfo | Represents type TDataInfo.
Top


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.Info
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Info.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.Info


TDataInfo Class

Summary

Represents type TDataInfo.

Namespace: BI.Info
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Info.TDataInfo
Syntax
Delphi
type
 TDataInfo=class(TDataItem)
 end;

The TDataInfo type exposes the following members.

Constructors
Show:
Name | Description
Create(TDataItem) | Overloaded. Initializes a new instance of the TDataInfo class.
Top
Properties
Show:
Name | Description
Data | Represents property Data.
Top
Methods
Show:
Name | Description
GetMinMax(TDataItem,Extended,Extended) | Represents method GetMinMax(TDataItem,Extended,Extended).
Top
See Also

Reference

  • BI.Info


TDataInfo Constructors

Constructors
Name | Description
Create(TDataItem) | Overloaded. Initializes a new instance of the TDataInfo class.
Top


TDataInfo.Create(TDataItem) Constructor

Summary

Initializes a new instance of the TDataInfo class.

Namespace: BI.Info
Syntax
Delphi
public
 Constructor Create(const AData:TDataItem); overload;

Parameters

AData
Type: TDataItem

See Also

Reference

  • TDataInfo
  • BI.Info


TDataInfo Properties

Properties
Name | Description
Data | Represents property Data.
Top


TDataInfo.Data Property

Summary

Represents property Data.

Namespace: BI.Info
Syntax
Delphi
public
 property Data:TDataItem read FData write SetData;

Property Value

Type: TDataItem

See Also

Reference

  • TDataInfo
  • BI.Info


TDataInfo Methods

Methods
Name | Description
GetMinMax(TDataItem,Extended,Extended) | Represents method GetMinMax(TDataItem,Extended,Extended).
Top


TDataInfo.GetMinMax(TDataItem,Extended,Extended) Method

Summary

Represents method GetMinMax(TDataItem,Extended,Extended).

Namespace: BI.Info
Syntax
Delphi
public
 class procedure GetMinMax(const AData:TDataItem; out AMin,AMax:Extended); static;

Parameters

AData
Type: TDataItem

AMin
Type: Extended

AMax
Type: Extended

See Also

Reference

  • TDataInfo
  • BI.Info


BI.Info Records

Records
Name | Description
TDataItemsInfo | Represents type TDataItemsInfo.
Top


TDataItemsInfo Record

Summary

Represents type TDataItemsInfo.

Namespace: BI.Info
Syntax
Delphi
type
 TDataItemsInfo=record
 end;

The TDataItemsInfo type exposes the following members.

Methods
Show:
Name | Description
ItemsOf(TDataItem) | Overloaded. Represents method ItemsOf(TDataItem).
Top
See Also

Reference

  • BI.Info


TDataItemsInfo Methods

Methods
Name | Description
ItemsOf(TDataItem) | Overloaded. Represents method ItemsOf(TDataItem).
Top


TDataItemsInfo.ItemsOf(TDataItem) Method

Summary

Represents method ItemsOf(TDataItem).

Namespace: BI.Info
Syntax
Delphi
public
 class function ItemsOf(const AData:TDataItem):TDataItem; overload; static;

Parameters

AData
Type: TDataItem

Return Value

Type: TDataItem

See Also

Reference

  • TDataItemsInfo
  • BI.Info


BI.JSON Namespace

Summary

Represents namespace BI.JSON.

Classes
Name | Description
EBIJSON | Represents type EBIJSON.
TBIJSON | Represents type TBIJSON.
TBIJSONExport | Represents type TBIJSONExport.
TDataAccess | Represents type TDataAccess.
TJSONEngine | Represents type TJSONEngine.
Top
Enumerations
Name | Description
TBIJSONFormat | Represents type TBIJSONFormat.
Top
Types
Name | Description
TJSONEngineClass | Represents type TJSONEngineClass.
Top


BI.JSON Classes

Classes
Name | Description
EBIJSON | Represents type EBIJSON.
TBIJSON | Represents type TBIJSON.
TBIJSONExport | Represents type TBIJSONExport.
TDataAccess | Represents type TDataAccess.
TJSONEngine | Represents type TJSONEngine.
Top


EBIJSON Class

Summary

Represents type EBIJSON.

Namespace: BI.JSON
Inheritance Hierarchy
Exception
BI.Arrays.EBIException
BI.JSON.EBIJSON
Syntax
Delphi
type
 EBIJSON=class(EBIException);
See Also

Reference

  • BI.JSON


TBIJSON Class

Summary

Represents type TBIJSON.

Namespace: BI.JSON
Inheritance Hierarchy
TObject
BI.DataSource.TBISource
BI.DataSource.TBIItemsSource
BI.DataSource.TBIFileSource
BI.DataSource.TBITextSource
BI.DataSource.TBIHierarchicalSource
BI.JSON.TBIJSON
Syntax
Delphi
type
 TBIJSON=class(TBIHierarchicalSource)
 end;

The TBIJSON type exposes the following members.

Constructors
Show:
Name | Description
Create(TDataDefinition,Boolean) | Initializes a new instance of the TBIJSON class. (Overrides TBIHierarchicalSource.Create(TDataDefinition,Boolean).)
CreateEngine(TJSONEngine) | Initializes a new instance of the TBIJSON class.
Destroy | Represents the destructor of the TBIJSON class.
Top
Methods
Show:
Name | Description
FileFilter | Represents method FileFilter. (Overrides TBIFileSource.FileFilter.)
FromFile(String,TBIJSONFormat) | Overloaded. Represents method FromFile(String,TBIJSONFormat).
Import(String,Boolean) | Overloaded. Represents method Import(String,Boolean).
Import(TStrings) | Overloaded. Represents method Import(TStrings). (Overrides TBIFileSource.Import(TStrings).)
ImportFile(String) | Represents method ImportFile(String). (Overrides TBIFileSource.ImportFile(String).)
ImportText(String) | Represents method ImportText(String).
Supports(String) | Represents method Supports(String). (Overrides TBIFileSource.Supports(String).)
Top
Fields
Show:
Name | Description
EngineClass | Represents field EngineClass.
Format | Represents field Format.
Top
See Also

Reference

  • BI.JSON


TBIJSON Constructors

Constructors
Name | Description
Create(TDataDefinition,Boolean) | Initializes a new instance of the TBIJSON class. (Overrides TBIHierarchicalSource.Create(TDataDefinition,Boolean).)
CreateEngine(TJSONEngine) | Initializes a new instance of the TBIJSON class.
Destroy | Represents the destructor of the TBIJSON class.
Top


TBIJSON.Create(TDataDefinition,Boolean) Constructor

Summary

Initializes a new instance of the TBIJSON class.

Namespace: BI.JSON
Syntax
Delphi
public
 Constructor Create(const Definition:TDataDefinition=nil; const MultiThread:Boolean=False); override;

Parameters

Definition
Type: TDataDefinition

MultiThread
Type: Boolean

Overrides

TBIHierarchicalSource.Create(TDataDefinition,Boolean)
See Also

Reference

  • TBIJSON
  • BI.JSON


TBIJSON.CreateEngine(TJSONEngine) Constructor

Summary

Initializes a new instance of the TBIJSON class.

Namespace: BI.JSON
Syntax
Delphi
public
 Constructor CreateEngine(const AEngine:TJSONEngine);

Parameters

AEngine
Type: TJSONEngine

See Also

Reference

  • TBIJSON
  • BI.JSON


TBIJSON.Destroy Destructor

Summary

Represents the destructor of the TBIJSON class.

Namespace: BI.JSON
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIJSON
  • BI.JSON


TBIJSON Methods

Methods
Name | Description
FileFilter | Represents method FileFilter. (Overrides TBIFileSource.FileFilter.)
FromFile(String,TBIJSONFormat) | Overloaded. Represents method FromFile(String,TBIJSONFormat).
Import(String,Boolean) | Overloaded. Represents method Import(String,Boolean).
Import(TStrings) | Overloaded. Represents method Import(TStrings). (Overrides TBIFileSource.Import(TStrings).)
ImportFile(String) | Represents method ImportFile(String). (Overrides TBIFileSource.ImportFile(String).)
ImportText(String) | Represents method ImportText(String).
Supports(String) | Represents method Supports(String). (Overrides TBIFileSource.Supports(String).)
Top


TBIJSON.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.JSON
Syntax
Delphi
public
 class function FileFilter:TFileFilters; override;

Return Value

Type: TFileFilters

Overrides

TBIFileSource.FileFilter
See Also

Reference

  • TBIJSON
  • BI.JSON


TBIJSON.FromFile(String,TBIJSONFormat) Method

Summary

Represents method FromFile(String,TBIJSONFormat).

Namespace: BI.JSON
Syntax
Delphi
public
 class function FromFile(const AFileName:String; const AFormat:TBIJSONFormat):TDataItem; overload;

Parameters

AFileName
Type: String

AFormat
Type: TBIJSONFormat

Return Value

Type: TDataItem

See Also

Reference

  • TBIJSON
  • BI.JSON


TBIJSON.Import(String,Boolean) Method

Summary

Represents method Import(String,Boolean).

Namespace: BI.JSON
Syntax
Delphi
public
 function Import(const Folder:String; Recursive:Boolean=False):TDataArray; overload;

Parameters

Folder
Type: String

Recursive
Type: Boolean

Return Value

Type: TDataArray

See Also

Reference

  • TBIJSON
  • BI.JSON


TBIJSON.Import(TStrings) Method

Summary

Represents method Import(TStrings).

Namespace: BI.JSON
Syntax
Delphi
public
 function Import(const Strings:TStrings):TDataArray; overload; override;

Parameters

Strings
Type: TStrings

Return Value

Type: TDataArray

Overrides

TBIFileSource.Import(TStrings)
See Also

Reference

  • TBIJSON
  • BI.JSON


TBIJSON.ImportFile(String) Method

Summary

Represents method ImportFile(String).

Namespace: BI.JSON
Syntax
Delphi
public
 function ImportFile(const FileName:String):TDataArray; override;

Parameters

FileName
Type: String

Return Value

Type: TDataArray

Overrides

TBIFileSource.ImportFile(String)
See Also

Reference

  • TBIJSON
  • BI.JSON


TBIJSON.ImportText(String) Method

Summary

Represents method ImportText(String).

Namespace: BI.JSON
Syntax
Delphi
public
 function ImportText(const Text:String): TDataItem;

Parameters

Text
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TBIJSON
  • BI.JSON


TBIJSON.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.JSON
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIFileSource.Supports(String)
See Also

Reference

  • TBIJSON
  • BI.JSON


TBIJSON Fields

Fields
Name | Description
EngineClass | Represents field EngineClass.
Format | Represents field Format.
Top


TBIJSON.EngineClass Field

Summary

Represents field EngineClass.

Namespace: BI.JSON
Syntax
Delphi
public
 class var
 EngineClass : TJSONEngineClass;

Field Value

Type: TJSONEngineClass

See Also

Reference

  • TBIJSON
  • BI.JSON


TBIJSON.Format Field

Summary

Represents field Format.

Namespace: BI.JSON
Syntax
Delphi
public
 class var
 Format : TBIJSONFormat;

Field Value

Type: TBIJSONFormat

See Also

Reference

  • TBIJSON
  • BI.JSON


TBIJSONExport Class

Summary

Represents type TBIJSONExport.

Namespace: BI.JSON
Inheritance Hierarchy
TObject
BI.DataSource.TBIExport
BI.DataSource.TBITextExport
BI.JSON.TBIJSONExport
Syntax
Delphi
type
 TBIJSONExport=class(TBITextExport)
 end;

The TBIJSONExport type exposes the following members.

Methods
Show:
Name | Description
AsString(TDataItem,Boolean) | Overloaded. Represents method AsString(TDataItem,Boolean).
DoEmit(TStrings) | Represents method DoEmit(TStrings). (Overrides TBIExport.DoEmit(TStrings).)
FileFilter | Represents method FileFilter. (Overrides TBIExport.FileFilter.)
Supports(String) | Represents method Supports(String). (Overrides TBIExport.Supports(String).)
Top
Fields
Show:
Name | Description
Header | Represents field Header.
Top
See Also

Reference

  • BI.JSON


TBIJSONExport Methods

Methods
Name | Description
AsString(TDataItem,Boolean) | Overloaded. Represents method AsString(TDataItem,Boolean).
DoEmit(TStrings) | Represents method DoEmit(TStrings). (Overrides TBIExport.DoEmit(TStrings).)
FileFilter | Represents method FileFilter. (Overrides TBIExport.FileFilter.)
Supports(String) | Represents method Supports(String). (Overrides TBIExport.Supports(String).)
Top


TBIJSONExport.AsString(TDataItem,Boolean) Method

Summary

Represents method AsString(TDataItem,Boolean).

Namespace: BI.JSON
Syntax
Delphi
public
 class function AsString(const AData: TDataItem; const Header:Boolean): String; overload; static;

Parameters

AData
Type: TDataItem

Header
Type: Boolean

Return Value

Type: String

See Also

Reference

  • TBIJSONExport
  • BI.JSON


TBIJSONExport.DoEmit(TStrings) Method

Summary

Represents method DoEmit(TStrings).

Namespace: BI.JSON
Syntax
Delphi
protected
 procedure DoEmit(const AItems: TStrings); override;

Parameters

AItems
Type: TStrings

Overrides

TBIExport.DoEmit(TStrings)
See Also

Reference

  • TBIJSONExport
  • BI.JSON


TBIJSONExport.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.JSON
Syntax
Delphi
public
 class function FileFilter: TFileFilters; override;

Return Value

Type: TFileFilters

Overrides

TBIExport.FileFilter
See Also

Reference

  • TBIJSONExport
  • BI.JSON


TBIJSONExport.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.JSON
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIExport.Supports(String)
See Also

Reference

  • TBIJSONExport
  • BI.JSON


TBIJSONExport Fields

Fields
Name | Description
Header | Represents field Header.
Top


TBIJSONExport.Header Field

Summary

Represents field Header.

Namespace: BI.JSON
Syntax
Delphi
public
 Header : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBIJSONExport
  • BI.JSON


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.JSON
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.JSON.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.JSON


TJSONEngine Class

Summary

Represents type TJSONEngine.

Namespace: BI.JSON
Inheritance Hierarchy
TObject
BI.JSON.TJSONEngine
BI.JSON.FPC.TFPCJSON
BI.JSON.mORMot.TmORMotJSONEngine
BI.JSON.Standard.TStandardJSON
BI.JSON.SuperObject.TSuperObjectJSON
Syntax
Delphi
type
 TJSONEngine=class abstract
 end;

The TJSONEngine type exposes the following members.

Methods
Show:
Name | Description
ArrayChild(Integer) | Represents method ArrayChild(Integer).
AsBoolean | Represents method AsBoolean.
AsDouble | Represents method AsDouble.
AsString | Represents method AsString.
EnterArray | Represents method EnterArray.
EnterObject | Represents method EnterObject.
IsArray | Represents method IsArray.
IsBoolean | Represents method IsBoolean.
IsNull | Represents method IsNull.
IsNumber | Represents method IsNumber.
IsObject | Represents method IsObject.
IsString | Represents method IsString.
ObjectChild(Integer) | Represents method ObjectChild(Integer).
Parse(String) | Represents method Parse(String).
Pop | Represents method Pop.
Top
See Also

Reference

  • BI.JSON


TJSONEngine Methods

Methods
Name | Description
ArrayChild(Integer) | Represents method ArrayChild(Integer).
AsBoolean | Represents method AsBoolean.
AsDouble | Represents method AsDouble.
AsString | Represents method AsString.
EnterArray | Represents method EnterArray.
EnterObject | Represents method EnterObject.
IsArray | Represents method IsArray.
IsBoolean | Represents method IsBoolean.
IsNull | Represents method IsNull.
IsNumber | Represents method IsNumber.
IsObject | Represents method IsObject.
IsString | Represents method IsString.
ObjectChild(Integer) | Represents method ObjectChild(Integer).
Parse(String) | Represents method Parse(String).
Pop | Represents method Pop.
Top


TJSONEngine.ArrayChild(Integer) Method

Summary

Represents method ArrayChild(Integer).

Namespace: BI.JSON
Syntax
Delphi
protected
 procedure ArrayChild(const Index:Integer); virtual; abstract;

Parameters

Index
Type: Integer

See Also

Reference

  • TJSONEngine
  • BI.JSON


TJSONEngine.AsBoolean Method

Summary

Represents method AsBoolean.

Namespace: BI.JSON
Syntax
Delphi
protected
 function AsBoolean:Boolean; virtual; abstract;

Return Value

Type: Boolean

See Also

Reference

  • TJSONEngine
  • BI.JSON


TJSONEngine.AsDouble Method

Summary

Represents method AsDouble.

Namespace: BI.JSON
Syntax
Delphi
protected
 function AsDouble:Double; virtual; abstract;

Return Value

Type: Double

See Also

Reference

  • TJSONEngine
  • BI.JSON


TJSONEngine.AsString Method

Summary

Represents method AsString.

Namespace: BI.JSON
Syntax
Delphi
protected
 function AsString:String; virtual; abstract;

Return Value

Type: String

See Also

Reference

  • TJSONEngine
  • BI.JSON


TJSONEngine.EnterArray Method

Summary

Represents method EnterArray.

Namespace: BI.JSON
Syntax
Delphi
protected
 function EnterArray:Integer; virtual; abstract;

Return Value

Type: Integer

See Also

Reference

  • TJSONEngine
  • BI.JSON


TJSONEngine.EnterObject Method

Summary

Represents method EnterObject.

Namespace: BI.JSON
Syntax
Delphi
protected
 function EnterObject:Integer; virtual; abstract;

Return Value

Type: Integer

See Also

Reference

  • TJSONEngine
  • BI.JSON


TJSONEngine.IsArray Method

Summary

Represents method IsArray.

Namespace: BI.JSON
Syntax
Delphi
protected
 function IsArray:Boolean; virtual; abstract;

Return Value

Type: Boolean

See Also

Reference

  • TJSONEngine
  • BI.JSON


TJSONEngine.IsBoolean Method

Summary

Represents method IsBoolean.

Namespace: BI.JSON
Syntax
Delphi
protected
 function IsBoolean:Boolean; virtual; abstract;

Return Value

Type: Boolean

See Also

Reference

  • TJSONEngine
  • BI.JSON


TJSONEngine.IsNull Method

Summary

Represents method IsNull.

Namespace: BI.JSON
Syntax
Delphi
protected
 function IsNull:Boolean; virtual; abstract;

Return Value

Type: Boolean

See Also

Reference

  • TJSONEngine
  • BI.JSON


TJSONEngine.IsNumber Method

Summary

Represents method IsNumber.

Namespace: BI.JSON
Syntax
Delphi
protected
 function IsNumber:Boolean; virtual; abstract;

Return Value

Type: Boolean

See Also

Reference

  • TJSONEngine
  • BI.JSON


TJSONEngine.IsObject Method

Summary

Represents method IsObject.

Namespace: BI.JSON
Syntax
Delphi
protected
 function IsObject:Boolean; virtual; abstract;

Return Value

Type: Boolean

See Also

Reference

  • TJSONEngine
  • BI.JSON


TJSONEngine.IsString Method

Summary

Represents method IsString.

Namespace: BI.JSON
Syntax
Delphi
protected
 function IsString:Boolean; virtual; abstract;

Return Value

Type: Boolean

See Also

Reference

  • TJSONEngine
  • BI.JSON


TJSONEngine.ObjectChild(Integer) Method

Summary

Represents method ObjectChild(Integer).

Namespace: BI.JSON
Syntax
Delphi
protected
 function ObjectChild(const Index:Integer):String; virtual; abstract;

Parameters

Index
Type: Integer

Return Value

Type: String

See Also

Reference

  • TJSONEngine
  • BI.JSON


TJSONEngine.Parse(String) Method

Summary

Represents method Parse(String).

Namespace: BI.JSON
Syntax
Delphi
protected
 procedure Parse(const Text:String); virtual; abstract;

Parameters

Text
Type: String

See Also

Reference

  • TJSONEngine
  • BI.JSON


TJSONEngine.Pop Method

Summary

Represents method Pop.

Namespace: BI.JSON
Syntax
Delphi
protected
 procedure Pop; virtual; abstract;
See Also

Reference

  • TJSONEngine
  • BI.JSON


BI.JSON Enumerations

Enumerations
Name | Description
TBIJSONFormat | Represents type TBIJSONFormat.
Top


TBIJSONFormat Enumeration

Summary

Represents type TBIJSONFormat.

Namespace: BI.JSON
Syntax
Delphi
type
 TBIJSONFormat=(&Normal, &Array);

The TBIJSONFormat type exposes the following members.

Members
Show:
Name | Description
&Array | Represents constant &Array.
&Normal | Represents constant &Normal.
Top
See Also

Reference

  • BI.JSON


BI.JSON Types

Types
Name | Description
TJSONEngineClass | Represents type TJSONEngineClass.
Top


TJSONEngineClass Type

Summary

Represents type TJSONEngineClass.

Namespace: BI.JSON
Syntax
Delphi
type
 TJSONEngineClass=class of TJSONEngine;
See Also

Reference

  • BI.JSON


BI.JSON.FPC Namespace

Summary

Represents namespace BI.JSON.FPC.

Classes
Name | Description
TFPCJSON | Represents type TFPCJSON.
Top


BI.JSON.FPC Classes

Classes
Name | Description
TFPCJSON | Represents type TFPCJSON.
Top


TFPCJSON Class

Summary

Represents type TFPCJSON.

Namespace: BI.JSON.FPC
Inheritance Hierarchy
TObject
BI.JSON.TJSONEngine
BI.JSON.FPC.TFPCJSON
Syntax
Delphi
type
 TFPCJSON=class(TJSONEngine)
 end;

The TFPCJSON type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TFPCJSON class.
Top
Methods
Show:
Name | Description
ArrayChild(Integer) | Represents method ArrayChild(Integer). (Overrides TJSONEngine.ArrayChild(Integer).)
AsBoolean | Represents method AsBoolean. (Overrides TJSONEngine.AsBoolean.)
AsDouble | Represents method AsDouble. (Overrides TJSONEngine.AsDouble.)
AsString | Represents method AsString. (Overrides TJSONEngine.AsString.)
EnterArray | Represents method EnterArray. (Overrides TJSONEngine.EnterArray.)
EnterObject | Represents method EnterObject. (Overrides TJSONEngine.EnterObject.)
IsArray | Represents method IsArray. (Overrides TJSONEngine.IsArray.)
IsBoolean | Represents method IsBoolean. (Overrides TJSONEngine.IsBoolean.)
IsNull | Represents method IsNull. (Overrides TJSONEngine.IsNull.)
IsNumber | Represents method IsNumber. (Overrides TJSONEngine.IsNumber.)
IsObject | Represents method IsObject. (Overrides TJSONEngine.IsObject.)
IsString | Represents method IsString. (Overrides TJSONEngine.IsString.)
ObjectChild(Integer) | Represents method ObjectChild(Integer). (Overrides TJSONEngine.ObjectChild(Integer).)
Parse(String) | Represents method Parse(String). (Overrides TJSONEngine.Parse(String).)
Pop | Represents method Pop. (Overrides TJSONEngine.Pop.)
Top
See Also

Reference

  • BI.JSON.FPC


TFPCJSON Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TFPCJSON class.
Top


TFPCJSON.Destroy Destructor

Summary

Represents the destructor of the TFPCJSON class.

Namespace: BI.JSON.FPC
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TFPCJSON
  • BI.JSON.FPC


TFPCJSON Methods

Methods
Name | Description
ArrayChild(Integer) | Represents method ArrayChild(Integer). (Overrides TJSONEngine.ArrayChild(Integer).)
AsBoolean | Represents method AsBoolean. (Overrides TJSONEngine.AsBoolean.)
AsDouble | Represents method AsDouble. (Overrides TJSONEngine.AsDouble.)
AsString | Represents method AsString. (Overrides TJSONEngine.AsString.)
EnterArray | Represents method EnterArray. (Overrides TJSONEngine.EnterArray.)
EnterObject | Represents method EnterObject. (Overrides TJSONEngine.EnterObject.)
IsArray | Represents method IsArray. (Overrides TJSONEngine.IsArray.)
IsBoolean | Represents method IsBoolean. (Overrides TJSONEngine.IsBoolean.)
IsNull | Represents method IsNull. (Overrides TJSONEngine.IsNull.)
IsNumber | Represents method IsNumber. (Overrides TJSONEngine.IsNumber.)
IsObject | Represents method IsObject. (Overrides TJSONEngine.IsObject.)
IsString | Represents method IsString. (Overrides TJSONEngine.IsString.)
ObjectChild(Integer) | Represents method ObjectChild(Integer). (Overrides TJSONEngine.ObjectChild(Integer).)
Parse(String) | Represents method Parse(String). (Overrides TJSONEngine.Parse(String).)
Pop | Represents method Pop. (Overrides TJSONEngine.Pop.)
Top


TFPCJSON.ArrayChild(Integer) Method

Summary

Represents method ArrayChild(Integer).

Namespace: BI.JSON.FPC
Syntax
Delphi
protected
 procedure ArrayChild(const Index:Integer); override;

Parameters

Index
Type: Integer

Overrides

TJSONEngine.ArrayChild(Integer)
See Also

Reference

  • TFPCJSON
  • BI.JSON.FPC


TFPCJSON.AsBoolean Method

Summary

Represents method AsBoolean.

Namespace: BI.JSON.FPC
Syntax
Delphi
protected
 function AsBoolean:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.AsBoolean
See Also

Reference

  • TFPCJSON
  • BI.JSON.FPC


TFPCJSON.AsDouble Method

Summary

Represents method AsDouble.

Namespace: BI.JSON.FPC
Syntax
Delphi
protected
 function AsDouble:Double; override;

Return Value

Type: Double

Overrides

TJSONEngine.AsDouble
See Also

Reference

  • TFPCJSON
  • BI.JSON.FPC


TFPCJSON.AsString Method

Summary

Represents method AsString.

Namespace: BI.JSON.FPC
Syntax
Delphi
protected
 function AsString:String; override;

Return Value

Type: String

Overrides

TJSONEngine.AsString
See Also

Reference

  • TFPCJSON
  • BI.JSON.FPC


TFPCJSON.EnterArray Method

Summary

Represents method EnterArray.

Namespace: BI.JSON.FPC
Syntax
Delphi
protected
 function EnterArray:Integer; override;

Return Value

Type: Integer

Overrides

TJSONEngine.EnterArray
See Also

Reference

  • TFPCJSON
  • BI.JSON.FPC


TFPCJSON.EnterObject Method

Summary

Represents method EnterObject.

Namespace: BI.JSON.FPC
Syntax
Delphi
protected
 function EnterObject:Integer; override;

Return Value

Type: Integer

Overrides

TJSONEngine.EnterObject
See Also

Reference

  • TFPCJSON
  • BI.JSON.FPC


TFPCJSON.IsArray Method

Summary

Represents method IsArray.

Namespace: BI.JSON.FPC
Syntax
Delphi
protected
 function IsArray:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsArray
See Also

Reference

  • TFPCJSON
  • BI.JSON.FPC


TFPCJSON.IsBoolean Method

Summary

Represents method IsBoolean.

Namespace: BI.JSON.FPC
Syntax
Delphi
protected
 function IsBoolean:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsBoolean
See Also

Reference

  • TFPCJSON
  • BI.JSON.FPC


TFPCJSON.IsNull Method

Summary

Represents method IsNull.

Namespace: BI.JSON.FPC
Syntax
Delphi
protected
 function IsNull:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsNull
See Also

Reference

  • TFPCJSON
  • BI.JSON.FPC


TFPCJSON.IsNumber Method

Summary

Represents method IsNumber.

Namespace: BI.JSON.FPC
Syntax
Delphi
protected
 function IsNumber:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsNumber
See Also

Reference

  • TFPCJSON
  • BI.JSON.FPC


TFPCJSON.IsObject Method

Summary

Represents method IsObject.

Namespace: BI.JSON.FPC
Syntax
Delphi
protected
 function IsObject:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsObject
See Also

Reference

  • TFPCJSON
  • BI.JSON.FPC


TFPCJSON.IsString Method

Summary

Represents method IsString.

Namespace: BI.JSON.FPC
Syntax
Delphi
protected
 function IsString:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsString
See Also

Reference

  • TFPCJSON
  • BI.JSON.FPC


TFPCJSON.ObjectChild(Integer) Method

Summary

Represents method ObjectChild(Integer).

Namespace: BI.JSON.FPC
Syntax
Delphi
protected
 function ObjectChild(const Index:Integer):String; override;

Parameters

Index
Type: Integer

Return Value

Type: String

Overrides

TJSONEngine.ObjectChild(Integer)
See Also

Reference

  • TFPCJSON
  • BI.JSON.FPC


TFPCJSON.Parse(String) Method

Summary

Represents method Parse(String).

Namespace: BI.JSON.FPC
Syntax
Delphi
protected
 procedure Parse(const Text:String); override;

Parameters

Text
Type: String

Overrides

TJSONEngine.Parse(String)
See Also

Reference

  • TFPCJSON
  • BI.JSON.FPC


TFPCJSON.Pop Method

Summary

Represents method Pop.

Namespace: BI.JSON.FPC
Syntax
Delphi
protected
 procedure Pop; override;

Overrides

TJSONEngine.Pop
See Also

Reference

  • TFPCJSON
  • BI.JSON.FPC


BI.JSON.mORMot Namespace

Summary

Represents namespace BI.JSON.mORMot.

Classes
Name | Description
TmORMotJSONEngine | Represents type TmORMotJSONEngine.
Top


BI.JSON.mORMot Classes

Classes
Name | Description
TmORMotJSONEngine | Represents type TmORMotJSONEngine.
Top


TmORMotJSONEngine Class

Summary

Represents type TmORMotJSONEngine.

Namespace: BI.JSON.mORMot
Inheritance Hierarchy
TObject
BI.JSON.TJSONEngine
BI.JSON.mORMot.TmORMotJSONEngine
Syntax
Delphi
type
 TmORMotJSONEngine=class(TJSONEngine)
 end;

The TmORMotJSONEngine type exposes the following members.

Methods
Show:
Name | Description
ArrayChild(Integer) | Represents method ArrayChild(Integer). (Overrides TJSONEngine.ArrayChild(Integer).)
AsBoolean | Represents method AsBoolean. (Overrides TJSONEngine.AsBoolean.)
AsDouble | Represents method AsDouble. (Overrides TJSONEngine.AsDouble.)
AsString | Represents method AsString. (Overrides TJSONEngine.AsString.)
EnterArray | Represents method EnterArray. (Overrides TJSONEngine.EnterArray.)
EnterObject | Represents method EnterObject. (Overrides TJSONEngine.EnterObject.)
IsArray | Represents method IsArray. (Overrides TJSONEngine.IsArray.)
IsBoolean | Represents method IsBoolean. (Overrides TJSONEngine.IsBoolean.)
IsNull | Represents method IsNull. (Overrides TJSONEngine.IsNull.)
IsNumber | Represents method IsNumber. (Overrides TJSONEngine.IsNumber.)
IsObject | Represents method IsObject. (Overrides TJSONEngine.IsObject.)
IsString | Represents method IsString. (Overrides TJSONEngine.IsString.)
ObjectChild(Integer) | Represents method ObjectChild(Integer). (Overrides TJSONEngine.ObjectChild(Integer).)
Parse(String) | Represents method Parse(String). (Overrides TJSONEngine.Parse(String).)
Pop | Represents method Pop. (Overrides TJSONEngine.Pop.)
Top
See Also

Reference

  • BI.JSON.mORMot


TmORMotJSONEngine Methods

Methods
Name | Description
ArrayChild(Integer) | Represents method ArrayChild(Integer). (Overrides TJSONEngine.ArrayChild(Integer).)
AsBoolean | Represents method AsBoolean. (Overrides TJSONEngine.AsBoolean.)
AsDouble | Represents method AsDouble. (Overrides TJSONEngine.AsDouble.)
AsString | Represents method AsString. (Overrides TJSONEngine.AsString.)
EnterArray | Represents method EnterArray. (Overrides TJSONEngine.EnterArray.)
EnterObject | Represents method EnterObject. (Overrides TJSONEngine.EnterObject.)
IsArray | Represents method IsArray. (Overrides TJSONEngine.IsArray.)
IsBoolean | Represents method IsBoolean. (Overrides TJSONEngine.IsBoolean.)
IsNull | Represents method IsNull. (Overrides TJSONEngine.IsNull.)
IsNumber | Represents method IsNumber. (Overrides TJSONEngine.IsNumber.)
IsObject | Represents method IsObject. (Overrides TJSONEngine.IsObject.)
IsString | Represents method IsString. (Overrides TJSONEngine.IsString.)
ObjectChild(Integer) | Represents method ObjectChild(Integer). (Overrides TJSONEngine.ObjectChild(Integer).)
Parse(String) | Represents method Parse(String). (Overrides TJSONEngine.Parse(String).)
Pop | Represents method Pop. (Overrides TJSONEngine.Pop.)
Top


TmORMotJSONEngine.ArrayChild(Integer) Method

Summary

Represents method ArrayChild(Integer).

Namespace: BI.JSON.mORMot
Syntax
Delphi
protected
 procedure ArrayChild(const Index:Integer); override;

Parameters

Index
Type: Integer

Overrides

TJSONEngine.ArrayChild(Integer)
See Also

Reference

  • TmORMotJSONEngine
  • BI.JSON.mORMot


TmORMotJSONEngine.AsBoolean Method

Summary

Represents method AsBoolean.

Namespace: BI.JSON.mORMot
Syntax
Delphi
protected
 function AsBoolean:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.AsBoolean
See Also

Reference

  • TmORMotJSONEngine
  • BI.JSON.mORMot


TmORMotJSONEngine.AsDouble Method

Summary

Represents method AsDouble.

Namespace: BI.JSON.mORMot
Syntax
Delphi
protected
 function AsDouble:Double; override;

Return Value

Type: Double

Overrides

TJSONEngine.AsDouble
See Also

Reference

  • TmORMotJSONEngine
  • BI.JSON.mORMot


TmORMotJSONEngine.AsString Method

Summary

Represents method AsString.

Namespace: BI.JSON.mORMot
Syntax
Delphi
protected
 function AsString:String; override;

Return Value

Type: String

Overrides

TJSONEngine.AsString
See Also

Reference

  • TmORMotJSONEngine
  • BI.JSON.mORMot


TmORMotJSONEngine.EnterArray Method

Summary

Represents method EnterArray.

Namespace: BI.JSON.mORMot
Syntax
Delphi
protected
 function EnterArray:Integer; override;

Return Value

Type: Integer

Overrides

TJSONEngine.EnterArray
See Also

Reference

  • TmORMotJSONEngine
  • BI.JSON.mORMot


TmORMotJSONEngine.EnterObject Method

Summary

Represents method EnterObject.

Namespace: BI.JSON.mORMot
Syntax
Delphi
protected
 function EnterObject:Integer; override;

Return Value

Type: Integer

Overrides

TJSONEngine.EnterObject
See Also

Reference

  • TmORMotJSONEngine
  • BI.JSON.mORMot


TmORMotJSONEngine.IsArray Method

Summary

Represents method IsArray.

Namespace: BI.JSON.mORMot
Syntax
Delphi
protected
 function IsArray:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsArray
See Also

Reference

  • TmORMotJSONEngine
  • BI.JSON.mORMot


TmORMotJSONEngine.IsBoolean Method

Summary

Represents method IsBoolean.

Namespace: BI.JSON.mORMot
Syntax
Delphi
protected
 function IsBoolean:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsBoolean
See Also

Reference

  • TmORMotJSONEngine
  • BI.JSON.mORMot


TmORMotJSONEngine.IsNull Method

Summary

Represents method IsNull.

Namespace: BI.JSON.mORMot
Syntax
Delphi
protected
 function IsNull:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsNull
See Also

Reference

  • TmORMotJSONEngine
  • BI.JSON.mORMot


TmORMotJSONEngine.IsNumber Method

Summary

Represents method IsNumber.

Namespace: BI.JSON.mORMot
Syntax
Delphi
protected
 function IsNumber:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsNumber
See Also

Reference

  • TmORMotJSONEngine
  • BI.JSON.mORMot


TmORMotJSONEngine.IsObject Method

Summary

Represents method IsObject.

Namespace: BI.JSON.mORMot
Syntax
Delphi
protected
 function IsObject:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsObject
See Also

Reference

  • TmORMotJSONEngine
  • BI.JSON.mORMot


TmORMotJSONEngine.IsString Method

Summary

Represents method IsString.

Namespace: BI.JSON.mORMot
Syntax
Delphi
protected
 function IsString:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsString
See Also

Reference

  • TmORMotJSONEngine
  • BI.JSON.mORMot


TmORMotJSONEngine.ObjectChild(Integer) Method

Summary

Represents method ObjectChild(Integer).

Namespace: BI.JSON.mORMot
Syntax
Delphi
protected
 function ObjectChild(const Index:Integer):String; override;

Parameters

Index
Type: Integer

Return Value

Type: String

Overrides

TJSONEngine.ObjectChild(Integer)
See Also

Reference

  • TmORMotJSONEngine
  • BI.JSON.mORMot


TmORMotJSONEngine.Parse(String) Method

Summary

Represents method Parse(String).

Namespace: BI.JSON.mORMot
Syntax
Delphi
protected
 procedure Parse(const Text:String); override;

Parameters

Text
Type: String

Overrides

TJSONEngine.Parse(String)
See Also

Reference

  • TmORMotJSONEngine
  • BI.JSON.mORMot


TmORMotJSONEngine.Pop Method

Summary

Represents method Pop.

Namespace: BI.JSON.mORMot
Syntax
Delphi
protected
 procedure Pop; override;

Overrides

TJSONEngine.Pop
See Also

Reference

  • TmORMotJSONEngine
  • BI.JSON.mORMot


BI.JSON.Standard Namespace

Summary

Represents namespace BI.JSON.Standard.

Classes
Name | Description
TStandardJSON | Represents type TStandardJSON.
Top


BI.JSON.Standard Classes

Classes
Name | Description
TStandardJSON | Represents type TStandardJSON.
Top


TStandardJSON Class

Summary

Represents type TStandardJSON.

Namespace: BI.JSON.Standard
Inheritance Hierarchy
TObject
BI.JSON.TJSONEngine
BI.JSON.Standard.TStandardJSON
Syntax
Delphi
type
 TStandardJSON=class(TJSONEngine)
 end;

The TStandardJSON type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TStandardJSON class.
Top
Methods
Show:
Name | Description
ArrayChild(Integer) | Represents method ArrayChild(Integer). (Overrides TJSONEngine.ArrayChild(Integer).)
AsBoolean | Represents method AsBoolean. (Overrides TJSONEngine.AsBoolean.)
AsDouble | Represents method AsDouble. (Overrides TJSONEngine.AsDouble.)
AsString | Represents method AsString. (Overrides TJSONEngine.AsString.)
EnterArray | Represents method EnterArray. (Overrides TJSONEngine.EnterArray.)
EnterObject | Represents method EnterObject. (Overrides TJSONEngine.EnterObject.)
IsArray | Represents method IsArray. (Overrides TJSONEngine.IsArray.)
IsBoolean | Represents method IsBoolean. (Overrides TJSONEngine.IsBoolean.)
IsNull | Represents method IsNull. (Overrides TJSONEngine.IsNull.)
IsNumber | Represents method IsNumber. (Overrides TJSONEngine.IsNumber.)
IsObject | Represents method IsObject. (Overrides TJSONEngine.IsObject.)
IsString | Represents method IsString. (Overrides TJSONEngine.IsString.)
ObjectChild(Integer) | Represents method ObjectChild(Integer). (Overrides TJSONEngine.ObjectChild(Integer).)
Parse(String) | Represents method Parse(String). (Overrides TJSONEngine.Parse(String).)
Pop | Represents method Pop. (Overrides TJSONEngine.Pop.)
Top
See Also

Reference

  • BI.JSON.Standard


TStandardJSON Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TStandardJSON class.
Top


TStandardJSON.Destroy Destructor

Summary

Represents the destructor of the TStandardJSON class.

Namespace: BI.JSON.Standard
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TStandardJSON
  • BI.JSON.Standard


TStandardJSON Methods

Methods
Name | Description
ArrayChild(Integer) | Represents method ArrayChild(Integer). (Overrides TJSONEngine.ArrayChild(Integer).)
AsBoolean | Represents method AsBoolean. (Overrides TJSONEngine.AsBoolean.)
AsDouble | Represents method AsDouble. (Overrides TJSONEngine.AsDouble.)
AsString | Represents method AsString. (Overrides TJSONEngine.AsString.)
EnterArray | Represents method EnterArray. (Overrides TJSONEngine.EnterArray.)
EnterObject | Represents method EnterObject. (Overrides TJSONEngine.EnterObject.)
IsArray | Represents method IsArray. (Overrides TJSONEngine.IsArray.)
IsBoolean | Represents method IsBoolean. (Overrides TJSONEngine.IsBoolean.)
IsNull | Represents method IsNull. (Overrides TJSONEngine.IsNull.)
IsNumber | Represents method IsNumber. (Overrides TJSONEngine.IsNumber.)
IsObject | Represents method IsObject. (Overrides TJSONEngine.IsObject.)
IsString | Represents method IsString. (Overrides TJSONEngine.IsString.)
ObjectChild(Integer) | Represents method ObjectChild(Integer). (Overrides TJSONEngine.ObjectChild(Integer).)
Parse(String) | Represents method Parse(String). (Overrides TJSONEngine.Parse(String).)
Pop | Represents method Pop. (Overrides TJSONEngine.Pop.)
Top


TStandardJSON.ArrayChild(Integer) Method

Summary

Represents method ArrayChild(Integer).

Namespace: BI.JSON.Standard
Syntax
Delphi
protected
 procedure ArrayChild(const Index:Integer); override;

Parameters

Index
Type: Integer

Overrides

TJSONEngine.ArrayChild(Integer)
See Also

Reference

  • TStandardJSON
  • BI.JSON.Standard


TStandardJSON.AsBoolean Method

Summary

Represents method AsBoolean.

Namespace: BI.JSON.Standard
Syntax
Delphi
protected
 function AsBoolean:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.AsBoolean
See Also

Reference

  • TStandardJSON
  • BI.JSON.Standard


TStandardJSON.AsDouble Method

Summary

Represents method AsDouble.

Namespace: BI.JSON.Standard
Syntax
Delphi
protected
 function AsDouble:Double; override;

Return Value

Type: Double

Overrides

TJSONEngine.AsDouble
See Also

Reference

  • TStandardJSON
  • BI.JSON.Standard


TStandardJSON.AsString Method

Summary

Represents method AsString.

Namespace: BI.JSON.Standard
Syntax
Delphi
protected
 function AsString:String; override;

Return Value

Type: String

Overrides

TJSONEngine.AsString
See Also

Reference

  • TStandardJSON
  • BI.JSON.Standard


TStandardJSON.EnterArray Method

Summary

Represents method EnterArray.

Namespace: BI.JSON.Standard
Syntax
Delphi
protected
 function EnterArray:Integer; override;

Return Value

Type: Integer

Overrides

TJSONEngine.EnterArray
See Also

Reference

  • TStandardJSON
  • BI.JSON.Standard


TStandardJSON.EnterObject Method

Summary

Represents method EnterObject.

Namespace: BI.JSON.Standard
Syntax
Delphi
protected
 function EnterObject:Integer; override;

Return Value

Type: Integer

Overrides

TJSONEngine.EnterObject
See Also

Reference

  • TStandardJSON
  • BI.JSON.Standard


TStandardJSON.IsArray Method

Summary

Represents method IsArray.

Namespace: BI.JSON.Standard
Syntax
Delphi
protected
 function IsArray:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsArray
See Also

Reference

  • TStandardJSON
  • BI.JSON.Standard


TStandardJSON.IsBoolean Method

Summary

Represents method IsBoolean.

Namespace: BI.JSON.Standard
Syntax
Delphi
protected
 function IsBoolean:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsBoolean
See Also

Reference

  • TStandardJSON
  • BI.JSON.Standard


TStandardJSON.IsNull Method

Summary

Represents method IsNull.

Namespace: BI.JSON.Standard
Syntax
Delphi
protected
 function IsNull:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsNull
See Also

Reference

  • TStandardJSON
  • BI.JSON.Standard


TStandardJSON.IsNumber Method

Summary

Represents method IsNumber.

Namespace: BI.JSON.Standard
Syntax
Delphi
protected
 function IsNumber:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsNumber
See Also

Reference

  • TStandardJSON
  • BI.JSON.Standard


TStandardJSON.IsObject Method

Summary

Represents method IsObject.

Namespace: BI.JSON.Standard
Syntax
Delphi
protected
 function IsObject:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsObject
See Also

Reference

  • TStandardJSON
  • BI.JSON.Standard


TStandardJSON.IsString Method

Summary

Represents method IsString.

Namespace: BI.JSON.Standard
Syntax
Delphi
protected
 function IsString:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsString
See Also

Reference

  • TStandardJSON
  • BI.JSON.Standard


TStandardJSON.ObjectChild(Integer) Method

Summary

Represents method ObjectChild(Integer).

Namespace: BI.JSON.Standard
Syntax
Delphi
protected
 function ObjectChild(const Index:Integer):String; override;

Parameters

Index
Type: Integer

Return Value

Type: String

Overrides

TJSONEngine.ObjectChild(Integer)
See Also

Reference

  • TStandardJSON
  • BI.JSON.Standard


TStandardJSON.Parse(String) Method

Summary

Represents method Parse(String).

Namespace: BI.JSON.Standard
Syntax
Delphi
protected
 procedure Parse(const Text:String); override;

Parameters

Text
Type: String

Overrides

TJSONEngine.Parse(String)
See Also

Reference

  • TStandardJSON
  • BI.JSON.Standard


TStandardJSON.Pop Method

Summary

Represents method Pop.

Namespace: BI.JSON.Standard
Syntax
Delphi
protected
 procedure Pop; override;

Overrides

TJSONEngine.Pop
See Also

Reference

  • TStandardJSON
  • BI.JSON.Standard


BI.JSON.SuperObject Namespace

Summary

Represents namespace BI.JSON.SuperObject.

Classes
Name | Description
TSuperObjectJSON | Represents type TSuperObjectJSON.
Top


BI.JSON.SuperObject Classes

Classes
Name | Description
TSuperObjectJSON | Represents type TSuperObjectJSON.
Top


TSuperObjectJSON Class

Summary

Represents type TSuperObjectJSON.

Namespace: BI.JSON.SuperObject
Inheritance Hierarchy
TObject
BI.JSON.TJSONEngine
BI.JSON.SuperObject.TSuperObjectJSON
Syntax
Delphi
type
 TSuperObjectJSON=class(TJSONEngine)
 end;

The TSuperObjectJSON type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TSuperObjectJSON class.
Top
Methods
Show:
Name | Description
ArrayChild(Integer) | Represents method ArrayChild(Integer). (Overrides TJSONEngine.ArrayChild(Integer).)
AsBoolean | Represents method AsBoolean. (Overrides TJSONEngine.AsBoolean.)
AsDouble | Represents method AsDouble. (Overrides TJSONEngine.AsDouble.)
AsString | Represents method AsString. (Overrides TJSONEngine.AsString.)
EnterArray | Represents method EnterArray. (Overrides TJSONEngine.EnterArray.)
EnterObject | Represents method EnterObject. (Overrides TJSONEngine.EnterObject.)
IsArray | Represents method IsArray. (Overrides TJSONEngine.IsArray.)
IsBoolean | Represents method IsBoolean. (Overrides TJSONEngine.IsBoolean.)
IsNull | Represents method IsNull. (Overrides TJSONEngine.IsNull.)
IsNumber | Represents method IsNumber. (Overrides TJSONEngine.IsNumber.)
IsObject | Represents method IsObject. (Overrides TJSONEngine.IsObject.)
IsString | Represents method IsString. (Overrides TJSONEngine.IsString.)
ObjectChild(Integer) | Represents method ObjectChild(Integer). (Overrides TJSONEngine.ObjectChild(Integer).)
Parse(String) | Represents method Parse(String). (Overrides TJSONEngine.Parse(String).)
Pop | Represents method Pop. (Overrides TJSONEngine.Pop.)
Top
See Also

Reference

  • BI.JSON.SuperObject


TSuperObjectJSON Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TSuperObjectJSON class.
Top


TSuperObjectJSON.Destroy Destructor

Summary

Represents the destructor of the TSuperObjectJSON class.

Namespace: BI.JSON.SuperObject
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TSuperObjectJSON
  • BI.JSON.SuperObject


TSuperObjectJSON Methods

Methods
Name | Description
ArrayChild(Integer) | Represents method ArrayChild(Integer). (Overrides TJSONEngine.ArrayChild(Integer).)
AsBoolean | Represents method AsBoolean. (Overrides TJSONEngine.AsBoolean.)
AsDouble | Represents method AsDouble. (Overrides TJSONEngine.AsDouble.)
AsString | Represents method AsString. (Overrides TJSONEngine.AsString.)
EnterArray | Represents method EnterArray. (Overrides TJSONEngine.EnterArray.)
EnterObject | Represents method EnterObject. (Overrides TJSONEngine.EnterObject.)
IsArray | Represents method IsArray. (Overrides TJSONEngine.IsArray.)
IsBoolean | Represents method IsBoolean. (Overrides TJSONEngine.IsBoolean.)
IsNull | Represents method IsNull. (Overrides TJSONEngine.IsNull.)
IsNumber | Represents method IsNumber. (Overrides TJSONEngine.IsNumber.)
IsObject | Represents method IsObject. (Overrides TJSONEngine.IsObject.)
IsString | Represents method IsString. (Overrides TJSONEngine.IsString.)
ObjectChild(Integer) | Represents method ObjectChild(Integer). (Overrides TJSONEngine.ObjectChild(Integer).)
Parse(String) | Represents method Parse(String). (Overrides TJSONEngine.Parse(String).)
Pop | Represents method Pop. (Overrides TJSONEngine.Pop.)
Top


TSuperObjectJSON.ArrayChild(Integer) Method

Summary

Represents method ArrayChild(Integer).

Namespace: BI.JSON.SuperObject
Syntax
Delphi
protected
 procedure ArrayChild(const Index:Integer); override;

Parameters

Index
Type: Integer

Overrides

TJSONEngine.ArrayChild(Integer)
See Also

Reference

  • TSuperObjectJSON
  • BI.JSON.SuperObject


TSuperObjectJSON.AsBoolean Method

Summary

Represents method AsBoolean.

Namespace: BI.JSON.SuperObject
Syntax
Delphi
protected
 function AsBoolean:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.AsBoolean
See Also

Reference

  • TSuperObjectJSON
  • BI.JSON.SuperObject


TSuperObjectJSON.AsDouble Method

Summary

Represents method AsDouble.

Namespace: BI.JSON.SuperObject
Syntax
Delphi
protected
 function AsDouble:Double; override;

Return Value

Type: Double

Overrides

TJSONEngine.AsDouble
See Also

Reference

  • TSuperObjectJSON
  • BI.JSON.SuperObject


TSuperObjectJSON.AsString Method

Summary

Represents method AsString.

Namespace: BI.JSON.SuperObject
Syntax
Delphi
protected
 function AsString:String; override;

Return Value

Type: String

Overrides

TJSONEngine.AsString
See Also

Reference

  • TSuperObjectJSON
  • BI.JSON.SuperObject


TSuperObjectJSON.EnterArray Method

Summary

Represents method EnterArray.

Namespace: BI.JSON.SuperObject
Syntax
Delphi
protected
 function EnterArray:Integer; override;

Return Value

Type: Integer

Overrides

TJSONEngine.EnterArray
See Also

Reference

  • TSuperObjectJSON
  • BI.JSON.SuperObject


TSuperObjectJSON.EnterObject Method

Summary

Represents method EnterObject.

Namespace: BI.JSON.SuperObject
Syntax
Delphi
protected
 function EnterObject:Integer; override;

Return Value

Type: Integer

Overrides

TJSONEngine.EnterObject
See Also

Reference

  • TSuperObjectJSON
  • BI.JSON.SuperObject


TSuperObjectJSON.IsArray Method

Summary

Represents method IsArray.

Namespace: BI.JSON.SuperObject
Syntax
Delphi
protected
 function IsArray:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsArray
See Also

Reference

  • TSuperObjectJSON
  • BI.JSON.SuperObject


TSuperObjectJSON.IsBoolean Method

Summary

Represents method IsBoolean.

Namespace: BI.JSON.SuperObject
Syntax
Delphi
protected
 function IsBoolean:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsBoolean
See Also

Reference

  • TSuperObjectJSON
  • BI.JSON.SuperObject


TSuperObjectJSON.IsNull Method

Summary

Represents method IsNull.

Namespace: BI.JSON.SuperObject
Syntax
Delphi
protected
 function IsNull:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsNull
See Also

Reference

  • TSuperObjectJSON
  • BI.JSON.SuperObject


TSuperObjectJSON.IsNumber Method

Summary

Represents method IsNumber.

Namespace: BI.JSON.SuperObject
Syntax
Delphi
protected
 function IsNumber:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsNumber
See Also

Reference

  • TSuperObjectJSON
  • BI.JSON.SuperObject


TSuperObjectJSON.IsObject Method

Summary

Represents method IsObject.

Namespace: BI.JSON.SuperObject
Syntax
Delphi
protected
 function IsObject:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsObject
See Also

Reference

  • TSuperObjectJSON
  • BI.JSON.SuperObject


TSuperObjectJSON.IsString Method

Summary

Represents method IsString.

Namespace: BI.JSON.SuperObject
Syntax
Delphi
protected
 function IsString:Boolean; override;

Return Value

Type: Boolean

Overrides

TJSONEngine.IsString
See Also

Reference

  • TSuperObjectJSON
  • BI.JSON.SuperObject


TSuperObjectJSON.ObjectChild(Integer) Method

Summary

Represents method ObjectChild(Integer).

Namespace: BI.JSON.SuperObject
Syntax
Delphi
protected
 function ObjectChild(const Index:Integer):String; override;

Parameters

Index
Type: Integer

Return Value

Type: String

Overrides

TJSONEngine.ObjectChild(Integer)
See Also

Reference

  • TSuperObjectJSON
  • BI.JSON.SuperObject


TSuperObjectJSON.Parse(String) Method

Summary

Represents method Parse(String).

Namespace: BI.JSON.SuperObject
Syntax
Delphi
protected
 procedure Parse(const Text:String); override;

Parameters

Text
Type: String

Overrides

TJSONEngine.Parse(String)
See Also

Reference

  • TSuperObjectJSON
  • BI.JSON.SuperObject


TSuperObjectJSON.Pop Method

Summary

Represents method Pop.

Namespace: BI.JSON.SuperObject
Syntax
Delphi
protected
 procedure Pop; override;

Overrides

TJSONEngine.Pop
See Also

Reference

  • TSuperObjectJSON
  • BI.JSON.SuperObject


BI.Languages.English Namespace

Summary

Represents namespace BI.Languages.English.

Variables
Name | Description
BIMsg_About | Represents variable BIMsg_About.
BIMsg_AlgorithmNeedKind | Represents variable BIMsg_AlgorithmNeedKind.
BIMsg_AlgorithmNeedQuantity | Represents variable BIMsg_AlgorithmNeedQuantity.
BIMsg_CannotAccessData | Represents variable BIMsg_CannotAccessData.
BIMsg_ChooseFolder | Represents variable BIMsg_ChooseFolder.
BIMsg_ConnectionTestPassed | Represents variable BIMsg_ConnectionTestPassed.
BIMsg_CSV_FirstRowNoFields | Represents variable BIMsg_CSV_FirstRowNoFields.
BIMsg_DataItem_ChildNotFound | Represents variable BIMsg_DataItem_ChildNotFound.
BIMsg_Dataset_DataNotFound | Represents variable BIMsg_Dataset_DataNotFound.
BIMsg_Dataset_NoData | Represents variable BIMsg_Dataset_NoData.
BIMsg_Dataset_NoDetail | Represents variable BIMsg_Dataset_NoDetail.
BIMsg_Dataset_NotAsTable | Represents variable BIMsg_Dataset_NotAsTable.
BIMsg_DataSourceAlreadyExists | Represents variable BIMsg_DataSourceAlreadyExists.
BIMsg_Data_ChangeName | Represents variable BIMsg_Data_ChangeName.
BIMsg_DB_NoEngineConfigured | Represents variable BIMsg_DB_NoEngineConfigured.
BIMsg_DB_SqlExpressWrongConnection | Represents variable BIMsg_DB_SqlExpressWrongConnection.
BIMsg_Default | Represents variable BIMsg_Default.
BIMsg_DifferentArrayLength | Represents variable BIMsg_DifferentArrayLength.
BIMsg_DuplicatedItem | Represents variable BIMsg_DuplicatedItem.
BIMsg_Edit | Represents variable BIMsg_Edit.
BIMsg_Enabled | Represents variable BIMsg_Enabled.
BIMsg_Export | Represents variable BIMsg_Export.
BIMsg_Export_EmptyData | Represents variable BIMsg_Export_EmptyData.
BIMsg_ExpressionEmpty | Represents variable BIMsg_ExpressionEmpty.
BIMsg_ExpressionError | Represents variable BIMsg_ExpressionError.
BIMsg_ExpressionFunctionMissing | Represents variable BIMsg_ExpressionFunctionMissing.
BIMsg_ExpressionNotLogical | Represents variable BIMsg_ExpressionNotLogical.
BIMsg_Field | Represents variable BIMsg_Field.
BIMsg_FileImporterMissing | Represents variable BIMsg_FileImporterMissing.
BIMsg_Grid_MissingEngine | Represents variable BIMsg_Grid_MissingEngine.
BIMsg_Http_UserCancelled | Represents variable BIMsg_Http_UserCancelled.
BIMsg_ImporterMissing | Represents variable BIMsg_ImporterMissing.
BIMsg_ImportError | Represents variable BIMsg_ImportError.
BIMsg_JSON_WrongClass | Represents variable BIMsg_JSON_WrongClass.
BIMsg_LoadTemplate | Represents variable BIMsg_LoadTemplate.
BIMsg_Name | Represents variable BIMsg_Name.
BIMsg_NativeFiles | Represents variable BIMsg_NativeFiles.
BIMsg_NavigatorItem | Represents variable BIMsg_NavigatorItem.
BIMsg_NavigatorPage | Represents variable BIMsg_NavigatorPage.
BIMsg_NavigatorSingleItem | Represents variable BIMsg_NavigatorSingleItem.
BIMsg_NewDataSource | Represents variable BIMsg_NewDataSource.
BIMsg_NewName | Represents variable BIMsg_NewName.
BIMsg_NotCompatible | Represents variable BIMsg_NotCompatible.
BIMsg_Persist_CorruptIndex | Represents variable BIMsg_Persist_CorruptIndex.
BIMsg_Persist_CorruptLoad | Represents variable BIMsg_Persist_CorruptLoad.
BIMsg_Persist_IncompatibleVersion | Represents variable BIMsg_Persist_IncompatibleVersion.
BIMsg_RelativeOriginNoParent | Represents variable BIMsg_RelativeOriginNoParent.
BIMsg_ServerAlreadyRunning | Represents variable BIMsg_ServerAlreadyRunning.
BIMsg_ServerSureToClose | Represents variable BIMsg_ServerSureToClose.
BIMsg_SortNoData | Represents variable BIMsg_SortNoData.
BIMsg_SortNoItems | Represents variable BIMsg_SortNoItems.
BIMsg_SortWrongParent | Represents variable BIMsg_SortWrongParent.
BIMsg_Store_AlreadyExists | Represents variable BIMsg_Store_AlreadyExists.
BIMsg_Store_ChangeName | Represents variable BIMsg_Store_ChangeName.
BIMsg_Store_DataLoadError | Represents variable BIMsg_Store_DataLoadError.
BIMsg_Store_EmptyName | Represents variable BIMsg_Store_EmptyName.
BIMsg_Store_ErrorOpening | Represents variable BIMsg_Store_ErrorOpening.
BIMsg_Store_MissingImporter | Represents variable BIMsg_Store_MissingImporter.
BIMsg_Store_NotRegistered | Represents variable BIMsg_Store_NotRegistered.
BIMsg_Store_SelectRemote | Represents variable BIMsg_Store_SelectRemote.
BIMsg_Store_SureRemove | Represents variable BIMsg_Store_SureRemove.
BIMsg_Store_SureToDelete | Represents variable BIMsg_Store_SureToDelete.
BIMsg_Store_WrongName | Represents variable BIMsg_Store_WrongName.
BIMsg_Summary_AtLeastOne | Represents variable BIMsg_Summary_AtLeastOne.
BIMsg_Summary_DeleteGroupBy | Represents variable BIMsg_Summary_DeleteGroupBy.
BIMsg_Summary_DeleteMeasure | Represents variable BIMsg_Summary_DeleteMeasure.
BIMsg_Summary_ErrorSortParameter | Represents variable BIMsg_Summary_ErrorSortParameter.
BIMsg_Summary_GroupByNilData | Represents variable BIMsg_Summary_GroupByNilData.
BIMsg_Summary_GroupByNilExpression | Represents variable BIMsg_Summary_GroupByNilExpression.
BIMsg_Summary_MeasureName | Represents variable BIMsg_Summary_MeasureName.
BIMsg_Summary_MeasureNilData | Represents variable BIMsg_Summary_MeasureNilData.
BIMsg_Summary_MeasureNilExpression | Represents variable BIMsg_Summary_MeasureNilExpression.
BIMsg_Summary_NoMainData | Represents variable BIMsg_Summary_NoMainData.
BIMsg_Summary_SwapGroupBy | Represents variable BIMsg_Summary_SwapGroupBy.
BIMsg_Summary_SwapMeasure | Represents variable BIMsg_Summary_SwapMeasure.
BIMsg_Summary_WrongAggregate | Represents variable BIMsg_Summary_WrongAggregate.
BIMsg_UnknownData | Represents variable BIMsg_UnknownData.
BIMsg_UnNamed | Represents variable BIMsg_UnNamed.
BIMsg_Web_ErrorCheckingUpdates | Represents variable BIMsg_Web_ErrorCheckingUpdates.
BIMsg_Web_ErrorEmptyDataStream | Represents variable BIMsg_Web_ErrorEmptyDataStream.
BIMsg_Web_ErrorUnzip | Represents variable BIMsg_Web_ErrorUnzip.
BIMsg_Web_ErrorWrongOrigin | Represents variable BIMsg_Web_ErrorWrongOrigin.
BIMsg_Web_LatestVersionDownloaded | Represents variable BIMsg_Web_LatestVersionDownloaded.
BIMsg_Web_NoDefaultStore | Represents variable BIMsg_Web_NoDefaultStore.
BIMsg_XML_WrongContent | Represents variable BIMsg_XML_WrongContent.
BIMsg_ZIP_FileNotValid | Represents variable BIMsg_ZIP_FileNotValid.
Top
Constants
Name | Description
TeeBI_CopyRight | Represents constant TeeBI_CopyRight.
TeeBI_Description | Represents constant TeeBI_Description.
TeeBI_Version | Represents constant TeeBI_Version.
TeeBI_VersionMode | Represents constant TeeBI_VersionMode.
TeeBI_VersionString | Represents constant TeeBI_VersionString.
Top


BI.Languages.English Variables

Variables
Name | Description
BIMsg_About | Represents variable BIMsg_About.
BIMsg_AlgorithmNeedKind | Represents variable BIMsg_AlgorithmNeedKind.
BIMsg_AlgorithmNeedQuantity | Represents variable BIMsg_AlgorithmNeedQuantity.
BIMsg_CannotAccessData | Represents variable BIMsg_CannotAccessData.
BIMsg_ChooseFolder | Represents variable BIMsg_ChooseFolder.
BIMsg_ConnectionTestPassed | Represents variable BIMsg_ConnectionTestPassed.
BIMsg_CSV_FirstRowNoFields | Represents variable BIMsg_CSV_FirstRowNoFields.
BIMsg_DataItem_ChildNotFound | Represents variable BIMsg_DataItem_ChildNotFound.
BIMsg_Dataset_DataNotFound | Represents variable BIMsg_Dataset_DataNotFound.
BIMsg_Dataset_NoData | Represents variable BIMsg_Dataset_NoData.
BIMsg_Dataset_NoDetail | Represents variable BIMsg_Dataset_NoDetail.
BIMsg_Dataset_NotAsTable | Represents variable BIMsg_Dataset_NotAsTable.
BIMsg_DataSourceAlreadyExists | Represents variable BIMsg_DataSourceAlreadyExists.
BIMsg_Data_ChangeName | Represents variable BIMsg_Data_ChangeName.
BIMsg_DB_NoEngineConfigured | Represents variable BIMsg_DB_NoEngineConfigured.
BIMsg_DB_SqlExpressWrongConnection | Represents variable BIMsg_DB_SqlExpressWrongConnection.
BIMsg_Default | Represents variable BIMsg_Default.
BIMsg_DifferentArrayLength | Represents variable BIMsg_DifferentArrayLength.
BIMsg_DuplicatedItem | Represents variable BIMsg_DuplicatedItem.
BIMsg_Edit | Represents variable BIMsg_Edit.
BIMsg_Enabled | Represents variable BIMsg_Enabled.
BIMsg_Export | Represents variable BIMsg_Export.
BIMsg_Export_EmptyData | Represents variable BIMsg_Export_EmptyData.
BIMsg_ExpressionEmpty | Represents variable BIMsg_ExpressionEmpty.
BIMsg_ExpressionError | Represents variable BIMsg_ExpressionError.
BIMsg_ExpressionFunctionMissing | Represents variable BIMsg_ExpressionFunctionMissing.
BIMsg_ExpressionNotLogical | Represents variable BIMsg_ExpressionNotLogical.
BIMsg_Field | Represents variable BIMsg_Field.
BIMsg_FileImporterMissing | Represents variable BIMsg_FileImporterMissing.
BIMsg_Grid_MissingEngine | Represents variable BIMsg_Grid_MissingEngine.
BIMsg_Http_UserCancelled | Represents variable BIMsg_Http_UserCancelled.
BIMsg_ImporterMissing | Represents variable BIMsg_ImporterMissing.
BIMsg_ImportError | Represents variable BIMsg_ImportError.
BIMsg_JSON_WrongClass | Represents variable BIMsg_JSON_WrongClass.
BIMsg_LoadTemplate | Represents variable BIMsg_LoadTemplate.
BIMsg_Name | Represents variable BIMsg_Name.
BIMsg_NativeFiles | Represents variable BIMsg_NativeFiles.
BIMsg_NavigatorItem | Represents variable BIMsg_NavigatorItem.
BIMsg_NavigatorPage | Represents variable BIMsg_NavigatorPage.
BIMsg_NavigatorSingleItem | Represents variable BIMsg_NavigatorSingleItem.
BIMsg_NewDataSource | Represents variable BIMsg_NewDataSource.
BIMsg_NewName | Represents variable BIMsg_NewName.
BIMsg_NotCompatible | Represents variable BIMsg_NotCompatible.
BIMsg_Persist_CorruptIndex | Represents variable BIMsg_Persist_CorruptIndex.
BIMsg_Persist_CorruptLoad | Represents variable BIMsg_Persist_CorruptLoad.
BIMsg_Persist_IncompatibleVersion | Represents variable BIMsg_Persist_IncompatibleVersion.
BIMsg_RelativeOriginNoParent | Represents variable BIMsg_RelativeOriginNoParent.
BIMsg_ServerAlreadyRunning | Represents variable BIMsg_ServerAlreadyRunning.
BIMsg_ServerSureToClose | Represents variable BIMsg_ServerSureToClose.
BIMsg_SortNoData | Represents variable BIMsg_SortNoData.
BIMsg_SortNoItems | Represents variable BIMsg_SortNoItems.
BIMsg_SortWrongParent | Represents variable BIMsg_SortWrongParent.
BIMsg_Store_AlreadyExists | Represents variable BIMsg_Store_AlreadyExists.
BIMsg_Store_ChangeName | Represents variable BIMsg_Store_ChangeName.
BIMsg_Store_DataLoadError | Represents variable BIMsg_Store_DataLoadError.
BIMsg_Store_EmptyName | Represents variable BIMsg_Store_EmptyName.
BIMsg_Store_ErrorOpening | Represents variable BIMsg_Store_ErrorOpening.
BIMsg_Store_MissingImporter | Represents variable BIMsg_Store_MissingImporter.
BIMsg_Store_NotRegistered | Represents variable BIMsg_Store_NotRegistered.
BIMsg_Store_SelectRemote | Represents variable BIMsg_Store_SelectRemote.
BIMsg_Store_SureRemove | Represents variable BIMsg_Store_SureRemove.
BIMsg_Store_SureToDelete | Represents variable BIMsg_Store_SureToDelete.
BIMsg_Store_WrongName | Represents variable BIMsg_Store_WrongName.
BIMsg_Summary_AtLeastOne | Represents variable BIMsg_Summary_AtLeastOne.
BIMsg_Summary_DeleteGroupBy | Represents variable BIMsg_Summary_DeleteGroupBy.
BIMsg_Summary_DeleteMeasure | Represents variable BIMsg_Summary_DeleteMeasure.
BIMsg_Summary_ErrorSortParameter | Represents variable BIMsg_Summary_ErrorSortParameter.
BIMsg_Summary_GroupByNilData | Represents variable BIMsg_Summary_GroupByNilData.
BIMsg_Summary_GroupByNilExpression | Represents variable BIMsg_Summary_GroupByNilExpression.
BIMsg_Summary_MeasureName | Represents variable BIMsg_Summary_MeasureName.
BIMsg_Summary_MeasureNilData | Represents variable BIMsg_Summary_MeasureNilData.
BIMsg_Summary_MeasureNilExpression | Represents variable BIMsg_Summary_MeasureNilExpression.
BIMsg_Summary_NoMainData | Represents variable BIMsg_Summary_NoMainData.
BIMsg_Summary_SwapGroupBy | Represents variable BIMsg_Summary_SwapGroupBy.
BIMsg_Summary_SwapMeasure | Represents variable BIMsg_Summary_SwapMeasure.
BIMsg_Summary_WrongAggregate | Represents variable BIMsg_Summary_WrongAggregate.
BIMsg_UnknownData | Represents variable BIMsg_UnknownData.
BIMsg_UnNamed | Represents variable BIMsg_UnNamed.
BIMsg_Web_ErrorCheckingUpdates | Represents variable BIMsg_Web_ErrorCheckingUpdates.
BIMsg_Web_ErrorEmptyDataStream | Represents variable BIMsg_Web_ErrorEmptyDataStream.
BIMsg_Web_ErrorUnzip | Represents variable BIMsg_Web_ErrorUnzip.
BIMsg_Web_ErrorWrongOrigin | Represents variable BIMsg_Web_ErrorWrongOrigin.
BIMsg_Web_LatestVersionDownloaded | Represents variable BIMsg_Web_LatestVersionDownloaded.
BIMsg_Web_NoDefaultStore | Represents variable BIMsg_Web_NoDefaultStore.
BIMsg_XML_WrongContent | Represents variable BIMsg_XML_WrongContent.
BIMsg_ZIP_FileNotValid | Represents variable BIMsg_ZIP_FileNotValid.
Top


BIMsg_About Variable

Summary

Represents variable BIMsg_About.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_About:String = 'About TeeBI...';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_AlgorithmNeedKind Variable

Summary

Represents variable BIMsg_AlgorithmNeedKind.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_AlgorithmNeedKind:String = 'Input Data Kind not valid: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_AlgorithmNeedQuantity Variable

Summary

Represents variable BIMsg_AlgorithmNeedQuantity.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_AlgorithmNeedQuantity:String = 'Input Data quantity not valid. Expected: %d, Actual: %d';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_CannotAccessData Variable

Summary

Represents variable BIMsg_CannotAccessData.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_CannotAccessData:String = 'Cannot access data: %s from: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_ChooseFolder Variable

Summary

Represents variable BIMsg_ChooseFolder.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_ChooseFolder:String = 'Choose a folder';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_ConnectionTestPassed Variable

Summary

Represents variable BIMsg_ConnectionTestPassed.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_ConnectionTestPassed:String = 'Connection test passed';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_CSV_FirstRowNoFields Variable

Summary

Represents variable BIMsg_CSV_FirstRowNoFields.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_CSV_FirstRowNoFields:String = 'First row contains no fields';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_DataItem_ChildNotFound Variable

Summary

Represents variable BIMsg_DataItem_ChildNotFound.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_DataItem_ChildNotFound:String = 'Error: Child data: %s not found';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Dataset_DataNotFound Variable

Summary

Represents variable BIMsg_Dataset_DataNotFound.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Dataset_DataNotFound:String = 'Internal Error: Data not found: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Dataset_NoData Variable

Summary

Represents variable BIMsg_Dataset_NoData.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Dataset_NoData:String = 'Cannot open BIDataSet. No Data assigned';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Dataset_NoDetail Variable

Summary

Represents variable BIMsg_Dataset_NoDetail.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Dataset_NoDetail:String = 'Error: Cannot link BIDataset to master dataset, no detail data';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Dataset_NotAsTable Variable

Summary

Represents variable BIMsg_Dataset_NotAsTable.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Dataset_NotAsTable:String = 'Internal Error: Data is not AsTable searching for: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_DataSourceAlreadyExists Variable

Summary

Represents variable BIMsg_DataSourceAlreadyExists.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_DataSourceAlreadyExists:String = 'Data: %s already exists. Choose a different name';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Data_ChangeName Variable

Summary

Represents variable BIMsg_Data_ChangeName.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Data_ChangeName:String = 'Change Data Name';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_DB_NoEngineConfigured Variable

Summary

Represents variable BIMsg_DB_NoEngineConfigured.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_DB_NoEngineConfigured:String = 'Error: No Database Engine configured. Use BI.DB.xx (Fire,SQLExpr,microOLAP,UniDAC,etc) units';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_DB_SqlExpressWrongConnection Variable

Summary

Represents variable BIMsg_DB_SqlExpressWrongConnection.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_DB_SqlExpressWrongConnection:String= 'Error: Connection is not TSQLConnection (SqlExpress engine)';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Default Variable

Summary

Represents variable BIMsg_Default.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Default:String = '(default)';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_DifferentArrayLength Variable

Summary

Represents variable BIMsg_DifferentArrayLength.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_DifferentArrayLength:String = 'Arrays are of different length';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_DuplicatedItem Variable

Summary

Represents variable BIMsg_DuplicatedItem.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_DuplicatedItem:String = 'Error: A duplicated data named: %s already exists';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Edit Variable

Summary

Represents variable BIMsg_Edit.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Edit:String = 'Edit...';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Enabled Variable

Summary

Represents variable BIMsg_Enabled.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Enabled:String = 'Enabled';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Export Variable

Summary

Represents variable BIMsg_Export.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Export:String = 'Export';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Export_EmptyData Variable

Summary

Represents variable BIMsg_Export_EmptyData.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Export_EmptyData:String = 'Error: Cannot export empty data';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_ExpressionEmpty Variable

Summary

Represents variable BIMsg_ExpressionEmpty.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_ExpressionEmpty:String = 'Error: Empty expression: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_ExpressionError Variable

Summary

Represents variable BIMsg_ExpressionError.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_ExpressionError:String = 'Error: %s at position: %d';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_ExpressionFunctionMissing Variable

Summary

Represents variable BIMsg_ExpressionFunctionMissing.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_ExpressionFunctionMissing:String = 'Cannot find function: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_ExpressionNotLogical Variable

Summary

Represents variable BIMsg_ExpressionNotLogical.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_ExpressionNotLogical:String = 'Expression: %s is not boolean (logical)';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Field Variable

Summary

Represents variable BIMsg_Field.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Field:String = 'Field';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_FileImporterMissing Variable

Summary

Represents variable BIMsg_FileImporterMissing.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_FileImporterMissing:String = 'Cannot find importer class for data file: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Grid_MissingEngine Variable

Summary

Represents variable BIMsg_Grid_MissingEngine.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Grid_MissingEngine:String = 'Error: Missing BIGrid Engine plugin';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Http_UserCancelled Variable

Summary

Represents variable BIMsg_Http_UserCancelled.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Http_UserCancelled:String = 'Http request user cancelled';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_ImporterMissing Variable

Summary

Represents variable BIMsg_ImporterMissing.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_ImporterMissing:String = 'Cannot find importer class for data path: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_ImportError Variable

Summary

Represents variable BIMsg_ImportError.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_ImportError:String = 'Cannot import data: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_JSON_WrongClass Variable

Summary

Represents variable BIMsg_JSON_WrongClass.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_JSON_WrongClass:String = 'Wrong JSON class: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_LoadTemplate Variable

Summary

Represents variable BIMsg_LoadTemplate.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_LoadTemplate:String = 'Load Dashboard Template';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Name Variable

Summary

Represents variable BIMsg_Name.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Name:String = 'Name';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_NativeFiles Variable

Summary

Represents variable BIMsg_NativeFiles.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_NativeFiles:String = 'TeeBI native';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_NavigatorItem Variable

Summary

Represents variable BIMsg_NavigatorItem.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_NavigatorItem:String = '%d-%d of %d';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_NavigatorPage Variable

Summary

Represents variable BIMsg_NavigatorPage.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_NavigatorPage:String = 'Page %d of %d';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_NavigatorSingleItem Variable

Summary

Represents variable BIMsg_NavigatorSingleItem.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_NavigatorSingleItem:String = '%d of %d';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_NewDataSource Variable

Summary

Represents variable BIMsg_NewDataSource.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_NewDataSource:String = 'New Data Source';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_NewName Variable

Summary

Represents variable BIMsg_NewName.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_NewName:String = 'New name:';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_NotCompatible Variable

Summary

Represents variable BIMsg_NotCompatible.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_NotCompatible:String = 'Error: Incompatible structures: %s %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Persist_CorruptIndex Variable

Summary

Represents variable BIMsg_Persist_CorruptIndex.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Persist_CorruptIndex:String = 'Error: Corrupt data index count: %s %d';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Persist_CorruptLoad Variable

Summary

Represents variable BIMsg_Persist_CorruptLoad.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Persist_CorruptLoad:String = 'Error: Corrupt data kind: %s (%s)';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Persist_IncompatibleVersion Variable

Summary

Represents variable BIMsg_Persist_IncompatibleVersion.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Persist_IncompatibleVersion:String = 'Data cannot be loaded. It was created with an old non-compatible version: %d';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_RelativeOriginNoParent Variable

Summary

Represents variable BIMsg_RelativeOriginNoParent.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_RelativeOriginNoParent:String = 'Error: Cannot find relative ".." origin, data: %s has no parent';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_ServerAlreadyRunning Variable

Summary

Represents variable BIMsg_ServerAlreadyRunning.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_ServerAlreadyRunning:String = 'BIWeb Server is already running.';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_ServerSureToClose Variable

Summary

Represents variable BIMsg_ServerSureToClose.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_ServerSureToClose:String = 'Are you sure to close this server? (There are %d active conections)';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_SortNoData Variable

Summary

Represents variable BIMsg_SortNoData.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_SortNoData:String = 'Sort error: No Data specified';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_SortNoItems Variable

Summary

Represents variable BIMsg_SortNoItems.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_SortNoItems:String = 'Sort error: At least a defined Item is necessary';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_SortWrongParent Variable

Summary

Represents variable BIMsg_SortWrongParent.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_SortWrongParent:String = 'Sort error: Parent of data: %s is not data: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Store_AlreadyExists Variable

Summary

Represents variable BIMsg_Store_AlreadyExists.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Store_AlreadyExists:String = 'Error: Store already exists: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Store_ChangeName Variable

Summary

Represents variable BIMsg_Store_ChangeName.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Store_ChangeName:String = 'Change Store Name';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Store_DataLoadError Variable

Summary

Represents variable BIMsg_Store_DataLoadError.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Store_DataLoadError:String = 'Error: Loading data: %s from store: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Store_EmptyName Variable

Summary

Represents variable BIMsg_Store_EmptyName.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Store_EmptyName:String = 'Error: Store name cannot be empty';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Store_ErrorOpening Variable

Summary

Represents variable BIMsg_Store_ErrorOpening.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Store_ErrorOpening:String = 'Error: %s opening store: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Store_MissingImporter Variable

Summary

Represents variable BIMsg_Store_MissingImporter.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Store_MissingImporter:String = 'Error: Cannot find data importer class for store: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Store_NotRegistered Variable

Summary

Represents variable BIMsg_Store_NotRegistered.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Store_NotRegistered:String = 'Error: Store %s is not configured in this machine registry';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Store_SelectRemote Variable

Summary

Represents variable BIMsg_Store_SelectRemote.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Store_SelectRemote:String = 'Select Remote Store';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Store_SureRemove Variable

Summary

Represents variable BIMsg_Store_SureRemove.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Store_SureRemove:String = 'Are you sure to remove store: %s from registry?';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Store_SureToDelete Variable

Summary

Represents variable BIMsg_Store_SureToDelete.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Store_SureToDelete:String = 'Are you sure to delete data: %s?';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Store_WrongName Variable

Summary

Represents variable BIMsg_Store_WrongName.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Store_WrongName:String = 'Error: Store name cannot contain ":" character: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Summary_AtLeastOne Variable

Summary

Represents variable BIMsg_Summary_AtLeastOne.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Summary_AtLeastOne:String = 'Summary: At least one active Measure or Groupby should be selected.';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Summary_DeleteGroupBy Variable

Summary

Represents variable BIMsg_Summary_DeleteGroupBy.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Summary_DeleteGroupBy:String = 'Error: Delete groupby index out of bounds: %d';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Summary_DeleteMeasure Variable

Summary

Represents variable BIMsg_Summary_DeleteMeasure.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Summary_DeleteMeasure:String = 'Error: Delete measure index out of bounds: %d';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Summary_ErrorSortParameter Variable

Summary

Represents variable BIMsg_Summary_ErrorSortParameter.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Summary_ErrorSortParameter:String = 'Error in sort parameter: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Summary_GroupByNilData Variable

Summary

Represents variable BIMsg_Summary_GroupByNilData.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Summary_GroupByNilData:String = 'Summary missing Data adding groupby';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Summary_GroupByNilExpression Variable

Summary

Represents variable BIMsg_Summary_GroupByNilExpression.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Summary_GroupByNilExpression:String= 'Summary missing expression adding groupby';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Summary_MeasureName Variable

Summary

Represents variable BIMsg_Summary_MeasureName.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Summary_MeasureName:String = '%s of %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Summary_MeasureNilData Variable

Summary

Represents variable BIMsg_Summary_MeasureNilData.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Summary_MeasureNilData:String = 'Summary missing Data adding measure';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Summary_MeasureNilExpression Variable

Summary

Represents variable BIMsg_Summary_MeasureNilExpression.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Summary_MeasureNilExpression:String= 'Summary missing Expression adding measure';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Summary_NoMainData Variable

Summary

Represents variable BIMsg_Summary_NoMainData.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Summary_NoMainData:String = 'Summary: No main data item.';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Summary_SwapGroupBy Variable

Summary

Represents variable BIMsg_Summary_SwapGroupBy.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Summary_SwapGroupBy:String = 'Error: Swap groupby index out of bounds: %d';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Summary_SwapMeasure Variable

Summary

Represents variable BIMsg_Summary_SwapMeasure.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Summary_SwapMeasure:String = 'Error: Swap measure index out of bounds: %d';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Summary_WrongAggregate Variable

Summary

Represents variable BIMsg_Summary_WrongAggregate.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Summary_WrongAggregate:String = 'Error: Wrong measure aggregate: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_UnknownData Variable

Summary

Represents variable BIMsg_UnknownData.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_UnknownData:String = 'Error Unknown Data: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_UnNamed Variable

Summary

Represents variable BIMsg_UnNamed.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_UnNamed:String = '(unnamed)';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Web_ErrorCheckingUpdates Variable

Summary

Represents variable BIMsg_Web_ErrorCheckingUpdates.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Web_ErrorCheckingUpdates:String = 'Cannot check for updates, error checking latest version: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Web_ErrorEmptyDataStream Variable

Summary

Represents variable BIMsg_Web_ErrorEmptyDataStream.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Web_ErrorEmptyDataStream:String = 'Error: Web data stream is empty';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Web_ErrorUnzip Variable

Summary

Represents variable BIMsg_Web_ErrorUnzip.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Web_ErrorUnzip:String = 'Error: Empty data uncompressing BIWeb stream.';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Web_ErrorWrongOrigin Variable

Summary

Represents variable BIMsg_Web_ErrorWrongOrigin.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Web_ErrorWrongOrigin:String = 'Error: Wrong web origin: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Web_LatestVersionDownloaded Variable

Summary

Represents variable BIMsg_Web_LatestVersionDownloaded.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Web_LatestVersionDownloaded:String = 'Latest version downloaded. Please re-start';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_Web_NoDefaultStore Variable

Summary

Represents variable BIMsg_Web_NoDefaultStore.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_Web_NoDefaultStore:String = 'BIWeb server cannot continue without a default Store';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_XML_WrongContent Variable

Summary

Represents variable BIMsg_XML_WrongContent.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_XML_WrongContent:String = 'Wrong XML content';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BIMsg_ZIP_FileNotValid Variable

Summary

Represents variable BIMsg_ZIP_FileNotValid.

Namespace: BI.Languages.English
Syntax
Delphi
BIMsg_ZIP_FileNotValid:String = 'Zip file format not valid: %s';

Value

Type: String

See Also

Reference

  • BI.Languages.English


BI.Languages.English Constants

Constants
Name | Description
TeeBI_CopyRight | Represents constant TeeBI_CopyRight.
TeeBI_Description | Represents constant TeeBI_Description.
TeeBI_Version | Represents constant TeeBI_Version.
TeeBI_VersionMode | Represents constant TeeBI_VersionMode.
TeeBI_VersionString | Represents constant TeeBI_VersionString.
Top


TeeBI_CopyRight Constant

Summary

Represents constant TeeBI_CopyRight.

Namespace: BI.Languages.English
Syntax
Delphi
 TeeBI_CopyRight='Copyright '+'©'+' 2015-2017 by Steema Software';

Value

Type: string

See Also

Reference

  • BI.Languages.English


TeeBI_Description Constant

Summary

Represents constant TeeBI_Description.

Namespace: BI.Languages.English
Syntax
Delphi
 TeeBI_Description='TeeBI';

Value

Type: string

See Also

Reference

  • BI.Languages.English


TeeBI_Version Constant

Summary

Represents constant TeeBI_Version.

Namespace: BI.Languages.English
Syntax
Delphi
 TeeBI_Version=20170927;

Value

Type: Integer

See Also

Reference

  • BI.Languages.English


TeeBI_VersionMode Constant

Summary

Represents constant TeeBI_VersionMode.

Namespace: BI.Languages.English
Syntax
Delphi
 TeeBI_VersionMode='';

Value

Type: string

See Also

Reference

  • BI.Languages.English


TeeBI_VersionString Constant

Summary

Represents constant TeeBI_VersionString.

Namespace: BI.Languages.English
Syntax
Delphi
 TeeBI_VersionString='v1 20170927';

Value

Type: string

See Also

Reference

  • BI.Languages.English


BI.Languages.Spanish Namespace

Summary

Represents namespace BI.Languages.Spanish.

Routines
Name | Description
BISpanish | Represents method BISpanish.
Top


BI.Languages.Spanish Routines

Routines
Name | Description
BISpanish | Represents method BISpanish.
Top


BISpanish Method

Summary

Represents method BISpanish.

Namespace: BI.Languages.Spanish
Syntax
Delphi
procedure BISpanish;
See Also

Reference

  • BI.Languages.Spanish


BI.MapReduce Namespace

Summary

Represents namespace BI.MapReduce.

Classes
Name | Description
TMapReduce | Represents type TMapReduce.
TMapReduce<T> | Represents type TMapReduce<T>.
Top
Types
Name | Description
TIndices | Represents an alias of the TInt64Array type.
TKeyIndex | Represents an alias of the TInteger type.
Top


BI.MapReduce Classes

Classes
Name | Description
TMapReduce | Represents type TMapReduce.
TMapReduce<T> | Represents type TMapReduce<T>.
Top


TMapReduce Class

Summary

Represents type TMapReduce.

Namespace: BI.MapReduce
Inheritance Hierarchy
TObject
BI.MapReduce.TMapReduce
Syntax
Delphi
type
 TMapReduce=class
 end;

The TMapReduce type exposes the following members.

Methods
Show:
Name | Description
Aggregate(TDataItem,String,TAggregate) | Overloaded. Represents method Aggregate(TDataItem,String,TAggregate).
Aggregate(TDataItem,TDataItem,TAggregate) | Overloaded. Represents method Aggregate(TDataItem,TDataItem,TAggregate).
Count(TDataItem) | Represents method Count(TDataItem).
Mean(TDataItem,TIndices) | Represents method Mean(TDataItem,TIndices).
Top
Fields
Show:
Name | Description
Parallel | Represents field Parallel.
Top
See Also

Reference

  • BI.MapReduce


TMapReduce Methods

Methods
Name | Description
Aggregate(TDataItem,String,TAggregate) | Overloaded. Represents method Aggregate(TDataItem,String,TAggregate).
Aggregate(TDataItem,TDataItem,TAggregate) | Overloaded. Represents method Aggregate(TDataItem,TDataItem,TAggregate).
Count(TDataItem) | Represents method Count(TDataItem).
Mean(TDataItem,TIndices) | Represents method Mean(TDataItem,TIndices).
Top


TMapReduce.Aggregate(TDataItem,String,TAggregate) Method

Summary

Represents method Aggregate(TDataItem,String,TAggregate).

Namespace: BI.MapReduce
Syntax
Delphi
public
 class function Aggregate(const AKey:TDataItem;
 const AExpression:String;
 const AAggregate:TAggregate):TDataItem; overload; static;

Parameters

AKey
Type: TDataItem

AExpression
Type: String

AAggregate
Type: TAggregate

Return Value

Type: TDataItem

See Also

Reference

  • TMapReduce
  • BI.MapReduce


TMapReduce.Aggregate(TDataItem,TDataItem,TAggregate) Method

Summary

Represents method Aggregate(TDataItem,TDataItem,TAggregate).

Namespace: BI.MapReduce
Syntax
Delphi
public
 class function Aggregate(const AKey,AValue:TDataItem;
 const AAggregate:TAggregate):TDataItem; overload; static;

Parameters

AKey
Type: TDataItem

AValue
Type: TDataItem

AAggregate
Type: TAggregate

Return Value

Type: TDataItem

See Also

Reference

  • TMapReduce
  • BI.MapReduce


TMapReduce.Count(TDataItem) Method

Summary

Represents method Count(TDataItem).

Namespace: BI.MapReduce
Syntax
Delphi
public
 class function Count(const AKey:TDataItem):TDataItem; static;

Parameters

AKey
Type: TDataItem

Return Value

Type: TDataItem

See Also

Reference

  • TMapReduce
  • BI.MapReduce


TMapReduce.Mean(TDataItem,TIndices) Method

Summary

Represents method Mean(TDataItem,TIndices).

Namespace: BI.MapReduce
Syntax
Delphi
public
 class function Mean(const AData:TDataItem; const AIndices:TIndices):Double; static;

Parameters

AData
Type: TDataItem

AIndices
Type: System.Void

Return Value

Type: Double

See Also

Reference

  • TMapReduce
  • BI.MapReduce


TMapReduce Fields

Fields
Name | Description
Parallel | Represents field Parallel.
Top


TMapReduce.Parallel Field

Summary

Represents field Parallel.

Namespace: BI.MapReduce
Syntax
Delphi
public
 class var
 Parallel : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TMapReduce
  • BI.MapReduce


TMapReduce<T> Class

Summary

Represents type TMapReduce<T>.

Namespace: BI.MapReduce
Inheritance Hierarchy
TObject
BI.MapReduce.TMapReduce<T>
Syntax
Delphi
type
 TMapReduce<T

Type Parameters

T
See Also

Reference

  • BI.MapReduce


BI.MapReduce Types

Types
Name | Description
TIndices | Represents an alias of the TInt64Array type.
TKeyIndex | Represents an alias of the TInteger type.
Top


TIndices Type

Summary

Represents an alias of the TInt64Array type.

Namespace: BI.MapReduce
Syntax
Delphi
type
 TIndices=TInt64Array;
See Also

Reference

  • BI.MapReduce


TKeyIndex Type

Summary

Represents an alias of the TInteger type.

Namespace: BI.MapReduce
Syntax
Delphi
type
 TKeyIndex=TInteger;
See Also

Reference

  • BI.MapReduce


BI.Merge Namespace

Summary

Represents namespace BI.Merge.

Classes
Name | Description
TDataItemAccess | Represents type TDataItemAccess.
Top
Records
Name | Description
TDataMerge | Represents type TDataMerge.
Top


BI.Merge Classes

Classes
Name | Description
TDataItemAccess | Represents type TDataItemAccess.
Top


TDataItemAccess Class

Summary

Represents type TDataItemAccess.

Namespace: BI.Merge
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Merge.TDataItemAccess
Syntax
Delphi
type
 TDataItemAccess=class(TDataItem);
See Also

Reference

  • BI.Merge


BI.Merge Records

Records
Name | Description
TDataMerge | Represents type TDataMerge.
Top


TDataMerge Record

Summary

Represents type TDataMerge.

Namespace: BI.Merge
Syntax
Delphi
type
 TDataMerge=record
 end;

The TDataMerge type exposes the following members.

Methods
Show:
Name | Description
CloneStructure(TDataItem) | Represents method CloneStructure(TDataItem).
Common(TDataItem,TDataArray,TDataArray) | Represents method Common(TDataItem,TDataArray,TDataArray).
Different(TDataItem,TDataArray,TDataArray) | Represents method Different(TDataItem,TDataArray,TDataArray).
FromData(TDataArray,Boolean) | Overloaded. Represents method FromData(TDataArray,Boolean).
FromData(TDataItem,TDataArray) | Overloaded. Represents method FromData(TDataItem,TDataArray).
FromFolder(String,String) | Represents method FromFolder(String,String).
FromStore(String,String) | Represents method FromStore(String,String).
SameStructure(TDataArray) | Overloaded. Represents method SameStructure(TDataArray).
SameStructure(TDataItem,TDataItem) | Overloaded. Represents method SameStructure(TDataItem,TDataItem).
Subtract(TDataItem,TDataItem) | Represents method Subtract(TDataItem,TDataItem).
Top
See Also

Reference

  • BI.Merge


TDataMerge Methods

Methods
Name | Description
CloneStructure(TDataItem) | Represents method CloneStructure(TDataItem).
Common(TDataItem,TDataArray,TDataArray) | Represents method Common(TDataItem,TDataArray,TDataArray).
Different(TDataItem,TDataArray,TDataArray) | Represents method Different(TDataItem,TDataArray,TDataArray).
FromData(TDataArray,Boolean) | Overloaded. Represents method FromData(TDataArray,Boolean).
FromData(TDataItem,TDataArray) | Overloaded. Represents method FromData(TDataItem,TDataArray).
FromFolder(String,String) | Represents method FromFolder(String,String).
FromStore(String,String) | Represents method FromStore(String,String).
SameStructure(TDataArray) | Overloaded. Represents method SameStructure(TDataArray).
SameStructure(TDataItem,TDataItem) | Overloaded. Represents method SameStructure(TDataItem,TDataItem).
Subtract(TDataItem,TDataItem) | Represents method Subtract(TDataItem,TDataItem).
Top


TDataMerge.CloneStructure(TDataItem) Method

Summary

Represents method CloneStructure(TDataItem).

Namespace: BI.Merge
Syntax
Delphi
public
 class function CloneStructure(const AData:TDataItem):TDataItem; static;

Parameters

AData
Type: TDataItem

Return Value

Type: TDataItem

See Also

Reference

  • TDataMerge
  • BI.Merge


TDataMerge.Common(TDataItem,TDataArray,TDataArray) Method

Summary

Represents method Common(TDataItem,TDataArray,TDataArray).

Namespace: BI.Merge
Syntax
Delphi
public
 class procedure Common(const ADest:TDataItem; const A,B:TDataArray); static;

Parameters

ADest
Type: TDataItem

A
Type: TDataArray

B
Type: TDataArray

See Also

Reference

  • TDataMerge
  • BI.Merge


TDataMerge.Different(TDataItem,TDataArray,TDataArray) Method

Summary

Represents method Different(TDataItem,TDataArray,TDataArray).

Namespace: BI.Merge
Syntax
Delphi
public
 class procedure Different(const ADest:TDataItem; const A,B:TDataArray); static;

Parameters

ADest
Type: TDataItem

A
Type: TDataArray

B
Type: TDataArray

See Also

Reference

  • TDataMerge
  • BI.Merge


TDataMerge.FromData(TDataArray,Boolean) Method

Summary

Represents method FromData(TDataArray,Boolean).

Namespace: BI.Merge
Syntax
Delphi
public
 class function FromData(const AData:TDataArray; const FreeData:Boolean=True):TDataItem; overload; static;

Parameters

AData
Type: TDataArray

FreeData
Type: Boolean

Return Value

Type: TDataItem

See Also

Reference

  • TDataMerge
  • BI.Merge


TDataMerge.FromData(TDataItem,TDataArray) Method

Summary

Represents method FromData(TDataItem,TDataArray).

Namespace: BI.Merge
Syntax
Delphi
public
 class procedure FromData(const ADest:TDataItem; const AData:TDataArray); overload; static;

Parameters

ADest
Type: TDataItem

AData
Type: TDataArray

See Also

Reference

  • TDataMerge
  • BI.Merge


TDataMerge.FromFolder(String,String) Method

Summary

Represents method FromFolder(String,String).

Namespace: BI.Merge
Syntax
Delphi
public
 class function FromFolder(const AFolder,AExtension:String):TDataItem; static;

Parameters

AFolder
Type: String

AExtension
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TDataMerge
  • BI.Merge


TDataMerge.FromStore(String,String) Method

Summary

Represents method FromStore(String,String).

Namespace: BI.Merge
Syntax
Delphi
public
 class function FromStore(const AStore,AName:String):TDataItem; static;

Parameters

AStore
Type: String

AName
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TDataMerge
  • BI.Merge


TDataMerge.SameStructure(TDataArray) Method

Summary

Represents method SameStructure(TDataArray).

Namespace: BI.Merge
Syntax
Delphi
public
 class function SameStructure(const AItems:TDataArray):Boolean; overload; static;

Parameters

AItems
Type: TDataArray

Return Value

Type: Boolean

See Also

Reference

  • TDataMerge
  • BI.Merge


TDataMerge.SameStructure(TDataItem,TDataItem) Method

Summary

Represents method SameStructure(TDataItem,TDataItem).

Namespace: BI.Merge
Syntax
Delphi
public
 class function SameStructure(const A,B:TDataItem):Boolean; overload; static;

Parameters

A
Type: TDataItem

B
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • TDataMerge
  • BI.Merge


TDataMerge.Subtract(TDataItem,TDataItem) Method

Summary

Represents method Subtract(TDataItem,TDataItem).

Namespace: BI.Merge
Syntax
Delphi
public
 class procedure Subtract(const ADest,ASource:TDataItem); static;

Parameters

ADest
Type: TDataItem

ASource
Type: TDataItem

See Also

Reference

  • TDataMerge
  • BI.Merge


BI.Persist Namespace

Summary

Represents namespace BI.Persist.

Classes
Name | Description
EBILoadVersionException | Represents type EBILoadVersionException.
TBaseDataImporter | Represents type TBaseDataImporter.
TBIRegistry | Represents type TBIRegistry.
TDataAccess | Represents type TDataAccess.
TDataAccessTimes | Represents type TDataAccessTimes.
TDatabaseDefinition | Represents type TDatabaseDefinition.
TDataDefinition | Represents type TDataDefinition.
TDataDelayProvider | Represents type TDataDelayProvider.
TDataImporter | Represents type TDataImporter.
TDataItemAccess | Represents type TDataItemAccess.
TDataItemPersistence | Represents type TDataItemPersistence.
TDataItemsAccess | Represents type TDataItemsAccess.
TDataMapAccess | Represents type TDataMapAccess.
TDataPersistence | Represents type TDataPersistence.
TDataRelation | Represents type TDataRelation.
TDataRelations | Represents type TDataRelations.
TDelayHandlerFolder | Represents type TDelayHandlerFolder.
TDelayHandlerStream | Represents type TDelayHandlerStream.
TEnvironment | Represents type TEnvironment.
TPersistence | Represents type TPersistence.
TStore | Represents type TStore.
TStores | Represents type TStores.
Top
Records
Name | Description
TIdentifiers | Represents type TIdentifiers.
TRefreshSettings | Represents type TRefreshSettings.
Top
Enumerations
Name | Description
TDataDefinitionKind | Represents type TDataDefinitionKind.
TRefreshUnit | Represents type TRefreshUnit.
Top
Delegates
Name | Description
TBIError | Represents type TBIError.
TBIProgress | Represents type TBIProgress.
Top
Types
Name | Description
TBIErrorProc | Represents type TBIErrorProc.
TDataImporterClass | Represents type TDataImporterClass.
Top
Constants
Name | Description
Default_Key | Represents constant Default_Key.
Steema_Ini | Represents constant Steema_Ini.
Steema_Key | Represents constant Steema_Key.
Top
Routines
Name | Description
CheckMap(TDataItem) | Represents method CheckMap(TDataItem).
VersionError(Integer) | Represents method VersionError(Integer).
Top


BI.Persist Classes

Classes
Name | Description
EBILoadVersionException | Represents type EBILoadVersionException.
TBaseDataImporter | Represents type TBaseDataImporter.
TBIRegistry | Represents type TBIRegistry.
TDataAccess | Represents type TDataAccess.
TDataAccessTimes | Represents type TDataAccessTimes.
TDatabaseDefinition | Represents type TDatabaseDefinition.
TDataDefinition | Represents type TDataDefinition.
TDataDelayProvider | Represents type TDataDelayProvider.
TDataImporter | Represents type TDataImporter.
TDataItemAccess | Represents type TDataItemAccess.
TDataItemPersistence | Represents type TDataItemPersistence.
TDataItemsAccess | Represents type TDataItemsAccess.
TDataMapAccess | Represents type TDataMapAccess.
TDataPersistence | Represents type TDataPersistence.
TDataRelation | Represents type TDataRelation.
TDataRelations | Represents type TDataRelations.
TDelayHandlerFolder | Represents type TDelayHandlerFolder.
TDelayHandlerStream | Represents type TDelayHandlerStream.
TEnvironment | Represents type TEnvironment.
TPersistence | Represents type TPersistence.
TStore | Represents type TStore.
TStores | Represents type TStores.
Top


EBILoadVersionException Class

Summary

Represents type EBILoadVersionException.

Namespace: BI.Persist
Inheritance Hierarchy
Exception
BI.Persist.EBILoadVersionException
Syntax
Delphi
type
 EBILoadVersionException=class(Exception)
 end;

The EBILoadVersionException type exposes the following members.

Constructors
Show:
Name | Description
CreateVersion(Integer) | Initializes a new instance of the EBILoadVersionException class.
Top
Fields
Show:
Name | Description
WrongVersion | Represents field WrongVersion.
Top
See Also

Reference

  • BI.Persist


EBILoadVersionException Constructors

Constructors
Name | Description
CreateVersion(Integer) | Initializes a new instance of the EBILoadVersionException class.
Top


EBILoadVersionException.CreateVersion(Integer) Constructor

Summary

Initializes a new instance of the EBILoadVersionException class.

Namespace: BI.Persist
Syntax
Delphi
public
 Constructor CreateVersion(const AVersion:Integer);

Parameters

AVersion
Type: Integer

See Also

Reference

  • EBILoadVersionException
  • BI.Persist


EBILoadVersionException Fields

Fields
Name | Description
WrongVersion | Represents field WrongVersion.
Top


EBILoadVersionException.WrongVersion Field

Summary

Represents field WrongVersion.

Namespace: BI.Persist
Syntax
Delphi
public
 WrongVersion : Integer;

Field Value

Type: Integer

See Also

Reference

  • EBILoadVersionException
  • BI.Persist


TBaseDataImporter Class

Summary

Represents type TBaseDataImporter.

Namespace: BI.Persist
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Persist.TBaseDataImporter
BI.Persist.TDataDefinition
BI.Query.TBIQuery
BI.RTTI.TRTTIProvider
BI.Store.Component.TComponentImporter
BI.Workflow.TBIWorkflow
Syntax
Delphi
type
 TBaseDataImporter=class(TDataProvider)
 end;

The TBaseDataImporter type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TBaseDataImporter class. (Overrides TDataProvider.Destroy.)
Top
Properties
Show:
Name | Description
Data | Represents property Data.
Top
Methods
Show:
Name | Description
Changed | Represents method Changed. (Overrides TDataProvider.Changed.)
Notify(TBIEvent) | Represents method Notify(TBIEvent).
Top
Fields
Show:
Name | Description
FData | Represents field FData.
IKeepData | Represents field IKeepData.
Top
See Also

Reference

  • BI.Persist


TBaseDataImporter Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TBaseDataImporter class. (Overrides TDataProvider.Destroy.)
Top


TBaseDataImporter.Destroy Destructor

Summary

Represents the destructor of the TBaseDataImporter class.

Namespace: BI.Persist
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TDataProvider.Destroy
See Also

Reference

  • TBaseDataImporter
  • BI.Persist


TBaseDataImporter Properties

Properties
Name | Description
Data | Represents property Data.
Top


TBaseDataImporter.Data Property

Summary

Represents property Data.

Namespace: BI.Persist
Syntax
Delphi
public
 property Data:TDataItem read GetData;

Property Value

Type: TDataItem

See Also

Reference

  • TBaseDataImporter
  • BI.Persist


TBaseDataImporter Methods

Methods
Name | Description
Changed | Represents method Changed. (Overrides TDataProvider.Changed.)
Notify(TBIEvent) | Represents method Notify(TBIEvent).
Top


TBaseDataImporter.Changed Method

Summary

Represents method Changed.

Namespace: BI.Persist
Syntax
Delphi
protected
 procedure Changed; override;

Overrides

TDataProvider.Changed
See Also

Reference

  • TBaseDataImporter
  • BI.Persist


TBaseDataImporter.Notify(TBIEvent) Method

Summary

Represents method Notify(TBIEvent).

Namespace: BI.Persist
Syntax
Delphi
protected
 procedure Notify(const AEvent:TBIEvent);

Parameters

AEvent
Type: TBIEvent

See Also

Reference

  • TBaseDataImporter
  • BI.Persist


TBaseDataImporter Fields

Fields
Name | Description
FData | Represents field FData.
IKeepData | Represents field IKeepData.
Top


TBaseDataImporter.FData Field

Summary

Represents field FData.

Namespace: BI.Persist
Syntax
Delphi
protected
 FData : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TBaseDataImporter
  • BI.Persist


TBaseDataImporter.IKeepData Field

Summary

Represents field IKeepData.

Namespace: BI.Persist
Syntax
Delphi
protected
 IKeepData : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBaseDataImporter
  • BI.Persist


TBIRegistry Class

Summary

Represents type TBIRegistry.

Namespace: BI.Persist
Inheritance Hierarchy
TObject
BI.Persist.TBIRegistry
Syntax
Delphi
type
 TBIRegistry=class
 end;

The TBIRegistry type exposes the following members.

Methods
Show:
Name | Description
Exists(String,String) | Represents method Exists(String,String).
ReadBoolean(String,String,Boolean) | Represents method ReadBoolean(String,String,Boolean).
ReadInteger(String,String,Integer) | Represents method ReadInteger(String,String,Integer).
ReadString(String,String,String) | Represents method ReadString(String,String,String).
RemoveItem(String,String) | Represents method RemoveItem(String,String).
WriteBoolean(String,String,Boolean) | Represents method WriteBoolean(String,String,Boolean).
WriteInteger(String,String,Integer) | Represents method WriteInteger(String,String,Integer).
WriteString(String,String,String) | Represents method WriteString(String,String,String).
Top
Fields
Show:
Name | Description
IniFile | Represents field IniFile.
UseRegistry | Represents field UseRegistry.
Top
See Also

Reference

  • BI.Persist


TBIRegistry Methods

Methods
Name | Description
Exists(String,String) | Represents method Exists(String,String).
ReadBoolean(String,String,Boolean) | Represents method ReadBoolean(String,String,Boolean).
ReadInteger(String,String,Integer) | Represents method ReadInteger(String,String,Integer).
ReadString(String,String,String) | Represents method ReadString(String,String,String).
RemoveItem(String,String) | Represents method RemoveItem(String,String).
WriteBoolean(String,String,Boolean) | Represents method WriteBoolean(String,String,Boolean).
WriteInteger(String,String,Integer) | Represents method WriteInteger(String,String,Integer).
WriteString(String,String,String) | Represents method WriteString(String,String,String).
Top


TBIRegistry.Exists(String,String) Method

Summary

Represents method Exists(String,String).

Namespace: BI.Persist
Syntax
Delphi
public
 class function Exists(const Key,Name:String):Boolean; static;

Parameters

Key
Type: String

Name
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TBIRegistry
  • BI.Persist


TBIRegistry.ReadBoolean(String,String,Boolean) Method

Summary

Represents method ReadBoolean(String,String,Boolean).

Namespace: BI.Persist
Syntax
Delphi
public
 class function ReadBoolean(const Key,Name:String; const Default:Boolean):Boolean; static;

Parameters

Key
Type: String

Name
Type: String

Default
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • TBIRegistry
  • BI.Persist


TBIRegistry.ReadInteger(String,String,Integer) Method

Summary

Represents method ReadInteger(String,String,Integer).

Namespace: BI.Persist
Syntax
Delphi
public
 class function ReadInteger(const Key,Name:String; const Default:Integer):Integer; static;

Parameters

Key
Type: String

Name
Type: String

Default
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TBIRegistry
  • BI.Persist


TBIRegistry.ReadString(String,String,String) Method

Summary

Represents method ReadString(String,String,String).

Namespace: BI.Persist
Syntax
Delphi
public
 class function ReadString(const Key, Name:String; const Default: String=''): String; static;

Parameters

Key
Type: String

Name
Type: String

Default
Type: String

Return Value

Type: String

See Also

Reference

  • TBIRegistry
  • BI.Persist


TBIRegistry.RemoveItem(String,String) Method

Summary

Represents method RemoveItem(String,String).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure RemoveItem(const Key, Name:String); static;

Parameters

Key
Type: String

Name
Type: String

See Also

Reference

  • TBIRegistry
  • BI.Persist


TBIRegistry.WriteBoolean(String,String,Boolean) Method

Summary

Represents method WriteBoolean(String,String,Boolean).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure WriteBoolean(const Key,Name:String; const Value:Boolean); static;

Parameters

Key
Type: String

Name
Type: String

Value
Type: Boolean

See Also

Reference

  • TBIRegistry
  • BI.Persist


TBIRegistry.WriteInteger(String,String,Integer) Method

Summary

Represents method WriteInteger(String,String,Integer).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure WriteInteger(const Key,Name:String; const Value:Integer); static;

Parameters

Key
Type: String

Name
Type: String

Value
Type: Integer

See Also

Reference

  • TBIRegistry
  • BI.Persist


TBIRegistry.WriteString(String,String,String) Method

Summary

Represents method WriteString(String,String,String).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure WriteString(const Key,Name,Value:String); static;

Parameters

Key
Type: String

Name
Type: String

Value
Type: String

See Also

Reference

  • TBIRegistry
  • BI.Persist


TBIRegistry Fields

Fields
Name | Description
IniFile | Represents field IniFile.
UseRegistry | Represents field UseRegistry.
Top


TBIRegistry.IniFile Field

Summary

Represents field IniFile.

Namespace: BI.Persist
Syntax
Delphi
public
 class var
 IniFile:String;

Field Value

Type: String

See Also

Reference

  • TBIRegistry
  • BI.Persist


TBIRegistry.UseRegistry Field

Summary

Represents field UseRegistry.

Namespace: BI.Persist
Syntax
Delphi
public
 class var
 UseRegistry:Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBIRegistry
  • BI.Persist


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.Persist
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Persist.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.Persist


TDataAccessTimes Class

Summary

Represents type TDataAccessTimes.

Namespace: BI.Persist
Inheritance Hierarchy
TObject
BI.Persist.TDataAccessTimes
Syntax
Delphi
type
 TDataAccessTimes=class
 end;
See Also

Reference

  • BI.Persist


TDatabaseDefinition Class

Summary

Represents type TDatabaseDefinition.

Namespace: BI.Persist
Inheritance Hierarchy
TPersistent
BI.Persist.TDatabaseDefinition
Syntax
Delphi
type
 TDatabaseDefinition=class(TPersistent)
 end;

The TDatabaseDefinition type exposes the following members.

Properties
Show:
Name | Description
IncludeSystem | Represents property IncludeSystem.
IncludeViews | Represents property IncludeViews.
Top
See Also

Reference

  • BI.Persist


TDatabaseDefinition Properties

Properties
Name | Description
IncludeSystem | Represents property IncludeSystem.
IncludeViews | Represents property IncludeViews.
Top


TDatabaseDefinition.IncludeSystem Property

Summary

Represents property IncludeSystem.

Namespace: BI.Persist
Syntax
Delphi
published
 property IncludeSystem:Boolean read GetSystem write SetSystem default False;

Property Value

Type: Boolean

See Also

Reference

  • TDatabaseDefinition
  • BI.Persist


TDatabaseDefinition.IncludeViews Property

Summary

Represents property IncludeViews.

Namespace: BI.Persist
Syntax
Delphi
published
 property IncludeViews:Boolean read GetViews write SetViews default False;

Property Value

Type: Boolean

See Also

Reference

  • TDatabaseDefinition
  • BI.Persist


TDataDefinition Class

Summary

Represents type TDataDefinition.

Namespace: BI.Persist
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Persist.TBaseDataImporter
BI.Persist.TDataDefinition
VCLBI.DataManager.TDataDefinitionAccess
Syntax
Delphi
type
 TDataDefinition=class(TBaseDataImporter)
 end;

The TDataDefinition type exposes the following members.

Constants
Show:
Name | Description
Extension | Represents constant Extension.
Top
Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TDataDefinition class.
Destroy | Represents the destructor of the TDataDefinition class. (Overrides TBaseDataImporter.Destroy.)
FromFile(TComponent,String) | Initializes a new instance of the TDataDefinition class.
Top
Properties
Show:
Name | Description
AsDatabase | Represents property AsDatabase.
CalcStats | Represents property CalcStats.
FileName | Represents property FileName.
Kind | Represents property Kind.
Links | Represents property Links.
Parallel | Represents property Parallel.
Strings | Represents property Strings.
Value[String] | Represents property Value[String].
Top
Methods
Show:
Name | Description
AsBoolean(String,Boolean) | Represents method AsBoolean(String,Boolean).
CreateFile(String,TDataDefinitionKind) | Represents method CreateFile(String,TDataDefinitionKind).
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Description | Represents method Description.
GetItems(TDataItem) | Represents method GetItems(TDataItem). (Overrides TDataProvider.GetItems(TDataItem).)
Import(String) | Represents method Import(String).
KindToString(TDataDefinitionKind) | Represents method KindToString(TDataDefinitionKind).
LastImport | Represents method LastImport.
LinksFrom(TStrings) | Represents method LinksFrom(TStrings).
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Loaded | Represents method Loaded.
LoadFromFile(String) | Represents method LoadFromFile(String).
LoadFromText(String) | Represents method LoadFromText(String).
Merge(TDataItem,TDataArray) | Overloaded. Represents method Merge(TDataItem,TDataArray).
Merge(TDataItem,TDataItem) | Overloaded. Represents method Merge(TDataItem,TDataItem).
MultiLineText(String) | Represents method MultiLineText(String).
NextRefresh | Represents method NextRefresh.
Save | Represents method Save.
SaveLinks | Represents method SaveLinks.
SetMasters(TDataItem,String,TDataRelations) | Overloaded. Represents method SetMasters(TDataItem,String,TDataRelations).
SetMasters(TDataItem,String,TStrings) | Overloaded. Represents method SetMasters(TDataItem,String,TStrings).
TryLoadDetails(String) | Represents method TryLoadDetails(String).
Top
Events
Show:
Name | Description
OnError | Represents property OnError.
OnImporting | Represents property OnImporting.
Top
Fields
Show:
Name | Description
FStrings | Represents field FStrings.
Refresh | Represents field Refresh.
Store | Represents field Store.
Volatile | Represents field Volatile.
Top
See Also

Reference

  • BI.Persist


TDataDefinition Constants

Constants
Name | Description
Extension | Represents constant Extension.
Top


TDataDefinition.Extension Constant

Summary

Represents constant Extension.

Namespace: BI.Persist
Syntax
Delphi
public
 Extension='.def';

Value

Type: string

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TDataDefinition class.
Destroy | Represents the destructor of the TDataDefinition class. (Overrides TBaseDataImporter.Destroy.)
FromFile(TComponent,String) | Initializes a new instance of the TDataDefinition class.
Top


TDataDefinition.Create(TComponent) Constructor

Summary

Initializes a new instance of the TDataDefinition class.

Namespace: BI.Persist
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.Destroy Destructor

Summary

Represents the destructor of the TDataDefinition class.

Namespace: BI.Persist
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TBaseDataImporter.Destroy
See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.FromFile(TComponent,String) Constructor

Summary

Initializes a new instance of the TDataDefinition class.

Namespace: BI.Persist
Syntax
Delphi
public
 Constructor FromFile(const AOwner:TComponent; const AFileName:String);

Parameters

AOwner
Type: TComponent

AFileName
Type: String

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition Properties

Properties
Name | Description
AsDatabase | Represents property AsDatabase.
CalcStats | Represents property CalcStats.
FileName | Represents property FileName.
Kind | Represents property Kind.
Links | Represents property Links.
Parallel | Represents property Parallel.
Strings | Represents property Strings.
Value[String] | Represents property Value[String].
Top


TDataDefinition.AsDatabase Property

Summary

Represents property AsDatabase.

Namespace: BI.Persist
Syntax
Delphi
public
 property AsDatabase:TDatabaseDefinition read FDatabase;

Property Value

Type: TDatabaseDefinition

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.CalcStats Property

Summary

Represents property CalcStats.

Namespace: BI.Persist
Syntax
Delphi
public
 property CalcStats:Boolean read GetCalcStats write SetCalcStats default False;

Property Value

Type: Boolean

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.FileName Property

Summary

Represents property FileName.

Namespace: BI.Persist
Syntax
Delphi
published
 property FileName:String read FFileName write SetFileName;

Property Value

Type: String

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.Kind Property

Summary

Represents property Kind.

Namespace: BI.Persist
Syntax
Delphi
published
 property Kind:TDataDefinitionKind read GetKind write SetKind default TDataDefinitionKind.Unknown;

Property Value

Type: TDataDefinitionKind

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.Links Property

Summary

Represents property Links.

Namespace: BI.Persist
Syntax
Delphi
published
 property Links:TDataRelations read GetLinks write SetLinks;

Property Value

Type: TDataRelations

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.Parallel Property

Summary

Represents property Parallel.

Namespace: BI.Persist
Syntax
Delphi
public
 property Parallel:Boolean read GetParallel write SetParallel default False;

Property Value

Type: Boolean

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.Strings Property

Summary

Represents property Strings.

Namespace: BI.Persist
Syntax
Delphi
published
 property Strings:TStrings read GetStrings write SetStrings;

Property Value

Type: TStrings

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.Value[String] Property

Summary

Represents property Value[String].

Namespace: BI.Persist
Syntax
Delphi
public
 property Value[const Index:String]:String read GetValue write SetValue; default;

Parameters

Index
Type: String

Property Value

Type: String

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition Methods

Methods
Name | Description
AsBoolean(String,Boolean) | Represents method AsBoolean(String,Boolean).
CreateFile(String,TDataDefinitionKind) | Represents method CreateFile(String,TDataDefinitionKind).
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Description | Represents method Description.
GetItems(TDataItem) | Represents method GetItems(TDataItem). (Overrides TDataProvider.GetItems(TDataItem).)
Import(String) | Represents method Import(String).
KindToString(TDataDefinitionKind) | Represents method KindToString(TDataDefinitionKind).
LastImport | Represents method LastImport.
LinksFrom(TStrings) | Represents method LinksFrom(TStrings).
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Loaded | Represents method Loaded.
LoadFromFile(String) | Represents method LoadFromFile(String).
LoadFromText(String) | Represents method LoadFromText(String).
Merge(TDataItem,TDataArray) | Overloaded. Represents method Merge(TDataItem,TDataArray).
Merge(TDataItem,TDataItem) | Overloaded. Represents method Merge(TDataItem,TDataItem).
MultiLineText(String) | Represents method MultiLineText(String).
NextRefresh | Represents method NextRefresh.
Save | Represents method Save.
SaveLinks | Represents method SaveLinks.
SetMasters(TDataItem,String,TDataRelations) | Overloaded. Represents method SetMasters(TDataItem,String,TDataRelations).
SetMasters(TDataItem,String,TStrings) | Overloaded. Represents method SetMasters(TDataItem,String,TStrings).
TryLoadDetails(String) | Represents method TryLoadDetails(String).
Top


TDataDefinition.AsBoolean(String,Boolean) Method

Summary

Represents method AsBoolean(String,Boolean).

Namespace: BI.Persist
Syntax
Delphi
public
 function AsBoolean(const Key:String; const ADefault:Boolean=True):Boolean;

Parameters

Key
Type: String

ADefault
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.CreateFile(String,TDataDefinitionKind) Method

Summary

Represents method CreateFile(String,TDataDefinitionKind).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure CreateFile(const FileName:String; const Kind:TDataDefinitionKind);

Parameters

FileName
Type: String

Kind
Type: TDataDefinitionKind

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: BI.Persist
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.Description Method

Summary

Represents method Description.

Namespace: BI.Persist
Syntax
Delphi
public
 function Description: String;

Return Value

Type: String

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.GetItems(TDataItem) Method

Summary

Represents method GetItems(TDataItem).

Namespace: BI.Persist
Syntax
Delphi
protected
 procedure GetItems(const AData:TDataItem); override;

Parameters

AData
Type: TDataItem

Overrides

TDataProvider.GetItems(TDataItem)
See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.Import(String) Method

Summary

Represents method Import(String).

Namespace: BI.Persist
Syntax
Delphi
public
 function Import(const AStore:String):TDataArray;

Parameters

AStore
Type: String

Return Value

Type: TDataArray

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.KindToString(TDataDefinitionKind) Method

Summary

Represents method KindToString(TDataDefinitionKind).

Namespace: BI.Persist
Syntax
Delphi
public
 class function KindToString(const AKind:TDataDefinitionKind):String;

Parameters

AKind
Type: TDataDefinitionKind

Return Value

Type: String

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.LastImport Method

Summary

Represents method LastImport.

Namespace: BI.Persist
Syntax
Delphi
public
 function LastImport:String;

Return Value

Type: String

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.LinksFrom(TStrings) Method

Summary

Represents method LinksFrom(TStrings).

Namespace: BI.Persist
Syntax
Delphi
public
 class function LinksFrom(const AStrings:TStrings):TDataRelations; static;

Parameters

AStrings
Type: TStrings

Return Value

Type: TDataRelations

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Persist
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.Loaded Method

Summary

Represents method Loaded.

Namespace: BI.Persist
Syntax
Delphi
protected
 procedure Loaded; override;
See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.LoadFromFile(String) Method

Summary

Represents method LoadFromFile(String).

Namespace: BI.Persist
Syntax
Delphi
public
 procedure LoadFromFile(const AFileName:String);

Parameters

AFileName
Type: String

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.LoadFromText(String) Method

Summary

Represents method LoadFromText(String).

Namespace: BI.Persist
Syntax
Delphi
public
 procedure LoadFromText(const AText:String);

Parameters

AText
Type: String

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.Merge(TDataItem,TDataArray) Method

Summary

Represents method Merge(TDataItem,TDataArray).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Merge(const AData: TDataItem; const AItems:TDataArray); overload; static;

Parameters

AData
Type: TDataItem

AItems
Type: TDataArray

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.Merge(TDataItem,TDataItem) Method

Summary

Represents method Merge(TDataItem,TDataItem).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Merge(const AData,ASource: TDataItem); overload; static;

Parameters

AData
Type: TDataItem

ASource
Type: TDataItem

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.MultiLineText(String) Method

Summary

Represents method MultiLineText(String).

Namespace: BI.Persist
Syntax
Delphi
public
 function MultiLineText(const ATag:String):String;

Parameters

ATag
Type: String

Return Value

Type: String

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.NextRefresh Method

Summary

Represents method NextRefresh.

Namespace: BI.Persist
Syntax
Delphi
public
 function NextRefresh:TDateTime;

Return Value

Type: TDateTime

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.Save Method

Summary

Represents method Save.

Namespace: BI.Persist
Syntax
Delphi
protected
 procedure Save;
See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.SaveLinks Method

Summary

Represents method SaveLinks.

Namespace: BI.Persist
Syntax
Delphi
public
 procedure SaveLinks;
See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.SetMasters(TDataItem,String,TDataRelations) Method

Summary

Represents method SetMasters(TDataItem,String,TDataRelations).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure SetMasters(const AData:TDataItem;
 const AStore:String;
 const Items:TDataRelations); overload; static;

Parameters

AData
Type: TDataItem

AStore
Type: String

Items
Type: TDataRelations

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.SetMasters(TDataItem,String,TStrings) Method

Summary

Represents method SetMasters(TDataItem,String,TStrings).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure SetMasters(const AData:TDataItem;
 const AStore:String;
 const AStrings:TStrings); overload; static;

Parameters

AData
Type: TDataItem

AStore
Type: String

AStrings
Type: TStrings

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.TryLoadDetails(String) Method

Summary

Represents method TryLoadDetails(String).

Namespace: BI.Persist
Syntax
Delphi
protected
 procedure TryLoadDetails(const AStore:String);

Parameters

AStore
Type: String

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition Events

Events
Name | Description
OnError | Represents property OnError.
OnImporting | Represents property OnImporting.
Top


TDataDefinition.OnError Event

Summary

Represents property OnError.

Namespace: BI.Persist
Syntax
Delphi
published
 property OnError:TBIError read FOnError write FOnError;

Value

Type: TBIError

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.OnImporting Event

Summary

Represents property OnImporting.

Namespace: BI.Persist
Syntax
Delphi
published
 property OnImporting:TBIProgress read FOnImporting write FOnImporting;

Value

Type: TBIProgress

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition Fields

Fields
Name | Description
FStrings | Represents field FStrings.
Refresh | Represents field Refresh.
Store | Represents field Store.
Volatile | Represents field Volatile.
Top


TDataDefinition.FStrings Field

Summary

Represents field FStrings.

Namespace: BI.Persist
Syntax
Delphi
protected
 FStrings : TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.Refresh Field

Summary

Represents field Refresh.

Namespace: BI.Persist
Syntax
Delphi
protected
 Refresh : TRefreshSettings;

Field Value

Type: TRefreshSettings

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.Store Field

Summary

Represents field Store.

Namespace: BI.Persist
Syntax
Delphi
public
 Store : String;

Field Value

Type: String

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDefinition.Volatile Field

Summary

Represents field Volatile.

Namespace: BI.Persist
Syntax
Delphi
protected
 Volatile : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TDataDefinition
  • BI.Persist


TDataDelayProvider Class

Summary

Represents type TDataDelayProvider.

Namespace: BI.Persist
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Persist.TDataDelayProvider
BI.Persist.TDelayHandlerFolder
BI.Persist.TDelayHandlerStream
BI.Web.TDelayHandlerWeb
Syntax
Delphi
type
 TDataDelayProvider=class(TDataProvider)
 end;
See Also

Reference

  • BI.Persist


TDataImporter Class

Summary

Represents type TDataImporter.

Namespace: BI.Persist
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Persist.TDataImporter
BI.DataSource.TBIFileImporter
BI.DB.TBIDBImporter
BI.Web.TBIWebImporter
Syntax
Delphi
type
 TDataImporter=class(TDataProvider)
 end;

The TDataImporter type exposes the following members.

Constructors
Show:
Name | Description
CreateDefinition(String,TDataDefinition) | Initializes a new instance of the TDataImporter class.
Top
Methods
Show:
Name | Description
AllData | Represents method AllData.
DoProgress(Single,Boolean) | Represents method DoProgress(Single,Boolean).
Find(TDataImporterClass) | Represents method Find(TDataImporterClass).
GetDefinition(String) | Represents method GetDefinition(String).
Guess(TDataDefinitionKind,String,TDataDefinition) | Represents method Guess(TDataDefinitionKind,String,TDataDefinition).
Import | Represents method Import.
IsRemote | Represents method IsRemote.
Load(String) | Represents method Load(String).
RegisterClass(TDataImporterClass) | Represents method RegisterClass(TDataImporterClass).
Supports(TDataDefinitionKind,TDataDefinition) | Represents method Supports(TDataDefinitionKind,TDataDefinition).
UnRegisterClass(TDataImporterClass) | Represents method UnRegisterClass(TDataImporterClass).
Top
Fields
Show:
Name | Description
Definition | Represents field Definition.
Importers | Represents field Importers.
Top
See Also

Reference

  • BI.Persist


TDataImporter Constructors

Constructors
Name | Description
CreateDefinition(String,TDataDefinition) | Initializes a new instance of the TDataImporter class.
Top


TDataImporter.CreateDefinition(String,TDataDefinition) Constructor

Summary

Initializes a new instance of the TDataImporter class.

Namespace: BI.Persist
Syntax
Delphi
public
 Constructor CreateDefinition(const AStore:String; const ADefinition:TDataDefinition); virtual;

Parameters

AStore
Type: String

ADefinition
Type: TDataDefinition

See Also

Reference

  • TDataImporter
  • BI.Persist


TDataImporter Methods

Methods
Name | Description
AllData | Represents method AllData.
DoProgress(Single,Boolean) | Represents method DoProgress(Single,Boolean).
Find(TDataImporterClass) | Represents method Find(TDataImporterClass).
GetDefinition(String) | Represents method GetDefinition(String).
Guess(TDataDefinitionKind,String,TDataDefinition) | Represents method Guess(TDataDefinitionKind,String,TDataDefinition).
Import | Represents method Import.
IsRemote | Represents method IsRemote.
Load(String) | Represents method Load(String).
RegisterClass(TDataImporterClass) | Represents method RegisterClass(TDataImporterClass).
Supports(TDataDefinitionKind,TDataDefinition) | Represents method Supports(TDataDefinitionKind,TDataDefinition).
UnRegisterClass(TDataImporterClass) | Represents method UnRegisterClass(TDataImporterClass).
Top


TDataImporter.AllData Method

Summary

Represents method AllData.

Namespace: BI.Persist
Syntax
Delphi
public
 function AllData:TStringArray; virtual; abstract;

Return Value

Type: TStringArray

See Also

Reference

  • TDataImporter
  • BI.Persist


TDataImporter.DoProgress(Single,Boolean) Method

Summary

Represents method DoProgress(Single,Boolean).

Namespace: BI.Persist
Syntax
Delphi
protected
 procedure DoProgress(const Percent:Single; var Cancel:Boolean);

Parameters

Percent
Type: Single

Cancel
Type: Boolean

See Also

Reference

  • TDataImporter
  • BI.Persist


TDataImporter.Find(TDataImporterClass) Method

Summary

Represents method Find(TDataImporterClass).

Namespace: BI.Persist
Syntax
Delphi
protected
 class function Find(const AClass:TDataImporterClass):Integer;

Parameters

AClass
Type: TDataImporterClass

Return Value

Type: Integer

See Also

Reference

  • TDataImporter
  • BI.Persist


TDataImporter.GetDefinition(String) Method

Summary

Represents method GetDefinition(String).

Namespace: BI.Persist
Syntax
Delphi
public
 function GetDefinition(const AName:String):TDataDefinition; virtual; abstract;

Parameters

AName
Type: String

Return Value

Type: TDataDefinition

See Also

Reference

  • TDataImporter
  • BI.Persist


TDataImporter.Guess(TDataDefinitionKind,String,TDataDefinition) Method

Summary

Represents method Guess(TDataDefinitionKind,String,TDataDefinition).

Namespace: BI.Persist
Syntax
Delphi
public
 class function Guess(const Kind:TDataDefinitionKind;
 const Store:String;
 const ADefinition:TDataDefinition):TDataImporter;

Parameters

Kind
Type: TDataDefinitionKind

Store
Type: String

ADefinition
Type: TDataDefinition

Return Value

Type: TDataImporter

See Also

Reference

  • TDataImporter
  • BI.Persist


TDataImporter.Import Method

Summary

Represents method Import.

Namespace: BI.Persist
Syntax
Delphi
public
 function Import:TDataArray; virtual; abstract;

Return Value

Type: TDataArray

See Also

Reference

  • TDataImporter
  • BI.Persist


TDataImporter.IsRemote Method

Summary

Represents method IsRemote.

Namespace: BI.Persist
Syntax
Delphi
public
 class function IsRemote:Boolean; virtual; abstract;

Return Value

Type: Boolean

See Also

Reference

  • TDataImporter
  • BI.Persist


TDataImporter.Load(String) Method

Summary

Represents method Load(String).

Namespace: BI.Persist
Syntax
Delphi
public
 function Load(const AName:String):TDataItem; virtual; abstract;

Parameters

AName
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TDataImporter
  • BI.Persist


TDataImporter.RegisterClass(TDataImporterClass) Method

Summary

Represents method RegisterClass(TDataImporterClass).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure RegisterClass(const AClass:TDataImporterClass);

Parameters

AClass
Type: TDataImporterClass

See Also

Reference

  • TDataImporter
  • BI.Persist


TDataImporter.Supports(TDataDefinitionKind,TDataDefinition) Method

Summary

Represents method Supports(TDataDefinitionKind,TDataDefinition).

Namespace: BI.Persist
Syntax
Delphi
public
 class function Supports(const Kind:TDataDefinitionKind; const ADefinition:TDataDefinition=nil):Boolean; virtual; abstract;

Parameters

Kind
Type: TDataDefinitionKind

ADefinition
Type: TDataDefinition

Return Value

Type: Boolean

See Also

Reference

  • TDataImporter
  • BI.Persist


TDataImporter.UnRegisterClass(TDataImporterClass) Method

Summary

Represents method UnRegisterClass(TDataImporterClass).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure UnRegisterClass(const AClass:TDataImporterClass);

Parameters

AClass
Type: TDataImporterClass

See Also

Reference

  • TDataImporter
  • BI.Persist


TDataImporter Fields

Fields
Name | Description
Definition | Represents field Definition.
Importers | Represents field Importers.
Top


TDataImporter.Definition Field

Summary

Represents field Definition.

Namespace: BI.Persist
Syntax
Delphi
protected
 Definition : TDataDefinition;

Field Value

Type: TDataDefinition

See Also

Reference

  • TDataImporter
  • BI.Persist


TDataImporter.Importers Field

Summary

Represents field Importers.

Namespace: BI.Persist
Syntax
Delphi
protected
 class var
 Importers:Array of TDataImporterClass;

Field Value

Type: Array of TDataImporterClass

See Also

Reference

  • TDataImporter
  • BI.Persist


TDataItemAccess Class

Summary

Represents type TDataItemAccess.

Namespace: BI.Persist
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Persist.TDataItemAccess
Syntax
Delphi
type
 TDataItemAccess=class(TDataItem);
See Also

Reference

  • BI.Persist


TDataItemPersistence Class

Summary

Represents type TDataItemPersistence.

Namespace: BI.Persist
Inheritance Hierarchy
TObject
BI.Persist.TDataItemPersistence
Syntax
Delphi
type
 TDataItemPersistence=class
 end;

The TDataItemPersistence type exposes the following members.

Constants
Show:
Name | Description
Extension | Represents constant Extension.
Top
Methods
Show:
Name | Description
Load(String) | Overloaded. Represents method Load(String).
Load(TStream) | Overloaded. Represents method Load(TStream).
Save(TDataItem,String) | Overloaded. Represents method Save(TDataItem,String).
Save(TDataItem,TStream) | Overloaded. Represents method Save(TDataItem,TStream).
Top
See Also

Reference

  • BI.Persist


TDataItemPersistence Constants

Constants
Name | Description
Extension | Represents constant Extension.
Top


TDataItemPersistence.Extension Constant

Summary

Represents constant Extension.

Namespace: BI.Persist
Syntax
Delphi
public
 Extension='.bidata';

Value

Type: string

See Also

Reference

  • TDataItemPersistence
  • BI.Persist


TDataItemPersistence Methods

Methods
Name | Description
Load(String) | Overloaded. Represents method Load(String).
Load(TStream) | Overloaded. Represents method Load(TStream).
Save(TDataItem,String) | Overloaded. Represents method Save(TDataItem,String).
Save(TDataItem,TStream) | Overloaded. Represents method Save(TDataItem,TStream).
Top


TDataItemPersistence.Load(String) Method

Summary

Represents method Load(String).

Namespace: BI.Persist
Syntax
Delphi
public
 class function Load(const FileName:String):TDataItem; overload; static;

Parameters

FileName
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TDataItemPersistence
  • BI.Persist


TDataItemPersistence.Load(TStream) Method

Summary

Represents method Load(TStream).

Namespace: BI.Persist
Syntax
Delphi
public
 class function Load(const Stream:TStream):TDataItem; overload; static;

Parameters

Stream
Type: TStream

Return Value

Type: TDataItem

See Also

Reference

  • TDataItemPersistence
  • BI.Persist


TDataItemPersistence.Save(TDataItem,String) Method

Summary

Represents method Save(TDataItem,String).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Save(const Data:TDataItem; const FileName:String); overload; static;

Parameters

Data
Type: TDataItem

FileName
Type: String

See Also

Reference

  • TDataItemPersistence
  • BI.Persist


TDataItemPersistence.Save(TDataItem,TStream) Method

Summary

Represents method Save(TDataItem,TStream).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Save(const Data:TDataItem; const Stream:TStream); overload; static;

Parameters

Data
Type: TDataItem

Stream
Type: TStream

See Also

Reference

  • TDataItemPersistence
  • BI.Persist


TDataItemsAccess Class

Summary

Represents type TDataItemsAccess.

Namespace: BI.Persist
Inheritance Hierarchy
TObject
BI.DataItem.TDataItems
BI.Persist.TDataItemsAccess
Syntax
Delphi
type
 TDataItemsAccess=class(TDataItems);
See Also

Reference

  • BI.Persist


TDataMapAccess Class

Summary

Represents type TDataMapAccess.

Namespace: BI.Persist
Inheritance Hierarchy
TObject
BI.Arrays.TDataMap
BI.Persist.TDataMapAccess
Syntax
Delphi
type
 TDataMapAccess=class(TDataMap);
See Also

Reference

  • BI.Persist


TDataPersistence Class

Summary

Represents type TDataPersistence.

Namespace: BI.Persist
Inheritance Hierarchy
TObject
BI.Persist.TDataPersistence
Syntax
Delphi
type
 TDataPersistence=class
 end;

The TDataPersistence type exposes the following members.

Constants
Show:
Name | Description
Extension | Represents constant Extension.
SupportedFrom | Represents constant SupportedFrom.
Version | Represents constant Version.
Top
Methods
Show:
Name | Description
DoLoad(TBIReader,TDataItem,Boolean,Boolean) | Represents method DoLoad(TBIReader,TDataItem,Boolean,Boolean).
Load(String,TDataItem,Boolean) | Overloaded. Represents method Load(String,TDataItem,Boolean).
Load(TBIReader,TDataItem,Boolean) | Overloaded. Represents method Load(TBIReader,TDataItem,Boolean).
Load(TStream,TDataArray) | Overloaded. Represents method Load(TStream,TDataArray).
Load(TStream,TDataItem,Boolean) | Overloaded. Represents method Load(TStream,TDataItem,Boolean).
Load(TStream,TInt32Array) | Overloaded. Represents method Load(TStream,TInt32Array).
Load(TStream,TInt64Array) | Overloaded. Represents method Load(TStream,TInt64Array).
LoadFromFolder(String,TDataItem,Boolean) | Overloaded. Represents method LoadFromFolder(String,TDataItem,Boolean).
LoadItem(TBIReader,TDataItem) | Represents method LoadItem(TBIReader,TDataItem).
Save(TDataArray,TStream) | Overloaded. Represents method Save(TDataArray,TStream).
Save(TDataItem,String,TBIProgress) | Overloaded. Represents method Save(TDataItem,String,TBIProgress).
Save(TDataItem,TBIWriter,TBIProgress) | Overloaded. Represents method Save(TDataItem,TBIWriter,TBIProgress).
Save(TDataItem,TStream,TBIProgress) | Overloaded. Represents method Save(TDataItem,TStream,TBIProgress).
SaveToFolder(TDataItem,String,TBIProgress) | Overloaded. Represents method SaveToFolder(TDataItem,String,TBIProgress).
Top
See Also

Reference

  • BI.Persist


TDataPersistence Constants

Constants
Name | Description
Extension | Represents constant Extension.
SupportedFrom | Represents constant SupportedFrom.
Version | Represents constant Version.
Top


TDataPersistence.Extension Constant

Summary

Represents constant Extension.

Namespace: BI.Persist
Syntax
Delphi
public
 Extension='.databi';

Value

Type: string

See Also

Reference

  • TDataPersistence
  • BI.Persist


TDataPersistence.SupportedFrom Constant

Summary

Represents constant SupportedFrom.

Namespace: BI.Persist
Syntax
Delphi
public
 SupportedFrom=5;

Value

Type: ShortInt

See Also

Reference

  • TDataPersistence
  • BI.Persist


TDataPersistence.Version Constant

Summary

Represents constant Version.

Namespace: BI.Persist
Syntax
Delphi
public
 Version=5;

Value

Type: ShortInt

See Also

Reference

  • TDataPersistence
  • BI.Persist


TDataPersistence Methods

Methods
Name | Description
DoLoad(TBIReader,TDataItem,Boolean,Boolean) | Represents method DoLoad(TBIReader,TDataItem,Boolean,Boolean).
Load(String,TDataItem,Boolean) | Overloaded. Represents method Load(String,TDataItem,Boolean).
Load(TBIReader,TDataItem,Boolean) | Overloaded. Represents method Load(TBIReader,TDataItem,Boolean).
Load(TStream,TDataArray) | Overloaded. Represents method Load(TStream,TDataArray).
Load(TStream,TDataItem,Boolean) | Overloaded. Represents method Load(TStream,TDataItem,Boolean).
Load(TStream,TInt32Array) | Overloaded. Represents method Load(TStream,TInt32Array).
Load(TStream,TInt64Array) | Overloaded. Represents method Load(TStream,TInt64Array).
LoadFromFolder(String,TDataItem,Boolean) | Overloaded. Represents method LoadFromFolder(String,TDataItem,Boolean).
LoadItem(TBIReader,TDataItem) | Represents method LoadItem(TBIReader,TDataItem).
Save(TDataArray,TStream) | Overloaded. Represents method Save(TDataArray,TStream).
Save(TDataItem,String,TBIProgress) | Overloaded. Represents method Save(TDataItem,String,TBIProgress).
Save(TDataItem,TBIWriter,TBIProgress) | Overloaded. Represents method Save(TDataItem,TBIWriter,TBIProgress).
Save(TDataItem,TStream,TBIProgress) | Overloaded. Represents method Save(TDataItem,TStream,TBIProgress).
SaveToFolder(TDataItem,String,TBIProgress) | Overloaded. Represents method SaveToFolder(TDataItem,String,TBIProgress).
Top


TDataPersistence.DoLoad(TBIReader,TDataItem,Boolean,Boolean) Method

Summary

Represents method DoLoad(TBIReader,TDataItem,Boolean,Boolean).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure DoLoad(const Reader:TBIReader; const Data:TDataItem;
 const Children:Boolean; const ForceLoad:Boolean=False); static;

Parameters

Reader
Type: TBIReader

Data
Type: TDataItem

Children
Type: Boolean

ForceLoad
Type: Boolean

See Also

Reference

  • TDataPersistence
  • BI.Persist


TDataPersistence.Load(String,TDataItem,Boolean) Method

Summary

Represents method Load(String,TDataItem,Boolean).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Load(const FileName:String; const Data:TDataItem; const DelayLoad:Boolean=True); overload; static;

Parameters

FileName
Type: String

Data
Type: TDataItem

DelayLoad
Type: Boolean

See Also

Reference

  • TDataPersistence
  • BI.Persist


TDataPersistence.Load(TBIReader,TDataItem,Boolean) Method

Summary

Represents method Load(TBIReader,TDataItem,Boolean).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Load(const Reader:TBIReader; const Data:TDataItem; const DelayLoad:Boolean=True); overload; static;

Parameters

Reader
Type: TBIReader

Data
Type: TDataItem

DelayLoad
Type: Boolean

See Also

Reference

  • TDataPersistence
  • BI.Persist


TDataPersistence.Load(TStream,TDataArray) Method

Summary

Represents method Load(TStream,TDataArray).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Load(const Stream: TStream; const Items: TDataArray); overload; static;

Parameters

Stream
Type: TStream

Items
Type: TDataArray

See Also

Reference

  • TDataPersistence
  • BI.Persist


TDataPersistence.Load(TStream,TDataItem,Boolean) Method

Summary

Represents method Load(TStream,TDataItem,Boolean).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Load(const Stream:TStream; const Data:TDataItem; const DelayLoad:Boolean=True); overload; static;

Parameters

Stream
Type: TStream

Data
Type: TDataItem

DelayLoad
Type: Boolean

See Also

Reference

  • TDataPersistence
  • BI.Persist


TDataPersistence.Load(TStream,TInt32Array) Method

Summary

Represents method Load(TStream,TInt32Array).

Namespace: BI.Persist
Syntax
Delphi
protected
 class procedure Load(const Stream: TStream; out Index: TInt32Array); overload; static;

Parameters

Stream
Type: TStream

Index
Type: TInt32Array

See Also

Reference

  • TDataPersistence
  • BI.Persist


TDataPersistence.Load(TStream,TInt64Array) Method

Summary

Represents method Load(TStream,TInt64Array).

Namespace: BI.Persist
Syntax
Delphi
protected
 class procedure Load(const Stream: TStream; out Index: TInt64Array); overload; static;

Parameters

Stream
Type: TStream

Index
Type: TInt64Array

See Also

Reference

  • TDataPersistence
  • BI.Persist


TDataPersistence.LoadFromFolder(String,TDataItem,Boolean) Method

Summary

Represents method LoadFromFolder(String,TDataItem,Boolean).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure LoadFromFolder(const Folder:String; const Data:TDataItem; const DelayLoad:Boolean=True); overload; static;

Parameters

Folder
Type: String

Data
Type: TDataItem

DelayLoad
Type: Boolean

See Also

Reference

  • TDataPersistence
  • BI.Persist


TDataPersistence.LoadItem(TBIReader,TDataItem) Method

Summary

Represents method LoadItem(TBIReader,TDataItem).

Namespace: BI.Persist
Syntax
Delphi
protected
 class procedure LoadItem(const Reader:TBIReader; const AData:TDataItem); static;

Parameters

Reader
Type: TBIReader

AData
Type: TDataItem

See Also

Reference

  • TDataPersistence
  • BI.Persist


TDataPersistence.Save(TDataArray,TStream) Method

Summary

Represents method Save(TDataArray,TStream).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Save(const Items:TDataArray; const Stream:TStream); overload; static;

Parameters

Items
Type: TDataArray

Stream
Type: TStream

See Also

Reference

  • TDataPersistence
  • BI.Persist


TDataPersistence.Save(TDataItem,String,TBIProgress) Method

Summary

Represents method Save(TDataItem,String,TBIProgress).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Save(const Data:TDataItem; const FileName:String; const Progress:TBIProgress=nil); overload; static;

Parameters

Data
Type: TDataItem

FileName
Type: String

Progress
Type: TBIProgress

See Also

Reference

  • TDataPersistence
  • BI.Persist


TDataPersistence.Save(TDataItem,TBIWriter,TBIProgress) Method

Summary

Represents method Save(TDataItem,TBIWriter,TBIProgress).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Save(const Data:TDataItem; const Writer:TBIWriter; const Progress:TBIProgress=nil); overload; static;

Parameters

Data
Type: TDataItem

Writer
Type: TBIWriter

Progress
Type: TBIProgress

See Also

Reference

  • TDataPersistence
  • BI.Persist


TDataPersistence.Save(TDataItem,TStream,TBIProgress) Method

Summary

Represents method Save(TDataItem,TStream,TBIProgress).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Save(const Data:TDataItem; const Stream:TStream; const Progress:TBIProgress=nil); overload; static;

Parameters

Data
Type: TDataItem

Stream
Type: TStream

Progress
Type: TBIProgress

See Also

Reference

  • TDataPersistence
  • BI.Persist


TDataPersistence.SaveToFolder(TDataItem,String,TBIProgress) Method

Summary

Represents method SaveToFolder(TDataItem,String,TBIProgress).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure SaveToFolder(const Data:TDataItem; const Folder:String; const Progress:TBIProgress=nil); overload; static;

Parameters

Data
Type: TDataItem

Folder
Type: String

Progress
Type: TBIProgress

See Also

Reference

  • TDataPersistence
  • BI.Persist


TDataRelation Class

Summary

Represents type TDataRelation.

Namespace: BI.Persist
Inheritance Hierarchy
TCollectionItem
BI.Persist.TDataRelation
Syntax
Delphi
type
 TDataRelation=class(TCollectionItem)
 end;

The TDataRelation type exposes the following members.

Properties
Show:
Name | Description
Detail | Represents property Detail.
Master | Represents property Master.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
See Also

Reference

  • BI.Persist


TDataRelation Properties

Properties
Name | Description
Detail | Represents property Detail.
Master | Represents property Master.
Top


TDataRelation.Detail Property

Summary

Represents property Detail.

Namespace: BI.Persist
Syntax
Delphi
published
 property Detail:String read FDetail write FDetail;

Property Value

Type: String

See Also

Reference

  • TDataRelation
  • BI.Persist


TDataRelation.Master Property

Summary

Represents property Master.

Namespace: BI.Persist
Syntax
Delphi
published
 property Master:String read FMaster write FMaster;

Property Value

Type: String

See Also

Reference

  • TDataRelation
  • BI.Persist


TDataRelation Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TDataRelation.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Persist
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TDataRelation
  • BI.Persist


TDataRelations Class

Summary

Represents type TDataRelations.

Namespace: BI.Persist
Inheritance Hierarchy
TOwnedCollection
BI.Persist.TDataRelations
Syntax
Delphi
type
 TDataRelations=class(TOwnedCollection)
 end;

The TDataRelations type exposes the following members.

Properties
Show:
Name | Description
Item[Integer] | Represents property Item[Integer].
Top
Methods
Show:
Name | Description
Add(String,String) | Represents method Add(String,String).
Top
See Also

Reference

  • BI.Persist


TDataRelations Properties

Properties
Name | Description
Item[Integer] | Represents property Item[Integer].
Top


TDataRelations.Item[Integer] Property

Summary

Represents property Item[Integer].

Namespace: BI.Persist
Syntax
Delphi
public
 property Item[const Index:Integer]:TDataRelation read Get write Put; default;

Parameters

Index
Type: Integer

Property Value

Type: TDataRelation

See Also

Reference

  • TDataRelations
  • BI.Persist


TDataRelations Methods

Methods
Name | Description
Add(String,String) | Represents method Add(String,String).
Top


TDataRelations.Add(String,String) Method

Summary

Represents method Add(String,String).

Namespace: BI.Persist
Syntax
Delphi
public
 function Add(const AMaster,ADetail:String):TDataRelation;

Parameters

AMaster
Type: String

ADetail
Type: String

Return Value

Type: TDataRelation

See Also

Reference

  • TDataRelations
  • BI.Persist


TDelayHandlerFolder Class

Summary

Represents type TDelayHandlerFolder.

Namespace: BI.Persist
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Persist.TDataDelayProvider
BI.Persist.TDelayHandlerFolder
Syntax
Delphi
type
 TDelayHandlerFolder=class(TDataDelayProvider)
 end;

The TDelayHandlerFolder type exposes the following members.

Constructors
Show:
Name | Description
CreateFolder(String) | Initializes a new instance of the TDelayHandlerFolder class.
Top
Methods
Show:
Name | Description
GetStream(TDataArray) | Represents method GetStream(TDataArray). (Overrides TDataProvider.GetStream(TDataArray).)
GetStream(TDataItem,TDataItem) | Represents method GetStream(TDataItem,TDataItem). (Overrides TDataProvider.GetStream(TDataItem,TDataItem).)
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Top
See Also

Reference

  • BI.Persist


TDelayHandlerFolder Constructors

Constructors
Name | Description
CreateFolder(String) | Initializes a new instance of the TDelayHandlerFolder class.
Top


TDelayHandlerFolder.CreateFolder(String) Constructor

Summary

Initializes a new instance of the TDelayHandlerFolder class.

Namespace: BI.Persist
Syntax
Delphi
public
 Constructor CreateFolder(const AFolder:String);

Parameters

AFolder
Type: String

See Also

Reference

  • TDelayHandlerFolder
  • BI.Persist


TDelayHandlerFolder Methods

Methods
Name | Description
GetStream(TDataArray) | Represents method GetStream(TDataArray). (Overrides TDataProvider.GetStream(TDataArray).)
GetStream(TDataItem,TDataItem) | Represents method GetStream(TDataItem,TDataItem). (Overrides TDataProvider.GetStream(TDataItem,TDataItem).)
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Top


TDelayHandlerFolder.GetStream(TDataItem,TDataItem) Method

Summary

Represents method GetStream(TDataItem,TDataItem).

Namespace: BI.Persist
Syntax
Delphi
protected
 function GetStream(const AData,ANext:TDataItem):TStream; override;

Parameters

AData
Type: TDataItem

ANext
Type: TDataItem

Return Value

Type: TStream

Overrides

TDataProvider.GetStream(TDataItem,TDataItem)
See Also

Reference

  • TDelayHandlerFolder
  • BI.Persist


TDelayHandlerFolder.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Persist
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TDelayHandlerFolder
  • BI.Persist


TDelayHandlerStream Class

Summary

Represents type TDelayHandlerStream.

Namespace: BI.Persist
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Persist.TDataDelayProvider
BI.Persist.TDelayHandlerStream
Syntax
Delphi
type
 TDelayHandlerStream=class(TDataDelayProvider)
 end;

The TDelayHandlerStream type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TDelayHandlerStream class.
CreateStream(TStream) | Initializes a new instance of the TDelayHandlerStream class.
Destroy | Represents the destructor of the TDelayHandlerStream class. (Overrides TDataProvider.Destroy.)
Top
Properties
Show:
Name | Description
Stream | Represents property Stream.
Top
Methods
Show:
Name | Description
GetStream(TDataArray) | Represents method GetStream(TDataArray). (Overrides TDataProvider.GetStream(TDataArray).)
GetStream(TDataItem,TDataItem) | Represents method GetStream(TDataItem,TDataItem). (Overrides TDataProvider.GetStream(TDataItem,TDataItem).)
Init(TObject) | Represents method Init(TObject).
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Reset | Represents method Reset.
Top
Fields
Show:
Name | Description
Reader | Represents field Reader.
Top
See Also

Reference

  • BI.Persist


TDelayHandlerStream Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TDelayHandlerStream class.
CreateStream(TStream) | Initializes a new instance of the TDelayHandlerStream class.
Destroy | Represents the destructor of the TDelayHandlerStream class. (Overrides TDataProvider.Destroy.)
Top


TDelayHandlerStream.Create(TComponent) Constructor

Summary

Initializes a new instance of the TDelayHandlerStream class.

Namespace: BI.Persist
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TDelayHandlerStream
  • BI.Persist


TDelayHandlerStream.CreateStream(TStream) Constructor

Summary

Initializes a new instance of the TDelayHandlerStream class.

Namespace: BI.Persist
Syntax
Delphi
public
 Constructor CreateStream(const AStream:TStream);

Parameters

AStream
Type: TStream

See Also

Reference

  • TDelayHandlerStream
  • BI.Persist


TDelayHandlerStream.Destroy Destructor

Summary

Represents the destructor of the TDelayHandlerStream class.

Namespace: BI.Persist
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TDataProvider.Destroy
See Also

Reference

  • TDelayHandlerStream
  • BI.Persist


TDelayHandlerStream Properties

Properties
Name | Description
Stream | Represents property Stream.
Top


TDelayHandlerStream.Stream Property

Summary

Represents property Stream.

Namespace: BI.Persist
Syntax
Delphi
public
 property Stream:TStream read FStream;

Property Value

Type: TStream

See Also

Reference

  • TDelayHandlerStream
  • BI.Persist


TDelayHandlerStream Methods

Methods
Name | Description
GetStream(TDataArray) | Represents method GetStream(TDataArray). (Overrides TDataProvider.GetStream(TDataArray).)
GetStream(TDataItem,TDataItem) | Represents method GetStream(TDataItem,TDataItem). (Overrides TDataProvider.GetStream(TDataItem,TDataItem).)
Init(TObject) | Represents method Init(TObject).
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Reset | Represents method Reset.
Top


TDelayHandlerStream.GetStream(TDataItem,TDataItem) Method

Summary

Represents method GetStream(TDataItem,TDataItem).

Namespace: BI.Persist
Syntax
Delphi
public
 function GetStream(const AData,ANext:TDataItem):TStream; override;

Parameters

AData
Type: TDataItem

ANext
Type: TDataItem

Return Value

Type: TStream

Overrides

TDataProvider.GetStream(TDataItem,TDataItem)
See Also

Reference

  • TDelayHandlerStream
  • BI.Persist


TDelayHandlerStream.Init(TObject) Method

Summary

Represents method Init(TObject).

Namespace: BI.Persist
Syntax
Delphi
public
 procedure Init(const Tag:TObject);

Parameters

Tag
Type: TObject

See Also

Reference

  • TDelayHandlerStream
  • BI.Persist


TDelayHandlerStream.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Persist
Syntax
Delphi
public
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TDelayHandlerStream
  • BI.Persist


TDelayHandlerStream.Reset Method

Summary

Represents method Reset.

Namespace: BI.Persist
Syntax
Delphi
public
 procedure Reset;
See Also

Reference

  • TDelayHandlerStream
  • BI.Persist


TDelayHandlerStream Fields

Fields
Name | Description
Reader | Represents field Reader.
Top


TDelayHandlerStream.Reader Field

Summary

Represents field Reader.

Namespace: BI.Persist
Syntax
Delphi
public
 Reader : TBIReader;

Field Value

Type: TBIReader

See Also

Reference

  • TDelayHandlerStream
  • BI.Persist


TEnvironment Class

Summary

Represents type TEnvironment.

Namespace: BI.Persist
Inheritance Hierarchy
TObject
BI.Persist.TEnvironment
Syntax
Delphi
type
 TEnvironment=class
 end;

The TEnvironment type exposes the following members.

Methods
Show:
Name | Description
Add(String,TDataItem) | Represents method Add(String,TDataItem).
Find(String,String) | Represents method Find(String,String).
TryKeepMemory | Represents method TryKeepMemory.
Top
Fields
Show:
Name | Description
Data | Represents field Data.
Identifiers | Represents field Identifiers.
Top
See Also

Reference

  • BI.Persist


TEnvironment Methods

Methods
Name | Description
Add(String,TDataItem) | Represents method Add(String,TDataItem).
Find(String,String) | Represents method Find(String,String).
TryKeepMemory | Represents method TryKeepMemory.
Top


TEnvironment.Add(String,TDataItem) Method

Summary

Represents method Add(String,TDataItem).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Add(const AStore:String; const AData:TDataItem); static;

Parameters

AStore
Type: String

AData
Type: TDataItem

See Also

Reference

  • TEnvironment
  • BI.Persist


TEnvironment.Find(String,String) Method

Summary

Represents method Find(String,String).

Namespace: BI.Persist
Syntax
Delphi
public
 class function Find(const AStore,AName:String):TDataItem; static;

Parameters

AStore
Type: String

AName
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TEnvironment
  • BI.Persist


TEnvironment.TryKeepMemory Method

Summary

Represents method TryKeepMemory.

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure TryKeepMemory; static;
See Also

Reference

  • TEnvironment
  • BI.Persist


TEnvironment Fields

Fields
Name | Description
Data | Represents field Data.
Identifiers | Represents field Identifiers.
Top


TEnvironment.Data Field

Summary

Represents field Data.

Namespace: BI.Persist
Syntax
Delphi
public
 class var Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TEnvironment
  • BI.Persist


TEnvironment.Identifiers Field

Summary

Represents field Identifiers.

Namespace: BI.Persist
Syntax
Delphi
public
 class var Identifiers : TIdentifiers;

Field Value

Type: TIdentifiers

See Also

Reference

  • TEnvironment
  • BI.Persist


TPersistence Class

Summary

Represents type TPersistence.

Namespace: BI.Persist
Inheritance Hierarchy
TObject
BI.Persist.TPersistence
Syntax
Delphi
type
 TPersistence=class
 end;

The TPersistence type exposes the following members.

Constants
Show:
Name | Description
DefaultBufferSize | Represents constant DefaultBufferSize.
Extension | Represents constant Extension.
SupportedFrom | Represents constant SupportedFrom.
Version | Represents constant Version.
Top
Methods
Show:
Name | Description
CreateFile(String) | Represents method CreateFile(String).
Load(String) | Overloaded. Represents method Load(String).
Load(TBIReader) | Overloaded. Represents method Load(TBIReader).
Load(TStream) | Overloaded. Represents method Load(TStream).
OpenFile(String) | Represents method OpenFile(String).
ReadItem(TBIReader,TDataItem) | Represents method ReadItem(TBIReader,TDataItem).
Save(TDataItem,String) | Overloaded. Represents method Save(TDataItem,String).
Save(TDataItem,TBIWriter) | Overloaded. Represents method Save(TDataItem,TBIWriter).
Save(TDataItem,TStream) | Overloaded. Represents method Save(TDataItem,TStream).
WriteItem(TBIWriter,TDataItem) | Represents method WriteItem(TBIWriter,TDataItem).
Top
Fields
Show:
Name | Description
HideErrors | Represents field HideErrors.
Raw | Represents field Raw.
Top
See Also

Reference

  • BI.Persist


TPersistence Constants

Constants
Name | Description
DefaultBufferSize | Represents constant DefaultBufferSize.
Extension | Represents constant Extension.
SupportedFrom | Represents constant SupportedFrom.
Version | Represents constant Version.
Top


TPersistence.DefaultBufferSize Constant

Summary

Represents constant DefaultBufferSize.

Namespace: BI.Persist
Syntax
Delphi
public
 DefaultBufferSize=32768;

Value

Type: Word

See Also

Reference

  • TPersistence
  • BI.Persist


TPersistence.Extension Constant

Summary

Represents constant Extension.

Namespace: BI.Persist
Syntax
Delphi
public
 Extension='.bi';

Value

Type: string

See Also

Reference

  • TPersistence
  • BI.Persist


TPersistence.SupportedFrom Constant

Summary

Represents constant SupportedFrom.

Namespace: BI.Persist
Syntax
Delphi
public
 SupportedFrom=7;

Value

Type: ShortInt

See Also

Reference

  • TPersistence
  • BI.Persist


TPersistence.Version Constant

Summary

Represents constant Version.

Namespace: BI.Persist
Syntax
Delphi
public
 Version=8;

Value

Type: ShortInt

See Also

Reference

  • TPersistence
  • BI.Persist


TPersistence Methods

Methods
Name | Description
CreateFile(String) | Represents method CreateFile(String).
Load(String) | Overloaded. Represents method Load(String).
Load(TBIReader) | Overloaded. Represents method Load(TBIReader).
Load(TStream) | Overloaded. Represents method Load(TStream).
OpenFile(String) | Represents method OpenFile(String).
ReadItem(TBIReader,TDataItem) | Represents method ReadItem(TBIReader,TDataItem).
Save(TDataItem,String) | Overloaded. Represents method Save(TDataItem,String).
Save(TDataItem,TBIWriter) | Overloaded. Represents method Save(TDataItem,TBIWriter).
Save(TDataItem,TStream) | Overloaded. Represents method Save(TDataItem,TStream).
WriteItem(TBIWriter,TDataItem) | Represents method WriteItem(TBIWriter,TDataItem).
Top


TPersistence.CreateFile(String) Method

Summary

Represents method CreateFile(String).

Namespace: BI.Persist
Syntax
Delphi
public
 class function CreateFile(const FileName:String):TFileStream; static;

Parameters

FileName
Type: String

Return Value

Type: TFileStream

See Also

Reference

  • TPersistence
  • BI.Persist


TPersistence.Load(String) Method

Summary

Represents method Load(String).

Namespace: BI.Persist
Syntax
Delphi
public
 class function Load(const FileName:String):TDataItem; overload; static;

Parameters

FileName
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TPersistence
  • BI.Persist


TPersistence.Load(TBIReader) Method

Summary

Represents method Load(TBIReader).

Namespace: BI.Persist
Syntax
Delphi
protected
 class function Load(const Reader:TBIReader):TDataItem; overload; static;

Parameters

Reader
Type: TBIReader

Return Value

Type: TDataItem

See Also

Reference

  • TPersistence
  • BI.Persist


TPersistence.Load(TStream) Method

Summary

Represents method Load(TStream).

Namespace: BI.Persist
Syntax
Delphi
public
 class function Load(const Stream:TStream):TDataItem; overload; static;

Parameters

Stream
Type: TStream

Return Value

Type: TDataItem

See Also

Reference

  • TPersistence
  • BI.Persist


TPersistence.OpenFile(String) Method

Summary

Represents method OpenFile(String).

Namespace: BI.Persist
Syntax
Delphi
public
 class function OpenFile(const FileName:String):TFileStream; static;

Parameters

FileName
Type: String

Return Value

Type: TFileStream

See Also

Reference

  • TPersistence
  • BI.Persist


TPersistence.ReadItem(TBIReader,TDataItem) Method

Summary

Represents method ReadItem(TBIReader,TDataItem).

Namespace: BI.Persist
Syntax
Delphi
protected
 class procedure ReadItem(const Reader: TBIReader; const AData: TDataItem); static;

Parameters

Reader
Type: TBIReader

AData
Type: TDataItem

See Also

Reference

  • TPersistence
  • BI.Persist


TPersistence.Save(TDataItem,String) Method

Summary

Represents method Save(TDataItem,String).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Save(const Data:TDataItem; const FileName:String); overload; static;

Parameters

Data
Type: TDataItem

FileName
Type: String

See Also

Reference

  • TPersistence
  • BI.Persist


TPersistence.Save(TDataItem,TBIWriter) Method

Summary

Represents method Save(TDataItem,TBIWriter).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Save(const Data:TDataItem; const Writer:TBIWriter); overload; static;

Parameters

Data
Type: TDataItem

Writer
Type: TBIWriter

See Also

Reference

  • TPersistence
  • BI.Persist


TPersistence.Save(TDataItem,TStream) Method

Summary

Represents method Save(TDataItem,TStream).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Save(const Data:TDataItem; const Stream:TStream); overload; static;

Parameters

Data
Type: TDataItem

Stream
Type: TStream

See Also

Reference

  • TPersistence
  • BI.Persist


TPersistence.WriteItem(TBIWriter,TDataItem) Method

Summary

Represents method WriteItem(TBIWriter,TDataItem).

Namespace: BI.Persist
Syntax
Delphi
protected
 class procedure WriteItem(const Writer: TBIWriter; const AData: TDataItem); static;

Parameters

Writer
Type: TBIWriter

AData
Type: TDataItem

See Also

Reference

  • TPersistence
  • BI.Persist


TPersistence Fields

Fields
Name | Description
HideErrors | Represents field HideErrors.
Raw | Represents field Raw.
Top


TPersistence.HideErrors Field

Summary

Represents field HideErrors.

Namespace: BI.Persist
Syntax
Delphi
public
 class var HideErrors : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TPersistence
  • BI.Persist


TPersistence.Raw Field

Summary

Represents field Raw.

Namespace: BI.Persist
Syntax
Delphi
public
 class var Raw : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TPersistence
  • BI.Persist


TStore Class

Summary

Represents type TStore.

Namespace: BI.Persist
Inheritance Hierarchy
TObject
BI.Persist.TStore
Syntax
Delphi
type
 TStore=class
 end;

The TStore type exposes the following members.

Properties
Show:
Name | Description
DefaultName | Represents property DefaultName.
Top
Methods
Show:
Name | Description
AllData(String) | Overloaded. Represents method AllData(String).
DataToStream(String,Boolean) | Overloaded. Represents method DataToStream(String,Boolean).
DataToStream(String,String,Boolean) | Overloaded. Represents method DataToStream(String,String,Boolean).
DataToStream(TDataItem,Boolean) | Overloaded. Represents method DataToStream(TDataItem,Boolean).
DefinitionOf(string) | Overloaded. Represents method DefinitionOf(string).
DefinitionOf(string,string) | Overloaded. Represents method DefinitionOf(string,string).
FullPath(string) | Overloaded. Represents method FullPath(string).
FullPath(string,string) | Overloaded. Represents method FullPath(string,string).
GetDefinition(String,String) | Represents method GetDefinition(String,String).
IsRemote(String) | Represents method IsRemote(String).
Load(String) | Overloaded. Represents method Load(String).
Load(String,String,TBIErrorProc) | Overloaded. Represents method Load(String,String,TBIErrorProc).
NameOf(String) | Represents method NameOf(String).
NotRegistered(String) | Represents method NotRegistered(String).
OriginOf(TDataItem,String,TDataItem) | Represents method OriginOf(TDataItem,String,TDataItem).
OriginToData(TDataItem,String,String,TBIErrorProc) | Represents method OriginToData(TDataItem,String,String,TBIErrorProc).
PathOf(String) | Represents method PathOf(String).
RemoveData(String,String) | Represents method RemoveData(String,String).
Rename(String,String,String) | Represents method Rename(String,String,String).
Save(TDataItem,String,Boolean,TBIProgress) | Overloaded. Represents method Save(TDataItem,String,Boolean,TBIProgress).
StoreOf(TDataItem) | Represents method StoreOf(TDataItem).
UnLoad(String,String) | Represents method UnLoad(String,String).
UnLoadAll | Represents method UnLoadAll.
ZipStream(TStream) | Represents method ZipStream(TStream).
Top
See Also

Reference

  • BI.Persist


TStore Properties

Properties
Name | Description
DefaultName | Represents property DefaultName.
Top


TStore.DefaultName Property

Summary

Represents property DefaultName.

Namespace: BI.Persist
Syntax
Delphi
public
 class property DefaultName:String read GetDefaultName write SetDefaultName;

Property Value

Type: String

See Also

Reference

  • TStore
  • BI.Persist


TStore Methods

Methods
Name | Description
AllData(String) | Overloaded. Represents method AllData(String).
DataToStream(String,Boolean) | Overloaded. Represents method DataToStream(String,Boolean).
DataToStream(String,String,Boolean) | Overloaded. Represents method DataToStream(String,String,Boolean).
DataToStream(TDataItem,Boolean) | Overloaded. Represents method DataToStream(TDataItem,Boolean).
DefinitionOf(string) | Overloaded. Represents method DefinitionOf(string).
DefinitionOf(string,string) | Overloaded. Represents method DefinitionOf(string,string).
FullPath(string) | Overloaded. Represents method FullPath(string).
FullPath(string,string) | Overloaded. Represents method FullPath(string,string).
GetDefinition(String,String) | Represents method GetDefinition(String,String).
IsRemote(String) | Represents method IsRemote(String).
Load(String) | Overloaded. Represents method Load(String).
Load(String,String,TBIErrorProc) | Overloaded. Represents method Load(String,String,TBIErrorProc).
NameOf(String) | Represents method NameOf(String).
NotRegistered(String) | Represents method NotRegistered(String).
OriginOf(TDataItem,String,TDataItem) | Represents method OriginOf(TDataItem,String,TDataItem).
OriginToData(TDataItem,String,String,TBIErrorProc) | Represents method OriginToData(TDataItem,String,String,TBIErrorProc).
PathOf(String) | Represents method PathOf(String).
RemoveData(String,String) | Represents method RemoveData(String,String).
Rename(String,String,String) | Represents method Rename(String,String,String).
Save(TDataItem,String,Boolean,TBIProgress) | Overloaded. Represents method Save(TDataItem,String,Boolean,TBIProgress).
StoreOf(TDataItem) | Represents method StoreOf(TDataItem).
UnLoad(String,String) | Represents method UnLoad(String,String).
UnLoadAll | Represents method UnLoadAll.
ZipStream(TStream) | Represents method ZipStream(TStream).
Top


TStore.AllData(String) Method

Summary

Represents method AllData(String).

Namespace: BI.Persist
Syntax
Delphi
public
 class function AllData(const AStore:String=''):TStringArray; overload; static;

Parameters

AStore
Type: String

Return Value

Type: TStringArray

See Also

Reference

  • TStore
  • BI.Persist


TStore.DataToStream(String,Boolean) Method

Summary

Represents method DataToStream(String,Boolean).

Namespace: BI.Persist
Syntax
Delphi
public
 class function DataToStream(const AName:String; const Zip:Boolean=False):TStream; overload; static;

Parameters

AName
Type: String

Zip
Type: Boolean

Return Value

Type: TStream

See Also

Reference

  • TStore
  • BI.Persist


TStore.DataToStream(String,String,Boolean) Method

Summary

Represents method DataToStream(String,String,Boolean).

Namespace: BI.Persist
Syntax
Delphi
public
 class function DataToStream(const APath,AName:String; const Zip:Boolean=False):TStream; overload; static;

Parameters

APath
Type: String

AName
Type: String

Zip
Type: Boolean

Return Value

Type: TStream

See Also

Reference

  • TStore
  • BI.Persist


TStore.DataToStream(TDataItem,Boolean) Method

Summary

Represents method DataToStream(TDataItem,Boolean).

Namespace: BI.Persist
Syntax
Delphi
public
 class function DataToStream(const AData:TDataItem; const Zip:Boolean=False):TStream; overload; static;

Parameters

AData
Type: TDataItem

Zip
Type: Boolean

Return Value

Type: TStream

See Also

Reference

  • TStore
  • BI.Persist


TStore.DefinitionOf(string) Method

Summary

Represents method DefinitionOf(string).

Namespace: BI.Persist
Syntax
Delphi
public
 class function DefinitionOf(const Name:string):String; overload; static;

Parameters

Name
Type: string

Return Value

Type: String

See Also

Reference

  • TStore
  • BI.Persist


TStore.DefinitionOf(string,string) Method

Summary

Represents method DefinitionOf(string,string).

Namespace: BI.Persist
Syntax
Delphi
public
 class function DefinitionOf(const AStore,Name: string): String; overload; static;

Parameters

AStore
Type: string

Name
Type: string

Return Value

Type: String

See Also

Reference

  • TStore
  • BI.Persist


TStore.FullPath(string) Method

Summary

Represents method FullPath(string).

Namespace: BI.Persist
Syntax
Delphi
public
 class function FullPath(const FileName:string):String; overload; static;

Parameters

FileName
Type: string

Return Value

Type: String

See Also

Reference

  • TStore
  • BI.Persist


TStore.FullPath(string,string) Method

Summary

Represents method FullPath(string,string).

Namespace: BI.Persist
Syntax
Delphi
public
 class function FullPath(const AStore,FileName: string): String; overload; static;

Parameters

AStore
Type: string

FileName
Type: string

Return Value

Type: String

See Also

Reference

  • TStore
  • BI.Persist


TStore.GetDefinition(String,String) Method

Summary

Represents method GetDefinition(String,String).

Namespace: BI.Persist
Syntax
Delphi
public
 class function GetDefinition(const AStore,AName:String):TDataDefinition; static;

Parameters

AStore
Type: String

AName
Type: String

Return Value

Type: TDataDefinition

See Also

Reference

  • TStore
  • BI.Persist


TStore.IsRemote(String) Method

Summary

Represents method IsRemote(String).

Namespace: BI.Persist
Syntax
Delphi
public
 class function IsRemote(const AStore:String):Boolean; static;

Parameters

AStore
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TStore
  • BI.Persist


TStore.Load(String) Method

Summary

Represents method Load(String).

Namespace: BI.Persist
Syntax
Delphi
public
 class function Load(const AName:String):TDataItem; overload; static;

Parameters

AName
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TStore
  • BI.Persist


TStore.Load(String,String,TBIErrorProc) Method

Summary

Represents method Load(String,String,TBIErrorProc).

Namespace: BI.Persist
Syntax
Delphi
public
 class function Load(const AStore,AName:String; const OnError:TBIErrorProc=nil):TDataItem; overload; static;

Parameters

AStore
Type: String

AName
Type: String

OnError
Type: TBIErrorProc

Return Value

Type: TDataItem

See Also

Reference

  • TStore
  • BI.Persist


TStore.NameOf(String) Method

Summary

Represents method NameOf(String).

Namespace: BI.Persist
Syntax
Delphi
public
 class function NameOf(const FileName:String):String; static;

Parameters

FileName
Type: String

Return Value

Type: String

See Also

Reference

  • TStore
  • BI.Persist


TStore.NotRegistered(String) Method

Summary

Represents method NotRegistered(String).

Namespace: BI.Persist
Syntax
Delphi
public
 class function NotRegistered(const AName: String):EBIException;

Parameters

AName
Type: String

Return Value

Type: EBIException

See Also

Reference

  • TStore
  • BI.Persist


TStore.OriginOf(TDataItem,String,TDataItem) Method

Summary

Represents method OriginOf(TDataItem,String,TDataItem).

Namespace: BI.Persist
Syntax
Delphi
public
 class function OriginOf(const AData:TDataItem;
 const DefaultStore:String;
 const RelativeTo:TDataItem=nil):String; static;

Parameters

AData
Type: TDataItem

DefaultStore
Type: String

RelativeTo
Type: TDataItem

Return Value

Type: String

See Also

Reference

  • TStore
  • BI.Persist


TStore.OriginToData(TDataItem,String,String,TBIErrorProc) Method

Summary

Represents method OriginToData(TDataItem,String,String,TBIErrorProc).

Namespace: BI.Persist
Syntax
Delphi
public
 class function OriginToData(const AData:TDataItem; const AStore,AOrigin:String;
 const Error:TBIErrorProc=nil):TDataItem; static;

Parameters

AData
Type: TDataItem

AStore
Type: String

AOrigin
Type: String

Error
Type: TBIErrorProc

Return Value

Type: TDataItem

See Also

Reference

  • TStore
  • BI.Persist


TStore.PathOf(String) Method

Summary

Represents method PathOf(String).

Namespace: BI.Persist
Syntax
Delphi
public
 class function PathOf(const AName:String):String; static;

Parameters

AName
Type: String

Return Value

Type: String

See Also

Reference

  • TStore
  • BI.Persist


TStore.RemoveData(String,String) Method

Summary

Represents method RemoveData(String,String).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure RemoveData(const AStore,AName:String); static;

Parameters

AStore
Type: String

AName
Type: String

See Also

Reference

  • TStore
  • BI.Persist


TStore.Rename(String,String,String) Method

Summary

Represents method Rename(String,String,String).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Rename(const AStore,AOld,ANew:String); static;

Parameters

AStore
Type: String

AOld
Type: String

ANew
Type: String

See Also

Reference

  • TStore
  • BI.Persist


TStore.Save(TDataItem,String,Boolean,TBIProgress) Method

Summary

Represents method Save(TDataItem,String,Boolean,TBIProgress).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Save(const Data:TDataItem; const AFileName:String;
 const AsFolder:Boolean=False;
 const Progress:TBIProgress=nil); overload; static;

Parameters

Data
Type: TDataItem

AFileName
Type: String

AsFolder
Type: Boolean

Progress
Type: TBIProgress

See Also

Reference

  • TStore
  • BI.Persist


TStore.StoreOf(TDataItem) Method

Summary

Represents method StoreOf(TDataItem).

Namespace: BI.Persist
Syntax
Delphi
public
 class function StoreOf(const AData:TDataItem):TDataItem; static;

Parameters

AData
Type: TDataItem

Return Value

Type: TDataItem

See Also

Reference

  • TStore
  • BI.Persist


TStore.UnLoad(String,String) Method

Summary

Represents method UnLoad(String,String).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure UnLoad(const AStore,AName:String); static;

Parameters

AStore
Type: String

AName
Type: String

See Also

Reference

  • TStore
  • BI.Persist


TStore.UnLoadAll Method

Summary

Represents method UnLoadAll.

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure UnLoadAll; static;
See Also

Reference

  • TStore
  • BI.Persist


TStore.ZipStream(TStream) Method

Summary

Represents method ZipStream(TStream).

Namespace: BI.Persist
Syntax
Delphi
public
 class function ZipStream(const AStream: TStream): TStream; static;

Parameters

AStream
Type: TStream

Return Value

Type: TStream

See Also

Reference

  • TStore
  • BI.Persist


TStores Class

Summary

Represents type TStores.

Namespace: BI.Persist
Inheritance Hierarchy
TObject
BI.Persist.TStores
Syntax
Delphi
type
 TStores=class
 end;

The TStores type exposes the following members.

Methods
Show:
Name | Description
Add(String,String) | Represents method Add(String,String).
All(Integer) | Represents method All(Integer).
AllTo(TStrings) | Represents method AllTo(TStrings).
ChangeName(String,String) | Represents method ChangeName(String,String).
ChangePath(String,String) | Represents method ChangePath(String,String).
Count | Represents method Count.
Exists(String) | Represents method Exists(String).
GlobalCache | Represents method GlobalCache.
IndexOf(String) | Represents method IndexOf(String).
NewName | Represents method NewName.
Remove(String) | Represents method Remove(String).
Save(Integer,String,String) | Overloaded. Represents method Save(Integer,String,String).
Save(TStringArray) | Overloaded. Represents method Save(TStringArray).
Top
See Also

Reference

  • BI.Persist


TStores Methods

Methods
Name | Description
Add(String,String) | Represents method Add(String,String).
All(Integer) | Represents method All(Integer).
AllTo(TStrings) | Represents method AllTo(TStrings).
ChangeName(String,String) | Represents method ChangeName(String,String).
ChangePath(String,String) | Represents method ChangePath(String,String).
Count | Represents method Count.
Exists(String) | Represents method Exists(String).
GlobalCache | Represents method GlobalCache.
IndexOf(String) | Represents method IndexOf(String).
NewName | Represents method NewName.
Remove(String) | Represents method Remove(String).
Save(Integer,String,String) | Overloaded. Represents method Save(Integer,String,String).
Save(TStringArray) | Overloaded. Represents method Save(TStringArray).
Top


TStores.Add(String,String) Method

Summary

Represents method Add(String,String).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Add(const AName,AOrigin:String); static;

Parameters

AName
Type: String

AOrigin
Type: String

See Also

Reference

  • TStores
  • BI.Persist


TStores.All(Integer) Method

Summary

Represents method All(Integer).

Namespace: BI.Persist
Syntax
Delphi
public
 class function All(const APart:Integer=0):TStringArray; static;

Parameters

APart
Type: Integer

Return Value

Type: TStringArray

See Also

Reference

  • TStores
  • BI.Persist


TStores.AllTo(TStrings) Method

Summary

Represents method AllTo(TStrings).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure AllTo(const Items:TStrings); static;

Parameters

Items
Type: TStrings

See Also

Reference

  • TStores
  • BI.Persist


TStores.ChangeName(String,String) Method

Summary

Represents method ChangeName(String,String).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure ChangeName(const AOld,ANew:String); static;

Parameters

AOld
Type: String

ANew
Type: String

See Also

Reference

  • TStores
  • BI.Persist


TStores.ChangePath(String,String) Method

Summary

Represents method ChangePath(String,String).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure ChangePath(const AName,AOrigin:String); static;

Parameters

AName
Type: String

AOrigin
Type: String

See Also

Reference

  • TStores
  • BI.Persist


TStores.Count Method

Summary

Represents method Count.

Namespace: BI.Persist
Syntax
Delphi
public
 class function Count:Integer; static;

Return Value

Type: Integer

See Also

Reference

  • TStores
  • BI.Persist


TStores.Exists(String) Method

Summary

Represents method Exists(String).

Namespace: BI.Persist
Syntax
Delphi
public
 class function Exists(const AName:String):Boolean; static;

Parameters

AName
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TStores
  • BI.Persist


TStores.GlobalCache Method

Summary

Represents method GlobalCache.

Namespace: BI.Persist
Syntax
Delphi
public
 class function GlobalCache:TDataItem; static;

Return Value

Type: TDataItem

See Also

Reference

  • TStores
  • BI.Persist


TStores.IndexOf(String) Method

Summary

Represents method IndexOf(String).

Namespace: BI.Persist
Syntax
Delphi
public
 class function IndexOf(const AName:String):Integer; static;

Parameters

AName
Type: String

Return Value

Type: Integer

See Also

Reference

  • TStores
  • BI.Persist


TStores.NewName Method

Summary

Represents method NewName.

Namespace: BI.Persist
Syntax
Delphi
public
 class function NewName:String; static;

Return Value

Type: String

See Also

Reference

  • TStores
  • BI.Persist


TStores.Remove(String) Method

Summary

Represents method Remove(String).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Remove(const AName:String); static;

Parameters

AName
Type: String

See Also

Reference

  • TStores
  • BI.Persist


TStores.Save(Integer,String,String) Method

Summary

Represents method Save(Integer,String,String).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Save(const Index:Integer; const AName,AOrigin:String); overload; static;

Parameters

Index
Type: Integer

AName
Type: String

AOrigin
Type: String

See Also

Reference

  • TStores
  • BI.Persist


TStores.Save(TStringArray) Method

Summary

Represents method Save(TStringArray).

Namespace: BI.Persist
Syntax
Delphi
public
 class procedure Save(const S:TStringArray); overload; static;

Parameters

S
Type: TStringArray

See Also

Reference

  • TStores
  • BI.Persist


BI.Persist Records

Records
Name | Description
TIdentifiers | Represents type TIdentifiers.
TRefreshSettings | Represents type TRefreshSettings.
Top


TIdentifiers Record

Summary

Represents type TIdentifiers.

Namespace: BI.Persist
Syntax
Delphi
type
 TIdentifiers=record
 end;
See Also

Reference

  • BI.Persist


TRefreshSettings Record

Summary

Represents type TRefreshSettings.

Namespace: BI.Persist
Syntax
Delphi
type
 TRefreshSettings=record
 end;

The TRefreshSettings type exposes the following members.

Fields
Show:
Name | Description
Enabled | Represents field Enabled.
Period | Represents field Period.
Units | Represents field Units.
Top
See Also

Reference

  • BI.Persist


TRefreshSettings Fields

Fields
Name | Description
Enabled | Represents field Enabled.
Period | Represents field Period.
Units | Represents field Units.
Top


TRefreshSettings.Enabled Field

Summary

Represents field Enabled.

Namespace: BI.Persist
Syntax
Delphi
public
 Enabled : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TRefreshSettings
  • BI.Persist


TRefreshSettings.Period Field

Summary

Represents field Period.

Namespace: BI.Persist
Syntax
Delphi
public
 Period : Integer;

Field Value

Type: Integer

See Also

Reference

  • TRefreshSettings
  • BI.Persist


TRefreshSettings.Units Field

Summary

Represents field Units.

Namespace: BI.Persist
Syntax
Delphi
public
 Units : TRefreshUnit;

Field Value

Type: TRefreshUnit

See Also

Reference

  • TRefreshSettings
  • BI.Persist


BI.Persist Enumerations

Enumerations
Name | Description
TDataDefinitionKind | Represents type TDataDefinitionKind.
TRefreshUnit | Represents type TRefreshUnit.
Top


TDataDefinitionKind Enumeration

Summary

Represents type TDataDefinitionKind.

Namespace: BI.Persist
Syntax
Delphi
type
 TDataDefinitionKind=(Files,Database,Web,Manual,Unknown);

The TDataDefinitionKind type exposes the following members.

Members
Show:
Name | Description
Database | Represents constant Database.
Files | Represents constant Files.
Manual | Represents constant Manual.
Unknown | Represents constant Unknown.
Web | Represents constant Web.
Top
See Also

Reference

  • BI.Persist


TRefreshUnit Enumeration

Summary

Represents type TRefreshUnit.

Namespace: BI.Persist
Syntax
Delphi
type
 TRefreshUnit=(Seconds,Minutes,Hours,Days,Weeks,Months,Years);

The TRefreshUnit type exposes the following members.

Members
Show:
Name | Description
Days | Represents constant Days.
Hours | Represents constant Hours.
Minutes | Represents constant Minutes.
Months | Represents constant Months.
Seconds | Represents constant Seconds.
Weeks | Represents constant Weeks.
Years | Represents constant Years.
Top
See Also

Reference

  • BI.Persist


BI.Persist Delegates

Delegates
Name | Description
TBIError | Represents type TBIError.
TBIProgress | Represents type TBIProgress.
Top


TBIError Delegate

Summary

Represents type TBIError.

Namespace: BI.Persist
Syntax
Delphi
type
 TBIError=function(const Sender:TObject; const Error:String):Boolean of object;
See Also

Reference

  • BI.Persist


TBIProgress Delegate

Summary

Represents type TBIProgress.

Namespace: BI.Persist
Syntax
Delphi
type
 TBIProgress=procedure(const Sender:TObject; const Percent:Single; var Cancel:Boolean) of object;
See Also

Reference

  • BI.Persist


BI.Persist Types

Types
Name | Description
TBIErrorProc | Represents type TBIErrorProc.
TDataImporterClass | Represents type TDataImporterClass.
Top


TBIErrorProc Type

Summary

Represents type TBIErrorProc.

Namespace: BI.Persist
Syntax
Delphi
type
 TBIErrorProc=
 reference to function(const Sender:TObject; const Error:String):Boolean;
See Also

Reference

  • BI.Persist


TDataImporterClass Type

Summary

Represents type TDataImporterClass.

Namespace: BI.Persist
Syntax
Delphi
type
 TDataImporterClass=class of TDataImporter;
See Also

Reference

  • BI.Persist


BI.Persist Constants

Constants
Name | Description
Default_Key | Represents constant Default_Key.
Steema_Ini | Represents constant Steema_Ini.
Steema_Key | Represents constant Steema_Key.
Top


Default_Key Constant

Summary

Represents constant Default_Key.

Namespace: BI.Persist
Syntax
Delphi
 Default_Key='Default';

Value

Type: string

See Also

Reference

  • BI.Persist


Steema_Ini Constant

Summary

Represents constant Steema_Ini.

Namespace: BI.Persist
Syntax
Delphi
 Steema_Ini='TeeBI.ini';

Value

Type: string

See Also

Reference

  • BI.Persist


Steema_Key Constant

Summary

Represents constant Steema_Key.

Namespace: BI.Persist
Syntax
Delphi
 Steema_Key='Software\Steema Software\TeeBI\';

Value

Type: string

See Also

Reference

  • BI.Persist


BI.Persist Routines

Routines
Name | Description
CheckMap(TDataItem) | Represents method CheckMap(TDataItem).
VersionError(Integer) | Represents method VersionError(Integer).
Top


CheckMap(TDataItem) Method

Summary

Represents method CheckMap(TDataItem).

Namespace: BI.Persist
Syntax
Delphi
function CheckMap(const AData:TDataItem):TDataMap;

Parameters

AData
Type: TDataItem

Return Value

Type: TDataMap

See Also

Reference

  • BI.Persist


VersionError(Integer) Method

Summary

Represents method VersionError(Integer).

Namespace: BI.Persist
Syntax
Delphi
procedure VersionError(const Old:Integer);

Parameters

Old
Type: Integer

See Also

Reference

  • BI.Persist


BI.Plugins.Python Namespace

Summary

Represents namespace BI.Plugins.Python.

Classes
Name | Description
TBIPython | Represents type TBIPython.
TBIPythonIO | Represents type TBIPythonIO.
TDataAccess | Represents type TDataAccess.
TScikitSupervisedModel | Represents type TScikitSupervisedModel.
Top
Routines
Name | Description
IsDateTime(PPyObject) | Represents method IsDateTime(PPyObject).
TypeOfArray(String) | Represents method TypeOfArray(String).
TypeOfListItem(PPyObject) | Represents method TypeOfListItem(PPyObject).
Top


BI.Plugins.Python Classes

Classes
Name | Description
TBIPython | Represents type TBIPython.
TBIPythonIO | Represents type TBIPythonIO.
TDataAccess | Represents type TDataAccess.
TScikitSupervisedModel | Represents type TScikitSupervisedModel.
Top


TBIPython Class

Summary

Represents type TBIPython.

Namespace: BI.Plugins.Python
Inheritance Hierarchy
TObject
BI.Algorithm.Model.TBIPlugin
BI.Plugins.Python.TBIPython
Syntax
Delphi
type
 TBIPython=class(TBIPlugin)
 end;

The TBIPython type exposes the following members.

Properties
Show:
Name | Description
Engine | Represents property Engine.
Output | Represents property Output.
Top
Methods
Show:
Name | Description
DataRowToVector(TInteger,TDataArray,Boolean) | Represents method DataRowToVector(TInteger,TDataArray,Boolean).
Evaluate(String) | Represents method Evaluate(String).
EvaluateAsString(String) | Represents method EvaluateAsString(String).
Execute(String) | Overloaded. Represents method Execute(String).
Execute(TStrings) | Overloaded. Represents method Execute(TStrings).
FromData(String,TDataArray,TNativeIntArray,Boolean) | Overloaded. Represents method FromData(String,TDataArray,TNativeIntArray,Boolean).
FromData(String,TDataItem,TNativeIntArray,Boolean) | Overloaded. Represents method FromData(String,TDataItem,TNativeIntArray,Boolean).
GetData(String) | Represents method GetData(String).
Top
See Also

Reference

  • BI.Plugins.Python


TBIPython Properties

Properties
Name | Description
Engine | Represents property Engine.
Output | Represents property Output.
Top


TBIPython.Engine Property

Summary

Represents property Engine.

Namespace: BI.Plugins.Python
Syntax
Delphi
public
 class property Engine:TPythonEngine read GetEngine;

Property Value

Type: TPythonEngine

See Also

Reference

  • TBIPython
  • BI.Plugins.Python


TBIPython.Output Property

Summary

Represents property Output.

Namespace: BI.Plugins.Python
Syntax
Delphi
public
 class property Output:TStrings read FOutput write FOutput;

Property Value

Type: TStrings

See Also

Reference

  • TBIPython
  • BI.Plugins.Python


TBIPython Methods

Methods
Name | Description
DataRowToVector(TInteger,TDataArray,Boolean) | Represents method DataRowToVector(TInteger,TDataArray,Boolean).
Evaluate(String) | Represents method Evaluate(String).
EvaluateAsString(String) | Represents method EvaluateAsString(String).
Execute(String) | Overloaded. Represents method Execute(String).
Execute(TStrings) | Overloaded. Represents method Execute(TStrings).
FromData(String,TDataArray,TNativeIntArray,Boolean) | Overloaded. Represents method FromData(String,TDataArray,TNativeIntArray,Boolean).
FromData(String,TDataItem,TNativeIntArray,Boolean) | Overloaded. Represents method FromData(String,TDataItem,TNativeIntArray,Boolean).
GetData(String) | Represents method GetData(String).
Top


TBIPython.DataRowToVector(TInteger,TDataArray,Boolean) Method

Summary

Represents method DataRowToVector(TInteger,TDataArray,Boolean).

Namespace: BI.Plugins.Python
Syntax
Delphi
public
 class function DataRowToVector(const AIndex:TInteger; const AData:TDataArray;
 const UseMissing:Boolean=True):String; static;

Parameters

AIndex
Type: System.Void

AData
Type: TDataArray

UseMissing
Type: Boolean

Return Value

Type: String

See Also

Reference

  • TBIPython
  • BI.Plugins.Python


TBIPython.Evaluate(String) Method

Summary

Represents method Evaluate(String).

Namespace: BI.Plugins.Python
Syntax
Delphi
public
 class function Evaluate(const AText:String):PPyObject; static;

Parameters

AText
Type: String

Return Value

Type: PPyObject

See Also

Reference

  • TBIPython
  • BI.Plugins.Python


TBIPython.EvaluateAsString(String) Method

Summary

Represents method EvaluateAsString(String).

Namespace: BI.Plugins.Python
Syntax
Delphi
public
 class function EvaluateAsString(const AText:String):String; static;

Parameters

AText
Type: String

Return Value

Type: String

See Also

Reference

  • TBIPython
  • BI.Plugins.Python


TBIPython.Execute(String) Method

Summary

Represents method Execute(String).

Namespace: BI.Plugins.Python
Syntax
Delphi
public
 class function Execute(const AText:String):Boolean; overload; static;

Parameters

AText
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TBIPython
  • BI.Plugins.Python


TBIPython.Execute(TStrings) Method

Summary

Represents method Execute(TStrings).

Namespace: BI.Plugins.Python
Syntax
Delphi
public
 class function Execute(const AScript:TStrings):Boolean; overload; static;

Parameters

AScript
Type: TStrings

Return Value

Type: Boolean

See Also

Reference

  • TBIPython
  • BI.Plugins.Python


TBIPython.FromData(String,TDataArray,TNativeIntArray,Boolean) Method

Summary

Represents method FromData(String,TDataArray,TNativeIntArray,Boolean).

Namespace: BI.Plugins.Python
Syntax
Delphi
public
 class function FromData(const AName:String; const AData:TDataArray; const Index:TNativeIntArray=nil;
 const UseMissing:Boolean=True):String; overload; static;

Parameters

AName
Type: String

AData
Type: TDataArray

Index
Type: System.Void

UseMissing
Type: Boolean

Return Value

Type: String

See Also

Reference

  • TBIPython
  • BI.Plugins.Python


TBIPython.FromData(String,TDataItem,TNativeIntArray,Boolean) Method

Summary

Represents method FromData(String,TDataItem,TNativeIntArray,Boolean).

Namespace: BI.Plugins.Python
Syntax
Delphi
public
 class function FromData(const AName:String; const AData:TDataItem; const Index:TNativeIntArray=nil;
 const UseMissing:Boolean=True):String; overload; static;

Parameters

AName
Type: String

AData
Type: TDataItem

Index
Type: System.Void

UseMissing
Type: Boolean

Return Value

Type: String

See Also

Reference

  • TBIPython
  • BI.Plugins.Python


TBIPython.GetData(String) Method

Summary

Represents method GetData(String).

Namespace: BI.Plugins.Python
Syntax
Delphi
public
 class function GetData(const AName:String):TDataItem; static;

Parameters

AName
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TBIPython
  • BI.Plugins.Python


TBIPythonIO Class

Summary

Represents type TBIPythonIO.

Namespace: BI.Plugins.Python
Inheritance Hierarchy
TComponent
BI.Plugins.Python.Engine.TPythonInputOutput
BI.Plugins.Python.TBIPythonIO
Syntax
Delphi
type
 TBIPythonIO=class(TPythonInputOutput)
 end;

The TBIPythonIO type exposes the following members.

Methods
Show:
Name | Description
SendData(AnsiString) | Represents method SendData(AnsiString). (Overrides TPythonInputOutput.SendData(AnsiString).)
Top
See Also

Reference

  • BI.Plugins.Python


TBIPythonIO Methods

Methods
Name | Description
SendData(AnsiString) | Represents method SendData(AnsiString). (Overrides TPythonInputOutput.SendData(AnsiString).)
Top


TBIPythonIO.SendData(AnsiString) Method

Summary

Represents method SendData(AnsiString).

Namespace: BI.Plugins.Python
Syntax
Delphi
protected
 procedure SendData(const Data:AnsiString); override;

Parameters

Data
Type: AnsiString

Overrides

TPythonInputOutput.SendData(AnsiString)
See Also

Reference

  • TBIPythonIO
  • BI.Plugins.Python


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.Plugins.Python
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Plugins.Python.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.Plugins.Python


TScikitSupervisedModel Class

Summary

Represents type TScikitSupervisedModel.

Namespace: BI.Plugins.Python
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TBaseAlgorithm
BI.Algorithm.Model.TModel
BI.Algorithm.Model.TSupervisedModel
BI.Plugins.Python.TScikitSupervisedModel
BI.Algorithm.Clustering.Scikit.TBIScikitClustering
Syntax
Delphi
type
 TScikitSupervisedModel=class(TSupervisedModel)
 end;

The TScikitSupervisedModel type exposes the following members.

Methods
Show:
Name | Description
BuildScript | Represents method BuildScript.
Fit | Represents method Fit.
Top
See Also

Reference

  • BI.Plugins.Python


TScikitSupervisedModel Methods

Methods
Name | Description
BuildScript | Represents method BuildScript.
Fit | Represents method Fit.
Top


TScikitSupervisedModel.BuildScript Method

Summary

Represents method BuildScript.

Namespace: BI.Plugins.Python
Syntax
Delphi
protected
 function BuildScript:TStrings; virtual; abstract;

Return Value

Type: TStrings

See Also

Reference

  • TScikitSupervisedModel
  • BI.Plugins.Python


TScikitSupervisedModel.Fit Method

Summary

Represents method Fit.

Namespace: BI.Plugins.Python
Syntax
Delphi
protected
 function Fit:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TScikitSupervisedModel
  • BI.Plugins.Python


BI.Plugins.Python Routines

Routines
Name | Description
IsDateTime(PPyObject) | Represents method IsDateTime(PPyObject).
TypeOfArray(String) | Represents method TypeOfArray(String).
TypeOfListItem(PPyObject) | Represents method TypeOfListItem(PPyObject).
Top


IsDateTime(PPyObject) Method

Summary

Represents method IsDateTime(PPyObject).

Namespace: BI.Plugins.Python
Syntax
Delphi
function IsDateTime(const AItem:PPyObject):Boolean;

Parameters

AItem
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • BI.Plugins.Python


TypeOfArray(String) Method

Summary

Represents method TypeOfArray(String).

Namespace: BI.Plugins.Python
Syntax
Delphi
function TypeOfArray(const AName:String):TDataKind;

Parameters

AName
Type: String

Return Value

Type: TDataKind

See Also

Reference

  • BI.Plugins.Python


TypeOfListItem(PPyObject) Method

Summary

Represents method TypeOfListItem(PPyObject).

Namespace: BI.Plugins.Python
Syntax
Delphi
function TypeOfListItem(const AItem:PPyObject):TDataKind;

Parameters

AItem
Type: PPyObject

Return Value

Type: TDataKind

See Also

Reference

  • BI.Plugins.Python


BI.Plugins.Python.Engine Namespace

Summary

Represents namespace BI.Plugins.Python.Engine.

Classes
Name | Description
EDLLImportError | Represents type EDLLImportError.
EDLLLoadError | Represents type EDLLLoadError.
EPyArithmeticError | Represents type EPyArithmeticError.
EPyAssertionError | Represents type EPyAssertionError.
EPyAttributeError | Represents type EPyAttributeError.
EPyDeprecationWarning | Represents type EPyDeprecationWarning.
EPyEnvironmentError | Represents type EPyEnvironmentError.
EPyEOFError | Represents type EPyEOFError.
EPyException |
EPyExecError | Represents type EPyExecError.
EPyFloatingPointError | Represents type EPyFloatingPointError.
EPyImportError | Represents type EPyImportError.
EPyIndentationError | Represents type EPyIndentationError.
EPyIndexError | Represents type EPyIndexError.
EPyIOError | Represents type EPyIOError.
EPyKeyboardInterrupt | Represents type EPyKeyboardInterrupt.
EPyKeyError | Represents type EPyKeyError.
EPyLookupError | Represents type EPyLookupError.
EPyMemoryError | Represents type EPyMemoryError.
EPyNameError | Represents type EPyNameError.
EPyNotImplementedError | Represents type EPyNotImplementedError.
EPyOSError | Represents type EPyOSError.
EPyOverflowError | Represents type EPyOverflowError.
EPyReferenceError | Represents type EPyReferenceError.
EPyRuntimeError | Represents type EPyRuntimeError.
EPyRuntimeWarning | Represents type EPyRuntimeWarning.
EPyStandardError | Represents type EPyStandardError.
EPyStopIteration | Represents type EPyStopIteration.
EPySyntaxError | Represents type EPySyntaxError.
EPySyntaxWarning | Represents type EPySyntaxWarning.
EPySystemError | Represents type EPySystemError.
EPySystemExit | Represents type EPySystemExit.
EPyTabError | Represents type EPyTabError.
EPythonError | Represents type EPythonError.
EPyTypeError | Represents type EPyTypeError.
EPyUnboundLocalError | Represents type EPyUnboundLocalError.
EPyUnicodeError | Represents type EPyUnicodeError.
EPyUserWarning | Represents type EPyUserWarning.
EPyValueError | Represents type EPyValueError.
EPyWarning | Represents type EPyWarning.
EPyWindowsError | Represents type EPyWindowsError.
EPyZeroDivisionError | Represents type EPyZeroDivisionError.
FutureWarning | Represents type FutureWarning.
PendingDeprecationWarning | Represents type PendingDeprecationWarning.
TDynamicDll | Represents type TDynamicDll.
TEngineClient | Represents type TEngineClient.
TError | Represents type TError.
TErrors | Represents type TErrors.
TEventDef | Represents type TEventDef.
TEventDefs | Represents type TEventDefs.
TGetSetContainer | Represents type TGetSetContainer.
TMembersContainer | Represents type TMembersContainer.
TMethodsContainer | Represents type TMethodsContainer.
TParentClassError | Represents type TParentClassError.
TPyObject | Represents type TPyObject.
TPythonDelphiVar | Represents type TPythonDelphiVar.
TPythonEngine | Represents type TPythonEngine.
TPythonInputOutput | Represents type TPythonInputOutput.
TPythonInterface | Represents type TPythonInterface.
TPythonModule | Represents type TPythonModule.
TPythonThread | Represents type TPythonThread.
TPythonTraceback | Represents type TPythonTraceback.
TPythonType | Represents type TPythonType.
TPyVar | Represents type TPyVar.
TTracebackItem | Represents type TTracebackItem.
TTypeServices | Represents type TTypeServices.
UnicodeDecodeError | Represents type UnicodeDecodeError.
UnicodeEncodeError | Represents type UnicodeEncodeError.
UnicodeTranslateError | Represents type UnicodeTranslateError.
Top
Records
Name | Description
node | Represents type node.
PyBufferProcs |
PyClassObject | Represents type PyClassObject.
PyCodeObject | Represents type PyCodeObject.
PyDateTime_Date | Represents type PyDateTime_Date.
PyDateTime_DateTime | Represents type PyDateTime_DateTime.
PyDateTime_Delta | Represents type PyDateTime_Delta.
PyDateTime_Time | Represents type PyDateTime_Time.
PyDateTime_TZInfo | Represents type PyDateTime_TZInfo.
PyDescrObject | Represents type PyDescrObject.
PyFrameObject | Represents type PyFrameObject.
PyGetSetDef | Represents type PyGetSetDef.
PyGetSetDescrObject | Represents type PyGetSetDescrObject.
PyInstanceObject | Represents type PyInstanceObject.
PyInterpreterState | Represents type PyInterpreterState.
PyIntObject | Represents type PyIntObject.
PyMappingMethods | Represents type PyMappingMethods.
PyMemberDef | Represents type PyMemberDef.
PyMemberDescrObject | Represents type PyMemberDescrObject.
PyMethodChain | Represents type PyMethodChain.
PyMethodDef | Represents type PyMethodDef.
PyMethodDescrObject | Represents type PyMethodDescrObject.
PyMethodObject | Represents type PyMethodObject.
PyModuleDef | Represents type PyModuleDef.
PyModuleDef_Base | Represents type PyModuleDef_Base.
PyNumberMethods | Represents type PyNumberMethods.
PyObject | Represents type PyObject.
PySequenceMethods | Represents type PySequenceMethods.
PySliceObject | Represents type PySliceObject.
PyThreadState | Represents type PyThreadState.
PyTraceBackObject | Represents type PyTraceBackObject.
PyTryBlock | Represents type PyTryBlock.
PyTypeObject | Represents type PyTypeObject.
PyWeakReference | Represents type PyWeakReference.
PyWrapperDescrObject | Represents type PyWrapperDescrObject.
Py_complex | Represents type Py_complex.
TCodeMemBlock | Represents type TCodeMemBlock.
TCodeMemPage | Represents type TCodeMemPage.
TPythonVersionProp | Represents type TPythonVersionProp.
wrapperbase | Represents type wrapperbase.
_frozen | Represents type _frozen.
_PyDateTime_BaseDateTime | Represents type _PyDateTime_BaseDateTime.
_PyDateTime_BaseTime | Represents type _PyDateTime_BaseTime.
_PyDateTime_BaseTZInfo | Represents type _PyDateTime_BaseTZInfo.
Top
Enumerations
Name | Description
BI.Plugins.Python.Engine. | Represents type .
BI.Plugins.Python.Engine. | Represents type .
BI.Plugins.Python.Engine. | Represents type .
BI.Plugins.Python.Engine. | Represents type .
BI.Plugins.Python.Engine. | Represents type .
PyGILState_STATE | Represents type PyGILState_STATE.
TCallType | Represents type TCallType.
TDatetimeConversionMode | Represents type TDatetimeConversionMode.
TErrorType | Represents type TErrorType.
TPFlag | Represents type TPFlag.
TPyMemberFlag | Represents type TPyMemberFlag.
TPyMemberType | Represents type TPyMemberType.
TPythonFlag | Represents type TPythonFlag.
TRichComparisonOpcode | Represents type TRichComparisonOpcode.
TThreadExecMode | Represents type TThreadExecMode.
Top
Delegates
Name | Description
allocfunc | Represents type allocfunc.
AtExitProc | Represents type AtExitProc.
binaryfunc | Represents type binaryfunc.
cmpfunc | Represents type cmpfunc.
coercion | Represents type coercion.
descrgetfunc | Represents type descrgetfunc.
descrsetfunc | Represents type descrsetfunc.
getattrfunc | Represents type getattrfunc.
getattrofunc | Represents type getattrofunc.
getcharbufferproc | Represents type getcharbufferproc.
getiterfunc | Represents type getiterfunc.
getreadbufferproc |
getsegcountproc | Represents type getsegcountproc.
getter | Represents type getter.
getwritebufferproc | Represents type getwritebufferproc.
hashfunc | Represents type hashfunc.
initproc | Represents type initproc.
inquiry | Represents type inquiry.
iternextfunc | Represents type iternextfunc.
lenfunc | Represents type lenfunc.
newfunc | Represents type newfunc.
objobjargproc | Represents type objobjargproc.
objobjproc | Represents type objobjproc.
printfunc | Represents type printfunc.
PyCFunction | Represents type PyCFunction.
PyCFunctionWithKW | Represents type PyCFunctionWithKW.
pydestructor | Represents type pydestructor.
reprfunc | Represents type reprfunc.
richcmpfunc | Represents type richcmpfunc.
setattrfunc | Represents type setattrfunc.
setattrofunc | Represents type setattrofunc.
setter | Represents type setter.
ssizeargfunc | Represents type ssizeargfunc.
ssizeobjargproc | Represents type ssizeobjargproc.
ssizessizeargfunc | Represents type ssizessizeargfunc.
ssizessizeobjargproc | Represents type ssizessizeobjargproc.
TCallBack | Represents type TCallBack.
TDDEAPIfunc | Represents type TDDEAPIfunc.
TDelphiMethod | Represents type TDelphiMethod.
TDelphiMethodWithKW | Represents type TDelphiMethodWithKW.
ternaryfunc | Represents type ternaryfunc.
TExtGetDataEvent | Represents type TExtGetDataEvent.
TExtSetDataEvent | Represents type TExtSetDataEvent.
TGetDataEvent | Represents type TGetDataEvent.
TPathInitializationEvent | Represents type TPathInitializationEvent.
TPythonEvent | Represents type TPythonEvent.
traverseproc | Represents type traverseproc.
TReceiveDataEvent | Represents type TReceiveDataEvent.
TReceiveUniDataEvent | Represents type TReceiveUniDataEvent.
TSendDataEvent | Represents type TSendDataEvent.
TSendUniDataEvent | Represents type TSendUniDataEvent.
TSetDataEvent | Represents type TSetDataEvent.
TSysPathInitEvent | Represents type TSysPathInitEvent.
unaryfunc | Represents type unaryfunc.
visitproc | Represents type visitproc.
wrapperfunc | Represents type wrapperfunc.
Top
Types
Name | Description
CO_MAXBLOCKS | Represents type CO_MAXBLOCKS.
IOChar | Represents an alias of the WideChar type.
IOString | Represents an alias of the UnicodeString type.
PByte | Represents a pointer type to Byte.
PCodeMemBlock | Represents a pointer type to TCodeMemBlock.
PCodeMemPage | Represents a pointer type to TCodeMemPage.
PDouble | Represents a pointer type to Double.
PFloat | Represents a pointer type to Real.
PGetSetArray | Represents a pointer type to TGetSetArray.
PInt | Represents a pointer type to Integer.
PLong | Represents a pointer type to LongInt.
PMemberArray | Represents a pointer type to TMemberArray.
PMethodArray | Represents a pointer type to TMethodArray.
PNativeInt | Represents a pointer type to NativeInt.
PNode | Represents a pointer type to node.
PPAnsiChar | Represents a pointer type to TPAnsiChar.
PPPPyObject | Represents a pointer type to PPPyObject.
PPPyObject | Represents a pointer type to PPyObject.
PPWideChar | Represents a pointer type to TPWideChar.
PPyBufferProcs | Represents a pointer type to PyBufferProcs.
PPyClassObject | Represents a pointer type to PyClassObject.
PPyCodeObject | Represents a pointer type to PyCodeObject.
PPyDateTime_Date | Represents a pointer type to PyDateTime_Date.
PPyDateTime_DateTime | Represents a pointer type to PyDateTime_DateTime.
PPyDateTime_Delta | Represents a pointer type to PyDateTime_Delta.
PPyDateTime_Time | Represents a pointer type to PyDateTime_Time.
PPyDateTime_TZInfo | Represents a pointer type to PyDateTime_TZInfo.
PPyDescrObject | Represents a pointer type to PyDescrObject.
PPyFrameObject | Represents a pointer type to PyFrameObject.
PPyGetSetDef | Represents a pointer type to PyGetSetDef.
PPyGetSetDescrObject | Represents a pointer type to PyGetSetDescrObject.
PPyInstanceObject | Represents a pointer type to PyInstanceObject.
PPyInterpreterState | Represents a pointer type to PyInterpreterState.
PPyIntObject | Represents a pointer type to PyIntObject.
PPyMappingMethods | Represents a pointer type to PyMappingMethods.
PPyMemberDef | Represents a pointer type to PyMemberDef.
PPyMemberDescrObject | Represents a pointer type to PyMemberDescrObject.
PPyMethodChain | Represents a pointer type to PyMethodChain.
PPyMethodDef | Represents a pointer type to PyMethodDef.
PPyMethodDescrObject | Represents a pointer type to PyMethodDescrObject.
PPyMethodObject | Represents a pointer type to PyMethodObject.
PPyModuleDef | Represents a pointer type to PyModuleDef.
PPyModuleDef_Base | Represents a pointer type to PyModuleDef_Base.
PPyNumberMethods | Represents a pointer type to PyNumberMethods.
PPyObject | Represents a pointer type to PyObject.
PPySequenceMethods | Represents a pointer type to PySequenceMethods.
PPySliceObject | Represents a pointer type to PySliceObject.
PPyThreadState | Represents a pointer type to PyThreadState.
PPyTraceBackObject | Represents a pointer type to PyTraceBackObject.
PPyTryBlock | Represents a pointer type to PyTryBlock.
PPyTypeObject | Represents a pointer type to PyTypeObject.
PPyWeakReference | Represents a pointer type to PyWeakReference.
PPyWrapperDescrObject | Represents a pointer type to PyWrapperDescrObject.
PP_frozen | Represents a pointer type to P_frozen.
PShort | Represents a pointer type to ShortInt.
PtrCalcType | Represents an alias of the Longint type.
pwrapperbase | Represents a pointer type to wrapperbase.
P_frozen | Represents a pointer type to _frozen.
TBasicServices | Represents type TBasicServices.
TGetSetArray | Represents an array of the PyGetSetDef type.
TInplaceNumberServices | Represents type TInplaceNumberServices.
TIOStringList | Represents an alias of the TUnicodeStringList type.
TMappingServices | Represents type TMappingServices.
TMemberArray | Represents an array of the PyMemberDef type.
TMethodArray | Represents an array of the PyMethodDef type.
TNumberServices | Represents type TNumberServices.
TPAnsiChar | Represents an array of the PAnsiChar type.
TPFlags | Represents type TPFlags.
TPWideChar | Represents an array of the PWideChar type.
TPyObjectClass | Represents type TPyObjectClass.
TPythonFlags | Represents type TPythonFlags.
TSequenceServices | Represents type TSequenceServices.
TUnicodeStringList | Represents an alias of the TStringList type.
_PPyDateTime_BaseDateTime | Represents a pointer type to _PyDateTime_BaseDateTime.
_PPyDateTime_BaseTime | Represents a pointer type to _PyDateTime_BaseTime.
_PPyDateTime_BaseTZInfo | Represents a pointer type to _PyDateTime_BaseTZInfo.
Top
Variables
Name | Description
CodeMemPages | Represents variable CodeMemPages.
gPythonEngine | Represents variable gPythonEngine.
gVarType | Represents variable gVarType.
Top
Constants
Name | Description
COMPILED_FOR_PYTHON_VERSION_INDEX | Represents constant COMPILED_FOR_PYTHON_VERSION_INDEX.
CO_NEWLOCALS | Represents constant CO_NEWLOCALS.
CO_OPTIMIZED | Represents constant CO_OPTIMIZED.
CO_VARARGS | Represents constant CO_VARARGS.
CO_VARKEYWORDS | Represents constant CO_VARKEYWORDS.
CR | Represents constant CR.
CRLF | Represents constant CRLF.
DEFAULT_DATETIME_CONVERSION_MODE | Represents constant DEFAULT_DATETIME_CONVERSION_MODE.
ErrInit | Represents constant ErrInit.
eval_input | Represents constant eval_input.
file_input | Represents constant file_input.
kMaxLineLength | Represents constant kMaxLineLength.
kMaxLines | Represents constant kMaxLines.
LF | Represents constant LF.
METH_KEYWORDS | Represents constant METH_KEYWORDS.
METH_VARARGS | Represents constant METH_VARARGS.
p4d_and_expr | Represents constant p4d_and_expr.
p4d_and_test | Represents constant p4d_and_test.
p4d_arglist | Represents constant p4d_arglist.
p4d_argument | Represents constant p4d_argument.
p4d_arith_expr | Represents constant p4d_arith_expr.
p4d_assert_stmt | Represents constant p4d_assert_stmt.
p4d_atom | Represents constant p4d_atom.
p4d_augassign | Represents constant p4d_augassign.
p4d_break_stmt | Represents constant p4d_break_stmt.
p4d_classdef | Represents constant p4d_classdef.
p4d_comparison | Represents constant p4d_comparison.
p4d_compound_stmt | Represents constant p4d_compound_stmt.
p4d_comp_op | Represents constant p4d_comp_op.
p4d_continue_stmt | Represents constant p4d_continue_stmt.
p4d_del_stmt | Represents constant p4d_del_stmt.
p4d_dictmaker | Represents constant p4d_dictmaker.
p4d_dotted_as_name | Represents constant p4d_dotted_as_name.
p4d_dotted_name | Represents constant p4d_dotted_name.
p4d_except_clause | Represents constant p4d_except_clause.
p4d_exec_stmt | Represents constant p4d_exec_stmt.
p4d_expr | Represents constant p4d_expr.
p4d_exprlist | Represents constant p4d_exprlist.
p4d_expr_stmt | Represents constant p4d_expr_stmt.
p4d_factor | Represents constant p4d_factor.
p4d_flow_stmt | Represents constant p4d_flow_stmt.
p4d_for_stmt | Represents constant p4d_for_stmt.
p4d_fpdef | Represents constant p4d_fpdef.
p4d_fplist | Represents constant p4d_fplist.
p4d_funcdef | Represents constant p4d_funcdef.
p4d_global_stmt | Represents constant p4d_global_stmt.
p4d_if_stmt | Represents constant p4d_if_stmt.
p4d_import_as_name | Represents constant p4d_import_as_name.
p4d_import_stmt | Represents constant p4d_import_stmt.
p4d_lambdef | Represents constant p4d_lambdef.
p4d_listmaker | Represents constant p4d_listmaker.
p4d_list_for | Represents constant p4d_list_for.
p4d_list_if | Represents constant p4d_list_if.
p4d_list_iter | Represents constant p4d_list_iter.
p4d_not_test | Represents constant p4d_not_test.
p4d_parameters | Represents constant p4d_parameters.
p4d_pass_stmt | Represents constant p4d_pass_stmt.
p4d_power | Represents constant p4d_power.
p4d_print_stmt | Represents constant p4d_print_stmt.
p4d_raise_stmt | Represents constant p4d_raise_stmt.
p4d_return_stmt | Represents constant p4d_return_stmt.
p4d_shift_expr | Represents constant p4d_shift_expr.
p4d_simple_stmt | Represents constant p4d_simple_stmt.
p4d_sliceop | Represents constant p4d_sliceop.
p4d_small_stmt | Represents constant p4d_small_stmt.
p4d_stmt | Represents constant p4d_stmt.
p4d_subscript | Represents constant p4d_subscript.
p4d_subscriptlist | Represents constant p4d_subscriptlist.
p4d_suite | Represents constant p4d_suite.
p4d_term | Represents constant p4d_term.
p4d_test | Represents constant p4d_test.
p4d_testlist | Represents constant p4d_testlist.
p4d_trailer | Represents constant p4d_trailer.
p4d_try_stmt | Represents constant p4d_try_stmt.
p4d_varargslist | Represents constant p4d_varargslist.
p4d_while_stmt | Represents constant p4d_while_stmt.
p4d_xor_expr | Represents constant p4d_xor_expr.
PageSize | Represents constant PageSize.
PYTHON_KNOWN_VERSIONS | Represents constant PYTHON_KNOWN_VERSIONS.
PYT_GETSET_BUFFER_INCREASE | Represents constant PYT_GETSET_BUFFER_INCREASE.
PYT_MEMBER_BUFFER_INCREASE | Represents constant PYT_MEMBER_BUFFER_INCREASE.
PYT_METHOD_BUFFER_INCREASE | Represents constant PYT_METHOD_BUFFER_INCREASE.
Py_EQ | Represents constant Py_EQ.
Py_GE | Represents constant Py_GE.
Py_GT | Represents constant Py_GT.
Py_LE | Represents constant Py_LE.
Py_LT | Represents constant Py_LT.
Py_NE | Represents constant Py_NE.
Py_TPFLAGS_BASETYPE | Represents constant Py_TPFLAGS_BASETYPE.
Py_TPFLAGS_CHECKTYPES | Represents constant Py_TPFLAGS_CHECKTYPES.
Py_TPFLAGS_DEFAULT | Represents constant Py_TPFLAGS_DEFAULT.
Py_TPFLAGS_GC | Represents constant Py_TPFLAGS_GC.
Py_TPFLAGS_HAVE_CLASS | Represents constant Py_TPFLAGS_HAVE_CLASS.
Py_TPFLAGS_HAVE_GC | Represents constant Py_TPFLAGS_HAVE_GC.
Py_TPFLAGS_HAVE_GETCHARBUFFER | Represents constant Py_TPFLAGS_HAVE_GETCHARBUFFER.
Py_TPFLAGS_HAVE_INPLACEOPS | Represents constant Py_TPFLAGS_HAVE_INPLACEOPS.
Py_TPFLAGS_HAVE_ITER | Represents constant Py_TPFLAGS_HAVE_ITER.
Py_TPFLAGS_HAVE_RICHCOMPARE | Represents constant Py_TPFLAGS_HAVE_RICHCOMPARE.
Py_TPFLAGS_HAVE_SEQUENCE_IN | Represents constant Py_TPFLAGS_HAVE_SEQUENCE_IN.
Py_TPFLAGS_HAVE_WEAKREFS | Represents constant Py_TPFLAGS_HAVE_WEAKREFS.
Py_TPFLAGS_HEAPTYPE | Represents constant Py_TPFLAGS_HEAPTYPE.
Py_TPFLAGS_READY | Represents constant Py_TPFLAGS_READY.
Py_TPFLAGS_READYING | Represents constant Py_TPFLAGS_READYING.
READONLY | Represents constant READONLY.
READ_RESTRICTED | Represents constant READ_RESTRICTED.
RESTRICTED | Represents constant RESTRICTED.
RO | Represents constant RO.
single_input | Represents constant single_input.
TAB | Represents constant TAB.
TPFLAGS_DEFAULT | Represents constant TPFLAGS_DEFAULT.
T_BYTE | Represents constant T_BYTE.
T_CHAR | Represents constant T_CHAR.
T_DOUBLE | Represents constant T_DOUBLE.
T_FLOAT | Represents constant T_FLOAT.
T_INT | Represents constant T_INT.
T_LONG | Represents constant T_LONG.
T_OBJECT | Represents constant T_OBJECT.
T_OBJECT_EX | Represents constant T_OBJECT_EX.
T_SHORT | Represents constant T_SHORT.
T_STRING | Represents constant T_STRING.
T_STRING_INPLACE | Represents constant T_STRING_INPLACE.
T_UBYTE | Represents constant T_UBYTE.
T_UINT | Represents constant T_UINT.
T_ULONG | Represents constant T_ULONG.
T_USHORT | Represents constant T_USHORT.
WRITE_RESTRICTED | Represents constant WRITE_RESTRICTED.
_PyDateTime_DATETIME_DATASIZE | Represents constant _PyDateTime_DATETIME_DATASIZE.
_PyDateTime_DATE_DATASIZE | Represents constant _PyDateTime_DATE_DATASIZE.
_PyDateTime_TIME_DATASIZE | Represents constant _PyDateTime_TIME_DATASIZE.
Top
Routines
Name | Description
CodeMemPageCount | Represents method CodeMemPageCount.
DeleteCallBack(Pointer) | Represents method DeleteCallBack(Pointer).
FreeCallBacks | Represents method FreeCallBacks.
FreeCodeMem(Pointer) | Represents method FreeCodeMem(Pointer).
FreeSubtypeInst(PPyObject) | Represents method FreeSubtypeInst(PPyObject).
GetCallBack(TObject,Pointer,Integer,TCallType) | Represents method GetCallBack(TObject,Pointer,Integer,TCallType).
GetCodeMem(PByte,integer) | Represents method GetCodeMem(PByte,integer).
GetDDECallBack(TDDEAPIfunc) | Represents method GetDDECallBack(TDDEAPIfunc).
GetOfObjectCallBack(TCallBack,Integer,TCallType) | Represents method GetOfObjectCallBack(TCallBack,Integer,TCallType).
GetPythonEngine | Represents method GetPythonEngine.
IsDelphiObject(PPyObject) | Represents method IsDelphiObject(PPyObject).
IsPythonVersionRegistered(string,string,Boolean) | Represents method IsPythonVersionRegistered(string,string,Boolean).
MaskFPUExceptions(boolean,Boolean) | Represents method MaskFPUExceptions(boolean,Boolean).
pyio_GetTypesStats(PPyObject,PPyObject) | Represents method pyio_GetTypesStats(PPyObject,PPyObject).
pyio_read(PPyObject,PPyObject) | Represents method pyio_read(PPyObject,PPyObject).
pyio_SetDelayWrites(PPyObject,PPyObject) | Represents method pyio_SetDelayWrites(PPyObject,PPyObject).
pyio_SetMaxLines(PPyObject,PPyObject) | Represents method pyio_SetMaxLines(PPyObject,PPyObject).
pyio_write(PPyObject,PPyObject) | Represents method pyio_write(PPyObject,PPyObject).
PyObjectDestructor(PPyObject) | Represents method PyObjectDestructor(PPyObject).
PythonOK | Represents method PythonOK.
PythonToDelphi(PPyObject) | Represents method PythonToDelphi(PPyObject).
PyType_HasFeature(PPyTypeObject,Integer) | Represents method PyType_HasFeature(PPyTypeObject,Integer).
Register | Represents method Register.
TPythonType_AllocSubtypeInst(PPyTypeObject,NativeInt) | Represents method TPythonType_AllocSubtypeInst(PPyTypeObject,NativeInt).
TPythonType_Call(PPyObject,PPyObject,PPyObject) | Represents method TPythonType_Call(PPyObject,PPyObject,PPyObject).
TPythonType_Clear(PPyObject) | Represents method TPythonType_Clear(PPyObject).
TPythonType_Compare(PPyObject,PPyObject) | Represents method TPythonType_Compare(PPyObject,PPyObject).
TPythonType_GetAttr(PPyObject,PAnsiChar) | Represents method TPythonType_GetAttr(PPyObject,PAnsiChar).
TPythonType_GetAttrO(PPyObject,PPyObject) | Represents method TPythonType_GetAttrO(PPyObject,PPyObject).
TPythonType_Hash(PPyObject) | Represents method TPythonType_Hash(PPyObject).
TPythonType_InitSubtype(PPyObject,PPyObject,PPyObject) | Represents method TPythonType_InitSubtype(PPyObject,PPyObject,PPyObject).
TPythonType_Iter(PPyObject) | Represents method TPythonType_Iter(PPyObject).
TPythonType_IterNext(PPyObject) | Represents method TPythonType_IterNext(PPyObject).
TPythonType_MpAssSubscript(PPyObject,PPyObject,PPyObject) | Represents method TPythonType_MpAssSubscript(PPyObject,PPyObject,PPyObject).
TPythonType_MpLength(PPyObject) | Represents method TPythonType_MpLength(PPyObject).
TPythonType_MpSubscript(PPyObject,PPyObject) | Represents method TPythonType_MpSubscript(PPyObject,PPyObject).
TPythonType_NbAbsolute(PPyObject) | Represents method TPythonType_NbAbsolute(PPyObject).
TPythonType_NbAdd(PPyObject,PPyObject) | Represents method TPythonType_NbAdd(PPyObject,PPyObject).
TPythonType_NbAnd(PPyObject,PPyObject) | Represents method TPythonType_NbAnd(PPyObject,PPyObject).
TPythonType_NbCoerce(PPPyObject,PPPyObject) | Represents method TPythonType_NbCoerce(PPPyObject,PPPyObject).
TPythonType_NbDivide(PPyObject,PPyObject) | Represents method TPythonType_NbDivide(PPyObject,PPyObject).
TPythonType_NbDivmod(PPyObject,PPyObject) | Represents method TPythonType_NbDivmod(PPyObject,PPyObject).
TPythonType_NbFloat(PPyObject) | Represents method TPythonType_NbFloat(PPyObject).
TPythonType_NbFloorDivide(PPyObject,PPyObject) | Represents method TPythonType_NbFloorDivide(PPyObject,PPyObject).
TPythonType_NbHex(PPyObject) | Represents method TPythonType_NbHex(PPyObject).
TPythonType_NbInplaceAdd(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceAdd(PPyObject,PPyObject).
TPythonType_NbInplaceAnd(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceAnd(PPyObject,PPyObject).
TPythonType_NbInplaceDivide(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceDivide(PPyObject,PPyObject).
TPythonType_NbInplaceFloorDivide(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceFloorDivide(PPyObject,PPyObject).
TPythonType_NbInplaceLshift(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceLshift(PPyObject,PPyObject).
TPythonType_NbInplaceMultiply(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceMultiply(PPyObject,PPyObject).
TPythonType_NbInplaceOr(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceOr(PPyObject,PPyObject).
TPythonType_NbInplacePower(PPyObject,PPyObject,PPyObject) | Represents method TPythonType_NbInplacePower(PPyObject,PPyObject,PPyObject).
TPythonType_NbInplaceRemainder(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceRemainder(PPyObject,PPyObject).
TPythonType_NbInplaceRshift(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceRshift(PPyObject,PPyObject).
TPythonType_NbInplaceSubtract(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceSubtract(PPyObject,PPyObject).
TPythonType_NbInplaceTrueDivide(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceTrueDivide(PPyObject,PPyObject).
TPythonType_NbInplaceXor(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceXor(PPyObject,PPyObject).
TPythonType_NbInt(PPyObject) | Represents method TPythonType_NbInt(PPyObject).
TPythonType_NbInvert(PPyObject) | Represents method TPythonType_NbInvert(PPyObject).
TPythonType_NbLong(PPyObject) | Represents method TPythonType_NbLong(PPyObject).
TPythonType_NbLShift(PPyObject,PPyObject) | Represents method TPythonType_NbLShift(PPyObject,PPyObject).
TPythonType_NbMultiply(PPyObject,PPyObject) | Represents method TPythonType_NbMultiply(PPyObject,PPyObject).
TPythonType_NbNegative(PPyObject) | Represents method TPythonType_NbNegative(PPyObject).
TPythonType_NbNonZero(PPyObject) | Represents method TPythonType_NbNonZero(PPyObject).
TPythonType_NbOct(PPyObject) | Represents method TPythonType_NbOct(PPyObject).
TPythonType_NbOr(PPyObject,PPyObject) | Represents method TPythonType_NbOr(PPyObject,PPyObject).
TPythonType_NbPositive(PPyObject) | Represents method TPythonType_NbPositive(PPyObject).
TPythonType_NbPower(PPyObject,PPyObject,PPyObject) | Represents method TPythonType_NbPower(PPyObject,PPyObject,PPyObject).
TPythonType_NbRemainder(PPyObject,PPyObject) | Represents method TPythonType_NbRemainder(PPyObject,PPyObject).
TPythonType_NbRShift(PPyObject,PPyObject) | Represents method TPythonType_NbRShift(PPyObject,PPyObject).
TPythonType_NbSubstract(PPyObject,PPyObject) | Represents method TPythonType_NbSubstract(PPyObject,PPyObject).
TPythonType_NbTrueDivide(PPyObject,PPyObject) | Represents method TPythonType_NbTrueDivide(PPyObject,PPyObject).
TPythonType_NbXor(PPyObject,PPyObject) | Represents method TPythonType_NbXor(PPyObject,PPyObject).
TPythonType_Print(PPyObject,file,integer) |
TPythonType_Repr(PPyObject) | Represents method TPythonType_Repr(PPyObject).
TPythonType_RichCmp(PPyObject,PPyObject,Integer) | Represents method TPythonType_RichCmp(PPyObject,PPyObject,Integer).
TPythonType_SetAttr(PPyObject,PAnsiChar,PPyObject) | Represents method TPythonType_SetAttr(PPyObject,PAnsiChar,PPyObject).
TPythonType_SetAttrO(PPyObject,PPyObject,PPyObject) | Represents method TPythonType_SetAttrO(PPyObject,PPyObject,PPyObject).
TPythonType_SqAssItem(PPyObject,NativeInt,PPyObject) | Represents method TPythonType_SqAssItem(PPyObject,NativeInt,PPyObject).
TPythonType_SqAssSlice(PPyObject,NativeInt,NativeInt,PPyObject) | Represents method TPythonType_SqAssSlice(PPyObject,NativeInt,NativeInt,PPyObject).
TPythonType_SqConcat(PPyObject,PPyObject) | Represents method TPythonType_SqConcat(PPyObject,PPyObject).
TPythonType_SqContains(PPyObject,PPyObject) | Represents method TPythonType_SqContains(PPyObject,PPyObject).
TPythonType_SqInplaceConcat(PPyObject,PPyObject) | Represents method TPythonType_SqInplaceConcat(PPyObject,PPyObject).
TPythonType_SqInplaceRepeat(PPyObject,NativeInt) | Represents method TPythonType_SqInplaceRepeat(PPyObject,NativeInt).
TPythonType_SqItem(PPyObject,NativeInt) | Represents method TPythonType_SqItem(PPyObject,NativeInt).
TPythonType_SqLength(PPyObject) | Represents method TPythonType_SqLength(PPyObject).
TPythonType_SqRepeat(PPyObject,NativeInt) | Represents method TPythonType_SqRepeat(PPyObject,NativeInt).
TPythonType_SqSlice(PPyObject,NativeInt,NativeInt) | Represents method TPythonType_SqSlice(PPyObject,NativeInt,NativeInt).
TPythonType_Str(PPyObject) | Represents method TPythonType_Str(PPyObject).
TPythonType_Traverse(PPyObject,visitproc,Pointer) | Represents method TPythonType_Traverse(PPyObject,visitproc,Pointer).
Top


BI.Plugins.Python.Engine Classes

Classes
Name | Description
EDLLImportError | Represents type EDLLImportError.
EDLLLoadError | Represents type EDLLLoadError.
EPyArithmeticError | Represents type EPyArithmeticError.
EPyAssertionError | Represents type EPyAssertionError.
EPyAttributeError | Represents type EPyAttributeError.
EPyDeprecationWarning | Represents type EPyDeprecationWarning.
EPyEnvironmentError | Represents type EPyEnvironmentError.
EPyEOFError | Represents type EPyEOFError.
EPyException |
EPyExecError | Represents type EPyExecError.
EPyFloatingPointError | Represents type EPyFloatingPointError.
EPyImportError | Represents type EPyImportError.
EPyIndentationError | Represents type EPyIndentationError.
EPyIndexError | Represents type EPyIndexError.
EPyIOError | Represents type EPyIOError.
EPyKeyboardInterrupt | Represents type EPyKeyboardInterrupt.
EPyKeyError | Represents type EPyKeyError.
EPyLookupError | Represents type EPyLookupError.
EPyMemoryError | Represents type EPyMemoryError.
EPyNameError | Represents type EPyNameError.
EPyNotImplementedError | Represents type EPyNotImplementedError.
EPyOSError | Represents type EPyOSError.
EPyOverflowError | Represents type EPyOverflowError.
EPyReferenceError | Represents type EPyReferenceError.
EPyRuntimeError | Represents type EPyRuntimeError.
EPyRuntimeWarning | Represents type EPyRuntimeWarning.
EPyStandardError | Represents type EPyStandardError.
EPyStopIteration | Represents type EPyStopIteration.
EPySyntaxError | Represents type EPySyntaxError.
EPySyntaxWarning | Represents type EPySyntaxWarning.
EPySystemError | Represents type EPySystemError.
EPySystemExit | Represents type EPySystemExit.
EPyTabError | Represents type EPyTabError.
EPythonError | Represents type EPythonError.
EPyTypeError | Represents type EPyTypeError.
EPyUnboundLocalError | Represents type EPyUnboundLocalError.
EPyUnicodeError | Represents type EPyUnicodeError.
EPyUserWarning | Represents type EPyUserWarning.
EPyValueError | Represents type EPyValueError.
EPyWarning | Represents type EPyWarning.
EPyWindowsError | Represents type EPyWindowsError.
EPyZeroDivisionError | Represents type EPyZeroDivisionError.
FutureWarning | Represents type FutureWarning.
PendingDeprecationWarning | Represents type PendingDeprecationWarning.
TDynamicDll | Represents type TDynamicDll.
TEngineClient | Represents type TEngineClient.
TError | Represents type TError.
TErrors | Represents type TErrors.
TEventDef | Represents type TEventDef.
TEventDefs | Represents type TEventDefs.
TGetSetContainer | Represents type TGetSetContainer.
TMembersContainer | Represents type TMembersContainer.
TMethodsContainer | Represents type TMethodsContainer.
TParentClassError | Represents type TParentClassError.
TPyObject | Represents type TPyObject.
TPythonDelphiVar | Represents type TPythonDelphiVar.
TPythonEngine | Represents type TPythonEngine.
TPythonInputOutput | Represents type TPythonInputOutput.
TPythonInterface | Represents type TPythonInterface.
TPythonModule | Represents type TPythonModule.
TPythonThread | Represents type TPythonThread.
TPythonTraceback | Represents type TPythonTraceback.
TPythonType | Represents type TPythonType.
TPyVar | Represents type TPyVar.
TTracebackItem | Represents type TTracebackItem.
TTypeServices | Represents type TTypeServices.
UnicodeDecodeError | Represents type UnicodeDecodeError.
UnicodeEncodeError | Represents type UnicodeEncodeError.
UnicodeTranslateError | Represents type UnicodeTranslateError.
Top


EDLLImportError Class

Summary

Represents type EDLLImportError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EDLLImportError
Syntax
Delphi
type
 EDLLImportError = class(Exception)
 end;

The EDLLImportError type exposes the following members.

Fields
Show:
Name | Description
ErrorCode | Represents field ErrorCode.
WrongFunc | Represents field WrongFunc.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


EDLLImportError Fields

Fields
Name | Description
ErrorCode | Represents field ErrorCode.
WrongFunc | Represents field WrongFunc.
Top


EDLLImportError.ErrorCode Field

Summary

Represents field ErrorCode.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ErrorCode : Integer;

Field Value

Type: Integer

See Also

Reference

  • EDLLImportError
  • BI.Plugins.Python.Engine


EDLLImportError.WrongFunc Field

Summary

Represents field WrongFunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 WrongFunc : AnsiString;

Field Value

Type: AnsiString

See Also

Reference

  • EDLLImportError
  • BI.Plugins.Python.Engine


EDLLLoadError Class

Summary

Represents type EDLLLoadError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EDLLLoadError
Syntax
Delphi
type
 EDLLLoadError = class(Exception);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyArithmeticError Class

Summary

Represents type EPyArithmeticError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyArithmeticError
BI.Plugins.Python.Engine.EPyFloatingPointError
BI.Plugins.Python.Engine.EPyOverflowError
BI.Plugins.Python.Engine.EPyZeroDivisionError
Syntax
Delphi
type
 EPyArithmeticError = class (EPyStandardError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyAssertionError Class

Summary

Represents type EPyAssertionError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyAssertionError
Syntax
Delphi
type
 EPyAssertionError = class (EPyStandardError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyAttributeError Class

Summary

Represents type EPyAttributeError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyAttributeError
Syntax
Delphi
type
 EPyAttributeError = class (EPyStandardError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyDeprecationWarning Class

Summary

Represents type EPyDeprecationWarning.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyWarning
BI.Plugins.Python.Engine.EPyDeprecationWarning
Syntax
Delphi
type
 EPyDeprecationWarning = class (EPyWarning);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyEnvironmentError Class

Summary

Represents type EPyEnvironmentError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyEnvironmentError
BI.Plugins.Python.Engine.EPyIOError
BI.Plugins.Python.Engine.EPyOSError
Syntax
Delphi
type
 EPyEnvironmentError = class (EPyStandardError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyEOFError Class

Summary

Represents type EPyEOFError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyEOFError
Syntax
Delphi
type
 EPyEOFError = class (EPyStandardError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyException Class

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyStopIteration
BI.Plugins.Python.Engine.EPySystemExit
BI.Plugins.Python.Engine.EPyWarning
Syntax
Delphi
type
 EPyException = class (EPythonError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyExecError Class

Summary

Represents type EPyExecError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyExecError
Syntax
Delphi
type
 EPyExecError = class(EPythonError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyFloatingPointError Class

Summary

Represents type EPyFloatingPointError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyArithmeticError
BI.Plugins.Python.Engine.EPyFloatingPointError
Syntax
Delphi
type
 EPyFloatingPointError = class (EPyArithmeticError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyImportError Class

Summary

Represents type EPyImportError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyImportError
Syntax
Delphi
type
 EPyImportError = class (EPyStandardError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyIndentationError Class

Summary

Represents type EPyIndentationError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPySyntaxError
BI.Plugins.Python.Engine.EPyIndentationError
BI.Plugins.Python.Engine.EPyTabError
Syntax
Delphi
type
 EPyIndentationError = class (EPySyntaxError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyIndexError Class

Summary

Represents type EPyIndexError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyLookupError
BI.Plugins.Python.Engine.EPyIndexError
Syntax
Delphi
type
 EPyIndexError = class (EPyLookupError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyIOError Class

Summary

Represents type EPyIOError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyEnvironmentError
BI.Plugins.Python.Engine.EPyIOError
Syntax
Delphi
type
 EPyIOError = class (EPyEnvironmentError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyKeyboardInterrupt Class

Summary

Represents type EPyKeyboardInterrupt.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyKeyboardInterrupt
Syntax
Delphi
type
 EPyKeyboardInterrupt = class (EPyStandardError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyKeyError Class

Summary

Represents type EPyKeyError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyLookupError
BI.Plugins.Python.Engine.EPyKeyError
Syntax
Delphi
type
 EPyKeyError = class (EPyLookupError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyLookupError Class

Summary

Represents type EPyLookupError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyLookupError
BI.Plugins.Python.Engine.EPyIndexError
BI.Plugins.Python.Engine.EPyKeyError
Syntax
Delphi
type
 EPyLookupError = class (EPyStandardError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyMemoryError Class

Summary

Represents type EPyMemoryError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyMemoryError
Syntax
Delphi
type
 EPyMemoryError = class (EPyStandardError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyNameError Class

Summary

Represents type EPyNameError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyNameError
BI.Plugins.Python.Engine.EPyUnboundLocalError
Syntax
Delphi
type
 EPyNameError = class (EPyStandardError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyNotImplementedError Class

Summary

Represents type EPyNotImplementedError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyRuntimeError
BI.Plugins.Python.Engine.EPyNotImplementedError
Syntax
Delphi
type
 EPyNotImplementedError = class (EPyRuntimeError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyOSError Class

Summary

Represents type EPyOSError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyEnvironmentError
BI.Plugins.Python.Engine.EPyOSError
BI.Plugins.Python.Engine.EPyWindowsError
Syntax
Delphi
type
 EPyOSError = class (EPyEnvironmentError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyOverflowError Class

Summary

Represents type EPyOverflowError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyArithmeticError
BI.Plugins.Python.Engine.EPyOverflowError
Syntax
Delphi
type
 EPyOverflowError = class (EPyArithmeticError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyReferenceError Class

Summary

Represents type EPyReferenceError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyReferenceError
Syntax
Delphi
type
 EPyReferenceError = class (EPyStandardError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyRuntimeError Class

Summary

Represents type EPyRuntimeError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyRuntimeError
BI.Plugins.Python.Engine.EPyNotImplementedError
Syntax
Delphi
type
 EPyRuntimeError = class (EPyStandardError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyRuntimeWarning Class

Summary

Represents type EPyRuntimeWarning.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyWarning
BI.Plugins.Python.Engine.EPyRuntimeWarning
Syntax
Delphi
type
 EPyRuntimeWarning = class (EPyWarning);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyStandardError Class

Summary

Represents type EPyStandardError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyArithmeticError
BI.Plugins.Python.Engine.EPyAssertionError
BI.Plugins.Python.Engine.EPyAttributeError
BI.Plugins.Python.Engine.EPyEnvironmentError
BI.Plugins.Python.Engine.EPyEOFError
BI.Plugins.Python.Engine.EPyImportError
BI.Plugins.Python.Engine.EPyKeyboardInterrupt
BI.Plugins.Python.Engine.EPyLookupError
BI.Plugins.Python.Engine.EPyMemoryError
BI.Plugins.Python.Engine.EPyNameError
BI.Plugins.Python.Engine.EPyReferenceError
BI.Plugins.Python.Engine.EPyRuntimeError
BI.Plugins.Python.Engine.EPySyntaxError
BI.Plugins.Python.Engine.EPySystemError
BI.Plugins.Python.Engine.EPyTypeError
BI.Plugins.Python.Engine.EPyValueError
Syntax
Delphi
type
 EPyStandardError = class (EPyException);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyStopIteration Class

Summary

Represents type EPyStopIteration.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStopIteration
Syntax
Delphi
type
 EPyStopIteration = class(EPyException);
See Also

Reference

  • BI.Plugins.Python.Engine


EPySyntaxError Class

Summary

Represents type EPySyntaxError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPySyntaxError
BI.Plugins.Python.Engine.EPyIndentationError
Syntax
Delphi
type
 EPySyntaxError = class (EPyStandardError)
 end;

The EPySyntaxError type exposes the following members.

Fields
Show:
Name | Description
EFileName | Represents field EFileName.
ELineNumber | Represents field ELineNumber.
ELineStr | Represents field ELineStr.
EOffset | Represents field EOffset.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


EPySyntaxError Fields

Fields
Name | Description
EFileName | Represents field EFileName.
ELineNumber | Represents field ELineNumber.
ELineStr | Represents field ELineStr.
EOffset | Represents field EOffset.
Top


EPySyntaxError.EFileName Field

Summary

Represents field EFileName.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 EFileName: string;

Field Value

Type: string

See Also

Reference

  • EPySyntaxError
  • BI.Plugins.Python.Engine


EPySyntaxError.ELineNumber Field

Summary

Represents field ELineNumber.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ELineNumber: Integer;

Field Value

Type: Integer

See Also

Reference

  • EPySyntaxError
  • BI.Plugins.Python.Engine


EPySyntaxError.ELineStr Field

Summary

Represents field ELineStr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ELineStr: string;

Field Value

Type: string

See Also

Reference

  • EPySyntaxError
  • BI.Plugins.Python.Engine


EPySyntaxError.EOffset Field

Summary

Represents field EOffset.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 EOffset: Integer;

Field Value

Type: Integer

See Also

Reference

  • EPySyntaxError
  • BI.Plugins.Python.Engine


EPySyntaxWarning Class

Summary

Represents type EPySyntaxWarning.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyWarning
BI.Plugins.Python.Engine.EPySyntaxWarning
Syntax
Delphi
type
 EPySyntaxWarning = class (EPyWarning);
See Also

Reference

  • BI.Plugins.Python.Engine


EPySystemError Class

Summary

Represents type EPySystemError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPySystemError
Syntax
Delphi
type
 EPySystemError = class (EPyStandardError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPySystemExit Class

Summary

Represents type EPySystemExit.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPySystemExit
Syntax
Delphi
type
 EPySystemExit = class (EPyException);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyTabError Class

Summary

Represents type EPyTabError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPySyntaxError
BI.Plugins.Python.Engine.EPyIndentationError
BI.Plugins.Python.Engine.EPyTabError
Syntax
Delphi
type
 EPyTabError = class (EPyIndentationError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPythonError Class

Summary

Represents type EPythonError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyExecError
Syntax
Delphi
type
 EPythonError = class(Exception)
 end;

The EPythonError type exposes the following members.

Fields
Show:
Name | Description
EName | Represents field EName.
EValue | Represents field EValue.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


EPythonError Fields

Fields
Name | Description
EName | Represents field EName.
EValue | Represents field EValue.
Top


EPythonError.EName Field

Summary

Represents field EName.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 EName : String;

Field Value

Type: String

See Also

Reference

  • EPythonError
  • BI.Plugins.Python.Engine


EPythonError.EValue Field

Summary

Represents field EValue.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 EValue : String;

Field Value

Type: String

See Also

Reference

  • EPythonError
  • BI.Plugins.Python.Engine


EPyTypeError Class

Summary

Represents type EPyTypeError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyTypeError
Syntax
Delphi
type
 EPyTypeError = class (EPyStandardError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyUnboundLocalError Class

Summary

Represents type EPyUnboundLocalError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyNameError
BI.Plugins.Python.Engine.EPyUnboundLocalError
Syntax
Delphi
type
 EPyUnboundLocalError = class (EPyNameError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyUnicodeError Class

Summary

Represents type EPyUnicodeError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyValueError
BI.Plugins.Python.Engine.EPyUnicodeError
BI.Plugins.Python.Engine.UnicodeDecodeError
BI.Plugins.Python.Engine.UnicodeEncodeError
BI.Plugins.Python.Engine.UnicodeTranslateError
Syntax
Delphi
type
 EPyUnicodeError = class (EPyValueError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyUserWarning Class

Summary

Represents type EPyUserWarning.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyWarning
BI.Plugins.Python.Engine.EPyUserWarning
Syntax
Delphi
type
 EPyUserWarning = class (EPyWarning);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyValueError Class

Summary

Represents type EPyValueError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyValueError
BI.Plugins.Python.Engine.EPyUnicodeError
Syntax
Delphi
type
 EPyValueError = class (EPyStandardError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyWarning Class

Summary

Represents type EPyWarning.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyWarning
BI.Plugins.Python.Engine.EPyDeprecationWarning
BI.Plugins.Python.Engine.EPyRuntimeWarning
BI.Plugins.Python.Engine.EPySyntaxWarning
BI.Plugins.Python.Engine.EPyUserWarning
BI.Plugins.Python.Engine.FutureWarning
BI.Plugins.Python.Engine.PendingDeprecationWarning
Syntax
Delphi
type
 EPyWarning = class (EPyException);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyWindowsError Class

Summary

Represents type EPyWindowsError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyEnvironmentError
BI.Plugins.Python.Engine.EPyOSError
BI.Plugins.Python.Engine.EPyWindowsError
Syntax
Delphi
type
 EPyWindowsError = class (EPyOSError);
See Also

Reference

  • BI.Plugins.Python.Engine


EPyZeroDivisionError Class

Summary

Represents type EPyZeroDivisionError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyArithmeticError
BI.Plugins.Python.Engine.EPyZeroDivisionError
Syntax
Delphi
type
 EPyZeroDivisionError = class (EPyArithmeticError);
See Also

Reference

  • BI.Plugins.Python.Engine


FutureWarning Class

Summary

Represents type FutureWarning.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyWarning
BI.Plugins.Python.Engine.FutureWarning
Syntax
Delphi
type
 FutureWarning = class (EPyWarning);
See Also

Reference

  • BI.Plugins.Python.Engine


PendingDeprecationWarning Class

Summary

Represents type PendingDeprecationWarning.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyWarning
BI.Plugins.Python.Engine.PendingDeprecationWarning
Syntax
Delphi
type
 PendingDeprecationWarning = class (EPyWarning);
See Also

Reference

  • BI.Plugins.Python.Engine


TDynamicDll Class

Summary

Represents type TDynamicDll.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TComponent
BI.Plugins.Python.Engine.TDynamicDll
BI.Plugins.Python.Engine.TPythonInterface
Syntax
Delphi
type
 TDynamicDll = class(TComponent)
 end;

The TDynamicDll type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TDynamicDll class.
Destroy | Represents the destructor of the TDynamicDll class.
Top
Properties
Show:
Name | Description
APIVersion | Represents property APIVersion.
AutoLoad | Represents property AutoLoad.
AutoUnload | Represents property AutoUnload.
DllName | Represents property DllName.
DllPath | Represents property DllPath.
FatalAbort | Represents property FatalAbort.
FatalMsgDlg | Represents property FatalMsgDlg.
OnAfterLoad | Represents property OnAfterLoad.
OnBeforeLoad | Represents property OnBeforeLoad.
OnBeforeUnload | Represents property OnBeforeUnload.
RegVersion | Represents property RegVersion.
UseLastKnownVersion | Represents property UseLastKnownVersion.
Top
Methods
Show:
Name | Description
AfterLoad | Represents method AfterLoad.
BeforeLoad | Represents method BeforeLoad.
BeforeUnload | Represents method BeforeUnload.
DoOpenDll(String) | Represents method DoOpenDll(String).
GetDllPath | Represents method GetDllPath.
GetQuitMessage | Represents method GetQuitMessage.
Import(AnsiString,Boolean) | Represents method Import(AnsiString,Boolean).
IsHandleValid | Represents method IsHandleValid.
LoadDll | Represents method LoadDll.
Loaded | Represents method Loaded.
OpenDll(String) | Represents method OpenDll(String).
Quit | Represents method Quit.
UnloadDll | Represents method UnloadDll.
Top
Fields
Show:
Name | Description
FAPIVersion | Represents field FAPIVersion.
FAutoLoad | Represents field FAutoLoad.
FAutoUnload | Represents field FAutoUnload.
FDLLHandle | Represents field FDLLHandle.
FDllName | Represents field FDllName.
FDllPath | Represents field FDllPath.
FFatalAbort | Represents field FFatalAbort.
FFatalMsgDlg | Represents field FFatalMsgDlg.
FOnAfterLoad | Represents field FOnAfterLoad.
FOnBeforeLoad | Represents field FOnBeforeLoad.
FOnBeforeUnload | Represents field FOnBeforeUnload.
FRegVersion | Represents field FRegVersion.
FUseLastKnownVersion | Represents field FUseLastKnownVersion.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TDynamicDll Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TDynamicDll class.
Destroy | Represents the destructor of the TDynamicDll class.
Top


TDynamicDll.Create(TComponent) Constructor

Summary

Initializes a new instance of the TDynamicDll class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.Destroy Destructor

Summary

Represents the destructor of the TDynamicDll class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll Properties

Properties
Name | Description
APIVersion | Represents property APIVersion.
AutoLoad | Represents property AutoLoad.
AutoUnload | Represents property AutoUnload.
DllName | Represents property DllName.
DllPath | Represents property DllPath.
FatalAbort | Represents property FatalAbort.
FatalMsgDlg | Represents property FatalMsgDlg.
OnAfterLoad | Represents property OnAfterLoad.
OnBeforeLoad | Represents property OnBeforeLoad.
OnBeforeUnload | Represents property OnBeforeUnload.
RegVersion | Represents property RegVersion.
UseLastKnownVersion | Represents property UseLastKnownVersion.
Top


TDynamicDll.APIVersion Property

Summary

Represents property APIVersion.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property APIVersion : Integer read FAPIVersion write FAPIVersion stored IsAPIVersionStored;

Property Value

Type: Integer

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.AutoLoad Property

Summary

Represents property AutoLoad.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property AutoLoad : Boolean read FAutoLoad write FAutoLoad default True;

Property Value

Type: Boolean

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.AutoUnload Property

Summary

Represents property AutoUnload.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property AutoUnload : Boolean read FAutoUnload write FAutoUnload default True;

Property Value

Type: Boolean

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.DllName Property

Summary

Represents property DllName.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property DllName : String read FDllName write SetDllName stored IsDllNameStored;

Property Value

Type: String

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.DllPath Property

Summary

Represents property DllPath.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property DllPath : String read FDllPath write FDllPath;

Property Value

Type: String

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.FatalAbort Property

Summary

Represents property FatalAbort.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property FatalAbort : Boolean read FFatalAbort write FFatalAbort default True;

Property Value

Type: Boolean

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.FatalMsgDlg Property

Summary

Represents property FatalMsgDlg.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property FatalMsgDlg : Boolean read FFatalMsgDlg write FFatalMsgDlg default True;

Property Value

Type: Boolean

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.OnAfterLoad Property

Summary

Represents property OnAfterLoad.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property OnAfterLoad : TNotifyEvent read FOnAfterLoad write FOnAfterLoad;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.OnBeforeLoad Property

Summary

Represents property OnBeforeLoad.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property OnBeforeLoad : TNotifyEvent read FOnBeforeLoad write FOnBeforeLoad;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.OnBeforeUnload Property

Summary

Represents property OnBeforeUnload.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property OnBeforeUnload : TNotifyEvent read FOnBeforeUnload write FOnBeforeUnload;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.RegVersion Property

Summary

Represents property RegVersion.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property RegVersion : String read FRegVersion write FRegVersion stored IsRegVersionStored;

Property Value

Type: String

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.UseLastKnownVersion Property

Summary

Represents property UseLastKnownVersion.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property UseLastKnownVersion: Boolean read FUseLastKnownVersion write FUseLastKnownVersion default True;

Property Value

Type: Boolean

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll Methods

Methods
Name | Description
AfterLoad | Represents method AfterLoad.
BeforeLoad | Represents method BeforeLoad.
BeforeUnload | Represents method BeforeUnload.
DoOpenDll(String) | Represents method DoOpenDll(String).
GetDllPath | Represents method GetDllPath.
GetQuitMessage | Represents method GetQuitMessage.
Import(AnsiString,Boolean) | Represents method Import(AnsiString,Boolean).
IsHandleValid | Represents method IsHandleValid.
LoadDll | Represents method LoadDll.
Loaded | Represents method Loaded.
OpenDll(String) | Represents method OpenDll(String).
Quit | Represents method Quit.
UnloadDll | Represents method UnloadDll.
Top


TDynamicDll.AfterLoad Method

Summary

Represents method AfterLoad.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure AfterLoad; virtual;
See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.BeforeLoad Method

Summary

Represents method BeforeLoad.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure BeforeLoad; virtual;
See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.BeforeUnload Method

Summary

Represents method BeforeUnload.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure BeforeUnload; virtual;
See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.DoOpenDll(String) Method

Summary

Represents method DoOpenDll(String).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure DoOpenDll(const aDllName : String); virtual;

Parameters

aDllName
Type: String

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.GetDllPath Method

Summary

Represents method GetDllPath.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 function GetDllPath : String;

Return Value

Type: String

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.GetQuitMessage Method

Summary

Represents method GetQuitMessage.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 function GetQuitMessage : String; virtual;

Return Value

Type: String

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.Import(AnsiString,Boolean) Method

Summary

Represents method Import(AnsiString,Boolean).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 function Import(const funcname: AnsiString; canFail : Boolean = True): Pointer;

Parameters

funcname
Type: AnsiString

canFail
Type: Boolean

Return Value

Type: Pointer

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.IsHandleValid Method

Summary

Represents method IsHandleValid.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function IsHandleValid : Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.LoadDll Method

Summary

Represents method LoadDll.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure LoadDll;
See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.Loaded Method

Summary

Represents method Loaded.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure Loaded; override;
See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.OpenDll(String) Method

Summary

Represents method OpenDll(String).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure OpenDll(const aDllName : String);

Parameters

aDllName
Type: String

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.Quit Method

Summary

Represents method Quit.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Quit;
See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.UnloadDll Method

Summary

Represents method UnloadDll.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure UnloadDll;
See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll Fields

Fields
Name | Description
FAPIVersion | Represents field FAPIVersion.
FAutoLoad | Represents field FAutoLoad.
FAutoUnload | Represents field FAutoUnload.
FDLLHandle | Represents field FDLLHandle.
FDllName | Represents field FDllName.
FDllPath | Represents field FDllPath.
FFatalAbort | Represents field FFatalAbort.
FFatalMsgDlg | Represents field FFatalMsgDlg.
FOnAfterLoad | Represents field FOnAfterLoad.
FOnBeforeLoad | Represents field FOnBeforeLoad.
FOnBeforeUnload | Represents field FOnBeforeUnload.
FRegVersion | Represents field FRegVersion.
FUseLastKnownVersion | Represents field FUseLastKnownVersion.
Top


TDynamicDll.FAPIVersion Field

Summary

Represents field FAPIVersion.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FAPIVersion : Integer;

Field Value

Type: Integer

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.FAutoLoad Field

Summary

Represents field FAutoLoad.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FAutoLoad : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.FAutoUnload Field

Summary

Represents field FAutoUnload.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FAutoUnload : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.FDLLHandle Field

Summary

Represents field FDLLHandle.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FDLLHandle : THandle;

Field Value

Type: THandle

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.FDllName Field

Summary

Represents field FDllName.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FDllName : String;

Field Value

Type: String

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.FDllPath Field

Summary

Represents field FDllPath.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FDllPath : String;

Field Value

Type: String

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.FFatalAbort Field

Summary

Represents field FFatalAbort.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FFatalAbort : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.FFatalMsgDlg Field

Summary

Represents field FFatalMsgDlg.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FFatalMsgDlg : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.FOnAfterLoad Field

Summary

Represents field FOnAfterLoad.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FOnAfterLoad : TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.FOnBeforeLoad Field

Summary

Represents field FOnBeforeLoad.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FOnBeforeLoad : TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.FOnBeforeUnload Field

Summary

Represents field FOnBeforeUnload.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FOnBeforeUnload : TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.FRegVersion Field

Summary

Represents field FRegVersion.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FRegVersion : String;

Field Value

Type: String

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TDynamicDll.FUseLastKnownVersion Field

Summary

Represents field FUseLastKnownVersion.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FUseLastKnownVersion: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TDynamicDll
  • BI.Plugins.Python.Engine


TEngineClient Class

Summary

Represents type TEngineClient.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TComponent
BI.Plugins.Python.Engine.TEngineClient
BI.Plugins.Python.Engine.TMethodsContainer
BI.Plugins.Python.Engine.TPythonDelphiVar
Syntax
Delphi
type
 TEngineClient = class(TComponent)
 end;

The TEngineClient type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TEngineClient class.
Destroy | Represents the destructor of the TEngineClient class.
Top
Properties
Show:
Name | Description
Engine | Represents property Engine.
Initialized | Represents property Initialized.
OnCreate | Represents property OnCreate.
OnDestroy | Represents property OnDestroy.
OnFinalization | Represents property OnFinalization.
OnInitialization | Represents property OnInitialization.
Top
Methods
Show:
Name | Description
CheckEngine | Represents method CheckEngine.
ClearEngine | Represents method ClearEngine.
Finalize | Represents method Finalize.
Initialize | Represents method Initialize.
Loaded | Represents method Loaded.
ModuleReady(TObject) | Represents method ModuleReady(TObject).
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
Top
Fields
Show:
Name | Description
FEngine | Represents field FEngine.
FInitialized | Represents field FInitialized.
FOnCreate | Represents field FOnCreate.
FOnDestroy | Represents field FOnDestroy.
FOnFinalization | Represents field FOnFinalization.
FOnInitialization | Represents field FOnInitialization.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TEngineClient Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TEngineClient class.
Destroy | Represents the destructor of the TEngineClient class.
Top


TEngineClient.Create(TComponent) Constructor

Summary

Initializes a new instance of the TEngineClient class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 constructor Create( AOwner : TComponent ); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TEngineClient
  • BI.Plugins.Python.Engine


TEngineClient.Destroy Destructor

Summary

Represents the destructor of the TEngineClient class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TEngineClient
  • BI.Plugins.Python.Engine


TEngineClient Properties

Properties
Name | Description
Engine | Represents property Engine.
Initialized | Represents property Initialized.
OnCreate | Represents property OnCreate.
OnDestroy | Represents property OnDestroy.
OnFinalization | Represents property OnFinalization.
OnInitialization | Represents property OnInitialization.
Top


TEngineClient.Engine Property

Summary

Represents property Engine.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property Engine : TPythonEngine read FEngine write SetEngine;

Property Value

Type: TPythonEngine

See Also

Reference

  • TEngineClient
  • BI.Plugins.Python.Engine


TEngineClient.Initialized Property

Summary

Represents property Initialized.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property Initialized: Boolean read FInitialized;

Property Value

Type: Boolean

See Also

Reference

  • TEngineClient
  • BI.Plugins.Python.Engine


TEngineClient.OnCreate Property

Summary

Represents property OnCreate.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property OnCreate : TNotifyEvent read FOnCreate write FOnCreate;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TEngineClient
  • BI.Plugins.Python.Engine


TEngineClient.OnDestroy Property

Summary

Represents property OnDestroy.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property OnDestroy : TNotifyEvent read FOnDestroy write FOnDestroy;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TEngineClient
  • BI.Plugins.Python.Engine


TEngineClient.OnFinalization Property

Summary

Represents property OnFinalization.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property OnFinalization : TNotifyEvent read FOnFinalization write FOnFinalization;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TEngineClient
  • BI.Plugins.Python.Engine


TEngineClient.OnInitialization Property

Summary

Represents property OnInitialization.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property OnInitialization : TNotifyEvent read FOnInitialization write FOnInitialization;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TEngineClient
  • BI.Plugins.Python.Engine


TEngineClient Methods

Methods
Name | Description
CheckEngine | Represents method CheckEngine.
ClearEngine | Represents method ClearEngine.
Finalize | Represents method Finalize.
Initialize | Represents method Initialize.
Loaded | Represents method Loaded.
ModuleReady(TObject) | Represents method ModuleReady(TObject).
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
Top


TEngineClient.CheckEngine Method

Summary

Represents method CheckEngine.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure CheckEngine;
See Also

Reference

  • TEngineClient
  • BI.Plugins.Python.Engine


TEngineClient.ClearEngine Method

Summary

Represents method ClearEngine.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure ClearEngine;
See Also

Reference

  • TEngineClient
  • BI.Plugins.Python.Engine


TEngineClient.Finalize Method

Summary

Represents method Finalize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Finalize; virtual;
See Also

Reference

  • TEngineClient
  • BI.Plugins.Python.Engine


TEngineClient.Initialize Method

Summary

Represents method Initialize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Initialize; virtual;
See Also

Reference

  • TEngineClient
  • BI.Plugins.Python.Engine


TEngineClient.Loaded Method

Summary

Represents method Loaded.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure Loaded; override;
See Also

Reference

  • TEngineClient
  • BI.Plugins.Python.Engine


TEngineClient.ModuleReady(TObject) Method

Summary

Represents method ModuleReady(TObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure ModuleReady(Sender : TObject); virtual;

Parameters

Sender
Type: TObject

See Also

Reference

  • TEngineClient
  • BI.Plugins.Python.Engine


TEngineClient.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure Notification( AComponent: TComponent;
 Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

See Also

Reference

  • TEngineClient
  • BI.Plugins.Python.Engine


TEngineClient Fields

Fields
Name | Description
FEngine | Represents field FEngine.
FInitialized | Represents field FInitialized.
FOnCreate | Represents field FOnCreate.
FOnDestroy | Represents field FOnDestroy.
FOnFinalization | Represents field FOnFinalization.
FOnInitialization | Represents field FOnInitialization.
Top


TEngineClient.FEngine Field

Summary

Represents field FEngine.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FEngine : TPythonEngine;

Field Value

Type: TPythonEngine

See Also

Reference

  • TEngineClient
  • BI.Plugins.Python.Engine


TEngineClient.FInitialized Field

Summary

Represents field FInitialized.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FInitialized : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TEngineClient
  • BI.Plugins.Python.Engine


TEngineClient.FOnCreate Field

Summary

Represents field FOnCreate.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FOnCreate : TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TEngineClient
  • BI.Plugins.Python.Engine


TEngineClient.FOnDestroy Field

Summary

Represents field FOnDestroy.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FOnDestroy : TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TEngineClient
  • BI.Plugins.Python.Engine


TEngineClient.FOnFinalization Field

Summary

Represents field FOnFinalization.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FOnFinalization : TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TEngineClient
  • BI.Plugins.Python.Engine


TEngineClient.FOnInitialization Field

Summary

Represents field FOnInitialization.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FOnInitialization : TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TEngineClient
  • BI.Plugins.Python.Engine


TError Class

Summary

Represents type TError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TCollectionItem
BI.Plugins.Python.Engine.TError
Syntax
Delphi
type
 TError = class(TCollectionItem)
 end;

The TError type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TError class.
Destroy | Represents the destructor of the TError class.
Top
Properties
Show:
Name | Description
Error | Represents property Error.
ErrorType | Represents property ErrorType.
Name | Represents property Name.
ParentClass | Represents property ParentClass.
Text | Represents property Text.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
BuildError(AnsiString) | Represents method BuildError(AnsiString).
GetDisplayName | Represents method GetDisplayName.
Owner | Represents method Owner.
RaiseError(AnsiString) | Represents method RaiseError(AnsiString).
RaiseErrorObj(AnsiString,PPyObject) | Represents method RaiseErrorObj(AnsiString,PPyObject).
Top
Fields
Show:
Name | Description
FError | Represents field FError.
FErrorType | Represents field FErrorType.
FName | Represents field FName.
FParentClass | Represents field FParentClass.
FText | Represents field FText.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TError Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TError class.
Destroy | Represents the destructor of the TError class.
Top


TError.Create(TCollection) Constructor

Summary

Initializes a new instance of the TError class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 constructor Create(ACollection: TCollection); override;

Parameters

ACollection
Type: TCollection

See Also

Reference

  • TError
  • BI.Plugins.Python.Engine


TError.Destroy Destructor

Summary

Represents the destructor of the TError class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TError
  • BI.Plugins.Python.Engine


TError Properties

Properties
Name | Description
Error | Represents property Error.
ErrorType | Represents property ErrorType.
Name | Represents property Name.
ParentClass | Represents property ParentClass.
Text | Represents property Text.
Top


TError.Error Property

Summary

Represents property Error.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property Error : PPyObject read FError write FError;

Property Value

Type: PPyObject

See Also

Reference

  • TError
  • BI.Plugins.Python.Engine


TError.ErrorType Property

Summary

Represents property ErrorType.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property ErrorType : TErrorType read FErrorType write SetErrorType;

Property Value

Type: TErrorType

See Also

Reference

  • TError
  • BI.Plugins.Python.Engine


TError.Name Property

Summary

Represents property Name.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property Name : AnsiString read FName write SetName;

Property Value

Type: AnsiString

See Also

Reference

  • TError
  • BI.Plugins.Python.Engine


TError.ParentClass Property

Summary

Represents property ParentClass.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property ParentClass : TParentClassError read FParentClass write SetParentClass;

Property Value

Type: TParentClassError

See Also

Reference

  • TError
  • BI.Plugins.Python.Engine


TError.Text Property

Summary

Represents property Text.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property Text : AnsiString read FText write SetText;

Property Value

Type: AnsiString

See Also

Reference

  • TError
  • BI.Plugins.Python.Engine


TError Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
BuildError(AnsiString) | Represents method BuildError(AnsiString).
GetDisplayName | Represents method GetDisplayName.
Owner | Represents method Owner.
RaiseError(AnsiString) | Represents method RaiseError(AnsiString).
RaiseErrorObj(AnsiString,PPyObject) | Represents method RaiseErrorObj(AnsiString,PPyObject).
Top


TError.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TError
  • BI.Plugins.Python.Engine


TError.BuildError(AnsiString) Method

Summary

Represents method BuildError(AnsiString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure BuildError( const ModuleName : AnsiString );

Parameters

ModuleName
Type: AnsiString

See Also

Reference

  • TError
  • BI.Plugins.Python.Engine


TError.GetDisplayName Method

Summary

Represents method GetDisplayName.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 function GetDisplayName: string; override;

Return Value

Type: string

See Also

Reference

  • TError
  • BI.Plugins.Python.Engine


TError.Owner Method

Summary

Represents method Owner.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Owner : TErrors;

Return Value

Type: TErrors

See Also

Reference

  • TError
  • BI.Plugins.Python.Engine


TError.RaiseError(AnsiString) Method

Summary

Represents method RaiseError(AnsiString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure RaiseError( const msg : AnsiString );

Parameters

msg
Type: AnsiString

See Also

Reference

  • TError
  • BI.Plugins.Python.Engine


TError.RaiseErrorObj(AnsiString,PPyObject) Method

Summary

Represents method RaiseErrorObj(AnsiString,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure RaiseErrorObj( const msg : AnsiString; obj : PPyObject );

Parameters

msg
Type: AnsiString

obj
Type: PPyObject

See Also

Reference

  • TError
  • BI.Plugins.Python.Engine


TError Fields

Fields
Name | Description
FError | Represents field FError.
FErrorType | Represents field FErrorType.
FName | Represents field FName.
FParentClass | Represents field FParentClass.
FText | Represents field FText.
Top


TError.FError Field

Summary

Represents field FError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FError : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • TError
  • BI.Plugins.Python.Engine


TError.FErrorType Field

Summary

Represents field FErrorType.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FErrorType : TErrorType;

Field Value

Type: TErrorType

See Also

Reference

  • TError
  • BI.Plugins.Python.Engine


TError.FName Field

Summary

Represents field FName.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FName : AnsiString;

Field Value

Type: AnsiString

See Also

Reference

  • TError
  • BI.Plugins.Python.Engine


TError.FParentClass Field

Summary

Represents field FParentClass.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FParentClass : TParentClassError;

Field Value

Type: TParentClassError

See Also

Reference

  • TError
  • BI.Plugins.Python.Engine


TError.FText Field

Summary

Represents field FText.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FText : AnsiString;

Field Value

Type: AnsiString

See Also

Reference

  • TError
  • BI.Plugins.Python.Engine


TErrors Class

Summary

Represents type TErrors.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TCollection
BI.Plugins.Python.Engine.TErrors
Syntax
Delphi
type
 TErrors = class(TCollection)
 end;

The TErrors type exposes the following members.

Constructors
Show:
Name | Description
Create(TPythonModule) | Initializes a new instance of the TErrors class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Add | Represents method Add.
GetOwner | Represents method GetOwner.
Owner | Represents method Owner.
Update(TCollectionItem) | Represents method Update(TCollectionItem).
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TErrors Constructors

Constructors
Name | Description
Create(TPythonModule) | Initializes a new instance of the TErrors class.
Top


TErrors.Create(TPythonModule) Constructor

Summary

Initializes a new instance of the TErrors class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 constructor Create(Module: TPythonModule);

Parameters

Module
Type: TPythonModule

See Also

Reference

  • TErrors
  • BI.Plugins.Python.Engine


TErrors Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TErrors.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property Items[Index: Integer]: TError read GetError write SetError; default;

Parameters

Index
Type: Integer

Property Value

Type: TError

See Also

Reference

  • TErrors
  • BI.Plugins.Python.Engine


TErrors Methods

Methods
Name | Description
Add | Represents method Add.
GetOwner | Represents method GetOwner.
Owner | Represents method Owner.
Update(TCollectionItem) | Represents method Update(TCollectionItem).
Top


TErrors.Add Method

Summary

Represents method Add.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Add: TError;

Return Value

Type: TError

See Also

Reference

  • TErrors
  • BI.Plugins.Python.Engine


TErrors.GetOwner Method

Summary

Represents method GetOwner.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 function GetOwner: TPersistent; override;

Return Value

Type: TPersistent

See Also

Reference

  • TErrors
  • BI.Plugins.Python.Engine


TErrors.Owner Method

Summary

Represents method Owner.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Owner : TPythonModule;

Return Value

Type: TPythonModule

See Also

Reference

  • TErrors
  • BI.Plugins.Python.Engine


TErrors.Update(TCollectionItem) Method

Summary

Represents method Update(TCollectionItem).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure Update(Item: TCollectionItem); override;

Parameters

Item
Type: TCollectionItem

See Also

Reference

  • TErrors
  • BI.Plugins.Python.Engine


TEventDef Class

Summary

Represents type TEventDef.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TCollectionItem
BI.Plugins.Python.Engine.TEventDef
Syntax
Delphi
type
 TEventDef = class(TCollectionItem)
 end;

The TEventDef type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TEventDef class.
Destroy | Represents the destructor of the TEventDef class.
Top
Properties
Show:
Name | Description
DocString | Represents property DocString.
Name | Represents property Name.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
GetDocString | Represents method GetDocString.
Owner | Represents method Owner.
PythonEvent(PPyObject,PPyObject) | Represents method PythonEvent(PPyObject,PPyObject).
Top
Events
Show:
Name | Description
OnExecute | Represents property OnExecute.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TEventDef Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TEventDef class.
Destroy | Represents the destructor of the TEventDef class.
Top


TEventDef.Create(TCollection) Constructor

Summary

Initializes a new instance of the TEventDef class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 constructor Create(ACollection: TCollection); override;

Parameters

ACollection
Type: TCollection

See Also

Reference

  • TEventDef
  • BI.Plugins.Python.Engine


TEventDef.Destroy Destructor

Summary

Represents the destructor of the TEventDef class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TEventDef
  • BI.Plugins.Python.Engine


TEventDef Properties

Properties
Name | Description
DocString | Represents property DocString.
Name | Represents property Name.
Top


TEventDef.DocString Property

Summary

Represents property DocString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property DocString: TStringList read FDocString write SetDocString;

Property Value

Type: TStringList

See Also

Reference

  • TEventDef
  • BI.Plugins.Python.Engine


TEventDef.Name Property

Summary

Represents property Name.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property Name: string read GetDisplayName write SetDisplayName;

Property Value

Type: string

See Also

Reference

  • TEventDef
  • BI.Plugins.Python.Engine


TEventDef Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
GetDocString | Represents method GetDocString.
Owner | Represents method Owner.
PythonEvent(PPyObject,PPyObject) | Represents method PythonEvent(PPyObject,PPyObject).
Top


TEventDef.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TEventDef
  • BI.Plugins.Python.Engine


TEventDef.GetDocString Method

Summary

Represents method GetDocString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function GetDocString : AnsiString;

Return Value

Type: AnsiString

See Also

Reference

  • TEventDef
  • BI.Plugins.Python.Engine


TEventDef.Owner Method

Summary

Represents method Owner.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Owner : TEventDefs;

Return Value

Type: TEventDefs

See Also

Reference

  • TEventDef
  • BI.Plugins.Python.Engine


TEventDef.PythonEvent(PPyObject,PPyObject) Method

Summary

Represents method PythonEvent(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PythonEvent(pself, args: PPyObject): PPyObject; cdecl;

Parameters

pself
Type: PPyObject

args
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TEventDef
  • BI.Plugins.Python.Engine


TEventDef Events

Events
Name | Description
OnExecute | Represents property OnExecute.
Top


TEventDef.OnExecute Event

Summary

Represents property OnExecute.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property OnExecute: TPythonEvent read FOnExecute write FOnExecute;

Value

Type: TPythonEvent

See Also

Reference

  • TEventDef
  • BI.Plugins.Python.Engine


TEventDefs Class

Summary

Represents type TEventDefs.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TCollection
BI.Plugins.Python.Engine.TEventDefs
Syntax
Delphi
type
 TEventDefs = class(TCollection)
 end;

The TEventDefs type exposes the following members.

Constructors
Show:
Name | Description
Create(TMethodsContainer) | Initializes a new instance of the TEventDefs class.
Top
Properties
Show:
Name | Description
Container | Represents property Container.
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Add | Represents method Add.
GetOwner | Represents method GetOwner.
RegisterEvents | Represents method RegisterEvents.
SetItems(Integer,TEventDef) | Represents method SetItems(Integer,TEventDef).
Top
Fields
Show:
Name | Description
FMethodsContainer | Represents field FMethodsContainer.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TEventDefs Constructors

Constructors
Name | Description
Create(TMethodsContainer) | Initializes a new instance of the TEventDefs class.
Top


TEventDefs.Create(TMethodsContainer) Constructor

Summary

Initializes a new instance of the TEventDefs class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 constructor Create( AMethodsContainer : TMethodsContainer );

Parameters

AMethodsContainer
Type: TMethodsContainer

See Also

Reference

  • TEventDefs
  • BI.Plugins.Python.Engine


TEventDefs Properties

Properties
Name | Description
Container | Represents property Container.
Items[Integer] | Represents property Items[Integer].
Top


TEventDefs.Container Property

Summary

Represents property Container.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property Container : TMethodsContainer read FMethodsContainer;

Property Value

Type: TMethodsContainer

See Also

Reference

  • TEventDefs
  • BI.Plugins.Python.Engine


TEventDefs.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property Items[ idx : Integer ] : TEventDef read GetItems;

Parameters

idx
Type: Integer

Property Value

Type: TEventDef

See Also

Reference

  • TEventDefs
  • BI.Plugins.Python.Engine


TEventDefs Methods

Methods
Name | Description
Add | Represents method Add.
GetOwner | Represents method GetOwner.
RegisterEvents | Represents method RegisterEvents.
SetItems(Integer,TEventDef) | Represents method SetItems(Integer,TEventDef).
Top


TEventDefs.Add Method

Summary

Represents method Add.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Add : TEventDef;

Return Value

Type: TEventDef

See Also

Reference

  • TEventDefs
  • BI.Plugins.Python.Engine


TEventDefs.GetOwner Method

Summary

Represents method GetOwner.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 function GetOwner: TPersistent; override;

Return Value

Type: TPersistent

See Also

Reference

  • TEventDefs
  • BI.Plugins.Python.Engine


TEventDefs.RegisterEvents Method

Summary

Represents method RegisterEvents.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure RegisterEvents;
See Also

Reference

  • TEventDefs
  • BI.Plugins.Python.Engine


TEventDefs.SetItems(Integer,TEventDef) Method

Summary

Represents method SetItems(Integer,TEventDef).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure SetItems( idx : Integer; Value : TEventDef );

Parameters

idx
Type: Integer

Value
Type: TEventDef

See Also

Reference

  • TEventDefs
  • BI.Plugins.Python.Engine


TEventDefs Fields

Fields
Name | Description
FMethodsContainer | Represents field FMethodsContainer.
Top


TEventDefs.FMethodsContainer Field

Summary

Represents field FMethodsContainer.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FMethodsContainer : TMethodsContainer;

Field Value

Type: TMethodsContainer

See Also

Reference

  • TEventDefs
  • BI.Plugins.Python.Engine


TGetSetContainer Class

Summary

Represents type TGetSetContainer.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TComponent
BI.Plugins.Python.Engine.TEngineClient
BI.Plugins.Python.Engine.TMethodsContainer
BI.Plugins.Python.Engine.TMembersContainer
BI.Plugins.Python.Engine.TGetSetContainer
BI.Plugins.Python.Engine.TPythonType
Syntax
Delphi
type
 TGetSetContainer = class(TMembersContainer)
 end;

The TGetSetContainer type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TGetSetContainer class. (Overrides TMembersContainer.Create(TComponent).)
Destroy | Represents the destructor of the TGetSetContainer class. (Overrides TMembersContainer.Destroy.)
Top
Properties
Show:
Name | Description
GetSetCount | Represents property GetSetCount.
GetSetData | Represents property GetSetData.
GetSet[Integer] | Represents property GetSet[Integer].
Top
Methods
Show:
Name | Description
AddGetSet(PAnsiChar,getter,setter,PAnsiChar,Pointer) | Represents method AddGetSet(PAnsiChar,getter,setter,PAnsiChar,Pointer).
ClearGetSets | Represents method ClearGetSets.
Finalize | Represents method Finalize. (Overrides TMembersContainer.Finalize.)
ReallocGetSets | Represents method ReallocGetSets.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TGetSetContainer Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TGetSetContainer class. (Overrides TMembersContainer.Create(TComponent).)
Destroy | Represents the destructor of the TGetSetContainer class. (Overrides TMembersContainer.Destroy.)
Top


TGetSetContainer.Create(TComponent) Constructor

Summary

Initializes a new instance of the TGetSetContainer class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 constructor Create( AOwner : TComponent ); override;

Parameters

AOwner
Type: TComponent

Overrides

TMembersContainer.Create(TComponent)
See Also

Reference

  • TGetSetContainer
  • BI.Plugins.Python.Engine


TGetSetContainer.Destroy Destructor

Summary

Represents the destructor of the TGetSetContainer class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TMembersContainer.Destroy
See Also

Reference

  • TGetSetContainer
  • BI.Plugins.Python.Engine


TGetSetContainer Properties

Properties
Name | Description
GetSetCount | Represents property GetSetCount.
GetSetData | Represents property GetSetData.
GetSet[Integer] | Represents property GetSet[Integer].
Top


TGetSetContainer.GetSetCount Property

Summary

Represents property GetSetCount.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property GetSetCount : Integer read FGetSetCount;

Property Value

Type: Integer

See Also

Reference

  • TGetSetContainer
  • BI.Plugins.Python.Engine


TGetSetContainer.GetSetData Property

Summary

Represents property GetSetData.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property GetSetData : PPyGetSetDef read FGetSets;

Property Value

Type: PPyGetSetDef

See Also

Reference

  • TGetSetContainer
  • BI.Plugins.Python.Engine


TGetSetContainer.GetSet[Integer] Property

Summary

Represents property GetSet[Integer].

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property GetSet[ idx : Integer ] : PPyGetSetDef read GetGetSet;

Parameters

idx
Type: Integer

Property Value

Type: PPyGetSetDef

See Also

Reference

  • TGetSetContainer
  • BI.Plugins.Python.Engine


TGetSetContainer Methods

Methods
Name | Description
AddGetSet(PAnsiChar,getter,setter,PAnsiChar,Pointer) | Represents method AddGetSet(PAnsiChar,getter,setter,PAnsiChar,Pointer).
ClearGetSets | Represents method ClearGetSets.
Finalize | Represents method Finalize. (Overrides TMembersContainer.Finalize.)
ReallocGetSets | Represents method ReallocGetSets.
Top


TGetSetContainer.AddGetSet(PAnsiChar,getter,setter,PAnsiChar,Pointer) Method

Summary

Represents method AddGetSet(PAnsiChar,getter,setter,PAnsiChar,Pointer).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure AddGetSet( AName : PAnsiChar;
 AGet : getter;
 ASet : setter;
 ADoc : PAnsiChar;
 AClosure : Pointer);

Parameters

AName
Type: PAnsiChar

AGet
Type: getter

ASet
Type: setter

ADoc
Type: PAnsiChar

AClosure
Type: Pointer

See Also

Reference

  • TGetSetContainer
  • BI.Plugins.Python.Engine


TGetSetContainer.ClearGetSets Method

Summary

Represents method ClearGetSets.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure ClearGetSets;
See Also

Reference

  • TGetSetContainer
  • BI.Plugins.Python.Engine


TGetSetContainer.Finalize Method

Summary

Represents method Finalize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Finalize; override;

Overrides

TMembersContainer.Finalize
See Also

Reference

  • TGetSetContainer
  • BI.Plugins.Python.Engine


TGetSetContainer.ReallocGetSets Method

Summary

Represents method ReallocGetSets.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure ReallocGetSets; virtual;
See Also

Reference

  • TGetSetContainer
  • BI.Plugins.Python.Engine


TMembersContainer Class

Summary

Represents type TMembersContainer.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TComponent
BI.Plugins.Python.Engine.TEngineClient
BI.Plugins.Python.Engine.TMethodsContainer
BI.Plugins.Python.Engine.TMembersContainer
BI.Plugins.Python.Engine.TGetSetContainer
Syntax
Delphi
type
 TMembersContainer = class(TMethodsContainer)
 end;

The TMembersContainer type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TMembersContainer class. (Overrides TMethodsContainer.Create(TComponent).)
Destroy | Represents the destructor of the TMembersContainer class. (Overrides TMethodsContainer.Destroy.)
Top
Properties
Show:
Name | Description
MemberCount | Represents property MemberCount.
MembersData | Represents property MembersData.
Members[Integer] | Represents property Members[Integer].
Top
Methods
Show:
Name | Description
AddMember(PAnsiChar,TPyMemberType,NativeInt,TPyMemberFlag,PAnsiChar) | Represents method AddMember(PAnsiChar,TPyMemberType,NativeInt,TPyMemberFlag,PAnsiChar).
ClearMembers | Represents method ClearMembers.
Finalize | Represents method Finalize. (Overrides TMethodsContainer.Finalize.)
GetMembersStartOffset | Represents method GetMembersStartOffset.
ReallocMembers | Represents method ReallocMembers.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TMembersContainer Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TMembersContainer class. (Overrides TMethodsContainer.Create(TComponent).)
Destroy | Represents the destructor of the TMembersContainer class. (Overrides TMethodsContainer.Destroy.)
Top


TMembersContainer.Create(TComponent) Constructor

Summary

Initializes a new instance of the TMembersContainer class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 constructor Create( AOwner : TComponent ); override;

Parameters

AOwner
Type: TComponent

Overrides

TMethodsContainer.Create(TComponent)
See Also

Reference

  • TMembersContainer
  • BI.Plugins.Python.Engine


TMembersContainer.Destroy Destructor

Summary

Represents the destructor of the TMembersContainer class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TMethodsContainer.Destroy
See Also

Reference

  • TMembersContainer
  • BI.Plugins.Python.Engine


TMembersContainer Properties

Properties
Name | Description
MemberCount | Represents property MemberCount.
MembersData | Represents property MembersData.
Members[Integer] | Represents property Members[Integer].
Top


TMembersContainer.MemberCount Property

Summary

Represents property MemberCount.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property MemberCount : Integer read FMemberCount;

Property Value

Type: Integer

See Also

Reference

  • TMembersContainer
  • BI.Plugins.Python.Engine


TMembersContainer.MembersData Property

Summary

Represents property MembersData.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property MembersData : PPyMemberDef read FMembers;

Property Value

Type: PPyMemberDef

See Also

Reference

  • TMembersContainer
  • BI.Plugins.Python.Engine


TMembersContainer.Members[Integer] Property

Summary

Represents property Members[Integer].

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property Members[ idx : Integer ] : PPyMemberDef read GetMembers;

Parameters

idx
Type: Integer

Property Value

Type: PPyMemberDef

See Also

Reference

  • TMembersContainer
  • BI.Plugins.Python.Engine


TMembersContainer Methods

Methods
Name | Description
AddMember(PAnsiChar,TPyMemberType,NativeInt,TPyMemberFlag,PAnsiChar) | Represents method AddMember(PAnsiChar,TPyMemberType,NativeInt,TPyMemberFlag,PAnsiChar).
ClearMembers | Represents method ClearMembers.
Finalize | Represents method Finalize. (Overrides TMethodsContainer.Finalize.)
GetMembersStartOffset | Represents method GetMembersStartOffset.
ReallocMembers | Represents method ReallocMembers.
Top


TMembersContainer.AddMember(PAnsiChar,TPyMemberType,NativeInt,TPyMemberFlag,PAnsiChar) Method

Summary

Represents method AddMember(PAnsiChar,TPyMemberType,NativeInt,TPyMemberFlag,PAnsiChar).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure AddMember( MemberName : PAnsiChar;
 MemberType : TPyMemberType;
 MemberOffset : NativeInt;
 MemberFlags : TPyMemberFlag;
 MemberDoc : PAnsiChar );

Parameters

MemberName
Type: PAnsiChar

MemberType
Type: TPyMemberType

MemberOffset
Type: NativeInt

MemberFlags
Type: TPyMemberFlag

MemberDoc
Type: PAnsiChar

See Also

Reference

  • TMembersContainer
  • BI.Plugins.Python.Engine


TMembersContainer.ClearMembers Method

Summary

Represents method ClearMembers.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure ClearMembers;
See Also

Reference

  • TMembersContainer
  • BI.Plugins.Python.Engine


TMembersContainer.Finalize Method

Summary

Represents method Finalize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Finalize; override;

Overrides

TMethodsContainer.Finalize
See Also

Reference

  • TMembersContainer
  • BI.Plugins.Python.Engine


TMembersContainer.GetMembersStartOffset Method

Summary

Represents method GetMembersStartOffset.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 function GetMembersStartOffset : Integer; virtual;

Return Value

Type: Integer

See Also

Reference

  • TMembersContainer
  • BI.Plugins.Python.Engine


TMembersContainer.ReallocMembers Method

Summary

Represents method ReallocMembers.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure ReallocMembers; virtual;
See Also

Reference

  • TMembersContainer
  • BI.Plugins.Python.Engine


TMethodsContainer Class

Summary

Represents type TMethodsContainer.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TComponent
BI.Plugins.Python.Engine.TEngineClient
BI.Plugins.Python.Engine.TMethodsContainer
BI.Plugins.Python.Engine.TMembersContainer
BI.Plugins.Python.Engine.TPythonModule
Syntax
Delphi
type
 TMethodsContainer = class(TEngineClient)
 end;

The TMethodsContainer type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TMethodsContainer class. (Overrides TEngineClient.Create(TComponent).)
Destroy | Represents the destructor of the TMethodsContainer class. (Overrides TEngineClient.Destroy.)
Top
Properties
Show:
Name | Description
Events | Represents property Events.
MethodCount | Represents property MethodCount.
MethodsData | Represents property MethodsData.
Methods[Integer] | Represents property Methods[Integer].
ModuleDef | Represents property ModuleDef.
Top
Methods
Show:
Name | Description
AddDelphiMethod(PAnsiChar,TDelphiMethod,PAnsiChar) | Represents method AddDelphiMethod(PAnsiChar,TDelphiMethod,PAnsiChar).
AddDelphiMethodWithKeywords(PAnsiChar,TDelphiMethodWithKW,PAnsiChar) | Represents method AddDelphiMethodWithKeywords(PAnsiChar,TDelphiMethodWithKW,PAnsiChar).
AddMethod(PAnsiChar,PyCFunction,PAnsiChar) | Represents method AddMethod(PAnsiChar,PyCFunction,PAnsiChar).
AddMethodWithKeywords(PAnsiChar,PyCFunctionWithKW,PAnsiChar) | Represents method AddMethodWithKeywords(PAnsiChar,PyCFunctionWithKW,PAnsiChar).
ClearMethods | Represents method ClearMethods.
Finalize | Represents method Finalize. (Overrides TEngineClient.Finalize.)
Initialize | Represents method Initialize. (Overrides TEngineClient.Initialize.)
ReallocMethods | Represents method ReallocMethods.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TMethodsContainer Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TMethodsContainer class. (Overrides TEngineClient.Create(TComponent).)
Destroy | Represents the destructor of the TMethodsContainer class. (Overrides TEngineClient.Destroy.)
Top


TMethodsContainer.Create(TComponent) Constructor

Summary

Initializes a new instance of the TMethodsContainer class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 constructor Create( AOwner : TComponent ); override;

Parameters

AOwner
Type: TComponent

Overrides

TEngineClient.Create(TComponent)
See Also

Reference

  • TMethodsContainer
  • BI.Plugins.Python.Engine


TMethodsContainer.Destroy Destructor

Summary

Represents the destructor of the TMethodsContainer class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TEngineClient.Destroy
See Also

Reference

  • TMethodsContainer
  • BI.Plugins.Python.Engine


TMethodsContainer Properties

Properties
Name | Description
Events | Represents property Events.
MethodCount | Represents property MethodCount.
MethodsData | Represents property MethodsData.
Methods[Integer] | Represents property Methods[Integer].
ModuleDef | Represents property ModuleDef.
Top


TMethodsContainer.Events Property

Summary

Represents property Events.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property Events: TEventDefs read fEventDefs write fEventDefs stored StoreEventDefs;

Property Value

Type: TEventDefs

See Also

Reference

  • TMethodsContainer
  • BI.Plugins.Python.Engine


TMethodsContainer.MethodCount Property

Summary

Represents property MethodCount.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property MethodCount : Integer read FMethodCount;

Property Value

Type: Integer

See Also

Reference

  • TMethodsContainer
  • BI.Plugins.Python.Engine


TMethodsContainer.MethodsData Property

Summary

Represents property MethodsData.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property MethodsData : PPyMethodDef read FMethods;

Property Value

Type: PPyMethodDef

See Also

Reference

  • TMethodsContainer
  • BI.Plugins.Python.Engine


TMethodsContainer.Methods[Integer] Property

Summary

Represents property Methods[Integer].

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property Methods[ idx : Integer ] : PPyMethodDef read GetMethods;

Parameters

idx
Type: Integer

Property Value

Type: PPyMethodDef

See Also

Reference

  • TMethodsContainer
  • BI.Plugins.Python.Engine


TMethodsContainer.ModuleDef Property

Summary

Represents property ModuleDef.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property ModuleDef : PyModuleDef read FModuleDef;

Property Value

Type: PyModuleDef

See Also

Reference

  • TMethodsContainer
  • BI.Plugins.Python.Engine


TMethodsContainer Methods

Methods
Name | Description
AddDelphiMethod(PAnsiChar,TDelphiMethod,PAnsiChar) | Represents method AddDelphiMethod(PAnsiChar,TDelphiMethod,PAnsiChar).
AddDelphiMethodWithKeywords(PAnsiChar,TDelphiMethodWithKW,PAnsiChar) | Represents method AddDelphiMethodWithKeywords(PAnsiChar,TDelphiMethodWithKW,PAnsiChar).
AddMethod(PAnsiChar,PyCFunction,PAnsiChar) | Represents method AddMethod(PAnsiChar,PyCFunction,PAnsiChar).
AddMethodWithKeywords(PAnsiChar,PyCFunctionWithKW,PAnsiChar) | Represents method AddMethodWithKeywords(PAnsiChar,PyCFunctionWithKW,PAnsiChar).
ClearMethods | Represents method ClearMethods.
Finalize | Represents method Finalize. (Overrides TEngineClient.Finalize.)
Initialize | Represents method Initialize. (Overrides TEngineClient.Initialize.)
ReallocMethods | Represents method ReallocMethods.
Top


TMethodsContainer.AddDelphiMethod(PAnsiChar,TDelphiMethod,PAnsiChar) Method

Summary

Represents method AddDelphiMethod(PAnsiChar,TDelphiMethod,PAnsiChar).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function AddDelphiMethod( AMethodName : PAnsiChar;
 ADelphiMethod: TDelphiMethod;
 ADocString : PAnsiChar ) : PPyMethodDef;

Parameters

AMethodName
Type: PAnsiChar

ADelphiMethod
Type: TDelphiMethod

ADocString
Type: PAnsiChar

Return Value

Type: PPyMethodDef

See Also

Reference

  • TMethodsContainer
  • BI.Plugins.Python.Engine


TMethodsContainer.AddDelphiMethodWithKeywords(PAnsiChar,TDelphiMethodWithKW,PAnsiChar) Method

Summary

Represents method AddDelphiMethodWithKeywords(PAnsiChar,TDelphiMethodWithKW,PAnsiChar).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function AddDelphiMethodWithKeywords( AMethodName : PAnsiChar;
 ADelphiMethod: TDelphiMethodWithKW;
 ADocString : PAnsiChar ) : PPyMethodDef;

Parameters

AMethodName
Type: PAnsiChar

ADelphiMethod
Type: TDelphiMethodWithKW

ADocString
Type: PAnsiChar

Return Value

Type: PPyMethodDef

See Also

Reference

  • TMethodsContainer
  • BI.Plugins.Python.Engine


TMethodsContainer.AddMethod(PAnsiChar,PyCFunction,PAnsiChar) Method

Summary

Represents method AddMethod(PAnsiChar,PyCFunction,PAnsiChar).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function AddMethod( AMethodName : PAnsiChar;
 AMethod : PyCFunction;
 ADocString : PAnsiChar ) : PPyMethodDef;

Parameters

AMethodName
Type: PAnsiChar

AMethod
Type: PyCFunction

ADocString
Type: PAnsiChar

Return Value

Type: PPyMethodDef

See Also

Reference

  • TMethodsContainer
  • BI.Plugins.Python.Engine


TMethodsContainer.AddMethodWithKeywords(PAnsiChar,PyCFunctionWithKW,PAnsiChar) Method

Summary

Represents method AddMethodWithKeywords(PAnsiChar,PyCFunctionWithKW,PAnsiChar).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function AddMethodWithKeywords( AMethodName : PAnsiChar;
 AMethod : PyCFunctionWithKW;
 ADocString : PAnsiChar ) : PPyMethodDef;

Parameters

AMethodName
Type: PAnsiChar

AMethod
Type: PyCFunctionWithKW

ADocString
Type: PAnsiChar

Return Value

Type: PPyMethodDef

See Also

Reference

  • TMethodsContainer
  • BI.Plugins.Python.Engine


TMethodsContainer.ClearMethods Method

Summary

Represents method ClearMethods.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure ClearMethods;
See Also

Reference

  • TMethodsContainer
  • BI.Plugins.Python.Engine


TMethodsContainer.Finalize Method

Summary

Represents method Finalize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Finalize; override;

Overrides

TEngineClient.Finalize
See Also

Reference

  • TMethodsContainer
  • BI.Plugins.Python.Engine


TMethodsContainer.Initialize Method

Summary

Represents method Initialize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Initialize; override;

Overrides

TEngineClient.Initialize
See Also

Reference

  • TMethodsContainer
  • BI.Plugins.Python.Engine


TMethodsContainer.ReallocMethods Method

Summary

Represents method ReallocMethods.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure ReallocMethods; virtual;
See Also

Reference

  • TMethodsContainer
  • BI.Plugins.Python.Engine


TParentClassError Class

Summary

Represents type TParentClassError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TPersistent
BI.Plugins.Python.Engine.TParentClassError
Syntax
Delphi
type
 TParentClassError = class(TPersistent)
 end;

The TParentClassError type exposes the following members.

Properties
Show:
Name | Description
Module | Represents property Module.
Name | Represents property Name.
Top
Methods
Show:
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
Top
Fields
Show:
Name | Description
FModule | Represents field FModule.
FName | Represents field FName.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TParentClassError Properties

Properties
Name | Description
Module | Represents property Module.
Name | Represents property Name.
Top


TParentClassError.Module Property

Summary

Represents property Module.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property Module : AnsiString read FModule write FModule;

Property Value

Type: AnsiString

See Also

Reference

  • TParentClassError
  • BI.Plugins.Python.Engine


TParentClassError.Name Property

Summary

Represents property Name.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property Name : AnsiString read FName write FName;

Property Value

Type: AnsiString

See Also

Reference

  • TParentClassError
  • BI.Plugins.Python.Engine


TParentClassError Methods

Methods
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
Top


TParentClassError.AssignTo(TPersistent) Method

Summary

Represents method AssignTo(TPersistent).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure AssignTo( Dest: TPersistent ); override;

Parameters

Dest
Type: TPersistent

See Also

Reference

  • TParentClassError
  • BI.Plugins.Python.Engine


TParentClassError Fields

Fields
Name | Description
FModule | Represents field FModule.
FName | Represents field FName.
Top


TParentClassError.FModule Field

Summary

Represents field FModule.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FModule : AnsiString;

Field Value

Type: AnsiString

See Also

Reference

  • TParentClassError
  • BI.Plugins.Python.Engine


TParentClassError.FName Field

Summary

Represents field FName.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FName : AnsiString;

Field Value

Type: AnsiString

See Also

Reference

  • TParentClassError
  • BI.Plugins.Python.Engine


TPyObject Class

Summary

Represents type TPyObject.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TObject
BI.Plugins.Python.Engine.TPyObject
BI.Plugins.Python.Engine.TPyVar
Syntax
Delphi
type
 TPyObject = class
 end;

The TPyObject type exposes the following members.

Constructors
Show:
Name | Description
Create(TPythonType) | Initializes a new instance of the TPyObject class.
CreateWith(TPythonType,PPyObject) | Initializes a new instance of the TPyObject class.
Destroy | Represents the destructor of the TPyObject class.
Top
Properties
Show:
Name | Description
ob_refcnt | Represents property ob_refcnt.
ob_type | Represents property ob_type.
Top
Methods
Show:
Name | Description
Adjust(Pointer) | Represents method Adjust(Pointer).
Call(PPyObject,PPyObject) | Represents method Call(PPyObject,PPyObject).
Clear | Represents method Clear.
Compare(PPyObject) | Represents method Compare(PPyObject).
FreeInstance | Represents method FreeInstance.
GetAttr(PAnsiChar) | Represents method GetAttr(PAnsiChar).
GetAttrO(PPyObject) | Represents method GetAttrO(PPyObject).
GetModule | Represents method GetModule.
GetSelf | Represents method GetSelf.
Hash | Represents method Hash.
IncRef | Represents method IncRef.
Init(PPyObject,PPyObject) | Represents method Init(PPyObject,PPyObject).
Iter | Represents method Iter.
IterNext | Represents method IterNext.
MpAssSubscript(PPyObject,PPyObject) | Represents method MpAssSubscript(PPyObject,PPyObject).
MpLength | Represents method MpLength.
MpSubscript(PPyObject) | Represents method MpSubscript(PPyObject).
NbAbsolute | Represents method NbAbsolute.
NbAdd(PPyObject) | Represents method NbAdd(PPyObject).
NbAnd(PPyObject) | Represents method NbAnd(PPyObject).
NbCoerce(PPPyObject) | Represents method NbCoerce(PPPyObject).
NbDivide(PPyObject) | Represents method NbDivide(PPyObject).
NbDivmod(PPyObject) | Represents method NbDivmod(PPyObject).
NbFloat | Represents method NbFloat.
NbFloorDivide(PPyObject) | Represents method NbFloorDivide(PPyObject).
NbHex | Represents method NbHex.
NbInplaceAdd(PPyObject) | Represents method NbInplaceAdd(PPyObject).
NbInplaceAnd(PPyObject) | Represents method NbInplaceAnd(PPyObject).
NbInplaceDivide(PPyObject) | Represents method NbInplaceDivide(PPyObject).
NbInplaceFloorDivide(PPyObject) | Represents method NbInplaceFloorDivide(PPyObject).
NbInplaceLshift(PPyObject) | Represents method NbInplaceLshift(PPyObject).
NbInplaceMultiply(PPyObject) | Represents method NbInplaceMultiply(PPyObject).
NbInplaceOr(PPyObject) | Represents method NbInplaceOr(PPyObject).
NbInplacePower(PPyObject,PPyObject) | Represents method NbInplacePower(PPyObject,PPyObject).
NbInplaceRemainder(PPyObject) | Represents method NbInplaceRemainder(PPyObject).
NbInplaceRshift(PPyObject) | Represents method NbInplaceRshift(PPyObject).
NbInplaceSubtract(PPyObject) | Represents method NbInplaceSubtract(PPyObject).
NbInplaceTrueDivide(PPyObject) | Represents method NbInplaceTrueDivide(PPyObject).
NbInplaceXor(PPyObject) | Represents method NbInplaceXor(PPyObject).
NbInt | Represents method NbInt.
NbInvert | Represents method NbInvert.
NbLong | Represents method NbLong.
NbLShift(PPyObject) | Represents method NbLShift(PPyObject).
NbMultiply(PPyObject) | Represents method NbMultiply(PPyObject).
NbNegative | Represents method NbNegative.
NbNonZero | Represents method NbNonZero.
NbOct | Represents method NbOct.
NbOr(PPyObject) | Represents method NbOr(PPyObject).
NbPositive | Represents method NbPositive.
NbPower(PPyObject,PPyObject) | Represents method NbPower(PPyObject,PPyObject).
NbRemainder(PPyObject) | Represents method NbRemainder(PPyObject).
NbRShift(PPyObject) | Represents method NbRShift(PPyObject).
NbSubstract(PPyObject) | Represents method NbSubstract(PPyObject).
NbTrueDivide(PPyObject) | Represents method NbTrueDivide(PPyObject).
NbXor(PPyObject) | Represents method NbXor(PPyObject).
NewInstance | Represents method NewInstance.
Print(file,integer) |
RegisterGetSets(TPythonType) | Represents method RegisterGetSets(TPythonType).
RegisterMembers(TPythonType) | Represents method RegisterMembers(TPythonType).
RegisterMethods(TPythonType) | Represents method RegisterMethods(TPythonType).
Repr | Represents method Repr.
RichCompare(PPyObject,TRichComparisonOpcode) | Represents method RichCompare(PPyObject,TRichComparisonOpcode).
SetAttr(PAnsiChar,PPyObject) | Represents method SetAttr(PAnsiChar,PPyObject).
SetAttrO(PPyObject,PPyObject) | Represents method SetAttrO(PPyObject,PPyObject).
SetupType(TPythonType) | Represents method SetupType(TPythonType).
SqAssItem(NativeInt,PPyObject) | Represents method SqAssItem(NativeInt,PPyObject).
SqAssSlice(NativeInt,NativeInt,PPyObject) | Represents method SqAssSlice(NativeInt,NativeInt,PPyObject).
SqConcat(PPyObject) | Represents method SqConcat(PPyObject).
SqContains(PPyObject) | Represents method SqContains(PPyObject).
SqInplaceConcat(PPyObject) | Represents method SqInplaceConcat(PPyObject).
SqInplaceRepeat(NativeInt) | Represents method SqInplaceRepeat(NativeInt).
SqItem(NativeInt) | Represents method SqItem(NativeInt).
SqLength | Represents method SqLength.
SqRepeat(NativeInt) | Represents method SqRepeat(NativeInt).
SqSlice(NativeInt,NativeInt) | Represents method SqSlice(NativeInt,NativeInt).
Str | Represents method Str.
Traverse(visitproc,Pointer) | Represents method Traverse(visitproc,Pointer).
Top
Fields
Show:
Name | Description
IsSubtype | Represents field IsSubtype.
PythonAlloc | Represents field PythonAlloc.
PythonType | Represents field PythonType.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TPyObject Constructors

Constructors
Name | Description
Create(TPythonType) | Initializes a new instance of the TPyObject class.
CreateWith(TPythonType,PPyObject) | Initializes a new instance of the TPyObject class.
Destroy | Represents the destructor of the TPyObject class.
Top


TPyObject.Create(TPythonType) Constructor

Summary

Initializes a new instance of the TPyObject class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 constructor Create( APythonType : TPythonType ); virtual;

Parameters

APythonType
Type: TPythonType

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.CreateWith(TPythonType,PPyObject) Constructor

Summary

Initializes a new instance of the TPyObject class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 constructor CreateWith( APythonType : TPythonType; args : PPyObject ); virtual;

Parameters

APythonType
Type: TPythonType

args
Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.Destroy Destructor

Summary

Represents the destructor of the TPyObject class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject Properties

Properties
Name | Description
ob_refcnt | Represents property ob_refcnt.
ob_type | Represents property ob_type.
Top


TPyObject.ob_refcnt Property

Summary

Represents property ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property ob_refcnt : NativeInt read Get_ob_refcnt write Set_ob_refcnt;

Property Value

Type: NativeInt

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.ob_type Property

Summary

Represents property ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property ob_type : PPyTypeObject read Get_ob_type write Set_ob_type;

Property Value

Type: PPyTypeObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject Methods

Methods
Name | Description
Adjust(Pointer) | Represents method Adjust(Pointer).
Call(PPyObject,PPyObject) | Represents method Call(PPyObject,PPyObject).
Clear | Represents method Clear.
Compare(PPyObject) | Represents method Compare(PPyObject).
FreeInstance | Represents method FreeInstance.
GetAttr(PAnsiChar) | Represents method GetAttr(PAnsiChar).
GetAttrO(PPyObject) | Represents method GetAttrO(PPyObject).
GetModule | Represents method GetModule.
GetSelf | Represents method GetSelf.
Hash | Represents method Hash.
IncRef | Represents method IncRef.
Init(PPyObject,PPyObject) | Represents method Init(PPyObject,PPyObject).
Iter | Represents method Iter.
IterNext | Represents method IterNext.
MpAssSubscript(PPyObject,PPyObject) | Represents method MpAssSubscript(PPyObject,PPyObject).
MpLength | Represents method MpLength.
MpSubscript(PPyObject) | Represents method MpSubscript(PPyObject).
NbAbsolute | Represents method NbAbsolute.
NbAdd(PPyObject) | Represents method NbAdd(PPyObject).
NbAnd(PPyObject) | Represents method NbAnd(PPyObject).
NbCoerce(PPPyObject) | Represents method NbCoerce(PPPyObject).
NbDivide(PPyObject) | Represents method NbDivide(PPyObject).
NbDivmod(PPyObject) | Represents method NbDivmod(PPyObject).
NbFloat | Represents method NbFloat.
NbFloorDivide(PPyObject) | Represents method NbFloorDivide(PPyObject).
NbHex | Represents method NbHex.
NbInplaceAdd(PPyObject) | Represents method NbInplaceAdd(PPyObject).
NbInplaceAnd(PPyObject) | Represents method NbInplaceAnd(PPyObject).
NbInplaceDivide(PPyObject) | Represents method NbInplaceDivide(PPyObject).
NbInplaceFloorDivide(PPyObject) | Represents method NbInplaceFloorDivide(PPyObject).
NbInplaceLshift(PPyObject) | Represents method NbInplaceLshift(PPyObject).
NbInplaceMultiply(PPyObject) | Represents method NbInplaceMultiply(PPyObject).
NbInplaceOr(PPyObject) | Represents method NbInplaceOr(PPyObject).
NbInplacePower(PPyObject,PPyObject) | Represents method NbInplacePower(PPyObject,PPyObject).
NbInplaceRemainder(PPyObject) | Represents method NbInplaceRemainder(PPyObject).
NbInplaceRshift(PPyObject) | Represents method NbInplaceRshift(PPyObject).
NbInplaceSubtract(PPyObject) | Represents method NbInplaceSubtract(PPyObject).
NbInplaceTrueDivide(PPyObject) | Represents method NbInplaceTrueDivide(PPyObject).
NbInplaceXor(PPyObject) | Represents method NbInplaceXor(PPyObject).
NbInt | Represents method NbInt.
NbInvert | Represents method NbInvert.
NbLong | Represents method NbLong.
NbLShift(PPyObject) | Represents method NbLShift(PPyObject).
NbMultiply(PPyObject) | Represents method NbMultiply(PPyObject).
NbNegative | Represents method NbNegative.
NbNonZero | Represents method NbNonZero.
NbOct | Represents method NbOct.
NbOr(PPyObject) | Represents method NbOr(PPyObject).
NbPositive | Represents method NbPositive.
NbPower(PPyObject,PPyObject) | Represents method NbPower(PPyObject,PPyObject).
NbRemainder(PPyObject) | Represents method NbRemainder(PPyObject).
NbRShift(PPyObject) | Represents method NbRShift(PPyObject).
NbSubstract(PPyObject) | Represents method NbSubstract(PPyObject).
NbTrueDivide(PPyObject) | Represents method NbTrueDivide(PPyObject).
NbXor(PPyObject) | Represents method NbXor(PPyObject).
NewInstance | Represents method NewInstance.
Print(file,integer) |
RegisterGetSets(TPythonType) | Represents method RegisterGetSets(TPythonType).
RegisterMembers(TPythonType) | Represents method RegisterMembers(TPythonType).
RegisterMethods(TPythonType) | Represents method RegisterMethods(TPythonType).
Repr | Represents method Repr.
RichCompare(PPyObject,TRichComparisonOpcode) | Represents method RichCompare(PPyObject,TRichComparisonOpcode).
SetAttr(PAnsiChar,PPyObject) | Represents method SetAttr(PAnsiChar,PPyObject).
SetAttrO(PPyObject,PPyObject) | Represents method SetAttrO(PPyObject,PPyObject).
SetupType(TPythonType) | Represents method SetupType(TPythonType).
SqAssItem(NativeInt,PPyObject) | Represents method SqAssItem(NativeInt,PPyObject).
SqAssSlice(NativeInt,NativeInt,PPyObject) | Represents method SqAssSlice(NativeInt,NativeInt,PPyObject).
SqConcat(PPyObject) | Represents method SqConcat(PPyObject).
SqContains(PPyObject) | Represents method SqContains(PPyObject).
SqInplaceConcat(PPyObject) | Represents method SqInplaceConcat(PPyObject).
SqInplaceRepeat(NativeInt) | Represents method SqInplaceRepeat(NativeInt).
SqItem(NativeInt) | Represents method SqItem(NativeInt).
SqLength | Represents method SqLength.
SqRepeat(NativeInt) | Represents method SqRepeat(NativeInt).
SqSlice(NativeInt,NativeInt) | Represents method SqSlice(NativeInt,NativeInt).
Str | Represents method Str.
Traverse(visitproc,Pointer) | Represents method Traverse(visitproc,Pointer).
Top


TPyObject.Adjust(Pointer) Method

Summary

Represents method Adjust(Pointer).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Adjust(PyPointer: Pointer);

Parameters

PyPointer
Type: Pointer

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.Call(PPyObject,PPyObject) Method

Summary

Represents method Call(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Call( ob1, ob2 : PPyObject) : PPyObject; virtual;

Parameters

ob1
Type: PPyObject

ob2
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.Clear Method

Summary

Represents method Clear.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Clear: integer; virtual;

Return Value

Type: integer

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.Compare(PPyObject) Method

Summary

Represents method Compare(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Compare( obj: PPyObject) : Integer; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: Integer

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.FreeInstance Method

Summary

Represents method FreeInstance.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure FreeInstance; override;
See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.GetAttr(PAnsiChar) Method

Summary

Represents method GetAttr(PAnsiChar).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function GetAttr(key : PAnsiChar) : PPyObject; virtual;

Parameters

key
Type: PAnsiChar

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.GetAttrO(PPyObject) Method

Summary

Represents method GetAttrO(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function GetAttrO( key: PPyObject) : PPyObject; virtual;

Parameters

key
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.GetModule Method

Summary

Represents method GetModule.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function GetModule : TPythonModule;

Return Value

Type: TPythonModule

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.GetSelf Method

Summary

Represents method GetSelf.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function GetSelf : PPyObject;

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.Hash Method

Summary

Represents method Hash.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Hash : NativeInt; virtual;

Return Value

Type: NativeInt

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.IncRef Method

Summary

Represents method IncRef.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure IncRef;
See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.Init(PPyObject,PPyObject) Method

Summary

Represents method Init(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Init( args, kwds : PPyObject ) : Integer; virtual;

Parameters

args
Type: PPyObject

kwds
Type: PPyObject

Return Value

Type: Integer

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.Iter Method

Summary

Represents method Iter.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Iter : PPyObject; virtual;

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.IterNext Method

Summary

Represents method IterNext.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function IterNext : PPyObject; virtual;

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.MpAssSubscript(PPyObject,PPyObject) Method

Summary

Represents method MpAssSubscript(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function MpAssSubscript( obj1, obj2 : PPyObject) : Integer; virtual;

Parameters

obj1
Type: PPyObject

obj2
Type: PPyObject

Return Value

Type: Integer

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.MpLength Method

Summary

Represents method MpLength.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function MpLength : NativeInt; virtual;

Return Value

Type: NativeInt

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.MpSubscript(PPyObject) Method

Summary

Represents method MpSubscript(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function MpSubscript( obj : PPyObject) : PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbAbsolute Method

Summary

Represents method NbAbsolute.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbAbsolute : PPyObject; virtual;

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbAdd(PPyObject) Method

Summary

Represents method NbAdd(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbAdd( obj : PPyObject) : PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbAnd(PPyObject) Method

Summary

Represents method NbAnd(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbAnd( obj : PPyObject) : PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbCoerce(PPPyObject) Method

Summary

Represents method NbCoerce(PPPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbCoerce( obj : PPPyObject) : Integer; virtual;

Parameters

obj
Type: PPPyObject

Return Value

Type: Integer

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbDivide(PPyObject) Method

Summary

Represents method NbDivide(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbDivide( obj : PPyObject) : PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbDivmod(PPyObject) Method

Summary

Represents method NbDivmod(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbDivmod( obj : PPyObject) : PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbFloat Method

Summary

Represents method NbFloat.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbFloat : PPyObject; virtual;

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbFloorDivide(PPyObject) Method

Summary

Represents method NbFloorDivide(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbFloorDivide( obj : PPyObject) : PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbHex Method

Summary

Represents method NbHex.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbHex : PPyObject; virtual;

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbInplaceAdd(PPyObject) Method

Summary

Represents method NbInplaceAdd(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbInplaceAdd( obj : PPyObject): PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbInplaceAnd(PPyObject) Method

Summary

Represents method NbInplaceAnd(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbInplaceAnd( obj : PPyObject): PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbInplaceDivide(PPyObject) Method

Summary

Represents method NbInplaceDivide(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbInplaceDivide( obj : PPyObject): PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbInplaceFloorDivide(PPyObject) Method

Summary

Represents method NbInplaceFloorDivide(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbInplaceFloorDivide( obj : PPyObject) : PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbInplaceLshift(PPyObject) Method

Summary

Represents method NbInplaceLshift(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbInplaceLshift( obj : PPyObject): PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbInplaceMultiply(PPyObject) Method

Summary

Represents method NbInplaceMultiply(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbInplaceMultiply( obj : PPyObject): PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbInplaceOr(PPyObject) Method

Summary

Represents method NbInplaceOr(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbInplaceOr( obj : PPyObject): PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbInplacePower(PPyObject,PPyObject) Method

Summary

Represents method NbInplacePower(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbInplacePower( ob1, ob2 : PPyObject): PPyObject; virtual;

Parameters

ob1
Type: PPyObject

ob2
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbInplaceRemainder(PPyObject) Method

Summary

Represents method NbInplaceRemainder(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbInplaceRemainder( obj : PPyObject): PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbInplaceRshift(PPyObject) Method

Summary

Represents method NbInplaceRshift(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbInplaceRshift( obj : PPyObject): PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbInplaceSubtract(PPyObject) Method

Summary

Represents method NbInplaceSubtract(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbInplaceSubtract( obj : PPyObject): PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbInplaceTrueDivide(PPyObject) Method

Summary

Represents method NbInplaceTrueDivide(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbInplaceTrueDivide( obj : PPyObject) : PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbInplaceXor(PPyObject) Method

Summary

Represents method NbInplaceXor(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbInplaceXor( obj : PPyObject): PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbInt Method

Summary

Represents method NbInt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbInt : PPyObject; virtual;

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbInvert Method

Summary

Represents method NbInvert.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbInvert : PPyObject; virtual;

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbLong Method

Summary

Represents method NbLong.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbLong : PPyObject; virtual;

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbLShift(PPyObject) Method

Summary

Represents method NbLShift(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbLShift( obj : PPyObject) : PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbMultiply(PPyObject) Method

Summary

Represents method NbMultiply(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbMultiply( obj : PPyObject) : PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbNegative Method

Summary

Represents method NbNegative.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbNegative : PPyObject; virtual;

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbNonZero Method

Summary

Represents method NbNonZero.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbNonZero : Integer; virtual;

Return Value

Type: Integer

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbOct Method

Summary

Represents method NbOct.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbOct : PPyObject; virtual;

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbOr(PPyObject) Method

Summary

Represents method NbOr(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbOr( obj : PPyObject) : PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbPositive Method

Summary

Represents method NbPositive.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbPositive : PPyObject; virtual;

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbPower(PPyObject,PPyObject) Method

Summary

Represents method NbPower(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbPower( ob1, ob2 : PPyObject) : PPyObject; virtual;

Parameters

ob1
Type: PPyObject

ob2
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbRemainder(PPyObject) Method

Summary

Represents method NbRemainder(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbRemainder( obj : PPyObject) : PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbRShift(PPyObject) Method

Summary

Represents method NbRShift(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbRShift( obj : PPyObject) : PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbSubstract(PPyObject) Method

Summary

Represents method NbSubstract(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbSubstract( obj : PPyObject) : PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbTrueDivide(PPyObject) Method

Summary

Represents method NbTrueDivide(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbTrueDivide( obj : PPyObject) : PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NbXor(PPyObject) Method

Summary

Represents method NbXor(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function NbXor( obj : PPyObject) : PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.NewInstance Method

Summary

Represents method NewInstance.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 class function NewInstance: TObject; override;

Return Value

Type: TObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.Print(file,integer) Method

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Print( var f: file; i: integer) : Integer; virtual;

Parameters

f
Type: file

i
Type: integer

Return Value

Type: Integer

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.RegisterGetSets(TPythonType) Method

Summary

Represents method RegisterGetSets(TPythonType).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 class procedure RegisterGetSets( APythonType : TPythonType ); virtual;

Parameters

APythonType
Type: TPythonType

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.RegisterMembers(TPythonType) Method

Summary

Represents method RegisterMembers(TPythonType).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 class procedure RegisterMembers( APythonType : TPythonType ); virtual;

Parameters

APythonType
Type: TPythonType

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.RegisterMethods(TPythonType) Method

Summary

Represents method RegisterMethods(TPythonType).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 class procedure RegisterMethods( APythonType : TPythonType ); virtual;

Parameters

APythonType
Type: TPythonType

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.Repr Method

Summary

Represents method Repr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Repr : PPyObject; virtual;

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.RichCompare(PPyObject,TRichComparisonOpcode) Method

Summary

Represents method RichCompare(PPyObject,TRichComparisonOpcode).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function RichCompare( obj : PPyObject; Op : TRichComparisonOpcode) : PPyObject; virtual;

Parameters

obj
Type: PPyObject

Op
Type: TRichComparisonOpcode

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.SetAttr(PAnsiChar,PPyObject) Method

Summary

Represents method SetAttr(PAnsiChar,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function SetAttr(key : PAnsiChar; value : PPyObject) : Integer; virtual;

Parameters

key
Type: PAnsiChar

value
Type: PPyObject

Return Value

Type: Integer

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.SetAttrO(PPyObject,PPyObject) Method

Summary

Represents method SetAttrO(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function SetAttrO( key, value: PPyObject) : Integer; virtual;

Parameters

key
Type: PPyObject

value
Type: PPyObject

Return Value

Type: Integer

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.SetupType(TPythonType) Method

Summary

Represents method SetupType(TPythonType).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 class procedure SetupType( APythonType : TPythonType ); virtual;

Parameters

APythonType
Type: TPythonType

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.SqAssItem(NativeInt,PPyObject) Method

Summary

Represents method SqAssItem(NativeInt,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function SqAssItem( idx : NativeInt; obj : PPyObject) : Integer; virtual;

Parameters

idx
Type: NativeInt

obj
Type: PPyObject

Return Value

Type: Integer

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.SqAssSlice(NativeInt,NativeInt,PPyObject) Method

Summary

Represents method SqAssSlice(NativeInt,NativeInt,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function SqAssSlice( idx1, idx2 : NativeInt; obj : PPyObject): integer; virtual;

Parameters

idx1
Type: NativeInt

idx2
Type: NativeInt

obj
Type: PPyObject

Return Value

Type: integer

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.SqConcat(PPyObject) Method

Summary

Represents method SqConcat(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function SqConcat( obj : PPyObject) : PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.SqContains(PPyObject) Method

Summary

Represents method SqContains(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function SqContains( obj: PPyObject): integer; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: integer

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.SqInplaceConcat(PPyObject) Method

Summary

Represents method SqInplaceConcat(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function SqInplaceConcat( obj : PPyObject): PPyObject; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.SqInplaceRepeat(NativeInt) Method

Summary

Represents method SqInplaceRepeat(NativeInt).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function SqInplaceRepeat( i: NativeInt): PPyObject; virtual;

Parameters

i
Type: NativeInt

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.SqItem(NativeInt) Method

Summary

Represents method SqItem(NativeInt).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function SqItem( idx : NativeInt ) : PPyObject; virtual;

Parameters

idx
Type: NativeInt

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.SqLength Method

Summary

Represents method SqLength.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function SqLength : NativeInt; virtual;

Return Value

Type: NativeInt

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.SqRepeat(NativeInt) Method

Summary

Represents method SqRepeat(NativeInt).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function SqRepeat( val : NativeInt ) : PPyObject; virtual;

Parameters

val
Type: NativeInt

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.SqSlice(NativeInt,NativeInt) Method

Summary

Represents method SqSlice(NativeInt,NativeInt).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function SqSlice( idx1, idx2 : NativeInt ) : PPyObject; virtual;

Parameters

idx1
Type: NativeInt

idx2
Type: NativeInt

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.Str Method

Summary

Represents method Str.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Str: PPyObject; virtual;

Return Value

Type: PPyObject

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.Traverse(visitproc,Pointer) Method

Summary

Represents method Traverse(visitproc,Pointer).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Traverse( proc: visitproc; ptr: Pointer) : integer; virtual;

Parameters

proc
Type: visitproc

ptr
Type: Pointer

Return Value

Type: integer

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject Fields

Fields
Name | Description
IsSubtype | Represents field IsSubtype.
PythonAlloc | Represents field PythonAlloc.
PythonType | Represents field PythonType.
Top


TPyObject.IsSubtype Field

Summary

Represents field IsSubtype.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 IsSubtype : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.PythonAlloc Field

Summary

Represents field PythonAlloc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PythonAlloc : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPyObject.PythonType Field

Summary

Represents field PythonType.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PythonType : TPythonType;

Field Value

Type: TPythonType

See Also

Reference

  • TPyObject
  • BI.Plugins.Python.Engine


TPythonDelphiVar Class

Summary

Represents type TPythonDelphiVar.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TComponent
BI.Plugins.Python.Engine.TEngineClient
BI.Plugins.Python.Engine.TPythonDelphiVar
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TPythonDelphiVar = class( TEngineClient )
 end;

The TPythonDelphiVar type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TPythonDelphiVar class. (Overrides TEngineClient.Create(TComponent).)
Top
Properties
Show:
Name | Description
Module | Represents property Module.
OnChange | Represents property OnChange.
Value | Represents property Value.
ValueAsString | Represents property ValueAsString.
ValueObject | Represents property ValueObject.
VarName | Represents property VarName.
VarObject | Represents property VarObject.
Top
Methods
Show:
Name | Description
CreateVar | Represents method CreateVar.
CreateVarType | Represents method CreateVarType.
Finalize | Represents method Finalize. (Overrides TEngineClient.Finalize.)
Initialize | Represents method Initialize. (Overrides TEngineClient.Initialize.)
IsVariantOk(Variant) | Represents method IsVariantOk(Variant).
Top
Events
Show:
Name | Description
OnExtGetData | Represents property OnExtGetData.
OnExtSetData | Represents property OnExtSetData.
OnGetData | Represents property OnGetData.
OnSetData | Represents property OnSetData.
Top
Fields
Show:
Name | Description
FModule | Represents field FModule.
FOnChange | Represents field FOnChange.
FOnExtGetData | Represents field FOnExtGetData.
FOnExtSetData | Represents field FOnExtSetData.
FOnGetData | Represents field FOnGetData.
FOnSetData | Represents field FOnSetData.
FVarName | Represents field FVarName.
FVarObject | Represents field FVarObject.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TPythonDelphiVar Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TPythonDelphiVar class. (Overrides TEngineClient.Create(TComponent).)
Top


TPythonDelphiVar.Create(TComponent) Constructor

Summary

Initializes a new instance of the TPythonDelphiVar class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 constructor Create( AOwner : TComponent ); override;

Parameters

AOwner
Type: TComponent

Overrides

TEngineClient.Create(TComponent)
See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar Properties

Properties
Name | Description
Module | Represents property Module.
OnChange | Represents property OnChange.
Value | Represents property Value.
ValueAsString | Represents property ValueAsString.
ValueObject | Represents property ValueObject.
VarName | Represents property VarName.
VarObject | Represents property VarObject.
Top


TPythonDelphiVar.Module Property

Summary

Represents property Module.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property Module : AnsiString read FModule write FModule;

Property Value

Type: AnsiString

See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar.OnChange Property

Summary

Represents property OnChange.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property OnChange : TNotifyEvent read FOnChange write FOnChange;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar.Value Property

Summary

Represents property Value.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property Value : Variant read GetValue write SetValue;

Property Value

Type: Variant

See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar.ValueAsString Property

Summary

Represents property ValueAsString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property ValueAsString : string read GetValueAsString;

Property Value

Type: string

See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar.ValueObject Property

Summary

Represents property ValueObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property ValueObject : PPyObject read GetValueAsPyObject write SetValueFromPyObject;

Property Value

Type: PPyObject

See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar.VarName Property

Summary

Represents property VarName.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property VarName : AnsiString read FVarName write SetVarName;

Property Value

Type: AnsiString

See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar.VarObject Property

Summary

Represents property VarObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property VarObject : PPyObject read FVarObject write FVarObject;

Property Value

Type: PPyObject

See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar Methods

Methods
Name | Description
CreateVar | Represents method CreateVar.
CreateVarType | Represents method CreateVarType.
Finalize | Represents method Finalize. (Overrides TEngineClient.Finalize.)
Initialize | Represents method Initialize. (Overrides TEngineClient.Initialize.)
IsVariantOk(Variant) | Represents method IsVariantOk(Variant).
Top


TPythonDelphiVar.CreateVar Method

Summary

Represents method CreateVar.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure CreateVar;
See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar.CreateVarType Method

Summary

Represents method CreateVarType.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure CreateVarType;
See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar.Finalize Method

Summary

Represents method Finalize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Finalize; override;

Overrides

TEngineClient.Finalize
See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar.Initialize Method

Summary

Represents method Initialize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Initialize; override;

Overrides

TEngineClient.Initialize
See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar.IsVariantOk(Variant) Method

Summary

Represents method IsVariantOk(Variant).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function IsVariantOk( const v : Variant ) : Boolean;

Parameters

v
Type: Variant

Return Value

Type: Boolean

See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar Events

Events
Name | Description
OnExtGetData | Represents property OnExtGetData.
OnExtSetData | Represents property OnExtSetData.
OnGetData | Represents property OnGetData.
OnSetData | Represents property OnSetData.
Top


TPythonDelphiVar.OnExtGetData Event

Summary

Represents property OnExtGetData.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property OnExtGetData : TExtGetDataEvent read FOnExtGetData write FOnExtGetData;

Value

Type: TExtGetDataEvent

See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar.OnExtSetData Event

Summary

Represents property OnExtSetData.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property OnExtSetData : TExtSetDataEvent read FOnExtSetData write FOnExtSetData;

Value

Type: TExtSetDataEvent

See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar.OnGetData Event

Summary

Represents property OnGetData.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property OnGetData : TGetDataEvent read FOnGetData write FOnGetData;

Value

Type: TGetDataEvent

See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar.OnSetData Event

Summary

Represents property OnSetData.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property OnSetData : TSetDataEvent read FOnSetData write FOnSetData;

Value

Type: TSetDataEvent

See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar Fields

Fields
Name | Description
FModule | Represents field FModule.
FOnChange | Represents field FOnChange.
FOnExtGetData | Represents field FOnExtGetData.
FOnExtSetData | Represents field FOnExtSetData.
FOnGetData | Represents field FOnGetData.
FOnSetData | Represents field FOnSetData.
FVarName | Represents field FVarName.
FVarObject | Represents field FVarObject.
Top


TPythonDelphiVar.FModule Field

Summary

Represents field FModule.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FModule : AnsiString;

Field Value

Type: AnsiString

See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar.FOnChange Field

Summary

Represents field FOnChange.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FOnChange : TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar.FOnExtGetData Field

Summary

Represents field FOnExtGetData.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FOnExtGetData : TExtGetDataEvent;

Field Value

Type: TExtGetDataEvent

See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar.FOnExtSetData Field

Summary

Represents field FOnExtSetData.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FOnExtSetData : TExtSetDataEvent;

Field Value

Type: TExtSetDataEvent

See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar.FOnGetData Field

Summary

Represents field FOnGetData.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FOnGetData : TGetDataEvent;

Field Value

Type: TGetDataEvent

See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar.FOnSetData Field

Summary

Represents field FOnSetData.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FOnSetData : TSetDataEvent;

Field Value

Type: TSetDataEvent

See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar.FVarName Field

Summary

Represents field FVarName.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FVarName : AnsiString;

Field Value

Type: AnsiString

See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonDelphiVar.FVarObject Field

Summary

Represents field FVarObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FVarObject : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • TPythonDelphiVar
  • BI.Plugins.Python.Engine


TPythonEngine Class

Summary

Represents type TPythonEngine.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TComponent
BI.Plugins.Python.Engine.TDynamicDll
BI.Plugins.Python.Engine.TPythonInterface
BI.Plugins.Python.Engine.TPythonEngine
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TPythonEngine = class(TPythonInterface)
 end;

The TPythonEngine type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TPythonEngine class. (Overrides TPythonInterface.Create(TComponent).)
Destroy | Represents the destructor of the TPythonEngine class. (Overrides TDynamicDll.Destroy.)
Top
Properties
Show:
Name | Description
AutoFinalize | Represents property AutoFinalize.
ClientCount | Represents property ClientCount.
Clients[Integer] | Represents property Clients[Integer].
DatetimeConversionMode | Represents property DatetimeConversionMode.
ExecModule | Represents property ExecModule.
GlobalVars | Represents property GlobalVars.
InitScript | Represents property InitScript.
InitThreads | Represents property InitThreads.
InterpreterState | Represents property InterpreterState.
IO | Represents property IO.
IOPythonModule | Represents property IOPythonModule.
LocalVars | Represents property LocalVars.
OnAfterInit | Represents property OnAfterInit.
PyFlags | Represents property PyFlags.
RedirectIO | Represents property RedirectIO.
ThreadState | Represents property ThreadState.
Traceback | Represents property Traceback.
UseWindowsConsole | Represents property UseWindowsConsole.
Version | Represents property Version.
Top
Methods
Show:
Name | Description
AddClient(TEngineClient) | Represents method AddClient(TEngineClient).
AfterLoad | Represents method AfterLoad. (Overrides TPythonInterface.AfterLoad.)
ArrayToPyDict(TVarRec[]) | Represents method ArrayToPyDict(TVarRec[]).
ArrayToPyList(TVarRec[]) | Represents method ArrayToPyList(TVarRec[]).
ArrayToPyTuple(TVarRec[]) | Represents method ArrayToPyTuple(TVarRec[]).
AssignPyFlags | Represents method AssignPyFlags.
BeforeLoad | Represents method BeforeLoad. (Overrides TDynamicDll.BeforeLoad.)
CheckError(Boolean) | Represents method CheckError(Boolean).
CheckEvalSyntax(AnsiString) | Represents method CheckEvalSyntax(AnsiString).
CheckExecSyntax(AnsiString) | Represents method CheckExecSyntax(AnsiString).
CheckRegistry | Represents method CheckRegistry.
CheckSyntax(AnsiString,Integer) | Represents method CheckSyntax(AnsiString,Integer).
CleanString(AnsiString) | Represents method CleanString(AnsiString).
DoOpenDll(String) | Represents method DoOpenDll(String). (Overrides TDynamicDll.DoOpenDll(String).)
DoRedirectIO | Represents method DoRedirectIO.
EvalFunction(PPyObject,TVarRec[]) | Represents method EvalFunction(PPyObject,TVarRec[]).
EvalFunctionNoArgs(PPyObject) | Represents method EvalFunctionNoArgs(PPyObject).
EvalPyFunction(PPyObject,PPyObject) | Represents method EvalPyFunction(PPyObject,PPyObject).
EvalString(AnsiString) | Overloaded. Represents method EvalString(AnsiString).
EvalString(AnsiString,PPyObject,PPyObject) | Overloaded. Represents method EvalString(AnsiString,PPyObject,PPyObject).
EvalStringAsStr(AnsiString) | Represents method EvalStringAsStr(AnsiString).
EvalStrings(TStrings) | Overloaded. Represents method EvalStrings(TStrings).
EvalStrings(TStrings,PPyObject,PPyObject) | Overloaded. Represents method EvalStrings(TStrings,PPyObject,PPyObject).
EvalStringsAsStr(TStrings) | Represents method EvalStringsAsStr(TStrings).
ExecString(AnsiString) | Overloaded. Represents method ExecString(AnsiString).
ExecString(AnsiString,PPyObject,PPyObject) | Overloaded. Represents method ExecString(AnsiString,PPyObject,PPyObject).
ExecStrings(TStrings) | Overloaded. Represents method ExecStrings(TStrings).
ExecStrings(TStrings,PPyObject,PPyObject) | Overloaded. Represents method ExecStrings(TStrings,PPyObject,PPyObject).
Finalize | Represents method Finalize.
FindClient(string) | Represents method FindClient(string).
FindFunction(AnsiString,AnsiString) | Represents method FindFunction(AnsiString,AnsiString).
FindModule(AnsiString) | Represents method FindModule(AnsiString).
GetAttrString(PPyObject,PAnsiChar) | Represents method GetAttrString(PPyObject,PAnsiChar).
GetMainModule | Represents method GetMainModule.
Initialize | Represents method Initialize.
InitWinConsole | Represents method InitWinConsole.
IsType(PPyObject,PPyTypeObject) | Represents method IsType(PPyObject,PPyTypeObject).
ListToSet(PPyObject,Pointer,Integer) | Represents method ListToSet(PPyObject,Pointer,Integer).
Lock | Represents method Lock.
MakePyList(PPyObject[]) | Represents method MakePyList(PPyObject[]).
MakePyTuple(PPyObject[]) | Represents method MakePyTuple(PPyObject[]).
MethodsByName(string) | Represents method MethodsByName(string).
ModuleByName(AnsiString) | Represents method ModuleByName(AnsiString).
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
PyDateTime_Check(PPyObject) | Represents method PyDateTime_Check(PPyObject).
PyDateTime_CheckExact(PPyObject) | Represents method PyDateTime_CheckExact(PPyObject).
PyDate_Check(PPyObject) | Represents method PyDate_Check(PPyObject).
PyDate_CheckExact(PPyObject) | Represents method PyDate_CheckExact(PPyObject).
PyDelta_Check(PPyObject) | Represents method PyDelta_Check(PPyObject).
PyDelta_CheckExact(PPyObject) | Represents method PyDelta_CheckExact(PPyObject).
PyListToStrings(PPyObject,TStrings) | Represents method PyListToStrings(PPyObject,TStrings).
PyObjectAsString(PPyObject) | Represents method PyObjectAsString(PPyObject).
PyObjectAsVariant(PPyObject) | Represents method PyObjectAsVariant(PPyObject).
PyString_AsAnsiString(PPyObject) | Represents method PyString_AsAnsiString(PPyObject).
PyString_AsDelphiString(PPyObject) | Represents method PyString_AsDelphiString(PPyObject). (Overrides TPythonInterface.PyString_AsDelphiString(PPyObject).)
PyString_AsWideString(PPyObject) | Represents method PyString_AsWideString(PPyObject).
PyString_FromString(PAnsiChar) | Represents method PyString_FromString(PAnsiChar). (Overrides TPythonInterface.PyString_FromString(PAnsiChar).)
PyTimeStruct_Check(PPyObject) | Represents method PyTimeStruct_Check(PPyObject).
PyTime_Check(PPyObject) | Represents method PyTime_Check(PPyObject).
PyTime_CheckExact(PPyObject) | Represents method PyTime_CheckExact(PPyObject).
PyTupleToStrings(PPyObject,TStrings) | Represents method PyTupleToStrings(PPyObject,TStrings).
PyTZInfo_Check(PPyObject) | Represents method PyTZInfo_Check(PPyObject).
PyTZInfo_CheckExact(PPyObject) | Represents method PyTZInfo_CheckExact(PPyObject).
PyUnicode_AsWideString(PPyObject) | Represents method PyUnicode_AsWideString(PPyObject).
PyUnicode_FromWideString(UnicodeString) | Represents method PyUnicode_FromWideString(UnicodeString).
RaiseError | Represents method RaiseError.
RemoveClient(TEngineClient) | Represents method RemoveClient(TEngineClient).
ReturnNone | Represents method ReturnNone.
Run_CommandAsObject(AnsiString,Integer) | Represents method Run_CommandAsObject(AnsiString,Integer).
Run_CommandAsObjectWithDict(AnsiString,Integer,PPyObject,PPyObject) | Represents method Run_CommandAsObjectWithDict(AnsiString,Integer,PPyObject,PPyObject).
Run_CommandAsString(AnsiString,Integer) | Represents method Run_CommandAsString(AnsiString,Integer).
SetProgramArgs | Represents method SetProgramArgs.
SetToList(Pointer,Integer) | Represents method SetToList(Pointer,Integer).
SetUseWindowsConsole(Boolean) | Represents method SetUseWindowsConsole(Boolean).
StringsToPyList(TStrings) | Represents method StringsToPyList(TStrings).
StringsToPyTuple(TStrings) | Represents method StringsToPyTuple(TStrings).
TypeByName(AnsiString) | Represents method TypeByName(AnsiString).
Unlock | Represents method Unlock.
VariantAsPyObject(Variant) | Represents method VariantAsPyObject(Variant).
VarRecAsPyObject(TVarRec) | Represents method VarRecAsPyObject(TVarRec).
Top
Events
Show:
Name | Description
OnPathInitialization | Represents property OnPathInitialization.
OnSysPathInit | Represents property OnSysPathInit.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TPythonEngine Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TPythonEngine class. (Overrides TPythonInterface.Create(TComponent).)
Destroy | Represents the destructor of the TPythonEngine class. (Overrides TDynamicDll.Destroy.)
Top


TPythonEngine.Create(TComponent) Constructor

Summary

Initializes a new instance of the TPythonEngine class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TPythonInterface.Create(TComponent)
See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.Destroy Destructor

Summary

Represents the destructor of the TPythonEngine class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TDynamicDll.Destroy
See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine Properties

Properties
Name | Description
AutoFinalize | Represents property AutoFinalize.
ClientCount | Represents property ClientCount.
Clients[Integer] | Represents property Clients[Integer].
DatetimeConversionMode | Represents property DatetimeConversionMode.
ExecModule | Represents property ExecModule.
GlobalVars | Represents property GlobalVars.
InitScript | Represents property InitScript.
InitThreads | Represents property InitThreads.
InterpreterState | Represents property InterpreterState.
IO | Represents property IO.
IOPythonModule | Represents property IOPythonModule.
LocalVars | Represents property LocalVars.
OnAfterInit | Represents property OnAfterInit.
PyFlags | Represents property PyFlags.
RedirectIO | Represents property RedirectIO.
ThreadState | Represents property ThreadState.
Traceback | Represents property Traceback.
UseWindowsConsole | Represents property UseWindowsConsole.
Version | Represents property Version.
Top


TPythonEngine.AutoFinalize Property

Summary

Represents property AutoFinalize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property AutoFinalize: Boolean read FAutoFinalize write FAutoFinalize default True;

Property Value

Type: Boolean

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.ClientCount Property

Summary

Represents property ClientCount.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property ClientCount : Integer read GetClientCount;

Property Value

Type: Integer

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.Clients[Integer] Property

Summary

Represents property Clients[Integer].

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property Clients[ idx : Integer ] : TEngineClient read GetClients;

Parameters

idx
Type: Integer

Property Value

Type: TEngineClient

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.DatetimeConversionMode Property

Summary

Represents property DatetimeConversionMode.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property DatetimeConversionMode: TDatetimeConversionMode read FDatetimeConversionMode write FDatetimeConversionMode default DEFAULT_DATETIME_CONVERSION_MODE;

Property Value

Type: TDatetimeConversionMode

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.ExecModule Property

Summary

Represents property ExecModule.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property ExecModule : AnsiString read FExecModule write FExecModule;

Property Value

Type: AnsiString

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.GlobalVars Property

Summary

Represents property GlobalVars.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property GlobalVars : PPyObject read FGlobalVars Write SetGlobalVars;

Property Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.InitScript Property

Summary

Represents property InitScript.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property InitScript: TStrings read FInitScript write SetInitScript;

Property Value

Type: TStrings

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.InitThreads Property

Summary

Represents property InitThreads.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property InitThreads: Boolean read FInitThreads write SetInitThreads default False;

Property Value

Type: Boolean

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.InterpreterState Property

Summary

Represents property InterpreterState.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property InterpreterState: PPyInterpreterState read GetInterpreterState;

Property Value

Type: PPyInterpreterState

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.IO Property

Summary

Represents property IO.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property IO: TPythonInputOutput read FIO write FIO;

Property Value

Type: TPythonInputOutput

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.IOPythonModule Property

Summary

Represents property IOPythonModule.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property IOPythonModule: TObject read FIOPythonModule;

Property Value

Type: TObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.LocalVars Property

Summary

Represents property LocalVars.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property LocalVars : PPyObject read FLocalVars Write SetLocalVars;

Property Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.OnAfterInit Property

Summary

Represents property OnAfterInit.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property OnAfterInit: TNotifyEvent read FOnAfterInit write FOnAfterInit;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyFlags Property

Summary

Represents property PyFlags.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property PyFlags: TPythonFlags read FPyFlags write SetPyFlags default [];

Property Value

Type: TPythonFlags

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.RedirectIO Property

Summary

Represents property RedirectIO.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property RedirectIO: Boolean read FRedirectIO write FRedirectIO default True;

Property Value

Type: Boolean

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.ThreadState Property

Summary

Represents property ThreadState.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property ThreadState: PPyThreadState read GetThreadState;

Property Value

Type: PPyThreadState

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.Traceback Property

Summary

Represents property Traceback.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property Traceback : TPythonTraceback read FTraceback;

Property Value

Type: TPythonTraceback

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.UseWindowsConsole Property

Summary

Represents property UseWindowsConsole.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property UseWindowsConsole: Boolean read FUseWindowsConsole write FUseWindowsConsole default False;

Property Value

Type: Boolean

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.Version Property

Summary

Represents property Version.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property Version : String read GetVersion write SetVersion stored False;

Property Value

Type: String

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine Methods

Methods
Name | Description
AddClient(TEngineClient) | Represents method AddClient(TEngineClient).
AfterLoad | Represents method AfterLoad. (Overrides TPythonInterface.AfterLoad.)
ArrayToPyDict(TVarRec[]) | Represents method ArrayToPyDict(TVarRec[]).
ArrayToPyList(TVarRec[]) | Represents method ArrayToPyList(TVarRec[]).
ArrayToPyTuple(TVarRec[]) | Represents method ArrayToPyTuple(TVarRec[]).
AssignPyFlags | Represents method AssignPyFlags.
BeforeLoad | Represents method BeforeLoad. (Overrides TDynamicDll.BeforeLoad.)
CheckError(Boolean) | Represents method CheckError(Boolean).
CheckEvalSyntax(AnsiString) | Represents method CheckEvalSyntax(AnsiString).
CheckExecSyntax(AnsiString) | Represents method CheckExecSyntax(AnsiString).
CheckRegistry | Represents method CheckRegistry.
CheckSyntax(AnsiString,Integer) | Represents method CheckSyntax(AnsiString,Integer).
CleanString(AnsiString) | Represents method CleanString(AnsiString).
DoOpenDll(String) | Represents method DoOpenDll(String). (Overrides TDynamicDll.DoOpenDll(String).)
DoRedirectIO | Represents method DoRedirectIO.
EvalFunction(PPyObject,TVarRec[]) | Represents method EvalFunction(PPyObject,TVarRec[]).
EvalFunctionNoArgs(PPyObject) | Represents method EvalFunctionNoArgs(PPyObject).
EvalPyFunction(PPyObject,PPyObject) | Represents method EvalPyFunction(PPyObject,PPyObject).
EvalString(AnsiString) | Overloaded. Represents method EvalString(AnsiString).
EvalString(AnsiString,PPyObject,PPyObject) | Overloaded. Represents method EvalString(AnsiString,PPyObject,PPyObject).
EvalStringAsStr(AnsiString) | Represents method EvalStringAsStr(AnsiString).
EvalStrings(TStrings) | Overloaded. Represents method EvalStrings(TStrings).
EvalStrings(TStrings,PPyObject,PPyObject) | Overloaded. Represents method EvalStrings(TStrings,PPyObject,PPyObject).
EvalStringsAsStr(TStrings) | Represents method EvalStringsAsStr(TStrings).
ExecString(AnsiString) | Overloaded. Represents method ExecString(AnsiString).
ExecString(AnsiString,PPyObject,PPyObject) | Overloaded. Represents method ExecString(AnsiString,PPyObject,PPyObject).
ExecStrings(TStrings) | Overloaded. Represents method ExecStrings(TStrings).
ExecStrings(TStrings,PPyObject,PPyObject) | Overloaded. Represents method ExecStrings(TStrings,PPyObject,PPyObject).
Finalize | Represents method Finalize.
FindClient(string) | Represents method FindClient(string).
FindFunction(AnsiString,AnsiString) | Represents method FindFunction(AnsiString,AnsiString).
FindModule(AnsiString) | Represents method FindModule(AnsiString).
GetAttrString(PPyObject,PAnsiChar) | Represents method GetAttrString(PPyObject,PAnsiChar).
GetMainModule | Represents method GetMainModule.
Initialize | Represents method Initialize.
InitWinConsole | Represents method InitWinConsole.
IsType(PPyObject,PPyTypeObject) | Represents method IsType(PPyObject,PPyTypeObject).
ListToSet(PPyObject,Pointer,Integer) | Represents method ListToSet(PPyObject,Pointer,Integer).
Lock | Represents method Lock.
MakePyList(PPyObject[]) | Represents method MakePyList(PPyObject[]).
MakePyTuple(PPyObject[]) | Represents method MakePyTuple(PPyObject[]).
MethodsByName(string) | Represents method MethodsByName(string).
ModuleByName(AnsiString) | Represents method ModuleByName(AnsiString).
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
PyDateTime_Check(PPyObject) | Represents method PyDateTime_Check(PPyObject).
PyDateTime_CheckExact(PPyObject) | Represents method PyDateTime_CheckExact(PPyObject).
PyDate_Check(PPyObject) | Represents method PyDate_Check(PPyObject).
PyDate_CheckExact(PPyObject) | Represents method PyDate_CheckExact(PPyObject).
PyDelta_Check(PPyObject) | Represents method PyDelta_Check(PPyObject).
PyDelta_CheckExact(PPyObject) | Represents method PyDelta_CheckExact(PPyObject).
PyListToStrings(PPyObject,TStrings) | Represents method PyListToStrings(PPyObject,TStrings).
PyObjectAsString(PPyObject) | Represents method PyObjectAsString(PPyObject).
PyObjectAsVariant(PPyObject) | Represents method PyObjectAsVariant(PPyObject).
PyString_AsAnsiString(PPyObject) | Represents method PyString_AsAnsiString(PPyObject).
PyString_AsDelphiString(PPyObject) | Represents method PyString_AsDelphiString(PPyObject). (Overrides TPythonInterface.PyString_AsDelphiString(PPyObject).)
PyString_AsWideString(PPyObject) | Represents method PyString_AsWideString(PPyObject).
PyString_FromString(PAnsiChar) | Represents method PyString_FromString(PAnsiChar). (Overrides TPythonInterface.PyString_FromString(PAnsiChar).)
PyTimeStruct_Check(PPyObject) | Represents method PyTimeStruct_Check(PPyObject).
PyTime_Check(PPyObject) | Represents method PyTime_Check(PPyObject).
PyTime_CheckExact(PPyObject) | Represents method PyTime_CheckExact(PPyObject).
PyTupleToStrings(PPyObject,TStrings) | Represents method PyTupleToStrings(PPyObject,TStrings).
PyTZInfo_Check(PPyObject) | Represents method PyTZInfo_Check(PPyObject).
PyTZInfo_CheckExact(PPyObject) | Represents method PyTZInfo_CheckExact(PPyObject).
PyUnicode_AsWideString(PPyObject) | Represents method PyUnicode_AsWideString(PPyObject).
PyUnicode_FromWideString(UnicodeString) | Represents method PyUnicode_FromWideString(UnicodeString).
RaiseError | Represents method RaiseError.
RemoveClient(TEngineClient) | Represents method RemoveClient(TEngineClient).
ReturnNone | Represents method ReturnNone.
Run_CommandAsObject(AnsiString,Integer) | Represents method Run_CommandAsObject(AnsiString,Integer).
Run_CommandAsObjectWithDict(AnsiString,Integer,PPyObject,PPyObject) | Represents method Run_CommandAsObjectWithDict(AnsiString,Integer,PPyObject,PPyObject).
Run_CommandAsString(AnsiString,Integer) | Represents method Run_CommandAsString(AnsiString,Integer).
SetProgramArgs | Represents method SetProgramArgs.
SetToList(Pointer,Integer) | Represents method SetToList(Pointer,Integer).
SetUseWindowsConsole(Boolean) | Represents method SetUseWindowsConsole(Boolean).
StringsToPyList(TStrings) | Represents method StringsToPyList(TStrings).
StringsToPyTuple(TStrings) | Represents method StringsToPyTuple(TStrings).
TypeByName(AnsiString) | Represents method TypeByName(AnsiString).
Unlock | Represents method Unlock.
VariantAsPyObject(Variant) | Represents method VariantAsPyObject(Variant).
VarRecAsPyObject(TVarRec) | Represents method VarRecAsPyObject(TVarRec).
Top


TPythonEngine.AddClient(TEngineClient) Method

Summary

Represents method AddClient(TEngineClient).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure AddClient( client : TEngineClient );

Parameters

client
Type: TEngineClient

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.AfterLoad Method

Summary

Represents method AfterLoad.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure AfterLoad; override;

Overrides

TPythonInterface.AfterLoad
See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.ArrayToPyDict(TVarRec[]) Method

Summary

Represents method ArrayToPyDict(TVarRec[]).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function ArrayToPyDict( items : array of const) : PPyObject;

Parameters

items
Type: array of const

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.ArrayToPyList(TVarRec[]) Method

Summary

Represents method ArrayToPyList(TVarRec[]).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function ArrayToPyList( items : array of const) : PPyObject;

Parameters

items
Type: array of const

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.ArrayToPyTuple(TVarRec[]) Method

Summary

Represents method ArrayToPyTuple(TVarRec[]).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function ArrayToPyTuple( items : array of const) : PPyObject;

Parameters

items
Type: array of const

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.AssignPyFlags Method

Summary

Represents method AssignPyFlags.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure AssignPyFlags;
See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.BeforeLoad Method

Summary

Represents method BeforeLoad.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure BeforeLoad; override;

Overrides

TDynamicDll.BeforeLoad
See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.CheckError(Boolean) Method

Summary

Represents method CheckError(Boolean).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure CheckError(ACatchStopEx : Boolean = False);

Parameters

ACatchStopEx
Type: Boolean

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.CheckEvalSyntax(AnsiString) Method

Summary

Represents method CheckEvalSyntax(AnsiString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function CheckEvalSyntax( const str : AnsiString ) : Boolean;

Parameters

str
Type: AnsiString

Return Value

Type: Boolean

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.CheckExecSyntax(AnsiString) Method

Summary

Represents method CheckExecSyntax(AnsiString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function CheckExecSyntax( const str : AnsiString ) : Boolean;

Parameters

str
Type: AnsiString

Return Value

Type: Boolean

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.CheckRegistry Method

Summary

Represents method CheckRegistry.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure CheckRegistry;
See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.CheckSyntax(AnsiString,Integer) Method

Summary

Represents method CheckSyntax(AnsiString,Integer).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function CheckSyntax( const str : AnsiString; mode : Integer ) : Boolean;

Parameters

str
Type: AnsiString

mode
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.CleanString(AnsiString) Method

Summary

Represents method CleanString(AnsiString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function CleanString(const s : AnsiString) : AnsiString;

Parameters

s
Type: AnsiString

Return Value

Type: AnsiString

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.DoOpenDll(String) Method

Summary

Represents method DoOpenDll(String).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure DoOpenDll(const aDllName : String); override;

Parameters

aDllName
Type: String

Overrides

TDynamicDll.DoOpenDll(String)
See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.DoRedirectIO Method

Summary

Represents method DoRedirectIO.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure DoRedirectIO;
See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.EvalFunction(PPyObject,TVarRec[]) Method

Summary

Represents method EvalFunction(PPyObject,TVarRec[]).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function EvalFunction(pyfunc:PPyObject; args: array of const): Variant;

Parameters

pyfunc
Type: PPyObject

args
Type: array of const

Return Value

Type: Variant

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.EvalFunctionNoArgs(PPyObject) Method

Summary

Represents method EvalFunctionNoArgs(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function EvalFunctionNoArgs(pyfunc:PPyObject): Variant;

Parameters

pyfunc
Type: PPyObject

Return Value

Type: Variant

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.EvalPyFunction(PPyObject,PPyObject) Method

Summary

Represents method EvalPyFunction(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function EvalPyFunction(pyfunc, pyargs:PPyObject): Variant;

Parameters

pyfunc
Type: PPyObject

pyargs
Type: PPyObject

Return Value

Type: Variant

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.EvalString(AnsiString) Method

Summary

Represents method EvalString(AnsiString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function EvalString(const command : AnsiString) : PPyObject; overload;

Parameters

command
Type: AnsiString

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.EvalString(AnsiString,PPyObject,PPyObject) Method

Summary

Represents method EvalString(AnsiString,PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function EvalString( const command : AnsiString; locals, globals : PPyObject ) : PPyObject; overload;

Parameters

command
Type: AnsiString

locals
Type: PPyObject

globals
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.EvalStringAsStr(AnsiString) Method

Summary

Represents method EvalStringAsStr(AnsiString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function EvalStringAsStr(const command : AnsiString) : String;

Parameters

command
Type: AnsiString

Return Value

Type: String

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.EvalStrings(TStrings) Method

Summary

Represents method EvalStrings(TStrings).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function EvalStrings( strings : TStrings ) : PPyObject; overload;

Parameters

strings
Type: TStrings

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.EvalStrings(TStrings,PPyObject,PPyObject) Method

Summary

Represents method EvalStrings(TStrings,PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function EvalStrings( strings : TStrings; locals, globals : PPyObject ) : PPyObject; overload;

Parameters

strings
Type: TStrings

locals
Type: PPyObject

globals
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.EvalStringsAsStr(TStrings) Method

Summary

Represents method EvalStringsAsStr(TStrings).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function EvalStringsAsStr( strings : TStrings ) : String;

Parameters

strings
Type: TStrings

Return Value

Type: String

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.ExecString(AnsiString) Method

Summary

Represents method ExecString(AnsiString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure ExecString(const command : AnsiString); overload;

Parameters

command
Type: AnsiString

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.ExecString(AnsiString,PPyObject,PPyObject) Method

Summary

Represents method ExecString(AnsiString,PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure ExecString(const command : AnsiString; locals, globals : PPyObject ); overload;

Parameters

command
Type: AnsiString

locals
Type: PPyObject

globals
Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.ExecStrings(TStrings) Method

Summary

Represents method ExecStrings(TStrings).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure ExecStrings( strings : TStrings ); overload;

Parameters

strings
Type: TStrings

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.ExecStrings(TStrings,PPyObject,PPyObject) Method

Summary

Represents method ExecStrings(TStrings,PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure ExecStrings( strings : TStrings; locals, globals : PPyObject ); overload;

Parameters

strings
Type: TStrings

locals
Type: PPyObject

globals
Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.Finalize Method

Summary

Represents method Finalize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Finalize;
See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.FindClient(string) Method

Summary

Represents method FindClient(string).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function FindClient( const aName : string ) : TEngineClient;

Parameters

aName
Type: string

Return Value

Type: TEngineClient

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.FindFunction(AnsiString,AnsiString) Method

Summary

Represents method FindFunction(AnsiString,AnsiString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function FindFunction(ModuleName,FuncName: AnsiString): PPyObject;

Parameters

ModuleName
Type: AnsiString

FuncName
Type: AnsiString

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.FindModule(AnsiString) Method

Summary

Represents method FindModule(AnsiString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function FindModule( const ModuleName : AnsiString ) : PPyObject;

Parameters

ModuleName
Type: AnsiString

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.GetAttrString(PPyObject,PAnsiChar) Method

Summary

Represents method GetAttrString(PPyObject,PAnsiChar).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function GetAttrString(obj: PPyObject; AName: PAnsiChar):PAnsiChar;

Parameters

obj
Type: PPyObject

AName
Type: PAnsiChar

Return Value

Type: PAnsiChar

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.GetMainModule Method

Summary

Represents method GetMainModule.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function GetMainModule : PPyObject;

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.Initialize Method

Summary

Represents method Initialize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Initialize;
See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.InitWinConsole Method

Summary

Represents method InitWinConsole.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure InitWinConsole;
See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.IsType(PPyObject,PPyTypeObject) Method

Summary

Represents method IsType(PPyObject,PPyTypeObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function IsType(ob: PPyObject; obt: PPyTypeObject): Boolean;

Parameters

ob
Type: PPyObject

obt
Type: PPyTypeObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.ListToSet(PPyObject,Pointer,Integer) Method

Summary

Represents method ListToSet(PPyObject,Pointer,Integer).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure ListToSet( List : PPyObject; data : Pointer; size : Integer );

Parameters

List
Type: PPyObject

data
Type: Pointer

size
Type: Integer

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.Lock Method

Summary

Represents method Lock.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Lock;
See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.MakePyList(PPyObject[]) Method

Summary

Represents method MakePyList(PPyObject[]).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function MakePyList( const objects : array of PPyObject ) : PPyObject;

Parameters

objects
Type: array of PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.MakePyTuple(PPyObject[]) Method

Summary

Represents method MakePyTuple(PPyObject[]).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function MakePyTuple( const objects : array of PPyObject ) : PPyObject;

Parameters

objects
Type: array of PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.MethodsByName(string) Method

Summary

Represents method MethodsByName(string).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function MethodsByName( const aMethodsContainer: string ) : PPyMethodDef;

Parameters

aMethodsContainer
Type: string

Return Value

Type: PPyMethodDef

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.ModuleByName(AnsiString) Method

Summary

Represents method ModuleByName(AnsiString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function ModuleByName( const aModuleName : AnsiString ) : PPyObject;

Parameters

aModuleName
Type: AnsiString

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent;
 Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyDateTime_Check(PPyObject) Method

Summary

Represents method PyDateTime_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyDateTime_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyDateTime_CheckExact(PPyObject) Method

Summary

Represents method PyDateTime_CheckExact(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyDateTime_CheckExact( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyDate_Check(PPyObject) Method

Summary

Represents method PyDate_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyDate_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyDate_CheckExact(PPyObject) Method

Summary

Represents method PyDate_CheckExact(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyDate_CheckExact( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyDelta_Check(PPyObject) Method

Summary

Represents method PyDelta_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyDelta_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyDelta_CheckExact(PPyObject) Method

Summary

Represents method PyDelta_CheckExact(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyDelta_CheckExact( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyListToStrings(PPyObject,TStrings) Method

Summary

Represents method PyListToStrings(PPyObject,TStrings).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure PyListToStrings( list : PPyObject; strings : TStrings );

Parameters

list
Type: PPyObject

strings
Type: TStrings

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyObjectAsString(PPyObject) Method

Summary

Represents method PyObjectAsString(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyObjectAsString( obj : PPyObject ) : String;

Parameters

obj
Type: PPyObject

Return Value

Type: String

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyObjectAsVariant(PPyObject) Method

Summary

Represents method PyObjectAsVariant(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyObjectAsVariant( obj : PPyObject ) : Variant; virtual;

Parameters

obj
Type: PPyObject

Return Value

Type: Variant

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyString_AsAnsiString(PPyObject) Method

Summary

Represents method PyString_AsAnsiString(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyString_AsAnsiString( ob: PPyObject): AnsiString;

Parameters

ob
Type: PPyObject

Return Value

Type: AnsiString

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyString_AsDelphiString(PPyObject) Method

Summary

Represents method PyString_AsDelphiString(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyString_AsDelphiString( ob: PPyObject): string; override;

Parameters

ob
Type: PPyObject

Return Value

Type: string

Overrides

TPythonInterface.PyString_AsDelphiString(PPyObject)
See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyString_AsWideString(PPyObject) Method

Summary

Represents method PyString_AsWideString(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyString_AsWideString( ob: PPyObject): UnicodeString;

Parameters

ob
Type: PPyObject

Return Value

Type: UnicodeString

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyString_FromString(PAnsiChar) Method

Summary

Represents method PyString_FromString(PAnsiChar).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyString_FromString( str: PAnsiChar): PPyObject; override;

Parameters

str
Type: PAnsiChar

Return Value

Type: PPyObject

Overrides

TPythonInterface.PyString_FromString(PAnsiChar)
See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyTimeStruct_Check(PPyObject) Method

Summary

Represents method PyTimeStruct_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyTimeStruct_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyTime_Check(PPyObject) Method

Summary

Represents method PyTime_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyTime_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyTime_CheckExact(PPyObject) Method

Summary

Represents method PyTime_CheckExact(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyTime_CheckExact( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyTupleToStrings(PPyObject,TStrings) Method

Summary

Represents method PyTupleToStrings(PPyObject,TStrings).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure PyTupleToStrings( tuple: PPyObject; strings : TStrings );

Parameters

tuple
Type: PPyObject

strings
Type: TStrings

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyTZInfo_Check(PPyObject) Method

Summary

Represents method PyTZInfo_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyTZInfo_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyTZInfo_CheckExact(PPyObject) Method

Summary

Represents method PyTZInfo_CheckExact(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyTZInfo_CheckExact( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyUnicode_AsWideString(PPyObject) Method

Summary

Represents method PyUnicode_AsWideString(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyUnicode_AsWideString( obj : PPyObject ) : UnicodeString;

Parameters

obj
Type: PPyObject

Return Value

Type: UnicodeString

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.PyUnicode_FromWideString(UnicodeString) Method

Summary

Represents method PyUnicode_FromWideString(UnicodeString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyUnicode_FromWideString( const AString : UnicodeString) : PPyObject;

Parameters

AString
Type: UnicodeString

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.RaiseError Method

Summary

Represents method RaiseError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure RaiseError;
See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.RemoveClient(TEngineClient) Method

Summary

Represents method RemoveClient(TEngineClient).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure RemoveClient( client : TEngineClient );

Parameters

client
Type: TEngineClient

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.ReturnNone Method

Summary

Represents method ReturnNone.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function ReturnNone : PPyObject;

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.Run_CommandAsObject(AnsiString,Integer) Method

Summary

Represents method Run_CommandAsObject(AnsiString,Integer).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Run_CommandAsObject(const command : AnsiString; mode : Integer) : PPyObject;

Parameters

command
Type: AnsiString

mode
Type: Integer

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.Run_CommandAsObjectWithDict(AnsiString,Integer,PPyObject,PPyObject) Method

Summary

Represents method Run_CommandAsObjectWithDict(AnsiString,Integer,PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Run_CommandAsObjectWithDict(const command : AnsiString; mode : Integer; locals, globals : PPyObject) : PPyObject;

Parameters

command
Type: AnsiString

mode
Type: Integer

locals
Type: PPyObject

globals
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.Run_CommandAsString(AnsiString,Integer) Method

Summary

Represents method Run_CommandAsString(AnsiString,Integer).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Run_CommandAsString(const command : AnsiString; mode : Integer) : String;

Parameters

command
Type: AnsiString

mode
Type: Integer

Return Value

Type: String

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.SetProgramArgs Method

Summary

Represents method SetProgramArgs.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure SetProgramArgs;
See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.SetToList(Pointer,Integer) Method

Summary

Represents method SetToList(Pointer,Integer).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function SetToList( data : Pointer; size : Integer ) : PPyObject;

Parameters

data
Type: Pointer

size
Type: Integer

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.SetUseWindowsConsole(Boolean) Method

Summary

Represents method SetUseWindowsConsole(Boolean).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure SetUseWindowsConsole( const Value : Boolean );

Parameters

Value
Type: Boolean

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.StringsToPyList(TStrings) Method

Summary

Represents method StringsToPyList(TStrings).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function StringsToPyList( strings : TStrings ) : PPyObject;

Parameters

strings
Type: TStrings

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.StringsToPyTuple(TStrings) Method

Summary

Represents method StringsToPyTuple(TStrings).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function StringsToPyTuple( strings : TStrings ) : PPyObject;

Parameters

strings
Type: TStrings

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.TypeByName(AnsiString) Method

Summary

Represents method TypeByName(AnsiString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function TypeByName( const aTypeName : AnsiString ) : PPyTypeObject;

Parameters

aTypeName
Type: AnsiString

Return Value

Type: PPyTypeObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.Unlock Method

Summary

Represents method Unlock.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Unlock;
See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.VariantAsPyObject(Variant) Method

Summary

Represents method VariantAsPyObject(Variant).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function VariantAsPyObject( const V : Variant ) : PPyObject; virtual;

Parameters

V
Type: Variant

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.VarRecAsPyObject(TVarRec) Method

Summary

Represents method VarRecAsPyObject(TVarRec).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function VarRecAsPyObject( v : TVarRec ) : PPyObject;

Parameters

v
Type: TVarRec

Return Value

Type: PPyObject

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine Events

Events
Name | Description
OnPathInitialization | Represents property OnPathInitialization.
OnSysPathInit | Represents property OnSysPathInit.
Top


TPythonEngine.OnPathInitialization Event

Summary

Represents property OnPathInitialization.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property OnPathInitialization: TPathInitializationEvent read FOnPathInitialization write FOnPathInitialization;

Value

Type: TPathInitializationEvent

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonEngine.OnSysPathInit Event

Summary

Represents property OnSysPathInit.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property OnSysPathInit: TSysPathInitEvent read FOnSysPathInit write FOnSysPathInit;

Value

Type: TSysPathInitEvent

See Also

Reference

  • TPythonEngine
  • BI.Plugins.Python.Engine


TPythonInputOutput Class

Summary

Represents type TPythonInputOutput.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TComponent
BI.Plugins.Python.Engine.TPythonInputOutput
BI.Plugins.Python.TBIPythonIO
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TPythonInputOutput = class(TComponent)
 end;

The TPythonInputOutput type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TPythonInputOutput class.
Destroy | Represents the destructor of the TPythonInputOutput class.
Top
Properties
Show:
Name | Description
DelayWrites | Represents property DelayWrites.
MaxLineLength | Represents property MaxLineLength.
MaxLines | Represents property MaxLines.
RawOutput | Represents property RawOutput.
UnicodeIO | Represents property UnicodeIO.
Top
Methods
Show:
Name | Description
AddPendingWrite | Represents method AddPendingWrite.
AddWrite(IOString) | Represents method AddWrite(IOString).
GetCurrentThreadLine | Represents method GetCurrentThreadLine.
GetCurrentThreadSlotIdx | Represents method GetCurrentThreadSlotIdx.
Lock | Represents method Lock.
ReceiveData | Represents method ReceiveData.
ReceiveUniData | Represents method ReceiveUniData.
SendData(AnsiString) | Represents method SendData(AnsiString).
SendUniData(UnicodeString) | Represents method SendUniData(UnicodeString).
Unlock | Represents method Unlock.
UpdateCurrentThreadLine | Represents method UpdateCurrentThreadLine.
Write(IOString) | Represents method Write(IOString).
WriteLine(IOString) | Represents method WriteLine(IOString).
Top
Events
Show:
Name | Description
OnReceiveData | Represents property OnReceiveData.
OnReceiveUniData | Represents property OnReceiveUniData.
OnSendData | Represents property OnSendData.
OnSendUniData | Represents property OnSendUniData.
Top
Fields
Show:
Name | Description
FDelayWrites | Represents field FDelayWrites.
FLinesPerThread | Represents field FLinesPerThread.
FLine_Buffer | Represents field FLine_Buffer.
FLock | Represents field FLock.
FMaxLineLength | Represents field FMaxLineLength.
FMaxLines | Represents field FMaxLines.
FOnReceiveData | Represents field FOnReceiveData.
FOnReceiveUniData | Represents field FOnReceiveUniData.
FOnSendData | Represents field FOnSendData.
FOnSendUniData | Represents field FOnSendUniData.
FQueue | Represents field FQueue.
FRawOutput | Represents field FRawOutput.
FUnicodeIO | Represents field FUnicodeIO.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TPythonInputOutput Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TPythonInputOutput class.
Destroy | Represents the destructor of the TPythonInputOutput class.
Top


TPythonInputOutput.Create(TComponent) Constructor

Summary

Initializes a new instance of the TPythonInputOutput class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 constructor Create( AOwner : TComponent ); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.Destroy Destructor

Summary

Represents the destructor of the TPythonInputOutput class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput Properties

Properties
Name | Description
DelayWrites | Represents property DelayWrites.
MaxLineLength | Represents property MaxLineLength.
MaxLines | Represents property MaxLines.
RawOutput | Represents property RawOutput.
UnicodeIO | Represents property UnicodeIO.
Top


TPythonInputOutput.DelayWrites Property

Summary

Represents property DelayWrites.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property DelayWrites : Boolean read FDelayWrites write FDelayWrites default False;

Property Value

Type: Boolean

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.MaxLineLength Property

Summary

Represents property MaxLineLength.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property MaxLineLength : Integer read FMaxLineLength write FMaxLineLength default kMaxLineLength;

Property Value

Type: Integer

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.MaxLines Property

Summary

Represents property MaxLines.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property MaxLines : Integer read FMaxLines write FMaxLines default kMaxLines;

Property Value

Type: Integer

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.RawOutput Property

Summary

Represents property RawOutput.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property RawOutput: Boolean read FRawOutput write FRawOutput;

Property Value

Type: Boolean

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.UnicodeIO Property

Summary

Represents property UnicodeIO.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property UnicodeIO: Boolean read FUnicodeIO write FUnicodeIO;

Property Value

Type: Boolean

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput Methods

Methods
Name | Description
AddPendingWrite | Represents method AddPendingWrite.
AddWrite(IOString) | Represents method AddWrite(IOString).
GetCurrentThreadLine | Represents method GetCurrentThreadLine.
GetCurrentThreadSlotIdx | Represents method GetCurrentThreadSlotIdx.
Lock | Represents method Lock.
ReceiveData | Represents method ReceiveData.
ReceiveUniData | Represents method ReceiveUniData.
SendData(AnsiString) | Represents method SendData(AnsiString).
SendUniData(UnicodeString) | Represents method SendUniData(UnicodeString).
Unlock | Represents method Unlock.
UpdateCurrentThreadLine | Represents method UpdateCurrentThreadLine.
Write(IOString) | Represents method Write(IOString).
WriteLine(IOString) | Represents method WriteLine(IOString).
Top


TPythonInputOutput.AddPendingWrite Method

Summary

Represents method AddPendingWrite.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure AddPendingWrite; virtual;
See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.AddWrite(IOString) Method

Summary

Represents method AddWrite(IOString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure AddWrite( const str : IOString );

Parameters

str
Type: System.Void

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.GetCurrentThreadLine Method

Summary

Represents method GetCurrentThreadLine.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 function GetCurrentThreadLine : IOString;

Return Value

Type: IOString

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.GetCurrentThreadSlotIdx Method

Summary

Represents method GetCurrentThreadSlotIdx.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 function GetCurrentThreadSlotIdx : Integer;

Return Value

Type: Integer

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.Lock Method

Summary

Represents method Lock.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure Lock;
See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.ReceiveData Method

Summary

Represents method ReceiveData.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 function ReceiveData : AnsiString; virtual;

Return Value

Type: AnsiString

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.ReceiveUniData Method

Summary

Represents method ReceiveUniData.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 function ReceiveUniData : UnicodeString; virtual;

Return Value

Type: UnicodeString

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.SendData(AnsiString) Method

Summary

Represents method SendData(AnsiString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure SendData( const Data : AnsiString ); virtual;

Parameters

Data
Type: AnsiString

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.SendUniData(UnicodeString) Method

Summary

Represents method SendUniData(UnicodeString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure SendUniData( const Data : UnicodeString ); virtual;

Parameters

Data
Type: UnicodeString

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.Unlock Method

Summary

Represents method Unlock.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure Unlock;
See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.UpdateCurrentThreadLine Method

Summary

Represents method UpdateCurrentThreadLine.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure UpdateCurrentThreadLine;
See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.Write(IOString) Method

Summary

Represents method Write(IOString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Write( const str : IOString );

Parameters

str
Type: System.Void

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.WriteLine(IOString) Method

Summary

Represents method WriteLine(IOString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure WriteLine( const str : IOString );

Parameters

str
Type: System.Void

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput Events

Events
Name | Description
OnReceiveData | Represents property OnReceiveData.
OnReceiveUniData | Represents property OnReceiveUniData.
OnSendData | Represents property OnSendData.
OnSendUniData | Represents property OnSendUniData.
Top


TPythonInputOutput.OnReceiveData Event

Summary

Represents property OnReceiveData.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property OnReceiveData : TReceiveDataEvent read FOnReceiveData write FOnReceiveData;

Value

Type: TReceiveDataEvent

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.OnReceiveUniData Event

Summary

Represents property OnReceiveUniData.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property OnReceiveUniData : TReceiveUniDataEvent read FOnReceiveUniData write FOnReceiveUniData;

Value

Type: TReceiveUniDataEvent

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.OnSendData Event

Summary

Represents property OnSendData.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property OnSendData : TSendDataEvent read FOnSendData write FOnSendData;

Value

Type: TSendDataEvent

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.OnSendUniData Event

Summary

Represents property OnSendUniData.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property OnSendUniData : TSendUniDataEvent read FOnSendUniData write FOnSendUniData;

Value

Type: TSendUniDataEvent

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput Fields

Fields
Name | Description
FDelayWrites | Represents field FDelayWrites.
FLinesPerThread | Represents field FLinesPerThread.
FLine_Buffer | Represents field FLine_Buffer.
FLock | Represents field FLock.
FMaxLineLength | Represents field FMaxLineLength.
FMaxLines | Represents field FMaxLines.
FOnReceiveData | Represents field FOnReceiveData.
FOnReceiveUniData | Represents field FOnReceiveUniData.
FOnSendData | Represents field FOnSendData.
FOnSendUniData | Represents field FOnSendUniData.
FQueue | Represents field FQueue.
FRawOutput | Represents field FRawOutput.
FUnicodeIO | Represents field FUnicodeIO.
Top


TPythonInputOutput.FDelayWrites Field

Summary

Represents field FDelayWrites.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FDelayWrites : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.FLinesPerThread Field

Summary

Represents field FLinesPerThread.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FLinesPerThread : TIOStringList;

Field Value

Type: TIOStringList

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.FLine_Buffer Field

Summary

Represents field FLine_Buffer.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FLine_Buffer : IOString;

Field Value

Type: IOString

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.FLock Field

Summary

Represents field FLock.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FLock : TCriticalSection;

Field Value

Type: TCriticalSection

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.FMaxLineLength Field

Summary

Represents field FMaxLineLength.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FMaxLineLength : Integer;

Field Value

Type: Integer

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.FMaxLines Field

Summary

Represents field FMaxLines.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FMaxLines : Integer;

Field Value

Type: Integer

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.FOnReceiveData Field

Summary

Represents field FOnReceiveData.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FOnReceiveData : TReceiveDataEvent;

Field Value

Type: TReceiveDataEvent

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.FOnReceiveUniData Field

Summary

Represents field FOnReceiveUniData.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FOnReceiveUniData: TReceiveUniDataEvent;

Field Value

Type: TReceiveUniDataEvent

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.FOnSendData Field

Summary

Represents field FOnSendData.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FOnSendData : TSendDataEvent;

Field Value

Type: TSendDataEvent

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.FOnSendUniData Field

Summary

Represents field FOnSendUniData.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FOnSendUniData : TSendUniDataEvent;

Field Value

Type: TSendUniDataEvent

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.FQueue Field

Summary

Represents field FQueue.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FQueue : TIOStringList;

Field Value

Type: TIOStringList

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.FRawOutput Field

Summary

Represents field FRawOutput.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FRawOutput : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInputOutput.FUnicodeIO Field

Summary

Represents field FUnicodeIO.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FUnicodeIO : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TPythonInputOutput
  • BI.Plugins.Python.Engine


TPythonInterface Class

Summary

Represents type TPythonInterface.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TComponent
BI.Plugins.Python.Engine.TDynamicDll
BI.Plugins.Python.Engine.TPythonInterface
BI.Plugins.Python.Engine.TPythonEngine
Syntax
Delphi
type
 TPythonInterface=class(TDynamicDll)
end;

The TPythonInterface type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TPythonInterface class. (Overrides TDynamicDll.Create(TComponent).)
Top
Properties
Show:
Name | Description
BuiltInModuleName | Represents property BuiltInModuleName.
Finalizing | Represents property Finalizing.
Initialized | Represents property Initialized.
IsPython3000 | Represents property IsPython3000.
MajorVersion | Represents property MajorVersion.
MinorVersion | Represents property MinorVersion.
Top
Methods
Show:
Name | Description
AfterLoad | Represents method AfterLoad. (Overrides TDynamicDll.AfterLoad.)
CheckPython | Represents method CheckPython.
GetQuitMessage | Represents method GetQuitMessage. (Overrides TDynamicDll.GetQuitMessage.)
GetUnicodeTypeSuffix | Represents method GetUnicodeTypeSuffix.
MapDll | Represents method MapDll.
PyBaseString_Check(PPyObject) | Represents method PyBaseString_Check(PPyObject).
PyBool_Check(PPyObject) | Represents method PyBool_Check(PPyObject).
PyClass_Check(PPyObject) | Represents method PyClass_Check(PPyObject).
PyCode_Addr2Line(PPyCodeObject,Integer) | Represents method PyCode_Addr2Line(PPyCodeObject,Integer).
PyDict_Check(PPyObject) | Represents method PyDict_Check(PPyObject).
PyDict_CheckExact(PPyObject) | Represents method PyDict_CheckExact(PPyObject).
PyEnum_Check(PPyObject) | Represents method PyEnum_Check(PPyObject).
PyFloat_Check(PPyObject) | Represents method PyFloat_Check(PPyObject).
PyFloat_CheckExact(PPyObject) | Represents method PyFloat_CheckExact(PPyObject).
PyFunction_Check(PPyObject) | Represents method PyFunction_Check(PPyObject).
PyImport_ExecCodeModule(AnsiString,PPyObject) | Represents method PyImport_ExecCodeModule(AnsiString,PPyObject).
PyInstance_Check(PPyObject) | Represents method PyInstance_Check(PPyObject).
PyInt_Check(PPyObject) | Represents method PyInt_Check(PPyObject).
PyInt_CheckExact(PPyObject) | Represents method PyInt_CheckExact(PPyObject).
PyIter_Check(PPyObject) | Represents method PyIter_Check(PPyObject).
PyList_Check(PPyObject) | Represents method PyList_Check(PPyObject).
PyList_CheckExact(PPyObject) | Represents method PyList_CheckExact(PPyObject).
PyLong_Check(PPyObject) | Represents method PyLong_Check(PPyObject).
PyLong_CheckExact(PPyObject) | Represents method PyLong_CheckExact(PPyObject).
PyMethod_Check(PPyObject) | Represents method PyMethod_Check(PPyObject).
PyModule_Check(PPyObject) | Represents method PyModule_Check(PPyObject).
PyModule_CheckExact(PPyObject) | Represents method PyModule_CheckExact(PPyObject).
PyObject_IS_GC(PPyObject) | Represents method PyObject_IS_GC(PPyObject).
PyObject_TypeCheck(PPyObject,PPyTypeObject) | Represents method PyObject_TypeCheck(PPyObject,PPyTypeObject).
PySlice_Check(PPyObject) | Represents method PySlice_Check(PPyObject).
PyString_AsDelphiString(PPyObject) | Represents method PyString_AsDelphiString(PPyObject).
PyString_Check(PPyObject) | Represents method PyString_Check(PPyObject).
PyString_CheckExact(PPyObject) | Represents method PyString_CheckExact(PPyObject).
PyString_FromString(PAnsiChar) | Represents method PyString_FromString(PAnsiChar).
PyTuple_Check(PPyObject) | Represents method PyTuple_Check(PPyObject).
PyTuple_CheckExact(PPyObject) | Represents method PyTuple_CheckExact(PPyObject).
PyType_CheckExact(PPyObject) | Represents method PyType_CheckExact(PPyObject).
PyType_IS_GC(PPyTypeObject) | Represents method PyType_IS_GC(PPyTypeObject).
PyUnicode_Check(PPyObject) | Represents method PyUnicode_Check(PPyObject).
PyUnicode_CheckExact(PPyObject) | Represents method PyUnicode_CheckExact(PPyObject).
PyWeakref_Check(PPyObject) | Represents method PyWeakref_Check(PPyObject).
PyWeakref_CheckProxy(PPyObject) | Represents method PyWeakref_CheckProxy(PPyObject).
PyWeakref_CheckRef(PPyObject) | Represents method PyWeakref_CheckRef(PPyObject).
Py_DECREF(PPyObject) | Represents method Py_DECREF(PPyObject).
Py_FlushLine | Represents method Py_FlushLine.
Py_GetBuildInfo | Represents method Py_GetBuildInfo.
Py_GetPlatform | Represents method Py_GetPlatform.
Py_INCREF(PPyObject) | Represents method Py_INCREF(PPyObject).
Py_InitModule(PAnsiChar,PPyMethodDef) | Represents method Py_InitModule(PAnsiChar,PPyMethodDef).
Py_InitModule3000(PyModuleDef) | Represents method Py_InitModule3000(PyModuleDef).
Py_XDECREF(PPyObject) | Represents method Py_XDECREF(PPyObject).
Py_XINCREF(PPyObject) | Represents method Py_XINCREF(PPyObject).
Top
Fields
Show:
Name | Description
FBuiltInModuleName | Represents field FBuiltInModuleName.
FFinalizing | Represents field FFinalizing.
FInitialized | Represents field FInitialized.
FIsPython3000 | Represents field FIsPython3000.
FMajorVersion | Represents field FMajorVersion.
FMinorVersion | Represents field FMinorVersion.
PyArg_Parse | Represents field PyArg_Parse.
PyArg_ParseTuple | Represents field PyArg_ParseTuple.
PyBaseObject_Type | Represents field PyBaseObject_Type.
PyBaseString_Type | Represents field PyBaseString_Type.
PyBool_FromLong | Represents field PyBool_FromLong.
PyBool_Type | Represents field PyBool_Type.
PyBuffer_Type | Represents field PyBuffer_Type.
PyCallable_Check | Represents field PyCallable_Check.
PyCallIter_Type | Represents field PyCallIter_Type.
PyCell_Type | Represents field PyCell_Type.
PyCFunction_GetFunction | Represents field PyCFunction_GetFunction.
PyCFunction_GetSelf | Represents field PyCFunction_GetSelf.
PyCFunction_New | Represents field PyCFunction_New.
PyCFunction_NewEx | Represents field PyCFunction_NewEx.
PyCFunction_Type | Represents field PyCFunction_Type.
PyClassMethod_Type | Represents field PyClassMethod_Type.
PyClass_IsSubclass | Represents field PyClass_IsSubclass.
PyClass_New | Represents field PyClass_New.
PyClass_Type | Represents field PyClass_Type.
PyCObject_AsVoidPtr | Represents field PyCObject_AsVoidPtr.
PyCObject_FromVoidPtr | Represents field PyCObject_FromVoidPtr.
PyCObject_Type | Represents field PyCObject_Type.
PyCode_Type | Represents field PyCode_Type.
PyComplex_AsCComplex | Represents field PyComplex_AsCComplex.
PyComplex_FromCComplex | Represents field PyComplex_FromCComplex.
PyComplex_FromDoubles | Represents field PyComplex_FromDoubles.
PyComplex_ImagAsDouble | Represents field PyComplex_ImagAsDouble.
PyComplex_RealAsDouble | Represents field PyComplex_RealAsDouble.
PyComplex_Type | Represents field PyComplex_Type.
PyDictProxy_New | Represents field PyDictProxy_New.
PyDict_Clear | Represents field PyDict_Clear.
PyDict_Copy | Represents field PyDict_Copy.
PyDict_DelItem | Represents field PyDict_DelItem.
PyDict_DelItemString | Represents field PyDict_DelItemString.
PyDict_GetItem | Represents field PyDict_GetItem.
PyDict_GetItemString | Represents field PyDict_GetItemString.
PyDict_Items | Represents field PyDict_Items.
PyDict_Keys | Represents field PyDict_Keys.
PyDict_New | Represents field PyDict_New.
PyDict_Next | Represents field PyDict_Next.
PyDict_SetItem | Represents field PyDict_SetItem.
PyDict_SetItemString | Represents field PyDict_SetItemString.
PyDict_Size | Represents field PyDict_Size.
PyDict_Type | Represents field PyDict_Type.
PyDict_Values | Represents field PyDict_Values.
PyEnum_Type | Represents field PyEnum_Type.
PyErr_BadArgument | Represents field PyErr_BadArgument.
PyErr_BadInternalCall | Represents field PyErr_BadInternalCall.
PyErr_CheckSignals | Represents field PyErr_CheckSignals.
PyErr_Clear | Represents field PyErr_Clear.
PyErr_ExceptionMatches | Represents field PyErr_ExceptionMatches.
PyErr_Fetch | Represents field PyErr_Fetch.
PyErr_GivenExceptionMatches | Represents field PyErr_GivenExceptionMatches.
PyErr_NewException | Represents field PyErr_NewException.
PyErr_NoMemory | Represents field PyErr_NoMemory.
PyErr_Occurred | Represents field PyErr_Occurred.
PyErr_Print | Represents field PyErr_Print.
PyErr_Restore | Represents field PyErr_Restore.
PyErr_SetFromErrno | Represents field PyErr_SetFromErrno.
PyErr_SetInterrupt | Represents field PyErr_SetInterrupt.
PyErr_SetNone | Represents field PyErr_SetNone.
PyErr_SetObject | Represents field PyErr_SetObject.
PyErr_SetString | Represents field PyErr_SetString.
PyEval_AcquireLock | Represents field PyEval_AcquireLock.
PyEval_AcquireThread | Represents field PyEval_AcquireThread.
PyEval_CallObjectWithKeywords | Represents field PyEval_CallObjectWithKeywords.
PyEval_EvalCode | Represents field PyEval_EvalCode.
PyEval_GetBuiltins | Represents field PyEval_GetBuiltins.
PyEval_GetFrame | Represents field PyEval_GetFrame.
PyEval_GetGlobals | Represents field PyEval_GetGlobals.
PyEval_GetLocals | Represents field PyEval_GetLocals.
PyEval_GetRestricted | Represents field PyEval_GetRestricted.
PyEval_InitThreads | Represents field PyEval_InitThreads.
PyEval_ReleaseLock | Represents field PyEval_ReleaseLock.
PyEval_ReleaseThread | Represents field PyEval_ReleaseThread.
PyEval_RestoreThread | Represents field PyEval_RestoreThread.
PyEval_SaveThread | Represents field PyEval_SaveThread.
PyExc_ArithmeticError | Represents field PyExc_ArithmeticError.
PyExc_AssertionError | Represents field PyExc_AssertionError.
PyExc_AttributeError | Represents field PyExc_AttributeError.
PyExc_DeprecationWarning | Represents field PyExc_DeprecationWarning.
PyExc_EnvironmentError | Represents field PyExc_EnvironmentError.
PyExc_EOFError | Represents field PyExc_EOFError.
PyExc_Exception | Represents field PyExc_Exception.
PyExc_FloatingPointError | Represents field PyExc_FloatingPointError.
PyExc_FutureWarning | Represents field PyExc_FutureWarning.
PyExc_ImportError | Represents field PyExc_ImportError.
PyExc_IndentationError | Represents field PyExc_IndentationError.
PyExc_IndexError | Represents field PyExc_IndexError.
PyExc_IOError | Represents field PyExc_IOError.
PyExc_KeyboardInterrupt | Represents field PyExc_KeyboardInterrupt.
PyExc_KeyError | Represents field PyExc_KeyError.
PyExc_LookupError | Represents field PyExc_LookupError.
PyExc_MemoryError | Represents field PyExc_MemoryError.
PyExc_MemoryErrorInst | Represents field PyExc_MemoryErrorInst.
PyExc_NameError | Represents field PyExc_NameError.
PyExc_NotImplementedError | Represents field PyExc_NotImplementedError.
PyExc_OSError | Represents field PyExc_OSError.
PyExc_OverflowError | Represents field PyExc_OverflowError.
PyExc_PendingDeprecationWarning | Represents field PyExc_PendingDeprecationWarning.
PyExc_ReferenceError | Represents field PyExc_ReferenceError.
PyExc_RuntimeError | Represents field PyExc_RuntimeError.
PyExc_RuntimeWarning | Represents field PyExc_RuntimeWarning.
PyExc_StandardError | Represents field PyExc_StandardError.
PyExc_StopIteration | Represents field PyExc_StopIteration.
PyExc_SyntaxError | Represents field PyExc_SyntaxError.
PyExc_SyntaxWarning | Represents field PyExc_SyntaxWarning.
PyExc_SystemError | Represents field PyExc_SystemError.
PyExc_SystemExit | Represents field PyExc_SystemExit.
PyExc_TabError | Represents field PyExc_TabError.
PyExc_TypeError | Represents field PyExc_TypeError.
PyExc_UnboundLocalError | Represents field PyExc_UnboundLocalError.
PyExc_UnicodeDecodeError | Represents field PyExc_UnicodeDecodeError.
PyExc_UnicodeEncodeError | Represents field PyExc_UnicodeEncodeError.
PyExc_UnicodeError | Represents field PyExc_UnicodeError.
PyExc_UnicodeTranslateError | Represents field PyExc_UnicodeTranslateError.
PyExc_UserWarning | Represents field PyExc_UserWarning.
PyExc_ValueError | Represents field PyExc_ValueError.
PyExc_Warning | Represents field PyExc_Warning.
PyExc_WindowsError | Represents field PyExc_WindowsError.
PyExc_ZeroDivisionError | Represents field PyExc_ZeroDivisionError.
PyFile_FromString | Represents field PyFile_FromString.
PyFile_GetLine | Represents field PyFile_GetLine.
PyFile_Name | Represents field PyFile_Name.
PyFile_SetBufSize | Represents field PyFile_SetBufSize.
PyFile_SoftSpace | Represents field PyFile_SoftSpace.
PyFile_Type | Represents field PyFile_Type.
PyFile_WriteObject | Represents field PyFile_WriteObject.
PyFile_WriteString | Represents field PyFile_WriteString.
PyFloat_AsDouble | Represents field PyFloat_AsDouble.
PyFloat_FromDouble | Represents field PyFloat_FromDouble.
PyFloat_Type | Represents field PyFloat_Type.
PyFrame_Type | Represents field PyFrame_Type.
PyFunction_GetCode | Represents field PyFunction_GetCode.
PyFunction_GetGlobals | Represents field PyFunction_GetGlobals.
PyFunction_New | Represents field PyFunction_New.
PyFunction_Type | Represents field PyFunction_Type.
PyGILState_Ensure | Represents field PyGILState_Ensure.
PyGILState_Release | Represents field PyGILState_Release.
PyImport_AddModule | Represents field PyImport_AddModule.
PyImport_Cleanup | Represents field PyImport_Cleanup.
PyImport_FrozenModules | Represents field PyImport_FrozenModules.
PyImport_GetMagicNumber | Represents field PyImport_GetMagicNumber.
PyImport_GetModuleDict | Represents field PyImport_GetModuleDict.
PyImport_Import | Represents field PyImport_Import.
PyImport_ImportFrozenModule | Represents field PyImport_ImportFrozenModule.
PyImport_ImportModule | Represents field PyImport_ImportModule.
PyImport_ReloadModule | Represents field PyImport_ReloadModule.
PyInstance_New | Represents field PyInstance_New.
PyInstance_Type | Represents field PyInstance_Type.
PyInterpreterState_Clear | Represents field PyInterpreterState_Clear.
PyInterpreterState_Delete | Represents field PyInterpreterState_Delete.
PyInterpreterState_New | Represents field PyInterpreterState_New.
PyInt_AsLong | Represents field PyInt_AsLong.
PyInt_FromLong | Represents field PyInt_FromLong.
PyInt_Type | Represents field PyInt_Type.
PyIter_Next | Represents field PyIter_Next.
PyList_Append | Represents field PyList_Append.
PyList_AsTuple | Represents field PyList_AsTuple.
PyList_GetItem | Represents field PyList_GetItem.
PyList_GetSlice | Represents field PyList_GetSlice.
PyList_Insert | Represents field PyList_Insert.
PyList_New | Represents field PyList_New.
PyList_Reverse | Represents field PyList_Reverse.
PyList_SetItem | Represents field PyList_SetItem.
PyList_SetSlice | Represents field PyList_SetSlice.
PyList_Size | Represents field PyList_Size.
PyList_Sort | Represents field PyList_Sort.
PyList_Type | Represents field PyList_Type.
PyLong_AsDouble | Represents field PyLong_AsDouble.
PyLong_AsLong | Represents field PyLong_AsLong.
PyLong_AsLongLong | Represents field PyLong_AsLongLong.
PyLong_AsUnsignedLong | Represents field PyLong_AsUnsignedLong.
PyLong_FromDouble | Represents field PyLong_FromDouble.
PyLong_FromLong | Represents field PyLong_FromLong.
PyLong_FromLongLong | Represents field PyLong_FromLongLong.
PyLong_FromString | Represents field PyLong_FromString.
PyLong_FromUnicode | Represents field PyLong_FromUnicode.
PyLong_FromUnsignedLong | Represents field PyLong_FromUnsignedLong.
PyLong_Type | Represents field PyLong_Type.
PyMapping_Check | Represents field PyMapping_Check.
PyMapping_GetItemString | Represents field PyMapping_GetItemString.
PyMapping_HasKey | Represents field PyMapping_HasKey.
PyMapping_HasKeyString | Represents field PyMapping_HasKeyString.
PyMapping_Length | Represents field PyMapping_Length.
PyMapping_SetItemString | Represents field PyMapping_SetItemString.
PyMem_Malloc | Represents field PyMem_Malloc.
PyMethod_Class | Represents field PyMethod_Class.
PyMethod_Function | Represents field PyMethod_Function.
PyMethod_New | Represents field PyMethod_New.
PyMethod_Self | Represents field PyMethod_Self.
PyMethod_Type | Represents field PyMethod_Type.
PyModule_Create2 | Represents field PyModule_Create2.
PyModule_GetDict | Represents field PyModule_GetDict.
PyModule_GetName | Represents field PyModule_GetName.
PyModule_New | Represents field PyModule_New.
PyModule_Type | Represents field PyModule_Type.
PyNode_Free | Represents field PyNode_Free.
PyNumber_Absolute | Represents field PyNumber_Absolute.
PyNumber_Add | Represents field PyNumber_Add.
PyNumber_And | Represents field PyNumber_And.
PyNumber_Check | Represents field PyNumber_Check.
PyNumber_Coerce | Represents field PyNumber_Coerce.
PyNumber_Divide | Represents field PyNumber_Divide.
PyNumber_Divmod | Represents field PyNumber_Divmod.
PyNumber_Float | Represents field PyNumber_Float.
PyNumber_FloorDivide | Represents field PyNumber_FloorDivide.
PyNumber_Int | Represents field PyNumber_Int.
PyNumber_Invert | Represents field PyNumber_Invert.
PyNumber_Long | Represents field PyNumber_Long.
PyNumber_Lshift | Represents field PyNumber_Lshift.
PyNumber_Multiply | Represents field PyNumber_Multiply.
PyNumber_Negative | Represents field PyNumber_Negative.
PyNumber_Or | Represents field PyNumber_Or.
PyNumber_Positive | Represents field PyNumber_Positive.
PyNumber_Power | Represents field PyNumber_Power.
PyNumber_Remainder | Represents field PyNumber_Remainder.
PyNumber_Rshift | Represents field PyNumber_Rshift.
PyNumber_Subtract | Represents field PyNumber_Subtract.
PyNumber_TrueDivide | Represents field PyNumber_TrueDivide.
PyNumber_Xor | Represents field PyNumber_Xor.
PyObject_Call | Represents field PyObject_Call.
PyObject_CallMethod | Represents field PyObject_CallMethod.
PyObject_CallMethodStr | Represents field PyObject_CallMethodStr.
PyObject_CallObject | Represents field PyObject_CallObject.
PyObject_Compare | Represents field PyObject_Compare.
PyObject_DelItem | Represents field PyObject_DelItem.
PyObject_Free | Represents field PyObject_Free.
PyObject_GC_Del | Represents field PyObject_GC_Del.
PyObject_GC_Malloc | Represents field PyObject_GC_Malloc.
PyObject_GC_New | Represents field PyObject_GC_New.
PyObject_GC_NewVar | Represents field PyObject_GC_NewVar.
PyObject_GC_Resize | Represents field PyObject_GC_Resize.
PyObject_GC_Track | Represents field PyObject_GC_Track.
PyObject_GC_UnTrack | Represents field PyObject_GC_UnTrack.
PyObject_GenericGetAttr | Represents field PyObject_GenericGetAttr.
PyObject_GenericSetAttr | Represents field PyObject_GenericSetAttr.
PyObject_GetAttr | Represents field PyObject_GetAttr.
PyObject_GetAttrString | Represents field PyObject_GetAttrString.
PyObject_GetItem | Represents field PyObject_GetItem.
PyObject_GetIter | Represents field PyObject_GetIter.
PyObject_HasAttrString | Represents field PyObject_HasAttrString.
PyObject_Hash | Represents field PyObject_Hash.
PyObject_Init | Represents field PyObject_Init.
PyObject_InitVar | Represents field PyObject_InitVar.
PyObject_IsInstance | Represents field PyObject_IsInstance.
PyObject_IsSubclass | Represents field PyObject_IsSubclass.
PyObject_IsTrue | Represents field PyObject_IsTrue.
PyObject_Length | Represents field PyObject_Length.
PyObject_New | Represents field PyObject_New.
PyObject_NewVar | Represents field PyObject_NewVar.
PyObject_Repr | Represents field PyObject_Repr.
PyObject_RichCompare | Represents field PyObject_RichCompare.
PyObject_RichCompareBool | Represents field PyObject_RichCompareBool.
PyObject_SetAttr | Represents field PyObject_SetAttr.
PyObject_SetAttrString | Represents field PyObject_SetAttrString.
PyObject_SetItem | Represents field PyObject_SetItem.
PyObject_Str | Represents field PyObject_Str.
PyObject_Type | Represents field PyObject_Type.
PyOS_InitInterrupts | Represents field PyOS_InitInterrupts.
PyOS_InterruptOccurred | Represents field PyOS_InterruptOccurred.
PyParser_SimpleParseString | Represents field PyParser_SimpleParseString.
PyProperty_Type | Represents field PyProperty_Type.
PyRange_Type | Represents field PyRange_Type.
PyRun_SimpleString | Represents field PyRun_SimpleString.
PyRun_String | Represents field PyRun_String.
PySeqIter_New | Represents field PySeqIter_New.
PySeqIter_Type | Represents field PySeqIter_Type.
PySequence_Check | Represents field PySequence_Check.
PySequence_Concat | Represents field PySequence_Concat.
PySequence_Contains | Represents field PySequence_Contains.
PySequence_Count | Represents field PySequence_Count.
PySequence_DelSlice | Represents field PySequence_DelSlice.
PySequence_GetItem | Represents field PySequence_GetItem.
PySequence_GetSlice | Represents field PySequence_GetSlice.
PySequence_In | Represents field PySequence_In.
PySequence_Index | Represents field PySequence_Index.
PySequence_Length | Represents field PySequence_Length.
PySequence_Repeat | Represents field PySequence_Repeat.
PySequence_SetItem | Represents field PySequence_SetItem.
PySequence_SetSlice | Represents field PySequence_SetSlice.
PySequence_Tuple | Represents field PySequence_Tuple.
PySlice_GetIndices | Represents field PySlice_GetIndices.
PySlice_GetIndicesEx | Represents field PySlice_GetIndicesEx.
PySlice_New | Represents field PySlice_New.
PySlice_Type | Represents field PySlice_Type.
PyStaticMethod_Type | Represents field PyStaticMethod_Type.
PyString_AsString | Represents field PyString_AsString.
PyString_Concat | Represents field PyString_Concat.
PyString_ConcatAndDel | Represents field PyString_ConcatAndDel.
PyString_DecodeEscape | Represents field PyString_DecodeEscape.
PyString_Format | Represents field PyString_Format.
PyString_FromStringAndSize | Represents field PyString_FromStringAndSize.
PyString_Repr | Represents field PyString_Repr.
PyString_Size | Represents field PyString_Size.
PyString_Type | Represents field PyString_Type.
PySuper_Type | Represents field PySuper_Type.
PySys_GetObject | Represents field PySys_GetObject.
PySys_SetArgv | Represents field PySys_SetArgv.
PySys_SetArgv3000 | Represents field PySys_SetArgv3000.
PySys_SetObject | Represents field PySys_SetObject.
PySys_SetPath | Represents field PySys_SetPath.
PyThreadState_Clear | Represents field PyThreadState_Clear.
PyThreadState_Delete | Represents field PyThreadState_Delete.
PyThreadState_Get | Represents field PyThreadState_Get.
PyThreadState_New | Represents field PyThreadState_New.
PyThreadState_SetAsyncExc | Represents field PyThreadState_SetAsyncExc.
PyThreadState_Swap | Represents field PyThreadState_Swap.
PyTraceBack_Here | Represents field PyTraceBack_Here.
PyTraceBack_Print | Represents field PyTraceBack_Print.
PyTraceBack_Type | Represents field PyTraceBack_Type.
PyTuple_GetItem | Represents field PyTuple_GetItem.
PyTuple_GetSlice | Represents field PyTuple_GetSlice.
PyTuple_New | Represents field PyTuple_New.
PyTuple_SetItem | Represents field PyTuple_SetItem.
PyTuple_Size | Represents field PyTuple_Size.
PyTuple_Type | Represents field PyTuple_Type.
PyType_GenericAlloc | Represents field PyType_GenericAlloc.
PyType_GenericNew | Represents field PyType_GenericNew.
PyType_IsSubtype | Represents field PyType_IsSubtype.
PyType_Ready | Represents field PyType_Ready.
PyType_Type | Represents field PyType_Type.
PyUnicode_AsEncodedString | Represents field PyUnicode_AsEncodedString.
PyUnicode_AsWideChar | Represents field PyUnicode_AsWideChar.
PyUnicode_Decode | Represents field PyUnicode_Decode.
PyUnicode_FromOrdinal | Represents field PyUnicode_FromOrdinal.
PyUnicode_FromWideChar | Represents field PyUnicode_FromWideChar.
PyUnicode_Type | Represents field PyUnicode_Type.
PyWeakref_GetObject | Represents field PyWeakref_GetObject.
PyWeakref_NewProxy | Represents field PyWeakref_NewProxy.
PyWeakref_NewRef | Represents field PyWeakref_NewRef.
PyWrapperDescr_Type | Represents field PyWrapperDescr_Type.
PyWrapper_New | Represents field PyWrapper_New.
Py_AtExit | Represents field Py_AtExit.
Py_BuildValue | Represents field Py_BuildValue.
Py_CompileString | Represents field Py_CompileString.
Py_DebugFlag | Represents field Py_DebugFlag.
Py_DivisionWarningFlag | Represents field Py_DivisionWarningFlag.
Py_Ellipsis | Represents field Py_Ellipsis.
Py_EndInterpreter | Represents field Py_EndInterpreter.
Py_Exit | Represents field Py_Exit.
Py_False | Represents field Py_False.
Py_FatalError | Represents field Py_FatalError.
Py_Finalize | Represents field Py_Finalize.
Py_FindMethod | Represents field Py_FindMethod.
Py_FindMethodInChain | Represents field Py_FindMethodInChain.
Py_FrozenFlag | Represents field Py_FrozenFlag.
Py_GetCopyright | Represents field Py_GetCopyright.
Py_GetExecPrefix | Represents field Py_GetExecPrefix.
Py_GetPath | Represents field Py_GetPath.
Py_GetPrefix | Represents field Py_GetPrefix.
Py_GetProgramFullPath | Represents field Py_GetProgramFullPath.
Py_GetProgramName | Represents field Py_GetProgramName.
Py_GetVersion | Represents field Py_GetVersion.
Py_IgnoreEnvironmentFlag | Represents field Py_IgnoreEnvironmentFlag.
Py_Initialize | Represents field Py_Initialize.
Py_InitModule4 | Represents field Py_InitModule4.
Py_InteractiveFlag | Represents field Py_InteractiveFlag.
Py_IsInitialized | Represents field Py_IsInitialized.
Py_Malloc | Represents field Py_Malloc.
Py_NewInterpreter | Represents field Py_NewInterpreter.
Py_None | Represents field Py_None.
Py_NoSiteFlag | Represents field Py_NoSiteFlag.
Py_NotImplemented | Represents field Py_NotImplemented.
Py_OptimizeFlag | Represents field Py_OptimizeFlag.
Py_SetProgramName | Represents field Py_SetProgramName.
Py_SetProgramName3000 | Represents field Py_SetProgramName3000.
Py_TabcheckFlag | Represents field Py_TabcheckFlag.
Py_True | Represents field Py_True.
Py_UnicodeFlag | Represents field Py_UnicodeFlag.
Py_UseClassExceptionsFlag | Represents field Py_UseClassExceptionsFlag.
Py_VerboseFlag | Represents field Py_VerboseFlag.
_PyObject_New | Represents field _PyObject_New.
_PyString_Resize | Represents field _PyString_Resize.
_PyWeakref_CallableProxyType | Represents field _PyWeakref_CallableProxyType.
_PyWeakref_ProxyType | Represents field _PyWeakref_ProxyType.
_PyWeakref_RefType | Represents field _PyWeakref_RefType.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TPythonInterface Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TPythonInterface class. (Overrides TDynamicDll.Create(TComponent).)
Top


TPythonInterface.Create(TComponent) Constructor

Summary

Initializes a new instance of the TPythonInterface class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 constructor Create(AOwner: TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TDynamicDll.Create(TComponent)
See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface Properties

Properties
Name | Description
BuiltInModuleName | Represents property BuiltInModuleName.
Finalizing | Represents property Finalizing.
Initialized | Represents property Initialized.
IsPython3000 | Represents property IsPython3000.
MajorVersion | Represents property MajorVersion.
MinorVersion | Represents property MinorVersion.
Top


TPythonInterface.BuiltInModuleName Property

Summary

Represents property BuiltInModuleName.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property BuiltInModuleName: String read FBuiltInModuleName write FBuiltInModuleName;

Property Value

Type: String

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Finalizing Property

Summary

Represents property Finalizing.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property Finalizing : Boolean read FFinalizing;

Property Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Initialized Property

Summary

Represents property Initialized.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property Initialized : Boolean read GetInitialized;

Property Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.IsPython3000 Property

Summary

Represents property IsPython3000.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property IsPython3000 : Boolean read FIsPython3000;

Property Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.MajorVersion Property

Summary

Represents property MajorVersion.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property MajorVersion : integer read FMajorVersion;

Property Value

Type: integer

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.MinorVersion Property

Summary

Represents property MinorVersion.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property MinorVersion : integer read FMinorVersion;

Property Value

Type: integer

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface Methods

Methods
Name | Description
AfterLoad | Represents method AfterLoad. (Overrides TDynamicDll.AfterLoad.)
CheckPython | Represents method CheckPython.
GetQuitMessage | Represents method GetQuitMessage. (Overrides TDynamicDll.GetQuitMessage.)
GetUnicodeTypeSuffix | Represents method GetUnicodeTypeSuffix.
MapDll | Represents method MapDll.
PyBaseString_Check(PPyObject) | Represents method PyBaseString_Check(PPyObject).
PyBool_Check(PPyObject) | Represents method PyBool_Check(PPyObject).
PyClass_Check(PPyObject) | Represents method PyClass_Check(PPyObject).
PyCode_Addr2Line(PPyCodeObject,Integer) | Represents method PyCode_Addr2Line(PPyCodeObject,Integer).
PyDict_Check(PPyObject) | Represents method PyDict_Check(PPyObject).
PyDict_CheckExact(PPyObject) | Represents method PyDict_CheckExact(PPyObject).
PyEnum_Check(PPyObject) | Represents method PyEnum_Check(PPyObject).
PyFloat_Check(PPyObject) | Represents method PyFloat_Check(PPyObject).
PyFloat_CheckExact(PPyObject) | Represents method PyFloat_CheckExact(PPyObject).
PyFunction_Check(PPyObject) | Represents method PyFunction_Check(PPyObject).
PyImport_ExecCodeModule(AnsiString,PPyObject) | Represents method PyImport_ExecCodeModule(AnsiString,PPyObject).
PyInstance_Check(PPyObject) | Represents method PyInstance_Check(PPyObject).
PyInt_Check(PPyObject) | Represents method PyInt_Check(PPyObject).
PyInt_CheckExact(PPyObject) | Represents method PyInt_CheckExact(PPyObject).
PyIter_Check(PPyObject) | Represents method PyIter_Check(PPyObject).
PyList_Check(PPyObject) | Represents method PyList_Check(PPyObject).
PyList_CheckExact(PPyObject) | Represents method PyList_CheckExact(PPyObject).
PyLong_Check(PPyObject) | Represents method PyLong_Check(PPyObject).
PyLong_CheckExact(PPyObject) | Represents method PyLong_CheckExact(PPyObject).
PyMethod_Check(PPyObject) | Represents method PyMethod_Check(PPyObject).
PyModule_Check(PPyObject) | Represents method PyModule_Check(PPyObject).
PyModule_CheckExact(PPyObject) | Represents method PyModule_CheckExact(PPyObject).
PyObject_IS_GC(PPyObject) | Represents method PyObject_IS_GC(PPyObject).
PyObject_TypeCheck(PPyObject,PPyTypeObject) | Represents method PyObject_TypeCheck(PPyObject,PPyTypeObject).
PySlice_Check(PPyObject) | Represents method PySlice_Check(PPyObject).
PyString_AsDelphiString(PPyObject) | Represents method PyString_AsDelphiString(PPyObject).
PyString_Check(PPyObject) | Represents method PyString_Check(PPyObject).
PyString_CheckExact(PPyObject) | Represents method PyString_CheckExact(PPyObject).
PyString_FromString(PAnsiChar) | Represents method PyString_FromString(PAnsiChar).
PyTuple_Check(PPyObject) | Represents method PyTuple_Check(PPyObject).
PyTuple_CheckExact(PPyObject) | Represents method PyTuple_CheckExact(PPyObject).
PyType_CheckExact(PPyObject) | Represents method PyType_CheckExact(PPyObject).
PyType_IS_GC(PPyTypeObject) | Represents method PyType_IS_GC(PPyTypeObject).
PyUnicode_Check(PPyObject) | Represents method PyUnicode_Check(PPyObject).
PyUnicode_CheckExact(PPyObject) | Represents method PyUnicode_CheckExact(PPyObject).
PyWeakref_Check(PPyObject) | Represents method PyWeakref_Check(PPyObject).
PyWeakref_CheckProxy(PPyObject) | Represents method PyWeakref_CheckProxy(PPyObject).
PyWeakref_CheckRef(PPyObject) | Represents method PyWeakref_CheckRef(PPyObject).
Py_DECREF(PPyObject) | Represents method Py_DECREF(PPyObject).
Py_FlushLine | Represents method Py_FlushLine.
Py_GetBuildInfo | Represents method Py_GetBuildInfo.
Py_GetPlatform | Represents method Py_GetPlatform.
Py_INCREF(PPyObject) | Represents method Py_INCREF(PPyObject).
Py_InitModule(PAnsiChar,PPyMethodDef) | Represents method Py_InitModule(PAnsiChar,PPyMethodDef).
Py_InitModule3000(PyModuleDef) | Represents method Py_InitModule3000(PyModuleDef).
Py_XDECREF(PPyObject) | Represents method Py_XDECREF(PPyObject).
Py_XINCREF(PPyObject) | Represents method Py_XINCREF(PPyObject).
Top


TPythonInterface.AfterLoad Method

Summary

Represents method AfterLoad.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure AfterLoad; override;

Overrides

TDynamicDll.AfterLoad
See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.CheckPython Method

Summary

Represents method CheckPython.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure CheckPython;
See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.GetQuitMessage Method

Summary

Represents method GetQuitMessage.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 function GetQuitMessage : String; override;

Return Value

Type: String

Overrides

TDynamicDll.GetQuitMessage
See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.GetUnicodeTypeSuffix Method

Summary

Represents method GetUnicodeTypeSuffix.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 function GetUnicodeTypeSuffix : String;

Return Value

Type: String

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.MapDll Method

Summary

Represents method MapDll.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure MapDll;
See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyBaseString_Check(PPyObject) Method

Summary

Represents method PyBaseString_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyBaseString_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyBool_Check(PPyObject) Method

Summary

Represents method PyBool_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyBool_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyClass_Check(PPyObject) Method

Summary

Represents method PyClass_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyClass_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyCode_Addr2Line(PPyCodeObject,Integer) Method

Summary

Represents method PyCode_Addr2Line(PPyCodeObject,Integer).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyCode_Addr2Line( co: PPyCodeObject; addrq : Integer ) : Integer; cdecl;

Parameters

co
Type: PPyCodeObject

addrq
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyDict_Check(PPyObject) Method

Summary

Represents method PyDict_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyDict_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyDict_CheckExact(PPyObject) Method

Summary

Represents method PyDict_CheckExact(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyDict_CheckExact( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyEnum_Check(PPyObject) Method

Summary

Represents method PyEnum_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyEnum_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyFloat_Check(PPyObject) Method

Summary

Represents method PyFloat_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyFloat_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyFloat_CheckExact(PPyObject) Method

Summary

Represents method PyFloat_CheckExact(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyFloat_CheckExact( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyFunction_Check(PPyObject) Method

Summary

Represents method PyFunction_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyFunction_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyImport_ExecCodeModule(AnsiString,PPyObject) Method

Summary

Represents method PyImport_ExecCodeModule(AnsiString,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyImport_ExecCodeModule( const AName : AnsiString; codeobject : PPyObject) : PPyObject;

Parameters

AName
Type: AnsiString

codeobject
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyInstance_Check(PPyObject) Method

Summary

Represents method PyInstance_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyInstance_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyInt_Check(PPyObject) Method

Summary

Represents method PyInt_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyInt_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyInt_CheckExact(PPyObject) Method

Summary

Represents method PyInt_CheckExact(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyInt_CheckExact( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyIter_Check(PPyObject) Method

Summary

Represents method PyIter_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyIter_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyList_Check(PPyObject) Method

Summary

Represents method PyList_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyList_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyList_CheckExact(PPyObject) Method

Summary

Represents method PyList_CheckExact(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyList_CheckExact( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyLong_Check(PPyObject) Method

Summary

Represents method PyLong_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyLong_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyLong_CheckExact(PPyObject) Method

Summary

Represents method PyLong_CheckExact(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyLong_CheckExact( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyMethod_Check(PPyObject) Method

Summary

Represents method PyMethod_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyMethod_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyModule_Check(PPyObject) Method

Summary

Represents method PyModule_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyModule_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyModule_CheckExact(PPyObject) Method

Summary

Represents method PyModule_CheckExact(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyModule_CheckExact( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_IS_GC(PPyObject) Method

Summary

Represents method PyObject_IS_GC(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyObject_IS_GC( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_TypeCheck(PPyObject,PPyTypeObject) Method

Summary

Represents method PyObject_TypeCheck(PPyObject,PPyTypeObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyObject_TypeCheck(obj:PPyObject; t:PPyTypeObject) : Boolean;

Parameters

obj
Type: PPyObject

t
Type: PPyTypeObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySlice_Check(PPyObject) Method

Summary

Represents method PySlice_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PySlice_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyString_AsDelphiString(PPyObject) Method

Summary

Represents method PyString_AsDelphiString(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyString_AsDelphiString( ob: PPyObject): string; virtual; abstract;

Parameters

ob
Type: PPyObject

Return Value

Type: string

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyString_Check(PPyObject) Method

Summary

Represents method PyString_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyString_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyString_CheckExact(PPyObject) Method

Summary

Represents method PyString_CheckExact(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyString_CheckExact( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyString_FromString(PAnsiChar) Method

Summary

Represents method PyString_FromString(PAnsiChar).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyString_FromString( str: PAnsiChar): PPyObject; virtual; abstract;

Parameters

str
Type: PAnsiChar

Return Value

Type: PPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyTuple_Check(PPyObject) Method

Summary

Represents method PyTuple_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyTuple_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyTuple_CheckExact(PPyObject) Method

Summary

Represents method PyTuple_CheckExact(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyTuple_CheckExact( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyType_CheckExact(PPyObject) Method

Summary

Represents method PyType_CheckExact(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyType_CheckExact( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyType_IS_GC(PPyTypeObject) Method

Summary

Represents method PyType_IS_GC(PPyTypeObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyType_IS_GC(t : PPyTypeObject ) : Boolean;

Parameters

t
Type: PPyTypeObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyUnicode_Check(PPyObject) Method

Summary

Represents method PyUnicode_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyUnicode_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyUnicode_CheckExact(PPyObject) Method

Summary

Represents method PyUnicode_CheckExact(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyUnicode_CheckExact( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyWeakref_Check(PPyObject) Method

Summary

Represents method PyWeakref_Check(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyWeakref_Check( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyWeakref_CheckProxy(PPyObject) Method

Summary

Represents method PyWeakref_CheckProxy(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyWeakref_CheckProxy( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyWeakref_CheckRef(PPyObject) Method

Summary

Represents method PyWeakref_CheckRef(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function PyWeakref_CheckRef( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_DECREF(PPyObject) Method

Summary

Represents method Py_DECREF(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Py_DECREF ( op: PPyObject);

Parameters

op
Type: PPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_FlushLine Method

Summary

Represents method Py_FlushLine.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Py_FlushLine; cdecl;
See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_GetBuildInfo Method

Summary

Represents method Py_GetBuildInfo.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Py_GetBuildInfo: PAnsiChar; cdecl;

Return Value

Type: PAnsiChar

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_GetPlatform Method

Summary

Represents method Py_GetPlatform.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Py_GetPlatform: PAnsiChar; cdecl;

Return Value

Type: PAnsiChar

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_INCREF(PPyObject) Method

Summary

Represents method Py_INCREF(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Py_INCREF ( op: PPyObject);

Parameters

op
Type: PPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_InitModule(PAnsiChar,PPyMethodDef) Method

Summary

Represents method Py_InitModule(PAnsiChar,PPyMethodDef).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Py_InitModule( const AName : PAnsiChar; md : PPyMethodDef) : PPyObject;

Parameters

AName
Type: PAnsiChar

md
Type: PPyMethodDef

Return Value

Type: PPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_InitModule3000(PyModuleDef) Method

Summary

Represents method Py_InitModule3000(PyModuleDef).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Py_InitModule3000( const md : PyModuleDef) : PPyObject;

Parameters

md
Type: PyModuleDef

Return Value

Type: PPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_XDECREF(PPyObject) Method

Summary

Represents method Py_XDECREF(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Py_XDECREF ( op: PPyObject);

Parameters

op
Type: PPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_XINCREF(PPyObject) Method

Summary

Represents method Py_XINCREF(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Py_XINCREF ( op: PPyObject);

Parameters

op
Type: PPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface Fields

Fields
Name | Description
FBuiltInModuleName | Represents field FBuiltInModuleName.
FFinalizing | Represents field FFinalizing.
FInitialized | Represents field FInitialized.
FIsPython3000 | Represents field FIsPython3000.
FMajorVersion | Represents field FMajorVersion.
FMinorVersion | Represents field FMinorVersion.
PyArg_Parse | Represents field PyArg_Parse.
PyArg_ParseTuple | Represents field PyArg_ParseTuple.
PyBaseObject_Type | Represents field PyBaseObject_Type.
PyBaseString_Type | Represents field PyBaseString_Type.
PyBool_FromLong | Represents field PyBool_FromLong.
PyBool_Type | Represents field PyBool_Type.
PyBuffer_Type | Represents field PyBuffer_Type.
PyCallable_Check | Represents field PyCallable_Check.
PyCallIter_Type | Represents field PyCallIter_Type.
PyCell_Type | Represents field PyCell_Type.
PyCFunction_GetFunction | Represents field PyCFunction_GetFunction.
PyCFunction_GetSelf | Represents field PyCFunction_GetSelf.
PyCFunction_New | Represents field PyCFunction_New.
PyCFunction_NewEx | Represents field PyCFunction_NewEx.
PyCFunction_Type | Represents field PyCFunction_Type.
PyClassMethod_Type | Represents field PyClassMethod_Type.
PyClass_IsSubclass | Represents field PyClass_IsSubclass.
PyClass_New | Represents field PyClass_New.
PyClass_Type | Represents field PyClass_Type.
PyCObject_AsVoidPtr | Represents field PyCObject_AsVoidPtr.
PyCObject_FromVoidPtr | Represents field PyCObject_FromVoidPtr.
PyCObject_Type | Represents field PyCObject_Type.
PyCode_Type | Represents field PyCode_Type.
PyComplex_AsCComplex | Represents field PyComplex_AsCComplex.
PyComplex_FromCComplex | Represents field PyComplex_FromCComplex.
PyComplex_FromDoubles | Represents field PyComplex_FromDoubles.
PyComplex_ImagAsDouble | Represents field PyComplex_ImagAsDouble.
PyComplex_RealAsDouble | Represents field PyComplex_RealAsDouble.
PyComplex_Type | Represents field PyComplex_Type.
PyDictProxy_New | Represents field PyDictProxy_New.
PyDict_Clear | Represents field PyDict_Clear.
PyDict_Copy | Represents field PyDict_Copy.
PyDict_DelItem | Represents field PyDict_DelItem.
PyDict_DelItemString | Represents field PyDict_DelItemString.
PyDict_GetItem | Represents field PyDict_GetItem.
PyDict_GetItemString | Represents field PyDict_GetItemString.
PyDict_Items | Represents field PyDict_Items.
PyDict_Keys | Represents field PyDict_Keys.
PyDict_New | Represents field PyDict_New.
PyDict_Next | Represents field PyDict_Next.
PyDict_SetItem | Represents field PyDict_SetItem.
PyDict_SetItemString | Represents field PyDict_SetItemString.
PyDict_Size | Represents field PyDict_Size.
PyDict_Type | Represents field PyDict_Type.
PyDict_Values | Represents field PyDict_Values.
PyEnum_Type | Represents field PyEnum_Type.
PyErr_BadArgument | Represents field PyErr_BadArgument.
PyErr_BadInternalCall | Represents field PyErr_BadInternalCall.
PyErr_CheckSignals | Represents field PyErr_CheckSignals.
PyErr_Clear | Represents field PyErr_Clear.
PyErr_ExceptionMatches | Represents field PyErr_ExceptionMatches.
PyErr_Fetch | Represents field PyErr_Fetch.
PyErr_GivenExceptionMatches | Represents field PyErr_GivenExceptionMatches.
PyErr_NewException | Represents field PyErr_NewException.
PyErr_NoMemory | Represents field PyErr_NoMemory.
PyErr_Occurred | Represents field PyErr_Occurred.
PyErr_Print | Represents field PyErr_Print.
PyErr_Restore | Represents field PyErr_Restore.
PyErr_SetFromErrno | Represents field PyErr_SetFromErrno.
PyErr_SetInterrupt | Represents field PyErr_SetInterrupt.
PyErr_SetNone | Represents field PyErr_SetNone.
PyErr_SetObject | Represents field PyErr_SetObject.
PyErr_SetString | Represents field PyErr_SetString.
PyEval_AcquireLock | Represents field PyEval_AcquireLock.
PyEval_AcquireThread | Represents field PyEval_AcquireThread.
PyEval_CallObjectWithKeywords | Represents field PyEval_CallObjectWithKeywords.
PyEval_EvalCode | Represents field PyEval_EvalCode.
PyEval_GetBuiltins | Represents field PyEval_GetBuiltins.
PyEval_GetFrame | Represents field PyEval_GetFrame.
PyEval_GetGlobals | Represents field PyEval_GetGlobals.
PyEval_GetLocals | Represents field PyEval_GetLocals.
PyEval_GetRestricted | Represents field PyEval_GetRestricted.
PyEval_InitThreads | Represents field PyEval_InitThreads.
PyEval_ReleaseLock | Represents field PyEval_ReleaseLock.
PyEval_ReleaseThread | Represents field PyEval_ReleaseThread.
PyEval_RestoreThread | Represents field PyEval_RestoreThread.
PyEval_SaveThread | Represents field PyEval_SaveThread.
PyExc_ArithmeticError | Represents field PyExc_ArithmeticError.
PyExc_AssertionError | Represents field PyExc_AssertionError.
PyExc_AttributeError | Represents field PyExc_AttributeError.
PyExc_DeprecationWarning | Represents field PyExc_DeprecationWarning.
PyExc_EnvironmentError | Represents field PyExc_EnvironmentError.
PyExc_EOFError | Represents field PyExc_EOFError.
PyExc_Exception | Represents field PyExc_Exception.
PyExc_FloatingPointError | Represents field PyExc_FloatingPointError.
PyExc_FutureWarning | Represents field PyExc_FutureWarning.
PyExc_ImportError | Represents field PyExc_ImportError.
PyExc_IndentationError | Represents field PyExc_IndentationError.
PyExc_IndexError | Represents field PyExc_IndexError.
PyExc_IOError | Represents field PyExc_IOError.
PyExc_KeyboardInterrupt | Represents field PyExc_KeyboardInterrupt.
PyExc_KeyError | Represents field PyExc_KeyError.
PyExc_LookupError | Represents field PyExc_LookupError.
PyExc_MemoryError | Represents field PyExc_MemoryError.
PyExc_MemoryErrorInst | Represents field PyExc_MemoryErrorInst.
PyExc_NameError | Represents field PyExc_NameError.
PyExc_NotImplementedError | Represents field PyExc_NotImplementedError.
PyExc_OSError | Represents field PyExc_OSError.
PyExc_OverflowError | Represents field PyExc_OverflowError.
PyExc_PendingDeprecationWarning | Represents field PyExc_PendingDeprecationWarning.
PyExc_ReferenceError | Represents field PyExc_ReferenceError.
PyExc_RuntimeError | Represents field PyExc_RuntimeError.
PyExc_RuntimeWarning | Represents field PyExc_RuntimeWarning.
PyExc_StandardError | Represents field PyExc_StandardError.
PyExc_StopIteration | Represents field PyExc_StopIteration.
PyExc_SyntaxError | Represents field PyExc_SyntaxError.
PyExc_SyntaxWarning | Represents field PyExc_SyntaxWarning.
PyExc_SystemError | Represents field PyExc_SystemError.
PyExc_SystemExit | Represents field PyExc_SystemExit.
PyExc_TabError | Represents field PyExc_TabError.
PyExc_TypeError | Represents field PyExc_TypeError.
PyExc_UnboundLocalError | Represents field PyExc_UnboundLocalError.
PyExc_UnicodeDecodeError | Represents field PyExc_UnicodeDecodeError.
PyExc_UnicodeEncodeError | Represents field PyExc_UnicodeEncodeError.
PyExc_UnicodeError | Represents field PyExc_UnicodeError.
PyExc_UnicodeTranslateError | Represents field PyExc_UnicodeTranslateError.
PyExc_UserWarning | Represents field PyExc_UserWarning.
PyExc_ValueError | Represents field PyExc_ValueError.
PyExc_Warning | Represents field PyExc_Warning.
PyExc_WindowsError | Represents field PyExc_WindowsError.
PyExc_ZeroDivisionError | Represents field PyExc_ZeroDivisionError.
PyFile_FromString | Represents field PyFile_FromString.
PyFile_GetLine | Represents field PyFile_GetLine.
PyFile_Name | Represents field PyFile_Name.
PyFile_SetBufSize | Represents field PyFile_SetBufSize.
PyFile_SoftSpace | Represents field PyFile_SoftSpace.
PyFile_Type | Represents field PyFile_Type.
PyFile_WriteObject | Represents field PyFile_WriteObject.
PyFile_WriteString | Represents field PyFile_WriteString.
PyFloat_AsDouble | Represents field PyFloat_AsDouble.
PyFloat_FromDouble | Represents field PyFloat_FromDouble.
PyFloat_Type | Represents field PyFloat_Type.
PyFrame_Type | Represents field PyFrame_Type.
PyFunction_GetCode | Represents field PyFunction_GetCode.
PyFunction_GetGlobals | Represents field PyFunction_GetGlobals.
PyFunction_New | Represents field PyFunction_New.
PyFunction_Type | Represents field PyFunction_Type.
PyGILState_Ensure | Represents field PyGILState_Ensure.
PyGILState_Release | Represents field PyGILState_Release.
PyImport_AddModule | Represents field PyImport_AddModule.
PyImport_Cleanup | Represents field PyImport_Cleanup.
PyImport_FrozenModules | Represents field PyImport_FrozenModules.
PyImport_GetMagicNumber | Represents field PyImport_GetMagicNumber.
PyImport_GetModuleDict | Represents field PyImport_GetModuleDict.
PyImport_Import | Represents field PyImport_Import.
PyImport_ImportFrozenModule | Represents field PyImport_ImportFrozenModule.
PyImport_ImportModule | Represents field PyImport_ImportModule.
PyImport_ReloadModule | Represents field PyImport_ReloadModule.
PyInstance_New | Represents field PyInstance_New.
PyInstance_Type | Represents field PyInstance_Type.
PyInterpreterState_Clear | Represents field PyInterpreterState_Clear.
PyInterpreterState_Delete | Represents field PyInterpreterState_Delete.
PyInterpreterState_New | Represents field PyInterpreterState_New.
PyInt_AsLong | Represents field PyInt_AsLong.
PyInt_FromLong | Represents field PyInt_FromLong.
PyInt_Type | Represents field PyInt_Type.
PyIter_Next | Represents field PyIter_Next.
PyList_Append | Represents field PyList_Append.
PyList_AsTuple | Represents field PyList_AsTuple.
PyList_GetItem | Represents field PyList_GetItem.
PyList_GetSlice | Represents field PyList_GetSlice.
PyList_Insert | Represents field PyList_Insert.
PyList_New | Represents field PyList_New.
PyList_Reverse | Represents field PyList_Reverse.
PyList_SetItem | Represents field PyList_SetItem.
PyList_SetSlice | Represents field PyList_SetSlice.
PyList_Size | Represents field PyList_Size.
PyList_Sort | Represents field PyList_Sort.
PyList_Type | Represents field PyList_Type.
PyLong_AsDouble | Represents field PyLong_AsDouble.
PyLong_AsLong | Represents field PyLong_AsLong.
PyLong_AsLongLong | Represents field PyLong_AsLongLong.
PyLong_AsUnsignedLong | Represents field PyLong_AsUnsignedLong.
PyLong_FromDouble | Represents field PyLong_FromDouble.
PyLong_FromLong | Represents field PyLong_FromLong.
PyLong_FromLongLong | Represents field PyLong_FromLongLong.
PyLong_FromString | Represents field PyLong_FromString.
PyLong_FromUnicode | Represents field PyLong_FromUnicode.
PyLong_FromUnsignedLong | Represents field PyLong_FromUnsignedLong.
PyLong_Type | Represents field PyLong_Type.
PyMapping_Check | Represents field PyMapping_Check.
PyMapping_GetItemString | Represents field PyMapping_GetItemString.
PyMapping_HasKey | Represents field PyMapping_HasKey.
PyMapping_HasKeyString | Represents field PyMapping_HasKeyString.
PyMapping_Length | Represents field PyMapping_Length.
PyMapping_SetItemString | Represents field PyMapping_SetItemString.
PyMem_Malloc | Represents field PyMem_Malloc.
PyMethod_Class | Represents field PyMethod_Class.
PyMethod_Function | Represents field PyMethod_Function.
PyMethod_New | Represents field PyMethod_New.
PyMethod_Self | Represents field PyMethod_Self.
PyMethod_Type | Represents field PyMethod_Type.
PyModule_Create2 | Represents field PyModule_Create2.
PyModule_GetDict | Represents field PyModule_GetDict.
PyModule_GetName | Represents field PyModule_GetName.
PyModule_New | Represents field PyModule_New.
PyModule_Type | Represents field PyModule_Type.
PyNode_Free | Represents field PyNode_Free.
PyNumber_Absolute | Represents field PyNumber_Absolute.
PyNumber_Add | Represents field PyNumber_Add.
PyNumber_And | Represents field PyNumber_And.
PyNumber_Check | Represents field PyNumber_Check.
PyNumber_Coerce | Represents field PyNumber_Coerce.
PyNumber_Divide | Represents field PyNumber_Divide.
PyNumber_Divmod | Represents field PyNumber_Divmod.
PyNumber_Float | Represents field PyNumber_Float.
PyNumber_FloorDivide | Represents field PyNumber_FloorDivide.
PyNumber_Int | Represents field PyNumber_Int.
PyNumber_Invert | Represents field PyNumber_Invert.
PyNumber_Long | Represents field PyNumber_Long.
PyNumber_Lshift | Represents field PyNumber_Lshift.
PyNumber_Multiply | Represents field PyNumber_Multiply.
PyNumber_Negative | Represents field PyNumber_Negative.
PyNumber_Or | Represents field PyNumber_Or.
PyNumber_Positive | Represents field PyNumber_Positive.
PyNumber_Power | Represents field PyNumber_Power.
PyNumber_Remainder | Represents field PyNumber_Remainder.
PyNumber_Rshift | Represents field PyNumber_Rshift.
PyNumber_Subtract | Represents field PyNumber_Subtract.
PyNumber_TrueDivide | Represents field PyNumber_TrueDivide.
PyNumber_Xor | Represents field PyNumber_Xor.
PyObject_Call | Represents field PyObject_Call.
PyObject_CallMethod | Represents field PyObject_CallMethod.
PyObject_CallMethodStr | Represents field PyObject_CallMethodStr.
PyObject_CallObject | Represents field PyObject_CallObject.
PyObject_Compare | Represents field PyObject_Compare.
PyObject_DelItem | Represents field PyObject_DelItem.
PyObject_Free | Represents field PyObject_Free.
PyObject_GC_Del | Represents field PyObject_GC_Del.
PyObject_GC_Malloc | Represents field PyObject_GC_Malloc.
PyObject_GC_New | Represents field PyObject_GC_New.
PyObject_GC_NewVar | Represents field PyObject_GC_NewVar.
PyObject_GC_Resize | Represents field PyObject_GC_Resize.
PyObject_GC_Track | Represents field PyObject_GC_Track.
PyObject_GC_UnTrack | Represents field PyObject_GC_UnTrack.
PyObject_GenericGetAttr | Represents field PyObject_GenericGetAttr.
PyObject_GenericSetAttr | Represents field PyObject_GenericSetAttr.
PyObject_GetAttr | Represents field PyObject_GetAttr.
PyObject_GetAttrString | Represents field PyObject_GetAttrString.
PyObject_GetItem | Represents field PyObject_GetItem.
PyObject_GetIter | Represents field PyObject_GetIter.
PyObject_HasAttrString | Represents field PyObject_HasAttrString.
PyObject_Hash | Represents field PyObject_Hash.
PyObject_Init | Represents field PyObject_Init.
PyObject_InitVar | Represents field PyObject_InitVar.
PyObject_IsInstance | Represents field PyObject_IsInstance.
PyObject_IsSubclass | Represents field PyObject_IsSubclass.
PyObject_IsTrue | Represents field PyObject_IsTrue.
PyObject_Length | Represents field PyObject_Length.
PyObject_New | Represents field PyObject_New.
PyObject_NewVar | Represents field PyObject_NewVar.
PyObject_Repr | Represents field PyObject_Repr.
PyObject_RichCompare | Represents field PyObject_RichCompare.
PyObject_RichCompareBool | Represents field PyObject_RichCompareBool.
PyObject_SetAttr | Represents field PyObject_SetAttr.
PyObject_SetAttrString | Represents field PyObject_SetAttrString.
PyObject_SetItem | Represents field PyObject_SetItem.
PyObject_Str | Represents field PyObject_Str.
PyObject_Type | Represents field PyObject_Type.
PyOS_InitInterrupts | Represents field PyOS_InitInterrupts.
PyOS_InterruptOccurred | Represents field PyOS_InterruptOccurred.
PyParser_SimpleParseString | Represents field PyParser_SimpleParseString.
PyProperty_Type | Represents field PyProperty_Type.
PyRange_Type | Represents field PyRange_Type.
PyRun_SimpleString | Represents field PyRun_SimpleString.
PyRun_String | Represents field PyRun_String.
PySeqIter_New | Represents field PySeqIter_New.
PySeqIter_Type | Represents field PySeqIter_Type.
PySequence_Check | Represents field PySequence_Check.
PySequence_Concat | Represents field PySequence_Concat.
PySequence_Contains | Represents field PySequence_Contains.
PySequence_Count | Represents field PySequence_Count.
PySequence_DelSlice | Represents field PySequence_DelSlice.
PySequence_GetItem | Represents field PySequence_GetItem.
PySequence_GetSlice | Represents field PySequence_GetSlice.
PySequence_In | Represents field PySequence_In.
PySequence_Index | Represents field PySequence_Index.
PySequence_Length | Represents field PySequence_Length.
PySequence_Repeat | Represents field PySequence_Repeat.
PySequence_SetItem | Represents field PySequence_SetItem.
PySequence_SetSlice | Represents field PySequence_SetSlice.
PySequence_Tuple | Represents field PySequence_Tuple.
PySlice_GetIndices | Represents field PySlice_GetIndices.
PySlice_GetIndicesEx | Represents field PySlice_GetIndicesEx.
PySlice_New | Represents field PySlice_New.
PySlice_Type | Represents field PySlice_Type.
PyStaticMethod_Type | Represents field PyStaticMethod_Type.
PyString_AsString | Represents field PyString_AsString.
PyString_Concat | Represents field PyString_Concat.
PyString_ConcatAndDel | Represents field PyString_ConcatAndDel.
PyString_DecodeEscape | Represents field PyString_DecodeEscape.
PyString_Format | Represents field PyString_Format.
PyString_FromStringAndSize | Represents field PyString_FromStringAndSize.
PyString_Repr | Represents field PyString_Repr.
PyString_Size | Represents field PyString_Size.
PyString_Type | Represents field PyString_Type.
PySuper_Type | Represents field PySuper_Type.
PySys_GetObject | Represents field PySys_GetObject.
PySys_SetArgv | Represents field PySys_SetArgv.
PySys_SetArgv3000 | Represents field PySys_SetArgv3000.
PySys_SetObject | Represents field PySys_SetObject.
PySys_SetPath | Represents field PySys_SetPath.
PyThreadState_Clear | Represents field PyThreadState_Clear.
PyThreadState_Delete | Represents field PyThreadState_Delete.
PyThreadState_Get | Represents field PyThreadState_Get.
PyThreadState_New | Represents field PyThreadState_New.
PyThreadState_SetAsyncExc | Represents field PyThreadState_SetAsyncExc.
PyThreadState_Swap | Represents field PyThreadState_Swap.
PyTraceBack_Here | Represents field PyTraceBack_Here.
PyTraceBack_Print | Represents field PyTraceBack_Print.
PyTraceBack_Type | Represents field PyTraceBack_Type.
PyTuple_GetItem | Represents field PyTuple_GetItem.
PyTuple_GetSlice | Represents field PyTuple_GetSlice.
PyTuple_New | Represents field PyTuple_New.
PyTuple_SetItem | Represents field PyTuple_SetItem.
PyTuple_Size | Represents field PyTuple_Size.
PyTuple_Type | Represents field PyTuple_Type.
PyType_GenericAlloc | Represents field PyType_GenericAlloc.
PyType_GenericNew | Represents field PyType_GenericNew.
PyType_IsSubtype | Represents field PyType_IsSubtype.
PyType_Ready | Represents field PyType_Ready.
PyType_Type | Represents field PyType_Type.
PyUnicode_AsEncodedString | Represents field PyUnicode_AsEncodedString.
PyUnicode_AsWideChar | Represents field PyUnicode_AsWideChar.
PyUnicode_Decode | Represents field PyUnicode_Decode.
PyUnicode_FromOrdinal | Represents field PyUnicode_FromOrdinal.
PyUnicode_FromWideChar | Represents field PyUnicode_FromWideChar.
PyUnicode_Type | Represents field PyUnicode_Type.
PyWeakref_GetObject | Represents field PyWeakref_GetObject.
PyWeakref_NewProxy | Represents field PyWeakref_NewProxy.
PyWeakref_NewRef | Represents field PyWeakref_NewRef.
PyWrapperDescr_Type | Represents field PyWrapperDescr_Type.
PyWrapper_New | Represents field PyWrapper_New.
Py_AtExit | Represents field Py_AtExit.
Py_BuildValue | Represents field Py_BuildValue.
Py_CompileString | Represents field Py_CompileString.
Py_DebugFlag | Represents field Py_DebugFlag.
Py_DivisionWarningFlag | Represents field Py_DivisionWarningFlag.
Py_Ellipsis | Represents field Py_Ellipsis.
Py_EndInterpreter | Represents field Py_EndInterpreter.
Py_Exit | Represents field Py_Exit.
Py_False | Represents field Py_False.
Py_FatalError | Represents field Py_FatalError.
Py_Finalize | Represents field Py_Finalize.
Py_FindMethod | Represents field Py_FindMethod.
Py_FindMethodInChain | Represents field Py_FindMethodInChain.
Py_FrozenFlag | Represents field Py_FrozenFlag.
Py_GetCopyright | Represents field Py_GetCopyright.
Py_GetExecPrefix | Represents field Py_GetExecPrefix.
Py_GetPath | Represents field Py_GetPath.
Py_GetPrefix | Represents field Py_GetPrefix.
Py_GetProgramFullPath | Represents field Py_GetProgramFullPath.
Py_GetProgramName | Represents field Py_GetProgramName.
Py_GetVersion | Represents field Py_GetVersion.
Py_IgnoreEnvironmentFlag | Represents field Py_IgnoreEnvironmentFlag.
Py_Initialize | Represents field Py_Initialize.
Py_InitModule4 | Represents field Py_InitModule4.
Py_InteractiveFlag | Represents field Py_InteractiveFlag.
Py_IsInitialized | Represents field Py_IsInitialized.
Py_Malloc | Represents field Py_Malloc.
Py_NewInterpreter | Represents field Py_NewInterpreter.
Py_None | Represents field Py_None.
Py_NoSiteFlag | Represents field Py_NoSiteFlag.
Py_NotImplemented | Represents field Py_NotImplemented.
Py_OptimizeFlag | Represents field Py_OptimizeFlag.
Py_SetProgramName | Represents field Py_SetProgramName.
Py_SetProgramName3000 | Represents field Py_SetProgramName3000.
Py_TabcheckFlag | Represents field Py_TabcheckFlag.
Py_True | Represents field Py_True.
Py_UnicodeFlag | Represents field Py_UnicodeFlag.
Py_UseClassExceptionsFlag | Represents field Py_UseClassExceptionsFlag.
Py_VerboseFlag | Represents field Py_VerboseFlag.
_PyObject_New | Represents field _PyObject_New.
_PyString_Resize | Represents field _PyString_Resize.
_PyWeakref_CallableProxyType | Represents field _PyWeakref_CallableProxyType.
_PyWeakref_ProxyType | Represents field _PyWeakref_ProxyType.
_PyWeakref_RefType | Represents field _PyWeakref_RefType.
Top


TPythonInterface.FBuiltInModuleName Field

Summary

Represents field FBuiltInModuleName.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FBuiltInModuleName: String;

Field Value

Type: String

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.FFinalizing Field

Summary

Represents field FFinalizing.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FFinalizing: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.FInitialized Field

Summary

Represents field FInitialized.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FInitialized: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.FIsPython3000 Field

Summary

Represents field FIsPython3000.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FIsPython3000: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.FMajorVersion Field

Summary

Represents field FMajorVersion.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FMajorVersion: integer;

Field Value

Type: integer

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.FMinorVersion Field

Summary

Represents field FMinorVersion.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FMinorVersion: integer;

Field Value

Type: integer

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyArg_Parse Field

Summary

Represents field PyArg_Parse.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyArg_Parse: function( args: PPyObject; format: PAnsiChar ) : Integer; cdecl varargs;

Field Value

Type: function( args: PPyObject; format: PAnsiChar ) : Integer; cdecl varargs

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyArg_ParseTuple Field

Summary

Represents field PyArg_ParseTuple.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyArg_ParseTuple: function( args: PPyObject; format: PAnsiChar ): Integer; cdecl varargs;

Field Value

Type: function( args: PPyObject; format: PAnsiChar ): Integer; cdecl varargs

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyBaseObject_Type Field

Summary

Represents field PyBaseObject_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyBaseObject_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyBaseString_Type Field

Summary

Represents field PyBaseString_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyBaseString_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyBool_FromLong Field

Summary

Represents field PyBool_FromLong.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyBool_FromLong: function ( ok : Integer) : PPyObject; cdecl;

Field Value

Type: function ( ok : Integer) : PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyBool_Type Field

Summary

Represents field PyBool_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyBool_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyBuffer_Type Field

Summary

Represents field PyBuffer_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyBuffer_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyCallable_Check Field

Summary

Represents field PyCallable_Check.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyCallable_Check: function(ob : PPyObject): integer; cdecl;

Field Value

Type: function(ob : PPyObject): integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyCallIter_Type Field

Summary

Represents field PyCallIter_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyCallIter_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyCell_Type Field

Summary

Represents field PyCell_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyCell_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyCFunction_GetFunction Field

Summary

Represents field PyCFunction_GetFunction.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyCFunction_GetFunction: function(ob : PPyObject): Pointer; cdecl;

Field Value

Type: function(ob : PPyObject): Pointer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyCFunction_GetSelf Field

Summary

Represents field PyCFunction_GetSelf.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyCFunction_GetSelf: function(ob : PPyObject): PPyObject; cdecl;

Field Value

Type: function(ob : PPyObject): PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyCFunction_New Field

Summary

Represents field PyCFunction_New.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyCFunction_New: function(md:PPyMethodDef;ob:PPyObject):PPyObject; cdecl;

Field Value

Type: function(md:PPyMethodDef;ob:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyCFunction_NewEx Field

Summary

Represents field PyCFunction_NewEx.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyCFunction_NewEx: function(md:PPyMethodDef;self, ob:PPyObject):PPyObject; cdecl;

Field Value

Type: function(md:PPyMethodDef;self, ob:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyCFunction_Type Field

Summary

Represents field PyCFunction_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyCFunction_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyClassMethod_Type Field

Summary

Represents field PyClassMethod_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyClassMethod_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyClass_IsSubclass Field

Summary

Represents field PyClass_IsSubclass.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyClass_IsSubclass: function (ob1, ob2 : PPyObject): integer cdecl;

Field Value

Type: function (ob1, ob2 : PPyObject): integer cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyClass_New Field

Summary

Represents field PyClass_New.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyClass_New: function (ob1,ob2,ob3 : PPyObject): PPyObject; cdecl;

Field Value

Type: function (ob1,ob2,ob3 : PPyObject): PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyClass_Type Field

Summary

Represents field PyClass_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyClass_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyCObject_AsVoidPtr Field

Summary

Represents field PyCObject_AsVoidPtr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyCObject_AsVoidPtr: function(ob : PPyObject): Pointer; cdecl;

Field Value

Type: function(ob : PPyObject): Pointer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyCObject_FromVoidPtr Field

Summary

Represents field PyCObject_FromVoidPtr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyCObject_FromVoidPtr: function(cobj, destruct : Pointer): PPyObject; cdecl;

Field Value

Type: function(cobj, destruct : Pointer): PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyCObject_Type Field

Summary

Represents field PyCObject_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyCObject_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyCode_Type Field

Summary

Represents field PyCode_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyCode_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyComplex_AsCComplex Field

Summary

Represents field PyComplex_AsCComplex.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyComplex_AsCComplex: function(op : PPyObject ): Py_complex; cdecl;

Field Value

Type: function(op : PPyObject ): Py_complex; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyComplex_FromCComplex Field

Summary

Represents field PyComplex_FromCComplex.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyComplex_FromCComplex: function(c: Py_complex):PPyObject; cdecl;

Field Value

Type: function(c: Py_complex):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyComplex_FromDoubles Field

Summary

Represents field PyComplex_FromDoubles.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyComplex_FromDoubles: function(realv,imag : double):PPyObject; cdecl;

Field Value

Type: function(realv,imag : double):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyComplex_ImagAsDouble Field

Summary

Represents field PyComplex_ImagAsDouble.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyComplex_ImagAsDouble: function(op : PPyObject ): double; cdecl;

Field Value

Type: function(op : PPyObject ): double; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyComplex_RealAsDouble Field

Summary

Represents field PyComplex_RealAsDouble.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyComplex_RealAsDouble: function(op : PPyObject ): double; cdecl;

Field Value

Type: function(op : PPyObject ): double; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyComplex_Type Field

Summary

Represents field PyComplex_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyComplex_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyDictProxy_New Field

Summary

Represents field PyDictProxy_New.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyDictProxy_New: function (obj : PPyObject) : PPyObject; cdecl;

Field Value

Type: function (obj : PPyObject) : PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyDict_Clear Field

Summary

Represents field PyDict_Clear.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyDict_Clear: procedure(mp : PPyObject); cdecl;

Field Value

Type: procedure(mp : PPyObject); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyDict_Copy Field

Summary

Represents field PyDict_Copy.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyDict_Copy: function(mp: PPyObject):PPyObject; cdecl;

Field Value

Type: function(mp: PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyDict_DelItem Field

Summary

Represents field PyDict_DelItem.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyDict_DelItem: function(mp, key : PPyObject ):integer; cdecl;

Field Value

Type: function(mp, key : PPyObject ):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyDict_DelItemString Field

Summary

Represents field PyDict_DelItemString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyDict_DelItemString: function(dp : PPyObject;key : PAnsiChar ):integer; cdecl;

Field Value

Type: function(dp : PPyObject;key : PAnsiChar ):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyDict_GetItem Field

Summary

Represents field PyDict_GetItem.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyDict_GetItem: function(mp, key : PPyObject):PPyObject; cdecl;

Field Value

Type: function(mp, key : PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyDict_GetItemString Field

Summary

Represents field PyDict_GetItemString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyDict_GetItemString: function( dp: PPyObject; key: PAnsiChar): PPyObject; cdecl;

Field Value

Type: function( dp: PPyObject; key: PAnsiChar): PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyDict_Items Field

Summary

Represents field PyDict_Items.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyDict_Items: function(mp: PPyObject):PPyObject; cdecl;

Field Value

Type: function(mp: PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyDict_Keys Field

Summary

Represents field PyDict_Keys.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyDict_Keys: function(mp: PPyObject):PPyObject; cdecl;

Field Value

Type: function(mp: PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyDict_New Field

Summary

Represents field PyDict_New.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyDict_New: function: PPyObject; cdecl;

Field Value

Type: function: PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyDict_Next Field

Summary

Represents field PyDict_Next.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyDict_Next: function(mp : PPyObject; pos: PNativeInt; key, value: PPPyObject):integer; cdecl;

Field Value

Type: function(mp : PPyObject; pos: PNativeInt; key, value: PPPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyDict_SetItem Field

Summary

Represents field PyDict_SetItem.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyDict_SetItem: function(mp, key, item :PPyObject ):integer; cdecl;

Field Value

Type: function(mp, key, item :PPyObject ):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyDict_SetItemString Field

Summary

Represents field PyDict_SetItemString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyDict_SetItemString: function( dp: PPyObject; key: PAnsiChar; item: PPyObject):
 Integer; cdecl;

Field Value

Type: function( dp: PPyObject; key: PAnsiChar; item: PPyObject): Integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyDict_Size Field

Summary

Represents field PyDict_Size.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyDict_Size: function(mp: PPyObject):NativeInt; cdecl;

Field Value

Type: function(mp: PPyObject):NativeInt; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyDict_Type Field

Summary

Represents field PyDict_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyDict_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyDict_Values Field

Summary

Represents field PyDict_Values.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyDict_Values: function(mp: PPyObject):PPyObject; cdecl;

Field Value

Type: function(mp: PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyEnum_Type Field

Summary

Represents field PyEnum_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyEnum_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyErr_BadArgument Field

Summary

Represents field PyErr_BadArgument.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyErr_BadArgument: function: integer; cdecl;

Field Value

Type: function: integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyErr_BadInternalCall Field

Summary

Represents field PyErr_BadInternalCall.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyErr_BadInternalCall: procedure; cdecl;

Field Value

Type: procedure; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyErr_CheckSignals Field

Summary

Represents field PyErr_CheckSignals.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyErr_CheckSignals: function: integer; cdecl;

Field Value

Type: function: integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyErr_Clear Field

Summary

Represents field PyErr_Clear.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyErr_Clear: procedure; cdecl;

Field Value

Type: procedure; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyErr_ExceptionMatches Field

Summary

Represents field PyErr_ExceptionMatches.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyErr_ExceptionMatches : function ( exc : PPyObject) : Integer; cdecl;

Field Value

Type: function ( exc : PPyObject) : Integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyErr_Fetch Field

Summary

Represents field PyErr_Fetch.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyErr_Fetch: procedure( errtype, errvalue, errtraceback: PPPyObject); cdecl;

Field Value

Type: procedure( errtype, errvalue, errtraceback: PPPyObject); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyErr_GivenExceptionMatches Field

Summary

Represents field PyErr_GivenExceptionMatches.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyErr_GivenExceptionMatches : function ( raised_exc, exc : PPyObject) : Integer; cdecl;

Field Value

Type: function ( raised_exc, exc : PPyObject) : Integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyErr_NewException Field

Summary

Represents field PyErr_NewException.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyErr_NewException : function ( name : PAnsiChar; base, dict : PPyObject ) : PPyObject; cdecl;

Field Value

Type: function ( name : PAnsiChar; base, dict : PPyObject ) : PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyErr_NoMemory Field

Summary

Represents field PyErr_NoMemory.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyErr_NoMemory: function: PPyObject; cdecl;

Field Value

Type: function: PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyErr_Occurred Field

Summary

Represents field PyErr_Occurred.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyErr_Occurred: function: PPyObject; cdecl;

Field Value

Type: function: PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyErr_Print Field

Summary

Represents field PyErr_Print.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyErr_Print: procedure; cdecl;

Field Value

Type: procedure; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyErr_Restore Field

Summary

Represents field PyErr_Restore.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyErr_Restore: procedure (errtype, errvalue, errtraceback: PPyObject); cdecl;

Field Value

Type: procedure (errtype, errvalue, errtraceback: PPyObject); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyErr_SetFromErrno Field

Summary

Represents field PyErr_SetFromErrno.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyErr_SetFromErrno: function (ob : PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob : PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyErr_SetInterrupt Field

Summary

Represents field PyErr_SetInterrupt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyErr_SetInterrupt : procedure; cdecl;

Field Value

Type: procedure; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyErr_SetNone Field

Summary

Represents field PyErr_SetNone.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyErr_SetNone: procedure(value: PPyObject); cdecl;

Field Value

Type: procedure(value: PPyObject); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyErr_SetObject Field

Summary

Represents field PyErr_SetObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyErr_SetObject: procedure (ob1, ob2 : PPyObject); cdecl;

Field Value

Type: procedure (ob1, ob2 : PPyObject); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyErr_SetString Field

Summary

Represents field PyErr_SetString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyErr_SetString: procedure( ErrorObject: PPyObject; text: PAnsiChar); cdecl;

Field Value

Type: procedure( ErrorObject: PPyObject; text: PAnsiChar); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyEval_AcquireLock Field

Summary

Represents field PyEval_AcquireLock.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyEval_AcquireLock : procedure; cdecl;

Field Value

Type: procedure; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyEval_AcquireThread Field

Summary

Represents field PyEval_AcquireThread.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyEval_AcquireThread : procedure( tstate: PPyThreadState); cdecl;

Field Value

Type: procedure( tstate: PPyThreadState); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyEval_CallObjectWithKeywords Field

Summary

Represents field PyEval_CallObjectWithKeywords.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyEval_CallObjectWithKeywords:function (callable_obj, args, kw:PPyObject):PPyObject; cdecl;

Field Value

Type: function (callable_obj, args, kw:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyEval_EvalCode Field

Summary

Represents field PyEval_EvalCode.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyEval_EvalCode : function ( co : PPyCodeObject; globals, locals : PPyObject) : PPyObject; cdecl;

Field Value

Type: function ( co : PPyCodeObject; globals, locals : PPyObject) : PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyEval_GetBuiltins Field

Summary

Represents field PyEval_GetBuiltins.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyEval_GetBuiltins: function: PPyObject; cdecl;

Field Value

Type: function: PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyEval_GetFrame Field

Summary

Represents field PyEval_GetFrame.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyEval_GetFrame:function :PPyObject; cdecl;

Field Value

Type: function :PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyEval_GetGlobals Field

Summary

Represents field PyEval_GetGlobals.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyEval_GetGlobals:function :PPyObject; cdecl;

Field Value

Type: function :PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyEval_GetLocals Field

Summary

Represents field PyEval_GetLocals.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyEval_GetLocals:function :PPyObject; cdecl;

Field Value

Type: function :PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyEval_GetRestricted Field

Summary

Represents field PyEval_GetRestricted.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyEval_GetRestricted:function :integer; cdecl;

Field Value

Type: function :integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyEval_InitThreads Field

Summary

Represents field PyEval_InitThreads.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyEval_InitThreads:procedure; cdecl;

Field Value

Type: procedure; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyEval_ReleaseLock Field

Summary

Represents field PyEval_ReleaseLock.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyEval_ReleaseLock : procedure; cdecl;

Field Value

Type: procedure; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyEval_ReleaseThread Field

Summary

Represents field PyEval_ReleaseThread.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyEval_ReleaseThread : procedure( tstate: PPyThreadState); cdecl;

Field Value

Type: procedure( tstate: PPyThreadState); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyEval_RestoreThread Field

Summary

Represents field PyEval_RestoreThread.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyEval_RestoreThread:procedure( tstate: PPyThreadState); cdecl;

Field Value

Type: procedure( tstate: PPyThreadState); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyEval_SaveThread Field

Summary

Represents field PyEval_SaveThread.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyEval_SaveThread:function :PPyThreadState; cdecl;

Field Value

Type: function :PPyThreadState; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_ArithmeticError Field

Summary

Represents field PyExc_ArithmeticError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_ArithmeticError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_AssertionError Field

Summary

Represents field PyExc_AssertionError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_AssertionError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_AttributeError Field

Summary

Represents field PyExc_AttributeError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_AttributeError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_DeprecationWarning Field

Summary

Represents field PyExc_DeprecationWarning.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_DeprecationWarning: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_EnvironmentError Field

Summary

Represents field PyExc_EnvironmentError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_EnvironmentError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_EOFError Field

Summary

Represents field PyExc_EOFError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_EOFError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_Exception Field

Summary

Represents field PyExc_Exception.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_Exception: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_FloatingPointError Field

Summary

Represents field PyExc_FloatingPointError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_FloatingPointError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_FutureWarning Field

Summary

Represents field PyExc_FutureWarning.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_FutureWarning: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_ImportError Field

Summary

Represents field PyExc_ImportError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_ImportError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_IndentationError Field

Summary

Represents field PyExc_IndentationError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_IndentationError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_IndexError Field

Summary

Represents field PyExc_IndexError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_IndexError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_IOError Field

Summary

Represents field PyExc_IOError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_IOError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_KeyboardInterrupt Field

Summary

Represents field PyExc_KeyboardInterrupt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_KeyboardInterrupt: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_KeyError Field

Summary

Represents field PyExc_KeyError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_KeyError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_LookupError Field

Summary

Represents field PyExc_LookupError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_LookupError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_MemoryError Field

Summary

Represents field PyExc_MemoryError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_MemoryError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_MemoryErrorInst Field

Summary

Represents field PyExc_MemoryErrorInst.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_MemoryErrorInst: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_NameError Field

Summary

Represents field PyExc_NameError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_NameError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_NotImplementedError Field

Summary

Represents field PyExc_NotImplementedError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_NotImplementedError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_OSError Field

Summary

Represents field PyExc_OSError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_OSError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_OverflowError Field

Summary

Represents field PyExc_OverflowError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_OverflowError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_PendingDeprecationWarning Field

Summary

Represents field PyExc_PendingDeprecationWarning.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_PendingDeprecationWarning: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_ReferenceError Field

Summary

Represents field PyExc_ReferenceError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_ReferenceError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_RuntimeError Field

Summary

Represents field PyExc_RuntimeError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_RuntimeError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_RuntimeWarning Field

Summary

Represents field PyExc_RuntimeWarning.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_RuntimeWarning: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_StandardError Field

Summary

Represents field PyExc_StandardError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_StandardError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_StopIteration Field

Summary

Represents field PyExc_StopIteration.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_StopIteration: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_SyntaxError Field

Summary

Represents field PyExc_SyntaxError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_SyntaxError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_SyntaxWarning Field

Summary

Represents field PyExc_SyntaxWarning.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_SyntaxWarning: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_SystemError Field

Summary

Represents field PyExc_SystemError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_SystemError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_SystemExit Field

Summary

Represents field PyExc_SystemExit.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_SystemExit: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_TabError Field

Summary

Represents field PyExc_TabError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_TabError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_TypeError Field

Summary

Represents field PyExc_TypeError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_TypeError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_UnboundLocalError Field

Summary

Represents field PyExc_UnboundLocalError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_UnboundLocalError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_UnicodeDecodeError Field

Summary

Represents field PyExc_UnicodeDecodeError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_UnicodeDecodeError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_UnicodeEncodeError Field

Summary

Represents field PyExc_UnicodeEncodeError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_UnicodeEncodeError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_UnicodeError Field

Summary

Represents field PyExc_UnicodeError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_UnicodeError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_UnicodeTranslateError Field

Summary

Represents field PyExc_UnicodeTranslateError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_UnicodeTranslateError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_UserWarning Field

Summary

Represents field PyExc_UserWarning.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_UserWarning: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_ValueError Field

Summary

Represents field PyExc_ValueError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_ValueError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_Warning Field

Summary

Represents field PyExc_Warning.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_Warning: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_WindowsError Field

Summary

Represents field PyExc_WindowsError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_WindowsError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyExc_ZeroDivisionError Field

Summary

Represents field PyExc_ZeroDivisionError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyExc_ZeroDivisionError: PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyFile_FromString Field

Summary

Represents field PyFile_FromString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyFile_FromString:function (pc1,pc2:PAnsiChar):PPyObject; cdecl;

Field Value

Type: function (pc1,pc2:PAnsiChar):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyFile_GetLine Field

Summary

Represents field PyFile_GetLine.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyFile_GetLine:function (ob:PPyObject;i:integer):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject;i:integer):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyFile_Name Field

Summary

Represents field PyFile_Name.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyFile_Name:function (ob:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyFile_SetBufSize Field

Summary

Represents field PyFile_SetBufSize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyFile_SetBufSize:procedure(ob:PPyObject;i:integer); cdecl;

Field Value

Type: procedure(ob:PPyObject;i:integer); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyFile_SoftSpace Field

Summary

Represents field PyFile_SoftSpace.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyFile_SoftSpace:function (ob:PPyObject;i:integer):integer; cdecl;

Field Value

Type: function (ob:PPyObject;i:integer):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyFile_Type Field

Summary

Represents field PyFile_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyFile_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyFile_WriteObject Field

Summary

Represents field PyFile_WriteObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyFile_WriteObject:function (ob1,ob2:PPyObject;i:integer):integer; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject;i:integer):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyFile_WriteString Field

Summary

Represents field PyFile_WriteString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyFile_WriteString:procedure(s:PAnsiChar;ob:PPyObject); cdecl;

Field Value

Type: procedure(s:PAnsiChar;ob:PPyObject); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyFloat_AsDouble Field

Summary

Represents field PyFloat_AsDouble.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyFloat_AsDouble:function (ob:PPyObject):DOUBLE; cdecl;

Field Value

Type: function (ob:PPyObject):DOUBLE; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyFloat_FromDouble Field

Summary

Represents field PyFloat_FromDouble.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyFloat_FromDouble:function (db:double):PPyObject; cdecl;

Field Value

Type: function (db:double):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyFloat_Type Field

Summary

Represents field PyFloat_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyFloat_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyFrame_Type Field

Summary

Represents field PyFrame_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyFrame_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyFunction_GetCode Field

Summary

Represents field PyFunction_GetCode.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyFunction_GetCode:function (ob:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyFunction_GetGlobals Field

Summary

Represents field PyFunction_GetGlobals.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyFunction_GetGlobals:function (ob:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyFunction_New Field

Summary

Represents field PyFunction_New.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyFunction_New:function (ob1,ob2:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyFunction_Type Field

Summary

Represents field PyFunction_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyFunction_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyGILState_Ensure Field

Summary

Represents field PyGILState_Ensure.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyGILState_Ensure : function() : PyGILstate_STATE; cdecl;

Field Value

Type: function() : PyGILstate_STATE; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyGILState_Release Field

Summary

Represents field PyGILState_Release.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyGILState_Release : procedure(gilstate : PyGILState_STATE); cdecl;

Field Value

Type: procedure(gilstate : PyGILState_STATE); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyImport_AddModule Field

Summary

Represents field PyImport_AddModule.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyImport_AddModule:function (name:PAnsiChar):PPyObject; cdecl;

Field Value

Type: function (name:PAnsiChar):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyImport_Cleanup Field

Summary

Represents field PyImport_Cleanup.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyImport_Cleanup:procedure; cdecl;

Field Value

Type: procedure; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyImport_FrozenModules Field

Summary

Represents field PyImport_FrozenModules.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyImport_FrozenModules: PP_frozen;

Field Value

Type: PP_frozen

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyImport_GetMagicNumber Field

Summary

Represents field PyImport_GetMagicNumber.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyImport_GetMagicNumber:function :LONGINT; cdecl;

Field Value

Type: function :LONGINT; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyImport_GetModuleDict Field

Summary

Represents field PyImport_GetModuleDict.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyImport_GetModuleDict: function: PPyObject; cdecl;

Field Value

Type: function: PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyImport_Import Field

Summary

Represents field PyImport_Import.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyImport_Import:function (name:PPyObject):PPyObject; cdecl;

Field Value

Type: function (name:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyImport_ImportFrozenModule Field

Summary

Represents field PyImport_ImportFrozenModule.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyImport_ImportFrozenModule:function (key:PAnsiChar):integer; cdecl;

Field Value

Type: function (key:PAnsiChar):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyImport_ImportModule Field

Summary

Represents field PyImport_ImportModule.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyImport_ImportModule:function (name:PAnsiChar):PPyObject; cdecl;

Field Value

Type: function (name:PAnsiChar):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyImport_ReloadModule Field

Summary

Represents field PyImport_ReloadModule.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyImport_ReloadModule:function (ob:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyInstance_New Field

Summary

Represents field PyInstance_New.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyInstance_New:function (obClass, obArg, obKW:PPyObject):PPyObject; cdecl;

Field Value

Type: function (obClass, obArg, obKW:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyInstance_Type Field

Summary

Represents field PyInstance_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyInstance_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyInterpreterState_Clear Field

Summary

Represents field PyInterpreterState_Clear.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyInterpreterState_Clear : procedure( interp: PPyInterpreterState); cdecl;

Field Value

Type: procedure( interp: PPyInterpreterState); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyInterpreterState_Delete Field

Summary

Represents field PyInterpreterState_Delete.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyInterpreterState_Delete : procedure( interp: PPyInterpreterState); cdecl;

Field Value

Type: procedure( interp: PPyInterpreterState); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyInterpreterState_New Field

Summary

Represents field PyInterpreterState_New.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyInterpreterState_New : function : PPyInterpreterState; cdecl;

Field Value

Type: function : PPyInterpreterState; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyInt_AsLong Field

Summary

Represents field PyInt_AsLong.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyInt_AsLong:function (ob:PPyObject):LONGINT; cdecl;

Field Value

Type: function (ob:PPyObject):LONGINT; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyInt_FromLong Field

Summary

Represents field PyInt_FromLong.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyInt_FromLong: function( x: LongInt):PPyObject; cdecl;

Field Value

Type: function( x: LongInt):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyInt_Type Field

Summary

Represents field PyInt_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyInt_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyIter_Next Field

Summary

Represents field PyIter_Next.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyIter_Next: function (obj: PPyObject) : PPyObject; cdecl;

Field Value

Type: function (obj: PPyObject) : PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyList_Append Field

Summary

Represents field PyList_Append.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyList_Append:function (ob1,ob2:PPyObject):integer; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyList_AsTuple Field

Summary

Represents field PyList_AsTuple.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyList_AsTuple:function (ob:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyList_GetItem Field

Summary

Represents field PyList_GetItem.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyList_GetItem:function (ob:PPyObject;i:NativeInt):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject;i:NativeInt):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyList_GetSlice Field

Summary

Represents field PyList_GetSlice.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyList_GetSlice:function (ob:PPyObject;i1,i2:NativeInt):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject;i1,i2:NativeInt):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyList_Insert Field

Summary

Represents field PyList_Insert.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyList_Insert:function (dp:PPyObject;idx:NativeInt;item:PPyObject):integer; cdecl;

Field Value

Type: function (dp:PPyObject;idx:NativeInt;item:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyList_New Field

Summary

Represents field PyList_New.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyList_New:function (size:NativeInt):PPyObject; cdecl;

Field Value

Type: function (size:NativeInt):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyList_Reverse Field

Summary

Represents field PyList_Reverse.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyList_Reverse:function (ob:PPyObject):integer; cdecl;

Field Value

Type: function (ob:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyList_SetItem Field

Summary

Represents field PyList_SetItem.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyList_SetItem:function (dp:PPyObject;idx:NativeInt;item:PPyObject):integer; cdecl;

Field Value

Type: function (dp:PPyObject;idx:NativeInt;item:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyList_SetSlice Field

Summary

Represents field PyList_SetSlice.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyList_SetSlice:function (ob:PPyObject;i1,i2:NativeInt;ob2:PPyObject):integer; cdecl;

Field Value

Type: function (ob:PPyObject;i1,i2:NativeInt;ob2:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyList_Size Field

Summary

Represents field PyList_Size.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyList_Size:function (ob:PPyObject):NativeInt; cdecl;

Field Value

Type: function (ob:PPyObject):NativeInt; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyList_Sort Field

Summary

Represents field PyList_Sort.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyList_Sort:function (ob:PPyObject):integer; cdecl;

Field Value

Type: function (ob:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyList_Type Field

Summary

Represents field PyList_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyList_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyLong_AsDouble Field

Summary

Represents field PyLong_AsDouble.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyLong_AsDouble:function (ob:PPyObject):DOUBLE; cdecl;

Field Value

Type: function (ob:PPyObject):DOUBLE; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyLong_AsLong Field

Summary

Represents field PyLong_AsLong.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyLong_AsLong:function (ob:PPyObject):LONGINT; cdecl;

Field Value

Type: function (ob:PPyObject):LONGINT; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyLong_AsLongLong Field

Summary

Represents field PyLong_AsLongLong.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyLong_AsLongLong:function(ob:PPyObject) : Int64; cdecl;

Field Value

Type: function(ob:PPyObject) : Int64; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyLong_AsUnsignedLong Field

Summary

Represents field PyLong_AsUnsignedLong.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyLong_AsUnsignedLong:function(ob:PPyObject) : Cardinal; cdecl;

Field Value

Type: function(ob:PPyObject) : Cardinal; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyLong_FromDouble Field

Summary

Represents field PyLong_FromDouble.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyLong_FromDouble:function (db:double):PPyObject; cdecl;

Field Value

Type: function (db:double):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyLong_FromLong Field

Summary

Represents field PyLong_FromLong.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyLong_FromLong:function (l:longint):PPyObject; cdecl;

Field Value

Type: function (l:longint):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyLong_FromLongLong Field

Summary

Represents field PyLong_FromLongLong.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyLong_FromLongLong:function(val:Int64) : PPyObject; cdecl;

Field Value

Type: function(val:Int64) : PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyLong_FromString Field

Summary

Represents field PyLong_FromString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyLong_FromString:function (pc:PAnsiChar;var ppc:PAnsiChar;i:integer):PPyObject; cdecl;

Field Value

Type: function (pc:PAnsiChar;var ppc:PAnsiChar;i:integer):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyLong_FromUnicode Field

Summary

Represents field PyLong_FromUnicode.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyLong_FromUnicode:function(ob:PPyObject; a, b : integer) : PPyObject; cdecl;

Field Value

Type: function(ob:PPyObject; a, b : integer) : PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyLong_FromUnsignedLong Field

Summary

Represents field PyLong_FromUnsignedLong.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyLong_FromUnsignedLong:function(val:cardinal) : PPyObject; cdecl;

Field Value

Type: function(val:cardinal) : PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyLong_Type Field

Summary

Represents field PyLong_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyLong_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyMapping_Check Field

Summary

Represents field PyMapping_Check.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyMapping_Check:function (ob:PPyObject):integer; cdecl;

Field Value

Type: function (ob:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyMapping_GetItemString Field

Summary

Represents field PyMapping_GetItemString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyMapping_GetItemString:function (ob:PPyObject;key:PAnsiChar):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject;key:PAnsiChar):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyMapping_HasKey Field

Summary

Represents field PyMapping_HasKey.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyMapping_HasKey:function (ob,key:PPyObject):integer; cdecl;

Field Value

Type: function (ob,key:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyMapping_HasKeyString Field

Summary

Represents field PyMapping_HasKeyString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyMapping_HasKeyString:function (ob:PPyObject;key:PAnsiChar):integer; cdecl;

Field Value

Type: function (ob:PPyObject;key:PAnsiChar):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyMapping_Length Field

Summary

Represents field PyMapping_Length.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyMapping_Length:function (ob:PPyObject):NativeInt; cdecl;

Field Value

Type: function (ob:PPyObject):NativeInt; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyMapping_SetItemString Field

Summary

Represents field PyMapping_SetItemString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyMapping_SetItemString:function (ob:PPyObject; key:PAnsiChar; value:PPyObject):integer; cdecl;

Field Value

Type: function (ob:PPyObject; key:PAnsiChar; value:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyMem_Malloc Field

Summary

Represents field PyMem_Malloc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyMem_Malloc : function ( size : NativeInt ) : Pointer;

Field Value

Type: function ( size : NativeInt ) : Pointer

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyMethod_Class Field

Summary

Represents field PyMethod_Class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyMethod_Class:function (ob:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyMethod_Function Field

Summary

Represents field PyMethod_Function.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyMethod_Function:function (ob:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyMethod_New Field

Summary

Represents field PyMethod_New.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyMethod_New:function (ob1,ob2,ob3:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob1,ob2,ob3:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyMethod_Self Field

Summary

Represents field PyMethod_Self.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyMethod_Self:function (ob:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyMethod_Type Field

Summary

Represents field PyMethod_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyMethod_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyModule_Create2 Field

Summary

Represents field PyModule_Create2.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyModule_Create2: function(moduledef: PPyModuleDef; Api_Version: Integer):PPyObject; cdecl;

Field Value

Type: function(moduledef: PPyModuleDef; Api_Version: Integer):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyModule_GetDict Field

Summary

Represents field PyModule_GetDict.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyModule_GetDict: function( module:PPyObject): PPyObject; cdecl;

Field Value

Type: function( module:PPyObject): PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyModule_GetName Field

Summary

Represents field PyModule_GetName.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyModule_GetName:function (ob:PPyObject):PAnsiChar; cdecl;

Field Value

Type: function (ob:PPyObject):PAnsiChar; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyModule_New Field

Summary

Represents field PyModule_New.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyModule_New:function (key:PAnsiChar):PPyObject; cdecl;

Field Value

Type: function (key:PAnsiChar):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyModule_Type Field

Summary

Represents field PyModule_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyModule_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNode_Free Field

Summary

Represents field PyNode_Free.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNode_Free : procedure( n : PNode ); cdecl;

Field Value

Type: procedure( n : PNode ); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_Absolute Field

Summary

Represents field PyNumber_Absolute.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_Absolute:function (ob:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_Add Field

Summary

Represents field PyNumber_Add.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_Add:function (ob1,ob2:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_And Field

Summary

Represents field PyNumber_And.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_And:function (ob1,ob2:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_Check Field

Summary

Represents field PyNumber_Check.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_Check:function (ob:PPyObject):integer; cdecl;

Field Value

Type: function (ob:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_Coerce Field

Summary

Represents field PyNumber_Coerce.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_Coerce:function (var ob1,ob2:PPyObject):integer; cdecl;

Field Value

Type: function (var ob1,ob2:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_Divide Field

Summary

Represents field PyNumber_Divide.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_Divide:function (ob1,ob2:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_Divmod Field

Summary

Represents field PyNumber_Divmod.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_Divmod:function (ob1,ob2:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_Float Field

Summary

Represents field PyNumber_Float.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_Float:function (ob:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_FloorDivide Field

Summary

Represents field PyNumber_FloorDivide.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_FloorDivide:function (ob1,ob2:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_Int Field

Summary

Represents field PyNumber_Int.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_Int:function (ob:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_Invert Field

Summary

Represents field PyNumber_Invert.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_Invert:function (ob:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_Long Field

Summary

Represents field PyNumber_Long.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_Long:function (ob:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_Lshift Field

Summary

Represents field PyNumber_Lshift.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_Lshift:function (ob1,ob2:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_Multiply Field

Summary

Represents field PyNumber_Multiply.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_Multiply:function (ob1,ob2:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_Negative Field

Summary

Represents field PyNumber_Negative.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_Negative:function (ob:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_Or Field

Summary

Represents field PyNumber_Or.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_Or:function (ob1,ob2:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_Positive Field

Summary

Represents field PyNumber_Positive.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_Positive:function (ob:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_Power Field

Summary

Represents field PyNumber_Power.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_Power:function (ob1,ob2,ob3:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob1,ob2,ob3:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_Remainder Field

Summary

Represents field PyNumber_Remainder.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_Remainder:function (ob1,ob2:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_Rshift Field

Summary

Represents field PyNumber_Rshift.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_Rshift:function (ob1,ob2:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_Subtract Field

Summary

Represents field PyNumber_Subtract.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_Subtract:function (ob1,ob2:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_TrueDivide Field

Summary

Represents field PyNumber_TrueDivide.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_TrueDivide:function (ob1,ob2:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyNumber_Xor Field

Summary

Represents field PyNumber_Xor.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyNumber_Xor:function (ob1,ob2:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_Call Field

Summary

Represents field PyObject_Call.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_Call:function (ob, args, kw:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob, args, kw:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_CallMethod Field

Summary

Represents field PyObject_CallMethod.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_CallMethod : function ( obj : PPyObject; method, format : PAnsiChar ) : PPyObject; cdecl varargs;

Field Value

Type: function ( obj : PPyObject; method, format : PAnsiChar ) : PPyObject; cdecl varargs

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_CallMethodStr Field

Summary

Represents field PyObject_CallMethodStr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_CallMethodStr: function ( obj : PPyObject; method, format, value : PAnsiChar ) : PPyObject; cdecl;

Field Value

Type: function ( obj : PPyObject; method, format, value : PAnsiChar ) : PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_CallObject Field

Summary

Represents field PyObject_CallObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_CallObject:function (ob,args:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob,args:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_Compare Field

Summary

Represents field PyObject_Compare.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_Compare: function (ob1,ob2:PPyObject):integer; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_DelItem Field

Summary

Represents field PyObject_DelItem.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_DelItem:function (ob,key:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob,key:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_Free Field

Summary

Represents field PyObject_Free.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_Free:procedure (ob:PPyObject); cdecl;

Field Value

Type: procedure (ob:PPyObject); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_GC_Del Field

Summary

Represents field PyObject_GC_Del.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_GC_Del:procedure (ob:PPyObject); cdecl;

Field Value

Type: procedure (ob:PPyObject); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_GC_Malloc Field

Summary

Represents field PyObject_GC_Malloc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_GC_Malloc:function (size:NativeUInt):PPyObject; cdecl;

Field Value

Type: function (size:NativeUInt):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_GC_New Field

Summary

Represents field PyObject_GC_New.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_GC_New:function (t:PPyTypeObject):PPyObject; cdecl;

Field Value

Type: function (t:PPyTypeObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_GC_NewVar Field

Summary

Represents field PyObject_GC_NewVar.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_GC_NewVar:function (t:PPyTypeObject; size:NativeInt):PPyObject; cdecl;

Field Value

Type: function (t:PPyTypeObject; size:NativeInt):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_GC_Resize Field

Summary

Represents field PyObject_GC_Resize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_GC_Resize:function (t:PPyObject; newsize:NativeInt):PPyObject; cdecl;

Field Value

Type: function (t:PPyObject; newsize:NativeInt):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_GC_Track Field

Summary

Represents field PyObject_GC_Track.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_GC_Track:procedure (ob:PPyObject); cdecl;

Field Value

Type: procedure (ob:PPyObject); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_GC_UnTrack Field

Summary

Represents field PyObject_GC_UnTrack.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_GC_UnTrack:procedure (ob:PPyObject); cdecl;

Field Value

Type: procedure (ob:PPyObject); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_GenericGetAttr Field

Summary

Represents field PyObject_GenericGetAttr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_GenericGetAttr:function (obj, name : PPyObject) : PPyObject; cdecl;

Field Value

Type: function (obj, name : PPyObject) : PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_GenericSetAttr Field

Summary

Represents field PyObject_GenericSetAttr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_GenericSetAttr:function (obj, name, value : PPyObject) : Integer; cdecl;

Field Value

Type: function (obj, name, value : PPyObject) : Integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_GetAttr Field

Summary

Represents field PyObject_GetAttr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_GetAttr:function (ob1,ob2:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_GetAttrString Field

Summary

Represents field PyObject_GetAttrString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_GetAttrString:function (ob:PPyObject;c:PAnsiChar):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject;c:PAnsiChar):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_GetItem Field

Summary

Represents field PyObject_GetItem.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_GetItem:function (ob,key:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob,key:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_GetIter Field

Summary

Represents field PyObject_GetIter.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_GetIter: function (obj: PPyObject) : PPyObject; cdecl;

Field Value

Type: function (obj: PPyObject) : PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_HasAttrString Field

Summary

Represents field PyObject_HasAttrString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_HasAttrString:function (ob:PPyObject;key:PAnsiChar):integer; cdecl;

Field Value

Type: function (ob:PPyObject;key:PAnsiChar):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_Hash Field

Summary

Represents field PyObject_Hash.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_Hash:function (ob:PPyObject):NativeInt; cdecl;

Field Value

Type: function (ob:PPyObject):NativeInt; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_Init Field

Summary

Represents field PyObject_Init.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_Init:function (ob:PPyObject; t:PPyTypeObject):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject; t:PPyTypeObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_InitVar Field

Summary

Represents field PyObject_InitVar.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_InitVar:function (ob:PPyObject; t:PPyTypeObject; size:NativeInt):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject; t:PPyTypeObject; size:NativeInt):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_IsInstance Field

Summary

Represents field PyObject_IsInstance.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_IsInstance:function (inst, cls:PPyObject):integer; cdecl;

Field Value

Type: function (inst, cls:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_IsSubclass Field

Summary

Represents field PyObject_IsSubclass.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_IsSubclass:function (derived, cls:PPyObject):integer; cdecl;

Field Value

Type: function (derived, cls:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_IsTrue Field

Summary

Represents field PyObject_IsTrue.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_IsTrue:function (ob:PPyObject):integer; cdecl;

Field Value

Type: function (ob:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_Length Field

Summary

Represents field PyObject_Length.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_Length:function (ob:PPyObject):NativeInt; cdecl;

Field Value

Type: function (ob:PPyObject):NativeInt; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_New Field

Summary

Represents field PyObject_New.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_New:function (t:PPyTypeObject):PPyObject; cdecl;

Field Value

Type: function (t:PPyTypeObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_NewVar Field

Summary

Represents field PyObject_NewVar.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_NewVar:function (t:PPyTypeObject; size:NativeInt):PPyObject; cdecl;

Field Value

Type: function (t:PPyTypeObject; size:NativeInt):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_Repr Field

Summary

Represents field PyObject_Repr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_Repr:function (ob:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_RichCompare Field

Summary

Represents field PyObject_RichCompare.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_RichCompare:function (ob1,ob2:PPyObject;opid:integer):PPyObject; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject;opid:integer):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_RichCompareBool Field

Summary

Represents field PyObject_RichCompareBool.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_RichCompareBool:function (ob1,ob2:PPyObject;opid:integer):Integer; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject;opid:integer):Integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_SetAttr Field

Summary

Represents field PyObject_SetAttr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_SetAttr:function (ob1,ob2,ob3:PPyObject):integer; cdecl;

Field Value

Type: function (ob1,ob2,ob3:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_SetAttrString Field

Summary

Represents field PyObject_SetAttrString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_SetAttrString:function (ob:PPyObject;key:PAnsiChar;value:PPyObject):integer; cdecl;

Field Value

Type: function (ob:PPyObject;key:PAnsiChar;value:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_SetItem Field

Summary

Represents field PyObject_SetItem.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_SetItem:function (ob1,ob2,ob3:PPyObject):integer; cdecl;

Field Value

Type: function (ob1,ob2,ob3:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_Str Field

Summary

Represents field PyObject_Str.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_Str: function( v: PPyObject): PPyObject; cdecl;

Field Value

Type: function( v: PPyObject): PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyObject_Type Field

Summary

Represents field PyObject_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyObject_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyOS_InitInterrupts Field

Summary

Represents field PyOS_InitInterrupts.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyOS_InitInterrupts:procedure; cdecl;

Field Value

Type: procedure; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyOS_InterruptOccurred Field

Summary

Represents field PyOS_InterruptOccurred.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyOS_InterruptOccurred:function :integer; cdecl;

Field Value

Type: function :integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyParser_SimpleParseString Field

Summary

Represents field PyParser_SimpleParseString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyParser_SimpleParseString : function ( str : PAnsiChar; start : Integer) : PNode; cdecl;

Field Value

Type: function ( str : PAnsiChar; start : Integer) : PNode; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyProperty_Type Field

Summary

Represents field PyProperty_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyProperty_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyRange_Type Field

Summary

Represents field PyRange_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyRange_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyRun_SimpleString Field

Summary

Represents field PyRun_SimpleString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyRun_SimpleString: function( str: PAnsiChar): Integer; cdecl;

Field Value

Type: function( str: PAnsiChar): Integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyRun_String Field

Summary

Represents field PyRun_String.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyRun_String: function( str: PAnsiChar; start: Integer; globals: PPyObject;
 locals: PPyObject): PPyObject; cdecl;

Field Value

Type: function( str: PAnsiChar; start: Integer; globals: PPyObject; locals: PPyObject): PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySeqIter_New Field

Summary

Represents field PySeqIter_New.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySeqIter_New: function(obj : PPyObject) : PPyObject; cdecl;

Field Value

Type: function(obj : PPyObject) : PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySeqIter_Type Field

Summary

Represents field PySeqIter_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySeqIter_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySequence_Check Field

Summary

Represents field PySequence_Check.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySequence_Check:function (ob:PPyObject):integer; cdecl;

Field Value

Type: function (ob:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySequence_Concat Field

Summary

Represents field PySequence_Concat.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySequence_Concat:function (ob1,ob2:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySequence_Contains Field

Summary

Represents field PySequence_Contains.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySequence_Contains:function (ob, value:PPyObject):integer; cdecl;

Field Value

Type: function (ob, value:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySequence_Count Field

Summary

Represents field PySequence_Count.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySequence_Count:function (ob1,ob2:PPyObject):integer; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySequence_DelSlice Field

Summary

Represents field PySequence_DelSlice.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySequence_DelSlice:function (ob:PPyObject;i1,i2:NativeInt):integer; cdecl;

Field Value

Type: function (ob:PPyObject;i1,i2:NativeInt):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySequence_GetItem Field

Summary

Represents field PySequence_GetItem.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySequence_GetItem:function (ob:PPyObject;i:NativeInt):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject;i:NativeInt):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySequence_GetSlice Field

Summary

Represents field PySequence_GetSlice.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySequence_GetSlice:function (ob:PPyObject;i1,i2:NativeInt):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject;i1,i2:NativeInt):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySequence_In Field

Summary

Represents field PySequence_In.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySequence_In:function (ob1,ob2:PPyObject):integer; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySequence_Index Field

Summary

Represents field PySequence_Index.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySequence_Index:function (ob1,ob2:PPyObject):NativeInt; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):NativeInt; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySequence_Length Field

Summary

Represents field PySequence_Length.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySequence_Length:function (ob:PPyObject):NativeInt; cdecl;

Field Value

Type: function (ob:PPyObject):NativeInt; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySequence_Repeat Field

Summary

Represents field PySequence_Repeat.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySequence_Repeat:function (ob:PPyObject;count:NativeInt):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject;count:NativeInt):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySequence_SetItem Field

Summary

Represents field PySequence_SetItem.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySequence_SetItem:function (ob:PPyObject;i:NativeInt;value:PPyObject):integer; cdecl;

Field Value

Type: function (ob:PPyObject;i:NativeInt;value:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySequence_SetSlice Field

Summary

Represents field PySequence_SetSlice.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySequence_SetSlice:function (ob:PPyObject;i1,i2:NativeInt;value:PPyObject):integer; cdecl;

Field Value

Type: function (ob:PPyObject;i1,i2:NativeInt;value:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySequence_Tuple Field

Summary

Represents field PySequence_Tuple.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySequence_Tuple:function (ob:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySlice_GetIndices Field

Summary

Represents field PySlice_GetIndices.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySlice_GetIndices:function (ob:PPySliceObject;length:NativeInt;var start,stop,step:NativeInt):integer; cdecl;

Field Value

Type: function (ob:PPySliceObject;length:NativeInt;var start,stop,step:NativeInt):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySlice_GetIndicesEx Field

Summary

Represents field PySlice_GetIndicesEx.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySlice_GetIndicesEx:function (ob:PPySliceObject;length:NativeInt;var start,stop,step,slicelength:NativeInt):integer; cdecl;

Field Value

Type: function (ob:PPySliceObject;length:NativeInt;var start,stop,step,slicelength:NativeInt):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySlice_New Field

Summary

Represents field PySlice_New.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySlice_New:function (start,stop,step:PPyObject):PPyObject; cdecl;

Field Value

Type: function (start,stop,step:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySlice_Type Field

Summary

Represents field PySlice_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySlice_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyStaticMethod_Type Field

Summary

Represents field PyStaticMethod_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyStaticMethod_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyString_AsString Field

Summary

Represents field PyString_AsString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyString_AsString: function( ob: PPyObject): PAnsiChar; cdecl;

Field Value

Type: function( ob: PPyObject): PAnsiChar; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyString_Concat Field

Summary

Represents field PyString_Concat.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyString_Concat:procedure(var ob1:PPyObject;ob2:PPyObject); cdecl;

Field Value

Type: procedure(var ob1:PPyObject;ob2:PPyObject); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyString_ConcatAndDel Field

Summary

Represents field PyString_ConcatAndDel.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyString_ConcatAndDel:procedure(var ob1:PPyObject;ob2:PPyObject); cdecl;

Field Value

Type: procedure(var ob1:PPyObject;ob2:PPyObject); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyString_DecodeEscape Field

Summary

Represents field PyString_DecodeEscape.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyString_DecodeEscape:function(s:PAnsiChar; len:NativeInt; errors:PAnsiChar; unicode:NativeInt; recode_encoding:PAnsiChar):PPyObject; cdecl;

Field Value

Type: function(s:PAnsiChar; len:NativeInt; errors:PAnsiChar; unicode:NativeInt; recode_encoding:PAnsiChar):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyString_Format Field

Summary

Represents field PyString_Format.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyString_Format:function (ob1,ob2:PPyObject):PPyObject; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyString_FromStringAndSize Field

Summary

Represents field PyString_FromStringAndSize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyString_FromStringAndSize:function (s:PAnsiChar;i:NativeInt):PPyObject; cdecl;

Field Value

Type: function (s:PAnsiChar;i:NativeInt):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyString_Repr Field

Summary

Represents field PyString_Repr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyString_Repr:function(ob:PPyObject; smartquotes:integer):PPyObject; cdecl;

Field Value

Type: function(ob:PPyObject; smartquotes:integer):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyString_Size Field

Summary

Represents field PyString_Size.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyString_Size:function (ob:PPyObject):NativeInt; cdecl;

Field Value

Type: function (ob:PPyObject):NativeInt; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyString_Type Field

Summary

Represents field PyString_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyString_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySuper_Type Field

Summary

Represents field PySuper_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySuper_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySys_GetObject Field

Summary

Represents field PySys_GetObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySys_GetObject:function (s:PAnsiChar):PPyObject; cdecl;

Field Value

Type: function (s:PAnsiChar):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySys_SetArgv Field

Summary

Represents field PySys_SetArgv.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySys_SetArgv: procedure( argc: Integer; argv: PPAnsiChar); cdecl;

Field Value

Type: procedure( argc: Integer; argv: PPAnsiChar); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySys_SetArgv3000 Field

Summary

Represents field PySys_SetArgv3000.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySys_SetArgv3000: procedure( argc: Integer; argv: PPWideChar); cdecl;

Field Value

Type: procedure( argc: Integer; argv: PPWideChar); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySys_SetObject Field

Summary

Represents field PySys_SetObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySys_SetObject:function (s:PAnsiChar;ob:PPyObject):integer; cdecl;

Field Value

Type: function (s:PAnsiChar;ob:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PySys_SetPath Field

Summary

Represents field PySys_SetPath.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PySys_SetPath:procedure(path:PAnsiChar); cdecl;

Field Value

Type: procedure(path:PAnsiChar); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyThreadState_Clear Field

Summary

Represents field PyThreadState_Clear.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyThreadState_Clear : procedure( tstate: PPyThreadState); cdecl;

Field Value

Type: procedure( tstate: PPyThreadState); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyThreadState_Delete Field

Summary

Represents field PyThreadState_Delete.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyThreadState_Delete : procedure( tstate: PPyThreadState); cdecl;

Field Value

Type: procedure( tstate: PPyThreadState); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyThreadState_Get Field

Summary

Represents field PyThreadState_Get.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyThreadState_Get : function : PPyThreadState; cdecl;

Field Value

Type: function : PPyThreadState; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyThreadState_New Field

Summary

Represents field PyThreadState_New.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyThreadState_New : function ( interp: PPyInterpreterState): PPyThreadState; cdecl;

Field Value

Type: function ( interp: PPyInterpreterState): PPyThreadState; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyThreadState_SetAsyncExc Field

Summary

Represents field PyThreadState_SetAsyncExc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyThreadState_SetAsyncExc: function(t_id :LongInt; exc :PPyObject) : Integer; cdecl;

Field Value

Type: function(t_id :LongInt; exc :PPyObject) : Integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyThreadState_Swap Field

Summary

Represents field PyThreadState_Swap.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyThreadState_Swap : function ( tstate: PPyThreadState): PPyThreadState; cdecl;

Field Value

Type: function ( tstate: PPyThreadState): PPyThreadState; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyTraceBack_Here Field

Summary

Represents field PyTraceBack_Here.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyTraceBack_Here:function (p:pointer):integer; cdecl;

Field Value

Type: function (p:pointer):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyTraceBack_Print Field

Summary

Represents field PyTraceBack_Print.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyTraceBack_Print:function (ob1,ob2:PPyObject):integer; cdecl;

Field Value

Type: function (ob1,ob2:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyTraceBack_Type Field

Summary

Represents field PyTraceBack_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyTraceBack_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyTuple_GetItem Field

Summary

Represents field PyTuple_GetItem.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyTuple_GetItem:function (ob:PPyObject;i:NativeInt):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject;i:NativeInt):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyTuple_GetSlice Field

Summary

Represents field PyTuple_GetSlice.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyTuple_GetSlice:function (ob:PPyObject;i1,i2:NativeInt):PPyObject; cdecl;

Field Value

Type: function (ob:PPyObject;i1,i2:NativeInt):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyTuple_New Field

Summary

Represents field PyTuple_New.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyTuple_New:function (size:NativeInt):PPyObject; cdecl;

Field Value

Type: function (size:NativeInt):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyTuple_SetItem Field

Summary

Represents field PyTuple_SetItem.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyTuple_SetItem:function (ob:PPyObject;key:NativeInt;value:PPyObject):integer; cdecl;

Field Value

Type: function (ob:PPyObject;key:NativeInt;value:PPyObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyTuple_Size Field

Summary

Represents field PyTuple_Size.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyTuple_Size:function (ob:PPyObject):NativeInt; cdecl;

Field Value

Type: function (ob:PPyObject):NativeInt; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyTuple_Type Field

Summary

Represents field PyTuple_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyTuple_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyType_GenericAlloc Field

Summary

Represents field PyType_GenericAlloc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyType_GenericAlloc:function(atype: PPyTypeObject; nitems:NativeInt) : PPyObject; cdecl;

Field Value

Type: function(atype: PPyTypeObject; nitems:NativeInt) : PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyType_GenericNew Field

Summary

Represents field PyType_GenericNew.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyType_GenericNew:function(atype: PPyTypeObject; args, kwds : PPyObject) : PPyObject; cdecl;

Field Value

Type: function(atype: PPyTypeObject; args, kwds : PPyObject) : PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyType_IsSubtype Field

Summary

Represents field PyType_IsSubtype.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyType_IsSubtype:function (a, b : PPyTypeObject):integer; cdecl;

Field Value

Type: function (a, b : PPyTypeObject):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyType_Ready Field

Summary

Represents field PyType_Ready.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyType_Ready:function(atype: PPyTypeObject) : integer; cdecl;

Field Value

Type: function(atype: PPyTypeObject) : integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyType_Type Field

Summary

Represents field PyType_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyType_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyUnicode_AsEncodedString Field

Summary

Represents field PyUnicode_AsEncodedString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyUnicode_AsEncodedString:function (unicode:PPyObject; const encoding:PAnsiChar; const errors:PAnsiChar):PPyObject; cdecl;

Field Value

Type: function (unicode:PPyObject; const encoding:PAnsiChar; const errors:PAnsiChar):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyUnicode_AsWideChar Field

Summary

Represents field PyUnicode_AsWideChar.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyUnicode_AsWideChar:function (unicode: PPyObject; w:PWideChar; size:NativeInt):integer; cdecl;

Field Value

Type: function (unicode: PPyObject; w:PWideChar; size:NativeInt):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyUnicode_Decode Field

Summary

Represents field PyUnicode_Decode.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyUnicode_Decode:function (const s:PAnsiChar; size: NativeInt; const encoding : PAnsiChar; const errors: PAnsiChar):PPyObject; cdecl;

Field Value

Type: function (const s:PAnsiChar; size: NativeInt; const encoding : PAnsiChar; const errors: PAnsiChar):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyUnicode_FromOrdinal Field

Summary

Represents field PyUnicode_FromOrdinal.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyUnicode_FromOrdinal:function (ordinal:integer):PPyObject; cdecl;

Field Value

Type: function (ordinal:integer):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyUnicode_FromWideChar Field

Summary

Represents field PyUnicode_FromWideChar.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyUnicode_FromWideChar:function (const w:PWideChar; size:NativeInt):PPyObject; cdecl;

Field Value

Type: function (const w:PWideChar; size:NativeInt):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyUnicode_Type Field

Summary

Represents field PyUnicode_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyUnicode_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyWeakref_GetObject Field

Summary

Represents field PyWeakref_GetObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyWeakref_GetObject: function ( ref : PPyObject) : PPyObject; cdecl;

Field Value

Type: function ( ref : PPyObject) : PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyWeakref_NewProxy Field

Summary

Represents field PyWeakref_NewProxy.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyWeakref_NewProxy: function ( ob, callback : PPyObject) : PPyObject; cdecl;

Field Value

Type: function ( ob, callback : PPyObject) : PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyWeakref_NewRef Field

Summary

Represents field PyWeakref_NewRef.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyWeakref_NewRef: function ( ob, callback : PPyObject) : PPyObject; cdecl;

Field Value

Type: function ( ob, callback : PPyObject) : PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyWrapperDescr_Type Field

Summary

Represents field PyWrapperDescr_Type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyWrapperDescr_Type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.PyWrapper_New Field

Summary

Represents field PyWrapper_New.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 PyWrapper_New: function ( ob1, ob2 : PPyObject) : PPyObject; cdecl;

Field Value

Type: function ( ob1, ob2 : PPyObject) : PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_AtExit Field

Summary

Represents field Py_AtExit.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_AtExit:function (proc: AtExitProc):integer; cdecl;

Field Value

Type: function (proc: AtExitProc):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_BuildValue Field

Summary

Represents field Py_BuildValue.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_BuildValue: function( format: PAnsiChar ): PPyObject; cdecl varargs;

Field Value

Type: function( format: PAnsiChar ): PPyObject; cdecl varargs

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_CompileString Field

Summary

Represents field Py_CompileString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_CompileString:function (s1,s2:PAnsiChar;i:integer):PPyObject; cdecl;

Field Value

Type: function (s1,s2:PAnsiChar;i:integer):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_DebugFlag Field

Summary

Represents field Py_DebugFlag.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_DebugFlag: PInt;

Field Value

Type: PInt

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_DivisionWarningFlag Field

Summary

Represents field Py_DivisionWarningFlag.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_DivisionWarningFlag: PInt;

Field Value

Type: PInt

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_Ellipsis Field

Summary

Represents field Py_Ellipsis.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_Ellipsis: PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_EndInterpreter Field

Summary

Represents field Py_EndInterpreter.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_EndInterpreter : procedure( tstate: PPyThreadState); cdecl;

Field Value

Type: procedure( tstate: PPyThreadState); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_Exit Field

Summary

Represents field Py_Exit.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_Exit: procedure( RetVal: Integer); cdecl;

Field Value

Type: procedure( RetVal: Integer); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_False Field

Summary

Represents field Py_False.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_False: PPyIntObject;

Field Value

Type: PPyIntObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_FatalError Field

Summary

Represents field Py_FatalError.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_FatalError:procedure(s:PAnsiChar); cdecl;

Field Value

Type: procedure(s:PAnsiChar); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_Finalize Field

Summary

Represents field Py_Finalize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_Finalize : procedure; cdecl;

Field Value

Type: procedure; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_FindMethod Field

Summary

Represents field Py_FindMethod.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_FindMethod:function (md:PPyMethodDef;ob:PPyObject;key:PAnsiChar):PPyObject; cdecl;

Field Value

Type: function (md:PPyMethodDef;ob:PPyObject;key:PAnsiChar):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_FindMethodInChain Field

Summary

Represents field Py_FindMethodInChain.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_FindMethodInChain:function (mc:PPyMethodChain;ob:PPyObject;key:PAnsiChar):PPyObject; cdecl;

Field Value

Type: function (mc:PPyMethodChain;ob:PPyObject;key:PAnsiChar):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_FrozenFlag Field

Summary

Represents field Py_FrozenFlag.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_FrozenFlag: PInt;

Field Value

Type: PInt

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_GetCopyright Field

Summary

Represents field Py_GetCopyright.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_GetCopyright : function : PAnsiChar; cdecl;

Field Value

Type: function : PAnsiChar; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_GetExecPrefix Field

Summary

Represents field Py_GetExecPrefix.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_GetExecPrefix : function : PAnsiChar; cdecl;

Field Value

Type: function : PAnsiChar; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_GetPath Field

Summary

Represents field Py_GetPath.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_GetPath : function : PAnsiChar; cdecl;

Field Value

Type: function : PAnsiChar; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_GetPrefix Field

Summary

Represents field Py_GetPrefix.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_GetPrefix : function : PAnsiChar; cdecl;

Field Value

Type: function : PAnsiChar; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_GetProgramFullPath Field

Summary

Represents field Py_GetProgramFullPath.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_GetProgramFullPath : function : PAnsiChar; cdecl;

Field Value

Type: function : PAnsiChar; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_GetProgramName Field

Summary

Represents field Py_GetProgramName.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_GetProgramName : function : PAnsiChar; cdecl;

Field Value

Type: function : PAnsiChar; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_GetVersion Field

Summary

Represents field Py_GetVersion.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_GetVersion : function : PAnsiChar; cdecl;

Field Value

Type: function : PAnsiChar; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_IgnoreEnvironmentFlag Field

Summary

Represents field Py_IgnoreEnvironmentFlag.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_IgnoreEnvironmentFlag: PInt;

Field Value

Type: PInt

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_Initialize Field

Summary

Represents field Py_Initialize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_Initialize: procedure; cdecl;

Field Value

Type: procedure; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_InitModule4 Field

Summary

Represents field Py_InitModule4.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_InitModule4: function( name: PAnsiChar; methods: PPyMethodDef; doc: PAnsiChar;
 passthrough: PPyObject; Api_Version: Integer):PPyObject; cdecl;

Field Value

Type: function( name: PAnsiChar; methods: PPyMethodDef; doc: PAnsiChar; passthrough: PPyObject; Api_Version: Integer):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_InteractiveFlag Field

Summary

Represents field Py_InteractiveFlag.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_InteractiveFlag: PInt;

Field Value

Type: PInt

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_IsInitialized Field

Summary

Represents field Py_IsInitialized.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_IsInitialized : function : integer; cdecl;

Field Value

Type: function : integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_Malloc Field

Summary

Represents field Py_Malloc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_Malloc : function ( size : NativeInt ) : Pointer;

Field Value

Type: function ( size : NativeInt ) : Pointer

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_NewInterpreter Field

Summary

Represents field Py_NewInterpreter.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_NewInterpreter : function : PPyThreadState; cdecl;

Field Value

Type: function : PPyThreadState; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_None Field

Summary

Represents field Py_None.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_None: PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_NoSiteFlag Field

Summary

Represents field Py_NoSiteFlag.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_NoSiteFlag: PInt;

Field Value

Type: PInt

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_NotImplemented Field

Summary

Represents field Py_NotImplemented.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_NotImplemented: PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_OptimizeFlag Field

Summary

Represents field Py_OptimizeFlag.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_OptimizeFlag: PInt;

Field Value

Type: PInt

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_SetProgramName Field

Summary

Represents field Py_SetProgramName.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_SetProgramName : procedure( name: PAnsiChar); cdecl;

Field Value

Type: procedure( name: PAnsiChar); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_SetProgramName3000 Field

Summary

Represents field Py_SetProgramName3000.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_SetProgramName3000 : procedure( name: PWideChar); cdecl;

Field Value

Type: procedure( name: PWideChar); cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_TabcheckFlag Field

Summary

Represents field Py_TabcheckFlag.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_TabcheckFlag: PInt;

Field Value

Type: PInt

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_True Field

Summary

Represents field Py_True.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_True: PPyIntObject;

Field Value

Type: PPyIntObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_UnicodeFlag Field

Summary

Represents field Py_UnicodeFlag.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_UnicodeFlag: PInt;

Field Value

Type: PInt

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_UseClassExceptionsFlag Field

Summary

Represents field Py_UseClassExceptionsFlag.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_UseClassExceptionsFlag: PInt;

Field Value

Type: PInt

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface.Py_VerboseFlag Field

Summary

Represents field Py_VerboseFlag.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Py_VerboseFlag: PInt;

Field Value

Type: PInt

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface._PyObject_New Field

Summary

Represents field _PyObject_New.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 _PyObject_New:function (obt:PPyTypeObject;ob:PPyObject):PPyObject; cdecl;

Field Value

Type: function (obt:PPyTypeObject;ob:PPyObject):PPyObject; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface._PyString_Resize Field

Summary

Represents field _PyString_Resize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 _PyString_Resize:function (var ob:PPyObject;i:NativeInt):integer; cdecl;

Field Value

Type: function (var ob:PPyObject;i:NativeInt):integer; cdecl

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface._PyWeakref_CallableProxyType Field

Summary

Represents field _PyWeakref_CallableProxyType.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 _PyWeakref_CallableProxyType: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface._PyWeakref_ProxyType Field

Summary

Represents field _PyWeakref_ProxyType.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 _PyWeakref_ProxyType: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonInterface._PyWeakref_RefType Field

Summary

Represents field _PyWeakref_RefType.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 _PyWeakref_RefType: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • TPythonInterface
  • BI.Plugins.Python.Engine


TPythonModule Class

Summary

Represents type TPythonModule.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TComponent
BI.Plugins.Python.Engine.TEngineClient
BI.Plugins.Python.Engine.TMethodsContainer
BI.Plugins.Python.Engine.TPythonModule
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TPythonModule = class(TMethodsContainer)
 end;

The TPythonModule type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TPythonModule class. (Overrides TMethodsContainer.Create(TComponent).)
Destroy | Represents the destructor of the TPythonModule class. (Overrides TMethodsContainer.Destroy.)
Top
Properties
Show:
Name | Description
ClientCount | Represents property ClientCount.
Clients[Integer] | Represents property Clients[Integer].
DocString | Represents property DocString.
Errors | Represents property Errors.
Module | Represents property Module.
ModuleName | Represents property ModuleName.
OnAfterInitialization | Represents property OnAfterInitialization.
Top
Methods
Show:
Name | Description
AddClient(TEngineClient) | Represents method AddClient(TEngineClient).
BuildErrors | Represents method BuildErrors.
DefineDocString | Represents method DefineDocString.
DeleteVar(AnsiString) | Represents method DeleteVar(AnsiString).
ErrorByName(AnsiString) | Represents method ErrorByName(AnsiString).
GetVar(AnsiString) | Represents method GetVar(AnsiString).
GetVarAsVariant(AnsiString) | Represents method GetVarAsVariant(AnsiString).
Initialize | Represents method Initialize. (Overrides TMethodsContainer.Initialize.)
InitializeForNewInterpreter | Represents method InitializeForNewInterpreter.
MakeModule | Represents method MakeModule.
RaiseError(AnsiString,AnsiString) | Represents method RaiseError(AnsiString,AnsiString).
RaiseErrorFmt(AnsiString,AnsiString,TVarRec[]) | Represents method RaiseErrorFmt(AnsiString,AnsiString,TVarRec[]).
RaiseErrorObj(AnsiString,AnsiString,PPyObject) | Represents method RaiseErrorObj(AnsiString,AnsiString,PPyObject).
SetVar(AnsiString,PPyObject) | Represents method SetVar(AnsiString,PPyObject).
SetVarFromVariant(AnsiString,Variant) | Represents method SetVarFromVariant(AnsiString,Variant).
Top
Fields
Show:
Name | Description
FClients | Represents field FClients.
FDocString | Represents field FDocString.
FErrors | Represents field FErrors.
FModule | Represents field FModule.
FModuleName | Represents field FModuleName.
FOnAfterInitialization | Represents field FOnAfterInitialization.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TPythonModule Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TPythonModule class. (Overrides TMethodsContainer.Create(TComponent).)
Destroy | Represents the destructor of the TPythonModule class. (Overrides TMethodsContainer.Destroy.)
Top


TPythonModule.Create(TComponent) Constructor

Summary

Initializes a new instance of the TPythonModule class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 constructor Create( AOwner : TComponent ); override;

Parameters

AOwner
Type: TComponent

Overrides

TMethodsContainer.Create(TComponent)
See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.Destroy Destructor

Summary

Represents the destructor of the TPythonModule class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TMethodsContainer.Destroy
See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule Properties

Properties
Name | Description
ClientCount | Represents property ClientCount.
Clients[Integer] | Represents property Clients[Integer].
DocString | Represents property DocString.
Errors | Represents property Errors.
Module | Represents property Module.
ModuleName | Represents property ModuleName.
OnAfterInitialization | Represents property OnAfterInitialization.
Top


TPythonModule.ClientCount Property

Summary

Represents property ClientCount.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property ClientCount : Integer read GetClientCount;

Property Value

Type: Integer

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.Clients[Integer] Property

Summary

Represents property Clients[Integer].

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property Clients[ idx : Integer ] : TEngineClient read GetClients;

Parameters

idx
Type: Integer

Property Value

Type: TEngineClient

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.DocString Property

Summary

Represents property DocString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property DocString : TStringList read FDocString write SetDocString;

Property Value

Type: TStringList

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.Errors Property

Summary

Represents property Errors.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property Errors : TErrors read FErrors write SetErrors;

Property Value

Type: TErrors

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.Module Property

Summary

Represents property Module.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property Module : PPyObject read FModule;

Property Value

Type: PPyObject

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.ModuleName Property

Summary

Represents property ModuleName.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property ModuleName : AnsiString read FModuleName write SetModuleName;

Property Value

Type: AnsiString

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.OnAfterInitialization Property

Summary

Represents property OnAfterInitialization.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property OnAfterInitialization : TNotifyEvent read FOnAfterInitialization write FOnAfterInitialization;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule Methods

Methods
Name | Description
AddClient(TEngineClient) | Represents method AddClient(TEngineClient).
BuildErrors | Represents method BuildErrors.
DefineDocString | Represents method DefineDocString.
DeleteVar(AnsiString) | Represents method DeleteVar(AnsiString).
ErrorByName(AnsiString) | Represents method ErrorByName(AnsiString).
GetVar(AnsiString) | Represents method GetVar(AnsiString).
GetVarAsVariant(AnsiString) | Represents method GetVarAsVariant(AnsiString).
Initialize | Represents method Initialize. (Overrides TMethodsContainer.Initialize.)
InitializeForNewInterpreter | Represents method InitializeForNewInterpreter.
MakeModule | Represents method MakeModule.
RaiseError(AnsiString,AnsiString) | Represents method RaiseError(AnsiString,AnsiString).
RaiseErrorFmt(AnsiString,AnsiString,TVarRec[]) | Represents method RaiseErrorFmt(AnsiString,AnsiString,TVarRec[]).
RaiseErrorObj(AnsiString,AnsiString,PPyObject) | Represents method RaiseErrorObj(AnsiString,AnsiString,PPyObject).
SetVar(AnsiString,PPyObject) | Represents method SetVar(AnsiString,PPyObject).
SetVarFromVariant(AnsiString,Variant) | Represents method SetVarFromVariant(AnsiString,Variant).
Top


TPythonModule.AddClient(TEngineClient) Method

Summary

Represents method AddClient(TEngineClient).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure AddClient( client : TEngineClient );

Parameters

client
Type: TEngineClient

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.BuildErrors Method

Summary

Represents method BuildErrors.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure BuildErrors;
See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.DefineDocString Method

Summary

Represents method DefineDocString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure DefineDocString;
See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.DeleteVar(AnsiString) Method

Summary

Represents method DeleteVar(AnsiString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure DeleteVar( const varName : AnsiString );

Parameters

varName
Type: AnsiString

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.ErrorByName(AnsiString) Method

Summary

Represents method ErrorByName(AnsiString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function ErrorByName( const AName : AnsiString ) : TError;

Parameters

AName
Type: AnsiString

Return Value

Type: TError

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.GetVar(AnsiString) Method

Summary

Represents method GetVar(AnsiString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function GetVar( const varName : AnsiString ) : PPyObject;

Parameters

varName
Type: AnsiString

Return Value

Type: PPyObject

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.GetVarAsVariant(AnsiString) Method

Summary

Represents method GetVarAsVariant(AnsiString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function GetVarAsVariant( const varName: AnsiString ) : Variant;

Parameters

varName
Type: AnsiString

Return Value

Type: Variant

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.Initialize Method

Summary

Represents method Initialize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Initialize; override;

Overrides

TMethodsContainer.Initialize
See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.InitializeForNewInterpreter Method

Summary

Represents method InitializeForNewInterpreter.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure InitializeForNewInterpreter;
See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.MakeModule Method

Summary

Represents method MakeModule.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure MakeModule;
See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.RaiseError(AnsiString,AnsiString) Method

Summary

Represents method RaiseError(AnsiString,AnsiString).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure RaiseError( const error, msg : AnsiString );

Parameters

error
Type: AnsiString

msg
Type: AnsiString

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.RaiseErrorFmt(AnsiString,AnsiString,TVarRec[]) Method

Summary

Represents method RaiseErrorFmt(AnsiString,AnsiString,TVarRec[]).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure RaiseErrorFmt( const error, format : AnsiString; Args : array of const );

Parameters

error
Type: AnsiString

format
Type: AnsiString

Args
Type: array of const

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.RaiseErrorObj(AnsiString,AnsiString,PPyObject) Method

Summary

Represents method RaiseErrorObj(AnsiString,AnsiString,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure RaiseErrorObj( const error, msg : AnsiString; obj : PPyObject );

Parameters

error
Type: AnsiString

msg
Type: AnsiString

obj
Type: PPyObject

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.SetVar(AnsiString,PPyObject) Method

Summary

Represents method SetVar(AnsiString,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure SetVar( const varName : AnsiString; value : PPyObject );

Parameters

varName
Type: AnsiString

value
Type: PPyObject

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.SetVarFromVariant(AnsiString,Variant) Method

Summary

Represents method SetVarFromVariant(AnsiString,Variant).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure SetVarFromVariant( const varName : AnsiString; const value : Variant );

Parameters

varName
Type: AnsiString

value
Type: Variant

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule Fields

Fields
Name | Description
FClients | Represents field FClients.
FDocString | Represents field FDocString.
FErrors | Represents field FErrors.
FModule | Represents field FModule.
FModuleName | Represents field FModuleName.
FOnAfterInitialization | Represents field FOnAfterInitialization.
Top


TPythonModule.FClients Field

Summary

Represents field FClients.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FClients : TList;

Field Value

Type: TList

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.FDocString Field

Summary

Represents field FDocString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FDocString : TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.FErrors Field

Summary

Represents field FErrors.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FErrors : TErrors;

Field Value

Type: TErrors

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.FModule Field

Summary

Represents field FModule.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FModule : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.FModuleName Field

Summary

Represents field FModuleName.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FModuleName : AnsiString;

Field Value

Type: AnsiString

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonModule.FOnAfterInitialization Field

Summary

Represents field FOnAfterInitialization.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FOnAfterInitialization : TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TPythonModule
  • BI.Plugins.Python.Engine


TPythonThread Class

Summary

Represents type TPythonThread.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TThread
BI.Plugins.Python.Engine.TPythonThread
Syntax
Delphi
type
 TPythonThread = class(TThread)
 end;

The TPythonThread type exposes the following members.

Properties
Show:
Name | Description
InterpreterState | Represents property InterpreterState.
ThreadExecMode | Represents property ThreadExecMode.
ThreadState | Represents property ThreadState.
Top
Methods
Show:
Name | Description
ExecuteWithPython | Represents method ExecuteWithPython.
Py_Begin_Allow_Threads | Represents method Py_Begin_Allow_Threads.
Py_Begin_Block_Threads | Represents method Py_Begin_Block_Threads.
Py_Begin_Unblock_Threads | Represents method Py_Begin_Unblock_Threads.
Py_End_Allow_Threads | Represents method Py_End_Allow_Threads.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TPythonThread Properties

Properties
Name | Description
InterpreterState | Represents property InterpreterState.
ThreadExecMode | Represents property ThreadExecMode.
ThreadState | Represents property ThreadState.
Top


TPythonThread.InterpreterState Property

Summary

Represents property InterpreterState.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property InterpreterState: PPyInterpreterState read fInterpreterState
 write fInterpreterState
 default nil;

Property Value

Type: PPyInterpreterState

See Also

Reference

  • TPythonThread
  • BI.Plugins.Python.Engine


TPythonThread.ThreadExecMode Property

Summary

Represents property ThreadExecMode.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property ThreadExecMode: TThreadExecMode read fThreadExecMode;

Property Value

Type: TThreadExecMode

See Also

Reference

  • TPythonThread
  • BI.Plugins.Python.Engine


TPythonThread.ThreadState Property

Summary

Represents property ThreadState.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property ThreadState: PPyThreadState read fThreadState
 write fThreadState;

Property Value

Type: PPyThreadState

See Also

Reference

  • TPythonThread
  • BI.Plugins.Python.Engine


TPythonThread Methods

Methods
Name | Description
ExecuteWithPython | Represents method ExecuteWithPython.
Py_Begin_Allow_Threads | Represents method Py_Begin_Allow_Threads.
Py_Begin_Block_Threads | Represents method Py_Begin_Block_Threads.
Py_Begin_Unblock_Threads | Represents method Py_Begin_Unblock_Threads.
Py_End_Allow_Threads | Represents method Py_End_Allow_Threads.
Top


TPythonThread.ExecuteWithPython Method

Summary

Represents method ExecuteWithPython.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure ExecuteWithPython; virtual; abstract;
See Also

Reference

  • TPythonThread
  • BI.Plugins.Python.Engine


TPythonThread.Py_Begin_Allow_Threads Method

Summary

Represents method Py_Begin_Allow_Threads.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure Py_Begin_Allow_Threads;
See Also

Reference

  • TPythonThread
  • BI.Plugins.Python.Engine


TPythonThread.Py_Begin_Block_Threads Method

Summary

Represents method Py_Begin_Block_Threads.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure Py_Begin_Block_Threads;
See Also

Reference

  • TPythonThread
  • BI.Plugins.Python.Engine


TPythonThread.Py_Begin_Unblock_Threads Method

Summary

Represents method Py_Begin_Unblock_Threads.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure Py_Begin_Unblock_Threads;
See Also

Reference

  • TPythonThread
  • BI.Plugins.Python.Engine


TPythonThread.Py_End_Allow_Threads Method

Summary

Represents method Py_End_Allow_Threads.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure Py_End_Allow_Threads;
See Also

Reference

  • TPythonThread
  • BI.Plugins.Python.Engine


TPythonTraceback Class

Summary

Represents type TPythonTraceback.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TObject
BI.Plugins.Python.Engine.TPythonTraceback
Syntax
Delphi
type
 TPythonTraceback = class
 end;

The TPythonTraceback type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TPythonTraceback class.
Destroy | Represents the destructor of the TPythonTraceback class.
Top
Properties
Show:
Name | Description
ItemCount | Represents property ItemCount.
Items[Integer] | Represents property Items[Integer].
Limit | Represents property Limit.
Top
Methods
Show:
Name | Description
Clear | Represents method Clear.
Refresh | Represents method Refresh.
Top
Fields
Show:
Name | Description
FItems | Represents field FItems.
FLimit | Represents field FLimit.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TPythonTraceback Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TPythonTraceback class.
Destroy | Represents the destructor of the TPythonTraceback class.
Top


TPythonTraceback.Create Constructor

Summary

Initializes a new instance of the TPythonTraceback class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TPythonTraceback
  • BI.Plugins.Python.Engine


TPythonTraceback.Destroy Destructor

Summary

Represents the destructor of the TPythonTraceback class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TPythonTraceback
  • BI.Plugins.Python.Engine


TPythonTraceback Properties

Properties
Name | Description
ItemCount | Represents property ItemCount.
Items[Integer] | Represents property Items[Integer].
Limit | Represents property Limit.
Top


TPythonTraceback.ItemCount Property

Summary

Represents property ItemCount.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property ItemCount : Integer read GetItemCount;

Property Value

Type: Integer

See Also

Reference

  • TPythonTraceback
  • BI.Plugins.Python.Engine


TPythonTraceback.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property Items[ idx : Integer ] : TTracebackItem read GetItem;

Parameters

idx
Type: Integer

Property Value

Type: TTracebackItem

See Also

Reference

  • TPythonTraceback
  • BI.Plugins.Python.Engine


TPythonTraceback.Limit Property

Summary

Represents property Limit.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property Limit : Integer read FLimit write FLimit;

Property Value

Type: Integer

See Also

Reference

  • TPythonTraceback
  • BI.Plugins.Python.Engine


TPythonTraceback Methods

Methods
Name | Description
Clear | Represents method Clear.
Refresh | Represents method Refresh.
Top


TPythonTraceback.Clear Method

Summary

Represents method Clear.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TPythonTraceback
  • BI.Plugins.Python.Engine


TPythonTraceback.Refresh Method

Summary

Represents method Refresh.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Refresh;
See Also

Reference

  • TPythonTraceback
  • BI.Plugins.Python.Engine


TPythonTraceback Fields

Fields
Name | Description
FItems | Represents field FItems.
FLimit | Represents field FLimit.
Top


TPythonTraceback.FItems Field

Summary

Represents field FItems.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FItems : TList;

Field Value

Type: TList

See Also

Reference

  • TPythonTraceback
  • BI.Plugins.Python.Engine


TPythonTraceback.FLimit Field

Summary

Represents field FLimit.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FLimit : Integer;

Field Value

Type: Integer

See Also

Reference

  • TPythonTraceback
  • BI.Plugins.Python.Engine


TPythonType Class

Summary

Represents type TPythonType.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TComponent
BI.Plugins.Python.Engine.TEngineClient
BI.Plugins.Python.Engine.TMethodsContainer
BI.Plugins.Python.Engine.TMembersContainer
BI.Plugins.Python.Engine.TGetSetContainer
BI.Plugins.Python.Engine.TPythonType
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64)]
 TPythonType = class(TGetSetContainer)
 end;

The TPythonType type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TPythonType class. (Overrides TGetSetContainer.Create(TComponent).)
Destroy | Represents the destructor of the TPythonType class. (Overrides TGetSetContainer.Destroy.)
Top
Properties
Show:
Name | Description
CreateHits | Represents property CreateHits.
DeleteHits | Represents property DeleteHits.
DocString | Represents property DocString.
GenerateCreateFunction | Represents property GenerateCreateFunction.
InstanceCount | Represents property InstanceCount.
Module | Represents property Module.
Prefix | Represents property Prefix.
PyObjectClass | Represents property PyObjectClass.
Services | Represents property Services.
TheType | Represents property TheType.
TheTypePtr | Represents property TheTypePtr.
TypeFlags | Represents property TypeFlags.
TypeName | Represents property TypeName.
Top
Methods
Show:
Name | Description
AddTypeVar | Represents method AddTypeVar.
CreateInstance | Represents method CreateInstance.
CreateInstanceWith(PPyObject) | Represents method CreateInstanceWith(PPyObject).
CreateMethod(PPyObject,PPyObject) | Represents method CreateMethod(PPyObject,PPyObject).
Finalize | Represents method Finalize. (Overrides TGetSetContainer.Finalize.)
GetMembersStartOffset | Represents method GetMembersStartOffset. (Overrides TMembersContainer.GetMembersStartOffset.)
Initialize | Represents method Initialize. (Overrides TMethodsContainer.Initialize.)
InitServices | Represents method InitServices.
ModuleReady(TObject) | Represents method ModuleReady(TObject). (Overrides TEngineClient.ModuleReady(TObject).)
NewSubtypeInst(PPyTypeObject,PPyObject,PPyObject) |
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TEngineClient.Notification(TComponent,TOperation).)
ReallocGetSets | Represents method ReallocGetSets. (Overrides TGetSetContainer.ReallocGetSets.)
ReallocMembers | Represents method ReallocMembers. (Overrides TMembersContainer.ReallocMembers.)
ReallocMethods | Represents method ReallocMethods. (Overrides TMethodsContainer.ReallocMethods.)
TypeFlagsAsInt | Represents method TypeFlagsAsInt.
Top
Fields
Show:
Name | Description
FCreateFunc | Represents field FCreateFunc.
FCreateFuncDef | Represents field FCreateFuncDef.
FCreateFuncDoc | Represents field FCreateFuncDoc.
FCreateFuncName | Represents field FCreateFuncName.
FCreateHits | Represents field FCreateHits.
FCurrentDocString | Represents field FCurrentDocString.
FDeleteHits | Represents field FDeleteHits.
FDocString | Represents field FDocString.
FGenerateCreateFunction | Represents field FGenerateCreateFunction.
FInstanceCount | Represents field FInstanceCount.
FMapping | Represents field FMapping.
FModule | Represents field FModule.
FNumber | Represents field FNumber.
FPrefix | Represents field FPrefix.
FPyObjectClass | Represents field FPyObjectClass.
FSequence | Represents field FSequence.
FServices | Represents field FServices.
FType | Represents field FType.
FTypeFlags | Represents field FTypeFlags.
FTypeName | Represents field FTypeName.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TPythonType class. (Overrides TGetSetContainer.Create(TComponent).)
Destroy | Represents the destructor of the TPythonType class. (Overrides TGetSetContainer.Destroy.)
Top


TPythonType.Create(TComponent) Constructor

Summary

Initializes a new instance of the TPythonType class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 constructor Create( AOwner : TComponent ); override;

Parameters

AOwner
Type: TComponent

Overrides

TGetSetContainer.Create(TComponent)
See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.Destroy Destructor

Summary

Represents the destructor of the TPythonType class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TGetSetContainer.Destroy
See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType Properties

Properties
Name | Description
CreateHits | Represents property CreateHits.
DeleteHits | Represents property DeleteHits.
DocString | Represents property DocString.
GenerateCreateFunction | Represents property GenerateCreateFunction.
InstanceCount | Represents property InstanceCount.
Module | Represents property Module.
Prefix | Represents property Prefix.
PyObjectClass | Represents property PyObjectClass.
Services | Represents property Services.
TheType | Represents property TheType.
TheTypePtr | Represents property TheTypePtr.
TypeFlags | Represents property TypeFlags.
TypeName | Represents property TypeName.
Top


TPythonType.CreateHits Property

Summary

Represents property CreateHits.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property CreateHits : Integer read FCreateHits;

Property Value

Type: Integer

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.DeleteHits Property

Summary

Represents property DeleteHits.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property DeleteHits : Integer read FDeleteHits;

Property Value

Type: Integer

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.DocString Property

Summary

Represents property DocString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property DocString : TStringList read FDocString write SetDocString;

Property Value

Type: TStringList

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.GenerateCreateFunction Property

Summary

Represents property GenerateCreateFunction.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property GenerateCreateFunction : Boolean read fGenerateCreateFunction write fGenerateCreateFunction default True;

Property Value

Type: Boolean

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.InstanceCount Property

Summary

Represents property InstanceCount.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property InstanceCount : Integer read FInstanceCount;

Property Value

Type: Integer

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.Module Property

Summary

Represents property Module.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property Module : TPythonModule read FModule write SetModule;

Property Value

Type: TPythonModule

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.Prefix Property

Summary

Represents property Prefix.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property Prefix : AnsiString read FPrefix write FPrefix;

Property Value

Type: AnsiString

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.PyObjectClass Property

Summary

Represents property PyObjectClass.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property PyObjectClass : TPyObjectClass read FPyObjectClass write SetPyObjectClass stored False;

Property Value

Type: TPyObjectClass

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.Services Property

Summary

Represents property Services.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property Services : TTypeServices read FServices write SetServices;

Property Value

Type: TTypeServices

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.TheType Property

Summary

Represents property TheType.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property TheType : PyTypeObject read FType write FType;

Property Value

Type: PyTypeObject

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.TheTypePtr Property

Summary

Represents property TheTypePtr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 property TheTypePtr : PPyTypeObject read GetTypePtr;

Property Value

Type: PPyTypeObject

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.TypeFlags Property

Summary

Represents property TypeFlags.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property TypeFlags : TPFlags read FTypeFlags write FTypeFlags default TPFLAGS_DEFAULT;

Property Value

Type: TPFlags

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.TypeName Property

Summary

Represents property TypeName.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property TypeName : AnsiString read FTypeName write SetTypeName;

Property Value

Type: AnsiString

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType Methods

Methods
Name | Description
AddTypeVar | Represents method AddTypeVar.
CreateInstance | Represents method CreateInstance.
CreateInstanceWith(PPyObject) | Represents method CreateInstanceWith(PPyObject).
CreateMethod(PPyObject,PPyObject) | Represents method CreateMethod(PPyObject,PPyObject).
Finalize | Represents method Finalize. (Overrides TGetSetContainer.Finalize.)
GetMembersStartOffset | Represents method GetMembersStartOffset. (Overrides TMembersContainer.GetMembersStartOffset.)
Initialize | Represents method Initialize. (Overrides TMethodsContainer.Initialize.)
InitServices | Represents method InitServices.
ModuleReady(TObject) | Represents method ModuleReady(TObject). (Overrides TEngineClient.ModuleReady(TObject).)
NewSubtypeInst(PPyTypeObject,PPyObject,PPyObject) |
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation). (Overrides TEngineClient.Notification(TComponent,TOperation).)
ReallocGetSets | Represents method ReallocGetSets. (Overrides TGetSetContainer.ReallocGetSets.)
ReallocMembers | Represents method ReallocMembers. (Overrides TMembersContainer.ReallocMembers.)
ReallocMethods | Represents method ReallocMethods. (Overrides TMethodsContainer.ReallocMethods.)
TypeFlagsAsInt | Represents method TypeFlagsAsInt.
Top


TPythonType.AddTypeVar Method

Summary

Represents method AddTypeVar.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure AddTypeVar;
See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.CreateInstance Method

Summary

Represents method CreateInstance.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function CreateInstance : PPyObject;

Return Value

Type: PPyObject

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.CreateInstanceWith(PPyObject) Method

Summary

Represents method CreateInstanceWith(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function CreateInstanceWith( args : PPyObject ) : PPyObject;

Parameters

args
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.CreateMethod(PPyObject,PPyObject) Method

Summary

Represents method CreateMethod(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 function CreateMethod( pSelf, args : PPyObject ) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

args
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.Finalize Method

Summary

Represents method Finalize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Finalize; override;

Overrides

TGetSetContainer.Finalize
See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.GetMembersStartOffset Method

Summary

Represents method GetMembersStartOffset.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 function GetMembersStartOffset : Integer; override;

Return Value

Type: Integer

Overrides

TMembersContainer.GetMembersStartOffset
See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.Initialize Method

Summary

Represents method Initialize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure Initialize; override;

Overrides

TMethodsContainer.Initialize
See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.InitServices Method

Summary

Represents method InitServices.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure InitServices;
See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.ModuleReady(TObject) Method

Summary

Represents method ModuleReady(TObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure ModuleReady(Sender : TObject); override;

Parameters

Sender
Type: TObject

Overrides

TEngineClient.ModuleReady(TObject)
See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.NewSubtypeInst(PPyTypeObject,PPyObject,PPyObject) Method

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 function NewSubtypeInst( aType: PPyTypeObject; args, kwds : PPyObject) : PPyObject; cdecl;

Parameters

aType
Type: PPyTypeObject

args
Type: PPyObject

kwds
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure Notification( AComponent: TComponent;
 Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

Overrides

TEngineClient.Notification(TComponent,TOperation)
See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.ReallocGetSets Method

Summary

Represents method ReallocGetSets.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure ReallocGetSets; override;

Overrides

TGetSetContainer.ReallocGetSets
See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.ReallocMembers Method

Summary

Represents method ReallocMembers.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure ReallocMembers; override;

Overrides

TMembersContainer.ReallocMembers
See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.ReallocMethods Method

Summary

Represents method ReallocMethods.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 procedure ReallocMethods; override;

Overrides

TMethodsContainer.ReallocMethods
See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.TypeFlagsAsInt Method

Summary

Represents method TypeFlagsAsInt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 function TypeFlagsAsInt : LongInt;

Return Value

Type: LongInt

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType Fields

Fields
Name | Description
FCreateFunc | Represents field FCreateFunc.
FCreateFuncDef | Represents field FCreateFuncDef.
FCreateFuncDoc | Represents field FCreateFuncDoc.
FCreateFuncName | Represents field FCreateFuncName.
FCreateHits | Represents field FCreateHits.
FCurrentDocString | Represents field FCurrentDocString.
FDeleteHits | Represents field FDeleteHits.
FDocString | Represents field FDocString.
FGenerateCreateFunction | Represents field FGenerateCreateFunction.
FInstanceCount | Represents field FInstanceCount.
FMapping | Represents field FMapping.
FModule | Represents field FModule.
FNumber | Represents field FNumber.
FPrefix | Represents field FPrefix.
FPyObjectClass | Represents field FPyObjectClass.
FSequence | Represents field FSequence.
FServices | Represents field FServices.
FType | Represents field FType.
FTypeFlags | Represents field FTypeFlags.
FTypeName | Represents field FTypeName.
Top


TPythonType.FCreateFunc Field

Summary

Represents field FCreateFunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FCreateFunc : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.FCreateFuncDef Field

Summary

Represents field FCreateFuncDef.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FCreateFuncDef : PyMethodDef;

Field Value

Type: PyMethodDef

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.FCreateFuncDoc Field

Summary

Represents field FCreateFuncDoc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FCreateFuncDoc : AnsiString;

Field Value

Type: AnsiString

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.FCreateFuncName Field

Summary

Represents field FCreateFuncName.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FCreateFuncName : AnsiString;

Field Value

Type: AnsiString

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.FCreateHits Field

Summary

Represents field FCreateHits.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FCreateHits : Integer;

Field Value

Type: Integer

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.FCurrentDocString Field

Summary

Represents field FCurrentDocString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FCurrentDocString: AnsiString;

Field Value

Type: AnsiString

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.FDeleteHits Field

Summary

Represents field FDeleteHits.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FDeleteHits : Integer;

Field Value

Type: Integer

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.FDocString Field

Summary

Represents field FDocString.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FDocString: TStringList;

Field Value

Type: TStringList

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.FGenerateCreateFunction Field

Summary

Represents field FGenerateCreateFunction.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FGenerateCreateFunction: Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.FInstanceCount Field

Summary

Represents field FInstanceCount.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FInstanceCount : Integer;

Field Value

Type: Integer

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.FMapping Field

Summary

Represents field FMapping.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FMapping: PyMappingMethods;

Field Value

Type: PyMappingMethods

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.FModule Field

Summary

Represents field FModule.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FModule : TPythonModule;

Field Value

Type: TPythonModule

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.FNumber Field

Summary

Represents field FNumber.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FNumber: PyNumberMethods;

Field Value

Type: PyNumberMethods

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.FPrefix Field

Summary

Represents field FPrefix.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FPrefix : AnsiString;

Field Value

Type: AnsiString

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.FPyObjectClass Field

Summary

Represents field FPyObjectClass.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FPyObjectClass : TPyObjectClass;

Field Value

Type: TPyObjectClass

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.FSequence Field

Summary

Represents field FSequence.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FSequence: PySequenceMethods;

Field Value

Type: PySequenceMethods

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.FServices Field

Summary

Represents field FServices.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FServices : TTypeServices;

Field Value

Type: TTypeServices

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.FType Field

Summary

Represents field FType.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FType : PyTypeObject;

Field Value

Type: PyTypeObject

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.FTypeFlags Field

Summary

Represents field FTypeFlags.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FTypeFlags : TPFlags;

Field Value

Type: TPFlags

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPythonType.FTypeName Field

Summary

Represents field FTypeName.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FTypeName : AnsiString;

Field Value

Type: AnsiString

See Also

Reference

  • TPythonType
  • BI.Plugins.Python.Engine


TPyVar Class

Summary

Represents type TPyVar.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TObject
BI.Plugins.Python.Engine.TPyObject
BI.Plugins.Python.Engine.TPyVar
Syntax
Delphi
type
 TPyVar = class(TPyObject)
 end;

The TPyVar type exposes the following members.

Constructors
Show:
Name | Description
Create(TPythonType) | Initializes a new instance of the TPyVar class. (Overrides TPyObject.Create(TPythonType).)
CreateWith(TPythonType,PPyObject) | Initializes a new instance of the TPyVar class. (Overrides TPyObject.CreateWith(TPythonType,PPyObject).)
Destroy | Represents the destructor of the TPyVar class. (Overrides TPyObject.Destroy.)
Top
Methods
Show:
Name | Description
GetAttr(PAnsiChar) | (Overrides TPyObject.GetAttr(PAnsiChar).)
GetValue | Represents method GetValue.
GetValueAsVariant | Represents method GetValueAsVariant.
RegisterMethods(TPythonType) | Represents method RegisterMethods(TPythonType). (Overrides TPyObject.RegisterMethods(TPythonType).)
Repr | Represents method Repr. (Overrides TPyObject.Repr.)
SetAttr(PAnsiChar,PPyObject) | Represents method SetAttr(PAnsiChar,PPyObject). (Overrides TPyObject.SetAttr(PAnsiChar,PPyObject).)
SetValue(PPyObject) | Represents method SetValue(PPyObject).
SetValueFromVariant(Variant) | Represents method SetValueFromVariant(Variant).
Top
Fields
Show:
Name | Description
dv_component | Represents field dv_component.
dv_object | Represents field dv_object.
dv_var | Represents field dv_var.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TPyVar Constructors

Constructors
Name | Description
Create(TPythonType) | Initializes a new instance of the TPyVar class. (Overrides TPyObject.Create(TPythonType).)
CreateWith(TPythonType,PPyObject) | Initializes a new instance of the TPyVar class. (Overrides TPyObject.CreateWith(TPythonType,PPyObject).)
Destroy | Represents the destructor of the TPyVar class. (Overrides TPyObject.Destroy.)
Top


TPyVar.Create(TPythonType) Constructor

Summary

Initializes a new instance of the TPyVar class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 constructor Create( APythonType : TPythonType ); override;

Parameters

APythonType
Type: TPythonType

Overrides

TPyObject.Create(TPythonType)
See Also

Reference

  • TPyVar
  • BI.Plugins.Python.Engine


TPyVar.CreateWith(TPythonType,PPyObject) Constructor

Summary

Initializes a new instance of the TPyVar class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 constructor CreateWith( APythonType : TPythonType; args : PPyObject ); override;

Parameters

APythonType
Type: TPythonType

args
Type: PPyObject

Overrides

TPyObject.CreateWith(TPythonType,PPyObject)
See Also

Reference

  • TPyVar
  • BI.Plugins.Python.Engine


TPyVar.Destroy Destructor

Summary

Represents the destructor of the TPyVar class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 destructor Destroy; override;

Overrides

TPyObject.Destroy
See Also

Reference

  • TPyVar
  • BI.Plugins.Python.Engine


TPyVar Methods

Methods
Name | Description
GetAttr(PAnsiChar) | (Overrides TPyObject.GetAttr(PAnsiChar).)
GetValue | Represents method GetValue.
GetValueAsVariant | Represents method GetValueAsVariant.
RegisterMethods(TPythonType) | Represents method RegisterMethods(TPythonType). (Overrides TPyObject.RegisterMethods(TPythonType).)
Repr | Represents method Repr. (Overrides TPyObject.Repr.)
SetAttr(PAnsiChar,PPyObject) | Represents method SetAttr(PAnsiChar,PPyObject). (Overrides TPyObject.SetAttr(PAnsiChar,PPyObject).)
SetValue(PPyObject) | Represents method SetValue(PPyObject).
SetValueFromVariant(Variant) | Represents method SetValueFromVariant(Variant).
Top


TPyVar.GetAttr(PAnsiChar) Method

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function GetAttr(key : PAnsiChar) : PPyObject; override;

Parameters

key
Type: PAnsiChar

Return Value

Type: PPyObject

Overrides

TPyObject.GetAttr(PAnsiChar)
See Also

Reference

  • TPyVar
  • BI.Plugins.Python.Engine


TPyVar.GetValue Method

Summary

Represents method GetValue.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function GetValue : PPyObject;

Return Value

Type: PPyObject

See Also

Reference

  • TPyVar
  • BI.Plugins.Python.Engine


TPyVar.GetValueAsVariant Method

Summary

Represents method GetValueAsVariant.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function GetValueAsVariant : Variant;

Return Value

Type: Variant

See Also

Reference

  • TPyVar
  • BI.Plugins.Python.Engine


TPyVar.RegisterMethods(TPythonType) Method

Summary

Represents method RegisterMethods(TPythonType).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 class procedure RegisterMethods( APythonType : TPythonType ); override;

Parameters

APythonType
Type: TPythonType

Overrides

TPyObject.RegisterMethods(TPythonType)
See Also

Reference

  • TPyVar
  • BI.Plugins.Python.Engine


TPyVar.Repr Method

Summary

Represents method Repr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function Repr : PPyObject; override;

Return Value

Type: PPyObject

Overrides

TPyObject.Repr
See Also

Reference

  • TPyVar
  • BI.Plugins.Python.Engine


TPyVar.SetAttr(PAnsiChar,PPyObject) Method

Summary

Represents method SetAttr(PAnsiChar,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 function SetAttr(key : PAnsiChar; value : PPyObject) : Integer; override;

Parameters

key
Type: PAnsiChar

value
Type: PPyObject

Return Value

Type: Integer

Overrides

TPyObject.SetAttr(PAnsiChar,PPyObject)
See Also

Reference

  • TPyVar
  • BI.Plugins.Python.Engine


TPyVar.SetValue(PPyObject) Method

Summary

Represents method SetValue(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure SetValue( value : PPyObject );

Parameters

value
Type: PPyObject

See Also

Reference

  • TPyVar
  • BI.Plugins.Python.Engine


TPyVar.SetValueFromVariant(Variant) Method

Summary

Represents method SetValueFromVariant(Variant).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure SetValueFromVariant( const value : Variant );

Parameters

value
Type: Variant

See Also

Reference

  • TPyVar
  • BI.Plugins.Python.Engine


TPyVar Fields

Fields
Name | Description
dv_component | Represents field dv_component.
dv_object | Represents field dv_object.
dv_var | Represents field dv_var.
Top


TPyVar.dv_component Field

Summary

Represents field dv_component.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 dv_component : TPythonDelphiVar;

Field Value

Type: TPythonDelphiVar

See Also

Reference

  • TPyVar
  • BI.Plugins.Python.Engine


TPyVar.dv_object Field

Summary

Represents field dv_object.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 dv_object : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • TPyVar
  • BI.Plugins.Python.Engine


TPyVar.dv_var Field

Summary

Represents field dv_var.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 dv_var : Variant;

Field Value

Type: Variant

See Also

Reference

  • TPyVar
  • BI.Plugins.Python.Engine


TTracebackItem Class

Summary

Represents type TTracebackItem.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TObject
BI.Plugins.Python.Engine.TTracebackItem
Syntax
Delphi
type
 TTracebackItem = class
 end;

The TTracebackItem type exposes the following members.

Fields
Show:
Name | Description
Context | Represents field Context.
FileName | Represents field FileName.
LineNo | Represents field LineNo.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TTracebackItem Fields

Fields
Name | Description
Context | Represents field Context.
FileName | Represents field FileName.
LineNo | Represents field LineNo.
Top


TTracebackItem.Context Field

Summary

Represents field Context.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Context : String;

Field Value

Type: String

See Also

Reference

  • TTracebackItem
  • BI.Plugins.Python.Engine


TTracebackItem.FileName Field

Summary

Represents field FileName.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 FileName : String;

Field Value

Type: String

See Also

Reference

  • TTracebackItem
  • BI.Plugins.Python.Engine


TTracebackItem.LineNo Field

Summary

Represents field LineNo.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 LineNo : Integer;

Field Value

Type: Integer

See Also

Reference

  • TTracebackItem
  • BI.Plugins.Python.Engine


TTypeServices Class

Summary

Represents type TTypeServices.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
TPersistent
BI.Plugins.Python.Engine.TTypeServices
Syntax
Delphi
type
 TTypeServices = class(TPersistent)
 end;

The TTypeServices type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TTypeServices class.
Top
Properties
Show:
Name | Description
Basic | Represents property Basic.
InplaceNumber | Represents property InplaceNumber.
Mapping | Represents property Mapping.
Number | Represents property Number.
Sequence | Represents property Sequence.
Top
Methods
Show:
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
Top
Fields
Show:
Name | Description
FBasic | Represents field FBasic.
FInplaceNumber | Represents field FInplaceNumber.
FMapping | Represents field FMapping.
FNumber | Represents field FNumber.
FSequence | Represents field FSequence.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TTypeServices Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TTypeServices class.
Top


TTypeServices.Create Constructor

Summary

Initializes a new instance of the TTypeServices class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 constructor Create;
See Also

Reference

  • TTypeServices
  • BI.Plugins.Python.Engine


TTypeServices Properties

Properties
Name | Description
Basic | Represents property Basic.
InplaceNumber | Represents property InplaceNumber.
Mapping | Represents property Mapping.
Number | Represents property Number.
Sequence | Represents property Sequence.
Top


TTypeServices.Basic Property

Summary

Represents property Basic.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property Basic : TBasicServices read FBasic write FBasic;

Property Value

Type: TBasicServices

See Also

Reference

  • TTypeServices
  • BI.Plugins.Python.Engine


TTypeServices.InplaceNumber Property

Summary

Represents property InplaceNumber.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property InplaceNumber : TInplaceNumberServices read FInplaceNumber Write FInplaceNumber;

Property Value

Type: TInplaceNumberServices

See Also

Reference

  • TTypeServices
  • BI.Plugins.Python.Engine


TTypeServices.Mapping Property

Summary

Represents property Mapping.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property Mapping : TMappingServices read FMapping write FMapping;

Property Value

Type: TMappingServices

See Also

Reference

  • TTypeServices
  • BI.Plugins.Python.Engine


TTypeServices.Number Property

Summary

Represents property Number.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property Number : TNumberServices read FNumber write FNumber;

Property Value

Type: TNumberServices

See Also

Reference

  • TTypeServices
  • BI.Plugins.Python.Engine


TTypeServices.Sequence Property

Summary

Represents property Sequence.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
published
 property Sequence : TSequenceServices read FSequence write FSequence;

Property Value

Type: TSequenceServices

See Also

Reference

  • TTypeServices
  • BI.Plugins.Python.Engine


TTypeServices Methods

Methods
Name | Description
AssignTo(TPersistent) | Represents method AssignTo(TPersistent).
Top


TTypeServices.AssignTo(TPersistent) Method

Summary

Represents method AssignTo(TPersistent).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 procedure AssignTo( Dest: TPersistent ); override;

Parameters

Dest
Type: TPersistent

See Also

Reference

  • TTypeServices
  • BI.Plugins.Python.Engine


TTypeServices Fields

Fields
Name | Description
FBasic | Represents field FBasic.
FInplaceNumber | Represents field FInplaceNumber.
FMapping | Represents field FMapping.
FNumber | Represents field FNumber.
FSequence | Represents field FSequence.
Top


TTypeServices.FBasic Field

Summary

Represents field FBasic.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FBasic : TBasicServices;

Field Value

Type: TBasicServices

See Also

Reference

  • TTypeServices
  • BI.Plugins.Python.Engine


TTypeServices.FInplaceNumber Field

Summary

Represents field FInplaceNumber.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FInplaceNumber : TInplaceNumberServices;

Field Value

Type: TInplaceNumberServices

See Also

Reference

  • TTypeServices
  • BI.Plugins.Python.Engine


TTypeServices.FMapping Field

Summary

Represents field FMapping.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FMapping : TMappingServices;

Field Value

Type: TMappingServices

See Also

Reference

  • TTypeServices
  • BI.Plugins.Python.Engine


TTypeServices.FNumber Field

Summary

Represents field FNumber.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FNumber : TNumberServices;

Field Value

Type: TNumberServices

See Also

Reference

  • TTypeServices
  • BI.Plugins.Python.Engine


TTypeServices.FSequence Field

Summary

Represents field FSequence.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
protected
 FSequence : TSequenceServices;

Field Value

Type: TSequenceServices

See Also

Reference

  • TTypeServices
  • BI.Plugins.Python.Engine


UnicodeDecodeError Class

Summary

Represents type UnicodeDecodeError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyValueError
BI.Plugins.Python.Engine.EPyUnicodeError
BI.Plugins.Python.Engine.UnicodeDecodeError
Syntax
Delphi
type
 UnicodeDecodeError = class (EPyUnicodeError);
See Also

Reference

  • BI.Plugins.Python.Engine


UnicodeEncodeError Class

Summary

Represents type UnicodeEncodeError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyValueError
BI.Plugins.Python.Engine.EPyUnicodeError
BI.Plugins.Python.Engine.UnicodeEncodeError
Syntax
Delphi
type
 UnicodeEncodeError = class (EPyUnicodeError);
See Also

Reference

  • BI.Plugins.Python.Engine


UnicodeTranslateError Class

Summary

Represents type UnicodeTranslateError.

Namespace: BI.Plugins.Python.Engine
Inheritance Hierarchy
Exception
BI.Plugins.Python.Engine.EPythonError
BI.Plugins.Python.Engine.EPyException
BI.Plugins.Python.Engine.EPyStandardError
BI.Plugins.Python.Engine.EPyValueError
BI.Plugins.Python.Engine.EPyUnicodeError
BI.Plugins.Python.Engine.UnicodeTranslateError
Syntax
Delphi
type
 UnicodeTranslateError = class (EPyUnicodeError);
See Also

Reference

  • BI.Plugins.Python.Engine


BI.Plugins.Python.Engine Records

Records
Name | Description
node | Represents type node.
PyBufferProcs |
PyClassObject | Represents type PyClassObject.
PyCodeObject | Represents type PyCodeObject.
PyDateTime_Date | Represents type PyDateTime_Date.
PyDateTime_DateTime | Represents type PyDateTime_DateTime.
PyDateTime_Delta | Represents type PyDateTime_Delta.
PyDateTime_Time | Represents type PyDateTime_Time.
PyDateTime_TZInfo | Represents type PyDateTime_TZInfo.
PyDescrObject | Represents type PyDescrObject.
PyFrameObject | Represents type PyFrameObject.
PyGetSetDef | Represents type PyGetSetDef.
PyGetSetDescrObject | Represents type PyGetSetDescrObject.
PyInstanceObject | Represents type PyInstanceObject.
PyInterpreterState | Represents type PyInterpreterState.
PyIntObject | Represents type PyIntObject.
PyMappingMethods | Represents type PyMappingMethods.
PyMemberDef | Represents type PyMemberDef.
PyMemberDescrObject | Represents type PyMemberDescrObject.
PyMethodChain | Represents type PyMethodChain.
PyMethodDef | Represents type PyMethodDef.
PyMethodDescrObject | Represents type PyMethodDescrObject.
PyMethodObject | Represents type PyMethodObject.
PyModuleDef | Represents type PyModuleDef.
PyModuleDef_Base | Represents type PyModuleDef_Base.
PyNumberMethods | Represents type PyNumberMethods.
PyObject | Represents type PyObject.
PySequenceMethods | Represents type PySequenceMethods.
PySliceObject | Represents type PySliceObject.
PyThreadState | Represents type PyThreadState.
PyTraceBackObject | Represents type PyTraceBackObject.
PyTryBlock | Represents type PyTryBlock.
PyTypeObject | Represents type PyTypeObject.
PyWeakReference | Represents type PyWeakReference.
PyWrapperDescrObject | Represents type PyWrapperDescrObject.
Py_complex | Represents type Py_complex.
TCodeMemBlock | Represents type TCodeMemBlock.
TCodeMemPage | Represents type TCodeMemPage.
TPythonVersionProp | Represents type TPythonVersionProp.
wrapperbase | Represents type wrapperbase.
_frozen | Represents type _frozen.
_PyDateTime_BaseDateTime | Represents type _PyDateTime_BaseDateTime.
_PyDateTime_BaseTime | Represents type _PyDateTime_BaseTime.
_PyDateTime_BaseTZInfo | Represents type _PyDateTime_BaseTZInfo.
Top


node Record

Summary

Represents type node.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 node = packed record
 end;

The node type exposes the following members.

Fields
Show:
Name | Description
n_child | Represents field n_child.
n_col_offset | Represents field n_col_offset.
n_lineno | Represents field n_lineno.
n_nchildren | Represents field n_nchildren.
n_str | Represents field n_str.
n_type | Represents field n_type.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


node Fields

Fields
Name | Description
n_child | Represents field n_child.
n_col_offset | Represents field n_col_offset.
n_lineno | Represents field n_lineno.
n_nchildren | Represents field n_nchildren.
n_str | Represents field n_str.
n_type | Represents field n_type.
Top


node.n_child Field

Summary

Represents field n_child.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 n_child : PNode;

Field Value

Type: PNode

See Also

Reference

  • node
  • BI.Plugins.Python.Engine


node.n_col_offset Field

Summary

Represents field n_col_offset.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 n_col_offset: integer;

Field Value

Type: integer

See Also

Reference

  • node
  • BI.Plugins.Python.Engine


node.n_lineno Field

Summary

Represents field n_lineno.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 n_lineno : integer;

Field Value

Type: integer

See Also

Reference

  • node
  • BI.Plugins.Python.Engine


node.n_nchildren Field

Summary

Represents field n_nchildren.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 n_nchildren : integer;

Field Value

Type: integer

See Also

Reference

  • node
  • BI.Plugins.Python.Engine


node.n_str Field

Summary

Represents field n_str.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 n_str : PAnsiChar;

Field Value

Type: PAnsiChar

See Also

Reference

  • node
  • BI.Plugins.Python.Engine


node.n_type Field

Summary

Represents field n_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 n_type : smallint;

Field Value

Type: smallint

See Also

Reference

  • node
  • BI.Plugins.Python.Engine


PyBufferProcs Record

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyBufferProcs = packed record
 end;

The PyBufferProcs type exposes the following members.

Fields
Show:
Name | Description
bf_getcharbuffer | Represents field bf_getcharbuffer.
bf_getreadbuffer | Represents field bf_getreadbuffer.
bf_getsegcount | Represents field bf_getsegcount.
bf_getwritebuffer | Represents field bf_getwritebuffer.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyBufferProcs Fields

Fields
Name | Description
bf_getcharbuffer | Represents field bf_getcharbuffer.
bf_getreadbuffer | Represents field bf_getreadbuffer.
bf_getsegcount | Represents field bf_getsegcount.
bf_getwritebuffer | Represents field bf_getwritebuffer.
Top


PyBufferProcs.bf_getcharbuffer Field

Summary

Represents field bf_getcharbuffer.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 bf_getcharbuffer : getcharbufferproc;

Field Value

Type: getcharbufferproc

See Also

Reference

  • PyBufferProcs
  • BI.Plugins.Python.Engine


PyBufferProcs.bf_getreadbuffer Field

Summary

Represents field bf_getreadbuffer.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 bf_getreadbuffer : getreadbufferproc;

Field Value

Type: getreadbufferproc

See Also

Reference

  • PyBufferProcs
  • BI.Plugins.Python.Engine


PyBufferProcs.bf_getsegcount Field

Summary

Represents field bf_getsegcount.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 bf_getsegcount : getsegcountproc;

Field Value

Type: getsegcountproc

See Also

Reference

  • PyBufferProcs
  • BI.Plugins.Python.Engine


PyBufferProcs.bf_getwritebuffer Field

Summary

Represents field bf_getwritebuffer.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 bf_getwritebuffer : getwritebufferproc;

Field Value

Type: getwritebufferproc

See Also

Reference

  • PyBufferProcs
  • BI.Plugins.Python.Engine


PyClassObject Record

Summary

Represents type PyClassObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyClassObject = packed record
 end;

The PyClassObject type exposes the following members.

Fields
Show:
Name | Description
cl_bases | Represents field cl_bases.
cl_delattr | Represents field cl_delattr.
cl_dict | Represents field cl_dict.
cl_getattr | Represents field cl_getattr.
cl_name | Represents field cl_name.
cl_setattr | Represents field cl_setattr.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyClassObject Fields

Fields
Name | Description
cl_bases | Represents field cl_bases.
cl_delattr | Represents field cl_delattr.
cl_dict | Represents field cl_dict.
cl_getattr | Represents field cl_getattr.
cl_name | Represents field cl_name.
cl_setattr | Represents field cl_setattr.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top


PyClassObject.cl_bases Field

Summary

Represents field cl_bases.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 cl_bases : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyClassObject
  • BI.Plugins.Python.Engine


PyClassObject.cl_delattr Field

Summary

Represents field cl_delattr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 cl_delattr : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyClassObject
  • BI.Plugins.Python.Engine


PyClassObject.cl_dict Field

Summary

Represents field cl_dict.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 cl_dict : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyClassObject
  • BI.Plugins.Python.Engine


PyClassObject.cl_getattr Field

Summary

Represents field cl_getattr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 cl_getattr : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyClassObject
  • BI.Plugins.Python.Engine


PyClassObject.cl_name Field

Summary

Represents field cl_name.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 cl_name : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyClassObject
  • BI.Plugins.Python.Engine


PyClassObject.cl_setattr Field

Summary

Represents field cl_setattr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 cl_setattr : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyClassObject
  • BI.Plugins.Python.Engine


PyClassObject.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyClassObject
  • BI.Plugins.Python.Engine


PyClassObject.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyClassObject
  • BI.Plugins.Python.Engine


PyCodeObject Record

Summary

Represents type PyCodeObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyCodeObject = packed record
 end;

The PyCodeObject type exposes the following members.

Fields
Show:
Name | Description
co_argcount | Represents field co_argcount.
co_cellvars | Represents field co_cellvars.
co_code | Represents field co_code.
co_consts | Represents field co_consts.
co_filename | Represents field co_filename.
co_firstlineno | Represents field co_firstlineno.
co_flags | Represents field co_flags.
co_freevars | Represents field co_freevars.
co_lnotab | Represents field co_lnotab.
co_name | Represents field co_name.
co_names | Represents field co_names.
co_nlocals | Represents field co_nlocals.
co_stacksize | Represents field co_stacksize.
co_varnames | Represents field co_varnames.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyCodeObject Fields

Fields
Name | Description
co_argcount | Represents field co_argcount.
co_cellvars | Represents field co_cellvars.
co_code | Represents field co_code.
co_consts | Represents field co_consts.
co_filename | Represents field co_filename.
co_firstlineno | Represents field co_firstlineno.
co_flags | Represents field co_flags.
co_freevars | Represents field co_freevars.
co_lnotab | Represents field co_lnotab.
co_name | Represents field co_name.
co_names | Represents field co_names.
co_nlocals | Represents field co_nlocals.
co_stacksize | Represents field co_stacksize.
co_varnames | Represents field co_varnames.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top


PyCodeObject.co_argcount Field

Summary

Represents field co_argcount.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 co_argcount : Integer;

Field Value

Type: Integer

See Also

Reference

  • PyCodeObject
  • BI.Plugins.Python.Engine


PyCodeObject.co_cellvars Field

Summary

Represents field co_cellvars.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 co_cellvars : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyCodeObject
  • BI.Plugins.Python.Engine


PyCodeObject.co_code Field

Summary

Represents field co_code.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 co_code : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyCodeObject
  • BI.Plugins.Python.Engine


PyCodeObject.co_consts Field

Summary

Represents field co_consts.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 co_consts : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyCodeObject
  • BI.Plugins.Python.Engine


PyCodeObject.co_filename Field

Summary

Represents field co_filename.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 co_filename : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyCodeObject
  • BI.Plugins.Python.Engine


PyCodeObject.co_firstlineno Field

Summary

Represents field co_firstlineno.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 co_firstlineno : Integer;

Field Value

Type: Integer

See Also

Reference

  • PyCodeObject
  • BI.Plugins.Python.Engine


PyCodeObject.co_flags Field

Summary

Represents field co_flags.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 co_flags : Integer;

Field Value

Type: Integer

See Also

Reference

  • PyCodeObject
  • BI.Plugins.Python.Engine


PyCodeObject.co_freevars Field

Summary

Represents field co_freevars.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 co_freevars : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyCodeObject
  • BI.Plugins.Python.Engine


PyCodeObject.co_lnotab Field

Summary

Represents field co_lnotab.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 co_lnotab : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyCodeObject
  • BI.Plugins.Python.Engine


PyCodeObject.co_name Field

Summary

Represents field co_name.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 co_name : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyCodeObject
  • BI.Plugins.Python.Engine


PyCodeObject.co_names Field

Summary

Represents field co_names.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 co_names : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyCodeObject
  • BI.Plugins.Python.Engine


PyCodeObject.co_nlocals Field

Summary

Represents field co_nlocals.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 co_nlocals : Integer;

Field Value

Type: Integer

See Also

Reference

  • PyCodeObject
  • BI.Plugins.Python.Engine


PyCodeObject.co_stacksize Field

Summary

Represents field co_stacksize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 co_stacksize : Integer;

Field Value

Type: Integer

See Also

Reference

  • PyCodeObject
  • BI.Plugins.Python.Engine


PyCodeObject.co_varnames Field

Summary

Represents field co_varnames.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 co_varnames : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyCodeObject
  • BI.Plugins.Python.Engine


PyCodeObject.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyCodeObject
  • BI.Plugins.Python.Engine


PyCodeObject.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyCodeObject
  • BI.Plugins.Python.Engine


PyDateTime_Date Record

Summary

Represents type PyDateTime_Date.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyDateTime_Date = packed record
 end;

The PyDateTime_Date type exposes the following members.

Fields
Show:
Name | Description
data | Represents field data.
hashcode | Represents field hashcode.
hastzinfo | Represents field hastzinfo.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyDateTime_Date Fields

Fields
Name | Description
data | Represents field data.
hashcode | Represents field hashcode.
hastzinfo | Represents field hastzinfo.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top


PyDateTime_Date.data Field

Summary

Represents field data.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 data : array[0..Pred(_PyDateTime_DATE_DATASIZE)] of Byte;

Field Value

Type: array[0..Pred(_PyDateTime_DATE_DATASIZE)] of Byte

See Also

Reference

  • PyDateTime_Date
  • BI.Plugins.Python.Engine


PyDateTime_Date.hashcode Field

Summary

Represents field hashcode.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 hashcode : Integer;

Field Value

Type: Integer

See Also

Reference

  • PyDateTime_Date
  • BI.Plugins.Python.Engine


PyDateTime_Date.hastzinfo Field

Summary

Represents field hastzinfo.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 hastzinfo : Char;

Field Value

Type: Char

See Also

Reference

  • PyDateTime_Date
  • BI.Plugins.Python.Engine


PyDateTime_Date.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyDateTime_Date
  • BI.Plugins.Python.Engine


PyDateTime_Date.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyDateTime_Date
  • BI.Plugins.Python.Engine


PyDateTime_DateTime Record

Summary

Represents type PyDateTime_DateTime.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyDateTime_DateTime = packed record
 end;

The PyDateTime_DateTime type exposes the following members.

Fields
Show:
Name | Description
data | Represents field data.
hashcode | Represents field hashcode.
hastzinfo | Represents field hastzinfo.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
tzinfo | Represents field tzinfo.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyDateTime_DateTime Fields

Fields
Name | Description
data | Represents field data.
hashcode | Represents field hashcode.
hastzinfo | Represents field hastzinfo.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
tzinfo | Represents field tzinfo.
Top


PyDateTime_DateTime.data Field

Summary

Represents field data.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 data : array[0..Pred(_PyDateTime_DATETIME_DATASIZE)] of Byte;

Field Value

Type: array[0..Pred(_PyDateTime_DATETIME_DATASIZE)] of Byte

See Also

Reference

  • PyDateTime_DateTime
  • BI.Plugins.Python.Engine


PyDateTime_DateTime.hashcode Field

Summary

Represents field hashcode.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 hashcode : Integer;

Field Value

Type: Integer

See Also

Reference

  • PyDateTime_DateTime
  • BI.Plugins.Python.Engine


PyDateTime_DateTime.hastzinfo Field

Summary

Represents field hastzinfo.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 hastzinfo : Char;

Field Value

Type: Char

See Also

Reference

  • PyDateTime_DateTime
  • BI.Plugins.Python.Engine


PyDateTime_DateTime.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyDateTime_DateTime
  • BI.Plugins.Python.Engine


PyDateTime_DateTime.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyDateTime_DateTime
  • BI.Plugins.Python.Engine


PyDateTime_DateTime.tzinfo Field

Summary

Represents field tzinfo.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tzinfo : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyDateTime_DateTime
  • BI.Plugins.Python.Engine


PyDateTime_Delta Record

Summary

Represents type PyDateTime_Delta.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyDateTime_Delta = packed record
 end;

The PyDateTime_Delta type exposes the following members.

Fields
Show:
Name | Description
days | Represents field days.
hashcode | Represents field hashcode.
microseconds | Represents field microseconds.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
seconds | Represents field seconds.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyDateTime_Delta Fields

Fields
Name | Description
days | Represents field days.
hashcode | Represents field hashcode.
microseconds | Represents field microseconds.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
seconds | Represents field seconds.
Top


PyDateTime_Delta.days Field

Summary

Represents field days.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 days : Integer;

Field Value

Type: Integer

See Also

Reference

  • PyDateTime_Delta
  • BI.Plugins.Python.Engine


PyDateTime_Delta.hashcode Field

Summary

Represents field hashcode.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 hashcode : Integer;

Field Value

Type: Integer

See Also

Reference

  • PyDateTime_Delta
  • BI.Plugins.Python.Engine


PyDateTime_Delta.microseconds Field

Summary

Represents field microseconds.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 microseconds: Integer;

Field Value

Type: Integer

See Also

Reference

  • PyDateTime_Delta
  • BI.Plugins.Python.Engine


PyDateTime_Delta.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyDateTime_Delta
  • BI.Plugins.Python.Engine


PyDateTime_Delta.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyDateTime_Delta
  • BI.Plugins.Python.Engine


PyDateTime_Delta.seconds Field

Summary

Represents field seconds.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 seconds : Integer;

Field Value

Type: Integer

See Also

Reference

  • PyDateTime_Delta
  • BI.Plugins.Python.Engine


PyDateTime_Time Record

Summary

Represents type PyDateTime_Time.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyDateTime_Time = packed record
 end;

The PyDateTime_Time type exposes the following members.

Fields
Show:
Name | Description
data | Represents field data.
hashcode | Represents field hashcode.
hastzinfo | Represents field hastzinfo.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
tzinfo | Represents field tzinfo.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyDateTime_Time Fields

Fields
Name | Description
data | Represents field data.
hashcode | Represents field hashcode.
hastzinfo | Represents field hastzinfo.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
tzinfo | Represents field tzinfo.
Top


PyDateTime_Time.data Field

Summary

Represents field data.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 data : array[0..Pred(_PyDateTime_TIME_DATASIZE)] of Byte;

Field Value

Type: array[0..Pred(_PyDateTime_TIME_DATASIZE)] of Byte

See Also

Reference

  • PyDateTime_Time
  • BI.Plugins.Python.Engine


PyDateTime_Time.hashcode Field

Summary

Represents field hashcode.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 hashcode : Integer;

Field Value

Type: Integer

See Also

Reference

  • PyDateTime_Time
  • BI.Plugins.Python.Engine


PyDateTime_Time.hastzinfo Field

Summary

Represents field hastzinfo.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 hastzinfo : Char;

Field Value

Type: Char

See Also

Reference

  • PyDateTime_Time
  • BI.Plugins.Python.Engine


PyDateTime_Time.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyDateTime_Time
  • BI.Plugins.Python.Engine


PyDateTime_Time.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyDateTime_Time
  • BI.Plugins.Python.Engine


PyDateTime_Time.tzinfo Field

Summary

Represents field tzinfo.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tzinfo : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyDateTime_Time
  • BI.Plugins.Python.Engine


PyDateTime_TZInfo Record

Summary

Represents type PyDateTime_TZInfo.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyDateTime_TZInfo = packed record
 end;

The PyDateTime_TZInfo type exposes the following members.

Fields
Show:
Name | Description
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyDateTime_TZInfo Fields

Fields
Name | Description
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top


PyDateTime_TZInfo.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyDateTime_TZInfo
  • BI.Plugins.Python.Engine


PyDateTime_TZInfo.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyDateTime_TZInfo
  • BI.Plugins.Python.Engine


PyDescrObject Record

Summary

Represents type PyDescrObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyDescrObject = packed record
 end;

The PyDescrObject type exposes the following members.

Fields
Show:
Name | Description
d_name | Represents field d_name.
d_type | Represents field d_type.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyDescrObject Fields

Fields
Name | Description
d_name | Represents field d_name.
d_type | Represents field d_type.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top


PyDescrObject.d_name Field

Summary

Represents field d_name.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 d_name : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyDescrObject
  • BI.Plugins.Python.Engine


PyDescrObject.d_type Field

Summary

Represents field d_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 d_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyDescrObject
  • BI.Plugins.Python.Engine


PyDescrObject.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyDescrObject
  • BI.Plugins.Python.Engine


PyDescrObject.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyDescrObject
  • BI.Plugins.Python.Engine


PyFrameObject Record

Summary

Represents type PyFrameObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyFrameObject = packed record
 end;

The PyFrameObject type exposes the following members.

Fields
Show:
Name | Description
f_back | Represents field f_back.
f_blockstack | Represents field f_blockstack.
f_builtins | Represents field f_builtins.
f_code | Represents field f_code.
f_exc_traceback | Represents field f_exc_traceback.
f_exc_type | Represents field f_exc_type.
f_exc_value | Represents field f_exc_value.
f_globals | Represents field f_globals.
f_iblock | Represents field f_iblock.
f_lasti | Represents field f_lasti.
f_lineno | Represents field f_lineno.
f_locals | Represents field f_locals.
f_localsplus | Represents field f_localsplus.
f_stacktop | Represents field f_stacktop.
f_trace | Represents field f_trace.
f_tstate | Represents field f_tstate.
f_valuestack | Represents field f_valuestack.
ob_refcnt | Represents field ob_refcnt.
ob_size | Represents field ob_size.
ob_type | Represents field ob_type.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyFrameObject Fields

Fields
Name | Description
f_back | Represents field f_back.
f_blockstack | Represents field f_blockstack.
f_builtins | Represents field f_builtins.
f_code | Represents field f_code.
f_exc_traceback | Represents field f_exc_traceback.
f_exc_type | Represents field f_exc_type.
f_exc_value | Represents field f_exc_value.
f_globals | Represents field f_globals.
f_iblock | Represents field f_iblock.
f_lasti | Represents field f_lasti.
f_lineno | Represents field f_lineno.
f_locals | Represents field f_locals.
f_localsplus | Represents field f_localsplus.
f_stacktop | Represents field f_stacktop.
f_trace | Represents field f_trace.
f_tstate | Represents field f_tstate.
f_valuestack | Represents field f_valuestack.
ob_refcnt | Represents field ob_refcnt.
ob_size | Represents field ob_size.
ob_type | Represents field ob_type.
Top


PyFrameObject.f_back Field

Summary

Represents field f_back.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 f_back : PPyFrameObject;

Field Value

Type: PPyFrameObject

See Also

Reference

  • PyFrameObject
  • BI.Plugins.Python.Engine


PyFrameObject.f_blockstack Field

Summary

Represents field f_blockstack.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 f_blockstack : array[CO_MAXBLOCKS] of PyTryBlock;

Field Value

Type: array[CO_MAXBLOCKS] of PyTryBlock

See Also

Reference

  • PyFrameObject
  • BI.Plugins.Python.Engine


PyFrameObject.f_builtins Field

Summary

Represents field f_builtins.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 f_builtins : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyFrameObject
  • BI.Plugins.Python.Engine


PyFrameObject.f_code Field

Summary

Represents field f_code.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 f_code : PPyCodeObject;

Field Value

Type: PPyCodeObject

See Also

Reference

  • PyFrameObject
  • BI.Plugins.Python.Engine


PyFrameObject.f_exc_traceback Field

Summary

Represents field f_exc_traceback.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 f_exc_type, f_exc_value, f_exc_traceback: PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyFrameObject
  • BI.Plugins.Python.Engine


PyFrameObject.f_exc_type Field

Summary

Represents field f_exc_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 f_exc_type, f_exc_value, f_exc_traceback: PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyFrameObject
  • BI.Plugins.Python.Engine


PyFrameObject.f_exc_value Field

Summary

Represents field f_exc_value.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 f_exc_type, f_exc_value, f_exc_traceback: PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyFrameObject
  • BI.Plugins.Python.Engine


PyFrameObject.f_globals Field

Summary

Represents field f_globals.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 f_globals : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyFrameObject
  • BI.Plugins.Python.Engine


PyFrameObject.f_iblock Field

Summary

Represents field f_iblock.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 f_iblock : Integer;

Field Value

Type: Integer

See Also

Reference

  • PyFrameObject
  • BI.Plugins.Python.Engine


PyFrameObject.f_lasti Field

Summary

Represents field f_lasti.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 f_lasti : Integer;

Field Value

Type: Integer

See Also

Reference

  • PyFrameObject
  • BI.Plugins.Python.Engine


PyFrameObject.f_lineno Field

Summary

Represents field f_lineno.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 f_lineno : Integer;

Field Value

Type: Integer

See Also

Reference

  • PyFrameObject
  • BI.Plugins.Python.Engine


PyFrameObject.f_locals Field

Summary

Represents field f_locals.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 f_locals : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyFrameObject
  • BI.Plugins.Python.Engine


PyFrameObject.f_localsplus Field

Summary

Represents field f_localsplus.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 f_localsplus : array[0..0] of PPyObject;

Field Value

Type: array[0..0] of PPyObject

See Also

Reference

  • PyFrameObject
  • BI.Plugins.Python.Engine


PyFrameObject.f_stacktop Field

Summary

Represents field f_stacktop.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 f_stacktop : PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • PyFrameObject
  • BI.Plugins.Python.Engine


PyFrameObject.f_trace Field

Summary

Represents field f_trace.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 f_trace : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyFrameObject
  • BI.Plugins.Python.Engine


PyFrameObject.f_tstate Field

Summary

Represents field f_tstate.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 f_tstate : PPyThreadState;

Field Value

Type: PPyThreadState

See Also

Reference

  • PyFrameObject
  • BI.Plugins.Python.Engine


PyFrameObject.f_valuestack Field

Summary

Represents field f_valuestack.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 f_valuestack : PPPyObject;

Field Value

Type: PPPyObject

See Also

Reference

  • PyFrameObject
  • BI.Plugins.Python.Engine


PyFrameObject.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyFrameObject
  • BI.Plugins.Python.Engine


PyFrameObject.ob_size Field

Summary

Represents field ob_size.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_size : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyFrameObject
  • BI.Plugins.Python.Engine


PyFrameObject.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyFrameObject
  • BI.Plugins.Python.Engine


PyGetSetDef Record

Summary

Represents type PyGetSetDef.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyGetSetDef = packed record
 end;

The PyGetSetDef type exposes the following members.

Fields
Show:
Name | Description
closure | Represents field closure.
doc | Represents field doc.
get | Represents field get.
name | Represents field name.
_set | Represents field _set.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyGetSetDef Fields

Fields
Name | Description
closure | Represents field closure.
doc | Represents field doc.
get | Represents field get.
name | Represents field name.
_set | Represents field _set.
Top


PyGetSetDef.closure Field

Summary

Represents field closure.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 closure : Pointer;

Field Value

Type: Pointer

See Also

Reference

  • PyGetSetDef
  • BI.Plugins.Python.Engine


PyGetSetDef.doc Field

Summary

Represents field doc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 doc : PAnsiChar;

Field Value

Type: PAnsiChar

See Also

Reference

  • PyGetSetDef
  • BI.Plugins.Python.Engine


PyGetSetDef.get Field

Summary

Represents field get.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 get : getter;

Field Value

Type: getter

See Also

Reference

  • PyGetSetDef
  • BI.Plugins.Python.Engine


PyGetSetDef.name Field

Summary

Represents field name.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 name : PAnsiChar;

Field Value

Type: PAnsiChar

See Also

Reference

  • PyGetSetDef
  • BI.Plugins.Python.Engine


PyGetSetDef._set Field

Summary

Represents field _set.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 _set : setter;

Field Value

Type: setter

See Also

Reference

  • PyGetSetDef
  • BI.Plugins.Python.Engine


PyGetSetDescrObject Record

Summary

Represents type PyGetSetDescrObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyGetSetDescrObject = packed record
 end;

The PyGetSetDescrObject type exposes the following members.

Fields
Show:
Name | Description
d_getset | Represents field d_getset.
d_name | Represents field d_name.
d_type | Represents field d_type.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyGetSetDescrObject Fields

Fields
Name | Description
d_getset | Represents field d_getset.
d_name | Represents field d_name.
d_type | Represents field d_type.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top


PyGetSetDescrObject.d_getset Field

Summary

Represents field d_getset.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 d_getset : PPyGetSetDef;

Field Value

Type: PPyGetSetDef

See Also

Reference

  • PyGetSetDescrObject
  • BI.Plugins.Python.Engine


PyGetSetDescrObject.d_name Field

Summary

Represents field d_name.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 d_name : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyGetSetDescrObject
  • BI.Plugins.Python.Engine


PyGetSetDescrObject.d_type Field

Summary

Represents field d_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 d_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyGetSetDescrObject
  • BI.Plugins.Python.Engine


PyGetSetDescrObject.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyGetSetDescrObject
  • BI.Plugins.Python.Engine


PyGetSetDescrObject.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyGetSetDescrObject
  • BI.Plugins.Python.Engine


PyInstanceObject Record

Summary

Represents type PyInstanceObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyInstanceObject = packed record
 end;

The PyInstanceObject type exposes the following members.

Fields
Show:
Name | Description
in_class | Represents field in_class.
in_dict | Represents field in_dict.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyInstanceObject Fields

Fields
Name | Description
in_class | Represents field in_class.
in_dict | Represents field in_dict.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top


PyInstanceObject.in_class Field

Summary

Represents field in_class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 in_class : PPyClassObject;

Field Value

Type: PPyClassObject

See Also

Reference

  • PyInstanceObject
  • BI.Plugins.Python.Engine


PyInstanceObject.in_dict Field

Summary

Represents field in_dict.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 in_dict : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyInstanceObject
  • BI.Plugins.Python.Engine


PyInstanceObject.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyInstanceObject
  • BI.Plugins.Python.Engine


PyInstanceObject.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyInstanceObject
  • BI.Plugins.Python.Engine


PyInterpreterState Record

Summary

Represents type PyInterpreterState.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyInterpreterState = packed record
 end;

The PyInterpreterState type exposes the following members.

Fields
Show:
Name | Description
builtins | Represents field builtins.
checkinterval | Represents field checkinterval.
modules | Represents field modules.
next | Represents field next.
sysdict | Represents field sysdict.
tstate_head | Represents field tstate_head.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyInterpreterState Fields

Fields
Name | Description
builtins | Represents field builtins.
checkinterval | Represents field checkinterval.
modules | Represents field modules.
next | Represents field next.
sysdict | Represents field sysdict.
tstate_head | Represents field tstate_head.
Top


PyInterpreterState.builtins Field

Summary

Represents field builtins.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 builtins : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyInterpreterState
  • BI.Plugins.Python.Engine


PyInterpreterState.checkinterval Field

Summary

Represents field checkinterval.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 checkinterval : integer;

Field Value

Type: integer

See Also

Reference

  • PyInterpreterState
  • BI.Plugins.Python.Engine


PyInterpreterState.modules Field

Summary

Represents field modules.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 modules : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyInterpreterState
  • BI.Plugins.Python.Engine


PyInterpreterState.next Field

Summary

Represents field next.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 next : PPyInterpreterState;

Field Value

Type: PPyInterpreterState

See Also

Reference

  • PyInterpreterState
  • BI.Plugins.Python.Engine


PyInterpreterState.sysdict Field

Summary

Represents field sysdict.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 sysdict : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyInterpreterState
  • BI.Plugins.Python.Engine


PyInterpreterState.tstate_head Field

Summary

Represents field tstate_head.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tstate_head : PPyThreadState;

Field Value

Type: PPyThreadState

See Also

Reference

  • PyInterpreterState
  • BI.Plugins.Python.Engine


PyIntObject Record

Summary

Represents type PyIntObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyIntObject = packed record
 end;

The PyIntObject type exposes the following members.

Fields
Show:
Name | Description
ob_ival | Represents field ob_ival.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyIntObject Fields

Fields
Name | Description
ob_ival | Represents field ob_ival.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top


PyIntObject.ob_ival Field

Summary

Represents field ob_ival.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_ival : LongInt;

Field Value

Type: LongInt

See Also

Reference

  • PyIntObject
  • BI.Plugins.Python.Engine


PyIntObject.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyIntObject
  • BI.Plugins.Python.Engine


PyIntObject.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyIntObject
  • BI.Plugins.Python.Engine


PyMappingMethods Record

Summary

Represents type PyMappingMethods.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyMappingMethods = packed record
 end;

The PyMappingMethods type exposes the following members.

Fields
Show:
Name | Description
mp_ass_subscript | Represents field mp_ass_subscript.
mp_length | Represents field mp_length.
mp_subscript | Represents field mp_subscript.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyMappingMethods Fields

Fields
Name | Description
mp_ass_subscript | Represents field mp_ass_subscript.
mp_length | Represents field mp_length.
mp_subscript | Represents field mp_subscript.
Top


PyMappingMethods.mp_ass_subscript Field

Summary

Represents field mp_ass_subscript.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 mp_ass_subscript : objobjargproc;

Field Value

Type: objobjargproc

See Also

Reference

  • PyMappingMethods
  • BI.Plugins.Python.Engine


PyMappingMethods.mp_length Field

Summary

Represents field mp_length.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 mp_length : lenfunc;

Field Value

Type: lenfunc

See Also

Reference

  • PyMappingMethods
  • BI.Plugins.Python.Engine


PyMappingMethods.mp_subscript Field

Summary

Represents field mp_subscript.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 mp_subscript : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyMappingMethods
  • BI.Plugins.Python.Engine


PyMemberDef Record

Summary

Represents type PyMemberDef.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyMemberDef = packed record
 end;

The PyMemberDef type exposes the following members.

Fields
Show:
Name | Description
doc | Represents field doc.
flags | Represents field flags.
name | Represents field name.
offset | Represents field offset.
_type | Represents field _type.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyMemberDef Fields

Fields
Name | Description
doc | Represents field doc.
flags | Represents field flags.
name | Represents field name.
offset | Represents field offset.
_type | Represents field _type.
Top


PyMemberDef.doc Field

Summary

Represents field doc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 doc : PAnsiChar;

Field Value

Type: PAnsiChar

See Also

Reference

  • PyMemberDef
  • BI.Plugins.Python.Engine


PyMemberDef.flags Field

Summary

Represents field flags.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 flags : integer;

Field Value

Type: integer

See Also

Reference

  • PyMemberDef
  • BI.Plugins.Python.Engine


PyMemberDef.name Field

Summary

Represents field name.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 name : PAnsiChar;

Field Value

Type: PAnsiChar

See Also

Reference

  • PyMemberDef
  • BI.Plugins.Python.Engine


PyMemberDef.offset Field

Summary

Represents field offset.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 offset : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyMemberDef
  • BI.Plugins.Python.Engine


PyMemberDef._type Field

Summary

Represents field _type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 _type : integer;

Field Value

Type: integer

See Also

Reference

  • PyMemberDef
  • BI.Plugins.Python.Engine


PyMemberDescrObject Record

Summary

Represents type PyMemberDescrObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyMemberDescrObject = packed record
 end;

The PyMemberDescrObject type exposes the following members.

Fields
Show:
Name | Description
d_member | Represents field d_member.
d_name | Represents field d_name.
d_type | Represents field d_type.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyMemberDescrObject Fields

Fields
Name | Description
d_member | Represents field d_member.
d_name | Represents field d_name.
d_type | Represents field d_type.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top


PyMemberDescrObject.d_member Field

Summary

Represents field d_member.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 d_member : PPyMemberDef;

Field Value

Type: PPyMemberDef

See Also

Reference

  • PyMemberDescrObject
  • BI.Plugins.Python.Engine


PyMemberDescrObject.d_name Field

Summary

Represents field d_name.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 d_name : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyMemberDescrObject
  • BI.Plugins.Python.Engine


PyMemberDescrObject.d_type Field

Summary

Represents field d_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 d_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyMemberDescrObject
  • BI.Plugins.Python.Engine


PyMemberDescrObject.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyMemberDescrObject
  • BI.Plugins.Python.Engine


PyMemberDescrObject.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyMemberDescrObject
  • BI.Plugins.Python.Engine


PyMethodChain Record

Summary

Represents type PyMethodChain.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyMethodChain = packed record
 end;

The PyMethodChain type exposes the following members.

Fields
Show:
Name | Description
link | Represents field link.
methods | Represents field methods.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyMethodChain Fields

Fields
Name | Description
link | Represents field link.
methods | Represents field methods.
Top


PyMethodChain.link Field

Summary

Represents field link.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 link: PPyMethodChain;

Field Value

Type: PPyMethodChain

See Also

Reference

  • PyMethodChain
  • BI.Plugins.Python.Engine


PyMethodChain.methods Field

Summary

Represents field methods.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 methods: PPyMethodDef;

Field Value

Type: PPyMethodDef

See Also

Reference

  • PyMethodChain
  • BI.Plugins.Python.Engine


PyMethodDef Record

Summary

Represents type PyMethodDef.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyMethodDef = packed record
 end;

The PyMethodDef type exposes the following members.

Fields
Show:
Name | Description
ml_doc | Represents field ml_doc.
ml_flags | Represents field ml_flags.
ml_meth | Represents field ml_meth.
ml_name | Represents field ml_name.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyMethodDef Fields

Fields
Name | Description
ml_doc | Represents field ml_doc.
ml_flags | Represents field ml_flags.
ml_meth | Represents field ml_meth.
ml_name | Represents field ml_name.
Top


PyMethodDef.ml_doc Field

Summary

Represents field ml_doc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ml_doc: PAnsiChar;

Field Value

Type: PAnsiChar

See Also

Reference

  • PyMethodDef
  • BI.Plugins.Python.Engine


PyMethodDef.ml_flags Field

Summary

Represents field ml_flags.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ml_flags: Integer;

Field Value

Type: Integer

See Also

Reference

  • PyMethodDef
  • BI.Plugins.Python.Engine


PyMethodDef.ml_meth Field

Summary

Represents field ml_meth.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ml_meth: PyCFunction;

Field Value

Type: PyCFunction

See Also

Reference

  • PyMethodDef
  • BI.Plugins.Python.Engine


PyMethodDef.ml_name Field

Summary

Represents field ml_name.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ml_name: PAnsiChar;

Field Value

Type: PAnsiChar

See Also

Reference

  • PyMethodDef
  • BI.Plugins.Python.Engine


PyMethodDescrObject Record

Summary

Represents type PyMethodDescrObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyMethodDescrObject = packed record
 end;

The PyMethodDescrObject type exposes the following members.

Fields
Show:
Name | Description
d_method | Represents field d_method.
d_name | Represents field d_name.
d_type | Represents field d_type.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyMethodDescrObject Fields

Fields
Name | Description
d_method | Represents field d_method.
d_name | Represents field d_name.
d_type | Represents field d_type.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top


PyMethodDescrObject.d_method Field

Summary

Represents field d_method.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 d_method : PPyMethodDef;

Field Value

Type: PPyMethodDef

See Also

Reference

  • PyMethodDescrObject
  • BI.Plugins.Python.Engine


PyMethodDescrObject.d_name Field

Summary

Represents field d_name.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 d_name : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyMethodDescrObject
  • BI.Plugins.Python.Engine


PyMethodDescrObject.d_type Field

Summary

Represents field d_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 d_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyMethodDescrObject
  • BI.Plugins.Python.Engine


PyMethodDescrObject.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyMethodDescrObject
  • BI.Plugins.Python.Engine


PyMethodDescrObject.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyMethodDescrObject
  • BI.Plugins.Python.Engine


PyMethodObject Record

Summary

Represents type PyMethodObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyMethodObject = packed record
 end;

The PyMethodObject type exposes the following members.

Fields
Show:
Name | Description
im_class | Represents field im_class.
im_func | Represents field im_func.
im_self | Represents field im_self.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyMethodObject Fields

Fields
Name | Description
im_class | Represents field im_class.
im_func | Represents field im_func.
im_self | Represents field im_self.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top


PyMethodObject.im_class Field

Summary

Represents field im_class.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 im_class : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyMethodObject
  • BI.Plugins.Python.Engine


PyMethodObject.im_func Field

Summary

Represents field im_func.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 im_func : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyMethodObject
  • BI.Plugins.Python.Engine


PyMethodObject.im_self Field

Summary

Represents field im_self.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 im_self : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyMethodObject
  • BI.Plugins.Python.Engine


PyMethodObject.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyMethodObject
  • BI.Plugins.Python.Engine


PyMethodObject.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyMethodObject
  • BI.Plugins.Python.Engine


PyModuleDef Record

Summary

Represents type PyModuleDef.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyModuleDef = packed record
 end;

The PyModuleDef type exposes the following members.

Fields
Show:
Name | Description
m_base | Represents field m_base.
m_clear | Represents field m_clear.
m_doc | Represents field m_doc.
m_free | Represents field m_free.
m_methods | Represents field m_methods.
m_name | Represents field m_name.
m_reload | Represents field m_reload.
m_size | Represents field m_size.
m_traverse | Represents field m_traverse.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyModuleDef Fields

Fields
Name | Description
m_base | Represents field m_base.
m_clear | Represents field m_clear.
m_doc | Represents field m_doc.
m_free | Represents field m_free.
m_methods | Represents field m_methods.
m_name | Represents field m_name.
m_reload | Represents field m_reload.
m_size | Represents field m_size.
m_traverse | Represents field m_traverse.
Top


PyModuleDef.m_base Field

Summary

Represents field m_base.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 m_base : PyModuleDef_Base;

Field Value

Type: PyModuleDef_Base

See Also

Reference

  • PyModuleDef
  • BI.Plugins.Python.Engine


PyModuleDef.m_clear Field

Summary

Represents field m_clear.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 m_clear : inquiry;

Field Value

Type: inquiry

See Also

Reference

  • PyModuleDef
  • BI.Plugins.Python.Engine


PyModuleDef.m_doc Field

Summary

Represents field m_doc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 m_doc : PAnsiChar;

Field Value

Type: PAnsiChar

See Also

Reference

  • PyModuleDef
  • BI.Plugins.Python.Engine


PyModuleDef.m_free Field

Summary

Represents field m_free.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 m_free : inquiry;

Field Value

Type: inquiry

See Also

Reference

  • PyModuleDef
  • BI.Plugins.Python.Engine


PyModuleDef.m_methods Field

Summary

Represents field m_methods.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 m_methods : PPyMethodDef;

Field Value

Type: PPyMethodDef

See Also

Reference

  • PyModuleDef
  • BI.Plugins.Python.Engine


PyModuleDef.m_name Field

Summary

Represents field m_name.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 m_name : PAnsiChar;

Field Value

Type: PAnsiChar

See Also

Reference

  • PyModuleDef
  • BI.Plugins.Python.Engine


PyModuleDef.m_reload Field

Summary

Represents field m_reload.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 m_reload : inquiry;

Field Value

Type: inquiry

See Also

Reference

  • PyModuleDef
  • BI.Plugins.Python.Engine


PyModuleDef.m_size Field

Summary

Represents field m_size.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 m_size : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyModuleDef
  • BI.Plugins.Python.Engine


PyModuleDef.m_traverse Field

Summary

Represents field m_traverse.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 m_traverse : traverseproc;

Field Value

Type: traverseproc

See Also

Reference

  • PyModuleDef
  • BI.Plugins.Python.Engine


PyModuleDef_Base Record

Summary

Represents type PyModuleDef_Base.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyModuleDef_Base = packed record
 end;

The PyModuleDef_Base type exposes the following members.

Fields
Show:
Name | Description
m_copy | Represents field m_copy.
m_index | Represents field m_index.
m_init | Represents field m_init.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyModuleDef_Base Fields

Fields
Name | Description
m_copy | Represents field m_copy.
m_index | Represents field m_index.
m_init | Represents field m_init.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top


PyModuleDef_Base.m_copy Field

Summary

Represents field m_copy.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 m_copy : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyModuleDef_Base
  • BI.Plugins.Python.Engine


PyModuleDef_Base.m_index Field

Summary

Represents field m_index.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 m_index : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyModuleDef_Base
  • BI.Plugins.Python.Engine


PyModuleDef_Base.m_init Field

Summary

Represents field m_init.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 m_init : function( ) : PPyObject; cdecl;

Field Value

Type: function( ) : PPyObject; cdecl

See Also

Reference

  • PyModuleDef_Base
  • BI.Plugins.Python.Engine


PyModuleDef_Base.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyModuleDef_Base
  • BI.Plugins.Python.Engine


PyModuleDef_Base.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyModuleDef_Base
  • BI.Plugins.Python.Engine


PyNumberMethods Record

Summary

Represents type PyNumberMethods.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyNumberMethods = packed record
 end;

The PyNumberMethods type exposes the following members.

Fields
Show:
Name | Description
nb_absolute | Represents field nb_absolute.
nb_add | Represents field nb_add.
nb_and | Represents field nb_and.
nb_coerce | Represents field nb_coerce.
nb_divide | Represents field nb_divide.
nb_divmod | Represents field nb_divmod.
nb_float | Represents field nb_float.
nb_floor_divide | Represents field nb_floor_divide.
nb_hex | Represents field nb_hex.
nb_inplace_add |
nb_inplace_and | Represents field nb_inplace_and.
nb_inplace_divide | Represents field nb_inplace_divide.
nb_inplace_floor_divide | Represents field nb_inplace_floor_divide.
nb_inplace_lshift | Represents field nb_inplace_lshift.
nb_inplace_multiply | Represents field nb_inplace_multiply.
nb_inplace_or | Represents field nb_inplace_or.
nb_inplace_power | Represents field nb_inplace_power.
nb_inplace_remainder | Represents field nb_inplace_remainder.
nb_inplace_rshift | Represents field nb_inplace_rshift.
nb_inplace_subtract | Represents field nb_inplace_subtract.
nb_inplace_true_divide | Represents field nb_inplace_true_divide.
nb_inplace_xor | Represents field nb_inplace_xor.
nb_int | Represents field nb_int.
nb_invert | Represents field nb_invert.
nb_long | Represents field nb_long.
nb_lshift | Represents field nb_lshift.
nb_multiply | Represents field nb_multiply.
nb_negative | Represents field nb_negative.
nb_nonzero | Represents field nb_nonzero.
nb_oct | Represents field nb_oct.
nb_or | Represents field nb_or.
nb_positive | Represents field nb_positive.
nb_power | Represents field nb_power.
nb_remainder | Represents field nb_remainder.
nb_rshift | Represents field nb_rshift.
nb_substract | Represents field nb_substract.
nb_true_divide | Represents field nb_true_divide.
nb_xor | Represents field nb_xor.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyNumberMethods Fields

Fields
Name | Description
nb_absolute | Represents field nb_absolute.
nb_add | Represents field nb_add.
nb_and | Represents field nb_and.
nb_coerce | Represents field nb_coerce.
nb_divide | Represents field nb_divide.
nb_divmod | Represents field nb_divmod.
nb_float | Represents field nb_float.
nb_floor_divide | Represents field nb_floor_divide.
nb_hex | Represents field nb_hex.
nb_inplace_add |
nb_inplace_and | Represents field nb_inplace_and.
nb_inplace_divide | Represents field nb_inplace_divide.
nb_inplace_floor_divide | Represents field nb_inplace_floor_divide.
nb_inplace_lshift | Represents field nb_inplace_lshift.
nb_inplace_multiply | Represents field nb_inplace_multiply.
nb_inplace_or | Represents field nb_inplace_or.
nb_inplace_power | Represents field nb_inplace_power.
nb_inplace_remainder | Represents field nb_inplace_remainder.
nb_inplace_rshift | Represents field nb_inplace_rshift.
nb_inplace_subtract | Represents field nb_inplace_subtract.
nb_inplace_true_divide | Represents field nb_inplace_true_divide.
nb_inplace_xor | Represents field nb_inplace_xor.
nb_int | Represents field nb_int.
nb_invert | Represents field nb_invert.
nb_long | Represents field nb_long.
nb_lshift | Represents field nb_lshift.
nb_multiply | Represents field nb_multiply.
nb_negative | Represents field nb_negative.
nb_nonzero | Represents field nb_nonzero.
nb_oct | Represents field nb_oct.
nb_or | Represents field nb_or.
nb_positive | Represents field nb_positive.
nb_power | Represents field nb_power.
nb_remainder | Represents field nb_remainder.
nb_rshift | Represents field nb_rshift.
nb_substract | Represents field nb_substract.
nb_true_divide | Represents field nb_true_divide.
nb_xor | Represents field nb_xor.
Top


PyNumberMethods.nb_absolute Field

Summary

Represents field nb_absolute.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_absolute : unaryfunc;

Field Value

Type: unaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_add Field

Summary

Represents field nb_add.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_add : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_and Field

Summary

Represents field nb_and.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_and : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_coerce Field

Summary

Represents field nb_coerce.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_coerce : coercion;

Field Value

Type: coercion

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_divide Field

Summary

Represents field nb_divide.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_divide : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_divmod Field

Summary

Represents field nb_divmod.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_divmod : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_float Field

Summary

Represents field nb_float.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_float : unaryfunc;

Field Value

Type: unaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_floor_divide Field

Summary

Represents field nb_floor_divide.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_floor_divide : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_hex Field

Summary

Represents field nb_hex.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_hex : unaryfunc;

Field Value

Type: unaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_inplace_add Field

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_inplace_add : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_inplace_and Field

Summary

Represents field nb_inplace_and.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_inplace_and : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_inplace_divide Field

Summary

Represents field nb_inplace_divide.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_inplace_divide : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_inplace_floor_divide Field

Summary

Represents field nb_inplace_floor_divide.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_inplace_floor_divide : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_inplace_lshift Field

Summary

Represents field nb_inplace_lshift.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_inplace_lshift : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_inplace_multiply Field

Summary

Represents field nb_inplace_multiply.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_inplace_multiply : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_inplace_or Field

Summary

Represents field nb_inplace_or.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_inplace_or : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_inplace_power Field

Summary

Represents field nb_inplace_power.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_inplace_power : ternaryfunc;

Field Value

Type: ternaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_inplace_remainder Field

Summary

Represents field nb_inplace_remainder.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_inplace_remainder : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_inplace_rshift Field

Summary

Represents field nb_inplace_rshift.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_inplace_rshift : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_inplace_subtract Field

Summary

Represents field nb_inplace_subtract.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_inplace_subtract : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_inplace_true_divide Field

Summary

Represents field nb_inplace_true_divide.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_inplace_true_divide : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_inplace_xor Field

Summary

Represents field nb_inplace_xor.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_inplace_xor : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_int Field

Summary

Represents field nb_int.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_int : unaryfunc;

Field Value

Type: unaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_invert Field

Summary

Represents field nb_invert.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_invert : unaryfunc;

Field Value

Type: unaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_long Field

Summary

Represents field nb_long.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_long : unaryfunc;

Field Value

Type: unaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_lshift Field

Summary

Represents field nb_lshift.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_lshift : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_multiply Field

Summary

Represents field nb_multiply.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_multiply : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_negative Field

Summary

Represents field nb_negative.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_negative : unaryfunc;

Field Value

Type: unaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_nonzero Field

Summary

Represents field nb_nonzero.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_nonzero : inquiry;

Field Value

Type: inquiry

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_oct Field

Summary

Represents field nb_oct.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_oct : unaryfunc;

Field Value

Type: unaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_or Field

Summary

Represents field nb_or.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_or : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_positive Field

Summary

Represents field nb_positive.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_positive : unaryfunc;

Field Value

Type: unaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_power Field

Summary

Represents field nb_power.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_power : ternaryfunc;

Field Value

Type: ternaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_remainder Field

Summary

Represents field nb_remainder.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_remainder : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_rshift Field

Summary

Represents field nb_rshift.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_rshift : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_substract Field

Summary

Represents field nb_substract.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_substract : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_true_divide Field

Summary

Represents field nb_true_divide.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_true_divide : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyNumberMethods.nb_xor Field

Summary

Represents field nb_xor.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 nb_xor : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PyNumberMethods
  • BI.Plugins.Python.Engine


PyObject Record

Summary

Represents type PyObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyObject = packed record
 end;

The PyObject type exposes the following members.

Fields
Show:
Name | Description
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyObject Fields

Fields
Name | Description
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top


PyObject.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt: NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyObject
  • BI.Plugins.Python.Engine


PyObject.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyObject
  • BI.Plugins.Python.Engine


PySequenceMethods Record

Summary

Represents type PySequenceMethods.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PySequenceMethods = packed record
 end;

The PySequenceMethods type exposes the following members.

Fields
Show:
Name | Description
sq_ass_item | Represents field sq_ass_item.
sq_ass_slice | Represents field sq_ass_slice.
sq_concat | Represents field sq_concat.
sq_contains |
sq_inplace_concat | Represents field sq_inplace_concat.
sq_inplace_repeat | Represents field sq_inplace_repeat.
sq_item | Represents field sq_item.
sq_length | Represents field sq_length.
sq_repeat | Represents field sq_repeat.
sq_slice | Represents field sq_slice.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PySequenceMethods Fields

Fields
Name | Description
sq_ass_item | Represents field sq_ass_item.
sq_ass_slice | Represents field sq_ass_slice.
sq_concat | Represents field sq_concat.
sq_contains |
sq_inplace_concat | Represents field sq_inplace_concat.
sq_inplace_repeat | Represents field sq_inplace_repeat.
sq_item | Represents field sq_item.
sq_length | Represents field sq_length.
sq_repeat | Represents field sq_repeat.
sq_slice | Represents field sq_slice.
Top


PySequenceMethods.sq_ass_item Field

Summary

Represents field sq_ass_item.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 sq_ass_item : ssizeobjargproc;

Field Value

Type: ssizeobjargproc

See Also

Reference

  • PySequenceMethods
  • BI.Plugins.Python.Engine


PySequenceMethods.sq_ass_slice Field

Summary

Represents field sq_ass_slice.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 sq_ass_slice : ssizessizeobjargproc;

Field Value

Type: ssizessizeobjargproc

See Also

Reference

  • PySequenceMethods
  • BI.Plugins.Python.Engine


PySequenceMethods.sq_concat Field

Summary

Represents field sq_concat.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 sq_concat : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PySequenceMethods
  • BI.Plugins.Python.Engine


PySequenceMethods.sq_contains Field

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 sq_contains : objobjproc;

Field Value

Type: objobjproc

See Also

Reference

  • PySequenceMethods
  • BI.Plugins.Python.Engine


PySequenceMethods.sq_inplace_concat Field

Summary

Represents field sq_inplace_concat.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 sq_inplace_concat : binaryfunc;

Field Value

Type: binaryfunc

See Also

Reference

  • PySequenceMethods
  • BI.Plugins.Python.Engine


PySequenceMethods.sq_inplace_repeat Field

Summary

Represents field sq_inplace_repeat.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 sq_inplace_repeat : ssizeargfunc;

Field Value

Type: ssizeargfunc

See Also

Reference

  • PySequenceMethods
  • BI.Plugins.Python.Engine


PySequenceMethods.sq_item Field

Summary

Represents field sq_item.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 sq_item : ssizeargfunc;

Field Value

Type: ssizeargfunc

See Also

Reference

  • PySequenceMethods
  • BI.Plugins.Python.Engine


PySequenceMethods.sq_length Field

Summary

Represents field sq_length.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 sq_length : lenfunc;

Field Value

Type: lenfunc

See Also

Reference

  • PySequenceMethods
  • BI.Plugins.Python.Engine


PySequenceMethods.sq_repeat Field

Summary

Represents field sq_repeat.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 sq_repeat : ssizeargfunc;

Field Value

Type: ssizeargfunc

See Also

Reference

  • PySequenceMethods
  • BI.Plugins.Python.Engine


PySequenceMethods.sq_slice Field

Summary

Represents field sq_slice.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 sq_slice : ssizessizeargfunc;

Field Value

Type: ssizessizeargfunc

See Also

Reference

  • PySequenceMethods
  • BI.Plugins.Python.Engine


PySliceObject Record

Summary

Represents type PySliceObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PySliceObject = packed record
 end;

The PySliceObject type exposes the following members.

Fields
Show:
Name | Description
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
start | Represents field start.
step | Represents field step.
stop | Represents field stop.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PySliceObject Fields

Fields
Name | Description
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
start | Represents field start.
step | Represents field step.
stop | Represents field stop.
Top


PySliceObject.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt: NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PySliceObject
  • BI.Plugins.Python.Engine


PySliceObject.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PySliceObject
  • BI.Plugins.Python.Engine


PySliceObject.start Field

Summary

Represents field start.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 start, stop, step: PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PySliceObject
  • BI.Plugins.Python.Engine


PySliceObject.step Field

Summary

Represents field step.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 start, stop, step: PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PySliceObject
  • BI.Plugins.Python.Engine


PySliceObject.stop Field

Summary

Represents field stop.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 start, stop, step: PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PySliceObject
  • BI.Plugins.Python.Engine


PyThreadState Record

Summary

Represents type PyThreadState.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyThreadState = packed record
 end;

The PyThreadState type exposes the following members.

Fields
Show:
Name | Description
async_exc | Represents field async_exc.
curexc_traceback | Represents field curexc_traceback.
curexc_type | Represents field curexc_type.
curexc_value | Represents field curexc_value.
dict | Represents field dict.
exc_traceback | Represents field exc_traceback.
exc_type | Represents field exc_type.
exc_value | Represents field exc_value.
frame | Represents field frame.
gilstate_counter | Represents field gilstate_counter.
interp | Represents field interp.
next | Represents field next.
recursion_depth | Represents field recursion_depth.
sys_profilefn | Represents field sys_profilefn.
sys_profilefunc | Represents field sys_profilefunc.
sys_tracefn | Represents field sys_tracefn.
sys_tracefunc | Represents field sys_tracefunc.
thread_id | Represents field thread_id.
ticker | Represents field ticker.
tick_counter | Represents field tick_counter.
tracing | Represents field tracing.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyThreadState Fields

Fields
Name | Description
async_exc | Represents field async_exc.
curexc_traceback | Represents field curexc_traceback.
curexc_type | Represents field curexc_type.
curexc_value | Represents field curexc_value.
dict | Represents field dict.
exc_traceback | Represents field exc_traceback.
exc_type | Represents field exc_type.
exc_value | Represents field exc_value.
frame | Represents field frame.
gilstate_counter | Represents field gilstate_counter.
interp | Represents field interp.
next | Represents field next.
recursion_depth | Represents field recursion_depth.
sys_profilefn | Represents field sys_profilefn.
sys_profilefunc | Represents field sys_profilefunc.
sys_tracefn | Represents field sys_tracefn.
sys_tracefunc | Represents field sys_tracefunc.
thread_id | Represents field thread_id.
ticker | Represents field ticker.
tick_counter | Represents field tick_counter.
tracing | Represents field tracing.
Top


PyThreadState.async_exc Field

Summary

Represents field async_exc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 async_exc :PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyThreadState
  • BI.Plugins.Python.Engine


PyThreadState.curexc_traceback Field

Summary

Represents field curexc_traceback.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 curexc_traceback: PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyThreadState
  • BI.Plugins.Python.Engine


PyThreadState.curexc_type Field

Summary

Represents field curexc_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 curexc_type : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyThreadState
  • BI.Plugins.Python.Engine


PyThreadState.curexc_value Field

Summary

Represents field curexc_value.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 curexc_value : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyThreadState
  • BI.Plugins.Python.Engine


PyThreadState.dict Field

Summary

Represents field dict.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 dict : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyThreadState
  • BI.Plugins.Python.Engine


PyThreadState.exc_traceback Field

Summary

Represents field exc_traceback.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 exc_traceback : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyThreadState
  • BI.Plugins.Python.Engine


PyThreadState.exc_type Field

Summary

Represents field exc_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 exc_type : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyThreadState
  • BI.Plugins.Python.Engine


PyThreadState.exc_value Field

Summary

Represents field exc_value.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 exc_value : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyThreadState
  • BI.Plugins.Python.Engine


PyThreadState.frame Field

Summary

Represents field frame.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 frame : PPyFrameObject;

Field Value

Type: PPyFrameObject

See Also

Reference

  • PyThreadState
  • BI.Plugins.Python.Engine


PyThreadState.gilstate_counter Field

Summary

Represents field gilstate_counter.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 gilstate_counter :Integer;

Field Value

Type: Integer

See Also

Reference

  • PyThreadState
  • BI.Plugins.Python.Engine


PyThreadState.interp Field

Summary

Represents field interp.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 interp : PPyInterpreterState;

Field Value

Type: PPyInterpreterState

See Also

Reference

  • PyThreadState
  • BI.Plugins.Python.Engine


PyThreadState.next Field

Summary

Represents field next.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 next : PPyThreadState;

Field Value

Type: PPyThreadState

See Also

Reference

  • PyThreadState
  • BI.Plugins.Python.Engine


PyThreadState.recursion_depth Field

Summary

Represents field recursion_depth.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 recursion_depth: integer;

Field Value

Type: integer

See Also

Reference

  • PyThreadState
  • BI.Plugins.Python.Engine


PyThreadState.sys_profilefn Field

Summary

Represents field sys_profilefn.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 sys_profilefn : Pointer;

Field Value

Type: Pointer

See Also

Reference

  • PyThreadState
  • BI.Plugins.Python.Engine


PyThreadState.sys_profilefunc Field

Summary

Represents field sys_profilefunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 sys_profilefunc: PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyThreadState
  • BI.Plugins.Python.Engine


PyThreadState.sys_tracefn Field

Summary

Represents field sys_tracefn.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 sys_tracefn : Pointer;

Field Value

Type: Pointer

See Also

Reference

  • PyThreadState
  • BI.Plugins.Python.Engine


PyThreadState.sys_tracefunc Field

Summary

Represents field sys_tracefunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 sys_tracefunc : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyThreadState
  • BI.Plugins.Python.Engine


PyThreadState.thread_id Field

Summary

Represents field thread_id.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 thread_id :LongInt;

Field Value

Type: LongInt

See Also

Reference

  • PyThreadState
  • BI.Plugins.Python.Engine


PyThreadState.ticker Field

Summary

Represents field ticker.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ticker : integer;

Field Value

Type: integer

See Also

Reference

  • PyThreadState
  • BI.Plugins.Python.Engine


PyThreadState.tick_counter Field

Summary

Represents field tick_counter.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tick_counter :Integer;

Field Value

Type: Integer

See Also

Reference

  • PyThreadState
  • BI.Plugins.Python.Engine


PyThreadState.tracing Field

Summary

Represents field tracing.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tracing : integer;

Field Value

Type: integer

See Also

Reference

  • PyThreadState
  • BI.Plugins.Python.Engine


PyTraceBackObject Record

Summary

Represents type PyTraceBackObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyTraceBackObject = packed record
 end;

The PyTraceBackObject type exposes the following members.

Fields
Show:
Name | Description
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
tb_frame | Represents field tb_frame.
tb_lasti | Represents field tb_lasti.
tb_lineno | Represents field tb_lineno.
tb_next | Represents field tb_next.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyTraceBackObject Fields

Fields
Name | Description
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
tb_frame | Represents field tb_frame.
tb_lasti | Represents field tb_lasti.
tb_lineno | Represents field tb_lineno.
tb_next | Represents field tb_next.
Top


PyTraceBackObject.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyTraceBackObject
  • BI.Plugins.Python.Engine


PyTraceBackObject.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyTraceBackObject
  • BI.Plugins.Python.Engine


PyTraceBackObject.tb_frame Field

Summary

Represents field tb_frame.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tb_frame : PPyFrameObject;

Field Value

Type: PPyFrameObject

See Also

Reference

  • PyTraceBackObject
  • BI.Plugins.Python.Engine


PyTraceBackObject.tb_lasti Field

Summary

Represents field tb_lasti.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tb_lasti : Integer;

Field Value

Type: Integer

See Also

Reference

  • PyTraceBackObject
  • BI.Plugins.Python.Engine


PyTraceBackObject.tb_lineno Field

Summary

Represents field tb_lineno.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tb_lineno : Integer;

Field Value

Type: Integer

See Also

Reference

  • PyTraceBackObject
  • BI.Plugins.Python.Engine


PyTraceBackObject.tb_next Field

Summary

Represents field tb_next.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tb_next : PPyTraceBackObject;

Field Value

Type: PPyTraceBackObject

See Also

Reference

  • PyTraceBackObject
  • BI.Plugins.Python.Engine


PyTryBlock Record

Summary

Represents type PyTryBlock.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyTryBlock = packed record
 end;

The PyTryBlock type exposes the following members.

Fields
Show:
Name | Description
b_handler | Represents field b_handler.
b_level | Represents field b_level.
b_type | Represents field b_type.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyTryBlock Fields

Fields
Name | Description
b_handler | Represents field b_handler.
b_level | Represents field b_level.
b_type | Represents field b_type.
Top


PyTryBlock.b_handler Field

Summary

Represents field b_handler.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 b_handler : Integer;

Field Value

Type: Integer

See Also

Reference

  • PyTryBlock
  • BI.Plugins.Python.Engine


PyTryBlock.b_level Field

Summary

Represents field b_level.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 b_level : Integer;

Field Value

Type: Integer

See Also

Reference

  • PyTryBlock
  • BI.Plugins.Python.Engine


PyTryBlock.b_type Field

Summary

Represents field b_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 b_type : Integer;

Field Value

Type: Integer

See Also

Reference

  • PyTryBlock
  • BI.Plugins.Python.Engine


PyTypeObject Record

Summary

Represents type PyTypeObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyTypeObject = packed record
 end;

The PyTypeObject type exposes the following members.

Fields
Show:
Name | Description
ob_refcnt | Represents field ob_refcnt.
ob_size | Represents field ob_size.
ob_type | Represents field ob_type.
tp_alloc | Represents field tp_alloc.
tp_as_buffer |
tp_as_mapping | Represents field tp_as_mapping.
tp_as_number | Represents field tp_as_number.
tp_as_sequence | Represents field tp_as_sequence.
tp_base | Represents field tp_base.
tp_bases | Represents field tp_bases.
tp_basicsize | Represents field tp_basicsize.
tp_cache | Represents field tp_cache.
tp_call | Represents field tp_call.
tp_clear | Represents field tp_clear.
tp_compare | Represents field tp_compare.
tp_dealloc | Represents field tp_dealloc.
tp_descr_get | Represents field tp_descr_get.
tp_descr_set | Represents field tp_descr_set.
tp_dict | Represents field tp_dict.
tp_dictoffset | Represents field tp_dictoffset.
tp_doc | Represents field tp_doc.
tp_flags | Represents field tp_flags.
tp_free | Represents field tp_free.
tp_getattr | Represents field tp_getattr.
tp_getattro | Represents field tp_getattro.
tp_getset | Represents field tp_getset.
tp_hash | Represents field tp_hash.
tp_init | Represents field tp_init.
tp_is_gc | Represents field tp_is_gc.
tp_itemsize | Represents field tp_itemsize.
tp_iter | Represents field tp_iter.
tp_iternext | Represents field tp_iternext.
tp_members | Represents field tp_members.
tp_methods | Represents field tp_methods.
tp_mro | Represents field tp_mro.
tp_name | Represents field tp_name.
tp_new | Represents field tp_new.
tp_print | Represents field tp_print.
tp_repr | Represents field tp_repr.
tp_richcompare | Represents field tp_richcompare.
tp_setattr | Represents field tp_setattr.
tp_setattro | Represents field tp_setattro.
tp_str | Represents field tp_str.
tp_subclasses | Represents field tp_subclasses.
tp_traverse | Represents field tp_traverse.
tp_weaklist | Represents field tp_weaklist.
tp_weaklistoffset | Represents field tp_weaklistoffset.
tp_xxx7 | Represents field tp_xxx7.
tp_xxx8 | Represents field tp_xxx8.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyTypeObject Fields

Fields
Name | Description
ob_refcnt | Represents field ob_refcnt.
ob_size | Represents field ob_size.
ob_type | Represents field ob_type.
tp_alloc | Represents field tp_alloc.
tp_as_buffer |
tp_as_mapping | Represents field tp_as_mapping.
tp_as_number | Represents field tp_as_number.
tp_as_sequence | Represents field tp_as_sequence.
tp_base | Represents field tp_base.
tp_bases | Represents field tp_bases.
tp_basicsize | Represents field tp_basicsize.
tp_cache | Represents field tp_cache.
tp_call | Represents field tp_call.
tp_clear | Represents field tp_clear.
tp_compare | Represents field tp_compare.
tp_dealloc | Represents field tp_dealloc.
tp_descr_get | Represents field tp_descr_get.
tp_descr_set | Represents field tp_descr_set.
tp_dict | Represents field tp_dict.
tp_dictoffset | Represents field tp_dictoffset.
tp_doc | Represents field tp_doc.
tp_flags | Represents field tp_flags.
tp_free | Represents field tp_free.
tp_getattr | Represents field tp_getattr.
tp_getattro | Represents field tp_getattro.
tp_getset | Represents field tp_getset.
tp_hash | Represents field tp_hash.
tp_init | Represents field tp_init.
tp_is_gc | Represents field tp_is_gc.
tp_itemsize | Represents field tp_itemsize.
tp_iter | Represents field tp_iter.
tp_iternext | Represents field tp_iternext.
tp_members | Represents field tp_members.
tp_methods | Represents field tp_methods.
tp_mro | Represents field tp_mro.
tp_name | Represents field tp_name.
tp_new | Represents field tp_new.
tp_print | Represents field tp_print.
tp_repr | Represents field tp_repr.
tp_richcompare | Represents field tp_richcompare.
tp_setattr | Represents field tp_setattr.
tp_setattro | Represents field tp_setattro.
tp_str | Represents field tp_str.
tp_subclasses | Represents field tp_subclasses.
tp_traverse | Represents field tp_traverse.
tp_weaklist | Represents field tp_weaklist.
tp_weaklistoffset | Represents field tp_weaklistoffset.
tp_xxx7 | Represents field tp_xxx7.
tp_xxx8 | Represents field tp_xxx8.
Top


PyTypeObject.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt: NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.ob_size Field

Summary

Represents field ob_size.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_size: NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type: PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_alloc Field

Summary

Represents field tp_alloc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_alloc : allocfunc;

Field Value

Type: allocfunc

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_as_buffer Field

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_as_buffer: PPyBufferProcs;

Field Value

Type: PPyBufferProcs

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_as_mapping Field

Summary

Represents field tp_as_mapping.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_as_mapping: PPyMappingMethods;

Field Value

Type: PPyMappingMethods

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_as_number Field

Summary

Represents field tp_as_number.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_as_number: PPyNumberMethods;

Field Value

Type: PPyNumberMethods

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_as_sequence Field

Summary

Represents field tp_as_sequence.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_as_sequence: PPySequenceMethods;

Field Value

Type: PPySequenceMethods

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_base Field

Summary

Represents field tp_base.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_base : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_bases Field

Summary

Represents field tp_bases.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_bases : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_basicsize Field

Summary

Represents field tp_basicsize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_basicsize, tp_itemsize: NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_cache Field

Summary

Represents field tp_cache.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_cache : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_call Field

Summary

Represents field tp_call.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_call: ternaryfunc;

Field Value

Type: ternaryfunc

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_clear Field

Summary

Represents field tp_clear.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_clear: inquiry;

Field Value

Type: inquiry

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_compare Field

Summary

Represents field tp_compare.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_compare: cmpfunc;

Field Value

Type: cmpfunc

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_dealloc Field

Summary

Represents field tp_dealloc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_dealloc: pydestructor;

Field Value

Type: pydestructor

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_descr_get Field

Summary

Represents field tp_descr_get.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_descr_get : descrgetfunc;

Field Value

Type: descrgetfunc

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_descr_set Field

Summary

Represents field tp_descr_set.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_descr_set : descrsetfunc;

Field Value

Type: descrsetfunc

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_dict Field

Summary

Represents field tp_dict.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_dict : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_dictoffset Field

Summary

Represents field tp_dictoffset.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_dictoffset : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_doc Field

Summary

Represents field tp_doc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_doc: PAnsiChar;

Field Value

Type: PAnsiChar

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_flags Field

Summary

Represents field tp_flags.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_flags: LongInt;

Field Value

Type: LongInt

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_free Field

Summary

Represents field tp_free.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_free : pydestructor;

Field Value

Type: pydestructor

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_getattr Field

Summary

Represents field tp_getattr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_getattr: getattrfunc;

Field Value

Type: getattrfunc

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_getattro Field

Summary

Represents field tp_getattro.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_getattro: getattrofunc;

Field Value

Type: getattrofunc

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_getset Field

Summary

Represents field tp_getset.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_getset : PPyGetSetDef;

Field Value

Type: PPyGetSetDef

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_hash Field

Summary

Represents field tp_hash.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_hash: hashfunc;

Field Value

Type: hashfunc

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_init Field

Summary

Represents field tp_init.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_init : initproc;

Field Value

Type: initproc

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_is_gc Field

Summary

Represents field tp_is_gc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_is_gc : inquiry;

Field Value

Type: inquiry

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_itemsize Field

Summary

Represents field tp_itemsize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_basicsize, tp_itemsize: NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_iter Field

Summary

Represents field tp_iter.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_iter : getiterfunc;

Field Value

Type: getiterfunc

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_iternext Field

Summary

Represents field tp_iternext.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_iternext : iternextfunc;

Field Value

Type: iternextfunc

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_members Field

Summary

Represents field tp_members.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_members : PPyMemberDef;

Field Value

Type: PPyMemberDef

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_methods Field

Summary

Represents field tp_methods.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_methods : PPyMethodDef;

Field Value

Type: PPyMethodDef

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_mro Field

Summary

Represents field tp_mro.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_mro : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_name Field

Summary

Represents field tp_name.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_name: PAnsiChar;

Field Value

Type: PAnsiChar

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_new Field

Summary

Represents field tp_new.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_new : newfunc;

Field Value

Type: newfunc

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_print Field

Summary

Represents field tp_print.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_print: printfunc;

Field Value

Type: printfunc

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_repr Field

Summary

Represents field tp_repr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_repr: reprfunc;

Field Value

Type: reprfunc

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_richcompare Field

Summary

Represents field tp_richcompare.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_richcompare: richcmpfunc;

Field Value

Type: richcmpfunc

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_setattr Field

Summary

Represents field tp_setattr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_setattr: setattrfunc;

Field Value

Type: setattrfunc

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_setattro Field

Summary

Represents field tp_setattro.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_setattro: setattrofunc;

Field Value

Type: setattrofunc

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_str Field

Summary

Represents field tp_str.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_str: reprfunc;

Field Value

Type: reprfunc

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_subclasses Field

Summary

Represents field tp_subclasses.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_subclasses : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_traverse Field

Summary

Represents field tp_traverse.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_traverse: traverseproc;

Field Value

Type: traverseproc

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_weaklist Field

Summary

Represents field tp_weaklist.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_weaklist : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_weaklistoffset Field

Summary

Represents field tp_weaklistoffset.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_weaklistoffset: NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_xxx7 Field

Summary

Represents field tp_xxx7.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_xxx7 : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyTypeObject.tp_xxx8 Field

Summary

Represents field tp_xxx8.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 tp_xxx8 : LongInt;

Field Value

Type: LongInt

See Also

Reference

  • PyTypeObject
  • BI.Plugins.Python.Engine


PyWeakReference Record

Summary

Represents type PyWeakReference.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyWeakReference = packed record
 end;

The PyWeakReference type exposes the following members.

Fields
Show:
Name | Description
hash | Represents field hash.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
wr_callback | Represents field wr_callback.
wr_next | Represents field wr_next.
wr_object | Represents field wr_object.
wr_prev | Represents field wr_prev.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyWeakReference Fields

Fields
Name | Description
hash | Represents field hash.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
wr_callback | Represents field wr_callback.
wr_next | Represents field wr_next.
wr_object | Represents field wr_object.
wr_prev | Represents field wr_prev.
Top


PyWeakReference.hash Field

Summary

Represents field hash.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 hash : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyWeakReference
  • BI.Plugins.Python.Engine


PyWeakReference.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyWeakReference
  • BI.Plugins.Python.Engine


PyWeakReference.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyWeakReference
  • BI.Plugins.Python.Engine


PyWeakReference.wr_callback Field

Summary

Represents field wr_callback.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 wr_callback : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyWeakReference
  • BI.Plugins.Python.Engine


PyWeakReference.wr_next Field

Summary

Represents field wr_next.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 wr_next : PPyWeakReference;

Field Value

Type: PPyWeakReference

See Also

Reference

  • PyWeakReference
  • BI.Plugins.Python.Engine


PyWeakReference.wr_object Field

Summary

Represents field wr_object.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 wr_object : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyWeakReference
  • BI.Plugins.Python.Engine


PyWeakReference.wr_prev Field

Summary

Represents field wr_prev.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 wr_prev : PPyWeakReference;

Field Value

Type: PPyWeakReference

See Also

Reference

  • PyWeakReference
  • BI.Plugins.Python.Engine


PyWrapperDescrObject Record

Summary

Represents type PyWrapperDescrObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyWrapperDescrObject = packed record
 end;

The PyWrapperDescrObject type exposes the following members.

Fields
Show:
Name | Description
d_base | Represents field d_base.
d_name | Represents field d_name.
d_type | Represents field d_type.
d_wrapped | Represents field d_wrapped.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


PyWrapperDescrObject Fields

Fields
Name | Description
d_base | Represents field d_base.
d_name | Represents field d_name.
d_type | Represents field d_type.
d_wrapped | Represents field d_wrapped.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top


PyWrapperDescrObject.d_base Field

Summary

Represents field d_base.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 d_base : pwrapperbase;

Field Value

Type: pwrapperbase

See Also

Reference

  • PyWrapperDescrObject
  • BI.Plugins.Python.Engine


PyWrapperDescrObject.d_name Field

Summary

Represents field d_name.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 d_name : PPyObject;

Field Value

Type: PPyObject

See Also

Reference

  • PyWrapperDescrObject
  • BI.Plugins.Python.Engine


PyWrapperDescrObject.d_type Field

Summary

Represents field d_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 d_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyWrapperDescrObject
  • BI.Plugins.Python.Engine


PyWrapperDescrObject.d_wrapped Field

Summary

Represents field d_wrapped.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 d_wrapped : Pointer;

Field Value

Type: Pointer

See Also

Reference

  • PyWrapperDescrObject
  • BI.Plugins.Python.Engine


PyWrapperDescrObject.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • PyWrapperDescrObject
  • BI.Plugins.Python.Engine


PyWrapperDescrObject.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • PyWrapperDescrObject
  • BI.Plugins.Python.Engine


Py_complex Record

Summary

Represents type Py_complex.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 Py_complex = packed record
 end;

The Py_complex type exposes the following members.

Fields
Show:
Name | Description
imag | Represents field imag.
real | Represents field real.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


Py_complex Fields

Fields
Name | Description
imag | Represents field imag.
real | Represents field real.
Top


Py_complex.imag Field

Summary

Represents field imag.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 imag : double;

Field Value

Type: double

See Also

Reference

  • Py_complex
  • BI.Plugins.Python.Engine


Py_complex.real Field

Summary

Represents field real.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 real : double;

Field Value

Type: double

See Also

Reference

  • Py_complex
  • BI.Plugins.Python.Engine


TCodeMemBlock Record

Summary

Represents type TCodeMemBlock.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TCodeMemBlock = packed record
 end;

The TCodeMemBlock type exposes the following members.

Fields
Show:
Name | Description
Code | Represents field Code.
Next | Represents field Next.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TCodeMemBlock Fields

Fields
Name | Description
Code | Represents field Code.
Next | Represents field Next.
Top


TCodeMemBlock.Code Field

Summary

Represents field Code.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Code: array[0..1] of byte;

Field Value

Type: array[0..1] of byte

See Also

Reference

  • TCodeMemBlock
  • BI.Plugins.Python.Engine


TCodeMemBlock.Next Field

Summary

Represents field Next.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Next: PCodeMemBlock;

Field Value

Type: PCodeMemBlock

See Also

Reference

  • TCodeMemBlock
  • BI.Plugins.Python.Engine


TCodeMemPage Record

Summary

Represents type TCodeMemPage.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TCodeMemPage = packed record
 end;

The TCodeMemPage type exposes the following members.

Fields
Show:
Name | Description
CodeBlocks | Represents field CodeBlocks.
Next | Represents field Next.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TCodeMemPage Fields

Fields
Name | Description
CodeBlocks | Represents field CodeBlocks.
Next | Represents field Next.
Top


TCodeMemPage.CodeBlocks Field

Summary

Represents field CodeBlocks.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 CodeBlocks: PCodeMemBlock;

Field Value

Type: PCodeMemBlock

See Also

Reference

  • TCodeMemPage
  • BI.Plugins.Python.Engine


TCodeMemPage.Next Field

Summary

Represents field Next.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 Next: PCodeMemPage;

Field Value

Type: PCodeMemPage

See Also

Reference

  • TCodeMemPage
  • BI.Plugins.Python.Engine


TPythonVersionProp Record

Summary

Represents type TPythonVersionProp.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TPythonVersionProp = packed record
 end;

The TPythonVersionProp type exposes the following members.

Fields
Show:
Name | Description
APIVersion | Represents field APIVersion.
CanUseLatest | Represents field CanUseLatest.
DllName | Represents field DllName.
RegVersion | Represents field RegVersion.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TPythonVersionProp Fields

Fields
Name | Description
APIVersion | Represents field APIVersion.
CanUseLatest | Represents field CanUseLatest.
DllName | Represents field DllName.
RegVersion | Represents field RegVersion.
Top


TPythonVersionProp.APIVersion Field

Summary

Represents field APIVersion.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 APIVersion : Integer;

Field Value

Type: Integer

See Also

Reference

  • TPythonVersionProp
  • BI.Plugins.Python.Engine


TPythonVersionProp.CanUseLatest Field

Summary

Represents field CanUseLatest.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 CanUseLatest : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TPythonVersionProp
  • BI.Plugins.Python.Engine


TPythonVersionProp.DllName Field

Summary

Represents field DllName.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 DllName : String;

Field Value

Type: String

See Also

Reference

  • TPythonVersionProp
  • BI.Plugins.Python.Engine


TPythonVersionProp.RegVersion Field

Summary

Represents field RegVersion.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 RegVersion : String;

Field Value

Type: String

See Also

Reference

  • TPythonVersionProp
  • BI.Plugins.Python.Engine


wrapperbase Record

Summary

Represents type wrapperbase.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 wrapperbase = packed record
 end;

The wrapperbase type exposes the following members.

Fields
Show:
Name | Description
doc | Represents field doc.
name | Represents field name.
wrapper | Represents field wrapper.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


wrapperbase Fields

Fields
Name | Description
doc | Represents field doc.
name | Represents field name.
wrapper | Represents field wrapper.
Top


wrapperbase.doc Field

Summary

Represents field doc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 doc : PAnsiChar;

Field Value

Type: PAnsiChar

See Also

Reference

  • wrapperbase
  • BI.Plugins.Python.Engine


wrapperbase.name Field

Summary

Represents field name.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 name : PAnsiChar;

Field Value

Type: PAnsiChar

See Also

Reference

  • wrapperbase
  • BI.Plugins.Python.Engine


wrapperbase.wrapper Field

Summary

Represents field wrapper.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 wrapper : wrapperfunc;

Field Value

Type: wrapperfunc

See Also

Reference

  • wrapperbase
  • BI.Plugins.Python.Engine


_frozen Record

Summary

Represents type _frozen.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 _frozen = packed record
 end;

The _frozen type exposes the following members.

Fields
Show:
Name | Description
code | Represents field code.
name | Represents field name.
size | Represents field size.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


_frozen Fields

Fields
Name | Description
code | Represents field code.
name | Represents field name.
size | Represents field size.
Top


_frozen.code Field

Summary

Represents field code.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 code : PByte;

Field Value

Type: PByte

See Also

Reference

  • _frozen
  • BI.Plugins.Python.Engine


_frozen.name Field

Summary

Represents field name.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 name : PAnsiChar;

Field Value

Type: PAnsiChar

See Also

Reference

  • _frozen
  • BI.Plugins.Python.Engine


_frozen.size Field

Summary

Represents field size.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 size : Integer;

Field Value

Type: Integer

See Also

Reference

  • _frozen
  • BI.Plugins.Python.Engine


_PyDateTime_BaseDateTime Record

Summary

Represents type _PyDateTime_BaseDateTime.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 _PyDateTime_BaseDateTime = packed record
 end;

The _PyDateTime_BaseDateTime type exposes the following members.

Fields
Show:
Name | Description
data | Represents field data.
hashcode | Represents field hashcode.
hastzinfo | Represents field hastzinfo.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


_PyDateTime_BaseDateTime Fields

Fields
Name | Description
data | Represents field data.
hashcode | Represents field hashcode.
hastzinfo | Represents field hastzinfo.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top


_PyDateTime_BaseDateTime.data Field

Summary

Represents field data.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 data : array[0..Pred(_PyDateTime_DATETIME_DATASIZE)] of Byte;

Field Value

Type: array[0..Pred(_PyDateTime_DATETIME_DATASIZE)] of Byte

See Also

Reference

  • _PyDateTime_BaseDateTime
  • BI.Plugins.Python.Engine


_PyDateTime_BaseDateTime.hashcode Field

Summary

Represents field hashcode.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 hashcode : Integer;

Field Value

Type: Integer

See Also

Reference

  • _PyDateTime_BaseDateTime
  • BI.Plugins.Python.Engine


_PyDateTime_BaseDateTime.hastzinfo Field

Summary

Represents field hastzinfo.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 hastzinfo : Char;

Field Value

Type: Char

See Also

Reference

  • _PyDateTime_BaseDateTime
  • BI.Plugins.Python.Engine


_PyDateTime_BaseDateTime.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • _PyDateTime_BaseDateTime
  • BI.Plugins.Python.Engine


_PyDateTime_BaseDateTime.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • _PyDateTime_BaseDateTime
  • BI.Plugins.Python.Engine


_PyDateTime_BaseTime Record

Summary

Represents type _PyDateTime_BaseTime.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 _PyDateTime_BaseTime = packed record
 end;

The _PyDateTime_BaseTime type exposes the following members.

Fields
Show:
Name | Description
data | Represents field data.
hashcode | Represents field hashcode.
hastzinfo | Represents field hastzinfo.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


_PyDateTime_BaseTime Fields

Fields
Name | Description
data | Represents field data.
hashcode | Represents field hashcode.
hastzinfo | Represents field hastzinfo.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top


_PyDateTime_BaseTime.data Field

Summary

Represents field data.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 data : array[0..Pred(_PyDateTime_TIME_DATASIZE)] of Byte;

Field Value

Type: array[0..Pred(_PyDateTime_TIME_DATASIZE)] of Byte

See Also

Reference

  • _PyDateTime_BaseTime
  • BI.Plugins.Python.Engine


_PyDateTime_BaseTime.hashcode Field

Summary

Represents field hashcode.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 hashcode : Integer;

Field Value

Type: Integer

See Also

Reference

  • _PyDateTime_BaseTime
  • BI.Plugins.Python.Engine


_PyDateTime_BaseTime.hastzinfo Field

Summary

Represents field hastzinfo.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 hastzinfo : Char;

Field Value

Type: Char

See Also

Reference

  • _PyDateTime_BaseTime
  • BI.Plugins.Python.Engine


_PyDateTime_BaseTime.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • _PyDateTime_BaseTime
  • BI.Plugins.Python.Engine


_PyDateTime_BaseTime.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • _PyDateTime_BaseTime
  • BI.Plugins.Python.Engine


_PyDateTime_BaseTZInfo Record

Summary

Represents type _PyDateTime_BaseTZInfo.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 _PyDateTime_BaseTZInfo = packed record
 end;

The _PyDateTime_BaseTZInfo type exposes the following members.

Fields
Show:
Name | Description
hashcode | Represents field hashcode.
hastzinfo | Represents field hastzinfo.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


_PyDateTime_BaseTZInfo Fields

Fields
Name | Description
hashcode | Represents field hashcode.
hastzinfo | Represents field hastzinfo.
ob_refcnt | Represents field ob_refcnt.
ob_type | Represents field ob_type.
Top


_PyDateTime_BaseTZInfo.hashcode Field

Summary

Represents field hashcode.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 hashcode : Integer;

Field Value

Type: Integer

See Also

Reference

  • _PyDateTime_BaseTZInfo
  • BI.Plugins.Python.Engine


_PyDateTime_BaseTZInfo.hastzinfo Field

Summary

Represents field hastzinfo.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 hastzinfo : Char;

Field Value

Type: Char

See Also

Reference

  • _PyDateTime_BaseTZInfo
  • BI.Plugins.Python.Engine


_PyDateTime_BaseTZInfo.ob_refcnt Field

Summary

Represents field ob_refcnt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_refcnt : NativeInt;

Field Value

Type: NativeInt

See Also

Reference

  • _PyDateTime_BaseTZInfo
  • BI.Plugins.Python.Engine


_PyDateTime_BaseTZInfo.ob_type Field

Summary

Represents field ob_type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
public
 ob_type : PPyTypeObject;

Field Value

Type: PPyTypeObject

See Also

Reference

  • _PyDateTime_BaseTZInfo
  • BI.Plugins.Python.Engine


BI.Plugins.Python.Engine Enumerations

Enumerations
Name | Description
BI.Plugins.Python.Engine. | Represents type .
BI.Plugins.Python.Engine. | Represents type .
BI.Plugins.Python.Engine. | Represents type .
BI.Plugins.Python.Engine. | Represents type .
BI.Plugins.Python.Engine. | Represents type .
PyGILState_STATE | Represents type PyGILState_STATE.
TCallType | Represents type TCallType.
TDatetimeConversionMode | Represents type TDatetimeConversionMode.
TErrorType | Represents type TErrorType.
TPFlag | Represents type TPFlag.
TPyMemberFlag | Represents type TPyMemberFlag.
TPyMemberType | Represents type TPyMemberType.
TPythonFlag | Represents type TPythonFlag.
TRichComparisonOpcode | Represents type TRichComparisonOpcode.
TThreadExecMode | Represents type TThreadExecMode.
Top


Enumeration

Summary

Represents type .

Namespace: BI.Plugins.Python.Engine
See Also

Reference

  • BI.Plugins.Python.Engine


PyGILState_STATE Enumeration

Summary

Represents type PyGILState_STATE.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyGILState_STATE = (PyGILState_LOCKED, PyGILState_UNLOCKED);

The PyGILState_STATE type exposes the following members.

Members
Show:
Name | Description
PyGILState_LOCKED | Represents constant PyGILState_LOCKED.
PyGILState_UNLOCKED | Represents constant PyGILState_UNLOCKED.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TCallType Enumeration

Summary

Represents type TCallType.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TCallType = (ctSTDCALL, ctCDECL);

The TCallType type exposes the following members.

Members
Show:
Name | Description
ctCDECL | Represents constant ctCDECL.
ctSTDCALL | Represents constant ctSTDCALL.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TDatetimeConversionMode Enumeration

Summary

Represents type TDatetimeConversionMode.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TDatetimeConversionMode = (dcmToTuple, dcmToDatetime);

The TDatetimeConversionMode type exposes the following members.

Members
Show:
Name | Description
dcmToDatetime | Represents constant dcmToDatetime.
dcmToTuple | Represents constant dcmToTuple.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TErrorType Enumeration

Summary

Represents type TErrorType.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TErrorType = (etString, etClass);

The TErrorType type exposes the following members.

Members
Show:
Name | Description
etClass | Represents constant etClass.
etString | Represents constant etString.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TPFlag Enumeration

Summary

Represents type TPFlag.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TPFlag = (tpfHaveGetCharBuffer, tpfHaveSequenceIn, tpfGC, tpfHaveInplaceOps,
 tpfCheckTypes, tpfHaveRichCompare, tpfHaveWeakRefs
 ,tpfHaveIter, tpfHaveClass, tpfHeapType, tpfBaseType, tpfReady, tpfReadying, tpfHaveGC
 );

The TPFlag type exposes the following members.

Members
Show:
Name | Description
tpfBaseType | Represents constant tpfBaseType.
tpfCheckTypes | Represents constant tpfCheckTypes.
tpfGC | Represents constant tpfGC.
tpfHaveClass | Represents constant tpfHaveClass.
tpfHaveGC | Represents constant tpfHaveGC.
tpfHaveGetCharBuffer | Represents constant tpfHaveGetCharBuffer.
tpfHaveInplaceOps | Represents constant tpfHaveInplaceOps.
tpfHaveIter | Represents constant tpfHaveIter.
tpfHaveRichCompare | Represents constant tpfHaveRichCompare.
tpfHaveSequenceIn | Represents constant tpfHaveSequenceIn.
tpfHaveWeakRefs | Represents constant tpfHaveWeakRefs.
tpfHeapType | Represents constant tpfHeapType.
tpfReady | Represents constant tpfReady.
tpfReadying | Represents constant tpfReadying.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TPyMemberFlag Enumeration

Summary

Represents type TPyMemberFlag.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TPyMemberFlag = (mfDefault, mfReadOnly, mfReadRestricted, mfWriteRestricted, mfRestricted);

The TPyMemberFlag type exposes the following members.

Members
Show:
Name | Description
mfDefault | Represents constant mfDefault.
mfReadOnly | Represents constant mfReadOnly.
mfReadRestricted | Represents constant mfReadRestricted.
mfRestricted | Represents constant mfRestricted.
mfWriteRestricted | Represents constant mfWriteRestricted.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TPyMemberType Enumeration

Summary

Represents type TPyMemberType.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TPyMemberType = (mtShort, mtInt, mtLong, mtFloat, mtDouble, mtString, mtObject,
 mtChar, mtByte, mtUByte, mtUShort, mtUInt, mtULong,
 mtStringInplace, mtObjectEx);

The TPyMemberType type exposes the following members.

Members
Show:
Name | Description
mtByte | Represents constant mtByte.
mtChar | Represents constant mtChar.
mtDouble | Represents constant mtDouble.
mtFloat | Represents constant mtFloat.
mtInt | Represents constant mtInt.
mtLong | Represents constant mtLong.
mtObject | Represents constant mtObject.
mtObjectEx | Represents constant mtObjectEx.
mtShort | Represents constant mtShort.
mtString | Represents constant mtString.
mtStringInplace | Represents constant mtStringInplace.
mtUByte | Represents constant mtUByte.
mtUInt | Represents constant mtUInt.
mtULong | Represents constant mtULong.
mtUShort | Represents constant mtUShort.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TPythonFlag Enumeration

Summary

Represents type TPythonFlag.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TPythonFlag = (pfDebug, pfInteractive, pfNoSite, pfOptimize, pfTabcheck, pfUnicode, pfVerbose,
 pfUseClassExceptionsFlag, pfFrozenFlag, pfIgnoreEnvironmentFlag, pfDivisionWarningFlag);

The TPythonFlag type exposes the following members.

Members
Show:
Name | Description
pfDebug | Represents constant pfDebug.
pfDivisionWarningFlag | Represents constant pfDivisionWarningFlag.
pfFrozenFlag | Represents constant pfFrozenFlag.
pfIgnoreEnvironmentFlag | Represents constant pfIgnoreEnvironmentFlag.
pfInteractive | Represents constant pfInteractive.
pfNoSite | Represents constant pfNoSite.
pfOptimize | Represents constant pfOptimize.
pfTabcheck | Represents constant pfTabcheck.
pfUnicode | Represents constant pfUnicode.
pfUseClassExceptionsFlag | Represents constant pfUseClassExceptionsFlag.
pfVerbose | Represents constant pfVerbose.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TRichComparisonOpcode Enumeration

Summary

Represents type TRichComparisonOpcode.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TRichComparisonOpcode = (pyLT, pyLE, pyEQ, pyNE, pyGT, pyGE);

The TRichComparisonOpcode type exposes the following members.

Members
Show:
Name | Description
pyEQ | Represents constant pyEQ.
pyGE | Represents constant pyGE.
pyGT | Represents constant pyGT.
pyLE | Represents constant pyLE.
pyLT | Represents constant pyLT.
pyNE | Represents constant pyNE.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TThreadExecMode Enumeration

Summary

Represents type TThreadExecMode.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TThreadExecMode = (emNewState, emNewInterpreter);

The TThreadExecMode type exposes the following members.

Members
Show:
Name | Description
emNewInterpreter | Represents constant emNewInterpreter.
emNewState | Represents constant emNewState.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


BI.Plugins.Python.Engine Delegates

Delegates
Name | Description
allocfunc | Represents type allocfunc.
AtExitProc | Represents type AtExitProc.
binaryfunc | Represents type binaryfunc.
cmpfunc | Represents type cmpfunc.
coercion | Represents type coercion.
descrgetfunc | Represents type descrgetfunc.
descrsetfunc | Represents type descrsetfunc.
getattrfunc | Represents type getattrfunc.
getattrofunc | Represents type getattrofunc.
getcharbufferproc | Represents type getcharbufferproc.
getiterfunc | Represents type getiterfunc.
getreadbufferproc |
getsegcountproc | Represents type getsegcountproc.
getter | Represents type getter.
getwritebufferproc | Represents type getwritebufferproc.
hashfunc | Represents type hashfunc.
initproc | Represents type initproc.
inquiry | Represents type inquiry.
iternextfunc | Represents type iternextfunc.
lenfunc | Represents type lenfunc.
newfunc | Represents type newfunc.
objobjargproc | Represents type objobjargproc.
objobjproc | Represents type objobjproc.
printfunc | Represents type printfunc.
PyCFunction | Represents type PyCFunction.
PyCFunctionWithKW | Represents type PyCFunctionWithKW.
pydestructor | Represents type pydestructor.
reprfunc | Represents type reprfunc.
richcmpfunc | Represents type richcmpfunc.
setattrfunc | Represents type setattrfunc.
setattrofunc | Represents type setattrofunc.
setter | Represents type setter.
ssizeargfunc | Represents type ssizeargfunc.
ssizeobjargproc | Represents type ssizeobjargproc.
ssizessizeargfunc | Represents type ssizessizeargfunc.
ssizessizeobjargproc | Represents type ssizessizeobjargproc.
TCallBack | Represents type TCallBack.
TDDEAPIfunc | Represents type TDDEAPIfunc.
TDelphiMethod | Represents type TDelphiMethod.
TDelphiMethodWithKW | Represents type TDelphiMethodWithKW.
ternaryfunc | Represents type ternaryfunc.
TExtGetDataEvent | Represents type TExtGetDataEvent.
TExtSetDataEvent | Represents type TExtSetDataEvent.
TGetDataEvent | Represents type TGetDataEvent.
TPathInitializationEvent | Represents type TPathInitializationEvent.
TPythonEvent | Represents type TPythonEvent.
traverseproc | Represents type traverseproc.
TReceiveDataEvent | Represents type TReceiveDataEvent.
TReceiveUniDataEvent | Represents type TReceiveUniDataEvent.
TSendDataEvent | Represents type TSendDataEvent.
TSendUniDataEvent | Represents type TSendUniDataEvent.
TSetDataEvent | Represents type TSetDataEvent.
TSysPathInitEvent | Represents type TSysPathInitEvent.
unaryfunc | Represents type unaryfunc.
visitproc | Represents type visitproc.
wrapperfunc | Represents type wrapperfunc.
Top


allocfunc Delegate

Summary

Represents type allocfunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 allocfunc = function ( self: PPyTypeObject; nitems : NativeInt) : PPyObject; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


AtExitProc Delegate

Summary

Represents type AtExitProc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 AtExitProc = procedure;
See Also

Reference

  • BI.Plugins.Python.Engine


binaryfunc Delegate

Summary

Represents type binaryfunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 binaryfunc = function( ob1,ob2 : PPyObject): PPyObject; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


cmpfunc Delegate

Summary

Represents type cmpfunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 cmpfunc = function( ob1,ob2: PPyObject): integer; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


coercion Delegate

Summary

Represents type coercion.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 coercion = function( ob1,ob2 : PPPyObject): integer; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


descrgetfunc Delegate

Summary

Represents type descrgetfunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 descrgetfunc = function ( ob1, ob2, ob3 : PPyObject) : PPyObject; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


descrsetfunc Delegate

Summary

Represents type descrsetfunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 descrsetfunc = function ( ob1, ob2, ob3 : PPyObject) : Integer; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


getattrfunc Delegate

Summary

Represents type getattrfunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 getattrfunc = function( ob1: PPyObject; name: PAnsiChar): PPyObject; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


getattrofunc Delegate

Summary

Represents type getattrofunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 getattrofunc = function( ob1,ob2: PPyObject): PPyObject; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


getcharbufferproc Delegate

Summary

Represents type getcharbufferproc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 getcharbufferproc = function ( ob1: PPyObject; i: NativeInt; const pstr: PAnsiChar): NativeInt; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


getiterfunc Delegate

Summary

Represents type getiterfunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 getiterfunc = function ( ob1 : PPyObject) : PPyObject; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


getreadbufferproc Delegate

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 getreadbufferproc = function ( ob1: PPyObject; i: NativeInt; ptr: Pointer): NativeInt; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


getsegcountproc Delegate

Summary

Represents type getsegcountproc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 getsegcountproc = function ( ob1: PPyObject; i: NativeInt): NativeInt; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


getter Delegate

Summary

Represents type getter.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 getter = function ( obj : PPyObject; context : Pointer) : PPyObject; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


getwritebufferproc Delegate

Summary

Represents type getwritebufferproc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 getwritebufferproc= function ( ob1: PPyObject; i: NativeInt; ptr: Pointer): NativeInt; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


hashfunc Delegate

Summary

Represents type hashfunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 hashfunc = function( ob: PPyObject): NativeInt; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


initproc Delegate

Summary

Represents type initproc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 initproc = function ( self, args, kwds : PPyObject) : Integer; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


inquiry Delegate

Summary

Represents type inquiry.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 inquiry = function( ob1 : PPyObject): integer; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


iternextfunc Delegate

Summary

Represents type iternextfunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 iternextfunc = function ( ob1 : PPyObject) : PPyObject; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


lenfunc Delegate

Summary

Represents type lenfunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 lenfunc = function( ob1 : PPyObject): NativeInt; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


newfunc Delegate

Summary

Represents type newfunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 newfunc = function ( subtype: PPyTypeObject; args, kwds : PPyObject) : PPyObject; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


objobjargproc Delegate

Summary

Represents type objobjargproc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 objobjargproc = function( ob1,ob2,ob3 : PPyObject): integer; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


objobjproc Delegate

Summary

Represents type objobjproc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 objobjproc = function ( ob1, ob2: PPyObject): integer; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


printfunc Delegate

Summary

Represents type printfunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 printfunc = function( ob: PPyObject; var f: file; i: integer): integer; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


PyCFunction Delegate

Summary

Represents type PyCFunction.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyCFunction = function( self, args:PPyObject): PPyObject; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


PyCFunctionWithKW Delegate

Summary

Represents type PyCFunctionWithKW.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PyCFunctionWithKW = function( self, args, keywords:PPyObject): PPyObject; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


pydestructor Delegate

Summary

Represents type pydestructor.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 pydestructor = procedure(ob: PPyObject); cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


reprfunc Delegate

Summary

Represents type reprfunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 reprfunc = function( ob: PPyObject): PPyObject; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


richcmpfunc Delegate

Summary

Represents type richcmpfunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 richcmpfunc = function ( ob1, ob2 : PPyObject; i : Integer) : PPyObject; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


setattrfunc Delegate

Summary

Represents type setattrfunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 setattrfunc = function( ob1: PPyObject; name: PAnsiChar; ob2: PPyObject): integer; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


setattrofunc Delegate

Summary

Represents type setattrofunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 setattrofunc = function( ob1,ob2,ob3: PPyObject): integer; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


setter Delegate

Summary

Represents type setter.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 setter = function ( obj, value : PPyObject; context : Pointer) : integer; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


ssizeargfunc Delegate

Summary

Represents type ssizeargfunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 ssizeargfunc = function( ob1 : PPyObject; i: NativeInt): PPyObject; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


ssizeobjargproc Delegate

Summary

Represents type ssizeobjargproc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 ssizeobjargproc = function( ob1 : PPyObject; i: NativeInt; ob2 : PPyObject):
 integer; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


ssizessizeargfunc Delegate

Summary

Represents type ssizessizeargfunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 ssizessizeargfunc = function( ob1 : PPyObject; i1, i2: NativeInt):
 PPyObject; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


ssizessizeobjargproc Delegate

Summary

Represents type ssizessizeobjargproc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 ssizessizeobjargproc = function( ob1: PPyObject; i1, i2: NativeInt;
 ob2: PPyObject): integer; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


TCallBack Delegate

Summary

Represents type TCallBack.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TCallBack = procedure of object;
See Also

Reference

  • BI.Plugins.Python.Engine


TDDEAPIfunc Delegate

Summary

Represents type TDDEAPIfunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TDDEAPIfunc = function( CallType, Fmt: Integer; Conv: longint;
 hsz1, hsz2: longint;
 Data: longint; Data1, Data2: integer):
 longint of object; stdcall;
See Also

Reference

  • BI.Plugins.Python.Engine


TDelphiMethod Delegate

Summary

Represents type TDelphiMethod.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TDelphiMethod = function ( self, args : PPyObject ) : PPyObject of object; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


TDelphiMethodWithKW Delegate

Summary

Represents type TDelphiMethodWithKW.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TDelphiMethodWithKW = function ( self, args, keywords : PPyObject ) : PPyObject of object; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


ternaryfunc Delegate

Summary

Represents type ternaryfunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 ternaryfunc = function( ob1,ob2,ob3 : PPyObject): PPyObject; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


TExtGetDataEvent Delegate

Summary

Represents type TExtGetDataEvent.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TExtGetDataEvent = procedure ( Sender : TObject; var Data : PPyObject ) of Object;
See Also

Reference

  • BI.Plugins.Python.Engine


TExtSetDataEvent Delegate

Summary

Represents type TExtSetDataEvent.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TExtSetDataEvent = procedure ( Sender : TObject; Data : PPyObject) of Object;
See Also

Reference

  • BI.Plugins.Python.Engine


TGetDataEvent Delegate

Summary

Represents type TGetDataEvent.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TGetDataEvent = procedure ( Sender : TObject; var Data : Variant ) of Object;
See Also

Reference

  • BI.Plugins.Python.Engine


TPathInitializationEvent Delegate

Summary

Represents type TPathInitializationEvent.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TPathInitializationEvent = procedure ( Sender : TObject; var Path : String ) of Object;
See Also

Reference

  • BI.Plugins.Python.Engine


TPythonEvent Delegate

Summary

Represents type TPythonEvent.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TPythonEvent = procedure(Sender: TObject; PSelf, Args: PPyObject; var Result: PPyObject) of object;
See Also

Reference

  • BI.Plugins.Python.Engine


traverseproc Delegate

Summary

Represents type traverseproc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 traverseproc = function ( ob1: PPyObject; proc: visitproc; ptr: Pointer): integer; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


TReceiveDataEvent Delegate

Summary

Represents type TReceiveDataEvent.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TReceiveDataEvent = procedure (Sender: TObject; var Data : AnsiString ) of object;
See Also

Reference

  • BI.Plugins.Python.Engine


TReceiveUniDataEvent Delegate

Summary

Represents type TReceiveUniDataEvent.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TReceiveUniDataEvent = procedure (Sender: TObject; var Data : UnicodeString ) of object;
See Also

Reference

  • BI.Plugins.Python.Engine


TSendDataEvent Delegate

Summary

Represents type TSendDataEvent.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TSendDataEvent = procedure (Sender: TObject; const Data : AnsiString ) of object;
See Also

Reference

  • BI.Plugins.Python.Engine


TSendUniDataEvent Delegate

Summary

Represents type TSendUniDataEvent.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TSendUniDataEvent = procedure (Sender: TObject; const Data : UnicodeString ) of object;
See Also

Reference

  • BI.Plugins.Python.Engine


TSetDataEvent Delegate

Summary

Represents type TSetDataEvent.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TSetDataEvent = procedure ( Sender : TObject; Data : Variant ) of Object;
See Also

Reference

  • BI.Plugins.Python.Engine


TSysPathInitEvent Delegate

Summary

Represents type TSysPathInitEvent.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TSysPathInitEvent = procedure ( Sender : TObject; PathList : PPyObject ) of Object;
See Also

Reference

  • BI.Plugins.Python.Engine


unaryfunc Delegate

Summary

Represents type unaryfunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 unaryfunc = function( ob1 : PPyObject): PPyObject; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


visitproc Delegate

Summary

Represents type visitproc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 visitproc = function ( ob1: PPyObject; ptr: Pointer): integer; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


wrapperfunc Delegate

Summary

Represents type wrapperfunc.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 wrapperfunc = function (self, args: PPyObject; wrapped : Pointer) : PPyObject; cdecl;
See Also

Reference

  • BI.Plugins.Python.Engine


BI.Plugins.Python.Engine Types

Types
Name | Description
CO_MAXBLOCKS | Represents type CO_MAXBLOCKS.
IOChar | Represents an alias of the WideChar type.
IOString | Represents an alias of the UnicodeString type.
PByte | Represents a pointer type to Byte.
PCodeMemBlock | Represents a pointer type to TCodeMemBlock.
PCodeMemPage | Represents a pointer type to TCodeMemPage.
PDouble | Represents a pointer type to Double.
PFloat | Represents a pointer type to Real.
PGetSetArray | Represents a pointer type to TGetSetArray.
PInt | Represents a pointer type to Integer.
PLong | Represents a pointer type to LongInt.
PMemberArray | Represents a pointer type to TMemberArray.
PMethodArray | Represents a pointer type to TMethodArray.
PNativeInt | Represents a pointer type to NativeInt.
PNode | Represents a pointer type to node.
PPAnsiChar | Represents a pointer type to TPAnsiChar.
PPPPyObject | Represents a pointer type to PPPyObject.
PPPyObject | Represents a pointer type to PPyObject.
PPWideChar | Represents a pointer type to TPWideChar.
PPyBufferProcs | Represents a pointer type to PyBufferProcs.
PPyClassObject | Represents a pointer type to PyClassObject.
PPyCodeObject | Represents a pointer type to PyCodeObject.
PPyDateTime_Date | Represents a pointer type to PyDateTime_Date.
PPyDateTime_DateTime | Represents a pointer type to PyDateTime_DateTime.
PPyDateTime_Delta | Represents a pointer type to PyDateTime_Delta.
PPyDateTime_Time | Represents a pointer type to PyDateTime_Time.
PPyDateTime_TZInfo | Represents a pointer type to PyDateTime_TZInfo.
PPyDescrObject | Represents a pointer type to PyDescrObject.
PPyFrameObject | Represents a pointer type to PyFrameObject.
PPyGetSetDef | Represents a pointer type to PyGetSetDef.
PPyGetSetDescrObject | Represents a pointer type to PyGetSetDescrObject.
PPyInstanceObject | Represents a pointer type to PyInstanceObject.
PPyInterpreterState | Represents a pointer type to PyInterpreterState.
PPyIntObject | Represents a pointer type to PyIntObject.
PPyMappingMethods | Represents a pointer type to PyMappingMethods.
PPyMemberDef | Represents a pointer type to PyMemberDef.
PPyMemberDescrObject | Represents a pointer type to PyMemberDescrObject.
PPyMethodChain | Represents a pointer type to PyMethodChain.
PPyMethodDef | Represents a pointer type to PyMethodDef.
PPyMethodDescrObject | Represents a pointer type to PyMethodDescrObject.
PPyMethodObject | Represents a pointer type to PyMethodObject.
PPyModuleDef | Represents a pointer type to PyModuleDef.
PPyModuleDef_Base | Represents a pointer type to PyModuleDef_Base.
PPyNumberMethods | Represents a pointer type to PyNumberMethods.
PPyObject | Represents a pointer type to PyObject.
PPySequenceMethods | Represents a pointer type to PySequenceMethods.
PPySliceObject | Represents a pointer type to PySliceObject.
PPyThreadState | Represents a pointer type to PyThreadState.
PPyTraceBackObject | Represents a pointer type to PyTraceBackObject.
PPyTryBlock | Represents a pointer type to PyTryBlock.
PPyTypeObject | Represents a pointer type to PyTypeObject.
PPyWeakReference | Represents a pointer type to PyWeakReference.
PPyWrapperDescrObject | Represents a pointer type to PyWrapperDescrObject.
PP_frozen | Represents a pointer type to P_frozen.
PShort | Represents a pointer type to ShortInt.
PtrCalcType | Represents an alias of the Longint type.
pwrapperbase | Represents a pointer type to wrapperbase.
P_frozen | Represents a pointer type to _frozen.
TBasicServices | Represents type TBasicServices.
TGetSetArray | Represents an array of the PyGetSetDef type.
TInplaceNumberServices | Represents type TInplaceNumberServices.
TIOStringList | Represents an alias of the TUnicodeStringList type.
TMappingServices | Represents type TMappingServices.
TMemberArray | Represents an array of the PyMemberDef type.
TMethodArray | Represents an array of the PyMethodDef type.
TNumberServices | Represents type TNumberServices.
TPAnsiChar | Represents an array of the PAnsiChar type.
TPFlags | Represents type TPFlags.
TPWideChar | Represents an array of the PWideChar type.
TPyObjectClass | Represents type TPyObjectClass.
TPythonFlags | Represents type TPythonFlags.
TSequenceServices | Represents type TSequenceServices.
TUnicodeStringList | Represents an alias of the TStringList type.
_PPyDateTime_BaseDateTime | Represents a pointer type to _PyDateTime_BaseDateTime.
_PPyDateTime_BaseTime | Represents a pointer type to _PyDateTime_BaseTime.
_PPyDateTime_BaseTZInfo | Represents a pointer type to _PyDateTime_BaseTZInfo.
Top


CO_MAXBLOCKS Type

Summary

Represents type CO_MAXBLOCKS.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 CO_MAXBLOCKS = 0..19;
See Also

Reference

  • BI.Plugins.Python.Engine


IOChar Type

Summary

Represents an alias of the WideChar type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 IOChar = WideChar;
See Also

Reference

  • BI.Plugins.Python.Engine


IOString Type

Summary

Represents an alias of the UnicodeString type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 IOString = UnicodeString;
See Also

Reference

  • BI.Plugins.Python.Engine


PByte Type

Summary

Represents a pointer type to Byte.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PByte = ^Byte;
See Also

Reference

  • BI.Plugins.Python.Engine


PCodeMemBlock Type

Summary

Represents a pointer type to TCodeMemBlock.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PCodeMemBlock = ^TCodeMemBlock;
See Also

Reference

  • BI.Plugins.Python.Engine


PCodeMemPage Type

Summary

Represents a pointer type to TCodeMemPage.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PCodeMemPage = ^TCodeMemPage;
See Also

Reference

  • BI.Plugins.Python.Engine


PDouble Type

Summary

Represents a pointer type to Double.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PDouble = ^Double;
See Also

Reference

  • BI.Plugins.Python.Engine


PFloat Type

Summary

Represents a pointer type to Real.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PFloat = ^Real;
See Also

Reference

  • BI.Plugins.Python.Engine


PGetSetArray Type

Summary

Represents a pointer type to TGetSetArray.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PGetSetArray = ^TGetSetArray;
See Also

Reference

  • BI.Plugins.Python.Engine


PInt Type

Summary

Represents a pointer type to Integer.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PInt = ^Integer;
See Also

Reference

  • BI.Plugins.Python.Engine


PLong Type

Summary

Represents a pointer type to LongInt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PLong = ^LongInt;
See Also

Reference

  • BI.Plugins.Python.Engine


PMemberArray Type

Summary

Represents a pointer type to TMemberArray.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PMemberArray = ^TMemberArray;
See Also

Reference

  • BI.Plugins.Python.Engine


PMethodArray Type

Summary

Represents a pointer type to TMethodArray.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PMethodArray = ^TMethodArray;
See Also

Reference

  • BI.Plugins.Python.Engine


PNativeInt Type

Summary

Represents a pointer type to NativeInt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PNativeInt = ^NativeInt;
See Also

Reference

  • BI.Plugins.Python.Engine


PNode Type

Summary

Represents a pointer type to node.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PNode = ^node;
See Also

Reference

  • BI.Plugins.Python.Engine


PPAnsiChar Type

Summary

Represents a pointer type to TPAnsiChar.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPAnsiChar = ^TPAnsiChar;
See Also

Reference

  • BI.Plugins.Python.Engine


PPPPyObject Type

Summary

Represents a pointer type to PPPyObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPPPyObject = ^PPPyObject;
See Also

Reference

  • BI.Plugins.Python.Engine


PPPyObject Type

Summary

Represents a pointer type to PPyObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPPyObject = ^PPyObject;
See Also

Reference

  • BI.Plugins.Python.Engine


PPWideChar Type

Summary

Represents a pointer type to TPWideChar.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPWideChar = ^TPWideChar;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyBufferProcs Type

Summary

Represents a pointer type to PyBufferProcs.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyBufferProcs = ^PyBufferProcs;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyClassObject Type

Summary

Represents a pointer type to PyClassObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyClassObject = ^PyClassObject;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyCodeObject Type

Summary

Represents a pointer type to PyCodeObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyCodeObject = ^PyCodeObject;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyDateTime_Date Type

Summary

Represents a pointer type to PyDateTime_Date.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyDateTime_Date = ^PyDateTime_Date;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyDateTime_DateTime Type

Summary

Represents a pointer type to PyDateTime_DateTime.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyDateTime_DateTime = ^PyDateTime_DateTime;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyDateTime_Delta Type

Summary

Represents a pointer type to PyDateTime_Delta.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyDateTime_Delta = ^PyDateTime_Delta;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyDateTime_Time Type

Summary

Represents a pointer type to PyDateTime_Time.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyDateTime_Time = ^PyDateTime_Time;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyDateTime_TZInfo Type

Summary

Represents a pointer type to PyDateTime_TZInfo.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyDateTime_TZInfo = ^PyDateTime_TZInfo;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyDescrObject Type

Summary

Represents a pointer type to PyDescrObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyDescrObject = ^PyDescrObject;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyFrameObject Type

Summary

Represents a pointer type to PyFrameObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyFrameObject = ^PyFrameObject;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyGetSetDef Type

Summary

Represents a pointer type to PyGetSetDef.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyGetSetDef = ^PyGetSetDef;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyGetSetDescrObject Type

Summary

Represents a pointer type to PyGetSetDescrObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyGetSetDescrObject = ^PyGetSetDescrObject;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyInstanceObject Type

Summary

Represents a pointer type to PyInstanceObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyInstanceObject = ^PyInstanceObject;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyInterpreterState Type

Summary

Represents a pointer type to PyInterpreterState.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyInterpreterState = ^PyInterpreterState;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyIntObject Type

Summary

Represents a pointer type to PyIntObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyIntObject = ^PyIntObject;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyMappingMethods Type

Summary

Represents a pointer type to PyMappingMethods.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyMappingMethods = ^PyMappingMethods;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyMemberDef Type

Summary

Represents a pointer type to PyMemberDef.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyMemberDef = ^PyMemberDef;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyMemberDescrObject Type

Summary

Represents a pointer type to PyMemberDescrObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyMemberDescrObject = ^PyMemberDescrObject;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyMethodChain Type

Summary

Represents a pointer type to PyMethodChain.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyMethodChain = ^PyMethodChain;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyMethodDef Type

Summary

Represents a pointer type to PyMethodDef.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyMethodDef = ^PyMethodDef;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyMethodDescrObject Type

Summary

Represents a pointer type to PyMethodDescrObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyMethodDescrObject = ^PyMethodDescrObject;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyMethodObject Type

Summary

Represents a pointer type to PyMethodObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyMethodObject = ^PyMethodObject;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyModuleDef Type

Summary

Represents a pointer type to PyModuleDef.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyModuleDef = ^PyModuleDef;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyModuleDef_Base Type

Summary

Represents a pointer type to PyModuleDef_Base.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyModuleDef_Base = ^PyModuleDef_Base;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyNumberMethods Type

Summary

Represents a pointer type to PyNumberMethods.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyNumberMethods = ^PyNumberMethods;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyObject Type

Summary

Represents a pointer type to PyObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyObject = ^PyObject;
See Also

Reference

  • BI.Plugins.Python.Engine


PPySequenceMethods Type

Summary

Represents a pointer type to PySequenceMethods.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPySequenceMethods = ^PySequenceMethods;
See Also

Reference

  • BI.Plugins.Python.Engine


PPySliceObject Type

Summary

Represents a pointer type to PySliceObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPySliceObject = ^PySliceObject;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyThreadState Type

Summary

Represents a pointer type to PyThreadState.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyThreadState = ^PyThreadState;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyTraceBackObject Type

Summary

Represents a pointer type to PyTraceBackObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyTraceBackObject = ^PyTraceBackObject;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyTryBlock Type

Summary

Represents a pointer type to PyTryBlock.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyTryBlock = ^PyTryBlock;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyTypeObject Type

Summary

Represents a pointer type to PyTypeObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyTypeObject = ^PyTypeObject;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyWeakReference Type

Summary

Represents a pointer type to PyWeakReference.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyWeakReference = ^PyWeakReference;
See Also

Reference

  • BI.Plugins.Python.Engine


PPyWrapperDescrObject Type

Summary

Represents a pointer type to PyWrapperDescrObject.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PPyWrapperDescrObject = ^PyWrapperDescrObject;
See Also

Reference

  • BI.Plugins.Python.Engine


PP_frozen Type

Summary

Represents a pointer type to P_frozen.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PP_frozen = ^P_frozen;
See Also

Reference

  • BI.Plugins.Python.Engine


PShort Type

Summary

Represents a pointer type to ShortInt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PShort = ^ShortInt;
See Also

Reference

  • BI.Plugins.Python.Engine


PtrCalcType Type

Summary

Represents an alias of the Longint type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 PtrCalcType = Longint;
See Also

Reference

  • BI.Plugins.Python.Engine


pwrapperbase Type

Summary

Represents a pointer type to wrapperbase.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 pwrapperbase = ^wrapperbase;
See Also

Reference

  • BI.Plugins.Python.Engine


P_frozen Type

Summary

Represents a pointer type to _frozen.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 P_frozen = ^_frozen;
See Also

Reference

  • BI.Plugins.Python.Engine


TBasicServices Type

Summary

Represents type TBasicServices.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TBasicServices = set of (bsPrint, bsGetAttr, bsSetAttr,
 bsRepr, bsCompare, bsHash,
 bsStr, bsGetAttrO, bsSetAttrO,
 bsCall,
 bsTraverse, bsClear,
 bsRichCompare,
 bsIter, bsIterNext);

The TBasicServices type exposes the following members.

Members
Show:
Name | Description
bsCall | Represents constant bsCall.
bsClear | Represents constant bsClear.
bsCompare | Represents constant bsCompare.
bsGetAttr | Represents constant bsGetAttr.
bsGetAttrO | Represents constant bsGetAttrO.
bsHash | Represents constant bsHash.
bsIter | Represents constant bsIter.
bsIterNext | Represents constant bsIterNext.
bsPrint | Represents constant bsPrint.
bsRepr | Represents constant bsRepr.
bsRichCompare | Represents constant bsRichCompare.
bsSetAttr | Represents constant bsSetAttr.
bsSetAttrO | Represents constant bsSetAttrO.
bsStr | Represents constant bsStr.
bsTraverse | Represents constant bsTraverse.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TGetSetArray Type

Summary

Represents an array of the PyGetSetDef type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TGetSetArray = array[ 0 .. 16000 ] of PyGetSetDef;
See Also

Reference

  • BI.Plugins.Python.Engine


TInplaceNumberServices Type

Summary

Represents type TInplaceNumberServices.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TInplaceNumberServices = set of (nsInplaceAdd, nsInplaceSubtract,
 nsInplaceMultiply, nsInplaceDivide,
 nsInplaceRemainder, nsInplacePower,
 nsInplaceLShift, nsInplaceRShift,
 nsInplaceAnd, nsInplaceXor, nsInplaceOr,
 nsInplaceFloorDivide, nsInplaceTrueDivide);

The TInplaceNumberServices type exposes the following members.

Members
Show:
Name | Description
nsInplaceAdd | Represents constant nsInplaceAdd.
nsInplaceAnd | Represents constant nsInplaceAnd.
nsInplaceDivide | Represents constant nsInplaceDivide.
nsInplaceFloorDivide | Represents constant nsInplaceFloorDivide.
nsInplaceLShift | Represents constant nsInplaceLShift.
nsInplaceMultiply | Represents constant nsInplaceMultiply.
nsInplaceOr | Represents constant nsInplaceOr.
nsInplacePower | Represents constant nsInplacePower.
nsInplaceRemainder | Represents constant nsInplaceRemainder.
nsInplaceRShift | Represents constant nsInplaceRShift.
nsInplaceSubtract | Represents constant nsInplaceSubtract.
nsInplaceTrueDivide | Represents constant nsInplaceTrueDivide.
nsInplaceXor | Represents constant nsInplaceXor.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TIOStringList Type

Summary

Represents an alias of the TUnicodeStringList type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TIOStringList = TUnicodeStringList;
See Also

Reference

  • BI.Plugins.Python.Engine


TMappingServices Type

Summary

Represents type TMappingServices.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TMappingServices = set of (msLength, msSubscript, msAssSubscript);

The TMappingServices type exposes the following members.

Members
Show:
Name | Description
msAssSubscript | Represents constant msAssSubscript.
msLength | Represents constant msLength.
msSubscript | Represents constant msSubscript.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TMemberArray Type

Summary

Represents an array of the PyMemberDef type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TMemberArray = array[ 0 .. 16000 ] of PyMemberDef;
See Also

Reference

  • BI.Plugins.Python.Engine


TMethodArray Type

Summary

Represents an array of the PyMethodDef type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TMethodArray = array[ 0 .. 16000 ] of PyMethodDef;
See Also

Reference

  • BI.Plugins.Python.Engine


TNumberServices Type

Summary

Represents type TNumberServices.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TNumberServices = set of (nsAdd, nsSubstract, nsMultiply,
 nsDivide, nsRemainder, nsDivmod,
 nsPower, nsNegative, nsPositive,
 nsAbsolute, nsNonZero, nsInvert,
 nsLShift, nsRShift, nsAnd,
 nsXor, nsOr, nsCoerce,
 nsInt, nsLong, nsFloat,
 nsOct, nsHex,
 nsFloorDivide, nsTrueDivide);

The TNumberServices type exposes the following members.

Members
Show:
Name | Description
nsAbsolute | Represents constant nsAbsolute.
nsAdd | Represents constant nsAdd.
nsAnd | Represents constant nsAnd.
nsCoerce | Represents constant nsCoerce.
nsDivide | Represents constant nsDivide.
nsDivmod | Represents constant nsDivmod.
nsFloat | Represents constant nsFloat.
nsFloorDivide | Represents constant nsFloorDivide.
nsHex | Represents constant nsHex.
nsInt | Represents constant nsInt.
nsInvert | Represents constant nsInvert.
nsLong | Represents constant nsLong.
nsLShift | Represents constant nsLShift.
nsMultiply | Represents constant nsMultiply.
nsNegative | Represents constant nsNegative.
nsNonZero | Represents constant nsNonZero.
nsOct | Represents constant nsOct.
nsOr | Represents constant nsOr.
nsPositive | Represents constant nsPositive.
nsPower | Represents constant nsPower.
nsRemainder | Represents constant nsRemainder.
nsRShift | Represents constant nsRShift.
nsSubstract | Represents constant nsSubstract.
nsTrueDivide | Represents constant nsTrueDivide.
nsXor | Represents constant nsXor.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TPAnsiChar Type

Summary

Represents an array of the PAnsiChar type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TPAnsiChar = array[0..16000] of PAnsiChar;
See Also

Reference

  • BI.Plugins.Python.Engine


TPFlags Type

Summary

Represents type TPFlags.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TPFlags = set of TPFlag;
See Also

Reference

  • BI.Plugins.Python.Engine


TPWideChar Type

Summary

Represents an array of the PWideChar type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TPWideChar = array[0..16000] of PWideChar;
See Also

Reference

  • BI.Plugins.Python.Engine


TPyObjectClass Type

Summary

Represents type TPyObjectClass.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TPyObjectClass = class of TPyObject;
See Also

Reference

  • BI.Plugins.Python.Engine


TPythonFlags Type

Summary

Represents type TPythonFlags.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TPythonFlags = set of TPythonFlag;
See Also

Reference

  • BI.Plugins.Python.Engine


TSequenceServices Type

Summary

Represents type TSequenceServices.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TSequenceServices = set of (ssLength, ssConcat, ssRepeat,
 ssItem, ssSlice, ssAssItem,
 ssAssSlice,
 ssContains,
 ssInplaceConcat,
 ssInplaceRepeat
 );

The TSequenceServices type exposes the following members.

Members
Show:
Name | Description
ssAssItem | Represents constant ssAssItem.
ssAssSlice | Represents constant ssAssSlice.
ssConcat | Represents constant ssConcat.
ssContains | Represents constant ssContains.
ssInplaceConcat | Represents constant ssInplaceConcat.
ssInplaceRepeat | Represents constant ssInplaceRepeat.
ssItem | Represents constant ssItem.
ssLength | Represents constant ssLength.
ssRepeat | Represents constant ssRepeat.
ssSlice | Represents constant ssSlice.
Top
See Also

Reference

  • BI.Plugins.Python.Engine


TUnicodeStringList Type

Summary

Represents an alias of the TStringList type.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 TUnicodeStringList = TStringList;
See Also

Reference

  • BI.Plugins.Python.Engine


_PPyDateTime_BaseDateTime Type

Summary

Represents a pointer type to _PyDateTime_BaseDateTime.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 _PPyDateTime_BaseDateTime = ^_PyDateTime_BaseDateTime;
See Also

Reference

  • BI.Plugins.Python.Engine


_PPyDateTime_BaseTime Type

Summary

Represents a pointer type to _PyDateTime_BaseTime.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 _PPyDateTime_BaseTime = ^_PyDateTime_BaseTime;
See Also

Reference

  • BI.Plugins.Python.Engine


_PPyDateTime_BaseTZInfo Type

Summary

Represents a pointer type to _PyDateTime_BaseTZInfo.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
type
 _PPyDateTime_BaseTZInfo = ^_PyDateTime_BaseTZInfo;
See Also

Reference

  • BI.Plugins.Python.Engine


BI.Plugins.Python.Engine Variables

Variables
Name | Description
CodeMemPages | Represents variable CodeMemPages.
gPythonEngine | Represents variable gPythonEngine.
gVarType | Represents variable gVarType.
Top


CodeMemPages Variable

Summary

Represents variable CodeMemPages.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
CodeMemPages: PCodeMemPage;

Value

Type: PCodeMemPage

See Also

Reference

  • BI.Plugins.Python.Engine


gPythonEngine Variable

Summary

Represents variable gPythonEngine.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
gPythonEngine : TPythonEngine;

Value

Type: TPythonEngine

See Also

Reference

  • BI.Plugins.Python.Engine


gVarType Variable

Summary

Represents variable gVarType.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
gVarType : TPythonType;

Value

Type: TPythonType

See Also

Reference

  • BI.Plugins.Python.Engine


BI.Plugins.Python.Engine Constants

Constants
Name | Description
COMPILED_FOR_PYTHON_VERSION_INDEX | Represents constant COMPILED_FOR_PYTHON_VERSION_INDEX.
CO_NEWLOCALS | Represents constant CO_NEWLOCALS.
CO_OPTIMIZED | Represents constant CO_OPTIMIZED.
CO_VARARGS | Represents constant CO_VARARGS.
CO_VARKEYWORDS | Represents constant CO_VARKEYWORDS.
CR | Represents constant CR.
CRLF | Represents constant CRLF.
DEFAULT_DATETIME_CONVERSION_MODE | Represents constant DEFAULT_DATETIME_CONVERSION_MODE.
ErrInit | Represents constant ErrInit.
eval_input | Represents constant eval_input.
file_input | Represents constant file_input.
kMaxLineLength | Represents constant kMaxLineLength.
kMaxLines | Represents constant kMaxLines.
LF | Represents constant LF.
METH_KEYWORDS | Represents constant METH_KEYWORDS.
METH_VARARGS | Represents constant METH_VARARGS.
p4d_and_expr | Represents constant p4d_and_expr.
p4d_and_test | Represents constant p4d_and_test.
p4d_arglist | Represents constant p4d_arglist.
p4d_argument | Represents constant p4d_argument.
p4d_arith_expr | Represents constant p4d_arith_expr.
p4d_assert_stmt | Represents constant p4d_assert_stmt.
p4d_atom | Represents constant p4d_atom.
p4d_augassign | Represents constant p4d_augassign.
p4d_break_stmt | Represents constant p4d_break_stmt.
p4d_classdef | Represents constant p4d_classdef.
p4d_comparison | Represents constant p4d_comparison.
p4d_compound_stmt | Represents constant p4d_compound_stmt.
p4d_comp_op | Represents constant p4d_comp_op.
p4d_continue_stmt | Represents constant p4d_continue_stmt.
p4d_del_stmt | Represents constant p4d_del_stmt.
p4d_dictmaker | Represents constant p4d_dictmaker.
p4d_dotted_as_name | Represents constant p4d_dotted_as_name.
p4d_dotted_name | Represents constant p4d_dotted_name.
p4d_except_clause | Represents constant p4d_except_clause.
p4d_exec_stmt | Represents constant p4d_exec_stmt.
p4d_expr | Represents constant p4d_expr.
p4d_exprlist | Represents constant p4d_exprlist.
p4d_expr_stmt | Represents constant p4d_expr_stmt.
p4d_factor | Represents constant p4d_factor.
p4d_flow_stmt | Represents constant p4d_flow_stmt.
p4d_for_stmt | Represents constant p4d_for_stmt.
p4d_fpdef | Represents constant p4d_fpdef.
p4d_fplist | Represents constant p4d_fplist.
p4d_funcdef | Represents constant p4d_funcdef.
p4d_global_stmt | Represents constant p4d_global_stmt.
p4d_if_stmt | Represents constant p4d_if_stmt.
p4d_import_as_name | Represents constant p4d_import_as_name.
p4d_import_stmt | Represents constant p4d_import_stmt.
p4d_lambdef | Represents constant p4d_lambdef.
p4d_listmaker | Represents constant p4d_listmaker.
p4d_list_for | Represents constant p4d_list_for.
p4d_list_if | Represents constant p4d_list_if.
p4d_list_iter | Represents constant p4d_list_iter.
p4d_not_test | Represents constant p4d_not_test.
p4d_parameters | Represents constant p4d_parameters.
p4d_pass_stmt | Represents constant p4d_pass_stmt.
p4d_power | Represents constant p4d_power.
p4d_print_stmt | Represents constant p4d_print_stmt.
p4d_raise_stmt | Represents constant p4d_raise_stmt.
p4d_return_stmt | Represents constant p4d_return_stmt.
p4d_shift_expr | Represents constant p4d_shift_expr.
p4d_simple_stmt | Represents constant p4d_simple_stmt.
p4d_sliceop | Represents constant p4d_sliceop.
p4d_small_stmt | Represents constant p4d_small_stmt.
p4d_stmt | Represents constant p4d_stmt.
p4d_subscript | Represents constant p4d_subscript.
p4d_subscriptlist | Represents constant p4d_subscriptlist.
p4d_suite | Represents constant p4d_suite.
p4d_term | Represents constant p4d_term.
p4d_test | Represents constant p4d_test.
p4d_testlist | Represents constant p4d_testlist.
p4d_trailer | Represents constant p4d_trailer.
p4d_try_stmt | Represents constant p4d_try_stmt.
p4d_varargslist | Represents constant p4d_varargslist.
p4d_while_stmt | Represents constant p4d_while_stmt.
p4d_xor_expr | Represents constant p4d_xor_expr.
PageSize | Represents constant PageSize.
PYTHON_KNOWN_VERSIONS | Represents constant PYTHON_KNOWN_VERSIONS.
PYT_GETSET_BUFFER_INCREASE | Represents constant PYT_GETSET_BUFFER_INCREASE.
PYT_MEMBER_BUFFER_INCREASE | Represents constant PYT_MEMBER_BUFFER_INCREASE.
PYT_METHOD_BUFFER_INCREASE | Represents constant PYT_METHOD_BUFFER_INCREASE.
Py_EQ | Represents constant Py_EQ.
Py_GE | Represents constant Py_GE.
Py_GT | Represents constant Py_GT.
Py_LE | Represents constant Py_LE.
Py_LT | Represents constant Py_LT.
Py_NE | Represents constant Py_NE.
Py_TPFLAGS_BASETYPE | Represents constant Py_TPFLAGS_BASETYPE.
Py_TPFLAGS_CHECKTYPES | Represents constant Py_TPFLAGS_CHECKTYPES.
Py_TPFLAGS_DEFAULT | Represents constant Py_TPFLAGS_DEFAULT.
Py_TPFLAGS_GC | Represents constant Py_TPFLAGS_GC.
Py_TPFLAGS_HAVE_CLASS | Represents constant Py_TPFLAGS_HAVE_CLASS.
Py_TPFLAGS_HAVE_GC | Represents constant Py_TPFLAGS_HAVE_GC.
Py_TPFLAGS_HAVE_GETCHARBUFFER | Represents constant Py_TPFLAGS_HAVE_GETCHARBUFFER.
Py_TPFLAGS_HAVE_INPLACEOPS | Represents constant Py_TPFLAGS_HAVE_INPLACEOPS.
Py_TPFLAGS_HAVE_ITER | Represents constant Py_TPFLAGS_HAVE_ITER.
Py_TPFLAGS_HAVE_RICHCOMPARE | Represents constant Py_TPFLAGS_HAVE_RICHCOMPARE.
Py_TPFLAGS_HAVE_SEQUENCE_IN | Represents constant Py_TPFLAGS_HAVE_SEQUENCE_IN.
Py_TPFLAGS_HAVE_WEAKREFS | Represents constant Py_TPFLAGS_HAVE_WEAKREFS.
Py_TPFLAGS_HEAPTYPE | Represents constant Py_TPFLAGS_HEAPTYPE.
Py_TPFLAGS_READY | Represents constant Py_TPFLAGS_READY.
Py_TPFLAGS_READYING | Represents constant Py_TPFLAGS_READYING.
READONLY | Represents constant READONLY.
READ_RESTRICTED | Represents constant READ_RESTRICTED.
RESTRICTED | Represents constant RESTRICTED.
RO | Represents constant RO.
single_input | Represents constant single_input.
TAB | Represents constant TAB.
TPFLAGS_DEFAULT | Represents constant TPFLAGS_DEFAULT.
T_BYTE | Represents constant T_BYTE.
T_CHAR | Represents constant T_CHAR.
T_DOUBLE | Represents constant T_DOUBLE.
T_FLOAT | Represents constant T_FLOAT.
T_INT | Represents constant T_INT.
T_LONG | Represents constant T_LONG.
T_OBJECT | Represents constant T_OBJECT.
T_OBJECT_EX | Represents constant T_OBJECT_EX.
T_SHORT | Represents constant T_SHORT.
T_STRING | Represents constant T_STRING.
T_STRING_INPLACE | Represents constant T_STRING_INPLACE.
T_UBYTE | Represents constant T_UBYTE.
T_UINT | Represents constant T_UINT.
T_ULONG | Represents constant T_ULONG.
T_USHORT | Represents constant T_USHORT.
WRITE_RESTRICTED | Represents constant WRITE_RESTRICTED.
_PyDateTime_DATETIME_DATASIZE | Represents constant _PyDateTime_DATETIME_DATASIZE.
_PyDateTime_DATE_DATASIZE | Represents constant _PyDateTime_DATE_DATASIZE.
_PyDateTime_TIME_DATASIZE | Represents constant _PyDateTime_TIME_DATASIZE.
Top


COMPILED_FOR_PYTHON_VERSION_INDEX Constant

Summary

Represents constant COMPILED_FOR_PYTHON_VERSION_INDEX.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 COMPILED_FOR_PYTHON_VERSION_INDEX = 5;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


CO_NEWLOCALS Constant

Summary

Represents constant CO_NEWLOCALS.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 CO_NEWLOCALS = $0002;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


CO_OPTIMIZED Constant

Summary

Represents constant CO_OPTIMIZED.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 CO_OPTIMIZED = $0001;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


CO_VARARGS Constant

Summary

Represents constant CO_VARARGS.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 CO_VARARGS = $0004;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


CO_VARKEYWORDS Constant

Summary

Represents constant CO_VARKEYWORDS.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 CO_VARKEYWORDS = $0008;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


CR Constant

Summary

Represents constant CR.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 CR = #13;

Value

Type: string

See Also

Reference

  • BI.Plugins.Python.Engine


CRLF Constant

Summary

Represents constant CRLF.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 CRLF = CR+LF;

Value

Type: string

See Also

Reference

  • BI.Plugins.Python.Engine


DEFAULT_DATETIME_CONVERSION_MODE Constant

Summary

Represents constant DEFAULT_DATETIME_CONVERSION_MODE.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 DEFAULT_DATETIME_CONVERSION_MODE = dcmToTuple;

Value

Type: Void

See Also

Reference

  • BI.Plugins.Python.Engine


ErrInit Constant

Summary

Represents constant ErrInit.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 ErrInit = -300;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


eval_input Constant

Summary

Represents constant eval_input.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 eval_input = 258;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


file_input Constant

Summary

Represents constant file_input.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 file_input = 257;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


kMaxLineLength Constant

Summary

Represents constant kMaxLineLength.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 kMaxLineLength = 256;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


kMaxLines Constant

Summary

Represents constant kMaxLines.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 kMaxLines = 1000;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


LF Constant

Summary

Represents constant LF.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 LF = #10;

Value

Type: string

See Also

Reference

  • BI.Plugins.Python.Engine


METH_KEYWORDS Constant

Summary

Represents constant METH_KEYWORDS.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 METH_KEYWORDS = $0002;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


METH_VARARGS Constant

Summary

Represents constant METH_VARARGS.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 METH_VARARGS = $0001;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_and_expr Constant

Summary

Represents constant p4d_and_expr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_and_expr = 298;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_and_test Constant

Summary

Represents constant p4d_and_test.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_and_test = 291;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_arglist Constant

Summary

Represents constant p4d_arglist.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_arglist = 315;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_argument Constant

Summary

Represents constant p4d_argument.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_argument = 316;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_arith_expr Constant

Summary

Represents constant p4d_arith_expr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_arith_expr = 300;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_assert_stmt Constant

Summary

Represents constant p4d_assert_stmt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_assert_stmt = 283;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_atom Constant

Summary

Represents constant p4d_atom.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_atom = 304;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_augassign Constant

Summary

Represents constant p4d_augassign.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_augassign = 268;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_break_stmt Constant

Summary

Represents constant p4d_break_stmt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_break_stmt = 273;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_classdef Constant

Summary

Represents constant p4d_classdef.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_classdef = 314;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_comparison Constant

Summary

Represents constant p4d_comparison.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_comparison = 294;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_compound_stmt Constant

Summary

Represents constant p4d_compound_stmt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_compound_stmt = 284;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_comp_op Constant

Summary

Represents constant p4d_comp_op.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_comp_op = 295;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_continue_stmt Constant

Summary

Represents constant p4d_continue_stmt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_continue_stmt = 274;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_del_stmt Constant

Summary

Represents constant p4d_del_stmt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_del_stmt = 270;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_dictmaker Constant

Summary

Represents constant p4d_dictmaker.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_dictmaker = 313;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_dotted_as_name Constant

Summary

Represents constant p4d_dotted_as_name.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_dotted_as_name = 279;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_dotted_name Constant

Summary

Represents constant p4d_dotted_name.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_dotted_name = 280;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_except_clause Constant

Summary

Represents constant p4d_except_clause.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_except_clause = 289;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_exec_stmt Constant

Summary

Represents constant p4d_exec_stmt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_exec_stmt = 282;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_expr Constant

Summary

Represents constant p4d_expr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_expr = 296;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_exprlist Constant

Summary

Represents constant p4d_exprlist.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_exprlist = 311;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_expr_stmt Constant

Summary

Represents constant p4d_expr_stmt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_expr_stmt = 267;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_factor Constant

Summary

Represents constant p4d_factor.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_factor = 302;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_flow_stmt Constant

Summary

Represents constant p4d_flow_stmt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_flow_stmt = 272;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_for_stmt Constant

Summary

Represents constant p4d_for_stmt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_for_stmt = 287;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_fpdef Constant

Summary

Represents constant p4d_fpdef.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_fpdef = 262;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_fplist Constant

Summary

Represents constant p4d_fplist.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_fplist = 263;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_funcdef Constant

Summary

Represents constant p4d_funcdef.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_funcdef = 259;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_global_stmt Constant

Summary

Represents constant p4d_global_stmt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_global_stmt = 281;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_if_stmt Constant

Summary

Represents constant p4d_if_stmt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_if_stmt = 285;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_import_as_name Constant

Summary

Represents constant p4d_import_as_name.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_import_as_name = 278;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_import_stmt Constant

Summary

Represents constant p4d_import_stmt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_import_stmt = 277;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_lambdef Constant

Summary

Represents constant p4d_lambdef.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_lambdef = 306;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_listmaker Constant

Summary

Represents constant p4d_listmaker.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_listmaker = 305;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_list_for Constant

Summary

Represents constant p4d_list_for.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_list_for = 318;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_list_if Constant

Summary

Represents constant p4d_list_if.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_list_if = 319;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_list_iter Constant

Summary

Represents constant p4d_list_iter.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_list_iter = 317;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_not_test Constant

Summary

Represents constant p4d_not_test.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_not_test = 293;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_parameters Constant

Summary

Represents constant p4d_parameters.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_parameters = 260;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_pass_stmt Constant

Summary

Represents constant p4d_pass_stmt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_pass_stmt = 271;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_power Constant

Summary

Represents constant p4d_power.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_power = 303;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_print_stmt Constant

Summary

Represents constant p4d_print_stmt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_print_stmt = 269;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_raise_stmt Constant

Summary

Represents constant p4d_raise_stmt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_raise_stmt = 276;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_return_stmt Constant

Summary

Represents constant p4d_return_stmt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_return_stmt = 275;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_shift_expr Constant

Summary

Represents constant p4d_shift_expr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_shift_expr = 299;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_simple_stmt Constant

Summary

Represents constant p4d_simple_stmt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_simple_stmt = 265;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_sliceop Constant

Summary

Represents constant p4d_sliceop.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_sliceop = 310;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_small_stmt Constant

Summary

Represents constant p4d_small_stmt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_small_stmt = 266;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_stmt Constant

Summary

Represents constant p4d_stmt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_stmt = 264;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_subscript Constant

Summary

Represents constant p4d_subscript.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_subscript = 309;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_subscriptlist Constant

Summary

Represents constant p4d_subscriptlist.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_subscriptlist = 308;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_suite Constant

Summary

Represents constant p4d_suite.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_suite = 290;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_term Constant

Summary

Represents constant p4d_term.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_term = 301;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_test Constant

Summary

Represents constant p4d_test.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_test = 291;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_testlist Constant

Summary

Represents constant p4d_testlist.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_testlist = 312;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_trailer Constant

Summary

Represents constant p4d_trailer.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_trailer = 307;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_try_stmt Constant

Summary

Represents constant p4d_try_stmt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_try_stmt = 288;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_varargslist Constant

Summary

Represents constant p4d_varargslist.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_varargslist = 261;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_while_stmt Constant

Summary

Represents constant p4d_while_stmt.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_while_stmt = 286;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


p4d_xor_expr Constant

Summary

Represents constant p4d_xor_expr.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 p4d_xor_expr = 297;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


PageSize Constant

Summary

Represents constant PageSize.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 PageSize = 4096;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


PYTHON_KNOWN_VERSIONS Constant

Summary

Represents constant PYTHON_KNOWN_VERSIONS.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 PYTHON_KNOWN_VERSIONS: array[1..14] of TPythonVersionProp =
 ( (DllName: 'python23.dll'; RegVersion: '2.3'; APIVersion: 1012; CanUseLatest: True),
 (DllName: 'python24.dll'; RegVersion: '2.4'; APIVersion: 1012; CanUseLatest: True),
 (DllName: 'python25.dll'; RegVersion: '2.5'; APIVersion: 1013; CanUseLatest: True),
 (DllName: 'python26.dll'; RegVersion: '2.6'; APIVersion: 1013; CanUseLatest: True),
 (DllName: 'python27.dll'; RegVersion: '2.7'; APIVersion: 1013; CanUseLatest: True),
 (DllName: 'python30.dll'; RegVersion: '3.0'; APIVersion: 1013; CanUseLatest: True),
 (DllName: 'python31.dll'; RegVersion: '3.1'; APIVersion: 1013; CanUseLatest: True),
 (DllName: 'python32.dll'; RegVersion: '3.2'; APIVersion: 1013; CanUseLatest: True),
 (DllName: 'python33.dll'; RegVersion: '3.3'; APIVersion: 1013; CanUseLatest: True),
 (DllName: 'python34.dll'; RegVersion: '3.4'; APIVersion: 1013; CanUseLatest: True),
 (DllName: 'python35.dll'; RegVersion: '3.5-32'; APIVersion: 1013; CanUseLatest: True),
 (DllName: 'python35.dll'; RegVersion: '3.5'; APIVersion: 1013; CanUseLatest: True),
 (DllName: 'python36.dll'; RegVersion: '3.6-32'; APIVersion: 1013; CanUseLatest: True),
 (DllName: 'python36.dll'; RegVersion: '3.6'; APIVersion: 1013; CanUseLatest: True) );

Value

Type: array[1..14] of TPythonVersionProp

See Also

Reference

  • BI.Plugins.Python.Engine


PYT_GETSET_BUFFER_INCREASE Constant

Summary

Represents constant PYT_GETSET_BUFFER_INCREASE.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 PYT_GETSET_BUFFER_INCREASE = 10;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


PYT_MEMBER_BUFFER_INCREASE Constant

Summary

Represents constant PYT_MEMBER_BUFFER_INCREASE.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 PYT_MEMBER_BUFFER_INCREASE = 10;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


PYT_METHOD_BUFFER_INCREASE Constant

Summary

Represents constant PYT_METHOD_BUFFER_INCREASE.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 PYT_METHOD_BUFFER_INCREASE = 10;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


Py_EQ Constant

Summary

Represents constant Py_EQ.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 Py_EQ = 2;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


Py_GE Constant

Summary

Represents constant Py_GE.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 Py_GE = 5;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


Py_GT Constant

Summary

Represents constant Py_GT.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 Py_GT = 4;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


Py_LE Constant

Summary

Represents constant Py_LE.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 Py_LE = 1;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


Py_LT Constant

Summary

Represents constant Py_LT.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 Py_LT = 0;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


Py_NE Constant

Summary

Represents constant Py_NE.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 Py_NE = 3;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


Py_TPFLAGS_BASETYPE Constant

Summary

Represents constant Py_TPFLAGS_BASETYPE.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 Py_TPFLAGS_BASETYPE = (1 shl 10);

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


Py_TPFLAGS_CHECKTYPES Constant

Summary

Represents constant Py_TPFLAGS_CHECKTYPES.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 Py_TPFLAGS_CHECKTYPES = (1 shl 4);

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


Py_TPFLAGS_DEFAULT Constant

Summary

Represents constant Py_TPFLAGS_DEFAULT.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 Py_TPFLAGS_DEFAULT = Py_TPFLAGS_HAVE_GETCHARBUFFER
 or Py_TPFLAGS_HAVE_SEQUENCE_IN
 or Py_TPFLAGS_HAVE_INPLACEOPS
 or Py_TPFLAGS_HAVE_RICHCOMPARE
 or Py_TPFLAGS_HAVE_WEAKREFS
 or Py_TPFLAGS_HAVE_ITER
 or Py_TPFLAGS_HAVE_CLASS
 or Py_TPFLAGS_BASETYPE
 ;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


Py_TPFLAGS_GC Constant

Summary

Represents constant Py_TPFLAGS_GC.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 Py_TPFLAGS_GC = (1 shl 2);

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


Py_TPFLAGS_HAVE_CLASS Constant

Summary

Represents constant Py_TPFLAGS_HAVE_CLASS.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 Py_TPFLAGS_HAVE_CLASS = (1 shl 8);

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


Py_TPFLAGS_HAVE_GC Constant

Summary

Represents constant Py_TPFLAGS_HAVE_GC.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 Py_TPFLAGS_HAVE_GC = (1 shl 14);

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


Py_TPFLAGS_HAVE_GETCHARBUFFER Constant

Summary

Represents constant Py_TPFLAGS_HAVE_GETCHARBUFFER.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 Py_TPFLAGS_HAVE_GETCHARBUFFER = (1 shl 0);

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


Py_TPFLAGS_HAVE_INPLACEOPS Constant

Summary

Represents constant Py_TPFLAGS_HAVE_INPLACEOPS.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 Py_TPFLAGS_HAVE_INPLACEOPS = (1 shl 3);

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


Py_TPFLAGS_HAVE_ITER Constant

Summary

Represents constant Py_TPFLAGS_HAVE_ITER.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 Py_TPFLAGS_HAVE_ITER = (1 shl 7);

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


Py_TPFLAGS_HAVE_RICHCOMPARE Constant

Summary

Represents constant Py_TPFLAGS_HAVE_RICHCOMPARE.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 Py_TPFLAGS_HAVE_RICHCOMPARE = (1 shl 5);

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


Py_TPFLAGS_HAVE_SEQUENCE_IN Constant

Summary

Represents constant Py_TPFLAGS_HAVE_SEQUENCE_IN.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 Py_TPFLAGS_HAVE_SEQUENCE_IN = (1 shl 1);

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


Py_TPFLAGS_HAVE_WEAKREFS Constant

Summary

Represents constant Py_TPFLAGS_HAVE_WEAKREFS.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 Py_TPFLAGS_HAVE_WEAKREFS = (1 shl 6);

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


Py_TPFLAGS_HEAPTYPE Constant

Summary

Represents constant Py_TPFLAGS_HEAPTYPE.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 Py_TPFLAGS_HEAPTYPE = (1 shl 9);

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


Py_TPFLAGS_READY Constant

Summary

Represents constant Py_TPFLAGS_READY.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 Py_TPFLAGS_READY = (1 shl 12);

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


Py_TPFLAGS_READYING Constant

Summary

Represents constant Py_TPFLAGS_READYING.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 Py_TPFLAGS_READYING = (1 shl 13);

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


READONLY Constant

Summary

Represents constant READONLY.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 READONLY = 1;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


READ_RESTRICTED Constant

Summary

Represents constant READ_RESTRICTED.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 READ_RESTRICTED = 2;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


RESTRICTED Constant

Summary

Represents constant RESTRICTED.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 RESTRICTED = (READ_RESTRICTED or WRITE_RESTRICTED);

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


RO Constant

Summary

Represents constant RO.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 RO = READONLY;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


single_input Constant

Summary

Represents constant single_input.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 single_input = 256;

Value

Type: SmallInt

See Also

Reference

  • BI.Plugins.Python.Engine


TAB Constant

Summary

Represents constant TAB.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 TAB = #09;

Value

Type: string

See Also

Reference

  • BI.Plugins.Python.Engine


TPFLAGS_DEFAULT Constant

Summary

Represents constant TPFLAGS_DEFAULT.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 TPFLAGS_DEFAULT = [tpfHaveGetCharBuffer, tpfHaveSequenceIn, tpfHaveInplaceOps,
 tpfHaveRichCompare, tpfHaveWeakRefs, tpfHaveIter,
 tpfHaveClass, tpfBaseType
 ];

Value

Type: Void

See Also

Reference

  • BI.Plugins.Python.Engine


T_BYTE Constant

Summary

Represents constant T_BYTE.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 T_BYTE = 8;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


T_CHAR Constant

Summary

Represents constant T_CHAR.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 T_CHAR = 7;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


T_DOUBLE Constant

Summary

Represents constant T_DOUBLE.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 T_DOUBLE = 4;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


T_FLOAT Constant

Summary

Represents constant T_FLOAT.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 T_FLOAT = 3;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


T_INT Constant

Summary

Represents constant T_INT.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 T_INT = 1;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


T_LONG Constant

Summary

Represents constant T_LONG.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 T_LONG = 2;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


T_OBJECT Constant

Summary

Represents constant T_OBJECT.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 T_OBJECT = 6;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


T_OBJECT_EX Constant

Summary

Represents constant T_OBJECT_EX.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 T_OBJECT_EX = 16;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


T_SHORT Constant

Summary

Represents constant T_SHORT.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 T_SHORT = 0;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


T_STRING Constant

Summary

Represents constant T_STRING.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 T_STRING = 5;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


T_STRING_INPLACE Constant

Summary

Represents constant T_STRING_INPLACE.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 T_STRING_INPLACE= 13;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


T_UBYTE Constant

Summary

Represents constant T_UBYTE.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 T_UBYTE = 9;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


T_UINT Constant

Summary

Represents constant T_UINT.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 T_UINT = 11;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


T_ULONG Constant

Summary

Represents constant T_ULONG.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 T_ULONG = 12;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


T_USHORT Constant

Summary

Represents constant T_USHORT.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 T_USHORT = 10;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


WRITE_RESTRICTED Constant

Summary

Represents constant WRITE_RESTRICTED.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 WRITE_RESTRICTED = 4;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


_PyDateTime_DATETIME_DATASIZE Constant

Summary

Represents constant _PyDateTime_DATETIME_DATASIZE.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 _PyDateTime_DATETIME_DATASIZE = 10;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


_PyDateTime_DATE_DATASIZE Constant

Summary

Represents constant _PyDateTime_DATE_DATASIZE.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 _PyDateTime_DATE_DATASIZE = 4;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


_PyDateTime_TIME_DATASIZE Constant

Summary

Represents constant _PyDateTime_TIME_DATASIZE.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 _PyDateTime_TIME_DATASIZE = 6;

Value

Type: ShortInt

See Also

Reference

  • BI.Plugins.Python.Engine


BI.Plugins.Python.Engine Routines

Routines
Name | Description
CodeMemPageCount | Represents method CodeMemPageCount.
DeleteCallBack(Pointer) | Represents method DeleteCallBack(Pointer).
FreeCallBacks | Represents method FreeCallBacks.
FreeCodeMem(Pointer) | Represents method FreeCodeMem(Pointer).
FreeSubtypeInst(PPyObject) | Represents method FreeSubtypeInst(PPyObject).
GetCallBack(TObject,Pointer,Integer,TCallType) | Represents method GetCallBack(TObject,Pointer,Integer,TCallType).
GetCodeMem(PByte,integer) | Represents method GetCodeMem(PByte,integer).
GetDDECallBack(TDDEAPIfunc) | Represents method GetDDECallBack(TDDEAPIfunc).
GetOfObjectCallBack(TCallBack,Integer,TCallType) | Represents method GetOfObjectCallBack(TCallBack,Integer,TCallType).
GetPythonEngine | Represents method GetPythonEngine.
IsDelphiObject(PPyObject) | Represents method IsDelphiObject(PPyObject).
IsPythonVersionRegistered(string,string,Boolean) | Represents method IsPythonVersionRegistered(string,string,Boolean).
MaskFPUExceptions(boolean,Boolean) | Represents method MaskFPUExceptions(boolean,Boolean).
pyio_GetTypesStats(PPyObject,PPyObject) | Represents method pyio_GetTypesStats(PPyObject,PPyObject).
pyio_read(PPyObject,PPyObject) | Represents method pyio_read(PPyObject,PPyObject).
pyio_SetDelayWrites(PPyObject,PPyObject) | Represents method pyio_SetDelayWrites(PPyObject,PPyObject).
pyio_SetMaxLines(PPyObject,PPyObject) | Represents method pyio_SetMaxLines(PPyObject,PPyObject).
pyio_write(PPyObject,PPyObject) | Represents method pyio_write(PPyObject,PPyObject).
PyObjectDestructor(PPyObject) | Represents method PyObjectDestructor(PPyObject).
PythonOK | Represents method PythonOK.
PythonToDelphi(PPyObject) | Represents method PythonToDelphi(PPyObject).
PyType_HasFeature(PPyTypeObject,Integer) | Represents method PyType_HasFeature(PPyTypeObject,Integer).
Register | Represents method Register.
TPythonType_AllocSubtypeInst(PPyTypeObject,NativeInt) | Represents method TPythonType_AllocSubtypeInst(PPyTypeObject,NativeInt).
TPythonType_Call(PPyObject,PPyObject,PPyObject) | Represents method TPythonType_Call(PPyObject,PPyObject,PPyObject).
TPythonType_Clear(PPyObject) | Represents method TPythonType_Clear(PPyObject).
TPythonType_Compare(PPyObject,PPyObject) | Represents method TPythonType_Compare(PPyObject,PPyObject).
TPythonType_GetAttr(PPyObject,PAnsiChar) | Represents method TPythonType_GetAttr(PPyObject,PAnsiChar).
TPythonType_GetAttrO(PPyObject,PPyObject) | Represents method TPythonType_GetAttrO(PPyObject,PPyObject).
TPythonType_Hash(PPyObject) | Represents method TPythonType_Hash(PPyObject).
TPythonType_InitSubtype(PPyObject,PPyObject,PPyObject) | Represents method TPythonType_InitSubtype(PPyObject,PPyObject,PPyObject).
TPythonType_Iter(PPyObject) | Represents method TPythonType_Iter(PPyObject).
TPythonType_IterNext(PPyObject) | Represents method TPythonType_IterNext(PPyObject).
TPythonType_MpAssSubscript(PPyObject,PPyObject,PPyObject) | Represents method TPythonType_MpAssSubscript(PPyObject,PPyObject,PPyObject).
TPythonType_MpLength(PPyObject) | Represents method TPythonType_MpLength(PPyObject).
TPythonType_MpSubscript(PPyObject,PPyObject) | Represents method TPythonType_MpSubscript(PPyObject,PPyObject).
TPythonType_NbAbsolute(PPyObject) | Represents method TPythonType_NbAbsolute(PPyObject).
TPythonType_NbAdd(PPyObject,PPyObject) | Represents method TPythonType_NbAdd(PPyObject,PPyObject).
TPythonType_NbAnd(PPyObject,PPyObject) | Represents method TPythonType_NbAnd(PPyObject,PPyObject).
TPythonType_NbCoerce(PPPyObject,PPPyObject) | Represents method TPythonType_NbCoerce(PPPyObject,PPPyObject).
TPythonType_NbDivide(PPyObject,PPyObject) | Represents method TPythonType_NbDivide(PPyObject,PPyObject).
TPythonType_NbDivmod(PPyObject,PPyObject) | Represents method TPythonType_NbDivmod(PPyObject,PPyObject).
TPythonType_NbFloat(PPyObject) | Represents method TPythonType_NbFloat(PPyObject).
TPythonType_NbFloorDivide(PPyObject,PPyObject) | Represents method TPythonType_NbFloorDivide(PPyObject,PPyObject).
TPythonType_NbHex(PPyObject) | Represents method TPythonType_NbHex(PPyObject).
TPythonType_NbInplaceAdd(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceAdd(PPyObject,PPyObject).
TPythonType_NbInplaceAnd(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceAnd(PPyObject,PPyObject).
TPythonType_NbInplaceDivide(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceDivide(PPyObject,PPyObject).
TPythonType_NbInplaceFloorDivide(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceFloorDivide(PPyObject,PPyObject).
TPythonType_NbInplaceLshift(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceLshift(PPyObject,PPyObject).
TPythonType_NbInplaceMultiply(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceMultiply(PPyObject,PPyObject).
TPythonType_NbInplaceOr(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceOr(PPyObject,PPyObject).
TPythonType_NbInplacePower(PPyObject,PPyObject,PPyObject) | Represents method TPythonType_NbInplacePower(PPyObject,PPyObject,PPyObject).
TPythonType_NbInplaceRemainder(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceRemainder(PPyObject,PPyObject).
TPythonType_NbInplaceRshift(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceRshift(PPyObject,PPyObject).
TPythonType_NbInplaceSubtract(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceSubtract(PPyObject,PPyObject).
TPythonType_NbInplaceTrueDivide(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceTrueDivide(PPyObject,PPyObject).
TPythonType_NbInplaceXor(PPyObject,PPyObject) | Represents method TPythonType_NbInplaceXor(PPyObject,PPyObject).
TPythonType_NbInt(PPyObject) | Represents method TPythonType_NbInt(PPyObject).
TPythonType_NbInvert(PPyObject) | Represents method TPythonType_NbInvert(PPyObject).
TPythonType_NbLong(PPyObject) | Represents method TPythonType_NbLong(PPyObject).
TPythonType_NbLShift(PPyObject,PPyObject) | Represents method TPythonType_NbLShift(PPyObject,PPyObject).
TPythonType_NbMultiply(PPyObject,PPyObject) | Represents method TPythonType_NbMultiply(PPyObject,PPyObject).
TPythonType_NbNegative(PPyObject) | Represents method TPythonType_NbNegative(PPyObject).
TPythonType_NbNonZero(PPyObject) | Represents method TPythonType_NbNonZero(PPyObject).
TPythonType_NbOct(PPyObject) | Represents method TPythonType_NbOct(PPyObject).
TPythonType_NbOr(PPyObject,PPyObject) | Represents method TPythonType_NbOr(PPyObject,PPyObject).
TPythonType_NbPositive(PPyObject) | Represents method TPythonType_NbPositive(PPyObject).
TPythonType_NbPower(PPyObject,PPyObject,PPyObject) | Represents method TPythonType_NbPower(PPyObject,PPyObject,PPyObject).
TPythonType_NbRemainder(PPyObject,PPyObject) | Represents method TPythonType_NbRemainder(PPyObject,PPyObject).
TPythonType_NbRShift(PPyObject,PPyObject) | Represents method TPythonType_NbRShift(PPyObject,PPyObject).
TPythonType_NbSubstract(PPyObject,PPyObject) | Represents method TPythonType_NbSubstract(PPyObject,PPyObject).
TPythonType_NbTrueDivide(PPyObject,PPyObject) | Represents method TPythonType_NbTrueDivide(PPyObject,PPyObject).
TPythonType_NbXor(PPyObject,PPyObject) | Represents method TPythonType_NbXor(PPyObject,PPyObject).
TPythonType_Print(PPyObject,file,integer) |
TPythonType_Repr(PPyObject) | Represents method TPythonType_Repr(PPyObject).
TPythonType_RichCmp(PPyObject,PPyObject,Integer) | Represents method TPythonType_RichCmp(PPyObject,PPyObject,Integer).
TPythonType_SetAttr(PPyObject,PAnsiChar,PPyObject) | Represents method TPythonType_SetAttr(PPyObject,PAnsiChar,PPyObject).
TPythonType_SetAttrO(PPyObject,PPyObject,PPyObject) | Represents method TPythonType_SetAttrO(PPyObject,PPyObject,PPyObject).
TPythonType_SqAssItem(PPyObject,NativeInt,PPyObject) | Represents method TPythonType_SqAssItem(PPyObject,NativeInt,PPyObject).
TPythonType_SqAssSlice(PPyObject,NativeInt,NativeInt,PPyObject) | Represents method TPythonType_SqAssSlice(PPyObject,NativeInt,NativeInt,PPyObject).
TPythonType_SqConcat(PPyObject,PPyObject) | Represents method TPythonType_SqConcat(PPyObject,PPyObject).
TPythonType_SqContains(PPyObject,PPyObject) | Represents method TPythonType_SqContains(PPyObject,PPyObject).
TPythonType_SqInplaceConcat(PPyObject,PPyObject) | Represents method TPythonType_SqInplaceConcat(PPyObject,PPyObject).
TPythonType_SqInplaceRepeat(PPyObject,NativeInt) | Represents method TPythonType_SqInplaceRepeat(PPyObject,NativeInt).
TPythonType_SqItem(PPyObject,NativeInt) | Represents method TPythonType_SqItem(PPyObject,NativeInt).
TPythonType_SqLength(PPyObject) | Represents method TPythonType_SqLength(PPyObject).
TPythonType_SqRepeat(PPyObject,NativeInt) | Represents method TPythonType_SqRepeat(PPyObject,NativeInt).
TPythonType_SqSlice(PPyObject,NativeInt,NativeInt) | Represents method TPythonType_SqSlice(PPyObject,NativeInt,NativeInt).
TPythonType_Str(PPyObject) | Represents method TPythonType_Str(PPyObject).
TPythonType_Traverse(PPyObject,visitproc,Pointer) | Represents method TPythonType_Traverse(PPyObject,visitproc,Pointer).
Top


CodeMemPageCount Method

Summary

Represents method CodeMemPageCount.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function CodeMemPageCount: integer;

Return Value

Type: integer

See Also

Reference

  • BI.Plugins.Python.Engine


DeleteCallBack(Pointer) Method

Summary

Represents method DeleteCallBack(Pointer).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
procedure DeleteCallBack( Proc: Pointer );

Parameters

Proc
Type: Pointer

See Also

Reference

  • BI.Plugins.Python.Engine


FreeCallBacks Method

Summary

Represents method FreeCallBacks.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
procedure FreeCallBacks;
See Also

Reference

  • BI.Plugins.Python.Engine


FreeCodeMem(Pointer) Method

Summary

Represents method FreeCodeMem(Pointer).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
procedure FreeCodeMem(ptr: Pointer);

Parameters

ptr
Type: Pointer

See Also

Reference

  • BI.Plugins.Python.Engine


FreeSubtypeInst(PPyObject) Method

Summary

Represents method FreeSubtypeInst(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
procedure FreeSubtypeInst(ob:PPyObject); cdecl;

Parameters

ob
Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


GetCallBack(TObject,Pointer,Integer,TCallType) Method

Summary

Represents method GetCallBack(TObject,Pointer,Integer,TCallType).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function GetCallBack( self: TObject; method: Pointer;
 argnum: Integer; calltype: tcalltype): Pointer;

Parameters

self
Type: TObject

method
Type: Pointer

argnum
Type: Integer

calltype
Type: tcalltype

Return Value

Type: Pointer

See Also

Reference

  • BI.Plugins.Python.Engine


GetCodeMem(PByte,integer) Method

Summary

Represents method GetCodeMem(PByte,integer).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
 procedure GetCodeMem(var ptr: PByte; size: integer);

Parameters

ptr
Type: PByte

size
Type: integer

See Also

Reference

  • BI.Plugins.Python.Engine


GetDDECallBack(TDDEAPIfunc) Method

Summary

Represents method GetDDECallBack(TDDEAPIfunc).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function GetDDECallBack(method: TDDEAPIfunc): Pointer;

Parameters

method
Type: TDDEAPIfunc

Return Value

Type: Pointer

See Also

Reference

  • BI.Plugins.Python.Engine


GetOfObjectCallBack(TCallBack,Integer,TCallType) Method

Summary

Represents method GetOfObjectCallBack(TCallBack,Integer,TCallType).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function GetOfObjectCallBack( CallBack: TCallBack;
 argnum: Integer; calltype: TCallType): Pointer;

Parameters

CallBack
Type: TCallBack

argnum
Type: Integer

calltype
Type: TCallType

Return Value

Type: Pointer

See Also

Reference

  • BI.Plugins.Python.Engine


GetPythonEngine Method

Summary

Represents method GetPythonEngine.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function GetPythonEngine : TPythonEngine;

Return Value

Type: TPythonEngine

See Also

Reference

  • BI.Plugins.Python.Engine


IsDelphiObject(PPyObject) Method

Summary

Represents method IsDelphiObject(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function IsDelphiObject( obj : PPyObject ) : Boolean;

Parameters

obj
Type: PPyObject

Return Value

Type: Boolean

See Also

Reference

  • BI.Plugins.Python.Engine


IsPythonVersionRegistered(string,string,Boolean) Method

Summary

Represents method IsPythonVersionRegistered(string,string,Boolean).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function IsPythonVersionRegistered(PythonVersion : string;
 out InstallPath: string; out AllUserInstall: Boolean) : Boolean;

Parameters

PythonVersion
Type: string

InstallPath
Type: string

AllUserInstall
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • BI.Plugins.Python.Engine


MaskFPUExceptions(boolean,Boolean) Method

Summary

Represents method MaskFPUExceptions(boolean,Boolean).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
procedure MaskFPUExceptions(ExceptionsMasked : boolean;
 MatchPythonPrecision : Boolean = True);

Parameters

ExceptionsMasked
Type: boolean

MatchPythonPrecision
Type: Boolean

See Also

Reference

  • BI.Plugins.Python.Engine


pyio_GetTypesStats(PPyObject,PPyObject) Method

Summary

Represents method pyio_GetTypesStats(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function pyio_GetTypesStats(self, args : PPyObject) : PPyObject; cdecl;

Parameters

self
Type: PPyObject

args
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


pyio_read(PPyObject,PPyObject) Method

Summary

Represents method pyio_read(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function pyio_read(self, args : PPyObject) : PPyObject; cdecl;

Parameters

self
Type: PPyObject

args
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


pyio_SetDelayWrites(PPyObject,PPyObject) Method

Summary

Represents method pyio_SetDelayWrites(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function pyio_SetDelayWrites(self, args : PPyObject) : PPyObject; cdecl;

Parameters

self
Type: PPyObject

args
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


pyio_SetMaxLines(PPyObject,PPyObject) Method

Summary

Represents method pyio_SetMaxLines(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function pyio_SetMaxLines(self, args : PPyObject) : PPyObject; cdecl;

Parameters

self
Type: PPyObject

args
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


pyio_write(PPyObject,PPyObject) Method

Summary

Represents method pyio_write(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function pyio_write(self, args : PPyObject) : PPyObject; cdecl;

Parameters

self
Type: PPyObject

args
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


PyObjectDestructor(PPyObject) Method

Summary

Represents method PyObjectDestructor(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
procedure PyObjectDestructor( pSelf : PPyObject); cdecl;

Parameters

pSelf
Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


PythonOK Method

Summary

Represents method PythonOK.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function PythonOK : Boolean;

Return Value

Type: Boolean

See Also

Reference

  • BI.Plugins.Python.Engine


PythonToDelphi(PPyObject) Method

Summary

Represents method PythonToDelphi(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function PythonToDelphi( obj : PPyObject ) : TPyObject;

Parameters

obj
Type: PPyObject

Return Value

Type: TPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


PyType_HasFeature(PPyTypeObject,Integer) Method

Summary

Represents method PyType_HasFeature(PPyTypeObject,Integer).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function PyType_HasFeature(AType : PPyTypeObject; AFlag : Integer) : Boolean;

Parameters

AType
Type: PPyTypeObject

AFlag
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • BI.Plugins.Python.Engine


Register Method

Summary

Represents method Register.

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
procedure Register;
See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_AllocSubtypeInst(PPyTypeObject,NativeInt) Method

Summary

Represents method TPythonType_AllocSubtypeInst(PPyTypeObject,NativeInt).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_AllocSubtypeInst( pSelf: PPyTypeObject; nitems : NativeInt) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyTypeObject

nitems
Type: NativeInt

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_Call(PPyObject,PPyObject,PPyObject) Method

Summary

Represents method TPythonType_Call(PPyObject,PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_Call( pSelf, ob1, ob2 : PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

ob1
Type: PPyObject

ob2
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_Clear(PPyObject) Method

Summary

Represents method TPythonType_Clear(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_Clear( pSelf: PPyObject): integer; cdecl;

Parameters

pSelf
Type: PPyObject

Return Value

Type: integer

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_Compare(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_Compare(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_Compare( pSelf, obj : PPyObject ) : Integer; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: Integer

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_GetAttr(PPyObject,PAnsiChar) Method

Summary

Represents method TPythonType_GetAttr(PPyObject,PAnsiChar).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_GetAttr( pSelf : PPyObject; key : PAnsiChar) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

key
Type: PAnsiChar

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_GetAttrO(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_GetAttrO(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_GetAttrO( pSelf, key: PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

key
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_Hash(PPyObject) Method

Summary

Represents method TPythonType_Hash(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_Hash( pSelf : PPyObject) : NativeInt; cdecl;

Parameters

pSelf
Type: PPyObject

Return Value

Type: NativeInt

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_InitSubtype(PPyObject,PPyObject,PPyObject) Method

Summary

Represents method TPythonType_InitSubtype(PPyObject,PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_InitSubtype( pSelf, args, kwds : PPyObject) : Integer; cdecl;

Parameters

pSelf
Type: PPyObject

args
Type: PPyObject

kwds
Type: PPyObject

Return Value

Type: Integer

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_Iter(PPyObject) Method

Summary

Represents method TPythonType_Iter(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_Iter( pSelf: PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_IterNext(PPyObject) Method

Summary

Represents method TPythonType_IterNext(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_IterNext( pSelf: PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_MpAssSubscript(PPyObject,PPyObject,PPyObject) Method

Summary

Represents method TPythonType_MpAssSubscript(PPyObject,PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_MpAssSubscript( pSelf, obj1, obj2 : PPyObject) : Integer; cdecl;

Parameters

pSelf
Type: PPyObject

obj1
Type: PPyObject

obj2
Type: PPyObject

Return Value

Type: Integer

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_MpLength(PPyObject) Method

Summary

Represents method TPythonType_MpLength(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_MpLength( pSelf : PPyObject ) : NativeInt; cdecl;

Parameters

pSelf
Type: PPyObject

Return Value

Type: NativeInt

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_MpSubscript(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_MpSubscript(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_MpSubscript( pSelf, obj : PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbAbsolute(PPyObject) Method

Summary

Represents method TPythonType_NbAbsolute(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbAbsolute( pSelf : PPyObject ) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbAdd(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbAdd(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbAdd( pSelf, obj : PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbAnd(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbAnd(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbAnd( pSelf, obj : PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbCoerce(PPPyObject,PPPyObject) Method

Summary

Represents method TPythonType_NbCoerce(PPPyObject,PPPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbCoerce( pSelf, obj : PPPyObject) : Integer; cdecl;

Parameters

pSelf
Type: PPPyObject

obj
Type: PPPyObject

Return Value

Type: Integer

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbDivide(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbDivide(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbDivide( pSelf, obj : PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbDivmod(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbDivmod(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbDivmod( pSelf, obj : PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbFloat(PPyObject) Method

Summary

Represents method TPythonType_NbFloat(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbFloat( pSelf : PPyObject ) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbFloorDivide(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbFloorDivide(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbFloorDivide( pSelf, obj : PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbHex(PPyObject) Method

Summary

Represents method TPythonType_NbHex(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbHex( pSelf : PPyObject ) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbInplaceAdd(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbInplaceAdd(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbInplaceAdd(pSelf, obj: PPyObject): PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbInplaceAnd(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbInplaceAnd(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbInplaceAnd(pSelf, obj: PPyObject): PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbInplaceDivide(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbInplaceDivide(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbInplaceDivide(pSelf, obj: PPyObject): PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbInplaceFloorDivide(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbInplaceFloorDivide(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbInplaceFloorDivide( pSelf, obj : PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbInplaceLshift(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbInplaceLshift(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbInplaceLshift(pSelf, obj: PPyObject): PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbInplaceMultiply(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbInplaceMultiply(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbInplaceMultiply(pSelf, obj: PPyObject): PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbInplaceOr(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbInplaceOr(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbInplaceOr(pSelf, obj: PPyObject): PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbInplacePower(PPyObject,PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbInplacePower(PPyObject,PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbInplacePower(pSelf, ob1, ob2: PPyObject): PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

ob1
Type: PPyObject

ob2
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbInplaceRemainder(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbInplaceRemainder(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbInplaceRemainder(pSelf, obj: PPyObject): PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbInplaceRshift(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbInplaceRshift(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbInplaceRshift(pSelf, obj: PPyObject): PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbInplaceSubtract(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbInplaceSubtract(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbInplaceSubtract(pSelf, obj: PPyObject): PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbInplaceTrueDivide(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbInplaceTrueDivide(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbInplaceTrueDivide( pSelf, obj : PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbInplaceXor(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbInplaceXor(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbInplaceXor(pSelf, obj: PPyObject): PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbInt(PPyObject) Method

Summary

Represents method TPythonType_NbInt(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbInt( pSelf : PPyObject ) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbInvert(PPyObject) Method

Summary

Represents method TPythonType_NbInvert(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbInvert( pSelf : PPyObject ) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbLong(PPyObject) Method

Summary

Represents method TPythonType_NbLong(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbLong( pSelf : PPyObject ) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbLShift(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbLShift(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbLShift( pSelf, obj : PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbMultiply(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbMultiply(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbMultiply( pSelf, obj : PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbNegative(PPyObject) Method

Summary

Represents method TPythonType_NbNegative(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbNegative( pSelf : PPyObject ) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbNonZero(PPyObject) Method

Summary

Represents method TPythonType_NbNonZero(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbNonZero( pSelf : PPyObject ) : Integer; cdecl;

Parameters

pSelf
Type: PPyObject

Return Value

Type: Integer

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbOct(PPyObject) Method

Summary

Represents method TPythonType_NbOct(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbOct( pSelf : PPyObject ) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbOr(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbOr(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbOr( pSelf, obj : PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbPositive(PPyObject) Method

Summary

Represents method TPythonType_NbPositive(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbPositive( pSelf : PPyObject ) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbPower(PPyObject,PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbPower(PPyObject,PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbPower( pSelf, ob1, ob2 : PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

ob1
Type: PPyObject

ob2
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbRemainder(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbRemainder(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbRemainder( pSelf, obj : PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbRShift(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbRShift(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbRShift( pSelf, obj : PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbSubstract(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbSubstract(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbSubstract( pSelf, obj : PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbTrueDivide(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbTrueDivide(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbTrueDivide( pSelf, obj : PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_NbXor(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_NbXor(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_NbXor( pSelf, obj : PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_Print(PPyObject,file,integer) Method

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_Print( pSelf : PPyObject; var f: file; i: integer) : Integer; cdecl;

Parameters

pSelf
Type: PPyObject

f
Type: file

i
Type: integer

Return Value

Type: Integer

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_Repr(PPyObject) Method

Summary

Represents method TPythonType_Repr(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_Repr( pSelf : PPyObject ) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_RichCmp(PPyObject,PPyObject,Integer) Method

Summary

Represents method TPythonType_RichCmp(PPyObject,PPyObject,Integer).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_RichCmp( pSelf, obj : PPyObject; i : Integer) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

i
Type: Integer

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_SetAttr(PPyObject,PAnsiChar,PPyObject) Method

Summary

Represents method TPythonType_SetAttr(PPyObject,PAnsiChar,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_SetAttr( pSelf : PPyObject; key : PAnsiChar; value : PPyObject) : Integer; cdecl;

Parameters

pSelf
Type: PPyObject

key
Type: PAnsiChar

value
Type: PPyObject

Return Value

Type: Integer

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_SetAttrO(PPyObject,PPyObject,PPyObject) Method

Summary

Represents method TPythonType_SetAttrO(PPyObject,PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_SetAttrO( pSelf, key, value: PPyObject) : Integer; cdecl;

Parameters

pSelf
Type: PPyObject

key
Type: PPyObject

value
Type: PPyObject

Return Value

Type: Integer

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_SqAssItem(PPyObject,NativeInt,PPyObject) Method

Summary

Represents method TPythonType_SqAssItem(PPyObject,NativeInt,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_SqAssItem( pSelf : PPyObject; idx : NativeInt; obj : PPyObject) : Integer; cdecl;

Parameters

pSelf
Type: PPyObject

idx
Type: NativeInt

obj
Type: PPyObject

Return Value

Type: Integer

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_SqAssSlice(PPyObject,NativeInt,NativeInt,PPyObject) Method

Summary

Represents method TPythonType_SqAssSlice(PPyObject,NativeInt,NativeInt,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_SqAssSlice( pSelf : PPyObject; idx1, idx2 : NativeInt; obj : PPyObject): integer; cdecl;

Parameters

pSelf
Type: PPyObject

idx1
Type: NativeInt

idx2
Type: NativeInt

obj
Type: PPyObject

Return Value

Type: integer

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_SqConcat(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_SqConcat(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_SqConcat( pSelf, obj : PPyObject) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_SqContains(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_SqContains(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_SqContains(pSelf, obj : PPyObject): integer; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: integer

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_SqInplaceConcat(PPyObject,PPyObject) Method

Summary

Represents method TPythonType_SqInplaceConcat(PPyObject,PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_SqInplaceConcat(pSelf, obj: PPyObject): PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

obj
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_SqInplaceRepeat(PPyObject,NativeInt) Method

Summary

Represents method TPythonType_SqInplaceRepeat(PPyObject,NativeInt).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_SqInplaceRepeat(pSelf : PPyObject; i: NativeInt): PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

i
Type: NativeInt

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_SqItem(PPyObject,NativeInt) Method

Summary

Represents method TPythonType_SqItem(PPyObject,NativeInt).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_SqItem( pSelf : PPyObject; idx : NativeInt ) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

idx
Type: NativeInt

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_SqLength(PPyObject) Method

Summary

Represents method TPythonType_SqLength(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_SqLength( pSelf : PPyObject ) : NativeInt; cdecl;

Parameters

pSelf
Type: PPyObject

Return Value

Type: NativeInt

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_SqRepeat(PPyObject,NativeInt) Method

Summary

Represents method TPythonType_SqRepeat(PPyObject,NativeInt).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_SqRepeat( pSelf : PPyObject; val : NativeInt ) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

val
Type: NativeInt

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_SqSlice(PPyObject,NativeInt,NativeInt) Method

Summary

Represents method TPythonType_SqSlice(PPyObject,NativeInt,NativeInt).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_SqSlice( pSelf : PPyObject; idx1, idx2 : NativeInt ) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

idx1
Type: NativeInt

idx2
Type: NativeInt

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_Str(PPyObject) Method

Summary

Represents method TPythonType_Str(PPyObject).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_Str( pSelf : PPyObject ) : PPyObject; cdecl;

Parameters

pSelf
Type: PPyObject

Return Value

Type: PPyObject

See Also

Reference

  • BI.Plugins.Python.Engine


TPythonType_Traverse(PPyObject,visitproc,Pointer) Method

Summary

Represents method TPythonType_Traverse(PPyObject,visitproc,Pointer).

Namespace: BI.Plugins.Python.Engine
Syntax
Delphi
function TPythonType_Traverse( pSelf: PPyObject; proc: visitproc; ptr: Pointer) : integer; cdecl;

Parameters

pSelf
Type: PPyObject

proc
Type: visitproc

ptr
Type: Pointer

Return Value

Type: integer

See Also

Reference

  • BI.Plugins.Python.Engine


BI.Plugins.R Namespace

Summary

Represents namespace BI.Plugins.R.

Classes
Name | Description
TBIREngine | Represents type TBIREngine.
TRBaseAlgorithm | Represents type TRBaseAlgorithm.
TRSupervisedModel | Represents type TRSupervisedModel.
Top


BI.Plugins.R Classes

Classes
Name | Description
TBIREngine | Represents type TBIREngine.
TRBaseAlgorithm | Represents type TRBaseAlgorithm.
TRSupervisedModel | Represents type TRSupervisedModel.
Top


TBIREngine Class

Summary

Represents type TBIREngine.

Namespace: BI.Plugins.R
Inheritance Hierarchy
TObject
BI.Algorithm.Model.TBIPlugin
BI.Plugins.R.TBIREngine
BI.Plugins.R.Command.TRCommand
BI.Plugins.R.opaR.TopaR
Syntax
Delphi
type
 TBIREngine=class(TBIPlugin)
 end;

The TBIREngine type exposes the following members.

Properties
Show:
Name | Description
Engine | Represents property Engine.
Top
Methods
Show:
Name | Description
AddPackage(TStrings,String) | Represents method AddPackage(TStrings,String).
AddVariable(String,TNativeIntArray,TDataArray,Boolean) | Overloaded. Represents method AddVariable(String,TNativeIntArray,TDataArray,Boolean).
AddVariable(String,TNativeIntArray,TDataItem,Boolean) | Overloaded. Represents method AddVariable(String,TNativeIntArray,TDataItem,Boolean).
Finish | Represents method Finish.
GetVariable(String,TDataItem) | Represents method GetVariable(String,TDataItem).
LoadPackage(String) | Represents method LoadPackage(String).
ParseOutput(TDataItem) | Represents method ParseOutput(TDataItem).
ParseRawMap(TDataItem,TDataItem) | Represents method ParseRawMap(TDataItem,TDataItem).
Start | Represents method Start.
Statement(String) | Represents method Statement(String).
Version | Represents method Version.
Top
Fields
Show:
Name | Description
Output | Represents field Output.
Top
See Also

Reference

  • BI.Plugins.R


TBIREngine Properties

Properties
Name | Description
Engine | Represents property Engine.
Top


TBIREngine.Engine Property

Summary

Represents property Engine.

Namespace: BI.Plugins.R
Syntax
Delphi
public
 class property Engine:TBIREngine read FEngine write SetEngine;

Property Value

Type: TBIREngine

See Also

Reference

  • TBIREngine
  • BI.Plugins.R


TBIREngine Methods

Methods
Name | Description
AddPackage(TStrings,String) | Represents method AddPackage(TStrings,String).
AddVariable(String,TNativeIntArray,TDataArray,Boolean) | Overloaded. Represents method AddVariable(String,TNativeIntArray,TDataArray,Boolean).
AddVariable(String,TNativeIntArray,TDataItem,Boolean) | Overloaded. Represents method AddVariable(String,TNativeIntArray,TDataItem,Boolean).
Finish | Represents method Finish.
GetVariable(String,TDataItem) | Represents method GetVariable(String,TDataItem).
LoadPackage(String) | Represents method LoadPackage(String).
ParseOutput(TDataItem) | Represents method ParseOutput(TDataItem).
ParseRawMap(TDataItem,TDataItem) | Represents method ParseRawMap(TDataItem,TDataItem).
Start | Represents method Start.
Statement(String) | Represents method Statement(String).
Version | Represents method Version.
Top


TBIREngine.AddPackage(TStrings,String) Method

Summary

Represents method AddPackage(TStrings,String).

Namespace: BI.Plugins.R
Syntax
Delphi
protected
 procedure AddPackage(const AOutput:TStrings; const APackage:String);

Parameters

AOutput
Type: TStrings

APackage
Type: String

See Also

Reference

  • TBIREngine
  • BI.Plugins.R


TBIREngine.AddVariable(String,TNativeIntArray,TDataArray,Boolean) Method

Summary

Represents method AddVariable(String,TNativeIntArray,TDataArray,Boolean).

Namespace: BI.Plugins.R
Syntax
Delphi
public
 procedure AddVariable(const AName:String; const Index:TNativeIntArray;
 const AData:TDataArray; const UseMissing:Boolean=True); overload; virtual; abstract;

Parameters

AName
Type: String

Index
Type: System.Void

AData
Type: TDataArray

UseMissing
Type: Boolean

See Also

Reference

  • TBIREngine
  • BI.Plugins.R


TBIREngine.AddVariable(String,TNativeIntArray,TDataItem,Boolean) Method

Summary

Represents method AddVariable(String,TNativeIntArray,TDataItem,Boolean).

Namespace: BI.Plugins.R
Syntax
Delphi
public
 procedure AddVariable(const AName:String; const Index:TNativeIntArray;
 const AData:TDataItem; const UseMissing:Boolean=True); overload;

Parameters

AName
Type: String

Index
Type: System.Void

AData
Type: TDataItem

UseMissing
Type: Boolean

See Also

Reference

  • TBIREngine
  • BI.Plugins.R


TBIREngine.Finish Method

Summary

Represents method Finish.

Namespace: BI.Plugins.R
Syntax
Delphi
protected
 function Finish:Boolean; virtual;

Return Value

Type: Boolean

See Also

Reference

  • TBIREngine
  • BI.Plugins.R


TBIREngine.GetVariable(String,TDataItem) Method

Summary

Represents method GetVariable(String,TDataItem).

Namespace: BI.Plugins.R
Syntax
Delphi
public
 procedure GetVariable(const AName:String; const AData:TDataItem); virtual; abstract;

Parameters

AName
Type: String

AData
Type: TDataItem

See Also

Reference

  • TBIREngine
  • BI.Plugins.R


TBIREngine.LoadPackage(String) Method

Summary

Represents method LoadPackage(String).

Namespace: BI.Plugins.R
Syntax
Delphi
public
 procedure LoadPackage(const APackage:String); virtual; abstract;

Parameters

APackage
Type: String

See Also

Reference

  • TBIREngine
  • BI.Plugins.R


TBIREngine.ParseOutput(TDataItem) Method

Summary

Represents method ParseOutput(TDataItem).

Namespace: BI.Plugins.R
Syntax
Delphi
public
 procedure ParseOutput(const ADest:TDataItem); virtual; abstract;

Parameters

ADest
Type: TDataItem

See Also

Reference

  • TBIREngine
  • BI.Plugins.R


TBIREngine.ParseRawMap(TDataItem,TDataItem) Method

Summary

Represents method ParseRawMap(TDataItem,TDataItem).

Namespace: BI.Plugins.R
Syntax
Delphi
public
 procedure ParseRawMap(const AMap,ADest:TDataItem); virtual; abstract;

Parameters

AMap
Type: TDataItem

ADest
Type: TDataItem

See Also

Reference

  • TBIREngine
  • BI.Plugins.R


TBIREngine.Start Method

Summary

Represents method Start.

Namespace: BI.Plugins.R
Syntax
Delphi
protected
 procedure Start; virtual;
See Also

Reference

  • TBIREngine
  • BI.Plugins.R


TBIREngine.Statement(String) Method

Summary

Represents method Statement(String).

Namespace: BI.Plugins.R
Syntax
Delphi
public
 procedure Statement(const AStatement:String); virtual; abstract;

Parameters

AStatement
Type: String

See Also

Reference

  • TBIREngine
  • BI.Plugins.R


TBIREngine.Version Method

Summary

Represents method Version.

Namespace: BI.Plugins.R
Syntax
Delphi
public
 function Version:String; virtual; abstract;

Return Value

Type: String

See Also

Reference

  • TBIREngine
  • BI.Plugins.R


TBIREngine Fields

Fields
Name | Description
Output | Represents field Output.
Top


TBIREngine.Output Field

Summary

Represents field Output.

Namespace: BI.Plugins.R
Syntax
Delphi
public
 class var
 Output : TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TBIREngine
  • BI.Plugins.R


TRBaseAlgorithm Class

Summary

Represents type TRBaseAlgorithm.

Namespace: BI.Plugins.R
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TBaseAlgorithm
BI.Plugins.R.TRBaseAlgorithm
BI.Algorithm.Classify.TBICrossTable
Syntax
Delphi
type
 TRBaseAlgorithm=class(TBaseAlgorithm)
 end;

The TRBaseAlgorithm type exposes the following members.

Methods
Show:
Name | Description
BuildScript | Represents method BuildScript.
Calculate | Represents method Calculate. (Overrides TBaseAlgorithm.Calculate.)
Plot | Represents method Plot.
R | Represents method R.
Top
See Also

Reference

  • BI.Plugins.R


TRBaseAlgorithm Methods

Methods
Name | Description
BuildScript | Represents method BuildScript.
Calculate | Represents method Calculate. (Overrides TBaseAlgorithm.Calculate.)
Plot | Represents method Plot.
R | Represents method R.
Top


TRBaseAlgorithm.BuildScript Method

Summary

Represents method BuildScript.

Namespace: BI.Plugins.R
Syntax
Delphi
protected
 procedure BuildScript; virtual; abstract;
See Also

Reference

  • TRBaseAlgorithm
  • BI.Plugins.R


TRBaseAlgorithm.Calculate Method

Summary

Represents method Calculate.

Namespace: BI.Plugins.R
Syntax
Delphi
public
 procedure Calculate; override;

Overrides

TBaseAlgorithm.Calculate
See Also

Reference

  • TRBaseAlgorithm
  • BI.Plugins.R


TRBaseAlgorithm.Plot Method

Summary

Represents method Plot.

Namespace: BI.Plugins.R
Syntax
Delphi
public
 procedure Plot; virtual;
See Also

Reference

  • TRBaseAlgorithm
  • BI.Plugins.R


TRBaseAlgorithm.R Method

Summary

Represents method R.

Namespace: BI.Plugins.R
Syntax
Delphi
protected
 function R:TBIREngine; inline;

Return Value

Type: TBIREngine

See Also

Reference

  • TRBaseAlgorithm
  • BI.Plugins.R


TRSupervisedModel Class

Summary

Represents type TRSupervisedModel.

Namespace: BI.Plugins.R
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TBaseAlgorithm
BI.Algorithm.Model.TModel
BI.Algorithm.Model.TSupervisedModel
BI.Plugins.R.TRSupervisedModel
BI.Algorithm.Bayes.TBINaiveBayes
BI.Algorithm.CART.TBICART
BI.Algorithm.Classify.TBINearestNeighbour
BI.Algorithm.DimReduction.TBIPCA
BI.Algorithm.Ensemble.TBIRandomForest
BI.Algorithm.Regression.TBISupportVector
Syntax
Delphi
type
 TRSupervisedModel=class(TSupervisedModel)
 end;

The TRSupervisedModel type exposes the following members.

Methods
Show:
Name | Description
BuildScript | Represents method BuildScript.
Calculate | Represents method Calculate. (Overrides TSupervisedModel.Calculate.)
Plot | Represents method Plot.
R | Represents method R.
Top
See Also

Reference

  • BI.Plugins.R


TRSupervisedModel Methods

Methods
Name | Description
BuildScript | Represents method BuildScript.
Calculate | Represents method Calculate. (Overrides TSupervisedModel.Calculate.)
Plot | Represents method Plot.
R | Represents method R.
Top


TRSupervisedModel.BuildScript Method

Summary

Represents method BuildScript.

Namespace: BI.Plugins.R
Syntax
Delphi
protected
 procedure BuildScript; virtual; abstract;
See Also

Reference

  • TRSupervisedModel
  • BI.Plugins.R


TRSupervisedModel.Calculate Method

Summary

Represents method Calculate.

Namespace: BI.Plugins.R
Syntax
Delphi
public
 procedure Calculate; override;

Overrides

TSupervisedModel.Calculate
See Also

Reference

  • TRSupervisedModel
  • BI.Plugins.R


TRSupervisedModel.Plot Method

Summary

Represents method Plot.

Namespace: BI.Plugins.R
Syntax
Delphi
public
 procedure Plot; virtual;
See Also

Reference

  • TRSupervisedModel
  • BI.Plugins.R


TRSupervisedModel.R Method

Summary

Represents method R.

Namespace: BI.Plugins.R
Syntax
Delphi
protected
 function R:TBIREngine; inline;

Return Value

Type: TBIREngine

See Also

Reference

  • TRSupervisedModel
  • BI.Plugins.R


BI.Plugins.R.Command Namespace

Summary

Represents namespace BI.Plugins.R.Command.

Classes
Name | Description
TRCommand | Represents type TRCommand.
Top
Records
Name | Description
TRStart | Represents type TRStart.
TRUnixStart | Represents type TRUnixStart.
Top
Enumerations
Name | Description
TStartupAction | Represents type TStartupAction.
TUiMode | Represents type TUiMode.
Top
Delegates
Name | Description
blah1 | Represents type blah1.
blah2 | Represents type blah2.
blah3 | Represents type blah3.
blah4 | Represents type blah4.
blah5 | Represents type blah5.
blah6 | Represents type blah6.
blah7 | Represents type blah7.
TR_DefParams | Represents type TR_DefParams.
TR_getDLLVersion | Represents type TR_getDLLVersion.
TR_SetParams | Represents type TR_SetParams.
TR_setStartTime | Represents type TR_setStartTime.
TR_tryEval | Represents type TR_tryEval.
Top
Types
Name | Description
Bool | Represents an alias of the LongBool type.
Top
Routines
Name | Description
AttributeNames(String,Integer) | Represents method AttributeNames(String,Integer).
RBusy(Integer) | Represents method RBusy(Integer).
RCallback | Represents method RCallback.
RReadConsole(PAnsiChar,PAnsiChar,Integer,Integer) | Represents method RReadConsole(PAnsiChar,PAnsiChar,Integer,Integer).
RShowMessage(PAnsiChar) | Represents method RShowMessage(PAnsiChar).
RWriteConsole(PAnsiChar,Integer) | Represents method RWriteConsole(PAnsiChar,Integer).
RWriteConsoleEx(PAnsiChar,Integer,Integer) | Represents method RWriteConsoleEx(PAnsiChar,Integer,Integer).
RYesNoCancel(PAnsiChar) | Represents method RYesNoCancel(PAnsiChar).
StartRAndWait(String,String,LongWord) | Represents method StartRAndWait(String,String,LongWord).
Top


BI.Plugins.R.Command Classes

Classes
Name | Description
TRCommand | Represents type TRCommand.
Top


TRCommand Class

Summary

Represents type TRCommand.

Namespace: BI.Plugins.R.Command
Inheritance Hierarchy
TObject
BI.Algorithm.Model.TBIPlugin
BI.Plugins.R.TBIREngine
BI.Plugins.R.Command.TRCommand
Syntax
Delphi
type
 TRCommand=class(TBIREngine)
 end;

The TRCommand type exposes the following members.

Constructors
Show:
Name | Description
Create(String) | Initializes a new instance of the TRCommand class.
Destroy | Represents the destructor of the TRCommand class.
Top
Methods
Show:
Name | Description
AddVariable(String,TNativeIntArray,TDataArray,Boolean) | Represents method AddVariable(String,TNativeIntArray,TDataArray,Boolean). (Overrides TBIREngine.AddVariable(String,TNativeIntArray,TDataArray,Boolean).)
CheckDLL | Represents method CheckDLL.
DLLPath | Represents method DLLPath.
Execute(String,LongWord) | Overloaded. Represents method Execute(String,LongWord).
Execute(TStrings,LongWord) | Overloaded. Represents method Execute(TStrings,LongWord).
ExecuteFile(String,LongWord) | Represents method ExecuteFile(String,LongWord).
Finish | Represents method Finish. (Overrides TBIREngine.Finish.)
GetVariable(String,TDataItem) | Represents method GetVariable(String,TDataItem). (Overrides TBIREngine.GetVariable(String,TDataItem).)
LoadPackage(String) | Represents method LoadPackage(String). (Overrides TBIREngine.LoadPackage(String).)
NextItem(Boolean) | Represents method NextItem(Boolean).
ParseItem(TLoopInteger,TDataItem,Boolean) | Represents method ParseItem(TLoopInteger,TDataItem,Boolean).
ParseOutput(TDataItem) | Represents method ParseOutput(TDataItem). (Overrides TBIREngine.ParseOutput(TDataItem).)
ParseRawMap(TDataItem,TDataItem) | Represents method ParseRawMap(TDataItem,TDataItem). (Overrides TBIREngine.ParseRawMap(TDataItem,TDataItem).)
Start | Represents method Start. (Overrides TBIREngine.Start.)
Statement(String) | Represents method Statement(String). (Overrides TBIREngine.Statement(String).)
Version | Represents method Version. (Overrides TBIREngine.Version.)
Top
See Also

Reference

  • BI.Plugins.R.Command


TRCommand Constructors

Constructors
Name | Description
Create(String) | Initializes a new instance of the TRCommand class.
Destroy | Represents the destructor of the TRCommand class.
Top


TRCommand.Create(String) Constructor

Summary

Initializes a new instance of the TRCommand class.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 Constructor Create(const APath:String='');

Parameters

APath
Type: String

See Also

Reference

  • TRCommand
  • BI.Plugins.R.Command


TRCommand.Destroy Destructor

Summary

Represents the destructor of the TRCommand class.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TRCommand
  • BI.Plugins.R.Command


TRCommand Methods

Methods
Name | Description
AddVariable(String,TNativeIntArray,TDataArray,Boolean) | Represents method AddVariable(String,TNativeIntArray,TDataArray,Boolean). (Overrides TBIREngine.AddVariable(String,TNativeIntArray,TDataArray,Boolean).)
CheckDLL | Represents method CheckDLL.
DLLPath | Represents method DLLPath.
Execute(String,LongWord) | Overloaded. Represents method Execute(String,LongWord).
Execute(TStrings,LongWord) | Overloaded. Represents method Execute(TStrings,LongWord).
ExecuteFile(String,LongWord) | Represents method ExecuteFile(String,LongWord).
Finish | Represents method Finish. (Overrides TBIREngine.Finish.)
GetVariable(String,TDataItem) | Represents method GetVariable(String,TDataItem). (Overrides TBIREngine.GetVariable(String,TDataItem).)
LoadPackage(String) | Represents method LoadPackage(String). (Overrides TBIREngine.LoadPackage(String).)
NextItem(Boolean) | Represents method NextItem(Boolean).
ParseItem(TLoopInteger,TDataItem,Boolean) | Represents method ParseItem(TLoopInteger,TDataItem,Boolean).
ParseOutput(TDataItem) | Represents method ParseOutput(TDataItem). (Overrides TBIREngine.ParseOutput(TDataItem).)
ParseRawMap(TDataItem,TDataItem) | Represents method ParseRawMap(TDataItem,TDataItem). (Overrides TBIREngine.ParseRawMap(TDataItem,TDataItem).)
Start | Represents method Start. (Overrides TBIREngine.Start.)
Statement(String) | Represents method Statement(String). (Overrides TBIREngine.Statement(String).)
Version | Represents method Version. (Overrides TBIREngine.Version.)
Top


TRCommand.AddVariable(String,TNativeIntArray,TDataArray,Boolean) Method

Summary

Represents method AddVariable(String,TNativeIntArray,TDataArray,Boolean).

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 procedure AddVariable(const AName:String; const Index:TNativeIntArray;
 const AData:TDataArray; const UseMissing:Boolean=True); override;

Parameters

AName
Type: String

Index
Type: System.Void

AData
Type: TDataArray

UseMissing
Type: Boolean

Overrides

TBIREngine.AddVariable(String,TNativeIntArray,TDataArray,Boolean)
See Also

Reference

  • TRCommand
  • BI.Plugins.R.Command


TRCommand.CheckDLL Method

Summary

Represents method CheckDLL.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
protected
 procedure CheckDLL;
See Also

Reference

  • TRCommand
  • BI.Plugins.R.Command


TRCommand.DLLPath Method

Summary

Represents method DLLPath.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 class function DLLPath:String; static;

Return Value

Type: String

See Also

Reference

  • TRCommand
  • BI.Plugins.R.Command


TRCommand.Execute(String,LongWord) Method

Summary

Represents method Execute(String,LongWord).

Namespace: BI.Plugins.R.Command
Syntax
Delphi
protected
 function Execute(const AScript:String; out ExitCode:LongWord):Boolean; overload;

Parameters

AScript
Type: String

ExitCode
Type: LongWord

Return Value

Type: Boolean

See Also

Reference

  • TRCommand
  • BI.Plugins.R.Command


TRCommand.Execute(TStrings,LongWord) Method

Summary

Represents method Execute(TStrings,LongWord).

Namespace: BI.Plugins.R.Command
Syntax
Delphi
protected
 function Execute(const AScript:TStrings; out ExitCode:LongWord):Boolean; overload;

Parameters

AScript
Type: TStrings

ExitCode
Type: LongWord

Return Value

Type: Boolean

See Also

Reference

  • TRCommand
  • BI.Plugins.R.Command


TRCommand.ExecuteFile(String,LongWord) Method

Summary

Represents method ExecuteFile(String,LongWord).

Namespace: BI.Plugins.R.Command
Syntax
Delphi
protected
 function ExecuteFile(const AScriptFile:String; out ExitCode:LongWord):Boolean;

Parameters

AScriptFile
Type: String

ExitCode
Type: LongWord

Return Value

Type: Boolean

See Also

Reference

  • TRCommand
  • BI.Plugins.R.Command


TRCommand.Finish Method

Summary

Represents method Finish.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 function Finish:Boolean; override;

Return Value

Type: Boolean

Overrides

TBIREngine.Finish
See Also

Reference

  • TRCommand
  • BI.Plugins.R.Command


TRCommand.GetVariable(String,TDataItem) Method

Summary

Represents method GetVariable(String,TDataItem).

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 procedure GetVariable(const AName:String; const AData:TDataItem); override;

Parameters

AName
Type: String

AData
Type: TDataItem

Overrides

TBIREngine.GetVariable(String,TDataItem)
See Also

Reference

  • TRCommand
  • BI.Plugins.R.Command


TRCommand.LoadPackage(String) Method

Summary

Represents method LoadPackage(String).

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 procedure LoadPackage(const APackage:String); override;

Parameters

APackage
Type: String

Overrides

TBIREngine.LoadPackage(String)
See Also

Reference

  • TRCommand
  • BI.Plugins.R.Command


TRCommand.NextItem(Boolean) Method

Summary

Represents method NextItem(Boolean).

Namespace: BI.Plugins.R.Command
Syntax
Delphi
protected
 function NextItem(const HasBrackets:Boolean):String;

Parameters

HasBrackets
Type: Boolean

Return Value

Type: String

See Also

Reference

  • TRCommand
  • BI.Plugins.R.Command


TRCommand.ParseItem(TLoopInteger,TDataItem,Boolean) Method

Summary

Represents method ParseItem(TLoopInteger,TDataItem,Boolean).

Namespace: BI.Plugins.R.Command
Syntax
Delphi
protected
 procedure ParseItem(const AIndex:TLoopInteger; const AData:TDataItem; const HasBrackets:Boolean);

Parameters

AIndex
Type: System.Void

AData
Type: TDataItem

HasBrackets
Type: Boolean

See Also

Reference

  • TRCommand
  • BI.Plugins.R.Command


TRCommand.ParseOutput(TDataItem) Method

Summary

Represents method ParseOutput(TDataItem).

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 procedure ParseOutput(const ADest:TDataItem); override;

Parameters

ADest
Type: TDataItem

Overrides

TBIREngine.ParseOutput(TDataItem)
See Also

Reference

  • TRCommand
  • BI.Plugins.R.Command


TRCommand.ParseRawMap(TDataItem,TDataItem) Method

Summary

Represents method ParseRawMap(TDataItem,TDataItem).

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 procedure ParseRawMap(const AMap,ADest:TDataItem); override;

Parameters

AMap
Type: TDataItem

ADest
Type: TDataItem

Overrides

TBIREngine.ParseRawMap(TDataItem,TDataItem)
See Also

Reference

  • TRCommand
  • BI.Plugins.R.Command


TRCommand.Start Method

Summary

Represents method Start.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 procedure Start; override;

Overrides

TBIREngine.Start
See Also

Reference

  • TRCommand
  • BI.Plugins.R.Command


TRCommand.Statement(String) Method

Summary

Represents method Statement(String).

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 procedure Statement(const AStatement:String); override;

Parameters

AStatement
Type: String

Overrides

TBIREngine.Statement(String)
See Also

Reference

  • TRCommand
  • BI.Plugins.R.Command


TRCommand.Version Method

Summary

Represents method Version.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 function Version:String; override;

Return Value

Type: String

Overrides

TBIREngine.Version
See Also

Reference

  • TRCommand
  • BI.Plugins.R.Command


BI.Plugins.R.Command Records

Records
Name | Description
TRStart | Represents type TRStart.
TRUnixStart | Represents type TRUnixStart.
Top


TRStart Record

Summary

Represents type TRStart.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
type
 TRStart=packed record
 end;

The TRStart type exposes the following members.

Fields
Show:
Name | Description
Busy | Represents field Busy.
CallBack | Represents field CallBack.
CharacterMode | Represents field CharacterMode.
Common | Represents field Common.
home | Represents field home.
ReadConsole | Represents field ReadConsole.
rhome | Represents field rhome.
ShowMessage | Represents field ShowMessage.
WriteConsole | Represents field WriteConsole.
WriteConsoleEx | Represents field WriteConsoleEx.
YesNoCancel | Represents field YesNoCancel.
Top
See Also

Reference

  • BI.Plugins.R.Command


TRStart Fields

Fields
Name | Description
Busy | Represents field Busy.
CallBack | Represents field CallBack.
CharacterMode | Represents field CharacterMode.
Common | Represents field Common.
home | Represents field home.
ReadConsole | Represents field ReadConsole.
rhome | Represents field rhome.
ShowMessage | Represents field ShowMessage.
WriteConsole | Represents field WriteConsole.
WriteConsoleEx | Represents field WriteConsoleEx.
YesNoCancel | Represents field YesNoCancel.
Top


TRStart.Busy Field

Summary

Represents field Busy.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 Busy:blah6;

Field Value

Type: blah6

See Also

Reference

  • TRStart
  • BI.Plugins.R.Command


TRStart.CallBack Field

Summary

Represents field CallBack.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 CallBack:blah3;

Field Value

Type: blah3

See Also

Reference

  • TRStart
  • BI.Plugins.R.Command


TRStart.CharacterMode Field

Summary

Represents field CharacterMode.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 CharacterMode:TUiMode;

Field Value

Type: TUiMode

See Also

Reference

  • TRStart
  • BI.Plugins.R.Command


TRStart.Common Field

Summary

Represents field Common.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 Common:TRUnixStart;

Field Value

Type: TRUnixStart

See Also

Reference

  • TRStart
  • BI.Plugins.R.Command


TRStart.home Field

Summary

Represents field home.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 rhome,
 home: Integer;

Field Value

Type: Integer

See Also

Reference

  • TRStart
  • BI.Plugins.R.Command


TRStart.ReadConsole Field

Summary

Represents field ReadConsole.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 ReadConsole:blah1;

Field Value

Type: blah1

See Also

Reference

  • TRStart
  • BI.Plugins.R.Command


TRStart.rhome Field

Summary

Represents field rhome.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 rhome,
 home: Integer;

Field Value

Type: Integer

See Also

Reference

  • TRStart
  • BI.Plugins.R.Command


TRStart.ShowMessage Field

Summary

Represents field ShowMessage.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 ShowMessage:blah4;

Field Value

Type: blah4

See Also

Reference

  • TRStart
  • BI.Plugins.R.Command


TRStart.WriteConsole Field

Summary

Represents field WriteConsole.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 WriteConsole:blah2;

Field Value

Type: blah2

See Also

Reference

  • TRStart
  • BI.Plugins.R.Command


TRStart.WriteConsoleEx Field

Summary

Represents field WriteConsoleEx.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 WriteConsoleEx:blah7;

Field Value

Type: blah7

See Also

Reference

  • TRStart
  • BI.Plugins.R.Command


TRStart.YesNoCancel Field

Summary

Represents field YesNoCancel.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 YesNoCancel:blah5;

Field Value

Type: blah5

See Also

Reference

  • TRStart
  • BI.Plugins.R.Command


TRUnixStart Record

Summary

Represents type TRUnixStart.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
type
 TRUnixStart=packed record
 end;

The TRUnixStart type exposes the following members.

Fields
Show:
Name | Description
DebugInitFile | Represents field DebugInitFile.
LoadInitFile | Represents field LoadInitFile.
LoadSiteFile | Represents field LoadSiteFile.
max_nsize | Represents field max_nsize.
max_vsize | Represents field max_vsize.
NoRenviron | Represents field NoRenviron.
nsize | Represents field nsize.
ppsize | Represents field ppsize.
RestoreAction | Represents field RestoreAction.
R_Interactive | Represents field R_Interactive.
R_Quiet | Represents field R_Quiet.
R_Slave | Represents field R_Slave.
R_Verbose | Represents field R_Verbose.
SaveAction | Represents field SaveAction.
vsize | Represents field vsize.
Top
See Also

Reference

  • BI.Plugins.R.Command


TRUnixStart Fields

Fields
Name | Description
DebugInitFile | Represents field DebugInitFile.
LoadInitFile | Represents field LoadInitFile.
LoadSiteFile | Represents field LoadSiteFile.
max_nsize | Represents field max_nsize.
max_vsize | Represents field max_vsize.
NoRenviron | Represents field NoRenviron.
nsize | Represents field nsize.
ppsize | Represents field ppsize.
RestoreAction | Represents field RestoreAction.
R_Interactive | Represents field R_Interactive.
R_Quiet | Represents field R_Quiet.
R_Slave | Represents field R_Slave.
R_Verbose | Represents field R_Verbose.
SaveAction | Represents field SaveAction.
vsize | Represents field vsize.
Top


TRUnixStart.DebugInitFile Field

Summary

Represents field DebugInitFile.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 R_Quiet,
 R_Slave,
 R_Interactive,
 R_Verbose,
 LoadSiteFile,
 LoadInitFile,
 DebugInitFile : Bool;

Field Value

Type: Bool

See Also

Reference

  • TRUnixStart
  • BI.Plugins.R.Command


TRUnixStart.LoadInitFile Field

Summary

Represents field LoadInitFile.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 R_Quiet,
 R_Slave,
 R_Interactive,
 R_Verbose,
 LoadSiteFile,
 LoadInitFile,
 DebugInitFile : Bool;

Field Value

Type: Bool

See Also

Reference

  • TRUnixStart
  • BI.Plugins.R.Command


TRUnixStart.LoadSiteFile Field

Summary

Represents field LoadSiteFile.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 R_Quiet,
 R_Slave,
 R_Interactive,
 R_Verbose,
 LoadSiteFile,
 LoadInitFile,
 DebugInitFile : Bool;

Field Value

Type: Bool

See Also

Reference

  • TRUnixStart
  • BI.Plugins.R.Command


TRUnixStart.max_nsize Field

Summary

Represents field max_nsize.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 vsize,
 nsize,
 max_vsize,
 max_nsize,
 ppsize: UInt32;

Field Value

Type: UInt32

See Also

Reference

  • TRUnixStart
  • BI.Plugins.R.Command


TRUnixStart.max_vsize Field

Summary

Represents field max_vsize.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 vsize,
 nsize,
 max_vsize,
 max_nsize,
 ppsize: UInt32;

Field Value

Type: UInt32

See Also

Reference

  • TRUnixStart
  • BI.Plugins.R.Command


TRUnixStart.NoRenviron Field

Summary

Represents field NoRenviron.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 NoRenviron:Integer;

Field Value

Type: Integer

See Also

Reference

  • TRUnixStart
  • BI.Plugins.R.Command


TRUnixStart.nsize Field

Summary

Represents field nsize.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 vsize,
 nsize,
 max_vsize,
 max_nsize,
 ppsize: UInt32;

Field Value

Type: UInt32

See Also

Reference

  • TRUnixStart
  • BI.Plugins.R.Command


TRUnixStart.ppsize Field

Summary

Represents field ppsize.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 vsize,
 nsize,
 max_vsize,
 max_nsize,
 ppsize: UInt32;

Field Value

Type: UInt32

See Also

Reference

  • TRUnixStart
  • BI.Plugins.R.Command


TRUnixStart.RestoreAction Field

Summary

Represents field RestoreAction.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 RestoreAction:TStartupAction;

Field Value

Type: TStartupAction

See Also

Reference

  • TRUnixStart
  • BI.Plugins.R.Command


TRUnixStart.R_Interactive Field

Summary

Represents field R_Interactive.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 R_Quiet,
 R_Slave,
 R_Interactive,
 R_Verbose,
 LoadSiteFile,
 LoadInitFile,
 DebugInitFile : Bool;

Field Value

Type: Bool

See Also

Reference

  • TRUnixStart
  • BI.Plugins.R.Command


TRUnixStart.R_Quiet Field

Summary

Represents field R_Quiet.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 R_Quiet,
 R_Slave,
 R_Interactive,
 R_Verbose,
 LoadSiteFile,
 LoadInitFile,
 DebugInitFile : Bool;

Field Value

Type: Bool

See Also

Reference

  • TRUnixStart
  • BI.Plugins.R.Command


TRUnixStart.R_Slave Field

Summary

Represents field R_Slave.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 R_Quiet,
 R_Slave,
 R_Interactive,
 R_Verbose,
 LoadSiteFile,
 LoadInitFile,
 DebugInitFile : Bool;

Field Value

Type: Bool

See Also

Reference

  • TRUnixStart
  • BI.Plugins.R.Command


TRUnixStart.R_Verbose Field

Summary

Represents field R_Verbose.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 R_Quiet,
 R_Slave,
 R_Interactive,
 R_Verbose,
 LoadSiteFile,
 LoadInitFile,
 DebugInitFile : Bool;

Field Value

Type: Bool

See Also

Reference

  • TRUnixStart
  • BI.Plugins.R.Command


TRUnixStart.SaveAction Field

Summary

Represents field SaveAction.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 SaveAction:TStartupAction;

Field Value

Type: TStartupAction

See Also

Reference

  • TRUnixStart
  • BI.Plugins.R.Command


TRUnixStart.vsize Field

Summary

Represents field vsize.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
public
 vsize,
 nsize,
 max_vsize,
 max_nsize,
 ppsize: UInt32;

Field Value

Type: UInt32

See Also

Reference

  • TRUnixStart
  • BI.Plugins.R.Command


BI.Plugins.R.Command Enumerations

Enumerations
Name | Description
TStartupAction | Represents type TStartupAction.
TUiMode | Represents type TUiMode.
Top


TStartupAction Enumeration

Summary

Represents type TStartupAction.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
type
 TStartupAction=(NoRestore,Restore,Default,SaveDefault,NoSave,Save,Ask,Suicide);

The TStartupAction type exposes the following members.

Members
Show:
Name | Description
Ask | Represents constant Ask.
Default | Represents constant Default.
NoRestore | Represents constant NoRestore.
NoSave | Represents constant NoSave.
Restore | Represents constant Restore.
Save | Represents constant Save.
SaveDefault | Represents constant SaveDefault.
Suicide | Represents constant Suicide.
Top
See Also

Reference

  • BI.Plugins.R.Command


TUiMode Enumeration

Summary

Represents type TUiMode.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
type
 TUiMode=(RGui,RTerminal,LinkDll);

The TUiMode type exposes the following members.

Members
Show:
Name | Description
LinkDll | Represents constant LinkDll.
RGui | Represents constant RGui.
RTerminal | Represents constant RTerminal.
Top
See Also

Reference

  • BI.Plugins.R.Command


BI.Plugins.R.Command Delegates

Delegates
Name | Description
blah1 | Represents type blah1.
blah2 | Represents type blah2.
blah3 | Represents type blah3.
blah4 | Represents type blah4.
blah5 | Represents type blah5.
blah6 | Represents type blah6.
blah7 | Represents type blah7.
TR_DefParams | Represents type TR_DefParams.
TR_getDLLVersion | Represents type TR_getDLLVersion.
TR_SetParams | Represents type TR_SetParams.
TR_setStartTime | Represents type TR_setStartTime.
TR_tryEval | Represents type TR_tryEval.
Top


blah1 Delegate

Summary

Represents type blah1.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
type
 blah1=function(const A,B:PAnsiChar; C,D:Integer):Integer; cdecl;
See Also

Reference

  • BI.Plugins.R.Command


blah2 Delegate

Summary

Represents type blah2.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
type
 blah2=procedure(const A:PAnsiChar; B:Integer); cdecl;
See Also

Reference

  • BI.Plugins.R.Command


blah3 Delegate

Summary

Represents type blah3.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
type
 blah3=procedure; cdecl;
See Also

Reference

  • BI.Plugins.R.Command


blah4 Delegate

Summary

Represents type blah4.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
type
 blah4=procedure(const A:PAnsiChar); cdecl;
See Also

Reference

  • BI.Plugins.R.Command


blah5 Delegate

Summary

Represents type blah5.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
type
 blah5=function(const A:PAnsiChar):Integer; cdecl;
See Also

Reference

  • BI.Plugins.R.Command


blah6 Delegate

Summary

Represents type blah6.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
type
 blah6=procedure(A:Integer); cdecl;
See Also

Reference

  • BI.Plugins.R.Command


blah7 Delegate

Summary

Represents type blah7.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
type
 blah7=procedure(const A:PAnsiChar; B,C:Integer); cdecl;
See Also

Reference

  • BI.Plugins.R.Command


TR_DefParams Delegate

Summary

Represents type TR_DefParams.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
type
 TR_DefParams=procedure(var P:TRStart); cdecl;
See Also

Reference

  • BI.Plugins.R.Command


TR_getDLLVersion Delegate

Summary

Represents type TR_getDLLVersion.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
type
 TR_getDLLVersion=function: IntPtr; cdecl;
See Also

Reference

  • BI.Plugins.R.Command


TR_SetParams Delegate

Summary

Represents type TR_SetParams.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
type
 TR_SetParams=procedure(var Start:TRStart); cdecl;
See Also

Reference

  • BI.Plugins.R.Command


TR_setStartTime Delegate

Summary

Represents type TR_setStartTime.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
type
 TR_setStartTime=procedure; cdecl;
See Also

Reference

  • BI.Plugins.R.Command


TR_tryEval Delegate

Summary

Represents type TR_tryEval.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
type
 TR_tryEval=function(Statement,Environment:IntPtr; var Error:Bool):IntPtr; cdecl;
See Also

Reference

  • BI.Plugins.R.Command


BI.Plugins.R.Command Types

Types
Name | Description
Bool | Represents an alias of the LongBool type.
Top


Bool Type

Summary

Represents an alias of the LongBool type.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
type
 Bool=LongBool;
See Also

Reference

  • BI.Plugins.R.Command


BI.Plugins.R.Command Routines

Routines
Name | Description
AttributeNames(String,Integer) | Represents method AttributeNames(String,Integer).
RBusy(Integer) | Represents method RBusy(Integer).
RCallback | Represents method RCallback.
RReadConsole(PAnsiChar,PAnsiChar,Integer,Integer) | Represents method RReadConsole(PAnsiChar,PAnsiChar,Integer,Integer).
RShowMessage(PAnsiChar) | Represents method RShowMessage(PAnsiChar).
RWriteConsole(PAnsiChar,Integer) | Represents method RWriteConsole(PAnsiChar,Integer).
RWriteConsoleEx(PAnsiChar,Integer,Integer) | Represents method RWriteConsoleEx(PAnsiChar,Integer,Integer).
RYesNoCancel(PAnsiChar) | Represents method RYesNoCancel(PAnsiChar).
StartRAndWait(String,String,LongWord) | Represents method StartRAndWait(String,String,LongWord).
Top


AttributeNames(String,Integer) Method

Summary

Represents method AttributeNames(String,Integer).

Namespace: BI.Plugins.R.Command
Syntax
Delphi
function AttributeNames(const Prefix:String; const Max:Integer):String;

Parameters

Prefix
Type: String

Max
Type: Integer

Return Value

Type: String

See Also

Reference

  • BI.Plugins.R.Command


RBusy(Integer) Method

Summary

Represents method RBusy(Integer).

Namespace: BI.Plugins.R.Command
Syntax
Delphi
procedure RBusy(A:Integer); cdecl;

Parameters

A
Type: Integer

See Also

Reference

  • BI.Plugins.R.Command


RCallback Method

Summary

Represents method RCallback.

Namespace: BI.Plugins.R.Command
Syntax
Delphi
procedure RCallback; cdecl;
See Also

Reference

  • BI.Plugins.R.Command


RReadConsole(PAnsiChar,PAnsiChar,Integer,Integer) Method

Summary

Represents method RReadConsole(PAnsiChar,PAnsiChar,Integer,Integer).

Namespace: BI.Plugins.R.Command
Syntax
Delphi
 function RReadConsole(const A,B:PAnsiChar; C,D:Integer):Integer; cdecl;

Parameters

A
Type: PAnsiChar

B
Type: PAnsiChar

C
Type: Integer

D
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • BI.Plugins.R.Command


RShowMessage(PAnsiChar) Method

Summary

Represents method RShowMessage(PAnsiChar).

Namespace: BI.Plugins.R.Command
Syntax
Delphi
procedure RShowMessage(const A:PAnsiChar); cdecl;

Parameters

A
Type: PAnsiChar

See Also

Reference

  • BI.Plugins.R.Command


RWriteConsole(PAnsiChar,Integer) Method

Summary

Represents method RWriteConsole(PAnsiChar,Integer).

Namespace: BI.Plugins.R.Command
Syntax
Delphi
procedure RWriteConsole(const A:PAnsiChar; B:Integer); cdecl;

Parameters

A
Type: PAnsiChar

B
Type: Integer

See Also

Reference

  • BI.Plugins.R.Command


RWriteConsoleEx(PAnsiChar,Integer,Integer) Method

Summary

Represents method RWriteConsoleEx(PAnsiChar,Integer,Integer).

Namespace: BI.Plugins.R.Command
Syntax
Delphi
procedure RWriteConsoleEx(const A:PAnsiChar; B,C:Integer); cdecl;

Parameters

A
Type: PAnsiChar

B
Type: Integer

C
Type: Integer

See Also

Reference

  • BI.Plugins.R.Command


RYesNoCancel(PAnsiChar) Method

Summary

Represents method RYesNoCancel(PAnsiChar).

Namespace: BI.Plugins.R.Command
Syntax
Delphi
function RYesNoCancel(const A:PAnsiChar):Integer; cdecl;

Parameters

A
Type: PAnsiChar

Return Value

Type: Integer

See Also

Reference

  • BI.Plugins.R.Command


StartRAndWait(String,String,LongWord) Method

Summary

Represents method StartRAndWait(String,String,LongWord).

Namespace: BI.Plugins.R.Command
Syntax
Delphi
function StartRAndWait(const RPath,CommandLine:String; out ExitCode:LongWord):Boolean;

Parameters

RPath
Type: String

CommandLine
Type: String

ExitCode
Type: LongWord

Return Value

Type: Boolean

See Also

Reference

  • BI.Plugins.R.Command


BI.Plugins.R.opaR Namespace

Summary

Represents namespace BI.Plugins.R.opaR.

Classes
Name | Description
TBooleanVector | Represents type TBooleanVector.
TDataAccess | Represents type TDataAccess.
TFloatVector | Represents type TFloatVector.
TInt64Vector | Represents type TInt64Vector.
TopaR | Represents type TopaR.
TStringsDevice | Represents type TStringsDevice.
Top
Variables
Name | Description
R | Represents variable R.
Top


BI.Plugins.R.opaR Classes

Classes
Name | Description
TBooleanVector | Represents type TBooleanVector.
TDataAccess | Represents type TDataAccess.
TFloatVector | Represents type TFloatVector.
TInt64Vector | Represents type TInt64Vector.
TopaR | Represents type TopaR.
TStringsDevice | Represents type TStringsDevice.
Top


TBooleanVector Class

Summary

Represents type TBooleanVector.

Namespace: BI.Plugins.R.opaR
Inheritance Hierarchy
TLogicalVector
BI.Plugins.R.opaR.TBooleanVector
Syntax
Delphi
type
 TBooleanVector=class(TLogicalVector)
 end;

The TBooleanVector type exposes the following members.

Constructors
Show:
Name | Description
Create(IREngine,TArray) | Overloaded. Initializes a new instance of the TBooleanVector class.
Top
See Also

Reference

  • BI.Plugins.R.opaR


TBooleanVector Constructors

Constructors
Name | Description
Create(IREngine,TArray) | Overloaded. Initializes a new instance of the TBooleanVector class.
Top


TBooleanVector.Create(IREngine,TArray) Constructor

Summary

Initializes a new instance of the TBooleanVector class.

Namespace: BI.Plugins.R.opaR
Syntax
Delphi
public
 Constructor Create(const engine: IREngine; const vector: TArray<Boolean>); overload;

Parameters

engine
Type: IREngine

vector
Type: TArray<Boolean>

See Also

Reference

  • TBooleanVector
  • BI.Plugins.R.opaR


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.Plugins.R.opaR
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Plugins.R.opaR.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.Plugins.R.opaR


TFloatVector Class

Summary

Represents type TFloatVector.

Namespace: BI.Plugins.R.opaR
Inheritance Hierarchy
TNumericVector
BI.Plugins.R.opaR.TFloatVector
Syntax
Delphi
type
 TFloatVector=class(TNumericVector)
 end;

The TFloatVector type exposes the following members.

Constructors
Show:
Name | Description
Create(IREngine,TArray) | Overloaded. Initializes a new instance of the TFloatVector class.
Create(IREngine,TArray) | Overloaded. Initializes a new instance of the TFloatVector class.
Top
See Also

Reference

  • BI.Plugins.R.opaR


TFloatVector Constructors

Constructors
Name | Description
Create(IREngine,TArray) | Overloaded. Initializes a new instance of the TFloatVector class.
Create(IREngine,TArray) | Overloaded. Initializes a new instance of the TFloatVector class.
Top


TFloatVector.Create(IREngine,TArray) Constructor

Summary

Initializes a new instance of the TFloatVector class.

Namespace: BI.Plugins.R.opaR
Syntax
Delphi
public
 Constructor Create(const engine: IREngine; const vector: TArray<Extended>); overload;

Parameters

engine
Type: IREngine

vector
Type: TArray<Extended>

See Also

Reference

  • TFloatVector
  • BI.Plugins.R.opaR


TInt64Vector Class

Summary

Represents type TInt64Vector.

Namespace: BI.Plugins.R.opaR
Inheritance Hierarchy
TIntegerVector
BI.Plugins.R.opaR.TInt64Vector
Syntax
Delphi
type
 TInt64Vector=class(TIntegerVector)
 end;

The TInt64Vector type exposes the following members.

Constructors
Show:
Name | Description
Create(IREngine,TArray) | Initializes a new instance of the TInt64Vector class.
Top
See Also

Reference

  • BI.Plugins.R.opaR


TInt64Vector Constructors

Constructors
Name | Description
Create(IREngine,TArray) | Initializes a new instance of the TInt64Vector class.
Top


TInt64Vector.Create(IREngine,TArray) Constructor

Summary

Initializes a new instance of the TInt64Vector class.

Namespace: BI.Plugins.R.opaR
Syntax
Delphi
public
 Constructor Create(const engine: IREngine; const vector: TArray<Int64>);

Parameters

engine
Type: IREngine

vector
Type: TArray<Int64>

See Also

Reference

  • TInt64Vector
  • BI.Plugins.R.opaR


TopaR Class

Summary

Represents type TopaR.

Namespace: BI.Plugins.R.opaR
Inheritance Hierarchy
TObject
BI.Algorithm.Model.TBIPlugin
BI.Plugins.R.TBIREngine
BI.Plugins.R.opaR.TopaR
Syntax
Delphi
type
 TopaR=class(TBIREngine)
 end;

The TopaR type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TopaR class.
Top
Methods
Show:
Name | Description
AddVariable(String,TNativeIntArray,TDataArray,Boolean) | Represents method AddVariable(String,TNativeIntArray,TDataArray,Boolean). (Overrides TBIREngine.AddVariable(String,TNativeIntArray,TDataArray,Boolean).)
Finish | Represents method Finish. (Overrides TBIREngine.Finish.)
GetVariable(String,TDataItem) | Represents method GetVariable(String,TDataItem). (Overrides TBIREngine.GetVariable(String,TDataItem).)
LoadPackage(String) | Represents method LoadPackage(String). (Overrides TBIREngine.LoadPackage(String).)
ParseOutput(TDataItem) | Represents method ParseOutput(TDataItem). (Overrides TBIREngine.ParseOutput(TDataItem).)
ParseRawMap(TDataItem,TDataItem) | Represents method ParseRawMap(TDataItem,TDataItem). (Overrides TBIREngine.ParseRawMap(TDataItem,TDataItem).)
Statement(String) | Represents method Statement(String). (Overrides TBIREngine.Statement(String).)
Version | Represents method Version. (Overrides TBIREngine.Version.)
Top
See Also

Reference

  • BI.Plugins.R.opaR


TopaR Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TopaR class.
Top


TopaR.Create Constructor

Summary

Initializes a new instance of the TopaR class.

Namespace: BI.Plugins.R.opaR
Syntax
Delphi
public
 Constructor Create;
See Also

Reference

  • TopaR
  • BI.Plugins.R.opaR


TopaR Methods

Methods
Name | Description
AddVariable(String,TNativeIntArray,TDataArray,Boolean) | Represents method AddVariable(String,TNativeIntArray,TDataArray,Boolean). (Overrides TBIREngine.AddVariable(String,TNativeIntArray,TDataArray,Boolean).)
Finish | Represents method Finish. (Overrides TBIREngine.Finish.)
GetVariable(String,TDataItem) | Represents method GetVariable(String,TDataItem). (Overrides TBIREngine.GetVariable(String,TDataItem).)
LoadPackage(String) | Represents method LoadPackage(String). (Overrides TBIREngine.LoadPackage(String).)
ParseOutput(TDataItem) | Represents method ParseOutput(TDataItem). (Overrides TBIREngine.ParseOutput(TDataItem).)
ParseRawMap(TDataItem,TDataItem) | Represents method ParseRawMap(TDataItem,TDataItem). (Overrides TBIREngine.ParseRawMap(TDataItem,TDataItem).)
Statement(String) | Represents method Statement(String). (Overrides TBIREngine.Statement(String).)
Version | Represents method Version. (Overrides TBIREngine.Version.)
Top


TopaR.AddVariable(String,TNativeIntArray,TDataArray,Boolean) Method

Summary

Represents method AddVariable(String,TNativeIntArray,TDataArray,Boolean).

Namespace: BI.Plugins.R.opaR
Syntax
Delphi
public
 procedure AddVariable(const AName:String; const Index:TNativeIntArray;
 const AData:TDataArray; const UseMissing:Boolean=True); override;

Parameters

AName
Type: String

Index
Type: System.Void

AData
Type: TDataArray

UseMissing
Type: Boolean

Overrides

TBIREngine.AddVariable(String,TNativeIntArray,TDataArray,Boolean)
See Also

Reference

  • TopaR
  • BI.Plugins.R.opaR


TopaR.Finish Method

Summary

Represents method Finish.

Namespace: BI.Plugins.R.opaR
Syntax
Delphi
protected
 function Finish:Boolean; override;

Return Value

Type: Boolean

Overrides

TBIREngine.Finish
See Also

Reference

  • TopaR
  • BI.Plugins.R.opaR


TopaR.GetVariable(String,TDataItem) Method

Summary

Represents method GetVariable(String,TDataItem).

Namespace: BI.Plugins.R.opaR
Syntax
Delphi
public
 procedure GetVariable(const AName:String; const AData:TDataItem); override;

Parameters

AName
Type: String

AData
Type: TDataItem

Overrides

TBIREngine.GetVariable(String,TDataItem)
See Also

Reference

  • TopaR
  • BI.Plugins.R.opaR


TopaR.LoadPackage(String) Method

Summary

Represents method LoadPackage(String).

Namespace: BI.Plugins.R.opaR
Syntax
Delphi
public
 procedure LoadPackage(const APackage:String); override;

Parameters

APackage
Type: String

Overrides

TBIREngine.LoadPackage(String)
See Also

Reference

  • TopaR
  • BI.Plugins.R.opaR


TopaR.ParseOutput(TDataItem) Method

Summary

Represents method ParseOutput(TDataItem).

Namespace: BI.Plugins.R.opaR
Syntax
Delphi
public
 procedure ParseOutput(const ADest:TDataItem); override;

Parameters

ADest
Type: TDataItem

Overrides

TBIREngine.ParseOutput(TDataItem)
See Also

Reference

  • TopaR
  • BI.Plugins.R.opaR


TopaR.ParseRawMap(TDataItem,TDataItem) Method

Summary

Represents method ParseRawMap(TDataItem,TDataItem).

Namespace: BI.Plugins.R.opaR
Syntax
Delphi
public
 procedure ParseRawMap(const AMap,ADest:TDataItem); override;

Parameters

AMap
Type: TDataItem

ADest
Type: TDataItem

Overrides

TBIREngine.ParseRawMap(TDataItem,TDataItem)
See Also

Reference

  • TopaR
  • BI.Plugins.R.opaR


TopaR.Statement(String) Method

Summary

Represents method Statement(String).

Namespace: BI.Plugins.R.opaR
Syntax
Delphi
public
 procedure Statement(const AStatement:String); override;

Parameters

AStatement
Type: String

Overrides

TBIREngine.Statement(String)
See Also

Reference

  • TopaR
  • BI.Plugins.R.opaR


TopaR.Version Method

Summary

Represents method Version.

Namespace: BI.Plugins.R.opaR
Syntax
Delphi
public
 function Version:String; override;

Return Value

Type: String

Overrides

TBIREngine.Version
See Also

Reference

  • TopaR
  • BI.Plugins.R.opaR


TStringsDevice Class

Summary

Represents type TStringsDevice.

Namespace: BI.Plugins.R.opaR
Inheritance Hierarchy
TNullCharacterDevice
BI.Plugins.R.opaR.TStringsDevice
Syntax
Delphi
type
 TStringsDevice = class(TNullCharacterDevice, ICharacterDevice)
 end;

The TStringsDevice type exposes the following members.

Methods
Show:
Name | Description
WriteConsole(string,integer,TConsoleOutputType) | Represents method WriteConsole(string,integer,TConsoleOutputType).
Top
See Also

Reference

  • BI.Plugins.R.opaR


TStringsDevice Methods

Methods
Name | Description
WriteConsole(string,integer,TConsoleOutputType) | Represents method WriteConsole(string,integer,TConsoleOutputType).
Top


TStringsDevice.WriteConsole(string,integer,TConsoleOutputType) Method

Summary

Represents method WriteConsole(string,integer,TConsoleOutputType).

Namespace: BI.Plugins.R.opaR
Syntax
Delphi
public
 procedure WriteConsole(output: string; length: integer; outputType: TConsoleOutputType);

Parameters

output
Type: string

length
Type: integer

outputType
Type: TConsoleOutputType

See Also

Reference

  • TStringsDevice
  • BI.Plugins.R.opaR


BI.Plugins.R.opaR Variables

Variables
Name | Description
R | Represents variable R.
Top


R Variable

Summary

Represents variable R.

Namespace: BI.Plugins.R.opaR
Syntax
Delphi
R : IREngine = nil;

Value

Type: IREngine

See Also

Reference

  • BI.Plugins.R.opaR


BI.Query Namespace

Summary

Represents namespace BI.Query.

Classes
Name | Description
TBIFilterAccess | Represents type TBIFilterAccess.
TBIQuery | Represents type TBIQuery.
TCollectionAccess | Represents type TCollectionAccess.
TDataAccess | Represents type TDataAccess.
TDataCursorAccess | Represents type TDataCursorAccess.
TDataProviderAccess | Represents type TDataProviderAccess.
TDataSelectAccess | Represents type TDataSelectAccess.
TGroupByAccess | Represents type TGroupByAccess.
TMeasureAccess | Represents type TMeasureAccess.
TQueryCollection | Represents type TQueryCollection.
TQueryDimension | Represents type TQueryDimension.
TQueryDimensions | Represents type TQueryDimensions.
TQueryItem | Represents type TQueryItem.
TQueryMeasure | Represents type TQueryMeasure.
TQueryMeasures | Represents type TQueryMeasures.
TQuerySort | Represents type TQuerySort.
TQuerySortItem | Represents type TQuerySortItem.
TRemoveMissingAccess | Represents type TRemoveMissingAccess.
TSummaryAccess | Represents type TSummaryAccess.
Top
Enumerations
Name | Description
TDimensionStyle | Represents type TDimensionStyle.
TQueryStyle | Represents type TQueryStyle.
Top
Routines
Name | Description
ErrorDataNil(String) | Represents method ErrorDataNil(String).
StyleOfBy(TGroupBy) | Represents method StyleOfBy(TGroupBy).
Top


BI.Query Classes

Classes
Name | Description
TBIFilterAccess | Represents type TBIFilterAccess.
TBIQuery | Represents type TBIQuery.
TCollectionAccess | Represents type TCollectionAccess.
TDataAccess | Represents type TDataAccess.
TDataCursorAccess | Represents type TDataCursorAccess.
TDataProviderAccess | Represents type TDataProviderAccess.
TDataSelectAccess | Represents type TDataSelectAccess.
TGroupByAccess | Represents type TGroupByAccess.
TMeasureAccess | Represents type TMeasureAccess.
TQueryCollection | Represents type TQueryCollection.
TQueryDimension | Represents type TQueryDimension.
TQueryDimensions | Represents type TQueryDimensions.
TQueryItem | Represents type TQueryItem.
TQueryMeasure | Represents type TQueryMeasure.
TQueryMeasures | Represents type TQueryMeasures.
TQuerySort | Represents type TQuerySort.
TQuerySortItem | Represents type TQuerySortItem.
TRemoveMissingAccess | Represents type TRemoveMissingAccess.
TSummaryAccess | Represents type TSummaryAccess.
Top


TBIFilterAccess Class

Summary

Represents type TBIFilterAccess.

Namespace: BI.Query
Inheritance Hierarchy
TPersistent
BI.Expression.Filter.TBIFilter
BI.Query.TBIFilterAccess
Syntax
Delphi
type
 TBIFilterAccess=class(TBIFilter);
See Also

Reference

  • BI.Query


TBIQuery Class

Summary

Represents type TBIQuery.

Namespace: BI.Query
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Persist.TBaseDataImporter
BI.Query.TBIQuery
BI.SQL.TBIQueryAccess
BI.Workflow.TBIQueryAccess
VCLBI.Editor.Hops.TBIQueryAccess
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64 or pidOSX32
 or pidiOSSimulator or pidiOSDevice
 or pidAndroid
 or pidiOSDevice64
 )]
 TBIQuery=class(TBaseDataImporter)
 end;

The TBIQuery type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIQuery class.
Destroy | Represents the destructor of the TBIQuery class. (Overrides TBaseDataImporter.Destroy.)
From(TComponent,TDataSelect) | Overloaded. Initializes a new instance of the TBIQuery class.
From(TComponent,TSummary) | Overloaded. Initializes a new instance of the TBIQuery class.
Top
Properties
Show:
Name | Description
Dimensions | Represents property Dimensions.
Distinct | Represents property Distinct.
Filter | Represents property Filter.
Main | Represents property Main.
MaxRows | Represents property MaxRows.
Measures | Represents property Measures.
RemoveMissing | Represents property RemoveMissing.
SortBy | Represents property SortBy.
StartRow | Represents property StartRow.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TDataProvider.Assign(TPersistent).)
Calculate | Represents method Calculate.
CanBeMeasure(TDataItem) | Represents method CanBeMeasure(TDataItem).
Changed | Represents method Changed. (Overrides TBaseDataImporter.Changed.)
Clear | Represents method Clear.
CreateProvider | Represents method CreateProvider.
GetItems(TDataItem) | Represents method GetItems(TDataItem). (Overrides TDataProvider.GetItems(TDataItem).)
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Loaded | Represents method Loaded.
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
Parse(TDataItem,String,TBIErrorProc) | Represents method Parse(TDataItem,String,TBIErrorProc).
Refresh | Represents method Refresh.
ToString | Represents method ToString.
Top
Events
Show:
Name | Description
OnError | Represents property OnError.
Top
Fields
Show:
Name | Description
Style | Represents field Style.
Top
See Also

Reference

  • BI.Query


TBIQuery Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBIQuery class.
Destroy | Represents the destructor of the TBIQuery class. (Overrides TBaseDataImporter.Destroy.)
From(TComponent,TDataSelect) | Overloaded. Initializes a new instance of the TBIQuery class.
From(TComponent,TSummary) | Overloaded. Initializes a new instance of the TBIQuery class.
Top


TBIQuery.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIQuery class.

Namespace: BI.Query
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.Destroy Destructor

Summary

Represents the destructor of the TBIQuery class.

Namespace: BI.Query
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TBaseDataImporter.Destroy
See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.From(TComponent,TDataSelect) Constructor

Summary

Initializes a new instance of the TBIQuery class.

Namespace: BI.Query
Syntax
Delphi
public
 Constructor From(const AOwner:TComponent; const ASelect:TDataSelect); overload;

Parameters

AOwner
Type: TComponent

ASelect
Type: TDataSelect

See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.From(TComponent,TSummary) Constructor

Summary

Initializes a new instance of the TBIQuery class.

Namespace: BI.Query
Syntax
Delphi
public
 Constructor From(const AOwner:TComponent; const ASummary:TSummary); overload;

Parameters

AOwner
Type: TComponent

ASummary
Type: TSummary

See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery Properties

Properties
Name | Description
Dimensions | Represents property Dimensions.
Distinct | Represents property Distinct.
Filter | Represents property Filter.
Main | Represents property Main.
MaxRows | Represents property MaxRows.
Measures | Represents property Measures.
RemoveMissing | Represents property RemoveMissing.
SortBy | Represents property SortBy.
StartRow | Represents property StartRow.
Top


TBIQuery.Dimensions Property

Summary

Represents property Dimensions.

Namespace: BI.Query
Syntax
Delphi
published
 property Dimensions:TQueryDimensions read FDimensions write SetDimensions stored IsDimensionsStored;

Property Value

Type: TQueryDimensions

See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.Distinct Property

Summary

Represents property Distinct.

Namespace: BI.Query
Syntax
Delphi
published
 property Distinct:Boolean read FDistinct write SetDistinct default False;

Property Value

Type: Boolean

See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.Filter Property

Summary

Represents property Filter.

Namespace: BI.Query
Syntax
Delphi
published
 property Filter:TBIFilter read FFilter write SetFilter;

Property Value

Type: TBIFilter

See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.Main Property

Summary

Represents property Main.

Namespace: BI.Query
Syntax
Delphi
public
 property Main:TDataItem read IMain;

Property Value

Type: TDataItem

See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.MaxRows Property

Summary

Represents property MaxRows.

Namespace: BI.Query
Syntax
Delphi
published
 property MaxRows:Int64 read FMax write SetMax default 0;

Property Value

Type: Int64

See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.Measures Property

Summary

Represents property Measures.

Namespace: BI.Query
Syntax
Delphi
published
 property Measures:TQueryMeasures read FMeasures write SetMeasures stored IsMeasuresStored;

Property Value

Type: TQueryMeasures

See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.RemoveMissing Property

Summary

Represents property RemoveMissing.

Namespace: BI.Query
Syntax
Delphi
published
 property RemoveMissing:TRemoveMissing read FRemoveMissing write SetRemoveMissing;

Property Value

Type: TRemoveMissing

See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.SortBy Property

Summary

Represents property SortBy.

Namespace: BI.Query
Syntax
Delphi
published
 property SortBy:TQuerySort read FSort write SetSort stored IsSortStored;

Property Value

Type: TQuerySort

See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.StartRow Property

Summary

Represents property StartRow.

Namespace: BI.Query
Syntax
Delphi
published
 property StartRow:Int64 read FStart write SetStartRow default 0;

Property Value

Type: Int64

See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TDataProvider.Assign(TPersistent).)
Calculate | Represents method Calculate.
CanBeMeasure(TDataItem) | Represents method CanBeMeasure(TDataItem).
Changed | Represents method Changed. (Overrides TBaseDataImporter.Changed.)
Clear | Represents method Clear.
CreateProvider | Represents method CreateProvider.
GetItems(TDataItem) | Represents method GetItems(TDataItem). (Overrides TDataProvider.GetItems(TDataItem).)
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Loaded | Represents method Loaded.
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
Parse(TDataItem,String,TBIErrorProc) | Represents method Parse(TDataItem,String,TBIErrorProc).
Refresh | Represents method Refresh.
ToString | Represents method ToString.
Top


TBIQuery.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Query
Syntax
Delphi
public
 procedure Assign(Source: TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TDataProvider.Assign(TPersistent)
See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.Calculate Method

Summary

Represents method Calculate.

Namespace: BI.Query
Syntax
Delphi
public
 function Calculate:TDataItem;

Return Value

Type: TDataItem

See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.CanBeMeasure(TDataItem) Method

Summary

Represents method CanBeMeasure(TDataItem).

Namespace: BI.Query
Syntax
Delphi
public
 class function CanBeMeasure(const AData:TDataItem):Boolean; static;

Parameters

AData
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.Changed Method

Summary

Represents method Changed.

Namespace: BI.Query
Syntax
Delphi
protected
 procedure Changed; override;

Overrides

TBaseDataImporter.Changed
See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.Clear Method

Summary

Represents method Clear.

Namespace: BI.Query
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.CreateProvider Method

Summary

Represents method CreateProvider.

Namespace: BI.Query
Syntax
Delphi
protected
 function CreateProvider:TDataProvider;

Return Value

Type: TDataProvider

See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.GetItems(TDataItem) Method

Summary

Represents method GetItems(TDataItem).

Namespace: BI.Query
Syntax
Delphi
protected
 procedure GetItems(const AData: TDataItem); override;

Parameters

AData
Type: TDataItem

Overrides

TDataProvider.GetItems(TDataItem)
See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Query
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.Loaded Method

Summary

Represents method Loaded.

Namespace: BI.Query
Syntax
Delphi
protected
 procedure Loaded; override;
See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: BI.Query
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent;
 Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.Parse(TDataItem,String,TBIErrorProc) Method

Summary

Represents method Parse(TDataItem,String,TBIErrorProc).

Namespace: BI.Query
Syntax
Delphi
public
 procedure Parse(const AData:TDataItem; const SQL:String; const AError:TBIErrorProc=nil);

Parameters

AData
Type: TDataItem

SQL
Type: String

AError
Type: TBIErrorProc

See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.Refresh Method

Summary

Represents method Refresh.

Namespace: BI.Query
Syntax
Delphi
public
 procedure Refresh;
See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery.ToString Method

Summary

Represents method ToString.

Namespace: BI.Query
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery Events

Events
Name | Description
OnError | Represents property OnError.
Top


TBIQuery.OnError Event

Summary

Represents property OnError.

Namespace: BI.Query
Syntax
Delphi
public
 property OnError:TErrorProc read FOnError write FOnError;

Value

Type: TErrorProc

See Also

Reference

  • TBIQuery
  • BI.Query


TBIQuery Fields

Fields
Name | Description
Style | Represents field Style.
Top


TBIQuery.Style Field

Summary

Represents field Style.

Namespace: BI.Query
Syntax
Delphi
public
 Style : TQueryStyle;

Field Value

Type: TQueryStyle

See Also

Reference

  • TBIQuery
  • BI.Query


TCollectionAccess Class

Summary

Represents type TCollectionAccess.

Namespace: BI.Query
Inheritance Hierarchy
TCollection
BI.Query.TCollectionAccess
Syntax
Delphi
type
 TCollectionAccess=class(TCollection);
See Also

Reference

  • BI.Query


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.Query
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Query.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.Query


TDataCursorAccess Class

Summary

Represents type TDataCursorAccess.

Namespace: BI.Query
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.DataSource.TDataCursor
BI.Query.TDataCursorAccess
Syntax
Delphi
type
 TDataCursorAccess=class(TDataCursor);
See Also

Reference

  • BI.Query


TDataProviderAccess Class

Summary

Represents type TDataProviderAccess.

Namespace: BI.Query
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Query.TDataProviderAccess
Syntax
Delphi
type
 TDataProviderAccess=class(TDataProvider);
See Also

Reference

  • BI.Query


TDataSelectAccess Class

Summary

Represents type TDataSelectAccess.

Namespace: BI.Query
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.DataSource.TDataCursor
BI.DataSource.TDataSelect
BI.Query.TDataSelectAccess
Syntax
Delphi
type
 TDataSelectAccess=class(TDataSelect);
See Also

Reference

  • BI.Query


TGroupByAccess Class

Summary

Represents type TGroupByAccess.

Namespace: BI.Query
Inheritance Hierarchy
TPersistent
BI.Summary.TBaseSummaryPersistent
BI.Summary.TSummaryItem
BI.Summary.TGroupBy
BI.Query.TGroupByAccess
Syntax
Delphi
type
 TGroupByAccess=class(TGroupBy);
See Also

Reference

  • BI.Query


TMeasureAccess Class

Summary

Represents type TMeasureAccess.

Namespace: BI.Query
Inheritance Hierarchy
TPersistent
BI.Summary.TBaseSummaryPersistent
BI.Summary.TSummaryItem
BI.Summary.TMeasure
BI.Query.TMeasureAccess
Syntax
Delphi
type
 TMeasureAccess=class(TMeasure);
See Also

Reference

  • BI.Query


TQueryCollection Class

Summary

Represents type TQueryCollection.

Namespace: BI.Query
Inheritance Hierarchy
TOwnedCollection
BI.Query.TQueryCollection
BI.Query.TQueryDimensions
BI.Query.TQueryMeasures
BI.Query.TQuerySort
Syntax
Delphi
type
 TQueryCollection=class(TOwnedCollection)
 end;

The TQueryCollection type exposes the following members.

Properties
Show:
Name | Description
Query | Represents property Query.
Top
Methods
Show:
Name | Description
Notify(TCollectionItem,TCollectionNotification) | Represents method Notify(TCollectionItem,TCollectionNotification).
Update(TCollectionItem) | Represents method Update(TCollectionItem).
Top
See Also

Reference

  • BI.Query


TQueryCollection Properties

Properties
Name | Description
Query | Represents property Query.
Top


TQueryCollection.Query Property

Summary

Represents property Query.

Namespace: BI.Query
Syntax
Delphi
public
 property Query:TBIQuery read GetQuery;

Property Value

Type: TBIQuery

See Also

Reference

  • TQueryCollection
  • BI.Query


TQueryCollection Methods

Methods
Name | Description
Notify(TCollectionItem,TCollectionNotification) | Represents method Notify(TCollectionItem,TCollectionNotification).
Update(TCollectionItem) | Represents method Update(TCollectionItem).
Top


TQueryCollection.Notify(TCollectionItem,TCollectionNotification) Method

Summary

Represents method Notify(TCollectionItem,TCollectionNotification).

Namespace: BI.Query
Syntax
Delphi
protected
 procedure Notify(Item: TCollectionItem; Action: TCollectionNotification); override;

Parameters

Item
Type: TCollectionItem

Action
Type: TCollectionNotification

See Also

Reference

  • TQueryCollection
  • BI.Query


TQueryCollection.Update(TCollectionItem) Method

Summary

Represents method Update(TCollectionItem).

Namespace: BI.Query
Syntax
Delphi
protected
 procedure Update(Item: TCollectionItem); override;

Parameters

Item
Type: TCollectionItem

See Also

Reference

  • TQueryCollection
  • BI.Query


TQueryDimension Class

Summary

Represents type TQueryDimension.

Namespace: BI.Query
Inheritance Hierarchy
TCollectionItem
BI.CollectionItem.TDataCollectionItem
BI.Query.TQueryItem
BI.Query.TQueryDimension
Syntax
Delphi
type
 TQueryDimension=class(TQueryItem)
 end;

The TQueryDimension type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TQueryDimension class. (Overrides TQueryItem.Create(TCollection).)
Destroy | Represents the destructor of the TQueryDimension class. (Overrides TDataCollectionItem.Destroy.)
Top
Properties
Show:
Name | Description
DatePart | Represents property DatePart.
Expression | Represents property Expression.
GroupBy | Represents property GroupBy.
Histogram | Represents property Histogram.
Style | Represents property Style.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TQueryItem.Assign(TPersistent).)
Layout | Represents method Layout.
RealData | Represents method RealData.
RealStyle | Represents method RealStyle.
SetData(TDataItem) | Represents method SetData(TDataItem). (Overrides TDataCollectionItem.SetData(TDataItem).)
ToString | Represents method ToString.
Top
See Also

Reference

  • BI.Query


TQueryDimension Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TQueryDimension class. (Overrides TQueryItem.Create(TCollection).)
Destroy | Represents the destructor of the TQueryDimension class. (Overrides TDataCollectionItem.Destroy.)
Top


TQueryDimension.Create(TCollection) Constructor

Summary

Initializes a new instance of the TQueryDimension class.

Namespace: BI.Query
Syntax
Delphi
public
 Constructor Create(Collection: TCollection); override;

Parameters

Collection
Type: TCollection

Overrides

TQueryItem.Create(TCollection)
See Also

Reference

  • TQueryDimension
  • BI.Query


TQueryDimension.Destroy Destructor

Summary

Represents the destructor of the TQueryDimension class.

Namespace: BI.Query
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TDataCollectionItem.Destroy
See Also

Reference

  • TQueryDimension
  • BI.Query


TQueryDimension Properties

Properties
Name | Description
DatePart | Represents property DatePart.
Expression | Represents property Expression.
GroupBy | Represents property GroupBy.
Histogram | Represents property Histogram.
Style | Represents property Style.
Top


TQueryDimension.DatePart Property

Summary

Represents property DatePart.

Namespace: BI.Query
Syntax
Delphi
published
 property DatePart:TDateTimePart read GetDatePart write SetDatePart default TDateTimePart.None;

Property Value

Type: TDateTimePart

See Also

Reference

  • TQueryDimension
  • BI.Query


TQueryDimension.Expression Property

Summary

Represents property Expression.

Namespace: BI.Query
Syntax
Delphi
public
 property Expression:TExpression read GetExpression write SetExpression;

Property Value

Type: TExpression

See Also

Reference

  • TQueryDimension
  • BI.Query


TQueryDimension.GroupBy Property

Summary

Represents property GroupBy.

Namespace: BI.Query
Syntax
Delphi
protected
 property GroupBy:TGroupBy read FGroupBy;

Property Value

Type: TGroupBy

See Also

Reference

  • TQueryDimension
  • BI.Query


TQueryDimension.Histogram Property

Summary

Represents property Histogram.

Namespace: BI.Query
Syntax
Delphi
published
 property Histogram:THistogram read GetHistogram write SetHistogram;

Property Value

Type: THistogram

See Also

Reference

  • TQueryDimension
  • BI.Query


TQueryDimension.Style Property

Summary

Represents property Style.

Namespace: BI.Query
Syntax
Delphi
published
 property Style:TDimensionStyle read FStyle write SetStyle default TDimensionStyle.Automatic;

Property Value

Type: TDimensionStyle

See Also

Reference

  • TQueryDimension
  • BI.Query


TQueryDimension Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TQueryItem.Assign(TPersistent).)
Layout | Represents method Layout.
RealData | Represents method RealData.
RealStyle | Represents method RealStyle.
SetData(TDataItem) | Represents method SetData(TDataItem). (Overrides TDataCollectionItem.SetData(TDataItem).)
ToString | Represents method ToString.
Top


TQueryDimension.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Query
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TQueryItem.Assign(TPersistent)
See Also

Reference

  • TQueryDimension
  • BI.Query


TQueryDimension.Layout Method

Summary

Represents method Layout.

Namespace: BI.Query
Syntax
Delphi
protected
 function Layout:TGroupByLayout;

Return Value

Type: TGroupByLayout

See Also

Reference

  • TQueryDimension
  • BI.Query


TQueryDimension.RealData Method

Summary

Represents method RealData.

Namespace: BI.Query
Syntax
Delphi
public
 function RealData:TDataItem;

Return Value

Type: TDataItem

See Also

Reference

  • TQueryDimension
  • BI.Query


TQueryDimension.RealStyle Method

Summary

Represents method RealStyle.

Namespace: BI.Query
Syntax
Delphi
public
 function RealStyle:TDimensionStyle;

Return Value

Type: TDimensionStyle

See Also

Reference

  • TQueryDimension
  • BI.Query


TQueryDimension.SetData(TDataItem) Method

Summary

Represents method SetData(TDataItem).

Namespace: BI.Query
Syntax
Delphi
protected
 procedure SetData(const Value: TDataItem); override;

Parameters

Value
Type: TDataItem

Overrides

TDataCollectionItem.SetData(TDataItem)
See Also

Reference

  • TQueryDimension
  • BI.Query


TQueryDimension.ToString Method

Summary

Represents method ToString.

Namespace: BI.Query
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TQueryDimension
  • BI.Query


TQueryDimensions Class

Summary

Represents type TQueryDimensions.

Namespace: BI.Query
Inheritance Hierarchy
TOwnedCollection
BI.Query.TQueryCollection
BI.Query.TQueryDimensions
Syntax
Delphi
type
 TQueryDimensions=class(TQueryCollection)
 end;

The TQueryDimensions type exposes the following members.

Constructors
Show:
Name | Description
Create(TPersistent) | Initializes a new instance of the TQueryDimensions class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Add(TDataItem,String,TDimensionStyle) | Overloaded. Represents method Add(TDataItem,String,TDimensionStyle).
Add(TDataItem,TDimensionStyle,Boolean) | Overloaded. Represents method Add(TDataItem,TDimensionStyle,Boolean).
Add(TGroupBy) | Overloaded. Represents method Add(TGroupBy).
Exchange(TQueryDimension,TQueryDimension) | Represents method Exchange(TQueryDimension,TQueryDimension).
IndexOf(TQueryDimension) | Represents method IndexOf(TQueryDimension).
Swap | Represents method Swap.
Top
See Also

Reference

  • BI.Query


TQueryDimensions Constructors

Constructors
Name | Description
Create(TPersistent) | Initializes a new instance of the TQueryDimensions class.
Top


TQueryDimensions.Create(TPersistent) Constructor

Summary

Initializes a new instance of the TQueryDimensions class.

Namespace: BI.Query
Syntax
Delphi
public
 Constructor Create(AOwner: TPersistent);

Parameters

AOwner
Type: TPersistent

See Also

Reference

  • TQueryDimensions
  • BI.Query


TQueryDimensions Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TQueryDimensions.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: BI.Query
Syntax
Delphi
public
 property Items[const Index:Integer]:TQueryDimension read Get write Put; default;

Parameters

Index
Type: Integer

Property Value

Type: TQueryDimension

See Also

Reference

  • TQueryDimensions
  • BI.Query


TQueryDimensions Methods

Methods
Name | Description
Add(TDataItem,String,TDimensionStyle) | Overloaded. Represents method Add(TDataItem,String,TDimensionStyle).
Add(TDataItem,TDimensionStyle,Boolean) | Overloaded. Represents method Add(TDataItem,TDimensionStyle,Boolean).
Add(TGroupBy) | Overloaded. Represents method Add(TGroupBy).
Exchange(TQueryDimension,TQueryDimension) | Represents method Exchange(TQueryDimension,TQueryDimension).
IndexOf(TQueryDimension) | Represents method IndexOf(TQueryDimension).
Swap | Represents method Swap.
Top


TQueryDimensions.Add(TDataItem,String,TDimensionStyle) Method

Summary

Represents method Add(TDataItem,String,TDimensionStyle).

Namespace: BI.Query
Syntax
Delphi
public
 function Add(const AData:TDataItem;
 const AExpression:String;
 const AStyle:TDimensionStyle=TDimensionStyle.Automatic): TQueryDimension; overload;

Parameters

AData
Type: TDataItem

AExpression
Type: String

AStyle
Type: TDimensionStyle

Return Value

Type: TQueryDimension

See Also

Reference

  • TQueryDimensions
  • BI.Query


TQueryDimensions.Add(TDataItem,TDimensionStyle,Boolean) Method

Summary

Represents method Add(TDataItem,TDimensionStyle,Boolean).

Namespace: BI.Query
Syntax
Delphi
public
 function Add(const AData:TDataItem;
 const AStyle:TDimensionStyle=TDimensionStyle.Automatic;
 const IsActive:Boolean=True): TQueryDimension; overload;

Parameters

AData
Type: TDataItem

AStyle
Type: TDimensionStyle

IsActive
Type: Boolean

Return Value

Type: TQueryDimension

See Also

Reference

  • TQueryDimensions
  • BI.Query


TQueryDimensions.Add(TGroupBy) Method

Summary

Represents method Add(TGroupBy).

Namespace: BI.Query
Syntax
Delphi
protected
 function Add(const AGroupBy:TGroupBy):TQueryDimension; overload;

Parameters

AGroupBy
Type: TGroupBy

Return Value

Type: TQueryDimension

See Also

Reference

  • TQueryDimensions
  • BI.Query


TQueryDimensions.Exchange(TQueryDimension,TQueryDimension) Method

Summary

Represents method Exchange(TQueryDimension,TQueryDimension).

Namespace: BI.Query
Syntax
Delphi
public
 procedure Exchange(const A,B:TQueryDimension);

Parameters

A
Type: TQueryDimension

B
Type: TQueryDimension

See Also

Reference

  • TQueryDimensions
  • BI.Query


TQueryDimensions.IndexOf(TQueryDimension) Method

Summary

Represents method IndexOf(TQueryDimension).

Namespace: BI.Query
Syntax
Delphi
public
 function IndexOf(const ADimension:TQueryDimension):Integer;

Parameters

ADimension
Type: TQueryDimension

Return Value

Type: Integer

See Also

Reference

  • TQueryDimensions
  • BI.Query


TQueryDimensions.Swap Method

Summary

Represents method Swap.

Namespace: BI.Query
Syntax
Delphi
public
 procedure Swap;
See Also

Reference

  • TQueryDimensions
  • BI.Query


TQueryItem Class

Summary

Represents type TQueryItem.

Namespace: BI.Query
Inheritance Hierarchy
TCollectionItem
BI.CollectionItem.TDataCollectionItem
BI.Query.TQueryItem
BI.Query.TQueryDimension
BI.Query.TQueryMeasure
BI.Query.TQuerySortItem
Syntax
Delphi
type
 TQueryItem=class(TDataCollectionItem)
 end;

The TQueryItem type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TQueryItem class.
Top
Properties
Show:
Name | Description
Enabled | Represents property Enabled.
Query | Represents property Query.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TDataCollectionItem.Assign(TPersistent).)
Changed | Represents method Changed. (Overrides TDataCollectionItem.Changed.)
Top
See Also

Reference

  • BI.Query


TQueryItem Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TQueryItem class.
Top


TQueryItem.Create(TCollection) Constructor

Summary

Initializes a new instance of the TQueryItem class.

Namespace: BI.Query
Syntax
Delphi
public
 Constructor Create(Collection: TCollection); override;

Parameters

Collection
Type: TCollection

See Also

Reference

  • TQueryItem
  • BI.Query


TQueryItem Properties

Properties
Name | Description
Enabled | Represents property Enabled.
Query | Represents property Query.
Top


TQueryItem.Enabled Property

Summary

Represents property Enabled.

Namespace: BI.Query
Syntax
Delphi
published
 property Enabled:Boolean read FEnabled write SetEnabled default True;

Property Value

Type: Boolean

See Also

Reference

  • TQueryItem
  • BI.Query


TQueryItem.Query Property

Summary

Represents property Query.

Namespace: BI.Query
Syntax
Delphi
public
 property Query:TBIQuery read GetQuery;

Property Value

Type: TBIQuery

See Also

Reference

  • TQueryItem
  • BI.Query


TQueryItem Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TDataCollectionItem.Assign(TPersistent).)
Changed | Represents method Changed. (Overrides TDataCollectionItem.Changed.)
Top


TQueryItem.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Query
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TDataCollectionItem.Assign(TPersistent)
See Also

Reference

  • TQueryItem
  • BI.Query


TQueryItem.Changed Method

Summary

Represents method Changed.

Namespace: BI.Query
Syntax
Delphi
protected
 procedure Changed; override;

Overrides

TDataCollectionItem.Changed
See Also

Reference

  • TQueryItem
  • BI.Query


TQueryMeasure Class

Summary

Represents type TQueryMeasure.

Namespace: BI.Query
Inheritance Hierarchy
TCollectionItem
BI.CollectionItem.TDataCollectionItem
BI.Query.TQueryItem
BI.Query.TQueryMeasure
Syntax
Delphi
type
 TQueryMeasure=class(TQueryItem)
 end;

The TQueryMeasure type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TQueryMeasure class. (Overrides TQueryItem.Create(TCollection).)
Destroy | Represents the destructor of the TQueryMeasure class. (Overrides TDataCollectionItem.Destroy.)
Top
Properties
Show:
Name | Description
Aggregate | Represents property Aggregate.
Calculation | Represents property Calculation.
Expression | Represents property Expression.
Measure | Represents property Measure.
Missing | Represents property Missing.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TQueryItem.Assign(TPersistent).)
RealData | Represents method RealData.
SetData(TDataItem) | Represents method SetData(TDataItem). (Overrides TDataCollectionItem.SetData(TDataItem).)
ToString | Represents method ToString.
Top
See Also

Reference

  • BI.Query


TQueryMeasure Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TQueryMeasure class. (Overrides TQueryItem.Create(TCollection).)
Destroy | Represents the destructor of the TQueryMeasure class. (Overrides TDataCollectionItem.Destroy.)
Top


TQueryMeasure.Create(TCollection) Constructor

Summary

Initializes a new instance of the TQueryMeasure class.

Namespace: BI.Query
Syntax
Delphi
public
 Constructor Create(Collection: TCollection); override;

Parameters

Collection
Type: TCollection

Overrides

TQueryItem.Create(TCollection)
See Also

Reference

  • TQueryMeasure
  • BI.Query


TQueryMeasure.Destroy Destructor

Summary

Represents the destructor of the TQueryMeasure class.

Namespace: BI.Query
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TDataCollectionItem.Destroy
See Also

Reference

  • TQueryMeasure
  • BI.Query


TQueryMeasure Properties

Properties
Name | Description
Aggregate | Represents property Aggregate.
Calculation | Represents property Calculation.
Expression | Represents property Expression.
Measure | Represents property Measure.
Missing | Represents property Missing.
Top


TQueryMeasure.Aggregate Property

Summary

Represents property Aggregate.

Namespace: BI.Query
Syntax
Delphi
published
 property Aggregate:TAggregate read GetAggregate write SetAggregate default TAggregate.Count;

Property Value

Type: TAggregate

See Also

Reference

  • TQueryMeasure
  • BI.Query


TQueryMeasure.Calculation Property

Summary

Represents property Calculation.

Namespace: BI.Query
Syntax
Delphi
published
 property Calculation : TMeasureCalculation read GetCalculation write SetCalculation;

Property Value

Type: TMeasureCalculation

See Also

Reference

  • TQueryMeasure
  • BI.Query


TQueryMeasure.Expression Property

Summary

Represents property Expression.

Namespace: BI.Query
Syntax
Delphi
public
 property Expression:TExpression read GetExpression write SetExpression;

Property Value

Type: TExpression

See Also

Reference

  • TQueryMeasure
  • BI.Query


TQueryMeasure.Measure Property

Summary

Represents property Measure.

Namespace: BI.Query
Syntax
Delphi
protected
 property Measure:TMeasure read FMeasure;

Property Value

Type: TMeasure

See Also

Reference

  • TQueryMeasure
  • BI.Query


TQueryMeasure.Missing Property

Summary

Represents property Missing.

Namespace: BI.Query
Syntax
Delphi
published
 property Missing : TMeasureMissing read GetMissing write SetMissing;

Property Value

Type: TMeasureMissing

See Also

Reference

  • TQueryMeasure
  • BI.Query


TQueryMeasure Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TQueryItem.Assign(TPersistent).)
RealData | Represents method RealData.
SetData(TDataItem) | Represents method SetData(TDataItem). (Overrides TDataCollectionItem.SetData(TDataItem).)
ToString | Represents method ToString.
Top


TQueryMeasure.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Query
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TQueryItem.Assign(TPersistent)
See Also

Reference

  • TQueryMeasure
  • BI.Query


TQueryMeasure.RealData Method

Summary

Represents method RealData.

Namespace: BI.Query
Syntax
Delphi
public
 function RealData:TDataItem;

Return Value

Type: TDataItem

See Also

Reference

  • TQueryMeasure
  • BI.Query


TQueryMeasure.SetData(TDataItem) Method

Summary

Represents method SetData(TDataItem).

Namespace: BI.Query
Syntax
Delphi
protected
 procedure SetData(const Value: TDataItem); override;

Parameters

Value
Type: TDataItem

Overrides

TDataCollectionItem.SetData(TDataItem)
See Also

Reference

  • TQueryMeasure
  • BI.Query


TQueryMeasure.ToString Method

Summary

Represents method ToString.

Namespace: BI.Query
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TQueryMeasure
  • BI.Query


TQueryMeasures Class

Summary

Represents type TQueryMeasures.

Namespace: BI.Query
Inheritance Hierarchy
TOwnedCollection
BI.Query.TQueryCollection
BI.Query.TQueryMeasures
Syntax
Delphi
type
 TQueryMeasures=class(TQueryCollection)
 end;

The TQueryMeasures type exposes the following members.

Constructors
Show:
Name | Description
Create(TPersistent) | Initializes a new instance of the TQueryMeasures class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Add(TDataItem,TAggregate,Boolean) | Overloaded. Represents method Add(TDataItem,TAggregate,Boolean).
Add(TMeasure) | Overloaded. Represents method Add(TMeasure).
EnabledCount | Represents method EnabledCount.
Exchange(TQueryMeasure,TQueryMeasure) | Represents method Exchange(TQueryMeasure,TQueryMeasure).
IndexOf(TQueryMeasure) | Represents method IndexOf(TQueryMeasure).
Top
See Also

Reference

  • BI.Query


TQueryMeasures Constructors

Constructors
Name | Description
Create(TPersistent) | Initializes a new instance of the TQueryMeasures class.
Top


TQueryMeasures.Create(TPersistent) Constructor

Summary

Initializes a new instance of the TQueryMeasures class.

Namespace: BI.Query
Syntax
Delphi
public
 Constructor Create(AOwner: TPersistent);

Parameters

AOwner
Type: TPersistent

See Also

Reference

  • TQueryMeasures
  • BI.Query


TQueryMeasures Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TQueryMeasures.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: BI.Query
Syntax
Delphi
public
 property Items[const Index:Integer]:TQueryMeasure read Get write Put; default;

Parameters

Index
Type: Integer

Property Value

Type: TQueryMeasure

See Also

Reference

  • TQueryMeasures
  • BI.Query


TQueryMeasures Methods

Methods
Name | Description
Add(TDataItem,TAggregate,Boolean) | Overloaded. Represents method Add(TDataItem,TAggregate,Boolean).
Add(TMeasure) | Overloaded. Represents method Add(TMeasure).
EnabledCount | Represents method EnabledCount.
Exchange(TQueryMeasure,TQueryMeasure) | Represents method Exchange(TQueryMeasure,TQueryMeasure).
IndexOf(TQueryMeasure) | Represents method IndexOf(TQueryMeasure).
Top


TQueryMeasures.Add(TDataItem,TAggregate,Boolean) Method

Summary

Represents method Add(TDataItem,TAggregate,Boolean).

Namespace: BI.Query
Syntax
Delphi
public
 function Add(const AData:TDataItem;
 const AMeasure:TAggregate;
 const IsActive:Boolean=True): TQueryMeasure; overload;

Parameters

AData
Type: TDataItem

AMeasure
Type: TAggregate

IsActive
Type: Boolean

Return Value

Type: TQueryMeasure

See Also

Reference

  • TQueryMeasures
  • BI.Query


TQueryMeasures.Add(TMeasure) Method

Summary

Represents method Add(TMeasure).

Namespace: BI.Query
Syntax
Delphi
protected
 function Add(const AMeasure:TMeasure):TQueryMeasure; overload;

Parameters

AMeasure
Type: TMeasure

Return Value

Type: TQueryMeasure

See Also

Reference

  • TQueryMeasures
  • BI.Query


TQueryMeasures.EnabledCount Method

Summary

Represents method EnabledCount.

Namespace: BI.Query
Syntax
Delphi
protected
 function EnabledCount:Integer;

Return Value

Type: Integer

See Also

Reference

  • TQueryMeasures
  • BI.Query


TQueryMeasures.Exchange(TQueryMeasure,TQueryMeasure) Method

Summary

Represents method Exchange(TQueryMeasure,TQueryMeasure).

Namespace: BI.Query
Syntax
Delphi
public
 procedure Exchange(const A,B:TQueryMeasure);

Parameters

A
Type: TQueryMeasure

B
Type: TQueryMeasure

See Also

Reference

  • TQueryMeasures
  • BI.Query


TQueryMeasures.IndexOf(TQueryMeasure) Method

Summary

Represents method IndexOf(TQueryMeasure).

Namespace: BI.Query
Syntax
Delphi
public
 function IndexOf(const AMeasure:TQueryMeasure):Integer;

Parameters

AMeasure
Type: TQueryMeasure

Return Value

Type: Integer

See Also

Reference

  • TQueryMeasures
  • BI.Query


TQuerySort Class

Summary

Represents type TQuerySort.

Namespace: BI.Query
Inheritance Hierarchy
TOwnedCollection
BI.Query.TQueryCollection
BI.Query.TQuerySort
VCLBI.Editor.Sort.TQuerySortAccess
Syntax
Delphi
type
 TQuerySort=class(TQueryCollection)
 end;

The TQuerySort type exposes the following members.

Constructors
Show:
Name | Description
Create(TPersistent) | Initializes a new instance of the TQuerySort class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
AddSort(TDataItem,Boolean,Boolean) | Represents method AddSort(TDataItem,Boolean,Boolean).
ItemOf(TDataItem) | Represents method ItemOf(TDataItem).
Sort | Represents method Sort.
Top
See Also

Reference

  • BI.Query


TQuerySort Constructors

Constructors
Name | Description
Create(TPersistent) | Initializes a new instance of the TQuerySort class.
Top


TQuerySort.Create(TPersistent) Constructor

Summary

Initializes a new instance of the TQuerySort class.

Namespace: BI.Query
Syntax
Delphi
public
 Constructor Create(AOwner: TPersistent);

Parameters

AOwner
Type: TPersistent

See Also

Reference

  • TQuerySort
  • BI.Query


TQuerySort Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TQuerySort.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: BI.Query
Syntax
Delphi
public
 property Items[const Index:Integer]:TQuerySortItem read Get write Put; default;

Parameters

Index
Type: Integer

Property Value

Type: TQuerySortItem

See Also

Reference

  • TQuerySort
  • BI.Query


TQuerySort Methods

Methods
Name | Description
AddSort(TDataItem,Boolean,Boolean) | Represents method AddSort(TDataItem,Boolean,Boolean).
ItemOf(TDataItem) | Represents method ItemOf(TDataItem).
Sort | Represents method Sort.
Top


TQuerySort.AddSort(TDataItem,Boolean,Boolean) Method

Summary

Represents method AddSort(TDataItem,Boolean,Boolean).

Namespace: BI.Query
Syntax
Delphi
public
 function AddSort(const AData:TDataItem;
 const Ascending:Boolean=True;
 const IgnoreTextCase:Boolean=True):TQuerySortItem;

Parameters

AData
Type: TDataItem

Ascending
Type: Boolean

IgnoreTextCase
Type: Boolean

Return Value

Type: TQuerySortItem

See Also

Reference

  • TQuerySort
  • BI.Query


TQuerySort.ItemOf(TDataItem) Method

Summary

Represents method ItemOf(TDataItem).

Namespace: BI.Query
Syntax
Delphi
public
 function ItemOf(const AData:TDataItem):TQuerySortItem;

Parameters

AData
Type: TDataItem

Return Value

Type: TQuerySortItem

See Also

Reference

  • TQuerySort
  • BI.Query


TQuerySort.Sort Method

Summary

Represents method Sort.

Namespace: BI.Query
Syntax
Delphi
protected
 function Sort:TSortItems;

Return Value

Type: TSortItems

See Also

Reference

  • TQuerySort
  • BI.Query


TQuerySortItem Class

Summary

Represents type TQuerySortItem.

Namespace: BI.Query
Inheritance Hierarchy
TCollectionItem
BI.CollectionItem.TDataCollectionItem
BI.Query.TQueryItem
BI.Query.TQuerySortItem
Syntax
Delphi
type
 TQuerySortItem=class(TQueryItem)
 end;

The TQuerySortItem type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TQuerySortItem class. (Overrides TQueryItem.Create(TCollection).)
Top
Properties
Show:
Name | Description
Ascending | Represents property Ascending.
IgnoreTextCase | Represents property IgnoreTextCase.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TQueryItem.Assign(TPersistent).)
Top
See Also

Reference

  • BI.Query


TQuerySortItem Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TQuerySortItem class. (Overrides TQueryItem.Create(TCollection).)
Top


TQuerySortItem.Create(TCollection) Constructor

Summary

Initializes a new instance of the TQuerySortItem class.

Namespace: BI.Query
Syntax
Delphi
public
 Constructor Create(ACollection:TCollection); override;

Parameters

ACollection
Type: TCollection

Overrides

TQueryItem.Create(TCollection)
See Also

Reference

  • TQuerySortItem
  • BI.Query


TQuerySortItem Properties

Properties
Name | Description
Ascending | Represents property Ascending.
IgnoreTextCase | Represents property IgnoreTextCase.
Top


TQuerySortItem.Ascending Property

Summary

Represents property Ascending.

Namespace: BI.Query
Syntax
Delphi
published
 property Ascending:Boolean read FAscending write SetAscending default True;

Property Value

Type: Boolean

See Also

Reference

  • TQuerySortItem
  • BI.Query


TQuerySortItem.IgnoreTextCase Property

Summary

Represents property IgnoreTextCase.

Namespace: BI.Query
Syntax
Delphi
published
 property IgnoreTextCase: Boolean read FIgnoreTextCase write SetIgnoreTextCase default True;

Property Value

Type: Boolean

See Also

Reference

  • TQuerySortItem
  • BI.Query


TQuerySortItem Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TQueryItem.Assign(TPersistent).)
Top


TQuerySortItem.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Query
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TQueryItem.Assign(TPersistent)
See Also

Reference

  • TQuerySortItem
  • BI.Query


TRemoveMissingAccess Class

Summary

Represents type TRemoveMissingAccess.

Namespace: BI.Query
Inheritance Hierarchy
TPersistent
BI.Summary.TBaseSummaryPersistent
BI.Summary.TRemoveMissing
BI.Query.TRemoveMissingAccess
Syntax
Delphi
type
 TRemoveMissingAccess=class(TRemoveMissing);
See Also

Reference

  • BI.Query


TSummaryAccess Class

Summary

Represents type TSummaryAccess.

Namespace: BI.Query
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Summary.TSummary
BI.Query.TSummaryAccess
Syntax
Delphi
type
 TSummaryAccess=class(TSummary);
See Also

Reference

  • BI.Query


BI.Query Enumerations

Enumerations
Name | Description
TDimensionStyle | Represents type TDimensionStyle.
TQueryStyle | Represents type TQueryStyle.
Top


TDimensionStyle Enumeration

Summary

Represents type TDimensionStyle.

Namespace: BI.Query
Syntax
Delphi
type
 TDimensionStyle=(Automatic,Row,Column);

The TDimensionStyle type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Column | Represents constant Column.
Row | Represents constant Row.
Top
See Also

Reference

  • BI.Query


TQueryStyle Enumeration

Summary

Represents type TQueryStyle.

Namespace: BI.Query
Syntax
Delphi
type
 TQueryStyle=(Unknown,Select,Summary);

The TQueryStyle type exposes the following members.

Members
Show:
Name | Description
Select | Represents constant Select.
Summary | Represents constant Summary.
Unknown | Represents constant Unknown.
Top
See Also

Reference

  • BI.Query


BI.Query Routines

Routines
Name | Description
ErrorDataNil(String) | Represents method ErrorDataNil(String).
StyleOfBy(TGroupBy) | Represents method StyleOfBy(TGroupBy).
Top


ErrorDataNil(String) Method

Summary

Represents method ErrorDataNil(String).

Namespace: BI.Query
Syntax
Delphi
procedure ErrorDataNil(const AMessage:String);

Parameters

AMessage
Type: String

See Also

Reference

  • BI.Query


StyleOfBy(TGroupBy) Method

Summary

Represents method StyleOfBy(TGroupBy).

Namespace: BI.Query
Syntax
Delphi
function StyleOfBy(const AGroup:TGroupBy):TDimensionStyle;

Parameters

AGroup
Type: TGroupBy

Return Value

Type: TDimensionStyle

See Also

Reference

  • BI.Query


BI.Rank Namespace

Summary

Represents namespace BI.Rank.

Records
Name | Description
TDataRank | Represents type TDataRank.
Top


BI.Rank Records

Records
Name | Description
TDataRank | Represents type TDataRank.
Top


TDataRank Record

Summary

Represents type TDataRank.

Namespace: BI.Rank
Syntax
Delphi
type
 TDataRank=record
 end;

The TDataRank type exposes the following members.

Methods
Show:
Name | Description
From(TDataItem,TDataArray,TDataItem,Boolean) | Represents method From(TDataItem,TDataArray,TDataItem,Boolean).
Top
See Also

Reference

  • BI.Rank


TDataRank Methods

Methods
Name | Description
From(TDataItem,TDataArray,TDataItem,Boolean) | Represents method From(TDataItem,TDataArray,TDataItem,Boolean).
Top


TDataRank.From(TDataItem,TDataArray,TDataItem,Boolean) Method

Summary

Represents method From(TDataItem,TDataArray,TDataItem,Boolean).

Namespace: BI.Rank
Syntax
Delphi
public
 class function From(const AData:TDataItem;
 const AGroups:TDataArray;
 const AValue:TDataItem;
 const Ascending:Boolean=False):TDataItem; static;

Parameters

AData
Type: TDataItem

AGroups
Type: TDataArray

AValue
Type: TDataItem

Ascending
Type: Boolean

Return Value

Type: TDataItem

See Also

Reference

  • TDataRank
  • BI.Rank


BI.RTTI Namespace

Summary

Represents namespace BI.RTTI.

Classes
Name | Description
TRTTIProvider | Represents type TRTTIProvider.
TTypeProvider<T> | Represents type TTypeProvider<T>.
Top
Enumerations
Name | Description
TRttiMembers | Represents type TRttiMembers.
Top
Types
Name | Description
TVisibility | Represents type TVisibility.
Top


BI.RTTI Classes

Classes
Name | Description
TRTTIProvider | Represents type TRTTIProvider.
TTypeProvider<T> | Represents type TTypeProvider<T>.
Top


TRTTIProvider Class

Summary

Represents type TRTTIProvider.

Namespace: BI.RTTI
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Persist.TBaseDataImporter
BI.RTTI.TRTTIProvider
Syntax
Delphi
type
 TRTTIProvider=class(TBaseDataImporter)
 end;

The TRTTIProvider type exposes the following members.

Constructors
Show:
Name | Description
CreateType(TComponent,PTypeInfo,TVisibility,TRttiMembers) | Overloaded. Initializes a new instance of the TRTTIProvider class.
Top
Properties
Show:
Name | Description
Members | Represents property Members.
Visibility | Represents property Visibility.
Top
Methods
Show:
Name | Description
DoAdd(TDataItem,TInteger,TValue) | Represents method DoAdd(TDataItem,TInteger,TValue).
GetItems(TDataItem) | Represents method GetItems(TDataItem). (Overrides TDataProvider.GetItems(TDataItem).)
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Same(TDataItem,TInteger,TValue) | Represents method Same(TDataItem,TInteger,TValue).
Top
See Also

Reference

  • BI.RTTI


TRTTIProvider Constructors

Constructors
Name | Description
CreateType(TComponent,PTypeInfo,TVisibility,TRttiMembers) | Overloaded. Initializes a new instance of the TRTTIProvider class.
Top


TRTTIProvider.CreateType(TComponent,PTypeInfo,TVisibility,TRttiMembers) Constructor

Summary

Initializes a new instance of the TRTTIProvider class.

Namespace: BI.RTTI
Syntax
Delphi
public
 Constructor CreateType(const AOwner:TComponent;
 const AType:PTypeInfo;
 const AVisibility:TVisibility=[mvPublic,mvPublished];
 const AMembers:TRttiMembers=TRttiMembers.Both); overload;

Parameters

AOwner
Type: TComponent

AType
Type: PTypeInfo

AVisibility
Type: TVisibility

AMembers
Type: TRttiMembers

See Also

Reference

  • TRTTIProvider
  • BI.RTTI


TRTTIProvider Properties

Properties
Name | Description
Members | Represents property Members.
Visibility | Represents property Visibility.
Top


TRTTIProvider.Members Property

Summary

Represents property Members.

Namespace: BI.RTTI
Syntax
Delphi
published
 property Members:TRttiMembers read FMembers write FMembers;

Property Value

Type: TRttiMembers

See Also

Reference

  • TRTTIProvider
  • BI.RTTI


TRTTIProvider.Visibility Property

Summary

Represents property Visibility.

Namespace: BI.RTTI
Syntax
Delphi
published
 property Visibility:TVisibility read FVisibility write FVisibility;

Property Value

Type: TVisibility

See Also

Reference

  • TRTTIProvider
  • BI.RTTI


TRTTIProvider Methods

Methods
Name | Description
DoAdd(TDataItem,TInteger,TValue) | Represents method DoAdd(TDataItem,TInteger,TValue).
GetItems(TDataItem) | Represents method GetItems(TDataItem). (Overrides TDataProvider.GetItems(TDataItem).)
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Same(TDataItem,TInteger,TValue) | Represents method Same(TDataItem,TInteger,TValue).
Top


TRTTIProvider.DoAdd(TDataItem,TInteger,TValue) Method

Summary

Represents method DoAdd(TDataItem,TInteger,TValue).

Namespace: BI.RTTI
Syntax
Delphi
protected
 procedure DoAdd(const AData:TDataItem; const APos:TInteger; const AValue:TValue);

Parameters

AData
Type: TDataItem

APos
Type: System.Void

AValue
Type: TValue

See Also

Reference

  • TRTTIProvider
  • BI.RTTI


TRTTIProvider.GetItems(TDataItem) Method

Summary

Represents method GetItems(TDataItem).

Namespace: BI.RTTI
Syntax
Delphi
protected
 procedure GetItems(const AData:TDataItem); override;

Parameters

AData
Type: TDataItem

Overrides

TDataProvider.GetItems(TDataItem)
See Also

Reference

  • TRTTIProvider
  • BI.RTTI


TRTTIProvider.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.RTTI
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TRTTIProvider
  • BI.RTTI


TRTTIProvider.Same(TDataItem,TInteger,TValue) Method

Summary

Represents method Same(TDataItem,TInteger,TValue).

Namespace: BI.RTTI
Syntax
Delphi
protected
 function Same(const AData:TDataItem; const APos:TInteger; const AValue:TValue):Boolean;

Parameters

AData
Type: TDataItem

APos
Type: System.Void

AValue
Type: TValue

Return Value

Type: Boolean

See Also

Reference

  • TRTTIProvider
  • BI.RTTI


TTypeProvider<T> Class

Summary

Represents type TTypeProvider<T>.

Namespace: BI.RTTI
Inheritance Hierarchy
TObject
BI.RTTI.TTypeProvider<T>
Syntax
Delphi
type
 TTypeProvider<T

Type Parameters

T
See Also

Reference

  • BI.RTTI


BI.RTTI Enumerations

Enumerations
Name | Description
TRttiMembers | Represents type TRttiMembers.
Top


TRttiMembers Enumeration

Summary

Represents type TRttiMembers.

Namespace: BI.RTTI
Syntax
Delphi
type
 TRttiMembers=(Both, Fields, Properties);

The TRttiMembers type exposes the following members.

Members
Show:
Name | Description
Both | Represents constant Both.
Fields | Represents constant Fields.
Properties | Represents constant Properties.
Top
See Also

Reference

  • BI.RTTI


BI.RTTI Types

Types
Name | Description
TVisibility | Represents type TVisibility.
Top


TVisibility Type

Summary

Represents type TVisibility.

Namespace: BI.RTTI
Syntax
Delphi
type
 TVisibility=set of TMemberVisibility;
See Also

Reference

  • BI.RTTI


BI.Schedule Namespace

Summary

Represents namespace BI.Schedule.

Classes
Name | Description
TScheduler | Represents type TScheduler.
TWorkItem | Represents type TWorkItem.
TWorkItemComparer | Represents type TWorkItemComparer.
Top
Types
Name | Description
TWork | Represents type TWork.
Top


BI.Schedule Classes

Classes
Name | Description
TScheduler | Represents type TScheduler.
TWorkItem | Represents type TWorkItem.
TWorkItemComparer | Represents type TWorkItemComparer.
Top


TScheduler Class

Summary

Represents type TScheduler.

Namespace: BI.Schedule
Inheritance Hierarchy
TComponent
BI.Schedule.TScheduler
Syntax
Delphi
type
 TScheduler=class(TComponent)
 end;

The TScheduler type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TScheduler class.
Top
Methods
Show:
Name | Description
Add(TDateTime,TObject,TWork) | Represents method Add(TDateTime,TObject,TWork).
Clear | Represents method Clear.
Count | Represents method Count.
Remove(TWorkItem) | Represents method Remove(TWorkItem).
Work | Represents method Work.
Top
Fields
Show:
Name | Description
Items | Represents field Items.
Top
See Also

Reference

  • BI.Schedule


TScheduler Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TScheduler class.
Top


TScheduler.Destroy Destructor

Summary

Represents the destructor of the TScheduler class.

Namespace: BI.Schedule
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TScheduler
  • BI.Schedule


TScheduler Methods

Methods
Name | Description
Add(TDateTime,TObject,TWork) | Represents method Add(TDateTime,TObject,TWork).
Clear | Represents method Clear.
Count | Represents method Count.
Remove(TWorkItem) | Represents method Remove(TWorkItem).
Work | Represents method Work.
Top


TScheduler.Add(TDateTime,TObject,TWork) Method

Summary

Represents method Add(TDateTime,TObject,TWork).

Namespace: BI.Schedule
Syntax
Delphi
public
 function Add(const DueTime:TDateTime; const Tag:TObject; const Work:TWork):TWorkItem;

Parameters

DueTime
Type: TDateTime

Tag
Type: TObject

Work
Type: TWork

Return Value

Type: TWorkItem

See Also

Reference

  • TScheduler
  • BI.Schedule


TScheduler.Clear Method

Summary

Represents method Clear.

Namespace: BI.Schedule
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TScheduler
  • BI.Schedule


TScheduler.Count Method

Summary

Represents method Count.

Namespace: BI.Schedule
Syntax
Delphi
public
 function Count:Integer;

Return Value

Type: Integer

See Also

Reference

  • TScheduler
  • BI.Schedule


TScheduler.Remove(TWorkItem) Method

Summary

Represents method Remove(TWorkItem).

Namespace: BI.Schedule
Syntax
Delphi
public
 procedure Remove(const Work:TWorkItem);

Parameters

Work
Type: TWorkItem

See Also

Reference

  • TScheduler
  • BI.Schedule


TScheduler.Work Method

Summary

Represents method Work.

Namespace: BI.Schedule
Syntax
Delphi
public
 procedure Work;
See Also

Reference

  • TScheduler
  • BI.Schedule


TScheduler Fields

Fields
Name | Description
Items | Represents field Items.
Top


TScheduler.Items Field

Summary

Represents field Items.

Namespace: BI.Schedule
Syntax
Delphi
public
 Items : TArray<TWorkItem>;

Field Value

Type: TArray<TWorkItem>

See Also

Reference

  • TScheduler
  • BI.Schedule


TWorkItem Class

Summary

Represents type TWorkItem.

Namespace: BI.Schedule
Inheritance Hierarchy
TObject
BI.Schedule.TWorkItem
Syntax
Delphi
type
 TWorkItem=class
 end;

The TWorkItem type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TWorkItem class.
Top
Properties
Show:
Name | Description
DueTime | Represents property DueTime.
Top
Methods
Show:
Name | Description
Work | Represents method Work.
Top
Fields
Show:
Name | Description
Asynchronous | Represents field Asynchronous.
Top
See Also

Reference

  • BI.Schedule


TWorkItem Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TWorkItem class.
Top


TWorkItem.Destroy Destructor

Summary

Represents the destructor of the TWorkItem class.

Namespace: BI.Schedule
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TWorkItem
  • BI.Schedule


TWorkItem Properties

Properties
Name | Description
DueTime | Represents property DueTime.
Top


TWorkItem.DueTime Property

Summary

Represents property DueTime.

Namespace: BI.Schedule
Syntax
Delphi
public
 property DueTime:TDateTime read FDueTime write SetDueTime;

Property Value

Type: TDateTime

See Also

Reference

  • TWorkItem
  • BI.Schedule


TWorkItem Methods

Methods
Name | Description
Work | Represents method Work.
Top


TWorkItem.Work Method

Summary

Represents method Work.

Namespace: BI.Schedule
Syntax
Delphi
public
 procedure Work;
See Also

Reference

  • TWorkItem
  • BI.Schedule


TWorkItem Fields

Fields
Name | Description
Asynchronous | Represents field Asynchronous.
Top


TWorkItem.Asynchronous Field

Summary

Represents field Asynchronous.

Namespace: BI.Schedule
Syntax
Delphi
public
 Asynchronous : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TWorkItem
  • BI.Schedule


TWorkItemComparer Class

Summary

Represents type TWorkItemComparer.

Namespace: BI.Schedule
Inheritance Hierarchy
TComparer
BI.Schedule.TWorkItemComparer
Syntax
Delphi
type
 TWorkItemComparer=class(TComparer<TWorkItem>)
 end;

The TWorkItemComparer type exposes the following members.

Methods
Show:
Name | Description
Compare(TWorkItem,TWorkItem) | Represents method Compare(TWorkItem,TWorkItem).
Top
See Also

Reference

  • BI.Schedule


TWorkItemComparer Methods

Methods
Name | Description
Compare(TWorkItem,TWorkItem) | Represents method Compare(TWorkItem,TWorkItem).
Top


TWorkItemComparer.Compare(TWorkItem,TWorkItem) Method

Summary

Represents method Compare(TWorkItem,TWorkItem).

Namespace: BI.Schedule
Syntax
Delphi
protected
 function Compare(const Left, Right: TWorkItem): Integer; override;

Parameters

Left
Type: TWorkItem

Right
Type: TWorkItem

Return Value

Type: Integer

See Also

Reference

  • TWorkItemComparer
  • BI.Schedule


BI.Schedule Types

Types
Name | Description
TWork | Represents type TWork.
Top


TWork Type

Summary

Represents type TWork.

Namespace: BI.Schedule
Syntax
Delphi
type
 TWork=reference to procedure(const Item:TObject);
See Also

Reference

  • BI.Schedule


BI.Search Namespace

Summary

Represents namespace BI.Search.

Classes
Name | Description
TMatchText | Represents type TMatchText.
Top
Records
Name | Description
TDataSearch | Represents type TDataSearch.
TSearchHits | Represents type TSearchHits.
Top
Enumerations
Name | Description
TDataSearchPart | Represents type TDataSearchPart.
Top
Delegates
Name | Description
TMatchFunction | Represents type TMatchFunction.
TSearchFinished | Represents type TSearchFinished.
TSearchProgress | Represents type TSearchProgress.
Top
Types
Name | Description
PDataSearch | Represents a pointer type to TDataSearch.
Top


BI.Search Classes

Classes
Name | Description
TMatchText | Represents type TMatchText.
Top


TMatchText Class

Summary

Represents type TMatchText.

Namespace: BI.Search
Inheritance Hierarchy
TObject
BI.Search.TMatchText
Syntax
Delphi
type
 TMatchText=class
 end;

The TMatchText type exposes the following members.

Constructors
Show:
Name | Description
Create(TDataSearch,String) | Initializes a new instance of the TMatchText class.
Top
Fields
Show:
Name | Description
Match | Represents field Match.
Part | Represents field Part.
Text | Represents field Text.
TextLength | Represents field TextLength.
Top
See Also

Reference

  • BI.Search


TMatchText Constructors

Constructors
Name | Description
Create(TDataSearch,String) | Initializes a new instance of the TMatchText class.
Top


TMatchText.Create(TDataSearch,String) Constructor

Summary

Initializes a new instance of the TMatchText class.

Namespace: BI.Search
Syntax
Delphi
public
 Constructor Create(const ASearch:TDataSearch; const AText:String);

Parameters

ASearch
Type: TDataSearch

AText
Type: String

See Also

Reference

  • TMatchText
  • BI.Search


TMatchText Fields

Fields
Name | Description
Match | Represents field Match.
Part | Represents field Part.
Text | Represents field Text.
TextLength | Represents field TextLength.
Top


TMatchText.Match Field

Summary

Represents field Match.

Namespace: BI.Search
Syntax
Delphi
public
 Match : TMatchFunction;

Field Value

Type: TMatchFunction

See Also

Reference

  • TMatchText
  • BI.Search


TMatchText.Part Field

Summary

Represents field Part.

Namespace: BI.Search
Syntax
Delphi
public
 Part : TDataSearchPart;

Field Value

Type: TDataSearchPart

See Also

Reference

  • TMatchText
  • BI.Search


TMatchText.Text Field

Summary

Represents field Text.

Namespace: BI.Search
Syntax
Delphi
public
 Text : String;

Field Value

Type: String

See Also

Reference

  • TMatchText
  • BI.Search


TMatchText.TextLength Field

Summary

Represents field TextLength.

Namespace: BI.Search
Syntax
Delphi
public
 TextLength : Integer;

Field Value

Type: Integer

See Also

Reference

  • TMatchText
  • BI.Search


BI.Search Records

Records
Name | Description
TDataSearch | Represents type TDataSearch.
TSearchHits | Represents type TSearchHits.
Top


TDataSearch Record

Summary

Represents type TDataSearch.

Namespace: BI.Search
Syntax
Delphi
type
 TDataSearch=record
 end;

The TDataSearch type exposes the following members.

Methods
Show:
Name | Description
BackgroundFind(String) | Represents method BackgroundFind(String).
Find(String) | Represents method Find(String).
Stop | Represents method Stop.
Top
Events
Show:
Name | Description
OnFinished | Represents property OnFinished.
OnProgress | Represents property OnProgress.
Top
Fields
Show:
Name | Description
CaseSensitive | Represents field CaseSensitive.
DateTimeFormat | Represents field DateTimeFormat.
FloatFormat | Represents field FloatFormat.
Hits | Represents field Hits.
Index | Represents field Index.
Items | Represents field Items.
Source | Represents field Source.
TextPart | Represents field TextPart.
Top
See Also

Reference

  • BI.Search


TDataSearch Methods

Methods
Name | Description
BackgroundFind(String) | Represents method BackgroundFind(String).
Find(String) | Represents method Find(String).
Stop | Represents method Stop.
Top


TDataSearch.BackgroundFind(String) Method

Summary

Represents method BackgroundFind(String).

Namespace: BI.Search
Syntax
Delphi
public
 procedure BackgroundFind(const AText:String);

Parameters

AText
Type: String

See Also

Reference

  • TDataSearch
  • BI.Search


TDataSearch.Find(String) Method

Summary

Represents method Find(String).

Namespace: BI.Search
Syntax
Delphi
public
 function Find(const AText:String):TCursorIndex;

Parameters

AText
Type: String

Return Value

Type: TCursorIndex

See Also

Reference

  • TDataSearch
  • BI.Search


TDataSearch.Stop Method

Summary

Represents method Stop.

Namespace: BI.Search
Syntax
Delphi
public
 procedure Stop;
See Also

Reference

  • TDataSearch
  • BI.Search


TDataSearch Events

Events
Name | Description
OnFinished | Represents property OnFinished.
OnProgress | Represents property OnProgress.
Top


TDataSearch.OnFinished Event

Summary

Represents property OnFinished.

Namespace: BI.Search
Syntax
Delphi
public
 property OnFinished:TSearchFinished read FOnFinished write FOnFinished;

Value

Type: TSearchFinished

See Also

Reference

  • TDataSearch
  • BI.Search


TDataSearch.OnProgress Event

Summary

Represents property OnProgress.

Namespace: BI.Search
Syntax
Delphi
public
 property OnProgress:TSearchProgress read FOnProgress write FOnProgress;

Value

Type: TSearchProgress

See Also

Reference

  • TDataSearch
  • BI.Search


TDataSearch Fields

Fields
Name | Description
CaseSensitive | Represents field CaseSensitive.
DateTimeFormat | Represents field DateTimeFormat.
FloatFormat | Represents field FloatFormat.
Hits | Represents field Hits.
Index | Represents field Index.
Items | Represents field Items.
Source | Represents field Source.
TextPart | Represents field TextPart.
Top


TDataSearch.CaseSensitive Field

Summary

Represents field CaseSensitive.

Namespace: BI.Search
Syntax
Delphi
public
 CaseSensitive : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TDataSearch
  • BI.Search


TDataSearch.DateTimeFormat Field

Summary

Represents field DateTimeFormat.

Namespace: BI.Search
Syntax
Delphi
public
 DateTimeFormat,
 FloatFormat : String;

Field Value

Type: String

See Also

Reference

  • TDataSearch
  • BI.Search


TDataSearch.FloatFormat Field

Summary

Represents field FloatFormat.

Namespace: BI.Search
Syntax
Delphi
public
 DateTimeFormat,
 FloatFormat : String;

Field Value

Type: String

See Also

Reference

  • TDataSearch
  • BI.Search


TDataSearch.Hits Field

Summary

Represents field Hits.

Namespace: BI.Search
Syntax
Delphi
public
 Hits : TSearchHits;

Field Value

Type: TSearchHits

See Also

Reference

  • TDataSearch
  • BI.Search


TDataSearch.Index Field

Summary

Represents field Index.

Namespace: BI.Search
Syntax
Delphi
public
 Index : TCursorIndex;

Field Value

Type: TCursorIndex

See Also

Reference

  • TDataSearch
  • BI.Search


TDataSearch.Items Field

Summary

Represents field Items.

Namespace: BI.Search
Syntax
Delphi
public
 Items : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TDataSearch
  • BI.Search


TDataSearch.Source Field

Summary

Represents field Source.

Namespace: BI.Search
Syntax
Delphi
public
 Source : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TDataSearch
  • BI.Search


TDataSearch.TextPart Field

Summary

Represents field TextPart.

Namespace: BI.Search
Syntax
Delphi
public
 TextPart : TDataSearchPart;

Field Value

Type: TDataSearchPart

See Also

Reference

  • TDataSearch
  • BI.Search


TSearchHits Record

Summary

Represents type TSearchHits.

Namespace: BI.Search
Syntax
Delphi
type
 TSearchHits=record
 end;

The TSearchHits type exposes the following members.

Methods
Show:
Name | Description
Append(TDataItem,TInteger) | Represents method Append(TDataItem,TInteger).
Count | Represents method Count.
Exists(TInteger,TDataItem) | Represents method Exists(TInteger,TDataItem).
Find(TInteger,TInteger,TDataItem) | Represents method Find(TInteger,TInteger,TDataItem).
IndexOf(TInteger,TDataItem) | Represents method IndexOf(TInteger,TDataItem).
Top
Fields
Show:
Name | Description
Enabled | Represents field Enabled.
Items | Represents field Items.
Top
See Also

Reference

  • BI.Search


TSearchHits Methods

Methods
Name | Description
Append(TDataItem,TInteger) | Represents method Append(TDataItem,TInteger).
Count | Represents method Count.
Exists(TInteger,TDataItem) | Represents method Exists(TInteger,TDataItem).
Find(TInteger,TInteger,TDataItem) | Represents method Find(TInteger,TInteger,TDataItem).
IndexOf(TInteger,TDataItem) | Represents method IndexOf(TInteger,TDataItem).
Top


TSearchHits.Append(TDataItem,TInteger) Method

Summary

Represents method Append(TDataItem,TInteger).

Namespace: BI.Search
Syntax
Delphi
public
 procedure Append(const AItem:TDataItem; const ARow:TInteger); inline;

Parameters

AItem
Type: TDataItem

ARow
Type: System.Void

See Also

Reference

  • TSearchHits
  • BI.Search


TSearchHits.Count Method

Summary

Represents method Count.

Namespace: BI.Search
Syntax
Delphi
public
 function Count:TInteger;

Return Value

Type: TInteger

See Also

Reference

  • TSearchHits
  • BI.Search


TSearchHits.Exists(TInteger,TDataItem) Method

Summary

Represents method Exists(TInteger,TDataItem).

Namespace: BI.Search
Syntax
Delphi
public
 function Exists(const ARow:TInteger; const AData:TDataItem):Boolean;

Parameters

ARow
Type: System.Void

AData
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • TSearchHits
  • BI.Search


TSearchHits.Find(TInteger,TInteger,TDataItem) Method

Summary

Represents method Find(TInteger,TInteger,TDataItem).

Namespace: BI.Search
Syntax
Delphi
public
 procedure Find(const AIndex:TInteger; out ARow:TInteger; out AData:TDataItem);

Parameters

AIndex
Type: System.Void

ARow
Type: System.Void

AData
Type: TDataItem

See Also

Reference

  • TSearchHits
  • BI.Search


TSearchHits.IndexOf(TInteger,TDataItem) Method

Summary

Represents method IndexOf(TInteger,TDataItem).

Namespace: BI.Search
Syntax
Delphi
public
 function IndexOf(const ARow:TInteger; const AData:TDataItem):TInteger;

Parameters

ARow
Type: System.Void

AData
Type: TDataItem

Return Value

Type: TInteger

See Also

Reference

  • TSearchHits
  • BI.Search


TSearchHits Fields

Fields
Name | Description
Enabled | Represents field Enabled.
Items | Represents field Items.
Top


TSearchHits.Enabled Field

Summary

Represents field Enabled.

Namespace: BI.Search
Syntax
Delphi
public
 Enabled : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TSearchHits
  • BI.Search


TSearchHits.Items Field

Summary

Represents field Items.

Namespace: BI.Search
Syntax
Delphi
public
 Items : Array of TDataArray;

Field Value

Type: Array of TDataArray

See Also

Reference

  • TSearchHits
  • BI.Search


BI.Search Enumerations

Enumerations
Name | Description
TDataSearchPart | Represents type TDataSearchPart.
Top


TDataSearchPart Enumeration

Summary

Represents type TDataSearchPart.

Namespace: BI.Search
Syntax
Delphi
type
 TDataSearchPart=(Anywhere, AtStart, AtEnd, Exact);

The TDataSearchPart type exposes the following members.

Members
Show:
Name | Description
Anywhere | Represents constant Anywhere.
AtEnd | Represents constant AtEnd.
AtStart | Represents constant AtStart.
Exact | Represents constant Exact.
Top
See Also

Reference

  • BI.Search


BI.Search Delegates

Delegates
Name | Description
TMatchFunction | Represents type TMatchFunction.
TSearchFinished | Represents type TSearchFinished.
TSearchProgress | Represents type TSearchProgress.
Top


TMatchFunction Delegate

Summary

Represents type TMatchFunction.

Namespace: BI.Search
Syntax
Delphi
type
 TMatchFunction=function(const AText:String):Boolean of object;
See Also

Reference

  • BI.Search


TSearchFinished Delegate

Summary

Represents type TSearchFinished.

Namespace: BI.Search
Syntax
Delphi
type
 TSearchFinished=procedure(const AIndex:TCursorIndex) of object;
See Also

Reference

  • BI.Search


TSearchProgress Delegate

Summary

Represents type TSearchProgress.

Namespace: BI.Search
Syntax
Delphi
type
 TSearchProgress=procedure(var Stop:Boolean) of object;
See Also

Reference

  • BI.Search


BI.Search Types

Types
Name | Description
PDataSearch | Represents a pointer type to TDataSearch.
Top


PDataSearch Type

Summary

Represents a pointer type to TDataSearch.

Namespace: BI.Search
Syntax
Delphi
type
 PDataSearch=^TDataSearch;
See Also

Reference

  • BI.Search


BI.SingleRecord Namespace

Summary

Represents namespace BI.SingleRecord.

Classes
Name | Description
TDataItemAccess | Represents type TDataItemAccess.
TSingleRecord | Represents type TSingleRecord.
Top


BI.SingleRecord Classes

Classes
Name | Description
TDataItemAccess | Represents type TDataItemAccess.
TSingleRecord | Represents type TSingleRecord.
Top


TDataItemAccess Class

Summary

Represents type TDataItemAccess.

Namespace: BI.SingleRecord
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.SingleRecord.TDataItemAccess
Syntax
Delphi
type
 TDataItemAccess=class(TDataItem);
See Also

Reference

  • BI.SingleRecord


TSingleRecord Class

Summary

Represents type TSingleRecord.

Namespace: BI.SingleRecord
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TSingleSourceProvider
BI.SingleRecord.TSingleRecord
Syntax
Delphi
type
 TSingleRecord=class(TSingleSourceProvider)
 end;

The TSingleRecord type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TSingleRecord class. (Overrides TSingleSourceProvider.Create(TComponent).)
Top
Properties
Show:
Name | Description
Row | Represents property Row.
Top
Methods
Show:
Name | Description
ClearSource | Represents method ClearSource. (Overrides TSingleSourceProvider.ClearSource.)
From(TDataItem,TInteger) | Represents method From(TDataItem,TInteger).
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
SetSource(TDataItem) | Represents method SetSource(TDataItem). (Overrides TSingleSourceProvider.SetSource(TDataItem).)
Top
See Also

Reference

  • BI.SingleRecord


TSingleRecord Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TSingleRecord class. (Overrides TSingleSourceProvider.Create(TComponent).)
Top


TSingleRecord.Create(TComponent) Constructor

Summary

Initializes a new instance of the TSingleRecord class.

Namespace: BI.SingleRecord
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TSingleSourceProvider.Create(TComponent)
See Also

Reference

  • TSingleRecord
  • BI.SingleRecord


TSingleRecord Properties

Properties
Name | Description
Row | Represents property Row.
Top


TSingleRecord.Row Property

Summary

Represents property Row.

Namespace: BI.SingleRecord
Syntax
Delphi
published
 property Row:TInteger read FRow write SetRow;

Property Value

Type: TInteger

See Also

Reference

  • TSingleRecord
  • BI.SingleRecord


TSingleRecord Methods

Methods
Name | Description
ClearSource | Represents method ClearSource. (Overrides TSingleSourceProvider.ClearSource.)
From(TDataItem,TInteger) | Represents method From(TDataItem,TInteger).
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
SetSource(TDataItem) | Represents method SetSource(TDataItem). (Overrides TSingleSourceProvider.SetSource(TDataItem).)
Top


TSingleRecord.ClearSource Method

Summary

Represents method ClearSource.

Namespace: BI.SingleRecord
Syntax
Delphi
protected
 procedure ClearSource; override;

Overrides

TSingleSourceProvider.ClearSource
See Also

Reference

  • TSingleRecord
  • BI.SingleRecord


TSingleRecord.From(TDataItem,TInteger) Method

Summary

Represents method From(TDataItem,TInteger).

Namespace: BI.SingleRecord
Syntax
Delphi
public
 class function From(const AData:TDataItem; const ARow:TInteger):TDataItem; static;

Parameters

AData
Type: TDataItem

ARow
Type: System.Void

Return Value

Type: TDataItem

See Also

Reference

  • TSingleRecord
  • BI.SingleRecord


TSingleRecord.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.SingleRecord
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TSingleRecord
  • BI.SingleRecord


TSingleRecord.SetSource(TDataItem) Method

Summary

Represents method SetSource(TDataItem).

Namespace: BI.SingleRecord
Syntax
Delphi
protected
 procedure SetSource(const Value: TDataItem); override;

Parameters

Value
Type: TDataItem

Overrides

TSingleSourceProvider.SetSource(TDataItem)
See Also

Reference

  • TSingleRecord
  • BI.SingleRecord


BI.SQL Namespace

Summary

Represents namespace BI.SQL.

Classes
Name | Description
ESQLParser | Represents type ESQLParser.
TBIQueryAccess | Represents type TBIQueryAccess.
TSQLParser | Represents type TSQLParser.
Top
Records
Name | Description
TBISQL | Represents type TBISQL.
Top
Types
Name | Description
TGetDataProc | Represents type TGetDataProc.
Top
Routines
Name | Description
AsName(String) | Represents method AsName(String).
EscapedName(String) | Overloaded. Represents method EscapedName(String).
EscapedName(TDataItem) | Overloaded. Represents method EscapedName(TDataItem).
IsClause(String) | Represents method IsClause(String).
IsQuoted(String) | Represents method IsQuoted(String).
NameOfItem(TDataItem,TDataItem,TDataArray) | Represents method NameOfItem(TDataItem,TDataItem,TDataArray).
ParentAndName(TDataItem) | Represents method ParentAndName(TDataItem).
ReplaceDots(String) | Represents method ReplaceDots(String).
SplitIdents(String) | Represents method SplitIdents(String).
UnBracket(String) | Represents method UnBracket(String).
UnParen(String) | Represents method UnParen(String).
Top


BI.SQL Classes

Classes
Name | Description
ESQLParser | Represents type ESQLParser.
TBIQueryAccess | Represents type TBIQueryAccess.
TSQLParser | Represents type TSQLParser.
Top


ESQLParser Class

Summary

Represents type ESQLParser.

Namespace: BI.SQL
Inheritance Hierarchy
Exception
BI.Arrays.EBIException
BI.SQL.ESQLParser
Syntax
Delphi
type
 ESQLParser=class(EBIException);
See Also

Reference

  • BI.SQL


TBIQueryAccess Class

Summary

Represents type TBIQueryAccess.

Namespace: BI.SQL
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Persist.TBaseDataImporter
BI.Query.TBIQuery
BI.SQL.TBIQueryAccess
Syntax
Delphi
type
 TBIQueryAccess=class(TBIQuery);
See Also

Reference

  • BI.SQL


TSQLParser Class

Summary

Represents type TSQLParser.

Namespace: BI.SQL
Inheritance Hierarchy
TObject
BI.SQL.TSQLParser
Syntax
Delphi
type
 TSQLParser=class
 end;

The TSQLParser type exposes the following members.

Constructors
Show:
Name | Description
Create(TDataItem,String) | Initializes a new instance of the TSQLParser class.
Top
Methods
Show:
Name | Description
Calculate(TBIErrorProc) | Represents method Calculate(TBIErrorProc).
DataFrom(TDataProvider) | Represents method DataFrom(TDataProvider).
DataFromString(TDataItem,String) | Represents method DataFromString(TDataItem,String).
FindAggregate(String,TAggregate) | Represents method FindAggregate(String,TAggregate).
FindGroupByPart(String,TDateTimePart) | Represents method FindGroupByPart(String,TDateTimePart).
GetFunction(String,String) | Represents method GetFunction(String,String).
Parse(TBIErrorProc) | Represents method Parse(TBIErrorProc).
ParseSort(TDataItem,TSortItems,TTextArray,Boolean,TBIErrorProc) | Represents method ParseSort(TDataItem,TSortItems,TTextArray,Boolean,TBIErrorProc).
StringToData(TDataItem,String,TBIErrorProc) | Represents method StringToData(TDataItem,String,TBIErrorProc).
Top
Events
Show:
Name | Description
OnGetData | Represents property OnGetData.
Top
See Also

Reference

  • BI.SQL


TSQLParser Constructors

Constructors
Name | Description
Create(TDataItem,String) | Initializes a new instance of the TSQLParser class.
Top


TSQLParser.Create(TDataItem,String) Constructor

Summary

Initializes a new instance of the TSQLParser class.

Namespace: BI.SQL
Syntax
Delphi
public
 Constructor Create(const AData:TDataItem; const AText:String);

Parameters

AData
Type: TDataItem

AText
Type: String

See Also

Reference

  • TSQLParser
  • BI.SQL


TSQLParser Methods

Methods
Name | Description
Calculate(TBIErrorProc) | Represents method Calculate(TBIErrorProc).
DataFrom(TDataProvider) | Represents method DataFrom(TDataProvider).
DataFromString(TDataItem,String) | Represents method DataFromString(TDataItem,String).
FindAggregate(String,TAggregate) | Represents method FindAggregate(String,TAggregate).
FindGroupByPart(String,TDateTimePart) | Represents method FindGroupByPart(String,TDateTimePart).
GetFunction(String,String) | Represents method GetFunction(String,String).
Parse(TBIErrorProc) | Represents method Parse(TBIErrorProc).
ParseSort(TDataItem,TSortItems,TTextArray,Boolean,TBIErrorProc) | Represents method ParseSort(TDataItem,TSortItems,TTextArray,Boolean,TBIErrorProc).
StringToData(TDataItem,String,TBIErrorProc) | Represents method StringToData(TDataItem,String,TBIErrorProc).
Top


TSQLParser.Calculate(TBIErrorProc) Method

Summary

Represents method Calculate(TBIErrorProc).

Namespace: BI.SQL
Syntax
Delphi
public
 function Calculate(const ErrorProc:TBIErrorProc=nil):TDataItem;

Parameters

ErrorProc
Type: TBIErrorProc

Return Value

Type: TDataItem

See Also

Reference

  • TSQLParser
  • BI.SQL


TSQLParser.DataFrom(TDataProvider) Method

Summary

Represents method DataFrom(TDataProvider).

Namespace: BI.SQL
Syntax
Delphi
public
 class function DataFrom(const AProvider:TDataProvider): TDataItem; static;

Parameters

AProvider
Type: TDataProvider

Return Value

Type: TDataItem

See Also

Reference

  • TSQLParser
  • BI.SQL


TSQLParser.DataFromString(TDataItem,String) Method

Summary

Represents method DataFromString(TDataItem,String).

Namespace: BI.SQL
Syntax
Delphi
protected
 class function DataFromString(const AData:TDataItem; const S:String):TDataItem; static;

Parameters

AData
Type: TDataItem

S
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TSQLParser
  • BI.SQL


TSQLParser.FindAggregate(String,TAggregate) Method

Summary

Represents method FindAggregate(String,TAggregate).

Namespace: BI.SQL
Syntax
Delphi
public
 class function FindAggregate(var S:String; out Agg:TAggregate):Boolean; static;

Parameters

S
Type: String

Agg
Type: TAggregate

Return Value

Type: Boolean

See Also

Reference

  • TSQLParser
  • BI.SQL


TSQLParser.FindGroupByPart(String,TDateTimePart) Method

Summary

Represents method FindGroupByPart(String,TDateTimePart).

Namespace: BI.SQL
Syntax
Delphi
public
 class function FindGroupByPart(var S:String; out APart:TDateTimePart):Boolean; static;

Parameters

S
Type: String

APart
Type: TDateTimePart

Return Value

Type: Boolean

See Also

Reference

  • TSQLParser
  • BI.SQL


TSQLParser.GetFunction(String,String) Method

Summary

Represents method GetFunction(String,String).

Namespace: BI.SQL
Syntax
Delphi
public
 class function GetFunction(var S:String; out AFunc:String):Boolean; static;

Parameters

S
Type: String

AFunc
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TSQLParser
  • BI.SQL


TSQLParser.Parse(TBIErrorProc) Method

Summary

Represents method Parse(TBIErrorProc).

Namespace: BI.SQL
Syntax
Delphi
public
 function Parse(const ErrorProc:TBIErrorProc=nil):TDataProvider;

Parameters

ErrorProc
Type: TBIErrorProc

Return Value

Type: TDataProvider

See Also

Reference

  • TSQLParser
  • BI.SQL


TSQLParser.ParseSort(TDataItem,TSortItems,TTextArray,Boolean,TBIErrorProc) Method

Summary

Represents method ParseSort(TDataItem,TSortItems,TTextArray,Boolean,TBIErrorProc).

Namespace: BI.SQL
Syntax
Delphi
public
 class procedure ParseSort(const AData:TDataItem; var ASort:TSortItems; const AOrder:TTextArray;
 const SQL:Boolean=False;
 const Error:TBIErrorProc=nil); static;

Parameters

AData
Type: TDataItem

ASort
Type: TSortItems

AOrder
Type: TTextArray

SQL
Type: Boolean

Error
Type: TBIErrorProc

See Also

Reference

  • TSQLParser
  • BI.SQL


TSQLParser.StringToData(TDataItem,String,TBIErrorProc) Method

Summary

Represents method StringToData(TDataItem,String,TBIErrorProc).

Namespace: BI.SQL
Syntax
Delphi
public
 class function StringToData(const AData:TDataItem; const S:String; const ErrorProc:TBIErrorProc=nil):TDataItem; static;

Parameters

AData
Type: TDataItem

S
Type: String

ErrorProc
Type: TBIErrorProc

Return Value

Type: TDataItem

See Also

Reference

  • TSQLParser
  • BI.SQL


TSQLParser Events

Events
Name | Description
OnGetData | Represents property OnGetData.
Top


TSQLParser.OnGetData Event

Summary

Represents property OnGetData.

Namespace: BI.SQL
Syntax
Delphi
public
 property OnGetData:TGetDataProc read FOnGetData write FOnGetData;

Value

Type: TGetDataProc

See Also

Reference

  • TSQLParser
  • BI.SQL


BI.SQL Records

Records
Name | Description
TBISQL | Represents type TBISQL.
Top


TBISQL Record

Summary

Represents type TBISQL.

Namespace: BI.SQL
Syntax
Delphi
type
 TBISQL=record
 end;

The TBISQL type exposes the following members.

Methods
Show:
Name | Description
From(TDataItem) | Overloaded. Represents method From(TDataItem).
From(TDataItem,String,TGetDataProc,TBIErrorProc) | Overloaded. Represents method From(TDataItem,String,TGetDataProc,TBIErrorProc).
From(TDataProvider) | Overloaded. Represents method From(TDataProvider).
ProviderFrom(TDataItem,String,TGetDataProc,TBIErrorProc) | Overloaded. Represents method ProviderFrom(TDataItem,String,TGetDataProc,TBIErrorProc).
Top
See Also

Reference

  • BI.SQL


TBISQL Methods

Methods
Name | Description
From(TDataItem) | Overloaded. Represents method From(TDataItem).
From(TDataItem,String,TGetDataProc,TBIErrorProc) | Overloaded. Represents method From(TDataItem,String,TGetDataProc,TBIErrorProc).
From(TDataProvider) | Overloaded. Represents method From(TDataProvider).
ProviderFrom(TDataItem,String,TGetDataProc,TBIErrorProc) | Overloaded. Represents method ProviderFrom(TDataItem,String,TGetDataProc,TBIErrorProc).
Top


TBISQL.From(TDataItem) Method

Summary

Represents method From(TDataItem).

Namespace: BI.SQL
Syntax
Delphi
public
 class function From(const AData:TDataItem):String; overload; static;

Parameters

AData
Type: TDataItem

Return Value

Type: String

See Also

Reference

  • TBISQL
  • BI.SQL


TBISQL.From(TDataItem,String,TGetDataProc,TBIErrorProc) Method

Summary

Represents method From(TDataItem,String,TGetDataProc,TBIErrorProc).

Namespace: BI.SQL
Syntax
Delphi
public
 class function From(const AData:TDataItem; const SQL:String;
 const GetData:TGetDataProc=nil;
 const ErrorProc:TBIErrorProc=nil):TDataItem; overload; static;

Parameters

AData
Type: TDataItem

SQL
Type: String

GetData
Type: TGetDataProc

ErrorProc
Type: TBIErrorProc

Return Value

Type: TDataItem

See Also

Reference

  • TBISQL
  • BI.SQL


TBISQL.From(TDataProvider) Method

Summary

Represents method From(TDataProvider).

Namespace: BI.SQL
Syntax
Delphi
public
 class function From(const AProvider:TDataProvider):String; overload; static;

Parameters

AProvider
Type: TDataProvider

Return Value

Type: String

See Also

Reference

  • TBISQL
  • BI.SQL


TBISQL.ProviderFrom(TDataItem,String,TGetDataProc,TBIErrorProc) Method

Summary

Represents method ProviderFrom(TDataItem,String,TGetDataProc,TBIErrorProc).

Namespace: BI.SQL
Syntax
Delphi
public
 class function ProviderFrom(const AData:TDataItem; const SQL:String;
 const GetData:TGetDataProc=nil;
 const ErrorProc:TBIErrorProc=nil):TDataProvider; overload; static;

Parameters

AData
Type: TDataItem

SQL
Type: String

GetData
Type: TGetDataProc

ErrorProc
Type: TBIErrorProc

Return Value

Type: TDataProvider

See Also

Reference

  • TBISQL
  • BI.SQL


BI.SQL Types

Types
Name | Description
TGetDataProc | Represents type TGetDataProc.
Top


TGetDataProc Type

Summary

Represents type TGetDataProc.

Namespace: BI.SQL
Syntax
Delphi
type
 TGetDataProc=
 reference to procedure(const AName:String; out AData:TDataItem);
See Also

Reference

  • BI.SQL


BI.SQL Routines

Routines
Name | Description
AsName(String) | Represents method AsName(String).
EscapedName(String) | Overloaded. Represents method EscapedName(String).
EscapedName(TDataItem) | Overloaded. Represents method EscapedName(TDataItem).
IsClause(String) | Represents method IsClause(String).
IsQuoted(String) | Represents method IsQuoted(String).
NameOfItem(TDataItem,TDataItem,TDataArray) | Represents method NameOfItem(TDataItem,TDataItem,TDataArray).
ParentAndName(TDataItem) | Represents method ParentAndName(TDataItem).
ReplaceDots(String) | Represents method ReplaceDots(String).
SplitIdents(String) | Represents method SplitIdents(String).
UnBracket(String) | Represents method UnBracket(String).
UnParen(String) | Represents method UnParen(String).
Top


AsName(String) Method

Summary

Represents method AsName(String).

Namespace: BI.SQL
Syntax
Delphi
function AsName(const AName:String):String;

Parameters

AName
Type: String

Return Value

Type: String

See Also

Reference

  • BI.SQL


EscapedName(String) Method

Summary

Represents method EscapedName(String).

Namespace: BI.SQL
Syntax
Delphi
function EscapedName(const AName:String):String; overload;

Parameters

AName
Type: String

Return Value

Type: String

See Also

Reference

  • BI.SQL


EscapedName(TDataItem) Method

Summary

Represents method EscapedName(TDataItem).

Namespace: BI.SQL
Syntax
Delphi
function EscapedName(const AData:TDataItem):String; overload;

Parameters

AData
Type: TDataItem

Return Value

Type: String

See Also

Reference

  • BI.SQL


IsClause(String) Method

Summary

Represents method IsClause(String).

Namespace: BI.SQL
Syntax
Delphi
function IsClause(const AText:String):Boolean;

Parameters

AText
Type: String

Return Value

Type: Boolean

See Also

Reference

  • BI.SQL


IsQuoted(String) Method

Summary

Represents method IsQuoted(String).

Namespace: BI.SQL
Syntax
Delphi
function IsQuoted(const S:String):Boolean;

Parameters

S
Type: String

Return Value

Type: Boolean

See Also

Reference

  • BI.SQL


NameOfItem(TDataItem,TDataItem,TDataArray) Method

Summary

Represents method NameOfItem(TDataItem,TDataItem,TDataArray).

Namespace: BI.SQL
Syntax
Delphi
function NameOfItem(const AMain,AItem:TDataItem; var AData:TDataArray):String;

Parameters

AMain
Type: TDataItem

AItem
Type: TDataItem

AData
Type: TDataArray

Return Value

Type: String

See Also

Reference

  • BI.SQL


ParentAndName(TDataItem) Method

Summary

Represents method ParentAndName(TDataItem).

Namespace: BI.SQL
Syntax
Delphi
function ParentAndName(const AItem:TDataItem):String;

Parameters

AItem
Type: TDataItem

Return Value

Type: String

See Also

Reference

  • BI.SQL


ReplaceDots(String) Method

Summary

Represents method ReplaceDots(String).

Namespace: BI.SQL
Syntax
Delphi
function ReplaceDots(const S:String):String;

Parameters

S
Type: String

Return Value

Type: String

See Also

Reference

  • BI.SQL


SplitIdents(String) Method

Summary

Represents method SplitIdents(String).

Namespace: BI.SQL
Syntax
Delphi
function SplitIdents(const S:String):TArrayOfStrings;

Parameters

S
Type: String

Return Value

Type: TArrayOfStrings

See Also

Reference

  • BI.SQL


UnBracket(String) Method

Summary

Represents method UnBracket(String).

Namespace: BI.SQL
Syntax
Delphi
function UnBracket(const S:String):String;

Parameters

S
Type: String

Return Value

Type: String

See Also

Reference

  • BI.SQL


UnParen(String) Method

Summary

Represents method UnParen(String).

Namespace: BI.SQL
Syntax
Delphi
function UnParen(const S:String):String;

Parameters

S
Type: String

Return Value

Type: String

See Also

Reference

  • BI.SQL


BI.SqlDB Namespace

Summary

Represents namespace BI.SqlDB.

Classes
Name | Description
TDBSqlDBEngine | Represents type TDBSqlDBEngine.
Top


BI.SqlDB Classes

Classes
Name | Description
TDBSqlDBEngine | Represents type TDBSqlDBEngine.
Top


TDBSqlDBEngine Class

Summary

Represents type TDBSqlDBEngine.

Namespace: BI.SqlDB
Inheritance Hierarchy
TObject
BI.DB.TBIDBEngine
BI.SqlDB.TDBSqlDBEngine
Syntax
Delphi
type
 TDBSqlDBEngine=class(TBIDBEngine)
 end;

The TDBSqlDBEngine type exposes the following members.

Constants
Show:
Name | Description
DBDriverNames | Represents constant DBDriverNames.
DBDrivers | Represents constant DBDrivers.
Top
Methods
Show:
Name | Description
CloneConnection(TCustomConnection) | Represents method CloneConnection(TCustomConnection). (Overrides TBIDBEngine.CloneConnection(TCustomConnection).)
CreateConnection(TComponent,String) | Overloaded. Represents method CreateConnection(TComponent,String).
CreateConnection(TDataDefinition) | Represents method CreateConnection(TDataDefinition). (Overrides TBIDBEngine.CreateConnection(TDataDefinition).)
CreateDataSet(TComponent,TDataItem) | Represents method CreateDataSet(TComponent,TDataItem). (Overrides TBIDBEngine.CreateDataSet(TComponent,TDataItem).)
CreateQuery(TCustomConnection,String) | Represents method CreateQuery(TCustomConnection,String). (Overrides TBIDBEngine.CreateQuery(TCustomConnection,String).)
DriverNames | Represents method DriverNames. (Overrides TBIDBEngine.DriverNames.)
DriverToName(String) | Represents method DriverToName(String). (Overrides TBIDBEngine.DriverToName(String).)
FileFilter | Represents method FileFilter. (Overrides TBIDBEngine.FileFilter.)
GetConnectionName(TCustomConnection) | Represents method GetConnectionName(TCustomConnection). (Overrides TBIDBEngine.GetConnectionName(TCustomConnection).)
GetDriver(Integer) | Represents method GetDriver(Integer). (Overrides TBIDBEngine.GetDriver(Integer).)
GetItemNames(TCustomConnection,Boolean,Boolean) | Represents method GetItemNames(TCustomConnection,Boolean,Boolean). (Overrides TBIDBEngine.GetItemNames(TCustomConnection,Boolean,Boolean).)
GetKeyFieldNames(TCustomConnection,String) | Represents method GetKeyFieldNames(TCustomConnection,String). (Overrides TBIDBEngine.GetKeyFieldNames(TCustomConnection,String).)
GetSchemas(TCustomConnection) | Represents method GetSchemas(TCustomConnection).
GetTable(TCustomConnection,String) | Represents method GetTable(TCustomConnection,String). (Overrides TBIDBEngine.GetTable(TCustomConnection,String).)
GuessForeignKeys(String,TDataSet,TDataItem,TBISource) | Represents method GuessForeignKeys(String,TDataSet,TDataItem,TBISource). (Overrides TBIDBEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource).)
ImportFile(TBIDB,String) | Represents method ImportFile(TBIDB,String). (Overrides TBIDBEngine.ImportFile(TBIDB,String).)
Supports(String) | Represents method Supports(String). (Overrides TBIDBEngine.Supports(String).)
Tester | Represents method Tester. (Overrides TBIDBEngine.Tester.)
Top
See Also

Reference

  • BI.SqlDB


TDBSqlDBEngine Constants

Constants
Name | Description
DBDriverNames | Represents constant DBDriverNames.
DBDrivers | Represents constant DBDrivers.
Top


TDBSqlDBEngine.DBDriverNames Constant

Summary

Represents constant DBDriverNames.

Namespace: BI.SqlDB
Syntax
Delphi
public
 DBDriverNames:Array[0..7] of String=('SQLite','MySQL','Oracle','Microsoft SQL Server',
 'ODBC','Embarcadero Interbase','Firebird','Postgres');

Value

Type: Array[0..7] of String

See Also

Reference

  • TDBSqlDBEngine
  • BI.SqlDB


TDBSqlDBEngine.DBDrivers Constant

Summary

Represents constant DBDrivers.

Namespace: BI.SqlDB
Syntax
Delphi
public
 DBDrivers:Array[0..7] of String=('SQLite','MySQL','Ora','MSSQL','ODBC','IB','FB','Postgres');

Value

Type: Array[0..7] of String

See Also

Reference

  • TDBSqlDBEngine
  • BI.SqlDB


TDBSqlDBEngine Methods

Methods
Name | Description
CloneConnection(TCustomConnection) | Represents method CloneConnection(TCustomConnection). (Overrides TBIDBEngine.CloneConnection(TCustomConnection).)
CreateConnection(TComponent,String) | Overloaded. Represents method CreateConnection(TComponent,String).
CreateConnection(TDataDefinition) | Represents method CreateConnection(TDataDefinition). (Overrides TBIDBEngine.CreateConnection(TDataDefinition).)
CreateDataSet(TComponent,TDataItem) | Represents method CreateDataSet(TComponent,TDataItem). (Overrides TBIDBEngine.CreateDataSet(TComponent,TDataItem).)
CreateQuery(TCustomConnection,String) | Represents method CreateQuery(TCustomConnection,String). (Overrides TBIDBEngine.CreateQuery(TCustomConnection,String).)
DriverNames | Represents method DriverNames. (Overrides TBIDBEngine.DriverNames.)
DriverToName(String) | Represents method DriverToName(String). (Overrides TBIDBEngine.DriverToName(String).)
FileFilter | Represents method FileFilter. (Overrides TBIDBEngine.FileFilter.)
GetConnectionName(TCustomConnection) | Represents method GetConnectionName(TCustomConnection). (Overrides TBIDBEngine.GetConnectionName(TCustomConnection).)
GetDriver(Integer) | Represents method GetDriver(Integer). (Overrides TBIDBEngine.GetDriver(Integer).)
GetItemNames(TCustomConnection,Boolean,Boolean) | Represents method GetItemNames(TCustomConnection,Boolean,Boolean). (Overrides TBIDBEngine.GetItemNames(TCustomConnection,Boolean,Boolean).)
GetKeyFieldNames(TCustomConnection,String) | Represents method GetKeyFieldNames(TCustomConnection,String). (Overrides TBIDBEngine.GetKeyFieldNames(TCustomConnection,String).)
GetSchemas(TCustomConnection) | Represents method GetSchemas(TCustomConnection).
GetTable(TCustomConnection,String) | Represents method GetTable(TCustomConnection,String). (Overrides TBIDBEngine.GetTable(TCustomConnection,String).)
GuessForeignKeys(String,TDataSet,TDataItem,TBISource) | Represents method GuessForeignKeys(String,TDataSet,TDataItem,TBISource). (Overrides TBIDBEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource).)
ImportFile(TBIDB,String) | Represents method ImportFile(TBIDB,String). (Overrides TBIDBEngine.ImportFile(TBIDB,String).)
Supports(String) | Represents method Supports(String). (Overrides TBIDBEngine.Supports(String).)
Tester | Represents method Tester. (Overrides TBIDBEngine.Tester.)
Top


TDBSqlDBEngine.CloneConnection(TCustomConnection) Method

Summary

Represents method CloneConnection(TCustomConnection).

Namespace: BI.SqlDB
Syntax
Delphi
public
 class function CloneConnection(const AConn:TCustomConnection): TCustomConnection; override;

Parameters

AConn
Type: TCustomConnection

Return Value

Type: TCustomConnection

Overrides

TBIDBEngine.CloneConnection(TCustomConnection)
See Also

Reference

  • TDBSqlDBEngine
  • BI.SqlDB


TDBSqlDBEngine.CreateConnection(TComponent,String) Method

Summary

Represents method CreateConnection(TComponent,String).

Namespace: BI.SqlDB
Syntax
Delphi
protected
 class function CreateConnection(const AOwner:TComponent; const ADriver:String):TSQLConnection; overload; static;

Parameters

AOwner
Type: TComponent

ADriver
Type: String

Return Value

Type: TSQLConnection

See Also

Reference

  • TDBSqlDBEngine
  • BI.SqlDB


TDBSqlDBEngine.CreateConnection(TDataDefinition) Method

Summary

Represents method CreateConnection(TDataDefinition).

Namespace: BI.SqlDB
Syntax
Delphi
public
 class function CreateConnection(const Definition:TDataDefinition):TCustomConnection; override;

Parameters

Definition
Type: TDataDefinition

Return Value

Type: TCustomConnection

Overrides

TBIDBEngine.CreateConnection(TDataDefinition)
See Also

Reference

  • TDBSqlDBEngine
  • BI.SqlDB


TDBSqlDBEngine.CreateDataSet(TComponent,TDataItem) Method

Summary

Represents method CreateDataSet(TComponent,TDataItem).

Namespace: BI.SqlDB
Syntax
Delphi
public
 class function CreateDataSet(const AOwner:TComponent; const AData:TDataItem):TDataSet; override;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

Return Value

Type: TDataSet

Overrides

TBIDBEngine.CreateDataSet(TComponent,TDataItem)
See Also

Reference

  • TDBSqlDBEngine
  • BI.SqlDB


TDBSqlDBEngine.CreateQuery(TCustomConnection,String) Method

Summary

Represents method CreateQuery(TCustomConnection,String).

Namespace: BI.SqlDB
Syntax
Delphi
public
 class function CreateQuery(const AConnection:TCustomConnection; const SQL:String):TDataSet; override;

Parameters

AConnection
Type: TCustomConnection

SQL
Type: String

Return Value

Type: TDataSet

Overrides

TBIDBEngine.CreateQuery(TCustomConnection,String)
See Also

Reference

  • TDBSqlDBEngine
  • BI.SqlDB


TDBSqlDBEngine.DriverNames Method

Summary

Represents method DriverNames.

Namespace: BI.SqlDB
Syntax
Delphi
public
 class function DriverNames:TStringDynArray; override;

Return Value

Type: TStringDynArray

Overrides

TBIDBEngine.DriverNames
See Also

Reference

  • TDBSqlDBEngine
  • BI.SqlDB


TDBSqlDBEngine.DriverToName(String) Method

Summary

Represents method DriverToName(String).

Namespace: BI.SqlDB
Syntax
Delphi
public
 class function DriverToName(const ADriver:String):String; override;

Parameters

ADriver
Type: String

Return Value

Type: String

Overrides

TBIDBEngine.DriverToName(String)
See Also

Reference

  • TDBSqlDBEngine
  • BI.SqlDB


TDBSqlDBEngine.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.SqlDB
Syntax
Delphi
public
 class function FileFilter: TFileFilters; override;

Return Value

Type: TFileFilters

Overrides

TBIDBEngine.FileFilter
See Also

Reference

  • TDBSqlDBEngine
  • BI.SqlDB


TDBSqlDBEngine.GetConnectionName(TCustomConnection) Method

Summary

Represents method GetConnectionName(TCustomConnection).

Namespace: BI.SqlDB
Syntax
Delphi
public
 class function GetConnectionName(const AConnection:TCustomConnection):String; override;

Parameters

AConnection
Type: TCustomConnection

Return Value

Type: String

Overrides

TBIDBEngine.GetConnectionName(TCustomConnection)
See Also

Reference

  • TDBSqlDBEngine
  • BI.SqlDB


TDBSqlDBEngine.GetDriver(Integer) Method

Summary

Represents method GetDriver(Integer).

Namespace: BI.SqlDB
Syntax
Delphi
public
 class function GetDriver(const AIndex:Integer):String; override;

Parameters

AIndex
Type: Integer

Return Value

Type: String

Overrides

TBIDBEngine.GetDriver(Integer)
See Also

Reference

  • TDBSqlDBEngine
  • BI.SqlDB


TDBSqlDBEngine.GetItemNames(TCustomConnection,Boolean,Boolean) Method

Summary

Represents method GetItemNames(TCustomConnection,Boolean,Boolean).

Namespace: BI.SqlDB
Syntax
Delphi
public
 class function GetItemNames(const AConnection:TCustomConnection;
 const IncludeSystem,IncludeViews:Boolean):TStrings; override;

Parameters

AConnection
Type: TCustomConnection

IncludeSystem
Type: Boolean

IncludeViews
Type: Boolean

Return Value

Type: TStrings

Overrides

TBIDBEngine.GetItemNames(TCustomConnection,Boolean,Boolean)
See Also

Reference

  • TDBSqlDBEngine
  • BI.SqlDB


TDBSqlDBEngine.GetKeyFieldNames(TCustomConnection,String) Method

Summary

Represents method GetKeyFieldNames(TCustomConnection,String).

Namespace: BI.SqlDB
Syntax
Delphi
public
 class function GetKeyFieldNames(const AConnection:TCustomConnection; const ATable:String):TStrings; override;

Parameters

AConnection
Type: TCustomConnection

ATable
Type: String

Return Value

Type: TStrings

Overrides

TBIDBEngine.GetKeyFieldNames(TCustomConnection,String)
See Also

Reference

  • TDBSqlDBEngine
  • BI.SqlDB


TDBSqlDBEngine.GetSchemas(TCustomConnection) Method

Summary

Represents method GetSchemas(TCustomConnection).

Namespace: BI.SqlDB
Syntax
Delphi
public
 class function GetSchemas(const AConnection:TCustomConnection):TStrings;

Parameters

AConnection
Type: TCustomConnection

Return Value

Type: TStrings

See Also

Reference

  • TDBSqlDBEngine
  • BI.SqlDB


TDBSqlDBEngine.GetTable(TCustomConnection,String) Method

Summary

Represents method GetTable(TCustomConnection,String).

Namespace: BI.SqlDB
Syntax
Delphi
public
 class function GetTable(const AConnection:TCustomConnection; const AName:String):TDataSet; override;

Parameters

AConnection
Type: TCustomConnection

AName
Type: String

Return Value

Type: TDataSet

Overrides

TBIDBEngine.GetTable(TCustomConnection,String)
See Also

Reference

  • TDBSqlDBEngine
  • BI.SqlDB


TDBSqlDBEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource) Method

Summary

Represents method GuessForeignKeys(String,TDataSet,TDataItem,TBISource).

Namespace: BI.SqlDB
Syntax
Delphi
public
 class procedure GuessForeignKeys(const AName:String; const Table:TDataSet; const AData:TDataItem; const Source:TBISource); override;

Parameters

AName
Type: String

Table
Type: TDataSet

AData
Type: TDataItem

Source
Type: TBISource

Overrides

TBIDBEngine.GuessForeignKeys(String,TDataSet,TDataItem,TBISource)
See Also

Reference

  • TDBSqlDBEngine
  • BI.SqlDB


TDBSqlDBEngine.ImportFile(TBIDB,String) Method

Summary

Represents method ImportFile(TBIDB,String).

Namespace: BI.SqlDB
Syntax
Delphi
public
 class function ImportFile(const Source:TBIDB; const AFileName:String):TDataArray; override;

Parameters

Source
Type: TBIDB

AFileName
Type: String

Return Value

Type: TDataArray

Overrides

TBIDBEngine.ImportFile(TBIDB,String)
See Also

Reference

  • TDBSqlDBEngine
  • BI.SqlDB


TDBSqlDBEngine.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.SqlDB
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIDBEngine.Supports(String)
See Also

Reference

  • TDBSqlDBEngine
  • BI.SqlDB


TDBSqlDBEngine.Tester Method

Summary

Represents method Tester.

Namespace: BI.SqlDB
Syntax
Delphi
public
 class function Tester:TBIDBTesterClass; override;

Return Value

Type: TBIDBTesterClass

Overrides

TBIDBEngine.Tester
See Also

Reference

  • TDBSqlDBEngine
  • BI.SqlDB


BI.Store.Component Namespace

Summary

Represents namespace BI.Store.Component.

Classes
Name | Description
TBIDataLink | Represents type TBIDataLink.
TComponentImporter | Represents type TComponentImporter.
TDataAccess | Represents type TDataAccess.
Top
Types
Name | Description
TComponentImporterClass | Represents type TComponentImporterClass.
Top
Variables
Name | Description
ImportCache | Represents variable ImportCache.
Top
Routines
Name | Description
AddToCache(TComponentImporter) | Represents method AddToCache(TComponentImporter).
DestroyCache | Represents method DestroyCache.
FindCache(TComponent) | Represents method FindCache(TComponent).
Top


BI.Store.Component Classes

Classes
Name | Description
TBIDataLink | Represents type TBIDataLink.
TComponentImporter | Represents type TComponentImporter.
TDataAccess | Represents type TDataAccess.
Top


TBIDataLink Class

Summary

Represents type TBIDataLink.

Namespace: BI.Store.Component
Inheritance Hierarchy
TDataLink
BI.Store.Component.TBIDataLink
Syntax
Delphi
type
 TBIDataLink=class(TDataLink)
 end;

The TBIDataLink type exposes the following members.

Methods
Show:
Name | Description
DataEvent(TDataEvent,NativeInt) | Represents method DataEvent(TDataEvent,NativeInt).
Top
See Also

Reference

  • BI.Store.Component


TBIDataLink Methods

Methods
Name | Description
DataEvent(TDataEvent,NativeInt) | Represents method DataEvent(TDataEvent,NativeInt).
Top


TBIDataLink.DataEvent(TDataEvent,NativeInt) Method

Summary

Represents method DataEvent(TDataEvent,NativeInt).

Namespace: BI.Store.Component
Syntax
Delphi
protected
 procedure DataEvent(Event: TDataEvent; Info: NativeInt); override;

Parameters

Event
Type: TDataEvent

Info
Type: NativeInt

See Also

Reference

  • TBIDataLink
  • BI.Store.Component


TComponentImporter Class

Summary

Represents type TComponentImporter.

Namespace: BI.Store.Component
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Persist.TBaseDataImporter
BI.Store.Component.TComponentImporter
FMXBI.Component.TControlImporter
VCLBI.Component.TControlImporter
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64 or pidOSX32
 or pidiOSSimulator or pidiOSDevice
 or pidAndroid
 or pidiOSDevice64
 )]
 TComponentImporter=class(TBaseDataImporter)
 end;

The TComponentImporter type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TComponentImporter class. (Overrides TBaseDataImporter.Destroy.)
Top
Properties
Show:
Name | Description
Source | Represents property Source.
Top
Methods
Show:
Name | Description
DataOf(TComponent) | Represents method DataOf(TComponent).
DataOfProvider(TDataItem) | Represents method DataOfProvider(TDataItem).
DoImport(TComponent) | Represents method DoImport(TComponent).
From(TComponent,TComponent) | Overloaded. Represents method From(TComponent,TComponent).
From(TComponent,TComponent,String) | Overloaded. Represents method From(TComponent,TComponent,String).
GetItems(TDataItem) | Represents method GetItems(TDataItem). (Overrides TDataProvider.GetItems(TDataItem).)
GuessFrom(String) | Overloaded. Represents method GuessFrom(String).
GuessFrom(TStrings) | Overloaded. Represents method GuessFrom(TStrings).
IsSupported(TComponent) | Represents method IsSupported(TComponent).
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
Origin(TComponent,TDataItem) | Represents method Origin(TComponent,TDataItem).
ProviderOf(TDataItem) | Represents method ProviderOf(TDataItem).
Refresh | Represents method Refresh.
StringsOf(TComponent) | Represents method StringsOf(TComponent).
Supports(TComponent) | Represents method Supports(TComponent).
TryLoadOrigin(TComponent,TComponent,String) | Represents method TryLoadOrigin(TComponent,TComponent,String).
Top
Fields
Show:
Name | Description
Plugins | Represents field Plugins.
Top
See Also

Reference

  • BI.Store.Component


TComponentImporter Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TComponentImporter class. (Overrides TBaseDataImporter.Destroy.)
Top


TComponentImporter.Destroy Destructor

Summary

Represents the destructor of the TComponentImporter class.

Namespace: BI.Store.Component
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TBaseDataImporter.Destroy
See Also

Reference

  • TComponentImporter
  • BI.Store.Component


TComponentImporter Properties

Properties
Name | Description
Source | Represents property Source.
Top


TComponentImporter.Source Property

Summary

Represents property Source.

Namespace: BI.Store.Component
Syntax
Delphi
published
 property Source:TComponent read FSource write SetSource;

Property Value

Type: TComponent

See Also

Reference

  • TComponentImporter
  • BI.Store.Component


TComponentImporter Methods

Methods
Name | Description
DataOf(TComponent) | Represents method DataOf(TComponent).
DataOfProvider(TDataItem) | Represents method DataOfProvider(TDataItem).
DoImport(TComponent) | Represents method DoImport(TComponent).
From(TComponent,TComponent) | Overloaded. Represents method From(TComponent,TComponent).
From(TComponent,TComponent,String) | Overloaded. Represents method From(TComponent,TComponent,String).
GetItems(TDataItem) | Represents method GetItems(TDataItem). (Overrides TDataProvider.GetItems(TDataItem).)
GuessFrom(String) | Overloaded. Represents method GuessFrom(String).
GuessFrom(TStrings) | Overloaded. Represents method GuessFrom(TStrings).
IsSupported(TComponent) | Represents method IsSupported(TComponent).
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
Origin(TComponent,TDataItem) | Represents method Origin(TComponent,TDataItem).
ProviderOf(TDataItem) | Represents method ProviderOf(TDataItem).
Refresh | Represents method Refresh.
StringsOf(TComponent) | Represents method StringsOf(TComponent).
Supports(TComponent) | Represents method Supports(TComponent).
TryLoadOrigin(TComponent,TComponent,String) | Represents method TryLoadOrigin(TComponent,TComponent,String).
Top


TComponentImporter.DataOf(TComponent) Method

Summary

Represents method DataOf(TComponent).

Namespace: BI.Store.Component
Syntax
Delphi
public
 class function DataOf(const AComponent:TComponent):TDataItem; virtual;

Parameters

AComponent
Type: TComponent

Return Value

Type: TDataItem

See Also

Reference

  • TComponentImporter
  • BI.Store.Component


TComponentImporter.DataOfProvider(TDataItem) Method

Summary

Represents method DataOfProvider(TDataItem).

Namespace: BI.Store.Component
Syntax
Delphi
public
 class function DataOfProvider(const AData:TDataItem):TDataItem; static;

Parameters

AData
Type: TDataItem

Return Value

Type: TDataItem

See Also

Reference

  • TComponentImporter
  • BI.Store.Component


TComponentImporter.DoImport(TComponent) Method

Summary

Represents method DoImport(TComponent).

Namespace: BI.Store.Component
Syntax
Delphi
protected
 function DoImport(const AComponent: TComponent):TDataItem; virtual;

Parameters

AComponent
Type: TComponent

Return Value

Type: TDataItem

See Also

Reference

  • TComponentImporter
  • BI.Store.Component


TComponentImporter.From(TComponent,TComponent) Method

Summary

Represents method From(TComponent,TComponent).

Namespace: BI.Store.Component
Syntax
Delphi
public
 class function From(const AOwner,AComponent:TComponent): TDataItem; overload; static;

Parameters

AOwner
Type: TComponent

AComponent
Type: TComponent

Return Value

Type: TDataItem

See Also

Reference

  • TComponentImporter
  • BI.Store.Component


TComponentImporter.From(TComponent,TComponent,String) Method

Summary

Represents method From(TComponent,TComponent,String).

Namespace: BI.Store.Component
Syntax
Delphi
public
 class function From(const AOwner,AComponent:TComponent; const AOrigin:String): TDataItem; overload; static;

Parameters

AOwner
Type: TComponent

AComponent
Type: TComponent

AOrigin
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TComponentImporter
  • BI.Store.Component


TComponentImporter.GetItems(TDataItem) Method

Summary

Represents method GetItems(TDataItem).

Namespace: BI.Store.Component
Syntax
Delphi
protected
 procedure GetItems(const AData:TDataItem); override;

Parameters

AData
Type: TDataItem

Overrides

TDataProvider.GetItems(TDataItem)
See Also

Reference

  • TComponentImporter
  • BI.Store.Component


TComponentImporter.GuessFrom(String) Method

Summary

Represents method GuessFrom(String).

Namespace: BI.Store.Component
Syntax
Delphi
protected
 class function GuessFrom(const AString:String):TDataItem; overload; static;

Parameters

AString
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TComponentImporter
  • BI.Store.Component


TComponentImporter.GuessFrom(TStrings) Method

Summary

Represents method GuessFrom(TStrings).

Namespace: BI.Store.Component
Syntax
Delphi
protected
 class function GuessFrom(const AStrings:TStrings):TDataItem; overload; static;

Parameters

AStrings
Type: TStrings

Return Value

Type: TDataItem

See Also

Reference

  • TComponentImporter
  • BI.Store.Component


TComponentImporter.IsSupported(TComponent) Method

Summary

Represents method IsSupported(TComponent).

Namespace: BI.Store.Component
Syntax
Delphi
public
 class function IsSupported(const AComponent:TComponent):Boolean; static;

Parameters

AComponent
Type: TComponent

Return Value

Type: Boolean

See Also

Reference

  • TComponentImporter
  • BI.Store.Component


TComponentImporter.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Store.Component
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TComponentImporter
  • BI.Store.Component


TComponentImporter.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: BI.Store.Component
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

See Also

Reference

  • TComponentImporter
  • BI.Store.Component


TComponentImporter.Origin(TComponent,TDataItem) Method

Summary

Represents method Origin(TComponent,TDataItem).

Namespace: BI.Store.Component
Syntax
Delphi
public
 class function Origin(const AComponent:TComponent; const AData:TDataItem):String; static;

Parameters

AComponent
Type: TComponent

AData
Type: TDataItem

Return Value

Type: String

See Also

Reference

  • TComponentImporter
  • BI.Store.Component


TComponentImporter.ProviderOf(TDataItem) Method

Summary

Represents method ProviderOf(TDataItem).

Namespace: BI.Store.Component
Syntax
Delphi
public
 class function ProviderOf(const AData:TDataItem):TComponent; static;

Parameters

AData
Type: TDataItem

Return Value

Type: TComponent

See Also

Reference

  • TComponentImporter
  • BI.Store.Component


TComponentImporter.Refresh Method

Summary

Represents method Refresh.

Namespace: BI.Store.Component
Syntax
Delphi
public
 procedure Refresh;
See Also

Reference

  • TComponentImporter
  • BI.Store.Component


TComponentImporter.StringsOf(TComponent) Method

Summary

Represents method StringsOf(TComponent).

Namespace: BI.Store.Component
Syntax
Delphi
protected
 class function StringsOf(const ASource:TComponent):TStrings; virtual;

Parameters

ASource
Type: TComponent

Return Value

Type: TStrings

See Also

Reference

  • TComponentImporter
  • BI.Store.Component


TComponentImporter.Supports(TComponent) Method

Summary

Represents method Supports(TComponent).

Namespace: BI.Store.Component
Syntax
Delphi
public
 class function Supports(const AComponent:TComponent):Boolean; virtual;

Parameters

AComponent
Type: TComponent

Return Value

Type: Boolean

See Also

Reference

  • TComponentImporter
  • BI.Store.Component


TComponentImporter.TryLoadOrigin(TComponent,TComponent,String) Method

Summary

Represents method TryLoadOrigin(TComponent,TComponent,String).

Namespace: BI.Store.Component
Syntax
Delphi
public
 class function TryLoadOrigin(const AOwner,AProvider:TComponent; var AOrigin:String):TDataItem; static;

Parameters

AOwner
Type: TComponent

AProvider
Type: TComponent

AOrigin
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TComponentImporter
  • BI.Store.Component


TComponentImporter Fields

Fields
Name | Description
Plugins | Represents field Plugins.
Top


TComponentImporter.Plugins Field

Summary

Represents field Plugins.

Namespace: BI.Store.Component
Syntax
Delphi
public
 class var
 Plugins : TList<TComponentImporterClass>;

Field Value

Type: TList<TComponentImporterClass>

See Also

Reference

  • TComponentImporter
  • BI.Store.Component


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.Store.Component
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Store.Component.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.Store.Component


BI.Store.Component Types

Types
Name | Description
TComponentImporterClass | Represents type TComponentImporterClass.
Top


TComponentImporterClass Type

Summary

Represents type TComponentImporterClass.

Namespace: BI.Store.Component
Syntax
Delphi
type
 TComponentImporterClass=class of TComponentImporter;
See Also

Reference

  • BI.Store.Component


BI.Store.Component Variables

Variables
Name | Description
ImportCache | Represents variable ImportCache.
Top


ImportCache Variable

Summary

Represents variable ImportCache.

Namespace: BI.Store.Component
Syntax
Delphi
ImportCache : TList<TComponentImporter>=nil;

Value

Type: TList<TComponentImporter>

See Also

Reference

  • BI.Store.Component


BI.Store.Component Routines

Routines
Name | Description
AddToCache(TComponentImporter) | Represents method AddToCache(TComponentImporter).
DestroyCache | Represents method DestroyCache.
FindCache(TComponent) | Represents method FindCache(TComponent).
Top


AddToCache(TComponentImporter) Method

Summary

Represents method AddToCache(TComponentImporter).

Namespace: BI.Store.Component
Syntax
Delphi
procedure AddToCache(const AImporter:TComponentImporter);

Parameters

AImporter
Type: TComponentImporter

See Also

Reference

  • BI.Store.Component


DestroyCache Method

Summary

Represents method DestroyCache.

Namespace: BI.Store.Component
Syntax
Delphi
procedure DestroyCache;
See Also

Reference

  • BI.Store.Component


FindCache(TComponent) Method

Summary

Represents method FindCache(TComponent).

Namespace: BI.Store.Component
Syntax
Delphi
function FindCache(const AComponent:TComponent):TComponentImporter;

Parameters

AComponent
Type: TComponent

Return Value

Type: TComponentImporter

See Also

Reference

  • BI.Store.Component


BI.Streams Namespace

Summary

Represents namespace BI.Streams.

Classes
Name | Description
TBIReader | Represents type TBIReader.
TBIStreamer | Represents type TBIStreamer.
TBIWriter | Represents type TBIWriter.
Top


BI.Streams Classes

Classes
Name | Description
TBIReader | Represents type TBIReader.
TBIStreamer | Represents type TBIStreamer.
TBIWriter | Represents type TBIWriter.
Top


TBIReader Class

Summary

Represents type TBIReader.

Namespace: BI.Streams
Inheritance Hierarchy
TObject
BI.Streams.TBIStreamer
BI.Streams.TBIReader
Syntax
Delphi
type
 TBIReader=class(TBIStreamer)
 end;

The TBIReader type exposes the following members.

Constructors
Show:
Name | Description
Create(TStream,Integer) | Initializes a new instance of the TBIReader class.
Destroy | Represents the destructor of the TBIReader class.
Top
Properties
Show:
Name | Description
Position | Represents property Position.
Top
Methods
Show:
Name | Description
Read(Void,Integer) | Represents method Read(Void,Integer).
ReadBoolean | Represents method ReadBoolean.
ReadComponent(TComponent) | Represents method ReadComponent(TComponent).
ReadDate | Represents method ReadDate.
ReadDouble | Represents method ReadDouble.
ReadFloat | Represents method ReadFloat.
ReadInt64 | Represents method ReadInt64.
ReadInteger | Represents method ReadInteger.
ReadSingle | Represents method ReadSingle.
ReadString | Represents method ReadString.
Top
Fields
Show:
Name | Description
Version | Represents field Version.
Top
See Also

Reference

  • BI.Streams


TBIReader Constructors

Constructors
Name | Description
Create(TStream,Integer) | Initializes a new instance of the TBIReader class.
Destroy | Represents the destructor of the TBIReader class.
Top


TBIReader.Create(TStream,Integer) Constructor

Summary

Initializes a new instance of the TBIReader class.

Namespace: BI.Streams
Syntax
Delphi
public
 Constructor Create(const AStream:TStream;
 const BufferSize:Integer=TBIStreamer.DefaultBuffer);

Parameters

AStream
Type: TStream

BufferSize
Type: Integer

See Also

Reference

  • TBIReader
  • BI.Streams


TBIReader.Destroy Destructor

Summary

Represents the destructor of the TBIReader class.

Namespace: BI.Streams
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIReader
  • BI.Streams


TBIReader Properties

Properties
Name | Description
Position | Represents property Position.
Top


TBIReader.Position Property

Summary

Represents property Position.

Namespace: BI.Streams
Syntax
Delphi
public
 property Position:Int64 read GetPosition write SetPosition;

Property Value

Type: Int64

See Also

Reference

  • TBIReader
  • BI.Streams


TBIReader Methods

Methods
Name | Description
Read(Void,Integer) | Represents method Read(Void,Integer).
ReadBoolean | Represents method ReadBoolean.
ReadComponent(TComponent) | Represents method ReadComponent(TComponent).
ReadDate | Represents method ReadDate.
ReadDouble | Represents method ReadDouble.
ReadFloat | Represents method ReadFloat.
ReadInt64 | Represents method ReadInt64.
ReadInteger | Represents method ReadInteger.
ReadSingle | Represents method ReadSingle.
ReadString | Represents method ReadString.
Top


TBIReader.Read(Void,Integer) Method

Summary

Represents method Read(Void,Integer).

Namespace: BI.Streams
Syntax
Delphi
public
 procedure Read(var Value; Size:Integer);

Parameters

Value
Type: System.Void

Size
Type: Integer

See Also

Reference

  • TBIReader
  • BI.Streams


TBIReader.ReadBoolean Method

Summary

Represents method ReadBoolean.

Namespace: BI.Streams
Syntax
Delphi
public
 function ReadBoolean:Boolean; inline;

Return Value

Type: Boolean

See Also

Reference

  • TBIReader
  • BI.Streams


TBIReader.ReadComponent(TComponent) Method

Summary

Represents method ReadComponent(TComponent).

Namespace: BI.Streams
Syntax
Delphi
public
 procedure ReadComponent(const Value:TComponent); inline;

Parameters

Value
Type: TComponent

See Also

Reference

  • TBIReader
  • BI.Streams


TBIReader.ReadDate Method

Summary

Represents method ReadDate.

Namespace: BI.Streams
Syntax
Delphi
public
 function ReadDate: TDateTime; inline;

Return Value

Type: TDateTime

See Also

Reference

  • TBIReader
  • BI.Streams


TBIReader.ReadDouble Method

Summary

Represents method ReadDouble.

Namespace: BI.Streams
Syntax
Delphi
public
 function ReadDouble: Double; inline;

Return Value

Type: Double

See Also

Reference

  • TBIReader
  • BI.Streams


TBIReader.ReadFloat Method

Summary

Represents method ReadFloat.

Namespace: BI.Streams
Syntax
Delphi
public
 function ReadFloat: Extended; inline;

Return Value

Type: Extended

See Also

Reference

  • TBIReader
  • BI.Streams


TBIReader.ReadInt64 Method

Summary

Represents method ReadInt64.

Namespace: BI.Streams
Syntax
Delphi
public
 function ReadInt64: Int64; inline;

Return Value

Type: Int64

See Also

Reference

  • TBIReader
  • BI.Streams


TBIReader.ReadInteger Method

Summary

Represents method ReadInteger.

Namespace: BI.Streams
Syntax
Delphi
public
 function ReadInteger: Integer; inline;

Return Value

Type: Integer

See Also

Reference

  • TBIReader
  • BI.Streams


TBIReader.ReadSingle Method

Summary

Represents method ReadSingle.

Namespace: BI.Streams
Syntax
Delphi
public
 function ReadSingle: Single; inline;

Return Value

Type: Single

See Also

Reference

  • TBIReader
  • BI.Streams


TBIReader.ReadString Method

Summary

Represents method ReadString.

Namespace: BI.Streams
Syntax
Delphi
public
 function ReadString:String;

Return Value

Type: String

See Also

Reference

  • TBIReader
  • BI.Streams


TBIReader Fields

Fields
Name | Description
Version | Represents field Version.
Top


TBIReader.Version Field

Summary

Represents field Version.

Namespace: BI.Streams
Syntax
Delphi
public
 Version : Integer;

Field Value

Type: Integer

See Also

Reference

  • TBIReader
  • BI.Streams


TBIStreamer Class

Summary

Represents type TBIStreamer.

Namespace: BI.Streams
Inheritance Hierarchy
TObject
BI.Streams.TBIStreamer
BI.Streams.TBIReader
BI.Streams.TBIWriter
Syntax
Delphi
type
 TBIStreamer=class
 end;

The TBIStreamer type exposes the following members.

Constants
Show:
Name | Description
DefaultBuffer | Represents constant DefaultBuffer.
Top
Constructors
Show:
Name | Description
Create(TStream) | Initializes a new instance of the TBIStreamer class.
Top
Properties
Show:
Name | Description
Raw | Represents property Raw.
Top
See Also

Reference

  • BI.Streams


TBIStreamer Constants

Constants
Name | Description
DefaultBuffer | Represents constant DefaultBuffer.
Top


TBIStreamer.DefaultBuffer Constant

Summary

Represents constant DefaultBuffer.

Namespace: BI.Streams
Syntax
Delphi
public
 DefaultBuffer=2048;

Value

Type: SmallInt

See Also

Reference

  • TBIStreamer
  • BI.Streams


TBIStreamer Constructors

Constructors
Name | Description
Create(TStream) | Initializes a new instance of the TBIStreamer class.
Top


TBIStreamer.Create(TStream) Constructor

Summary

Initializes a new instance of the TBIStreamer class.

Namespace: BI.Streams
Syntax
Delphi
public
 Constructor Create(const AStream:TStream);

Parameters

AStream
Type: TStream

See Also

Reference

  • TBIStreamer
  • BI.Streams


TBIStreamer Properties

Properties
Name | Description
Raw | Represents property Raw.
Top


TBIStreamer.Raw Property

Summary

Represents property Raw.

Namespace: BI.Streams
Syntax
Delphi
public
 property Raw:Boolean read IRaw;

Property Value

Type: Boolean

See Also

Reference

  • TBIStreamer
  • BI.Streams


TBIWriter Class

Summary

Represents type TBIWriter.

Namespace: BI.Streams
Inheritance Hierarchy
TObject
BI.Streams.TBIStreamer
BI.Streams.TBIWriter
Syntax
Delphi
type
 TBIWriter=class(TBIStreamer)
 end;

The TBIWriter type exposes the following members.

Constructors
Show:
Name | Description
Create(TStream,Integer,Boolean) | Initializes a new instance of the TBIWriter class.
Destroy | Represents the destructor of the TBIWriter class.
Top
Properties
Show:
Name | Description
Position | Represents property Position.
Top
Methods
Show:
Name | Description
FlushBuffer | Represents method FlushBuffer.
Write(Void,Integer) | Represents method Write(Void,Integer).
WriteBoolean(Boolean) | Represents method WriteBoolean(Boolean).
WriteComponent(TComponent) | Represents method WriteComponent(TComponent).
WriteDate(TDateTime) | Represents method WriteDate(TDateTime).
WriteDouble(Double) | Represents method WriteDouble(Double).
WriteFloat(Extended) | Represents method WriteFloat(Extended).
WriteInt64(Int64) | Represents method WriteInt64(Int64).
WriteInteger(Int64) | Overloaded. Represents method WriteInteger(Int64).
WriteInteger(Integer) | Overloaded. Represents method WriteInteger(Integer).
WriteSingle(Single) | Represents method WriteSingle(Single).
WriteString(String) | Represents method WriteString(String).
Top
See Also

Reference

  • BI.Streams


TBIWriter Constructors

Constructors
Name | Description
Create(TStream,Integer,Boolean) | Initializes a new instance of the TBIWriter class.
Destroy | Represents the destructor of the TBIWriter class.
Top


TBIWriter.Create(TStream,Integer,Boolean) Constructor

Summary

Initializes a new instance of the TBIWriter class.

Namespace: BI.Streams
Syntax
Delphi
public
 Constructor Create(const AStream:TStream;
 const BufferSize:Integer=TBIStreamer.DefaultBuffer;
 const Raw:Boolean=False);

Parameters

AStream
Type: TStream

BufferSize
Type: Integer

Raw
Type: Boolean

See Also

Reference

  • TBIWriter
  • BI.Streams


TBIWriter.Destroy Destructor

Summary

Represents the destructor of the TBIWriter class.

Namespace: BI.Streams
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIWriter
  • BI.Streams


TBIWriter Properties

Properties
Name | Description
Position | Represents property Position.
Top


TBIWriter.Position Property

Summary

Represents property Position.

Namespace: BI.Streams
Syntax
Delphi
public
 property Position:Int64 read GetPosition write SetPosition;

Property Value

Type: Int64

See Also

Reference

  • TBIWriter
  • BI.Streams


TBIWriter Methods

Methods
Name | Description
FlushBuffer | Represents method FlushBuffer.
Write(Void,Integer) | Represents method Write(Void,Integer).
WriteBoolean(Boolean) | Represents method WriteBoolean(Boolean).
WriteComponent(TComponent) | Represents method WriteComponent(TComponent).
WriteDate(TDateTime) | Represents method WriteDate(TDateTime).
WriteDouble(Double) | Represents method WriteDouble(Double).
WriteFloat(Extended) | Represents method WriteFloat(Extended).
WriteInt64(Int64) | Represents method WriteInt64(Int64).
WriteInteger(Int64) | Overloaded. Represents method WriteInteger(Int64).
WriteInteger(Integer) | Overloaded. Represents method WriteInteger(Integer).
WriteSingle(Single) | Represents method WriteSingle(Single).
WriteString(String) | Represents method WriteString(String).
Top


TBIWriter.FlushBuffer Method

Summary

Represents method FlushBuffer.

Namespace: BI.Streams
Syntax
Delphi
public
 procedure FlushBuffer;
See Also

Reference

  • TBIWriter
  • BI.Streams


TBIWriter.Write(Void,Integer) Method

Summary

Represents method Write(Void,Integer).

Namespace: BI.Streams
Syntax
Delphi
public
 procedure Write(const Value; Size:Integer);

Parameters

Value
Type: System.Void

Size
Type: Integer

See Also

Reference

  • TBIWriter
  • BI.Streams


TBIWriter.WriteBoolean(Boolean) Method

Summary

Represents method WriteBoolean(Boolean).

Namespace: BI.Streams
Syntax
Delphi
public
 procedure WriteBoolean(const Value: Boolean); inline;

Parameters

Value
Type: Boolean

See Also

Reference

  • TBIWriter
  • BI.Streams


TBIWriter.WriteComponent(TComponent) Method

Summary

Represents method WriteComponent(TComponent).

Namespace: BI.Streams
Syntax
Delphi
public
 procedure WriteComponent(const Value:TComponent); inline;

Parameters

Value
Type: TComponent

See Also

Reference

  • TBIWriter
  • BI.Streams


TBIWriter.WriteDate(TDateTime) Method

Summary

Represents method WriteDate(TDateTime).

Namespace: BI.Streams
Syntax
Delphi
public
 procedure WriteDate(const Value: TDateTime); inline;

Parameters

Value
Type: TDateTime

See Also

Reference

  • TBIWriter
  • BI.Streams


TBIWriter.WriteDouble(Double) Method

Summary

Represents method WriteDouble(Double).

Namespace: BI.Streams
Syntax
Delphi
public
 procedure WriteDouble(const Value: Double); inline;

Parameters

Value
Type: Double

See Also

Reference

  • TBIWriter
  • BI.Streams


TBIWriter.WriteFloat(Extended) Method

Summary

Represents method WriteFloat(Extended).

Namespace: BI.Streams
Syntax
Delphi
public
 procedure WriteFloat(const Value: Extended); inline;

Parameters

Value
Type: Extended

See Also

Reference

  • TBIWriter
  • BI.Streams


TBIWriter.WriteInt64(Int64) Method

Summary

Represents method WriteInt64(Int64).

Namespace: BI.Streams
Syntax
Delphi
public
 procedure WriteInt64(const Value: Int64); inline;

Parameters

Value
Type: Int64

See Also

Reference

  • TBIWriter
  • BI.Streams


TBIWriter.WriteInteger(Int64) Method

Summary

Represents method WriteInteger(Int64).

Namespace: BI.Streams
Syntax
Delphi
public
 procedure WriteInteger(const Value: Int64); overload; inline;

Parameters

Value
Type: Int64

See Also

Reference

  • TBIWriter
  • BI.Streams


TBIWriter.WriteInteger(Integer) Method

Summary

Represents method WriteInteger(Integer).

Namespace: BI.Streams
Syntax
Delphi
public
 procedure WriteInteger(const Value: Integer); overload; inline;

Parameters

Value
Type: Integer

See Also

Reference

  • TBIWriter
  • BI.Streams


TBIWriter.WriteSingle(Single) Method

Summary

Represents method WriteSingle(Single).

Namespace: BI.Streams
Syntax
Delphi
public
 procedure WriteSingle(const Value: Single); inline;

Parameters

Value
Type: Single

See Also

Reference

  • TBIWriter
  • BI.Streams


TBIWriter.WriteString(String) Method

Summary

Represents method WriteString(String).

Namespace: BI.Streams
Syntax
Delphi
public
 procedure WriteString(const Value: String);

Parameters

Value
Type: String

See Also

Reference

  • TBIWriter
  • BI.Streams


BI.Streams.Reader Namespace

Summary

Represents namespace BI.Streams.Reader.

Classes
Name | Description
TBIStreamReader | Represents type TBIStreamReader.
Top


BI.Streams.Reader Classes

Classes
Name | Description
TBIStreamReader | Represents type TBIStreamReader.
Top


TBIStreamReader Class

Summary

Represents type TBIStreamReader.

Namespace: BI.Streams.Reader
Inheritance Hierarchy
TTextReader
BI.Streams.Reader.TBIStreamReader
Syntax
Delphi
type
 TBIStreamReader = class(TTextReader)
 end;

The TBIStreamReader type exposes the following members.

Constructors
Show:
Name | Description
Create(string) | Overloaded. Initializes a new instance of the TBIStreamReader class.
Create(string,Boolean) | Overloaded. Initializes a new instance of the TBIStreamReader class.
Create(string,TEncoding,Boolean,Integer) | Overloaded. Initializes a new instance of the TBIStreamReader class.
Create(TStream) | Overloaded. Initializes a new instance of the TBIStreamReader class.
Create(TStream,Boolean) | Overloaded. Initializes a new instance of the TBIStreamReader class.
Create(TStream,TEncoding,Boolean,Integer) | Overloaded. Initializes a new instance of the TBIStreamReader class.
Destroy | Represents the destructor of the TBIStreamReader class.
Top
Properties
Show:
Name | Description
BaseStream | Represents property BaseStream.
CurrentEncoding | Represents property CurrentEncoding.
EndOfStream | Represents property EndOfStream.
Top
Methods
Show:
Name | Description
Close | Represents method Close.
OwnStream | Represents method OwnStream.
Peek | Represents method Peek.
Read | Overloaded. Represents method Read.
Read(TCharArray,Integer,Integer) | Overloaded. Represents method Read(TCharArray,Integer,Integer).
ReadBlock(TCharArray,Integer,Integer) | Represents method ReadBlock(TCharArray,Integer,Integer).
ReadLine | Represents method ReadLine.
ReadToEnd | Represents method ReadToEnd.
Top
See Also

Reference

  • BI.Streams.Reader


TBIStreamReader Constructors

Constructors
Name | Description
Create(string) | Overloaded. Initializes a new instance of the TBIStreamReader class.
Create(string,Boolean) | Overloaded. Initializes a new instance of the TBIStreamReader class.
Create(string,TEncoding,Boolean,Integer) | Overloaded. Initializes a new instance of the TBIStreamReader class.
Create(TStream) | Overloaded. Initializes a new instance of the TBIStreamReader class.
Create(TStream,Boolean) | Overloaded. Initializes a new instance of the TBIStreamReader class.
Create(TStream,TEncoding,Boolean,Integer) | Overloaded. Initializes a new instance of the TBIStreamReader class.
Destroy | Represents the destructor of the TBIStreamReader class.
Top


TBIStreamReader.Create(string) Constructor

Summary

Initializes a new instance of the TBIStreamReader class.

Namespace: BI.Streams.Reader
Syntax
Delphi
public
 constructor Create(const Filename: string); overload;

Parameters

Filename
Type: string

See Also

Reference

  • TBIStreamReader
  • BI.Streams.Reader


TBIStreamReader.Create(string,Boolean) Constructor

Summary

Initializes a new instance of the TBIStreamReader class.

Namespace: BI.Streams.Reader
Syntax
Delphi
public
 constructor Create(const Filename: string; DetectBOM: Boolean); overload;

Parameters

Filename
Type: string

DetectBOM
Type: Boolean

See Also

Reference

  • TBIStreamReader
  • BI.Streams.Reader


TBIStreamReader.Create(string,TEncoding,Boolean,Integer) Constructor

Summary

Initializes a new instance of the TBIStreamReader class.

Namespace: BI.Streams.Reader
Syntax
Delphi
public
 constructor Create(const Filename: string; Encoding: TEncoding;
 DetectBOM: Boolean = False; BufferSize: Integer = 4096); overload;

Parameters

Filename
Type: string

Encoding
Type: TEncoding

DetectBOM
Type: Boolean

BufferSize
Type: Integer

See Also

Reference

  • TBIStreamReader
  • BI.Streams.Reader


TBIStreamReader.Create(TStream) Constructor

Summary

Initializes a new instance of the TBIStreamReader class.

Namespace: BI.Streams.Reader
Syntax
Delphi
public
 constructor Create(Stream: TStream); overload;

Parameters

Stream
Type: TStream

See Also

Reference

  • TBIStreamReader
  • BI.Streams.Reader


TBIStreamReader.Create(TStream,Boolean) Constructor

Summary

Initializes a new instance of the TBIStreamReader class.

Namespace: BI.Streams.Reader
Syntax
Delphi
public
 constructor Create(Stream: TStream; DetectBOM: Boolean); overload;

Parameters

Stream
Type: TStream

DetectBOM
Type: Boolean

See Also

Reference

  • TBIStreamReader
  • BI.Streams.Reader


TBIStreamReader.Create(TStream,TEncoding,Boolean,Integer) Constructor

Summary

Initializes a new instance of the TBIStreamReader class.

Namespace: BI.Streams.Reader
Syntax
Delphi
public
 constructor Create(Stream: TStream; Encoding: TEncoding;
 DetectBOM: Boolean = False; BufferSize: Integer = 4096); overload;

Parameters

Stream
Type: TStream

Encoding
Type: TEncoding

DetectBOM
Type: Boolean

BufferSize
Type: Integer

See Also

Reference

  • TBIStreamReader
  • BI.Streams.Reader


TBIStreamReader.Destroy Destructor

Summary

Represents the destructor of the TBIStreamReader class.

Namespace: BI.Streams.Reader
Syntax
Delphi
public
 destructor Destroy; override;
See Also

Reference

  • TBIStreamReader
  • BI.Streams.Reader


TBIStreamReader Properties

Properties
Name | Description
BaseStream | Represents property BaseStream.
CurrentEncoding | Represents property CurrentEncoding.
EndOfStream | Represents property EndOfStream.
Top


TBIStreamReader.BaseStream Property

Summary

Represents property BaseStream.

Namespace: BI.Streams.Reader
Syntax
Delphi
public
 property BaseStream: TStream read FStream;

Property Value

Type: TStream

See Also

Reference

  • TBIStreamReader
  • BI.Streams.Reader


TBIStreamReader.CurrentEncoding Property

Summary

Represents property CurrentEncoding.

Namespace: BI.Streams.Reader
Syntax
Delphi
public
 property CurrentEncoding: TEncoding read FEncoding;

Property Value

Type: TEncoding

See Also

Reference

  • TBIStreamReader
  • BI.Streams.Reader


TBIStreamReader.EndOfStream Property

Summary

Represents property EndOfStream.

Namespace: BI.Streams.Reader
Syntax
Delphi
public
 property EndOfStream: Boolean read GetEndOfStream;

Property Value

Type: Boolean

See Also

Reference

  • TBIStreamReader
  • BI.Streams.Reader


TBIStreamReader Methods

Methods
Name | Description
Close | Represents method Close.
OwnStream | Represents method OwnStream.
Peek | Represents method Peek.
Read | Overloaded. Represents method Read.
Read(TCharArray,Integer,Integer) | Overloaded. Represents method Read(TCharArray,Integer,Integer).
ReadBlock(TCharArray,Integer,Integer) | Represents method ReadBlock(TCharArray,Integer,Integer).
ReadLine | Represents method ReadLine.
ReadToEnd | Represents method ReadToEnd.
Top


TBIStreamReader.Close Method

Summary

Represents method Close.

Namespace: BI.Streams.Reader
Syntax
Delphi
public
 procedure Close; override;
See Also

Reference

  • TBIStreamReader
  • BI.Streams.Reader


TBIStreamReader.OwnStream Method

Summary

Represents method OwnStream.

Namespace: BI.Streams.Reader
Syntax
Delphi
public
 procedure OwnStream; inline;
See Also

Reference

  • TBIStreamReader
  • BI.Streams.Reader


TBIStreamReader.Peek Method

Summary

Represents method Peek.

Namespace: BI.Streams.Reader
Syntax
Delphi
public
 function Peek: Integer; override;

Return Value

Type: Integer

See Also

Reference

  • TBIStreamReader
  • BI.Streams.Reader


TBIStreamReader.Read Method

Summary

Represents method Read.

Namespace: BI.Streams.Reader
Syntax
Delphi
public
 function Read: Integer; overload; override;

Return Value

Type: Integer

See Also

Reference

  • TBIStreamReader
  • BI.Streams.Reader


TBIStreamReader.Read(TCharArray,Integer,Integer) Method

Summary

Represents method Read(TCharArray,Integer,Integer).

Namespace: BI.Streams.Reader
Syntax
Delphi
public
 function Read(var Buffer: TCharArray; Index, Count: Integer): Integer; overload; override;

Parameters

Buffer
Type: TCharArray

Index
Type: Integer

Count
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TBIStreamReader
  • BI.Streams.Reader


TBIStreamReader.ReadBlock(TCharArray,Integer,Integer) Method

Summary

Represents method ReadBlock(TCharArray,Integer,Integer).

Namespace: BI.Streams.Reader
Syntax
Delphi
public
 function ReadBlock(var Buffer: TCharArray; Index, Count: Integer): Integer; override;

Parameters

Buffer
Type: TCharArray

Index
Type: Integer

Count
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TBIStreamReader
  • BI.Streams.Reader


TBIStreamReader.ReadLine Method

Summary

Represents method ReadLine.

Namespace: BI.Streams.Reader
Syntax
Delphi
public
 function ReadLine: string; override;

Return Value

Type: string

See Also

Reference

  • TBIStreamReader
  • BI.Streams.Reader


TBIStreamReader.ReadToEnd Method

Summary

Represents method ReadToEnd.

Namespace: BI.Streams.Reader
Syntax
Delphi
public
 function ReadToEnd: string; override;

Return Value

Type: string

See Also

Reference

  • TBIStreamReader
  • BI.Streams.Reader


BI.Summary Namespace

Summary

Represents namespace BI.Summary.

Classes
Name | Description
TAggregateHelper | Represents type TAggregateHelper.
TBaseSummaryPersistent | Represents type TBaseSummaryPersistent.
TDataAccess | Represents type TDataAccess.
TDataItemAccess | Represents type TDataItemAccess.
TExpressionColumnAccess | Represents type TExpressionColumnAccess.
TGroupBy | Represents type TGroupBy.
TGroupBysHelper | Represents type TGroupBysHelper.
THistogram | Represents type THistogram.
TMeasure | Represents type TMeasure.
TMeasureCalculation | Represents type TMeasureCalculation.
TMeasureMissing | Represents type TMeasureMissing.
TMeasuresHelper | Represents type TMeasuresHelper.
TRemoveMissing | Represents type TRemoveMissing.
TRowFunction | Represents type TRowFunction.
TSummary | Represents type TSummary.
TSummaryExpression | Represents type TSummaryExpression.
TSummaryFilter | Represents type TSummaryFilter.
TSummaryItem | Represents type TSummaryItem.
Top
Records
Name | Description
TBin | Represents type TBin.
TGroupByDate | Represents type TGroupByDate.
Top
Enumerations
Name | Description
TAggregate | Represents type TAggregate.
TCalculationPercentage | Represents type TCalculationPercentage.
TCalculationRunning | Represents type TCalculationRunning.
TGroupByLayout | Represents type TGroupByLayout.
TSummaryItemType | Represents type TSummaryItemType.
Top
Types
Name | Description
TBinArray | Represents an array of the TBin type.
TGroupBys | Represents an array of the TGroupBy type.
TMeasures | Represents an array of the TMeasure type.
Top
Routines
Name | Description
DecadeOf(Integer) | Represents method DecadeOf(Integer).
Top


BI.Summary Classes

Classes
Name | Description
TAggregateHelper | Represents type TAggregateHelper.
TBaseSummaryPersistent | Represents type TBaseSummaryPersistent.
TDataAccess | Represents type TDataAccess.
TDataItemAccess | Represents type TDataItemAccess.
TExpressionColumnAccess | Represents type TExpressionColumnAccess.
TGroupBy | Represents type TGroupBy.
TGroupBysHelper | Represents type TGroupBysHelper.
THistogram | Represents type THistogram.
TMeasure | Represents type TMeasure.
TMeasureCalculation | Represents type TMeasureCalculation.
TMeasureMissing | Represents type TMeasureMissing.
TMeasuresHelper | Represents type TMeasuresHelper.
TRemoveMissing | Represents type TRemoveMissing.
TRowFunction | Represents type TRowFunction.
TSummary | Represents type TSummary.
TSummaryExpression | Represents type TSummaryExpression.
TSummaryFilter | Represents type TSummaryFilter.
TSummaryItem | Represents type TSummaryItem.
Top


TAggregateHelper Class Helper

Summary

Represents type TAggregateHelper.

Namespace: BI.Summary
Syntax
Delphi
type
 TAggregateHelper=record helper for TAggregate
 end;
Methods
Name | Description
AllToText | Represents method AllToText.
FromString(String,TAggregate) | Represents method FromString(String,TAggregate).
SupportsAsZero | Represents method SupportsAsZero.
ToString | Represents method ToString.
Top
See Also

Reference

  • BI.Summary


TAggregateHelper Methods

Methods
Name | Description
AllToText | Represents method AllToText.
FromString(String,TAggregate) | Represents method FromString(String,TAggregate).
SupportsAsZero | Represents method SupportsAsZero.
ToString | Represents method ToString.
Top


TAggregateHelper.AllToText Method

Summary

Represents method AllToText.

Namespace: BI.Summary
Syntax
Delphi
public
 class function AllToText:String; static;

Return Value

Type: String

See Also

Reference

  • TAggregateHelper
  • BI.Summary


TAggregateHelper.FromString(String,TAggregate) Method

Summary

Represents method FromString(String,TAggregate).

Namespace: BI.Summary
Syntax
Delphi
public
 class function FromString(const S:String; out Aggregate:TAggregate):Boolean; static;

Parameters

S
Type: String

Aggregate
Type: TAggregate

Return Value

Type: Boolean

See Also

Reference

  • TAggregateHelper
  • BI.Summary


TAggregateHelper.SupportsAsZero Method

Summary

Represents method SupportsAsZero.

Namespace: BI.Summary
Syntax
Delphi
public
 function SupportsAsZero:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TAggregateHelper
  • BI.Summary


TAggregateHelper.ToString Method

Summary

Represents method ToString.

Namespace: BI.Summary
Syntax
Delphi
public
 function ToString:String; inline;

Return Value

Type: String

See Also

Reference

  • TAggregateHelper
  • BI.Summary


TBaseSummaryPersistent Class

Summary

Represents type TBaseSummaryPersistent.

Namespace: BI.Summary
Inheritance Hierarchy
TPersistent
BI.Summary.TBaseSummaryPersistent
BI.Summary.THistogram
BI.Summary.TMeasureCalculation
BI.Summary.TMeasureMissing
BI.Summary.TRemoveMissing
BI.Summary.TSummaryItem
Syntax
Delphi
type
 TBaseSummaryPersistent=class(TPersistent)
 end;

The TBaseSummaryPersistent type exposes the following members.

Methods
Show:
Name | Description
Changed | Represents method Changed.
DoChanged(TObject) | Represents method DoChanged(TObject).
Top
Fields
Show:
Name | Description
IChanged | Represents field IChanged.
Top
See Also

Reference

  • BI.Summary


TBaseSummaryPersistent Methods

Methods
Name | Description
Changed | Represents method Changed.
DoChanged(TObject) | Represents method DoChanged(TObject).
Top


TBaseSummaryPersistent.Changed Method

Summary

Represents method Changed.

Namespace: BI.Summary
Syntax
Delphi
protected
 procedure Changed;
See Also

Reference

  • TBaseSummaryPersistent
  • BI.Summary


TBaseSummaryPersistent.DoChanged(TObject) Method

Summary

Represents method DoChanged(TObject).

Namespace: BI.Summary
Syntax
Delphi
protected
 procedure DoChanged(Sender:TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBaseSummaryPersistent
  • BI.Summary


TBaseSummaryPersistent Fields

Fields
Name | Description
IChanged | Represents field IChanged.
Top


TBaseSummaryPersistent.IChanged Field

Summary

Represents field IChanged.

Namespace: BI.Summary
Syntax
Delphi
protected
 IChanged : TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TBaseSummaryPersistent
  • BI.Summary


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.Summary
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Summary.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.Summary


TDataItemAccess Class

Summary

Represents type TDataItemAccess.

Namespace: BI.Summary
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Summary.TDataItemAccess
Syntax
Delphi
type
 TDataItemAccess=class(TDataItem);
See Also

Reference

  • BI.Summary


TExpressionColumnAccess Class

Summary

Represents type TExpressionColumnAccess.

Namespace: BI.Summary
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Expressions.TExpressionColumn
BI.Summary.TExpressionColumnAccess
Syntax
Delphi
type
 TExpressionColumnAccess=class(TExpressionColumn);
See Also

Reference

  • BI.Summary


TGroupBy Class

Summary

Represents type TGroupBy.

Namespace: BI.Summary
Inheritance Hierarchy
TPersistent
BI.Summary.TBaseSummaryPersistent
BI.Summary.TSummaryItem
BI.Summary.TGroupBy
BI.Query.TGroupByAccess
BI.Summary.Totals.TGroupByAccess
VCLBI.Editor.Query.TGroupByAccess
Syntax
Delphi
type
 TGroupBy=class(TSummaryItem)
 end;

The TGroupBy type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TGroupBy class. (Overrides TSummaryItem.Create.)
Destroy | Represents the destructor of the TGroupBy class. (Overrides TSummaryItem.Destroy.)
Top
Properties
Show:
Name | Description
DatePart | Represents property DatePart.
Histogram | Represents property Histogram.
Layout | Represents property Layout.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TSummaryItem.Assign(TPersistent).)
Clone | Represents method Clone.
ToString | Represents method ToString.
Top
Fields
Show:
Name | Description
DateOptions | Represents field DateOptions.
RealLayout | Represents field RealLayout.
Top
See Also

Reference

  • BI.Summary


TGroupBy Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TGroupBy class. (Overrides TSummaryItem.Create.)
Destroy | Represents the destructor of the TGroupBy class. (Overrides TSummaryItem.Destroy.)
Top


TGroupBy.Create Constructor

Summary

Initializes a new instance of the TGroupBy class.

Namespace: BI.Summary
Syntax
Delphi
public
 Constructor Create; override;

Overrides

TSummaryItem.Create
See Also

Reference

  • TGroupBy
  • BI.Summary


TGroupBy.Destroy Destructor

Summary

Represents the destructor of the TGroupBy class.

Namespace: BI.Summary
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TSummaryItem.Destroy
See Also

Reference

  • TGroupBy
  • BI.Summary


TGroupBy Properties

Properties
Name | Description
DatePart | Represents property DatePart.
Histogram | Represents property Histogram.
Layout | Represents property Layout.
Top


TGroupBy.DatePart Property

Summary

Represents property DatePart.

Namespace: BI.Summary
Syntax
Delphi
published
 property DatePart:TDateTimePart read GetDatePart write SetDatePart default TDateTimePart.None;

Property Value

Type: TDateTimePart

See Also

Reference

  • TGroupBy
  • BI.Summary


TGroupBy.Histogram Property

Summary

Represents property Histogram.

Namespace: BI.Summary
Syntax
Delphi
published
 property Histogram:THistogram read FHistogram write SetHistogram;

Property Value

Type: THistogram

See Also

Reference

  • TGroupBy
  • BI.Summary


TGroupBy.Layout Property

Summary

Represents property Layout.

Namespace: BI.Summary
Syntax
Delphi
published
 property Layout:TGroupByLayout read FLayout write FLayout default TGroupByLayout.Automatic;

Property Value

Type: TGroupByLayout

See Also

Reference

  • TGroupBy
  • BI.Summary


TGroupBy Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TSummaryItem.Assign(TPersistent).)
Clone | Represents method Clone.
ToString | Represents method ToString.
Top


TGroupBy.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TSummaryItem.Assign(TPersistent)
See Also

Reference

  • TGroupBy
  • BI.Summary


TGroupBy.Clone Method

Summary

Represents method Clone.

Namespace: BI.Summary
Syntax
Delphi
public
 function Clone:TGroupBy;

Return Value

Type: TGroupBy

See Also

Reference

  • TGroupBy
  • BI.Summary


TGroupBy.ToString Method

Summary

Represents method ToString.

Namespace: BI.Summary
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TGroupBy
  • BI.Summary


TGroupBy Fields

Fields
Name | Description
DateOptions | Represents field DateOptions.
RealLayout | Represents field RealLayout.
Top


TGroupBy.DateOptions Field

Summary

Represents field DateOptions.

Namespace: BI.Summary
Syntax
Delphi
protected
 DateOptions : TGroupByDate;

Field Value

Type: TGroupByDate

See Also

Reference

  • TGroupBy
  • BI.Summary


TGroupBy.RealLayout Field

Summary

Represents field RealLayout.

Namespace: BI.Summary
Syntax
Delphi
protected
 RealLayout : TGroupByLayout;

Field Value

Type: TGroupByLayout

See Also

Reference

  • TGroupBy
  • BI.Summary


TGroupBysHelper Class Helper

Summary

Represents type TGroupBysHelper.

Namespace: BI.Summary
Syntax
Delphi
type
 TGroupBysHelper=record helper for TGroupBys
 end;
Methods
Name | Description
Add(TDataItem) | Overloaded. Represents method Add(TDataItem).
Add(TExpression) | Overloaded. Represents method Add(TExpression).
Append(TGroupBy) | Represents method Append(TGroupBy).
Count | Represents method Count.
Delete(Integer) | Represents method Delete(Integer).
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer).
IndexOf(TGroupBy) | Represents method IndexOf(TGroupBy).
Remove(TGroupBy) | Represents method Remove(TGroupBy).
Top
See Also

Reference

  • BI.Summary


TGroupBysHelper Methods

Methods
Name | Description
Add(TDataItem) | Overloaded. Represents method Add(TDataItem).
Add(TExpression) | Overloaded. Represents method Add(TExpression).
Append(TGroupBy) | Represents method Append(TGroupBy).
Count | Represents method Count.
Delete(Integer) | Represents method Delete(Integer).
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer).
IndexOf(TGroupBy) | Represents method IndexOf(TGroupBy).
Remove(TGroupBy) | Represents method Remove(TGroupBy).
Top


TGroupBysHelper.Add(TDataItem) Method

Summary

Represents method Add(TDataItem).

Namespace: BI.Summary
Syntax
Delphi
public
 function Add(const AData:TDataItem):TGroupBy; overload;

Parameters

AData
Type: TDataItem

Return Value

Type: TGroupBy

See Also

Reference

  • TGroupBysHelper
  • BI.Summary


TGroupBysHelper.Add(TExpression) Method

Summary

Represents method Add(TExpression).

Namespace: BI.Summary
Syntax
Delphi
public
 function Add(const AExpression: TExpression):TGroupBy; overload;

Parameters

AExpression
Type: TExpression

Return Value

Type: TGroupBy

See Also

Reference

  • TGroupBysHelper
  • BI.Summary


TGroupBysHelper.Append(TGroupBy) Method

Summary

Represents method Append(TGroupBy).

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Append(const AGroupBy:TGroupBy);

Parameters

AGroupBy
Type: TGroupBy

See Also

Reference

  • TGroupBysHelper
  • BI.Summary


TGroupBysHelper.Count Method

Summary

Represents method Count.

Namespace: BI.Summary
Syntax
Delphi
public
 function Count:Integer; inline;

Return Value

Type: Integer

See Also

Reference

  • TGroupBysHelper
  • BI.Summary


TGroupBysHelper.Delete(Integer) Method

Summary

Represents method Delete(Integer).

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Delete(const AIndex:Integer);

Parameters

AIndex
Type: Integer

See Also

Reference

  • TGroupBysHelper
  • BI.Summary


TGroupBysHelper.Exchange(Integer,Integer) Method

Summary

Represents method Exchange(Integer,Integer).

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Exchange(const A,B:Integer);

Parameters

A
Type: Integer

B
Type: Integer

See Also

Reference

  • TGroupBysHelper
  • BI.Summary


TGroupBysHelper.IndexOf(TGroupBy) Method

Summary

Represents method IndexOf(TGroupBy).

Namespace: BI.Summary
Syntax
Delphi
public
 function IndexOf(const AGroupBy:TGroupBy):Integer;

Parameters

AGroupBy
Type: TGroupBy

Return Value

Type: Integer

See Also

Reference

  • TGroupBysHelper
  • BI.Summary


TGroupBysHelper.Remove(TGroupBy) Method

Summary

Represents method Remove(TGroupBy).

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Remove(const AGroupBy:TGroupBy);

Parameters

AGroupBy
Type: TGroupBy

See Also

Reference

  • TGroupBysHelper
  • BI.Summary


THistogram Class

Summary

Represents type THistogram.

Namespace: BI.Summary
Inheritance Hierarchy
TPersistent
BI.Summary.TBaseSummaryPersistent
BI.Summary.THistogram
Syntax
Delphi
type
 THistogram=class(TBaseSummaryPersistent)
 end;

The THistogram type exposes the following members.

Constants
Show:
Name | Description
CountOfText | Represents constant CountOfText.
DefaultName | Represents constant DefaultName.
UpToText | Represents constant UpToText.
Top
Constructors
Show:
Name | Description
Create | Initializes a new instance of the THistogram class.
Top
Properties
Show:
Name | Description
Active | Represents property Active.
AutoMaximum | Represents property AutoMaximum.
AutoMinimum | Represents property AutoMinimum.
BinSize | Represents property BinSize.
FloatFormat | Represents property FloatFormat.
Maximum | Represents property Maximum.
Minimum | Represents property Minimum.
NumBins | Represents property NumBins.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
BinCount | Represents method BinCount.
Calculate(TDataItem) | Represents method Calculate(TDataItem).
Top
See Also

Reference

  • BI.Summary


THistogram Constants

Constants
Name | Description
CountOfText | Represents constant CountOfText.
DefaultName | Represents constant DefaultName.
UpToText | Represents constant UpToText.
Top


THistogram.CountOfText Constant

Summary

Represents constant CountOfText.

Namespace: BI.Summary
Syntax
Delphi
public
 CountOfText='Count of ';

Value

Type: string

See Also

Reference

  • THistogram
  • BI.Summary


THistogram.DefaultName Constant

Summary

Represents constant DefaultName.

Namespace: BI.Summary
Syntax
Delphi
public
 DefaultName='Histogram';

Value

Type: string

See Also

Reference

  • THistogram
  • BI.Summary


THistogram.UpToText Constant

Summary

Represents constant UpToText.

Namespace: BI.Summary
Syntax
Delphi
public
 UpToText='Up to';

Value

Type: string

See Also

Reference

  • THistogram
  • BI.Summary


THistogram Constructors

Constructors
Name | Description
Create | Initializes a new instance of the THistogram class.
Top


THistogram.Create Constructor

Summary

Initializes a new instance of the THistogram class.

Namespace: BI.Summary
Syntax
Delphi
public
 Constructor Create;
See Also

Reference

  • THistogram
  • BI.Summary


THistogram Properties

Properties
Name | Description
Active | Represents property Active.
AutoMaximum | Represents property AutoMaximum.
AutoMinimum | Represents property AutoMinimum.
BinSize | Represents property BinSize.
FloatFormat | Represents property FloatFormat.
Maximum | Represents property Maximum.
Minimum | Represents property Minimum.
NumBins | Represents property NumBins.
Top


THistogram.Active Property

Summary

Represents property Active.

Namespace: BI.Summary
Syntax
Delphi
published
 property Active:Boolean read FActive write SetActive default False;

Property Value

Type: Boolean

See Also

Reference

  • THistogram
  • BI.Summary


THistogram.AutoMaximum Property

Summary

Represents property AutoMaximum.

Namespace: BI.Summary
Syntax
Delphi
published
 property AutoMaximum : Boolean read FAutoMaximum write SetAutoMaximum default True;

Property Value

Type: Boolean

See Also

Reference

  • THistogram
  • BI.Summary


THistogram.AutoMinimum Property

Summary

Represents property AutoMinimum.

Namespace: BI.Summary
Syntax
Delphi
published
 property AutoMinimum : Boolean read FAutoMinimum write SetAutoMinimum default True;

Property Value

Type: Boolean

See Also

Reference

  • THistogram
  • BI.Summary


THistogram.BinSize Property

Summary

Represents property BinSize.

Namespace: BI.Summary
Syntax
Delphi
published
 property BinSize : TFloat read FBinSize write SetBinSize;

Property Value

Type: TFloat

See Also

Reference

  • THistogram
  • BI.Summary


THistogram.FloatFormat Property

Summary

Represents property FloatFormat.

Namespace: BI.Summary
Syntax
Delphi
published
 property FloatFormat : String read FFloatFormat write FFloatFormat;

Property Value

Type: String

See Also

Reference

  • THistogram
  • BI.Summary


THistogram.Maximum Property

Summary

Represents property Maximum.

Namespace: BI.Summary
Syntax
Delphi
published
 property Maximum : TFloat read FMaximum write SetMaximum;

Property Value

Type: TFloat

See Also

Reference

  • THistogram
  • BI.Summary


THistogram.Minimum Property

Summary

Represents property Minimum.

Namespace: BI.Summary
Syntax
Delphi
published
 property Minimum : TFloat read FMinimum write SetMinimum;

Property Value

Type: TFloat

See Also

Reference

  • THistogram
  • BI.Summary


THistogram.NumBins Property

Summary

Represents property NumBins.

Namespace: BI.Summary
Syntax
Delphi
published
 property NumBins : Integer read FNumBins write SetNumBins default 0;

Property Value

Type: Integer

See Also

Reference

  • THistogram
  • BI.Summary


THistogram Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
BinCount | Represents method BinCount.
Calculate(TDataItem) | Represents method Calculate(TDataItem).
Top


THistogram.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • THistogram
  • BI.Summary


THistogram.BinCount Method

Summary

Represents method BinCount.

Namespace: BI.Summary
Syntax
Delphi
public
 function BinCount:Integer; inline;

Return Value

Type: Integer

See Also

Reference

  • THistogram
  • BI.Summary


THistogram.Calculate(TDataItem) Method

Summary

Represents method Calculate(TDataItem).

Namespace: BI.Summary
Syntax
Delphi
public
 function Calculate(const Source:TDataItem):TDataItem;

Parameters

Source
Type: TDataItem

Return Value

Type: TDataItem

See Also

Reference

  • THistogram
  • BI.Summary


TMeasure Class

Summary

Represents type TMeasure.

Namespace: BI.Summary
Inheritance Hierarchy
TPersistent
BI.Summary.TBaseSummaryPersistent
BI.Summary.TSummaryItem
BI.Summary.TMeasure
BI.Query.TMeasureAccess
Syntax
Delphi
type
 TMeasure=class(TSummaryItem)
 end;

The TMeasure type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TMeasure class. (Overrides TSummaryItem.Create.)
Destroy | Represents the destructor of the TMeasure class. (Overrides TSummaryItem.Destroy.)
Top
Properties
Show:
Name | Description
Aggregate | Represents property Aggregate.
Calculation | Represents property Calculation.
Missing | Represents property Missing.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TSummaryItem.Assign(TPersistent).)
Clone | Represents method Clone.
Kind | Represents method Kind.
ToString | Represents method ToString.
Top
See Also

Reference

  • BI.Summary


TMeasure Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TMeasure class. (Overrides TSummaryItem.Create.)
Destroy | Represents the destructor of the TMeasure class. (Overrides TSummaryItem.Destroy.)
Top


TMeasure.Create Constructor

Summary

Initializes a new instance of the TMeasure class.

Namespace: BI.Summary
Syntax
Delphi
public
 Constructor Create; override;

Overrides

TSummaryItem.Create
See Also

Reference

  • TMeasure
  • BI.Summary


TMeasure.Destroy Destructor

Summary

Represents the destructor of the TMeasure class.

Namespace: BI.Summary
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TSummaryItem.Destroy
See Also

Reference

  • TMeasure
  • BI.Summary


TMeasure Properties

Properties
Name | Description
Aggregate | Represents property Aggregate.
Calculation | Represents property Calculation.
Missing | Represents property Missing.
Top


TMeasure.Aggregate Property

Summary

Represents property Aggregate.

Namespace: BI.Summary
Syntax
Delphi
published
 property Aggregate : TAggregate read FAggregate write SetAggregate default TAggregate.Count;

Property Value

Type: TAggregate

See Also

Reference

  • TMeasure
  • BI.Summary


TMeasure.Calculation Property

Summary

Represents property Calculation.

Namespace: BI.Summary
Syntax
Delphi
published
 property Calculation : TMeasureCalculation read FCalculation write SetCalculation;

Property Value

Type: TMeasureCalculation

See Also

Reference

  • TMeasure
  • BI.Summary


TMeasure.Missing Property

Summary

Represents property Missing.

Namespace: BI.Summary
Syntax
Delphi
published
 property Missing : TMeasureMissing read FMissing write SetMissing;

Property Value

Type: TMeasureMissing

See Also

Reference

  • TMeasure
  • BI.Summary


TMeasure Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TSummaryItem.Assign(TPersistent).)
Clone | Represents method Clone.
Kind | Represents method Kind.
ToString | Represents method ToString.
Top


TMeasure.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TSummaryItem.Assign(TPersistent)
See Also

Reference

  • TMeasure
  • BI.Summary


TMeasure.Clone Method

Summary

Represents method Clone.

Namespace: BI.Summary
Syntax
Delphi
public
 function Clone:TMeasure;

Return Value

Type: TMeasure

See Also

Reference

  • TMeasure
  • BI.Summary


TMeasure.Kind Method

Summary

Represents method Kind.

Namespace: BI.Summary
Syntax
Delphi
public
 function Kind:TDataKind;

Return Value

Type: TDataKind

See Also

Reference

  • TMeasure
  • BI.Summary


TMeasure.ToString Method

Summary

Represents method ToString.

Namespace: BI.Summary
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TMeasure
  • BI.Summary


TMeasureCalculation Class

Summary

Represents type TMeasureCalculation.

Namespace: BI.Summary
Inheritance Hierarchy
TPersistent
BI.Summary.TBaseSummaryPersistent
BI.Summary.TMeasureCalculation
Syntax
Delphi
type
 TMeasureCalculation=class(TBaseSummaryPersistent)
 end;

The TMeasureCalculation type exposes the following members.

Properties
Show:
Name | Description
Percentage | Represents property Percentage.
Running | Represents property Running.
RunningByRows | Represents property RunningByRows.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
See Also

Reference

  • BI.Summary


TMeasureCalculation Properties

Properties
Name | Description
Percentage | Represents property Percentage.
Running | Represents property Running.
RunningByRows | Represents property RunningByRows.
Top


TMeasureCalculation.Percentage Property

Summary

Represents property Percentage.

Namespace: BI.Summary
Syntax
Delphi
published
 property Percentage : TCalculationPercentage read FPercentage write SetPercentage default TCalculationPercentage.None;

Property Value

Type: TCalculationPercentage

See Also

Reference

  • TMeasureCalculation
  • BI.Summary


TMeasureCalculation.Running Property

Summary

Represents property Running.

Namespace: BI.Summary
Syntax
Delphi
published
 property Running : TCalculationRunning read FRunning write SetRunning default TCalculationRunning.No;

Property Value

Type: TCalculationRunning

See Also

Reference

  • TMeasureCalculation
  • BI.Summary


TMeasureCalculation.RunningByRows Property

Summary

Represents property RunningByRows.

Namespace: BI.Summary
Syntax
Delphi
published
 property RunningByRows : Boolean read FRunningByRows write SetRunningByRows default False;

Property Value

Type: Boolean

See Also

Reference

  • TMeasureCalculation
  • BI.Summary


TMeasureCalculation Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TMeasureCalculation.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TMeasureCalculation
  • BI.Summary


TMeasureMissing Class

Summary

Represents type TMeasureMissing.

Namespace: BI.Summary
Inheritance Hierarchy
TPersistent
BI.Summary.TBaseSummaryPersistent
BI.Summary.TMeasureMissing
Syntax
Delphi
type
 TMeasureMissing=class(TBaseSummaryPersistent)
 end;

The TMeasureMissing type exposes the following members.

Properties
Show:
Name | Description
AsZero | Represents property AsZero.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
See Also

Reference

  • BI.Summary


TMeasureMissing Properties

Properties
Name | Description
AsZero | Represents property AsZero.
Top


TMeasureMissing.AsZero Property

Summary

Represents property AsZero.

Namespace: BI.Summary
Syntax
Delphi
published
 property AsZero : Boolean read FAsZero write SetAsZero default False;

Property Value

Type: Boolean

See Also

Reference

  • TMeasureMissing
  • BI.Summary


TMeasureMissing Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TMeasureMissing.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TMeasureMissing
  • BI.Summary


TMeasuresHelper Class Helper

Summary

Represents type TMeasuresHelper.

Namespace: BI.Summary
Syntax
Delphi
type
 TMeasuresHelper=record helper for TMeasures
 end;
Methods
Name | Description
Add(TDataItem,TAggregate) | Overloaded. Represents method Add(TDataItem,TAggregate).
Add(TExpression,TAggregate) | Overloaded. Represents method Add(TExpression,TAggregate).
Append(TMeasure) | Represents method Append(TMeasure).
Count | Represents method Count.
Delete(Integer) | Represents method Delete(Integer).
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer).
IndexOf(TMeasure) | Represents method IndexOf(TMeasure).
Remove(TMeasure) | Represents method Remove(TMeasure).
Top
See Also

Reference

  • BI.Summary


TMeasuresHelper Methods

Methods
Name | Description
Add(TDataItem,TAggregate) | Overloaded. Represents method Add(TDataItem,TAggregate).
Add(TExpression,TAggregate) | Overloaded. Represents method Add(TExpression,TAggregate).
Append(TMeasure) | Represents method Append(TMeasure).
Count | Represents method Count.
Delete(Integer) | Represents method Delete(Integer).
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer).
IndexOf(TMeasure) | Represents method IndexOf(TMeasure).
Remove(TMeasure) | Represents method Remove(TMeasure).
Top


TMeasuresHelper.Add(TDataItem,TAggregate) Method

Summary

Represents method Add(TDataItem,TAggregate).

Namespace: BI.Summary
Syntax
Delphi
public
 function Add(const AData: TDataItem; const Aggregate: TAggregate):TMeasure; overload;

Parameters

AData
Type: TDataItem

Aggregate
Type: TAggregate

Return Value

Type: TMeasure

See Also

Reference

  • TMeasuresHelper
  • BI.Summary


TMeasuresHelper.Add(TExpression,TAggregate) Method

Summary

Represents method Add(TExpression,TAggregate).

Namespace: BI.Summary
Syntax
Delphi
public
 function Add(const AExpression: TExpression; const Aggregate: TAggregate):TMeasure; overload;

Parameters

AExpression
Type: TExpression

Aggregate
Type: TAggregate

Return Value

Type: TMeasure

See Also

Reference

  • TMeasuresHelper
  • BI.Summary


TMeasuresHelper.Append(TMeasure) Method

Summary

Represents method Append(TMeasure).

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Append(const AMeasure:TMeasure);

Parameters

AMeasure
Type: TMeasure

See Also

Reference

  • TMeasuresHelper
  • BI.Summary


TMeasuresHelper.Count Method

Summary

Represents method Count.

Namespace: BI.Summary
Syntax
Delphi
public
 function Count:Integer; inline;

Return Value

Type: Integer

See Also

Reference

  • TMeasuresHelper
  • BI.Summary


TMeasuresHelper.Delete(Integer) Method

Summary

Represents method Delete(Integer).

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Delete(const Index:Integer);

Parameters

Index
Type: Integer

See Also

Reference

  • TMeasuresHelper
  • BI.Summary


TMeasuresHelper.Exchange(Integer,Integer) Method

Summary

Represents method Exchange(Integer,Integer).

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Exchange(const A,B:Integer);

Parameters

A
Type: Integer

B
Type: Integer

See Also

Reference

  • TMeasuresHelper
  • BI.Summary


TMeasuresHelper.IndexOf(TMeasure) Method

Summary

Represents method IndexOf(TMeasure).

Namespace: BI.Summary
Syntax
Delphi
public
 function IndexOf(const AMeasure:TMeasure):Integer;

Parameters

AMeasure
Type: TMeasure

Return Value

Type: Integer

See Also

Reference

  • TMeasuresHelper
  • BI.Summary


TMeasuresHelper.Remove(TMeasure) Method

Summary

Represents method Remove(TMeasure).

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Remove(const AMeasure:TMeasure);

Parameters

AMeasure
Type: TMeasure

See Also

Reference

  • TMeasuresHelper
  • BI.Summary


TRemoveMissing Class

Summary

Represents type TRemoveMissing.

Namespace: BI.Summary
Inheritance Hierarchy
TPersistent
BI.Summary.TBaseSummaryPersistent
BI.Summary.TRemoveMissing
BI.Query.TRemoveMissingAccess
Syntax
Delphi
type
 TRemoveMissing=class(TBaseSummaryPersistent)
 end;

The TRemoveMissing type exposes the following members.

Properties
Show:
Name | Description
Columns | Represents property Columns.
Rows | Represents property Rows.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
See Also

Reference

  • BI.Summary


TRemoveMissing Properties

Properties
Name | Description
Columns | Represents property Columns.
Rows | Represents property Rows.
Top


TRemoveMissing.Columns Property

Summary

Represents property Columns.

Namespace: BI.Summary
Syntax
Delphi
published
 property Columns:Boolean read FColumns write SetColumns default False;

Property Value

Type: Boolean

See Also

Reference

  • TRemoveMissing
  • BI.Summary


TRemoveMissing.Rows Property

Summary

Represents property Rows.

Namespace: BI.Summary
Syntax
Delphi
published
 property Rows:Boolean read FRows write SetRows default False;

Property Value

Type: Boolean

See Also

Reference

  • TRemoveMissing
  • BI.Summary


TRemoveMissing Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TRemoveMissing.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TRemoveMissing
  • BI.Summary


TRowFunction Class

Summary

Represents type TRowFunction.

Namespace: BI.Summary
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Expression.TUnaryExpression
BI.Expressions.TColumnExpression
BI.Summary.TRowFunction
Syntax
Delphi
type
 TRowFunction=class(TColumnExpression)
 end;

The TRowFunction type exposes the following members.

Methods
Show:
Name | Description
Calculate(TDataHops,TDataItem) | Represents method Calculate(TDataHops,TDataItem). (Overrides TColumnExpression.Calculate(TDataHops,TDataItem).)
Kind | Represents method Kind. (Overrides TColumnExpression.Kind.)
ToString | Represents method ToString.
TryParse(String) | Represents method TryParse(String). (Overrides TColumnExpression.TryParse(String).)
Value | Represents method Value. (Overrides TExpression.Value.)
Top
Fields
Show:
Name | Description
MissingAsZero | Represents field MissingAsZero.
Operand | Represents field Operand.
Top
See Also

Reference

  • BI.Summary


TRowFunction Methods

Methods
Name | Description
Calculate(TDataHops,TDataItem) | Represents method Calculate(TDataHops,TDataItem). (Overrides TColumnExpression.Calculate(TDataHops,TDataItem).)
Kind | Represents method Kind. (Overrides TColumnExpression.Kind.)
ToString | Represents method ToString.
TryParse(String) | Represents method TryParse(String). (Overrides TColumnExpression.TryParse(String).)
Value | Represents method Value. (Overrides TExpression.Value.)
Top


TRowFunction.Calculate(TDataHops,TDataItem) Method

Summary

Represents method Calculate(TDataHops,TDataItem).

Namespace: BI.Summary
Syntax
Delphi
protected
 procedure Calculate(const Hops:TDataHops; const Dest:TDataItem); override;

Parameters

Hops
Type: TDataHops

Dest
Type: TDataItem

Overrides

TColumnExpression.Calculate(TDataHops,TDataItem)
See Also

Reference

  • TRowFunction
  • BI.Summary


TRowFunction.Kind Method

Summary

Represents method Kind.

Namespace: BI.Summary
Syntax
Delphi
protected
 function Kind:TDataKind; override;

Return Value

Type: TDataKind

Overrides

TColumnExpression.Kind
See Also

Reference

  • TRowFunction
  • BI.Summary


TRowFunction.ToString Method

Summary

Represents method ToString.

Namespace: BI.Summary
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TRowFunction
  • BI.Summary


TRowFunction.TryParse(String) Method

Summary

Represents method TryParse(String).

Namespace: BI.Summary
Syntax
Delphi
protected
 class function TryParse(const S:String):TColumnExpression; override;

Parameters

S
Type: String

Return Value

Type: TColumnExpression

Overrides

TColumnExpression.TryParse(String)
See Also

Reference

  • TRowFunction
  • BI.Summary


TRowFunction.Value Method

Summary

Represents method Value.

Namespace: BI.Summary
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TRowFunction
  • BI.Summary


TRowFunction Fields

Fields
Name | Description
MissingAsZero | Represents field MissingAsZero.
Operand | Represents field Operand.
Top


TRowFunction.MissingAsZero Field

Summary

Represents field MissingAsZero.

Namespace: BI.Summary
Syntax
Delphi
public
 MissingAsZero : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TRowFunction
  • BI.Summary


TRowFunction.Operand Field

Summary

Represents field Operand.

Namespace: BI.Summary
Syntax
Delphi
public
 Operand : TAggregate;

Field Value

Type: TAggregate

See Also

Reference

  • TRowFunction
  • BI.Summary


TSummary Class

Summary

Represents type TSummary.

Namespace: BI.Summary
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Summary.TSummary
BI.Query.TSummaryAccess
BI.Summary.Persist.TSummaryAccess
VCLBI.Editor.Hops.TSummaryAccess
Syntax
Delphi
type
 TSummary=class(TDataProvider)
 end;

The TSummary type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TSummary class.
Destroy | Represents the destructor of the TSummary class. (Overrides TDataProvider.Destroy.)
Top
Properties
Show:
Name | Description
Description | Represents property Description.
Filter | Represents property Filter.
Having | Represents property Having.
MainData | Represents property MainData.
RemoveMissing | Represents property RemoveMissing.
UseFilter | Represents property UseFilter.
Top
Methods
Show:
Name | Description
AddGroupBy(TDataItem) | Overloaded. Represents method AddGroupBy(TDataItem).
AddGroupBy(TExpression) | Overloaded. Represents method AddGroupBy(TExpression).
AddMeasure(TDataItem,TAggregate) | Overloaded. Represents method AddMeasure(TDataItem,TAggregate).
AddMeasure(TExpression,TAggregate) | Overloaded. Represents method AddMeasure(TExpression,TAggregate).
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TDataProvider.Assign(TPersistent).)
Calculate | Overloaded. Represents method Calculate.
Calculate(TDataItem) | Overloaded. Represents method Calculate(TDataItem).
Clear | Represents method Clear.
FillGroupByRows | Represents method FillGroupByRows.
GuessByLayout | Represents method GuessByLayout.
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Prepare | Represents method Prepare.
SetDirectFilter(TExpression) | Represents method SetDirectFilter(TExpression).
ToString | Represents method ToString.
Valid | Represents method Valid.
Top
Fields
Show:
Name | Description
By | Represents field By.
ByCols | Represents field ByCols.
ByRows | Represents field ByRows.
Hops | Represents field Hops.
Measures | Represents field Measures.
SortBy | Represents field SortBy.
Top
See Also

Reference

  • BI.Summary


TSummary Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TSummary class.
Destroy | Represents the destructor of the TSummary class. (Overrides TDataProvider.Destroy.)
Top


TSummary.Create(TComponent) Constructor

Summary

Initializes a new instance of the TSummary class.

Namespace: BI.Summary
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TSummary
  • BI.Summary


TSummary.Destroy Destructor

Summary

Represents the destructor of the TSummary class.

Namespace: BI.Summary
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TDataProvider.Destroy
See Also

Reference

  • TSummary
  • BI.Summary


TSummary Properties

Properties
Name | Description
Description | Represents property Description.
Filter | Represents property Filter.
Having | Represents property Having.
MainData | Represents property MainData.
RemoveMissing | Represents property RemoveMissing.
UseFilter | Represents property UseFilter.
Top


TSummary.Description Property

Summary

Represents property Description.

Namespace: BI.Summary
Syntax
Delphi
published
 property Description:String read FDescription write FDescription;

Property Value

Type: String

See Also

Reference

  • TSummary
  • BI.Summary


TSummary.Filter Property

Summary

Represents property Filter.

Namespace: BI.Summary
Syntax
Delphi
published
 property Filter:TExpression read FFilter write SetFilter;

Property Value

Type: TExpression

See Also

Reference

  • TSummary
  • BI.Summary


TSummary.Having Property

Summary

Represents property Having.

Namespace: BI.Summary
Syntax
Delphi
published
 property Having:TSummaryFilter read GetHaving write SetHaving;

Property Value

Type: TSummaryFilter

See Also

Reference

  • TSummary
  • BI.Summary


TSummary.MainData Property

Summary

Represents property MainData.

Namespace: BI.Summary
Syntax
Delphi
public
 property MainData:TDataItem read GetMainData;

Property Value

Type: TDataItem

See Also

Reference

  • TSummary
  • BI.Summary


TSummary.RemoveMissing Property

Summary

Represents property RemoveMissing.

Namespace: BI.Summary
Syntax
Delphi
published
 property RemoveMissing:TRemoveMissing read FRemove write SetRemove;

Property Value

Type: TRemoveMissing

See Also

Reference

  • TSummary
  • BI.Summary


TSummary.UseFilter Property

Summary

Represents property UseFilter.

Namespace: BI.Summary
Syntax
Delphi
published
 property UseFilter:Boolean read FUseFilter write FUseFilter default True;

Property Value

Type: Boolean

See Also

Reference

  • TSummary
  • BI.Summary


TSummary Methods

Methods
Name | Description
AddGroupBy(TDataItem) | Overloaded. Represents method AddGroupBy(TDataItem).
AddGroupBy(TExpression) | Overloaded. Represents method AddGroupBy(TExpression).
AddMeasure(TDataItem,TAggregate) | Overloaded. Represents method AddMeasure(TDataItem,TAggregate).
AddMeasure(TExpression,TAggregate) | Overloaded. Represents method AddMeasure(TExpression,TAggregate).
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TDataProvider.Assign(TPersistent).)
Calculate | Overloaded. Represents method Calculate.
Calculate(TDataItem) | Overloaded. Represents method Calculate(TDataItem).
Clear | Represents method Clear.
FillGroupByRows | Represents method FillGroupByRows.
GuessByLayout | Represents method GuessByLayout.
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Prepare | Represents method Prepare.
SetDirectFilter(TExpression) | Represents method SetDirectFilter(TExpression).
ToString | Represents method ToString.
Valid | Represents method Valid.
Top


TSummary.AddGroupBy(TDataItem) Method

Summary

Represents method AddGroupBy(TDataItem).

Namespace: BI.Summary
Syntax
Delphi
public
 function AddGroupBy(const AData: TDataItem):TGroupBy; overload; inline;

Parameters

AData
Type: TDataItem

Return Value

Type: TGroupBy

See Also

Reference

  • TSummary
  • BI.Summary


TSummary.AddGroupBy(TExpression) Method

Summary

Represents method AddGroupBy(TExpression).

Namespace: BI.Summary
Syntax
Delphi
public
 function AddGroupBy(const AExpression: TExpression):TGroupBy; overload; inline;

Parameters

AExpression
Type: TExpression

Return Value

Type: TGroupBy

See Also

Reference

  • TSummary
  • BI.Summary


TSummary.AddMeasure(TDataItem,TAggregate) Method

Summary

Represents method AddMeasure(TDataItem,TAggregate).

Namespace: BI.Summary
Syntax
Delphi
public
 function AddMeasure(const AData:TDataItem; const Aggregate:TAggregate):TMeasure; overload; inline;

Parameters

AData
Type: TDataItem

Aggregate
Type: TAggregate

Return Value

Type: TMeasure

See Also

Reference

  • TSummary
  • BI.Summary


TSummary.AddMeasure(TExpression,TAggregate) Method

Summary

Represents method AddMeasure(TExpression,TAggregate).

Namespace: BI.Summary
Syntax
Delphi
public
 function AddMeasure(const AExpression:TExpression; const Aggregate:TAggregate):TMeasure; overload; inline;

Parameters

AExpression
Type: TExpression

Aggregate
Type: TAggregate

Return Value

Type: TMeasure

See Also

Reference

  • TSummary
  • BI.Summary


TSummary.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TDataProvider.Assign(TPersistent)
See Also

Reference

  • TSummary
  • BI.Summary


TSummary.Calculate Method

Summary

Represents method Calculate.

Namespace: BI.Summary
Syntax
Delphi
public
 function Calculate:TDataItem; overload;

Return Value

Type: TDataItem

See Also

Reference

  • TSummary
  • BI.Summary


TSummary.Calculate(TDataItem) Method

Summary

Represents method Calculate(TDataItem).

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Calculate(const AData:TDataItem); overload;

Parameters

AData
Type: TDataItem

See Also

Reference

  • TSummary
  • BI.Summary


TSummary.Clear Method

Summary

Represents method Clear.

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TSummary
  • BI.Summary


TSummary.FillGroupByRows Method

Summary

Represents method FillGroupByRows.

Namespace: BI.Summary
Syntax
Delphi
protected
 procedure FillGroupByRows;
See Also

Reference

  • TSummary
  • BI.Summary


TSummary.GuessByLayout Method

Summary

Represents method GuessByLayout.

Namespace: BI.Summary
Syntax
Delphi
protected
 procedure GuessByLayout;
See Also

Reference

  • TSummary
  • BI.Summary


TSummary.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Summary
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TSummary
  • BI.Summary


TSummary.Prepare Method

Summary

Represents method Prepare.

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Prepare;
See Also

Reference

  • TSummary
  • BI.Summary


TSummary.SetDirectFilter(TExpression) Method

Summary

Represents method SetDirectFilter(TExpression).

Namespace: BI.Summary
Syntax
Delphi
protected
 procedure SetDirectFilter(const Value: TExpression);

Parameters

Value
Type: TExpression

See Also

Reference

  • TSummary
  • BI.Summary


TSummary.ToString Method

Summary

Represents method ToString.

Namespace: BI.Summary
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TSummary
  • BI.Summary


TSummary.Valid Method

Summary

Represents method Valid.

Namespace: BI.Summary
Syntax
Delphi
public
 function Valid:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TSummary
  • BI.Summary


TSummary Fields

Fields
Name | Description
By | Represents field By.
ByCols | Represents field ByCols.
ByRows | Represents field ByRows.
Hops | Represents field Hops.
Measures | Represents field Measures.
SortBy | Represents field SortBy.
Top


TSummary.By Field

Summary

Represents field By.

Namespace: BI.Summary
Syntax
Delphi
public
 By : TGroupBys;

Field Value

Type: TGroupBys

See Also

Reference

  • TSummary
  • BI.Summary


TSummary.ByCols Field

Summary

Represents field ByCols.

Namespace: BI.Summary
Syntax
Delphi
protected
 ByRows,
 ByCols : TGroupBys;

Field Value

Type: TGroupBys

See Also

Reference

  • TSummary
  • BI.Summary


TSummary.ByRows Field

Summary

Represents field ByRows.

Namespace: BI.Summary
Syntax
Delphi
protected
 ByRows,
 ByCols : TGroupBys;

Field Value

Type: TGroupBys

See Also

Reference

  • TSummary
  • BI.Summary


TSummary.Hops Field

Summary

Represents field Hops.

Namespace: BI.Summary
Syntax
Delphi
protected
 Hops : TDataHops;

Field Value

Type: TDataHops

See Also

Reference

  • TSummary
  • BI.Summary


TSummary.Measures Field

Summary

Represents field Measures.

Namespace: BI.Summary
Syntax
Delphi
public
 Measures : TMeasures;

Field Value

Type: TMeasures

See Also

Reference

  • TSummary
  • BI.Summary


TSummary.SortBy Field

Summary

Represents field SortBy.

Namespace: BI.Summary
Syntax
Delphi
public
 SortBy : TSortItems;

Field Value

Type: TSortItems

See Also

Reference

  • TSummary
  • BI.Summary


TSummaryExpression Class

Summary

Represents type TSummaryExpression.

Namespace: BI.Summary
Inheritance Hierarchy
TObject
BI.Expression.TExpression
BI.Summary.TSummaryExpression
Syntax
Delphi
type
 TSummaryExpression=class(TExpression)
 end;

The TSummaryExpression type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TSummaryExpression class.
Top
Methods
Show:
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
FromString(TSummaryItem,String) | Represents method FromString(TSummaryItem,String).
GetExpression(TDataItem) | Represents method GetExpression(TDataItem).
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top
See Also

Reference

  • BI.Summary


TSummaryExpression Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TSummaryExpression class.
Top


TSummaryExpression.Destroy Destructor

Summary

Represents the destructor of the TSummaryExpression class.

Namespace: BI.Summary
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TSummaryExpression
  • BI.Summary


TSummaryExpression Methods

Methods
Name | Description
Assign(TExpression) | Represents method Assign(TExpression). (Overrides TExpression.Assign(TExpression).)
FromString(TSummaryItem,String) | Represents method FromString(TSummaryItem,String).
GetExpression(TDataItem) | Represents method GetExpression(TDataItem).
ToString | Represents method ToString.
Value | Represents method Value. (Overrides TExpression.Value.)
Top


TSummaryExpression.Assign(TExpression) Method

Summary

Represents method Assign(TExpression).

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Assign(const Source:TExpression); override;

Parameters

Source
Type: TExpression

Overrides

TExpression.Assign(TExpression)
See Also

Reference

  • TSummaryExpression
  • BI.Summary


TSummaryExpression.FromString(TSummaryItem,String) Method

Summary

Represents method FromString(TSummaryItem,String).

Namespace: BI.Summary
Syntax
Delphi
public
 class function FromString(const AItem:TSummaryItem; const AExpression:String):TSummaryExpression; static;

Parameters

AItem
Type: TSummaryItem

AExpression
Type: String

Return Value

Type: TSummaryExpression

See Also

Reference

  • TSummaryExpression
  • BI.Summary


TSummaryExpression.GetExpression(TDataItem) Method

Summary

Represents method GetExpression(TDataItem).

Namespace: BI.Summary
Syntax
Delphi
public
 function GetExpression(const AData:TDataItem):TExpression;

Parameters

AData
Type: TDataItem

Return Value

Type: TExpression

See Also

Reference

  • TSummaryExpression
  • BI.Summary


TSummaryExpression.ToString Method

Summary

Represents method ToString.

Namespace: BI.Summary
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TSummaryExpression
  • BI.Summary


TSummaryExpression.Value Method

Summary

Represents method Value.

Namespace: BI.Summary
Syntax
Delphi
public
 function Value:TData; override;

Return Value

Type: TData

Overrides

TExpression.Value
See Also

Reference

  • TSummaryExpression
  • BI.Summary


TSummaryFilter Class

Summary

Represents type TSummaryFilter.

Namespace: BI.Summary
Inheritance Hierarchy
TObject
BI.Expressions.TDataExpression
BI.Summary.TSummaryFilter
Syntax
Delphi
type
 TSummaryFilter=class(TDataExpression)
 end;

The TSummaryFilter type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TSummaryFilter class.
Top
Methods
Show:
Name | Description
Add(String) | Overloaded. Represents method Add(String).
Add(TSummaryItem,String) | Overloaded. Represents method Add(TSummaryItem,String).
Assign(TSummaryFilter) | Represents method Assign(TSummaryFilter).
Clear | Represents method Clear.
GetExpression(TDataItem) | Represents method GetExpression(TDataItem).
Reset | Represents method Reset.
Resolve(TDataItem,String,TErrorProc) | Represents method Resolve(TDataItem,String,TErrorProc). (Overrides TDataExpression.Resolve(TDataItem,String,TErrorProc).)
ToString | Represents method ToString.
Top
See Also

Reference

  • BI.Summary


TSummaryFilter Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TSummaryFilter class.
Top


TSummaryFilter.Destroy Destructor

Summary

Represents the destructor of the TSummaryFilter class.

Namespace: BI.Summary
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TSummaryFilter
  • BI.Summary


TSummaryFilter Methods

Methods
Name | Description
Add(String) | Overloaded. Represents method Add(String).
Add(TSummaryItem,String) | Overloaded. Represents method Add(TSummaryItem,String).
Assign(TSummaryFilter) | Represents method Assign(TSummaryFilter).
Clear | Represents method Clear.
GetExpression(TDataItem) | Represents method GetExpression(TDataItem).
Reset | Represents method Reset.
Resolve(TDataItem,String,TErrorProc) | Represents method Resolve(TDataItem,String,TErrorProc). (Overrides TDataExpression.Resolve(TDataItem,String,TErrorProc).)
ToString | Represents method ToString.
Top


TSummaryFilter.Add(String) Method

Summary

Represents method Add(String).

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Add(const AExpression:String); overload;

Parameters

AExpression
Type: String

See Also

Reference

  • TSummaryFilter
  • BI.Summary


TSummaryFilter.Add(TSummaryItem,String) Method

Summary

Represents method Add(TSummaryItem,String).

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Add(const AItem:TSummaryItem; const AExpression:String); overload;

Parameters

AItem
Type: TSummaryItem

AExpression
Type: String

See Also

Reference

  • TSummaryFilter
  • BI.Summary


TSummaryFilter.Assign(TSummaryFilter) Method

Summary

Represents method Assign(TSummaryFilter).

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Assign(const AFilter:TSummaryFilter);

Parameters

AFilter
Type: TSummaryFilter

See Also

Reference

  • TSummaryFilter
  • BI.Summary


TSummaryFilter.Clear Method

Summary

Represents method Clear.

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TSummaryFilter
  • BI.Summary


TSummaryFilter.GetExpression(TDataItem) Method

Summary

Represents method GetExpression(TDataItem).

Namespace: BI.Summary
Syntax
Delphi
public
 function GetExpression(const AData:TDataItem):TExpression;

Parameters

AData
Type: TDataItem

Return Value

Type: TExpression

See Also

Reference

  • TSummaryFilter
  • BI.Summary


TSummaryFilter.Reset Method

Summary

Represents method Reset.

Namespace: BI.Summary
Syntax
Delphi
protected
 procedure Reset;
See Also

Reference

  • TSummaryFilter
  • BI.Summary


TSummaryFilter.Resolve(TDataItem,String,TErrorProc) Method

Summary

Represents method Resolve(TDataItem,String,TErrorProc).

Namespace: BI.Summary
Syntax
Delphi
protected
 class function Resolve(const AData:TDataItem; const AText:String;
 const Error:TErrorProc):TExpression; override;

Parameters

AData
Type: TDataItem

AText
Type: String

Error
Type: TErrorProc

Return Value

Type: TExpression

Overrides

TDataExpression.Resolve(TDataItem,String,TErrorProc)
See Also

Reference

  • TSummaryFilter
  • BI.Summary


TSummaryFilter.ToString Method

Summary

Represents method ToString.

Namespace: BI.Summary
Syntax
Delphi
public
 function ToString:String; override;

Return Value

Type: String

See Also

Reference

  • TSummaryFilter
  • BI.Summary


TSummaryItem Class

Summary

Represents type TSummaryItem.

Namespace: BI.Summary
Inheritance Hierarchy
TPersistent
BI.Summary.TBaseSummaryPersistent
BI.Summary.TSummaryItem
BI.Summary.TGroupBy
BI.Summary.TMeasure
VCLBI.Editor.Hops.TSummaryItemAccess
Syntax
Delphi
type
 TSummaryItem=class(TBaseSummaryPersistent)
 end;

The TSummaryItem type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TSummaryItem class.
Destroy | Represents the destructor of the TSummaryItem class.
Top
Properties
Show:
Name | Description
Active | Represents property Active.
Data | Represents property Data.
DestData | Represents property DestData.
Expression | Represents property Expression.
Name | Represents property Name.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Clear | Represents method Clear.
GuessType(TDataItem) | Represents method GuessType(TDataItem).
RealData | Represents method RealData.
Top
Fields
Show:
Name | Description
Source | Represents field Source.
Top
See Also

Reference

  • BI.Summary


TSummaryItem Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TSummaryItem class.
Destroy | Represents the destructor of the TSummaryItem class.
Top


TSummaryItem.Create Constructor

Summary

Initializes a new instance of the TSummaryItem class.

Namespace: BI.Summary
Syntax
Delphi
public
 Constructor Create; virtual;
See Also

Reference

  • TSummaryItem
  • BI.Summary


TSummaryItem.Destroy Destructor

Summary

Represents the destructor of the TSummaryItem class.

Namespace: BI.Summary
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TSummaryItem
  • BI.Summary


TSummaryItem Properties

Properties
Name | Description
Active | Represents property Active.
Data | Represents property Data.
DestData | Represents property DestData.
Expression | Represents property Expression.
Name | Represents property Name.
Top


TSummaryItem.Active Property

Summary

Represents property Active.

Namespace: BI.Summary
Syntax
Delphi
published
 property Active:Boolean read FActive write SetActive default True;

Property Value

Type: Boolean

See Also

Reference

  • TSummaryItem
  • BI.Summary


TSummaryItem.Data Property

Summary

Represents property Data.

Namespace: BI.Summary
Syntax
Delphi
published
 property Data:TDataItem read FData write SetData;

Property Value

Type: TDataItem

See Also

Reference

  • TSummaryItem
  • BI.Summary


TSummaryItem.DestData Property

Summary

Represents property DestData.

Namespace: BI.Summary
Syntax
Delphi
published
 property DestData:TDataItem read FDestData;

Property Value

Type: TDataItem

See Also

Reference

  • TSummaryItem
  • BI.Summary


TSummaryItem.Expression Property

Summary

Represents property Expression.

Namespace: BI.Summary
Syntax
Delphi
published
 property Expression:TExpression read Source write SetExpression;

Property Value

Type: TExpression

See Also

Reference

  • TSummaryItem
  • BI.Summary


TSummaryItem.Name Property

Summary

Represents property Name.

Namespace: BI.Summary
Syntax
Delphi
published
 property Name:String read FName write SetName;

Property Value

Type: String

See Also

Reference

  • TSummaryItem
  • BI.Summary


TSummaryItem Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Clear | Represents method Clear.
GuessType(TDataItem) | Represents method GuessType(TDataItem).
RealData | Represents method RealData.
Top


TSummaryItem.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TSummaryItem
  • BI.Summary


TSummaryItem.Clear Method

Summary

Represents method Clear.

Namespace: BI.Summary
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TSummaryItem
  • BI.Summary


TSummaryItem.GuessType(TDataItem) Method

Summary

Represents method GuessType(TDataItem).

Namespace: BI.Summary
Syntax
Delphi
public
 class function GuessType(const AData:TDataItem):TSummaryItemType; static;

Parameters

AData
Type: TDataItem

Return Value

Type: TSummaryItemType

See Also

Reference

  • TSummaryItem
  • BI.Summary


TSummaryItem.RealData Method

Summary

Represents method RealData.

Namespace: BI.Summary
Syntax
Delphi
public
 function RealData:TDataItem;

Return Value

Type: TDataItem

See Also

Reference

  • TSummaryItem
  • BI.Summary


TSummaryItem Fields

Fields
Name | Description
Source | Represents field Source.
Top


TSummaryItem.Source Field

Summary

Represents field Source.

Namespace: BI.Summary
Syntax
Delphi
protected
 Source : TExpression;

Field Value

Type: TExpression

See Also

Reference

  • TSummaryItem
  • BI.Summary


BI.Summary Records

Records
Name | Description
TBin | Represents type TBin.
TGroupByDate | Represents type TGroupByDate.
Top


TBin Record

Summary

Represents type TBin.

Namespace: BI.Summary
Syntax
Delphi
type
 TBin=record
 end;

The TBin type exposes the following members.

Fields
Show:
Name | Description
Count | Represents field Count.
Maximum | Represents field Maximum.
Top
See Also

Reference

  • BI.Summary


TBin Fields

Fields
Name | Description
Count | Represents field Count.
Maximum | Represents field Maximum.
Top


TBin.Count Field

Summary

Represents field Count.

Namespace: BI.Summary
Syntax
Delphi
public
 Count : TInteger;

Field Value

Type: TInteger

See Also

Reference

  • TBin
  • BI.Summary


TBin.Maximum Field

Summary

Represents field Maximum.

Namespace: BI.Summary
Syntax
Delphi
public
 Maximum : TFloat;

Field Value

Type: TFloat

See Also

Reference

  • TBin
  • BI.Summary


TGroupByDate Record

Summary

Represents type TGroupByDate.

Namespace: BI.Summary
Syntax
Delphi
type
 TGroupByDate=record
 end;

The TGroupByDate type exposes the following members.

Fields
Show:
Name | Description
Part | Represents field Part.
Top
See Also

Reference

  • BI.Summary


TGroupByDate Fields

Fields
Name | Description
Part | Represents field Part.
Top


TGroupByDate.Part Field

Summary

Represents field Part.

Namespace: BI.Summary
Syntax
Delphi
public
 Part : TDateTimePart;

Field Value

Type: TDateTimePart

See Also

Reference

  • TGroupByDate
  • BI.Summary


BI.Summary Enumerations

Enumerations
Name | Description
TAggregate | Represents type TAggregate.
TCalculationPercentage | Represents type TCalculationPercentage.
TCalculationRunning | Represents type TCalculationRunning.
TGroupByLayout | Represents type TGroupByLayout.
TSummaryItemType | Represents type TSummaryItemType.
Top


TAggregate Enumeration

Summary

Represents type TAggregate.

Namespace: BI.Summary
Syntax
Delphi
type
 TAggregate=(Count,Sum,Average,Minimum,Maximum,First,Last);

The TAggregate type exposes the following members.

Members
Show:
Name | Description
Average | Represents constant Average.
Count | Represents constant Count.
First | Represents constant First.
Last | Represents constant Last.
Maximum | Represents constant Maximum.
Minimum | Represents constant Minimum.
Sum | Represents constant Sum.
Top
See Also

Reference

  • BI.Summary


TCalculationPercentage Enumeration

Summary

Represents type TCalculationPercentage.

Namespace: BI.Summary
Syntax
Delphi
type
 TCalculationPercentage=(None, Column, Row, Total);

The TCalculationPercentage type exposes the following members.

Members
Show:
Name | Description
Column | Represents constant Column.
None | Represents constant None.
Row | Represents constant Row.
Total | Represents constant Total.
Top
See Also

Reference

  • BI.Summary


TCalculationRunning Enumeration

Summary

Represents type TCalculationRunning.

Namespace: BI.Summary
Syntax
Delphi
type
 TCalculationRunning=(No, Cumulative, Difference);

The TCalculationRunning type exposes the following members.

Members
Show:
Name | Description
Cumulative | Represents constant Cumulative.
Difference | Represents constant Difference.
No | Represents constant No.
Top
See Also

Reference

  • BI.Summary


TGroupByLayout Enumeration

Summary

Represents type TGroupByLayout.

Namespace: BI.Summary
Syntax
Delphi
type
 TGroupByLayout=(Automatic,Rows,Items);

The TGroupByLayout type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Items | Represents constant Items.
Rows | Represents constant Rows.
Top
See Also

Reference

  • BI.Summary


TSummaryItemType Enumeration

Summary

Represents type TSummaryItemType.

Namespace: BI.Summary
Syntax
Delphi
type
 TSummaryItemType=(GroupBy, Measure, GroupOrMeasure);

The TSummaryItemType type exposes the following members.

Members
Show:
Name | Description
GroupBy | Represents constant GroupBy.
GroupOrMeasure | Represents constant GroupOrMeasure.
Measure | Represents constant Measure.
Top
See Also

Reference

  • BI.Summary


BI.Summary Types

Types
Name | Description
TBinArray | Represents an array of the TBin type.
TGroupBys | Represents an array of the TGroupBy type.
TMeasures | Represents an array of the TMeasure type.
Top


TBinArray Type

Summary

Represents an array of the TBin type.

Namespace: BI.Summary
Syntax
Delphi
type
 TBinArray=Array of TBin;
See Also

Reference

  • BI.Summary


TGroupBys Type

Summary

Represents an array of the TGroupBy type.

Namespace: BI.Summary
Syntax
Delphi
type
 TGroupBys=Array of TGroupBy;
See Also

Reference

  • BI.Summary


TMeasures Type

Summary

Represents an array of the TMeasure type.

Namespace: BI.Summary
Syntax
Delphi
type
 TMeasures=Array of TMeasure;
See Also

Reference

  • BI.Summary


BI.Summary Routines

Routines
Name | Description
DecadeOf(Integer) | Represents method DecadeOf(Integer).
Top


DecadeOf(Integer) Method

Summary

Represents method DecadeOf(Integer).

Namespace: BI.Summary
Syntax
Delphi
function DecadeOf(const AYear:Integer):Integer; inline;

Parameters

AYear
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • BI.Summary


BI.Summary.Persist Namespace

Summary

Represents namespace BI.Summary.Persist.

Classes
Name | Description
TSummaries | Represents type TSummaries.
TSummaryAccess | Represents type TSummaryAccess.
TSummaryPersist | Represents type TSummaryPersist.
Top
Records
Name | Description
TNamedSummary | Represents type TNamedSummary.
Top


BI.Summary.Persist Classes

Classes
Name | Description
TSummaries | Represents type TSummaries.
TSummaryAccess | Represents type TSummaryAccess.
TSummaryPersist | Represents type TSummaryPersist.
Top


TSummaries Class

Summary

Represents type TSummaries.

Namespace: BI.Summary.Persist
Inheritance Hierarchy
TObject
BI.Summary.Persist.TSummaries
Syntax
Delphi
type
 TSummaries=class
 end;

The TSummaries type exposes the following members.

Constructors
Show:
Name | Description
Destroy | Represents the destructor of the TSummaries class.
Top
Methods
Show:
Name | Description
Add(TSummary) | Represents method Add(TSummary).
Clear | Represents method Clear.
Count | Represents method Count.
Load(String) | Overloaded. Represents method Load(String).
Load(TBIReader) | Overloaded. Represents method Load(TBIReader).
Load(TStream) | Overloaded. Represents method Load(TStream).
Save(String) | Overloaded. Represents method Save(String).
Save(TBIWriter) | Overloaded. Represents method Save(TBIWriter).
Save(TStream) | Overloaded. Represents method Save(TStream).
Top
Fields
Show:
Name | Description
Items | Represents field Items.
Top
See Also

Reference

  • BI.Summary.Persist


TSummaries Constructors

Constructors
Name | Description
Destroy | Represents the destructor of the TSummaries class.
Top


TSummaries.Destroy Destructor

Summary

Represents the destructor of the TSummaries class.

Namespace: BI.Summary.Persist
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TSummaries
  • BI.Summary.Persist


TSummaries Methods

Methods
Name | Description
Add(TSummary) | Represents method Add(TSummary).
Clear | Represents method Clear.
Count | Represents method Count.
Load(String) | Overloaded. Represents method Load(String).
Load(TBIReader) | Overloaded. Represents method Load(TBIReader).
Load(TStream) | Overloaded. Represents method Load(TStream).
Save(String) | Overloaded. Represents method Save(String).
Save(TBIWriter) | Overloaded. Represents method Save(TBIWriter).
Save(TStream) | Overloaded. Represents method Save(TStream).
Top


TSummaries.Add(TSummary) Method

Summary

Represents method Add(TSummary).

Namespace: BI.Summary.Persist
Syntax
Delphi
public
 procedure Add(const ASummary:TSummary);

Parameters

ASummary
Type: TSummary

See Also

Reference

  • TSummaries
  • BI.Summary.Persist


TSummaries.Clear Method

Summary

Represents method Clear.

Namespace: BI.Summary.Persist
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TSummaries
  • BI.Summary.Persist


TSummaries.Count Method

Summary

Represents method Count.

Namespace: BI.Summary.Persist
Syntax
Delphi
public
 function Count:Integer;

Return Value

Type: Integer

See Also

Reference

  • TSummaries
  • BI.Summary.Persist


TSummaries.Load(String) Method

Summary

Represents method Load(String).

Namespace: BI.Summary.Persist
Syntax
Delphi
public
 procedure Load(const FileName:String); overload;

Parameters

FileName
Type: String

See Also

Reference

  • TSummaries
  • BI.Summary.Persist


TSummaries.Load(TBIReader) Method

Summary

Represents method Load(TBIReader).

Namespace: BI.Summary.Persist
Syntax
Delphi
public
 procedure Load(const Reader:TBIReader); overload;

Parameters

Reader
Type: TBIReader

See Also

Reference

  • TSummaries
  • BI.Summary.Persist


TSummaries.Load(TStream) Method

Summary

Represents method Load(TStream).

Namespace: BI.Summary.Persist
Syntax
Delphi
public
 procedure Load(const Stream:TStream); overload;

Parameters

Stream
Type: TStream

See Also

Reference

  • TSummaries
  • BI.Summary.Persist


TSummaries.Save(String) Method

Summary

Represents method Save(String).

Namespace: BI.Summary.Persist
Syntax
Delphi
public
 procedure Save(const FileName:String); overload;

Parameters

FileName
Type: String

See Also

Reference

  • TSummaries
  • BI.Summary.Persist


TSummaries.Save(TBIWriter) Method

Summary

Represents method Save(TBIWriter).

Namespace: BI.Summary.Persist
Syntax
Delphi
public
 procedure Save(const Writer:TBIWriter); overload;

Parameters

Writer
Type: TBIWriter

See Also

Reference

  • TSummaries
  • BI.Summary.Persist


TSummaries.Save(TStream) Method

Summary

Represents method Save(TStream).

Namespace: BI.Summary.Persist
Syntax
Delphi
public
 procedure Save(const Stream:TStream); overload;

Parameters

Stream
Type: TStream

See Also

Reference

  • TSummaries
  • BI.Summary.Persist


TSummaries Fields

Fields
Name | Description
Items | Represents field Items.
Top


TSummaries.Items Field

Summary

Represents field Items.

Namespace: BI.Summary.Persist
Syntax
Delphi
public
 Items : Array of TNamedSummary;

Field Value

Type: Array of TNamedSummary

See Also

Reference

  • TSummaries
  • BI.Summary.Persist


TSummaryAccess Class

Summary

Represents type TSummaryAccess.

Namespace: BI.Summary.Persist
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Summary.TSummary
BI.Summary.Persist.TSummaryAccess
Syntax
Delphi
type
 TSummaryAccess=class(TSummary);
See Also

Reference

  • BI.Summary.Persist


TSummaryPersist Class

Summary

Represents type TSummaryPersist.

Namespace: BI.Summary.Persist
Inheritance Hierarchy
TObject
BI.Summary.Persist.TSummaryPersist
Syntax
Delphi
type
 TSummaryPersist=class
 end;

The TSummaryPersist type exposes the following members.

Methods
Show:
Name | Description
LoadFrom(TBIReader) | Overloaded. Represents method LoadFrom(TBIReader).
LoadFrom(TStream) | Overloaded. Represents method LoadFrom(TStream).
Save(TBIWriter,TSummary) | Overloaded. Represents method Save(TBIWriter,TSummary).
Save(TStream,TSummary) | Overloaded. Represents method Save(TStream,TSummary).
Top
See Also

Reference

  • BI.Summary.Persist


TSummaryPersist Methods

Methods
Name | Description
LoadFrom(TBIReader) | Overloaded. Represents method LoadFrom(TBIReader).
LoadFrom(TStream) | Overloaded. Represents method LoadFrom(TStream).
Save(TBIWriter,TSummary) | Overloaded. Represents method Save(TBIWriter,TSummary).
Save(TStream,TSummary) | Overloaded. Represents method Save(TStream,TSummary).
Top


TSummaryPersist.LoadFrom(TBIReader) Method

Summary

Represents method LoadFrom(TBIReader).

Namespace: BI.Summary.Persist
Syntax
Delphi
public
 class function LoadFrom(const Reader: TBIReader): TSummary; overload; static;

Parameters

Reader
Type: TBIReader

Return Value

Type: TSummary

See Also

Reference

  • TSummaryPersist
  • BI.Summary.Persist


TSummaryPersist.LoadFrom(TStream) Method

Summary

Represents method LoadFrom(TStream).

Namespace: BI.Summary.Persist
Syntax
Delphi
public
 class function LoadFrom(const Stream: TStream): TSummary; overload; static;

Parameters

Stream
Type: TStream

Return Value

Type: TSummary

See Also

Reference

  • TSummaryPersist
  • BI.Summary.Persist


TSummaryPersist.Save(TBIWriter,TSummary) Method

Summary

Represents method Save(TBIWriter,TSummary).

Namespace: BI.Summary.Persist
Syntax
Delphi
public
 class procedure Save(const Writer: TBIWriter; const Summary:TSummary); overload; static;

Parameters

Writer
Type: TBIWriter

Summary
Type: TSummary

See Also

Reference

  • TSummaryPersist
  • BI.Summary.Persist


TSummaryPersist.Save(TStream,TSummary) Method

Summary

Represents method Save(TStream,TSummary).

Namespace: BI.Summary.Persist
Syntax
Delphi
public
 class procedure Save(const Stream: TStream; const Summary:TSummary); overload; static;

Parameters

Stream
Type: TStream

Summary
Type: TSummary

See Also

Reference

  • TSummaryPersist
  • BI.Summary.Persist


BI.Summary.Persist Records

Records
Name | Description
TNamedSummary | Represents type TNamedSummary.
Top


TNamedSummary Record

Summary

Represents type TNamedSummary.

Namespace: BI.Summary.Persist
Syntax
Delphi
type
 TNamedSummary=record
 end;

The TNamedSummary type exposes the following members.

Fields
Show:
Name | Description
Name | Represents field Name.
Summary | Represents field Summary.
Top
See Also

Reference

  • BI.Summary.Persist


TNamedSummary Fields

Fields
Name | Description
Name | Represents field Name.
Summary | Represents field Summary.
Top


TNamedSummary.Name Field

Summary

Represents field Name.

Namespace: BI.Summary.Persist
Syntax
Delphi
public
 Name : String;

Field Value

Type: String

See Also

Reference

  • TNamedSummary
  • BI.Summary.Persist


TNamedSummary.Summary Field

Summary

Represents field Summary.

Namespace: BI.Summary.Persist
Syntax
Delphi
public
 Summary : TSummary;

Field Value

Type: TSummary

See Also

Reference

  • TNamedSummary
  • BI.Summary.Persist


BI.Summary.Totals Namespace

Summary

Represents namespace BI.Summary.Totals.

Classes
Name | Description
TDataItemAccess | Represents type TDataItemAccess.
TGroupByAccess | Represents type TGroupByAccess.
TSummaryTotals | Represents type TSummaryTotals.
Top


BI.Summary.Totals Classes

Classes
Name | Description
TDataItemAccess | Represents type TDataItemAccess.
TGroupByAccess | Represents type TGroupByAccess.
TSummaryTotals | Represents type TSummaryTotals.
Top


TDataItemAccess Class

Summary

Represents type TDataItemAccess.

Namespace: BI.Summary.Totals
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Summary.Totals.TDataItemAccess
Syntax
Delphi
type
 TDataItemAccess=class(TDataItem);
See Also

Reference

  • BI.Summary.Totals


TGroupByAccess Class

Summary

Represents type TGroupByAccess.

Namespace: BI.Summary.Totals
Inheritance Hierarchy
TPersistent
BI.Summary.TBaseSummaryPersistent
BI.Summary.TSummaryItem
BI.Summary.TGroupBy
BI.Summary.Totals.TGroupByAccess
Syntax
Delphi
type
 TGroupByAccess=class(TGroupBy);
See Also

Reference

  • BI.Summary.Totals


TSummaryTotals Class

Summary

Represents type TSummaryTotals.

Namespace: BI.Summary.Totals
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Summary.Totals.TSummaryTotals
Syntax
Delphi
type
 TSummaryTotals=class(TDataProvider)
 end;

The TSummaryTotals type exposes the following members.

Constructors
Show:
Name | Description
CreateSummary(TComponent,TSummary) | Initializes a new instance of the TSummaryTotals class.
Destroy | Represents the destructor of the TSummaryTotals class. (Overrides TDataProvider.Destroy.)
Top
Properties
Show:
Name | Description
Summary | Represents property Summary.
Top
Methods
Show:
Name | Description
Calculate(TDataItem) | Represents method Calculate(TDataItem).
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
Top
See Also

Reference

  • BI.Summary.Totals


TSummaryTotals Constructors

Constructors
Name | Description
CreateSummary(TComponent,TSummary) | Initializes a new instance of the TSummaryTotals class.
Destroy | Represents the destructor of the TSummaryTotals class. (Overrides TDataProvider.Destroy.)
Top


TSummaryTotals.CreateSummary(TComponent,TSummary) Constructor

Summary

Initializes a new instance of the TSummaryTotals class.

Namespace: BI.Summary.Totals
Syntax
Delphi
public
 Constructor CreateSummary(const AOwner:TComponent; const ASummary:TSummary);

Parameters

AOwner
Type: TComponent

ASummary
Type: TSummary

See Also

Reference

  • TSummaryTotals
  • BI.Summary.Totals


TSummaryTotals.Destroy Destructor

Summary

Represents the destructor of the TSummaryTotals class.

Namespace: BI.Summary.Totals
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TDataProvider.Destroy
See Also

Reference

  • TSummaryTotals
  • BI.Summary.Totals


TSummaryTotals Properties

Properties
Name | Description
Summary | Represents property Summary.
Top


TSummaryTotals.Summary Property

Summary

Represents property Summary.

Namespace: BI.Summary.Totals
Syntax
Delphi
published
 property Summary:TSummary read FSummary write SetSummary;

Property Value

Type: TSummary

See Also

Reference

  • TSummaryTotals
  • BI.Summary.Totals


TSummaryTotals Methods

Methods
Name | Description
Calculate(TDataItem) | Represents method Calculate(TDataItem).
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
Top


TSummaryTotals.Calculate(TDataItem) Method

Summary

Represents method Calculate(TDataItem).

Namespace: BI.Summary.Totals
Syntax
Delphi
public
 procedure Calculate(const AData:TDataItem);

Parameters

AData
Type: TDataItem

See Also

Reference

  • TSummaryTotals
  • BI.Summary.Totals


TSummaryTotals.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Summary.Totals
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TSummaryTotals
  • BI.Summary.Totals


TSummaryTotals.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: BI.Summary.Totals
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

See Also

Reference

  • TSummaryTotals
  • BI.Summary.Totals


BI.Tools Namespace

Summary

Represents namespace BI.Tools.

Classes
Name | Description
TDataAccess | Represents type TDataAccess.
Top
Records
Name | Description
TDataNormalize | Represents type TDataNormalize.
TDataSplit | Represents type TDataSplit.
TSplitOptions | Represents type TSplitOptions.
Top
Enumerations
Name | Description
TSplitBy | Represents type TSplitBy.
TSplitMode | Represents type TSplitMode.
Top


BI.Tools Classes

Classes
Name | Description
TDataAccess | Represents type TDataAccess.
Top


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.Tools
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Tools.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.Tools


BI.Tools Records

Records
Name | Description
TDataNormalize | Represents type TDataNormalize.
TDataSplit | Represents type TDataSplit.
TSplitOptions | Represents type TSplitOptions.
Top


TDataNormalize Record

Summary

Represents type TDataNormalize.

Namespace: BI.Tools
Syntax
Delphi
type
 TDataNormalize=record
 end;

The TDataNormalize type exposes the following members.

Methods
Show:
Name | Description
Normalize(TDataArray) | Overloaded. Represents method Normalize(TDataArray).
Normalize(TDataItem) | Overloaded. Represents method Normalize(TDataItem).
Top
See Also

Reference

  • BI.Tools


TDataNormalize Methods

Methods
Name | Description
Normalize(TDataArray) | Overloaded. Represents method Normalize(TDataArray).
Normalize(TDataItem) | Overloaded. Represents method Normalize(TDataItem).
Top


TDataNormalize.Normalize(TDataArray) Method

Summary

Represents method Normalize(TDataArray).

Namespace: BI.Tools
Syntax
Delphi
public
 class procedure Normalize(const AData:TDataArray); overload; static;

Parameters

AData
Type: TDataArray

See Also

Reference

  • TDataNormalize
  • BI.Tools


TDataNormalize.Normalize(TDataItem) Method

Summary

Represents method Normalize(TDataItem).

Namespace: BI.Tools
Syntax
Delphi
public
 class procedure Normalize(const AData:TDataItem); overload; static;

Parameters

AData
Type: TDataItem

See Also

Reference

  • TDataNormalize
  • BI.Tools


TDataSplit Record

Summary

Represents type TDataSplit.

Namespace: BI.Tools
Syntax
Delphi
type
 TDataSplit=record
 end;

The TDataSplit type exposes the following members.

Methods
Show:
Name | Description
From(TInteger,TSplitOptions) | Represents method From(TInteger,TSplitOptions).
Random(TInteger,TInteger) | Represents method Random(TInteger,TInteger).
Sequence(TInteger,TInteger) | Represents method Sequence(TInteger,TInteger).
Top
Fields
Show:
Name | Description
A | Represents field A.
B | Represents field B.
Top
See Also

Reference

  • BI.Tools


TDataSplit Methods

Methods
Name | Description
From(TInteger,TSplitOptions) | Represents method From(TInteger,TSplitOptions).
Random(TInteger,TInteger) | Represents method Random(TInteger,TInteger).
Sequence(TInteger,TInteger) | Represents method Sequence(TInteger,TInteger).
Top


TDataSplit.From(TInteger,TSplitOptions) Method

Summary

Represents method From(TInteger,TSplitOptions).

Namespace: BI.Tools
Syntax
Delphi
public
 procedure From(const ATotal:TInteger; const AOptions:TSplitOptions);

Parameters

ATotal
Type: System.Void

AOptions
Type: TSplitOptions

See Also

Reference

  • TDataSplit
  • BI.Tools


TDataSplit.Random(TInteger,TInteger) Method

Summary

Represents method Random(TInteger,TInteger).

Namespace: BI.Tools
Syntax
Delphi
public
 procedure Random(const CountA, CountB:TInteger);

Parameters

CountA
Type: System.Void

CountB
Type: System.Void

See Also

Reference

  • TDataSplit
  • BI.Tools


TDataSplit.Sequence(TInteger,TInteger) Method

Summary

Represents method Sequence(TInteger,TInteger).

Namespace: BI.Tools
Syntax
Delphi
public
 procedure Sequence(const CountA, CountB:TInteger);

Parameters

CountA
Type: System.Void

CountB
Type: System.Void

See Also

Reference

  • TDataSplit
  • BI.Tools


TDataSplit Fields

Fields
Name | Description
A | Represents field A.
B | Represents field B.
Top


TDataSplit.A Field

Summary

Represents field A.

Namespace: BI.Tools
Syntax
Delphi
public
 A,
 B : TNativeIntArray;

Field Value

Type: TNativeIntArray

See Also

Reference

  • TDataSplit
  • BI.Tools


TDataSplit.B Field

Summary

Represents field B.

Namespace: BI.Tools
Syntax
Delphi
public
 A,
 B : TNativeIntArray;

Field Value

Type: TNativeIntArray

See Also

Reference

  • TDataSplit
  • BI.Tools


TSplitOptions Record

Summary

Represents type TSplitOptions.

Namespace: BI.Tools
Syntax
Delphi
type
 TSplitOptions=record
 end;

The TSplitOptions type exposes the following members.

Methods
Show:
Name | Description
Initialize | Represents method Initialize.
Top
Fields
Show:
Name | Description
By | Represents field By.
Count | Represents field Count.
Mode | Represents field Mode.
Percent | Represents field Percent.
Top
See Also

Reference

  • BI.Tools


TSplitOptions Methods

Methods
Name | Description
Initialize | Represents method Initialize.
Top


TSplitOptions.Initialize Method

Summary

Represents method Initialize.

Namespace: BI.Tools
Syntax
Delphi
public
 procedure Initialize;
See Also

Reference

  • TSplitOptions
  • BI.Tools


TSplitOptions Fields

Fields
Name | Description
By | Represents field By.
Count | Represents field Count.
Mode | Represents field Mode.
Percent | Represents field Percent.
Top


TSplitOptions.By Field

Summary

Represents field By.

Namespace: BI.Tools
Syntax
Delphi
public
 By : TSplitBy;

Field Value

Type: TSplitBy

See Also

Reference

  • TSplitOptions
  • BI.Tools


TSplitOptions.Count Field

Summary

Represents field Count.

Namespace: BI.Tools
Syntax
Delphi
public
 Count : Integer;

Field Value

Type: Integer

See Also

Reference

  • TSplitOptions
  • BI.Tools


TSplitOptions.Mode Field

Summary

Represents field Mode.

Namespace: BI.Tools
Syntax
Delphi
public
 Mode : TSplitMode;

Field Value

Type: TSplitMode

See Also

Reference

  • TSplitOptions
  • BI.Tools


TSplitOptions.Percent Field

Summary

Represents field Percent.

Namespace: BI.Tools
Syntax
Delphi
public
 Percent : Single;

Field Value

Type: Single

See Also

Reference

  • TSplitOptions
  • BI.Tools


BI.Tools Enumerations

Enumerations
Name | Description
TSplitBy | Represents type TSplitBy.
TSplitMode | Represents type TSplitMode.
Top


TSplitBy Enumeration

Summary

Represents type TSplitBy.

Namespace: BI.Tools
Syntax
Delphi
type
 TSplitBy=(Percent,Count);

The TSplitBy type exposes the following members.

Members
Show:
Name | Description
Count | Represents constant Count.
Percent | Represents constant Percent.
Top
See Also

Reference

  • BI.Tools


TSplitMode Enumeration

Summary

Represents type TSplitMode.

Namespace: BI.Tools
Syntax
Delphi
type
 TSplitMode=(Random,Start);

The TSplitMode type exposes the following members.

Members
Show:
Name | Description
Random | Represents constant Random.
Start | Represents constant Start.
Top
See Also

Reference

  • BI.Tools


BI.Tree Namespace

Summary

Represents namespace BI.Tree.

Classes
Name | Description
TNode<T> | Represents type TNode<T>.
Top
Types
Name | Description
TInteger | Represents an alias of the NativeInt type.
Top


BI.Tree Classes

Classes
Name | Description
TNode<T> | Represents type TNode<T>.
Top


TNode<T> Class

Summary

Represents type TNode<T>.

Namespace: BI.Tree
Inheritance Hierarchy
TObject
BI.Tree.TNode<T>
Syntax
Delphi
type
 TNode<T

Type Parameters

T
See Also

Reference

  • BI.Tree


BI.Tree Types

Types
Name | Description
TInteger | Represents an alias of the NativeInt type.
Top


TInteger Type

Summary

Represents an alias of the NativeInt type.

Namespace: BI.Tree
Syntax
Delphi
type
 TInteger=NativeInt;
See Also

Reference

  • BI.Tree


BI.UI Namespace

Summary

Represents namespace BI.UI.

Classes
Name | Description
TAlternateColor | Represents type TAlternateColor.
TCrypto | Represents type TCrypto.
TDataColorizersHelper | Represents type TDataColorizersHelper.
TDataMapAsData | Represents type TDataMapAsData.
Top
Records
Name | Description
TCommonUI | Represents type TCommonUI.
TDataColorizer | Represents type TDataColorizer.
Top
Enumerations
Name | Description
TColorizeMode | Represents type TColorizeMode.
TColorizeTextColor | Represents type TColorizeTextColor.
TDataMapAsData.TDataMapOrder | Represents type TDataMapOrder.
Top
Delegates
Name | Description
TShowMessageProc | Represents type TShowMessageProc.
Top
Types
Name | Description
TCryptoClass | Represents type TCryptoClass.
TDataColorizers | Represents an array of the TDataColorizer type.
Top
Routines
Name | Description
Max(Integer,Integer) | Overloaded. Represents method Max(Integer,Integer).
Top


BI.UI Classes

Classes
Name | Description
TAlternateColor | Represents type TAlternateColor.
TCrypto | Represents type TCrypto.
TDataColorizersHelper | Represents type TDataColorizersHelper.
TDataMapAsData | Represents type TDataMapAsData.
Top


TAlternateColor Class

Summary

Represents type TAlternateColor.

Namespace: BI.UI
Inheritance Hierarchy
TPersistent
BI.UI.TAlternateColor
Syntax
Delphi
type
 TAlternateColor=class(TPersistent)
 end;

The TAlternateColor type exposes the following members.

Constants
Show:
Name | Description
DefaultColor | Represents constant DefaultColor.
Top
Constructors
Show:
Name | Description
Create | Initializes a new instance of the TAlternateColor class.
Top
Properties
Show:
Name | Description
Color | Represents property Color.
Enabled | Represents property Enabled.
OnChange | Represents property OnChange.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
Fields
Show:
Name | Description
FOnChange | Represents field FOnChange.
Top
See Also

Reference

  • BI.UI


TAlternateColor Constants

Constants
Name | Description
DefaultColor | Represents constant DefaultColor.
Top


TAlternateColor.DefaultColor Constant

Summary

Represents constant DefaultColor.

Namespace: BI.UI
Syntax
Delphi
public
 DefaultColor=$F2F2F2;

Value

Type: Integer

See Also

Reference

  • TAlternateColor
  • BI.UI


TAlternateColor Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TAlternateColor class.
Top


TAlternateColor.Create Constructor

Summary

Initializes a new instance of the TAlternateColor class.

Namespace: BI.UI
Syntax
Delphi
public
 Constructor Create;
See Also

Reference

  • TAlternateColor
  • BI.UI


TAlternateColor Properties

Properties
Name | Description
Color | Represents property Color.
Enabled | Represents property Enabled.
OnChange | Represents property OnChange.
Top


TAlternateColor.Color Property

Summary

Represents property Color.

Namespace: BI.UI
Syntax
Delphi
published
 property Color:TColor read FColor write SetColor default DefaultColor;

Property Value

Type: TColor

See Also

Reference

  • TAlternateColor
  • BI.UI


TAlternateColor.Enabled Property

Summary

Represents property Enabled.

Namespace: BI.UI
Syntax
Delphi
published
 property Enabled:Boolean read FEnabled write SetEnabled default False;

Property Value

Type: Boolean

See Also

Reference

  • TAlternateColor
  • BI.UI


TAlternateColor.OnChange Property

Summary

Represents property OnChange.

Namespace: BI.UI
Syntax
Delphi
published
 property OnChange:TNotifyEvent read FOnChange write FOnChange;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TAlternateColor
  • BI.UI


TAlternateColor Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TAlternateColor.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: BI.UI
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TAlternateColor
  • BI.UI


TAlternateColor Fields

Fields
Name | Description
FOnChange | Represents field FOnChange.
Top


TAlternateColor.FOnChange Field

Summary

Represents field FOnChange.

Namespace: BI.UI
Syntax
Delphi
protected
 FOnChange : TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TAlternateColor
  • BI.UI


TCrypto Class

Summary

Represents type TCrypto.

Namespace: BI.UI
Inheritance Hierarchy
TObject
BI.UI.TCrypto
BI.Crypt.LockBox.TBILockBox
Syntax
Delphi
type
 TCrypto=class
 end;

The TCrypto type exposes the following members.

Methods
Show:
Name | Description
Decrypt(String) | Overloaded. Represents method Decrypt(String).
Decrypt(TStream) | Overloaded. Represents method Decrypt(TStream).
Encrypt(String) | Overloaded. Represents method Encrypt(String).
Encrypt(TStream) | Overloaded. Represents method Encrypt(TStream).
Top
Fields
Show:
Name | Description
Engine | Represents field Engine.
Top
See Also

Reference

  • BI.UI


TCrypto Methods

Methods
Name | Description
Decrypt(String) | Overloaded. Represents method Decrypt(String).
Decrypt(TStream) | Overloaded. Represents method Decrypt(TStream).
Encrypt(String) | Overloaded. Represents method Encrypt(String).
Encrypt(TStream) | Overloaded. Represents method Encrypt(TStream).
Top


TCrypto.Decrypt(String) Method

Summary

Represents method Decrypt(String).

Namespace: BI.UI
Syntax
Delphi
public
 class function Decrypt(const Text:String):String; overload; virtual;

Parameters

Text
Type: String

Return Value

Type: String

See Also

Reference

  • TCrypto
  • BI.UI


TCrypto.Decrypt(TStream) Method

Summary

Represents method Decrypt(TStream).

Namespace: BI.UI
Syntax
Delphi
public
 class function Decrypt(const Stream:TStream):TStream; overload; virtual;

Parameters

Stream
Type: TStream

Return Value

Type: TStream

See Also

Reference

  • TCrypto
  • BI.UI


TCrypto.Encrypt(String) Method

Summary

Represents method Encrypt(String).

Namespace: BI.UI
Syntax
Delphi
public
 class function Encrypt(const Text:String):String; overload; virtual;

Parameters

Text
Type: String

Return Value

Type: String

See Also

Reference

  • TCrypto
  • BI.UI


TCrypto.Encrypt(TStream) Method

Summary

Represents method Encrypt(TStream).

Namespace: BI.UI
Syntax
Delphi
public
 class function Encrypt(const Stream:TStream):TStream; overload; virtual;

Parameters

Stream
Type: TStream

Return Value

Type: TStream

See Also

Reference

  • TCrypto
  • BI.UI


TCrypto Fields

Fields
Name | Description
Engine | Represents field Engine.
Top


TCrypto.Engine Field

Summary

Represents field Engine.

Namespace: BI.UI
Syntax
Delphi
public
 class var Engine : TCryptoClass;

Field Value

Type: TCryptoClass

See Also

Reference

  • TCrypto
  • BI.UI


TDataColorizersHelper Class Helper

Summary

Represents type TDataColorizersHelper.

Namespace: BI.UI
Syntax
Delphi
type
 TDataColorizersHelper=record helper for TDataColorizers
 end;
Methods
Name | Description
Add(TDataItem) | Represents method Add(TDataItem).
Clear | Represents method Clear.
TryColorize(TDataItem,Integer,Double,Integer) | Represents method TryColorize(TDataItem,Integer,Double,Integer).
Top
See Also

Reference

  • BI.UI


TDataColorizersHelper Methods

Methods
Name | Description
Add(TDataItem) | Represents method Add(TDataItem).
Clear | Represents method Clear.
TryColorize(TDataItem,Integer,Double,Integer) | Represents method TryColorize(TDataItem,Integer,Double,Integer).
Top


TDataColorizersHelper.Add(TDataItem) Method

Summary

Represents method Add(TDataItem).

Namespace: BI.UI
Syntax
Delphi
public
 procedure Add(const AItem:TDataItem);

Parameters

AItem
Type: TDataItem

See Also

Reference

  • TDataColorizersHelper
  • BI.UI


TDataColorizersHelper.Clear Method

Summary

Represents method Clear.

Namespace: BI.UI
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TDataColorizersHelper
  • BI.UI


TDataColorizersHelper.TryColorize(TDataItem,Integer,Double,Integer) Method

Summary

Represents method TryColorize(TDataItem,Integer,Double,Integer).

Namespace: BI.UI
Syntax
Delphi
public
 function TryColorize(const AItem:TDataItem; const AIndex:Integer;
 out APercent:Double; out AColorIndex:Integer):Boolean;

Parameters

AItem
Type: TDataItem

AIndex
Type: Integer

APercent
Type: Double

AColorIndex
Type: Integer

Return Value

Type: Boolean

See Also

Reference

  • TDataColorizersHelper
  • BI.UI


TDataMapAsData Class

Summary

Represents type TDataMapAsData.

Namespace: BI.UI
Inheritance Hierarchy
TObject
BI.UI.TDataMapAsData
Syntax
Delphi
type
 TDataMapAsData=class
 end;

The TDataMapAsData type exposes the following members.

Methods
Show:
Name | Description
CopyFrom(TDataItem,TDataItem) | Represents method CopyFrom(TDataItem,TDataItem).
FromData(TDataItem,Boolean,TDataMapOrder,Boolean) | Represents method FromData(TDataItem,Boolean,TDataMapOrder,Boolean).
Top
See Also

Reference

  • BI.UI


TDataMapAsData Methods

Methods
Name | Description
CopyFrom(TDataItem,TDataItem) | Represents method CopyFrom(TDataItem,TDataItem).
FromData(TDataItem,Boolean,TDataMapOrder,Boolean) | Represents method FromData(TDataItem,Boolean,TDataMapOrder,Boolean).
Top


TDataMapAsData.CopyFrom(TDataItem,TDataItem) Method

Summary

Represents method CopyFrom(TDataItem,TDataItem).

Namespace: BI.UI
Syntax
Delphi
public
 class procedure CopyFrom(const ASource,ADest:TDataItem); static;

Parameters

ASource
Type: TDataItem

ADest
Type: TDataItem

See Also

Reference

  • TDataMapAsData
  • BI.UI


TDataMapAsData.FromData(TDataItem,Boolean,TDataMapOrder,Boolean) Method

Summary

Represents method FromData(TDataItem,Boolean,TDataMapOrder,Boolean).

Namespace: BI.UI
Syntax
Delphi
public
 class function FromData(const AData:TDataItem;
 const AddCounts:Boolean=True;
 const Order:TDataMapOrder=TDataMapOrder.Count;
 const Ascending:Boolean=False):TDataItem; static;

Parameters

AData
Type: TDataItem

AddCounts
Type: Boolean

Order
Type: TDataMapOrder

Ascending
Type: Boolean

Return Value

Type: TDataItem

See Also

Reference

  • TDataMapAsData
  • BI.UI


BI.UI Records

Records
Name | Description
TCommonUI | Represents type TCommonUI.
TDataColorizer | Represents type TDataColorizer.
Top


TCommonUI Record

Summary

Represents type TCommonUI.

Namespace: BI.UI
Syntax
Delphi
type
 TCommonUI=record
 end;

The TCommonUI type exposes the following members.

Constants
Show:
Name | Description
CRLF | Represents constant CRLF.
Top
Methods
Show:
Name | Description
AddInfo(TDataItem,TStrings) | Represents method AddInfo(TDataItem,TStrings).
AddItems(TDataItem,TStrings) | Represents method AddItems(TDataItem,TStrings).
AddKinds(TStrings) | Represents method AddKinds(TStrings).
BytesToString(Int64) | Represents method BytesToString(Int64).
IsURL(String) | Represents method IsURL(String).
MSecToString(Int64) | Represents method MSecToString(Int64).
ToBooleanString(Boolean) | Represents method ToBooleanString(Boolean).
UniqueName(TComponent) | Represents method UniqueName(TComponent).
Top
Fields
Show:
Name | Description
ShowMessage | Represents field ShowMessage.
Top
See Also

Reference

  • BI.UI


TCommonUI Constants

Constants
Name | Description
CRLF | Represents constant CRLF.
Top


TCommonUI.CRLF Constant

Summary

Represents constant CRLF.

Namespace: BI.UI
Syntax
Delphi
public
 CRLF=sLineBreak;

Value

Type: Void

See Also

Reference

  • TCommonUI
  • BI.UI


TCommonUI Methods

Methods
Name | Description
AddInfo(TDataItem,TStrings) | Represents method AddInfo(TDataItem,TStrings).
AddItems(TDataItem,TStrings) | Represents method AddItems(TDataItem,TStrings).
AddKinds(TStrings) | Represents method AddKinds(TStrings).
BytesToString(Int64) | Represents method BytesToString(Int64).
IsURL(String) | Represents method IsURL(String).
MSecToString(Int64) | Represents method MSecToString(Int64).
ToBooleanString(Boolean) | Represents method ToBooleanString(Boolean).
UniqueName(TComponent) | Represents method UniqueName(TComponent).
Top


TCommonUI.AddInfo(TDataItem,TStrings) Method

Summary

Represents method AddInfo(TDataItem,TStrings).

Namespace: BI.UI
Syntax
Delphi
public
 class procedure AddInfo(const AData:TDataItem; const AItems:TStrings); static;

Parameters

AData
Type: TDataItem

AItems
Type: TStrings

See Also

Reference

  • TCommonUI
  • BI.UI


TCommonUI.AddItems(TDataItem,TStrings) Method

Summary

Represents method AddItems(TDataItem,TStrings).

Namespace: BI.UI
Syntax
Delphi
public
 class procedure AddItems(const AData:TDataItem; const AItems:TStrings); static;

Parameters

AData
Type: TDataItem

AItems
Type: TStrings

See Also

Reference

  • TCommonUI
  • BI.UI


TCommonUI.AddKinds(TStrings) Method

Summary

Represents method AddKinds(TStrings).

Namespace: BI.UI
Syntax
Delphi
public
 class procedure AddKinds(const AItems:TStrings); static;

Parameters

AItems
Type: TStrings

See Also

Reference

  • TCommonUI
  • BI.UI


TCommonUI.BytesToString(Int64) Method

Summary

Represents method BytesToString(Int64).

Namespace: BI.UI
Syntax
Delphi
public
 class function BytesToString(const Bytes: Int64): String; static;

Parameters

Bytes
Type: Int64

Return Value

Type: String

See Also

Reference

  • TCommonUI
  • BI.UI


TCommonUI.IsURL(String) Method

Summary

Represents method IsURL(String).

Namespace: BI.UI
Syntax
Delphi
public
 class function IsURL(const AFileName:String):Boolean; static;

Parameters

AFileName
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TCommonUI
  • BI.UI


TCommonUI.MSecToString(Int64) Method

Summary

Represents method MSecToString(Int64).

Namespace: BI.UI
Syntax
Delphi
public
 class function MSecToString(const MSec:Int64):String; static;

Parameters

MSec
Type: Int64

Return Value

Type: String

See Also

Reference

  • TCommonUI
  • BI.UI


TCommonUI.ToBooleanString(Boolean) Method

Summary

Represents method ToBooleanString(Boolean).

Namespace: BI.UI
Syntax
Delphi
public
 class function ToBooleanString(const Bool:Boolean):String; static;

Parameters

Bool
Type: Boolean

Return Value

Type: String

See Also

Reference

  • TCommonUI
  • BI.UI


TCommonUI.UniqueName(TComponent) Method

Summary

Represents method UniqueName(TComponent).

Namespace: BI.UI
Syntax
Delphi
public
 class function UniqueName(const AComponent:TComponent):String; static;

Parameters

AComponent
Type: TComponent

Return Value

Type: String

See Also

Reference

  • TCommonUI
  • BI.UI


TCommonUI Fields

Fields
Name | Description
ShowMessage | Represents field ShowMessage.
Top


TCommonUI.ShowMessage Field

Summary

Represents field ShowMessage.

Namespace: BI.UI
Syntax
Delphi
public
 class var
 ShowMessage:TShowMessageProc;

Field Value

Type: TShowMessageProc

See Also

Reference

  • TCommonUI
  • BI.UI


TDataColorizer Record

Summary

Represents type TDataColorizer.

Namespace: BI.UI
Syntax
Delphi
type
 TDataColorizer=record
 end;

The TDataColorizer type exposes the following members.

Methods
Show:
Name | Description
AlphaColorOf(Double) | Represents method AlphaColorOf(Double).
ColorOf(Double) | Represents method ColorOf(Double).
Normalized(Double) | Represents method Normalized(Double).
ValidRange | Represents method ValidRange.
Top
Fields
Show:
Name | Description
Colors | Represents field Colors.
Data | Represents field Data.
Mode | Represents field Mode.
TextColor | Represents field TextColor.
Top
See Also

Reference

  • BI.UI


TDataColorizer Methods

Methods
Name | Description
AlphaColorOf(Double) | Represents method AlphaColorOf(Double).
ColorOf(Double) | Represents method ColorOf(Double).
Normalized(Double) | Represents method Normalized(Double).
ValidRange | Represents method ValidRange.
Top


TDataColorizer.AlphaColorOf(Double) Method

Summary

Represents method AlphaColorOf(Double).

Namespace: BI.UI
Syntax
Delphi
public
 function AlphaColorOf(const Value: Double): TAlphaColor;

Parameters

Value
Type: Double

Return Value

Type: TAlphaColor

See Also

Reference

  • TDataColorizer
  • BI.UI


TDataColorizer.ColorOf(Double) Method

Summary

Represents method ColorOf(Double).

Namespace: BI.UI
Syntax
Delphi
public
 function ColorOf(const Value:Double):TColor;

Parameters

Value
Type: Double

Return Value

Type: TColor

See Also

Reference

  • TDataColorizer
  • BI.UI


TDataColorizer.Normalized(Double) Method

Summary

Represents method Normalized(Double).

Namespace: BI.UI
Syntax
Delphi
public
 function Normalized(const Value:Double):Double;

Parameters

Value
Type: Double

Return Value

Type: Double

See Also

Reference

  • TDataColorizer
  • BI.UI


TDataColorizer.ValidRange Method

Summary

Represents method ValidRange.

Namespace: BI.UI
Syntax
Delphi
public
 function ValidRange:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TDataColorizer
  • BI.UI


TDataColorizer Fields

Fields
Name | Description
Colors | Represents field Colors.
Data | Represents field Data.
Mode | Represents field Mode.
TextColor | Represents field TextColor.
Top


TDataColorizer.Colors Field

Summary

Represents field Colors.

Namespace: BI.UI
Syntax
Delphi
public
 Colors : TColorFunction;

Field Value

Type: TColorFunction

See Also

Reference

  • TDataColorizer
  • BI.UI


TDataColorizer.Data Field

Summary

Represents field Data.

Namespace: BI.UI
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TDataColorizer
  • BI.UI


TDataColorizer.Mode Field

Summary

Represents field Mode.

Namespace: BI.UI
Syntax
Delphi
public
 Mode : TColorizeMode;

Field Value

Type: TColorizeMode

See Also

Reference

  • TDataColorizer
  • BI.UI


TDataColorizer.TextColor Field

Summary

Represents field TextColor.

Namespace: BI.UI
Syntax
Delphi
public
 TextColor : TColorizeTextColor;

Field Value

Type: TColorizeTextColor

See Also

Reference

  • TDataColorizer
  • BI.UI


BI.UI Enumerations

Enumerations
Name | Description
TColorizeMode | Represents type TColorizeMode.
TColorizeTextColor | Represents type TColorizeTextColor.
TDataMapAsData.TDataMapOrder | Represents type TDataMapOrder.
Top


TColorizeMode Enumeration

Summary

Represents type TColorizeMode.

Namespace: BI.UI
Syntax
Delphi
type
 TColorizeMode=(Full,Left);

The TColorizeMode type exposes the following members.

Members
Show:
Name | Description
Full | Represents constant Full.
Left | Represents constant Left.
Top
See Also

Reference

  • BI.UI


TColorizeTextColor Enumeration

Summary

Represents type TColorizeTextColor.

Namespace: BI.UI
Syntax
Delphi
type
 TColorizeTextColor=(Automatic,Fixed);

The TColorizeTextColor type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Fixed | Represents constant Fixed.
Top
See Also

Reference

  • BI.UI


TDataMapAsData.TDataMapOrder Enumeration

Summary

Represents type TDataMapOrder.

Namespace: BI.UI
Syntax
Delphi
public
type
 TDataMapOrder=(None,Item,Count);

The TDataMapAsData.TDataMapOrder type exposes the following members.

Members
Show:
Name | Description
Count | Represents constant Count.
Item | Represents constant Item.
None | Represents constant None.
Top
See Also

Reference

  • TDataMapAsData
  • BI.UI


BI.UI Delegates

Delegates
Name | Description
TShowMessageProc | Represents type TShowMessageProc.
Top


TShowMessageProc Delegate

Summary

Represents type TShowMessageProc.

Namespace: BI.UI
Syntax
Delphi
type
 TShowMessageProc=procedure(const AText:String);
See Also

Reference

  • BI.UI


BI.UI Types

Types
Name | Description
TCryptoClass | Represents type TCryptoClass.
TDataColorizers | Represents an array of the TDataColorizer type.
Top


TCryptoClass Type

Summary

Represents type TCryptoClass.

Namespace: BI.UI
Syntax
Delphi
type
 TCryptoClass=class of TCrypto;
See Also

Reference

  • BI.UI


TDataColorizers Type

Summary

Represents an array of the TDataColorizer type.

Namespace: BI.UI
Syntax
Delphi
type
 TDataColorizers=Array of TDataColorizer;
See Also

Reference

  • BI.UI


BI.UI Routines

Routines
Name | Description
Max(Integer,Integer) | Overloaded. Represents method Max(Integer,Integer).
Top


Max(Integer,Integer) Method

Summary

Represents method Max(Integer,Integer).

Namespace: BI.UI
Syntax
Delphi
function Max(const A,B:Integer):Integer; overload;

Parameters

A
Type: Integer

B
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • BI.UI


BI.UI.Colors Namespace

Summary

Represents namespace BI.UI.Colors.

Records
Name | Description
TColorFunction | Represents type TColorFunction.
TColorItem | Represents type TColorItem.
Top
Types
Name | Description
TColorItems | Represents an array of the TColorItem type.
Top


BI.UI.Colors Records

Records
Name | Description
TColorFunction | Represents type TColorFunction.
TColorItem | Represents type TColorItem.
Top


TColorFunction Record

Summary

Represents type TColorFunction.

Namespace: BI.UI.Colors
Syntax
Delphi
type
 TColorFunction=record
 end;

The TColorFunction type exposes the following members.

Methods
Show:
Name | Description
Add(Single,TAlphaColor) | Represents method Add(Single,TAlphaColor).
Clear | Represents method Clear.
FromValue(Single) | Represents method FromValue(Single).
ToRGB(TAlphaColor) | Represents method ToRGB(TAlphaColor).
Top
Fields
Show:
Name | Description
Inverted | Represents field Inverted.
Palette | Represents field Palette.
Top
See Also

Reference

  • BI.UI.Colors


TColorFunction Methods

Methods
Name | Description
Add(Single,TAlphaColor) | Represents method Add(Single,TAlphaColor).
Clear | Represents method Clear.
FromValue(Single) | Represents method FromValue(Single).
ToRGB(TAlphaColor) | Represents method ToRGB(TAlphaColor).
Top


TColorFunction.Add(Single,TAlphaColor) Method

Summary

Represents method Add(Single,TAlphaColor).

Namespace: BI.UI.Colors
Syntax
Delphi
public
 procedure Add(const AValue:Single; const AColor:TAlphaColor);

Parameters

AValue
Type: Single

AColor
Type: TAlphaColor

See Also

Reference

  • TColorFunction
  • BI.UI.Colors


TColorFunction.Clear Method

Summary

Represents method Clear.

Namespace: BI.UI.Colors
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TColorFunction
  • BI.UI.Colors


TColorFunction.FromValue(Single) Method

Summary

Represents method FromValue(Single).

Namespace: BI.UI.Colors
Syntax
Delphi
public
 function FromValue(const AValue:Single):TAlphaColor;

Parameters

AValue
Type: Single

Return Value

Type: TAlphaColor

See Also

Reference

  • TColorFunction
  • BI.UI.Colors


TColorFunction.ToRGB(TAlphaColor) Method

Summary

Represents method ToRGB(TAlphaColor).

Namespace: BI.UI.Colors
Syntax
Delphi
public
 class function ToRGB(const AColor:TAlphaColor):Integer; static;

Parameters

AColor
Type: TAlphaColor

Return Value

Type: Integer

See Also

Reference

  • TColorFunction
  • BI.UI.Colors


TColorFunction Fields

Fields
Name | Description
Inverted | Represents field Inverted.
Palette | Represents field Palette.
Top


TColorFunction.Inverted Field

Summary

Represents field Inverted.

Namespace: BI.UI.Colors
Syntax
Delphi
public
 Inverted : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TColorFunction
  • BI.UI.Colors


TColorFunction.Palette Field

Summary

Represents field Palette.

Namespace: BI.UI.Colors
Syntax
Delphi
public
 Palette : TColorItems;

Field Value

Type: TColorItems

See Also

Reference

  • TColorFunction
  • BI.UI.Colors


TColorItem Record

Summary

Represents type TColorItem.

Namespace: BI.UI.Colors
Syntax
Delphi
type
 TColorItem=record
 end;

The TColorItem type exposes the following members.

Fields
Show:
Name | Description
Color | Represents field Color.
Value | Represents field Value.
Top
See Also

Reference

  • BI.UI.Colors


TColorItem Fields

Fields
Name | Description
Color | Represents field Color.
Value | Represents field Value.
Top


TColorItem.Color Field

Summary

Represents field Color.

Namespace: BI.UI.Colors
Syntax
Delphi
public
 Color : TAlphaColor;

Field Value

Type: TAlphaColor

See Also

Reference

  • TColorItem
  • BI.UI.Colors


TColorItem.Value Field

Summary

Represents field Value.

Namespace: BI.UI.Colors
Syntax
Delphi
public
 Value : Single;

Field Value

Type: Single

See Also

Reference

  • TColorItem
  • BI.UI.Colors


BI.UI.Colors Types

Types
Name | Description
TColorItems | Represents an array of the TColorItem type.
Top


TColorItems Type

Summary

Represents an array of the TColorItem type.

Namespace: BI.UI.Colors
Syntax
Delphi
type
 TColorItems=Array of TColorItem;
See Also

Reference

  • BI.UI.Colors


BI.Verify Namespace

Summary

Represents namespace BI.Verify.

Classes
Name | Description
TDataAccess | Represents type TDataAccess.
TVerificator | Represents type TVerificator.
Top


BI.Verify Classes

Classes
Name | Description
TDataAccess | Represents type TDataAccess.
TVerificator | Represents type TVerificator.
Top


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.Verify
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Verify.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.Verify


TVerificator Class

Summary

Represents type TVerificator.

Namespace: BI.Verify
Inheritance Hierarchy
TObject
BI.Verify.TVerificator
Syntax
Delphi
type
 TVerificator=class
 end;

The TVerificator type exposes the following members.

Constructors
Show:
Name | Description
Create(TStrings) | Initializes a new instance of the TVerificator class.
Top
Methods
Show:
Name | Description
Verify(TDataItem) | Overloaded. Represents method Verify(TDataItem).
Top
Fields
Show:
Name | Description
Strings | Represents field Strings.
Top
See Also

Reference

  • BI.Verify


TVerificator Constructors

Constructors
Name | Description
Create(TStrings) | Initializes a new instance of the TVerificator class.
Top


TVerificator.Create(TStrings) Constructor

Summary

Initializes a new instance of the TVerificator class.

Namespace: BI.Verify
Syntax
Delphi
public
 Constructor Create(const AStrings:TStrings);

Parameters

AStrings
Type: TStrings

See Also

Reference

  • TVerificator
  • BI.Verify


TVerificator Methods

Methods
Name | Description
Verify(TDataItem) | Overloaded. Represents method Verify(TDataItem).
Top


TVerificator.Verify(TDataItem) Method

Summary

Represents method Verify(TDataItem).

Namespace: BI.Verify
Syntax
Delphi
public
 procedure Verify(const AData:TDataItem); overload;

Parameters

AData
Type: TDataItem

See Also

Reference

  • TVerificator
  • BI.Verify


TVerificator Fields

Fields
Name | Description
Strings | Represents field Strings.
Top


TVerificator.Strings Field

Summary

Represents field Strings.

Namespace: BI.Verify
Syntax
Delphi
public
 Strings: TStrings;

Field Value

Type: TStrings

See Also

Reference

  • TVerificator
  • BI.Verify


BI.Web Namespace

Summary

Represents namespace BI.Web.

Classes
Name | Description
EHttpAbort | Represents type EHttpAbort.
TBIFtp | Represents type TBIFtp.
TBIHttp | Represents type TBIHttp.
TBIURLSource | Represents type TBIURLSource.
TBIWebClient | Represents type TBIWebClient.
TBIWebHistory | Represents type TBIWebHistory.
TBIWebImporter | Represents type TBIWebImporter.
TBIWebServer | Represents type TBIWebServer.
TDataItemAccess | Represents type TDataItemAccess.
TDelayHandlerWeb | Represents type TDelayHandlerWeb.
TSteema | Represents type TSteema.
Top
Records
Name | Description
TBIWebServer.TVersion | Represents type TVersion.
TWebProxy | Represents type TWebProxy.
TWebURL | Represents type TWebURL.
Top
Enumerations
Name | Description
TWebCompression | Represents type TWebCompression.
Top
Delegates
Name | Description
TBIHttpProgress | Represents type TBIHttpProgress.
Top
Types
Name | Description
TBIHttpClass | Represents type TBIHttpClass.
Top
Constants
Name | Description
SteemaBIWeb | Represents constant SteemaBIWeb.
Top


BI.Web Classes

Classes
Name | Description
EHttpAbort | Represents type EHttpAbort.
TBIFtp | Represents type TBIFtp.
TBIHttp | Represents type TBIHttp.
TBIURLSource | Represents type TBIURLSource.
TBIWebClient | Represents type TBIWebClient.
TBIWebHistory | Represents type TBIWebHistory.
TBIWebImporter | Represents type TBIWebImporter.
TBIWebServer | Represents type TBIWebServer.
TDataItemAccess | Represents type TDataItemAccess.
TDelayHandlerWeb | Represents type TDelayHandlerWeb.
TSteema | Represents type TSteema.
Top


EHttpAbort Class

Summary

Represents type EHttpAbort.

Namespace: BI.Web
Inheritance Hierarchy
Exception
BI.Web.EHttpAbort
Syntax
Delphi
type
 EHttpAbort=class(Exception);
See Also

Reference

  • BI.Web


TBIFtp Class

Summary

Represents type TBIFtp.

Namespace: BI.Web
Inheritance Hierarchy
TObject
BI.Web.TBIFtp
BI.Web.Indy.TBIIndyFtp
Syntax
Delphi
type
 TBIFtp=class
 end;

The TBIFtp type exposes the following members.

Constants
Show:
Name | Description
DefaultPort | Represents constant DefaultPort.
Top
Constructors
Show:
Name | Description
Create(TDataDefinition) | Initializes a new instance of the TBIFtp class.
Top
Methods
Show:
Name | Description
Connect | Represents method Connect.
DisConnect | Represents method DisConnect.
Get(String) | Represents method Get(String).
IncludedFiles(String,String) | Represents method IncludedFiles(String,String).
ListFiles(String,String) | Represents method ListFiles(String,String).
Top
See Also

Reference

  • BI.Web


TBIFtp Constants

Constants
Name | Description
DefaultPort | Represents constant DefaultPort.
Top


TBIFtp.DefaultPort Constant

Summary

Represents constant DefaultPort.

Namespace: BI.Web
Syntax
Delphi
public
 DefaultPort=21;

Value

Type: ShortInt

See Also

Reference

  • TBIFtp
  • BI.Web


TBIFtp Constructors

Constructors
Name | Description
Create(TDataDefinition) | Initializes a new instance of the TBIFtp class.
Top


TBIFtp.Create(TDataDefinition) Constructor

Summary

Initializes a new instance of the TBIFtp class.

Namespace: BI.Web
Syntax
Delphi
public
 Constructor Create(const ADef:TDataDefinition); virtual; abstract;

Parameters

ADef
Type: TDataDefinition

See Also

Reference

  • TBIFtp
  • BI.Web


TBIFtp Methods

Methods
Name | Description
Connect | Represents method Connect.
DisConnect | Represents method DisConnect.
Get(String) | Represents method Get(String).
IncludedFiles(String,String) | Represents method IncludedFiles(String,String).
ListFiles(String,String) | Represents method ListFiles(String,String).
Top


TBIFtp.Connect Method

Summary

Represents method Connect.

Namespace: BI.Web
Syntax
Delphi
public
 procedure Connect; virtual; abstract;
See Also

Reference

  • TBIFtp
  • BI.Web


TBIFtp.DisConnect Method

Summary

Represents method DisConnect.

Namespace: BI.Web
Syntax
Delphi
public
 procedure DisConnect; virtual; abstract;
See Also

Reference

  • TBIFtp
  • BI.Web


TBIFtp.Get(String) Method

Summary

Represents method Get(String).

Namespace: BI.Web
Syntax
Delphi
public
 function Get(const AFileName:String):TStream; virtual; abstract;

Parameters

AFileName
Type: String

Return Value

Type: TStream

See Also

Reference

  • TBIFtp
  • BI.Web


TBIFtp.IncludedFiles(String,String) Method

Summary

Represents method IncludedFiles(String,String).

Namespace: BI.Web
Syntax
Delphi
public
 function IncludedFiles(const AFolder,AIncludeMask:String):TStringDynArray; virtual; abstract;

Parameters

AFolder
Type: String

AIncludeMask
Type: String

Return Value

Type: TStringDynArray

See Also

Reference

  • TBIFtp
  • BI.Web


TBIFtp.ListFiles(String,String) Method

Summary

Represents method ListFiles(String,String).

Namespace: BI.Web
Syntax
Delphi
public
 function ListFiles(const AFolder,AIncludeMask:String): TStrings; virtual; abstract;

Parameters

AFolder
Type: String

AIncludeMask
Type: String

Return Value

Type: TStrings

See Also

Reference

  • TBIFtp
  • BI.Web


TBIHttp Class

Summary

Represents type TBIHttp.

Namespace: BI.Web
Inheritance Hierarchy
TObject
BI.Web.TBIHttp
BI.Web.FPC.TBIFPCWeb
BI.Web.Indy.TBIIndy
BI.Web.Net.TBIHttpClient
Syntax
Delphi
type
 TBIHttp=class abstract
 end;

The TBIHttp type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIHttp class.
Top
Methods
Show:
Name | Description
DoProgress(Int64,Int64) | Represents method DoProgress(Int64,Int64).
FTP(TDataDefinition) | Represents method FTP(TDataDefinition).
Get(String) | Overloaded. Represents method Get(String).
Get(String,TStream) | Overloaded. Represents method Get(String,TStream).
Parse(String) | Represents method Parse(String).
SetProxy(TWebProxy) | Represents method SetProxy(TWebProxy).
SetTimeout(Integer) | Represents method SetTimeout(Integer).
Top
Events
Show:
Name | Description
OnProgress | Represents property OnProgress.
Top
Fields
Show:
Name | Description
Engine | Represents field Engine.
Top
See Also

Reference

  • BI.Web


TBIHttp Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBIHttp class.
Top


TBIHttp.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIHttp class.

Namespace: BI.Web
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); virtual; abstract;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBIHttp
  • BI.Web


TBIHttp Methods

Methods
Name | Description
DoProgress(Int64,Int64) | Represents method DoProgress(Int64,Int64).
FTP(TDataDefinition) | Represents method FTP(TDataDefinition).
Get(String) | Overloaded. Represents method Get(String).
Get(String,TStream) | Overloaded. Represents method Get(String,TStream).
Parse(String) | Represents method Parse(String).
SetProxy(TWebProxy) | Represents method SetProxy(TWebProxy).
SetTimeout(Integer) | Represents method SetTimeout(Integer).
Top


TBIHttp.DoProgress(Int64,Int64) Method

Summary

Represents method DoProgress(Int64,Int64).

Namespace: BI.Web
Syntax
Delphi
protected
 procedure DoProgress(const ACurrent,ATotal:Int64);

Parameters

ACurrent
Type: Int64

ATotal
Type: Int64

See Also

Reference

  • TBIHttp
  • BI.Web


TBIHttp.FTP(TDataDefinition) Method

Summary

Represents method FTP(TDataDefinition).

Namespace: BI.Web
Syntax
Delphi
public
 class function FTP(const ADef:TDataDefinition):TBIFtp; virtual; abstract;

Parameters

ADef
Type: TDataDefinition

Return Value

Type: TBIFtp

See Also

Reference

  • TBIHttp
  • BI.Web


TBIHttp.Get(String) Method

Summary

Represents method Get(String).

Namespace: BI.Web
Syntax
Delphi
public
 function Get(const AURL:String):String; overload; virtual; abstract;

Parameters

AURL
Type: String

Return Value

Type: String

See Also

Reference

  • TBIHttp
  • BI.Web


TBIHttp.Get(String,TStream) Method

Summary

Represents method Get(String,TStream).

Namespace: BI.Web
Syntax
Delphi
public
 procedure Get(const AURL:String; const AStream:TStream); overload; virtual; abstract;

Parameters

AURL
Type: String

AStream
Type: TStream

See Also

Reference

  • TBIHttp
  • BI.Web


TBIHttp.Parse(String) Method

Summary

Represents method Parse(String).

Namespace: BI.Web
Syntax
Delphi
public
 class function Parse(const AURL:String):TWebURL; virtual; abstract;

Parameters

AURL
Type: String

Return Value

Type: TWebURL

See Also

Reference

  • TBIHttp
  • BI.Web


TBIHttp.SetProxy(TWebProxy) Method

Summary

Represents method SetProxy(TWebProxy).

Namespace: BI.Web
Syntax
Delphi
public
 procedure SetProxy(const AProxy:TWebProxy); virtual; abstract;

Parameters

AProxy
Type: TWebProxy

See Also

Reference

  • TBIHttp
  • BI.Web


TBIHttp.SetTimeout(Integer) Method

Summary

Represents method SetTimeout(Integer).

Namespace: BI.Web
Syntax
Delphi
public
 procedure SetTimeout(const ATimeout:Integer); virtual; abstract;

Parameters

ATimeout
Type: Integer

See Also

Reference

  • TBIHttp
  • BI.Web


TBIHttp Events

Events
Name | Description
OnProgress | Represents property OnProgress.
Top


TBIHttp.OnProgress Event

Summary

Represents property OnProgress.

Namespace: BI.Web
Syntax
Delphi
public
 class property OnProgress:TBIHttpProgress read FOnProgress write FOnProgress;

Value

Type: TBIHttpProgress

See Also

Reference

  • TBIHttp
  • BI.Web


TBIHttp Fields

Fields
Name | Description
Engine | Represents field Engine.
Top


TBIHttp.Engine Field

Summary

Represents field Engine.

Namespace: BI.Web
Syntax
Delphi
public
 class var
 Engine : TBIHttpClass;

Field Value

Type: TBIHttpClass

See Also

Reference

  • TBIHttp
  • BI.Web


TBIURLSource Class

Summary

Represents type TBIURLSource.

Namespace: BI.Web
Inheritance Hierarchy
TObject
BI.DataSource.TBISource
BI.DataSource.TBIItemsSource
BI.DataSource.TBIFileSource
BI.Web.TBIURLSource
Syntax
Delphi
type
 TBIURLSource=class(TBIFileSource)
 end;

The TBIURLSource type exposes the following members.

Methods
Show:
Name | Description
DoImportFile(String) | Represents method DoImportFile(String). (Overrides TBIFileSource.DoImportFile(String).)
FileFilter | Represents method FileFilter. (Overrides TBIFileSource.FileFilter.)
From(String) | Represents method From(String).
FromStrings(String,TStrings) | Represents method FromStrings(String,TStrings).
Import(String) | Represents method Import(String).
ImportURLFile(String) | Represents method ImportURLFile(String).
StreamFrom(String) | Represents method StreamFrom(String).
Supports(String) | Represents method Supports(String). (Overrides TBIFileSource.Supports(String).)
Top
See Also

Reference

  • BI.Web


TBIURLSource Methods

Methods
Name | Description
DoImportFile(String) | Represents method DoImportFile(String). (Overrides TBIFileSource.DoImportFile(String).)
FileFilter | Represents method FileFilter. (Overrides TBIFileSource.FileFilter.)
From(String) | Represents method From(String).
FromStrings(String,TStrings) | Represents method FromStrings(String,TStrings).
Import(String) | Represents method Import(String).
ImportURLFile(String) | Represents method ImportURLFile(String).
StreamFrom(String) | Represents method StreamFrom(String).
Supports(String) | Represents method Supports(String). (Overrides TBIFileSource.Supports(String).)
Top


TBIURLSource.DoImportFile(String) Method

Summary

Represents method DoImportFile(String).

Namespace: BI.Web
Syntax
Delphi
protected
 function DoImportFile(const FileName:String):TDataArray; override;

Parameters

FileName
Type: String

Return Value

Type: TDataArray

Overrides

TBIFileSource.DoImportFile(String)
See Also

Reference

  • TBIURLSource
  • BI.Web


TBIURLSource.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.Web
Syntax
Delphi
public
 class function FileFilter:TFileFilters; override;

Return Value

Type: TFileFilters

Overrides

TBIFileSource.FileFilter
See Also

Reference

  • TBIURLSource
  • BI.Web


TBIURLSource.From(String) Method

Summary

Represents method From(String).

Namespace: BI.Web
Syntax
Delphi
public
 class function From(const AURL:String):TDataItem; static;

Parameters

AURL
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TBIURLSource
  • BI.Web


TBIURLSource.FromStrings(String,TStrings) Method

Summary

Represents method FromStrings(String,TStrings).

Namespace: BI.Web
Syntax
Delphi
public
 function FromStrings(const URL:String; const S:TStrings):TDataArray;

Parameters

URL
Type: String

S
Type: TStrings

Return Value

Type: TDataArray

See Also

Reference

  • TBIURLSource
  • BI.Web


TBIURLSource.Import(String) Method

Summary

Represents method Import(String).

Namespace: BI.Web
Syntax
Delphi
public
 function Import(const URL:String):TDataArray;

Parameters

URL
Type: String

Return Value

Type: TDataArray

See Also

Reference

  • TBIURLSource
  • BI.Web


TBIURLSource.ImportURLFile(String) Method

Summary

Represents method ImportURLFile(String).

Namespace: BI.Web
Syntax
Delphi
protected
 function ImportURLFile(const FileName:String):TDataArray;

Parameters

FileName
Type: String

Return Value

Type: TDataArray

See Also

Reference

  • TBIURLSource
  • BI.Web


TBIURLSource.StreamFrom(String) Method

Summary

Represents method StreamFrom(String).

Namespace: BI.Web
Syntax
Delphi
public
 class function StreamFrom(const URL: String): TStream; static;

Parameters

URL
Type: String

Return Value

Type: TStream

See Also

Reference

  • TBIURLSource
  • BI.Web


TBIURLSource.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.Web
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIFileSource.Supports(String)
See Also

Reference

  • TBIURLSource
  • BI.Web


TBIWebClient Class

Summary

Represents type TBIWebClient.

Namespace: BI.Web
Inheritance Hierarchy
TObject
BI.Web.TBIWebClient
BI.Web.TSteema
Syntax
Delphi
type
 TBIWebClient=class
 end;

The TBIWebClient type exposes the following members.

Constants
Show:
Name | Description
DefaultPort | Represents constant DefaultPort.
DefaultTimeout | Represents constant DefaultTimeout.
Top
Constructors
Show:
Name | Description
Create(String,Integer) | Overloaded. Initializes a new instance of the TBIWebClient class.
Create(TDataDefinition) | Overloaded. Initializes a new instance of the TBIWebClient class.
Destroy | Represents the destructor of the TBIWebClient class.
Top
Properties
Show:
Name | Description
Http | Represents property Http.
OnFinish | Represents property OnFinish.
OnStart | Represents property OnStart.
Top
Methods
Show:
Name | Description
DoFromURL(String) | Represents method DoFromURL(String).
FromPath(String) | Represents method FromPath(String).
FromURL(String,Integer,String,TWebCompression) | Overloaded. Represents method FromURL(String,Integer,String,TWebCompression).
FromURL(String,TWebCompression) | Overloaded. Represents method FromURL(String,TWebCompression).
FTP(TDataDefinition) | Represents method FTP(TDataDefinition).
GetData | Overloaded. Represents method GetData.
GetData(String,Boolean,TWebCompression) | Overloaded. Represents method GetData(String,Boolean,TWebCompression).
GetData(String,TDataArray,TWebCompression) | Overloaded. Represents method GetData(String,TDataArray,TWebCompression).
GetData(String,TDataItem,Boolean,TWebCompression) | Overloaded. Represents method GetData(String,TDataItem,Boolean,TWebCompression).
GetData(TDataItem,Boolean,TWebCompression) | Overloaded. Represents method GetData(TDataItem,Boolean,TWebCompression).
GetDataStream(String,Boolean,TWebCompression) | Represents method GetDataStream(String,Boolean,TWebCompression).
GetMetaData(String,TWebCompression) | Represents method GetMetaData(String,TWebCompression).
GetStream(String) | Represents method GetStream(String).
GetString(String) | Represents method GetString(String).
Load(String,TWebCompression) | Represents method Load(String,TWebCompression).
Query(String,String,String) | Represents method Query(String,String,String).
UnZip(TStream) | Represents method UnZip(TStream).
URL | Represents method URL.
Top
Fields
Show:
Name | Description
Compress | Represents field Compress.
Port | Represents field Port.
Proxy | Represents field Proxy.
Server | Represents field Server.
Store | Represents field Store.
Timeout | Represents field Timeout.
Top
See Also

Reference

  • BI.Web


TBIWebClient Constants

Constants
Name | Description
DefaultPort | Represents constant DefaultPort.
DefaultTimeout | Represents constant DefaultTimeout.
Top


TBIWebClient.DefaultPort Constant

Summary

Represents constant DefaultPort.

Namespace: BI.Web
Syntax
Delphi
public
 DefaultPort=15015;

Value

Type: SmallInt

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.DefaultTimeout Constant

Summary

Represents constant DefaultTimeout.

Namespace: BI.Web
Syntax
Delphi
public
 DefaultTimeout=2000;

Value

Type: SmallInt

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient Constructors

Constructors
Name | Description
Create(String,Integer) | Overloaded. Initializes a new instance of the TBIWebClient class.
Create(TDataDefinition) | Overloaded. Initializes a new instance of the TBIWebClient class.
Destroy | Represents the destructor of the TBIWebClient class.
Top


TBIWebClient.Create(String,Integer) Constructor

Summary

Initializes a new instance of the TBIWebClient class.

Namespace: BI.Web
Syntax
Delphi
public
 Constructor Create(const AServer:String; const APort:Integer=DefaultPort); overload;

Parameters

AServer
Type: String

APort
Type: Integer

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.Create(TDataDefinition) Constructor

Summary

Initializes a new instance of the TBIWebClient class.

Namespace: BI.Web
Syntax
Delphi
public
 Constructor Create(const AData:TDataDefinition); overload;

Parameters

AData
Type: TDataDefinition

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.Destroy Destructor

Summary

Represents the destructor of the TBIWebClient class.

Namespace: BI.Web
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient Properties

Properties
Name | Description
Http | Represents property Http.
OnFinish | Represents property OnFinish.
OnStart | Represents property OnStart.
Top


TBIWebClient.Http Property

Summary

Represents property Http.

Namespace: BI.Web
Syntax
Delphi
public
 property Http:TBIHttp read GetHttp;

Property Value

Type: TBIHttp

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.OnFinish Property

Summary

Represents property OnFinish.

Namespace: BI.Web
Syntax
Delphi
public
 class property OnFinish:TNotifyEvent read FOnFinish write FOnFinish;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.OnStart Property

Summary

Represents property OnStart.

Namespace: BI.Web
Syntax
Delphi
public
 class property OnStart:TNotifyEvent read FOnStart write FOnStart;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient Methods

Methods
Name | Description
DoFromURL(String) | Represents method DoFromURL(String).
FromPath(String) | Represents method FromPath(String).
FromURL(String,Integer,String,TWebCompression) | Overloaded. Represents method FromURL(String,Integer,String,TWebCompression).
FromURL(String,TWebCompression) | Overloaded. Represents method FromURL(String,TWebCompression).
FTP(TDataDefinition) | Represents method FTP(TDataDefinition).
GetData | Overloaded. Represents method GetData.
GetData(String,Boolean,TWebCompression) | Overloaded. Represents method GetData(String,Boolean,TWebCompression).
GetData(String,TDataArray,TWebCompression) | Overloaded. Represents method GetData(String,TDataArray,TWebCompression).
GetData(String,TDataItem,Boolean,TWebCompression) | Overloaded. Represents method GetData(String,TDataItem,Boolean,TWebCompression).
GetData(TDataItem,Boolean,TWebCompression) | Overloaded. Represents method GetData(TDataItem,Boolean,TWebCompression).
GetDataStream(String,Boolean,TWebCompression) | Represents method GetDataStream(String,Boolean,TWebCompression).
GetMetaData(String,TWebCompression) | Represents method GetMetaData(String,TWebCompression).
GetStream(String) | Represents method GetStream(String).
GetString(String) | Represents method GetString(String).
Load(String,TWebCompression) | Represents method Load(String,TWebCompression).
Query(String,String,String) | Represents method Query(String,String,String).
UnZip(TStream) | Represents method UnZip(TStream).
URL | Represents method URL.
Top


TBIWebClient.DoFromURL(String) Method

Summary

Represents method DoFromURL(String).

Namespace: BI.Web
Syntax
Delphi
protected
 function DoFromURL(const AURL:String): TDataItem;

Parameters

AURL
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.FromPath(String) Method

Summary

Represents method FromPath(String).

Namespace: BI.Web
Syntax
Delphi
public
 class function FromPath(const APath:String):TBIWebClient; static;

Parameters

APath
Type: String

Return Value

Type: TBIWebClient

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.FromURL(String,Integer,String,TWebCompression) Method

Summary

Represents method FromURL(String,Integer,String,TWebCompression).

Namespace: BI.Web
Syntax
Delphi
public
 class function FromURL(const AServer:String;
 const APort:Integer;
 const AParams:String;
 const ACompress: TWebCompression=TWebCompression.Yes): TDataItem; overload; static;

Parameters

AServer
Type: String

APort
Type: Integer

AParams
Type: String

ACompress
Type: TWebCompression

Return Value

Type: TDataItem

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.FromURL(String,TWebCompression) Method

Summary

Represents method FromURL(String,TWebCompression).

Namespace: BI.Web
Syntax
Delphi
public
 class function FromURL(const AURL:String;
 const ACompress: TWebCompression=TWebCompression.Yes): TDataItem; overload; static;

Parameters

AURL
Type: String

ACompress
Type: TWebCompression

Return Value

Type: TDataItem

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.FTP(TDataDefinition) Method

Summary

Represents method FTP(TDataDefinition).

Namespace: BI.Web
Syntax
Delphi
public
 class function FTP(const ADef:TDataDefinition):TBIFtp; static;

Parameters

ADef
Type: TDataDefinition

Return Value

Type: TBIFtp

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.GetData Method

Summary

Represents method GetData.

Namespace: BI.Web
Syntax
Delphi
public
 function GetData:String; overload;

Return Value

Type: String

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.GetData(String,Boolean,TWebCompression) Method

Summary

Represents method GetData(String,Boolean,TWebCompression).

Namespace: BI.Web
Syntax
Delphi
public
 function GetData(const AData:String; const Children:Boolean; const ACompress:TWebCompression):TDataItem; overload;

Parameters

AData
Type: String

Children
Type: Boolean

ACompress
Type: TWebCompression

Return Value

Type: TDataItem

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.GetData(String,TDataArray,TWebCompression) Method

Summary

Represents method GetData(String,TDataArray,TWebCompression).

Namespace: BI.Web
Syntax
Delphi
public
 procedure GetData(const Data:String; var Items:TDataArray; const ACompress:TWebCompression); overload;

Parameters

Data
Type: String

Items
Type: TDataArray

ACompress
Type: TWebCompression

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.GetData(String,TDataItem,Boolean,TWebCompression) Method

Summary

Represents method GetData(String,TDataItem,Boolean,TWebCompression).

Namespace: BI.Web
Syntax
Delphi
public
 procedure GetData(const AOrigin:String; const AData:TDataItem; const Children:Boolean; const ACompress:TWebCompression); overload;

Parameters

AOrigin
Type: String

AData
Type: TDataItem

Children
Type: Boolean

ACompress
Type: TWebCompression

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.GetData(TDataItem,Boolean,TWebCompression) Method

Summary

Represents method GetData(TDataItem,Boolean,TWebCompression).

Namespace: BI.Web
Syntax
Delphi
public
 procedure GetData(const AData:TDataItem; const Children:Boolean; const ACompress:TWebCompression); overload;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

ACompress
Type: TWebCompression

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.GetDataStream(String,Boolean,TWebCompression) Method

Summary

Represents method GetDataStream(String,Boolean,TWebCompression).

Namespace: BI.Web
Syntax
Delphi
protected
 function GetDataStream(const Data:String; const Children:Boolean; const Compress:TWebCompression): TStream;

Parameters

Data
Type: String

Children
Type: Boolean

Compress
Type: TWebCompression

Return Value

Type: TStream

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.GetMetaData(String,TWebCompression) Method

Summary

Represents method GetMetaData(String,TWebCompression).

Namespace: BI.Web
Syntax
Delphi
public
 function GetMetaData(const S:String; const ACompress:TWebCompression): TDataItem;

Parameters

S
Type: String

ACompress
Type: TWebCompression

Return Value

Type: TDataItem

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.GetStream(String) Method

Summary

Represents method GetStream(String).

Namespace: BI.Web
Syntax
Delphi
public
 function GetStream(const S:String):TStream;

Parameters

S
Type: String

Return Value

Type: TStream

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.GetString(String) Method

Summary

Represents method GetString(String).

Namespace: BI.Web
Syntax
Delphi
public
 function GetString(const S:String):String;

Parameters

S
Type: String

Return Value

Type: String

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.Load(String,TWebCompression) Method

Summary

Represents method Load(String,TWebCompression).

Namespace: BI.Web
Syntax
Delphi
public
 function Load(const AData: String; const ACompress: TWebCompression=TWebCompression.Yes): TDataItem;

Parameters

AData
Type: String

ACompress
Type: TWebCompression

Return Value

Type: TDataItem

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.Query(String,String,String) Method

Summary

Represents method Query(String,String,String).

Namespace: BI.Web
Syntax
Delphi
public
 class function Query(const AStore,AData,ASQL:String):TDataItem; static;

Parameters

AStore
Type: String

AData
Type: String

ASQL
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.UnZip(TStream) Method

Summary

Represents method UnZip(TStream).

Namespace: BI.Web
Syntax
Delphi
public
 class function UnZip(const AStream:TStream):TStream; static; inline;

Parameters

AStream
Type: TStream

Return Value

Type: TStream

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.URL Method

Summary

Represents method URL.

Namespace: BI.Web
Syntax
Delphi
public
 function URL:String;

Return Value

Type: String

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient Fields

Fields
Name | Description
Compress | Represents field Compress.
Port | Represents field Port.
Proxy | Represents field Proxy.
Server | Represents field Server.
Store | Represents field Store.
Timeout | Represents field Timeout.
Top


TBIWebClient.Compress Field

Summary

Represents field Compress.

Namespace: BI.Web
Syntax
Delphi
public
 Compress : TWebCompression;

Field Value

Type: TWebCompression

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.Port Field

Summary

Represents field Port.

Namespace: BI.Web
Syntax
Delphi
public
 Port : Integer;

Field Value

Type: Integer

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.Proxy Field

Summary

Represents field Proxy.

Namespace: BI.Web
Syntax
Delphi
public
 Proxy : TWebProxy;

Field Value

Type: TWebProxy

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.Server Field

Summary

Represents field Server.

Namespace: BI.Web
Syntax
Delphi
public
 Server : String;

Field Value

Type: String

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.Store Field

Summary

Represents field Store.

Namespace: BI.Web
Syntax
Delphi
public
 Store : String;

Field Value

Type: String

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebClient.Timeout Field

Summary

Represents field Timeout.

Namespace: BI.Web
Syntax
Delphi
public
 Timeout : Integer;

Field Value

Type: Integer

See Also

Reference

  • TBIWebClient
  • BI.Web


TBIWebHistory Class

Summary

Represents type TBIWebHistory.

Namespace: BI.Web
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Web.TBIWebHistory
Syntax
Delphi
type
 TBIWebHistory=class(TDataItem)
 end;

The TBIWebHistory type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TBIWebHistory class.
Top
Methods
Show:
Name | Description
Add(TDateTime,String,String,String,Boolean,Integer,Int64) | Represents method Add(TDateTime,String,String,String,Boolean,Integer,Int64).
Top
See Also

Reference

  • BI.Web


TBIWebHistory Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TBIWebHistory class.
Top


TBIWebHistory.Create Constructor

Summary

Initializes a new instance of the TBIWebHistory class.

Namespace: BI.Web
Syntax
Delphi
public
 Constructor Create;
See Also

Reference

  • TBIWebHistory
  • BI.Web


TBIWebHistory Methods

Methods
Name | Description
Add(TDateTime,String,String,String,Boolean,Integer,Int64) | Represents method Add(TDateTime,String,String,String,Boolean,Integer,Int64).
Top


TBIWebHistory.Add(TDateTime,String,String,String,Boolean,Integer,Int64) Method

Summary

Represents method Add(TDateTime,String,String,String,Boolean,Integer,Int64).

Namespace: BI.Web
Syntax
Delphi
public
 function Add(const Time:TDateTime; const RemoteIP,Command,Tag:String;
 const Success:Boolean; const Millisec:Integer; const Size:Int64):TInteger;

Parameters

Time
Type: TDateTime

RemoteIP
Type: String

Command
Type: String

Tag
Type: String

Success
Type: Boolean

Millisec
Type: Integer

Size
Type: Int64

Return Value

Type: TInteger

See Also

Reference

  • TBIWebHistory
  • BI.Web


TBIWebImporter Class

Summary

Represents type TBIWebImporter.

Namespace: BI.Web
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Persist.TDataImporter
BI.Web.TBIWebImporter
Syntax
Delphi
type
 TBIWebImporter=class(TDataImporter)
 end;

The TBIWebImporter type exposes the following members.

Constructors
Show:
Name | Description
CreateDefinition(String,TDataDefinition) | Initializes a new instance of the TBIWebImporter class. (Overrides TDataImporter.CreateDefinition(String,TDataDefinition).)
Destroy | Represents the destructor of the TBIWebImporter class. (Overrides TDataProvider.Destroy.)
Top
Properties
Show:
Name | Description
Store | Represents property Store.
Top
Methods
Show:
Name | Description
AllData | Represents method AllData. (Overrides TDataImporter.AllData.)
GetDefinition(String) | Represents method GetDefinition(String). (Overrides TDataImporter.GetDefinition(String).)
Import | Represents method Import. (Overrides TDataImporter.Import.)
IsRemote | Represents method IsRemote. (Overrides TDataImporter.IsRemote.)
Load(String) | Represents method Load(String). (Overrides TDataImporter.Load(String).)
Supports(TDataDefinitionKind,TDataDefinition) | Represents method Supports(TDataDefinitionKind,TDataDefinition). (Overrides TDataImporter.Supports(TDataDefinitionKind,TDataDefinition).)
Top
See Also

Reference

  • BI.Web


TBIWebImporter Constructors

Constructors
Name | Description
CreateDefinition(String,TDataDefinition) | Initializes a new instance of the TBIWebImporter class. (Overrides TDataImporter.CreateDefinition(String,TDataDefinition).)
Destroy | Represents the destructor of the TBIWebImporter class. (Overrides TDataProvider.Destroy.)
Top


TBIWebImporter.CreateDefinition(String,TDataDefinition) Constructor

Summary

Initializes a new instance of the TBIWebImporter class.

Namespace: BI.Web
Syntax
Delphi
public
 Constructor CreateDefinition(const AStore:String; const ADefinition:TDataDefinition); override;

Parameters

AStore
Type: String

ADefinition
Type: TDataDefinition

Overrides

TDataImporter.CreateDefinition(String,TDataDefinition)
See Also

Reference

  • TBIWebImporter
  • BI.Web


TBIWebImporter.Destroy Destructor

Summary

Represents the destructor of the TBIWebImporter class.

Namespace: BI.Web
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TDataProvider.Destroy
See Also

Reference

  • TBIWebImporter
  • BI.Web


TBIWebImporter Properties

Properties
Name | Description
Store | Represents property Store.
Top


TBIWebImporter.Store Property

Summary

Represents property Store.

Namespace: BI.Web
Syntax
Delphi
published
 property Store:String read GetStore write SetStore;

Property Value

Type: String

See Also

Reference

  • TBIWebImporter
  • BI.Web


TBIWebImporter Methods

Methods
Name | Description
AllData | Represents method AllData. (Overrides TDataImporter.AllData.)
GetDefinition(String) | Represents method GetDefinition(String). (Overrides TDataImporter.GetDefinition(String).)
Import | Represents method Import. (Overrides TDataImporter.Import.)
IsRemote | Represents method IsRemote. (Overrides TDataImporter.IsRemote.)
Load(String) | Represents method Load(String). (Overrides TDataImporter.Load(String).)
Supports(TDataDefinitionKind,TDataDefinition) | Represents method Supports(TDataDefinitionKind,TDataDefinition). (Overrides TDataImporter.Supports(TDataDefinitionKind,TDataDefinition).)
Top


TBIWebImporter.AllData Method

Summary

Represents method AllData.

Namespace: BI.Web
Syntax
Delphi
public
 function AllData:TStringArray; override;

Return Value

Type: TStringArray

Overrides

TDataImporter.AllData
See Also

Reference

  • TBIWebImporter
  • BI.Web


TBIWebImporter.GetDefinition(String) Method

Summary

Represents method GetDefinition(String).

Namespace: BI.Web
Syntax
Delphi
public
 function GetDefinition(const AName:String):TDataDefinition; override;

Parameters

AName
Type: String

Return Value

Type: TDataDefinition

Overrides

TDataImporter.GetDefinition(String)
See Also

Reference

  • TBIWebImporter
  • BI.Web


TBIWebImporter.Import Method

Summary

Represents method Import.

Namespace: BI.Web
Syntax
Delphi
public
 function Import:TDataArray; override;

Return Value

Type: TDataArray

Overrides

TDataImporter.Import
See Also

Reference

  • TBIWebImporter
  • BI.Web


TBIWebImporter.IsRemote Method

Summary

Represents method IsRemote.

Namespace: BI.Web
Syntax
Delphi
public
 class function IsRemote:Boolean; override;

Return Value

Type: Boolean

Overrides

TDataImporter.IsRemote
See Also

Reference

  • TBIWebImporter
  • BI.Web


TBIWebImporter.Load(String) Method

Summary

Represents method Load(String).

Namespace: BI.Web
Syntax
Delphi
public
 function Load(const AName:String):TDataItem; override;

Parameters

AName
Type: String

Return Value

Type: TDataItem

Overrides

TDataImporter.Load(String)
See Also

Reference

  • TBIWebImporter
  • BI.Web


TBIWebImporter.Supports(TDataDefinitionKind,TDataDefinition) Method

Summary

Represents method Supports(TDataDefinitionKind,TDataDefinition).

Namespace: BI.Web
Syntax
Delphi
public
 class function Supports(const Kind:TDataDefinitionKind; const ADefinition:TDataDefinition=nil):Boolean; override;

Parameters

Kind
Type: TDataDefinitionKind

ADefinition
Type: TDataDefinition

Return Value

Type: Boolean

Overrides

TDataImporter.Supports(TDataDefinitionKind,TDataDefinition)
See Also

Reference

  • TBIWebImporter
  • BI.Web


TBIWebServer Class

Summary

Represents type TBIWebServer.

Namespace: BI.Web
Inheritance Hierarchy
TObject
BI.Web.TBIWebServer
Syntax
Delphi
type
 TBIWebServer=class
 end;

The TBIWebServer type exposes the following members.

Constants
Show:
Name | Description
Version | Represents constant Version.
Top
See Also

Reference

  • BI.Web


TBIWebServer Constants

Constants
Name | Description
Version | Represents constant Version.
Top


TBIWebServer.Version Constant

Summary

Represents constant Version.

Namespace: BI.Web
Syntax
Delphi
public
 Version:TVersion=(Major:1; Minor:0; URL:'');

Value

Type: TVersion

See Also

Reference

  • TBIWebServer
  • BI.Web


TDataItemAccess Class

Summary

Represents type TDataItemAccess.

Namespace: BI.Web
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Web.TDataItemAccess
Syntax
Delphi
type
 TDataItemAccess=class(TDataItem);
See Also

Reference

  • BI.Web


TDelayHandlerWeb Class

Summary

Represents type TDelayHandlerWeb.

Namespace: BI.Web
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Persist.TDataDelayProvider
BI.Web.TDelayHandlerWeb
Syntax
Delphi
type
 TDelayHandlerWeb=class(TDataDelayProvider)
 end;

The TDelayHandlerWeb type exposes the following members.

Constructors
Show:
Name | Description
CreateWeb(TBIWebClient) | Initializes a new instance of the TDelayHandlerWeb class.
Destroy | Represents the destructor of the TDelayHandlerWeb class. (Overrides TDataProvider.Destroy.)
Top
Methods
Show:
Name | Description
GetStream(TDataArray) | Represents method GetStream(TDataArray). (Overrides TDataProvider.GetStream(TDataArray).)
GetStream(TDataItem,TDataItem) | Represents method GetStream(TDataItem,TDataItem). (Overrides TDataProvider.GetStream(TDataItem,TDataItem).)
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Top
Fields
Show:
Name | Description
BIWeb | Represents field BIWeb.
Top
See Also

Reference

  • BI.Web


TDelayHandlerWeb Constructors

Constructors
Name | Description
CreateWeb(TBIWebClient) | Initializes a new instance of the TDelayHandlerWeb class.
Destroy | Represents the destructor of the TDelayHandlerWeb class. (Overrides TDataProvider.Destroy.)
Top


TDelayHandlerWeb.CreateWeb(TBIWebClient) Constructor

Summary

Initializes a new instance of the TDelayHandlerWeb class.

Namespace: BI.Web
Syntax
Delphi
public
 Constructor CreateWeb(const ABIWeb:TBIWebClient);

Parameters

ABIWeb
Type: TBIWebClient

See Also

Reference

  • TDelayHandlerWeb
  • BI.Web


TDelayHandlerWeb.Destroy Destructor

Summary

Represents the destructor of the TDelayHandlerWeb class.

Namespace: BI.Web
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TDataProvider.Destroy
See Also

Reference

  • TDelayHandlerWeb
  • BI.Web


TDelayHandlerWeb Methods

Methods
Name | Description
GetStream(TDataArray) | Represents method GetStream(TDataArray). (Overrides TDataProvider.GetStream(TDataArray).)
GetStream(TDataItem,TDataItem) | Represents method GetStream(TDataItem,TDataItem). (Overrides TDataProvider.GetStream(TDataItem,TDataItem).)
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Top


TDelayHandlerWeb.GetStream(TDataItem,TDataItem) Method

Summary

Represents method GetStream(TDataItem,TDataItem).

Namespace: BI.Web
Syntax
Delphi
protected
 function GetStream(const AData,ANext:TDataItem):TStream; override;

Parameters

AData
Type: TDataItem

ANext
Type: TDataItem

Return Value

Type: TStream

Overrides

TDataProvider.GetStream(TDataItem,TDataItem)
See Also

Reference

  • TDelayHandlerWeb
  • BI.Web


TDelayHandlerWeb.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Web
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TDelayHandlerWeb
  • BI.Web


TDelayHandlerWeb Fields

Fields
Name | Description
BIWeb | Represents field BIWeb.
Top


TDelayHandlerWeb.BIWeb Field

Summary

Represents field BIWeb.

Namespace: BI.Web
Syntax
Delphi
public
 BIWeb : TBIWebClient;

Field Value

Type: TBIWebClient

See Also

Reference

  • TDelayHandlerWeb
  • BI.Web


TSteema Class

Summary

Represents type TSteema.

Namespace: BI.Web
Inheritance Hierarchy
TObject
BI.Web.TBIWebClient
BI.Web.TSteema
Syntax
Delphi
type
 TSteema=class(TBIWebClient)
 end;

The TSteema type exposes the following members.

Methods
Show:
Name | Description
CheckNewVersion(String) | Represents method CheckNewVersion(String).
Download(String,String) | Represents method Download(String,String).
GetLatestVersion(TVersion,String) | Represents method GetLatestVersion(TVersion,String).
Top
See Also

Reference

  • BI.Web


TSteema Methods

Methods
Name | Description
CheckNewVersion(String) | Represents method CheckNewVersion(String).
Download(String,String) | Represents method Download(String,String).
GetLatestVersion(TVersion,String) | Represents method GetLatestVersion(TVersion,String).
Top


TSteema.CheckNewVersion(String) Method

Summary

Represents method CheckNewVersion(String).

Namespace: BI.Web
Syntax
Delphi
public
 class function CheckNewVersion(out AError:String):Boolean; static;

Parameters

AError
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TSteema
  • BI.Web


TSteema.Download(String,String) Method

Summary

Represents method Download(String,String).

Namespace: BI.Web
Syntax
Delphi
public
 class function Download(const Source,Dest:String):Boolean; static;

Parameters

Source
Type: String

Dest
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TSteema
  • BI.Web


TSteema.GetLatestVersion(TVersion,String) Method

Summary

Represents method GetLatestVersion(TVersion,String).

Namespace: BI.Web
Syntax
Delphi
public
 class function GetLatestVersion(out V: TBIWebServer.TVersion; out Error:String):Boolean; static;

Parameters

V
Type: TBIWebServer.TVersion

Error
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TSteema
  • BI.Web


BI.Web Records

Records
Name | Description
TBIWebServer.TVersion | Represents type TVersion.
TWebProxy | Represents type TWebProxy.
TWebURL | Represents type TWebURL.
Top


TBIWebServer.TVersion Record

Summary

Represents type TVersion.

Namespace: BI.Web
Syntax
Delphi
public
type
 TVersion=record
 end;

The TBIWebServer.TVersion type exposes the following members.

Methods
Show:
Name | Description
ToString | Represents method ToString.
Top
Fields
Show:
Name | Description
Major | Represents field Major.
Minor | Represents field Minor.
URL | Represents field URL.
Top
See Also

Reference

  • TBIWebServer
  • BI.Web


TBIWebServer.TVersion Methods

Methods
Name | Description
ToString | Represents method ToString.
Top


TBIWebServer.TVersion.ToString Method

Summary

Represents method ToString.

Namespace: BI.Web
Syntax
Delphi
public
 function ToString:String;

Return Value

Type: String

See Also

Reference

  • TBIWebServer.TVersion
  • TBIWebServer
  • BI.Web


TBIWebServer.TVersion Fields

Fields
Name | Description
Major | Represents field Major.
Minor | Represents field Minor.
URL | Represents field URL.
Top


TBIWebServer.TVersion.Major Field

Summary

Represents field Major.

Namespace: BI.Web
Syntax
Delphi
public
 Major,
 Minor : Integer;

Field Value

Type: Integer

See Also

Reference

  • TBIWebServer.TVersion
  • TBIWebServer
  • BI.Web


TBIWebServer.TVersion.Minor Field

Summary

Represents field Minor.

Namespace: BI.Web
Syntax
Delphi
public
 Major,
 Minor : Integer;

Field Value

Type: Integer

See Also

Reference

  • TBIWebServer.TVersion
  • TBIWebServer
  • BI.Web


TBIWebServer.TVersion.URL Field

Summary

Represents field URL.

Namespace: BI.Web
Syntax
Delphi
public
 URL : String;

Field Value

Type: String

See Also

Reference

  • TBIWebServer.TVersion
  • TBIWebServer
  • BI.Web


TWebProxy Record

Summary

Represents type TWebProxy.

Namespace: BI.Web
Syntax
Delphi
type
 TWebProxy=record
 end;

The TWebProxy type exposes the following members.

Fields
Show:
Name | Description
Host | Represents field Host.
Password | Represents field Password.
Port | Represents field Port.
User | Represents field User.
Top
See Also

Reference

  • BI.Web


TWebProxy Fields

Fields
Name | Description
Host | Represents field Host.
Password | Represents field Password.
Port | Represents field Port.
User | Represents field User.
Top


TWebProxy.Host Field

Summary

Represents field Host.

Namespace: BI.Web
Syntax
Delphi
public
 Host : String;

Field Value

Type: String

See Also

Reference

  • TWebProxy
  • BI.Web


TWebProxy.Password Field

Summary

Represents field Password.

Namespace: BI.Web
Syntax
Delphi
public
 User,
 Password : String;

Field Value

Type: String

See Also

Reference

  • TWebProxy
  • BI.Web


TWebProxy.Port Field

Summary

Represents field Port.

Namespace: BI.Web
Syntax
Delphi
public
 Port : Integer;

Field Value

Type: Integer

See Also

Reference

  • TWebProxy
  • BI.Web


TWebProxy.User Field

Summary

Represents field User.

Namespace: BI.Web
Syntax
Delphi
public
 User,
 Password : String;

Field Value

Type: String

See Also

Reference

  • TWebProxy
  • BI.Web


TWebURL Record

Summary

Represents type TWebURL.

Namespace: BI.Web
Syntax
Delphi
type
 TWebURL=record
 end;

The TWebURL type exposes the following members.

Fields
Show:
Name | Description
Host | Represents field Host.
Params | Represents field Params.
Port | Represents field Port.
Top
See Also

Reference

  • BI.Web


TWebURL Fields

Fields
Name | Description
Host | Represents field Host.
Params | Represents field Params.
Port | Represents field Port.
Top


TWebURL.Host Field

Summary

Represents field Host.

Namespace: BI.Web
Syntax
Delphi
public
 Host : String;

Field Value

Type: String

See Also

Reference

  • TWebURL
  • BI.Web


TWebURL.Params Field

Summary

Represents field Params.

Namespace: BI.Web
Syntax
Delphi
public
 Params : String;

Field Value

Type: String

See Also

Reference

  • TWebURL
  • BI.Web


TWebURL.Port Field

Summary

Represents field Port.

Namespace: BI.Web
Syntax
Delphi
public
 Port : Integer;

Field Value

Type: Integer

See Also

Reference

  • TWebURL
  • BI.Web


BI.Web Enumerations

Enumerations
Name | Description
TWebCompression | Represents type TWebCompression.
Top


TWebCompression Enumeration

Summary

Represents type TWebCompression.

Namespace: BI.Web
Syntax
Delphi
type
 TWebCompression=(No,Yes);

The TWebCompression type exposes the following members.

Members
Show:
Name | Description
No | Represents constant No.
Yes | Represents constant Yes.
Top
See Also

Reference

  • BI.Web


BI.Web Delegates

Delegates
Name | Description
TBIHttpProgress | Represents type TBIHttpProgress.
Top


TBIHttpProgress Delegate

Summary

Represents type TBIHttpProgress.

Namespace: BI.Web
Syntax
Delphi
type
 TBIHttpProgress=procedure(Sender:TObject; const ACurrent,ATotal:Int64; var Abort:Boolean) of object;
See Also

Reference

  • BI.Web


BI.Web Types

Types
Name | Description
TBIHttpClass | Represents type TBIHttpClass.
Top


TBIHttpClass Type

Summary

Represents type TBIHttpClass.

Namespace: BI.Web
Syntax
Delphi
type
 TBIHttpClass=class of TBIHttp;
See Also

Reference

  • BI.Web


BI.Web Constants

Constants
Name | Description
SteemaBIWeb | Represents constant SteemaBIWeb.
Top


SteemaBIWeb Constant

Summary

Represents constant SteemaBIWeb.

Namespace: BI.Web
Syntax
Delphi
 SteemaBIWeb='http://www.steema.cat';

Value

Type: string

See Also

Reference

  • BI.Web


BI.Web.FPC Namespace

Summary

Represents namespace BI.Web.FPC.

Classes
Name | Description
EHttpAbort | Represents type EHttpAbort.
TBIFPCWeb | Represents type TBIFPCWeb.
Top


BI.Web.FPC Classes

Classes
Name | Description
EHttpAbort | Represents type EHttpAbort.
TBIFPCWeb | Represents type TBIFPCWeb.
Top


EHttpAbort Class

Summary

Represents type EHttpAbort.

Namespace: BI.Web.FPC
Inheritance Hierarchy
Exception
BI.Web.FPC.EHttpAbort
Syntax
Delphi
type
 EHttpAbort=class(Exception);
See Also

Reference

  • BI.Web.FPC


TBIFPCWeb Class

Summary

Represents type TBIFPCWeb.

Namespace: BI.Web.FPC
Inheritance Hierarchy
TObject
BI.Web.TBIHttp
BI.Web.FPC.TBIFPCWeb
Syntax
Delphi
type
 TBIFPCWeb=class(TBIHttp)
 end;

The TBIFPCWeb type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIFPCWeb class. (Overrides TBIHttp.Create(TComponent).)
Destroy | Represents the destructor of the TBIFPCWeb class.
Top
Methods
Show:
Name | Description
FTP(TDataDefinition) | Represents method FTP(TDataDefinition). (Overrides TBIHttp.FTP(TDataDefinition).)
Get(String) | Overloaded. Represents method Get(String). (Overrides TBIHttp.Get(String).)
Get(String,TStream) | Overloaded. Represents method Get(String,TStream). (Overrides TBIHttp.Get(String,TStream).)
Parse(String) | Represents method Parse(String). (Overrides TBIHttp.Parse(String).)
SetProxy(TWebProxy) | Represents method SetProxy(TWebProxy). (Overrides TBIHttp.SetProxy(TWebProxy).)
SetTimeout(Integer) | Represents method SetTimeout(Integer). (Overrides TBIHttp.SetTimeout(Integer).)
Top
See Also

Reference

  • BI.Web.FPC


TBIFPCWeb Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBIFPCWeb class. (Overrides TBIHttp.Create(TComponent).)
Destroy | Represents the destructor of the TBIFPCWeb class.
Top


TBIFPCWeb.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIFPCWeb class.

Namespace: BI.Web.FPC
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TBIHttp.Create(TComponent)
See Also

Reference

  • TBIFPCWeb
  • BI.Web.FPC


TBIFPCWeb.Destroy Destructor

Summary

Represents the destructor of the TBIFPCWeb class.

Namespace: BI.Web.FPC
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIFPCWeb
  • BI.Web.FPC


TBIFPCWeb Methods

Methods
Name | Description
FTP(TDataDefinition) | Represents method FTP(TDataDefinition). (Overrides TBIHttp.FTP(TDataDefinition).)
Get(String) | Overloaded. Represents method Get(String). (Overrides TBIHttp.Get(String).)
Get(String,TStream) | Overloaded. Represents method Get(String,TStream). (Overrides TBIHttp.Get(String,TStream).)
Parse(String) | Represents method Parse(String). (Overrides TBIHttp.Parse(String).)
SetProxy(TWebProxy) | Represents method SetProxy(TWebProxy). (Overrides TBIHttp.SetProxy(TWebProxy).)
SetTimeout(Integer) | Represents method SetTimeout(Integer). (Overrides TBIHttp.SetTimeout(Integer).)
Top


TBIFPCWeb.FTP(TDataDefinition) Method

Summary

Represents method FTP(TDataDefinition).

Namespace: BI.Web.FPC
Syntax
Delphi
public
 class function FTP(const ADef:TDataDefinition):TBIFtp; override;

Parameters

ADef
Type: TDataDefinition

Return Value

Type: TBIFtp

Overrides

TBIHttp.FTP(TDataDefinition)
See Also

Reference

  • TBIFPCWeb
  • BI.Web.FPC


TBIFPCWeb.Get(String) Method

Summary

Represents method Get(String).

Namespace: BI.Web.FPC
Syntax
Delphi
public
 function Get(const AURL:String):String; overload; override;

Parameters

AURL
Type: String

Return Value

Type: String

Overrides

TBIHttp.Get(String)
See Also

Reference

  • TBIFPCWeb
  • BI.Web.FPC


TBIFPCWeb.Get(String,TStream) Method

Summary

Represents method Get(String,TStream).

Namespace: BI.Web.FPC
Syntax
Delphi
public
 procedure Get(const AURL:String; const AStream:TStream); overload; override;

Parameters

AURL
Type: String

AStream
Type: TStream

Overrides

TBIHttp.Get(String,TStream)
See Also

Reference

  • TBIFPCWeb
  • BI.Web.FPC


TBIFPCWeb.Parse(String) Method

Summary

Represents method Parse(String).

Namespace: BI.Web.FPC
Syntax
Delphi
public
 class function Parse(const AURL:String):TWebURL; override;

Parameters

AURL
Type: String

Return Value

Type: TWebURL

Overrides

TBIHttp.Parse(String)
See Also

Reference

  • TBIFPCWeb
  • BI.Web.FPC


TBIFPCWeb.SetProxy(TWebProxy) Method

Summary

Represents method SetProxy(TWebProxy).

Namespace: BI.Web.FPC
Syntax
Delphi
public
 procedure SetProxy(const AProxy:TWebProxy); override;

Parameters

AProxy
Type: TWebProxy

Overrides

TBIHttp.SetProxy(TWebProxy)
See Also

Reference

  • TBIFPCWeb
  • BI.Web.FPC


TBIFPCWeb.SetTimeout(Integer) Method

Summary

Represents method SetTimeout(Integer).

Namespace: BI.Web.FPC
Syntax
Delphi
public
 procedure SetTimeout(const ATimeout:Integer); override;

Parameters

ATimeout
Type: Integer

Overrides

TBIHttp.SetTimeout(Integer)
See Also

Reference

  • TBIFPCWeb
  • BI.Web.FPC


BI.Web.Html Namespace

Summary

Represents namespace BI.Web.Html.

Classes
Name | Description
THTMLHelper | Represents type THTMLHelper.
Top


BI.Web.Html Classes

Classes
Name | Description
THTMLHelper | Represents type THTMLHelper.
Top


THTMLHelper Class

Summary

Represents type THTMLHelper.

Namespace: BI.Web.Html
Inheritance Hierarchy
TObject
BI.Web.Html.THTMLHelper
Syntax
Delphi
type
 THTMLHelper=class
 end;

The THTMLHelper type exposes the following members.

Constants
Show:
Name | Description
PureCSS | Represents constant PureCSS.
Top
Methods
Show:
Name | Description
AlphaColorToColor(TAlphaColor) | Represents method AlphaColorToColor(TAlphaColor).
Top
See Also

Reference

  • BI.Web.Html


THTMLHelper Constants

Constants
Name | Description
PureCSS | Represents constant PureCSS.
Top


THTMLHelper.PureCSS Constant

Summary

Represents constant PureCSS.

Namespace: BI.Web.Html
Syntax
Delphi
public
 PureCSS='<link rel="stylesheet" href="http://yui.yahooapis.com/pure/0.6.0/pure-min.css">';

Value

Type: string

See Also

Reference

  • THTMLHelper
  • BI.Web.Html


THTMLHelper Methods

Methods
Name | Description
AlphaColorToColor(TAlphaColor) | Represents method AlphaColorToColor(TAlphaColor).
Top


THTMLHelper.AlphaColorToColor(TAlphaColor) Method

Summary

Represents method AlphaColorToColor(TAlphaColor).

Namespace: BI.Web.Html
Syntax
Delphi
public
 class function AlphaColorToColor(const AColor:TAlphaColor):TColor; static;

Parameters

AColor
Type: TAlphaColor

Return Value

Type: TColor

See Also

Reference

  • THTMLHelper
  • BI.Web.Html


BI.Web.Indy Namespace

Summary

Represents namespace BI.Web.Indy.

Classes
Name | Description
TBIIndy | Represents type TBIIndy.
TBIIndyFtp | Represents type TBIIndyFtp.
Top


BI.Web.Indy Classes

Classes
Name | Description
TBIIndy | Represents type TBIIndy.
TBIIndyFtp | Represents type TBIIndyFtp.
Top


TBIIndy Class

Summary

Represents type TBIIndy.

Namespace: BI.Web.Indy
Inheritance Hierarchy
TObject
BI.Web.TBIHttp
BI.Web.Indy.TBIIndy
Syntax
Delphi
type
 TBIIndy=class(TBIHttp)
 end;

The TBIIndy type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIIndy class. (Overrides TBIHttp.Create(TComponent).)
Destroy | Represents the destructor of the TBIIndy class.
Top
Properties
Show:
Name | Description
Http | Represents property Http.
Top
Methods
Show:
Name | Description
FTP(TDataDefinition) | Represents method FTP(TDataDefinition). (Overrides TBIHttp.FTP(TDataDefinition).)
Get(String) | Overloaded. Represents method Get(String). (Overrides TBIHttp.Get(String).)
Get(String,TStream) | Overloaded. Represents method Get(String,TStream). (Overrides TBIHttp.Get(String,TStream).)
Parse(String) | Represents method Parse(String). (Overrides TBIHttp.Parse(String).)
SetProxy(TWebProxy) | Represents method SetProxy(TWebProxy). (Overrides TBIHttp.SetProxy(TWebProxy).)
SetTimeout(Integer) | Represents method SetTimeout(Integer). (Overrides TBIHttp.SetTimeout(Integer).)
Top
See Also

Reference

  • BI.Web.Indy


TBIIndy Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBIIndy class. (Overrides TBIHttp.Create(TComponent).)
Destroy | Represents the destructor of the TBIIndy class.
Top


TBIIndy.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIIndy class.

Namespace: BI.Web.Indy
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TBIHttp.Create(TComponent)
See Also

Reference

  • TBIIndy
  • BI.Web.Indy


TBIIndy.Destroy Destructor

Summary

Represents the destructor of the TBIIndy class.

Namespace: BI.Web.Indy
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIIndy
  • BI.Web.Indy


TBIIndy Properties

Properties
Name | Description
Http | Represents property Http.
Top


TBIIndy.Http Property

Summary

Represents property Http.

Namespace: BI.Web.Indy
Syntax
Delphi
public
 property Http:TIdHTTP read FHttp;

Property Value

Type: TIdHTTP

See Also

Reference

  • TBIIndy
  • BI.Web.Indy


TBIIndy Methods

Methods
Name | Description
FTP(TDataDefinition) | Represents method FTP(TDataDefinition). (Overrides TBIHttp.FTP(TDataDefinition).)
Get(String) | Overloaded. Represents method Get(String). (Overrides TBIHttp.Get(String).)
Get(String,TStream) | Overloaded. Represents method Get(String,TStream). (Overrides TBIHttp.Get(String,TStream).)
Parse(String) | Represents method Parse(String). (Overrides TBIHttp.Parse(String).)
SetProxy(TWebProxy) | Represents method SetProxy(TWebProxy). (Overrides TBIHttp.SetProxy(TWebProxy).)
SetTimeout(Integer) | Represents method SetTimeout(Integer). (Overrides TBIHttp.SetTimeout(Integer).)
Top


TBIIndy.FTP(TDataDefinition) Method

Summary

Represents method FTP(TDataDefinition).

Namespace: BI.Web.Indy
Syntax
Delphi
public
 class function FTP(const ADef:TDataDefinition):TBIFtp; override;

Parameters

ADef
Type: TDataDefinition

Return Value

Type: TBIFtp

Overrides

TBIHttp.FTP(TDataDefinition)
See Also

Reference

  • TBIIndy
  • BI.Web.Indy


TBIIndy.Get(String) Method

Summary

Represents method Get(String).

Namespace: BI.Web.Indy
Syntax
Delphi
public
 function Get(const AURL:String):String; overload; override;

Parameters

AURL
Type: String

Return Value

Type: String

Overrides

TBIHttp.Get(String)
See Also

Reference

  • TBIIndy
  • BI.Web.Indy


TBIIndy.Get(String,TStream) Method

Summary

Represents method Get(String,TStream).

Namespace: BI.Web.Indy
Syntax
Delphi
public
 procedure Get(const AURL:String; const AStream:TStream); overload; override;

Parameters

AURL
Type: String

AStream
Type: TStream

Overrides

TBIHttp.Get(String,TStream)
See Also

Reference

  • TBIIndy
  • BI.Web.Indy


TBIIndy.Parse(String) Method

Summary

Represents method Parse(String).

Namespace: BI.Web.Indy
Syntax
Delphi
public
 class function Parse(const AURL:String):TWebURL; override;

Parameters

AURL
Type: String

Return Value

Type: TWebURL

Overrides

TBIHttp.Parse(String)
See Also

Reference

  • TBIIndy
  • BI.Web.Indy


TBIIndy.SetProxy(TWebProxy) Method

Summary

Represents method SetProxy(TWebProxy).

Namespace: BI.Web.Indy
Syntax
Delphi
public
 procedure SetProxy(const AProxy:TWebProxy); override;

Parameters

AProxy
Type: TWebProxy

Overrides

TBIHttp.SetProxy(TWebProxy)
See Also

Reference

  • TBIIndy
  • BI.Web.Indy


TBIIndy.SetTimeout(Integer) Method

Summary

Represents method SetTimeout(Integer).

Namespace: BI.Web.Indy
Syntax
Delphi
public
 procedure SetTimeout(const ATimeout:Integer); override;

Parameters

ATimeout
Type: Integer

Overrides

TBIHttp.SetTimeout(Integer)
See Also

Reference

  • TBIIndy
  • BI.Web.Indy


TBIIndyFtp Class

Summary

Represents type TBIIndyFtp.

Namespace: BI.Web.Indy
Inheritance Hierarchy
TObject
BI.Web.TBIFtp
BI.Web.Indy.TBIIndyFtp
Syntax
Delphi
type
 TBIIndyFtp=class(TBIFtp)
 end;

The TBIIndyFtp type exposes the following members.

Constructors
Show:
Name | Description
Create(TDataDefinition) | Initializes a new instance of the TBIIndyFtp class. (Overrides TBIFtp.Create(TDataDefinition).)
Destroy | Represents the destructor of the TBIIndyFtp class.
Top
Methods
Show:
Name | Description
Connect | Represents method Connect. (Overrides TBIFtp.Connect.)
DisConnect | Represents method DisConnect. (Overrides TBIFtp.DisConnect.)
Get(String) | Represents method Get(String). (Overrides TBIFtp.Get(String).)
IncludedFiles(String,String) | Represents method IncludedFiles(String,String). (Overrides TBIFtp.IncludedFiles(String,String).)
ListFiles(String,String) | Represents method ListFiles(String,String). (Overrides TBIFtp.ListFiles(String,String).)
Top
See Also

Reference

  • BI.Web.Indy


TBIIndyFtp Constructors

Constructors
Name | Description
Create(TDataDefinition) | Initializes a new instance of the TBIIndyFtp class. (Overrides TBIFtp.Create(TDataDefinition).)
Destroy | Represents the destructor of the TBIIndyFtp class.
Top


TBIIndyFtp.Create(TDataDefinition) Constructor

Summary

Initializes a new instance of the TBIIndyFtp class.

Namespace: BI.Web.Indy
Syntax
Delphi
public
 Constructor Create(const ADef:TDataDefinition); override;

Parameters

ADef
Type: TDataDefinition

Overrides

TBIFtp.Create(TDataDefinition)
See Also

Reference

  • TBIIndyFtp
  • BI.Web.Indy


TBIIndyFtp.Destroy Destructor

Summary

Represents the destructor of the TBIIndyFtp class.

Namespace: BI.Web.Indy
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIIndyFtp
  • BI.Web.Indy


TBIIndyFtp Methods

Methods
Name | Description
Connect | Represents method Connect. (Overrides TBIFtp.Connect.)
DisConnect | Represents method DisConnect. (Overrides TBIFtp.DisConnect.)
Get(String) | Represents method Get(String). (Overrides TBIFtp.Get(String).)
IncludedFiles(String,String) | Represents method IncludedFiles(String,String). (Overrides TBIFtp.IncludedFiles(String,String).)
ListFiles(String,String) | Represents method ListFiles(String,String). (Overrides TBIFtp.ListFiles(String,String).)
Top


TBIIndyFtp.Connect Method

Summary

Represents method Connect.

Namespace: BI.Web.Indy
Syntax
Delphi
public
 procedure Connect; override;

Overrides

TBIFtp.Connect
See Also

Reference

  • TBIIndyFtp
  • BI.Web.Indy


TBIIndyFtp.DisConnect Method

Summary

Represents method DisConnect.

Namespace: BI.Web.Indy
Syntax
Delphi
public
 procedure DisConnect; override;

Overrides

TBIFtp.DisConnect
See Also

Reference

  • TBIIndyFtp
  • BI.Web.Indy


TBIIndyFtp.Get(String) Method

Summary

Represents method Get(String).

Namespace: BI.Web.Indy
Syntax
Delphi
public
 function Get(const AFileName:String):TStream; override;

Parameters

AFileName
Type: String

Return Value

Type: TStream

Overrides

TBIFtp.Get(String)
See Also

Reference

  • TBIIndyFtp
  • BI.Web.Indy


TBIIndyFtp.IncludedFiles(String,String) Method

Summary

Represents method IncludedFiles(String,String).

Namespace: BI.Web.Indy
Syntax
Delphi
public
 function IncludedFiles(const AFolder,AIncludeMask:String):TStringDynArray; override;

Parameters

AFolder
Type: String

AIncludeMask
Type: String

Return Value

Type: TStringDynArray

Overrides

TBIFtp.IncludedFiles(String,String)
See Also

Reference

  • TBIIndyFtp
  • BI.Web.Indy


TBIIndyFtp.ListFiles(String,String) Method

Summary

Represents method ListFiles(String,String).

Namespace: BI.Web.Indy
Syntax
Delphi
public
 function ListFiles(const AFolder,AIncludeMask:String): TStrings; override;

Parameters

AFolder
Type: String

AIncludeMask
Type: String

Return Value

Type: TStrings

Overrides

TBIFtp.ListFiles(String,String)
See Also

Reference

  • TBIIndyFtp
  • BI.Web.Indy


BI.Web.Net Namespace

Summary

Represents namespace BI.Web.Net.

Classes
Name | Description
TBIHttpClient | Represents type TBIHttpClient.
Top


BI.Web.Net Classes

Classes
Name | Description
TBIHttpClient | Represents type TBIHttpClient.
Top


TBIHttpClient Class

Summary

Represents type TBIHttpClient.

Namespace: BI.Web.Net
Inheritance Hierarchy
TObject
BI.Web.TBIHttp
BI.Web.Net.TBIHttpClient
Syntax
Delphi
type
 TBIHttpClient=class(TBIHttp)
 end;

The TBIHttpClient type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIHttpClient class. (Overrides TBIHttp.Create(TComponent).)
Destroy | Represents the destructor of the TBIHttpClient class.
Top
Properties
Show:
Name | Description
Http | Represents property Http.
Top
Methods
Show:
Name | Description
FTP(TDataDefinition) | Represents method FTP(TDataDefinition). (Overrides TBIHttp.FTP(TDataDefinition).)
Get(String) | Overloaded. Represents method Get(String). (Overrides TBIHttp.Get(String).)
Get(String,TStream) | Overloaded. Represents method Get(String,TStream). (Overrides TBIHttp.Get(String,TStream).)
Parse(String) | Represents method Parse(String). (Overrides TBIHttp.Parse(String).)
SetProxy(TWebProxy) | Represents method SetProxy(TWebProxy). (Overrides TBIHttp.SetProxy(TWebProxy).)
SetTimeout(Integer) | Represents method SetTimeout(Integer). (Overrides TBIHttp.SetTimeout(Integer).)
Top
See Also

Reference

  • BI.Web.Net


TBIHttpClient Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBIHttpClient class. (Overrides TBIHttp.Create(TComponent).)
Destroy | Represents the destructor of the TBIHttpClient class.
Top


TBIHttpClient.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIHttpClient class.

Namespace: BI.Web.Net
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TBIHttp.Create(TComponent)
See Also

Reference

  • TBIHttpClient
  • BI.Web.Net


TBIHttpClient.Destroy Destructor

Summary

Represents the destructor of the TBIHttpClient class.

Namespace: BI.Web.Net
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIHttpClient
  • BI.Web.Net


TBIHttpClient Properties

Properties
Name | Description
Http | Represents property Http.
Top


TBIHttpClient.Http Property

Summary

Represents property Http.

Namespace: BI.Web.Net
Syntax
Delphi
public
 property Http:TNetHTTPClient read FHttp;

Property Value

Type: TNetHTTPClient

See Also

Reference

  • TBIHttpClient
  • BI.Web.Net


TBIHttpClient Methods

Methods
Name | Description
FTP(TDataDefinition) | Represents method FTP(TDataDefinition). (Overrides TBIHttp.FTP(TDataDefinition).)
Get(String) | Overloaded. Represents method Get(String). (Overrides TBIHttp.Get(String).)
Get(String,TStream) | Overloaded. Represents method Get(String,TStream). (Overrides TBIHttp.Get(String,TStream).)
Parse(String) | Represents method Parse(String). (Overrides TBIHttp.Parse(String).)
SetProxy(TWebProxy) | Represents method SetProxy(TWebProxy). (Overrides TBIHttp.SetProxy(TWebProxy).)
SetTimeout(Integer) | Represents method SetTimeout(Integer). (Overrides TBIHttp.SetTimeout(Integer).)
Top


TBIHttpClient.FTP(TDataDefinition) Method

Summary

Represents method FTP(TDataDefinition).

Namespace: BI.Web.Net
Syntax
Delphi
public
 class function FTP(const ADef:TDataDefinition):TBIFtp; override;

Parameters

ADef
Type: TDataDefinition

Return Value

Type: TBIFtp

Overrides

TBIHttp.FTP(TDataDefinition)
See Also

Reference

  • TBIHttpClient
  • BI.Web.Net


TBIHttpClient.Get(String) Method

Summary

Represents method Get(String).

Namespace: BI.Web.Net
Syntax
Delphi
public
 function Get(const AURL:String):String; overload; override;

Parameters

AURL
Type: String

Return Value

Type: String

Overrides

TBIHttp.Get(String)
See Also

Reference

  • TBIHttpClient
  • BI.Web.Net


TBIHttpClient.Get(String,TStream) Method

Summary

Represents method Get(String,TStream).

Namespace: BI.Web.Net
Syntax
Delphi
public
 procedure Get(const AURL:String; const AStream:TStream); overload; override;

Parameters

AURL
Type: String

AStream
Type: TStream

Overrides

TBIHttp.Get(String,TStream)
See Also

Reference

  • TBIHttpClient
  • BI.Web.Net


TBIHttpClient.Parse(String) Method

Summary

Represents method Parse(String).

Namespace: BI.Web.Net
Syntax
Delphi
public
 class function Parse(const AURL: String): TWebURL; override;

Parameters

AURL
Type: String

Return Value

Type: TWebURL

Overrides

TBIHttp.Parse(String)
See Also

Reference

  • TBIHttpClient
  • BI.Web.Net


TBIHttpClient.SetProxy(TWebProxy) Method

Summary

Represents method SetProxy(TWebProxy).

Namespace: BI.Web.Net
Syntax
Delphi
public
 procedure SetProxy(const AProxy:TWebProxy); override;

Parameters

AProxy
Type: TWebProxy

Overrides

TBIHttp.SetProxy(TWebProxy)
See Also

Reference

  • TBIHttpClient
  • BI.Web.Net


TBIHttpClient.SetTimeout(Integer) Method

Summary

Represents method SetTimeout(Integer).

Namespace: BI.Web.Net
Syntax
Delphi
public
 procedure SetTimeout(const ATimeout:Integer); override;

Parameters

ATimeout
Type: Integer

Overrides

TBIHttp.SetTimeout(Integer)
See Also

Reference

  • TBIHttpClient
  • BI.Web.Net


BI.Workflow Namespace

Summary

Represents namespace BI.Workflow.

Classes
Name | Description
TBIQueryAccess | Represents type TBIQueryAccess.
TBIWorkflow | Represents type TBIWorkflow.
TCompareItem | Represents type TCompareItem.
TConvertItem | Represents type TConvertItem.
TDataAccess | Represents type TDataAccess.
TDataGridifyItem | Represents type TDataGridifyItem.
TDataProviderNeedsAccess | Represents type TDataProviderNeedsAccess.
TDataRankItem | Represents type TDataRankItem.
TDataShuffle | Represents type TDataShuffle.
TDataTranspose | Represents type TDataTranspose.
TDeleteItems | Represents type TDeleteItems.
TDuplicateItems | Represents type TDuplicateItems.
TFilterAction | Represents type TFilterAction.
TGroupByItem | Represents type TGroupByItem.
TItemAction | Represents type TItemAction.
TItemsAction | Represents type TItemsAction.
TMergeItem | Represents type TMergeItem.
TNewItem | Represents type TNewItem.
TNormalizeItem | Represents type TNormalizeItem.
TRenameItem | Represents type TRenameItem.
TReorderItem | Represents type TReorderItem.
TSortActionItem | Represents type TSortActionItem.
TSplitItem | Represents type TSplitItem.
TWorkflowItem | Represents type TWorkflowItem.
TWorkflowItems | Represents type TWorkflowItems.
Top
Enumerations
Name | Description
TMergeStyle | Represents type TMergeStyle.
Top
Delegates
Name | Description
TBIProviderChooser | Represents type TBIProviderChooser.
Top
Variables
Name | Description
BIFunctionChooser | Represents variable BIFunctionChooser.
Top
Constants
Name | Description
ItemClasses | Represents constant ItemClasses.
Top


BI.Workflow Classes

Classes
Name | Description
TBIQueryAccess | Represents type TBIQueryAccess.
TBIWorkflow | Represents type TBIWorkflow.
TCompareItem | Represents type TCompareItem.
TConvertItem | Represents type TConvertItem.
TDataAccess | Represents type TDataAccess.
TDataGridifyItem | Represents type TDataGridifyItem.
TDataProviderNeedsAccess | Represents type TDataProviderNeedsAccess.
TDataRankItem | Represents type TDataRankItem.
TDataShuffle | Represents type TDataShuffle.
TDataTranspose | Represents type TDataTranspose.
TDeleteItems | Represents type TDeleteItems.
TDuplicateItems | Represents type TDuplicateItems.
TFilterAction | Represents type TFilterAction.
TGroupByItem | Represents type TGroupByItem.
TItemAction | Represents type TItemAction.
TItemsAction | Represents type TItemsAction.
TMergeItem | Represents type TMergeItem.
TNewItem | Represents type TNewItem.
TNormalizeItem | Represents type TNormalizeItem.
TRenameItem | Represents type TRenameItem.
TReorderItem | Represents type TReorderItem.
TSortActionItem | Represents type TSortActionItem.
TSplitItem | Represents type TSplitItem.
TWorkflowItem | Represents type TWorkflowItem.
TWorkflowItems | Represents type TWorkflowItems.
Top


TBIQueryAccess Class

Summary

Represents type TBIQueryAccess.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Persist.TBaseDataImporter
BI.Query.TBIQuery
BI.Workflow.TBIQueryAccess
Syntax
Delphi
type
 TBIQueryAccess=class(TBIQuery);
See Also

Reference

  • BI.Workflow


TBIWorkflow Class

Summary

Represents type TBIWorkflow.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Persist.TBaseDataImporter
BI.Workflow.TBIWorkflow
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64 or pidOSX32
 or pidiOSSimulator or pidiOSDevice
 or pidAndroid
 or pidiOSDevice64
 )]
 TBIWorkflow=class(TBaseDataImporter)
 end;

The TBIWorkflow type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIWorkflow class.
Destroy | Represents the destructor of the TBIWorkflow class. (Overrides TBaseDataImporter.Destroy.)
Top
Properties
Show:
Name | Description
Items | Represents property Items.
Top
Methods
Show:
Name | Description
GetChildOwner | Represents method GetChildOwner.
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent).
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Loaded | Represents method Loaded.
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
Top
See Also

Reference

  • BI.Workflow


TBIWorkflow Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBIWorkflow class.
Destroy | Represents the destructor of the TBIWorkflow class. (Overrides TBaseDataImporter.Destroy.)
Top


TBIWorkflow.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIWorkflow class.

Namespace: BI.Workflow
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBIWorkflow
  • BI.Workflow


TBIWorkflow.Destroy Destructor

Summary

Represents the destructor of the TBIWorkflow class.

Namespace: BI.Workflow
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TBaseDataImporter.Destroy
See Also

Reference

  • TBIWorkflow
  • BI.Workflow


TBIWorkflow Properties

Properties
Name | Description
Items | Represents property Items.
Top


TBIWorkflow.Items Property

Summary

Represents property Items.

Namespace: BI.Workflow
Syntax
Delphi
published
 property Items:TWorkflowItems read FItems write SetItems;

Property Value

Type: TWorkflowItems

See Also

Reference

  • TBIWorkflow
  • BI.Workflow


TBIWorkflow Methods

Methods
Name | Description
GetChildOwner | Represents method GetChildOwner.
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent).
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Loaded | Represents method Loaded.
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
Top


TBIWorkflow.GetChildOwner Method

Summary

Represents method GetChildOwner.

Namespace: BI.Workflow
Syntax
Delphi
protected
 function GetChildOwner: TComponent; override;

Return Value

Type: TComponent

See Also

Reference

  • TBIWorkflow
  • BI.Workflow


TBIWorkflow.GetChildren(TGetChildProc,TComponent) Method

Summary

Represents method GetChildren(TGetChildProc,TComponent).

Namespace: BI.Workflow
Syntax
Delphi
protected
 Procedure GetChildren(Proc:TGetChildProc; Root:TComponent); override;

Parameters

Proc
Type: TGetChildProc

Root
Type: TComponent

See Also

Reference

  • TBIWorkflow
  • BI.Workflow


TBIWorkflow.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TBIWorkflow
  • BI.Workflow


TBIWorkflow.Loaded Method

Summary

Represents method Loaded.

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure Loaded; override;
See Also

Reference

  • TBIWorkflow
  • BI.Workflow


TBIWorkflow.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent;
 Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

See Also

Reference

  • TBIWorkflow
  • BI.Workflow


TCompareItem Class

Summary

Represents type TCompareItem.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Workflow.TCompareItem
Syntax
Delphi
type
 TCompareItem=class(TDataProviderNeeds)
 end;

The TCompareItem type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TCompareItem class.
Top
Properties
Show:
Name | Description
A | Represents property A.
B | Represents property B.
Top
Methods
Show:
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Top
See Also

Reference

  • BI.Workflow


TCompareItem Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TCompareItem class.
Top


TCompareItem.Create(TComponent) Constructor

Summary

Initializes a new instance of the TCompareItem class.

Namespace: BI.Workflow
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TCompareItem
  • BI.Workflow


TCompareItem Properties

Properties
Name | Description
A | Represents property A.
B | Represents property B.
Top


TCompareItem.A Property

Summary

Represents property A.

Namespace: BI.Workflow
Syntax
Delphi
public
 property A:TDataItem read GetA write SetA;

Property Value

Type: TDataItem

See Also

Reference

  • TCompareItem
  • BI.Workflow


TCompareItem.B Property

Summary

Represents property B.

Namespace: BI.Workflow
Syntax
Delphi
public
 property B:TDataItem read GetB write SetB;

Property Value

Type: TDataItem

See Also

Reference

  • TCompareItem
  • BI.Workflow


TCompareItem Methods

Methods
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Top


TCompareItem.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TCompareItem
  • BI.Workflow


TConvertItem Class

Summary

Represents type TConvertItem.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TSingleSourceProvider
BI.Algorithm.TCloneProvider
BI.Workflow.TConvertItem
Syntax
Delphi
type
 TConvertItem=class(TCloneProvider)
 end;

The TConvertItem type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TConvertItem class. (Overrides TSingleSourceProvider.Create(TComponent).)
Top
Properties
Show:
Name | Description
Kind | Represents property Kind.
Top
Methods
Show:
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top
See Also

Reference

  • BI.Workflow


TConvertItem Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TConvertItem class. (Overrides TSingleSourceProvider.Create(TComponent).)
Top


TConvertItem.Create(TComponent) Constructor

Summary

Initializes a new instance of the TConvertItem class.

Namespace: BI.Workflow
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TSingleSourceProvider.Create(TComponent)
See Also

Reference

  • TConvertItem
  • BI.Workflow


TConvertItem Properties

Properties
Name | Description
Kind | Represents property Kind.
Top


TConvertItem.Kind Property

Summary

Represents property Kind.

Namespace: BI.Workflow
Syntax
Delphi
published
 property Kind:TDataKind read FKind write SetKind default TDataKind.dkUnknown;

Property Value

Type: TDataKind

See Also

Reference

  • TConvertItem
  • BI.Workflow


TConvertItem Methods

Methods
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top


TConvertItem.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TCloneProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TConvertItem
  • BI.Workflow


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.Workflow
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.Workflow.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.Workflow


TDataGridifyItem Class

Summary

Represents type TDataGridifyItem.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TSingleSourceProvider
BI.Workflow.TDataGridifyItem
Syntax
Delphi
type
 TDataGridifyItem=class(TSingleSourceProvider)
 end;

The TDataGridifyItem type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TDataGridifyItem class. (Overrides TSingleSourceProvider.Create(TComponent).)
Top
Properties
Show:
Name | Description
Columns | Represents property Columns.
Rows | Represents property Rows.
Value | Represents property Value.
Top
Methods
Show:
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Top
See Also

Reference

  • BI.Workflow


TDataGridifyItem Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TDataGridifyItem class. (Overrides TSingleSourceProvider.Create(TComponent).)
Top


TDataGridifyItem.Create(TComponent) Constructor

Summary

Initializes a new instance of the TDataGridifyItem class.

Namespace: BI.Workflow
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TSingleSourceProvider.Create(TComponent)
See Also

Reference

  • TDataGridifyItem
  • BI.Workflow


TDataGridifyItem Properties

Properties
Name | Description
Columns | Represents property Columns.
Rows | Represents property Rows.
Value | Represents property Value.
Top


TDataGridifyItem.Columns Property

Summary

Represents property Columns.

Namespace: BI.Workflow
Syntax
Delphi
public
 property Columns:TDataArray read GetColumns write SetColumns;

Property Value

Type: TDataArray

See Also

Reference

  • TDataGridifyItem
  • BI.Workflow


TDataGridifyItem.Rows Property

Summary

Represents property Rows.

Namespace: BI.Workflow
Syntax
Delphi
public
 property Rows:TDataArray read GetRows write SetRows;

Property Value

Type: TDataArray

See Also

Reference

  • TDataGridifyItem
  • BI.Workflow


TDataGridifyItem.Value Property

Summary

Represents property Value.

Namespace: BI.Workflow
Syntax
Delphi
public
 property Value:TDataItem read GetValue write SetValue;

Property Value

Type: TDataItem

See Also

Reference

  • TDataGridifyItem
  • BI.Workflow


TDataGridifyItem Methods

Methods
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Top


TDataGridifyItem.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TDataGridifyItem
  • BI.Workflow


TDataProviderNeedsAccess Class

Summary

Represents type TDataProviderNeedsAccess.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Workflow.TDataProviderNeedsAccess
Syntax
Delphi
type
 TDataProviderNeedsAccess=class(TDataProviderNeeds);
See Also

Reference

  • BI.Workflow


TDataRankItem Class

Summary

Represents type TDataRankItem.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TSingleSourceProvider
BI.Algorithm.TCloneProvider
BI.Workflow.TDataRankItem
Syntax
Delphi
type
 TDataRankItem=class(TCloneProvider)
 end;

The TDataRankItem type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TDataRankItem class. (Overrides TSingleSourceProvider.Create(TComponent).)
Top
Properties
Show:
Name | Description
Ascending | Represents property Ascending.
Groups | Represents property Groups.
Value | Represents property Value.
Top
Methods
Show:
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top
See Also

Reference

  • BI.Workflow


TDataRankItem Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TDataRankItem class. (Overrides TSingleSourceProvider.Create(TComponent).)
Top


TDataRankItem.Create(TComponent) Constructor

Summary

Initializes a new instance of the TDataRankItem class.

Namespace: BI.Workflow
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TSingleSourceProvider.Create(TComponent)
See Also

Reference

  • TDataRankItem
  • BI.Workflow


TDataRankItem Properties

Properties
Name | Description
Ascending | Represents property Ascending.
Groups | Represents property Groups.
Value | Represents property Value.
Top


TDataRankItem.Ascending Property

Summary

Represents property Ascending.

Namespace: BI.Workflow
Syntax
Delphi
published
 property Ascending:Boolean read FAscending write SetAscending;

Property Value

Type: Boolean

See Also

Reference

  • TDataRankItem
  • BI.Workflow


TDataRankItem.Groups Property

Summary

Represents property Groups.

Namespace: BI.Workflow
Syntax
Delphi
public
 property Groups:TDataArray read GetGroups write SetGroups;

Property Value

Type: TDataArray

See Also

Reference

  • TDataRankItem
  • BI.Workflow


TDataRankItem.Value Property

Summary

Represents property Value.

Namespace: BI.Workflow
Syntax
Delphi
public
 property Value:TDataItem read GetValue write SetValue;

Property Value

Type: TDataItem

See Also

Reference

  • TDataRankItem
  • BI.Workflow


TDataRankItem Methods

Methods
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top


TDataRankItem.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TCloneProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TDataRankItem
  • BI.Workflow


TDataShuffle Class

Summary

Represents type TDataShuffle.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TSingleSourceProvider
BI.Algorithm.TCloneProvider
BI.Workflow.TDataShuffle
Syntax
Delphi
type
 TDataShuffle=class(TCloneProvider)
 end;

The TDataShuffle type exposes the following members.

Methods
Show:
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top
See Also

Reference

  • BI.Workflow


TDataShuffle Methods

Methods
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top


TDataShuffle.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TCloneProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TDataShuffle
  • BI.Workflow


TDataTranspose Class

Summary

Represents type TDataTranspose.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TSingleSourceProvider
BI.Workflow.TDataTranspose
Syntax
Delphi
type
 TDataTranspose=class(TSingleSourceProvider)
 end;

The TDataTranspose type exposes the following members.

Methods
Show:
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Top
See Also

Reference

  • BI.Workflow


TDataTranspose Methods

Methods
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Top


TDataTranspose.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TDataTranspose
  • BI.Workflow


TDeleteItems Class

Summary

Represents type TDeleteItems.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TSingleSourceProvider
BI.Algorithm.TCloneProvider
BI.Workflow.TItemsAction
BI.Workflow.TDeleteItems
Syntax
Delphi
type
 TDeleteItems=class(TItemsAction)
 end;

The TDeleteItems type exposes the following members.

Methods
Show:
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top
See Also

Reference

  • BI.Workflow


TDeleteItems Methods

Methods
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top


TDeleteItems.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TCloneProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TDeleteItems
  • BI.Workflow


TDuplicateItems Class

Summary

Represents type TDuplicateItems.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TSingleSourceProvider
BI.Algorithm.TCloneProvider
BI.Workflow.TItemsAction
BI.Workflow.TDuplicateItems
Syntax
Delphi
type
 TDuplicateItems=class(TItemsAction)
 end;

The TDuplicateItems type exposes the following members.

Methods
Show:
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top
See Also

Reference

  • BI.Workflow


TDuplicateItems Methods

Methods
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top


TDuplicateItems.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TCloneProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TDuplicateItems
  • BI.Workflow


TFilterAction Class

Summary

Represents type TFilterAction.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TSingleSourceProvider
BI.Workflow.TFilterAction
Syntax
Delphi
type
 TFilterAction=class(TSingleSourceProvider)
 end;

The TFilterAction type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TFilterAction class. (Overrides TSingleSourceProvider.Create(TComponent).)
Destroy | Represents the destructor of the TFilterAction class. (Overrides TSingleSourceProvider.Destroy.)
Top
Properties
Show:
Name | Description
Filter | Represents property Filter.
Top
Methods
Show:
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Top
See Also

Reference

  • BI.Workflow


TFilterAction Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TFilterAction class. (Overrides TSingleSourceProvider.Create(TComponent).)
Destroy | Represents the destructor of the TFilterAction class. (Overrides TSingleSourceProvider.Destroy.)
Top


TFilterAction.Create(TComponent) Constructor

Summary

Initializes a new instance of the TFilterAction class.

Namespace: BI.Workflow
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TSingleSourceProvider.Create(TComponent)
See Also

Reference

  • TFilterAction
  • BI.Workflow


TFilterAction.Destroy Destructor

Summary

Represents the destructor of the TFilterAction class.

Namespace: BI.Workflow
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TSingleSourceProvider.Destroy
See Also

Reference

  • TFilterAction
  • BI.Workflow


TFilterAction Properties

Properties
Name | Description
Filter | Represents property Filter.
Top


TFilterAction.Filter Property

Summary

Represents property Filter.

Namespace: BI.Workflow
Syntax
Delphi
public
 property Filter:TBIFilter read GetFilter write SetFilter;

Property Value

Type: TBIFilter

See Also

Reference

  • TFilterAction
  • BI.Workflow


TFilterAction Methods

Methods
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Top


TFilterAction.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TFilterAction
  • BI.Workflow


TGroupByItem Class

Summary

Represents type TGroupByItem.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TSingleSourceProvider
BI.Workflow.TGroupByItem
Syntax
Delphi
type
 TGroupByItem=class(TSingleSourceProvider)
 end;

The TGroupByItem type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TGroupByItem class. (Overrides TSingleSourceProvider.Create(TComponent).)
Top
Properties
Show:
Name | Description
Groups | Represents property Groups.
Top
Methods
Show:
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Top
See Also

Reference

  • BI.Workflow


TGroupByItem Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TGroupByItem class. (Overrides TSingleSourceProvider.Create(TComponent).)
Top


TGroupByItem.Create(TComponent) Constructor

Summary

Initializes a new instance of the TGroupByItem class.

Namespace: BI.Workflow
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TSingleSourceProvider.Create(TComponent)
See Also

Reference

  • TGroupByItem
  • BI.Workflow


TGroupByItem Properties

Properties
Name | Description
Groups | Represents property Groups.
Top


TGroupByItem.Groups Property

Summary

Represents property Groups.

Namespace: BI.Workflow
Syntax
Delphi
public
 property Groups:TDataArray read GetGroups write SetGroups;

Property Value

Type: TDataArray

See Also

Reference

  • TGroupByItem
  • BI.Workflow


TGroupByItem Methods

Methods
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Top


TGroupByItem.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TGroupByItem
  • BI.Workflow


TItemAction Class

Summary

Represents type TItemAction.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TSingleSourceProvider
BI.Algorithm.TCloneProvider
BI.Workflow.TItemAction
BI.Workflow.TNewItem
BI.Workflow.TRenameItem
Syntax
Delphi
type
 TItemAction=class(TCloneProvider)
 end;

The TItemAction type exposes the following members.

Properties
Show:
Name | Description
ItemName | Represents property ItemName.
Top
See Also

Reference

  • BI.Workflow


TItemAction Properties

Properties
Name | Description
ItemName | Represents property ItemName.
Top


TItemAction.ItemName Property

Summary

Represents property ItemName.

Namespace: BI.Workflow
Syntax
Delphi
published
 property ItemName:String read FItemName write SetItemName;

Property Value

Type: String

See Also

Reference

  • TItemAction
  • BI.Workflow


TItemsAction Class

Summary

Represents type TItemsAction.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TSingleSourceProvider
BI.Algorithm.TCloneProvider
BI.Workflow.TItemsAction
BI.Workflow.TDeleteItems
BI.Workflow.TDuplicateItems
Syntax
Delphi
type
 TItemsAction=class(TCloneProvider)
 end;

The TItemsAction type exposes the following members.

Properties
Show:
Name | Description
Items | Represents property Items.
Top
See Also

Reference

  • BI.Workflow


TItemsAction Properties

Properties
Name | Description
Items | Represents property Items.
Top


TItemsAction.Items Property

Summary

Represents property Items.

Namespace: BI.Workflow
Syntax
Delphi
published
 property Items:TStringArray read FItems write SetItems;

Property Value

Type: TStringArray

See Also

Reference

  • TItemsAction
  • BI.Workflow


TMergeItem Class

Summary

Represents type TMergeItem.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TSingleSourceProvider
BI.Algorithm.TCloneProvider
BI.Workflow.TMergeItem
Syntax
Delphi
type
 TMergeItem=class(TCloneProvider)
 end;

The TMergeItem type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TMergeItem class. (Overrides TSingleSourceProvider.Create(TComponent).)
Top
Properties
Show:
Name | Description
Items | Represents property Items.
Style | Represents property Style.
Top
Methods
Show:
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top
See Also

Reference

  • BI.Workflow


TMergeItem Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TMergeItem class. (Overrides TSingleSourceProvider.Create(TComponent).)
Top


TMergeItem.Create(TComponent) Constructor

Summary

Initializes a new instance of the TMergeItem class.

Namespace: BI.Workflow
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TSingleSourceProvider.Create(TComponent)
See Also

Reference

  • TMergeItem
  • BI.Workflow


TMergeItem Properties

Properties
Name | Description
Items | Represents property Items.
Style | Represents property Style.
Top


TMergeItem.Items Property

Summary

Represents property Items.

Namespace: BI.Workflow
Syntax
Delphi
published
 property Items:TDataArray read FItems write FItems;

Property Value

Type: TDataArray

See Also

Reference

  • TMergeItem
  • BI.Workflow


TMergeItem.Style Property

Summary

Represents property Style.

Namespace: BI.Workflow
Syntax
Delphi
published
 property Style:TMergeStyle read FStyle write FStyle default TMergeStyle.Join;

Property Value

Type: TMergeStyle

See Also

Reference

  • TMergeItem
  • BI.Workflow


TMergeItem Methods

Methods
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top


TMergeItem.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TCloneProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TMergeItem
  • BI.Workflow


TNewItem Class

Summary

Represents type TNewItem.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TSingleSourceProvider
BI.Algorithm.TCloneProvider
BI.Workflow.TItemAction
BI.Workflow.TNewItem
Syntax
Delphi
type
 TNewItem=class(TItemAction)
 end;

The TNewItem type exposes the following members.

Properties
Show:
Name | Description
Kind | Represents property Kind.
Top
Methods
Show:
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top
See Also

Reference

  • BI.Workflow


TNewItem Properties

Properties
Name | Description
Kind | Represents property Kind.
Top


TNewItem.Kind Property

Summary

Represents property Kind.

Namespace: BI.Workflow
Syntax
Delphi
published
 property Kind:TDataKind read FKind write SetKind;

Property Value

Type: TDataKind

See Also

Reference

  • TNewItem
  • BI.Workflow


TNewItem Methods

Methods
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top


TNewItem.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TCloneProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TNewItem
  • BI.Workflow


TNormalizeItem Class

Summary

Represents type TNormalizeItem.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TSingleSourceProvider
BI.Algorithm.TCloneProvider
BI.Workflow.TNormalizeItem
Syntax
Delphi
type
 TNormalizeItem=class(TCloneProvider)
 end;

The TNormalizeItem type exposes the following members.

Methods
Show:
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top
See Also

Reference

  • BI.Workflow


TNormalizeItem Methods

Methods
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top


TNormalizeItem.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TCloneProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TNormalizeItem
  • BI.Workflow


TRenameItem Class

Summary

Represents type TRenameItem.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TSingleSourceProvider
BI.Algorithm.TCloneProvider
BI.Workflow.TItemAction
BI.Workflow.TRenameItem
Syntax
Delphi
type
 TRenameItem=class(TItemAction)
 end;

The TRenameItem type exposes the following members.

Properties
Show:
Name | Description
NewName | Represents property NewName.
Top
Methods
Show:
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top
See Also

Reference

  • BI.Workflow


TRenameItem Properties

Properties
Name | Description
NewName | Represents property NewName.
Top


TRenameItem.NewName Property

Summary

Represents property NewName.

Namespace: BI.Workflow
Syntax
Delphi
public
 property NewName:String read FNewName write SetNewName;

Property Value

Type: String

See Also

Reference

  • TRenameItem
  • BI.Workflow


TRenameItem Methods

Methods
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top


TRenameItem.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TCloneProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TRenameItem
  • BI.Workflow


TReorderItem Class

Summary

Represents type TReorderItem.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TSingleSourceProvider
BI.Algorithm.TCloneProvider
BI.Workflow.TReorderItem
Syntax
Delphi
type
 TReorderItem=class(TCloneProvider)
 end;

The TReorderItem type exposes the following members.

Methods
Show:
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top
Fields
Show:
Name | Description
Items | Represents field Items.
Top
See Also

Reference

  • BI.Workflow


TReorderItem Methods

Methods
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top


TReorderItem.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TCloneProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TReorderItem
  • BI.Workflow


TReorderItem Fields

Fields
Name | Description
Items | Represents field Items.
Top


TReorderItem.Items Field

Summary

Represents field Items.

Namespace: BI.Workflow
Syntax
Delphi
public
 Items : TDataArray;

Field Value

Type: TDataArray

See Also

Reference

  • TReorderItem
  • BI.Workflow


TSortActionItem Class

Summary

Represents type TSortActionItem.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TSingleSourceProvider
BI.Algorithm.TCloneProvider
BI.Workflow.TSortActionItem
Syntax
Delphi
type
 TSortActionItem=class(TCloneProvider)
 end;

The TSortActionItem type exposes the following members.

Properties
Show:
Name | Description
SortItems | Represents property SortItems.
Top
Methods
Show:
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top
See Also

Reference

  • BI.Workflow


TSortActionItem Properties

Properties
Name | Description
SortItems | Represents property SortItems.
Top


TSortActionItem.SortItems Property

Summary

Represents property SortItems.

Namespace: BI.Workflow
Syntax
Delphi
public
 property SortItems:TSortItems read FItems write SetItems;

Property Value

Type: TSortItems

See Also

Reference

  • TSortActionItem
  • BI.Workflow


TSortActionItem Methods

Methods
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TCloneProvider.Load(TDataItem,Boolean).)
Top


TSortActionItem.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TCloneProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TSortActionItem
  • BI.Workflow


TSplitItem Class

Summary

Represents type TSplitItem.

Namespace: BI.Workflow
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
BI.Algorithm.TSingleSourceProvider
BI.Workflow.TSplitItem
Syntax
Delphi
type
 TSplitItem=class(TSingleSourceProvider)
 end;

The TSplitItem type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TSplitItem class. (Overrides TSingleSourceProvider.Create(TComponent).)
Top
Properties
Show:
Name | Description
By | Represents property By.
Count | Represents property Count.
Mode | Represents property Mode.
Percent | Represents property Percent.
Top
Methods
Show:
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Top
See Also

Reference

  • BI.Workflow


TSplitItem Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TSplitItem class. (Overrides TSingleSourceProvider.Create(TComponent).)
Top


TSplitItem.Create(TComponent) Constructor

Summary

Initializes a new instance of the TSplitItem class.

Namespace: BI.Workflow
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TSingleSourceProvider.Create(TComponent)
See Also

Reference

  • TSplitItem
  • BI.Workflow


TSplitItem Properties

Properties
Name | Description
By | Represents property By.
Count | Represents property Count.
Mode | Represents property Mode.
Percent | Represents property Percent.
Top


TSplitItem.By Property

Summary

Represents property By.

Namespace: BI.Workflow
Syntax
Delphi
published
 property By:TSplitBy read FBy write SetBy default TSplitBy.Percent;

Property Value

Type: TSplitBy

See Also

Reference

  • TSplitItem
  • BI.Workflow


TSplitItem.Count Property

Summary

Represents property Count.

Namespace: BI.Workflow
Syntax
Delphi
published
 property Count:Integer read FCount write SetCount default 0;

Property Value

Type: Integer

See Also

Reference

  • TSplitItem
  • BI.Workflow


TSplitItem.Mode Property

Summary

Represents property Mode.

Namespace: BI.Workflow
Syntax
Delphi
published
 property Mode:TSplitMode read FMode write SetMode default TSplitMode.Start;

Property Value

Type: TSplitMode

See Also

Reference

  • TSplitItem
  • BI.Workflow


TSplitItem.Percent Property

Summary

Represents property Percent.

Namespace: BI.Workflow
Syntax
Delphi
published
 property Percent:Single read FPercent write SetPercent;

Property Value

Type: Single

See Also

Reference

  • TSplitItem
  • BI.Workflow


TSplitItem Methods

Methods
Name | Description
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Top


TSplitItem.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TSplitItem
  • BI.Workflow


TWorkflowItem Class

Summary

Represents type TWorkflowItem.

Namespace: BI.Workflow
Inheritance Hierarchy
TCollectionItem
BI.CollectionItem.TDataCollectionItem
BI.Workflow.TWorkflowItem
VCLBI.Editor.Workflow.TWorkflowItemAccess
Syntax
Delphi
type
 TWorkflowItem=class(TDataCollectionItem)
 end;

The TWorkflowItem type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TWorkflowItem class.
Destroy | Represents the destructor of the TWorkflowItem class. (Overrides TDataCollectionItem.Destroy.)
Top
Properties
Show:
Name | Description
Items | Represents property Items.
ParentItem | Represents property ParentItem.
Top
Methods
Show:
Name | Description
DefineProperties(TFiler) | Represents method DefineProperties(TFiler). (Overrides TDataCollectionItem.DefineProperties(TFiler).)
OriginsStored | Represents method OriginsStored.
Owner | Represents method Owner. (Overrides TDataCollectionItem.Owner.)
ParentData | Represents method ParentData.
SetData(TDataItem) | Represents method SetData(TDataItem). (Overrides TDataCollectionItem.SetData(TDataItem).)
SetProvider(TComponent) | Represents method SetProvider(TComponent). (Overrides TDataCollectionItem.SetProvider(TComponent).)
Top
See Also

Reference

  • BI.Workflow


TWorkflowItem Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TWorkflowItem class.
Destroy | Represents the destructor of the TWorkflowItem class. (Overrides TDataCollectionItem.Destroy.)
Top


TWorkflowItem.Create(TCollection) Constructor

Summary

Initializes a new instance of the TWorkflowItem class.

Namespace: BI.Workflow
Syntax
Delphi
public
 Constructor Create(Collection: TCollection); override;

Parameters

Collection
Type: TCollection

See Also

Reference

  • TWorkflowItem
  • BI.Workflow


TWorkflowItem.Destroy Destructor

Summary

Represents the destructor of the TWorkflowItem class.

Namespace: BI.Workflow
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TDataCollectionItem.Destroy
See Also

Reference

  • TWorkflowItem
  • BI.Workflow


TWorkflowItem Properties

Properties
Name | Description
Items | Represents property Items.
ParentItem | Represents property ParentItem.
Top


TWorkflowItem.Items Property

Summary

Represents property Items.

Namespace: BI.Workflow
Syntax
Delphi
published
 property Items:TWorkflowItems read FItems write SetItems stored IsItemsStored;

Property Value

Type: TWorkflowItems

See Also

Reference

  • TWorkflowItem
  • BI.Workflow


TWorkflowItem.ParentItem Property

Summary

Represents property ParentItem.

Namespace: BI.Workflow
Syntax
Delphi
published
 property ParentItem:String read FParentItem write FParentItem;

Property Value

Type: String

See Also

Reference

  • TWorkflowItem
  • BI.Workflow


TWorkflowItem Methods

Methods
Name | Description
DefineProperties(TFiler) | Represents method DefineProperties(TFiler). (Overrides TDataCollectionItem.DefineProperties(TFiler).)
OriginsStored | Represents method OriginsStored.
Owner | Represents method Owner. (Overrides TDataCollectionItem.Owner.)
ParentData | Represents method ParentData.
SetData(TDataItem) | Represents method SetData(TDataItem). (Overrides TDataCollectionItem.SetData(TDataItem).)
SetProvider(TComponent) | Represents method SetProvider(TComponent). (Overrides TDataCollectionItem.SetProvider(TComponent).)
Top


TWorkflowItem.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

Overrides

TDataCollectionItem.DefineProperties(TFiler)
See Also

Reference

  • TWorkflowItem
  • BI.Workflow


TWorkflowItem.OriginsStored Method

Summary

Represents method OriginsStored.

Namespace: BI.Workflow
Syntax
Delphi
protected
 function OriginsStored:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TWorkflowItem
  • BI.Workflow


TWorkflowItem.Owner Method

Summary

Represents method Owner.

Namespace: BI.Workflow
Syntax
Delphi
protected
 function Owner:TComponent; override;

Return Value

Type: TComponent

Overrides

TDataCollectionItem.Owner
See Also

Reference

  • TWorkflowItem
  • BI.Workflow


TWorkflowItem.ParentData Method

Summary

Represents method ParentData.

Namespace: BI.Workflow
Syntax
Delphi
public
 function ParentData:TDataItem;

Return Value

Type: TDataItem

See Also

Reference

  • TWorkflowItem
  • BI.Workflow


TWorkflowItem.SetData(TDataItem) Method

Summary

Represents method SetData(TDataItem).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure SetData(const Value: TDataItem); override;

Parameters

Value
Type: TDataItem

Overrides

TDataCollectionItem.SetData(TDataItem)
See Also

Reference

  • TWorkflowItem
  • BI.Workflow


TWorkflowItem.SetProvider(TComponent) Method

Summary

Represents method SetProvider(TComponent).

Namespace: BI.Workflow
Syntax
Delphi
protected
 procedure SetProvider(const Value: TComponent); override;

Parameters

Value
Type: TComponent

Overrides

TDataCollectionItem.SetProvider(TComponent)
See Also

Reference

  • TWorkflowItem
  • BI.Workflow


TWorkflowItems Class

Summary

Represents type TWorkflowItems.

Namespace: BI.Workflow
Inheritance Hierarchy
TOwnedCollection
BI.Workflow.TWorkflowItems
Syntax
Delphi
type
 TWorkflowItems=class(TOwnedCollection)
 end;

The TWorkflowItems type exposes the following members.

Constructors
Show:
Name | Description
Create(TPersistent) | Initializes a new instance of the TWorkflowItems class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Add | Overloaded. Represents method Add.
Add(TDataArray,TDataProvider,String) | Overloaded. Represents method Add(TDataArray,TDataProvider,String).
Add(TDataItem,TDataProvider,String) | Overloaded. Represents method Add(TDataItem,TDataProvider,String).
Add(TDataProvider,String) | Overloaded. Represents method Add(TDataProvider,String).
Top
See Also

Reference

  • BI.Workflow


TWorkflowItems Constructors

Constructors
Name | Description
Create(TPersistent) | Initializes a new instance of the TWorkflowItems class.
Top


TWorkflowItems.Create(TPersistent) Constructor

Summary

Initializes a new instance of the TWorkflowItems class.

Namespace: BI.Workflow
Syntax
Delphi
public
 Constructor Create(AOwner: TPersistent);

Parameters

AOwner
Type: TPersistent

See Also

Reference

  • TWorkflowItems
  • BI.Workflow


TWorkflowItems Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TWorkflowItems.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: BI.Workflow
Syntax
Delphi
public
 property Items[const Index:Integer]:TWorkflowItem read Get write Put; default;

Parameters

Index
Type: Integer

Property Value

Type: TWorkflowItem

See Also

Reference

  • TWorkflowItems
  • BI.Workflow


TWorkflowItems Methods

Methods
Name | Description
Add | Overloaded. Represents method Add.
Add(TDataArray,TDataProvider,String) | Overloaded. Represents method Add(TDataArray,TDataProvider,String).
Add(TDataItem,TDataProvider,String) | Overloaded. Represents method Add(TDataItem,TDataProvider,String).
Add(TDataProvider,String) | Overloaded. Represents method Add(TDataProvider,String).
Top


TWorkflowItems.Add Method

Summary

Represents method Add.

Namespace: BI.Workflow
Syntax
Delphi
public
 function Add: TWorkflowItem; overload;

Return Value

Type: TWorkflowItem

See Also

Reference

  • TWorkflowItems
  • BI.Workflow


TWorkflowItems.Add(TDataArray,TDataProvider,String) Method

Summary

Represents method Add(TDataArray,TDataProvider,String).

Namespace: BI.Workflow
Syntax
Delphi
public
 function Add(const ASources:TDataArray;
 const AProvider:TDataProvider;
 const AName:String):TWorkflowItem; overload;

Parameters

ASources
Type: TDataArray

AProvider
Type: TDataProvider

AName
Type: String

Return Value

Type: TWorkflowItem

See Also

Reference

  • TWorkflowItems
  • BI.Workflow


TWorkflowItems.Add(TDataItem,TDataProvider,String) Method

Summary

Represents method Add(TDataItem,TDataProvider,String).

Namespace: BI.Workflow
Syntax
Delphi
public
 function Add(const ASource:TDataItem;
 const AProvider:TDataProvider;
 const AName:String):TWorkflowItem; overload;

Parameters

ASource
Type: TDataItem

AProvider
Type: TDataProvider

AName
Type: String

Return Value

Type: TWorkflowItem

See Also

Reference

  • TWorkflowItems
  • BI.Workflow


TWorkflowItems.Add(TDataProvider,String) Method

Summary

Represents method Add(TDataProvider,String).

Namespace: BI.Workflow
Syntax
Delphi
public
 function Add(const AProvider:TDataProvider;
 const AName:String):TWorkflowItem; overload;

Parameters

AProvider
Type: TDataProvider

AName
Type: String

Return Value

Type: TWorkflowItem

See Also

Reference

  • TWorkflowItems
  • BI.Workflow


BI.Workflow Enumerations

Enumerations
Name | Description
TMergeStyle | Represents type TMergeStyle.
Top


TMergeStyle Enumeration

Summary

Represents type TMergeStyle.

Namespace: BI.Workflow
Syntax
Delphi
type
 TMergeStyle=(Join,Subtract,Common,Different);

The TMergeStyle type exposes the following members.

Members
Show:
Name | Description
Common | Represents constant Common.
Different | Represents constant Different.
Join | Represents constant Join.
Subtract | Represents constant Subtract.
Top
See Also

Reference

  • BI.Workflow


BI.Workflow Delegates

Delegates
Name | Description
TBIProviderChooser | Represents type TBIProviderChooser.
Top


TBIProviderChooser Delegate

Summary

Represents type TBIProviderChooser.

Namespace: BI.Workflow
Syntax
Delphi
type
 TBIProviderChooser=function(const AOwner:TComponent):TDataProvider;
See Also

Reference

  • BI.Workflow


BI.Workflow Variables

Variables
Name | Description
BIFunctionChooser | Represents variable BIFunctionChooser.
Top


BIFunctionChooser Variable

Summary

Represents variable BIFunctionChooser.

Namespace: BI.Workflow
Syntax
Delphi
BIFunctionChooser:TBIProviderChooser=nil;

Value

Type: TBIProviderChooser

See Also

Reference

  • BI.Workflow


BI.Workflow Constants

Constants
Name | Description
ItemClasses | Represents constant ItemClasses.
Top


ItemClasses Constant

Summary

Represents constant ItemClasses.

Namespace: BI.Workflow
Syntax
Delphi
 ItemClasses:Array[0..18] of TPersistentClass=
 (
 TNewItem,TDeleteItems,TDuplicateItems,TRenameItem,TDataTranspose,
 TBIQuery,TDataShuffle,TSplitItem,TNormalizeItem,
 TDataDefinition,TDataRankItem,TDataGridifyItem,
 TMergeItem,TCloneProvider,TCompareItem,TGroupByItem,
 TSingleRecord, TSortActionItem, TFilterAction
 );

Value

Type: Array[0..18] of TPersistentClass

See Also

Reference

  • BI.Workflow


BI.XMLData Namespace

Summary

Represents namespace BI.XMLData.

Classes
Name | Description
EBIXML | Represents type EBIXML.
TBIXML | Represents type TBIXML.
TBIXMLExport | Represents type TBIXMLExport.
TDataAccess | Represents type TDataAccess.
TXmlEngine | Represents type TXmlEngine.
Top
Enumerations
Name | Description
TBIXMLEmit | Represents type TBIXMLEmit.
Top
Types
Name | Description
TXmlEngineClass | Represents type TXmlEngineClass.
Top
Routines
Name | Description
ToBoolean(Boolean) | Represents method ToBoolean(Boolean).
XMLTag(String) | Represents method XMLTag(String).
Top


BI.XMLData Classes

Classes
Name | Description
EBIXML | Represents type EBIXML.
TBIXML | Represents type TBIXML.
TBIXMLExport | Represents type TBIXMLExport.
TDataAccess | Represents type TDataAccess.
TXmlEngine | Represents type TXmlEngine.
Top


EBIXML Class

Summary

Represents type EBIXML.

Namespace: BI.XMLData
Inheritance Hierarchy
Exception
BI.Arrays.EBIException
BI.XMLData.EBIXML
Syntax
Delphi
type
 EBIXML=class(EBIException);
See Also

Reference

  • BI.XMLData


TBIXML Class

Summary

Represents type TBIXML.

Namespace: BI.XMLData
Inheritance Hierarchy
TObject
BI.DataSource.TBISource
BI.DataSource.TBIItemsSource
BI.DataSource.TBIFileSource
BI.DataSource.TBITextSource
BI.DataSource.TBIHierarchicalSource
BI.XMLData.TBIXML
BI.Html.TBIXMLAccess
Syntax
Delphi
type
 TBIXML=class(TBIHierarchicalSource)
 end;

The TBIXML type exposes the following members.

Constructors
Show:
Name | Description
CreateEngine(TXmlEngine) | Initializes a new instance of the TBIXML class.
Destroy | Represents the destructor of the TBIXML class.
Top
Properties
Show:
Name | Description
ExcludeNodes | Represents property ExcludeNodes.
Top
Methods
Show:
Name | Description
FileFilter | Represents method FileFilter. (Overrides TBIFileSource.FileFilter.)
Import(String,Boolean) | Overloaded. Represents method Import(String,Boolean).
Import(TStrings) | Overloaded. Represents method Import(TStrings). (Overrides TBIFileSource.Import(TStrings).)
ImportText(String) | Represents method ImportText(String).
Parse(String) | Represents method Parse(String).
Supports(String) | Represents method Supports(String). (Overrides TBIFileSource.Supports(String).)
Top
Fields
Show:
Name | Description
EngineClass | Represents field EngineClass.
XML | Represents field XML.
Top
See Also

Reference

  • BI.XMLData


TBIXML Constructors

Constructors
Name | Description
CreateEngine(TXmlEngine) | Initializes a new instance of the TBIXML class.
Destroy | Represents the destructor of the TBIXML class.
Top


TBIXML.CreateEngine(TXmlEngine) Constructor

Summary

Initializes a new instance of the TBIXML class.

Namespace: BI.XMLData
Syntax
Delphi
public
 Constructor CreateEngine(const AEngine:TXmlEngine);

Parameters

AEngine
Type: TXmlEngine

See Also

Reference

  • TBIXML
  • BI.XMLData


TBIXML.Destroy Destructor

Summary

Represents the destructor of the TBIXML class.

Namespace: BI.XMLData
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIXML
  • BI.XMLData


TBIXML Properties

Properties
Name | Description
ExcludeNodes | Represents property ExcludeNodes.
Top


TBIXML.ExcludeNodes Property

Summary

Represents property ExcludeNodes.

Namespace: BI.XMLData
Syntax
Delphi
public
 property ExcludeNodes:TTextArray read FExclude;

Property Value

Type: TTextArray

See Also

Reference

  • TBIXML
  • BI.XMLData


TBIXML Methods

Methods
Name | Description
FileFilter | Represents method FileFilter. (Overrides TBIFileSource.FileFilter.)
Import(String,Boolean) | Overloaded. Represents method Import(String,Boolean).
Import(TStrings) | Overloaded. Represents method Import(TStrings). (Overrides TBIFileSource.Import(TStrings).)
ImportText(String) | Represents method ImportText(String).
Parse(String) | Represents method Parse(String).
Supports(String) | Represents method Supports(String). (Overrides TBIFileSource.Supports(String).)
Top


TBIXML.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.XMLData
Syntax
Delphi
public
 class function FileFilter: TFileFilters; override;

Return Value

Type: TFileFilters

Overrides

TBIFileSource.FileFilter
See Also

Reference

  • TBIXML
  • BI.XMLData


TBIXML.Import(String,Boolean) Method

Summary

Represents method Import(String,Boolean).

Namespace: BI.XMLData
Syntax
Delphi
public
 function Import(const Folder:String; Recursive:Boolean=False):TDataArray; overload;

Parameters

Folder
Type: String

Recursive
Type: Boolean

Return Value

Type: TDataArray

See Also

Reference

  • TBIXML
  • BI.XMLData


TBIXML.Import(TStrings) Method

Summary

Represents method Import(TStrings).

Namespace: BI.XMLData
Syntax
Delphi
public
 function Import(const Strings:TStrings):TDataArray; overload; override;

Parameters

Strings
Type: TStrings

Return Value

Type: TDataArray

Overrides

TBIFileSource.Import(TStrings)
See Also

Reference

  • TBIXML
  • BI.XMLData


TBIXML.ImportText(String) Method

Summary

Represents method ImportText(String).

Namespace: BI.XMLData
Syntax
Delphi
public
 function ImportText(const Text:String): TDataItem;

Parameters

Text
Type: String

Return Value

Type: TDataItem

See Also

Reference

  • TBIXML
  • BI.XMLData


TBIXML.Parse(String) Method

Summary

Represents method Parse(String).

Namespace: BI.XMLData
Syntax
Delphi
public
 function Parse(const Text:String): Boolean;

Parameters

Text
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TBIXML
  • BI.XMLData


TBIXML.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.XMLData
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIFileSource.Supports(String)
See Also

Reference

  • TBIXML
  • BI.XMLData


TBIXML Fields

Fields
Name | Description
EngineClass | Represents field EngineClass.
XML | Represents field XML.
Top


TBIXML.EngineClass Field

Summary

Represents field EngineClass.

Namespace: BI.XMLData
Syntax
Delphi
public
 class var
 EngineClass : TXmlEngineClass;

Field Value

Type: TXmlEngineClass

See Also

Reference

  • TBIXML
  • BI.XMLData


TBIXML.XML Field

Summary

Represents field XML.

Namespace: BI.XMLData
Syntax
Delphi
protected
 XML : TXmlEngine;

Field Value

Type: TXmlEngine

See Also

Reference

  • TBIXML
  • BI.XMLData


TBIXMLExport Class

Summary

Represents type TBIXMLExport.

Namespace: BI.XMLData
Inheritance Hierarchy
TObject
BI.DataSource.TBIExport
BI.DataSource.TBITextExport
BI.XMLData.TBIXMLExport
Syntax
Delphi
type
 TBIXMLExport=class(TBITextExport)
 end;

The TBIXMLExport type exposes the following members.

Methods
Show:
Name | Description
DoEmit(TStrings) | Represents method DoEmit(TStrings). (Overrides TBIExport.DoEmit(TStrings).)
FileFilter | Represents method FileFilter. (Overrides TBIExport.FileFilter.)
Supports(String) | Represents method Supports(String). (Overrides TBIExport.Supports(String).)
Top
Fields
Show:
Name | Description
Emit | Represents field Emit.
Top
See Also

Reference

  • BI.XMLData


TBIXMLExport Methods

Methods
Name | Description
DoEmit(TStrings) | Represents method DoEmit(TStrings). (Overrides TBIExport.DoEmit(TStrings).)
FileFilter | Represents method FileFilter. (Overrides TBIExport.FileFilter.)
Supports(String) | Represents method Supports(String). (Overrides TBIExport.Supports(String).)
Top


TBIXMLExport.DoEmit(TStrings) Method

Summary

Represents method DoEmit(TStrings).

Namespace: BI.XMLData
Syntax
Delphi
protected
 procedure DoEmit(const AItems: TStrings); override;

Parameters

AItems
Type: TStrings

Overrides

TBIExport.DoEmit(TStrings)
See Also

Reference

  • TBIXMLExport
  • BI.XMLData


TBIXMLExport.FileFilter Method

Summary

Represents method FileFilter.

Namespace: BI.XMLData
Syntax
Delphi
public
 class function FileFilter: TFileFilters; override;

Return Value

Type: TFileFilters

Overrides

TBIExport.FileFilter
See Also

Reference

  • TBIXMLExport
  • BI.XMLData


TBIXMLExport.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: BI.XMLData
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIExport.Supports(String)
See Also

Reference

  • TBIXMLExport
  • BI.XMLData


TBIXMLExport Fields

Fields
Name | Description
Emit | Represents field Emit.
Top


TBIXMLExport.Emit Field

Summary

Represents field Emit.

Namespace: BI.XMLData
Syntax
Delphi
public
 Emit : TBIXMLEmit;

Field Value

Type: TBIXMLEmit

See Also

Reference

  • TBIXMLExport
  • BI.XMLData


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: BI.XMLData
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
BI.XMLData.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • BI.XMLData


TXmlEngine Class

Summary

Represents type TXmlEngine.

Namespace: BI.XMLData
Inheritance Hierarchy
TObject
BI.XMLData.TXmlEngine
BI.XMLData.FPC.TFPCXML
BI.XMLData.MSXML.TMsXML
BI.XMLData.Omni.TOmniXML
BI.XMLData.OXml.TOXml
Syntax
Delphi
type
 TXmlEngine=class abstract
 end;

The TXmlEngine type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TXmlEngine class.
Top
Methods
Show:
Name | Description
Attribute(Integer) | Represents method Attribute(Integer).
AttributeCount | Represents method AttributeCount.
AttributeName(Integer) | Represents method AttributeName(Integer).
Count | Represents method Count.
FromString(String) | Represents method FromString(String).
GetAttribute(String) | Represents method GetAttribute(String).
HasParent | Represents method HasParent.
HasText | Represents method HasText.
IsValid | Represents method IsValid.
Item(Integer) | Represents method Item(Integer).
LoadFromFile(String) | Represents method LoadFromFile(String).
Name | Represents method Name.
Parent | Represents method Parent.
Root | Represents method Root.
Text | Represents method Text.
Top
See Also

Reference

  • BI.XMLData


TXmlEngine Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TXmlEngine class.
Top


TXmlEngine.Create(TComponent) Constructor

Summary

Initializes a new instance of the TXmlEngine class.

Namespace: BI.XMLData
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); virtual; abstract;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TXmlEngine
  • BI.XMLData


TXmlEngine Methods

Methods
Name | Description
Attribute(Integer) | Represents method Attribute(Integer).
AttributeCount | Represents method AttributeCount.
AttributeName(Integer) | Represents method AttributeName(Integer).
Count | Represents method Count.
FromString(String) | Represents method FromString(String).
GetAttribute(String) | Represents method GetAttribute(String).
HasParent | Represents method HasParent.
HasText | Represents method HasText.
IsValid | Represents method IsValid.
Item(Integer) | Represents method Item(Integer).
LoadFromFile(String) | Represents method LoadFromFile(String).
Name | Represents method Name.
Parent | Represents method Parent.
Root | Represents method Root.
Text | Represents method Text.
Top


TXmlEngine.Attribute(Integer) Method

Summary

Represents method Attribute(Integer).

Namespace: BI.XMLData
Syntax
Delphi
public
 function Attribute(const Index:Integer):String; virtual; abstract;

Parameters

Index
Type: Integer

Return Value

Type: String

See Also

Reference

  • TXmlEngine
  • BI.XMLData


TXmlEngine.AttributeCount Method

Summary

Represents method AttributeCount.

Namespace: BI.XMLData
Syntax
Delphi
public
 function AttributeCount:Integer; virtual; abstract;

Return Value

Type: Integer

See Also

Reference

  • TXmlEngine
  • BI.XMLData


TXmlEngine.AttributeName(Integer) Method

Summary

Represents method AttributeName(Integer).

Namespace: BI.XMLData
Syntax
Delphi
public
 function AttributeName(const Index: Integer):String; virtual; abstract;

Parameters

Index
Type: Integer

Return Value

Type: String

See Also

Reference

  • TXmlEngine
  • BI.XMLData


TXmlEngine.Count Method

Summary

Represents method Count.

Namespace: BI.XMLData
Syntax
Delphi
public
 function Count:Integer; virtual; abstract;

Return Value

Type: Integer

See Also

Reference

  • TXmlEngine
  • BI.XMLData


TXmlEngine.FromString(String) Method

Summary

Represents method FromString(String).

Namespace: BI.XMLData
Syntax
Delphi
public
 procedure FromString(const Text:String); virtual; abstract;

Parameters

Text
Type: String

See Also

Reference

  • TXmlEngine
  • BI.XMLData


TXmlEngine.GetAttribute(String) Method

Summary

Represents method GetAttribute(String).

Namespace: BI.XMLData
Syntax
Delphi
public
 function GetAttribute(const AName:String):String;

Parameters

AName
Type: String

Return Value

Type: String

See Also

Reference

  • TXmlEngine
  • BI.XMLData


TXmlEngine.HasParent Method

Summary

Represents method HasParent.

Namespace: BI.XMLData
Syntax
Delphi
public
 function HasParent:Boolean; virtual; abstract;

Return Value

Type: Boolean

See Also

Reference

  • TXmlEngine
  • BI.XMLData


TXmlEngine.HasText Method

Summary

Represents method HasText.

Namespace: BI.XMLData
Syntax
Delphi
public
 function HasText:Boolean; virtual; abstract;

Return Value

Type: Boolean

See Also

Reference

  • TXmlEngine
  • BI.XMLData


TXmlEngine.IsValid Method

Summary

Represents method IsValid.

Namespace: BI.XMLData
Syntax
Delphi
public
 function IsValid:Boolean; virtual; abstract;

Return Value

Type: Boolean

See Also

Reference

  • TXmlEngine
  • BI.XMLData


TXmlEngine.Item(Integer) Method

Summary

Represents method Item(Integer).

Namespace: BI.XMLData
Syntax
Delphi
public
 procedure Item(const Index: Integer); virtual; abstract;

Parameters

Index
Type: Integer

See Also

Reference

  • TXmlEngine
  • BI.XMLData


TXmlEngine.LoadFromFile(String) Method

Summary

Represents method LoadFromFile(String).

Namespace: BI.XMLData
Syntax
Delphi
public
 procedure LoadFromFile(const Filename: String); virtual; abstract;

Parameters

Filename
Type: String

See Also

Reference

  • TXmlEngine
  • BI.XMLData


TXmlEngine.Name Method

Summary

Represents method Name.

Namespace: BI.XMLData
Syntax
Delphi
public
 function Name:String; virtual; abstract;

Return Value

Type: String

See Also

Reference

  • TXmlEngine
  • BI.XMLData


TXmlEngine.Parent Method

Summary

Represents method Parent.

Namespace: BI.XMLData
Syntax
Delphi
public
 procedure Parent; virtual; abstract;
See Also

Reference

  • TXmlEngine
  • BI.XMLData


TXmlEngine.Root Method

Summary

Represents method Root.

Namespace: BI.XMLData
Syntax
Delphi
public
 procedure Root; virtual; abstract;
See Also

Reference

  • TXmlEngine
  • BI.XMLData


TXmlEngine.Text Method

Summary

Represents method Text.

Namespace: BI.XMLData
Syntax
Delphi
public
 function Text:String; virtual; abstract;

Return Value

Type: String

See Also

Reference

  • TXmlEngine
  • BI.XMLData


BI.XMLData Enumerations

Enumerations
Name | Description
TBIXMLEmit | Represents type TBIXMLEmit.
Top


TBIXMLEmit Enumeration

Summary

Represents type TBIXMLEmit.

Namespace: BI.XMLData
Syntax
Delphi
type
 TBIXMLEmit=(Header,Simple);

The TBIXMLEmit type exposes the following members.

Members
Show:
Name | Description
Header | Represents constant Header.
Simple | Represents constant Simple.
Top
See Also

Reference

  • BI.XMLData


BI.XMLData Types

Types
Name | Description
TXmlEngineClass | Represents type TXmlEngineClass.
Top


TXmlEngineClass Type

Summary

Represents type TXmlEngineClass.

Namespace: BI.XMLData
Syntax
Delphi
type
 TXmlEngineClass=class of TXmlEngine;
See Also

Reference

  • BI.XMLData


BI.XMLData Routines

Routines
Name | Description
ToBoolean(Boolean) | Represents method ToBoolean(Boolean).
XMLTag(String) | Represents method XMLTag(String).
Top


ToBoolean(Boolean) Method

Summary

Represents method ToBoolean(Boolean).

Namespace: BI.XMLData
Syntax
Delphi
function ToBoolean(const Value:Boolean):String;

Parameters

Value
Type: Boolean

Return Value

Type: String

See Also

Reference

  • BI.XMLData


XMLTag(String) Method

Summary

Represents method XMLTag(String).

Namespace: BI.XMLData
Syntax
Delphi
function XMLTag(const S:String):String;

Parameters

S
Type: String

Return Value

Type: String

See Also

Reference

  • BI.XMLData


BI.XMLData.FPC Namespace

Summary

Represents namespace BI.XMLData.FPC.

Classes
Name | Description
TFPCXML | Represents type TFPCXML.
Top


BI.XMLData.FPC Classes

Classes
Name | Description
TFPCXML | Represents type TFPCXML.
Top


TFPCXML Class

Summary

Represents type TFPCXML.

Namespace: BI.XMLData.FPC
Inheritance Hierarchy
TObject
BI.XMLData.TXmlEngine
BI.XMLData.FPC.TFPCXML
Syntax
Delphi
type
 TFPCXML=class(TXMLEngine)
 end;

The TFPCXML type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TFPCXML class. (Overrides TXmlEngine.Create(TComponent).)
Destroy | Represents the destructor of the TFPCXML class.
Top
Methods
Show:
Name | Description
Attribute(Integer) | Represents method Attribute(Integer). (Overrides TXmlEngine.Attribute(Integer).)
AttributeCount | Represents method AttributeCount. (Overrides TXmlEngine.AttributeCount.)
AttributeName(Integer) | Represents method AttributeName(Integer). (Overrides TXmlEngine.AttributeName(Integer).)
Count | Represents method Count. (Overrides TXmlEngine.Count.)
FromString(String) | Represents method FromString(String). (Overrides TXmlEngine.FromString(String).)
HasParent | Represents method HasParent. (Overrides TXmlEngine.HasParent.)
HasText | Represents method HasText. (Overrides TXmlEngine.HasText.)
IsValid | Represents method IsValid. (Overrides TXmlEngine.IsValid.)
Item(Integer) | Represents method Item(Integer). (Overrides TXmlEngine.Item(Integer).)
LoadFromFile(String) | Represents method LoadFromFile(String). (Overrides TXmlEngine.LoadFromFile(String).)
Name | Represents method Name. (Overrides TXmlEngine.Name.)
Normalize(String) | Represents method Normalize(String).
Parent | Represents method Parent. (Overrides TXmlEngine.Parent.)
Root | Represents method Root. (Overrides TXmlEngine.Root.)
Text | Represents method Text. (Overrides TXmlEngine.Text.)
Top
See Also

Reference

  • BI.XMLData.FPC


TFPCXML Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TFPCXML class. (Overrides TXmlEngine.Create(TComponent).)
Destroy | Represents the destructor of the TFPCXML class.
Top


TFPCXML.Create(TComponent) Constructor

Summary

Initializes a new instance of the TFPCXML class.

Namespace: BI.XMLData.FPC
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TXmlEngine.Create(TComponent)
See Also

Reference

  • TFPCXML
  • BI.XMLData.FPC


TFPCXML.Destroy Destructor

Summary

Represents the destructor of the TFPCXML class.

Namespace: BI.XMLData.FPC
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TFPCXML
  • BI.XMLData.FPC


TFPCXML Methods

Methods
Name | Description
Attribute(Integer) | Represents method Attribute(Integer). (Overrides TXmlEngine.Attribute(Integer).)
AttributeCount | Represents method AttributeCount. (Overrides TXmlEngine.AttributeCount.)
AttributeName(Integer) | Represents method AttributeName(Integer). (Overrides TXmlEngine.AttributeName(Integer).)
Count | Represents method Count. (Overrides TXmlEngine.Count.)
FromString(String) | Represents method FromString(String). (Overrides TXmlEngine.FromString(String).)
HasParent | Represents method HasParent. (Overrides TXmlEngine.HasParent.)
HasText | Represents method HasText. (Overrides TXmlEngine.HasText.)
IsValid | Represents method IsValid. (Overrides TXmlEngine.IsValid.)
Item(Integer) | Represents method Item(Integer). (Overrides TXmlEngine.Item(Integer).)
LoadFromFile(String) | Represents method LoadFromFile(String). (Overrides TXmlEngine.LoadFromFile(String).)
Name | Represents method Name. (Overrides TXmlEngine.Name.)
Normalize(String) | Represents method Normalize(String).
Parent | Represents method Parent. (Overrides TXmlEngine.Parent.)
Root | Represents method Root. (Overrides TXmlEngine.Root.)
Text | Represents method Text. (Overrides TXmlEngine.Text.)
Top


TFPCXML.Attribute(Integer) Method

Summary

Represents method Attribute(Integer).

Namespace: BI.XMLData.FPC
Syntax
Delphi
public
 function Attribute(const Index:Integer):String; override;

Parameters

Index
Type: Integer

Return Value

Type: String

Overrides

TXmlEngine.Attribute(Integer)
See Also

Reference

  • TFPCXML
  • BI.XMLData.FPC


TFPCXML.AttributeCount Method

Summary

Represents method AttributeCount.

Namespace: BI.XMLData.FPC
Syntax
Delphi
public
 function AttributeCount:Integer; override;

Return Value

Type: Integer

Overrides

TXmlEngine.AttributeCount
See Also

Reference

  • TFPCXML
  • BI.XMLData.FPC


TFPCXML.AttributeName(Integer) Method

Summary

Represents method AttributeName(Integer).

Namespace: BI.XMLData.FPC
Syntax
Delphi
public
 function AttributeName(const Index: Integer): String; override;

Parameters

Index
Type: Integer

Return Value

Type: String

Overrides

TXmlEngine.AttributeName(Integer)
See Also

Reference

  • TFPCXML
  • BI.XMLData.FPC


TFPCXML.Count Method

Summary

Represents method Count.

Namespace: BI.XMLData.FPC
Syntax
Delphi
public
 function Count:Integer; override;

Return Value

Type: Integer

Overrides

TXmlEngine.Count
See Also

Reference

  • TFPCXML
  • BI.XMLData.FPC


TFPCXML.FromString(String) Method

Summary

Represents method FromString(String).

Namespace: BI.XMLData.FPC
Syntax
Delphi
public
 procedure FromString(const Text:String); override;

Parameters

Text
Type: String

Overrides

TXmlEngine.FromString(String)
See Also

Reference

  • TFPCXML
  • BI.XMLData.FPC


TFPCXML.HasParent Method

Summary

Represents method HasParent.

Namespace: BI.XMLData.FPC
Syntax
Delphi
public
 function HasParent:Boolean; override;

Return Value

Type: Boolean

Overrides

TXmlEngine.HasParent
See Also

Reference

  • TFPCXML
  • BI.XMLData.FPC


TFPCXML.HasText Method

Summary

Represents method HasText.

Namespace: BI.XMLData.FPC
Syntax
Delphi
public
 function HasText:Boolean; override;

Return Value

Type: Boolean

Overrides

TXmlEngine.HasText
See Also

Reference

  • TFPCXML
  • BI.XMLData.FPC


TFPCXML.IsValid Method

Summary

Represents method IsValid.

Namespace: BI.XMLData.FPC
Syntax
Delphi
public
 function IsValid:Boolean; override;

Return Value

Type: Boolean

Overrides

TXmlEngine.IsValid
See Also

Reference

  • TFPCXML
  • BI.XMLData.FPC


TFPCXML.Item(Integer) Method

Summary

Represents method Item(Integer).

Namespace: BI.XMLData.FPC
Syntax
Delphi
public
 procedure Item(const Index: Integer); override;

Parameters

Index
Type: Integer

Overrides

TXmlEngine.Item(Integer)
See Also

Reference

  • TFPCXML
  • BI.XMLData.FPC


TFPCXML.LoadFromFile(String) Method

Summary

Represents method LoadFromFile(String).

Namespace: BI.XMLData.FPC
Syntax
Delphi
public
 procedure LoadFromFile(const Filename: String); override;

Parameters

Filename
Type: String

Overrides

TXmlEngine.LoadFromFile(String)
See Also

Reference

  • TFPCXML
  • BI.XMLData.FPC


TFPCXML.Name Method

Summary

Represents method Name.

Namespace: BI.XMLData.FPC
Syntax
Delphi
public
 function Name:String; override;

Return Value

Type: String

Overrides

TXmlEngine.Name
See Also

Reference

  • TFPCXML
  • BI.XMLData.FPC


TFPCXML.Normalize(String) Method

Summary

Represents method Normalize(String).

Namespace: BI.XMLData.FPC
Syntax
Delphi
public
 class function Normalize(const S:String):String;

Parameters

S
Type: String

Return Value

Type: String

See Also

Reference

  • TFPCXML
  • BI.XMLData.FPC


TFPCXML.Parent Method

Summary

Represents method Parent.

Namespace: BI.XMLData.FPC
Syntax
Delphi
public
 procedure Parent; override;

Overrides

TXmlEngine.Parent
See Also

Reference

  • TFPCXML
  • BI.XMLData.FPC


TFPCXML.Root Method

Summary

Represents method Root.

Namespace: BI.XMLData.FPC
Syntax
Delphi
public
 procedure Root; override;

Overrides

TXmlEngine.Root
See Also

Reference

  • TFPCXML
  • BI.XMLData.FPC


TFPCXML.Text Method

Summary

Represents method Text.

Namespace: BI.XMLData.FPC
Syntax
Delphi
public
 function Text:String; override;

Return Value

Type: String

Overrides

TXmlEngine.Text
See Also

Reference

  • TFPCXML
  • BI.XMLData.FPC


BI.XMLData.MSXML Namespace

Summary

Represents namespace BI.XMLData.MSXML.

Classes
Name | Description
TMsXML | Represents type TMsXML.
Top


BI.XMLData.MSXML Classes

Classes
Name | Description
TMsXML | Represents type TMsXML.
Top


TMsXML Class

Summary

Represents type TMsXML.

Namespace: BI.XMLData.MSXML
Inheritance Hierarchy
TObject
BI.XMLData.TXmlEngine
BI.XMLData.MSXML.TMsXML
Syntax
Delphi
type
 TMsXML=class(TXMLEngine)
 end;

The TMsXML type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TMsXML class. (Overrides TXmlEngine.Create(TComponent).)
Destroy | Represents the destructor of the TMsXML class.
Top
Methods
Show:
Name | Description
Attribute(Integer) | Represents method Attribute(Integer). (Overrides TXmlEngine.Attribute(Integer).)
AttributeCount | Represents method AttributeCount. (Overrides TXmlEngine.AttributeCount.)
AttributeName(Integer) | Represents method AttributeName(Integer). (Overrides TXmlEngine.AttributeName(Integer).)
Count | Represents method Count. (Overrides TXmlEngine.Count.)
FromString(String) | Represents method FromString(String). (Overrides TXmlEngine.FromString(String).)
HasParent | Represents method HasParent. (Overrides TXmlEngine.HasParent.)
HasText | Represents method HasText. (Overrides TXmlEngine.HasText.)
IsValid | Represents method IsValid. (Overrides TXmlEngine.IsValid.)
Item(Integer) | Represents method Item(Integer). (Overrides TXmlEngine.Item(Integer).)
LoadFromFile(String) | Represents method LoadFromFile(String). (Overrides TXmlEngine.LoadFromFile(String).)
Name | Represents method Name. (Overrides TXmlEngine.Name.)
Parent | Represents method Parent. (Overrides TXmlEngine.Parent.)
Root | Represents method Root. (Overrides TXmlEngine.Root.)
Text | Represents method Text. (Overrides TXmlEngine.Text.)
Top
See Also

Reference

  • BI.XMLData.MSXML


TMsXML Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TMsXML class. (Overrides TXmlEngine.Create(TComponent).)
Destroy | Represents the destructor of the TMsXML class.
Top


TMsXML.Create(TComponent) Constructor

Summary

Initializes a new instance of the TMsXML class.

Namespace: BI.XMLData.MSXML
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TXmlEngine.Create(TComponent)
See Also

Reference

  • TMsXML
  • BI.XMLData.MSXML


TMsXML.Destroy Destructor

Summary

Represents the destructor of the TMsXML class.

Namespace: BI.XMLData.MSXML
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TMsXML
  • BI.XMLData.MSXML


TMsXML Methods

Methods
Name | Description
Attribute(Integer) | Represents method Attribute(Integer). (Overrides TXmlEngine.Attribute(Integer).)
AttributeCount | Represents method AttributeCount. (Overrides TXmlEngine.AttributeCount.)
AttributeName(Integer) | Represents method AttributeName(Integer). (Overrides TXmlEngine.AttributeName(Integer).)
Count | Represents method Count. (Overrides TXmlEngine.Count.)
FromString(String) | Represents method FromString(String). (Overrides TXmlEngine.FromString(String).)
HasParent | Represents method HasParent. (Overrides TXmlEngine.HasParent.)
HasText | Represents method HasText. (Overrides TXmlEngine.HasText.)
IsValid | Represents method IsValid. (Overrides TXmlEngine.IsValid.)
Item(Integer) | Represents method Item(Integer). (Overrides TXmlEngine.Item(Integer).)
LoadFromFile(String) | Represents method LoadFromFile(String). (Overrides TXmlEngine.LoadFromFile(String).)
Name | Represents method Name. (Overrides TXmlEngine.Name.)
Parent | Represents method Parent. (Overrides TXmlEngine.Parent.)
Root | Represents method Root. (Overrides TXmlEngine.Root.)
Text | Represents method Text. (Overrides TXmlEngine.Text.)
Top


TMsXML.Attribute(Integer) Method

Summary

Represents method Attribute(Integer).

Namespace: BI.XMLData.MSXML
Syntax
Delphi
public
 function Attribute(const Index:Integer):String; override;

Parameters

Index
Type: Integer

Return Value

Type: String

Overrides

TXmlEngine.Attribute(Integer)
See Also

Reference

  • TMsXML
  • BI.XMLData.MSXML


TMsXML.AttributeCount Method

Summary

Represents method AttributeCount.

Namespace: BI.XMLData.MSXML
Syntax
Delphi
public
 function AttributeCount:Integer; override;

Return Value

Type: Integer

Overrides

TXmlEngine.AttributeCount
See Also

Reference

  • TMsXML
  • BI.XMLData.MSXML


TMsXML.AttributeName(Integer) Method

Summary

Represents method AttributeName(Integer).

Namespace: BI.XMLData.MSXML
Syntax
Delphi
public
 function AttributeName(const Index: Integer): String; override;

Parameters

Index
Type: Integer

Return Value

Type: String

Overrides

TXmlEngine.AttributeName(Integer)
See Also

Reference

  • TMsXML
  • BI.XMLData.MSXML


TMsXML.Count Method

Summary

Represents method Count.

Namespace: BI.XMLData.MSXML
Syntax
Delphi
public
 function Count:Integer; override;

Return Value

Type: Integer

Overrides

TXmlEngine.Count
See Also

Reference

  • TMsXML
  • BI.XMLData.MSXML


TMsXML.FromString(String) Method

Summary

Represents method FromString(String).

Namespace: BI.XMLData.MSXML
Syntax
Delphi
public
 procedure FromString(const Text:String); override;

Parameters

Text
Type: String

Overrides

TXmlEngine.FromString(String)
See Also

Reference

  • TMsXML
  • BI.XMLData.MSXML


TMsXML.HasParent Method

Summary

Represents method HasParent.

Namespace: BI.XMLData.MSXML
Syntax
Delphi
public
 function HasParent:Boolean; override;

Return Value

Type: Boolean

Overrides

TXmlEngine.HasParent
See Also

Reference

  • TMsXML
  • BI.XMLData.MSXML


TMsXML.HasText Method

Summary

Represents method HasText.

Namespace: BI.XMLData.MSXML
Syntax
Delphi
public
 function HasText:Boolean; override;

Return Value

Type: Boolean

Overrides

TXmlEngine.HasText
See Also

Reference

  • TMsXML
  • BI.XMLData.MSXML


TMsXML.IsValid Method

Summary

Represents method IsValid.

Namespace: BI.XMLData.MSXML
Syntax
Delphi
public
 function IsValid:Boolean; override;

Return Value

Type: Boolean

Overrides

TXmlEngine.IsValid
See Also

Reference

  • TMsXML
  • BI.XMLData.MSXML


TMsXML.Item(Integer) Method

Summary

Represents method Item(Integer).

Namespace: BI.XMLData.MSXML
Syntax
Delphi
public
 procedure Item(const Index: Integer); override;

Parameters

Index
Type: Integer

Overrides

TXmlEngine.Item(Integer)
See Also

Reference

  • TMsXML
  • BI.XMLData.MSXML


TMsXML.LoadFromFile(String) Method

Summary

Represents method LoadFromFile(String).

Namespace: BI.XMLData.MSXML
Syntax
Delphi
public
 procedure LoadFromFile(const Filename: String); override;

Parameters

Filename
Type: String

Overrides

TXmlEngine.LoadFromFile(String)
See Also

Reference

  • TMsXML
  • BI.XMLData.MSXML


TMsXML.Name Method

Summary

Represents method Name.

Namespace: BI.XMLData.MSXML
Syntax
Delphi
public
 function Name:String; override;

Return Value

Type: String

Overrides

TXmlEngine.Name
See Also

Reference

  • TMsXML
  • BI.XMLData.MSXML


TMsXML.Parent Method

Summary

Represents method Parent.

Namespace: BI.XMLData.MSXML
Syntax
Delphi
public
 procedure Parent; override;

Overrides

TXmlEngine.Parent
See Also

Reference

  • TMsXML
  • BI.XMLData.MSXML


TMsXML.Root Method

Summary

Represents method Root.

Namespace: BI.XMLData.MSXML
Syntax
Delphi
public
 procedure Root; override;

Overrides

TXmlEngine.Root
See Also

Reference

  • TMsXML
  • BI.XMLData.MSXML


TMsXML.Text Method

Summary

Represents method Text.

Namespace: BI.XMLData.MSXML
Syntax
Delphi
public
 function Text:String; override;

Return Value

Type: String

Overrides

TXmlEngine.Text
See Also

Reference

  • TMsXML
  • BI.XMLData.MSXML


BI.XMLData.Omni Namespace

Summary

Represents namespace BI.XMLData.Omni.

Classes
Name | Description
TOmniXML | Represents type TOmniXML.
Top


BI.XMLData.Omni Classes

Classes
Name | Description
TOmniXML | Represents type TOmniXML.
Top


TOmniXML Class

Summary

Represents type TOmniXML.

Namespace: BI.XMLData.Omni
Inheritance Hierarchy
TObject
BI.XMLData.TXmlEngine
BI.XMLData.Omni.TOmniXML
Syntax
Delphi
type
 TOmniXML=class(TXMLEngine)
 end;

The TOmniXML type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TOmniXML class. (Overrides TXmlEngine.Create(TComponent).)
Destroy | Represents the destructor of the TOmniXML class.
Top
Methods
Show:
Name | Description
Attribute(Integer) | Represents method Attribute(Integer). (Overrides TXmlEngine.Attribute(Integer).)
AttributeCount | Represents method AttributeCount. (Overrides TXmlEngine.AttributeCount.)
AttributeName(Integer) | Represents method AttributeName(Integer). (Overrides TXmlEngine.AttributeName(Integer).)
Count | Represents method Count. (Overrides TXmlEngine.Count.)
FromString(String) | Represents method FromString(String). (Overrides TXmlEngine.FromString(String).)
HasParent | Represents method HasParent. (Overrides TXmlEngine.HasParent.)
HasText | Represents method HasText. (Overrides TXmlEngine.HasText.)
IsValid | Represents method IsValid. (Overrides TXmlEngine.IsValid.)
Item(Integer) | Represents method Item(Integer). (Overrides TXmlEngine.Item(Integer).)
LoadFromFile(String) | Represents method LoadFromFile(String). (Overrides TXmlEngine.LoadFromFile(String).)
Name | Represents method Name. (Overrides TXmlEngine.Name.)
Parent | Represents method Parent. (Overrides TXmlEngine.Parent.)
Root | Represents method Root. (Overrides TXmlEngine.Root.)
Text | Represents method Text. (Overrides TXmlEngine.Text.)
Top
See Also

Reference

  • BI.XMLData.Omni


TOmniXML Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TOmniXML class. (Overrides TXmlEngine.Create(TComponent).)
Destroy | Represents the destructor of the TOmniXML class.
Top


TOmniXML.Create(TComponent) Constructor

Summary

Initializes a new instance of the TOmniXML class.

Namespace: BI.XMLData.Omni
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TXmlEngine.Create(TComponent)
See Also

Reference

  • TOmniXML
  • BI.XMLData.Omni


TOmniXML.Destroy Destructor

Summary

Represents the destructor of the TOmniXML class.

Namespace: BI.XMLData.Omni
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TOmniXML
  • BI.XMLData.Omni


TOmniXML Methods

Methods
Name | Description
Attribute(Integer) | Represents method Attribute(Integer). (Overrides TXmlEngine.Attribute(Integer).)
AttributeCount | Represents method AttributeCount. (Overrides TXmlEngine.AttributeCount.)
AttributeName(Integer) | Represents method AttributeName(Integer). (Overrides TXmlEngine.AttributeName(Integer).)
Count | Represents method Count. (Overrides TXmlEngine.Count.)
FromString(String) | Represents method FromString(String). (Overrides TXmlEngine.FromString(String).)
HasParent | Represents method HasParent. (Overrides TXmlEngine.HasParent.)
HasText | Represents method HasText. (Overrides TXmlEngine.HasText.)
IsValid | Represents method IsValid. (Overrides TXmlEngine.IsValid.)
Item(Integer) | Represents method Item(Integer). (Overrides TXmlEngine.Item(Integer).)
LoadFromFile(String) | Represents method LoadFromFile(String). (Overrides TXmlEngine.LoadFromFile(String).)
Name | Represents method Name. (Overrides TXmlEngine.Name.)
Parent | Represents method Parent. (Overrides TXmlEngine.Parent.)
Root | Represents method Root. (Overrides TXmlEngine.Root.)
Text | Represents method Text. (Overrides TXmlEngine.Text.)
Top


TOmniXML.Attribute(Integer) Method

Summary

Represents method Attribute(Integer).

Namespace: BI.XMLData.Omni
Syntax
Delphi
public
 function Attribute(const Index:Integer):String; override;

Parameters

Index
Type: Integer

Return Value

Type: String

Overrides

TXmlEngine.Attribute(Integer)
See Also

Reference

  • TOmniXML
  • BI.XMLData.Omni


TOmniXML.AttributeCount Method

Summary

Represents method AttributeCount.

Namespace: BI.XMLData.Omni
Syntax
Delphi
public
 function AttributeCount:Integer; override;

Return Value

Type: Integer

Overrides

TXmlEngine.AttributeCount
See Also

Reference

  • TOmniXML
  • BI.XMLData.Omni


TOmniXML.AttributeName(Integer) Method

Summary

Represents method AttributeName(Integer).

Namespace: BI.XMLData.Omni
Syntax
Delphi
public
 function AttributeName(const Index: Integer): String; override;

Parameters

Index
Type: Integer

Return Value

Type: String

Overrides

TXmlEngine.AttributeName(Integer)
See Also

Reference

  • TOmniXML
  • BI.XMLData.Omni


TOmniXML.Count Method

Summary

Represents method Count.

Namespace: BI.XMLData.Omni
Syntax
Delphi
public
 function Count:Integer; override;

Return Value

Type: Integer

Overrides

TXmlEngine.Count
See Also

Reference

  • TOmniXML
  • BI.XMLData.Omni


TOmniXML.FromString(String) Method

Summary

Represents method FromString(String).

Namespace: BI.XMLData.Omni
Syntax
Delphi
public
 procedure FromString(const Text:String); override;

Parameters

Text
Type: String

Overrides

TXmlEngine.FromString(String)
See Also

Reference

  • TOmniXML
  • BI.XMLData.Omni


TOmniXML.HasParent Method

Summary

Represents method HasParent.

Namespace: BI.XMLData.Omni
Syntax
Delphi
public
 function HasParent:Boolean; override;

Return Value

Type: Boolean

Overrides

TXmlEngine.HasParent
See Also

Reference

  • TOmniXML
  • BI.XMLData.Omni


TOmniXML.HasText Method

Summary

Represents method HasText.

Namespace: BI.XMLData.Omni
Syntax
Delphi
public
 function HasText:Boolean; override;

Return Value

Type: Boolean

Overrides

TXmlEngine.HasText
See Also

Reference

  • TOmniXML
  • BI.XMLData.Omni


TOmniXML.IsValid Method

Summary

Represents method IsValid.

Namespace: BI.XMLData.Omni
Syntax
Delphi
public
 function IsValid:Boolean; override;

Return Value

Type: Boolean

Overrides

TXmlEngine.IsValid
See Also

Reference

  • TOmniXML
  • BI.XMLData.Omni


TOmniXML.Item(Integer) Method

Summary

Represents method Item(Integer).

Namespace: BI.XMLData.Omni
Syntax
Delphi
public
 procedure Item(const Index: Integer); override;

Parameters

Index
Type: Integer

Overrides

TXmlEngine.Item(Integer)
See Also

Reference

  • TOmniXML
  • BI.XMLData.Omni


TOmniXML.LoadFromFile(String) Method

Summary

Represents method LoadFromFile(String).

Namespace: BI.XMLData.Omni
Syntax
Delphi
public
 procedure LoadFromFile(const Filename: String); override;

Parameters

Filename
Type: String

Overrides

TXmlEngine.LoadFromFile(String)
See Also

Reference

  • TOmniXML
  • BI.XMLData.Omni


TOmniXML.Name Method

Summary

Represents method Name.

Namespace: BI.XMLData.Omni
Syntax
Delphi
public
 function Name:String; override;

Return Value

Type: String

Overrides

TXmlEngine.Name
See Also

Reference

  • TOmniXML
  • BI.XMLData.Omni


TOmniXML.Parent Method

Summary

Represents method Parent.

Namespace: BI.XMLData.Omni
Syntax
Delphi
public
 procedure Parent; override;

Overrides

TXmlEngine.Parent
See Also

Reference

  • TOmniXML
  • BI.XMLData.Omni


TOmniXML.Root Method

Summary

Represents method Root.

Namespace: BI.XMLData.Omni
Syntax
Delphi
public
 procedure Root; override;

Overrides

TXmlEngine.Root
See Also

Reference

  • TOmniXML
  • BI.XMLData.Omni


TOmniXML.Text Method

Summary

Represents method Text.

Namespace: BI.XMLData.Omni
Syntax
Delphi
public
 function Text:String; override;

Return Value

Type: String

Overrides

TXmlEngine.Text
See Also

Reference

  • TOmniXML
  • BI.XMLData.Omni


BI.XMLData.OXml Namespace

Summary

Represents namespace BI.XMLData.OXml.

Classes
Name | Description
TOXml | Represents type TOXml.
Top


BI.XMLData.OXml Classes

Classes
Name | Description
TOXml | Represents type TOXml.
Top


TOXml Class

Summary

Represents type TOXml.

Namespace: BI.XMLData.OXml
Inheritance Hierarchy
TObject
BI.XMLData.TXmlEngine
BI.XMLData.OXml.TOXml
Syntax
Delphi
type
 TOXml=class(TXMLEngine)
 end;

The TOXml type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TOXml class. (Overrides TXmlEngine.Create(TComponent).)
Destroy | Represents the destructor of the TOXml class.
Top
Methods
Show:
Name | Description
Attribute(Integer) | Represents method Attribute(Integer). (Overrides TXmlEngine.Attribute(Integer).)
AttributeCount | Represents method AttributeCount. (Overrides TXmlEngine.AttributeCount.)
AttributeName(Integer) | Represents method AttributeName(Integer). (Overrides TXmlEngine.AttributeName(Integer).)
Count | Represents method Count. (Overrides TXmlEngine.Count.)
FromString(String) | Represents method FromString(String). (Overrides TXmlEngine.FromString(String).)
HasParent | Represents method HasParent. (Overrides TXmlEngine.HasParent.)
HasText | Represents method HasText. (Overrides TXmlEngine.HasText.)
IsValid | Represents method IsValid. (Overrides TXmlEngine.IsValid.)
Item(Integer) | Represents method Item(Integer). (Overrides TXmlEngine.Item(Integer).)
LoadFromFile(String) | Represents method LoadFromFile(String). (Overrides TXmlEngine.LoadFromFile(String).)
Name | Represents method Name. (Overrides TXmlEngine.Name.)
Parent | Represents method Parent. (Overrides TXmlEngine.Parent.)
Root | Represents method Root. (Overrides TXmlEngine.Root.)
Text | Represents method Text. (Overrides TXmlEngine.Text.)
Top
See Also

Reference

  • BI.XMLData.OXml


TOXml Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TOXml class. (Overrides TXmlEngine.Create(TComponent).)
Destroy | Represents the destructor of the TOXml class.
Top


TOXml.Create(TComponent) Constructor

Summary

Initializes a new instance of the TOXml class.

Namespace: BI.XMLData.OXml
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TXmlEngine.Create(TComponent)
See Also

Reference

  • TOXml
  • BI.XMLData.OXml


TOXml.Destroy Destructor

Summary

Represents the destructor of the TOXml class.

Namespace: BI.XMLData.OXml
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TOXml
  • BI.XMLData.OXml


TOXml Methods

Methods
Name | Description
Attribute(Integer) | Represents method Attribute(Integer). (Overrides TXmlEngine.Attribute(Integer).)
AttributeCount | Represents method AttributeCount. (Overrides TXmlEngine.AttributeCount.)
AttributeName(Integer) | Represents method AttributeName(Integer). (Overrides TXmlEngine.AttributeName(Integer).)
Count | Represents method Count. (Overrides TXmlEngine.Count.)
FromString(String) | Represents method FromString(String). (Overrides TXmlEngine.FromString(String).)
HasParent | Represents method HasParent. (Overrides TXmlEngine.HasParent.)
HasText | Represents method HasText. (Overrides TXmlEngine.HasText.)
IsValid | Represents method IsValid. (Overrides TXmlEngine.IsValid.)
Item(Integer) | Represents method Item(Integer). (Overrides TXmlEngine.Item(Integer).)
LoadFromFile(String) | Represents method LoadFromFile(String). (Overrides TXmlEngine.LoadFromFile(String).)
Name | Represents method Name. (Overrides TXmlEngine.Name.)
Parent | Represents method Parent. (Overrides TXmlEngine.Parent.)
Root | Represents method Root. (Overrides TXmlEngine.Root.)
Text | Represents method Text. (Overrides TXmlEngine.Text.)
Top


TOXml.Attribute(Integer) Method

Summary

Represents method Attribute(Integer).

Namespace: BI.XMLData.OXml
Syntax
Delphi
public
 function Attribute(const Index:Integer):String; override;

Parameters

Index
Type: Integer

Return Value

Type: String

Overrides

TXmlEngine.Attribute(Integer)
See Also

Reference

  • TOXml
  • BI.XMLData.OXml


TOXml.AttributeCount Method

Summary

Represents method AttributeCount.

Namespace: BI.XMLData.OXml
Syntax
Delphi
public
 function AttributeCount:Integer; override;

Return Value

Type: Integer

Overrides

TXmlEngine.AttributeCount
See Also

Reference

  • TOXml
  • BI.XMLData.OXml


TOXml.AttributeName(Integer) Method

Summary

Represents method AttributeName(Integer).

Namespace: BI.XMLData.OXml
Syntax
Delphi
public
 function AttributeName(const Index: Integer): String; override;

Parameters

Index
Type: Integer

Return Value

Type: String

Overrides

TXmlEngine.AttributeName(Integer)
See Also

Reference

  • TOXml
  • BI.XMLData.OXml


TOXml.Count Method

Summary

Represents method Count.

Namespace: BI.XMLData.OXml
Syntax
Delphi
public
 function Count:Integer; override;

Return Value

Type: Integer

Overrides

TXmlEngine.Count
See Also

Reference

  • TOXml
  • BI.XMLData.OXml


TOXml.FromString(String) Method

Summary

Represents method FromString(String).

Namespace: BI.XMLData.OXml
Syntax
Delphi
public
 procedure FromString(const Text:String); override;

Parameters

Text
Type: String

Overrides

TXmlEngine.FromString(String)
See Also

Reference

  • TOXml
  • BI.XMLData.OXml


TOXml.HasParent Method

Summary

Represents method HasParent.

Namespace: BI.XMLData.OXml
Syntax
Delphi
public
 function HasParent:Boolean; override;

Return Value

Type: Boolean

Overrides

TXmlEngine.HasParent
See Also

Reference

  • TOXml
  • BI.XMLData.OXml


TOXml.HasText Method

Summary

Represents method HasText.

Namespace: BI.XMLData.OXml
Syntax
Delphi
public
 function HasText:Boolean; override;

Return Value

Type: Boolean

Overrides

TXmlEngine.HasText
See Also

Reference

  • TOXml
  • BI.XMLData.OXml


TOXml.IsValid Method

Summary

Represents method IsValid.

Namespace: BI.XMLData.OXml
Syntax
Delphi
public
 function IsValid:Boolean; override;

Return Value

Type: Boolean

Overrides

TXmlEngine.IsValid
See Also

Reference

  • TOXml
  • BI.XMLData.OXml


TOXml.Item(Integer) Method

Summary

Represents method Item(Integer).

Namespace: BI.XMLData.OXml
Syntax
Delphi
public
 procedure Item(const Index: Integer); override;

Parameters

Index
Type: Integer

Overrides

TXmlEngine.Item(Integer)
See Also

Reference

  • TOXml
  • BI.XMLData.OXml


TOXml.LoadFromFile(String) Method

Summary

Represents method LoadFromFile(String).

Namespace: BI.XMLData.OXml
Syntax
Delphi
public
 procedure LoadFromFile(const Filename: String); override;

Parameters

Filename
Type: String

Overrides

TXmlEngine.LoadFromFile(String)
See Also

Reference

  • TOXml
  • BI.XMLData.OXml


TOXml.Name Method

Summary

Represents method Name.

Namespace: BI.XMLData.OXml
Syntax
Delphi
public
 function Name:String; override;

Return Value

Type: String

Overrides

TXmlEngine.Name
See Also

Reference

  • TOXml
  • BI.XMLData.OXml


TOXml.Parent Method

Summary

Represents method Parent.

Namespace: BI.XMLData.OXml
Syntax
Delphi
public
 procedure Parent; override;

Overrides

TXmlEngine.Parent
See Also

Reference

  • TOXml
  • BI.XMLData.OXml


TOXml.Root Method

Summary

Represents method Root.

Namespace: BI.XMLData.OXml
Syntax
Delphi
public
 procedure Root; override;

Overrides

TXmlEngine.Root
See Also

Reference

  • TOXml
  • BI.XMLData.OXml


TOXml.Text Method

Summary

Represents method Text.

Namespace: BI.XMLData.OXml
Syntax
Delphi
public
 function Text:String; override;

Return Value

Type: String

Overrides

TXmlEngine.Text
See Also

Reference

  • TOXml
  • BI.XMLData.OXml


FMXBI.Chart Namespace

Summary

Represents namespace FMXBI.Chart.

Classes
Name | Description
TBIChart | Represents type TBIChart.
TBIChartItems | Represents type TBIChartItems.
TBIChartOptions | Represents type TBIChartOptions.
TCustomSeriesAccess | Represents type TCustomSeriesAccess.
TDataItemAccess | Represents type TDataItemAccess.
TSeriesAccess | Represents type TSeriesAccess.
Top
Enumerations
Name | Description
TBIChart3DMode | Represents type TBIChart3DMode.
TBIChartDimensions | Represents type TBIChartDimensions.
TBIChartLegend | Represents type TBIChartLegend.
TBIChartMarks | Represents type TBIChartMarks.
TBIChartMode | Represents type TBIChartMode.
TBISeriesDirection | Represents type TBISeriesDirection.
Top
Types
Name | Description
TGetText | Represents an alias of the TFunc type.
Top
Constants
Name | Description
LightSilver | Represents constant LightSilver.
Top
Routines
Name | Description
AssociateSeries(TChartSeries,TDataItem) | Represents method AssociateSeries(TChartSeries,TDataItem).
CanBeMeasure(TDataItem) | Represents method CanBeMeasure(TDataItem).
HasMeasures(TDataItem) | Represents method HasMeasures(TDataItem).
IsMeasure(TDataItem) | Represents method IsMeasure(TDataItem).
IsNumericOrDateTime(TDataItem) | Represents method IsNumericOrDateTime(TDataItem).
LastUniqueTable(TDataItem) | Represents method LastUniqueTable(TDataItem).
MapCount(TDataItem) | Represents method MapCount(TDataItem).
Top


FMXBI.Chart Classes

Classes
Name | Description
TBIChart | Represents type TBIChart.
TBIChartItems | Represents type TBIChartItems.
TBIChartOptions | Represents type TBIChartOptions.
TCustomSeriesAccess | Represents type TCustomSeriesAccess.
TDataItemAccess | Represents type TDataItemAccess.
TSeriesAccess | Represents type TSeriesAccess.
Top


TBIChart Class

Summary

Represents type TBIChart.

Namespace: FMXBI.Chart
Inheritance Hierarchy
TLayout
FMXBI.DataControl.TBIDataControl
FMXBI.Chart.TBIChart
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64 or pidOSX32
 or pidiOSSimulator or pidiOSDevice
 or pidAndroid
 or pidiOSDevice64
 )]
 TBIChart=class(TBIDataControl)
 end;

The TBIChart type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIChart class. (Overrides TBIDataControl.Create(TComponent).)
Destroy | Represents the destructor of the TBIChart class. (Overrides TBIDataControl.Destroy.)
Top
Properties
Show:
Name | Description
Chart | Represents property Chart.
Options | Represents property Options.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Clear | Represents method Clear.
DirectRefresh | Represents method DirectRefresh.
ExchangeXY | Represents method ExchangeXY.
ExchangeXZ | Represents method ExchangeXZ.
ExchangeYZ | Represents method ExchangeYZ.
Fill(TDataArray) | Overloaded. Represents method Fill(TDataArray).
Fill(TDataCursor,TDataArray) | Overloaded. Represents method Fill(TDataCursor,TDataArray).
Fill(TDataItems) | Overloaded. Represents method Fill(TDataItems).
Fill(TDataMap,TGetText) | Overloaded. Represents method Fill(TDataMap,TGetText).
Fill(THistogram,TDataItem) | Overloaded. Represents method Fill(THistogram,TDataItem).
Fill(TSummary) | Overloaded. Represents method Fill(TSummary).
GetChildOwner | Represents method GetChildOwner.
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent).
Loaded | Represents method Loaded. (Overrides TBIDataControl.Loaded.)
Paint | Represents method Paint.
ReadState(TReader) | Represents method ReadState(TReader).
ResetTheme | Represents method ResetTheme.
SetDataDirect(TDataItem) | Represents method SetDataDirect(TDataItem). (Overrides TBIDataControl.SetDataDirect(TDataItem).)
SetTwoAxes | Represents method SetTwoAxes.
SplitAxes(Boolean) | Represents method SplitAxes(Boolean).
Top
Fields
Show:
Name | Description
Index | Represents field Index.
RealMode | Represents field RealMode.
RealMode3D | Represents field RealMode3D.
Top
See Also

Reference

  • FMXBI.Chart


TBIChart Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBIChart class. (Overrides TBIDataControl.Create(TComponent).)
Destroy | Represents the destructor of the TBIChart class. (Overrides TBIDataControl.Destroy.)
Top


TBIChart.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIChart class.

Namespace: FMXBI.Chart
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TBIDataControl.Create(TComponent)
See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.Destroy Destructor

Summary

Represents the destructor of the TBIChart class.

Namespace: FMXBI.Chart
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TBIDataControl.Destroy
See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart Properties

Properties
Name | Description
Chart | Represents property Chart.
Options | Represents property Options.
Top


TBIChart.Chart Property

Summary

Represents property Chart.

Namespace: FMXBI.Chart
Syntax
Delphi
published
 property Chart:TBITChart read GetChart;

Property Value

Type: TBITChart

See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.Options Property

Summary

Represents property Options.

Namespace: FMXBI.Chart
Syntax
Delphi
published
 property Options:TBIChartOptions read FOptions write SetOptions;

Property Value

Type: TBIChartOptions

See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Clear | Represents method Clear.
DirectRefresh | Represents method DirectRefresh.
ExchangeXY | Represents method ExchangeXY.
ExchangeXZ | Represents method ExchangeXZ.
ExchangeYZ | Represents method ExchangeYZ.
Fill(TDataArray) | Overloaded. Represents method Fill(TDataArray).
Fill(TDataCursor,TDataArray) | Overloaded. Represents method Fill(TDataCursor,TDataArray).
Fill(TDataItems) | Overloaded. Represents method Fill(TDataItems).
Fill(TDataMap,TGetText) | Overloaded. Represents method Fill(TDataMap,TGetText).
Fill(THistogram,TDataItem) | Overloaded. Represents method Fill(THistogram,TDataItem).
Fill(TSummary) | Overloaded. Represents method Fill(TSummary).
GetChildOwner | Represents method GetChildOwner.
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent).
Loaded | Represents method Loaded. (Overrides TBIDataControl.Loaded.)
Paint | Represents method Paint.
ReadState(TReader) | Represents method ReadState(TReader).
ResetTheme | Represents method ResetTheme.
SetDataDirect(TDataItem) | Represents method SetDataDirect(TDataItem). (Overrides TBIDataControl.SetDataDirect(TDataItem).)
SetTwoAxes | Represents method SetTwoAxes.
SplitAxes(Boolean) | Represents method SplitAxes(Boolean).
Top


TBIChart.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: FMXBI.Chart
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.Clear Method

Summary

Represents method Clear.

Namespace: FMXBI.Chart
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.DirectRefresh Method

Summary

Represents method DirectRefresh.

Namespace: FMXBI.Chart
Syntax
Delphi
protected
 procedure DirectRefresh;
See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.ExchangeXY Method

Summary

Represents method ExchangeXY.

Namespace: FMXBI.Chart
Syntax
Delphi
protected
 procedure ExchangeXY;
See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.ExchangeXZ Method

Summary

Represents method ExchangeXZ.

Namespace: FMXBI.Chart
Syntax
Delphi
protected
 procedure ExchangeXZ;
See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.ExchangeYZ Method

Summary

Represents method ExchangeYZ.

Namespace: FMXBI.Chart
Syntax
Delphi
protected
 procedure ExchangeYZ;
See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.Fill(TDataArray) Method

Summary

Represents method Fill(TDataArray).

Namespace: FMXBI.Chart
Syntax
Delphi
public
 procedure Fill(const AData:TDataArray); overload;

Parameters

AData
Type: TDataArray

See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.Fill(TDataCursor,TDataArray) Method

Summary

Represents method Fill(TDataCursor,TDataArray).

Namespace: FMXBI.Chart
Syntax
Delphi
public
 procedure Fill(const ACursor:TDataCursor; const AItems:TDataArray=nil); overload;

Parameters

ACursor
Type: TDataCursor

AItems
Type: TDataArray

See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.Fill(TDataItems) Method

Summary

Represents method Fill(TDataItems).

Namespace: FMXBI.Chart
Syntax
Delphi
public
 procedure Fill(const AItems:TDataItems); overload;

Parameters

AItems
Type: TDataItems

See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.Fill(TDataMap,TGetText) Method

Summary

Represents method Fill(TDataMap,TGetText).

Namespace: FMXBI.Chart
Syntax
Delphi
public
 procedure Fill(const Map:TDataMap; const Text:TGetText=nil); overload;

Parameters

Map
Type: TDataMap

Text
Type: System.Void

See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.Fill(THistogram,TDataItem) Method

Summary

Represents method Fill(THistogram,TDataItem).

Namespace: FMXBI.Chart
Syntax
Delphi
public
 procedure Fill(const AHistogram:THistogram; const ASource:TDataItem); overload;

Parameters

AHistogram
Type: THistogram

ASource
Type: TDataItem

See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.Fill(TSummary) Method

Summary

Represents method Fill(TSummary).

Namespace: FMXBI.Chart
Syntax
Delphi
public
 procedure Fill(const ASummary:TSummary); overload;

Parameters

ASummary
Type: TSummary

See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.GetChildOwner Method

Summary

Represents method GetChildOwner.

Namespace: FMXBI.Chart
Syntax
Delphi
public
 function GetChildOwner: TComponent; override;

Return Value

Type: TComponent

See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.GetChildren(TGetChildProc,TComponent) Method

Summary

Represents method GetChildren(TGetChildProc,TComponent).

Namespace: FMXBI.Chart
Syntax
Delphi
public
 Procedure GetChildren(Proc:TGetChildProc; Root:TComponent); override;

Parameters

Proc
Type: TGetChildProc

Root
Type: TComponent

See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.Loaded Method

Summary

Represents method Loaded.

Namespace: FMXBI.Chart
Syntax
Delphi
protected
 procedure Loaded; override;

Overrides

TBIDataControl.Loaded
See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.Paint Method

Summary

Represents method Paint.

Namespace: FMXBI.Chart
Syntax
Delphi
protected
 procedure Paint; override;
See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.ReadState(TReader) Method

Summary

Represents method ReadState(TReader).

Namespace: FMXBI.Chart
Syntax
Delphi
protected
 procedure ReadState(Reader: TReader); override;

Parameters

Reader
Type: TReader

See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.ResetTheme Method

Summary

Represents method ResetTheme.

Namespace: FMXBI.Chart
Syntax
Delphi
protected
 procedure ResetTheme;
See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.SetDataDirect(TDataItem) Method

Summary

Represents method SetDataDirect(TDataItem).

Namespace: FMXBI.Chart
Syntax
Delphi
protected
 procedure SetDataDirect(const Value: TDataItem); override;

Parameters

Value
Type: TDataItem

Overrides

TBIDataControl.SetDataDirect(TDataItem)
See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.SetTwoAxes Method

Summary

Represents method SetTwoAxes.

Namespace: FMXBI.Chart
Syntax
Delphi
public
 procedure SetTwoAxes;
See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.SplitAxes(Boolean) Method

Summary

Represents method SplitAxes(Boolean).

Namespace: FMXBI.Chart
Syntax
Delphi
public
 procedure SplitAxes(const Vertical:Boolean);

Parameters

Vertical
Type: Boolean

See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart Fields

Fields
Name | Description
Index | Represents field Index.
RealMode | Represents field RealMode.
RealMode3D | Represents field RealMode3D.
Top


TBIChart.Index Field

Summary

Represents field Index.

Namespace: FMXBI.Chart
Syntax
Delphi
protected
 Index : TCursorIndex;

Field Value

Type: TCursorIndex

See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.RealMode Field

Summary

Represents field RealMode.

Namespace: FMXBI.Chart
Syntax
Delphi
protected
 RealMode : TBIChartMode;

Field Value

Type: TBIChartMode

See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChart.RealMode3D Field

Summary

Represents field RealMode3D.

Namespace: FMXBI.Chart
Syntax
Delphi
protected
 RealMode3D : TBIChart3DMode;

Field Value

Type: TBIChart3DMode

See Also

Reference

  • TBIChart
  • FMXBI.Chart


TBIChartItems Class

Summary

Represents type TBIChartItems.

Namespace: FMXBI.Chart
Inheritance Hierarchy
TPersistent
FMXBI.Chart.TBIChartItems
Syntax
Delphi
type
 TBIChartItems=class(TPersistent)
 end;

The TBIChartItems type exposes the following members.

Methods
Show:
Name | Description
CanFinancial | Represents method CanFinancial.
CanGeoGraphic | Represents method CanGeoGraphic.
CanThreeD | Represents method CanThreeD.
CanXYZ | Represents method CanXYZ.
Clear | Represents method Clear.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Loaded(TDataArray) | Represents method Loaded(TDataArray).
Top
Fields
Show:
Name | Description
Colors | Represents field Colors.
Group | Represents field Group.
Text | Represents field Text.
X | Represents field X.
Y | Represents field Y.
Z | Represents field Z.
Top
See Also

Reference

  • FMXBI.Chart


TBIChartItems Methods

Methods
Name | Description
CanFinancial | Represents method CanFinancial.
CanGeoGraphic | Represents method CanGeoGraphic.
CanThreeD | Represents method CanThreeD.
CanXYZ | Represents method CanXYZ.
Clear | Represents method Clear.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Loaded(TDataArray) | Represents method Loaded(TDataArray).
Top


TBIChartItems.CanFinancial Method

Summary

Represents method CanFinancial.

Namespace: FMXBI.Chart
Syntax
Delphi
public
 function CanFinancial:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TBIChartItems
  • FMXBI.Chart


TBIChartItems.CanGeoGraphic Method

Summary

Represents method CanGeoGraphic.

Namespace: FMXBI.Chart
Syntax
Delphi
public
 function CanGeoGraphic:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TBIChartItems
  • FMXBI.Chart


TBIChartItems.CanThreeD Method

Summary

Represents method CanThreeD.

Namespace: FMXBI.Chart
Syntax
Delphi
public
 function CanThreeD:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TBIChartItems
  • FMXBI.Chart


TBIChartItems.CanXYZ Method

Summary

Represents method CanXYZ.

Namespace: FMXBI.Chart
Syntax
Delphi
public
 function CanXYZ:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TBIChartItems
  • FMXBI.Chart


TBIChartItems.Clear Method

Summary

Represents method Clear.

Namespace: FMXBI.Chart
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TBIChartItems
  • FMXBI.Chart


TBIChartItems.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: FMXBI.Chart
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TBIChartItems
  • FMXBI.Chart


TBIChartItems.Loaded(TDataArray) Method

Summary

Represents method Loaded(TDataArray).

Namespace: FMXBI.Chart
Syntax
Delphi
protected
 procedure Loaded(const AData:TDataArray);

Parameters

AData
Type: TDataArray

See Also

Reference

  • TBIChartItems
  • FMXBI.Chart


TBIChartItems Fields

Fields
Name | Description
Colors | Represents field Colors.
Group | Represents field Group.
Text | Represents field Text.
X | Represents field X.
Y | Represents field Y.
Z | Represents field Z.
Top


TBIChartItems.Colors Field

Summary

Represents field Colors.

Namespace: FMXBI.Chart
Syntax
Delphi
public
 X,
 Z,
 Text,
 Colors,
 Group : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TBIChartItems
  • FMXBI.Chart


TBIChartItems.Group Field

Summary

Represents field Group.

Namespace: FMXBI.Chart
Syntax
Delphi
public
 X,
 Z,
 Text,
 Colors,
 Group : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TBIChartItems
  • FMXBI.Chart


TBIChartItems.Text Field

Summary

Represents field Text.

Namespace: FMXBI.Chart
Syntax
Delphi
public
 X,
 Z,
 Text,
 Colors,
 Group : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TBIChartItems
  • FMXBI.Chart


TBIChartItems.X Field

Summary

Represents field X.

Namespace: FMXBI.Chart
Syntax
Delphi
public
 X,
 Z,
 Text,
 Colors,
 Group : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TBIChartItems
  • FMXBI.Chart


TBIChartItems.Y Field

Summary

Represents field Y.

Namespace: FMXBI.Chart
Syntax
Delphi
public
 Y : TDataArray;

Field Value

Type: TDataArray

See Also

Reference

  • TBIChartItems
  • FMXBI.Chart


TBIChartItems.Z Field

Summary

Represents field Z.

Namespace: FMXBI.Chart
Syntax
Delphi
public
 X,
 Z,
 Text,
 Colors,
 Group : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TBIChartItems
  • FMXBI.Chart


TBIChartOptions Class

Summary

Represents type TBIChartOptions.

Namespace: FMXBI.Chart
Inheritance Hierarchy
TPersistent
FMXBI.Chart.TBIChartOptions
Syntax
Delphi
type
 TBIChartOptions=class(TPersistent)
 end;

The TBIChartOptions type exposes the following members.

Constructors
Show:
Name | Description
Create(TBIChart) | Initializes a new instance of the TBIChartOptions class.
Destroy | Represents the destructor of the TBIChartOptions class.
Top
Properties
Show:
Name | Description
Dimensions | Represents property Dimensions.
Direction | Represents property Direction.
Items | Represents property Items.
Legend | Represents property Legend.
Marks | Represents property Marks.
Mode | Represents property Mode.
Series2D | Represents property Series2D.
Series3D | Represents property Series3D.
SeriesDirection | Represents property SeriesDirection.
Stacked | Represents property Stacked.
XYZMode | Represents property XYZMode.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
ChangeSeries2D(TChartSeriesClass,Boolean,Boolean) | Represents method ChangeSeries2D(TChartSeriesClass,Boolean,Boolean).
Top
See Also

Reference

  • FMXBI.Chart


TBIChartOptions Constructors

Constructors
Name | Description
Create(TBIChart) | Initializes a new instance of the TBIChartOptions class.
Destroy | Represents the destructor of the TBIChartOptions class.
Top


TBIChartOptions.Create(TBIChart) Constructor

Summary

Initializes a new instance of the TBIChartOptions class.

Namespace: FMXBI.Chart
Syntax
Delphi
public
 Constructor Create(const AChart:TBIChart);

Parameters

AChart
Type: TBIChart

See Also

Reference

  • TBIChartOptions
  • FMXBI.Chart


TBIChartOptions.Destroy Destructor

Summary

Represents the destructor of the TBIChartOptions class.

Namespace: FMXBI.Chart
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIChartOptions
  • FMXBI.Chart


TBIChartOptions Properties

Properties
Name | Description
Dimensions | Represents property Dimensions.
Direction | Represents property Direction.
Items | Represents property Items.
Legend | Represents property Legend.
Marks | Represents property Marks.
Mode | Represents property Mode.
Series2D | Represents property Series2D.
Series3D | Represents property Series3D.
SeriesDirection | Represents property SeriesDirection.
Stacked | Represents property Stacked.
XYZMode | Represents property XYZMode.
Top


TBIChartOptions.Dimensions Property

Summary

Represents property Dimensions.

Namespace: FMXBI.Chart
Syntax
Delphi
published
 property Dimensions:TBIChartDimensions read FDimensions write SetDimensions
 default TBIChartDimensions.Automatic;

Property Value

Type: TBIChartDimensions

See Also

Reference

  • TBIChartOptions
  • FMXBI.Chart


TBIChartOptions.Direction Property

Summary

Represents property Direction.

Namespace: FMXBI.Chart
Syntax
Delphi
published
 property Direction:TBIChartDirection read FDirection write SetDirection default TBIChartDirection.Automatic;

Property Value

Type: TBIChartDirection

See Also

Reference

  • TBIChartOptions
  • FMXBI.Chart


TBIChartOptions.Items Property

Summary

Represents property Items.

Namespace: FMXBI.Chart
Syntax
Delphi
published
 property Items:TBIChartItems read FItems write SetItems;

Property Value

Type: TBIChartItems

See Also

Reference

  • TBIChartOptions
  • FMXBI.Chart


TBIChartOptions.Legend Property

Summary

Represents property Legend.

Namespace: FMXBI.Chart
Syntax
Delphi
published
 property Legend:TBIChartLegend read FLegend write SetLegend
 default TBIChartLegend.Automatic;

Property Value

Type: TBIChartLegend

See Also

Reference

  • TBIChartOptions
  • FMXBI.Chart


TBIChartOptions.Marks Property

Summary

Represents property Marks.

Namespace: FMXBI.Chart
Syntax
Delphi
published
 property Marks:TBIChartMarks read FMarks write SetMarks
 default TBIChartMarks.Automatic;

Property Value

Type: TBIChartMarks

See Also

Reference

  • TBIChartOptions
  • FMXBI.Chart


TBIChartOptions.Mode Property

Summary

Represents property Mode.

Namespace: FMXBI.Chart
Syntax
Delphi
published
 property Mode:TBIChartMode read FMode write SetMode default TBIChartMode.Automatic;

Property Value

Type: TBIChartMode

See Also

Reference

  • TBIChartOptions
  • FMXBI.Chart


TBIChartOptions.Series2D Property

Summary

Represents property Series2D.

Namespace: FMXBI.Chart
Syntax
Delphi
public
 property Series2D:TChartSeriesClass read GetSeries2D write SetSeries2D;

Property Value

Type: TChartSeriesClass

See Also

Reference

  • TBIChartOptions
  • FMXBI.Chart


TBIChartOptions.Series3D Property

Summary

Represents property Series3D.

Namespace: FMXBI.Chart
Syntax
Delphi
public
 property Series3D:TChartSeriesClass read GetSeries3D write SetSeries3D;

Property Value

Type: TChartSeriesClass

See Also

Reference

  • TBIChartOptions
  • FMXBI.Chart


TBIChartOptions.SeriesDirection Property

Summary

Represents property SeriesDirection.

Namespace: FMXBI.Chart
Syntax
Delphi
published
 property SeriesDirection: TBISeriesDirection read FSeriesDirection write SetSeriesDirection
 default TBISeriesDirection.Automatic;

Property Value

Type: TBISeriesDirection

See Also

Reference

  • TBIChartOptions
  • FMXBI.Chart


TBIChartOptions.Stacked Property

Summary

Represents property Stacked.

Namespace: FMXBI.Chart
Syntax
Delphi
published
 property Stacked:TBIChartStacked read FStacked write SetStacked
 default TBIChartStacked.Automatic;

Property Value

Type: TBIChartStacked

See Also

Reference

  • TBIChartOptions
  • FMXBI.Chart


TBIChartOptions.XYZMode Property

Summary

Represents property XYZMode.

Namespace: FMXBI.Chart
Syntax
Delphi
published
 property XYZMode:TBIChart3DMode read FXYZMode write SetXYZMode default TBIChart3DMode.Automatic;

Property Value

Type: TBIChart3DMode

See Also

Reference

  • TBIChartOptions
  • FMXBI.Chart


TBIChartOptions Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
ChangeSeries2D(TChartSeriesClass,Boolean,Boolean) | Represents method ChangeSeries2D(TChartSeriesClass,Boolean,Boolean).
Top


TBIChartOptions.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: FMXBI.Chart
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TBIChartOptions
  • FMXBI.Chart


TBIChartOptions.ChangeSeries2D(TChartSeriesClass,Boolean,Boolean) Method

Summary

Represents method ChangeSeries2D(TChartSeriesClass,Boolean,Boolean).

Namespace: FMXBI.Chart
Syntax
Delphi
public
 procedure ChangeSeries2D(const AClass:TChartSeriesClass;
 const AHorizontal,ALinePointer:Boolean);

Parameters

AClass
Type: TChartSeriesClass

AHorizontal
Type: Boolean

ALinePointer
Type: Boolean

See Also

Reference

  • TBIChartOptions
  • FMXBI.Chart


TCustomSeriesAccess Class

Summary

Represents type TCustomSeriesAccess.

Namespace: FMXBI.Chart
Inheritance Hierarchy
TCustomSeries
FMXBI.Chart.TCustomSeriesAccess
Syntax
Delphi
type
 TCustomSeriesAccess=class(TCustomSeries);
See Also

Reference

  • FMXBI.Chart


TDataItemAccess Class

Summary

Represents type TDataItemAccess.

Namespace: FMXBI.Chart
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
FMXBI.Chart.TDataItemAccess
Syntax
Delphi
type
 TDataItemAccess=class(TDataItem);
See Also

Reference

  • FMXBI.Chart


TSeriesAccess Class

Summary

Represents type TSeriesAccess.

Namespace: FMXBI.Chart
Inheritance Hierarchy
TChartSeries
FMXBI.Chart.TSeriesAccess
Syntax
Delphi
type
 TSeriesAccess=class(TChartSeries);
See Also

Reference

  • FMXBI.Chart


FMXBI.Chart Enumerations

Enumerations
Name | Description
TBIChart3DMode | Represents type TBIChart3DMode.
TBIChartDimensions | Represents type TBIChartDimensions.
TBIChartLegend | Represents type TBIChartLegend.
TBIChartMarks | Represents type TBIChartMarks.
TBIChartMode | Represents type TBIChartMode.
TBISeriesDirection | Represents type TBISeriesDirection.
Top


TBIChart3DMode Enumeration

Summary

Represents type TBIChart3DMode.

Namespace: FMXBI.Chart
Syntax
Delphi
type
 TBIChart3DMode=(Automatic, Table, Grid, XYZ);

The TBIChart3DMode type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Grid | Represents constant Grid.
Table | Represents constant Table.
XYZ | Represents constant XYZ.
Top
See Also

Reference

  • FMXBI.Chart


TBIChartDimensions Enumeration

Summary

Represents type TBIChartDimensions.

Namespace: FMXBI.Chart
Syntax
Delphi
type
 TBIChartDimensions=(Automatic, View2D, Orthogonal, View3D);

The TBIChartDimensions type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Orthogonal | Represents constant Orthogonal.
View2D | Represents constant View2D.
View3D | Represents constant View3D.
Top
See Also

Reference

  • FMXBI.Chart


TBIChartLegend Enumeration

Summary

Represents type TBIChartLegend.

Namespace: FMXBI.Chart
Syntax
Delphi
type
 TBIChartLegend=(Automatic, Show, Hide);

The TBIChartLegend type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Hide | Represents constant Hide.
Show | Represents constant Show.
Top
See Also

Reference

  • FMXBI.Chart


TBIChartMarks Enumeration

Summary

Represents type TBIChartMarks.

Namespace: FMXBI.Chart
Syntax
Delphi
type
 TBIChartMarks=(Automatic, Show, Hide);

The TBIChartMarks type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Hide | Represents constant Hide.
Show | Represents constant Show.
Top
See Also

Reference

  • FMXBI.Chart


TBIChartMode Enumeration

Summary

Represents type TBIChartMode.

Namespace: FMXBI.Chart
Syntax
Delphi
type
 TBIChartMode=(Automatic, XY, ThreeD, Financial, Geographic);

The TBIChartMode type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Financial | Represents constant Financial.
Geographic | Represents constant Geographic.
ThreeD | Represents constant ThreeD.
XY | Represents constant XY.
Top
See Also

Reference

  • FMXBI.Chart


TBISeriesDirection Enumeration

Summary

Represents type TBISeriesDirection.

Namespace: FMXBI.Chart
Syntax
Delphi
type
 TBISeriesDirection=(Automatic, Horizontal, Vertical);

The TBISeriesDirection type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Horizontal | Represents constant Horizontal.
Vertical | Represents constant Vertical.
Top
See Also

Reference

  • FMXBI.Chart


FMXBI.Chart Types

Types
Name | Description
TGetText | Represents an alias of the TFunc type.
Top


TGetText Type

Summary

Represents an alias of the TFunc type.

Namespace: FMXBI.Chart
Syntax
Delphi
type
 TGetText=TFunc<Integer,String>;
See Also

Reference

  • FMXBI.Chart


FMXBI.Chart Constants

Constants
Name | Description
LightSilver | Represents constant LightSilver.
Top


LightSilver Constant

Summary

Represents constant LightSilver.

Namespace: FMXBI.Chart
Syntax
Delphi
 LightSilver=$FFE6E6E6;

Value

Type: Cardinal

See Also

Reference

  • FMXBI.Chart


FMXBI.Chart Routines

Routines
Name | Description
AssociateSeries(TChartSeries,TDataItem) | Represents method AssociateSeries(TChartSeries,TDataItem).
CanBeMeasure(TDataItem) | Represents method CanBeMeasure(TDataItem).
HasMeasures(TDataItem) | Represents method HasMeasures(TDataItem).
IsMeasure(TDataItem) | Represents method IsMeasure(TDataItem).
IsNumericOrDateTime(TDataItem) | Represents method IsNumericOrDateTime(TDataItem).
LastUniqueTable(TDataItem) | Represents method LastUniqueTable(TDataItem).
MapCount(TDataItem) | Represents method MapCount(TDataItem).
Top


AssociateSeries(TChartSeries,TDataItem) Method

Summary

Represents method AssociateSeries(TChartSeries,TDataItem).

Namespace: FMXBI.Chart
Syntax
Delphi
procedure AssociateSeries(const ASeries:TChartSeries; const AData:TDataItem);

Parameters

ASeries
Type: TChartSeries

AData
Type: TDataItem

See Also

Reference

  • FMXBI.Chart


CanBeMeasure(TDataItem) Method

Summary

Represents method CanBeMeasure(TDataItem).

Namespace: FMXBI.Chart
Syntax
Delphi
function CanBeMeasure(const ANumeric:TDataItem):Boolean;

Parameters

ANumeric
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • FMXBI.Chart


HasMeasures(TDataItem) Method

Summary

Represents method HasMeasures(TDataItem).

Namespace: FMXBI.Chart
Syntax
Delphi
function HasMeasures(const AData:TDataItem):Boolean;

Parameters

AData
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • FMXBI.Chart


IsMeasure(TDataItem) Method

Summary

Represents method IsMeasure(TDataItem).

Namespace: FMXBI.Chart
Syntax
Delphi
function IsMeasure(const AData:TDataItem):Boolean;

Parameters

AData
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • FMXBI.Chart


IsNumericOrDateTime(TDataItem) Method

Summary

Represents method IsNumericOrDateTime(TDataItem).

Namespace: FMXBI.Chart
Syntax
Delphi
function IsNumericOrDateTime(const AData:TDataItem):Boolean;

Parameters

AData
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • FMXBI.Chart


LastUniqueTable(TDataItem) Method

Summary

Represents method LastUniqueTable(TDataItem).

Namespace: FMXBI.Chart
Syntax
Delphi
function LastUniqueTable(const AData:TDataItem):TDataItem;

Parameters

AData
Type: TDataItem

Return Value

Type: TDataItem

See Also

Reference

  • FMXBI.Chart


MapCount(TDataItem) Method

Summary

Represents method MapCount(TDataItem).

Namespace: FMXBI.Chart
Syntax
Delphi
function MapCount(const AData:TDataItem):TInteger;

Parameters

AData
Type: TDataItem

Return Value

Type: TInteger

See Also

Reference

  • FMXBI.Chart


FMXBI.Chart.Financial Namespace

Summary

Represents namespace FMXBI.Chart.Financial.

Classes
Name | Description
TDataItemAccess | Represents type TDataItemAccess.
Top
Records
Name | Description
TFinancialChart | Represents type TFinancialChart.
TOpenClose | Represents type TOpenClose.
Top
Types
Name | Description
TOHLCSeriesClass | Represents type TOHLCSeriesClass.
Top
Constants
Name | Description
OpenClose | Represents constant OpenClose.
Top
Routines
Name | Description
ContainsText(String,String) | Represents method ContainsText(String,String).
ExistsData(String,TDataArray) | Represents method ExistsData(String,TDataArray).
ReverseDate(String) | Represents method ReverseDate(String).
SwapFloat(TChartValue,TChartValue) | Represents method SwapFloat(TChartValue,TChartValue).
Top


FMXBI.Chart.Financial Classes

Classes
Name | Description
TDataItemAccess | Represents type TDataItemAccess.
Top


TDataItemAccess Class

Summary

Represents type TDataItemAccess.

Namespace: FMXBI.Chart.Financial
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
FMXBI.Chart.Financial.TDataItemAccess
Syntax
Delphi
type
 TDataItemAccess=class(TDataItem);
See Also

Reference

  • FMXBI.Chart.Financial


FMXBI.Chart.Financial Records

Records
Name | Description
TFinancialChart | Represents type TFinancialChart.
TOpenClose | Represents type TOpenClose.
Top


TFinancialChart Record

Summary

Represents type TFinancialChart.

Namespace: FMXBI.Chart.Financial
Syntax
Delphi
type
 TFinancialChart=record
 end;

The TFinancialChart type exposes the following members.

Methods
Show:
Name | Description
CanReuse(TBITChart) | Represents method CanReuse(TBITChart).
Fill(TBITChart,TDataArray,TDataItem) | Represents method Fill(TBITChart,TDataArray,TDataItem).
Guess(TDataArray) | Represents method Guess(TDataArray).
Top
Fields
Show:
Name | Description
SeriesClass | Represents field SeriesClass.
Top
See Also

Reference

  • FMXBI.Chart.Financial


TFinancialChart Methods

Methods
Name | Description
CanReuse(TBITChart) | Represents method CanReuse(TBITChart).
Fill(TBITChart,TDataArray,TDataItem) | Represents method Fill(TBITChart,TDataArray,TDataItem).
Guess(TDataArray) | Represents method Guess(TDataArray).
Top


TFinancialChart.CanReuse(TBITChart) Method

Summary

Represents method CanReuse(TBITChart).

Namespace: FMXBI.Chart.Financial
Syntax
Delphi
public
 class function CanReuse(const AChart:TBITChart):Boolean; static;

Parameters

AChart
Type: TBITChart

Return Value

Type: Boolean

See Also

Reference

  • TFinancialChart
  • FMXBI.Chart.Financial


TFinancialChart.Fill(TBITChart,TDataArray,TDataItem) Method

Summary

Represents method Fill(TBITChart,TDataArray,TDataItem).

Namespace: FMXBI.Chart.Financial
Syntax
Delphi
public
 class procedure Fill(const AChart:TBITChart;
 const AValues:TDataArray;
 const AX:TDataItem); static;

Parameters

AChart
Type: TBITChart

AValues
Type: TDataArray

AX
Type: TDataItem

See Also

Reference

  • TFinancialChart
  • FMXBI.Chart.Financial


TFinancialChart.Guess(TDataArray) Method

Summary

Represents method Guess(TDataArray).

Namespace: FMXBI.Chart.Financial
Syntax
Delphi
public
 class function Guess(const AValues:TDataArray):Boolean; static;

Parameters

AValues
Type: TDataArray

Return Value

Type: Boolean

See Also

Reference

  • TFinancialChart
  • FMXBI.Chart.Financial


TFinancialChart Fields

Fields
Name | Description
SeriesClass | Represents field SeriesClass.
Top


TFinancialChart.SeriesClass Field

Summary

Represents field SeriesClass.

Namespace: FMXBI.Chart.Financial
Syntax
Delphi
public
 class var
 SeriesClass : TOHLCSeriesClass;

Field Value

Type: TOHLCSeriesClass

See Also

Reference

  • TFinancialChart
  • FMXBI.Chart.Financial


TOpenClose Record

Summary

Represents type TOpenClose.

Namespace: FMXBI.Chart.Financial
Syntax
Delphi
type
 TOpenClose=record
 end;

The TOpenClose type exposes the following members.

Fields
Show:
Name | Description
Close | Represents field Close.
Open | Represents field Open.
Top
See Also

Reference

  • FMXBI.Chart.Financial


TOpenClose Fields

Fields
Name | Description
Close | Represents field Close.
Open | Represents field Open.
Top


TOpenClose.Close Field

Summary

Represents field Close.

Namespace: FMXBI.Chart.Financial
Syntax
Delphi
public
 Open,
 Close : String;

Field Value

Type: String

See Also

Reference

  • TOpenClose
  • FMXBI.Chart.Financial


TOpenClose.Open Field

Summary

Represents field Open.

Namespace: FMXBI.Chart.Financial
Syntax
Delphi
public
 Open,
 Close : String;

Field Value

Type: String

See Also

Reference

  • TOpenClose
  • FMXBI.Chart.Financial


FMXBI.Chart.Financial Types

Types
Name | Description
TOHLCSeriesClass | Represents type TOHLCSeriesClass.
Top


TOHLCSeriesClass Type

Summary

Represents type TOHLCSeriesClass.

Namespace: FMXBI.Chart.Financial
Syntax
Delphi
type
 TOHLCSeriesClass=class of TOHLCSeries;
See Also

Reference

  • FMXBI.Chart.Financial


FMXBI.Chart.Financial Constants

Constants
Name | Description
OpenClose | Represents constant OpenClose.
Top


OpenClose Constant

Summary

Represents constant OpenClose.

Namespace: FMXBI.Chart.Financial
Syntax
Delphi
 OpenClose : Array[0..2] of TOpenClose=
 (
 ( Open:'open'; Close:'close'),
 ( Open:'apertura'; Close:'cierre'),
 ( Open:'ouvrir'; Close:'clôture')
 );

Value

Type: Array[0..2] of TOpenClose

See Also

Reference

  • FMXBI.Chart.Financial


FMXBI.Chart.Financial Routines

Routines
Name | Description
ContainsText(String,String) | Represents method ContainsText(String,String).
ExistsData(String,TDataArray) | Represents method ExistsData(String,TDataArray).
ReverseDate(String) | Represents method ReverseDate(String).
SwapFloat(TChartValue,TChartValue) | Represents method SwapFloat(TChartValue,TChartValue).
Top


ContainsText(String,String) Method

Summary

Represents method ContainsText(String,String).

Namespace: FMXBI.Chart.Financial
Syntax
Delphi
function ContainsText(const Big,Small:String):Boolean;

Parameters

Big
Type: String

Small
Type: String

Return Value

Type: Boolean

See Also

Reference

  • FMXBI.Chart.Financial


ExistsData(String,TDataArray) Method

Summary

Represents method ExistsData(String,TDataArray).

Namespace: FMXBI.Chart.Financial
Syntax
Delphi
function ExistsData(const AName:String; const AData:TDataArray):TDataItem;

Parameters

AName
Type: String

AData
Type: TDataArray

Return Value

Type: TDataItem

See Also

Reference

  • FMXBI.Chart.Financial


ReverseDate(String) Method

Summary

Represents method ReverseDate(String).

Namespace: FMXBI.Chart.Financial
Syntax
Delphi
function ReverseDate(const S:String):String;

Parameters

S
Type: String

Return Value

Type: String

See Also

Reference

  • FMXBI.Chart.Financial


SwapFloat(TChartValue,TChartValue) Method

Summary

Represents method SwapFloat(TChartValue,TChartValue).

Namespace: FMXBI.Chart.Financial
Syntax
Delphi
procedure SwapFloat(var A,B:TChartValue);

Parameters

A
Type: TChartValue

B
Type: TChartValue

See Also

Reference

  • FMXBI.Chart.Financial


FMXBI.Chart.Geo Namespace

Summary

Represents namespace FMXBI.Chart.Geo.

Classes
Name | Description
TChartSeriesAccess | Represents type TChartSeriesAccess.
TDataAccess | Represents type TDataAccess.
TEntityMapsHelper | Represents type TEntityMapsHelper.
Top
Records
Name | Description
TEntityMap | Represents type TEntityMap.
TGeoChart | Represents type TGeoChart.
TGeoContext | Represents type TGeoContext.
Top
Types
Name | Description
TEntityMaps | Represents an array of the TEntityMap type.
Top
Variables
Name | Description
IEntityMaps | Represents variable IEntityMaps.
Top
Routines
Name | Description
ContainsAlaskaHawaii(TDataItem,Boolean) | Represents method ContainsAlaskaHawaii(TDataItem,Boolean).
FillPolygons(TWorldSeries,TDataItem,TDataItem,Boolean,Boolean) | Represents method FillPolygons(TWorldSeries,TDataItem,TDataItem,Boolean,Boolean).
FindMapEntities(TDataItem,TGeoContext) | Represents method FindMapEntities(TDataItem,TGeoContext).
SetAllNull(TChartSeries) | Represents method SetAllNull(TChartSeries).
Top


FMXBI.Chart.Geo Classes

Classes
Name | Description
TChartSeriesAccess | Represents type TChartSeriesAccess.
TDataAccess | Represents type TDataAccess.
TEntityMapsHelper | Represents type TEntityMapsHelper.
Top


TChartSeriesAccess Class

Summary

Represents type TChartSeriesAccess.

Namespace: FMXBI.Chart.Geo
Inheritance Hierarchy
TChartSeries
FMXBI.Chart.Geo.TChartSeriesAccess
Syntax
Delphi
type
 TChartSeriesAccess=class(TChartSeries);
See Also

Reference

  • FMXBI.Chart.Geo


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: FMXBI.Chart.Geo
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
FMXBI.Chart.Geo.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • FMXBI.Chart.Geo


TEntityMapsHelper Class Helper

Summary

Represents type TEntityMapsHelper.

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
type
 TEntityMapsHelper=record helper for TEntityMaps
 end;
Methods
Name | Description
Add(TWorldMap,TEntity,Boolean) | Represents method Add(TWorldMap,TEntity,Boolean).
AddMulti(TWorldMap,TEntity,Boolean) | Represents method AddMulti(TWorldMap,TEntity,Boolean).
Count | Represents method Count.
Top
See Also

Reference

  • FMXBI.Chart.Geo


TEntityMapsHelper Methods

Methods
Name | Description
Add(TWorldMap,TEntity,Boolean) | Represents method Add(TWorldMap,TEntity,Boolean).
AddMulti(TWorldMap,TEntity,Boolean) | Represents method AddMulti(TWorldMap,TEntity,Boolean).
Count | Represents method Count.
Top


TEntityMapsHelper.Add(TWorldMap,TEntity,Boolean) Method

Summary

Represents method Add(TWorldMap,TEntity,Boolean).

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
public
 procedure Add(const AMap:TWorldMap;
 const AEntity:TEntity;
 const UseSynonyms:Boolean=False);

Parameters

AMap
Type: TWorldMap

AEntity
Type: TEntity

UseSynonyms
Type: Boolean

See Also

Reference

  • TEntityMapsHelper
  • FMXBI.Chart.Geo


TEntityMapsHelper.AddMulti(TWorldMap,TEntity,Boolean) Method

Summary

Represents method AddMulti(TWorldMap,TEntity,Boolean).

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
public
 procedure AddMulti(const AMap:TWorldMap;
 const AEntity:TEntity;
 const UseSynonyms:Boolean=False);

Parameters

AMap
Type: TWorldMap

AEntity
Type: TEntity

UseSynonyms
Type: Boolean

See Also

Reference

  • TEntityMapsHelper
  • FMXBI.Chart.Geo


TEntityMapsHelper.Count Method

Summary

Represents method Count.

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
public
 function Count:Integer; inline;

Return Value

Type: Integer

See Also

Reference

  • TEntityMapsHelper
  • FMXBI.Chart.Geo


FMXBI.Chart.Geo Records

Records
Name | Description
TEntityMap | Represents type TEntityMap.
TGeoChart | Represents type TGeoChart.
TGeoContext | Represents type TGeoContext.
Top


TEntityMap Record

Summary

Represents type TEntityMap.

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
type
 TEntityMap=record
 end;

The TEntityMap type exposes the following members.

Fields
Show:
Name | Description
Entity | Represents field Entity.
IsMulti | Represents field IsMulti.
Map | Represents field Map.
Synonyms | Represents field Synonyms.
Top
See Also

Reference

  • FMXBI.Chart.Geo


TEntityMap Fields

Fields
Name | Description
Entity | Represents field Entity.
IsMulti | Represents field IsMulti.
Map | Represents field Map.
Synonyms | Represents field Synonyms.
Top


TEntityMap.Entity Field

Summary

Represents field Entity.

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
public
 Entity : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntityMap
  • FMXBI.Chart.Geo


TEntityMap.IsMulti Field

Summary

Represents field IsMulti.

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
public
 IsMulti,
 Synonyms : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TEntityMap
  • FMXBI.Chart.Geo


TEntityMap.Map Field

Summary

Represents field Map.

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
public
 Map : TWorldMap;

Field Value

Type: TWorldMap

See Also

Reference

  • TEntityMap
  • FMXBI.Chart.Geo


TEntityMap.Synonyms Field

Summary

Represents field Synonyms.

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
public
 IsMulti,
 Synonyms : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TEntityMap
  • FMXBI.Chart.Geo


TGeoChart Record

Summary

Represents type TGeoChart.

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
type
 TGeoChart=record
 end;

The TGeoChart type exposes the following members.

Methods
Show:
Name | Description
CanReuse(TBITChart,TGeoContext) | Represents method CanReuse(TBITChart,TGeoContext).
Fill(TBITChart,TDataItem,TDataItem,TGeoContext) | Represents method Fill(TBITChart,TDataItem,TDataItem,TGeoContext).
Guess(TDataItem,TDataItem,TGeoContext) | Represents method Guess(TDataItem,TDataItem,TGeoContext).
Top
See Also

Reference

  • FMXBI.Chart.Geo


TGeoChart Methods

Methods
Name | Description
CanReuse(TBITChart,TGeoContext) | Represents method CanReuse(TBITChart,TGeoContext).
Fill(TBITChart,TDataItem,TDataItem,TGeoContext) | Represents method Fill(TBITChart,TDataItem,TDataItem,TGeoContext).
Guess(TDataItem,TDataItem,TGeoContext) | Represents method Guess(TDataItem,TDataItem,TGeoContext).
Top


TGeoChart.CanReuse(TBITChart,TGeoContext) Method

Summary

Represents method CanReuse(TBITChart,TGeoContext).

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
public
 class function CanReuse(const AChart:TBITChart;
 const AContext:TGeoContext):Boolean; static;

Parameters

AChart
Type: TBITChart

AContext
Type: TGeoContext

Return Value

Type: Boolean

See Also

Reference

  • TGeoChart
  • FMXBI.Chart.Geo


TGeoChart.Fill(TBITChart,TDataItem,TDataItem,TGeoContext) Method

Summary

Represents method Fill(TBITChart,TDataItem,TDataItem,TGeoContext).

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
public
 class procedure Fill(const AChart:TBITChart;
 const AValues,AText:TDataItem;
 const AContext:TGeoContext); static;

Parameters

AChart
Type: TBITChart

AValues
Type: TDataItem

AText
Type: TDataItem

AContext
Type: TGeoContext

See Also

Reference

  • TGeoChart
  • FMXBI.Chart.Geo


TGeoChart.Guess(TDataItem,TDataItem,TGeoContext) Method

Summary

Represents method Guess(TDataItem,TDataItem,TGeoContext).

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
public
 class function Guess(const X,Text:TDataItem;
 out AContext:TGeoContext):Boolean; static;

Parameters

X
Type: TDataItem

Text
Type: TDataItem

AContext
Type: TGeoContext

Return Value

Type: Boolean

See Also

Reference

  • TGeoChart
  • FMXBI.Chart.Geo


TGeoContext Record

Summary

Represents type TGeoContext.

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
type
 TGeoContext=record
 end;

The TGeoContext type exposes the following members.

Fields
Show:
Name | Description
ByCode | Represents field ByCode.
IsMulti | Represents field IsMulti.
Map | Represents field Map.
Top
See Also

Reference

  • FMXBI.Chart.Geo


TGeoContext Fields

Fields
Name | Description
ByCode | Represents field ByCode.
IsMulti | Represents field IsMulti.
Map | Represents field Map.
Top


TGeoContext.ByCode Field

Summary

Represents field ByCode.

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
public
 ByCode,
 IsMulti : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TGeoContext
  • FMXBI.Chart.Geo


TGeoContext.IsMulti Field

Summary

Represents field IsMulti.

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
public
 ByCode,
 IsMulti : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TGeoContext
  • FMXBI.Chart.Geo


TGeoContext.Map Field

Summary

Represents field Map.

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
public
 Map : TWorldMap;

Field Value

Type: TWorldMap

See Also

Reference

  • TGeoContext
  • FMXBI.Chart.Geo


FMXBI.Chart.Geo Types

Types
Name | Description
TEntityMaps | Represents an array of the TEntityMap type.
Top


TEntityMaps Type

Summary

Represents an array of the TEntityMap type.

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
type
 TEntityMaps=Array of TEntityMap;
See Also

Reference

  • FMXBI.Chart.Geo


FMXBI.Chart.Geo Variables

Variables
Name | Description
IEntityMaps | Represents variable IEntityMaps.
Top


IEntityMaps Variable

Summary

Represents variable IEntityMaps.

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
IEntityMaps:TEntityMaps=nil;

Value

Type: TEntityMaps

See Also

Reference

  • FMXBI.Chart.Geo


FMXBI.Chart.Geo Routines

Routines
Name | Description
ContainsAlaskaHawaii(TDataItem,Boolean) | Represents method ContainsAlaskaHawaii(TDataItem,Boolean).
FillPolygons(TWorldSeries,TDataItem,TDataItem,Boolean,Boolean) | Represents method FillPolygons(TWorldSeries,TDataItem,TDataItem,Boolean,Boolean).
FindMapEntities(TDataItem,TGeoContext) | Represents method FindMapEntities(TDataItem,TGeoContext).
SetAllNull(TChartSeries) | Represents method SetAllNull(TChartSeries).
Top


ContainsAlaskaHawaii(TDataItem,Boolean) Method

Summary

Represents method ContainsAlaskaHawaii(TDataItem,Boolean).

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
function ContainsAlaskaHawaii(const Text:TDataItem; const ByCode:Boolean):Boolean;

Parameters

Text
Type: TDataItem

ByCode
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • FMXBI.Chart.Geo


FillPolygons(TWorldSeries,TDataItem,TDataItem,Boolean,Boolean) Method

Summary

Represents method FillPolygons(TWorldSeries,TDataItem,TDataItem,Boolean,Boolean).

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
procedure FillPolygons(const ASeries:TWorldSeries; const AData,AEntity:TDataItem; const ByCode,IsMulti:Boolean);

Parameters

ASeries
Type: TWorldSeries

AData
Type: TDataItem

AEntity
Type: TDataItem

ByCode
Type: Boolean

IsMulti
Type: Boolean

See Also

Reference

  • FMXBI.Chart.Geo


FindMapEntities(TDataItem,TGeoContext) Method

Summary

Represents method FindMapEntities(TDataItem,TGeoContext).

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
function FindMapEntities(const Text:TDataItem; out AContext:TGeoContext):Boolean;

Parameters

Text
Type: TDataItem

AContext
Type: TGeoContext

Return Value

Type: Boolean

See Also

Reference

  • FMXBI.Chart.Geo


SetAllNull(TChartSeries) Method

Summary

Represents method SetAllNull(TChartSeries).

Namespace: FMXBI.Chart.Geo
Syntax
Delphi
procedure SetAllNull(const ASeries:TChartSeries);

Parameters

ASeries
Type: TChartSeries

See Also

Reference

  • FMXBI.Chart.Geo


FMXBI.Chart.Plugin Namespace

Summary

Represents namespace FMXBI.Chart.Plugin.

Classes
Name | Description
TBIDataControlAccess | Represents type TBIDataControlAccess.
TBITChart | Represents type TBITChart.
TDataAccess | Represents type TDataAccess.
TLabelsListAccess | Represents type TLabelsListAccess.
TSeriesAccess | Represents type TSeriesAccess.
Top
Records
Name | Description
TArrayToValues | Represents type TArrayToValues.
TChartData | Represents type TChartData.
Top
Enumerations
Name | Description
TBIChartDirection | Represents type TBIChartDirection.
TBIChartStacked | Represents type TBIChartStacked.
Top
Constants
Name | Description
WhiteColor | Represents constant WhiteColor.
Top
Routines
Name | Description
AddLabels(TChartSeries,TDataItem) | Represents method AddLabels(TChartSeries,TDataItem).
CopyData(TChartValueList,TDataItem) | Represents method CopyData(TChartValueList,TDataItem).
FixDesignTime(TChartSeries) | Represents method FixDesignTime(TChartSeries).
Top


FMXBI.Chart.Plugin Classes

Classes
Name | Description
TBIDataControlAccess | Represents type TBIDataControlAccess.
TBITChart | Represents type TBITChart.
TDataAccess | Represents type TDataAccess.
TLabelsListAccess | Represents type TLabelsListAccess.
TSeriesAccess | Represents type TSeriesAccess.
Top


TBIDataControlAccess Class

Summary

Represents type TBIDataControlAccess.

Namespace: FMXBI.Chart.Plugin
Inheritance Hierarchy
TLayout
FMXBI.DataControl.TBIDataControl
FMXBI.Chart.Plugin.TBIDataControlAccess
Syntax
Delphi
type
 TBIDataControlAccess=class(TBIDataControl);
See Also

Reference

  • FMXBI.Chart.Plugin


TBITChart Class

Summary

Represents type TBITChart.

Namespace: FMXBI.Chart.Plugin
Inheritance Hierarchy
TChart
FMXBI.Chart.Plugin.TBITChart
Syntax
Delphi
type
 TBITChart=class(TChart)
 end;

The TBITChart type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBITChart class.
Top
Properties
Show:
Name | Description
Align | Represents property Align.
BevelOuter | Represents property BevelOuter.
Color | Represents property Color.
Series2D | Represents property Series2D.
Series3D | Represents property Series3D.
View3D | Represents property View3D.
Top
Methods
Show:
Name | Description
AddLine(TChartAxis) | Represents method AddLine(TChartAxis).
ChangeSeries2D(TChartSeriesClass,Boolean,Boolean) | Represents method ChangeSeries2D(TChartSeriesClass,Boolean,Boolean).
ClearTitles | Represents method ClearTitles.
CreateMulti2D(TDataItem,TDataItem,TDataItem,TBIChartDirection) | Represents method CreateMulti2D(TDataItem,TDataItem,TDataItem,TBIChartDirection).
Fill(TDataArray,TDataItem) | Overloaded. Represents method Fill(TDataArray,TDataItem).
Fill(TDataItem) | Overloaded. Represents method Fill(TDataItem).
Fill(TDataSet,Integer,Integer) | Overloaded. Represents method Fill(TDataSet,Integer,Integer).
Fill(TDoubleArray) | Overloaded. Represents method Fill(TDoubleArray).
Fill(TInt32Array) | Overloaded. Represents method Fill(TInt32Array).
Fill(TInt64Array) | Overloaded. Represents method Fill(TInt64Array).
FillXY(TDataSet,Integer,Integer) | Overloaded. Represents method FillXY(TDataSet,Integer,Integer).
FillXY(TField,TField) | Overloaded. Represents method FillXY(TField,TField).
FinishViewDimensions | Represents method FinishViewDimensions.
GetParentComponent | Represents method GetParentComponent.
GetValue(TDataItem,TInteger) | Represents method GetValue(TDataItem,TInteger).
HasParent | Represents method HasParent.
Init(Boolean) | Represents method Init(Boolean).
NewSeries(Integer) | Overloaded. Represents method NewSeries(Integer).
NewSeries(String,String) | Overloaded. Represents method NewSeries(String,String).
NewSeries(TChartSeriesClass) | Overloaded. Represents method NewSeries(TChartSeriesClass).
ReadState(TReader) | Represents method ReadState(TReader).
SetAxesTitles(TChartSeries,String,String) | Represents method SetAxesTitles(TChartSeries,String,String).
SetParentComponent(TComponent) | Represents method SetParentComponent(TComponent).
ShowHideAxesWalls(Boolean) | Represents method ShowHideAxesWalls(Boolean).
TrySetName(TComponent,String) | Represents method TrySetName(TComponent,String).
Top
Fields
Show:
Name | Description
DefaultXYSeries | Represents field DefaultXYSeries.
FourItemSeries | Represents field FourItemSeries.
FSeries2D | Represents field FSeries2D.
FSeries3D | Represents field FSeries3D.
LinePointer | Represents field LinePointer.
Three3DSeries | Represents field Three3DSeries.
Top
See Also

Reference

  • FMXBI.Chart.Plugin


TBITChart Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBITChart class.
Top


TBITChart.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBITChart class.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart Properties

Properties
Name | Description
Align | Represents property Align.
BevelOuter | Represents property BevelOuter.
Color | Represents property Color.
Series2D | Represents property Series2D.
Series3D | Represents property Series3D.
View3D | Represents property View3D.
Top


TBITChart.Align Property

Summary

Represents property Align.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
published
 property Align default TUICommon.AlignClient;

Property Value

Type: Void

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.BevelOuter Property

Summary

Represents property BevelOuter.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
published
 property BevelOuter default bvNone;

Property Value

Type: Void

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.Color Property

Summary

Represents property Color.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
published
 property Color default WhiteColor;

Property Value

Type: Void

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.Series2D Property

Summary

Represents property Series2D.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 property Series2D:TChartSeriesClass read FSeries2D write FSeries2D;

Property Value

Type: TChartSeriesClass

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.Series3D Property

Summary

Represents property Series3D.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 property Series3D:TChartSeriesClass read FSeries3D write FSeries3D;

Property Value

Type: TChartSeriesClass

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.View3D Property

Summary

Represents property View3D.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
published
 property View3D default False;

Property Value

Type: Void

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart Methods

Methods
Name | Description
AddLine(TChartAxis) | Represents method AddLine(TChartAxis).
ChangeSeries2D(TChartSeriesClass,Boolean,Boolean) | Represents method ChangeSeries2D(TChartSeriesClass,Boolean,Boolean).
ClearTitles | Represents method ClearTitles.
CreateMulti2D(TDataItem,TDataItem,TDataItem,TBIChartDirection) | Represents method CreateMulti2D(TDataItem,TDataItem,TDataItem,TBIChartDirection).
Fill(TDataArray,TDataItem) | Overloaded. Represents method Fill(TDataArray,TDataItem).
Fill(TDataItem) | Overloaded. Represents method Fill(TDataItem).
Fill(TDataSet,Integer,Integer) | Overloaded. Represents method Fill(TDataSet,Integer,Integer).
Fill(TDoubleArray) | Overloaded. Represents method Fill(TDoubleArray).
Fill(TInt32Array) | Overloaded. Represents method Fill(TInt32Array).
Fill(TInt64Array) | Overloaded. Represents method Fill(TInt64Array).
FillXY(TDataSet,Integer,Integer) | Overloaded. Represents method FillXY(TDataSet,Integer,Integer).
FillXY(TField,TField) | Overloaded. Represents method FillXY(TField,TField).
FinishViewDimensions | Represents method FinishViewDimensions.
GetParentComponent | Represents method GetParentComponent.
GetValue(TDataItem,TInteger) | Represents method GetValue(TDataItem,TInteger).
HasParent | Represents method HasParent.
Init(Boolean) | Represents method Init(Boolean).
NewSeries(Integer) | Overloaded. Represents method NewSeries(Integer).
NewSeries(String,String) | Overloaded. Represents method NewSeries(String,String).
NewSeries(TChartSeriesClass) | Overloaded. Represents method NewSeries(TChartSeriesClass).
ReadState(TReader) | Represents method ReadState(TReader).
SetAxesTitles(TChartSeries,String,String) | Represents method SetAxesTitles(TChartSeries,String,String).
SetParentComponent(TComponent) | Represents method SetParentComponent(TComponent).
ShowHideAxesWalls(Boolean) | Represents method ShowHideAxesWalls(Boolean).
TrySetName(TComponent,String) | Represents method TrySetName(TComponent,String).
Top


TBITChart.AddLine(TChartAxis) Method

Summary

Represents method AddLine(TChartAxis).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 procedure AddLine(const Axis:TChartAxis);

Parameters

Axis
Type: TChartAxis

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.ChangeSeries2D(TChartSeriesClass,Boolean,Boolean) Method

Summary

Represents method ChangeSeries2D(TChartSeriesClass,Boolean,Boolean).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 procedure ChangeSeries2D(const AClass: TChartSeriesClass;
 const AHorizontal, ALinePointer: Boolean);

Parameters

AClass
Type: TChartSeriesClass

AHorizontal
Type: Boolean

ALinePointer
Type: Boolean

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.ClearTitles Method

Summary

Represents method ClearTitles.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 procedure ClearTitles;
See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.CreateMulti2D(TDataItem,TDataItem,TDataItem,TBIChartDirection) Method

Summary

Represents method CreateMulti2D(TDataItem,TDataItem,TDataItem,TBIChartDirection).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 procedure CreateMulti2D(const X,Y,Z:TDataItem; const ADirection:TBIChartDirection);

Parameters

X
Type: TDataItem

Y
Type: TDataItem

Z
Type: TDataItem

ADirection
Type: TBIChartDirection

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.Fill(TDataArray,TDataItem) Method

Summary

Represents method Fill(TDataArray,TDataItem).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 procedure Fill(const AData:TDataArray; const ASeries: TDataItem); overload;

Parameters

AData
Type: TDataArray

ASeries
Type: TDataItem

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.Fill(TDataItem) Method

Summary

Represents method Fill(TDataItem).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 function Fill(const AData:TDataItem):TChartSeries; overload;

Parameters

AData
Type: TDataItem

Return Value

Type: TChartSeries

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.Fill(TDataSet,Integer,Integer) Method

Summary

Represents method Fill(TDataSet,Integer,Integer).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 procedure Fill(const AData:TDataSet; const ValueField:Integer; const TextField:Integer=-1); overload;

Parameters

AData
Type: TDataSet

ValueField
Type: Integer

TextField
Type: Integer

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.Fill(TDoubleArray) Method

Summary

Represents method Fill(TDoubleArray).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 function Fill(const AData:BI.Arrays.TDoubleArray):TChartSeries; overload;

Parameters

AData
Type: BI.Arrays.TDoubleArray

Return Value

Type: TChartSeries

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.Fill(TInt32Array) Method

Summary

Represents method Fill(TInt32Array).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 function Fill(const AData:TInt32Array):TChartSeries; overload;

Parameters

AData
Type: TInt32Array

Return Value

Type: TChartSeries

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.Fill(TInt64Array) Method

Summary

Represents method Fill(TInt64Array).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 function Fill(const AData:TInt64Array):TChartSeries; overload;

Parameters

AData
Type: TInt64Array

Return Value

Type: TChartSeries

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.FillXY(TDataSet,Integer,Integer) Method

Summary

Represents method FillXY(TDataSet,Integer,Integer).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 function FillXY(const AData:TDataSet; const X,Y:Integer):TChartSeries; overload;

Parameters

AData
Type: TDataSet

X
Type: Integer

Y
Type: Integer

Return Value

Type: TChartSeries

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.FillXY(TField,TField) Method

Summary

Represents method FillXY(TField,TField).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 function FillXY(const X,Y:TField):TChartSeries; overload;

Parameters

X
Type: TField

Y
Type: TField

Return Value

Type: TChartSeries

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.FinishViewDimensions Method

Summary

Represents method FinishViewDimensions.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 procedure FinishViewDimensions;
See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.GetParentComponent Method

Summary

Represents method GetParentComponent.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 Function GetParentComponent: TComponent; override;

Return Value

Type: TComponent

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.GetValue(TDataItem,TInteger) Method

Summary

Represents method GetValue(TDataItem,TInteger).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 class function GetValue(const AData:TDataItem; const Index:TInteger):TChartValue; static;

Parameters

AData
Type: TDataItem

Index
Type: System.Void

Return Value

Type: TChartValue

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.HasParent Method

Summary

Represents method HasParent.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 Function HasParent:Boolean; override;

Return Value

Type: Boolean

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.Init(Boolean) Method

Summary

Represents method Init(Boolean).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 procedure Init(const FreeSeries:Boolean);

Parameters

FreeSeries
Type: Boolean

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.NewSeries(Integer) Method

Summary

Represents method NewSeries(Integer).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 function NewSeries(const Count:Integer):TChartSeries; overload;

Parameters

Count
Type: Integer

Return Value

Type: TChartSeries

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.NewSeries(String,String) Method

Summary

Represents method NewSeries(String,String).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 function NewSeries(const X,Y:String):TChartSeries; overload;

Parameters

X
Type: String

Y
Type: String

Return Value

Type: TChartSeries

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.NewSeries(TChartSeriesClass) Method

Summary

Represents method NewSeries(TChartSeriesClass).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 function NewSeries(const AClass:TChartSeriesClass):TChartSeries; overload;

Parameters

AClass
Type: TChartSeriesClass

Return Value

Type: TChartSeries

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.ReadState(TReader) Method

Summary

Represents method ReadState(TReader).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
protected
 procedure ReadState(Reader: TReader); override;

Parameters

Reader
Type: TReader

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.SetAxesTitles(TChartSeries,String,String) Method

Summary

Represents method SetAxesTitles(TChartSeries,String,String).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 class procedure SetAxesTitles(const ASeries:TChartSeries; const X,Y:String); static;

Parameters

ASeries
Type: TChartSeries

X
Type: String

Y
Type: String

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.SetParentComponent(TComponent) Method

Summary

Represents method SetParentComponent(TComponent).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 procedure SetParentComponent(AParent: TComponent); override;

Parameters

AParent
Type: TComponent

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.ShowHideAxesWalls(Boolean) Method

Summary

Represents method ShowHideAxesWalls(Boolean).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 procedure ShowHideAxesWalls(const AVisible:Boolean);

Parameters

AVisible
Type: Boolean

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.TrySetName(TComponent,String) Method

Summary

Represents method TrySetName(TComponent,String).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 class procedure TrySetName(const AComponent:TComponent; const APrefix:String); static;

Parameters

AComponent
Type: TComponent

APrefix
Type: String

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart Fields

Fields
Name | Description
DefaultXYSeries | Represents field DefaultXYSeries.
FourItemSeries | Represents field FourItemSeries.
FSeries2D | Represents field FSeries2D.
FSeries3D | Represents field FSeries3D.
LinePointer | Represents field LinePointer.
Three3DSeries | Represents field Three3DSeries.
Top


TBITChart.DefaultXYSeries Field

Summary

Represents field DefaultXYSeries.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
protected
 DefaultXYSeries : TChartSeriesClass;

Field Value

Type: TChartSeriesClass

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.FourItemSeries Field

Summary

Represents field FourItemSeries.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 class var
 FourItemSeries,
 Three3DSeries : TChartSeriesClass;

Field Value

Type: TChartSeriesClass

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.FSeries2D Field

Summary

Represents field FSeries2D.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
protected
 FSeries2D : TChartSeriesClass;

Field Value

Type: TChartSeriesClass

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.FSeries3D Field

Summary

Represents field FSeries3D.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
protected
 FSeries3D : TChartSeriesClass;

Field Value

Type: TChartSeriesClass

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.LinePointer Field

Summary

Represents field LinePointer.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
protected
 LinePointer : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TBITChart.Three3DSeries Field

Summary

Represents field Three3DSeries.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 class var
 FourItemSeries,
 Three3DSeries : TChartSeriesClass;

Field Value

Type: TChartSeriesClass

See Also

Reference

  • TBITChart
  • FMXBI.Chart.Plugin


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: FMXBI.Chart.Plugin
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
FMXBI.Chart.Plugin.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • FMXBI.Chart.Plugin


TLabelsListAccess Class

Summary

Represents type TLabelsListAccess.

Namespace: FMXBI.Chart.Plugin
Inheritance Hierarchy
TLabelsList
FMXBI.Chart.Plugin.TLabelsListAccess
Syntax
Delphi
type
 TLabelsListAccess=class(TLabelsList);
See Also

Reference

  • FMXBI.Chart.Plugin


TSeriesAccess Class

Summary

Represents type TSeriesAccess.

Namespace: FMXBI.Chart.Plugin
Inheritance Hierarchy
TChartSeries
FMXBI.Chart.Plugin.TSeriesAccess
Syntax
Delphi
type
 TSeriesAccess=class(TChartSeries);
See Also

Reference

  • FMXBI.Chart.Plugin


FMXBI.Chart.Plugin Records

Records
Name | Description
TArrayToValues | Represents type TArrayToValues.
TChartData | Represents type TChartData.
Top


TArrayToValues Record

Summary

Represents type TArrayToValues.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
type
 TArrayToValues=record
 end;

The TArrayToValues type exposes the following members.

Methods
Show:
Name | Description
From(TDataItem) | Overloaded. Represents method From(TDataItem).
From(TExtendedArray) | Overloaded. Represents method From(TExtendedArray).
From(TInt32Array) | Overloaded. Represents method From(TInt32Array).
From(TInt64Array) | Overloaded. Represents method From(TInt64Array).
From(TSingleArray) | Overloaded. Represents method From(TSingleArray).
Top
See Also

Reference

  • FMXBI.Chart.Plugin


TArrayToValues Methods

Methods
Name | Description
From(TDataItem) | Overloaded. Represents method From(TDataItem).
From(TExtendedArray) | Overloaded. Represents method From(TExtendedArray).
From(TInt32Array) | Overloaded. Represents method From(TInt32Array).
From(TInt64Array) | Overloaded. Represents method From(TInt64Array).
From(TSingleArray) | Overloaded. Represents method From(TSingleArray).
Top


TArrayToValues.From(TDataItem) Method

Summary

Represents method From(TDataItem).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 class function From(const AItem:TDataItem):TChartValues; overload; static;

Parameters

AItem
Type: TDataItem

Return Value

Type: TChartValues

See Also

Reference

  • TArrayToValues
  • FMXBI.Chart.Plugin


TArrayToValues.From(TExtendedArray) Method

Summary

Represents method From(TExtendedArray).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 class function From(const AData:TExtendedArray):TChartValues; overload; static;

Parameters

AData
Type: TExtendedArray

Return Value

Type: TChartValues

See Also

Reference

  • TArrayToValues
  • FMXBI.Chart.Plugin


TArrayToValues.From(TInt32Array) Method

Summary

Represents method From(TInt32Array).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 class function From(const AData:TInt32Array):TChartValues; overload; static;

Parameters

AData
Type: TInt32Array

Return Value

Type: TChartValues

See Also

Reference

  • TArrayToValues
  • FMXBI.Chart.Plugin


TArrayToValues.From(TInt64Array) Method

Summary

Represents method From(TInt64Array).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 class function From(const AData:TInt64Array):TChartValues; overload; static;

Parameters

AData
Type: TInt64Array

Return Value

Type: TChartValues

See Also

Reference

  • TArrayToValues
  • FMXBI.Chart.Plugin


TArrayToValues.From(TSingleArray) Method

Summary

Represents method From(TSingleArray).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 class function From(const AData:TSingleArray):TChartValues; overload; static;

Parameters

AData
Type: TSingleArray

Return Value

Type: TChartValues

See Also

Reference

  • TArrayToValues
  • FMXBI.Chart.Plugin


TChartData Record

Summary

Represents type TChartData.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
type
 TChartData=record
 end;

The TChartData type exposes the following members.

Methods
Show:
Name | Description
AddSeries(TChartSeries,TDataItem) | Represents method AddSeries(TChartSeries,TDataItem).
From(TChartSeries) | Overloaded. Represents method From(TChartSeries).
From(TChartSeries[]) | Overloaded. Represents method From(TChartSeries[]).
From(TCustomChart) | Overloaded. Represents method From(TCustomChart).
From(TDataArray,TComponent,TChartSeriesClass) | Overloaded. Represents method From(TDataArray,TComponent,TChartSeriesClass).
From(TDataItem,TComponent,TChartSeriesClass) | Overloaded. Represents method From(TDataItem,TComponent,TChartSeriesClass).
Top
See Also

Reference

  • FMXBI.Chart.Plugin


TChartData Methods

Methods
Name | Description
AddSeries(TChartSeries,TDataItem) | Represents method AddSeries(TChartSeries,TDataItem).
From(TChartSeries) | Overloaded. Represents method From(TChartSeries).
From(TChartSeries[]) | Overloaded. Represents method From(TChartSeries[]).
From(TCustomChart) | Overloaded. Represents method From(TCustomChart).
From(TDataArray,TComponent,TChartSeriesClass) | Overloaded. Represents method From(TDataArray,TComponent,TChartSeriesClass).
From(TDataItem,TComponent,TChartSeriesClass) | Overloaded. Represents method From(TDataItem,TComponent,TChartSeriesClass).
Top


TChartData.AddSeries(TChartSeries,TDataItem) Method

Summary

Represents method AddSeries(TChartSeries,TDataItem).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 class procedure AddSeries(const ASeries: TChartSeries; const ADest: TDataItem); static;

Parameters

ASeries
Type: TChartSeries

ADest
Type: TDataItem

See Also

Reference

  • TChartData
  • FMXBI.Chart.Plugin


TChartData.From(TChartSeries) Method

Summary

Represents method From(TChartSeries).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 class function From(const ASeries:TChartSeries):TDataItem; overload; static;

Parameters

ASeries
Type: TChartSeries

Return Value

Type: TDataItem

See Also

Reference

  • TChartData
  • FMXBI.Chart.Plugin


TChartData.From(TChartSeries[]) Method

Summary

Represents method From(TChartSeries[]).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 class function From(const ASeries:Array of TChartSeries):TDataItem; overload; static;

Parameters

ASeries
Type: Array of TChartSeries

Return Value

Type: TDataItem

See Also

Reference

  • TChartData
  • FMXBI.Chart.Plugin


TChartData.From(TCustomChart) Method

Summary

Represents method From(TCustomChart).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 class function From(const AChart:TCustomChart):TDataItem; overload; static;

Parameters

AChart
Type: TCustomChart

Return Value

Type: TDataItem

See Also

Reference

  • TChartData
  • FMXBI.Chart.Plugin


TChartData.From(TDataArray,TComponent,TChartSeriesClass) Method

Summary

Represents method From(TDataArray,TComponent,TChartSeriesClass).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 class function From(const AData:TDataArray;
 const AOwner:TComponent;
 const AClass:TChartSeriesClass=nil):TChartSeries; overload; static;

Parameters

AData
Type: TDataArray

AOwner
Type: TComponent

AClass
Type: TChartSeriesClass

Return Value

Type: TChartSeries

See Also

Reference

  • TChartData
  • FMXBI.Chart.Plugin


TChartData.From(TDataItem,TComponent,TChartSeriesClass) Method

Summary

Represents method From(TDataItem,TComponent,TChartSeriesClass).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
public
 class function From(const AData:TDataItem;
 const AOwner:TComponent;
 const AClass:TChartSeriesClass=nil):TChartSeries; overload; static;

Parameters

AData
Type: TDataItem

AOwner
Type: TComponent

AClass
Type: TChartSeriesClass

Return Value

Type: TChartSeries

See Also

Reference

  • TChartData
  • FMXBI.Chart.Plugin


FMXBI.Chart.Plugin Enumerations

Enumerations
Name | Description
TBIChartDirection | Represents type TBIChartDirection.
TBIChartStacked | Represents type TBIChartStacked.
Top


TBIChartDirection Enumeration

Summary

Represents type TBIChartDirection.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
type
 TBIChartDirection=(Automatic, Rows, Columns);

The TBIChartDirection type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Columns | Represents constant Columns.
Rows | Represents constant Rows.
Top
See Also

Reference

  • FMXBI.Chart.Plugin


TBIChartStacked Enumeration

Summary

Represents type TBIChartStacked.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
type
 TBIChartStacked=(Automatic, No, Yes, Stacked100, Side, SideAll, SelfStack);

The TBIChartStacked type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
No | Represents constant No.
SelfStack | Represents constant SelfStack.
Side | Represents constant Side.
SideAll | Represents constant SideAll.
Stacked100 | Represents constant Stacked100.
Yes | Represents constant Yes.
Top
See Also

Reference

  • FMXBI.Chart.Plugin


FMXBI.Chart.Plugin Constants

Constants
Name | Description
WhiteColor | Represents constant WhiteColor.
Top


WhiteColor Constant

Summary

Represents constant WhiteColor.

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
 WhiteColor=TAlphaColors.White;

Value

Type: Void

See Also

Reference

  • FMXBI.Chart.Plugin


FMXBI.Chart.Plugin Routines

Routines
Name | Description
AddLabels(TChartSeries,TDataItem) | Represents method AddLabels(TChartSeries,TDataItem).
CopyData(TChartValueList,TDataItem) | Represents method CopyData(TChartValueList,TDataItem).
FixDesignTime(TChartSeries) | Represents method FixDesignTime(TChartSeries).
Top


AddLabels(TChartSeries,TDataItem) Method

Summary

Represents method AddLabels(TChartSeries,TDataItem).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
procedure AddLabels(const ASeries:TChartSeries; const AData:TDataItem);

Parameters

ASeries
Type: TChartSeries

AData
Type: TDataItem

See Also

Reference

  • FMXBI.Chart.Plugin


CopyData(TChartValueList,TDataItem) Method

Summary

Represents method CopyData(TChartValueList,TDataItem).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
procedure CopyData(const AList:TChartValueList; const AData:TDataItem);

Parameters

AList
Type: TChartValueList

AData
Type: TDataItem

See Also

Reference

  • FMXBI.Chart.Plugin


FixDesignTime(TChartSeries) Method

Summary

Represents method FixDesignTime(TChartSeries).

Namespace: FMXBI.Chart.Plugin
Syntax
Delphi
procedure FixDesignTime(const ASeries:TChartSeries);

Parameters

ASeries
Type: TChartSeries

See Also

Reference

  • FMXBI.Chart.Plugin


FMXBI.Chart.Source Namespace

Summary

Represents namespace FMXBI.Chart.Source.

Classes
Name | Description
TDataCollectionItemAccess | Represents type TDataCollectionItemAccess.
TTeeBISource | Represents type TTeeBISource.
Top
Constants
Name | Description
BITeeMsg_DataItem | Represents constant BITeeMsg_DataItem.
Top


FMXBI.Chart.Source Classes

Classes
Name | Description
TDataCollectionItemAccess | Represents type TDataCollectionItemAccess.
TTeeBISource | Represents type TTeeBISource.
Top


TDataCollectionItemAccess Class

Summary

Represents type TDataCollectionItemAccess.

Namespace: FMXBI.Chart.Source
Inheritance Hierarchy
TCollectionItem
BI.CollectionItem.TDataCollectionItem
FMXBI.Chart.Source.TDataCollectionItemAccess
Syntax
Delphi
type
 TDataCollectionItemAccess=class(TDataCollectionItem);
See Also

Reference

  • FMXBI.Chart.Source


TTeeBISource Class

Summary

Represents type TTeeBISource.

Namespace: FMXBI.Chart.Source
Inheritance Hierarchy
TTeeSeriesSource
FMXBI.Chart.Source.TTeeBISource
Syntax
Delphi
type
 TTeeBISource=class(TTeeSeriesSource)
 end;

The TTeeBISource type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TTeeBISource class.
Destroy | Represents the destructor of the TTeeBISource class.
Top
Properties
Show:
Name | Description
Active | Represents property Active.
Data | Represents property Data.
Provider | Represents property Provider.
Series | Represents property Series.
Top
Methods
Show:
Name | Description
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Description | Represents method Description.
Editor | Represents method Editor.
Load | Represents method Load.
Loaded | Represents method Loaded.
Top
See Also

Reference

  • FMXBI.Chart.Source


TTeeBISource Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TTeeBISource class.
Destroy | Represents the destructor of the TTeeBISource class.
Top


TTeeBISource.Create(TComponent) Constructor

Summary

Initializes a new instance of the TTeeBISource class.

Namespace: FMXBI.Chart.Source
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TTeeBISource
  • FMXBI.Chart.Source


TTeeBISource.Destroy Destructor

Summary

Represents the destructor of the TTeeBISource class.

Namespace: FMXBI.Chart.Source
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TTeeBISource
  • FMXBI.Chart.Source


TTeeBISource Properties

Properties
Name | Description
Active | Represents property Active.
Data | Represents property Data.
Provider | Represents property Provider.
Series | Represents property Series.
Top


TTeeBISource.Active Property

Summary

Represents property Active.

Namespace: FMXBI.Chart.Source
Syntax
Delphi
published
 property Active;

Property Value

Type: Void

See Also

Reference

  • TTeeBISource
  • FMXBI.Chart.Source


TTeeBISource.Data Property

Summary

Represents property Data.

Namespace: FMXBI.Chart.Source
Syntax
Delphi
published
 property Data:TDataItem read GetData write SetData;

Property Value

Type: TDataItem

See Also

Reference

  • TTeeBISource
  • FMXBI.Chart.Source


TTeeBISource.Provider Property

Summary

Represents property Provider.

Namespace: FMXBI.Chart.Source
Syntax
Delphi
published
 property Provider:TComponent read GetProvider write SetProvider;

Property Value

Type: TComponent

See Also

Reference

  • TTeeBISource
  • FMXBI.Chart.Source


TTeeBISource.Series Property

Summary

Represents property Series.

Namespace: FMXBI.Chart.Source
Syntax
Delphi
published
 property Series;

Property Value

Type: Void

See Also

Reference

  • TTeeBISource
  • FMXBI.Chart.Source


TTeeBISource Methods

Methods
Name | Description
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Description | Represents method Description.
Editor | Represents method Editor.
Load | Represents method Load.
Loaded | Represents method Loaded.
Top


TTeeBISource.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: FMXBI.Chart.Source
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TTeeBISource
  • FMXBI.Chart.Source


TTeeBISource.Description Method

Summary

Represents method Description.

Namespace: FMXBI.Chart.Source
Syntax
Delphi
public
 class Function Description:String; override;

Return Value

Type: String

See Also

Reference

  • TTeeBISource
  • FMXBI.Chart.Source


TTeeBISource.Editor Method

Summary

Represents method Editor.

Namespace: FMXBI.Chart.Source
Syntax
Delphi
public
 class Function Editor:TComponentClass; override;

Return Value

Type: TComponentClass

See Also

Reference

  • TTeeBISource
  • FMXBI.Chart.Source


TTeeBISource.Load Method

Summary

Represents method Load.

Namespace: FMXBI.Chart.Source
Syntax
Delphi
public
 Procedure Load; override;
See Also

Reference

  • TTeeBISource
  • FMXBI.Chart.Source


TTeeBISource.Loaded Method

Summary

Represents method Loaded.

Namespace: FMXBI.Chart.Source
Syntax
Delphi
protected
 procedure Loaded; override;
See Also

Reference

  • TTeeBISource
  • FMXBI.Chart.Source


FMXBI.Chart.Source Constants

Constants
Name | Description
BITeeMsg_DataItem | Represents constant BITeeMsg_DataItem.
Top


BITeeMsg_DataItem Constant

Summary

Represents constant BITeeMsg_DataItem.

Namespace: FMXBI.Chart.Source
Syntax
Delphi
 BITeeMsg_DataItem='BI Data';

Value

Type: string

See Also

Reference

  • FMXBI.Chart.Source


FMXBI.Chart.ThreeD Namespace

Summary

Represents namespace FMXBI.Chart.ThreeD.

Records
Name | Description
TThreeDChart | Represents type TThreeDChart.
Top
Types
Name | Description
TCustom3DSeriesClass | Represents type TCustom3DSeriesClass.
Top
Routines
Name | Description
TowerStack(TBIChartStacked) | Represents method TowerStack(TBIChartStacked).
Top


FMXBI.Chart.ThreeD Records

Records
Name | Description
TThreeDChart | Represents type TThreeDChart.
Top


TThreeDChart Record

Summary

Represents type TThreeDChart.

Namespace: FMXBI.Chart.ThreeD
Syntax
Delphi
type
 TThreeDChart=record
 end;

The TThreeDChart type exposes the following members.

Methods
Show:
Name | Description
CanReuse(TBITChart) | Represents method CanReuse(TBITChart).
Create3DSeries(TBITChart) | Represents method Create3DSeries(TBITChart).
CreateGrid3D(TBITChart,TDataItem,TDataItem,TDataItem,TBIChartDirection) | Represents method CreateGrid3D(TBITChart,TDataItem,TDataItem,TDataItem,TBIChartDirection).
CreateGridTable(TBITChart,TDataArray,TBIChartDirection) | Represents method CreateGridTable(TBITChart,TDataArray,TBIChartDirection).
CreateXYZ(TBITChart,TDataItem,TDataItem,TDataItem) | Represents method CreateXYZ(TBITChart,TDataItem,TDataItem,TDataItem).
FinishSeries(TChart,TChartSeries,TBIChartStacked) | Represents method FinishSeries(TChart,TChartSeries,TBIChartStacked).
FinishXYZ(TChart) | Represents method FinishXYZ(TChart).
SetSeries3D(TBITChart,TChartSeriesClass) | Represents method SetSeries3D(TBITChart,TChartSeriesClass).
Top
See Also

Reference

  • FMXBI.Chart.ThreeD


TThreeDChart Methods

Methods
Name | Description
CanReuse(TBITChart) | Represents method CanReuse(TBITChart).
Create3DSeries(TBITChart) | Represents method Create3DSeries(TBITChart).
CreateGrid3D(TBITChart,TDataItem,TDataItem,TDataItem,TBIChartDirection) | Represents method CreateGrid3D(TBITChart,TDataItem,TDataItem,TDataItem,TBIChartDirection).
CreateGridTable(TBITChart,TDataArray,TBIChartDirection) | Represents method CreateGridTable(TBITChart,TDataArray,TBIChartDirection).
CreateXYZ(TBITChart,TDataItem,TDataItem,TDataItem) | Represents method CreateXYZ(TBITChart,TDataItem,TDataItem,TDataItem).
FinishSeries(TChart,TChartSeries,TBIChartStacked) | Represents method FinishSeries(TChart,TChartSeries,TBIChartStacked).
FinishXYZ(TChart) | Represents method FinishXYZ(TChart).
SetSeries3D(TBITChart,TChartSeriesClass) | Represents method SetSeries3D(TBITChart,TChartSeriesClass).
Top


TThreeDChart.CanReuse(TBITChart) Method

Summary

Represents method CanReuse(TBITChart).

Namespace: FMXBI.Chart.ThreeD
Syntax
Delphi
public
 class function CanReuse(const AChart:TBITChart):Boolean; static;

Parameters

AChart
Type: TBITChart

Return Value

Type: Boolean

See Also

Reference

  • TThreeDChart
  • FMXBI.Chart.ThreeD


TThreeDChart.Create3DSeries(TBITChart) Method

Summary

Represents method Create3DSeries(TBITChart).

Namespace: FMXBI.Chart.ThreeD
Syntax
Delphi
public
 class function Create3DSeries(const AChart:TBITChart):TCustom3DSeries; static;

Parameters

AChart
Type: TBITChart

Return Value

Type: TCustom3DSeries

See Also

Reference

  • TThreeDChart
  • FMXBI.Chart.ThreeD


TThreeDChart.CreateGrid3D(TBITChart,TDataItem,TDataItem,TDataItem,TBIChartDirection) Method

Summary

Represents method CreateGrid3D(TBITChart,TDataItem,TDataItem,TDataItem,TBIChartDirection).

Namespace: FMXBI.Chart.ThreeD
Syntax
Delphi
public
 class procedure CreateGrid3D(const AChart:TBITChart;
 const X,Y,Z:TDataItem;
 const ADirection:TBIChartDirection); static;

Parameters

AChart
Type: TBITChart

X
Type: TDataItem

Y
Type: TDataItem

Z
Type: TDataItem

ADirection
Type: TBIChartDirection

See Also

Reference

  • TThreeDChart
  • FMXBI.Chart.ThreeD


TThreeDChart.CreateGridTable(TBITChart,TDataArray,TBIChartDirection) Method

Summary

Represents method CreateGridTable(TBITChart,TDataArray,TBIChartDirection).

Namespace: FMXBI.Chart.ThreeD
Syntax
Delphi
public
 class procedure CreateGridTable(const AChart:TBITChart;
 const AData:TDataArray;
 const ADirection:TBIChartDirection); static;

Parameters

AChart
Type: TBITChart

AData
Type: TDataArray

ADirection
Type: TBIChartDirection

See Also

Reference

  • TThreeDChart
  • FMXBI.Chart.ThreeD


TThreeDChart.CreateXYZ(TBITChart,TDataItem,TDataItem,TDataItem) Method

Summary

Represents method CreateXYZ(TBITChart,TDataItem,TDataItem,TDataItem).

Namespace: FMXBI.Chart.ThreeD
Syntax
Delphi
public
 class procedure CreateXYZ(const AChart:TBITChart;
 const X,Y,Z:TDataItem); static;

Parameters

AChart
Type: TBITChart

X
Type: TDataItem

Y
Type: TDataItem

Z
Type: TDataItem

See Also

Reference

  • TThreeDChart
  • FMXBI.Chart.ThreeD


TThreeDChart.FinishSeries(TChart,TChartSeries,TBIChartStacked) Method

Summary

Represents method FinishSeries(TChart,TChartSeries,TBIChartStacked).

Namespace: FMXBI.Chart.ThreeD
Syntax
Delphi
public
 class procedure FinishSeries(const AChart:TChart;
 const ASeries:TChartSeries;
 const AStacked:TBIChartStacked); static;

Parameters

AChart
Type: TChart

ASeries
Type: TChartSeries

AStacked
Type: TBIChartStacked

See Also

Reference

  • TThreeDChart
  • FMXBI.Chart.ThreeD


TThreeDChart.FinishXYZ(TChart) Method

Summary

Represents method FinishXYZ(TChart).

Namespace: FMXBI.Chart.ThreeD
Syntax
Delphi
public
 class procedure FinishXYZ(const AChart:TChart); static;

Parameters

AChart
Type: TChart

See Also

Reference

  • TThreeDChart
  • FMXBI.Chart.ThreeD


TThreeDChart.SetSeries3D(TBITChart,TChartSeriesClass) Method

Summary

Represents method SetSeries3D(TBITChart,TChartSeriesClass).

Namespace: FMXBI.Chart.ThreeD
Syntax
Delphi
public
 class function SetSeries3D(const AChart:TBITChart;
 const AClass:TChartSeriesClass):Boolean; static;

Parameters

AChart
Type: TBITChart

AClass
Type: TChartSeriesClass

Return Value

Type: Boolean

See Also

Reference

  • TThreeDChart
  • FMXBI.Chart.ThreeD


FMXBI.Chart.ThreeD Types

Types
Name | Description
TCustom3DSeriesClass | Represents type TCustom3DSeriesClass.
Top


TCustom3DSeriesClass Type

Summary

Represents type TCustom3DSeriesClass.

Namespace: FMXBI.Chart.ThreeD
Syntax
Delphi
type
 TCustom3DSeriesClass=class of TCustom3DSeries;
See Also

Reference

  • FMXBI.Chart.ThreeD


FMXBI.Chart.ThreeD Routines

Routines
Name | Description
TowerStack(TBIChartStacked) | Represents method TowerStack(TBIChartStacked).
Top


TowerStack(TBIChartStacked) Method

Summary

Represents method TowerStack(TBIChartStacked).

Namespace: FMXBI.Chart.ThreeD
Syntax
Delphi
function TowerStack(const AStacked:TBIChartStacked):TTowerStacked;

Parameters

AStacked
Type: TBIChartStacked

Return Value

Type: TTowerStacked

See Also

Reference

  • FMXBI.Chart.ThreeD


FMXBI.ChartFunctions Namespace

Summary

Represents namespace FMXBI.ChartFunctions.

Classes
Name | Description
TDataAccess | Represents type TDataAccess.
TDataFunction | Represents type TDataFunction.
TFunctionAccess | Represents type TFunctionAccess.
TSeriesAccess | Represents type TSeriesAccess.
Top
Routines
Name | Description
IsType(TClass,TClass[]) | Represents method IsType(TClass,TClass[]).
Top


FMXBI.ChartFunctions Classes

Classes
Name | Description
TDataAccess | Represents type TDataAccess.
TDataFunction | Represents type TDataFunction.
TFunctionAccess | Represents type TFunctionAccess.
TSeriesAccess | Represents type TSeriesAccess.
Top


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: FMXBI.ChartFunctions
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
FMXBI.ChartFunctions.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • FMXBI.ChartFunctions


TDataFunction Class

Summary

Represents type TDataFunction.

Namespace: FMXBI.ChartFunctions
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
FMXBI.ChartFunctions.TDataFunction
Syntax
Delphi
type
 TDataFunction=class(TDataProviderNeeds)
 end;

The TDataFunction type exposes the following members.

Constructors
Show:
Name | Description
CreateFunction(TComponent,TTeeFunction) | Overloaded. Initializes a new instance of the TDataFunction class.
CreateFunction(TComponent,TTeeFunctionClass) | Overloaded. Initializes a new instance of the TDataFunction class.
Top
Properties
Show:
Name | Description
FunctionClass | Represents property FunctionClass.
Period | Represents property Period.
TeeFunction | Represents property TeeFunction.
Top
Methods
Show:
Name | Description
FunctionTitle | Represents method FunctionTitle.
GetChildOwner | Represents method GetChildOwner.
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent).
IsFinancial | Represents method IsFinancial.
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Loaded | Represents method Loaded.
Top
See Also

Reference

  • FMXBI.ChartFunctions


TDataFunction Constructors

Constructors
Name | Description
CreateFunction(TComponent,TTeeFunction) | Overloaded. Initializes a new instance of the TDataFunction class.
CreateFunction(TComponent,TTeeFunctionClass) | Overloaded. Initializes a new instance of the TDataFunction class.
Top


TDataFunction.CreateFunction(TComponent,TTeeFunction) Constructor

Summary

Initializes a new instance of the TDataFunction class.

Namespace: FMXBI.ChartFunctions
Syntax
Delphi
public
 Constructor CreateFunction(const AOwner:TComponent; const AFunction:TTeeFunction); overload;

Parameters

AOwner
Type: TComponent

AFunction
Type: TTeeFunction

See Also

Reference

  • TDataFunction
  • FMXBI.ChartFunctions


TDataFunction.CreateFunction(TComponent,TTeeFunctionClass) Constructor

Summary

Initializes a new instance of the TDataFunction class.

Namespace: FMXBI.ChartFunctions
Syntax
Delphi
public
 Constructor CreateFunction(const AOwner:TComponent; const AFunctionClass:TTeeFunctionClass); overload;

Parameters

AOwner
Type: TComponent

AFunctionClass
Type: TTeeFunctionClass

See Also

Reference

  • TDataFunction
  • FMXBI.ChartFunctions


TDataFunction Properties

Properties
Name | Description
FunctionClass | Represents property FunctionClass.
Period | Represents property Period.
TeeFunction | Represents property TeeFunction.
Top


TDataFunction.FunctionClass Property

Summary

Represents property FunctionClass.

Namespace: FMXBI.ChartFunctions
Syntax
Delphi
public
 property FunctionClass:TTeeFunctionClass read CalcClass;

Property Value

Type: TTeeFunctionClass

See Also

Reference

  • TDataFunction
  • FMXBI.ChartFunctions


TDataFunction.Period Property

Summary

Represents property Period.

Namespace: FMXBI.ChartFunctions
Syntax
Delphi
published
 property Period:Double read GetPeriod write SetPeriod stored False;

Property Value

Type: Double

See Also

Reference

  • TDataFunction
  • FMXBI.ChartFunctions


TDataFunction.TeeFunction Property

Summary

Represents property TeeFunction.

Namespace: FMXBI.ChartFunctions
Syntax
Delphi
public
 property TeeFunction:TTeeFunction read GetTeeFunction;

Property Value

Type: TTeeFunction

See Also

Reference

  • TDataFunction
  • FMXBI.ChartFunctions


TDataFunction Methods

Methods
Name | Description
FunctionTitle | Represents method FunctionTitle.
GetChildOwner | Represents method GetChildOwner.
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent).
IsFinancial | Represents method IsFinancial.
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Loaded | Represents method Loaded.
Top


TDataFunction.FunctionTitle Method

Summary

Represents method FunctionTitle.

Namespace: FMXBI.ChartFunctions
Syntax
Delphi
public
 function FunctionTitle:String;

Return Value

Type: String

See Also

Reference

  • TDataFunction
  • FMXBI.ChartFunctions


TDataFunction.GetChildOwner Method

Summary

Represents method GetChildOwner.

Namespace: FMXBI.ChartFunctions
Syntax
Delphi
protected
 function GetChildOwner: TComponent; override;

Return Value

Type: TComponent

See Also

Reference

  • TDataFunction
  • FMXBI.ChartFunctions


TDataFunction.GetChildren(TGetChildProc,TComponent) Method

Summary

Represents method GetChildren(TGetChildProc,TComponent).

Namespace: FMXBI.ChartFunctions
Syntax
Delphi
protected
 Procedure GetChildren(Proc:TGetChildProc; Root:TComponent); override;

Parameters

Proc
Type: TGetChildProc

Root
Type: TComponent

See Also

Reference

  • TDataFunction
  • FMXBI.ChartFunctions


TDataFunction.IsFinancial Method

Summary

Represents method IsFinancial.

Namespace: FMXBI.ChartFunctions
Syntax
Delphi
public
 function IsFinancial:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TDataFunction
  • FMXBI.ChartFunctions


TDataFunction.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: FMXBI.ChartFunctions
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TDataFunction
  • FMXBI.ChartFunctions


TDataFunction.Loaded Method

Summary

Represents method Loaded.

Namespace: FMXBI.ChartFunctions
Syntax
Delphi
protected
 procedure Loaded; override;
See Also

Reference

  • TDataFunction
  • FMXBI.ChartFunctions


TFunctionAccess Class

Summary

Represents type TFunctionAccess.

Namespace: FMXBI.ChartFunctions
Inheritance Hierarchy
TTeeFunction
FMXBI.ChartFunctions.TFunctionAccess
Syntax
Delphi
type
 TFunctionAccess=class(TTeeFunction);
See Also

Reference

  • FMXBI.ChartFunctions


TSeriesAccess Class

Summary

Represents type TSeriesAccess.

Namespace: FMXBI.ChartFunctions
Inheritance Hierarchy
TChartSeries
FMXBI.ChartFunctions.TSeriesAccess
Syntax
Delphi
type
 TSeriesAccess=class(TChartSeries);
See Also

Reference

  • FMXBI.ChartFunctions


FMXBI.ChartFunctions Routines

Routines
Name | Description
IsType(TClass,TClass[]) | Represents method IsType(TClass,TClass[]).
Top


IsType(TClass,TClass[]) Method

Summary

Represents method IsType(TClass,TClass[]).

Namespace: FMXBI.ChartFunctions
Syntax
Delphi
function IsType(const AType:TClass; const AClasses:Array of TClass):Boolean;

Parameters

AType
Type: TClass

AClasses
Type: Array of TClass

Return Value

Type: Boolean

See Also

Reference

  • FMXBI.ChartFunctions


FMXBI.Component Namespace

Summary

Represents namespace FMXBI.Component.

Classes
Name | Description
TControlImporter | Represents type TControlImporter.
Top


FMXBI.Component Classes

Classes
Name | Description
TControlImporter | Represents type TControlImporter.
Top


TControlImporter Class

Summary

Represents type TControlImporter.

Namespace: FMXBI.Component
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Persist.TBaseDataImporter
BI.Store.Component.TComponentImporter
FMXBI.Component.TControlImporter
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64 or pidOSX32
 or pidiOSSimulator or pidiOSDevice
 or pidAndroid
 or pidiOSDevice64
 )]
 TControlImporter=class(TComponentImporter)
 end;

The TControlImporter type exposes the following members.

Methods
Show:
Name | Description
DataOf(TComponent) | Represents method DataOf(TComponent). (Overrides TComponentImporter.DataOf(TComponent).)
DoImport(TComponent) | Represents method DoImport(TComponent). (Overrides TComponentImporter.DoImport(TComponent).)
HasDataProperty(TComponent) | Represents method HasDataProperty(TComponent).
HasTextProperty(TComponent) | Represents method HasTextProperty(TComponent).
StringsOf(TComponent) | Represents method StringsOf(TComponent). (Overrides TComponentImporter.StringsOf(TComponent).)
Supports(TComponent) | Represents method Supports(TComponent). (Overrides TComponentImporter.Supports(TComponent).)
TextOf(TComponent) | Overloaded. Represents method TextOf(TComponent).
Top
See Also

Reference

  • FMXBI.Component


TControlImporter Methods

Methods
Name | Description
DataOf(TComponent) | Represents method DataOf(TComponent). (Overrides TComponentImporter.DataOf(TComponent).)
DoImport(TComponent) | Represents method DoImport(TComponent). (Overrides TComponentImporter.DoImport(TComponent).)
HasDataProperty(TComponent) | Represents method HasDataProperty(TComponent).
HasTextProperty(TComponent) | Represents method HasTextProperty(TComponent).
StringsOf(TComponent) | Represents method StringsOf(TComponent). (Overrides TComponentImporter.StringsOf(TComponent).)
Supports(TComponent) | Represents method Supports(TComponent). (Overrides TComponentImporter.Supports(TComponent).)
TextOf(TComponent) | Overloaded. Represents method TextOf(TComponent).
Top


TControlImporter.DataOf(TComponent) Method

Summary

Represents method DataOf(TComponent).

Namespace: FMXBI.Component
Syntax
Delphi
public
 class function DataOf(const AComponent:TComponent):TDataItem; override;

Parameters

AComponent
Type: TComponent

Return Value

Type: TDataItem

Overrides

TComponentImporter.DataOf(TComponent)
See Also

Reference

  • TControlImporter
  • FMXBI.Component


TControlImporter.DoImport(TComponent) Method

Summary

Represents method DoImport(TComponent).

Namespace: FMXBI.Component
Syntax
Delphi
protected
 function DoImport(const AComponent: TComponent):TDataItem; override;

Parameters

AComponent
Type: TComponent

Return Value

Type: TDataItem

Overrides

TComponentImporter.DoImport(TComponent)
See Also

Reference

  • TControlImporter
  • FMXBI.Component


TControlImporter.HasDataProperty(TComponent) Method

Summary

Represents method HasDataProperty(TComponent).

Namespace: FMXBI.Component
Syntax
Delphi
public
 class function HasDataProperty(const AComponent:TComponent):Boolean; static;

Parameters

AComponent
Type: TComponent

Return Value

Type: Boolean

See Also

Reference

  • TControlImporter
  • FMXBI.Component


TControlImporter.HasTextProperty(TComponent) Method

Summary

Represents method HasTextProperty(TComponent).

Namespace: FMXBI.Component
Syntax
Delphi
public
 class function HasTextProperty(const AComponent:TComponent):Boolean; static;

Parameters

AComponent
Type: TComponent

Return Value

Type: Boolean

See Also

Reference

  • TControlImporter
  • FMXBI.Component


TControlImporter.StringsOf(TComponent) Method

Summary

Represents method StringsOf(TComponent).

Namespace: FMXBI.Component
Syntax
Delphi
public
 class function StringsOf(const ASource:TComponent):TStrings; override;

Parameters

ASource
Type: TComponent

Return Value

Type: TStrings

Overrides

TComponentImporter.StringsOf(TComponent)
See Also

Reference

  • TControlImporter
  • FMXBI.Component


TControlImporter.Supports(TComponent) Method

Summary

Represents method Supports(TComponent).

Namespace: FMXBI.Component
Syntax
Delphi
public
 class function Supports(const AComponent:TComponent):Boolean; override;

Parameters

AComponent
Type: TComponent

Return Value

Type: Boolean

Overrides

TComponentImporter.Supports(TComponent)
See Also

Reference

  • TControlImporter
  • FMXBI.Component


TControlImporter.TextOf(TComponent) Method

Summary

Represents method TextOf(TComponent).

Namespace: FMXBI.Component
Syntax
Delphi
public
 class function TextOf(const AComponent:TComponent):String; overload; static;

Parameters

AComponent
Type: TComponent

Return Value

Type: String

See Also

Reference

  • TControlImporter
  • FMXBI.Component


FMXBI.Dashboard Namespace

Summary

Represents namespace FMXBI.Dashboard.

Classes
Name | Description
TBaseItemAccess | Represents type TBaseItemAccess.
TBIPanelAccess | Represents type TBIPanelAccess.
TBITemplateAccess | Represents type TBITemplateAccess.
TBIVisual | Represents type TBIVisual.
TBIVisualAccess | Represents type TBIVisualAccess.
TButtonsPanel | Represents type TButtonsPanel.
TControlHelper | Represents type TControlHelper.
TDashboardItemAccess | Represents type TDashboardItemAccess.
TDashboardTree | Represents type TDashboardTree.
TGridAccess | Represents type TGridAccess.
TLayoutComboBox | Represents type TLayoutComboBox.
TLayoutListBox | Represents type TLayoutListBox.
TLayoutPanel | Represents type TLayoutPanel.
TRenderAccess | Represents type TRenderAccess.
TScreenRender | Represents type TScreenRender.
TScreenRender.TTargetControlsHelper | Represents type TTargetControlsHelper.
Top
Types
Name | Description
TAlign | Represents an alias of the TAlignLayout type.
TCheckListBox | Represents an alias of the TListBox type.
TControlClass | Represents type TControlClass.
TDBNavigator | Represents an alias of the TBindNavigator type.
TGraphic | Represents an alias of the TBitmap type.
TPageControl | Represents an alias of the TTabControl type.
TPanel | Represents an alias of the TRectangle type.
TScreenRenderClass | Represents type TScreenRenderClass.
TTabSheet | Represents an alias of the TTabItem type.
TWinControl | Represents an alias of the TControl type.
Top
Constants
Name | Description
BrushKindNone | Represents constant BrushKindNone.
BrushKindSolid | Represents constant BrushKindSolid.
Top
Routines
Name | Description
AlignOf(String) | Represents method AlignOf(String).
AlphaColorToColor(TAlphaColor) | Represents method AlphaColorToColor(TAlphaColor).
CreatePanelFrame(TWinControl) | Represents method CreatePanelFrame(TWinControl).
CreatePanelText(TControl,String) | Represents method CreatePanelText(TControl,String).
DoSetPadding(TWinControl,Single) | Represents method DoSetPadding(TWinControl,Single).
GetURLStream(String) | Represents method GetURLStream(String).
IsAlignLeftRight(TControl) | Represents method IsAlignLeftRight(TControl).
IsAlignTopBottom(TControl) | Represents method IsAlignTopBottom(TControl).
LoadImage(TImage,String) | Represents method LoadImage(TImage,String).
NewTab(TControl,TWinControl,String) | Represents method NewTab(TControl,TWinControl,String).
ParentOf(TControl) | Represents method ParentOf(TControl).
RandomLightColor | Represents method RandomLightColor.
RepositionControl(TControl) | Represents method RepositionControl(TControl).
ScrollContentOf(TWinControl) | Represents method ScrollContentOf(TWinControl).
SetDefaultPadding(TWinControl) | Represents method SetDefaultPadding(TWinControl).
ShowHideAll(TControl,Integer) | Represents method ShowHideAll(TControl,Integer).
TitleOf(TDashboardItem) | Represents method TitleOf(TDashboardItem).
Top


FMXBI.Dashboard Classes

Classes
Name | Description
TBaseItemAccess | Represents type TBaseItemAccess.
TBIPanelAccess | Represents type TBIPanelAccess.
TBITemplateAccess | Represents type TBITemplateAccess.
TBIVisual | Represents type TBIVisual.
TBIVisualAccess | Represents type TBIVisualAccess.
TButtonsPanel | Represents type TButtonsPanel.
TControlHelper | Represents type TControlHelper.
TDashboardItemAccess | Represents type TDashboardItemAccess.
TDashboardTree | Represents type TDashboardTree.
TGridAccess | Represents type TGridAccess.
TLayoutComboBox | Represents type TLayoutComboBox.
TLayoutListBox | Represents type TLayoutListBox.
TLayoutPanel | Represents type TLayoutPanel.
TRenderAccess | Represents type TRenderAccess.
TScreenRender | Represents type TScreenRender.
TScreenRender.TTargetControlsHelper | Represents type TTargetControlsHelper.
Top


TBaseItemAccess Class

Summary

Represents type TBaseItemAccess.

Namespace: FMXBI.Dashboard
Inheritance Hierarchy
TCollectionItem
BI.Dashboard.TBaseItem
FMXBI.Dashboard.TBaseItemAccess
Syntax
Delphi
type
 TBaseItemAccess=class(TBaseItem);
See Also

Reference

  • FMXBI.Dashboard


TBIPanelAccess Class

Summary

Represents type TBIPanelAccess.

Namespace: FMXBI.Dashboard
Inheritance Hierarchy
TCollectionItem
BI.Dashboard.TBaseItem
BI.Dashboard.TCustomBIPanel
BI.Dashboard.TBIPanel
FMXBI.Dashboard.TBIPanelAccess
Syntax
Delphi
type
 TBIPanelAccess=class(TBIPanel);
See Also

Reference

  • FMXBI.Dashboard


TBITemplateAccess Class

Summary

Represents type TBITemplateAccess.

Namespace: FMXBI.Dashboard
Inheritance Hierarchy
TComponent
BI.Dashboard.TBITemplate
FMXBI.Dashboard.TBITemplateAccess
Syntax
Delphi
type
 TBITemplateAccess=class(TBITemplate);
See Also

Reference

  • FMXBI.Dashboard


TBIVisual Class

Summary

Represents type TBIVisual.

Namespace: FMXBI.Dashboard
Inheritance Hierarchy
TScrollBox
FMXBI.Dashboard.TBIVisual
FMXBI.Dashboard.TBIVisualAccess
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64
 or pidOSX32
 or pidiOSSimulator or pidiOSDevice
 or pidAndroid
 or pidiOSDevice64
 )]
 TBIVisual=class(TScrollBox)
 end;

The TBIVisual type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIVisual class.
Destroy | Represents the destructor of the TBIVisual class.
Top
Properties
Show:
Name | Description
Align | Represents property Align.
Anchors | Represents property Anchors.
ClipChildren | Represents property ClipChildren.
ClipParent | Represents property ClipParent.
Cursor | Represents property Cursor.
Dashboard | Represents property Dashboard.
Dashboards | Represents property Dashboards.
Data | Represents property Data.
DragMode | Represents property DragMode.
Enabled | Represents property Enabled.
EnableDragHighlight | Represents property EnableDragHighlight.
Height | Represents property Height.
HitTest | Represents property HitTest.
Layouts | Represents property Layouts.
Locked | Represents property Locked.
Margins | Represents property Margins.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnDragDrop | Represents property OnDragDrop.
OnDragEnd | Represents property OnDragEnd.
OnDragEnter | Represents property OnDragEnter.
OnDragLeave | Represents property OnDragLeave.
OnDragOver | Represents property OnDragOver.
OnMouseDown | Represents property OnMouseDown.
OnMouseEnter | Represents property OnMouseEnter.
OnMouseLeave | Represents property OnMouseLeave.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnMouseWheel | Represents property OnMouseWheel.
OnPaint | Represents property OnPaint.
OnPainting | Represents property OnPainting.
OnResize | Represents property OnResize.
Opacity | Represents property Opacity.
Padding | Represents property Padding.
Panels | Represents property Panels.
PopupMenu | Represents property PopupMenu.
Position | Represents property Position.
Render | Represents property Render.
RotationAngle | Represents property RotationAngle.
RotationCenter | Represents property RotationCenter.
Scale | Represents property Scale.
Size | Represents property Size.
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
Template | Represents property Template.
TouchTargetExpansion | Represents property TouchTargetExpansion.
Visible | Represents property Visible.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
Clear | Represents method Clear.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Generate(TBIPanel) | Overloaded. Represents method Generate(TBIPanel).
Generate(TDashboard,String) | Overloaded. Represents method Generate(TDashboard,String).
GetChildOwner | Represents method GetChildOwner.
Loaded | Represents method Loaded.
Resize | Represents method Resize.
ResizeLayout | Represents method ResizeLayout.
Top
Fields
Show:
Name | Description
RenderClass | Represents field RenderClass.
Top
See Also

Reference

  • FMXBI.Dashboard


TBIVisual Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBIVisual class.
Destroy | Represents the destructor of the TBIVisual class.
Top


TBIVisual.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIVisual class.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Destroy Destructor

Summary

Represents the destructor of the TBIVisual class.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual Properties

Properties
Name | Description
Align | Represents property Align.
Anchors | Represents property Anchors.
ClipChildren | Represents property ClipChildren.
ClipParent | Represents property ClipParent.
Cursor | Represents property Cursor.
Dashboard | Represents property Dashboard.
Dashboards | Represents property Dashboards.
Data | Represents property Data.
DragMode | Represents property DragMode.
Enabled | Represents property Enabled.
EnableDragHighlight | Represents property EnableDragHighlight.
Height | Represents property Height.
HitTest | Represents property HitTest.
Layouts | Represents property Layouts.
Locked | Represents property Locked.
Margins | Represents property Margins.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnDragDrop | Represents property OnDragDrop.
OnDragEnd | Represents property OnDragEnd.
OnDragEnter | Represents property OnDragEnter.
OnDragLeave | Represents property OnDragLeave.
OnDragOver | Represents property OnDragOver.
OnMouseDown | Represents property OnMouseDown.
OnMouseEnter | Represents property OnMouseEnter.
OnMouseLeave | Represents property OnMouseLeave.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnMouseWheel | Represents property OnMouseWheel.
OnPaint | Represents property OnPaint.
OnPainting | Represents property OnPainting.
OnResize | Represents property OnResize.
Opacity | Represents property Opacity.
Padding | Represents property Padding.
Panels | Represents property Panels.
PopupMenu | Represents property PopupMenu.
Position | Represents property Position.
Render | Represents property Render.
RotationAngle | Represents property RotationAngle.
RotationCenter | Represents property RotationCenter.
Scale | Represents property Scale.
Size | Represents property Size.
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
Template | Represents property Template.
TouchTargetExpansion | Represents property TouchTargetExpansion.
Visible | Represents property Visible.
Width | Represents property Width.
Top


TBIVisual.Align Property

Summary

Represents property Align.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property Align;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Anchors Property

Summary

Represents property Anchors.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property Anchors;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.ClipChildren Property

Summary

Represents property ClipChildren.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property ClipChildren;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.ClipParent Property

Summary

Represents property ClipParent.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property ClipParent;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Cursor Property

Summary

Represents property Cursor.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property Cursor;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Dashboard Property

Summary

Represents property Dashboard.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property Dashboard:TDashboard read FCurrent write SetCurrent stored False;

Property Value

Type: TDashboard

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Dashboards Property

Summary

Represents property Dashboards.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property Dashboards : TDashboards read GetDashboards write SetDashboards;

Property Value

Type: TDashboards

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Data Property

Summary

Represents property Data.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property Data : TVisualDataItems read GetDataItems write SetDataItems;

Property Value

Type: TVisualDataItems

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.DragMode Property

Summary

Represents property DragMode.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property DragMode;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Enabled Property

Summary

Represents property Enabled.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property Enabled;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.EnableDragHighlight Property

Summary

Represents property EnableDragHighlight.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property EnableDragHighlight;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Height Property

Summary

Represents property Height.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property Height;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.HitTest Property

Summary

Represents property HitTest.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property HitTest;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Layouts Property

Summary

Represents property Layouts.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property Layouts : TLayouts read GetLayouts write SetLayouts;

Property Value

Type: TLayouts

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Locked Property

Summary

Represents property Locked.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property Locked;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Margins Property

Summary

Represents property Margins.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property Margins;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.OnClick Property

Summary

Represents property OnClick.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.OnDragDrop Property

Summary

Represents property OnDragDrop.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property OnDragDrop;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.OnDragEnd Property

Summary

Represents property OnDragEnd.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property OnDragEnd;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.OnDragEnter Property

Summary

Represents property OnDragEnter.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property OnDragEnter;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.OnDragLeave Property

Summary

Represents property OnDragLeave.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property OnDragLeave;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.OnDragOver Property

Summary

Represents property OnDragOver.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property OnDragOver;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.OnMouseEnter Property

Summary

Represents property OnMouseEnter.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property OnMouseEnter;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.OnMouseLeave Property

Summary

Represents property OnMouseLeave.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property OnMouseLeave;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.OnMouseWheel Property

Summary

Represents property OnMouseWheel.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property OnMouseWheel;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.OnPaint Property

Summary

Represents property OnPaint.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property OnPaint;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.OnPainting Property

Summary

Represents property OnPainting.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property OnPainting;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.OnResize Property

Summary

Represents property OnResize.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property OnResize;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Opacity Property

Summary

Represents property Opacity.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property Opacity;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Padding Property

Summary

Represents property Padding.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property Padding;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Panels Property

Summary

Represents property Panels.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property Panels : TPanels read GetPanels write SetPanels;

Property Value

Type: TPanels

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.PopupMenu Property

Summary

Represents property PopupMenu.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property PopupMenu;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Position Property

Summary

Represents property Position.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property Position;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Render Property

Summary

Represents property Render.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 property Render:TRender read FRender write SetRender;

Property Value

Type: TRender

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.RotationAngle Property

Summary

Represents property RotationAngle.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property RotationAngle;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.RotationCenter Property

Summary

Represents property RotationCenter.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property RotationCenter;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Scale Property

Summary

Represents property Scale.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property Scale;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Size Property

Summary

Represents property Size.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property Size;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.TabOrder Property

Summary

Represents property TabOrder.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property TabOrder;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.TabStop Property

Summary

Represents property TabStop.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Template Property

Summary

Represents property Template.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 property Template:TBITemplate read FTemplate write SetTemplate;

Property Value

Type: TBITemplate

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.TouchTargetExpansion Property

Summary

Represents property TouchTargetExpansion.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property TouchTargetExpansion;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Visible Property

Summary

Represents property Visible.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property Visible;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Width Property

Summary

Represents property Width.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property Width;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual Methods

Methods
Name | Description
Clear | Represents method Clear.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Generate(TBIPanel) | Overloaded. Represents method Generate(TBIPanel).
Generate(TDashboard,String) | Overloaded. Represents method Generate(TDashboard,String).
GetChildOwner | Represents method GetChildOwner.
Loaded | Represents method Loaded.
Resize | Represents method Resize.
ResizeLayout | Represents method ResizeLayout.
Top


TBIVisual.Clear Method

Summary

Represents method Clear.

Namespace: FMXBI.Dashboard
Syntax
Delphi
protected
 procedure Clear;
See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: FMXBI.Dashboard
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Generate(TBIPanel) Method

Summary

Represents method Generate(TBIPanel).

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 procedure Generate(const APanel:TBIPanel); overload;

Parameters

APanel
Type: TBIPanel

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Generate(TDashboard,String) Method

Summary

Represents method Generate(TDashboard,String).

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 procedure Generate(const ADashboard:TDashboard=nil; const ALayout:String=''); overload;

Parameters

ADashboard
Type: TDashboard

ALayout
Type: String

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.GetChildOwner Method

Summary

Represents method GetChildOwner.

Namespace: FMXBI.Dashboard
Syntax
Delphi
protected
 function GetChildOwner: TComponent; override;

Return Value

Type: TComponent

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Loaded Method

Summary

Represents method Loaded.

Namespace: FMXBI.Dashboard
Syntax
Delphi
protected
 procedure Loaded; override;
See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.Resize Method

Summary

Represents method Resize.

Namespace: FMXBI.Dashboard
Syntax
Delphi
protected
 procedure Resize; override;
See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual.ResizeLayout Method

Summary

Represents method ResizeLayout.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 procedure ResizeLayout;
See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisual Fields

Fields
Name | Description
RenderClass | Represents field RenderClass.
Top


TBIVisual.RenderClass Field

Summary

Represents field RenderClass.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 class var
 RenderClass : TRenderClass;

Field Value

Type: TRenderClass

See Also

Reference

  • TBIVisual
  • FMXBI.Dashboard


TBIVisualAccess Class

Summary

Represents type TBIVisualAccess.

Namespace: FMXBI.Dashboard
Inheritance Hierarchy
TScrollBox
FMXBI.Dashboard.TBIVisual
FMXBI.Dashboard.TBIVisualAccess
Syntax
Delphi
type
 TBIVisualAccess=class(TBIVisual);
See Also

Reference

  • FMXBI.Dashboard


TButtonsPanel Class

Summary

Represents type TButtonsPanel.

Namespace: FMXBI.Dashboard
Inheritance Hierarchy
TScrollBox
FMXBI.Dashboard.TButtonsPanel
Syntax
Delphi
type
 TButtonsPanel=class(TScrollBox)
 end;

The TButtonsPanel type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TButtonsPanel class.
Destroy | Represents the destructor of the TButtonsPanel class.
Top
Properties
Show:
Name | Description
Horizontal | Represents property Horizontal.
ItemIndex | Represents property ItemIndex.
Items | Represents property Items.
OnChange | Represents property OnChange.
Top
See Also

Reference

  • FMXBI.Dashboard


TButtonsPanel Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TButtonsPanel class.
Destroy | Represents the destructor of the TButtonsPanel class.
Top


TButtonsPanel.Create(TComponent) Constructor

Summary

Initializes a new instance of the TButtonsPanel class.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TButtonsPanel
  • FMXBI.Dashboard


TButtonsPanel.Destroy Destructor

Summary

Represents the destructor of the TButtonsPanel class.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TButtonsPanel
  • FMXBI.Dashboard


TButtonsPanel Properties

Properties
Name | Description
Horizontal | Represents property Horizontal.
ItemIndex | Represents property ItemIndex.
Items | Represents property Items.
OnChange | Represents property OnChange.
Top


TButtonsPanel.Horizontal Property

Summary

Represents property Horizontal.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property Horizontal : Boolean read FHorizontal write FHorizontal default True;

Property Value

Type: Boolean

See Also

Reference

  • TButtonsPanel
  • FMXBI.Dashboard


TButtonsPanel.ItemIndex Property

Summary

Represents property ItemIndex.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property ItemIndex : Integer read FItemIndex write SetItemIndex default -1;

Property Value

Type: Integer

See Also

Reference

  • TButtonsPanel
  • FMXBI.Dashboard


TButtonsPanel.Items Property

Summary

Represents property Items.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property Items:TStrings read FItems write SetItems;

Property Value

Type: TStrings

See Also

Reference

  • TButtonsPanel
  • FMXBI.Dashboard


TButtonsPanel.OnChange Property

Summary

Represents property OnChange.

Namespace: FMXBI.Dashboard
Syntax
Delphi
published
 property OnChange:TNotifyEvent read FOnChange write FOnChange;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TButtonsPanel
  • FMXBI.Dashboard


TControlHelper Class Helper

Summary

Represents type TControlHelper.

Namespace: FMXBI.Dashboard
Syntax
Delphi
type
 TControlHelper=class helper for TControl
 end;
Properties
Name | Description
Left | Represents property Left.
Top | Represents property Top.
Top
Methods
Name | Description
ControlCount | Represents method ControlCount.
Top
See Also

Reference

  • FMXBI.Dashboard


TControlHelper Properties

Properties
Name | Description
Left | Represents property Left.
Top | Represents property Top.
Top


TControlHelper.Left Property

Summary

Represents property Left.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 property Left:Single read GetLeft write SetLeft;

Property Value

Type: Single

See Also

Reference

  • TControlHelper
  • FMXBI.Dashboard


TControlHelper.Top Property

Summary

Represents property Top.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 property Top:Single read GetTop write SetTop;

Property Value

Type: Single

See Also

Reference

  • TControlHelper
  • FMXBI.Dashboard


TControlHelper Methods

Methods
Name | Description
ControlCount | Represents method ControlCount.
Top


TControlHelper.ControlCount Method

Summary

Represents method ControlCount.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 function ControlCount:Integer;

Return Value

Type: Integer

See Also

Reference

  • TControlHelper
  • FMXBI.Dashboard


TDashboardItemAccess Class

Summary

Represents type TDashboardItemAccess.

Namespace: FMXBI.Dashboard
Inheritance Hierarchy
TCollectionItem
BI.Dashboard.TBaseItem
BI.Dashboard.TCustomBIPanel
BI.Dashboard.TDashboardItem
FMXBI.Dashboard.TDashboardItemAccess
Syntax
Delphi
type
 TDashboardItemAccess=class(TDashboardItem);
See Also

Reference

  • FMXBI.Dashboard


TDashboardTree Class

Summary

Represents type TDashboardTree.

Namespace: FMXBI.Dashboard
Inheritance Hierarchy
TLayout
FMXBI.DataControl.TBIDataControl
FMXBI.Tree.TBITree
FMXBI.Dashboard.TDashboardTree
Syntax
Delphi
type
 TDashboardTree=class(TBITree)
 end;
See Also

Reference

  • FMXBI.Dashboard


TGridAccess Class

Summary

Represents type TGridAccess.

Namespace: FMXBI.Dashboard
Inheritance Hierarchy
TObject
FMXBI.Grid.Grid.TBIFMXGrid
FMXBI.Dashboard.TGridAccess
Syntax
Delphi
type
 TGridAccess=class(TBIFMXGrid);
See Also

Reference

  • FMXBI.Dashboard


TLayoutComboBox Class

Summary

Represents type TLayoutComboBox.

Namespace: FMXBI.Dashboard
Inheritance Hierarchy
TComboBox
FMXBI.Dashboard.TLayoutComboBox
Syntax
Delphi
type
 TLayoutComboBox=class(TComboBox)
 end;

The TLayoutComboBox type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TLayoutComboBox class.
Top
See Also

Reference

  • FMXBI.Dashboard


TLayoutComboBox Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TLayoutComboBox class.
Top


TLayoutComboBox.Create(TComponent) Constructor

Summary

Initializes a new instance of the TLayoutComboBox class.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TLayoutComboBox
  • FMXBI.Dashboard


TLayoutListBox Class

Summary

Represents type TLayoutListBox.

Namespace: FMXBI.Dashboard
Inheritance Hierarchy
TListBox
FMXBI.Dashboard.TLayoutListBox
Syntax
Delphi
type
 TLayoutListBox=class(TListBox)
 end;

The TLayoutListBox type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TLayoutListBox class.
Top
See Also

Reference

  • FMXBI.Dashboard


TLayoutListBox Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TLayoutListBox class.
Top


TLayoutListBox.Create(TComponent) Constructor

Summary

Initializes a new instance of the TLayoutListBox class.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TLayoutListBox
  • FMXBI.Dashboard


TLayoutPanel Class

Summary

Represents type TLayoutPanel.

Namespace: FMXBI.Dashboard
Inheritance Hierarchy
FMXBI.Dashboard.TPanel
FMXBI.Dashboard.TLayoutPanel
Syntax
Delphi
type
 TLayoutPanel=class(TPanel)
 end;

The TLayoutPanel type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TLayoutPanel class.
Top
Properties
Show:
Name | Description
BackColor | Represents property BackColor.
Top
Fields
Show:
Name | Description
DefaultColor | Represents field DefaultColor.
Top
See Also

Reference

  • FMXBI.Dashboard


TLayoutPanel Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TLayoutPanel class.
Top


TLayoutPanel.Create(TComponent) Constructor

Summary

Initializes a new instance of the TLayoutPanel class.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TLayoutPanel
  • FMXBI.Dashboard


TLayoutPanel Properties

Properties
Name | Description
BackColor | Represents property BackColor.
Top


TLayoutPanel.BackColor Property

Summary

Represents property BackColor.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 property BackColor:TAlphaColor read FBackColor write SetBackColor default TAlphaColors.Null;

Property Value

Type: TAlphaColor

See Also

Reference

  • TLayoutPanel
  • FMXBI.Dashboard


TLayoutPanel Fields

Fields
Name | Description
DefaultColor | Represents field DefaultColor.
Top


TLayoutPanel.DefaultColor Field

Summary

Represents field DefaultColor.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 DefaultColor : TAlphaColor;

Field Value

Type: TAlphaColor

See Also

Reference

  • TLayoutPanel
  • FMXBI.Dashboard


TRenderAccess Class

Summary

Represents type TRenderAccess.

Namespace: FMXBI.Dashboard
Inheritance Hierarchy
TObject
BI.Dashboard.TRender
FMXBI.Dashboard.TRenderAccess
Syntax
Delphi
type
 TRenderAccess=class(TRender);
See Also

Reference

  • FMXBI.Dashboard


TScreenRender Class

Summary

Represents type TScreenRender.

Namespace: FMXBI.Dashboard
Inheritance Hierarchy
TObject
BI.Dashboard.TRender
FMXBI.Dashboard.TScreenRender
FMXBI.Dashboard.Chart.TScreenChartRender
FMXBI.Dashboard.Chart.TScreenRenderAccess
Syntax
Delphi
type
 TScreenRender=class(TRender)
 end;

The TScreenRender type exposes the following members.

Properties
Show:
Name | Description
Control | Represents property Control.
Top
Methods
Show:
Name | Description
AddListener(String,TObject) | Represents method AddListener(String,TObject). (Overrides TRender.AddListener(String,TObject).)
CanRefreshData(TControl) | Represents method CanRefreshData(TControl).
Clear | Represents method Clear. (Overrides TRender.Clear.)
CreateControl(TLayoutItem,TWinControl,String,Boolean,Boolean) | Represents method CreateControl(TLayoutItem,TWinControl,String,Boolean,Boolean).
CreatePanel | Overloaded. Represents method CreatePanel.
CreatePanel(TAlphaColor) | Overloaded. Represents method CreatePanel(TAlphaColor).
Emit(TDashboard,Integer,String) | Represents method Emit(TDashboard,Integer,String). (Overrides TRender.Emit(TDashboard,Integer,String).)
EmitPanel(TDashboardItem,TPanelKind,String) | Represents method EmitPanel(TDashboardItem,TPanelKind,String).
EnsurePanelData(TCustomBIPanel) | Represents method EnsurePanelData(TCustomBIPanel).
Finish | Represents method Finish. (Overrides TRender.Finish.)
GetItemOf(TControl) | Represents method GetItemOf(TControl).
Init(TDashboard,String,TStrings) | Represents method Init(TDashboard,String,TStrings). (Overrides TRender.Init(TDashboard,String,TStrings).)
NewControl(TPanelKind,TDashboardItem) | Represents method NewControl(TPanelKind,TDashboardItem).
ParentRender | Represents method ParentRender.
PostAddControl(TControl,TDashboardItem) | Represents method PostAddControl(TControl,TDashboardItem).
RadioChange(TObject) | Represents method RadioChange(TObject).
SetNested(TLayoutItem,String,Boolean,Boolean) | Represents method SetNested(TLayoutItem,String,Boolean,Boolean).
Top
Fields
Show:
Name | Description
Targets | Represents field Targets.
Top
See Also

Reference

  • FMXBI.Dashboard


TScreenRender Properties

Properties
Name | Description
Control | Represents property Control.
Top


TScreenRender.Control Property

Summary

Represents property Control.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 property Control:TBIVisual read FControl write FControl;

Property Value

Type: TBIVisual

See Also

Reference

  • TScreenRender
  • FMXBI.Dashboard


TScreenRender Methods

Methods
Name | Description
AddListener(String,TObject) | Represents method AddListener(String,TObject). (Overrides TRender.AddListener(String,TObject).)
CanRefreshData(TControl) | Represents method CanRefreshData(TControl).
Clear | Represents method Clear. (Overrides TRender.Clear.)
CreateControl(TLayoutItem,TWinControl,String,Boolean,Boolean) | Represents method CreateControl(TLayoutItem,TWinControl,String,Boolean,Boolean).
CreatePanel | Overloaded. Represents method CreatePanel.
CreatePanel(TAlphaColor) | Overloaded. Represents method CreatePanel(TAlphaColor).
Emit(TDashboard,Integer,String) | Represents method Emit(TDashboard,Integer,String). (Overrides TRender.Emit(TDashboard,Integer,String).)
EmitPanel(TDashboardItem,TPanelKind,String) | Represents method EmitPanel(TDashboardItem,TPanelKind,String).
EnsurePanelData(TCustomBIPanel) | Represents method EnsurePanelData(TCustomBIPanel).
Finish | Represents method Finish. (Overrides TRender.Finish.)
GetItemOf(TControl) | Represents method GetItemOf(TControl).
Init(TDashboard,String,TStrings) | Represents method Init(TDashboard,String,TStrings). (Overrides TRender.Init(TDashboard,String,TStrings).)
NewControl(TPanelKind,TDashboardItem) | Represents method NewControl(TPanelKind,TDashboardItem).
ParentRender | Represents method ParentRender.
PostAddControl(TControl,TDashboardItem) | Represents method PostAddControl(TControl,TDashboardItem).
RadioChange(TObject) | Represents method RadioChange(TObject).
SetNested(TLayoutItem,String,Boolean,Boolean) | Represents method SetNested(TLayoutItem,String,Boolean,Boolean).
Top


TScreenRender.AddListener(String,TObject) Method

Summary

Represents method AddListener(String,TObject).

Namespace: FMXBI.Dashboard
Syntax
Delphi
protected
 procedure AddListener(const AName:String; const ASource:TObject); override;

Parameters

AName
Type: String

ASource
Type: TObject

Overrides

TRender.AddListener(String,TObject)
See Also

Reference

  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.CanRefreshData(TControl) Method

Summary

Represents method CanRefreshData(TControl).

Namespace: FMXBI.Dashboard
Syntax
Delphi
protected
 function CanRefreshData(const AControl:TControl):Boolean; virtual;

Parameters

AControl
Type: TControl

Return Value

Type: Boolean

See Also

Reference

  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.Clear Method

Summary

Represents method Clear.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 procedure Clear; override;

Overrides

TRender.Clear
See Also

Reference

  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.CreateControl(TLayoutItem,TWinControl,String,Boolean,Boolean) Method

Summary

Represents method CreateControl(TLayoutItem,TWinControl,String,Boolean,Boolean).

Namespace: FMXBI.Dashboard
Syntax
Delphi
protected
 function CreateControl(const ALayout:TLayoutItem; const AParent:TWinControl;
 const APrefix:String;
 const Splitters,ShowNames:Boolean):TWinControl;

Parameters

ALayout
Type: TLayoutItem

AParent
Type: System.Void

APrefix
Type: String

Splitters
Type: Boolean

ShowNames
Type: Boolean

Return Value

Type: TWinControl

See Also

Reference

  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.CreatePanel Method

Summary

Represents method CreatePanel.

Namespace: FMXBI.Dashboard
Syntax
Delphi
protected
 function CreatePanel:TLayoutPanel; overload; inline;

Return Value

Type: TLayoutPanel

See Also

Reference

  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.CreatePanel(TAlphaColor) Method

Summary

Represents method CreatePanel(TAlphaColor).

Namespace: FMXBI.Dashboard
Syntax
Delphi
protected
 function CreatePanel(const ABack:TAlphaColor):TLayoutPanel; overload;

Parameters

ABack
Type: TAlphaColor

Return Value

Type: TLayoutPanel

See Also

Reference

  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.Emit(TDashboard,Integer,String) Method

Summary

Represents method Emit(TDashboard,Integer,String).

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 procedure Emit(const ADashboard:TDashboard; const AItem:Integer; const APosition:String); override;

Parameters

ADashboard
Type: TDashboard

AItem
Type: Integer

APosition
Type: String

Overrides

TRender.Emit(TDashboard,Integer,String)
See Also

Reference

  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.EmitPanel(TDashboardItem,TPanelKind,String) Method

Summary

Represents method EmitPanel(TDashboardItem,TPanelKind,String).

Namespace: FMXBI.Dashboard
Syntax
Delphi
protected
 function EmitPanel(const AItem:TDashboardItem; const AKind:TPanelKind; const APosition:String=''):TControl;

Parameters

AItem
Type: TDashboardItem

AKind
Type: TPanelKind

APosition
Type: String

Return Value

Type: TControl

See Also

Reference

  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.EnsurePanelData(TCustomBIPanel) Method

Summary

Represents method EnsurePanelData(TCustomBIPanel).

Namespace: FMXBI.Dashboard
Syntax
Delphi
protected
 function EnsurePanelData(const APanel:TCustomBIPanel):TDataItem;

Parameters

APanel
Type: TCustomBIPanel

Return Value

Type: TDataItem

See Also

Reference

  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.Finish Method

Summary

Represents method Finish.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 procedure Finish; override;

Overrides

TRender.Finish
See Also

Reference

  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.GetItemOf(TControl) Method

Summary

Represents method GetItemOf(TControl).

Namespace: FMXBI.Dashboard
Syntax
Delphi
protected
 class function GetItemOf(const Sender:TControl):TDashboardItem; static;

Parameters

Sender
Type: TControl

Return Value

Type: TDashboardItem

See Also

Reference

  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.Init(TDashboard,String,TStrings) Method

Summary

Represents method Init(TDashboard,String,TStrings).

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 procedure Init(const ADashboard:TDashboard; const ALayout:String=''; const AParams:TStrings=nil); override;

Parameters

ADashboard
Type: TDashboard

ALayout
Type: String

AParams
Type: TStrings

Overrides

TRender.Init(TDashboard,String,TStrings)
See Also

Reference

  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.NewControl(TPanelKind,TDashboardItem) Method

Summary

Represents method NewControl(TPanelKind,TDashboardItem).

Namespace: FMXBI.Dashboard
Syntax
Delphi
protected
 function NewControl(const AKind:TPanelKind; const AItem:TDashboardItem):TControl; virtual;

Parameters

AKind
Type: TPanelKind

AItem
Type: TDashboardItem

Return Value

Type: TControl

See Also

Reference

  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.ParentRender Method

Summary

Represents method ParentRender.

Namespace: FMXBI.Dashboard
Syntax
Delphi
protected
 function ParentRender:TScreenRender;

Return Value

Type: TScreenRender

See Also

Reference

  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.PostAddControl(TControl,TDashboardItem) Method

Summary

Represents method PostAddControl(TControl,TDashboardItem).

Namespace: FMXBI.Dashboard
Syntax
Delphi
protected
 procedure PostAddControl(const AControl:TControl; const AItem:TDashboardItem); virtual;

Parameters

AControl
Type: TControl

AItem
Type: TDashboardItem

See Also

Reference

  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.RadioChange(TObject) Method

Summary

Represents method RadioChange(TObject).

Namespace: FMXBI.Dashboard
Syntax
Delphi
protected
 procedure RadioChange(Sender: TObject); virtual;

Parameters

Sender
Type: TObject

See Also

Reference

  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.SetNested(TLayoutItem,String,Boolean,Boolean) Method

Summary

Represents method SetNested(TLayoutItem,String,Boolean,Boolean).

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 procedure SetNested(const AItem:TLayoutItem; const AName:String; const Splitters,ShowNames:Boolean);

Parameters

AItem
Type: TLayoutItem

AName
Type: String

Splitters
Type: Boolean

ShowNames
Type: Boolean

See Also

Reference

  • TScreenRender
  • FMXBI.Dashboard


TScreenRender Fields

Fields
Name | Description
Targets | Represents field Targets.
Top


TScreenRender.Targets Field

Summary

Represents field Targets.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 Targets : TTargetControls;

Field Value

Type: TTargetControls

See Also

Reference

  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.TTargetControlsHelper Class Helper

Summary

Represents type TTargetControlsHelper.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
type
 TTargetControlsHelper=record helper for TTargetControls
 end;
Methods
Name | Description
Add(String,TControl,TLayoutItem) | Represents method Add(String,TControl,TLayoutItem).
Count | Represents method Count.
FindControl(String) | Overloaded. Represents method FindControl(String).
FindControl(TLayoutItem) | Overloaded. Represents method FindControl(TLayoutItem).
FindLayout(TControl) | Represents method FindLayout(TControl).
Top
See Also

Reference

  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.TTargetControlsHelper Methods

Methods
Name | Description
Add(String,TControl,TLayoutItem) | Represents method Add(String,TControl,TLayoutItem).
Count | Represents method Count.
FindControl(String) | Overloaded. Represents method FindControl(String).
FindControl(TLayoutItem) | Overloaded. Represents method FindControl(TLayoutItem).
FindLayout(TControl) | Represents method FindLayout(TControl).
Top


TScreenRender.TTargetControlsHelper.Add(String,TControl,TLayoutItem) Method

Summary

Represents method Add(String,TControl,TLayoutItem).

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 function Add(const AName:String; const AControl:TControl; const ALayout:TLayoutItem):Integer;

Parameters

AName
Type: String

AControl
Type: TControl

ALayout
Type: TLayoutItem

Return Value

Type: Integer

See Also

Reference

  • TScreenRender.TTargetControlsHelper
  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.TTargetControlsHelper.Count Method

Summary

Represents method Count.

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 function Count:Integer; inline;

Return Value

Type: Integer

See Also

Reference

  • TScreenRender.TTargetControlsHelper
  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.TTargetControlsHelper.FindControl(String) Method

Summary

Represents method FindControl(String).

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 function FindControl(const AName:String):TControl; overload;

Parameters

AName
Type: String

Return Value

Type: TControl

See Also

Reference

  • TScreenRender.TTargetControlsHelper
  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.TTargetControlsHelper.FindControl(TLayoutItem) Method

Summary

Represents method FindControl(TLayoutItem).

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 function FindControl(const AItem:TLayoutItem):TControl; overload;

Parameters

AItem
Type: TLayoutItem

Return Value

Type: TControl

See Also

Reference

  • TScreenRender.TTargetControlsHelper
  • TScreenRender
  • FMXBI.Dashboard


TScreenRender.TTargetControlsHelper.FindLayout(TControl) Method

Summary

Represents method FindLayout(TControl).

Namespace: FMXBI.Dashboard
Syntax
Delphi
public
 function FindLayout(const AControl:TControl):TLayoutItem;

Parameters

AControl
Type: TControl

Return Value

Type: TLayoutItem

See Also

Reference

  • TScreenRender.TTargetControlsHelper
  • TScreenRender
  • FMXBI.Dashboard


FMXBI.Dashboard Types

Types
Name | Description
TAlign | Represents an alias of the TAlignLayout type.
TCheckListBox | Represents an alias of the TListBox type.
TControlClass | Represents type TControlClass.
TDBNavigator | Represents an alias of the TBindNavigator type.
TGraphic | Represents an alias of the TBitmap type.
TPageControl | Represents an alias of the TTabControl type.
TPanel | Represents an alias of the TRectangle type.
TScreenRenderClass | Represents type TScreenRenderClass.
TTabSheet | Represents an alias of the TTabItem type.
TWinControl | Represents an alias of the TControl type.
Top


TAlign Type

Summary

Represents an alias of the TAlignLayout type.

Namespace: FMXBI.Dashboard
Syntax
Delphi
type
 TAlign=TAlignLayout;
See Also

Reference

  • FMXBI.Dashboard


TCheckListBox Type

Summary

Represents an alias of the TListBox type.

Namespace: FMXBI.Dashboard
Syntax
Delphi
type
 TCheckListBox=TListBox;
See Also

Reference

  • FMXBI.Dashboard


TControlClass Type

Summary

Represents type TControlClass.

Namespace: FMXBI.Dashboard
Syntax
Delphi
type
 TControlClass=class of TWinControl;
See Also

Reference

  • FMXBI.Dashboard


TDBNavigator Type

Summary

Represents an alias of the TBindNavigator type.

Namespace: FMXBI.Dashboard
Syntax
Delphi
type
 TDBNavigator=TBindNavigator;
See Also

Reference

  • FMXBI.Dashboard


TGraphic Type

Summary

Represents an alias of the TBitmap type.

Namespace: FMXBI.Dashboard
Syntax
Delphi
type
 TGraphic=TBitmap;
See Also

Reference

  • FMXBI.Dashboard


TPageControl Type

Summary

Represents an alias of the TTabControl type.

Namespace: FMXBI.Dashboard
Syntax
Delphi
type
 TPageControl=TTabControl;
See Also

Reference

  • FMXBI.Dashboard


TPanel Type

Summary

Represents an alias of the TRectangle type.

Namespace: FMXBI.Dashboard
Syntax
Delphi
type
 TPanel=TRectangle;
See Also

Reference

  • FMXBI.Dashboard


TScreenRenderClass Type

Summary

Represents type TScreenRenderClass.

Namespace: FMXBI.Dashboard
Syntax
Delphi
type
 TScreenRenderClass=class of TScreenRender;
See Also

Reference

  • FMXBI.Dashboard


TTabSheet Type

Summary

Represents an alias of the TTabItem type.

Namespace: FMXBI.Dashboard
Syntax
Delphi
type
 TTabSheet=TTabItem;
See Also

Reference

  • FMXBI.Dashboard


TWinControl Type

Summary

Represents an alias of the TControl type.

Namespace: FMXBI.Dashboard
Syntax
Delphi
type
 TWinControl=TControl;
See Also

Reference

  • FMXBI.Dashboard


FMXBI.Dashboard Constants

Constants
Name | Description
BrushKindNone | Represents constant BrushKindNone.
BrushKindSolid | Represents constant BrushKindSolid.
Top


BrushKindNone Constant

Summary

Represents constant BrushKindNone.

Namespace: FMXBI.Dashboard
Syntax
Delphi
 BrushKindNone:TBrushKind=TBrushKind.None;

Value

Type: TBrushKind

See Also

Reference

  • FMXBI.Dashboard


BrushKindSolid Constant

Summary

Represents constant BrushKindSolid.

Namespace: FMXBI.Dashboard
Syntax
Delphi
 BrushKindSolid:TBrushKind=TBrushKind.Solid;

Value

Type: TBrushKind

See Also

Reference

  • FMXBI.Dashboard


FMXBI.Dashboard Routines

Routines
Name | Description
AlignOf(String) | Represents method AlignOf(String).
AlphaColorToColor(TAlphaColor) | Represents method AlphaColorToColor(TAlphaColor).
CreatePanelFrame(TWinControl) | Represents method CreatePanelFrame(TWinControl).
CreatePanelText(TControl,String) | Represents method CreatePanelText(TControl,String).
DoSetPadding(TWinControl,Single) | Represents method DoSetPadding(TWinControl,Single).
GetURLStream(String) | Represents method GetURLStream(String).
IsAlignLeftRight(TControl) | Represents method IsAlignLeftRight(TControl).
IsAlignTopBottom(TControl) | Represents method IsAlignTopBottom(TControl).
LoadImage(TImage,String) | Represents method LoadImage(TImage,String).
NewTab(TControl,TWinControl,String) | Represents method NewTab(TControl,TWinControl,String).
ParentOf(TControl) | Represents method ParentOf(TControl).
RandomLightColor | Represents method RandomLightColor.
RepositionControl(TControl) | Represents method RepositionControl(TControl).
ScrollContentOf(TWinControl) | Represents method ScrollContentOf(TWinControl).
SetDefaultPadding(TWinControl) | Represents method SetDefaultPadding(TWinControl).
ShowHideAll(TControl,Integer) | Represents method ShowHideAll(TControl,Integer).
TitleOf(TDashboardItem) | Represents method TitleOf(TDashboardItem).
Top


AlignOf(String) Method

Summary

Represents method AlignOf(String).

Namespace: FMXBI.Dashboard
Syntax
Delphi
function AlignOf(const Align:String):TAlign;

Parameters

Align
Type: String

Return Value

Type: TAlign

See Also

Reference

  • FMXBI.Dashboard


AlphaColorToColor(TAlphaColor) Method

Summary

Represents method AlphaColorToColor(TAlphaColor).

Namespace: FMXBI.Dashboard
Syntax
Delphi
function AlphaColorToColor(const Color: TAlphaColor): TColor;

Parameters

Color
Type: TAlphaColor

Return Value

Type: TColor

See Also

Reference

  • FMXBI.Dashboard


CreatePanelFrame(TWinControl) Method

Summary

Represents method CreatePanelFrame(TWinControl).

Namespace: FMXBI.Dashboard
Syntax
Delphi
function CreatePanelFrame(const AControl:TWinControl):TRectangle;

Parameters

AControl
Type: System.Void

Return Value

Type: TRectangle

See Also

Reference

  • FMXBI.Dashboard


CreatePanelText(TControl,String) Method

Summary

Represents method CreatePanelText(TControl,String).

Namespace: FMXBI.Dashboard
Syntax
Delphi
function CreatePanelText(const AOwner:TControl; const AText:String):TText;

Parameters

AOwner
Type: TControl

AText
Type: String

Return Value

Type: TText

See Also

Reference

  • FMXBI.Dashboard


DoSetPadding(TWinControl,Single) Method

Summary

Represents method DoSetPadding(TWinControl,Single).

Namespace: FMXBI.Dashboard
Syntax
Delphi
procedure DoSetPadding(const AControl: TWinControl; const APadding:Single);

Parameters

AControl
Type: System.Void

APadding
Type: Single

See Also

Reference

  • FMXBI.Dashboard


GetURLStream(String) Method

Summary

Represents method GetURLStream(String).

Namespace: FMXBI.Dashboard
Syntax
Delphi
function GetURLStream(const AURL:String):TStream;

Parameters

AURL
Type: String

Return Value

Type: TStream

See Also

Reference

  • FMXBI.Dashboard


IsAlignLeftRight(TControl) Method

Summary

Represents method IsAlignLeftRight(TControl).

Namespace: FMXBI.Dashboard
Syntax
Delphi
function IsAlignLeftRight(const AControl:TControl):Boolean;

Parameters

AControl
Type: TControl

Return Value

Type: Boolean

See Also

Reference

  • FMXBI.Dashboard


IsAlignTopBottom(TControl) Method

Summary

Represents method IsAlignTopBottom(TControl).

Namespace: FMXBI.Dashboard
Syntax
Delphi
function IsAlignTopBottom(const AControl:TControl):Boolean;

Parameters

AControl
Type: TControl

Return Value

Type: Boolean

See Also

Reference

  • FMXBI.Dashboard


LoadImage(TImage,String) Method

Summary

Represents method LoadImage(TImage,String).

Namespace: FMXBI.Dashboard
Syntax
Delphi
procedure LoadImage(const AImage:TImage; const AURL:String);

Parameters

AImage
Type: TImage

AURL
Type: String

See Also

Reference

  • FMXBI.Dashboard


NewTab(TControl,TWinControl,String) Method

Summary

Represents method NewTab(TControl,TWinControl,String).

Namespace: FMXBI.Dashboard
Syntax
Delphi
function NewTab(var FTabs:TControl; const AOwner:TWinControl;
 const ATitle:String):TTabSheet;

Parameters

FTabs
Type: TControl

AOwner
Type: System.Void

ATitle
Type: String

Return Value

Type: TTabSheet

See Also

Reference

  • FMXBI.Dashboard


ParentOf(TControl) Method

Summary

Represents method ParentOf(TControl).

Namespace: FMXBI.Dashboard
Syntax
Delphi
function ParentOf(const AControl:TControl):TWinControl; inline;

Parameters

AControl
Type: TControl

Return Value

Type: TWinControl

See Also

Reference

  • FMXBI.Dashboard


RandomLightColor Method

Summary

Represents method RandomLightColor.

Namespace: FMXBI.Dashboard
Syntax
Delphi
function RandomLightColor:TAlphaColor;

Return Value

Type: TAlphaColor

See Also

Reference

  • FMXBI.Dashboard


RepositionControl(TControl) Method

Summary

Represents method RepositionControl(TControl).

Namespace: FMXBI.Dashboard
Syntax
Delphi
procedure RepositionControl(const AControl:TControl);

Parameters

AControl
Type: TControl

See Also

Reference

  • FMXBI.Dashboard


ScrollContentOf(TWinControl) Method

Summary

Represents method ScrollContentOf(TWinControl).

Namespace: FMXBI.Dashboard
Syntax
Delphi
function ScrollContentOf(const AParent:TWinControl):TWinControl;

Parameters

AParent
Type: System.Void

Return Value

Type: TWinControl

See Also

Reference

  • FMXBI.Dashboard


SetDefaultPadding(TWinControl) Method

Summary

Represents method SetDefaultPadding(TWinControl).

Namespace: FMXBI.Dashboard
Syntax
Delphi
procedure SetDefaultPadding(const AControl:TWinControl);

Parameters

AControl
Type: System.Void

See Also

Reference

  • FMXBI.Dashboard


ShowHideAll(TControl,Integer) Method

Summary

Represents method ShowHideAll(TControl,Integer).

Namespace: FMXBI.Dashboard
Syntax
Delphi
procedure ShowHideAll(const AControl:TControl; const AIndex:Integer);

Parameters

AControl
Type: TControl

AIndex
Type: Integer

See Also

Reference

  • FMXBI.Dashboard


TitleOf(TDashboardItem) Method

Summary

Represents method TitleOf(TDashboardItem).

Namespace: FMXBI.Dashboard
Syntax
Delphi
function TitleOf(const AItem:TDashboardItem):String;

Parameters

AItem
Type: TDashboardItem

Return Value

Type: String

See Also

Reference

  • FMXBI.Dashboard


FMXBI.Dashboard.Chart Namespace

Summary

Represents namespace FMXBI.Dashboard.Chart.

Classes
Name | Description
TDashboardItemAccess | Represents type TDashboardItemAccess.
TScreenChartRender | Represents type TScreenChartRender.
TScreenRenderAccess | Represents type TScreenRenderAccess.
Top


FMXBI.Dashboard.Chart Classes

Classes
Name | Description
TDashboardItemAccess | Represents type TDashboardItemAccess.
TScreenChartRender | Represents type TScreenChartRender.
TScreenRenderAccess | Represents type TScreenRenderAccess.
Top


TDashboardItemAccess Class

Summary

Represents type TDashboardItemAccess.

Namespace: FMXBI.Dashboard.Chart
Inheritance Hierarchy
TCollectionItem
BI.Dashboard.TBaseItem
BI.Dashboard.TCustomBIPanel
BI.Dashboard.TDashboardItem
FMXBI.Dashboard.Chart.TDashboardItemAccess
Syntax
Delphi
type
 TDashboardItemAccess=class(TDashboardItem);
See Also

Reference

  • FMXBI.Dashboard.Chart


TScreenChartRender Class

Summary

Represents type TScreenChartRender.

Namespace: FMXBI.Dashboard.Chart
Inheritance Hierarchy
TObject
BI.Dashboard.TRender
FMXBI.Dashboard.TScreenRender
FMXBI.Dashboard.Chart.TScreenChartRender
Syntax
Delphi
type
 TScreenChartRender=class(TScreenRender)
 end;

The TScreenChartRender type exposes the following members.

Methods
Show:
Name | Description
CanRefreshData(TControl) | Represents method CanRefreshData(TControl). (Overrides TScreenRender.CanRefreshData(TControl).)
NewChart(TComponent,TDashboardItem,TDataItem,String) | Represents method NewChart(TComponent,TDashboardItem,TDataItem,String).
NewControl(TPanelKind,TDashboardItem) | Represents method NewControl(TPanelKind,TDashboardItem). (Overrides TScreenRender.NewControl(TPanelKind,TDashboardItem).)
PostAddControl(TControl,TDashboardItem) | Represents method PostAddControl(TControl,TDashboardItem). (Overrides TScreenRender.PostAddControl(TControl,TDashboardItem).)
RadioChange(TObject) | Represents method RadioChange(TObject). (Overrides TScreenRender.RadioChange(TObject).)
Top
See Also

Reference

  • FMXBI.Dashboard.Chart


TScreenChartRender Methods

Methods
Name | Description
CanRefreshData(TControl) | Represents method CanRefreshData(TControl). (Overrides TScreenRender.CanRefreshData(TControl).)
NewChart(TComponent,TDashboardItem,TDataItem,String) | Represents method NewChart(TComponent,TDashboardItem,TDataItem,String).
NewControl(TPanelKind,TDashboardItem) | Represents method NewControl(TPanelKind,TDashboardItem). (Overrides TScreenRender.NewControl(TPanelKind,TDashboardItem).)
PostAddControl(TControl,TDashboardItem) | Represents method PostAddControl(TControl,TDashboardItem). (Overrides TScreenRender.PostAddControl(TControl,TDashboardItem).)
RadioChange(TObject) | Represents method RadioChange(TObject). (Overrides TScreenRender.RadioChange(TObject).)
Top


TScreenChartRender.CanRefreshData(TControl) Method

Summary

Represents method CanRefreshData(TControl).

Namespace: FMXBI.Dashboard.Chart
Syntax
Delphi
protected
 function CanRefreshData(const AControl:TControl):Boolean; override;

Parameters

AControl
Type: TControl

Return Value

Type: Boolean

Overrides

TScreenRender.CanRefreshData(TControl)
See Also

Reference

  • TScreenChartRender
  • FMXBI.Dashboard.Chart


TScreenChartRender.NewChart(TComponent,TDashboardItem,TDataItem,String) Method

Summary

Represents method NewChart(TComponent,TDashboardItem,TDataItem,String).

Namespace: FMXBI.Dashboard.Chart
Syntax
Delphi
public
 class function NewChart(const AOwner:TComponent; const AItem:TDashboardItem;
 const AData:TDataItem;
 const AFormat:String):TBIChart; static;

Parameters

AOwner
Type: TComponent

AItem
Type: TDashboardItem

AData
Type: TDataItem

AFormat
Type: String

Return Value

Type: TBIChart

See Also

Reference

  • TScreenChartRender
  • FMXBI.Dashboard.Chart


TScreenChartRender.NewControl(TPanelKind,TDashboardItem) Method

Summary

Represents method NewControl(TPanelKind,TDashboardItem).

Namespace: FMXBI.Dashboard.Chart
Syntax
Delphi
protected
 function NewControl(const AKind:TPanelKind; const AItem:TDashboardItem):TControl; override;

Parameters

AKind
Type: TPanelKind

AItem
Type: TDashboardItem

Return Value

Type: TControl

Overrides

TScreenRender.NewControl(TPanelKind,TDashboardItem)
See Also

Reference

  • TScreenChartRender
  • FMXBI.Dashboard.Chart


TScreenChartRender.PostAddControl(TControl,TDashboardItem) Method

Summary

Represents method PostAddControl(TControl,TDashboardItem).

Namespace: FMXBI.Dashboard.Chart
Syntax
Delphi
protected
 procedure PostAddControl(const AControl:TControl; const AItem:TDashboardItem); override;

Parameters

AControl
Type: TControl

AItem
Type: TDashboardItem

Overrides

TScreenRender.PostAddControl(TControl,TDashboardItem)
See Also

Reference

  • TScreenChartRender
  • FMXBI.Dashboard.Chart


TScreenChartRender.RadioChange(TObject) Method

Summary

Represents method RadioChange(TObject).

Namespace: FMXBI.Dashboard.Chart
Syntax
Delphi
protected
 procedure RadioChange(Sender: TObject); override;

Parameters

Sender
Type: TObject

Overrides

TScreenRender.RadioChange(TObject)
See Also

Reference

  • TScreenChartRender
  • FMXBI.Dashboard.Chart


TScreenRenderAccess Class

Summary

Represents type TScreenRenderAccess.

Namespace: FMXBI.Dashboard.Chart
Inheritance Hierarchy
TObject
BI.Dashboard.TRender
FMXBI.Dashboard.TScreenRender
FMXBI.Dashboard.Chart.TScreenRenderAccess
Syntax
Delphi
type
 TScreenRenderAccess=class(TScreenRender);
See Also

Reference

  • FMXBI.Dashboard.Chart


FMXBI.DataControl Namespace

Summary

Represents namespace FMXBI.DataControl.

Classes
Name | Description
TBIDataControl | Represents type TBIDataControl.
TDataAccess | Represents type TDataAccess.
TDataProviderAccess | Represents type TDataProviderAccess.
Top


FMXBI.DataControl Classes

Classes
Name | Description
TBIDataControl | Represents type TBIDataControl.
TDataAccess | Represents type TDataAccess.
TDataProviderAccess | Represents type TDataProviderAccess.
Top


TBIDataControl Class

Summary

Represents type TBIDataControl.

Namespace: FMXBI.DataControl
Inheritance Hierarchy
TLayout
FMXBI.DataControl.TBIDataControl
FMXBI.Chart.Plugin.TBIDataControlAccess
FMXBI.Chart.TBIChart
FMXBI.Grid.TBIGrid
FMXBI.Tree.TBITree
Syntax
Delphi
type
 TBIDataControl=class(TLayout)
 end;

The TBIDataControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIDataControl class.
Destroy | Represents the destructor of the TBIDataControl class.
Top
Properties
Show:
Name | Description
Align | Represents property Align.
Anchors | Represents property Anchors.
ClipChildren | Represents property ClipChildren.
ClipParent | Represents property ClipParent.
Data | Represents property Data.
DragMode | Represents property DragMode.
Enabled | Represents property Enabled.
EnableDragHighlight | Represents property EnableDragHighlight.
Height | Represents property Height.
HitTest | Represents property HitTest.
Locked | Represents property Locked.
Margins | Represents property Margins.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnDragDrop | Represents property OnDragDrop.
OnDragEnd | Represents property OnDragEnd.
OnDragEnter | Represents property OnDragEnter.
OnDragLeave | Represents property OnDragLeave.
OnDragOver | Represents property OnDragOver.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnGesture | Represents property OnGesture.
OnMouseDown | Represents property OnMouseDown.
OnMouseEnter | Represents property OnMouseEnter.
OnMouseLeave | Represents property OnMouseLeave.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnPaint | Represents property OnPaint.
OnPainting | Represents property OnPainting.
OnResize | Represents property OnResize.
OnResized | Represents property OnResized.
Opacity | Represents property Opacity.
Padding | Represents property Padding.
PopupMenu | Represents property PopupMenu.
Position | Represents property Position.
Provider | Represents property Provider.
RotationAngle | Represents property RotationAngle.
RotationCenter | Represents property RotationCenter.
Scale | Represents property Scale.
ShowHint | Represents property ShowHint.
Size | Represents property Size.
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
Touch | Represents property Touch.
TouchTargetExpansion | Represents property TouchTargetExpansion.
Visible | Represents property Visible.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
AddNotify | Represents method AddNotify.
ControlOfClass(TClass) | Represents method ControlOfClass(TClass).
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
DestroyData | Represents method DestroyData.
Loaded | Represents method Loaded.
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
RefreshData | Represents method RefreshData.
RemoveNotify | Represents method RemoveNotify.
SetDataDirect(TDataItem) | Represents method SetDataDirect(TDataItem).
UpdatedDataValues | Represents method UpdatedDataValues.
Top
See Also

Reference

  • FMXBI.DataControl


TBIDataControl Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBIDataControl class.
Destroy | Represents the destructor of the TBIDataControl class.
Top


TBIDataControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIDataControl class.

Namespace: FMXBI.DataControl
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.Destroy Destructor

Summary

Represents the destructor of the TBIDataControl class.

Namespace: FMXBI.DataControl
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl Properties

Properties
Name | Description
Align | Represents property Align.
Anchors | Represents property Anchors.
ClipChildren | Represents property ClipChildren.
ClipParent | Represents property ClipParent.
Data | Represents property Data.
DragMode | Represents property DragMode.
Enabled | Represents property Enabled.
EnableDragHighlight | Represents property EnableDragHighlight.
Height | Represents property Height.
HitTest | Represents property HitTest.
Locked | Represents property Locked.
Margins | Represents property Margins.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnDragDrop | Represents property OnDragDrop.
OnDragEnd | Represents property OnDragEnd.
OnDragEnter | Represents property OnDragEnter.
OnDragLeave | Represents property OnDragLeave.
OnDragOver | Represents property OnDragOver.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnGesture | Represents property OnGesture.
OnMouseDown | Represents property OnMouseDown.
OnMouseEnter | Represents property OnMouseEnter.
OnMouseLeave | Represents property OnMouseLeave.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnPaint | Represents property OnPaint.
OnPainting | Represents property OnPainting.
OnResize | Represents property OnResize.
OnResized | Represents property OnResized.
Opacity | Represents property Opacity.
Padding | Represents property Padding.
PopupMenu | Represents property PopupMenu.
Position | Represents property Position.
Provider | Represents property Provider.
RotationAngle | Represents property RotationAngle.
RotationCenter | Represents property RotationCenter.
Scale | Represents property Scale.
ShowHint | Represents property ShowHint.
Size | Represents property Size.
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
Touch | Represents property Touch.
TouchTargetExpansion | Represents property TouchTargetExpansion.
Visible | Represents property Visible.
Width | Represents property Width.
Top


TBIDataControl.Align Property

Summary

Represents property Align.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property Align;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.Anchors Property

Summary

Represents property Anchors.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property Anchors;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.ClipChildren Property

Summary

Represents property ClipChildren.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property ClipChildren;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.ClipParent Property

Summary

Represents property ClipParent.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property ClipParent;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.Data Property

Summary

Represents property Data.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property Data:TDataItem read GetDataItem write SetDataItem default nil;

Property Value

Type: TDataItem

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.DragMode Property

Summary

Represents property DragMode.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property DragMode;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.Enabled Property

Summary

Represents property Enabled.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property Enabled;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.EnableDragHighlight Property

Summary

Represents property EnableDragHighlight.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property EnableDragHighlight;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.Height Property

Summary

Represents property Height.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property Height;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.HitTest Property

Summary

Represents property HitTest.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property HitTest;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.Locked Property

Summary

Represents property Locked.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property Locked;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.Margins Property

Summary

Represents property Margins.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property Margins;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.OnClick Property

Summary

Represents property OnClick.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.OnDragDrop Property

Summary

Represents property OnDragDrop.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property OnDragDrop;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.OnDragEnd Property

Summary

Represents property OnDragEnd.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property OnDragEnd;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.OnDragEnter Property

Summary

Represents property OnDragEnter.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property OnDragEnter;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.OnDragLeave Property

Summary

Represents property OnDragLeave.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property OnDragLeave;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.OnDragOver Property

Summary

Represents property OnDragOver.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property OnDragOver;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.OnEnter Property

Summary

Represents property OnEnter.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.OnExit Property

Summary

Represents property OnExit.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.OnGesture Property

Summary

Represents property OnGesture.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property OnGesture;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.OnMouseEnter Property

Summary

Represents property OnMouseEnter.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property OnMouseEnter;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.OnMouseLeave Property

Summary

Represents property OnMouseLeave.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property OnMouseLeave;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.OnPaint Property

Summary

Represents property OnPaint.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property OnPaint;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.OnPainting Property

Summary

Represents property OnPainting.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property OnPainting;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.OnResize Property

Summary

Represents property OnResize.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property OnResize;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.OnResized Property

Summary

Represents property OnResized.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property OnResized;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.Opacity Property

Summary

Represents property Opacity.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property Opacity;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.Padding Property

Summary

Represents property Padding.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property Padding;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.PopupMenu Property

Summary

Represents property PopupMenu.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property PopupMenu;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.Position Property

Summary

Represents property Position.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property Position;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.Provider Property

Summary

Represents property Provider.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property Provider:TComponent read GetProvider write SetProvider;

Property Value

Type: TComponent

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.RotationAngle Property

Summary

Represents property RotationAngle.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property RotationAngle;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.RotationCenter Property

Summary

Represents property RotationCenter.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property RotationCenter;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.Scale Property

Summary

Represents property Scale.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property Scale;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.ShowHint Property

Summary

Represents property ShowHint.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property ShowHint;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.Size Property

Summary

Represents property Size.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property Size;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.TabOrder Property

Summary

Represents property TabOrder.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property TabOrder;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.TabStop Property

Summary

Represents property TabStop.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.Touch Property

Summary

Represents property Touch.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property Touch;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.TouchTargetExpansion Property

Summary

Represents property TouchTargetExpansion.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property TouchTargetExpansion;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.Visible Property

Summary

Represents property Visible.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property Visible;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.Width Property

Summary

Represents property Width.

Namespace: FMXBI.DataControl
Syntax
Delphi
published
 property Width;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl Methods

Methods
Name | Description
AddNotify | Represents method AddNotify.
ControlOfClass(TClass) | Represents method ControlOfClass(TClass).
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
DestroyData | Represents method DestroyData.
Loaded | Represents method Loaded.
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
RefreshData | Represents method RefreshData.
RemoveNotify | Represents method RemoveNotify.
SetDataDirect(TDataItem) | Represents method SetDataDirect(TDataItem).
UpdatedDataValues | Represents method UpdatedDataValues.
Top


TBIDataControl.AddNotify Method

Summary

Represents method AddNotify.

Namespace: FMXBI.DataControl
Syntax
Delphi
protected
 procedure AddNotify;
See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.ControlOfClass(TClass) Method

Summary

Represents method ControlOfClass(TClass).

Namespace: FMXBI.DataControl
Syntax
Delphi
protected
 function ControlOfClass(const AClass:TClass): TControl;

Parameters

AClass
Type: TClass

Return Value

Type: TControl

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: FMXBI.DataControl
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.DestroyData Method

Summary

Represents method DestroyData.

Namespace: FMXBI.DataControl
Syntax
Delphi
public
 procedure DestroyData;
See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.Loaded Method

Summary

Represents method Loaded.

Namespace: FMXBI.DataControl
Syntax
Delphi
protected
 procedure Loaded; override;
See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: FMXBI.DataControl
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.RefreshData Method

Summary

Represents method RefreshData.

Namespace: FMXBI.DataControl
Syntax
Delphi
public
 procedure RefreshData; virtual;
See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.RemoveNotify Method

Summary

Represents method RemoveNotify.

Namespace: FMXBI.DataControl
Syntax
Delphi
protected
 procedure RemoveNotify;
See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.SetDataDirect(TDataItem) Method

Summary

Represents method SetDataDirect(TDataItem).

Namespace: FMXBI.DataControl
Syntax
Delphi
protected
 procedure SetDataDirect(const Value: TDataItem); virtual;

Parameters

Value
Type: TDataItem

See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TBIDataControl.UpdatedDataValues Method

Summary

Represents method UpdatedDataValues.

Namespace: FMXBI.DataControl
Syntax
Delphi
protected
 procedure UpdatedDataValues; virtual;
See Also

Reference

  • TBIDataControl
  • FMXBI.DataControl


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: FMXBI.DataControl
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
FMXBI.DataControl.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • FMXBI.DataControl


TDataProviderAccess Class

Summary

Represents type TDataProviderAccess.

Namespace: FMXBI.DataControl
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
FMXBI.DataControl.TDataProviderAccess
Syntax
Delphi
type
 TDataProviderAccess=class(TDataProvider);
See Also

Reference

  • FMXBI.DataControl


FMXBI.DataManager Namespace

Summary

Represents namespace FMXBI.DataManager.

Classes
Name | Description
TDataManager | Represents type TDataManager.
Top
Enumerations
Name | Description
TDataManagerEmbedMode | Represents type TDataManagerEmbedMode.
Top


FMXBI.DataManager Classes

Classes
Name | Description
TDataManager | Represents type TDataManager.
Top


TDataManager Class

Summary

Represents type TDataManager.

Namespace: FMXBI.DataManager
Inheritance Hierarchy
TForm
FMXBI.DataManager.TDataManager
Syntax
Delphi
type
 TDataManager = class(TForm)
 end;

The TDataManager type exposes the following members.

Properties
Show:
Name | Description
OnSelect | Represents property OnSelect.
Top
Methods
Show:
Name | Description
BAddClick(TObject) | Represents method BAddClick(TObject).
BCancelClick(TObject) | Represents method BCancelClick(TObject).
BChangeClick(TObject) | Represents method BChangeClick(TObject).
BDeleteClick(TObject) | Represents method BDeleteClick(TObject).
BImportNowClick(TObject) | Represents method BImportNowClick(TObject).
BRenameClick(TObject) | Represents method BRenameClick(TObject).
BSelectClick(TObject) | Represents method BSelectClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
BViewDataClick(TObject) | Represents method BViewDataClick(TObject).
CBParallelChange(TObject) | Represents method CBParallelChange(TObject).
CBRefreshChange(TObject) | Represents method CBRefreshChange(TObject).
CBStoresChange(TObject) | Represents method CBStoresChange(TObject).
ChooseData(TComponent,String,TDataItem) | Represents method ChooseData(TComponent,String,TDataItem).
ChooseName(TComponent,String) | Represents method ChooseName(TComponent,String).
Edit(TComponent,String) | Represents method Edit(TComponent,String).
Embed(TComponent,TControl,TDataManagerEmbedMode,String) | Represents method Embed(TComponent,TControl,TDataManagerEmbedMode,String).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
ListDataChange(TObject) | Represents method ListDataChange(TObject).
LSourcesChange(TObject) | Represents method LSourcesChange(TObject).
MenuItem1Click(TObject) | Represents method MenuItem1Click(TObject).
MenuItem2Click(TObject) | Represents method MenuItem2Click(TObject).
MenuItem3Click(TObject) | Represents method MenuItem3Click(TObject).
MenuItem4Click(TObject) | Represents method MenuItem4Click(TObject).
PeriodChange(TObject) | Represents method PeriodChange(TObject).
RefreshUnitChange(TObject) | Represents method RefreshUnitChange(TObject).
Selected | Represents method Selected.
TabControl1Change(TObject) | Represents method TabControl1Change(TObject).
TabControl1Resize(TObject) | Represents method TabControl1Resize(TObject).
Top
Fields
Show:
Name | Description
BAdd | Represents field BAdd.
BCancel | Represents field BCancel.
BChange | Represents field BChange.
BDelete | Represents field BDelete.
BImportNow | Represents field BImportNow.
BRename | Represents field BRename.
BSelect | Represents field BSelect.
Button1 | Represents field Button1.
BViewData | Represents field BViewData.
CBKeep | Represents field CBKeep.
CBParallel | Represents field CBParallel.
CBRefresh | Represents field CBRefresh.
CBStopOnErrors | Represents field CBStopOnErrors.
CBStores | Represents field CBStores.
ImportProgress | Represents field ImportProgress.
Label1 | Represents field Label1.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
Layout1 | Represents field Layout1.
Layout3 | Represents field Layout3.
LayoutAddDelete | Represents field LayoutAddDelete.
LayoutButtons | Represents field LayoutButtons.
LayoutOkCancel | Represents field LayoutOkCancel.
LayoutSources | Represents field LayoutSources.
LayoutStore | Represents field LayoutStore.
ListData | Represents field ListData.
LLastImport | Represents field LLastImport.
LNextRefresh | Represents field LNextRefresh.
LSources | Represents field LSources.
LStore | Represents field LStore.
MemoDataInfo | Represents field MemoDataInfo.
MemoImportLog | Represents field MemoImportLog.
MenuItem1 | Represents field MenuItem1.
MenuItem2 | Represents field MenuItem2.
MenuItem3 | Represents field MenuItem3.
MenuItem4 | Represents field MenuItem4.
NumberBox1 | Represents field NumberBox1.
Period | Represents field Period.
PopupKinds | Represents field PopupKinds.
RefreshUnit | Represents field RefreshUnit.
Splitter1 | Represents field Splitter1.
TabControl1 | Represents field TabControl1.
TabData | Represents field TabData.
TabSchedule | Represents field TabSchedule.
TabSettings | Represents field TabSettings.
Top
See Also

Reference

  • FMXBI.DataManager


TDataManager Properties

Properties
Name | Description
OnSelect | Represents property OnSelect.
Top


TDataManager.OnSelect Property

Summary

Represents property OnSelect.

Namespace: FMXBI.DataManager
Syntax
Delphi
public
 property OnSelect:TNotifyEvent read FOnSelect write FOnSelect;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager Methods

Methods
Name | Description
BAddClick(TObject) | Represents method BAddClick(TObject).
BCancelClick(TObject) | Represents method BCancelClick(TObject).
BChangeClick(TObject) | Represents method BChangeClick(TObject).
BDeleteClick(TObject) | Represents method BDeleteClick(TObject).
BImportNowClick(TObject) | Represents method BImportNowClick(TObject).
BRenameClick(TObject) | Represents method BRenameClick(TObject).
BSelectClick(TObject) | Represents method BSelectClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
BViewDataClick(TObject) | Represents method BViewDataClick(TObject).
CBParallelChange(TObject) | Represents method CBParallelChange(TObject).
CBRefreshChange(TObject) | Represents method CBRefreshChange(TObject).
CBStoresChange(TObject) | Represents method CBStoresChange(TObject).
ChooseData(TComponent,String,TDataItem) | Represents method ChooseData(TComponent,String,TDataItem).
ChooseName(TComponent,String) | Represents method ChooseName(TComponent,String).
Edit(TComponent,String) | Represents method Edit(TComponent,String).
Embed(TComponent,TControl,TDataManagerEmbedMode,String) | Represents method Embed(TComponent,TControl,TDataManagerEmbedMode,String).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
ListDataChange(TObject) | Represents method ListDataChange(TObject).
LSourcesChange(TObject) | Represents method LSourcesChange(TObject).
MenuItem1Click(TObject) | Represents method MenuItem1Click(TObject).
MenuItem2Click(TObject) | Represents method MenuItem2Click(TObject).
MenuItem3Click(TObject) | Represents method MenuItem3Click(TObject).
MenuItem4Click(TObject) | Represents method MenuItem4Click(TObject).
PeriodChange(TObject) | Represents method PeriodChange(TObject).
RefreshUnitChange(TObject) | Represents method RefreshUnitChange(TObject).
Selected | Represents method Selected.
TabControl1Change(TObject) | Represents method TabControl1Change(TObject).
TabControl1Resize(TObject) | Represents method TabControl1Resize(TObject).
Top


TDataManager.BAddClick(TObject) Method

Summary

Represents method BAddClick(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure BAddClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.BCancelClick(TObject) Method

Summary

Represents method BCancelClick(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure BCancelClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.BChangeClick(TObject) Method

Summary

Represents method BChangeClick(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure BChangeClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.BDeleteClick(TObject) Method

Summary

Represents method BDeleteClick(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure BDeleteClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.BImportNowClick(TObject) Method

Summary

Represents method BImportNowClick(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure BImportNowClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.BRenameClick(TObject) Method

Summary

Represents method BRenameClick(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure BRenameClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.BSelectClick(TObject) Method

Summary

Represents method BSelectClick(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure BSelectClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.BViewDataClick(TObject) Method

Summary

Represents method BViewDataClick(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure BViewDataClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.CBParallelChange(TObject) Method

Summary

Represents method CBParallelChange(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure CBParallelChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.CBRefreshChange(TObject) Method

Summary

Represents method CBRefreshChange(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure CBRefreshChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.CBStoresChange(TObject) Method

Summary

Represents method CBStoresChange(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure CBStoresChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.ChooseData(TComponent,String,TDataItem) Method

Summary

Represents method ChooseData(TComponent,String,TDataItem).

Namespace: FMXBI.DataManager
Syntax
Delphi
public
 class function ChooseData(const AOwner:TComponent; const AStore:String='';
 const ACurrent:TDataItem=nil):TDataItem; static;

Parameters

AOwner
Type: TComponent

AStore
Type: String

ACurrent
Type: TDataItem

Return Value

Type: TDataItem

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.ChooseName(TComponent,String) Method

Summary

Represents method ChooseName(TComponent,String).

Namespace: FMXBI.DataManager
Syntax
Delphi
public
 class function ChooseName(const AOwner:TComponent; const AStore:String=''):String; static;

Parameters

AOwner
Type: TComponent

AStore
Type: String

Return Value

Type: String

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.Edit(TComponent,String) Method

Summary

Represents method Edit(TComponent,String).

Namespace: FMXBI.DataManager
Syntax
Delphi
public
 class procedure Edit(const AOwner:TComponent; const AStore:String=''); static;

Parameters

AOwner
Type: TComponent

AStore
Type: String

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.Embed(TComponent,TControl,TDataManagerEmbedMode,String) Method

Summary

Represents method Embed(TComponent,TControl,TDataManagerEmbedMode,String).

Namespace: FMXBI.DataManager
Syntax
Delphi
public
 class function Embed(const AOwner:TComponent;
 const AParent:TControl;
 const AMode:TDataManagerEmbedMode=TDataManagerEmbedMode.Choose;
 const AStore:String=''):TDataManager; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TControl

AMode
Type: TDataManagerEmbedMode

AStore
Type: String

Return Value

Type: TDataManager

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.FormClose(TObject,TCloseAction) Method

Summary

Represents method FormClose(TObject,TCloseAction).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure FormClose(Sender: TObject; var Action: TCloseAction);

Parameters

Sender
Type: TObject

Action
Type: TCloseAction

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.FormDestroy(TObject) Method

Summary

Represents method FormDestroy(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure FormDestroy(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.ListDataChange(TObject) Method

Summary

Represents method ListDataChange(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure ListDataChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.LSourcesChange(TObject) Method

Summary

Represents method LSourcesChange(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure LSourcesChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.MenuItem1Click(TObject) Method

Summary

Represents method MenuItem1Click(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure MenuItem1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.MenuItem2Click(TObject) Method

Summary

Represents method MenuItem2Click(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure MenuItem2Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.MenuItem3Click(TObject) Method

Summary

Represents method MenuItem3Click(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure MenuItem3Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.MenuItem4Click(TObject) Method

Summary

Represents method MenuItem4Click(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure MenuItem4Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.PeriodChange(TObject) Method

Summary

Represents method PeriodChange(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure PeriodChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.RefreshUnitChange(TObject) Method

Summary

Represents method RefreshUnitChange(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure RefreshUnitChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.Selected Method

Summary

Represents method Selected.

Namespace: FMXBI.DataManager
Syntax
Delphi
public
 function Selected:TDataItem;

Return Value

Type: TDataItem

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.TabControl1Change(TObject) Method

Summary

Represents method TabControl1Change(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure TabControl1Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.TabControl1Resize(TObject) Method

Summary

Represents method TabControl1Resize(TObject).

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 procedure TabControl1Resize(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager Fields

Fields
Name | Description
BAdd | Represents field BAdd.
BCancel | Represents field BCancel.
BChange | Represents field BChange.
BDelete | Represents field BDelete.
BImportNow | Represents field BImportNow.
BRename | Represents field BRename.
BSelect | Represents field BSelect.
Button1 | Represents field Button1.
BViewData | Represents field BViewData.
CBKeep | Represents field CBKeep.
CBParallel | Represents field CBParallel.
CBRefresh | Represents field CBRefresh.
CBStopOnErrors | Represents field CBStopOnErrors.
CBStores | Represents field CBStores.
ImportProgress | Represents field ImportProgress.
Label1 | Represents field Label1.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
Layout1 | Represents field Layout1.
Layout3 | Represents field Layout3.
LayoutAddDelete | Represents field LayoutAddDelete.
LayoutButtons | Represents field LayoutButtons.
LayoutOkCancel | Represents field LayoutOkCancel.
LayoutSources | Represents field LayoutSources.
LayoutStore | Represents field LayoutStore.
ListData | Represents field ListData.
LLastImport | Represents field LLastImport.
LNextRefresh | Represents field LNextRefresh.
LSources | Represents field LSources.
LStore | Represents field LStore.
MemoDataInfo | Represents field MemoDataInfo.
MemoImportLog | Represents field MemoImportLog.
MenuItem1 | Represents field MenuItem1.
MenuItem2 | Represents field MenuItem2.
MenuItem3 | Represents field MenuItem3.
MenuItem4 | Represents field MenuItem4.
NumberBox1 | Represents field NumberBox1.
Period | Represents field Period.
PopupKinds | Represents field PopupKinds.
RefreshUnit | Represents field RefreshUnit.
Splitter1 | Represents field Splitter1.
TabControl1 | Represents field TabControl1.
TabData | Represents field TabData.
TabSchedule | Represents field TabSchedule.
TabSettings | Represents field TabSettings.
Top


TDataManager.BAdd Field

Summary

Represents field BAdd.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 BAdd: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.BCancel Field

Summary

Represents field BCancel.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 BCancel: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.BChange Field

Summary

Represents field BChange.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 BChange: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.BDelete Field

Summary

Represents field BDelete.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 BDelete: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.BImportNow Field

Summary

Represents field BImportNow.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 BImportNow: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.BRename Field

Summary

Represents field BRename.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 BRename: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.BSelect Field

Summary

Represents field BSelect.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 BSelect: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.Button1 Field

Summary

Represents field Button1.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.BViewData Field

Summary

Represents field BViewData.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 BViewData: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.CBKeep Field

Summary

Represents field CBKeep.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 CBKeep: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.CBParallel Field

Summary

Represents field CBParallel.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 CBParallel: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.CBRefresh Field

Summary

Represents field CBRefresh.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 CBRefresh: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.CBStopOnErrors Field

Summary

Represents field CBStopOnErrors.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 CBStopOnErrors: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.CBStores Field

Summary

Represents field CBStores.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 CBStores: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.ImportProgress Field

Summary

Represents field ImportProgress.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 ImportProgress: TProgressBar;

Field Value

Type: TProgressBar

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.Label1 Field

Summary

Represents field Label1.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.Label3 Field

Summary

Represents field Label3.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.Label4 Field

Summary

Represents field Label4.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 Label4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.Label5 Field

Summary

Represents field Label5.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 Label5: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.Label6 Field

Summary

Represents field Label6.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 Label6: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.Label7 Field

Summary

Represents field Label7.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 Label7: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.Layout1 Field

Summary

Represents field Layout1.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 Layout1: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.Layout3 Field

Summary

Represents field Layout3.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 Layout3: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.LayoutAddDelete Field

Summary

Represents field LayoutAddDelete.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 LayoutAddDelete: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.LayoutButtons Field

Summary

Represents field LayoutButtons.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 LayoutButtons: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.LayoutOkCancel Field

Summary

Represents field LayoutOkCancel.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 LayoutOkCancel: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.LayoutSources Field

Summary

Represents field LayoutSources.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 LayoutSources: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.LayoutStore Field

Summary

Represents field LayoutStore.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 LayoutStore: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.ListData Field

Summary

Represents field ListData.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 ListData: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.LLastImport Field

Summary

Represents field LLastImport.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 LLastImport: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.LNextRefresh Field

Summary

Represents field LNextRefresh.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 LNextRefresh: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.LSources Field

Summary

Represents field LSources.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 LSources: TListView;

Field Value

Type: TListView

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.LStore Field

Summary

Represents field LStore.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 LStore: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.MemoDataInfo Field

Summary

Represents field MemoDataInfo.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 MemoDataInfo: TMemo;

Field Value

Type: TMemo

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.MemoImportLog Field

Summary

Represents field MemoImportLog.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 MemoImportLog: TMemo;

Field Value

Type: TMemo

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.MenuItem1 Field

Summary

Represents field MenuItem1.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 MenuItem1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.MenuItem2 Field

Summary

Represents field MenuItem2.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 MenuItem2: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.MenuItem3 Field

Summary

Represents field MenuItem3.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 MenuItem3: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.MenuItem4 Field

Summary

Represents field MenuItem4.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 MenuItem4: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.NumberBox1 Field

Summary

Represents field NumberBox1.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 NumberBox1: TNumberBox;

Field Value

Type: TNumberBox

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.Period Field

Summary

Represents field Period.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 Period: TNumberBox;

Field Value

Type: TNumberBox

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.PopupKinds Field

Summary

Represents field PopupKinds.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 PopupKinds: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.RefreshUnit Field

Summary

Represents field RefreshUnit.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 RefreshUnit: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.Splitter1 Field

Summary

Represents field Splitter1.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 Splitter1: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.TabControl1 Field

Summary

Represents field TabControl1.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 TabControl1: TTabControl;

Field Value

Type: TTabControl

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.TabData Field

Summary

Represents field TabData.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 TabData: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.TabSchedule Field

Summary

Represents field TabSchedule.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 TabSchedule: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


TDataManager.TabSettings Field

Summary

Represents field TabSettings.

Namespace: FMXBI.DataManager
Syntax
Delphi
published
 TabSettings: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TDataManager
  • FMXBI.DataManager


FMXBI.DataManager Enumerations

Enumerations
Name | Description
TDataManagerEmbedMode | Represents type TDataManagerEmbedMode.
Top


TDataManagerEmbedMode Enumeration

Summary

Represents type TDataManagerEmbedMode.

Namespace: FMXBI.DataManager
Syntax
Delphi
type
 TDataManagerEmbedMode=(Choose,Edit);

The TDataManagerEmbedMode type exposes the following members.

Members
Show:
Name | Description
Choose | Represents constant Choose.
Edit | Represents constant Edit.
Top
See Also

Reference

  • FMXBI.DataManager


FMXBI.DataViewer Namespace

Summary

Represents namespace FMXBI.DataViewer.

Classes
Name | Description
TDataTree | Represents type TDataTree.
TDataViewer | Represents type TDataViewer.
Top


FMXBI.DataViewer Classes

Classes
Name | Description
TDataTree | Represents type TDataTree.
TDataViewer | Represents type TDataViewer.
Top


TDataTree Class

Summary

Represents type TDataTree.

Namespace: FMXBI.DataViewer
Inheritance Hierarchy
TObject
FMXBI.DataViewer.TDataTree
Syntax
Delphi
type
 TDataTree=class
 end;

The TDataTree type exposes the following members.

Methods
Show:
Name | Description
Fill(TDataItem,TTreeView,Boolean) | Represents method Fill(TDataItem,TTreeView,Boolean).
Top
See Also

Reference

  • FMXBI.DataViewer


TDataTree Methods

Methods
Name | Description
Fill(TDataItem,TTreeView,Boolean) | Represents method Fill(TDataItem,TTreeView,Boolean).
Top


TDataTree.Fill(TDataItem,TTreeView,Boolean) Method

Summary

Represents method Fill(TDataItem,TTreeView,Boolean).

Namespace: FMXBI.DataViewer
Syntax
Delphi
public
 class procedure Fill(const AData:TDataItem; const ATree:TTreeView; const AddLeaves:Boolean=True); static;

Parameters

AData
Type: TDataItem

ATree
Type: TTreeView

AddLeaves
Type: Boolean

See Also

Reference

  • TDataTree
  • FMXBI.DataViewer


TDataViewer Class

Summary

Represents type TDataViewer.

Namespace: FMXBI.DataViewer
Inheritance Hierarchy
TForm
FMXBI.DataViewer.TDataViewer
Syntax
Delphi
type
 TDataViewer = class(TForm)
 end;

The TDataViewer type exposes the following members.

Methods
Show:
Name | Description
CBViewChange(TObject) | Represents method CBViewChange(TObject).
CBViewDataChange(TObject) | Represents method CBViewDataChange(TObject).
Embedd(TComponent,TControl,TDataItem) | Represents method Embedd(TComponent,TControl,TDataItem).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
MenuItem1Click(TObject) | Represents method MenuItem1Click(TObject).
MenuItem2Click(TObject) | Represents method MenuItem2Click(TObject).
Select(TDataItem) | Represents method Select(TDataItem).
TreeChange(TObject) | Represents method TreeChange(TObject).
View(TComponent,TDataItem) | Represents method View(TComponent,TDataItem).
Top
Fields
Show:
Name | Description
CBView | Represents field CBView.
CBViewData | Represents field CBViewData.
DataGrid | Represents field DataGrid.
ItemsGrid | Represents field ItemsGrid.
Layout2 | Represents field Layout2.
Layout3 | Represents field Layout3.
LayoutTree | Represents field LayoutTree.
LName | Represents field LName.
MenuItem1 | Represents field MenuItem1.
MenuItem2 | Represents field MenuItem2.
PopupMenu1 | Represents field PopupMenu1.
PopupMenu2 | Represents field PopupMenu2.
SplitData | Represents field SplitData.
Splitter1 | Represents field Splitter1.
Tree | Represents field Tree.
Top
See Also

Reference

  • FMXBI.DataViewer


TDataViewer Methods

Methods
Name | Description
CBViewChange(TObject) | Represents method CBViewChange(TObject).
CBViewDataChange(TObject) | Represents method CBViewDataChange(TObject).
Embedd(TComponent,TControl,TDataItem) | Represents method Embedd(TComponent,TControl,TDataItem).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
MenuItem1Click(TObject) | Represents method MenuItem1Click(TObject).
MenuItem2Click(TObject) | Represents method MenuItem2Click(TObject).
Select(TDataItem) | Represents method Select(TDataItem).
TreeChange(TObject) | Represents method TreeChange(TObject).
View(TComponent,TDataItem) | Represents method View(TComponent,TDataItem).
Top


TDataViewer.CBViewChange(TObject) Method

Summary

Represents method CBViewChange(TObject).

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 procedure CBViewChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.CBViewDataChange(TObject) Method

Summary

Represents method CBViewDataChange(TObject).

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 procedure CBViewDataChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.Embedd(TComponent,TControl,TDataItem) Method

Summary

Represents method Embedd(TComponent,TControl,TDataItem).

Namespace: FMXBI.DataViewer
Syntax
Delphi
public
 class function Embedd(const AOwner: TComponent; const AParent: TControl; const AData: TDataItem): TDataViewer; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TControl

AData
Type: TDataItem

Return Value

Type: TDataViewer

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.FormClose(TObject,TCloseAction) Method

Summary

Represents method FormClose(TObject,TCloseAction).

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 procedure FormClose(Sender: TObject; var Action: TCloseAction);

Parameters

Sender
Type: TObject

Action
Type: TCloseAction

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.FormDestroy(TObject) Method

Summary

Represents method FormDestroy(TObject).

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 procedure FormDestroy(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.MenuItem1Click(TObject) Method

Summary

Represents method MenuItem1Click(TObject).

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 procedure MenuItem1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.MenuItem2Click(TObject) Method

Summary

Represents method MenuItem2Click(TObject).

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 procedure MenuItem2Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.Select(TDataItem) Method

Summary

Represents method Select(TDataItem).

Namespace: FMXBI.DataViewer
Syntax
Delphi
public
 procedure Select(const AData:TDataItem);

Parameters

AData
Type: TDataItem

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.TreeChange(TObject) Method

Summary

Represents method TreeChange(TObject).

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 procedure TreeChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.View(TComponent,TDataItem) Method

Summary

Represents method View(TComponent,TDataItem).

Namespace: FMXBI.DataViewer
Syntax
Delphi
public
 class function View(const AOwner:TComponent; const AData:TDataItem):TModalResult; static;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

Return Value

Type: TModalResult

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer Fields

Fields
Name | Description
CBView | Represents field CBView.
CBViewData | Represents field CBViewData.
DataGrid | Represents field DataGrid.
ItemsGrid | Represents field ItemsGrid.
Layout2 | Represents field Layout2.
Layout3 | Represents field Layout3.
LayoutTree | Represents field LayoutTree.
LName | Represents field LName.
MenuItem1 | Represents field MenuItem1.
MenuItem2 | Represents field MenuItem2.
PopupMenu1 | Represents field PopupMenu1.
PopupMenu2 | Represents field PopupMenu2.
SplitData | Represents field SplitData.
Splitter1 | Represents field Splitter1.
Tree | Represents field Tree.
Top


TDataViewer.CBView Field

Summary

Represents field CBView.

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 CBView: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.CBViewData Field

Summary

Represents field CBViewData.

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 CBViewData: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.DataGrid Field

Summary

Represents field DataGrid.

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 DataGrid: TBIGrid;

Field Value

Type: TBIGrid

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.ItemsGrid Field

Summary

Represents field ItemsGrid.

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 ItemsGrid: TBIGrid;

Field Value

Type: TBIGrid

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.Layout2 Field

Summary

Represents field Layout2.

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 Layout2: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.Layout3 Field

Summary

Represents field Layout3.

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 Layout3: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.LayoutTree Field

Summary

Represents field LayoutTree.

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 LayoutTree: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.LName Field

Summary

Represents field LName.

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 LName: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.MenuItem1 Field

Summary

Represents field MenuItem1.

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 MenuItem1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.MenuItem2 Field

Summary

Represents field MenuItem2.

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 MenuItem2: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.PopupMenu1 Field

Summary

Represents field PopupMenu1.

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 PopupMenu1: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.PopupMenu2 Field

Summary

Represents field PopupMenu2.

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 PopupMenu2: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.SplitData Field

Summary

Represents field SplitData.

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 SplitData: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.Splitter1 Field

Summary

Represents field Splitter1.

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 Splitter1: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


TDataViewer.Tree Field

Summary

Represents field Tree.

Namespace: FMXBI.DataViewer
Syntax
Delphi
published
 Tree: TTreeView;

Field Value

Type: TTreeView

See Also

Reference

  • TDataViewer
  • FMXBI.DataViewer


FMXBI.Editor.Chart.Source Namespace

Summary

Represents namespace FMXBI.Editor.Chart.Source.

Classes
Name | Description
TBISourceEditor | Represents type TBISourceEditor.
Top
Records
Name | Description
TValueControl | Represents type TValueControl.
Top


FMXBI.Editor.Chart.Source Classes

Classes
Name | Description
TBISourceEditor | Represents type TBISourceEditor.
Top


TBISourceEditor Class

Summary

Represents type TBISourceEditor.

Namespace: FMXBI.Editor.Chart.Source
Inheritance Hierarchy
TBaseSourceEditor
FMXBI.Editor.Chart.Source.TBISourceEditor
Syntax
Delphi
type
 TBISourceEditor = class(TBaseSourceEditor)
 end;

The TBISourceEditor type exposes the following members.

Methods
Show:
Name | Description
BApplyClick(TObject) | Represents method BApplyClick(TObject).
BSelectDataClick(TObject) | Represents method BSelectDataClick(TObject).
CBLabelsFieldChange(TObject) | Represents method CBLabelsFieldChange(TObject).
Edit(TComponent,TTeeBISource) | Represents method Edit(TComponent,TTeeBISource).
FormActivate(TObject) | Represents method FormActivate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
Top
Fields
Show:
Name | Description
BSelectData | Represents field BSelectData.
CBLabelsField | Represents field CBLabelsField.
GroupFields | Represents field GroupFields.
LayoutData | Represents field LayoutData.
LData | Represents field LData.
LLabels | Represents field LLabels.
Top
See Also

Reference

  • FMXBI.Editor.Chart.Source


TBISourceEditor Methods

Methods
Name | Description
BApplyClick(TObject) | Represents method BApplyClick(TObject).
BSelectDataClick(TObject) | Represents method BSelectDataClick(TObject).
CBLabelsFieldChange(TObject) | Represents method CBLabelsFieldChange(TObject).
Edit(TComponent,TTeeBISource) | Represents method Edit(TComponent,TTeeBISource).
FormActivate(TObject) | Represents method FormActivate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
Top


TBISourceEditor.BApplyClick(TObject) Method

Summary

Represents method BApplyClick(TObject).

Namespace: FMXBI.Editor.Chart.Source
Syntax
Delphi
published
 procedure BApplyClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBISourceEditor
  • FMXBI.Editor.Chart.Source


TBISourceEditor.BSelectDataClick(TObject) Method

Summary

Represents method BSelectDataClick(TObject).

Namespace: FMXBI.Editor.Chart.Source
Syntax
Delphi
published
 procedure BSelectDataClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBISourceEditor
  • FMXBI.Editor.Chart.Source


TBISourceEditor.CBLabelsFieldChange(TObject) Method

Summary

Represents method CBLabelsFieldChange(TObject).

Namespace: FMXBI.Editor.Chart.Source
Syntax
Delphi
published
 procedure CBLabelsFieldChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBISourceEditor
  • FMXBI.Editor.Chart.Source


TBISourceEditor.Edit(TComponent,TTeeBISource) Method

Summary

Represents method Edit(TComponent,TTeeBISource).

Namespace: FMXBI.Editor.Chart.Source
Syntax
Delphi
public
 class procedure Edit(const AOwner:TComponent; const ASource:TTeeBISource); static;

Parameters

AOwner
Type: TComponent

ASource
Type: TTeeBISource

See Also

Reference

  • TBISourceEditor
  • FMXBI.Editor.Chart.Source


TBISourceEditor.FormActivate(TObject) Method

Summary

Represents method FormActivate(TObject).

Namespace: FMXBI.Editor.Chart.Source
Syntax
Delphi
published
 procedure FormActivate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBISourceEditor
  • FMXBI.Editor.Chart.Source


TBISourceEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: FMXBI.Editor.Chart.Source
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBISourceEditor
  • FMXBI.Editor.Chart.Source


TBISourceEditor Fields

Fields
Name | Description
BSelectData | Represents field BSelectData.
CBLabelsField | Represents field CBLabelsField.
GroupFields | Represents field GroupFields.
LayoutData | Represents field LayoutData.
LData | Represents field LData.
LLabels | Represents field LLabels.
Top


TBISourceEditor.BSelectData Field

Summary

Represents field BSelectData.

Namespace: FMXBI.Editor.Chart.Source
Syntax
Delphi
published
 BSelectData: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBISourceEditor
  • FMXBI.Editor.Chart.Source


TBISourceEditor.CBLabelsField Field

Summary

Represents field CBLabelsField.

Namespace: FMXBI.Editor.Chart.Source
Syntax
Delphi
published
 CBLabelsField: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TBISourceEditor
  • FMXBI.Editor.Chart.Source


TBISourceEditor.GroupFields Field

Summary

Represents field GroupFields.

Namespace: FMXBI.Editor.Chart.Source
Syntax
Delphi
published
 GroupFields: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TBISourceEditor
  • FMXBI.Editor.Chart.Source


TBISourceEditor.LayoutData Field

Summary

Represents field LayoutData.

Namespace: FMXBI.Editor.Chart.Source
Syntax
Delphi
published
 LayoutData: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TBISourceEditor
  • FMXBI.Editor.Chart.Source


TBISourceEditor.LData Field

Summary

Represents field LData.

Namespace: FMXBI.Editor.Chart.Source
Syntax
Delphi
published
 LData: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBISourceEditor
  • FMXBI.Editor.Chart.Source


TBISourceEditor.LLabels Field

Summary

Represents field LLabels.

Namespace: FMXBI.Editor.Chart.Source
Syntax
Delphi
published
 LLabels: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBISourceEditor
  • FMXBI.Editor.Chart.Source


FMXBI.Editor.Chart.Source Records

Records
Name | Description
TValueControl | Represents type TValueControl.
Top


TValueControl Record

Summary

Represents type TValueControl.

Namespace: FMXBI.Editor.Chart.Source
Syntax
Delphi
type
 TValueControl=record
 end;

The TValueControl type exposes the following members.

Fields
Show:
Name | Description
Combo | Represents field Combo.
Text | Represents field Text.
Top
See Also

Reference

  • FMXBI.Editor.Chart.Source


TValueControl Fields

Fields
Name | Description
Combo | Represents field Combo.
Text | Represents field Text.
Top


TValueControl.Combo Field

Summary

Represents field Combo.

Namespace: FMXBI.Editor.Chart.Source
Syntax
Delphi
public
 Combo : TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TValueControl
  • FMXBI.Editor.Chart.Source


TValueControl.Text Field

Summary

Represents field Text.

Namespace: FMXBI.Editor.Chart.Source
Syntax
Delphi
public
 Text : TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TValueControl
  • FMXBI.Editor.Chart.Source


FMXBI.Editor.Column Namespace

Summary

Represents namespace FMXBI.Editor.Column.

Classes
Name | Description
TColumnEditor | Represents type TColumnEditor.
TDataItemAccess | Represents type TDataItemAccess.
Top


FMXBI.Editor.Column Classes

Classes
Name | Description
TColumnEditor | Represents type TColumnEditor.
TDataItemAccess | Represents type TDataItemAccess.
Top


TColumnEditor Class

Summary

Represents type TColumnEditor.

Namespace: FMXBI.Editor.Column
Inheritance Hierarchy
TForm
FMXBI.Editor.Column.TColumnEditor
Syntax
Delphi
type
 TColumnEditor = class(TForm)
 end;

The TColumnEditor type exposes the following members.

Methods
Show:
Name | Description
Button1Click(TObject) | Represents method Button1Click(TObject).
CBKindChange(TObject) | Represents method CBKindChange(TObject).
CBMasterChange(TObject) | Represents method CBMasterChange(TObject).
Edit(TComponent,TDataItem) | Represents method Edit(TComponent,TDataItem).
FormShow(TObject) | Represents method FormShow(TObject).
Top
Fields
Show:
Name | Description
Button1 | Represents field Button1.
CBKind | Represents field CBKind.
CBMaster | Represents field CBMaster.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Top
See Also

Reference

  • FMXBI.Editor.Column


TColumnEditor Methods

Methods
Name | Description
Button1Click(TObject) | Represents method Button1Click(TObject).
CBKindChange(TObject) | Represents method CBKindChange(TObject).
CBMasterChange(TObject) | Represents method CBMasterChange(TObject).
Edit(TComponent,TDataItem) | Represents method Edit(TComponent,TDataItem).
FormShow(TObject) | Represents method FormShow(TObject).
Top


TColumnEditor.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: FMXBI.Editor.Column
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnEditor
  • FMXBI.Editor.Column


TColumnEditor.CBKindChange(TObject) Method

Summary

Represents method CBKindChange(TObject).

Namespace: FMXBI.Editor.Column
Syntax
Delphi
published
 procedure CBKindChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnEditor
  • FMXBI.Editor.Column


TColumnEditor.CBMasterChange(TObject) Method

Summary

Represents method CBMasterChange(TObject).

Namespace: FMXBI.Editor.Column
Syntax
Delphi
published
 procedure CBMasterChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnEditor
  • FMXBI.Editor.Column


TColumnEditor.Edit(TComponent,TDataItem) Method

Summary

Represents method Edit(TComponent,TDataItem).

Namespace: FMXBI.Editor.Column
Syntax
Delphi
public
 class procedure Edit(const AOwner:TComponent; const AData:TDataItem); static;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

See Also

Reference

  • TColumnEditor
  • FMXBI.Editor.Column


TColumnEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: FMXBI.Editor.Column
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TColumnEditor
  • FMXBI.Editor.Column


TColumnEditor Fields

Fields
Name | Description
Button1 | Represents field Button1.
CBKind | Represents field CBKind.
CBMaster | Represents field CBMaster.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Top


TColumnEditor.Button1 Field

Summary

Represents field Button1.

Namespace: FMXBI.Editor.Column
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TColumnEditor
  • FMXBI.Editor.Column


TColumnEditor.CBKind Field

Summary

Represents field CBKind.

Namespace: FMXBI.Editor.Column
Syntax
Delphi
published
 CBKind: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TColumnEditor
  • FMXBI.Editor.Column


TColumnEditor.CBMaster Field

Summary

Represents field CBMaster.

Namespace: FMXBI.Editor.Column
Syntax
Delphi
published
 CBMaster: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TColumnEditor
  • FMXBI.Editor.Column


TColumnEditor.Label1 Field

Summary

Represents field Label1.

Namespace: FMXBI.Editor.Column
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TColumnEditor
  • FMXBI.Editor.Column


TColumnEditor.Label2 Field

Summary

Represents field Label2.

Namespace: FMXBI.Editor.Column
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TColumnEditor
  • FMXBI.Editor.Column


TColumnEditor.Label3 Field

Summary

Represents field Label3.

Namespace: FMXBI.Editor.Column
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TColumnEditor
  • FMXBI.Editor.Column


TColumnEditor.Label4 Field

Summary

Represents field Label4.

Namespace: FMXBI.Editor.Column
Syntax
Delphi
published
 Label4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TColumnEditor
  • FMXBI.Editor.Column


TDataItemAccess Class

Summary

Represents type TDataItemAccess.

Namespace: FMXBI.Editor.Column
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
FMXBI.Editor.Column.TDataItemAccess
Syntax
Delphi
type
 TDataItemAccess=class(TDataItem);
See Also

Reference

  • FMXBI.Editor.Column


FMXBI.Editor.ControlTree Namespace

Summary

Represents namespace FMXBI.Editor.ControlTree.

Classes
Name | Description
TBIControlTree | Represents type TBIControlTree.
Top
Variables
Name | Description
BIControlTree | Represents variable BIControlTree.
Top


FMXBI.Editor.ControlTree Classes

Classes
Name | Description
TBIControlTree | Represents type TBIControlTree.
Top


TBIControlTree Class

Summary

Represents type TBIControlTree.

Namespace: FMXBI.Editor.ControlTree
Inheritance Hierarchy
TForm
FMXBI.Editor.ControlTree.TBIControlTree
Syntax
Delphi
type
 TBIControlTree = class(TForm)
 end;

The TBIControlTree type exposes the following members.

Methods
Show:
Name | Description
BEditChartClick(TObject) | Represents method BEditChartClick(TObject).
CBOpacityChangeTracking(TObject) | Represents method CBOpacityChangeTracking(TObject).
CBVisibleChange(TObject) | Represents method CBVisibleChange(TObject).
ColorPanel1Change(TObject) | Represents method ColorPanel1Change(TObject).
Edit(TComponent,TControl) | Represents method Edit(TComponent,TControl).
FormCreate(TObject) | Represents method FormCreate(TObject).
Refresh(TControl) | Represents method Refresh(TControl).
RGAlignChange(TObject) | Represents method RGAlignChange(TObject).
TreeView1Change(TObject) | Represents method TreeView1Change(TObject).
Top
Fields
Show:
Name | Description
BEditChart | Represents field BEditChart.
CBOpacity | Represents field CBOpacity.
CBVisible | Represents field CBVisible.
ColorPanel1 | Represents field ColorPanel1.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Label6 | Represents field Label6.
Panel1 | Represents field Panel1.
RGAlign | Represents field RGAlign.
SBHeight | Represents field SBHeight.
SBLeft | Represents field SBLeft.
SBTop | Represents field SBTop.
SBWidth | Represents field SBWidth.
TreeView1 | Represents field TreeView1.
Top
See Also

Reference

  • FMXBI.Editor.ControlTree


TBIControlTree Methods

Methods
Name | Description
BEditChartClick(TObject) | Represents method BEditChartClick(TObject).
CBOpacityChangeTracking(TObject) | Represents method CBOpacityChangeTracking(TObject).
CBVisibleChange(TObject) | Represents method CBVisibleChange(TObject).
ColorPanel1Change(TObject) | Represents method ColorPanel1Change(TObject).
Edit(TComponent,TControl) | Represents method Edit(TComponent,TControl).
FormCreate(TObject) | Represents method FormCreate(TObject).
Refresh(TControl) | Represents method Refresh(TControl).
RGAlignChange(TObject) | Represents method RGAlignChange(TObject).
TreeView1Change(TObject) | Represents method TreeView1Change(TObject).
Top


TBIControlTree.BEditChartClick(TObject) Method

Summary

Represents method BEditChartClick(TObject).

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 procedure BEditChartClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.CBOpacityChangeTracking(TObject) Method

Summary

Represents method CBOpacityChangeTracking(TObject).

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 procedure CBOpacityChangeTracking(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.CBVisibleChange(TObject) Method

Summary

Represents method CBVisibleChange(TObject).

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 procedure CBVisibleChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.ColorPanel1Change(TObject) Method

Summary

Represents method ColorPanel1Change(TObject).

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 procedure ColorPanel1Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.Edit(TComponent,TControl) Method

Summary

Represents method Edit(TComponent,TControl).

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
public
 class procedure Edit(const AOwner:TComponent; const AControl:TControl); static;

Parameters

AOwner
Type: TComponent

AControl
Type: TControl

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.Refresh(TControl) Method

Summary

Represents method Refresh(TControl).

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
public
 procedure Refresh(const AControl:TControl);

Parameters

AControl
Type: TControl

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.RGAlignChange(TObject) Method

Summary

Represents method RGAlignChange(TObject).

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 procedure RGAlignChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.TreeView1Change(TObject) Method

Summary

Represents method TreeView1Change(TObject).

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 procedure TreeView1Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree Fields

Fields
Name | Description
BEditChart | Represents field BEditChart.
CBOpacity | Represents field CBOpacity.
CBVisible | Represents field CBVisible.
ColorPanel1 | Represents field ColorPanel1.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Label6 | Represents field Label6.
Panel1 | Represents field Panel1.
RGAlign | Represents field RGAlign.
SBHeight | Represents field SBHeight.
SBLeft | Represents field SBLeft.
SBTop | Represents field SBTop.
SBWidth | Represents field SBWidth.
TreeView1 | Represents field TreeView1.
Top


TBIControlTree.BEditChart Field

Summary

Represents field BEditChart.

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 BEditChart: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.CBOpacity Field

Summary

Represents field CBOpacity.

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 CBOpacity: TComboTrackBar;

Field Value

Type: TComboTrackBar

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.CBVisible Field

Summary

Represents field CBVisible.

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 CBVisible: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.ColorPanel1 Field

Summary

Represents field ColorPanel1.

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 ColorPanel1: TColorPanel;

Field Value

Type: TColorPanel

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.Label1 Field

Summary

Represents field Label1.

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.Label2 Field

Summary

Represents field Label2.

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.Label3 Field

Summary

Represents field Label3.

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.Label4 Field

Summary

Represents field Label4.

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 Label4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.Label5 Field

Summary

Represents field Label5.

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 Label5: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.Label6 Field

Summary

Represents field Label6.

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 Label6: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.Panel1 Field

Summary

Represents field Panel1.

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 Panel1: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.RGAlign Field

Summary

Represents field RGAlign.

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 RGAlign: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.SBHeight Field

Summary

Represents field SBHeight.

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 SBHeight: TSpinBox;

Field Value

Type: TSpinBox

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.SBLeft Field

Summary

Represents field SBLeft.

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 SBLeft: TSpinBox;

Field Value

Type: TSpinBox

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.SBTop Field

Summary

Represents field SBTop.

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 SBTop: TSpinBox;

Field Value

Type: TSpinBox

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.SBWidth Field

Summary

Represents field SBWidth.

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 SBWidth: TSpinBox;

Field Value

Type: TSpinBox

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


TBIControlTree.TreeView1 Field

Summary

Represents field TreeView1.

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
published
 TreeView1: TTreeView;

Field Value

Type: TTreeView

See Also

Reference

  • TBIControlTree
  • FMXBI.Editor.ControlTree


FMXBI.Editor.ControlTree Variables

Variables
Name | Description
BIControlTree | Represents variable BIControlTree.
Top


BIControlTree Variable

Summary

Represents variable BIControlTree.

Namespace: FMXBI.Editor.ControlTree
Syntax
Delphi
BIControlTree: TBIControlTree;

Value

Type: TBIControlTree

See Also

Reference

  • FMXBI.Editor.ControlTree


FMXBI.Editor.Data Namespace

Summary

Represents namespace FMXBI.Editor.Data.

Classes
Name | Description
TDataEditor | Represents type TDataEditor.
Top


FMXBI.Editor.Data Classes

Classes
Name | Description
TDataEditor | Represents type TDataEditor.
Top


TDataEditor Class

Summary

Represents type TDataEditor.

Namespace: FMXBI.Editor.Data
Inheritance Hierarchy
TForm
FMXBI.Editor.Data.TDataEditor
FMXBI.Editor.Stores.TDataEditorAccess
Syntax
Delphi
type
 TDataEditor = class(TForm)
 end;

The TDataEditor type exposes the following members.

Properties
Show:
Name | Description
OnChangeWeb | Represents property OnChangeWeb.
Top
Methods
Show:
Name | Description
BDBTestClick(TObject) | Represents method BDBTestClick(TObject).
BSelectFileClick(TObject) | Represents method BSelectFileClick(TObject).
BSelectFolderClick(TObject) | Represents method BSelectFolderClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
Button2Click(TObject) | Represents method Button2Click(TObject).
BWebTestClick(TObject) | Represents method BWebTestClick(TObject).
CBAllFolderChange(TObject) | Represents method CBAllFolderChange(TObject).
CBAllItemsChange(TObject) | Represents method CBAllItemsChange(TObject).
CBDBDriverChange(TObject) | Represents method CBDBDriverChange(TObject).
CBDBSystemChange(TObject) | Represents method CBDBSystemChange(TObject).
CBFileTypeChange(TObject) | Represents method CBFileTypeChange(TObject).
CBLoginChange(TObject) | Represents method CBLoginChange(TObject).
CBRecursiveChange(TObject) | Represents method CBRecursiveChange(TObject).
CBWebDataChangeTracking(TObject) | Represents method CBWebDataChangeTracking(TObject).
CBWebDataClick(TObject) | Represents method CBWebDataClick(TObject).
CBZipChange(TObject) | Represents method CBZipChange(TObject).
ClearWeb | Represents method ClearWeb.
EDBDatabaseChange(TObject) | Represents method EDBDatabaseChange(TObject).
EDBIncludeChange(TObject) | Represents method EDBIncludeChange(TObject).
EDBPasswordChange(TObject) | Represents method EDBPasswordChange(TObject).
EDBPortChange(TObject) | Represents method EDBPortChange(TObject).
EDBServerChange(TObject) | Represents method EDBServerChange(TObject).
EDBUserChange(TObject) | Represents method EDBUserChange(TObject).
Edit(TComponent,TDataDefinition) | Represents method Edit(TComponent,TDataDefinition).
EExcludedChange(TObject) | Represents method EExcludedChange(TObject).
EFileChange(TObject) | Represents method EFileChange(TObject).
EFileMaskChange(TObject) | Represents method EFileMaskChange(TObject).
EFolderChange(TObject) | Represents method EFolderChange(TObject).
EProxyHostChange(TObject) | Represents method EProxyHostChange(TObject).
EProxyPasswordChange(TObject) | Represents method EProxyPasswordChange(TObject).
EProxyUserChange(TObject) | Represents method EProxyUserChange(TObject).
EWebServerChangeTracking(TObject) | Represents method EWebServerChangeTracking(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
FormResize(TObject) | Represents method FormResize(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
MemoSQLChange(TObject) | Represents method MemoSQLChange(TObject).
NewWeb(TComponent,String) | Represents method NewWeb(TComponent,String).
NPortChangeTracking(TObject) | Represents method NPortChangeTracking(TObject).
ProxyPortChange(TObject) | Represents method ProxyPortChange(TObject).
Select(String,String) | Overloaded. Represents method Select(String,String).
Select(TDataDefinition) | Overloaded. Represents method Select(TDataDefinition).
SetWebPath(String) | Represents method SetWebPath(String).
TabSourcesChange(TObject) | Represents method TabSourcesChange(TObject).
WebPath | Represents method WebPath.
Top
Fields
Show:
Name | Description
BCancel | Represents field BCancel.
BDBTest | Represents field BDBTest.
BOK | Represents field BOK.
BSelectFile | Represents field BSelectFile.
BSelectFolder | Represents field BSelectFolder.
Button1 | Represents field Button1.
Button2 | Represents field Button2.
BWebTest | Represents field BWebTest.
CBAllFolder | Represents field CBAllFolder.
CBAllItems | Represents field CBAllItems.
CBDBDriver | Represents field CBDBDriver.
CBDBSystem | Represents field CBDBSystem.
CBFileType | Represents field CBFileType.
CBLogin | Represents field CBLogin.
CBRecursive | Represents field CBRecursive.
CBWebData | Represents field CBWebData.
CBZip | Represents field CBZip.
Connection | Represents field Connection.
Data | Represents field Data.
EDBDatabase | Represents field EDBDatabase.
EDBExclude | Represents field EDBExclude.
EDBInclude | Represents field EDBInclude.
EDBPassword | Represents field EDBPassword.
EDBPort | Represents field EDBPort.
EDBServer | Represents field EDBServer.
EDBUser | Represents field EDBUser.
EExcluded | Represents field EExcluded.
EFile | Represents field EFile.
EFileMask | Represents field EFileMask.
EFolder | Represents field EFolder.
EProxyHost | Represents field EProxyHost.
EProxyPassword | Represents field EProxyPassword.
EProxyUser | Represents field EProxyUser.
EWebServer | Represents field EWebServer.
Label1 | Represents field Label1.
Label10 | Represents field Label10.
Label11 | Represents field Label11.
Label12 | Represents field Label12.
Label13 | Represents field Label13.
Label14 | Represents field Label14.
Label15 | Represents field Label15.
Label16 | Represents field Label16.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
Label8 | Represents field Label8.
Label9 | Represents field Label9.
Layout1 | Represents field Layout1.
LayoutOkCancel | Represents field LayoutOkCancel.
LayoutWebData | Represents field LayoutWebData.
LDBExclude | Represents field LDBExclude.
LDBInclude | Represents field LDBInclude.
LFileMissing | Represents field LFileMissing.
LFolderMissing | Represents field LFolderMissing.
LWebData | Represents field LWebData.
LWebTest | Represents field LWebTest.
MemoDBTest | Represents field MemoDBTest.
MemoSQL | Represents field MemoSQL.
NPort | Represents field NPort.
OpenFile | Represents field OpenFile.
PasswordEditButton1 | Represents field PasswordEditButton1.
ProxyPort | Represents field ProxyPort.
SQL | Represents field SQL.
TabControlDB | Represents field TabControlDB.
TabControlDBItems | Represents field TabControlDBItems.
TabControlFile | Represents field TabControlFile.
TabDatabase | Represents field TabDatabase.
TabFile | Represents field TabFile.
TabFiles | Represents field TabFiles.
TabFolder | Represents field TabFolder.
TabHttpProxy | Represents field TabHttpProxy.
TabHttpServer | Represents field TabHttpServer.
TabItemAllDB | Represents field TabItemAllDB.
TabManual | Represents field TabManual.
TabSources | Represents field TabSources.
TabSQL | Represents field TabSQL.
TabUnknown | Represents field TabUnknown.
TabWeb | Represents field TabWeb.
TabWebHost | Represents field TabWebHost.
Top
See Also

Reference

  • FMXBI.Editor.Data


TDataEditor Properties

Properties
Name | Description
OnChangeWeb | Represents property OnChangeWeb.
Top


TDataEditor.OnChangeWeb Property

Summary

Represents property OnChangeWeb.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
public
 property OnChangeWeb:TNotifyEvent read FOnChangeWeb write FOnChangeWeb;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor Methods

Methods
Name | Description
BDBTestClick(TObject) | Represents method BDBTestClick(TObject).
BSelectFileClick(TObject) | Represents method BSelectFileClick(TObject).
BSelectFolderClick(TObject) | Represents method BSelectFolderClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
Button2Click(TObject) | Represents method Button2Click(TObject).
BWebTestClick(TObject) | Represents method BWebTestClick(TObject).
CBAllFolderChange(TObject) | Represents method CBAllFolderChange(TObject).
CBAllItemsChange(TObject) | Represents method CBAllItemsChange(TObject).
CBDBDriverChange(TObject) | Represents method CBDBDriverChange(TObject).
CBDBSystemChange(TObject) | Represents method CBDBSystemChange(TObject).
CBFileTypeChange(TObject) | Represents method CBFileTypeChange(TObject).
CBLoginChange(TObject) | Represents method CBLoginChange(TObject).
CBRecursiveChange(TObject) | Represents method CBRecursiveChange(TObject).
CBWebDataChangeTracking(TObject) | Represents method CBWebDataChangeTracking(TObject).
CBWebDataClick(TObject) | Represents method CBWebDataClick(TObject).
CBZipChange(TObject) | Represents method CBZipChange(TObject).
ClearWeb | Represents method ClearWeb.
EDBDatabaseChange(TObject) | Represents method EDBDatabaseChange(TObject).
EDBIncludeChange(TObject) | Represents method EDBIncludeChange(TObject).
EDBPasswordChange(TObject) | Represents method EDBPasswordChange(TObject).
EDBPortChange(TObject) | Represents method EDBPortChange(TObject).
EDBServerChange(TObject) | Represents method EDBServerChange(TObject).
EDBUserChange(TObject) | Represents method EDBUserChange(TObject).
Edit(TComponent,TDataDefinition) | Represents method Edit(TComponent,TDataDefinition).
EExcludedChange(TObject) | Represents method EExcludedChange(TObject).
EFileChange(TObject) | Represents method EFileChange(TObject).
EFileMaskChange(TObject) | Represents method EFileMaskChange(TObject).
EFolderChange(TObject) | Represents method EFolderChange(TObject).
EProxyHostChange(TObject) | Represents method EProxyHostChange(TObject).
EProxyPasswordChange(TObject) | Represents method EProxyPasswordChange(TObject).
EProxyUserChange(TObject) | Represents method EProxyUserChange(TObject).
EWebServerChangeTracking(TObject) | Represents method EWebServerChangeTracking(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
FormResize(TObject) | Represents method FormResize(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
MemoSQLChange(TObject) | Represents method MemoSQLChange(TObject).
NewWeb(TComponent,String) | Represents method NewWeb(TComponent,String).
NPortChangeTracking(TObject) | Represents method NPortChangeTracking(TObject).
ProxyPortChange(TObject) | Represents method ProxyPortChange(TObject).
Select(String,String) | Overloaded. Represents method Select(String,String).
Select(TDataDefinition) | Overloaded. Represents method Select(TDataDefinition).
SetWebPath(String) | Represents method SetWebPath(String).
TabSourcesChange(TObject) | Represents method TabSourcesChange(TObject).
WebPath | Represents method WebPath.
Top


TDataEditor.BDBTestClick(TObject) Method

Summary

Represents method BDBTestClick(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure BDBTestClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.BSelectFileClick(TObject) Method

Summary

Represents method BSelectFileClick(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure BSelectFileClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.BSelectFolderClick(TObject) Method

Summary

Represents method BSelectFolderClick(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure BSelectFolderClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Button2Click(TObject) Method

Summary

Represents method Button2Click(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure Button2Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.BWebTestClick(TObject) Method

Summary

Represents method BWebTestClick(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure BWebTestClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.CBAllFolderChange(TObject) Method

Summary

Represents method CBAllFolderChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure CBAllFolderChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.CBAllItemsChange(TObject) Method

Summary

Represents method CBAllItemsChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure CBAllItemsChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.CBDBDriverChange(TObject) Method

Summary

Represents method CBDBDriverChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure CBDBDriverChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.CBDBSystemChange(TObject) Method

Summary

Represents method CBDBSystemChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure CBDBSystemChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.CBFileTypeChange(TObject) Method

Summary

Represents method CBFileTypeChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure CBFileTypeChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.CBLoginChange(TObject) Method

Summary

Represents method CBLoginChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure CBLoginChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.CBRecursiveChange(TObject) Method

Summary

Represents method CBRecursiveChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure CBRecursiveChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.CBWebDataChangeTracking(TObject) Method

Summary

Represents method CBWebDataChangeTracking(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure CBWebDataChangeTracking(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.CBWebDataClick(TObject) Method

Summary

Represents method CBWebDataClick(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure CBWebDataClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.CBZipChange(TObject) Method

Summary

Represents method CBZipChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure CBZipChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.ClearWeb Method

Summary

Represents method ClearWeb.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
protected
 procedure ClearWeb;
See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EDBDatabaseChange(TObject) Method

Summary

Represents method EDBDatabaseChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure EDBDatabaseChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EDBIncludeChange(TObject) Method

Summary

Represents method EDBIncludeChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure EDBIncludeChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EDBPasswordChange(TObject) Method

Summary

Represents method EDBPasswordChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure EDBPasswordChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EDBPortChange(TObject) Method

Summary

Represents method EDBPortChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure EDBPortChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EDBServerChange(TObject) Method

Summary

Represents method EDBServerChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure EDBServerChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EDBUserChange(TObject) Method

Summary

Represents method EDBUserChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure EDBUserChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Edit(TComponent,TDataDefinition) Method

Summary

Represents method Edit(TComponent,TDataDefinition).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const AData:TDataDefinition):Boolean; static;

Parameters

AOwner
Type: TComponent

AData
Type: TDataDefinition

Return Value

Type: Boolean

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EExcludedChange(TObject) Method

Summary

Represents method EExcludedChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure EExcludedChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EFileChange(TObject) Method

Summary

Represents method EFileChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure EFileChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EFileMaskChange(TObject) Method

Summary

Represents method EFileMaskChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure EFileMaskChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EFolderChange(TObject) Method

Summary

Represents method EFolderChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure EFolderChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EProxyHostChange(TObject) Method

Summary

Represents method EProxyHostChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure EProxyHostChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EProxyPasswordChange(TObject) Method

Summary

Represents method EProxyPasswordChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure EProxyPasswordChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EProxyUserChange(TObject) Method

Summary

Represents method EProxyUserChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure EProxyUserChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EWebServerChangeTracking(TObject) Method

Summary

Represents method EWebServerChangeTracking(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure EWebServerChangeTracking(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.FormDestroy(TObject) Method

Summary

Represents method FormDestroy(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure FormDestroy(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.FormResize(TObject) Method

Summary

Represents method FormResize(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure FormResize(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.MemoSQLChange(TObject) Method

Summary

Represents method MemoSQLChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure MemoSQLChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.NewWeb(TComponent,String) Method

Summary

Represents method NewWeb(TComponent,String).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
public
 class function NewWeb(const AOwner:TComponent; out AWeb:String):Boolean; static;

Parameters

AOwner
Type: TComponent

AWeb
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.NPortChangeTracking(TObject) Method

Summary

Represents method NPortChangeTracking(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure NPortChangeTracking(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.ProxyPortChange(TObject) Method

Summary

Represents method ProxyPortChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure ProxyPortChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Select(String,String) Method

Summary

Represents method Select(String,String).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
public
 procedure Select(const AStore,AName:String); overload;

Parameters

AStore
Type: String

AName
Type: String

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Select(TDataDefinition) Method

Summary

Represents method Select(TDataDefinition).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
public
 procedure Select(const AData:TDataDefinition); overload;

Parameters

AData
Type: TDataDefinition

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.SetWebPath(String) Method

Summary

Represents method SetWebPath(String).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
protected
 procedure SetWebPath(const APath:String);

Parameters

APath
Type: String

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.TabSourcesChange(TObject) Method

Summary

Represents method TabSourcesChange(TObject).

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 procedure TabSourcesChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.WebPath Method

Summary

Represents method WebPath.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
protected
 function WebPath:String;

Return Value

Type: String

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor Fields

Fields
Name | Description
BCancel | Represents field BCancel.
BDBTest | Represents field BDBTest.
BOK | Represents field BOK.
BSelectFile | Represents field BSelectFile.
BSelectFolder | Represents field BSelectFolder.
Button1 | Represents field Button1.
Button2 | Represents field Button2.
BWebTest | Represents field BWebTest.
CBAllFolder | Represents field CBAllFolder.
CBAllItems | Represents field CBAllItems.
CBDBDriver | Represents field CBDBDriver.
CBDBSystem | Represents field CBDBSystem.
CBFileType | Represents field CBFileType.
CBLogin | Represents field CBLogin.
CBRecursive | Represents field CBRecursive.
CBWebData | Represents field CBWebData.
CBZip | Represents field CBZip.
Connection | Represents field Connection.
Data | Represents field Data.
EDBDatabase | Represents field EDBDatabase.
EDBExclude | Represents field EDBExclude.
EDBInclude | Represents field EDBInclude.
EDBPassword | Represents field EDBPassword.
EDBPort | Represents field EDBPort.
EDBServer | Represents field EDBServer.
EDBUser | Represents field EDBUser.
EExcluded | Represents field EExcluded.
EFile | Represents field EFile.
EFileMask | Represents field EFileMask.
EFolder | Represents field EFolder.
EProxyHost | Represents field EProxyHost.
EProxyPassword | Represents field EProxyPassword.
EProxyUser | Represents field EProxyUser.
EWebServer | Represents field EWebServer.
Label1 | Represents field Label1.
Label10 | Represents field Label10.
Label11 | Represents field Label11.
Label12 | Represents field Label12.
Label13 | Represents field Label13.
Label14 | Represents field Label14.
Label15 | Represents field Label15.
Label16 | Represents field Label16.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
Label8 | Represents field Label8.
Label9 | Represents field Label9.
Layout1 | Represents field Layout1.
LayoutOkCancel | Represents field LayoutOkCancel.
LayoutWebData | Represents field LayoutWebData.
LDBExclude | Represents field LDBExclude.
LDBInclude | Represents field LDBInclude.
LFileMissing | Represents field LFileMissing.
LFolderMissing | Represents field LFolderMissing.
LWebData | Represents field LWebData.
LWebTest | Represents field LWebTest.
MemoDBTest | Represents field MemoDBTest.
MemoSQL | Represents field MemoSQL.
NPort | Represents field NPort.
OpenFile | Represents field OpenFile.
PasswordEditButton1 | Represents field PasswordEditButton1.
ProxyPort | Represents field ProxyPort.
SQL | Represents field SQL.
TabControlDB | Represents field TabControlDB.
TabControlDBItems | Represents field TabControlDBItems.
TabControlFile | Represents field TabControlFile.
TabDatabase | Represents field TabDatabase.
TabFile | Represents field TabFile.
TabFiles | Represents field TabFiles.
TabFolder | Represents field TabFolder.
TabHttpProxy | Represents field TabHttpProxy.
TabHttpServer | Represents field TabHttpServer.
TabItemAllDB | Represents field TabItemAllDB.
TabManual | Represents field TabManual.
TabSources | Represents field TabSources.
TabSQL | Represents field TabSQL.
TabUnknown | Represents field TabUnknown.
TabWeb | Represents field TabWeb.
TabWebHost | Represents field TabWebHost.
Top


TDataEditor.BCancel Field

Summary

Represents field BCancel.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 BCancel: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.BDBTest Field

Summary

Represents field BDBTest.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 BDBTest: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.BOK Field

Summary

Represents field BOK.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 BOK: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.BSelectFile Field

Summary

Represents field BSelectFile.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 BSelectFile: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.BSelectFolder Field

Summary

Represents field BSelectFolder.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 BSelectFolder: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Button1 Field

Summary

Represents field Button1.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Button2 Field

Summary

Represents field Button2.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 Button2: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.BWebTest Field

Summary

Represents field BWebTest.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 BWebTest: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.CBAllFolder Field

Summary

Represents field CBAllFolder.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 CBAllFolder: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.CBAllItems Field

Summary

Represents field CBAllItems.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 CBAllItems: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.CBDBDriver Field

Summary

Represents field CBDBDriver.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 CBDBDriver: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.CBDBSystem Field

Summary

Represents field CBDBSystem.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 CBDBSystem: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.CBFileType Field

Summary

Represents field CBFileType.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 CBFileType: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.CBLogin Field

Summary

Represents field CBLogin.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 CBLogin: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.CBRecursive Field

Summary

Represents field CBRecursive.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 CBRecursive: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.CBWebData Field

Summary

Represents field CBWebData.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 CBWebData: TComboEdit;

Field Value

Type: TComboEdit

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.CBZip Field

Summary

Represents field CBZip.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 CBZip: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Connection Field

Summary

Represents field Connection.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 Connection: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Data Field

Summary

Represents field Data.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
public
 Data : TDataDefinition;

Field Value

Type: TDataDefinition

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EDBDatabase Field

Summary

Represents field EDBDatabase.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 EDBDatabase: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EDBExclude Field

Summary

Represents field EDBExclude.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 EDBExclude: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EDBInclude Field

Summary

Represents field EDBInclude.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 EDBInclude: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EDBPassword Field

Summary

Represents field EDBPassword.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 EDBPassword: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EDBPort Field

Summary

Represents field EDBPort.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 EDBPort: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EDBServer Field

Summary

Represents field EDBServer.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 EDBServer: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EDBUser Field

Summary

Represents field EDBUser.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 EDBUser: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EExcluded Field

Summary

Represents field EExcluded.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 EExcluded: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EFile Field

Summary

Represents field EFile.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 EFile: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EFileMask Field

Summary

Represents field EFileMask.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 EFileMask: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EFolder Field

Summary

Represents field EFolder.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 EFolder: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EProxyHost Field

Summary

Represents field EProxyHost.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 EProxyHost: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EProxyPassword Field

Summary

Represents field EProxyPassword.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 EProxyPassword: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EProxyUser Field

Summary

Represents field EProxyUser.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 EProxyUser: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.EWebServer Field

Summary

Represents field EWebServer.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 EWebServer: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Label1 Field

Summary

Represents field Label1.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Label10 Field

Summary

Represents field Label10.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 Label10: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Label11 Field

Summary

Represents field Label11.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 Label11: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Label12 Field

Summary

Represents field Label12.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 Label12: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Label13 Field

Summary

Represents field Label13.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 Label13: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Label14 Field

Summary

Represents field Label14.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 Label14: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Label15 Field

Summary

Represents field Label15.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 Label15: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Label16 Field

Summary

Represents field Label16.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 Label16: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Label2 Field

Summary

Represents field Label2.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Label3 Field

Summary

Represents field Label3.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Label4 Field

Summary

Represents field Label4.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 Label4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Label5 Field

Summary

Represents field Label5.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 Label5: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Label6 Field

Summary

Represents field Label6.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 Label6: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Label7 Field

Summary

Represents field Label7.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 Label7: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Label8 Field

Summary

Represents field Label8.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 Label8: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Label9 Field

Summary

Represents field Label9.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 Label9: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.Layout1 Field

Summary

Represents field Layout1.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 Layout1: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.LayoutOkCancel Field

Summary

Represents field LayoutOkCancel.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 LayoutOkCancel: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.LayoutWebData Field

Summary

Represents field LayoutWebData.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 LayoutWebData: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.LDBExclude Field

Summary

Represents field LDBExclude.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 LDBExclude: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.LDBInclude Field

Summary

Represents field LDBInclude.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 LDBInclude: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.LFileMissing Field

Summary

Represents field LFileMissing.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 LFileMissing: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.LFolderMissing Field

Summary

Represents field LFolderMissing.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 LFolderMissing: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.LWebData Field

Summary

Represents field LWebData.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 LWebData: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.LWebTest Field

Summary

Represents field LWebTest.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 LWebTest: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.MemoDBTest Field

Summary

Represents field MemoDBTest.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 MemoDBTest: TMemo;

Field Value

Type: TMemo

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.MemoSQL Field

Summary

Represents field MemoSQL.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 MemoSQL: TMemo;

Field Value

Type: TMemo

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.NPort Field

Summary

Represents field NPort.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 NPort: TNumberBox;

Field Value

Type: TNumberBox

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.OpenFile Field

Summary

Represents field OpenFile.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 OpenFile: TOpenDialog;

Field Value

Type: TOpenDialog

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.PasswordEditButton1 Field

Summary

Represents field PasswordEditButton1.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 PasswordEditButton1: TPasswordEditButton;

Field Value

Type: TPasswordEditButton

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.ProxyPort Field

Summary

Represents field ProxyPort.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 ProxyPort: TNumberBox;

Field Value

Type: TNumberBox

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.SQL Field

Summary

Represents field SQL.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 SQL: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.TabControlDB Field

Summary

Represents field TabControlDB.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 TabControlDB: TTabControl;

Field Value

Type: TTabControl

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.TabControlDBItems Field

Summary

Represents field TabControlDBItems.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 TabControlDBItems: TTabControl;

Field Value

Type: TTabControl

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.TabControlFile Field

Summary

Represents field TabControlFile.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 TabControlFile: TTabControl;

Field Value

Type: TTabControl

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.TabDatabase Field

Summary

Represents field TabDatabase.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 TabDatabase: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.TabFile Field

Summary

Represents field TabFile.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 TabFile: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.TabFiles Field

Summary

Represents field TabFiles.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 TabFiles: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.TabFolder Field

Summary

Represents field TabFolder.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 TabFolder: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.TabHttpProxy Field

Summary

Represents field TabHttpProxy.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 TabHttpProxy: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.TabHttpServer Field

Summary

Represents field TabHttpServer.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 TabHttpServer: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.TabItemAllDB Field

Summary

Represents field TabItemAllDB.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 TabItemAllDB: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.TabManual Field

Summary

Represents field TabManual.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 TabManual: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.TabSources Field

Summary

Represents field TabSources.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 TabSources: TTabControl;

Field Value

Type: TTabControl

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.TabSQL Field

Summary

Represents field TabSQL.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 TabSQL: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.TabUnknown Field

Summary

Represents field TabUnknown.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 TabUnknown: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.TabWeb Field

Summary

Represents field TabWeb.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 TabWeb: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


TDataEditor.TabWebHost Field

Summary

Represents field TabWebHost.

Namespace: FMXBI.Editor.Data
Syntax
Delphi
published
 TabWebHost: TTabControl;

Field Value

Type: TTabControl

See Also

Reference

  • TDataEditor
  • FMXBI.Editor.Data


FMXBI.Editor.Grid Namespace

Summary

Represents namespace FMXBI.Editor.Grid.

Classes
Name | Description
TBIGridEditor | Represents type TBIGridEditor.
Top


FMXBI.Editor.Grid Classes

Classes
Name | Description
TBIGridEditor | Represents type TBIGridEditor.
Top


TBIGridEditor Class

Summary

Represents type TBIGridEditor.

Namespace: FMXBI.Editor.Grid
Inheritance Hierarchy
TForm
FMXBI.Editor.Grid.TBIGridEditor
Syntax
Delphi
type
 TBIGridEditor = class(TForm)
 end;

The TBIGridEditor type exposes the following members.

Methods
Show:
Name | Description
CBAlternateChange(TObject) | Represents method CBAlternateChange(TObject).
CBColorizeChange(TObject) | Represents method CBColorizeChange(TObject).
CBSortChange(TObject) | Represents method CBSortChange(TObject).
Edit(TComponent,TBIGrid) | Represents method Edit(TComponent,TBIGrid).
Embedd(TComponent,TControl,TBIGrid) | Represents method Embedd(TComponent,TControl,TBIGrid).
Refresh(TBIGrid) | Represents method Refresh(TBIGrid).
Top
Fields
Show:
Name | Description
CBAlternate | Represents field CBAlternate.
CBColorize | Represents field CBColorize.
CBSort | Represents field CBSort.
GroupBox1 | Represents field GroupBox1.
TabControl1 | Represents field TabControl1.
TabOptions | Represents field TabOptions.
TabPlugin | Represents field TabPlugin.
Top
See Also

Reference

  • FMXBI.Editor.Grid


TBIGridEditor Methods

Methods
Name | Description
CBAlternateChange(TObject) | Represents method CBAlternateChange(TObject).
CBColorizeChange(TObject) | Represents method CBColorizeChange(TObject).
CBSortChange(TObject) | Represents method CBSortChange(TObject).
Edit(TComponent,TBIGrid) | Represents method Edit(TComponent,TBIGrid).
Embedd(TComponent,TControl,TBIGrid) | Represents method Embedd(TComponent,TControl,TBIGrid).
Refresh(TBIGrid) | Represents method Refresh(TBIGrid).
Top


TBIGridEditor.CBAlternateChange(TObject) Method

Summary

Represents method CBAlternateChange(TObject).

Namespace: FMXBI.Editor.Grid
Syntax
Delphi
published
 procedure CBAlternateChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIGridEditor
  • FMXBI.Editor.Grid


TBIGridEditor.CBColorizeChange(TObject) Method

Summary

Represents method CBColorizeChange(TObject).

Namespace: FMXBI.Editor.Grid
Syntax
Delphi
published
 procedure CBColorizeChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIGridEditor
  • FMXBI.Editor.Grid


TBIGridEditor.CBSortChange(TObject) Method

Summary

Represents method CBSortChange(TObject).

Namespace: FMXBI.Editor.Grid
Syntax
Delphi
published
 procedure CBSortChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIGridEditor
  • FMXBI.Editor.Grid


TBIGridEditor.Edit(TComponent,TBIGrid) Method

Summary

Represents method Edit(TComponent,TBIGrid).

Namespace: FMXBI.Editor.Grid
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const AGrid:TBIGrid):Boolean; static;

Parameters

AOwner
Type: TComponent

AGrid
Type: TBIGrid

Return Value

Type: Boolean

See Also

Reference

  • TBIGridEditor
  • FMXBI.Editor.Grid


TBIGridEditor.Embedd(TComponent,TControl,TBIGrid) Method

Summary

Represents method Embedd(TComponent,TControl,TBIGrid).

Namespace: FMXBI.Editor.Grid
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TControl;
 const AGrid:TBIGrid):TBIGridEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TControl

AGrid
Type: TBIGrid

Return Value

Type: TBIGridEditor

See Also

Reference

  • TBIGridEditor
  • FMXBI.Editor.Grid


TBIGridEditor.Refresh(TBIGrid) Method

Summary

Represents method Refresh(TBIGrid).

Namespace: FMXBI.Editor.Grid
Syntax
Delphi
public
 procedure Refresh(const AGrid:TBIGrid);

Parameters

AGrid
Type: TBIGrid

See Also

Reference

  • TBIGridEditor
  • FMXBI.Editor.Grid


TBIGridEditor Fields

Fields
Name | Description
CBAlternate | Represents field CBAlternate.
CBColorize | Represents field CBColorize.
CBSort | Represents field CBSort.
GroupBox1 | Represents field GroupBox1.
TabControl1 | Represents field TabControl1.
TabOptions | Represents field TabOptions.
TabPlugin | Represents field TabPlugin.
Top


TBIGridEditor.CBAlternate Field

Summary

Represents field CBAlternate.

Namespace: FMXBI.Editor.Grid
Syntax
Delphi
published
 CBAlternate: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIGridEditor
  • FMXBI.Editor.Grid


TBIGridEditor.CBColorize Field

Summary

Represents field CBColorize.

Namespace: FMXBI.Editor.Grid
Syntax
Delphi
published
 CBColorize: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIGridEditor
  • FMXBI.Editor.Grid


TBIGridEditor.CBSort Field

Summary

Represents field CBSort.

Namespace: FMXBI.Editor.Grid
Syntax
Delphi
published
 CBSort: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIGridEditor
  • FMXBI.Editor.Grid


TBIGridEditor.GroupBox1 Field

Summary

Represents field GroupBox1.

Namespace: FMXBI.Editor.Grid
Syntax
Delphi
published
 GroupBox1: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TBIGridEditor
  • FMXBI.Editor.Grid


TBIGridEditor.TabControl1 Field

Summary

Represents field TabControl1.

Namespace: FMXBI.Editor.Grid
Syntax
Delphi
published
 TabControl1: TTabControl;

Field Value

Type: TTabControl

See Also

Reference

  • TBIGridEditor
  • FMXBI.Editor.Grid


TBIGridEditor.TabOptions Field

Summary

Represents field TabOptions.

Namespace: FMXBI.Editor.Grid
Syntax
Delphi
published
 TabOptions: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TBIGridEditor
  • FMXBI.Editor.Grid


TBIGridEditor.TabPlugin Field

Summary

Represents field TabPlugin.

Namespace: FMXBI.Editor.Grid
Syntax
Delphi
published
 TabPlugin: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TBIGridEditor
  • FMXBI.Editor.Grid


FMXBI.Editor.Items Namespace

Summary

Represents namespace FMXBI.Editor.Items.

Classes
Name | Description
TItemsEditor | Represents type TItemsEditor.
Top


FMXBI.Editor.Items Classes

Classes
Name | Description
TItemsEditor | Represents type TItemsEditor.
Top


TItemsEditor Class

Summary

Represents type TItemsEditor.

Namespace: FMXBI.Editor.Items
Inheritance Hierarchy
TForm
FMXBI.Editor.Items.TItemsEditor
Syntax
Delphi
type
 TItemsEditor = class(TForm)
 end;

The TItemsEditor type exposes the following members.

Properties
Show:
Name | Description
OnChanged | Represents property OnChanged.
Top
Methods
Show:
Name | Description
CBKindChange(TObject) | Represents method CBKindChange(TObject).
Edit(TComponent,TDataItems) | Represents method Edit(TComponent,TDataItems).
Embedd(TComponent,TControl,TDataItems) | Represents method Embedd(TComponent,TControl,TDataItems).
ENameChange(TObject) | Represents method ENameChange(TObject).
ENameChangeTracking(TObject) | Represents method ENameChangeTracking(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
LBFieldsChange(TObject) | Represents method LBFieldsChange(TObject).
Refresh(TDataItems) | Represents method Refresh(TDataItems).
SBAddClick(TObject) | Represents method SBAddClick(TObject).
SBDownClick(TObject) | Represents method SBDownClick(TObject).
SBRemoveClick(TObject) | Represents method SBRemoveClick(TObject).
SBUpClick(TObject) | Represents method SBUpClick(TObject).
Top
Fields
Show:
Name | Description
BOK | Represents field BOK.
CBKind | Represents field CBKind.
EName | Represents field EName.
GroupBox1 | Represents field GroupBox1.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Layout1 | Represents field Layout1.
Layout2 | Represents field Layout2.
Layout3 | Represents field Layout3.
Layout4 | Represents field Layout4.
Layout5 | Represents field Layout5.
LayoutButtons | Represents field LayoutButtons.
LayoutGrid | Represents field LayoutGrid.
LBFields | Represents field LBFields.
LDuplicateName | Represents field LDuplicateName.
SBAdd | Represents field SBAdd.
SBDown | Represents field SBDown.
SBRemove | Represents field SBRemove.
SBUp | Represents field SBUp.
Top
See Also

Reference

  • FMXBI.Editor.Items


TItemsEditor Properties

Properties
Name | Description
OnChanged | Represents property OnChanged.
Top


TItemsEditor.OnChanged Property

Summary

Represents property OnChanged.

Namespace: FMXBI.Editor.Items
Syntax
Delphi
public
 property OnChanged:TNotifyEvent read FOnChanged write FOnChanged;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor Methods

Methods
Name | Description
CBKindChange(TObject) | Represents method CBKindChange(TObject).
Edit(TComponent,TDataItems) | Represents method Edit(TComponent,TDataItems).
Embedd(TComponent,TControl,TDataItems) | Represents method Embedd(TComponent,TControl,TDataItems).
ENameChange(TObject) | Represents method ENameChange(TObject).
ENameChangeTracking(TObject) | Represents method ENameChangeTracking(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
LBFieldsChange(TObject) | Represents method LBFieldsChange(TObject).
Refresh(TDataItems) | Represents method Refresh(TDataItems).
SBAddClick(TObject) | Represents method SBAddClick(TObject).
SBDownClick(TObject) | Represents method SBDownClick(TObject).
SBRemoveClick(TObject) | Represents method SBRemoveClick(TObject).
SBUpClick(TObject) | Represents method SBUpClick(TObject).
Top


TItemsEditor.CBKindChange(TObject) Method

Summary

Represents method CBKindChange(TObject).

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 procedure CBKindChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.Edit(TComponent,TDataItems) Method

Summary

Represents method Edit(TComponent,TDataItems).

Namespace: FMXBI.Editor.Items
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent;
 const AItems:TDataItems):TModalResult; static;

Parameters

AOwner
Type: TComponent

AItems
Type: TDataItems

Return Value

Type: TModalResult

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.Embedd(TComponent,TControl,TDataItems) Method

Summary

Represents method Embedd(TComponent,TControl,TDataItems).

Namespace: FMXBI.Editor.Items
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TControl;
 const AItems:TDataItems):TItemsEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TControl

AItems
Type: TDataItems

Return Value

Type: TItemsEditor

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.ENameChange(TObject) Method

Summary

Represents method ENameChange(TObject).

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 procedure ENameChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.ENameChangeTracking(TObject) Method

Summary

Represents method ENameChangeTracking(TObject).

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 procedure ENameChangeTracking(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.LBFieldsChange(TObject) Method

Summary

Represents method LBFieldsChange(TObject).

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 procedure LBFieldsChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.Refresh(TDataItems) Method

Summary

Represents method Refresh(TDataItems).

Namespace: FMXBI.Editor.Items
Syntax
Delphi
public
 procedure Refresh(const AItems:TDataItems);

Parameters

AItems
Type: TDataItems

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.SBAddClick(TObject) Method

Summary

Represents method SBAddClick(TObject).

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 procedure SBAddClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.SBDownClick(TObject) Method

Summary

Represents method SBDownClick(TObject).

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 procedure SBDownClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.SBRemoveClick(TObject) Method

Summary

Represents method SBRemoveClick(TObject).

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 procedure SBRemoveClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.SBUpClick(TObject) Method

Summary

Represents method SBUpClick(TObject).

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 procedure SBUpClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor Fields

Fields
Name | Description
BOK | Represents field BOK.
CBKind | Represents field CBKind.
EName | Represents field EName.
GroupBox1 | Represents field GroupBox1.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Layout1 | Represents field Layout1.
Layout2 | Represents field Layout2.
Layout3 | Represents field Layout3.
Layout4 | Represents field Layout4.
Layout5 | Represents field Layout5.
LayoutButtons | Represents field LayoutButtons.
LayoutGrid | Represents field LayoutGrid.
LBFields | Represents field LBFields.
LDuplicateName | Represents field LDuplicateName.
SBAdd | Represents field SBAdd.
SBDown | Represents field SBDown.
SBRemove | Represents field SBRemove.
SBUp | Represents field SBUp.
Top


TItemsEditor.BOK Field

Summary

Represents field BOK.

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 BOK: TButton;

Field Value

Type: TButton

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.CBKind Field

Summary

Represents field CBKind.

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 CBKind: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.EName Field

Summary

Represents field EName.

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 EName: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.GroupBox1 Field

Summary

Represents field GroupBox1.

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 GroupBox1: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.Label1 Field

Summary

Represents field Label1.

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.Label2 Field

Summary

Represents field Label2.

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.Layout1 Field

Summary

Represents field Layout1.

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 Layout1: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.Layout2 Field

Summary

Represents field Layout2.

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 Layout2: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.Layout3 Field

Summary

Represents field Layout3.

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 Layout3: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.Layout4 Field

Summary

Represents field Layout4.

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 Layout4: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.Layout5 Field

Summary

Represents field Layout5.

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 Layout5: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.LayoutButtons Field

Summary

Represents field LayoutButtons.

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 LayoutButtons: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.LayoutGrid Field

Summary

Represents field LayoutGrid.

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 LayoutGrid: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.LBFields Field

Summary

Represents field LBFields.

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 LBFields: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.LDuplicateName Field

Summary

Represents field LDuplicateName.

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 LDuplicateName: TText;

Field Value

Type: TText

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.SBAdd Field

Summary

Represents field SBAdd.

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 SBAdd: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.SBDown Field

Summary

Represents field SBDown.

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 SBDown: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.SBRemove Field

Summary

Represents field SBRemove.

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 SBRemove: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


TItemsEditor.SBUp Field

Summary

Represents field SBUp.

Namespace: FMXBI.Editor.Items
Syntax
Delphi
published
 SBUp: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TItemsEditor
  • FMXBI.Editor.Items


FMXBI.Editor.Stores Namespace

Summary

Represents namespace FMXBI.Editor.Stores.

Classes
Name | Description
TDataEditorAccess | Represents type TDataEditorAccess.
TStoreEditor | Represents type TStoreEditor.
Top


FMXBI.Editor.Stores Classes

Classes
Name | Description
TDataEditorAccess | Represents type TDataEditorAccess.
TStoreEditor | Represents type TStoreEditor.
Top


TDataEditorAccess Class

Summary

Represents type TDataEditorAccess.

Namespace: FMXBI.Editor.Stores
Inheritance Hierarchy
TForm
FMXBI.Editor.Data.TDataEditor
FMXBI.Editor.Stores.TDataEditorAccess
Syntax
Delphi
type
 TDataEditorAccess=class(TDataEditor);
See Also

Reference

  • FMXBI.Editor.Stores


TStoreEditor Class

Summary

Represents type TStoreEditor.

Namespace: FMXBI.Editor.Stores
Inheritance Hierarchy
TForm
FMXBI.Editor.Stores.TStoreEditor
Syntax
Delphi
type
 TStoreEditor = class(TForm)
 end;

The TStoreEditor type exposes the following members.

Methods
Show:
Name | Description
BRemoveClick(TObject) | Represents method BRemoveClick(TObject).
BRenameClick(TObject) | Represents method BRenameClick(TObject).
BSelectFolderClick(TObject) | Represents method BSelectFolderClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
CBDefaultChange(TObject) | Represents method CBDefaultChange(TObject).
Edit(TComponent) | Represents method Edit(TComponent).
EFolderChange(TObject) | Represents method EFolderChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
LBStoresChange(TObject) | Represents method LBStoresChange(TObject).
MenuItem1Click(TObject) | Represents method MenuItem1Click(TObject).
MenuItem2Click(TObject) | Represents method MenuItem2Click(TObject).
Top
Fields
Show:
Name | Description
BRemove | Represents field BRemove.
BRename | Represents field BRename.
BSelectFolder | Represents field BSelectFolder.
Button1 | Represents field Button1.
Button2 | Represents field Button2.
CBDefault | Represents field CBDefault.
EFolder | Represents field EFolder.
Label8 | Represents field Label8.
LabelEmpty | Represents field LabelEmpty.
Layout1 | Represents field Layout1.
Layout2 | Represents field Layout2.
LayoutButtons | Represents field LayoutButtons.
LBadFolder | Represents field LBadFolder.
LBStores | Represents field LBStores.
MenuItem1 | Represents field MenuItem1.
MenuItem2 | Represents field MenuItem2.
PopupMenu1 | Represents field PopupMenu1.
TabControl1 | Represents field TabControl1.
TabFolder | Represents field TabFolder.
TabWeb | Represents field TabWeb.
Top
See Also

Reference

  • FMXBI.Editor.Stores


TStoreEditor Methods

Methods
Name | Description
BRemoveClick(TObject) | Represents method BRemoveClick(TObject).
BRenameClick(TObject) | Represents method BRenameClick(TObject).
BSelectFolderClick(TObject) | Represents method BSelectFolderClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
CBDefaultChange(TObject) | Represents method CBDefaultChange(TObject).
Edit(TComponent) | Represents method Edit(TComponent).
EFolderChange(TObject) | Represents method EFolderChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
LBStoresChange(TObject) | Represents method LBStoresChange(TObject).
MenuItem1Click(TObject) | Represents method MenuItem1Click(TObject).
MenuItem2Click(TObject) | Represents method MenuItem2Click(TObject).
Top


TStoreEditor.BRemoveClick(TObject) Method

Summary

Represents method BRemoveClick(TObject).

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 procedure BRemoveClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.BRenameClick(TObject) Method

Summary

Represents method BRenameClick(TObject).

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 procedure BRenameClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.BSelectFolderClick(TObject) Method

Summary

Represents method BSelectFolderClick(TObject).

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 procedure BSelectFolderClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.CBDefaultChange(TObject) Method

Summary

Represents method CBDefaultChange(TObject).

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 procedure CBDefaultChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.Edit(TComponent) Method

Summary

Represents method Edit(TComponent).

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
public
 class procedure Edit(const AOwner:TComponent); static;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.EFolderChange(TObject) Method

Summary

Represents method EFolderChange(TObject).

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 procedure EFolderChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.LBStoresChange(TObject) Method

Summary

Represents method LBStoresChange(TObject).

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 procedure LBStoresChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.MenuItem1Click(TObject) Method

Summary

Represents method MenuItem1Click(TObject).

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 procedure MenuItem1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.MenuItem2Click(TObject) Method

Summary

Represents method MenuItem2Click(TObject).

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 procedure MenuItem2Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor Fields

Fields
Name | Description
BRemove | Represents field BRemove.
BRename | Represents field BRename.
BSelectFolder | Represents field BSelectFolder.
Button1 | Represents field Button1.
Button2 | Represents field Button2.
CBDefault | Represents field CBDefault.
EFolder | Represents field EFolder.
Label8 | Represents field Label8.
LabelEmpty | Represents field LabelEmpty.
Layout1 | Represents field Layout1.
Layout2 | Represents field Layout2.
LayoutButtons | Represents field LayoutButtons.
LBadFolder | Represents field LBadFolder.
LBStores | Represents field LBStores.
MenuItem1 | Represents field MenuItem1.
MenuItem2 | Represents field MenuItem2.
PopupMenu1 | Represents field PopupMenu1.
TabControl1 | Represents field TabControl1.
TabFolder | Represents field TabFolder.
TabWeb | Represents field TabWeb.
Top


TStoreEditor.BRemove Field

Summary

Represents field BRemove.

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 BRemove: TButton;

Field Value

Type: TButton

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.BRename Field

Summary

Represents field BRename.

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 BRename: TButton;

Field Value

Type: TButton

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.BSelectFolder Field

Summary

Represents field BSelectFolder.

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 BSelectFolder: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.Button1 Field

Summary

Represents field Button1.

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.Button2 Field

Summary

Represents field Button2.

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 Button2: TButton;

Field Value

Type: TButton

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.CBDefault Field

Summary

Represents field CBDefault.

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 CBDefault: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.EFolder Field

Summary

Represents field EFolder.

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 EFolder: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.Label8 Field

Summary

Represents field Label8.

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 Label8: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.LabelEmpty Field

Summary

Represents field LabelEmpty.

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 LabelEmpty: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.Layout1 Field

Summary

Represents field Layout1.

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 Layout1: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.Layout2 Field

Summary

Represents field Layout2.

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 Layout2: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.LayoutButtons Field

Summary

Represents field LayoutButtons.

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 LayoutButtons: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.LBadFolder Field

Summary

Represents field LBadFolder.

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 LBadFolder: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.LBStores Field

Summary

Represents field LBStores.

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 LBStores: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.MenuItem1 Field

Summary

Represents field MenuItem1.

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 MenuItem1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.MenuItem2 Field

Summary

Represents field MenuItem2.

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 MenuItem2: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.PopupMenu1 Field

Summary

Represents field PopupMenu1.

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 PopupMenu1: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.TabControl1 Field

Summary

Represents field TabControl1.

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 TabControl1: TTabControl;

Field Value

Type: TTabControl

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.TabFolder Field

Summary

Represents field TabFolder.

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 TabFolder: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


TStoreEditor.TabWeb Field

Summary

Represents field TabWeb.

Namespace: FMXBI.Editor.Stores
Syntax
Delphi
published
 TabWeb: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TStoreEditor
  • FMXBI.Editor.Stores


FMXBI.Editor.Visualizer Namespace

Summary

Represents namespace FMXBI.Editor.Visualizer.

Classes
Name | Description
TVisualizerEditor | Represents type TVisualizerEditor.
Top


FMXBI.Editor.Visualizer Classes

Classes
Name | Description
TVisualizerEditor | Represents type TVisualizerEditor.
Top


TVisualizerEditor Class

Summary

Represents type TVisualizerEditor.

Namespace: FMXBI.Editor.Visualizer
Inheritance Hierarchy
TForm
FMXBI.Editor.Visualizer.TVisualizerEditor
FMXBI.Editor.Visualizer.Chart.TVizAccess
Syntax
Delphi
type
 TVisualizerEditor = class(TForm)
 end;

The TVisualizerEditor type exposes the following members.

Methods
Show:
Name | Description
Button1Click(TObject) | Represents method Button1Click(TObject).
CBClassChange(TObject) | Represents method CBClassChange(TObject).
CBComboAlignChange(TObject) | Represents method CBComboAlignChange(TObject).
CBListAlignChange(TObject) | Represents method CBListAlignChange(TObject).
CBMultiScrollChange(TObject) | Represents method CBMultiScrollChange(TObject).
Embedd(TComponent,TWinControl) | Represents method Embedd(TComponent,TWinControl).
FormCreate(TObject) | Represents method FormCreate(TObject).
LBGroupsChange(TObject) | Represents method LBGroupsChange(TObject).
LBGroupsChangeCheck(TObject) | Represents method LBGroupsChangeCheck(TObject).
LBValuesChange(TObject) | Represents method LBValuesChange(TObject).
LBValuesChangeCheck(TObject) | Represents method LBValuesChangeCheck(TObject).
Refresh(TBIComposer) | Represents method Refresh(TBIComposer).
SBDownGroupClick(TObject) | Represents method SBDownGroupClick(TObject).
SBDownValueClick(TObject) | Represents method SBDownValueClick(TObject).
SBUpGroupClick(TObject) | Represents method SBUpGroupClick(TObject).
SBUpValueClick(TObject) | Represents method SBUpValueClick(TObject).
ShowSettings(TTabItem) | Represents method ShowSettings(TTabItem).
UDColumnsChangeTracking(TObject) | Represents method UDColumnsChangeTracking(TObject).
Top
Fields
Show:
Name | Description
Button1 | Represents field Button1.
CBClass | Represents field CBClass.
CBComboAlign | Represents field CBComboAlign.
CBGroupBy | Represents field CBGroupBy.
CBListAlign | Represents field CBListAlign.
CBMultiScroll | Represents field CBMultiScroll.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Layout1 | Represents field Layout1.
Layout2 | Represents field Layout2.
Layout3 | Represents field Layout3.
Layout4 | Represents field Layout4.
Layout5 | Represents field Layout5.
LBGroups | Represents field LBGroups.
LBValues | Represents field LBValues.
LClass | Represents field LClass.
LCurrent | Represents field LCurrent.
LCurrentHeader | Represents field LCurrentHeader.
PageSettings | Represents field PageSettings.
SBDownGroup | Represents field SBDownGroup.
SBDownValue | Represents field SBDownValue.
SBUpGroup | Represents field SBUpGroup.
SBUpValue | Represents field SBUpValue.
TabCombo | Represents field TabCombo.
TabControl1 | Represents field TabControl1.
TabGroups | Represents field TabGroups.
TabList | Represents field TabList.
TabMulti | Represents field TabMulti.
TabValues | Represents field TabValues.
UDColumns | Represents field UDColumns.
Top
See Also

Reference

  • FMXBI.Editor.Visualizer


TVisualizerEditor Methods

Methods
Name | Description
Button1Click(TObject) | Represents method Button1Click(TObject).
CBClassChange(TObject) | Represents method CBClassChange(TObject).
CBComboAlignChange(TObject) | Represents method CBComboAlignChange(TObject).
CBListAlignChange(TObject) | Represents method CBListAlignChange(TObject).
CBMultiScrollChange(TObject) | Represents method CBMultiScrollChange(TObject).
Embedd(TComponent,TWinControl) | Represents method Embedd(TComponent,TWinControl).
FormCreate(TObject) | Represents method FormCreate(TObject).
LBGroupsChange(TObject) | Represents method LBGroupsChange(TObject).
LBGroupsChangeCheck(TObject) | Represents method LBGroupsChangeCheck(TObject).
LBValuesChange(TObject) | Represents method LBValuesChange(TObject).
LBValuesChangeCheck(TObject) | Represents method LBValuesChangeCheck(TObject).
Refresh(TBIComposer) | Represents method Refresh(TBIComposer).
SBDownGroupClick(TObject) | Represents method SBDownGroupClick(TObject).
SBDownValueClick(TObject) | Represents method SBDownValueClick(TObject).
SBUpGroupClick(TObject) | Represents method SBUpGroupClick(TObject).
SBUpValueClick(TObject) | Represents method SBUpValueClick(TObject).
ShowSettings(TTabItem) | Represents method ShowSettings(TTabItem).
UDColumnsChangeTracking(TObject) | Represents method UDColumnsChangeTracking(TObject).
Top


TVisualizerEditor.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.CBClassChange(TObject) Method

Summary

Represents method CBClassChange(TObject).

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 procedure CBClassChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.CBComboAlignChange(TObject) Method

Summary

Represents method CBComboAlignChange(TObject).

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 procedure CBComboAlignChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.CBListAlignChange(TObject) Method

Summary

Represents method CBListAlignChange(TObject).

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 procedure CBListAlignChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.CBMultiScrollChange(TObject) Method

Summary

Represents method CBMultiScrollChange(TObject).

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 procedure CBMultiScrollChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.Embedd(TComponent,TWinControl) Method

Summary

Represents method Embedd(TComponent,TWinControl).

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl):TVisualizerEditor;

Parameters

AOwner
Type: TComponent

AParent
Type: System.Void

Return Value

Type: TVisualizerEditor

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.LBGroupsChange(TObject) Method

Summary

Represents method LBGroupsChange(TObject).

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 procedure LBGroupsChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.LBGroupsChangeCheck(TObject) Method

Summary

Represents method LBGroupsChangeCheck(TObject).

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 procedure LBGroupsChangeCheck(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.LBValuesChange(TObject) Method

Summary

Represents method LBValuesChange(TObject).

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 procedure LBValuesChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.LBValuesChangeCheck(TObject) Method

Summary

Represents method LBValuesChangeCheck(TObject).

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 procedure LBValuesChangeCheck(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.Refresh(TBIComposer) Method

Summary

Represents method Refresh(TBIComposer).

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
public
 procedure Refresh(const AVisualizer:TBIComposer);

Parameters

AVisualizer
Type: TBIComposer

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.SBDownGroupClick(TObject) Method

Summary

Represents method SBDownGroupClick(TObject).

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 procedure SBDownGroupClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.SBDownValueClick(TObject) Method

Summary

Represents method SBDownValueClick(TObject).

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 procedure SBDownValueClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.SBUpGroupClick(TObject) Method

Summary

Represents method SBUpGroupClick(TObject).

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 procedure SBUpGroupClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.SBUpValueClick(TObject) Method

Summary

Represents method SBUpValueClick(TObject).

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 procedure SBUpValueClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.ShowSettings(TTabItem) Method

Summary

Represents method ShowSettings(TTabItem).

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
public
 procedure ShowSettings(const ATab:TTabItem);

Parameters

ATab
Type: TTabItem

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.UDColumnsChangeTracking(TObject) Method

Summary

Represents method UDColumnsChangeTracking(TObject).

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 procedure UDColumnsChangeTracking(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor Fields

Fields
Name | Description
Button1 | Represents field Button1.
CBClass | Represents field CBClass.
CBComboAlign | Represents field CBComboAlign.
CBGroupBy | Represents field CBGroupBy.
CBListAlign | Represents field CBListAlign.
CBMultiScroll | Represents field CBMultiScroll.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Layout1 | Represents field Layout1.
Layout2 | Represents field Layout2.
Layout3 | Represents field Layout3.
Layout4 | Represents field Layout4.
Layout5 | Represents field Layout5.
LBGroups | Represents field LBGroups.
LBValues | Represents field LBValues.
LClass | Represents field LClass.
LCurrent | Represents field LCurrent.
LCurrentHeader | Represents field LCurrentHeader.
PageSettings | Represents field PageSettings.
SBDownGroup | Represents field SBDownGroup.
SBDownValue | Represents field SBDownValue.
SBUpGroup | Represents field SBUpGroup.
SBUpValue | Represents field SBUpValue.
TabCombo | Represents field TabCombo.
TabControl1 | Represents field TabControl1.
TabGroups | Represents field TabGroups.
TabList | Represents field TabList.
TabMulti | Represents field TabMulti.
TabValues | Represents field TabValues.
UDColumns | Represents field UDColumns.
Top


TVisualizerEditor.Button1 Field

Summary

Represents field Button1.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.CBClass Field

Summary

Represents field CBClass.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 CBClass: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.CBComboAlign Field

Summary

Represents field CBComboAlign.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 CBComboAlign: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.CBGroupBy Field

Summary

Represents field CBGroupBy.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 CBGroupBy: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.CBListAlign Field

Summary

Represents field CBListAlign.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 CBListAlign: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.CBMultiScroll Field

Summary

Represents field CBMultiScroll.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 CBMultiScroll: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.Label1 Field

Summary

Represents field Label1.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.Label2 Field

Summary

Represents field Label2.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.Label3 Field

Summary

Represents field Label3.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.Label4 Field

Summary

Represents field Label4.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 Label4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.Label5 Field

Summary

Represents field Label5.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 Label5: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.Layout1 Field

Summary

Represents field Layout1.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 Layout1: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.Layout2 Field

Summary

Represents field Layout2.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 Layout2: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.Layout3 Field

Summary

Represents field Layout3.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 Layout3: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.Layout4 Field

Summary

Represents field Layout4.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 Layout4: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.Layout5 Field

Summary

Represents field Layout5.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 Layout5: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.LBGroups Field

Summary

Represents field LBGroups.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 LBGroups: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.LBValues Field

Summary

Represents field LBValues.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 LBValues: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.LClass Field

Summary

Represents field LClass.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 LClass: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.LCurrent Field

Summary

Represents field LCurrent.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 LCurrent: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.LCurrentHeader Field

Summary

Represents field LCurrentHeader.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 LCurrentHeader: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.PageSettings Field

Summary

Represents field PageSettings.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 PageSettings: TTabControl;

Field Value

Type: TTabControl

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.SBDownGroup Field

Summary

Represents field SBDownGroup.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 SBDownGroup: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.SBDownValue Field

Summary

Represents field SBDownValue.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 SBDownValue: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.SBUpGroup Field

Summary

Represents field SBUpGroup.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 SBUpGroup: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.SBUpValue Field

Summary

Represents field SBUpValue.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 SBUpValue: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.TabCombo Field

Summary

Represents field TabCombo.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 TabCombo: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.TabControl1 Field

Summary

Represents field TabControl1.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 TabControl1: TTabControl;

Field Value

Type: TTabControl

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.TabGroups Field

Summary

Represents field TabGroups.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 TabGroups: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.TabList Field

Summary

Represents field TabList.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 TabList: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.TabMulti Field

Summary

Represents field TabMulti.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 TabMulti: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.TabValues Field

Summary

Represents field TabValues.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 TabValues: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


TVisualizerEditor.UDColumns Field

Summary

Represents field UDColumns.

Namespace: FMXBI.Editor.Visualizer
Syntax
Delphi
published
 UDColumns: TSpinBox;

Field Value

Type: TSpinBox

See Also

Reference

  • TVisualizerEditor
  • FMXBI.Editor.Visualizer


FMXBI.Editor.Visualizer.Chart Namespace

Summary

Represents namespace FMXBI.Editor.Visualizer.Chart.

Classes
Name | Description
TChartVisualizerEditor | Represents type TChartVisualizerEditor.
TVizAccess | Represents type TVizAccess.
Top


FMXBI.Editor.Visualizer.Chart Classes

Classes
Name | Description
TChartVisualizerEditor | Represents type TChartVisualizerEditor.
TVizAccess | Represents type TVizAccess.
Top


TChartVisualizerEditor Class

Summary

Represents type TChartVisualizerEditor.

Namespace: FMXBI.Editor.Visualizer.Chart
Inheritance Hierarchy
TForm
FMXBI.Editor.Visualizer.Chart.TChartVisualizerEditor
Syntax
Delphi
type
 TChartVisualizerEditor = class(TForm)
 end;

The TChartVisualizerEditor type exposes the following members.

Methods
Show:
Name | Description
Button2Click(TObject) | Represents method Button2Click(TObject).
CB2DChange(TObject) | Represents method CB2DChange(TObject).
CB3DChange(TObject) | Represents method CB3DChange(TObject).
CBAddNullsChange(TObject) | Represents method CBAddNullsChange(TObject).
CBAutoStackChange(TObject) | Represents method CBAutoStackChange(TObject).
CBSeriesStyleChange(TObject) | Represents method CBSeriesStyleChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
Top
Fields
Show:
Name | Description
Button2 | Represents field Button2.
CB2D | Represents field CB2D.
CB3D | Represents field CB3D.
CBAddNulls | Represents field CBAddNulls.
CBAutoStack | Represents field CBAutoStack.
CBSeriesStyle | Represents field CBSeriesStyle.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
Label8 | Represents field Label8.
Label9 | Represents field Label9.
TabChart | Represents field TabChart.
TabControl1 | Represents field TabControl1.
TabSeries | Represents field TabSeries.
Top
See Also

Reference

  • FMXBI.Editor.Visualizer.Chart


TChartVisualizerEditor Methods

Methods
Name | Description
Button2Click(TObject) | Represents method Button2Click(TObject).
CB2DChange(TObject) | Represents method CB2DChange(TObject).
CB3DChange(TObject) | Represents method CB3DChange(TObject).
CBAddNullsChange(TObject) | Represents method CBAddNullsChange(TObject).
CBAutoStackChange(TObject) | Represents method CBAutoStackChange(TObject).
CBSeriesStyleChange(TObject) | Represents method CBSeriesStyleChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
Top


TChartVisualizerEditor.Button2Click(TObject) Method

Summary

Represents method Button2Click(TObject).

Namespace: FMXBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure Button2Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • FMXBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CB2DChange(TObject) Method

Summary

Represents method CB2DChange(TObject).

Namespace: FMXBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure CB2DChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • FMXBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CB3DChange(TObject) Method

Summary

Represents method CB3DChange(TObject).

Namespace: FMXBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure CB3DChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • FMXBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBAddNullsChange(TObject) Method

Summary

Represents method CBAddNullsChange(TObject).

Namespace: FMXBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure CBAddNullsChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • FMXBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBAutoStackChange(TObject) Method

Summary

Represents method CBAutoStackChange(TObject).

Namespace: FMXBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure CBAutoStackChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • FMXBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBSeriesStyleChange(TObject) Method

Summary

Represents method CBSeriesStyleChange(TObject).

Namespace: FMXBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure CBSeriesStyleChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • FMXBI.Editor.Visualizer.Chart


TChartVisualizerEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: FMXBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • FMXBI.Editor.Visualizer.Chart


TChartVisualizerEditor Fields

Fields
Name | Description
Button2 | Represents field Button2.
CB2D | Represents field CB2D.
CB3D | Represents field CB3D.
CBAddNulls | Represents field CBAddNulls.
CBAutoStack | Represents field CBAutoStack.
CBSeriesStyle | Represents field CBSeriesStyle.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
Label8 | Represents field Label8.
Label9 | Represents field Label9.
TabChart | Represents field TabChart.
TabControl1 | Represents field TabControl1.
TabSeries | Represents field TabSeries.
Top


TChartVisualizerEditor.Button2 Field

Summary

Represents field Button2.

Namespace: FMXBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 Button2: TButton;

Field Value

Type: TButton

See Also

Reference

  • TChartVisualizerEditor
  • FMXBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CB2D Field

Summary

Represents field CB2D.

Namespace: FMXBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 CB2D: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TChartVisualizerEditor
  • FMXBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CB3D Field

Summary

Represents field CB3D.

Namespace: FMXBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 CB3D: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TChartVisualizerEditor
  • FMXBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBAddNulls Field

Summary

Represents field CBAddNulls.

Namespace: FMXBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 CBAddNulls: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TChartVisualizerEditor
  • FMXBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBAutoStack Field

Summary

Represents field CBAutoStack.

Namespace: FMXBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 CBAutoStack: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TChartVisualizerEditor
  • FMXBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBSeriesStyle Field

Summary

Represents field CBSeriesStyle.

Namespace: FMXBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 CBSeriesStyle: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TChartVisualizerEditor
  • FMXBI.Editor.Visualizer.Chart


TChartVisualizerEditor.Label6 Field

Summary

Represents field Label6.

Namespace: FMXBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 Label6: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TChartVisualizerEditor
  • FMXBI.Editor.Visualizer.Chart


TChartVisualizerEditor.Label7 Field

Summary

Represents field Label7.

Namespace: FMXBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 Label7: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TChartVisualizerEditor
  • FMXBI.Editor.Visualizer.Chart


TChartVisualizerEditor.Label8 Field

Summary

Represents field Label8.

Namespace: FMXBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 Label8: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TChartVisualizerEditor
  • FMXBI.Editor.Visualizer.Chart


TChartVisualizerEditor.Label9 Field

Summary

Represents field Label9.

Namespace: FMXBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 Label9: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TChartVisualizerEditor
  • FMXBI.Editor.Visualizer.Chart


TChartVisualizerEditor.TabChart Field

Summary

Represents field TabChart.

Namespace: FMXBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 TabChart: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TChartVisualizerEditor
  • FMXBI.Editor.Visualizer.Chart


TChartVisualizerEditor.TabControl1 Field

Summary

Represents field TabControl1.

Namespace: FMXBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 TabControl1: TTabControl;

Field Value

Type: TTabControl

See Also

Reference

  • TChartVisualizerEditor
  • FMXBI.Editor.Visualizer.Chart


TChartVisualizerEditor.TabSeries Field

Summary

Represents field TabSeries.

Namespace: FMXBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 TabSeries: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TChartVisualizerEditor
  • FMXBI.Editor.Visualizer.Chart


TVizAccess Class

Summary

Represents type TVizAccess.

Namespace: FMXBI.Editor.Visualizer.Chart
Inheritance Hierarchy
TForm
FMXBI.Editor.Visualizer.TVisualizerEditor
FMXBI.Editor.Visualizer.Chart.TVizAccess
Syntax
Delphi
type
 TVizAccess=class(TVisualizerEditor);
See Also

Reference

  • FMXBI.Editor.Visualizer.Chart


FMXBI.Grid Namespace

Summary

Represents namespace FMXBI.Grid.

Classes
Name | Description
TBIGrid | Represents type TBIGrid.
TPluginAccess | Represents type TPluginAccess.
Top
Records
Name | Description
TUICommon | Represents type TUICommon.
Top
Enumerations
Name | Description
TGridShowItems | Represents type TGridShowItems.
Top
Constants
Name | Description
EditorsKey | Represents constant EditorsKey.
Top
Routines
Name | Description
DataSetOf(TObject) | Represents method DataSetOf(TObject).
GetScreenSize | Represents method GetScreenSize.
InternalShowMessage(String) | Represents method InternalShowMessage(String).
Top


FMXBI.Grid Classes

Classes
Name | Description
TBIGrid | Represents type TBIGrid.
TPluginAccess | Represents type TPluginAccess.
Top


TBIGrid Class

Summary

Represents type TBIGrid.

Namespace: FMXBI.Grid
Inheritance Hierarchy
TLayout
FMXBI.DataControl.TBIDataControl
FMXBI.Grid.TBIGrid
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64 or pidOSX32
 or pidiOSSimulator or pidiOSDevice
 or pidAndroid
 or pidiOSDevice64
 )]
 TBIGrid = class(TBIDataControl)
 end;

The TBIGrid type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIGrid class. (Overrides TBIDataControl.Create(TComponent).)
Destroy | Represents the destructor of the TBIGrid class. (Overrides TBIDataControl.Destroy.)
Top
Properties
Show:
Name | Description
Alternate | Represents property Alternate.
CurrentRow | Represents property CurrentRow.
DataSet | Represents property DataSet.
OnDataChange | Represents property OnDataChange.
Plugin | Represents property Plugin.
ReadOnly | Represents property ReadOnly.
ShowItems | Represents property ShowItems.
Top
Methods
Show:
Name | Description
BindTo(TDataItem) | Represents method BindTo(TDataItem).
Colorize | Overloaded. Represents method Colorize.
Colorize(TDataColorizers) | Overloaded. Represents method Colorize(TDataColorizers).
Duplicates(TDataItem,Boolean) | Represents method Duplicates(TDataItem,Boolean).
Embedd(TComponent,TFmxObject) | Represents method Embedd(TComponent,TFmxObject).
SetDataDirect(TDataItem) | Represents method SetDataDirect(TDataItem). (Overrides TBIDataControl.SetDataDirect(TDataItem).)
UpdatedDataValues | Represents method UpdatedDataValues. (Overrides TBIDataControl.UpdatedDataValues.)
Top
Fields
Show:
Name | Description
Engine | Represents field Engine.
Top
See Also

Reference

  • FMXBI.Grid


TBIGrid Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBIGrid class. (Overrides TBIDataControl.Create(TComponent).)
Destroy | Represents the destructor of the TBIGrid class. (Overrides TBIDataControl.Destroy.)
Top


TBIGrid.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIGrid class.

Namespace: FMXBI.Grid
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TBIDataControl.Create(TComponent)
See Also

Reference

  • TBIGrid
  • FMXBI.Grid


TBIGrid.Destroy Destructor

Summary

Represents the destructor of the TBIGrid class.

Namespace: FMXBI.Grid
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TBIDataControl.Destroy
See Also

Reference

  • TBIGrid
  • FMXBI.Grid


TBIGrid Properties

Properties
Name | Description
Alternate | Represents property Alternate.
CurrentRow | Represents property CurrentRow.
DataSet | Represents property DataSet.
OnDataChange | Represents property OnDataChange.
Plugin | Represents property Plugin.
ReadOnly | Represents property ReadOnly.
ShowItems | Represents property ShowItems.
Top


TBIGrid.Alternate Property

Summary

Represents property Alternate.

Namespace: FMXBI.Grid
Syntax
Delphi
published
 property Alternate:TAlternateColor read FAlternate write SetAlternate;

Property Value

Type: TAlternateColor

See Also

Reference

  • TBIGrid
  • FMXBI.Grid


TBIGrid.CurrentRow Property

Summary

Represents property CurrentRow.

Namespace: FMXBI.Grid
Syntax
Delphi
public
 property CurrentRow:Integer read GetCurrentRow;

Property Value

Type: Integer

See Also

Reference

  • TBIGrid
  • FMXBI.Grid


TBIGrid.DataSet Property

Summary

Represents property DataSet.

Namespace: FMXBI.Grid
Syntax
Delphi
public
 property DataSet:TBIDataSet read IDataSet write SetDataSet;

Property Value

Type: TBIDataSet

See Also

Reference

  • TBIGrid
  • FMXBI.Grid


TBIGrid.OnDataChange Property

Summary

Represents property OnDataChange.

Namespace: FMXBI.Grid
Syntax
Delphi
published
 property OnDataChange:TNotifyEvent read FOnDataChange write FOnDataChange;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TBIGrid
  • FMXBI.Grid


TBIGrid.Plugin Property

Summary

Represents property Plugin.

Namespace: FMXBI.Grid
Syntax
Delphi
public
 property Plugin:TBIGridPlugin read IPlugin write SetPlugin;

Property Value

Type: TBIGridPlugin

See Also

Reference

  • TBIGrid
  • FMXBI.Grid


TBIGrid.ReadOnly Property

Summary

Represents property ReadOnly.

Namespace: FMXBI.Grid
Syntax
Delphi
published
 property ReadOnly:Boolean read GetReadOnly write SetReadOnly default True;

Property Value

Type: Boolean

See Also

Reference

  • TBIGrid
  • FMXBI.Grid


TBIGrid.ShowItems Property

Summary

Represents property ShowItems.

Namespace: FMXBI.Grid
Syntax
Delphi
published
 property ShowItems:TGridShowItems read FShowItems write SetShowItems default TGridShowItems.Automatic;

Property Value

Type: TGridShowItems

See Also

Reference

  • TBIGrid
  • FMXBI.Grid


TBIGrid Methods

Methods
Name | Description
BindTo(TDataItem) | Represents method BindTo(TDataItem).
Colorize | Overloaded. Represents method Colorize.
Colorize(TDataColorizers) | Overloaded. Represents method Colorize(TDataColorizers).
Duplicates(TDataItem,Boolean) | Represents method Duplicates(TDataItem,Boolean).
Embedd(TComponent,TFmxObject) | Represents method Embedd(TComponent,TFmxObject).
SetDataDirect(TDataItem) | Represents method SetDataDirect(TDataItem). (Overrides TBIDataControl.SetDataDirect(TDataItem).)
UpdatedDataValues | Represents method UpdatedDataValues. (Overrides TBIDataControl.UpdatedDataValues.)
Top


TBIGrid.BindTo(TDataItem) Method

Summary

Represents method BindTo(TDataItem).

Namespace: FMXBI.Grid
Syntax
Delphi
public
 procedure BindTo(const AData: TDataItem);

Parameters

AData
Type: TDataItem

See Also

Reference

  • TBIGrid
  • FMXBI.Grid


TBIGrid.Colorize Method

Summary

Represents method Colorize.

Namespace: FMXBI.Grid
Syntax
Delphi
public
 procedure Colorize; overload;
See Also

Reference

  • TBIGrid
  • FMXBI.Grid


TBIGrid.Colorize(TDataColorizers) Method

Summary

Represents method Colorize(TDataColorizers).

Namespace: FMXBI.Grid
Syntax
Delphi
public
 procedure Colorize(const AItems:TDataColorizers); overload;

Parameters

AItems
Type: TDataColorizers

See Also

Reference

  • TBIGrid
  • FMXBI.Grid


TBIGrid.Duplicates(TDataItem,Boolean) Method

Summary

Represents method Duplicates(TDataItem,Boolean).

Namespace: FMXBI.Grid
Syntax
Delphi
public
 procedure Duplicates(const AData:TDataItem; const Hide:Boolean);

Parameters

AData
Type: TDataItem

Hide
Type: Boolean

See Also

Reference

  • TBIGrid
  • FMXBI.Grid


TBIGrid.Embedd(TComponent,TFmxObject) Method

Summary

Represents method Embedd(TComponent,TFmxObject).

Namespace: FMXBI.Grid
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TFmxObject):TBIGrid; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TFmxObject

Return Value

Type: TBIGrid

See Also

Reference

  • TBIGrid
  • FMXBI.Grid


TBIGrid.SetDataDirect(TDataItem) Method

Summary

Represents method SetDataDirect(TDataItem).

Namespace: FMXBI.Grid
Syntax
Delphi
protected
 procedure SetDataDirect(const Value: TDataItem); override;

Parameters

Value
Type: TDataItem

Overrides

TBIDataControl.SetDataDirect(TDataItem)
See Also

Reference

  • TBIGrid
  • FMXBI.Grid


TBIGrid.UpdatedDataValues Method

Summary

Represents method UpdatedDataValues.

Namespace: FMXBI.Grid
Syntax
Delphi
protected
 procedure UpdatedDataValues; override;

Overrides

TBIDataControl.UpdatedDataValues
See Also

Reference

  • TBIGrid
  • FMXBI.Grid


TBIGrid Fields

Fields
Name | Description
Engine | Represents field Engine.
Top


TBIGrid.Engine Field

Summary

Represents field Engine.

Namespace: FMXBI.Grid
Syntax
Delphi
public
 class var
 Engine : TBIGridPluginClass;

Field Value

Type: TBIGridPluginClass

See Also

Reference

  • TBIGrid
  • FMXBI.Grid


TPluginAccess Class

Summary

Represents type TPluginAccess.

Namespace: FMXBI.Grid
Inheritance Hierarchy
TObject
BI.Grid.Plugin.TBIGridPlugin
FMXBI.Grid.TPluginAccess
Syntax
Delphi
type
 TPluginAccess=class(TBIGridPlugin);
See Also

Reference

  • FMXBI.Grid


FMXBI.Grid Records

Records
Name | Description
TUICommon | Represents type TUICommon.
Top


TUICommon Record

Summary

Represents type TUICommon.

Namespace: FMXBI.Grid
Syntax
Delphi
type
 TUICommon=record
 end;

The TUICommon type exposes the following members.

Constants
Show:
Name | Description
AlignBottom | Represents constant AlignBottom.
AlignClient | Represents constant AlignClient.
AlignLeft | Represents constant AlignLeft.
AlignNone | Represents constant AlignNone.
AlignRight | Represents constant AlignRight.
AlignTop | Represents constant AlignTop.
Top
Methods
Show:
Name | Description
AddForm(TCommonCustomForm,TFmxObject) | Represents method AddForm(TCommonCustomForm,TFmxObject).
AddNewTab(TCommonCustomForm,TTabControl) | Represents method AddNewTab(TCommonCustomForm,TTabControl).
AutoTest | Represents method AutoTest.
CopyToClipboard(String) | Represents method CopyToClipboard(String).
GotoURL(TControl,String) | Represents method GotoURL(TControl,String).
Input(String,String,String,String) | Represents method Input(String,String,String,String).
LoadPosition(TCommonCustomForm,String) | Overloaded. Represents method LoadPosition(TCommonCustomForm,String).
LoadPosition(TCommonCustomForm,String,String) | Overloaded. Represents method LoadPosition(TCommonCustomForm,String,String).
Popup(TPopupMenu,TControl) | Represents method Popup(TPopupMenu,TControl).
SavePosition(TCommonCustomForm,String) | Overloaded. Represents method SavePosition(TCommonCustomForm,String).
SavePosition(TCommonCustomForm,String,String) | Overloaded. Represents method SavePosition(TCommonCustomForm,String,String).
SelectFolder(String) | Represents method SelectFolder(String).
YesNo(String) | Represents method YesNo(String).
Top
See Also

Reference

  • FMXBI.Grid


TUICommon Constants

Constants
Name | Description
AlignBottom | Represents constant AlignBottom.
AlignClient | Represents constant AlignClient.
AlignLeft | Represents constant AlignLeft.
AlignNone | Represents constant AlignNone.
AlignRight | Represents constant AlignRight.
AlignTop | Represents constant AlignTop.
Top


TUICommon.AlignBottom Constant

Summary

Represents constant AlignBottom.

Namespace: FMXBI.Grid
Syntax
Delphi
public
 AlignBottom=TAlignLayout.Bottom;

Value

Type: Void

See Also

Reference

  • TUICommon
  • FMXBI.Grid


TUICommon.AlignClient Constant

Summary

Represents constant AlignClient.

Namespace: FMXBI.Grid
Syntax
Delphi
public
 AlignClient=TAlignLayout.Client;

Value

Type: Void

See Also

Reference

  • TUICommon
  • FMXBI.Grid


TUICommon.AlignLeft Constant

Summary

Represents constant AlignLeft.

Namespace: FMXBI.Grid
Syntax
Delphi
public
 AlignLeft=TAlignLayout.Left;

Value

Type: Void

See Also

Reference

  • TUICommon
  • FMXBI.Grid


TUICommon.AlignNone Constant

Summary

Represents constant AlignNone.

Namespace: FMXBI.Grid
Syntax
Delphi
public
 AlignNone=TAlignLayout.None;

Value

Type: Void

See Also

Reference

  • TUICommon
  • FMXBI.Grid


TUICommon.AlignRight Constant

Summary

Represents constant AlignRight.

Namespace: FMXBI.Grid
Syntax
Delphi
public
 AlignRight=TAlignLayout.Right;

Value

Type: Void

See Also

Reference

  • TUICommon
  • FMXBI.Grid


TUICommon.AlignTop Constant

Summary

Represents constant AlignTop.

Namespace: FMXBI.Grid
Syntax
Delphi
public
 AlignTop=TAlignLayout.Top;

Value

Type: Void

See Also

Reference

  • TUICommon
  • FMXBI.Grid


TUICommon Methods

Methods
Name | Description
AddForm(TCommonCustomForm,TFmxObject) | Represents method AddForm(TCommonCustomForm,TFmxObject).
AddNewTab(TCommonCustomForm,TTabControl) | Represents method AddNewTab(TCommonCustomForm,TTabControl).
AutoTest | Represents method AutoTest.
CopyToClipboard(String) | Represents method CopyToClipboard(String).
GotoURL(TControl,String) | Represents method GotoURL(TControl,String).
Input(String,String,String,String) | Represents method Input(String,String,String,String).
LoadPosition(TCommonCustomForm,String) | Overloaded. Represents method LoadPosition(TCommonCustomForm,String).
LoadPosition(TCommonCustomForm,String,String) | Overloaded. Represents method LoadPosition(TCommonCustomForm,String,String).
Popup(TPopupMenu,TControl) | Represents method Popup(TPopupMenu,TControl).
SavePosition(TCommonCustomForm,String) | Overloaded. Represents method SavePosition(TCommonCustomForm,String).
SavePosition(TCommonCustomForm,String,String) | Overloaded. Represents method SavePosition(TCommonCustomForm,String,String).
SelectFolder(String) | Represents method SelectFolder(String).
YesNo(String) | Represents method YesNo(String).
Top


TUICommon.AddForm(TCommonCustomForm,TFmxObject) Method

Summary

Represents method AddForm(TCommonCustomForm,TFmxObject).

Namespace: FMXBI.Grid
Syntax
Delphi
public
 class procedure AddForm(const AForm: TCommonCustomForm; const AParent: TFmxObject); static;

Parameters

AForm
Type: TCommonCustomForm

AParent
Type: TFmxObject

See Also

Reference

  • TUICommon
  • FMXBI.Grid


TUICommon.AddNewTab(TCommonCustomForm,TTabControl) Method

Summary

Represents method AddNewTab(TCommonCustomForm,TTabControl).

Namespace: FMXBI.Grid
Syntax
Delphi
public
 class function AddNewTab(const AForm: TCommonCustomForm; const AParent: TTabControl):TTabItem; static;

Parameters

AForm
Type: TCommonCustomForm

AParent
Type: TTabControl

Return Value

Type: TTabItem

See Also

Reference

  • TUICommon
  • FMXBI.Grid


TUICommon.AutoTest Method

Summary

Represents method AutoTest.

Namespace: FMXBI.Grid
Syntax
Delphi
public
 class function AutoTest:Boolean; static;

Return Value

Type: Boolean

See Also

Reference

  • TUICommon
  • FMXBI.Grid


TUICommon.CopyToClipboard(String) Method

Summary

Represents method CopyToClipboard(String).

Namespace: FMXBI.Grid
Syntax
Delphi
public
 class procedure CopyToClipboard(const AText:String); static;

Parameters

AText
Type: String

See Also

Reference

  • TUICommon
  • FMXBI.Grid


TUICommon.GotoURL(TControl,String) Method

Summary

Represents method GotoURL(TControl,String).

Namespace: FMXBI.Grid
Syntax
Delphi
public
 class procedure GotoURL(const AOwner:TControl; const AURL:String); static;

Parameters

AOwner
Type: TControl

AURL
Type: String

See Also

Reference

  • TUICommon
  • FMXBI.Grid


TUICommon.Input(String,String,String,String) Method

Summary

Represents method Input(String,String,String,String).

Namespace: FMXBI.Grid
Syntax
Delphi
public
 class function Input(const ATitle,ACaption,ADefault:String; out AValue:String):Boolean; static;

Parameters

ATitle
Type: String

ACaption
Type: String

ADefault
Type: String

AValue
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TUICommon
  • FMXBI.Grid


TUICommon.LoadPosition(TCommonCustomForm,String) Method

Summary

Represents method LoadPosition(TCommonCustomForm,String).

Namespace: FMXBI.Grid
Syntax
Delphi
public
 class procedure LoadPosition(const AForm:TCommonCustomForm; const Key:String); overload; static;

Parameters

AForm
Type: TCommonCustomForm

Key
Type: String

See Also

Reference

  • TUICommon
  • FMXBI.Grid


TUICommon.LoadPosition(TCommonCustomForm,String,String) Method

Summary

Represents method LoadPosition(TCommonCustomForm,String,String).

Namespace: FMXBI.Grid
Syntax
Delphi
public
 class procedure LoadPosition(const AForm:TCommonCustomForm; const Parent,Key:String); overload; static;

Parameters

AForm
Type: TCommonCustomForm

Parent
Type: String

Key
Type: String

See Also

Reference

  • TUICommon
  • FMXBI.Grid


TUICommon.Popup(TPopupMenu,TControl) Method

Summary

Represents method Popup(TPopupMenu,TControl).

Namespace: FMXBI.Grid
Syntax
Delphi
public
 class procedure Popup(const APopup:TPopupMenu; const AControl:TControl); static;

Parameters

APopup
Type: TPopupMenu

AControl
Type: TControl

See Also

Reference

  • TUICommon
  • FMXBI.Grid


TUICommon.SavePosition(TCommonCustomForm,String) Method

Summary

Represents method SavePosition(TCommonCustomForm,String).

Namespace: FMXBI.Grid
Syntax
Delphi
public
 class procedure SavePosition(const AForm:TCommonCustomForm; const Key:String); overload; static;

Parameters

AForm
Type: TCommonCustomForm

Key
Type: String

See Also

Reference

  • TUICommon
  • FMXBI.Grid


TUICommon.SavePosition(TCommonCustomForm,String,String) Method

Summary

Represents method SavePosition(TCommonCustomForm,String,String).

Namespace: FMXBI.Grid
Syntax
Delphi
public
 class procedure SavePosition(const AForm:TCommonCustomForm; const Parent,Key:String); overload; static;

Parameters

AForm
Type: TCommonCustomForm

Parent
Type: String

Key
Type: String

See Also

Reference

  • TUICommon
  • FMXBI.Grid


TUICommon.SelectFolder(String) Method

Summary

Represents method SelectFolder(String).

Namespace: FMXBI.Grid
Syntax
Delphi
public
 class function SelectFolder(var AFolder: String): Boolean; static;

Parameters

AFolder
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TUICommon
  • FMXBI.Grid


TUICommon.YesNo(String) Method

Summary

Represents method YesNo(String).

Namespace: FMXBI.Grid
Syntax
Delphi
public
 class function YesNo(const AMessage:String):Boolean; static;

Parameters

AMessage
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TUICommon
  • FMXBI.Grid


FMXBI.Grid Enumerations

Enumerations
Name | Description
TGridShowItems | Represents type TGridShowItems.
Top


TGridShowItems Enumeration

Summary

Represents type TGridShowItems.

Namespace: FMXBI.Grid
Syntax
Delphi
type
 TGridShowItems=(Automatic, Yes, No);

The TGridShowItems type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
No | Represents constant No.
Yes | Represents constant Yes.
Top
See Also

Reference

  • FMXBI.Grid


FMXBI.Grid Constants

Constants
Name | Description
EditorsKey | Represents constant EditorsKey.
Top


EditorsKey Constant

Summary

Represents constant EditorsKey.

Namespace: FMXBI.Grid
Syntax
Delphi
 EditorsKey='Editors';

Value

Type: string

See Also

Reference

  • FMXBI.Grid


FMXBI.Grid Routines

Routines
Name | Description
DataSetOf(TObject) | Represents method DataSetOf(TObject).
GetScreenSize | Represents method GetScreenSize.
InternalShowMessage(String) | Represents method InternalShowMessage(String).
Top


DataSetOf(TObject) Method

Summary

Represents method DataSetOf(TObject).

Namespace: FMXBI.Grid
Syntax
Delphi
function DataSetOf(const AObject:TObject):TDataSet;

Parameters

AObject
Type: TObject

Return Value

Type: TDataSet

See Also

Reference

  • FMXBI.Grid


GetScreenSize Method

Summary

Represents method GetScreenSize.

Namespace: FMXBI.Grid
Syntax
Delphi
function GetScreenSize:TPointF;

Return Value

Type: TPointF

See Also

Reference

  • FMXBI.Grid


InternalShowMessage(String) Method

Summary

Represents method InternalShowMessage(String).

Namespace: FMXBI.Grid
Syntax
Delphi
procedure InternalShowMessage(const AText:String);

Parameters

AText
Type: String

See Also

Reference

  • FMXBI.Grid


FMXBI.Grid.Grid Namespace

Summary

Represents namespace FMXBI.Grid.Grid.

Classes
Name | Description
TBIFMXGrid | Represents type TBIFMXGrid.
TBIFMXGridPlugin | Represents type TBIFMXGridPlugin.
TBindSourceDBAccess | Represents type TBindSourceDBAccess.
TColumnAccess | Represents type TColumnAccess.
TDataAccess | Represents type TDataAccess.
Top
Routines
Name | Description
SwapRGB(TAlphaColor) | Represents method SwapRGB(TAlphaColor).
Top


FMXBI.Grid.Grid Classes

Classes
Name | Description
TBIFMXGrid | Represents type TBIFMXGrid.
TBIFMXGridPlugin | Represents type TBIFMXGridPlugin.
TBindSourceDBAccess | Represents type TBindSourceDBAccess.
TColumnAccess | Represents type TColumnAccess.
TDataAccess | Represents type TDataAccess.
Top


TBIFMXGrid Class

Summary

Represents type TBIFMXGrid.

Namespace: FMXBI.Grid.Grid
Inheritance Hierarchy
TObject
FMXBI.Grid.Grid.TBIFMXGrid
FMXBI.Dashboard.TGridAccess
FMXBI.GridForm.TGridAccess
Syntax
Delphi
type
 TBIFMXGrid=class
 end;

The TBIFMXGrid type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIFMXGrid class.
Destroy | Represents the destructor of the TBIFMXGrid class.
Top
Properties
Show:
Name | Description
ColumnSort | Represents property ColumnSort.
Grid | Represents property Grid.
OnRowChanged | Represents property OnRowChanged.
Top
Methods
Show:
Name | Description
DataOf(TColumn,TBIDataset) | Represents method DataOf(TColumn,TBIDataset).
TotalWidth | Represents method TotalWidth.
Top
Fields
Show:
Name | Description
BindSource | Represents field BindSource.
Top
See Also

Reference

  • FMXBI.Grid.Grid


TBIFMXGrid Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBIFMXGrid class.
Destroy | Represents the destructor of the TBIFMXGrid class.
Top


TBIFMXGrid.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIFMXGrid class.

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent);

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBIFMXGrid
  • FMXBI.Grid.Grid


TBIFMXGrid.Destroy Destructor

Summary

Represents the destructor of the TBIFMXGrid class.

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIFMXGrid
  • FMXBI.Grid.Grid


TBIFMXGrid Properties

Properties
Name | Description
ColumnSort | Represents property ColumnSort.
Grid | Represents property Grid.
OnRowChanged | Represents property OnRowChanged.
Top


TBIFMXGrid.ColumnSort Property

Summary

Represents property ColumnSort.

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
public
 property ColumnSort:Boolean read FColumnSort write SetColumnSort default True;

Property Value

Type: Boolean

See Also

Reference

  • TBIFMXGrid
  • FMXBI.Grid.Grid


TBIFMXGrid.Grid Property

Summary

Represents property Grid.

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
public
 property Grid:TGrid read IFMXGrid;

Property Value

Type: TGrid

See Also

Reference

  • TBIFMXGrid
  • FMXBI.Grid.Grid


TBIFMXGrid.OnRowChanged Property

Summary

Represents property OnRowChanged.

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
public
 property OnRowChanged:TNotifyEvent read FOnRowChanged write FOnRowChanged;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TBIFMXGrid
  • FMXBI.Grid.Grid


TBIFMXGrid Methods

Methods
Name | Description
DataOf(TColumn,TBIDataset) | Represents method DataOf(TColumn,TBIDataset).
TotalWidth | Represents method TotalWidth.
Top


TBIFMXGrid.DataOf(TColumn,TBIDataset) Method

Summary

Represents method DataOf(TColumn,TBIDataset).

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
protected
 function DataOf(const AColumn:TColumn; out ADataSet:TBIDataSet):TDataItem;

Parameters

AColumn
Type: TColumn

ADataSet
Type: TBIDataSet

Return Value

Type: TDataItem

See Also

Reference

  • TBIFMXGrid
  • FMXBI.Grid.Grid


TBIFMXGrid.TotalWidth Method

Summary

Represents method TotalWidth.

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
protected
 function TotalWidth:Single;

Return Value

Type: Single

See Also

Reference

  • TBIFMXGrid
  • FMXBI.Grid.Grid


TBIFMXGrid Fields

Fields
Name | Description
BindSource | Represents field BindSource.
Top


TBIFMXGrid.BindSource Field

Summary

Represents field BindSource.

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
protected
 BindSource : TBindSourceDB;

Field Value

Type: TBindSourceDB

See Also

Reference

  • TBIFMXGrid
  • FMXBI.Grid.Grid


TBIFMXGridPlugin Class

Summary

Represents type TBIFMXGridPlugin.

Namespace: FMXBI.Grid.Grid
Inheritance Hierarchy
TObject
BI.Grid.Plugin.TBIGridPlugin
FMXBI.Grid.Grid.TBIFMXGridPlugin
Syntax
Delphi
type
 TBIFMXGridPlugin=class(TBIGridPlugin)
 end;

The TBIFMXGridPlugin type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIFMXGridPlugin class. (Overrides TBIGridPlugin.Create(TComponent).)
Destroy | Represents the destructor of the TBIFMXGridPlugin class.
Top
Methods
Show:
Name | Description
AutoWidth | Represents method AutoWidth. (Overrides TBIGridPlugin.AutoWidth.)
BindTo(TDataSet) | Represents method BindTo(TDataSet). (Overrides TBIGridPlugin.BindTo(TDataSet).)
ChangedAlternate(TObject) | Represents method ChangedAlternate(TObject). (Overrides TBIGridPlugin.ChangedAlternate(TObject).)
Colorize(TDataColorizers) | Represents method Colorize(TDataColorizers). (Overrides TBIGridPlugin.Colorize(TDataColorizers).)
Duplicates(TDataItem,Boolean) | Represents method Duplicates(TDataItem,Boolean). (Overrides TBIGridPlugin.Duplicates(TDataItem,Boolean).)
GetCanSort | Represents method GetCanSort. (Overrides TBIGridPlugin.GetCanSort.)
GetControl | Represents method GetControl. (Overrides TBIGridPlugin.GetControl.)
GetDataSource | Represents method GetDataSource. (Overrides TBIGridPlugin.GetDataSource.)
GetObject | Represents method GetObject. (Overrides TBIGridPlugin.GetObject.)
GetReadOnly | Represents method GetReadOnly. (Overrides TBIGridPlugin.GetReadOnly.)
GetSortEnabled | Represents method GetSortEnabled. (Overrides TBIGridPlugin.GetSortEnabled.)
GetTotals | Represents method GetTotals. (Overrides TBIGridPlugin.GetTotals.)
SetDataSource(TDataSource) | Represents method SetDataSource(TDataSource). (Overrides TBIGridPlugin.SetDataSource(TDataSource).)
SetOnRowChanged(TNotifyEvent) | Represents method SetOnRowChanged(TNotifyEvent). (Overrides TBIGridPlugin.SetOnRowChanged(TNotifyEvent).)
SetPopup(TObject) | Represents method SetPopup(TObject). (Overrides TBIGridPlugin.SetPopup(TObject).)
SetReadOnly(Boolean) | Represents method SetReadOnly(Boolean). (Overrides TBIGridPlugin.SetReadOnly(Boolean).)
SetSortEnabled(Boolean) | Represents method SetSortEnabled(Boolean). (Overrides TBIGridPlugin.SetSortEnabled(Boolean).)
SetTotals(Boolean) | Represents method SetTotals(Boolean). (Overrides TBIGridPlugin.SetTotals(Boolean).)
Top
See Also

Reference

  • FMXBI.Grid.Grid


TBIFMXGridPlugin Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBIFMXGridPlugin class. (Overrides TBIGridPlugin.Create(TComponent).)
Destroy | Represents the destructor of the TBIFMXGridPlugin class.
Top


TBIFMXGridPlugin.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIFMXGridPlugin class.

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TBIGridPlugin.Create(TComponent)
See Also

Reference

  • TBIFMXGridPlugin
  • FMXBI.Grid.Grid


TBIFMXGridPlugin.Destroy Destructor

Summary

Represents the destructor of the TBIFMXGridPlugin class.

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIFMXGridPlugin
  • FMXBI.Grid.Grid


TBIFMXGridPlugin Methods

Methods
Name | Description
AutoWidth | Represents method AutoWidth. (Overrides TBIGridPlugin.AutoWidth.)
BindTo(TDataSet) | Represents method BindTo(TDataSet). (Overrides TBIGridPlugin.BindTo(TDataSet).)
ChangedAlternate(TObject) | Represents method ChangedAlternate(TObject). (Overrides TBIGridPlugin.ChangedAlternate(TObject).)
Colorize(TDataColorizers) | Represents method Colorize(TDataColorizers). (Overrides TBIGridPlugin.Colorize(TDataColorizers).)
Duplicates(TDataItem,Boolean) | Represents method Duplicates(TDataItem,Boolean). (Overrides TBIGridPlugin.Duplicates(TDataItem,Boolean).)
GetCanSort | Represents method GetCanSort. (Overrides TBIGridPlugin.GetCanSort.)
GetControl | Represents method GetControl. (Overrides TBIGridPlugin.GetControl.)
GetDataSource | Represents method GetDataSource. (Overrides TBIGridPlugin.GetDataSource.)
GetObject | Represents method GetObject. (Overrides TBIGridPlugin.GetObject.)
GetReadOnly | Represents method GetReadOnly. (Overrides TBIGridPlugin.GetReadOnly.)
GetSortEnabled | Represents method GetSortEnabled. (Overrides TBIGridPlugin.GetSortEnabled.)
GetTotals | Represents method GetTotals. (Overrides TBIGridPlugin.GetTotals.)
SetDataSource(TDataSource) | Represents method SetDataSource(TDataSource). (Overrides TBIGridPlugin.SetDataSource(TDataSource).)
SetOnRowChanged(TNotifyEvent) | Represents method SetOnRowChanged(TNotifyEvent). (Overrides TBIGridPlugin.SetOnRowChanged(TNotifyEvent).)
SetPopup(TObject) | Represents method SetPopup(TObject). (Overrides TBIGridPlugin.SetPopup(TObject).)
SetReadOnly(Boolean) | Represents method SetReadOnly(Boolean). (Overrides TBIGridPlugin.SetReadOnly(Boolean).)
SetSortEnabled(Boolean) | Represents method SetSortEnabled(Boolean). (Overrides TBIGridPlugin.SetSortEnabled(Boolean).)
SetTotals(Boolean) | Represents method SetTotals(Boolean). (Overrides TBIGridPlugin.SetTotals(Boolean).)
Top


TBIFMXGridPlugin.AutoWidth Method

Summary

Represents method AutoWidth.

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
protected
 procedure AutoWidth; override;

Overrides

TBIGridPlugin.AutoWidth
See Also

Reference

  • TBIFMXGridPlugin
  • FMXBI.Grid.Grid


TBIFMXGridPlugin.BindTo(TDataSet) Method

Summary

Represents method BindTo(TDataSet).

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
public
 procedure BindTo(const ADataSet:TDataSet); override;

Parameters

ADataSet
Type: TDataSet

Overrides

TBIGridPlugin.BindTo(TDataSet)
See Also

Reference

  • TBIFMXGridPlugin
  • FMXBI.Grid.Grid


TBIFMXGridPlugin.ChangedAlternate(TObject) Method

Summary

Represents method ChangedAlternate(TObject).

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
protected
 procedure ChangedAlternate(Sender:TObject); override;

Parameters

Sender
Type: TObject

Overrides

TBIGridPlugin.ChangedAlternate(TObject)
See Also

Reference

  • TBIFMXGridPlugin
  • FMXBI.Grid.Grid


TBIFMXGridPlugin.Colorize(TDataColorizers) Method

Summary

Represents method Colorize(TDataColorizers).

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
public
 procedure Colorize(const AItems:TDataColorizers); override;

Parameters

AItems
Type: TDataColorizers

Overrides

TBIGridPlugin.Colorize(TDataColorizers)
See Also

Reference

  • TBIFMXGridPlugin
  • FMXBI.Grid.Grid


TBIFMXGridPlugin.Duplicates(TDataItem,Boolean) Method

Summary

Represents method Duplicates(TDataItem,Boolean).

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
public
 procedure Duplicates(const AData:TDataItem; const Hide:Boolean); override;

Parameters

AData
Type: TDataItem

Hide
Type: Boolean

Overrides

TBIGridPlugin.Duplicates(TDataItem,Boolean)
See Also

Reference

  • TBIFMXGridPlugin
  • FMXBI.Grid.Grid


TBIFMXGridPlugin.GetCanSort Method

Summary

Represents method GetCanSort.

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
protected
 function GetCanSort: Boolean; override;

Return Value

Type: Boolean

Overrides

TBIGridPlugin.GetCanSort
See Also

Reference

  • TBIFMXGridPlugin
  • FMXBI.Grid.Grid


TBIFMXGridPlugin.GetControl Method

Summary

Represents method GetControl.

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
public
 function GetControl:TObject; override;

Return Value

Type: TObject

Overrides

TBIGridPlugin.GetControl
See Also

Reference

  • TBIFMXGridPlugin
  • FMXBI.Grid.Grid


TBIFMXGridPlugin.GetDataSource Method

Summary

Represents method GetDataSource.

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
protected
 function GetDataSource: TDataSource; override;

Return Value

Type: TDataSource

Overrides

TBIGridPlugin.GetDataSource
See Also

Reference

  • TBIFMXGridPlugin
  • FMXBI.Grid.Grid


TBIFMXGridPlugin.GetObject Method

Summary

Represents method GetObject.

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
public
 function GetObject:TObject; override;

Return Value

Type: TObject

Overrides

TBIGridPlugin.GetObject
See Also

Reference

  • TBIFMXGridPlugin
  • FMXBI.Grid.Grid


TBIFMXGridPlugin.GetReadOnly Method

Summary

Represents method GetReadOnly.

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
protected
 function GetReadOnly:Boolean; override;

Return Value

Type: Boolean

Overrides

TBIGridPlugin.GetReadOnly
See Also

Reference

  • TBIFMXGridPlugin
  • FMXBI.Grid.Grid


TBIFMXGridPlugin.GetSortEnabled Method

Summary

Represents method GetSortEnabled.

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
protected
 function GetSortEnabled: Boolean; override;

Return Value

Type: Boolean

Overrides

TBIGridPlugin.GetSortEnabled
See Also

Reference

  • TBIFMXGridPlugin
  • FMXBI.Grid.Grid


TBIFMXGridPlugin.GetTotals Method

Summary

Represents method GetTotals.

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
protected
 function GetTotals:Boolean; override;

Return Value

Type: Boolean

Overrides

TBIGridPlugin.GetTotals
See Also

Reference

  • TBIFMXGridPlugin
  • FMXBI.Grid.Grid


TBIFMXGridPlugin.SetDataSource(TDataSource) Method

Summary

Represents method SetDataSource(TDataSource).

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
protected
 procedure SetDataSource(const Value: TDataSource); override;

Parameters

Value
Type: TDataSource

Overrides

TBIGridPlugin.SetDataSource(TDataSource)
See Also

Reference

  • TBIFMXGridPlugin
  • FMXBI.Grid.Grid


TBIFMXGridPlugin.SetOnRowChanged(TNotifyEvent) Method

Summary

Represents method SetOnRowChanged(TNotifyEvent).

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
protected
 procedure SetOnRowChanged(const AEvent:TNotifyEvent); override;

Parameters

AEvent
Type: TNotifyEvent

Overrides

TBIGridPlugin.SetOnRowChanged(TNotifyEvent)
See Also

Reference

  • TBIFMXGridPlugin
  • FMXBI.Grid.Grid


TBIFMXGridPlugin.SetPopup(TObject) Method

Summary

Represents method SetPopup(TObject).

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
protected
 procedure SetPopup(const Value:TObject); override;

Parameters

Value
Type: TObject

Overrides

TBIGridPlugin.SetPopup(TObject)
See Also

Reference

  • TBIFMXGridPlugin
  • FMXBI.Grid.Grid


TBIFMXGridPlugin.SetReadOnly(Boolean) Method

Summary

Represents method SetReadOnly(Boolean).

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
protected
 procedure SetReadOnly(const Value:Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBIGridPlugin.SetReadOnly(Boolean)
See Also

Reference

  • TBIFMXGridPlugin
  • FMXBI.Grid.Grid


TBIFMXGridPlugin.SetSortEnabled(Boolean) Method

Summary

Represents method SetSortEnabled(Boolean).

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
protected
 procedure SetSortEnabled(const Value: Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBIGridPlugin.SetSortEnabled(Boolean)
See Also

Reference

  • TBIFMXGridPlugin
  • FMXBI.Grid.Grid


TBIFMXGridPlugin.SetTotals(Boolean) Method

Summary

Represents method SetTotals(Boolean).

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
protected
 procedure SetTotals(const Value:Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBIGridPlugin.SetTotals(Boolean)
See Also

Reference

  • TBIFMXGridPlugin
  • FMXBI.Grid.Grid


TBindSourceDBAccess Class

Summary

Represents type TBindSourceDBAccess.

Namespace: FMXBI.Grid.Grid
Inheritance Hierarchy
TBindSourceDB
FMXBI.Grid.Grid.TBindSourceDBAccess
Syntax
Delphi
type
 TBindSourceDBAccess=class(TBindSourceDB);
See Also

Reference

  • FMXBI.Grid.Grid


TColumnAccess Class

Summary

Represents type TColumnAccess.

Namespace: FMXBI.Grid.Grid
Inheritance Hierarchy
TColumn
FMXBI.Grid.Grid.TColumnAccess
Syntax
Delphi
type
 TColumnAccess=class(TColumn);
See Also

Reference

  • FMXBI.Grid.Grid


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: FMXBI.Grid.Grid
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
FMXBI.Grid.Grid.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • FMXBI.Grid.Grid


FMXBI.Grid.Grid Routines

Routines
Name | Description
SwapRGB(TAlphaColor) | Represents method SwapRGB(TAlphaColor).
Top


SwapRGB(TAlphaColor) Method

Summary

Represents method SwapRGB(TAlphaColor).

Namespace: FMXBI.Grid.Grid
Syntax
Delphi
function SwapRGB(const AColor: TAlphaColor): Integer;

Parameters

AColor
Type: TAlphaColor

Return Value

Type: Integer

See Also

Reference

  • FMXBI.Grid.Grid


FMXBI.Grid.TeeGrid Namespace

Summary

Represents namespace FMXBI.Grid.TeeGrid.

Classes
Name | Description
TBITeeGrid | Represents type TBITeeGrid.
TBITeeGridPlugin | Represents type TBITeeGridPlugin.
Top


FMXBI.Grid.TeeGrid Classes

Classes
Name | Description
TBITeeGrid | Represents type TBITeeGrid.
TBITeeGridPlugin | Represents type TBITeeGridPlugin.
Top


TBITeeGrid Class

Summary

Represents type TBITeeGrid.

Namespace: FMXBI.Grid.TeeGrid
Inheritance Hierarchy
TTeeGrid
FMXBI.Grid.TeeGrid.TBITeeGrid
Syntax
Delphi
type
 TBITeeGrid=class(TTeeGrid)
 end;

The TBITeeGrid type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBITeeGrid class.
Top
See Also

Reference

  • FMXBI.Grid.TeeGrid


TBITeeGrid Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBITeeGrid class.
Top


TBITeeGrid.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBITeeGrid class.

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBITeeGrid
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin Class

Summary

Represents type TBITeeGridPlugin.

Namespace: FMXBI.Grid.TeeGrid
Inheritance Hierarchy
TObject
BI.Grid.Plugin.TBIGridPlugin
FMXBI.Grid.TeeGrid.TBITeeGridPlugin
Syntax
Delphi
type
 TBITeeGridPlugin=class(TBIGridPlugin)
 end;

The TBITeeGridPlugin type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBITeeGridPlugin class. (Overrides TBIGridPlugin.Create(TComponent).)
Top
Methods
Show:
Name | Description
AutoWidth | Represents method AutoWidth. (Overrides TBIGridPlugin.AutoWidth.)
BindTo(TDataSet) | Represents method BindTo(TDataSet). (Overrides TBIGridPlugin.BindTo(TDataSet).)
ChangedAlternate(TObject) | Represents method ChangedAlternate(TObject). (Overrides TBIGridPlugin.ChangedAlternate(TObject).)
Colorize(TDataColorizers) | Represents method Colorize(TDataColorizers). (Overrides TBIGridPlugin.Colorize(TDataColorizers).)
Duplicates(TDataItem,Boolean) | Represents method Duplicates(TDataItem,Boolean). (Overrides TBIGridPlugin.Duplicates(TDataItem,Boolean).)
GetCanSort | Represents method GetCanSort. (Overrides TBIGridPlugin.GetCanSort.)
GetControl | Represents method GetControl. (Overrides TBIGridPlugin.GetControl.)
GetDataSource | Represents method GetDataSource. (Overrides TBIGridPlugin.GetDataSource.)
GetEditorClass | Represents method GetEditorClass. (Overrides TBIGridPlugin.GetEditorClass.)
GetObject | Represents method GetObject. (Overrides TBIGridPlugin.GetObject.)
GetReadOnly | Represents method GetReadOnly. (Overrides TBIGridPlugin.GetReadOnly.)
GetSortEnabled | Represents method GetSortEnabled. (Overrides TBIGridPlugin.GetSortEnabled.)
GetTotals | Represents method GetTotals. (Overrides TBIGridPlugin.GetTotals.)
SetDataSource(TDataSource) | Represents method SetDataSource(TDataSource). (Overrides TBIGridPlugin.SetDataSource(TDataSource).)
SetFilters(Boolean) | Represents method SetFilters(Boolean). (Overrides TBIGridPlugin.SetFilters(Boolean).)
SetOnRowChanged(TNotifyEvent) | Represents method SetOnRowChanged(TNotifyEvent). (Overrides TBIGridPlugin.SetOnRowChanged(TNotifyEvent).)
SetPopup(TObject) | Represents method SetPopup(TObject). (Overrides TBIGridPlugin.SetPopup(TObject).)
SetReadOnly(Boolean) | Represents method SetReadOnly(Boolean). (Overrides TBIGridPlugin.SetReadOnly(Boolean).)
SetRowNumber(Boolean) | Represents method SetRowNumber(Boolean). (Overrides TBIGridPlugin.SetRowNumber(Boolean).)
SetSearch(Boolean) | Represents method SetSearch(Boolean). (Overrides TBIGridPlugin.SetSearch(Boolean).)
SetSortEnabled(Boolean) | Represents method SetSortEnabled(Boolean). (Overrides TBIGridPlugin.SetSortEnabled(Boolean).)
SetTotals(Boolean) | Represents method SetTotals(Boolean). (Overrides TBIGridPlugin.SetTotals(Boolean).)
Top
See Also

Reference

  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBITeeGridPlugin class. (Overrides TBIGridPlugin.Create(TComponent).)
Top


TBITeeGridPlugin.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBITeeGridPlugin class.

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TBIGridPlugin.Create(TComponent)
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin Methods

Methods
Name | Description
AutoWidth | Represents method AutoWidth. (Overrides TBIGridPlugin.AutoWidth.)
BindTo(TDataSet) | Represents method BindTo(TDataSet). (Overrides TBIGridPlugin.BindTo(TDataSet).)
ChangedAlternate(TObject) | Represents method ChangedAlternate(TObject). (Overrides TBIGridPlugin.ChangedAlternate(TObject).)
Colorize(TDataColorizers) | Represents method Colorize(TDataColorizers). (Overrides TBIGridPlugin.Colorize(TDataColorizers).)
Duplicates(TDataItem,Boolean) | Represents method Duplicates(TDataItem,Boolean). (Overrides TBIGridPlugin.Duplicates(TDataItem,Boolean).)
GetCanSort | Represents method GetCanSort. (Overrides TBIGridPlugin.GetCanSort.)
GetControl | Represents method GetControl. (Overrides TBIGridPlugin.GetControl.)
GetDataSource | Represents method GetDataSource. (Overrides TBIGridPlugin.GetDataSource.)
GetEditorClass | Represents method GetEditorClass. (Overrides TBIGridPlugin.GetEditorClass.)
GetObject | Represents method GetObject. (Overrides TBIGridPlugin.GetObject.)
GetReadOnly | Represents method GetReadOnly. (Overrides TBIGridPlugin.GetReadOnly.)
GetSortEnabled | Represents method GetSortEnabled. (Overrides TBIGridPlugin.GetSortEnabled.)
GetTotals | Represents method GetTotals. (Overrides TBIGridPlugin.GetTotals.)
SetDataSource(TDataSource) | Represents method SetDataSource(TDataSource). (Overrides TBIGridPlugin.SetDataSource(TDataSource).)
SetFilters(Boolean) | Represents method SetFilters(Boolean). (Overrides TBIGridPlugin.SetFilters(Boolean).)
SetOnRowChanged(TNotifyEvent) | Represents method SetOnRowChanged(TNotifyEvent). (Overrides TBIGridPlugin.SetOnRowChanged(TNotifyEvent).)
SetPopup(TObject) | Represents method SetPopup(TObject). (Overrides TBIGridPlugin.SetPopup(TObject).)
SetReadOnly(Boolean) | Represents method SetReadOnly(Boolean). (Overrides TBIGridPlugin.SetReadOnly(Boolean).)
SetRowNumber(Boolean) | Represents method SetRowNumber(Boolean). (Overrides TBIGridPlugin.SetRowNumber(Boolean).)
SetSearch(Boolean) | Represents method SetSearch(Boolean). (Overrides TBIGridPlugin.SetSearch(Boolean).)
SetSortEnabled(Boolean) | Represents method SetSortEnabled(Boolean). (Overrides TBIGridPlugin.SetSortEnabled(Boolean).)
SetTotals(Boolean) | Represents method SetTotals(Boolean). (Overrides TBIGridPlugin.SetTotals(Boolean).)
Top


TBITeeGridPlugin.AutoWidth Method

Summary

Represents method AutoWidth.

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure AutoWidth; override;

Overrides

TBIGridPlugin.AutoWidth
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin.BindTo(TDataSet) Method

Summary

Represents method BindTo(TDataSet).

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
public
 procedure BindTo(const ADataSet:TDataSet); override;

Parameters

ADataSet
Type: TDataSet

Overrides

TBIGridPlugin.BindTo(TDataSet)
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin.ChangedAlternate(TObject) Method

Summary

Represents method ChangedAlternate(TObject).

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure ChangedAlternate(Sender:TObject); override;

Parameters

Sender
Type: TObject

Overrides

TBIGridPlugin.ChangedAlternate(TObject)
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin.Colorize(TDataColorizers) Method

Summary

Represents method Colorize(TDataColorizers).

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
public
 procedure Colorize(const AItems:TDataColorizers); override;

Parameters

AItems
Type: TDataColorizers

Overrides

TBIGridPlugin.Colorize(TDataColorizers)
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin.Duplicates(TDataItem,Boolean) Method

Summary

Represents method Duplicates(TDataItem,Boolean).

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
public
 procedure Duplicates(const AData:TDataItem; const Hide:Boolean); override;

Parameters

AData
Type: TDataItem

Hide
Type: Boolean

Overrides

TBIGridPlugin.Duplicates(TDataItem,Boolean)
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin.GetCanSort Method

Summary

Represents method GetCanSort.

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
protected
 function GetCanSort: Boolean; override;

Return Value

Type: Boolean

Overrides

TBIGridPlugin.GetCanSort
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin.GetControl Method

Summary

Represents method GetControl.

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
public
 function GetControl:TObject; override;

Return Value

Type: TObject

Overrides

TBIGridPlugin.GetControl
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin.GetDataSource Method

Summary

Represents method GetDataSource.

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
protected
 function GetDataSource: TDataSource; override;

Return Value

Type: TDataSource

Overrides

TBIGridPlugin.GetDataSource
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin.GetEditorClass Method

Summary

Represents method GetEditorClass.

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
protected
 function GetEditorClass:String; override;

Return Value

Type: String

Overrides

TBIGridPlugin.GetEditorClass
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin.GetObject Method

Summary

Represents method GetObject.

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
public
 function GetObject:TObject; override;

Return Value

Type: TObject

Overrides

TBIGridPlugin.GetObject
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin.GetReadOnly Method

Summary

Represents method GetReadOnly.

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
protected
 function GetReadOnly:Boolean; override;

Return Value

Type: Boolean

Overrides

TBIGridPlugin.GetReadOnly
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin.GetSortEnabled Method

Summary

Represents method GetSortEnabled.

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
protected
 function GetSortEnabled: Boolean; override;

Return Value

Type: Boolean

Overrides

TBIGridPlugin.GetSortEnabled
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin.GetTotals Method

Summary

Represents method GetTotals.

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
protected
 function GetTotals:Boolean; override;

Return Value

Type: Boolean

Overrides

TBIGridPlugin.GetTotals
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin.SetDataSource(TDataSource) Method

Summary

Represents method SetDataSource(TDataSource).

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure SetDataSource(const Value: TDataSource); override;

Parameters

Value
Type: TDataSource

Overrides

TBIGridPlugin.SetDataSource(TDataSource)
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin.SetFilters(Boolean) Method

Summary

Represents method SetFilters(Boolean).

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure SetFilters(const Value:Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBIGridPlugin.SetFilters(Boolean)
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin.SetOnRowChanged(TNotifyEvent) Method

Summary

Represents method SetOnRowChanged(TNotifyEvent).

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure SetOnRowChanged(const AEvent:TNotifyEvent); override;

Parameters

AEvent
Type: TNotifyEvent

Overrides

TBIGridPlugin.SetOnRowChanged(TNotifyEvent)
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin.SetPopup(TObject) Method

Summary

Represents method SetPopup(TObject).

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure SetPopup(const Value:TObject); override;

Parameters

Value
Type: TObject

Overrides

TBIGridPlugin.SetPopup(TObject)
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin.SetReadOnly(Boolean) Method

Summary

Represents method SetReadOnly(Boolean).

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure SetReadOnly(const Value:Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBIGridPlugin.SetReadOnly(Boolean)
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin.SetRowNumber(Boolean) Method

Summary

Represents method SetRowNumber(Boolean).

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure SetRowNumber(const Value:Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBIGridPlugin.SetRowNumber(Boolean)
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin.SetSearch(Boolean) Method

Summary

Represents method SetSearch(Boolean).

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure SetSearch(const Value:Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBIGridPlugin.SetSearch(Boolean)
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin.SetSortEnabled(Boolean) Method

Summary

Represents method SetSortEnabled(Boolean).

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure SetSortEnabled(const Value: Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBIGridPlugin.SetSortEnabled(Boolean)
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


TBITeeGridPlugin.SetTotals(Boolean) Method

Summary

Represents method SetTotals(Boolean).

Namespace: FMXBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure SetTotals(const Value:Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBIGridPlugin.SetTotals(Boolean)
See Also

Reference

  • TBITeeGridPlugin
  • FMXBI.Grid.TeeGrid


FMXBI.Grid.TMS Namespace

Summary

Represents namespace FMXBI.Grid.TMS.

Classes
Name | Description
TBITMSGrid | Represents type TBITMSGrid.
TBITMSGridPlugin | Represents type TBITMSGridPlugin.
Top


FMXBI.Grid.TMS Classes

Classes
Name | Description
TBITMSGrid | Represents type TBITMSGrid.
TBITMSGridPlugin | Represents type TBITMSGridPlugin.
Top


TBITMSGrid Class

Summary

Represents type TBITMSGrid.

Namespace: FMXBI.Grid.TMS
Inheritance Hierarchy
TTMSFMXLiveGrid
FMXBI.Grid.TMS.TBITMSGrid
Syntax
Delphi
type
 TBITMSGrid=class(TTMSFMXLiveGrid)
 end;

The TBITMSGrid type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBITMSGrid class.
Destroy | Represents the destructor of the TBITMSGrid class.
Top
Fields
Show:
Name | Description
BindSource | Represents field BindSource.
Top
See Also

Reference

  • FMXBI.Grid.TMS


TBITMSGrid Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBITMSGrid class.
Destroy | Represents the destructor of the TBITMSGrid class.
Top


TBITMSGrid.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBITMSGrid class.

Namespace: FMXBI.Grid.TMS
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBITMSGrid
  • FMXBI.Grid.TMS


TBITMSGrid.Destroy Destructor

Summary

Represents the destructor of the TBITMSGrid class.

Namespace: FMXBI.Grid.TMS
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBITMSGrid
  • FMXBI.Grid.TMS


TBITMSGrid Fields

Fields
Name | Description
BindSource | Represents field BindSource.
Top


TBITMSGrid.BindSource Field

Summary

Represents field BindSource.

Namespace: FMXBI.Grid.TMS
Syntax
Delphi
protected
 BindSource : TBindSourceDB;

Field Value

Type: TBindSourceDB

See Also

Reference

  • TBITMSGrid
  • FMXBI.Grid.TMS


TBITMSGridPlugin Class

Summary

Represents type TBITMSGridPlugin.

Namespace: FMXBI.Grid.TMS
Inheritance Hierarchy
TBIGridPlugin
FMXBI.Grid.TMS.TBITMSGridPlugin
Syntax
Delphi
type
 TBITMSGridPlugin=class(TBIGridPlugin)
 end;

The TBITMSGridPlugin type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBITMSGridPlugin class.
Top
Methods
Show:
Name | Description
BindTo(TDataSet) | Represents method BindTo(TDataSet).
Colorize(TDataColorizers) | Represents method Colorize(TDataColorizers).
Duplicates(TDataItem,Boolean) | Represents method Duplicates(TDataItem,Boolean).
GetDataSource | Represents method GetDataSource.
GetObject | Represents method GetObject.
GetTotals | Represents method GetTotals.
SetDataSource(TDataSource) | Represents method SetDataSource(TDataSource).
SetTotals(Boolean) | Represents method SetTotals(Boolean).
Top
See Also

Reference

  • FMXBI.Grid.TMS


TBITMSGridPlugin Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBITMSGridPlugin class.
Top


TBITMSGridPlugin.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBITMSGridPlugin class.

Namespace: FMXBI.Grid.TMS
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBITMSGridPlugin
  • FMXBI.Grid.TMS


TBITMSGridPlugin Methods

Methods
Name | Description
BindTo(TDataSet) | Represents method BindTo(TDataSet).
Colorize(TDataColorizers) | Represents method Colorize(TDataColorizers).
Duplicates(TDataItem,Boolean) | Represents method Duplicates(TDataItem,Boolean).
GetDataSource | Represents method GetDataSource.
GetObject | Represents method GetObject.
GetTotals | Represents method GetTotals.
SetDataSource(TDataSource) | Represents method SetDataSource(TDataSource).
SetTotals(Boolean) | Represents method SetTotals(Boolean).
Top


TBITMSGridPlugin.BindTo(TDataSet) Method

Summary

Represents method BindTo(TDataSet).

Namespace: FMXBI.Grid.TMS
Syntax
Delphi
public
 procedure BindTo(const ADataSet:TDataSet); override;

Parameters

ADataSet
Type: TDataSet

See Also

Reference

  • TBITMSGridPlugin
  • FMXBI.Grid.TMS


TBITMSGridPlugin.Colorize(TDataColorizers) Method

Summary

Represents method Colorize(TDataColorizers).

Namespace: FMXBI.Grid.TMS
Syntax
Delphi
public
 procedure Colorize(const AItems:TDataColorizers); override;

Parameters

AItems
Type: TDataColorizers

See Also

Reference

  • TBITMSGridPlugin
  • FMXBI.Grid.TMS


TBITMSGridPlugin.Duplicates(TDataItem,Boolean) Method

Summary

Represents method Duplicates(TDataItem,Boolean).

Namespace: FMXBI.Grid.TMS
Syntax
Delphi
public
 procedure Duplicates(const AData:TDataItem; const Hide:Boolean); override;

Parameters

AData
Type: TDataItem

Hide
Type: Boolean

See Also

Reference

  • TBITMSGridPlugin
  • FMXBI.Grid.TMS


TBITMSGridPlugin.GetDataSource Method

Summary

Represents method GetDataSource.

Namespace: FMXBI.Grid.TMS
Syntax
Delphi
protected
 function GetDataSource: TDataSource; override;

Return Value

Type: TDataSource

See Also

Reference

  • TBITMSGridPlugin
  • FMXBI.Grid.TMS


TBITMSGridPlugin.GetObject Method

Summary

Represents method GetObject.

Namespace: FMXBI.Grid.TMS
Syntax
Delphi
public
 function GetObject:TObject; override;

Return Value

Type: TObject

See Also

Reference

  • TBITMSGridPlugin
  • FMXBI.Grid.TMS


TBITMSGridPlugin.GetTotals Method

Summary

Represents method GetTotals.

Namespace: FMXBI.Grid.TMS
Syntax
Delphi
protected
 function GetTotals:Boolean; override;

Return Value

Type: Boolean

See Also

Reference

  • TBITMSGridPlugin
  • FMXBI.Grid.TMS


TBITMSGridPlugin.SetDataSource(TDataSource) Method

Summary

Represents method SetDataSource(TDataSource).

Namespace: FMXBI.Grid.TMS
Syntax
Delphi
protected
 procedure SetDataSource(const Value: TDataSource); override;

Parameters

Value
Type: TDataSource

See Also

Reference

  • TBITMSGridPlugin
  • FMXBI.Grid.TMS


TBITMSGridPlugin.SetTotals(Boolean) Method

Summary

Represents method SetTotals(Boolean).

Namespace: FMXBI.Grid.TMS
Syntax
Delphi
protected
 procedure SetTotals(const Value:Boolean); override;

Parameters

Value
Type: Boolean

See Also

Reference

  • TBITMSGridPlugin
  • FMXBI.Grid.TMS


FMXBI.Grid.Woll Namespace

Summary

Represents namespace FMXBI.Grid.Woll.

Classes
Name | Description
TBIWollGrid | Represents type TBIWollGrid.
TBIWollGridPlugin | Represents type TBIWollGridPlugin.
Top


FMXBI.Grid.Woll Classes

Classes
Name | Description
TBIWollGrid | Represents type TBIWollGrid.
TBIWollGridPlugin | Represents type TBIWollGridPlugin.
Top


TBIWollGrid Class

Summary

Represents type TBIWollGrid.

Namespace: FMXBI.Grid.Woll
Inheritance Hierarchy
TwwDataGrid
FMXBI.Grid.Woll.TBIWollGrid
Syntax
Delphi
type
 TBIWollGrid=class(TwwDataGrid)
 end;

The TBIWollGrid type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIWollGrid class.
Top
See Also

Reference

  • FMXBI.Grid.Woll


TBIWollGrid Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBIWollGrid class.
Top


TBIWollGrid.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIWollGrid class.

Namespace: FMXBI.Grid.Woll
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBIWollGrid
  • FMXBI.Grid.Woll


TBIWollGridPlugin Class

Summary

Represents type TBIWollGridPlugin.

Namespace: FMXBI.Grid.Woll
Inheritance Hierarchy
TBIGridPlugin
FMXBI.Grid.Woll.TBIWollGridPlugin
Syntax
Delphi
type
 TBIWollGridPlugin=class(TBIGridPlugin)
 end;

The TBIWollGridPlugin type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIWollGridPlugin class.
Top
Methods
Show:
Name | Description
BindTo(TDataSet) | Represents method BindTo(TDataSet).
Duplicates(TDataItem,Boolean) | Represents method Duplicates(TDataItem,Boolean).
GetDataSource | Represents method GetDataSource.
GetObject | Represents method GetObject.
GetTotals | Represents method GetTotals.
SetDataSource(TDataSource) | Represents method SetDataSource(TDataSource).
SetTotals(Boolean) | Represents method SetTotals(Boolean).
Top
See Also

Reference

  • FMXBI.Grid.Woll


TBIWollGridPlugin Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBIWollGridPlugin class.
Top


TBIWollGridPlugin.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIWollGridPlugin class.

Namespace: FMXBI.Grid.Woll
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBIWollGridPlugin
  • FMXBI.Grid.Woll


TBIWollGridPlugin Methods

Methods
Name | Description
BindTo(TDataSet) | Represents method BindTo(TDataSet).
Duplicates(TDataItem,Boolean) | Represents method Duplicates(TDataItem,Boolean).
GetDataSource | Represents method GetDataSource.
GetObject | Represents method GetObject.
GetTotals | Represents method GetTotals.
SetDataSource(TDataSource) | Represents method SetDataSource(TDataSource).
SetTotals(Boolean) | Represents method SetTotals(Boolean).
Top


TBIWollGridPlugin.BindTo(TDataSet) Method

Summary

Represents method BindTo(TDataSet).

Namespace: FMXBI.Grid.Woll
Syntax
Delphi
public
 procedure BindTo(const ADataSet:TDataSet); override;

Parameters

ADataSet
Type: TDataSet

See Also

Reference

  • TBIWollGridPlugin
  • FMXBI.Grid.Woll


TBIWollGridPlugin.Duplicates(TDataItem,Boolean) Method

Summary

Represents method Duplicates(TDataItem,Boolean).

Namespace: FMXBI.Grid.Woll
Syntax
Delphi
public
 procedure Duplicates(const AData:TDataItem; const Hide:Boolean); override;

Parameters

AData
Type: TDataItem

Hide
Type: Boolean

See Also

Reference

  • TBIWollGridPlugin
  • FMXBI.Grid.Woll


TBIWollGridPlugin.GetDataSource Method

Summary

Represents method GetDataSource.

Namespace: FMXBI.Grid.Woll
Syntax
Delphi
protected
 function GetDataSource: TDataSource; override;

Return Value

Type: TDataSource

See Also

Reference

  • TBIWollGridPlugin
  • FMXBI.Grid.Woll


TBIWollGridPlugin.GetObject Method

Summary

Represents method GetObject.

Namespace: FMXBI.Grid.Woll
Syntax
Delphi
public
 function GetObject:TObject; override;

Return Value

Type: TObject

See Also

Reference

  • TBIWollGridPlugin
  • FMXBI.Grid.Woll


TBIWollGridPlugin.GetTotals Method

Summary

Represents method GetTotals.

Namespace: FMXBI.Grid.Woll
Syntax
Delphi
protected
 function GetTotals:Boolean; override;

Return Value

Type: Boolean

See Also

Reference

  • TBIWollGridPlugin
  • FMXBI.Grid.Woll


TBIWollGridPlugin.SetDataSource(TDataSource) Method

Summary

Represents method SetDataSource(TDataSource).

Namespace: FMXBI.Grid.Woll
Syntax
Delphi
protected
 procedure SetDataSource(const Value: TDataSource); override;

Parameters

Value
Type: TDataSource

See Also

Reference

  • TBIWollGridPlugin
  • FMXBI.Grid.Woll


TBIWollGridPlugin.SetTotals(Boolean) Method

Summary

Represents method SetTotals(Boolean).

Namespace: FMXBI.Grid.Woll
Syntax
Delphi
protected
 procedure SetTotals(const Value:Boolean); override;

Parameters

Value
Type: Boolean

See Also

Reference

  • TBIWollGridPlugin
  • FMXBI.Grid.Woll


FMXBI.GridForm Namespace

Summary

Represents namespace FMXBI.GridForm.

Classes
Name | Description
TBIGridForm | Represents type TBIGridForm.
TGridAccess | Represents type TGridAccess.
Top


FMXBI.GridForm Classes

Classes
Name | Description
TBIGridForm | Represents type TBIGridForm.
TGridAccess | Represents type TGridAccess.
Top


TBIGridForm Class

Summary

Represents type TBIGridForm.

Namespace: FMXBI.GridForm
Inheritance Hierarchy
TForm
FMXBI.GridForm.TBIGridForm
Syntax
Delphi
type
 TBIGridForm = class(TForm)
 end;

The TBIGridForm type exposes the following members.

Properties
Show:
Name | Description
OnDataChange | Represents property OnDataChange.
Top
Methods
Show:
Name | Description
Embedd(TComponent,TControl,TDataItem) | Represents method Embedd(TComponent,TControl,TDataItem).
FormCreate(TObject) | Represents method FormCreate(TObject).
MakeEditable | Represents method MakeEditable.
Present(TComponent,TDataItem) | Overloaded. Represents method Present(TComponent,TDataItem).
Top
Fields
Show:
Name | Description
BindNavigator1 | Represents field BindNavigator1.
Grid | Represents field Grid.
Layout1 | Represents field Layout1.
Layout2 | Represents field Layout2.
LRow | Represents field LRow.
Top
See Also

Reference

  • FMXBI.GridForm


TBIGridForm Properties

Properties
Name | Description
OnDataChange | Represents property OnDataChange.
Top


TBIGridForm.OnDataChange Property

Summary

Represents property OnDataChange.

Namespace: FMXBI.GridForm
Syntax
Delphi
public
 property OnDataChange:TNotifyEvent read FOnDataChange write FOnDataChange;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TBIGridForm
  • FMXBI.GridForm


TBIGridForm Methods

Methods
Name | Description
Embedd(TComponent,TControl,TDataItem) | Represents method Embedd(TComponent,TControl,TDataItem).
FormCreate(TObject) | Represents method FormCreate(TObject).
MakeEditable | Represents method MakeEditable.
Present(TComponent,TDataItem) | Overloaded. Represents method Present(TComponent,TDataItem).
Top


TBIGridForm.Embedd(TComponent,TControl,TDataItem) Method

Summary

Represents method Embedd(TComponent,TControl,TDataItem).

Namespace: FMXBI.GridForm
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TControl;
 const AData:TDataItem):TBIGridForm; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TControl

AData
Type: TDataItem

Return Value

Type: TBIGridForm

See Also

Reference

  • TBIGridForm
  • FMXBI.GridForm


TBIGridForm.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: FMXBI.GridForm
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIGridForm
  • FMXBI.GridForm


TBIGridForm.MakeEditable Method

Summary

Represents method MakeEditable.

Namespace: FMXBI.GridForm
Syntax
Delphi
public
 procedure MakeEditable;
See Also

Reference

  • TBIGridForm
  • FMXBI.GridForm


TBIGridForm.Present(TComponent,TDataItem) Method

Summary

Represents method Present(TComponent,TDataItem).

Namespace: FMXBI.GridForm
Syntax
Delphi
public
 class function Present(const AOwner:TComponent; const AData:TDataItem):TModalResult; overload;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

Return Value

Type: TModalResult

See Also

Reference

  • TBIGridForm
  • FMXBI.GridForm


TBIGridForm Fields

Fields
Name | Description
BindNavigator1 | Represents field BindNavigator1.
Grid | Represents field Grid.
Layout1 | Represents field Layout1.
Layout2 | Represents field Layout2.
LRow | Represents field LRow.
Top


TBIGridForm.BindNavigator1 Field

Summary

Represents field BindNavigator1.

Namespace: FMXBI.GridForm
Syntax
Delphi
published
 BindNavigator1: TBindNavigator;

Field Value

Type: TBindNavigator

See Also

Reference

  • TBIGridForm
  • FMXBI.GridForm


TBIGridForm.Grid Field

Summary

Represents field Grid.

Namespace: FMXBI.GridForm
Syntax
Delphi
public
 Grid : TBIGrid;

Field Value

Type: TBIGrid

See Also

Reference

  • TBIGridForm
  • FMXBI.GridForm


TBIGridForm.Layout1 Field

Summary

Represents field Layout1.

Namespace: FMXBI.GridForm
Syntax
Delphi
published
 Layout1: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TBIGridForm
  • FMXBI.GridForm


TBIGridForm.Layout2 Field

Summary

Represents field Layout2.

Namespace: FMXBI.GridForm
Syntax
Delphi
published
 Layout2: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TBIGridForm
  • FMXBI.GridForm


TBIGridForm.LRow Field

Summary

Represents field LRow.

Namespace: FMXBI.GridForm
Syntax
Delphi
published
 LRow: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIGridForm
  • FMXBI.GridForm


TGridAccess Class

Summary

Represents type TGridAccess.

Namespace: FMXBI.GridForm
Inheritance Hierarchy
TObject
FMXBI.Grid.Grid.TBIFMXGrid
FMXBI.GridForm.TGridAccess
Syntax
Delphi
type
 TGridAccess=class(TBIFMXGrid);
See Also

Reference

  • FMXBI.GridForm


FMXBI.PDF Namespace

Summary

Represents namespace FMXBI.PDF.

Classes
Name | Description
TBIPDFExport | Represents type TBIPDFExport.
TFormat | Represents type TFormat.
TGridLines | Represents type TGridLines.
THeader | Represents type THeader.
TPage | Represents type TPage.
TPageNumbering | Represents type TPageNumbering.
TRowFormat | Represents type TRowFormat.
TTitle | Represents type TTitle.
Top
Enumerations
Name | Description
TAlignment | Represents type TAlignment.
THeaderPosition | Represents type THeaderPosition.
Top
Types
Name | Description
TCoordinate | Represents an alias of the Single type.
Top
Constants
Name | Description
BeigeColor | Represents constant BeigeColor.
SilverColor | Represents constant SilverColor.
TA_CENTER | Represents constant TA_CENTER.
TA_LEFT | Represents constant TA_LEFT.
TA_RIGHT | Represents constant TA_RIGHT.
Top


FMXBI.PDF Classes

Classes
Name | Description
TBIPDFExport | Represents type TBIPDFExport.
TFormat | Represents type TFormat.
TGridLines | Represents type TGridLines.
THeader | Represents type THeader.
TPage | Represents type TPage.
TPageNumbering | Represents type TPageNumbering.
TRowFormat | Represents type TRowFormat.
TTitle | Represents type TTitle.
Top


TBIPDFExport Class

Summary

Represents type TBIPDFExport.

Namespace: FMXBI.PDF
Inheritance Hierarchy
TObject
BI.DataSource.TBIExport
BI.DataSource.TBITextExport
FMXBI.PDF.TBIPDFExport
Syntax
Delphi
type
 TBIPDFExport=class(TBITextExport)
 end;

The TBIPDFExport type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TBIPDFExport class. (Overrides TBIExport.Create.)
Destroy | Represents the destructor of the TBIPDFExport class. (Overrides TBIExport.Destroy.)
Top
Properties
Show:
Name | Description
Alignment | Represents property Alignment.
AutoWidth | Represents property AutoWidth.
Footer | Represents property Footer.
GridLines | Represents property GridLines.
Header | Represents property Header.
Page | Represents property Page.
RowFormat | Represents property RowFormat.
Title | Represents property Title.
Top
Methods
Show:
Name | Description
DoEmit(TStrings) | Represents method DoEmit(TStrings). (Overrides TBIExport.DoEmit(TStrings).)
Supports(String) | Represents method Supports(String). (Overrides TBIExport.Supports(String).)
Top
See Also

Reference

  • FMXBI.PDF


TBIPDFExport Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TBIPDFExport class. (Overrides TBIExport.Create.)
Destroy | Represents the destructor of the TBIPDFExport class. (Overrides TBIExport.Destroy.)
Top


TBIPDFExport.Create Constructor

Summary

Initializes a new instance of the TBIPDFExport class.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 Constructor Create; override;

Overrides

TBIExport.Create
See Also

Reference

  • TBIPDFExport
  • FMXBI.PDF


TBIPDFExport.Destroy Destructor

Summary

Represents the destructor of the TBIPDFExport class.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TBIExport.Destroy
See Also

Reference

  • TBIPDFExport
  • FMXBI.PDF


TBIPDFExport Properties

Properties
Name | Description
Alignment | Represents property Alignment.
AutoWidth | Represents property AutoWidth.
Footer | Represents property Footer.
GridLines | Represents property GridLines.
Header | Represents property Header.
Page | Represents property Page.
RowFormat | Represents property RowFormat.
Title | Represents property Title.
Top


TBIPDFExport.Alignment Property

Summary

Represents property Alignment.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 property Alignment:TAlignment read FAlignment write FAlignment default TAlignment.Center;

Property Value

Type: TAlignment

See Also

Reference

  • TBIPDFExport
  • FMXBI.PDF


TBIPDFExport.AutoWidth Property

Summary

Represents property AutoWidth.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 property AutoWidth:Boolean read FAutoWidth write FAutoWidth default True;

Property Value

Type: Boolean

See Also

Reference

  • TBIPDFExport
  • FMXBI.PDF


TBIPDFExport.Footer Property

Summary

Represents property Footer.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 property Footer:TTitle read FFooter;

Property Value

Type: TTitle

See Also

Reference

  • TBIPDFExport
  • FMXBI.PDF


TBIPDFExport.GridLines Property

Summary

Represents property GridLines.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 property GridLines:TGridLines read FGridLines write SetGridLines;

Property Value

Type: TGridLines

See Also

Reference

  • TBIPDFExport
  • FMXBI.PDF


TBIPDFExport.Header Property

Summary

Represents property Header.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 property Header:THeader read FHeader;

Property Value

Type: THeader

See Also

Reference

  • TBIPDFExport
  • FMXBI.PDF


TBIPDFExport.Page Property

Summary

Represents property Page.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 property Page:TPage read FPage;

Property Value

Type: TPage

See Also

Reference

  • TBIPDFExport
  • FMXBI.PDF


TBIPDFExport.RowFormat Property

Summary

Represents property RowFormat.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 property RowFormat:TRowFormat read FRowFormat;

Property Value

Type: TRowFormat

See Also

Reference

  • TBIPDFExport
  • FMXBI.PDF


TBIPDFExport.Title Property

Summary

Represents property Title.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 property Title:TTitle read FTitle;

Property Value

Type: TTitle

See Also

Reference

  • TBIPDFExport
  • FMXBI.PDF


TBIPDFExport Methods

Methods
Name | Description
DoEmit(TStrings) | Represents method DoEmit(TStrings). (Overrides TBIExport.DoEmit(TStrings).)
Supports(String) | Represents method Supports(String). (Overrides TBIExport.Supports(String).)
Top


TBIPDFExport.DoEmit(TStrings) Method

Summary

Represents method DoEmit(TStrings).

Namespace: FMXBI.PDF
Syntax
Delphi
protected
 procedure DoEmit(const AItems: TStrings); override;

Parameters

AItems
Type: TStrings

Overrides

TBIExport.DoEmit(TStrings)
See Also

Reference

  • TBIPDFExport
  • FMXBI.PDF


TBIPDFExport.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: FMXBI.PDF
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIExport.Supports(String)
See Also

Reference

  • TBIPDFExport
  • FMXBI.PDF


TFormat Class

Summary

Represents type TFormat.

Namespace: FMXBI.PDF
Inheritance Hierarchy
TPersistent
FMXBI.PDF.TFormat
FMXBI.PDF.THeader
FMXBI.PDF.TRowFormat
Syntax
Delphi
type
 TFormat=class(TPersistent)
 end;

The TFormat type exposes the following members.

Constructors
Show:
Name | Description
Create(TBIPDFExport) | Initializes a new instance of the TFormat class.
Destroy | Represents the destructor of the TFormat class.
Top
Properties
Show:
Name | Description
Brush | Represents property Brush.
Font | Represents property Font.
Visible | Represents property Visible.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
See Also

Reference

  • FMXBI.PDF


TFormat Constructors

Constructors
Name | Description
Create(TBIPDFExport) | Initializes a new instance of the TFormat class.
Destroy | Represents the destructor of the TFormat class.
Top


TFormat.Create(TBIPDFExport) Constructor

Summary

Initializes a new instance of the TFormat class.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 Constructor Create(const AParent:TBIPDFExport); virtual;

Parameters

AParent
Type: TBIPDFExport

See Also

Reference

  • TFormat
  • FMXBI.PDF


TFormat.Destroy Destructor

Summary

Represents the destructor of the TFormat class.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TFormat
  • FMXBI.PDF


TFormat Properties

Properties
Name | Description
Brush | Represents property Brush.
Font | Represents property Font.
Visible | Represents property Visible.
Top


TFormat.Brush Property

Summary

Represents property Brush.

Namespace: FMXBI.PDF
Syntax
Delphi
published
 property Brush:TTeeBrush read FBrush write SetBrush;

Property Value

Type: TTeeBrush

See Also

Reference

  • TFormat
  • FMXBI.PDF


TFormat.Font Property

Summary

Represents property Font.

Namespace: FMXBI.PDF
Syntax
Delphi
published
 property Font:TTeeFont read FFont write SetFont;

Property Value

Type: TTeeFont

See Also

Reference

  • TFormat
  • FMXBI.PDF


TFormat.Visible Property

Summary

Represents property Visible.

Namespace: FMXBI.PDF
Syntax
Delphi
published
 property Visible:Boolean read FVisible write FVisible default True;

Property Value

Type: Boolean

See Also

Reference

  • TFormat
  • FMXBI.PDF


TFormat Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TFormat.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: FMXBI.PDF
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TFormat
  • FMXBI.PDF


TGridLines Class

Summary

Represents type TGridLines.

Namespace: FMXBI.PDF
Inheritance Hierarchy
TPersistent
FMXBI.PDF.TGridLines
Syntax
Delphi
type
 TGridLines=class(TPersistent)
 end;

The TGridLines type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TGridLines class.
Destroy | Represents the destructor of the TGridLines class.
Top
Properties
Show:
Name | Description
Horizontal | Represents property Horizontal.
Vertical | Represents property Vertical.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
See Also

Reference

  • FMXBI.PDF


TGridLines Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TGridLines class.
Destroy | Represents the destructor of the TGridLines class.
Top


TGridLines.Create Constructor

Summary

Initializes a new instance of the TGridLines class.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 Constructor Create;
See Also

Reference

  • TGridLines
  • FMXBI.PDF


TGridLines.Destroy Destructor

Summary

Represents the destructor of the TGridLines class.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TGridLines
  • FMXBI.PDF


TGridLines Properties

Properties
Name | Description
Horizontal | Represents property Horizontal.
Vertical | Represents property Vertical.
Top


TGridLines.Horizontal Property

Summary

Represents property Horizontal.

Namespace: FMXBI.PDF
Syntax
Delphi
published
 property Horizontal:TTeePen read FHorizontal write SetHorizontal;

Property Value

Type: TTeePen

See Also

Reference

  • TGridLines
  • FMXBI.PDF


TGridLines.Vertical Property

Summary

Represents property Vertical.

Namespace: FMXBI.PDF
Syntax
Delphi
published
 property Vertical:TTeePen read FVertical write SetVertical;

Property Value

Type: TTeePen

See Also

Reference

  • TGridLines
  • FMXBI.PDF


TGridLines Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TGridLines.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: FMXBI.PDF
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TGridLines
  • FMXBI.PDF


THeader Class

Summary

Represents type THeader.

Namespace: FMXBI.PDF
Inheritance Hierarchy
TPersistent
FMXBI.PDF.TFormat
FMXBI.PDF.THeader
FMXBI.PDF.TTitle
Syntax
Delphi
type
 THeader=class(TFormat)
 end;

The THeader type exposes the following members.

Constructors
Show:
Name | Description
Create(TBIPDFExport) | Initializes a new instance of the THeader class. (Overrides TFormat.Create(TBIPDFExport).)
Top
Properties
Show:
Name | Description
Position | Represents property Position.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TFormat.Assign(TPersistent).)
Top
See Also

Reference

  • FMXBI.PDF


THeader Constructors

Constructors
Name | Description
Create(TBIPDFExport) | Initializes a new instance of the THeader class. (Overrides TFormat.Create(TBIPDFExport).)
Top


THeader.Create(TBIPDFExport) Constructor

Summary

Initializes a new instance of the THeader class.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 Constructor Create(const AParent:TBIPDFExport); override;

Parameters

AParent
Type: TBIPDFExport

Overrides

TFormat.Create(TBIPDFExport)
See Also

Reference

  • THeader
  • FMXBI.PDF


THeader Properties

Properties
Name | Description
Position | Represents property Position.
Top


THeader.Position Property

Summary

Represents property Position.

Namespace: FMXBI.PDF
Syntax
Delphi
published
 property Position:THeaderPosition read FPosition write FPosition default AllPages;

Property Value

Type: THeaderPosition

See Also

Reference

  • THeader
  • FMXBI.PDF


THeader Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TFormat.Assign(TPersistent).)
Top


THeader.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: FMXBI.PDF
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TFormat.Assign(TPersistent)
See Also

Reference

  • THeader
  • FMXBI.PDF


TPage Class

Summary

Represents type TPage.

Namespace: FMXBI.PDF
Inheritance Hierarchy
TPersistent
FMXBI.PDF.TPage
Syntax
Delphi
type
 TPage=class(TPersistent)
 end;

The TPage type exposes the following members.

Constructors
Show:
Name | Description
Create(TBIPDFExport) | Initializes a new instance of the TPage class.
Destroy | Represents the destructor of the TPage class.
Top
Properties
Show:
Name | Description
Current | Represents property Current.
CustomHeight | Represents property CustomHeight.
CustomWidth | Represents property CustomWidth.
Numbering | Represents property Numbering.
Orientation | Represents property Orientation.
Size | Represents property Size.
Total | Represents property Total.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
See Also

Reference

  • FMXBI.PDF


TPage Constructors

Constructors
Name | Description
Create(TBIPDFExport) | Initializes a new instance of the TPage class.
Destroy | Represents the destructor of the TPage class.
Top


TPage.Create(TBIPDFExport) Constructor

Summary

Initializes a new instance of the TPage class.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 Constructor Create(const AParent:TBIPDFExport);

Parameters

AParent
Type: TBIPDFExport

See Also

Reference

  • TPage
  • FMXBI.PDF


TPage.Destroy Destructor

Summary

Represents the destructor of the TPage class.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TPage
  • FMXBI.PDF


TPage Properties

Properties
Name | Description
Current | Represents property Current.
CustomHeight | Represents property CustomHeight.
CustomWidth | Represents property CustomWidth.
Numbering | Represents property Numbering.
Orientation | Represents property Orientation.
Size | Represents property Size.
Total | Represents property Total.
Top


TPage.Current Property

Summary

Represents property Current.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 property Current:Integer read FCurrent;

Property Value

Type: Integer

See Also

Reference

  • TPage
  • FMXBI.PDF


TPage.CustomHeight Property

Summary

Represents property CustomHeight.

Namespace: FMXBI.PDF
Syntax
Delphi
published
 property CustomHeight:Integer read FCustomHeight write FCustomHeight default 0;

Property Value

Type: Integer

See Also

Reference

  • TPage
  • FMXBI.PDF


TPage.CustomWidth Property

Summary

Represents property CustomWidth.

Namespace: FMXBI.PDF
Syntax
Delphi
published
 property CustomWidth:Integer read FCustomWidth write FCustomWidth default 0;

Property Value

Type: Integer

See Also

Reference

  • TPage
  • FMXBI.PDF


TPage.Numbering Property

Summary

Represents property Numbering.

Namespace: FMXBI.PDF
Syntax
Delphi
published
 property Numbering:TPageNumbering read FNumbering write SetNumbering;

Property Value

Type: TPageNumbering

See Also

Reference

  • TPage
  • FMXBI.PDF


TPage.Orientation Property

Summary

Represents property Orientation.

Namespace: FMXBI.PDF
Syntax
Delphi
published
 property Orientation:TPDFPageOrientation read FOrientation write FOrientation default TPDFPageOrientation.poPortrait;

Property Value

Type: TPDFPageOrientation

See Also

Reference

  • TPage
  • FMXBI.PDF


TPage.Size Property

Summary

Represents property Size.

Namespace: FMXBI.PDF
Syntax
Delphi
published
 property Size:TPDFPageSize read FSize write FSize default TPDFPageSize.psDefault;

Property Value

Type: TPDFPageSize

See Also

Reference

  • TPage
  • FMXBI.PDF


TPage.Total Property

Summary

Represents property Total.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 property Total:Integer read FTotal;

Property Value

Type: Integer

See Also

Reference

  • TPage
  • FMXBI.PDF


TPage Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TPage.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: FMXBI.PDF
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TPage
  • FMXBI.PDF


TPageNumbering Class

Summary

Represents type TPageNumbering.

Namespace: FMXBI.PDF
Inheritance Hierarchy
TPersistent
FMXBI.PDF.TFormat
FMXBI.PDF.THeader
FMXBI.PDF.TTitle
FMXBI.PDF.TPageNumbering
Syntax
Delphi
type
 TPageNumbering=class(TTitle)
 end;

The TPageNumbering type exposes the following members.

Constructors
Show:
Name | Description
Create(TBIPDFExport) | Initializes a new instance of the TPageNumbering class. (Overrides TTitle.Create(TBIPDFExport).)
Top
Properties
Show:
Name | Description
Alignment | Represents property Alignment.
Expression | Represents property Expression.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TTitle.Assign(TPersistent).)
Top
See Also

Reference

  • FMXBI.PDF


TPageNumbering Constructors

Constructors
Name | Description
Create(TBIPDFExport) | Initializes a new instance of the TPageNumbering class. (Overrides TTitle.Create(TBIPDFExport).)
Top


TPageNumbering.Create(TBIPDFExport) Constructor

Summary

Initializes a new instance of the TPageNumbering class.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 Constructor Create(const AParent:TBIPDFExport); override;

Parameters

AParent
Type: TBIPDFExport

Overrides

TTitle.Create(TBIPDFExport)
See Also

Reference

  • TPageNumbering
  • FMXBI.PDF


TPageNumbering Properties

Properties
Name | Description
Alignment | Represents property Alignment.
Expression | Represents property Expression.
Top


TPageNumbering.Alignment Property

Summary

Represents property Alignment.

Namespace: FMXBI.PDF
Syntax
Delphi
published
 property Alignment default TAlignment.Right;

Property Value

Type: Void

See Also

Reference

  • TPageNumbering
  • FMXBI.PDF


TPageNumbering.Expression Property

Summary

Represents property Expression.

Namespace: FMXBI.PDF
Syntax
Delphi
published
 property Expression:String read FExpression write FExpression;

Property Value

Type: String

See Also

Reference

  • TPageNumbering
  • FMXBI.PDF


TPageNumbering Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TTitle.Assign(TPersistent).)
Top


TPageNumbering.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: FMXBI.PDF
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TTitle.Assign(TPersistent)
See Also

Reference

  • TPageNumbering
  • FMXBI.PDF


TRowFormat Class

Summary

Represents type TRowFormat.

Namespace: FMXBI.PDF
Inheritance Hierarchy
TPersistent
FMXBI.PDF.TFormat
FMXBI.PDF.TRowFormat
Syntax
Delphi
type
 TRowFormat=class(TFormat)
 end;

The TRowFormat type exposes the following members.

Constructors
Show:
Name | Description
Create(TBIPDFExport) | Initializes a new instance of the TRowFormat class. (Overrides TFormat.Create(TBIPDFExport).)
Destroy | Represents the destructor of the TRowFormat class. (Overrides TFormat.Destroy.)
Top
Properties
Show:
Name | Description
Alternate | Represents property Alternate.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TFormat.Assign(TPersistent).)
Top
See Also

Reference

  • FMXBI.PDF


TRowFormat Constructors

Constructors
Name | Description
Create(TBIPDFExport) | Initializes a new instance of the TRowFormat class. (Overrides TFormat.Create(TBIPDFExport).)
Destroy | Represents the destructor of the TRowFormat class. (Overrides TFormat.Destroy.)
Top


TRowFormat.Create(TBIPDFExport) Constructor

Summary

Initializes a new instance of the TRowFormat class.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 Constructor Create(const AParent:TBIPDFExport); override;

Parameters

AParent
Type: TBIPDFExport

Overrides

TFormat.Create(TBIPDFExport)
See Also

Reference

  • TRowFormat
  • FMXBI.PDF


TRowFormat.Destroy Destructor

Summary

Represents the destructor of the TRowFormat class.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TFormat.Destroy
See Also

Reference

  • TRowFormat
  • FMXBI.PDF


TRowFormat Properties

Properties
Name | Description
Alternate | Represents property Alternate.
Top


TRowFormat.Alternate Property

Summary

Represents property Alternate.

Namespace: FMXBI.PDF
Syntax
Delphi
published
 property Alternate:TFormat read FAlternate write SetAlternate;

Property Value

Type: TFormat

See Also

Reference

  • TRowFormat
  • FMXBI.PDF


TRowFormat Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TFormat.Assign(TPersistent).)
Top


TRowFormat.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: FMXBI.PDF
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TFormat.Assign(TPersistent)
See Also

Reference

  • TRowFormat
  • FMXBI.PDF


TTitle Class

Summary

Represents type TTitle.

Namespace: FMXBI.PDF
Inheritance Hierarchy
TPersistent
FMXBI.PDF.TFormat
FMXBI.PDF.THeader
FMXBI.PDF.TTitle
FMXBI.PDF.TPageNumbering
Syntax
Delphi
type
 TTitle=class(THeader)
 end;

The TTitle type exposes the following members.

Constructors
Show:
Name | Description
Create(TBIPDFExport) | Initializes a new instance of the TTitle class. (Overrides THeader.Create(TBIPDFExport).)
Destroy | Represents the destructor of the TTitle class. (Overrides TFormat.Destroy.)
Top
Properties
Show:
Name | Description
Alignment | Represents property Alignment.
Height | Represents property Height.
Text | Represents property Text.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides THeader.Assign(TPersistent).)
Top
See Also

Reference

  • FMXBI.PDF


TTitle Constructors

Constructors
Name | Description
Create(TBIPDFExport) | Initializes a new instance of the TTitle class. (Overrides THeader.Create(TBIPDFExport).)
Destroy | Represents the destructor of the TTitle class. (Overrides TFormat.Destroy.)
Top


TTitle.Create(TBIPDFExport) Constructor

Summary

Initializes a new instance of the TTitle class.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 Constructor Create(const AParent:TBIPDFExport); override;

Parameters

AParent
Type: TBIPDFExport

Overrides

THeader.Create(TBIPDFExport)
See Also

Reference

  • TTitle
  • FMXBI.PDF


TTitle.Destroy Destructor

Summary

Represents the destructor of the TTitle class.

Namespace: FMXBI.PDF
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TFormat.Destroy
See Also

Reference

  • TTitle
  • FMXBI.PDF


TTitle Properties

Properties
Name | Description
Alignment | Represents property Alignment.
Height | Represents property Height.
Text | Represents property Text.
Top


TTitle.Alignment Property

Summary

Represents property Alignment.

Namespace: FMXBI.PDF
Syntax
Delphi
published
 property Alignment:TAlignment read FAlign write FAlign default TAlignment.Center;

Property Value

Type: TAlignment

See Also

Reference

  • TTitle
  • FMXBI.PDF


TTitle.Height Property

Summary

Represents property Height.

Namespace: FMXBI.PDF
Syntax
Delphi
published
 property Height:TCoordinate read FHeight;

Property Value

Type: TCoordinate

See Also

Reference

  • TTitle
  • FMXBI.PDF


TTitle.Text Property

Summary

Represents property Text.

Namespace: FMXBI.PDF
Syntax
Delphi
published
 property Text:TStrings read FText write SetText;

Property Value

Type: TStrings

See Also

Reference

  • TTitle
  • FMXBI.PDF


TTitle Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides THeader.Assign(TPersistent).)
Top


TTitle.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: FMXBI.PDF
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

THeader.Assign(TPersistent)
See Also

Reference

  • TTitle
  • FMXBI.PDF


FMXBI.PDF Enumerations

Enumerations
Name | Description
TAlignment | Represents type TAlignment.
THeaderPosition | Represents type THeaderPosition.
Top


TAlignment Enumeration

Summary

Represents type TAlignment.

Namespace: FMXBI.PDF
Syntax
Delphi
type
 TAlignment=(Left,Center,Right);

The TAlignment type exposes the following members.

Members
Show:
Name | Description
Center | Represents constant Center.
Left | Represents constant Left.
Right | Represents constant Right.
Top
See Also

Reference

  • FMXBI.PDF


THeaderPosition Enumeration

Summary

Represents type THeaderPosition.

Namespace: FMXBI.PDF
Syntax
Delphi
type
 THeaderPosition=(AllPages, FirstPage);

The THeaderPosition type exposes the following members.

Members
Show:
Name | Description
AllPages | Represents constant AllPages.
FirstPage | Represents constant FirstPage.
Top
See Also

Reference

  • FMXBI.PDF


FMXBI.PDF Types

Types
Name | Description
TCoordinate | Represents an alias of the Single type.
Top


TCoordinate Type

Summary

Represents an alias of the Single type.

Namespace: FMXBI.PDF
Syntax
Delphi
type
 TCoordinate=Single;
See Also

Reference

  • FMXBI.PDF


FMXBI.PDF Constants

Constants
Name | Description
BeigeColor | Represents constant BeigeColor.
SilverColor | Represents constant SilverColor.
TA_CENTER | Represents constant TA_CENTER.
TA_LEFT | Represents constant TA_LEFT.
TA_RIGHT | Represents constant TA_RIGHT.
Top


BeigeColor Constant

Summary

Represents constant BeigeColor.

Namespace: FMXBI.PDF
Syntax
Delphi
 BeigeColor=TAlphaColors.Beige;

Value

Type: Void

See Also

Reference

  • FMXBI.PDF


SilverColor Constant

Summary

Represents constant SilverColor.

Namespace: FMXBI.PDF
Syntax
Delphi
 SilverColor=TAlphaColors.Silver;

Value

Type: Void

See Also

Reference

  • FMXBI.PDF


TA_CENTER Constant

Summary

Represents constant TA_CENTER.

Namespace: FMXBI.PDF
Syntax
Delphi
 TA_CENTER = 6;

Value

Type: ShortInt

See Also

Reference

  • FMXBI.PDF


TA_LEFT Constant

Summary

Represents constant TA_LEFT.

Namespace: FMXBI.PDF
Syntax
Delphi
 TA_LEFT = 0;

Value

Type: ShortInt

See Also

Reference

  • FMXBI.PDF


TA_RIGHT Constant

Summary

Represents constant TA_RIGHT.

Namespace: FMXBI.PDF
Syntax
Delphi
 TA_RIGHT = 2;

Value

Type: ShortInt

See Also

Reference

  • FMXBI.PDF


FMXBI.R.Console Namespace

Summary

Represents namespace FMXBI.R.Console.

Classes
Name | Description
TBIRConsole | Represents type TBIRConsole.
Top


FMXBI.R.Console Classes

Classes
Name | Description
TBIRConsole | Represents type TBIRConsole.
Top


TBIRConsole Class

Summary

Represents type TBIRConsole.

Namespace: FMXBI.R.Console
Inheritance Hierarchy
TForm
FMXBI.R.Console.TBIRConsole
Syntax
Delphi
type
 TBIRConsole = class(TForm)
 end;

The TBIRConsole type exposes the following members.

Methods
Show:
Name | Description
Add(TStrings) | Represents method Add(TStrings).
BGoClick(TObject) | Represents method BGoClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
EStatementChangeTracking(TObject) | Represents method EStatementChangeTracking(TObject).
EStatementKeyUp(TObject,Word,Char,TShiftState) | Represents method EStatementKeyUp(TObject,Word,Char,TShiftState).
Top
Fields
Show:
Name | Description
BGo | Represents field BGo.
Button1 | Represents field Button1.
EStatement | Represents field EStatement.
Layout1 | Represents field Layout1.
Layout2 | Represents field Layout2.
Layout3 | Represents field Layout3.
Memo | Represents field Memo.
Top
See Also

Reference

  • FMXBI.R.Console


TBIRConsole Methods

Methods
Name | Description
Add(TStrings) | Represents method Add(TStrings).
BGoClick(TObject) | Represents method BGoClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
EStatementChangeTracking(TObject) | Represents method EStatementChangeTracking(TObject).
EStatementKeyUp(TObject,Word,Char,TShiftState) | Represents method EStatementKeyUp(TObject,Word,Char,TShiftState).
Top


TBIRConsole.Add(TStrings) Method

Summary

Represents method Add(TStrings).

Namespace: FMXBI.R.Console
Syntax
Delphi
public
 procedure Add(const Value: TStrings);

Parameters

Value
Type: TStrings

See Also

Reference

  • TBIRConsole
  • FMXBI.R.Console


TBIRConsole.BGoClick(TObject) Method

Summary

Represents method BGoClick(TObject).

Namespace: FMXBI.R.Console
Syntax
Delphi
published
 procedure BGoClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIRConsole
  • FMXBI.R.Console


TBIRConsole.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: FMXBI.R.Console
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIRConsole
  • FMXBI.R.Console


TBIRConsole.EStatementChangeTracking(TObject) Method

Summary

Represents method EStatementChangeTracking(TObject).

Namespace: FMXBI.R.Console
Syntax
Delphi
published
 procedure EStatementChangeTracking(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIRConsole
  • FMXBI.R.Console


TBIRConsole.EStatementKeyUp(TObject,Word,Char,TShiftState) Method

Summary

Represents method EStatementKeyUp(TObject,Word,Char,TShiftState).

Namespace: FMXBI.R.Console
Syntax
Delphi
published
 procedure EStatementKeyUp(Sender: TObject; var Key: Word; var KeyChar: Char;
 Shift: TShiftState);

Parameters

Sender
Type: TObject

Key
Type: Word

KeyChar
Type: Char

Shift
Type: TShiftState

See Also

Reference

  • TBIRConsole
  • FMXBI.R.Console


TBIRConsole Fields

Fields
Name | Description
BGo | Represents field BGo.
Button1 | Represents field Button1.
EStatement | Represents field EStatement.
Layout1 | Represents field Layout1.
Layout2 | Represents field Layout2.
Layout3 | Represents field Layout3.
Memo | Represents field Memo.
Top


TBIRConsole.BGo Field

Summary

Represents field BGo.

Namespace: FMXBI.R.Console
Syntax
Delphi
published
 BGo: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIRConsole
  • FMXBI.R.Console


TBIRConsole.Button1 Field

Summary

Represents field Button1.

Namespace: FMXBI.R.Console
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIRConsole
  • FMXBI.R.Console


TBIRConsole.EStatement Field

Summary

Represents field EStatement.

Namespace: FMXBI.R.Console
Syntax
Delphi
published
 EStatement: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TBIRConsole
  • FMXBI.R.Console


TBIRConsole.Layout1 Field

Summary

Represents field Layout1.

Namespace: FMXBI.R.Console
Syntax
Delphi
published
 Layout1: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TBIRConsole
  • FMXBI.R.Console


TBIRConsole.Layout2 Field

Summary

Represents field Layout2.

Namespace: FMXBI.R.Console
Syntax
Delphi
published
 Layout2: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TBIRConsole
  • FMXBI.R.Console


TBIRConsole.Layout3 Field

Summary

Represents field Layout3.

Namespace: FMXBI.R.Console
Syntax
Delphi
published
 Layout3: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TBIRConsole
  • FMXBI.R.Console


TBIRConsole.Memo Field

Summary

Represents field Memo.

Namespace: FMXBI.R.Console
Syntax
Delphi
published
 Memo: TMemo;

Field Value

Type: TMemo

See Also

Reference

  • TBIRConsole
  • FMXBI.R.Console


FMXBI.Status Namespace

Summary

Represents namespace FMXBI.Status.

Classes
Name | Description
TStoreStatus | Represents type TStoreStatus.
Top


FMXBI.Status Classes

Classes
Name | Description
TStoreStatus | Represents type TStoreStatus.
Top


TStoreStatus Class

Summary

Represents type TStoreStatus.

Namespace: FMXBI.Status
Inheritance Hierarchy
TForm
FMXBI.Status.TStoreStatus
Syntax
Delphi
type
 TStoreStatus = class(TForm)
 end;

The TStoreStatus type exposes the following members.

Methods
Show:
Name | Description
BUnloadAllClick(TObject) | Represents method BUnloadAllClick(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
Image1Click(TObject) | Represents method Image1Click(TObject).
View(TComponent) | Represents method View(TComponent).
Top
Fields
Show:
Name | Description
BUnloadAll | Represents field BUnloadAll.
Image1 | Represents field Image1.
Label1 | Represents field Label1.
Layout1 | Represents field Layout1.
Layout2 | Represents field Layout2.
LMemory | Represents field LMemory.
TabControl1 | Represents field TabControl1.
TabItem1 | Represents field TabItem1.
Top
See Also

Reference

  • FMXBI.Status


TStoreStatus Methods

Methods
Name | Description
BUnloadAllClick(TObject) | Represents method BUnloadAllClick(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
Image1Click(TObject) | Represents method Image1Click(TObject).
View(TComponent) | Represents method View(TComponent).
Top


TStoreStatus.BUnloadAllClick(TObject) Method

Summary

Represents method BUnloadAllClick(TObject).

Namespace: FMXBI.Status
Syntax
Delphi
published
 procedure BUnloadAllClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreStatus
  • FMXBI.Status


TStoreStatus.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: FMXBI.Status
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreStatus
  • FMXBI.Status


TStoreStatus.FormDestroy(TObject) Method

Summary

Represents method FormDestroy(TObject).

Namespace: FMXBI.Status
Syntax
Delphi
published
 procedure FormDestroy(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreStatus
  • FMXBI.Status


TStoreStatus.Image1Click(TObject) Method

Summary

Represents method Image1Click(TObject).

Namespace: FMXBI.Status
Syntax
Delphi
published
 procedure Image1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreStatus
  • FMXBI.Status


TStoreStatus.View(TComponent) Method

Summary

Represents method View(TComponent).

Namespace: FMXBI.Status
Syntax
Delphi
public
 class procedure View(const AOwner:TComponent);

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TStoreStatus
  • FMXBI.Status


TStoreStatus Fields

Fields
Name | Description
BUnloadAll | Represents field BUnloadAll.
Image1 | Represents field Image1.
Label1 | Represents field Label1.
Layout1 | Represents field Layout1.
Layout2 | Represents field Layout2.
LMemory | Represents field LMemory.
TabControl1 | Represents field TabControl1.
TabItem1 | Represents field TabItem1.
Top


TStoreStatus.BUnloadAll Field

Summary

Represents field BUnloadAll.

Namespace: FMXBI.Status
Syntax
Delphi
published
 BUnloadAll: TButton;

Field Value

Type: TButton

See Also

Reference

  • TStoreStatus
  • FMXBI.Status


TStoreStatus.Image1 Field

Summary

Represents field Image1.

Namespace: FMXBI.Status
Syntax
Delphi
published
 Image1: TImage;

Field Value

Type: TImage

See Also

Reference

  • TStoreStatus
  • FMXBI.Status


TStoreStatus.Label1 Field

Summary

Represents field Label1.

Namespace: FMXBI.Status
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TStoreStatus
  • FMXBI.Status


TStoreStatus.Layout1 Field

Summary

Represents field Layout1.

Namespace: FMXBI.Status
Syntax
Delphi
published
 Layout1: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TStoreStatus
  • FMXBI.Status


TStoreStatus.Layout2 Field

Summary

Represents field Layout2.

Namespace: FMXBI.Status
Syntax
Delphi
published
 Layout2: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TStoreStatus
  • FMXBI.Status


TStoreStatus.LMemory Field

Summary

Represents field LMemory.

Namespace: FMXBI.Status
Syntax
Delphi
published
 LMemory: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TStoreStatus
  • FMXBI.Status


TStoreStatus.TabControl1 Field

Summary

Represents field TabControl1.

Namespace: FMXBI.Status
Syntax
Delphi
published
 TabControl1: TTabControl;

Field Value

Type: TTabControl

See Also

Reference

  • TStoreStatus
  • FMXBI.Status


TStoreStatus.TabItem1 Field

Summary

Represents field TabItem1.

Namespace: FMXBI.Status
Syntax
Delphi
published
 TabItem1: TTabItem;

Field Value

Type: TTabItem

See Also

Reference

  • TStoreStatus
  • FMXBI.Status


FMXBI.Tree Namespace

Summary

Represents namespace FMXBI.Tree.

Classes
Name | Description
TBITree | Represents type TBITree.
TBITree.TBITreeNodes | Represents type TBITreeNodes.
TBITreeNode | Represents type TBITreeNode.
TBITreePlugin | Represents type TBITreePlugin.
TBITreePlugin.TNodeData | Represents type TNodeData.
TControlAccess | Represents type TControlAccess.
Top
Delegates
Name | Description
TBITreeExpandingEvent | Represents type TBITreeExpandingEvent.
Top
Types
Name | Description
TBITreePluginClass | Represents type TBITreePluginClass.
Top


FMXBI.Tree Classes

Classes
Name | Description
TBITree | Represents type TBITree.
TBITree.TBITreeNodes | Represents type TBITreeNodes.
TBITreeNode | Represents type TBITreeNode.
TBITreePlugin | Represents type TBITreePlugin.
TBITreePlugin.TNodeData | Represents type TNodeData.
TControlAccess | Represents type TControlAccess.
Top


TBITree Class

Summary

Represents type TBITree.

Namespace: FMXBI.Tree
Inheritance Hierarchy
TLayout
FMXBI.DataControl.TBIDataControl
FMXBI.Tree.TBITree
FMXBI.Dashboard.TDashboardTree
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64 or pidOSX32
 or pidiOSSimulator or pidiOSDevice
 or pidAndroid
 or pidiOSDevice64
 )]
 TBITree=class(TBIDataControl)
 end;

The TBITree type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBITree class. (Overrides TBIDataControl.Create(TComponent).)
Destroy | Represents the destructor of the TBITree class. (Overrides TBIDataControl.Destroy.)
Top
Properties
Show:
Name | Description
AllowDelete | Represents property AllowDelete.
Nodes | Represents property Nodes.
OnChange | Represents property OnChange.
OnDeleting | Represents property OnDeleting.
Plugin | Represents property Plugin.
Selected | Represents property Selected.
Top
Methods
Show:
Name | Description
Add(String,TObject) | Overloaded. Represents method Add(String,TObject).
Add(TBITreeNode,String,TObject) | Overloaded. Represents method Add(TBITreeNode,String,TObject).
BeginUpdating | Represents method BeginUpdating.
ChangeDragMode | Represents method ChangeDragMode.
ChangePlugin(TBITreePluginClass) | Represents method ChangePlugin(TBITreePluginClass).
Clear(TBITreeNode) | Represents method Clear(TBITreeNode).
DataOf(TBITreeNode) | Represents method DataOf(TBITreeNode).
DeletedNode(TObject) | Represents method DeletedNode(TObject).
EndUpdating | Represents method EndUpdating.
Expand(TBITreeNode,Boolean,Boolean) | Represents method Expand(TBITreeNode,Boolean,Boolean).
Fill(TDataItem) | Overloaded. Represents method Fill(TDataItem).
Fill(TDataItem,TDataItem) | Overloaded. Represents method Fill(TDataItem,TDataItem).
FillParent(TDataItem,TDataItem,TDataItem) | Represents method FillParent(TDataItem,TDataItem,TDataItem).
FillStore(String) | Represents method FillStore(String).
FillStores | Represents method FillStores.
Find(String) | Represents method Find(String).
Loaded | Represents method Loaded. (Overrides TBIDataControl.Loaded.)
NodeAt(Integer,Integer) | Represents method NodeAt(Integer,Integer).
ParentOf(TBITreeNode) | Represents method ParentOf(TBITreeNode).
SelectedData | Represents method SelectedData.
SelectedText | Represents method SelectedText.
SetDataDirect(TDataItem) | Represents method SetDataDirect(TDataItem). (Overrides TBIDataControl.SetDataDirect(TDataItem).)
SetNodeData(TBITreeNode,TObject) | Represents method SetNodeData(TBITreeNode,TObject).
Top
Events
Show:
Name | Description
OnExpanding | Represents property OnExpanding.
Top
Fields
Show:
Name | Description
Engine | Represents field Engine.
Top
See Also

Reference

  • FMXBI.Tree


TBITree Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBITree class. (Overrides TBIDataControl.Create(TComponent).)
Destroy | Represents the destructor of the TBITree class. (Overrides TBIDataControl.Destroy.)
Top


TBITree.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBITree class.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TBIDataControl.Create(TComponent)
See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.Destroy Destructor

Summary

Represents the destructor of the TBITree class.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TBIDataControl.Destroy
See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree Properties

Properties
Name | Description
AllowDelete | Represents property AllowDelete.
Nodes | Represents property Nodes.
OnChange | Represents property OnChange.
OnDeleting | Represents property OnDeleting.
Plugin | Represents property Plugin.
Selected | Represents property Selected.
Top


TBITree.AllowDelete Property

Summary

Represents property AllowDelete.

Namespace: FMXBI.Tree
Syntax
Delphi
published
 property AllowDelete:Boolean read GetAllowDelete write SetAllowDelete default False;

Property Value

Type: Boolean

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.Nodes Property

Summary

Represents property Nodes.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 property Nodes:TBITreeNodes read FNodes;

Property Value

Type: TBITreeNodes

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.OnChange Property

Summary

Represents property OnChange.

Namespace: FMXBI.Tree
Syntax
Delphi
published
 property OnChange:TNotifyEvent read GetOnChange write SetOnChange;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.OnDeleting Property

Summary

Represents property OnDeleting.

Namespace: FMXBI.Tree
Syntax
Delphi
published
 property OnDeleting:TNotifyEvent read FOnDeleting write FOnDeleting;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.Plugin Property

Summary

Represents property Plugin.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 property Plugin:TBITreePlugin read FPlugin write SetPlugin;

Property Value

Type: TBITreePlugin

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.Selected Property

Summary

Represents property Selected.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 property Selected:TBITreeNode read GetSelected write SetSelected;

Property Value

Type: TBITreeNode

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree Methods

Methods
Name | Description
Add(String,TObject) | Overloaded. Represents method Add(String,TObject).
Add(TBITreeNode,String,TObject) | Overloaded. Represents method Add(TBITreeNode,String,TObject).
BeginUpdating | Represents method BeginUpdating.
ChangeDragMode | Represents method ChangeDragMode.
ChangePlugin(TBITreePluginClass) | Represents method ChangePlugin(TBITreePluginClass).
Clear(TBITreeNode) | Represents method Clear(TBITreeNode).
DataOf(TBITreeNode) | Represents method DataOf(TBITreeNode).
DeletedNode(TObject) | Represents method DeletedNode(TObject).
EndUpdating | Represents method EndUpdating.
Expand(TBITreeNode,Boolean,Boolean) | Represents method Expand(TBITreeNode,Boolean,Boolean).
Fill(TDataItem) | Overloaded. Represents method Fill(TDataItem).
Fill(TDataItem,TDataItem) | Overloaded. Represents method Fill(TDataItem,TDataItem).
FillParent(TDataItem,TDataItem,TDataItem) | Represents method FillParent(TDataItem,TDataItem,TDataItem).
FillStore(String) | Represents method FillStore(String).
FillStores | Represents method FillStores.
Find(String) | Represents method Find(String).
Loaded | Represents method Loaded. (Overrides TBIDataControl.Loaded.)
NodeAt(Integer,Integer) | Represents method NodeAt(Integer,Integer).
ParentOf(TBITreeNode) | Represents method ParentOf(TBITreeNode).
SelectedData | Represents method SelectedData.
SelectedText | Represents method SelectedText.
SetDataDirect(TDataItem) | Represents method SetDataDirect(TDataItem). (Overrides TBIDataControl.SetDataDirect(TDataItem).)
SetNodeData(TBITreeNode,TObject) | Represents method SetNodeData(TBITreeNode,TObject).
Top


TBITree.Add(String,TObject) Method

Summary

Represents method Add(String,TObject).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 function Add(const AText:String; const AObject:TObject=nil):TBITreeNode; overload; inline;

Parameters

AText
Type: String

AObject
Type: TObject

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.Add(TBITreeNode,String,TObject) Method

Summary

Represents method Add(TBITreeNode,String,TObject).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 function Add(const AParent:TBITreeNode; const AText:String; const AObject:TObject=nil):TBITreeNode; overload;

Parameters

AParent
Type: TBITreeNode

AText
Type: String

AObject
Type: TObject

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.BeginUpdating Method

Summary

Represents method BeginUpdating.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 procedure BeginUpdating;
See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.ChangeDragMode Method

Summary

Represents method ChangeDragMode.

Namespace: FMXBI.Tree
Syntax
Delphi
protected
 procedure ChangeDragMode;
See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.ChangePlugin(TBITreePluginClass) Method

Summary

Represents method ChangePlugin(TBITreePluginClass).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 procedure ChangePlugin(const APluginClass:TBITreePluginClass);

Parameters

APluginClass
Type: TBITreePluginClass

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.Clear(TBITreeNode) Method

Summary

Represents method Clear(TBITreeNode).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 procedure Clear(const ANode:TBITreeNode=nil);

Parameters

ANode
Type: TBITreeNode

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.DataOf(TBITreeNode) Method

Summary

Represents method DataOf(TBITreeNode).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 function DataOf(const ANode:TBITreeNode):TObject;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TObject

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.DeletedNode(TObject) Method

Summary

Represents method DeletedNode(TObject).

Namespace: FMXBI.Tree
Syntax
Delphi
protected
 procedure DeletedNode(Sender:TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.EndUpdating Method

Summary

Represents method EndUpdating.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 procedure EndUpdating;
See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.Expand(TBITreeNode,Boolean,Boolean) Method

Summary

Represents method Expand(TBITreeNode,Boolean,Boolean).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 procedure Expand(const ANode:TBITreeNode;
 const DoExpand:Boolean=True;
 const Recursive:Boolean=False);

Parameters

ANode
Type: TBITreeNode

DoExpand
Type: Boolean

Recursive
Type: Boolean

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.Fill(TDataItem) Method

Summary

Represents method Fill(TDataItem).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 procedure Fill(const AData:TDataItem); overload;

Parameters

AData
Type: TDataItem

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.Fill(TDataItem,TDataItem) Method

Summary

Represents method Fill(TDataItem,TDataItem).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 procedure Fill(const AMaster,ADetail:TDataItem); overload;

Parameters

AMaster
Type: TDataItem

ADetail
Type: TDataItem

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.FillParent(TDataItem,TDataItem,TDataItem) Method

Summary

Represents method FillParent(TDataItem,TDataItem,TDataItem).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 procedure FillParent(const AKey,AParent:TDataItem; const ADisplay:TDataItem=nil);

Parameters

AKey
Type: TDataItem

AParent
Type: TDataItem

ADisplay
Type: TDataItem

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.FillStore(String) Method

Summary

Represents method FillStore(String).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 procedure FillStore(const AStore:String);

Parameters

AStore
Type: String

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.FillStores Method

Summary

Represents method FillStores.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 procedure FillStores;
See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.Find(String) Method

Summary

Represents method Find(String).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 function Find(const AText:String):TBITreeNode;

Parameters

AText
Type: String

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.Loaded Method

Summary

Represents method Loaded.

Namespace: FMXBI.Tree
Syntax
Delphi
protected
 procedure Loaded; override;

Overrides

TBIDataControl.Loaded
See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.NodeAt(Integer,Integer) Method

Summary

Represents method NodeAt(Integer,Integer).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 function NodeAt(const X,Y:Integer):TBITreeNode;

Parameters

X
Type: Integer

Y
Type: Integer

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.ParentOf(TBITreeNode) Method

Summary

Represents method ParentOf(TBITreeNode).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 function ParentOf(const ANode:TBITreeNode):TBITreeNode;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.SelectedData Method

Summary

Represents method SelectedData.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 function SelectedData:TDataItem;

Return Value

Type: TDataItem

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.SelectedText Method

Summary

Represents method SelectedText.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 function SelectedText:String;

Return Value

Type: String

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.SetDataDirect(TDataItem) Method

Summary

Represents method SetDataDirect(TDataItem).

Namespace: FMXBI.Tree
Syntax
Delphi
protected
 procedure SetDataDirect(const Value: TDataItem); override;

Parameters

Value
Type: TDataItem

Overrides

TBIDataControl.SetDataDirect(TDataItem)
See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.SetNodeData(TBITreeNode,TObject) Method

Summary

Represents method SetNodeData(TBITreeNode,TObject).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 procedure SetNodeData(const ANode:TBITreeNode; const AData:TObject);

Parameters

ANode
Type: TBITreeNode

AData
Type: TObject

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree Events

Events
Name | Description
OnExpanding | Represents property OnExpanding.
Top


TBITree.OnExpanding Event

Summary

Represents property OnExpanding.

Namespace: FMXBI.Tree
Syntax
Delphi
published
 property OnExpanding:TBITreeExpandingEvent read GetExpanding write SetExpanding;

Value

Type: TBITreeExpandingEvent

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree Fields

Fields
Name | Description
Engine | Represents field Engine.
Top


TBITree.Engine Field

Summary

Represents field Engine.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 class var
 Engine : TBITreePluginClass;

Field Value

Type: TBITreePluginClass

See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.TBITreeNodes Class

Summary

Represents type TBITreeNodes.

Namespace: FMXBI.Tree
Inheritance Hierarchy
TObject
FMXBI.Tree.TBITree.TBITreeNodes
Syntax
Delphi
public
type
 TBITreeNodes=class
 end;

The TBITree.TBITreeNodes type exposes the following members.

Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Count | Represents method Count.
Top
See Also

Reference

  • TBITree
  • FMXBI.Tree


TBITree.TBITreeNodes Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TBITree.TBITreeNodes.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: FMXBI.Tree
Syntax
Delphi
public
 property Items[const Index:Integer]:TBITreeNode read Get; default;

Parameters

Index
Type: Integer

Property Value

Type: TBITreeNode

See Also

Reference

  • TBITree.TBITreeNodes
  • TBITree
  • FMXBI.Tree


TBITree.TBITreeNodes Methods

Methods
Name | Description
Count | Represents method Count.
Top


TBITree.TBITreeNodes.Count Method

Summary

Represents method Count.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 function Count:Integer;

Return Value

Type: Integer

See Also

Reference

  • TBITree.TBITreeNodes
  • TBITree
  • FMXBI.Tree


TBITreeNode Class

Summary

Represents type TBITreeNode.

Namespace: FMXBI.Tree
Inheritance Hierarchy
TObject
FMXBI.Tree.TBITreeNode
Syntax
Delphi
type
 TBITreeNode=class(TObject);
See Also

Reference

  • FMXBI.Tree


TBITreePlugin Class

Summary

Represents type TBITreePlugin.

Namespace: FMXBI.Tree
Inheritance Hierarchy
TObject
FMXBI.Tree.TBITreePlugin
FMXBI.Tree.TeeTree.TTeeTreePlugin
FMXBI.Tree.TreeView.TBITreeViewPlugin
Syntax
Delphi
type
 TBITreePlugin=class abstract
 end;

The TBITreePlugin type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBITreePlugin class.
Destroy | Represents the destructor of the TBITreePlugin class.
Top
Properties
Show:
Name | Description
AllowDelete | Represents property AllowDelete.
Control | Represents property Control.
Count | Represents property Count.
OnChange | Represents property OnChange.
OnCheck | Represents property OnCheck.
Selected | Represents property Selected.
SelectedData | Represents property SelectedData.
Top
Methods
Show:
Name | Description
BeginUpdating | Represents method BeginUpdating.
Children(TBITreeNode,Integer) | Represents method Children(TBITreeNode,Integer).
ChildrenCount(TBITreeNode) | Represents method ChildrenCount(TBITreeNode).
Clear(TBITreeNode) | Represents method Clear(TBITreeNode).
ClearData | Overloaded. Represents method ClearData.
ClearData(TBITreeNode) | Overloaded. Represents method ClearData(TBITreeNode).
DataOf(TBITreeNode) | Represents method DataOf(TBITreeNode).
DeleteData(TNodeData) | Represents method DeleteData(TNodeData).
EndUpdating | Represents method EndUpdating.
Expand(Integer) | Overloaded. Represents method Expand(Integer).
Expand(TBITreeNode,Boolean,Boolean) | Overloaded. Represents method Expand(TBITreeNode,Boolean,Boolean).
Find(TObject,Integer) | Represents method Find(TObject,Integer).
FirstNode | Represents method FirstNode.
GetNode(Integer) | Represents method GetNode(Integer).
IsChecked(TBITreeNode) | Represents method IsChecked(TBITreeNode).
IsExpanded(TBITreeNode) | Represents method IsExpanded(TBITreeNode).
NewNode(TBITreeNode,String,TObject,TInteger) | Represents method NewNode(TBITreeNode,String,TObject,TInteger).
NewNodeData(TObject,TInteger) | Represents method NewNodeData(TObject,TInteger).
NextNode(TBITreeNode) | Represents method NextNode(TBITreeNode).
NodeAt(Integer,Integer) | Represents method NodeAt(Integer,Integer).
ParentOf(TBITreeNode) | Represents method ParentOf(TBITreeNode).
SelectedText | Represents method SelectedText.
SetChecked(TBITreeNode,Boolean) | Represents method SetChecked(TBITreeNode,Boolean).
SetData(TBITreeNode,TObject) | Represents method SetData(TBITreeNode,TObject).
SetText(TBITreeNode,String) | Represents method SetText(TBITreeNode,String).
SiblingIndex(TBITreeNode) | Represents method SiblingIndex(TBITreeNode).
TextOf(TBITreeNode) | Represents method TextOf(TBITreeNode).
Top
Events
Show:
Name | Description
OnExpanding | Represents property OnExpanding.
Top
Fields
Show:
Name | Description
FOnDelete | Represents field FOnDelete.
IData | Represents field IData.
Top
See Also

Reference

  • FMXBI.Tree


TBITreePlugin Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBITreePlugin class.
Destroy | Represents the destructor of the TBITreePlugin class.
Top


TBITreePlugin.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBITreePlugin class.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); virtual; abstract;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.Destroy Destructor

Summary

Represents the destructor of the TBITreePlugin class.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin Properties

Properties
Name | Description
AllowDelete | Represents property AllowDelete.
Control | Represents property Control.
Count | Represents property Count.
OnChange | Represents property OnChange.
OnCheck | Represents property OnCheck.
Selected | Represents property Selected.
SelectedData | Represents property SelectedData.
Top


TBITreePlugin.AllowDelete Property

Summary

Represents property AllowDelete.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 property AllowDelete:Boolean read GetAllowDelete write SetAllowDelete;

Property Value

Type: Boolean

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.Control Property

Summary

Represents property Control.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 property Control:TControl read GetControl;

Property Value

Type: TControl

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.Count Property

Summary

Represents property Count.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 property Count:Integer read GetCount;

Property Value

Type: Integer

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.OnChange Property

Summary

Represents property OnChange.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 property OnChange:TNotifyEvent read GetOnChange write SetOnChange;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.OnCheck Property

Summary

Represents property OnCheck.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 property OnCheck:TNotifyEvent read GetOnCheck write SetOnCheck;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.Selected Property

Summary

Represents property Selected.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 property Selected:TBITreeNode read GetSelected write SetSelected;

Property Value

Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.SelectedData Property

Summary

Represents property SelectedData.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 property SelectedData:TBITreePlugin.TNodeData read GetSelectedData;

Property Value

Type: TBITreePlugin.TNodeData

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin Methods

Methods
Name | Description
BeginUpdating | Represents method BeginUpdating.
Children(TBITreeNode,Integer) | Represents method Children(TBITreeNode,Integer).
ChildrenCount(TBITreeNode) | Represents method ChildrenCount(TBITreeNode).
Clear(TBITreeNode) | Represents method Clear(TBITreeNode).
ClearData | Overloaded. Represents method ClearData.
ClearData(TBITreeNode) | Overloaded. Represents method ClearData(TBITreeNode).
DataOf(TBITreeNode) | Represents method DataOf(TBITreeNode).
DeleteData(TNodeData) | Represents method DeleteData(TNodeData).
EndUpdating | Represents method EndUpdating.
Expand(Integer) | Overloaded. Represents method Expand(Integer).
Expand(TBITreeNode,Boolean,Boolean) | Overloaded. Represents method Expand(TBITreeNode,Boolean,Boolean).
Find(TObject,Integer) | Represents method Find(TObject,Integer).
FirstNode | Represents method FirstNode.
GetNode(Integer) | Represents method GetNode(Integer).
IsChecked(TBITreeNode) | Represents method IsChecked(TBITreeNode).
IsExpanded(TBITreeNode) | Represents method IsExpanded(TBITreeNode).
NewNode(TBITreeNode,String,TObject,TInteger) | Represents method NewNode(TBITreeNode,String,TObject,TInteger).
NewNodeData(TObject,TInteger) | Represents method NewNodeData(TObject,TInteger).
NextNode(TBITreeNode) | Represents method NextNode(TBITreeNode).
NodeAt(Integer,Integer) | Represents method NodeAt(Integer,Integer).
ParentOf(TBITreeNode) | Represents method ParentOf(TBITreeNode).
SelectedText | Represents method SelectedText.
SetChecked(TBITreeNode,Boolean) | Represents method SetChecked(TBITreeNode,Boolean).
SetData(TBITreeNode,TObject) | Represents method SetData(TBITreeNode,TObject).
SetText(TBITreeNode,String) | Represents method SetText(TBITreeNode,String).
SiblingIndex(TBITreeNode) | Represents method SiblingIndex(TBITreeNode).
TextOf(TBITreeNode) | Represents method TextOf(TBITreeNode).
Top


TBITreePlugin.BeginUpdating Method

Summary

Represents method BeginUpdating.

Namespace: FMXBI.Tree
Syntax
Delphi
protected
 procedure BeginUpdating; virtual; abstract;
See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.Children(TBITreeNode,Integer) Method

Summary

Represents method Children(TBITreeNode,Integer).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 function Children(const ANode:TBITreeNode; const AIndex:Integer):TBITreeNode; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

AIndex
Type: Integer

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.ChildrenCount(TBITreeNode) Method

Summary

Represents method ChildrenCount(TBITreeNode).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 function ChildrenCount(const ANode:TBITreeNode):Integer; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Integer

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.Clear(TBITreeNode) Method

Summary

Represents method Clear(TBITreeNode).

Namespace: FMXBI.Tree
Syntax
Delphi
protected
 procedure Clear(const ANode:TBITreeNode=nil); virtual; abstract;

Parameters

ANode
Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.ClearData Method

Summary

Represents method ClearData.

Namespace: FMXBI.Tree
Syntax
Delphi
protected
 procedure ClearData; overload;
See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.ClearData(TBITreeNode) Method

Summary

Represents method ClearData(TBITreeNode).

Namespace: FMXBI.Tree
Syntax
Delphi
protected
 procedure ClearData(const ANode:TBITreeNode); overload; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.DataOf(TBITreeNode) Method

Summary

Represents method DataOf(TBITreeNode).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 function DataOf(const ANode:TBITreeNode):TObject; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TObject

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.DeleteData(TNodeData) Method

Summary

Represents method DeleteData(TNodeData).

Namespace: FMXBI.Tree
Syntax
Delphi
protected
 procedure DeleteData(const AData:TNodeData);

Parameters

AData
Type: TNodeData

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.EndUpdating Method

Summary

Represents method EndUpdating.

Namespace: FMXBI.Tree
Syntax
Delphi
protected
 procedure EndUpdating; virtual; abstract;
See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.Expand(Integer) Method

Summary

Represents method Expand(Integer).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 procedure Expand(const AIndex:Integer); overload; virtual; abstract;

Parameters

AIndex
Type: Integer

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.Expand(TBITreeNode,Boolean,Boolean) Method

Summary

Represents method Expand(TBITreeNode,Boolean,Boolean).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 procedure Expand(const ANode:TBITreeNode;
 const DoExpand:Boolean=True;
 const Recursive:Boolean=False); overload; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

DoExpand
Type: Boolean

Recursive
Type: Boolean

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.Find(TObject,Integer) Method

Summary

Represents method Find(TObject,Integer).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 function Find(const ATag:TObject; const AIndex:Integer=-1):TBITreeNode; virtual; abstract;

Parameters

ATag
Type: TObject

AIndex
Type: Integer

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.FirstNode Method

Summary

Represents method FirstNode.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 function FirstNode:TBITreeNode; virtual; abstract;

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.GetNode(Integer) Method

Summary

Represents method GetNode(Integer).

Namespace: FMXBI.Tree
Syntax
Delphi
protected
 function GetNode(const AIndex:Integer):TBITreeNode; virtual; abstract;

Parameters

AIndex
Type: Integer

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.IsChecked(TBITreeNode) Method

Summary

Represents method IsChecked(TBITreeNode).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 function IsChecked(const ANode:TBITreeNode):Boolean; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Boolean

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.IsExpanded(TBITreeNode) Method

Summary

Represents method IsExpanded(TBITreeNode).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 function IsExpanded(const ANode:TBITreeNode):Boolean; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Boolean

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.NewNode(TBITreeNode,String,TObject,TInteger) Method

Summary

Represents method NewNode(TBITreeNode,String,TObject,TInteger).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 function NewNode(const AParent:TBITreeNode; const AText:String;
 const ATag:TObject=nil;
 const AIndex:TInteger=-1):TBITreeNode; virtual; abstract;

Parameters

AParent
Type: TBITreeNode

AText
Type: String

ATag
Type: TObject

AIndex
Type: System.Void

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.NewNodeData(TObject,TInteger) Method

Summary

Represents method NewNodeData(TObject,TInteger).

Namespace: FMXBI.Tree
Syntax
Delphi
protected
 function NewNodeData(const ATag:TObject; const AIndex:TInteger):TNodeData;

Parameters

ATag
Type: TObject

AIndex
Type: System.Void

Return Value

Type: TNodeData

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.NextNode(TBITreeNode) Method

Summary

Represents method NextNode(TBITreeNode).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 function NextNode(const ANode:TBITreeNode):TBITreeNode; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.NodeAt(Integer,Integer) Method

Summary

Represents method NodeAt(Integer,Integer).

Namespace: FMXBI.Tree
Syntax
Delphi
protected
 function NodeAt(const X,Y:Integer):TBITreeNode; virtual; abstract;

Parameters

X
Type: Integer

Y
Type: Integer

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.ParentOf(TBITreeNode) Method

Summary

Represents method ParentOf(TBITreeNode).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 function ParentOf(const ANode:TBITreeNode):TBITreeNode; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.SelectedText Method

Summary

Represents method SelectedText.

Namespace: FMXBI.Tree
Syntax
Delphi
protected
 function SelectedText:String; virtual; abstract;

Return Value

Type: String

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.SetChecked(TBITreeNode,Boolean) Method

Summary

Represents method SetChecked(TBITreeNode,Boolean).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 procedure SetChecked(const ANode:TBITreeNode; const Value:Boolean); virtual; abstract;

Parameters

ANode
Type: TBITreeNode

Value
Type: Boolean

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.SetData(TBITreeNode,TObject) Method

Summary

Represents method SetData(TBITreeNode,TObject).

Namespace: FMXBI.Tree
Syntax
Delphi
protected
 procedure SetData(const ANode:TBITreeNode; const AData:TObject); virtual; abstract;

Parameters

ANode
Type: TBITreeNode

AData
Type: TObject

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.SetText(TBITreeNode,String) Method

Summary

Represents method SetText(TBITreeNode,String).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 procedure SetText(const ANode:TBITreeNode; const Value:String); virtual; abstract;

Parameters

ANode
Type: TBITreeNode

Value
Type: String

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.SiblingIndex(TBITreeNode) Method

Summary

Represents method SiblingIndex(TBITreeNode).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 function SiblingIndex(const ANode:TBITreeNode):Integer; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Integer

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.TextOf(TBITreeNode) Method

Summary

Represents method TextOf(TBITreeNode).

Namespace: FMXBI.Tree
Syntax
Delphi
public
 function TextOf(const ANode:TBITreeNode):String; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: String

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin Events

Events
Name | Description
OnExpanding | Represents property OnExpanding.
Top


TBITreePlugin.OnExpanding Event

Summary

Represents property OnExpanding.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 property OnExpanding:TBITreeExpandingEvent read GetOnExpanding write SetOnExpanding;

Value

Type: TBITreeExpandingEvent

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin Fields

Fields
Name | Description
FOnDelete | Represents field FOnDelete.
IData | Represents field IData.
Top


TBITreePlugin.FOnDelete Field

Summary

Represents field FOnDelete.

Namespace: FMXBI.Tree
Syntax
Delphi
protected
 FOnDelete : TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.IData Field

Summary

Represents field IData.

Namespace: FMXBI.Tree
Syntax
Delphi
protected
 IData : Array of TNodeData;

Field Value

Type: Array of TNodeData

See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.TNodeData Class

Summary

Represents type TNodeData.

Namespace: FMXBI.Tree
Inheritance Hierarchy
TObject
FMXBI.Tree.TBITreePlugin.TNodeData
Syntax
Delphi
public
type
 TNodeData=class
 end;

The TBITreePlugin.TNodeData type exposes the following members.

Fields
Show:
Name | Description
Index | Represents field Index.
Tag | Represents field Tag.
Top
See Also

Reference

  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.TNodeData Fields

Fields
Name | Description
Index | Represents field Index.
Tag | Represents field Tag.
Top


TBITreePlugin.TNodeData.Index Field

Summary

Represents field Index.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 Index : TInteger;

Field Value

Type: TInteger

See Also

Reference

  • TBITreePlugin.TNodeData
  • TBITreePlugin
  • FMXBI.Tree


TBITreePlugin.TNodeData.Tag Field

Summary

Represents field Tag.

Namespace: FMXBI.Tree
Syntax
Delphi
public
 Tag : TObject;

Field Value

Type: TObject

See Also

Reference

  • TBITreePlugin.TNodeData
  • TBITreePlugin
  • FMXBI.Tree


TControlAccess Class

Summary

Represents type TControlAccess.

Namespace: FMXBI.Tree
Inheritance Hierarchy
TControl
FMXBI.Tree.TControlAccess
Syntax
Delphi
type
 TControlAccess=class(TControl);
See Also

Reference

  • FMXBI.Tree


FMXBI.Tree Delegates

Delegates
Name | Description
TBITreeExpandingEvent | Represents type TBITreeExpandingEvent.
Top


TBITreeExpandingEvent Delegate

Summary

Represents type TBITreeExpandingEvent.

Namespace: FMXBI.Tree
Syntax
Delphi
type
 TBITreeExpandingEvent=procedure(Sender: TObject; const Node: TBITreeNode;
 var AllowExpansion: Boolean) of object;
See Also

Reference

  • FMXBI.Tree


FMXBI.Tree Types

Types
Name | Description
TBITreePluginClass | Represents type TBITreePluginClass.
Top


TBITreePluginClass Type

Summary

Represents type TBITreePluginClass.

Namespace: FMXBI.Tree
Syntax
Delphi
type
 TBITreePluginClass=class of TBITreePlugin;
See Also

Reference

  • FMXBI.Tree


FMXBI.Tree.TeeTree Namespace

Summary

Represents namespace FMXBI.Tree.TeeTree.

Classes
Name | Description
TTeeTreePlugin | Represents type TTeeTreePlugin.
TTreeNodeShapeAccess | Represents type TTreeNodeShapeAccess.
Top


FMXBI.Tree.TeeTree Classes

Classes
Name | Description
TTeeTreePlugin | Represents type TTeeTreePlugin.
TTreeNodeShapeAccess | Represents type TTreeNodeShapeAccess.
Top


TTeeTreePlugin Class

Summary

Represents type TTeeTreePlugin.

Namespace: FMXBI.Tree.TeeTree
Inheritance Hierarchy
TObject
FMXBI.Tree.TBITreePlugin
FMXBI.Tree.TeeTree.TTeeTreePlugin
Syntax
Delphi
type
 TTeeTreePlugin=class(TBITreePlugin)
 end;

The TTeeTreePlugin type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TTeeTreePlugin class. (Overrides TBITreePlugin.Create(TComponent).)
Top
Methods
Show:
Name | Description
BeginUpdating | Represents method BeginUpdating. (Overrides TBITreePlugin.BeginUpdating.)
Children(TBITreeNode,Integer) | Represents method Children(TBITreeNode,Integer). (Overrides TBITreePlugin.Children(TBITreeNode,Integer).)
ChildrenCount(TBITreeNode) | Represents method ChildrenCount(TBITreeNode). (Overrides TBITreePlugin.ChildrenCount(TBITreeNode).)
Clear(TBITreeNode) | Represents method Clear(TBITreeNode). (Overrides TBITreePlugin.Clear(TBITreeNode).)
ClearData(TBITreeNode) | Represents method ClearData(TBITreeNode). (Overrides TBITreePlugin.ClearData(TBITreeNode).)
DataOf(TBITreeNode) | Represents method DataOf(TBITreeNode). (Overrides TBITreePlugin.DataOf(TBITreeNode).)
EndUpdating | Represents method EndUpdating. (Overrides TBITreePlugin.EndUpdating.)
Expand(Integer) | Represents method Expand(Integer). (Overrides TBITreePlugin.Expand(Integer).)
Expand(TBITreeNode,Boolean,Boolean) | Represents method Expand(TBITreeNode,Boolean,Boolean). (Overrides TBITreePlugin.Expand(TBITreeNode,Boolean,Boolean).)
Find(TObject,Integer) | Represents method Find(TObject,Integer). (Overrides TBITreePlugin.Find(TObject,Integer).)
FirstNode | Represents method FirstNode. (Overrides TBITreePlugin.FirstNode.)
GetAllowDelete | Represents method GetAllowDelete. (Overrides TBITreePlugin.GetAllowDelete.)
GetControl | Represents method GetControl. (Overrides TBITreePlugin.GetControl.)
GetCount | Represents method GetCount. (Overrides TBITreePlugin.GetCount.)
GetNode(Integer) | Represents method GetNode(Integer). (Overrides TBITreePlugin.GetNode(Integer).)
GetOnChange | Represents method GetOnChange. (Overrides TBITreePlugin.GetOnChange.)
GetOnCheck | Represents method GetOnCheck. (Overrides TBITreePlugin.GetOnCheck.)
GetOnExpanding | Represents method GetOnExpanding. (Overrides TBITreePlugin.GetOnExpanding.)
GetSelected | Represents method GetSelected. (Overrides TBITreePlugin.GetSelected.)
GetSelectedData | Represents method GetSelectedData. (Overrides TBITreePlugin.GetSelectedData.)
IsChecked(TBITreeNode) | Represents method IsChecked(TBITreeNode). (Overrides TBITreePlugin.IsChecked(TBITreeNode).)
IsExpanded(TBITreeNode) | Represents method IsExpanded(TBITreeNode). (Overrides TBITreePlugin.IsExpanded(TBITreeNode).)
NewNode(TBITreeNode,String,TObject,TInteger) | Represents method NewNode(TBITreeNode,String,TObject,TInteger). (Overrides TBITreePlugin.NewNode(TBITreeNode,String,TObject,TInteger).)
NextNode(TBITreeNode) | Represents method NextNode(TBITreeNode). (Overrides TBITreePlugin.NextNode(TBITreeNode).)
NodeAt(Integer,Integer) | Represents method NodeAt(Integer,Integer). (Overrides TBITreePlugin.NodeAt(Integer,Integer).)
ParentOf(TBITreeNode) | Represents method ParentOf(TBITreeNode). (Overrides TBITreePlugin.ParentOf(TBITreeNode).)
SelectedText | Represents method SelectedText. (Overrides TBITreePlugin.SelectedText.)
SetAllowDelete(Boolean) | Represents method SetAllowDelete(Boolean). (Overrides TBITreePlugin.SetAllowDelete(Boolean).)
SetChecked(TBITreeNode,Boolean) | Represents method SetChecked(TBITreeNode,Boolean). (Overrides TBITreePlugin.SetChecked(TBITreeNode,Boolean).)
SetData(TBITreeNode,TObject) | Represents method SetData(TBITreeNode,TObject). (Overrides TBITreePlugin.SetData(TBITreeNode,TObject).)
SetOnChange(TNotifyEvent) | Represents method SetOnChange(TNotifyEvent). (Overrides TBITreePlugin.SetOnChange(TNotifyEvent).)
SetOnCheck(TNotifyEvent) | Represents method SetOnCheck(TNotifyEvent). (Overrides TBITreePlugin.SetOnCheck(TNotifyEvent).)
SetOnExpanding(TBITreeExpandingEvent) | Represents method SetOnExpanding(TBITreeExpandingEvent). (Overrides TBITreePlugin.SetOnExpanding(TBITreeExpandingEvent).)
SetSelected(TBITreeNode) | Represents method SetSelected(TBITreeNode). (Overrides TBITreePlugin.SetSelected(TBITreeNode).)
SetText(TBITreeNode,String) | Represents method SetText(TBITreeNode,String). (Overrides TBITreePlugin.SetText(TBITreeNode,String).)
SiblingIndex(TBITreeNode) | Represents method SiblingIndex(TBITreeNode). (Overrides TBITreePlugin.SiblingIndex(TBITreeNode).)
TextOf(TBITreeNode) | Represents method TextOf(TBITreeNode). (Overrides TBITreePlugin.TextOf(TBITreeNode).)
Top
See Also

Reference

  • FMXBI.Tree.TeeTree


TTeeTreePlugin Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TTeeTreePlugin class. (Overrides TBITreePlugin.Create(TComponent).)
Top


TTeeTreePlugin.Create(TComponent) Constructor

Summary

Initializes a new instance of the TTeeTreePlugin class.

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TBITreePlugin.Create(TComponent)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin Methods

Methods
Name | Description
BeginUpdating | Represents method BeginUpdating. (Overrides TBITreePlugin.BeginUpdating.)
Children(TBITreeNode,Integer) | Represents method Children(TBITreeNode,Integer). (Overrides TBITreePlugin.Children(TBITreeNode,Integer).)
ChildrenCount(TBITreeNode) | Represents method ChildrenCount(TBITreeNode). (Overrides TBITreePlugin.ChildrenCount(TBITreeNode).)
Clear(TBITreeNode) | Represents method Clear(TBITreeNode). (Overrides TBITreePlugin.Clear(TBITreeNode).)
ClearData(TBITreeNode) | Represents method ClearData(TBITreeNode). (Overrides TBITreePlugin.ClearData(TBITreeNode).)
DataOf(TBITreeNode) | Represents method DataOf(TBITreeNode). (Overrides TBITreePlugin.DataOf(TBITreeNode).)
EndUpdating | Represents method EndUpdating. (Overrides TBITreePlugin.EndUpdating.)
Expand(Integer) | Represents method Expand(Integer). (Overrides TBITreePlugin.Expand(Integer).)
Expand(TBITreeNode,Boolean,Boolean) | Represents method Expand(TBITreeNode,Boolean,Boolean). (Overrides TBITreePlugin.Expand(TBITreeNode,Boolean,Boolean).)
Find(TObject,Integer) | Represents method Find(TObject,Integer). (Overrides TBITreePlugin.Find(TObject,Integer).)
FirstNode | Represents method FirstNode. (Overrides TBITreePlugin.FirstNode.)
GetAllowDelete | Represents method GetAllowDelete. (Overrides TBITreePlugin.GetAllowDelete.)
GetControl | Represents method GetControl. (Overrides TBITreePlugin.GetControl.)
GetCount | Represents method GetCount. (Overrides TBITreePlugin.GetCount.)
GetNode(Integer) | Represents method GetNode(Integer). (Overrides TBITreePlugin.GetNode(Integer).)
GetOnChange | Represents method GetOnChange. (Overrides TBITreePlugin.GetOnChange.)
GetOnCheck | Represents method GetOnCheck. (Overrides TBITreePlugin.GetOnCheck.)
GetOnExpanding | Represents method GetOnExpanding. (Overrides TBITreePlugin.GetOnExpanding.)
GetSelected | Represents method GetSelected. (Overrides TBITreePlugin.GetSelected.)
GetSelectedData | Represents method GetSelectedData. (Overrides TBITreePlugin.GetSelectedData.)
IsChecked(TBITreeNode) | Represents method IsChecked(TBITreeNode). (Overrides TBITreePlugin.IsChecked(TBITreeNode).)
IsExpanded(TBITreeNode) | Represents method IsExpanded(TBITreeNode). (Overrides TBITreePlugin.IsExpanded(TBITreeNode).)
NewNode(TBITreeNode,String,TObject,TInteger) | Represents method NewNode(TBITreeNode,String,TObject,TInteger). (Overrides TBITreePlugin.NewNode(TBITreeNode,String,TObject,TInteger).)
NextNode(TBITreeNode) | Represents method NextNode(TBITreeNode). (Overrides TBITreePlugin.NextNode(TBITreeNode).)
NodeAt(Integer,Integer) | Represents method NodeAt(Integer,Integer). (Overrides TBITreePlugin.NodeAt(Integer,Integer).)
ParentOf(TBITreeNode) | Represents method ParentOf(TBITreeNode). (Overrides TBITreePlugin.ParentOf(TBITreeNode).)
SelectedText | Represents method SelectedText. (Overrides TBITreePlugin.SelectedText.)
SetAllowDelete(Boolean) | Represents method SetAllowDelete(Boolean). (Overrides TBITreePlugin.SetAllowDelete(Boolean).)
SetChecked(TBITreeNode,Boolean) | Represents method SetChecked(TBITreeNode,Boolean). (Overrides TBITreePlugin.SetChecked(TBITreeNode,Boolean).)
SetData(TBITreeNode,TObject) | Represents method SetData(TBITreeNode,TObject). (Overrides TBITreePlugin.SetData(TBITreeNode,TObject).)
SetOnChange(TNotifyEvent) | Represents method SetOnChange(TNotifyEvent). (Overrides TBITreePlugin.SetOnChange(TNotifyEvent).)
SetOnCheck(TNotifyEvent) | Represents method SetOnCheck(TNotifyEvent). (Overrides TBITreePlugin.SetOnCheck(TNotifyEvent).)
SetOnExpanding(TBITreeExpandingEvent) | Represents method SetOnExpanding(TBITreeExpandingEvent). (Overrides TBITreePlugin.SetOnExpanding(TBITreeExpandingEvent).)
SetSelected(TBITreeNode) | Represents method SetSelected(TBITreeNode). (Overrides TBITreePlugin.SetSelected(TBITreeNode).)
SetText(TBITreeNode,String) | Represents method SetText(TBITreeNode,String). (Overrides TBITreePlugin.SetText(TBITreeNode,String).)
SiblingIndex(TBITreeNode) | Represents method SiblingIndex(TBITreeNode). (Overrides TBITreePlugin.SiblingIndex(TBITreeNode).)
TextOf(TBITreeNode) | Represents method TextOf(TBITreeNode). (Overrides TBITreePlugin.TextOf(TBITreeNode).)
Top


TTeeTreePlugin.BeginUpdating Method

Summary

Represents method BeginUpdating.

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
protected
 procedure BeginUpdating; override;

Overrides

TBITreePlugin.BeginUpdating
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.Children(TBITreeNode,Integer) Method

Summary

Represents method Children(TBITreeNode,Integer).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
public
 function Children(const ANode:TBITreeNode; const AIndex:Integer):TBITreeNode; override;

Parameters

ANode
Type: TBITreeNode

AIndex
Type: Integer

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.Children(TBITreeNode,Integer)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.ChildrenCount(TBITreeNode) Method

Summary

Represents method ChildrenCount(TBITreeNode).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
public
 function ChildrenCount(const ANode:TBITreeNode):Integer; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Integer

Overrides

TBITreePlugin.ChildrenCount(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.Clear(TBITreeNode) Method

Summary

Represents method Clear(TBITreeNode).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
protected
 procedure Clear(const ANode:TBITreeNode=nil); override;

Parameters

ANode
Type: TBITreeNode

Overrides

TBITreePlugin.Clear(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.ClearData(TBITreeNode) Method

Summary

Represents method ClearData(TBITreeNode).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
protected
 procedure ClearData(const ANode:TBITreeNode); override;

Parameters

ANode
Type: TBITreeNode

Overrides

TBITreePlugin.ClearData(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.DataOf(TBITreeNode) Method

Summary

Represents method DataOf(TBITreeNode).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
public
 function DataOf(const ANode:TBITreeNode):TObject; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TObject

Overrides

TBITreePlugin.DataOf(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.EndUpdating Method

Summary

Represents method EndUpdating.

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
protected
 procedure EndUpdating; override;

Overrides

TBITreePlugin.EndUpdating
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.Expand(TBITreeNode,Boolean,Boolean) Method

Summary

Represents method Expand(TBITreeNode,Boolean,Boolean).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
public
 procedure Expand(const ANode:TBITreeNode; const DoExpand:Boolean=True; const Recursive:Boolean=False); override;

Parameters

ANode
Type: TBITreeNode

DoExpand
Type: Boolean

Recursive
Type: Boolean

Overrides

TBITreePlugin.Expand(TBITreeNode,Boolean,Boolean)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.Find(TObject,Integer) Method

Summary

Represents method Find(TObject,Integer).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
public
 function Find(const ATag:TObject; const AIndex:Integer):TBITreeNode; override;

Parameters

ATag
Type: TObject

AIndex
Type: Integer

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.Find(TObject,Integer)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.FirstNode Method

Summary

Represents method FirstNode.

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
public
 function FirstNode:TBITreeNode; override;

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.FirstNode
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.GetAllowDelete Method

Summary

Represents method GetAllowDelete.

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
protected
 function GetAllowDelete: Boolean; override;

Return Value

Type: Boolean

Overrides

TBITreePlugin.GetAllowDelete
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.GetControl Method

Summary

Represents method GetControl.

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
protected
 function GetControl:TControl; override;

Return Value

Type: TControl

Overrides

TBITreePlugin.GetControl
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.GetCount Method

Summary

Represents method GetCount.

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
protected
 function GetCount:Integer; override;

Return Value

Type: Integer

Overrides

TBITreePlugin.GetCount
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.GetNode(Integer) Method

Summary

Represents method GetNode(Integer).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
protected
 function GetNode(const AIndex:Integer):TBITreeNode; override;

Parameters

AIndex
Type: Integer

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.GetNode(Integer)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.GetOnChange Method

Summary

Represents method GetOnChange.

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
protected
 function GetOnChange: TNotifyEvent; override;

Return Value

Type: TNotifyEvent

Overrides

TBITreePlugin.GetOnChange
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.GetOnCheck Method

Summary

Represents method GetOnCheck.

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
protected
 function GetOnCheck: TNotifyEvent; override;

Return Value

Type: TNotifyEvent

Overrides

TBITreePlugin.GetOnCheck
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.GetOnExpanding Method

Summary

Represents method GetOnExpanding.

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
protected
 function GetOnExpanding: TBITreeExpandingEvent; override;

Return Value

Type: TBITreeExpandingEvent

Overrides

TBITreePlugin.GetOnExpanding
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.GetSelected Method

Summary

Represents method GetSelected.

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
protected
 function GetSelected:TBITreeNode; override;

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.GetSelected
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.GetSelectedData Method

Summary

Represents method GetSelectedData.

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
protected
 function GetSelectedData: TBITreePlugin.TNodeData; override;

Return Value

Type: TBITreePlugin.TNodeData

Overrides

TBITreePlugin.GetSelectedData
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.IsChecked(TBITreeNode) Method

Summary

Represents method IsChecked(TBITreeNode).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
public
 function IsChecked(const ANode:TBITreeNode):Boolean; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Boolean

Overrides

TBITreePlugin.IsChecked(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.IsExpanded(TBITreeNode) Method

Summary

Represents method IsExpanded(TBITreeNode).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
public
 function IsExpanded(const ANode:TBITreeNode):Boolean; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Boolean

Overrides

TBITreePlugin.IsExpanded(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.NewNode(TBITreeNode,String,TObject,TInteger) Method

Summary

Represents method NewNode(TBITreeNode,String,TObject,TInteger).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
public
 function NewNode(const AParent:TBITreeNode; const AText:String;
 const ATag:TObject=nil; const AIndex:TInteger=-1):TBITreeNode; override;

Parameters

AParent
Type: TBITreeNode

AText
Type: String

ATag
Type: TObject

AIndex
Type: System.Void

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.NewNode(TBITreeNode,String,TObject,TInteger)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.NextNode(TBITreeNode) Method

Summary

Represents method NextNode(TBITreeNode).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
public
 function NextNode(const ANode:TBITreeNode):TBITreeNode; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.NextNode(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.NodeAt(Integer,Integer) Method

Summary

Represents method NodeAt(Integer,Integer).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
protected
 function NodeAt(const X,Y:Integer):TBITreeNode; override;

Parameters

X
Type: Integer

Y
Type: Integer

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.NodeAt(Integer,Integer)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.ParentOf(TBITreeNode) Method

Summary

Represents method ParentOf(TBITreeNode).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
public
 function ParentOf(const ANode:TBITreeNode):TBITreeNode; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.ParentOf(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.SelectedText Method

Summary

Represents method SelectedText.

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
protected
 function SelectedText:String; override;

Return Value

Type: String

Overrides

TBITreePlugin.SelectedText
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.SetAllowDelete(Boolean) Method

Summary

Represents method SetAllowDelete(Boolean).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
protected
 procedure SetAllowDelete(const Value: Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBITreePlugin.SetAllowDelete(Boolean)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.SetChecked(TBITreeNode,Boolean) Method

Summary

Represents method SetChecked(TBITreeNode,Boolean).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
public
 procedure SetChecked(const ANode:TBITreeNode; const Value:Boolean); override;

Parameters

ANode
Type: TBITreeNode

Value
Type: Boolean

Overrides

TBITreePlugin.SetChecked(TBITreeNode,Boolean)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.SetData(TBITreeNode,TObject) Method

Summary

Represents method SetData(TBITreeNode,TObject).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
protected
 procedure SetData(const ANode: TBITreeNode; const AData: TObject); override;

Parameters

ANode
Type: TBITreeNode

AData
Type: TObject

Overrides

TBITreePlugin.SetData(TBITreeNode,TObject)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.SetOnChange(TNotifyEvent) Method

Summary

Represents method SetOnChange(TNotifyEvent).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
protected
 procedure SetOnChange(const Value: TNotifyEvent); override;

Parameters

Value
Type: TNotifyEvent

Overrides

TBITreePlugin.SetOnChange(TNotifyEvent)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.SetOnCheck(TNotifyEvent) Method

Summary

Represents method SetOnCheck(TNotifyEvent).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
protected
 procedure SetOnCheck(const Value: TNotifyEvent); override;

Parameters

Value
Type: TNotifyEvent

Overrides

TBITreePlugin.SetOnCheck(TNotifyEvent)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.SetOnExpanding(TBITreeExpandingEvent) Method

Summary

Represents method SetOnExpanding(TBITreeExpandingEvent).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
protected
 procedure SetOnExpanding(const Value: TBITreeExpandingEvent); override;

Parameters

Value
Type: TBITreeExpandingEvent

Overrides

TBITreePlugin.SetOnExpanding(TBITreeExpandingEvent)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.SetSelected(TBITreeNode) Method

Summary

Represents method SetSelected(TBITreeNode).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
protected
 procedure SetSelected(const Value: TBITreeNode); override;

Parameters

Value
Type: TBITreeNode

Overrides

TBITreePlugin.SetSelected(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.SetText(TBITreeNode,String) Method

Summary

Represents method SetText(TBITreeNode,String).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
public
 procedure SetText(const ANode:TBITreeNode; const Value:String); override;

Parameters

ANode
Type: TBITreeNode

Value
Type: String

Overrides

TBITreePlugin.SetText(TBITreeNode,String)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.SiblingIndex(TBITreeNode) Method

Summary

Represents method SiblingIndex(TBITreeNode).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
public
 function SiblingIndex(const ANode:TBITreeNode):Integer; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Integer

Overrides

TBITreePlugin.SiblingIndex(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTeeTreePlugin.TextOf(TBITreeNode) Method

Summary

Represents method TextOf(TBITreeNode).

Namespace: FMXBI.Tree.TeeTree
Syntax
Delphi
public
 function TextOf(const ANode:TBITreeNode):String; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: String

Overrides

TBITreePlugin.TextOf(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • FMXBI.Tree.TeeTree


TTreeNodeShapeAccess Class

Summary

Represents type TTreeNodeShapeAccess.

Namespace: FMXBI.Tree.TeeTree
Inheritance Hierarchy
TTreeNodeShape
FMXBI.Tree.TeeTree.TTreeNodeShapeAccess
Syntax
Delphi
type
 TTreeNodeShapeAccess=class(TTreeNodeShape);
See Also

Reference

  • FMXBI.Tree.TeeTree


FMXBI.Tree.TreeView Namespace

Summary

Represents namespace FMXBI.Tree.TreeView.

Classes
Name | Description
TBITreeViewPlugin | Represents type TBITreeViewPlugin.
Top


FMXBI.Tree.TreeView Classes

Classes
Name | Description
TBITreeViewPlugin | Represents type TBITreeViewPlugin.
Top


TBITreeViewPlugin Class

Summary

Represents type TBITreeViewPlugin.

Namespace: FMXBI.Tree.TreeView
Inheritance Hierarchy
TObject
FMXBI.Tree.TBITreePlugin
FMXBI.Tree.TreeView.TBITreeViewPlugin
Syntax
Delphi
type
 TBITreeViewPlugin=class(TBITreePlugin)
 end;

The TBITreeViewPlugin type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBITreeViewPlugin class. (Overrides TBITreePlugin.Create(TComponent).)
Top
Methods
Show:
Name | Description
BeginUpdating | Represents method BeginUpdating. (Overrides TBITreePlugin.BeginUpdating.)
Children(TBITreeNode,Integer) | Represents method Children(TBITreeNode,Integer). (Overrides TBITreePlugin.Children(TBITreeNode,Integer).)
ChildrenCount(TBITreeNode) | Represents method ChildrenCount(TBITreeNode). (Overrides TBITreePlugin.ChildrenCount(TBITreeNode).)
Clear(TBITreeNode) | Represents method Clear(TBITreeNode). (Overrides TBITreePlugin.Clear(TBITreeNode).)
ClearData(TBITreeNode) | Represents method ClearData(TBITreeNode). (Overrides TBITreePlugin.ClearData(TBITreeNode).)
DataOf(TBITreeNode) | Represents method DataOf(TBITreeNode). (Overrides TBITreePlugin.DataOf(TBITreeNode).)
EndUpdating | Represents method EndUpdating. (Overrides TBITreePlugin.EndUpdating.)
Expand(Integer) | Represents method Expand(Integer). (Overrides TBITreePlugin.Expand(Integer).)
Expand(TBITreeNode,Boolean,Boolean) | Represents method Expand(TBITreeNode,Boolean,Boolean). (Overrides TBITreePlugin.Expand(TBITreeNode,Boolean,Boolean).)
Find(TObject,Integer) | Represents method Find(TObject,Integer). (Overrides TBITreePlugin.Find(TObject,Integer).)
FirstNode | Represents method FirstNode. (Overrides TBITreePlugin.FirstNode.)
GetAllowDelete | Represents method GetAllowDelete. (Overrides TBITreePlugin.GetAllowDelete.)
GetControl | Represents method GetControl. (Overrides TBITreePlugin.GetControl.)
GetCount | Represents method GetCount. (Overrides TBITreePlugin.GetCount.)
GetNode(Integer) | Represents method GetNode(Integer). (Overrides TBITreePlugin.GetNode(Integer).)
GetOnChange | Represents method GetOnChange. (Overrides TBITreePlugin.GetOnChange.)
GetOnCheck | Represents method GetOnCheck. (Overrides TBITreePlugin.GetOnCheck.)
GetOnExpanding | Represents method GetOnExpanding. (Overrides TBITreePlugin.GetOnExpanding.)
GetSelected | Represents method GetSelected. (Overrides TBITreePlugin.GetSelected.)
GetSelectedData | Represents method GetSelectedData. (Overrides TBITreePlugin.GetSelectedData.)
IsChecked(TBITreeNode) | Represents method IsChecked(TBITreeNode). (Overrides TBITreePlugin.IsChecked(TBITreeNode).)
IsExpanded(TBITreeNode) | Represents method IsExpanded(TBITreeNode). (Overrides TBITreePlugin.IsExpanded(TBITreeNode).)
NewNode(TBITreeNode,String,TObject,TInteger) | Represents method NewNode(TBITreeNode,String,TObject,TInteger). (Overrides TBITreePlugin.NewNode(TBITreeNode,String,TObject,TInteger).)
NextNode(TBITreeNode) | Represents method NextNode(TBITreeNode). (Overrides TBITreePlugin.NextNode(TBITreeNode).)
NodeAt(Integer,Integer) | Represents method NodeAt(Integer,Integer). (Overrides TBITreePlugin.NodeAt(Integer,Integer).)
ParentOf(TBITreeNode) | Represents method ParentOf(TBITreeNode). (Overrides TBITreePlugin.ParentOf(TBITreeNode).)
SelectedText | Represents method SelectedText. (Overrides TBITreePlugin.SelectedText.)
SetAllowDelete(Boolean) | Represents method SetAllowDelete(Boolean). (Overrides TBITreePlugin.SetAllowDelete(Boolean).)
SetChecked(TBITreeNode,Boolean) | Represents method SetChecked(TBITreeNode,Boolean). (Overrides TBITreePlugin.SetChecked(TBITreeNode,Boolean).)
SetData(TBITreeNode,TObject) | Represents method SetData(TBITreeNode,TObject). (Overrides TBITreePlugin.SetData(TBITreeNode,TObject).)
SetOnChange(TNotifyEvent) | Represents method SetOnChange(TNotifyEvent). (Overrides TBITreePlugin.SetOnChange(TNotifyEvent).)
SetOnCheck(TNotifyEvent) | Represents method SetOnCheck(TNotifyEvent). (Overrides TBITreePlugin.SetOnCheck(TNotifyEvent).)
SetOnExpanding(TBITreeExpandingEvent) | Represents method SetOnExpanding(TBITreeExpandingEvent). (Overrides TBITreePlugin.SetOnExpanding(TBITreeExpandingEvent).)
SetSelected(TBITreeNode) | Represents method SetSelected(TBITreeNode). (Overrides TBITreePlugin.SetSelected(TBITreeNode).)
SetText(TBITreeNode,String) | Represents method SetText(TBITreeNode,String). (Overrides TBITreePlugin.SetText(TBITreeNode,String).)
SiblingIndex(TBITreeNode) | Represents method SiblingIndex(TBITreeNode). (Overrides TBITreePlugin.SiblingIndex(TBITreeNode).)
TextOf(TBITreeNode) | Represents method TextOf(TBITreeNode). (Overrides TBITreePlugin.TextOf(TBITreeNode).)
Top
See Also

Reference

  • FMXBI.Tree.TreeView


TBITreeViewPlugin Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBITreeViewPlugin class. (Overrides TBITreePlugin.Create(TComponent).)
Top


TBITreeViewPlugin.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBITreeViewPlugin class.

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TBITreePlugin.Create(TComponent)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin Methods

Methods
Name | Description
BeginUpdating | Represents method BeginUpdating. (Overrides TBITreePlugin.BeginUpdating.)
Children(TBITreeNode,Integer) | Represents method Children(TBITreeNode,Integer). (Overrides TBITreePlugin.Children(TBITreeNode,Integer).)
ChildrenCount(TBITreeNode) | Represents method ChildrenCount(TBITreeNode). (Overrides TBITreePlugin.ChildrenCount(TBITreeNode).)
Clear(TBITreeNode) | Represents method Clear(TBITreeNode). (Overrides TBITreePlugin.Clear(TBITreeNode).)
ClearData(TBITreeNode) | Represents method ClearData(TBITreeNode). (Overrides TBITreePlugin.ClearData(TBITreeNode).)
DataOf(TBITreeNode) | Represents method DataOf(TBITreeNode). (Overrides TBITreePlugin.DataOf(TBITreeNode).)
EndUpdating | Represents method EndUpdating. (Overrides TBITreePlugin.EndUpdating.)
Expand(Integer) | Represents method Expand(Integer). (Overrides TBITreePlugin.Expand(Integer).)
Expand(TBITreeNode,Boolean,Boolean) | Represents method Expand(TBITreeNode,Boolean,Boolean). (Overrides TBITreePlugin.Expand(TBITreeNode,Boolean,Boolean).)
Find(TObject,Integer) | Represents method Find(TObject,Integer). (Overrides TBITreePlugin.Find(TObject,Integer).)
FirstNode | Represents method FirstNode. (Overrides TBITreePlugin.FirstNode.)
GetAllowDelete | Represents method GetAllowDelete. (Overrides TBITreePlugin.GetAllowDelete.)
GetControl | Represents method GetControl. (Overrides TBITreePlugin.GetControl.)
GetCount | Represents method GetCount. (Overrides TBITreePlugin.GetCount.)
GetNode(Integer) | Represents method GetNode(Integer). (Overrides TBITreePlugin.GetNode(Integer).)
GetOnChange | Represents method GetOnChange. (Overrides TBITreePlugin.GetOnChange.)
GetOnCheck | Represents method GetOnCheck. (Overrides TBITreePlugin.GetOnCheck.)
GetOnExpanding | Represents method GetOnExpanding. (Overrides TBITreePlugin.GetOnExpanding.)
GetSelected | Represents method GetSelected. (Overrides TBITreePlugin.GetSelected.)
GetSelectedData | Represents method GetSelectedData. (Overrides TBITreePlugin.GetSelectedData.)
IsChecked(TBITreeNode) | Represents method IsChecked(TBITreeNode). (Overrides TBITreePlugin.IsChecked(TBITreeNode).)
IsExpanded(TBITreeNode) | Represents method IsExpanded(TBITreeNode). (Overrides TBITreePlugin.IsExpanded(TBITreeNode).)
NewNode(TBITreeNode,String,TObject,TInteger) | Represents method NewNode(TBITreeNode,String,TObject,TInteger). (Overrides TBITreePlugin.NewNode(TBITreeNode,String,TObject,TInteger).)
NextNode(TBITreeNode) | Represents method NextNode(TBITreeNode). (Overrides TBITreePlugin.NextNode(TBITreeNode).)
NodeAt(Integer,Integer) | Represents method NodeAt(Integer,Integer). (Overrides TBITreePlugin.NodeAt(Integer,Integer).)
ParentOf(TBITreeNode) | Represents method ParentOf(TBITreeNode). (Overrides TBITreePlugin.ParentOf(TBITreeNode).)
SelectedText | Represents method SelectedText. (Overrides TBITreePlugin.SelectedText.)
SetAllowDelete(Boolean) | Represents method SetAllowDelete(Boolean). (Overrides TBITreePlugin.SetAllowDelete(Boolean).)
SetChecked(TBITreeNode,Boolean) | Represents method SetChecked(TBITreeNode,Boolean). (Overrides TBITreePlugin.SetChecked(TBITreeNode,Boolean).)
SetData(TBITreeNode,TObject) | Represents method SetData(TBITreeNode,TObject). (Overrides TBITreePlugin.SetData(TBITreeNode,TObject).)
SetOnChange(TNotifyEvent) | Represents method SetOnChange(TNotifyEvent). (Overrides TBITreePlugin.SetOnChange(TNotifyEvent).)
SetOnCheck(TNotifyEvent) | Represents method SetOnCheck(TNotifyEvent). (Overrides TBITreePlugin.SetOnCheck(TNotifyEvent).)
SetOnExpanding(TBITreeExpandingEvent) | Represents method SetOnExpanding(TBITreeExpandingEvent). (Overrides TBITreePlugin.SetOnExpanding(TBITreeExpandingEvent).)
SetSelected(TBITreeNode) | Represents method SetSelected(TBITreeNode). (Overrides TBITreePlugin.SetSelected(TBITreeNode).)
SetText(TBITreeNode,String) | Represents method SetText(TBITreeNode,String). (Overrides TBITreePlugin.SetText(TBITreeNode,String).)
SiblingIndex(TBITreeNode) | Represents method SiblingIndex(TBITreeNode). (Overrides TBITreePlugin.SiblingIndex(TBITreeNode).)
TextOf(TBITreeNode) | Represents method TextOf(TBITreeNode). (Overrides TBITreePlugin.TextOf(TBITreeNode).)
Top


TBITreeViewPlugin.BeginUpdating Method

Summary

Represents method BeginUpdating.

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
protected
 procedure BeginUpdating; override;

Overrides

TBITreePlugin.BeginUpdating
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.Children(TBITreeNode,Integer) Method

Summary

Represents method Children(TBITreeNode,Integer).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
public
 function Children(const ANode:TBITreeNode; const AIndex:Integer):TBITreeNode; override;

Parameters

ANode
Type: TBITreeNode

AIndex
Type: Integer

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.Children(TBITreeNode,Integer)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.ChildrenCount(TBITreeNode) Method

Summary

Represents method ChildrenCount(TBITreeNode).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
public
 function ChildrenCount(const ANode:TBITreeNode):Integer; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Integer

Overrides

TBITreePlugin.ChildrenCount(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.Clear(TBITreeNode) Method

Summary

Represents method Clear(TBITreeNode).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
protected
 procedure Clear(const ANode:TBITreeNode=nil); override;

Parameters

ANode
Type: TBITreeNode

Overrides

TBITreePlugin.Clear(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.ClearData(TBITreeNode) Method

Summary

Represents method ClearData(TBITreeNode).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
protected
 procedure ClearData(const ANode:TBITreeNode); override;

Parameters

ANode
Type: TBITreeNode

Overrides

TBITreePlugin.ClearData(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.DataOf(TBITreeNode) Method

Summary

Represents method DataOf(TBITreeNode).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
public
 function DataOf(const ANode:TBITreeNode):TObject; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TObject

Overrides

TBITreePlugin.DataOf(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.EndUpdating Method

Summary

Represents method EndUpdating.

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
protected
 procedure EndUpdating; override;

Overrides

TBITreePlugin.EndUpdating
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.Expand(TBITreeNode,Boolean,Boolean) Method

Summary

Represents method Expand(TBITreeNode,Boolean,Boolean).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
public
 procedure Expand(const ANode:TBITreeNode; const DoExpand:Boolean=True; const Recursive:Boolean=False); override;

Parameters

ANode
Type: TBITreeNode

DoExpand
Type: Boolean

Recursive
Type: Boolean

Overrides

TBITreePlugin.Expand(TBITreeNode,Boolean,Boolean)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.Find(TObject,Integer) Method

Summary

Represents method Find(TObject,Integer).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
public
 function Find(const ATag:TObject; const AIndex:Integer):TBITreeNode; override;

Parameters

ATag
Type: TObject

AIndex
Type: Integer

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.Find(TObject,Integer)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.FirstNode Method

Summary

Represents method FirstNode.

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
public
 function FirstNode:TBITreeNode; override;

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.FirstNode
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.GetAllowDelete Method

Summary

Represents method GetAllowDelete.

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
protected
 function GetAllowDelete: Boolean; override;

Return Value

Type: Boolean

Overrides

TBITreePlugin.GetAllowDelete
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.GetControl Method

Summary

Represents method GetControl.

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
protected
 function GetControl:TControl; override;

Return Value

Type: TControl

Overrides

TBITreePlugin.GetControl
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.GetCount Method

Summary

Represents method GetCount.

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
protected
 function GetCount:Integer; override;

Return Value

Type: Integer

Overrides

TBITreePlugin.GetCount
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.GetNode(Integer) Method

Summary

Represents method GetNode(Integer).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
protected
 function GetNode(const AIndex:Integer):TBITreeNode; override;

Parameters

AIndex
Type: Integer

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.GetNode(Integer)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.GetOnChange Method

Summary

Represents method GetOnChange.

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
protected
 function GetOnChange: TNotifyEvent; override;

Return Value

Type: TNotifyEvent

Overrides

TBITreePlugin.GetOnChange
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.GetOnCheck Method

Summary

Represents method GetOnCheck.

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
protected
 function GetOnCheck: TNotifyEvent; override;

Return Value

Type: TNotifyEvent

Overrides

TBITreePlugin.GetOnCheck
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.GetOnExpanding Method

Summary

Represents method GetOnExpanding.

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
protected
 function GetOnExpanding: TBITreeExpandingEvent; override;

Return Value

Type: TBITreeExpandingEvent

Overrides

TBITreePlugin.GetOnExpanding
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.GetSelected Method

Summary

Represents method GetSelected.

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
protected
 function GetSelected:TBITreeNode; override;

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.GetSelected
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.GetSelectedData Method

Summary

Represents method GetSelectedData.

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
protected
 function GetSelectedData:TBITreePlugin.TNodeData; override;

Return Value

Type: TBITreePlugin.TNodeData

Overrides

TBITreePlugin.GetSelectedData
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.IsChecked(TBITreeNode) Method

Summary

Represents method IsChecked(TBITreeNode).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
public
 function IsChecked(const ANode:TBITreeNode):Boolean; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Boolean

Overrides

TBITreePlugin.IsChecked(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.IsExpanded(TBITreeNode) Method

Summary

Represents method IsExpanded(TBITreeNode).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
public
 function IsExpanded(const ANode:TBITreeNode):Boolean; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Boolean

Overrides

TBITreePlugin.IsExpanded(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.NewNode(TBITreeNode,String,TObject,TInteger) Method

Summary

Represents method NewNode(TBITreeNode,String,TObject,TInteger).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
public
 function NewNode(const AParent:TBITreeNode; const AText:String;
 const ATag:TObject=nil;
 const AIndex:TInteger=-1):TBITreeNode; override;

Parameters

AParent
Type: TBITreeNode

AText
Type: String

ATag
Type: TObject

AIndex
Type: System.Void

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.NewNode(TBITreeNode,String,TObject,TInteger)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.NextNode(TBITreeNode) Method

Summary

Represents method NextNode(TBITreeNode).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
public
 function NextNode(const ANode:TBITreeNode):TBITreeNode; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.NextNode(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.NodeAt(Integer,Integer) Method

Summary

Represents method NodeAt(Integer,Integer).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
protected
 function NodeAt(const X,Y:Integer):TBITreeNode; override;

Parameters

X
Type: Integer

Y
Type: Integer

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.NodeAt(Integer,Integer)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.ParentOf(TBITreeNode) Method

Summary

Represents method ParentOf(TBITreeNode).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
public
 function ParentOf(const ANode:TBITreeNode):TBITreeNode; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.ParentOf(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.SelectedText Method

Summary

Represents method SelectedText.

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
protected
 function SelectedText:String; override;

Return Value

Type: String

Overrides

TBITreePlugin.SelectedText
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.SetAllowDelete(Boolean) Method

Summary

Represents method SetAllowDelete(Boolean).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
protected
 procedure SetAllowDelete(const Value: Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBITreePlugin.SetAllowDelete(Boolean)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.SetChecked(TBITreeNode,Boolean) Method

Summary

Represents method SetChecked(TBITreeNode,Boolean).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
public
 procedure SetChecked(const ANode:TBITreeNode; const Value:Boolean); override;

Parameters

ANode
Type: TBITreeNode

Value
Type: Boolean

Overrides

TBITreePlugin.SetChecked(TBITreeNode,Boolean)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.SetData(TBITreeNode,TObject) Method

Summary

Represents method SetData(TBITreeNode,TObject).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
protected
 procedure SetData(const ANode:TBITreeNode; const AData:TObject); override;

Parameters

ANode
Type: TBITreeNode

AData
Type: TObject

Overrides

TBITreePlugin.SetData(TBITreeNode,TObject)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.SetOnChange(TNotifyEvent) Method

Summary

Represents method SetOnChange(TNotifyEvent).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
protected
 procedure SetOnChange(const Value: TNotifyEvent); override;

Parameters

Value
Type: TNotifyEvent

Overrides

TBITreePlugin.SetOnChange(TNotifyEvent)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.SetOnCheck(TNotifyEvent) Method

Summary

Represents method SetOnCheck(TNotifyEvent).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
protected
 procedure SetOnCheck(const Value: TNotifyEvent); override;

Parameters

Value
Type: TNotifyEvent

Overrides

TBITreePlugin.SetOnCheck(TNotifyEvent)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.SetOnExpanding(TBITreeExpandingEvent) Method

Summary

Represents method SetOnExpanding(TBITreeExpandingEvent).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
protected
 procedure SetOnExpanding(const Value: TBITreeExpandingEvent); override;

Parameters

Value
Type: TBITreeExpandingEvent

Overrides

TBITreePlugin.SetOnExpanding(TBITreeExpandingEvent)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.SetSelected(TBITreeNode) Method

Summary

Represents method SetSelected(TBITreeNode).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
protected
 procedure SetSelected(const Value: TBITreeNode); override;

Parameters

Value
Type: TBITreeNode

Overrides

TBITreePlugin.SetSelected(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.SetText(TBITreeNode,String) Method

Summary

Represents method SetText(TBITreeNode,String).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
public
 procedure SetText(const ANode:TBITreeNode; const Value:String); override;

Parameters

ANode
Type: TBITreeNode

Value
Type: String

Overrides

TBITreePlugin.SetText(TBITreeNode,String)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.SiblingIndex(TBITreeNode) Method

Summary

Represents method SiblingIndex(TBITreeNode).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
public
 function SiblingIndex(const ANode:TBITreeNode):Integer; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Integer

Overrides

TBITreePlugin.SiblingIndex(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


TBITreeViewPlugin.TextOf(TBITreeNode) Method

Summary

Represents method TextOf(TBITreeNode).

Namespace: FMXBI.Tree.TreeView
Syntax
Delphi
public
 function TextOf(const ANode:TBITreeNode):String; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: String

Overrides

TBITreePlugin.TextOf(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • FMXBI.Tree.TreeView


FMXBI.Visualizer Namespace

Summary

Represents namespace FMXBI.Visualizer.

Classes
Name | Description
TBIComposer | Represents type TBIComposer.
TGroup | Represents type TGroup.
TGroupProc<T> | Represents type TGroupProc<T>.
TVisualizerItem | Represents type TVisualizerItem.
TVisualizerItems | Represents type TVisualizerItems.
Top
Records
Name | Description
TVisualizerItems.TEnabled | Represents type TEnabled.
Top
Types
Name | Description
TGroupClass | Represents type TGroupClass.
TPageControl | Represents an alias of the TTabControl type.
TWinControl | Represents an alias of the TControl type.
Top


FMXBI.Visualizer Classes

Classes
Name | Description
TBIComposer | Represents type TBIComposer.
TGroup | Represents type TGroup.
TGroupProc<T> | Represents type TGroupProc<T>.
TVisualizerItem | Represents type TVisualizerItem.
TVisualizerItems | Represents type TVisualizerItems.
Top


TBIComposer Class

Summary

Represents type TBIComposer.

Namespace: FMXBI.Visualizer
Inheritance Hierarchy
FMXBI.Visualizer.TBIComposer
FMXBI.Visualizer.Chart.TComposerAccess
See Also

Reference

  • FMXBI.Visualizer


TGroup Class

Summary

Represents type TGroup.

Namespace: FMXBI.Visualizer
Inheritance Hierarchy
FMXBI.Visualizer.TGroup
FMXBI.Visualizer.Chart.TGroupAccess
FMXBI.Visualizer.Chart.TGroupChart
See Also

Reference

  • FMXBI.Visualizer


TGroupProc<T> Class

Summary

Represents type TGroupProc<T>.

Namespace: FMXBI.Visualizer
Inheritance Hierarchy
TObject
FMXBI.Visualizer.TGroupProc<T>
Syntax
Delphi
type
 TGroupProc<T

Type Parameters

T
See Also

Reference

  • FMXBI.Visualizer


TVisualizerItem Class

Summary

Represents type TVisualizerItem.

Namespace: FMXBI.Visualizer
Inheritance Hierarchy
TCollectionItem
FMXBI.Visualizer.TVisualizerItem
Syntax
Delphi
type
 TVisualizerItem=class(TCollectionItem)
 end;

The TVisualizerItem type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TVisualizerItem class.
Destroy | Represents the destructor of the TVisualizerItem class.
Top
Properties
Show:
Name | Description
Enabled | Represents property Enabled.
Selected[TInteger] | Represents property Selected[TInteger].
Top
Methods
Show:
Name | Description
AsString(TInteger) | Represents method AsString(TInteger).
Count | Represents method Count.
IsEnabled | Represents method IsEnabled.
MapToString(TDataItem,TDataMap,TInteger) | Represents method MapToString(TDataItem,TDataMap,TInteger).
Top
Fields
Show:
Name | Description
Current | Represents field Current.
Data | Represents field Data.
GroupBy | Represents field GroupBy.
GroupClass | Represents field GroupClass.
Top
See Also

Reference

  • FMXBI.Visualizer


TVisualizerItem Constructors

Constructors
Name | Description
Create(TCollection) | Initializes a new instance of the TVisualizerItem class.
Destroy | Represents the destructor of the TVisualizerItem class.
Top


TVisualizerItem.Create(TCollection) Constructor

Summary

Initializes a new instance of the TVisualizerItem class.

Namespace: FMXBI.Visualizer
Syntax
Delphi
public
 Constructor Create(Collection:TCollection); override;

Parameters

Collection
Type: TCollection

See Also

Reference

  • TVisualizerItem
  • FMXBI.Visualizer


TVisualizerItem.Destroy Destructor

Summary

Represents the destructor of the TVisualizerItem class.

Namespace: FMXBI.Visualizer
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TVisualizerItem
  • FMXBI.Visualizer


TVisualizerItem Properties

Properties
Name | Description
Enabled | Represents property Enabled.
Selected[TInteger] | Represents property Selected[TInteger].
Top


TVisualizerItem.Enabled Property

Summary

Represents property Enabled.

Namespace: FMXBI.Visualizer
Syntax
Delphi
published
 property Enabled:Boolean read FEnabled write SetEnabled default True;

Property Value

Type: Boolean

See Also

Reference

  • TVisualizerItem
  • FMXBI.Visualizer


TVisualizerItem.Selected[TInteger] Property

Summary

Represents property Selected[TInteger].

Namespace: FMXBI.Visualizer
Syntax
Delphi
public
 property Selected[const Index:TInteger]:Boolean read GetSelected write SetSelected;

Parameters

Index
Type: System.Void

Property Value

Type: Boolean

See Also

Reference

  • TVisualizerItem
  • FMXBI.Visualizer


TVisualizerItem Methods

Methods
Name | Description
AsString(TInteger) | Represents method AsString(TInteger).
Count | Represents method Count.
IsEnabled | Represents method IsEnabled.
MapToString(TDataItem,TDataMap,TInteger) | Represents method MapToString(TDataItem,TDataMap,TInteger).
Top


TVisualizerItem.AsString(TInteger) Method

Summary

Represents method AsString(TInteger).

Namespace: FMXBI.Visualizer
Syntax
Delphi
public
 function AsString(const AIndex:TInteger):String;

Parameters

AIndex
Type: System.Void

Return Value

Type: String

See Also

Reference

  • TVisualizerItem
  • FMXBI.Visualizer


TVisualizerItem.Count Method

Summary

Represents method Count.

Namespace: FMXBI.Visualizer
Syntax
Delphi
public
 function Count:TInteger;

Return Value

Type: TInteger

See Also

Reference

  • TVisualizerItem
  • FMXBI.Visualizer


TVisualizerItem.IsEnabled Method

Summary

Represents method IsEnabled.

Namespace: FMXBI.Visualizer
Syntax
Delphi
public
 function IsEnabled:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TVisualizerItem
  • FMXBI.Visualizer


TVisualizerItem.MapToString(TDataItem,TDataMap,TInteger) Method

Summary

Represents method MapToString(TDataItem,TDataMap,TInteger).

Namespace: FMXBI.Visualizer
Syntax
Delphi
public
 class function MapToString(const AData:TDataItem; const AMap:TDataMap; const APos:TInteger):String; static;

Parameters

AData
Type: TDataItem

AMap
Type: TDataMap

APos
Type: System.Void

Return Value

Type: String

See Also

Reference

  • TVisualizerItem
  • FMXBI.Visualizer


TVisualizerItem Fields

Fields
Name | Description
Current | Represents field Current.
Data | Represents field Data.
GroupBy | Represents field GroupBy.
GroupClass | Represents field GroupClass.
Top


TVisualizerItem.Current Field

Summary

Represents field Current.

Namespace: FMXBI.Visualizer
Syntax
Delphi
public
 Current : TGroup;

Field Value

Type: TGroup

See Also

Reference

  • TVisualizerItem
  • FMXBI.Visualizer


TVisualizerItem.Data Field

Summary

Represents field Data.

Namespace: FMXBI.Visualizer
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TVisualizerItem
  • FMXBI.Visualizer


TVisualizerItem.GroupBy Field

Summary

Represents field GroupBy.

Namespace: FMXBI.Visualizer
Syntax
Delphi
public
 GroupBy : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TVisualizerItem
  • FMXBI.Visualizer


TVisualizerItem.GroupClass Field

Summary

Represents field GroupClass.

Namespace: FMXBI.Visualizer
Syntax
Delphi
public
 GroupClass : TGroupClass;

Field Value

Type: TGroupClass

See Also

Reference

  • TVisualizerItem
  • FMXBI.Visualizer


TVisualizerItems Class

Summary

Represents type TVisualizerItems.

Namespace: FMXBI.Visualizer
Inheritance Hierarchy
TOwnedCollection
FMXBI.Visualizer.TVisualizerItems
Syntax
Delphi
type
 TVisualizerItems=class(TOwnedCollection)
 end;

The TVisualizerItems type exposes the following members.

Constructors
Show:
Name | Description
Create(TPersistent) | Initializes a new instance of the TVisualizerItems class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Add(TDataItem) | Represents method Add(TDataItem).
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer).
Top
Fields
Show:
Name | Description
Enabled | Represents field Enabled.
Top
See Also

Reference

  • FMXBI.Visualizer


TVisualizerItems Constructors

Constructors
Name | Description
Create(TPersistent) | Initializes a new instance of the TVisualizerItems class.
Top


TVisualizerItems.Create(TPersistent) Constructor

Summary

Initializes a new instance of the TVisualizerItems class.

Namespace: FMXBI.Visualizer
Syntax
Delphi
public
 Constructor Create(AOwner: TPersistent);

Parameters

AOwner
Type: TPersistent

See Also

Reference

  • TVisualizerItems
  • FMXBI.Visualizer


TVisualizerItems Properties

Properties
Name | Description
Items[Integer] | Represents property Items[Integer].
Top


TVisualizerItems.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: FMXBI.Visualizer
Syntax
Delphi
public
 property Items[const Index:Integer]:TVisualizerItem read GetItem write SetItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TVisualizerItem

See Also

Reference

  • TVisualizerItems
  • FMXBI.Visualizer


TVisualizerItems Methods

Methods
Name | Description
Add(TDataItem) | Represents method Add(TDataItem).
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer).
Top


TVisualizerItems.Add(TDataItem) Method

Summary

Represents method Add(TDataItem).

Namespace: FMXBI.Visualizer
Syntax
Delphi
public
 function Add(const AData:TDataItem):TVisualizerItem;

Parameters

AData
Type: TDataItem

Return Value

Type: TVisualizerItem

See Also

Reference

  • TVisualizerItems
  • FMXBI.Visualizer


TVisualizerItems.Exchange(Integer,Integer) Method

Summary

Represents method Exchange(Integer,Integer).

Namespace: FMXBI.Visualizer
Syntax
Delphi
public
 procedure Exchange(const A,B:Integer);

Parameters

A
Type: Integer

B
Type: Integer

See Also

Reference

  • TVisualizerItems
  • FMXBI.Visualizer


TVisualizerItems Fields

Fields
Name | Description
Enabled | Represents field Enabled.
Top


TVisualizerItems.Enabled Field

Summary

Represents field Enabled.

Namespace: FMXBI.Visualizer
Syntax
Delphi
public
 Enabled : TEnabled;

Field Value

Type: TEnabled

See Also

Reference

  • TVisualizerItems
  • FMXBI.Visualizer


FMXBI.Visualizer Records

Records
Name | Description
TVisualizerItems.TEnabled | Represents type TEnabled.
Top


TVisualizerItems.TEnabled Record

Summary

Represents type TEnabled.

Namespace: FMXBI.Visualizer
Syntax
Delphi
public
type
 TEnabled=record
 end;

The TVisualizerItems.TEnabled type exposes the following members.

Methods
Show:
Name | Description
Count | Represents method Count.
First | Overloaded. Represents method First.
First(Integer) | Overloaded. Represents method First(Integer).
Last | Represents method Last.
Top
See Also

Reference

  • TVisualizerItems
  • FMXBI.Visualizer


TVisualizerItems.TEnabled Methods

Methods
Name | Description
Count | Represents method Count.
First | Overloaded. Represents method First.
First(Integer) | Overloaded. Represents method First(Integer).
Last | Represents method Last.
Top


TVisualizerItems.TEnabled.Count Method

Summary

Represents method Count.

Namespace: FMXBI.Visualizer
Syntax
Delphi
public
 function Count:Integer;

Return Value

Type: Integer

See Also

Reference

  • TVisualizerItems.TEnabled
  • TVisualizerItems
  • FMXBI.Visualizer


TVisualizerItems.TEnabled.First Method

Summary

Represents method First.

Namespace: FMXBI.Visualizer
Syntax
Delphi
public
 function First:Integer; overload;

Return Value

Type: Integer

See Also

Reference

  • TVisualizerItems.TEnabled
  • TVisualizerItems
  • FMXBI.Visualizer


TVisualizerItems.TEnabled.First(Integer) Method

Summary

Represents method First(Integer).

Namespace: FMXBI.Visualizer
Syntax
Delphi
public
 function First(const Start:Integer):Integer; overload;

Parameters

Start
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TVisualizerItems.TEnabled
  • TVisualizerItems
  • FMXBI.Visualizer


TVisualizerItems.TEnabled.Last Method

Summary

Represents method Last.

Namespace: FMXBI.Visualizer
Syntax
Delphi
public
 function Last:Integer;

Return Value

Type: Integer

See Also

Reference

  • TVisualizerItems.TEnabled
  • TVisualizerItems
  • FMXBI.Visualizer


FMXBI.Visualizer Types

Types
Name | Description
TGroupClass | Represents type TGroupClass.
TPageControl | Represents an alias of the TTabControl type.
TWinControl | Represents an alias of the TControl type.
Top


TGroupClass Type

Summary

Represents type TGroupClass.

Namespace: FMXBI.Visualizer
Syntax
Delphi
type
 TGroupClass=class of TGroup;
See Also

Reference

  • FMXBI.Visualizer


TPageControl Type

Summary

Represents an alias of the TTabControl type.

Namespace: FMXBI.Visualizer
Syntax
Delphi
type
 TPageControl=TTabControl;
See Also

Reference

  • FMXBI.Visualizer


TWinControl Type

Summary

Represents an alias of the TControl type.

Namespace: FMXBI.Visualizer
Syntax
Delphi
type
 TWinControl=TControl;
See Also

Reference

  • FMXBI.Visualizer


FMXBI.Visualizer.Chart Namespace

Summary

Represents namespace FMXBI.Visualizer.Chart.

Classes
Name | Description
TComposerAccess | Represents type TComposerAccess.
TCustomSeriesAccess | Represents type TCustomSeriesAccess.
TGroupAccess | Represents type TGroupAccess.
TGroupChart | Represents type TGroupChart.
TGroupChartOptions | Represents type TGroupChartOptions.
TGroupSeries | Represents type TGroupSeries.
TGroupSeriesOptions | Represents type TGroupSeriesOptions.
Top
Records
Name | Description
TBIChartComposerUI | Represents type TBIChartComposerUI.
TSeriesData | Represents type TSeriesData.
Top
Enumerations
Name | Description
TAutoStackSeries | Represents type TAutoStackSeries.
TBIMultiAxis | Represents type TBIMultiAxis.
TGroupSeriesStyle | Represents type TGroupSeriesStyle.
Top
Types
Name | Description
TChartProc | Represents type TChartProc.
TWinControl | Represents an alias of the TControl type.
Top
Routines
Name | Description
AddSettingsButton(TWinControl) | Represents method AddSettingsButton(TWinControl).
IsNumericOrDateTime(TDataItem) | Represents method IsNumericOrDateTime(TDataItem).
MandatoryAxis(TChartSeries) | Represents method MandatoryAxis(TChartSeries).
NotMandatoryAxis(TChartSeries) | Represents method NotMandatoryAxis(TChartSeries).
SetColorEach(TChartSeries) | Represents method SetColorEach(TChartSeries).
TeeBIGetCursorPos | Represents method TeeBIGetCursorPos.
TraverseChart(TCustomChart,TChartProc) | Represents method TraverseChart(TCustomChart,TChartProc).
TryChangeSeriesStyle(TChartSeries) | Represents method TryChangeSeriesStyle(TChartSeries).
Top


FMXBI.Visualizer.Chart Classes

Classes
Name | Description
TComposerAccess | Represents type TComposerAccess.
TCustomSeriesAccess | Represents type TCustomSeriesAccess.
TGroupAccess | Represents type TGroupAccess.
TGroupChart | Represents type TGroupChart.
TGroupChartOptions | Represents type TGroupChartOptions.
TGroupSeries | Represents type TGroupSeries.
TGroupSeriesOptions | Represents type TGroupSeriesOptions.
Top


TComposerAccess Class

Summary

Represents type TComposerAccess.

Namespace: FMXBI.Visualizer.Chart
Inheritance Hierarchy
FMXBI.Visualizer.TBIComposer
FMXBI.Visualizer.Chart.TComposerAccess
Syntax
Delphi
type
 TComposerAccess=class(TBIComposer);
See Also

Reference

  • FMXBI.Visualizer.Chart


TCustomSeriesAccess Class

Summary

Represents type TCustomSeriesAccess.

Namespace: FMXBI.Visualizer.Chart
Inheritance Hierarchy
TCustomSeries
FMXBI.Visualizer.Chart.TCustomSeriesAccess
Syntax
Delphi
type
 TCustomSeriesAccess=class(TCustomSeries);
See Also

Reference

  • FMXBI.Visualizer.Chart


TGroupAccess Class

Summary

Represents type TGroupAccess.

Namespace: FMXBI.Visualizer.Chart
Inheritance Hierarchy
FMXBI.Visualizer.TGroup
FMXBI.Visualizer.Chart.TGroupAccess
Syntax
Delphi
type
 TGroupAccess=class(TGroup);
See Also

Reference

  • FMXBI.Visualizer.Chart


TGroupChart Class

Summary

Represents type TGroupChart.

Namespace: FMXBI.Visualizer.Chart
Inheritance Hierarchy
FMXBI.Visualizer.TGroup
FMXBI.Visualizer.Chart.TGroupChart
FMXBI.Visualizer.Chart.TGroupSeries
Syntax
Delphi
type
 TGroupChart=class(TGroup)
 end;

The TGroupChart type exposes the following members.

Constructors
Show:
Name | Description
CreateData(TVisualizerItem,TGroup) | Initializes a new instance of the TGroupChart class.
Destroy | Represents the destructor of the TGroupChart class.
Top
Properties
Show:
Name | Description
Chart | Represents property Chart.
Group | Represents property Group.
Options | Represents property Options.
Top
Methods
Show:
Name | Description
Add(TInteger) | Represents method Add(TInteger).
AddItem | Represents method AddItem.
ApplyTemplate | Overloaded. Represents method ApplyTemplate.
ApplyTemplate(TCustomChart,TCustomChart) | Overloaded. Represents method ApplyTemplate(TCustomChart,TCustomChart).
Assign(TPersistent) | Represents method Assign(TPersistent).
ChartResized(TObject) | Represents method ChartResized(TObject).
Finished | Represents method Finished.
Init | Represents method Init.
SetAxisTitle(TChartSeries,TDataItem) | Represents method SetAxisTitle(TChartSeries,TDataItem).
Top
See Also

Reference

  • FMXBI.Visualizer.Chart


TGroupChart Constructors

Constructors
Name | Description
CreateData(TVisualizerItem,TGroup) | Initializes a new instance of the TGroupChart class.
Destroy | Represents the destructor of the TGroupChart class.
Top


TGroupChart.CreateData(TVisualizerItem,TGroup) Constructor

Summary

Initializes a new instance of the TGroupChart class.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 Constructor CreateData(const AItem:TVisualizerItem; const AParent:TGroup); override;

Parameters

AItem
Type: TVisualizerItem

AParent
Type: TGroup

See Also

Reference

  • TGroupChart
  • FMXBI.Visualizer.Chart


TGroupChart.Destroy Destructor

Summary

Represents the destructor of the TGroupChart class.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TGroupChart
  • FMXBI.Visualizer.Chart


TGroupChart Properties

Properties
Name | Description
Chart | Represents property Chart.
Group | Represents property Group.
Options | Represents property Options.
Top


TGroupChart.Chart Property

Summary

Represents property Chart.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 property Chart:TBIChart read FChart;

Property Value

Type: TBIChart

See Also

Reference

  • TGroupChart
  • FMXBI.Visualizer.Chart


TGroupChart.Group Property

Summary

Represents property Group.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 property Group:TGroupChart read IParent;

Property Value

Type: TGroupChart

See Also

Reference

  • TGroupChart
  • FMXBI.Visualizer.Chart


TGroupChart.Options Property

Summary

Represents property Options.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
published
 property Options:TGroupChartOptions read FOptions;

Property Value

Type: TGroupChartOptions

See Also

Reference

  • TGroupChart
  • FMXBI.Visualizer.Chart


TGroupChart Methods

Methods
Name | Description
Add(TInteger) | Represents method Add(TInteger).
AddItem | Represents method AddItem.
ApplyTemplate | Overloaded. Represents method ApplyTemplate.
ApplyTemplate(TCustomChart,TCustomChart) | Overloaded. Represents method ApplyTemplate(TCustomChart,TCustomChart).
Assign(TPersistent) | Represents method Assign(TPersistent).
ChartResized(TObject) | Represents method ChartResized(TObject).
Finished | Represents method Finished.
Init | Represents method Init.
SetAxisTitle(TChartSeries,TDataItem) | Represents method SetAxisTitle(TChartSeries,TDataItem).
Top


TGroupChart.Add(TInteger) Method

Summary

Represents method Add(TInteger).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 procedure Add(const AIndex:TInteger); override;

Parameters

AIndex
Type: System.Void

See Also

Reference

  • TGroupChart
  • FMXBI.Visualizer.Chart


TGroupChart.AddItem Method

Summary

Represents method AddItem.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
protected
 function AddItem:TComponent; virtual;

Return Value

Type: TComponent

See Also

Reference

  • TGroupChart
  • FMXBI.Visualizer.Chart


TGroupChart.ApplyTemplate Method

Summary

Represents method ApplyTemplate.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 procedure ApplyTemplate; overload;
See Also

Reference

  • TGroupChart
  • FMXBI.Visualizer.Chart


TGroupChart.ApplyTemplate(TCustomChart,TCustomChart) Method

Summary

Represents method ApplyTemplate(TCustomChart,TCustomChart).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
protected
 procedure ApplyTemplate(const AChart,ATemplate:TCustomChart); overload; virtual;

Parameters

AChart
Type: TCustomChart

ATemplate
Type: TCustomChart

See Also

Reference

  • TGroupChart
  • FMXBI.Visualizer.Chart


TGroupChart.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TGroupChart
  • FMXBI.Visualizer.Chart


TGroupChart.ChartResized(TObject) Method

Summary

Represents method ChartResized(TObject).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
protected
 procedure ChartResized(Sender:TObject); virtual;

Parameters

Sender
Type: TObject

See Also

Reference

  • TGroupChart
  • FMXBI.Visualizer.Chart


TGroupChart.Finished Method

Summary

Represents method Finished.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
protected
 procedure Finished; override;
See Also

Reference

  • TGroupChart
  • FMXBI.Visualizer.Chart


TGroupChart.Init Method

Summary

Represents method Init.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
protected
 procedure Init; override;
See Also

Reference

  • TGroupChart
  • FMXBI.Visualizer.Chart


TGroupChart.SetAxisTitle(TChartSeries,TDataItem) Method

Summary

Represents method SetAxisTitle(TChartSeries,TDataItem).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
protected
 class procedure SetAxisTitle(const ASeries:TChartSeries; const AData:TDataItem); static;

Parameters

ASeries
Type: TChartSeries

AData
Type: TDataItem

See Also

Reference

  • TGroupChart
  • FMXBI.Visualizer.Chart


TGroupChartOptions Class

Summary

Represents type TGroupChartOptions.

Namespace: FMXBI.Visualizer.Chart
Inheritance Hierarchy
TPersistent
FMXBI.Visualizer.Chart.TGroupChartOptions
Syntax
Delphi
type
 TGroupChartOptions=class(TPersistent)
 end;

The TGroupChartOptions type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TGroupChartOptions class.
Destroy | Represents the destructor of the TGroupChartOptions class.
Top
Properties
Show:
Name | Description
Legend | Represents property Legend.
Marks | Represents property Marks.
MultiAxes | Represents property MultiAxes.
Render | Represents property Render.
Settings | Represents property Settings.
Template | Represents property Template.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
See Also

Reference

  • FMXBI.Visualizer.Chart


TGroupChartOptions Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TGroupChartOptions class.
Destroy | Represents the destructor of the TGroupChartOptions class.
Top


TGroupChartOptions.Create Constructor

Summary

Initializes a new instance of the TGroupChartOptions class.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 Constructor Create;
See Also

Reference

  • TGroupChartOptions
  • FMXBI.Visualizer.Chart


TGroupChartOptions.Destroy Destructor

Summary

Represents the destructor of the TGroupChartOptions class.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TGroupChartOptions
  • FMXBI.Visualizer.Chart


TGroupChartOptions Properties

Properties
Name | Description
Legend | Represents property Legend.
Marks | Represents property Marks.
MultiAxes | Represents property MultiAxes.
Render | Represents property Render.
Settings | Represents property Settings.
Template | Represents property Template.
Top


TGroupChartOptions.Legend Property

Summary

Represents property Legend.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
published
 property Legend:Boolean read GetLegend write SetLegend default True;

Property Value

Type: Boolean

See Also

Reference

  • TGroupChartOptions
  • FMXBI.Visualizer.Chart


TGroupChartOptions.Marks Property

Summary

Represents property Marks.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
published
 property Marks:Boolean read GetMarks write SetMarks;

Property Value

Type: Boolean

See Also

Reference

  • TGroupChartOptions
  • FMXBI.Visualizer.Chart


TGroupChartOptions.MultiAxes Property

Summary

Represents property MultiAxes.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
published
 property MultiAxes:TBIMultiAxis read FMultiAxes write SetMultiAxes default TBIMultiAxis.Automatic;

Property Value

Type: TBIMultiAxis

See Also

Reference

  • TGroupChartOptions
  • FMXBI.Visualizer.Chart


TGroupChartOptions.Render Property

Summary

Represents property Render.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
published
 property Render:TCanvas3DClass read FRender write SetRender;

Property Value

Type: TCanvas3DClass

See Also

Reference

  • TGroupChartOptions
  • FMXBI.Visualizer.Chart


TGroupChartOptions.Settings Property

Summary

Represents property Settings.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
published
 property Settings:Boolean read FSettings write SetSettings default True;

Property Value

Type: Boolean

See Also

Reference

  • TGroupChartOptions
  • FMXBI.Visualizer.Chart


TGroupChartOptions.Template Property

Summary

Represents property Template.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
published
 property Template:TChart read GetTemplate write SetTemplate;

Property Value

Type: TChart

See Also

Reference

  • TGroupChartOptions
  • FMXBI.Visualizer.Chart


TGroupChartOptions Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TGroupChartOptions.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TGroupChartOptions
  • FMXBI.Visualizer.Chart


TGroupSeries Class

Summary

Represents type TGroupSeries.

Namespace: FMXBI.Visualizer.Chart
Inheritance Hierarchy
FMXBI.Visualizer.TGroup
FMXBI.Visualizer.Chart.TGroupChart
FMXBI.Visualizer.Chart.TGroupSeries
Syntax
Delphi
type
 TGroupSeries=class(TGroupChart)
 end;

The TGroupSeries type exposes the following members.

Constructors
Show:
Name | Description
CreateData(TVisualizerItem,TGroup) | Initializes a new instance of the TGroupSeries class. (Overrides TGroupChart.CreateData(TVisualizerItem,TGroup).)
Destroy | Represents the destructor of the TGroupSeries class. (Overrides TGroupChart.Destroy.)
Top
Properties
Show:
Name | Description
Options | Represents property Options.
Top
Methods
Show:
Name | Description
AddValues(TComponent,TVisualizerItems,TVisualizerItem,TCursorIndex) | Represents method AddValues(TComponent,TVisualizerItems,TVisualizerItem,TCursorIndex).
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TGroupChart.Assign(TPersistent).)
BestControl(Integer,Integer,Integer) | Represents method BestControl(Integer,Integer,Integer).
Finished | Represents method Finished. (Overrides TGroupChart.Finished.)
Top
See Also

Reference

  • FMXBI.Visualizer.Chart


TGroupSeries Constructors

Constructors
Name | Description
CreateData(TVisualizerItem,TGroup) | Initializes a new instance of the TGroupSeries class. (Overrides TGroupChart.CreateData(TVisualizerItem,TGroup).)
Destroy | Represents the destructor of the TGroupSeries class. (Overrides TGroupChart.Destroy.)
Top


TGroupSeries.CreateData(TVisualizerItem,TGroup) Constructor

Summary

Initializes a new instance of the TGroupSeries class.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 Constructor CreateData(const AItem:TVisualizerItem; const AParent:TGroup); override;

Parameters

AItem
Type: TVisualizerItem

AParent
Type: TGroup

Overrides

TGroupChart.CreateData(TVisualizerItem,TGroup)
See Also

Reference

  • TGroupSeries
  • FMXBI.Visualizer.Chart


TGroupSeries.Destroy Destructor

Summary

Represents the destructor of the TGroupSeries class.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TGroupChart.Destroy
See Also

Reference

  • TGroupSeries
  • FMXBI.Visualizer.Chart


TGroupSeries Properties

Properties
Name | Description
Options | Represents property Options.
Top


TGroupSeries.Options Property

Summary

Represents property Options.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
published
 property Options:TGroupSeriesOptions read FSeriesOptions write SetOptions;

Property Value

Type: TGroupSeriesOptions

See Also

Reference

  • TGroupSeries
  • FMXBI.Visualizer.Chart


TGroupSeries Methods

Methods
Name | Description
AddValues(TComponent,TVisualizerItems,TVisualizerItem,TCursorIndex) | Represents method AddValues(TComponent,TVisualizerItems,TVisualizerItem,TCursorIndex).
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TGroupChart.Assign(TPersistent).)
BestControl(Integer,Integer,Integer) | Represents method BestControl(Integer,Integer,Integer).
Finished | Represents method Finished. (Overrides TGroupChart.Finished.)
Top


TGroupSeries.AddValues(TComponent,TVisualizerItems,TVisualizerItem,TCursorIndex) Method

Summary

Represents method AddValues(TComponent,TVisualizerItems,TVisualizerItem,TCursorIndex).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 procedure AddValues(const AComponent:TComponent;
 const Values:TVisualizerItems;
 const AGroup:TVisualizerItem;
 const ARows:TCursorIndex); override;

Parameters

AComponent
Type: TComponent

Values
Type: TVisualizerItems

AGroup
Type: TVisualizerItem

ARows
Type: System.Void

See Also

Reference

  • TGroupSeries
  • FMXBI.Visualizer.Chart


TGroupSeries.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TGroupChart.Assign(TPersistent)
See Also

Reference

  • TGroupSeries
  • FMXBI.Visualizer.Chart


TGroupSeries.BestControl(Integer,Integer,Integer) Method

Summary

Represents method BestControl(Integer,Integer,Integer).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 class function BestControl(const AIndex,ATotal,AValues:Integer):TGroupClass; override;

Parameters

AIndex
Type: Integer

ATotal
Type: Integer

AValues
Type: Integer

Return Value

Type: TGroupClass

See Also

Reference

  • TGroupSeries
  • FMXBI.Visualizer.Chart


TGroupSeries.Finished Method

Summary

Represents method Finished.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
protected
 procedure Finished; override;

Overrides

TGroupChart.Finished
See Also

Reference

  • TGroupSeries
  • FMXBI.Visualizer.Chart


TGroupSeriesOptions Class

Summary

Represents type TGroupSeriesOptions.

Namespace: FMXBI.Visualizer.Chart
Inheritance Hierarchy
TPersistent
FMXBI.Visualizer.Chart.TGroupSeriesOptions
Syntax
Delphi
type
 TGroupSeriesOptions=class(TPersistent)
 end;

The TGroupSeriesOptions type exposes the following members.

Constructors
Show:
Name | Description
Create(TGroupSeries) | Initializes a new instance of the TGroupSeriesOptions class.
Top
Properties
Show:
Name | Description
AddNulls | Represents property AddNulls.
AutoStack | Represents property AutoStack.
Series2D | Represents property Series2D.
Series3D | Represents property Series3D.
Style | Represents property Style.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
See Also

Reference

  • FMXBI.Visualizer.Chart


TGroupSeriesOptions Constructors

Constructors
Name | Description
Create(TGroupSeries) | Initializes a new instance of the TGroupSeriesOptions class.
Top


TGroupSeriesOptions.Create(TGroupSeries) Constructor

Summary

Initializes a new instance of the TGroupSeriesOptions class.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 Constructor Create(const AParent:TGroupSeries);

Parameters

AParent
Type: TGroupSeries

See Also

Reference

  • TGroupSeriesOptions
  • FMXBI.Visualizer.Chart


TGroupSeriesOptions Properties

Properties
Name | Description
AddNulls | Represents property AddNulls.
AutoStack | Represents property AutoStack.
Series2D | Represents property Series2D.
Series3D | Represents property Series3D.
Style | Represents property Style.
Top


TGroupSeriesOptions.AddNulls Property

Summary

Represents property AddNulls.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
published
 property AddNulls:Boolean read FAddNulls write SetAddNulls default True;

Property Value

Type: Boolean

See Also

Reference

  • TGroupSeriesOptions
  • FMXBI.Visualizer.Chart


TGroupSeriesOptions.AutoStack Property

Summary

Represents property AutoStack.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
published
 property AutoStack:TAutoStackSeries read FAutoStack write SetAutoStack default TAutoStackSeries.Automatic;

Property Value

Type: TAutoStackSeries

See Also

Reference

  • TGroupSeriesOptions
  • FMXBI.Visualizer.Chart


TGroupSeriesOptions.Series2D Property

Summary

Represents property Series2D.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 property Series2D:TChartSeriesClass read FSeries2D write SetSeries2D;

Property Value

Type: TChartSeriesClass

See Also

Reference

  • TGroupSeriesOptions
  • FMXBI.Visualizer.Chart


TGroupSeriesOptions.Series3D Property

Summary

Represents property Series3D.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 property Series3D:TChartSeriesClass read FSeries3D write SetSeries3D;

Property Value

Type: TChartSeriesClass

See Also

Reference

  • TGroupSeriesOptions
  • FMXBI.Visualizer.Chart


TGroupSeriesOptions.Style Property

Summary

Represents property Style.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
published
 property Style:TGroupSeriesStyle read FStyle write SetStyle default TGroupSeriesStyle.Automatic;

Property Value

Type: TGroupSeriesStyle

See Also

Reference

  • TGroupSeriesOptions
  • FMXBI.Visualizer.Chart


TGroupSeriesOptions Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top


TGroupSeriesOptions.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TGroupSeriesOptions
  • FMXBI.Visualizer.Chart


FMXBI.Visualizer.Chart Records

Records
Name | Description
TBIChartComposerUI | Represents type TBIChartComposerUI.
TSeriesData | Represents type TSeriesData.
Top


TBIChartComposerUI Record

Summary

Represents type TBIChartComposerUI.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
type
 TBIChartComposerUI=record
 end;

The TBIChartComposerUI type exposes the following members.

Methods
Show:
Name | Description
CurrentSeriesClass(TComboBox) | Represents method CurrentSeriesClass(TComboBox).
Fill2DSeries(TStrings) | Represents method Fill2DSeries(TStrings).
Fill3DSeries(TStrings) | Represents method Fill3DSeries(TStrings).
FindSeries(TStrings,TChartSeriesClass) | Represents method FindSeries(TStrings,TChartSeriesClass).
GetChart(Integer) | Represents method GetChart(Integer).
GetSeries(Integer) | Represents method GetSeries(Integer).
Top
Fields
Show:
Name | Description
Viz | Represents field Viz.
Top
See Also

Reference

  • FMXBI.Visualizer.Chart


TBIChartComposerUI Methods

Methods
Name | Description
CurrentSeriesClass(TComboBox) | Represents method CurrentSeriesClass(TComboBox).
Fill2DSeries(TStrings) | Represents method Fill2DSeries(TStrings).
Fill3DSeries(TStrings) | Represents method Fill3DSeries(TStrings).
FindSeries(TStrings,TChartSeriesClass) | Represents method FindSeries(TStrings,TChartSeriesClass).
GetChart(Integer) | Represents method GetChart(Integer).
GetSeries(Integer) | Represents method GetSeries(Integer).
Top


TBIChartComposerUI.CurrentSeriesClass(TComboBox) Method

Summary

Represents method CurrentSeriesClass(TComboBox).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 class function CurrentSeriesClass(const AItems:TComboBox):TChartSeriesClass; static;

Parameters

AItems
Type: TComboBox

Return Value

Type: TChartSeriesClass

See Also

Reference

  • TBIChartComposerUI
  • FMXBI.Visualizer.Chart


TBIChartComposerUI.Fill2DSeries(TStrings) Method

Summary

Represents method Fill2DSeries(TStrings).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 class procedure Fill2DSeries(const AItems:TStrings); static;

Parameters

AItems
Type: TStrings

See Also

Reference

  • TBIChartComposerUI
  • FMXBI.Visualizer.Chart


TBIChartComposerUI.Fill3DSeries(TStrings) Method

Summary

Represents method Fill3DSeries(TStrings).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 class procedure Fill3DSeries(const AItems:TStrings); static;

Parameters

AItems
Type: TStrings

See Also

Reference

  • TBIChartComposerUI
  • FMXBI.Visualizer.Chart


TBIChartComposerUI.FindSeries(TStrings,TChartSeriesClass) Method

Summary

Represents method FindSeries(TStrings,TChartSeriesClass).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 class function FindSeries(const AItems:TStrings; const AClass:TChartSeriesClass):Integer; static;

Parameters

AItems
Type: TStrings

AClass
Type: TChartSeriesClass

Return Value

Type: Integer

See Also

Reference

  • TBIChartComposerUI
  • FMXBI.Visualizer.Chart


TBIChartComposerUI.GetChart(Integer) Method

Summary

Represents method GetChart(Integer).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 function GetChart(const AIndex:Integer):TGroupChart;

Parameters

AIndex
Type: Integer

Return Value

Type: TGroupChart

See Also

Reference

  • TBIChartComposerUI
  • FMXBI.Visualizer.Chart


TBIChartComposerUI.GetSeries(Integer) Method

Summary

Represents method GetSeries(Integer).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 function GetSeries(const AIndex:Integer):TGroupSeries;

Parameters

AIndex
Type: Integer

Return Value

Type: TGroupSeries

See Also

Reference

  • TBIChartComposerUI
  • FMXBI.Visualizer.Chart


TBIChartComposerUI Fields

Fields
Name | Description
Viz | Represents field Viz.
Top


TBIChartComposerUI.Viz Field

Summary

Represents field Viz.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 Viz : TBIComposer;

Field Value

Type: TBIComposer

See Also

Reference

  • TBIChartComposerUI
  • FMXBI.Visualizer.Chart


TSeriesData Record

Summary

Represents type TSeriesData.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
type
 TSeriesData=record
 end;

The TSeriesData type exposes the following members.

Methods
Show:
Name | Description
AddPoint(TInteger,String,Integer,Integer) | Represents method AddPoint(TInteger,String,Integer,Integer).
Top
Fields
Show:
Name | Description
AddNulls | Represents field AddNulls.
Data | Represents field Data.
Series | Represents field Series.
Top
See Also

Reference

  • FMXBI.Visualizer.Chart


TSeriesData Methods

Methods
Name | Description
AddPoint(TInteger,String,Integer,Integer) | Represents method AddPoint(TInteger,String,Integer,Integer).
Top


TSeriesData.AddPoint(TInteger,String,Integer,Integer) Method

Summary

Represents method AddPoint(TInteger,String,Integer,Integer).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 procedure AddPoint(const APos:TInteger; const AText:String; const XPos,ZPos:Integer);

Parameters

APos
Type: System.Void

AText
Type: String

XPos
Type: Integer

ZPos
Type: Integer

See Also

Reference

  • TSeriesData
  • FMXBI.Visualizer.Chart


TSeriesData Fields

Fields
Name | Description
AddNulls | Represents field AddNulls.
Data | Represents field Data.
Series | Represents field Series.
Top


TSeriesData.AddNulls Field

Summary

Represents field AddNulls.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 AddNulls : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TSeriesData
  • FMXBI.Visualizer.Chart


TSeriesData.Data Field

Summary

Represents field Data.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TSeriesData
  • FMXBI.Visualizer.Chart


TSeriesData.Series Field

Summary

Represents field Series.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
public
 Series : TChartSeries;

Field Value

Type: TChartSeries

See Also

Reference

  • TSeriesData
  • FMXBI.Visualizer.Chart


FMXBI.Visualizer.Chart Enumerations

Enumerations
Name | Description
TAutoStackSeries | Represents type TAutoStackSeries.
TBIMultiAxis | Represents type TBIMultiAxis.
TGroupSeriesStyle | Represents type TGroupSeriesStyle.
Top


TAutoStackSeries Enumeration

Summary

Represents type TAutoStackSeries.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
type
 TAutoStackSeries=(Automatic,Yes,Yes100,No);

The TAutoStackSeries type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
No | Represents constant No.
Yes | Represents constant Yes.
Yes100 | Represents constant Yes100.
Top
See Also

Reference

  • FMXBI.Visualizer.Chart


TBIMultiAxis Enumeration

Summary

Represents type TBIMultiAxis.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
type
 TBIMultiAxis=(Automatic,Single,Two,Multiple);

The TBIMultiAxis type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Multiple | Represents constant Multiple.
Single | Represents constant Single.
Two | Represents constant Two.
Top
See Also

Reference

  • FMXBI.Visualizer.Chart


TGroupSeriesStyle Enumeration

Summary

Represents type TGroupSeriesStyle.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
type
 TGroupSeriesStyle=(Automatic,Series2D,Series3D,Geographic);

The TGroupSeriesStyle type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Geographic | Represents constant Geographic.
Series2D | Represents constant Series2D.
Series3D | Represents constant Series3D.
Top
See Also

Reference

  • FMXBI.Visualizer.Chart


FMXBI.Visualizer.Chart Types

Types
Name | Description
TChartProc | Represents type TChartProc.
TWinControl | Represents an alias of the TControl type.
Top


TChartProc Type

Summary

Represents type TChartProc.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
type
 TChartProc=reference to procedure(const AChart:TCustomChart);
See Also

Reference

  • FMXBI.Visualizer.Chart


TWinControl Type

Summary

Represents an alias of the TControl type.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
type
 TWinControl=TControl;
See Also

Reference

  • FMXBI.Visualizer.Chart


FMXBI.Visualizer.Chart Routines

Routines
Name | Description
AddSettingsButton(TWinControl) | Represents method AddSettingsButton(TWinControl).
IsNumericOrDateTime(TDataItem) | Represents method IsNumericOrDateTime(TDataItem).
MandatoryAxis(TChartSeries) | Represents method MandatoryAxis(TChartSeries).
NotMandatoryAxis(TChartSeries) | Represents method NotMandatoryAxis(TChartSeries).
SetColorEach(TChartSeries) | Represents method SetColorEach(TChartSeries).
TeeBIGetCursorPos | Represents method TeeBIGetCursorPos.
TraverseChart(TCustomChart,TChartProc) | Represents method TraverseChart(TCustomChart,TChartProc).
TryChangeSeriesStyle(TChartSeries) | Represents method TryChangeSeriesStyle(TChartSeries).
Top


AddSettingsButton(TWinControl) Method

Summary

Represents method AddSettingsButton(TWinControl).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
function AddSettingsButton(const AControl:TWinControl):TSpeedButton;

Parameters

AControl
Type: System.Void

Return Value

Type: TSpeedButton

See Also

Reference

  • FMXBI.Visualizer.Chart


IsNumericOrDateTime(TDataItem) Method

Summary

Represents method IsNumericOrDateTime(TDataItem).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
function IsNumericOrDateTime(const AData:TDataItem):Boolean;

Parameters

AData
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • FMXBI.Visualizer.Chart


MandatoryAxis(TChartSeries) Method

Summary

Represents method MandatoryAxis(TChartSeries).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
function MandatoryAxis(const ASeries:TChartSeries):TChartAxis;

Parameters

ASeries
Type: TChartSeries

Return Value

Type: TChartAxis

See Also

Reference

  • FMXBI.Visualizer.Chart


NotMandatoryAxis(TChartSeries) Method

Summary

Represents method NotMandatoryAxis(TChartSeries).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
function NotMandatoryAxis(const ASeries:TChartSeries):TChartAxis;

Parameters

ASeries
Type: TChartSeries

Return Value

Type: TChartAxis

See Also

Reference

  • FMXBI.Visualizer.Chart


SetColorEach(TChartSeries) Method

Summary

Represents method SetColorEach(TChartSeries).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
procedure SetColorEach(const ASeries:TChartSeries);

Parameters

ASeries
Type: TChartSeries

See Also

Reference

  • FMXBI.Visualizer.Chart


TeeBIGetCursorPos Method

Summary

Represents method TeeBIGetCursorPos.

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
function TeeBIGetCursorPos:TPoint;

Return Value

Type: TPoint

See Also

Reference

  • FMXBI.Visualizer.Chart


TraverseChart(TCustomChart,TChartProc) Method

Summary

Represents method TraverseChart(TCustomChart,TChartProc).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
procedure TraverseChart(const AChart:TCustomChart; const AProc:TChartProc);

Parameters

AChart
Type: TCustomChart

AProc
Type: TChartProc

See Also

Reference

  • FMXBI.Visualizer.Chart


TryChangeSeriesStyle(TChartSeries) Method

Summary

Represents method TryChangeSeriesStyle(TChartSeries).

Namespace: FMXBI.Visualizer.Chart
Syntax
Delphi
procedure TryChangeSeriesStyle(var ASeries:TChartSeries);

Parameters

ASeries
Type: TChartSeries

See Also

Reference

  • FMXBI.Visualizer.Chart


teebi Namespace

Summary

Represents namespace teebi.

Routines
Name | Description
Register | Represents method Register.
Top


teebi Routines

Routines
Name | Description
Register | Represents method Register.
Top


Register Method

Summary

Represents method Register.

Namespace: teebi
Syntax
Delphi
procedure Register;
See Also

Reference

  • teebi


TeeBIAbout Namespace

Summary

Represents namespace TeeBIAbout.

Classes
Name | Description
TAboutBI | Represents type TAboutBI.
Top


TeeBIAbout Classes

Classes
Name | Description
TAboutBI | Represents type TAboutBI.
Top


TAboutBI Class

Summary

Represents type TAboutBI.

Namespace: TeeBIAbout
Inheritance Hierarchy
TForm
TeeBIAbout.TAboutBI
Syntax
Delphi
type
 TAboutBI = class(TForm)
 end;

The TAboutBI type exposes the following members.

Methods
Show:
Name | Description
BOKClick(TObject) | Represents method BOKClick(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
Label2Click(TObject) | Represents method Label2Click(TObject).
Show(TComponent) | Represents method Show(TComponent).
Top
Fields
Show:
Name | Description
BOK | Represents field BOK.
Image1 | Represents field Image1.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
LCopyright | Represents field LCopyright.
LVersion | Represents field LVersion.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Top
See Also

Reference

  • TeeBIAbout


TAboutBI Methods

Methods
Name | Description
BOKClick(TObject) | Represents method BOKClick(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
Label2Click(TObject) | Represents method Label2Click(TObject).
Show(TComponent) | Represents method Show(TComponent).
Top


TAboutBI.BOKClick(TObject) Method

Summary

Represents method BOKClick(TObject).

Namespace: TeeBIAbout
Syntax
Delphi
published
 procedure BOKClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TAboutBI
  • TeeBIAbout


TAboutBI.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: TeeBIAbout
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TAboutBI
  • TeeBIAbout


TAboutBI.Label2Click(TObject) Method

Summary

Represents method Label2Click(TObject).

Namespace: TeeBIAbout
Syntax
Delphi
published
 procedure Label2Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TAboutBI
  • TeeBIAbout


TAboutBI.Show(TComponent) Method

Summary

Represents method Show(TComponent).

Namespace: TeeBIAbout
Syntax
Delphi
public
 class procedure Show(const AOwner:TComponent);

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TAboutBI
  • TeeBIAbout


TAboutBI Fields

Fields
Name | Description
BOK | Represents field BOK.
Image1 | Represents field Image1.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
LCopyright | Represents field LCopyright.
LVersion | Represents field LVersion.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Top


TAboutBI.BOK Field

Summary

Represents field BOK.

Namespace: TeeBIAbout
Syntax
Delphi
published
 BOK: TButton;

Field Value

Type: TButton

See Also

Reference

  • TAboutBI
  • TeeBIAbout


TAboutBI.Image1 Field

Summary

Represents field Image1.

Namespace: TeeBIAbout
Syntax
Delphi
published
 Image1: TImage;

Field Value

Type: TImage

See Also

Reference

  • TAboutBI
  • TeeBIAbout


TAboutBI.Label1 Field

Summary

Represents field Label1.

Namespace: TeeBIAbout
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TAboutBI
  • TeeBIAbout


TAboutBI.Label2 Field

Summary

Represents field Label2.

Namespace: TeeBIAbout
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TAboutBI
  • TeeBIAbout


TAboutBI.LCopyright Field

Summary

Represents field LCopyright.

Namespace: TeeBIAbout
Syntax
Delphi
published
 LCopyright: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TAboutBI
  • TeeBIAbout


TAboutBI.LVersion Field

Summary

Represents field LVersion.

Namespace: TeeBIAbout
Syntax
Delphi
published
 LVersion: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TAboutBI
  • TeeBIAbout


TAboutBI.Panel1 Field

Summary

Represents field Panel1.

Namespace: TeeBIAbout
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TAboutBI
  • TeeBIAbout


TAboutBI.Panel2 Field

Summary

Represents field Panel2.

Namespace: TeeBIAbout
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TAboutBI
  • TeeBIAbout


TeeBIDebugFrame Namespace

Summary

Represents namespace TeeBIDebugFrame.

Classes
Name | Description
TDataItemDebugFrame | Represents type TDataItemDebugFrame.
TDataViewerAccess | Represents type TDataViewerAccess.
Top
Records
Name | Description
TDebugContext | Represents type TDebugContext.
TDebugEvaluate | Represents type TDebugEvaluate.
TDebugModify | Represents type TDebugModify.
TDeferredEvaluate | Represents type TDeferredEvaluate.
Top
Enumerations
Name | Description
TAvailableState | Represents type TAvailableState.
Top


TeeBIDebugFrame Classes

Classes
Name | Description
TDataItemDebugFrame | Represents type TDataItemDebugFrame.
TDataViewerAccess | Represents type TDataViewerAccess.
Top


TDataItemDebugFrame Class

Summary

Represents type TDataItemDebugFrame.

Namespace: TeeBIDebugFrame
Inheritance Hierarchy
TFrame
TeeBIDebugFrame.TDataItemDebugFrame
Syntax
Delphi
type
 TDataItemDebugFrame = class(TFrame, IOTADebuggerVisualizerExternalViewerUpdater, IOTAThreadNotifier)
 end;

The TDataItemDebugFrame type exposes the following members.

Methods
Show:
Name | Description
AfterSave | Represents method AfterSave.
BeforeSave | Represents method BeforeSave.
CheckOnCreate | Represents method CheckOnCreate.
CloseVisualizer | Represents method CloseVisualizer.
Destroyed | Represents method Destroyed.
DoEvaluate(String,String,String) | Represents method DoEvaluate(String,String,String).
EvaluateExpression(TDebugContext,String,String,String) | Represents method EvaluateExpression(TDebugContext,String,String,String).
EvaluatePointer(TDebugContext,String) | Represents method EvaluatePointer(TDebugContext,String).
EvaluateStringValue(TDebugContext,String) | Represents method EvaluateStringValue(TDebugContext,String).
EvaluteComplete(string,string,Boolean,LongWord,LongWord,Integer) | Represents method EvaluteComplete(string,string,Boolean,LongWord,LongWord,Integer).
MarkUnavailable(TOTAVisualizerUnavailableReason) | Represents method MarkUnavailable(TOTAVisualizerUnavailableReason).
Modified | Represents method Modified.
ModifyComplete(string,string,Integer) | Represents method ModifyComplete(string,string,Integer).
RefreshVisualizer(string,string,string) | Represents method RefreshVisualizer(string,string,string).
SetClosedCallback(TOTAVisualizerClosedProcedure) | Represents method SetClosedCallback(TOTAVisualizerClosedProcedure).
SetParent(TWinControl) | Represents method SetParent(TWinControl).
ThreadNotify(TOTANotifyReason) | Represents method ThreadNotify(TOTANotifyReason).
Top
Fields
Show:
Name | Description
IForm | Represents field IForm.
StatusLabel | Represents field StatusLabel.
Top
See Also

Reference

  • TeeBIDebugFrame


TDataItemDebugFrame Methods

Methods
Name | Description
AfterSave | Represents method AfterSave.
BeforeSave | Represents method BeforeSave.
CheckOnCreate | Represents method CheckOnCreate.
CloseVisualizer | Represents method CloseVisualizer.
Destroyed | Represents method Destroyed.
DoEvaluate(String,String,String) | Represents method DoEvaluate(String,String,String).
EvaluateExpression(TDebugContext,String,String,String) | Represents method EvaluateExpression(TDebugContext,String,String,String).
EvaluatePointer(TDebugContext,String) | Represents method EvaluatePointer(TDebugContext,String).
EvaluateStringValue(TDebugContext,String) | Represents method EvaluateStringValue(TDebugContext,String).
EvaluteComplete(string,string,Boolean,LongWord,LongWord,Integer) | Represents method EvaluteComplete(string,string,Boolean,LongWord,LongWord,Integer).
MarkUnavailable(TOTAVisualizerUnavailableReason) | Represents method MarkUnavailable(TOTAVisualizerUnavailableReason).
Modified | Represents method Modified.
ModifyComplete(string,string,Integer) | Represents method ModifyComplete(string,string,Integer).
RefreshVisualizer(string,string,string) | Represents method RefreshVisualizer(string,string,string).
SetClosedCallback(TOTAVisualizerClosedProcedure) | Represents method SetClosedCallback(TOTAVisualizerClosedProcedure).
SetParent(TWinControl) | Represents method SetParent(TWinControl).
ThreadNotify(TOTANotifyReason) | Represents method ThreadNotify(TOTANotifyReason).
Top


TDataItemDebugFrame.AfterSave Method

Summary

Represents method AfterSave.

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 procedure AfterSave;
See Also

Reference

  • TDataItemDebugFrame
  • TeeBIDebugFrame


TDataItemDebugFrame.BeforeSave Method

Summary

Represents method BeforeSave.

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 procedure BeforeSave;
See Also

Reference

  • TDataItemDebugFrame
  • TeeBIDebugFrame


TDataItemDebugFrame.CheckOnCreate Method

Summary

Represents method CheckOnCreate.

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 procedure CheckOnCreate;
See Also

Reference

  • TDataItemDebugFrame
  • TeeBIDebugFrame


TDataItemDebugFrame.CloseVisualizer Method

Summary

Represents method CloseVisualizer.

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 procedure CloseVisualizer;
See Also

Reference

  • TDataItemDebugFrame
  • TeeBIDebugFrame


TDataItemDebugFrame.Destroyed Method

Summary

Represents method Destroyed.

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 procedure Destroyed;
See Also

Reference

  • TDataItemDebugFrame
  • TeeBIDebugFrame


TDataItemDebugFrame.DoEvaluate(String,String,String) Method

Summary

Represents method DoEvaluate(String,String,String).

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 procedure DoEvaluate(const Expression, TypeName, EvalResult:String);

Parameters

Expression
Type: String

TypeName
Type: String

EvalResult
Type: String

See Also

Reference

  • TDataItemDebugFrame
  • TeeBIDebugFrame


TDataItemDebugFrame.EvaluateExpression(TDebugContext,String,String,String) Method

Summary

Represents method EvaluateExpression(TDebugContext,String,String,String).

Namespace: TeeBIDebugFrame
Syntax
Delphi
protected
 procedure EvaluateExpression(const Context:TDebugContext; const Expression,TypeName,EvalResult:String);

Parameters

Context
Type: TDebugContext

Expression
Type: String

TypeName
Type: String

EvalResult
Type: String

See Also

Reference

  • TDataItemDebugFrame
  • TeeBIDebugFrame


TDataItemDebugFrame.EvaluatePointer(TDebugContext,String) Method

Summary

Represents method EvaluatePointer(TDebugContext,String).

Namespace: TeeBIDebugFrame
Syntax
Delphi
protected
 function EvaluatePointer(const Context: TDebugContext; Expression:String):Pointer;

Parameters

Context
Type: TDebugContext

Expression
Type: String

Return Value

Type: Pointer

See Also

Reference

  • TDataItemDebugFrame
  • TeeBIDebugFrame


TDataItemDebugFrame.EvaluateStringValue(TDebugContext,String) Method

Summary

Represents method EvaluateStringValue(TDebugContext,String).

Namespace: TeeBIDebugFrame
Syntax
Delphi
protected
 function EvaluateStringValue(const Context: TDebugContext; Expression:String):String;

Parameters

Context
Type: TDebugContext

Expression
Type: String

Return Value

Type: String

See Also

Reference

  • TDataItemDebugFrame
  • TeeBIDebugFrame


TDataItemDebugFrame.EvaluteComplete(string,string,Boolean,LongWord,LongWord,Integer) Method

Summary

Represents method EvaluteComplete(string,string,Boolean,LongWord,LongWord,Integer).

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 procedure EvaluteComplete(const ExprStr, ResultStr: string; CanModify: Boolean; ResultAddress, ResultSize: LongWord; ReturnCode: Integer);

Parameters

ExprStr
Type: string

ResultStr
Type: string

CanModify
Type: Boolean

ResultAddress
Type: LongWord

ResultSize
Type: LongWord

ReturnCode
Type: Integer

See Also

Reference

  • TDataItemDebugFrame
  • TeeBIDebugFrame


TDataItemDebugFrame.MarkUnavailable(TOTAVisualizerUnavailableReason) Method

Summary

Represents method MarkUnavailable(TOTAVisualizerUnavailableReason).

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 procedure MarkUnavailable(Reason: TOTAVisualizerUnavailableReason);

Parameters

Reason
Type: TOTAVisualizerUnavailableReason

See Also

Reference

  • TDataItemDebugFrame
  • TeeBIDebugFrame


TDataItemDebugFrame.Modified Method

Summary

Represents method Modified.

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 procedure Modified;
See Also

Reference

  • TDataItemDebugFrame
  • TeeBIDebugFrame


TDataItemDebugFrame.ModifyComplete(string,string,Integer) Method

Summary

Represents method ModifyComplete(string,string,Integer).

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 procedure ModifyComplete(const ExprStr, ResultStr: string; ReturnCode: Integer);

Parameters

ExprStr
Type: string

ResultStr
Type: string

ReturnCode
Type: Integer

See Also

Reference

  • TDataItemDebugFrame
  • TeeBIDebugFrame


TDataItemDebugFrame.RefreshVisualizer(string,string,string) Method

Summary

Represents method RefreshVisualizer(string,string,string).

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 procedure RefreshVisualizer(const Expression, TypeName, EvalResult: string);

Parameters

Expression
Type: string

TypeName
Type: string

EvalResult
Type: string

See Also

Reference

  • TDataItemDebugFrame
  • TeeBIDebugFrame


TDataItemDebugFrame.SetClosedCallback(TOTAVisualizerClosedProcedure) Method

Summary

Represents method SetClosedCallback(TOTAVisualizerClosedProcedure).

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 procedure SetClosedCallback(ClosedProc: TOTAVisualizerClosedProcedure);

Parameters

ClosedProc
Type: TOTAVisualizerClosedProcedure

See Also

Reference

  • TDataItemDebugFrame
  • TeeBIDebugFrame


TDataItemDebugFrame.SetParent(TWinControl) Method

Summary

Represents method SetParent(TWinControl).

Namespace: TeeBIDebugFrame
Syntax
Delphi
protected
 procedure SetParent(AParent: TWinControl); override;

Parameters

AParent
Type: TWinControl

See Also

Reference

  • TDataItemDebugFrame
  • TeeBIDebugFrame


TDataItemDebugFrame.ThreadNotify(TOTANotifyReason) Method

Summary

Represents method ThreadNotify(TOTANotifyReason).

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 procedure ThreadNotify(Reason: TOTANotifyReason);

Parameters

Reason
Type: TOTANotifyReason

See Also

Reference

  • TDataItemDebugFrame
  • TeeBIDebugFrame


TDataItemDebugFrame Fields

Fields
Name | Description
IForm | Represents field IForm.
StatusLabel | Represents field StatusLabel.
Top


TDataItemDebugFrame.IForm Field

Summary

Represents field IForm.

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 IForm : TCustomForm;

Field Value

Type: TCustomForm

See Also

Reference

  • TDataItemDebugFrame
  • TeeBIDebugFrame


TDataItemDebugFrame.StatusLabel Field

Summary

Represents field StatusLabel.

Namespace: TeeBIDebugFrame
Syntax
Delphi
published
 StatusLabel: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataItemDebugFrame
  • TeeBIDebugFrame


TDataViewerAccess Class

Summary

Represents type TDataViewerAccess.

Namespace: TeeBIDebugFrame
Inheritance Hierarchy
TForm
VCLBI.DataViewer.TDataViewer
TeeBIDebugFrame.TDataViewerAccess
Syntax
Delphi
type
 TDataViewerAccess=class(TDataViewer);
See Also

Reference

  • TeeBIDebugFrame


TeeBIDebugFrame Records

Records
Name | Description
TDebugContext | Represents type TDebugContext.
TDebugEvaluate | Represents type TDebugEvaluate.
TDebugModify | Represents type TDebugModify.
TDeferredEvaluate | Represents type TDeferredEvaluate.
Top


TDebugContext Record

Summary

Represents type TDebugContext.

Namespace: TeeBIDebugFrame
Syntax
Delphi
type
 TDebugContext=record
 end;

The TDebugContext type exposes the following members.

Fields
Show:
Name | Description
Debug | Represents field Debug.
Process | Represents field Process.
Thread | Represents field Thread.
Top
See Also

Reference

  • TeeBIDebugFrame


TDebugContext Fields

Fields
Name | Description
Debug | Represents field Debug.
Process | Represents field Process.
Thread | Represents field Thread.
Top


TDebugContext.Debug Field

Summary

Represents field Debug.

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 Debug: IOTADebuggerServices;

Field Value

Type: IOTADebuggerServices

See Also

Reference

  • TDebugContext
  • TeeBIDebugFrame


TDebugContext.Process Field

Summary

Represents field Process.

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 Process: IOTAProcess;

Field Value

Type: IOTAProcess

See Also

Reference

  • TDebugContext
  • TeeBIDebugFrame


TDebugContext.Thread Field

Summary

Represents field Thread.

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 Thread: IOTAThread;

Field Value

Type: IOTAThread

See Also

Reference

  • TDebugContext
  • TeeBIDebugFrame


TDebugEvaluate Record

Summary

Represents type TDebugEvaluate.

Namespace: TeeBIDebugFrame
Syntax
Delphi
type
 TDebugEvaluate=record
 end;

The TDebugEvaluate type exposes the following members.

Fields
Show:
Name | Description
Completed | Represents field Completed.
Deferred | Represents field Deferred.
Top
See Also

Reference

  • TeeBIDebugFrame


TDebugEvaluate Fields

Fields
Name | Description
Completed | Represents field Completed.
Deferred | Represents field Deferred.
Top


TDebugEvaluate.Completed Field

Summary

Represents field Completed.

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 Completed : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TDebugEvaluate
  • TeeBIDebugFrame


TDebugEvaluate.Deferred Field

Summary

Represents field Deferred.

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 Deferred : TDeferredEvaluate;

Field Value

Type: TDeferredEvaluate

See Also

Reference

  • TDebugEvaluate
  • TeeBIDebugFrame


TDebugModify Record

Summary

Represents type TDebugModify.

Namespace: TeeBIDebugFrame
Syntax
Delphi
type
 TDebugModify=record
 end;

The TDebugModify type exposes the following members.

Fields
Show:
Name | Description
Code | Represents field Code.
Completed | Represents field Completed.
Result | Represents field Result.
Top
See Also

Reference

  • TeeBIDebugFrame


TDebugModify Fields

Fields
Name | Description
Code | Represents field Code.
Completed | Represents field Completed.
Result | Represents field Result.
Top


TDebugModify.Code Field

Summary

Represents field Code.

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 Code : Integer;

Field Value

Type: Integer

See Also

Reference

  • TDebugModify
  • TeeBIDebugFrame


TDebugModify.Completed Field

Summary

Represents field Completed.

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 Completed : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TDebugModify
  • TeeBIDebugFrame


TDebugModify.Result Field

Summary

Represents field Result.

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 Result : String;

Field Value

Type: String

See Also

Reference

  • TDebugModify
  • TeeBIDebugFrame


TDeferredEvaluate Record

Summary

Represents type TDeferredEvaluate.

Namespace: TeeBIDebugFrame
Syntax
Delphi
type
 TDeferredEvaluate=record
 end;

The TDeferredEvaluate type exposes the following members.

Fields
Show:
Name | Description
Address | Represents field Address.
Code | Represents field Code.
Result | Represents field Result.
Top
See Also

Reference

  • TeeBIDebugFrame


TDeferredEvaluate Fields

Fields
Name | Description
Address | Represents field Address.
Code | Represents field Code.
Result | Represents field Result.
Top


TDeferredEvaluate.Address Field

Summary

Represents field Address.

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 Address: LongWord;

Field Value

Type: LongWord

See Also

Reference

  • TDeferredEvaluate
  • TeeBIDebugFrame


TDeferredEvaluate.Code Field

Summary

Represents field Code.

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 Code : Integer;

Field Value

Type: Integer

See Also

Reference

  • TDeferredEvaluate
  • TeeBIDebugFrame


TDeferredEvaluate.Result Field

Summary

Represents field Result.

Namespace: TeeBIDebugFrame
Syntax
Delphi
public
 Result: String;

Field Value

Type: String

See Also

Reference

  • TDeferredEvaluate
  • TeeBIDebugFrame


TeeBIDebugFrame Enumerations

Enumerations
Name | Description
TAvailableState | Represents type TAvailableState.
Top


TAvailableState Enumeration

Summary

Represents type TAvailableState.

Namespace: TeeBIDebugFrame
Syntax
Delphi
type
 TAvailableState = (asAvailable, asProcRunning, asOutOfScope);

The TAvailableState type exposes the following members.

Members
Show:
Name | Description
asAvailable | Represents constant asAvailable.
asOutOfScope | Represents constant asOutOfScope.
asProcRunning | Represents constant asProcRunning.
Top
See Also

Reference

  • TeeBIDebugFrame


TeeBIDebugVisualizer Namespace

Summary

Represents namespace TeeBIDebugVisualizer.

Classes
Name | Description
TDataDebugForm | Represents type TDataDebugForm.
TDataItemVisualizer | Represents type TDataItemVisualizer.
Top
Variables
Name | Description
DataItemVisualizer | Represents variable DataItemVisualizer.
Top
Routines
Name | Description
RegisterVisualizer | Represents method RegisterVisualizer.
RemoveVisualizer | Represents method RemoveVisualizer.
Top


TeeBIDebugVisualizer Classes

Classes
Name | Description
TDataDebugForm | Represents type TDataDebugForm.
TDataItemVisualizer | Represents type TDataItemVisualizer.
Top


TDataDebugForm Class

Summary

Represents type TDataDebugForm.

Namespace: TeeBIDebugVisualizer
Inheritance Hierarchy
TInterfacedObject
TeeBIDebugVisualizer.TDataDebugForm
Syntax
Delphi
type
 TDataDebugForm=class(TInterfacedObject, INTACustomDockableForm)
 end;

The TDataDebugForm type exposes the following members.

Methods
Show:
Name | Description
CustomizePopupMenu(TPopupMenu) | Represents method CustomizePopupMenu(TPopupMenu).
CustomizeToolBar(TToolBar) | Represents method CustomizeToolBar(TToolBar).
EditAction(TEditAction) | Represents method EditAction(TEditAction).
FrameCreated(TCustomFrame) | Represents method FrameCreated(TCustomFrame).
GetCaption | Represents method GetCaption.
GetEditState | Represents method GetEditState.
GetFrameClass | Represents method GetFrameClass.
GetIdentifier | Represents method GetIdentifier.
GetMenuActionList | Represents method GetMenuActionList.
GetMenuImageList | Represents method GetMenuImageList.
GetToolbarActionList | Represents method GetToolbarActionList.
GetToolbarImageList | Represents method GetToolbarImageList.
LoadWindowState(TCustomIniFile,string) | Represents method LoadWindowState(TCustomIniFile,string).
SaveWindowState(TCustomIniFile,string,Boolean) | Represents method SaveWindowState(TCustomIniFile,string,Boolean).
Top
Fields
Show:
Name | Description
FExpression | Represents field FExpression.
FViewerFrame | Represents field FViewerFrame.
Top
See Also

Reference

  • TeeBIDebugVisualizer


TDataDebugForm Methods

Methods
Name | Description
CustomizePopupMenu(TPopupMenu) | Represents method CustomizePopupMenu(TPopupMenu).
CustomizeToolBar(TToolBar) | Represents method CustomizeToolBar(TToolBar).
EditAction(TEditAction) | Represents method EditAction(TEditAction).
FrameCreated(TCustomFrame) | Represents method FrameCreated(TCustomFrame).
GetCaption | Represents method GetCaption.
GetEditState | Represents method GetEditState.
GetFrameClass | Represents method GetFrameClass.
GetIdentifier | Represents method GetIdentifier.
GetMenuActionList | Represents method GetMenuActionList.
GetMenuImageList | Represents method GetMenuImageList.
GetToolbarActionList | Represents method GetToolbarActionList.
GetToolbarImageList | Represents method GetToolbarImageList.
LoadWindowState(TCustomIniFile,string) | Represents method LoadWindowState(TCustomIniFile,string).
SaveWindowState(TCustomIniFile,string,Boolean) | Represents method SaveWindowState(TCustomIniFile,string,Boolean).
Top


TDataDebugForm.CustomizePopupMenu(TPopupMenu) Method

Summary

Represents method CustomizePopupMenu(TPopupMenu).

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
public
 procedure CustomizePopupMenu(PopupMenu:TPopupMenu);

Parameters

PopupMenu
Type: TPopupMenu

See Also

Reference

  • TDataDebugForm
  • TeeBIDebugVisualizer


TDataDebugForm.CustomizeToolBar(TToolBar) Method

Summary

Represents method CustomizeToolBar(TToolBar).

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
public
 procedure CustomizeToolBar(ToolBar:TToolBar);

Parameters

ToolBar
Type: TToolBar

See Also

Reference

  • TDataDebugForm
  • TeeBIDebugVisualizer


TDataDebugForm.EditAction(TEditAction) Method

Summary

Represents method EditAction(TEditAction).

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
public
 function EditAction(Action: TEditAction):Boolean;

Parameters

Action
Type: TEditAction

Return Value

Type: Boolean

See Also

Reference

  • TDataDebugForm
  • TeeBIDebugVisualizer


TDataDebugForm.FrameCreated(TCustomFrame) Method

Summary

Represents method FrameCreated(TCustomFrame).

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
public
 procedure FrameCreated(AFrame: TCustomFrame);

Parameters

AFrame
Type: TCustomFrame

See Also

Reference

  • TDataDebugForm
  • TeeBIDebugVisualizer


TDataDebugForm.GetCaption Method

Summary

Represents method GetCaption.

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
public
 function GetCaption:String;

Return Value

Type: String

See Also

Reference

  • TDataDebugForm
  • TeeBIDebugVisualizer


TDataDebugForm.GetEditState Method

Summary

Represents method GetEditState.

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
public
 function GetEditState:TEditState;

Return Value

Type: TEditState

See Also

Reference

  • TDataDebugForm
  • TeeBIDebugVisualizer


TDataDebugForm.GetFrameClass Method

Summary

Represents method GetFrameClass.

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
public
 function GetFrameClass:TCustomFrameClass;

Return Value

Type: TCustomFrameClass

See Also

Reference

  • TDataDebugForm
  • TeeBIDebugVisualizer


TDataDebugForm.GetIdentifier Method

Summary

Represents method GetIdentifier.

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
public
 function GetIdentifier:String;

Return Value

Type: String

See Also

Reference

  • TDataDebugForm
  • TeeBIDebugVisualizer


TDataDebugForm.GetMenuActionList Method

Summary

Represents method GetMenuActionList.

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
public
 function GetMenuActionList:TCustomActionList;

Return Value

Type: TCustomActionList

See Also

Reference

  • TDataDebugForm
  • TeeBIDebugVisualizer


TDataDebugForm.GetMenuImageList Method

Summary

Represents method GetMenuImageList.

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
public
 function GetMenuImageList:TCustomImageList;

Return Value

Type: TCustomImageList

See Also

Reference

  • TDataDebugForm
  • TeeBIDebugVisualizer


TDataDebugForm.GetToolbarActionList Method

Summary

Represents method GetToolbarActionList.

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
public
 function GetToolbarActionList:TCustomActionList;

Return Value

Type: TCustomActionList

See Also

Reference

  • TDataDebugForm
  • TeeBIDebugVisualizer


TDataDebugForm.GetToolbarImageList Method

Summary

Represents method GetToolbarImageList.

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
public
 function GetToolbarImageList:TCustomImageList;

Return Value

Type: TCustomImageList

See Also

Reference

  • TDataDebugForm
  • TeeBIDebugVisualizer


TDataDebugForm.LoadWindowState(TCustomIniFile,string) Method

Summary

Represents method LoadWindowState(TCustomIniFile,string).

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
public
 procedure LoadWindowState(Desktop: TCustomIniFile; const Section: string);

Parameters

Desktop
Type: TCustomIniFile

Section
Type: string

See Also

Reference

  • TDataDebugForm
  • TeeBIDebugVisualizer


TDataDebugForm.SaveWindowState(TCustomIniFile,string,Boolean) Method

Summary

Represents method SaveWindowState(TCustomIniFile,string,Boolean).

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
public
 procedure SaveWindowState(Desktop: TCustomIniFile; const Section: string; IsProject: Boolean);

Parameters

Desktop
Type: TCustomIniFile

Section
Type: string

IsProject
Type: Boolean

See Also

Reference

  • TDataDebugForm
  • TeeBIDebugVisualizer


TDataDebugForm Fields

Fields
Name | Description
FExpression | Represents field FExpression.
FViewerFrame | Represents field FViewerFrame.
Top


TDataDebugForm.FExpression Field

Summary

Represents field FExpression.

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
protected
 FExpression: String;

Field Value

Type: String

See Also

Reference

  • TDataDebugForm
  • TeeBIDebugVisualizer


TDataDebugForm.FViewerFrame Field

Summary

Represents field FViewerFrame.

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
protected
 FViewerFrame: TDataItemDebugFrame;

Field Value

Type: TDataItemDebugFrame

See Also

Reference

  • TDataDebugForm
  • TeeBIDebugVisualizer


TDataItemVisualizer Class

Summary

Represents type TDataItemVisualizer.

Namespace: TeeBIDebugVisualizer
Inheritance Hierarchy
TInterfacedObject
TeeBIDebugVisualizer.TDataItemVisualizer
Syntax
Delphi
type
 TDataItemVisualizer=class(TInterfacedObject, IOTADebuggerVisualizer,
 IOTADebuggerVisualizerExternalViewer)
 end;

The TDataItemVisualizer type exposes the following members.

Methods
Show:
Name | Description
GetMenuText | Represents method GetMenuText.
GetSupportedType(Integer,string,Boolean) | Represents method GetSupportedType(Integer,string,Boolean).
GetSupportedTypeCount | Represents method GetSupportedTypeCount.
GetVisualizerDescription | Represents method GetVisualizerDescription.
GetVisualizerIdentifier | Represents method GetVisualizerIdentifier.
GetVisualizerName | Represents method GetVisualizerName.
Show(string,string,string,Integer,Integer) | Represents method Show(string,string,string,Integer,Integer).
Top
See Also

Reference

  • TeeBIDebugVisualizer


TDataItemVisualizer Methods

Methods
Name | Description
GetMenuText | Represents method GetMenuText.
GetSupportedType(Integer,string,Boolean) | Represents method GetSupportedType(Integer,string,Boolean).
GetSupportedTypeCount | Represents method GetSupportedTypeCount.
GetVisualizerDescription | Represents method GetVisualizerDescription.
GetVisualizerIdentifier | Represents method GetVisualizerIdentifier.
GetVisualizerName | Represents method GetVisualizerName.
Show(string,string,string,Integer,Integer) | Represents method Show(string,string,string,Integer,Integer).
Top


TDataItemVisualizer.GetMenuText Method

Summary

Represents method GetMenuText.

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
public
 function GetMenuText: string;

Return Value

Type: string

See Also

Reference

  • TDataItemVisualizer
  • TeeBIDebugVisualizer


TDataItemVisualizer.GetSupportedType(Integer,string,Boolean) Method

Summary

Represents method GetSupportedType(Integer,string,Boolean).

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
public
 procedure GetSupportedType(Index: Integer; var TypeName: string;
 var AllDescendents: Boolean);

Parameters

Index
Type: Integer

TypeName
Type: string

AllDescendents
Type: Boolean

See Also

Reference

  • TDataItemVisualizer
  • TeeBIDebugVisualizer


TDataItemVisualizer.GetSupportedTypeCount Method

Summary

Represents method GetSupportedTypeCount.

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
public
 function GetSupportedTypeCount: Integer;

Return Value

Type: Integer

See Also

Reference

  • TDataItemVisualizer
  • TeeBIDebugVisualizer


TDataItemVisualizer.GetVisualizerDescription Method

Summary

Represents method GetVisualizerDescription.

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
public
 function GetVisualizerDescription: string;

Return Value

Type: string

See Also

Reference

  • TDataItemVisualizer
  • TeeBIDebugVisualizer


TDataItemVisualizer.GetVisualizerIdentifier Method

Summary

Represents method GetVisualizerIdentifier.

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
public
 function GetVisualizerIdentifier: string;

Return Value

Type: string

See Also

Reference

  • TDataItemVisualizer
  • TeeBIDebugVisualizer


TDataItemVisualizer.GetVisualizerName Method

Summary

Represents method GetVisualizerName.

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
public
 function GetVisualizerName: string;

Return Value

Type: string

See Also

Reference

  • TDataItemVisualizer
  • TeeBIDebugVisualizer


TDataItemVisualizer.Show(string,string,string,Integer,Integer) Method

Summary

Represents method Show(string,string,string,Integer,Integer).

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
public
 function Show(const Expression, TypeName, EvalResult: string;
 SuggestedLeft, SuggestedTop: Integer): IOTADebuggerVisualizerExternalViewerUpdater;

Parameters

Expression
Type: string

TypeName
Type: string

EvalResult
Type: string

SuggestedLeft
Type: Integer

SuggestedTop
Type: Integer

Return Value

Type: IOTADebuggerVisualizerExternalViewerUpdater

See Also

Reference

  • TDataItemVisualizer
  • TeeBIDebugVisualizer


TeeBIDebugVisualizer Variables

Variables
Name | Description
DataItemVisualizer | Represents variable DataItemVisualizer.
Top


DataItemVisualizer Variable

Summary

Represents variable DataItemVisualizer.

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
DataItemVisualizer : IOTADebuggerVisualizer;

Value

Type: IOTADebuggerVisualizer

See Also

Reference

  • TeeBIDebugVisualizer


TeeBIDebugVisualizer Routines

Routines
Name | Description
RegisterVisualizer | Represents method RegisterVisualizer.
RemoveVisualizer | Represents method RemoveVisualizer.
Top


RegisterVisualizer Method

Summary

Represents method RegisterVisualizer.

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
procedure RegisterVisualizer;
See Also

Reference

  • TeeBIDebugVisualizer


RemoveVisualizer Method

Summary

Represents method RemoveVisualizer.

Namespace: TeeBIDebugVisualizer
Syntax
Delphi
procedure RemoveVisualizer;
See Also

Reference

  • TeeBIDebugVisualizer


TeeBIFMXAbout Namespace

Summary

Represents namespace TeeBIFMXAbout.

Classes
Name | Description
TAboutBI | Represents type TAboutBI.
Top


TeeBIFMXAbout Classes

Classes
Name | Description
TAboutBI | Represents type TAboutBI.
Top


TAboutBI Class

Summary

Represents type TAboutBI.

Namespace: TeeBIFMXAbout
Inheritance Hierarchy
TForm
TeeBIFMXAbout.TAboutBI
Syntax
Delphi
type
 TAboutBI = class(TForm)
 end;

The TAboutBI type exposes the following members.

Methods
Show:
Name | Description
Button1Click(TObject) | Represents method Button1Click(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
Label1Click(TObject) | Represents method Label1Click(TObject).
Show(TComponent) | Represents method Show(TComponent).
Top
Fields
Show:
Name | Description
Button1 | Represents field Button1.
Image1 | Represents field Image1.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Layout1 | Represents field Layout1.
LCopyright | Represents field LCopyright.
LVersion | Represents field LVersion.
Top
See Also

Reference

  • TeeBIFMXAbout


TAboutBI Methods

Methods
Name | Description
Button1Click(TObject) | Represents method Button1Click(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
Label1Click(TObject) | Represents method Label1Click(TObject).
Show(TComponent) | Represents method Show(TComponent).
Top


TAboutBI.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: TeeBIFMXAbout
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TAboutBI
  • TeeBIFMXAbout


TAboutBI.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: TeeBIFMXAbout
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TAboutBI
  • TeeBIFMXAbout


TAboutBI.Label1Click(TObject) Method

Summary

Represents method Label1Click(TObject).

Namespace: TeeBIFMXAbout
Syntax
Delphi
published
 procedure Label1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TAboutBI
  • TeeBIFMXAbout


TAboutBI.Show(TComponent) Method

Summary

Represents method Show(TComponent).

Namespace: TeeBIFMXAbout
Syntax
Delphi
public
 class procedure Show(const AOwner:TComponent);

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TAboutBI
  • TeeBIFMXAbout


TAboutBI Fields

Fields
Name | Description
Button1 | Represents field Button1.
Image1 | Represents field Image1.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Layout1 | Represents field Layout1.
LCopyright | Represents field LCopyright.
LVersion | Represents field LVersion.
Top


TAboutBI.Button1 Field

Summary

Represents field Button1.

Namespace: TeeBIFMXAbout
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TAboutBI
  • TeeBIFMXAbout


TAboutBI.Image1 Field

Summary

Represents field Image1.

Namespace: TeeBIFMXAbout
Syntax
Delphi
published
 Image1: TImage;

Field Value

Type: TImage

See Also

Reference

  • TAboutBI
  • TeeBIFMXAbout


TAboutBI.Label1 Field

Summary

Represents field Label1.

Namespace: TeeBIFMXAbout
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TAboutBI
  • TeeBIFMXAbout


TAboutBI.Label2 Field

Summary

Represents field Label2.

Namespace: TeeBIFMXAbout
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TAboutBI
  • TeeBIFMXAbout


TAboutBI.Layout1 Field

Summary

Represents field Layout1.

Namespace: TeeBIFMXAbout
Syntax
Delphi
published
 Layout1: TLayout;

Field Value

Type: TLayout

See Also

Reference

  • TAboutBI
  • TeeBIFMXAbout


TAboutBI.LCopyright Field

Summary

Represents field LCopyright.

Namespace: TeeBIFMXAbout
Syntax
Delphi
published
 LCopyright: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TAboutBI
  • TeeBIFMXAbout


TAboutBI.LVersion Field

Summary

Represents field LVersion.

Namespace: TeeBIFMXAbout
Syntax
Delphi
published
 LVersion: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TAboutBI
  • TeeBIFMXAbout


TeeBIFMXRegister Namespace

Summary

Represents namespace TeeBIFMXRegister.

Classes
Name | Description
TBIComponentEditor | Represents type TBIComponentEditor.
TBIGridCompEditor | Represents type TBIGridCompEditor.
Top
Routines
Name | Description
Register | Represents method Register.
Top


TeeBIFMXRegister Classes

Classes
Name | Description
TBIComponentEditor | Represents type TBIComponentEditor.
TBIGridCompEditor | Represents type TBIGridCompEditor.
Top


TBIComponentEditor Class

Summary

Represents type TBIComponentEditor.

Namespace: TeeBIFMXRegister
Inheritance Hierarchy
TComponentEditor
TeeBIFMXRegister.TBIComponentEditor
TeeBIFMXRegister.TBIGridCompEditor
Syntax
Delphi
type
 TBIComponentEditor=class(TComponentEditor)
 end;

The TBIComponentEditor type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit.
ExecuteVerb(Integer) | Represents method ExecuteVerb(Integer).
GetVerb(Integer) | Represents method GetVerb(Integer).
GetVerbCount | Represents method GetVerbCount.
Top
See Also

Reference

  • TeeBIFMXRegister


TBIComponentEditor Methods

Methods
Name | Description
Edit | Represents method Edit.
ExecuteVerb(Integer) | Represents method ExecuteVerb(Integer).
GetVerb(Integer) | Represents method GetVerb(Integer).
GetVerbCount | Represents method GetVerbCount.
Top


TBIComponentEditor.Edit Method

Summary

Represents method Edit.

Namespace: TeeBIFMXRegister
Syntax
Delphi
public
 procedure Edit; override;
See Also

Reference

  • TBIComponentEditor
  • TeeBIFMXRegister


TBIComponentEditor.ExecuteVerb(Integer) Method

Summary

Represents method ExecuteVerb(Integer).

Namespace: TeeBIFMXRegister
Syntax
Delphi
public
 procedure ExecuteVerb(Index:Integer); override;

Parameters

Index
Type: Integer

See Also

Reference

  • TBIComponentEditor
  • TeeBIFMXRegister


TBIComponentEditor.GetVerb(Integer) Method

Summary

Represents method GetVerb(Integer).

Namespace: TeeBIFMXRegister
Syntax
Delphi
public
 function GetVerb(Index:Integer):String; override;

Parameters

Index
Type: Integer

Return Value

Type: String

See Also

Reference

  • TBIComponentEditor
  • TeeBIFMXRegister


TBIComponentEditor.GetVerbCount Method

Summary

Represents method GetVerbCount.

Namespace: TeeBIFMXRegister
Syntax
Delphi
public
 function GetVerbCount:Integer; override;

Return Value

Type: Integer

See Also

Reference

  • TBIComponentEditor
  • TeeBIFMXRegister


TBIGridCompEditor Class

Summary

Represents type TBIGridCompEditor.

Namespace: TeeBIFMXRegister
Inheritance Hierarchy
TComponentEditor
TeeBIFMXRegister.TBIComponentEditor
TeeBIFMXRegister.TBIGridCompEditor
Syntax
Delphi
type
 TBIGridCompEditor=class(TBIComponentEditor)
 end;

The TBIGridCompEditor type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit. (Overrides TBIComponentEditor.Edit.)
Top
See Also

Reference

  • TeeBIFMXRegister


TBIGridCompEditor Methods

Methods
Name | Description
Edit | Represents method Edit. (Overrides TBIComponentEditor.Edit.)
Top


TBIGridCompEditor.Edit Method

Summary

Represents method Edit.

Namespace: TeeBIFMXRegister
Syntax
Delphi
public
 procedure Edit; override;

Overrides

TBIComponentEditor.Edit
See Also

Reference

  • TBIGridCompEditor
  • TeeBIFMXRegister


TeeBIFMXRegister Routines

Routines
Name | Description
Register | Represents method Register.
Top


Register Method

Summary

Represents method Register.

Namespace: TeeBIFMXRegister
Syntax
Delphi
procedure Register;
See Also

Reference

  • TeeBIFMXRegister


TeeBIRegister Namespace

Summary

Represents namespace TeeBIRegister.

Classes
Name | Description
TBIChartCompEditor | Represents type TBIChartCompEditor.
TBIClassProperty | Represents type TBIClassProperty.
TBIClassSubProperties | Represents type TBIClassSubProperties.
TBIComponentEditor | Represents type TBIComponentEditor.
TBIComposerEditor | Represents type TBIComposerEditor.
TBIControlImporterEditor | Represents type TBIControlImporterEditor.
TBIDataDefinitionEditor | Represents type TBIDataDefinitionEditor.
TBIDataDefinitionProperty | Represents type TBIDataDefinitionProperty.
TBIDataProperty | Represents type TBIDataProperty.
TBIDataSetCompEditor | Represents type TBIDataSetCompEditor.
TBIDesignSources | Represents type TBIDesignSources.
TBIFilterProperty | Represents type TBIFilterProperty.
TBIGridCompEditor | Represents type TBIGridCompEditor.
TBIQueryCompEditor | Represents type TBIQueryCompEditor.
TBISortByProperty | Represents type TBISortByProperty.
TBITreeCompEditor | Represents type TBITreeCompEditor.
TBIVisualEditor | Represents type TBIVisualEditor.
TBIWorkflowCompEditor | Represents type TBIWorkflowCompEditor.
TDashboardProperty | Represents type TDashboardProperty.
Top
Routines
Name | Description
BIDesignTimeOnGetDesignerNames(TBIAddComponent,TComponent) | Represents method BIDesignTimeOnGetDesignerNames(TBIAddComponent,TComponent).
Register | Represents method Register.
Top


TeeBIRegister Classes

Classes
Name | Description
TBIChartCompEditor | Represents type TBIChartCompEditor.
TBIClassProperty | Represents type TBIClassProperty.
TBIClassSubProperties | Represents type TBIClassSubProperties.
TBIComponentEditor | Represents type TBIComponentEditor.
TBIComposerEditor | Represents type TBIComposerEditor.
TBIControlImporterEditor | Represents type TBIControlImporterEditor.
TBIDataDefinitionEditor | Represents type TBIDataDefinitionEditor.
TBIDataDefinitionProperty | Represents type TBIDataDefinitionProperty.
TBIDataProperty | Represents type TBIDataProperty.
TBIDataSetCompEditor | Represents type TBIDataSetCompEditor.
TBIDesignSources | Represents type TBIDesignSources.
TBIFilterProperty | Represents type TBIFilterProperty.
TBIGridCompEditor | Represents type TBIGridCompEditor.
TBIQueryCompEditor | Represents type TBIQueryCompEditor.
TBISortByProperty | Represents type TBISortByProperty.
TBITreeCompEditor | Represents type TBITreeCompEditor.
TBIVisualEditor | Represents type TBIVisualEditor.
TBIWorkflowCompEditor | Represents type TBIWorkflowCompEditor.
TDashboardProperty | Represents type TDashboardProperty.
Top


TBIChartCompEditor Class

Summary

Represents type TBIChartCompEditor.

Namespace: TeeBIRegister
Inheritance Hierarchy
TComponentEditor
TeeBIRegister.TBIComponentEditor
TeeBIRegister.TBIChartCompEditor
Syntax
Delphi
type
 TBIChartCompEditor=class(TBIComponentEditor)
 end;

The TBIChartCompEditor type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit. (Overrides TBIComponentEditor.Edit.)
Top
See Also

Reference

  • TeeBIRegister


TBIChartCompEditor Methods

Methods
Name | Description
Edit | Represents method Edit. (Overrides TBIComponentEditor.Edit.)
Top


TBIChartCompEditor.Edit Method

Summary

Represents method Edit.

Namespace: TeeBIRegister
Syntax
Delphi
public
 procedure Edit; override;

Overrides

TBIComponentEditor.Edit
See Also

Reference

  • TBIChartCompEditor
  • TeeBIRegister


TBIClassProperty Class

Summary

Represents type TBIClassProperty.

Namespace: TeeBIRegister
Inheritance Hierarchy
TClassProperty
TeeBIRegister.TBIClassProperty
TeeBIRegister.TBIClassSubProperties
TeeBIRegister.TBIDataDefinitionProperty
TeeBIRegister.TBIDataProperty
TeeBIRegister.TBIFilterProperty
TeeBIRegister.TBISortByProperty
Syntax
Delphi
type
 TBIClassProperty=class(TClassProperty)
 end;

The TBIClassProperty type exposes the following members.

Methods
Show:
Name | Description
GetAttributes | Represents method GetAttributes.
GetObject | Represents method GetObject.
GetValue | Represents method GetValue.
Top
See Also

Reference

  • TeeBIRegister


TBIClassProperty Methods

Methods
Name | Description
GetAttributes | Represents method GetAttributes.
GetObject | Represents method GetObject.
GetValue | Represents method GetValue.
Top


TBIClassProperty.GetAttributes Method

Summary

Represents method GetAttributes.

Namespace: TeeBIRegister
Syntax
Delphi
public
 function GetAttributes : TPropertyAttributes; override;

Return Value

Type: TPropertyAttributes

See Also

Reference

  • TBIClassProperty
  • TeeBIRegister


TBIClassProperty.GetObject Method

Summary

Represents method GetObject.

Namespace: TeeBIRegister
Syntax
Delphi
protected
 function GetObject:Integer;

Return Value

Type: Integer

See Also

Reference

  • TBIClassProperty
  • TeeBIRegister


TBIClassProperty.GetValue Method

Summary

Represents method GetValue.

Namespace: TeeBIRegister
Syntax
Delphi
public
 function GetValue: String; override;

Return Value

Type: String

See Also

Reference

  • TBIClassProperty
  • TeeBIRegister


TBIClassSubProperties Class

Summary

Represents type TBIClassSubProperties.

Namespace: TeeBIRegister
Inheritance Hierarchy
TClassProperty
TeeBIRegister.TBIClassProperty
TeeBIRegister.TBIClassSubProperties
Syntax
Delphi
type
 TBIClassSubProperties=class(TBIClassProperty)
 end;

The TBIClassSubProperties type exposes the following members.

Methods
Show:
Name | Description
GetAttributes | Represents method GetAttributes. (Overrides TBIClassProperty.GetAttributes.)
Top
See Also

Reference

  • TeeBIRegister


TBIClassSubProperties Methods

Methods
Name | Description
GetAttributes | Represents method GetAttributes. (Overrides TBIClassProperty.GetAttributes.)
Top


TBIClassSubProperties.GetAttributes Method

Summary

Represents method GetAttributes.

Namespace: TeeBIRegister
Syntax
Delphi
public
 function GetAttributes : TPropertyAttributes; override;

Return Value

Type: TPropertyAttributes

Overrides

TBIClassProperty.GetAttributes
See Also

Reference

  • TBIClassSubProperties
  • TeeBIRegister


TBIComponentEditor Class

Summary

Represents type TBIComponentEditor.

Namespace: TeeBIRegister
Inheritance Hierarchy
TComponentEditor
TeeBIRegister.TBIComponentEditor
TeeBIRegister.TBIChartCompEditor
TeeBIRegister.TBIComposerEditor
TeeBIRegister.TBIControlImporterEditor
TeeBIRegister.TBIDataDefinitionEditor
TeeBIRegister.TBIDataSetCompEditor
TeeBIRegister.TBIGridCompEditor
TeeBIRegister.TBIQueryCompEditor
TeeBIRegister.TBITreeCompEditor
TeeBIRegister.TBIVisualEditor
TeeBIRegister.TBIWorkflowCompEditor
Syntax
Delphi
type
 TBIComponentEditor=class(TComponentEditor)
 end;

The TBIComponentEditor type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit.
ExecuteVerb(Integer) | Represents method ExecuteVerb(Integer).
GetVerb(Integer) | Represents method GetVerb(Integer).
GetVerbCount | Represents method GetVerbCount.
Top
See Also

Reference

  • TeeBIRegister


TBIComponentEditor.Edit Method

Summary

Represents method Edit.

Namespace: TeeBIRegister
Syntax
Delphi
public
 procedure Edit; override;
See Also

Reference

  • TBIComponentEditor
  • TeeBIRegister


TBIComponentEditor.ExecuteVerb(Integer) Method

Summary

Represents method ExecuteVerb(Integer).

Namespace: TeeBIRegister
Syntax
Delphi
public
 procedure ExecuteVerb(Index:Integer); override;

Parameters

Index
Type: Integer

See Also

Reference

  • TBIComponentEditor
  • TeeBIRegister


TBIComponentEditor.GetVerb(Integer) Method

Summary

Represents method GetVerb(Integer).

Namespace: TeeBIRegister
Syntax
Delphi
public
 function GetVerb(Index:Integer):String; override;

Parameters

Index
Type: Integer

Return Value

Type: String

See Also

Reference

  • TBIComponentEditor
  • TeeBIRegister


TBIComponentEditor.GetVerbCount Method

Summary

Represents method GetVerbCount.

Namespace: TeeBIRegister
Syntax
Delphi
public
 function GetVerbCount:Integer; override;

Return Value

Type: Integer

See Also

Reference

  • TBIComponentEditor
  • TeeBIRegister


TBIComposerEditor Class

Summary

Represents type TBIComposerEditor.

Namespace: TeeBIRegister
Inheritance Hierarchy
TComponentEditor
TeeBIRegister.TBIComponentEditor
TeeBIRegister.TBIComposerEditor
Syntax
Delphi
type
 TBIComposerEditor=class(TBIComponentEditor)
 end;

The TBIComposerEditor type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit. (Overrides TBIComponentEditor.Edit.)
Top
See Also

Reference

  • TeeBIRegister


TBIComposerEditor Methods

Methods
Name | Description
Edit | Represents method Edit. (Overrides TBIComponentEditor.Edit.)
Top


TBIComposerEditor.Edit Method

Summary

Represents method Edit.

Namespace: TeeBIRegister
Syntax
Delphi
public
 procedure Edit; override;

Overrides

TBIComponentEditor.Edit
See Also

Reference

  • TBIComposerEditor
  • TeeBIRegister


TBIControlImporterEditor Class

Summary

Represents type TBIControlImporterEditor.

Namespace: TeeBIRegister
Inheritance Hierarchy
TComponentEditor
TeeBIRegister.TBIComponentEditor
TeeBIRegister.TBIControlImporterEditor
Syntax
Delphi
type
 TBIControlImporterEditor=class(TBIComponentEditor)
 end;

The TBIControlImporterEditor type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit. (Overrides TBIComponentEditor.Edit.)
Top
See Also

Reference

  • TeeBIRegister


TBIControlImporterEditor Methods

Methods
Name | Description
Edit | Represents method Edit. (Overrides TBIComponentEditor.Edit.)
Top


TBIControlImporterEditor.Edit Method

Summary

Represents method Edit.

Namespace: TeeBIRegister
Syntax
Delphi
public
 procedure Edit; override;

Overrides

TBIComponentEditor.Edit
See Also

Reference

  • TBIControlImporterEditor
  • TeeBIRegister


TBIDataDefinitionEditor Class

Summary

Represents type TBIDataDefinitionEditor.

Namespace: TeeBIRegister
Inheritance Hierarchy
TComponentEditor
TeeBIRegister.TBIComponentEditor
TeeBIRegister.TBIDataDefinitionEditor
Syntax
Delphi
type
 TBIDataDefinitionEditor=class(TBIComponentEditor)
 end;

The TBIDataDefinitionEditor type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit. (Overrides TBIComponentEditor.Edit.)
Top
See Also

Reference

  • TeeBIRegister


TBIDataDefinitionEditor Methods

Methods
Name | Description
Edit | Represents method Edit. (Overrides TBIComponentEditor.Edit.)
Top


TBIDataDefinitionEditor.Edit Method

Summary

Represents method Edit.

Namespace: TeeBIRegister
Syntax
Delphi
public
 procedure Edit; override;

Overrides

TBIComponentEditor.Edit
See Also

Reference

  • TBIDataDefinitionEditor
  • TeeBIRegister


TBIDataDefinitionProperty Class

Summary

Represents type TBIDataDefinitionProperty.

Namespace: TeeBIRegister
Inheritance Hierarchy
TClassProperty
TeeBIRegister.TBIClassProperty
TeeBIRegister.TBIDataDefinitionProperty
Syntax
Delphi
type
 TBIDataDefinitionProperty=class(TBIClassProperty)
 end;

The TBIDataDefinitionProperty type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit.
Top
See Also

Reference

  • TeeBIRegister


TBIDataDefinitionProperty Methods

Methods
Name | Description
Edit | Represents method Edit.
Top


TBIDataDefinitionProperty.Edit Method

Summary

Represents method Edit.

Namespace: TeeBIRegister
Syntax
Delphi
public
 procedure Edit; override;
See Also

Reference

  • TBIDataDefinitionProperty
  • TeeBIRegister


TBIDataProperty Class

Summary

Represents type TBIDataProperty.

Namespace: TeeBIRegister
Inheritance Hierarchy
TClassProperty
TeeBIRegister.TBIClassProperty
TeeBIRegister.TBIDataProperty
Syntax
Delphi
type
 TBIDataProperty=class(TBIClassProperty)
 end;

The TBIDataProperty type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit.
Top
See Also

Reference

  • TeeBIRegister


TBIDataProperty Methods

Methods
Name | Description
Edit | Represents method Edit.
Top


TBIDataProperty.Edit Method

Summary

Represents method Edit.

Namespace: TeeBIRegister
Syntax
Delphi
public
 procedure Edit; override;
See Also

Reference

  • TBIDataProperty
  • TeeBIRegister


TBIDataSetCompEditor Class

Summary

Represents type TBIDataSetCompEditor.

Namespace: TeeBIRegister
Inheritance Hierarchy
TComponentEditor
TeeBIRegister.TBIComponentEditor
TeeBIRegister.TBIDataSetCompEditor
Syntax
Delphi
type
 TBIDataSetCompEditor=class(TBIComponentEditor)
 end;

The TBIDataSetCompEditor type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit. (Overrides TBIComponentEditor.Edit.)
Top
See Also

Reference

  • TeeBIRegister


TBIDataSetCompEditor Methods

Methods
Name | Description
Edit | Represents method Edit. (Overrides TBIComponentEditor.Edit.)
Top


TBIDataSetCompEditor.Edit Method

Summary

Represents method Edit.

Namespace: TeeBIRegister
Syntax
Delphi
public
 procedure Edit; override;

Overrides

TBIComponentEditor.Edit
See Also

Reference

  • TBIDataSetCompEditor
  • TeeBIRegister


TBIDesignSources Class

Summary

Represents type TBIDesignSources.

Namespace: TeeBIRegister
Inheritance Hierarchy
TObject
TeeBIRegister.TBIDesignSources
Syntax
Delphi
type
 TBIDesignSources=class
 end;

The TBIDesignSources type exposes the following members.

Methods
Show:
Name | Description
Add(String) | Represents method Add(String).
Top
Fields
Show:
Name | Description
FDesigner | Represents field FDesigner.
Proc | Represents field Proc.
Top
See Also

Reference

  • TeeBIRegister


TBIDesignSources Methods

Methods
Name | Description
Add(String) | Represents method Add(String).
Top


TBIDesignSources.Add(String) Method

Summary

Represents method Add(String).

Namespace: TeeBIRegister
Syntax
Delphi
public
 procedure Add(const AName:String);

Parameters

AName
Type: String

See Also

Reference

  • TBIDesignSources
  • TeeBIRegister


TBIDesignSources Fields

Fields
Name | Description
FDesigner | Represents field FDesigner.
Proc | Represents field Proc.
Top


TBIDesignSources.FDesigner Field

Summary

Represents field FDesigner.

Namespace: TeeBIRegister
Syntax
Delphi
public
 FDesigner:IDesigner;

Field Value

Type: IDesigner

See Also

Reference

  • TBIDesignSources
  • TeeBIRegister


TBIDesignSources.Proc Field

Summary

Represents field Proc.

Namespace: TeeBIRegister
Syntax
Delphi
public
 Proc:TDataComponent.TBIAddComponent;

Field Value

Type: TDataComponent.TBIAddComponent

See Also

Reference

  • TBIDesignSources
  • TeeBIRegister


TBIFilterProperty Class

Summary

Represents type TBIFilterProperty.

Namespace: TeeBIRegister
Inheritance Hierarchy
TClassProperty
TeeBIRegister.TBIClassProperty
TeeBIRegister.TBIFilterProperty
Syntax
Delphi
type
 TBIFilterProperty=class(TBIClassProperty)
 end;

The TBIFilterProperty type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit.
Top
See Also

Reference

  • TeeBIRegister


TBIFilterProperty Methods

Methods
Name | Description
Edit | Represents method Edit.
Top


TBIFilterProperty.Edit Method

Summary

Represents method Edit.

Namespace: TeeBIRegister
Syntax
Delphi
public
 procedure Edit; override;
See Also

Reference

  • TBIFilterProperty
  • TeeBIRegister


TBIGridCompEditor Class

Summary

Represents type TBIGridCompEditor.

Namespace: TeeBIRegister
Inheritance Hierarchy
TComponentEditor
TeeBIRegister.TBIComponentEditor
TeeBIRegister.TBIGridCompEditor
Syntax
Delphi
type
 TBIGridCompEditor=class(TBIComponentEditor)
 end;

The TBIGridCompEditor type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit. (Overrides TBIComponentEditor.Edit.)
Top
See Also

Reference

  • TeeBIRegister


TBIGridCompEditor.Edit Method

Summary

Represents method Edit.

Namespace: TeeBIRegister
Syntax
Delphi
public
 procedure Edit; override;

Overrides

TBIComponentEditor.Edit
See Also

Reference

  • TBIGridCompEditor
  • TeeBIRegister


TBIQueryCompEditor Class

Summary

Represents type TBIQueryCompEditor.

Namespace: TeeBIRegister
Inheritance Hierarchy
TComponentEditor
TeeBIRegister.TBIComponentEditor
TeeBIRegister.TBIQueryCompEditor
Syntax
Delphi
type
 TBIQueryCompEditor=class(TBIComponentEditor)
 end;

The TBIQueryCompEditor type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit. (Overrides TBIComponentEditor.Edit.)
Top
See Also

Reference

  • TeeBIRegister


TBIQueryCompEditor Methods

Methods
Name | Description
Edit | Represents method Edit. (Overrides TBIComponentEditor.Edit.)
Top


TBIQueryCompEditor.Edit Method

Summary

Represents method Edit.

Namespace: TeeBIRegister
Syntax
Delphi
public
 procedure Edit; override;

Overrides

TBIComponentEditor.Edit
See Also

Reference

  • TBIQueryCompEditor
  • TeeBIRegister


TBISortByProperty Class

Summary

Represents type TBISortByProperty.

Namespace: TeeBIRegister
Inheritance Hierarchy
TClassProperty
TeeBIRegister.TBIClassProperty
TeeBIRegister.TBISortByProperty
Syntax
Delphi
type
 TBISortByProperty=class(TBIClassProperty)
 end;

The TBISortByProperty type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit.
Top
See Also

Reference

  • TeeBIRegister


TBISortByProperty Methods

Methods
Name | Description
Edit | Represents method Edit.
Top


TBISortByProperty.Edit Method

Summary

Represents method Edit.

Namespace: TeeBIRegister
Syntax
Delphi
public
 procedure Edit; override;
See Also

Reference

  • TBISortByProperty
  • TeeBIRegister


TBITreeCompEditor Class

Summary

Represents type TBITreeCompEditor.

Namespace: TeeBIRegister
Inheritance Hierarchy
TComponentEditor
TeeBIRegister.TBIComponentEditor
TeeBIRegister.TBITreeCompEditor
Syntax
Delphi
type
 TBITreeCompEditor=class(TBIComponentEditor);
See Also

Reference

  • TeeBIRegister


TBIVisualEditor Class

Summary

Represents type TBIVisualEditor.

Namespace: TeeBIRegister
Inheritance Hierarchy
TComponentEditor
TeeBIRegister.TBIComponentEditor
TeeBIRegister.TBIVisualEditor
Syntax
Delphi
type
 TBIVisualEditor=class(TBIComponentEditor)
 end;

The TBIVisualEditor type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit. (Overrides TBIComponentEditor.Edit.)
ExecuteVerb(Integer) | Represents method ExecuteVerb(Integer). (Overrides TBIComponentEditor.ExecuteVerb(Integer).)
GetVerb(Integer) | Represents method GetVerb(Integer). (Overrides TBIComponentEditor.GetVerb(Integer).)
GetVerbCount | Represents method GetVerbCount. (Overrides TBIComponentEditor.GetVerbCount.)
Load | Represents method Load.
Top
See Also

Reference

  • TeeBIRegister


TBIVisualEditor Methods

Methods
Name | Description
Edit | Represents method Edit. (Overrides TBIComponentEditor.Edit.)
ExecuteVerb(Integer) | Represents method ExecuteVerb(Integer). (Overrides TBIComponentEditor.ExecuteVerb(Integer).)
GetVerb(Integer) | Represents method GetVerb(Integer). (Overrides TBIComponentEditor.GetVerb(Integer).)
GetVerbCount | Represents method GetVerbCount. (Overrides TBIComponentEditor.GetVerbCount.)
Load | Represents method Load.
Top


TBIVisualEditor.Edit Method

Summary

Represents method Edit.

Namespace: TeeBIRegister
Syntax
Delphi
public
 procedure Edit; override;

Overrides

TBIComponentEditor.Edit
See Also

Reference

  • TBIVisualEditor
  • TeeBIRegister


TBIVisualEditor.ExecuteVerb(Integer) Method

Summary

Represents method ExecuteVerb(Integer).

Namespace: TeeBIRegister
Syntax
Delphi
public
 procedure ExecuteVerb(Index:Integer); override;

Parameters

Index
Type: Integer

Overrides

TBIComponentEditor.ExecuteVerb(Integer)
See Also

Reference

  • TBIVisualEditor
  • TeeBIRegister


TBIVisualEditor.GetVerb(Integer) Method

Summary

Represents method GetVerb(Integer).

Namespace: TeeBIRegister
Syntax
Delphi
public
 function GetVerb(Index:Integer):String; override;

Parameters

Index
Type: Integer

Return Value

Type: String

Overrides

TBIComponentEditor.GetVerb(Integer)
See Also

Reference

  • TBIVisualEditor
  • TeeBIRegister


TBIVisualEditor.GetVerbCount Method

Summary

Represents method GetVerbCount.

Namespace: TeeBIRegister
Syntax
Delphi
public
 function GetVerbCount:Integer; override;

Return Value

Type: Integer

Overrides

TBIComponentEditor.GetVerbCount
See Also

Reference

  • TBIVisualEditor
  • TeeBIRegister


TBIVisualEditor.Load Method

Summary

Represents method Load.

Namespace: TeeBIRegister
Syntax
Delphi
public
 procedure Load;
See Also

Reference

  • TBIVisualEditor
  • TeeBIRegister


TBIWorkflowCompEditor Class

Summary

Represents type TBIWorkflowCompEditor.

Namespace: TeeBIRegister
Inheritance Hierarchy
TComponentEditor
TeeBIRegister.TBIComponentEditor
TeeBIRegister.TBIWorkflowCompEditor
Syntax
Delphi
type
 TBIWorkflowCompEditor=class(TBIComponentEditor)
 end;

The TBIWorkflowCompEditor type exposes the following members.

Methods
Show:
Name | Description
Edit | Represents method Edit. (Overrides TBIComponentEditor.Edit.)
Top
See Also

Reference

  • TeeBIRegister


TBIWorkflowCompEditor Methods

Methods
Name | Description
Edit | Represents method Edit. (Overrides TBIComponentEditor.Edit.)
Top


TBIWorkflowCompEditor.Edit Method

Summary

Represents method Edit.

Namespace: TeeBIRegister
Syntax
Delphi
public
 procedure Edit; override;

Overrides

TBIComponentEditor.Edit
See Also

Reference

  • TBIWorkflowCompEditor
  • TeeBIRegister


TDashboardProperty Class

Summary

Represents type TDashboardProperty.

Namespace: TeeBIRegister
Inheritance Hierarchy
TClassProperty
TeeBIRegister.TDashboardProperty
Syntax
Delphi
type
 TDashboardProperty=class(TClassProperty)
 end;

The TDashboardProperty type exposes the following members.

Methods
Show:
Name | Description
GetAttributes | Represents method GetAttributes.
GetValue | Represents method GetValue.
GetValues(TGetStrProc) | Represents method GetValues(TGetStrProc).
SetValue(string) | Represents method SetValue(string).
Top
See Also

Reference

  • TeeBIRegister


TDashboardProperty Methods

Methods
Name | Description
GetAttributes | Represents method GetAttributes.
GetValue | Represents method GetValue.
GetValues(TGetStrProc) | Represents method GetValues(TGetStrProc).
SetValue(string) | Represents method SetValue(string).
Top


TDashboardProperty.GetAttributes Method

Summary

Represents method GetAttributes.

Namespace: TeeBIRegister
Syntax
Delphi
public
 function GetAttributes : TPropertyAttributes; override;

Return Value

Type: TPropertyAttributes

See Also

Reference

  • TDashboardProperty
  • TeeBIRegister


TDashboardProperty.GetValue Method

Summary

Represents method GetValue.

Namespace: TeeBIRegister
Syntax
Delphi
public
 function GetValue:String; override;

Return Value

Type: String

See Also

Reference

  • TDashboardProperty
  • TeeBIRegister


TDashboardProperty.GetValues(TGetStrProc) Method

Summary

Represents method GetValues(TGetStrProc).

Namespace: TeeBIRegister
Syntax
Delphi
public
 procedure GetValues(Proc: TGetStrProc); override;

Parameters

Proc
Type: TGetStrProc

See Also

Reference

  • TDashboardProperty
  • TeeBIRegister


TDashboardProperty.SetValue(string) Method

Summary

Represents method SetValue(string).

Namespace: TeeBIRegister
Syntax
Delphi
public
 procedure SetValue(const Value: string); override;

Parameters

Value
Type: string

See Also

Reference

  • TDashboardProperty
  • TeeBIRegister


TeeBIRegister Routines

Routines
Name | Description
BIDesignTimeOnGetDesignerNames(TBIAddComponent,TComponent) | Represents method BIDesignTimeOnGetDesignerNames(TBIAddComponent,TComponent).
Register | Represents method Register.
Top


BIDesignTimeOnGetDesignerNames(TBIAddComponent,TComponent) Method

Summary

Represents method BIDesignTimeOnGetDesignerNames(TBIAddComponent,TComponent).

Namespace: TeeBIRegister
Syntax
Delphi
procedure BIDesignTimeOnGetDesignerNames(AProc:TDataComponent.TBIAddComponent; AOwner:TComponent);

Parameters

AProc
Type: TDataComponent.TBIAddComponent

AOwner
Type: TComponent

See Also

Reference

  • TeeBIRegister


Register Method

Summary

Represents method Register.

Namespace: TeeBIRegister
Syntax
Delphi
procedure Register;
See Also

Reference

  • TeeBIRegister


TeeBIRegisterAbout Namespace

Summary

Represents namespace TeeBIRegisterAbout.

Variables
Name | Description
AboutBoxIndex | Represents variable AboutBoxIndex.
SplashScreenInitialized | Represents variable SplashScreenInitialized.
Top
Constants
Name | Description
BIMsg_AboutDescription | Represents constant BIMsg_AboutDescription.
BIMsg_AboutTitle | Represents constant BIMsg_AboutTitle.
Top
Routines
Name | Description
GetSplashBitmap | Represents method GetSplashBitmap.
RegisterAboutBox | Represents method RegisterAboutBox.
RegisterSplashScreen | Represents method RegisterSplashScreen.
UnRegisterAboutBox | Represents method UnRegisterAboutBox.
Top


TeeBIRegisterAbout Variables

Variables
Name | Description
AboutBoxIndex | Represents variable AboutBoxIndex.
SplashScreenInitialized | Represents variable SplashScreenInitialized.
Top


AboutBoxIndex Variable

Summary

Represents variable AboutBoxIndex.

Namespace: TeeBIRegisterAbout
Syntax
Delphi
AboutBoxIndex: Integer = -1;

Value

Type: Integer

See Also

Reference

  • TeeBIRegisterAbout


SplashScreenInitialized Variable

Summary

Represents variable SplashScreenInitialized.

Namespace: TeeBIRegisterAbout
Syntax
Delphi
SplashScreenInitialized: Boolean = False;

Value

Type: Boolean

See Also

Reference

  • TeeBIRegisterAbout


TeeBIRegisterAbout Constants

Constants
Name | Description
BIMsg_AboutDescription | Represents constant BIMsg_AboutDescription.
BIMsg_AboutTitle | Represents constant BIMsg_AboutTitle.
Top


BIMsg_AboutDescription Constant

Summary

Represents constant BIMsg_AboutDescription.

Namespace: TeeBIRegisterAbout
Syntax
Delphi
 BIMsg_AboutDescription='Business Intelligence and Data Visualization Tools';

Value

Type: string

See Also

Reference

  • TeeBIRegisterAbout


BIMsg_AboutTitle Constant

Summary

Represents constant BIMsg_AboutTitle.

Namespace: TeeBIRegisterAbout
Syntax
Delphi
 BIMsg_AboutTitle='TeeBI '+TeeBI_VersionString+' '+TeeBI_VersionMode;

Value

Type: string

See Also

Reference

  • TeeBIRegisterAbout


TeeBIRegisterAbout Routines

Routines
Name | Description
GetSplashBitmap | Represents method GetSplashBitmap.
RegisterAboutBox | Represents method RegisterAboutBox.
RegisterSplashScreen | Represents method RegisterSplashScreen.
UnRegisterAboutBox | Represents method UnRegisterAboutBox.
Top


GetSplashBitmap Method

Summary

Represents method GetSplashBitmap.

Namespace: TeeBIRegisterAbout
Syntax
Delphi
 function GetSplashBitmap:HBITMAP;

Return Value

Type: HBITMAP

See Also

Reference

  • TeeBIRegisterAbout


RegisterAboutBox Method

Summary

Represents method RegisterAboutBox.

Namespace: TeeBIRegisterAbout
Syntax
Delphi
procedure RegisterAboutBox;
See Also

Reference

  • TeeBIRegisterAbout


RegisterSplashScreen Method

Summary

Represents method RegisterSplashScreen.

Namespace: TeeBIRegisterAbout
Syntax
Delphi
procedure RegisterSplashScreen;
See Also

Reference

  • TeeBIRegisterAbout


UnRegisterAboutBox Method

Summary

Represents method UnRegisterAboutBox.

Namespace: TeeBIRegisterAbout
Syntax
Delphi
procedure UnRegisterAboutBox;
See Also

Reference

  • TeeBIRegisterAbout


TeeBIRegisterCreator Namespace

Summary

Represents namespace TeeBIRegisterCreator.

Classes
Name | Description
TGeneratedCreator | Represents type TGeneratedCreator.
Top


TeeBIRegisterCreator Classes

Classes
Name | Description
TGeneratedCreator | Represents type TGeneratedCreator.
Top


TGeneratedCreator Class

Summary

Represents type TGeneratedCreator.

Namespace: TeeBIRegisterCreator
Inheritance Hierarchy
TInterfacedObject
TeeBIRegisterCreator.TGeneratedCreator
Syntax
Delphi
type
 TGeneratedCreator=class(TInterfacedObject, IOTACreator, IOTAModuleCreator)
 end;

The TGeneratedCreator type exposes the following members.

Constructors
Show:
Name | Description
Create(String,String) | Initializes a new instance of the TGeneratedCreator class.
Top
Methods
Show:
Name | Description
FormCreated(IOTAFormEditor) | Represents method FormCreated(IOTAFormEditor).
GetAncestorName | Represents method GetAncestorName.
GetCreatorType | Represents method GetCreatorType.
GetExisting | Represents method GetExisting.
GetFileSystem | Represents method GetFileSystem.
GetFormName | Represents method GetFormName.
GetImplFileName | Represents method GetImplFileName.
GetIntfFileName | Represents method GetIntfFileName.
GetMainForm | Represents method GetMainForm.
GetOwner | Represents method GetOwner.
GetShowForm | Represents method GetShowForm.
GetShowSource | Represents method GetShowSource.
GetUnnamed | Represents method GetUnnamed.
NewFormFile(string,string) | Represents method NewFormFile(string,string).
NewImplSource(string,string,string) | Represents method NewImplSource(string,string,string).
NewIntfSource(string,string,string) | Represents method NewIntfSource(string,string,string).
Top
Fields
Show:
Name | Description
Code | Represents field Code.
UnitName | Represents field UnitName.
Top
See Also

Reference

  • TeeBIRegisterCreator


TGeneratedCreator Constructors

Constructors
Name | Description
Create(String,String) | Initializes a new instance of the TGeneratedCreator class.
Top


TGeneratedCreator.Create(String,String) Constructor

Summary

Initializes a new instance of the TGeneratedCreator class.

Namespace: TeeBIRegisterCreator
Syntax
Delphi
public
 Constructor Create(const ACode,AUnitName:String);

Parameters

ACode
Type: String

AUnitName
Type: String

See Also

Reference

  • TGeneratedCreator
  • TeeBIRegisterCreator


TGeneratedCreator Methods

Methods
Name | Description
FormCreated(IOTAFormEditor) | Represents method FormCreated(IOTAFormEditor).
GetAncestorName | Represents method GetAncestorName.
GetCreatorType | Represents method GetCreatorType.
GetExisting | Represents method GetExisting.
GetFileSystem | Represents method GetFileSystem.
GetFormName | Represents method GetFormName.
GetImplFileName | Represents method GetImplFileName.
GetIntfFileName | Represents method GetIntfFileName.
GetMainForm | Represents method GetMainForm.
GetOwner | Represents method GetOwner.
GetShowForm | Represents method GetShowForm.
GetShowSource | Represents method GetShowSource.
GetUnnamed | Represents method GetUnnamed.
NewFormFile(string,string) | Represents method NewFormFile(string,string).
NewImplSource(string,string,string) | Represents method NewImplSource(string,string,string).
NewIntfSource(string,string,string) | Represents method NewIntfSource(string,string,string).
Top


TGeneratedCreator.FormCreated(IOTAFormEditor) Method

Summary

Represents method FormCreated(IOTAFormEditor).

Namespace: TeeBIRegisterCreator
Syntax
Delphi
public
 procedure FormCreated(const FormEditor: IOTAFormEditor);

Parameters

FormEditor
Type: IOTAFormEditor

See Also

Reference

  • TGeneratedCreator
  • TeeBIRegisterCreator


TGeneratedCreator.GetAncestorName Method

Summary

Represents method GetAncestorName.

Namespace: TeeBIRegisterCreator
Syntax
Delphi
public
 function GetAncestorName: string;

Return Value

Type: string

See Also

Reference

  • TGeneratedCreator
  • TeeBIRegisterCreator


TGeneratedCreator.GetCreatorType Method

Summary

Represents method GetCreatorType.

Namespace: TeeBIRegisterCreator
Syntax
Delphi
public
 function GetCreatorType: string;

Return Value

Type: string

See Also

Reference

  • TGeneratedCreator
  • TeeBIRegisterCreator


TGeneratedCreator.GetExisting Method

Summary

Represents method GetExisting.

Namespace: TeeBIRegisterCreator
Syntax
Delphi
public
 function GetExisting: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TGeneratedCreator
  • TeeBIRegisterCreator


TGeneratedCreator.GetFileSystem Method

Summary

Represents method GetFileSystem.

Namespace: TeeBIRegisterCreator
Syntax
Delphi
public
 function GetFileSystem: string;

Return Value

Type: string

See Also

Reference

  • TGeneratedCreator
  • TeeBIRegisterCreator


TGeneratedCreator.GetFormName Method

Summary

Represents method GetFormName.

Namespace: TeeBIRegisterCreator
Syntax
Delphi
public
 function GetFormName: string;

Return Value

Type: string

See Also

Reference

  • TGeneratedCreator
  • TeeBIRegisterCreator


TGeneratedCreator.GetImplFileName Method

Summary

Represents method GetImplFileName.

Namespace: TeeBIRegisterCreator
Syntax
Delphi
public
 function GetImplFileName: string;

Return Value

Type: string

See Also

Reference

  • TGeneratedCreator
  • TeeBIRegisterCreator


TGeneratedCreator.GetIntfFileName Method

Summary

Represents method GetIntfFileName.

Namespace: TeeBIRegisterCreator
Syntax
Delphi
public
 function GetIntfFileName: string;

Return Value

Type: string

See Also

Reference

  • TGeneratedCreator
  • TeeBIRegisterCreator


TGeneratedCreator.GetMainForm Method

Summary

Represents method GetMainForm.

Namespace: TeeBIRegisterCreator
Syntax
Delphi
public
 function GetMainForm: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TGeneratedCreator
  • TeeBIRegisterCreator


TGeneratedCreator.GetOwner Method

Summary

Represents method GetOwner.

Namespace: TeeBIRegisterCreator
Syntax
Delphi
public
 function GetOwner: IOTAModule;

Return Value

Type: IOTAModule

See Also

Reference

  • TGeneratedCreator
  • TeeBIRegisterCreator


TGeneratedCreator.GetShowForm Method

Summary

Represents method GetShowForm.

Namespace: TeeBIRegisterCreator
Syntax
Delphi
public
 function GetShowForm: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TGeneratedCreator
  • TeeBIRegisterCreator


TGeneratedCreator.GetShowSource Method

Summary

Represents method GetShowSource.

Namespace: TeeBIRegisterCreator
Syntax
Delphi
public
 function GetShowSource: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TGeneratedCreator
  • TeeBIRegisterCreator


TGeneratedCreator.GetUnnamed Method

Summary

Represents method GetUnnamed.

Namespace: TeeBIRegisterCreator
Syntax
Delphi
public
 function GetUnnamed: Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TGeneratedCreator
  • TeeBIRegisterCreator


TGeneratedCreator.NewFormFile(string,string) Method

Summary

Represents method NewFormFile(string,string).

Namespace: TeeBIRegisterCreator
Syntax
Delphi
public
 function NewFormFile(const FormIdent, AncestorIdent: string): IOTAFile;

Parameters

FormIdent
Type: string

AncestorIdent
Type: string

Return Value

Type: IOTAFile

See Also

Reference

  • TGeneratedCreator
  • TeeBIRegisterCreator


TGeneratedCreator.NewImplSource(string,string,string) Method

Summary

Represents method NewImplSource(string,string,string).

Namespace: TeeBIRegisterCreator
Syntax
Delphi
public
 function NewImplSource(const ModuleIdent, FormIdent, AncestorIdent: string): IOTAFile;

Parameters

ModuleIdent
Type: string

FormIdent
Type: string

AncestorIdent
Type: string

Return Value

Type: IOTAFile

See Also

Reference

  • TGeneratedCreator
  • TeeBIRegisterCreator


TGeneratedCreator.NewIntfSource(string,string,string) Method

Summary

Represents method NewIntfSource(string,string,string).

Namespace: TeeBIRegisterCreator
Syntax
Delphi
public
 function NewIntfSource(const ModuleIdent, FormIdent, AncestorIdent: string): IOTAFile;

Parameters

ModuleIdent
Type: string

FormIdent
Type: string

AncestorIdent
Type: string

Return Value

Type: IOTAFile

See Also

Reference

  • TGeneratedCreator
  • TeeBIRegisterCreator


TGeneratedCreator Fields

Fields
Name | Description
Code | Represents field Code.
UnitName | Represents field UnitName.
Top


TGeneratedCreator.Code Field

Summary

Represents field Code.

Namespace: TeeBIRegisterCreator
Syntax
Delphi
public
 Code,
 UnitName : String;

Field Value

Type: String

See Also

Reference

  • TGeneratedCreator
  • TeeBIRegisterCreator


TGeneratedCreator.UnitName Field

Summary

Represents field UnitName.

Namespace: TeeBIRegisterCreator
Syntax
Delphi
public
 Code,
 UnitName : String;

Field Value

Type: String

See Also

Reference

  • TGeneratedCreator
  • TeeBIRegisterCreator


TeeBIRegisterMenu Namespace

Summary

Represents namespace TeeBIRegisterMenu.

Classes
Name | Description
TDummyMenu | Represents type TDummyMenu.
Top
Variables
Name | Description
BIMenu | Represents variable BIMenu.
Dummy | Represents variable Dummy.
Top
Routines
Name | Description
FindMenu(TMenuItem,String) | Represents method FindMenu(TMenuItem,String).
RegisterDataManagerMenu | Represents method RegisterDataManagerMenu.
Top


TeeBIRegisterMenu Classes

Classes
Name | Description
TDummyMenu | Represents type TDummyMenu.
Top


TDummyMenu Class

Summary

Represents type TDummyMenu.

Namespace: TeeBIRegisterMenu
Inheritance Hierarchy
TObject
TeeBIRegisterMenu.TDummyMenu
Syntax
Delphi
type
 TDummyMenu=class
 end;

The TDummyMenu type exposes the following members.

Methods
Show:
Name | Description
AboutAction(TObject) | Represents method AboutAction(TObject).
DataManagerAction(TObject) | Represents method DataManagerAction(TObject).
DemosAction(TObject) | Represents method DemosAction(TObject).
DocumentationAction(TObject) | Represents method DocumentationAction(TObject).
GenerateAction(TObject) | Represents method GenerateAction(TObject).
Top
See Also

Reference

  • TeeBIRegisterMenu


TDummyMenu Methods

Methods
Name | Description
AboutAction(TObject) | Represents method AboutAction(TObject).
DataManagerAction(TObject) | Represents method DataManagerAction(TObject).
DemosAction(TObject) | Represents method DemosAction(TObject).
DocumentationAction(TObject) | Represents method DocumentationAction(TObject).
GenerateAction(TObject) | Represents method GenerateAction(TObject).
Top


TDummyMenu.AboutAction(TObject) Method

Summary

Represents method AboutAction(TObject).

Namespace: TeeBIRegisterMenu
Syntax
Delphi
public
 procedure AboutAction(Sender:TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDummyMenu
  • TeeBIRegisterMenu


TDummyMenu.DataManagerAction(TObject) Method

Summary

Represents method DataManagerAction(TObject).

Namespace: TeeBIRegisterMenu
Syntax
Delphi
public
 procedure DataManagerAction(Sender:TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDummyMenu
  • TeeBIRegisterMenu


TDummyMenu.DemosAction(TObject) Method

Summary

Represents method DemosAction(TObject).

Namespace: TeeBIRegisterMenu
Syntax
Delphi
public
 procedure DemosAction(Sender:TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDummyMenu
  • TeeBIRegisterMenu


TDummyMenu.DocumentationAction(TObject) Method

Summary

Represents method DocumentationAction(TObject).

Namespace: TeeBIRegisterMenu
Syntax
Delphi
public
 procedure DocumentationAction(Sender:TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDummyMenu
  • TeeBIRegisterMenu


TDummyMenu.GenerateAction(TObject) Method

Summary

Represents method GenerateAction(TObject).

Namespace: TeeBIRegisterMenu
Syntax
Delphi
public
 procedure GenerateAction(Sender:TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDummyMenu
  • TeeBIRegisterMenu


TeeBIRegisterMenu Variables

Variables
Name | Description
BIMenu | Represents variable BIMenu.
Dummy | Represents variable Dummy.
Top


BIMenu Variable

Summary

Represents variable BIMenu.

Namespace: TeeBIRegisterMenu
Syntax
Delphi
BIMenu : TMenuItem=nil;

Value

Type: TMenuItem

See Also

Reference

  • TeeBIRegisterMenu


Dummy Variable

Summary

Represents variable Dummy.

Namespace: TeeBIRegisterMenu
Syntax
Delphi
Dummy : TDummyMenu=nil;

Value

Type: TDummyMenu

See Also

Reference

  • TeeBIRegisterMenu


TeeBIRegisterMenu Routines

Routines
Name | Description
FindMenu(TMenuItem,String) | Represents method FindMenu(TMenuItem,String).
RegisterDataManagerMenu | Represents method RegisterDataManagerMenu.
Top


FindMenu(TMenuItem,String) Method

Summary

Represents method FindMenu(TMenuItem,String).

Namespace: TeeBIRegisterMenu
Syntax
Delphi
function FindMenu(const AParent:TMenuItem; const AName:String):TMenuItem;

Parameters

AParent
Type: TMenuItem

AName
Type: String

Return Value

Type: TMenuItem

See Also

Reference

  • TeeBIRegisterMenu


RegisterDataManagerMenu Method

Summary

Represents method RegisterDataManagerMenu.

Namespace: TeeBIRegisterMenu
Syntax
Delphi
procedure RegisterDataManagerMenu;
See Also

Reference

  • TeeBIRegisterMenu


Unit_Icon_Generator Namespace

Summary

Represents namespace Unit_Icon_Generator.

Classes
Name | Description
TFormIconGenerator | Represents type TFormIconGenerator.
Top
Variables
Name | Description
FormIconGenerator | Represents variable FormIconGenerator.
Top
Constants
Name | Description
PNGExtension | Represents constant PNGExtension.
Top
Routines
Name | Description
OriginalBitmap(TGraphic) | Represents method OriginalBitmap(TGraphic).
ReduceTo8Bit(TBitmap,TColorReduction,TDitherMode) | Represents method ReduceTo8Bit(TBitmap,TColorReduction,TDitherMode).
ResizeBitmap(TBitmap,TBitmap,InterpolationMode) | Represents method ResizeBitmap(TBitmap,TBitmap,InterpolationMode).
Top


Unit_Icon_Generator Classes

Classes
Name | Description
TFormIconGenerator | Represents type TFormIconGenerator.
Top


TFormIconGenerator Class

Summary

Represents type TFormIconGenerator.

Namespace: Unit_Icon_Generator
Inheritance Hierarchy
TForm
Unit_Icon_Generator.TFormIconGenerator
Syntax
Delphi
type
 TFormIconGenerator = class(TForm)
 end;

The TFormIconGenerator type exposes the following members.

Methods
Show:
Name | Description
BLoadClick(TObject) | Represents method BLoadClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
LBIconsClick(TObject) | Represents method LBIconsClick(TObject).
LBQualityClick(TObject) | Represents method LBQualityClick(TObject).
Top
Fields
Show:
Name | Description
BLoad | Represents field BLoad.
Button1 | Represents field Button1.
EPath | Represents field EPath.
Image16x16 | Represents field Image16x16.
Image24x24 | Represents field Image24x24.
Image32x32 | Represents field Image32x32.
ImageOriginal | Represents field ImageOriginal.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
LBIcons | Represents field LBIcons.
LBQuality | Represents field LBQuality.
Top
See Also

Reference

  • Unit_Icon_Generator


TFormIconGenerator Methods

Methods
Name | Description
BLoadClick(TObject) | Represents method BLoadClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
LBIconsClick(TObject) | Represents method LBIconsClick(TObject).
LBQualityClick(TObject) | Represents method LBQualityClick(TObject).
Top


TFormIconGenerator.BLoadClick(TObject) Method

Summary

Represents method BLoadClick(TObject).

Namespace: Unit_Icon_Generator
Syntax
Delphi
published
 procedure BLoadClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFormIconGenerator
  • Unit_Icon_Generator


TFormIconGenerator.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: Unit_Icon_Generator
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFormIconGenerator
  • Unit_Icon_Generator


TFormIconGenerator.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: Unit_Icon_Generator
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFormIconGenerator
  • Unit_Icon_Generator


TFormIconGenerator.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: Unit_Icon_Generator
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFormIconGenerator
  • Unit_Icon_Generator


TFormIconGenerator.LBIconsClick(TObject) Method

Summary

Represents method LBIconsClick(TObject).

Namespace: Unit_Icon_Generator
Syntax
Delphi
published
 procedure LBIconsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFormIconGenerator
  • Unit_Icon_Generator


TFormIconGenerator.LBQualityClick(TObject) Method

Summary

Represents method LBQualityClick(TObject).

Namespace: Unit_Icon_Generator
Syntax
Delphi
published
 procedure LBQualityClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFormIconGenerator
  • Unit_Icon_Generator


TFormIconGenerator Fields

Fields
Name | Description
BLoad | Represents field BLoad.
Button1 | Represents field Button1.
EPath | Represents field EPath.
Image16x16 | Represents field Image16x16.
Image24x24 | Represents field Image24x24.
Image32x32 | Represents field Image32x32.
ImageOriginal | Represents field ImageOriginal.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
LBIcons | Represents field LBIcons.
LBQuality | Represents field LBQuality.
Top


TFormIconGenerator.BLoad Field

Summary

Represents field BLoad.

Namespace: Unit_Icon_Generator
Syntax
Delphi
published
 BLoad: TButton;

Field Value

Type: TButton

See Also

Reference

  • TFormIconGenerator
  • Unit_Icon_Generator


TFormIconGenerator.Button1 Field

Summary

Represents field Button1.

Namespace: Unit_Icon_Generator
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TFormIconGenerator
  • Unit_Icon_Generator


TFormIconGenerator.EPath Field

Summary

Represents field EPath.

Namespace: Unit_Icon_Generator
Syntax
Delphi
published
 EPath: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TFormIconGenerator
  • Unit_Icon_Generator


TFormIconGenerator.Image16x16 Field

Summary

Represents field Image16x16.

Namespace: Unit_Icon_Generator
Syntax
Delphi
published
 Image16x16: TImage;

Field Value

Type: TImage

See Also

Reference

  • TFormIconGenerator
  • Unit_Icon_Generator


TFormIconGenerator.Image24x24 Field

Summary

Represents field Image24x24.

Namespace: Unit_Icon_Generator
Syntax
Delphi
published
 Image24x24: TImage;

Field Value

Type: TImage

See Also

Reference

  • TFormIconGenerator
  • Unit_Icon_Generator


TFormIconGenerator.Image32x32 Field

Summary

Represents field Image32x32.

Namespace: Unit_Icon_Generator
Syntax
Delphi
published
 Image32x32: TImage;

Field Value

Type: TImage

See Also

Reference

  • TFormIconGenerator
  • Unit_Icon_Generator


TFormIconGenerator.ImageOriginal Field

Summary

Represents field ImageOriginal.

Namespace: Unit_Icon_Generator
Syntax
Delphi
published
 ImageOriginal: TImage;

Field Value

Type: TImage

See Also

Reference

  • TFormIconGenerator
  • Unit_Icon_Generator


TFormIconGenerator.Label1 Field

Summary

Represents field Label1.

Namespace: Unit_Icon_Generator
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TFormIconGenerator
  • Unit_Icon_Generator


TFormIconGenerator.Label2 Field

Summary

Represents field Label2.

Namespace: Unit_Icon_Generator
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TFormIconGenerator
  • Unit_Icon_Generator


TFormIconGenerator.Label3 Field

Summary

Represents field Label3.

Namespace: Unit_Icon_Generator
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TFormIconGenerator
  • Unit_Icon_Generator


TFormIconGenerator.Label4 Field

Summary

Represents field Label4.

Namespace: Unit_Icon_Generator
Syntax
Delphi
published
 Label4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TFormIconGenerator
  • Unit_Icon_Generator


TFormIconGenerator.LBIcons Field

Summary

Represents field LBIcons.

Namespace: Unit_Icon_Generator
Syntax
Delphi
published
 LBIcons: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TFormIconGenerator
  • Unit_Icon_Generator


TFormIconGenerator.LBQuality Field

Summary

Represents field LBQuality.

Namespace: Unit_Icon_Generator
Syntax
Delphi
published
 LBQuality: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TFormIconGenerator
  • Unit_Icon_Generator


Unit_Icon_Generator Variables

Variables
Name | Description
FormIconGenerator | Represents variable FormIconGenerator.
Top


FormIconGenerator Variable

Summary

Represents variable FormIconGenerator.

Namespace: Unit_Icon_Generator
Syntax
Delphi
FormIconGenerator: TFormIconGenerator;

Value

Type: TFormIconGenerator

See Also

Reference

  • Unit_Icon_Generator


Unit_Icon_Generator Constants

Constants
Name | Description
PNGExtension | Represents constant PNGExtension.
Top


PNGExtension Constant

Summary

Represents constant PNGExtension.

Namespace: Unit_Icon_Generator
Syntax
Delphi
 PNGExtension='.png';

Value

Type: string

See Also

Reference

  • Unit_Icon_Generator


Unit_Icon_Generator Routines

Routines
Name | Description
OriginalBitmap(TGraphic) | Represents method OriginalBitmap(TGraphic).
ReduceTo8Bit(TBitmap,TColorReduction,TDitherMode) | Represents method ReduceTo8Bit(TBitmap,TColorReduction,TDitherMode).
ResizeBitmap(TBitmap,TBitmap,InterpolationMode) | Represents method ResizeBitmap(TBitmap,TBitmap,InterpolationMode).
Top


OriginalBitmap(TGraphic) Method

Summary

Represents method OriginalBitmap(TGraphic).

Namespace: Unit_Icon_Generator
Syntax
Delphi
function OriginalBitmap(const AGraphic:TGraphic):TBitmap;

Parameters

AGraphic
Type: TGraphic

Return Value

Type: TBitmap

See Also

Reference

  • Unit_Icon_Generator


ReduceTo8Bit(TBitmap,TColorReduction,TDitherMode) Method

Summary

Represents method ReduceTo8Bit(TBitmap,TColorReduction,TDitherMode).

Namespace: Unit_Icon_Generator
Syntax
Delphi
Procedure ReduceTo8Bit(var bmp:TBitmap; ColorReduction: TColorReduction; DitherMode: TDitherMode);

Parameters

bmp
Type: TBitmap

ColorReduction
Type: TColorReduction

DitherMode
Type: TDitherMode

See Also

Reference

  • Unit_Icon_Generator


ResizeBitmap(TBitmap,TBitmap,InterpolationMode) Method

Summary

Represents method ResizeBitmap(TBitmap,TBitmap,InterpolationMode).

Namespace: Unit_Icon_Generator
Syntax
Delphi
procedure ResizeBitmap(const Source,Dest:TBitmap; const AMode:InterpolationMode);

Parameters

Source
Type: TBitmap

Dest
Type: TBitmap

AMode
Type: InterpolationMode

See Also

Reference

  • Unit_Icon_Generator


VCLBI.Chart Namespace

Summary

Represents namespace VCLBI.Chart.

Classes
Name | Description
TBIChart | Represents type TBIChart.
TBIChartItems | Represents type TBIChartItems.
TBIChartOptions | Represents type TBIChartOptions.
TCustomSeriesAccess | Represents type TCustomSeriesAccess.
TDataItemAccess | Represents type TDataItemAccess.
TSeriesAccess | Represents type TSeriesAccess.
Top
Enumerations
Name | Description
TBIChart3DMode | Represents type TBIChart3DMode.
TBIChartDimensions | Represents type TBIChartDimensions.
TBIChartLegend | Represents type TBIChartLegend.
TBIChartMarks | Represents type TBIChartMarks.
TBIChartMode | Represents type TBIChartMode.
TBISeriesDirection | Represents type TBISeriesDirection.
Top
Types
Name | Description
TGetText | Represents an alias of the TFunc type.
Top
Constants
Name | Description
LightSilver | Represents constant LightSilver.
Top
Routines
Name | Description
AssociateSeries(TChartSeries,TDataItem) | Represents method AssociateSeries(TChartSeries,TDataItem).
CanBeMeasure(TDataItem) | Represents method CanBeMeasure(TDataItem).
HasMeasures(TDataItem) | Represents method HasMeasures(TDataItem).
IsMeasure(TDataItem) | Represents method IsMeasure(TDataItem).
IsNumericOrDateTime(TDataItem) | Represents method IsNumericOrDateTime(TDataItem).
LastUniqueTable(TDataItem) | Represents method LastUniqueTable(TDataItem).
MapCount(TDataItem) | Represents method MapCount(TDataItem).
Top


VCLBI.Chart Classes

Classes
Name | Description
TBIChart | Represents type TBIChart.
TBIChartItems | Represents type TBIChartItems.
TBIChartOptions | Represents type TBIChartOptions.
TCustomSeriesAccess | Represents type TCustomSeriesAccess.
TDataItemAccess | Represents type TDataItemAccess.
TSeriesAccess | Represents type TSeriesAccess.
Top


TBIChart Class

Summary

Represents type TBIChart.

Namespace: VCLBI.Chart
Inheritance Hierarchy
TWinControl
VCLBI.DataControl.TBIDataControl
VCLBI.Chart.TBIChart
VCLBI.Editor.Chart.TBIChartAccess
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64 or pidOSX32
 or pidiOSSimulator or pidiOSDevice
 or pidAndroid
 or pidiOSDevice64
 )]
 TBIChart=class(TBIDataControl)
 end;

The TBIChart type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIChart class. (Overrides TBIDataControl.Create(TComponent).)
Destroy | Represents the destructor of the TBIChart class. (Overrides TBIDataControl.Destroy.)
Top
Properties
Show:
Name | Description
Chart | Represents property Chart.
Height | Represents property Height.
Options | Represents property Options.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Clear | Represents method Clear.
DirectRefresh | Represents method DirectRefresh.
ExchangeXY | Represents method ExchangeXY.
ExchangeXZ | Represents method ExchangeXZ.
ExchangeYZ | Represents method ExchangeYZ.
Fill(TDataArray) | Overloaded. Represents method Fill(TDataArray).
Fill(TDataCursor,TDataArray) | Overloaded. Represents method Fill(TDataCursor,TDataArray).
Fill(TDataItems) | Overloaded. Represents method Fill(TDataItems).
Fill(TDataMap,TGetText) | Overloaded. Represents method Fill(TDataMap,TGetText).
Fill(THistogram,TDataItem) | Overloaded. Represents method Fill(THistogram,TDataItem).
Fill(TSummary) | Overloaded. Represents method Fill(TSummary).
GetChildOwner | Represents method GetChildOwner.
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent).
Loaded | Represents method Loaded. (Overrides TBIDataControl.Loaded.)
ReadState(TReader) | Represents method ReadState(TReader).
ResetTheme | Represents method ResetTheme.
SetDataDirect(TDataItem) | Represents method SetDataDirect(TDataItem). (Overrides TBIDataControl.SetDataDirect(TDataItem).)
SetTwoAxes | Represents method SetTwoAxes.
SplitAxes(Boolean) | Represents method SplitAxes(Boolean).
WMPaint(TWMPaint) | Represents method WMPaint(TWMPaint).
Top
Fields
Show:
Name | Description
Index | Represents field Index.
RealMode | Represents field RealMode.
RealMode3D | Represents field RealMode3D.
Top
See Also

Reference

  • VCLBI.Chart


TBIChart.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIChart class.

Namespace: VCLBI.Chart
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TBIDataControl.Create(TComponent)
See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.Destroy Destructor

Summary

Represents the destructor of the TBIChart class.

Namespace: VCLBI.Chart
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TBIDataControl.Destroy
See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart Properties

Properties
Name | Description
Chart | Represents property Chart.
Height | Represents property Height.
Options | Represents property Options.
Width | Represents property Width.
Top


TBIChart.Chart Property

Summary

Represents property Chart.

Namespace: VCLBI.Chart
Syntax
Delphi
published
 property Chart:TBITChart read GetChart;

Property Value

Type: TBITChart

See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.Height Property

Summary

Represents property Height.

Namespace: VCLBI.Chart
Syntax
Delphi
published
 property Height default 250;

Property Value

Type: Void

See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.Options Property

Summary

Represents property Options.

Namespace: VCLBI.Chart
Syntax
Delphi
published
 property Options:TBIChartOptions read FOptions write SetOptions;

Property Value

Type: TBIChartOptions

See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.Width Property

Summary

Represents property Width.

Namespace: VCLBI.Chart
Syntax
Delphi
published
 property Width default 400;

Property Value

Type: Void

See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart Methods

Methods
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Clear | Represents method Clear.
DirectRefresh | Represents method DirectRefresh.
ExchangeXY | Represents method ExchangeXY.
ExchangeXZ | Represents method ExchangeXZ.
ExchangeYZ | Represents method ExchangeYZ.
Fill(TDataArray) | Overloaded. Represents method Fill(TDataArray).
Fill(TDataCursor,TDataArray) | Overloaded. Represents method Fill(TDataCursor,TDataArray).
Fill(TDataItems) | Overloaded. Represents method Fill(TDataItems).
Fill(TDataMap,TGetText) | Overloaded. Represents method Fill(TDataMap,TGetText).
Fill(THistogram,TDataItem) | Overloaded. Represents method Fill(THistogram,TDataItem).
Fill(TSummary) | Overloaded. Represents method Fill(TSummary).
GetChildOwner | Represents method GetChildOwner.
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent).
Loaded | Represents method Loaded. (Overrides TBIDataControl.Loaded.)
ReadState(TReader) | Represents method ReadState(TReader).
ResetTheme | Represents method ResetTheme.
SetDataDirect(TDataItem) | Represents method SetDataDirect(TDataItem). (Overrides TBIDataControl.SetDataDirect(TDataItem).)
SetTwoAxes | Represents method SetTwoAxes.
SplitAxes(Boolean) | Represents method SplitAxes(Boolean).
WMPaint(TWMPaint) | Represents method WMPaint(TWMPaint).
Top


TBIChart.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: VCLBI.Chart
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.Clear Method

Summary

Represents method Clear.

Namespace: VCLBI.Chart
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.DirectRefresh Method

Summary

Represents method DirectRefresh.

Namespace: VCLBI.Chart
Syntax
Delphi
protected
 procedure DirectRefresh;
See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.ExchangeXY Method

Summary

Represents method ExchangeXY.

Namespace: VCLBI.Chart
Syntax
Delphi
protected
 procedure ExchangeXY;
See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.ExchangeXZ Method

Summary

Represents method ExchangeXZ.

Namespace: VCLBI.Chart
Syntax
Delphi
protected
 procedure ExchangeXZ;
See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.ExchangeYZ Method

Summary

Represents method ExchangeYZ.

Namespace: VCLBI.Chart
Syntax
Delphi
protected
 procedure ExchangeYZ;
See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.Fill(TDataArray) Method

Summary

Represents method Fill(TDataArray).

Namespace: VCLBI.Chart
Syntax
Delphi
public
 procedure Fill(const AData:TDataArray); overload;

Parameters

AData
Type: TDataArray

See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.Fill(TDataCursor,TDataArray) Method

Summary

Represents method Fill(TDataCursor,TDataArray).

Namespace: VCLBI.Chart
Syntax
Delphi
public
 procedure Fill(const ACursor:TDataCursor; const AItems:TDataArray=nil); overload;

Parameters

ACursor
Type: TDataCursor

AItems
Type: TDataArray

See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.Fill(TDataItems) Method

Summary

Represents method Fill(TDataItems).

Namespace: VCLBI.Chart
Syntax
Delphi
public
 procedure Fill(const AItems:TDataItems); overload;

Parameters

AItems
Type: TDataItems

See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.Fill(TDataMap,TGetText) Method

Summary

Represents method Fill(TDataMap,TGetText).

Namespace: VCLBI.Chart
Syntax
Delphi
public
 procedure Fill(const Map:TDataMap; const Text:TGetText=nil); overload;

Parameters

Map
Type: TDataMap

Text
Type: System.Void

See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.Fill(THistogram,TDataItem) Method

Summary

Represents method Fill(THistogram,TDataItem).

Namespace: VCLBI.Chart
Syntax
Delphi
public
 procedure Fill(const AHistogram:THistogram; const ASource:TDataItem); overload;

Parameters

AHistogram
Type: THistogram

ASource
Type: TDataItem

See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.Fill(TSummary) Method

Summary

Represents method Fill(TSummary).

Namespace: VCLBI.Chart
Syntax
Delphi
public
 procedure Fill(const ASummary:TSummary); overload;

Parameters

ASummary
Type: TSummary

See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.GetChildOwner Method

Summary

Represents method GetChildOwner.

Namespace: VCLBI.Chart
Syntax
Delphi
public
 function GetChildOwner: TComponent; override;

Return Value

Type: TComponent

See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.GetChildren(TGetChildProc,TComponent) Method

Summary

Represents method GetChildren(TGetChildProc,TComponent).

Namespace: VCLBI.Chart
Syntax
Delphi
public
 Procedure GetChildren(Proc:TGetChildProc; Root:TComponent); override;

Parameters

Proc
Type: TGetChildProc

Root
Type: TComponent

See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.Loaded Method

Summary

Represents method Loaded.

Namespace: VCLBI.Chart
Syntax
Delphi
protected
 procedure Loaded; override;

Overrides

TBIDataControl.Loaded
See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.ReadState(TReader) Method

Summary

Represents method ReadState(TReader).

Namespace: VCLBI.Chart
Syntax
Delphi
protected
 procedure ReadState(Reader: TReader); override;

Parameters

Reader
Type: TReader

See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.ResetTheme Method

Summary

Represents method ResetTheme.

Namespace: VCLBI.Chart
Syntax
Delphi
protected
 procedure ResetTheme;
See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.SetDataDirect(TDataItem) Method

Summary

Represents method SetDataDirect(TDataItem).

Namespace: VCLBI.Chart
Syntax
Delphi
protected
 procedure SetDataDirect(const Value: TDataItem); override;

Parameters

Value
Type: TDataItem

Overrides

TBIDataControl.SetDataDirect(TDataItem)
See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.SetTwoAxes Method

Summary

Represents method SetTwoAxes.

Namespace: VCLBI.Chart
Syntax
Delphi
public
 procedure SetTwoAxes;
See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.SplitAxes(Boolean) Method

Summary

Represents method SplitAxes(Boolean).

Namespace: VCLBI.Chart
Syntax
Delphi
public
 procedure SplitAxes(const Vertical:Boolean);

Parameters

Vertical
Type: Boolean

See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.WMPaint(TWMPaint) Method

Summary

Represents method WMPaint(TWMPaint).

Namespace: VCLBI.Chart
Syntax
Delphi
protected
 procedure WMPaint(var Message: TWMPaint); message WM_PAINT;

Parameters

Message
Type: TWMPaint

See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.Index Field

Summary

Represents field Index.

Namespace: VCLBI.Chart
Syntax
Delphi
protected
 Index : TCursorIndex;

Field Value

Type: TCursorIndex

See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.RealMode Field

Summary

Represents field RealMode.

Namespace: VCLBI.Chart
Syntax
Delphi
protected
 RealMode : TBIChartMode;

Field Value

Type: TBIChartMode

See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChart.RealMode3D Field

Summary

Represents field RealMode3D.

Namespace: VCLBI.Chart
Syntax
Delphi
protected
 RealMode3D : TBIChart3DMode;

Field Value

Type: TBIChart3DMode

See Also

Reference

  • TBIChart
  • VCLBI.Chart


TBIChartItems Class

Summary

Represents type TBIChartItems.

Namespace: VCLBI.Chart
Inheritance Hierarchy
TPersistent
VCLBI.Chart.TBIChartItems
Syntax
Delphi
type
 TBIChartItems=class(TPersistent)
 end;

The TBIChartItems type exposes the following members.

Methods
Show:
Name | Description
CanFinancial | Represents method CanFinancial.
CanGeoGraphic | Represents method CanGeoGraphic.
CanThreeD | Represents method CanThreeD.
CanXYZ | Represents method CanXYZ.
Clear | Represents method Clear.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Loaded(TDataArray) | Represents method Loaded(TDataArray).
Top
Fields
Show:
Name | Description
Colors | Represents field Colors.
Group | Represents field Group.
Text | Represents field Text.
X | Represents field X.
Y | Represents field Y.
Z | Represents field Z.
Top
See Also

Reference

  • VCLBI.Chart


TBIChartItems.CanFinancial Method

Summary

Represents method CanFinancial.

Namespace: VCLBI.Chart
Syntax
Delphi
public
 function CanFinancial:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TBIChartItems
  • VCLBI.Chart


TBIChartItems.CanGeoGraphic Method

Summary

Represents method CanGeoGraphic.

Namespace: VCLBI.Chart
Syntax
Delphi
public
 function CanGeoGraphic:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TBIChartItems
  • VCLBI.Chart


TBIChartItems.CanThreeD Method

Summary

Represents method CanThreeD.

Namespace: VCLBI.Chart
Syntax
Delphi
public
 function CanThreeD:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TBIChartItems
  • VCLBI.Chart


TBIChartItems.CanXYZ Method

Summary

Represents method CanXYZ.

Namespace: VCLBI.Chart
Syntax
Delphi
public
 function CanXYZ:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TBIChartItems
  • VCLBI.Chart


TBIChartItems.Clear Method

Summary

Represents method Clear.

Namespace: VCLBI.Chart
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TBIChartItems
  • VCLBI.Chart


TBIChartItems.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: VCLBI.Chart
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TBIChartItems
  • VCLBI.Chart


TBIChartItems.Loaded(TDataArray) Method

Summary

Represents method Loaded(TDataArray).

Namespace: VCLBI.Chart
Syntax
Delphi
protected
 procedure Loaded(const AData:TDataArray);

Parameters

AData
Type: TDataArray

See Also

Reference

  • TBIChartItems
  • VCLBI.Chart


TBIChartItems.Colors Field

Summary

Represents field Colors.

Namespace: VCLBI.Chart
Syntax
Delphi
public
 X,
 Z,
 Text,
 Colors,
 Group : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TBIChartItems
  • VCLBI.Chart


TBIChartItems.Group Field

Summary

Represents field Group.

Namespace: VCLBI.Chart
Syntax
Delphi
public
 X,
 Z,
 Text,
 Colors,
 Group : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TBIChartItems
  • VCLBI.Chart


TBIChartItems.Text Field

Summary

Represents field Text.

Namespace: VCLBI.Chart
Syntax
Delphi
public
 X,
 Z,
 Text,
 Colors,
 Group : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TBIChartItems
  • VCLBI.Chart


TBIChartItems.X Field

Summary

Represents field X.

Namespace: VCLBI.Chart
Syntax
Delphi
public
 X,
 Z,
 Text,
 Colors,
 Group : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TBIChartItems
  • VCLBI.Chart


TBIChartItems.Y Field

Summary

Represents field Y.

Namespace: VCLBI.Chart
Syntax
Delphi
public
 Y : TDataArray;

Field Value

Type: TDataArray

See Also

Reference

  • TBIChartItems
  • VCLBI.Chart


TBIChartItems.Z Field

Summary

Represents field Z.

Namespace: VCLBI.Chart
Syntax
Delphi
public
 X,
 Z,
 Text,
 Colors,
 Group : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TBIChartItems
  • VCLBI.Chart


TBIChartOptions Class

Summary

Represents type TBIChartOptions.

Namespace: VCLBI.Chart
Inheritance Hierarchy
TPersistent
VCLBI.Chart.TBIChartOptions
Syntax
Delphi
type
 TBIChartOptions=class(TPersistent)
 end;

The TBIChartOptions type exposes the following members.

Constructors
Show:
Name | Description
Create(TBIChart) | Initializes a new instance of the TBIChartOptions class.
Destroy | Represents the destructor of the TBIChartOptions class.
Top
Properties
Show:
Name | Description
Dimensions | Represents property Dimensions.
Direction | Represents property Direction.
Items | Represents property Items.
Legend | Represents property Legend.
Marks | Represents property Marks.
Mode | Represents property Mode.
Series2D | Represents property Series2D.
Series3D | Represents property Series3D.
SeriesDirection | Represents property SeriesDirection.
Stacked | Represents property Stacked.
XYZMode | Represents property XYZMode.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
ChangeSeries2D(TChartSeriesClass,Boolean,Boolean) | Represents method ChangeSeries2D(TChartSeriesClass,Boolean,Boolean).
Top
See Also

Reference

  • VCLBI.Chart


TBIChartOptions.Create(TBIChart) Constructor

Summary

Initializes a new instance of the TBIChartOptions class.

Namespace: VCLBI.Chart
Syntax
Delphi
public
 Constructor Create(const AChart:TBIChart);

Parameters

AChart
Type: TBIChart

See Also

Reference

  • TBIChartOptions
  • VCLBI.Chart


TBIChartOptions.Destroy Destructor

Summary

Represents the destructor of the TBIChartOptions class.

Namespace: VCLBI.Chart
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIChartOptions
  • VCLBI.Chart


TBIChartOptions.Dimensions Property

Summary

Represents property Dimensions.

Namespace: VCLBI.Chart
Syntax
Delphi
published
 property Dimensions:TBIChartDimensions read FDimensions write SetDimensions
 default TBIChartDimensions.Automatic;

Property Value

Type: TBIChartDimensions

See Also

Reference

  • TBIChartOptions
  • VCLBI.Chart


TBIChartOptions.Direction Property

Summary

Represents property Direction.

Namespace: VCLBI.Chart
Syntax
Delphi
published
 property Direction:TBIChartDirection read FDirection write SetDirection default TBIChartDirection.Automatic;

Property Value

Type: TBIChartDirection

See Also

Reference

  • TBIChartOptions
  • VCLBI.Chart


TBIChartOptions.Items Property

Summary

Represents property Items.

Namespace: VCLBI.Chart
Syntax
Delphi
published
 property Items:TBIChartItems read FItems write SetItems;

Property Value

Type: TBIChartItems

See Also

Reference

  • TBIChartOptions
  • VCLBI.Chart


TBIChartOptions.Legend Property

Summary

Represents property Legend.

Namespace: VCLBI.Chart
Syntax
Delphi
published
 property Legend:TBIChartLegend read FLegend write SetLegend
 default TBIChartLegend.Automatic;

Property Value

Type: TBIChartLegend

See Also

Reference

  • TBIChartOptions
  • VCLBI.Chart


TBIChartOptions.Marks Property

Summary

Represents property Marks.

Namespace: VCLBI.Chart
Syntax
Delphi
published
 property Marks:TBIChartMarks read FMarks write SetMarks
 default TBIChartMarks.Automatic;

Property Value

Type: TBIChartMarks

See Also

Reference

  • TBIChartOptions
  • VCLBI.Chart


TBIChartOptions.Mode Property

Summary

Represents property Mode.

Namespace: VCLBI.Chart
Syntax
Delphi
published
 property Mode:TBIChartMode read FMode write SetMode default TBIChartMode.Automatic;

Property Value

Type: TBIChartMode

See Also

Reference

  • TBIChartOptions
  • VCLBI.Chart


TBIChartOptions.Series2D Property

Summary

Represents property Series2D.

Namespace: VCLBI.Chart
Syntax
Delphi
public
 property Series2D:TChartSeriesClass read GetSeries2D write SetSeries2D;

Property Value

Type: TChartSeriesClass

See Also

Reference

  • TBIChartOptions
  • VCLBI.Chart


TBIChartOptions.Series3D Property

Summary

Represents property Series3D.

Namespace: VCLBI.Chart
Syntax
Delphi
public
 property Series3D:TChartSeriesClass read GetSeries3D write SetSeries3D;

Property Value

Type: TChartSeriesClass

See Also

Reference

  • TBIChartOptions
  • VCLBI.Chart


TBIChartOptions.SeriesDirection Property

Summary

Represents property SeriesDirection.

Namespace: VCLBI.Chart
Syntax
Delphi
published
 property SeriesDirection: TBISeriesDirection read FSeriesDirection write SetSeriesDirection
 default TBISeriesDirection.Automatic;

Property Value

Type: TBISeriesDirection

See Also

Reference

  • TBIChartOptions
  • VCLBI.Chart


TBIChartOptions.Stacked Property

Summary

Represents property Stacked.

Namespace: VCLBI.Chart
Syntax
Delphi
published
 property Stacked:TBIChartStacked read FStacked write SetStacked
 default TBIChartStacked.Automatic;

Property Value

Type: TBIChartStacked

See Also

Reference

  • TBIChartOptions
  • VCLBI.Chart


TBIChartOptions.XYZMode Property

Summary

Represents property XYZMode.

Namespace: VCLBI.Chart
Syntax
Delphi
published
 property XYZMode:TBIChart3DMode read FXYZMode write SetXYZMode default TBIChart3DMode.Automatic;

Property Value

Type: TBIChart3DMode

See Also

Reference

  • TBIChartOptions
  • VCLBI.Chart


TBIChartOptions.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: VCLBI.Chart
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TBIChartOptions
  • VCLBI.Chart


TBIChartOptions.ChangeSeries2D(TChartSeriesClass,Boolean,Boolean) Method

Summary

Represents method ChangeSeries2D(TChartSeriesClass,Boolean,Boolean).

Namespace: VCLBI.Chart
Syntax
Delphi
public
 procedure ChangeSeries2D(const AClass:TChartSeriesClass;
 const AHorizontal,ALinePointer:Boolean);

Parameters

AClass
Type: TChartSeriesClass

AHorizontal
Type: Boolean

ALinePointer
Type: Boolean

See Also

Reference

  • TBIChartOptions
  • VCLBI.Chart


TCustomSeriesAccess Class

Summary

Represents type TCustomSeriesAccess.

Namespace: VCLBI.Chart
Inheritance Hierarchy
TCustomSeries
VCLBI.Chart.TCustomSeriesAccess
Syntax
Delphi
type
 TCustomSeriesAccess=class(TCustomSeries);
See Also

Reference

  • VCLBI.Chart


TDataItemAccess Class

Summary

Represents type TDataItemAccess.

Namespace: VCLBI.Chart
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
VCLBI.Chart.TDataItemAccess
Syntax
Delphi
type
 TDataItemAccess=class(TDataItem);
See Also

Reference

  • VCLBI.Chart


TSeriesAccess Class

Summary

Represents type TSeriesAccess.

Namespace: VCLBI.Chart
Inheritance Hierarchy
TChartSeries
VCLBI.Chart.TSeriesAccess
Syntax
Delphi
type
 TSeriesAccess=class(TChartSeries);
See Also

Reference

  • VCLBI.Chart


VCLBI.Chart Enumerations

Enumerations
Name | Description
TBIChart3DMode | Represents type TBIChart3DMode.
TBIChartDimensions | Represents type TBIChartDimensions.
TBIChartLegend | Represents type TBIChartLegend.
TBIChartMarks | Represents type TBIChartMarks.
TBIChartMode | Represents type TBIChartMode.
TBISeriesDirection | Represents type TBISeriesDirection.
Top


TBIChart3DMode Enumeration

Summary

Represents type TBIChart3DMode.

Namespace: VCLBI.Chart
Syntax
Delphi
type
 TBIChart3DMode=(Automatic, Table, Grid, XYZ);

The TBIChart3DMode type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Grid | Represents constant Grid.
Table | Represents constant Table.
XYZ | Represents constant XYZ.
Top
See Also

Reference

  • VCLBI.Chart


TBIChartDimensions Enumeration

Summary

Represents type TBIChartDimensions.

Namespace: VCLBI.Chart
Syntax
Delphi
type
 TBIChartDimensions=(Automatic, View2D, Orthogonal, View3D);

The TBIChartDimensions type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Orthogonal | Represents constant Orthogonal.
View2D | Represents constant View2D.
View3D | Represents constant View3D.
Top
See Also

Reference

  • VCLBI.Chart


TBIChartLegend Enumeration

Summary

Represents type TBIChartLegend.

Namespace: VCLBI.Chart
Syntax
Delphi
type
 TBIChartLegend=(Automatic, Show, Hide);

The TBIChartLegend type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Hide | Represents constant Hide.
Show | Represents constant Show.
Top
See Also

Reference

  • VCLBI.Chart


TBIChartMarks Enumeration

Summary

Represents type TBIChartMarks.

Namespace: VCLBI.Chart
Syntax
Delphi
type
 TBIChartMarks=(Automatic, Show, Hide);

The TBIChartMarks type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Hide | Represents constant Hide.
Show | Represents constant Show.
Top
See Also

Reference

  • VCLBI.Chart


TBIChartMode Enumeration

Summary

Represents type TBIChartMode.

Namespace: VCLBI.Chart
Syntax
Delphi
type
 TBIChartMode=(Automatic, XY, ThreeD, Financial, Geographic);

The TBIChartMode type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Financial | Represents constant Financial.
Geographic | Represents constant Geographic.
ThreeD | Represents constant ThreeD.
XY | Represents constant XY.
Top
See Also

Reference

  • VCLBI.Chart


TBISeriesDirection Enumeration

Summary

Represents type TBISeriesDirection.

Namespace: VCLBI.Chart
Syntax
Delphi
type
 TBISeriesDirection=(Automatic, Horizontal, Vertical);

The TBISeriesDirection type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Horizontal | Represents constant Horizontal.
Vertical | Represents constant Vertical.
Top
See Also

Reference

  • VCLBI.Chart


VCLBI.Chart Types

Types
Name | Description
TGetText | Represents an alias of the TFunc type.
Top


TGetText Type

Summary

Represents an alias of the TFunc type.

Namespace: VCLBI.Chart
Syntax
Delphi
type
 TGetText=TFunc<Integer,String>;
See Also

Reference

  • VCLBI.Chart


VCLBI.Chart Constants

Constants
Name | Description
LightSilver | Represents constant LightSilver.
Top


LightSilver Constant

Summary

Represents constant LightSilver.

Namespace: VCLBI.Chart
Syntax
Delphi
 LightSilver=$E6E6E6;

Value

Type: Integer

See Also

Reference

  • VCLBI.Chart


VCLBI.Chart Routines

Routines
Name | Description
AssociateSeries(TChartSeries,TDataItem) | Represents method AssociateSeries(TChartSeries,TDataItem).
CanBeMeasure(TDataItem) | Represents method CanBeMeasure(TDataItem).
HasMeasures(TDataItem) | Represents method HasMeasures(TDataItem).
IsMeasure(TDataItem) | Represents method IsMeasure(TDataItem).
IsNumericOrDateTime(TDataItem) | Represents method IsNumericOrDateTime(TDataItem).
LastUniqueTable(TDataItem) | Represents method LastUniqueTable(TDataItem).
MapCount(TDataItem) | Represents method MapCount(TDataItem).
Top


AssociateSeries(TChartSeries,TDataItem) Method

Summary

Represents method AssociateSeries(TChartSeries,TDataItem).

Namespace: VCLBI.Chart
Syntax
Delphi
procedure AssociateSeries(const ASeries:TChartSeries; const AData:TDataItem);

Parameters

ASeries
Type: TChartSeries

AData
Type: TDataItem

See Also

Reference

  • VCLBI.Chart


CanBeMeasure(TDataItem) Method

Summary

Represents method CanBeMeasure(TDataItem).

Namespace: VCLBI.Chart
Syntax
Delphi
function CanBeMeasure(const ANumeric:TDataItem):Boolean;

Parameters

ANumeric
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • VCLBI.Chart


HasMeasures(TDataItem) Method

Summary

Represents method HasMeasures(TDataItem).

Namespace: VCLBI.Chart
Syntax
Delphi
function HasMeasures(const AData:TDataItem):Boolean;

Parameters

AData
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • VCLBI.Chart


IsMeasure(TDataItem) Method

Summary

Represents method IsMeasure(TDataItem).

Namespace: VCLBI.Chart
Syntax
Delphi
function IsMeasure(const AData:TDataItem):Boolean;

Parameters

AData
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • VCLBI.Chart


IsNumericOrDateTime(TDataItem) Method

Summary

Represents method IsNumericOrDateTime(TDataItem).

Namespace: VCLBI.Chart
Syntax
Delphi
function IsNumericOrDateTime(const AData:TDataItem):Boolean;

Parameters

AData
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • VCLBI.Chart


LastUniqueTable(TDataItem) Method

Summary

Represents method LastUniqueTable(TDataItem).

Namespace: VCLBI.Chart
Syntax
Delphi
function LastUniqueTable(const AData:TDataItem):TDataItem;

Parameters

AData
Type: TDataItem

Return Value

Type: TDataItem

See Also

Reference

  • VCLBI.Chart


MapCount(TDataItem) Method

Summary

Represents method MapCount(TDataItem).

Namespace: VCLBI.Chart
Syntax
Delphi
function MapCount(const AData:TDataItem):TInteger;

Parameters

AData
Type: TDataItem

Return Value

Type: TInteger

See Also

Reference

  • VCLBI.Chart


VCLBI.Chart.Financial Namespace

Summary

Represents namespace VCLBI.Chart.Financial.

Classes
Name | Description
TDataItemAccess | Represents type TDataItemAccess.
Top
Records
Name | Description
TFinancialChart | Represents type TFinancialChart.
TOpenClose | Represents type TOpenClose.
Top
Types
Name | Description
TOHLCSeriesClass | Represents type TOHLCSeriesClass.
Top
Constants
Name | Description
OpenClose | Represents constant OpenClose.
Top
Routines
Name | Description
ContainsText(String,String) | Represents method ContainsText(String,String).
ExistsData(String,TDataArray) | Represents method ExistsData(String,TDataArray).
ReverseDate(String) | Represents method ReverseDate(String).
SwapFloat(TChartValue,TChartValue) | Represents method SwapFloat(TChartValue,TChartValue).
Top


VCLBI.Chart.Financial Classes

Classes
Name | Description
TDataItemAccess | Represents type TDataItemAccess.
Top


TDataItemAccess Class

Summary

Represents type TDataItemAccess.

Namespace: VCLBI.Chart.Financial
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
VCLBI.Chart.Financial.TDataItemAccess
Syntax
Delphi
type
 TDataItemAccess=class(TDataItem);
See Also

Reference

  • VCLBI.Chart.Financial


VCLBI.Chart.Financial Records

Records
Name | Description
TFinancialChart | Represents type TFinancialChart.
TOpenClose | Represents type TOpenClose.
Top


TFinancialChart Record

Summary

Represents type TFinancialChart.

Namespace: VCLBI.Chart.Financial
Syntax
Delphi
type
 TFinancialChart=record
 end;

The TFinancialChart type exposes the following members.

Methods
Show:
Name | Description
CanReuse(TBITChart) | Represents method CanReuse(TBITChart).
Fill(TBITChart,TDataArray,TDataItem) | Represents method Fill(TBITChart,TDataArray,TDataItem).
Guess(TDataArray) | Represents method Guess(TDataArray).
Top
Fields
Show:
Name | Description
SeriesClass | Represents field SeriesClass.
Top
See Also

Reference

  • VCLBI.Chart.Financial


TFinancialChart.CanReuse(TBITChart) Method

Summary

Represents method CanReuse(TBITChart).

Namespace: VCLBI.Chart.Financial
Syntax
Delphi
public
 class function CanReuse(const AChart:TBITChart):Boolean; static;

Parameters

AChart
Type: TBITChart

Return Value

Type: Boolean

See Also

Reference

  • TFinancialChart
  • VCLBI.Chart.Financial


TFinancialChart.Fill(TBITChart,TDataArray,TDataItem) Method

Summary

Represents method Fill(TBITChart,TDataArray,TDataItem).

Namespace: VCLBI.Chart.Financial
Syntax
Delphi
public
 class procedure Fill(const AChart:TBITChart;
 const AValues:TDataArray;
 const AX:TDataItem); static;

Parameters

AChart
Type: TBITChart

AValues
Type: TDataArray

AX
Type: TDataItem

See Also

Reference

  • TFinancialChart
  • VCLBI.Chart.Financial


TFinancialChart.Guess(TDataArray) Method

Summary

Represents method Guess(TDataArray).

Namespace: VCLBI.Chart.Financial
Syntax
Delphi
public
 class function Guess(const AValues:TDataArray):Boolean; static;

Parameters

AValues
Type: TDataArray

Return Value

Type: Boolean

See Also

Reference

  • TFinancialChart
  • VCLBI.Chart.Financial


TFinancialChart.SeriesClass Field

Summary

Represents field SeriesClass.

Namespace: VCLBI.Chart.Financial
Syntax
Delphi
public
 class var
 SeriesClass : TOHLCSeriesClass;

Field Value

Type: TOHLCSeriesClass

See Also

Reference

  • TFinancialChart
  • VCLBI.Chart.Financial


TOpenClose Record

Summary

Represents type TOpenClose.

Namespace: VCLBI.Chart.Financial
Syntax
Delphi
type
 TOpenClose=record
 end;

The TOpenClose type exposes the following members.

Fields
Show:
Name | Description
Close | Represents field Close.
Open | Represents field Open.
Top
See Also

Reference

  • VCLBI.Chart.Financial


TOpenClose.Close Field

Summary

Represents field Close.

Namespace: VCLBI.Chart.Financial
Syntax
Delphi
public
 Open,
 Close : String;

Field Value

Type: String

See Also

Reference

  • TOpenClose
  • VCLBI.Chart.Financial


TOpenClose.Open Field

Summary

Represents field Open.

Namespace: VCLBI.Chart.Financial
Syntax
Delphi
public
 Open,
 Close : String;

Field Value

Type: String

See Also

Reference

  • TOpenClose
  • VCLBI.Chart.Financial


VCLBI.Chart.Financial Types

Types
Name | Description
TOHLCSeriesClass | Represents type TOHLCSeriesClass.
Top


TOHLCSeriesClass Type

Summary

Represents type TOHLCSeriesClass.

Namespace: VCLBI.Chart.Financial
Syntax
Delphi
type
 TOHLCSeriesClass=class of TOHLCSeries;
See Also

Reference

  • VCLBI.Chart.Financial


VCLBI.Chart.Financial Constants

Constants
Name | Description
OpenClose | Represents constant OpenClose.
Top


OpenClose Constant

Summary

Represents constant OpenClose.

Namespace: VCLBI.Chart.Financial
Syntax
Delphi
 OpenClose : Array[0..2] of TOpenClose=
 (
 ( Open:'open'; Close:'close'),
 ( Open:'apertura'; Close:'cierre'),
 ( Open:'ouvrir'; Close:'clôture')
 );

Value

Type: Array[0..2] of TOpenClose

See Also

Reference

  • VCLBI.Chart.Financial


VCLBI.Chart.Financial Routines

Routines
Name | Description
ContainsText(String,String) | Represents method ContainsText(String,String).
ExistsData(String,TDataArray) | Represents method ExistsData(String,TDataArray).
ReverseDate(String) | Represents method ReverseDate(String).
SwapFloat(TChartValue,TChartValue) | Represents method SwapFloat(TChartValue,TChartValue).
Top


ContainsText(String,String) Method

Summary

Represents method ContainsText(String,String).

Namespace: VCLBI.Chart.Financial
Syntax
Delphi
function ContainsText(const Big,Small:String):Boolean;

Parameters

Big
Type: String

Small
Type: String

Return Value

Type: Boolean

See Also

Reference

  • VCLBI.Chart.Financial


ExistsData(String,TDataArray) Method

Summary

Represents method ExistsData(String,TDataArray).

Namespace: VCLBI.Chart.Financial
Syntax
Delphi
function ExistsData(const AName:String; const AData:TDataArray):TDataItem;

Parameters

AName
Type: String

AData
Type: TDataArray

Return Value

Type: TDataItem

See Also

Reference

  • VCLBI.Chart.Financial


ReverseDate(String) Method

Summary

Represents method ReverseDate(String).

Namespace: VCLBI.Chart.Financial
Syntax
Delphi
function ReverseDate(const S:String):String;

Parameters

S
Type: String

Return Value

Type: String

See Also

Reference

  • VCLBI.Chart.Financial


SwapFloat(TChartValue,TChartValue) Method

Summary

Represents method SwapFloat(TChartValue,TChartValue).

Namespace: VCLBI.Chart.Financial
Syntax
Delphi
procedure SwapFloat(var A,B:TChartValue);

Parameters

A
Type: TChartValue

B
Type: TChartValue

See Also

Reference

  • VCLBI.Chart.Financial


VCLBI.Chart.Geo Namespace

Summary

Represents namespace VCLBI.Chart.Geo.

Classes
Name | Description
TChartSeriesAccess | Represents type TChartSeriesAccess.
TDataAccess | Represents type TDataAccess.
TEntityMapsHelper | Represents type TEntityMapsHelper.
Top
Records
Name | Description
TEntityMap | Represents type TEntityMap.
TGeoChart | Represents type TGeoChart.
TGeoContext | Represents type TGeoContext.
Top
Types
Name | Description
TEntityMaps | Represents an array of the TEntityMap type.
Top
Variables
Name | Description
IEntityMaps | Represents variable IEntityMaps.
Top
Routines
Name | Description
ContainsAlaskaHawaii(TDataItem,Boolean) | Represents method ContainsAlaskaHawaii(TDataItem,Boolean).
FillPolygons(TWorldSeries,TDataItem,TDataItem,Boolean,Boolean) | Represents method FillPolygons(TWorldSeries,TDataItem,TDataItem,Boolean,Boolean).
FindMapEntities(TDataItem,TGeoContext) | Represents method FindMapEntities(TDataItem,TGeoContext).
SetAllNull(TChartSeries) | Represents method SetAllNull(TChartSeries).
Top


VCLBI.Chart.Geo Classes

Classes
Name | Description
TChartSeriesAccess | Represents type TChartSeriesAccess.
TDataAccess | Represents type TDataAccess.
TEntityMapsHelper | Represents type TEntityMapsHelper.
Top


TChartSeriesAccess Class

Summary

Represents type TChartSeriesAccess.

Namespace: VCLBI.Chart.Geo
Inheritance Hierarchy
TChartSeries
VCLBI.Chart.Geo.TChartSeriesAccess
Syntax
Delphi
type
 TChartSeriesAccess=class(TChartSeries);
See Also

Reference

  • VCLBI.Chart.Geo


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: VCLBI.Chart.Geo
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
VCLBI.Chart.Geo.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • VCLBI.Chart.Geo


TEntityMapsHelper Class Helper

Summary

Represents type TEntityMapsHelper.

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
type
 TEntityMapsHelper=record helper for TEntityMaps
 end;
Methods
Name | Description
Add(TWorldMap,TEntity,Boolean) | Represents method Add(TWorldMap,TEntity,Boolean).
AddMulti(TWorldMap,TEntity,Boolean) | Represents method AddMulti(TWorldMap,TEntity,Boolean).
Count | Represents method Count.
Top
See Also

Reference

  • VCLBI.Chart.Geo


TEntityMapsHelper.Add(TWorldMap,TEntity,Boolean) Method

Summary

Represents method Add(TWorldMap,TEntity,Boolean).

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
public
 procedure Add(const AMap:TWorldMap;
 const AEntity:TEntity;
 const UseSynonyms:Boolean=False);

Parameters

AMap
Type: TWorldMap

AEntity
Type: TEntity

UseSynonyms
Type: Boolean

See Also

Reference

  • TEntityMapsHelper
  • VCLBI.Chart.Geo


TEntityMapsHelper.AddMulti(TWorldMap,TEntity,Boolean) Method

Summary

Represents method AddMulti(TWorldMap,TEntity,Boolean).

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
public
 procedure AddMulti(const AMap:TWorldMap;
 const AEntity:TEntity;
 const UseSynonyms:Boolean=False);

Parameters

AMap
Type: TWorldMap

AEntity
Type: TEntity

UseSynonyms
Type: Boolean

See Also

Reference

  • TEntityMapsHelper
  • VCLBI.Chart.Geo


TEntityMapsHelper.Count Method

Summary

Represents method Count.

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
public
 function Count:Integer; inline;

Return Value

Type: Integer

See Also

Reference

  • TEntityMapsHelper
  • VCLBI.Chart.Geo


VCLBI.Chart.Geo Records

Records
Name | Description
TEntityMap | Represents type TEntityMap.
TGeoChart | Represents type TGeoChart.
TGeoContext | Represents type TGeoContext.
Top


TEntityMap Record

Summary

Represents type TEntityMap.

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
type
 TEntityMap=record
 end;

The TEntityMap type exposes the following members.

Fields
Show:
Name | Description
Entity | Represents field Entity.
IsMulti | Represents field IsMulti.
Map | Represents field Map.
Synonyms | Represents field Synonyms.
Top
See Also

Reference

  • VCLBI.Chart.Geo


TEntityMap.Entity Field

Summary

Represents field Entity.

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
public
 Entity : TEntity;

Field Value

Type: TEntity

See Also

Reference

  • TEntityMap
  • VCLBI.Chart.Geo


TEntityMap.IsMulti Field

Summary

Represents field IsMulti.

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
public
 IsMulti,
 Synonyms : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TEntityMap
  • VCLBI.Chart.Geo


TEntityMap.Map Field

Summary

Represents field Map.

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
public
 Map : TWorldMap;

Field Value

Type: TWorldMap

See Also

Reference

  • TEntityMap
  • VCLBI.Chart.Geo


TEntityMap.Synonyms Field

Summary

Represents field Synonyms.

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
public
 IsMulti,
 Synonyms : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TEntityMap
  • VCLBI.Chart.Geo


TGeoChart Record

Summary

Represents type TGeoChart.

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
type
 TGeoChart=record
 end;

The TGeoChart type exposes the following members.

Methods
Show:
Name | Description
CanReuse(TBITChart,TGeoContext) | Represents method CanReuse(TBITChart,TGeoContext).
Fill(TBITChart,TDataItem,TDataItem,TGeoContext) | Represents method Fill(TBITChart,TDataItem,TDataItem,TGeoContext).
Guess(TDataItem,TDataItem,TGeoContext) | Represents method Guess(TDataItem,TDataItem,TGeoContext).
Top
See Also

Reference

  • VCLBI.Chart.Geo


TGeoChart.CanReuse(TBITChart,TGeoContext) Method

Summary

Represents method CanReuse(TBITChart,TGeoContext).

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
public
 class function CanReuse(const AChart:TBITChart;
 const AContext:TGeoContext):Boolean; static;

Parameters

AChart
Type: TBITChart

AContext
Type: TGeoContext

Return Value

Type: Boolean

See Also

Reference

  • TGeoChart
  • VCLBI.Chart.Geo


TGeoChart.Fill(TBITChart,TDataItem,TDataItem,TGeoContext) Method

Summary

Represents method Fill(TBITChart,TDataItem,TDataItem,TGeoContext).

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
public
 class procedure Fill(const AChart:TBITChart;
 const AValues,AText:TDataItem;
 const AContext:TGeoContext); static;

Parameters

AChart
Type: TBITChart

AValues
Type: TDataItem

AText
Type: TDataItem

AContext
Type: TGeoContext

See Also

Reference

  • TGeoChart
  • VCLBI.Chart.Geo


TGeoChart.Guess(TDataItem,TDataItem,TGeoContext) Method

Summary

Represents method Guess(TDataItem,TDataItem,TGeoContext).

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
public
 class function Guess(const X,Text:TDataItem;
 out AContext:TGeoContext):Boolean; static;

Parameters

X
Type: TDataItem

Text
Type: TDataItem

AContext
Type: TGeoContext

Return Value

Type: Boolean

See Also

Reference

  • TGeoChart
  • VCLBI.Chart.Geo


TGeoContext Record

Summary

Represents type TGeoContext.

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
type
 TGeoContext=record
 end;

The TGeoContext type exposes the following members.

Fields
Show:
Name | Description
ByCode | Represents field ByCode.
IsMulti | Represents field IsMulti.
Map | Represents field Map.
Top
See Also

Reference

  • VCLBI.Chart.Geo


TGeoContext.ByCode Field

Summary

Represents field ByCode.

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
public
 ByCode,
 IsMulti : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TGeoContext
  • VCLBI.Chart.Geo


TGeoContext.IsMulti Field

Summary

Represents field IsMulti.

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
public
 ByCode,
 IsMulti : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TGeoContext
  • VCLBI.Chart.Geo


TGeoContext.Map Field

Summary

Represents field Map.

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
public
 Map : TWorldMap;

Field Value

Type: TWorldMap

See Also

Reference

  • TGeoContext
  • VCLBI.Chart.Geo


VCLBI.Chart.Geo Types

Types
Name | Description
TEntityMaps | Represents an array of the TEntityMap type.
Top


TEntityMaps Type

Summary

Represents an array of the TEntityMap type.

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
type
 TEntityMaps=Array of TEntityMap;
See Also

Reference

  • VCLBI.Chart.Geo


VCLBI.Chart.Geo Variables

Variables
Name | Description
IEntityMaps | Represents variable IEntityMaps.
Top


IEntityMaps Variable

Summary

Represents variable IEntityMaps.

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
IEntityMaps:TEntityMaps=nil;

Value

Type: TEntityMaps

See Also

Reference

  • VCLBI.Chart.Geo


VCLBI.Chart.Geo Routines

Routines
Name | Description
ContainsAlaskaHawaii(TDataItem,Boolean) | Represents method ContainsAlaskaHawaii(TDataItem,Boolean).
FillPolygons(TWorldSeries,TDataItem,TDataItem,Boolean,Boolean) | Represents method FillPolygons(TWorldSeries,TDataItem,TDataItem,Boolean,Boolean).
FindMapEntities(TDataItem,TGeoContext) | Represents method FindMapEntities(TDataItem,TGeoContext).
SetAllNull(TChartSeries) | Represents method SetAllNull(TChartSeries).
Top


ContainsAlaskaHawaii(TDataItem,Boolean) Method

Summary

Represents method ContainsAlaskaHawaii(TDataItem,Boolean).

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
function ContainsAlaskaHawaii(const Text:TDataItem; const ByCode:Boolean):Boolean;

Parameters

Text
Type: TDataItem

ByCode
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • VCLBI.Chart.Geo


FillPolygons(TWorldSeries,TDataItem,TDataItem,Boolean,Boolean) Method

Summary

Represents method FillPolygons(TWorldSeries,TDataItem,TDataItem,Boolean,Boolean).

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
procedure FillPolygons(const ASeries:TWorldSeries; const AData,AEntity:TDataItem; const ByCode,IsMulti:Boolean);

Parameters

ASeries
Type: TWorldSeries

AData
Type: TDataItem

AEntity
Type: TDataItem

ByCode
Type: Boolean

IsMulti
Type: Boolean

See Also

Reference

  • VCLBI.Chart.Geo


FindMapEntities(TDataItem,TGeoContext) Method

Summary

Represents method FindMapEntities(TDataItem,TGeoContext).

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
function FindMapEntities(const Text:TDataItem; out AContext:TGeoContext):Boolean;

Parameters

Text
Type: TDataItem

AContext
Type: TGeoContext

Return Value

Type: Boolean

See Also

Reference

  • VCLBI.Chart.Geo


SetAllNull(TChartSeries) Method

Summary

Represents method SetAllNull(TChartSeries).

Namespace: VCLBI.Chart.Geo
Syntax
Delphi
procedure SetAllNull(const ASeries:TChartSeries);

Parameters

ASeries
Type: TChartSeries

See Also

Reference

  • VCLBI.Chart.Geo


VCLBI.Chart.Plugin Namespace

Summary

Represents namespace VCLBI.Chart.Plugin.

Classes
Name | Description
TBIDataControlAccess | Represents type TBIDataControlAccess.
TBITChart | Represents type TBITChart.
TDataAccess | Represents type TDataAccess.
TLabelsListAccess | Represents type TLabelsListAccess.
TSeriesAccess | Represents type TSeriesAccess.
Top
Records
Name | Description
TArrayToValues | Represents type TArrayToValues.
TChartData | Represents type TChartData.
Top
Enumerations
Name | Description
TBIChartDirection | Represents type TBIChartDirection.
TBIChartStacked | Represents type TBIChartStacked.
Top
Constants
Name | Description
WhiteColor | Represents constant WhiteColor.
Top
Routines
Name | Description
AddLabels(TChartSeries,TDataItem) | Represents method AddLabels(TChartSeries,TDataItem).
CopyData(TChartValueList,TDataItem) | Represents method CopyData(TChartValueList,TDataItem).
FixDesignTime(TChartSeries) | Represents method FixDesignTime(TChartSeries).
Top


VCLBI.Chart.Plugin Classes

Classes
Name | Description
TBIDataControlAccess | Represents type TBIDataControlAccess.
TBITChart | Represents type TBITChart.
TDataAccess | Represents type TDataAccess.
TLabelsListAccess | Represents type TLabelsListAccess.
TSeriesAccess | Represents type TSeriesAccess.
Top


TBIDataControlAccess Class

Summary

Represents type TBIDataControlAccess.

Namespace: VCLBI.Chart.Plugin
Inheritance Hierarchy
TWinControl
VCLBI.DataControl.TBIDataControl
VCLBI.Chart.Plugin.TBIDataControlAccess
Syntax
Delphi
type
 TBIDataControlAccess=class(TBIDataControl);
See Also

Reference

  • VCLBI.Chart.Plugin


TBITChart Class

Summary

Represents type TBITChart.

Namespace: VCLBI.Chart.Plugin
Inheritance Hierarchy
TChart
VCLBI.Chart.Plugin.TBITChart
VCLBI.Editor.Chart.TBITChartAccess
Syntax
Delphi
type
 TBITChart=class(TChart)
 end;

The TBITChart type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBITChart class.
Top
Properties
Show:
Name | Description
Align | Represents property Align.
BevelOuter | Represents property BevelOuter.
Color | Represents property Color.
Series2D | Represents property Series2D.
Series3D | Represents property Series3D.
View3D | Represents property View3D.
Top
Methods
Show:
Name | Description
AddLine(TChartAxis) | Represents method AddLine(TChartAxis).
ChangeSeries2D(TChartSeriesClass,Boolean,Boolean) | Represents method ChangeSeries2D(TChartSeriesClass,Boolean,Boolean).
ClearTitles | Represents method ClearTitles.
CreateMulti2D(TDataItem,TDataItem,TDataItem,TBIChartDirection) | Represents method CreateMulti2D(TDataItem,TDataItem,TDataItem,TBIChartDirection).
Fill(TDataArray,TDataItem) | Overloaded. Represents method Fill(TDataArray,TDataItem).
Fill(TDataItem) | Overloaded. Represents method Fill(TDataItem).
Fill(TDataSet,Integer,Integer) | Overloaded. Represents method Fill(TDataSet,Integer,Integer).
Fill(TDoubleArray) | Overloaded. Represents method Fill(TDoubleArray).
Fill(TInt32Array) | Overloaded. Represents method Fill(TInt32Array).
Fill(TInt64Array) | Overloaded. Represents method Fill(TInt64Array).
FillXY(TDataSet,Integer,Integer) | Overloaded. Represents method FillXY(TDataSet,Integer,Integer).
FillXY(TField,TField) | Overloaded. Represents method FillXY(TField,TField).
FinishViewDimensions | Represents method FinishViewDimensions.
GetParentComponent | Represents method GetParentComponent.
GetValue(TDataItem,TInteger) | Represents method GetValue(TDataItem,TInteger).
HasParent | Represents method HasParent.
Init(Boolean) | Represents method Init(Boolean).
NewSeries(Integer) | Overloaded. Represents method NewSeries(Integer).
NewSeries(String,String) | Overloaded. Represents method NewSeries(String,String).
NewSeries(TChartSeriesClass) | Overloaded. Represents method NewSeries(TChartSeriesClass).
ReadState(TReader) | Represents method ReadState(TReader).
SetAxesTitles(TChartSeries,String,String) | Represents method SetAxesTitles(TChartSeries,String,String).
SetParentComponent(TComponent) | Represents method SetParentComponent(TComponent).
ShowHideAxesWalls(Boolean) | Represents method ShowHideAxesWalls(Boolean).
TrySetName(TComponent,String) | Represents method TrySetName(TComponent,String).
Top
Fields
Show:
Name | Description
DefaultXYSeries | Represents field DefaultXYSeries.
FourItemSeries | Represents field FourItemSeries.
FSeries2D | Represents field FSeries2D.
FSeries3D | Represents field FSeries3D.
LinePointer | Represents field LinePointer.
Three3DSeries | Represents field Three3DSeries.
Top
See Also

Reference

  • VCLBI.Chart.Plugin


TBITChart.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBITChart class.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.Align Property

Summary

Represents property Align.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
published
 property Align default TUICommon.AlignClient;

Property Value

Type: Void

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.BevelOuter Property

Summary

Represents property BevelOuter.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
published
 property BevelOuter default bvNone;

Property Value

Type: Void

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.Color Property

Summary

Represents property Color.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
published
 property Color default WhiteColor;

Property Value

Type: Void

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.Series2D Property

Summary

Represents property Series2D.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 property Series2D:TChartSeriesClass read FSeries2D write FSeries2D;

Property Value

Type: TChartSeriesClass

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.Series3D Property

Summary

Represents property Series3D.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 property Series3D:TChartSeriesClass read FSeries3D write FSeries3D;

Property Value

Type: TChartSeriesClass

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.View3D Property

Summary

Represents property View3D.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
published
 property View3D default False;

Property Value

Type: Void

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.AddLine(TChartAxis) Method

Summary

Represents method AddLine(TChartAxis).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 procedure AddLine(const Axis:TChartAxis);

Parameters

Axis
Type: TChartAxis

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.ChangeSeries2D(TChartSeriesClass,Boolean,Boolean) Method

Summary

Represents method ChangeSeries2D(TChartSeriesClass,Boolean,Boolean).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 procedure ChangeSeries2D(const AClass: TChartSeriesClass;
 const AHorizontal, ALinePointer: Boolean);

Parameters

AClass
Type: TChartSeriesClass

AHorizontal
Type: Boolean

ALinePointer
Type: Boolean

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.ClearTitles Method

Summary

Represents method ClearTitles.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 procedure ClearTitles;
See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.CreateMulti2D(TDataItem,TDataItem,TDataItem,TBIChartDirection) Method

Summary

Represents method CreateMulti2D(TDataItem,TDataItem,TDataItem,TBIChartDirection).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 procedure CreateMulti2D(const X,Y,Z:TDataItem; const ADirection:TBIChartDirection);

Parameters

X
Type: TDataItem

Y
Type: TDataItem

Z
Type: TDataItem

ADirection
Type: TBIChartDirection

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.Fill(TDataArray,TDataItem) Method

Summary

Represents method Fill(TDataArray,TDataItem).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 procedure Fill(const AData:TDataArray; const ASeries: TDataItem); overload;

Parameters

AData
Type: TDataArray

ASeries
Type: TDataItem

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.Fill(TDataItem) Method

Summary

Represents method Fill(TDataItem).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 function Fill(const AData:TDataItem):TChartSeries; overload;

Parameters

AData
Type: TDataItem

Return Value

Type: TChartSeries

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.Fill(TDataSet,Integer,Integer) Method

Summary

Represents method Fill(TDataSet,Integer,Integer).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 procedure Fill(const AData:TDataSet; const ValueField:Integer; const TextField:Integer=-1); overload;

Parameters

AData
Type: TDataSet

ValueField
Type: Integer

TextField
Type: Integer

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.Fill(TDoubleArray) Method

Summary

Represents method Fill(TDoubleArray).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 function Fill(const AData:BI.Arrays.TDoubleArray):TChartSeries; overload;

Parameters

AData
Type: BI.Arrays.TDoubleArray

Return Value

Type: TChartSeries

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.Fill(TInt32Array) Method

Summary

Represents method Fill(TInt32Array).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 function Fill(const AData:TInt32Array):TChartSeries; overload;

Parameters

AData
Type: TInt32Array

Return Value

Type: TChartSeries

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.Fill(TInt64Array) Method

Summary

Represents method Fill(TInt64Array).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 function Fill(const AData:TInt64Array):TChartSeries; overload;

Parameters

AData
Type: TInt64Array

Return Value

Type: TChartSeries

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.FillXY(TDataSet,Integer,Integer) Method

Summary

Represents method FillXY(TDataSet,Integer,Integer).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 function FillXY(const AData:TDataSet; const X,Y:Integer):TChartSeries; overload;

Parameters

AData
Type: TDataSet

X
Type: Integer

Y
Type: Integer

Return Value

Type: TChartSeries

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.FillXY(TField,TField) Method

Summary

Represents method FillXY(TField,TField).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 function FillXY(const X,Y:TField):TChartSeries; overload;

Parameters

X
Type: TField

Y
Type: TField

Return Value

Type: TChartSeries

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.FinishViewDimensions Method

Summary

Represents method FinishViewDimensions.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 procedure FinishViewDimensions;
See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.GetParentComponent Method

Summary

Represents method GetParentComponent.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 Function GetParentComponent: TComponent; override;

Return Value

Type: TComponent

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.GetValue(TDataItem,TInteger) Method

Summary

Represents method GetValue(TDataItem,TInteger).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 class function GetValue(const AData:TDataItem; const Index:TInteger):TChartValue; static;

Parameters

AData
Type: TDataItem

Index
Type: System.Void

Return Value

Type: TChartValue

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.HasParent Method

Summary

Represents method HasParent.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 Function HasParent:Boolean; override;

Return Value

Type: Boolean

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.Init(Boolean) Method

Summary

Represents method Init(Boolean).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 procedure Init(const FreeSeries:Boolean);

Parameters

FreeSeries
Type: Boolean

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.NewSeries(Integer) Method

Summary

Represents method NewSeries(Integer).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 function NewSeries(const Count:Integer):TChartSeries; overload;

Parameters

Count
Type: Integer

Return Value

Type: TChartSeries

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.NewSeries(String,String) Method

Summary

Represents method NewSeries(String,String).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 function NewSeries(const X,Y:String):TChartSeries; overload;

Parameters

X
Type: String

Y
Type: String

Return Value

Type: TChartSeries

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.NewSeries(TChartSeriesClass) Method

Summary

Represents method NewSeries(TChartSeriesClass).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 function NewSeries(const AClass:TChartSeriesClass):TChartSeries; overload;

Parameters

AClass
Type: TChartSeriesClass

Return Value

Type: TChartSeries

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.ReadState(TReader) Method

Summary

Represents method ReadState(TReader).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
protected
 procedure ReadState(Reader: TReader); override;

Parameters

Reader
Type: TReader

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.SetAxesTitles(TChartSeries,String,String) Method

Summary

Represents method SetAxesTitles(TChartSeries,String,String).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 class procedure SetAxesTitles(const ASeries:TChartSeries; const X,Y:String); static;

Parameters

ASeries
Type: TChartSeries

X
Type: String

Y
Type: String

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.SetParentComponent(TComponent) Method

Summary

Represents method SetParentComponent(TComponent).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 procedure SetParentComponent(AParent: TComponent); override;

Parameters

AParent
Type: TComponent

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.ShowHideAxesWalls(Boolean) Method

Summary

Represents method ShowHideAxesWalls(Boolean).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 procedure ShowHideAxesWalls(const AVisible:Boolean);

Parameters

AVisible
Type: Boolean

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.TrySetName(TComponent,String) Method

Summary

Represents method TrySetName(TComponent,String).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 class procedure TrySetName(const AComponent:TComponent; const APrefix:String); static;

Parameters

AComponent
Type: TComponent

APrefix
Type: String

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.DefaultXYSeries Field

Summary

Represents field DefaultXYSeries.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
protected
 DefaultXYSeries : TChartSeriesClass;

Field Value

Type: TChartSeriesClass

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.FourItemSeries Field

Summary

Represents field FourItemSeries.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 class var
 FourItemSeries,
 Three3DSeries : TChartSeriesClass;

Field Value

Type: TChartSeriesClass

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.FSeries2D Field

Summary

Represents field FSeries2D.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
protected
 FSeries2D : TChartSeriesClass;

Field Value

Type: TChartSeriesClass

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.FSeries3D Field

Summary

Represents field FSeries3D.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
protected
 FSeries3D : TChartSeriesClass;

Field Value

Type: TChartSeriesClass

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.LinePointer Field

Summary

Represents field LinePointer.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
protected
 LinePointer : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TBITChart.Three3DSeries Field

Summary

Represents field Three3DSeries.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 class var
 FourItemSeries,
 Three3DSeries : TChartSeriesClass;

Field Value

Type: TChartSeriesClass

See Also

Reference

  • TBITChart
  • VCLBI.Chart.Plugin


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: VCLBI.Chart.Plugin
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
VCLBI.Chart.Plugin.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • VCLBI.Chart.Plugin


TLabelsListAccess Class

Summary

Represents type TLabelsListAccess.

Namespace: VCLBI.Chart.Plugin
Inheritance Hierarchy
TLabelsList
VCLBI.Chart.Plugin.TLabelsListAccess
Syntax
Delphi
type
 TLabelsListAccess=class(TLabelsList);
See Also

Reference

  • VCLBI.Chart.Plugin


TSeriesAccess Class

Summary

Represents type TSeriesAccess.

Namespace: VCLBI.Chart.Plugin
Inheritance Hierarchy
TChartSeries
VCLBI.Chart.Plugin.TSeriesAccess
Syntax
Delphi
type
 TSeriesAccess=class(TChartSeries);
See Also

Reference

  • VCLBI.Chart.Plugin


VCLBI.Chart.Plugin Records

Records
Name | Description
TArrayToValues | Represents type TArrayToValues.
TChartData | Represents type TChartData.
Top


TArrayToValues Record

Summary

Represents type TArrayToValues.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
type
 TArrayToValues=record
 end;

The TArrayToValues type exposes the following members.

Methods
Show:
Name | Description
From(TDataItem) | Overloaded. Represents method From(TDataItem).
From(TExtendedArray) | Overloaded. Represents method From(TExtendedArray).
From(TInt32Array) | Overloaded. Represents method From(TInt32Array).
From(TInt64Array) | Overloaded. Represents method From(TInt64Array).
From(TSingleArray) | Overloaded. Represents method From(TSingleArray).
Top
See Also

Reference

  • VCLBI.Chart.Plugin


TArrayToValues.From(TDataItem) Method

Summary

Represents method From(TDataItem).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 class function From(const AItem:TDataItem):TChartValues; overload; static;

Parameters

AItem
Type: TDataItem

Return Value

Type: TChartValues

See Also

Reference

  • TArrayToValues
  • VCLBI.Chart.Plugin


TArrayToValues.From(TExtendedArray) Method

Summary

Represents method From(TExtendedArray).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 class function From(const AData:TExtendedArray):TChartValues; overload; static;

Parameters

AData
Type: TExtendedArray

Return Value

Type: TChartValues

See Also

Reference

  • TArrayToValues
  • VCLBI.Chart.Plugin


TArrayToValues.From(TInt32Array) Method

Summary

Represents method From(TInt32Array).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 class function From(const AData:TInt32Array):TChartValues; overload; static;

Parameters

AData
Type: TInt32Array

Return Value

Type: TChartValues

See Also

Reference

  • TArrayToValues
  • VCLBI.Chart.Plugin


TArrayToValues.From(TInt64Array) Method

Summary

Represents method From(TInt64Array).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 class function From(const AData:TInt64Array):TChartValues; overload; static;

Parameters

AData
Type: TInt64Array

Return Value

Type: TChartValues

See Also

Reference

  • TArrayToValues
  • VCLBI.Chart.Plugin


TArrayToValues.From(TSingleArray) Method

Summary

Represents method From(TSingleArray).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 class function From(const AData:TSingleArray):TChartValues; overload; static;

Parameters

AData
Type: TSingleArray

Return Value

Type: TChartValues

See Also

Reference

  • TArrayToValues
  • VCLBI.Chart.Plugin


TChartData Record

Summary

Represents type TChartData.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
type
 TChartData=record
 end;

The TChartData type exposes the following members.

Methods
Show:
Name | Description
AddSeries(TChartSeries,TDataItem) | Represents method AddSeries(TChartSeries,TDataItem).
From(TChartSeries) | Overloaded. Represents method From(TChartSeries).
From(TChartSeries[]) | Overloaded. Represents method From(TChartSeries[]).
From(TCustomChart) | Overloaded. Represents method From(TCustomChart).
From(TDataArray,TComponent,TChartSeriesClass) | Overloaded. Represents method From(TDataArray,TComponent,TChartSeriesClass).
From(TDataItem,TComponent,TChartSeriesClass) | Overloaded. Represents method From(TDataItem,TComponent,TChartSeriesClass).
Top
See Also

Reference

  • VCLBI.Chart.Plugin


TChartData.AddSeries(TChartSeries,TDataItem) Method

Summary

Represents method AddSeries(TChartSeries,TDataItem).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 class procedure AddSeries(const ASeries: TChartSeries; const ADest: TDataItem); static;

Parameters

ASeries
Type: TChartSeries

ADest
Type: TDataItem

See Also

Reference

  • TChartData
  • VCLBI.Chart.Plugin


TChartData.From(TChartSeries) Method

Summary

Represents method From(TChartSeries).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 class function From(const ASeries:TChartSeries):TDataItem; overload; static;

Parameters

ASeries
Type: TChartSeries

Return Value

Type: TDataItem

See Also

Reference

  • TChartData
  • VCLBI.Chart.Plugin


TChartData.From(TChartSeries[]) Method

Summary

Represents method From(TChartSeries[]).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 class function From(const ASeries:Array of TChartSeries):TDataItem; overload; static;

Parameters

ASeries
Type: Array of TChartSeries

Return Value

Type: TDataItem

See Also

Reference

  • TChartData
  • VCLBI.Chart.Plugin


TChartData.From(TCustomChart) Method

Summary

Represents method From(TCustomChart).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 class function From(const AChart:TCustomChart):TDataItem; overload; static;

Parameters

AChart
Type: TCustomChart

Return Value

Type: TDataItem

See Also

Reference

  • TChartData
  • VCLBI.Chart.Plugin


TChartData.From(TDataArray,TComponent,TChartSeriesClass) Method

Summary

Represents method From(TDataArray,TComponent,TChartSeriesClass).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 class function From(const AData:TDataArray;
 const AOwner:TComponent;
 const AClass:TChartSeriesClass=nil):TChartSeries; overload; static;

Parameters

AData
Type: TDataArray

AOwner
Type: TComponent

AClass
Type: TChartSeriesClass

Return Value

Type: TChartSeries

See Also

Reference

  • TChartData
  • VCLBI.Chart.Plugin


TChartData.From(TDataItem,TComponent,TChartSeriesClass) Method

Summary

Represents method From(TDataItem,TComponent,TChartSeriesClass).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
public
 class function From(const AData:TDataItem;
 const AOwner:TComponent;
 const AClass:TChartSeriesClass=nil):TChartSeries; overload; static;

Parameters

AData
Type: TDataItem

AOwner
Type: TComponent

AClass
Type: TChartSeriesClass

Return Value

Type: TChartSeries

See Also

Reference

  • TChartData
  • VCLBI.Chart.Plugin


VCLBI.Chart.Plugin Enumerations

Enumerations
Name | Description
TBIChartDirection | Represents type TBIChartDirection.
TBIChartStacked | Represents type TBIChartStacked.
Top


TBIChartDirection Enumeration

Summary

Represents type TBIChartDirection.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
type
 TBIChartDirection=(Automatic, Rows, Columns);

The TBIChartDirection type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Columns | Represents constant Columns.
Rows | Represents constant Rows.
Top
See Also

Reference

  • VCLBI.Chart.Plugin


TBIChartStacked Enumeration

Summary

Represents type TBIChartStacked.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
type
 TBIChartStacked=(Automatic, No, Yes, Stacked100, Side, SideAll, SelfStack);

The TBIChartStacked type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
No | Represents constant No.
SelfStack | Represents constant SelfStack.
Side | Represents constant Side.
SideAll | Represents constant SideAll.
Stacked100 | Represents constant Stacked100.
Yes | Represents constant Yes.
Top
See Also

Reference

  • VCLBI.Chart.Plugin


VCLBI.Chart.Plugin Constants

Constants
Name | Description
WhiteColor | Represents constant WhiteColor.
Top


WhiteColor Constant

Summary

Represents constant WhiteColor.

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
 WhiteColor=clWhite;

Value

Type: Void

See Also

Reference

  • VCLBI.Chart.Plugin


VCLBI.Chart.Plugin Routines

Routines
Name | Description
AddLabels(TChartSeries,TDataItem) | Represents method AddLabels(TChartSeries,TDataItem).
CopyData(TChartValueList,TDataItem) | Represents method CopyData(TChartValueList,TDataItem).
FixDesignTime(TChartSeries) | Represents method FixDesignTime(TChartSeries).
Top


AddLabels(TChartSeries,TDataItem) Method

Summary

Represents method AddLabels(TChartSeries,TDataItem).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
procedure AddLabels(const ASeries:TChartSeries; const AData:TDataItem);

Parameters

ASeries
Type: TChartSeries

AData
Type: TDataItem

See Also

Reference

  • VCLBI.Chart.Plugin


CopyData(TChartValueList,TDataItem) Method

Summary

Represents method CopyData(TChartValueList,TDataItem).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
procedure CopyData(const AList:TChartValueList; const AData:TDataItem);

Parameters

AList
Type: TChartValueList

AData
Type: TDataItem

See Also

Reference

  • VCLBI.Chart.Plugin


FixDesignTime(TChartSeries) Method

Summary

Represents method FixDesignTime(TChartSeries).

Namespace: VCLBI.Chart.Plugin
Syntax
Delphi
procedure FixDesignTime(const ASeries:TChartSeries);

Parameters

ASeries
Type: TChartSeries

See Also

Reference

  • VCLBI.Chart.Plugin


VCLBI.Chart.Source Namespace

Summary

Represents namespace VCLBI.Chart.Source.

Classes
Name | Description
TDataCollectionItemAccess | Represents type TDataCollectionItemAccess.
TTeeBISource | Represents type TTeeBISource.
Top
Constants
Name | Description
BITeeMsg_DataItem | Represents constant BITeeMsg_DataItem.
Top


VCLBI.Chart.Source Classes

Classes
Name | Description
TDataCollectionItemAccess | Represents type TDataCollectionItemAccess.
TTeeBISource | Represents type TTeeBISource.
Top


TDataCollectionItemAccess Class

Summary

Represents type TDataCollectionItemAccess.

Namespace: VCLBI.Chart.Source
Inheritance Hierarchy
TCollectionItem
BI.CollectionItem.TDataCollectionItem
VCLBI.Chart.Source.TDataCollectionItemAccess
Syntax
Delphi
type
 TDataCollectionItemAccess=class(TDataCollectionItem);
See Also

Reference

  • VCLBI.Chart.Source


TTeeBISource Class

Summary

Represents type TTeeBISource.

Namespace: VCLBI.Chart.Source
Inheritance Hierarchy
TTeeSeriesSource
VCLBI.Chart.Source.TTeeBISource
Syntax
Delphi
type
 TTeeBISource=class(TTeeSeriesSource)
 end;

The TTeeBISource type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TTeeBISource class.
Destroy | Represents the destructor of the TTeeBISource class.
Top
Properties
Show:
Name | Description
Active | Represents property Active.
Data | Represents property Data.
Provider | Represents property Provider.
Series | Represents property Series.
Top
Methods
Show:
Name | Description
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Description | Represents method Description.
Editor | Represents method Editor.
Load | Represents method Load.
Loaded | Represents method Loaded.
Top
See Also

Reference

  • VCLBI.Chart.Source


TTeeBISource.Create(TComponent) Constructor

Summary

Initializes a new instance of the TTeeBISource class.

Namespace: VCLBI.Chart.Source
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TTeeBISource
  • VCLBI.Chart.Source


TTeeBISource.Destroy Destructor

Summary

Represents the destructor of the TTeeBISource class.

Namespace: VCLBI.Chart.Source
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TTeeBISource
  • VCLBI.Chart.Source


TTeeBISource.Active Property

Summary

Represents property Active.

Namespace: VCLBI.Chart.Source
Syntax
Delphi
published
 property Active;

Property Value

Type: Void

See Also

Reference

  • TTeeBISource
  • VCLBI.Chart.Source


TTeeBISource.Data Property

Summary

Represents property Data.

Namespace: VCLBI.Chart.Source
Syntax
Delphi
published
 property Data:TDataItem read GetData write SetData;

Property Value

Type: TDataItem

See Also

Reference

  • TTeeBISource
  • VCLBI.Chart.Source


TTeeBISource.Provider Property

Summary

Represents property Provider.

Namespace: VCLBI.Chart.Source
Syntax
Delphi
published
 property Provider:TComponent read GetProvider write SetProvider;

Property Value

Type: TComponent

See Also

Reference

  • TTeeBISource
  • VCLBI.Chart.Source


TTeeBISource.Series Property

Summary

Represents property Series.

Namespace: VCLBI.Chart.Source
Syntax
Delphi
published
 property Series;

Property Value

Type: Void

See Also

Reference

  • TTeeBISource
  • VCLBI.Chart.Source


TTeeBISource.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: VCLBI.Chart.Source
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TTeeBISource
  • VCLBI.Chart.Source


TTeeBISource.Description Method

Summary

Represents method Description.

Namespace: VCLBI.Chart.Source
Syntax
Delphi
public
 class Function Description:String; override;

Return Value

Type: String

See Also

Reference

  • TTeeBISource
  • VCLBI.Chart.Source


TTeeBISource.Editor Method

Summary

Represents method Editor.

Namespace: VCLBI.Chart.Source
Syntax
Delphi
public
 class Function Editor:TComponentClass; override;

Return Value

Type: TComponentClass

See Also

Reference

  • TTeeBISource
  • VCLBI.Chart.Source


TTeeBISource.Load Method

Summary

Represents method Load.

Namespace: VCLBI.Chart.Source
Syntax
Delphi
public
 Procedure Load; override;
See Also

Reference

  • TTeeBISource
  • VCLBI.Chart.Source


TTeeBISource.Loaded Method

Summary

Represents method Loaded.

Namespace: VCLBI.Chart.Source
Syntax
Delphi
protected
 procedure Loaded; override;
See Also

Reference

  • TTeeBISource
  • VCLBI.Chart.Source


VCLBI.Chart.Source Constants

Constants
Name | Description
BITeeMsg_DataItem | Represents constant BITeeMsg_DataItem.
Top


BITeeMsg_DataItem Constant

Summary

Represents constant BITeeMsg_DataItem.

Namespace: VCLBI.Chart.Source
Syntax
Delphi
 BITeeMsg_DataItem='BI Data';

Value

Type: string

See Also

Reference

  • VCLBI.Chart.Source


VCLBI.Chart.ThreeD Namespace

Summary

Represents namespace VCLBI.Chart.ThreeD.

Records
Name | Description
TThreeDChart | Represents type TThreeDChart.
Top
Types
Name | Description
TCustom3DSeriesClass | Represents type TCustom3DSeriesClass.
Top
Routines
Name | Description
TowerStack(TBIChartStacked) | Represents method TowerStack(TBIChartStacked).
Top


VCLBI.Chart.ThreeD Records

Records
Name | Description
TThreeDChart | Represents type TThreeDChart.
Top


TThreeDChart Record

Summary

Represents type TThreeDChart.

Namespace: VCLBI.Chart.ThreeD
Syntax
Delphi
type
 TThreeDChart=record
 end;

The TThreeDChart type exposes the following members.

Methods
Show:
Name | Description
CanReuse(TBITChart) | Represents method CanReuse(TBITChart).
Create3DSeries(TBITChart) | Represents method Create3DSeries(TBITChart).
CreateGrid3D(TBITChart,TDataItem,TDataItem,TDataItem,TBIChartDirection) | Represents method CreateGrid3D(TBITChart,TDataItem,TDataItem,TDataItem,TBIChartDirection).
CreateGridTable(TBITChart,TDataArray,TBIChartDirection) | Represents method CreateGridTable(TBITChart,TDataArray,TBIChartDirection).
CreateXYZ(TBITChart,TDataItem,TDataItem,TDataItem) | Represents method CreateXYZ(TBITChart,TDataItem,TDataItem,TDataItem).
FinishSeries(TChart,TChartSeries,TBIChartStacked) | Represents method FinishSeries(TChart,TChartSeries,TBIChartStacked).
FinishXYZ(TChart) | Represents method FinishXYZ(TChart).
SetSeries3D(TBITChart,TChartSeriesClass) | Represents method SetSeries3D(TBITChart,TChartSeriesClass).
Top
See Also

Reference

  • VCLBI.Chart.ThreeD


TThreeDChart.CanReuse(TBITChart) Method

Summary

Represents method CanReuse(TBITChart).

Namespace: VCLBI.Chart.ThreeD
Syntax
Delphi
public
 class function CanReuse(const AChart:TBITChart):Boolean; static;

Parameters

AChart
Type: TBITChart

Return Value

Type: Boolean

See Also

Reference

  • TThreeDChart
  • VCLBI.Chart.ThreeD


TThreeDChart.Create3DSeries(TBITChart) Method

Summary

Represents method Create3DSeries(TBITChart).

Namespace: VCLBI.Chart.ThreeD
Syntax
Delphi
public
 class function Create3DSeries(const AChart:TBITChart):TCustom3DSeries; static;

Parameters

AChart
Type: TBITChart

Return Value

Type: TCustom3DSeries

See Also

Reference

  • TThreeDChart
  • VCLBI.Chart.ThreeD


TThreeDChart.CreateGrid3D(TBITChart,TDataItem,TDataItem,TDataItem,TBIChartDirection) Method

Summary

Represents method CreateGrid3D(TBITChart,TDataItem,TDataItem,TDataItem,TBIChartDirection).

Namespace: VCLBI.Chart.ThreeD
Syntax
Delphi
public
 class procedure CreateGrid3D(const AChart:TBITChart;
 const X,Y,Z:TDataItem;
 const ADirection:TBIChartDirection); static;

Parameters

AChart
Type: TBITChart

X
Type: TDataItem

Y
Type: TDataItem

Z
Type: TDataItem

ADirection
Type: TBIChartDirection

See Also

Reference

  • TThreeDChart
  • VCLBI.Chart.ThreeD


TThreeDChart.CreateGridTable(TBITChart,TDataArray,TBIChartDirection) Method

Summary

Represents method CreateGridTable(TBITChart,TDataArray,TBIChartDirection).

Namespace: VCLBI.Chart.ThreeD
Syntax
Delphi
public
 class procedure CreateGridTable(const AChart:TBITChart;
 const AData:TDataArray;
 const ADirection:TBIChartDirection); static;

Parameters

AChart
Type: TBITChart

AData
Type: TDataArray

ADirection
Type: TBIChartDirection

See Also

Reference

  • TThreeDChart
  • VCLBI.Chart.ThreeD


TThreeDChart.CreateXYZ(TBITChart,TDataItem,TDataItem,TDataItem) Method

Summary

Represents method CreateXYZ(TBITChart,TDataItem,TDataItem,TDataItem).

Namespace: VCLBI.Chart.ThreeD
Syntax
Delphi
public
 class procedure CreateXYZ(const AChart:TBITChart;
 const X,Y,Z:TDataItem); static;

Parameters

AChart
Type: TBITChart

X
Type: TDataItem

Y
Type: TDataItem

Z
Type: TDataItem

See Also

Reference

  • TThreeDChart
  • VCLBI.Chart.ThreeD


TThreeDChart.FinishSeries(TChart,TChartSeries,TBIChartStacked) Method

Summary

Represents method FinishSeries(TChart,TChartSeries,TBIChartStacked).

Namespace: VCLBI.Chart.ThreeD
Syntax
Delphi
public
 class procedure FinishSeries(const AChart:TChart;
 const ASeries:TChartSeries;
 const AStacked:TBIChartStacked); static;

Parameters

AChart
Type: TChart

ASeries
Type: TChartSeries

AStacked
Type: TBIChartStacked

See Also

Reference

  • TThreeDChart
  • VCLBI.Chart.ThreeD


TThreeDChart.FinishXYZ(TChart) Method

Summary

Represents method FinishXYZ(TChart).

Namespace: VCLBI.Chart.ThreeD
Syntax
Delphi
public
 class procedure FinishXYZ(const AChart:TChart); static;

Parameters

AChart
Type: TChart

See Also

Reference

  • TThreeDChart
  • VCLBI.Chart.ThreeD


TThreeDChart.SetSeries3D(TBITChart,TChartSeriesClass) Method

Summary

Represents method SetSeries3D(TBITChart,TChartSeriesClass).

Namespace: VCLBI.Chart.ThreeD
Syntax
Delphi
public
 class function SetSeries3D(const AChart:TBITChart;
 const AClass:TChartSeriesClass):Boolean; static;

Parameters

AChart
Type: TBITChart

AClass
Type: TChartSeriesClass

Return Value

Type: Boolean

See Also

Reference

  • TThreeDChart
  • VCLBI.Chart.ThreeD


VCLBI.Chart.ThreeD Types

Types
Name | Description
TCustom3DSeriesClass | Represents type TCustom3DSeriesClass.
Top


TCustom3DSeriesClass Type

Summary

Represents type TCustom3DSeriesClass.

Namespace: VCLBI.Chart.ThreeD
Syntax
Delphi
type
 TCustom3DSeriesClass=class of TCustom3DSeries;
See Also

Reference

  • VCLBI.Chart.ThreeD


VCLBI.Chart.ThreeD Routines

Routines
Name | Description
TowerStack(TBIChartStacked) | Represents method TowerStack(TBIChartStacked).
Top


TowerStack(TBIChartStacked) Method

Summary

Represents method TowerStack(TBIChartStacked).

Namespace: VCLBI.Chart.ThreeD
Syntax
Delphi
function TowerStack(const AStacked:TBIChartStacked):TTowerStacked;

Parameters

AStacked
Type: TBIChartStacked

Return Value

Type: TTowerStacked

See Also

Reference

  • VCLBI.Chart.ThreeD


VCLBI.ChartFunctions Namespace

Summary

Represents namespace VCLBI.ChartFunctions.

Classes
Name | Description
TDataAccess | Represents type TDataAccess.
TDataFunction | Represents type TDataFunction.
TFunctionAccess | Represents type TFunctionAccess.
TSeriesAccess | Represents type TSeriesAccess.
Top
Routines
Name | Description
FunctionChooser(TComponent) | Represents method FunctionChooser(TComponent).
IsType(TClass,TClass[]) | Represents method IsType(TClass,TClass[]).
Top


VCLBI.ChartFunctions Classes

Classes
Name | Description
TDataAccess | Represents type TDataAccess.
TDataFunction | Represents type TDataFunction.
TFunctionAccess | Represents type TFunctionAccess.
TSeriesAccess | Represents type TSeriesAccess.
Top


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: VCLBI.ChartFunctions
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
VCLBI.ChartFunctions.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • VCLBI.ChartFunctions


TDataFunction Class

Summary

Represents type TDataFunction.

Namespace: VCLBI.ChartFunctions
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Algorithm.TDataProviderNeeds
VCLBI.ChartFunctions.TDataFunction
Syntax
Delphi
type
 TDataFunction=class(TDataProviderNeeds)
 end;

The TDataFunction type exposes the following members.

Constructors
Show:
Name | Description
CreateFunction(TComponent,TTeeFunction) | Overloaded. Initializes a new instance of the TDataFunction class.
CreateFunction(TComponent,TTeeFunctionClass) | Overloaded. Initializes a new instance of the TDataFunction class.
Top
Properties
Show:
Name | Description
FunctionClass | Represents property FunctionClass.
Period | Represents property Period.
TeeFunction | Represents property TeeFunction.
Top
Methods
Show:
Name | Description
FunctionTitle | Represents method FunctionTitle.
GetChildOwner | Represents method GetChildOwner.
GetChildren(TGetChildProc,TComponent) | Represents method GetChildren(TGetChildProc,TComponent).
IsFinancial | Represents method IsFinancial.
Load(TDataItem,Boolean) | Represents method Load(TDataItem,Boolean). (Overrides TDataProvider.Load(TDataItem,Boolean).)
Loaded | Represents method Loaded.
Top
See Also

Reference

  • VCLBI.ChartFunctions


TDataFunction.CreateFunction(TComponent,TTeeFunction) Constructor

Summary

Initializes a new instance of the TDataFunction class.

Namespace: VCLBI.ChartFunctions
Syntax
Delphi
public
 Constructor CreateFunction(const AOwner:TComponent; const AFunction:TTeeFunction); overload;

Parameters

AOwner
Type: TComponent

AFunction
Type: TTeeFunction

See Also

Reference

  • TDataFunction
  • VCLBI.ChartFunctions


TDataFunction.CreateFunction(TComponent,TTeeFunctionClass) Constructor

Summary

Initializes a new instance of the TDataFunction class.

Namespace: VCLBI.ChartFunctions
Syntax
Delphi
public
 Constructor CreateFunction(const AOwner:TComponent; const AFunctionClass:TTeeFunctionClass); overload;

Parameters

AOwner
Type: TComponent

AFunctionClass
Type: TTeeFunctionClass

See Also

Reference

  • TDataFunction
  • VCLBI.ChartFunctions


TDataFunction.FunctionClass Property

Summary

Represents property FunctionClass.

Namespace: VCLBI.ChartFunctions
Syntax
Delphi
public
 property FunctionClass:TTeeFunctionClass read CalcClass;

Property Value

Type: TTeeFunctionClass

See Also

Reference

  • TDataFunction
  • VCLBI.ChartFunctions


TDataFunction.Period Property

Summary

Represents property Period.

Namespace: VCLBI.ChartFunctions
Syntax
Delphi
published
 property Period:Double read GetPeriod write SetPeriod stored False;

Property Value

Type: Double

See Also

Reference

  • TDataFunction
  • VCLBI.ChartFunctions


TDataFunction.TeeFunction Property

Summary

Represents property TeeFunction.

Namespace: VCLBI.ChartFunctions
Syntax
Delphi
public
 property TeeFunction:TTeeFunction read GetTeeFunction;

Property Value

Type: TTeeFunction

See Also

Reference

  • TDataFunction
  • VCLBI.ChartFunctions


TDataFunction.FunctionTitle Method

Summary

Represents method FunctionTitle.

Namespace: VCLBI.ChartFunctions
Syntax
Delphi
public
 function FunctionTitle:String;

Return Value

Type: String

See Also

Reference

  • TDataFunction
  • VCLBI.ChartFunctions


TDataFunction.GetChildOwner Method

Summary

Represents method GetChildOwner.

Namespace: VCLBI.ChartFunctions
Syntax
Delphi
protected
 function GetChildOwner: TComponent; override;

Return Value

Type: TComponent

See Also

Reference

  • TDataFunction
  • VCLBI.ChartFunctions


TDataFunction.GetChildren(TGetChildProc,TComponent) Method

Summary

Represents method GetChildren(TGetChildProc,TComponent).

Namespace: VCLBI.ChartFunctions
Syntax
Delphi
protected
 Procedure GetChildren(Proc:TGetChildProc; Root:TComponent); override;

Parameters

Proc
Type: TGetChildProc

Root
Type: TComponent

See Also

Reference

  • TDataFunction
  • VCLBI.ChartFunctions


TDataFunction.IsFinancial Method

Summary

Represents method IsFinancial.

Namespace: VCLBI.ChartFunctions
Syntax
Delphi
public
 function IsFinancial:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TDataFunction
  • VCLBI.ChartFunctions


TDataFunction.Load(TDataItem,Boolean) Method

Summary

Represents method Load(TDataItem,Boolean).

Namespace: VCLBI.ChartFunctions
Syntax
Delphi
protected
 procedure Load(const AData:TDataItem; const Children:Boolean); override;

Parameters

AData
Type: TDataItem

Children
Type: Boolean

Overrides

TDataProvider.Load(TDataItem,Boolean)
See Also

Reference

  • TDataFunction
  • VCLBI.ChartFunctions


TDataFunction.Loaded Method

Summary

Represents method Loaded.

Namespace: VCLBI.ChartFunctions
Syntax
Delphi
protected
 procedure Loaded; override;
See Also

Reference

  • TDataFunction
  • VCLBI.ChartFunctions


TFunctionAccess Class

Summary

Represents type TFunctionAccess.

Namespace: VCLBI.ChartFunctions
Inheritance Hierarchy
TTeeFunction
VCLBI.ChartFunctions.TFunctionAccess
Syntax
Delphi
type
 TFunctionAccess=class(TTeeFunction);
See Also

Reference

  • VCLBI.ChartFunctions


TSeriesAccess Class

Summary

Represents type TSeriesAccess.

Namespace: VCLBI.ChartFunctions
Inheritance Hierarchy
TChartSeries
VCLBI.ChartFunctions.TSeriesAccess
Syntax
Delphi
type
 TSeriesAccess=class(TChartSeries);
See Also

Reference

  • VCLBI.ChartFunctions


VCLBI.ChartFunctions Routines

Routines
Name | Description
FunctionChooser(TComponent) | Represents method FunctionChooser(TComponent).
IsType(TClass,TClass[]) | Represents method IsType(TClass,TClass[]).
Top


FunctionChooser(TComponent) Method

Summary

Represents method FunctionChooser(TComponent).

Namespace: VCLBI.ChartFunctions
Syntax
Delphi
 function FunctionChooser(const AOwner:TComponent):TDataProvider;

Parameters

AOwner
Type: TComponent

Return Value

Type: TDataProvider

See Also

Reference

  • VCLBI.ChartFunctions


IsType(TClass,TClass[]) Method

Summary

Represents method IsType(TClass,TClass[]).

Namespace: VCLBI.ChartFunctions
Syntax
Delphi
function IsType(const AType:TClass; const AClasses:Array of TClass):Boolean;

Parameters

AType
Type: TClass

AClasses
Type: Array of TClass

Return Value

Type: Boolean

See Also

Reference

  • VCLBI.ChartFunctions


VCLBI.Component Namespace

Summary

Represents namespace VCLBI.Component.

Classes
Name | Description
TControlImporter | Represents type TControlImporter.
TGridAccess | Represents type TGridAccess.
TListAccess | Represents type TListAccess.
TTreeAccess | Represents type TTreeAccess.
Top
Routines
Name | Description
DataFrom(TCustomGrid) | Overloaded. Represents method DataFrom(TCustomGrid).
DataFrom(TCustomListView) | Overloaded. Represents method DataFrom(TCustomListView).
DataFrom(TCustomTreeView) | Overloaded. Represents method DataFrom(TCustomTreeView).
Top


VCLBI.Component Classes

Classes
Name | Description
TControlImporter | Represents type TControlImporter.
TGridAccess | Represents type TGridAccess.
TListAccess | Represents type TListAccess.
TTreeAccess | Represents type TTreeAccess.
Top


TControlImporter Class

Summary

Represents type TControlImporter.

Namespace: VCLBI.Component
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Persist.TBaseDataImporter
BI.Store.Component.TComponentImporter
VCLBI.Component.TControlImporter
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64 or pidOSX32
 or pidiOSSimulator or pidiOSDevice
 or pidAndroid
 or pidiOSDevice64
 )]
 TControlImporter=class(TComponentImporter)
 end;

The TControlImporter type exposes the following members.

Methods
Show:
Name | Description
DataOf(TComponent) | Represents method DataOf(TComponent). (Overrides TComponentImporter.DataOf(TComponent).)
DoImport(TComponent) | Represents method DoImport(TComponent). (Overrides TComponentImporter.DoImport(TComponent).)
HasDataProperty(TComponent) | Represents method HasDataProperty(TComponent).
HasTextProperty(TComponent) | Represents method HasTextProperty(TComponent).
StringsOf(TComponent) | Represents method StringsOf(TComponent). (Overrides TComponentImporter.StringsOf(TComponent).)
Supports(TComponent) | Represents method Supports(TComponent). (Overrides TComponentImporter.Supports(TComponent).)
TextOf(TComponent) | Overloaded. Represents method TextOf(TComponent).
Top
See Also

Reference

  • VCLBI.Component


TControlImporter.DataOf(TComponent) Method

Summary

Represents method DataOf(TComponent).

Namespace: VCLBI.Component
Syntax
Delphi
public
 class function DataOf(const AComponent:TComponent):TDataItem; override;

Parameters

AComponent
Type: TComponent

Return Value

Type: TDataItem

Overrides

TComponentImporter.DataOf(TComponent)
See Also

Reference

  • TControlImporter
  • VCLBI.Component


TControlImporter.DoImport(TComponent) Method

Summary

Represents method DoImport(TComponent).

Namespace: VCLBI.Component
Syntax
Delphi
protected
 function DoImport(const AComponent: TComponent):TDataItem; override;

Parameters

AComponent
Type: TComponent

Return Value

Type: TDataItem

Overrides

TComponentImporter.DoImport(TComponent)
See Also

Reference

  • TControlImporter
  • VCLBI.Component


TControlImporter.HasDataProperty(TComponent) Method

Summary

Represents method HasDataProperty(TComponent).

Namespace: VCLBI.Component
Syntax
Delphi
public
 class function HasDataProperty(const AComponent:TComponent):Boolean; static;

Parameters

AComponent
Type: TComponent

Return Value

Type: Boolean

See Also

Reference

  • TControlImporter
  • VCLBI.Component


TControlImporter.HasTextProperty(TComponent) Method

Summary

Represents method HasTextProperty(TComponent).

Namespace: VCLBI.Component
Syntax
Delphi
public
 class function HasTextProperty(const AComponent:TComponent):Boolean; static;

Parameters

AComponent
Type: TComponent

Return Value

Type: Boolean

See Also

Reference

  • TControlImporter
  • VCLBI.Component


TControlImporter.StringsOf(TComponent) Method

Summary

Represents method StringsOf(TComponent).

Namespace: VCLBI.Component
Syntax
Delphi
public
 class function StringsOf(const ASource:TComponent):TStrings; override;

Parameters

ASource
Type: TComponent

Return Value

Type: TStrings

Overrides

TComponentImporter.StringsOf(TComponent)
See Also

Reference

  • TControlImporter
  • VCLBI.Component


TControlImporter.Supports(TComponent) Method

Summary

Represents method Supports(TComponent).

Namespace: VCLBI.Component
Syntax
Delphi
public
 class function Supports(const AComponent:TComponent):Boolean; override;

Parameters

AComponent
Type: TComponent

Return Value

Type: Boolean

Overrides

TComponentImporter.Supports(TComponent)
See Also

Reference

  • TControlImporter
  • VCLBI.Component


TControlImporter.TextOf(TComponent) Method

Summary

Represents method TextOf(TComponent).

Namespace: VCLBI.Component
Syntax
Delphi
public
 class function TextOf(const AComponent:TComponent):String; overload; static;

Parameters

AComponent
Type: TComponent

Return Value

Type: String

See Also

Reference

  • TControlImporter
  • VCLBI.Component


TGridAccess Class

Summary

Represents type TGridAccess.

Namespace: VCLBI.Component
Inheritance Hierarchy
TCustomGrid
VCLBI.Component.TGridAccess
Syntax
Delphi
type
 TGridAccess=class(TCustomGrid);
See Also

Reference

  • VCLBI.Component


TListAccess Class

Summary

Represents type TListAccess.

Namespace: VCLBI.Component
Inheritance Hierarchy
TCustomListView
VCLBI.Component.TListAccess
Syntax
Delphi
type
 TListAccess=class(TCustomListView);
See Also

Reference

  • VCLBI.Component


TTreeAccess Class

Summary

Represents type TTreeAccess.

Namespace: VCLBI.Component
Inheritance Hierarchy
TCustomTreeView
VCLBI.Component.TTreeAccess
Syntax
Delphi
type
 TTreeAccess=class(TCustomTreeView);
See Also

Reference

  • VCLBI.Component


VCLBI.Component Routines

Routines
Name | Description
DataFrom(TCustomGrid) | Overloaded. Represents method DataFrom(TCustomGrid).
DataFrom(TCustomListView) | Overloaded. Represents method DataFrom(TCustomListView).
DataFrom(TCustomTreeView) | Overloaded. Represents method DataFrom(TCustomTreeView).
Top


DataFrom(TCustomGrid) Method

Summary

Represents method DataFrom(TCustomGrid).

Namespace: VCLBI.Component
Syntax
Delphi
function DataFrom(const AGrid:TCustomGrid):TDataItem; overload;

Parameters

AGrid
Type: TCustomGrid

Return Value

Type: TDataItem

See Also

Reference

  • VCLBI.Component


DataFrom(TCustomListView) Method

Summary

Represents method DataFrom(TCustomListView).

Namespace: VCLBI.Component
Syntax
Delphi
function DataFrom(const AList:TCustomListView):TDataItem; overload;

Parameters

AList
Type: TCustomListView

Return Value

Type: TDataItem

See Also

Reference

  • VCLBI.Component


DataFrom(TCustomTreeView) Method

Summary

Represents method DataFrom(TCustomTreeView).

Namespace: VCLBI.Component
Syntax
Delphi
function DataFrom(const ATree:TCustomTreeView):TDataItem; overload;

Parameters

ATree
Type: TCustomTreeView

Return Value

Type: TDataItem

See Also

Reference

  • VCLBI.Component


VCLBI.Dashboard Namespace

Summary

Represents namespace VCLBI.Dashboard.

Classes
Name | Description
TBaseItemAccess | Represents type TBaseItemAccess.
TBIPanelAccess | Represents type TBIPanelAccess.
TBITemplateAccess | Represents type TBITemplateAccess.
TBIVisual | Represents type TBIVisual.
TBIVisualAccess | Represents type TBIVisualAccess.
TButtonsPanel | Represents type TButtonsPanel.
TControlAccess | Represents type TControlAccess.
TDashboardItemAccess | Represents type TDashboardItemAccess.
TDashboardTree | Represents type TDashboardTree.
TLayoutComboBox | Represents type TLayoutComboBox.
TLayoutListBox | Represents type TLayoutListBox.
TLayoutPanel | Represents type TLayoutPanel.
TRenderAccess | Represents type TRenderAccess.
TScreenRender | Represents type TScreenRender.
TScreenRender.TTargetControlsHelper | Represents type TTargetControlsHelper.
Top
Types
Name | Description
TScreenRenderClass | Represents type TScreenRenderClass.
Top
Routines
Name | Description
AlignOf(String) | Represents method AlignOf(String).
AlphaColorToColor(TAlphaColor) | Represents method AlphaColorToColor(TAlphaColor).
AlphaToColor(TAlphaColor) | Represents method AlphaToColor(TAlphaColor).
CreatePanelFrame(TWinControl) | Represents method CreatePanelFrame(TWinControl).
DoSetPadding(TWinControl,Single) | Represents method DoSetPadding(TWinControl,Single).
GetURLStream(String) | Represents method GetURLStream(String).
IsAlignLeftRight(TControl) | Represents method IsAlignLeftRight(TControl).
IsAlignTopBottom(TControl) | Represents method IsAlignTopBottom(TControl).
LoadImage(TImage,String) | Represents method LoadImage(TImage,String).
NewTab(TControl,TWinControl,String) | Represents method NewTab(TControl,TWinControl,String).
ParentOf(TControl) | Represents method ParentOf(TControl).
RandomLightColor | Represents method RandomLightColor.
RepositionControl(TControl) | Represents method RepositionControl(TControl).
ScrollContentOf(TWinControl) | Represents method ScrollContentOf(TWinControl).
SetDefaultPadding(TWinControl) | Represents method SetDefaultPadding(TWinControl).
ShowHideAll(TControl,Integer) | Represents method ShowHideAll(TControl,Integer).
TitleOf(TDashboardItem) | Represents method TitleOf(TDashboardItem).
Top


VCLBI.Dashboard Classes

Classes
Name | Description
TBaseItemAccess | Represents type TBaseItemAccess.
TBIPanelAccess | Represents type TBIPanelAccess.
TBITemplateAccess | Represents type TBITemplateAccess.
TBIVisual | Represents type TBIVisual.
TBIVisualAccess | Represents type TBIVisualAccess.
TButtonsPanel | Represents type TButtonsPanel.
TControlAccess | Represents type TControlAccess.
TDashboardItemAccess | Represents type TDashboardItemAccess.
TDashboardTree | Represents type TDashboardTree.
TLayoutComboBox | Represents type TLayoutComboBox.
TLayoutListBox | Represents type TLayoutListBox.
TLayoutPanel | Represents type TLayoutPanel.
TRenderAccess | Represents type TRenderAccess.
TScreenRender | Represents type TScreenRender.
TScreenRender.TTargetControlsHelper | Represents type TTargetControlsHelper.
Top


TBaseItemAccess Class

Summary

Represents type TBaseItemAccess.

Namespace: VCLBI.Dashboard
Inheritance Hierarchy
TCollectionItem
BI.Dashboard.TBaseItem
VCLBI.Dashboard.TBaseItemAccess
Syntax
Delphi
type
 TBaseItemAccess=class(TBaseItem);
See Also

Reference

  • VCLBI.Dashboard


TBIPanelAccess Class

Summary

Represents type TBIPanelAccess.

Namespace: VCLBI.Dashboard
Inheritance Hierarchy
TCollectionItem
BI.Dashboard.TBaseItem
BI.Dashboard.TCustomBIPanel
BI.Dashboard.TBIPanel
VCLBI.Dashboard.TBIPanelAccess
Syntax
Delphi
type
 TBIPanelAccess=class(TBIPanel);
See Also

Reference

  • VCLBI.Dashboard


TBITemplateAccess Class

Summary

Represents type TBITemplateAccess.

Namespace: VCLBI.Dashboard
Inheritance Hierarchy
TComponent
BI.Dashboard.TBITemplate
VCLBI.Dashboard.TBITemplateAccess
Syntax
Delphi
type
 TBITemplateAccess=class(TBITemplate);
See Also

Reference

  • VCLBI.Dashboard


TBIVisual Class

Summary

Represents type TBIVisual.

Namespace: VCLBI.Dashboard
Inheritance Hierarchy
TScrollingWinControl
VCLBI.Dashboard.TBIVisual
VCLBI.Dashboard.TBIVisualAccess
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64
 )]
 TBIVisual=class(TScrollingWinControl)
 end;

The TBIVisual type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIVisual class.
Destroy | Represents the destructor of the TBIVisual class.
Top
Properties
Show:
Name | Description
Align | Represents property Align.
Anchors | Represents property Anchors.
Cursor | Represents property Cursor.
Dashboard | Represents property Dashboard.
Dashboards | Represents property Dashboards.
Data | Represents property Data.
DragMode | Represents property DragMode.
Enabled | Represents property Enabled.
Height | Represents property Height.
Layouts | Represents property Layouts.
Margins | Represents property Margins.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnDragDrop | Represents property OnDragDrop.
OnDragOver | Represents property OnDragOver.
OnMouseDown | Represents property OnMouseDown.
OnMouseEnter | Represents property OnMouseEnter.
OnMouseLeave | Represents property OnMouseLeave.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnMouseWheel | Represents property OnMouseWheel.
OnResize | Represents property OnResize.
Padding | Represents property Padding.
Panels | Represents property Panels.
PopupMenu | Represents property PopupMenu.
Render | Represents property Render.
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
Template | Represents property Template.
Visible | Represents property Visible.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
Clear | Represents method Clear.
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
Generate(TBIPanel) | Overloaded. Represents method Generate(TBIPanel).
Generate(TDashboard,String) | Overloaded. Represents method Generate(TDashboard,String).
GetChildOwner | Represents method GetChildOwner.
Loaded | Represents method Loaded.
Resize | Represents method Resize.
ResizeLayout | Represents method ResizeLayout.
Top
Fields
Show:
Name | Description
RenderClass | Represents field RenderClass.
Top
See Also

Reference

  • VCLBI.Dashboard


TBIVisual.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIVisual class.

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.Destroy Destructor

Summary

Represents the destructor of the TBIVisual class.

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual Properties

Properties
Name | Description
Align | Represents property Align.
Anchors | Represents property Anchors.
Cursor | Represents property Cursor.
Dashboard | Represents property Dashboard.
Dashboards | Represents property Dashboards.
Data | Represents property Data.
DragMode | Represents property DragMode.
Enabled | Represents property Enabled.
Height | Represents property Height.
Layouts | Represents property Layouts.
Margins | Represents property Margins.
OnClick | Represents property OnClick.
OnDblClick | Represents property OnDblClick.
OnDragDrop | Represents property OnDragDrop.
OnDragOver | Represents property OnDragOver.
OnMouseDown | Represents property OnMouseDown.
OnMouseEnter | Represents property OnMouseEnter.
OnMouseLeave | Represents property OnMouseLeave.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnMouseWheel | Represents property OnMouseWheel.
OnResize | Represents property OnResize.
Padding | Represents property Padding.
Panels | Represents property Panels.
PopupMenu | Represents property PopupMenu.
Render | Represents property Render.
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
Template | Represents property Template.
Visible | Represents property Visible.
Width | Represents property Width.
Top


TBIVisual.Align Property

Summary

Represents property Align.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property Align;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.Anchors Property

Summary

Represents property Anchors.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property Anchors;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.Cursor Property

Summary

Represents property Cursor.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property Cursor;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.Dashboard Property

Summary

Represents property Dashboard.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property Dashboard:TDashboard read FCurrent write SetCurrent stored False;

Property Value

Type: TDashboard

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.Dashboards Property

Summary

Represents property Dashboards.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property Dashboards : TDashboards read GetDashboards write SetDashboards;

Property Value

Type: TDashboards

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.Data Property

Summary

Represents property Data.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property Data : TVisualDataItems read GetDataItems write SetDataItems;

Property Value

Type: TVisualDataItems

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.DragMode Property

Summary

Represents property DragMode.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property DragMode;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.Enabled Property

Summary

Represents property Enabled.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property Enabled;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.Height Property

Summary

Represents property Height.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property Height;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.Layouts Property

Summary

Represents property Layouts.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property Layouts : TLayouts read GetLayouts write SetLayouts;

Property Value

Type: TLayouts

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.Margins Property

Summary

Represents property Margins.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property Margins;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.OnClick Property

Summary

Represents property OnClick.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.OnDragDrop Property

Summary

Represents property OnDragDrop.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property OnDragDrop;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.OnDragOver Property

Summary

Represents property OnDragOver.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property OnDragOver;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.OnMouseEnter Property

Summary

Represents property OnMouseEnter.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property OnMouseEnter;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.OnMouseLeave Property

Summary

Represents property OnMouseLeave.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property OnMouseLeave;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.OnMouseWheel Property

Summary

Represents property OnMouseWheel.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property OnMouseWheel;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.OnResize Property

Summary

Represents property OnResize.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property OnResize;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.Padding Property

Summary

Represents property Padding.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property Padding;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.Panels Property

Summary

Represents property Panels.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property Panels : TPanels read GetPanels write SetPanels;

Property Value

Type: TPanels

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.PopupMenu Property

Summary

Represents property PopupMenu.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property PopupMenu;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.Render Property

Summary

Represents property Render.

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 property Render:TRender read FRender write SetRender;

Property Value

Type: TRender

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.TabOrder Property

Summary

Represents property TabOrder.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property TabOrder;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.TabStop Property

Summary

Represents property TabStop.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.Template Property

Summary

Represents property Template.

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 property Template:TBITemplate read FTemplate write SetTemplate;

Property Value

Type: TBITemplate

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.Visible Property

Summary

Represents property Visible.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property Visible;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.Width Property

Summary

Represents property Width.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property Width;

Property Value

Type: Void

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.Clear Method

Summary

Represents method Clear.

Namespace: VCLBI.Dashboard
Syntax
Delphi
protected
 procedure Clear;
See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: VCLBI.Dashboard
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.Generate(TBIPanel) Method

Summary

Represents method Generate(TBIPanel).

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 procedure Generate(const APanel:TBIPanel); overload;

Parameters

APanel
Type: TBIPanel

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.Generate(TDashboard,String) Method

Summary

Represents method Generate(TDashboard,String).

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 procedure Generate(const ADashboard:TDashboard=nil; const ALayout:String=''); overload;

Parameters

ADashboard
Type: TDashboard

ALayout
Type: String

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.GetChildOwner Method

Summary

Represents method GetChildOwner.

Namespace: VCLBI.Dashboard
Syntax
Delphi
protected
 function GetChildOwner: TComponent; override;

Return Value

Type: TComponent

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.Loaded Method

Summary

Represents method Loaded.

Namespace: VCLBI.Dashboard
Syntax
Delphi
protected
 procedure Loaded; override;
See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.Resize Method

Summary

Represents method Resize.

Namespace: VCLBI.Dashboard
Syntax
Delphi
protected
 procedure Resize; override;
See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.ResizeLayout Method

Summary

Represents method ResizeLayout.

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 procedure ResizeLayout;
See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisual.RenderClass Field

Summary

Represents field RenderClass.

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 class var
 RenderClass : TRenderClass;

Field Value

Type: TRenderClass

See Also

Reference

  • TBIVisual
  • VCLBI.Dashboard


TBIVisualAccess Class

Summary

Represents type TBIVisualAccess.

Namespace: VCLBI.Dashboard
Inheritance Hierarchy
TScrollingWinControl
VCLBI.Dashboard.TBIVisual
VCLBI.Dashboard.TBIVisualAccess
Syntax
Delphi
type
 TBIVisualAccess=class(TBIVisual);
See Also

Reference

  • VCLBI.Dashboard


TButtonsPanel Class

Summary

Represents type TButtonsPanel.

Namespace: VCLBI.Dashboard
Inheritance Hierarchy
TScrollBox
VCLBI.Dashboard.TButtonsPanel
Syntax
Delphi
type
 TButtonsPanel=class(TScrollBox)
 end;

The TButtonsPanel type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TButtonsPanel class.
Destroy | Represents the destructor of the TButtonsPanel class.
Top
Properties
Show:
Name | Description
Horizontal | Represents property Horizontal.
ItemIndex | Represents property ItemIndex.
Items | Represents property Items.
OnChange | Represents property OnChange.
Top
See Also

Reference

  • VCLBI.Dashboard


TButtonsPanel.Create(TComponent) Constructor

Summary

Initializes a new instance of the TButtonsPanel class.

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TButtonsPanel
  • VCLBI.Dashboard


TButtonsPanel.Destroy Destructor

Summary

Represents the destructor of the TButtonsPanel class.

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TButtonsPanel
  • VCLBI.Dashboard


TButtonsPanel.Horizontal Property

Summary

Represents property Horizontal.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property Horizontal : Boolean read FHorizontal write FHorizontal default True;

Property Value

Type: Boolean

See Also

Reference

  • TButtonsPanel
  • VCLBI.Dashboard


TButtonsPanel.ItemIndex Property

Summary

Represents property ItemIndex.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property ItemIndex : Integer read FItemIndex write SetItemIndex default -1;

Property Value

Type: Integer

See Also

Reference

  • TButtonsPanel
  • VCLBI.Dashboard


TButtonsPanel.Items Property

Summary

Represents property Items.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property Items:TStrings read FItems write SetItems;

Property Value

Type: TStrings

See Also

Reference

  • TButtonsPanel
  • VCLBI.Dashboard


TButtonsPanel.OnChange Property

Summary

Represents property OnChange.

Namespace: VCLBI.Dashboard
Syntax
Delphi
published
 property OnChange:TNotifyEvent read FOnChange write FOnChange;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TButtonsPanel
  • VCLBI.Dashboard


TControlAccess Class

Summary

Represents type TControlAccess.

Namespace: VCLBI.Dashboard
Inheritance Hierarchy
TWinControl
VCLBI.Dashboard.TControlAccess
Syntax
Delphi
type
 TControlAccess=class(TWinControl);
See Also

Reference

  • VCLBI.Dashboard


TDashboardItemAccess Class

Summary

Represents type TDashboardItemAccess.

Namespace: VCLBI.Dashboard
Inheritance Hierarchy
TCollectionItem
BI.Dashboard.TBaseItem
BI.Dashboard.TCustomBIPanel
BI.Dashboard.TDashboardItem
VCLBI.Dashboard.TDashboardItemAccess
Syntax
Delphi
type
 TDashboardItemAccess=class(TDashboardItem);
See Also

Reference

  • VCLBI.Dashboard


TDashboardTree Class

Summary

Represents type TDashboardTree.

Namespace: VCLBI.Dashboard
Inheritance Hierarchy
TWinControl
VCLBI.DataControl.TBIDataControl
VCLBI.Tree.TBITree
VCLBI.Dashboard.TDashboardTree
Syntax
Delphi
type
 TDashboardTree=class(TBITree)
 end;
See Also

Reference

  • VCLBI.Dashboard


TLayoutComboBox Class

Summary

Represents type TLayoutComboBox.

Namespace: VCLBI.Dashboard
Inheritance Hierarchy
TComboBox
VCLBI.Dashboard.TLayoutComboBox
Syntax
Delphi
type
 TLayoutComboBox=class(TComboBox)
 end;

The TLayoutComboBox type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TLayoutComboBox class.
Top
See Also

Reference

  • VCLBI.Dashboard


TLayoutComboBox.Create(TComponent) Constructor

Summary

Initializes a new instance of the TLayoutComboBox class.

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TLayoutComboBox
  • VCLBI.Dashboard


TLayoutListBox Class

Summary

Represents type TLayoutListBox.

Namespace: VCLBI.Dashboard
Inheritance Hierarchy
TListBox
VCLBI.Dashboard.TLayoutListBox
Syntax
Delphi
type
 TLayoutListBox=class(TListBox)
 end;

The TLayoutListBox type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TLayoutListBox class.
Top
See Also

Reference

  • VCLBI.Dashboard


TLayoutListBox.Create(TComponent) Constructor

Summary

Initializes a new instance of the TLayoutListBox class.

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TLayoutListBox
  • VCLBI.Dashboard


TLayoutPanel Class

Summary

Represents type TLayoutPanel.

Namespace: VCLBI.Dashboard
Inheritance Hierarchy
TPanel
VCLBI.Dashboard.TLayoutPanel
Syntax
Delphi
type
 TLayoutPanel=class(TPanel)
 end;

The TLayoutPanel type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TLayoutPanel class.
Top
Properties
Show:
Name | Description
BackColor | Represents property BackColor.
Top
Fields
Show:
Name | Description
DefaultColor | Represents field DefaultColor.
Top
See Also

Reference

  • VCLBI.Dashboard


TLayoutPanel.Create(TComponent) Constructor

Summary

Initializes a new instance of the TLayoutPanel class.

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TLayoutPanel
  • VCLBI.Dashboard


TLayoutPanel.BackColor Property

Summary

Represents property BackColor.

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 property BackColor:TAlphaColor read FBackColor write SetBackColor default TAlphaColors.Null;

Property Value

Type: TAlphaColor

See Also

Reference

  • TLayoutPanel
  • VCLBI.Dashboard


TLayoutPanel.DefaultColor Field

Summary

Represents field DefaultColor.

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 DefaultColor : TAlphaColor;

Field Value

Type: TAlphaColor

See Also

Reference

  • TLayoutPanel
  • VCLBI.Dashboard


TRenderAccess Class

Summary

Represents type TRenderAccess.

Namespace: VCLBI.Dashboard
Inheritance Hierarchy
TObject
BI.Dashboard.TRender
VCLBI.Dashboard.TRenderAccess
Syntax
Delphi
type
 TRenderAccess=class(TRender);
See Also

Reference

  • VCLBI.Dashboard


TScreenRender Class

Summary

Represents type TScreenRender.

Namespace: VCLBI.Dashboard
Inheritance Hierarchy
TObject
BI.Dashboard.TRender
VCLBI.Dashboard.TScreenRender
VCLBI.Dashboard.Chart.TScreenChartRender
Syntax
Delphi
type
 TScreenRender=class(TRender)
 end;

The TScreenRender type exposes the following members.

Properties
Show:
Name | Description
Control | Represents property Control.
Top
Methods
Show:
Name | Description
AddListener(String,TObject) | Represents method AddListener(String,TObject). (Overrides TRender.AddListener(String,TObject).)
CanRefreshData(TControl) | Represents method CanRefreshData(TControl).
Clear | Represents method Clear. (Overrides TRender.Clear.)
CreateControl(TLayoutItem,TWinControl,String,Boolean,Boolean) | Represents method CreateControl(TLayoutItem,TWinControl,String,Boolean,Boolean).
CreatePanel | Overloaded. Represents method CreatePanel.
CreatePanel(TAlphaColor) | Overloaded. Represents method CreatePanel(TAlphaColor).
Emit(TDashboard,Integer,String) | Represents method Emit(TDashboard,Integer,String). (Overrides TRender.Emit(TDashboard,Integer,String).)
EmitPanel(TDashboardItem,TPanelKind,String) | Represents method EmitPanel(TDashboardItem,TPanelKind,String).
EnsurePanelData(TCustomBIPanel) | Represents method EnsurePanelData(TCustomBIPanel).
Finish | Represents method Finish. (Overrides TRender.Finish.)
GetItemOf(TControl) | Represents method GetItemOf(TControl).
Init(TDashboard,String,TStrings) | Represents method Init(TDashboard,String,TStrings). (Overrides TRender.Init(TDashboard,String,TStrings).)
NewControl(TPanelKind,TDashboardItem) | Represents method NewControl(TPanelKind,TDashboardItem).
ParentRender | Represents method ParentRender.
PostAddControl(TControl,TDashboardItem) | Represents method PostAddControl(TControl,TDashboardItem).
RadioChange(TObject) | Represents method RadioChange(TObject).
SetNested(TLayoutItem,String,Boolean,Boolean) | Represents method SetNested(TLayoutItem,String,Boolean,Boolean).
Top
Fields
Show:
Name | Description
Targets | Represents field Targets.
Top
See Also

Reference

  • VCLBI.Dashboard


TScreenRender.Control Property

Summary

Represents property Control.

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 property Control:TBIVisual read FControl write FControl;

Property Value

Type: TBIVisual

See Also

Reference

  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.AddListener(String,TObject) Method

Summary

Represents method AddListener(String,TObject).

Namespace: VCLBI.Dashboard
Syntax
Delphi
protected
 procedure AddListener(const AName:String; const ASource:TObject); override;

Parameters

AName
Type: String

ASource
Type: TObject

Overrides

TRender.AddListener(String,TObject)
See Also

Reference

  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.CanRefreshData(TControl) Method

Summary

Represents method CanRefreshData(TControl).

Namespace: VCLBI.Dashboard
Syntax
Delphi
protected
 function CanRefreshData(const AControl:TControl):Boolean; virtual;

Parameters

AControl
Type: TControl

Return Value

Type: Boolean

See Also

Reference

  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.Clear Method

Summary

Represents method Clear.

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 procedure Clear; override;

Overrides

TRender.Clear
See Also

Reference

  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.CreateControl(TLayoutItem,TWinControl,String,Boolean,Boolean) Method

Summary

Represents method CreateControl(TLayoutItem,TWinControl,String,Boolean,Boolean).

Namespace: VCLBI.Dashboard
Syntax
Delphi
protected
 function CreateControl(const ALayout:TLayoutItem; const AParent:TWinControl;
 const APrefix:String;
 const Splitters,ShowNames:Boolean):TWinControl;

Parameters

ALayout
Type: TLayoutItem

AParent
Type: TWinControl

APrefix
Type: String

Splitters
Type: Boolean

ShowNames
Type: Boolean

Return Value

Type: TWinControl

See Also

Reference

  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.CreatePanel Method

Summary

Represents method CreatePanel.

Namespace: VCLBI.Dashboard
Syntax
Delphi
protected
 function CreatePanel:TLayoutPanel; overload; inline;

Return Value

Type: TLayoutPanel

See Also

Reference

  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.CreatePanel(TAlphaColor) Method

Summary

Represents method CreatePanel(TAlphaColor).

Namespace: VCLBI.Dashboard
Syntax
Delphi
protected
 function CreatePanel(const ABack:TAlphaColor):TLayoutPanel; overload;

Parameters

ABack
Type: TAlphaColor

Return Value

Type: TLayoutPanel

See Also

Reference

  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.Emit(TDashboard,Integer,String) Method

Summary

Represents method Emit(TDashboard,Integer,String).

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 procedure Emit(const ADashboard:TDashboard; const AItem:Integer; const APosition:String); override;

Parameters

ADashboard
Type: TDashboard

AItem
Type: Integer

APosition
Type: String

Overrides

TRender.Emit(TDashboard,Integer,String)
See Also

Reference

  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.EmitPanel(TDashboardItem,TPanelKind,String) Method

Summary

Represents method EmitPanel(TDashboardItem,TPanelKind,String).

Namespace: VCLBI.Dashboard
Syntax
Delphi
protected
 function EmitPanel(const AItem:TDashboardItem; const AKind:TPanelKind; const APosition:String=''):TControl;

Parameters

AItem
Type: TDashboardItem

AKind
Type: TPanelKind

APosition
Type: String

Return Value

Type: TControl

See Also

Reference

  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.EnsurePanelData(TCustomBIPanel) Method

Summary

Represents method EnsurePanelData(TCustomBIPanel).

Namespace: VCLBI.Dashboard
Syntax
Delphi
protected
 function EnsurePanelData(const APanel:TCustomBIPanel):TDataItem;

Parameters

APanel
Type: TCustomBIPanel

Return Value

Type: TDataItem

See Also

Reference

  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.Finish Method

Summary

Represents method Finish.

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 procedure Finish; override;

Overrides

TRender.Finish
See Also

Reference

  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.GetItemOf(TControl) Method

Summary

Represents method GetItemOf(TControl).

Namespace: VCLBI.Dashboard
Syntax
Delphi
protected
 class function GetItemOf(const Sender:TControl):TDashboardItem; static;

Parameters

Sender
Type: TControl

Return Value

Type: TDashboardItem

See Also

Reference

  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.Init(TDashboard,String,TStrings) Method

Summary

Represents method Init(TDashboard,String,TStrings).

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 procedure Init(const ADashboard:TDashboard; const ALayout:String=''; const AParams:TStrings=nil); override;

Parameters

ADashboard
Type: TDashboard

ALayout
Type: String

AParams
Type: TStrings

Overrides

TRender.Init(TDashboard,String,TStrings)
See Also

Reference

  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.NewControl(TPanelKind,TDashboardItem) Method

Summary

Represents method NewControl(TPanelKind,TDashboardItem).

Namespace: VCLBI.Dashboard
Syntax
Delphi
protected
 function NewControl(const AKind:TPanelKind; const AItem:TDashboardItem):TControl; virtual;

Parameters

AKind
Type: TPanelKind

AItem
Type: TDashboardItem

Return Value

Type: TControl

See Also

Reference

  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.ParentRender Method

Summary

Represents method ParentRender.

Namespace: VCLBI.Dashboard
Syntax
Delphi
protected
 function ParentRender:TScreenRender;

Return Value

Type: TScreenRender

See Also

Reference

  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.PostAddControl(TControl,TDashboardItem) Method

Summary

Represents method PostAddControl(TControl,TDashboardItem).

Namespace: VCLBI.Dashboard
Syntax
Delphi
protected
 procedure PostAddControl(const AControl:TControl; const AItem:TDashboardItem); virtual;

Parameters

AControl
Type: TControl

AItem
Type: TDashboardItem

See Also

Reference

  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.RadioChange(TObject) Method

Summary

Represents method RadioChange(TObject).

Namespace: VCLBI.Dashboard
Syntax
Delphi
protected
 procedure RadioChange(Sender: TObject); virtual;

Parameters

Sender
Type: TObject

See Also

Reference

  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.SetNested(TLayoutItem,String,Boolean,Boolean) Method

Summary

Represents method SetNested(TLayoutItem,String,Boolean,Boolean).

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 procedure SetNested(const AItem:TLayoutItem; const AName:String; const Splitters,ShowNames:Boolean);

Parameters

AItem
Type: TLayoutItem

AName
Type: String

Splitters
Type: Boolean

ShowNames
Type: Boolean

See Also

Reference

  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.Targets Field

Summary

Represents field Targets.

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 Targets : TTargetControls;

Field Value

Type: TTargetControls

See Also

Reference

  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.TTargetControlsHelper Class Helper

Summary

Represents type TTargetControlsHelper.

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
type
 TTargetControlsHelper=record helper for TTargetControls
 end;
Methods
Name | Description
Add(String,TControl,TLayoutItem) | Represents method Add(String,TControl,TLayoutItem).
Count | Represents method Count.
FindControl(String) | Overloaded. Represents method FindControl(String).
FindControl(TLayoutItem) | Overloaded. Represents method FindControl(TLayoutItem).
FindLayout(TControl) | Represents method FindLayout(TControl).
Top
See Also

Reference

  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.TTargetControlsHelper.Add(String,TControl,TLayoutItem) Method

Summary

Represents method Add(String,TControl,TLayoutItem).

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 function Add(const AName:String; const AControl:TControl; const ALayout:TLayoutItem):Integer;

Parameters

AName
Type: String

AControl
Type: TControl

ALayout
Type: TLayoutItem

Return Value

Type: Integer

See Also

Reference

  • TScreenRender.TTargetControlsHelper
  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.TTargetControlsHelper.Count Method

Summary

Represents method Count.

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 function Count:Integer; inline;

Return Value

Type: Integer

See Also

Reference

  • TScreenRender.TTargetControlsHelper
  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.TTargetControlsHelper.FindControl(String) Method

Summary

Represents method FindControl(String).

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 function FindControl(const AName:String):TControl; overload;

Parameters

AName
Type: String

Return Value

Type: TControl

See Also

Reference

  • TScreenRender.TTargetControlsHelper
  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.TTargetControlsHelper.FindControl(TLayoutItem) Method

Summary

Represents method FindControl(TLayoutItem).

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 function FindControl(const AItem:TLayoutItem):TControl; overload;

Parameters

AItem
Type: TLayoutItem

Return Value

Type: TControl

See Also

Reference

  • TScreenRender.TTargetControlsHelper
  • TScreenRender
  • VCLBI.Dashboard


TScreenRender.TTargetControlsHelper.FindLayout(TControl) Method

Summary

Represents method FindLayout(TControl).

Namespace: VCLBI.Dashboard
Syntax
Delphi
public
 function FindLayout(const AControl:TControl):TLayoutItem;

Parameters

AControl
Type: TControl

Return Value

Type: TLayoutItem

See Also

Reference

  • TScreenRender.TTargetControlsHelper
  • TScreenRender
  • VCLBI.Dashboard


VCLBI.Dashboard Types

Types
Name | Description
TScreenRenderClass | Represents type TScreenRenderClass.
Top


TScreenRenderClass Type

Summary

Represents type TScreenRenderClass.

Namespace: VCLBI.Dashboard
Syntax
Delphi
type
 TScreenRenderClass=class of TScreenRender;
See Also

Reference

  • VCLBI.Dashboard


VCLBI.Dashboard Routines

Routines
Name | Description
AlignOf(String) | Represents method AlignOf(String).
AlphaColorToColor(TAlphaColor) | Represents method AlphaColorToColor(TAlphaColor).
AlphaToColor(TAlphaColor) | Represents method AlphaToColor(TAlphaColor).
CreatePanelFrame(TWinControl) | Represents method CreatePanelFrame(TWinControl).
DoSetPadding(TWinControl,Single) | Represents method DoSetPadding(TWinControl,Single).
GetURLStream(String) | Represents method GetURLStream(String).
IsAlignLeftRight(TControl) | Represents method IsAlignLeftRight(TControl).
IsAlignTopBottom(TControl) | Represents method IsAlignTopBottom(TControl).
LoadImage(TImage,String) | Represents method LoadImage(TImage,String).
NewTab(TControl,TWinControl,String) | Represents method NewTab(TControl,TWinControl,String).
ParentOf(TControl) | Represents method ParentOf(TControl).
RandomLightColor | Represents method RandomLightColor.
RepositionControl(TControl) | Represents method RepositionControl(TControl).
ScrollContentOf(TWinControl) | Represents method ScrollContentOf(TWinControl).
SetDefaultPadding(TWinControl) | Represents method SetDefaultPadding(TWinControl).
ShowHideAll(TControl,Integer) | Represents method ShowHideAll(TControl,Integer).
TitleOf(TDashboardItem) | Represents method TitleOf(TDashboardItem).
Top


AlignOf(String) Method

Summary

Represents method AlignOf(String).

Namespace: VCLBI.Dashboard
Syntax
Delphi
function AlignOf(const Align:String):TAlign;

Parameters

Align
Type: String

Return Value

Type: TAlign

See Also

Reference

  • VCLBI.Dashboard


AlphaColorToColor(TAlphaColor) Method

Summary

Represents method AlphaColorToColor(TAlphaColor).

Namespace: VCLBI.Dashboard
Syntax
Delphi
function AlphaColorToColor(const Color: TAlphaColor): TColor;

Parameters

Color
Type: TAlphaColor

Return Value

Type: TColor

See Also

Reference

  • VCLBI.Dashboard


AlphaToColor(TAlphaColor) Method

Summary

Represents method AlphaToColor(TAlphaColor).

Namespace: VCLBI.Dashboard
Syntax
Delphi
function AlphaToColor(const ABack:TAlphaColor):TColor;

Parameters

ABack
Type: TAlphaColor

Return Value

Type: TColor

See Also

Reference

  • VCLBI.Dashboard


CreatePanelFrame(TWinControl) Method

Summary

Represents method CreatePanelFrame(TWinControl).

Namespace: VCLBI.Dashboard
Syntax
Delphi
function CreatePanelFrame(const AControl:TWinControl):TShape;

Parameters

AControl
Type: TWinControl

Return Value

Type: TShape

See Also

Reference

  • VCLBI.Dashboard


DoSetPadding(TWinControl,Single) Method

Summary

Represents method DoSetPadding(TWinControl,Single).

Namespace: VCLBI.Dashboard
Syntax
Delphi
procedure DoSetPadding(const AControl: TWinControl; const APadding:Single);

Parameters

AControl
Type: TWinControl

APadding
Type: Single

See Also

Reference

  • VCLBI.Dashboard


GetURLStream(String) Method

Summary

Represents method GetURLStream(String).

Namespace: VCLBI.Dashboard
Syntax
Delphi
function GetURLStream(const AURL:String):TStream;

Parameters

AURL
Type: String

Return Value

Type: TStream

See Also

Reference

  • VCLBI.Dashboard


IsAlignLeftRight(TControl) Method

Summary

Represents method IsAlignLeftRight(TControl).

Namespace: VCLBI.Dashboard
Syntax
Delphi
function IsAlignLeftRight(const AControl:TControl):Boolean;

Parameters

AControl
Type: TControl

Return Value

Type: Boolean

See Also

Reference

  • VCLBI.Dashboard


IsAlignTopBottom(TControl) Method

Summary

Represents method IsAlignTopBottom(TControl).

Namespace: VCLBI.Dashboard
Syntax
Delphi
function IsAlignTopBottom(const AControl:TControl):Boolean;

Parameters

AControl
Type: TControl

Return Value

Type: Boolean

See Also

Reference

  • VCLBI.Dashboard


LoadImage(TImage,String) Method

Summary

Represents method LoadImage(TImage,String).

Namespace: VCLBI.Dashboard
Syntax
Delphi
procedure LoadImage(const AImage:TImage; const AURL:String);

Parameters

AImage
Type: TImage

AURL
Type: String

See Also

Reference

  • VCLBI.Dashboard


NewTab(TControl,TWinControl,String) Method

Summary

Represents method NewTab(TControl,TWinControl,String).

Namespace: VCLBI.Dashboard
Syntax
Delphi
function NewTab(var FTabs:TControl; const AOwner:TWinControl;
 const ATitle:String):TTabSheet;

Parameters

FTabs
Type: TControl

AOwner
Type: TWinControl

ATitle
Type: String

Return Value

Type: TTabSheet

See Also

Reference

  • VCLBI.Dashboard


ParentOf(TControl) Method

Summary

Represents method ParentOf(TControl).

Namespace: VCLBI.Dashboard
Syntax
Delphi
function ParentOf(const AControl:TControl):TWinControl; inline;

Parameters

AControl
Type: TControl

Return Value

Type: TWinControl

See Also

Reference

  • VCLBI.Dashboard


RandomLightColor Method

Summary

Represents method RandomLightColor.

Namespace: VCLBI.Dashboard
Syntax
Delphi
function RandomLightColor:TAlphaColor;

Return Value

Type: TAlphaColor

See Also

Reference

  • VCLBI.Dashboard


RepositionControl(TControl) Method

Summary

Represents method RepositionControl(TControl).

Namespace: VCLBI.Dashboard
Syntax
Delphi
procedure RepositionControl(const AControl:TControl);

Parameters

AControl
Type: TControl

See Also

Reference

  • VCLBI.Dashboard


ScrollContentOf(TWinControl) Method

Summary

Represents method ScrollContentOf(TWinControl).

Namespace: VCLBI.Dashboard
Syntax
Delphi
function ScrollContentOf(const AParent:TWinControl):TWinControl;

Parameters

AParent
Type: TWinControl

Return Value

Type: TWinControl

See Also

Reference

  • VCLBI.Dashboard


SetDefaultPadding(TWinControl) Method

Summary

Represents method SetDefaultPadding(TWinControl).

Namespace: VCLBI.Dashboard
Syntax
Delphi
procedure SetDefaultPadding(const AControl:TWinControl);

Parameters

AControl
Type: TWinControl

See Also

Reference

  • VCLBI.Dashboard


ShowHideAll(TControl,Integer) Method

Summary

Represents method ShowHideAll(TControl,Integer).

Namespace: VCLBI.Dashboard
Syntax
Delphi
procedure ShowHideAll(const AControl:TControl; const AIndex:Integer);

Parameters

AControl
Type: TControl

AIndex
Type: Integer

See Also

Reference

  • VCLBI.Dashboard


TitleOf(TDashboardItem) Method

Summary

Represents method TitleOf(TDashboardItem).

Namespace: VCLBI.Dashboard
Syntax
Delphi
function TitleOf(const AItem:TDashboardItem):String;

Parameters

AItem
Type: TDashboardItem

Return Value

Type: String

See Also

Reference

  • VCLBI.Dashboard


VCLBI.Dashboard.Chart Namespace

Summary

Represents namespace VCLBI.Dashboard.Chart.

Classes
Name | Description
TDashboardItemAccess | Represents type TDashboardItemAccess.
TScreenChartRender | Represents type TScreenChartRender.
Top


VCLBI.Dashboard.Chart Classes

Classes
Name | Description
TDashboardItemAccess | Represents type TDashboardItemAccess.
TScreenChartRender | Represents type TScreenChartRender.
Top


TDashboardItemAccess Class

Summary

Represents type TDashboardItemAccess.

Namespace: VCLBI.Dashboard.Chart
Inheritance Hierarchy
TCollectionItem
BI.Dashboard.TBaseItem
BI.Dashboard.TCustomBIPanel
BI.Dashboard.TDashboardItem
VCLBI.Dashboard.Chart.TDashboardItemAccess
Syntax
Delphi
type
 TDashboardItemAccess=class(TDashboardItem);
See Also

Reference

  • VCLBI.Dashboard.Chart


TScreenChartRender Class

Summary

Represents type TScreenChartRender.

Namespace: VCLBI.Dashboard.Chart
Inheritance Hierarchy
TObject
BI.Dashboard.TRender
VCLBI.Dashboard.TScreenRender
VCLBI.Dashboard.Chart.TScreenChartRender
Syntax
Delphi
type
 TScreenChartRender=class(TScreenRender)
 end;

The TScreenChartRender type exposes the following members.

Methods
Show:
Name | Description
CanRefreshData(TControl) | Represents method CanRefreshData(TControl). (Overrides TScreenRender.CanRefreshData(TControl).)
NewChart(TComponent,TDashboardItem,TDataItem,String) | Represents method NewChart(TComponent,TDashboardItem,TDataItem,String).
NewControl(TPanelKind,TDashboardItem) | Represents method NewControl(TPanelKind,TDashboardItem). (Overrides TScreenRender.NewControl(TPanelKind,TDashboardItem).)
Top
See Also

Reference

  • VCLBI.Dashboard.Chart


TScreenChartRender Methods

Methods
Name | Description
CanRefreshData(TControl) | Represents method CanRefreshData(TControl). (Overrides TScreenRender.CanRefreshData(TControl).)
NewChart(TComponent,TDashboardItem,TDataItem,String) | Represents method NewChart(TComponent,TDashboardItem,TDataItem,String).
NewControl(TPanelKind,TDashboardItem) | Represents method NewControl(TPanelKind,TDashboardItem). (Overrides TScreenRender.NewControl(TPanelKind,TDashboardItem).)
Top


TScreenChartRender.CanRefreshData(TControl) Method

Summary

Represents method CanRefreshData(TControl).

Namespace: VCLBI.Dashboard.Chart
Syntax
Delphi
protected
 function CanRefreshData(const AControl:TControl):Boolean; override;

Parameters

AControl
Type: TControl

Return Value

Type: Boolean

Overrides

TScreenRender.CanRefreshData(TControl)
See Also

Reference

  • TScreenChartRender
  • VCLBI.Dashboard.Chart


TScreenChartRender.NewChart(TComponent,TDashboardItem,TDataItem,String) Method

Summary

Represents method NewChart(TComponent,TDashboardItem,TDataItem,String).

Namespace: VCLBI.Dashboard.Chart
Syntax
Delphi
public
 class function NewChart(const AOwner:TComponent; const AItem:TDashboardItem;
 const AData:TDataItem;
 const AFormat:String):TBIChart; static;

Parameters

AOwner
Type: TComponent

AItem
Type: TDashboardItem

AData
Type: TDataItem

AFormat
Type: String

Return Value

Type: TBIChart

See Also

Reference

  • TScreenChartRender
  • VCLBI.Dashboard.Chart


TScreenChartRender.NewControl(TPanelKind,TDashboardItem) Method

Summary

Represents method NewControl(TPanelKind,TDashboardItem).

Namespace: VCLBI.Dashboard.Chart
Syntax
Delphi
protected
 function NewControl(const AKind:TPanelKind; const AItem:TDashboardItem):TControl; override;

Parameters

AKind
Type: TPanelKind

AItem
Type: TDashboardItem

Return Value

Type: TControl

Overrides

TScreenRender.NewControl(TPanelKind,TDashboardItem)
See Also

Reference

  • TScreenChartRender
  • VCLBI.Dashboard.Chart


VCLBI.DataControl Namespace

Summary

Represents namespace VCLBI.DataControl.

Classes
Name | Description
TBIDataControl | Represents type TBIDataControl.
TDataAccess | Represents type TDataAccess.
TDataProviderAccess | Represents type TDataProviderAccess.
Top


VCLBI.DataControl Classes

Classes
Name | Description
TBIDataControl | Represents type TBIDataControl.
TDataAccess | Represents type TDataAccess.
TDataProviderAccess | Represents type TDataProviderAccess.
Top


TBIDataControl Class

Summary

Represents type TBIDataControl.

Namespace: VCLBI.DataControl
Inheritance Hierarchy
TWinControl
VCLBI.DataControl.TBIDataControl
VCLBI.Chart.Plugin.TBIDataControlAccess
VCLBI.Chart.TBIChart
VCLBI.Grid.TBIGrid
VCLBI.Tree.TBITree
Syntax
Delphi
type
 TBIDataControl=class(TWinControl)
 end;

The TBIDataControl type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIDataControl class.
Destroy | Represents the destructor of the TBIDataControl class.
Top
Properties
Show:
Name | Description
Align | Represents property Align.
Anchors | Represents property Anchors.
AutoSize | Represents property AutoSize.
BiDiMode | Represents property BiDiMode.
Color | Represents property Color.
Constraints | Represents property Constraints.
Data | Represents property Data.
DockManager | Represents property DockManager.
DockSite | Represents property DockSite.
DoubleBuffered | Represents property DoubleBuffered.
DragCursor | Represents property DragCursor.
DragKind | Represents property DragKind.
DragMode | Represents property DragMode.
Enabled | Represents property Enabled.
Height | Represents property Height.
Margins | Represents property Margins.
OnAlignInsertBefore | Represents property OnAlignInsertBefore.
OnAlignPosition | Represents property OnAlignPosition.
OnCanResize | Represents property OnCanResize.
OnClick | Represents property OnClick.
OnConstrainedResize | Represents property OnConstrainedResize.
OnContextPopup | Represents property OnContextPopup.
OnDblClick | Represents property OnDblClick.
OnDockDrop | Represents property OnDockDrop.
OnDockOver | Represents property OnDockOver.
OnDragDrop | Represents property OnDragDrop.
OnDragOver | Represents property OnDragOver.
OnEndDock | Represents property OnEndDock.
OnEndDrag | Represents property OnEndDrag.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnGesture | Represents property OnGesture.
OnGetSiteInfo | Represents property OnGetSiteInfo.
OnMouseActivate | Represents property OnMouseActivate.
OnMouseDown | Represents property OnMouseDown.
OnMouseEnter | Represents property OnMouseEnter.
OnMouseLeave | Represents property OnMouseLeave.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnResize | Represents property OnResize.
OnStartDock | Represents property OnStartDock.
OnStartDrag | Represents property OnStartDrag.
OnUnDock | Represents property OnUnDock.
Padding | Represents property Padding.
ParentBackground | Represents property ParentBackground.
ParentBiDiMode | Represents property ParentBiDiMode.
ParentColor | Represents property ParentColor.
ParentDoubleBuffered | Represents property ParentDoubleBuffered.
ParentShowHint | Represents property ParentShowHint.
PopupMenu | Represents property PopupMenu.
Provider | Represents property Provider.
ShowHint | Represents property ShowHint.
StyleElements | Represents property StyleElements.
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
Touch | Represents property Touch.
UseDockManager | Represents property UseDockManager.
Visible | Represents property Visible.
Width | Represents property Width.
Top
Methods
Show:
Name | Description
AddNotify | Represents method AddNotify.
ControlOfClass(TClass) | Represents method ControlOfClass(TClass).
DefineProperties(TFiler) | Represents method DefineProperties(TFiler).
DestroyData | Represents method DestroyData.
Loaded | Represents method Loaded.
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
RefreshData | Represents method RefreshData.
RemoveNotify | Represents method RemoveNotify.
SetDataDirect(TDataItem) | Represents method SetDataDirect(TDataItem).
UpdatedDataValues | Represents method UpdatedDataValues.
Top
See Also

Reference

  • VCLBI.DataControl


TBIDataControl.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIDataControl class.

Namespace: VCLBI.DataControl
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.Destroy Destructor

Summary

Represents the destructor of the TBIDataControl class.

Namespace: VCLBI.DataControl
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl Properties

Properties
Name | Description
Align | Represents property Align.
Anchors | Represents property Anchors.
AutoSize | Represents property AutoSize.
BiDiMode | Represents property BiDiMode.
Color | Represents property Color.
Constraints | Represents property Constraints.
Data | Represents property Data.
DockManager | Represents property DockManager.
DockSite | Represents property DockSite.
DoubleBuffered | Represents property DoubleBuffered.
DragCursor | Represents property DragCursor.
DragKind | Represents property DragKind.
DragMode | Represents property DragMode.
Enabled | Represents property Enabled.
Height | Represents property Height.
Margins | Represents property Margins.
OnAlignInsertBefore | Represents property OnAlignInsertBefore.
OnAlignPosition | Represents property OnAlignPosition.
OnCanResize | Represents property OnCanResize.
OnClick | Represents property OnClick.
OnConstrainedResize | Represents property OnConstrainedResize.
OnContextPopup | Represents property OnContextPopup.
OnDblClick | Represents property OnDblClick.
OnDockDrop | Represents property OnDockDrop.
OnDockOver | Represents property OnDockOver.
OnDragDrop | Represents property OnDragDrop.
OnDragOver | Represents property OnDragOver.
OnEndDock | Represents property OnEndDock.
OnEndDrag | Represents property OnEndDrag.
OnEnter | Represents property OnEnter.
OnExit | Represents property OnExit.
OnGesture | Represents property OnGesture.
OnGetSiteInfo | Represents property OnGetSiteInfo.
OnMouseActivate | Represents property OnMouseActivate.
OnMouseDown | Represents property OnMouseDown.
OnMouseEnter | Represents property OnMouseEnter.
OnMouseLeave | Represents property OnMouseLeave.
OnMouseMove | Represents property OnMouseMove.
OnMouseUp | Represents property OnMouseUp.
OnResize | Represents property OnResize.
OnStartDock | Represents property OnStartDock.
OnStartDrag | Represents property OnStartDrag.
OnUnDock | Represents property OnUnDock.
Padding | Represents property Padding.
ParentBackground | Represents property ParentBackground.
ParentBiDiMode | Represents property ParentBiDiMode.
ParentColor | Represents property ParentColor.
ParentDoubleBuffered | Represents property ParentDoubleBuffered.
ParentShowHint | Represents property ParentShowHint.
PopupMenu | Represents property PopupMenu.
Provider | Represents property Provider.
ShowHint | Represents property ShowHint.
StyleElements | Represents property StyleElements.
TabOrder | Represents property TabOrder.
TabStop | Represents property TabStop.
Touch | Represents property Touch.
UseDockManager | Represents property UseDockManager.
Visible | Represents property Visible.
Width | Represents property Width.
Top


TBIDataControl.Align Property

Summary

Represents property Align.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property Align;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.Anchors Property

Summary

Represents property Anchors.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property Anchors;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.AutoSize Property

Summary

Represents property AutoSize.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property AutoSize;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.BiDiMode Property

Summary

Represents property BiDiMode.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property BiDiMode;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.Color Property

Summary

Represents property Color.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property Color default clBtnFace;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.Constraints Property

Summary

Represents property Constraints.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property Constraints;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.Data Property

Summary

Represents property Data.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property Data:TDataItem read GetDataItem write SetDataItem default nil;

Property Value

Type: TDataItem

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.DockManager Property

Summary

Represents property DockManager.

Namespace: VCLBI.DataControl
Syntax
Delphi
protected
 property DockManager;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.DockSite Property

Summary

Represents property DockSite.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property DockSite;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.DoubleBuffered Property

Summary

Represents property DoubleBuffered.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property DoubleBuffered;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.DragCursor Property

Summary

Represents property DragCursor.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property DragCursor;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.DragKind Property

Summary

Represents property DragKind.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property DragKind;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.DragMode Property

Summary

Represents property DragMode.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property DragMode;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.Enabled Property

Summary

Represents property Enabled.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property Enabled;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.Height Property

Summary

Represents property Height.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property Height;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.Margins Property

Summary

Represents property Margins.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property Margins;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnAlignInsertBefore Property

Summary

Represents property OnAlignInsertBefore.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnAlignInsertBefore;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnAlignPosition Property

Summary

Represents property OnAlignPosition.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnAlignPosition;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnCanResize Property

Summary

Represents property OnCanResize.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnCanResize;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnClick Property

Summary

Represents property OnClick.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnClick;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnConstrainedResize Property

Summary

Represents property OnConstrainedResize.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnConstrainedResize;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnContextPopup Property

Summary

Represents property OnContextPopup.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnContextPopup;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnDblClick Property

Summary

Represents property OnDblClick.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnDblClick;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnDockDrop Property

Summary

Represents property OnDockDrop.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnDockDrop;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnDockOver Property

Summary

Represents property OnDockOver.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnDockOver;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnDragDrop Property

Summary

Represents property OnDragDrop.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnDragDrop;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnDragOver Property

Summary

Represents property OnDragOver.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnDragOver;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnEndDock Property

Summary

Represents property OnEndDock.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnEndDock;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnEndDrag Property

Summary

Represents property OnEndDrag.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnEndDrag;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnEnter Property

Summary

Represents property OnEnter.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnEnter;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnExit Property

Summary

Represents property OnExit.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnExit;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnGesture Property

Summary

Represents property OnGesture.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnGesture;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnGetSiteInfo Property

Summary

Represents property OnGetSiteInfo.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnGetSiteInfo;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnMouseActivate Property

Summary

Represents property OnMouseActivate.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnMouseActivate;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnMouseDown Property

Summary

Represents property OnMouseDown.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnMouseDown;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnMouseEnter Property

Summary

Represents property OnMouseEnter.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnMouseEnter;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnMouseLeave Property

Summary

Represents property OnMouseLeave.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnMouseLeave;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnMouseMove Property

Summary

Represents property OnMouseMove.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnMouseMove;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnMouseUp Property

Summary

Represents property OnMouseUp.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnMouseUp;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnResize Property

Summary

Represents property OnResize.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnResize;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnStartDock Property

Summary

Represents property OnStartDock.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnStartDock;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnStartDrag Property

Summary

Represents property OnStartDrag.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnStartDrag;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.OnUnDock Property

Summary

Represents property OnUnDock.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property OnUnDock;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.Padding Property

Summary

Represents property Padding.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property Padding;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.ParentBackground Property

Summary

Represents property ParentBackground.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property ParentBackground ;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.ParentBiDiMode Property

Summary

Represents property ParentBiDiMode.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property ParentBiDiMode;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.ParentColor Property

Summary

Represents property ParentColor.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property ParentColor;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.ParentDoubleBuffered Property

Summary

Represents property ParentDoubleBuffered.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property ParentDoubleBuffered;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.ParentShowHint Property

Summary

Represents property ParentShowHint.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property ParentShowHint;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.PopupMenu Property

Summary

Represents property PopupMenu.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property PopupMenu;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.Provider Property

Summary

Represents property Provider.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property Provider:TComponent read GetProvider write SetProvider;

Property Value

Type: TComponent

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.ShowHint Property

Summary

Represents property ShowHint.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property ShowHint;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.StyleElements Property

Summary

Represents property StyleElements.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property StyleElements;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.TabOrder Property

Summary

Represents property TabOrder.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property TabOrder;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.TabStop Property

Summary

Represents property TabStop.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property TabStop;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.Touch Property

Summary

Represents property Touch.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property Touch;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.UseDockManager Property

Summary

Represents property UseDockManager.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property UseDockManager default True;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.Visible Property

Summary

Represents property Visible.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property Visible;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.Width Property

Summary

Represents property Width.

Namespace: VCLBI.DataControl
Syntax
Delphi
published
 property Width;

Property Value

Type: Void

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.AddNotify Method

Summary

Represents method AddNotify.

Namespace: VCLBI.DataControl
Syntax
Delphi
protected
 procedure AddNotify;
See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.ControlOfClass(TClass) Method

Summary

Represents method ControlOfClass(TClass).

Namespace: VCLBI.DataControl
Syntax
Delphi
protected
 function ControlOfClass(const AClass:TClass): TControl;

Parameters

AClass
Type: TClass

Return Value

Type: TControl

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.DefineProperties(TFiler) Method

Summary

Represents method DefineProperties(TFiler).

Namespace: VCLBI.DataControl
Syntax
Delphi
protected
 procedure DefineProperties(Filer: TFiler); override;

Parameters

Filer
Type: TFiler

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.DestroyData Method

Summary

Represents method DestroyData.

Namespace: VCLBI.DataControl
Syntax
Delphi
public
 procedure DestroyData;
See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.Loaded Method

Summary

Represents method Loaded.

Namespace: VCLBI.DataControl
Syntax
Delphi
protected
 procedure Loaded; override;
See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: VCLBI.DataControl
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.RefreshData Method

Summary

Represents method RefreshData.

Namespace: VCLBI.DataControl
Syntax
Delphi
public
 procedure RefreshData; virtual;
See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.RemoveNotify Method

Summary

Represents method RemoveNotify.

Namespace: VCLBI.DataControl
Syntax
Delphi
protected
 procedure RemoveNotify;
See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.SetDataDirect(TDataItem) Method

Summary

Represents method SetDataDirect(TDataItem).

Namespace: VCLBI.DataControl
Syntax
Delphi
protected
 procedure SetDataDirect(const Value: TDataItem); virtual;

Parameters

Value
Type: TDataItem

See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TBIDataControl.UpdatedDataValues Method

Summary

Represents method UpdatedDataValues.

Namespace: VCLBI.DataControl
Syntax
Delphi
protected
 procedure UpdatedDataValues; virtual;
See Also

Reference

  • TBIDataControl
  • VCLBI.DataControl


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: VCLBI.DataControl
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
VCLBI.DataControl.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • VCLBI.DataControl


TDataProviderAccess Class

Summary

Represents type TDataProviderAccess.

Namespace: VCLBI.DataControl
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
VCLBI.DataControl.TDataProviderAccess
Syntax
Delphi
type
 TDataProviderAccess=class(TDataProvider);
See Also

Reference

  • VCLBI.DataControl


VCLBI.DataEditor Namespace

Summary

Represents namespace VCLBI.DataEditor.

Classes
Name | Description
TDataItemEditor | Represents type TDataItemEditor.
Top


VCLBI.DataEditor Classes

Classes
Name | Description
TDataItemEditor | Represents type TDataItemEditor.
Top


TDataItemEditor Class

Summary

Represents type TDataItemEditor.

Namespace: VCLBI.DataEditor
Inheritance Hierarchy
TForm
VCLBI.DataViewer.TDataViewer
VCLBI.DataEditor.TDataItemEditor
Syntax
Delphi
type
 TDataItemEditor = class(TDataViewer)
 end;

The TDataItemEditor type exposes the following members.

Methods
Show:
Name | Description
AddField1Click(TObject) | Represents method AddField1Click(TObject).
AddFolder1Click(TObject) | Represents method AddFolder1Click(TObject).
AddTable1Click(TObject) | Represents method AddTable1Click(TObject).
BOKClick(TObject) | Represents method BOKClick(TObject).
Boolean1Click(TObject) | Represents method Boolean1Click(TObject).
DataSource2UpdateData(TObject) | Represents method DataSource2UpdateData(TObject).
Edit(TComponent,TDataItem) | Represents method Edit(TComponent,TDataItem).
FormCloseQuery(TObject,Boolean) | Represents method FormCloseQuery(TObject,Boolean).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
ItemsBeforeDelete(TDataSet) | Represents method ItemsBeforeDelete(TDataSet).
PopupNodePopup(TObject) | Represents method PopupNodePopup(TObject).
Rename1Click(TObject) | Represents method Rename1Click(TObject).
TryAddInfoEditors(TObject) | Represents method TryAddInfoEditors(TObject). (Overrides TDataViewer.TryAddInfoEditors(TObject).)
Top
Fields
Show:
Name | Description
AddField1 | Represents field AddField1.
AddFolder1 | Represents field AddFolder1.
AddTable1 | Represents field AddTable1.
BCancel | Represents field BCancel.
BOK | Represents field BOK.
Boolean1 | Represents field Boolean1.
DateTime1 | Represents field DateTime1.
FloatDouble1 | Represents field FloatDouble1.
FloatExtended1 | Represents field FloatExtended1.
FloatSingle1 | Represents field FloatSingle1.
Integer32bit1 | Represents field Integer32bit1.
Integer64bit1 | Represents field Integer64bit1.
Kind1 | Represents field Kind1.
N2 | Represents field N2.
Panel7 | Represents field Panel7.
PanelButtons | Represents field PanelButtons.
PopupNode | Represents field PopupNode.
Rename1 | Represents field Rename1.
Text1 | Represents field Text1.
Top
See Also

Reference

  • VCLBI.DataEditor


TDataItemEditor Methods

Methods
Name | Description
AddField1Click(TObject) | Represents method AddField1Click(TObject).
AddFolder1Click(TObject) | Represents method AddFolder1Click(TObject).
AddTable1Click(TObject) | Represents method AddTable1Click(TObject).
BOKClick(TObject) | Represents method BOKClick(TObject).
Boolean1Click(TObject) | Represents method Boolean1Click(TObject).
DataSource2UpdateData(TObject) | Represents method DataSource2UpdateData(TObject).
Edit(TComponent,TDataItem) | Represents method Edit(TComponent,TDataItem).
FormCloseQuery(TObject,Boolean) | Represents method FormCloseQuery(TObject,Boolean).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
ItemsBeforeDelete(TDataSet) | Represents method ItemsBeforeDelete(TDataSet).
PopupNodePopup(TObject) | Represents method PopupNodePopup(TObject).
Rename1Click(TObject) | Represents method Rename1Click(TObject).
TryAddInfoEditors(TObject) | Represents method TryAddInfoEditors(TObject). (Overrides TDataViewer.TryAddInfoEditors(TObject).)
Top


TDataItemEditor.AddField1Click(TObject) Method

Summary

Represents method AddField1Click(TObject).

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 procedure AddField1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.AddFolder1Click(TObject) Method

Summary

Represents method AddFolder1Click(TObject).

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 procedure AddFolder1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.AddTable1Click(TObject) Method

Summary

Represents method AddTable1Click(TObject).

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 procedure AddTable1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.BOKClick(TObject) Method

Summary

Represents method BOKClick(TObject).

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 procedure BOKClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.Boolean1Click(TObject) Method

Summary

Represents method Boolean1Click(TObject).

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 procedure Boolean1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.DataSource2UpdateData(TObject) Method

Summary

Represents method DataSource2UpdateData(TObject).

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 procedure DataSource2UpdateData(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.Edit(TComponent,TDataItem) Method

Summary

Represents method Edit(TComponent,TDataItem).

Namespace: VCLBI.DataEditor
Syntax
Delphi
public
 class function Edit(const AOwner: TComponent; const AData: TDataItem):Boolean; static;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.FormCloseQuery(TObject,Boolean) Method

Summary

Represents method FormCloseQuery(TObject,Boolean).

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 procedure FormCloseQuery(Sender: TObject; var CanClose: Boolean);

Parameters

Sender
Type: TObject

CanClose
Type: Boolean

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.FormDestroy(TObject) Method

Summary

Represents method FormDestroy(TObject).

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 procedure FormDestroy(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.ItemsBeforeDelete(TDataSet) Method

Summary

Represents method ItemsBeforeDelete(TDataSet).

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 procedure ItemsBeforeDelete(DataSet: TDataSet);

Parameters

DataSet
Type: TDataSet

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.PopupNodePopup(TObject) Method

Summary

Represents method PopupNodePopup(TObject).

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 procedure PopupNodePopup(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.Rename1Click(TObject) Method

Summary

Represents method Rename1Click(TObject).

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 procedure Rename1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.TryAddInfoEditors(TObject) Method

Summary

Represents method TryAddInfoEditors(TObject).

Namespace: VCLBI.DataEditor
Syntax
Delphi
protected
 procedure TryAddInfoEditors(const AGrid:TObject); override;

Parameters

AGrid
Type: TObject

Overrides

TDataViewer.TryAddInfoEditors(TObject)
See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor Fields

Fields
Name | Description
AddField1 | Represents field AddField1.
AddFolder1 | Represents field AddFolder1.
AddTable1 | Represents field AddTable1.
BCancel | Represents field BCancel.
BOK | Represents field BOK.
Boolean1 | Represents field Boolean1.
DateTime1 | Represents field DateTime1.
FloatDouble1 | Represents field FloatDouble1.
FloatExtended1 | Represents field FloatExtended1.
FloatSingle1 | Represents field FloatSingle1.
Integer32bit1 | Represents field Integer32bit1.
Integer64bit1 | Represents field Integer64bit1.
Kind1 | Represents field Kind1.
N2 | Represents field N2.
Panel7 | Represents field Panel7.
PanelButtons | Represents field PanelButtons.
PopupNode | Represents field PopupNode.
Rename1 | Represents field Rename1.
Text1 | Represents field Text1.
Top


TDataItemEditor.AddField1 Field

Summary

Represents field AddField1.

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 AddField1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.AddFolder1 Field

Summary

Represents field AddFolder1.

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 AddFolder1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.AddTable1 Field

Summary

Represents field AddTable1.

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 AddTable1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.BCancel Field

Summary

Represents field BCancel.

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 BCancel: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.BOK Field

Summary

Represents field BOK.

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 BOK: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.Boolean1 Field

Summary

Represents field Boolean1.

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 Boolean1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.DateTime1 Field

Summary

Represents field DateTime1.

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 DateTime1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.FloatDouble1 Field

Summary

Represents field FloatDouble1.

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 FloatDouble1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.FloatExtended1 Field

Summary

Represents field FloatExtended1.

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 FloatExtended1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.FloatSingle1 Field

Summary

Represents field FloatSingle1.

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 FloatSingle1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.Integer32bit1 Field

Summary

Represents field Integer32bit1.

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 Integer32bit1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.Integer64bit1 Field

Summary

Represents field Integer64bit1.

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 Integer64bit1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.Kind1 Field

Summary

Represents field Kind1.

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 Kind1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.N2 Field

Summary

Represents field N2.

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 N2: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.Panel7 Field

Summary

Represents field Panel7.

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 Panel7: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.PanelButtons Field

Summary

Represents field PanelButtons.

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 PanelButtons: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.PopupNode Field

Summary

Represents field PopupNode.

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 PopupNode: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.Rename1 Field

Summary

Represents field Rename1.

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 Rename1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


TDataItemEditor.Text1 Field

Summary

Represents field Text1.

Namespace: VCLBI.DataEditor
Syntax
Delphi
published
 Text1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataItemEditor
  • VCLBI.DataEditor


VCLBI.DataManager Namespace

Summary

Represents namespace VCLBI.DataManager.

Classes
Name | Description
TDataAcess | Represents type TDataAcess.
TDataDefinitionAccess | Represents type TDataDefinitionAccess.
TDataManager | Represents type TDataManager.
TDataManagerFilter | Represents type TDataManagerFilter.
TErrorHandler | Represents type TErrorHandler.
TMasterFilter | Represents type TMasterFilter.
Top
Enumerations
Name | Description
TDataManagerEmbedMode | Represents type TDataManagerEmbedMode.
Top
Constants
Name | Description
DummyNode | Represents constant DummyNode.
Top
Routines
Name | Description
FindRootNode(TTreeView,String) | Represents method FindRootNode(TTreeView,String).
Top


VCLBI.DataManager Classes

Classes
Name | Description
TDataAcess | Represents type TDataAcess.
TDataDefinitionAccess | Represents type TDataDefinitionAccess.
TDataManager | Represents type TDataManager.
TDataManagerFilter | Represents type TDataManagerFilter.
TErrorHandler | Represents type TErrorHandler.
TMasterFilter | Represents type TMasterFilter.
Top


TDataAcess Class

Summary

Represents type TDataAcess.

Namespace: VCLBI.DataManager
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
VCLBI.DataManager.TDataAcess
Syntax
Delphi
type
 TDataAcess=class(TDataItem);
See Also

Reference

  • VCLBI.DataManager


TDataDefinitionAccess Class

Summary

Represents type TDataDefinitionAccess.

Namespace: VCLBI.DataManager
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Persist.TBaseDataImporter
BI.Persist.TDataDefinition
VCLBI.DataManager.TDataDefinitionAccess
Syntax
Delphi
type
 TDataDefinitionAccess=class(TDataDefinition);
See Also

Reference

  • VCLBI.DataManager


TDataManager Class

Summary

Represents type TDataManager.

Namespace: VCLBI.DataManager
Inheritance Hierarchy
TForm
VCLBI.DataManager.TDataManager
Syntax
Delphi
type
 TDataManager = class(TForm)
 end;

The TDataManager type exposes the following members.

Properties
Show:
Name | Description
OnFilter | Represents property OnFilter.
OnSelect | Represents property OnSelect.
Top
Methods
Show:
Name | Description
AddNodeItems(TTreeNode) | Represents method AddNodeItems(TTreeNode).
BAddClick(TObject) | Represents method BAddClick(TObject).
BDeleteClick(TObject) | Represents method BDeleteClick(TObject).
BImportNowClick(TObject) | Represents method BImportNowClick(TObject).
BIWeb1Click(TObject) | Represents method BIWeb1Click(TObject).
BManageStoresClick(TObject) | Represents method BManageStoresClick(TObject).
BRenameClick(TObject) | Represents method BRenameClick(TObject).
BViewDataClick(TObject) | Represents method BViewDataClick(TObject).
CBParallelClick(TObject) | Represents method CBParallelClick(TObject).
CBStoresChange(TObject) | Represents method CBStoresChange(TObject).
Choose(TComponent,TDataItem,Boolean) | Represents method Choose(TComponent,TDataItem,Boolean).
CurrentStore | Represents method CurrentStore.
Custommanual1Click(TObject) | Represents method Custommanual1Click(TObject).
DatabaseServer1Click(TObject) | Represents method DatabaseServer1Click(TObject).
Edit(TComponent,String) | Represents method Edit(TComponent,String).
Embed(TComponent,TWinControl,TDataManagerEmbedMode,String,TDataItem) | Represents method Embed(TComponent,TWinControl,TDataManagerEmbedMode,String,TDataItem).
ESearchChange(TObject) | Represents method ESearchChange(TObject).
Files1Click(TObject) | Represents method Files1Click(TObject).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormResize(TObject) | Represents method FormResize(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
PanelSearchResize(TObject) | Represents method PanelSearchResize(TObject).
PanelStoresResize(TObject) | Represents method PanelStoresResize(TObject).
SelectData(TDataItem) | Represents method SelectData(TDataItem).
Selected | Represents method Selected.
SelectedData | Represents method SelectedData.
SelectedDefinition | Represents method SelectedDefinition.
TreeChange(TObject,TTreeNode) | Represents method TreeChange(TObject,TTreeNode).
TreeDblClick(TObject) | Represents method TreeDblClick(TObject).
TreeExpanding(TObject,TTreeNode,Boolean) | Represents method TreeExpanding(TObject,TTreeNode,Boolean).
ViewData1Click(TObject) | Represents method ViewData1Click(TObject).
Top
Fields
Show:
Name | Description
AddItems | Represents field AddItems.
BAdd | Represents field BAdd.
BCancel | Represents field BCancel.
BDelete | Represents field BDelete.
BImportNow | Represents field BImportNow.
BIWeb1 | Represents field BIWeb1.
BManageStores | Represents field BManageStores.
BOk | Represents field BOk.
BRename | Represents field BRename.
BViewData | Represents field BViewData.
CBParallel | Represents field CBParallel.
CBStoponerrors | Represents field CBStoponerrors.
CBStores | Represents field CBStores.
Custommanual1 | Represents field Custommanual1.
DatabaseServer1 | Represents field DatabaseServer1.
DataMenu | Represents field DataMenu.
ESearch | Represents field ESearch.
Files1 | Represents field Files1.
ImportProgress | Represents field ImportProgress.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
LLastImport | Represents field LLastImport.
LSearch | Represents field LSearch.
MemoDataInfo | Represents field MemoDataInfo.
MemoImportLog | Represents field MemoImportLog.
PageControl1 | Represents field PageControl1.
Panel1 | Represents field Panel1.
PanelButtons | Represents field PanelButtons.
PanelDataTop | Represents field PanelDataTop.
PanelManage | Represents field PanelManage.
PanelOk | Represents field PanelOk.
PanelSearch | Represents field PanelSearch.
PanelStores | Represents field PanelStores.
PopupMenu1 | Represents field PopupMenu1.
Splitter1 | Represents field Splitter1.
TabData | Represents field TabData.
TabLinks | Represents field TabLinks.
TabSettings | Represents field TabSettings.
Tree | Represents field Tree.
ViewData1 | Represents field ViewData1.
Top
See Also

Reference

  • VCLBI.DataManager


TDataManager Properties

Properties
Name | Description
OnFilter | Represents property OnFilter.
OnSelect | Represents property OnSelect.
Top


TDataManager.OnFilter Property

Summary

Represents property OnFilter.

Namespace: VCLBI.DataManager
Syntax
Delphi
public
 property OnFilter:TDataManagerFilter read IFilterTree write SetFilterTree;

Property Value

Type: TDataManagerFilter

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.OnSelect Property

Summary

Represents property OnSelect.

Namespace: VCLBI.DataManager
Syntax
Delphi
public
 property OnSelect:TNotifyEvent read FOnSelect write FOnSelect;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager Methods

Methods
Name | Description
AddNodeItems(TTreeNode) | Represents method AddNodeItems(TTreeNode).
BAddClick(TObject) | Represents method BAddClick(TObject).
BDeleteClick(TObject) | Represents method BDeleteClick(TObject).
BImportNowClick(TObject) | Represents method BImportNowClick(TObject).
BIWeb1Click(TObject) | Represents method BIWeb1Click(TObject).
BManageStoresClick(TObject) | Represents method BManageStoresClick(TObject).
BRenameClick(TObject) | Represents method BRenameClick(TObject).
BViewDataClick(TObject) | Represents method BViewDataClick(TObject).
CBParallelClick(TObject) | Represents method CBParallelClick(TObject).
CBStoresChange(TObject) | Represents method CBStoresChange(TObject).
Choose(TComponent,TDataItem,Boolean) | Represents method Choose(TComponent,TDataItem,Boolean).
CurrentStore | Represents method CurrentStore.
Custommanual1Click(TObject) | Represents method Custommanual1Click(TObject).
DatabaseServer1Click(TObject) | Represents method DatabaseServer1Click(TObject).
Edit(TComponent,String) | Represents method Edit(TComponent,String).
Embed(TComponent,TWinControl,TDataManagerEmbedMode,String,TDataItem) | Represents method Embed(TComponent,TWinControl,TDataManagerEmbedMode,String,TDataItem).
ESearchChange(TObject) | Represents method ESearchChange(TObject).
Files1Click(TObject) | Represents method Files1Click(TObject).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormResize(TObject) | Represents method FormResize(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
PanelSearchResize(TObject) | Represents method PanelSearchResize(TObject).
PanelStoresResize(TObject) | Represents method PanelStoresResize(TObject).
SelectData(TDataItem) | Represents method SelectData(TDataItem).
Selected | Represents method Selected.
SelectedData | Represents method SelectedData.
SelectedDefinition | Represents method SelectedDefinition.
TreeChange(TObject,TTreeNode) | Represents method TreeChange(TObject,TTreeNode).
TreeDblClick(TObject) | Represents method TreeDblClick(TObject).
TreeExpanding(TObject,TTreeNode,Boolean) | Represents method TreeExpanding(TObject,TTreeNode,Boolean).
ViewData1Click(TObject) | Represents method ViewData1Click(TObject).
Top


TDataManager.AddNodeItems(TTreeNode) Method

Summary

Represents method AddNodeItems(TTreeNode).

Namespace: VCLBI.DataManager
Syntax
Delphi
public
 procedure AddNodeItems(const Node:TTreeNode);

Parameters

Node
Type: TTreeNode

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.BAddClick(TObject) Method

Summary

Represents method BAddClick(TObject).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure BAddClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.BDeleteClick(TObject) Method

Summary

Represents method BDeleteClick(TObject).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure BDeleteClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.BImportNowClick(TObject) Method

Summary

Represents method BImportNowClick(TObject).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure BImportNowClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.BIWeb1Click(TObject) Method

Summary

Represents method BIWeb1Click(TObject).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure BIWeb1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.BManageStoresClick(TObject) Method

Summary

Represents method BManageStoresClick(TObject).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure BManageStoresClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.BRenameClick(TObject) Method

Summary

Represents method BRenameClick(TObject).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure BRenameClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.BViewDataClick(TObject) Method

Summary

Represents method BViewDataClick(TObject).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure BViewDataClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.CBParallelClick(TObject) Method

Summary

Represents method CBParallelClick(TObject).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure CBParallelClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.CBStoresChange(TObject) Method

Summary

Represents method CBStoresChange(TObject).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure CBStoresChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.Choose(TComponent,TDataItem,Boolean) Method

Summary

Represents method Choose(TComponent,TDataItem,Boolean).

Namespace: VCLBI.DataManager
Syntax
Delphi
public
 class function Choose(const AOwner:TComponent; const ACurrent:TDataItem=nil;
 const FillItems:Boolean=False):TDataItem; static;

Parameters

AOwner
Type: TComponent

ACurrent
Type: TDataItem

FillItems
Type: Boolean

Return Value

Type: TDataItem

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.CurrentStore Method

Summary

Represents method CurrentStore.

Namespace: VCLBI.DataManager
Syntax
Delphi
public
 function CurrentStore:String;

Return Value

Type: String

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.Custommanual1Click(TObject) Method

Summary

Represents method Custommanual1Click(TObject).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure Custommanual1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.DatabaseServer1Click(TObject) Method

Summary

Represents method DatabaseServer1Click(TObject).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure DatabaseServer1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.Edit(TComponent,String) Method

Summary

Represents method Edit(TComponent,String).

Namespace: VCLBI.DataManager
Syntax
Delphi
public
 class procedure Edit(const AOwner:TComponent; const AStore:String=''); static;

Parameters

AOwner
Type: TComponent

AStore
Type: String

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.Embed(TComponent,TWinControl,TDataManagerEmbedMode,String,TDataItem) Method

Summary

Represents method Embed(TComponent,TWinControl,TDataManagerEmbedMode,String,TDataItem).

Namespace: VCLBI.DataManager
Syntax
Delphi
public
 class function Embed(const AOwner:TComponent;
 const AParent:TWinControl;
 const AMode:TDataManagerEmbedMode=TDataManagerEmbedMode.Choose;
 const AStore:String='';
 const ACurrent:TDataItem=nil):TDataManager; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AMode
Type: TDataManagerEmbedMode

AStore
Type: String

ACurrent
Type: TDataItem

Return Value

Type: TDataManager

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.ESearchChange(TObject) Method

Summary

Represents method ESearchChange(TObject).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure ESearchChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.Files1Click(TObject) Method

Summary

Represents method Files1Click(TObject).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure Files1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.FormClose(TObject,TCloseAction) Method

Summary

Represents method FormClose(TObject,TCloseAction).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure FormClose(Sender: TObject; var Action: TCloseAction);

Parameters

Sender
Type: TObject

Action
Type: TCloseAction

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.FormResize(TObject) Method

Summary

Represents method FormResize(TObject).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure FormResize(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.PageControl1Change(TObject) Method

Summary

Represents method PageControl1Change(TObject).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure PageControl1Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.PanelSearchResize(TObject) Method

Summary

Represents method PanelSearchResize(TObject).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure PanelSearchResize(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.PanelStoresResize(TObject) Method

Summary

Represents method PanelStoresResize(TObject).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure PanelStoresResize(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.SelectData(TDataItem) Method

Summary

Represents method SelectData(TDataItem).

Namespace: VCLBI.DataManager
Syntax
Delphi
public
 procedure SelectData(const AData:TDataItem);

Parameters

AData
Type: TDataItem

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.Selected Method

Summary

Represents method Selected.

Namespace: VCLBI.DataManager
Syntax
Delphi
public
 function Selected: TDataItem;

Return Value

Type: TDataItem

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.SelectedData Method

Summary

Represents method SelectedData.

Namespace: VCLBI.DataManager
Syntax
Delphi
public
 function SelectedData:TDataItem;

Return Value

Type: TDataItem

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.SelectedDefinition Method

Summary

Represents method SelectedDefinition.

Namespace: VCLBI.DataManager
Syntax
Delphi
public
 function SelectedDefinition:TDataDefinition;

Return Value

Type: TDataDefinition

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.TreeChange(TObject,TTreeNode) Method

Summary

Represents method TreeChange(TObject,TTreeNode).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure TreeChange(Sender: TObject; Node: TTreeNode);

Parameters

Sender
Type: TObject

Node
Type: TTreeNode

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.TreeDblClick(TObject) Method

Summary

Represents method TreeDblClick(TObject).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure TreeDblClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.TreeExpanding(TObject,TTreeNode,Boolean) Method

Summary

Represents method TreeExpanding(TObject,TTreeNode,Boolean).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure TreeExpanding(Sender: TObject; Node: TTreeNode;
 var AllowExpansion: Boolean);

Parameters

Sender
Type: TObject

Node
Type: TTreeNode

AllowExpansion
Type: Boolean

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.ViewData1Click(TObject) Method

Summary

Represents method ViewData1Click(TObject).

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 procedure ViewData1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager Fields

Fields
Name | Description
AddItems | Represents field AddItems.
BAdd | Represents field BAdd.
BCancel | Represents field BCancel.
BDelete | Represents field BDelete.
BImportNow | Represents field BImportNow.
BIWeb1 | Represents field BIWeb1.
BManageStores | Represents field BManageStores.
BOk | Represents field BOk.
BRename | Represents field BRename.
BViewData | Represents field BViewData.
CBParallel | Represents field CBParallel.
CBStoponerrors | Represents field CBStoponerrors.
CBStores | Represents field CBStores.
Custommanual1 | Represents field Custommanual1.
DatabaseServer1 | Represents field DatabaseServer1.
DataMenu | Represents field DataMenu.
ESearch | Represents field ESearch.
Files1 | Represents field Files1.
ImportProgress | Represents field ImportProgress.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
LLastImport | Represents field LLastImport.
LSearch | Represents field LSearch.
MemoDataInfo | Represents field MemoDataInfo.
MemoImportLog | Represents field MemoImportLog.
PageControl1 | Represents field PageControl1.
Panel1 | Represents field Panel1.
PanelButtons | Represents field PanelButtons.
PanelDataTop | Represents field PanelDataTop.
PanelManage | Represents field PanelManage.
PanelOk | Represents field PanelOk.
PanelSearch | Represents field PanelSearch.
PanelStores | Represents field PanelStores.
PopupMenu1 | Represents field PopupMenu1.
Splitter1 | Represents field Splitter1.
TabData | Represents field TabData.
TabLinks | Represents field TabLinks.
TabSettings | Represents field TabSettings.
Tree | Represents field Tree.
ViewData1 | Represents field ViewData1.
Top


TDataManager.AddItems Field

Summary

Represents field AddItems.

Namespace: VCLBI.DataManager
Syntax
Delphi
public
 AddItems : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.BAdd Field

Summary

Represents field BAdd.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 BAdd: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.BCancel Field

Summary

Represents field BCancel.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 BCancel: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.BDelete Field

Summary

Represents field BDelete.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 BDelete: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.BImportNow Field

Summary

Represents field BImportNow.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 BImportNow: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.BIWeb1 Field

Summary

Represents field BIWeb1.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 BIWeb1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.BManageStores Field

Summary

Represents field BManageStores.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 BManageStores: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.BOk Field

Summary

Represents field BOk.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 BOk: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.BRename Field

Summary

Represents field BRename.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 BRename: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.BViewData Field

Summary

Represents field BViewData.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 BViewData: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.CBParallel Field

Summary

Represents field CBParallel.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 CBParallel: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.CBStoponerrors Field

Summary

Represents field CBStoponerrors.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 CBStoponerrors: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.CBStores Field

Summary

Represents field CBStores.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 CBStores: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.Custommanual1 Field

Summary

Represents field Custommanual1.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 Custommanual1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.DatabaseServer1 Field

Summary

Represents field DatabaseServer1.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 DatabaseServer1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.DataMenu Field

Summary

Represents field DataMenu.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 DataMenu: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.ESearch Field

Summary

Represents field ESearch.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 ESearch: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.Files1 Field

Summary

Represents field Files1.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 Files1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.ImportProgress Field

Summary

Represents field ImportProgress.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 ImportProgress: TProgressBar;

Field Value

Type: TProgressBar

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.Label2 Field

Summary

Represents field Label2.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.LLastImport Field

Summary

Represents field LLastImport.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 LLastImport: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.LSearch Field

Summary

Represents field LSearch.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 LSearch: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.MemoDataInfo Field

Summary

Represents field MemoDataInfo.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 MemoDataInfo: TMemo;

Field Value

Type: TMemo

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.MemoImportLog Field

Summary

Represents field MemoImportLog.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 MemoImportLog: TMemo;

Field Value

Type: TMemo

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.PageControl1 Field

Summary

Represents field PageControl1.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 PageControl1: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.PanelButtons Field

Summary

Represents field PanelButtons.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 PanelButtons: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.PanelDataTop Field

Summary

Represents field PanelDataTop.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 PanelDataTop: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.PanelManage Field

Summary

Represents field PanelManage.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 PanelManage: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.PanelOk Field

Summary

Represents field PanelOk.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 PanelOk: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.PanelSearch Field

Summary

Represents field PanelSearch.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 PanelSearch: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.PanelStores Field

Summary

Represents field PanelStores.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 PanelStores: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.PopupMenu1 Field

Summary

Represents field PopupMenu1.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 PopupMenu1: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.Splitter1 Field

Summary

Represents field Splitter1.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 Splitter1: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.TabData Field

Summary

Represents field TabData.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 TabData: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.TabLinks Field

Summary

Represents field TabLinks.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 TabLinks: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.TabSettings Field

Summary

Represents field TabSettings.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 TabSettings: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.Tree Field

Summary

Represents field Tree.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 Tree: TTreeView;

Field Value

Type: TTreeView

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManager.ViewData1 Field

Summary

Represents field ViewData1.

Namespace: VCLBI.DataManager
Syntax
Delphi
published
 ViewData1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataManager
  • VCLBI.DataManager


TDataManagerFilter Class

Summary

Represents type TDataManagerFilter.

Namespace: VCLBI.DataManager
Inheritance Hierarchy
TObject
VCLBI.DataManager.TDataManagerFilter
VCLBI.DataManager.TMasterFilter
Syntax
Delphi
type
 TDataManagerFilter=class abstract
 end;

The TDataManagerFilter type exposes the following members.

Methods
Show:
Name | Description
Clear | Represents method Clear.
Valid(String) | Overloaded. Represents method Valid(String).
Valid(TDataItem) | Overloaded. Represents method Valid(TDataItem).
Top
See Also

Reference

  • VCLBI.DataManager


TDataManagerFilter Methods

Methods
Name | Description
Clear | Represents method Clear.
Valid(String) | Overloaded. Represents method Valid(String).
Valid(TDataItem) | Overloaded. Represents method Valid(TDataItem).
Top


TDataManagerFilter.Clear Method

Summary

Represents method Clear.

Namespace: VCLBI.DataManager
Syntax
Delphi
public
 procedure Clear; virtual; abstract;
See Also

Reference

  • TDataManagerFilter
  • VCLBI.DataManager


TDataManagerFilter.Valid(String) Method

Summary

Represents method Valid(String).

Namespace: VCLBI.DataManager
Syntax
Delphi
public
 function Valid(const AName:String):Boolean; overload; virtual; abstract;

Parameters

AName
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TDataManagerFilter
  • VCLBI.DataManager


TDataManagerFilter.Valid(TDataItem) Method

Summary

Represents method Valid(TDataItem).

Namespace: VCLBI.DataManager
Syntax
Delphi
public
 function Valid(const AData:TDataItem):Boolean; overload; virtual; abstract;

Parameters

AData
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • TDataManagerFilter
  • VCLBI.DataManager


TErrorHandler Class

Summary

Represents type TErrorHandler.

Namespace: VCLBI.DataManager
Inheritance Hierarchy
TObject
VCLBI.DataManager.TErrorHandler
Syntax
Delphi
type
 TErrorHandler=class
 end;
See Also

Reference

  • VCLBI.DataManager


TMasterFilter Class

Summary

Represents type TMasterFilter.

Namespace: VCLBI.DataManager
Inheritance Hierarchy
TObject
VCLBI.DataManager.TDataManagerFilter
VCLBI.DataManager.TMasterFilter
Syntax
Delphi
type
 TMasterFilter=class(TDataManagerFilter)
 end;

The TMasterFilter type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TMasterFilter class.
Destroy | Represents the destructor of the TMasterFilter class.
Top
Methods
Show:
Name | Description
Add(TDataItem) | Represents method Add(TDataItem).
Clear | Represents method Clear. (Overrides TDataManagerFilter.Clear.)
Valid(String) | Represents method Valid(String). (Overrides TDataManagerFilter.Valid(String).)
Valid(TDataItem) | Represents method Valid(TDataItem). (Overrides TDataManagerFilter.Valid(TDataItem).)
Top
See Also

Reference

  • VCLBI.DataManager


TMasterFilter Constructors

Constructors
Name | Description
Create | Initializes a new instance of the TMasterFilter class.
Destroy | Represents the destructor of the TMasterFilter class.
Top


TMasterFilter.Create Constructor

Summary

Initializes a new instance of the TMasterFilter class.

Namespace: VCLBI.DataManager
Syntax
Delphi
public
 Constructor Create;
See Also

Reference

  • TMasterFilter
  • VCLBI.DataManager


TMasterFilter.Destroy Destructor

Summary

Represents the destructor of the TMasterFilter class.

Namespace: VCLBI.DataManager
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TMasterFilter
  • VCLBI.DataManager


TMasterFilter Methods

Methods
Name | Description
Add(TDataItem) | Represents method Add(TDataItem).
Clear | Represents method Clear. (Overrides TDataManagerFilter.Clear.)
Valid(String) | Represents method Valid(String). (Overrides TDataManagerFilter.Valid(String).)
Valid(TDataItem) | Represents method Valid(TDataItem). (Overrides TDataManagerFilter.Valid(TDataItem).)
Top


TMasterFilter.Add(TDataItem) Method

Summary

Represents method Add(TDataItem).

Namespace: VCLBI.DataManager
Syntax
Delphi
public
 procedure Add(const AData:TDataItem);

Parameters

AData
Type: TDataItem

See Also

Reference

  • TMasterFilter
  • VCLBI.DataManager


TMasterFilter.Clear Method

Summary

Represents method Clear.

Namespace: VCLBI.DataManager
Syntax
Delphi
public
 procedure Clear; override;

Overrides

TDataManagerFilter.Clear
See Also

Reference

  • TMasterFilter
  • VCLBI.DataManager


TMasterFilter.Valid(TDataItem) Method

Summary

Represents method Valid(TDataItem).

Namespace: VCLBI.DataManager
Syntax
Delphi
public
 function Valid(const AData:TDataItem):Boolean; override;

Parameters

AData
Type: TDataItem

Return Value

Type: Boolean

Overrides

TDataManagerFilter.Valid(TDataItem)
See Also

Reference

  • TMasterFilter
  • VCLBI.DataManager


VCLBI.DataManager Enumerations

Enumerations
Name | Description
TDataManagerEmbedMode | Represents type TDataManagerEmbedMode.
Top


TDataManagerEmbedMode Enumeration

Summary

Represents type TDataManagerEmbedMode.

Namespace: VCLBI.DataManager
Syntax
Delphi
type
 TDataManagerEmbedMode=(Choose,Edit);

The TDataManagerEmbedMode type exposes the following members.

Members
Show:
Name | Description
Choose | Represents constant Choose.
Edit | Represents constant Edit.
Top
See Also

Reference

  • VCLBI.DataManager


VCLBI.DataManager Constants

Constants
Name | Description
DummyNode | Represents constant DummyNode.
Top


DummyNode Constant

Summary

Represents constant DummyNode.

Namespace: VCLBI.DataManager
Syntax
Delphi
 DummyNode='**********************';

Value

Type: string

See Also

Reference

  • VCLBI.DataManager


VCLBI.DataManager Routines

Routines
Name | Description
FindRootNode(TTreeView,String) | Represents method FindRootNode(TTreeView,String).
Top


FindRootNode(TTreeView,String) Method

Summary

Represents method FindRootNode(TTreeView,String).

Namespace: VCLBI.DataManager
Syntax
Delphi
function FindRootNode(const ATree:TTreeView; const AText:String):TTreeNode;

Parameters

ATree
Type: TTreeView

AText
Type: String

Return Value

Type: TTreeNode

See Also

Reference

  • VCLBI.DataManager


VCLBI.DataSelect Namespace

Summary

Represents namespace VCLBI.DataSelect.

Classes
Name | Description
TDataAccess | Represents type TDataAccess.
TDataComponentAccess | Represents type TDataComponentAccess.
TDataSelector | Represents type TDataSelector.
Top


VCLBI.DataSelect Classes

Classes
Name | Description
TDataAccess | Represents type TDataAccess.
TDataComponentAccess | Represents type TDataComponentAccess.
TDataSelector | Represents type TDataSelector.
Top


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: VCLBI.DataSelect
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
VCLBI.DataSelect.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • VCLBI.DataSelect


TDataComponentAccess Class

Summary

Represents type TDataComponentAccess.

Namespace: VCLBI.DataSelect
Inheritance Hierarchy
TForm
VCLBI.Editor.DataComponent.TDataComponent
VCLBI.DataSelect.TDataComponentAccess
Syntax
Delphi
type
 TDataComponentAccess=class(TDataComponent);
See Also

Reference

  • VCLBI.DataSelect


TDataSelector Class

Summary

Represents type TDataSelector.

Namespace: VCLBI.DataSelect
Inheritance Hierarchy
TForm
VCLBI.DataSelect.TDataSelector
VCLBI.Editor.Query.TDataSelectorAccess
VCLBI.Editor.Workflow.TDataSelectorAccess
Syntax
Delphi
type
 TDataSelector = class(TForm)
 end;

The TDataSelector type exposes the following members.

Properties
Show:
Name | Description
ComponentSelector | Represents property ComponentSelector.
Manager | Represents property Manager.
OnSelect | Represents property OnSelect.
Top
Methods
Show:
Name | Description
BClearClick(TObject) | Represents method BClearClick(TObject).
BNewClick(TObject) | Represents method BNewClick(TObject).
Choose(TComponent,TBIDataControl) | Overloaded. Represents method Choose(TComponent,TBIDataControl).
Choose(TComponent,TComponent) | Overloaded. Represents method Choose(TComponent,TComponent).
Choose(TComponent,TComponent,TDataItem,TComponent) | Overloaded. Represents method Choose(TComponent,TComponent,TDataItem,TComponent).
CustomData1Click(TObject) | Represents method CustomData1Click(TObject).
Database1Click(TObject) | Represents method Database1Click(TObject).
Embedd(TComponent,TWinControl,TComponent) | Represents method Embedd(TComponent,TWinControl,TComponent).
Files1Click(TObject) | Represents method Files1Click(TObject).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
Query1Click(TObject) | Represents method Query1Click(TObject).
RefreshTree(TDataManagerFilter) | Represents method RefreshTree(TDataManagerFilter).
Select(TDataItem) | Represents method Select(TDataItem).
Selected | Represents method Selected.
SetEdited(TComponent) | Represents method SetEdited(TComponent).
Web1Click(TObject) | Represents method Web1Click(TObject).
Top
Fields
Show:
Name | Description
BCancel | Represents field BCancel.
BClear | Represents field BClear.
BNew | Represents field BNew.
BOK | Represents field BOK.
CustomData1 | Represents field CustomData1.
Database1 | Represents field Database1.
Files1 | Represents field Files1.
Import1 | Represents field Import1.
ImportMenu | Represents field ImportMenu.
PageControl1 | Represents field PageControl1.
Panel1 | Represents field Panel1.
PanelAlignButtons | Represents field PanelAlignButtons.
PanelButtons | Represents field PanelButtons.
Query1 | Represents field Query1.
TabComponent | Represents field TabComponent.
TabStore | Represents field TabStore.
Web1 | Represents field Web1.
Top
See Also

Reference

  • VCLBI.DataSelect


TDataSelector Properties

Properties
Name | Description
ComponentSelector | Represents property ComponentSelector.
Manager | Represents property Manager.
OnSelect | Represents property OnSelect.
Top


TDataSelector.ComponentSelector Property

Summary

Represents property ComponentSelector.

Namespace: VCLBI.DataSelect
Syntax
Delphi
public
 property ComponentSelector:TDataComponent read IComp;

Property Value

Type: TDataComponent

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.Manager Property

Summary

Represents property Manager.

Namespace: VCLBI.DataSelect
Syntax
Delphi
public
 property Manager:TDataManager read IManager;

Property Value

Type: TDataManager

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.OnSelect Property

Summary

Represents property OnSelect.

Namespace: VCLBI.DataSelect
Syntax
Delphi
public
 property OnSelect:TNotifyEvent read FOnSelect write FOnSelect;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector Methods

Methods
Name | Description
BClearClick(TObject) | Represents method BClearClick(TObject).
BNewClick(TObject) | Represents method BNewClick(TObject).
Choose(TComponent,TBIDataControl) | Overloaded. Represents method Choose(TComponent,TBIDataControl).
Choose(TComponent,TComponent) | Overloaded. Represents method Choose(TComponent,TComponent).
Choose(TComponent,TComponent,TDataItem,TComponent) | Overloaded. Represents method Choose(TComponent,TComponent,TDataItem,TComponent).
CustomData1Click(TObject) | Represents method CustomData1Click(TObject).
Database1Click(TObject) | Represents method Database1Click(TObject).
Embedd(TComponent,TWinControl,TComponent) | Represents method Embedd(TComponent,TWinControl,TComponent).
Files1Click(TObject) | Represents method Files1Click(TObject).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
Query1Click(TObject) | Represents method Query1Click(TObject).
RefreshTree(TDataManagerFilter) | Represents method RefreshTree(TDataManagerFilter).
Select(TDataItem) | Represents method Select(TDataItem).
Selected | Represents method Selected.
SetEdited(TComponent) | Represents method SetEdited(TComponent).
Web1Click(TObject) | Represents method Web1Click(TObject).
Top


TDataSelector.BClearClick(TObject) Method

Summary

Represents method BClearClick(TObject).

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 procedure BClearClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.BNewClick(TObject) Method

Summary

Represents method BNewClick(TObject).

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 procedure BNewClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.Choose(TComponent,TBIDataControl) Method

Summary

Represents method Choose(TComponent,TBIDataControl).

Namespace: VCLBI.DataSelect
Syntax
Delphi
public
 class procedure Choose(const AOwner:TComponent;
 const AEdited:TBIDataControl); overload; static;

Parameters

AOwner
Type: TComponent

AEdited
Type: TBIDataControl

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.Choose(TComponent,TComponent) Method

Summary

Represents method Choose(TComponent,TComponent).

Namespace: VCLBI.DataSelect
Syntax
Delphi
public
 class function Choose(const AOwner:TComponent;
 const AEdited:TComponent):TDataItem; overload; static;

Parameters

AOwner
Type: TComponent

AEdited
Type: TComponent

Return Value

Type: TDataItem

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.Choose(TComponent,TComponent,TDataItem,TComponent) Method

Summary

Represents method Choose(TComponent,TComponent,TDataItem,TComponent).

Namespace: VCLBI.DataSelect
Syntax
Delphi
public
 class function Choose(const AOwner:TComponent;
 const AEdited:TComponent;
 var AData:TDataItem;
 const AFilterOwner:TComponent=nil):Boolean; overload; static;

Parameters

AOwner
Type: TComponent

AEdited
Type: TComponent

AData
Type: TDataItem

AFilterOwner
Type: TComponent

Return Value

Type: Boolean

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.CustomData1Click(TObject) Method

Summary

Represents method CustomData1Click(TObject).

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 procedure CustomData1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.Database1Click(TObject) Method

Summary

Represents method Database1Click(TObject).

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 procedure Database1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.Embedd(TComponent,TWinControl,TComponent) Method

Summary

Represents method Embedd(TComponent,TWinControl,TComponent).

Namespace: VCLBI.DataSelect
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent;
 const AParent:TWinControl;
 const AEdited: TComponent):TDataSelector; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AEdited
Type: TComponent

Return Value

Type: TDataSelector

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.Files1Click(TObject) Method

Summary

Represents method Files1Click(TObject).

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 procedure Files1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.FormClose(TObject,TCloseAction) Method

Summary

Represents method FormClose(TObject,TCloseAction).

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 procedure FormClose(Sender: TObject; var Action: TCloseAction);

Parameters

Sender
Type: TObject

Action
Type: TCloseAction

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.PageControl1Change(TObject) Method

Summary

Represents method PageControl1Change(TObject).

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 procedure PageControl1Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.Query1Click(TObject) Method

Summary

Represents method Query1Click(TObject).

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 procedure Query1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.RefreshTree(TDataManagerFilter) Method

Summary

Represents method RefreshTree(TDataManagerFilter).

Namespace: VCLBI.DataSelect
Syntax
Delphi
public
 procedure RefreshTree(const AFilter:TDataManagerFilter);

Parameters

AFilter
Type: TDataManagerFilter

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.Select(TDataItem) Method

Summary

Represents method Select(TDataItem).

Namespace: VCLBI.DataSelect
Syntax
Delphi
public
 procedure Select(const AData:TDataItem);

Parameters

AData
Type: TDataItem

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.Selected Method

Summary

Represents method Selected.

Namespace: VCLBI.DataSelect
Syntax
Delphi
public
 function Selected:TDataItem;

Return Value

Type: TDataItem

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.SetEdited(TComponent) Method

Summary

Represents method SetEdited(TComponent).

Namespace: VCLBI.DataSelect
Syntax
Delphi
protected
 procedure SetEdited(const AEdited:TComponent);

Parameters

AEdited
Type: TComponent

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.Web1Click(TObject) Method

Summary

Represents method Web1Click(TObject).

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 procedure Web1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector Fields

Fields
Name | Description
BCancel | Represents field BCancel.
BClear | Represents field BClear.
BNew | Represents field BNew.
BOK | Represents field BOK.
CustomData1 | Represents field CustomData1.
Database1 | Represents field Database1.
Files1 | Represents field Files1.
Import1 | Represents field Import1.
ImportMenu | Represents field ImportMenu.
PageControl1 | Represents field PageControl1.
Panel1 | Represents field Panel1.
PanelAlignButtons | Represents field PanelAlignButtons.
PanelButtons | Represents field PanelButtons.
Query1 | Represents field Query1.
TabComponent | Represents field TabComponent.
TabStore | Represents field TabStore.
Web1 | Represents field Web1.
Top


TDataSelector.BCancel Field

Summary

Represents field BCancel.

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 BCancel: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.BClear Field

Summary

Represents field BClear.

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 BClear: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.BNew Field

Summary

Represents field BNew.

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 BNew: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.BOK Field

Summary

Represents field BOK.

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 BOK: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.CustomData1 Field

Summary

Represents field CustomData1.

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 CustomData1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.Database1 Field

Summary

Represents field Database1.

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 Database1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.Files1 Field

Summary

Represents field Files1.

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 Files1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.Import1 Field

Summary

Represents field Import1.

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 Import1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.ImportMenu Field

Summary

Represents field ImportMenu.

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 ImportMenu: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.PageControl1 Field

Summary

Represents field PageControl1.

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 PageControl1: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.PanelAlignButtons Field

Summary

Represents field PanelAlignButtons.

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 PanelAlignButtons: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.PanelButtons Field

Summary

Represents field PanelButtons.

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 PanelButtons: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.Query1 Field

Summary

Represents field Query1.

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 Query1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.TabComponent Field

Summary

Represents field TabComponent.

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 TabComponent: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.TabStore Field

Summary

Represents field TabStore.

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 TabStore: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


TDataSelector.Web1 Field

Summary

Represents field Web1.

Namespace: VCLBI.DataSelect
Syntax
Delphi
published
 Web1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataSelector
  • VCLBI.DataSelect


VCLBI.DataTree Namespace

Summary

Represents namespace VCLBI.DataTree.

Classes
Name | Description
TDataTree | Represents type TDataTree.
TDataTree.TNodeGetText<T> | Represents type TNodeGetText<T>.
Top


VCLBI.DataTree Classes

Classes
Name | Description
TDataTree | Represents type TDataTree.
TDataTree.TNodeGetText<T> | Represents type TNodeGetText<T>.
Top


TDataTree Class

Summary

Represents type TDataTree.

Namespace: VCLBI.DataTree
Inheritance Hierarchy
TObject
VCLBI.DataTree.TDataTree
Syntax
Delphi
type
 TDataTree=class
See Also

Reference

  • VCLBI.DataTree


TDataTree.TNodeGetText<T> Class

Summary

Represents type TNodeGetText<T>.

Namespace: VCLBI.DataTree
Inheritance Hierarchy
TObject
VCLBI.DataTree.TDataTree.TNodeGetText<T>
Syntax
Delphi
public
type
 TNodeGetText<T

Type Parameters

T
See Also

Reference

  • TDataTree
  • VCLBI.DataTree


VCLBI.DataViewer Namespace

Summary

Represents namespace VCLBI.DataViewer.

Classes
Name | Description
TDataAccess | Represents type TDataAccess.
TDataViewer | Represents type TDataViewer.
Top
Routines
Name | Description
CheckName(String) | Represents method CheckName(String).
Roots(TTreeView) | Represents method Roots(TTreeView).
Top


VCLBI.DataViewer Classes

Classes
Name | Description
TDataAccess | Represents type TDataAccess.
TDataViewer | Represents type TDataViewer.
Top


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: VCLBI.DataViewer
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
VCLBI.DataViewer.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • VCLBI.DataViewer


TDataViewer Class

Summary

Represents type TDataViewer.

Namespace: VCLBI.DataViewer
Inheritance Hierarchy
TForm
VCLBI.DataViewer.TDataViewer
TeeBIDebugFrame.TDataViewerAccess
VCLBI.DataEditor.TDataItemEditor
Syntax
Delphi
type
 TDataViewer = class(TForm)
 end;

The TDataViewer type exposes the following members.

Methods
Show:
Name | Description
BDiagramClick(TObject) | Represents method BDiagramClick(TObject).
Button2Click(TObject) | Represents method Button2Click(TObject).
CBRecordClick(TObject) | Represents method CBRecordClick(TObject).
CBViewChange(TObject) | Represents method CBViewChange(TObject).
CBViewDataClick(TObject) | Represents method CBViewDataClick(TObject).
DataGridDataChange(TObject) | Represents method DataGridDataChange(TObject).
Embedd(TComponent,TWinControl,TDataItem) | Represents method Embedd(TComponent,TWinControl,TDataItem).
FillData(TDataItem) | Represents method FillData(TDataItem).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
ItemsAfterInsert(TDataSet) | Represents method ItemsAfterInsert(TDataSet).
RefreshLabelName | Represents method RefreshLabelName.
Select(TDataItem) | Represents method Select(TDataItem).
Selected | Represents method Selected.
SelectedChange(TObject) | Represents method SelectedChange(TObject).
TryAddInfoEditors(TObject) | Represents method TryAddInfoEditors(TObject).
View(TComponent,TDataItem) | Represents method View(TComponent,TDataItem).
View1Click(TObject) | Represents method View1Click(TObject).
Top
Fields
Show:
Name | Description
BDiagram | Represents field BDiagram.
Button2 | Represents field Button2.
CBRecord | Represents field CBRecord.
CBView | Represents field CBView.
CBViewData | Represents field CBViewData.
DataGrid | Represents field DataGrid.
DataSource2 | Represents field DataSource2.
DataTotals | Represents field DataTotals.
DBNavigator1 | Represents field DBNavigator1.
DBNavigator2 | Represents field DBNavigator2.
FData | Represents field FData.
Items | Represents field Items.
ItemsGrid | Represents field ItemsGrid.
Label1 | Represents field Label1.
LName | Represents field LName.
LRow | Represents field LRow.
N1 | Represents field N1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
Panel5 | Represents field Panel5.
PanelData | Represents field PanelData.
PanelDataGrid | Represents field PanelDataGrid.
PanelDatas | Represents field PanelDatas.
PanelItems | Represents field PanelItems.
PanelItemsGrid | Represents field PanelItemsGrid.
PanelNav | Represents field PanelNav.
PanelTop | Represents field PanelTop.
PopupMenu1 | Represents field PopupMenu1.
RecordView | Represents field RecordView.
Splitter1 | Represents field Splitter1.
SplitterData | Represents field SplitterData.
SplitterRecord | Represents field SplitterRecord.
Tree | Represents field Tree.
View1 | Represents field View1.
Top
See Also

Reference

  • VCLBI.DataViewer


TDataViewer Methods

Methods
Name | Description
BDiagramClick(TObject) | Represents method BDiagramClick(TObject).
Button2Click(TObject) | Represents method Button2Click(TObject).
CBRecordClick(TObject) | Represents method CBRecordClick(TObject).
CBViewChange(TObject) | Represents method CBViewChange(TObject).
CBViewDataClick(TObject) | Represents method CBViewDataClick(TObject).
DataGridDataChange(TObject) | Represents method DataGridDataChange(TObject).
Embedd(TComponent,TWinControl,TDataItem) | Represents method Embedd(TComponent,TWinControl,TDataItem).
FillData(TDataItem) | Represents method FillData(TDataItem).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
ItemsAfterInsert(TDataSet) | Represents method ItemsAfterInsert(TDataSet).
RefreshLabelName | Represents method RefreshLabelName.
Select(TDataItem) | Represents method Select(TDataItem).
Selected | Represents method Selected.
SelectedChange(TObject) | Represents method SelectedChange(TObject).
TryAddInfoEditors(TObject) | Represents method TryAddInfoEditors(TObject).
View(TComponent,TDataItem) | Represents method View(TComponent,TDataItem).
View1Click(TObject) | Represents method View1Click(TObject).
Top


TDataViewer.BDiagramClick(TObject) Method

Summary

Represents method BDiagramClick(TObject).

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 procedure BDiagramClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.Button2Click(TObject) Method

Summary

Represents method Button2Click(TObject).

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 procedure Button2Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.CBRecordClick(TObject) Method

Summary

Represents method CBRecordClick(TObject).

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 procedure CBRecordClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.CBViewChange(TObject) Method

Summary

Represents method CBViewChange(TObject).

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 procedure CBViewChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.CBViewDataClick(TObject) Method

Summary

Represents method CBViewDataClick(TObject).

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 procedure CBViewDataClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.DataGridDataChange(TObject) Method

Summary

Represents method DataGridDataChange(TObject).

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 procedure DataGridDataChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.Embedd(TComponent,TWinControl,TDataItem) Method

Summary

Represents method Embedd(TComponent,TWinControl,TDataItem).

Namespace: VCLBI.DataViewer
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl; const AData:TDataItem):TDataViewer; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AData
Type: TDataItem

Return Value

Type: TDataViewer

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.FillData(TDataItem) Method

Summary

Represents method FillData(TDataItem).

Namespace: VCLBI.DataViewer
Syntax
Delphi
protected
 procedure FillData(const AData:TDataItem);

Parameters

AData
Type: TDataItem

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.FormClose(TObject,TCloseAction) Method

Summary

Represents method FormClose(TObject,TCloseAction).

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 procedure FormClose(Sender: TObject; var Action: TCloseAction);

Parameters

Sender
Type: TObject

Action
Type: TCloseAction

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.FormDestroy(TObject) Method

Summary

Represents method FormDestroy(TObject).

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 procedure FormDestroy(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.ItemsAfterInsert(TDataSet) Method

Summary

Represents method ItemsAfterInsert(TDataSet).

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 procedure ItemsAfterInsert(DataSet: TDataSet);

Parameters

DataSet
Type: TDataSet

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.RefreshLabelName Method

Summary

Represents method RefreshLabelName.

Namespace: VCLBI.DataViewer
Syntax
Delphi
protected
 procedure RefreshLabelName;
See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.Select(TDataItem) Method

Summary

Represents method Select(TDataItem).

Namespace: VCLBI.DataViewer
Syntax
Delphi
public
 procedure Select(const AData:TDataItem);

Parameters

AData
Type: TDataItem

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.Selected Method

Summary

Represents method Selected.

Namespace: VCLBI.DataViewer
Syntax
Delphi
protected
 function Selected:TDataItem;

Return Value

Type: TDataItem

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.SelectedChange(TObject) Method

Summary

Represents method SelectedChange(TObject).

Namespace: VCLBI.DataViewer
Syntax
Delphi
protected
 procedure SelectedChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.TryAddInfoEditors(TObject) Method

Summary

Represents method TryAddInfoEditors(TObject).

Namespace: VCLBI.DataViewer
Syntax
Delphi
protected
 procedure TryAddInfoEditors(const AGrid:TObject); virtual;

Parameters

AGrid
Type: TObject

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.View(TComponent,TDataItem) Method

Summary

Represents method View(TComponent,TDataItem).

Namespace: VCLBI.DataViewer
Syntax
Delphi
public
 class procedure View(const AOwner:TComponent; const AData:TDataItem); static;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.View1Click(TObject) Method

Summary

Represents method View1Click(TObject).

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 procedure View1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer Fields

Fields
Name | Description
BDiagram | Represents field BDiagram.
Button2 | Represents field Button2.
CBRecord | Represents field CBRecord.
CBView | Represents field CBView.
CBViewData | Represents field CBViewData.
DataGrid | Represents field DataGrid.
DataSource2 | Represents field DataSource2.
DataTotals | Represents field DataTotals.
DBNavigator1 | Represents field DBNavigator1.
DBNavigator2 | Represents field DBNavigator2.
FData | Represents field FData.
Items | Represents field Items.
ItemsGrid | Represents field ItemsGrid.
Label1 | Represents field Label1.
LName | Represents field LName.
LRow | Represents field LRow.
N1 | Represents field N1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
Panel5 | Represents field Panel5.
PanelData | Represents field PanelData.
PanelDataGrid | Represents field PanelDataGrid.
PanelDatas | Represents field PanelDatas.
PanelItems | Represents field PanelItems.
PanelItemsGrid | Represents field PanelItemsGrid.
PanelNav | Represents field PanelNav.
PanelTop | Represents field PanelTop.
PopupMenu1 | Represents field PopupMenu1.
RecordView | Represents field RecordView.
Splitter1 | Represents field Splitter1.
SplitterData | Represents field SplitterData.
SplitterRecord | Represents field SplitterRecord.
Tree | Represents field Tree.
View1 | Represents field View1.
Top


TDataViewer.BDiagram Field

Summary

Represents field BDiagram.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 BDiagram: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.Button2 Field

Summary

Represents field Button2.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 Button2: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.CBRecord Field

Summary

Represents field CBRecord.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 CBRecord: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.CBView Field

Summary

Represents field CBView.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 CBView: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.CBViewData Field

Summary

Represents field CBViewData.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 CBViewData: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.DataGrid Field

Summary

Represents field DataGrid.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 DataGrid: TBIGrid;

Field Value

Type: TBIGrid

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.DataSource2 Field

Summary

Represents field DataSource2.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 DataSource2: TDataSource;

Field Value

Type: TDataSource

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.DataTotals Field

Summary

Represents field DataTotals.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 DataTotals: TStringGrid;

Field Value

Type: TStringGrid

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.DBNavigator1 Field

Summary

Represents field DBNavigator1.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 DBNavigator1: TDBNavigator;

Field Value

Type: TDBNavigator

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.DBNavigator2 Field

Summary

Represents field DBNavigator2.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 DBNavigator2: TDBNavigator;

Field Value

Type: TDBNavigator

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.FData Field

Summary

Represents field FData.

Namespace: VCLBI.DataViewer
Syntax
Delphi
protected
 FData : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.Items Field

Summary

Represents field Items.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 Items: TBIDataset;

Field Value

Type: TBIDataset

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.ItemsGrid Field

Summary

Represents field ItemsGrid.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 ItemsGrid: TBIGrid;

Field Value

Type: TBIGrid

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.LName Field

Summary

Represents field LName.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 LName: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.LRow Field

Summary

Represents field LRow.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 LRow: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.N1 Field

Summary

Represents field N1.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 N1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.Panel3 Field

Summary

Represents field Panel3.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 Panel3: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.Panel4 Field

Summary

Represents field Panel4.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 Panel4: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.Panel5 Field

Summary

Represents field Panel5.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 Panel5: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.PanelData Field

Summary

Represents field PanelData.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 PanelData: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.PanelDataGrid Field

Summary

Represents field PanelDataGrid.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 PanelDataGrid: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.PanelDatas Field

Summary

Represents field PanelDatas.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 PanelDatas: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.PanelItems Field

Summary

Represents field PanelItems.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 PanelItems: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.PanelItemsGrid Field

Summary

Represents field PanelItemsGrid.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 PanelItemsGrid: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.PanelNav Field

Summary

Represents field PanelNav.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 PanelNav: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.PanelTop Field

Summary

Represents field PanelTop.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 PanelTop: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.PopupMenu1 Field

Summary

Represents field PopupMenu1.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 PopupMenu1: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.RecordView Field

Summary

Represents field RecordView.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 RecordView: TBIGrid;

Field Value

Type: TBIGrid

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.Splitter1 Field

Summary

Represents field Splitter1.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 Splitter1: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.SplitterData Field

Summary

Represents field SplitterData.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 SplitterData: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.SplitterRecord Field

Summary

Represents field SplitterRecord.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 SplitterRecord: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.Tree Field

Summary

Represents field Tree.

Namespace: VCLBI.DataViewer
Syntax
Delphi
protected
 Tree : TTreeView;

Field Value

Type: TTreeView

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


TDataViewer.View1 Field

Summary

Represents field View1.

Namespace: VCLBI.DataViewer
Syntax
Delphi
published
 View1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataViewer
  • VCLBI.DataViewer


VCLBI.DataViewer Routines

Routines
Name | Description
CheckName(String) | Represents method CheckName(String).
Roots(TTreeView) | Represents method Roots(TTreeView).
Top


CheckName(String) Method

Summary

Represents method CheckName(String).

Namespace: VCLBI.DataViewer
Syntax
Delphi
function CheckName(const S:String):String;

Parameters

S
Type: String

Return Value

Type: String

See Also

Reference

  • VCLBI.DataViewer


Roots(TTreeView) Method

Summary

Represents method Roots(TTreeView).

Namespace: VCLBI.DataViewer
Syntax
Delphi
function Roots(const ATree:TTreeView):Integer;

Parameters

ATree
Type: TTreeView

Return Value

Type: Integer

See Also

Reference

  • VCLBI.DataViewer


VCLBI.Designer.Template.Layouts Namespace

Summary

Represents namespace VCLBI.Designer.Template.Layouts.

Classes
Name | Description
TControlAccess | Represents type TControlAccess.
TLayoutDesigner | Represents type TLayoutDesigner.
Top
Routines
Name | Description
ExampleLayout | Represents method ExampleLayout.
LayoutToJSON(TLayoutItem,String) | Represents method LayoutToJSON(TLayoutItem,String).
StyleToString(TLayoutStyle) | Represents method StyleToString(TLayoutStyle).
Traverse(TControl,TProc) | Represents method Traverse(TControl,TProc).
Top


VCLBI.Designer.Template.Layouts Classes

Classes
Name | Description
TControlAccess | Represents type TControlAccess.
TLayoutDesigner | Represents type TLayoutDesigner.
Top


TControlAccess Class

Summary

Represents type TControlAccess.

Namespace: VCLBI.Designer.Template.Layouts
Inheritance Hierarchy
TControl
VCLBI.Designer.Template.Layouts.TControlAccess
Syntax
Delphi
type
 TControlAccess=class(TControl);
See Also

Reference

  • VCLBI.Designer.Template.Layouts


TLayoutDesigner Class

Summary

Represents type TLayoutDesigner.

Namespace: VCLBI.Designer.Template.Layouts
Inheritance Hierarchy
TForm
VCLBI.Designer.Template.Layouts.TLayoutDesigner
Syntax
Delphi
type
 TLayoutDesigner = class(TForm)
 end;

The TLayoutDesigner type exposes the following members.

Properties
Show:
Name | Description
OnItemChange | Represents property OnItemChange.
Top
Methods
Show:
Name | Description
BClearClick(TObject) | Represents method BClearClick(TObject).
BDeleteClick(TObject) | Represents method BDeleteClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
Captions1Click(TObject) | Represents method Captions1Click(TObject).
Colors1Click(TObject) | Represents method Colors1Click(TObject).
Edit(TComponent,TLayoutItem) | Represents method Edit(TComponent,TLayoutItem).
Embedd(TComponent,TWinControl) | Represents method Embedd(TComponent,TWinControl).
EPaddingChange(TObject) | Represents method EPaddingChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
Frames1Click(TObject) | Represents method Frames1Click(TObject).
LBLayoutsClick(TObject) | Represents method LBLayoutsClick(TObject).
Refresh(TLayoutItem) | Represents method Refresh(TLayoutItem).
SelectedItem | Represents method SelectedItem.
Splitters1Click(TObject) | Represents method Splitters1Click(TObject).
Top
Fields
Show:
Name | Description
BClear | Represents field BClear.
BDelete | Represents field BDelete.
BIVisual1 | Represents field BIVisual1.
Button1 | Represents field Button1.
Captions1 | Represents field Captions1.
CBAlign | Represents field CBAlign.
Colors1 | Represents field Colors1.
EPadding | Represents field EPadding.
Frames1 | Represents field Frames1.
Gallery | Represents field Gallery.
GalleryTemplate | Represents field GalleryTemplate.
Label1 | Represents field Label1.
LAlign | Represents field LAlign.
LBLayouts | Represents field LBLayouts.
MemoTemplate | Represents field MemoTemplate.
PageControl1 | Represents field PageControl1.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
PanelLeft | Represents field PanelLeft.
PopupMenu1 | Represents field PopupMenu1.
Splitter1 | Represents field Splitter1.
Splitter2 | Represents field Splitter2.
Splitters1 | Represents field Splitters1.
TabSheet1 | Represents field TabSheet1.
TabSheet2 | Represents field TabSheet2.
UDPadding | Represents field UDPadding.
Top
See Also

Reference

  • VCLBI.Designer.Template.Layouts


TLayoutDesigner Properties

Properties
Name | Description
OnItemChange | Represents property OnItemChange.
Top


TLayoutDesigner.OnItemChange Property

Summary

Represents property OnItemChange.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
public
 property OnItemChange:TNotifyEvent read FOnItemChange write FOnItemChange;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner Methods

Methods
Name | Description
BClearClick(TObject) | Represents method BClearClick(TObject).
BDeleteClick(TObject) | Represents method BDeleteClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
Captions1Click(TObject) | Represents method Captions1Click(TObject).
Colors1Click(TObject) | Represents method Colors1Click(TObject).
Edit(TComponent,TLayoutItem) | Represents method Edit(TComponent,TLayoutItem).
Embedd(TComponent,TWinControl) | Represents method Embedd(TComponent,TWinControl).
EPaddingChange(TObject) | Represents method EPaddingChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
Frames1Click(TObject) | Represents method Frames1Click(TObject).
LBLayoutsClick(TObject) | Represents method LBLayoutsClick(TObject).
Refresh(TLayoutItem) | Represents method Refresh(TLayoutItem).
SelectedItem | Represents method SelectedItem.
Splitters1Click(TObject) | Represents method Splitters1Click(TObject).
Top


TLayoutDesigner.BClearClick(TObject) Method

Summary

Represents method BClearClick(TObject).

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 procedure BClearClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.BDeleteClick(TObject) Method

Summary

Represents method BDeleteClick(TObject).

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 procedure BDeleteClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.Captions1Click(TObject) Method

Summary

Represents method Captions1Click(TObject).

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 procedure Captions1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.Colors1Click(TObject) Method

Summary

Represents method Colors1Click(TObject).

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 procedure Colors1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.Edit(TComponent,TLayoutItem) Method

Summary

Represents method Edit(TComponent,TLayoutItem).

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent;
 const ALayout:TLayoutItem):Boolean; static;

Parameters

AOwner
Type: TComponent

ALayout
Type: TLayoutItem

Return Value

Type: Boolean

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.Embedd(TComponent,TWinControl) Method

Summary

Represents method Embedd(TComponent,TWinControl).

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent;
 const AParent:TWinControl):TLayoutDesigner; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

Return Value

Type: TLayoutDesigner

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.EPaddingChange(TObject) Method

Summary

Represents method EPaddingChange(TObject).

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 procedure EPaddingChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.Frames1Click(TObject) Method

Summary

Represents method Frames1Click(TObject).

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 procedure Frames1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.LBLayoutsClick(TObject) Method

Summary

Represents method LBLayoutsClick(TObject).

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 procedure LBLayoutsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.Refresh(TLayoutItem) Method

Summary

Represents method Refresh(TLayoutItem).

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
public
 procedure Refresh(const ALayout:TLayoutItem);

Parameters

ALayout
Type: TLayoutItem

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.SelectedItem Method

Summary

Represents method SelectedItem.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
public
 function SelectedItem:TPanel;

Return Value

Type: TPanel

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.Splitters1Click(TObject) Method

Summary

Represents method Splitters1Click(TObject).

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 procedure Splitters1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner Fields

Fields
Name | Description
BClear | Represents field BClear.
BDelete | Represents field BDelete.
BIVisual1 | Represents field BIVisual1.
Button1 | Represents field Button1.
Captions1 | Represents field Captions1.
CBAlign | Represents field CBAlign.
Colors1 | Represents field Colors1.
EPadding | Represents field EPadding.
Frames1 | Represents field Frames1.
Gallery | Represents field Gallery.
GalleryTemplate | Represents field GalleryTemplate.
Label1 | Represents field Label1.
LAlign | Represents field LAlign.
LBLayouts | Represents field LBLayouts.
MemoTemplate | Represents field MemoTemplate.
PageControl1 | Represents field PageControl1.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
PanelLeft | Represents field PanelLeft.
PopupMenu1 | Represents field PopupMenu1.
Splitter1 | Represents field Splitter1.
Splitter2 | Represents field Splitter2.
Splitters1 | Represents field Splitters1.
TabSheet1 | Represents field TabSheet1.
TabSheet2 | Represents field TabSheet2.
UDPadding | Represents field UDPadding.
Top


TLayoutDesigner.BClear Field

Summary

Represents field BClear.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 BClear: TButton;

Field Value

Type: TButton

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.BDelete Field

Summary

Represents field BDelete.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 BDelete: TButton;

Field Value

Type: TButton

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.BIVisual1 Field

Summary

Represents field BIVisual1.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 BIVisual1: TBIVisual;

Field Value

Type: TBIVisual

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.Button1 Field

Summary

Represents field Button1.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.Captions1 Field

Summary

Represents field Captions1.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 Captions1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.CBAlign Field

Summary

Represents field CBAlign.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 CBAlign: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.Colors1 Field

Summary

Represents field Colors1.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 Colors1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.EPadding Field

Summary

Represents field EPadding.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 EPadding: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.Frames1 Field

Summary

Represents field Frames1.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 Frames1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.Gallery Field

Summary

Represents field Gallery.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 Gallery: TBIVisual;

Field Value

Type: TBIVisual

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.GalleryTemplate Field

Summary

Represents field GalleryTemplate.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 GalleryTemplate: TMemo;

Field Value

Type: TMemo

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.LAlign Field

Summary

Represents field LAlign.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 LAlign: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.LBLayouts Field

Summary

Represents field LBLayouts.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 LBLayouts: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.MemoTemplate Field

Summary

Represents field MemoTemplate.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 MemoTemplate: TMemo;

Field Value

Type: TMemo

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.PageControl1 Field

Summary

Represents field PageControl1.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 PageControl1: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.PanelLeft Field

Summary

Represents field PanelLeft.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 PanelLeft: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.PopupMenu1 Field

Summary

Represents field PopupMenu1.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 PopupMenu1: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.Splitter1 Field

Summary

Represents field Splitter1.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 Splitter1: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.Splitter2 Field

Summary

Represents field Splitter2.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 Splitter2: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.Splitters1 Field

Summary

Represents field Splitters1.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 Splitters1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.TabSheet1 Field

Summary

Represents field TabSheet1.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 TabSheet1: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.TabSheet2 Field

Summary

Represents field TabSheet2.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 TabSheet2: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


TLayoutDesigner.UDPadding Field

Summary

Represents field UDPadding.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
published
 UDPadding: TUpDown;

Field Value

Type: TUpDown

See Also

Reference

  • TLayoutDesigner
  • VCLBI.Designer.Template.Layouts


VCLBI.Designer.Template.Layouts Routines

Routines
Name | Description
ExampleLayout | Represents method ExampleLayout.
LayoutToJSON(TLayoutItem,String) | Represents method LayoutToJSON(TLayoutItem,String).
StyleToString(TLayoutStyle) | Represents method StyleToString(TLayoutStyle).
Traverse(TControl,TProc) | Represents method Traverse(TControl,TProc).
Top


ExampleLayout Method

Summary

Represents method ExampleLayout.

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
function ExampleLayout:TLayoutItem;

Return Value

Type: TLayoutItem

See Also

Reference

  • VCLBI.Designer.Template.Layouts


LayoutToJSON(TLayoutItem,String) Method

Summary

Represents method LayoutToJSON(TLayoutItem,String).

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
function LayoutToJSON(const ALayout:TLayoutItem; const AIndent:String=''):String;

Parameters

ALayout
Type: TLayoutItem

AIndent
Type: String

Return Value

Type: String

See Also

Reference

  • VCLBI.Designer.Template.Layouts


StyleToString(TLayoutStyle) Method

Summary

Represents method StyleToString(TLayoutStyle).

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
function StyleToString(const AStyle:TLayoutStyle):String;

Parameters

AStyle
Type: TLayoutStyle

Return Value

Type: String

See Also

Reference

  • VCLBI.Designer.Template.Layouts


Traverse(TControl,TProc) Method

Summary

Represents method Traverse(TControl,TProc).

Namespace: VCLBI.Designer.Template.Layouts
Syntax
Delphi
procedure Traverse(const AControl:TControl;
 const AProc:TProc<TControl>);

Parameters

AControl
Type: TControl

AProc
Type: TProc<TControl>

See Also

Reference

  • VCLBI.Designer.Template.Layouts


VCLBI.Editor.BIGrid Namespace

Summary

Represents namespace VCLBI.Editor.BIGrid.

Classes
Name | Description
TBIGridEditor | Represents type TBIGridEditor.
Top


VCLBI.Editor.BIGrid Classes

Classes
Name | Description
TBIGridEditor | Represents type TBIGridEditor.
Top


TBIGridEditor Class

Summary

Represents type TBIGridEditor.

Namespace: VCLBI.Editor.BIGrid
Inheritance Hierarchy
TForm
VCLBI.Editor.BIGrid.TBIGridEditor
Syntax
Delphi
type
 TBIGridEditor = class(TForm)
 end;

The TBIGridEditor type exposes the following members.

Methods
Show:
Name | Description
BAltColorClick(TObject) | Represents method BAltColorClick(TObject).
CBAltRowsClick(TObject) | Represents method CBAltRowsClick(TObject).
CBColorizeClick(TObject) | Represents method CBColorizeClick(TObject).
CBFilterClick(TObject) | Represents method CBFilterClick(TObject).
CBRowNumbersClick(TObject) | Represents method CBRowNumbersClick(TObject).
CBSearchClick(TObject) | Represents method CBSearchClick(TObject).
CBShowItemsChange(TObject) | Represents method CBShowItemsChange(TObject).
Edit(TComponent,TBIGrid) | Represents method Edit(TComponent,TBIGrid).
Embedd(TComponent,TWinControl,TBIGrid) | Represents method Embedd(TComponent,TWinControl,TBIGrid).
FormShow(TObject) | Represents method FormShow(TObject).
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
Refresh(TBIGrid) | Represents method Refresh(TBIGrid).
Top
Fields
Show:
Name | Description
BAltColor | Represents field BAltColor.
CBAltRows | Represents field CBAltRows.
CBColorize | Represents field CBColorize.
CBFilter | Represents field CBFilter.
CBRowNumbers | Represents field CBRowNumbers.
CBSearch | Represents field CBSearch.
CBShowItems | Represents field CBShowItems.
GroupBox1 | Represents field GroupBox1.
Label1 | Represents field Label1.
PageControl1 | Represents field PageControl1.
TabBIGrid | Represents field TabBIGrid.
TabPlugin | Represents field TabPlugin.
Top
See Also

Reference

  • VCLBI.Editor.BIGrid


TBIGridEditor Methods

Methods
Name | Description
BAltColorClick(TObject) | Represents method BAltColorClick(TObject).
CBAltRowsClick(TObject) | Represents method CBAltRowsClick(TObject).
CBColorizeClick(TObject) | Represents method CBColorizeClick(TObject).
CBFilterClick(TObject) | Represents method CBFilterClick(TObject).
CBRowNumbersClick(TObject) | Represents method CBRowNumbersClick(TObject).
CBSearchClick(TObject) | Represents method CBSearchClick(TObject).
CBShowItemsChange(TObject) | Represents method CBShowItemsChange(TObject).
Edit(TComponent,TBIGrid) | Represents method Edit(TComponent,TBIGrid).
Embedd(TComponent,TWinControl,TBIGrid) | Represents method Embedd(TComponent,TWinControl,TBIGrid).
FormShow(TObject) | Represents method FormShow(TObject).
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
Refresh(TBIGrid) | Represents method Refresh(TBIGrid).
Top


TBIGridEditor.BAltColorClick(TObject) Method

Summary

Represents method BAltColorClick(TObject).

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
published
 procedure BAltColorClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.CBAltRowsClick(TObject) Method

Summary

Represents method CBAltRowsClick(TObject).

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
published
 procedure CBAltRowsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.CBColorizeClick(TObject) Method

Summary

Represents method CBColorizeClick(TObject).

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
published
 procedure CBColorizeClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.CBFilterClick(TObject) Method

Summary

Represents method CBFilterClick(TObject).

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
published
 procedure CBFilterClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.CBRowNumbersClick(TObject) Method

Summary

Represents method CBRowNumbersClick(TObject).

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
published
 procedure CBRowNumbersClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.CBSearchClick(TObject) Method

Summary

Represents method CBSearchClick(TObject).

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
published
 procedure CBSearchClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.CBShowItemsChange(TObject) Method

Summary

Represents method CBShowItemsChange(TObject).

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
published
 procedure CBShowItemsChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.Edit(TComponent,TBIGrid) Method

Summary

Represents method Edit(TComponent,TBIGrid).

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
public
 class procedure Edit(const AOwner:TComponent; const ABIGrid:TBIGrid); static;

Parameters

AOwner
Type: TComponent

ABIGrid
Type: TBIGrid

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.Embedd(TComponent,TWinControl,TBIGrid) Method

Summary

Represents method Embedd(TComponent,TWinControl,TBIGrid).

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const AGrid:TBIGrid):TBIGridEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AGrid
Type: TBIGrid

Return Value

Type: TBIGridEditor

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.PageControl1Change(TObject) Method

Summary

Represents method PageControl1Change(TObject).

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
published
 procedure PageControl1Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.Refresh(TBIGrid) Method

Summary

Represents method Refresh(TBIGrid).

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
public
 procedure Refresh(const AGrid:TBIGrid);

Parameters

AGrid
Type: TBIGrid

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor Fields

Fields
Name | Description
BAltColor | Represents field BAltColor.
CBAltRows | Represents field CBAltRows.
CBColorize | Represents field CBColorize.
CBFilter | Represents field CBFilter.
CBRowNumbers | Represents field CBRowNumbers.
CBSearch | Represents field CBSearch.
CBShowItems | Represents field CBShowItems.
GroupBox1 | Represents field GroupBox1.
Label1 | Represents field Label1.
PageControl1 | Represents field PageControl1.
TabBIGrid | Represents field TabBIGrid.
TabPlugin | Represents field TabPlugin.
Top


TBIGridEditor.BAltColor Field

Summary

Represents field BAltColor.

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
published
 BAltColor: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.CBAltRows Field

Summary

Represents field CBAltRows.

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
published
 CBAltRows: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.CBColorize Field

Summary

Represents field CBColorize.

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
published
 CBColorize: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.CBFilter Field

Summary

Represents field CBFilter.

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
published
 CBFilter: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.CBRowNumbers Field

Summary

Represents field CBRowNumbers.

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
published
 CBRowNumbers: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.CBSearch Field

Summary

Represents field CBSearch.

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
published
 CBSearch: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.CBShowItems Field

Summary

Represents field CBShowItems.

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
published
 CBShowItems: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.GroupBox1 Field

Summary

Represents field GroupBox1.

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
published
 GroupBox1: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.PageControl1 Field

Summary

Represents field PageControl1.

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
published
 PageControl1: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.TabBIGrid Field

Summary

Represents field TabBIGrid.

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
published
 TabBIGrid: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


TBIGridEditor.TabPlugin Field

Summary

Represents field TabPlugin.

Namespace: VCLBI.Editor.BIGrid
Syntax
Delphi
published
 TabPlugin: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIGridEditor
  • VCLBI.Editor.BIGrid


VCLBI.Editor.Chart Namespace

Summary

Represents namespace VCLBI.Editor.Chart.

Classes
Name | Description
TBIChartAccess | Represents type TBIChartAccess.
TBIChartEditor | Represents type TBIChartEditor.
TBITChartAccess | Represents type TBITChartAccess.
Top
Routines
Name | Description
Calc2DSeries(Integer,Boolean) | Represents method Calc2DSeries(Integer,Boolean).
FindClass(TStrings,TChartSeriesClass) | Represents method FindClass(TStrings,TChartSeriesClass).
FindSeries(TChartSeriesList,TChartSeriesClass) | Represents method FindSeries(TChartSeriesList,TChartSeriesClass).
Needs3D(TChartSeriesClass) | Represents method Needs3D(TChartSeriesClass).
ShowQueryEditor(TWinControl,TComponent,TDataItem) | Represents method ShowQueryEditor(TWinControl,TComponent,TDataItem).
Top


VCLBI.Editor.Chart Classes

Classes
Name | Description
TBIChartAccess | Represents type TBIChartAccess.
TBIChartEditor | Represents type TBIChartEditor.
TBITChartAccess | Represents type TBITChartAccess.
Top


TBIChartAccess Class

Summary

Represents type TBIChartAccess.

Namespace: VCLBI.Editor.Chart
Inheritance Hierarchy
TWinControl
VCLBI.DataControl.TBIDataControl
VCLBI.Chart.TBIChart
VCLBI.Editor.Chart.TBIChartAccess
Syntax
Delphi
type
 TBIChartAccess=class(TBIChart);
See Also

Reference

  • VCLBI.Editor.Chart


TBIChartEditor Class

Summary

Represents type TBIChartEditor.

Namespace: VCLBI.Editor.Chart
Inheritance Hierarchy
TForm
VCLBI.Editor.Chart.TBIChartEditor
Syntax
Delphi
type
 TBIChartEditor = class(TForm)
 end;

The TBIChartEditor type exposes the following members.

Properties
Show:
Name | Description
Chart | Represents property Chart.
Top
Methods
Show:
Name | Description
BSwapXYClick(TObject) | Represents method BSwapXYClick(TObject).
BSwapXZClick(TObject) | Represents method BSwapXZClick(TObject).
BSwapYZClick(TObject) | Represents method BSwapYZClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
CBAutoMapClick(TObject) | Represents method CBAutoMapClick(TObject).
CBCitiesClick(TObject) | Represents method CBCitiesClick(TObject).
CBCloseChange(TObject) | Represents method CBCloseChange(TObject).
CBFlagsClick(TObject) | Represents method CBFlagsClick(TObject).
CBHighChange(TObject) | Represents method CBHighChange(TObject).
CBHoriz2DChange(TObject) | Represents method CBHoriz2DChange(TObject).
CBLowChange(TObject) | Represents method CBLowChange(TObject).
CBMap3DClick(TObject) | Represents method CBMap3DClick(TObject).
CBMapChange(TObject) | Represents method CBMapChange(TObject).
CBOpenChange(TObject) | Represents method CBOpenChange(TObject).
CBOpenGLClick(TObject) | Represents method CBOpenGLClick(TObject).
CBStackedChange(TObject) | Represents method CBStackedChange(TObject).
CBStatesClick(TObject) | Represents method CBStatesClick(TObject).
CBTextChange(TObject) | Represents method CBTextChange(TObject).
CBVolumeChange(TObject) | Represents method CBVolumeChange(TObject).
CBX2DChange(TObject) | Represents method CBX2DChange(TObject).
CBXChange(TObject) | Represents method CBXChange(TObject).
CBYChange(TObject) | Represents method CBYChange(TObject).
CBZChange(TObject) | Represents method CBZChange(TObject).
Edit(TComponent,TBIChart) | Represents method Edit(TComponent,TBIChart).
Embedd(TComponent,TWinControl,TBIChart) | Represents method Embedd(TComponent,TWinControl,TBIChart).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
LB2DClick(TObject) | Represents method LB2DClick(TObject).
LB3DClick(TObject) | Represents method LB3DClick(TObject).
LBFinancialClick(TObject) | Represents method LBFinancialClick(TObject).
LBXYZClick(TObject) | Represents method LBXYZClick(TObject).
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
RB3DClick(TObject) | Represents method RB3DClick(TObject).
RBAutoClick(TObject) | Represents method RBAutoClick(TObject).
RBFinancialClick(TObject) | Represents method RBFinancialClick(TObject).
RBGeoClick(TObject) | Represents method RBGeoClick(TObject).
RBXYClick(TObject) | Represents method RBXYClick(TObject).
RefreshData | Overloaded. Represents method RefreshData.
RefreshData(TBIChartItems) | Overloaded. Represents method RefreshData(TBIChartItems).
RG3DClick(TObject) | Represents method RG3DClick(TObject).
RGDirectionClick(TObject) | Represents method RGDirectionClick(TObject).
RGLegendClick(TObject) | Represents method RGLegendClick(TObject).
RGMarksClick(TObject) | Represents method RGMarksClick(TObject).
RGViewClick(TObject) | Represents method RGViewClick(TObject).
Top
Fields
Show:
Name | Description
BOK | Represents field BOK.
BSwapXY | Represents field BSwapXY.
BSwapXZ | Represents field BSwapXZ.
BSwapYZ | Represents field BSwapYZ.
Button1 | Represents field Button1.
CB3D | Represents field CB3D.
CBAutoFinancial | Represents field CBAutoFinancial.
CBAutoMap | Represents field CBAutoMap.
CBCities | Represents field CBCities.
CBClose | Represents field CBClose.
CBColors | Represents field CBColors.
CBFlags | Represents field CBFlags.
CBHigh | Represents field CBHigh.
CBHoriz2D | Represents field CBHoriz2D.
CBLow | Represents field CBLow.
CBMap | Represents field CBMap.
CBMap3D | Represents field CBMap3D.
CBOpen | Represents field CBOpen.
CBOpenGL | Represents field CBOpenGL.
CBStacked | Represents field CBStacked.
CBStates | Represents field CBStates.
CBText | Represents field CBText.
CBVolume | Represents field CBVolume.
CBX | Represents field CBX.
CBX2D | Represents field CBX2D.
CBY | Represents field CBY.
CBZ | Represents field CBZ.
GroupBox1 | Represents field GroupBox1.
GroupBox2 | Represents field GroupBox2.
GroupBox3 | Represents field GroupBox3.
Label1 | Represents field Label1.
Label10 | Represents field Label10.
Label11 | Represents field Label11.
Label12 | Represents field Label12.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
Label8 | Represents field Label8.
Label9 | Represents field Label9.
LB2D | Represents field LB2D.
LB3D | Represents field LB3D.
LBFinancial | Represents field LBFinancial.
LBXYZ | Represents field LBXYZ.
PageControl1 | Represents field PageControl1.
PageMode | Represents field PageMode.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel3D | Represents field Panel3D.
Panel4 | Represents field Panel4.
Panel9 | Represents field Panel9.
PanelButtons | Represents field PanelButtons.
PanelItems | Represents field PanelItems.
PanelY | Represents field PanelY.
PanelYTable | Represents field PanelYTable.
RB3D | Represents field RB3D.
RBAuto | Represents field RBAuto.
RBFinancial | Represents field RBFinancial.
RBGeo | Represents field RBGeo.
RBXY | Represents field RBXY.
RG3D | Represents field RG3D.
RGDirection | Represents field RGDirection.
RGLegend | Represents field RGLegend.
RGMarks | Represents field RGMarks.
RGView | Represents field RGView.
Shape1 | Represents field Shape1.
Shape2 | Represents field Shape2.
Tab2D | Represents field Tab2D.
Tab3D | Represents field Tab3D.
TabChart | Represents field TabChart.
TabData | Represents field TabData.
TabFinancial | Represents field TabFinancial.
TabGeo | Represents field TabGeo.
TabOptions | Represents field TabOptions.
TabView | Represents field TabView.
Top
See Also

Reference

  • VCLBI.Editor.Chart


TBIChartEditor Properties

Properties
Name | Description
Chart | Represents property Chart.
Top


TBIChartEditor.Chart Property

Summary

Represents property Chart.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
public
 property Chart:TBIChart read FChart write SetChart;

Property Value

Type: TBIChart

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor Methods

Methods
Name | Description
BSwapXYClick(TObject) | Represents method BSwapXYClick(TObject).
BSwapXZClick(TObject) | Represents method BSwapXZClick(TObject).
BSwapYZClick(TObject) | Represents method BSwapYZClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
CBAutoMapClick(TObject) | Represents method CBAutoMapClick(TObject).
CBCitiesClick(TObject) | Represents method CBCitiesClick(TObject).
CBCloseChange(TObject) | Represents method CBCloseChange(TObject).
CBFlagsClick(TObject) | Represents method CBFlagsClick(TObject).
CBHighChange(TObject) | Represents method CBHighChange(TObject).
CBHoriz2DChange(TObject) | Represents method CBHoriz2DChange(TObject).
CBLowChange(TObject) | Represents method CBLowChange(TObject).
CBMap3DClick(TObject) | Represents method CBMap3DClick(TObject).
CBMapChange(TObject) | Represents method CBMapChange(TObject).
CBOpenChange(TObject) | Represents method CBOpenChange(TObject).
CBOpenGLClick(TObject) | Represents method CBOpenGLClick(TObject).
CBStackedChange(TObject) | Represents method CBStackedChange(TObject).
CBStatesClick(TObject) | Represents method CBStatesClick(TObject).
CBTextChange(TObject) | Represents method CBTextChange(TObject).
CBVolumeChange(TObject) | Represents method CBVolumeChange(TObject).
CBX2DChange(TObject) | Represents method CBX2DChange(TObject).
CBXChange(TObject) | Represents method CBXChange(TObject).
CBYChange(TObject) | Represents method CBYChange(TObject).
CBZChange(TObject) | Represents method CBZChange(TObject).
Edit(TComponent,TBIChart) | Represents method Edit(TComponent,TBIChart).
Embedd(TComponent,TWinControl,TBIChart) | Represents method Embedd(TComponent,TWinControl,TBIChart).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
LB2DClick(TObject) | Represents method LB2DClick(TObject).
LB3DClick(TObject) | Represents method LB3DClick(TObject).
LBFinancialClick(TObject) | Represents method LBFinancialClick(TObject).
LBXYZClick(TObject) | Represents method LBXYZClick(TObject).
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
RB3DClick(TObject) | Represents method RB3DClick(TObject).
RBAutoClick(TObject) | Represents method RBAutoClick(TObject).
RBFinancialClick(TObject) | Represents method RBFinancialClick(TObject).
RBGeoClick(TObject) | Represents method RBGeoClick(TObject).
RBXYClick(TObject) | Represents method RBXYClick(TObject).
RefreshData | Overloaded. Represents method RefreshData.
RefreshData(TBIChartItems) | Overloaded. Represents method RefreshData(TBIChartItems).
RG3DClick(TObject) | Represents method RG3DClick(TObject).
RGDirectionClick(TObject) | Represents method RGDirectionClick(TObject).
RGLegendClick(TObject) | Represents method RGLegendClick(TObject).
RGMarksClick(TObject) | Represents method RGMarksClick(TObject).
RGViewClick(TObject) | Represents method RGViewClick(TObject).
Top


TBIChartEditor.BSwapXYClick(TObject) Method

Summary

Represents method BSwapXYClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure BSwapXYClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.BSwapXZClick(TObject) Method

Summary

Represents method BSwapXZClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure BSwapXZClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.BSwapYZClick(TObject) Method

Summary

Represents method BSwapYZClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure BSwapYZClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBAutoMapClick(TObject) Method

Summary

Represents method CBAutoMapClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure CBAutoMapClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBCitiesClick(TObject) Method

Summary

Represents method CBCitiesClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure CBCitiesClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBCloseChange(TObject) Method

Summary

Represents method CBCloseChange(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure CBCloseChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBFlagsClick(TObject) Method

Summary

Represents method CBFlagsClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure CBFlagsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBHighChange(TObject) Method

Summary

Represents method CBHighChange(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure CBHighChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBHoriz2DChange(TObject) Method

Summary

Represents method CBHoriz2DChange(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure CBHoriz2DChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBLowChange(TObject) Method

Summary

Represents method CBLowChange(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure CBLowChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBMap3DClick(TObject) Method

Summary

Represents method CBMap3DClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure CBMap3DClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBMapChange(TObject) Method

Summary

Represents method CBMapChange(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure CBMapChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBOpenChange(TObject) Method

Summary

Represents method CBOpenChange(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure CBOpenChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBOpenGLClick(TObject) Method

Summary

Represents method CBOpenGLClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure CBOpenGLClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBStackedChange(TObject) Method

Summary

Represents method CBStackedChange(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure CBStackedChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBStatesClick(TObject) Method

Summary

Represents method CBStatesClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure CBStatesClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBTextChange(TObject) Method

Summary

Represents method CBTextChange(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure CBTextChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBVolumeChange(TObject) Method

Summary

Represents method CBVolumeChange(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure CBVolumeChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBX2DChange(TObject) Method

Summary

Represents method CBX2DChange(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure CBX2DChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBXChange(TObject) Method

Summary

Represents method CBXChange(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure CBXChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBYChange(TObject) Method

Summary

Represents method CBYChange(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure CBYChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBZChange(TObject) Method

Summary

Represents method CBZChange(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure CBZChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Edit(TComponent,TBIChart) Method

Summary

Represents method Edit(TComponent,TBIChart).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
public
 class procedure Edit(const AOwner:TComponent; const AChart:TBIChart); static;

Parameters

AOwner
Type: TComponent

AChart
Type: TBIChart

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Embedd(TComponent,TWinControl,TBIChart) Method

Summary

Represents method Embedd(TComponent,TWinControl,TBIChart).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const AChart:TBIChart):TBIChartEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AChart
Type: TBIChart

Return Value

Type: TBIChartEditor

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.LB2DClick(TObject) Method

Summary

Represents method LB2DClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure LB2DClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.LB3DClick(TObject) Method

Summary

Represents method LB3DClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure LB3DClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.LBFinancialClick(TObject) Method

Summary

Represents method LBFinancialClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure LBFinancialClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.LBXYZClick(TObject) Method

Summary

Represents method LBXYZClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure LBXYZClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.PageControl1Change(TObject) Method

Summary

Represents method PageControl1Change(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure PageControl1Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RB3DClick(TObject) Method

Summary

Represents method RB3DClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure RB3DClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RBAutoClick(TObject) Method

Summary

Represents method RBAutoClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure RBAutoClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RBFinancialClick(TObject) Method

Summary

Represents method RBFinancialClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure RBFinancialClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RBGeoClick(TObject) Method

Summary

Represents method RBGeoClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure RBGeoClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RBXYClick(TObject) Method

Summary

Represents method RBXYClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure RBXYClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RefreshData Method

Summary

Represents method RefreshData.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
public
 procedure RefreshData; overload;
See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RefreshData(TBIChartItems) Method

Summary

Represents method RefreshData(TBIChartItems).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
protected
 procedure RefreshData(const AItems:TBIChartItems); overload;

Parameters

AItems
Type: TBIChartItems

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RG3DClick(TObject) Method

Summary

Represents method RG3DClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure RG3DClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RGDirectionClick(TObject) Method

Summary

Represents method RGDirectionClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure RGDirectionClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RGLegendClick(TObject) Method

Summary

Represents method RGLegendClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure RGLegendClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RGMarksClick(TObject) Method

Summary

Represents method RGMarksClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure RGMarksClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RGViewClick(TObject) Method

Summary

Represents method RGViewClick(TObject).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 procedure RGViewClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor Fields

Fields
Name | Description
BOK | Represents field BOK.
BSwapXY | Represents field BSwapXY.
BSwapXZ | Represents field BSwapXZ.
BSwapYZ | Represents field BSwapYZ.
Button1 | Represents field Button1.
CB3D | Represents field CB3D.
CBAutoFinancial | Represents field CBAutoFinancial.
CBAutoMap | Represents field CBAutoMap.
CBCities | Represents field CBCities.
CBClose | Represents field CBClose.
CBColors | Represents field CBColors.
CBFlags | Represents field CBFlags.
CBHigh | Represents field CBHigh.
CBHoriz2D | Represents field CBHoriz2D.
CBLow | Represents field CBLow.
CBMap | Represents field CBMap.
CBMap3D | Represents field CBMap3D.
CBOpen | Represents field CBOpen.
CBOpenGL | Represents field CBOpenGL.
CBStacked | Represents field CBStacked.
CBStates | Represents field CBStates.
CBText | Represents field CBText.
CBVolume | Represents field CBVolume.
CBX | Represents field CBX.
CBX2D | Represents field CBX2D.
CBY | Represents field CBY.
CBZ | Represents field CBZ.
GroupBox1 | Represents field GroupBox1.
GroupBox2 | Represents field GroupBox2.
GroupBox3 | Represents field GroupBox3.
Label1 | Represents field Label1.
Label10 | Represents field Label10.
Label11 | Represents field Label11.
Label12 | Represents field Label12.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
Label8 | Represents field Label8.
Label9 | Represents field Label9.
LB2D | Represents field LB2D.
LB3D | Represents field LB3D.
LBFinancial | Represents field LBFinancial.
LBXYZ | Represents field LBXYZ.
PageControl1 | Represents field PageControl1.
PageMode | Represents field PageMode.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel3D | Represents field Panel3D.
Panel4 | Represents field Panel4.
Panel9 | Represents field Panel9.
PanelButtons | Represents field PanelButtons.
PanelItems | Represents field PanelItems.
PanelY | Represents field PanelY.
PanelYTable | Represents field PanelYTable.
RB3D | Represents field RB3D.
RBAuto | Represents field RBAuto.
RBFinancial | Represents field RBFinancial.
RBGeo | Represents field RBGeo.
RBXY | Represents field RBXY.
RG3D | Represents field RG3D.
RGDirection | Represents field RGDirection.
RGLegend | Represents field RGLegend.
RGMarks | Represents field RGMarks.
RGView | Represents field RGView.
Shape1 | Represents field Shape1.
Shape2 | Represents field Shape2.
Tab2D | Represents field Tab2D.
Tab3D | Represents field Tab3D.
TabChart | Represents field TabChart.
TabData | Represents field TabData.
TabFinancial | Represents field TabFinancial.
TabGeo | Represents field TabGeo.
TabOptions | Represents field TabOptions.
TabView | Represents field TabView.
Top


TBIChartEditor.BOK Field

Summary

Represents field BOK.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 BOK: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.BSwapXY Field

Summary

Represents field BSwapXY.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 BSwapXY: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.BSwapXZ Field

Summary

Represents field BSwapXZ.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 BSwapXZ: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.BSwapYZ Field

Summary

Represents field BSwapYZ.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 BSwapYZ: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Button1 Field

Summary

Represents field Button1.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CB3D Field

Summary

Represents field CB3D.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CB3D: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBAutoFinancial Field

Summary

Represents field CBAutoFinancial.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CBAutoFinancial: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBAutoMap Field

Summary

Represents field CBAutoMap.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CBAutoMap: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBCities Field

Summary

Represents field CBCities.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CBCities: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBClose Field

Summary

Represents field CBClose.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CBClose: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBColors Field

Summary

Represents field CBColors.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CBColors: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBFlags Field

Summary

Represents field CBFlags.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CBFlags: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBHigh Field

Summary

Represents field CBHigh.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CBHigh: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBHoriz2D Field

Summary

Represents field CBHoriz2D.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CBHoriz2D: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBLow Field

Summary

Represents field CBLow.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CBLow: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBMap Field

Summary

Represents field CBMap.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CBMap: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBMap3D Field

Summary

Represents field CBMap3D.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CBMap3D: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBOpen Field

Summary

Represents field CBOpen.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CBOpen: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBOpenGL Field

Summary

Represents field CBOpenGL.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CBOpenGL: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBStacked Field

Summary

Represents field CBStacked.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CBStacked: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBStates Field

Summary

Represents field CBStates.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CBStates: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBText Field

Summary

Represents field CBText.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CBText: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBVolume Field

Summary

Represents field CBVolume.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CBVolume: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBX Field

Summary

Represents field CBX.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CBX: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBX2D Field

Summary

Represents field CBX2D.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CBX2D: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBY Field

Summary

Represents field CBY.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CBY: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.CBZ Field

Summary

Represents field CBZ.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 CBZ: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.GroupBox1 Field

Summary

Represents field GroupBox1.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 GroupBox1: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.GroupBox2 Field

Summary

Represents field GroupBox2.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 GroupBox2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.GroupBox3 Field

Summary

Represents field GroupBox3.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 GroupBox3: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Label10 Field

Summary

Represents field Label10.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Label10: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Label11 Field

Summary

Represents field Label11.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Label11: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Label12 Field

Summary

Represents field Label12.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Label12: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Label2 Field

Summary

Represents field Label2.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Label3 Field

Summary

Represents field Label3.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Label4 Field

Summary

Represents field Label4.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Label4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Label5 Field

Summary

Represents field Label5.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Label5: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Label6 Field

Summary

Represents field Label6.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Label6: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Label7 Field

Summary

Represents field Label7.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Label7: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Label8 Field

Summary

Represents field Label8.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Label8: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Label9 Field

Summary

Represents field Label9.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Label9: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.LB2D Field

Summary

Represents field LB2D.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 LB2D: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.LB3D Field

Summary

Represents field LB3D.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 LB3D: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.LBFinancial Field

Summary

Represents field LBFinancial.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 LBFinancial: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.LBXYZ Field

Summary

Represents field LBXYZ.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 LBXYZ: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.PageControl1 Field

Summary

Represents field PageControl1.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 PageControl1: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.PageMode Field

Summary

Represents field PageMode.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 PageMode: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Panel3 Field

Summary

Represents field Panel3.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Panel3: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Panel3D Field

Summary

Represents field Panel3D.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Panel3D: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Panel4 Field

Summary

Represents field Panel4.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Panel4: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Panel9 Field

Summary

Represents field Panel9.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Panel9: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.PanelButtons Field

Summary

Represents field PanelButtons.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 PanelButtons: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.PanelItems Field

Summary

Represents field PanelItems.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 PanelItems: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.PanelY Field

Summary

Represents field PanelY.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 PanelY: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.PanelYTable Field

Summary

Represents field PanelYTable.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 PanelYTable: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RB3D Field

Summary

Represents field RB3D.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 RB3D: TRadioButton;

Field Value

Type: TRadioButton

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RBAuto Field

Summary

Represents field RBAuto.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 RBAuto: TRadioButton;

Field Value

Type: TRadioButton

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RBFinancial Field

Summary

Represents field RBFinancial.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 RBFinancial: TRadioButton;

Field Value

Type: TRadioButton

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RBGeo Field

Summary

Represents field RBGeo.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 RBGeo: TRadioButton;

Field Value

Type: TRadioButton

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RBXY Field

Summary

Represents field RBXY.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 RBXY: TRadioButton;

Field Value

Type: TRadioButton

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RG3D Field

Summary

Represents field RG3D.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 RG3D: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RGDirection Field

Summary

Represents field RGDirection.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 RGDirection: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RGLegend Field

Summary

Represents field RGLegend.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 RGLegend: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RGMarks Field

Summary

Represents field RGMarks.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 RGMarks: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.RGView Field

Summary

Represents field RGView.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 RGView: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Shape1 Field

Summary

Represents field Shape1.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Shape1: TShape;

Field Value

Type: TShape

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Shape2 Field

Summary

Represents field Shape2.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Shape2: TShape;

Field Value

Type: TShape

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Tab2D Field

Summary

Represents field Tab2D.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Tab2D: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.Tab3D Field

Summary

Represents field Tab3D.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 Tab3D: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.TabChart Field

Summary

Represents field TabChart.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 TabChart: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.TabData Field

Summary

Represents field TabData.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 TabData: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.TabFinancial Field

Summary

Represents field TabFinancial.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 TabFinancial: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.TabGeo Field

Summary

Represents field TabGeo.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 TabGeo: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.TabOptions Field

Summary

Represents field TabOptions.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 TabOptions: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBIChartEditor.TabView Field

Summary

Represents field TabView.

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
published
 TabView: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIChartEditor
  • VCLBI.Editor.Chart


TBITChartAccess Class

Summary

Represents type TBITChartAccess.

Namespace: VCLBI.Editor.Chart
Inheritance Hierarchy
TChart
VCLBI.Chart.Plugin.TBITChart
VCLBI.Editor.Chart.TBITChartAccess
Syntax
Delphi
type
 TBITChartAccess=class(TBITChart);
See Also

Reference

  • VCLBI.Editor.Chart


VCLBI.Editor.Chart Routines

Routines
Name | Description
Calc2DSeries(Integer,Boolean) | Represents method Calc2DSeries(Integer,Boolean).
FindClass(TStrings,TChartSeriesClass) | Represents method FindClass(TStrings,TChartSeriesClass).
FindSeries(TChartSeriesList,TChartSeriesClass) | Represents method FindSeries(TChartSeriesList,TChartSeriesClass).
Needs3D(TChartSeriesClass) | Represents method Needs3D(TChartSeriesClass).
ShowQueryEditor(TWinControl,TComponent,TDataItem) | Represents method ShowQueryEditor(TWinControl,TComponent,TDataItem).
Top


Calc2DSeries(Integer,Boolean) Method

Summary

Represents method Calc2DSeries(Integer,Boolean).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
function Calc2DSeries(const AIndex:Integer; const Horizontal:Boolean):TChartSeriesClass;

Parameters

AIndex
Type: Integer

Horizontal
Type: Boolean

Return Value

Type: TChartSeriesClass

See Also

Reference

  • VCLBI.Editor.Chart


FindClass(TStrings,TChartSeriesClass) Method

Summary

Represents method FindClass(TStrings,TChartSeriesClass).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
function FindClass(const AItems:TStrings; const AClass:TChartSeriesClass):Integer;

Parameters

AItems
Type: TStrings

AClass
Type: TChartSeriesClass

Return Value

Type: Integer

See Also

Reference

  • VCLBI.Editor.Chart


FindSeries(TChartSeriesList,TChartSeriesClass) Method

Summary

Represents method FindSeries(TChartSeriesList,TChartSeriesClass).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
function FindSeries(const AList:TChartSeriesList; const AClass:TChartSeriesClass):TChartSeries;

Parameters

AList
Type: TChartSeriesList

AClass
Type: TChartSeriesClass

Return Value

Type: TChartSeries

See Also

Reference

  • VCLBI.Editor.Chart


Needs3D(TChartSeriesClass) Method

Summary

Represents method Needs3D(TChartSeriesClass).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
function Needs3D(const AClass:TChartSeriesClass):Boolean;

Parameters

AClass
Type: TChartSeriesClass

Return Value

Type: Boolean

See Also

Reference

  • VCLBI.Editor.Chart


ShowQueryEditor(TWinControl,TComponent,TDataItem) Method

Summary

Represents method ShowQueryEditor(TWinControl,TComponent,TDataItem).

Namespace: VCLBI.Editor.Chart
Syntax
Delphi
procedure ShowQueryEditor(const AParent:TWinControl;
 const AProvider:TComponent;
 const AData:TDataItem);

Parameters

AParent
Type: TWinControl

AProvider
Type: TComponent

AData
Type: TDataItem

See Also

Reference

  • VCLBI.Editor.Chart


VCLBI.Editor.Chart.Source Namespace

Summary

Represents namespace VCLBI.Editor.Chart.Source.

Classes
Name | Description
TBISourceEditor | Represents type TBISourceEditor.
Top
Records
Name | Description
TValueControl | Represents type TValueControl.
Top


VCLBI.Editor.Chart.Source Classes

Classes
Name | Description
TBISourceEditor | Represents type TBISourceEditor.
Top


TBISourceEditor Class

Summary

Represents type TBISourceEditor.

Namespace: VCLBI.Editor.Chart.Source
Inheritance Hierarchy
TBaseSourceEditor
VCLBI.Editor.Chart.Source.TBISourceEditor
Syntax
Delphi
type
 TBISourceEditor = class(TBaseSourceEditor)
 end;

The TBISourceEditor type exposes the following members.

Methods
Show:
Name | Description
BApplyClick(TObject) | Represents method BApplyClick(TObject).
BSelectDataClick(TObject) | Represents method BSelectDataClick(TObject).
CBLabelsFieldChange(TObject) | Represents method CBLabelsFieldChange(TObject).
Edit(TComponent,TTeeBISource) | Represents method Edit(TComponent,TTeeBISource).
FormShow(TObject) | Represents method FormShow(TObject).
Top
Fields
Show:
Name | Description
BSelectData | Represents field BSelectData.
CBLabelsField | Represents field CBLabelsField.
GroupFields | Represents field GroupFields.
LData | Represents field LData.
LLabels | Represents field LLabels.
PanelData | Represents field PanelData.
Top
See Also

Reference

  • VCLBI.Editor.Chart.Source


TBISourceEditor Methods

Methods
Name | Description
BApplyClick(TObject) | Represents method BApplyClick(TObject).
BSelectDataClick(TObject) | Represents method BSelectDataClick(TObject).
CBLabelsFieldChange(TObject) | Represents method CBLabelsFieldChange(TObject).
Edit(TComponent,TTeeBISource) | Represents method Edit(TComponent,TTeeBISource).
FormShow(TObject) | Represents method FormShow(TObject).
Top


TBISourceEditor.BApplyClick(TObject) Method

Summary

Represents method BApplyClick(TObject).

Namespace: VCLBI.Editor.Chart.Source
Syntax
Delphi
published
 procedure BApplyClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBISourceEditor
  • VCLBI.Editor.Chart.Source


TBISourceEditor.BSelectDataClick(TObject) Method

Summary

Represents method BSelectDataClick(TObject).

Namespace: VCLBI.Editor.Chart.Source
Syntax
Delphi
published
 procedure BSelectDataClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBISourceEditor
  • VCLBI.Editor.Chart.Source


TBISourceEditor.CBLabelsFieldChange(TObject) Method

Summary

Represents method CBLabelsFieldChange(TObject).

Namespace: VCLBI.Editor.Chart.Source
Syntax
Delphi
published
 procedure CBLabelsFieldChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBISourceEditor
  • VCLBI.Editor.Chart.Source


TBISourceEditor.Edit(TComponent,TTeeBISource) Method

Summary

Represents method Edit(TComponent,TTeeBISource).

Namespace: VCLBI.Editor.Chart.Source
Syntax
Delphi
public
 class procedure Edit(const AOwner:TComponent; const ASource:TTeeBISource); static;

Parameters

AOwner
Type: TComponent

ASource
Type: TTeeBISource

See Also

Reference

  • TBISourceEditor
  • VCLBI.Editor.Chart.Source


TBISourceEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Editor.Chart.Source
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBISourceEditor
  • VCLBI.Editor.Chart.Source


TBISourceEditor Fields

Fields
Name | Description
BSelectData | Represents field BSelectData.
CBLabelsField | Represents field CBLabelsField.
GroupFields | Represents field GroupFields.
LData | Represents field LData.
LLabels | Represents field LLabels.
PanelData | Represents field PanelData.
Top


TBISourceEditor.BSelectData Field

Summary

Represents field BSelectData.

Namespace: VCLBI.Editor.Chart.Source
Syntax
Delphi
published
 BSelectData: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBISourceEditor
  • VCLBI.Editor.Chart.Source


TBISourceEditor.CBLabelsField Field

Summary

Represents field CBLabelsField.

Namespace: VCLBI.Editor.Chart.Source
Syntax
Delphi
published
 CBLabelsField: TComboFlat;

Field Value

Type: TComboFlat

See Also

Reference

  • TBISourceEditor
  • VCLBI.Editor.Chart.Source


TBISourceEditor.GroupFields Field

Summary

Represents field GroupFields.

Namespace: VCLBI.Editor.Chart.Source
Syntax
Delphi
published
 GroupFields: TScrollBox;

Field Value

Type: TScrollBox

See Also

Reference

  • TBISourceEditor
  • VCLBI.Editor.Chart.Source


TBISourceEditor.LData Field

Summary

Represents field LData.

Namespace: VCLBI.Editor.Chart.Source
Syntax
Delphi
published
 LData: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBISourceEditor
  • VCLBI.Editor.Chart.Source


TBISourceEditor.LLabels Field

Summary

Represents field LLabels.

Namespace: VCLBI.Editor.Chart.Source
Syntax
Delphi
published
 LLabels: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBISourceEditor
  • VCLBI.Editor.Chart.Source


TBISourceEditor.PanelData Field

Summary

Represents field PanelData.

Namespace: VCLBI.Editor.Chart.Source
Syntax
Delphi
published
 PanelData: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBISourceEditor
  • VCLBI.Editor.Chart.Source


VCLBI.Editor.Chart.Source Records

Records
Name | Description
TValueControl | Represents type TValueControl.
Top


TValueControl Record

Summary

Represents type TValueControl.

Namespace: VCLBI.Editor.Chart.Source
Syntax
Delphi
type
 TValueControl=record
 end;

The TValueControl type exposes the following members.

Fields
Show:
Name | Description
Combo | Represents field Combo.
Text | Represents field Text.
Top
See Also

Reference

  • VCLBI.Editor.Chart.Source


TValueControl.Combo Field

Summary

Represents field Combo.

Namespace: VCLBI.Editor.Chart.Source
Syntax
Delphi
public
 Combo : TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TValueControl
  • VCLBI.Editor.Chart.Source


TValueControl.Text Field

Summary

Represents field Text.

Namespace: VCLBI.Editor.Chart.Source
Syntax
Delphi
public
 Text : TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TValueControl
  • VCLBI.Editor.Chart.Source


VCLBI.Editor.ChartFunctions Namespace

Summary

Represents namespace VCLBI.Editor.ChartFunctions.

Classes
Name | Description
TDataFunctionEditor | Represents type TDataFunctionEditor.
TFunctionAccess | Represents type TFunctionAccess.
Top
Routines
Name | Description
CreateFunctionEditor(TComponent,String) | Represents method CreateFunctionEditor(TComponent,String).
Top


VCLBI.Editor.ChartFunctions Classes

Classes
Name | Description
TDataFunctionEditor | Represents type TDataFunctionEditor.
TFunctionAccess | Represents type TFunctionAccess.
Top


TDataFunctionEditor Class

Summary

Represents type TDataFunctionEditor.

Namespace: VCLBI.Editor.ChartFunctions
Inheritance Hierarchy
TForm
VCLBI.Editor.ChartFunctions.TDataFunctionEditor
Syntax
Delphi
type
 TDataFunctionEditor = class(TForm)
 end;

The TDataFunctionEditor type exposes the following members.

Methods
Show:
Name | Description
FormShow(TObject) | Represents method FormShow(TObject).
Top
See Also

Reference

  • VCLBI.Editor.ChartFunctions


TDataFunctionEditor Methods

Methods
Name | Description
FormShow(TObject) | Represents method FormShow(TObject).
Top


TDataFunctionEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Editor.ChartFunctions
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataFunctionEditor
  • VCLBI.Editor.ChartFunctions


TFunctionAccess Class

Summary

Represents type TFunctionAccess.

Namespace: VCLBI.Editor.ChartFunctions
Inheritance Hierarchy
TTeeFunction
VCLBI.Editor.ChartFunctions.TFunctionAccess
Syntax
Delphi
type
 TFunctionAccess=class(TTeeFunction);
See Also

Reference

  • VCLBI.Editor.ChartFunctions


VCLBI.Editor.ChartFunctions Routines

Routines
Name | Description
CreateFunctionEditor(TComponent,String) | Represents method CreateFunctionEditor(TComponent,String).
Top


CreateFunctionEditor(TComponent,String) Method

Summary

Represents method CreateFunctionEditor(TComponent,String).

Namespace: VCLBI.Editor.ChartFunctions
Syntax
Delphi
function CreateFunctionEditor(const AOwner:TComponent; const EditorClass:String):TCustomForm;

Parameters

AOwner
Type: TComponent

EditorClass
Type: String

Return Value

Type: TCustomForm

See Also

Reference

  • VCLBI.Editor.ChartFunctions


VCLBI.Editor.Completion Namespace

Summary

Represents namespace VCLBI.Editor.Completion.

Classes
Name | Description
TExpressionCompletion | Represents type TExpressionCompletion.
TSizeListBox | Represents type TSizeListBox.
Top
Delegates
Name | Description
TCompleteEvent | Represents type TCompleteEvent.
Top
Routines
Name | Description
CharIn(Char,TSysCharSet) | Represents method CharIn(Char,TSysCharSet).
IsIdentChar(Char) | Represents method IsIdentChar(Char).
Top


VCLBI.Editor.Completion Classes

Classes
Name | Description
TExpressionCompletion | Represents type TExpressionCompletion.
TSizeListBox | Represents type TSizeListBox.
Top


TExpressionCompletion Class

Summary

Represents type TExpressionCompletion.

Namespace: VCLBI.Editor.Completion
Inheritance Hierarchy
TObject
VCLBI.Editor.Completion.TExpressionCompletion
Syntax
Delphi
type
 TExpressionCompletion=class
 end;

The TExpressionCompletion type exposes the following members.

Constructors
Show:
Name | Description
Create(TWinControl) | Initializes a new instance of the TExpressionCompletion class.
Destroy | Represents the destructor of the TExpressionCompletion class.
Top
Properties
Show:
Name | Description
Control | Represents property Control.
Fields | Represents property Fields.
Items | Represents property Items.
OnResize | Represents property OnResize.
Top
Methods
Show:
Name | Description
AddItems(Boolean) | Represents method AddItems(Boolean).
Handle(Char) | Overloaded. Represents method Handle(Char).
Handle(Word,TShiftState) | Overloaded. Represents method Handle(Word,TShiftState).
Hide | Represents method Hide.
Show(Boolean) | Represents method Show(Boolean).
Visible | Represents method Visible.
Top
Events
Show:
Name | Description
OnComplete | Represents property OnComplete.
OnGetFields | Represents property OnGetFields.
Top
See Also

Reference

  • VCLBI.Editor.Completion


TExpressionCompletion Constructors

Constructors
Name | Description
Create(TWinControl) | Initializes a new instance of the TExpressionCompletion class.
Destroy | Represents the destructor of the TExpressionCompletion class.
Top


TExpressionCompletion.Create(TWinControl) Constructor

Summary

Initializes a new instance of the TExpressionCompletion class.

Namespace: VCLBI.Editor.Completion
Syntax
Delphi
public
 Constructor Create(const AParent:TWinControl);

Parameters

AParent
Type: TWinControl

See Also

Reference

  • TExpressionCompletion
  • VCLBI.Editor.Completion


TExpressionCompletion.Destroy Destructor

Summary

Represents the destructor of the TExpressionCompletion class.

Namespace: VCLBI.Editor.Completion
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TExpressionCompletion
  • VCLBI.Editor.Completion


TExpressionCompletion Properties

Properties
Name | Description
Control | Represents property Control.
Fields | Represents property Fields.
Items | Represents property Items.
OnResize | Represents property OnResize.
Top


TExpressionCompletion.Control Property

Summary

Represents property Control.

Namespace: VCLBI.Editor.Completion
Syntax
Delphi
public
 property Control:TSizeListBox read GetControl;

Property Value

Type: TSizeListBox

See Also

Reference

  • TExpressionCompletion
  • VCLBI.Editor.Completion


TExpressionCompletion.Fields Property

Summary

Represents property Fields.

Namespace: VCLBI.Editor.Completion
Syntax
Delphi
public
 property Fields:TStrings read FFields;

Property Value

Type: TStrings

See Also

Reference

  • TExpressionCompletion
  • VCLBI.Editor.Completion


TExpressionCompletion.Items Property

Summary

Represents property Items.

Namespace: VCLBI.Editor.Completion
Syntax
Delphi
public
 property Items:TStrings read FItems;

Property Value

Type: TStrings

See Also

Reference

  • TExpressionCompletion
  • VCLBI.Editor.Completion


TExpressionCompletion.OnResize Property

Summary

Represents property OnResize.

Namespace: VCLBI.Editor.Completion
Syntax
Delphi
public
 property OnResize:TNotifyEvent read FOnResize write FOnResize;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TExpressionCompletion
  • VCLBI.Editor.Completion


TExpressionCompletion Methods

Methods
Name | Description
AddItems(Boolean) | Represents method AddItems(Boolean).
Handle(Char) | Overloaded. Represents method Handle(Char).
Handle(Word,TShiftState) | Overloaded. Represents method Handle(Word,TShiftState).
Hide | Represents method Hide.
Show(Boolean) | Represents method Show(Boolean).
Visible | Represents method Visible.
Top


TExpressionCompletion.AddItems(Boolean) Method

Summary

Represents method AddItems(Boolean).

Namespace: VCLBI.Editor.Completion
Syntax
Delphi
public
 procedure AddItems(const FieldsOnly:Boolean);

Parameters

FieldsOnly
Type: Boolean

See Also

Reference

  • TExpressionCompletion
  • VCLBI.Editor.Completion


TExpressionCompletion.Handle(Char) Method

Summary

Represents method Handle(Char).

Namespace: VCLBI.Editor.Completion
Syntax
Delphi
public
 function Handle(var Key:Char):Boolean; overload;

Parameters

Key
Type: Char

Return Value

Type: Boolean

See Also

Reference

  • TExpressionCompletion
  • VCLBI.Editor.Completion


TExpressionCompletion.Handle(Word,TShiftState) Method

Summary

Represents method Handle(Word,TShiftState).

Namespace: VCLBI.Editor.Completion
Syntax
Delphi
public
 function Handle(var Key: Word; Shift: TShiftState):Boolean; overload;

Parameters

Key
Type: Word

Shift
Type: TShiftState

Return Value

Type: Boolean

See Also

Reference

  • TExpressionCompletion
  • VCLBI.Editor.Completion


TExpressionCompletion.Hide Method

Summary

Represents method Hide.

Namespace: VCLBI.Editor.Completion
Syntax
Delphi
public
 procedure Hide;
See Also

Reference

  • TExpressionCompletion
  • VCLBI.Editor.Completion


TExpressionCompletion.Show(Boolean) Method

Summary

Represents method Show(Boolean).

Namespace: VCLBI.Editor.Completion
Syntax
Delphi
public
 procedure Show(const FieldsOnly:Boolean);

Parameters

FieldsOnly
Type: Boolean

See Also

Reference

  • TExpressionCompletion
  • VCLBI.Editor.Completion


TExpressionCompletion.Visible Method

Summary

Represents method Visible.

Namespace: VCLBI.Editor.Completion
Syntax
Delphi
public
 function Visible:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TExpressionCompletion
  • VCLBI.Editor.Completion


TExpressionCompletion Events

Events
Name | Description
OnComplete | Represents property OnComplete.
OnGetFields | Represents property OnGetFields.
Top


TExpressionCompletion.OnComplete Event

Summary

Represents property OnComplete.

Namespace: VCLBI.Editor.Completion
Syntax
Delphi
public
 property OnComplete:TCompleteEvent read FOnComplete write FOnComplete;

Value

Type: TCompleteEvent

See Also

Reference

  • TExpressionCompletion
  • VCLBI.Editor.Completion


TExpressionCompletion.OnGetFields Event

Summary

Represents property OnGetFields.

Namespace: VCLBI.Editor.Completion
Syntax
Delphi
public
 property OnGetFields:TCompleteEvent read FOnGetFields write FOnGetFields;

Value

Type: TCompleteEvent

See Also

Reference

  • TExpressionCompletion
  • VCLBI.Editor.Completion


TSizeListBox Class

Summary

Represents type TSizeListBox.

Namespace: VCLBI.Editor.Completion
Inheritance Hierarchy
TListBox
VCLBI.Editor.Completion.TSizeListBox
Syntax
Delphi
type
 TSizeListBox=class(TListBox)
 end;

The TSizeListBox type exposes the following members.

Methods
Show:
Name | Description
CreateParams(TCreateParams) | Represents method CreateParams(TCreateParams).
Resize | Represents method Resize.
Top
See Also

Reference

  • VCLBI.Editor.Completion


TSizeListBox Methods

Methods
Name | Description
CreateParams(TCreateParams) | Represents method CreateParams(TCreateParams).
Resize | Represents method Resize.
Top


TSizeListBox.CreateParams(TCreateParams) Method

Summary

Represents method CreateParams(TCreateParams).

Namespace: VCLBI.Editor.Completion
Syntax
Delphi
protected
 procedure CreateParams(var Params: TCreateParams); override;

Parameters

Params
Type: TCreateParams

See Also

Reference

  • TSizeListBox
  • VCLBI.Editor.Completion


TSizeListBox.Resize Method

Summary

Represents method Resize.

Namespace: VCLBI.Editor.Completion
Syntax
Delphi
protected
 procedure Resize; override;
See Also

Reference

  • TSizeListBox
  • VCLBI.Editor.Completion


VCLBI.Editor.Completion Delegates

Delegates
Name | Description
TCompleteEvent | Represents type TCompleteEvent.
Top


TCompleteEvent Delegate

Summary

Represents type TCompleteEvent.

Namespace: VCLBI.Editor.Completion
Syntax
Delphi
type
 TCompleteEvent=procedure(Sender:TObject; const Text:String) of object;
See Also

Reference

  • VCLBI.Editor.Completion


VCLBI.Editor.Completion Routines

Routines
Name | Description
CharIn(Char,TSysCharSet) | Represents method CharIn(Char,TSysCharSet).
IsIdentChar(Char) | Represents method IsIdentChar(Char).
Top


CharIn(Char,TSysCharSet) Method

Summary

Represents method CharIn(Char,TSysCharSet).

Namespace: VCLBI.Editor.Completion
Syntax
Delphi
function CharIn(const C:Char; const AChars:TSysCharSet):Boolean;

Parameters

C
Type: Char

AChars
Type: TSysCharSet

Return Value

Type: Boolean

See Also

Reference

  • VCLBI.Editor.Completion


IsIdentChar(Char) Method

Summary

Represents method IsIdentChar(Char).

Namespace: VCLBI.Editor.Completion
Syntax
Delphi
function IsIdentChar(const C:Char):Boolean;

Parameters

C
Type: Char

Return Value

Type: Boolean

See Also

Reference

  • VCLBI.Editor.Completion


VCLBI.Editor.ControlTree Namespace

Summary

Represents namespace VCLBI.Editor.ControlTree.

Classes
Name | Description
TBIControlTree | Represents type TBIControlTree.
TControlAccess | Represents type TControlAccess.
Top


VCLBI.Editor.ControlTree Classes

Classes
Name | Description
TBIControlTree | Represents type TBIControlTree.
TControlAccess | Represents type TControlAccess.
Top


TBIControlTree Class

Summary

Represents type TBIControlTree.

Namespace: VCLBI.Editor.ControlTree
Inheritance Hierarchy
TForm
VCLBI.Editor.ControlTree.TBIControlTree
Syntax
Delphi
type
 TBIControlTree = class(TForm)
 end;

The TBIControlTree type exposes the following members.

Methods
Show:
Name | Description
BEditChartClick(TObject) | Represents method BEditChartClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
CBParentBackClick(TObject) | Represents method CBParentBackClick(TObject).
CBParentColorClick(TObject) | Represents method CBParentColorClick(TObject).
CBParentFontClick(TObject) | Represents method CBParentFontClick(TObject).
CBVisibleClick(TObject) | Represents method CBVisibleClick(TObject).
ColorListBox1Click(TObject) | Represents method ColorListBox1Click(TObject).
Edit(TComponent,TWinControl) | Represents method Edit(TComponent,TWinControl).
EHeightChange(TObject) | Represents method EHeightChange(TObject).
EWidthChange(TObject) | Represents method EWidthChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
Refresh(TWinControl) | Represents method Refresh(TWinControl).
RGAlignClick(TObject) | Represents method RGAlignClick(TObject).
TreeView1Change(TObject,TTreeNode) | Represents method TreeView1Change(TObject,TTreeNode).
Top
Fields
Show:
Name | Description
BEditChart | Represents field BEditChart.
Button1 | Represents field Button1.
CBParentBack | Represents field CBParentBack.
CBParentColor | Represents field CBParentColor.
CBParentFont | Represents field CBParentFont.
CBVisible | Represents field CBVisible.
ColorListBox1 | Represents field ColorListBox1.
Edit1 | Represents field Edit1.
Edit2 | Represents field Edit2.
EHeight | Represents field EHeight.
EWidth | Represents field EWidth.
FontDialog1 | Represents field FontDialog1.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Panel1 | Represents field Panel1.
RGAlign | Represents field RGAlign.
Splitter1 | Represents field Splitter1.
TreeView1 | Represents field TreeView1.
UDHeight | Represents field UDHeight.
UDLeft | Represents field UDLeft.
UDTop | Represents field UDTop.
UDWidth | Represents field UDWidth.
Top
See Also

Reference

  • VCLBI.Editor.ControlTree


TBIControlTree Methods

Methods
Name | Description
BEditChartClick(TObject) | Represents method BEditChartClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
CBParentBackClick(TObject) | Represents method CBParentBackClick(TObject).
CBParentColorClick(TObject) | Represents method CBParentColorClick(TObject).
CBParentFontClick(TObject) | Represents method CBParentFontClick(TObject).
CBVisibleClick(TObject) | Represents method CBVisibleClick(TObject).
ColorListBox1Click(TObject) | Represents method ColorListBox1Click(TObject).
Edit(TComponent,TWinControl) | Represents method Edit(TComponent,TWinControl).
EHeightChange(TObject) | Represents method EHeightChange(TObject).
EWidthChange(TObject) | Represents method EWidthChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
Refresh(TWinControl) | Represents method Refresh(TWinControl).
RGAlignClick(TObject) | Represents method RGAlignClick(TObject).
TreeView1Change(TObject,TTreeNode) | Represents method TreeView1Change(TObject,TTreeNode).
Top


TBIControlTree.BEditChartClick(TObject) Method

Summary

Represents method BEditChartClick(TObject).

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 procedure BEditChartClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.CBParentBackClick(TObject) Method

Summary

Represents method CBParentBackClick(TObject).

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 procedure CBParentBackClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.CBParentColorClick(TObject) Method

Summary

Represents method CBParentColorClick(TObject).

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 procedure CBParentColorClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.CBParentFontClick(TObject) Method

Summary

Represents method CBParentFontClick(TObject).

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 procedure CBParentFontClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.CBVisibleClick(TObject) Method

Summary

Represents method CBVisibleClick(TObject).

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 procedure CBVisibleClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.ColorListBox1Click(TObject) Method

Summary

Represents method ColorListBox1Click(TObject).

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 procedure ColorListBox1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.Edit(TComponent,TWinControl) Method

Summary

Represents method Edit(TComponent,TWinControl).

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
public
 class procedure Edit(const AOwner:TComponent; const AControl:TWinControl); static;

Parameters

AOwner
Type: TComponent

AControl
Type: TWinControl

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.EHeightChange(TObject) Method

Summary

Represents method EHeightChange(TObject).

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 procedure EHeightChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.EWidthChange(TObject) Method

Summary

Represents method EWidthChange(TObject).

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 procedure EWidthChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.Refresh(TWinControl) Method

Summary

Represents method Refresh(TWinControl).

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
public
 procedure Refresh(const AControl:TWinControl);

Parameters

AControl
Type: TWinControl

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.RGAlignClick(TObject) Method

Summary

Represents method RGAlignClick(TObject).

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 procedure RGAlignClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.TreeView1Change(TObject,TTreeNode) Method

Summary

Represents method TreeView1Change(TObject,TTreeNode).

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 procedure TreeView1Change(Sender: TObject; Node: TTreeNode);

Parameters

Sender
Type: TObject

Node
Type: TTreeNode

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree Fields

Fields
Name | Description
BEditChart | Represents field BEditChart.
Button1 | Represents field Button1.
CBParentBack | Represents field CBParentBack.
CBParentColor | Represents field CBParentColor.
CBParentFont | Represents field CBParentFont.
CBVisible | Represents field CBVisible.
ColorListBox1 | Represents field ColorListBox1.
Edit1 | Represents field Edit1.
Edit2 | Represents field Edit2.
EHeight | Represents field EHeight.
EWidth | Represents field EWidth.
FontDialog1 | Represents field FontDialog1.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Panel1 | Represents field Panel1.
RGAlign | Represents field RGAlign.
Splitter1 | Represents field Splitter1.
TreeView1 | Represents field TreeView1.
UDHeight | Represents field UDHeight.
UDLeft | Represents field UDLeft.
UDTop | Represents field UDTop.
UDWidth | Represents field UDWidth.
Top


TBIControlTree.BEditChart Field

Summary

Represents field BEditChart.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 BEditChart: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.Button1 Field

Summary

Represents field Button1.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.CBParentBack Field

Summary

Represents field CBParentBack.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 CBParentBack: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.CBParentColor Field

Summary

Represents field CBParentColor.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 CBParentColor: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.CBParentFont Field

Summary

Represents field CBParentFont.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 CBParentFont: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.CBVisible Field

Summary

Represents field CBVisible.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 CBVisible: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.ColorListBox1 Field

Summary

Represents field ColorListBox1.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 ColorListBox1: TColorListBox;

Field Value

Type: TColorListBox

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.Edit1 Field

Summary

Represents field Edit1.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 Edit1: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.Edit2 Field

Summary

Represents field Edit2.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 Edit2: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.EHeight Field

Summary

Represents field EHeight.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 EHeight: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.EWidth Field

Summary

Represents field EWidth.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 EWidth: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.FontDialog1 Field

Summary

Represents field FontDialog1.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 FontDialog1: TFontDialog;

Field Value

Type: TFontDialog

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.Label2 Field

Summary

Represents field Label2.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.Label3 Field

Summary

Represents field Label3.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.Label4 Field

Summary

Represents field Label4.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 Label4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.RGAlign Field

Summary

Represents field RGAlign.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 RGAlign: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.Splitter1 Field

Summary

Represents field Splitter1.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 Splitter1: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.TreeView1 Field

Summary

Represents field TreeView1.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 TreeView1: TTreeView;

Field Value

Type: TTreeView

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.UDHeight Field

Summary

Represents field UDHeight.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 UDHeight: TUpDown;

Field Value

Type: TUpDown

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.UDLeft Field

Summary

Represents field UDLeft.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 UDLeft: TUpDown;

Field Value

Type: TUpDown

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.UDTop Field

Summary

Represents field UDTop.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 UDTop: TUpDown;

Field Value

Type: TUpDown

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TBIControlTree.UDWidth Field

Summary

Represents field UDWidth.

Namespace: VCLBI.Editor.ControlTree
Syntax
Delphi
published
 UDWidth: TUpDown;

Field Value

Type: TUpDown

See Also

Reference

  • TBIControlTree
  • VCLBI.Editor.ControlTree


TControlAccess Class

Summary

Represents type TControlAccess.

Namespace: VCLBI.Editor.ControlTree
Inheritance Hierarchy
TControl
VCLBI.Editor.ControlTree.TControlAccess
Syntax
Delphi
type
 TControlAccess=class(TControl);
See Also

Reference

  • VCLBI.Editor.ControlTree


VCLBI.Editor.Data Namespace

Summary

Represents namespace VCLBI.Editor.Data.

Classes
Name | Description
TDataEditor | Represents type TDataEditor.
Top


VCLBI.Editor.Data Classes

Classes
Name | Description
TDataEditor | Represents type TDataEditor.
Top


TDataEditor Class

Summary

Represents type TDataEditor.

Namespace: VCLBI.Editor.Data
Inheritance Hierarchy
TForm
VCLBI.Editor.Data.TDataEditor
VCLBI.Editor.Stores.TDataEditorAccess
Syntax
Delphi
type
 TDataEditor = class(TForm)
 end;

The TDataEditor type exposes the following members.

Properties
Show:
Name | Description
OnChangeWeb | Represents property OnChangeWeb.
Top
Methods
Show:
Name | Description
BDBTestClick(TObject) | Represents method BDBTestClick(TObject).
BFTPTestClick(TObject) | Represents method BFTPTestClick(TObject).
BOKClick(TObject) | Represents method BOKClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
Button3Click(TObject) | Represents method Button3Click(TObject).
Button4Click(TObject) | Represents method Button4Click(TObject).
Button5Click(TObject) | Represents method Button5Click(TObject).
Button6Click(TObject) | Represents method Button6Click(TObject).
Button7Click(TObject) | Represents method Button7Click(TObject).
BWebTestClick(TObject) | Represents method BWebTestClick(TObject).
CBAllFolderClick(TObject) | Represents method CBAllFolderClick(TObject).
CBAllItemsClick(TObject) | Represents method CBAllItemsClick(TObject).
CBDBDriverChange(TObject) | Represents method CBDBDriverChange(TObject).
CBDBSystemClick(TObject) | Represents method CBDBSystemClick(TObject).
CBDBViewsClick(TObject) | Represents method CBDBViewsClick(TObject).
CBFileTypeChange(TObject) | Represents method CBFileTypeChange(TObject).
CBLoginClick(TObject) | Represents method CBLoginClick(TObject).
CBParallelClick(TObject) | Represents method CBParallelClick(TObject).
CBRecursiveClick(TObject) | Represents method CBRecursiveClick(TObject).
CBStatsClick(TObject) | Represents method CBStatsClick(TObject).
CBWebDataChange(TObject) | Represents method CBWebDataChange(TObject).
CBWebDataDropDown(TObject) | Represents method CBWebDataDropDown(TObject).
CBZipClick(TObject) | Represents method CBZipClick(TObject).
ClearWeb | Represents method ClearWeb.
Description | Represents method Description.
EDBDatabaseChange(TObject) | Represents method EDBDatabaseChange(TObject).
EDBIncludeChange(TObject) | Represents method EDBIncludeChange(TObject).
EDBPasswordChange(TObject) | Represents method EDBPasswordChange(TObject).
EDBPortChange(TObject) | Represents method EDBPortChange(TObject).
EDBServerChange(TObject) | Represents method EDBServerChange(TObject).
EDBUserChange(TObject) | Represents method EDBUserChange(TObject).
Edit(TComponent,TDataDefinition) | Represents method Edit(TComponent,TDataDefinition).
EExcludedChange(TObject) | Represents method EExcludedChange(TObject).
EFileChange(TObject) | Represents method EFileChange(TObject).
EFileMaskChange(TObject) | Represents method EFileMaskChange(TObject).
EFolderChange(TObject) | Represents method EFolderChange(TObject).
EFTPPasswordChange(TObject) | Represents method EFTPPasswordChange(TObject).
EFTPPortChange(TObject) | Represents method EFTPPortChange(TObject).
EFTPServerChange(TObject) | Represents method EFTPServerChange(TObject).
EFTPUserChange(TObject) | Represents method EFTPUserChange(TObject).
EPortChange(TObject) | Represents method EPortChange(TObject).
EProxyHostChange(TObject) | Represents method EProxyHostChange(TObject).
EProxyPasswordChange(TObject) | Represents method EProxyPasswordChange(TObject).
EProxyPortChange(TObject) | Represents method EProxyPortChange(TObject).
EProxyUserChange(TObject) | Represents method EProxyUserChange(TObject).
ETimeoutChange(TObject) | Represents method ETimeoutChange(TObject).
EWebServerChange(TObject) | Represents method EWebServerChange(TObject).
EWebURLChange(TObject) | Represents method EWebURLChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
LayoutWebDataResize(TObject) | Represents method LayoutWebDataResize(TObject).
MemoSQLChange(TObject) | Represents method MemoSQLChange(TObject).
NewDefinition(TComponent,TComponent,TDataDefinitionKind,String) | Represents method NewDefinition(TComponent,TComponent,TDataDefinitionKind,String).
PageControlFileChange(TObject) | Represents method PageControlFileChange(TObject).
Select(String,String) | Overloaded. Represents method Select(String,String).
Select(TDataDefinition) | Overloaded. Represents method Select(TDataDefinition).
SetWebPath(String) | Represents method SetWebPath(String).
WebPath | Represents method WebPath.
Top
Fields
Show:
Name | Description
BDBTest | Represents field BDBTest.
BFTPTest | Represents field BFTPTest.
BOK | Represents field BOK.
Button1 | Represents field Button1.
Button2 | Represents field Button2.
Button3 | Represents field Button3.
Button4 | Represents field Button4.
Button5 | Represents field Button5.
Button6 | Represents field Button6.
Button7 | Represents field Button7.
BWebTest | Represents field BWebTest.
CBAllFolder | Represents field CBAllFolder.
CBAllItems | Represents field CBAllItems.
CBDBDriver | Represents field CBDBDriver.
CBDBSystem | Represents field CBDBSystem.
CBDBViews | Represents field CBDBViews.
CBFileType | Represents field CBFileType.
CBLogin | Represents field CBLogin.
CBParallel | Represents field CBParallel.
CBRecursive | Represents field CBRecursive.
CBStats | Represents field CBStats.
CBWebData | Represents field CBWebData.
CBZip | Represents field CBZip.
Data | Represents field Data.
EDBDatabase | Represents field EDBDatabase.
EDBExclude | Represents field EDBExclude.
EDBInclude | Represents field EDBInclude.
EDBPassword | Represents field EDBPassword.
EDBPort | Represents field EDBPort.
EDBServer | Represents field EDBServer.
EDBUser | Represents field EDBUser.
EExcluded | Represents field EExcluded.
EFile | Represents field EFile.
EFileMask | Represents field EFileMask.
EFolder | Represents field EFolder.
EFTPPassword | Represents field EFTPPassword.
EFTPPort | Represents field EFTPPort.
EFTPServer | Represents field EFTPServer.
EFTPUser | Represents field EFTPUser.
EPort | Represents field EPort.
EProxyHost | Represents field EProxyHost.
EProxyPassword | Represents field EProxyPassword.
EProxyPort | Represents field EProxyPort.
EProxyUser | Represents field EProxyUser.
ETimeout | Represents field ETimeout.
EWebServer | Represents field EWebServer.
EWebURL | Represents field EWebURL.
ITabFormats | Represents field ITabFormats.
ItemsEditor | Represents field ItemsEditor.
Label1 | Represents field Label1.
Label10 | Represents field Label10.
Label11 | Represents field Label11.
Label12 | Represents field Label12.
Label13 | Represents field Label13.
Label14 | Represents field Label14.
Label15 | Represents field Label15.
Label16 | Represents field Label16.
Label17 | Represents field Label17.
Label18 | Represents field Label18.
Label19 | Represents field Label19.
Label2 | Represents field Label2.
Label20 | Represents field Label20.
Label21 | Represents field Label21.
Label22 | Represents field Label22.
Label23 | Represents field Label23.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
Label8 | Represents field Label8.
Label9 | Represents field Label9.
LayoutWebData | Represents field LayoutWebData.
LDBExclude | Represents field LDBExclude.
LDBInclude | Represents field LDBInclude.
LFileMissing | Represents field LFileMissing.
LFolderMissing | Represents field LFolderMissing.
LFTPStatus | Represents field LFTPStatus.
LWebTest | Represents field LWebTest.
MemoDBTest | Represents field MemoDBTest.
MemoSQL | Represents field MemoSQL.
OpenDialog1 | Represents field OpenDialog1.
OpenDialogDatabase | Represents field OpenDialogDatabase.
PageControl3 | Represents field PageControl3.
PageControlDBItems | Represents field PageControlDBItems.
PageControlFile | Represents field PageControlFile.
PageControlWeb | Represents field PageControlWeb.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
PanelButtons | Represents field PanelButtons.
RGKind | Represents field RGKind.
SQL | Represents field SQL.
TabConnection | Represents field TabConnection.
TabDatabase | Represents field TabDatabase.
TabDBOptions | Represents field TabDBOptions.
TabFile | Represents field TabFile.
TabFiles | Represents field TabFiles.
TabFolder | Represents field TabFolder.
TabFTP | Represents field TabFTP.
TabHttpProxy | Represents field TabHttpProxy.
TabHttpServer | Represents field TabHttpServer.
TabItemAllDB | Represents field TabItemAllDB.
TabManual | Represents field TabManual.
TabSources | Represents field TabSources.
TabSQL | Represents field TabSQL.
TabStyle | Represents field TabStyle.
TabWeb | Represents field TabWeb.
UDFTPPort | Represents field UDFTPPort.
UDPort | Represents field UDPort.
UDProxyPort | Represents field UDProxyPort.
UDTimeout | Represents field UDTimeout.
Top
See Also

Reference

  • VCLBI.Editor.Data


TDataEditor.OnChangeWeb Property

Summary

Represents property OnChangeWeb.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
public
 property OnChangeWeb:TNotifyEvent read FOnChangeWeb write FOnChangeWeb;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor Methods

Methods
Name | Description
BDBTestClick(TObject) | Represents method BDBTestClick(TObject).
BFTPTestClick(TObject) | Represents method BFTPTestClick(TObject).
BOKClick(TObject) | Represents method BOKClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
Button3Click(TObject) | Represents method Button3Click(TObject).
Button4Click(TObject) | Represents method Button4Click(TObject).
Button5Click(TObject) | Represents method Button5Click(TObject).
Button6Click(TObject) | Represents method Button6Click(TObject).
Button7Click(TObject) | Represents method Button7Click(TObject).
BWebTestClick(TObject) | Represents method BWebTestClick(TObject).
CBAllFolderClick(TObject) | Represents method CBAllFolderClick(TObject).
CBAllItemsClick(TObject) | Represents method CBAllItemsClick(TObject).
CBDBDriverChange(TObject) | Represents method CBDBDriverChange(TObject).
CBDBSystemClick(TObject) | Represents method CBDBSystemClick(TObject).
CBDBViewsClick(TObject) | Represents method CBDBViewsClick(TObject).
CBFileTypeChange(TObject) | Represents method CBFileTypeChange(TObject).
CBLoginClick(TObject) | Represents method CBLoginClick(TObject).
CBParallelClick(TObject) | Represents method CBParallelClick(TObject).
CBRecursiveClick(TObject) | Represents method CBRecursiveClick(TObject).
CBStatsClick(TObject) | Represents method CBStatsClick(TObject).
CBWebDataChange(TObject) | Represents method CBWebDataChange(TObject).
CBWebDataDropDown(TObject) | Represents method CBWebDataDropDown(TObject).
CBZipClick(TObject) | Represents method CBZipClick(TObject).
ClearWeb | Represents method ClearWeb.
Description | Represents method Description.
EDBDatabaseChange(TObject) | Represents method EDBDatabaseChange(TObject).
EDBIncludeChange(TObject) | Represents method EDBIncludeChange(TObject).
EDBPasswordChange(TObject) | Represents method EDBPasswordChange(TObject).
EDBPortChange(TObject) | Represents method EDBPortChange(TObject).
EDBServerChange(TObject) | Represents method EDBServerChange(TObject).
EDBUserChange(TObject) | Represents method EDBUserChange(TObject).
Edit(TComponent,TDataDefinition) | Represents method Edit(TComponent,TDataDefinition).
EExcludedChange(TObject) | Represents method EExcludedChange(TObject).
EFileChange(TObject) | Represents method EFileChange(TObject).
EFileMaskChange(TObject) | Represents method EFileMaskChange(TObject).
EFolderChange(TObject) | Represents method EFolderChange(TObject).
EFTPPasswordChange(TObject) | Represents method EFTPPasswordChange(TObject).
EFTPPortChange(TObject) | Represents method EFTPPortChange(TObject).
EFTPServerChange(TObject) | Represents method EFTPServerChange(TObject).
EFTPUserChange(TObject) | Represents method EFTPUserChange(TObject).
EPortChange(TObject) | Represents method EPortChange(TObject).
EProxyHostChange(TObject) | Represents method EProxyHostChange(TObject).
EProxyPasswordChange(TObject) | Represents method EProxyPasswordChange(TObject).
EProxyPortChange(TObject) | Represents method EProxyPortChange(TObject).
EProxyUserChange(TObject) | Represents method EProxyUserChange(TObject).
ETimeoutChange(TObject) | Represents method ETimeoutChange(TObject).
EWebServerChange(TObject) | Represents method EWebServerChange(TObject).
EWebURLChange(TObject) | Represents method EWebURLChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
LayoutWebDataResize(TObject) | Represents method LayoutWebDataResize(TObject).
MemoSQLChange(TObject) | Represents method MemoSQLChange(TObject).
NewDefinition(TComponent,TComponent,TDataDefinitionKind,String) | Represents method NewDefinition(TComponent,TComponent,TDataDefinitionKind,String).
PageControlFileChange(TObject) | Represents method PageControlFileChange(TObject).
Select(String,String) | Overloaded. Represents method Select(String,String).
Select(TDataDefinition) | Overloaded. Represents method Select(TDataDefinition).
SetWebPath(String) | Represents method SetWebPath(String).
WebPath | Represents method WebPath.
Top


TDataEditor.BDBTestClick(TObject) Method

Summary

Represents method BDBTestClick(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure BDBTestClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.BFTPTestClick(TObject) Method

Summary

Represents method BFTPTestClick(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure BFTPTestClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.BOKClick(TObject) Method

Summary

Represents method BOKClick(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure BOKClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Button3Click(TObject) Method

Summary

Represents method Button3Click(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure Button3Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Button4Click(TObject) Method

Summary

Represents method Button4Click(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure Button4Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Button5Click(TObject) Method

Summary

Represents method Button5Click(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure Button5Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Button6Click(TObject) Method

Summary

Represents method Button6Click(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure Button6Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Button7Click(TObject) Method

Summary

Represents method Button7Click(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure Button7Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.BWebTestClick(TObject) Method

Summary

Represents method BWebTestClick(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure BWebTestClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBAllFolderClick(TObject) Method

Summary

Represents method CBAllFolderClick(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure CBAllFolderClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBAllItemsClick(TObject) Method

Summary

Represents method CBAllItemsClick(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure CBAllItemsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBDBDriverChange(TObject) Method

Summary

Represents method CBDBDriverChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure CBDBDriverChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBDBSystemClick(TObject) Method

Summary

Represents method CBDBSystemClick(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure CBDBSystemClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBDBViewsClick(TObject) Method

Summary

Represents method CBDBViewsClick(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure CBDBViewsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBFileTypeChange(TObject) Method

Summary

Represents method CBFileTypeChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure CBFileTypeChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBLoginClick(TObject) Method

Summary

Represents method CBLoginClick(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure CBLoginClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBParallelClick(TObject) Method

Summary

Represents method CBParallelClick(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure CBParallelClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBRecursiveClick(TObject) Method

Summary

Represents method CBRecursiveClick(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure CBRecursiveClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBStatsClick(TObject) Method

Summary

Represents method CBStatsClick(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure CBStatsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBWebDataChange(TObject) Method

Summary

Represents method CBWebDataChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure CBWebDataChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBWebDataDropDown(TObject) Method

Summary

Represents method CBWebDataDropDown(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure CBWebDataDropDown(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBZipClick(TObject) Method

Summary

Represents method CBZipClick(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure CBZipClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.ClearWeb Method

Summary

Represents method ClearWeb.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
protected
 procedure ClearWeb;
See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Description Method

Summary

Represents method Description.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
public
 function Description:String;

Return Value

Type: String

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EDBDatabaseChange(TObject) Method

Summary

Represents method EDBDatabaseChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure EDBDatabaseChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EDBIncludeChange(TObject) Method

Summary

Represents method EDBIncludeChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure EDBIncludeChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EDBPasswordChange(TObject) Method

Summary

Represents method EDBPasswordChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure EDBPasswordChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EDBPortChange(TObject) Method

Summary

Represents method EDBPortChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure EDBPortChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EDBServerChange(TObject) Method

Summary

Represents method EDBServerChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure EDBServerChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EDBUserChange(TObject) Method

Summary

Represents method EDBUserChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure EDBUserChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Edit(TComponent,TDataDefinition) Method

Summary

Represents method Edit(TComponent,TDataDefinition).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const AData:TDataDefinition):Boolean; static;

Parameters

AOwner
Type: TComponent

AData
Type: TDataDefinition

Return Value

Type: Boolean

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EExcludedChange(TObject) Method

Summary

Represents method EExcludedChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure EExcludedChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EFileChange(TObject) Method

Summary

Represents method EFileChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure EFileChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EFileMaskChange(TObject) Method

Summary

Represents method EFileMaskChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure EFileMaskChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EFolderChange(TObject) Method

Summary

Represents method EFolderChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure EFolderChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EFTPPasswordChange(TObject) Method

Summary

Represents method EFTPPasswordChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure EFTPPasswordChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EFTPPortChange(TObject) Method

Summary

Represents method EFTPPortChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure EFTPPortChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EFTPServerChange(TObject) Method

Summary

Represents method EFTPServerChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure EFTPServerChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EFTPUserChange(TObject) Method

Summary

Represents method EFTPUserChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure EFTPUserChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EPortChange(TObject) Method

Summary

Represents method EPortChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure EPortChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EProxyHostChange(TObject) Method

Summary

Represents method EProxyHostChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure EProxyHostChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EProxyPasswordChange(TObject) Method

Summary

Represents method EProxyPasswordChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure EProxyPasswordChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EProxyPortChange(TObject) Method

Summary

Represents method EProxyPortChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure EProxyPortChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EProxyUserChange(TObject) Method

Summary

Represents method EProxyUserChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure EProxyUserChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.ETimeoutChange(TObject) Method

Summary

Represents method ETimeoutChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure ETimeoutChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EWebServerChange(TObject) Method

Summary

Represents method EWebServerChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure EWebServerChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EWebURLChange(TObject) Method

Summary

Represents method EWebURLChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure EWebURLChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.FormDestroy(TObject) Method

Summary

Represents method FormDestroy(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure FormDestroy(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.LayoutWebDataResize(TObject) Method

Summary

Represents method LayoutWebDataResize(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure LayoutWebDataResize(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.MemoSQLChange(TObject) Method

Summary

Represents method MemoSQLChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure MemoSQLChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.NewDefinition(TComponent,TComponent,TDataDefinitionKind,String) Method

Summary

Represents method NewDefinition(TComponent,TComponent,TDataDefinitionKind,String).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
public
 class function NewDefinition(const AOwner:TComponent;
 const ADataOwner:TComponent;
 const AKind:TDataDefinitionKind;
 out AName:String):TDataDefinition; static;

Parameters

AOwner
Type: TComponent

ADataOwner
Type: TComponent

AKind
Type: TDataDefinitionKind

AName
Type: String

Return Value

Type: TDataDefinition

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.PageControlFileChange(TObject) Method

Summary

Represents method PageControlFileChange(TObject).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 procedure PageControlFileChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Select(String,String) Method

Summary

Represents method Select(String,String).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
public
 procedure Select(const AStore,AName:String); overload;

Parameters

AStore
Type: String

AName
Type: String

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Select(TDataDefinition) Method

Summary

Represents method Select(TDataDefinition).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
public
 procedure Select(const AData:TDataDefinition); overload;

Parameters

AData
Type: TDataDefinition

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.SetWebPath(String) Method

Summary

Represents method SetWebPath(String).

Namespace: VCLBI.Editor.Data
Syntax
Delphi
protected
 procedure SetWebPath(const APath:String);

Parameters

APath
Type: String

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.WebPath Method

Summary

Represents method WebPath.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
protected
 function WebPath:String;

Return Value

Type: String

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor Fields

Fields
Name | Description
BDBTest | Represents field BDBTest.
BFTPTest | Represents field BFTPTest.
BOK | Represents field BOK.
Button1 | Represents field Button1.
Button2 | Represents field Button2.
Button3 | Represents field Button3.
Button4 | Represents field Button4.
Button5 | Represents field Button5.
Button6 | Represents field Button6.
Button7 | Represents field Button7.
BWebTest | Represents field BWebTest.
CBAllFolder | Represents field CBAllFolder.
CBAllItems | Represents field CBAllItems.
CBDBDriver | Represents field CBDBDriver.
CBDBSystem | Represents field CBDBSystem.
CBDBViews | Represents field CBDBViews.
CBFileType | Represents field CBFileType.
CBLogin | Represents field CBLogin.
CBParallel | Represents field CBParallel.
CBRecursive | Represents field CBRecursive.
CBStats | Represents field CBStats.
CBWebData | Represents field CBWebData.
CBZip | Represents field CBZip.
Data | Represents field Data.
EDBDatabase | Represents field EDBDatabase.
EDBExclude | Represents field EDBExclude.
EDBInclude | Represents field EDBInclude.
EDBPassword | Represents field EDBPassword.
EDBPort | Represents field EDBPort.
EDBServer | Represents field EDBServer.
EDBUser | Represents field EDBUser.
EExcluded | Represents field EExcluded.
EFile | Represents field EFile.
EFileMask | Represents field EFileMask.
EFolder | Represents field EFolder.
EFTPPassword | Represents field EFTPPassword.
EFTPPort | Represents field EFTPPort.
EFTPServer | Represents field EFTPServer.
EFTPUser | Represents field EFTPUser.
EPort | Represents field EPort.
EProxyHost | Represents field EProxyHost.
EProxyPassword | Represents field EProxyPassword.
EProxyPort | Represents field EProxyPort.
EProxyUser | Represents field EProxyUser.
ETimeout | Represents field ETimeout.
EWebServer | Represents field EWebServer.
EWebURL | Represents field EWebURL.
ITabFormats | Represents field ITabFormats.
ItemsEditor | Represents field ItemsEditor.
Label1 | Represents field Label1.
Label10 | Represents field Label10.
Label11 | Represents field Label11.
Label12 | Represents field Label12.
Label13 | Represents field Label13.
Label14 | Represents field Label14.
Label15 | Represents field Label15.
Label16 | Represents field Label16.
Label17 | Represents field Label17.
Label18 | Represents field Label18.
Label19 | Represents field Label19.
Label2 | Represents field Label2.
Label20 | Represents field Label20.
Label21 | Represents field Label21.
Label22 | Represents field Label22.
Label23 | Represents field Label23.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
Label8 | Represents field Label8.
Label9 | Represents field Label9.
LayoutWebData | Represents field LayoutWebData.
LDBExclude | Represents field LDBExclude.
LDBInclude | Represents field LDBInclude.
LFileMissing | Represents field LFileMissing.
LFolderMissing | Represents field LFolderMissing.
LFTPStatus | Represents field LFTPStatus.
LWebTest | Represents field LWebTest.
MemoDBTest | Represents field MemoDBTest.
MemoSQL | Represents field MemoSQL.
OpenDialog1 | Represents field OpenDialog1.
OpenDialogDatabase | Represents field OpenDialogDatabase.
PageControl3 | Represents field PageControl3.
PageControlDBItems | Represents field PageControlDBItems.
PageControlFile | Represents field PageControlFile.
PageControlWeb | Represents field PageControlWeb.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
PanelButtons | Represents field PanelButtons.
RGKind | Represents field RGKind.
SQL | Represents field SQL.
TabConnection | Represents field TabConnection.
TabDatabase | Represents field TabDatabase.
TabDBOptions | Represents field TabDBOptions.
TabFile | Represents field TabFile.
TabFiles | Represents field TabFiles.
TabFolder | Represents field TabFolder.
TabFTP | Represents field TabFTP.
TabHttpProxy | Represents field TabHttpProxy.
TabHttpServer | Represents field TabHttpServer.
TabItemAllDB | Represents field TabItemAllDB.
TabManual | Represents field TabManual.
TabSources | Represents field TabSources.
TabSQL | Represents field TabSQL.
TabStyle | Represents field TabStyle.
TabWeb | Represents field TabWeb.
UDFTPPort | Represents field UDFTPPort.
UDPort | Represents field UDPort.
UDProxyPort | Represents field UDProxyPort.
UDTimeout | Represents field UDTimeout.
Top


TDataEditor.BDBTest Field

Summary

Represents field BDBTest.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 BDBTest: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.BFTPTest Field

Summary

Represents field BFTPTest.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 BFTPTest: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.BOK Field

Summary

Represents field BOK.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 BOK: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Button1 Field

Summary

Represents field Button1.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Button2 Field

Summary

Represents field Button2.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Button2: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Button3 Field

Summary

Represents field Button3.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Button3: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Button4 Field

Summary

Represents field Button4.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Button4: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Button5 Field

Summary

Represents field Button5.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Button5: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Button6 Field

Summary

Represents field Button6.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Button6: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Button7 Field

Summary

Represents field Button7.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Button7: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.BWebTest Field

Summary

Represents field BWebTest.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 BWebTest: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBAllFolder Field

Summary

Represents field CBAllFolder.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 CBAllFolder: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBAllItems Field

Summary

Represents field CBAllItems.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 CBAllItems: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBDBDriver Field

Summary

Represents field CBDBDriver.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 CBDBDriver: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBDBSystem Field

Summary

Represents field CBDBSystem.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 CBDBSystem: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBDBViews Field

Summary

Represents field CBDBViews.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 CBDBViews: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBFileType Field

Summary

Represents field CBFileType.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 CBFileType: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBLogin Field

Summary

Represents field CBLogin.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 CBLogin: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBParallel Field

Summary

Represents field CBParallel.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 CBParallel: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBRecursive Field

Summary

Represents field CBRecursive.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 CBRecursive: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBStats Field

Summary

Represents field CBStats.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 CBStats: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBWebData Field

Summary

Represents field CBWebData.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 CBWebData: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.CBZip Field

Summary

Represents field CBZip.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 CBZip: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Data Field

Summary

Represents field Data.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
public
 Data : TDataDefinition;

Field Value

Type: TDataDefinition

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EDBDatabase Field

Summary

Represents field EDBDatabase.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EDBDatabase: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EDBExclude Field

Summary

Represents field EDBExclude.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EDBExclude: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EDBInclude Field

Summary

Represents field EDBInclude.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EDBInclude: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EDBPassword Field

Summary

Represents field EDBPassword.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EDBPassword: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EDBPort Field

Summary

Represents field EDBPort.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EDBPort: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EDBServer Field

Summary

Represents field EDBServer.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EDBServer: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EDBUser Field

Summary

Represents field EDBUser.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EDBUser: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EExcluded Field

Summary

Represents field EExcluded.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EExcluded: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EFile Field

Summary

Represents field EFile.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EFile: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EFileMask Field

Summary

Represents field EFileMask.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EFileMask: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EFolder Field

Summary

Represents field EFolder.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EFolder: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EFTPPassword Field

Summary

Represents field EFTPPassword.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EFTPPassword: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EFTPPort Field

Summary

Represents field EFTPPort.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EFTPPort: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EFTPServer Field

Summary

Represents field EFTPServer.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EFTPServer: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EFTPUser Field

Summary

Represents field EFTPUser.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EFTPUser: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EPort Field

Summary

Represents field EPort.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EPort: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EProxyHost Field

Summary

Represents field EProxyHost.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EProxyHost: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EProxyPassword Field

Summary

Represents field EProxyPassword.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EProxyPassword: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EProxyPort Field

Summary

Represents field EProxyPort.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EProxyPort: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EProxyUser Field

Summary

Represents field EProxyUser.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EProxyUser: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.ETimeout Field

Summary

Represents field ETimeout.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 ETimeout: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EWebServer Field

Summary

Represents field EWebServer.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EWebServer: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.EWebURL Field

Summary

Represents field EWebURL.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 EWebURL: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.ITabFormats Field

Summary

Represents field ITabFormats.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
protected
 ITabFormats : TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.ItemsEditor Field

Summary

Represents field ItemsEditor.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
protected
 ItemsEditor : TItemsEditor;

Field Value

Type: TItemsEditor

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label10 Field

Summary

Represents field Label10.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label10: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label11 Field

Summary

Represents field Label11.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label11: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label12 Field

Summary

Represents field Label12.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label12: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label13 Field

Summary

Represents field Label13.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label13: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label14 Field

Summary

Represents field Label14.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label14: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label15 Field

Summary

Represents field Label15.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label15: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label16 Field

Summary

Represents field Label16.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label16: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label17 Field

Summary

Represents field Label17.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label17: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label18 Field

Summary

Represents field Label18.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label18: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label19 Field

Summary

Represents field Label19.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label19: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label2 Field

Summary

Represents field Label2.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label20 Field

Summary

Represents field Label20.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label20: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label21 Field

Summary

Represents field Label21.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label21: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label22 Field

Summary

Represents field Label22.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label22: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label23 Field

Summary

Represents field Label23.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label23: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label3 Field

Summary

Represents field Label3.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label4 Field

Summary

Represents field Label4.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label5 Field

Summary

Represents field Label5.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label5: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label6 Field

Summary

Represents field Label6.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label6: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label7 Field

Summary

Represents field Label7.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label7: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label8 Field

Summary

Represents field Label8.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label8: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Label9 Field

Summary

Represents field Label9.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Label9: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.LayoutWebData Field

Summary

Represents field LayoutWebData.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 LayoutWebData: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.LDBExclude Field

Summary

Represents field LDBExclude.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 LDBExclude: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.LDBInclude Field

Summary

Represents field LDBInclude.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 LDBInclude: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.LFileMissing Field

Summary

Represents field LFileMissing.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 LFileMissing: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.LFolderMissing Field

Summary

Represents field LFolderMissing.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 LFolderMissing: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.LFTPStatus Field

Summary

Represents field LFTPStatus.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 LFTPStatus: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.LWebTest Field

Summary

Represents field LWebTest.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 LWebTest: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.MemoDBTest Field

Summary

Represents field MemoDBTest.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 MemoDBTest: TMemo;

Field Value

Type: TMemo

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.MemoSQL Field

Summary

Represents field MemoSQL.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 MemoSQL: TMemo;

Field Value

Type: TMemo

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.OpenDialog1 Field

Summary

Represents field OpenDialog1.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 OpenDialog1: TOpenDialog;

Field Value

Type: TOpenDialog

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.OpenDialogDatabase Field

Summary

Represents field OpenDialogDatabase.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 OpenDialogDatabase: TOpenDialog;

Field Value

Type: TOpenDialog

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.PageControl3 Field

Summary

Represents field PageControl3.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 PageControl3: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.PageControlDBItems Field

Summary

Represents field PageControlDBItems.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 PageControlDBItems: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.PageControlFile Field

Summary

Represents field PageControlFile.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 PageControlFile: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.PageControlWeb Field

Summary

Represents field PageControlWeb.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 PageControlWeb: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.PanelButtons Field

Summary

Represents field PanelButtons.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 PanelButtons: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.RGKind Field

Summary

Represents field RGKind.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 RGKind: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.SQL Field

Summary

Represents field SQL.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 SQL: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.TabConnection Field

Summary

Represents field TabConnection.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 TabConnection: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.TabDatabase Field

Summary

Represents field TabDatabase.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 TabDatabase: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.TabDBOptions Field

Summary

Represents field TabDBOptions.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 TabDBOptions: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.TabFile Field

Summary

Represents field TabFile.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 TabFile: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.TabFiles Field

Summary

Represents field TabFiles.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 TabFiles: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.TabFolder Field

Summary

Represents field TabFolder.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 TabFolder: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.TabFTP Field

Summary

Represents field TabFTP.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 TabFTP: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.TabHttpProxy Field

Summary

Represents field TabHttpProxy.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 TabHttpProxy: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.TabHttpServer Field

Summary

Represents field TabHttpServer.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 TabHttpServer: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.TabItemAllDB Field

Summary

Represents field TabItemAllDB.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 TabItemAllDB: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.TabManual Field

Summary

Represents field TabManual.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 TabManual: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.TabSources Field

Summary

Represents field TabSources.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 TabSources: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.TabSQL Field

Summary

Represents field TabSQL.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 TabSQL: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.TabStyle Field

Summary

Represents field TabStyle.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 TabStyle: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.TabWeb Field

Summary

Represents field TabWeb.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 TabWeb: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.UDFTPPort Field

Summary

Represents field UDFTPPort.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 UDFTPPort: TUpDown;

Field Value

Type: TUpDown

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.UDPort Field

Summary

Represents field UDPort.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 UDPort: TUpDown;

Field Value

Type: TUpDown

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.UDProxyPort Field

Summary

Represents field UDProxyPort.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 UDProxyPort: TUpDown;

Field Value

Type: TUpDown

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


TDataEditor.UDTimeout Field

Summary

Represents field UDTimeout.

Namespace: VCLBI.Editor.Data
Syntax
Delphi
published
 UDTimeout: TUpDown;

Field Value

Type: TUpDown

See Also

Reference

  • TDataEditor
  • VCLBI.Editor.Data


VCLBI.Editor.Data.Links Namespace

Summary

Represents namespace VCLBI.Editor.Data.Links.

Classes
Name | Description
TDataLinksEditor | Represents type TDataLinksEditor.
Top


VCLBI.Editor.Data.Links Classes

Classes
Name | Description
TDataLinksEditor | Represents type TDataLinksEditor.
Top


TDataLinksEditor Class

Summary

Represents type TDataLinksEditor.

Namespace: VCLBI.Editor.Data.Links
Inheritance Hierarchy
TForm
VCLBI.Editor.Data.Links.TDataLinksEditor
Syntax
Delphi
type
 TDataLinksEditor = class(TForm)
 end;

The TDataLinksEditor type exposes the following members.

Methods
Show:
Name | Description
BAddClick(TObject) | Represents method BAddClick(TObject).
BDeleteClick(TObject) | Represents method BDeleteClick(TObject).
BIGrid1DataChange(TObject) | Represents method BIGrid1DataChange(TObject).
EDetailChange(TObject) | Represents method EDetailChange(TObject).
EMasterChange(TObject) | Represents method EMasterChange(TObject).
Embed(TComponent,TWinControl) | Represents method Embed(TComponent,TWinControl).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
Refresh(TDataDefinition) | Represents method Refresh(TDataDefinition).
SpeedButton1Click(TObject) | Represents method SpeedButton1Click(TObject).
SpeedButton2Click(TObject) | Represents method SpeedButton2Click(TObject).
Top
Fields
Show:
Name | Description
BAdd | Represents field BAdd.
BDelete | Represents field BDelete.
BIGrid1 | Represents field BIGrid1.
EDetail | Represents field EDetail.
EMaster | Represents field EMaster.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Panel2 | Represents field Panel2.
PanelLink | Represents field PanelLink.
SpeedButton1 | Represents field SpeedButton1.
SpeedButton2 | Represents field SpeedButton2.
Top
See Also

Reference

  • VCLBI.Editor.Data.Links


TDataLinksEditor Methods

Methods
Name | Description
BAddClick(TObject) | Represents method BAddClick(TObject).
BDeleteClick(TObject) | Represents method BDeleteClick(TObject).
BIGrid1DataChange(TObject) | Represents method BIGrid1DataChange(TObject).
EDetailChange(TObject) | Represents method EDetailChange(TObject).
EMasterChange(TObject) | Represents method EMasterChange(TObject).
Embed(TComponent,TWinControl) | Represents method Embed(TComponent,TWinControl).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
Refresh(TDataDefinition) | Represents method Refresh(TDataDefinition).
SpeedButton1Click(TObject) | Represents method SpeedButton1Click(TObject).
SpeedButton2Click(TObject) | Represents method SpeedButton2Click(TObject).
Top


TDataLinksEditor.BAddClick(TObject) Method

Summary

Represents method BAddClick(TObject).

Namespace: VCLBI.Editor.Data.Links
Syntax
Delphi
published
 procedure BAddClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataLinksEditor
  • VCLBI.Editor.Data.Links


TDataLinksEditor.BDeleteClick(TObject) Method

Summary

Represents method BDeleteClick(TObject).

Namespace: VCLBI.Editor.Data.Links
Syntax
Delphi
published
 procedure BDeleteClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataLinksEditor
  • VCLBI.Editor.Data.Links


TDataLinksEditor.BIGrid1DataChange(TObject) Method

Summary

Represents method BIGrid1DataChange(TObject).

Namespace: VCLBI.Editor.Data.Links
Syntax
Delphi
published
 procedure BIGrid1DataChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataLinksEditor
  • VCLBI.Editor.Data.Links


TDataLinksEditor.EDetailChange(TObject) Method

Summary

Represents method EDetailChange(TObject).

Namespace: VCLBI.Editor.Data.Links
Syntax
Delphi
published
 procedure EDetailChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataLinksEditor
  • VCLBI.Editor.Data.Links


TDataLinksEditor.EMasterChange(TObject) Method

Summary

Represents method EMasterChange(TObject).

Namespace: VCLBI.Editor.Data.Links
Syntax
Delphi
published
 procedure EMasterChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataLinksEditor
  • VCLBI.Editor.Data.Links


TDataLinksEditor.Embed(TComponent,TWinControl) Method

Summary

Represents method Embed(TComponent,TWinControl).

Namespace: VCLBI.Editor.Data.Links
Syntax
Delphi
public
 class function Embed(const AOwner:TComponent;
 const AParent:TWinControl):TDataLinksEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

Return Value

Type: TDataLinksEditor

See Also

Reference

  • TDataLinksEditor
  • VCLBI.Editor.Data.Links


TDataLinksEditor.FormDestroy(TObject) Method

Summary

Represents method FormDestroy(TObject).

Namespace: VCLBI.Editor.Data.Links
Syntax
Delphi
published
 procedure FormDestroy(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataLinksEditor
  • VCLBI.Editor.Data.Links


TDataLinksEditor.Refresh(TDataDefinition) Method

Summary

Represents method Refresh(TDataDefinition).

Namespace: VCLBI.Editor.Data.Links
Syntax
Delphi
public
 procedure Refresh(const AData:TDataDefinition);

Parameters

AData
Type: TDataDefinition

See Also

Reference

  • TDataLinksEditor
  • VCLBI.Editor.Data.Links


TDataLinksEditor.SpeedButton1Click(TObject) Method

Summary

Represents method SpeedButton1Click(TObject).

Namespace: VCLBI.Editor.Data.Links
Syntax
Delphi
published
 procedure SpeedButton1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataLinksEditor
  • VCLBI.Editor.Data.Links


TDataLinksEditor.SpeedButton2Click(TObject) Method

Summary

Represents method SpeedButton2Click(TObject).

Namespace: VCLBI.Editor.Data.Links
Syntax
Delphi
published
 procedure SpeedButton2Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataLinksEditor
  • VCLBI.Editor.Data.Links


TDataLinksEditor Fields

Fields
Name | Description
BAdd | Represents field BAdd.
BDelete | Represents field BDelete.
BIGrid1 | Represents field BIGrid1.
EDetail | Represents field EDetail.
EMaster | Represents field EMaster.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Panel2 | Represents field Panel2.
PanelLink | Represents field PanelLink.
SpeedButton1 | Represents field SpeedButton1.
SpeedButton2 | Represents field SpeedButton2.
Top


TDataLinksEditor.BAdd Field

Summary

Represents field BAdd.

Namespace: VCLBI.Editor.Data.Links
Syntax
Delphi
published
 BAdd: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataLinksEditor
  • VCLBI.Editor.Data.Links


TDataLinksEditor.BDelete Field

Summary

Represents field BDelete.

Namespace: VCLBI.Editor.Data.Links
Syntax
Delphi
published
 BDelete: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataLinksEditor
  • VCLBI.Editor.Data.Links


TDataLinksEditor.BIGrid1 Field

Summary

Represents field BIGrid1.

Namespace: VCLBI.Editor.Data.Links
Syntax
Delphi
published
 BIGrid1: TBIGrid;

Field Value

Type: TBIGrid

See Also

Reference

  • TDataLinksEditor
  • VCLBI.Editor.Data.Links


TDataLinksEditor.EDetail Field

Summary

Represents field EDetail.

Namespace: VCLBI.Editor.Data.Links
Syntax
Delphi
published
 EDetail: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataLinksEditor
  • VCLBI.Editor.Data.Links


TDataLinksEditor.EMaster Field

Summary

Represents field EMaster.

Namespace: VCLBI.Editor.Data.Links
Syntax
Delphi
published
 EMaster: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataLinksEditor
  • VCLBI.Editor.Data.Links


TDataLinksEditor.Label3 Field

Summary

Represents field Label3.

Namespace: VCLBI.Editor.Data.Links
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataLinksEditor
  • VCLBI.Editor.Data.Links


TDataLinksEditor.Label4 Field

Summary

Represents field Label4.

Namespace: VCLBI.Editor.Data.Links
Syntax
Delphi
published
 Label4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataLinksEditor
  • VCLBI.Editor.Data.Links


TDataLinksEditor.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.Editor.Data.Links
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataLinksEditor
  • VCLBI.Editor.Data.Links


TDataLinksEditor.PanelLink Field

Summary

Represents field PanelLink.

Namespace: VCLBI.Editor.Data.Links
Syntax
Delphi
published
 PanelLink: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataLinksEditor
  • VCLBI.Editor.Data.Links


TDataLinksEditor.SpeedButton1 Field

Summary

Represents field SpeedButton1.

Namespace: VCLBI.Editor.Data.Links
Syntax
Delphi
published
 SpeedButton1: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TDataLinksEditor
  • VCLBI.Editor.Data.Links


TDataLinksEditor.SpeedButton2 Field

Summary

Represents field SpeedButton2.

Namespace: VCLBI.Editor.Data.Links
Syntax
Delphi
published
 SpeedButton2: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TDataLinksEditor
  • VCLBI.Editor.Data.Links


VCLBI.Editor.DataComponent Namespace

Summary

Represents namespace VCLBI.Editor.DataComponent.

Classes
Name | Description
TDataComponent | Represents type TDataComponent.
TDataItemAccess | Represents type TDataItemAccess.
Top
Delegates
Name | Description
TDataComponent.TBIAddComponent | Represents type TBIAddComponent.
TFilterEvent | Represents type TFilterEvent.
Top


VCLBI.Editor.DataComponent Classes

Classes
Name | Description
TDataComponent | Represents type TDataComponent.
TDataItemAccess | Represents type TDataItemAccess.
Top


TDataComponent Class

Summary

Represents type TDataComponent.

Namespace: VCLBI.Editor.DataComponent
Inheritance Hierarchy
TForm
VCLBI.Editor.DataComponent.TDataComponent
VCLBI.DataSelect.TDataComponentAccess
Syntax
Delphi
type
 TDataComponent = class(TForm)
 end;

The TDataComponent type exposes the following members.

Properties
Show:
Name | Description
OnSelected | Represents property OnSelected.
Top
Methods
Show:
Name | Description
Add(TComponent,TComponent) | Overloaded. Represents method Add(TComponent,TComponent).
Add(TTreeNode,TComponent,String) | Overloaded. Represents method Add(TTreeNode,TComponent,String).
Choose(TComponent,TComponent,TComponent) | Overloaded. Represents method Choose(TComponent,TComponent,TComponent).
Choose(TComponent,TDataItem,TDataItem) | Overloaded. Represents method Choose(TComponent,TDataItem,TDataItem).
ChooseMany(TComponent,TDataItem,TDataItem,Boolean) | Represents method ChooseMany(TComponent,TDataItem,TDataItem,Boolean).
Data(TComponent) | Represents method Data(TComponent).
Embedd(TComponent,TWinControl,TDataItem) | Represents method Embedd(TComponent,TWinControl,TDataItem).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormShow(TObject) | Represents method FormShow(TObject).
Import(TComponent,TObject) | Represents method Import(TComponent,TObject).
NodeOf(TObject) | Represents method NodeOf(TObject).
PopupMenu1Popup(TObject) | Represents method PopupMenu1Popup(TObject).
Select(TObject) | Represents method Select(TObject).
Selected | Represents method Selected.
SelectedData | Represents method SelectedData.
SelectedHasData | Represents method SelectedHasData.
SelectedItems | Represents method SelectedItems.
TreeChange(TObject,TTreeNode) | Represents method TreeChange(TObject,TTreeNode).
TreeExpanding(TObject,TTreeNode,Boolean) | Represents method TreeExpanding(TObject,TTreeNode,Boolean).
TryFreeData | Represents method TryFreeData.
ViewData1Click(TObject) | Represents method ViewData1Click(TObject).
Top
Events
Show:
Name | Description
OnFilter | Represents property OnFilter.
Top
Fields
Show:
Name | Description
BCancel | Represents field BCancel.
BOk | Represents field BOk.
FCurrent | Represents field FCurrent.
IEdited | Represents field IEdited.
OnGetDesignerNames | Represents field OnGetDesignerNames.
PanelButtons | Represents field PanelButtons.
PanelOk | Represents field PanelOk.
PopupMenu1 | Represents field PopupMenu1.
Tree | Represents field Tree.
ViewData1 | Represents field ViewData1.
Top
See Also

Reference

  • VCLBI.Editor.DataComponent


TDataComponent Properties

Properties
Name | Description
OnSelected | Represents property OnSelected.
Top


TDataComponent.OnSelected Property

Summary

Represents property OnSelected.

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
public
 property OnSelected:TNotifyEvent read FOnSelected write FOnSelected;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent Methods

Methods
Name | Description
Add(TComponent,TComponent) | Overloaded. Represents method Add(TComponent,TComponent).
Add(TTreeNode,TComponent,String) | Overloaded. Represents method Add(TTreeNode,TComponent,String).
Choose(TComponent,TComponent,TComponent) | Overloaded. Represents method Choose(TComponent,TComponent,TComponent).
Choose(TComponent,TDataItem,TDataItem) | Overloaded. Represents method Choose(TComponent,TDataItem,TDataItem).
ChooseMany(TComponent,TDataItem,TDataItem,Boolean) | Represents method ChooseMany(TComponent,TDataItem,TDataItem,Boolean).
Data(TComponent) | Represents method Data(TComponent).
Embedd(TComponent,TWinControl,TDataItem) | Represents method Embedd(TComponent,TWinControl,TDataItem).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormShow(TObject) | Represents method FormShow(TObject).
Import(TComponent,TObject) | Represents method Import(TComponent,TObject).
NodeOf(TObject) | Represents method NodeOf(TObject).
PopupMenu1Popup(TObject) | Represents method PopupMenu1Popup(TObject).
Select(TObject) | Represents method Select(TObject).
Selected | Represents method Selected.
SelectedData | Represents method SelectedData.
SelectedHasData | Represents method SelectedHasData.
SelectedItems | Represents method SelectedItems.
TreeChange(TObject,TTreeNode) | Represents method TreeChange(TObject,TTreeNode).
TreeExpanding(TObject,TTreeNode,Boolean) | Represents method TreeExpanding(TObject,TTreeNode,Boolean).
TryFreeData | Represents method TryFreeData.
ViewData1Click(TObject) | Represents method ViewData1Click(TObject).
Top


TDataComponent.Add(TComponent,TComponent) Method

Summary

Represents method Add(TComponent,TComponent).

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
protected
 procedure Add(const AParent,AComponent:TComponent); overload;

Parameters

AParent
Type: TComponent

AComponent
Type: TComponent

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.Add(TTreeNode,TComponent,String) Method

Summary

Represents method Add(TTreeNode,TComponent,String).

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
protected
 procedure Add(const AParent:TTreeNode; const AComponent:TComponent; const AName:String); overload;

Parameters

AParent
Type: TTreeNode

AComponent
Type: TComponent

AName
Type: String

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.Choose(TComponent,TComponent,TComponent) Method

Summary

Represents method Choose(TComponent,TComponent,TComponent).

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
public
 class function Choose(const AOwner,AEdited:TComponent;
 const ACurrent:TComponent=nil):TComponent; overload; static;

Parameters

AOwner
Type: TComponent

AEdited
Type: TComponent

ACurrent
Type: TComponent

Return Value

Type: TComponent

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.Choose(TComponent,TDataItem,TDataItem) Method

Summary

Represents method Choose(TComponent,TDataItem,TDataItem).

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
public
 class function Choose(const AOwner:TComponent; const ARoot:TDataItem;
 const ACurrent:TDataItem=nil):TDataItem; overload; static;

Parameters

AOwner
Type: TComponent

ARoot
Type: TDataItem

ACurrent
Type: TDataItem

Return Value

Type: TDataItem

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.ChooseMany(TComponent,TDataItem,TDataItem,Boolean) Method

Summary

Represents method ChooseMany(TComponent,TDataItem,TDataItem,Boolean).

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
public
 class function ChooseMany(const AOwner:TComponent; const ARoot:TDataItem;
 const ACurrent:TDataItem=nil;
 const Compatible:Boolean=False):TDataArray; static;

Parameters

AOwner
Type: TComponent

ARoot
Type: TDataItem

ACurrent
Type: TDataItem

Compatible
Type: Boolean

Return Value

Type: TDataArray

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.Data(TComponent) Method

Summary

Represents method Data(TComponent).

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
public
 function Data(const AOwner:TComponent):TDataItem;

Parameters

AOwner
Type: TComponent

Return Value

Type: TDataItem

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.Embedd(TComponent,TWinControl,TDataItem) Method

Summary

Represents method Embedd(TComponent,TWinControl,TDataItem).

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent;
 const AParent:TWinControl;
 const ARoot:TDataItem):TDataComponent; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

ARoot
Type: TDataItem

Return Value

Type: TDataComponent

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.FormClose(TObject,TCloseAction) Method

Summary

Represents method FormClose(TObject,TCloseAction).

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
published
 procedure FormClose(Sender: TObject; var Action: TCloseAction);

Parameters

Sender
Type: TObject

Action
Type: TCloseAction

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.Import(TComponent,TObject) Method

Summary

Represents method Import(TComponent,TObject).

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
public
 class function Import(const AOwner:TComponent; const AObject:TObject):TDataItem; static;

Parameters

AOwner
Type: TComponent

AObject
Type: TObject

Return Value

Type: TDataItem

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.NodeOf(TObject) Method

Summary

Represents method NodeOf(TObject).

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
protected
 function NodeOf(const AObject:TObject):TTreeNode;

Parameters

AObject
Type: TObject

Return Value

Type: TTreeNode

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.PopupMenu1Popup(TObject) Method

Summary

Represents method PopupMenu1Popup(TObject).

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
published
 procedure PopupMenu1Popup(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.Select(TObject) Method

Summary

Represents method Select(TObject).

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
public
 procedure Select(const AObject:TObject);

Parameters

AObject
Type: TObject

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.Selected Method

Summary

Represents method Selected.

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
public
 function Selected:TComponent;

Return Value

Type: TComponent

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.SelectedData Method

Summary

Represents method SelectedData.

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
public
 function SelectedData:TDataItem;

Return Value

Type: TDataItem

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.SelectedHasData Method

Summary

Represents method SelectedHasData.

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
protected
 function SelectedHasData:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.SelectedItems Method

Summary

Represents method SelectedItems.

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
public
 function SelectedItems:TDataArray;

Return Value

Type: TDataArray

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.TreeChange(TObject,TTreeNode) Method

Summary

Represents method TreeChange(TObject,TTreeNode).

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
published
 procedure TreeChange(Sender: TObject; Node: TTreeNode);

Parameters

Sender
Type: TObject

Node
Type: TTreeNode

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.TreeExpanding(TObject,TTreeNode,Boolean) Method

Summary

Represents method TreeExpanding(TObject,TTreeNode,Boolean).

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
published
 procedure TreeExpanding(Sender: TObject; Node: TTreeNode;
 var AllowExpansion: Boolean);

Parameters

Sender
Type: TObject

Node
Type: TTreeNode

AllowExpansion
Type: Boolean

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.TryFreeData Method

Summary

Represents method TryFreeData.

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
protected
 procedure TryFreeData;
See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.ViewData1Click(TObject) Method

Summary

Represents method ViewData1Click(TObject).

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
published
 procedure ViewData1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent Events

Events
Name | Description
OnFilter | Represents property OnFilter.
Top


TDataComponent.OnFilter Event

Summary

Represents property OnFilter.

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
public
 property OnFilter:TFilterEvent read FOnFilter write FOnFilter;

Value

Type: TFilterEvent

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent Fields

Fields
Name | Description
BCancel | Represents field BCancel.
BOk | Represents field BOk.
FCurrent | Represents field FCurrent.
IEdited | Represents field IEdited.
OnGetDesignerNames | Represents field OnGetDesignerNames.
PanelButtons | Represents field PanelButtons.
PanelOk | Represents field PanelOk.
PopupMenu1 | Represents field PopupMenu1.
Tree | Represents field Tree.
ViewData1 | Represents field ViewData1.
Top


TDataComponent.BCancel Field

Summary

Represents field BCancel.

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
published
 BCancel: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.BOk Field

Summary

Represents field BOk.

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
published
 BOk: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.FCurrent Field

Summary

Represents field FCurrent.

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
protected
 FCurrent : TObject;

Field Value

Type: TObject

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.IEdited Field

Summary

Represents field IEdited.

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
protected
 IEdited : TComponent;

Field Value

Type: TComponent

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.OnGetDesignerNames Field

Summary

Represents field OnGetDesignerNames.

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
public
 class
 var OnGetDesignerNames : TProc<TBIAddComponent,TComponent>;

Field Value

Type: TProc<TBIAddComponent,TComponent>

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.PanelButtons Field

Summary

Represents field PanelButtons.

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
published
 PanelButtons: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.PanelOk Field

Summary

Represents field PanelOk.

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
published
 PanelOk: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.PopupMenu1 Field

Summary

Represents field PopupMenu1.

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
published
 PopupMenu1: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.Tree Field

Summary

Represents field Tree.

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
published
 Tree: TTreeView;

Field Value

Type: TTreeView

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataComponent.ViewData1 Field

Summary

Represents field ViewData1.

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
published
 ViewData1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TDataItemAccess Class

Summary

Represents type TDataItemAccess.

Namespace: VCLBI.Editor.DataComponent
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
VCLBI.Editor.DataComponent.TDataItemAccess
Syntax
Delphi
type
 TDataItemAccess=class(TDataItem);
See Also

Reference

  • VCLBI.Editor.DataComponent


VCLBI.Editor.DataComponent Delegates

Delegates
Name | Description
TDataComponent.TBIAddComponent | Represents type TBIAddComponent.
TFilterEvent | Represents type TFilterEvent.
Top


TDataComponent.TBIAddComponent Delegate

Summary

Represents type TBIAddComponent.

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
public
type
 TBIAddComponent=procedure(const AParent:TTreeNode; const AComponent:TComponent; const AName:String) of object;
See Also

Reference

  • TDataComponent
  • VCLBI.Editor.DataComponent


TFilterEvent Delegate

Summary

Represents type TFilterEvent.

Namespace: VCLBI.Editor.DataComponent
Syntax
Delphi
type
 TFilterEvent=procedure(Sender: TComponent; var Valid:Boolean) of object;
See Also

Reference

  • VCLBI.Editor.DataComponent


VCLBI.Editor.DataRank Namespace

Summary

Represents namespace VCLBI.Editor.DataRank.

Classes
Name | Description
TDataRankEditor | Represents type TDataRankEditor.
Top


VCLBI.Editor.DataRank Classes

Classes
Name | Description
TDataRankEditor | Represents type TDataRankEditor.
Top


TDataRankEditor Class

Summary

Represents type TDataRankEditor.

Namespace: VCLBI.Editor.DataRank
Inheritance Hierarchy
TForm
VCLBI.Editor.DataRank.TDataRankEditor
Syntax
Delphi
type
 TDataRankEditor = class(TForm)
 end;

The TDataRankEditor type exposes the following members.

Methods
Show:
Name | Description
CBAscendingClick(TObject) | Represents method CBAscendingClick(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
Top
Fields
Show:
Name | Description
CBAscending | Represents field CBAscending.
Top
See Also

Reference

  • VCLBI.Editor.DataRank


TDataRankEditor Methods

Methods
Name | Description
CBAscendingClick(TObject) | Represents method CBAscendingClick(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
Top


TDataRankEditor.CBAscendingClick(TObject) Method

Summary

Represents method CBAscendingClick(TObject).

Namespace: VCLBI.Editor.DataRank
Syntax
Delphi
published
 procedure CBAscendingClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataRankEditor
  • VCLBI.Editor.DataRank


TDataRankEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Editor.DataRank
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataRankEditor
  • VCLBI.Editor.DataRank


TDataRankEditor Fields

Fields
Name | Description
CBAscending | Represents field CBAscending.
Top


TDataRankEditor.CBAscending Field

Summary

Represents field CBAscending.

Namespace: VCLBI.Editor.DataRank
Syntax
Delphi
published
 CBAscending: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataRankEditor
  • VCLBI.Editor.DataRank


VCLBI.Editor.DataSelect Namespace

Summary

Represents namespace VCLBI.Editor.DataSelect.

Classes
Name | Description
TDataSelectEditor | Represents type TDataSelectEditor.
Top


VCLBI.Editor.DataSelect Classes

Classes
Name | Description
TDataSelectEditor | Represents type TDataSelectEditor.
Top


TDataSelectEditor Class

Summary

Represents type TDataSelectEditor.

Namespace: VCLBI.Editor.DataSelect
Inheritance Hierarchy
TForm
VCLBI.Editor.DataSelect.TDataSelectEditor
Syntax
Delphi
type
 TDataSelectEditor = class(TForm)
 end;

The TDataSelectEditor type exposes the following members.

Properties
Show:
Name | Description
OnChange | Represents property OnChange.
Select | Represents property Select.
Top
Methods
Show:
Name | Description
BAddClick(TObject) | Represents method BAddClick(TObject).
BAddSortClick(TObject) | Represents method BAddSortClick(TObject).
BDownClick(TObject) | Represents method BDownClick(TObject).
BDownSortClick(TObject) | Represents method BDownSortClick(TObject).
BRemoveItemClick(TObject) | Represents method BRemoveItemClick(TObject).
BRemoveSortClick(TObject) | Represents method BRemoveSortClick(TObject).
BUpClick(TObject) | Represents method BUpClick(TObject).
BUpSortClick(TObject) | Represents method BUpSortClick(TObject).
CBAscendingClick(TObject) | Represents method CBAscendingClick(TObject).
CBDistinctClick(TObject) | Represents method CBDistinctClick(TObject).
CBIgnoreCaseClick(TObject) | Represents method CBIgnoreCaseClick(TObject).
Data1Click(TObject) | Represents method Data1Click(TObject).
Edit(TComponent,TDataSelect,TNotifyEvent) | Represents method Edit(TComponent,TDataSelect,TNotifyEvent).
EFilterChange(TObject) | Represents method EFilterChange(TObject).
EItemExpressionChange(TObject) | Represents method EItemExpressionChange(TObject).
EItemNameChange(TObject) | Represents method EItemNameChange(TObject).
EMaxChange(TObject) | Represents method EMaxChange(TObject).
ESortExpressionChange(TObject) | Represents method ESortExpressionChange(TObject).
Expression1Click(TObject) | Represents method Expression1Click(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
LBSortClick(TObject) | Represents method LBSortClick(TObject).
LBSortClickCheck(TObject) | Represents method LBSortClickCheck(TObject).
LBSortDragDrop(TObject,TObject,Integer,Integer) | Represents method LBSortDragDrop(TObject,TObject,Integer,Integer).
LBSortDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method LBSortDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
LItemsClick(TObject) | Represents method LItemsClick(TObject).
LItemsClickCheck(TObject) | Represents method LItemsClickCheck(TObject).
LItemsDragDrop(TObject,TObject,Integer,Integer) | Represents method LItemsDragDrop(TObject,TObject,Integer,Integer).
LItemsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method LItemsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
MenuItem1Click(TObject) | Represents method MenuItem1Click(TObject).
MenuItem2Click(TObject) | Represents method MenuItem2Click(TObject).
Refresh(TDataSelect) | Represents method Refresh(TDataSelect).
Top
Fields
Show:
Name | Description
BAdd | Represents field BAdd.
BAddSort | Represents field BAddSort.
BDown | Represents field BDown.
BDownSort | Represents field BDownSort.
BOK | Represents field BOK.
BRemoveItem | Represents field BRemoveItem.
BRemoveSort | Represents field BRemoveSort.
BUp | Represents field BUp.
BUpSort | Represents field BUpSort.
Button2 | Represents field Button2.
CBAscending | Represents field CBAscending.
CBDistinct | Represents field CBDistinct.
CBIgnoreCase | Represents field CBIgnoreCase.
Data1 | Represents field Data1.
EFilter | Represents field EFilter.
EItemExpression | Represents field EItemExpression.
EItemName | Represents field EItemName.
EMax | Represents field EMax.
ESortExpression | Represents field ESortExpression.
Expression1 | Represents field Expression1.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
LBSort | Represents field LBSort.
LFilter | Represents field LFilter.
LItemError | Represents field LItemError.
LItems | Represents field LItems.
LSortError | Represents field LSortError.
LSortExpression | Represents field LSortExpression.
MemoSQL | Represents field MemoSQL.
MenuItem1 | Represents field MenuItem1.
MenuItem2 | Represents field MenuItem2.
PageControl1 | Represents field PageControl1.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
Panel5 | Represents field Panel5.
Panel9 | Represents field Panel9.
PanelButtons | Represents field PanelButtons.
PopupItems | Represents field PopupItems.
PopupSort | Represents field PopupSort.
TabFilter | Represents field TabFilter.
TabItems | Represents field TabItems.
TabSort | Represents field TabSort.
TabSQL | Represents field TabSQL.
Top
See Also

Reference

  • VCLBI.Editor.DataSelect


TDataSelectEditor Properties

Properties
Name | Description
OnChange | Represents property OnChange.
Select | Represents property Select.
Top


TDataSelectEditor.OnChange Property

Summary

Represents property OnChange.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
public
 property OnChange:TNotifyEvent read FOnChanged write FOnChanged;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.Select Property

Summary

Represents property Select.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
public
 property Select:TDataSelect read ISelect;

Property Value

Type: TDataSelect

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor Methods

Methods
Name | Description
BAddClick(TObject) | Represents method BAddClick(TObject).
BAddSortClick(TObject) | Represents method BAddSortClick(TObject).
BDownClick(TObject) | Represents method BDownClick(TObject).
BDownSortClick(TObject) | Represents method BDownSortClick(TObject).
BRemoveItemClick(TObject) | Represents method BRemoveItemClick(TObject).
BRemoveSortClick(TObject) | Represents method BRemoveSortClick(TObject).
BUpClick(TObject) | Represents method BUpClick(TObject).
BUpSortClick(TObject) | Represents method BUpSortClick(TObject).
CBAscendingClick(TObject) | Represents method CBAscendingClick(TObject).
CBDistinctClick(TObject) | Represents method CBDistinctClick(TObject).
CBIgnoreCaseClick(TObject) | Represents method CBIgnoreCaseClick(TObject).
Data1Click(TObject) | Represents method Data1Click(TObject).
Edit(TComponent,TDataSelect,TNotifyEvent) | Represents method Edit(TComponent,TDataSelect,TNotifyEvent).
EFilterChange(TObject) | Represents method EFilterChange(TObject).
EItemExpressionChange(TObject) | Represents method EItemExpressionChange(TObject).
EItemNameChange(TObject) | Represents method EItemNameChange(TObject).
EMaxChange(TObject) | Represents method EMaxChange(TObject).
ESortExpressionChange(TObject) | Represents method ESortExpressionChange(TObject).
Expression1Click(TObject) | Represents method Expression1Click(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
LBSortClick(TObject) | Represents method LBSortClick(TObject).
LBSortClickCheck(TObject) | Represents method LBSortClickCheck(TObject).
LBSortDragDrop(TObject,TObject,Integer,Integer) | Represents method LBSortDragDrop(TObject,TObject,Integer,Integer).
LBSortDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method LBSortDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
LItemsClick(TObject) | Represents method LItemsClick(TObject).
LItemsClickCheck(TObject) | Represents method LItemsClickCheck(TObject).
LItemsDragDrop(TObject,TObject,Integer,Integer) | Represents method LItemsDragDrop(TObject,TObject,Integer,Integer).
LItemsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method LItemsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
MenuItem1Click(TObject) | Represents method MenuItem1Click(TObject).
MenuItem2Click(TObject) | Represents method MenuItem2Click(TObject).
Refresh(TDataSelect) | Represents method Refresh(TDataSelect).
Top


TDataSelectEditor.BAddClick(TObject) Method

Summary

Represents method BAddClick(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure BAddClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.BAddSortClick(TObject) Method

Summary

Represents method BAddSortClick(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure BAddSortClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.BDownClick(TObject) Method

Summary

Represents method BDownClick(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure BDownClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.BDownSortClick(TObject) Method

Summary

Represents method BDownSortClick(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure BDownSortClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.BRemoveItemClick(TObject) Method

Summary

Represents method BRemoveItemClick(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure BRemoveItemClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.BRemoveSortClick(TObject) Method

Summary

Represents method BRemoveSortClick(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure BRemoveSortClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.BUpClick(TObject) Method

Summary

Represents method BUpClick(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure BUpClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.BUpSortClick(TObject) Method

Summary

Represents method BUpSortClick(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure BUpSortClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.CBAscendingClick(TObject) Method

Summary

Represents method CBAscendingClick(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure CBAscendingClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.CBDistinctClick(TObject) Method

Summary

Represents method CBDistinctClick(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure CBDistinctClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.CBIgnoreCaseClick(TObject) Method

Summary

Represents method CBIgnoreCaseClick(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure CBIgnoreCaseClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.Data1Click(TObject) Method

Summary

Represents method Data1Click(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure Data1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.Edit(TComponent,TDataSelect,TNotifyEvent) Method

Summary

Represents method Edit(TComponent,TDataSelect,TNotifyEvent).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent;
 const ASelect:TDataSelect;
 const OnChanged:TNotifyEvent=nil):Boolean; static;

Parameters

AOwner
Type: TComponent

ASelect
Type: TDataSelect

OnChanged
Type: TNotifyEvent

Return Value

Type: Boolean

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.EFilterChange(TObject) Method

Summary

Represents method EFilterChange(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure EFilterChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.EItemExpressionChange(TObject) Method

Summary

Represents method EItemExpressionChange(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure EItemExpressionChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.EItemNameChange(TObject) Method

Summary

Represents method EItemNameChange(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure EItemNameChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.EMaxChange(TObject) Method

Summary

Represents method EMaxChange(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure EMaxChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.ESortExpressionChange(TObject) Method

Summary

Represents method ESortExpressionChange(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure ESortExpressionChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.Expression1Click(TObject) Method

Summary

Represents method Expression1Click(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure Expression1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.LBSortClick(TObject) Method

Summary

Represents method LBSortClick(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure LBSortClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.LBSortClickCheck(TObject) Method

Summary

Represents method LBSortClickCheck(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure LBSortClickCheck(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.LBSortDragDrop(TObject,TObject,Integer,Integer) Method

Summary

Represents method LBSortDragDrop(TObject,TObject,Integer,Integer).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure LBSortDragDrop(Sender, Source: TObject; X, Y: Integer);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.LBSortDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) Method

Summary

Represents method LBSortDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure LBSortDragOver(Sender, Source: TObject; X, Y: Integer;
 State: TDragState; var Accept: Boolean);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

State
Type: TDragState

Accept
Type: Boolean

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.LItemsClick(TObject) Method

Summary

Represents method LItemsClick(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure LItemsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.LItemsClickCheck(TObject) Method

Summary

Represents method LItemsClickCheck(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure LItemsClickCheck(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.LItemsDragDrop(TObject,TObject,Integer,Integer) Method

Summary

Represents method LItemsDragDrop(TObject,TObject,Integer,Integer).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure LItemsDragDrop(Sender, Source: TObject; X, Y: Integer);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.LItemsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) Method

Summary

Represents method LItemsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure LItemsDragOver(Sender, Source: TObject; X, Y: Integer;
 State: TDragState; var Accept: Boolean);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

State
Type: TDragState

Accept
Type: Boolean

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.MenuItem1Click(TObject) Method

Summary

Represents method MenuItem1Click(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure MenuItem1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.MenuItem2Click(TObject) Method

Summary

Represents method MenuItem2Click(TObject).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 procedure MenuItem2Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.Refresh(TDataSelect) Method

Summary

Represents method Refresh(TDataSelect).

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
public
 procedure Refresh(const ASelect:TDataSelect);

Parameters

ASelect
Type: TDataSelect

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor Fields

Fields
Name | Description
BAdd | Represents field BAdd.
BAddSort | Represents field BAddSort.
BDown | Represents field BDown.
BDownSort | Represents field BDownSort.
BOK | Represents field BOK.
BRemoveItem | Represents field BRemoveItem.
BRemoveSort | Represents field BRemoveSort.
BUp | Represents field BUp.
BUpSort | Represents field BUpSort.
Button2 | Represents field Button2.
CBAscending | Represents field CBAscending.
CBDistinct | Represents field CBDistinct.
CBIgnoreCase | Represents field CBIgnoreCase.
Data1 | Represents field Data1.
EFilter | Represents field EFilter.
EItemExpression | Represents field EItemExpression.
EItemName | Represents field EItemName.
EMax | Represents field EMax.
ESortExpression | Represents field ESortExpression.
Expression1 | Represents field Expression1.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
LBSort | Represents field LBSort.
LFilter | Represents field LFilter.
LItemError | Represents field LItemError.
LItems | Represents field LItems.
LSortError | Represents field LSortError.
LSortExpression | Represents field LSortExpression.
MemoSQL | Represents field MemoSQL.
MenuItem1 | Represents field MenuItem1.
MenuItem2 | Represents field MenuItem2.
PageControl1 | Represents field PageControl1.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
Panel5 | Represents field Panel5.
Panel9 | Represents field Panel9.
PanelButtons | Represents field PanelButtons.
PopupItems | Represents field PopupItems.
PopupSort | Represents field PopupSort.
TabFilter | Represents field TabFilter.
TabItems | Represents field TabItems.
TabSort | Represents field TabSort.
TabSQL | Represents field TabSQL.
Top


TDataSelectEditor.BAdd Field

Summary

Represents field BAdd.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 BAdd: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.BAddSort Field

Summary

Represents field BAddSort.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 BAddSort: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.BDown Field

Summary

Represents field BDown.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 BDown: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.BDownSort Field

Summary

Represents field BDownSort.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 BDownSort: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.BOK Field

Summary

Represents field BOK.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 BOK: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.BRemoveItem Field

Summary

Represents field BRemoveItem.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 BRemoveItem: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.BRemoveSort Field

Summary

Represents field BRemoveSort.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 BRemoveSort: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.BUp Field

Summary

Represents field BUp.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 BUp: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.BUpSort Field

Summary

Represents field BUpSort.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 BUpSort: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.Button2 Field

Summary

Represents field Button2.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 Button2: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.CBAscending Field

Summary

Represents field CBAscending.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 CBAscending: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.CBDistinct Field

Summary

Represents field CBDistinct.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 CBDistinct: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.CBIgnoreCase Field

Summary

Represents field CBIgnoreCase.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 CBIgnoreCase: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.Data1 Field

Summary

Represents field Data1.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 Data1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.EFilter Field

Summary

Represents field EFilter.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 EFilter: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.EItemExpression Field

Summary

Represents field EItemExpression.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 EItemExpression: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.EItemName Field

Summary

Represents field EItemName.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 EItemName: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.EMax Field

Summary

Represents field EMax.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 EMax: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.ESortExpression Field

Summary

Represents field ESortExpression.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 ESortExpression: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.Expression1 Field

Summary

Represents field Expression1.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 Expression1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.Label2 Field

Summary

Represents field Label2.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.Label3 Field

Summary

Represents field Label3.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.LBSort Field

Summary

Represents field LBSort.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 LBSort: TCheckListBox;

Field Value

Type: TCheckListBox

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.LFilter Field

Summary

Represents field LFilter.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 LFilter: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.LItemError Field

Summary

Represents field LItemError.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 LItemError: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.LItems Field

Summary

Represents field LItems.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 LItems: TCheckListBox;

Field Value

Type: TCheckListBox

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.LSortError Field

Summary

Represents field LSortError.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 LSortError: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.LSortExpression Field

Summary

Represents field LSortExpression.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 LSortExpression: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.MemoSQL Field

Summary

Represents field MemoSQL.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 MemoSQL: TMemo;

Field Value

Type: TMemo

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.MenuItem1 Field

Summary

Represents field MenuItem1.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 MenuItem1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.MenuItem2 Field

Summary

Represents field MenuItem2.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 MenuItem2: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.PageControl1 Field

Summary

Represents field PageControl1.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 PageControl1: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.Panel3 Field

Summary

Represents field Panel3.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 Panel3: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.Panel4 Field

Summary

Represents field Panel4.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 Panel4: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.Panel5 Field

Summary

Represents field Panel5.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 Panel5: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.Panel9 Field

Summary

Represents field Panel9.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 Panel9: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.PanelButtons Field

Summary

Represents field PanelButtons.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 PanelButtons: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.PopupItems Field

Summary

Represents field PopupItems.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 PopupItems: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.PopupSort Field

Summary

Represents field PopupSort.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 PopupSort: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.TabFilter Field

Summary

Represents field TabFilter.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 TabFilter: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.TabItems Field

Summary

Represents field TabItems.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 TabItems: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.TabSort Field

Summary

Represents field TabSort.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 TabSort: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


TDataSelectEditor.TabSQL Field

Summary

Represents field TabSQL.

Namespace: VCLBI.Editor.DataSelect
Syntax
Delphi
published
 TabSQL: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataSelectEditor
  • VCLBI.Editor.DataSelect


VCLBI.Editor.DataSet Namespace

Summary

Represents namespace VCLBI.Editor.DataSet.

Classes
Name | Description
TBIDataSetEditor | Represents type TBIDataSetEditor.
Top


VCLBI.Editor.DataSet Classes

Classes
Name | Description
TBIDataSetEditor | Represents type TBIDataSetEditor.
Top


TBIDataSetEditor Class

Summary

Represents type TBIDataSetEditor.

Namespace: VCLBI.Editor.DataSet
Inheritance Hierarchy
TForm
VCLBI.Editor.DataSet.TBIDataSetEditor
Syntax
Delphi
type
 TBIDataSetEditor = class(TForm)
 end;

The TBIDataSetEditor type exposes the following members.

Methods
Show:
Name | Description
BOKClick(TObject) | Represents method BOKClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
CBActiveClick(TObject) | Represents method CBActiveClick(TObject).
CBPreviewClick(TObject) | Represents method CBPreviewClick(TObject).
CBReadonlyClick(TObject) | Represents method CBReadonlyClick(TObject).
Edit(TComponent,TBIDataset) | Represents method Edit(TComponent,TBIDataset).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCloseQuery(TObject,Boolean) | Represents method FormCloseQuery(TObject,Boolean).
FormShow(TObject) | Represents method FormShow(TObject).
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
Refresh(TBIDataset) | Represents method Refresh(TBIDataset).
Top
Fields
Show:
Name | Description
Backup | Represents field Backup.
BCancel | Represents field BCancel.
BITree1 | Represents field BITree1.
BOK | Represents field BOK.
Button1 | Represents field Button1.
CBActive | Represents field CBActive.
CBPreview | Represents field CBPreview.
CBReadonly | Represents field CBReadonly.
Label1 | Represents field Label1.
PageControl1 | Represents field PageControl1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
TabData | Represents field TabData.
TabOptions | Represents field TabOptions.
Top
See Also

Reference

  • VCLBI.Editor.DataSet


TBIDataSetEditor Methods

Methods
Name | Description
BOKClick(TObject) | Represents method BOKClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
CBActiveClick(TObject) | Represents method CBActiveClick(TObject).
CBPreviewClick(TObject) | Represents method CBPreviewClick(TObject).
CBReadonlyClick(TObject) | Represents method CBReadonlyClick(TObject).
Edit(TComponent,TBIDataset) | Represents method Edit(TComponent,TBIDataset).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCloseQuery(TObject,Boolean) | Represents method FormCloseQuery(TObject,Boolean).
FormShow(TObject) | Represents method FormShow(TObject).
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
Refresh(TBIDataset) | Represents method Refresh(TBIDataset).
Top


TBIDataSetEditor.BOKClick(TObject) Method

Summary

Represents method BOKClick(TObject).

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 procedure BOKClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.CBActiveClick(TObject) Method

Summary

Represents method CBActiveClick(TObject).

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 procedure CBActiveClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.CBPreviewClick(TObject) Method

Summary

Represents method CBPreviewClick(TObject).

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 procedure CBPreviewClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.CBReadonlyClick(TObject) Method

Summary

Represents method CBReadonlyClick(TObject).

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 procedure CBReadonlyClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.Edit(TComponent,TBIDataset) Method

Summary

Represents method Edit(TComponent,TBIDataset).

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const ADataSet:TBIDataSet):Boolean; static;

Parameters

AOwner
Type: TComponent

ADataSet
Type: TBIDataSet

Return Value

Type: Boolean

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.FormClose(TObject,TCloseAction) Method

Summary

Represents method FormClose(TObject,TCloseAction).

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 procedure FormClose(Sender: TObject; var Action: TCloseAction);

Parameters

Sender
Type: TObject

Action
Type: TCloseAction

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.FormCloseQuery(TObject,Boolean) Method

Summary

Represents method FormCloseQuery(TObject,Boolean).

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 procedure FormCloseQuery(Sender: TObject; var CanClose: Boolean);

Parameters

Sender
Type: TObject

CanClose
Type: Boolean

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.PageControl1Change(TObject) Method

Summary

Represents method PageControl1Change(TObject).

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 procedure PageControl1Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.Refresh(TBIDataset) Method

Summary

Represents method Refresh(TBIDataset).

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
public
 procedure Refresh(const ADataSet:TBIDataSet);

Parameters

ADataSet
Type: TBIDataSet

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor Fields

Fields
Name | Description
Backup | Represents field Backup.
BCancel | Represents field BCancel.
BITree1 | Represents field BITree1.
BOK | Represents field BOK.
Button1 | Represents field Button1.
CBActive | Represents field CBActive.
CBPreview | Represents field CBPreview.
CBReadonly | Represents field CBReadonly.
Label1 | Represents field Label1.
PageControl1 | Represents field PageControl1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
TabData | Represents field TabData.
TabOptions | Represents field TabOptions.
Top


TBIDataSetEditor.Backup Field

Summary

Represents field Backup.

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 Backup: TBIDataset;

Field Value

Type: TBIDataset

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.BCancel Field

Summary

Represents field BCancel.

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 BCancel: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.BITree1 Field

Summary

Represents field BITree1.

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 BITree1: TBITree;

Field Value

Type: TBITree

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.BOK Field

Summary

Represents field BOK.

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 BOK: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.Button1 Field

Summary

Represents field Button1.

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.CBActive Field

Summary

Represents field CBActive.

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 CBActive: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.CBPreview Field

Summary

Represents field CBPreview.

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 CBPreview: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.CBReadonly Field

Summary

Represents field CBReadonly.

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 CBReadonly: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.PageControl1 Field

Summary

Represents field PageControl1.

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 PageControl1: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.Panel3 Field

Summary

Represents field Panel3.

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 Panel3: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.Panel4 Field

Summary

Represents field Panel4.

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 Panel4: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.TabData Field

Summary

Represents field TabData.

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 TabData: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


TBIDataSetEditor.TabOptions Field

Summary

Represents field TabOptions.

Namespace: VCLBI.Editor.DataSet
Syntax
Delphi
published
 TabOptions: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIDataSetEditor
  • VCLBI.Editor.DataSet


VCLBI.Editor.DateTimeRange Namespace

Summary

Represents namespace VCLBI.Editor.DateTimeRange.

Classes
Name | Description
TDateTimeRangeEditor | Represents type TDateTimeRangeEditor.
TNumericFromToAccess | Represents type TNumericFromToAccess.
Top
Records
Name | Description
TDatePart | Represents type TDatePart.
TDateRange | Represents type TDateRange.
TSelectedPart | Represents type TSelectedPart.
Top
Constants
Name | Description
Period_Last | Represents constant Period_Last.
Period_Next | Represents constant Period_Next.
Top
Routines
Name | Description
AddDays(TStrings,Word,Word) | Represents method AddDays(TStrings,Word,Word).
AddYears(TStrings,Word,Word) | Represents method AddYears(TStrings,Word,Word).
Top


VCLBI.Editor.DateTimeRange Classes

Classes
Name | Description
TDateTimeRangeEditor | Represents type TDateTimeRangeEditor.
TNumericFromToAccess | Represents type TNumericFromToAccess.
Top


TDateTimeRangeEditor Class

Summary

Represents type TDateTimeRangeEditor.

Namespace: VCLBI.Editor.DateTimeRange
Inheritance Hierarchy
TForm
VCLBI.Editor.DateTimeRange.TDateTimeRangeEditor
Syntax
Delphi
type
 TDateTimeRangeEditor = class(TForm)
 end;

The TDateTimeRangeEditor type exposes the following members.

Properties
Show:
Name | Description
OnChanged | Represents property OnChanged.
Top
Methods
Show:
Name | Description
AddMonths(TStrings,Word,Word) | Represents method AddMonths(TStrings,Word,Word).
CalendarFromClick(TObject) | Represents method CalendarFromClick(TObject).
CBDayChange(TObject) | Represents method CBDayChange(TObject).
CBDayToChange(TObject) | Represents method CBDayToChange(TObject).
CBFromEqualChange(TObject) | Represents method CBFromEqualChange(TObject).
CBMonthChange(TObject) | Represents method CBMonthChange(TObject).
CBMonthToChange(TObject) | Represents method CBMonthToChange(TObject).
CBPartChange(TObject) | Represents method CBPartChange(TObject).
CBPeriod2Change(TObject) | Represents method CBPeriod2Change(TObject).
CBPeriodChange(TObject) | Represents method CBPeriodChange(TObject).
CBYearChange(TObject) | Represents method CBYearChange(TObject).
CBYearToChange(TObject) | Represents method CBYearToChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FromDate | Represents method FromDate.
FromEqual | Represents method FromEqual.
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
PageRangeChange(TObject) | Represents method PageRangeChange(TObject).
Part | Represents method Part.
Refresh(TDataItem) | Represents method Refresh(TDataItem).
SelectRange(TDataItem) | Overloaded. Represents method SelectRange(TDataItem).
SelectRange(TDateTime,TDateTime,Boolean,Boolean) | Overloaded. Represents method SelectRange(TDateTime,TDateTime,Boolean,Boolean).
ToDate | Represents method ToDate.
ToEqual | Represents method ToEqual.
Top
Fields
Show:
Name | Description
CalendarFrom | Represents field CalendarFrom.
CalendarTo | Represents field CalendarTo.
CBDay | Represents field CBDay.
CBDayTo | Represents field CBDayTo.
CBFromEqual | Represents field CBFromEqual.
CBMonth | Represents field CBMonth.
CBMonthTo | Represents field CBMonthTo.
CBPart | Represents field CBPart.
CBPeriod | Represents field CBPeriod.
CBPeriod2 | Represents field CBPeriod2.
CBToEqual | Represents field CBToEqual.
CBYear | Represents field CBYear.
CBYearTo | Represents field CBYearTo.
Data | Represents field Data.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
PageControl1 | Represents field PageControl1.
PageRange | Represents field PageRange.
Panel1 | Represents field Panel1.
TabCalendar | Represents field TabCalendar.
TabCombo | Represents field TabCombo.
TabFromTo | Represents field TabFromTo.
TabRange | Represents field TabRange.
TabSelected | Represents field TabSelected.
Top
See Also

Reference

  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor Properties

Properties
Name | Description
OnChanged | Represents property OnChanged.
Top


TDateTimeRangeEditor.OnChanged Property

Summary

Represents property OnChanged.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 property OnChanged:TNotifyEvent read FOnChanged write FOnChanged;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor Methods

Methods
Name | Description
AddMonths(TStrings,Word,Word) | Represents method AddMonths(TStrings,Word,Word).
CalendarFromClick(TObject) | Represents method CalendarFromClick(TObject).
CBDayChange(TObject) | Represents method CBDayChange(TObject).
CBDayToChange(TObject) | Represents method CBDayToChange(TObject).
CBFromEqualChange(TObject) | Represents method CBFromEqualChange(TObject).
CBMonthChange(TObject) | Represents method CBMonthChange(TObject).
CBMonthToChange(TObject) | Represents method CBMonthToChange(TObject).
CBPartChange(TObject) | Represents method CBPartChange(TObject).
CBPeriod2Change(TObject) | Represents method CBPeriod2Change(TObject).
CBPeriodChange(TObject) | Represents method CBPeriodChange(TObject).
CBYearChange(TObject) | Represents method CBYearChange(TObject).
CBYearToChange(TObject) | Represents method CBYearToChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FromDate | Represents method FromDate.
FromEqual | Represents method FromEqual.
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
PageRangeChange(TObject) | Represents method PageRangeChange(TObject).
Part | Represents method Part.
Refresh(TDataItem) | Represents method Refresh(TDataItem).
SelectRange(TDataItem) | Overloaded. Represents method SelectRange(TDataItem).
SelectRange(TDateTime,TDateTime,Boolean,Boolean) | Overloaded. Represents method SelectRange(TDateTime,TDateTime,Boolean,Boolean).
ToDate | Represents method ToDate.
ToEqual | Represents method ToEqual.
Top


TDateTimeRangeEditor.AddMonths(TStrings,Word,Word) Method

Summary

Represents method AddMonths(TStrings,Word,Word).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 class procedure AddMonths(const AItems:TStrings; const AMin,AMax:Word); static;

Parameters

AItems
Type: TStrings

AMin
Type: Word

AMax
Type: Word

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CalendarFromClick(TObject) Method

Summary

Represents method CalendarFromClick(TObject).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 procedure CalendarFromClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CBDayChange(TObject) Method

Summary

Represents method CBDayChange(TObject).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 procedure CBDayChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CBDayToChange(TObject) Method

Summary

Represents method CBDayToChange(TObject).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 procedure CBDayToChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CBFromEqualChange(TObject) Method

Summary

Represents method CBFromEqualChange(TObject).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 procedure CBFromEqualChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CBMonthChange(TObject) Method

Summary

Represents method CBMonthChange(TObject).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 procedure CBMonthChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CBMonthToChange(TObject) Method

Summary

Represents method CBMonthToChange(TObject).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 procedure CBMonthToChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CBPartChange(TObject) Method

Summary

Represents method CBPartChange(TObject).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 procedure CBPartChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CBPeriod2Change(TObject) Method

Summary

Represents method CBPeriod2Change(TObject).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 procedure CBPeriod2Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CBPeriodChange(TObject) Method

Summary

Represents method CBPeriodChange(TObject).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 procedure CBPeriodChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CBYearChange(TObject) Method

Summary

Represents method CBYearChange(TObject).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 procedure CBYearChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CBYearToChange(TObject) Method

Summary

Represents method CBYearToChange(TObject).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 procedure CBYearToChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.FromDate Method

Summary

Represents method FromDate.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 function FromDate:TDateTime;

Return Value

Type: TDateTime

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.FromEqual Method

Summary

Represents method FromEqual.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 function FromEqual:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.PageControl1Change(TObject) Method

Summary

Represents method PageControl1Change(TObject).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 procedure PageControl1Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.PageRangeChange(TObject) Method

Summary

Represents method PageRangeChange(TObject).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 procedure PageRangeChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.Part Method

Summary

Represents method Part.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 function Part:TSelectedPart;

Return Value

Type: TSelectedPart

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.Refresh(TDataItem) Method

Summary

Represents method Refresh(TDataItem).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 procedure Refresh(const AData:TDataItem);

Parameters

AData
Type: TDataItem

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.SelectRange(TDataItem) Method

Summary

Represents method SelectRange(TDataItem).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 procedure SelectRange(const AData:TDataItem); overload;

Parameters

AData
Type: TDataItem

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.SelectRange(TDateTime,TDateTime,Boolean,Boolean) Method

Summary

Represents method SelectRange(TDateTime,TDateTime,Boolean,Boolean).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 procedure SelectRange(const AFrom,ATo:TDateTime; const AFromEqual,AToEqual:Boolean); overload;

Parameters

AFrom
Type: TDateTime

ATo
Type: TDateTime

AFromEqual
Type: Boolean

AToEqual
Type: Boolean

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.ToDate Method

Summary

Represents method ToDate.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 function ToDate:TDateTime;

Return Value

Type: TDateTime

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.ToEqual Method

Summary

Represents method ToEqual.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 function ToEqual:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor Fields

Fields
Name | Description
CalendarFrom | Represents field CalendarFrom.
CalendarTo | Represents field CalendarTo.
CBDay | Represents field CBDay.
CBDayTo | Represents field CBDayTo.
CBFromEqual | Represents field CBFromEqual.
CBMonth | Represents field CBMonth.
CBMonthTo | Represents field CBMonthTo.
CBPart | Represents field CBPart.
CBPeriod | Represents field CBPeriod.
CBPeriod2 | Represents field CBPeriod2.
CBToEqual | Represents field CBToEqual.
CBYear | Represents field CBYear.
CBYearTo | Represents field CBYearTo.
Data | Represents field Data.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
PageControl1 | Represents field PageControl1.
PageRange | Represents field PageRange.
Panel1 | Represents field Panel1.
TabCalendar | Represents field TabCalendar.
TabCombo | Represents field TabCombo.
TabFromTo | Represents field TabFromTo.
TabRange | Represents field TabRange.
TabSelected | Represents field TabSelected.
Top


TDateTimeRangeEditor.CalendarFrom Field

Summary

Represents field CalendarFrom.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 CalendarFrom: TMonthCalendar;

Field Value

Type: TMonthCalendar

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CalendarTo Field

Summary

Represents field CalendarTo.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 CalendarTo: TMonthCalendar;

Field Value

Type: TMonthCalendar

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CBDay Field

Summary

Represents field CBDay.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 CBDay: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CBDayTo Field

Summary

Represents field CBDayTo.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 CBDayTo: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CBFromEqual Field

Summary

Represents field CBFromEqual.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 CBFromEqual: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CBMonth Field

Summary

Represents field CBMonth.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 CBMonth: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CBMonthTo Field

Summary

Represents field CBMonthTo.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 CBMonthTo: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CBPart Field

Summary

Represents field CBPart.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 CBPart: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CBPeriod Field

Summary

Represents field CBPeriod.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 CBPeriod: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CBPeriod2 Field

Summary

Represents field CBPeriod2.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 CBPeriod2: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CBToEqual Field

Summary

Represents field CBToEqual.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 CBToEqual: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CBYear Field

Summary

Represents field CBYear.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 CBYear: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.CBYearTo Field

Summary

Represents field CBYearTo.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 CBYearTo: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.Data Field

Summary

Represents field Data.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.Label2 Field

Summary

Represents field Label2.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.Label3 Field

Summary

Represents field Label3.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.Label4 Field

Summary

Represents field Label4.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 Label4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.Label5 Field

Summary

Represents field Label5.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 Label5: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.PageControl1 Field

Summary

Represents field PageControl1.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 PageControl1: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.PageRange Field

Summary

Represents field PageRange.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 PageRange: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.TabCalendar Field

Summary

Represents field TabCalendar.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 TabCalendar: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.TabCombo Field

Summary

Represents field TabCombo.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 TabCombo: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.TabFromTo Field

Summary

Represents field TabFromTo.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 TabFromTo: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.TabRange Field

Summary

Represents field TabRange.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 TabRange: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TDateTimeRangeEditor.TabSelected Field

Summary

Represents field TabSelected.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
published
 TabSelected: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDateTimeRangeEditor
  • VCLBI.Editor.DateTimeRange


TNumericFromToAccess Class

Summary

Represents type TNumericFromToAccess.

Namespace: VCLBI.Editor.DateTimeRange
Inheritance Hierarchy
TForm
VCLBI.Editor.NumericFromTo.TNumericFromTo
VCLBI.Editor.DateTimeRange.TNumericFromToAccess
Syntax
Delphi
type
 TNumericFromToAccess=class(TNumericFromTo);
See Also

Reference

  • VCLBI.Editor.DateTimeRange


VCLBI.Editor.DateTimeRange Records

Records
Name | Description
TDatePart | Represents type TDatePart.
TDateRange | Represents type TDateRange.
TSelectedPart | Represents type TSelectedPart.
Top


TDatePart Record

Summary

Represents type TDatePart.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
type
 TDatePart=record
 end;

The TDatePart type exposes the following members.

Methods
Show:
Name | Description
Init(TDateTime,Boolean) | Represents method Init(TDateTime,Boolean).
Top
Fields
Show:
Name | Description
Day | Represents field Day.
Equal | Represents field Equal.
Month | Represents field Month.
Value | Represents field Value.
Year | Represents field Year.
Top
See Also

Reference

  • VCLBI.Editor.DateTimeRange


TDatePart Methods

Methods
Name | Description
Init(TDateTime,Boolean) | Represents method Init(TDateTime,Boolean).
Top


TDatePart.Init(TDateTime,Boolean) Method

Summary

Represents method Init(TDateTime,Boolean).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 procedure Init(const AValue:TDateTime; const AEqual:Boolean);

Parameters

AValue
Type: TDateTime

AEqual
Type: Boolean

See Also

Reference

  • TDatePart
  • VCLBI.Editor.DateTimeRange


TDatePart Fields

Fields
Name | Description
Day | Represents field Day.
Equal | Represents field Equal.
Month | Represents field Month.
Value | Represents field Value.
Year | Represents field Year.
Top


TDatePart.Day Field

Summary

Represents field Day.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 Day,
 Month,
 Year : Word;

Field Value

Type: Word

See Also

Reference

  • TDatePart
  • VCLBI.Editor.DateTimeRange


TDatePart.Equal Field

Summary

Represents field Equal.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 Equal : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TDatePart
  • VCLBI.Editor.DateTimeRange


TDatePart.Month Field

Summary

Represents field Month.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 Day,
 Month,
 Year : Word;

Field Value

Type: Word

See Also

Reference

  • TDatePart
  • VCLBI.Editor.DateTimeRange


TDatePart.Value Field

Summary

Represents field Value.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 Value : TDateTime;

Field Value

Type: TDateTime

See Also

Reference

  • TDatePart
  • VCLBI.Editor.DateTimeRange


TDatePart.Year Field

Summary

Represents field Year.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 Day,
 Month,
 Year : Word;

Field Value

Type: Word

See Also

Reference

  • TDatePart
  • VCLBI.Editor.DateTimeRange


TDateRange Record

Summary

Represents type TDateRange.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
type
 TDateRange=record
 end;

The TDateRange type exposes the following members.

Methods
Show:
Name | Description
Init(TDataItem) | Overloaded. Represents method Init(TDataItem).
Init(TDateTime,TDateTime) | Overloaded. Represents method Init(TDateTime,TDateTime).
Init(TDateTime,TDateTime,Boolean,Boolean) | Overloaded. Represents method Init(TDateTime,TDateTime,Boolean,Boolean).
Top
Fields
Show:
Name | Description
Max | Represents field Max.
Min | Represents field Min.
Top
See Also

Reference

  • VCLBI.Editor.DateTimeRange


TDateRange Methods

Methods
Name | Description
Init(TDataItem) | Overloaded. Represents method Init(TDataItem).
Init(TDateTime,TDateTime) | Overloaded. Represents method Init(TDateTime,TDateTime).
Init(TDateTime,TDateTime,Boolean,Boolean) | Overloaded. Represents method Init(TDateTime,TDateTime,Boolean,Boolean).
Top


TDateRange.Init(TDataItem) Method

Summary

Represents method Init(TDataItem).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 procedure Init(const AData:TDataItem); overload;

Parameters

AData
Type: TDataItem

See Also

Reference

  • TDateRange
  • VCLBI.Editor.DateTimeRange


TDateRange.Init(TDateTime,TDateTime) Method

Summary

Represents method Init(TDateTime,TDateTime).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 procedure Init(const AFrom,ATo:TDateTime); overload; inline;

Parameters

AFrom
Type: TDateTime

ATo
Type: TDateTime

See Also

Reference

  • TDateRange
  • VCLBI.Editor.DateTimeRange


TDateRange.Init(TDateTime,TDateTime,Boolean,Boolean) Method

Summary

Represents method Init(TDateTime,TDateTime,Boolean,Boolean).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 procedure Init(const AFrom,ATo:TDateTime; const AFromEqual,AToEqual:Boolean); overload;

Parameters

AFrom
Type: TDateTime

ATo
Type: TDateTime

AFromEqual
Type: Boolean

AToEqual
Type: Boolean

See Also

Reference

  • TDateRange
  • VCLBI.Editor.DateTimeRange


TDateRange Fields

Fields
Name | Description
Max | Represents field Max.
Min | Represents field Min.
Top


TDateRange.Max Field

Summary

Represents field Max.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 Min,
 Max : TDatePart;

Field Value

Type: TDatePart

See Also

Reference

  • TDateRange
  • VCLBI.Editor.DateTimeRange


TDateRange.Min Field

Summary

Represents field Min.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 Min,
 Max : TDatePart;

Field Value

Type: TDatePart

See Also

Reference

  • TDateRange
  • VCLBI.Editor.DateTimeRange


TSelectedPart Record

Summary

Represents type TSelectedPart.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
type
 TSelectedPart=record
 end;

The TSelectedPart type exposes the following members.

Fields
Show:
Name | Description
DateTime | Represents field DateTime.
Enabled | Represents field Enabled.
Part | Represents field Part.
Value | Represents field Value.
Top
See Also

Reference

  • VCLBI.Editor.DateTimeRange


TSelectedPart Fields

Fields
Name | Description
DateTime | Represents field DateTime.
Enabled | Represents field Enabled.
Part | Represents field Part.
Value | Represents field Value.
Top


TSelectedPart.DateTime Field

Summary

Represents field DateTime.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 DateTime : TDateTime;

Field Value

Type: TDateTime

See Also

Reference

  • TSelectedPart
  • VCLBI.Editor.DateTimeRange


TSelectedPart.Enabled Field

Summary

Represents field Enabled.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 Enabled : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TSelectedPart
  • VCLBI.Editor.DateTimeRange


TSelectedPart.Part Field

Summary

Represents field Part.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 Part : TDateTimePart;

Field Value

Type: TDateTimePart

See Also

Reference

  • TSelectedPart
  • VCLBI.Editor.DateTimeRange


TSelectedPart.Value Field

Summary

Represents field Value.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
public
 Value : Integer;

Field Value

Type: Integer

See Also

Reference

  • TSelectedPart
  • VCLBI.Editor.DateTimeRange


VCLBI.Editor.DateTimeRange Constants

Constants
Name | Description
Period_Last | Represents constant Period_Last.
Period_Next | Represents constant Period_Next.
Top


Period_Last Constant

Summary

Represents constant Period_Last.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
 Period_Last = 6;

Value

Type: ShortInt

See Also

Reference

  • VCLBI.Editor.DateTimeRange


Period_Next Constant

Summary

Represents constant Period_Next.

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
 Period_Next = 7;

Value

Type: ShortInt

See Also

Reference

  • VCLBI.Editor.DateTimeRange


VCLBI.Editor.DateTimeRange Routines

Routines
Name | Description
AddDays(TStrings,Word,Word) | Represents method AddDays(TStrings,Word,Word).
AddYears(TStrings,Word,Word) | Represents method AddYears(TStrings,Word,Word).
Top


AddDays(TStrings,Word,Word) Method

Summary

Represents method AddDays(TStrings,Word,Word).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
procedure AddDays(const AItems:TStrings; const AMin,AMax:Word);

Parameters

AItems
Type: TStrings

AMin
Type: Word

AMax
Type: Word

See Also

Reference

  • VCLBI.Editor.DateTimeRange


AddYears(TStrings,Word,Word) Method

Summary

Represents method AddYears(TStrings,Word,Word).

Namespace: VCLBI.Editor.DateTimeRange
Syntax
Delphi
procedure AddYears(const AItems:TStrings; const AMin,AMax:Word);

Parameters

AItems
Type: TStrings

AMin
Type: Word

AMax
Type: Word

See Also

Reference

  • VCLBI.Editor.DateTimeRange


VCLBI.Editor.DynamicFilter Namespace

Summary

Represents namespace VCLBI.Editor.DynamicFilter.

Classes
Name | Description
TBIFilterAccess | Represents type TBIFilterAccess.
TDataAccess | Represents type TDataAccess.
TDynamicFilterEditor | Represents type TDynamicFilterEditor.
Top
Constants
Name | Description
DummyNode | Represents constant DummyNode.
Top


VCLBI.Editor.DynamicFilter Classes

Classes
Name | Description
TBIFilterAccess | Represents type TBIFilterAccess.
TDataAccess | Represents type TDataAccess.
TDynamicFilterEditor | Represents type TDynamicFilterEditor.
Top


TBIFilterAccess Class

Summary

Represents type TBIFilterAccess.

Namespace: VCLBI.Editor.DynamicFilter
Inheritance Hierarchy
TPersistent
BI.Expression.Filter.TBIFilter
VCLBI.Editor.DynamicFilter.TBIFilterAccess
Syntax
Delphi
type
 TBIFilterAccess=class(TBIFilter);
See Also

Reference

  • VCLBI.Editor.DynamicFilter


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: VCLBI.Editor.DynamicFilter
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
VCLBI.Editor.DynamicFilter.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor Class

Summary

Represents type TDynamicFilterEditor.

Namespace: VCLBI.Editor.DynamicFilter
Inheritance Hierarchy
TForm
VCLBI.Editor.DynamicFilter.TDynamicFilterEditor
Syntax
Delphi
type
 TDynamicFilterEditor = class(TForm)
 end;

The TDynamicFilterEditor type exposes the following members.

Properties
Show:
Name | Description
OnChange | Represents property OnChange.
Top
Methods
Show:
Name | Description
BAddClick(TObject) | Represents method BAddClick(TObject).
BDeleteClick(TObject) | Represents method BDeleteClick(TObject).
BITree1Change(TObject) | Represents method BITree1Change(TObject).
CBCustomChange(TObject) | Represents method CBCustomChange(TObject).
CBEnabledClick(TObject) | Represents method CBEnabledClick(TObject).
CBItemsClick(TObject) | Represents method CBItemsClick(TObject).
CBItemsClickCheck(TObject) | Represents method CBItemsClickCheck(TObject).
Choose(TComponent,TDataItem,TDataItem) | Represents method Choose(TComponent,TDataItem,TDataItem).
ECustomChange(TObject) | Represents method ECustomChange(TObject).
Edit(TComponent,TBIFilter,TDataItem,TDataItem) | Represents method Edit(TComponent,TBIFilter,TDataItem,TDataItem).
Embedd(TComponent,TWinControl,TBIFilter,TDataItem,TDataItem) | Represents method Embedd(TComponent,TWinControl,TBIFilter,TDataItem,TDataItem).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
PanelCustomResize(TObject) | Represents method PanelCustomResize(TObject).
Refresh(TBIFilter,TDataItem,TDataItem) | Overloaded. Represents method Refresh(TBIFilter,TDataItem,TDataItem).
Refresh(TDataItem,TDataItem) | Overloaded. Represents method Refresh(TDataItem,TDataItem).
SBCustomClick(TObject) | Represents method SBCustomClick(TObject).
Top
Fields
Show:
Name | Description
BAdd | Represents field BAdd.
BDelete | Represents field BDelete.
BITree1 | Represents field BITree1.
Button1 | Represents field Button1.
Button2 | Represents field Button2.
CBCustom | Represents field CBCustom.
CBEnabled | Represents field CBEnabled.
CBItems | Represents field CBItems.
ECustom | Represents field ECustom.
LError | Represents field LError.
PageControl1 | Represents field PageControl1.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
PanelButtons | Represents field PanelButtons.
PanelCustom | Represents field PanelCustom.
PanelItem | Represents field PanelItem.
SBCustom | Represents field SBCustom.
Splitter1 | Represents field Splitter1.
TabCustom | Represents field TabCustom.
TabData | Represents field TabData.
TabItems | Represents field TabItems.
Top
See Also

Reference

  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor Properties

Properties
Name | Description
OnChange | Represents property OnChange.
Top


TDynamicFilterEditor.OnChange Property

Summary

Represents property OnChange.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
public
 property OnChange:TNotifyEvent read FOnChange write FOnChange;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor Methods

Methods
Name | Description
BAddClick(TObject) | Represents method BAddClick(TObject).
BDeleteClick(TObject) | Represents method BDeleteClick(TObject).
BITree1Change(TObject) | Represents method BITree1Change(TObject).
CBCustomChange(TObject) | Represents method CBCustomChange(TObject).
CBEnabledClick(TObject) | Represents method CBEnabledClick(TObject).
CBItemsClick(TObject) | Represents method CBItemsClick(TObject).
CBItemsClickCheck(TObject) | Represents method CBItemsClickCheck(TObject).
Choose(TComponent,TDataItem,TDataItem) | Represents method Choose(TComponent,TDataItem,TDataItem).
ECustomChange(TObject) | Represents method ECustomChange(TObject).
Edit(TComponent,TBIFilter,TDataItem,TDataItem) | Represents method Edit(TComponent,TBIFilter,TDataItem,TDataItem).
Embedd(TComponent,TWinControl,TBIFilter,TDataItem,TDataItem) | Represents method Embedd(TComponent,TWinControl,TBIFilter,TDataItem,TDataItem).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
PanelCustomResize(TObject) | Represents method PanelCustomResize(TObject).
Refresh(TBIFilter,TDataItem,TDataItem) | Overloaded. Represents method Refresh(TBIFilter,TDataItem,TDataItem).
Refresh(TDataItem,TDataItem) | Overloaded. Represents method Refresh(TDataItem,TDataItem).
SBCustomClick(TObject) | Represents method SBCustomClick(TObject).
Top


TDynamicFilterEditor.BAddClick(TObject) Method

Summary

Represents method BAddClick(TObject).

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 procedure BAddClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.BDeleteClick(TObject) Method

Summary

Represents method BDeleteClick(TObject).

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 procedure BDeleteClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.BITree1Change(TObject) Method

Summary

Represents method BITree1Change(TObject).

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 procedure BITree1Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.CBCustomChange(TObject) Method

Summary

Represents method CBCustomChange(TObject).

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 procedure CBCustomChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.CBEnabledClick(TObject) Method

Summary

Represents method CBEnabledClick(TObject).

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 procedure CBEnabledClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.CBItemsClick(TObject) Method

Summary

Represents method CBItemsClick(TObject).

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 procedure CBItemsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.CBItemsClickCheck(TObject) Method

Summary

Represents method CBItemsClickCheck(TObject).

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 procedure CBItemsClickCheck(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.Choose(TComponent,TDataItem,TDataItem) Method

Summary

Represents method Choose(TComponent,TDataItem,TDataItem).

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
public
 class function Choose(const AOwner:TComponent;
 const AData:TDataItem;
 const AMain:TDataItem=nil):TExpression; static;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

AMain
Type: TDataItem

Return Value

Type: TExpression

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.ECustomChange(TObject) Method

Summary

Represents method ECustomChange(TObject).

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 procedure ECustomChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.Edit(TComponent,TBIFilter,TDataItem,TDataItem) Method

Summary

Represents method Edit(TComponent,TBIFilter,TDataItem,TDataItem).

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent;
 const AFilter:TBIFilter;
 const AData:TDataItem=nil;
 const AMain:TDataItem=nil):Boolean; static;

Parameters

AOwner
Type: TComponent

AFilter
Type: TBIFilter

AData
Type: TDataItem

AMain
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.Embedd(TComponent,TWinControl,TBIFilter,TDataItem,TDataItem) Method

Summary

Represents method Embedd(TComponent,TWinControl,TBIFilter,TDataItem,TDataItem).

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent;
 const AParent:TWinControl;
 const AFilter:TBIFilter;
 const AData:TDataItem;
 const AMain:TDataItem=nil):TDynamicFilterEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AFilter
Type: TBIFilter

AData
Type: TDataItem

AMain
Type: TDataItem

Return Value

Type: TDynamicFilterEditor

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.FormDestroy(TObject) Method

Summary

Represents method FormDestroy(TObject).

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 procedure FormDestroy(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.PanelCustomResize(TObject) Method

Summary

Represents method PanelCustomResize(TObject).

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 procedure PanelCustomResize(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.Refresh(TBIFilter,TDataItem,TDataItem) Method

Summary

Represents method Refresh(TBIFilter,TDataItem,TDataItem).

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
public
 procedure Refresh(const AFilter:TBIFilter; const AData:TDataItem; const AMain:TDataItem=nil); overload;

Parameters

AFilter
Type: TBIFilter

AData
Type: TDataItem

AMain
Type: TDataItem

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.Refresh(TDataItem,TDataItem) Method

Summary

Represents method Refresh(TDataItem,TDataItem).

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
public
 procedure Refresh(const AData:TDataItem; const AMain:TDataItem=nil); overload;

Parameters

AData
Type: TDataItem

AMain
Type: TDataItem

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.SBCustomClick(TObject) Method

Summary

Represents method SBCustomClick(TObject).

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 procedure SBCustomClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor Fields

Fields
Name | Description
BAdd | Represents field BAdd.
BDelete | Represents field BDelete.
BITree1 | Represents field BITree1.
Button1 | Represents field Button1.
Button2 | Represents field Button2.
CBCustom | Represents field CBCustom.
CBEnabled | Represents field CBEnabled.
CBItems | Represents field CBItems.
ECustom | Represents field ECustom.
LError | Represents field LError.
PageControl1 | Represents field PageControl1.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
PanelButtons | Represents field PanelButtons.
PanelCustom | Represents field PanelCustom.
PanelItem | Represents field PanelItem.
SBCustom | Represents field SBCustom.
Splitter1 | Represents field Splitter1.
TabCustom | Represents field TabCustom.
TabData | Represents field TabData.
TabItems | Represents field TabItems.
Top


TDynamicFilterEditor.BAdd Field

Summary

Represents field BAdd.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 BAdd: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.BDelete Field

Summary

Represents field BDelete.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 BDelete: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.BITree1 Field

Summary

Represents field BITree1.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 BITree1: TBITree;

Field Value

Type: TBITree

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.Button1 Field

Summary

Represents field Button1.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.Button2 Field

Summary

Represents field Button2.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 Button2: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.CBCustom Field

Summary

Represents field CBCustom.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 CBCustom: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.CBEnabled Field

Summary

Represents field CBEnabled.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 CBEnabled: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.CBItems Field

Summary

Represents field CBItems.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 CBItems: TCheckListBox;

Field Value

Type: TCheckListBox

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.ECustom Field

Summary

Represents field ECustom.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 ECustom: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.LError Field

Summary

Represents field LError.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 LError: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.PageControl1 Field

Summary

Represents field PageControl1.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 PageControl1: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.Panel3 Field

Summary

Represents field Panel3.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 Panel3: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.Panel4 Field

Summary

Represents field Panel4.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 Panel4: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.PanelButtons Field

Summary

Represents field PanelButtons.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 PanelButtons: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.PanelCustom Field

Summary

Represents field PanelCustom.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 PanelCustom: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.PanelItem Field

Summary

Represents field PanelItem.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 PanelItem: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.SBCustom Field

Summary

Represents field SBCustom.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 SBCustom: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.Splitter1 Field

Summary

Represents field Splitter1.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 Splitter1: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.TabCustom Field

Summary

Represents field TabCustom.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 TabCustom: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.TabData Field

Summary

Represents field TabData.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 TabData: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


TDynamicFilterEditor.TabItems Field

Summary

Represents field TabItems.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
published
 TabItems: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDynamicFilterEditor
  • VCLBI.Editor.DynamicFilter


VCLBI.Editor.DynamicFilter Constants

Constants
Name | Description
DummyNode | Represents constant DummyNode.
Top


DummyNode Constant

Summary

Represents constant DummyNode.

Namespace: VCLBI.Editor.DynamicFilter
Syntax
Delphi
 DummyNode='**********************';

Value

Type: string

See Also

Reference

  • VCLBI.Editor.DynamicFilter


VCLBI.Editor.ExportData Namespace

Summary

Represents namespace VCLBI.Editor.ExportData.

Classes
Name | Description
TExportData | Represents type TExportData.
Top


VCLBI.Editor.ExportData Classes

Classes
Name | Description
TExportData | Represents type TExportData.
Top


TExportData Class

Summary

Represents type TExportData.

Namespace: VCLBI.Editor.ExportData
Inheritance Hierarchy
TForm
VCLBI.Editor.ExportData.TExportData
Syntax
Delphi
type
 TExportData = class(TForm)
 end;

The TExportData type exposes the following members.

Methods
Show:
Name | Description
BCopyClick(TObject) | Represents method BCopyClick(TObject).
BSaveClick(TObject) | Represents method BSaveClick(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
HasAnyFormat | Represents method HasAnyFormat.
LBFormatClick(TObject) | Represents method LBFormatClick(TObject).
SaveToFile(String) | Overloaded. Represents method SaveToFile(String).
SaveToFile(TDataItem,String) | Overloaded. Represents method SaveToFile(TDataItem,String).
Show(TComponent,TDataItem) | Represents method Show(TComponent,TDataItem).
Top
Fields
Show:
Name | Description
BClose | Represents field BClose.
BCopy | Represents field BCopy.
BSave | Represents field BSave.
CBSchema | Represents field CBSchema.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
LBFormat | Represents field LBFormat.
LSize | Represents field LSize.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
SaveDialog1 | Represents field SaveDialog1.
Top
See Also

Reference

  • VCLBI.Editor.ExportData


TExportData Methods

Methods
Name | Description
BCopyClick(TObject) | Represents method BCopyClick(TObject).
BSaveClick(TObject) | Represents method BSaveClick(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
HasAnyFormat | Represents method HasAnyFormat.
LBFormatClick(TObject) | Represents method LBFormatClick(TObject).
SaveToFile(String) | Overloaded. Represents method SaveToFile(String).
SaveToFile(TDataItem,String) | Overloaded. Represents method SaveToFile(TDataItem,String).
Show(TComponent,TDataItem) | Represents method Show(TComponent,TDataItem).
Top


TExportData.BCopyClick(TObject) Method

Summary

Represents method BCopyClick(TObject).

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
published
 procedure BCopyClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData.BSaveClick(TObject) Method

Summary

Represents method BSaveClick(TObject).

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
published
 procedure BSaveClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData.FormDestroy(TObject) Method

Summary

Represents method FormDestroy(TObject).

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
published
 procedure FormDestroy(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData.HasAnyFormat Method

Summary

Represents method HasAnyFormat.

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
public
 class function HasAnyFormat:Boolean; static;

Return Value

Type: Boolean

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData.LBFormatClick(TObject) Method

Summary

Represents method LBFormatClick(TObject).

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
published
 procedure LBFormatClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData.SaveToFile(String) Method

Summary

Represents method SaveToFile(String).

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
public
 procedure SaveToFile(const AFile:String); overload;

Parameters

AFile
Type: String

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData.SaveToFile(TDataItem,String) Method

Summary

Represents method SaveToFile(TDataItem,String).

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
public
 class procedure SaveToFile(const AData:TDataItem; const AFile:String); overload; static;

Parameters

AData
Type: TDataItem

AFile
Type: String

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData.Show(TComponent,TDataItem) Method

Summary

Represents method Show(TComponent,TDataItem).

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
public
 class procedure Show(const AOwner:TComponent; const AData:TDataItem); static;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData Fields

Fields
Name | Description
BClose | Represents field BClose.
BCopy | Represents field BCopy.
BSave | Represents field BSave.
CBSchema | Represents field CBSchema.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
LBFormat | Represents field LBFormat.
LSize | Represents field LSize.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
SaveDialog1 | Represents field SaveDialog1.
Top


TExportData.BClose Field

Summary

Represents field BClose.

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
published
 BClose: TButton;

Field Value

Type: TButton

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData.BCopy Field

Summary

Represents field BCopy.

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
published
 BCopy: TButton;

Field Value

Type: TButton

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData.BSave Field

Summary

Represents field BSave.

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
published
 BSave: TButton;

Field Value

Type: TButton

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData.CBSchema Field

Summary

Represents field CBSchema.

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
published
 CBSchema: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData.Label2 Field

Summary

Represents field Label2.

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData.Label3 Field

Summary

Represents field Label3.

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData.LBFormat Field

Summary

Represents field LBFormat.

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
published
 LBFormat: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData.LSize Field

Summary

Represents field LSize.

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
published
 LSize: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData.Panel3 Field

Summary

Represents field Panel3.

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
published
 Panel3: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData.Panel4 Field

Summary

Represents field Panel4.

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
published
 Panel4: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


TExportData.SaveDialog1 Field

Summary

Represents field SaveDialog1.

Namespace: VCLBI.Editor.ExportData
Syntax
Delphi
published
 SaveDialog1: TSaveDialog;

Field Value

Type: TSaveDialog

See Also

Reference

  • TExportData
  • VCLBI.Editor.ExportData


VCLBI.Editor.Expression Namespace

Summary

Represents namespace VCLBI.Editor.Expression.

Classes
Name | Description
TBITreeAccess | Represents type TBITreeAccess.
TExpressionEditor | Represents type TExpressionEditor.
Top
Constants
Name | Description
RegKey | Represents constant RegKey.
Top


VCLBI.Editor.Expression Classes

Classes
Name | Description
TBITreeAccess | Represents type TBITreeAccess.
TExpressionEditor | Represents type TExpressionEditor.
Top


TBITreeAccess Class

Summary

Represents type TBITreeAccess.

Namespace: VCLBI.Editor.Expression
Inheritance Hierarchy
TWinControl
VCLBI.DataControl.TBIDataControl
VCLBI.Tree.TBITree
VCLBI.Editor.Expression.TBITreeAccess
Syntax
Delphi
type
 TBITreeAccess=class(TBITree);
See Also

Reference

  • VCLBI.Editor.Expression


TExpressionEditor Class

Summary

Represents type TExpressionEditor.

Namespace: VCLBI.Editor.Expression
Inheritance Hierarchy
TForm
VCLBI.Editor.Expression.TExpressionEditor
Syntax
Delphi
type
 TExpressionEditor = class(TForm)
 end;

The TExpressionEditor type exposes the following members.

Properties
Show:
Name | Description
Expression | Represents property Expression.
OnChange | Represents property OnChange.
Top
Methods
Show:
Name | Description
AddFields(String[]) | Represents method AddFields(String[]).
BDeleteClick(TObject) | Represents method BDeleteClick(TObject).
BITree2Change(TObject) | Represents method BITree2Change(TObject).
BITree2DragDrop(TObject,TObject,Integer,Integer) | Represents method BITree2DragDrop(TObject,TObject,Integer,Integer).
BITree2DragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method BITree2DragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
Edit(TComponent,TExpression,TResolveProc) | Represents method Edit(TComponent,TExpression,TResolveProc).
EditExpChange(TObject) | Represents method EditExpChange(TObject).
EditExpKeyDown(TObject,Word,TShiftState) | Represents method EditExpKeyDown(TObject,Word,TShiftState).
EditExpKeyPress(TObject,Char) | Represents method EditExpKeyPress(TObject,Char).
Embedd(TComponent,TWinControl) | Represents method Embedd(TComponent,TWinControl).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
Panel2Resize(TObject) | Represents method Panel2Resize(TObject).
ParseError(Integer,String) | Represents method ParseError(Integer,String).
Refresh(TExpression) | Represents method Refresh(TExpression).
SBToogleClick(TObject) | Represents method SBToogleClick(TObject).
Top
Events
Show:
Name | Description
OnGetFields | Represents property OnGetFields.
Top
Fields
Show:
Name | Description
BCancel | Represents field BCancel.
BDelete | Represents field BDelete.
BITree1 | Represents field BITree1.
BITree2 | Represents field BITree2.
BOK | Represents field BOK.
EditExp | Represents field EditExp.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
LError | Represents field LError.
LValue | Represents field LValue.
PageControl1 | Represents field PageControl1.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel4 | Represents field Panel4.
Panel9 | Represents field Panel9.
PanelButtons | Represents field PanelButtons.
PanelError | Represents field PanelError.
PanelFunctions | Represents field PanelFunctions.
Resolver | Represents field Resolver.
SBToogle | Represents field SBToogle.
Splitter1 | Represents field Splitter1.
TabExpression | Represents field TabExpression.
TabTree | Represents field TabTree.
Top
See Also

Reference

  • VCLBI.Editor.Expression


TExpressionEditor Properties

Properties
Name | Description
Expression | Represents property Expression.
OnChange | Represents property OnChange.
Top


TExpressionEditor.Expression Property

Summary

Represents property Expression.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
public
 property Expression:TExpression read IExp;

Property Value

Type: TExpression

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.OnChange Property

Summary

Represents property OnChange.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
public
 property OnChange:TNotifyEvent read FOnChange write FOnChange;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor Methods

Methods
Name | Description
AddFields(String[]) | Represents method AddFields(String[]).
BDeleteClick(TObject) | Represents method BDeleteClick(TObject).
BITree2Change(TObject) | Represents method BITree2Change(TObject).
BITree2DragDrop(TObject,TObject,Integer,Integer) | Represents method BITree2DragDrop(TObject,TObject,Integer,Integer).
BITree2DragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method BITree2DragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
Edit(TComponent,TExpression,TResolveProc) | Represents method Edit(TComponent,TExpression,TResolveProc).
EditExpChange(TObject) | Represents method EditExpChange(TObject).
EditExpKeyDown(TObject,Word,TShiftState) | Represents method EditExpKeyDown(TObject,Word,TShiftState).
EditExpKeyPress(TObject,Char) | Represents method EditExpKeyPress(TObject,Char).
Embedd(TComponent,TWinControl) | Represents method Embedd(TComponent,TWinControl).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
Panel2Resize(TObject) | Represents method Panel2Resize(TObject).
ParseError(Integer,String) | Represents method ParseError(Integer,String).
Refresh(TExpression) | Represents method Refresh(TExpression).
SBToogleClick(TObject) | Represents method SBToogleClick(TObject).
Top


TExpressionEditor.AddFields(String[]) Method

Summary

Represents method AddFields(String[]).

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
public
 procedure AddFields(const AItems:Array of String);

Parameters

AItems
Type: Array of String

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.BDeleteClick(TObject) Method

Summary

Represents method BDeleteClick(TObject).

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 procedure BDeleteClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.BITree2Change(TObject) Method

Summary

Represents method BITree2Change(TObject).

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 procedure BITree2Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.BITree2DragDrop(TObject,TObject,Integer,Integer) Method

Summary

Represents method BITree2DragDrop(TObject,TObject,Integer,Integer).

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 procedure BITree2DragDrop(Sender, Source: TObject; X, Y: Integer);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.BITree2DragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) Method

Summary

Represents method BITree2DragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 procedure BITree2DragOver(Sender, Source: TObject; X, Y: Integer;
 State: TDragState; var Accept: Boolean);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

State
Type: TDragState

Accept
Type: Boolean

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.Edit(TComponent,TExpression,TResolveProc) Method

Summary

Represents method Edit(TComponent,TExpression,TResolveProc).

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; var AExpression:TExpression;
 const AResolver:TResolveProc=nil):Boolean; static;

Parameters

AOwner
Type: TComponent

AExpression
Type: TExpression

AResolver
Type: TResolveProc

Return Value

Type: Boolean

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.EditExpChange(TObject) Method

Summary

Represents method EditExpChange(TObject).

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 procedure EditExpChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.EditExpKeyDown(TObject,Word,TShiftState) Method

Summary

Represents method EditExpKeyDown(TObject,Word,TShiftState).

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 procedure EditExpKeyDown(Sender: TObject; var Key: Word;
 Shift: TShiftState);

Parameters

Sender
Type: TObject

Key
Type: Word

Shift
Type: TShiftState

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.EditExpKeyPress(TObject,Char) Method

Summary

Represents method EditExpKeyPress(TObject,Char).

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 procedure EditExpKeyPress(Sender: TObject; var Key: Char);

Parameters

Sender
Type: TObject

Key
Type: Char

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.Embedd(TComponent,TWinControl) Method

Summary

Represents method Embedd(TComponent,TWinControl).

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl):TExpressionEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

Return Value

Type: TExpressionEditor

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.FormDestroy(TObject) Method

Summary

Represents method FormDestroy(TObject).

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 procedure FormDestroy(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.PageControl1Change(TObject) Method

Summary

Represents method PageControl1Change(TObject).

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 procedure PageControl1Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.Panel2Resize(TObject) Method

Summary

Represents method Panel2Resize(TObject).

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 procedure Panel2Resize(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.ParseError(Integer,String) Method

Summary

Represents method ParseError(Integer,String).

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
public
 function ParseError(const APos:Integer; const AMessage:String):Boolean;

Parameters

APos
Type: Integer

AMessage
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.Refresh(TExpression) Method

Summary

Represents method Refresh(TExpression).

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
public
 procedure Refresh(const AExpression:TExpression);

Parameters

AExpression
Type: TExpression

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.SBToogleClick(TObject) Method

Summary

Represents method SBToogleClick(TObject).

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 procedure SBToogleClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor Events

Events
Name | Description
OnGetFields | Represents property OnGetFields.
Top


TExpressionEditor.OnGetFields Event

Summary

Represents property OnGetFields.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
public
 property OnGetFields:TCompleteEvent read FOnGetFields write FOnGetFields;

Value

Type: TCompleteEvent

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor Fields

Fields
Name | Description
BCancel | Represents field BCancel.
BDelete | Represents field BDelete.
BITree1 | Represents field BITree1.
BITree2 | Represents field BITree2.
BOK | Represents field BOK.
EditExp | Represents field EditExp.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
LError | Represents field LError.
LValue | Represents field LValue.
PageControl1 | Represents field PageControl1.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel4 | Represents field Panel4.
Panel9 | Represents field Panel9.
PanelButtons | Represents field PanelButtons.
PanelError | Represents field PanelError.
PanelFunctions | Represents field PanelFunctions.
Resolver | Represents field Resolver.
SBToogle | Represents field SBToogle.
Splitter1 | Represents field Splitter1.
TabExpression | Represents field TabExpression.
TabTree | Represents field TabTree.
Top


TExpressionEditor.BCancel Field

Summary

Represents field BCancel.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 BCancel: TButton;

Field Value

Type: TButton

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.BDelete Field

Summary

Represents field BDelete.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 BDelete: TButton;

Field Value

Type: TButton

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.BITree1 Field

Summary

Represents field BITree1.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 BITree1: TBITree;

Field Value

Type: TBITree

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.BITree2 Field

Summary

Represents field BITree2.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 BITree2: TBITree;

Field Value

Type: TBITree

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.BOK Field

Summary

Represents field BOK.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 BOK: TButton;

Field Value

Type: TButton

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.EditExp Field

Summary

Represents field EditExp.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 EditExp: TMemo;

Field Value

Type: TMemo

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.Label2 Field

Summary

Represents field Label2.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.LError Field

Summary

Represents field LError.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 LError: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.LValue Field

Summary

Represents field LValue.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 LValue: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.PageControl1 Field

Summary

Represents field PageControl1.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 PageControl1: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.Panel4 Field

Summary

Represents field Panel4.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 Panel4: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.Panel9 Field

Summary

Represents field Panel9.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 Panel9: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.PanelButtons Field

Summary

Represents field PanelButtons.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 PanelButtons: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.PanelError Field

Summary

Represents field PanelError.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 PanelError: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.PanelFunctions Field

Summary

Represents field PanelFunctions.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 PanelFunctions: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.Resolver Field

Summary

Represents field Resolver.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
public
 Resolver : TResolveProc;

Field Value

Type: TResolveProc

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.SBToogle Field

Summary

Represents field SBToogle.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 SBToogle: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.Splitter1 Field

Summary

Represents field Splitter1.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 Splitter1: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.TabExpression Field

Summary

Represents field TabExpression.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 TabExpression: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


TExpressionEditor.TabTree Field

Summary

Represents field TabTree.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
published
 TabTree: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TExpressionEditor
  • VCLBI.Editor.Expression


VCLBI.Editor.Expression Constants

Constants
Name | Description
RegKey | Represents constant RegKey.
Top


RegKey Constant

Summary

Represents constant RegKey.

Namespace: VCLBI.Editor.Expression
Syntax
Delphi
 RegKey='Editors\Expression\Completion';

Value

Type: string

See Also

Reference

  • VCLBI.Editor.Expression


VCLBI.Editor.Filter.DateTime Namespace

Summary

Represents namespace VCLBI.Editor.Filter.DateTime.

Classes
Name | Description
TDateTimeFilterEditor | Represents type TDateTimeFilterEditor.
TFilterItemAccess | Represents type TFilterItemAccess.
TMonthsAccess | Represents type TMonthsAccess.
TWeekDaysAccess | Represents type TWeekDaysAccess.
Top
Routines
Name | Description
AddWeekDays(TStrings,Word,Word) | Represents method AddWeekDays(TStrings,Word,Word).
Top


VCLBI.Editor.Filter.DateTime Classes

Classes
Name | Description
TDateTimeFilterEditor | Represents type TDateTimeFilterEditor.
TFilterItemAccess | Represents type TFilterItemAccess.
TMonthsAccess | Represents type TMonthsAccess.
TWeekDaysAccess | Represents type TWeekDaysAccess.
Top


TDateTimeFilterEditor Class

Summary

Represents type TDateTimeFilterEditor.

Namespace: VCLBI.Editor.Filter.DateTime
Inheritance Hierarchy
TForm
VCLBI.Editor.Filter.DateTime.TDateTimeFilterEditor
Syntax
Delphi
type
 TDateTimeFilterEditor = class(TForm)
 end;

The TDateTimeFilterEditor type exposes the following members.

Properties
Show:
Name | Description
OnChanged | Represents property OnChanged.
Top
Methods
Show:
Name | Description
Embed(TComponent,TWinControl,TNotifyEvent) | Represents method Embed(TComponent,TWinControl,TNotifyEvent).
FormShow(TObject) | Represents method FormShow(TObject).
LBCommonClick(TObject) | Represents method LBCommonClick(TObject).
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
Refresh(TFilterItem) | Represents method Refresh(TFilterItem).
Top
Fields
Show:
Name | Description
LBCommon | Represents field LBCommon.
PageControl1 | Represents field PageControl1.
PanelMonths | Represents field PanelMonths.
PanelWeeks | Represents field PanelWeeks.
Splitter1 | Represents field Splitter1.
TabCommon | Represents field TabCommon.
TabCustom | Represents field TabCustom.
TabIncluded | Represents field TabIncluded.
Top
See Also

Reference

  • VCLBI.Editor.Filter.DateTime


TDateTimeFilterEditor Properties

Properties
Name | Description
OnChanged | Represents property OnChanged.
Top


TDateTimeFilterEditor.OnChanged Property

Summary

Represents property OnChanged.

Namespace: VCLBI.Editor.Filter.DateTime
Syntax
Delphi
public
 property OnChanged:TNotifyEvent read FOnChanged write FOnChanged;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TDateTimeFilterEditor
  • VCLBI.Editor.Filter.DateTime


TDateTimeFilterEditor Methods

Methods
Name | Description
Embed(TComponent,TWinControl,TNotifyEvent) | Represents method Embed(TComponent,TWinControl,TNotifyEvent).
FormShow(TObject) | Represents method FormShow(TObject).
LBCommonClick(TObject) | Represents method LBCommonClick(TObject).
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
Refresh(TFilterItem) | Represents method Refresh(TFilterItem).
Top


TDateTimeFilterEditor.Embed(TComponent,TWinControl,TNotifyEvent) Method

Summary

Represents method Embed(TComponent,TWinControl,TNotifyEvent).

Namespace: VCLBI.Editor.Filter.DateTime
Syntax
Delphi
public
 class function Embed(const AOwner:TComponent; const AParent:TWinControl;
 const AOnChange:TNotifyEvent):TDateTimeFilterEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AOnChange
Type: TNotifyEvent

Return Value

Type: TDateTimeFilterEditor

See Also

Reference

  • TDateTimeFilterEditor
  • VCLBI.Editor.Filter.DateTime


TDateTimeFilterEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Editor.Filter.DateTime
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDateTimeFilterEditor
  • VCLBI.Editor.Filter.DateTime


TDateTimeFilterEditor.LBCommonClick(TObject) Method

Summary

Represents method LBCommonClick(TObject).

Namespace: VCLBI.Editor.Filter.DateTime
Syntax
Delphi
published
 procedure LBCommonClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDateTimeFilterEditor
  • VCLBI.Editor.Filter.DateTime


TDateTimeFilterEditor.PageControl1Change(TObject) Method

Summary

Represents method PageControl1Change(TObject).

Namespace: VCLBI.Editor.Filter.DateTime
Syntax
Delphi
published
 procedure PageControl1Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDateTimeFilterEditor
  • VCLBI.Editor.Filter.DateTime


TDateTimeFilterEditor.Refresh(TFilterItem) Method

Summary

Represents method Refresh(TFilterItem).

Namespace: VCLBI.Editor.Filter.DateTime
Syntax
Delphi
public
 procedure Refresh(const AItem:TFilterItem);

Parameters

AItem
Type: TFilterItem

See Also

Reference

  • TDateTimeFilterEditor
  • VCLBI.Editor.Filter.DateTime


TDateTimeFilterEditor Fields

Fields
Name | Description
LBCommon | Represents field LBCommon.
PageControl1 | Represents field PageControl1.
PanelMonths | Represents field PanelMonths.
PanelWeeks | Represents field PanelWeeks.
Splitter1 | Represents field Splitter1.
TabCommon | Represents field TabCommon.
TabCustom | Represents field TabCustom.
TabIncluded | Represents field TabIncluded.
Top


TDateTimeFilterEditor.LBCommon Field

Summary

Represents field LBCommon.

Namespace: VCLBI.Editor.Filter.DateTime
Syntax
Delphi
published
 LBCommon: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TDateTimeFilterEditor
  • VCLBI.Editor.Filter.DateTime


TDateTimeFilterEditor.PageControl1 Field

Summary

Represents field PageControl1.

Namespace: VCLBI.Editor.Filter.DateTime
Syntax
Delphi
published
 PageControl1: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TDateTimeFilterEditor
  • VCLBI.Editor.Filter.DateTime


TDateTimeFilterEditor.PanelMonths Field

Summary

Represents field PanelMonths.

Namespace: VCLBI.Editor.Filter.DateTime
Syntax
Delphi
published
 PanelMonths: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDateTimeFilterEditor
  • VCLBI.Editor.Filter.DateTime


TDateTimeFilterEditor.PanelWeeks Field

Summary

Represents field PanelWeeks.

Namespace: VCLBI.Editor.Filter.DateTime
Syntax
Delphi
published
 PanelWeeks: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDateTimeFilterEditor
  • VCLBI.Editor.Filter.DateTime


TDateTimeFilterEditor.Splitter1 Field

Summary

Represents field Splitter1.

Namespace: VCLBI.Editor.Filter.DateTime
Syntax
Delphi
published
 Splitter1: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TDateTimeFilterEditor
  • VCLBI.Editor.Filter.DateTime


TDateTimeFilterEditor.TabCommon Field

Summary

Represents field TabCommon.

Namespace: VCLBI.Editor.Filter.DateTime
Syntax
Delphi
published
 TabCommon: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDateTimeFilterEditor
  • VCLBI.Editor.Filter.DateTime


TDateTimeFilterEditor.TabCustom Field

Summary

Represents field TabCustom.

Namespace: VCLBI.Editor.Filter.DateTime
Syntax
Delphi
published
 TabCustom: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDateTimeFilterEditor
  • VCLBI.Editor.Filter.DateTime


TDateTimeFilterEditor.TabIncluded Field

Summary

Represents field TabIncluded.

Namespace: VCLBI.Editor.Filter.DateTime
Syntax
Delphi
published
 TabIncluded: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDateTimeFilterEditor
  • VCLBI.Editor.Filter.DateTime


TFilterItemAccess Class

Summary

Represents type TFilterItemAccess.

Namespace: VCLBI.Editor.Filter.DateTime
Inheritance Hierarchy
TCollectionItem
BI.CollectionItem.TDataCollectionItem
BI.Expression.Filter.TFilterItem
VCLBI.Editor.Filter.DateTime.TFilterItemAccess
Syntax
Delphi
type
 TFilterItemAccess=class(TFilterItem);
See Also

Reference

  • VCLBI.Editor.Filter.DateTime


TMonthsAccess Class

Summary

Represents type TMonthsAccess.

Namespace: VCLBI.Editor.Filter.DateTime
Inheritance Hierarchy
TPersistent
BI.Expression.Filter.TFilterPart
BI.Expression.Filter.TMonths
VCLBI.Editor.Filter.DateTime.TMonthsAccess
Syntax
Delphi
type
 TMonthsAccess=class(TMonths);
See Also

Reference

  • VCLBI.Editor.Filter.DateTime


TWeekDaysAccess Class

Summary

Represents type TWeekDaysAccess.

Namespace: VCLBI.Editor.Filter.DateTime
Inheritance Hierarchy
TPersistent
BI.Expression.Filter.TFilterPart
BI.Expression.Filter.TWeekdays
VCLBI.Editor.Filter.DateTime.TWeekDaysAccess
Syntax
Delphi
type
 TWeekDaysAccess=class(TWeekdays);
See Also

Reference

  • VCLBI.Editor.Filter.DateTime


VCLBI.Editor.Filter.DateTime Routines

Routines
Name | Description
AddWeekDays(TStrings,Word,Word) | Represents method AddWeekDays(TStrings,Word,Word).
Top


AddWeekDays(TStrings,Word,Word) Method

Summary

Represents method AddWeekDays(TStrings,Word,Word).

Namespace: VCLBI.Editor.Filter.DateTime
Syntax
Delphi
procedure AddWeekDays(const AItems:TStrings; const AMin,AMax:Word);

Parameters

AItems
Type: TStrings

AMin
Type: Word

AMax
Type: Word

See Also

Reference

  • VCLBI.Editor.Filter.DateTime


VCLBI.Editor.Filter.Item Namespace

Summary

Represents namespace VCLBI.Editor.Filter.Item.

Classes
Name | Description
TFilterItemAccess | Represents type TFilterItemAccess.
TFilterItemEditor | Represents type TFilterItemEditor.
TNumericFromToAccess | Represents type TNumericFromToAccess.
Top


VCLBI.Editor.Filter.Item Classes

Classes
Name | Description
TFilterItemAccess | Represents type TFilterItemAccess.
TFilterItemEditor | Represents type TFilterItemEditor.
TNumericFromToAccess | Represents type TNumericFromToAccess.
Top


TFilterItemAccess Class

Summary

Represents type TFilterItemAccess.

Namespace: VCLBI.Editor.Filter.Item
Inheritance Hierarchy
TCollectionItem
BI.CollectionItem.TDataCollectionItem
BI.Expression.Filter.TFilterItem
VCLBI.Editor.Filter.Item.TFilterItemAccess
Syntax
Delphi
type
 TFilterItemAccess=class(TFilterItem);
See Also

Reference

  • VCLBI.Editor.Filter.Item


TFilterItemEditor Class

Summary

Represents type TFilterItemEditor.

Namespace: VCLBI.Editor.Filter.Item
Inheritance Hierarchy
TForm
VCLBI.Editor.Filter.Item.TFilterItemEditor
Syntax
Delphi
type
 TFilterItemEditor = class(TForm)
 end;

The TFilterItemEditor type exposes the following members.

Properties
Show:
Name | Description
OnChange | Represents property OnChange.
Top
Methods
Show:
Name | Description
CBFalseClick(TObject) | Represents method CBFalseClick(TObject).
CBTextCaseClick(TObject) | Represents method CBTextCaseClick(TObject).
CBTrueClick(TObject) | Represents method CBTrueClick(TObject).
Embedd(TComponent,TWinControl,TFilterItem) | Represents method Embedd(TComponent,TWinControl,TFilterItem).
ETextChange(TObject) | Represents method ETextChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
LBTextStyleClick(TObject) | Represents method LBTextStyleClick(TObject).
Refresh(TFilterItem) | Represents method Refresh(TFilterItem).
Top
Fields
Show:
Name | Description
CBFalse | Represents field CBFalse.
CBTextCase | Represents field CBTextCase.
CBTrue | Represents field CBTrue.
EText | Represents field EText.
Label1 | Represents field Label1.
LBTextStyle | Represents field LBTextStyle.
PageControl2 | Represents field PageControl2.
PageItem | Represents field PageItem.
PageNumeric | Represents field PageNumeric.
TabBoolean | Represents field TabBoolean.
TabDateTime | Represents field TabDateTime.
TabExcluded | Represents field TabExcluded.
TabIncluded | Represents field TabIncluded.
TabNumeric | Represents field TabNumeric.
TabNumericRange | Represents field TabNumericRange.
TabNumericSelected | Represents field TabNumericSelected.
TabText | Represents field TabText.
TabTextOptions | Represents field TabTextOptions.
Top
See Also

Reference

  • VCLBI.Editor.Filter.Item


TFilterItemEditor Properties

Properties
Name | Description
OnChange | Represents property OnChange.
Top


TFilterItemEditor.OnChange Property

Summary

Represents property OnChange.

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
public
 property OnChange:TNotifyEvent read FOnChange write FOnChange;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor Methods

Methods
Name | Description
CBFalseClick(TObject) | Represents method CBFalseClick(TObject).
CBTextCaseClick(TObject) | Represents method CBTextCaseClick(TObject).
CBTrueClick(TObject) | Represents method CBTrueClick(TObject).
Embedd(TComponent,TWinControl,TFilterItem) | Represents method Embedd(TComponent,TWinControl,TFilterItem).
ETextChange(TObject) | Represents method ETextChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
LBTextStyleClick(TObject) | Represents method LBTextStyleClick(TObject).
Refresh(TFilterItem) | Represents method Refresh(TFilterItem).
Top


TFilterItemEditor.CBFalseClick(TObject) Method

Summary

Represents method CBFalseClick(TObject).

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 procedure CBFalseClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.CBTextCaseClick(TObject) Method

Summary

Represents method CBTextCaseClick(TObject).

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 procedure CBTextCaseClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.CBTrueClick(TObject) Method

Summary

Represents method CBTrueClick(TObject).

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 procedure CBTrueClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.Embedd(TComponent,TWinControl,TFilterItem) Method

Summary

Represents method Embedd(TComponent,TWinControl,TFilterItem).

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent;
 const AParent:TWinControl;
 const AItem:TFilterItem):TFilterItemEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AItem
Type: TFilterItem

Return Value

Type: TFilterItemEditor

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.ETextChange(TObject) Method

Summary

Represents method ETextChange(TObject).

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 procedure ETextChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.LBTextStyleClick(TObject) Method

Summary

Represents method LBTextStyleClick(TObject).

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 procedure LBTextStyleClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.Refresh(TFilterItem) Method

Summary

Represents method Refresh(TFilterItem).

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
public
 procedure Refresh(const AItem:TFilterItem);

Parameters

AItem
Type: TFilterItem

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor Fields

Fields
Name | Description
CBFalse | Represents field CBFalse.
CBTextCase | Represents field CBTextCase.
CBTrue | Represents field CBTrue.
EText | Represents field EText.
Label1 | Represents field Label1.
LBTextStyle | Represents field LBTextStyle.
PageControl2 | Represents field PageControl2.
PageItem | Represents field PageItem.
PageNumeric | Represents field PageNumeric.
TabBoolean | Represents field TabBoolean.
TabDateTime | Represents field TabDateTime.
TabExcluded | Represents field TabExcluded.
TabIncluded | Represents field TabIncluded.
TabNumeric | Represents field TabNumeric.
TabNumericRange | Represents field TabNumericRange.
TabNumericSelected | Represents field TabNumericSelected.
TabText | Represents field TabText.
TabTextOptions | Represents field TabTextOptions.
Top


TFilterItemEditor.CBFalse Field

Summary

Represents field CBFalse.

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 CBFalse: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.CBTextCase Field

Summary

Represents field CBTextCase.

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 CBTextCase: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.CBTrue Field

Summary

Represents field CBTrue.

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 CBTrue: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.EText Field

Summary

Represents field EText.

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 EText: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.LBTextStyle Field

Summary

Represents field LBTextStyle.

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 LBTextStyle: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.PageControl2 Field

Summary

Represents field PageControl2.

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 PageControl2: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.PageItem Field

Summary

Represents field PageItem.

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 PageItem: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.PageNumeric Field

Summary

Represents field PageNumeric.

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 PageNumeric: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.TabBoolean Field

Summary

Represents field TabBoolean.

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 TabBoolean: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.TabDateTime Field

Summary

Represents field TabDateTime.

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 TabDateTime: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.TabExcluded Field

Summary

Represents field TabExcluded.

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 TabExcluded: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.TabIncluded Field

Summary

Represents field TabIncluded.

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 TabIncluded: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.TabNumeric Field

Summary

Represents field TabNumeric.

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 TabNumeric: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.TabNumericRange Field

Summary

Represents field TabNumericRange.

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 TabNumericRange: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.TabNumericSelected Field

Summary

Represents field TabNumericSelected.

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 TabNumericSelected: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.TabText Field

Summary

Represents field TabText.

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 TabText: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TFilterItemEditor.TabTextOptions Field

Summary

Represents field TabTextOptions.

Namespace: VCLBI.Editor.Filter.Item
Syntax
Delphi
published
 TabTextOptions: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TFilterItemEditor
  • VCLBI.Editor.Filter.Item


TNumericFromToAccess Class

Summary

Represents type TNumericFromToAccess.

Namespace: VCLBI.Editor.Filter.Item
Inheritance Hierarchy
TForm
VCLBI.Editor.NumericFromTo.TNumericFromTo
VCLBI.Editor.Filter.Item.TNumericFromToAccess
Syntax
Delphi
type
 TNumericFromToAccess=class(TNumericFromTo);
See Also

Reference

  • VCLBI.Editor.Filter.Item


VCLBI.Editor.Formats Namespace

Summary

Represents namespace VCLBI.Editor.Formats.

Classes
Name | Description
TDataFormatEditor | Represents type TDataFormatEditor.
Top


VCLBI.Editor.Formats Classes

Classes
Name | Description
TDataFormatEditor | Represents type TDataFormatEditor.
Top


TDataFormatEditor Class

Summary

Represents type TDataFormatEditor.

Namespace: VCLBI.Editor.Formats
Inheritance Hierarchy
TForm
VCLBI.Editor.Formats.TDataFormatEditor
Syntax
Delphi
type
 TDataFormatEditor = class(TForm)
 end;

The TDataFormatEditor type exposes the following members.

Methods
Show:
Name | Description
CBDelimiterChange(TObject) | Represents method CBDelimiterChange(TObject).
CBHeaderChange(TObject) | Represents method CBHeaderChange(TObject).
CBIncludeViewsClick(TObject) | Represents method CBIncludeViewsClick(TObject).
CBQuoteChange(TObject) | Represents method CBQuoteChange(TObject).
ECustomDelimiterChange(TObject) | Represents method ECustomDelimiterChange(TObject).
Edit1Change(TObject) | Represents method Edit1Change(TObject).
EExcelHeaderChange(TObject) | Represents method EExcelHeaderChange(TObject).
Embedd(TDataDefinition,TWinControl) | Represents method Embedd(TDataDefinition,TWinControl).
EMissingChange(TObject) | Represents method EMissingChange(TObject).
EZipPasswordChange(TObject) | Represents method EZipPasswordChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
Refresh(TDataDefinition) | Represents method Refresh(TDataDefinition).
RGJSONFormatClick(TObject) | Represents method RGJSONFormatClick(TObject).
RGJSONStyleClick(TObject) | Represents method RGJSONStyleClick(TObject).
RGXMLStyleClick(TObject) | Represents method RGXMLStyleClick(TObject).
Top
Fields
Show:
Name | Description
CBDelimiter | Represents field CBDelimiter.
CBHeader | Represents field CBHeader.
CBIncludeViews | Represents field CBIncludeViews.
CBQuote | Represents field CBQuote.
ECustomDelimiter | Represents field ECustomDelimiter.
Edit1 | Represents field Edit1.
EExcelHeader | Represents field EExcelHeader.
EMissing | Represents field EMissing.
EZipPassword | Represents field EZipPassword.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
PageFormat | Represents field PageFormat.
RGJSONFormat | Represents field RGJSONFormat.
RGJSONStyle | Represents field RGJSONStyle.
RGXMLStyle | Represents field RGXMLStyle.
TabCSV | Represents field TabCSV.
TabExcel | Represents field TabExcel.
TabJSON | Represents field TabJSON.
TabSheet1 | Represents field TabSheet1.
TabXML | Represents field TabXML.
TabZip | Represents field TabZip.
UDExcelHeader | Represents field UDExcelHeader.
UDHeader | Represents field UDHeader.
Top
See Also

Reference

  • VCLBI.Editor.Formats


TDataFormatEditor Methods

Methods
Name | Description
CBDelimiterChange(TObject) | Represents method CBDelimiterChange(TObject).
CBHeaderChange(TObject) | Represents method CBHeaderChange(TObject).
CBIncludeViewsClick(TObject) | Represents method CBIncludeViewsClick(TObject).
CBQuoteChange(TObject) | Represents method CBQuoteChange(TObject).
ECustomDelimiterChange(TObject) | Represents method ECustomDelimiterChange(TObject).
Edit1Change(TObject) | Represents method Edit1Change(TObject).
EExcelHeaderChange(TObject) | Represents method EExcelHeaderChange(TObject).
Embedd(TDataDefinition,TWinControl) | Represents method Embedd(TDataDefinition,TWinControl).
EMissingChange(TObject) | Represents method EMissingChange(TObject).
EZipPasswordChange(TObject) | Represents method EZipPasswordChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
Refresh(TDataDefinition) | Represents method Refresh(TDataDefinition).
RGJSONFormatClick(TObject) | Represents method RGJSONFormatClick(TObject).
RGJSONStyleClick(TObject) | Represents method RGJSONStyleClick(TObject).
RGXMLStyleClick(TObject) | Represents method RGXMLStyleClick(TObject).
Top


TDataFormatEditor.CBDelimiterChange(TObject) Method

Summary

Represents method CBDelimiterChange(TObject).

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 procedure CBDelimiterChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.CBHeaderChange(TObject) Method

Summary

Represents method CBHeaderChange(TObject).

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 procedure CBHeaderChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.CBIncludeViewsClick(TObject) Method

Summary

Represents method CBIncludeViewsClick(TObject).

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 procedure CBIncludeViewsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.CBQuoteChange(TObject) Method

Summary

Represents method CBQuoteChange(TObject).

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 procedure CBQuoteChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.ECustomDelimiterChange(TObject) Method

Summary

Represents method ECustomDelimiterChange(TObject).

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 procedure ECustomDelimiterChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.Edit1Change(TObject) Method

Summary

Represents method Edit1Change(TObject).

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 procedure Edit1Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.EExcelHeaderChange(TObject) Method

Summary

Represents method EExcelHeaderChange(TObject).

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 procedure EExcelHeaderChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.Embedd(TDataDefinition,TWinControl) Method

Summary

Represents method Embedd(TDataDefinition,TWinControl).

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
public
 class procedure Embedd(const AData:TDataDefinition; const AParent:TWinControl); static;

Parameters

AData
Type: TDataDefinition

AParent
Type: TWinControl

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.EMissingChange(TObject) Method

Summary

Represents method EMissingChange(TObject).

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 procedure EMissingChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.EZipPasswordChange(TObject) Method

Summary

Represents method EZipPasswordChange(TObject).

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 procedure EZipPasswordChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.Refresh(TDataDefinition) Method

Summary

Represents method Refresh(TDataDefinition).

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
public
 procedure Refresh(const AData:TDataDefinition);

Parameters

AData
Type: TDataDefinition

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.RGJSONFormatClick(TObject) Method

Summary

Represents method RGJSONFormatClick(TObject).

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 procedure RGJSONFormatClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.RGJSONStyleClick(TObject) Method

Summary

Represents method RGJSONStyleClick(TObject).

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 procedure RGJSONStyleClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.RGXMLStyleClick(TObject) Method

Summary

Represents method RGXMLStyleClick(TObject).

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 procedure RGXMLStyleClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor Fields

Fields
Name | Description
CBDelimiter | Represents field CBDelimiter.
CBHeader | Represents field CBHeader.
CBIncludeViews | Represents field CBIncludeViews.
CBQuote | Represents field CBQuote.
ECustomDelimiter | Represents field ECustomDelimiter.
Edit1 | Represents field Edit1.
EExcelHeader | Represents field EExcelHeader.
EMissing | Represents field EMissing.
EZipPassword | Represents field EZipPassword.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
PageFormat | Represents field PageFormat.
RGJSONFormat | Represents field RGJSONFormat.
RGJSONStyle | Represents field RGJSONStyle.
RGXMLStyle | Represents field RGXMLStyle.
TabCSV | Represents field TabCSV.
TabExcel | Represents field TabExcel.
TabJSON | Represents field TabJSON.
TabSheet1 | Represents field TabSheet1.
TabXML | Represents field TabXML.
TabZip | Represents field TabZip.
UDExcelHeader | Represents field UDExcelHeader.
UDHeader | Represents field UDHeader.
Top


TDataFormatEditor.CBDelimiter Field

Summary

Represents field CBDelimiter.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 CBDelimiter: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.CBHeader Field

Summary

Represents field CBHeader.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 CBHeader: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.CBIncludeViews Field

Summary

Represents field CBIncludeViews.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 CBIncludeViews: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.CBQuote Field

Summary

Represents field CBQuote.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 CBQuote: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.ECustomDelimiter Field

Summary

Represents field ECustomDelimiter.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 ECustomDelimiter: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.Edit1 Field

Summary

Represents field Edit1.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 Edit1: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.EExcelHeader Field

Summary

Represents field EExcelHeader.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 EExcelHeader: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.EMissing Field

Summary

Represents field EMissing.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 EMissing: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.EZipPassword Field

Summary

Represents field EZipPassword.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 EZipPassword: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.Label2 Field

Summary

Represents field Label2.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.Label3 Field

Summary

Represents field Label3.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.Label4 Field

Summary

Represents field Label4.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 Label4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.Label5 Field

Summary

Represents field Label5.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 Label5: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.Label6 Field

Summary

Represents field Label6.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 Label6: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.Label7 Field

Summary

Represents field Label7.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 Label7: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.PageFormat Field

Summary

Represents field PageFormat.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 PageFormat: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.RGJSONFormat Field

Summary

Represents field RGJSONFormat.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 RGJSONFormat: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.RGJSONStyle Field

Summary

Represents field RGJSONStyle.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 RGJSONStyle: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.RGXMLStyle Field

Summary

Represents field RGXMLStyle.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 RGXMLStyle: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.TabCSV Field

Summary

Represents field TabCSV.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 TabCSV: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.TabExcel Field

Summary

Represents field TabExcel.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 TabExcel: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.TabJSON Field

Summary

Represents field TabJSON.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 TabJSON: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.TabSheet1 Field

Summary

Represents field TabSheet1.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 TabSheet1: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.TabXML Field

Summary

Represents field TabXML.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 TabXML: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.TabZip Field

Summary

Represents field TabZip.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 TabZip: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.UDExcelHeader Field

Summary

Represents field UDExcelHeader.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 UDExcelHeader: TUpDown;

Field Value

Type: TUpDown

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


TDataFormatEditor.UDHeader Field

Summary

Represents field UDHeader.

Namespace: VCLBI.Editor.Formats
Syntax
Delphi
published
 UDHeader: TUpDown;

Field Value

Type: TUpDown

See Also

Reference

  • TDataFormatEditor
  • VCLBI.Editor.Formats


VCLBI.Editor.Grid Namespace

Summary

Represents namespace VCLBI.Editor.Grid.

Classes
Name | Description
TBIDBGridEditor | Represents type TBIDBGridEditor.
Top
Types
Name | Description
TColumnProc | Represents type TColumnProc.
Top
Constants
Name | Description
Options | Represents constant Options.
Top
Routines
Name | Description
Traverse(TColumn,TColumnProc) | Represents method Traverse(TColumn,TColumnProc).
Top


VCLBI.Editor.Grid Classes

Classes
Name | Description
TBIDBGridEditor | Represents type TBIDBGridEditor.
Top


TBIDBGridEditor Class

Summary

Represents type TBIDBGridEditor.

Namespace: VCLBI.Editor.Grid
Inheritance Hierarchy
TForm
VCLBI.Editor.Grid.TBIDBGridEditor
Syntax
Delphi
type
 TBIDBGridEditor = class(TForm)
 end;

The TBIDBGridEditor type exposes the following members.

Methods
Show:
Name | Description
BBackColorClick(TObject) | Represents method BBackColorClick(TObject).
BCellsFontClick(TObject) | Represents method BCellsFontClick(TObject).
BColColorClick(TObject) | Represents method BColColorClick(TObject).
BTitleFontClick(TObject) | Represents method BTitleFontClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
CBBorderClick(TObject) | Represents method CBBorderClick(TObject).
CBColAlignChange(TObject) | Represents method CBColAlignChange(TObject).
CBColExpandedClick(TObject) | Represents method CBColExpandedClick(TObject).
CBColVisibleClick(TObject) | Represents method CBColVisibleClick(TObject).
CBMenuClick(TObject) | Represents method CBMenuClick(TObject).
CBOptionsClickCheck(TObject) | Represents method CBOptionsClickCheck(TObject).
CBReadOnlyClick(TObject) | Represents method CBReadOnlyClick(TObject).
CBSortClick(TObject) | Represents method CBSortClick(TObject).
CBStyleChange(TObject) | Represents method CBStyleChange(TObject).
EColWidthChange(TObject) | Represents method EColWidthChange(TObject).
Edit(TComponent,TBIDBGrid) | Represents method Edit(TComponent,TBIDBGrid).
ELineWidthChange(TObject) | Represents method ELineWidthChange(TObject).
Embedd(TComponent,TWinControl,TBIDBGrid) | Represents method Embedd(TComponent,TWinControl,TBIDBGrid).
ERowHeightChange(TObject) | Represents method ERowHeightChange(TObject).
FillColumns | Represents method FillColumns.
FontDialog1Apply(TObject,HWND) | Represents method FontDialog1Apply(TObject,HWND).
FontDialog2Apply(TObject,HWND) | Represents method FontDialog2Apply(TObject,HWND).
FontDialog3Apply(TObject,HWND) | Represents method FontDialog3Apply(TObject,HWND).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
Refresh(TBIDBGrid) | Represents method Refresh(TBIDBGrid).
TreeChange(TObject,TTreeNode) | Represents method TreeChange(TObject,TTreeNode).
Top
Fields
Show:
Name | Description
BBackColor | Represents field BBackColor.
BCellsFont | Represents field BCellsFont.
BColColor | Represents field BColColor.
BTitleFont | Represents field BTitleFont.
Button1 | Represents field Button1.
CBBorder | Represents field CBBorder.
CBColAlign | Represents field CBColAlign.
CBColExpanded | Represents field CBColExpanded.
CBColVisible | Represents field CBColVisible.
CBMenu | Represents field CBMenu.
CBOptions | Represents field CBOptions.
CBReadOnly | Represents field CBReadOnly.
CBSort | Represents field CBSort.
CBStyle | Represents field CBStyle.
EColWidth | Represents field EColWidth.
ELineWidth | Represents field ELineWidth.
ERowHeight | Represents field ERowHeight.
FontDialog1 | Represents field FontDialog1.
FontDialog2 | Represents field FontDialog2.
FontDialog3 | Represents field FontDialog3.
GBColumn | Represents field GBColumn.
GroupBox2 | Represents field GroupBox2.
Label1 | Represents field Label1.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
PageControl1 | Represents field PageControl1.
TabMenu | Represents field TabMenu.
TabSheet1 | Represents field TabSheet1.
TabSheet2 | Represents field TabSheet2.
TabSheet3 | Represents field TabSheet3.
Tree | Represents field Tree.
UDColWidth | Represents field UDColWidth.
UDLineWidth | Represents field UDLineWidth.
UDRowHeight | Represents field UDRowHeight.
Top
See Also

Reference

  • VCLBI.Editor.Grid


TBIDBGridEditor Methods

Methods
Name | Description
BBackColorClick(TObject) | Represents method BBackColorClick(TObject).
BCellsFontClick(TObject) | Represents method BCellsFontClick(TObject).
BColColorClick(TObject) | Represents method BColColorClick(TObject).
BTitleFontClick(TObject) | Represents method BTitleFontClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
CBBorderClick(TObject) | Represents method CBBorderClick(TObject).
CBColAlignChange(TObject) | Represents method CBColAlignChange(TObject).
CBColExpandedClick(TObject) | Represents method CBColExpandedClick(TObject).
CBColVisibleClick(TObject) | Represents method CBColVisibleClick(TObject).
CBMenuClick(TObject) | Represents method CBMenuClick(TObject).
CBOptionsClickCheck(TObject) | Represents method CBOptionsClickCheck(TObject).
CBReadOnlyClick(TObject) | Represents method CBReadOnlyClick(TObject).
CBSortClick(TObject) | Represents method CBSortClick(TObject).
CBStyleChange(TObject) | Represents method CBStyleChange(TObject).
EColWidthChange(TObject) | Represents method EColWidthChange(TObject).
Edit(TComponent,TBIDBGrid) | Represents method Edit(TComponent,TBIDBGrid).
ELineWidthChange(TObject) | Represents method ELineWidthChange(TObject).
Embedd(TComponent,TWinControl,TBIDBGrid) | Represents method Embedd(TComponent,TWinControl,TBIDBGrid).
ERowHeightChange(TObject) | Represents method ERowHeightChange(TObject).
FillColumns | Represents method FillColumns.
FontDialog1Apply(TObject,HWND) | Represents method FontDialog1Apply(TObject,HWND).
FontDialog2Apply(TObject,HWND) | Represents method FontDialog2Apply(TObject,HWND).
FontDialog3Apply(TObject,HWND) | Represents method FontDialog3Apply(TObject,HWND).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
Refresh(TBIDBGrid) | Represents method Refresh(TBIDBGrid).
TreeChange(TObject,TTreeNode) | Represents method TreeChange(TObject,TTreeNode).
Top


TBIDBGridEditor.BBackColorClick(TObject) Method

Summary

Represents method BBackColorClick(TObject).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure BBackColorClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.BCellsFontClick(TObject) Method

Summary

Represents method BCellsFontClick(TObject).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure BCellsFontClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.BColColorClick(TObject) Method

Summary

Represents method BColColorClick(TObject).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure BColColorClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.BTitleFontClick(TObject) Method

Summary

Represents method BTitleFontClick(TObject).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure BTitleFontClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.CBBorderClick(TObject) Method

Summary

Represents method CBBorderClick(TObject).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure CBBorderClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.CBColAlignChange(TObject) Method

Summary

Represents method CBColAlignChange(TObject).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure CBColAlignChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.CBColExpandedClick(TObject) Method

Summary

Represents method CBColExpandedClick(TObject).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure CBColExpandedClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.CBColVisibleClick(TObject) Method

Summary

Represents method CBColVisibleClick(TObject).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure CBColVisibleClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.CBMenuClick(TObject) Method

Summary

Represents method CBMenuClick(TObject).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure CBMenuClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.CBOptionsClickCheck(TObject) Method

Summary

Represents method CBOptionsClickCheck(TObject).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure CBOptionsClickCheck(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.CBReadOnlyClick(TObject) Method

Summary

Represents method CBReadOnlyClick(TObject).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure CBReadOnlyClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.CBSortClick(TObject) Method

Summary

Represents method CBSortClick(TObject).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure CBSortClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.CBStyleChange(TObject) Method

Summary

Represents method CBStyleChange(TObject).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure CBStyleChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.EColWidthChange(TObject) Method

Summary

Represents method EColWidthChange(TObject).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure EColWidthChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.Edit(TComponent,TBIDBGrid) Method

Summary

Represents method Edit(TComponent,TBIDBGrid).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
public
 class procedure Edit(const AOwner:TComponent; const ABIGrid:TBIDBGrid); static;

Parameters

AOwner
Type: TComponent

ABIGrid
Type: TBIDBGrid

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.ELineWidthChange(TObject) Method

Summary

Represents method ELineWidthChange(TObject).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure ELineWidthChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.Embedd(TComponent,TWinControl,TBIDBGrid) Method

Summary

Represents method Embedd(TComponent,TWinControl,TBIDBGrid).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const AGrid:TBIDBGrid):TBIDBGridEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AGrid
Type: TBIDBGrid

Return Value

Type: TBIDBGridEditor

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.ERowHeightChange(TObject) Method

Summary

Represents method ERowHeightChange(TObject).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure ERowHeightChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.FillColumns Method

Summary

Represents method FillColumns.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
public
 procedure FillColumns;
See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.FontDialog1Apply(TObject,HWND) Method

Summary

Represents method FontDialog1Apply(TObject,HWND).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure FontDialog1Apply(Sender: TObject; Wnd: HWND);

Parameters

Sender
Type: TObject

Wnd
Type: HWND

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.FontDialog2Apply(TObject,HWND) Method

Summary

Represents method FontDialog2Apply(TObject,HWND).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure FontDialog2Apply(Sender: TObject; Wnd: HWND);

Parameters

Sender
Type: TObject

Wnd
Type: HWND

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.FontDialog3Apply(TObject,HWND) Method

Summary

Represents method FontDialog3Apply(TObject,HWND).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure FontDialog3Apply(Sender: TObject; Wnd: HWND);

Parameters

Sender
Type: TObject

Wnd
Type: HWND

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.FormClose(TObject,TCloseAction) Method

Summary

Represents method FormClose(TObject,TCloseAction).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure FormClose(Sender: TObject; var Action: TCloseAction);

Parameters

Sender
Type: TObject

Action
Type: TCloseAction

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.Refresh(TBIDBGrid) Method

Summary

Represents method Refresh(TBIDBGrid).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
public
 procedure Refresh(const AGrid:TBIDBGrid);

Parameters

AGrid
Type: TBIDBGrid

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.TreeChange(TObject,TTreeNode) Method

Summary

Represents method TreeChange(TObject,TTreeNode).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 procedure TreeChange(Sender: TObject; Node: TTreeNode);

Parameters

Sender
Type: TObject

Node
Type: TTreeNode

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor Fields

Fields
Name | Description
BBackColor | Represents field BBackColor.
BCellsFont | Represents field BCellsFont.
BColColor | Represents field BColColor.
BTitleFont | Represents field BTitleFont.
Button1 | Represents field Button1.
CBBorder | Represents field CBBorder.
CBColAlign | Represents field CBColAlign.
CBColExpanded | Represents field CBColExpanded.
CBColVisible | Represents field CBColVisible.
CBMenu | Represents field CBMenu.
CBOptions | Represents field CBOptions.
CBReadOnly | Represents field CBReadOnly.
CBSort | Represents field CBSort.
CBStyle | Represents field CBStyle.
EColWidth | Represents field EColWidth.
ELineWidth | Represents field ELineWidth.
ERowHeight | Represents field ERowHeight.
FontDialog1 | Represents field FontDialog1.
FontDialog2 | Represents field FontDialog2.
FontDialog3 | Represents field FontDialog3.
GBColumn | Represents field GBColumn.
GroupBox2 | Represents field GroupBox2.
Label1 | Represents field Label1.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
PageControl1 | Represents field PageControl1.
TabMenu | Represents field TabMenu.
TabSheet1 | Represents field TabSheet1.
TabSheet2 | Represents field TabSheet2.
TabSheet3 | Represents field TabSheet3.
Tree | Represents field Tree.
UDColWidth | Represents field UDColWidth.
UDLineWidth | Represents field UDLineWidth.
UDRowHeight | Represents field UDRowHeight.
Top


TBIDBGridEditor.BBackColor Field

Summary

Represents field BBackColor.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 BBackColor: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.BCellsFont Field

Summary

Represents field BCellsFont.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 BCellsFont: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.BColColor Field

Summary

Represents field BColColor.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 BColColor: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.BTitleFont Field

Summary

Represents field BTitleFont.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 BTitleFont: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.Button1 Field

Summary

Represents field Button1.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.CBBorder Field

Summary

Represents field CBBorder.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 CBBorder: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.CBColAlign Field

Summary

Represents field CBColAlign.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 CBColAlign: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.CBColExpanded Field

Summary

Represents field CBColExpanded.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 CBColExpanded: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.CBColVisible Field

Summary

Represents field CBColVisible.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 CBColVisible: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.CBMenu Field

Summary

Represents field CBMenu.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 CBMenu: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.CBOptions Field

Summary

Represents field CBOptions.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 CBOptions: TCheckListBox;

Field Value

Type: TCheckListBox

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.CBReadOnly Field

Summary

Represents field CBReadOnly.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 CBReadOnly: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.CBSort Field

Summary

Represents field CBSort.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 CBSort: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.CBStyle Field

Summary

Represents field CBStyle.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 CBStyle: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.EColWidth Field

Summary

Represents field EColWidth.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 EColWidth: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.ELineWidth Field

Summary

Represents field ELineWidth.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 ELineWidth: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.ERowHeight Field

Summary

Represents field ERowHeight.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 ERowHeight: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.FontDialog1 Field

Summary

Represents field FontDialog1.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 FontDialog1: TFontDialog;

Field Value

Type: TFontDialog

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.FontDialog2 Field

Summary

Represents field FontDialog2.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 FontDialog2: TFontDialog;

Field Value

Type: TFontDialog

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.FontDialog3 Field

Summary

Represents field FontDialog3.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 FontDialog3: TFontDialog;

Field Value

Type: TFontDialog

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.GBColumn Field

Summary

Represents field GBColumn.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 GBColumn: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.GroupBox2 Field

Summary

Represents field GroupBox2.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 GroupBox2: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.Label3 Field

Summary

Represents field Label3.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.Label4 Field

Summary

Represents field Label4.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 Label4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.Label5 Field

Summary

Represents field Label5.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 Label5: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.PageControl1 Field

Summary

Represents field PageControl1.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 PageControl1: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.TabMenu Field

Summary

Represents field TabMenu.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 TabMenu: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.TabSheet1 Field

Summary

Represents field TabSheet1.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 TabSheet1: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.TabSheet2 Field

Summary

Represents field TabSheet2.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 TabSheet2: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.TabSheet3 Field

Summary

Represents field TabSheet3.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 TabSheet3: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.Tree Field

Summary

Represents field Tree.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 Tree: TTreeView;

Field Value

Type: TTreeView

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.UDColWidth Field

Summary

Represents field UDColWidth.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 UDColWidth: TUpDown;

Field Value

Type: TUpDown

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.UDLineWidth Field

Summary

Represents field UDLineWidth.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 UDLineWidth: TUpDown;

Field Value

Type: TUpDown

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


TBIDBGridEditor.UDRowHeight Field

Summary

Represents field UDRowHeight.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
published
 UDRowHeight: TUpDown;

Field Value

Type: TUpDown

See Also

Reference

  • TBIDBGridEditor
  • VCLBI.Editor.Grid


VCLBI.Editor.Grid Types

Types
Name | Description
TColumnProc | Represents type TColumnProc.
Top


TColumnProc Type

Summary

Represents type TColumnProc.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
type
 TColumnProc=reference to procedure(const Col:TColumn) ;
See Also

Reference

  • VCLBI.Editor.Grid


VCLBI.Editor.Grid Constants

Constants
Name | Description
Options | Represents constant Options.
Top


Options Constant

Summary

Represents constant Options.

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
 Options:Array[0..13] of TDBGridOption=(
 dgAlwaysShowEditor,
 dgAlwaysShowSelection,
 dgCancelOnExit,
 dgColLines,
 dgColumnResize,
 dgConfirmDelete,
 dgEditing,
 dgIndicator,
 dgRowLines,
 dgRowSelect,
 dgTabs,
 dgTitleClick,
 dgTitleHotTrack,
 dgTitles);

Value

Type: Array[0..13] of TDBGridOption

See Also

Reference

  • VCLBI.Editor.Grid


VCLBI.Editor.Grid Routines

Routines
Name | Description
Traverse(TColumn,TColumnProc) | Represents method Traverse(TColumn,TColumnProc).
Top


Traverse(TColumn,TColumnProc) Method

Summary

Represents method Traverse(TColumn,TColumnProc).

Namespace: VCLBI.Editor.Grid
Syntax
Delphi
procedure Traverse(const Col:TColumn; const Proc:TColumnProc);

Parameters

Col
Type: TColumn

Proc
Type: TColumnProc

See Also

Reference

  • VCLBI.Editor.Grid


VCLBI.Editor.Gridify Namespace

Summary

Represents namespace VCLBI.Editor.Gridify.

Classes
Name | Description
TGridifyEditor | Represents type TGridifyEditor.
Top


VCLBI.Editor.Gridify Classes

Classes
Name | Description
TGridifyEditor | Represents type TGridifyEditor.
Top


TGridifyEditor Class

Summary

Represents type TGridifyEditor.

Namespace: VCLBI.Editor.Gridify
Inheritance Hierarchy
TForm
VCLBI.Editor.Gridify.TGridifyEditor
Syntax
Delphi
type
 TGridifyEditor = class(TForm)
 end;

The TGridifyEditor type exposes the following members.

Methods
Show:
Name | Description
Choose(TComponent,TDataItem,TComponent,TDataGridifyItem) | Represents method Choose(TComponent,TDataItem,TComponent,TDataGridifyItem).
FormShow(TObject) | Represents method FormShow(TObject).
Top
Fields
Show:
Name | Description
BCancel | Represents field BCancel.
BOk | Represents field BOk.
PageControl1 | Represents field PageControl1.
PanelButtons | Represents field PanelButtons.
PanelOk | Represents field PanelOk.
TabColumns | Represents field TabColumns.
TabRows | Represents field TabRows.
TabValue | Represents field TabValue.
Top
See Also

Reference

  • VCLBI.Editor.Gridify


TGridifyEditor Methods

Methods
Name | Description
Choose(TComponent,TDataItem,TComponent,TDataGridifyItem) | Represents method Choose(TComponent,TDataItem,TComponent,TDataGridifyItem).
FormShow(TObject) | Represents method FormShow(TObject).
Top


TGridifyEditor.Choose(TComponent,TDataItem,TComponent,TDataGridifyItem) Method

Summary

Represents method Choose(TComponent,TDataItem,TComponent,TDataGridifyItem).

Namespace: VCLBI.Editor.Gridify
Syntax
Delphi
public
 class function Choose(const AOwner:TComponent;
 const AData:TDataItem;
 const AGridOwner:TComponent;
 out AGrid:TDataGridifyItem):Boolean; static;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

AGridOwner
Type: TComponent

AGrid
Type: TDataGridifyItem

Return Value

Type: Boolean

See Also

Reference

  • TGridifyEditor
  • VCLBI.Editor.Gridify


TGridifyEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Editor.Gridify
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TGridifyEditor
  • VCLBI.Editor.Gridify


TGridifyEditor Fields

Fields
Name | Description
BCancel | Represents field BCancel.
BOk | Represents field BOk.
PageControl1 | Represents field PageControl1.
PanelButtons | Represents field PanelButtons.
PanelOk | Represents field PanelOk.
TabColumns | Represents field TabColumns.
TabRows | Represents field TabRows.
TabValue | Represents field TabValue.
Top


TGridifyEditor.BCancel Field

Summary

Represents field BCancel.

Namespace: VCLBI.Editor.Gridify
Syntax
Delphi
published
 BCancel: TButton;

Field Value

Type: TButton

See Also

Reference

  • TGridifyEditor
  • VCLBI.Editor.Gridify


TGridifyEditor.BOk Field

Summary

Represents field BOk.

Namespace: VCLBI.Editor.Gridify
Syntax
Delphi
published
 BOk: TButton;

Field Value

Type: TButton

See Also

Reference

  • TGridifyEditor
  • VCLBI.Editor.Gridify


TGridifyEditor.PageControl1 Field

Summary

Represents field PageControl1.

Namespace: VCLBI.Editor.Gridify
Syntax
Delphi
published
 PageControl1: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TGridifyEditor
  • VCLBI.Editor.Gridify


TGridifyEditor.PanelButtons Field

Summary

Represents field PanelButtons.

Namespace: VCLBI.Editor.Gridify
Syntax
Delphi
published
 PanelButtons: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TGridifyEditor
  • VCLBI.Editor.Gridify


TGridifyEditor.PanelOk Field

Summary

Represents field PanelOk.

Namespace: VCLBI.Editor.Gridify
Syntax
Delphi
published
 PanelOk: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TGridifyEditor
  • VCLBI.Editor.Gridify


TGridifyEditor.TabColumns Field

Summary

Represents field TabColumns.

Namespace: VCLBI.Editor.Gridify
Syntax
Delphi
published
 TabColumns: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TGridifyEditor
  • VCLBI.Editor.Gridify


TGridifyEditor.TabRows Field

Summary

Represents field TabRows.

Namespace: VCLBI.Editor.Gridify
Syntax
Delphi
published
 TabRows: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TGridifyEditor
  • VCLBI.Editor.Gridify


TGridifyEditor.TabValue Field

Summary

Represents field TabValue.

Namespace: VCLBI.Editor.Gridify
Syntax
Delphi
published
 TabValue: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TGridifyEditor
  • VCLBI.Editor.Gridify


VCLBI.Editor.Hops Namespace

Summary

Represents namespace VCLBI.Editor.Hops.

Classes
Name | Description
TBIQueryAccess | Represents type TBIQueryAccess.
THopsViewer | Represents type THopsViewer.
TSummaryAccess | Represents type TSummaryAccess.
TSummaryItemAccess | Represents type TSummaryItemAccess.
Top
Routines
Name | Description
HopsFromSelect(TDataSelect) | Represents method HopsFromSelect(TDataSelect).
HopsFromSummary(TSummary) | Represents method HopsFromSummary(TSummary).
Top


VCLBI.Editor.Hops Classes

Classes
Name | Description
TBIQueryAccess | Represents type TBIQueryAccess.
THopsViewer | Represents type THopsViewer.
TSummaryAccess | Represents type TSummaryAccess.
TSummaryItemAccess | Represents type TSummaryItemAccess.
Top


TBIQueryAccess Class

Summary

Represents type TBIQueryAccess.

Namespace: VCLBI.Editor.Hops
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Persist.TBaseDataImporter
BI.Query.TBIQuery
VCLBI.Editor.Hops.TBIQueryAccess
Syntax
Delphi
type
 TBIQueryAccess=class(TBIQuery);
See Also

Reference

  • VCLBI.Editor.Hops


THopsViewer Class

Summary

Represents type THopsViewer.

Namespace: VCLBI.Editor.Hops
Inheritance Hierarchy
TForm
VCLBI.Editor.Hops.THopsViewer
Syntax
Delphi
type
 THopsViewer = class(TForm)
 end;

The THopsViewer type exposes the following members.

Methods
Show:
Name | Description
FormShow(TObject) | Represents method FormShow(TObject).
HopsFrom(TBIQuery) | Overloaded. Represents method HopsFrom(TBIQuery).
HopsFrom(TDataProvider) | Overloaded. Represents method HopsFrom(TDataProvider).
LBHopsClick(TObject) | Represents method LBHopsClick(TObject).
View(TComponent,TBIQuery) | Overloaded. Represents method View(TComponent,TBIQuery).
View(TComponent,TDataHops) | Overloaded. Represents method View(TComponent,TDataHops).
Top
Fields
Show:
Name | Description
Label1 | Represents field Label1.
Label2 | Represents field Label2.
LBHops | Represents field LBHops.
LBItems | Represents field LBItems.
LCount | Represents field LCount.
LMain | Represents field LMain.
LParent | Represents field LParent.
Top
See Also

Reference

  • VCLBI.Editor.Hops


THopsViewer Methods

Methods
Name | Description
FormShow(TObject) | Represents method FormShow(TObject).
HopsFrom(TBIQuery) | Overloaded. Represents method HopsFrom(TBIQuery).
HopsFrom(TDataProvider) | Overloaded. Represents method HopsFrom(TDataProvider).
LBHopsClick(TObject) | Represents method LBHopsClick(TObject).
View(TComponent,TBIQuery) | Overloaded. Represents method View(TComponent,TBIQuery).
View(TComponent,TDataHops) | Overloaded. Represents method View(TComponent,TDataHops).
Top


THopsViewer.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Editor.Hops
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • THopsViewer
  • VCLBI.Editor.Hops


THopsViewer.HopsFrom(TBIQuery) Method

Summary

Represents method HopsFrom(TBIQuery).

Namespace: VCLBI.Editor.Hops
Syntax
Delphi
public
 class function HopsFrom(const AQuery:TBIQuery):TDataHops; overload; static;

Parameters

AQuery
Type: TBIQuery

Return Value

Type: TDataHops

See Also

Reference

  • THopsViewer
  • VCLBI.Editor.Hops


THopsViewer.HopsFrom(TDataProvider) Method

Summary

Represents method HopsFrom(TDataProvider).

Namespace: VCLBI.Editor.Hops
Syntax
Delphi
public
 class function HopsFrom(const AProvider:TDataProvider):TDataHops; overload; static;

Parameters

AProvider
Type: TDataProvider

Return Value

Type: TDataHops

See Also

Reference

  • THopsViewer
  • VCLBI.Editor.Hops


THopsViewer.LBHopsClick(TObject) Method

Summary

Represents method LBHopsClick(TObject).

Namespace: VCLBI.Editor.Hops
Syntax
Delphi
published
 procedure LBHopsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • THopsViewer
  • VCLBI.Editor.Hops


THopsViewer.View(TComponent,TBIQuery) Method

Summary

Represents method View(TComponent,TBIQuery).

Namespace: VCLBI.Editor.Hops
Syntax
Delphi
public
 class procedure View(const AOwner:TComponent; const AQuery:TBIQuery); overload; static;

Parameters

AOwner
Type: TComponent

AQuery
Type: TBIQuery

See Also

Reference

  • THopsViewer
  • VCLBI.Editor.Hops


THopsViewer.View(TComponent,TDataHops) Method

Summary

Represents method View(TComponent,TDataHops).

Namespace: VCLBI.Editor.Hops
Syntax
Delphi
public
 class procedure View(const AOwner:TComponent; const AHops:TDataHops); overload; static;

Parameters

AOwner
Type: TComponent

AHops
Type: TDataHops

See Also

Reference

  • THopsViewer
  • VCLBI.Editor.Hops


THopsViewer Fields

Fields
Name | Description
Label1 | Represents field Label1.
Label2 | Represents field Label2.
LBHops | Represents field LBHops.
LBItems | Represents field LBItems.
LCount | Represents field LCount.
LMain | Represents field LMain.
LParent | Represents field LParent.
Top


THopsViewer.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.Editor.Hops
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • THopsViewer
  • VCLBI.Editor.Hops


THopsViewer.Label2 Field

Summary

Represents field Label2.

Namespace: VCLBI.Editor.Hops
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • THopsViewer
  • VCLBI.Editor.Hops


THopsViewer.LBHops Field

Summary

Represents field LBHops.

Namespace: VCLBI.Editor.Hops
Syntax
Delphi
published
 LBHops: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • THopsViewer
  • VCLBI.Editor.Hops


THopsViewer.LBItems Field

Summary

Represents field LBItems.

Namespace: VCLBI.Editor.Hops
Syntax
Delphi
published
 LBItems: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • THopsViewer
  • VCLBI.Editor.Hops


THopsViewer.LCount Field

Summary

Represents field LCount.

Namespace: VCLBI.Editor.Hops
Syntax
Delphi
published
 LCount: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • THopsViewer
  • VCLBI.Editor.Hops


THopsViewer.LMain Field

Summary

Represents field LMain.

Namespace: VCLBI.Editor.Hops
Syntax
Delphi
published
 LMain: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • THopsViewer
  • VCLBI.Editor.Hops


THopsViewer.LParent Field

Summary

Represents field LParent.

Namespace: VCLBI.Editor.Hops
Syntax
Delphi
published
 LParent: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • THopsViewer
  • VCLBI.Editor.Hops


TSummaryAccess Class

Summary

Represents type TSummaryAccess.

Namespace: VCLBI.Editor.Hops
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
BI.Summary.TSummary
VCLBI.Editor.Hops.TSummaryAccess
Syntax
Delphi
type
 TSummaryAccess=class(TSummary);
See Also

Reference

  • VCLBI.Editor.Hops


TSummaryItemAccess Class

Summary

Represents type TSummaryItemAccess.

Namespace: VCLBI.Editor.Hops
Inheritance Hierarchy
TPersistent
BI.Summary.TBaseSummaryPersistent
BI.Summary.TSummaryItem
VCLBI.Editor.Hops.TSummaryItemAccess
Syntax
Delphi
type
 TSummaryItemAccess=class(TSummaryItem);
See Also

Reference

  • VCLBI.Editor.Hops


VCLBI.Editor.Hops Routines

Routines
Name | Description
HopsFromSelect(TDataSelect) | Represents method HopsFromSelect(TDataSelect).
HopsFromSummary(TSummary) | Represents method HopsFromSummary(TSummary).
Top


HopsFromSelect(TDataSelect) Method

Summary

Represents method HopsFromSelect(TDataSelect).

Namespace: VCLBI.Editor.Hops
Syntax
Delphi
function HopsFromSelect(const ASelect:TDataSelect):TDataHops;

Parameters

ASelect
Type: TDataSelect

Return Value

Type: TDataHops

See Also

Reference

  • VCLBI.Editor.Hops


HopsFromSummary(TSummary) Method

Summary

Represents method HopsFromSummary(TSummary).

Namespace: VCLBI.Editor.Hops
Syntax
Delphi
function HopsFromSummary(const ASummary:TSummary):TDataHops;

Parameters

ASummary
Type: TSummary

Return Value

Type: TDataHops

See Also

Reference

  • VCLBI.Editor.Hops


VCLBI.Editor.Items Namespace

Summary

Represents namespace VCLBI.Editor.Items.

Classes
Name | Description
TItemsEditor | Represents type TItemsEditor.
Top


VCLBI.Editor.Items Classes

Classes
Name | Description
TItemsEditor | Represents type TItemsEditor.
Top


TItemsEditor Class

Summary

Represents type TItemsEditor.

Namespace: VCLBI.Editor.Items
Inheritance Hierarchy
TForm
VCLBI.Editor.Items.TItemsEditor
Syntax
Delphi
type
 TItemsEditor = class(TForm)
 end;

The TItemsEditor type exposes the following members.

Methods
Show:
Name | Description
CBKindChange(TObject) | Represents method CBKindChange(TObject).
Edit(TComponent,TDataItems) | Represents method Edit(TComponent,TDataItems).
Embedd(TComponent,TWinControl,TDataItems) | Represents method Embedd(TComponent,TWinControl,TDataItems).
ENameChange(TObject) | Represents method ENameChange(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
LBFieldsClick(TObject) | Represents method LBFieldsClick(TObject).
LBFieldsDragDrop(TObject,TObject,Integer,Integer) | Represents method LBFieldsDragDrop(TObject,TObject,Integer,Integer).
LBFieldsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method LBFieldsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
Refresh(TDataItems) | Represents method Refresh(TDataItems).
SBAddFieldClick(TObject) | Represents method SBAddFieldClick(TObject).
SBDownFieldClick(TObject) | Represents method SBDownFieldClick(TObject).
SBRemoveFieldClick(TObject) | Represents method SBRemoveFieldClick(TObject).
SBUpFieldClick(TObject) | Represents method SBUpFieldClick(TObject).
Top
Fields
Show:
Name | Description
BOK | Represents field BOK.
CBKind | Represents field CBKind.
EName | Represents field EName.
GroupBox1 | Represents field GroupBox1.
Label24 | Represents field Label24.
Label25 | Represents field Label25.
LBFields | Represents field LBFields.
LDuplicateName | Represents field LDuplicateName.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
Panel5 | Represents field Panel5.
PanelButtons | Represents field PanelButtons.
PanelGrid | Represents field PanelGrid.
SBAddField | Represents field SBAddField.
SBDownField | Represents field SBDownField.
SBRemoveField | Represents field SBRemoveField.
SBUpField | Represents field SBUpField.
Splitter1 | Represents field Splitter1.
Top
See Also

Reference

  • VCLBI.Editor.Items


TItemsEditor Methods

Methods
Name | Description
CBKindChange(TObject) | Represents method CBKindChange(TObject).
Edit(TComponent,TDataItems) | Represents method Edit(TComponent,TDataItems).
Embedd(TComponent,TWinControl,TDataItems) | Represents method Embedd(TComponent,TWinControl,TDataItems).
ENameChange(TObject) | Represents method ENameChange(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
LBFieldsClick(TObject) | Represents method LBFieldsClick(TObject).
LBFieldsDragDrop(TObject,TObject,Integer,Integer) | Represents method LBFieldsDragDrop(TObject,TObject,Integer,Integer).
LBFieldsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method LBFieldsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
Refresh(TDataItems) | Represents method Refresh(TDataItems).
SBAddFieldClick(TObject) | Represents method SBAddFieldClick(TObject).
SBDownFieldClick(TObject) | Represents method SBDownFieldClick(TObject).
SBRemoveFieldClick(TObject) | Represents method SBRemoveFieldClick(TObject).
SBUpFieldClick(TObject) | Represents method SBUpFieldClick(TObject).
Top


TItemsEditor.CBKindChange(TObject) Method

Summary

Represents method CBKindChange(TObject).

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 procedure CBKindChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.Edit(TComponent,TDataItems) Method

Summary

Represents method Edit(TComponent,TDataItems).

Namespace: VCLBI.Editor.Items
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent;
 const AItems:TDataItems):Boolean; static;

Parameters

AOwner
Type: TComponent

AItems
Type: TDataItems

Return Value

Type: Boolean

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.Embedd(TComponent,TWinControl,TDataItems) Method

Summary

Represents method Embedd(TComponent,TWinControl,TDataItems).

Namespace: VCLBI.Editor.Items
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const AItems:TDataItems):TItemsEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AItems
Type: TDataItems

Return Value

Type: TItemsEditor

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.ENameChange(TObject) Method

Summary

Represents method ENameChange(TObject).

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 procedure ENameChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.LBFieldsClick(TObject) Method

Summary

Represents method LBFieldsClick(TObject).

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 procedure LBFieldsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.LBFieldsDragDrop(TObject,TObject,Integer,Integer) Method

Summary

Represents method LBFieldsDragDrop(TObject,TObject,Integer,Integer).

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 procedure LBFieldsDragDrop(Sender, Source: TObject; X, Y: Integer);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.LBFieldsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) Method

Summary

Represents method LBFieldsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 procedure LBFieldsDragOver(Sender, Source: TObject; X, Y: Integer;
 State: TDragState; var Accept: Boolean);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

State
Type: TDragState

Accept
Type: Boolean

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.Refresh(TDataItems) Method

Summary

Represents method Refresh(TDataItems).

Namespace: VCLBI.Editor.Items
Syntax
Delphi
public
 procedure Refresh(const AItems:TDataItems);

Parameters

AItems
Type: TDataItems

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.SBAddFieldClick(TObject) Method

Summary

Represents method SBAddFieldClick(TObject).

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 procedure SBAddFieldClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.SBDownFieldClick(TObject) Method

Summary

Represents method SBDownFieldClick(TObject).

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 procedure SBDownFieldClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.SBRemoveFieldClick(TObject) Method

Summary

Represents method SBRemoveFieldClick(TObject).

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 procedure SBRemoveFieldClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.SBUpFieldClick(TObject) Method

Summary

Represents method SBUpFieldClick(TObject).

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 procedure SBUpFieldClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor Fields

Fields
Name | Description
BOK | Represents field BOK.
CBKind | Represents field CBKind.
EName | Represents field EName.
GroupBox1 | Represents field GroupBox1.
Label24 | Represents field Label24.
Label25 | Represents field Label25.
LBFields | Represents field LBFields.
LDuplicateName | Represents field LDuplicateName.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
Panel5 | Represents field Panel5.
PanelButtons | Represents field PanelButtons.
PanelGrid | Represents field PanelGrid.
SBAddField | Represents field SBAddField.
SBDownField | Represents field SBDownField.
SBRemoveField | Represents field SBRemoveField.
SBUpField | Represents field SBUpField.
Splitter1 | Represents field Splitter1.
Top


TItemsEditor.BOK Field

Summary

Represents field BOK.

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 BOK: TButton;

Field Value

Type: TButton

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.CBKind Field

Summary

Represents field CBKind.

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 CBKind: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.EName Field

Summary

Represents field EName.

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 EName: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.GroupBox1 Field

Summary

Represents field GroupBox1.

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 GroupBox1: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.Label24 Field

Summary

Represents field Label24.

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 Label24: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.Label25 Field

Summary

Represents field Label25.

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 Label25: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.LBFields Field

Summary

Represents field LBFields.

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 LBFields: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.LDuplicateName Field

Summary

Represents field LDuplicateName.

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 LDuplicateName: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.Panel3 Field

Summary

Represents field Panel3.

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 Panel3: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.Panel4 Field

Summary

Represents field Panel4.

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 Panel4: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.Panel5 Field

Summary

Represents field Panel5.

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 Panel5: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.PanelButtons Field

Summary

Represents field PanelButtons.

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 PanelButtons: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.PanelGrid Field

Summary

Represents field PanelGrid.

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 PanelGrid: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.SBAddField Field

Summary

Represents field SBAddField.

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 SBAddField: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.SBDownField Field

Summary

Represents field SBDownField.

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 SBDownField: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.SBRemoveField Field

Summary

Represents field SBRemoveField.

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 SBRemoveField: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.SBUpField Field

Summary

Represents field SBUpField.

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 SBUpField: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


TItemsEditor.Splitter1 Field

Summary

Represents field Splitter1.

Namespace: VCLBI.Editor.Items
Syntax
Delphi
published
 Splitter1: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TItemsEditor
  • VCLBI.Editor.Items


VCLBI.Editor.ListItems Namespace

Summary

Represents namespace VCLBI.Editor.ListItems.

Classes
Name | Description
TFormListItems | Represents type TFormListItems.
Top
Delegates
Name | Description
TListExchangedEvent | Represents type TListExchangedEvent.
TListItemsEvent | Represents type TListItemsEvent.
Top


VCLBI.Editor.ListItems Classes

Classes
Name | Description
TFormListItems | Represents type TFormListItems.
Top


TFormListItems Class

Summary

Represents type TFormListItems.

Namespace: VCLBI.Editor.ListItems
Inheritance Hierarchy
TForm
VCLBI.Editor.ListItems.TFormListItems
Syntax
Delphi
type
 TFormListItems = class(TForm)
 end;

The TFormListItems type exposes the following members.

Properties
Show:
Name | Description
OnChanged | Represents property OnChanged.
OnChecked | Represents property OnChecked.
OnCheckedAll | Represents property OnCheckedAll.
OnSelected | Represents property OnSelected.
Top
Methods
Show:
Name | Description
AddCombo(TComboBox,TDataItem[]) | Represents method AddCombo(TComboBox,TDataItem[]).
AddItems(TDataItem[],Boolean) | Overloaded. Represents method AddItems(TDataItem[],Boolean).
AddItems(TStrings,TDataItem[],Boolean) | Overloaded. Represents method AddItems(TStrings,TDataItem[],Boolean).
AddMap(TDataItem) | Overloaded. Represents method AddMap(TDataItem).
AddMap(TDataItem,TStrings) | Overloaded. Represents method AddMap(TDataItem,TStrings).
BAllClick(TObject) | Represents method BAllClick(TObject).
BNoneClick(TObject) | Represents method BNoneClick(TObject).
Check(Integer,Boolean) | Represents method Check(Integer,Boolean).
CheckAll(Boolean) | Represents method CheckAll(Boolean).
CheckedCount | Represents method CheckedCount.
DoAddItems(TStrings,TDataItem[]) | Represents method DoAddItems(TStrings,TDataItem[]).
Edit(TComponent,TDataArray,Boolean) | Represents method Edit(TComponent,TDataArray,Boolean).
Embed(TComponent,TWinControl) | Represents method Embed(TComponent,TWinControl).
EnableCheckButtons | Represents method EnableCheckButtons.
EnableDrag(Boolean) | Represents method EnableDrag(Boolean).
Items | Represents method Items.
LBItemsClick(TObject) | Represents method LBItemsClick(TObject).
LBItemsClickCheck(TObject) | Represents method LBItemsClickCheck(TObject).
LBItemsDragDrop(TObject,TObject,Integer,Integer) | Represents method LBItemsDragDrop(TObject,TObject,Integer,Integer).
LBItemsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method LBItemsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
SBDownClick(TObject) | Represents method SBDownClick(TObject).
SBUpClick(TObject) | Represents method SBUpClick(TObject).
TryAdd(TDataItem) | Represents method TryAdd(TDataItem).
Top
Events
Show:
Name | Description
OnExchanged | Represents property OnExchanged.
Top
Fields
Show:
Name | Description
BAll | Represents field BAll.
BCancel | Represents field BCancel.
BNone | Represents field BNone.
BOk | Represents field BOk.
LBItems | Represents field LBItems.
Panel1 | Represents field Panel1.
PanelButtons | Represents field PanelButtons.
PanelOk | Represents field PanelOk.
SBDown | Represents field SBDown.
SBUp | Represents field SBUp.
Top
See Also

Reference

  • VCLBI.Editor.ListItems


TFormListItems Properties

Properties
Name | Description
OnChanged | Represents property OnChanged.
OnChecked | Represents property OnChecked.
OnCheckedAll | Represents property OnCheckedAll.
OnSelected | Represents property OnSelected.
Top


TFormListItems.OnChanged Property

Summary

Represents property OnChanged.

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
public
 property OnChanged:TNotifyEvent read FOnChanged write FOnChanged;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.OnChecked Property

Summary

Represents property OnChecked.

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
public
 property OnChecked:TNotifyEvent read FOnChecked write FOnChecked;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.OnCheckedAll Property

Summary

Represents property OnCheckedAll.

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
public
 property OnCheckedAll:TNotifyEvent read FOnCheckedAll write FOnCheckedAll;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.OnSelected Property

Summary

Represents property OnSelected.

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
public
 property OnSelected:TNotifyEvent read FOnSelected write FOnSelected;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems Methods

Methods
Name | Description
AddCombo(TComboBox,TDataItem[]) | Represents method AddCombo(TComboBox,TDataItem[]).
AddItems(TDataItem[],Boolean) | Overloaded. Represents method AddItems(TDataItem[],Boolean).
AddItems(TStrings,TDataItem[],Boolean) | Overloaded. Represents method AddItems(TStrings,TDataItem[],Boolean).
AddMap(TDataItem) | Overloaded. Represents method AddMap(TDataItem).
AddMap(TDataItem,TStrings) | Overloaded. Represents method AddMap(TDataItem,TStrings).
BAllClick(TObject) | Represents method BAllClick(TObject).
BNoneClick(TObject) | Represents method BNoneClick(TObject).
Check(Integer,Boolean) | Represents method Check(Integer,Boolean).
CheckAll(Boolean) | Represents method CheckAll(Boolean).
CheckedCount | Represents method CheckedCount.
DoAddItems(TStrings,TDataItem[]) | Represents method DoAddItems(TStrings,TDataItem[]).
Edit(TComponent,TDataArray,Boolean) | Represents method Edit(TComponent,TDataArray,Boolean).
Embed(TComponent,TWinControl) | Represents method Embed(TComponent,TWinControl).
EnableCheckButtons | Represents method EnableCheckButtons.
EnableDrag(Boolean) | Represents method EnableDrag(Boolean).
Items | Represents method Items.
LBItemsClick(TObject) | Represents method LBItemsClick(TObject).
LBItemsClickCheck(TObject) | Represents method LBItemsClickCheck(TObject).
LBItemsDragDrop(TObject,TObject,Integer,Integer) | Represents method LBItemsDragDrop(TObject,TObject,Integer,Integer).
LBItemsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method LBItemsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
SBDownClick(TObject) | Represents method SBDownClick(TObject).
SBUpClick(TObject) | Represents method SBUpClick(TObject).
TryAdd(TDataItem) | Represents method TryAdd(TDataItem).
Top


TFormListItems.AddCombo(TComboBox,TDataItem[]) Method

Summary

Represents method AddCombo(TComboBox,TDataItem[]).

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
public
 class procedure AddCombo(const ACombo:TComboBox; const AData:Array of TDataItem); static;

Parameters

ACombo
Type: TComboBox

AData
Type: Array of TDataItem

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.AddItems(TDataItem[],Boolean) Method

Summary

Represents method AddItems(TDataItem[],Boolean).

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
public
 procedure AddItems(const AData:Array of TDataItem;
 const AddBlank:Boolean=True); overload;

Parameters

AData
Type: Array of TDataItem

AddBlank
Type: Boolean

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.AddItems(TStrings,TDataItem[],Boolean) Method

Summary

Represents method AddItems(TStrings,TDataItem[],Boolean).

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
public
 class procedure AddItems(const AItems:TStrings; const AData:Array of TDataItem;
 const AddBlank:Boolean=True); overload; static;

Parameters

AItems
Type: TStrings

AData
Type: Array of TDataItem

AddBlank
Type: Boolean

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.AddMap(TDataItem) Method

Summary

Represents method AddMap(TDataItem).

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
public
 procedure AddMap(const AData:TDataItem); overload;

Parameters

AData
Type: TDataItem

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.AddMap(TDataItem,TStrings) Method

Summary

Represents method AddMap(TDataItem,TStrings).

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
public
 class procedure AddMap(const AData: TDataItem; const AItems:TStrings); overload; static;

Parameters

AData
Type: TDataItem

AItems
Type: TStrings

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.BAllClick(TObject) Method

Summary

Represents method BAllClick(TObject).

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
published
 procedure BAllClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.BNoneClick(TObject) Method

Summary

Represents method BNoneClick(TObject).

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
published
 procedure BNoneClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.Check(Integer,Boolean) Method

Summary

Represents method Check(Integer,Boolean).

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
public
 procedure Check(const AIndex:Integer; const ACheck:Boolean);

Parameters

AIndex
Type: Integer

ACheck
Type: Boolean

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.CheckAll(Boolean) Method

Summary

Represents method CheckAll(Boolean).

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
public
 procedure CheckAll(const ACheck:Boolean=True);

Parameters

ACheck
Type: Boolean

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.CheckedCount Method

Summary

Represents method CheckedCount.

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
public
 function CheckedCount:Integer;

Return Value

Type: Integer

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.DoAddItems(TStrings,TDataItem[]) Method

Summary

Represents method DoAddItems(TStrings,TDataItem[]).

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
public
 class procedure DoAddItems(const AItems:TStrings; const AData:Array of TDataItem); static;

Parameters

AItems
Type: TStrings

AData
Type: Array of TDataItem

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.Edit(TComponent,TDataArray,Boolean) Method

Summary

Represents method Edit(TComponent,TDataArray,Boolean).

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent;
 var AItems:TDataArray;
 const AllChecked:Boolean=True):Boolean; static;

Parameters

AOwner
Type: TComponent

AItems
Type: TDataArray

AllChecked
Type: Boolean

Return Value

Type: Boolean

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.Embed(TComponent,TWinControl) Method

Summary

Represents method Embed(TComponent,TWinControl).

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
public
 class function Embed(const AOwner:TComponent; const AParent:TWinControl):TFormListItems; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

Return Value

Type: TFormListItems

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.EnableCheckButtons Method

Summary

Represents method EnableCheckButtons.

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
public
 procedure EnableCheckButtons;
See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.EnableDrag(Boolean) Method

Summary

Represents method EnableDrag(Boolean).

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
public
 procedure EnableDrag(const AEnabled:Boolean);

Parameters

AEnabled
Type: Boolean

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.Items Method

Summary

Represents method Items.

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
public
 function Items:TDataArray;

Return Value

Type: TDataArray

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.LBItemsClick(TObject) Method

Summary

Represents method LBItemsClick(TObject).

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
published
 procedure LBItemsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.LBItemsClickCheck(TObject) Method

Summary

Represents method LBItemsClickCheck(TObject).

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
published
 procedure LBItemsClickCheck(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.LBItemsDragDrop(TObject,TObject,Integer,Integer) Method

Summary

Represents method LBItemsDragDrop(TObject,TObject,Integer,Integer).

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
published
 procedure LBItemsDragDrop(Sender, Source: TObject; X, Y: Integer);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.LBItemsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) Method

Summary

Represents method LBItemsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
published
 procedure LBItemsDragOver(Sender, Source: TObject; X, Y: Integer;
 State: TDragState; var Accept: Boolean);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

State
Type: TDragState

Accept
Type: Boolean

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.SBDownClick(TObject) Method

Summary

Represents method SBDownClick(TObject).

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
published
 procedure SBDownClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.SBUpClick(TObject) Method

Summary

Represents method SBUpClick(TObject).

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
published
 procedure SBUpClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.TryAdd(TDataItem) Method

Summary

Represents method TryAdd(TDataItem).

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
public
 procedure TryAdd(const AData:TDataItem);

Parameters

AData
Type: TDataItem

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems Events

Events
Name | Description
OnExchanged | Represents property OnExchanged.
Top


TFormListItems.OnExchanged Event

Summary

Represents property OnExchanged.

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
public
 property OnExchanged:TListExchangedEvent read FOnExchanged write FOnExchanged;

Value

Type: TListExchangedEvent

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems Fields

Fields
Name | Description
BAll | Represents field BAll.
BCancel | Represents field BCancel.
BNone | Represents field BNone.
BOk | Represents field BOk.
LBItems | Represents field LBItems.
Panel1 | Represents field Panel1.
PanelButtons | Represents field PanelButtons.
PanelOk | Represents field PanelOk.
SBDown | Represents field SBDown.
SBUp | Represents field SBUp.
Top


TFormListItems.BAll Field

Summary

Represents field BAll.

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
published
 BAll: TButton;

Field Value

Type: TButton

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.BCancel Field

Summary

Represents field BCancel.

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
published
 BCancel: TButton;

Field Value

Type: TButton

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.BNone Field

Summary

Represents field BNone.

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
published
 BNone: TButton;

Field Value

Type: TButton

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.BOk Field

Summary

Represents field BOk.

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
published
 BOk: TButton;

Field Value

Type: TButton

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.LBItems Field

Summary

Represents field LBItems.

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
published
 LBItems: TCheckListBox;

Field Value

Type: TCheckListBox

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.PanelButtons Field

Summary

Represents field PanelButtons.

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
published
 PanelButtons: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.PanelOk Field

Summary

Represents field PanelOk.

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
published
 PanelOk: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.SBDown Field

Summary

Represents field SBDown.

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
published
 SBDown: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


TFormListItems.SBUp Field

Summary

Represents field SBUp.

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
published
 SBUp: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TFormListItems
  • VCLBI.Editor.ListItems


VCLBI.Editor.ListItems Delegates

Delegates
Name | Description
TListExchangedEvent | Represents type TListExchangedEvent.
TListItemsEvent | Represents type TListItemsEvent.
Top


TListExchangedEvent Delegate

Summary

Represents type TListExchangedEvent.

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
type
 TListExchangedEvent=procedure(const Sender:TObject; const A,B:Integer) of object;
See Also

Reference

  • VCLBI.Editor.ListItems


TListItemsEvent Delegate

Summary

Represents type TListItemsEvent.

Namespace: VCLBI.Editor.ListItems
Syntax
Delphi
type
 TListItemsEvent=procedure(const AItems:TDataArray; const ARefresh:Boolean) of object;
See Also

Reference

  • VCLBI.Editor.ListItems


VCLBI.Editor.Needs Namespace

Summary

Represents namespace VCLBI.Editor.Needs.

Classes
Name | Description
TDataProviderAccess | Represents type TDataProviderAccess.
TProviderNeedsEditor | Represents type TProviderNeedsEditor.
TRegisteredProvidersHelper | Represents type TRegisteredProvidersHelper.
Top
Records
Name | Description
TRegisteredProvider | Represents type TRegisteredProvider.
Top
Types
Name | Description
TDataProviderClass | Represents type TDataProviderClass.
TRegisteredProviders | Represents an array of the TRegisteredProvider type.
Top
Variables
Name | Description
RegisteredProviders | Represents variable RegisteredProviders.
Top


VCLBI.Editor.Needs Classes

Classes
Name | Description
TDataProviderAccess | Represents type TDataProviderAccess.
TProviderNeedsEditor | Represents type TProviderNeedsEditor.
TRegisteredProvidersHelper | Represents type TRegisteredProvidersHelper.
Top


TDataProviderAccess Class

Summary

Represents type TDataProviderAccess.

Namespace: VCLBI.Editor.Needs
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
VCLBI.Editor.Needs.TDataProviderAccess
Syntax
Delphi
type
 TDataProviderAccess=class(TDataProvider);
See Also

Reference

  • VCLBI.Editor.Needs


TProviderNeedsEditor Class

Summary

Represents type TProviderNeedsEditor.

Namespace: VCLBI.Editor.Needs
Inheritance Hierarchy
TForm
VCLBI.Editor.Needs.TProviderNeedsEditor
Syntax
Delphi
type
 TProviderNeedsEditor = class(TForm)
 end;

The TProviderNeedsEditor type exposes the following members.

Properties
Show:
Name | Description
Needs | Represents property Needs.
Options | Represents property Options.
Top
Methods
Show:
Name | Description
BApplyClick(TObject) | Represents method BApplyClick(TObject).
Embed(TComponent,TWinControl,TDataProviderNeeds,TDataItem) | Represents method Embed(TComponent,TWinControl,TDataProviderNeeds,TDataItem).
EnableApply | Represents method EnableApply.
RefreshNeeds(TDataProviderNeeds,TDataItem) | Represents method RefreshNeeds(TDataProviderNeeds,TDataItem).
Top
Fields
Show:
Name | Description
BApply | Represents field BApply.
BCancel | Represents field BCancel.
BOk | Represents field BOk.
PageNeeds | Represents field PageNeeds.
PanelBottom | Represents field PanelBottom.
PanelOk | Represents field PanelOk.
Top
See Also

Reference

  • VCLBI.Editor.Needs


TProviderNeedsEditor Properties

Properties
Name | Description
Needs | Represents property Needs.
Options | Represents property Options.
Top


TProviderNeedsEditor.Needs Property

Summary

Represents property Needs.

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
public
 property Needs:TDataProviderNeeds read INeeds;

Property Value

Type: TDataProviderNeeds

See Also

Reference

  • TProviderNeedsEditor
  • VCLBI.Editor.Needs


TProviderNeedsEditor.Options Property

Summary

Represents property Options.

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
public
 property Options:TCustomForm read FOptions;

Property Value

Type: TCustomForm

See Also

Reference

  • TProviderNeedsEditor
  • VCLBI.Editor.Needs


TProviderNeedsEditor Methods

Methods
Name | Description
BApplyClick(TObject) | Represents method BApplyClick(TObject).
Embed(TComponent,TWinControl,TDataProviderNeeds,TDataItem) | Represents method Embed(TComponent,TWinControl,TDataProviderNeeds,TDataItem).
EnableApply | Represents method EnableApply.
RefreshNeeds(TDataProviderNeeds,TDataItem) | Represents method RefreshNeeds(TDataProviderNeeds,TDataItem).
Top


TProviderNeedsEditor.BApplyClick(TObject) Method

Summary

Represents method BApplyClick(TObject).

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
published
 procedure BApplyClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TProviderNeedsEditor
  • VCLBI.Editor.Needs


TProviderNeedsEditor.Embed(TComponent,TWinControl,TDataProviderNeeds,TDataItem) Method

Summary

Represents method Embed(TComponent,TWinControl,TDataProviderNeeds,TDataItem).

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
public
 class function Embed(const AOwner:TComponent;
 const AParent: TWinControl;
 const ANeeds:TDataProviderNeeds;
 const ASource:TDataItem):TProviderNeedsEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

ANeeds
Type: TDataProviderNeeds

ASource
Type: TDataItem

Return Value

Type: TProviderNeedsEditor

See Also

Reference

  • TProviderNeedsEditor
  • VCLBI.Editor.Needs


TProviderNeedsEditor.EnableApply Method

Summary

Represents method EnableApply.

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
public
 procedure EnableApply;
See Also

Reference

  • TProviderNeedsEditor
  • VCLBI.Editor.Needs


TProviderNeedsEditor.RefreshNeeds(TDataProviderNeeds,TDataItem) Method

Summary

Represents method RefreshNeeds(TDataProviderNeeds,TDataItem).

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
public
 procedure RefreshNeeds(const ANeeds:TDataProviderNeeds; const ASource:TDataItem);

Parameters

ANeeds
Type: TDataProviderNeeds

ASource
Type: TDataItem

See Also

Reference

  • TProviderNeedsEditor
  • VCLBI.Editor.Needs


TProviderNeedsEditor Fields

Fields
Name | Description
BApply | Represents field BApply.
BCancel | Represents field BCancel.
BOk | Represents field BOk.
PageNeeds | Represents field PageNeeds.
PanelBottom | Represents field PanelBottom.
PanelOk | Represents field PanelOk.
Top


TProviderNeedsEditor.BApply Field

Summary

Represents field BApply.

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
published
 BApply: TButton;

Field Value

Type: TButton

See Also

Reference

  • TProviderNeedsEditor
  • VCLBI.Editor.Needs


TProviderNeedsEditor.BCancel Field

Summary

Represents field BCancel.

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
published
 BCancel: TButton;

Field Value

Type: TButton

See Also

Reference

  • TProviderNeedsEditor
  • VCLBI.Editor.Needs


TProviderNeedsEditor.BOk Field

Summary

Represents field BOk.

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
published
 BOk: TButton;

Field Value

Type: TButton

See Also

Reference

  • TProviderNeedsEditor
  • VCLBI.Editor.Needs


TProviderNeedsEditor.PageNeeds Field

Summary

Represents field PageNeeds.

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
published
 PageNeeds: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TProviderNeedsEditor
  • VCLBI.Editor.Needs


TProviderNeedsEditor.PanelBottom Field

Summary

Represents field PanelBottom.

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
published
 PanelBottom: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TProviderNeedsEditor
  • VCLBI.Editor.Needs


TProviderNeedsEditor.PanelOk Field

Summary

Represents field PanelOk.

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
published
 PanelOk: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TProviderNeedsEditor
  • VCLBI.Editor.Needs


TRegisteredProvidersHelper Class Helper

Summary

Represents type TRegisteredProvidersHelper.

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
type
 TRegisteredProvidersHelper=record helper for TRegisteredProviders
 end;
Methods
Name | Description
Count | Represents method Count.
EditorOf(TComponent,TDataProvider) | Represents method EditorOf(TComponent,TDataProvider).
IndexOf(TDataProviderClass) | Represents method IndexOf(TDataProviderClass).
RegisterProvider(TDataProviderClass,TCustomFormClass) | Represents method RegisterProvider(TDataProviderClass,TCustomFormClass).
UnRegisterProvider(TDataProviderClass) | Represents method UnRegisterProvider(TDataProviderClass).
Top
See Also

Reference

  • VCLBI.Editor.Needs


TRegisteredProvidersHelper Methods

Methods
Name | Description
Count | Represents method Count.
EditorOf(TComponent,TDataProvider) | Represents method EditorOf(TComponent,TDataProvider).
IndexOf(TDataProviderClass) | Represents method IndexOf(TDataProviderClass).
RegisterProvider(TDataProviderClass,TCustomFormClass) | Represents method RegisterProvider(TDataProviderClass,TCustomFormClass).
UnRegisterProvider(TDataProviderClass) | Represents method UnRegisterProvider(TDataProviderClass).
Top


TRegisteredProvidersHelper.Count Method

Summary

Represents method Count.

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
public
 function Count:Integer; inline;

Return Value

Type: Integer

See Also

Reference

  • TRegisteredProvidersHelper
  • VCLBI.Editor.Needs


TRegisteredProvidersHelper.EditorOf(TComponent,TDataProvider) Method

Summary

Represents method EditorOf(TComponent,TDataProvider).

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
public
 function EditorOf(const AOwner:TComponent; const AProvider:TDataProvider):TCustomForm;

Parameters

AOwner
Type: TComponent

AProvider
Type: TDataProvider

Return Value

Type: TCustomForm

See Also

Reference

  • TRegisteredProvidersHelper
  • VCLBI.Editor.Needs


TRegisteredProvidersHelper.IndexOf(TDataProviderClass) Method

Summary

Represents method IndexOf(TDataProviderClass).

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
public
 function IndexOf(const AClass:TDataProviderClass):Integer;

Parameters

AClass
Type: TDataProviderClass

Return Value

Type: Integer

See Also

Reference

  • TRegisteredProvidersHelper
  • VCLBI.Editor.Needs


TRegisteredProvidersHelper.RegisterProvider(TDataProviderClass,TCustomFormClass) Method

Summary

Represents method RegisterProvider(TDataProviderClass,TCustomFormClass).

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
public
 class procedure RegisterProvider(const AClass:TDataProviderClass;
 const AEditor:TCustomFormClass); static;

Parameters

AClass
Type: TDataProviderClass

AEditor
Type: TCustomFormClass

See Also

Reference

  • TRegisteredProvidersHelper
  • VCLBI.Editor.Needs


TRegisteredProvidersHelper.UnRegisterProvider(TDataProviderClass) Method

Summary

Represents method UnRegisterProvider(TDataProviderClass).

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
public
 procedure UnRegisterProvider(const AClass:TDataProviderClass);

Parameters

AClass
Type: TDataProviderClass

See Also

Reference

  • TRegisteredProvidersHelper
  • VCLBI.Editor.Needs


VCLBI.Editor.Needs Records

Records
Name | Description
TRegisteredProvider | Represents type TRegisteredProvider.
Top


TRegisteredProvider Record

Summary

Represents type TRegisteredProvider.

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
type
 TRegisteredProvider=record
 end;

The TRegisteredProvider type exposes the following members.

Fields
Show:
Name | Description
EditorClass | Represents field EditorClass.
ProviderClass | Represents field ProviderClass.
Top
See Also

Reference

  • VCLBI.Editor.Needs


TRegisteredProvider Fields

Fields
Name | Description
EditorClass | Represents field EditorClass.
ProviderClass | Represents field ProviderClass.
Top


TRegisteredProvider.EditorClass Field

Summary

Represents field EditorClass.

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
public
 EditorClass : TCustomFormClass;

Field Value

Type: TCustomFormClass

See Also

Reference

  • TRegisteredProvider
  • VCLBI.Editor.Needs


TRegisteredProvider.ProviderClass Field

Summary

Represents field ProviderClass.

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
public
 ProviderClass : TDataProviderClass;

Field Value

Type: TDataProviderClass

See Also

Reference

  • TRegisteredProvider
  • VCLBI.Editor.Needs


VCLBI.Editor.Needs Types

Types
Name | Description
TDataProviderClass | Represents type TDataProviderClass.
TRegisteredProviders | Represents an array of the TRegisteredProvider type.
Top


TDataProviderClass Type

Summary

Represents type TDataProviderClass.

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
type
 TDataProviderClass=class of TDataProvider;
See Also

Reference

  • VCLBI.Editor.Needs


TRegisteredProviders Type

Summary

Represents an array of the TRegisteredProvider type.

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
type
 TRegisteredProviders=Array of TRegisteredProvider;
See Also

Reference

  • VCLBI.Editor.Needs


VCLBI.Editor.Needs Variables

Variables
Name | Description
RegisteredProviders | Represents variable RegisteredProviders.
Top


RegisteredProviders Variable

Summary

Represents variable RegisteredProviders.

Namespace: VCLBI.Editor.Needs
Syntax
Delphi
RegisteredProviders : TRegisteredProviders=nil;

Value

Type: TRegisteredProviders

See Also

Reference

  • VCLBI.Editor.Needs


VCLBI.Editor.NumericFromTo Namespace

Summary

Represents namespace VCLBI.Editor.NumericFromTo.

Classes
Name | Description
TNumericFromTo | Represents type TNumericFromTo.
Top


VCLBI.Editor.NumericFromTo Classes

Classes
Name | Description
TNumericFromTo | Represents type TNumericFromTo.
Top


TNumericFromTo Class

Summary

Represents type TNumericFromTo.

Namespace: VCLBI.Editor.NumericFromTo
Inheritance Hierarchy
TForm
VCLBI.Editor.NumericFromTo.TNumericFromTo
VCLBI.Editor.DateTimeRange.TNumericFromToAccess
VCLBI.Editor.Filter.Item.TNumericFromToAccess
Syntax
Delphi
type
 TNumericFromTo = class(TForm)
 end;

The TNumericFromTo type exposes the following members.

Properties
Show:
Name | Description
FromEqual | Represents property FromEqual.
FromValue | Represents property FromValue.
ToEqual | Represents property ToEqual.
ToValue | Represents property ToValue.
Top
Methods
Show:
Name | Description
CBFromClick(TObject) | Represents method CBFromClick(TObject).
CBFromEqualChange(TObject) | Represents method CBFromEqualChange(TObject).
CBToClick(TObject) | Represents method CBToClick(TObject).
CBToEqualChange(TObject) | Represents method CBToEqualChange(TObject).
EFromChange(TObject) | Represents method EFromChange(TObject).
Embedd(TComponent,TWinControl,TNotifyEvent) | Represents method Embedd(TComponent,TWinControl,TNotifyEvent).
EnabledFrom | Represents method EnabledFrom.
EnabledTo | Represents method EnabledTo.
EToChange(TObject) | Represents method EToChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
HideTo | Represents method HideTo.
PanelTracksResize(TObject) | Represents method PanelTracksResize(TObject).
Refresh(Extended,Extended,Extended,Extended) | Overloaded. Represents method Refresh(Extended,Extended,Extended,Extended).
Refresh(TDataItem) | Overloaded. Represents method Refresh(TDataItem).
TBFromChange(TObject) | Represents method TBFromChange(TObject).
TBToChange(TObject) | Represents method TBToChange(TObject).
Top
Fields
Show:
Name | Description
CBFrom | Represents field CBFrom.
CBFromEqual | Represents field CBFromEqual.
CBTo | Represents field CBTo.
CBToEqual | Represents field CBToEqual.
DateTime | Represents field DateTime.
EFrom | Represents field EFrom.
ETo | Represents field ETo.
Float | Represents field Float.
LErrorFrom | Represents field LErrorFrom.
LErrorTo | Represents field LErrorTo.
PanelTracks | Represents field PanelTracks.
TBFrom | Represents field TBFrom.
TBTo | Represents field TBTo.
Top
See Also

Reference

  • VCLBI.Editor.NumericFromTo


TNumericFromTo Properties

Properties
Name | Description
FromEqual | Represents property FromEqual.
FromValue | Represents property FromValue.
ToEqual | Represents property ToEqual.
ToValue | Represents property ToValue.
Top


TNumericFromTo.FromEqual Property

Summary

Represents property FromEqual.

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
public
 property FromEqual:Boolean read GetFromEqual write SetFromEqual;

Property Value

Type: Boolean

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.FromValue Property

Summary

Represents property FromValue.

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
public
 property FromValue:Extended read GetFrom write SetFrom;

Property Value

Type: Extended

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.ToEqual Property

Summary

Represents property ToEqual.

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
public
 property ToEqual:Boolean read GetToEqual write SetToEqual;

Property Value

Type: Boolean

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.ToValue Property

Summary

Represents property ToValue.

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
public
 property ToValue:Extended read GetTo write SetTo;

Property Value

Type: Extended

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo Methods

Methods
Name | Description
CBFromClick(TObject) | Represents method CBFromClick(TObject).
CBFromEqualChange(TObject) | Represents method CBFromEqualChange(TObject).
CBToClick(TObject) | Represents method CBToClick(TObject).
CBToEqualChange(TObject) | Represents method CBToEqualChange(TObject).
EFromChange(TObject) | Represents method EFromChange(TObject).
Embedd(TComponent,TWinControl,TNotifyEvent) | Represents method Embedd(TComponent,TWinControl,TNotifyEvent).
EnabledFrom | Represents method EnabledFrom.
EnabledTo | Represents method EnabledTo.
EToChange(TObject) | Represents method EToChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
HideTo | Represents method HideTo.
PanelTracksResize(TObject) | Represents method PanelTracksResize(TObject).
Refresh(Extended,Extended,Extended,Extended) | Overloaded. Represents method Refresh(Extended,Extended,Extended,Extended).
Refresh(TDataItem) | Overloaded. Represents method Refresh(TDataItem).
TBFromChange(TObject) | Represents method TBFromChange(TObject).
TBToChange(TObject) | Represents method TBToChange(TObject).
Top


TNumericFromTo.CBFromClick(TObject) Method

Summary

Represents method CBFromClick(TObject).

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
published
 procedure CBFromClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.CBFromEqualChange(TObject) Method

Summary

Represents method CBFromEqualChange(TObject).

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
published
 procedure CBFromEqualChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.CBToClick(TObject) Method

Summary

Represents method CBToClick(TObject).

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
published
 procedure CBToClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.CBToEqualChange(TObject) Method

Summary

Represents method CBToEqualChange(TObject).

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
published
 procedure CBToEqualChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.EFromChange(TObject) Method

Summary

Represents method EFromChange(TObject).

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
published
 procedure EFromChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.Embedd(TComponent,TWinControl,TNotifyEvent) Method

Summary

Represents method Embedd(TComponent,TWinControl,TNotifyEvent).

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent;
 const AParent:TWinControl;
 const OnChange:TNotifyEvent):TNumericFromTo; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

OnChange
Type: TNotifyEvent

Return Value

Type: TNumericFromTo

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.EnabledFrom Method

Summary

Represents method EnabledFrom.

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
public
 function EnabledFrom:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.EnabledTo Method

Summary

Represents method EnabledTo.

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
public
 function EnabledTo:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.EToChange(TObject) Method

Summary

Represents method EToChange(TObject).

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
published
 procedure EToChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.HideTo Method

Summary

Represents method HideTo.

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
protected
 procedure HideTo;
See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.PanelTracksResize(TObject) Method

Summary

Represents method PanelTracksResize(TObject).

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
published
 procedure PanelTracksResize(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.Refresh(Extended,Extended,Extended,Extended) Method

Summary

Represents method Refresh(Extended,Extended,Extended,Extended).

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
public
 procedure Refresh(const AMin,AMax,AFrom,ATo:Extended); overload;

Parameters

AMin
Type: Extended

AMax
Type: Extended

AFrom
Type: Extended

ATo
Type: Extended

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.Refresh(TDataItem) Method

Summary

Represents method Refresh(TDataItem).

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
public
 procedure Refresh(const AData:TDataItem); overload;

Parameters

AData
Type: TDataItem

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.TBFromChange(TObject) Method

Summary

Represents method TBFromChange(TObject).

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
published
 procedure TBFromChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.TBToChange(TObject) Method

Summary

Represents method TBToChange(TObject).

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
published
 procedure TBToChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo Fields

Fields
Name | Description
CBFrom | Represents field CBFrom.
CBFromEqual | Represents field CBFromEqual.
CBTo | Represents field CBTo.
CBToEqual | Represents field CBToEqual.
DateTime | Represents field DateTime.
EFrom | Represents field EFrom.
ETo | Represents field ETo.
Float | Represents field Float.
LErrorFrom | Represents field LErrorFrom.
LErrorTo | Represents field LErrorTo.
PanelTracks | Represents field PanelTracks.
TBFrom | Represents field TBFrom.
TBTo | Represents field TBTo.
Top


TNumericFromTo.CBFrom Field

Summary

Represents field CBFrom.

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
published
 CBFrom: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.CBFromEqual Field

Summary

Represents field CBFromEqual.

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
published
 CBFromEqual: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.CBTo Field

Summary

Represents field CBTo.

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
published
 CBTo: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.CBToEqual Field

Summary

Represents field CBToEqual.

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
published
 CBToEqual: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.DateTime Field

Summary

Represents field DateTime.

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
public
 DateTime : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.EFrom Field

Summary

Represents field EFrom.

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
published
 EFrom: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.ETo Field

Summary

Represents field ETo.

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
published
 ETo: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.Float Field

Summary

Represents field Float.

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
public
 Float : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.LErrorFrom Field

Summary

Represents field LErrorFrom.

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
published
 LErrorFrom: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.LErrorTo Field

Summary

Represents field LErrorTo.

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
published
 LErrorTo: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.PanelTracks Field

Summary

Represents field PanelTracks.

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
published
 PanelTracks: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.TBFrom Field

Summary

Represents field TBFrom.

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
published
 TBFrom: TTrackBar;

Field Value

Type: TTrackBar

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


TNumericFromTo.TBTo Field

Summary

Represents field TBTo.

Namespace: VCLBI.Editor.NumericFromTo
Syntax
Delphi
published
 TBTo: TTrackBar;

Field Value

Type: TTrackBar

See Also

Reference

  • TNumericFromTo
  • VCLBI.Editor.NumericFromTo


VCLBI.Editor.Query Namespace

Summary

Represents namespace VCLBI.Editor.Query.

Classes
Name | Description
TBIQueryEditor | Represents type TBIQueryEditor.
TDataProviderAccess | Represents type TDataProviderAccess.
TDataSelectorAccess | Represents type TDataSelectorAccess.
TGroupByAccess | Represents type TGroupByAccess.
Top
Delegates
Name | Description
TOnShowQueryEditor | Represents type TOnShowQueryEditor.
Top
Routines
Name | Description
DimensionOf(TCheckListBox) | Overloaded. Represents method DimensionOf(TCheckListBox).
DimensionOf(TCheckListBox,Integer) | Overloaded. Represents method DimensionOf(TCheckListBox,Integer).
EnableUpDown(TCheckListBox,TControl,TControl) | Represents method EnableUpDown(TCheckListBox,TControl,TControl).
MeasureOf(TCheckListBox) | Overloaded. Represents method MeasureOf(TCheckListBox).
MeasureOf(TCheckListBox,Integer) | Overloaded. Represents method MeasureOf(TCheckListBox,Integer).
Top


VCLBI.Editor.Query Classes

Classes
Name | Description
TBIQueryEditor | Represents type TBIQueryEditor.
TDataProviderAccess | Represents type TDataProviderAccess.
TDataSelectorAccess | Represents type TDataSelectorAccess.
TGroupByAccess | Represents type TGroupByAccess.
Top


TBIQueryEditor Class

Summary

Represents type TBIQueryEditor.

Namespace: VCLBI.Editor.Query
Inheritance Hierarchy
TForm
VCLBI.Editor.Query.TBIQueryEditor
Syntax
Delphi
type
 TBIQueryEditor = class(TForm)
 end;

The TBIQueryEditor type exposes the following members.

Properties
Show:
Name | Description
Preview | Represents property Preview.
Top
Methods
Show:
Name | Description
BDeleteColumnClick(TObject) | Represents method BDeleteColumnClick(TObject).
BDeleteMeasureClick(TObject) | Represents method BDeleteMeasureClick(TObject).
BDeleteRowClick(TObject) | Represents method BDeleteRowClick(TObject).
BOKClick(TObject) | Represents method BOKClick(TObject).
CBAggregateChange(TObject) | Represents method CBAggregateChange(TObject).
CBDatePartChange(TObject) | Represents method CBDatePartChange(TObject).
CBDistinctClick(TObject) | Represents method CBDistinctClick(TObject).
CBHistoActiveClick(TObject) | Represents method CBHistoActiveClick(TObject).
CBMissingAsZeroClick(TObject) | Represents method CBMissingAsZeroClick(TObject).
CBPreviewClick(TObject) | Represents method CBPreviewClick(TObject).
CBRemoveColsClick(TObject) | Represents method CBRemoveColsClick(TObject).
CBRemoveRowsClick(TObject) | Represents method CBRemoveRowsClick(TObject).
CBRunningRowsClick(TObject) | Represents method CBRunningRowsClick(TObject).
EBinsChange(TObject) | Represents method EBinsChange(TObject).
Edit(TComponent,TBIQuery) | Represents method Edit(TComponent,TBIQuery).
EItemExpressionChange(TObject) | Represents method EItemExpressionChange(TObject).
EMaxChange(TObject) | Represents method EMaxChange(TObject).
Embedd(TComponent,TWinControl,TBIQuery) | Represents method Embedd(TComponent,TWinControl,TBIQuery).
EStartChange(TObject) | Represents method EStartChange(TObject).
ETitleChange(TObject) | Represents method ETitleChange(TObject).
FormCloseQuery(TObject,Boolean) | Represents method FormCloseQuery(TObject,Boolean).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
ListColumnsClick(TObject) | Represents method ListColumnsClick(TObject).
ListMeasuresClick(TObject) | Represents method ListMeasuresClick(TObject).
ListMeasuresDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method ListMeasuresDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
ListRowsClick(TObject) | Represents method ListRowsClick(TObject).
ListRowsClickCheck(TObject) | Represents method ListRowsClickCheck(TObject).
ListRowsDragDrop(TObject,TObject,Integer,Integer) | Represents method ListRowsDragDrop(TObject,TObject,Integer,Integer).
ListRowsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method ListRowsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
PageDataChange(TObject) | Represents method PageDataChange(TObject).
PagePreviewChange(TObject) | Represents method PagePreviewChange(TObject).
Refresh(TBIQuery) | Represents method Refresh(TBIQuery).
RGPercentageClick(TObject) | Represents method RGPercentageClick(TObject).
RGRunningClick(TObject) | Represents method RGRunningClick(TObject).
SBColDownClick(TObject) | Represents method SBColDownClick(TObject).
SBColUpClick(TObject) | Represents method SBColUpClick(TObject).
SBMeasureDownClick(TObject) | Represents method SBMeasureDownClick(TObject).
SBMeasureUpClick(TObject) | Represents method SBMeasureUpClick(TObject).
SBRowDownClick(TObject) | Represents method SBRowDownClick(TObject).
SBRowUpClick(TObject) | Represents method SBRowUpClick(TObject).
SBSelectorClick(TObject) | Represents method SBSelectorClick(TObject).
SBSwapClick(TObject) | Represents method SBSwapClick(TObject).
Selector | Represents method Selector.
ShowSelector(Boolean) | Represents method ShowSelector(Boolean).
SpeedButton1Click(TObject) | Represents method SpeedButton1Click(TObject).
Top
Fields
Show:
Name | Description
BDeleteColumn | Represents field BDeleteColumn.
BDeleteMeasure | Represents field BDeleteMeasure.
BDeleteRow | Represents field BDeleteRow.
BIGrid1 | Represents field BIGrid1.
BIQuery1 | Represents field BIQuery1.
BOK | Represents field BOK.
Button1 | Represents field Button1.
CBAggregate | Represents field CBAggregate.
CBDatePart | Represents field CBDatePart.
CBDistinct | Represents field CBDistinct.
CBHistoActive | Represents field CBHistoActive.
CBMissingAsZero | Represents field CBMissingAsZero.
CBPreview | Represents field CBPreview.
CBRemoveCols | Represents field CBRemoveCols.
CBRemoveRows | Represents field CBRemoveRows.
CBRunningRows | Represents field CBRunningRows.
EBins | Represents field EBins.
EItemExpression | Represents field EItemExpression.
EMax | Represents field EMax.
EStart | Represents field EStart.
ETitle | Represents field ETitle.
GBHistogram | Represents field GBHistogram.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
LabelItemKind | Represents field LabelItemKind.
LExpressionError | Represents field LExpressionError.
ListColumns | Represents field ListColumns.
ListMeasures | Represents field ListMeasures.
ListRows | Represents field ListRows.
LMax | Represents field LMax.
LStart | Represents field LStart.
MemoSQL | Represents field MemoSQL.
OnShowEditor | Represents field OnShowEditor.
OuterPanel | Represents field OuterPanel.
PageData | Represents field PageData.
PageMeasures | Represents field PageMeasures.
PageOptions | Represents field PageOptions.
PagePreview | Represents field PagePreview.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
Panel5 | Represents field Panel5.
Panel6 | Represents field Panel6.
Panel7 | Represents field Panel7.
Panel8 | Represents field Panel8.
PanelButtons | Represents field PanelButtons.
PanelColumns | Represents field PanelColumns.
PanelEdit | Represents field PanelEdit.
PanelMeasures | Represents field PanelMeasures.
PanelOptions | Represents field PanelOptions.
PanelRows | Represents field PanelRows.
PanelSelector | Represents field PanelSelector.
RGPercentage | Represents field RGPercentage.
RGRunning | Represents field RGRunning.
SBColDown | Represents field SBColDown.
SBColUp | Represents field SBColUp.
SBMeasureDown | Represents field SBMeasureDown.
SBMeasureUp | Represents field SBMeasureUp.
SBRowDown | Represents field SBRowDown.
SBRowUp | Represents field SBRowUp.
SBSelector | Represents field SBSelector.
SBSwap | Represents field SBSwap.
SpeedButton1 | Represents field SpeedButton1.
SplitterPreview | Represents field SplitterPreview.
SplitterSelector | Represents field SplitterSelector.
TabCalc | Represents field TabCalc.
TabChart | Represents field TabChart.
TabData | Represents field TabData.
TabFilter | Represents field TabFilter.
TabGrid | Represents field TabGrid.
TabItem | Represents field TabItem.
TabItemData | Represents field TabItemData.
TabMeasure | Represents field TabMeasure.
TabMeasureOptions | Represents field TabMeasureOptions.
TabSort | Represents field TabSort.
TabSQL | Represents field TabSQL.
UDBins | Represents field UDBins.
Top
See Also

Reference

  • VCLBI.Editor.Query


TBIQueryEditor Properties

Properties
Name | Description
Preview | Represents property Preview.
Top


TBIQueryEditor.Preview Property

Summary

Represents property Preview.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
public
 property Preview:Boolean read GetPreview write SetPreview;

Property Value

Type: Boolean

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor Methods

Methods
Name | Description
BDeleteColumnClick(TObject) | Represents method BDeleteColumnClick(TObject).
BDeleteMeasureClick(TObject) | Represents method BDeleteMeasureClick(TObject).
BDeleteRowClick(TObject) | Represents method BDeleteRowClick(TObject).
BOKClick(TObject) | Represents method BOKClick(TObject).
CBAggregateChange(TObject) | Represents method CBAggregateChange(TObject).
CBDatePartChange(TObject) | Represents method CBDatePartChange(TObject).
CBDistinctClick(TObject) | Represents method CBDistinctClick(TObject).
CBHistoActiveClick(TObject) | Represents method CBHistoActiveClick(TObject).
CBMissingAsZeroClick(TObject) | Represents method CBMissingAsZeroClick(TObject).
CBPreviewClick(TObject) | Represents method CBPreviewClick(TObject).
CBRemoveColsClick(TObject) | Represents method CBRemoveColsClick(TObject).
CBRemoveRowsClick(TObject) | Represents method CBRemoveRowsClick(TObject).
CBRunningRowsClick(TObject) | Represents method CBRunningRowsClick(TObject).
EBinsChange(TObject) | Represents method EBinsChange(TObject).
Edit(TComponent,TBIQuery) | Represents method Edit(TComponent,TBIQuery).
EItemExpressionChange(TObject) | Represents method EItemExpressionChange(TObject).
EMaxChange(TObject) | Represents method EMaxChange(TObject).
Embedd(TComponent,TWinControl,TBIQuery) | Represents method Embedd(TComponent,TWinControl,TBIQuery).
EStartChange(TObject) | Represents method EStartChange(TObject).
ETitleChange(TObject) | Represents method ETitleChange(TObject).
FormCloseQuery(TObject,Boolean) | Represents method FormCloseQuery(TObject,Boolean).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormDestroy(TObject) | Represents method FormDestroy(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
ListColumnsClick(TObject) | Represents method ListColumnsClick(TObject).
ListMeasuresClick(TObject) | Represents method ListMeasuresClick(TObject).
ListMeasuresDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method ListMeasuresDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
ListRowsClick(TObject) | Represents method ListRowsClick(TObject).
ListRowsClickCheck(TObject) | Represents method ListRowsClickCheck(TObject).
ListRowsDragDrop(TObject,TObject,Integer,Integer) | Represents method ListRowsDragDrop(TObject,TObject,Integer,Integer).
ListRowsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method ListRowsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
PageDataChange(TObject) | Represents method PageDataChange(TObject).
PagePreviewChange(TObject) | Represents method PagePreviewChange(TObject).
Refresh(TBIQuery) | Represents method Refresh(TBIQuery).
RGPercentageClick(TObject) | Represents method RGPercentageClick(TObject).
RGRunningClick(TObject) | Represents method RGRunningClick(TObject).
SBColDownClick(TObject) | Represents method SBColDownClick(TObject).
SBColUpClick(TObject) | Represents method SBColUpClick(TObject).
SBMeasureDownClick(TObject) | Represents method SBMeasureDownClick(TObject).
SBMeasureUpClick(TObject) | Represents method SBMeasureUpClick(TObject).
SBRowDownClick(TObject) | Represents method SBRowDownClick(TObject).
SBRowUpClick(TObject) | Represents method SBRowUpClick(TObject).
SBSelectorClick(TObject) | Represents method SBSelectorClick(TObject).
SBSwapClick(TObject) | Represents method SBSwapClick(TObject).
Selector | Represents method Selector.
ShowSelector(Boolean) | Represents method ShowSelector(Boolean).
SpeedButton1Click(TObject) | Represents method SpeedButton1Click(TObject).
Top


TBIQueryEditor.BDeleteColumnClick(TObject) Method

Summary

Represents method BDeleteColumnClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure BDeleteColumnClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.BDeleteMeasureClick(TObject) Method

Summary

Represents method BDeleteMeasureClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure BDeleteMeasureClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.BDeleteRowClick(TObject) Method

Summary

Represents method BDeleteRowClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure BDeleteRowClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.BOKClick(TObject) Method

Summary

Represents method BOKClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure BOKClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.CBAggregateChange(TObject) Method

Summary

Represents method CBAggregateChange(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure CBAggregateChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.CBDatePartChange(TObject) Method

Summary

Represents method CBDatePartChange(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure CBDatePartChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.CBDistinctClick(TObject) Method

Summary

Represents method CBDistinctClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure CBDistinctClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.CBHistoActiveClick(TObject) Method

Summary

Represents method CBHistoActiveClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure CBHistoActiveClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.CBMissingAsZeroClick(TObject) Method

Summary

Represents method CBMissingAsZeroClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure CBMissingAsZeroClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.CBPreviewClick(TObject) Method

Summary

Represents method CBPreviewClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure CBPreviewClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.CBRemoveColsClick(TObject) Method

Summary

Represents method CBRemoveColsClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure CBRemoveColsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.CBRemoveRowsClick(TObject) Method

Summary

Represents method CBRemoveRowsClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure CBRemoveRowsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.CBRunningRowsClick(TObject) Method

Summary

Represents method CBRunningRowsClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure CBRunningRowsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.EBinsChange(TObject) Method

Summary

Represents method EBinsChange(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure EBinsChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.Edit(TComponent,TBIQuery) Method

Summary

Represents method Edit(TComponent,TBIQuery).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const AQuery:TBIQuery):Boolean; static;

Parameters

AOwner
Type: TComponent

AQuery
Type: TBIQuery

Return Value

Type: Boolean

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.EItemExpressionChange(TObject) Method

Summary

Represents method EItemExpressionChange(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure EItemExpressionChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.EMaxChange(TObject) Method

Summary

Represents method EMaxChange(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure EMaxChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.Embedd(TComponent,TWinControl,TBIQuery) Method

Summary

Represents method Embedd(TComponent,TWinControl,TBIQuery).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
public
 class function Embedd(const AOwner: TComponent; const AParent: TWinControl; const AQuery:TBIQuery): TBIQueryEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AQuery
Type: TBIQuery

Return Value

Type: TBIQueryEditor

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.EStartChange(TObject) Method

Summary

Represents method EStartChange(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure EStartChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.ETitleChange(TObject) Method

Summary

Represents method ETitleChange(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure ETitleChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.FormCloseQuery(TObject,Boolean) Method

Summary

Represents method FormCloseQuery(TObject,Boolean).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure FormCloseQuery(Sender: TObject; var CanClose: Boolean);

Parameters

Sender
Type: TObject

CanClose
Type: Boolean

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.FormDestroy(TObject) Method

Summary

Represents method FormDestroy(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure FormDestroy(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.ListColumnsClick(TObject) Method

Summary

Represents method ListColumnsClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure ListColumnsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.ListMeasuresClick(TObject) Method

Summary

Represents method ListMeasuresClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure ListMeasuresClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.ListMeasuresDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) Method

Summary

Represents method ListMeasuresDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure ListMeasuresDragOver(Sender, Source: TObject; X, Y: Integer;
 State: TDragState; var Accept: Boolean);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

State
Type: TDragState

Accept
Type: Boolean

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.ListRowsClick(TObject) Method

Summary

Represents method ListRowsClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure ListRowsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.ListRowsClickCheck(TObject) Method

Summary

Represents method ListRowsClickCheck(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure ListRowsClickCheck(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.ListRowsDragDrop(TObject,TObject,Integer,Integer) Method

Summary

Represents method ListRowsDragDrop(TObject,TObject,Integer,Integer).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure ListRowsDragDrop(Sender, Source: TObject; X, Y: Integer);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.ListRowsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) Method

Summary

Represents method ListRowsDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure ListRowsDragOver(Sender, Source: TObject; X, Y: Integer;
 State: TDragState; var Accept: Boolean);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

State
Type: TDragState

Accept
Type: Boolean

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.PageDataChange(TObject) Method

Summary

Represents method PageDataChange(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure PageDataChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.PagePreviewChange(TObject) Method

Summary

Represents method PagePreviewChange(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure PagePreviewChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.Refresh(TBIQuery) Method

Summary

Represents method Refresh(TBIQuery).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
public
 procedure Refresh(const AQuery:TBIQuery);

Parameters

AQuery
Type: TBIQuery

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.RGPercentageClick(TObject) Method

Summary

Represents method RGPercentageClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure RGPercentageClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.RGRunningClick(TObject) Method

Summary

Represents method RGRunningClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure RGRunningClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.SBColDownClick(TObject) Method

Summary

Represents method SBColDownClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure SBColDownClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.SBColUpClick(TObject) Method

Summary

Represents method SBColUpClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure SBColUpClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.SBMeasureDownClick(TObject) Method

Summary

Represents method SBMeasureDownClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure SBMeasureDownClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.SBMeasureUpClick(TObject) Method

Summary

Represents method SBMeasureUpClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure SBMeasureUpClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.SBRowDownClick(TObject) Method

Summary

Represents method SBRowDownClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure SBRowDownClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.SBRowUpClick(TObject) Method

Summary

Represents method SBRowUpClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure SBRowUpClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.SBSelectorClick(TObject) Method

Summary

Represents method SBSelectorClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure SBSelectorClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.SBSwapClick(TObject) Method

Summary

Represents method SBSwapClick(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure SBSwapClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.Selector Method

Summary

Represents method Selector.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
public
 function Selector:TDataSelector;

Return Value

Type: TDataSelector

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.ShowSelector(Boolean) Method

Summary

Represents method ShowSelector(Boolean).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
public
 procedure ShowSelector(const AShow:Boolean);

Parameters

AShow
Type: Boolean

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.SpeedButton1Click(TObject) Method

Summary

Represents method SpeedButton1Click(TObject).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 procedure SpeedButton1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor Fields

Fields
Name | Description
BDeleteColumn | Represents field BDeleteColumn.
BDeleteMeasure | Represents field BDeleteMeasure.
BDeleteRow | Represents field BDeleteRow.
BIGrid1 | Represents field BIGrid1.
BIQuery1 | Represents field BIQuery1.
BOK | Represents field BOK.
Button1 | Represents field Button1.
CBAggregate | Represents field CBAggregate.
CBDatePart | Represents field CBDatePart.
CBDistinct | Represents field CBDistinct.
CBHistoActive | Represents field CBHistoActive.
CBMissingAsZero | Represents field CBMissingAsZero.
CBPreview | Represents field CBPreview.
CBRemoveCols | Represents field CBRemoveCols.
CBRemoveRows | Represents field CBRemoveRows.
CBRunningRows | Represents field CBRunningRows.
EBins | Represents field EBins.
EItemExpression | Represents field EItemExpression.
EMax | Represents field EMax.
EStart | Represents field EStart.
ETitle | Represents field ETitle.
GBHistogram | Represents field GBHistogram.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
LabelItemKind | Represents field LabelItemKind.
LExpressionError | Represents field LExpressionError.
ListColumns | Represents field ListColumns.
ListMeasures | Represents field ListMeasures.
ListRows | Represents field ListRows.
LMax | Represents field LMax.
LStart | Represents field LStart.
MemoSQL | Represents field MemoSQL.
OnShowEditor | Represents field OnShowEditor.
OuterPanel | Represents field OuterPanel.
PageData | Represents field PageData.
PageMeasures | Represents field PageMeasures.
PageOptions | Represents field PageOptions.
PagePreview | Represents field PagePreview.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
Panel5 | Represents field Panel5.
Panel6 | Represents field Panel6.
Panel7 | Represents field Panel7.
Panel8 | Represents field Panel8.
PanelButtons | Represents field PanelButtons.
PanelColumns | Represents field PanelColumns.
PanelEdit | Represents field PanelEdit.
PanelMeasures | Represents field PanelMeasures.
PanelOptions | Represents field PanelOptions.
PanelRows | Represents field PanelRows.
PanelSelector | Represents field PanelSelector.
RGPercentage | Represents field RGPercentage.
RGRunning | Represents field RGRunning.
SBColDown | Represents field SBColDown.
SBColUp | Represents field SBColUp.
SBMeasureDown | Represents field SBMeasureDown.
SBMeasureUp | Represents field SBMeasureUp.
SBRowDown | Represents field SBRowDown.
SBRowUp | Represents field SBRowUp.
SBSelector | Represents field SBSelector.
SBSwap | Represents field SBSwap.
SpeedButton1 | Represents field SpeedButton1.
SplitterPreview | Represents field SplitterPreview.
SplitterSelector | Represents field SplitterSelector.
TabCalc | Represents field TabCalc.
TabChart | Represents field TabChart.
TabData | Represents field TabData.
TabFilter | Represents field TabFilter.
TabGrid | Represents field TabGrid.
TabItem | Represents field TabItem.
TabItemData | Represents field TabItemData.
TabMeasure | Represents field TabMeasure.
TabMeasureOptions | Represents field TabMeasureOptions.
TabSort | Represents field TabSort.
TabSQL | Represents field TabSQL.
UDBins | Represents field UDBins.
Top


TBIQueryEditor.BDeleteColumn Field

Summary

Represents field BDeleteColumn.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 BDeleteColumn: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.BDeleteMeasure Field

Summary

Represents field BDeleteMeasure.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 BDeleteMeasure: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.BDeleteRow Field

Summary

Represents field BDeleteRow.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 BDeleteRow: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.BIGrid1 Field

Summary

Represents field BIGrid1.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 BIGrid1: TBIGrid;

Field Value

Type: TBIGrid

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.BIQuery1 Field

Summary

Represents field BIQuery1.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 BIQuery1: TBIQuery;

Field Value

Type: TBIQuery

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.BOK Field

Summary

Represents field BOK.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 BOK: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.Button1 Field

Summary

Represents field Button1.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.CBAggregate Field

Summary

Represents field CBAggregate.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 CBAggregate: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.CBDatePart Field

Summary

Represents field CBDatePart.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 CBDatePart: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.CBDistinct Field

Summary

Represents field CBDistinct.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 CBDistinct: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.CBHistoActive Field

Summary

Represents field CBHistoActive.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 CBHistoActive: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.CBMissingAsZero Field

Summary

Represents field CBMissingAsZero.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 CBMissingAsZero: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.CBPreview Field

Summary

Represents field CBPreview.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 CBPreview: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.CBRemoveCols Field

Summary

Represents field CBRemoveCols.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 CBRemoveCols: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.CBRemoveRows Field

Summary

Represents field CBRemoveRows.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 CBRemoveRows: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.CBRunningRows Field

Summary

Represents field CBRunningRows.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 CBRunningRows: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.EBins Field

Summary

Represents field EBins.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 EBins: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.EItemExpression Field

Summary

Represents field EItemExpression.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 EItemExpression: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.EMax Field

Summary

Represents field EMax.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 EMax: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.EStart Field

Summary

Represents field EStart.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 EStart: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.ETitle Field

Summary

Represents field ETitle.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 ETitle: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.GBHistogram Field

Summary

Represents field GBHistogram.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 GBHistogram: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.Label2 Field

Summary

Represents field Label2.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.Label3 Field

Summary

Represents field Label3.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.Label4 Field

Summary

Represents field Label4.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 Label4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.Label5 Field

Summary

Represents field Label5.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 Label5: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.Label6 Field

Summary

Represents field Label6.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 Label6: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.Label7 Field

Summary

Represents field Label7.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 Label7: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.LabelItemKind Field

Summary

Represents field LabelItemKind.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 LabelItemKind: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.LExpressionError Field

Summary

Represents field LExpressionError.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 LExpressionError: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.ListColumns Field

Summary

Represents field ListColumns.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 ListColumns: TCheckListBox;

Field Value

Type: TCheckListBox

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.ListMeasures Field

Summary

Represents field ListMeasures.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 ListMeasures: TCheckListBox;

Field Value

Type: TCheckListBox

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.ListRows Field

Summary

Represents field ListRows.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 ListRows: TCheckListBox;

Field Value

Type: TCheckListBox

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.LMax Field

Summary

Represents field LMax.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 LMax: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.LStart Field

Summary

Represents field LStart.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 LStart: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.MemoSQL Field

Summary

Represents field MemoSQL.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 MemoSQL: TMemo;

Field Value

Type: TMemo

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.OnShowEditor Field

Summary

Represents field OnShowEditor.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
public
 class
 var OnShowEditor : TOnShowQueryEditor;

Field Value

Type: TOnShowQueryEditor

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.OuterPanel Field

Summary

Represents field OuterPanel.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 OuterPanel: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.PageData Field

Summary

Represents field PageData.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 PageData: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.PageMeasures Field

Summary

Represents field PageMeasures.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 PageMeasures: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.PageOptions Field

Summary

Represents field PageOptions.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 PageOptions: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.PagePreview Field

Summary

Represents field PagePreview.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 PagePreview: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.Panel3 Field

Summary

Represents field Panel3.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 Panel3: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.Panel4 Field

Summary

Represents field Panel4.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 Panel4: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.Panel5 Field

Summary

Represents field Panel5.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 Panel5: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.Panel6 Field

Summary

Represents field Panel6.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 Panel6: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.Panel7 Field

Summary

Represents field Panel7.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 Panel7: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.Panel8 Field

Summary

Represents field Panel8.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 Panel8: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.PanelButtons Field

Summary

Represents field PanelButtons.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 PanelButtons: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.PanelColumns Field

Summary

Represents field PanelColumns.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 PanelColumns: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.PanelEdit Field

Summary

Represents field PanelEdit.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 PanelEdit: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.PanelMeasures Field

Summary

Represents field PanelMeasures.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 PanelMeasures: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.PanelOptions Field

Summary

Represents field PanelOptions.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 PanelOptions: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.PanelRows Field

Summary

Represents field PanelRows.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 PanelRows: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.PanelSelector Field

Summary

Represents field PanelSelector.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 PanelSelector: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.RGPercentage Field

Summary

Represents field RGPercentage.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 RGPercentage: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.RGRunning Field

Summary

Represents field RGRunning.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 RGRunning: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.SBColDown Field

Summary

Represents field SBColDown.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 SBColDown: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.SBColUp Field

Summary

Represents field SBColUp.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 SBColUp: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.SBMeasureDown Field

Summary

Represents field SBMeasureDown.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 SBMeasureDown: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.SBMeasureUp Field

Summary

Represents field SBMeasureUp.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 SBMeasureUp: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.SBRowDown Field

Summary

Represents field SBRowDown.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 SBRowDown: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.SBRowUp Field

Summary

Represents field SBRowUp.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 SBRowUp: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.SBSelector Field

Summary

Represents field SBSelector.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 SBSelector: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.SBSwap Field

Summary

Represents field SBSwap.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 SBSwap: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.SpeedButton1 Field

Summary

Represents field SpeedButton1.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 SpeedButton1: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.SplitterPreview Field

Summary

Represents field SplitterPreview.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 SplitterPreview: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.SplitterSelector Field

Summary

Represents field SplitterSelector.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 SplitterSelector: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.TabCalc Field

Summary

Represents field TabCalc.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 TabCalc: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.TabChart Field

Summary

Represents field TabChart.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 TabChart: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.TabData Field

Summary

Represents field TabData.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 TabData: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.TabFilter Field

Summary

Represents field TabFilter.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 TabFilter: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.TabGrid Field

Summary

Represents field TabGrid.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 TabGrid: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.TabItem Field

Summary

Represents field TabItem.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 TabItem: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.TabItemData Field

Summary

Represents field TabItemData.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 TabItemData: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.TabMeasure Field

Summary

Represents field TabMeasure.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 TabMeasure: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.TabMeasureOptions Field

Summary

Represents field TabMeasureOptions.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 TabMeasureOptions: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.TabSort Field

Summary

Represents field TabSort.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 TabSort: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.TabSQL Field

Summary

Represents field TabSQL.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 TabSQL: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TBIQueryEditor.UDBins Field

Summary

Represents field UDBins.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
published
 UDBins: TUpDown;

Field Value

Type: TUpDown

See Also

Reference

  • TBIQueryEditor
  • VCLBI.Editor.Query


TDataProviderAccess Class

Summary

Represents type TDataProviderAccess.

Namespace: VCLBI.Editor.Query
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
VCLBI.Editor.Query.TDataProviderAccess
Syntax
Delphi
type
 TDataProviderAccess=class(TDataProvider);
See Also

Reference

  • VCLBI.Editor.Query


TDataSelectorAccess Class

Summary

Represents type TDataSelectorAccess.

Namespace: VCLBI.Editor.Query
Inheritance Hierarchy
TForm
VCLBI.DataSelect.TDataSelector
VCLBI.Editor.Query.TDataSelectorAccess
Syntax
Delphi
type
 TDataSelectorAccess=class(TDataSelector);
See Also

Reference

  • VCLBI.Editor.Query


TGroupByAccess Class

Summary

Represents type TGroupByAccess.

Namespace: VCLBI.Editor.Query
Inheritance Hierarchy
TPersistent
BI.Summary.TBaseSummaryPersistent
BI.Summary.TSummaryItem
BI.Summary.TGroupBy
VCLBI.Editor.Query.TGroupByAccess
Syntax
Delphi
type
 TGroupByAccess=class(TGroupBy);
See Also

Reference

  • VCLBI.Editor.Query


VCLBI.Editor.Query Delegates

Delegates
Name | Description
TOnShowQueryEditor | Represents type TOnShowQueryEditor.
Top


TOnShowQueryEditor Delegate

Summary

Represents type TOnShowQueryEditor.

Namespace: VCLBI.Editor.Query
Syntax
Delphi
type
 TOnShowQueryEditor=procedure(const AParent:TWinControl;
 const AProvider:TComponent;
 const AData:TDataItem);
See Also

Reference

  • VCLBI.Editor.Query


VCLBI.Editor.Query Routines

Routines
Name | Description
DimensionOf(TCheckListBox) | Overloaded. Represents method DimensionOf(TCheckListBox).
DimensionOf(TCheckListBox,Integer) | Overloaded. Represents method DimensionOf(TCheckListBox,Integer).
EnableUpDown(TCheckListBox,TControl,TControl) | Represents method EnableUpDown(TCheckListBox,TControl,TControl).
MeasureOf(TCheckListBox) | Overloaded. Represents method MeasureOf(TCheckListBox).
MeasureOf(TCheckListBox,Integer) | Overloaded. Represents method MeasureOf(TCheckListBox,Integer).
Top


DimensionOf(TCheckListBox) Method

Summary

Represents method DimensionOf(TCheckListBox).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
function DimensionOf(const AList:TCheckListBox):TQueryDimension; overload; inline;

Parameters

AList
Type: TCheckListBox

Return Value

Type: TQueryDimension

See Also

Reference

  • VCLBI.Editor.Query


DimensionOf(TCheckListBox,Integer) Method

Summary

Represents method DimensionOf(TCheckListBox,Integer).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
function DimensionOf(const AList:TCheckListBox; const AIndex:Integer):TQueryDimension; overload;

Parameters

AList
Type: TCheckListBox

AIndex
Type: Integer

Return Value

Type: TQueryDimension

See Also

Reference

  • VCLBI.Editor.Query


EnableUpDown(TCheckListBox,TControl,TControl) Method

Summary

Represents method EnableUpDown(TCheckListBox,TControl,TControl).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
procedure EnableUpDown(const AList:TCheckListBox; const AUp,ADown:TControl);

Parameters

AList
Type: TCheckListBox

AUp
Type: TControl

ADown
Type: TControl

See Also

Reference

  • VCLBI.Editor.Query


MeasureOf(TCheckListBox) Method

Summary

Represents method MeasureOf(TCheckListBox).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
function MeasureOf(const AList:TCheckListBox):TQueryMeasure; overload; inline;

Parameters

AList
Type: TCheckListBox

Return Value

Type: TQueryMeasure

See Also

Reference

  • VCLBI.Editor.Query


MeasureOf(TCheckListBox,Integer) Method

Summary

Represents method MeasureOf(TCheckListBox,Integer).

Namespace: VCLBI.Editor.Query
Syntax
Delphi
function MeasureOf(const AList:TCheckListBox; const AIndex:Integer):TQueryMeasure; overload;

Parameters

AList
Type: TCheckListBox

AIndex
Type: Integer

Return Value

Type: TQueryMeasure

See Also

Reference

  • VCLBI.Editor.Query


VCLBI.Editor.Search Namespace

Summary

Represents namespace VCLBI.Editor.Search.

Classes
Name | Description
TSearchEditor | Represents type TSearchEditor.
Top
Delegates
Name | Description
TGetDataSet | Represents type TGetDataSet.
Top


VCLBI.Editor.Search Classes

Classes
Name | Description
TSearchEditor | Represents type TSearchEditor.
Top


TSearchEditor Class

Summary

Represents type TSearchEditor.

Namespace: VCLBI.Editor.Search
Inheritance Hierarchy
TForm
VCLBI.Editor.Search.TSearchEditor
Syntax
Delphi
type
 TSearchEditor = class(TForm)
 end;

The TSearchEditor type exposes the following members.

Properties
Show:
Name | Description
OnChanged | Represents property OnChanged.
Top
Methods
Show:
Name | Description
Casesensitive1Click(TObject) | Represents method Casesensitive1Click(TObject).
Clear | Represents method Clear.
Embed(TComponent,TWinControl,TAlign) | Represents method Embed(TComponent,TWinControl,TAlign).
ESearchChange(TObject) | Represents method ESearchChange(TObject).
Exact1Click(TObject) | Represents method Exact1Click(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
HasHit(Integer,TDataItem,TInteger) | Represents method HasHit(Integer,TDataItem,TInteger).
HasHits | Represents method HasHits.
HitIndex(Integer,TDataItem) | Represents method HitIndex(Integer,TDataItem).
Reposition(Integer) | Represents method Reposition(Integer).
SBDownClick(TObject) | Represents method SBDownClick(TObject).
SBMenuClick(TObject) | Represents method SBMenuClick(TObject).
SBUpClick(TObject) | Represents method SBUpClick(TObject).
Top
Events
Show:
Name | Description
OnGetDataSet | Represents property OnGetDataSet.
Top
Fields
Show:
Name | Description
Anywhere1 | Represents field Anywhere1.
Casesensitive1 | Represents field Casesensitive1.
Current | Represents field Current.
CurrentColor | Represents field CurrentColor.
End1 | Represents field End1.
ESearch | Represents field ESearch.
Exact1 | Represents field Exact1.
HighLightColor | Represents field HighLightColor.
LHits | Represents field LHits.
PopupMenu1 | Represents field PopupMenu1.
SBClose | Represents field SBClose.
SBDown | Represents field SBDown.
SBMenu | Represents field SBMenu.
SBUp | Represents field SBUp.
Search | Represents field Search.
Searchat1 | Represents field Searchat1.
Start1 | Represents field Start1.
Total | Represents field Total.
Top
See Also

Reference

  • VCLBI.Editor.Search


TSearchEditor Properties

Properties
Name | Description
OnChanged | Represents property OnChanged.
Top


TSearchEditor.OnChanged Property

Summary

Represents property OnChanged.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
public
 property OnChanged:TNotifyEvent read FOnChanged write FOnChanged;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor Methods

Methods
Name | Description
Casesensitive1Click(TObject) | Represents method Casesensitive1Click(TObject).
Clear | Represents method Clear.
Embed(TComponent,TWinControl,TAlign) | Represents method Embed(TComponent,TWinControl,TAlign).
ESearchChange(TObject) | Represents method ESearchChange(TObject).
Exact1Click(TObject) | Represents method Exact1Click(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
HasHit(Integer,TDataItem,TInteger) | Represents method HasHit(Integer,TDataItem,TInteger).
HasHits | Represents method HasHits.
HitIndex(Integer,TDataItem) | Represents method HitIndex(Integer,TDataItem).
Reposition(Integer) | Represents method Reposition(Integer).
SBDownClick(TObject) | Represents method SBDownClick(TObject).
SBMenuClick(TObject) | Represents method SBMenuClick(TObject).
SBUpClick(TObject) | Represents method SBUpClick(TObject).
Top


TSearchEditor.Casesensitive1Click(TObject) Method

Summary

Represents method Casesensitive1Click(TObject).

Namespace: VCLBI.Editor.Search
Syntax
Delphi
published
 procedure Casesensitive1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.Clear Method

Summary

Represents method Clear.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.Embed(TComponent,TWinControl,TAlign) Method

Summary

Represents method Embed(TComponent,TWinControl,TAlign).

Namespace: VCLBI.Editor.Search
Syntax
Delphi
public
 class function Embed(const AOwner:TComponent; const AParent:TWinControl;
 const AAlign:TAlign):TSearchEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AAlign
Type: TAlign

Return Value

Type: TSearchEditor

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.ESearchChange(TObject) Method

Summary

Represents method ESearchChange(TObject).

Namespace: VCLBI.Editor.Search
Syntax
Delphi
published
 procedure ESearchChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.Exact1Click(TObject) Method

Summary

Represents method Exact1Click(TObject).

Namespace: VCLBI.Editor.Search
Syntax
Delphi
published
 procedure Exact1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.Search
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.HasHit(Integer,TDataItem,TInteger) Method

Summary

Represents method HasHit(Integer,TDataItem,TInteger).

Namespace: VCLBI.Editor.Search
Syntax
Delphi
public
 function HasHit(const ARow:Integer;
 const AItem:TDataItem;
 out AIndex:TInteger):Boolean;

Parameters

ARow
Type: Integer

AItem
Type: TDataItem

AIndex
Type: System.Void

Return Value

Type: Boolean

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.HasHits Method

Summary

Represents method HasHits.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
public
 function HasHits:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.HitIndex(Integer,TDataItem) Method

Summary

Represents method HitIndex(Integer,TDataItem).

Namespace: VCLBI.Editor.Search
Syntax
Delphi
public
 function HitIndex(const ARow:Integer;
 const AItem:TDataItem):TInteger;

Parameters

ARow
Type: Integer

AItem
Type: TDataItem

Return Value

Type: TInteger

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.Reposition(Integer) Method

Summary

Represents method Reposition(Integer).

Namespace: VCLBI.Editor.Search
Syntax
Delphi
public
 procedure Reposition(const ALeft:Integer);

Parameters

ALeft
Type: Integer

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.SBDownClick(TObject) Method

Summary

Represents method SBDownClick(TObject).

Namespace: VCLBI.Editor.Search
Syntax
Delphi
published
 procedure SBDownClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.SBMenuClick(TObject) Method

Summary

Represents method SBMenuClick(TObject).

Namespace: VCLBI.Editor.Search
Syntax
Delphi
published
 procedure SBMenuClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.SBUpClick(TObject) Method

Summary

Represents method SBUpClick(TObject).

Namespace: VCLBI.Editor.Search
Syntax
Delphi
published
 procedure SBUpClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor Events

Events
Name | Description
OnGetDataSet | Represents property OnGetDataSet.
Top


TSearchEditor.OnGetDataSet Event

Summary

Represents property OnGetDataSet.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
public
 property OnGetDataSet:TGetDataSet read FOnGetDataSet write FOnGetDataSet;

Value

Type: TGetDataSet

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor Fields

Fields
Name | Description
Anywhere1 | Represents field Anywhere1.
Casesensitive1 | Represents field Casesensitive1.
Current | Represents field Current.
CurrentColor | Represents field CurrentColor.
End1 | Represents field End1.
ESearch | Represents field ESearch.
Exact1 | Represents field Exact1.
HighLightColor | Represents field HighLightColor.
LHits | Represents field LHits.
PopupMenu1 | Represents field PopupMenu1.
SBClose | Represents field SBClose.
SBDown | Represents field SBDown.
SBMenu | Represents field SBMenu.
SBUp | Represents field SBUp.
Search | Represents field Search.
Searchat1 | Represents field Searchat1.
Start1 | Represents field Start1.
Total | Represents field Total.
Top


TSearchEditor.Anywhere1 Field

Summary

Represents field Anywhere1.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
published
 Anywhere1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.Casesensitive1 Field

Summary

Represents field Casesensitive1.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
published
 Casesensitive1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.Current Field

Summary

Represents field Current.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
public
 Current,
 Total : TInteger;

Field Value

Type: TInteger

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.CurrentColor Field

Summary

Represents field CurrentColor.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
public
 CurrentColor,
 HighLightColor : TColor;

Field Value

Type: TColor

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.End1 Field

Summary

Represents field End1.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
published
 End1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.ESearch Field

Summary

Represents field ESearch.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
published
 ESearch: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.Exact1 Field

Summary

Represents field Exact1.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
published
 Exact1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.HighLightColor Field

Summary

Represents field HighLightColor.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
public
 CurrentColor,
 HighLightColor : TColor;

Field Value

Type: TColor

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.LHits Field

Summary

Represents field LHits.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
published
 LHits: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.PopupMenu1 Field

Summary

Represents field PopupMenu1.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
published
 PopupMenu1: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.SBClose Field

Summary

Represents field SBClose.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
published
 SBClose: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.SBDown Field

Summary

Represents field SBDown.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
published
 SBDown: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.SBMenu Field

Summary

Represents field SBMenu.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
published
 SBMenu: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.SBUp Field

Summary

Represents field SBUp.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
published
 SBUp: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.Search Field

Summary

Represents field Search.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
public
 Search : TDataSearch;

Field Value

Type: TDataSearch

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.Searchat1 Field

Summary

Represents field Searchat1.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
published
 Searchat1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.Start1 Field

Summary

Represents field Start1.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
published
 Start1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


TSearchEditor.Total Field

Summary

Represents field Total.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
public
 Current,
 Total : TInteger;

Field Value

Type: TInteger

See Also

Reference

  • TSearchEditor
  • VCLBI.Editor.Search


VCLBI.Editor.Search Delegates

Delegates
Name | Description
TGetDataSet | Represents type TGetDataSet.
Top


TGetDataSet Delegate

Summary

Represents type TGetDataSet.

Namespace: VCLBI.Editor.Search
Syntax
Delphi
type
 TGetDataSet=function:TBIDataSet of object;
See Also

Reference

  • VCLBI.Editor.Search


VCLBI.Editor.SelectText Namespace

Summary

Represents namespace VCLBI.Editor.SelectText.

Classes
Name | Description
TSelectTextItems | Represents type TSelectTextItems.
Top
Delegates
Name | Description
TSelectTextCheckEvent | Represents type TSelectTextCheckEvent.
Top


VCLBI.Editor.SelectText Classes

Classes
Name | Description
TSelectTextItems | Represents type TSelectTextItems.
Top


TSelectTextItems Class

Summary

Represents type TSelectTextItems.

Namespace: VCLBI.Editor.SelectText
Inheritance Hierarchy
TForm
VCLBI.Editor.SelectText.TSelectTextItems
Syntax
Delphi
type
 TSelectTextItems = class(TForm)
 end;

The TSelectTextItems type exposes the following members.

Properties
Show:
Name | Description
OnChanged | Represents property OnChanged.
Top
Methods
Show:
Name | Description
FormCreate(TObject) | Represents method FormCreate(TObject).
LBSingleTextClick(TObject) | Represents method LBSingleTextClick(TObject).
PageTextChange(TObject) | Represents method PageTextChange(TObject).
Refresh(TDataItem) | Represents method Refresh(TDataItem).
Selected | Represents method Selected.
Top
Events
Show:
Name | Description
OnChecked | Represents property OnChecked.
Top
Fields
Show:
Name | Description
LBSingleText | Represents field LBSingleText.
PageText | Represents field PageText.
TabMultiText | Represents field TabMultiText.
TabSingleText | Represents field TabSingleText.
Top
See Also

Reference

  • VCLBI.Editor.SelectText


TSelectTextItems Properties

Properties
Name | Description
OnChanged | Represents property OnChanged.
Top


TSelectTextItems.OnChanged Property

Summary

Represents property OnChanged.

Namespace: VCLBI.Editor.SelectText
Syntax
Delphi
public
 property OnChanged:TNotifyEvent read FOnChanged write FOnChanged;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TSelectTextItems
  • VCLBI.Editor.SelectText


TSelectTextItems Methods

Methods
Name | Description
FormCreate(TObject) | Represents method FormCreate(TObject).
LBSingleTextClick(TObject) | Represents method LBSingleTextClick(TObject).
PageTextChange(TObject) | Represents method PageTextChange(TObject).
Refresh(TDataItem) | Represents method Refresh(TDataItem).
Selected | Represents method Selected.
Top


TSelectTextItems.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.SelectText
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSelectTextItems
  • VCLBI.Editor.SelectText


TSelectTextItems.LBSingleTextClick(TObject) Method

Summary

Represents method LBSingleTextClick(TObject).

Namespace: VCLBI.Editor.SelectText
Syntax
Delphi
published
 procedure LBSingleTextClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSelectTextItems
  • VCLBI.Editor.SelectText


TSelectTextItems.PageTextChange(TObject) Method

Summary

Represents method PageTextChange(TObject).

Namespace: VCLBI.Editor.SelectText
Syntax
Delphi
published
 procedure PageTextChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSelectTextItems
  • VCLBI.Editor.SelectText


TSelectTextItems.Refresh(TDataItem) Method

Summary

Represents method Refresh(TDataItem).

Namespace: VCLBI.Editor.SelectText
Syntax
Delphi
public
 procedure Refresh(const AData:TDataItem);

Parameters

AData
Type: TDataItem

See Also

Reference

  • TSelectTextItems
  • VCLBI.Editor.SelectText


TSelectTextItems.Selected Method

Summary

Represents method Selected.

Namespace: VCLBI.Editor.SelectText
Syntax
Delphi
public
 function Selected:TStringList;

Return Value

Type: TStringList

See Also

Reference

  • TSelectTextItems
  • VCLBI.Editor.SelectText


TSelectTextItems Events

Events
Name | Description
OnChecked | Represents property OnChecked.
Top


TSelectTextItems.OnChecked Event

Summary

Represents property OnChecked.

Namespace: VCLBI.Editor.SelectText
Syntax
Delphi
public
 property OnChecked:TSelectTextCheckEvent read FOnChecked write FOnChecked;

Value

Type: TSelectTextCheckEvent

See Also

Reference

  • TSelectTextItems
  • VCLBI.Editor.SelectText


TSelectTextItems Fields

Fields
Name | Description
LBSingleText | Represents field LBSingleText.
PageText | Represents field PageText.
TabMultiText | Represents field TabMultiText.
TabSingleText | Represents field TabSingleText.
Top


TSelectTextItems.LBSingleText Field

Summary

Represents field LBSingleText.

Namespace: VCLBI.Editor.SelectText
Syntax
Delphi
published
 LBSingleText: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TSelectTextItems
  • VCLBI.Editor.SelectText


TSelectTextItems.PageText Field

Summary

Represents field PageText.

Namespace: VCLBI.Editor.SelectText
Syntax
Delphi
published
 PageText: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TSelectTextItems
  • VCLBI.Editor.SelectText


TSelectTextItems.TabMultiText Field

Summary

Represents field TabMultiText.

Namespace: VCLBI.Editor.SelectText
Syntax
Delphi
published
 TabMultiText: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TSelectTextItems
  • VCLBI.Editor.SelectText


TSelectTextItems.TabSingleText Field

Summary

Represents field TabSingleText.

Namespace: VCLBI.Editor.SelectText
Syntax
Delphi
published
 TabSingleText: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TSelectTextItems
  • VCLBI.Editor.SelectText


VCLBI.Editor.SelectText Delegates

Delegates
Name | Description
TSelectTextCheckEvent | Represents type TSelectTextCheckEvent.
Top


TSelectTextCheckEvent Delegate

Summary

Represents type TSelectTextCheckEvent.

Namespace: VCLBI.Editor.SelectText
Syntax
Delphi
type
 TSelectTextCheckEvent=procedure(const Sender:TObject;
 const AText:String;
 const IsChecked:Boolean) of object;
See Also

Reference

  • VCLBI.Editor.SelectText


VCLBI.Editor.Sort Namespace

Summary

Represents namespace VCLBI.Editor.Sort.

Classes
Name | Description
TQuerySortAccess | Represents type TQuerySortAccess.
TSortEditor | Represents type TSortEditor.
Top
Routines
Name | Description
CheckName(String) | Represents method CheckName(String).
Top


VCLBI.Editor.Sort Classes

Classes
Name | Description
TQuerySortAccess | Represents type TQuerySortAccess.
TSortEditor | Represents type TSortEditor.
Top


TQuerySortAccess Class

Summary

Represents type TQuerySortAccess.

Namespace: VCLBI.Editor.Sort
Inheritance Hierarchy
TOwnedCollection
BI.Query.TQueryCollection
BI.Query.TQuerySort
VCLBI.Editor.Sort.TQuerySortAccess
Syntax
Delphi
type
 TQuerySortAccess=class(TQuerySort);
See Also

Reference

  • VCLBI.Editor.Sort


TSortEditor Class

Summary

Represents type TSortEditor.

Namespace: VCLBI.Editor.Sort
Inheritance Hierarchy
TForm
VCLBI.Editor.Sort.TSortEditor
Syntax
Delphi
type
 TSortEditor = class(TForm)
 end;

The TSortEditor type exposes the following members.

Properties
Show:
Name | Description
OnChanged | Represents property OnChanged.
Top
Methods
Show:
Name | Description
BAddClick(TObject) | Represents method BAddClick(TObject).
BDeleteClick(TObject) | Represents method BDeleteClick(TObject).
CBAscendingClick(TObject) | Represents method CBAscendingClick(TObject).
CBIgnoreCaseClick(TObject) | Represents method CBIgnoreCaseClick(TObject).
Edit(TComponent,TDataItem,TSortItems) | Overloaded. Represents method Edit(TComponent,TDataItem,TSortItems).
Edit(TComponent,TQuerySort) | Overloaded. Represents method Edit(TComponent,TQuerySort).
Embedd(TComponent,TWinControl,TQuerySort) | Represents method Embedd(TComponent,TWinControl,TQuerySort).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
LBAvailableClick(TObject) | Represents method LBAvailableClick(TObject).
Refresh(TQuerySort) | Represents method Refresh(TQuerySort).
Top
Fields
Show:
Name | Description
BAdd | Represents field BAdd.
BCancel | Represents field BCancel.
BDelete | Represents field BDelete.
BOk | Represents field BOk.
CBAscending | Represents field CBAscending.
CBIgnoreCase | Represents field CBIgnoreCase.
LBAvailable | Represents field LBAvailable.
Panel1 | Represents field Panel1.
PanelButtons | Represents field PanelButtons.
PanelOk | Represents field PanelOk.
Splitter1 | Represents field Splitter1.
Top
See Also

Reference

  • VCLBI.Editor.Sort


TSortEditor Properties

Properties
Name | Description
OnChanged | Represents property OnChanged.
Top


TSortEditor.OnChanged Property

Summary

Represents property OnChanged.

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
public
 property OnChanged:TNotifyEvent read FOnChanged write FOnChanged;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor Methods

Methods
Name | Description
BAddClick(TObject) | Represents method BAddClick(TObject).
BDeleteClick(TObject) | Represents method BDeleteClick(TObject).
CBAscendingClick(TObject) | Represents method CBAscendingClick(TObject).
CBIgnoreCaseClick(TObject) | Represents method CBIgnoreCaseClick(TObject).
Edit(TComponent,TDataItem,TSortItems) | Overloaded. Represents method Edit(TComponent,TDataItem,TSortItems).
Edit(TComponent,TQuerySort) | Overloaded. Represents method Edit(TComponent,TQuerySort).
Embedd(TComponent,TWinControl,TQuerySort) | Represents method Embedd(TComponent,TWinControl,TQuerySort).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
LBAvailableClick(TObject) | Represents method LBAvailableClick(TObject).
Refresh(TQuerySort) | Represents method Refresh(TQuerySort).
Top


TSortEditor.BAddClick(TObject) Method

Summary

Represents method BAddClick(TObject).

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
published
 procedure BAddClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor.BDeleteClick(TObject) Method

Summary

Represents method BDeleteClick(TObject).

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
published
 procedure BDeleteClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor.CBAscendingClick(TObject) Method

Summary

Represents method CBAscendingClick(TObject).

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
published
 procedure CBAscendingClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor.CBIgnoreCaseClick(TObject) Method

Summary

Represents method CBIgnoreCaseClick(TObject).

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
published
 procedure CBIgnoreCaseClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor.Edit(TComponent,TDataItem,TSortItems) Method

Summary

Represents method Edit(TComponent,TDataItem,TSortItems).

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
public
 class function Edit(const AOwner: TComponent;
 const AData:TDataItem;
 out AItems:TSortItems):Boolean; overload; static;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

AItems
Type: TSortItems

Return Value

Type: Boolean

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor.Edit(TComponent,TQuerySort) Method

Summary

Represents method Edit(TComponent,TQuerySort).

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent;
 const ASort:TQuerySort):Boolean; overload; static;

Parameters

AOwner
Type: TComponent

ASort
Type: TQuerySort

Return Value

Type: Boolean

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor.Embedd(TComponent,TWinControl,TQuerySort) Method

Summary

Represents method Embedd(TComponent,TWinControl,TQuerySort).

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const ASort:TQuerySort):TSortEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

ASort
Type: TQuerySort

Return Value

Type: TSortEditor

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor.LBAvailableClick(TObject) Method

Summary

Represents method LBAvailableClick(TObject).

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
published
 procedure LBAvailableClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor.Refresh(TQuerySort) Method

Summary

Represents method Refresh(TQuerySort).

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
public
 procedure Refresh(const ASort:TQuerySort);

Parameters

ASort
Type: TQuerySort

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor Fields

Fields
Name | Description
BAdd | Represents field BAdd.
BCancel | Represents field BCancel.
BDelete | Represents field BDelete.
BOk | Represents field BOk.
CBAscending | Represents field CBAscending.
CBIgnoreCase | Represents field CBIgnoreCase.
LBAvailable | Represents field LBAvailable.
Panel1 | Represents field Panel1.
PanelButtons | Represents field PanelButtons.
PanelOk | Represents field PanelOk.
Splitter1 | Represents field Splitter1.
Top


TSortEditor.BAdd Field

Summary

Represents field BAdd.

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
published
 BAdd: TButton;

Field Value

Type: TButton

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor.BCancel Field

Summary

Represents field BCancel.

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
published
 BCancel: TButton;

Field Value

Type: TButton

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor.BDelete Field

Summary

Represents field BDelete.

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
published
 BDelete: TButton;

Field Value

Type: TButton

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor.BOk Field

Summary

Represents field BOk.

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
published
 BOk: TButton;

Field Value

Type: TButton

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor.CBAscending Field

Summary

Represents field CBAscending.

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
published
 CBAscending: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor.CBIgnoreCase Field

Summary

Represents field CBIgnoreCase.

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
published
 CBIgnoreCase: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor.LBAvailable Field

Summary

Represents field LBAvailable.

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
published
 LBAvailable: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor.PanelButtons Field

Summary

Represents field PanelButtons.

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
published
 PanelButtons: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor.PanelOk Field

Summary

Represents field PanelOk.

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
published
 PanelOk: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


TSortEditor.Splitter1 Field

Summary

Represents field Splitter1.

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
published
 Splitter1: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TSortEditor
  • VCLBI.Editor.Sort


VCLBI.Editor.Sort Routines

Routines
Name | Description
CheckName(String) | Represents method CheckName(String).
Top


CheckName(String) Method

Summary

Represents method CheckName(String).

Namespace: VCLBI.Editor.Sort
Syntax
Delphi
function CheckName(const AName:String):String;

Parameters

AName
Type: String

Return Value

Type: String

See Also

Reference

  • VCLBI.Editor.Sort


VCLBI.Editor.Split Namespace

Summary

Represents namespace VCLBI.Editor.Split.

Classes
Name | Description
TSplitEditor | Represents type TSplitEditor.
Top


VCLBI.Editor.Split Classes

Classes
Name | Description
TSplitEditor | Represents type TSplitEditor.
Top


TSplitEditor Class

Summary

Represents type TSplitEditor.

Namespace: VCLBI.Editor.Split
Inheritance Hierarchy
TForm
VCLBI.Editor.Split.TSplitEditor
Syntax
Delphi
type
 TSplitEditor = class(TForm)
 end;

The TSplitEditor type exposes the following members.

Methods
Show:
Name | Description
ECountChange(TObject) | Represents method ECountChange(TObject).
Edit(TComponent,TSplitOptions) | Represents method Edit(TComponent,TSplitOptions).
PageByChange(TObject) | Represents method PageByChange(TObject).
TBPercentChange(TObject) | Represents method TBPercentChange(TObject).
Top
Fields
Show:
Name | Description
BCancel | Represents field BCancel.
BOk | Represents field BOk.
ECount | Represents field ECount.
LPercent | Represents field LPercent.
LValue | Represents field LValue.
PageBy | Represents field PageBy.
Panel1 | Represents field Panel1.
PanelButtons | Represents field PanelButtons.
PanelOk | Represents field PanelOk.
RGMode | Represents field RGMode.
TabCount | Represents field TabCount.
TabPercent | Represents field TabPercent.
TBPercent | Represents field TBPercent.
Top
See Also

Reference

  • VCLBI.Editor.Split


TSplitEditor Methods

Methods
Name | Description
ECountChange(TObject) | Represents method ECountChange(TObject).
Edit(TComponent,TSplitOptions) | Represents method Edit(TComponent,TSplitOptions).
PageByChange(TObject) | Represents method PageByChange(TObject).
TBPercentChange(TObject) | Represents method TBPercentChange(TObject).
Top


TSplitEditor.ECountChange(TObject) Method

Summary

Represents method ECountChange(TObject).

Namespace: VCLBI.Editor.Split
Syntax
Delphi
published
 procedure ECountChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSplitEditor
  • VCLBI.Editor.Split


TSplitEditor.Edit(TComponent,TSplitOptions) Method

Summary

Represents method Edit(TComponent,TSplitOptions).

Namespace: VCLBI.Editor.Split
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; var ASplit:TSplitOptions):Boolean; static;

Parameters

AOwner
Type: TComponent

ASplit
Type: TSplitOptions

Return Value

Type: Boolean

See Also

Reference

  • TSplitEditor
  • VCLBI.Editor.Split


TSplitEditor.PageByChange(TObject) Method

Summary

Represents method PageByChange(TObject).

Namespace: VCLBI.Editor.Split
Syntax
Delphi
published
 procedure PageByChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSplitEditor
  • VCLBI.Editor.Split


TSplitEditor.TBPercentChange(TObject) Method

Summary

Represents method TBPercentChange(TObject).

Namespace: VCLBI.Editor.Split
Syntax
Delphi
published
 procedure TBPercentChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSplitEditor
  • VCLBI.Editor.Split


TSplitEditor Fields

Fields
Name | Description
BCancel | Represents field BCancel.
BOk | Represents field BOk.
ECount | Represents field ECount.
LPercent | Represents field LPercent.
LValue | Represents field LValue.
PageBy | Represents field PageBy.
Panel1 | Represents field Panel1.
PanelButtons | Represents field PanelButtons.
PanelOk | Represents field PanelOk.
RGMode | Represents field RGMode.
TabCount | Represents field TabCount.
TabPercent | Represents field TabPercent.
TBPercent | Represents field TBPercent.
Top


TSplitEditor.BCancel Field

Summary

Represents field BCancel.

Namespace: VCLBI.Editor.Split
Syntax
Delphi
published
 BCancel: TButton;

Field Value

Type: TButton

See Also

Reference

  • TSplitEditor
  • VCLBI.Editor.Split


TSplitEditor.BOk Field

Summary

Represents field BOk.

Namespace: VCLBI.Editor.Split
Syntax
Delphi
published
 BOk: TButton;

Field Value

Type: TButton

See Also

Reference

  • TSplitEditor
  • VCLBI.Editor.Split


TSplitEditor.ECount Field

Summary

Represents field ECount.

Namespace: VCLBI.Editor.Split
Syntax
Delphi
published
 ECount: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TSplitEditor
  • VCLBI.Editor.Split


TSplitEditor.LPercent Field

Summary

Represents field LPercent.

Namespace: VCLBI.Editor.Split
Syntax
Delphi
published
 LPercent: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TSplitEditor
  • VCLBI.Editor.Split


TSplitEditor.LValue Field

Summary

Represents field LValue.

Namespace: VCLBI.Editor.Split
Syntax
Delphi
published
 LValue: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TSplitEditor
  • VCLBI.Editor.Split


TSplitEditor.PageBy Field

Summary

Represents field PageBy.

Namespace: VCLBI.Editor.Split
Syntax
Delphi
published
 PageBy: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TSplitEditor
  • VCLBI.Editor.Split


TSplitEditor.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Editor.Split
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TSplitEditor
  • VCLBI.Editor.Split


TSplitEditor.PanelButtons Field

Summary

Represents field PanelButtons.

Namespace: VCLBI.Editor.Split
Syntax
Delphi
published
 PanelButtons: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TSplitEditor
  • VCLBI.Editor.Split


TSplitEditor.PanelOk Field

Summary

Represents field PanelOk.

Namespace: VCLBI.Editor.Split
Syntax
Delphi
published
 PanelOk: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TSplitEditor
  • VCLBI.Editor.Split


TSplitEditor.RGMode Field

Summary

Represents field RGMode.

Namespace: VCLBI.Editor.Split
Syntax
Delphi
published
 RGMode: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TSplitEditor
  • VCLBI.Editor.Split


TSplitEditor.TabCount Field

Summary

Represents field TabCount.

Namespace: VCLBI.Editor.Split
Syntax
Delphi
published
 TabCount: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TSplitEditor
  • VCLBI.Editor.Split


TSplitEditor.TabPercent Field

Summary

Represents field TabPercent.

Namespace: VCLBI.Editor.Split
Syntax
Delphi
published
 TabPercent: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TSplitEditor
  • VCLBI.Editor.Split


TSplitEditor.TBPercent Field

Summary

Represents field TBPercent.

Namespace: VCLBI.Editor.Split
Syntax
Delphi
published
 TBPercent: TTrackBar;

Field Value

Type: TTrackBar

See Also

Reference

  • TSplitEditor
  • VCLBI.Editor.Split


VCLBI.Editor.Stores Namespace

Summary

Represents namespace VCLBI.Editor.Stores.

Classes
Name | Description
TDataEditorAccess | Represents type TDataEditorAccess.
TListBoxAccess | Represents type TListBoxAccess.
TStoreEditor | Represents type TStoreEditor.
Top
Routines
Name | Description
TryFocus(TWinControl) | Represents method TryFocus(TWinControl).
Top


VCLBI.Editor.Stores Classes

Classes
Name | Description
TDataEditorAccess | Represents type TDataEditorAccess.
TListBoxAccess | Represents type TListBoxAccess.
TStoreEditor | Represents type TStoreEditor.
Top


TDataEditorAccess Class

Summary

Represents type TDataEditorAccess.

Namespace: VCLBI.Editor.Stores
Inheritance Hierarchy
TForm
VCLBI.Editor.Data.TDataEditor
VCLBI.Editor.Stores.TDataEditorAccess
Syntax
Delphi
type
 TDataEditorAccess=class(TDataEditor);
See Also

Reference

  • VCLBI.Editor.Stores


TListBoxAccess Class

Summary

Represents type TListBoxAccess.

Namespace: VCLBI.Editor.Stores
Inheritance Hierarchy
TListBox
VCLBI.Editor.Stores.TListBoxAccess
Syntax
Delphi
type
 TListBoxAccess=class(TListBox);
See Also

Reference

  • VCLBI.Editor.Stores


TStoreEditor Class

Summary

Represents type TStoreEditor.

Namespace: VCLBI.Editor.Stores
Inheritance Hierarchy
TForm
VCLBI.Editor.Stores.TStoreEditor
Syntax
Delphi
type
 TStoreEditor = class(TForm)
 end;

The TStoreEditor type exposes the following members.

Methods
Show:
Name | Description
BCloseClick(TObject) | Represents method BCloseClick(TObject).
BRemoveClick(TObject) | Represents method BRemoveClick(TObject).
BRenameClick(TObject) | Represents method BRenameClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
CBDefaultClick(TObject) | Represents method CBDefaultClick(TObject).
Edit(TComponent) | Represents method Edit(TComponent).
EFolderChange(TObject) | Represents method EFolderChange(TObject).
Folder1Click(TObject) | Represents method Folder1Click(TObject).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
LBStoresClick(TObject) | Represents method LBStoresClick(TObject).
LBStoresDrawItem(TWinControl,Integer,TRect,TOwnerDrawState) | Represents method LBStoresDrawItem(TWinControl,Integer,TRect,TOwnerDrawState).
SpeedButton1Click(TObject) | Represents method SpeedButton1Click(TObject).
WebServer1Click(TObject) | Represents method WebServer1Click(TObject).
Top
Fields
Show:
Name | Description
BClose | Represents field BClose.
BRemove | Represents field BRemove.
BRename | Represents field BRename.
Button1 | Represents field Button1.
CBDefault | Represents field CBDefault.
EFolder | Represents field EFolder.
Folder1 | Represents field Folder1.
Label1 | Represents field Label1.
LBadFolder | Represents field LBadFolder.
LBStores | Represents field LBStores.
PageControl1 | Represents field PageControl1.
Panel1 | Represents field Panel1.
Panel4 | Represents field Panel4.
PanelButtons | Represents field PanelButtons.
PopupMenu1 | Represents field PopupMenu1.
SpeedButton1 | Represents field SpeedButton1.
TabFolder | Represents field TabFolder.
TabWeb | Represents field TabWeb.
WebServer1 | Represents field WebServer1.
Top
See Also

Reference

  • VCLBI.Editor.Stores


TStoreEditor Methods

Methods
Name | Description
BCloseClick(TObject) | Represents method BCloseClick(TObject).
BRemoveClick(TObject) | Represents method BRemoveClick(TObject).
BRenameClick(TObject) | Represents method BRenameClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
CBDefaultClick(TObject) | Represents method CBDefaultClick(TObject).
Edit(TComponent) | Represents method Edit(TComponent).
EFolderChange(TObject) | Represents method EFolderChange(TObject).
Folder1Click(TObject) | Represents method Folder1Click(TObject).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
LBStoresClick(TObject) | Represents method LBStoresClick(TObject).
LBStoresDrawItem(TWinControl,Integer,TRect,TOwnerDrawState) | Represents method LBStoresDrawItem(TWinControl,Integer,TRect,TOwnerDrawState).
SpeedButton1Click(TObject) | Represents method SpeedButton1Click(TObject).
WebServer1Click(TObject) | Represents method WebServer1Click(TObject).
Top


TStoreEditor.BCloseClick(TObject) Method

Summary

Represents method BCloseClick(TObject).

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 procedure BCloseClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.BRemoveClick(TObject) Method

Summary

Represents method BRemoveClick(TObject).

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 procedure BRemoveClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.BRenameClick(TObject) Method

Summary

Represents method BRenameClick(TObject).

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 procedure BRenameClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.CBDefaultClick(TObject) Method

Summary

Represents method CBDefaultClick(TObject).

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 procedure CBDefaultClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.Edit(TComponent) Method

Summary

Represents method Edit(TComponent).

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
public
 class procedure Edit(const AOwner:TComponent); static;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.EFolderChange(TObject) Method

Summary

Represents method EFolderChange(TObject).

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 procedure EFolderChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.Folder1Click(TObject) Method

Summary

Represents method Folder1Click(TObject).

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 procedure Folder1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.FormClose(TObject,TCloseAction) Method

Summary

Represents method FormClose(TObject,TCloseAction).

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 procedure FormClose(Sender: TObject; var Action: TCloseAction);

Parameters

Sender
Type: TObject

Action
Type: TCloseAction

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.LBStoresClick(TObject) Method

Summary

Represents method LBStoresClick(TObject).

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 procedure LBStoresClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.LBStoresDrawItem(TWinControl,Integer,TRect,TOwnerDrawState) Method

Summary

Represents method LBStoresDrawItem(TWinControl,Integer,TRect,TOwnerDrawState).

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 procedure LBStoresDrawItem(Control: TWinControl; Index: Integer;
 Rect: TRect; State: TOwnerDrawState);

Parameters

Control
Type: TWinControl

Index
Type: Integer

Rect
Type: TRect

State
Type: TOwnerDrawState

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.SpeedButton1Click(TObject) Method

Summary

Represents method SpeedButton1Click(TObject).

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 procedure SpeedButton1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.WebServer1Click(TObject) Method

Summary

Represents method WebServer1Click(TObject).

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 procedure WebServer1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor Fields

Fields
Name | Description
BClose | Represents field BClose.
BRemove | Represents field BRemove.
BRename | Represents field BRename.
Button1 | Represents field Button1.
CBDefault | Represents field CBDefault.
EFolder | Represents field EFolder.
Folder1 | Represents field Folder1.
Label1 | Represents field Label1.
LBadFolder | Represents field LBadFolder.
LBStores | Represents field LBStores.
PageControl1 | Represents field PageControl1.
Panel1 | Represents field Panel1.
Panel4 | Represents field Panel4.
PanelButtons | Represents field PanelButtons.
PopupMenu1 | Represents field PopupMenu1.
SpeedButton1 | Represents field SpeedButton1.
TabFolder | Represents field TabFolder.
TabWeb | Represents field TabWeb.
WebServer1 | Represents field WebServer1.
Top


TStoreEditor.BClose Field

Summary

Represents field BClose.

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 BClose: TButton;

Field Value

Type: TButton

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.BRemove Field

Summary

Represents field BRemove.

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 BRemove: TButton;

Field Value

Type: TButton

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.BRename Field

Summary

Represents field BRename.

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 BRename: TButton;

Field Value

Type: TButton

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.Button1 Field

Summary

Represents field Button1.

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.CBDefault Field

Summary

Represents field CBDefault.

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 CBDefault: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.EFolder Field

Summary

Represents field EFolder.

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 EFolder: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.Folder1 Field

Summary

Represents field Folder1.

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 Folder1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.LBadFolder Field

Summary

Represents field LBadFolder.

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 LBadFolder: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.LBStores Field

Summary

Represents field LBStores.

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 LBStores: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.PageControl1 Field

Summary

Represents field PageControl1.

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 PageControl1: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.Panel4 Field

Summary

Represents field Panel4.

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 Panel4: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.PanelButtons Field

Summary

Represents field PanelButtons.

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 PanelButtons: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.PopupMenu1 Field

Summary

Represents field PopupMenu1.

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 PopupMenu1: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.SpeedButton1 Field

Summary

Represents field SpeedButton1.

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 SpeedButton1: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.TabFolder Field

Summary

Represents field TabFolder.

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 TabFolder: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.TabWeb Field

Summary

Represents field TabWeb.

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 TabWeb: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


TStoreEditor.WebServer1 Field

Summary

Represents field WebServer1.

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
published
 WebServer1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TStoreEditor
  • VCLBI.Editor.Stores


VCLBI.Editor.Stores Routines

Routines
Name | Description
TryFocus(TWinControl) | Represents method TryFocus(TWinControl).
Top


TryFocus(TWinControl) Method

Summary

Represents method TryFocus(TWinControl).

Namespace: VCLBI.Editor.Stores
Syntax
Delphi
procedure TryFocus(const AControl:TWinControl);

Parameters

AControl
Type: TWinControl

See Also

Reference

  • VCLBI.Editor.Stores


VCLBI.Editor.Summary Namespace

Summary

Represents namespace VCLBI.Editor.Summary.

Classes
Name | Description
TSummaryEditor | Represents type TSummaryEditor.
Top


VCLBI.Editor.Summary Classes

Classes
Name | Description
TSummaryEditor | Represents type TSummaryEditor.
Top


TSummaryEditor Class

Summary

Represents type TSummaryEditor.

Namespace: VCLBI.Editor.Summary
Inheritance Hierarchy
TForm
VCLBI.Editor.Summary.TSummaryEditor
Syntax
Delphi
type
 TSummaryEditor = class(TForm)
 end;

The TSummaryEditor type exposes the following members.

Methods
Show:
Name | Description
BDownClick(TObject) | Represents method BDownClick(TObject).
BRemoveDimClick(TObject) | Represents method BRemoveDimClick(TObject).
BRemoveMeasureClick(TObject) | Represents method BRemoveMeasureClick(TObject).
BUpClick(TObject) | Represents method BUpClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
Button3Click(TObject) | Represents method Button3Click(TObject).
CBAggregateChange(TObject) | Represents method CBAggregateChange(TObject).
CBAutoBinsClick(TObject) | Represents method CBAutoBinsClick(TObject).
CBDatePartChange(TObject) | Represents method CBDatePartChange(TObject).
CBHistogramClick(TObject) | Represents method CBHistogramClick(TObject).
CBMaxAutoClick(TObject) | Represents method CBMaxAutoClick(TObject).
CBMinAutoClick(TObject) | Represents method CBMinAutoClick(TObject).
CBMissingAsZeroClick(TObject) | Represents method CBMissingAsZeroClick(TObject).
CBRemoveColsClick(TObject) | Represents method CBRemoveColsClick(TObject).
CBRemoveMissingClick(TObject) | Represents method CBRemoveMissingClick(TObject).
CBRunningRowsClick(TObject) | Represents method CBRunningRowsClick(TObject).
DownDimClick(TObject) | Represents method DownDimClick(TObject).
EBinsChange(TObject) | Represents method EBinsChange(TObject).
Edit(TComponent,TSummary) | Represents method Edit(TComponent,TSummary).
EFilterChange(TObject) | Represents method EFilterChange(TObject).
EGroupExpressionChange(TObject) | Represents method EGroupExpressionChange(TObject).
EGroupNameChange(TObject) | Represents method EGroupNameChange(TObject).
EHavingChange(TObject) | Represents method EHavingChange(TObject).
EHistFormatChange(TObject) | Represents method EHistFormatChange(TObject).
EHistoMaxChange(TObject) | Represents method EHistoMaxChange(TObject).
EHistoMinChange(TObject) | Represents method EHistoMinChange(TObject).
EMeasureExpressionChange(TObject) | Represents method EMeasureExpressionChange(TObject).
EMeasureNameChange(TObject) | Represents method EMeasureNameChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
LDimensionsClick(TObject) | Represents method LDimensionsClick(TObject).
LDimensionsClickCheck(TObject) | Represents method LDimensionsClickCheck(TObject).
LDimensionsDragDrop(TObject,TObject,Integer,Integer) | Represents method LDimensionsDragDrop(TObject,TObject,Integer,Integer).
LMeasuresClick(TObject) | Represents method LMeasuresClick(TObject).
LMeasuresClickCheck(TObject) | Represents method LMeasuresClickCheck(TObject).
LMeasuresDragDrop(TObject,TObject,Integer,Integer) | Represents method LMeasuresDragDrop(TObject,TObject,Integer,Integer).
LMeasuresDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method LMeasuresDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
PageGroupsResize(TObject) | Represents method PageGroupsResize(TObject).
PageMeasuresResize(TObject) | Represents method PageMeasuresResize(TObject).
Refresh(TSummary) | Represents method Refresh(TSummary).
RGLayoutClick(TObject) | Represents method RGLayoutClick(TObject).
RGPercentageClick(TObject) | Represents method RGPercentageClick(TObject).
RGRunningClick(TObject) | Represents method RGRunningClick(TObject).
UpDimClick(TObject) | Represents method UpDimClick(TObject).
Top
Fields
Show:
Name | Description
BDown | Represents field BDown.
BOK | Represents field BOK.
BRemoveDim | Represents field BRemoveDim.
BRemoveMeasure | Represents field BRemoveMeasure.
BUp | Represents field BUp.
Button1 | Represents field Button1.
Button2 | Represents field Button2.
Button3 | Represents field Button3.
CBAggregate | Represents field CBAggregate.
CBAutoBins | Represents field CBAutoBins.
CBDatePart | Represents field CBDatePart.
CBHistogram | Represents field CBHistogram.
CBMaxAuto | Represents field CBMaxAuto.
CBMinAuto | Represents field CBMinAuto.
CBMissingAsZero | Represents field CBMissingAsZero.
CBRemoveCols | Represents field CBRemoveCols.
CBRemoveMissing | Represents field CBRemoveMissing.
CBRunningRows | Represents field CBRunningRows.
DownDim | Represents field DownDim.
EBins | Represents field EBins.
EFilter | Represents field EFilter.
EGroupExpression | Represents field EGroupExpression.
EGroupName | Represents field EGroupName.
EHaving | Represents field EHaving.
EHistFormat | Represents field EHistFormat.
EHistoMax | Represents field EHistoMax.
EHistoMin | Represents field EHistoMin.
EMeasureExpression | Represents field EMeasureExpression.
EMeasureName | Represents field EMeasureName.
GroupBox1 | Represents field GroupBox1.
Label1 | Represents field Label1.
Label10 | Represents field Label10.
Label11 | Represents field Label11.
Label12 | Represents field Label12.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
Label8 | Represents field Label8.
Label9 | Represents field Label9.
LabelMeasureKind | Represents field LabelMeasureKind.
LDimensions | Represents field LDimensions.
LFilter | Represents field LFilter.
LGroupError | Represents field LGroupError.
LHaving | Represents field LHaving.
LMeasureError | Represents field LMeasureError.
LMeasures | Represents field LMeasures.
OnRecalculate | Represents field OnRecalculate.
PageControl1 | Represents field PageControl1.
PageGroups | Represents field PageGroups.
PageMeasures | Represents field PageMeasures.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel9 | Represents field Panel9.
PanelButtons | Represents field PanelButtons.
PanelGroups | Represents field PanelGroups.
RGLayout | Represents field RGLayout.
RGPercentage | Represents field RGPercentage.
RGRunning | Represents field RGRunning.
TabCalc | Represents field TabCalc.
TabDimensions | Represents field TabDimensions.
TabFilter | Represents field TabFilter.
TabGroup | Represents field TabGroup.
TabGroupData | Represents field TabGroupData.
TabHistogram | Represents field TabHistogram.
TabMeasure | Represents field TabMeasure.
TabMeasureInfo | Represents field TabMeasureInfo.
TabMeasures | Represents field TabMeasures.
TabSheet2 | Represents field TabSheet2.
UDBins | Represents field UDBins.
UpDim | Represents field UpDim.
Top
See Also

Reference

  • VCLBI.Editor.Summary


TSummaryEditor Methods

Methods
Name | Description
BDownClick(TObject) | Represents method BDownClick(TObject).
BRemoveDimClick(TObject) | Represents method BRemoveDimClick(TObject).
BRemoveMeasureClick(TObject) | Represents method BRemoveMeasureClick(TObject).
BUpClick(TObject) | Represents method BUpClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
Button3Click(TObject) | Represents method Button3Click(TObject).
CBAggregateChange(TObject) | Represents method CBAggregateChange(TObject).
CBAutoBinsClick(TObject) | Represents method CBAutoBinsClick(TObject).
CBDatePartChange(TObject) | Represents method CBDatePartChange(TObject).
CBHistogramClick(TObject) | Represents method CBHistogramClick(TObject).
CBMaxAutoClick(TObject) | Represents method CBMaxAutoClick(TObject).
CBMinAutoClick(TObject) | Represents method CBMinAutoClick(TObject).
CBMissingAsZeroClick(TObject) | Represents method CBMissingAsZeroClick(TObject).
CBRemoveColsClick(TObject) | Represents method CBRemoveColsClick(TObject).
CBRemoveMissingClick(TObject) | Represents method CBRemoveMissingClick(TObject).
CBRunningRowsClick(TObject) | Represents method CBRunningRowsClick(TObject).
DownDimClick(TObject) | Represents method DownDimClick(TObject).
EBinsChange(TObject) | Represents method EBinsChange(TObject).
Edit(TComponent,TSummary) | Represents method Edit(TComponent,TSummary).
EFilterChange(TObject) | Represents method EFilterChange(TObject).
EGroupExpressionChange(TObject) | Represents method EGroupExpressionChange(TObject).
EGroupNameChange(TObject) | Represents method EGroupNameChange(TObject).
EHavingChange(TObject) | Represents method EHavingChange(TObject).
EHistFormatChange(TObject) | Represents method EHistFormatChange(TObject).
EHistoMaxChange(TObject) | Represents method EHistoMaxChange(TObject).
EHistoMinChange(TObject) | Represents method EHistoMinChange(TObject).
EMeasureExpressionChange(TObject) | Represents method EMeasureExpressionChange(TObject).
EMeasureNameChange(TObject) | Represents method EMeasureNameChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
LDimensionsClick(TObject) | Represents method LDimensionsClick(TObject).
LDimensionsClickCheck(TObject) | Represents method LDimensionsClickCheck(TObject).
LDimensionsDragDrop(TObject,TObject,Integer,Integer) | Represents method LDimensionsDragDrop(TObject,TObject,Integer,Integer).
LMeasuresClick(TObject) | Represents method LMeasuresClick(TObject).
LMeasuresClickCheck(TObject) | Represents method LMeasuresClickCheck(TObject).
LMeasuresDragDrop(TObject,TObject,Integer,Integer) | Represents method LMeasuresDragDrop(TObject,TObject,Integer,Integer).
LMeasuresDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method LMeasuresDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
PageGroupsResize(TObject) | Represents method PageGroupsResize(TObject).
PageMeasuresResize(TObject) | Represents method PageMeasuresResize(TObject).
Refresh(TSummary) | Represents method Refresh(TSummary).
RGLayoutClick(TObject) | Represents method RGLayoutClick(TObject).
RGPercentageClick(TObject) | Represents method RGPercentageClick(TObject).
RGRunningClick(TObject) | Represents method RGRunningClick(TObject).
UpDimClick(TObject) | Represents method UpDimClick(TObject).
Top


TSummaryEditor.BDownClick(TObject) Method

Summary

Represents method BDownClick(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure BDownClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.BRemoveDimClick(TObject) Method

Summary

Represents method BRemoveDimClick(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure BRemoveDimClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.BRemoveMeasureClick(TObject) Method

Summary

Represents method BRemoveMeasureClick(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure BRemoveMeasureClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.BUpClick(TObject) Method

Summary

Represents method BUpClick(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure BUpClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Button3Click(TObject) Method

Summary

Represents method Button3Click(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure Button3Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.CBAggregateChange(TObject) Method

Summary

Represents method CBAggregateChange(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure CBAggregateChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.CBAutoBinsClick(TObject) Method

Summary

Represents method CBAutoBinsClick(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure CBAutoBinsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.CBDatePartChange(TObject) Method

Summary

Represents method CBDatePartChange(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure CBDatePartChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.CBHistogramClick(TObject) Method

Summary

Represents method CBHistogramClick(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure CBHistogramClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.CBMaxAutoClick(TObject) Method

Summary

Represents method CBMaxAutoClick(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure CBMaxAutoClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.CBMinAutoClick(TObject) Method

Summary

Represents method CBMinAutoClick(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure CBMinAutoClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.CBMissingAsZeroClick(TObject) Method

Summary

Represents method CBMissingAsZeroClick(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure CBMissingAsZeroClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.CBRemoveColsClick(TObject) Method

Summary

Represents method CBRemoveColsClick(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure CBRemoveColsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.CBRemoveMissingClick(TObject) Method

Summary

Represents method CBRemoveMissingClick(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure CBRemoveMissingClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.CBRunningRowsClick(TObject) Method

Summary

Represents method CBRunningRowsClick(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure CBRunningRowsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.DownDimClick(TObject) Method

Summary

Represents method DownDimClick(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure DownDimClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.EBinsChange(TObject) Method

Summary

Represents method EBinsChange(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure EBinsChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Edit(TComponent,TSummary) Method

Summary

Represents method Edit(TComponent,TSummary).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const ASummary:TSummary):Boolean; static;

Parameters

AOwner
Type: TComponent

ASummary
Type: TSummary

Return Value

Type: Boolean

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.EFilterChange(TObject) Method

Summary

Represents method EFilterChange(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure EFilterChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.EGroupExpressionChange(TObject) Method

Summary

Represents method EGroupExpressionChange(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure EGroupExpressionChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.EGroupNameChange(TObject) Method

Summary

Represents method EGroupNameChange(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure EGroupNameChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.EHavingChange(TObject) Method

Summary

Represents method EHavingChange(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure EHavingChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.EHistFormatChange(TObject) Method

Summary

Represents method EHistFormatChange(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure EHistFormatChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.EHistoMaxChange(TObject) Method

Summary

Represents method EHistoMaxChange(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure EHistoMaxChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.EHistoMinChange(TObject) Method

Summary

Represents method EHistoMinChange(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure EHistoMinChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.EMeasureExpressionChange(TObject) Method

Summary

Represents method EMeasureExpressionChange(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure EMeasureExpressionChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.EMeasureNameChange(TObject) Method

Summary

Represents method EMeasureNameChange(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure EMeasureNameChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.LDimensionsClick(TObject) Method

Summary

Represents method LDimensionsClick(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure LDimensionsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.LDimensionsClickCheck(TObject) Method

Summary

Represents method LDimensionsClickCheck(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure LDimensionsClickCheck(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.LDimensionsDragDrop(TObject,TObject,Integer,Integer) Method

Summary

Represents method LDimensionsDragDrop(TObject,TObject,Integer,Integer).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure LDimensionsDragDrop(Sender, Source: TObject; X, Y: Integer);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.LMeasuresClick(TObject) Method

Summary

Represents method LMeasuresClick(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure LMeasuresClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.LMeasuresClickCheck(TObject) Method

Summary

Represents method LMeasuresClickCheck(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure LMeasuresClickCheck(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.LMeasuresDragDrop(TObject,TObject,Integer,Integer) Method

Summary

Represents method LMeasuresDragDrop(TObject,TObject,Integer,Integer).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure LMeasuresDragDrop(Sender, Source: TObject; X, Y: Integer);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.LMeasuresDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) Method

Summary

Represents method LMeasuresDragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure LMeasuresDragOver(Sender, Source: TObject; X, Y: Integer;
 State: TDragState; var Accept: Boolean);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

State
Type: TDragState

Accept
Type: Boolean

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.PageGroupsResize(TObject) Method

Summary

Represents method PageGroupsResize(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure PageGroupsResize(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.PageMeasuresResize(TObject) Method

Summary

Represents method PageMeasuresResize(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure PageMeasuresResize(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Refresh(TSummary) Method

Summary

Represents method Refresh(TSummary).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
public
 procedure Refresh(const ASummary:TSummary);

Parameters

ASummary
Type: TSummary

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.RGLayoutClick(TObject) Method

Summary

Represents method RGLayoutClick(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure RGLayoutClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.RGPercentageClick(TObject) Method

Summary

Represents method RGPercentageClick(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure RGPercentageClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.RGRunningClick(TObject) Method

Summary

Represents method RGRunningClick(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure RGRunningClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.UpDimClick(TObject) Method

Summary

Represents method UpDimClick(TObject).

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 procedure UpDimClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor Fields

Fields
Name | Description
BDown | Represents field BDown.
BOK | Represents field BOK.
BRemoveDim | Represents field BRemoveDim.
BRemoveMeasure | Represents field BRemoveMeasure.
BUp | Represents field BUp.
Button1 | Represents field Button1.
Button2 | Represents field Button2.
Button3 | Represents field Button3.
CBAggregate | Represents field CBAggregate.
CBAutoBins | Represents field CBAutoBins.
CBDatePart | Represents field CBDatePart.
CBHistogram | Represents field CBHistogram.
CBMaxAuto | Represents field CBMaxAuto.
CBMinAuto | Represents field CBMinAuto.
CBMissingAsZero | Represents field CBMissingAsZero.
CBRemoveCols | Represents field CBRemoveCols.
CBRemoveMissing | Represents field CBRemoveMissing.
CBRunningRows | Represents field CBRunningRows.
DownDim | Represents field DownDim.
EBins | Represents field EBins.
EFilter | Represents field EFilter.
EGroupExpression | Represents field EGroupExpression.
EGroupName | Represents field EGroupName.
EHaving | Represents field EHaving.
EHistFormat | Represents field EHistFormat.
EHistoMax | Represents field EHistoMax.
EHistoMin | Represents field EHistoMin.
EMeasureExpression | Represents field EMeasureExpression.
EMeasureName | Represents field EMeasureName.
GroupBox1 | Represents field GroupBox1.
Label1 | Represents field Label1.
Label10 | Represents field Label10.
Label11 | Represents field Label11.
Label12 | Represents field Label12.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
Label8 | Represents field Label8.
Label9 | Represents field Label9.
LabelMeasureKind | Represents field LabelMeasureKind.
LDimensions | Represents field LDimensions.
LFilter | Represents field LFilter.
LGroupError | Represents field LGroupError.
LHaving | Represents field LHaving.
LMeasureError | Represents field LMeasureError.
LMeasures | Represents field LMeasures.
OnRecalculate | Represents field OnRecalculate.
PageControl1 | Represents field PageControl1.
PageGroups | Represents field PageGroups.
PageMeasures | Represents field PageMeasures.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel9 | Represents field Panel9.
PanelButtons | Represents field PanelButtons.
PanelGroups | Represents field PanelGroups.
RGLayout | Represents field RGLayout.
RGPercentage | Represents field RGPercentage.
RGRunning | Represents field RGRunning.
TabCalc | Represents field TabCalc.
TabDimensions | Represents field TabDimensions.
TabFilter | Represents field TabFilter.
TabGroup | Represents field TabGroup.
TabGroupData | Represents field TabGroupData.
TabHistogram | Represents field TabHistogram.
TabMeasure | Represents field TabMeasure.
TabMeasureInfo | Represents field TabMeasureInfo.
TabMeasures | Represents field TabMeasures.
TabSheet2 | Represents field TabSheet2.
UDBins | Represents field UDBins.
UpDim | Represents field UpDim.
Top


TSummaryEditor.BDown Field

Summary

Represents field BDown.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 BDown: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.BOK Field

Summary

Represents field BOK.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 BOK: TButton;

Field Value

Type: TButton

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.BRemoveDim Field

Summary

Represents field BRemoveDim.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 BRemoveDim: TButton;

Field Value

Type: TButton

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.BRemoveMeasure Field

Summary

Represents field BRemoveMeasure.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 BRemoveMeasure: TButton;

Field Value

Type: TButton

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.BUp Field

Summary

Represents field BUp.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 BUp: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Button1 Field

Summary

Represents field Button1.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Button2 Field

Summary

Represents field Button2.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 Button2: TButton;

Field Value

Type: TButton

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Button3 Field

Summary

Represents field Button3.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 Button3: TButton;

Field Value

Type: TButton

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.CBAggregate Field

Summary

Represents field CBAggregate.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 CBAggregate: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.CBAutoBins Field

Summary

Represents field CBAutoBins.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 CBAutoBins: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.CBDatePart Field

Summary

Represents field CBDatePart.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 CBDatePart: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.CBHistogram Field

Summary

Represents field CBHistogram.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 CBHistogram: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.CBMaxAuto Field

Summary

Represents field CBMaxAuto.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 CBMaxAuto: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.CBMinAuto Field

Summary

Represents field CBMinAuto.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 CBMinAuto: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.CBMissingAsZero Field

Summary

Represents field CBMissingAsZero.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 CBMissingAsZero: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.CBRemoveCols Field

Summary

Represents field CBRemoveCols.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 CBRemoveCols: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.CBRemoveMissing Field

Summary

Represents field CBRemoveMissing.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 CBRemoveMissing: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.CBRunningRows Field

Summary

Represents field CBRunningRows.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 CBRunningRows: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.DownDim Field

Summary

Represents field DownDim.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 DownDim: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.EBins Field

Summary

Represents field EBins.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 EBins: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.EFilter Field

Summary

Represents field EFilter.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 EFilter: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.EGroupExpression Field

Summary

Represents field EGroupExpression.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 EGroupExpression: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.EGroupName Field

Summary

Represents field EGroupName.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 EGroupName: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.EHaving Field

Summary

Represents field EHaving.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 EHaving: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.EHistFormat Field

Summary

Represents field EHistFormat.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 EHistFormat: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.EHistoMax Field

Summary

Represents field EHistoMax.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 EHistoMax: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.EHistoMin Field

Summary

Represents field EHistoMin.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 EHistoMin: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.EMeasureExpression Field

Summary

Represents field EMeasureExpression.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 EMeasureExpression: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.EMeasureName Field

Summary

Represents field EMeasureName.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 EMeasureName: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.GroupBox1 Field

Summary

Represents field GroupBox1.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 GroupBox1: TGroupBox;

Field Value

Type: TGroupBox

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Label10 Field

Summary

Represents field Label10.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 Label10: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Label11 Field

Summary

Represents field Label11.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 Label11: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Label12 Field

Summary

Represents field Label12.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 Label12: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Label2 Field

Summary

Represents field Label2.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Label3 Field

Summary

Represents field Label3.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Label4 Field

Summary

Represents field Label4.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 Label4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Label5 Field

Summary

Represents field Label5.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 Label5: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Label6 Field

Summary

Represents field Label6.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 Label6: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Label7 Field

Summary

Represents field Label7.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 Label7: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Label8 Field

Summary

Represents field Label8.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 Label8: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Label9 Field

Summary

Represents field Label9.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 Label9: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.LabelMeasureKind Field

Summary

Represents field LabelMeasureKind.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 LabelMeasureKind: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.LDimensions Field

Summary

Represents field LDimensions.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 LDimensions: TCheckListBox;

Field Value

Type: TCheckListBox

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.LFilter Field

Summary

Represents field LFilter.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 LFilter: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.LGroupError Field

Summary

Represents field LGroupError.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 LGroupError: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.LHaving Field

Summary

Represents field LHaving.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 LHaving: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.LMeasureError Field

Summary

Represents field LMeasureError.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 LMeasureError: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.LMeasures Field

Summary

Represents field LMeasures.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 LMeasures: TCheckListBox;

Field Value

Type: TCheckListBox

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.OnRecalculate Field

Summary

Represents field OnRecalculate.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
public
 OnRecalculate : TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.PageControl1 Field

Summary

Represents field PageControl1.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 PageControl1: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.PageGroups Field

Summary

Represents field PageGroups.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 PageGroups: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.PageMeasures Field

Summary

Represents field PageMeasures.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 PageMeasures: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.Panel9 Field

Summary

Represents field Panel9.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 Panel9: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.PanelButtons Field

Summary

Represents field PanelButtons.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 PanelButtons: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.PanelGroups Field

Summary

Represents field PanelGroups.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 PanelGroups: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.RGLayout Field

Summary

Represents field RGLayout.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 RGLayout: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.RGPercentage Field

Summary

Represents field RGPercentage.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 RGPercentage: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.RGRunning Field

Summary

Represents field RGRunning.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 RGRunning: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.TabCalc Field

Summary

Represents field TabCalc.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 TabCalc: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.TabDimensions Field

Summary

Represents field TabDimensions.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 TabDimensions: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.TabFilter Field

Summary

Represents field TabFilter.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 TabFilter: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.TabGroup Field

Summary

Represents field TabGroup.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 TabGroup: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.TabGroupData Field

Summary

Represents field TabGroupData.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 TabGroupData: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.TabHistogram Field

Summary

Represents field TabHistogram.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 TabHistogram: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.TabMeasure Field

Summary

Represents field TabMeasure.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 TabMeasure: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.TabMeasureInfo Field

Summary

Represents field TabMeasureInfo.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 TabMeasureInfo: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.TabMeasures Field

Summary

Represents field TabMeasures.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 TabMeasures: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.TabSheet2 Field

Summary

Represents field TabSheet2.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 TabSheet2: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.UDBins Field

Summary

Represents field UDBins.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 UDBins: TUpDown;

Field Value

Type: TUpDown

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


TSummaryEditor.UpDim Field

Summary

Represents field UpDim.

Namespace: VCLBI.Editor.Summary
Syntax
Delphi
published
 UpDim: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TSummaryEditor
  • VCLBI.Editor.Summary


VCLBI.Editor.Template Namespace

Summary

Represents namespace VCLBI.Editor.Template.

Classes
Name | Description
TBITemplateAccess | Represents type TBITemplateAccess.
TBITreeAccess | Represents type TBITreeAccess.
TTemplateAccess | Represents type TTemplateAccess.
TTemplateEditor | Represents type TTemplateEditor.
Top
Constants
Name | Description
BIMsg_Dashboards | Represents constant BIMsg_Dashboards.
BIMsg_Data | Represents constant BIMsg_Data.
BIMsg_Name | Represents constant BIMsg_Name.
BIMsg_Panels | Represents constant BIMsg_Panels.
BIMsg_Rename | Represents constant BIMsg_Rename.
Top
Routines
Name | Description
AskName(String,String) | Represents method AskName(String,String).
DashboardFrom(TObject) | Represents method DashboardFrom(TObject).
Top


VCLBI.Editor.Template Classes

Classes
Name | Description
TBITemplateAccess | Represents type TBITemplateAccess.
TBITreeAccess | Represents type TBITreeAccess.
TTemplateAccess | Represents type TTemplateAccess.
TTemplateEditor | Represents type TTemplateEditor.
Top


TBITemplateAccess Class

Summary

Represents type TBITemplateAccess.

Namespace: VCLBI.Editor.Template
Inheritance Hierarchy
TComponent
BI.Dashboard.TBITemplate
VCLBI.Editor.Template.TBITemplateAccess
Syntax
Delphi
type
 TBITemplateAccess=class(TBITemplate);
See Also

Reference

  • VCLBI.Editor.Template


TBITreeAccess Class

Summary

Represents type TBITreeAccess.

Namespace: VCLBI.Editor.Template
Inheritance Hierarchy
TWinControl
VCLBI.DataControl.TBIDataControl
VCLBI.Tree.TBITree
VCLBI.Editor.Template.TBITreeAccess
Syntax
Delphi
type
 TBITreeAccess=class(TBITree);
See Also

Reference

  • VCLBI.Editor.Template


TTemplateAccess Class

Summary

Represents type TTemplateAccess.

Namespace: VCLBI.Editor.Template
Inheritance Hierarchy
TComponent
BI.Dashboard.TBITemplate
VCLBI.Editor.Template.TTemplateAccess
Syntax
Delphi
type
 TTemplateAccess=class(TBITemplate);
See Also

Reference

  • VCLBI.Editor.Template


TTemplateEditor Class

Summary

Represents type TTemplateEditor.

Namespace: VCLBI.Editor.Template
Inheritance Hierarchy
TForm
VCLBI.Editor.Template.TTemplateEditor
Syntax
Delphi
type
 TTemplateEditor = class(TForm)
 end;

The TTemplateEditor type exposes the following members.

Methods
Show:
Name | Description
AddItem1Click(TObject) | Represents method AddItem1Click(TObject).
BAddClick(TObject) | Represents method BAddClick(TObject).
BChangeClick(TObject) | Represents method BChangeClick(TObject).
BDeleteClick(TObject) | Represents method BDeleteClick(TObject).
BEditProviderClick(TObject) | Represents method BEditProviderClick(TObject).
BITree1Change(TObject) | Represents method BITree1Change(TObject).
BIWebServer1Click(TObject) | Represents method BIWebServer1Click(TObject).
BSelectLayoutClick(TObject) | Represents method BSelectLayoutClick(TObject).
CBAutoPositionClick(TObject) | Represents method CBAutoPositionClick(TObject).
CBDataKindChange(TObject) | Represents method CBDataKindChange(TObject).
CBItemKindChange(TObject) | Represents method CBItemKindChange(TObject).
CBPanelDataChange(TObject) | Represents method CBPanelDataChange(TObject).
CBPanelKindChange(TObject) | Represents method CBPanelKindChange(TObject).
CBPanelsChange(TObject) | Represents method CBPanelsChange(TObject).
CBPositionChange(TObject) | Represents method CBPositionChange(TObject).
CBSplittersClick(TObject) | Represents method CBSplittersClick(TObject).
CBTitlesClick(TObject) | Represents method CBTitlesClick(TObject).
Data1Click(TObject) | Represents method Data1Click(TObject).
DatabaseServer1Click(TObject) | Represents method DatabaseServer1Click(TObject).
Edit(TComponent,TBITemplate) | Represents method Edit(TComponent,TBITemplate).
Files1Click(TObject) | Represents method Files1Click(TObject).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
PopupItemPopup(TObject) | Represents method PopupItemPopup(TObject).
Query1Click(TObject) | Represents method Query1Click(TObject).
Refresh(TBITemplate) | Represents method Refresh(TBITemplate).
RemoveItem1Click(TObject) | Represents method RemoveItem1Click(TObject).
Rename1Click(TObject) | Represents method Rename1Click(TObject).
Top
Fields
Show:
Name | Description
AddItem1 | Represents field AddItem1.
BAdd | Represents field BAdd.
BChange | Represents field BChange.
BDelete | Represents field BDelete.
BEditProvider | Represents field BEditProvider.
BIGrid1 | Represents field BIGrid1.
BITree1 | Represents field BITree1.
BIVisual1 | Represents field BIVisual1.
BIWebServer1 | Represents field BIWebServer1.
BSelectLayout | Represents field BSelectLayout.
CBAutoPosition | Represents field CBAutoPosition.
CBHeightUnits | Represents field CBHeightUnits.
CBItemKind | Represents field CBItemKind.
CBPanelData | Represents field CBPanelData.
CBPanelKind | Represents field CBPanelKind.
CBPanels | Represents field CBPanels.
CBPosition | Represents field CBPosition.
CBSplitters | Represents field CBSplitters.
CBTitles | Represents field CBTitles.
CBWidthUnits | Represents field CBWidthUnits.
Data1 | Represents field Data1.
DatabaseServer1 | Represents field DatabaseServer1.
EHeight | Represents field EHeight.
EWidth | Represents field EWidth.
Files1 | Represents field Files1.
Import1 | Represents field Import1.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
Label8 | Represents field Label8.
LData | Represents field LData.
LLayout | Represents field LLayout.
LRealKind | Represents field LRealKind.
MemoJSON | Represents field MemoJSON.
PageControl1 | Represents field PageControl1.
PageControl2 | Represents field PageControl2.
PageProperties | Represents field PageProperties.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
PopupData | Represents field PopupData.
PopupItem | Represents field PopupItem.
Query1 | Represents field Query1.
RemoveItem1 | Represents field RemoveItem1.
Rename1 | Represents field Rename1.
Splitter1 | Represents field Splitter1.
Splitter2 | Represents field Splitter2.
TabDashboard | Represents field TabDashboard.
TabData | Represents field TabData.
TabItem | Represents field TabItem.
TabItemOptions | Represents field TabItemOptions.
TabItemSize | Represents field TabItemSize.
TabPanel | Represents field TabPanel.
TabPreview | Represents field TabPreview.
TabTemplate | Represents field TabTemplate.
Top
See Also

Reference

  • VCLBI.Editor.Template


TTemplateEditor Methods

Methods
Name | Description
AddItem1Click(TObject) | Represents method AddItem1Click(TObject).
BAddClick(TObject) | Represents method BAddClick(TObject).
BChangeClick(TObject) | Represents method BChangeClick(TObject).
BDeleteClick(TObject) | Represents method BDeleteClick(TObject).
BEditProviderClick(TObject) | Represents method BEditProviderClick(TObject).
BITree1Change(TObject) | Represents method BITree1Change(TObject).
BIWebServer1Click(TObject) | Represents method BIWebServer1Click(TObject).
BSelectLayoutClick(TObject) | Represents method BSelectLayoutClick(TObject).
CBAutoPositionClick(TObject) | Represents method CBAutoPositionClick(TObject).
CBDataKindChange(TObject) | Represents method CBDataKindChange(TObject).
CBItemKindChange(TObject) | Represents method CBItemKindChange(TObject).
CBPanelDataChange(TObject) | Represents method CBPanelDataChange(TObject).
CBPanelKindChange(TObject) | Represents method CBPanelKindChange(TObject).
CBPanelsChange(TObject) | Represents method CBPanelsChange(TObject).
CBPositionChange(TObject) | Represents method CBPositionChange(TObject).
CBSplittersClick(TObject) | Represents method CBSplittersClick(TObject).
CBTitlesClick(TObject) | Represents method CBTitlesClick(TObject).
Data1Click(TObject) | Represents method Data1Click(TObject).
DatabaseServer1Click(TObject) | Represents method DatabaseServer1Click(TObject).
Edit(TComponent,TBITemplate) | Represents method Edit(TComponent,TBITemplate).
Files1Click(TObject) | Represents method Files1Click(TObject).
FormClose(TObject,TCloseAction) | Represents method FormClose(TObject,TCloseAction).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
PopupItemPopup(TObject) | Represents method PopupItemPopup(TObject).
Query1Click(TObject) | Represents method Query1Click(TObject).
Refresh(TBITemplate) | Represents method Refresh(TBITemplate).
RemoveItem1Click(TObject) | Represents method RemoveItem1Click(TObject).
Rename1Click(TObject) | Represents method Rename1Click(TObject).
Top


TTemplateEditor.AddItem1Click(TObject) Method

Summary

Represents method AddItem1Click(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure AddItem1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.BAddClick(TObject) Method

Summary

Represents method BAddClick(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure BAddClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.BChangeClick(TObject) Method

Summary

Represents method BChangeClick(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure BChangeClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.BDeleteClick(TObject) Method

Summary

Represents method BDeleteClick(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure BDeleteClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.BEditProviderClick(TObject) Method

Summary

Represents method BEditProviderClick(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure BEditProviderClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.BITree1Change(TObject) Method

Summary

Represents method BITree1Change(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure BITree1Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.BIWebServer1Click(TObject) Method

Summary

Represents method BIWebServer1Click(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure BIWebServer1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.BSelectLayoutClick(TObject) Method

Summary

Represents method BSelectLayoutClick(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure BSelectLayoutClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.CBAutoPositionClick(TObject) Method

Summary

Represents method CBAutoPositionClick(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure CBAutoPositionClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.CBDataKindChange(TObject) Method

Summary

Represents method CBDataKindChange(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure CBDataKindChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.CBItemKindChange(TObject) Method

Summary

Represents method CBItemKindChange(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure CBItemKindChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.CBPanelDataChange(TObject) Method

Summary

Represents method CBPanelDataChange(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure CBPanelDataChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.CBPanelKindChange(TObject) Method

Summary

Represents method CBPanelKindChange(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure CBPanelKindChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.CBPanelsChange(TObject) Method

Summary

Represents method CBPanelsChange(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure CBPanelsChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.CBPositionChange(TObject) Method

Summary

Represents method CBPositionChange(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure CBPositionChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.CBSplittersClick(TObject) Method

Summary

Represents method CBSplittersClick(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure CBSplittersClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.CBTitlesClick(TObject) Method

Summary

Represents method CBTitlesClick(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure CBTitlesClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Data1Click(TObject) Method

Summary

Represents method Data1Click(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure Data1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.DatabaseServer1Click(TObject) Method

Summary

Represents method DatabaseServer1Click(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure DatabaseServer1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Edit(TComponent,TBITemplate) Method

Summary

Represents method Edit(TComponent,TBITemplate).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const ATemplate:TBITemplate):Boolean; static;

Parameters

AOwner
Type: TComponent

ATemplate
Type: TBITemplate

Return Value

Type: Boolean

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Files1Click(TObject) Method

Summary

Represents method Files1Click(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure Files1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.FormClose(TObject,TCloseAction) Method

Summary

Represents method FormClose(TObject,TCloseAction).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure FormClose(Sender: TObject; var Action: TCloseAction);

Parameters

Sender
Type: TObject

Action
Type: TCloseAction

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.PageControl1Change(TObject) Method

Summary

Represents method PageControl1Change(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure PageControl1Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.PopupItemPopup(TObject) Method

Summary

Represents method PopupItemPopup(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure PopupItemPopup(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Query1Click(TObject) Method

Summary

Represents method Query1Click(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure Query1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Refresh(TBITemplate) Method

Summary

Represents method Refresh(TBITemplate).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
public
 procedure Refresh(const ATemplate:TBITemplate);

Parameters

ATemplate
Type: TBITemplate

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.RemoveItem1Click(TObject) Method

Summary

Represents method RemoveItem1Click(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure RemoveItem1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Rename1Click(TObject) Method

Summary

Represents method Rename1Click(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 procedure Rename1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor Fields

Fields
Name | Description
AddItem1 | Represents field AddItem1.
BAdd | Represents field BAdd.
BChange | Represents field BChange.
BDelete | Represents field BDelete.
BEditProvider | Represents field BEditProvider.
BIGrid1 | Represents field BIGrid1.
BITree1 | Represents field BITree1.
BIVisual1 | Represents field BIVisual1.
BIWebServer1 | Represents field BIWebServer1.
BSelectLayout | Represents field BSelectLayout.
CBAutoPosition | Represents field CBAutoPosition.
CBHeightUnits | Represents field CBHeightUnits.
CBItemKind | Represents field CBItemKind.
CBPanelData | Represents field CBPanelData.
CBPanelKind | Represents field CBPanelKind.
CBPanels | Represents field CBPanels.
CBPosition | Represents field CBPosition.
CBSplitters | Represents field CBSplitters.
CBTitles | Represents field CBTitles.
CBWidthUnits | Represents field CBWidthUnits.
Data1 | Represents field Data1.
DatabaseServer1 | Represents field DatabaseServer1.
EHeight | Represents field EHeight.
EWidth | Represents field EWidth.
Files1 | Represents field Files1.
Import1 | Represents field Import1.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
Label3 | Represents field Label3.
Label4 | Represents field Label4.
Label5 | Represents field Label5.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
Label8 | Represents field Label8.
LData | Represents field LData.
LLayout | Represents field LLayout.
LRealKind | Represents field LRealKind.
MemoJSON | Represents field MemoJSON.
PageControl1 | Represents field PageControl1.
PageControl2 | Represents field PageControl2.
PageProperties | Represents field PageProperties.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
PopupData | Represents field PopupData.
PopupItem | Represents field PopupItem.
Query1 | Represents field Query1.
RemoveItem1 | Represents field RemoveItem1.
Rename1 | Represents field Rename1.
Splitter1 | Represents field Splitter1.
Splitter2 | Represents field Splitter2.
TabDashboard | Represents field TabDashboard.
TabData | Represents field TabData.
TabItem | Represents field TabItem.
TabItemOptions | Represents field TabItemOptions.
TabItemSize | Represents field TabItemSize.
TabPanel | Represents field TabPanel.
TabPreview | Represents field TabPreview.
TabTemplate | Represents field TabTemplate.
Top


TTemplateEditor.AddItem1 Field

Summary

Represents field AddItem1.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 AddItem1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.BAdd Field

Summary

Represents field BAdd.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 BAdd: TButton;

Field Value

Type: TButton

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.BChange Field

Summary

Represents field BChange.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 BChange: TButton;

Field Value

Type: TButton

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.BDelete Field

Summary

Represents field BDelete.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 BDelete: TButton;

Field Value

Type: TButton

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.BEditProvider Field

Summary

Represents field BEditProvider.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 BEditProvider: TButton;

Field Value

Type: TButton

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.BIGrid1 Field

Summary

Represents field BIGrid1.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 BIGrid1: TBIGrid;

Field Value

Type: TBIGrid

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.BITree1 Field

Summary

Represents field BITree1.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 BITree1: TBITree;

Field Value

Type: TBITree

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.BIVisual1 Field

Summary

Represents field BIVisual1.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 BIVisual1: TBIVisual;

Field Value

Type: TBIVisual

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.BIWebServer1 Field

Summary

Represents field BIWebServer1.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 BIWebServer1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.BSelectLayout Field

Summary

Represents field BSelectLayout.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 BSelectLayout: TButton;

Field Value

Type: TButton

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.CBAutoPosition Field

Summary

Represents field CBAutoPosition.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 CBAutoPosition: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.CBHeightUnits Field

Summary

Represents field CBHeightUnits.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 CBHeightUnits: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.CBItemKind Field

Summary

Represents field CBItemKind.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 CBItemKind: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.CBPanelData Field

Summary

Represents field CBPanelData.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 CBPanelData: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.CBPanelKind Field

Summary

Represents field CBPanelKind.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 CBPanelKind: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.CBPanels Field

Summary

Represents field CBPanels.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 CBPanels: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.CBPosition Field

Summary

Represents field CBPosition.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 CBPosition: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.CBSplitters Field

Summary

Represents field CBSplitters.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 CBSplitters: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.CBTitles Field

Summary

Represents field CBTitles.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 CBTitles: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.CBWidthUnits Field

Summary

Represents field CBWidthUnits.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 CBWidthUnits: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Data1 Field

Summary

Represents field Data1.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 Data1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.DatabaseServer1 Field

Summary

Represents field DatabaseServer1.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 DatabaseServer1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.EHeight Field

Summary

Represents field EHeight.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 EHeight: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.EWidth Field

Summary

Represents field EWidth.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 EWidth: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Files1 Field

Summary

Represents field Files1.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 Files1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Import1 Field

Summary

Represents field Import1.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 Import1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Label2 Field

Summary

Represents field Label2.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Label3 Field

Summary

Represents field Label3.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Label4 Field

Summary

Represents field Label4.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 Label4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Label5 Field

Summary

Represents field Label5.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 Label5: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Label6 Field

Summary

Represents field Label6.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 Label6: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Label7 Field

Summary

Represents field Label7.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 Label7: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Label8 Field

Summary

Represents field Label8.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 Label8: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.LData Field

Summary

Represents field LData.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 LData: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.LLayout Field

Summary

Represents field LLayout.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 LLayout: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.LRealKind Field

Summary

Represents field LRealKind.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 LRealKind: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.MemoJSON Field

Summary

Represents field MemoJSON.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 MemoJSON: TMemo;

Field Value

Type: TMemo

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.PageControl1 Field

Summary

Represents field PageControl1.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 PageControl1: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.PageControl2 Field

Summary

Represents field PageControl2.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 PageControl2: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.PageProperties Field

Summary

Represents field PageProperties.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 PageProperties: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.PopupData Field

Summary

Represents field PopupData.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 PopupData: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.PopupItem Field

Summary

Represents field PopupItem.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 PopupItem: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Query1 Field

Summary

Represents field Query1.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 Query1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.RemoveItem1 Field

Summary

Represents field RemoveItem1.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 RemoveItem1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Rename1 Field

Summary

Represents field Rename1.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 Rename1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Splitter1 Field

Summary

Represents field Splitter1.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 Splitter1: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.Splitter2 Field

Summary

Represents field Splitter2.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 Splitter2: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.TabDashboard Field

Summary

Represents field TabDashboard.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 TabDashboard: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.TabData Field

Summary

Represents field TabData.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 TabData: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.TabItem Field

Summary

Represents field TabItem.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 TabItem: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.TabItemOptions Field

Summary

Represents field TabItemOptions.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 TabItemOptions: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.TabItemSize Field

Summary

Represents field TabItemSize.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 TabItemSize: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.TabPanel Field

Summary

Represents field TabPanel.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 TabPanel: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.TabPreview Field

Summary

Represents field TabPreview.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 TabPreview: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


TTemplateEditor.TabTemplate Field

Summary

Represents field TabTemplate.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
published
 TabTemplate: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TTemplateEditor
  • VCLBI.Editor.Template


VCLBI.Editor.Template Constants

Constants
Name | Description
BIMsg_Dashboards | Represents constant BIMsg_Dashboards.
BIMsg_Data | Represents constant BIMsg_Data.
BIMsg_Name | Represents constant BIMsg_Name.
BIMsg_Panels | Represents constant BIMsg_Panels.
BIMsg_Rename | Represents constant BIMsg_Rename.
Top


BIMsg_Dashboards Constant

Summary

Represents constant BIMsg_Dashboards.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
 BIMsg_Dashboards='Dashboards';

Value

Type: string

See Also

Reference

  • VCLBI.Editor.Template


BIMsg_Data Constant

Summary

Represents constant BIMsg_Data.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
 BIMsg_Data='Data';

Value

Type: string

See Also

Reference

  • VCLBI.Editor.Template


BIMsg_Name Constant

Summary

Represents constant BIMsg_Name.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
 BIMsg_Name='Name';

Value

Type: string

See Also

Reference

  • VCLBI.Editor.Template


BIMsg_Panels Constant

Summary

Represents constant BIMsg_Panels.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
 BIMsg_Panels='Panels';

Value

Type: string

See Also

Reference

  • VCLBI.Editor.Template


BIMsg_Rename Constant

Summary

Represents constant BIMsg_Rename.

Namespace: VCLBI.Editor.Template
Syntax
Delphi
 BIMsg_Rename='Rename';

Value

Type: string

See Also

Reference

  • VCLBI.Editor.Template


VCLBI.Editor.Template Routines

Routines
Name | Description
AskName(String,String) | Represents method AskName(String,String).
DashboardFrom(TObject) | Represents method DashboardFrom(TObject).
Top


AskName(String,String) Method

Summary

Represents method AskName(String,String).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
function AskName(const AOld:String; out ANew:String):Boolean;

Parameters

AOld
Type: String

ANew
Type: String

Return Value

Type: Boolean

See Also

Reference

  • VCLBI.Editor.Template


DashboardFrom(TObject) Method

Summary

Represents method DashboardFrom(TObject).

Namespace: VCLBI.Editor.Template
Syntax
Delphi
function DashboardFrom(const AObject:TObject):TDashboard;

Parameters

AObject
Type: TObject

Return Value

Type: TDashboard

See Also

Reference

  • VCLBI.Editor.Template


VCLBI.Editor.Template.Data Namespace

Summary

Represents namespace VCLBI.Editor.Template.Data.

Classes
Name | Description
TDataGallery | Represents type TDataGallery.
Top


VCLBI.Editor.Template.Data Classes

Classes
Name | Description
TDataGallery | Represents type TDataGallery.
Top


TDataGallery Class

Summary

Represents type TDataGallery.

Namespace: VCLBI.Editor.Template.Data
Inheritance Hierarchy
TForm
VCLBI.Editor.Template.Data.TDataGallery
Syntax
Delphi
type
 TDataGallery = class(TForm)
 end;

The TDataGallery type exposes the following members.

Methods
Show:
Name | Description
AddData(TStrings,TVisualDataItems) | Represents method AddData(TStrings,TVisualDataItems).
Choose(TComponent,TVisualDataItems,TVisualData) | Represents method Choose(TComponent,TVisualDataItems,TVisualData).
Current | Represents method Current.
LBDataClick(TObject) | Represents method LBDataClick(TObject).
Refresh(TVisualDataItems) | Represents method Refresh(TVisualDataItems).
Top
Fields
Show:
Name | Description
BCancel | Represents field BCancel.
BIGrid1 | Represents field BIGrid1.
BOK | Represents field BOK.
LBData | Represents field LBData.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Splitter1 | Represents field Splitter1.
Top
See Also

Reference

  • VCLBI.Editor.Template.Data


TDataGallery Methods

Methods
Name | Description
AddData(TStrings,TVisualDataItems) | Represents method AddData(TStrings,TVisualDataItems).
Choose(TComponent,TVisualDataItems,TVisualData) | Represents method Choose(TComponent,TVisualDataItems,TVisualData).
Current | Represents method Current.
LBDataClick(TObject) | Represents method LBDataClick(TObject).
Refresh(TVisualDataItems) | Represents method Refresh(TVisualDataItems).
Top


TDataGallery.AddData(TStrings,TVisualDataItems) Method

Summary

Represents method AddData(TStrings,TVisualDataItems).

Namespace: VCLBI.Editor.Template.Data
Syntax
Delphi
public
 class procedure AddData(const AItems:TStrings; const AData:TVisualDataItems); static;

Parameters

AItems
Type: TStrings

AData
Type: TVisualDataItems

See Also

Reference

  • TDataGallery
  • VCLBI.Editor.Template.Data


TDataGallery.Choose(TComponent,TVisualDataItems,TVisualData) Method

Summary

Represents method Choose(TComponent,TVisualDataItems,TVisualData).

Namespace: VCLBI.Editor.Template.Data
Syntax
Delphi
public
 class function Choose(const AOwner:TComponent;
 const ADataItems:TVisualDataItems;
 out AData:TVisualData):Boolean; static;

Parameters

AOwner
Type: TComponent

ADataItems
Type: TVisualDataItems

AData
Type: TVisualData

Return Value

Type: Boolean

See Also

Reference

  • TDataGallery
  • VCLBI.Editor.Template.Data


TDataGallery.Current Method

Summary

Represents method Current.

Namespace: VCLBI.Editor.Template.Data
Syntax
Delphi
public
 function Current:TVisualData;

Return Value

Type: TVisualData

See Also

Reference

  • TDataGallery
  • VCLBI.Editor.Template.Data


TDataGallery.LBDataClick(TObject) Method

Summary

Represents method LBDataClick(TObject).

Namespace: VCLBI.Editor.Template.Data
Syntax
Delphi
published
 procedure LBDataClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataGallery
  • VCLBI.Editor.Template.Data


TDataGallery.Refresh(TVisualDataItems) Method

Summary

Represents method Refresh(TVisualDataItems).

Namespace: VCLBI.Editor.Template.Data
Syntax
Delphi
public
 procedure Refresh(const ADataItems:TVisualDataItems);

Parameters

ADataItems
Type: TVisualDataItems

See Also

Reference

  • TDataGallery
  • VCLBI.Editor.Template.Data


TDataGallery Fields

Fields
Name | Description
BCancel | Represents field BCancel.
BIGrid1 | Represents field BIGrid1.
BOK | Represents field BOK.
LBData | Represents field LBData.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Splitter1 | Represents field Splitter1.
Top


TDataGallery.BCancel Field

Summary

Represents field BCancel.

Namespace: VCLBI.Editor.Template.Data
Syntax
Delphi
published
 BCancel: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataGallery
  • VCLBI.Editor.Template.Data


TDataGallery.BIGrid1 Field

Summary

Represents field BIGrid1.

Namespace: VCLBI.Editor.Template.Data
Syntax
Delphi
published
 BIGrid1: TBIGrid;

Field Value

Type: TBIGrid

See Also

Reference

  • TDataGallery
  • VCLBI.Editor.Template.Data


TDataGallery.BOK Field

Summary

Represents field BOK.

Namespace: VCLBI.Editor.Template.Data
Syntax
Delphi
published
 BOK: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataGallery
  • VCLBI.Editor.Template.Data


TDataGallery.LBData Field

Summary

Represents field LBData.

Namespace: VCLBI.Editor.Template.Data
Syntax
Delphi
published
 LBData: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TDataGallery
  • VCLBI.Editor.Template.Data


TDataGallery.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Editor.Template.Data
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataGallery
  • VCLBI.Editor.Template.Data


TDataGallery.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.Editor.Template.Data
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataGallery
  • VCLBI.Editor.Template.Data


TDataGallery.Splitter1 Field

Summary

Represents field Splitter1.

Namespace: VCLBI.Editor.Template.Data
Syntax
Delphi
published
 Splitter1: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TDataGallery
  • VCLBI.Editor.Template.Data


VCLBI.Editor.Template.Layouts Namespace

Summary

Represents namespace VCLBI.Editor.Template.Layouts.

Classes
Name | Description
TLayoutGallery | Represents type TLayoutGallery.
Top


VCLBI.Editor.Template.Layouts Classes

Classes
Name | Description
TLayoutGallery | Represents type TLayoutGallery.
Top


TLayoutGallery Class

Summary

Represents type TLayoutGallery.

Namespace: VCLBI.Editor.Template.Layouts
Inheritance Hierarchy
TForm
VCLBI.Editor.Template.Layouts.TLayoutGallery
Syntax
Delphi
type
 TLayoutGallery = class(TForm)
 end;

The TLayoutGallery type exposes the following members.

Methods
Show:
Name | Description
Button1Click(TObject) | Represents method Button1Click(TObject).
CBCurrentClick(TObject) | Represents method CBCurrentClick(TObject).
Choose(TComponent,String,TLayoutItem) | Represents method Choose(TComponent,String,TLayoutItem).
FormShow(TObject) | Represents method FormShow(TObject).
LBLayoutsClick(TObject) | Represents method LBLayoutsClick(TObject).
Top
Fields
Show:
Name | Description
BCancel | Represents field BCancel.
BIVisual1 | Represents field BIVisual1.
BOK | Represents field BOK.
Button1 | Represents field Button1.
CBCurrent | Represents field CBCurrent.
LBLayouts | Represents field LBLayouts.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
Splitter1 | Represents field Splitter1.
Top
See Also

Reference

  • VCLBI.Editor.Template.Layouts


TLayoutGallery Methods

Methods
Name | Description
Button1Click(TObject) | Represents method Button1Click(TObject).
CBCurrentClick(TObject) | Represents method CBCurrentClick(TObject).
Choose(TComponent,String,TLayoutItem) | Represents method Choose(TComponent,String,TLayoutItem).
FormShow(TObject) | Represents method FormShow(TObject).
LBLayoutsClick(TObject) | Represents method LBLayoutsClick(TObject).
Top


TLayoutGallery.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: VCLBI.Editor.Template.Layouts
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TLayoutGallery
  • VCLBI.Editor.Template.Layouts


TLayoutGallery.CBCurrentClick(TObject) Method

Summary

Represents method CBCurrentClick(TObject).

Namespace: VCLBI.Editor.Template.Layouts
Syntax
Delphi
published
 procedure CBCurrentClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TLayoutGallery
  • VCLBI.Editor.Template.Layouts


TLayoutGallery.Choose(TComponent,String,TLayoutItem) Method

Summary

Represents method Choose(TComponent,String,TLayoutItem).

Namespace: VCLBI.Editor.Template.Layouts
Syntax
Delphi
public
 class function Choose(const AOwner:TComponent;
 out ALayout:String;
 const ACurrent:TLayoutItem):Boolean; static;

Parameters

AOwner
Type: TComponent

ALayout
Type: String

ACurrent
Type: TLayoutItem

Return Value

Type: Boolean

See Also

Reference

  • TLayoutGallery
  • VCLBI.Editor.Template.Layouts


TLayoutGallery.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Editor.Template.Layouts
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TLayoutGallery
  • VCLBI.Editor.Template.Layouts


TLayoutGallery.LBLayoutsClick(TObject) Method

Summary

Represents method LBLayoutsClick(TObject).

Namespace: VCLBI.Editor.Template.Layouts
Syntax
Delphi
published
 procedure LBLayoutsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TLayoutGallery
  • VCLBI.Editor.Template.Layouts


TLayoutGallery Fields

Fields
Name | Description
BCancel | Represents field BCancel.
BIVisual1 | Represents field BIVisual1.
BOK | Represents field BOK.
Button1 | Represents field Button1.
CBCurrent | Represents field CBCurrent.
LBLayouts | Represents field LBLayouts.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
Splitter1 | Represents field Splitter1.
Top


TLayoutGallery.BCancel Field

Summary

Represents field BCancel.

Namespace: VCLBI.Editor.Template.Layouts
Syntax
Delphi
published
 BCancel: TButton;

Field Value

Type: TButton

See Also

Reference

  • TLayoutGallery
  • VCLBI.Editor.Template.Layouts


TLayoutGallery.BIVisual1 Field

Summary

Represents field BIVisual1.

Namespace: VCLBI.Editor.Template.Layouts
Syntax
Delphi
published
 BIVisual1: TBIVisual;

Field Value

Type: TBIVisual

See Also

Reference

  • TLayoutGallery
  • VCLBI.Editor.Template.Layouts


TLayoutGallery.BOK Field

Summary

Represents field BOK.

Namespace: VCLBI.Editor.Template.Layouts
Syntax
Delphi
published
 BOK: TButton;

Field Value

Type: TButton

See Also

Reference

  • TLayoutGallery
  • VCLBI.Editor.Template.Layouts


TLayoutGallery.Button1 Field

Summary

Represents field Button1.

Namespace: VCLBI.Editor.Template.Layouts
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TLayoutGallery
  • VCLBI.Editor.Template.Layouts


TLayoutGallery.CBCurrent Field

Summary

Represents field CBCurrent.

Namespace: VCLBI.Editor.Template.Layouts
Syntax
Delphi
published
 CBCurrent: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TLayoutGallery
  • VCLBI.Editor.Template.Layouts


TLayoutGallery.LBLayouts Field

Summary

Represents field LBLayouts.

Namespace: VCLBI.Editor.Template.Layouts
Syntax
Delphi
published
 LBLayouts: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TLayoutGallery
  • VCLBI.Editor.Template.Layouts


TLayoutGallery.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Editor.Template.Layouts
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TLayoutGallery
  • VCLBI.Editor.Template.Layouts


TLayoutGallery.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.Editor.Template.Layouts
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TLayoutGallery
  • VCLBI.Editor.Template.Layouts


TLayoutGallery.Panel3 Field

Summary

Represents field Panel3.

Namespace: VCLBI.Editor.Template.Layouts
Syntax
Delphi
published
 Panel3: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TLayoutGallery
  • VCLBI.Editor.Template.Layouts


TLayoutGallery.Panel4 Field

Summary

Represents field Panel4.

Namespace: VCLBI.Editor.Template.Layouts
Syntax
Delphi
published
 Panel4: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TLayoutGallery
  • VCLBI.Editor.Template.Layouts


TLayoutGallery.Splitter1 Field

Summary

Represents field Splitter1.

Namespace: VCLBI.Editor.Template.Layouts
Syntax
Delphi
published
 Splitter1: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TLayoutGallery
  • VCLBI.Editor.Template.Layouts


VCLBI.Editor.Template.Panels Namespace

Summary

Represents namespace VCLBI.Editor.Template.Panels.

Classes
Name | Description
TPanelGallery | Represents type TPanelGallery.
Top


VCLBI.Editor.Template.Panels Classes

Classes
Name | Description
TPanelGallery | Represents type TPanelGallery.
Top


TPanelGallery Class

Summary

Represents type TPanelGallery.

Namespace: VCLBI.Editor.Template.Panels
Inheritance Hierarchy
TForm
VCLBI.Editor.Template.Panels.TPanelGallery
Syntax
Delphi
type
 TPanelGallery = class(TForm)
 end;

The TPanelGallery type exposes the following members.

Methods
Show:
Name | Description
AddPanels(TStrings,TPanels) | Represents method AddPanels(TStrings,TPanels).
Choose(TComponent,TPanels,TBIPanel) | Represents method Choose(TComponent,TPanels,TBIPanel).
Current | Represents method Current.
LBPanelsClick(TObject) | Represents method LBPanelsClick(TObject).
Refresh(TPanels) | Represents method Refresh(TPanels).
Top
Fields
Show:
Name | Description
BCancel | Represents field BCancel.
BIVisual1 | Represents field BIVisual1.
BOK | Represents field BOK.
LBPanels | Represents field LBPanels.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Splitter1 | Represents field Splitter1.
Top
See Also

Reference

  • VCLBI.Editor.Template.Panels


TPanelGallery Methods

Methods
Name | Description
AddPanels(TStrings,TPanels) | Represents method AddPanels(TStrings,TPanels).
Choose(TComponent,TPanels,TBIPanel) | Represents method Choose(TComponent,TPanels,TBIPanel).
Current | Represents method Current.
LBPanelsClick(TObject) | Represents method LBPanelsClick(TObject).
Refresh(TPanels) | Represents method Refresh(TPanels).
Top


TPanelGallery.AddPanels(TStrings,TPanels) Method

Summary

Represents method AddPanels(TStrings,TPanels).

Namespace: VCLBI.Editor.Template.Panels
Syntax
Delphi
public
 class procedure AddPanels(const AItems:TStrings; const APanels:TPanels); static;

Parameters

AItems
Type: TStrings

APanels
Type: TPanels

See Also

Reference

  • TPanelGallery
  • VCLBI.Editor.Template.Panels


TPanelGallery.Choose(TComponent,TPanels,TBIPanel) Method

Summary

Represents method Choose(TComponent,TPanels,TBIPanel).

Namespace: VCLBI.Editor.Template.Panels
Syntax
Delphi
public
 class function Choose(const AOwner:TComponent;
 const APanels:TPanels;
 out APanel:TBIPanel):Boolean; static;

Parameters

AOwner
Type: TComponent

APanels
Type: TPanels

APanel
Type: TBIPanel

Return Value

Type: Boolean

See Also

Reference

  • TPanelGallery
  • VCLBI.Editor.Template.Panels


TPanelGallery.Current Method

Summary

Represents method Current.

Namespace: VCLBI.Editor.Template.Panels
Syntax
Delphi
public
 function Current:TBIPanel;

Return Value

Type: TBIPanel

See Also

Reference

  • TPanelGallery
  • VCLBI.Editor.Template.Panels


TPanelGallery.LBPanelsClick(TObject) Method

Summary

Represents method LBPanelsClick(TObject).

Namespace: VCLBI.Editor.Template.Panels
Syntax
Delphi
published
 procedure LBPanelsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TPanelGallery
  • VCLBI.Editor.Template.Panels


TPanelGallery.Refresh(TPanels) Method

Summary

Represents method Refresh(TPanels).

Namespace: VCLBI.Editor.Template.Panels
Syntax
Delphi
public
 procedure Refresh(const APanels:TPanels);

Parameters

APanels
Type: TPanels

See Also

Reference

  • TPanelGallery
  • VCLBI.Editor.Template.Panels


TPanelGallery Fields

Fields
Name | Description
BCancel | Represents field BCancel.
BIVisual1 | Represents field BIVisual1.
BOK | Represents field BOK.
LBPanels | Represents field LBPanels.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Splitter1 | Represents field Splitter1.
Top


TPanelGallery.BCancel Field

Summary

Represents field BCancel.

Namespace: VCLBI.Editor.Template.Panels
Syntax
Delphi
published
 BCancel: TButton;

Field Value

Type: TButton

See Also

Reference

  • TPanelGallery
  • VCLBI.Editor.Template.Panels


TPanelGallery.BIVisual1 Field

Summary

Represents field BIVisual1.

Namespace: VCLBI.Editor.Template.Panels
Syntax
Delphi
published
 BIVisual1: TBIVisual;

Field Value

Type: TBIVisual

See Also

Reference

  • TPanelGallery
  • VCLBI.Editor.Template.Panels


TPanelGallery.BOK Field

Summary

Represents field BOK.

Namespace: VCLBI.Editor.Template.Panels
Syntax
Delphi
published
 BOK: TButton;

Field Value

Type: TButton

See Also

Reference

  • TPanelGallery
  • VCLBI.Editor.Template.Panels


TPanelGallery.LBPanels Field

Summary

Represents field LBPanels.

Namespace: VCLBI.Editor.Template.Panels
Syntax
Delphi
published
 LBPanels: TListBox;

Field Value

Type: TListBox

See Also

Reference

  • TPanelGallery
  • VCLBI.Editor.Template.Panels


TPanelGallery.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Editor.Template.Panels
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TPanelGallery
  • VCLBI.Editor.Template.Panels


TPanelGallery.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.Editor.Template.Panels
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TPanelGallery
  • VCLBI.Editor.Template.Panels


TPanelGallery.Splitter1 Field

Summary

Represents field Splitter1.

Namespace: VCLBI.Editor.Template.Panels
Syntax
Delphi
published
 Splitter1: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TPanelGallery
  • VCLBI.Editor.Template.Panels


VCLBI.Editor.Visualizer Namespace

Summary

Represents namespace VCLBI.Editor.Visualizer.

Classes
Name | Description
TVisualizerEditor | Represents type TVisualizerEditor.
Top


VCLBI.Editor.Visualizer Classes

Classes
Name | Description
TVisualizerEditor | Represents type TVisualizerEditor.
Top


TVisualizerEditor Class

Summary

Represents type TVisualizerEditor.

Namespace: VCLBI.Editor.Visualizer
Inheritance Hierarchy
TForm
VCLBI.Editor.Visualizer.TVisualizerEditor
VCLBI.Editor.Visualizer.Chart.TVizAccess
Syntax
Delphi
type
 TVisualizerEditor = class(TForm)
 end;

The TVisualizerEditor type exposes the following members.

Methods
Show:
Name | Description
BDownClick(TObject) | Represents method BDownClick(TObject).
BUpClick(TObject) | Represents method BUpClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
Button2Click(TObject) | Represents method Button2Click(TObject).
CBCheckBoxesClick(TObject) | Represents method CBCheckBoxesClick(TObject).
CBColorizeClick(TObject) | Represents method CBColorizeClick(TObject).
CBControlAlignChange(TObject) | Represents method CBControlAlignChange(TObject).
CBControlLabelClick(TObject) | Represents method CBControlLabelClick(TObject).
CBDuplicatesClick(TObject) | Represents method CBDuplicatesClick(TObject).
CBExpandLastClick(TObject) | Represents method CBExpandLastClick(TObject).
CBGroupByChange(TObject) | Represents method CBGroupByChange(TObject).
CBMultiScrollChange(TObject) | Represents method CBMultiScrollChange(TObject).
CBSelectedClickCheck(TObject) | Represents method CBSelectedClickCheck(TObject).
CBSplittersClick(TObject) | Represents method CBSplittersClick(TObject).
CheckDuplicates(TSummary) | Represents method CheckDuplicates(TSummary).
EColumnsChange(TObject) | Represents method EColumnsChange(TObject).
Edit(TComponent,TBIComposer) | Represents method Edit(TComponent,TBIComposer).
Embedd(TComponent,TWinControl) | Represents method Embedd(TComponent,TWinControl).
ERowHeightChange(TObject) | Represents method ERowHeightChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
LBGroupsClick(TObject) | Represents method LBGroupsClick(TObject).
LBGroupsClickCheck(TObject) | Represents method LBGroupsClickCheck(TObject).
LBValuesClick(TObject) | Represents method LBValuesClick(TObject).
LBValuesClickCheck(TObject) | Represents method LBValuesClickCheck(TObject).
PageSettingsChange(TObject) | Represents method PageSettingsChange(TObject).
Refresh(TBIComposer) | Represents method Refresh(TBIComposer).
RGClassClick(TObject) | Represents method RGClassClick(TObject).
SBDownValueClick(TObject) | Represents method SBDownValueClick(TObject).
SBUpValueClick(TObject) | Represents method SBUpValueClick(TObject).
ShowSettings(TTabSheet) | Represents method ShowSettings(TTabSheet).
SpeedButton2Click(TObject) | Represents method SpeedButton2Click(TObject).
Top
Fields
Show:
Name | Description
BDown | Represents field BDown.
BIGrid1 | Represents field BIGrid1.
BUp | Represents field BUp.
Button1 | Represents field Button1.
Button2 | Represents field Button2.
CBCheckBoxes | Represents field CBCheckBoxes.
CBColorize | Represents field CBColorize.
CBControlAlign | Represents field CBControlAlign.
CBControlLabel | Represents field CBControlLabel.
CBDuplicates | Represents field CBDuplicates.
CBExpandLast | Represents field CBExpandLast.
CBGroupBy | Represents field CBGroupBy.
CBMultiScroll | Represents field CBMultiScroll.
CBSelected | Represents field CBSelected.
CBSplitters | Represents field CBSplitters.
EColumns | Represents field EColumns.
ERowHeight | Represents field ERowHeight.
Group | Represents field Group.
Label12 | Represents field Label12.
Label14 | Represents field Label14.
Label3 | Represents field Label3.
Label9 | Represents field Label9.
LBGroups | Represents field LBGroups.
LBValues | Represents field LBValues.
LCurrent | Represents field LCurrent.
LCurrentHeader | Represents field LCurrentHeader.
LMultiScroll | Represents field LMultiScroll.
PageItems | Represents field PageItems.
PageSettings | Represents field PageSettings.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
Panel5 | Represents field Panel5.
Panel6 | Represents field Panel6.
Panel7 | Represents field Panel7.
Panel8 | Represents field Panel8.
RGClass | Represents field RGClass.
SBDownValue | Represents field SBDownValue.
SBUpValue | Represents field SBUpValue.
SpeedButton2 | Represents field SpeedButton2.
TabCombo | Represents field TabCombo.
TabControl | Represents field TabControl.
TabGrid | Represents field TabGrid.
TabList | Represents field TabList.
TabMulti | Represents field TabMulti.
TabPage | Represents field TabPage.
TabSelected | Represents field TabSelected.
TabTrack | Represents field TabTrack.
TabValues | Represents field TabValues.
UDColumns | Represents field UDColumns.
UDRowHeight | Represents field UDRowHeight.
Top
See Also

Reference

  • VCLBI.Editor.Visualizer


TVisualizerEditor Methods

Methods
Name | Description
BDownClick(TObject) | Represents method BDownClick(TObject).
BUpClick(TObject) | Represents method BUpClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
Button2Click(TObject) | Represents method Button2Click(TObject).
CBCheckBoxesClick(TObject) | Represents method CBCheckBoxesClick(TObject).
CBColorizeClick(TObject) | Represents method CBColorizeClick(TObject).
CBControlAlignChange(TObject) | Represents method CBControlAlignChange(TObject).
CBControlLabelClick(TObject) | Represents method CBControlLabelClick(TObject).
CBDuplicatesClick(TObject) | Represents method CBDuplicatesClick(TObject).
CBExpandLastClick(TObject) | Represents method CBExpandLastClick(TObject).
CBGroupByChange(TObject) | Represents method CBGroupByChange(TObject).
CBMultiScrollChange(TObject) | Represents method CBMultiScrollChange(TObject).
CBSelectedClickCheck(TObject) | Represents method CBSelectedClickCheck(TObject).
CBSplittersClick(TObject) | Represents method CBSplittersClick(TObject).
CheckDuplicates(TSummary) | Represents method CheckDuplicates(TSummary).
EColumnsChange(TObject) | Represents method EColumnsChange(TObject).
Edit(TComponent,TBIComposer) | Represents method Edit(TComponent,TBIComposer).
Embedd(TComponent,TWinControl) | Represents method Embedd(TComponent,TWinControl).
ERowHeightChange(TObject) | Represents method ERowHeightChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
LBGroupsClick(TObject) | Represents method LBGroupsClick(TObject).
LBGroupsClickCheck(TObject) | Represents method LBGroupsClickCheck(TObject).
LBValuesClick(TObject) | Represents method LBValuesClick(TObject).
LBValuesClickCheck(TObject) | Represents method LBValuesClickCheck(TObject).
PageSettingsChange(TObject) | Represents method PageSettingsChange(TObject).
Refresh(TBIComposer) | Represents method Refresh(TBIComposer).
RGClassClick(TObject) | Represents method RGClassClick(TObject).
SBDownValueClick(TObject) | Represents method SBDownValueClick(TObject).
SBUpValueClick(TObject) | Represents method SBUpValueClick(TObject).
ShowSettings(TTabSheet) | Represents method ShowSettings(TTabSheet).
SpeedButton2Click(TObject) | Represents method SpeedButton2Click(TObject).
Top


TVisualizerEditor.BDownClick(TObject) Method

Summary

Represents method BDownClick(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure BDownClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.BUpClick(TObject) Method

Summary

Represents method BUpClick(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure BUpClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.Button2Click(TObject) Method

Summary

Represents method Button2Click(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure Button2Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.CBCheckBoxesClick(TObject) Method

Summary

Represents method CBCheckBoxesClick(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure CBCheckBoxesClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.CBColorizeClick(TObject) Method

Summary

Represents method CBColorizeClick(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure CBColorizeClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.CBControlAlignChange(TObject) Method

Summary

Represents method CBControlAlignChange(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure CBControlAlignChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.CBControlLabelClick(TObject) Method

Summary

Represents method CBControlLabelClick(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure CBControlLabelClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.CBDuplicatesClick(TObject) Method

Summary

Represents method CBDuplicatesClick(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure CBDuplicatesClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.CBExpandLastClick(TObject) Method

Summary

Represents method CBExpandLastClick(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure CBExpandLastClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.CBGroupByChange(TObject) Method

Summary

Represents method CBGroupByChange(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure CBGroupByChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.CBMultiScrollChange(TObject) Method

Summary

Represents method CBMultiScrollChange(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure CBMultiScrollChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.CBSelectedClickCheck(TObject) Method

Summary

Represents method CBSelectedClickCheck(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure CBSelectedClickCheck(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.CBSplittersClick(TObject) Method

Summary

Represents method CBSplittersClick(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure CBSplittersClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.CheckDuplicates(TSummary) Method

Summary

Represents method CheckDuplicates(TSummary).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
public
 procedure CheckDuplicates(const ASummary:TSummary);

Parameters

ASummary
Type: TSummary

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.EColumnsChange(TObject) Method

Summary

Represents method EColumnsChange(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure EColumnsChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.Edit(TComponent,TBIComposer) Method

Summary

Represents method Edit(TComponent,TBIComposer).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
public
 class procedure Edit(const AOwner:TComponent; const AVisualizer:TBIComposer); static;

Parameters

AOwner
Type: TComponent

AVisualizer
Type: TBIComposer

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.Embedd(TComponent,TWinControl) Method

Summary

Represents method Embedd(TComponent,TWinControl).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl):TVisualizerEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

Return Value

Type: TVisualizerEditor

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.ERowHeightChange(TObject) Method

Summary

Represents method ERowHeightChange(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure ERowHeightChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.LBGroupsClick(TObject) Method

Summary

Represents method LBGroupsClick(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure LBGroupsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.LBGroupsClickCheck(TObject) Method

Summary

Represents method LBGroupsClickCheck(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure LBGroupsClickCheck(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.LBValuesClick(TObject) Method

Summary

Represents method LBValuesClick(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure LBValuesClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.LBValuesClickCheck(TObject) Method

Summary

Represents method LBValuesClickCheck(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure LBValuesClickCheck(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.PageSettingsChange(TObject) Method

Summary

Represents method PageSettingsChange(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure PageSettingsChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.Refresh(TBIComposer) Method

Summary

Represents method Refresh(TBIComposer).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
public
 procedure Refresh(const AVisualizer:TBIComposer);

Parameters

AVisualizer
Type: TBIComposer

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.RGClassClick(TObject) Method

Summary

Represents method RGClassClick(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure RGClassClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.SBDownValueClick(TObject) Method

Summary

Represents method SBDownValueClick(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure SBDownValueClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.SBUpValueClick(TObject) Method

Summary

Represents method SBUpValueClick(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure SBUpValueClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.ShowSettings(TTabSheet) Method

Summary

Represents method ShowSettings(TTabSheet).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
protected
 procedure ShowSettings(const ATab:TTabSheet);

Parameters

ATab
Type: TTabSheet

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.SpeedButton2Click(TObject) Method

Summary

Represents method SpeedButton2Click(TObject).

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 procedure SpeedButton2Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor Fields

Fields
Name | Description
BDown | Represents field BDown.
BIGrid1 | Represents field BIGrid1.
BUp | Represents field BUp.
Button1 | Represents field Button1.
Button2 | Represents field Button2.
CBCheckBoxes | Represents field CBCheckBoxes.
CBColorize | Represents field CBColorize.
CBControlAlign | Represents field CBControlAlign.
CBControlLabel | Represents field CBControlLabel.
CBDuplicates | Represents field CBDuplicates.
CBExpandLast | Represents field CBExpandLast.
CBGroupBy | Represents field CBGroupBy.
CBMultiScroll | Represents field CBMultiScroll.
CBSelected | Represents field CBSelected.
CBSplitters | Represents field CBSplitters.
EColumns | Represents field EColumns.
ERowHeight | Represents field ERowHeight.
Group | Represents field Group.
Label12 | Represents field Label12.
Label14 | Represents field Label14.
Label3 | Represents field Label3.
Label9 | Represents field Label9.
LBGroups | Represents field LBGroups.
LBValues | Represents field LBValues.
LCurrent | Represents field LCurrent.
LCurrentHeader | Represents field LCurrentHeader.
LMultiScroll | Represents field LMultiScroll.
PageItems | Represents field PageItems.
PageSettings | Represents field PageSettings.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Panel4 | Represents field Panel4.
Panel5 | Represents field Panel5.
Panel6 | Represents field Panel6.
Panel7 | Represents field Panel7.
Panel8 | Represents field Panel8.
RGClass | Represents field RGClass.
SBDownValue | Represents field SBDownValue.
SBUpValue | Represents field SBUpValue.
SpeedButton2 | Represents field SpeedButton2.
TabCombo | Represents field TabCombo.
TabControl | Represents field TabControl.
TabGrid | Represents field TabGrid.
TabList | Represents field TabList.
TabMulti | Represents field TabMulti.
TabPage | Represents field TabPage.
TabSelected | Represents field TabSelected.
TabTrack | Represents field TabTrack.
TabValues | Represents field TabValues.
UDColumns | Represents field UDColumns.
UDRowHeight | Represents field UDRowHeight.
Top


TVisualizerEditor.BDown Field

Summary

Represents field BDown.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 BDown: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.BIGrid1 Field

Summary

Represents field BIGrid1.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 BIGrid1: TBIGrid;

Field Value

Type: TBIGrid

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.BUp Field

Summary

Represents field BUp.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 BUp: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.Button1 Field

Summary

Represents field Button1.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.Button2 Field

Summary

Represents field Button2.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 Button2: TButton;

Field Value

Type: TButton

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.CBCheckBoxes Field

Summary

Represents field CBCheckBoxes.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 CBCheckBoxes: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.CBColorize Field

Summary

Represents field CBColorize.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 CBColorize: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.CBControlAlign Field

Summary

Represents field CBControlAlign.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 CBControlAlign: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.CBControlLabel Field

Summary

Represents field CBControlLabel.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 CBControlLabel: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.CBDuplicates Field

Summary

Represents field CBDuplicates.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 CBDuplicates: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.CBExpandLast Field

Summary

Represents field CBExpandLast.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 CBExpandLast: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.CBGroupBy Field

Summary

Represents field CBGroupBy.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 CBGroupBy: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.CBMultiScroll Field

Summary

Represents field CBMultiScroll.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 CBMultiScroll: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.CBSelected Field

Summary

Represents field CBSelected.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 CBSelected: TCheckListBox;

Field Value

Type: TCheckListBox

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.CBSplitters Field

Summary

Represents field CBSplitters.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 CBSplitters: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.EColumns Field

Summary

Represents field EColumns.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 EColumns: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.ERowHeight Field

Summary

Represents field ERowHeight.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 ERowHeight: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.Group Field

Summary

Represents field Group.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 Group: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.Label12 Field

Summary

Represents field Label12.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 Label12: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.Label14 Field

Summary

Represents field Label14.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 Label14: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.Label3 Field

Summary

Represents field Label3.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 Label3: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.Label9 Field

Summary

Represents field Label9.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 Label9: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.LBGroups Field

Summary

Represents field LBGroups.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 LBGroups: TCheckListBox;

Field Value

Type: TCheckListBox

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.LBValues Field

Summary

Represents field LBValues.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 LBValues: TCheckListBox;

Field Value

Type: TCheckListBox

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.LCurrent Field

Summary

Represents field LCurrent.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 LCurrent: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.LCurrentHeader Field

Summary

Represents field LCurrentHeader.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 LCurrentHeader: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.LMultiScroll Field

Summary

Represents field LMultiScroll.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 LMultiScroll: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.PageItems Field

Summary

Represents field PageItems.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 PageItems: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.PageSettings Field

Summary

Represents field PageSettings.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 PageSettings: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.Panel3 Field

Summary

Represents field Panel3.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 Panel3: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.Panel4 Field

Summary

Represents field Panel4.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 Panel4: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.Panel5 Field

Summary

Represents field Panel5.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 Panel5: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.Panel6 Field

Summary

Represents field Panel6.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 Panel6: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.Panel7 Field

Summary

Represents field Panel7.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 Panel7: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.Panel8 Field

Summary

Represents field Panel8.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 Panel8: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.RGClass Field

Summary

Represents field RGClass.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 RGClass: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.SBDownValue Field

Summary

Represents field SBDownValue.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 SBDownValue: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.SBUpValue Field

Summary

Represents field SBUpValue.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 SBUpValue: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.SpeedButton2 Field

Summary

Represents field SpeedButton2.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 SpeedButton2: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.TabCombo Field

Summary

Represents field TabCombo.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 TabCombo: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.TabControl Field

Summary

Represents field TabControl.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 TabControl: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.TabGrid Field

Summary

Represents field TabGrid.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 TabGrid: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.TabList Field

Summary

Represents field TabList.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 TabList: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.TabMulti Field

Summary

Represents field TabMulti.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 TabMulti: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.TabPage Field

Summary

Represents field TabPage.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 TabPage: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.TabSelected Field

Summary

Represents field TabSelected.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 TabSelected: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.TabTrack Field

Summary

Represents field TabTrack.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 TabTrack: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.TabValues Field

Summary

Represents field TabValues.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 TabValues: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.UDColumns Field

Summary

Represents field UDColumns.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 UDColumns: TUpDown;

Field Value

Type: TUpDown

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


TVisualizerEditor.UDRowHeight Field

Summary

Represents field UDRowHeight.

Namespace: VCLBI.Editor.Visualizer
Syntax
Delphi
published
 UDRowHeight: TUpDown;

Field Value

Type: TUpDown

See Also

Reference

  • TVisualizerEditor
  • VCLBI.Editor.Visualizer


VCLBI.Editor.Visualizer.Chart Namespace

Summary

Represents namespace VCLBI.Editor.Visualizer.Chart.

Classes
Name | Description
TChartVisualizerEditor | Represents type TChartVisualizerEditor.
TVizAccess | Represents type TVizAccess.
Top


VCLBI.Editor.Visualizer.Chart Classes

Classes
Name | Description
TChartVisualizerEditor | Represents type TChartVisualizerEditor.
TVizAccess | Represents type TVizAccess.
Top


TChartVisualizerEditor Class

Summary

Represents type TChartVisualizerEditor.

Namespace: VCLBI.Editor.Visualizer.Chart
Inheritance Hierarchy
TForm
VCLBI.Editor.Visualizer.Chart.TChartVisualizerEditor
Syntax
Delphi
type
 TChartVisualizerEditor = class(TForm)
 end;

The TChartVisualizerEditor type exposes the following members.

Methods
Show:
Name | Description
BEditChartClick(TObject) | Represents method BEditChartClick(TObject).
CB2DChange(TObject) | Represents method CB2DChange(TObject).
CB3DChange(TObject) | Represents method CB3DChange(TObject).
CBAddNullsClick(TObject) | Represents method CBAddNullsClick(TObject).
CBAutoStackChange(TObject) | Represents method CBAutoStackChange(TObject).
CBChartSettingsClick(TObject) | Represents method CBChartSettingsClick(TObject).
CBLegendClick(TObject) | Represents method CBLegendClick(TObject).
CBMarksClick(TObject) | Represents method CBMarksClick(TObject).
CBMultiAxisChange(TObject) | Represents method CBMultiAxisChange(TObject).
CBRenderChange(TObject) | Represents method CBRenderChange(TObject).
CBRenderSeriesChange(TObject) | Represents method CBRenderSeriesChange(TObject).
CBSameAxisRangeClick(TObject) | Represents method CBSameAxisRangeClick(TObject).
CBStyleChange(TObject) | Represents method CBStyleChange(TObject).
CBSubColumnsClick(TObject) | Represents method CBSubColumnsClick(TObject).
ESubColumnsChange(TObject) | Represents method ESubColumnsChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
Top
Fields
Show:
Name | Description
BEditChart | Represents field BEditChart.
CB2D | Represents field CB2D.
CB3D | Represents field CB3D.
CBAddNulls | Represents field CBAddNulls.
CBAutoStack | Represents field CBAutoStack.
CBChartSettings | Represents field CBChartSettings.
CBLegend | Represents field CBLegend.
CBMarks | Represents field CBMarks.
CBMultiAxis | Represents field CBMultiAxis.
CBRender | Represents field CBRender.
CBRenderSeries | Represents field CBRenderSeries.
CBSameAxisRange | Represents field CBSameAxisRange.
CBStyle | Represents field CBStyle.
CBSubColumns | Represents field CBSubColumns.
ESubColumns | Represents field ESubColumns.
Label1 | Represents field Label1.
Label10 | Represents field Label10.
Label11 | Represents field Label11.
Label15 | Represents field Label15.
Label4 | Represents field Label4.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
Label8 | Represents field Label8.
PageControl1 | Represents field PageControl1.
TabChart | Represents field TabChart.
TabOptions | Represents field TabOptions.
TabSeries | Represents field TabSeries.
TabSubChart | Represents field TabSubChart.
UDSubColumns | Represents field UDSubColumns.
Top
See Also

Reference

  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor Methods

Methods
Name | Description
BEditChartClick(TObject) | Represents method BEditChartClick(TObject).
CB2DChange(TObject) | Represents method CB2DChange(TObject).
CB3DChange(TObject) | Represents method CB3DChange(TObject).
CBAddNullsClick(TObject) | Represents method CBAddNullsClick(TObject).
CBAutoStackChange(TObject) | Represents method CBAutoStackChange(TObject).
CBChartSettingsClick(TObject) | Represents method CBChartSettingsClick(TObject).
CBLegendClick(TObject) | Represents method CBLegendClick(TObject).
CBMarksClick(TObject) | Represents method CBMarksClick(TObject).
CBMultiAxisChange(TObject) | Represents method CBMultiAxisChange(TObject).
CBRenderChange(TObject) | Represents method CBRenderChange(TObject).
CBRenderSeriesChange(TObject) | Represents method CBRenderSeriesChange(TObject).
CBSameAxisRangeClick(TObject) | Represents method CBSameAxisRangeClick(TObject).
CBStyleChange(TObject) | Represents method CBStyleChange(TObject).
CBSubColumnsClick(TObject) | Represents method CBSubColumnsClick(TObject).
ESubColumnsChange(TObject) | Represents method ESubColumnsChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
PageControl1Change(TObject) | Represents method PageControl1Change(TObject).
Top


TChartVisualizerEditor.BEditChartClick(TObject) Method

Summary

Represents method BEditChartClick(TObject).

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure BEditChartClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CB2DChange(TObject) Method

Summary

Represents method CB2DChange(TObject).

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure CB2DChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CB3DChange(TObject) Method

Summary

Represents method CB3DChange(TObject).

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure CB3DChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBAddNullsClick(TObject) Method

Summary

Represents method CBAddNullsClick(TObject).

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure CBAddNullsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBAutoStackChange(TObject) Method

Summary

Represents method CBAutoStackChange(TObject).

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure CBAutoStackChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBChartSettingsClick(TObject) Method

Summary

Represents method CBChartSettingsClick(TObject).

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure CBChartSettingsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBLegendClick(TObject) Method

Summary

Represents method CBLegendClick(TObject).

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure CBLegendClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBMarksClick(TObject) Method

Summary

Represents method CBMarksClick(TObject).

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure CBMarksClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBMultiAxisChange(TObject) Method

Summary

Represents method CBMultiAxisChange(TObject).

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure CBMultiAxisChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBRenderChange(TObject) Method

Summary

Represents method CBRenderChange(TObject).

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure CBRenderChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBRenderSeriesChange(TObject) Method

Summary

Represents method CBRenderSeriesChange(TObject).

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure CBRenderSeriesChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBSameAxisRangeClick(TObject) Method

Summary

Represents method CBSameAxisRangeClick(TObject).

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure CBSameAxisRangeClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBStyleChange(TObject) Method

Summary

Represents method CBStyleChange(TObject).

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure CBStyleChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBSubColumnsClick(TObject) Method

Summary

Represents method CBSubColumnsClick(TObject).

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure CBSubColumnsClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.ESubColumnsChange(TObject) Method

Summary

Represents method ESubColumnsChange(TObject).

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure ESubColumnsChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.PageControl1Change(TObject) Method

Summary

Represents method PageControl1Change(TObject).

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 procedure PageControl1Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor Fields

Fields
Name | Description
BEditChart | Represents field BEditChart.
CB2D | Represents field CB2D.
CB3D | Represents field CB3D.
CBAddNulls | Represents field CBAddNulls.
CBAutoStack | Represents field CBAutoStack.
CBChartSettings | Represents field CBChartSettings.
CBLegend | Represents field CBLegend.
CBMarks | Represents field CBMarks.
CBMultiAxis | Represents field CBMultiAxis.
CBRender | Represents field CBRender.
CBRenderSeries | Represents field CBRenderSeries.
CBSameAxisRange | Represents field CBSameAxisRange.
CBStyle | Represents field CBStyle.
CBSubColumns | Represents field CBSubColumns.
ESubColumns | Represents field ESubColumns.
Label1 | Represents field Label1.
Label10 | Represents field Label10.
Label11 | Represents field Label11.
Label15 | Represents field Label15.
Label4 | Represents field Label4.
Label6 | Represents field Label6.
Label7 | Represents field Label7.
Label8 | Represents field Label8.
PageControl1 | Represents field PageControl1.
TabChart | Represents field TabChart.
TabOptions | Represents field TabOptions.
TabSeries | Represents field TabSeries.
TabSubChart | Represents field TabSubChart.
UDSubColumns | Represents field UDSubColumns.
Top


TChartVisualizerEditor.BEditChart Field

Summary

Represents field BEditChart.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 BEditChart: TButton;

Field Value

Type: TButton

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CB2D Field

Summary

Represents field CB2D.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 CB2D: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CB3D Field

Summary

Represents field CB3D.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 CB3D: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBAddNulls Field

Summary

Represents field CBAddNulls.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 CBAddNulls: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBAutoStack Field

Summary

Represents field CBAutoStack.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 CBAutoStack: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBChartSettings Field

Summary

Represents field CBChartSettings.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 CBChartSettings: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBLegend Field

Summary

Represents field CBLegend.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 CBLegend: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBMarks Field

Summary

Represents field CBMarks.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 CBMarks: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBMultiAxis Field

Summary

Represents field CBMultiAxis.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 CBMultiAxis: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBRender Field

Summary

Represents field CBRender.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 CBRender: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBRenderSeries Field

Summary

Represents field CBRenderSeries.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 CBRenderSeries: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBSameAxisRange Field

Summary

Represents field CBSameAxisRange.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 CBSameAxisRange: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBStyle Field

Summary

Represents field CBStyle.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 CBStyle: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.CBSubColumns Field

Summary

Represents field CBSubColumns.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 CBSubColumns: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.ESubColumns Field

Summary

Represents field ESubColumns.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 ESubColumns: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.Label10 Field

Summary

Represents field Label10.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 Label10: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.Label11 Field

Summary

Represents field Label11.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 Label11: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.Label15 Field

Summary

Represents field Label15.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 Label15: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.Label4 Field

Summary

Represents field Label4.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 Label4: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.Label6 Field

Summary

Represents field Label6.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 Label6: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.Label7 Field

Summary

Represents field Label7.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 Label7: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.Label8 Field

Summary

Represents field Label8.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 Label8: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.PageControl1 Field

Summary

Represents field PageControl1.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 PageControl1: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.TabChart Field

Summary

Represents field TabChart.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 TabChart: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.TabOptions Field

Summary

Represents field TabOptions.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 TabOptions: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.TabSeries Field

Summary

Represents field TabSeries.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 TabSeries: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.TabSubChart Field

Summary

Represents field TabSubChart.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 TabSubChart: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TChartVisualizerEditor.UDSubColumns Field

Summary

Represents field UDSubColumns.

Namespace: VCLBI.Editor.Visualizer.Chart
Syntax
Delphi
published
 UDSubColumns: TUpDown;

Field Value

Type: TUpDown

See Also

Reference

  • TChartVisualizerEditor
  • VCLBI.Editor.Visualizer.Chart


TVizAccess Class

Summary

Represents type TVizAccess.

Namespace: VCLBI.Editor.Visualizer.Chart
Inheritance Hierarchy
TForm
VCLBI.Editor.Visualizer.TVisualizerEditor
VCLBI.Editor.Visualizer.Chart.TVizAccess
Syntax
Delphi
type
 TVizAccess=class(TVisualizerEditor);
See Also

Reference

  • VCLBI.Editor.Visualizer.Chart


VCLBI.Editor.Workflow Namespace

Summary

Represents namespace VCLBI.Editor.Workflow.

Classes
Name | Description
TBIWorkflowEditor | Represents type TBIWorkflowEditor.
TDataSelectorAccess | Represents type TDataSelectorAccess.
TWorkflowItemAccess | Represents type TWorkflowItemAccess.
Top
Constants
Name | Description
DummyNode | Represents constant DummyNode.
Top
Routines
Name | Description
NamesOf(TDataArray) | Represents method NamesOf(TDataArray).
Top


VCLBI.Editor.Workflow Classes

Classes
Name | Description
TBIWorkflowEditor | Represents type TBIWorkflowEditor.
TDataSelectorAccess | Represents type TDataSelectorAccess.
TWorkflowItemAccess | Represents type TWorkflowItemAccess.
Top


TBIWorkflowEditor Class

Summary

Represents type TBIWorkflowEditor.

Namespace: VCLBI.Editor.Workflow
Inheritance Hierarchy
TForm
VCLBI.Editor.Workflow.TBIWorkflowEditor
Syntax
Delphi
type
 TBIWorkflowEditor = class(TForm)
 end;

The TBIWorkflowEditor type exposes the following members.

Constants
Show:
Name | Description
TeeMsg_ItemsWorkflow | Represents constant TeeMsg_ItemsWorkflow.
Top
Properties
Show:
Name | Description
Workflow | Represents property Workflow.
Top
Methods
Show:
Name | Description
Add1Click(TObject) | Represents method Add1Click(TObject).
BAddClick(TObject) | Represents method BAddClick(TObject).
BDeleteClick(TObject) | Represents method BDeleteClick(TObject).
BITree1Change(TObject) | Represents method BITree1Change(TObject).
BITree1Deleting(TObject) | Represents method BITree1Deleting(TObject).
BIWebServer1Click(TObject) | Represents method BIWebServer1Click(TObject).
BNewClick(TObject) | Represents method BNewClick(TObject).
Boolean1Click(TObject) | Represents method Boolean1Click(TObject).
BPreviewClick(TObject) | Represents method BPreviewClick(TObject).
Change1Click(TObject) | Represents method Change1Click(TObject).
Chart1Click(TObject) | Represents method Chart1Click(TObject).
Clone1Click(TObject) | Represents method Clone1Click(TObject).
Common1Click(TObject) | Represents method Common1Click(TObject).
Compare1Click(TObject) | Represents method Compare1Click(TObject).
CrossTableConfusionMatrix1Click(TObject) | Represents method CrossTableConfusionMatrix1Click(TObject).
DatabaseServer1Click(TObject) | Represents method DatabaseServer1Click(TObject).
Delete1Click(TObject) | Represents method Delete1Click(TObject).
Different1Click(TObject) | Represents method Different1Click(TObject).
Duplicate1Click(TObject) | Represents method Duplicate1Click(TObject).
Edit(TComponent,TBIWorkflow) | Represents method Edit(TComponent,TBIWorkflow).
Embedd(TComponent,TWinControl,TBIWorkflow) | Represents method Embedd(TComponent,TWinControl,TBIWorkflow).
Files1Click(TObject) | Represents method Files1Click(TObject).
Filter1Click(TObject) | Represents method Filter1Click(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
Function1Click(TObject) | Represents method Function1Click(TObject).
Grid1Click(TObject) | Represents method Grid1Click(TObject).
Gridify1Click(TObject) | Represents method Gridify1Click(TObject).
Groupby1Click(TObject) | Represents method Groupby1Click(TObject).
Join1Click(TObject) | Represents method Join1Click(TObject).
NewCustomData1Click(TObject) | Represents method NewCustomData1Click(TObject).
Normalize1Click(TObject) | Represents method Normalize1Click(TObject).
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
PopupAddPopup(TObject) | Represents method PopupAddPopup(TObject).
Query1Click(TObject) | Represents method Query1Click(TObject).
Rank1Click(TObject) | Represents method Rank1Click(TObject).
ranspose1Click(TObject) | Represents method ranspose1Click(TObject).
Refresh(TBIWorkflow) | Represents method Refresh(TBIWorkflow).
Regression1Click(TObject) | Represents method Regression1Click(TObject).
Rename1Click(TObject) | Represents method Rename1Click(TObject).
Reorder1Click(TObject) | Represents method Reorder1Click(TObject).
SBSelectorClick(TObject) | Represents method SBSelectorClick(TObject).
Shuffle1Click(TObject) | Represents method Shuffle1Click(TObject).
Singlerow1Click(TObject) | Represents method Singlerow1Click(TObject).
Sort1Click(TObject) | Represents method Sort1Click(TObject).
Split1Click(TObject) | Represents method Split1Click(TObject).
Tree1DragDrop(TObject,TObject,Integer,Integer) | Represents method Tree1DragDrop(TObject,TObject,Integer,Integer).
Tree1DragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method Tree1DragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
Top
Fields
Show:
Name | Description
Add1 | Represents field Add1.
BAdd | Represents field BAdd.
BDelete | Represents field BDelete.
BITree1 | Represents field BITree1.
BNew | Represents field BNew.
Boolean1 | Represents field Boolean1.
BPreview | Represents field BPreview.
Change1 | Represents field Change1.
Chart1 | Represents field Chart1.
Clone1 | Represents field Clone1.
Column1 | Represents field Column1.
Common1 | Represents field Common1.
CrossTableConfusionMatrix1 | Represents field CrossTableConfusionMatrix1.
DateTime1 | Represents field DateTime1.
Delete1 | Represents field Delete1.
Different1 | Represents field Different1.
Doublefloat1 | Represents field Doublefloat1.
Duplicate1 | Represents field Duplicate1.
ext1 | Represents field ext1.
Extendedfloat1 | Represents field Extendedfloat1.
Filter1 | Represents field Filter1.
Function1 | Represents field Function1.
Grid1 | Represents field Grid1.
Gridify1 | Represents field Gridify1.
Groupby1 | Represents field Groupby1.
Integer32bit1 | Represents field Integer32bit1.
Integer64bit1 | Represents field Integer64bit1.
Join1 | Represents field Join1.
MachineLearning1 | Represents field MachineLearning1.
MenuItem2 | Represents field MenuItem2.
MenuItem20 | Represents field MenuItem20.
MenuItem22 | Represents field MenuItem22.
MenuItem29 | Represents field MenuItem29.
MenuItem34 | Represents field MenuItem34.
MenuItem35 | Represents field MenuItem35.
MenuItem36 | Represents field MenuItem36.
MenuItem37 | Represents field MenuItem37.
MenuItem38 | Represents field MenuItem38.
N1 | Represents field N1.
Normalize1 | Represents field Normalize1.
Panel2 | Represents field Panel2.
PanelChart | Represents field PanelChart.
PanelEditor | Represents field PanelEditor.
PanelMain | Represents field PanelMain.
PanelPreview | Represents field PanelPreview.
PanelPreviewButton | Represents field PanelPreviewButton.
PanelSelector | Represents field PanelSelector.
PanelTree | Represents field PanelTree.
PopupAdd | Represents field PopupAdd.
PopupNew | Represents field PopupNew.
PopupPreview | Represents field PopupPreview.
Rank1 | Represents field Rank1.
ranspose1 | Represents field ranspose1.
Regression1 | Represents field Regression1.
Rename1 | Represents field Rename1.
Reorder1 | Represents field Reorder1.
SBSelector | Represents field SBSelector.
Shuffle1 | Represents field Shuffle1.
Singlefloat1 | Represents field Singlefloat1.
Singlerow1 | Represents field Singlerow1.
Sort1 | Represents field Sort1.
Split1 | Represents field Split1.
Splitter1 | Represents field Splitter1.
SplitterChart | Represents field SplitterChart.
SplitterEditor | Represents field SplitterEditor.
SplitterPreview | Represents field SplitterPreview.
Top
See Also

Reference

  • VCLBI.Editor.Workflow


TBIWorkflowEditor Constants

Constants
Name | Description
TeeMsg_ItemsWorkflow | Represents constant TeeMsg_ItemsWorkflow.
Top


TBIWorkflowEditor.TeeMsg_ItemsWorkflow Constant

Summary

Represents constant TeeMsg_ItemsWorkflow.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
protected
 TeeMsg_ItemsWorkflow='...';

Value

Type: string

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor Properties

Properties
Name | Description
Workflow | Represents property Workflow.
Top


TBIWorkflowEditor.Workflow Property

Summary

Represents property Workflow.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
public
 property Workflow:TBIWorkflow read FWorkflow write SetWorkflow;

Property Value

Type: TBIWorkflow

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor Methods

Methods
Name | Description
Add1Click(TObject) | Represents method Add1Click(TObject).
BAddClick(TObject) | Represents method BAddClick(TObject).
BDeleteClick(TObject) | Represents method BDeleteClick(TObject).
BITree1Change(TObject) | Represents method BITree1Change(TObject).
BITree1Deleting(TObject) | Represents method BITree1Deleting(TObject).
BIWebServer1Click(TObject) | Represents method BIWebServer1Click(TObject).
BNewClick(TObject) | Represents method BNewClick(TObject).
Boolean1Click(TObject) | Represents method Boolean1Click(TObject).
BPreviewClick(TObject) | Represents method BPreviewClick(TObject).
Change1Click(TObject) | Represents method Change1Click(TObject).
Chart1Click(TObject) | Represents method Chart1Click(TObject).
Clone1Click(TObject) | Represents method Clone1Click(TObject).
Common1Click(TObject) | Represents method Common1Click(TObject).
Compare1Click(TObject) | Represents method Compare1Click(TObject).
CrossTableConfusionMatrix1Click(TObject) | Represents method CrossTableConfusionMatrix1Click(TObject).
DatabaseServer1Click(TObject) | Represents method DatabaseServer1Click(TObject).
Delete1Click(TObject) | Represents method Delete1Click(TObject).
Different1Click(TObject) | Represents method Different1Click(TObject).
Duplicate1Click(TObject) | Represents method Duplicate1Click(TObject).
Edit(TComponent,TBIWorkflow) | Represents method Edit(TComponent,TBIWorkflow).
Embedd(TComponent,TWinControl,TBIWorkflow) | Represents method Embedd(TComponent,TWinControl,TBIWorkflow).
Files1Click(TObject) | Represents method Files1Click(TObject).
Filter1Click(TObject) | Represents method Filter1Click(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
FormShow(TObject) | Represents method FormShow(TObject).
Function1Click(TObject) | Represents method Function1Click(TObject).
Grid1Click(TObject) | Represents method Grid1Click(TObject).
Gridify1Click(TObject) | Represents method Gridify1Click(TObject).
Groupby1Click(TObject) | Represents method Groupby1Click(TObject).
Join1Click(TObject) | Represents method Join1Click(TObject).
NewCustomData1Click(TObject) | Represents method NewCustomData1Click(TObject).
Normalize1Click(TObject) | Represents method Normalize1Click(TObject).
Notification(TComponent,TOperation) | Represents method Notification(TComponent,TOperation).
PopupAddPopup(TObject) | Represents method PopupAddPopup(TObject).
Query1Click(TObject) | Represents method Query1Click(TObject).
Rank1Click(TObject) | Represents method Rank1Click(TObject).
ranspose1Click(TObject) | Represents method ranspose1Click(TObject).
Refresh(TBIWorkflow) | Represents method Refresh(TBIWorkflow).
Regression1Click(TObject) | Represents method Regression1Click(TObject).
Rename1Click(TObject) | Represents method Rename1Click(TObject).
Reorder1Click(TObject) | Represents method Reorder1Click(TObject).
SBSelectorClick(TObject) | Represents method SBSelectorClick(TObject).
Shuffle1Click(TObject) | Represents method Shuffle1Click(TObject).
Singlerow1Click(TObject) | Represents method Singlerow1Click(TObject).
Sort1Click(TObject) | Represents method Sort1Click(TObject).
Split1Click(TObject) | Represents method Split1Click(TObject).
Tree1DragDrop(TObject,TObject,Integer,Integer) | Represents method Tree1DragDrop(TObject,TObject,Integer,Integer).
Tree1DragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) | Represents method Tree1DragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).
Top


TBIWorkflowEditor.Add1Click(TObject) Method

Summary

Represents method Add1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Add1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.BAddClick(TObject) Method

Summary

Represents method BAddClick(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure BAddClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.BDeleteClick(TObject) Method

Summary

Represents method BDeleteClick(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure BDeleteClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.BITree1Change(TObject) Method

Summary

Represents method BITree1Change(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure BITree1Change(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.BITree1Deleting(TObject) Method

Summary

Represents method BITree1Deleting(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure BITree1Deleting(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.BIWebServer1Click(TObject) Method

Summary

Represents method BIWebServer1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure BIWebServer1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.BNewClick(TObject) Method

Summary

Represents method BNewClick(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure BNewClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Boolean1Click(TObject) Method

Summary

Represents method Boolean1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Boolean1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.BPreviewClick(TObject) Method

Summary

Represents method BPreviewClick(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure BPreviewClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Change1Click(TObject) Method

Summary

Represents method Change1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Change1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Chart1Click(TObject) Method

Summary

Represents method Chart1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Chart1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Clone1Click(TObject) Method

Summary

Represents method Clone1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Clone1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Common1Click(TObject) Method

Summary

Represents method Common1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Common1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Compare1Click(TObject) Method

Summary

Represents method Compare1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Compare1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.CrossTableConfusionMatrix1Click(TObject) Method

Summary

Represents method CrossTableConfusionMatrix1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure CrossTableConfusionMatrix1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.DatabaseServer1Click(TObject) Method

Summary

Represents method DatabaseServer1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure DatabaseServer1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Delete1Click(TObject) Method

Summary

Represents method Delete1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Delete1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Different1Click(TObject) Method

Summary

Represents method Different1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Different1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Duplicate1Click(TObject) Method

Summary

Represents method Duplicate1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Duplicate1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Edit(TComponent,TBIWorkflow) Method

Summary

Represents method Edit(TComponent,TBIWorkflow).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
public
 class function Edit(const AOwner:TComponent; const AWorkflow:TBIWorkflow):Boolean; static;

Parameters

AOwner
Type: TComponent

AWorkflow
Type: TBIWorkflow

Return Value

Type: Boolean

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Embedd(TComponent,TWinControl,TBIWorkflow) Method

Summary

Represents method Embedd(TComponent,TWinControl,TBIWorkflow).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl;
 const AWorkflow:TBIWorkflow):TBIWorkflowEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AWorkflow
Type: TBIWorkflow

Return Value

Type: TBIWorkflowEditor

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Files1Click(TObject) Method

Summary

Represents method Files1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Files1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Filter1Click(TObject) Method

Summary

Represents method Filter1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Filter1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Function1Click(TObject) Method

Summary

Represents method Function1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Function1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Grid1Click(TObject) Method

Summary

Represents method Grid1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Grid1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Gridify1Click(TObject) Method

Summary

Represents method Gridify1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Gridify1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Groupby1Click(TObject) Method

Summary

Represents method Groupby1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Groupby1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Join1Click(TObject) Method

Summary

Represents method Join1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Join1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.NewCustomData1Click(TObject) Method

Summary

Represents method NewCustomData1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure NewCustomData1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Normalize1Click(TObject) Method

Summary

Represents method Normalize1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Normalize1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Notification(TComponent,TOperation) Method

Summary

Represents method Notification(TComponent,TOperation).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
protected
 procedure Notification(AComponent: TComponent; Operation: TOperation); override;

Parameters

AComponent
Type: TComponent

Operation
Type: TOperation

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.PopupAddPopup(TObject) Method

Summary

Represents method PopupAddPopup(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure PopupAddPopup(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Query1Click(TObject) Method

Summary

Represents method Query1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Query1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Rank1Click(TObject) Method

Summary

Represents method Rank1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Rank1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.ranspose1Click(TObject) Method

Summary

Represents method ranspose1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure ranspose1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Refresh(TBIWorkflow) Method

Summary

Represents method Refresh(TBIWorkflow).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
public
 procedure Refresh(const Value: TBIWorkflow);

Parameters

Value
Type: TBIWorkflow

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Regression1Click(TObject) Method

Summary

Represents method Regression1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Regression1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Rename1Click(TObject) Method

Summary

Represents method Rename1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Rename1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Reorder1Click(TObject) Method

Summary

Represents method Reorder1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Reorder1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.SBSelectorClick(TObject) Method

Summary

Represents method SBSelectorClick(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure SBSelectorClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Shuffle1Click(TObject) Method

Summary

Represents method Shuffle1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Shuffle1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Singlerow1Click(TObject) Method

Summary

Represents method Singlerow1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Singlerow1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Sort1Click(TObject) Method

Summary

Represents method Sort1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Sort1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Split1Click(TObject) Method

Summary

Represents method Split1Click(TObject).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Split1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Tree1DragDrop(TObject,TObject,Integer,Integer) Method

Summary

Represents method Tree1DragDrop(TObject,TObject,Integer,Integer).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Tree1DragDrop(Sender, Source: TObject; X, Y: Integer);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Tree1DragOver(TObject,TObject,Integer,Integer,TDragState,Boolean) Method

Summary

Represents method Tree1DragOver(TObject,TObject,Integer,Integer,TDragState,Boolean).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 procedure Tree1DragOver(Sender, Source: TObject; X, Y: Integer;
 State: TDragState; var Accept: Boolean);

Parameters

Sender
Type: TObject

Source
Type: TObject

X
Type: Integer

Y
Type: Integer

State
Type: TDragState

Accept
Type: Boolean

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor Fields

Fields
Name | Description
Add1 | Represents field Add1.
BAdd | Represents field BAdd.
BDelete | Represents field BDelete.
BITree1 | Represents field BITree1.
BNew | Represents field BNew.
Boolean1 | Represents field Boolean1.
BPreview | Represents field BPreview.
Change1 | Represents field Change1.
Chart1 | Represents field Chart1.
Clone1 | Represents field Clone1.
Column1 | Represents field Column1.
Common1 | Represents field Common1.
CrossTableConfusionMatrix1 | Represents field CrossTableConfusionMatrix1.
DateTime1 | Represents field DateTime1.
Delete1 | Represents field Delete1.
Different1 | Represents field Different1.
Doublefloat1 | Represents field Doublefloat1.
Duplicate1 | Represents field Duplicate1.
ext1 | Represents field ext1.
Extendedfloat1 | Represents field Extendedfloat1.
Filter1 | Represents field Filter1.
Function1 | Represents field Function1.
Grid1 | Represents field Grid1.
Gridify1 | Represents field Gridify1.
Groupby1 | Represents field Groupby1.
Integer32bit1 | Represents field Integer32bit1.
Integer64bit1 | Represents field Integer64bit1.
Join1 | Represents field Join1.
MachineLearning1 | Represents field MachineLearning1.
MenuItem2 | Represents field MenuItem2.
MenuItem20 | Represents field MenuItem20.
MenuItem22 | Represents field MenuItem22.
MenuItem29 | Represents field MenuItem29.
MenuItem34 | Represents field MenuItem34.
MenuItem35 | Represents field MenuItem35.
MenuItem36 | Represents field MenuItem36.
MenuItem37 | Represents field MenuItem37.
MenuItem38 | Represents field MenuItem38.
N1 | Represents field N1.
Normalize1 | Represents field Normalize1.
Panel2 | Represents field Panel2.
PanelChart | Represents field PanelChart.
PanelEditor | Represents field PanelEditor.
PanelMain | Represents field PanelMain.
PanelPreview | Represents field PanelPreview.
PanelPreviewButton | Represents field PanelPreviewButton.
PanelSelector | Represents field PanelSelector.
PanelTree | Represents field PanelTree.
PopupAdd | Represents field PopupAdd.
PopupNew | Represents field PopupNew.
PopupPreview | Represents field PopupPreview.
Rank1 | Represents field Rank1.
ranspose1 | Represents field ranspose1.
Regression1 | Represents field Regression1.
Rename1 | Represents field Rename1.
Reorder1 | Represents field Reorder1.
SBSelector | Represents field SBSelector.
Shuffle1 | Represents field Shuffle1.
Singlefloat1 | Represents field Singlefloat1.
Singlerow1 | Represents field Singlerow1.
Sort1 | Represents field Sort1.
Split1 | Represents field Split1.
Splitter1 | Represents field Splitter1.
SplitterChart | Represents field SplitterChart.
SplitterEditor | Represents field SplitterEditor.
SplitterPreview | Represents field SplitterPreview.
Top


TBIWorkflowEditor.Add1 Field

Summary

Represents field Add1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Add1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.BAdd Field

Summary

Represents field BAdd.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 BAdd: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.BDelete Field

Summary

Represents field BDelete.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 BDelete: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.BITree1 Field

Summary

Represents field BITree1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 BITree1: TBITree;

Field Value

Type: TBITree

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.BNew Field

Summary

Represents field BNew.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 BNew: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Boolean1 Field

Summary

Represents field Boolean1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Boolean1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.BPreview Field

Summary

Represents field BPreview.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 BPreview: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Change1 Field

Summary

Represents field Change1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Change1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Chart1 Field

Summary

Represents field Chart1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Chart1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Clone1 Field

Summary

Represents field Clone1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Clone1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Column1 Field

Summary

Represents field Column1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Column1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Common1 Field

Summary

Represents field Common1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Common1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.CrossTableConfusionMatrix1 Field

Summary

Represents field CrossTableConfusionMatrix1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 CrossTableConfusionMatrix1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.DateTime1 Field

Summary

Represents field DateTime1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 DateTime1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Delete1 Field

Summary

Represents field Delete1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Delete1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Different1 Field

Summary

Represents field Different1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Different1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Doublefloat1 Field

Summary

Represents field Doublefloat1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Doublefloat1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Duplicate1 Field

Summary

Represents field Duplicate1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Duplicate1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.ext1 Field

Summary

Represents field ext1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 ext1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Extendedfloat1 Field

Summary

Represents field Extendedfloat1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Extendedfloat1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Filter1 Field

Summary

Represents field Filter1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Filter1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Function1 Field

Summary

Represents field Function1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Function1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Grid1 Field

Summary

Represents field Grid1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Grid1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Gridify1 Field

Summary

Represents field Gridify1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Gridify1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Groupby1 Field

Summary

Represents field Groupby1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Groupby1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Integer32bit1 Field

Summary

Represents field Integer32bit1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Integer32bit1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Integer64bit1 Field

Summary

Represents field Integer64bit1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Integer64bit1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Join1 Field

Summary

Represents field Join1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Join1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.MachineLearning1 Field

Summary

Represents field MachineLearning1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 MachineLearning1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.MenuItem2 Field

Summary

Represents field MenuItem2.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 MenuItem2: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.MenuItem20 Field

Summary

Represents field MenuItem20.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 MenuItem20: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.MenuItem22 Field

Summary

Represents field MenuItem22.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 MenuItem22: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.MenuItem29 Field

Summary

Represents field MenuItem29.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 MenuItem29: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.MenuItem34 Field

Summary

Represents field MenuItem34.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 MenuItem34: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.MenuItem35 Field

Summary

Represents field MenuItem35.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 MenuItem35: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.MenuItem36 Field

Summary

Represents field MenuItem36.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 MenuItem36: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.MenuItem37 Field

Summary

Represents field MenuItem37.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 MenuItem37: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.MenuItem38 Field

Summary

Represents field MenuItem38.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 MenuItem38: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.N1 Field

Summary

Represents field N1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 N1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Normalize1 Field

Summary

Represents field Normalize1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Normalize1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.PanelChart Field

Summary

Represents field PanelChart.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 PanelChart: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.PanelEditor Field

Summary

Represents field PanelEditor.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 PanelEditor: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.PanelMain Field

Summary

Represents field PanelMain.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 PanelMain: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.PanelPreview Field

Summary

Represents field PanelPreview.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 PanelPreview: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.PanelPreviewButton Field

Summary

Represents field PanelPreviewButton.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 PanelPreviewButton: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.PanelSelector Field

Summary

Represents field PanelSelector.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 PanelSelector: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.PanelTree Field

Summary

Represents field PanelTree.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 PanelTree: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.PopupAdd Field

Summary

Represents field PopupAdd.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 PopupAdd: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.PopupNew Field

Summary

Represents field PopupNew.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 PopupNew: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.PopupPreview Field

Summary

Represents field PopupPreview.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 PopupPreview: TPopupMenu;

Field Value

Type: TPopupMenu

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Rank1 Field

Summary

Represents field Rank1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Rank1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.ranspose1 Field

Summary

Represents field ranspose1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 ranspose1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Regression1 Field

Summary

Represents field Regression1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Regression1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Rename1 Field

Summary

Represents field Rename1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Rename1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Reorder1 Field

Summary

Represents field Reorder1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Reorder1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.SBSelector Field

Summary

Represents field SBSelector.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 SBSelector: TSpeedButton;

Field Value

Type: TSpeedButton

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Shuffle1 Field

Summary

Represents field Shuffle1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Shuffle1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Singlefloat1 Field

Summary

Represents field Singlefloat1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Singlefloat1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Singlerow1 Field

Summary

Represents field Singlerow1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Singlerow1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Sort1 Field

Summary

Represents field Sort1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Sort1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Split1 Field

Summary

Represents field Split1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Split1: TMenuItem;

Field Value

Type: TMenuItem

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.Splitter1 Field

Summary

Represents field Splitter1.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 Splitter1: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.SplitterChart Field

Summary

Represents field SplitterChart.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 SplitterChart: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.SplitterEditor Field

Summary

Represents field SplitterEditor.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 SplitterEditor: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TBIWorkflowEditor.SplitterPreview Field

Summary

Represents field SplitterPreview.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
published
 SplitterPreview: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TBIWorkflowEditor
  • VCLBI.Editor.Workflow


TDataSelectorAccess Class

Summary

Represents type TDataSelectorAccess.

Namespace: VCLBI.Editor.Workflow
Inheritance Hierarchy
TForm
VCLBI.DataSelect.TDataSelector
VCLBI.Editor.Workflow.TDataSelectorAccess
Syntax
Delphi
type
 TDataSelectorAccess=class(TDataSelector);
See Also

Reference

  • VCLBI.Editor.Workflow


TWorkflowItemAccess Class

Summary

Represents type TWorkflowItemAccess.

Namespace: VCLBI.Editor.Workflow
Inheritance Hierarchy
TCollectionItem
BI.CollectionItem.TDataCollectionItem
BI.Workflow.TWorkflowItem
VCLBI.Editor.Workflow.TWorkflowItemAccess
Syntax
Delphi
type
 TWorkflowItemAccess=class(TWorkflowItem);
See Also

Reference

  • VCLBI.Editor.Workflow


VCLBI.Editor.Workflow Constants

Constants
Name | Description
DummyNode | Represents constant DummyNode.
Top


DummyNode Constant

Summary

Represents constant DummyNode.

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
 DummyNode='(_pending_)';

Value

Type: string

See Also

Reference

  • VCLBI.Editor.Workflow


VCLBI.Editor.Workflow Routines

Routines
Name | Description
NamesOf(TDataArray) | Represents method NamesOf(TDataArray).
Top


NamesOf(TDataArray) Method

Summary

Represents method NamesOf(TDataArray).

Namespace: VCLBI.Editor.Workflow
Syntax
Delphi
function NamesOf(const AItems:TDataArray):TStringArray;

Parameters

AItems
Type: TDataArray

Return Value

Type: TStringArray

See Also

Reference

  • VCLBI.Editor.Workflow


VCLBI.Editor.WorkflowItem Namespace

Summary

Represents namespace VCLBI.Editor.WorkflowItem.

Classes
Name | Description
TDataProviderAccess | Represents type TDataProviderAccess.
TWorkflowItemEditor | Represents type TWorkflowItemEditor.
Top
Routines
Name | Description
AddKinds(TStrings) | Represents method AddKinds(TStrings).
Top


VCLBI.Editor.WorkflowItem Classes

Classes
Name | Description
TDataProviderAccess | Represents type TDataProviderAccess.
TWorkflowItemEditor | Represents type TWorkflowItemEditor.
Top


TDataProviderAccess Class

Summary

Represents type TDataProviderAccess.

Namespace: VCLBI.Editor.WorkflowItem
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
VCLBI.Editor.WorkflowItem.TDataProviderAccess
Syntax
Delphi
type
 TDataProviderAccess=class(TDataProvider);
See Also

Reference

  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor Class

Summary

Represents type TWorkflowItemEditor.

Namespace: VCLBI.Editor.WorkflowItem
Inheritance Hierarchy
TForm
VCLBI.Editor.WorkflowItem.TWorkflowItemEditor
Syntax
Delphi
type
 TWorkflowItemEditor = class(TForm)
 end;

The TWorkflowItemEditor type exposes the following members.

Methods
Show:
Name | Description
BEditFilterClick(TObject) | Represents method BEditFilterClick(TObject).
BEditQueryClick(TObject) | Represents method BEditQueryClick(TObject).
CBKindChange(TObject) | Represents method CBKindChange(TObject).
EAddChange(TObject) | Represents method EAddChange(TObject).
Embedd(TComponent,TWinControl) | Represents method Embedd(TComponent,TWinControl).
ENewNameChange(TObject) | Represents method ENewNameChange(TObject).
ERowChange(TObject) | Represents method ERowChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
HasContent | Represents method HasContent.
ItemNamesChange(TObject) | Represents method ItemNamesChange(TObject).
MemoSQLChange(TObject) | Represents method MemoSQLChange(TObject).
Refresh(TWorkflowItem) | Represents method Refresh(TWorkflowItem).
TBRowChange(TObject) | Represents method TBRowChange(TObject).
Top
Fields
Show:
Name | Description
BEditFilter | Represents field BEditFilter.
BEditQuery | Represents field BEditQuery.
CBKind | Represents field CBKind.
DeleteItemNames | Represents field DeleteItemNames.
EAdd | Represents field EAdd.
ENewName | Represents field ENewName.
ERow | Represents field ERow.
ItemNames | Represents field ItemNames.
Label1 | Represents field Label1.
LError | Represents field LError.
MemoSQL | Represents field MemoSQL.
PageControl1 | Represents field PageControl1.
Panel1 | Represents field Panel1.
TabAdd | Represents field TabAdd.
TabDelete | Represents field TabDelete.
TabFilter | Represents field TabFilter.
TabNeeds | Represents field TabNeeds.
TabQuery | Represents field TabQuery.
TabRename | Represents field TabRename.
TabSingleRow | Represents field TabSingleRow.
TBRow | Represents field TBRow.
UDRow | Represents field UDRow.
Top
See Also

Reference

  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor Methods

Methods
Name | Description
BEditFilterClick(TObject) | Represents method BEditFilterClick(TObject).
BEditQueryClick(TObject) | Represents method BEditQueryClick(TObject).
CBKindChange(TObject) | Represents method CBKindChange(TObject).
EAddChange(TObject) | Represents method EAddChange(TObject).
Embedd(TComponent,TWinControl) | Represents method Embedd(TComponent,TWinControl).
ENewNameChange(TObject) | Represents method ENewNameChange(TObject).
ERowChange(TObject) | Represents method ERowChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
HasContent | Represents method HasContent.
ItemNamesChange(TObject) | Represents method ItemNamesChange(TObject).
MemoSQLChange(TObject) | Represents method MemoSQLChange(TObject).
Refresh(TWorkflowItem) | Represents method Refresh(TWorkflowItem).
TBRowChange(TObject) | Represents method TBRowChange(TObject).
Top


TWorkflowItemEditor.BEditFilterClick(TObject) Method

Summary

Represents method BEditFilterClick(TObject).

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 procedure BEditFilterClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.BEditQueryClick(TObject) Method

Summary

Represents method BEditQueryClick(TObject).

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 procedure BEditQueryClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.CBKindChange(TObject) Method

Summary

Represents method CBKindChange(TObject).

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 procedure CBKindChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.EAddChange(TObject) Method

Summary

Represents method EAddChange(TObject).

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 procedure EAddChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.Embedd(TComponent,TWinControl) Method

Summary

Represents method Embedd(TComponent,TWinControl).

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl):TWorkflowItemEditor; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

Return Value

Type: TWorkflowItemEditor

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.ENewNameChange(TObject) Method

Summary

Represents method ENewNameChange(TObject).

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 procedure ENewNameChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.ERowChange(TObject) Method

Summary

Represents method ERowChange(TObject).

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 procedure ERowChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.HasContent Method

Summary

Represents method HasContent.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
public
 function HasContent:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.ItemNamesChange(TObject) Method

Summary

Represents method ItemNamesChange(TObject).

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 procedure ItemNamesChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.MemoSQLChange(TObject) Method

Summary

Represents method MemoSQLChange(TObject).

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 procedure MemoSQLChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.Refresh(TWorkflowItem) Method

Summary

Represents method Refresh(TWorkflowItem).

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
public
 procedure Refresh(const AItem:TWorkflowItem);

Parameters

AItem
Type: TWorkflowItem

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.TBRowChange(TObject) Method

Summary

Represents method TBRowChange(TObject).

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 procedure TBRowChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor Fields

Fields
Name | Description
BEditFilter | Represents field BEditFilter.
BEditQuery | Represents field BEditQuery.
CBKind | Represents field CBKind.
DeleteItemNames | Represents field DeleteItemNames.
EAdd | Represents field EAdd.
ENewName | Represents field ENewName.
ERow | Represents field ERow.
ItemNames | Represents field ItemNames.
Label1 | Represents field Label1.
LError | Represents field LError.
MemoSQL | Represents field MemoSQL.
PageControl1 | Represents field PageControl1.
Panel1 | Represents field Panel1.
TabAdd | Represents field TabAdd.
TabDelete | Represents field TabDelete.
TabFilter | Represents field TabFilter.
TabNeeds | Represents field TabNeeds.
TabQuery | Represents field TabQuery.
TabRename | Represents field TabRename.
TabSingleRow | Represents field TabSingleRow.
TBRow | Represents field TBRow.
UDRow | Represents field UDRow.
Top


TWorkflowItemEditor.BEditFilter Field

Summary

Represents field BEditFilter.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 BEditFilter: TButton;

Field Value

Type: TButton

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.BEditQuery Field

Summary

Represents field BEditQuery.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 BEditQuery: TButton;

Field Value

Type: TButton

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.CBKind Field

Summary

Represents field CBKind.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 CBKind: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.DeleteItemNames Field

Summary

Represents field DeleteItemNames.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 DeleteItemNames: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.EAdd Field

Summary

Represents field EAdd.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 EAdd: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.ENewName Field

Summary

Represents field ENewName.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 ENewName: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.ERow Field

Summary

Represents field ERow.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 ERow: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.ItemNames Field

Summary

Represents field ItemNames.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 ItemNames: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.LError Field

Summary

Represents field LError.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 LError: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.MemoSQL Field

Summary

Represents field MemoSQL.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 MemoSQL: TMemo;

Field Value

Type: TMemo

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.PageControl1 Field

Summary

Represents field PageControl1.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 PageControl1: TPageControl;

Field Value

Type: TPageControl

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.TabAdd Field

Summary

Represents field TabAdd.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 TabAdd: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.TabDelete Field

Summary

Represents field TabDelete.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 TabDelete: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.TabFilter Field

Summary

Represents field TabFilter.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 TabFilter: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.TabNeeds Field

Summary

Represents field TabNeeds.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 TabNeeds: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.TabQuery Field

Summary

Represents field TabQuery.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 TabQuery: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.TabRename Field

Summary

Represents field TabRename.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 TabRename: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.TabSingleRow Field

Summary

Represents field TabSingleRow.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 TabSingleRow: TTabSheet;

Field Value

Type: TTabSheet

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.TBRow Field

Summary

Represents field TBRow.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 TBRow: TTrackBar;

Field Value

Type: TTrackBar

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


TWorkflowItemEditor.UDRow Field

Summary

Represents field UDRow.

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
published
 UDRow: TUpDown;

Field Value

Type: TUpDown

See Also

Reference

  • TWorkflowItemEditor
  • VCLBI.Editor.WorkflowItem


VCLBI.Editor.WorkflowItem Routines

Routines
Name | Description
AddKinds(TStrings) | Represents method AddKinds(TStrings).
Top


AddKinds(TStrings) Method

Summary

Represents method AddKinds(TStrings).

Namespace: VCLBI.Editor.WorkflowItem
Syntax
Delphi
procedure AddKinds(const AItems:TStrings);

Parameters

AItems
Type: TStrings

See Also

Reference

  • VCLBI.Editor.WorkflowItem


VCLBI.Export.RichView Namespace

Summary

Represents namespace VCLBI.Export.RichView.

Records
Name | Description
TDataRichView | Represents type TDataRichView.
Top


VCLBI.Export.RichView Records

Records
Name | Description
TDataRichView | Represents type TDataRichView.
Top


TDataRichView Record

Summary

Represents type TDataRichView.

Namespace: VCLBI.Export.RichView
Syntax
Delphi
type
 TDataRichView=record
 end;

The TDataRichView type exposes the following members.

Methods
Show:
Name | Description
Add(TDataArray,TRichView) | Overloaded. Represents method Add(TDataArray,TRichView).
Add(TDataCursor,TRichView) | Overloaded. Represents method Add(TDataCursor,TRichView).
Add(TDataItem,TRichView) | Overloaded. Represents method Add(TDataItem,TRichView).
DefaultStyle(TRVTableItemInfo) | Represents method DefaultStyle(TRVTableItemInfo).
Top
See Also

Reference

  • VCLBI.Export.RichView


TDataRichView Methods

Methods
Name | Description
Add(TDataArray,TRichView) | Overloaded. Represents method Add(TDataArray,TRichView).
Add(TDataCursor,TRichView) | Overloaded. Represents method Add(TDataCursor,TRichView).
Add(TDataItem,TRichView) | Overloaded. Represents method Add(TDataItem,TRichView).
DefaultStyle(TRVTableItemInfo) | Represents method DefaultStyle(TRVTableItemInfo).
Top


TDataRichView.Add(TDataArray,TRichView) Method

Summary

Represents method Add(TDataArray,TRichView).

Namespace: VCLBI.Export.RichView
Syntax
Delphi
public
 class function Add(const AData:TDataArray; const ARichView:TRichView):TRVTableItemInfo; overload; static;

Parameters

AData
Type: TDataArray

ARichView
Type: TRichView

Return Value

Type: TRVTableItemInfo

See Also

Reference

  • TDataRichView
  • VCLBI.Export.RichView


TDataRichView.Add(TDataCursor,TRichView) Method

Summary

Represents method Add(TDataCursor,TRichView).

Namespace: VCLBI.Export.RichView
Syntax
Delphi
public
 class function Add(const ACursor:TDataCursor; const ARichView:TRichView):TRVTableItemInfo; overload; static;

Parameters

ACursor
Type: TDataCursor

ARichView
Type: TRichView

Return Value

Type: TRVTableItemInfo

See Also

Reference

  • TDataRichView
  • VCLBI.Export.RichView


TDataRichView.Add(TDataItem,TRichView) Method

Summary

Represents method Add(TDataItem,TRichView).

Namespace: VCLBI.Export.RichView
Syntax
Delphi
public
 class function Add(const AData:TDataItem; const ARichView:TRichView):TRVTableItemInfo; overload; static;

Parameters

AData
Type: TDataItem

ARichView
Type: TRichView

Return Value

Type: TRVTableItemInfo

See Also

Reference

  • TDataRichView
  • VCLBI.Export.RichView


TDataRichView.DefaultStyle(TRVTableItemInfo) Method

Summary

Represents method DefaultStyle(TRVTableItemInfo).

Namespace: VCLBI.Export.RichView
Syntax
Delphi
public
 class procedure DefaultStyle(const ATable:TRVTableItemInfo); static;

Parameters

ATable
Type: TRVTableItemInfo

See Also

Reference

  • TDataRichView
  • VCLBI.Export.RichView


VCLBI.Grid Namespace

Summary

Represents namespace VCLBI.Grid.

Classes
Name | Description
TBaseEnabled | Represents type TBaseEnabled.
TBIDatasetAccess | Represents type TBIDatasetAccess.
TBIGrid | Represents type TBIGrid.
TControlAccess | Represents type TControlAccess.
TDataItemAccess | Represents type TDataItemAccess.
TDataProviderAccess | Represents type TDataProviderAccess.
TGridFilters | Represents type TGridFilters.
TGridSearch | Represents type TGridSearch.
TPluginAccess | Represents type TPluginAccess.
TRowNumbers | Represents type TRowNumbers.
Top
Records
Name | Description
TUICommon | Represents type TUICommon.
Top
Enumerations
Name | Description
TGridShowItems | Represents type TGridShowItems.
Top
Delegates
Name | Description
TDiagramEvent | Represents type TDiagramEvent.
Top
Constants
Name | Description
EditorsKey | Represents constant EditorsKey.
Top
Routines
Name | Description
InternalShowMessage(String) | Represents method InternalShowMessage(String).
Top


VCLBI.Grid Classes

Classes
Name | Description
TBaseEnabled | Represents type TBaseEnabled.
TBIDatasetAccess | Represents type TBIDatasetAccess.
TBIGrid | Represents type TBIGrid.
TControlAccess | Represents type TControlAccess.
TDataItemAccess | Represents type TDataItemAccess.
TDataProviderAccess | Represents type TDataProviderAccess.
TGridFilters | Represents type TGridFilters.
TGridSearch | Represents type TGridSearch.
TPluginAccess | Represents type TPluginAccess.
TRowNumbers | Represents type TRowNumbers.
Top


TBaseEnabled Class

Summary

Represents type TBaseEnabled.

Namespace: VCLBI.Grid
Inheritance Hierarchy
TPersistent
VCLBI.Grid.TBaseEnabled
VCLBI.Grid.TGridFilters
VCLBI.Grid.TGridSearch
VCLBI.Grid.TRowNumbers
Syntax
Delphi
type
 TBaseEnabled=class(TPersistent)
 end;

The TBaseEnabled type exposes the following members.

Properties
Show:
Name | Description
Enabled | Represents property Enabled.
Top
See Also

Reference

  • VCLBI.Grid


TBaseEnabled Properties

Properties
Name | Description
Enabled | Represents property Enabled.
Top


TBaseEnabled.Enabled Property

Summary

Represents property Enabled.

Namespace: VCLBI.Grid
Syntax
Delphi
published
 property Enabled:Boolean read FEnabled write SetEnabled default False;

Property Value

Type: Boolean

See Also

Reference

  • TBaseEnabled
  • VCLBI.Grid


TBIDatasetAccess Class

Summary

Represents type TBIDatasetAccess.

Namespace: VCLBI.Grid
Inheritance Hierarchy
TDataSet
BI.Dataset.TBICustomDataSet
BI.Dataset.TBIDataset
VCLBI.Grid.TBIDatasetAccess
Syntax
Delphi
type
 TBIDatasetAccess=class(TBIDataset);
See Also

Reference

  • VCLBI.Grid


TBIGrid Class

Summary

Represents type TBIGrid.

Namespace: VCLBI.Grid
Inheritance Hierarchy
TWinControl
VCLBI.DataControl.TBIDataControl
VCLBI.Grid.TBIGrid
Syntax
Delphi
type
 TBIGrid = class(TBIDataControl)
 end;

The TBIGrid type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIGrid class. (Overrides TBIDataControl.Create(TComponent).)
Destroy | Represents the destructor of the TBIGrid class. (Overrides TBIDataControl.Destroy.)
Top
Properties
Show:
Name | Description
Alternate | Represents property Alternate.
CurrentRow | Represents property CurrentRow.
DataSource | Represents property DataSource.
Filter | Represents property Filter.
Filters | Represents property Filters.
OnDataChange | Represents property OnDataChange.
OnUpdateData | Represents property OnUpdateData.
Plugin | Represents property Plugin.
ReadOnly | Represents property ReadOnly.
RowNumbers | Represents property RowNumbers.
Search | Represents property Search.
ShowItems | Represents property ShowItems.
Totals | Represents property Totals.
Top
Methods
Show:
Name | Description
BindTo(TDataItem) | Represents method BindTo(TDataItem).
Colorize(TDataColorizers) | Represents method Colorize(TDataColorizers).
Duplicates(TDataItem,Boolean) | Represents method Duplicates(TDataItem,Boolean).
Invalidate | Represents method Invalidate.
SetDataDirect(TDataItem) | Represents method SetDataDirect(TDataItem). (Overrides TBIDataControl.SetDataDirect(TDataItem).)
SubGrid | Represents method SubGrid.
SubItem | Represents method SubItem.
UpdatedDataValues | Represents method UpdatedDataValues. (Overrides TBIDataControl.UpdatedDataValues.)
Top
Fields
Show:
Name | Description
Engine | Represents field Engine.
Top
See Also

Reference

  • VCLBI.Grid


TBIGrid.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIGrid class.

Namespace: VCLBI.Grid
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TBIDataControl.Create(TComponent)
See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid.Destroy Destructor

Summary

Represents the destructor of the TBIGrid class.

Namespace: VCLBI.Grid
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TBIDataControl.Destroy
See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid Properties

Properties
Name | Description
Alternate | Represents property Alternate.
CurrentRow | Represents property CurrentRow.
DataSource | Represents property DataSource.
Filter | Represents property Filter.
Filters | Represents property Filters.
OnDataChange | Represents property OnDataChange.
OnUpdateData | Represents property OnUpdateData.
Plugin | Represents property Plugin.
ReadOnly | Represents property ReadOnly.
RowNumbers | Represents property RowNumbers.
Search | Represents property Search.
ShowItems | Represents property ShowItems.
Totals | Represents property Totals.
Top


TBIGrid.Alternate Property

Summary

Represents property Alternate.

Namespace: VCLBI.Grid
Syntax
Delphi
published
 property Alternate:TAlternateColor read FAlternate write SetAlternate;

Property Value

Type: TAlternateColor

See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid.CurrentRow Property

Summary

Represents property CurrentRow.

Namespace: VCLBI.Grid
Syntax
Delphi
public
 property CurrentRow:Integer read GetCurrentRow write SetCurrentRow;

Property Value

Type: Integer

See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid.DataSource Property

Summary

Represents property DataSource.

Namespace: VCLBI.Grid
Syntax
Delphi
published
 property DataSource:TDataSource read GetDataSource write SetDataSource;

Property Value

Type: TDataSource

See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid.Filter Property

Summary

Represents property Filter.

Namespace: VCLBI.Grid
Syntax
Delphi
public
 property Filter:TExpression read GetFilter write SetFilter;

Property Value

Type: TExpression

See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid.Filters Property

Summary

Represents property Filters.

Namespace: VCLBI.Grid
Syntax
Delphi
published
 property Filters:TGridFilters read FGridFilters write SetGridFilters;

Property Value

Type: TGridFilters

See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid.OnDataChange Property

Summary

Represents property OnDataChange.

Namespace: VCLBI.Grid
Syntax
Delphi
published
 property OnDataChange:TNotifyEvent read FOnDataChange write FOnDataChange;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid.OnUpdateData Property

Summary

Represents property OnUpdateData.

Namespace: VCLBI.Grid
Syntax
Delphi
published
 property OnUpdateData:TNotifyEvent read FOnUpdateData write FOnUpdateData;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid.Plugin Property

Summary

Represents property Plugin.

Namespace: VCLBI.Grid
Syntax
Delphi
public
 property Plugin:TBIGridPlugin read IPlugin write SetPlugin;

Property Value

Type: TBIGridPlugin

See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid.ReadOnly Property

Summary

Represents property ReadOnly.

Namespace: VCLBI.Grid
Syntax
Delphi
published
 property ReadOnly:Boolean read GetReadOnly write SetReadOnly default True;

Property Value

Type: Boolean

See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid.RowNumbers Property

Summary

Represents property RowNumbers.

Namespace: VCLBI.Grid
Syntax
Delphi
published
 property RowNumbers:TRowNumbers read FRowNumbers write SetRowNumbers;

Property Value

Type: TRowNumbers

See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid.Search Property

Summary

Represents property Search.

Namespace: VCLBI.Grid
Syntax
Delphi
published
 property Search:TGridSearch read FSearch write SetSearch;

Property Value

Type: TGridSearch

See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid.ShowItems Property

Summary

Represents property ShowItems.

Namespace: VCLBI.Grid
Syntax
Delphi
published
 property ShowItems:TGridShowItems read FShowItems write SetShowItems default TGridShowItems.Automatic;

Property Value

Type: TGridShowItems

See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid.Totals Property

Summary

Represents property Totals.

Namespace: VCLBI.Grid
Syntax
Delphi
published
 property Totals:Boolean read GetTotals write SetTotals default False;

Property Value

Type: Boolean

See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid Methods

Methods
Name | Description
BindTo(TDataItem) | Represents method BindTo(TDataItem).
Colorize(TDataColorizers) | Represents method Colorize(TDataColorizers).
Duplicates(TDataItem,Boolean) | Represents method Duplicates(TDataItem,Boolean).
Invalidate | Represents method Invalidate.
SetDataDirect(TDataItem) | Represents method SetDataDirect(TDataItem). (Overrides TBIDataControl.SetDataDirect(TDataItem).)
SubGrid | Represents method SubGrid.
SubItem | Represents method SubItem.
UpdatedDataValues | Represents method UpdatedDataValues. (Overrides TBIDataControl.UpdatedDataValues.)
Top


TBIGrid.BindTo(TDataItem) Method

Summary

Represents method BindTo(TDataItem).

Namespace: VCLBI.Grid
Syntax
Delphi
public
 procedure BindTo(const AData:TDataItem);

Parameters

AData
Type: TDataItem

See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid.Colorize(TDataColorizers) Method

Summary

Represents method Colorize(TDataColorizers).

Namespace: VCLBI.Grid
Syntax
Delphi
public
 procedure Colorize(const AItems:TDataColorizers);

Parameters

AItems
Type: TDataColorizers

See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid.Duplicates(TDataItem,Boolean) Method

Summary

Represents method Duplicates(TDataItem,Boolean).

Namespace: VCLBI.Grid
Syntax
Delphi
public
 procedure Duplicates(const AData:TDataItem; const Hide:Boolean);

Parameters

AData
Type: TDataItem

Hide
Type: Boolean

See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid.Invalidate Method

Summary

Represents method Invalidate.

Namespace: VCLBI.Grid
Syntax
Delphi
public
 procedure Invalidate; override;
See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid.SetDataDirect(TDataItem) Method

Summary

Represents method SetDataDirect(TDataItem).

Namespace: VCLBI.Grid
Syntax
Delphi
protected
 procedure SetDataDirect(const Value: TDataItem); override;

Parameters

Value
Type: TDataItem

Overrides

TBIDataControl.SetDataDirect(TDataItem)
See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid.SubGrid Method

Summary

Represents method SubGrid.

Namespace: VCLBI.Grid
Syntax
Delphi
protected
 function SubGrid:TBIGridPlugin;

Return Value

Type: TBIGridPlugin

See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid.SubItem Method

Summary

Represents method SubItem.

Namespace: VCLBI.Grid
Syntax
Delphi
protected
 function SubItem:TDataItem;

Return Value

Type: TDataItem

See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid.UpdatedDataValues Method

Summary

Represents method UpdatedDataValues.

Namespace: VCLBI.Grid
Syntax
Delphi
protected
 procedure UpdatedDataValues; override;

Overrides

TBIDataControl.UpdatedDataValues
See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TBIGrid.Engine Field

Summary

Represents field Engine.

Namespace: VCLBI.Grid
Syntax
Delphi
public
 class var
 Engine : TBIGridPluginClass;

Field Value

Type: TBIGridPluginClass

See Also

Reference

  • TBIGrid
  • VCLBI.Grid


TControlAccess Class

Summary

Represents type TControlAccess.

Namespace: VCLBI.Grid
Inheritance Hierarchy
TControl
VCLBI.Grid.TControlAccess
Syntax
Delphi
type
 TControlAccess=class(TControl);
See Also

Reference

  • VCLBI.Grid


TDataItemAccess Class

Summary

Represents type TDataItemAccess.

Namespace: VCLBI.Grid
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
VCLBI.Grid.TDataItemAccess
Syntax
Delphi
type
 TDataItemAccess=class(TDataItem);
See Also

Reference

  • VCLBI.Grid


TDataProviderAccess Class

Summary

Represents type TDataProviderAccess.

Namespace: VCLBI.Grid
Inheritance Hierarchy
TComponent
BI.DataItem.TDataProvider
VCLBI.Grid.TDataProviderAccess
Syntax
Delphi
type
 TDataProviderAccess=class(TDataProvider);
See Also

Reference

  • VCLBI.Grid


TGridFilters Class

Summary

Represents type TGridFilters.

Namespace: VCLBI.Grid
Inheritance Hierarchy
TPersistent
VCLBI.Grid.TBaseEnabled
VCLBI.Grid.TGridFilters
Syntax
Delphi
type
 TGridFilters=class(TBaseEnabled)
 end;

The TGridFilters type exposes the following members.

Methods
Show:
Name | Description
SetEnabled(Boolean) | Represents method SetEnabled(Boolean). (Overrides TBaseEnabled.SetEnabled(Boolean).)
Top
See Also

Reference

  • VCLBI.Grid


TGridFilters Methods

Methods
Name | Description
SetEnabled(Boolean) | Represents method SetEnabled(Boolean). (Overrides TBaseEnabled.SetEnabled(Boolean).)
Top


TGridFilters.SetEnabled(Boolean) Method

Summary

Represents method SetEnabled(Boolean).

Namespace: VCLBI.Grid
Syntax
Delphi
protected
 procedure SetEnabled(const Value: Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBaseEnabled.SetEnabled(Boolean)
See Also

Reference

  • TGridFilters
  • VCLBI.Grid


TGridSearch Class

Summary

Represents type TGridSearch.

Namespace: VCLBI.Grid
Inheritance Hierarchy
TPersistent
VCLBI.Grid.TBaseEnabled
VCLBI.Grid.TGridSearch
Syntax
Delphi
type
 TGridSearch=class(TBaseEnabled)
 end;

The TGridSearch type exposes the following members.

Methods
Show:
Name | Description
SetEnabled(Boolean) | Represents method SetEnabled(Boolean). (Overrides TBaseEnabled.SetEnabled(Boolean).)
Top
See Also

Reference

  • VCLBI.Grid


TGridSearch Methods

Methods
Name | Description
SetEnabled(Boolean) | Represents method SetEnabled(Boolean). (Overrides TBaseEnabled.SetEnabled(Boolean).)
Top


TGridSearch.SetEnabled(Boolean) Method

Summary

Represents method SetEnabled(Boolean).

Namespace: VCLBI.Grid
Syntax
Delphi
protected
 procedure SetEnabled(const Value: Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBaseEnabled.SetEnabled(Boolean)
See Also

Reference

  • TGridSearch
  • VCLBI.Grid


TPluginAccess Class

Summary

Represents type TPluginAccess.

Namespace: VCLBI.Grid
Inheritance Hierarchy
TObject
BI.Grid.Plugin.TBIGridPlugin
VCLBI.Grid.TPluginAccess
Syntax
Delphi
type
 TPluginAccess=class(TBIGridPlugin);
See Also

Reference

  • VCLBI.Grid


TRowNumbers Class

Summary

Represents type TRowNumbers.

Namespace: VCLBI.Grid
Inheritance Hierarchy
TPersistent
VCLBI.Grid.TBaseEnabled
VCLBI.Grid.TRowNumbers
Syntax
Delphi
type
 TRowNumbers=class(TBaseEnabled)
 end;

The TRowNumbers type exposes the following members.

Methods
Show:
Name | Description
SetEnabled(Boolean) | Represents method SetEnabled(Boolean). (Overrides TBaseEnabled.SetEnabled(Boolean).)
Top
See Also

Reference

  • VCLBI.Grid


TRowNumbers Methods

Methods
Name | Description
SetEnabled(Boolean) | Represents method SetEnabled(Boolean). (Overrides TBaseEnabled.SetEnabled(Boolean).)
Top


TRowNumbers.SetEnabled(Boolean) Method

Summary

Represents method SetEnabled(Boolean).

Namespace: VCLBI.Grid
Syntax
Delphi
protected
 procedure SetEnabled(const Value: Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBaseEnabled.SetEnabled(Boolean)
See Also

Reference

  • TRowNumbers
  • VCLBI.Grid


VCLBI.Grid Records

Records
Name | Description
TUICommon | Represents type TUICommon.
Top


TUICommon Record

Summary

Represents type TUICommon.

Namespace: VCLBI.Grid
Syntax
Delphi
type
 TUICommon=record
 end;

The TUICommon type exposes the following members.

Constants
Show:
Name | Description
AlignBottom | Represents constant AlignBottom.
AlignClient | Represents constant AlignClient.
AlignLeft | Represents constant AlignLeft.
AlignNone | Represents constant AlignNone.
AlignRight | Represents constant AlignRight.
AlignTop | Represents constant AlignTop.
Top
Methods
Show:
Name | Description
AddForm(TCustomForm,TWinControl) | Represents method AddForm(TCustomForm,TWinControl).
AutoTest | Represents method AutoTest.
EditColor(TComponent,TColor,TColor) | Represents method EditColor(TComponent,TColor,TColor).
GotoURL(TWinControl,String) | Represents method GotoURL(TWinControl,String).
Input(String,String,String,String) | Represents method Input(String,String,String,String).
LoadPosition(TCustomForm,String) | Overloaded. Represents method LoadPosition(TCustomForm,String).
LoadPosition(TCustomForm,String,String) | Overloaded. Represents method LoadPosition(TCustomForm,String,String).
Point(Integer,Integer) | Represents method Point(Integer,Integer).
SavePosition(TCustomForm,String) | Overloaded. Represents method SavePosition(TCustomForm,String).
SavePosition(TCustomForm,String,String) | Overloaded. Represents method SavePosition(TCustomForm,String,String).
SelectFolder(String) | Represents method SelectFolder(String).
ShowUnique(TTabSheet) | Represents method ShowUnique(TTabSheet).
YesNo(String) | Represents method YesNo(String).
Top
Fields
Show:
Name | Description
Diagram | Represents field Diagram.
Top
See Also

Reference

  • VCLBI.Grid


TUICommon.AlignBottom Constant

Summary

Represents constant AlignBottom.

Namespace: VCLBI.Grid
Syntax
Delphi
public
 AlignBottom=TAlign.alBottom;

Value

Type: Void

See Also

Reference

  • TUICommon
  • VCLBI.Grid


TUICommon.AlignClient Constant

Summary

Represents constant AlignClient.

Namespace: VCLBI.Grid
Syntax
Delphi
public
 AlignClient=TAlign.alClient;

Value

Type: Void

See Also

Reference

  • TUICommon
  • VCLBI.Grid


TUICommon.AlignLeft Constant

Summary

Represents constant AlignLeft.

Namespace: VCLBI.Grid
Syntax
Delphi
public
 AlignLeft=TAlign.alLeft;

Value

Type: Void

See Also

Reference

  • TUICommon
  • VCLBI.Grid


TUICommon.AlignNone Constant

Summary

Represents constant AlignNone.

Namespace: VCLBI.Grid
Syntax
Delphi
public
 AlignNone=TAlign.alNone;

Value

Type: Void

See Also

Reference

  • TUICommon
  • VCLBI.Grid


TUICommon.AlignRight Constant

Summary

Represents constant AlignRight.

Namespace: VCLBI.Grid
Syntax
Delphi
public
 AlignRight=TAlign.alRight;

Value

Type: Void

See Also

Reference

  • TUICommon
  • VCLBI.Grid


TUICommon.AlignTop Constant

Summary

Represents constant AlignTop.

Namespace: VCLBI.Grid
Syntax
Delphi
public
 AlignTop=TAlign.alTop;

Value

Type: Void

See Also

Reference

  • TUICommon
  • VCLBI.Grid


TUICommon Methods

Methods
Name | Description
AddForm(TCustomForm,TWinControl) | Represents method AddForm(TCustomForm,TWinControl).
AutoTest | Represents method AutoTest.
EditColor(TComponent,TColor,TColor) | Represents method EditColor(TComponent,TColor,TColor).
GotoURL(TWinControl,String) | Represents method GotoURL(TWinControl,String).
Input(String,String,String,String) | Represents method Input(String,String,String,String).
LoadPosition(TCustomForm,String) | Overloaded. Represents method LoadPosition(TCustomForm,String).
LoadPosition(TCustomForm,String,String) | Overloaded. Represents method LoadPosition(TCustomForm,String,String).
Point(Integer,Integer) | Represents method Point(Integer,Integer).
SavePosition(TCustomForm,String) | Overloaded. Represents method SavePosition(TCustomForm,String).
SavePosition(TCustomForm,String,String) | Overloaded. Represents method SavePosition(TCustomForm,String,String).
SelectFolder(String) | Represents method SelectFolder(String).
ShowUnique(TTabSheet) | Represents method ShowUnique(TTabSheet).
YesNo(String) | Represents method YesNo(String).
Top


TUICommon.AddForm(TCustomForm,TWinControl) Method

Summary

Represents method AddForm(TCustomForm,TWinControl).

Namespace: VCLBI.Grid
Syntax
Delphi
public
 class procedure AddForm(const AForm: TCustomForm; const AParent: TWinControl); static;

Parameters

AForm
Type: TCustomForm

AParent
Type: TWinControl

See Also

Reference

  • TUICommon
  • VCLBI.Grid


TUICommon.AutoTest Method

Summary

Represents method AutoTest.

Namespace: VCLBI.Grid
Syntax
Delphi
public
 class function AutoTest:Boolean; static;

Return Value

Type: Boolean

See Also

Reference

  • TUICommon
  • VCLBI.Grid


TUICommon.EditColor(TComponent,TColor,TColor) Method

Summary

Represents method EditColor(TComponent,TColor,TColor).

Namespace: VCLBI.Grid
Syntax
Delphi
public
 class function EditColor(const AOwner:TComponent; const AColor:TColor; out ANew:TColor):Boolean; static;

Parameters

AOwner
Type: TComponent

AColor
Type: TColor

ANew
Type: TColor

Return Value

Type: Boolean

See Also

Reference

  • TUICommon
  • VCLBI.Grid


TUICommon.GotoURL(TWinControl,String) Method

Summary

Represents method GotoURL(TWinControl,String).

Namespace: VCLBI.Grid
Syntax
Delphi
public
 class procedure GotoURL(const AOwner:TWinControl; const AURL:String); static;

Parameters

AOwner
Type: TWinControl

AURL
Type: String

See Also

Reference

  • TUICommon
  • VCLBI.Grid


TUICommon.Input(String,String,String,String) Method

Summary

Represents method Input(String,String,String,String).

Namespace: VCLBI.Grid
Syntax
Delphi
public
 class function Input(const ATitle,ACaption,ADefault:String; out ANew:String):Boolean; static;

Parameters

ATitle
Type: String

ACaption
Type: String

ADefault
Type: String

ANew
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TUICommon
  • VCLBI.Grid


TUICommon.LoadPosition(TCustomForm,String) Method

Summary

Represents method LoadPosition(TCustomForm,String).

Namespace: VCLBI.Grid
Syntax
Delphi
public
 class procedure LoadPosition(const AForm:TCustomForm; const Key:String); overload; static;

Parameters

AForm
Type: TCustomForm

Key
Type: String

See Also

Reference

  • TUICommon
  • VCLBI.Grid


TUICommon.LoadPosition(TCustomForm,String,String) Method

Summary

Represents method LoadPosition(TCustomForm,String,String).

Namespace: VCLBI.Grid
Syntax
Delphi
public
 class procedure LoadPosition(const AForm:TCustomForm; const Parent,Key:String); overload; static;

Parameters

AForm
Type: TCustomForm

Parent
Type: String

Key
Type: String

See Also

Reference

  • TUICommon
  • VCLBI.Grid


TUICommon.Point(Integer,Integer) Method

Summary

Represents method Point(Integer,Integer).

Namespace: VCLBI.Grid
Syntax
Delphi
public
 class function Point(const X,Y:Integer):TPoint; static; inline;

Parameters

X
Type: Integer

Y
Type: Integer

Return Value

Type: TPoint

See Also

Reference

  • TUICommon
  • VCLBI.Grid


TUICommon.SavePosition(TCustomForm,String) Method

Summary

Represents method SavePosition(TCustomForm,String).

Namespace: VCLBI.Grid
Syntax
Delphi
public
 class procedure SavePosition(const AForm:TCustomForm; const Key:String); overload; static;

Parameters

AForm
Type: TCustomForm

Key
Type: String

See Also

Reference

  • TUICommon
  • VCLBI.Grid


TUICommon.SavePosition(TCustomForm,String,String) Method

Summary

Represents method SavePosition(TCustomForm,String,String).

Namespace: VCLBI.Grid
Syntax
Delphi
public
 class procedure SavePosition(const AForm:TCustomForm; const Parent,Key:String); overload; static;

Parameters

AForm
Type: TCustomForm

Parent
Type: String

Key
Type: String

See Also

Reference

  • TUICommon
  • VCLBI.Grid


TUICommon.SelectFolder(String) Method

Summary

Represents method SelectFolder(String).

Namespace: VCLBI.Grid
Syntax
Delphi
public
 class function SelectFolder(var AFolder:String):Boolean; static;

Parameters

AFolder
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TUICommon
  • VCLBI.Grid


TUICommon.ShowUnique(TTabSheet) Method

Summary

Represents method ShowUnique(TTabSheet).

Namespace: VCLBI.Grid
Syntax
Delphi
public
 class procedure ShowUnique(const ATab:TTabSheet); static;

Parameters

ATab
Type: TTabSheet

See Also

Reference

  • TUICommon
  • VCLBI.Grid


TUICommon.YesNo(String) Method

Summary

Represents method YesNo(String).

Namespace: VCLBI.Grid
Syntax
Delphi
public
 class function YesNo(const Message:String):Boolean; static;

Parameters

Message
Type: String

Return Value

Type: Boolean

See Also

Reference

  • TUICommon
  • VCLBI.Grid


TUICommon Fields

Fields
Name | Description
Diagram | Represents field Diagram.
Top


TUICommon.Diagram Field

Summary

Represents field Diagram.

Namespace: VCLBI.Grid
Syntax
Delphi
public
 class var Diagram : TDiagramEvent;

Field Value

Type: TDiagramEvent

See Also

Reference

  • TUICommon
  • VCLBI.Grid


VCLBI.Grid Enumerations

Enumerations
Name | Description
TGridShowItems | Represents type TGridShowItems.
Top


TGridShowItems Enumeration

Summary

Represents type TGridShowItems.

Namespace: VCLBI.Grid
Syntax
Delphi
type
 TGridShowItems=(Automatic, Yes, No);

The TGridShowItems type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
No | Represents constant No.
Yes | Represents constant Yes.
Top
See Also

Reference

  • VCLBI.Grid


VCLBI.Grid Delegates

Delegates
Name | Description
TDiagramEvent | Represents type TDiagramEvent.
Top


TDiagramEvent Delegate

Summary

Represents type TDiagramEvent.

Namespace: VCLBI.Grid
Syntax
Delphi
type
 TDiagramEvent=procedure(const AOwner:TComponent; const AData:TDataItem);
See Also

Reference

  • VCLBI.Grid


VCLBI.Grid Constants

Constants
Name | Description
EditorsKey | Represents constant EditorsKey.
Top


EditorsKey Constant

Summary

Represents constant EditorsKey.

Namespace: VCLBI.Grid
Syntax
Delphi
 EditorsKey='Editors';

Value

Type: string

See Also

Reference

  • VCLBI.Grid


VCLBI.Grid Routines

Routines
Name | Description
InternalShowMessage(String) | Represents method InternalShowMessage(String).
Top


InternalShowMessage(String) Method

Summary

Represents method InternalShowMessage(String).

Namespace: VCLBI.Grid
Syntax
Delphi
procedure InternalShowMessage(const AText:String);

Parameters

AText
Type: String

See Also

Reference

  • VCLBI.Grid


VCLBI.Grid.DBGrid Namespace

Summary

Represents namespace VCLBI.Grid.DBGrid.

Classes
Name | Description
TBIDatasetAccess | Represents type TBIDatasetAccess.
TBIDBGrid | Represents type TBIDBGrid.
TBIDBGridColumns | Represents type TBIDBGridColumns.
TBIDBGridPlugin | Represents type TBIDBGridPlugin.
TDataAccess | Represents type TDataAccess.
TFilterGrid | Represents type TFilterGrid.
Top
Records
Name | Description
TColumnFormat | Represents type TColumnFormat.
TSearchValue | Represents type TSearchValue.
TSearchValues | Represents type TSearchValues.
Top
Types
Name | Description
TSearchValueArray | Represents an array of the TSearchValue type.
Top
Constants
Name | Description
BIMenu_AlternateRows | Represents constant BIMenu_AlternateRows.
BIMenu_Close | Represents constant BIMenu_Close.
BIMenu_ColorizeColumns | Represents constant BIMenu_ColorizeColumns.
BIMenu_ColumnFilters | Represents constant BIMenu_ColumnFilters.
BIMenu_ColumnSort | Represents constant BIMenu_ColumnSort.
BIMenu_Detail | Represents constant BIMenu_Detail.
BIMenu_Export | Represents constant BIMenu_Export.
BIMenu_GroupBy | Represents constant BIMenu_GroupBy.
BIMenu_RowNumbers | Represents constant BIMenu_RowNumbers.
BIMenu_Search | Represents constant BIMenu_Search.
Top


VCLBI.Grid.DBGrid Classes

Classes
Name | Description
TBIDatasetAccess | Represents type TBIDatasetAccess.
TBIDBGrid | Represents type TBIDBGrid.
TBIDBGridColumns | Represents type TBIDBGridColumns.
TBIDBGridPlugin | Represents type TBIDBGridPlugin.
TDataAccess | Represents type TDataAccess.
TFilterGrid | Represents type TFilterGrid.
Top


TBIDatasetAccess Class

Summary

Represents type TBIDatasetAccess.

Namespace: VCLBI.Grid.DBGrid
Inheritance Hierarchy
TDataSet
BI.Dataset.TBICustomDataSet
BI.Dataset.TBIDataset
VCLBI.Grid.DBGrid.TBIDatasetAccess
Syntax
Delphi
type
 TBIDatasetAccess=class(TBIDataset);
See Also

Reference

  • VCLBI.Grid.DBGrid


TBIDBGrid Class

Summary

Represents type TBIDBGrid.

Namespace: VCLBI.Grid.DBGrid
Inheritance Hierarchy
TDBGrid
VCLBI.Grid.DBGrid.TBIDBGrid
Syntax
Delphi
type
 TBIDBGrid=class(TDBGrid)
 end;

The TBIDBGrid type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIDBGrid class.
Destroy | Represents the destructor of the TBIDBGrid class.
Top
Properties
Show:
Name | Description
ColumnSort | Represents property ColumnSort.
DefaultColWidth | Represents property DefaultColWidth.
DefaultRowHeight | Represents property DefaultRowHeight.
Detail | Represents property Detail.
DrawingStyle | Represents property DrawingStyle.
GridLineWidth | Represents property GridLineWidth.
IndicatorOffset | Represents property IndicatorOffset.
MenuButton | Represents property MenuButton.
OnAfterDrawCell | Represents property OnAfterDrawCell.
OnBeforeDrawCell | Represents property OnBeforeDrawCell.
ReadOnly | Represents property ReadOnly.
SearchEditor | Represents property SearchEditor.
TopRow | Represents property TopRow.
Top
Methods
Show:
Name | Description
ColumnMoved(Longint,Longint) | Represents method ColumnMoved(Longint,Longint).
ColumnOf(Integer) | Overloaded. Represents method ColumnOf(Integer).
ColumnOf(TDataItem) | Overloaded. Represents method ColumnOf(TDataItem).
ColumnOf(TField) | Overloaded. Represents method ColumnOf(TField).
ColWidthsChanged | Represents method ColWidthsChanged.
CreateColumns | Represents method CreateColumns.
DrawCell(Longint,Longint,TRect,TGridDrawState) | Represents method DrawCell(Longint,Longint,TRect,TGridDrawState).
GetClientRect | Represents method GetClientRect.
LinkActive(Boolean) | Represents method LinkActive(Boolean).
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer).
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
Resize | Represents method Resize.
SetColumnAttributes | Represents method SetColumnAttributes.
SetParent(TWinControl) | Represents method SetParent(TWinControl).
TitleClick(TColumn) | Represents method TitleClick(TColumn).
TopLeftChanged | Represents method TopLeftChanged.
TotalWidth | Represents method TotalWidth.
Traverse(TColumn,TProc) | Represents method Traverse(TColumn,TProc).
TryClearFilter | Represents method TryClearFilter.
TryCloseGroup | Represents method TryCloseGroup.
Top
Fields
Show:
Name | Description
ScrollTrack | Represents field ScrollTrack.
Top
See Also

Reference

  • VCLBI.Grid.DBGrid


TBIDBGrid Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBIDBGrid class.
Destroy | Represents the destructor of the TBIDBGrid class.
Top


TBIDBGrid.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIDBGrid class.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.Destroy Destructor

Summary

Represents the destructor of the TBIDBGrid class.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid Properties

Properties
Name | Description
ColumnSort | Represents property ColumnSort.
DefaultColWidth | Represents property DefaultColWidth.
DefaultRowHeight | Represents property DefaultRowHeight.
Detail | Represents property Detail.
DrawingStyle | Represents property DrawingStyle.
GridLineWidth | Represents property GridLineWidth.
IndicatorOffset | Represents property IndicatorOffset.
MenuButton | Represents property MenuButton.
OnAfterDrawCell | Represents property OnAfterDrawCell.
OnBeforeDrawCell | Represents property OnBeforeDrawCell.
ReadOnly | Represents property ReadOnly.
SearchEditor | Represents property SearchEditor.
TopRow | Represents property TopRow.
Top


TBIDBGrid.ColumnSort Property

Summary

Represents property ColumnSort.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
published
 property ColumnSort:Boolean read FColumnSort write SetColumnSort default True;

Property Value

Type: Boolean

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.DefaultColWidth Property

Summary

Represents property DefaultColWidth.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
published
 property DefaultColWidth;

Property Value

Type: Void

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.DefaultRowHeight Property

Summary

Represents property DefaultRowHeight.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
published
 property DefaultRowHeight;

Property Value

Type: Void

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.Detail Property

Summary

Represents property Detail.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 property Detail:TDataItem read GetDetail write SetDetail;

Property Value

Type: TDataItem

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.DrawingStyle Property

Summary

Represents property DrawingStyle.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
published
 property DrawingStyle default TGridDrawingStyle.gdsThemed;

Property Value

Type: Void

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.GridLineWidth Property

Summary

Represents property GridLineWidth.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
published
 property GridLineWidth;

Property Value

Type: Void

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.IndicatorOffset Property

Summary

Represents property IndicatorOffset.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
published
 property IndicatorOffset;

Property Value

Type: Void

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.MenuButton Property

Summary

Represents property MenuButton.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 property MenuButton:TSpeedButton read IMenu.Button;

Property Value

Type: TSpeedButton

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.OnAfterDrawCell Property

Summary

Represents property OnAfterDrawCell.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
published
 property OnAfterDrawCell:TDrawCellEvent read FOnAfterDrawCell write FOnAfterDrawCell;

Property Value

Type: TDrawCellEvent

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.OnBeforeDrawCell Property

Summary

Represents property OnBeforeDrawCell.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
published
 property OnBeforeDrawCell:TDrawCellEvent read FOnBeforeDrawCell write FOnBeforeDrawCell;

Property Value

Type: TDrawCellEvent

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.ReadOnly Property

Summary

Represents property ReadOnly.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
published
 property ReadOnly default True;

Property Value

Type: Void

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.SearchEditor Property

Summary

Represents property SearchEditor.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 property SearchEditor:TSearchEditor read GetSearchEditor;

Property Value

Type: TSearchEditor

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.TopRow Property

Summary

Represents property TopRow.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 property TopRow;

Property Value

Type: Void

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid Methods

Methods
Name | Description
ColumnMoved(Longint,Longint) | Represents method ColumnMoved(Longint,Longint).
ColumnOf(Integer) | Overloaded. Represents method ColumnOf(Integer).
ColumnOf(TDataItem) | Overloaded. Represents method ColumnOf(TDataItem).
ColumnOf(TField) | Overloaded. Represents method ColumnOf(TField).
ColWidthsChanged | Represents method ColWidthsChanged.
CreateColumns | Represents method CreateColumns.
DrawCell(Longint,Longint,TRect,TGridDrawState) | Represents method DrawCell(Longint,Longint,TRect,TGridDrawState).
GetClientRect | Represents method GetClientRect.
LinkActive(Boolean) | Represents method LinkActive(Boolean).
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer).
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
Resize | Represents method Resize.
SetColumnAttributes | Represents method SetColumnAttributes.
SetParent(TWinControl) | Represents method SetParent(TWinControl).
TitleClick(TColumn) | Represents method TitleClick(TColumn).
TopLeftChanged | Represents method TopLeftChanged.
TotalWidth | Represents method TotalWidth.
Traverse(TColumn,TProc) | Represents method Traverse(TColumn,TProc).
TryClearFilter | Represents method TryClearFilter.
TryCloseGroup | Represents method TryCloseGroup.
Top


TBIDBGrid.ColumnMoved(Longint,Longint) Method

Summary

Represents method ColumnMoved(Longint,Longint).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure ColumnMoved(FromIndex, ToIndex: Longint); override;

Parameters

FromIndex
Type: Longint

ToIndex
Type: Longint

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.ColumnOf(Integer) Method

Summary

Represents method ColumnOf(Integer).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 function ColumnOf(const X:Integer):TColumn; overload;

Parameters

X
Type: Integer

Return Value

Type: TColumn

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.ColumnOf(TDataItem) Method

Summary

Represents method ColumnOf(TDataItem).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 function ColumnOf(const AData:TDataItem):TColumn; overload;

Parameters

AData
Type: TDataItem

Return Value

Type: TColumn

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.ColumnOf(TField) Method

Summary

Represents method ColumnOf(TField).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 function ColumnOf(const AField:TField):TColumn; overload;

Parameters

AField
Type: TField

Return Value

Type: TColumn

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.ColWidthsChanged Method

Summary

Represents method ColWidthsChanged.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure ColWidthsChanged; override;
See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.CreateColumns Method

Summary

Represents method CreateColumns.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 function CreateColumns: TDBGridColumns; override;

Return Value

Type: TDBGridColumns

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.DrawCell(Longint,Longint,TRect,TGridDrawState) Method

Summary

Represents method DrawCell(Longint,Longint,TRect,TGridDrawState).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure DrawCell(ACol, ARow: Longint; ARect: TRect; AState: TGridDrawState); override;

Parameters

ACol
Type: Longint

ARow
Type: Longint

ARect
Type: TRect

AState
Type: TGridDrawState

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.GetClientRect Method

Summary

Represents method GetClientRect.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 function GetClientRect:TRect; override;

Return Value

Type: TRect

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.LinkActive(Boolean) Method

Summary

Represents method LinkActive(Boolean).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure LinkActive(Value: Boolean); override;

Parameters

Value
Type: Boolean

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.MouseMove(TShiftState,Integer,Integer) Method

Summary

Represents method MouseMove(TShiftState,Integer,Integer).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure MouseMove(Shift: TShiftState; X, Y: Integer); override;

Parameters

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.MouseUp(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure MouseUp(Button: TMouseButton; Shift: TShiftState; X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.Resize Method

Summary

Represents method Resize.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure Resize; override;
See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.SetColumnAttributes Method

Summary

Represents method SetColumnAttributes.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure SetColumnAttributes; override;
See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.SetParent(TWinControl) Method

Summary

Represents method SetParent(TWinControl).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure SetParent(AParent: TWinControl); override;

Parameters

AParent
Type: TWinControl

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.TitleClick(TColumn) Method

Summary

Represents method TitleClick(TColumn).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure TitleClick(Column: TColumn); override;

Parameters

Column
Type: TColumn

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.TopLeftChanged Method

Summary

Represents method TopLeftChanged.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure TopLeftChanged; override;
See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.TotalWidth Method

Summary

Represents method TotalWidth.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 function TotalWidth:Integer;

Return Value

Type: Integer

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.Traverse(TColumn,TProc) Method

Summary

Represents method Traverse(TColumn,TProc).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 procedure Traverse(const AColumn:TColumn; const AProc:TProc<TColumn>);

Parameters

AColumn
Type: TColumn

AProc
Type: TProc<TColumn>

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.TryClearFilter Method

Summary

Represents method TryClearFilter.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure TryClearFilter;
See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid.TryCloseGroup Method

Summary

Represents method TryCloseGroup.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure TryCloseGroup;
See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGrid Fields

Fields
Name | Description
ScrollTrack | Represents field ScrollTrack.
Top


TBIDBGrid.ScrollTrack Field

Summary

Represents field ScrollTrack.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 ScrollTrack : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TBIDBGrid
  • VCLBI.Grid.DBGrid


TBIDBGridColumns Class

Summary

Represents type TBIDBGridColumns.

Namespace: VCLBI.Grid.DBGrid
Inheritance Hierarchy
TDBGridColumns
VCLBI.Grid.DBGrid.TBIDBGridColumns
Syntax
Delphi
type
 TBIDBGridColumns=class(TDBGridColumns)
 end;

The TBIDBGridColumns type exposes the following members.

Methods
Show:
Name | Description
Update(TCollectionItem) | Represents method Update(TCollectionItem).
Top
See Also

Reference

  • VCLBI.Grid.DBGrid


TBIDBGridColumns Methods

Methods
Name | Description
Update(TCollectionItem) | Represents method Update(TCollectionItem).
Top


TBIDBGridColumns.Update(TCollectionItem) Method

Summary

Represents method Update(TCollectionItem).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure Update(Item: TCollectionItem); override;

Parameters

Item
Type: TCollectionItem

See Also

Reference

  • TBIDBGridColumns
  • VCLBI.Grid.DBGrid


TBIDBGridPlugin Class

Summary

Represents type TBIDBGridPlugin.

Namespace: VCLBI.Grid.DBGrid
Inheritance Hierarchy
TObject
BI.Grid.Plugin.TBIGridPlugin
VCLBI.Grid.DBGrid.TBIDBGridPlugin
Syntax
Delphi
type
 TBIDBGridPlugin=class(TBIGridPlugin)
 end;

The TBIDBGridPlugin type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIDBGridPlugin class. (Overrides TBIGridPlugin.Create(TComponent).)
Destroy | Represents the destructor of the TBIDBGridPlugin class.
Top
Methods
Show:
Name | Description
AutoWidth | Represents method AutoWidth. (Overrides TBIGridPlugin.AutoWidth.)
BindTo(TDataSet) | Represents method BindTo(TDataSet). (Overrides TBIGridPlugin.BindTo(TDataSet).)
ChangedAlternate(TObject) | Represents method ChangedAlternate(TObject). (Overrides TBIGridPlugin.ChangedAlternate(TObject).)
Colorize(TDataColorizers) | Represents method Colorize(TDataColorizers). (Overrides TBIGridPlugin.Colorize(TDataColorizers).)
Duplicates(TDataItem,Boolean) | Represents method Duplicates(TDataItem,Boolean). (Overrides TBIGridPlugin.Duplicates(TDataItem,Boolean).)
GetDataSource | Represents method GetDataSource. (Overrides TBIGridPlugin.GetDataSource.)
GetEditorClass | Represents method GetEditorClass. (Overrides TBIGridPlugin.GetEditorClass.)
GetObject | Represents method GetObject. (Overrides TBIGridPlugin.GetObject.)
GetReadOnly | Represents method GetReadOnly. (Overrides TBIGridPlugin.GetReadOnly.)
GetTotals | Represents method GetTotals. (Overrides TBIGridPlugin.GetTotals.)
SetDataSource(TDataSource) | Represents method SetDataSource(TDataSource). (Overrides TBIGridPlugin.SetDataSource(TDataSource).)
SetFilters(Boolean) | Represents method SetFilters(Boolean). (Overrides TBIGridPlugin.SetFilters(Boolean).)
SetReadOnly(Boolean) | Represents method SetReadOnly(Boolean). (Overrides TBIGridPlugin.SetReadOnly(Boolean).)
SetRowNumber(Boolean) | Represents method SetRowNumber(Boolean). (Overrides TBIGridPlugin.SetRowNumber(Boolean).)
SetSearch(Boolean) | Represents method SetSearch(Boolean). (Overrides TBIGridPlugin.SetSearch(Boolean).)
SetTotals(Boolean) | Represents method SetTotals(Boolean). (Overrides TBIGridPlugin.SetTotals(Boolean).)
Top
See Also

Reference

  • VCLBI.Grid.DBGrid


TBIDBGridPlugin Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBIDBGridPlugin class. (Overrides TBIGridPlugin.Create(TComponent).)
Destroy | Represents the destructor of the TBIDBGridPlugin class.
Top


TBIDBGridPlugin.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIDBGridPlugin class.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TBIGridPlugin.Create(TComponent)
See Also

Reference

  • TBIDBGridPlugin
  • VCLBI.Grid.DBGrid


TBIDBGridPlugin.Destroy Destructor

Summary

Represents the destructor of the TBIDBGridPlugin class.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBIDBGridPlugin
  • VCLBI.Grid.DBGrid


TBIDBGridPlugin Methods

Methods
Name | Description
AutoWidth | Represents method AutoWidth. (Overrides TBIGridPlugin.AutoWidth.)
BindTo(TDataSet) | Represents method BindTo(TDataSet). (Overrides TBIGridPlugin.BindTo(TDataSet).)
ChangedAlternate(TObject) | Represents method ChangedAlternate(TObject). (Overrides TBIGridPlugin.ChangedAlternate(TObject).)
Colorize(TDataColorizers) | Represents method Colorize(TDataColorizers). (Overrides TBIGridPlugin.Colorize(TDataColorizers).)
Duplicates(TDataItem,Boolean) | Represents method Duplicates(TDataItem,Boolean). (Overrides TBIGridPlugin.Duplicates(TDataItem,Boolean).)
GetDataSource | Represents method GetDataSource. (Overrides TBIGridPlugin.GetDataSource.)
GetEditorClass | Represents method GetEditorClass. (Overrides TBIGridPlugin.GetEditorClass.)
GetObject | Represents method GetObject. (Overrides TBIGridPlugin.GetObject.)
GetReadOnly | Represents method GetReadOnly. (Overrides TBIGridPlugin.GetReadOnly.)
GetTotals | Represents method GetTotals. (Overrides TBIGridPlugin.GetTotals.)
SetDataSource(TDataSource) | Represents method SetDataSource(TDataSource). (Overrides TBIGridPlugin.SetDataSource(TDataSource).)
SetFilters(Boolean) | Represents method SetFilters(Boolean). (Overrides TBIGridPlugin.SetFilters(Boolean).)
SetReadOnly(Boolean) | Represents method SetReadOnly(Boolean). (Overrides TBIGridPlugin.SetReadOnly(Boolean).)
SetRowNumber(Boolean) | Represents method SetRowNumber(Boolean). (Overrides TBIGridPlugin.SetRowNumber(Boolean).)
SetSearch(Boolean) | Represents method SetSearch(Boolean). (Overrides TBIGridPlugin.SetSearch(Boolean).)
SetTotals(Boolean) | Represents method SetTotals(Boolean). (Overrides TBIGridPlugin.SetTotals(Boolean).)
Top


TBIDBGridPlugin.AutoWidth Method

Summary

Represents method AutoWidth.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure AutoWidth; override;

Overrides

TBIGridPlugin.AutoWidth
See Also

Reference

  • TBIDBGridPlugin
  • VCLBI.Grid.DBGrid


TBIDBGridPlugin.BindTo(TDataSet) Method

Summary

Represents method BindTo(TDataSet).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 procedure BindTo(const ADataSet:TDataSet); override;

Parameters

ADataSet
Type: TDataSet

Overrides

TBIGridPlugin.BindTo(TDataSet)
See Also

Reference

  • TBIDBGridPlugin
  • VCLBI.Grid.DBGrid


TBIDBGridPlugin.ChangedAlternate(TObject) Method

Summary

Represents method ChangedAlternate(TObject).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure ChangedAlternate(Sender:TObject); override;

Parameters

Sender
Type: TObject

Overrides

TBIGridPlugin.ChangedAlternate(TObject)
See Also

Reference

  • TBIDBGridPlugin
  • VCLBI.Grid.DBGrid


TBIDBGridPlugin.Colorize(TDataColorizers) Method

Summary

Represents method Colorize(TDataColorizers).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 procedure Colorize(const AItems:TDataColorizers); override;

Parameters

AItems
Type: TDataColorizers

Overrides

TBIGridPlugin.Colorize(TDataColorizers)
See Also

Reference

  • TBIDBGridPlugin
  • VCLBI.Grid.DBGrid


TBIDBGridPlugin.Duplicates(TDataItem,Boolean) Method

Summary

Represents method Duplicates(TDataItem,Boolean).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 procedure Duplicates(const AData:TDataItem; const Hide:Boolean); override;

Parameters

AData
Type: TDataItem

Hide
Type: Boolean

Overrides

TBIGridPlugin.Duplicates(TDataItem,Boolean)
See Also

Reference

  • TBIDBGridPlugin
  • VCLBI.Grid.DBGrid


TBIDBGridPlugin.GetDataSource Method

Summary

Represents method GetDataSource.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 function GetDataSource: TDataSource; override;

Return Value

Type: TDataSource

Overrides

TBIGridPlugin.GetDataSource
See Also

Reference

  • TBIDBGridPlugin
  • VCLBI.Grid.DBGrid


TBIDBGridPlugin.GetEditorClass Method

Summary

Represents method GetEditorClass.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 function GetEditorClass:String; override;

Return Value

Type: String

Overrides

TBIGridPlugin.GetEditorClass
See Also

Reference

  • TBIDBGridPlugin
  • VCLBI.Grid.DBGrid


TBIDBGridPlugin.GetObject Method

Summary

Represents method GetObject.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 function GetObject:TObject; override;

Return Value

Type: TObject

Overrides

TBIGridPlugin.GetObject
See Also

Reference

  • TBIDBGridPlugin
  • VCLBI.Grid.DBGrid


TBIDBGridPlugin.GetReadOnly Method

Summary

Represents method GetReadOnly.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 function GetReadOnly:Boolean; override;

Return Value

Type: Boolean

Overrides

TBIGridPlugin.GetReadOnly
See Also

Reference

  • TBIDBGridPlugin
  • VCLBI.Grid.DBGrid


TBIDBGridPlugin.GetTotals Method

Summary

Represents method GetTotals.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 function GetTotals:Boolean; override;

Return Value

Type: Boolean

Overrides

TBIGridPlugin.GetTotals
See Also

Reference

  • TBIDBGridPlugin
  • VCLBI.Grid.DBGrid


TBIDBGridPlugin.SetDataSource(TDataSource) Method

Summary

Represents method SetDataSource(TDataSource).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure SetDataSource(const Value: TDataSource); override;

Parameters

Value
Type: TDataSource

Overrides

TBIGridPlugin.SetDataSource(TDataSource)
See Also

Reference

  • TBIDBGridPlugin
  • VCLBI.Grid.DBGrid


TBIDBGridPlugin.SetFilters(Boolean) Method

Summary

Represents method SetFilters(Boolean).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure SetFilters(const Value:Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBIGridPlugin.SetFilters(Boolean)
See Also

Reference

  • TBIDBGridPlugin
  • VCLBI.Grid.DBGrid


TBIDBGridPlugin.SetReadOnly(Boolean) Method

Summary

Represents method SetReadOnly(Boolean).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure SetReadOnly(const Value:Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBIGridPlugin.SetReadOnly(Boolean)
See Also

Reference

  • TBIDBGridPlugin
  • VCLBI.Grid.DBGrid


TBIDBGridPlugin.SetRowNumber(Boolean) Method

Summary

Represents method SetRowNumber(Boolean).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure SetRowNumber(const Value:Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBIGridPlugin.SetRowNumber(Boolean)
See Also

Reference

  • TBIDBGridPlugin
  • VCLBI.Grid.DBGrid


TBIDBGridPlugin.SetSearch(Boolean) Method

Summary

Represents method SetSearch(Boolean).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure SetSearch(const Value:Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBIGridPlugin.SetSearch(Boolean)
See Also

Reference

  • TBIDBGridPlugin
  • VCLBI.Grid.DBGrid


TBIDBGridPlugin.SetTotals(Boolean) Method

Summary

Represents method SetTotals(Boolean).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
protected
 procedure SetTotals(const Value:Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBIGridPlugin.SetTotals(Boolean)
See Also

Reference

  • TBIDBGridPlugin
  • VCLBI.Grid.DBGrid


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: VCLBI.Grid.DBGrid
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
VCLBI.Grid.DBGrid.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • VCLBI.Grid.DBGrid


TFilterGrid Class

Summary

Represents type TFilterGrid.

Namespace: VCLBI.Grid.DBGrid
Inheritance Hierarchy
TPanel
VCLBI.Grid.DBGrid.TFilterGrid
Syntax
Delphi
type
 TFilterGrid=class(TPanel)
 end;

The TFilterGrid type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TFilterGrid class.
Top
Methods
Show:
Name | Description
Clear | Represents method Clear.
Reset | Represents method Reset.
Show(Boolean) | Represents method Show(Boolean).
Top
See Also

Reference

  • VCLBI.Grid.DBGrid


TFilterGrid Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TFilterGrid class.
Top


TFilterGrid.Create(TComponent) Constructor

Summary

Initializes a new instance of the TFilterGrid class.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TFilterGrid
  • VCLBI.Grid.DBGrid


TFilterGrid Methods

Methods
Name | Description
Clear | Represents method Clear.
Reset | Represents method Reset.
Show(Boolean) | Represents method Show(Boolean).
Top


TFilterGrid.Clear Method

Summary

Represents method Clear.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 procedure Clear;
See Also

Reference

  • TFilterGrid
  • VCLBI.Grid.DBGrid


TFilterGrid.Reset Method

Summary

Represents method Reset.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 procedure Reset;
See Also

Reference

  • TFilterGrid
  • VCLBI.Grid.DBGrid


TFilterGrid.Show(Boolean) Method

Summary

Represents method Show(Boolean).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 procedure Show(const AVisible:Boolean);

Parameters

AVisible
Type: Boolean

See Also

Reference

  • TFilterGrid
  • VCLBI.Grid.DBGrid


VCLBI.Grid.DBGrid Records

Records
Name | Description
TColumnFormat | Represents type TColumnFormat.
TSearchValue | Represents type TSearchValue.
TSearchValues | Represents type TSearchValues.
Top


TColumnFormat Record

Summary

Represents type TColumnFormat.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
type
 TColumnFormat=record
 end;

The TColumnFormat type exposes the following members.

Methods
Show:
Name | Description
Restore | Represents method Restore.
Save(TColumn) | Represents method Save(TColumn).
Top
See Also

Reference

  • VCLBI.Grid.DBGrid


TColumnFormat Methods

Methods
Name | Description
Restore | Represents method Restore.
Save(TColumn) | Represents method Save(TColumn).
Top


TColumnFormat.Restore Method

Summary

Represents method Restore.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 procedure Restore;
See Also

Reference

  • TColumnFormat
  • VCLBI.Grid.DBGrid


TColumnFormat.Save(TColumn) Method

Summary

Represents method Save(TColumn).

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 procedure Save(const ACol:TColumn);

Parameters

ACol
Type: TColumn

See Also

Reference

  • TColumnFormat
  • VCLBI.Grid.DBGrid


TSearchValue Record

Summary

Represents type TSearchValue.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
type
 TSearchValue=record
 end;

The TSearchValue type exposes the following members.

Fields
Show:
Name | Description
Data | Represents field Data.
Text | Represents field Text.
Top
See Also

Reference

  • VCLBI.Grid.DBGrid


TSearchValue Fields

Fields
Name | Description
Data | Represents field Data.
Text | Represents field Text.
Top


TSearchValue.Data Field

Summary

Represents field Data.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TSearchValue
  • VCLBI.Grid.DBGrid


TSearchValue.Text Field

Summary

Represents field Text.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 Text : String;

Field Value

Type: String

See Also

Reference

  • TSearchValue
  • VCLBI.Grid.DBGrid


TSearchValues Record

Summary

Represents type TSearchValues.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
type
 TSearchValues=record
 end;

The TSearchValues type exposes the following members.

Methods
Show:
Name | Description
AllEmpty | Represents method AllEmpty.
Filled | Represents method Filled.
Top
Fields
Show:
Name | Description
Items | Represents field Items.
Top
See Also

Reference

  • VCLBI.Grid.DBGrid


TSearchValues Methods

Methods
Name | Description
AllEmpty | Represents method AllEmpty.
Filled | Represents method Filled.
Top


TSearchValues.AllEmpty Method

Summary

Represents method AllEmpty.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 function AllEmpty:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TSearchValues
  • VCLBI.Grid.DBGrid


TSearchValues.Filled Method

Summary

Represents method Filled.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 function Filled:TSearchValueArray;

Return Value

Type: TSearchValueArray

See Also

Reference

  • TSearchValues
  • VCLBI.Grid.DBGrid


TSearchValues Fields

Fields
Name | Description
Items | Represents field Items.
Top


TSearchValues.Items Field

Summary

Represents field Items.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
public
 Items : TSearchValueArray;

Field Value

Type: TSearchValueArray

See Also

Reference

  • TSearchValues
  • VCLBI.Grid.DBGrid


VCLBI.Grid.DBGrid Types

Types
Name | Description
TSearchValueArray | Represents an array of the TSearchValue type.
Top


TSearchValueArray Type

Summary

Represents an array of the TSearchValue type.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
type
 TSearchValueArray=Array of TSearchValue;
See Also

Reference

  • VCLBI.Grid.DBGrid


VCLBI.Grid.DBGrid Constants

Constants
Name | Description
BIMenu_AlternateRows | Represents constant BIMenu_AlternateRows.
BIMenu_Close | Represents constant BIMenu_Close.
BIMenu_ColorizeColumns | Represents constant BIMenu_ColorizeColumns.
BIMenu_ColumnFilters | Represents constant BIMenu_ColumnFilters.
BIMenu_ColumnSort | Represents constant BIMenu_ColumnSort.
BIMenu_Detail | Represents constant BIMenu_Detail.
BIMenu_Export | Represents constant BIMenu_Export.
BIMenu_GroupBy | Represents constant BIMenu_GroupBy.
BIMenu_RowNumbers | Represents constant BIMenu_RowNumbers.
BIMenu_Search | Represents constant BIMenu_Search.
Top


BIMenu_AlternateRows Constant

Summary

Represents constant BIMenu_AlternateRows.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
 BIMenu_AlternateRows='&Alternate Rows';

Value

Type: string

See Also

Reference

  • VCLBI.Grid.DBGrid


BIMenu_Close Constant

Summary

Represents constant BIMenu_Close.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
 BIMenu_Close='&Close';

Value

Type: string

See Also

Reference

  • VCLBI.Grid.DBGrid


BIMenu_ColorizeColumns Constant

Summary

Represents constant BIMenu_ColorizeColumns.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
 BIMenu_ColorizeColumns='&Colorize';

Value

Type: string

See Also

Reference

  • VCLBI.Grid.DBGrid


BIMenu_ColumnFilters Constant

Summary

Represents constant BIMenu_ColumnFilters.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
 BIMenu_ColumnFilters='&Column Filters';

Value

Type: string

See Also

Reference

  • VCLBI.Grid.DBGrid


BIMenu_ColumnSort Constant

Summary

Represents constant BIMenu_ColumnSort.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
 BIMenu_ColumnSort='&Column Sort';

Value

Type: string

See Also

Reference

  • VCLBI.Grid.DBGrid


BIMenu_Detail Constant

Summary

Represents constant BIMenu_Detail.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
 BIMenu_Detail='&Detail';

Value

Type: string

See Also

Reference

  • VCLBI.Grid.DBGrid


BIMenu_Export Constant

Summary

Represents constant BIMenu_Export.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
 BIMenu_Export='&Export Data...';

Value

Type: string

See Also

Reference

  • VCLBI.Grid.DBGrid


BIMenu_GroupBy Constant

Summary

Represents constant BIMenu_GroupBy.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
 BIMenu_GroupBy='&Group by';

Value

Type: string

See Also

Reference

  • VCLBI.Grid.DBGrid


BIMenu_RowNumbers Constant

Summary

Represents constant BIMenu_RowNumbers.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
 BIMenu_RowNumbers='&Row Numbers';

Value

Type: string

See Also

Reference

  • VCLBI.Grid.DBGrid


BIMenu_Search Constant

Summary

Represents constant BIMenu_Search.

Namespace: VCLBI.Grid.DBGrid
Syntax
Delphi
 BIMenu_Search='&Search';

Value

Type: string

See Also

Reference

  • VCLBI.Grid.DBGrid


VCLBI.Grid.JVCL Namespace

Summary

Represents namespace VCLBI.Grid.JVCL.

Classes
Name | Description
TBIJVCLGrid | Represents type TBIJVCLGrid.
TBIJVCLGridPlugin | Represents type TBIJVCLGridPlugin.
Top


VCLBI.Grid.JVCL Classes

Classes
Name | Description
TBIJVCLGrid | Represents type TBIJVCLGrid.
TBIJVCLGridPlugin | Represents type TBIJVCLGridPlugin.
Top


TBIJVCLGrid Class

Summary

Represents type TBIJVCLGrid.

Namespace: VCLBI.Grid.JVCL
Inheritance Hierarchy
TJVDBGrid
VCLBI.Grid.JVCL.TBIJVCLGrid
Syntax
Delphi
type
 TBIJVCLGrid=class(TJVDBGrid)
 end;

The TBIJVCLGrid type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIJVCLGrid class.
Top
Properties
Show:
Name | Description
DefaultColWidth | Represents property DefaultColWidth.
DefaultRowHeight | Represents property DefaultRowHeight.
DrawingStyle | Represents property DrawingStyle.
GridLineWidth | Represents property GridLineWidth.
IndicatorOffset | Represents property IndicatorOffset.
ReadOnly | Represents property ReadOnly.
Top
Methods
Show:
Name | Description
ColumnOf(TDataItem) | Overloaded. Represents method ColumnOf(TDataItem).
ColumnOf(TField) | Overloaded. Represents method ColumnOf(TField).
DrawCell(Longint,Longint,TRect,TGridDrawState) | Represents method DrawCell(Longint,Longint,TRect,TGridDrawState).
GetClientRect | Represents method GetClientRect.
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer).
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
TitleClick(TColumn) | Represents method TitleClick(TColumn).
Traverse(TColumn,TProc) | Represents method Traverse(TColumn,TProc).
Top
See Also

Reference

  • VCLBI.Grid.JVCL


TBIJVCLGrid Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBIJVCLGrid class.
Top


TBIJVCLGrid.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIJVCLGrid class.

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBIJVCLGrid
  • VCLBI.Grid.JVCL


TBIJVCLGrid Properties

Properties
Name | Description
DefaultColWidth | Represents property DefaultColWidth.
DefaultRowHeight | Represents property DefaultRowHeight.
DrawingStyle | Represents property DrawingStyle.
GridLineWidth | Represents property GridLineWidth.
IndicatorOffset | Represents property IndicatorOffset.
ReadOnly | Represents property ReadOnly.
Top


TBIJVCLGrid.DefaultColWidth Property

Summary

Represents property DefaultColWidth.

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
published
 property DefaultColWidth;

Property Value

Type: Void

See Also

Reference

  • TBIJVCLGrid
  • VCLBI.Grid.JVCL


TBIJVCLGrid.DefaultRowHeight Property

Summary

Represents property DefaultRowHeight.

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
published
 property DefaultRowHeight;

Property Value

Type: Void

See Also

Reference

  • TBIJVCLGrid
  • VCLBI.Grid.JVCL


TBIJVCLGrid.DrawingStyle Property

Summary

Represents property DrawingStyle.

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
published
 property DrawingStyle default TGridDrawingStyle.gdsThemed;

Property Value

Type: Void

See Also

Reference

  • TBIJVCLGrid
  • VCLBI.Grid.JVCL


TBIJVCLGrid.GridLineWidth Property

Summary

Represents property GridLineWidth.

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
published
 property GridLineWidth;

Property Value

Type: Void

See Also

Reference

  • TBIJVCLGrid
  • VCLBI.Grid.JVCL


TBIJVCLGrid.IndicatorOffset Property

Summary

Represents property IndicatorOffset.

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
published
 property IndicatorOffset;

Property Value

Type: Void

See Also

Reference

  • TBIJVCLGrid
  • VCLBI.Grid.JVCL


TBIJVCLGrid.ReadOnly Property

Summary

Represents property ReadOnly.

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
published
 property ReadOnly default True;

Property Value

Type: Void

See Also

Reference

  • TBIJVCLGrid
  • VCLBI.Grid.JVCL


TBIJVCLGrid Methods

Methods
Name | Description
ColumnOf(TDataItem) | Overloaded. Represents method ColumnOf(TDataItem).
ColumnOf(TField) | Overloaded. Represents method ColumnOf(TField).
DrawCell(Longint,Longint,TRect,TGridDrawState) | Represents method DrawCell(Longint,Longint,TRect,TGridDrawState).
GetClientRect | Represents method GetClientRect.
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer).
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
TitleClick(TColumn) | Represents method TitleClick(TColumn).
Traverse(TColumn,TProc) | Represents method Traverse(TColumn,TProc).
Top


TBIJVCLGrid.ColumnOf(TDataItem) Method

Summary

Represents method ColumnOf(TDataItem).

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
public
 function ColumnOf(const AColumn:TDataItem):TColumn; overload;

Parameters

AColumn
Type: TDataItem

Return Value

Type: TColumn

See Also

Reference

  • TBIJVCLGrid
  • VCLBI.Grid.JVCL


TBIJVCLGrid.ColumnOf(TField) Method

Summary

Represents method ColumnOf(TField).

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
public
 function ColumnOf(const AField:TField):TColumn; overload;

Parameters

AField
Type: TField

Return Value

Type: TColumn

See Also

Reference

  • TBIJVCLGrid
  • VCLBI.Grid.JVCL


TBIJVCLGrid.DrawCell(Longint,Longint,TRect,TGridDrawState) Method

Summary

Represents method DrawCell(Longint,Longint,TRect,TGridDrawState).

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
protected
 procedure DrawCell(ACol, ARow: Longint; ARect: TRect; AState: TGridDrawState); override;

Parameters

ACol
Type: Longint

ARow
Type: Longint

ARect
Type: TRect

AState
Type: TGridDrawState

See Also

Reference

  • TBIJVCLGrid
  • VCLBI.Grid.JVCL


TBIJVCLGrid.GetClientRect Method

Summary

Represents method GetClientRect.

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
protected
 function GetClientRect:TRect; override;

Return Value

Type: TRect

See Also

Reference

  • TBIJVCLGrid
  • VCLBI.Grid.JVCL


TBIJVCLGrid.MouseMove(TShiftState,Integer,Integer) Method

Summary

Represents method MouseMove(TShiftState,Integer,Integer).

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
protected
 procedure MouseMove(Shift: TShiftState; X, Y: Integer); override;

Parameters

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TBIJVCLGrid
  • VCLBI.Grid.JVCL


TBIJVCLGrid.MouseUp(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
protected
 procedure MouseUp(Button: TMouseButton; Shift: TShiftState; X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TBIJVCLGrid
  • VCLBI.Grid.JVCL


TBIJVCLGrid.TitleClick(TColumn) Method

Summary

Represents method TitleClick(TColumn).

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
protected
 procedure TitleClick(Column: TColumn); override;

Parameters

Column
Type: TColumn

See Also

Reference

  • TBIJVCLGrid
  • VCLBI.Grid.JVCL


TBIJVCLGrid.Traverse(TColumn,TProc) Method

Summary

Represents method Traverse(TColumn,TProc).

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
public
 procedure Traverse(const AColumn:TColumn; const AProc:TProc<TColumn>);

Parameters

AColumn
Type: TColumn

AProc
Type: TProc<TColumn>

See Also

Reference

  • TBIJVCLGrid
  • VCLBI.Grid.JVCL


TBIJVCLGridPlugin Class

Summary

Represents type TBIJVCLGridPlugin.

Namespace: VCLBI.Grid.JVCL
Inheritance Hierarchy
TBIGridPlugin
VCLBI.Grid.JVCL.TBIJVCLGridPlugin
Syntax
Delphi
type
 TBIJVCLGridPlugin=class(TBIGridPlugin)
 end;

The TBIJVCLGridPlugin type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBIJVCLGridPlugin class.
Top
Methods
Show:
Name | Description
BindTo(TDataSet) | Represents method BindTo(TDataSet).
Duplicates(TDataItem,Boolean) | Represents method Duplicates(TDataItem,Boolean).
GetDataSource | Represents method GetDataSource.
GetObject | Represents method GetObject.
GetReadOnly | Represents method GetReadOnly.
GetTotals | Represents method GetTotals.
SetDataSource(TDataSource) | Represents method SetDataSource(TDataSource).
SetReadOnly(Boolean) | Represents method SetReadOnly(Boolean).
SetTotals(Boolean) | Represents method SetTotals(Boolean).
Top
See Also

Reference

  • VCLBI.Grid.JVCL


TBIJVCLGridPlugin Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBIJVCLGridPlugin class.
Top


TBIJVCLGridPlugin.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBIJVCLGridPlugin class.

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBIJVCLGridPlugin
  • VCLBI.Grid.JVCL


TBIJVCLGridPlugin Methods

Methods
Name | Description
BindTo(TDataSet) | Represents method BindTo(TDataSet).
Duplicates(TDataItem,Boolean) | Represents method Duplicates(TDataItem,Boolean).
GetDataSource | Represents method GetDataSource.
GetObject | Represents method GetObject.
GetReadOnly | Represents method GetReadOnly.
GetTotals | Represents method GetTotals.
SetDataSource(TDataSource) | Represents method SetDataSource(TDataSource).
SetReadOnly(Boolean) | Represents method SetReadOnly(Boolean).
SetTotals(Boolean) | Represents method SetTotals(Boolean).
Top


TBIJVCLGridPlugin.BindTo(TDataSet) Method

Summary

Represents method BindTo(TDataSet).

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
public
 procedure BindTo(const ADataSet:TDataSet); override;

Parameters

ADataSet
Type: TDataSet

See Also

Reference

  • TBIJVCLGridPlugin
  • VCLBI.Grid.JVCL


TBIJVCLGridPlugin.Duplicates(TDataItem,Boolean) Method

Summary

Represents method Duplicates(TDataItem,Boolean).

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
public
 procedure Duplicates(const AData:TDataItem; const Hide:Boolean); override;

Parameters

AData
Type: TDataItem

Hide
Type: Boolean

See Also

Reference

  • TBIJVCLGridPlugin
  • VCLBI.Grid.JVCL


TBIJVCLGridPlugin.GetDataSource Method

Summary

Represents method GetDataSource.

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
protected
 function GetDataSource: TDataSource; override;

Return Value

Type: TDataSource

See Also

Reference

  • TBIJVCLGridPlugin
  • VCLBI.Grid.JVCL


TBIJVCLGridPlugin.GetObject Method

Summary

Represents method GetObject.

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
public
 function GetObject:TObject; override;

Return Value

Type: TObject

See Also

Reference

  • TBIJVCLGridPlugin
  • VCLBI.Grid.JVCL


TBIJVCLGridPlugin.GetReadOnly Method

Summary

Represents method GetReadOnly.

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
protected
 function GetReadOnly:Boolean; override;

Return Value

Type: Boolean

See Also

Reference

  • TBIJVCLGridPlugin
  • VCLBI.Grid.JVCL


TBIJVCLGridPlugin.GetTotals Method

Summary

Represents method GetTotals.

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
protected
 function GetTotals:Boolean; override;

Return Value

Type: Boolean

See Also

Reference

  • TBIJVCLGridPlugin
  • VCLBI.Grid.JVCL


TBIJVCLGridPlugin.SetDataSource(TDataSource) Method

Summary

Represents method SetDataSource(TDataSource).

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
protected
 procedure SetDataSource(const Value: TDataSource); override;

Parameters

Value
Type: TDataSource

See Also

Reference

  • TBIJVCLGridPlugin
  • VCLBI.Grid.JVCL


TBIJVCLGridPlugin.SetReadOnly(Boolean) Method

Summary

Represents method SetReadOnly(Boolean).

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
protected
 procedure SetReadOnly(const Value:Boolean); override;

Parameters

Value
Type: Boolean

See Also

Reference

  • TBIJVCLGridPlugin
  • VCLBI.Grid.JVCL


TBIJVCLGridPlugin.SetTotals(Boolean) Method

Summary

Represents method SetTotals(Boolean).

Namespace: VCLBI.Grid.JVCL
Syntax
Delphi
protected
 procedure SetTotals(const Value:Boolean); override;

Parameters

Value
Type: Boolean

See Also

Reference

  • TBIJVCLGridPlugin
  • VCLBI.Grid.JVCL


VCLBI.Grid.SMDBGrid Namespace

Summary

Represents namespace VCLBI.Grid.SMDBGrid.

Classes
Name | Description
TBISMDBGrid | Represents type TBISMDBGrid.
TBISMDBGridPlugin | Represents type TBISMDBGridPlugin.
Top


VCLBI.Grid.SMDBGrid Classes

Classes
Name | Description
TBISMDBGrid | Represents type TBISMDBGrid.
TBISMDBGridPlugin | Represents type TBISMDBGridPlugin.
Top


TBISMDBGrid Class

Summary

Represents type TBISMDBGrid.

Namespace: VCLBI.Grid.SMDBGrid
Inheritance Hierarchy
TSMDBGrid
VCLBI.Grid.SMDBGrid.TBISMDBGrid
Syntax
Delphi
type
 TBISMDBGrid=class(TSMDBGrid)
 end;

The TBISMDBGrid type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBISMDBGrid class.
Top
Properties
Show:
Name | Description
DefaultColWidth | Represents property DefaultColWidth.
DefaultRowHeight | Represents property DefaultRowHeight.
DrawingStyle | Represents property DrawingStyle.
GridLineWidth | Represents property GridLineWidth.
IndicatorOffset | Represents property IndicatorOffset.
ReadOnly | Represents property ReadOnly.
Top
Methods
Show:
Name | Description
ColumnOf(TDataItem) | Overloaded. Represents method ColumnOf(TDataItem).
ColumnOf(TField) | Overloaded. Represents method ColumnOf(TField).
DrawCell(Longint,Longint,TRect,TGridDrawState) | Represents method DrawCell(Longint,Longint,TRect,TGridDrawState).
GetClientRect | Represents method GetClientRect.
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer).
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
TitleClick(TColumn) | Represents method TitleClick(TColumn).
Traverse(TColumn,TProc) | Represents method Traverse(TColumn,TProc).
Top
See Also

Reference

  • VCLBI.Grid.SMDBGrid


TBISMDBGrid Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBISMDBGrid class.
Top


TBISMDBGrid.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBISMDBGrid class.

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBISMDBGrid
  • VCLBI.Grid.SMDBGrid


TBISMDBGrid Properties

Properties
Name | Description
DefaultColWidth | Represents property DefaultColWidth.
DefaultRowHeight | Represents property DefaultRowHeight.
DrawingStyle | Represents property DrawingStyle.
GridLineWidth | Represents property GridLineWidth.
IndicatorOffset | Represents property IndicatorOffset.
ReadOnly | Represents property ReadOnly.
Top


TBISMDBGrid.DefaultColWidth Property

Summary

Represents property DefaultColWidth.

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
published
 property DefaultColWidth;

Property Value

Type: Void

See Also

Reference

  • TBISMDBGrid
  • VCLBI.Grid.SMDBGrid


TBISMDBGrid.DefaultRowHeight Property

Summary

Represents property DefaultRowHeight.

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
published
 property DefaultRowHeight;

Property Value

Type: Void

See Also

Reference

  • TBISMDBGrid
  • VCLBI.Grid.SMDBGrid


TBISMDBGrid.DrawingStyle Property

Summary

Represents property DrawingStyle.

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
published
 property DrawingStyle default TGridDrawingStyle.gdsThemed;

Property Value

Type: Void

See Also

Reference

  • TBISMDBGrid
  • VCLBI.Grid.SMDBGrid


TBISMDBGrid.GridLineWidth Property

Summary

Represents property GridLineWidth.

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
published
 property GridLineWidth;

Property Value

Type: Void

See Also

Reference

  • TBISMDBGrid
  • VCLBI.Grid.SMDBGrid


TBISMDBGrid.IndicatorOffset Property

Summary

Represents property IndicatorOffset.

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
published
 property IndicatorOffset;

Property Value

Type: Void

See Also

Reference

  • TBISMDBGrid
  • VCLBI.Grid.SMDBGrid


TBISMDBGrid.ReadOnly Property

Summary

Represents property ReadOnly.

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
published
 property ReadOnly default True;

Property Value

Type: Void

See Also

Reference

  • TBISMDBGrid
  • VCLBI.Grid.SMDBGrid


TBISMDBGrid Methods

Methods
Name | Description
ColumnOf(TDataItem) | Overloaded. Represents method ColumnOf(TDataItem).
ColumnOf(TField) | Overloaded. Represents method ColumnOf(TField).
DrawCell(Longint,Longint,TRect,TGridDrawState) | Represents method DrawCell(Longint,Longint,TRect,TGridDrawState).
GetClientRect | Represents method GetClientRect.
MouseMove(TShiftState,Integer,Integer) | Represents method MouseMove(TShiftState,Integer,Integer).
MouseUp(TMouseButton,TShiftState,Integer,Integer) | Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).
TitleClick(TColumn) | Represents method TitleClick(TColumn).
Traverse(TColumn,TProc) | Represents method Traverse(TColumn,TProc).
Top


TBISMDBGrid.ColumnOf(TDataItem) Method

Summary

Represents method ColumnOf(TDataItem).

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
public
 function ColumnOf(const AColumn:TDataItem):TColumn; overload;

Parameters

AColumn
Type: TDataItem

Return Value

Type: TColumn

See Also

Reference

  • TBISMDBGrid
  • VCLBI.Grid.SMDBGrid


TBISMDBGrid.ColumnOf(TField) Method

Summary

Represents method ColumnOf(TField).

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
public
 function ColumnOf(const AField:TField):TColumn; overload;

Parameters

AField
Type: TField

Return Value

Type: TColumn

See Also

Reference

  • TBISMDBGrid
  • VCLBI.Grid.SMDBGrid


TBISMDBGrid.DrawCell(Longint,Longint,TRect,TGridDrawState) Method

Summary

Represents method DrawCell(Longint,Longint,TRect,TGridDrawState).

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
protected
 procedure DrawCell(ACol, ARow: Longint; ARect: TRect; AState: TGridDrawState); override;

Parameters

ACol
Type: Longint

ARow
Type: Longint

ARect
Type: TRect

AState
Type: TGridDrawState

See Also

Reference

  • TBISMDBGrid
  • VCLBI.Grid.SMDBGrid


TBISMDBGrid.GetClientRect Method

Summary

Represents method GetClientRect.

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
protected
 function GetClientRect:TRect; override;

Return Value

Type: TRect

See Also

Reference

  • TBISMDBGrid
  • VCLBI.Grid.SMDBGrid


TBISMDBGrid.MouseMove(TShiftState,Integer,Integer) Method

Summary

Represents method MouseMove(TShiftState,Integer,Integer).

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
protected
 procedure MouseMove(Shift: TShiftState; X, Y: Integer); override;

Parameters

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TBISMDBGrid
  • VCLBI.Grid.SMDBGrid


TBISMDBGrid.MouseUp(TMouseButton,TShiftState,Integer,Integer) Method

Summary

Represents method MouseUp(TMouseButton,TShiftState,Integer,Integer).

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
protected
 procedure MouseUp(Button: TMouseButton; Shift: TShiftState; X, Y: Integer); override;

Parameters

Button
Type: TMouseButton

Shift
Type: TShiftState

X
Type: Integer

Y
Type: Integer

See Also

Reference

  • TBISMDBGrid
  • VCLBI.Grid.SMDBGrid


TBISMDBGrid.TitleClick(TColumn) Method

Summary

Represents method TitleClick(TColumn).

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
protected
 procedure TitleClick(Column: TColumn); override;

Parameters

Column
Type: TColumn

See Also

Reference

  • TBISMDBGrid
  • VCLBI.Grid.SMDBGrid


TBISMDBGrid.Traverse(TColumn,TProc) Method

Summary

Represents method Traverse(TColumn,TProc).

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
public
 procedure Traverse(const AColumn:TColumn; const AProc:TProc<TColumn>);

Parameters

AColumn
Type: TColumn

AProc
Type: TProc<TColumn>

See Also

Reference

  • TBISMDBGrid
  • VCLBI.Grid.SMDBGrid


TBISMDBGridPlugin Class

Summary

Represents type TBISMDBGridPlugin.

Namespace: VCLBI.Grid.SMDBGrid
Inheritance Hierarchy
TBIGridPlugin
VCLBI.Grid.SMDBGrid.TBISMDBGridPlugin
Syntax
Delphi
type
 TBISMDBGridPlugin=class(TBIGridPlugin)
 end;

The TBISMDBGridPlugin type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBISMDBGridPlugin class.
Top
Methods
Show:
Name | Description
BindTo(TDataSet) | Represents method BindTo(TDataSet).
Duplicates(TDataItem,Boolean) | Represents method Duplicates(TDataItem,Boolean).
GetDataSource | Represents method GetDataSource.
GetObject | Represents method GetObject.
GetReadOnly | Represents method GetReadOnly.
GetTotals | Represents method GetTotals.
SetDataSource(TDataSource) | Represents method SetDataSource(TDataSource).
SetReadOnly(Boolean) | Represents method SetReadOnly(Boolean).
SetTotals(Boolean) | Represents method SetTotals(Boolean).
Top
See Also

Reference

  • VCLBI.Grid.SMDBGrid


TBISMDBGridPlugin Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TBISMDBGridPlugin class.
Top


TBISMDBGridPlugin.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBISMDBGridPlugin class.

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBISMDBGridPlugin
  • VCLBI.Grid.SMDBGrid


TBISMDBGridPlugin Methods

Methods
Name | Description
BindTo(TDataSet) | Represents method BindTo(TDataSet).
Duplicates(TDataItem,Boolean) | Represents method Duplicates(TDataItem,Boolean).
GetDataSource | Represents method GetDataSource.
GetObject | Represents method GetObject.
GetReadOnly | Represents method GetReadOnly.
GetTotals | Represents method GetTotals.
SetDataSource(TDataSource) | Represents method SetDataSource(TDataSource).
SetReadOnly(Boolean) | Represents method SetReadOnly(Boolean).
SetTotals(Boolean) | Represents method SetTotals(Boolean).
Top


TBISMDBGridPlugin.BindTo(TDataSet) Method

Summary

Represents method BindTo(TDataSet).

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
public
 procedure BindTo(const ADataSet:TDataSet); override;

Parameters

ADataSet
Type: TDataSet

See Also

Reference

  • TBISMDBGridPlugin
  • VCLBI.Grid.SMDBGrid


TBISMDBGridPlugin.Duplicates(TDataItem,Boolean) Method

Summary

Represents method Duplicates(TDataItem,Boolean).

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
public
 procedure Duplicates(const AData:TDataItem; const Hide:Boolean); override;

Parameters

AData
Type: TDataItem

Hide
Type: Boolean

See Also

Reference

  • TBISMDBGridPlugin
  • VCLBI.Grid.SMDBGrid


TBISMDBGridPlugin.GetDataSource Method

Summary

Represents method GetDataSource.

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
protected
 function GetDataSource: TDataSource; override;

Return Value

Type: TDataSource

See Also

Reference

  • TBISMDBGridPlugin
  • VCLBI.Grid.SMDBGrid


TBISMDBGridPlugin.GetObject Method

Summary

Represents method GetObject.

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
public
 function GetObject:TObject; override;

Return Value

Type: TObject

See Also

Reference

  • TBISMDBGridPlugin
  • VCLBI.Grid.SMDBGrid


TBISMDBGridPlugin.GetReadOnly Method

Summary

Represents method GetReadOnly.

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
protected
 function GetReadOnly:Boolean; override;

Return Value

Type: Boolean

See Also

Reference

  • TBISMDBGridPlugin
  • VCLBI.Grid.SMDBGrid


TBISMDBGridPlugin.GetTotals Method

Summary

Represents method GetTotals.

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
protected
 function GetTotals:Boolean; override;

Return Value

Type: Boolean

See Also

Reference

  • TBISMDBGridPlugin
  • VCLBI.Grid.SMDBGrid


TBISMDBGridPlugin.SetDataSource(TDataSource) Method

Summary

Represents method SetDataSource(TDataSource).

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
protected
 procedure SetDataSource(const Value: TDataSource); override;

Parameters

Value
Type: TDataSource

See Also

Reference

  • TBISMDBGridPlugin
  • VCLBI.Grid.SMDBGrid


TBISMDBGridPlugin.SetReadOnly(Boolean) Method

Summary

Represents method SetReadOnly(Boolean).

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
protected
 procedure SetReadOnly(const Value:Boolean); override;

Parameters

Value
Type: Boolean

See Also

Reference

  • TBISMDBGridPlugin
  • VCLBI.Grid.SMDBGrid


TBISMDBGridPlugin.SetTotals(Boolean) Method

Summary

Represents method SetTotals(Boolean).

Namespace: VCLBI.Grid.SMDBGrid
Syntax
Delphi
protected
 procedure SetTotals(const Value:Boolean); override;

Parameters

Value
Type: Boolean

See Also

Reference

  • TBISMDBGridPlugin
  • VCLBI.Grid.SMDBGrid


VCLBI.Grid.TeeGrid Namespace

Summary

Represents namespace VCLBI.Grid.TeeGrid.

Classes
Name | Description
TBITeeGrid | Represents type TBITeeGrid.
TBITeeGridPlugin | Represents type TBITeeGridPlugin.
Top


VCLBI.Grid.TeeGrid Classes

Classes
Name | Description
TBITeeGrid | Represents type TBITeeGrid.
TBITeeGridPlugin | Represents type TBITeeGridPlugin.
Top


TBITeeGrid Class

Summary

Represents type TBITeeGrid.

Namespace: VCLBI.Grid.TeeGrid
Inheritance Hierarchy
TTeeGrid
VCLBI.Grid.TeeGrid.TBITeeGrid
Syntax
Delphi
type
 TBITeeGrid=class(TTeeGrid)
 end;

The TBITeeGrid type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBITeeGrid class.
Top
See Also

Reference

  • VCLBI.Grid.TeeGrid


TBITeeGrid.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBITeeGrid class.

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBITeeGrid
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin Class

Summary

Represents type TBITeeGridPlugin.

Namespace: VCLBI.Grid.TeeGrid
Inheritance Hierarchy
TObject
BI.Grid.Plugin.TBIGridPlugin
VCLBI.Grid.TeeGrid.TBITeeGridPlugin
Syntax
Delphi
type
 TBITeeGridPlugin=class(TBIGridPlugin)
 end;

The TBITeeGridPlugin type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBITeeGridPlugin class. (Overrides TBIGridPlugin.Create(TComponent).)
Top
Methods
Show:
Name | Description
AutoWidth | Represents method AutoWidth. (Overrides TBIGridPlugin.AutoWidth.)
BindTo(TDataSet) | Represents method BindTo(TDataSet). (Overrides TBIGridPlugin.BindTo(TDataSet).)
ChangedAlternate(TObject) | Represents method ChangedAlternate(TObject). (Overrides TBIGridPlugin.ChangedAlternate(TObject).)
Colorize(TDataColorizers) | Represents method Colorize(TDataColorizers). (Overrides TBIGridPlugin.Colorize(TDataColorizers).)
Duplicates(TDataItem,Boolean) | Represents method Duplicates(TDataItem,Boolean). (Overrides TBIGridPlugin.Duplicates(TDataItem,Boolean).)
GetCanSort | Represents method GetCanSort. (Overrides TBIGridPlugin.GetCanSort.)
GetControl | Represents method GetControl. (Overrides TBIGridPlugin.GetControl.)
GetDataSource | Represents method GetDataSource. (Overrides TBIGridPlugin.GetDataSource.)
GetEditorClass | Represents method GetEditorClass. (Overrides TBIGridPlugin.GetEditorClass.)
GetObject | Represents method GetObject. (Overrides TBIGridPlugin.GetObject.)
GetReadOnly | Represents method GetReadOnly. (Overrides TBIGridPlugin.GetReadOnly.)
GetSortEnabled | Represents method GetSortEnabled. (Overrides TBIGridPlugin.GetSortEnabled.)
GetTotals | Represents method GetTotals. (Overrides TBIGridPlugin.GetTotals.)
SetDataSource(TDataSource) | Represents method SetDataSource(TDataSource). (Overrides TBIGridPlugin.SetDataSource(TDataSource).)
SetFilters(Boolean) | Represents method SetFilters(Boolean). (Overrides TBIGridPlugin.SetFilters(Boolean).)
SetOnRowChanged(TNotifyEvent) | Represents method SetOnRowChanged(TNotifyEvent). (Overrides TBIGridPlugin.SetOnRowChanged(TNotifyEvent).)
SetPopup(TObject) | Represents method SetPopup(TObject). (Overrides TBIGridPlugin.SetPopup(TObject).)
SetReadOnly(Boolean) | Represents method SetReadOnly(Boolean). (Overrides TBIGridPlugin.SetReadOnly(Boolean).)
SetRowNumber(Boolean) | Represents method SetRowNumber(Boolean). (Overrides TBIGridPlugin.SetRowNumber(Boolean).)
SetSearch(Boolean) | Represents method SetSearch(Boolean). (Overrides TBIGridPlugin.SetSearch(Boolean).)
SetSortEnabled(Boolean) | Represents method SetSortEnabled(Boolean). (Overrides TBIGridPlugin.SetSortEnabled(Boolean).)
SetTotals(Boolean) | Represents method SetTotals(Boolean). (Overrides TBIGridPlugin.SetTotals(Boolean).)
Top
See Also

Reference

  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBITeeGridPlugin class.

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TBIGridPlugin.Create(TComponent)
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.AutoWidth Method

Summary

Represents method AutoWidth.

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure AutoWidth; override;

Overrides

TBIGridPlugin.AutoWidth
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.BindTo(TDataSet) Method

Summary

Represents method BindTo(TDataSet).

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
public
 procedure BindTo(const ADataSet:TDataSet); override;

Parameters

ADataSet
Type: TDataSet

Overrides

TBIGridPlugin.BindTo(TDataSet)
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.ChangedAlternate(TObject) Method

Summary

Represents method ChangedAlternate(TObject).

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure ChangedAlternate(Sender:TObject); override;

Parameters

Sender
Type: TObject

Overrides

TBIGridPlugin.ChangedAlternate(TObject)
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.Colorize(TDataColorizers) Method

Summary

Represents method Colorize(TDataColorizers).

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
public
 procedure Colorize(const AItems:TDataColorizers); override;

Parameters

AItems
Type: TDataColorizers

Overrides

TBIGridPlugin.Colorize(TDataColorizers)
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.Duplicates(TDataItem,Boolean) Method

Summary

Represents method Duplicates(TDataItem,Boolean).

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
public
 procedure Duplicates(const AData:TDataItem; const Hide:Boolean); override;

Parameters

AData
Type: TDataItem

Hide
Type: Boolean

Overrides

TBIGridPlugin.Duplicates(TDataItem,Boolean)
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.GetCanSort Method

Summary

Represents method GetCanSort.

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
protected
 function GetCanSort: Boolean; override;

Return Value

Type: Boolean

Overrides

TBIGridPlugin.GetCanSort
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.GetControl Method

Summary

Represents method GetControl.

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
public
 function GetControl:TObject; override;

Return Value

Type: TObject

Overrides

TBIGridPlugin.GetControl
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.GetDataSource Method

Summary

Represents method GetDataSource.

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
protected
 function GetDataSource: TDataSource; override;

Return Value

Type: TDataSource

Overrides

TBIGridPlugin.GetDataSource
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.GetEditorClass Method

Summary

Represents method GetEditorClass.

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
protected
 function GetEditorClass:String; override;

Return Value

Type: String

Overrides

TBIGridPlugin.GetEditorClass
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.GetObject Method

Summary

Represents method GetObject.

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
public
 function GetObject:TObject; override;

Return Value

Type: TObject

Overrides

TBIGridPlugin.GetObject
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.GetReadOnly Method

Summary

Represents method GetReadOnly.

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
protected
 function GetReadOnly:Boolean; override;

Return Value

Type: Boolean

Overrides

TBIGridPlugin.GetReadOnly
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.GetSortEnabled Method

Summary

Represents method GetSortEnabled.

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
protected
 function GetSortEnabled: Boolean; override;

Return Value

Type: Boolean

Overrides

TBIGridPlugin.GetSortEnabled
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.GetTotals Method

Summary

Represents method GetTotals.

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
protected
 function GetTotals:Boolean; override;

Return Value

Type: Boolean

Overrides

TBIGridPlugin.GetTotals
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.SetDataSource(TDataSource) Method

Summary

Represents method SetDataSource(TDataSource).

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure SetDataSource(const Value: TDataSource); override;

Parameters

Value
Type: TDataSource

Overrides

TBIGridPlugin.SetDataSource(TDataSource)
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.SetFilters(Boolean) Method

Summary

Represents method SetFilters(Boolean).

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure SetFilters(const Value:Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBIGridPlugin.SetFilters(Boolean)
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.SetOnRowChanged(TNotifyEvent) Method

Summary

Represents method SetOnRowChanged(TNotifyEvent).

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure SetOnRowChanged(const AEvent:TNotifyEvent); override;

Parameters

AEvent
Type: TNotifyEvent

Overrides

TBIGridPlugin.SetOnRowChanged(TNotifyEvent)
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.SetPopup(TObject) Method

Summary

Represents method SetPopup(TObject).

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure SetPopup(const Value:TObject); override;

Parameters

Value
Type: TObject

Overrides

TBIGridPlugin.SetPopup(TObject)
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.SetReadOnly(Boolean) Method

Summary

Represents method SetReadOnly(Boolean).

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure SetReadOnly(const Value:Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBIGridPlugin.SetReadOnly(Boolean)
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.SetRowNumber(Boolean) Method

Summary

Represents method SetRowNumber(Boolean).

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure SetRowNumber(const Value:Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBIGridPlugin.SetRowNumber(Boolean)
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.SetSearch(Boolean) Method

Summary

Represents method SetSearch(Boolean).

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure SetSearch(const Value:Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBIGridPlugin.SetSearch(Boolean)
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.SetSortEnabled(Boolean) Method

Summary

Represents method SetSortEnabled(Boolean).

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure SetSortEnabled(const Value: Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBIGridPlugin.SetSortEnabled(Boolean)
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


TBITeeGridPlugin.SetTotals(Boolean) Method

Summary

Represents method SetTotals(Boolean).

Namespace: VCLBI.Grid.TeeGrid
Syntax
Delphi
protected
 procedure SetTotals(const Value:Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBIGridPlugin.SetTotals(Boolean)
See Also

Reference

  • TBITeeGridPlugin
  • VCLBI.Grid.TeeGrid


VCLBI.GridChart Namespace

Summary

Represents namespace VCLBI.GridChart.

Classes
Name | Description
TGridChart | Represents type TGridChart.
Top


VCLBI.GridChart Classes

Classes
Name | Description
TGridChart | Represents type TGridChart.
Top


TGridChart Class

Summary

Represents type TGridChart.

Namespace: VCLBI.GridChart
Inheritance Hierarchy
TForm
VCLBI.GridChart.TGridChart
Syntax
Delphi
type
 TGridChart = class(TForm)
 end;

The TGridChart type exposes the following members.

Methods
Show:
Name | Description
Show(TComponent,TDataItem,TSquareGrid) | Represents method Show(TComponent,TDataItem,TSquareGrid).
Top
Fields
Show:
Name | Description
Chart1 | Represents field Chart1.
ChartTool1 | Represents field ChartTool1.
Series1 | Represents field Series1.
TeeCommander1 | Represents field TeeCommander1.
Top
See Also

Reference

  • VCLBI.GridChart


TGridChart Methods

Methods
Name | Description
Show(TComponent,TDataItem,TSquareGrid) | Represents method Show(TComponent,TDataItem,TSquareGrid).
Top


TGridChart.Show(TComponent,TDataItem,TSquareGrid) Method

Summary

Represents method Show(TComponent,TDataItem,TSquareGrid).

Namespace: VCLBI.GridChart
Syntax
Delphi
public
 class function Show(const AOwner:TComponent; const Data:TDataItem; const Grid:TSquareGrid):TModalResult;

Parameters

AOwner
Type: TComponent

Data
Type: TDataItem

Grid
Type: TSquareGrid

Return Value

Type: TModalResult

See Also

Reference

  • TGridChart
  • VCLBI.GridChart


TGridChart Fields

Fields
Name | Description
Chart1 | Represents field Chart1.
ChartTool1 | Represents field ChartTool1.
Series1 | Represents field Series1.
TeeCommander1 | Represents field TeeCommander1.
Top


TGridChart.Chart1 Field

Summary

Represents field Chart1.

Namespace: VCLBI.GridChart
Syntax
Delphi
published
 Chart1: TChart;

Field Value

Type: TChart

See Also

Reference

  • TGridChart
  • VCLBI.GridChart


TGridChart.ChartTool1 Field

Summary

Represents field ChartTool1.

Namespace: VCLBI.GridChart
Syntax
Delphi
published
 ChartTool1: TLegendPaletteTool;

Field Value

Type: TLegendPaletteTool

See Also

Reference

  • TGridChart
  • VCLBI.GridChart


TGridChart.Series1 Field

Summary

Represents field Series1.

Namespace: VCLBI.GridChart
Syntax
Delphi
published
 Series1: TColorGridSeries;

Field Value

Type: TColorGridSeries

See Also

Reference

  • TGridChart
  • VCLBI.GridChart


TGridChart.TeeCommander1 Field

Summary

Represents field TeeCommander1.

Namespace: VCLBI.GridChart
Syntax
Delphi
published
 TeeCommander1: TTeeCommander;

Field Value

Type: TTeeCommander

See Also

Reference

  • TGridChart
  • VCLBI.GridChart


VCLBI.GridForm Namespace

Summary

Represents namespace VCLBI.GridForm.

Classes
Name | Description
TBIGridForm | Represents type TBIGridForm.
Top


VCLBI.GridForm Classes

Classes
Name | Description
TBIGridForm | Represents type TBIGridForm.
Top


TBIGridForm Class

Summary

Represents type TBIGridForm.

Namespace: VCLBI.GridForm
Inheritance Hierarchy
TForm
VCLBI.GridForm.TBIGridForm
Syntax
Delphi
type
 TBIGridForm = class(TForm)
 end;

The TBIGridForm type exposes the following members.

Properties
Show:
Name | Description
Data | Represents property Data.
Top
Methods
Show:
Name | Description
Embedd(TComponent,TWinControl,TDataItem) | Represents method Embedd(TComponent,TWinControl,TDataItem).
FormShow(TObject) | Represents method FormShow(TObject).
GridDataChange(TObject) | Represents method GridDataChange(TObject).
MakeEditable | Represents method MakeEditable.
Present(TComponent,TDataItem) | Overloaded. Represents method Present(TComponent,TDataItem).
Top
Fields
Show:
Name | Description
DBNavigator1 | Represents field DBNavigator1.
Grid | Represents field Grid.
LRow | Represents field LRow.
Panel2 | Represents field Panel2.
PanelNav | Represents field PanelNav.
Top
See Also

Reference

  • VCLBI.GridForm


TBIGridForm Properties

Properties
Name | Description
Data | Represents property Data.
Top


TBIGridForm.Data Property

Summary

Represents property Data.

Namespace: VCLBI.GridForm
Syntax
Delphi
public
 property Data:TDataItem read GetDataItem write SetDataItem;

Property Value

Type: TDataItem

See Also

Reference

  • TBIGridForm
  • VCLBI.GridForm


TBIGridForm Methods

Methods
Name | Description
Embedd(TComponent,TWinControl,TDataItem) | Represents method Embedd(TComponent,TWinControl,TDataItem).
FormShow(TObject) | Represents method FormShow(TObject).
GridDataChange(TObject) | Represents method GridDataChange(TObject).
MakeEditable | Represents method MakeEditable.
Present(TComponent,TDataItem) | Overloaded. Represents method Present(TComponent,TDataItem).
Top


TBIGridForm.Embedd(TComponent,TWinControl,TDataItem) Method

Summary

Represents method Embedd(TComponent,TWinControl,TDataItem).

Namespace: VCLBI.GridForm
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent;
 const AParent:TWinControl;
 const AData:TDataItem):TBIGridForm;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AData
Type: TDataItem

Return Value

Type: TBIGridForm

See Also

Reference

  • TBIGridForm
  • VCLBI.GridForm


TBIGridForm.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.GridForm
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIGridForm
  • VCLBI.GridForm


TBIGridForm.GridDataChange(TObject) Method

Summary

Represents method GridDataChange(TObject).

Namespace: VCLBI.GridForm
Syntax
Delphi
published
 procedure GridDataChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIGridForm
  • VCLBI.GridForm


TBIGridForm.MakeEditable Method

Summary

Represents method MakeEditable.

Namespace: VCLBI.GridForm
Syntax
Delphi
public
 procedure MakeEditable;
See Also

Reference

  • TBIGridForm
  • VCLBI.GridForm


TBIGridForm.Present(TComponent,TDataItem) Method

Summary

Represents method Present(TComponent,TDataItem).

Namespace: VCLBI.GridForm
Syntax
Delphi
public
 class function Present(const AOwner:TComponent; const AData:TDataItem):TModalResult; overload;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

Return Value

Type: TModalResult

See Also

Reference

  • TBIGridForm
  • VCLBI.GridForm


TBIGridForm Fields

Fields
Name | Description
DBNavigator1 | Represents field DBNavigator1.
Grid | Represents field Grid.
LRow | Represents field LRow.
Panel2 | Represents field Panel2.
PanelNav | Represents field PanelNav.
Top


TBIGridForm.DBNavigator1 Field

Summary

Represents field DBNavigator1.

Namespace: VCLBI.GridForm
Syntax
Delphi
published
 DBNavigator1: TDBNavigator;

Field Value

Type: TDBNavigator

See Also

Reference

  • TBIGridForm
  • VCLBI.GridForm


TBIGridForm.Grid Field

Summary

Represents field Grid.

Namespace: VCLBI.GridForm
Syntax
Delphi
published
 Grid: TBIGrid;

Field Value

Type: TBIGrid

See Also

Reference

  • TBIGridForm
  • VCLBI.GridForm


TBIGridForm.LRow Field

Summary

Represents field LRow.

Namespace: VCLBI.GridForm
Syntax
Delphi
published
 LRow: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TBIGridForm
  • VCLBI.GridForm


TBIGridForm.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.GridForm
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIGridForm
  • VCLBI.GridForm


TBIGridForm.PanelNav Field

Summary

Represents field PanelNav.

Namespace: VCLBI.GridForm
Syntax
Delphi
published
 PanelNav: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIGridForm
  • VCLBI.GridForm


VCLBI.LinkDiagram Namespace

Summary

Represents namespace VCLBI.LinkDiagram.

Classes
Name | Description
TDataAccess | Represents type TDataAccess.
TDataDiagram | Represents type TDataDiagram.
Top
Routines
Name | Description
ShowDiagram(TComponent,TDataItem) | Represents method ShowDiagram(TComponent,TDataItem).
Top


VCLBI.LinkDiagram Classes

Classes
Name | Description
TDataAccess | Represents type TDataAccess.
TDataDiagram | Represents type TDataDiagram.
Top


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: VCLBI.LinkDiagram
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
VCLBI.LinkDiagram.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • VCLBI.LinkDiagram


TDataDiagram Class

Summary

Represents type TDataDiagram.

Namespace: VCLBI.LinkDiagram
Inheritance Hierarchy
TForm
VCLBI.LinkDiagram.TDataDiagram
Syntax
Delphi
type
 TDataDiagram = class(TForm)
 end;

The TDataDiagram type exposes the following members.

Methods
Show:
Name | Description
BLoadClick(TObject) | Represents method BLoadClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
CBGDIPlusClick(TObject) | Represents method CBGDIPlusClick(TObject).
Embedd(TComponent,TWinControl,TDataItem) | Represents method Embedd(TComponent,TWinControl,TDataItem).
FormShow(TObject) | Represents method FormShow(TObject).
Show(TComponent,TDataItem) | Represents method Show(TComponent,TDataItem).
TBFontChange(TObject) | Represents method TBFontChange(TObject).
Tree1BeforeDraw(TObject) | Represents method Tree1BeforeDraw(TObject).
Tree1SelectShape(TTreeNodeShape) | Represents method Tree1SelectShape(TTreeNodeShape).
Top
Fields
Show:
Name | Description
BIDataset1 | Represents field BIDataset1.
BLoad | Represents field BLoad.
Button1 | Represents field Button1.
CBGDIPlus | Represents field CBGDIPlus.
DataSource1 | Represents field DataSource1.
Grid | Represents field Grid.
Label1 | Represents field Label1.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Splitter1 | Represents field Splitter1.
TBFont | Represents field TBFont.
Tree1 | Represents field Tree1.
Top
See Also

Reference

  • VCLBI.LinkDiagram


TDataDiagram Methods

Methods
Name | Description
BLoadClick(TObject) | Represents method BLoadClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
CBGDIPlusClick(TObject) | Represents method CBGDIPlusClick(TObject).
Embedd(TComponent,TWinControl,TDataItem) | Represents method Embedd(TComponent,TWinControl,TDataItem).
FormShow(TObject) | Represents method FormShow(TObject).
Show(TComponent,TDataItem) | Represents method Show(TComponent,TDataItem).
TBFontChange(TObject) | Represents method TBFontChange(TObject).
Tree1BeforeDraw(TObject) | Represents method Tree1BeforeDraw(TObject).
Tree1SelectShape(TTreeNodeShape) | Represents method Tree1SelectShape(TTreeNodeShape).
Top


TDataDiagram.BLoadClick(TObject) Method

Summary

Represents method BLoadClick(TObject).

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
published
 procedure BLoadClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataDiagram
  • VCLBI.LinkDiagram


TDataDiagram.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataDiagram
  • VCLBI.LinkDiagram


TDataDiagram.CBGDIPlusClick(TObject) Method

Summary

Represents method CBGDIPlusClick(TObject).

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
published
 procedure CBGDIPlusClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataDiagram
  • VCLBI.LinkDiagram


TDataDiagram.Embedd(TComponent,TWinControl,TDataItem) Method

Summary

Represents method Embedd(TComponent,TWinControl,TDataItem).

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
public
 class function Embedd(const AOwner:TComponent; const AParent:TWinControl; const AData:TDataItem):TDataDiagram; static;

Parameters

AOwner
Type: TComponent

AParent
Type: TWinControl

AData
Type: TDataItem

Return Value

Type: TDataDiagram

See Also

Reference

  • TDataDiagram
  • VCLBI.LinkDiagram


TDataDiagram.FormShow(TObject) Method

Summary

Represents method FormShow(TObject).

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
published
 procedure FormShow(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataDiagram
  • VCLBI.LinkDiagram


TDataDiagram.Show(TComponent,TDataItem) Method

Summary

Represents method Show(TComponent,TDataItem).

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
public
 class function Show(const AOwner:TComponent; const AData:TDataItem):TModalResult; static;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

Return Value

Type: TModalResult

See Also

Reference

  • TDataDiagram
  • VCLBI.LinkDiagram


TDataDiagram.TBFontChange(TObject) Method

Summary

Represents method TBFontChange(TObject).

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
published
 procedure TBFontChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataDiagram
  • VCLBI.LinkDiagram


TDataDiagram.Tree1BeforeDraw(TObject) Method

Summary

Represents method Tree1BeforeDraw(TObject).

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
published
 procedure Tree1BeforeDraw(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TDataDiagram
  • VCLBI.LinkDiagram


TDataDiagram.Tree1SelectShape(TTreeNodeShape) Method

Summary

Represents method Tree1SelectShape(TTreeNodeShape).

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
published
 procedure Tree1SelectShape(Sender: TTreeNodeShape);

Parameters

Sender
Type: TTreeNodeShape

See Also

Reference

  • TDataDiagram
  • VCLBI.LinkDiagram


TDataDiagram Fields

Fields
Name | Description
BIDataset1 | Represents field BIDataset1.
BLoad | Represents field BLoad.
Button1 | Represents field Button1.
CBGDIPlus | Represents field CBGDIPlus.
DataSource1 | Represents field DataSource1.
Grid | Represents field Grid.
Label1 | Represents field Label1.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Splitter1 | Represents field Splitter1.
TBFont | Represents field TBFont.
Tree1 | Represents field Tree1.
Top


TDataDiagram.BIDataset1 Field

Summary

Represents field BIDataset1.

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
published
 BIDataset1: TBIDataset;

Field Value

Type: TBIDataset

See Also

Reference

  • TDataDiagram
  • VCLBI.LinkDiagram


TDataDiagram.BLoad Field

Summary

Represents field BLoad.

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
published
 BLoad: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataDiagram
  • VCLBI.LinkDiagram


TDataDiagram.Button1 Field

Summary

Represents field Button1.

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TDataDiagram
  • VCLBI.LinkDiagram


TDataDiagram.CBGDIPlus Field

Summary

Represents field CBGDIPlus.

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
published
 CBGDIPlus: TCheckBox;

Field Value

Type: TCheckBox

See Also

Reference

  • TDataDiagram
  • VCLBI.LinkDiagram


TDataDiagram.DataSource1 Field

Summary

Represents field DataSource1.

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
published
 DataSource1: TDataSource;

Field Value

Type: TDataSource

See Also

Reference

  • TDataDiagram
  • VCLBI.LinkDiagram


TDataDiagram.Grid Field

Summary

Represents field Grid.

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
published
 Grid: TBIGrid;

Field Value

Type: TBIGrid

See Also

Reference

  • TDataDiagram
  • VCLBI.LinkDiagram


TDataDiagram.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TDataDiagram
  • VCLBI.LinkDiagram


TDataDiagram.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataDiagram
  • VCLBI.LinkDiagram


TDataDiagram.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TDataDiagram
  • VCLBI.LinkDiagram


TDataDiagram.Splitter1 Field

Summary

Represents field Splitter1.

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
published
 Splitter1: TSplitter;

Field Value

Type: TSplitter

See Also

Reference

  • TDataDiagram
  • VCLBI.LinkDiagram


TDataDiagram.TBFont Field

Summary

Represents field TBFont.

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
published
 TBFont: TTrackBar;

Field Value

Type: TTrackBar

See Also

Reference

  • TDataDiagram
  • VCLBI.LinkDiagram


TDataDiagram.Tree1 Field

Summary

Represents field Tree1.

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
published
 Tree1: TTree;

Field Value

Type: TTree

See Also

Reference

  • TDataDiagram
  • VCLBI.LinkDiagram


VCLBI.LinkDiagram Routines

Routines
Name | Description
ShowDiagram(TComponent,TDataItem) | Represents method ShowDiagram(TComponent,TDataItem).
Top


ShowDiagram(TComponent,TDataItem) Method

Summary

Represents method ShowDiagram(TComponent,TDataItem).

Namespace: VCLBI.LinkDiagram
Syntax
Delphi
procedure ShowDiagram(const AOwner:TComponent; const AData:TDataItem);

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

See Also

Reference

  • VCLBI.LinkDiagram


VCLBI.Menus Namespace

Summary

Represents namespace VCLBI.Menus.

Records
Name | Description
TBIMenu | Represents type TBIMenu.
Top


VCLBI.Menus Records

Records
Name | Description
TBIMenu | Represents type TBIMenu.
Top


TBIMenu Record

Summary

Represents type TBIMenu.

Namespace: VCLBI.Menus
Syntax
Delphi
type
 TBIMenu=record
 end;

The TBIMenu type exposes the following members.

Methods
Show:
Name | Description
Add(TMenu,String,TNotifyEvent) | Overloaded. Represents method Add(TMenu,String,TNotifyEvent).
Add(TMenuItem,String,TNotifyEvent) | Overloaded. Represents method Add(TMenuItem,String,TNotifyEvent).
AddSeparator(TMenu) | Represents method AddSeparator(TMenu).
NewItem(TComponent,String,TNotifyEvent) | Represents method NewItem(TComponent,String,TNotifyEvent).
Popup(TPopupMenu,TControl) | Represents method Popup(TPopupMenu,TControl).
Top
See Also

Reference

  • VCLBI.Menus


TBIMenu Methods

Methods
Name | Description
Add(TMenu,String,TNotifyEvent) | Overloaded. Represents method Add(TMenu,String,TNotifyEvent).
Add(TMenuItem,String,TNotifyEvent) | Overloaded. Represents method Add(TMenuItem,String,TNotifyEvent).
AddSeparator(TMenu) | Represents method AddSeparator(TMenu).
NewItem(TComponent,String,TNotifyEvent) | Represents method NewItem(TComponent,String,TNotifyEvent).
Popup(TPopupMenu,TControl) | Represents method Popup(TPopupMenu,TControl).
Top


TBIMenu.Add(TMenu,String,TNotifyEvent) Method

Summary

Represents method Add(TMenu,String,TNotifyEvent).

Namespace: VCLBI.Menus
Syntax
Delphi
public
 class function Add(const AMenu:TMenu; const ACaption:String;
 const AClick:TNotifyEvent=nil):TMenuItem; overload; static;

Parameters

AMenu
Type: TMenu

ACaption
Type: String

AClick
Type: TNotifyEvent

Return Value

Type: TMenuItem

See Also

Reference

  • TBIMenu
  • VCLBI.Menus


TBIMenu.Add(TMenuItem,String,TNotifyEvent) Method

Summary

Represents method Add(TMenuItem,String,TNotifyEvent).

Namespace: VCLBI.Menus
Syntax
Delphi
public
 class function Add(const AItem:TMenuItem; const ACaption:String;
 const AClick:TNotifyEvent=nil):TMenuItem; overload; static;

Parameters

AItem
Type: TMenuItem

ACaption
Type: String

AClick
Type: TNotifyEvent

Return Value

Type: TMenuItem

See Also

Reference

  • TBIMenu
  • VCLBI.Menus


TBIMenu.AddSeparator(TMenu) Method

Summary

Represents method AddSeparator(TMenu).

Namespace: VCLBI.Menus
Syntax
Delphi
public
 class function AddSeparator(const AMenu:TMenu):TMenuItem; static;

Parameters

AMenu
Type: TMenu

Return Value

Type: TMenuItem

See Also

Reference

  • TBIMenu
  • VCLBI.Menus


TBIMenu.NewItem(TComponent,String,TNotifyEvent) Method

Summary

Represents method NewItem(TComponent,String,TNotifyEvent).

Namespace: VCLBI.Menus
Syntax
Delphi
public
 class function NewItem(const AOwner:TComponent;
 const ACaption:String;
 const AClick:TNotifyEvent):TMenuItem; static;

Parameters

AOwner
Type: TComponent

ACaption
Type: String

AClick
Type: TNotifyEvent

Return Value

Type: TMenuItem

See Also

Reference

  • TBIMenu
  • VCLBI.Menus


TBIMenu.Popup(TPopupMenu,TControl) Method

Summary

Represents method Popup(TPopupMenu,TControl).

Namespace: VCLBI.Menus
Syntax
Delphi
public
 class procedure Popup(const APopup:TPopupMenu; const AParent:TControl); static;

Parameters

APopup
Type: TPopupMenu

AParent
Type: TControl

See Also

Reference

  • TBIMenu
  • VCLBI.Menus


VCLBI.NewColumn Namespace

Summary

Represents namespace VCLBI.NewColumn.

Classes
Name | Description
TAddColumn | Represents type TAddColumn.
TDataAccess | Represents type TDataAccess.
Top
Constants
Name | Description
TypeData | Represents constant TypeData.
TypeDetail | Represents constant TypeDetail.
TypeExpression | Represents constant TypeExpression.
TypeLookup | Represents constant TypeLookup.
Top


VCLBI.NewColumn Classes

Classes
Name | Description
TAddColumn | Represents type TAddColumn.
TDataAccess | Represents type TDataAccess.
Top


TAddColumn Class

Summary

Represents type TAddColumn.

Namespace: VCLBI.NewColumn
Inheritance Hierarchy
TForm
VCLBI.NewColumn.TAddColumn
Syntax
Delphi
type
 TAddColumn = class(TForm)
 end;

The TAddColumn type exposes the following members.

Constructors
Show:
Name | Description
CreateData(TComponent,TDataItem) | Initializes a new instance of the TAddColumn class.
Top
Methods
Show:
Name | Description
CBDetailChange(TObject) | Represents method CBDetailChange(TObject).
CBKindChange(TObject) | Represents method CBKindChange(TObject).
CBLookupChange(TObject) | Represents method CBLookupChange(TObject).
EExpressionChange(TObject) | Represents method EExpressionChange(TObject).
ENameChange(TObject) | Represents method ENameChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
NewColumn(TComponent,TDataItem) | Represents method NewColumn(TComponent,TDataItem).
RGStyleClick(TObject) | Represents method RGStyleClick(TObject).
Top
Fields
Show:
Name | Description
BOk | Represents field BOk.
Button2 | Represents field Button2.
CBDetail | Represents field CBDetail.
CBKind | Represents field CBKind.
CBLookup | Represents field CBLookup.
EExpression | Represents field EExpression.
EName | Represents field EName.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
LError | Represents field LError.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
RGStyle | Represents field RGStyle.
Top
See Also

Reference

  • VCLBI.NewColumn


TAddColumn Constructors

Constructors
Name | Description
CreateData(TComponent,TDataItem) | Initializes a new instance of the TAddColumn class.
Top


TAddColumn.CreateData(TComponent,TDataItem) Constructor

Summary

Initializes a new instance of the TAddColumn class.

Namespace: VCLBI.NewColumn
Syntax
Delphi
public
 Constructor CreateData(const AOwner:TComponent; const AData:TDataItem);

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TAddColumn Methods

Methods
Name | Description
CBDetailChange(TObject) | Represents method CBDetailChange(TObject).
CBKindChange(TObject) | Represents method CBKindChange(TObject).
CBLookupChange(TObject) | Represents method CBLookupChange(TObject).
EExpressionChange(TObject) | Represents method EExpressionChange(TObject).
ENameChange(TObject) | Represents method ENameChange(TObject).
FormCreate(TObject) | Represents method FormCreate(TObject).
NewColumn(TComponent,TDataItem) | Represents method NewColumn(TComponent,TDataItem).
RGStyleClick(TObject) | Represents method RGStyleClick(TObject).
Top


TAddColumn.CBDetailChange(TObject) Method

Summary

Represents method CBDetailChange(TObject).

Namespace: VCLBI.NewColumn
Syntax
Delphi
published
 procedure CBDetailChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TAddColumn.CBKindChange(TObject) Method

Summary

Represents method CBKindChange(TObject).

Namespace: VCLBI.NewColumn
Syntax
Delphi
published
 procedure CBKindChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TAddColumn.CBLookupChange(TObject) Method

Summary

Represents method CBLookupChange(TObject).

Namespace: VCLBI.NewColumn
Syntax
Delphi
published
 procedure CBLookupChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TAddColumn.EExpressionChange(TObject) Method

Summary

Represents method EExpressionChange(TObject).

Namespace: VCLBI.NewColumn
Syntax
Delphi
published
 procedure EExpressionChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TAddColumn.ENameChange(TObject) Method

Summary

Represents method ENameChange(TObject).

Namespace: VCLBI.NewColumn
Syntax
Delphi
published
 procedure ENameChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TAddColumn.FormCreate(TObject) Method

Summary

Represents method FormCreate(TObject).

Namespace: VCLBI.NewColumn
Syntax
Delphi
published
 procedure FormCreate(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TAddColumn.NewColumn(TComponent,TDataItem) Method

Summary

Represents method NewColumn(TComponent,TDataItem).

Namespace: VCLBI.NewColumn
Syntax
Delphi
public
 class function NewColumn(const AOwner:TComponent; const AData:TDataItem):TDataItem;

Parameters

AOwner
Type: TComponent

AData
Type: TDataItem

Return Value

Type: TDataItem

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TAddColumn.RGStyleClick(TObject) Method

Summary

Represents method RGStyleClick(TObject).

Namespace: VCLBI.NewColumn
Syntax
Delphi
published
 procedure RGStyleClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TAddColumn Fields

Fields
Name | Description
BOk | Represents field BOk.
Button2 | Represents field Button2.
CBDetail | Represents field CBDetail.
CBKind | Represents field CBKind.
CBLookup | Represents field CBLookup.
EExpression | Represents field EExpression.
EName | Represents field EName.
Label1 | Represents field Label1.
Label2 | Represents field Label2.
LError | Represents field LError.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
RGStyle | Represents field RGStyle.
Top


TAddColumn.BOk Field

Summary

Represents field BOk.

Namespace: VCLBI.NewColumn
Syntax
Delphi
published
 BOk: TButton;

Field Value

Type: TButton

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TAddColumn.Button2 Field

Summary

Represents field Button2.

Namespace: VCLBI.NewColumn
Syntax
Delphi
published
 Button2: TButton;

Field Value

Type: TButton

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TAddColumn.CBDetail Field

Summary

Represents field CBDetail.

Namespace: VCLBI.NewColumn
Syntax
Delphi
published
 CBDetail: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TAddColumn.CBKind Field

Summary

Represents field CBKind.

Namespace: VCLBI.NewColumn
Syntax
Delphi
published
 CBKind: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TAddColumn.CBLookup Field

Summary

Represents field CBLookup.

Namespace: VCLBI.NewColumn
Syntax
Delphi
published
 CBLookup: TComboBox;

Field Value

Type: TComboBox

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TAddColumn.EExpression Field

Summary

Represents field EExpression.

Namespace: VCLBI.NewColumn
Syntax
Delphi
published
 EExpression: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TAddColumn.EName Field

Summary

Represents field EName.

Namespace: VCLBI.NewColumn
Syntax
Delphi
published
 EName: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TAddColumn.Label1 Field

Summary

Represents field Label1.

Namespace: VCLBI.NewColumn
Syntax
Delphi
published
 Label1: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TAddColumn.Label2 Field

Summary

Represents field Label2.

Namespace: VCLBI.NewColumn
Syntax
Delphi
published
 Label2: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TAddColumn.LError Field

Summary

Represents field LError.

Namespace: VCLBI.NewColumn
Syntax
Delphi
published
 LError: TLabel;

Field Value

Type: TLabel

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TAddColumn.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.NewColumn
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TAddColumn.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.NewColumn
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TAddColumn.RGStyle Field

Summary

Represents field RGStyle.

Namespace: VCLBI.NewColumn
Syntax
Delphi
published
 RGStyle: TRadioGroup;

Field Value

Type: TRadioGroup

See Also

Reference

  • TAddColumn
  • VCLBI.NewColumn


TDataAccess Class

Summary

Represents type TDataAccess.

Namespace: VCLBI.NewColumn
Inheritance Hierarchy
TObject
BI.DataItem.TDataItem
VCLBI.NewColumn.TDataAccess
Syntax
Delphi
type
 TDataAccess=class(TDataItem);
See Also

Reference

  • VCLBI.NewColumn


VCLBI.NewColumn Constants

Constants
Name | Description
TypeData | Represents constant TypeData.
TypeDetail | Represents constant TypeDetail.
TypeExpression | Represents constant TypeExpression.
TypeLookup | Represents constant TypeLookup.
Top


TypeData Constant

Summary

Represents constant TypeData.

Namespace: VCLBI.NewColumn
Syntax
Delphi
 TypeData=0;

Value

Type: ShortInt

See Also

Reference

  • VCLBI.NewColumn


TypeDetail Constant

Summary

Represents constant TypeDetail.

Namespace: VCLBI.NewColumn
Syntax
Delphi
 TypeDetail=2;

Value

Type: ShortInt

See Also

Reference

  • VCLBI.NewColumn


TypeExpression Constant

Summary

Represents constant TypeExpression.

Namespace: VCLBI.NewColumn
Syntax
Delphi
 TypeExpression=3;

Value

Type: ShortInt

See Also

Reference

  • VCLBI.NewColumn


TypeLookup Constant

Summary

Represents constant TypeLookup.

Namespace: VCLBI.NewColumn
Syntax
Delphi
 TypeLookup=1;

Value

Type: ShortInt

See Also

Reference

  • VCLBI.NewColumn


VCLBI.PDF Namespace

Summary

Represents namespace VCLBI.PDF.

Classes
Name | Description
TBIPDFExport | Represents type TBIPDFExport.
TFormat | Represents type TFormat.
TGridLines | Represents type TGridLines.
THeader | Represents type THeader.
TPage | Represents type TPage.
TPageNumbering | Represents type TPageNumbering.
TRowFormat | Represents type TRowFormat.
TTitle | Represents type TTitle.
Top
Enumerations
Name | Description
TAlignment | Represents type TAlignment.
THeaderPosition | Represents type THeaderPosition.
Top
Types
Name | Description
TCoordinate | Represents an alias of the Integer type.
Top
Constants
Name | Description
BeigeColor | Represents constant BeigeColor.
SilverColor | Represents constant SilverColor.
TA_CENTER | Represents constant TA_CENTER.
TA_LEFT | Represents constant TA_LEFT.
TA_RIGHT | Represents constant TA_RIGHT.
Top


VCLBI.PDF Classes

Classes
Name | Description
TBIPDFExport | Represents type TBIPDFExport.
TFormat | Represents type TFormat.
TGridLines | Represents type TGridLines.
THeader | Represents type THeader.
TPage | Represents type TPage.
TPageNumbering | Represents type TPageNumbering.
TRowFormat | Represents type TRowFormat.
TTitle | Represents type TTitle.
Top


TBIPDFExport Class

Summary

Represents type TBIPDFExport.

Namespace: VCLBI.PDF
Inheritance Hierarchy
TObject
BI.DataSource.TBIExport
BI.DataSource.TBITextExport
VCLBI.PDF.TBIPDFExport
Syntax
Delphi
type
 TBIPDFExport=class(TBITextExport)
 end;

The TBIPDFExport type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TBIPDFExport class. (Overrides TBIExport.Create.)
Destroy | Represents the destructor of the TBIPDFExport class. (Overrides TBIExport.Destroy.)
Top
Properties
Show:
Name | Description
Alignment | Represents property Alignment.
AutoWidth | Represents property AutoWidth.
Footer | Represents property Footer.
GridLines | Represents property GridLines.
Header | Represents property Header.
Page | Represents property Page.
RowFormat | Represents property RowFormat.
Title | Represents property Title.
Top
Methods
Show:
Name | Description
DoEmit(TStrings) | Represents method DoEmit(TStrings). (Overrides TBIExport.DoEmit(TStrings).)
Supports(String) | Represents method Supports(String). (Overrides TBIExport.Supports(String).)
Top
See Also

Reference

  • VCLBI.PDF


TBIPDFExport.Create Constructor

Summary

Initializes a new instance of the TBIPDFExport class.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 Constructor Create; override;

Overrides

TBIExport.Create
See Also

Reference

  • TBIPDFExport
  • VCLBI.PDF


TBIPDFExport.Destroy Destructor

Summary

Represents the destructor of the TBIPDFExport class.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TBIExport.Destroy
See Also

Reference

  • TBIPDFExport
  • VCLBI.PDF


TBIPDFExport.Alignment Property

Summary

Represents property Alignment.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 property Alignment:TAlignment read FAlignment write FAlignment default TAlignment.Center;

Property Value

Type: TAlignment

See Also

Reference

  • TBIPDFExport
  • VCLBI.PDF


TBIPDFExport.AutoWidth Property

Summary

Represents property AutoWidth.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 property AutoWidth:Boolean read FAutoWidth write FAutoWidth default True;

Property Value

Type: Boolean

See Also

Reference

  • TBIPDFExport
  • VCLBI.PDF


TBIPDFExport.Footer Property

Summary

Represents property Footer.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 property Footer:TTitle read FFooter;

Property Value

Type: TTitle

See Also

Reference

  • TBIPDFExport
  • VCLBI.PDF


TBIPDFExport.GridLines Property

Summary

Represents property GridLines.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 property GridLines:TGridLines read FGridLines write SetGridLines;

Property Value

Type: TGridLines

See Also

Reference

  • TBIPDFExport
  • VCLBI.PDF


TBIPDFExport.Header Property

Summary

Represents property Header.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 property Header:THeader read FHeader;

Property Value

Type: THeader

See Also

Reference

  • TBIPDFExport
  • VCLBI.PDF


TBIPDFExport.Page Property

Summary

Represents property Page.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 property Page:TPage read FPage;

Property Value

Type: TPage

See Also

Reference

  • TBIPDFExport
  • VCLBI.PDF


TBIPDFExport.RowFormat Property

Summary

Represents property RowFormat.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 property RowFormat:TRowFormat read FRowFormat;

Property Value

Type: TRowFormat

See Also

Reference

  • TBIPDFExport
  • VCLBI.PDF


TBIPDFExport.Title Property

Summary

Represents property Title.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 property Title:TTitle read FTitle;

Property Value

Type: TTitle

See Also

Reference

  • TBIPDFExport
  • VCLBI.PDF


TBIPDFExport.DoEmit(TStrings) Method

Summary

Represents method DoEmit(TStrings).

Namespace: VCLBI.PDF
Syntax
Delphi
protected
 procedure DoEmit(const AItems: TStrings); override;

Parameters

AItems
Type: TStrings

Overrides

TBIExport.DoEmit(TStrings)
See Also

Reference

  • TBIPDFExport
  • VCLBI.PDF


TBIPDFExport.Supports(String) Method

Summary

Represents method Supports(String).

Namespace: VCLBI.PDF
Syntax
Delphi
public
 class function Supports(const Extension:String):Boolean; override;

Parameters

Extension
Type: String

Return Value

Type: Boolean

Overrides

TBIExport.Supports(String)
See Also

Reference

  • TBIPDFExport
  • VCLBI.PDF


TFormat Class

Summary

Represents type TFormat.

Namespace: VCLBI.PDF
Inheritance Hierarchy
TPersistent
VCLBI.PDF.TFormat
VCLBI.PDF.THeader
VCLBI.PDF.TRowFormat
Syntax
Delphi
type
 TFormat=class(TPersistent)
 end;

The TFormat type exposes the following members.

Constructors
Show:
Name | Description
Create(TBIPDFExport) | Initializes a new instance of the TFormat class.
Destroy | Represents the destructor of the TFormat class.
Top
Properties
Show:
Name | Description
Brush | Represents property Brush.
Font | Represents property Font.
Visible | Represents property Visible.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
See Also

Reference

  • VCLBI.PDF


TFormat.Create(TBIPDFExport) Constructor

Summary

Initializes a new instance of the TFormat class.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 Constructor Create(const AParent:TBIPDFExport); virtual;

Parameters

AParent
Type: TBIPDFExport

See Also

Reference

  • TFormat
  • VCLBI.PDF


TFormat.Destroy Destructor

Summary

Represents the destructor of the TFormat class.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TFormat
  • VCLBI.PDF


TFormat.Brush Property

Summary

Represents property Brush.

Namespace: VCLBI.PDF
Syntax
Delphi
published
 property Brush:TTeeBrush read FBrush write SetBrush;

Property Value

Type: TTeeBrush

See Also

Reference

  • TFormat
  • VCLBI.PDF


TFormat.Font Property

Summary

Represents property Font.

Namespace: VCLBI.PDF
Syntax
Delphi
published
 property Font:TTeeFont read FFont write SetFont;

Property Value

Type: TTeeFont

See Also

Reference

  • TFormat
  • VCLBI.PDF


TFormat.Visible Property

Summary

Represents property Visible.

Namespace: VCLBI.PDF
Syntax
Delphi
published
 property Visible:Boolean read FVisible write FVisible default True;

Property Value

Type: Boolean

See Also

Reference

  • TFormat
  • VCLBI.PDF


TFormat.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: VCLBI.PDF
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TFormat
  • VCLBI.PDF


TGridLines Class

Summary

Represents type TGridLines.

Namespace: VCLBI.PDF
Inheritance Hierarchy
TPersistent
VCLBI.PDF.TGridLines
Syntax
Delphi
type
 TGridLines=class(TPersistent)
 end;

The TGridLines type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TGridLines class.
Destroy | Represents the destructor of the TGridLines class.
Top
Properties
Show:
Name | Description
Horizontal | Represents property Horizontal.
Vertical | Represents property Vertical.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
See Also

Reference

  • VCLBI.PDF


TGridLines.Create Constructor

Summary

Initializes a new instance of the TGridLines class.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 Constructor Create;
See Also

Reference

  • TGridLines
  • VCLBI.PDF


TGridLines.Destroy Destructor

Summary

Represents the destructor of the TGridLines class.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TGridLines
  • VCLBI.PDF


TGridLines.Horizontal Property

Summary

Represents property Horizontal.

Namespace: VCLBI.PDF
Syntax
Delphi
published
 property Horizontal:TTeePen read FHorizontal write SetHorizontal;

Property Value

Type: TTeePen

See Also

Reference

  • TGridLines
  • VCLBI.PDF


TGridLines.Vertical Property

Summary

Represents property Vertical.

Namespace: VCLBI.PDF
Syntax
Delphi
published
 property Vertical:TTeePen read FVertical write SetVertical;

Property Value

Type: TTeePen

See Also

Reference

  • TGridLines
  • VCLBI.PDF


TGridLines.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: VCLBI.PDF
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TGridLines
  • VCLBI.PDF


THeader Class

Summary

Represents type THeader.

Namespace: VCLBI.PDF
Inheritance Hierarchy
TPersistent
VCLBI.PDF.TFormat
VCLBI.PDF.THeader
VCLBI.PDF.TTitle
Syntax
Delphi
type
 THeader=class(TFormat)
 end;

The THeader type exposes the following members.

Constructors
Show:
Name | Description
Create(TBIPDFExport) | Initializes a new instance of the THeader class. (Overrides TFormat.Create(TBIPDFExport).)
Top
Properties
Show:
Name | Description
Position | Represents property Position.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TFormat.Assign(TPersistent).)
Top
See Also

Reference

  • VCLBI.PDF


THeader.Create(TBIPDFExport) Constructor

Summary

Initializes a new instance of the THeader class.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 Constructor Create(const AParent:TBIPDFExport); override;

Parameters

AParent
Type: TBIPDFExport

Overrides

TFormat.Create(TBIPDFExport)
See Also

Reference

  • THeader
  • VCLBI.PDF


THeader.Position Property

Summary

Represents property Position.

Namespace: VCLBI.PDF
Syntax
Delphi
published
 property Position:THeaderPosition read FPosition write FPosition default AllPages;

Property Value

Type: THeaderPosition

See Also

Reference

  • THeader
  • VCLBI.PDF


THeader.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: VCLBI.PDF
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TFormat.Assign(TPersistent)
See Also

Reference

  • THeader
  • VCLBI.PDF


TPage Class

Summary

Represents type TPage.

Namespace: VCLBI.PDF
Inheritance Hierarchy
TPersistent
VCLBI.PDF.TPage
Syntax
Delphi
type
 TPage=class(TPersistent)
 end;

The TPage type exposes the following members.

Constructors
Show:
Name | Description
Create(TBIPDFExport) | Initializes a new instance of the TPage class.
Destroy | Represents the destructor of the TPage class.
Top
Properties
Show:
Name | Description
Current | Represents property Current.
CustomHeight | Represents property CustomHeight.
CustomWidth | Represents property CustomWidth.
Numbering | Represents property Numbering.
Orientation | Represents property Orientation.
Size | Represents property Size.
Total | Represents property Total.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
See Also

Reference

  • VCLBI.PDF


TPage.Create(TBIPDFExport) Constructor

Summary

Initializes a new instance of the TPage class.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 Constructor Create(const AParent:TBIPDFExport);

Parameters

AParent
Type: TBIPDFExport

See Also

Reference

  • TPage
  • VCLBI.PDF


TPage.Destroy Destructor

Summary

Represents the destructor of the TPage class.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TPage
  • VCLBI.PDF


TPage.Current Property

Summary

Represents property Current.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 property Current:Integer read FCurrent;

Property Value

Type: Integer

See Also

Reference

  • TPage
  • VCLBI.PDF


TPage.CustomHeight Property

Summary

Represents property CustomHeight.

Namespace: VCLBI.PDF
Syntax
Delphi
published
 property CustomHeight:Integer read FCustomHeight write FCustomHeight default 0;

Property Value

Type: Integer

See Also

Reference

  • TPage
  • VCLBI.PDF


TPage.CustomWidth Property

Summary

Represents property CustomWidth.

Namespace: VCLBI.PDF
Syntax
Delphi
published
 property CustomWidth:Integer read FCustomWidth write FCustomWidth default 0;

Property Value

Type: Integer

See Also

Reference

  • TPage
  • VCLBI.PDF


TPage.Numbering Property

Summary

Represents property Numbering.

Namespace: VCLBI.PDF
Syntax
Delphi
published
 property Numbering:TPageNumbering read FNumbering write SetNumbering;

Property Value

Type: TPageNumbering

See Also

Reference

  • TPage
  • VCLBI.PDF


TPage.Orientation Property

Summary

Represents property Orientation.

Namespace: VCLBI.PDF
Syntax
Delphi
published
 property Orientation:TPDFPageOrientation read FOrientation write FOrientation default TPDFPageOrientation.poPortrait;

Property Value

Type: TPDFPageOrientation

See Also

Reference

  • TPage
  • VCLBI.PDF


TPage.Size Property

Summary

Represents property Size.

Namespace: VCLBI.PDF
Syntax
Delphi
published
 property Size:TPDFPageSize read FSize write FSize default TPDFPageSize.psDefault;

Property Value

Type: TPDFPageSize

See Also

Reference

  • TPage
  • VCLBI.PDF


TPage.Total Property

Summary

Represents property Total.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 property Total:Integer read FTotal;

Property Value

Type: Integer

See Also

Reference

  • TPage
  • VCLBI.PDF


TPage.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: VCLBI.PDF
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TPage
  • VCLBI.PDF


TPageNumbering Class

Summary

Represents type TPageNumbering.

Namespace: VCLBI.PDF
Inheritance Hierarchy
TPersistent
VCLBI.PDF.TFormat
VCLBI.PDF.THeader
VCLBI.PDF.TTitle
VCLBI.PDF.TPageNumbering
Syntax
Delphi
type
 TPageNumbering=class(TTitle)
 end;

The TPageNumbering type exposes the following members.

Constructors
Show:
Name | Description
Create(TBIPDFExport) | Initializes a new instance of the TPageNumbering class. (Overrides TTitle.Create(TBIPDFExport).)
Top
Properties
Show:
Name | Description
Alignment | Represents property Alignment.
Expression | Represents property Expression.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TTitle.Assign(TPersistent).)
Top
See Also

Reference

  • VCLBI.PDF


TPageNumbering.Create(TBIPDFExport) Constructor

Summary

Initializes a new instance of the TPageNumbering class.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 Constructor Create(const AParent:TBIPDFExport); override;

Parameters

AParent
Type: TBIPDFExport

Overrides

TTitle.Create(TBIPDFExport)
See Also

Reference

  • TPageNumbering
  • VCLBI.PDF


TPageNumbering.Alignment Property

Summary

Represents property Alignment.

Namespace: VCLBI.PDF
Syntax
Delphi
published
 property Alignment default TAlignment.Right;

Property Value

Type: Void

See Also

Reference

  • TPageNumbering
  • VCLBI.PDF


TPageNumbering.Expression Property

Summary

Represents property Expression.

Namespace: VCLBI.PDF
Syntax
Delphi
published
 property Expression:String read FExpression write FExpression;

Property Value

Type: String

See Also

Reference

  • TPageNumbering
  • VCLBI.PDF


TPageNumbering.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: VCLBI.PDF
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TTitle.Assign(TPersistent)
See Also

Reference

  • TPageNumbering
  • VCLBI.PDF


TRowFormat Class

Summary

Represents type TRowFormat.

Namespace: VCLBI.PDF
Inheritance Hierarchy
TPersistent
VCLBI.PDF.TFormat
VCLBI.PDF.TRowFormat
Syntax
Delphi
type
 TRowFormat=class(TFormat)
 end;

The TRowFormat type exposes the following members.

Constructors
Show:
Name | Description
Create(TBIPDFExport) | Initializes a new instance of the TRowFormat class. (Overrides TFormat.Create(TBIPDFExport).)
Destroy | Represents the destructor of the TRowFormat class. (Overrides TFormat.Destroy.)
Top
Properties
Show:
Name | Description
Alternate | Represents property Alternate.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TFormat.Assign(TPersistent).)
Top
See Also

Reference

  • VCLBI.PDF


TRowFormat.Create(TBIPDFExport) Constructor

Summary

Initializes a new instance of the TRowFormat class.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 Constructor Create(const AParent:TBIPDFExport); override;

Parameters

AParent
Type: TBIPDFExport

Overrides

TFormat.Create(TBIPDFExport)
See Also

Reference

  • TRowFormat
  • VCLBI.PDF


TRowFormat.Destroy Destructor

Summary

Represents the destructor of the TRowFormat class.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TFormat.Destroy
See Also

Reference

  • TRowFormat
  • VCLBI.PDF


TRowFormat.Alternate Property

Summary

Represents property Alternate.

Namespace: VCLBI.PDF
Syntax
Delphi
published
 property Alternate:TFormat read FAlternate write SetAlternate;

Property Value

Type: TFormat

See Also

Reference

  • TRowFormat
  • VCLBI.PDF


TRowFormat.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: VCLBI.PDF
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TFormat.Assign(TPersistent)
See Also

Reference

  • TRowFormat
  • VCLBI.PDF


TTitle Class

Summary

Represents type TTitle.

Namespace: VCLBI.PDF
Inheritance Hierarchy
TPersistent
VCLBI.PDF.TFormat
VCLBI.PDF.THeader
VCLBI.PDF.TTitle
VCLBI.PDF.TPageNumbering
Syntax
Delphi
type
 TTitle=class(THeader)
 end;

The TTitle type exposes the following members.

Constructors
Show:
Name | Description
Create(TBIPDFExport) | Initializes a new instance of the TTitle class. (Overrides THeader.Create(TBIPDFExport).)
Destroy | Represents the destructor of the TTitle class. (Overrides TFormat.Destroy.)
Top
Properties
Show:
Name | Description
Alignment | Represents property Alignment.
Height | Represents property Height.
Text | Represents property Text.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides THeader.Assign(TPersistent).)
Top
See Also

Reference

  • VCLBI.PDF


TTitle.Create(TBIPDFExport) Constructor

Summary

Initializes a new instance of the TTitle class.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 Constructor Create(const AParent:TBIPDFExport); override;

Parameters

AParent
Type: TBIPDFExport

Overrides

THeader.Create(TBIPDFExport)
See Also

Reference

  • TTitle
  • VCLBI.PDF


TTitle.Destroy Destructor

Summary

Represents the destructor of the TTitle class.

Namespace: VCLBI.PDF
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TFormat.Destroy
See Also

Reference

  • TTitle
  • VCLBI.PDF


TTitle.Alignment Property

Summary

Represents property Alignment.

Namespace: VCLBI.PDF
Syntax
Delphi
published
 property Alignment:TAlignment read FAlign write FAlign default TAlignment.Center;

Property Value

Type: TAlignment

See Also

Reference

  • TTitle
  • VCLBI.PDF


TTitle.Height Property

Summary

Represents property Height.

Namespace: VCLBI.PDF
Syntax
Delphi
published
 property Height:TCoordinate read FHeight;

Property Value

Type: TCoordinate

See Also

Reference

  • TTitle
  • VCLBI.PDF


TTitle.Text Property

Summary

Represents property Text.

Namespace: VCLBI.PDF
Syntax
Delphi
published
 property Text:TStrings read FText write SetText;

Property Value

Type: TStrings

See Also

Reference

  • TTitle
  • VCLBI.PDF


TTitle.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: VCLBI.PDF
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

THeader.Assign(TPersistent)
See Also

Reference

  • TTitle
  • VCLBI.PDF


VCLBI.PDF Enumerations

Enumerations
Name | Description
TAlignment | Represents type TAlignment.
THeaderPosition | Represents type THeaderPosition.
Top


TAlignment Enumeration

Summary

Represents type TAlignment.

Namespace: VCLBI.PDF
Syntax
Delphi
type
 TAlignment=(Left,Center,Right);

The TAlignment type exposes the following members.

Members
Show:
Name | Description
Center | Represents constant Center.
Left | Represents constant Left.
Right | Represents constant Right.
Top
See Also

Reference

  • VCLBI.PDF


THeaderPosition Enumeration

Summary

Represents type THeaderPosition.

Namespace: VCLBI.PDF
Syntax
Delphi
type
 THeaderPosition=(AllPages, FirstPage);

The THeaderPosition type exposes the following members.

Members
Show:
Name | Description
AllPages | Represents constant AllPages.
FirstPage | Represents constant FirstPage.
Top
See Also

Reference

  • VCLBI.PDF


VCLBI.PDF Types

Types
Name | Description
TCoordinate | Represents an alias of the Integer type.
Top


TCoordinate Type

Summary

Represents an alias of the Integer type.

Namespace: VCLBI.PDF
Syntax
Delphi
type
 TCoordinate=Integer;
See Also

Reference

  • VCLBI.PDF


VCLBI.PDF Constants

Constants
Name | Description
BeigeColor | Represents constant BeigeColor.
SilverColor | Represents constant SilverColor.
TA_CENTER | Represents constant TA_CENTER.
TA_LEFT | Represents constant TA_LEFT.
TA_RIGHT | Represents constant TA_RIGHT.
Top


BeigeColor Constant

Summary

Represents constant BeigeColor.

Namespace: VCLBI.PDF
Syntax
Delphi
 BeigeColor=$F5F5DC;

Value

Type: Integer

See Also

Reference

  • VCLBI.PDF


SilverColor Constant

Summary

Represents constant SilverColor.

Namespace: VCLBI.PDF
Syntax
Delphi
 SilverColor=clSilver;

Value

Type: Void

See Also

Reference

  • VCLBI.PDF


TA_CENTER Constant

Summary

Represents constant TA_CENTER.

Namespace: VCLBI.PDF
Syntax
Delphi
 TA_CENTER = 6;

Value

Type: ShortInt

See Also

Reference

  • VCLBI.PDF


TA_LEFT Constant

Summary

Represents constant TA_LEFT.

Namespace: VCLBI.PDF
Syntax
Delphi
 TA_LEFT = 0;

Value

Type: ShortInt

See Also

Reference

  • VCLBI.PDF


TA_RIGHT Constant

Summary

Represents constant TA_RIGHT.

Namespace: VCLBI.PDF
Syntax
Delphi
 TA_RIGHT = 2;

Value

Type: ShortInt

See Also

Reference

  • VCLBI.PDF


VCLBI.R.Console Namespace

Summary

Represents namespace VCLBI.R.Console.

Classes
Name | Description
TBIRConsole | Represents type TBIRConsole.
Top
Routines
Name | Description
ScrollToEnd(TMemo) | Represents method ScrollToEnd(TMemo).
Top


VCLBI.R.Console Classes

Classes
Name | Description
TBIRConsole | Represents type TBIRConsole.
Top


TBIRConsole Class

Summary

Represents type TBIRConsole.

Namespace: VCLBI.R.Console
Inheritance Hierarchy
TForm
VCLBI.R.Console.TBIRConsole
Syntax
Delphi
type
 TBIRConsole = class(TForm)
 end;

The TBIRConsole type exposes the following members.

Methods
Show:
Name | Description
Add(TStrings) | Represents method Add(TStrings).
BGoClick(TObject) | Represents method BGoClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
EStatementChange(TObject) | Represents method EStatementChange(TObject).
EStatementKeyPress(TObject,Char) | Represents method EStatementKeyPress(TObject,Char).
Panel1Resize(TObject) | Represents method Panel1Resize(TObject).
Top
Fields
Show:
Name | Description
BGo | Represents field BGo.
Button1 | Represents field Button1.
EStatement | Represents field EStatement.
Memo | Represents field Memo.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Top
See Also

Reference

  • VCLBI.R.Console


TBIRConsole Methods

Methods
Name | Description
Add(TStrings) | Represents method Add(TStrings).
BGoClick(TObject) | Represents method BGoClick(TObject).
Button1Click(TObject) | Represents method Button1Click(TObject).
EStatementChange(TObject) | Represents method EStatementChange(TObject).
EStatementKeyPress(TObject,Char) | Represents method EStatementKeyPress(TObject,Char).
Panel1Resize(TObject) | Represents method Panel1Resize(TObject).
Top


TBIRConsole.Add(TStrings) Method

Summary

Represents method Add(TStrings).

Namespace: VCLBI.R.Console
Syntax
Delphi
public
 procedure Add(const Value:TStrings);

Parameters

Value
Type: TStrings

See Also

Reference

  • TBIRConsole
  • VCLBI.R.Console


TBIRConsole.BGoClick(TObject) Method

Summary

Represents method BGoClick(TObject).

Namespace: VCLBI.R.Console
Syntax
Delphi
published
 procedure BGoClick(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIRConsole
  • VCLBI.R.Console


TBIRConsole.Button1Click(TObject) Method

Summary

Represents method Button1Click(TObject).

Namespace: VCLBI.R.Console
Syntax
Delphi
published
 procedure Button1Click(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIRConsole
  • VCLBI.R.Console


TBIRConsole.EStatementChange(TObject) Method

Summary

Represents method EStatementChange(TObject).

Namespace: VCLBI.R.Console
Syntax
Delphi
published
 procedure EStatementChange(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIRConsole
  • VCLBI.R.Console


TBIRConsole.EStatementKeyPress(TObject,Char) Method

Summary

Represents method EStatementKeyPress(TObject,Char).

Namespace: VCLBI.R.Console
Syntax
Delphi
published
 procedure EStatementKeyPress(Sender: TObject; var Key: Char);

Parameters

Sender
Type: TObject

Key
Type: Char

See Also

Reference

  • TBIRConsole
  • VCLBI.R.Console


TBIRConsole.Panel1Resize(TObject) Method

Summary

Represents method Panel1Resize(TObject).

Namespace: VCLBI.R.Console
Syntax
Delphi
published
 procedure Panel1Resize(Sender: TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBIRConsole
  • VCLBI.R.Console


TBIRConsole Fields

Fields
Name | Description
BGo | Represents field BGo.
Button1 | Represents field Button1.
EStatement | Represents field EStatement.
Memo | Represents field Memo.
Panel1 | Represents field Panel1.
Panel2 | Represents field Panel2.
Panel3 | Represents field Panel3.
Top


TBIRConsole.BGo Field

Summary

Represents field BGo.

Namespace: VCLBI.R.Console
Syntax
Delphi
published
 BGo: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIRConsole
  • VCLBI.R.Console


TBIRConsole.Button1 Field

Summary

Represents field Button1.

Namespace: VCLBI.R.Console
Syntax
Delphi
published
 Button1: TButton;

Field Value

Type: TButton

See Also

Reference

  • TBIRConsole
  • VCLBI.R.Console


TBIRConsole.EStatement Field

Summary

Represents field EStatement.

Namespace: VCLBI.R.Console
Syntax
Delphi
published
 EStatement: TEdit;

Field Value

Type: TEdit

See Also

Reference

  • TBIRConsole
  • VCLBI.R.Console


TBIRConsole.Memo Field

Summary

Represents field Memo.

Namespace: VCLBI.R.Console
Syntax
Delphi
published
 Memo: TMemo;

Field Value

Type: TMemo

See Also

Reference

  • TBIRConsole
  • VCLBI.R.Console


TBIRConsole.Panel1 Field

Summary

Represents field Panel1.

Namespace: VCLBI.R.Console
Syntax
Delphi
published
 Panel1: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIRConsole
  • VCLBI.R.Console


TBIRConsole.Panel2 Field

Summary

Represents field Panel2.

Namespace: VCLBI.R.Console
Syntax
Delphi
published
 Panel2: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIRConsole
  • VCLBI.R.Console


TBIRConsole.Panel3 Field

Summary

Represents field Panel3.

Namespace: VCLBI.R.Console
Syntax
Delphi
published
 Panel3: TPanel;

Field Value

Type: TPanel

See Also

Reference

  • TBIRConsole
  • VCLBI.R.Console


VCLBI.R.Console Routines

Routines
Name | Description
ScrollToEnd(TMemo) | Represents method ScrollToEnd(TMemo).
Top


ScrollToEnd(TMemo) Method

Summary

Represents method ScrollToEnd(TMemo).

Namespace: VCLBI.R.Console
Syntax
Delphi
procedure ScrollToEnd(const AMemo:TMemo);

Parameters

AMemo
Type: TMemo

See Also

Reference

  • VCLBI.R.Console


VCLBI.Tree Namespace

Summary

Represents namespace VCLBI.Tree.

Classes
Name | Description
TBITree | Represents type TBITree.
TBITree.TBITreeNodes | Represents type TBITreeNodes.
TBITreeNode | Represents type TBITreeNode.
TBITreePlugin | Represents type TBITreePlugin.
TBITreePlugin.TNodeData | Represents type TNodeData.
TControlAccess | Represents type TControlAccess.
Top
Delegates
Name | Description
TBITreeExpandingEvent | Represents type TBITreeExpandingEvent.
Top
Types
Name | Description
TBITreePluginClass | Represents type TBITreePluginClass.
Top


VCLBI.Tree Classes

Classes
Name | Description
TBITree | Represents type TBITree.
TBITree.TBITreeNodes | Represents type TBITreeNodes.
TBITreeNode | Represents type TBITreeNode.
TBITreePlugin | Represents type TBITreePlugin.
TBITreePlugin.TNodeData | Represents type TNodeData.
TControlAccess | Represents type TControlAccess.
Top


TBITree Class

Summary

Represents type TBITree.

Namespace: VCLBI.Tree
Inheritance Hierarchy
TWinControl
VCLBI.DataControl.TBIDataControl
VCLBI.Tree.TBITree
VCLBI.Dashboard.TDashboardTree
VCLBI.Editor.Expression.TBITreeAccess
VCLBI.Editor.Template.TBITreeAccess
Syntax
Delphi
type
 [ComponentPlatformsAttribute(pidWin32 or pidWin64 or pidOSX32
 or pidiOSSimulator or pidiOSDevice
 or pidAndroid
 or pidiOSDevice64
 )]
 TBITree=class(TBIDataControl)
 end;

The TBITree type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBITree class. (Overrides TBIDataControl.Create(TComponent).)
Destroy | Represents the destructor of the TBITree class. (Overrides TBIDataControl.Destroy.)
Top
Properties
Show:
Name | Description
AllowDelete | Represents property AllowDelete.
Color | Represents property Color.
Nodes | Represents property Nodes.
OnChange | Represents property OnChange.
OnDeleting | Represents property OnDeleting.
Plugin | Represents property Plugin.
Selected | Represents property Selected.
Top
Methods
Show:
Name | Description
Add(String,TObject) | Overloaded. Represents method Add(String,TObject).
Add(TBITreeNode,String,TObject) | Overloaded. Represents method Add(TBITreeNode,String,TObject).
BeginUpdating | Represents method BeginUpdating.
ChangeDragMode | Represents method ChangeDragMode.
ChangePlugin(TBITreePluginClass) | Represents method ChangePlugin(TBITreePluginClass).
Clear(TBITreeNode) | Represents method Clear(TBITreeNode).
DataOf(TBITreeNode) | Represents method DataOf(TBITreeNode).
DeletedNode(TObject) | Represents method DeletedNode(TObject).
EndUpdating | Represents method EndUpdating.
Expand(TBITreeNode,Boolean,Boolean) | Represents method Expand(TBITreeNode,Boolean,Boolean).
Fill(TDataItem) | Overloaded. Represents method Fill(TDataItem).
Fill(TDataItem,TDataItem) | Overloaded. Represents method Fill(TDataItem,TDataItem).
FillParent(TDataItem,TDataItem,TDataItem) | Represents method FillParent(TDataItem,TDataItem,TDataItem).
FillStore(String) | Represents method FillStore(String).
FillStores | Represents method FillStores.
Find(String) | Represents method Find(String).
Loaded | Represents method Loaded. (Overrides TBIDataControl.Loaded.)
NodeAt(Integer,Integer) | Represents method NodeAt(Integer,Integer).
ParentOf(TBITreeNode) | Represents method ParentOf(TBITreeNode).
SelectedData | Represents method SelectedData.
SelectedText | Represents method SelectedText.
SetDataDirect(TDataItem) | Represents method SetDataDirect(TDataItem). (Overrides TBIDataControl.SetDataDirect(TDataItem).)
SetNodeData(TBITreeNode,TObject) | Represents method SetNodeData(TBITreeNode,TObject).
Top
Events
Show:
Name | Description
OnExpanding | Represents property OnExpanding.
Top
Fields
Show:
Name | Description
Engine | Represents field Engine.
Top
See Also

Reference

  • VCLBI.Tree


TBITree.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBITree class.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 Constructor Create(AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TBIDataControl.Create(TComponent)
See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.Destroy Destructor

Summary

Represents the destructor of the TBITree class.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TBIDataControl.Destroy
See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree Properties

Properties
Name | Description
AllowDelete | Represents property AllowDelete.
Color | Represents property Color.
Nodes | Represents property Nodes.
OnChange | Represents property OnChange.
OnDeleting | Represents property OnDeleting.
Plugin | Represents property Plugin.
Selected | Represents property Selected.
Top


TBITree.AllowDelete Property

Summary

Represents property AllowDelete.

Namespace: VCLBI.Tree
Syntax
Delphi
published
 property AllowDelete:Boolean read GetAllowDelete write SetAllowDelete default False;

Property Value

Type: Boolean

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.Color Property

Summary

Represents property Color.

Namespace: VCLBI.Tree
Syntax
Delphi
published
 property Color default clWhite;

Property Value

Type: Void

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.Nodes Property

Summary

Represents property Nodes.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 property Nodes:TBITreeNodes read FNodes;

Property Value

Type: TBITreeNodes

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.OnChange Property

Summary

Represents property OnChange.

Namespace: VCLBI.Tree
Syntax
Delphi
published
 property OnChange:TNotifyEvent read GetOnChange write SetOnChange;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.OnDeleting Property

Summary

Represents property OnDeleting.

Namespace: VCLBI.Tree
Syntax
Delphi
published
 property OnDeleting:TNotifyEvent read FOnDeleting write FOnDeleting;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.Plugin Property

Summary

Represents property Plugin.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 property Plugin:TBITreePlugin read FPlugin write SetPlugin;

Property Value

Type: TBITreePlugin

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.Selected Property

Summary

Represents property Selected.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 property Selected:TBITreeNode read GetSelected write SetSelected;

Property Value

Type: TBITreeNode

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.Add(String,TObject) Method

Summary

Represents method Add(String,TObject).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 function Add(const AText:String; const AObject:TObject=nil):TBITreeNode; overload; inline;

Parameters

AText
Type: String

AObject
Type: TObject

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.Add(TBITreeNode,String,TObject) Method

Summary

Represents method Add(TBITreeNode,String,TObject).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 function Add(const AParent:TBITreeNode; const AText:String; const AObject:TObject=nil):TBITreeNode; overload;

Parameters

AParent
Type: TBITreeNode

AText
Type: String

AObject
Type: TObject

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.BeginUpdating Method

Summary

Represents method BeginUpdating.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 procedure BeginUpdating;
See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.ChangeDragMode Method

Summary

Represents method ChangeDragMode.

Namespace: VCLBI.Tree
Syntax
Delphi
protected
 procedure ChangeDragMode;
See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.ChangePlugin(TBITreePluginClass) Method

Summary

Represents method ChangePlugin(TBITreePluginClass).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 procedure ChangePlugin(const APluginClass:TBITreePluginClass);

Parameters

APluginClass
Type: TBITreePluginClass

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.Clear(TBITreeNode) Method

Summary

Represents method Clear(TBITreeNode).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 procedure Clear(const ANode:TBITreeNode=nil);

Parameters

ANode
Type: TBITreeNode

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.DataOf(TBITreeNode) Method

Summary

Represents method DataOf(TBITreeNode).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 function DataOf(const ANode:TBITreeNode):TObject;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TObject

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.DeletedNode(TObject) Method

Summary

Represents method DeletedNode(TObject).

Namespace: VCLBI.Tree
Syntax
Delphi
protected
 procedure DeletedNode(Sender:TObject);

Parameters

Sender
Type: TObject

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.EndUpdating Method

Summary

Represents method EndUpdating.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 procedure EndUpdating;
See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.Expand(TBITreeNode,Boolean,Boolean) Method

Summary

Represents method Expand(TBITreeNode,Boolean,Boolean).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 procedure Expand(const ANode:TBITreeNode;
 const DoExpand:Boolean=True;
 const Recursive:Boolean=False);

Parameters

ANode
Type: TBITreeNode

DoExpand
Type: Boolean

Recursive
Type: Boolean

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.Fill(TDataItem) Method

Summary

Represents method Fill(TDataItem).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 procedure Fill(const AData:TDataItem); overload;

Parameters

AData
Type: TDataItem

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.Fill(TDataItem,TDataItem) Method

Summary

Represents method Fill(TDataItem,TDataItem).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 procedure Fill(const AMaster,ADetail:TDataItem); overload;

Parameters

AMaster
Type: TDataItem

ADetail
Type: TDataItem

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.FillParent(TDataItem,TDataItem,TDataItem) Method

Summary

Represents method FillParent(TDataItem,TDataItem,TDataItem).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 procedure FillParent(const AKey,AParent:TDataItem; const ADisplay:TDataItem=nil);

Parameters

AKey
Type: TDataItem

AParent
Type: TDataItem

ADisplay
Type: TDataItem

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.FillStore(String) Method

Summary

Represents method FillStore(String).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 procedure FillStore(const AStore:String);

Parameters

AStore
Type: String

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.FillStores Method

Summary

Represents method FillStores.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 procedure FillStores;
See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.Find(String) Method

Summary

Represents method Find(String).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 function Find(const AText:String):TBITreeNode;

Parameters

AText
Type: String

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.Loaded Method

Summary

Represents method Loaded.

Namespace: VCLBI.Tree
Syntax
Delphi
protected
 procedure Loaded; override;

Overrides

TBIDataControl.Loaded
See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.NodeAt(Integer,Integer) Method

Summary

Represents method NodeAt(Integer,Integer).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 function NodeAt(const X,Y:Integer):TBITreeNode;

Parameters

X
Type: Integer

Y
Type: Integer

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.ParentOf(TBITreeNode) Method

Summary

Represents method ParentOf(TBITreeNode).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 function ParentOf(const ANode:TBITreeNode):TBITreeNode;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.SelectedData Method

Summary

Represents method SelectedData.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 function SelectedData:TDataItem;

Return Value

Type: TDataItem

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.SelectedText Method

Summary

Represents method SelectedText.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 function SelectedText:String;

Return Value

Type: String

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.SetDataDirect(TDataItem) Method

Summary

Represents method SetDataDirect(TDataItem).

Namespace: VCLBI.Tree
Syntax
Delphi
protected
 procedure SetDataDirect(const Value: TDataItem); override;

Parameters

Value
Type: TDataItem

Overrides

TBIDataControl.SetDataDirect(TDataItem)
See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.SetNodeData(TBITreeNode,TObject) Method

Summary

Represents method SetNodeData(TBITreeNode,TObject).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 procedure SetNodeData(const ANode:TBITreeNode; const AData:TObject);

Parameters

ANode
Type: TBITreeNode

AData
Type: TObject

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.OnExpanding Event

Summary

Represents property OnExpanding.

Namespace: VCLBI.Tree
Syntax
Delphi
published
 property OnExpanding:TBITreeExpandingEvent read GetExpanding write SetExpanding;

Value

Type: TBITreeExpandingEvent

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.Engine Field

Summary

Represents field Engine.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 class var
 Engine : TBITreePluginClass;

Field Value

Type: TBITreePluginClass

See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.TBITreeNodes Class

Summary

Represents type TBITreeNodes.

Namespace: VCLBI.Tree
Inheritance Hierarchy
TObject
VCLBI.Tree.TBITree.TBITreeNodes
Syntax
Delphi
public
type
 TBITreeNodes=class
 end;

The TBITree.TBITreeNodes type exposes the following members.

Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Count | Represents method Count.
Top
See Also

Reference

  • TBITree
  • VCLBI.Tree


TBITree.TBITreeNodes.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: VCLBI.Tree
Syntax
Delphi
public
 property Items[const Index:Integer]:TBITreeNode read Get; default;

Parameters

Index
Type: Integer

Property Value

Type: TBITreeNode

See Also

Reference

  • TBITree.TBITreeNodes
  • TBITree
  • VCLBI.Tree


TBITree.TBITreeNodes.Count Method

Summary

Represents method Count.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 function Count:Integer;

Return Value

Type: Integer

See Also

Reference

  • TBITree.TBITreeNodes
  • TBITree
  • VCLBI.Tree


TBITreeNode Class

Summary

Represents type TBITreeNode.

Namespace: VCLBI.Tree
Inheritance Hierarchy
TObject
VCLBI.Tree.TBITreeNode
Syntax
Delphi
type
 TBITreeNode=class(TObject);
See Also

Reference

  • VCLBI.Tree


TBITreePlugin Class

Summary

Represents type TBITreePlugin.

Namespace: VCLBI.Tree
Inheritance Hierarchy
TObject
VCLBI.Tree.TBITreePlugin
VCLBI.Tree.TeeTree.TTeeTreePlugin
VCLBI.Tree.TreeView.TBITreeViewPlugin
VCLBI.Tree.VirtualTreeView.TVirtualTreePlugin
Syntax
Delphi
type
 TBITreePlugin=class abstract
 end;

The TBITreePlugin type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBITreePlugin class.
Destroy | Represents the destructor of the TBITreePlugin class.
Top
Properties
Show:
Name | Description
AllowDelete | Represents property AllowDelete.
Control | Represents property Control.
Count | Represents property Count.
OnChange | Represents property OnChange.
OnCheck | Represents property OnCheck.
Selected | Represents property Selected.
SelectedData | Represents property SelectedData.
Top
Methods
Show:
Name | Description
BeginUpdating | Represents method BeginUpdating.
Children(TBITreeNode,Integer) | Represents method Children(TBITreeNode,Integer).
ChildrenCount(TBITreeNode) | Represents method ChildrenCount(TBITreeNode).
Clear(TBITreeNode) | Represents method Clear(TBITreeNode).
ClearData | Overloaded. Represents method ClearData.
ClearData(TBITreeNode) | Overloaded. Represents method ClearData(TBITreeNode).
DataOf(TBITreeNode) | Represents method DataOf(TBITreeNode).
DeleteData(TNodeData) | Represents method DeleteData(TNodeData).
EndUpdating | Represents method EndUpdating.
Expand(Integer) | Overloaded. Represents method Expand(Integer).
Expand(TBITreeNode,Boolean,Boolean) | Overloaded. Represents method Expand(TBITreeNode,Boolean,Boolean).
Find(TObject,Integer) | Represents method Find(TObject,Integer).
FirstNode | Represents method FirstNode.
GetNode(Integer) | Represents method GetNode(Integer).
IsChecked(TBITreeNode) | Represents method IsChecked(TBITreeNode).
IsExpanded(TBITreeNode) | Represents method IsExpanded(TBITreeNode).
NewNode(TBITreeNode,String,TObject,TInteger) | Represents method NewNode(TBITreeNode,String,TObject,TInteger).
NewNodeData(TObject,TInteger) | Represents method NewNodeData(TObject,TInteger).
NextNode(TBITreeNode) | Represents method NextNode(TBITreeNode).
NodeAt(Integer,Integer) | Represents method NodeAt(Integer,Integer).
ParentOf(TBITreeNode) | Represents method ParentOf(TBITreeNode).
SelectedText | Represents method SelectedText.
SetChecked(TBITreeNode,Boolean) | Represents method SetChecked(TBITreeNode,Boolean).
SetData(TBITreeNode,TObject) | Represents method SetData(TBITreeNode,TObject).
SetText(TBITreeNode,String) | Represents method SetText(TBITreeNode,String).
SiblingIndex(TBITreeNode) | Represents method SiblingIndex(TBITreeNode).
TextOf(TBITreeNode) | Represents method TextOf(TBITreeNode).
Top
Events
Show:
Name | Description
OnExpanding | Represents property OnExpanding.
Top
Fields
Show:
Name | Description
FOnDelete | Represents field FOnDelete.
IData | Represents field IData.
Top
See Also

Reference

  • VCLBI.Tree


TBITreePlugin.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBITreePlugin class.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); virtual; abstract;

Parameters

AOwner
Type: TComponent

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.Destroy Destructor

Summary

Represents the destructor of the TBITreePlugin class.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.AllowDelete Property

Summary

Represents property AllowDelete.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 property AllowDelete:Boolean read GetAllowDelete write SetAllowDelete;

Property Value

Type: Boolean

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.Control Property

Summary

Represents property Control.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 property Control:TControl read GetControl;

Property Value

Type: TControl

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.Count Property

Summary

Represents property Count.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 property Count:Integer read GetCount;

Property Value

Type: Integer

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.OnChange Property

Summary

Represents property OnChange.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 property OnChange:TNotifyEvent read GetOnChange write SetOnChange;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.OnCheck Property

Summary

Represents property OnCheck.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 property OnCheck:TNotifyEvent read GetOnCheck write SetOnCheck;

Property Value

Type: TNotifyEvent

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.Selected Property

Summary

Represents property Selected.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 property Selected:TBITreeNode read GetSelected write SetSelected;

Property Value

Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.SelectedData Property

Summary

Represents property SelectedData.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 property SelectedData:TBITreePlugin.TNodeData read GetSelectedData;

Property Value

Type: TBITreePlugin.TNodeData

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.BeginUpdating Method

Summary

Represents method BeginUpdating.

Namespace: VCLBI.Tree
Syntax
Delphi
protected
 procedure BeginUpdating; virtual; abstract;
See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.Children(TBITreeNode,Integer) Method

Summary

Represents method Children(TBITreeNode,Integer).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 function Children(const ANode:TBITreeNode; const AIndex:Integer):TBITreeNode; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

AIndex
Type: Integer

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.ChildrenCount(TBITreeNode) Method

Summary

Represents method ChildrenCount(TBITreeNode).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 function ChildrenCount(const ANode:TBITreeNode):Integer; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Integer

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.Clear(TBITreeNode) Method

Summary

Represents method Clear(TBITreeNode).

Namespace: VCLBI.Tree
Syntax
Delphi
protected
 procedure Clear(const ANode:TBITreeNode=nil); virtual; abstract;

Parameters

ANode
Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.ClearData Method

Summary

Represents method ClearData.

Namespace: VCLBI.Tree
Syntax
Delphi
protected
 procedure ClearData; overload;
See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.ClearData(TBITreeNode) Method

Summary

Represents method ClearData(TBITreeNode).

Namespace: VCLBI.Tree
Syntax
Delphi
protected
 procedure ClearData(const ANode:TBITreeNode); overload; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.DataOf(TBITreeNode) Method

Summary

Represents method DataOf(TBITreeNode).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 function DataOf(const ANode:TBITreeNode):TObject; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TObject

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.DeleteData(TNodeData) Method

Summary

Represents method DeleteData(TNodeData).

Namespace: VCLBI.Tree
Syntax
Delphi
protected
 procedure DeleteData(const AData:TNodeData);

Parameters

AData
Type: TNodeData

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.EndUpdating Method

Summary

Represents method EndUpdating.

Namespace: VCLBI.Tree
Syntax
Delphi
protected
 procedure EndUpdating; virtual; abstract;
See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.Expand(Integer) Method

Summary

Represents method Expand(Integer).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 procedure Expand(const AIndex:Integer); overload; virtual; abstract;

Parameters

AIndex
Type: Integer

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.Expand(TBITreeNode,Boolean,Boolean) Method

Summary

Represents method Expand(TBITreeNode,Boolean,Boolean).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 procedure Expand(const ANode:TBITreeNode;
 const DoExpand:Boolean=True;
 const Recursive:Boolean=False); overload; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

DoExpand
Type: Boolean

Recursive
Type: Boolean

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.Find(TObject,Integer) Method

Summary

Represents method Find(TObject,Integer).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 function Find(const ATag:TObject; const AIndex:Integer=-1):TBITreeNode; virtual; abstract;

Parameters

ATag
Type: TObject

AIndex
Type: Integer

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.FirstNode Method

Summary

Represents method FirstNode.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 function FirstNode:TBITreeNode; virtual; abstract;

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.GetNode(Integer) Method

Summary

Represents method GetNode(Integer).

Namespace: VCLBI.Tree
Syntax
Delphi
protected
 function GetNode(const AIndex:Integer):TBITreeNode; virtual; abstract;

Parameters

AIndex
Type: Integer

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.IsChecked(TBITreeNode) Method

Summary

Represents method IsChecked(TBITreeNode).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 function IsChecked(const ANode:TBITreeNode):Boolean; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Boolean

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.IsExpanded(TBITreeNode) Method

Summary

Represents method IsExpanded(TBITreeNode).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 function IsExpanded(const ANode:TBITreeNode):Boolean; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Boolean

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.NewNode(TBITreeNode,String,TObject,TInteger) Method

Summary

Represents method NewNode(TBITreeNode,String,TObject,TInteger).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 function NewNode(const AParent:TBITreeNode; const AText:String;
 const ATag:TObject=nil;
 const AIndex:TInteger=-1):TBITreeNode; virtual; abstract;

Parameters

AParent
Type: TBITreeNode

AText
Type: String

ATag
Type: TObject

AIndex
Type: System.Void

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.NewNodeData(TObject,TInteger) Method

Summary

Represents method NewNodeData(TObject,TInteger).

Namespace: VCLBI.Tree
Syntax
Delphi
protected
 function NewNodeData(const ATag:TObject; const AIndex:TInteger):TNodeData;

Parameters

ATag
Type: TObject

AIndex
Type: System.Void

Return Value

Type: TNodeData

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.NextNode(TBITreeNode) Method

Summary

Represents method NextNode(TBITreeNode).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 function NextNode(const ANode:TBITreeNode):TBITreeNode; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.NodeAt(Integer,Integer) Method

Summary

Represents method NodeAt(Integer,Integer).

Namespace: VCLBI.Tree
Syntax
Delphi
protected
 function NodeAt(const X,Y:Integer):TBITreeNode; virtual; abstract;

Parameters

X
Type: Integer

Y
Type: Integer

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.ParentOf(TBITreeNode) Method

Summary

Represents method ParentOf(TBITreeNode).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 function ParentOf(const ANode:TBITreeNode):TBITreeNode; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TBITreeNode

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.SelectedText Method

Summary

Represents method SelectedText.

Namespace: VCLBI.Tree
Syntax
Delphi
protected
 function SelectedText:String; virtual; abstract;

Return Value

Type: String

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.SetChecked(TBITreeNode,Boolean) Method

Summary

Represents method SetChecked(TBITreeNode,Boolean).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 procedure SetChecked(const ANode:TBITreeNode; const Value:Boolean); virtual; abstract;

Parameters

ANode
Type: TBITreeNode

Value
Type: Boolean

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.SetData(TBITreeNode,TObject) Method

Summary

Represents method SetData(TBITreeNode,TObject).

Namespace: VCLBI.Tree
Syntax
Delphi
protected
 procedure SetData(const ANode:TBITreeNode; const AData:TObject); virtual; abstract;

Parameters

ANode
Type: TBITreeNode

AData
Type: TObject

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.SetText(TBITreeNode,String) Method

Summary

Represents method SetText(TBITreeNode,String).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 procedure SetText(const ANode:TBITreeNode; const Value:String); virtual; abstract;

Parameters

ANode
Type: TBITreeNode

Value
Type: String

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.SiblingIndex(TBITreeNode) Method

Summary

Represents method SiblingIndex(TBITreeNode).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 function SiblingIndex(const ANode:TBITreeNode):Integer; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Integer

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.TextOf(TBITreeNode) Method

Summary

Represents method TextOf(TBITreeNode).

Namespace: VCLBI.Tree
Syntax
Delphi
public
 function TextOf(const ANode:TBITreeNode):String; virtual; abstract;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: String

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.OnExpanding Event

Summary

Represents property OnExpanding.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 property OnExpanding:TBITreeExpandingEvent read GetOnExpanding write SetOnExpanding;

Value

Type: TBITreeExpandingEvent

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.FOnDelete Field

Summary

Represents field FOnDelete.

Namespace: VCLBI.Tree
Syntax
Delphi
protected
 FOnDelete : TNotifyEvent;

Field Value

Type: TNotifyEvent

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.IData Field

Summary

Represents field IData.

Namespace: VCLBI.Tree
Syntax
Delphi
protected
 IData : Array of TNodeData;

Field Value

Type: Array of TNodeData

See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.TNodeData Class

Summary

Represents type TNodeData.

Namespace: VCLBI.Tree
Inheritance Hierarchy
TObject
VCLBI.Tree.TBITreePlugin.TNodeData
Syntax
Delphi
public
type
 TNodeData=class
 end;

The TBITreePlugin.TNodeData type exposes the following members.

Fields
Show:
Name | Description
Index | Represents field Index.
Tag | Represents field Tag.
Top
See Also

Reference

  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.TNodeData.Index Field

Summary

Represents field Index.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 Index : TInteger;

Field Value

Type: TInteger

See Also

Reference

  • TBITreePlugin.TNodeData
  • TBITreePlugin
  • VCLBI.Tree


TBITreePlugin.TNodeData.Tag Field

Summary

Represents field Tag.

Namespace: VCLBI.Tree
Syntax
Delphi
public
 Tag : TObject;

Field Value

Type: TObject

See Also

Reference

  • TBITreePlugin.TNodeData
  • TBITreePlugin
  • VCLBI.Tree


TControlAccess Class

Summary

Represents type TControlAccess.

Namespace: VCLBI.Tree
Inheritance Hierarchy
TWinControl
VCLBI.Tree.TControlAccess
Syntax
Delphi
type
 TControlAccess=class(TWinControl);
See Also

Reference

  • VCLBI.Tree


VCLBI.Tree Delegates

Delegates
Name | Description
TBITreeExpandingEvent | Represents type TBITreeExpandingEvent.
Top


TBITreeExpandingEvent Delegate

Summary

Represents type TBITreeExpandingEvent.

Namespace: VCLBI.Tree
Syntax
Delphi
type
 TBITreeExpandingEvent=procedure(Sender: TObject; const Node: TBITreeNode;
 var AllowExpansion: Boolean) of object;
See Also

Reference

  • VCLBI.Tree


VCLBI.Tree Types

Types
Name | Description
TBITreePluginClass | Represents type TBITreePluginClass.
Top


TBITreePluginClass Type

Summary

Represents type TBITreePluginClass.

Namespace: VCLBI.Tree
Syntax
Delphi
type
 TBITreePluginClass=class of TBITreePlugin;
See Also

Reference

  • VCLBI.Tree


VCLBI.Tree.TeeTree Namespace

Summary

Represents namespace VCLBI.Tree.TeeTree.

Classes
Name | Description
TTeeTreePlugin | Represents type TTeeTreePlugin.
TTreeNodeShapeAccess | Represents type TTreeNodeShapeAccess.
Top


VCLBI.Tree.TeeTree Classes

Classes
Name | Description
TTeeTreePlugin | Represents type TTeeTreePlugin.
TTreeNodeShapeAccess | Represents type TTreeNodeShapeAccess.
Top


TTeeTreePlugin Class

Summary

Represents type TTeeTreePlugin.

Namespace: VCLBI.Tree.TeeTree
Inheritance Hierarchy
TObject
VCLBI.Tree.TBITreePlugin
VCLBI.Tree.TeeTree.TTeeTreePlugin
Syntax
Delphi
type
 TTeeTreePlugin=class(TBITreePlugin)
 end;

The TTeeTreePlugin type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TTeeTreePlugin class. (Overrides TBITreePlugin.Create(TComponent).)
Top
Methods
Show:
Name | Description
BeginUpdating | Represents method BeginUpdating. (Overrides TBITreePlugin.BeginUpdating.)
Children(TBITreeNode,Integer) | Represents method Children(TBITreeNode,Integer). (Overrides TBITreePlugin.Children(TBITreeNode,Integer).)
ChildrenCount(TBITreeNode) | Represents method ChildrenCount(TBITreeNode). (Overrides TBITreePlugin.ChildrenCount(TBITreeNode).)
Clear(TBITreeNode) | Represents method Clear(TBITreeNode). (Overrides TBITreePlugin.Clear(TBITreeNode).)
ClearData(TBITreeNode) | Represents method ClearData(TBITreeNode). (Overrides TBITreePlugin.ClearData(TBITreeNode).)
DataOf(TBITreeNode) | Represents method DataOf(TBITreeNode). (Overrides TBITreePlugin.DataOf(TBITreeNode).)
EndUpdating | Represents method EndUpdating. (Overrides TBITreePlugin.EndUpdating.)
Expand(Integer) | Represents method Expand(Integer). (Overrides TBITreePlugin.Expand(Integer).)
Expand(TBITreeNode,Boolean,Boolean) | Represents method Expand(TBITreeNode,Boolean,Boolean). (Overrides TBITreePlugin.Expand(TBITreeNode,Boolean,Boolean).)
Find(TObject,Integer) | Represents method Find(TObject,Integer). (Overrides TBITreePlugin.Find(TObject,Integer).)
FirstNode | Represents method FirstNode. (Overrides TBITreePlugin.FirstNode.)
GetAllowDelete | Represents method GetAllowDelete. (Overrides TBITreePlugin.GetAllowDelete.)
GetControl | Represents method GetControl. (Overrides TBITreePlugin.GetControl.)
GetCount | Represents method GetCount. (Overrides TBITreePlugin.GetCount.)
GetNode(Integer) | Represents method GetNode(Integer). (Overrides TBITreePlugin.GetNode(Integer).)
GetOnChange | Represents method GetOnChange. (Overrides TBITreePlugin.GetOnChange.)
GetOnCheck | Represents method GetOnCheck. (Overrides TBITreePlugin.GetOnCheck.)
GetOnExpanding | Represents method GetOnExpanding. (Overrides TBITreePlugin.GetOnExpanding.)
GetSelected | Represents method GetSelected. (Overrides TBITreePlugin.GetSelected.)
GetSelectedData | Represents method GetSelectedData. (Overrides TBITreePlugin.GetSelectedData.)
IsChecked(TBITreeNode) | Represents method IsChecked(TBITreeNode). (Overrides TBITreePlugin.IsChecked(TBITreeNode).)
IsExpanded(TBITreeNode) | Represents method IsExpanded(TBITreeNode). (Overrides TBITreePlugin.IsExpanded(TBITreeNode).)
NewNode(TBITreeNode,String,TObject,TInteger) | Represents method NewNode(TBITreeNode,String,TObject,TInteger). (Overrides TBITreePlugin.NewNode(TBITreeNode,String,TObject,TInteger).)
NextNode(TBITreeNode) | Represents method NextNode(TBITreeNode). (Overrides TBITreePlugin.NextNode(TBITreeNode).)
NodeAt(Integer,Integer) | Represents method NodeAt(Integer,Integer). (Overrides TBITreePlugin.NodeAt(Integer,Integer).)
ParentOf(TBITreeNode) | Represents method ParentOf(TBITreeNode). (Overrides TBITreePlugin.ParentOf(TBITreeNode).)
SelectedText | Represents method SelectedText. (Overrides TBITreePlugin.SelectedText.)
SetAllowDelete(Boolean) | Represents method SetAllowDelete(Boolean). (Overrides TBITreePlugin.SetAllowDelete(Boolean).)
SetChecked(TBITreeNode,Boolean) | Represents method SetChecked(TBITreeNode,Boolean). (Overrides TBITreePlugin.SetChecked(TBITreeNode,Boolean).)
SetData(TBITreeNode,TObject) | Represents method SetData(TBITreeNode,TObject). (Overrides TBITreePlugin.SetData(TBITreeNode,TObject).)
SetOnChange(TNotifyEvent) | Represents method SetOnChange(TNotifyEvent). (Overrides TBITreePlugin.SetOnChange(TNotifyEvent).)
SetOnCheck(TNotifyEvent) | Represents method SetOnCheck(TNotifyEvent). (Overrides TBITreePlugin.SetOnCheck(TNotifyEvent).)
SetOnExpanding(TBITreeExpandingEvent) | Represents method SetOnExpanding(TBITreeExpandingEvent). (Overrides TBITreePlugin.SetOnExpanding(TBITreeExpandingEvent).)
SetSelected(TBITreeNode) | Represents method SetSelected(TBITreeNode). (Overrides TBITreePlugin.SetSelected(TBITreeNode).)
SetText(TBITreeNode,String) | Represents method SetText(TBITreeNode,String). (Overrides TBITreePlugin.SetText(TBITreeNode,String).)
SiblingIndex(TBITreeNode) | Represents method SiblingIndex(TBITreeNode). (Overrides TBITreePlugin.SiblingIndex(TBITreeNode).)
TextOf(TBITreeNode) | Represents method TextOf(TBITreeNode). (Overrides TBITreePlugin.TextOf(TBITreeNode).)
Top
See Also

Reference

  • VCLBI.Tree.TeeTree


TTeeTreePlugin.Create(TComponent) Constructor

Summary

Initializes a new instance of the TTeeTreePlugin class.

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TBITreePlugin.Create(TComponent)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.BeginUpdating Method

Summary

Represents method BeginUpdating.

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
protected
 procedure BeginUpdating; override;

Overrides

TBITreePlugin.BeginUpdating
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.Children(TBITreeNode,Integer) Method

Summary

Represents method Children(TBITreeNode,Integer).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
public
 function Children(const ANode:TBITreeNode; const AIndex:Integer):TBITreeNode; override;

Parameters

ANode
Type: TBITreeNode

AIndex
Type: Integer

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.Children(TBITreeNode,Integer)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.ChildrenCount(TBITreeNode) Method

Summary

Represents method ChildrenCount(TBITreeNode).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
public
 function ChildrenCount(const ANode:TBITreeNode):Integer; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Integer

Overrides

TBITreePlugin.ChildrenCount(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.Clear(TBITreeNode) Method

Summary

Represents method Clear(TBITreeNode).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
protected
 procedure Clear(const ANode:TBITreeNode=nil); override;

Parameters

ANode
Type: TBITreeNode

Overrides

TBITreePlugin.Clear(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.ClearData(TBITreeNode) Method

Summary

Represents method ClearData(TBITreeNode).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
protected
 procedure ClearData(const ANode:TBITreeNode); override;

Parameters

ANode
Type: TBITreeNode

Overrides

TBITreePlugin.ClearData(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.DataOf(TBITreeNode) Method

Summary

Represents method DataOf(TBITreeNode).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
public
 function DataOf(const ANode:TBITreeNode):TObject; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TObject

Overrides

TBITreePlugin.DataOf(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.EndUpdating Method

Summary

Represents method EndUpdating.

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
protected
 procedure EndUpdating; override;

Overrides

TBITreePlugin.EndUpdating
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.Expand(TBITreeNode,Boolean,Boolean) Method

Summary

Represents method Expand(TBITreeNode,Boolean,Boolean).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
public
 procedure Expand(const ANode:TBITreeNode; const DoExpand:Boolean=True; const Recursive:Boolean=False); override;

Parameters

ANode
Type: TBITreeNode

DoExpand
Type: Boolean

Recursive
Type: Boolean

Overrides

TBITreePlugin.Expand(TBITreeNode,Boolean,Boolean)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.Find(TObject,Integer) Method

Summary

Represents method Find(TObject,Integer).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
public
 function Find(const ATag:TObject; const AIndex:Integer):TBITreeNode; override;

Parameters

ATag
Type: TObject

AIndex
Type: Integer

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.Find(TObject,Integer)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.FirstNode Method

Summary

Represents method FirstNode.

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
public
 function FirstNode:TBITreeNode; override;

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.FirstNode
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.GetAllowDelete Method

Summary

Represents method GetAllowDelete.

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
protected
 function GetAllowDelete: Boolean; override;

Return Value

Type: Boolean

Overrides

TBITreePlugin.GetAllowDelete
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.GetControl Method

Summary

Represents method GetControl.

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
protected
 function GetControl:TControl; override;

Return Value

Type: TControl

Overrides

TBITreePlugin.GetControl
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.GetCount Method

Summary

Represents method GetCount.

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
protected
 function GetCount:Integer; override;

Return Value

Type: Integer

Overrides

TBITreePlugin.GetCount
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.GetNode(Integer) Method

Summary

Represents method GetNode(Integer).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
protected
 function GetNode(const AIndex:Integer):TBITreeNode; override;

Parameters

AIndex
Type: Integer

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.GetNode(Integer)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.GetOnChange Method

Summary

Represents method GetOnChange.

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
protected
 function GetOnChange: TNotifyEvent; override;

Return Value

Type: TNotifyEvent

Overrides

TBITreePlugin.GetOnChange
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.GetOnCheck Method

Summary

Represents method GetOnCheck.

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
protected
 function GetOnCheck: TNotifyEvent; override;

Return Value

Type: TNotifyEvent

Overrides

TBITreePlugin.GetOnCheck
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.GetOnExpanding Method

Summary

Represents method GetOnExpanding.

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
protected
 function GetOnExpanding: TBITreeExpandingEvent; override;

Return Value

Type: TBITreeExpandingEvent

Overrides

TBITreePlugin.GetOnExpanding
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.GetSelected Method

Summary

Represents method GetSelected.

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
protected
 function GetSelected:TBITreeNode; override;

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.GetSelected
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.GetSelectedData Method

Summary

Represents method GetSelectedData.

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
protected
 function GetSelectedData: TBITreePlugin.TNodeData; override;

Return Value

Type: TBITreePlugin.TNodeData

Overrides

TBITreePlugin.GetSelectedData
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.IsChecked(TBITreeNode) Method

Summary

Represents method IsChecked(TBITreeNode).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
public
 function IsChecked(const ANode:TBITreeNode):Boolean; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Boolean

Overrides

TBITreePlugin.IsChecked(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.IsExpanded(TBITreeNode) Method

Summary

Represents method IsExpanded(TBITreeNode).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
public
 function IsExpanded(const ANode:TBITreeNode):Boolean; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Boolean

Overrides

TBITreePlugin.IsExpanded(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.NewNode(TBITreeNode,String,TObject,TInteger) Method

Summary

Represents method NewNode(TBITreeNode,String,TObject,TInteger).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
public
 function NewNode(const AParent:TBITreeNode; const AText:String;
 const ATag:TObject=nil; const AIndex:TInteger=-1):TBITreeNode; override;

Parameters

AParent
Type: TBITreeNode

AText
Type: String

ATag
Type: TObject

AIndex
Type: System.Void

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.NewNode(TBITreeNode,String,TObject,TInteger)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.NextNode(TBITreeNode) Method

Summary

Represents method NextNode(TBITreeNode).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
public
 function NextNode(const ANode:TBITreeNode):TBITreeNode; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.NextNode(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.NodeAt(Integer,Integer) Method

Summary

Represents method NodeAt(Integer,Integer).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
protected
 function NodeAt(const X,Y:Integer):TBITreeNode; override;

Parameters

X
Type: Integer

Y
Type: Integer

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.NodeAt(Integer,Integer)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.ParentOf(TBITreeNode) Method

Summary

Represents method ParentOf(TBITreeNode).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
public
 function ParentOf(const ANode:TBITreeNode):TBITreeNode; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.ParentOf(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.SelectedText Method

Summary

Represents method SelectedText.

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
protected
 function SelectedText:String; override;

Return Value

Type: String

Overrides

TBITreePlugin.SelectedText
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.SetAllowDelete(Boolean) Method

Summary

Represents method SetAllowDelete(Boolean).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
protected
 procedure SetAllowDelete(const Value: Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBITreePlugin.SetAllowDelete(Boolean)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.SetChecked(TBITreeNode,Boolean) Method

Summary

Represents method SetChecked(TBITreeNode,Boolean).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
public
 procedure SetChecked(const ANode:TBITreeNode; const Value:Boolean); override;

Parameters

ANode
Type: TBITreeNode

Value
Type: Boolean

Overrides

TBITreePlugin.SetChecked(TBITreeNode,Boolean)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.SetData(TBITreeNode,TObject) Method

Summary

Represents method SetData(TBITreeNode,TObject).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
protected
 procedure SetData(const ANode: TBITreeNode; const AData: TObject); override;

Parameters

ANode
Type: TBITreeNode

AData
Type: TObject

Overrides

TBITreePlugin.SetData(TBITreeNode,TObject)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.SetOnChange(TNotifyEvent) Method

Summary

Represents method SetOnChange(TNotifyEvent).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
protected
 procedure SetOnChange(const Value: TNotifyEvent); override;

Parameters

Value
Type: TNotifyEvent

Overrides

TBITreePlugin.SetOnChange(TNotifyEvent)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.SetOnCheck(TNotifyEvent) Method

Summary

Represents method SetOnCheck(TNotifyEvent).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
protected
 procedure SetOnCheck(const Value: TNotifyEvent); override;

Parameters

Value
Type: TNotifyEvent

Overrides

TBITreePlugin.SetOnCheck(TNotifyEvent)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.SetOnExpanding(TBITreeExpandingEvent) Method

Summary

Represents method SetOnExpanding(TBITreeExpandingEvent).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
protected
 procedure SetOnExpanding(const Value: TBITreeExpandingEvent); override;

Parameters

Value
Type: TBITreeExpandingEvent

Overrides

TBITreePlugin.SetOnExpanding(TBITreeExpandingEvent)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.SetSelected(TBITreeNode) Method

Summary

Represents method SetSelected(TBITreeNode).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
protected
 procedure SetSelected(const Value: TBITreeNode); override;

Parameters

Value
Type: TBITreeNode

Overrides

TBITreePlugin.SetSelected(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.SetText(TBITreeNode,String) Method

Summary

Represents method SetText(TBITreeNode,String).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
public
 procedure SetText(const ANode:TBITreeNode; const Value:String); override;

Parameters

ANode
Type: TBITreeNode

Value
Type: String

Overrides

TBITreePlugin.SetText(TBITreeNode,String)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.SiblingIndex(TBITreeNode) Method

Summary

Represents method SiblingIndex(TBITreeNode).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
public
 function SiblingIndex(const ANode:TBITreeNode):Integer; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Integer

Overrides

TBITreePlugin.SiblingIndex(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTeeTreePlugin.TextOf(TBITreeNode) Method

Summary

Represents method TextOf(TBITreeNode).

Namespace: VCLBI.Tree.TeeTree
Syntax
Delphi
public
 function TextOf(const ANode:TBITreeNode):String; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: String

Overrides

TBITreePlugin.TextOf(TBITreeNode)
See Also

Reference

  • TTeeTreePlugin
  • VCLBI.Tree.TeeTree


TTreeNodeShapeAccess Class

Summary

Represents type TTreeNodeShapeAccess.

Namespace: VCLBI.Tree.TeeTree
Inheritance Hierarchy
TTreeNodeShape
VCLBI.Tree.TeeTree.TTreeNodeShapeAccess
Syntax
Delphi
type
 TTreeNodeShapeAccess=class(TTreeNodeShape);
See Also

Reference

  • VCLBI.Tree.TeeTree


VCLBI.Tree.TreeView Namespace

Summary

Represents namespace VCLBI.Tree.TreeView.

Classes
Name | Description
TBITreeViewPlugin | Represents type TBITreeViewPlugin.
Top
Constants
Name | Description
Img_Checked | Represents constant Img_Checked.
Img_UnChecked | Represents constant Img_UnChecked.
Top


VCLBI.Tree.TreeView Classes

Classes
Name | Description
TBITreeViewPlugin | Represents type TBITreeViewPlugin.
Top


TBITreeViewPlugin Class

Summary

Represents type TBITreeViewPlugin.

Namespace: VCLBI.Tree.TreeView
Inheritance Hierarchy
TObject
VCLBI.Tree.TBITreePlugin
VCLBI.Tree.TreeView.TBITreeViewPlugin
Syntax
Delphi
type
 TBITreeViewPlugin=class(TBITreePlugin)
 end;

The TBITreeViewPlugin type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TBITreeViewPlugin class. (Overrides TBITreePlugin.Create(TComponent).)
Top
Methods
Show:
Name | Description
BeginUpdating | Represents method BeginUpdating. (Overrides TBITreePlugin.BeginUpdating.)
Children(TBITreeNode,Integer) | Represents method Children(TBITreeNode,Integer). (Overrides TBITreePlugin.Children(TBITreeNode,Integer).)
ChildrenCount(TBITreeNode) | Represents method ChildrenCount(TBITreeNode). (Overrides TBITreePlugin.ChildrenCount(TBITreeNode).)
Clear(TBITreeNode) | Represents method Clear(TBITreeNode). (Overrides TBITreePlugin.Clear(TBITreeNode).)
ClearData(TBITreeNode) | Represents method ClearData(TBITreeNode). (Overrides TBITreePlugin.ClearData(TBITreeNode).)
DataOf(TBITreeNode) | Represents method DataOf(TBITreeNode). (Overrides TBITreePlugin.DataOf(TBITreeNode).)
EndUpdating | Represents method EndUpdating. (Overrides TBITreePlugin.EndUpdating.)
Expand(Integer) | Represents method Expand(Integer). (Overrides TBITreePlugin.Expand(Integer).)
Expand(TBITreeNode,Boolean,Boolean) | Represents method Expand(TBITreeNode,Boolean,Boolean). (Overrides TBITreePlugin.Expand(TBITreeNode,Boolean,Boolean).)
Find(TObject,Integer) | Represents method Find(TObject,Integer). (Overrides TBITreePlugin.Find(TObject,Integer).)
FirstNode | Represents method FirstNode. (Overrides TBITreePlugin.FirstNode.)
GetAllowDelete | Represents method GetAllowDelete. (Overrides TBITreePlugin.GetAllowDelete.)
GetControl | Represents method GetControl. (Overrides TBITreePlugin.GetControl.)
GetCount | Represents method GetCount. (Overrides TBITreePlugin.GetCount.)
GetNode(Integer) | Represents method GetNode(Integer). (Overrides TBITreePlugin.GetNode(Integer).)
GetOnChange | Represents method GetOnChange. (Overrides TBITreePlugin.GetOnChange.)
GetOnCheck | Represents method GetOnCheck. (Overrides TBITreePlugin.GetOnCheck.)
GetOnExpanding | Represents method GetOnExpanding. (Overrides TBITreePlugin.GetOnExpanding.)
GetSelected | Represents method GetSelected. (Overrides TBITreePlugin.GetSelected.)
GetSelectedData | Represents method GetSelectedData. (Overrides TBITreePlugin.GetSelectedData.)
IsChecked(TBITreeNode) | Represents method IsChecked(TBITreeNode). (Overrides TBITreePlugin.IsChecked(TBITreeNode).)
IsExpanded(TBITreeNode) | Represents method IsExpanded(TBITreeNode). (Overrides TBITreePlugin.IsExpanded(TBITreeNode).)
NewNode(TBITreeNode,String,TObject,TInteger) | Represents method NewNode(TBITreeNode,String,TObject,TInteger). (Overrides TBITreePlugin.NewNode(TBITreeNode,String,TObject,TInteger).)
NextNode(TBITreeNode) | Represents method NextNode(TBITreeNode). (Overrides TBITreePlugin.NextNode(TBITreeNode).)
NodeAt(Integer,Integer) | Represents method NodeAt(Integer,Integer). (Overrides TBITreePlugin.NodeAt(Integer,Integer).)
ParentOf(TBITreeNode) | Represents method ParentOf(TBITreeNode). (Overrides TBITreePlugin.ParentOf(TBITreeNode).)
SelectedText | Represents method SelectedText. (Overrides TBITreePlugin.SelectedText.)
SetAllowDelete(Boolean) | Represents method SetAllowDelete(Boolean). (Overrides TBITreePlugin.SetAllowDelete(Boolean).)
SetChecked(TBITreeNode,Boolean) | Represents method SetChecked(TBITreeNode,Boolean). (Overrides TBITreePlugin.SetChecked(TBITreeNode,Boolean).)
SetData(TBITreeNode,TObject) | Represents method SetData(TBITreeNode,TObject). (Overrides TBITreePlugin.SetData(TBITreeNode,TObject).)
SetOnChange(TNotifyEvent) | Represents method SetOnChange(TNotifyEvent). (Overrides TBITreePlugin.SetOnChange(TNotifyEvent).)
SetOnCheck(TNotifyEvent) | Represents method SetOnCheck(TNotifyEvent). (Overrides TBITreePlugin.SetOnCheck(TNotifyEvent).)
SetOnExpanding(TBITreeExpandingEvent) | Represents method SetOnExpanding(TBITreeExpandingEvent). (Overrides TBITreePlugin.SetOnExpanding(TBITreeExpandingEvent).)
SetSelected(TBITreeNode) | Represents method SetSelected(TBITreeNode). (Overrides TBITreePlugin.SetSelected(TBITreeNode).)
SetText(TBITreeNode,String) | Represents method SetText(TBITreeNode,String). (Overrides TBITreePlugin.SetText(TBITreeNode,String).)
SiblingIndex(TBITreeNode) | Represents method SiblingIndex(TBITreeNode). (Overrides TBITreePlugin.SiblingIndex(TBITreeNode).)
TextOf(TBITreeNode) | Represents method TextOf(TBITreeNode). (Overrides TBITreePlugin.TextOf(TBITreeNode).)
Top
See Also

Reference

  • VCLBI.Tree.TreeView


TBITreeViewPlugin.Create(TComponent) Constructor

Summary

Initializes a new instance of the TBITreeViewPlugin class.

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TBITreePlugin.Create(TComponent)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.BeginUpdating Method

Summary

Represents method BeginUpdating.

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
protected
 procedure BeginUpdating; override;

Overrides

TBITreePlugin.BeginUpdating
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.Children(TBITreeNode,Integer) Method

Summary

Represents method Children(TBITreeNode,Integer).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
public
 function Children(const ANode:TBITreeNode; const AIndex:Integer):TBITreeNode; override;

Parameters

ANode
Type: TBITreeNode

AIndex
Type: Integer

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.Children(TBITreeNode,Integer)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.ChildrenCount(TBITreeNode) Method

Summary

Represents method ChildrenCount(TBITreeNode).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
public
 function ChildrenCount(const ANode:TBITreeNode):Integer; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Integer

Overrides

TBITreePlugin.ChildrenCount(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.Clear(TBITreeNode) Method

Summary

Represents method Clear(TBITreeNode).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
protected
 procedure Clear(const ANode:TBITreeNode=nil); override;

Parameters

ANode
Type: TBITreeNode

Overrides

TBITreePlugin.Clear(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.ClearData(TBITreeNode) Method

Summary

Represents method ClearData(TBITreeNode).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
protected
 procedure ClearData(const ANode:TBITreeNode); override;

Parameters

ANode
Type: TBITreeNode

Overrides

TBITreePlugin.ClearData(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.DataOf(TBITreeNode) Method

Summary

Represents method DataOf(TBITreeNode).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
public
 function DataOf(const ANode:TBITreeNode):TObject; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TObject

Overrides

TBITreePlugin.DataOf(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.EndUpdating Method

Summary

Represents method EndUpdating.

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
protected
 procedure EndUpdating; override;

Overrides

TBITreePlugin.EndUpdating
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.Expand(TBITreeNode,Boolean,Boolean) Method

Summary

Represents method Expand(TBITreeNode,Boolean,Boolean).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
public
 procedure Expand(const ANode:TBITreeNode; const DoExpand:Boolean=True; const Recursive:Boolean=False); override;

Parameters

ANode
Type: TBITreeNode

DoExpand
Type: Boolean

Recursive
Type: Boolean

Overrides

TBITreePlugin.Expand(TBITreeNode,Boolean,Boolean)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.Find(TObject,Integer) Method

Summary

Represents method Find(TObject,Integer).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
public
 function Find(const ATag:TObject; const AIndex:Integer):TBITreeNode; override;

Parameters

ATag
Type: TObject

AIndex
Type: Integer

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.Find(TObject,Integer)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.FirstNode Method

Summary

Represents method FirstNode.

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
public
 function FirstNode:TBITreeNode; override;

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.FirstNode
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.GetAllowDelete Method

Summary

Represents method GetAllowDelete.

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
protected
 function GetAllowDelete: Boolean; override;

Return Value

Type: Boolean

Overrides

TBITreePlugin.GetAllowDelete
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.GetControl Method

Summary

Represents method GetControl.

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
protected
 function GetControl:TControl; override;

Return Value

Type: TControl

Overrides

TBITreePlugin.GetControl
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.GetCount Method

Summary

Represents method GetCount.

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
protected
 function GetCount:Integer; override;

Return Value

Type: Integer

Overrides

TBITreePlugin.GetCount
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.GetNode(Integer) Method

Summary

Represents method GetNode(Integer).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
protected
 function GetNode(const AIndex:Integer):TBITreeNode; override;

Parameters

AIndex
Type: Integer

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.GetNode(Integer)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.GetOnChange Method

Summary

Represents method GetOnChange.

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
protected
 function GetOnChange: TNotifyEvent; override;

Return Value

Type: TNotifyEvent

Overrides

TBITreePlugin.GetOnChange
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.GetOnCheck Method

Summary

Represents method GetOnCheck.

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
protected
 function GetOnCheck: TNotifyEvent; override;

Return Value

Type: TNotifyEvent

Overrides

TBITreePlugin.GetOnCheck
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.GetOnExpanding Method

Summary

Represents method GetOnExpanding.

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
protected
 function GetOnExpanding: TBITreeExpandingEvent; override;

Return Value

Type: TBITreeExpandingEvent

Overrides

TBITreePlugin.GetOnExpanding
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.GetSelected Method

Summary

Represents method GetSelected.

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
protected
 function GetSelected:TBITreeNode; override;

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.GetSelected
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.GetSelectedData Method

Summary

Represents method GetSelectedData.

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
protected
 function GetSelectedData: TBITreePlugin.TNodeData; override;

Return Value

Type: TBITreePlugin.TNodeData

Overrides

TBITreePlugin.GetSelectedData
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.IsChecked(TBITreeNode) Method

Summary

Represents method IsChecked(TBITreeNode).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
public
 function IsChecked(const ANode:TBITreeNode):Boolean; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Boolean

Overrides

TBITreePlugin.IsChecked(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.IsExpanded(TBITreeNode) Method

Summary

Represents method IsExpanded(TBITreeNode).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
public
 function IsExpanded(const ANode:TBITreeNode):Boolean; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Boolean

Overrides

TBITreePlugin.IsExpanded(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.NewNode(TBITreeNode,String,TObject,TInteger) Method

Summary

Represents method NewNode(TBITreeNode,String,TObject,TInteger).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
public
 function NewNode(const AParent:TBITreeNode; const AText:String;
 const ATag:TObject=nil; const AIndex:TInteger=-1):TBITreeNode; override;

Parameters

AParent
Type: TBITreeNode

AText
Type: String

ATag
Type: TObject

AIndex
Type: System.Void

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.NewNode(TBITreeNode,String,TObject,TInteger)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.NextNode(TBITreeNode) Method

Summary

Represents method NextNode(TBITreeNode).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
public
 function NextNode(const ANode:TBITreeNode):TBITreeNode; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.NextNode(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.NodeAt(Integer,Integer) Method

Summary

Represents method NodeAt(Integer,Integer).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
protected
 function NodeAt(const X,Y:Integer):TBITreeNode; override;

Parameters

X
Type: Integer

Y
Type: Integer

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.NodeAt(Integer,Integer)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.ParentOf(TBITreeNode) Method

Summary

Represents method ParentOf(TBITreeNode).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
public
 function ParentOf(const ANode:TBITreeNode):TBITreeNode; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.ParentOf(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.SelectedText Method

Summary

Represents method SelectedText.

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
protected
 function SelectedText:String; override;

Return Value

Type: String

Overrides

TBITreePlugin.SelectedText
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.SetAllowDelete(Boolean) Method

Summary

Represents method SetAllowDelete(Boolean).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
protected
 procedure SetAllowDelete(const Value: Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBITreePlugin.SetAllowDelete(Boolean)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.SetChecked(TBITreeNode,Boolean) Method

Summary

Represents method SetChecked(TBITreeNode,Boolean).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
public
 procedure SetChecked(const ANode:TBITreeNode; const Value:Boolean); override;

Parameters

ANode
Type: TBITreeNode

Value
Type: Boolean

Overrides

TBITreePlugin.SetChecked(TBITreeNode,Boolean)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.SetData(TBITreeNode,TObject) Method

Summary

Represents method SetData(TBITreeNode,TObject).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
protected
 procedure SetData(const ANode: TBITreeNode; const AData: TObject); override;

Parameters

ANode
Type: TBITreeNode

AData
Type: TObject

Overrides

TBITreePlugin.SetData(TBITreeNode,TObject)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.SetOnChange(TNotifyEvent) Method

Summary

Represents method SetOnChange(TNotifyEvent).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
protected
 procedure SetOnChange(const Value: TNotifyEvent); override;

Parameters

Value
Type: TNotifyEvent

Overrides

TBITreePlugin.SetOnChange(TNotifyEvent)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.SetOnCheck(TNotifyEvent) Method

Summary

Represents method SetOnCheck(TNotifyEvent).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
protected
 procedure SetOnCheck(const Value: TNotifyEvent); override;

Parameters

Value
Type: TNotifyEvent

Overrides

TBITreePlugin.SetOnCheck(TNotifyEvent)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.SetOnExpanding(TBITreeExpandingEvent) Method

Summary

Represents method SetOnExpanding(TBITreeExpandingEvent).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
protected
 procedure SetOnExpanding(const Value: TBITreeExpandingEvent); override;

Parameters

Value
Type: TBITreeExpandingEvent

Overrides

TBITreePlugin.SetOnExpanding(TBITreeExpandingEvent)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.SetSelected(TBITreeNode) Method

Summary

Represents method SetSelected(TBITreeNode).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
protected
 procedure SetSelected(const Value: TBITreeNode); override;

Parameters

Value
Type: TBITreeNode

Overrides

TBITreePlugin.SetSelected(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.SetText(TBITreeNode,String) Method

Summary

Represents method SetText(TBITreeNode,String).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
public
 procedure SetText(const ANode:TBITreeNode; const Value:String); override;

Parameters

ANode
Type: TBITreeNode

Value
Type: String

Overrides

TBITreePlugin.SetText(TBITreeNode,String)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.SiblingIndex(TBITreeNode) Method

Summary

Represents method SiblingIndex(TBITreeNode).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
public
 function SiblingIndex(const ANode:TBITreeNode):Integer; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Integer

Overrides

TBITreePlugin.SiblingIndex(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


TBITreeViewPlugin.TextOf(TBITreeNode) Method

Summary

Represents method TextOf(TBITreeNode).

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
public
 function TextOf(const ANode:TBITreeNode):String; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: String

Overrides

TBITreePlugin.TextOf(TBITreeNode)
See Also

Reference

  • TBITreeViewPlugin
  • VCLBI.Tree.TreeView


VCLBI.Tree.TreeView Constants

Constants
Name | Description
Img_Checked | Represents constant Img_Checked.
Img_UnChecked | Represents constant Img_UnChecked.
Top


Img_Checked Constant

Summary

Represents constant Img_Checked.

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
 Img_Checked=2;

Value

Type: ShortInt

See Also

Reference

  • VCLBI.Tree.TreeView


Img_UnChecked Constant

Summary

Represents constant Img_UnChecked.

Namespace: VCLBI.Tree.TreeView
Syntax
Delphi
 Img_UnChecked=1;

Value

Type: ShortInt

See Also

Reference

  • VCLBI.Tree.TreeView


VCLBI.Tree.VirtualTreeView Namespace

Summary

Represents namespace VCLBI.Tree.VirtualTreeView.

Classes
Name | Description
TVirtualTreePlugin | Represents type TVirtualTreePlugin.
Top
Types
Name | Description
TVirtualTreeTexts | Represents an alias of the TDictionary type.
Top
Constants
Name | Description
Img_Checked | Represents constant Img_Checked.
Img_UnChecked | Represents constant Img_UnChecked.
Top


VCLBI.Tree.VirtualTreeView Classes

Classes
Name | Description
TVirtualTreePlugin | Represents type TVirtualTreePlugin.
Top


TVirtualTreePlugin Class

Summary

Represents type TVirtualTreePlugin.

Namespace: VCLBI.Tree.VirtualTreeView
Inheritance Hierarchy
TObject
VCLBI.Tree.TBITreePlugin
VCLBI.Tree.VirtualTreeView.TVirtualTreePlugin
Syntax
Delphi
type
 TVirtualTreePlugin=class(TBITreePlugin)
 end;

The TVirtualTreePlugin type exposes the following members.

Constructors
Show:
Name | Description
Create(TComponent) | Initializes a new instance of the TVirtualTreePlugin class. (Overrides TBITreePlugin.Create(TComponent).)
Destroy | Represents the destructor of the TVirtualTreePlugin class. (Overrides TBITreePlugin.Destroy.)
Top
Methods
Show:
Name | Description
BeginUpdating | Represents method BeginUpdating. (Overrides TBITreePlugin.BeginUpdating.)
Children(TBITreeNode,Integer) | Represents method Children(TBITreeNode,Integer). (Overrides TBITreePlugin.Children(TBITreeNode,Integer).)
ChildrenCount(TBITreeNode) | Represents method ChildrenCount(TBITreeNode). (Overrides TBITreePlugin.ChildrenCount(TBITreeNode).)
Clear(TBITreeNode) | Represents method Clear(TBITreeNode). (Overrides TBITreePlugin.Clear(TBITreeNode).)
ClearData(TBITreeNode) | Represents method ClearData(TBITreeNode). (Overrides TBITreePlugin.ClearData(TBITreeNode).)
DataOf(TBITreeNode) | Represents method DataOf(TBITreeNode). (Overrides TBITreePlugin.DataOf(TBITreeNode).)
EndUpdating | Represents method EndUpdating. (Overrides TBITreePlugin.EndUpdating.)
Expand(Integer) | Represents method Expand(Integer). (Overrides TBITreePlugin.Expand(Integer).)
Expand(TBITreeNode,Boolean,Boolean) | Represents method Expand(TBITreeNode,Boolean,Boolean). (Overrides TBITreePlugin.Expand(TBITreeNode,Boolean,Boolean).)
Find(TObject,Integer) | Represents method Find(TObject,Integer). (Overrides TBITreePlugin.Find(TObject,Integer).)
FirstNode | Represents method FirstNode. (Overrides TBITreePlugin.FirstNode.)
GetAllowDelete | Represents method GetAllowDelete. (Overrides TBITreePlugin.GetAllowDelete.)
GetControl | Represents method GetControl. (Overrides TBITreePlugin.GetControl.)
GetCount | Represents method GetCount. (Overrides TBITreePlugin.GetCount.)
GetNode(Integer) | Represents method GetNode(Integer). (Overrides TBITreePlugin.GetNode(Integer).)
GetOnChange | Represents method GetOnChange. (Overrides TBITreePlugin.GetOnChange.)
GetOnCheck | Represents method GetOnCheck. (Overrides TBITreePlugin.GetOnCheck.)
GetOnExpanding | Represents method GetOnExpanding. (Overrides TBITreePlugin.GetOnExpanding.)
GetSelected | Represents method GetSelected. (Overrides TBITreePlugin.GetSelected.)
GetSelectedData | Represents method GetSelectedData. (Overrides TBITreePlugin.GetSelectedData.)
IsChecked(TBITreeNode) | Represents method IsChecked(TBITreeNode). (Overrides TBITreePlugin.IsChecked(TBITreeNode).)
IsExpanded(TBITreeNode) | Represents method IsExpanded(TBITreeNode). (Overrides TBITreePlugin.IsExpanded(TBITreeNode).)
NewNode(TBITreeNode,String,TObject,TInteger) | Represents method NewNode(TBITreeNode,String,TObject,TInteger). (Overrides TBITreePlugin.NewNode(TBITreeNode,String,TObject,TInteger).)
NextNode(TBITreeNode) | Represents method NextNode(TBITreeNode). (Overrides TBITreePlugin.NextNode(TBITreeNode).)
NodeAt(Integer,Integer) | Represents method NodeAt(Integer,Integer). (Overrides TBITreePlugin.NodeAt(Integer,Integer).)
ParentOf(TBITreeNode) | Represents method ParentOf(TBITreeNode). (Overrides TBITreePlugin.ParentOf(TBITreeNode).)
SelectedText | Represents method SelectedText. (Overrides TBITreePlugin.SelectedText.)
SetAllowDelete(Boolean) | Represents method SetAllowDelete(Boolean). (Overrides TBITreePlugin.SetAllowDelete(Boolean).)
SetChecked(TBITreeNode,Boolean) | Represents method SetChecked(TBITreeNode,Boolean). (Overrides TBITreePlugin.SetChecked(TBITreeNode,Boolean).)
SetData(TBITreeNode,TObject) | Represents method SetData(TBITreeNode,TObject). (Overrides TBITreePlugin.SetData(TBITreeNode,TObject).)
SetOnChange(TNotifyEvent) | Represents method SetOnChange(TNotifyEvent). (Overrides TBITreePlugin.SetOnChange(TNotifyEvent).)
SetOnCheck(TNotifyEvent) | Represents method SetOnCheck(TNotifyEvent). (Overrides TBITreePlugin.SetOnCheck(TNotifyEvent).)
SetOnExpanding(TBITreeExpandingEvent) | Represents method SetOnExpanding(TBITreeExpandingEvent). (Overrides TBITreePlugin.SetOnExpanding(TBITreeExpandingEvent).)
SetSelected(TBITreeNode) | Represents method SetSelected(TBITreeNode). (Overrides TBITreePlugin.SetSelected(TBITreeNode).)
SetText(TBITreeNode,String) | Represents method SetText(TBITreeNode,String). (Overrides TBITreePlugin.SetText(TBITreeNode,String).)
SiblingIndex(TBITreeNode) | Represents method SiblingIndex(TBITreeNode). (Overrides TBITreePlugin.SiblingIndex(TBITreeNode).)
TextOf(TBITreeNode) | Represents method TextOf(TBITreeNode). (Overrides TBITreePlugin.TextOf(TBITreeNode).)
Top
See Also

Reference

  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin Constructors

Constructors
Name | Description
Create(TComponent) | Initializes a new instance of the TVirtualTreePlugin class. (Overrides TBITreePlugin.Create(TComponent).)
Destroy | Represents the destructor of the TVirtualTreePlugin class. (Overrides TBITreePlugin.Destroy.)
Top


TVirtualTreePlugin.Create(TComponent) Constructor

Summary

Initializes a new instance of the TVirtualTreePlugin class.

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
public
 Constructor Create(const AOwner:TComponent); override;

Parameters

AOwner
Type: TComponent

Overrides

TBITreePlugin.Create(TComponent)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.Destroy Destructor

Summary

Represents the destructor of the TVirtualTreePlugin class.

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TBITreePlugin.Destroy
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin Methods

Methods
Name | Description
BeginUpdating | Represents method BeginUpdating. (Overrides TBITreePlugin.BeginUpdating.)
Children(TBITreeNode,Integer) | Represents method Children(TBITreeNode,Integer). (Overrides TBITreePlugin.Children(TBITreeNode,Integer).)
ChildrenCount(TBITreeNode) | Represents method ChildrenCount(TBITreeNode). (Overrides TBITreePlugin.ChildrenCount(TBITreeNode).)
Clear(TBITreeNode) | Represents method Clear(TBITreeNode). (Overrides TBITreePlugin.Clear(TBITreeNode).)
ClearData(TBITreeNode) | Represents method ClearData(TBITreeNode). (Overrides TBITreePlugin.ClearData(TBITreeNode).)
DataOf(TBITreeNode) | Represents method DataOf(TBITreeNode). (Overrides TBITreePlugin.DataOf(TBITreeNode).)
EndUpdating | Represents method EndUpdating. (Overrides TBITreePlugin.EndUpdating.)
Expand(Integer) | Represents method Expand(Integer). (Overrides TBITreePlugin.Expand(Integer).)
Expand(TBITreeNode,Boolean,Boolean) | Represents method Expand(TBITreeNode,Boolean,Boolean). (Overrides TBITreePlugin.Expand(TBITreeNode,Boolean,Boolean).)
Find(TObject,Integer) | Represents method Find(TObject,Integer). (Overrides TBITreePlugin.Find(TObject,Integer).)
FirstNode | Represents method FirstNode. (Overrides TBITreePlugin.FirstNode.)
GetAllowDelete | Represents method GetAllowDelete. (Overrides TBITreePlugin.GetAllowDelete.)
GetControl | Represents method GetControl. (Overrides TBITreePlugin.GetControl.)
GetCount | Represents method GetCount. (Overrides TBITreePlugin.GetCount.)
GetNode(Integer) | Represents method GetNode(Integer). (Overrides TBITreePlugin.GetNode(Integer).)
GetOnChange | Represents method GetOnChange. (Overrides TBITreePlugin.GetOnChange.)
GetOnCheck | Represents method GetOnCheck. (Overrides TBITreePlugin.GetOnCheck.)
GetOnExpanding | Represents method GetOnExpanding. (Overrides TBITreePlugin.GetOnExpanding.)
GetSelected | Represents method GetSelected. (Overrides TBITreePlugin.GetSelected.)
GetSelectedData | Represents method GetSelectedData. (Overrides TBITreePlugin.GetSelectedData.)
IsChecked(TBITreeNode) | Represents method IsChecked(TBITreeNode). (Overrides TBITreePlugin.IsChecked(TBITreeNode).)
IsExpanded(TBITreeNode) | Represents method IsExpanded(TBITreeNode). (Overrides TBITreePlugin.IsExpanded(TBITreeNode).)
NewNode(TBITreeNode,String,TObject,TInteger) | Represents method NewNode(TBITreeNode,String,TObject,TInteger). (Overrides TBITreePlugin.NewNode(TBITreeNode,String,TObject,TInteger).)
NextNode(TBITreeNode) | Represents method NextNode(TBITreeNode). (Overrides TBITreePlugin.NextNode(TBITreeNode).)
NodeAt(Integer,Integer) | Represents method NodeAt(Integer,Integer). (Overrides TBITreePlugin.NodeAt(Integer,Integer).)
ParentOf(TBITreeNode) | Represents method ParentOf(TBITreeNode). (Overrides TBITreePlugin.ParentOf(TBITreeNode).)
SelectedText | Represents method SelectedText. (Overrides TBITreePlugin.SelectedText.)
SetAllowDelete(Boolean) | Represents method SetAllowDelete(Boolean). (Overrides TBITreePlugin.SetAllowDelete(Boolean).)
SetChecked(TBITreeNode,Boolean) | Represents method SetChecked(TBITreeNode,Boolean). (Overrides TBITreePlugin.SetChecked(TBITreeNode,Boolean).)
SetData(TBITreeNode,TObject) | Represents method SetData(TBITreeNode,TObject). (Overrides TBITreePlugin.SetData(TBITreeNode,TObject).)
SetOnChange(TNotifyEvent) | Represents method SetOnChange(TNotifyEvent). (Overrides TBITreePlugin.SetOnChange(TNotifyEvent).)
SetOnCheck(TNotifyEvent) | Represents method SetOnCheck(TNotifyEvent). (Overrides TBITreePlugin.SetOnCheck(TNotifyEvent).)
SetOnExpanding(TBITreeExpandingEvent) | Represents method SetOnExpanding(TBITreeExpandingEvent). (Overrides TBITreePlugin.SetOnExpanding(TBITreeExpandingEvent).)
SetSelected(TBITreeNode) | Represents method SetSelected(TBITreeNode). (Overrides TBITreePlugin.SetSelected(TBITreeNode).)
SetText(TBITreeNode,String) | Represents method SetText(TBITreeNode,String). (Overrides TBITreePlugin.SetText(TBITreeNode,String).)
SiblingIndex(TBITreeNode) | Represents method SiblingIndex(TBITreeNode). (Overrides TBITreePlugin.SiblingIndex(TBITreeNode).)
TextOf(TBITreeNode) | Represents method TextOf(TBITreeNode). (Overrides TBITreePlugin.TextOf(TBITreeNode).)
Top


TVirtualTreePlugin.BeginUpdating Method

Summary

Represents method BeginUpdating.

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
protected
 procedure BeginUpdating; override;

Overrides

TBITreePlugin.BeginUpdating
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.Children(TBITreeNode,Integer) Method

Summary

Represents method Children(TBITreeNode,Integer).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
public
 function Children(const ANode:TBITreeNode; const AIndex:Integer):TBITreeNode; override;

Parameters

ANode
Type: TBITreeNode

AIndex
Type: Integer

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.Children(TBITreeNode,Integer)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.ChildrenCount(TBITreeNode) Method

Summary

Represents method ChildrenCount(TBITreeNode).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
public
 function ChildrenCount(const ANode:TBITreeNode):Integer; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Integer

Overrides

TBITreePlugin.ChildrenCount(TBITreeNode)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.Clear(TBITreeNode) Method

Summary

Represents method Clear(TBITreeNode).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
protected
 procedure Clear(const ANode:TBITreeNode=nil); override;

Parameters

ANode
Type: TBITreeNode

Overrides

TBITreePlugin.Clear(TBITreeNode)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.ClearData(TBITreeNode) Method

Summary

Represents method ClearData(TBITreeNode).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
protected
 procedure ClearData(const ANode:TBITreeNode); override;

Parameters

ANode
Type: TBITreeNode

Overrides

TBITreePlugin.ClearData(TBITreeNode)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.DataOf(TBITreeNode) Method

Summary

Represents method DataOf(TBITreeNode).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
public
 function DataOf(const ANode:TBITreeNode):TObject; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TObject

Overrides

TBITreePlugin.DataOf(TBITreeNode)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.EndUpdating Method

Summary

Represents method EndUpdating.

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
protected
 procedure EndUpdating; override;

Overrides

TBITreePlugin.EndUpdating
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.Expand(TBITreeNode,Boolean,Boolean) Method

Summary

Represents method Expand(TBITreeNode,Boolean,Boolean).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
public
 procedure Expand(const ANode:TBITreeNode; const DoExpand:Boolean=True; const Recursive:Boolean=False); override;

Parameters

ANode
Type: TBITreeNode

DoExpand
Type: Boolean

Recursive
Type: Boolean

Overrides

TBITreePlugin.Expand(TBITreeNode,Boolean,Boolean)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.Find(TObject,Integer) Method

Summary

Represents method Find(TObject,Integer).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
public
 function Find(const ATag:TObject; const AIndex:Integer):TBITreeNode; override;

Parameters

ATag
Type: TObject

AIndex
Type: Integer

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.Find(TObject,Integer)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.FirstNode Method

Summary

Represents method FirstNode.

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
public
 function FirstNode:TBITreeNode; override;

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.FirstNode
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.GetAllowDelete Method

Summary

Represents method GetAllowDelete.

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
protected
 function GetAllowDelete: Boolean; override;

Return Value

Type: Boolean

Overrides

TBITreePlugin.GetAllowDelete
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.GetControl Method

Summary

Represents method GetControl.

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
protected
 function GetControl:TControl; override;

Return Value

Type: TControl

Overrides

TBITreePlugin.GetControl
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.GetCount Method

Summary

Represents method GetCount.

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
protected
 function GetCount:Integer; override;

Return Value

Type: Integer

Overrides

TBITreePlugin.GetCount
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.GetNode(Integer) Method

Summary

Represents method GetNode(Integer).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
protected
 function GetNode(const AIndex:Integer):TBITreeNode; override;

Parameters

AIndex
Type: Integer

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.GetNode(Integer)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.GetOnChange Method

Summary

Represents method GetOnChange.

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
protected
 function GetOnChange: TNotifyEvent; override;

Return Value

Type: TNotifyEvent

Overrides

TBITreePlugin.GetOnChange
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.GetOnCheck Method

Summary

Represents method GetOnCheck.

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
protected
 function GetOnCheck: TNotifyEvent; override;

Return Value

Type: TNotifyEvent

Overrides

TBITreePlugin.GetOnCheck
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.GetOnExpanding Method

Summary

Represents method GetOnExpanding.

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
protected
 function GetOnExpanding: TBITreeExpandingEvent; override;

Return Value

Type: TBITreeExpandingEvent

Overrides

TBITreePlugin.GetOnExpanding
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.GetSelected Method

Summary

Represents method GetSelected.

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
protected
 function GetSelected:TBITreeNode; override;

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.GetSelected
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.GetSelectedData Method

Summary

Represents method GetSelectedData.

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
protected
 function GetSelectedData: TBITreePlugin.TNodeData; override;

Return Value

Type: TBITreePlugin.TNodeData

Overrides

TBITreePlugin.GetSelectedData
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.IsChecked(TBITreeNode) Method

Summary

Represents method IsChecked(TBITreeNode).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
public
 function IsChecked(const ANode:TBITreeNode):Boolean; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Boolean

Overrides

TBITreePlugin.IsChecked(TBITreeNode)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.IsExpanded(TBITreeNode) Method

Summary

Represents method IsExpanded(TBITreeNode).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
public
 function IsExpanded(const ANode:TBITreeNode):Boolean; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Boolean

Overrides

TBITreePlugin.IsExpanded(TBITreeNode)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.NewNode(TBITreeNode,String,TObject,TInteger) Method

Summary

Represents method NewNode(TBITreeNode,String,TObject,TInteger).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
public
 function NewNode(const AParent:TBITreeNode; const AText:String;
 const ATag:TObject=nil; const AIndex:TInteger=-1):TBITreeNode; override;

Parameters

AParent
Type: TBITreeNode

AText
Type: String

ATag
Type: TObject

AIndex
Type: System.Void

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.NewNode(TBITreeNode,String,TObject,TInteger)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.NextNode(TBITreeNode) Method

Summary

Represents method NextNode(TBITreeNode).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
public
 function NextNode(const ANode:TBITreeNode):TBITreeNode; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.NextNode(TBITreeNode)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.NodeAt(Integer,Integer) Method

Summary

Represents method NodeAt(Integer,Integer).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
protected
 function NodeAt(const X,Y:Integer):TBITreeNode; override;

Parameters

X
Type: Integer

Y
Type: Integer

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.NodeAt(Integer,Integer)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.ParentOf(TBITreeNode) Method

Summary

Represents method ParentOf(TBITreeNode).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
public
 function ParentOf(const ANode:TBITreeNode):TBITreeNode; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: TBITreeNode

Overrides

TBITreePlugin.ParentOf(TBITreeNode)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.SelectedText Method

Summary

Represents method SelectedText.

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
protected
 function SelectedText:String; override;

Return Value

Type: String

Overrides

TBITreePlugin.SelectedText
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.SetAllowDelete(Boolean) Method

Summary

Represents method SetAllowDelete(Boolean).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
protected
 procedure SetAllowDelete(const Value: Boolean); override;

Parameters

Value
Type: Boolean

Overrides

TBITreePlugin.SetAllowDelete(Boolean)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.SetChecked(TBITreeNode,Boolean) Method

Summary

Represents method SetChecked(TBITreeNode,Boolean).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
public
 procedure SetChecked(const ANode:TBITreeNode; const Value:Boolean); override;

Parameters

ANode
Type: TBITreeNode

Value
Type: Boolean

Overrides

TBITreePlugin.SetChecked(TBITreeNode,Boolean)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.SetData(TBITreeNode,TObject) Method

Summary

Represents method SetData(TBITreeNode,TObject).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
protected
 procedure SetData(const ANode: TBITreeNode; const AData: TObject); override;

Parameters

ANode
Type: TBITreeNode

AData
Type: TObject

Overrides

TBITreePlugin.SetData(TBITreeNode,TObject)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.SetOnChange(TNotifyEvent) Method

Summary

Represents method SetOnChange(TNotifyEvent).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
protected
 procedure SetOnChange(const Value: TNotifyEvent); override;

Parameters

Value
Type: TNotifyEvent

Overrides

TBITreePlugin.SetOnChange(TNotifyEvent)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.SetOnCheck(TNotifyEvent) Method

Summary

Represents method SetOnCheck(TNotifyEvent).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
protected
 procedure SetOnCheck(const Value: TNotifyEvent); override;

Parameters

Value
Type: TNotifyEvent

Overrides

TBITreePlugin.SetOnCheck(TNotifyEvent)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.SetOnExpanding(TBITreeExpandingEvent) Method

Summary

Represents method SetOnExpanding(TBITreeExpandingEvent).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
protected
 procedure SetOnExpanding(const Value: TBITreeExpandingEvent); override;

Parameters

Value
Type: TBITreeExpandingEvent

Overrides

TBITreePlugin.SetOnExpanding(TBITreeExpandingEvent)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.SetSelected(TBITreeNode) Method

Summary

Represents method SetSelected(TBITreeNode).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
protected
 procedure SetSelected(const Value: TBITreeNode); override;

Parameters

Value
Type: TBITreeNode

Overrides

TBITreePlugin.SetSelected(TBITreeNode)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.SetText(TBITreeNode,String) Method

Summary

Represents method SetText(TBITreeNode,String).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
public
 procedure SetText(const ANode:TBITreeNode; const Value:String); override;

Parameters

ANode
Type: TBITreeNode

Value
Type: String

Overrides

TBITreePlugin.SetText(TBITreeNode,String)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.SiblingIndex(TBITreeNode) Method

Summary

Represents method SiblingIndex(TBITreeNode).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
public
 function SiblingIndex(const ANode:TBITreeNode):Integer; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: Integer

Overrides

TBITreePlugin.SiblingIndex(TBITreeNode)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


TVirtualTreePlugin.TextOf(TBITreeNode) Method

Summary

Represents method TextOf(TBITreeNode).

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
public
 function TextOf(const ANode:TBITreeNode):String; override;

Parameters

ANode
Type: TBITreeNode

Return Value

Type: String

Overrides

TBITreePlugin.TextOf(TBITreeNode)
See Also

Reference

  • TVirtualTreePlugin
  • VCLBI.Tree.VirtualTreeView


VCLBI.Tree.VirtualTreeView Types

Types
Name | Description
TVirtualTreeTexts | Represents an alias of the TDictionary type.
Top


TVirtualTreeTexts Type

Summary

Represents an alias of the TDictionary type.

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
type
 TVirtualTreeTexts=TDictionary<PVirtualNode,String>;
See Also

Reference

  • VCLBI.Tree.VirtualTreeView


VCLBI.Tree.VirtualTreeView Constants

Constants
Name | Description
Img_Checked | Represents constant Img_Checked.
Img_UnChecked | Represents constant Img_UnChecked.
Top


Img_Checked Constant

Summary

Represents constant Img_Checked.

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
 Img_Checked=2;

Value

Type: ShortInt

See Also

Reference

  • VCLBI.Tree.VirtualTreeView


Img_UnChecked Constant

Summary

Represents constant Img_UnChecked.

Namespace: VCLBI.Tree.VirtualTreeView
Syntax
Delphi
 Img_UnChecked=1;

Value

Type: ShortInt

See Also

Reference

  • VCLBI.Tree.VirtualTreeView


VCLBI.Visualizer Namespace

Summary

Represents namespace VCLBI.Visualizer.

Classes
Name | Description
TBIComposer | Represents type TBIComposer.
TGroup | Represents type TGroup.
TGroupProc<T> | Represents type TGroupProc<T>.
TVisualizerItem | Represents type TVisualizerItem.
TVisualizerItems | Represents type TVisualizerItems.
Top
Records
Name | Description
TVisualizerItems.TEnabled | Represents type TEnabled.
Top
Types
Name | Description
TGroupClass | Represents type TGroupClass.
Top


VCLBI.Visualizer Classes

Classes
Name | Description
TBIComposer | Represents type TBIComposer.
TGroup | Represents type TGroup.
TGroupProc<T> | Represents type TGroupProc<T>.
TVisualizerItem | Represents type TVisualizerItem.
TVisualizerItems | Represents type TVisualizerItems.
Top


TBIComposer Class

Summary

Represents type TBIComposer.

Namespace: VCLBI.Visualizer
Inheritance Hierarchy
VCLBI.Visualizer.TBIComposer
VCLBI.Visualizer.Chart.TComposerAccess
See Also

Reference

  • VCLBI.Visualizer


TGroup Class

Summary

Represents type TGroup.

Namespace: VCLBI.Visualizer
Inheritance Hierarchy
VCLBI.Visualizer.TGroup
VCLBI.Visualizer.Chart.TGroupAccess
VCLBI.Visualizer.Chart.TGroupChart
See Also

Reference

  • VCLBI.Visualizer


TGroupProc<T> Class

Summary

Represents type TGroupProc<T>.

Namespace: VCLBI.Visualizer
Inheritance Hierarchy
TObject
VCLBI.Visualizer.TGroupProc<T>
Syntax
Delphi
type
 TGroupProc<T

Type Parameters

T
See Also

Reference

  • VCLBI.Visualizer


TVisualizerItem Class

Summary

Represents type TVisualizerItem.

Namespace: VCLBI.Visualizer
Inheritance Hierarchy
TCollectionItem
VCLBI.Visualizer.TVisualizerItem
Syntax
Delphi
type
 TVisualizerItem=class(TCollectionItem)
 end;

The TVisualizerItem type exposes the following members.

Constructors
Show:
Name | Description
Create(TCollection) | Initializes a new instance of the TVisualizerItem class.
Destroy | Represents the destructor of the TVisualizerItem class.
Top
Properties
Show:
Name | Description
Enabled | Represents property Enabled.
Selected[TInteger] | Represents property Selected[TInteger].
Top
Methods
Show:
Name | Description
AsString(TInteger) | Represents method AsString(TInteger).
Count | Represents method Count.
IsEnabled | Represents method IsEnabled.
MapToString(TDataItem,TDataMap,TInteger) | Represents method MapToString(TDataItem,TDataMap,TInteger).
Top
Fields
Show:
Name | Description
Current | Represents field Current.
Data | Represents field Data.
GroupBy | Represents field GroupBy.
GroupClass | Represents field GroupClass.
Top
See Also

Reference

  • VCLBI.Visualizer


TVisualizerItem.Create(TCollection) Constructor

Summary

Initializes a new instance of the TVisualizerItem class.

Namespace: VCLBI.Visualizer
Syntax
Delphi
public
 Constructor Create(Collection:TCollection); override;

Parameters

Collection
Type: TCollection

See Also

Reference

  • TVisualizerItem
  • VCLBI.Visualizer


TVisualizerItem.Destroy Destructor

Summary

Represents the destructor of the TVisualizerItem class.

Namespace: VCLBI.Visualizer
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TVisualizerItem
  • VCLBI.Visualizer


TVisualizerItem.Enabled Property

Summary

Represents property Enabled.

Namespace: VCLBI.Visualizer
Syntax
Delphi
published
 property Enabled:Boolean read FEnabled write SetEnabled default True;

Property Value

Type: Boolean

See Also

Reference

  • TVisualizerItem
  • VCLBI.Visualizer


TVisualizerItem.Selected[TInteger] Property

Summary

Represents property Selected[TInteger].

Namespace: VCLBI.Visualizer
Syntax
Delphi
public
 property Selected[const Index:TInteger]:Boolean read GetSelected write SetSelected;

Parameters

Index
Type: System.Void

Property Value

Type: Boolean

See Also

Reference

  • TVisualizerItem
  • VCLBI.Visualizer


TVisualizerItem.AsString(TInteger) Method

Summary

Represents method AsString(TInteger).

Namespace: VCLBI.Visualizer
Syntax
Delphi
public
 function AsString(const AIndex:TInteger):String;

Parameters

AIndex
Type: System.Void

Return Value

Type: String

See Also

Reference

  • TVisualizerItem
  • VCLBI.Visualizer


TVisualizerItem.Count Method

Summary

Represents method Count.

Namespace: VCLBI.Visualizer
Syntax
Delphi
public
 function Count:TInteger;

Return Value

Type: TInteger

See Also

Reference

  • TVisualizerItem
  • VCLBI.Visualizer


TVisualizerItem.IsEnabled Method

Summary

Represents method IsEnabled.

Namespace: VCLBI.Visualizer
Syntax
Delphi
public
 function IsEnabled:Boolean;

Return Value

Type: Boolean

See Also

Reference

  • TVisualizerItem
  • VCLBI.Visualizer


TVisualizerItem.MapToString(TDataItem,TDataMap,TInteger) Method

Summary

Represents method MapToString(TDataItem,TDataMap,TInteger).

Namespace: VCLBI.Visualizer
Syntax
Delphi
public
 class function MapToString(const AData:TDataItem; const AMap:TDataMap; const APos:TInteger):String; static;

Parameters

AData
Type: TDataItem

AMap
Type: TDataMap

APos
Type: System.Void

Return Value

Type: String

See Also

Reference

  • TVisualizerItem
  • VCLBI.Visualizer


TVisualizerItem.Current Field

Summary

Represents field Current.

Namespace: VCLBI.Visualizer
Syntax
Delphi
public
 Current : TGroup;

Field Value

Type: TGroup

See Also

Reference

  • TVisualizerItem
  • VCLBI.Visualizer


TVisualizerItem.Data Field

Summary

Represents field Data.

Namespace: VCLBI.Visualizer
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TVisualizerItem
  • VCLBI.Visualizer


TVisualizerItem.GroupBy Field

Summary

Represents field GroupBy.

Namespace: VCLBI.Visualizer
Syntax
Delphi
public
 GroupBy : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TVisualizerItem
  • VCLBI.Visualizer


TVisualizerItem.GroupClass Field

Summary

Represents field GroupClass.

Namespace: VCLBI.Visualizer
Syntax
Delphi
public
 GroupClass : TGroupClass;

Field Value

Type: TGroupClass

See Also

Reference

  • TVisualizerItem
  • VCLBI.Visualizer


TVisualizerItems Class

Summary

Represents type TVisualizerItems.

Namespace: VCLBI.Visualizer
Inheritance Hierarchy
TOwnedCollection
VCLBI.Visualizer.TVisualizerItems
Syntax
Delphi
type
 TVisualizerItems=class(TOwnedCollection)
 end;

The TVisualizerItems type exposes the following members.

Constructors
Show:
Name | Description
Create(TPersistent) | Initializes a new instance of the TVisualizerItems class.
Top
Properties
Show:
Name | Description
Items[Integer] | Represents property Items[Integer].
Top
Methods
Show:
Name | Description
Add(TDataItem) | Represents method Add(TDataItem).
Exchange(Integer,Integer) | Represents method Exchange(Integer,Integer).
Top
Fields
Show:
Name | Description
Enabled | Represents field Enabled.
Top
See Also

Reference

  • VCLBI.Visualizer


TVisualizerItems.Create(TPersistent) Constructor

Summary

Initializes a new instance of the TVisualizerItems class.

Namespace: VCLBI.Visualizer
Syntax
Delphi
public
 Constructor Create(AOwner: TPersistent);

Parameters

AOwner
Type: TPersistent

See Also

Reference

  • TVisualizerItems
  • VCLBI.Visualizer


TVisualizerItems.Items[Integer] Property

Summary

Represents property Items[Integer].

Namespace: VCLBI.Visualizer
Syntax
Delphi
public
 property Items[const Index:Integer]:TVisualizerItem read GetItem write SetItem; default;

Parameters

Index
Type: Integer

Property Value

Type: TVisualizerItem

See Also

Reference

  • TVisualizerItems
  • VCLBI.Visualizer


TVisualizerItems.Add(TDataItem) Method

Summary

Represents method Add(TDataItem).

Namespace: VCLBI.Visualizer
Syntax
Delphi
public
 function Add(const AData:TDataItem):TVisualizerItem;

Parameters

AData
Type: TDataItem

Return Value

Type: TVisualizerItem

See Also

Reference

  • TVisualizerItems
  • VCLBI.Visualizer


TVisualizerItems.Exchange(Integer,Integer) Method

Summary

Represents method Exchange(Integer,Integer).

Namespace: VCLBI.Visualizer
Syntax
Delphi
public
 procedure Exchange(const A,B:Integer);

Parameters

A
Type: Integer

B
Type: Integer

See Also

Reference

  • TVisualizerItems
  • VCLBI.Visualizer


TVisualizerItems.Enabled Field

Summary

Represents field Enabled.

Namespace: VCLBI.Visualizer
Syntax
Delphi
public
 Enabled : TEnabled;

Field Value

Type: TEnabled

See Also

Reference

  • TVisualizerItems
  • VCLBI.Visualizer


VCLBI.Visualizer Records

Records
Name | Description
TVisualizerItems.TEnabled | Represents type TEnabled.
Top


TVisualizerItems.TEnabled Record

Summary

Represents type TEnabled.

Namespace: VCLBI.Visualizer
Syntax
Delphi
public
type
 TEnabled=record
 end;

The TVisualizerItems.TEnabled type exposes the following members.

Methods
Show:
Name | Description
Count | Represents method Count.
First | Overloaded. Represents method First.
First(Integer) | Overloaded. Represents method First(Integer).
Last | Represents method Last.
Top
See Also

Reference

  • TVisualizerItems
  • VCLBI.Visualizer


TVisualizerItems.TEnabled.Count Method

Summary

Represents method Count.

Namespace: VCLBI.Visualizer
Syntax
Delphi
public
 function Count:Integer;

Return Value

Type: Integer

See Also

Reference

  • TVisualizerItems.TEnabled
  • TVisualizerItems
  • VCLBI.Visualizer


TVisualizerItems.TEnabled.First Method

Summary

Represents method First.

Namespace: VCLBI.Visualizer
Syntax
Delphi
public
 function First:Integer; overload;

Return Value

Type: Integer

See Also

Reference

  • TVisualizerItems.TEnabled
  • TVisualizerItems
  • VCLBI.Visualizer


TVisualizerItems.TEnabled.First(Integer) Method

Summary

Represents method First(Integer).

Namespace: VCLBI.Visualizer
Syntax
Delphi
public
 function First(const Start:Integer):Integer; overload;

Parameters

Start
Type: Integer

Return Value

Type: Integer

See Also

Reference

  • TVisualizerItems.TEnabled
  • TVisualizerItems
  • VCLBI.Visualizer


TVisualizerItems.TEnabled.Last Method

Summary

Represents method Last.

Namespace: VCLBI.Visualizer
Syntax
Delphi
public
 function Last:Integer;

Return Value

Type: Integer

See Also

Reference

  • TVisualizerItems.TEnabled
  • TVisualizerItems
  • VCLBI.Visualizer


VCLBI.Visualizer Types

Types
Name | Description
TGroupClass | Represents type TGroupClass.
Top


TGroupClass Type

Summary

Represents type TGroupClass.

Namespace: VCLBI.Visualizer
Syntax
Delphi
type
 TGroupClass=class of TGroup;
See Also

Reference

  • VCLBI.Visualizer


VCLBI.Visualizer.Chart Namespace

Summary

Represents namespace VCLBI.Visualizer.Chart.

Classes
Name | Description
TComposerAccess | Represents type TComposerAccess.
TCustomSeriesAccess | Represents type TCustomSeriesAccess.
TGroupAccess | Represents type TGroupAccess.
TGroupChart | Represents type TGroupChart.
TGroupChartOptions | Represents type TGroupChartOptions.
TGroupSeries | Represents type TGroupSeries.
TGroupSeriesOptions | Represents type TGroupSeriesOptions.
Top
Records
Name | Description
TBIChartComposerUI | Represents type TBIChartComposerUI.
TSeriesData | Represents type TSeriesData.
Top
Enumerations
Name | Description
TAutoStackSeries | Represents type TAutoStackSeries.
TBIMultiAxis | Represents type TBIMultiAxis.
TGroupSeriesStyle | Represents type TGroupSeriesStyle.
Top
Types
Name | Description
TChartProc | Represents type TChartProc.
Top
Routines
Name | Description
AddSettingsButton(TWinControl) | Represents method AddSettingsButton(TWinControl).
IsNumericOrDateTime(TDataItem) | Represents method IsNumericOrDateTime(TDataItem).
MandatoryAxis(TChartSeries) | Represents method MandatoryAxis(TChartSeries).
NotMandatoryAxis(TChartSeries) | Represents method NotMandatoryAxis(TChartSeries).
SetColorEach(TChartSeries) | Represents method SetColorEach(TChartSeries).
TraverseChart(TCustomChart,TChartProc) | Represents method TraverseChart(TCustomChart,TChartProc).
TryChangeSeriesStyle(TChartSeries) | Represents method TryChangeSeriesStyle(TChartSeries).
Top


VCLBI.Visualizer.Chart Classes

Classes
Name | Description
TComposerAccess | Represents type TComposerAccess.
TCustomSeriesAccess | Represents type TCustomSeriesAccess.
TGroupAccess | Represents type TGroupAccess.
TGroupChart | Represents type TGroupChart.
TGroupChartOptions | Represents type TGroupChartOptions.
TGroupSeries | Represents type TGroupSeries.
TGroupSeriesOptions | Represents type TGroupSeriesOptions.
Top


TComposerAccess Class

Summary

Represents type TComposerAccess.

Namespace: VCLBI.Visualizer.Chart
Inheritance Hierarchy
VCLBI.Visualizer.TBIComposer
VCLBI.Visualizer.Chart.TComposerAccess
Syntax
Delphi
type
 TComposerAccess=class(TBIComposer);
See Also

Reference

  • VCLBI.Visualizer.Chart


TCustomSeriesAccess Class

Summary

Represents type TCustomSeriesAccess.

Namespace: VCLBI.Visualizer.Chart
Inheritance Hierarchy
TCustomSeries
VCLBI.Visualizer.Chart.TCustomSeriesAccess
Syntax
Delphi
type
 TCustomSeriesAccess=class(TCustomSeries);
See Also

Reference

  • VCLBI.Visualizer.Chart


TGroupAccess Class

Summary

Represents type TGroupAccess.

Namespace: VCLBI.Visualizer.Chart
Inheritance Hierarchy
VCLBI.Visualizer.TGroup
VCLBI.Visualizer.Chart.TGroupAccess
Syntax
Delphi
type
 TGroupAccess=class(TGroup);
See Also

Reference

  • VCLBI.Visualizer.Chart


TGroupChart Class

Summary

Represents type TGroupChart.

Namespace: VCLBI.Visualizer.Chart
Inheritance Hierarchy
VCLBI.Visualizer.TGroup
VCLBI.Visualizer.Chart.TGroupChart
VCLBI.Visualizer.Chart.TGroupSeries
Syntax
Delphi
type
 TGroupChart=class(TGroup)
 end;

The TGroupChart type exposes the following members.

Constructors
Show:
Name | Description
CreateData(TVisualizerItem,TGroup) | Initializes a new instance of the TGroupChart class.
Destroy | Represents the destructor of the TGroupChart class.
Top
Properties
Show:
Name | Description
Chart | Represents property Chart.
Group | Represents property Group.
Options | Represents property Options.
Top
Methods
Show:
Name | Description
Add(TInteger) | Represents method Add(TInteger).
AddItem | Represents method AddItem.
ApplyTemplate | Overloaded. Represents method ApplyTemplate.
ApplyTemplate(TCustomChart,TCustomChart) | Overloaded. Represents method ApplyTemplate(TCustomChart,TCustomChart).
Assign(TPersistent) | Represents method Assign(TPersistent).
ChartResized(TObject) | Represents method ChartResized(TObject).
Finished | Represents method Finished.
Init | Represents method Init.
SetAxisTitle(TChartSeries,TDataItem) | Represents method SetAxisTitle(TChartSeries,TDataItem).
Top
See Also

Reference

  • VCLBI.Visualizer.Chart


TGroupChart.CreateData(TVisualizerItem,TGroup) Constructor

Summary

Initializes a new instance of the TGroupChart class.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 Constructor CreateData(const AItem:TVisualizerItem; const AParent:TGroup); override;

Parameters

AItem
Type: TVisualizerItem

AParent
Type: TGroup

See Also

Reference

  • TGroupChart
  • VCLBI.Visualizer.Chart


TGroupChart.Destroy Destructor

Summary

Represents the destructor of the TGroupChart class.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TGroupChart
  • VCLBI.Visualizer.Chart


TGroupChart.Chart Property

Summary

Represents property Chart.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 property Chart:TBIChart read FChart;

Property Value

Type: TBIChart

See Also

Reference

  • TGroupChart
  • VCLBI.Visualizer.Chart


TGroupChart.Group Property

Summary

Represents property Group.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 property Group:TGroupChart read IParent;

Property Value

Type: TGroupChart

See Also

Reference

  • TGroupChart
  • VCLBI.Visualizer.Chart


TGroupChart.Options Property

Summary

Represents property Options.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
published
 property Options:TGroupChartOptions read FOptions;

Property Value

Type: TGroupChartOptions

See Also

Reference

  • TGroupChart
  • VCLBI.Visualizer.Chart


TGroupChart.Add(TInteger) Method

Summary

Represents method Add(TInteger).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 procedure Add(const AIndex:TInteger); override;

Parameters

AIndex
Type: System.Void

See Also

Reference

  • TGroupChart
  • VCLBI.Visualizer.Chart


TGroupChart.AddItem Method

Summary

Represents method AddItem.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
protected
 function AddItem:TComponent; virtual;

Return Value

Type: TComponent

See Also

Reference

  • TGroupChart
  • VCLBI.Visualizer.Chart


TGroupChart.ApplyTemplate Method

Summary

Represents method ApplyTemplate.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 procedure ApplyTemplate; overload;
See Also

Reference

  • TGroupChart
  • VCLBI.Visualizer.Chart


TGroupChart.ApplyTemplate(TCustomChart,TCustomChart) Method

Summary

Represents method ApplyTemplate(TCustomChart,TCustomChart).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
protected
 procedure ApplyTemplate(const AChart,ATemplate:TCustomChart); overload; virtual;

Parameters

AChart
Type: TCustomChart

ATemplate
Type: TCustomChart

See Also

Reference

  • TGroupChart
  • VCLBI.Visualizer.Chart


TGroupChart.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TGroupChart
  • VCLBI.Visualizer.Chart


TGroupChart.ChartResized(TObject) Method

Summary

Represents method ChartResized(TObject).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
protected
 procedure ChartResized(Sender:TObject); virtual;

Parameters

Sender
Type: TObject

See Also

Reference

  • TGroupChart
  • VCLBI.Visualizer.Chart


TGroupChart.Finished Method

Summary

Represents method Finished.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
protected
 procedure Finished; override;
See Also

Reference

  • TGroupChart
  • VCLBI.Visualizer.Chart


TGroupChart.Init Method

Summary

Represents method Init.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
protected
 procedure Init; override;
See Also

Reference

  • TGroupChart
  • VCLBI.Visualizer.Chart


TGroupChart.SetAxisTitle(TChartSeries,TDataItem) Method

Summary

Represents method SetAxisTitle(TChartSeries,TDataItem).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
protected
 class procedure SetAxisTitle(const ASeries:TChartSeries; const AData:TDataItem); static;

Parameters

ASeries
Type: TChartSeries

AData
Type: TDataItem

See Also

Reference

  • TGroupChart
  • VCLBI.Visualizer.Chart


TGroupChartOptions Class

Summary

Represents type TGroupChartOptions.

Namespace: VCLBI.Visualizer.Chart
Inheritance Hierarchy
TPersistent
VCLBI.Visualizer.Chart.TGroupChartOptions
Syntax
Delphi
type
 TGroupChartOptions=class(TPersistent)
 end;

The TGroupChartOptions type exposes the following members.

Constructors
Show:
Name | Description
Create | Initializes a new instance of the TGroupChartOptions class.
Destroy | Represents the destructor of the TGroupChartOptions class.
Top
Properties
Show:
Name | Description
Legend | Represents property Legend.
Marks | Represents property Marks.
MultiAxes | Represents property MultiAxes.
Render | Represents property Render.
Settings | Represents property Settings.
Template | Represents property Template.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
See Also

Reference

  • VCLBI.Visualizer.Chart


TGroupChartOptions.Create Constructor

Summary

Initializes a new instance of the TGroupChartOptions class.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 Constructor Create;
See Also

Reference

  • TGroupChartOptions
  • VCLBI.Visualizer.Chart


TGroupChartOptions.Destroy Destructor

Summary

Represents the destructor of the TGroupChartOptions class.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 Destructor Destroy; override;
See Also

Reference

  • TGroupChartOptions
  • VCLBI.Visualizer.Chart


TGroupChartOptions.Legend Property

Summary

Represents property Legend.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
published
 property Legend:Boolean read GetLegend write SetLegend default True;

Property Value

Type: Boolean

See Also

Reference

  • TGroupChartOptions
  • VCLBI.Visualizer.Chart


TGroupChartOptions.Marks Property

Summary

Represents property Marks.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
published
 property Marks:Boolean read GetMarks write SetMarks;

Property Value

Type: Boolean

See Also

Reference

  • TGroupChartOptions
  • VCLBI.Visualizer.Chart


TGroupChartOptions.MultiAxes Property

Summary

Represents property MultiAxes.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
published
 property MultiAxes:TBIMultiAxis read FMultiAxes write SetMultiAxes default TBIMultiAxis.Automatic;

Property Value

Type: TBIMultiAxis

See Also

Reference

  • TGroupChartOptions
  • VCLBI.Visualizer.Chart


TGroupChartOptions.Render Property

Summary

Represents property Render.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
published
 property Render:TCanvas3DClass read FRender write SetRender;

Property Value

Type: TCanvas3DClass

See Also

Reference

  • TGroupChartOptions
  • VCLBI.Visualizer.Chart


TGroupChartOptions.Settings Property

Summary

Represents property Settings.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
published
 property Settings:Boolean read FSettings write SetSettings default True;

Property Value

Type: Boolean

See Also

Reference

  • TGroupChartOptions
  • VCLBI.Visualizer.Chart


TGroupChartOptions.Template Property

Summary

Represents property Template.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
published
 property Template:TChart read GetTemplate write SetTemplate;

Property Value

Type: TChart

See Also

Reference

  • TGroupChartOptions
  • VCLBI.Visualizer.Chart


TGroupChartOptions.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TGroupChartOptions
  • VCLBI.Visualizer.Chart


TGroupSeries Class

Summary

Represents type TGroupSeries.

Namespace: VCLBI.Visualizer.Chart
Inheritance Hierarchy
VCLBI.Visualizer.TGroup
VCLBI.Visualizer.Chart.TGroupChart
VCLBI.Visualizer.Chart.TGroupSeries
Syntax
Delphi
type
 TGroupSeries=class(TGroupChart)
 end;

The TGroupSeries type exposes the following members.

Constructors
Show:
Name | Description
CreateData(TVisualizerItem,TGroup) | Initializes a new instance of the TGroupSeries class. (Overrides TGroupChart.CreateData(TVisualizerItem,TGroup).)
Destroy | Represents the destructor of the TGroupSeries class. (Overrides TGroupChart.Destroy.)
Top
Properties
Show:
Name | Description
Options | Represents property Options.
Top
Methods
Show:
Name | Description
AddValues(TComponent,TVisualizerItems,TVisualizerItem,TCursorIndex) | Represents method AddValues(TComponent,TVisualizerItems,TVisualizerItem,TCursorIndex).
Assign(TPersistent) | Represents method Assign(TPersistent). (Overrides TGroupChart.Assign(TPersistent).)
BestControl(Integer,Integer,Integer) | Represents method BestControl(Integer,Integer,Integer).
Finished | Represents method Finished. (Overrides TGroupChart.Finished.)
Top
See Also

Reference

  • VCLBI.Visualizer.Chart


TGroupSeries.CreateData(TVisualizerItem,TGroup) Constructor

Summary

Initializes a new instance of the TGroupSeries class.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 Constructor CreateData(const AItem:TVisualizerItem; const AParent:TGroup); override;

Parameters

AItem
Type: TVisualizerItem

AParent
Type: TGroup

Overrides

TGroupChart.CreateData(TVisualizerItem,TGroup)
See Also

Reference

  • TGroupSeries
  • VCLBI.Visualizer.Chart


TGroupSeries.Destroy Destructor

Summary

Represents the destructor of the TGroupSeries class.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 Destructor Destroy; override;

Overrides

TGroupChart.Destroy
See Also

Reference

  • TGroupSeries
  • VCLBI.Visualizer.Chart


TGroupSeries.Options Property

Summary

Represents property Options.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
published
 property Options:TGroupSeriesOptions read FSeriesOptions write SetOptions;

Property Value

Type: TGroupSeriesOptions

See Also

Reference

  • TGroupSeries
  • VCLBI.Visualizer.Chart


TGroupSeries.AddValues(TComponent,TVisualizerItems,TVisualizerItem,TCursorIndex) Method

Summary

Represents method AddValues(TComponent,TVisualizerItems,TVisualizerItem,TCursorIndex).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 procedure AddValues(const AComponent:TComponent;
 const Values:TVisualizerItems;
 const AGroup:TVisualizerItem;
 const ARows:TCursorIndex); override;

Parameters

AComponent
Type: TComponent

Values
Type: TVisualizerItems

AGroup
Type: TVisualizerItem

ARows
Type: System.Void

See Also

Reference

  • TGroupSeries
  • VCLBI.Visualizer.Chart


TGroupSeries.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

Overrides

TGroupChart.Assign(TPersistent)
See Also

Reference

  • TGroupSeries
  • VCLBI.Visualizer.Chart


TGroupSeries.BestControl(Integer,Integer,Integer) Method

Summary

Represents method BestControl(Integer,Integer,Integer).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 class function BestControl(const AIndex,ATotal,AValues:Integer):TGroupClass; override;

Parameters

AIndex
Type: Integer

ATotal
Type: Integer

AValues
Type: Integer

Return Value

Type: TGroupClass

See Also

Reference

  • TGroupSeries
  • VCLBI.Visualizer.Chart


TGroupSeries.Finished Method

Summary

Represents method Finished.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
protected
 procedure Finished; override;

Overrides

TGroupChart.Finished
See Also

Reference

  • TGroupSeries
  • VCLBI.Visualizer.Chart


TGroupSeriesOptions Class

Summary

Represents type TGroupSeriesOptions.

Namespace: VCLBI.Visualizer.Chart
Inheritance Hierarchy
TPersistent
VCLBI.Visualizer.Chart.TGroupSeriesOptions
Syntax
Delphi
type
 TGroupSeriesOptions=class(TPersistent)
 end;

The TGroupSeriesOptions type exposes the following members.

Constructors
Show:
Name | Description
Create(TGroupSeries) | Initializes a new instance of the TGroupSeriesOptions class.
Top
Properties
Show:
Name | Description
AddNulls | Represents property AddNulls.
AutoStack | Represents property AutoStack.
Series2D | Represents property Series2D.
Series3D | Represents property Series3D.
Style | Represents property Style.
Top
Methods
Show:
Name | Description
Assign(TPersistent) | Represents method Assign(TPersistent).
Top
See Also

Reference

  • VCLBI.Visualizer.Chart


TGroupSeriesOptions.Create(TGroupSeries) Constructor

Summary

Initializes a new instance of the TGroupSeriesOptions class.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 Constructor Create(const AParent:TGroupSeries);

Parameters

AParent
Type: TGroupSeries

See Also

Reference

  • TGroupSeriesOptions
  • VCLBI.Visualizer.Chart


TGroupSeriesOptions.AddNulls Property

Summary

Represents property AddNulls.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
published
 property AddNulls:Boolean read FAddNulls write SetAddNulls default True;

Property Value

Type: Boolean

See Also

Reference

  • TGroupSeriesOptions
  • VCLBI.Visualizer.Chart


TGroupSeriesOptions.AutoStack Property

Summary

Represents property AutoStack.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
published
 property AutoStack:TAutoStackSeries read FAutoStack write SetAutoStack default TAutoStackSeries.Automatic;

Property Value

Type: TAutoStackSeries

See Also

Reference

  • TGroupSeriesOptions
  • VCLBI.Visualizer.Chart


TGroupSeriesOptions.Series2D Property

Summary

Represents property Series2D.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 property Series2D:TChartSeriesClass read FSeries2D write SetSeries2D;

Property Value

Type: TChartSeriesClass

See Also

Reference

  • TGroupSeriesOptions
  • VCLBI.Visualizer.Chart


TGroupSeriesOptions.Series3D Property

Summary

Represents property Series3D.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 property Series3D:TChartSeriesClass read FSeries3D write SetSeries3D;

Property Value

Type: TChartSeriesClass

See Also

Reference

  • TGroupSeriesOptions
  • VCLBI.Visualizer.Chart


TGroupSeriesOptions.Style Property

Summary

Represents property Style.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
published
 property Style:TGroupSeriesStyle read FStyle write SetStyle default TGroupSeriesStyle.Automatic;

Property Value

Type: TGroupSeriesStyle

See Also

Reference

  • TGroupSeriesOptions
  • VCLBI.Visualizer.Chart


TGroupSeriesOptions.Assign(TPersistent) Method

Summary

Represents method Assign(TPersistent).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 procedure Assign(Source:TPersistent); override;

Parameters

Source
Type: TPersistent

See Also

Reference

  • TGroupSeriesOptions
  • VCLBI.Visualizer.Chart


VCLBI.Visualizer.Chart Records

Records
Name | Description
TBIChartComposerUI | Represents type TBIChartComposerUI.
TSeriesData | Represents type TSeriesData.
Top


TBIChartComposerUI Record

Summary

Represents type TBIChartComposerUI.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
type
 TBIChartComposerUI=record
 end;

The TBIChartComposerUI type exposes the following members.

Methods
Show:
Name | Description
CurrentSeriesClass(TComboBox) | Represents method CurrentSeriesClass(TComboBox).
Fill2DSeries(TStrings) | Represents method Fill2DSeries(TStrings).
Fill3DSeries(TStrings) | Represents method Fill3DSeries(TStrings).
FindSeries(TStrings,TChartSeriesClass) | Represents method FindSeries(TStrings,TChartSeriesClass).
GetChart(Integer) | Represents method GetChart(Integer).
GetSeries(Integer) | Represents method GetSeries(Integer).
Top
Fields
Show:
Name | Description
Viz | Represents field Viz.
Top
See Also

Reference

  • VCLBI.Visualizer.Chart


TBIChartComposerUI.CurrentSeriesClass(TComboBox) Method

Summary

Represents method CurrentSeriesClass(TComboBox).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 class function CurrentSeriesClass(const AItems:TComboBox):TChartSeriesClass; static;

Parameters

AItems
Type: TComboBox

Return Value

Type: TChartSeriesClass

See Also

Reference

  • TBIChartComposerUI
  • VCLBI.Visualizer.Chart


TBIChartComposerUI.Fill2DSeries(TStrings) Method

Summary

Represents method Fill2DSeries(TStrings).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 class procedure Fill2DSeries(const AItems:TStrings); static;

Parameters

AItems
Type: TStrings

See Also

Reference

  • TBIChartComposerUI
  • VCLBI.Visualizer.Chart


TBIChartComposerUI.Fill3DSeries(TStrings) Method

Summary

Represents method Fill3DSeries(TStrings).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 class procedure Fill3DSeries(const AItems:TStrings); static;

Parameters

AItems
Type: TStrings

See Also

Reference

  • TBIChartComposerUI
  • VCLBI.Visualizer.Chart


TBIChartComposerUI.FindSeries(TStrings,TChartSeriesClass) Method

Summary

Represents method FindSeries(TStrings,TChartSeriesClass).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 class function FindSeries(const AItems:TStrings; const AClass:TChartSeriesClass):Integer; static;

Parameters

AItems
Type: TStrings

AClass
Type: TChartSeriesClass

Return Value

Type: Integer

See Also

Reference

  • TBIChartComposerUI
  • VCLBI.Visualizer.Chart


TBIChartComposerUI.GetChart(Integer) Method

Summary

Represents method GetChart(Integer).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 function GetChart(const AIndex:Integer):TGroupChart;

Parameters

AIndex
Type: Integer

Return Value

Type: TGroupChart

See Also

Reference

  • TBIChartComposerUI
  • VCLBI.Visualizer.Chart


TBIChartComposerUI.GetSeries(Integer) Method

Summary

Represents method GetSeries(Integer).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 function GetSeries(const AIndex:Integer):TGroupSeries;

Parameters

AIndex
Type: Integer

Return Value

Type: TGroupSeries

See Also

Reference

  • TBIChartComposerUI
  • VCLBI.Visualizer.Chart


TBIChartComposerUI.Viz Field

Summary

Represents field Viz.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 Viz : TBIComposer;

Field Value

Type: TBIComposer

See Also

Reference

  • TBIChartComposerUI
  • VCLBI.Visualizer.Chart


TSeriesData Record

Summary

Represents type TSeriesData.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
type
 TSeriesData=record
 end;

The TSeriesData type exposes the following members.

Methods
Show:
Name | Description
AddPoint(TInteger,String,Integer,Integer) | Represents method AddPoint(TInteger,String,Integer,Integer).
Top
Fields
Show:
Name | Description
AddNulls | Represents field AddNulls.
Data | Represents field Data.
Series | Represents field Series.
Top
See Also

Reference

  • VCLBI.Visualizer.Chart


TSeriesData.AddPoint(TInteger,String,Integer,Integer) Method

Summary

Represents method AddPoint(TInteger,String,Integer,Integer).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 procedure AddPoint(const APos:TInteger; const AText:String; const XPos,ZPos:Integer);

Parameters

APos
Type: System.Void

AText
Type: String

XPos
Type: Integer

ZPos
Type: Integer

See Also

Reference

  • TSeriesData
  • VCLBI.Visualizer.Chart


TSeriesData.AddNulls Field

Summary

Represents field AddNulls.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 AddNulls : Boolean;

Field Value

Type: Boolean

See Also

Reference

  • TSeriesData
  • VCLBI.Visualizer.Chart


TSeriesData.Data Field

Summary

Represents field Data.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 Data : TDataItem;

Field Value

Type: TDataItem

See Also

Reference

  • TSeriesData
  • VCLBI.Visualizer.Chart


TSeriesData.Series Field

Summary

Represents field Series.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
public
 Series : TChartSeries;

Field Value

Type: TChartSeries

See Also

Reference

  • TSeriesData
  • VCLBI.Visualizer.Chart


VCLBI.Visualizer.Chart Enumerations

Enumerations
Name | Description
TAutoStackSeries | Represents type TAutoStackSeries.
TBIMultiAxis | Represents type TBIMultiAxis.
TGroupSeriesStyle | Represents type TGroupSeriesStyle.
Top


TAutoStackSeries Enumeration

Summary

Represents type TAutoStackSeries.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
type
 TAutoStackSeries=(Automatic,Yes,Yes100,No);

The TAutoStackSeries type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
No | Represents constant No.
Yes | Represents constant Yes.
Yes100 | Represents constant Yes100.
Top
See Also

Reference

  • VCLBI.Visualizer.Chart


TBIMultiAxis Enumeration

Summary

Represents type TBIMultiAxis.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
type
 TBIMultiAxis=(Automatic,Single,Two,Multiple);

The TBIMultiAxis type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Multiple | Represents constant Multiple.
Single | Represents constant Single.
Two | Represents constant Two.
Top
See Also

Reference

  • VCLBI.Visualizer.Chart


TGroupSeriesStyle Enumeration

Summary

Represents type TGroupSeriesStyle.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
type
 TGroupSeriesStyle=(Automatic,Series2D,Series3D,Geographic);

The TGroupSeriesStyle type exposes the following members.

Members
Show:
Name | Description
Automatic | Represents constant Automatic.
Geographic | Represents constant Geographic.
Series2D | Represents constant Series2D.
Series3D | Represents constant Series3D.
Top
See Also

Reference

  • VCLBI.Visualizer.Chart


VCLBI.Visualizer.Chart Types

Types
Name | Description
TChartProc | Represents type TChartProc.
Top


TChartProc Type

Summary

Represents type TChartProc.

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
type
 TChartProc=reference to procedure(const AChart:TCustomChart);
See Also

Reference

  • VCLBI.Visualizer.Chart


VCLBI.Visualizer.Chart Routines

Routines
Name | Description
AddSettingsButton(TWinControl) | Represents method AddSettingsButton(TWinControl).
IsNumericOrDateTime(TDataItem) | Represents method IsNumericOrDateTime(TDataItem).
MandatoryAxis(TChartSeries) | Represents method MandatoryAxis(TChartSeries).
NotMandatoryAxis(TChartSeries) | Represents method NotMandatoryAxis(TChartSeries).
SetColorEach(TChartSeries) | Represents method SetColorEach(TChartSeries).
TraverseChart(TCustomChart,TChartProc) | Represents method TraverseChart(TCustomChart,TChartProc).
TryChangeSeriesStyle(TChartSeries) | Represents method TryChangeSeriesStyle(TChartSeries).
Top


AddSettingsButton(TWinControl) Method

Summary

Represents method AddSettingsButton(TWinControl).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
function AddSettingsButton(const AControl:TWinControl):TSpeedButton;

Parameters

AControl
Type: TWinControl

Return Value

Type: TSpeedButton

See Also

Reference

  • VCLBI.Visualizer.Chart


IsNumericOrDateTime(TDataItem) Method

Summary

Represents method IsNumericOrDateTime(TDataItem).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
function IsNumericOrDateTime(const AData:TDataItem):Boolean;

Parameters

AData
Type: TDataItem

Return Value

Type: Boolean

See Also

Reference

  • VCLBI.Visualizer.Chart


MandatoryAxis(TChartSeries) Method

Summary

Represents method MandatoryAxis(TChartSeries).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
function MandatoryAxis(const ASeries:TChartSeries):TChartAxis;

Parameters

ASeries
Type: TChartSeries

Return Value

Type: TChartAxis

See Also

Reference

  • VCLBI.Visualizer.Chart


NotMandatoryAxis(TChartSeries) Method

Summary

Represents method NotMandatoryAxis(TChartSeries).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
function NotMandatoryAxis(const ASeries:TChartSeries):TChartAxis;

Parameters

ASeries
Type: TChartSeries

Return Value

Type: TChartAxis

See Also

Reference

  • VCLBI.Visualizer.Chart


SetColorEach(TChartSeries) Method

Summary

Represents method SetColorEach(TChartSeries).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
procedure SetColorEach(const ASeries:TChartSeries);

Parameters

ASeries
Type: TChartSeries

See Also

Reference

  • VCLBI.Visualizer.Chart


TraverseChart(TCustomChart,TChartProc) Method

Summary

Represents method TraverseChart(TCustomChart,TChartProc).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
procedure TraverseChart(const AChart:TCustomChart; const AProc:TChartProc);

Parameters

AChart
Type: TCustomChart

AProc
Type: TChartProc

See Also

Reference

  • VCLBI.Visualizer.Chart


TryChangeSeriesStyle(TChartSeries) Method

Summary

Represents method TryChangeSeriesStyle(TChartSeries).

Namespace: VCLBI.Visualizer.Chart
Syntax
Delphi
procedure TryChangeSeriesStyle(var ASeries:TChartSeries);

Parameters

ASeries
Type: TChartSeries

See Also

Reference

  • VCLBI.Visualizer.Chart